首页

声 明

本《英特尔®英保通™软件用户手册》与其中提及之软件均按许可协议提供，其使用或复制必须遵守许可协议项下规定之条件。本用户手册提供之信息仅供参考，未经事先通知可随时发生变化，不得将其解释为英特尔公司作出的具体承诺。英特尔公司不对文档中或与文档同时提供的软件中可能出现的错误或不准确信息承担任何责任。

除非上述许可协议另有规定，未经英特尔明确书面许可，不得对本文档中的任何部分加以复制，或存储于检索系统中，或以任何方式以任何形式加以传播。

英特尔、Intel 、Intel Inside 以及 奔腾、赛扬、至强和英保通是英特尔公司及其在美国和其他国家（地区）的子公司之商标或者注册商标。文中涉及的其它名称及商标属于各自所有者资产。所有权利受到保护。

* 其他名称和品牌分别为其相应所有者的财产。


手册目标读者

《英特尔®英保通™软件- 用户手册》的目标读者为英特尔®英保通™软件的系统管理人员。

本手册提供系统管理人员关于英特尔®英保通™软件的安装、使用和维护知识。


手册内容结构

《英特尔®英保通™软件- 用户手册》由以下四单元组成：

第一单元、 概述

介绍英特尔®英保通™软件的架构、安装前配置需求，使相关人员对系统有初步的了解。内容包括：

第一章、

产品概述

第二单元、基础部分：安装步骤

介绍初次使用英特尔®英保通™软件时的安装步骤，使相关人员能按步骤完成系统安装和初步配置。内容包括：

第二章、

安装步骤

第三单元、高级部分：配置与管理

介绍高级部分的配置与管理，包括使用技巧与注意事项，使相关人员能掌握对英特尔®英保通™软件服务器端、客户端、固件端的使用。内容包括：

第三章、 | 服务器端的使用
第四章、 | 辅助管理工具的使用
第五章、 | 升级工具的使用
第六章、 | 客户端的使用
第七章、 | 固件端的使用
第八章、 | 安装、卸载和升级

第四单元、实例应用

目的在于通过介绍常见的应用案例和一些常见的问题以及解决方法，为系统管理人员提供第一手的技术支持。内容包括：

第九章、 | 常见应用实例
第十章、 | 常见问题解答


手册使用技巧

[注意] | 需要注意的要点，否则可能导致任务失败或无效。
[警告] | 需要强调注意的要点，否则可能导致无法挽救的损坏。
[提示] | 使用技巧提示。
[注释] | 对于一些不易理解的概念或名词，本手册中将使用[注释] 来详细解释。


第一章、产品概述


1.1英特尔(R)英保通(TM)技术简介

1.1英特尔®英保通™技术简介

英特尔®英保通™技术是一个管理平台，它致力于简化对中小型计算机网络内的计算机和软件应用程序的管理，提供最新的英特尔®英保通™技术与英特尔®英保通™软件应用，为那些注重成本的组织机构，如小企业、网吧和学校提供了便捷。它保证了一个更稳定、更安全的应用环境。在对计算机的管理无需进行重大投入的情况下，将计算机菪机时间减少到最小程度。

英特尔®英保通™技术是Intel® Platform Administration Technology的中文名，又称英特尔®平台管理技术，采用了该技术的平台可称为英特尔®英保通™平台。

英特尔®英保通™技术为管理员在网络环境中的计算机管理提供增值服务。它包括：

§ 主板技术

§ 固件层技术（基于英特尔®EFI平台创新架构）

§ 客户端和服务器端软件

§ 用于开发基于英特尔®英保通™技术应用方案的应用程序接口（API）

英特尔®英保通™技术所涵盖的功能包括：

§ “开箱即用”的计算机安装策略，自动通过网络安装操作系统和软件，简化繁琐冗长的装机过程

§ 资产监控和远程管理

§ 在网络环境中，通过软件包分发完成每台计算机的软件升级

§ 系统恢复和硬盘保护

英特尔®英保通™技术的产品特点包括：

§ 组播模式 (1对多点) 的镜像分发，避免了网络拥塞，能在100Mb以太网中实现1GB的操作系统在几分钟内完成对几百台PC的分发

§ 基于磁盘块的增量式磁盘镜像生成和部署，为快速软件分发和升级提供方案

§ 低性能损耗的硬盘保护技术，确保系统远离病毒和恶意破坏的困扰

§ 网络还原，可以轻松恢复被破坏的客户机

§ 硬件和软件资产管理

§ 独立于任何操作系统和CPU状态的远程控制：远程开机、关机、重启和实时客户机状态查询


1.2英特尔(R)英保通(TM)软件简介

1.2 英特尔®英保通™软件简介

英特尔®英保通™软件 Intel® Platform Administrator的中文名，又称英特尔®平台管理解决方案。

英特尔®英保通™软件是英特尔公司开发的支持英特尔®英保通™技术的一套软件解决方案，它包括：

§ 英特尔®英保通™软件服务器端 （网吧专业版1.1）

§ 英特尔®英保通™软件客户端（专业版1.1）

§ 英特尔®英保通™软件固件端（专业版1.1）

英特尔®英保通™软件服务器端是一套应用程序，运行于服务器上，包括管理界面和后台服务。服务端需要数据库的配合。

英特尔®英保通™软件服务器端负责远程管理网络环境中的所有客户机。管理员对客户机的所有操作，都是通过英特尔®英保通™软件服务器端发出的。

在客户机的BIOS状态，英特尔®英保通™软件服务器端与英特尔®英保通™软件固件端进行交互，完成创建镜像、部署镜像、网络还原、远程控制等操作。

在客户机的操作系统状态，英特尔®英保通™软件服务器端与英特尔®英保通™软件客户端进行交互，完成远程管理和控制等操作。

英特尔®英保通™软件客户端是一套应用程序，运行于客户机上，包括磁盘保护和后台监控程序。

英特尔®英保通™软件固件端是位于客户机BIOS上的程序，它和服务器通讯，提供了网络管理和部署等核心功能。


1.3英特尔(R)英保通(TM)软件典型应用场景

1.3英特尔®英保通™软件典型应用场景

下图给出了英特尔®英保通™软件的典型应用场景。用户需要做的就是在客户机上启用英特尔®英保通™软件固件端并安装英特尔®英保通™软件客户端程序；在服务器上安装英特尔®英保通™软件服务器端程序。安装完成后，管理员就可以通过服务器远程管理各个客户机。


1.4英特尔(R)英保通(TM)软件基础知识

1.4英特尔®英保通™软件基础知识


1.4.1常用术语

母机器 | 母机器可以看作是网络环境中的样机，其他机器都是对它的拷贝，要求母机器与其他机器的硬件配置完全一致。
镜像 | 镜像文件方便了硬盘数据的备份与传输。可从母机器生成一个镜像文件，传输复制给其他机器，从而简化了操作系统及其他软件的安装过程。
增量安装包 | 增量安装包方便用户快速更新客户机系统。在需要更新客户机系统时，用户可在母机器上安装、删除或升级某个程序并生成增量安装包文件，生成的增量安装包将记录母机器上一次硬盘更新之后的更改部分，用户可通过部署这一增量安装包给其他客户机以快速更新系统。
部署 | 将镜像或增量安装包通过网络传输给客户机的过程称为部署。
网络还原 | 网络还原可以通过网络传输自动地向被破坏的客户机重复部署以往的镜像和增量安装包，从而将客户机恢复到上一次的正常运行状态。
硬盘保护 | 客户端的硬盘保护软件可以保护硬盘上的数据免受破坏，不管是系统数据或者是用户的数据都可以得到保护。在安装有硬盘保护的机器上，客户机可以恢复到任意一个之前被保存的状态，并且每次重启后硬盘上被保护的扇区都将恢复到上次保存过的状态。
还原点 | 还原点是指客户机硬盘的某个状态。在启动硬盘保护软件的客户端，用户可通过创建还原点来保存本次的所有操作和数据。
本地还原 | 在客户端启动硬盘保护软件并创建还原点后，客户机可通过选择本机上的还原点将硬盘恢复到之前创建的某个还原点状态，这一过程称为本地还原。
数据转存 | 数据转存可将当前客户机的硬盘状态永久保存，在操作系统中所作的当前更改都将被记录下来。数据转存后，以前所创建的还原点都将被删除，系统将从当前的硬盘状态开始创建随后的还原点。
资产监控 | 资产监控是指用户可通过服务器端对网络内的资产进行监控，包括在服务器端查看每台客户机的软件清单、硬件清单，查看警报信息，远程修改客户机名称，远程开/关机和重启。


1.4.2光盘内容

在光盘上包含以下内容：

在光盘根目录下：

-        光盘自动启动程序文件（autorun.exe, AUTORUN.INF, IPATlog.ico）

-        光盘自述说明（英文：Readme.txt, 中文：Readme_CN.txt）

-        发布说明（英文：ReleaseNotes.htm, 中文：ReleaseNotes_CN.htm）

在目录3rdPartyTools下：

-        Micrsoft SQL Server 2000 Desktop Engine* (MSDE 2000)的安装程序（子目录MSDE）

-        Microsoft .NET* Framework 1.1.4322* 的安装程序（子目录dotnet）

在Chinese目录下：

包含英特尔®英保通™软件中文版的安装程序和相关文档

在Setup子目录下：

-        英特尔®英保通™软件服务器端（网吧专业版1.1）安装程序（IntelPATServerSetup.exe）

-        英特尔®英保通™软件客户端（专业版1.1）安装程序（IntelPATClientSetup.exe）

-        英特尔®英保通™软件固件端（专业版1.1）(IntelPATAgent.exe)

在Document子目录下：

-        英特尔®英保通™软件用户手册（IntelPlatformAdministratorUserManual_CN.chm）

-        英特尔®英保通™软件白皮书 (IntelPlatformAdministratorWhitePaper_CN.pdf)

在Training子目录下：

-        英特尔®英保通™软件（专业版1.1）使用教程（Tutorial目录）

在English目录下：

包含英特尔®英保通™软件英文版的安装程序和相关文档

在Setup子目录下：

-        英特尔®英保通™软件服务器端（网吧专业版1.1）安装程序 （IntelPATServerSetup.exe）

-        英特尔®英保通™软件客户端（专业版1.1）安装程序（IntelPATClientSetup.exe）

-        英特尔®英保通™软件固件端（专业版1.1）(文件IntelPATAgent.exe)

在Document子目录下：

-        英特尔®英保通™软件用户手册(IntelPlatformAdministratorUserManual_EN.chm)

-        英特尔®英保通™软件白皮书 (IntelPlatformAdministratorWhitePaper_EN.pdf)

在Training子目录下：

-        英特尔®英保通™软件（专业版1.1）使用教程（Tutorial目录）


1.5英特尔(R)英保通(TM)软件的系统要求

1.5英特尔®英保通™软件的系统要求


1.5.1系统硬件配置要求

硬件 | 推荐服务器配置 | 最低服务器配置 | 推荐客户端配置
CPU | 英特尔® 奔腾® 4处理器， 2.8GHz | 英特尔® 奔腾® 4处理器， 2.4GHz | 英特尔® 赛扬® D处理器， 2.4GHz | 英特尔® 奔腾® 4处理器， 2.8GHz
内存 | 1GB | 512MB | 512MB
硬盘 | 160GB IDE | 120GB IDE | 80GB IDE
CD-ROM | CD-ROM 16x | CD-ROM 16x |
网卡 | 1000Mbps | 100Mbps | 自带100Mbps网卡
主板 | 任意一款英特尔认证的服务器主板 | 任意一款英特尔认证的服务器主板 | 英特尔® 台式机主板D865PCK | 英特尔® 台式机 主板D915PDT


1.5.2系统软件配置要求


1.5.2.1 服务器端的要求

支持的操作系统：

- Windows 2000 Server* (SP4) 中英文版

- Windows 2000 Advanced Server* (SP4) 中英文版

- Windows Server 2003 Standard Edition* 中英文版

- Windows Server 2003 Enterprise Edition*中英文版

- Windows XP Professional Edition* (SP2) 中英文版

系统服务和部件：

- 简单网络管理协议 (SNMP)

- Internet 信息服务 (IIS) ，要求版本5.0或以上

- 动态主机配置协议 (DHCP) （可选）

-        Windows Management Instrumentation

[提示]

如果服务器上没有安装这些组件，请单击[开始] à [控制面板] à [添加或删除程序] à [添加/删除Windows组件] 安装这些组件。

其它第三方软件：

- Microsoft SQL Server 2000 Desktop Engine (MSDE 2000) * (SP3a) 或者Microsoft SQL Server 2000* (SP3a)

- Internet Explorer 6.0* (或更高)

- Windows ASP. NET*

- Microsoft .NET Framework 1.1.4322* (Windows Server 2003* 默认已安装，Microsoft 2000 Advanced Server* 需要手工安装）

[提示]

所需软件安装请参考“英特尔®英保通™软件”安装光盘。

[注意]

确保已下载并安装了最新的Service Pack和安全补丁。


1.5.2.2 客户机端的要求

支持的操作系统：

- Windows 2000 Professional Edition* (SP4) 中英文版

- Windows XP Professional Edition* (SP2) 中英文版

[注意]

确保已下载并安装了最新的Service Pack和安全补丁。

系统服务和部件：

- DHCP Client（可选）

- Network Connection

- Windows Management Instrumentation

** 以下简称英特尔®英保通™软件为英保通软件。


第二章、安装步骤

英保通软件的基本安装配置可分为10个步骤：

 | 步骤 | 要点 | 操作执行端
第1步、 | 组建网络 |  | 网络
第2步、 | 安装前准备 | * 安装服务器操作系统 * 安装第三方软件 * 安装windows网络组件 - 安装简单网络管理协议 (SNMP) - 安装Internet 信息服务 (IIS) - 安装动态主机配置协议 (DHCP) （可选） * 允许ASP 和ASP.net服务 * 设置Internet Explorer | 服务器端
第3步、 | 安装服务器端 |  | 服务器端
第4步、 | 设置服务器 | * 设置文件传输服务器 * 设置自动部署 | 服务器端
第5步、 | 启用和升级客户机固件端 | * 启用固件端 * 确定固件端版本 * 升级固件端 | 客户机端 （所有）
第6步、 | 设置客户机固件端 | * 输入地址信息 * 配置IP地址 | 客户机端 （所有）
第7步、 | 安装选定的母机器 | * 安装操作系统与应用程序 * 安装客户端 | 客户机端 （母机器）
第8步、 | 管理注册客户机 | * 接受客户机 * 执行本地启动 * 设置母机器 | 服务器端
第9步、 | 创建磁盘镜像 |  | 服务器端
第10步、 | 部署磁盘镜像 |  | 服务器端
完成 |  |  |


第1步、组建网络

英特尔®英保通™软件及所支持的硬件可以在各类以太网拓扑结构下正常工作。但是，为了能最大限度的保证网络的可用性及性能，建议您规划的网络拓扑结构层次不要超过三层。并且在顶层的第一级网络上使用一个千兆交换机以保证足够的网络带宽。另外根据需要，可适度划分VLAN来隔离IP广播包，防止网络风暴的扩散。

在使用与英保通服务器直接连接的一级交换机时，请注意以下事项：

1. 请使用具备千兆 (1000Mbps) 交换功能的交换机；

2. 请使用具备线速 ( Wire Speed) 交换功能的交换机；

3. 请使用支持组播侦听（IGMP Snooping）功能的交换机。

下图是一个示范性的网络拓扑结构图。在该网络的第一级，使用了一个千兆的交换机，与英保通服务器直接连接。在第二级和第三级，使用了数个百兆的交换机来连接客户机。这些客户机都处于同一个IP网段。请确保服务器与客户机都已通过五类或超五类网线连入交换机。

下图仅供示范，用户可根据自身需要组建网络。

[提示]

1. 请确保一级交换机的组播侦听（IGMP Snooping）功能已被启用。

2. 请选用正规厂商的五类或超五类网线。

3. 请将服务器端的网卡驱动程序升级到最新版本。


第2步、安装前装备

在安装英保通软件服务器端前，需要准备：

§ 安装服务器操作系统

§ 安装第三方软件

§ 安装windows网络组件

- 安装简单网络管理协议 (SNMP)

- 安装Internet 信息服务 (IIS)

- 安装动态主机配置协议 (DHCP) （可选）

§ 允许ASP 和ASP.NET服务

§ 设置Internet Explorer


安装服务器操作系统

请首先安装服务器端的操作系统。有关支持英保通软件服务器端的操作系统， 参见 1.5.2.1节 。


安装第三方软件

请确保服务器端所需第三方软件已安装。 参见 1.5.2.1节 。


安装Windows网络组件

服务器端要求配备如下Windows网络组件：

-        简单网络管理协议 (SNMP)

-        Internet 信息服务 (IIS)

-        动态主机配置协议 (DHCP) （可选）

如果服务器上已安装以上网络组件，请进入下一节“允许ASP和ASP.NET服务 ”。

如果服务器上没有安装这些组件，请单击[开始] à [控制面板] à [添加或删除程序] à [添加/删除Windows组件]， 进行安装。如图所示：


安装简单网络管理协议（SNMP）

安装SNMP组件

在Windows组件内选择[管理和监视工具] à [简单网络管理协议（SNMP）]，在选项框内打上“√”。如下图所示：


安装Internet 信息服务(IIS)

安装IIS组件

在Windows组件内选择[应用程序服务器] à [Internet 信息服务(IIS) ]，在选项框内打上“√”。如下图所示：


安装动态主机配置协议（DHCP）（可选）title> 安装DHCP组件（可选） 安装这一组件不是必需的，只有当用户希望自动为客户机分配IP地址时，用户需要安装DHCP组件。 在Windows组件内选择[网络服务] à [DHCP]，在选项框内打上“√”。如下图所示：

安装动态主机配置协议（DHCP）（可选）

安装这一组件不是必需的，只有当用户希望自动为客户机分配IP地址时，用户需要安装DHCP组件。

在Windows组件内选择[网络服务] à [动态主机配置协议DHCP]，在选项框内打上“√”。如下图所示：


允许ASP和ASP.NET服务

允许ASP和ASP.NET

如果服务器系统为Windows 2000， 可跳过此步骤，继续执行下一步。

如果服务器系统为Windows 2003，单击[管理工具]à [Internet 信息服务(IIS)管理器] à [Web服务扩展]，允许“Active Server Pages”和“ASP.NET v1.1.4322”。如下图所示：


设置Internet Explorer

英保通软件的报警功能需要Internet Explorer支持动画播放的功能。因此，需要对Internet Explorer进行设置。

单击[Internet Explorer]à [工具] à [Internet 选项] à [高级] à [多媒体]，设置“播放网页中的动画”。如下图所示：


第3步、安装服务器端

英保通软件服务器端是服务器集中管理局域网中所有客户机的管理界面。

在安装英保通软件服务器端前，请先确认服务器端已经正确安装了1.5.2.1节中服务器端所需软件环境。

1）选择语言

服务器端进入Windows系统后，将英保通软件安装光盘放入光驱，系统的安装程序将自动运行，选择语言。

如果没有设置自动运行功能，请单击光盘根目录下的autorun.exe，选择语言。

2）确认“安装前准备”。

选择安装语言后，出现如下屏幕：

首先点击“安装前准备”，查看是否安装前准备已就绪。点击“返回”。

3）选择英保通软件服务器端。

确认安装前准备就绪后。点击“返回”，选择[安装英特尔®英保通™软件服务器端 (网吧专业版1.1) ]。

屏幕出现如下图所示的对话框：

单击“下一步”继续。

4）同意“许可协议”。

请阅读“英特尔软件许可协议”，选择“同意”， 单击“下一步”继续。

5）确认安装要求。

阅读“安装要求”，请确认所有软件都已正确安装，单击“下一步”继续。

6）输入服务器端的客户信息和公司名称，单击“下一步”继续。

7）选择安装路径。

选择安装英特尔®英保通™服务器端软件的路径，单击“下一步”继续。

8）确认安装。

单击“下一步”继续。

9）系统将显示安装进程，如下图所示：

10) 系统将弹出窗口要求用户选择MTFTP路径，如下图所示。MTFTP根目录将用于存放镜像文件和安装包文件等，为方便日后管理，建议用户建立一个专门的目录。如：[c:\IPAT Server\MTFTP\ ]。设定MTFTP路径后，点击“是”继续。

11）系统出现以下对话框，要求输入数据库服务器信息：

如果使用机器管理员账号登陆服务器，请选择“使用Windows集成验证登录”，点击“确定”。当选择此项后，用户只要成功登录Windows后，即可打开英保通软件服务器端控制台。

如果选用非管理员账号登陆服务器，请选择“使用指定的用户帐号和密码登陆”，输入数据库的用户名及对应密码。当选择此项后，用户在成功登录Windows后，还需输入此处指定的用户帐号和密码才能打开英保通软件服务器端控制台。

点击“确定”后系统提示正在安装数据库与Windows服务。

12) 安装完成，点击“关闭”。

13）重启系统

安装完成后，选择“是”进行系统重启以使安装生效。

英保通软件服务器端安装完成。

14）启动服务器管理界面。

系统重启后，可在Windows单击[开始] à [所有程序] à [英特尔®英保通™软件] à [服务器端网吧版1.1] à [服务器端控制台]，即可启动服务器管理界面。

英保通软件服务器端是服务器集中管理局域网中所有客户机的管理界面。

启动服务器端控制台后，默认将进入以下[已托管客户机] 页面：


第4步、设置服务器

点击页面左边菜单栏的 [服务器配置]，将进入“服务器配置”页面。

服务器初始化配置可以对文件传输服务器根目录进行配置。

设置传输服务器根目录

英保通软件服务器端通过文件传输服务器进行镜像文件的传输。该文件传输器目录在安装时已由用户设定，安装完成后用户也可在界面右边 [服务器设置] 下的 [传输服务器根目录] 选项内进行更改。

在输入框中填入当前安装的文件传输服务器的根目录（如C:\IPAT Server\MTFTP\）。文件传输服务器将在这个根目录下读写文件。在设置完成后，请重启MTFTP服务。

[提示]

1. MTFTP根目录将用于存放镜像文件和安装包文件等，为方便日后管理，建议用户建立一个专门的目录。如：[如C:\IPAT Server\MTFTP\]。

2. 若在使用过程中需要修改文件传输服务器的根目录，请将原路径下的镜像文件拷贝到新的路径下，否则将造成原有镜像文件无法部署。

[警告]

1. MTFTP服务重启之前，MTFTP根目录的改动不会生效。

2. 请确保输入文件传输服务器的根目录所在分区是NTFS分区格式。如果是FAT或FAT32分区，可以读写的最大文件大小为4GB,如果将来创建的文件大小超过这个限制，那么会造成读写文件失败。

3. 请确保输入文件传输服务器的根目录所在分区有足够大的剩余磁盘空间。将来创建的所有磁盘镜像和安装包文件都将存放在这个根目录下。如果没有足够的磁盘空间，将会造成读写文件失败。

重启MTFTP服务：

在Windows单击[开始] à [控制面板] à [管理工具] à [服务] 打开服务（本地）界面。

2）选中“Intel (R) Platform Administrator Server – MTFTP Service”，单击右键，在弹出菜单中选中“重新启动”。

3）系统将重启MTFTP服务，重启后根目录的地址改变生效。


第5步、启用和升级客户机固件端

在安装版本为1.1的英特尔®英保通™软件客户端前，用户需要先确定每台客户机的固件端版本。

如果客户机的固件端版本为1.1，用户只需执行“启用固件端”的操作，然后直接进入第6步“设置客户机固件端”。

如果客户机的固件端版本为1.0，用户必须先将客户机固件端升级到版本1.1。

在确定客户机的固件端版本前，需要先启用固件端。


启用固件端

在默认BIOS出厂设置下，英保通软件固件端是未被启用的。

启动客户机，按F2进入BIOS，将看到BIOS选项第一栏为“Manageability”。在“Manageability”配置中，选择“Agent”, 按下Enter键，在弹出框内选择“Enable”，如下图所示。

选择完毕后再次按下Enter键确认，然后按下F10键，在弹出的Save and Exit窗口选择Y保存并退出。客户机的固件端已被启用。

[提示]

版本1.0和版本1.1的固件端设置界面略有区别。


确定固件端版本

完成以上操作后，客户机将重启，用户可看到屏幕上出现以下信息。

用户可通过屏幕显示的版本号的前二位来确定客户机上的固件端版本。

如：屏幕上显示Professional Edition 1.1.0.100，则表示该固件端版本为1.1，若屏幕上显示Professional Edition 1.0.0.57，则表示该固件端版本为1.0。

如果客户机的固件端版本为1.1，用户可跳过以下步骤，直接进入第6步“设置客户机固件端”。

如果客户机的固件端版本为1.0，用户还需执行以下步骤将客户机固件端升级到版本1.1。


升级固件端

如果客户机的固件端版本为1.0，通过PXE 下载方式升级固件端需要使用DHCP服务器，关于如何配置DHCP服务器，参见第6步“自动分配IP地址”。

1） 在服务器端，将版本为1.1的固件端升级文件IntelPATagent.efi拷贝到指定的MTFTP目录下。用户可在光盘上\\Chinese\Setup\Agent目录下找到这一文件。

2） 在每台客户机上，按下F2键进入版本为1.0的BIOS设置界面， 在 “Manageability”页面下，设置“Agent”为“Disable”。

3) 按下F10键，在弹出的Exit Saving Changes窗口选择Y保存并退出。

4) 客户机重启后，在每台客户机上，按下F2键再次进入版本为1.0的BIOS设置界面，在 “Boot”页面下，设置“Boot to EFI PXE”为“Enable”。

5) 按下F10键，在弹出的Exit Saving Changes窗口选择Y保存并退出。

6) 客户机将通过PXE启动方式，下载版本1.1的固件端更新文件，并烧入BIOS的Flash ROM中。

7) 客户机的固件端已经从版本1.0更新到版本1.1。

[提示]

如果英保通软件固件端已被启用，则BIOS 的Boot页内选项不可操作。用户需先禁用固件端，选择保存并退出。在客户机重启后，再次进入BIOS对 Boot页内选项进行设置。


启用报警功能

如果客户机的固件端版本为1.0，用户还需人工启用报警功能。

如果客户机的固件端版本为1.1，此报警功能默认已被启用。

人工启用报警功能步骤如下：

1) 按下 F2键进入BIOS设置界面。

2) 在Power页面的 “Wake on LAN from S5”选项中，选择 “Power on”。

3) 在Power页面的 “ACPI Suspend State”选项中，选择 “S3 State”。

4）按下F10键选择保存并退出。


第6步、设置客户机固件端

英保通软件固件端与英保通软件客户端配合使用，实现在客户端的各种操作。

在启用客户机固件端后，用户还需在固件端对客户机进行设置，包括：

- 输入地址信息

- 配置IP地址


输入地址信息

BIOS界面中的“Manageability”页面中提供了“Location Info”一栏，用户可在此栏中输入客户机的位置信息，保存后的位置信息可在服务器端管理界面中显示，包括“未托管客户机页面”、“托管客户机页面”、“磁盘镜像管理”、“升级安装包管理”、“异常警报”等页面，这一信息可帮助用户迅速确定该客户机的位置。

按F2进入BIOS，在“Manageability”配置界面中，如下图所示，选择“Location Info”，按下Enter键，在弹出框内输入该客户机的位置信息，输入完毕后按下Enter键， 弹出框里的位置信息将显示在配置界面“Location Info”栏内。

[提示]

1. 位置信息的允许长度为1-15个字符。

2. 只支持英文字母、数字输入和特定字符，包括：英文字母“A~Z，a~z”， 数字“0-9”，字符“ - _ . ”。

3. 位置信息必须至少包含一个英文字母， 注意不可输入空格等其他字符。

4. 不支持中文输入和换行输入。


配置IP地址

配置IP地址有自动分配（动态）和人工分配（静态）二种方式。


自动分配IP地址

系统默认为自动分配IP地址。

如果用户希望自动为客户机分配IP地址，用户需要在安装DHCP组件后建立一个DHCP域。步骤如下：

建立DHCP作用域

1) 单击[开始] à [控制面板] à [管理工具] à [DHCP]。

2) DHCP配置页面。

3）从菜单中选择 [操作] à [添加服务器]，在“此服务器”文本框中输入当前服务器的IP地址或者机器名，单击“确定”。

4）服务器添加成功后，右键单击此服务器，选择“新建作用域”。

5）输入此作用域的“名称”和“描述”，单击“下一步”，输入此作用域分配的地址范围，

6）单击“下一步”，添加想要排除的IP地址范围，

7）单击“下一步”，设定租约期限，

8）单击“下一步”，进行最常用的DHCP选项配置，

9）单击“下一步”，添加路由器的IP地址，在IP地址文本框中输入要添加的路由器的IP地址，单击右边的“添加”，

10）单击“下一步”，添加DNS服务器和WINS服务器，

11）单击“下一步”，激活此作用域，

12）单击“下一步”，DHCP配置完成。

正确配置好的DHCP，如下图所示：

配置DHCP服务器选项

在完成DHCP作用域配置后，用户还需配置“服务器选项”。

1）双击打开“服务器选项”界面，选择启动服务器主机名。输入服务器IP地址。

2）选择“启动文件名”，输入固件端更新文件名，这一文件将用于PXE方式更新固件端。


使用静态IP地址

如果用户希望客户机使用固定的IP地址，则需要在IP Address，Subnet Mask， Default gateway栏内输入相应的值。步骤如下：

1）将Obtain an IP automatically 设为“No”。

2）在IP Address 栏内输入IP地址。

3）输入子网掩码 (Subnet Mask)

选择“Obtain an IP automatically”为“No”后，，此栏内会自动显示默认子网掩码255.255.255.0。

用户也可自行输入其他值，如255.255.0.0。

4) 输入默认网关 (Default Gateway)

输入网关的IP地址。

5）按F10保存当前设置并退出。

用户可重复以上步骤为每台客户机启用固件端，输入地址信息并配置IP地址。


第7步、安装选定的母机器

选中一台客户机安装操作系统、应用程序和英保通软件客户端，这台选定的客户机将被用作母机器。

什么是母机器？

母机器可以看作是网络环境中的样机，其他机器都是对他的拷贝，要求母机器与其他机器的硬件配置完全一致。

在配置同样一批机器的情况下，传统的做法是每一台机器单独配置，从安装操作系统到安装各种软件，然后再进行各种设置。这种做法非常耗费时间。

英保通软件提供了另外一种解决方案，对于相同硬件配置的同一批机器，只要在一台母机器上进行各种安装配置，再将这台母机器的镜像部署给其他机器即完成所有客户机的安装设置。常见的操作顺序是：

1. 启用客户机英保通软件固件端并分配IP地址以后注册到服务器成为托管客户机；

2. 选中某一台客户机安装操作系统和应用软件

3. 将这台机器选为母机器；

4. 安装英保通软件客户端

5. 创建母机器的镜像并部署到其他的同样硬件配置的客户机上。


安装操作系统与应用程序

由于在第5步中已经将网络内所有客户机的固件端都启用，包括被选为母机器的客户机。固件端启用后，客户机将从硬盘启动自动寻找网络内的英保通软件服务器端。

如果该选定的母机器尚未安装操作系统，用户可等待片刻使系统以其他方式启动，或将选定的母机器固件端禁用并设置从CD-ROM启动，以安装客户机操作系统。客户机端支持的操作系统包括简体中文或英文的Windows 2000 和Windows XP，具体要求参见 1.5.2.2节 。

安装完操作系统后，请在该选定的客户机上安装各种网吧所需的应用程序（浏览器、游戏、聊天工具等，视网吧自身需要而定），以便为第9步“创建磁盘镜像”做准备。

[注意]

安装完母机器的操作系统和应用程序后，请重新启用母机器固件端，否则无法安装英保通软件客户端。


安装客户端

英保通软件客户端由操作系统客户端服务与硬盘保护两部分组成。操作系统客户端服务负责与英保通软件服务器端通信完成操作系统管理，硬盘保护功能负责监控磁盘的I/O操作并且保护系统。

使用硬盘保护功能，需要满足如下要求：

1. 客户机上至少有一个FAT32分区被保护；

2. 建议在被保护的分区上运行chkdsk.exe，如有错误请修复文件系统；

3. 建议将系统虚拟内存的分页文件（Paging File）设置在非保护的分区上，提高系统运行性能；

4. 建议在被保护的分区上进行磁盘碎片整理；

5. 在被保护的FAT32分区上应保留足够的可用空间。最小的可用空间要求参照下表：

最小的可用空间要求

被保护的所有分区的 大小(PS) | 被保护的FAT分区上的 可用空间 (5%*PS) | 被保护的FAT分区上的连续可用空间(3%*PS)
10G | 1G | 300M
20G | 2G | 600M

[警告]

请确保在安装英保通软件客户端之前，英保通软件固件端已经按照第5步的方法启用。否则可能导致客户机启动不正常。

1）启动安装程序。

客户端进入Windows系统后，将英保通软件安装光盘放入光驱，系统安装程序将自动运行，用户也可直接单击光盘根目录下的autorun.exe以进行安装。

2) 确认安装前要求。

选择语言后，出现如下屏幕。点击“安装前准备”。

检查安装前准备是否已完成。点击“返回”。

3）选择“安装英特尔®英保通™软件客户端 (专业版1.1)”。

点击[安装英特尔®英保通™软件客户端 (专业版1.1) ]，单击“下一步”继续。

4）同意“许可协议”。

请阅读“英特尔软件许可协议”，选择“同意”， 单击“下一步”继续。

5）确认安装要求。

阅读“安装要求”，请确认符合所有要求，单击“下一步”继续。

6）输入客户端的客户信息和公司名称，单击“下一步”继续。

7）选择安装路径。

选择安装英保通软件客户端的路径，单击“下一步”继续。

8）确认安装，单击“下一步”继续。

9）开始安装。

系统开始安装并提示用户在继续安装前对即将受保护的分区进行检查和磁盘整理。点击“是”继续。

10）设置硬盘保护密码。

选择需要“硬盘保护”功能的磁盘分区，需要确保至少有一个为FAT32分区，输入管理员密码后确认密码。密码长度为6-15个字符。

11）安装完成。

点击关闭，系统将弹出是否重启的窗口。

单击“是”，机器将自动重启。

英保通软件客户端安装完成。


第8步、管理注册客户机

管理客户机包括三部分：

-        在“未托管客户机”页面内，接受新注册的客户机。

-        在“已托管客户机”页面内，选择将被作为母机器的客户机，执行本地启动。

-        在弹出页面中，设置该客户机为母机器。


接受客户机

在启用了英保通软件固件端并设置IP地址以后，当客户机连接到服务器所在的网络并开机后，会自动发送注册请求，要求注册到服务器。客户机屏幕上出现以下信息：

同时在服务器端会产生其他事件报警。用户将在页面左下方看到“新客户机注册”图标，新客户机注册属于报警类别中的“其他报警”。

编号 | 报警信息 | 报警原因与报警条件 | 客户机是否需开机 | 声音 报警 | 最大延时 （秒）
1 | 新客户机注册 | § 报警原因： 在局域网中有新的客户机注册到服务器 § 报警条件： 局域网中的新客户机必须已启用固件端 | 是 | 无 | 3

用户也可在“未托管客户机”按钮旁看到等待接受的客户机数目。

点击“非托管客户机”按钮，将看到非托管客户机的列表和详细信息：

选中要接受的客户机，点击“未托管客户机” 页面上方的“接受”按钮。

系统将弹出确认对话框，点击“是”继续。

被选中的客户机将从“未托管客户机”队列消失，转移到“已托管客户机”队列。

客户机在被接受后会停留在“BIOS状态”。


执行本地启动

对于被选定为母机器的客户机，用户需执行“本地启动”使之进入“操作系统状态”就绪，为创建磁盘镜像作准备。

在“已托管客户机”页面中，选中将被设为母机器的客户机，在页面上方点击“本地启动”按钮。


设置为母机器

系统将弹出如下对话框，点击“是”确认。

系统将询问用户是否要将新客户机设置为母机器。

选择“是”该客户机将被设为母机器。

选定为母机器的客户机将自动重启，由“新客户机”转变到就绪客户机，并从 “BIOS状态”转变到“操作系统状态”。母机器就绪完成。

[提示]

1. 选择“取消”该客户机将成为普通客户机。

2. “您是否要将新客户机设置为母机器”的对话框只有在仅选中一台客户机的情况下才会弹出，如果用户同时接受一批客户机，此对话框不会弹出。


第9步、创建磁盘镜像

从服务器端控制台选择母机器进行磁盘镜像创建。

点击左边菜单栏的 [磁盘镜像管理]，单击页面上方“生成磁盘镜像”按钮。

第一步、选择一个母机器

点击需要生成镜像的母机器后面的“选择”，该选中的母机器IP地址将出现在下方“母机器”框内。点击“下一步”继续。

第二步、选择磁盘分区

选择需要生成镜像的母机器的IDE设备，点击“下一步”继续。

生成的镜像将包含母机器上的所有分区。

[提示]

在有磁盘保护的客户机上做镜像， 应在此处选中所有被保护的磁盘分区，否则生成的磁盘镜像在部署到其他客户机上可能会出错。

第三步、填写磁盘镜像信息

在“磁盘镜像名称”栏输入用户对此镜像的命名(不支持中文名)， 建议采用某种比较易于区分的命名规则以便日后记忆，如机器名+“_”+日期（例如 IPAT-000-010_20050801）。此栏是必须的。

在“简介”中输入对所创建磁盘镜像的的注释，以便日后的镜像管理，此栏是可选的。

缺省的镜像产生方法是磁盘的精确备份，即需要创建镜像分区的大小就是所创建的镜像文件的大小。

若选中“基于文件系统生成较小的磁盘镜像文件”将根据文件系统的记录创建镜像，也就是只对存有文件数据的磁盘空间产生镜像文件，这样如果磁盘中真正写入的数据磁盘空间较小，所产生的镜像文件的大小也会较小。

若选中“立即重启客户机以执行操作”则被选中的客户机将立即重启以执行磁盘镜像创建任务，否则将在下次机器重启时执行该任务。

[提示]

1. 对于NTFS分区，英保通软件只能采用精确复制的方法创建磁盘镜像文件，也就是 “基于文件系统生成较小的磁盘镜像文件”不起作用。

2. 如果选中“基于文件系统生成较小的磁盘镜像文件”，那么在部署同样大小的磁盘镜像可能需要较部署精确复制的磁盘镜像文件时间较长。如果不需要考虑服务器上的磁盘空间大小，那么建议在客户机的磁盘分区中被使用的磁盘空间有50%以上时，采用精确复制磁盘的镜像创建方式以节约镜像部署的时间。

第四步、生成磁盘镜像

检查磁盘镜像信息是否正确，点击“生成”以创建磁盘镜像。否则回到“上一步”重新设置。

完成以上步骤后，该母机器将自动重启并开始创建磁盘镜像，过程可能会持续几分钟到几十分钟，时间长短取决于机器性能及镜像大小。

创建好的磁盘镜像将通过MTFTP发送到指定的MTFTP服务器目录下，然后进入操作系统。有关MTFTP服务器及目录的设置，请参见第4步。

[警告]

请确保MTFTP文件传输服务器的根目录所在分区是NTFS分区格式。如果是FAT或FAT32分区，可以读写的最大文件大小为4GB,如果将来创建的文件大小超过这个限制，那么会造成读写文件失败。并且在创建磁盘镜像以前，检查一下MTFTP文件传输服务器的根目录所在分区有足够的磁盘空间以上传镜像文件。


第10步、部署磁盘镜像

启动所有需要分发磁盘镜像的客户机。确保所有客户机已经启动固件端并已正确配置IP地址。

进入“已托管客户机”页面，选中希望部署磁盘镜像的客户机前面的选择框，该客户机就被选中。选中后，该客户机行显示为红色。可以同时选中多个客户机。

[提示]

如何选中多个客户机：选中一个客户机，然后按住SHIFT选中下方任何一台客户机，之间的客户机也会被一起选中。

在存在大量客户机的情况下，您也可一次性选择所有就绪客户机。方法为：

点击“已托管客户机”页面右上角的“选择过滤方式”，在下拉框中选择“选中所有就绪客户机”。

在 [已托管客户机] – [客户机管理] 界面上方选择 “部署磁盘镜像”按钮。如图所示：

系统提示是否确定要对所选客户机部署磁盘镜像，点击“是”确定。

磁盘镜像部署可分为二个步骤：

第一步：选择一个磁盘镜像

在“磁盘镜像管理”界面内选中需要部署的镜像。点击“下一步”继续。

[注意]

一次只能部署一个磁盘镜像。

第二步：部署磁盘镜像

检查磁盘镜像信息是否正确，若信息无误，点击“下一步”继续。否则回到“上一步”重新设置。

点击“部署”以部署选中的磁盘镜像。

可以通过“当前执行任务”页面查看本次磁盘镜像部署执行过程。

客户机将重新启动后进入BIOS界面，会执行磁盘镜像部署，部署进度如下图所示：

客户机部署后进入操作系统，此时，由于客户机的配置与母机完全相同，在网络上会出现机器名冲突。英保通软件服务器端会自动进行客户机初始化设置，为每台客户机进行个性化配置。

用户只需等待，客户机会自动重启，重新进入操作系统，本次客户机器镜像部署完成，不会有网络名冲突。

[提示]

1. 客户机必须启用英保通软件固件端才可以自动部署磁盘镜像。

2. 被部署的客户机的硬盘大小必须大于或者等于母机器的硬盘大小，注意如果是不同型号的硬盘，即使标称值都为同样大小如80G，实际的大小仍然可能不同。在这种情况下，如果母机器的硬盘较大，那么生成的镜像文件无法部署到客户机上。

[警告]

请不要部署镜像给母机器，否则部署后网络内可能会产生IP地址冲突。


完成

客户机完成磁盘镜像部署后，会进行机器名配置以及其他初始化设置。由于客户机的设置与母机器完全一样，包括机器名。因此，当初次部署完毕后，客户端会出现“网络重名”的提示。

系统会根据服务器端的配置自动对新客户机的名字进行分配并再次重启，重启后的每台客户机将分别获得不同的机器名。

客户机完成磁盘镜像部署后，系统会根据服务器端的配置自动对新客户机的名字进行分配并再次重启，重启后的每台客户机将分别获得不同的机器名。

默认的客户机机器名前缀为 IPAT。

-        如果用户没有在BIOS输入Location Info，，系统会在机器名前缀后（如IPAT）加上客户机的IP地址后2个字节组成机器名。重启后的客户机将分别获得机器名IPAT-000-010、IPAT-000-011、 IPAT-000-012…

-        如果用户已在BIOS输入Location Info，，系统会截取Location Info的前15位组成机器名。如：若用户在Location Info 中输入Area_A.Row_01.Seat_01，则机器名将为Location Info的前15位Area_A.Row_01.S。

[提示]

只有被部署镜像的客户机会按照以上规则被命名，母机器仍然使用原来的机器名。

用户也可通过对客户机进行个性化配置来改变机器名，具体步骤 参见3.2.3.2节。

自此，整个应用环境搭建完成。用户可以使用服务器端的管理控制台对所管理的客户机进行维护和管理。


第三章、服务器端的使用

在安装完英保通软件后，首先要启动并配置服务器端程序。

启动方法1：

单击[开始] à [所有程序] à [英特尔(R)英保通(TM)软件] à [服务器端网吧版1.1] à [服务器端控制台]，即可启动服务器端管理界面。

启动方法2：

在桌面上，双击快捷方式“服务器端控制台”，即可启动服务器端管理界面。

启动方法3：

本地启动服务器端管理界面，在浏览器的地址栏中输入：

http://localhost/IPAT/

服务器端管理界面也可通过远程访问。在浏览器的地址栏中输入：

http:// +“服务器机器名 或 服务器IP地址”+ “/IPAT/

例如：服务器的机器名为IPATServer，则完整的地址为：

http://IPATServer/IPAT/ 或http://192.168.0.1/IPAT/

浏览器将弹出网络密码对话框，输入服务器本地用户名及对应密码即可访问服务器端管理界面。

启动后，将会看到界面的左侧是主菜单栏，提供了“客户机管理”、“磁盘镜像/安装包管理”、“任务/事件管理”和“其他”四类操作。如下图所示：

未托管客户机、已托管客户机、当前执行任务

磁盘镜像管理、升级安装包管理

异常警报、资产变更、任务日志

服务器配置、帮助、联系我们


3.1 服务器配置

在进行其他操作以前，首先应该配置服务器。

通过服务器管理主页面，能够对服务器的各种属性进行配置。

点击服务器端管理界面左边的[服务器配置] 可以进入服务器配置属性页：

点击“高级”按钮可看到更多“服务器设置”选项。

在服务器配置页面中，您可以对服务器的各种属性进行设置。可以设置的属性包括:

-        文件传输服务器的根目录；

-        是否允许报警功能；

-        是否自动接收新的客户机；

-        当传输同一个文件给多个客户端时，是否自动采用组播的形式以节约时间；

-        对存放在服务器数据库中的事件日志和任务日志进行定时清空；

-        是否定时检查客户端的在线情况以及确定检查时间的间隔；

-        部署磁盘镜像延时同步。


3.1.1 设置文件传输服务器根目录

参见第二章、第4步 。


3.1.2 设置报警功能

服务器端已默认设置了“启用硬件报警及管理功能”。

异常报警包括：

1. 客户机连接丢失警报

2. 操作系统崩溃警报

3. USB设备移除警报

4. 处理器异常警报

5. 机箱入侵警报

当 “启用异常报警及远程控制功能”被启用后，其中第3-5项报警功能默认已被启用。而第1-2项功能还需进行个别设置才能被启用。

如：当用户希望除了默认的第3-5项报警功能被启用外，还希望启用第1项“客户机连接丢失报警功能”时，需要首先保证“启用异常报警及远程控制功能”已被启用，再启用子功能“启用客户机连接丢失报警功能”。

如图：


3.1.3 设置自动接收新客户机

当一台新客户机加入安装有英保通软件的局域网时，新客户机启动后会自动寻找网络中的服务器并试图进行注册。管理员可以手工接受或者拒绝这个机器的注册请求，但如果管理员有时外出，可以通过设置自动接收新客户机来代理管理员的工作。

选中“自动接受新的客户机” 前的选择框：

设置后，当新的客户机连接到网络后，系统将自动接受该客户机，在 “已托管客户机” 界面内将出现该客户机信息。

如果想取消自动接收注册，只需要取消选中“自动接受新的客户机”。

关于如何接受注册 /删除客户机，请参见 3.2节 。


3.1.4 设置自动多播

当传输同一文件给若干个客户机的时候，如果采用组播技术，可以大大节约传输的时间。除了手工指定在传输文件中是否采用多播以外，还可以在服务器配置中设置自动多播，这样服务器在发现正在向若干个客户机传输同一个文件时，会自动采用多播传送以提高效率。

点击界面右边 [服务器设置] 下的 [高级] 选项，系统默认已选中“当存在多台客户机同时操作时，自动采用多播”前面的选择框。这一选项在对批量新机器统一进行部署镜像时非常方便。

[警告]

组播技术需要交换机的支持，如果所采用的交换机不支持IGMP的功能（或该功能未被正确设置），则组播数据包会发到交换机的每一个端口，给整个网络带来过多的负载，有可能影响其他网络应用程序的正常运行。因此使用组播技术时需要谨慎。建议在采用组播方式部署镜像或安装包文件时，网络里不要放置正在营业的电脑以免影响其它机器的正常使用。


3.1.5 设置清理日志

随着服务器的运行，会在数据库中保存大量的日志信息，如报警事件日志，执行任务日志等等。当这些日志不再需要的时候，可以将它们删除，这样可以节约一定的磁盘空间。在服务器管理页面中提供了一个简单的工具用以清空日志。每隔一段时间后，这些日志会被自动删除，这样简化了手工清理日志的工作。

进行自动清理事件日志，需要选中“清空事件日志”前面的选择框并在后面的输入框内填入每隔多少时间（以天为单位）清除日志，然后点击对应的“执行”按钮。同样，我们也可以设置在设定的时间自动清除任务日志。


3.1.6 监测客户机在线情况

当服务器运行时，会自动向每一台托管的客户机隔一段时间发送一个消息以查询客户机是否正常工作。管理员可以设置是否采用这个操作以及决定时间间隔。为此，需要选中“检测客户机生成在线情况”前面的选择框并在后面的输入框内输入时间间隔（以秒作为单位），然后点击对应的“应用”按钮。

[提示]

设置检测客户机的在线情况可以使管理员随时掌握客户机的当前状态，比如是否关机等。但启动这一功能会一定程度地影响服务器性能，用户可根据自己的服务器情况进行设定。


3.1.7设置磁盘镜像部署同步延时

管理员可以设置是否采用磁盘镜像部署同步延时以及决定延迟时间。

设置部署磁盘镜像开始延迟时间

当服务器部署镜像时，管理员可设置磁盘镜像部署开始延迟时间，以使所有注册客户机可同步进行更新。由于各个客户机的机器性能与网络配置不同，在对多台机器进行镜像部署时，不同客户机所需的重启时间及部署时间也不同，导致任务的开始与完成时间不一致，并容易对网络性能造成影响。

对这一选项进行设置后，在执行磁盘镜像部署命令后，服务器端会弹出计时器窗口并开始倒计时，被部署的客户机将自动重启并停留在BIOS状态，计时器计时结束后客户机将同时开始部署磁盘镜像。这一功能可达到优化网络性能的目的，同时也给管理员对客户机的监控和管理带来方便。

系统默认已选中“设置部署磁盘镜像开始延迟时间”前面的选择框，默认延迟时间为300秒。

如果用户希望改变该延迟时间，在“设置部署磁盘镜像开始延迟时间”后面的输入框内输入时间间隔（以秒作为单位），然后点击对应的“应用”按钮。建议最少设置180秒。

设置部署磁盘镜像间隔延迟时间

启用这一选项后，客户机会在第一个硬盘分区部署完成后，间隔一定时间开始部署第二个硬盘分区。计时从客户机（网络内在最短时间内部署完第一个硬盘分区的客户机）完成部署的时间算起。

如：三台客户机ABC同时开始部署磁盘镜像，客户机A最先部署完第一个硬盘分区，那么客户机A会等待60秒以便和客户机B和C同时开始部署第二个硬盘分区。

系统默认已选中“设置部署磁盘镜像间隔延迟时间”前面的选择框，默认间隔延迟时间为60秒。

如果用户希望改变该延迟时间，在“设置部署磁盘镜像间隔延迟时间”后面的输入框内输入时间间隔（以秒作为单位），然后点击对应的“应用”按钮。建议最少设置60秒。


3.1.8 默认网络配置

服务器端的管理界面可对首选域名解析服务器、备用域名解析服务器进行配置。

若需改变DNS设置，输入对应的值，点击屏幕右上方的“应用”按钮。

客户机的IP地址、子网掩码、默认网关则在客户端的BIOS界面则进行配置。


3.1.9 服务器服务信息

服务器端的管理界面可查看服务器端的当前服务启动状况，包括 ：

- 报警服务信息： ASF Proxy Service

- 启动管理服务信息： Boot Management Service

- 文件传输服务器信息： MTFTP Service

- 操作系统管理任务服务信息： OS Management Service


设置自动部署

在“自动配置”栏内，选中“自动为新的客户机布署磁盘镜像” 前的选择框，界面上将列出系统已创建的镜像文件信息。

设置后，当新的客户机连接到网络后，系统将自动部署默认磁盘镜像。

[提示]

默认磁盘镜像：在系统创建镜像后，此栏中会自动列出所有磁盘镜像信息，用户只需在“设为默认”下选择希望自动部署的镜像即可。


3.2客户机注册与管理

在配置好服务器以后，就可以接受客户机的注册。在接受客户机的注册以后，客户就由未托管客户机成为托管客户机，可以接受服务器的各种管理。

[提示]

客户机的注册功能是在英保通软件固件端里实现的，客户端无需安装任何软件（裸机）即可完成注册工作。


3.2.1 未托管客户机

“未托管客户机”的 “客户机管理”页显示正在等待注册的客户机信息。

接受 | 接受新客户机注册到英保通软件服务器端。
拒绝 | 拒绝新客户机的注册。
删除 | 删除客户机，客户机将从未托管客户机队列消失。


3.2.1.1 接受

用户可选择接受新客户机。点击“接受”后，被选中的客户机将从“未托管客户机”队列消失，转移到“已托管客户机”队列。

具体步骤 参见第二章、第8步 。


3.2.1.2 拒绝

用户可以通过点击“拒绝”拒绝新客户机的注册，如点击“拒绝”，此客户机将从状态“新客户机”转变为“被拒绝客户机”。


3.2.1.3 删除

删除客户机，客户机将从未托管客户机队列消失。


3.2.2 已托管客户机

被接受的客户机将出现在“已托管客户机”页面：

开机 | 对客户机进行远程开机。
关机 | 对客户机进行远程关机。
重启 | 对客户机进行远程重启。
本地启动 | 对新客户机从硬盘进行本地启动到操作系统状态，以使新客户机就绪。
部署磁盘镜像 | 对客户机部署磁盘镜像。部署磁盘镜像可以帮助配置、恢复系统。
部署升级安装包 | 对客户机部署安装包。部署安装包可通过增量部署方式快速更新系统。
网络恢复 | 对客户机进行网络恢复。客户机将立即重启并恢复到上一次正常运行的状态。
更新固件端 | 对客户机固件端进行更新。
删除 | 删除已托管的客户机。客户机将列入未托管客户机页面中的被拒绝客户机队列。

远程控制功能能够使得管理员在远程服务器上对客户机进行控制，包括远程开机、关机、重启、本地启动、更新客户固件端、部署磁盘镜像、部署升级安装包等。


3.2.2.1 远程开机

选择需要开机的客户机，点击 “开机”按钮，客户机会立刻执行“开机”命令。该命令只针对处于待机状态的客户机，如果计算机处于其他状态，例如操作系统状态，该命令无效。


3.2.2.2 远程关机

选择需要关机的客户机，点击“关机”按钮，客户机会立刻执行“关机”命令。该命令只针对处于非待机状态的客户机。

如果计算机处于操作系统运行阶段，关机命令为软关机，其他状态下，执行硬关机。如果软关机不成功，会自动执行硬关机。


3.2.2.3 远程重启

选择需要重启的客户机，点击“重启”按钮，客户机会立刻执行“重启”命令。该命令只针对处于非待机状态的客户机。

如果计算机处操作系统运行阶段，关机命令为软重启，其他状态下，执行硬重启。如果软重启不成功，会自动执行硬重启。


3.2.2.4 本地启动

本地启动命令能够让远程客户机从硬盘进行本地启动。

已托管客户机的就绪状态分为“就绪客户机”和“新客户机”两种：

“新客户机”为所有已注册，但尚未执行本地启动操作的客户机，对于“新客户机”服务器端需要进行“本地启动”以使新客户机就绪。

“就绪客户机”则包含了所有已经注册，并执行了本地启动操作的客户机相关信息。

对于“就绪客户机”，服务器端可进行各种功能操作。


3.2.2.5 网络恢复

对客户机进行网络恢复。客户机将立即重启并恢复到上一次正常运行的状态。

服务器在每次给客户机部署硬盘镜像和升级包的时候会记录每次操作，利用网络恢复功能，可以自动地向被破坏的客户机重复部署以往的镜像和升级包。如果客户机感染了软件病毒或者运行出现不稳定，就可以很快将客户机恢复，显著地增加了客户机可以运营的时间，减少了日常维护管理的负担。

点击控制台左边主菜单栏的“托管客户机”按钮，将看到系统中所有已经注册完成的客户机的信息，如图：

选中客户机，点击“网络恢复”按钮，系统将出现确认对话框。点击“确定”，客户机将重启。

客户机重启后，在BIOS界面上会显示部署磁盘镜像或者分发软件包信息。

所有的部署和分发任务完成后，系统会重新启动到操作系统，进一步完成恢复后初始化的配置。此时，由于客户机的配置与母机相同，在网络上会出现机器名冲突。英保通软件服务器端会自动进行客户机初始化设置，为每台客户机进行个性化配置。用户只需等待，新安装的客户机会自动重新启动到操作系统，本次客户机器远程恢复操作完成。


3.2.2.6 更新固件端

在进行固件端更新前，需要注意：

1. 必须先使用辅助管理工具导入固件端升级文件，具体步骤参见4.4节。

2. 必须选择正确的升级文件，由于不同的主板型号所对应的升级文件也不同，用户在进行固件端升级前需要确定客户机的主板型号以选择正确的固件端升级文件。

英保通软件提供的固件端升级文件以 [IntelPATAgent] + [主板系列号] 命名，如IntelPATAgent865.exe用于更新865系列主板的固件端, IntelPATAgent915.exe用于更新915系列主板的固件端。

如何确定主板型号

关于确定客户机的主板型号，共有二种方法：

方法1

用户可以在服务器端的“已托管客户机” 页面的“主板类型” 栏内查看。如图：

用户可通过“主板类型”栏内显示的前五位来确定客户机的主板类型。

如：屏幕上“主板类型”栏内显示 CK86510J.1171，前五位为CK865，则表示该主板型号为865系列；若“主板类型”栏内显示 DT91510J.0222，前五位为DT915，则表示该主板型号为915系列。

方法2

用户可以在客户机上按F2进入BIOS界面的Main页内查看。如图：

用户可通过BIOS Version栏内显示的前五位来确定客户机的主板类型。

如：屏幕上BIOS Version栏内显示 CK86510J.86A.1171.2005.0601.1027，前五位为CK865，则表示该主板型号为865系列；若BIOS Version栏内显示 DT91510J.86A.0222.2005.0714.1604，前五位为DT915，则表示该主板型号为915系列。

更新客户机固件端

在导入固件端升级文件完成后，选择需要更新固件端的客户机，点击“更新客户机固件端”按钮，服务器端会弹出“更新客户机固件端”窗口。

第一步：选择一个文件

系统将列出所有已被导入的固件端更新文件，点击“选中”进行选择。选中后的固件端更新文件将出现在页面下方。

第二步：更新客户机固件端

查看固件端更新信息，若正确无误，点击“更新”。被选择的客户机将立即重启并更新固件端。

客户机重启后，用户可看到以下信息，完成后客户机将重启并进入操作系统状态。


3.2.2.7 部署磁盘镜像

选择需要部署镜像的客户机，点击“部署磁盘镜像”按钮，服务器端会弹出“部署磁盘镜像”窗口。

具体步骤 参见第二章、第10步 。


3.2.2.8 部署升级安装包

选择需要升级安装包的客户机，点击“部署升级安装包”按钮，服务器端会弹出“部署升级安装包”窗口。

具体步骤 参见 3.4.3节 。


3.2.2.9 删除注册客户机

在“已托管客户机”页面中选中需要删除的注册客户机，可对客户机进行“删除”操作。

选中要删除的客户机，点击页面上方的“删除”按钮。

系统将出现如下提示，点击“是”继续。

执行了此操作的客户机将被转移到“未托管客户机”队列中，状态为“被拒绝客户机”。

服务器会自动拒绝状态为“被拒绝客户机“的客户机的注册请求，因此这些客户机无法再受到此服务器的管理，管理员也看不到注册请求。

如果该客户机被误删，可以在“未托管页面”中选择“接受”，客户机将重新回到“已托管客户机”列表中，成为新客户机，用户需要对客户机手动重启。手动重启后客户机状态为“未知状态”，需要重新进行“本地启动”以使该客户机就绪。

如果在“未托管页面”中选择“删除”，客户机将在下一次重启时自动搜索新的服务器，管理员将看到它的注册请求，可以选择拒绝或接受此客户机注册。


3.2.3 远程配置客户机

在“托管客户机”页面中，点击相应客户机的“配置”按钮，可对该客户机进行个性化配置，如下图所示：


3.2.3.1 设置母机器

母机器是用来创建初始磁盘镜像的机器。磁盘镜像和增量软件包只能从母机器上进行创建。母机器也可以被设置成普通客户机。

[提示]

1. 当该客户机被设置为母机器后，该客户机的所有本地还原点会被清除，即该客户机会恢复到初始被部署镜像的状态。

2. 建议网络上仅存在一个母机器，否则有可能会出现机器同名的警告。当该机器不需要创建磁盘镜像或者增量软件包的时候，建议将其设置为一台普通客户机。当需要的时候，重新设置为母机器。


3.2.3.2 更改计算机名

如果希望为客户机另取名字，进入 [已托管客户机] – [客户机管理] 界面，在需要进行配置的客户机的“配置”栏点击“设置”，进入客户机管理界面：

在“计算机名”框内填入计算机名称，在“立即重启客户机以使得设置生效”选项前打“√”，点击“执行”。客户机将重启，新的名字将在重启后生效。

[提示]

1. 该命令会在客户机上创建一个新的还原点，对该客户机分发增量软件安装包后，该还原点会被清除，客户机仍然会使用新设置的机器名。

2. 如果在更改计算机名后，用户对该客户机的位置信息或IP地址进行了重新设置，则系统将按照命名规则重新为客户机设置计算机名。

3. 关于计算机命名规则，请参见第二章“完成”部分。


3.2.3.3 启用异常报警功能

异常报警功能能够提供远程控制、防盗报警、系统异常报警以及系统状态报警。用户可以启用该功能，也可以关闭该功能。

用户可以在服务器设置页面中设置是否默认打开此功能。此外，用户也可以此“配置”页面中为该客户机进行单独设置。

用户可使用下拉框选择网卡，并在“启用” 选项框内打上“√”，点击“执行”。新的设置将在下次重启后生效。用户也可选择“立即重启客户机以使得设置生效”以立即生效。


3.2.4 查看客户机信息

点击“已托管客户机”页，将看到所有已托管的客户机信息：

“客户机管理”页包含了所有已经注册的客户机相关信息，如是否有报警信息、客户机位置、IP地址、当前状态、部署信息、主板类型、固件端版本、机器配置、当前执行任务等。

当前状态可分为“操作系统状态”、“BIOS状态”、“关机状态”、“未知状态”四种。

操作系统状态： | 客户机正在操作系统下
BIOS状态： | 客户机处于EFI状态下
关闭状态： | 客户机处于关机状态下
未知状态： | 客户机处于未知状态 （这种情况对刚注册上来未安装硬盘保护程序的客户机会有短暂出现，但若客户机已安装硬盘保护程序并正常启动至操作系统，服务器端依然显示该状态，则表示该客户端不正常，需手动重启。）

点击“位置”可查看客户机系统信息、硬件信息和硬盘管理信息：

[提示]

点击每个信息栏右端的 [image] 按钮可以展开/隐藏相应的子信息。


3.2.4.1系统信息

“系统信息”栏显示了机器名、机器位置、IP地址、MAC地址、操作系统版本，客户机所安装的所有软件等信息。

点击“显示客户机软件”可以看到此机器上已安装的软件信息：

点击“历史任务”可以看到此客户机上的历史固件端管理任务和历史操作系统任务：

[注释]

1. 历史固件端管理任务指服务器发给客户固件代理的管理任务，例如创建磁盘镜像、分发磁盘镜像等。

2. 历史操作系统任务指服务器发给客户端的管理任务，例如配置机器名、修改网络配置等。


3.2.4.2 硬件信息

“硬件信息”栏显示了机器的CPU类型、CPU数量、内存大小，硬盘分区情况等。

点击“显示详细信息”将看到更详细的硬件信息：

点击“显示历史”则可以看到此计算机的历史硬件信息。

同时选中二个历史信息可对该客户机的历史硬件纪录进行对比，用户可通过此功能察看是否有硬件改变，以及改变的具体信息。

对比步骤：

1. 选中需要对比的二个历史信息；

2. 在右下角的下拉框中选择“比较”；

3. 点击“执行”按钮。

更改状态：

系统将列出硬件更改信息，更改状态包括：

未改变： 二次历史时间的硬件配置完全一样

新增： 该硬件为第二次历史时间新增的硬件

删除： 该硬件在第二次历史时间已被删除

在下图中，可看到相比于 2005年8月2日，系统在 2005年8月3日了移除了硬盘，其他硬件则保持相同。

点击“详细”则可以看到每次更改记录的计算机历史硬件信息。


3.2.4.3 硬盘信息

“硬盘信息”栏显示了机器的磁盘信息、磁盘分区情况、部署镜像记录、部署安装包记录等。


3.3 磁盘镜像的创建、管理和部署

在英保通软件中，提供了强大的网络磁盘镜像功能，用户可以用选定的母机器创建磁盘镜像上传到服务器，然后使用该创建好的磁盘镜像部署到其他相同硬件配置的机器上。这样如果需要部署同一批机器，只需要选择部署一台机器就可以了，大大减轻了日常维护管理的负担。此外，磁盘镜像也可以用于系统的恢复，如果某一台机器出现软件故障，那么只要简单的把原来创建好的镜像文件再重新部署一下，客户机就会恢复正常工作。因此，网络磁盘镜像对于机器的管理有着很大的帮助。


3.3.1创建磁盘镜像

具体步骤参见第二章、第9步 。


3.3.2管理磁盘镜像

在成功创建磁盘镜像后，点击控制台左边主菜单栏的“磁盘镜像管理”按钮，将看到当前服务器上保留的所有磁盘镜像相关信息：

磁盘镜像编号： | 服务器分配给此镜像的标识号，一般按照1，2，3，4的编号顺序来分配。
磁盘镜像名称： | 镜像创建过程中输入的名称。
简介： | 镜像创建过程中输入的镜像描述。
创建时间： | 此镜像的创建时间（以服务器当时的时间为准）。
状态： | 表示镜像的当前状态，对于已生成好的镜像显示为“就绪”，对于正在生成的显示为“创建中”。
创建源： | 创建此镜像的母机器位置信息。

点击“删除”按钮可从此列表中将对应镜像删除，对应的磁盘文件本身也将被从文件系统中删除。

[警告] ] 删除镜像以后无法恢复。


3.3.3部署磁盘镜像

从母机器上创建好镜像文件以后，就可以将创建好的镜像部署给其他相同硬件配置的客户机了。


3.3.3.1 人工部署磁盘镜像

人工部署磁盘镜像

关于人工部署磁盘镜像，具体步骤参见 第二章、第十步 。

部署磁盘镜像延迟时间：

如果管理员已在“服务器设置”中设定了“设置部署磁盘镜像延迟时间”。

在按以上步骤对客户机执行镜像部署时，系统会弹出计时器窗口：

所有被选中的注册客户机会重启并停留在固件端状态，并在计时结束后同时开始进行镜像部署。这一设置可帮助管理员更好地对客户机进行管理和优化网络性能。

[提示]

系统默认值为300秒，推荐值为大于或等于180秒。如果设定的时间过短，由于机器性能与网络配置的差别，某些客户机将不能在该时间内进入固件端状态。在这种情况下，镜像部署命令对这些客户机将无效，客户机将保持原有状态。请确保所有的客户机停留在固件端状态，如果不是，请人工重启客户机。


3.3.3.2自动部署磁盘镜像

自动部署磁盘镜像

当一台未经配置的客户机被连接到安装有英保通软件的局域网时，如果能够注册成

功并在服务器端“服务器配置”页面中选择“自动为新的客户机部署磁盘镜像”，服务器可以自动向这台未经配置的客户机部署镜像，这样便于配置大批量的新电脑。

如果用户已在[服务器设置] – [自动配置] 中设置“自动为新的客户机部署磁盘镜像”。

管理员可以在当前磁盘镜像列表中选择新创建的磁盘镜像。只要在“设为默认”下面的“选择”按钮上点击就将选中的磁盘镜像作为默认镜像部署给新客户机。

做好这些设置以后，其他尚未配置的客户机只要接入服务器所在的网络，启动后就会自动注册到服务器，在管理员接受客户机注册后系统自动给尚未配置的客户机部署磁盘镜像。如下图所示：

[提示]

客户机必须启用英保通软件固件端才可以自动部署磁盘镜像。

自动多播磁盘镜像

在“服务器配置”页面中选中“当存在多台客户机同时操作时，自动采用多播”前的选择框，就会在多台客户机自动部署磁盘镜像时使用组播技术。这一选项在对批量新机器统一进行部署镜像时特别有效。

设置缺省磁盘镜像

管理员可以在当前磁盘镜像列表中选择缺省的部署镜像。只要在“设为默认”下面的“选择”按钮上点击就将选中的磁盘镜像作为默认镜像部署给新客户机。做好这些设置以后，裸机只要接入服务器所在的网络，启动后就会自动注册到服务器，在管理员接受客户机注册后系统自动给裸机部署磁盘镜像，而且在镜像部署启动以后会自动修改本机器的网络设置，大大减轻了新机器的安装任务工作量。


3.4 安装包的创建、管理和部署

在日常的运营维护中，最常见的操作就是为每一台机器安装新的软件或者删除旧的软件。在英保通软件中，提供了强大的增量部署功能，用户可以在选定的母机器安装新软件或者删除旧软件，然后创建安装包上传到服务器，使用该创建好的安装包部署到其他相同硬件配置的机器上，被部署了安装包的机器也会像母机器一样安装或者删除该软件。这样如果需要为同一批机器安装新软件或删除旧软件，只需要对一台机器操作然后再部署给其他机器就可以了，大大减轻了日常维护管理的负担。


3.4.1 创建安装包

首先在母机器上安装所需要的软件或者删除掉不需要的旧软件。

在母机器更新完成以后，不要重新启动母机器，点击服务器控制台左边主菜单栏中的“升级安装包管理”页面，将进入以下界面：

点击页面上方“生成升级安装包”按钮，将进入生成安装包页面。

创建安装包可分为四个步骤：

第一步：选择一个母机器

系统会列出所有母机器，选择希望生成安装包的母机器，该母机器的IP地址将出现在列表下方。

点击“下一步”继续。

第二步：选择IDE设备

页面上将列出该母机器所有的IDE设备。下拉框显示母机器的硬盘列表。选择母机器上刚才安装/删除软件时被更新的硬盘。（如果母机器上只有一个硬盘，那么就选择这个唯一的硬盘。）

点击“下一步”继续。

第三步：填写升级安装包信息

在“安装包名称”栏输入用户对此安装包的命名， 建议采用某种比较易于区分的命名规则以便日后管理，如增加/删除的软件名+“_”+日期（例如CSPatch03_20050801）， 所创建的安装包必须要有命名。

若选中“立即重启客户机以使得设置生效”则客户机将立即重启执行创建安装包的任务，否则将在下次重启时执行。

第四步：生成升级安装包

最后点击“生成”按钮，任务布置成功。

该指定的客户机在重启后会首先创建安装包，并将创建好的安装包通过MTFTP发送到MTFTP服务器的指定目录下，然后保留上次的硬盘更新并更新硬盘状态。有关MTFTP服务器及目录的设置，参见第二章、第4步。

创建安装包时的客户端将显示以下信息：

用户可在此看到安装包创建进度。


3.4.2 管理安装包

升级安装包的管理与磁盘镜像管理相类似。点击控制台左边主菜单栏的“升级安装包管理”按钮，将进入以下页面。

“升级安装包管理“页面中列出当前的所有安装包信息，包括：

安装包编号： | 服务器分配给此安装包的标识号，一般按照1，2，3，4的编号顺序来分配。
安装包名称： | 安装包创建过程中输入的名称。
已部署客户机数： | 此安装包已部署的客户机数目。
创建时间： | 此安装包的创建时间（以服务器当时的时间为准）。
状态： | 表示安装包的当前状态，对于已生成好的安装包显示为“就绪”，对于正在生成的安装包显示为“创建中”。
创建源： | 创建此安装包的母机器位置信息。

点击“删除”按钮可从此列表中将对应安装包删除，对应的磁盘文件本身也将被从文件系统中删除。

[警告]

删除安装包以后无法恢复。


3.4.3 部署安装包

从母机器上创建好安装包文件以后，就可以将创建好的安装包部署给其他相同硬件配置的客户机了。

进入“已托管客户机”页面，选中希望部署磁盘镜像的客户机前面的选择框，该客户机就被选中。选中后，该客户机行显示为红色。可以同时选中多个客户机：

在存在大量客户机的情况下，您也可一次性选择所有就绪客户机。方法为：

点击“已托管客户机”页面右上角的“选择过滤方式”，在下拉框中选择“选中所有就绪客户机”。

点击“部署升级安装包”按钮，系统将出现以下提示：

点击“确定”继续。

安装包部署可分为二个步骤：

第一步：选择升级安装包

“升级安装包部署”页面将列出所有已创建的安装包文件，用户可以选择需要部署的安装包。

如果用户选中某个安装包，系统会自动检查之前生成的安装包是否已被部署到选中的客户机，如果没有，系统会自动选中该安装包及之前所有尚未被部署的安装包。

点击 “下一步”继续。

第二步：部署升级安装包

察看安装包信息是否正确，若信息无误，点击“部署”以部署选中的升级安装包。被选中的客户端立即重新启动，部署任务被执行。可以通过“当前执行任务”页面查看本次安装包镜像部署执行过程。

客户机重新启动后进入BIOS界面，会执行升级安装包部署，部署进度如下图所示：

当部署任务完成后，客户机会重新启动后进入操作系统，完成部署后的初始化配置。

[提示]

被部署安装包的客户机首先应该部署母机器的硬盘镜像，否则无法直接部署安装包。


3.5 任务/事件管理

英保通软件提供了软硬件资产监控功能。 在特定情况下，当客户端发生异常时，服务器端管理控制台将收到报警信息。其中部分监控功能在客户机开关机状态下都有效。

在以下情况下，服务器端都会收到报警信息：

- 机箱被入侵（需要预安装传感器的特定机箱支持）

- USB设备移除 （需要英特尔®台式机主板D915PDT支持，支持严格使用USB2.0标准的设备）

- 客户机网络连接或电源连接丢失

- 资产变更（内存，硬盘等)

- 客户机操作系统异常或处理器异常

- 服务器端和客户端的英保通软件版本不一致

注意：

- 不同警报的产生时间根据具体情况略有不同

- 某些警报可由系统管理员进行单独启用或禁用

- 资产变更警报必须在客户机重启后才能产生


3.5.1 异常警报

报警信息分为3种：

§ 异常报警：

§ 资产报警： 关于资产报警，参见3.5.2节。

§ 其他报警： 关于其他报警，参见第二章、第8步。

在此节中，我们只对异常警报进行说明。

如果管理员在“服务器设置”页面中启用了报警功能，如图：

当客户机的系统出现异常时，服务器会就收到报警信息，一些报警信息还会同时播放报警语音。

目前英保通软件支持的异常警报信息包括以下5种：

编号 | 报警信息 | 报警原因与报警条件 | 客户机是否需开机 | 声音 报警 | 最大延时 （秒）
1 | 客户机连接丢失 | § 报警原因：客户机与服务器之间的连接不存在。如网线松动或被拔、交换机未开启。 § 报警语音：客户机连接丢失 | 否 | 有 | 60
2 | 操作系统异常 | § 报警原因：操作系统异常，如客户机系统崩溃，出现蓝屏现象。 § 报警语音：系统异常警报 | 是 | 有 | 5
3 | USB设备移除 | § 报警原因：USB设备被移除。 § 报警语音：系统异常警报。 § 报警条件：需要英特尔® 台式机主板D915PDT支持，支持严格使用USB2.0标准的设备。 | 否 | 有 | 5
4 | 处理器异常 | § 报警原因：CPU出现非正常工作情况，如CPU风扇运转不正常。 § 报警语音：系统异常警报 | 否 | 有 | 5
5 | 机箱入侵 | § 报警原因：机箱被打开。 § 报警语音：系统异常警报 § 报警条件：需要预安装传感器的特定机箱支持。 | 否 | 有 | 5

下图给出了客户机出现异常报警时的界面：

点击“确认”可以将对应的报警从列表中删除，点击“确认所有事件”可将所有报警从列表中删除。

当系统出现报警时，在“已托管客户机”页面中对应的客户机“报警”栏内会出现 [image] 提示，用户可看到有哪些客户机发出报警信息。


3.5.2资产变更

资产警报图标如下：

硬件信息变更

当服务器端监测到某台客户机本次启动时的硬件信息与上次启动不一致时，系统会在“资产变更”页面中列出资产变更信息并发出报警。可产生资产变更信息的硬件包括CPU，主板，内存，硬盘等。

编号 | 报警信息 | 报警原因与报警条件 | 客户机是否需开机 | 声音 报警 | 最大延时 （秒）
1 | 资产变更 | § 报警原因：客户机本次启动时的硬件信息与上次启动不一致。 § 报警语音：防盗警报 § 报警条件： 1. 只有内存，硬盘的变更才会产生报警。 2. 在资产变更后，只有当客户机系统重新启动后才会产生报警。 | 是 | 有 | 3

软件版本不符

此外，如果系统在网络中探测到英保通软件固件端版本或客户端版本与英保通软件服务器端版本不符时，也会产生资产警报。报警信息包括：

编号 | 报警信息 | 报警原因与报警条件 | 客户机是否需开机 | 声音 报警 | 最大延时 （秒）
1 | 在网络中探测到旧版本的英保通(R)固件端 | § 报警原因：在局域网中探测到客户机安装的英保通软件固件端为旧版本。 § 报警条件：旧版本是指重大的版本改变。如：服务器端版本为1.1， 而固件端版本为1.0，系统会产生报警。但如果服务器端版本为1.1.0.198， 而固件端版本为1.1.0.100，二个版本同属版本1.1系列，系统不会产生报警 | 是 | 无 | 3
2 | 在网络中探测到旧版本的英保通(R)客户端 | § 报警原因：在局域网中探测到客户机安装的英保通软件客户端应用程序为旧版本。 § 报警条件：旧版本是指重大的版本改变。如：服务器端版本为1.1， 而客户端版本为1.0，系统会产生报警。但如果服务器端版本为1.1.0.198， 而客户端版本为1.1.0.100，二个版本同属版本1.1系列，系统不会产生报警。 | 是 | 无 | 3

资产变更页面包括以下信息：

-        最后变更时间 最后一次硬件变更的发生时间

-        位置 客户机在BIOS界面设置的位置信息

-        客户机IP 客户机被分配到的IP地址

-        最后硬件变更 最后产生变更的硬件名称和变更状态（新增或删除）

-        状态 该硬件变更信息的确认状态

-        历史详细 点击进入可查看详细的历史硬件信息

点击“位置”栏内的位置信息可查看该客户机的系统信息、硬件信息和硬盘管理信息。

点击“状态”栏内的“确认”可确认该资产变更信息，点击页面右上方的“确认所有改变”可同时确认所有的资产变更信息。

点击“历史详细”栏内的“详细”可看到详细历史变更信息，如下图：


3.5.3 任务日志

“任务日志”页面列出了所有的任务执行情况，包括成功任务和失败任务。

任务日志页面包括以下信息：

- 日志时间 | 任务的发生时间
- 位置 | 客户机在BIOS界面设置的位置信息
- 客户机IP | 客户机被分配到的IP地址
- 任务信息 | 任务的执行方式（执行任务、查询）和任务名称
- 状态 | 任务执行状态，包括成功和失败。对于失败任务，系统会列出错误代码

系统默认将只显示失败任务日志，用户也可在右上方的下拉框中选择“显示所有任务日志”以显示所有任务。

常见错误代码

错误代码 | 代码含义 | 说明
0x00000000 | 任务成功 | 表示任务已成功完成。
0x80000002 | 无效参数 | 常见原因： 1. 当前磁盘状态已经不是有效状态。如：有些命令发出后要求重启某项服务或重启系统才能生效，但这些要求没有被马上实现，在命令生效前用户又作出其他的操作改变了硬盘状态，从而导致服务器端发出命令时的磁盘状态和执行命令时的磁盘状态已经不再匹配。 2. 客户机的本地命令尚未执行完毕，但服务器端又发出了一些命令。由于客户机在执行命令时会将本地命令的优先级设为最高，在此情况下，如果服务器端发出命令，这些命令会被返回并在服务器端控制台报错。 3. 用户在操作过程中没有按照要求的步骤进行。
0x8000000E | 设备未找到 | 常见原因： 1. 设备连接错误。如：因为连接错误而未能发现硬盘或其他设备。 2. 硬盘已恢复到以前的磁盘状态。这一情况大多出现在母机器的操作过程中。 3. 如果不是母机器，则很有可能表示这台客户机无法找到正确的路径回到指定的磁盘状态，导致增量包部署或者其他工作无法进行。原因可能是以前的创建还原点过程中出现过错误。
0x80000016 | 网络错误 | 常见原因： 1. 网络数据包传输错误。原因可能多种，通常为网络不通、主机不可达、路由不可用等网络本身原因。
0x80000017 | 文件传输错误 | 常见原因： 1. 文件传输服务器路径设置不对。 2. 文件传输服务器路径下的镜像文件或安装包文件已被修改或删除。 3. 文件传输服务器路径所在的硬盘空间不足。如：当用户在进行创建镜像等操作时，由于所创建的镜像文件会被放在指定的文件传输路径下，如果硬盘上没有足够的空间存放这一文件，系统也会报错。


第四章、辅助管理工具的使用

英保通软件辅助管理工具包括四大功能：

-        备份/恢复全部数据（包括服务器验证码）

-        导入/导出服务器验证码

-        导入/导出磁盘镜像与升级安装包信息

-        管理固件端升级文件

单击[开始] à [所有程序] à [英特尔®英保通™ 软件] à [服务器端网吧版1.1] à [辅助管理工具]，即可启动辅助管理工具界面。


4.3备份恢复服务器数据与设置

4.1 备份/恢复服务器全部数据

当服务器需要进行备份或恢复到原先的某个备份状态时，以及实现服务器之间的迁移时，可使用备份/恢复服务器数据功能实现这一目的。


4.3.1备份服务器数据与设置

4.1.1 备份服务器全部数据

当用户需要备份服务器数据时，选择“备份服务器全部数据”，点击“下一步”继续。

指定数据备份的存储目录后（建议用户新创建一个文件夹），点击“下一步”继续。

系统将开始备份服务器数据，如图所示。用户请耐心等待。

系统将提示操作成功，如下图所示。

点击“完成”将回到“英特尔® 英保通™软件辅助管理工具”首页。

[注意]

数据备份成功后将在指定的目录下备份数据。为方便管理，请建立一个文件夹专门用于存放备份数据，建议可用日期作为文件夹名，该备份数据只能用于同版本的服务器端。


4.3.2恢复服务器数据与设置

4.1.2 恢复服务器全部数据

在服务器数据遭到破坏或因其他原因需要恢复时，选择“恢复服务器全部数据”，点击“下一步”继续。

用户需要指定包含备份文件的目录。点击“下一步”继续。

因为本操作将重启所有相关服务，可能会对正在执行的任务产生影响。系统将会有如下提示：

点击“是”确认。系统将开始根据先前备份的文件恢复服务器的数据。

系统将自动重启”启动服务”与”管理服务”以使设置生效。

系统将提示操作成功，如下图所示。

点击“完成”将回到“英特尔® 英保通™软件辅助管理工具”首页。


4.2 导入/导出服务器验证码

当服务器升级、重装或更换后，为了让更新后的服务器仍能管理原先绑定的客户机，可使用服务器验证码导入/导出功能来实现这一目的。

在英保通软件系统中，客户机的初次注册过程中会完成与服务器的绑定，客户机得到唯一的服务器验证码，服务器得到客户机的MAC地址。以后的通信过程中，从服务器端发出的消息都会带有服务器验证码信息用于认证，反之，从客户端发出的消息都会带有客户端MAC地址用于认证。因此，被绑定的客户机只能接受与之绑定的服务器的管理，而无法注册到其他服务器。

而“导入/导出服务器验证码”功能可恢复服务器对原先绑定的客户机的管理。


4.2.1 导出服务器验证码

首先将旧的服务器验证码导出。选择“导出系统验证码”，点击“下一步”继续。

点击“请指定文件”栏旁的按钮，选择导出服务器验证码的存放路径并对服务器验证码进行命名。点击“保存”，该服务器验证码将被存放在指定的目录下，文件格式为.svk。

点击“下一步”继续。

因为本操作将重启所有相关服务，可能会对正在执行的任务产生影响。系统将会有如下提示：

点击“是”确认。系统将开始导出服务器验证码。

系统将提示操作成功，如下图所示。

点击“完成”将回到“英特尔® 英保通™软件辅助管理工具”首页。


4.2.2 导入服务器验证码

当服务器更新完成后，将服务器验证码导入。选择“导入系统验证码”，点击“下一步”继续。

点击“请指定文件”栏旁的按钮，选择希望导入的服务器验证码文件，点击“打开”。

点击“下一步”继续。

因为本操作将重启所有相关服务，可能会对正在执行的任务产生影响。系统将会有如下提示：

点击“是”确认。系统将开始导入服务器验证码。

请确保任务开始前退出所有正在使用SQL Server的其他程序，否则可能出现错误。

系统将自动重启”启动服务”与”管理服务”以使设置生效。

系统将提示操作成功，如下图所示。

点击“完成”将回到“英特尔® 英保通™软件辅助管理工具”首页。


4.3 导入/导出磁盘镜像与升级安装包信息

当服务器升级、重装或更换后，为了让更新后的服务器仍能管理已创建的磁盘镜像和升级安装包，可使用磁盘镜像和升级安装包信息导入/导出功能来实现这一目的。

该信息文件仅为磁盘镜像与升级安装包的各种信息，如名称、创建日期、文件大小、创建源等。在实际使用过程中，用户还需将已创建的磁盘镜像与升级安装包拷贝到文件传输目录下。


4.3.1 导出磁盘镜像与升级安装包信息

首先将已创建的磁盘镜像与升级安装包文件信息导出。选择“导出磁盘镜像与升级安装包信息”，点击“下一步”继续。

点击“请指定文件夹”栏旁的按钮，选择导出磁盘镜像与升级安装包信息的存放路径。点击“保存”，该信息文件将被存放在指定的目录下。

点击“下一步”继续。

点击“是”确认。系统将开始导出磁盘镜像与升级安装包信息。

系统将提示操作成功，如下图所示。

点击“完成”将回到“英特尔® 英保通™软件辅助管理工具”首页。


4.3.2 导入磁盘镜像与升级安装包信息

当服务器更新完成后，将磁盘镜像与升级安装包信息导入。选择“导入磁盘镜像与升级安装包信息”，点击“下一步”继续。

点击“请指定文件夹”栏旁的按钮，选择希望导入的磁盘镜像与升级安装包信息文件，点击“打开”。

点击“下一步”继续。

点击“下一步”。系统将开始导入磁盘镜像与升级安装包信息。

请确保将导入的数据库中不存在于备份数据中同名的磁盘镜像文件和升级安装包文件。

系统将提示操作成功，如下图所示。

点击“完成”将回到“英特尔® 英保通™软件辅助管理工具”首页。

[注意]

完成本操作后请将相关磁盘镜像文件及升级安装包文件拷至文件传输目录，以使本操作生效。


4.1管理固件端升级文件

4.4 管理固件端升级文件

这一功能可帮助用户对固件端的升级文件进行管理。

用户如果没有最新升级文件，可点击页面上的链接进行下载。

如果用户已下载升级文件，点击“下一步”继续。

在“升级文件列表”中，用户可以对升级文件进行添加、删除和浏览。


4.1.1添加

4.4.1 添加

用户可从浏览现有的列表以察看该升级文件是否已在现有列表中。

如果没有，用户可点击“添加”按钮，出现以下窗口。

选择升级文件，点击“打开”。

选中的升级文件被列入“升级文件列表”中。

升级文件列表中的“备注”栏是可编辑的，用户可在此栏中输入备注信息。


4.1.2删除

4.4.2 删除

如果用户希望删除旧的升级文件，可从“升级文件列表”中选择希望删除的文件，点击“删除”按钮进行删除。

[提示]

在使用过程中：

1. 用户不可直接用“Delete”键进行删除。

2. 用户可使用Ctrl 或Shift键进行多选。

在添加升级文件后，点击“下一步”继续。系统将出现确认修改的提示

点击“是”确认，系统将提示操作成功，如下图所示。

点击“完成”将回到“英特尔® 英保通™软件辅助管理工具”首页。


第五章、客户机固件端升级工具的使用

本章介绍英保通软件客户机固件端升级工具的使用。

升级工具专为将客户机固件端从版本1.0升级到更高版本的情形而设计。在用户对固件端更新前，需要先使用这一升级工具导入升级文件。

单击[开始] à [所有程序] à [英特尔®英保通™ 软件] à [服务器端网吧版1.1] à [客户机固件端升级工具]，即可启动固件端升级工具界面。

客户机固件端升级文件的配置可通过二种方式进行：自动配置升级文件和从指定位置配置升级文件。在进行以下步骤前请确保：

1. 服务器端的DHCP服务已打开。

2. 待升级客户机上的英保通软件客户端已卸载。


5.1 自动配置升级文件

在通常情况下，用户只需选用自动配置方式，系统会自动搜索升级文件，选择服务器IP地址和“自动配置升级文件”，点击“确定”。如果客户机存在多个网段，应分别选择对应客户机网段的服务器IP地址以进行正确的升级。

请确认已启动DHCP服务，然后点击“确定”。

系统将出现提示，提示用户在升级客户机时需先卸载客户端。点击“是”继续。

系统将自动配置固件端升级文件，操作完成。


5.2从指定位置配置升级文件

5.2 指定配置升级文件

但在某些情况下，固件端升级文件已被篡改或破坏，用户可以重新拷贝正确的固件端升级文件到服务器的用户指定路径下，然后在“英特尔®英保通™软件1.0至1.1版本升级工具”页面中选择“从指定位置配置升级文件”。

点击空白路径栏旁的图标，选择存放正确固件端升级文件的路径，点击“打开”。

指定文件路径将出现在地址栏内。点击“确定”。

请确认已启动DHCP服务，然后点击“确定”。

系统将出现提示，提示用户在升级客户机时需先卸载客户端。点击“是”继续。

系统将自动配置固件端升级文件，操作完成。

[提示] 由于系统采用的是静态地址，在配置完升级文件进行母机器的更新后，部署镜像给其他客户机前，请关闭DHCP服务，否则可能出现错误。


第六章、客户端的使用

英特尔®英保通™软件客户端运行在客户机操作系统之上，主要提供硬盘保护功能。

硬盘保护软件可以保护硬盘上的数据免受破坏，不管是系统数据或者是用户的数据都可以得到保护。在安装有硬盘保护的机器上，每次重启后硬盘上被保护的扇区都将恢复到上次保存过的状态，因此，机器重启后所有上次的操作都将丢失。这特别适合网吧，多媒体教室等环境，可以极大的减轻系统管理员们的工作负担。当然，用户也可在本软件中通过设置“还原点”来保存本次的所有操作和数据，用户还可以选择将硬盘还原到某个“还原点”上，同样，用户也可以删除还原点，但要注意的是，在删除某个还原点时，该还原点以后的所有还原点也将同时被删除。

英保通软件客户端（专业版1.1）的硬盘保护软件的功能包括：

§ 启动/停止硬盘保护功能

§ 查看磁盘剩余空间

§ 执行各种硬盘保护操作命令，包括：

- 创建新的还原点

- 恢复到最近的还原点

- 恢复到过去指定的还原点

- 数据转存

- 参数设置

§ 查看硬盘保护软件版本信息

§ 退出硬盘保护软件

安装完硬盘保护软件，并重新启动操作系统后，硬盘保护软件将自动运行，并在系统托盘区显示英特尔®英保通™软件客户端图标[ [image] ]，在图标上单击右键，会弹出如下菜单：


6.1 启动/停止硬盘保护功能

在完成客户端硬盘保护软件的安装后，默认状态为硬盘保护功能已启动。


6.1.1 停止硬盘保护功能

如需停止硬盘保护功能，点击“启动硬盘保护功能”，确保该项未选中，在弹出的窗口内输入先前设定的硬盘保护密码。

系统将弹出以下提示框，单击“是”继续。

系统将自动重启并停止硬盘保护功能。屏幕右下角的硬盘保护软件图标从[ [image] ] 变为[ [image] ]。


6.1.2 重新启动硬盘保护功能

在硬盘保护功能被停止后，如需重新启动硬盘保护功能。点击“启动硬盘保护功能”，确保该项被选中。

在弹出的窗口内输入先前设定的硬盘保护密码。

系统将弹出以下提示框，单击“是”继续。

重新为硬盘保护软件设置密码，单击“确定”继续。

单击“是”以重新启动计算机使设置生效。

系统重启后将启动硬盘保护功能。屏幕右下角的硬盘保护软件图标从[ [image] ] 恢复为 [ [image] ] 。


6.2 查看硬盘剩余空间

在硬盘保护软件的菜单上点击“硬盘剩余空间”可查看客户端被保护硬盘分区的使用情况。包括被保护的磁盘分区、磁盘号、剩余空间、剩余空间与总空间的百分比。

上图显示所保护的是C盘，其剩余空间是63％，还剩下7667MB空间。

[注意]

1. 硬盘保护只支持一个物理硬盘。

2. 硬盘保护不支持同一客户机内安装多个操作系统。

3. 启用硬盘保护功能后，用户不能更改分区信息，如创建新分区等，以及格式化某个分区。


6.3命令

在硬盘保护软件的菜单上点击“命令”可执行各种硬盘保护操作命令，包括：

-        创建新的还原点

-        恢复到最近的还原点

-        恢复到过去指定的还原点

-        数据转存

-        参数设置

系统将弹出如下密码输入框提示用户输入密码，以确保只有系统管理员才能进行操作。

当输入密码后，系统将会进行认证，当用户密码得到认证后，系统会弹出“开始”管理命令对话框。


6.3.1创建新的原点

在“开始”窗口内选择“创建新的还原点”，单击“下一步”继续。

“创建新的还原点”命令将对当前硬盘的状态创建一个新的还原点，本次在操作系统中所作的更改都将被记录在这个还原点中，同时可以为新创建的还原点指定一个名字用于标识该还原点。如果操作系统被非正常关闭（例如系统掉电），则该操作不能成功执行，本次在操作系统中作的操作会被还原

[注意]

1. 在一台机器上最多能保持32个还原点。

2. 还原点名称长度应为1-31个字符，可使用的字符为英文字母和数字。

输入您希望的新的还原点的名字，单击“下一步”继续。

查看系统显示的任务是否正确，选择“马上重启”并单击“完成”，系统将立即重启并创建用户命名的新还原点。

若不选择“马上重启”，系统将在下一次重启时创建新的还原点。


6.3.2 恢复到最近的还原点

在“开始”窗口内选择“恢复到最近的还原点”，单击“下一步”继续。

此命令将使当前的硬盘状态恢复到最近一次还原点，此种情况下，当前所有对硬盘所写的数据都将会丢失。

选择“马上重启”并单击“完成”，系统将立即重启并恢复到最近的还原点。

若不选择“马上重启”，系统将在下一次重启时恢复到最近的还原点。


6.3.3 恢复到过去指定的还原点

“恢复到过去指定的还原点”命令会使系统还原到指定的还原点。

在“开始”窗口内选择“恢复到过去指定的还原点”，单击“下一步”继续。

从系统的还原点列表中选择您希望恢复到的还原点，单击“下一步”继续。

查看系统显示的任务是否正确，选择“马上重启”并单击“完成”，系统将立即重启并恢复到指定的还原点。

若不选择“马上重启”，系统将在下一次重启时恢复到指定的还原点。

执行该操作后，在这个还原点之后的还原点将被清除。


6.3.4 数据转存

在“开始”窗口内选择“数据转存”，单击“下一步”继续。

“数据转存”命令将永久保存当前的硬盘状态，本次在操作系统中所作的更改都将被记录下来。在此种情况下，以前所创建的还原点都将被删除，系统将从目前的硬盘状态开始创建随后的还原点：

系统将提示“以前所有的还原点将被删除，该操作将导致增量部署无法正常进行”。选择“马上重启”并单击“完成”，系统将立即重启并永久保存所作操作，同时创建一个新的初始还原点。

若不选择“马上重启”，系统将在下一次重启时进行数据转存。

[注意]

如果在设置各项命令使后不选择“马上重启”。 在完成设置后的各项操作会被记录下来，命令将从系统重启时才开始实际执行。

[警告]

1. 选择创建还原点或永久保存数据将记录下所有对磁盘的更改，请确保这些更改不会对操作系统造成伤害。

2. 磁盘保护不支持对分区格式或大小的变更。如果用户对分区格式或大小进行了改动，这些改动有一部分不能执行，剩余部分将在下次重启后被恢复。但如果用户在作了这些改动后选择创建还原点或永久保存数据，则可能使系统工作不正常。

3. 在安装磁盘保护之后，受保护的分区中将有一部分空间被标记为坏磁道，请不要试图去修复这些磁道，否则可能使系统工作不正常。在卸载磁盘保护之后，这些坏磁道将自动恢复。


6.3.5 参数设置

在“开始”窗口内选择“参数设置”，单击“下一步”继续。

用户可通过“参数设置”设置硬盘剩余空间提示，也可在此修改硬盘保护软件的密码。

硬盘剩余空间提示

更改“硬盘剩余空间提示”值将会使系统在剩余磁盘空间不足所指定的百分比时提示用户。英保通软件客户端硬盘保护默认值为当硬盘剩余空间不到1%时，系统会进行提示。

用户可通过 [image] [image] 自行设定硬盘剩余空间的百分比。设定后，当硬盘剩余空间不足时，系统会弹出以下提示窗口：

用户应在得到系统提示后对硬盘内的冗余文件进行整理删除或重启系统，否则系统可能崩溃。

更改密码

单击“更改密码”按钮，输入原密码和新密码，单击“确定”。可对硬盘保护功能的密码进行更改。


6.4 查看版本信息

在客户端软件的菜单上点击“关于”可查看英保通软件客户端的版本信息。


6.5 退出硬盘保护程序

在客户端软件的菜单上点击“退出硬盘保护程序”，客户端软件图标将从屏幕右下角消失。该操作的结果仅为退出用户使用界面，并未退出保护功能，客户端硬盘仍处于受保护的状态。


第七章、固件端的使用

英保通软件固件端与英保通软件客户端配合使用，实现在客户端的各种操作。在安装英保通软件客户端之前，应先启用英保通软件固件端。在默认的BIOS出厂设置，英保通软件固件端是未被启用的。


7.1固件端的管理

英保通软件固件端的管理包括固件端的启用和禁止等功能。


7.1.1启用固件端

参见第二章、第5步。


7.1.2 禁用固件端

重新启动客户机，按F2进入BIOS，在“Manageability”配置界面中，选择“Agent”选项，按下Enter键，在弹出框内选择“Disable”，再次按下Enter键选定。

按F10保存当前设置并退出，客户机将自动重启。

[警告]

在禁用英保通软件固件端之前，请确保英保通软件客户端已被卸载。否则可能导致英保通软件客户端工作不正常。


7.2 释放绑定

当与客户机绑定的服务器不可用时（如系统崩溃，机器丢失等），可在固件端将原绑定释放。单击F2进入BIOS设置，在“Manageability”页中选择“Bound to server”， 按下Enter键，在弹出框内选择“NO”，再次按下Enter键选定。.

按F10保存当前设置并退出，客户机将自动重启。

机器重启之后，客户机会注册到其他服务器并与之建立绑定。如果“Manageability”页的“Bound to server”选项为“NO”且不可操作，表明此客户机未与任何服务器建立绑定。


7.3 输入位置信息

参见第二章、第6步 。


7.4 配置IP地址

参见第二章、第6步 。


7.5 硬盘保护功能

固件端的硬盘保护功能对应于客户端的硬盘保护功能，包括恢复到还原点、卸载硬盘保护功能等功能。


7.5.1 恢复到还原点

请选择<Recover to Checkpoint>选项按下Enter键，在弹出的还原点列表中选择还原点，再次按下Enter键选定。.

按F10保存当前设置并退出，客户机将自动重启，并执行“恢复到还原点”命令。


7.5.2 禁用硬盘保护功能

请选择“Disable Disk Protection”，按下Enter键，选择<Yes>选项，再次按下Enter键选定。

按F10保存当前设置并退出，客户机将自动重启。此后系统将不再受硬盘保护，但硬盘保护的软件组件依然存在，只是从功能上不起作用。

[警告]

在正常状况下，应该通过在操作系统中英保通软件客户端来禁用硬盘保护和恢复到某个还原点。该功能仅用于当操作系统已被破坏、需要重装操作系统以前，或用于遗失硬盘保护的密码、需要用非常手段急救之时。


第八章、安装、卸载和升级


8.1安装英特尔(R)英保通(TM)软件

8.1 安装英特尔®英保通™软件


8.1.1 安装服务器端

具体步骤 参见第二章、第3步。


8.1.2 启用固件端

具体步骤 参见第二章、第5步。


8.1.3 安装客户端

具体步骤 参见第二章、第7步。


8.1.4 注册

请访问英特尔®英保通™ 软件支持网站http://www.intel.com/platformadmintech/cn 注册英特尔®英保通™ 软件。


8.2卸载英特尔(R)英保(TM)软件

8.2 卸载英特尔®英保通™软件


8.2.1 卸载服务器端

选择[控制面板] à [添加或删除程序] à 删除“英特尔®英保通™软件服务器端 (网吧专业版1.1)”。

选择“是”继续。系统开始删除英保通软件服务器端。

删除完毕后，用户可选择立即重启生效，或以后以人工方式重启。


8.2.2 卸载客户端

1）禁用客户端。

在卸载英保通软件客户端前，需要先禁用客户端。

在Windows右下角硬盘保护程序的图标 [image] 上单击右键，将弹出以下窗口，单击“启动硬盘保护功能”以禁用客户端。

输入最后设定的硬盘保护密码。

系统将出现以下提示：

单击“是”，客户机将立即重启，启动后客户端硬盘保护程序将被禁用。

2）卸载客户端。

禁用客户端硬盘保护程序后，就可以进行客户端软件的删除。

选择[控制面板] à [添加或删除程序] à 删除“英特尔®英保通™软件客户端（专业版1.1）”。

系统将提示确认删除程序，选择“是”继续。

系统要求输入密码。输入硬盘保护密码并单击“确定”按钮。

系统将提示是否立即重启，点击“确定”继续。

系统将会完成卸载。下次系统启动后所有以前保护的硬盘将不再受保护。


8.3升级英特尔(R)英保通(TM)软件

8.3 升级英特尔®英保通™软件


8.3.1 升级服务器端

1） 导出服务器验证码。

具体步骤 参见4.2.1节。

2） 删除旧版本的英保通软件服务器端。

具体步骤 参见8.2.1节。

3）安装新版本的英保通软件服务器端。

具体步骤 参见第二章、第3步。

4）导入服务器验证码。

具体步骤 参见4.2.2节。

[注意]

在删除英保通软件服务器端前，用户需要首先导出服务器验证码。在安装完新版本的服务器端后，再导入这一服务器验证码。如果不执行这一操作，原有的客户机将不能注册到安装了新版本的服务器。用户需要在每台客户机的BIOS设置页面对原有的IP地址绑定进行释放才能使原有的客户机重新注册。


8.3.2 升级客户端

1） 卸载旧版本的英保通软件客户端。

具体步骤 参见8.2.2节。

2）安装新版本的英保通软件客户端。

具体步骤 参见第二章、第7步。


8.3.3 升级固件端

本节所述针对将版本1.1升级到更高版本的情形。

如果用户希望将版本1.0升级到版本1.1， 参见9.9节。

升级英保通软件固件端可通过2种方法实现：

方法1、远程升级：在服务器端，通过 “更新客户机固件端/BIOS”功能进行升级。

方法2、本地升级：在客户端，通过本地执行IntelPATAgent.exe升级。

方法1为推荐方法，方法一可同时选中多台客户机进行部署，更新速度快。

方法2需要到每台客户机上进行重复操作，可用于更新少量客户机固件端的个别情形。


8.3.3.1 使用远程升级

具体步骤 参见 3.2.2.6节 。


8.3.3.2 使用本地升级

由于不同的主板型号所对应的升级文件也不同，用户在进行固件端升级前需要确定客户机的主板型号以选择正确的固件端升级文件。

关于如何确定主板型号并选择正确的升级文件，参见3.2.2.6节。

操作系统状态下，在客户端双击IntelPATAgent.exe文件。将出现以下界面：

单击“Next”继续。

单击“Yes”继续。

单击“Finish”结束操作系统状态下的固件端更新，客户机将自动重启并将英保通软件固件端烧入BIOS的Flash ROM中。

[注意]

在通过本地升级方式更新客户机固件端前，请以具备管理员权限的帐号登录，否则更新过程可能出错。


第九章、常见应用实例

以下给出了英保通软件在实际应用中的常见应用案例。


9.1 我要安装新系统并创建新镜像…

我要用英保通软件来生成一个全新的客户机系统，并想制作镜像，怎么办？


9.1.1 使用现有的客户机

1. 选择母机器

2. 在母机器上，卸除旧版本的英保通软件客户端

3. 在母机器上，安装操作系统和应用程序

- 尽可能用FAT32格式

4. 在母机器上，安装新版本的英保通软件客户端

5. 在服务器上，使用“生成磁盘镜像”功能来制作新镜像

6. 在服务器上，将镜像部署给其他客户机


9.1.2 使用新的客户机

1. 在所有客户机上，启用英保通软件固件端

2. 在所有客户机上，设置IP地址分配

3. 在母机器上，安装操作系统和应用程序

- 尽可能用FAT32格式

4. 在母机器上，安装英保通软件客户端

5. 在服务器上，将客户端注册到服务器

6. 在服务器上，使用“生成磁盘镜像”功能来制作新镜像

7. 在服务器上，将镜像部署给其他客户机


9.2 我要部署新的客户机…

网吧购置了新的英保通客户机，怎么办？

1. 在新客户机上，启用英保通软件固件端

2. 在新客户机上，设置IP地址分配

3. 在服务器上，将新客户端注册到服务器

4. 在服务器上，更新新客户机的固件端和BIOS

5. 在服务器上，为新英保通客户机部署磁盘镜像


9.3 我要修复现有的客户机…

英保通软件客户端提供了磁盘保护功能，但一旦由于操作不慎，使得系统损坏，怎么修复？


9.3.1 采用远程恢复功能

1. 在服务器上，选中要修复的客户机

2. 在服务器上，选择“恢复”下拉菜单

3. 在服务器上，点击“执行”按钮

4. 服务器将自动根据该客户机上部署历史（镜像/安装包等）对客户机进行重新部署


9.3.2采用重新部署

1. 在服务器上，选中要修复的客户机

2. 在服务器上，选择“部署磁盘镜像”下拉菜单

3. 在服务器上，选中镜像

4. 在服务器上，点击“执行”按钮


9.4 我要替换损坏的客户机…

我的某台客户机有硬件损坏，现在替换了硬件，怎么办？


9.4.1 替换硬盘

请参见 9.3节 。


9.4.2 替换主板

1. 在服务器上，在客户机列表里删除被替换的旧客户机

2. 在客户机上，重新设置IP地址分配

3. 在服务器上，将客户端重新注册到服务器

4. 在服务器上，让客户机执行本地启动到操作系统


9.4.3 替换其他硬件

无需任何修改


9.5 我要安装新软件/删除旧软件/升级游戏…

我要安装新软件/删除旧软件/升级游戏，怎么办？

1. 选择/设置母机器

- 不用创建还原点

- 不要重启母机器

2. 在母机器上，安装新软件/删除旧软件/升级游戏

3. 在服务器上，使用“生成安装包”功能来制作新的安装包

4. 在服务器上，将安装包部署给其他客户机

[提示]

安装包部署没有采用组播协议，因此在大规模部署时会有网络瓶颈。根据经验，50台一次的安装包部署性能最优。


9.6 我要升级服务器端…

我要升级英保通软件服务器端，怎么办？

1. 在服务器上，使用辅助管理工具导出服务器验证码

2. 在服务器上，使用辅助管理工具导出（备份）磁盘镜像/安装包信息

3. 在服务器上，卸载旧版本的英保通软件服务器端

4. 在服务器上，安装新版本的英保通软件服务器端

5. 在服务器上，使用辅助管理工具导入服务器验证码

6. 在服务器上，使用辅助管理工具导入磁盘镜像/安装包信息


9.7我要升级客户端…

9.7 我要升级软件客户端…

我要升级英保通软件客户端，怎么办？

1. 在母机器上，卸载旧版本的英保通软件客户端

2. 在母机器上，安装新版本的英保通软件客户端

3. 在服务器上，需要从母机器重新创建磁盘镜像并部署给所有客户机

请参见9.1节。


9.8 我要升级固件端…

我要升级英保通固件端，怎么办？


9.8.1 使用本地升级

1. 在客户机上，进入BIOS确定客户机主板型号以选择正确的固件端升级文件。

2. 在客户机上，双击执行固件端升级文件 IntelPATagent.exe即可


9.8.2 使用远程升级

1. 选择母机器

2. 在母机器上，将固件端升级程序复制到母机

3. 在母机器上，双击执行固件端升级程序IntelPATagent.exe

4. 在服务器上，生成新的安装包

5. 在服务器上，将新的安装包部署到其他客户机


9.9 我要升级系统从版本1.0到版本1.1

我要在已安装版本为1.0（指固件端、客户端、服务器端的版本都为1.0）的英保通系统的网吧环境内将英保通系统升级到版本1.1（包括固件端、客户端、服务器端）。

共分6个步骤：

1. 在服务器端，卸载版本1.0的英保通软件服务器端，安装版本1.1的英保通软件服务器端。

2. 在所有客户机上，，启用报警功能。步骤如下：

1) 按下F2键进入BIOS设置界面。

2) 在Power页面的 “Wake on LAN from S5”选项中，选择 “Power on”。

3) 在Power页面的 “ACPI Suspend State”选项中，选择 “S3 State”。

4) 按下F10键选择保存并退出。

3. 在母机器上，卸载版本1.0的英保通软件客户端。

4. 在所有客户机上，升级版本1.0的固件端到版本1.1。用户可从以下二种方法选择一种进行升级。

方法1、通过Boot to EFI PXE方式升级

通过Boot to EFI PXE方式升级，需要先配置固件端更新文件。

在服务器端，配置固件端更新文件。用户可从以下二种方法选择一种进行配置。

方法A：人工配置

将固件端更新文件IntelPATagent.efi拷贝到指定的MTFTP目录下。

方法B：自动配置

使用升级工具导入最新的固件端更新文件，该工具将帮助把固件端更新文件IntelPATagent.efi拷贝到指定的MTFTP目录下。

完成升级文件配置后，请保证已启用DHCP服务器并正确配置“服务器选项”，参见第二章、第六步“自动分配IP地址”。

完成后，用户可通过PXE启动方式升级，步骤如下：

在每台客户机上，进入版本为1.0的BIOS设置界面：

1) 在 “Manageability”页面下，设置“Agent”为“Disable”。

2) 在 “Boot”页面下，设置“Boot to EFI PXE”为“Enable”。

3) 按F10保存并退出。

客户机将通过PXE启动方式，下载最新的英保通软件固件端更新文件，并烧入BIOS的Flash ROM中。

方法2、通过IntelPATAgent.exe升级

在每台客户机上，将固件端更新文件（IntelPATagent.exe）拷贝到某个目录下，并逐一进行本地执行。

固件端更新到版本1.1后，客户机将注册到版本1.1的服务器端等待接受。

5. 选择母机器，安装版本1.1的英保通软件客户端。

6. 生成母机器镜像并将镜像部署到其他客户机。

[注意]

1. 在更新母机器固件端前，必须按照第3步所述先卸载母机器上的英保通软件客户端，否则在完成第4步固件端更新后，母机器将无法进入操作系统。

2. 其他客户机在更新固件端前，不必逐一卸载英保通软件客户端，可在完成第4步固件端更新后，通过第5、6步中生成和部署母机器镜像的方式来实现正常运行。


9.10 我要升级系统从版本1.1到最新版本

我要在已安装版本为1.1.0.168或1.1.0.198（指固件端、客户端、服务器端的版本都为同一版本）的英特尔®英保通™软件的网吧环境内将系统升级到最新版本（包括固件端、客户端、服务器端）。

如果用户先前已安装某个版本为1.1.0.168或1.1.0.198的英特尔®英保通™软件，则无须卸载旧版本，用户可直接执行升级程序，升级后系统将保留升级前的客户机信息和配置信息。

[注意]

仅适用于从版本1.1.0.168或1.1.0.198的英特尔®英保通™软件升级到最新版本的情形。

对于版本低于1.1.0.168的英特尔®英保通™软件，不可通过升级程序升级到最新版本。

升级后服务器端管理界面的客户机信息和配置信息都将保留。

升级到最新版本后，升级前用辅助管理工具导出的数据库备份将不可导入。

安装前准备：

1. 下载升级程序，包括服务器端、客户端升级程序和固件端升级文件。

2. 确认母机器上已安装了版本为1.1.0.168或1.1.0.198的英特尔®英保通™软件客户端，而且已生成镜像并已部署给所有客户机。

第一步、升级服务器端

1. 停止所有与英特尔®英保通™软件有关的任务，并关闭服务器端管理界面。

2. 双击服务器端升级程序setup.exe开始安装。选择要安装的语言并点击“确定”，进入安装向导，根据屏幕指示，点击“下一步”继续安装。

3. 点击“完成”并重启机器。

4. 服务器端升级已完成。重启后打开服务器端管理界面，用户可看到服务器端软件版本号已更新为最新版本号，之前的客户机信息和服务器配置信息都被保留。

第二步、升级客户端

1. 在母机器上，双击客户端升级程序setup.exe开始安装。选择要安装的语言并点击“确定”，进入安装向导，根据屏幕指示，点击“下一步”继续安装。

2. 点击“完成”结束安装。

[注意]

完成客户端升级程序后，请勿重启母机器。

3. 在母机器上，右键点击屏幕右下角的硬盘保护软件图标，在弹出菜单中选择“关于”，可看到客户端软件版本号已更改。

4. 在服务器端，用母机器创建升级安装包。

5. 在服务器端，将升级安装包部署到其它客户机。

6. 部署完毕后， 母机器和客户机的客户端软件都已升级完成，户可看到客户端软件版本号已更新为最新版本。

第三步、升级固件端

1. 在服务器端，通过辅助管理工具添加最新版本的固件端升级文件。

2. 在服务器端，通过服务器端管理界面对所有客户机固件端进行更新。


第十章、常见问题解答


10.1 安装与启动

 | 问题 | 可能的原因和解决方案
1 | 为什么在Windows 2003 Server上数据库已经安装，但是在安装的过程中会出现“SQL Server不存在或访问拒绝”的提示？ | 首先请检查数据库安装是否正确，MS SQL Server的服务是否已经正常启动。然后请检查网络连接是否正常，网线是否接触良好。如果网口的指示灯没有闪亮，很可能这就是网线连接的原因造成数据库不能正常连接。
2 | 为什么服务器端安装程序运行很久而停住没有反应？ | 在安装过程由于鼠标的点击改变了焦点，数据库配置的窗口很可能被主界面遮挡，试着移开主界面并查看数据库配置窗口是否在后面。
3 | 为什么我安装了DHCP服务器，系统还是不能正常运行？ | 请确保DHCP服务器配置完全正确而且服务已经正常启动，否则系统是不能正常工作的。关于DHCP 服务器配置，请参考相关文档。
4 | 客户端为什么装不上？ | 可能英保通软件固件端没有被启用，请重新启动客户机，按F2进入BIOS设置页面，具体可参照用户手册。
5 | 为什么客户机注册不上服务器？ | 多种问题都有可能造成客户机注册失败，您可以采取以下步骤来确定问题的原因： a. 服务器原因 1) 服务是否都已经启动。请您检查DHCP Service和Intel(R) Platform Administrator Server – Boot Management Service的工作情况。 2) 是否服务器在之前更改过IP。请在服务器更改IP后重启系统。 3) 如果网络采用动态IP，用户没有为服务器设置DHCP域，客户机不能分配到IP地址。 b. 客户机原因 1) 客户机是否已经集成了英保通技术。您需要到BIOS设置中启用英保通软件固件端，如果没有经历这一步骤，请先参考用户手册。 2) 客户机注册可能之前注册到其他服务器且没有释放绑定，请进入BIOS设置释放客户机与其他服务器的绑定。 3) 如果网络采用静态IP，用户在客户机BIOS 界面中没有手动为客户机输入IP，SUBNET MASK和GATEWAY。 c. 网络传输原因 1) 客户机和服务器的网线是否接触良好。如果网口的指示灯没有闪亮，很可能这就是网线连接的原因。 2) 客户机和服务器是否可以进行网络通讯。您可以分别在客户机和服务器上用ping命令来探测对方。 3) 重启客户机。有时候网络的突然中断或阻塞也会导致注册行为的失败。
6 | 在安装了英保通软件的机器上重新安装操作系统，安装过程无法正常进行，这是怎么回事？ | 请确保硬盘保护程序已经卸载。在BIOS启动过程中，进入BIOS设置页面，在 [Management] 界面卸载硬盘保护程序，并保存设置。系统重启后再进行新系统的安装。


10.2管理界面

问题

可能的原因和解决方案

1

我的管理窗口里怎么无法显示客户机的中文软件名？

这个问题可能是由于您的操作系统的当前语言设置无法支持中文显示而造成的。该问题经常出现在以下环境中：

1) 您的服务器运行在非中文版的操作系统上，同时没有安装中文语言支持包。

2) 您的服务器运行在非中文版的操作系统上，并且已经安装了中文语言支持包。

3) 您的客户端运行在非中文版的操作系统上，同时没有安装中文语言支持包。

4) 您的客户端运行在非中文版的操作系统上，并且已经安装了中文语言支持包。

您可以执行以下步骤来解决该问题：

1) 如果您的环境符合以上第一和第三种描述，请您在相应的操作系统上先安装中文语言支持包。

2) 将符合以上描述的相应的客户机或者服务器的默认区域设置成“China”。

Control Panel → Regional and Language Settings -> Regional Options

3) 将默认语言设置为“China(PRC)”。

Control Panel → Regional and Language Settings → Advanced

2

我的管理界面是英文的，想看中文界面，怎么办？

管理界面的显示语言是由您所使用的浏览器的默认语言决定的。如果您希望浏览中文版的界面，请将浏览器的默认语言设置成中文。以Microsoft Internet Explorer为例：

在IE中，选择“Tool(工具)”菜单→ “Internet Options(Internet选项)”。

选择“语言”，在“语言”中将中文设置在第一个位置。

3

客户机出现蓝屏怎么回事?

如果在操作系统正常运行过程中出现蓝屏，很可能是由于系统的硬盘空间或者内存不足造成，请注意蓝屏中的出错信息。用户只需重新启动机器，机器重新启动后会恢复到被保护的状态。

如果在操作系统启动过程中出现蓝屏，则是由于英保通软件固件端不存在（例如被禁用）而无法完成一些预定的操作所造成，将其启用或重新下载新版本的英保通软件固件端即能恢复。

4

在我将一台客户机设置为母机器后，为何客户机反复重启？

该问题一般是由于客户机操作系统的不正确安装（或不正确的镜像文件），导致客户机系统WMI接口或注册表损坏，因此服务器无法正确识别客户机的IP设置，使得客户机反复重启。

该问题的解决方法是：

1) 取消该客户机为母机器的设置 （使客户机停止反复重启）

2) 另选一台客户机为母机器

3) 如果以上方法均失败，则需要在客户机上重新安装操作系统和生成镜像文件

5

我的母机器为什么报告网络上有机器同名？

这个问题不会导致任何系统异常，也不会影响到系统的管理和使用。

母机器就是处于最近部署（镜像或安装包）状态的客户机，母机器具有镜像或安装包中所含有的源机器名。因此当一个网络中有两台或以上的母机器时，它们就将报告系统同名。 因此，建议在网络上最多只存在一个母机器，暂时不用的母机器可以设置为普通机器。当需要创建磁盘镜像或者创建软件包的时候，再设置为母机器。

而当其他客户机处于部署状态时，它们也将在很短的一段时间内具有镜像或安装包中所含有的源机器名，这时母机器可能也会报告系统重名。

6

如何看到当前管理任务的进度，例如分发磁盘镜像？

查看“当前执行任务”和“任务日志” ，点击每个子信息可得到更详细的记录。通过刷新页面，能够显示当前管理任务的进度。

7

为什么管理页面无法显示报警动画页面？

请确认在Internet Explorer中已设置“Play Animations in Web Pages”。

8

为什么没有声音报警？

1) 首先，在“服务器配置”中，检查报警服务是否已经被启动.

2) 请确认当前所用机器是否安装有声卡，并安装好相应的驱动程序。

9

为什么远程开机控制命令无效？

多种问题都有可能造成远程开机失败，您可以采取以下步骤来确定问题的原因：

a. 服务器原因

1) 服务是否都已经启动。请您检查ALRT_PRV，SNMP Service，SNMP Trap Service，和Intel(R) Platform Administrator Server → ASF Proxy Service的工作情况。

2) 服务器安装后是否已重启。

b. 网络传输原因

1) 客户机和服务器的网线是否接触良好。如果网口的指示灯没有闪亮，很可能这就是网线连接的原因。

2) 客户机和服务器是否可以进行网络通讯。您可以分别在客户机和服务器上用ping命令来探测对方。

3) 试着再次执行远程开机操作。有时候网络的突然中断或阻塞也会导致命令的失败。

[提示]

1) 此命令对母机器无效。

2) 您可以进入“失败任务”来了解操作失败的原因。

10

为什么报警选项被勾上了，但在某些情况下，客户机并没有报警？

1) 请确认在BIOS设置界面内，Power → Wake on LAN from S5 → Power on 已被启用。

2) 请确认在BIOS设置界面内，Power → ACPI Suspend State → S3 State 已被启用。

3) 请确认在操作系统内，控制面板→ 系统→ 硬件 → 设备管理器 → network adapter → Intel® Pro/1000 MT Network Connection → 属性→ Power Management → Allow this device to bring the computer out of standby 选项已被勾上。

4) 请确认在操作系统内，控制面板→ 系统→ 硬件 → 设备管理器 → network adapter → Intel® Pro/1000 MT Network Connection → 属性→ Power Management → Allow this computer to turn off this device to save power 选项已被勾上。

11

为什么在客户机上拔除了USB设备，服务器端并没有收到报警？

1) 请确认服务器端管理界面内的“服务器配置”页面中，“服务器设置”（高级）下的“启用USB设备移除报警功能”已被启用。

2) 请确认该USB设备为严格使用USB2.0标准的设备。如：某些音箱仅使用USB接口获取电源，并非标准意义上的USB设备，在被拔除时不会产生报警。

12

远程修改客户机的配置，按下“执行”按钮了，当我从新刷新页面，发现设置没有改变，怎么回事？

多种问题都有可能造成这种现象，而且这很可能并不是一个错误：

a. 操作执行时间原因

远程配置需要花费一些时间来执行，这其中包括客户机执行和网络传输的时间。在远程配置执行完毕前，服务器端总是显示原始的客户机配置。因此请等待30秒后再次刷新客户机配置页面，以确定任务是否执行完成。

b. 服务器原因

服务是否都已经启动。请您检查Intel(R) Platform Administrator Server→ OS Management Service的工作情况。

c. 客户机原因

1) 客户机是否处于操作系统状态。由于远程配置功能是作用于客户机操作系统的，因此只有当客户机处于操作系统状态时，改配置命令才会生效。

2) 客户机操作系统和英特尔®平台管理解决方案客户端是否安装正确。由于远程配置功能是依赖于客户机操作系统调用的，因此当客户机软件（特别是WMI组件）安装不正确时，远程配置将无法成功。

d. 网络传输原因

1) 客户机和服务器的网线是否接触良好。如果网口的指示灯没有闪亮，很可能这就是网线连接的原因。

2) 客户机和服务器是否可以进行网络通讯。您可以分别在客户机和服务器上用ping命令来探测对方。

3) 试着再次执行远程配置操作。有时候网络的突然中断或阻塞也会导致命令的失败。


10.3 镜像与安装包

问题

可能的原因和解决方案

1

为什么无法创建磁盘镜像？

多种问题都有可能造成镜像创建失败，您可以采取以下步骤来确定问题的原因：

a. 服务器原因

1) 传输服务器根目录是否设置正确。传输服务器根据该目录来读写镜像文件。

2) 传输服务器根目录所在的磁盘分区是否有足够的剩余空间。如果你设置了不合理的磁盘配额(quota)，这也有可能会导致传输服务器无法写入文件而失败。

3) 服务是否都已经启动。请您检查DHCP Service和Intel(R) Platform Administrator Server – Boot Management Service的工作情况。

4) 服务器的MTFTP的路径设在格式是FAT/FAT32的磁盘分区上，且镜像的大小超过10G (FAT/FAT32不支持10G以上单个文件)。

b. 客户机原因

1) 客户机磁盘是否正常工作。您可以确认一下客户机磁盘的数据线和电源线的连接是否良好。

2) 客户机是否已经集成了英保通技术。请参见前文的讨论。

c. 网络传输原因

1) 客户机和服务器的网线是否接触良好。如果网口的指示灯没有闪亮，很可能这就是网线连接的原因。

2) 客户机和服务器是否可以进行网络通讯。您可以分别在客户机和服务器上用ping命令来探测对方。

3) 试着再次创建镜像。有时候网络的突然中断或阻塞也会导致创建操作的失败。

经验：您可以进入“当前执行任务”和“事件日志”来了解操作失败的原因。

2

采用以文件系统方式创建磁盘镜像，为何创建的磁盘镜像大小是整个分区，而不是所占有的文件系统？

用户创建的分区文件系统可能是NTFS格式。英保通软件1.1版本目前并不支持NTFS文件格式，因此，对于NTFS格式的分区，磁盘镜像的创建将是整个分区，而不是文件系统本身。

3

为什么我做的改动很少，但生成的增量安装包很大？

除了用户做的改动之外，操作系统自身会产生其他的改动（改动量的大小受很多因素的影响，例如系统运行时间）。所有这些改动都会被作为增量安装包上传到服务器端。

4

为什么我做的改动很少，但创建还原点和生成增量安装包要花很长时间？

用户有可能在创建还原点或生成增量安装包之前为硬盘被保护区作了磁盘文件碎片整理等操作。

5

为何无法分发从不同型号硬盘上创建的镜像到其他客户机上？

请确保母机器上的总的磁盘空间小于或等于目标客户机上总的磁盘空间，否则，用户无法从管理界面上进行磁盘镜像的分发。

6

为什么镜像分发失败？

多种问题都有可能造成镜像分发失败，您可以采取以下步骤来确定问题的原因：

a. 服务器原因

1) 传输服务器根目录是否设置正确。传输服务器根据该目录来读写镜像文件。

2) 镜像文件是否存在于传输服务器根目录。如果镜像是导入生成的，请您确认是否有镜像文件被遗漏。

3) 服务是否都已经启动。请您检查DHCP Service和Intel(R) Platform Administrator Server – Boot Management Service的工作情况。

b. 客户机原因

1) 客户机磁盘是否正常工作。您可以确认一下客户机磁盘的数据线和电源线的连接是否良好。

2) 客户机的磁盘容量是否大于或等于镜像源磁盘容量？如果客户机的磁盘容量小于镜像源磁盘容量，分发工作将无法进行。

3) 客户机是否已经集成了英保通技术。请参见前文的讨论。

c. 网络传输原因

1) 客户机和服务器的网线是否接触良好。如果网口的指示灯没有闪亮，很可能这就是网线连接的原因。

2) 客户机和服务器是否可以进行网络通讯。您可以分别在客户机和服务器上用ping命令来探测对方。

3) 试着再次分发镜像。有时候网络的突然中断或阻塞也会导致分发行为的失败。

4) 关闭“多播”选项，请再尝试一次。

d. 镜像原因

如果从母机器生成的镜像因为一些本地操作而被改动了，也会造成镜像部署失败。

[提示]

您可以进入“当前执行任务”和“失败任务”了解操作失败的原因。

7

我在母机器上装了外设硬件的驱动程序（如网络摄像头）并生成安装包部署给了其他客户机，为什么在其他客户机上这个硬件不能正常工作？

请检查您插入外设硬件的接口是否与母机器的保持一致。

如：网络摄像头在母机器上通过USB controller1连接，但在其他客户机上通过USB controller2连接，客户机上的网络摄像头就不能像在母机器上的摄像头一样正常工作。

8

为什么我的客户机总是在部署磁盘镜像或安装包的时候报告“客户机连接丢失”？这是一个误报吗？

这不是一个误报，一般是由于客户机所部署的磁盘镜像造成的。

为了更好的理解这个问题，我们首先需要说明一下“客户机连接丢失”警告的原理：“客户机连接丢失”是基于异常报警功能的。在设置客户机异常报警功能时，会同时记录一个服务器的地址，随后客户机将不断地将心跳信号发给该服务器。当服务器在一定时间内没有接受到心跳信号时，就将发出一个“客户机连接丢失”异常。

以下的操作步骤将导致客户机总是在部署磁盘镜像或安装包的时候报告“客户机连接丢失”：

操作 | 服务器地址
在母机器上使用异常报警功能，服务器地址A被记录下来。 | A
如果使用了磁盘保护功能，则在母机器上创建还原点或保存磁盘状态，使得异常报警功能的设置被保存下来。 | A
选择该母机器创建磁盘镜像，然后： 改变服务器的地址。 或者将该镜像导出给其他服务器使用。 或者将该母机器连接到其他服务器上创建磁盘镜像。 | A->B
将该镜像部署到其他客户机。由于镜像中记录的服务器地址为A，因此B将无法接受到心跳信号，从而报告“客户机连接丢失”。 | B
部署完成后，客户机会进行自动配置，将服务器地址更新为B，客户机心跳信号恢复。 | B
对这些客户机部署安装包，客户机将回滚到初始的镜像状态。由于镜像中记录的服务器地址为A，因此B将无法接受到心跳信号，从而报告“客户机连接丢失”。 | B
部署完成后，客户机会进行自动配置，将服务器地址更新为B，客户机心跳信号恢复。 | B

解决方法：

由于自动配置功能可以更新服务器地址，该报警不会对实际功能产生任何影响，因此在部署磁盘镜像或安装包的时候报告的“客户机连接丢失”可以忽略。

如果在母机器上使用并保存了异常报警功能，而且发生了：

- 改变服务器的地址。

- 将镜像导出给其他服务器使用。

- 将母机器连接到其他服务器上创建磁盘镜像。

最稳妥的方法是在服务器B上：

- 选择母机器

- 启用或禁用异常报警功能(使得镜像中记录的服务器地址得到更新)

- 保存设置

- 重新创建磁盘镜像


10.4 硬盘保护

 | 问题 | 可能的原因和解决方案
1 | 为什么我的硬盘上有那么多空间，但它总是说空间不够？ | 磁盘保护程序的可用空间受两个因素的影响： 1) 其一是受保护的FAT分区上的剩余空间，当受保护的FAT分区上的剩余空间不足时，即使受保护的NTFS上有很多空间，磁盘保护程序也无法使用。 2) 另一个因素是安装磁盘保护程序时受保护的FAT分区上是否有足够的连续空间，如果安装时连续空间不足，也会影响磁盘保护程序的可用空间，这就是在安装前推荐进行磁盘整理的原因。
2 | 为什么我发下去的创建还原点的命令没有被执行？ | 当系统非正常关机（例如掉电、系统崩溃等）时，磁盘保护组件记录的改动可能并不完整，在这种情况下，为安全起见，这些改动将被还原，不会创建一个新的还原点。
3 | 我已经保护了C盘，现在想保护更多的磁盘分区，怎么做？ | 先选择禁用英保通软件客户端，然后重新启动，就可重新选择需要保护的分区。
4 | 我的硬盘保护的密码丢失了怎么办？ | 硬盘保护的密码必须牢记，一旦忘记则无法对系统进行正常的管理和维护。如果遗忘了密码，请进入BIOS选择禁用硬盘保护，并重新安装系统。如果不重新安装系统，则系统处于不受保护的状态，但英保通软件客户端仍然存在。
5 | 我不小心退出了硬盘保护程序，要如何重新启动它？ | 退出硬盘保护程序并不意味着硬盘不受保护，只是硬盘保护图标将从屏幕右下角消失。 要重新使该图标出现在原来的位置，可采用以下二种方法： 1) 方法1：重新启动该客户机，客户端程序的图标将重新出现。 2) 方法2：被保护硬盘的Program Files → Intel → HDGuard → 双击 Configure2.exe。
6 | 为什么我删除了硬盘保护程序，但图标仍然出现在屏幕右下角？ | 在某些情况下，由于删除过程中出现一些错误，导致客户端程序未能删除干净。 可采用以下方法： 被保护硬盘的Program Files → Intel → HDGuard → 双击 Uninstall.exe。
7 | 为什么我在安装有硬盘保护程序的客户机上增加了一块新硬盘后，系统出现蓝屏？ | 如果用户需要增加新的硬盘，必须先卸载英保通软件客户端。等新的硬盘安装完毕后，再重新安装英保通软件客户端。


系统初始化信息中英文对照表(A-Z)

1 | Client Information | 客户机信息
2 | Disabling HD protection ... | 正在卸载硬盘保护……
3 | Disk image creation is in process... | 正在创建磁盘镜像……
4 | Disk image deployment is in process... | 正在部署磁盘镜像……
5 | Estimated time left: x Hours x Minutes x Seconds | 估计剩余时间：x小时x分钟x秒
6 | Incremental package (a%) deployment is in process… | 正在部署升级安装包……（进度：a%）
7 | Incremental package (a%) creation is in process ... | 正在创建升级安装包……（进度：a%）
8 | Incremental package (a%)) deployment completed! | 升级安装包部署完成!（进度：a%）
9 | Incremental package (a%) creation completed! | 升级安装包创建完成!（进度：a%）
10 | Incremental package (a%) creation failed! | 升级安装包创建失败!（进度：a%）
11 | Incremental package (a%) deployment failed! | 升级安装包部署失败!（进度：a%）
12 | Initializing HD Protection… | 正在初始化硬盘保护……
13 | Intel(R) Platform Administrator Server (xxx.xxx.xxx.xxx) was found. Registration succeeded! | 英保通服务器(IP地址：xxx.xxx.xxx.xxx)已找到。注册成功！
14 | Intel(R) Platform Administrator Server was found. Waiting for acceptance... | 英保通服务器(IP地址：xxx.xxx.xxx.xxx)已找到。等待接受……
15 | Intel(R) Platform Administrator Server was not found. Please check your system configuration! | 英保通服务器未找到。请检查您的网络设置或系统配置！
16 | Invalid IP address! Press any key to reset and reconfigure ... | 无效IP地址！按任意键重启或重新配置……
17 | Invalid IP settings! Press any key to reset and reconfigure ... | 无效IP设置！按任意键重启或重新配置……
18 | Invalid route configuration! Press any key to reset and reconfigure ... | 无效路由设置！按任意键重启或重新配置……
19 | Invalid subnet mask! Press any key to reset and reconfigure ... | 无效子网掩码！按任意键重启或重新配置……
20 | Local checkpoint recovery is in process ... | 正在恢复本地还原点……
21 | MBR… | 主引导记录……（部署）
22 | MBR Completed! (Time elapsed: x hours x minutes) | 主引导记录完成！（总耗时：x小时x分钟）
23 | MBR Failed! | 主引导记录（部署）失败！
24 | Network adapter is missing ! System will do local boot… | 无法找到网卡！系统将本地启动……
25 | Network cable is not connected ! System will do local boot… | 网线未连接！系统将本地启动……
26 | Null or bad gateway setting! Press any key to reset and reconfigure… | 未设或错设网关！按任意键重启或重新配置……
27 | Partition # (x) … | 分区# (x)…… （部署）
28 | Partition # (x) Completed! (Time elapsed: x hours x minutes) | 分区# (x)部署完成！（总耗时：：x小时x分钟）
29 | Partition # (x) Failed! | 分区# (x)部署失败！
30 | Post processing ... | 后期处理……
31 | Press any key to reset… | 按任意键重启……
32 | Press any key to continue ... | 按任意键继续……
33 | Reconfiguration is not supported yet. | 尚不支持重新配置。
34 | Re-initializing, please wait a minute... | 正在重新初始化，请稍等……
35 | Saving disk status ... | 保存硬盘状态……
36 | Searching Intel(R) Platform Administrator Server, please wait ... | 寻找英保通服务器，请稍等……
37 | There is an IP address conflict with another system (MAC xx-xx-xx-xx-xx) on the network! | 与网络内其他设备 (MAC地址 xx-xx-xx-xx-xx) IP地址冲突！
38 | The computer may be shut down abnormally last time… | 该计算机上一次未正常关机……
39 | The disk protection installation failed and please free some disk space.\n The disk protection will be disabled. | 硬盘保护程序安装失败，请清理磁盘空间。硬盘保护功能将被禁用。
40 | Warning: This operation may take several minutes. Please do not interrupt. | 警告：此操作需要较长时间。请勿重启或关闭机器。


设置文件传输服务器目录

英保通软件服务器端通过文件传输服务器进行镜像文件的传输。该文件传输器目录在安装时已由用户设定，安装完成后用户也可在界面右边 [服务器设置] 下的 [传输服务器根目录] 选项内进行更改。

设置传输服务器根目录：

在输入框中填入当前安装的文件传输服务器的根目录（如C:\IPAT Server\MTFTP\）。文件传输服务器将在这个根目录下读写文件。在设置完成后，请重启MTFTP服务。

[提示]

1. MTFTP根目录将用于存放镜像文件和安装包文件等，为方便日后管理，建议用户建立一个专门的目录。如：[如C:\IPAT Server\MTFTP\]。

2. 若在使用过程中需要修改文件传输服务器的根目录，请将原路径下的镜像文件拷贝到新的路径下，否则将造成原有镜像文件无法部署。

[警告]

1. MTFTP服务重启之前，MTFTP根目录的改动不会生效。

2. 请确保输入文件传输服务器的根目录所在分区是NTFS分区格式。如果是FAT或FAT32分区，可以读写的最大文件大小为4GB,如果将来创建的文件大小超过这个限制，那么会造成读写文件失败。

3. 请确保输入文件传输服务器的根目录所在分区有足够大的剩余磁盘空间。将来创建的所有磁盘镜像和安装包文件都将存放在这个根目录下。如果没有足够的磁盘空间，将会造成读写文件失败。

重启MTFTP服务：

在Windows单击[开始] à [控制面板] à [管理工具] à [服务] 打开服务（本地）界面。

2）选中“Intel (R) Platform Administrator Server – MTFTP Service”，单击右键，在弹出菜单中选中“重新启动”。

3）系统将重启MTFTP服务，重启后根目录的地址改变生效。