Using the Control Panel Applet

ZyXEL Communications Corp. / Unleash Networking Power!

Using the ZyXEL OMNI ADSL USB Control Panel Applet

The ZyXEL OMNI ADSL USB Control Panel Applet gives the user a display of the current status, statistics, and other information about the ZyXEL OMNI ADSL USB modem. It also provides control of the ZyXEL OMNI ADSL USB modem functionality by allowing the user to view and change certain operating parameters.

Control Panel Applet starts in General Information Mode which provides an overview of the ADSL line connection to the user and allows to change basic configuration settings. There are two additional Control Panel Applet modes which are designed for qualified ISP personnel only: Advanced Statistics Mode and Advanced Diagnostics Mode. Both of them are intended for in-depth line monitoring and testing. To switch Control Panel Applet view to Advanced Statistics Mode press ALT-A. Advanced Diagnostics Mode can be accessed by pressing ALT-C. All of these modes are described in more detail in the topics that follow.

The ZyXEL OMNI ADSL USB Control Panel Applet contain several different terms that have the same meaning. The terms Near, Near End, Downstream, and Receive all refer to data received by the OMNI ADSL USB modem or data in the DSL Data Pump on the modem. The terms Far, Far End, Head End, Upstream, and Transmit all refer to data transmitted by the DSL modem or data in the DSL Data Pump at the other end of the DSL line to which the OMNI ADSL USB modem is connected.


General Information Mode

Control Panel Applet in General Information Mode

General Information Mode provides an overview of the ADSL line connection to the user and allows to change basic configuration settings.

There are three tabs in General Information Mode:

  • General

  • Line Setup

  • Protocol Setup


General Tab

The General tab provides an overview of the ADSL connection status. A sample of the General tab for a ZyXEL OMNI ADSL USB Modem in LAN mode is as follows.

ADSL Line Information

The ADSL line connection state is displayed as both an animated graphic and text. Possible ADSL line connection states are listed below.

  • Line Down

  • Attempting to Activate Line

  • Waiting for Initialization

  • Initializing the ADSL Line

  • ADSL Connection Established

  • Training

  • Channel Analysis

  • Exchange

  • Undefined Status

ADSL Connection Information

The Bytes Received value indicates the number of accumulated bytes received on the ADSL connection. This accumulation is retained in the control panel applet and may be cleared or reset to zero by pressing Clear button.

The Bytes Transmitted value indicates the number of accumulated bytes transmitted on the ADSL connection. This accumulation is retained in the control panel applet and may be cleared or reset to zero by pressing Clear button.

The Receive Rate value indicates the receive transfer bit rate of the ADSL connection.

The Transmit Rate value indicates the transmit transfer bit rate of the ADSL connection.

Driver S/W Version

A display of the ADSL driver product version.

Clear Button

The Clear button zeroes the Bytes Received and Bytes Transmitted displayed accumulation values.


Line Setup

Line Setup Tab

Line Setup tab specifies physical layer ADSL connection parameters. A sample of the Line Setup tab for a ZyXEL OMNI ADSL USB Modem in LAN mode is as follows.

Line Setup Tab

Modulation

This field displays the current modulation mode being used by modem. The modulation type identifies the modulation standard used to transfer data between the ADSL Modem and the ADSL line provider's ADSL equipment. There are three standards supported G.dmt (G.992.1), G.lite(G.992.2), ANSI T1.413, and several sets of automatic mode presets.

ADSL Head End / ADSL Head End Env.

The ADSL Head End is the manufacturer of the remote ADSL modem owned by your ISP. Leave these fields to Unknown/Non-Specific until your ISP requires you to make the changes. If possible, during line activation ZyXEL OMNI ADSL USB learns remote ADSL modem manufacturer and sets ADSL Head End parameter automatically.

Annex Selection

Annex section indicates your modem type. Annex A (ADSL over POTS) refers to the modem designed to work over usual telephone line also known as POTS (Plain Old Telephone Service). Annex B (ADSL over ISDN) refers to the modem designed to operate over an ISDN (Integrated Services Digital Network) line or POTS line that has flat protection service from police already running over it. One of the options will be grayed out depending on the type of your modem.


Protocol Setup

Protocol Setup Tab

Protocol Setup tab let you configure ATM parameters and choose encapsulation protocol. A sample of the Protocol Setup tab for a ZyXEL OMNI ADSL USB Modem in LAN mode is as follows.

Protocol Setup Tab

ATM Virtual Circuit Identification

VPI is Virtual Path Identifier. VCI is Virtual Circuit Identifier. Both parameters depend on your ISP settings.

Aggregate Channel Setup

Encapsulation Mode means of wrapping a data protocol to allow multiple protocols on a single VC. Select the method of encapsulation used by your ISP.

Maximum Packet Length is the maximum packet length for both received and transmitted packets.

Peak Cell Rate is the maximum rate at which the sender can send cell. Select the Peak Cell Rate from the drop-down list box.


Advanced Statistics Mode

Control Panel Applet in Advanced Statistics Mode

Advanced Statistics Mode provides in-depth monitoring of the ADSL line connection. To switch Control Panel Applet view to Advanced Statistics Mode press ALT-A.

This mode is intended for qualified ISP personnel only!

There are four tabs in Advanced Statistics Mode:

  • General

  • ATM Link Statistics

  • AAL Link Statistics

  • Physical Layer Statistics


General Advanced

General Tab in Advanced Mode

This General tab provides advanced overview of the ADSL connection status. A sample of the General tab for a ZyXEL OMNI ADSL USB Modem in LAN mode is as follows.

General Tab in Advanced mode

ADSL Line Information

The ADSL line connection state is displayed as both a LED panel and text. Possible ADSL line status states are listed below.

  • Line Down

  • Attempting to Activate Line

  • Waiting for Initialization

  • Initializing the ADSL Line

  • ADSL Connection Established

  • Training

  • Channel Analysis

  • Exchange

  • Undefined Status

Press Stop ADSL button to terminate physical connection. To resume press Start ADSL button.

ADSL Modulation

This field displays the current modulation mode being used by modem. The modulation type identifies the modulation standard used to transfer data between the ADSL Modem and the ADSL line provider's ADSL equipment. There are three standards supported G.dmt (G.992.1), G.lite(G.992.2), ANSI T1.413.

Call Status

Indicates current status of call.

Encapsulation Mode

Means of wrapping a data protocol to allow multiple protocols on a single VC.

Driver S/W Version

A display of the ADSL driver product version.


ATM Link Statistics Tab

The ATM Link Statistics tab displays ATM link statistics. A sample of the tab for a ZyXEL OMNI ADSL USB Modem in LAN mode is as follows.

ATM Link Statistics

The ATM Link Statistics tab displays the following ATM link statistics and is automatically updated once per second:

  • Receive Bytes and Transmit Bytes

  • Receive Cells and Transmit Cells

  • Receive Cells/Second and Transmit Cells/Second

  • Receive Management Cells and Transmit Management Cells

  • Receive CLP = 0 Cells and Transmit CLP = 0 Cells

  • Receive CLP = 1 Cells and Transmit CLP = 1 Cells

  • Receive Unroutable Cells

Note that Link statistics refer to data collected on all active Virtual Channels.

Bytes refers to the number of bytes (octets) processed.

Cells refers to the number of 53 byte/octet blocks processed.

Cells/Second refers to the number of cells processed in a one-second period.

CLP = 0 Cells refers to the number of cells processed with the CLP bit in the header set to zero.

CLP = 1 Cells refers to the number of cells processed with the CLP bit in the header set to one.

Unroutable Cells refers to the number of cells received that had no active Virtual Channel to which they could be routed.

The Clear All button resets all statistics to zero.


AAL Link Statistics Tab

The AAL Link Statistics tab displays AAL link statistics. A sample of the tab for a ZyXEL OMNI ADSL USB Modem in LAN mode is as follows.

AAL Link Statistics Tab

The AAL Link Statistics tab displays the following AAL link statistics and is automatically updated once per second.

  • Receive Good Bytes and Transmit Good Bytes

  • Receive Good Frames and Transmit Good Frames

  • Receive Total Discarded Bytes and Transmit Total Discarded Bytes

  • Receive Total Discarded Frames and Transmit Total Discarded Frames

  • Receive CRC Errors

  • Receive Invalid Length Errors

  • Receive Timeout Errors

  • Receive AAL Type

Note that Link statistics refer to data collected on all active Virtual Channels on a given physical channel or link.

Good Bytes refers to the total number of good bytes processed.

Good Frames refers to the total number of good frames processed.

Total Discarded Bytes refers to the total number of bytes discarded because of any error.

Total Discarded Frames refers to the total number of frames discarded because of any error.

CRC Errors refers to the number of frames received that contained CRC errors.

Invalid Length Errors refers to the number of frames received that contained an invalid length.

Timeout Errors refers to the number of frames not reassembled within the time allowed.

AAL Type refers to the protocol that describes how the frames are to be built or reassembled.

The Clear All button resets all statistics to zero.


Physical Layer Statistics

Physical Layer Statistics Tab

This tab shows detailed statistics for physical layer of ADSL link. A sample of the tab for a ZyXEL OMNI ADSL USB Modem in LAN mode is as follows.

Physical Layer Statistics Tab

Pressing Clear All button will reset error statistics.

After connection was established Bit Loading button appears in lower right corner of this tab. Pressing this button opens Bits Per Bin graph that shows number of upstream and downstream channels used, their distribution across frequency range and number of bits transmitted on each channel.

Bit loading graph


Advanced Diagnostics Mode

Control Panel Applet in Advanced Diagnostics Mode

Advanced Diagnostics Mode provide means for testing of the ADSL line connection. To switch Control Panel Applet view to Advanced Diagnostics Mode press ALT-C.

This mode is intended for qualified ISP personnel only! Do not run any diagnostics without prior instructions from ISP personnel.

There are five tabs in Advanced Diagnostics Mode:

  • ATM Statistics

  • ATM Diagnostics

  • AAL Statistics

  • ATM OAM Loopback

  • ATM Bert Diagnostics


Additional Help

Additional help is provided by the following:

  • Glossary — A glossary providing brief explanations of acronyms, words, and/or phrases that may be unfamiliar to the user.

  • References — A section providing lists of references.


Glossary

The following table provides brief explanations of acronyms, words, and/or phrases that may be unfamiliar to the user.

Word, Phrase or Acronym

Definition/Explanation

AAL

ATM Adaptation Layer

ADSL

Asymmetric Digital Subscriber Line

AGC

Automatic Gain Control

ANSI

American National Standards Institute

Application Programming Interface (API)

set of routines that an application uses to request and carry out lower-level services performed by another component

Attenuation

difference in dB between the signal power level received and a reference transmitted signal power level the decrease in magnitude of a communications signal between the transmitter and the receiver, measured in dB

ATM

Asynchronous Transfer Mode

BER

Bit Error Rate

Capacity Occupation

downstream bit rate as a percentage of the maximum attainable

CBR

Constant Bit Rate

Cell

fixed length data message, always 53 bytes for ATM

Client

computer that uses the services of another computer (the server)

CLP

Cell Loss Priority (as in CLP bit)

Control Panel Applet

application that provides setup/control, diagnostics, and/or statistics to the user for a device

CRC

Cyclic Redundancy Check

dB

Decibels, signal power or voltage measurement unit, referred to another power or voltage

dBm

measure of signal power, one milliwatt accross 600 ohms is defined as zero dBm

DHCP

see Dynamic Host Configuration Protocol (DHCP)

Dial-Up Networking (DUN)

component of Windows NT and Windows 95 that enables users to connect to remote networks, such as the Internet or an internal network, over a telephone line

DLL

see Dynamic-Link Library

DNS

see Domain Name System (DNS)

Domain

For a Windows NT Server network, a collection of computers that share a common domain database and security policy; also called a workgroup. Each domain has a unique name. See also Domain Name System (DNS).

Domain Name

The computer name that substitutes for a network IP address. For example, www.microsoft.com instead of the IP address 157.45.60.81. Also called the friendly name. See also Domain Name System (DNS).

Domain Name System (DNS)

A protocol and computer-naming hierarchy used throughout the Internet to map computer IP addresses to their domain name. DNS is sometimes referred to as the BIND service.

Downstream

the direction of data, data received by the user's DSL device

DP

Data Pump

Driver

Program that interacts with a particular device or special (frequently optional) kind of software. The driver contains the special knowledge of the device or special software interface that programs using the driver do not.

DSL

Digital Subscriber Line

DSL Modem

digital (e.g., ADSL) modem

DUN

Dial-Up Networking

Dynamic Host Configuration Protocol (DHCP)

Protocol that offers dynamic assignment of IP addresses and related information for temporarily connected network users. DHCP provides safe, reliable, and simple TCP/IP network configuration, prevents address conflicts, and helps conserve the use of IP addresses through centralized management of address allocation.

Dynamic-Link Library (DLL)

Operating system feature that enables executable routines (generally serving a specific function or set of functions) to be stored separately as files with .dll extensions and to be loaded only when needed by the program that calls them.

EEPROM

Electrically Eraseable Programmable Read-Only Memory, a non-volatile memory storage device

Encapsulation

means of wrapping a data protocol to allow multiple protocols on a single VC

Far

data or information at the other end of the DSL line with respect to the user's DSL device

Far End

data or information at the other end of the DSL line with respect to the user's DSL device

File Transfer Protocol (FTP)

Internet standard protocol for transferring files between computers. FTP uses the Telnet and TCP protocols. The server requires a client to supply a logon user name and password before honoring requests. See also anonymous logon.

FTP

see File Transfer Protocol (FTP)

Frame

variable length data message

G.DMT

standard for ADSL that allows data rates of up to 8 Mbps downstream and up to 1.5 Mbps Kbps upstream

G.Lite

also known as Universal ADSL and as "splitterless DSL", a standard for ADSL that allows data rates of up to 1.5 Mbps downstream and up to 384 Kbps upstream

HEC

Header Error Control

Host

see Server

Internet

global network of computers that communicate through a common set of protocols known as TCP/IP

Internet Protocol (IP)

Internet standard routing protocol that defines the IP datagram as the unit of data transfer and provides the IP address scheme to route packets from one network location to another. IP includes the ICMP protocol. The Internet protocol suite is often called TCP/IP.

Internet Service Provider (ISP)

company or educational institution that enables remote users to access the Internet by providing dial-up connections or installing leased lines.

IP

see Internet Protocol (IP)

IP Address

Internet Protocol Address. Unique address that identifies a computer on a network by using a 32-bit address that is unique across a TCP/IP network. An IP address is usually represented in dotted-decimal notation, which depicts an octet (8 bits, or 1 byte) of an IP address as its decimal value and separates each octet with a period; for example, 102.54.94.97.

ISP

see Internet Service Provider (ISP)

ITU

International Telecommunication Union

KB

Kilo Byte, typically 1024 bytes (210)

kbit/s, kbits/s, or Kbps

kilo bits per second, typcially one thousand (1,000) bits per second

L1

Layer 1

LAN

see Local Area Network (LAN)

LED

Light-Emitting Diode

Line

the physical DSL line

Link

an electrical or logical connection between two entities

Local

data or information at the user's end of the DSL line, at the user's DSL device

Local Area Network (LAN)

group of computers connected by a communications link that enables any computer to interact with any other on the network

MAC Address

Media Access Control Address, the computer's unique hardware address on the network

Management Cells

OAM cells

MB

Mega Byte, typically 1024*1024 (1,048,576, or 220) bytes when used to describe real and/or virtual memory; but one million (1,000,000) bytes when used to describe disk storage capacity and data transmission rates

Mbps

Mega bits per second, typcially one million (1,000,000) bits per second

Modem

Modulator/demodulator. Communications device that enables a computer to transmit information over a standard telephone line.

Modulation

scheme used to convert digital data into an analog signal (e.g., for transmission over a telephone line)

Name Server

name server, which is used for local name resolution, can be a Domain Name System (DNS) server, Windows Internet Name Service (WINS), or Dynamic Host Configuration Protocol (DHCP).

NDIS

Network Device Interface Specification

Near

data or information at the user's end of the DSL line, at the user's DSL device

Near End

data or information at the user's end of the DSL line, at the user's DSL device

Network Adapter

device, usually a hardware card, used to connect a computer to a local area network (LAN)

NIC

Network Interface Card

Noise Margin

amount of increased noise that can be tolerated while maintaining the designated BER

OAM

Operations, Administration and Maintenance

Output Power

transmit power level, measured in dBm

Packet

Fixed number of bytes that represents the basic unit of information sent across a physical network. Packets consist of binary information representing both data and a header containing an ID number, source and destination addresses, and error-control data.

PCI Bus

interconnection system between a computer's microprocessor and attached devices and cards within the computer

PCR

Peak Cell Rate

PDU

Protocol Data Unit

Physical Layer

means of transferring data or information between two entities (i.e., the physical line and the electrical signal on the physical line); e.g., communications between two ships might use lights to transmit morse code, in which case, light and the length of the light pulses or blinks would be the physical layer

Point-to-Point Protocol (PPP)

In contrast to SLIP, a more recently established Internet communications protocol that standardizes dial-up networking that uses analog modem hardware and standard telephone lines. Although PPP is a well-standardized protocol, vendor implementations of PPP service can vary significantly.

POTS

Plain Old Telephone Service

PPP

see Point-to-Point Protocol (PPP)

Program File

A file that starts an application or program. A program file has an .exe, .pif, .com, .cmd, or .bat file name extension.

Protocol

special set of rules for communicating that the end points in a telecommunication connection use when they send signals back and forth (protocols exist at several levels in a telecommunication connection)

software that allows computers to communicate over a network, the Internet protocol is TCP/IP

PVC

Permanent Virtual Circuit

QoS

Quality of Service

RAS

see Remote Access Service (RAS)

Receive

data or information received at the user's end of the DSL line, at the user's DSL device

Remote

data or information at the other end of the DSL line with respect to the user's DSL device

Remote Access Service (RAS)

Microsoft-developed service that allows remote client computers running Microsoft dial-up networking, all Microsoft RAS clients, or any third-party PPP client to dial in to a network server (RAS server). RAS servers can also be configured to allow local client computers to dial out to servers outside an internal network.

SAR

Segmentation and Reassembly

SDU

Service Data Unit

Server

computer that provides services to other computers, also referred to as a host

Service

Process that performs a specific system function and often provides an API for other processes to call. Web Proxy service and WinSock Proxy service are two services provided by Microsoft Proxy Server.

SVC

Switched Virtual Circuit

T1.413

ANSI standard for ADSL that allows data rates of up to 8 Mbps downstream and up to 1.5 Mbps Kbps upstream

Tab

selectable display or page for the Control Panel Applet

TCP

see Transmission Control Protocol (TCP)

TCP/IP

see Transmission Control Protocol / Internet Protocol (TCP/IP)

Transmission Control Protocol (TCP)

Internet standard transport protocol that provides the reliable, two-way connected service that allows an application to send a stream of data end-to-end between two computers across a network. The Internet protocol suite is often called TCP/IP.

Transmission Control Protocol / Internet Protocol (TCP/IP)

Family of networking protocols that allows computers with diverse hardware architectures and various operating systems to communicate across interconnected networks and the Internet. TCP/IP includes standards for how computers communicate and conventions for connecting networks and routing traffic. Every computer on the Internet supports TCP/IP.

Transmit

data or information transmitted from the user's end of the DSL line, at the user's DSL device

UBR

UBR Undefined Bit Rate

UNI

User Network Interface

Unroutable Cells

cells received that do not match any open VC

Upstream

the direction of data, data transmitted by the user's DSL device

USB

Universal Serial Bus. A bidirectional, isochronous, dynamically attachable serial interface for adding periperal devices such as modems, game controllers, serial and parallel ports, and input/output devices on a single bus.

Universal Serial Bus. Interconnection system between a computer's microprocessor and attached external (to the computer) devices.

VBR

Variable Bit Rate

VC

Virtual Channel (not circuit)

VCC

Virtual Channel Connection

VCI

Virtual Channel Identifier

VP

Virtual Path

VPC

Virtual Path Connection

VPI

Virtual Path Identifier

WAN

see Wide Area Network (WAN)

Wide Area Network (WAN)

Network that extends across distance and is not confined to a single site. This type of network typically involves interconnecting multiple local area networks (LANs) that use multiple physical topologies.

Wizard

Application to simplify the installation and/or configuration of the ZyXEL OMNI ADSL USB modem


More Information on DSL

ZyXEL Communications Corp. / Unleash Networking Power

More Information on ADSL

For more information on ADSL, see the following specifications:

  • ANSI T1.413-1998, Issue 2 - Interface Between Networks and Customer Installation - Asymmetric Digital Subscriber Line (ADSL) Metallic Interface.

  • ITU-T G.992.1 (G.dmt) - Asymmetrical Digital Subscriber Line (ADSL) Transceivers.

  • ITU-T G.992.2 (G.lite) - Splitterless Asymmetrical Digital Subscriber Line (ADSL) Transceivers.

  • ITU-T G.994.1 (G.hs) - Handshake procedures for Digital Subscriber Line (DSL) transceivers.

Information may also be accessed at the following internet addresses:

  • ADSL Forum — www.adsl.com

  • ANSI — www.ansi.org

  • ITU — www.itu.int


Copyright

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of ZyXEL Communications Corp. Permission to print one copy is hereby granted if your only means of access is electronic.

ZyXEL may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. The furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

Microsoft, MS, Windows, Windows NT, and Win32 are either registered trademarks or trademarks of Microsoft Corporation in the U.S.A. and/or other countries.

Other product and company names mentioned herein may be the trademarks of their respective owners.