概要

ThinkPad EasyEject ユーティリティを使うと、複数のデバイスを一度に停止させることができるため、個々のデバイスを一つずつ停止させるよりも簡単かつスピーディに、コンピュータに装着しているデバイスを取りはずすことが可能です。

USB、IEEE 1394、PC カードなどのデバイスのほとんどは、ホットあるいはウォーム・スワップが可能です。これは、コンピュータ、拡張ユニット（ドック）、ミニ・ドック、ウルトラベースなどから電源を切ることなしに、装着したり取り外したりすることが可能であることを意味します。しかしながら、それらのデバイスを物理的に取り外す前には、オペレーティング・システムがアクセスしないように、デバイスを停止させる必要があります。これを行わないとデータを失うことにもつながります。

EasyEject ユーティリティを使って、一度のクリックでどのデバイスを停止させたいかのリストを作成することができます。EasyEjectの機能は、Fn+F9キー、EasyEjectトレイ・アイコン (Windows 2000/XPのみ)、スタート・メニューの三通りの方法から使用することができます。

注意: ThinkPadのいくつかのモデルでは、Fn+F9 キーをサポートしていません。

EasyEjectの設定の変更

EasyEjectの使用

商標および登録商標


EasyEjectの設定の変更

EasyEjectに停止させたいデバイスのリストを作成することや、EasyEjectの機能を使用する方法を選択することができます。

EasyEjectの設定を変更するには、以下のことをしてください :

  1. システム・トレイ中のEasyEject アイコンをクリックして、 EasyEject ユーティリティのEasyEjectのActionの設定画面を開きます (Windows 2000/XPのみ):

    または、Fn+F9キーを押して、EasyEjectのActionの設定をクリックします。あるいは、スタート・メニューからも開くことができます。

    注意: ThinkPadのいくつかのモデルでは、Fn+F9 キーをサポートしていません。

    EasyEjectのActionの設定画面は、コンピュータ、拡張ユニット（ドック）、ミニ・ドック、ウルトラベース、ポート・リプリケータなどに装着している取り外し可能なデバイスのリストを表示します。新しいデバイスが装着されたときには、リストは自動的に更新されます。

  2. EasyEjectのリスト中の個々のデバイスに、EasyEjectのアクションから一つのアクションを選択して割り当てます。一つのデバイスに対して、三つの選択肢があります :

    選択 | EasyEjectのアクションの実行をクリックしたときの動作 | 例
    デバイスを停止する | EasyEjectはデバイスを停止しようとする | USB デバイス、ネットワーク PC カード、ワイアレス PC カード
    デバイスを停止しない | EasyEjectはデバイスを停止しようとしない | 着脱可能 デバイス・ベイ・デバイス
    入力を求める | EasyEjectは、デバイスを停止するかしないかを聞いてくる | Microdrive ストレージ・デバイス、USB メモリー・キー・ストレージ・デバイス

    EasyEjectのアクションの実行をクリックすると、リスト中に指定したすべてのアクションが実行され、個々のデバイスの状況を示す画面が表示されます。それによって、デバイスを安全に取り外すことができるかどうかを知ることができます。

    EasyEjectのリストに表示されるデバイス名を変更する場合には、デバイス名の上を右クリックして、名前の変更を選択してください。

    もし今後使用しないデバイスがあるときには、EasyEjectのリストから削除することもできます。リストからデバイスを削除するには、デバイス名の上で右クリックし、リストからの削除を選択してください。次回に装着されるまで、そのデバイスはリストから削除されます。

  3. EasyEjectのオプションを選択します :

    デバイス停止時にビープ音を鳴らす

    デバイスが停止するときにビープ音を聞きたいときには、このオプションを選択してください。

    EasyEjectの状態画面を自動で閉じる

    すべてのデバイスの停止に成功したときにEasyEjectの状態画面を5秒後に自動で閉じたいときには、このオプションを選択してください。

    EasyEject アイコンをタスクバーに表示する (Windows 2000/XPのみ)

    EasyEject アイコンをシステム・トレイに追加したいときには、このオプションを選択してください。

    Windowsのハードウェアの取り外し/取り出しアイコンをタスクバーに表示する

    Windows 2000に含まれるハードウェアの取り外しまたは取り出しトレイ・アイコンを表示させたいときには、このオプションを選択してください。EasyEject アイコンをタスクバーに表示するを選択しているときのみ設定可能です。設定を有効にするにはシステムの再起動が必要です。

  4. Fn+F9 の設定...をクリックして、Fn+F9 キーを押したときのアクションを選択します。Fn+F9を押したときに、機能の選択のためのメニューを表示するか、EasyEjectのリスト中に指定したアクションを即座に実行するか、拡張ユニット（ドック）、ミニ・ドック、ウルトラベースからThinkPad PCを安全に取り外すために必要なすべてのデバイスを自動的に停止させるか、を選択することができます。

    注意: ThinkPadのいくつかのモデルでは、Fn+F9 キーをサポートしていません。


EasyEjectの使用

EasyEjectを使用すると、一つのデバイスを停止させることも、複数のデバイスを停止させることも、また、ThinkPad PCを拡張ユニット（ドック）、ミニ・ドック、ウルトラベースから取りはずすこともできます。

EasyEjectを使って一つのデバイスを停止させるには、EasyEject システム・トレイ・アイコン上を左クリックするか (Windows 2000/XPのみ) Fn+F9を押して、停止させたいデバイスを選択します。Fn+F9のオン・スクリーン表示メニューから一つのデバイスを停止させるには、Fn+F9 の設定...をクリックして、個々の取り外し可能なデバイスを別のメニュー項目として表示する オプションを選択してください。

EasyEjectを使って複数のデバイスを同時に停止させるには、EasyEjectのActionの設定画面中か、Fn+F9を押したときに表示されるメニュー中か、EasyEject システム・トレイ・アイコン上を左クリックしたときのメニュー中の (Windows 2000/XPのみ) 、EasyEjectのActionの実行を選択します。 EasyEject ユーティリティの実行の方法や、EasyEjectのActionの実行を選択したときに停止させるデバイスを設定する方法については、EasyEjectの設定の変更を参照してください。

EasyEjectを使って拡張ユニット（ドック）、ミニ・ドック、ウルトラベースからThinkPad PCを安全に取り外すために必要なすべてのデバイスを自動的に停止させるには、Fn+F9を押してThinkPad PCを取り外すを選択します。この機能を使用するためには、Fn+F9の機能を、EasyEject メニューを表示させるか、ThinkPad PCを取り外す機能を直接実行するかに設定しておく必要があります。Fn+F9の機能を設定する方法については、EasyEjectの設定の変更を参照してください。

EasyEjectのActionの実行 または ThinkPad PCを取り外すを選択した後には、個々のデバイスの状況を示す画面が表示されます。それによって、デバイスを安全に取り外すことができるかどうかを知ることができます。

注意: ThinkPadのいくつかのモデルでは、Fn+F9 キーをサポートしていません。


商標および登録商標

以下の用語は、レノボのアメリカ合衆国およびその他の国における 商標または登録商標です :

  • ThinkPad

以下の用語は、他社が所有している商標または登録商標です :

  • Microsoft : Microsoft Corporation

  • Windows : Microsoft Corporation

  • PCMCIA : Personal Computer Memory Card International Association