Preventing problems

An important part of owning a ThinkPad computer is maintenance. With proper care, you can avoid common problems. The following sections provide information that can help you to keep your computer running smoothly.

General tips for preventing problems

Backup-and-restore tools

Backing up your system

Data backup-and-restore tools

Checking for viruses

Making sure device drivers are current

Caring for your ThinkPad computer


Backing up data

Hard disks are reliable data storage devices. However, you should protect yourself against accidental data loss or the unlikely event of a hard disk malfunction by backing up your important files regularly.

  1. To start the backup application, click this button:
  2. Make sure that the Create a new backup job button is marked.
  3. Click OK. The Backup Wizard will guide you through backing up some or all of the files on your hard disk.


Backing up your system

When you add software applications or devices to your computer, the installation process might change your registry and configuration.

If your computer does not work properly after you add applications or devices, restore the previous registry.

Before you make changes, backup the configuration. If something goes wrong, you can restore the system registry and configuration files.

To capture or restore a snapshot of your system registry and configuration, click one of the following buttons depending on your operating system and follow the on-screen instructions.

Windows 98 or Windows 2000

Windows XP


Data backup-and-restore tools

If you are not already using a data backup program, you should. If the information stored on your computer is critical to the operation of your business, backing up your data on a regular basis is a must.

Large companies

Many large companies provide backup and restore services as part of their Information Technology (IT) infrastructure. Check with your network administrator to see what services are available.

Small businesses and individual PC users

The IBM backup and restore program, powered by XPoint Technologies, provides backup and recovery protection for your important data. This includes all personal files, applications, registry files, system files, Internet productivity files, and personal settings. Intended for individual PC users and small businesses, the IBM backup and restore program makes regular backup and recovery protection simple and easy.

The IBM backup and restore program is available from the IBM Web site. As improvements and new releases become available, they will also be made available on the IBM Web site.

To download the IBM backup and restore program from the IBM Web site, connect to the Internet; then, click the following button.


Backup-and-Restore tools

It is important to back up the data you create as well as critical system files that contain configuration information about your computer.

  • For information about tools used to back up critical system files and settings only, see Configuration backup-and-restore tools.

  • For information about tools used to back up data (including the operating system, system files and settings, personal files, applications, Internet productivity files, and personal settings) see Data backup-and-restore tools.


Checking for viruses

To protect your computer against viruses that can delete important files or make using your computer frustrating, use antivirus software to keep your computer free of viruses.

Keeping your virus protection up-to-date

Depending on your choice of anti-virus software, with an Internet connection, you can generally access the latest virus list available on the software provider Web site. You can also download the latest anti-virus protections to keep your ThinkPad computer running smoothly.


Making sure device drivers are current

Device drivers are programs that contain instructions for the operating system about how to operate or "drive" a certain piece of hardware. Each hardware component on your computer has its own specific driver. If you add a new component, the operating system needs to be instructed on how to operate that piece of hardware. After you install the driver, the operating system can recognize the hardware component and understand how to use it.

Note: Because drivers are programs, like any other file on your computer, they are susceptible to corruption and might not perform properly if corruption occurs.

It is not always necessary to download the latest drivers; however, when you notice poor performance from a component or add a new component, it is time to download the latest driver for that component to eliminate the driver as the cause of the problem.

  1. Access the following Web site: http://www.ibm.com/pc/us/support/thinkpad/tpopsys.html . When you get to the site, find your model (for example A30, T20, X20, etc.) and click it once.
  1. Locate the correct component and operating system from the list provided and click on the link.
  1. This page contains the actual drivers (it is the blue link with the extension .exe) which you can download in addition to the installation instructions. Notes are included detailing the latest additions made to the driver.
  1. Running the .exe file only extracts the file your hard disk. You will then need to run the setup or follow the installation instructions to install the .inf file.
  1. After you receive a message that the file has completely downloaded, close all the programs that you have been running. Find the file that you just downloaded and double-click on it to execute it. The driver(s) extract on your hard disk drive. For some older files and all BIOS files, you are required to insert a blank 3." floppy diskette to extract the files to.
  1. Follow the installation instructions from the Web page to perform the installation.

Note: If you would like to be notified when updated drivers are provided, IBM has created a Profile page that will notify you of any important news regarding your IBM ThinkPad computer. To setup your own profile page, click on the "Profile" link at the top of the Web page. Follow the directions to be notified via email whenever a new driver is available for your ThinkPad computer.


General tips for preventing problems

  1. Check your hard disk drive capacity from time to time. Windows(R) will slow down and might produce errors if the hard disk drive gets too full.
    2. Note: You can check your drive space by double left-clicking the "My Computer" icon from the Windows desktop; then single right-clicking on the desired drive to produce a menu. From that menu, single left-click on "Properties."
  2. Empty your recycle bin on a regular basis.
  3. Use the Microsoft(R) Disk Defragmenter (Windows(R) 98, Windows Me, and Windows 2000) on your hard disk drive on a regular basis to improve data seek and read times. To start the Disk Defragmenter, access Start --> Programs --> Accessories -->System Tools --> Disk Defragmenter.
  4. To free up disk space, uninstall unused application programs.
    5. Note: You might also want to look for application program duplication or overlapping versions.
  5. Clean out your Inbox, Sent, and Trash folders from your e-mail client program.
  1. At least once a week, make a point to back up your data. If critical data is present, it is a good idea to perform a daily backup. IBM has many backup options available for your ThinkPad(R) computer. Zip drives, LS-120 drives and CD-RW drives are available for most machines and are easily installed.
  1. Use or schedule ConfigSafe to take a system snapshot periodically.
    2. Note: Always take a system snapshot before installing new drivers, updating software, or installing new software.
  2. Update device drivers when needed.
  1. Profile your machine at http://www.pc.ibm.com/support to keep up to date with current drivers and revisions.
  1. Keep up to date for device drivers on other non-IBM hardware. You might want to read the device driver information release notes prior to updating for compatibility or known issues.
  1. Keep a log book. Entries might include major hardware or software changes, driver updates, minor issues you have experienced and how you resolved them.
  1. If you ever need to run a recovery on your computer to return the IBM preload onto the machine, the following tips might help along the way:

    • Remove all external devices such as the printer, keyboard, etc.

    • Make sure that your battery is charged and that you have the ac power connected.

    • Boot into the BIOS and load the default settings.

    • Restart the machine and start the recovery.

    • If your machine uses CD-ROMs as the recovery media, DO NOT remove the CD-ROM from the drive until prompted to do so.

  1. For suspected hard disk drive issues, download the IBM Fitness Test prior to calling the Help Center. If the Drive Fitness Test returns any error codes, call the IBM Help Center with the codes and the computer in front of you. An IBM technician will assist you in further problem determination or aid you in servicing or replacing the hard disk drive.
    2. Note: You can download the drive fitness test at http://www.storage.ibm.com/techsup/hddtech/welcome.htm free of charge.
  2. If required, you can find your country's IBM Help Center at the following Web address: http://www.pc.ibm.com/qtechinfo/MIGR-4HWSE3.html . When calling the IBM Help Center, please make sure you have your machine model type, serial number and the computer in front of you. Also, if the machine is producing error codes, it is helpful to have the error screen on or the message written down.


Caring for your ThinkPad computer

Although your computer is designed to function reliably in normal work environments, you need to use common sense in handling it. By following these important tips, you will get the most use and enjoyment out of your computer.

Important tips:

Be careful about where and how you work

Be gentle with your computer

Carry your computer properly

Handle storage media and drives properly

Take care in setting passwords

Other important tips

Cleaning your computer

Be careful about where and how you work

  • Avoid leaving the base of your computer in contact with your lap or any part of your body for an extended period when the computer is turned on or when the battery is charging. Your computer generates some heat during normal operation. This amount of heat is a function of the level of system activity and battery charge level. Extended contact with your body, even through clothing, could cause discomfort or even a skin burn.

  • Place liquids away from your computer to avoid spills, and keep your computer away from water (to avoid the danger of electrical shock).

  • Store packing materials safely out of the reach of children to prevent the risk of suffocation from plastic bags.

  • Keep your computer away from magnets, activated cellular phones, electrical appliances, or speakers (within 13cm or 5 in).

  • Avoid subjecting your computer to extreme temperatures (below 5 degrees Celsius/41 degrees Farenheit or above 35 degrees Celsius/95 degrees Farenheit).

Be gentle with your computer

  • Avoid placing any objects (including paper) between the display and the keyboard or under the keyboard.

  • Do not drop, bump, scratch, twist, hit, vibrate, push or place heavy objects on your computer, display, or external devices.

  • Your computer display is designed to be opened and used at an angle slightly greater than 90 degrees. Do not open the display beyond 135 degrees, as this might damage the computer hinge.

Carry your computer properly

  • Before moving your computer, be sure to remove any media, turn off attached devices, and disconnect cords and cables.

  • Be sure your computer is in standby or hibernation mode, or turned off, before moving it. This will help prevent damage to the hard disk drive and data loss.

  • When picking up your open computer, hold it by the bottom. Do not pick up or hold your computer by the display.

  • Use a quality carrying case that provides adequate cushion and protection. Do not pack your computer in a tightly packed suitcase or bag.

Handle storage media and drives properly

  • If your computer comes with a diskette drive, avoid inserting diskettes at an angle and attaching multiple or loose diskette labels, as these can lodge in the drive.

  • If your computer comes with a CD or DVD drive, do not touch the surface of a CD or the lens on the CD or DVD tray.

  • Wait until you hear the CD or DVD click into the center pivot of the CD or DVD drive before closing the CD or DVD tray

  • When installing your hard disk, diskette, CD, or DVD drive, follow the instructions shipped with your hardware, and apply pressure only where needed on the device.

Take care in setting passwords

  • Remember your passwords. If you forget a supervisor or hard disk password, IBM will not reset it, and you might have to replace your system board or hard disk drive.

  • If you are an administrator, remember that setting a supervisor password can prevent unauthorized initialization.

Other important tips

  • Your computer modem may use only an analog telephone network, or public-switched telephone network (PSTN). Do not connect the modem to a PBX (private branch exchange) or any other digital telephone extension line because this could damage your modem. Analog phone lines are often used in homes, while digital phone lines are often used in hotels or office buildings. If you are not sure which kind of phone line you are using, contact your telephone company.

  • Your computer might have both an Ethernet connector and a modem connector. If so, be sure to connect your communication cable to the correct one, so your connector is not damaged.

  • Register your ThinkPad products with IBM (refer to the Web page: http://www.ibm.com/pc/register). This can help authorities return your computer to you if it is lost or stolen. Registering your computer also enables IBM to notify you about possible technical information and upgrades.

  • Only an authorized IBM ThinkPad repair technician should disassemble and repair your computer.

  • Do not modify or tape the latches to keep the display open or closed.

  • Take care not to turn your computer over while the ac adapter is plugged in. This could break the adapter plug.

  • Turn off your computer if you are replacing a device in a device bay, or else verify that the device is warm- or hot-swappable.

  • If you exchange drives in your computer, reinstall the plastic bezel faces (if supplied).

  • Store your external and removable hard disk, diskette, CD, and DVD drives in the appropriate containers or packaging when they are not being used.

Cleaning your computer

Occasionally clean your computer as follows:

  • Use a soft cloth moistened with nonalkaline detergent to wipe the exterior of the computer.

  • Avoid spraying cleaner directly on the display or the keyboard.

  • Gently wipe the display with a soft, dry cloth. If you see a scratchlike mark on your display, it might be a stain transferred from the keyboard or the TrackPoint pointer when the cover was pressed from the outside. Wipe or dust the stain gently with a soft, dry cloth. If the stain remains, moisten a soft, lint-free cloth with water that does not contain impurities, wring out as much of the water as you can, and then wipe the display again. Be sure to dry the display before closing it.