запрос на изменение <термины Jet>

запрос на изменение

Запрос, позволяющий перемещать или изменять данные. К запросам на изменение относятся запросы на добавление записей, на создание таблиц, на удаление записей и на обновление записей. Запросы на удаление и на обновление записей изменяют существующие данные; запросы на добавление записей и на создание таблицы перемещают существующие данные. В SQL эти запросы называют запросами на языке обработки данных (DML); они включаю ключевые слова DELETE, INSERT и UPDATE. Microsoft® Jet поддерживает ключевое слово SELECT INTO, которое также рассматривается как запрос DDL. В противовес этим запросам, запросы на выборку возвращают данные записей. Запрос к серверу SQL также может быть запросом на изменение.


объекты ADO (Active Data Objects) <термины Jet>

объекты ADO (Active Data Objects)

Программный интерфейс, обеспечивающий доступ и управление объектами базы данных.


статистическая функция <термины Jet>

статистическая функция

Функция, например Sum, Count, Avg или Max, которая используется для вычисления итоговых значений. Создавая выражение или текст программы, применяйте для различных статистических вычислений статистические функции языка SQL (включая перечисленные выше) и статистические функции по подмножеству.


псевдоним <термины Jet>

псевдоним

Visual Basic: псевдоним является альтернативным именем, которое присваивается внешней процедуре для предотвращения конфликтов с ключевым словом Microsoft® Visual Basic®, глобальной переменной, константой или именем, не соответствующим правилам именования Visual Basic.

SQL: псевдоним является альтернативным именем, которое присваивается полю или выражению в инструкции SELECT (с помощью предложения AS). В ANSI псевдоним называют корреляционным именем.


набор символов ANSI <термины Jet>

набор символов ANSI

8-битовый набор символов, разработанный ANSI (American National Standards Institute), который используется в Microsoft® Windows® и позволяет представлять до 256 символов (с кодами от 0 до 255). Набор символов ASCII является подмножеством набора ANSI.


режим ANSI SQL-92 <термины Jet>

режим ANSI SQL-92

Режим учитывающий расширенный синтаксис SQL и обеспечивающий большую совместимость с SQL-92 и Microsoft® SQL Server™. Этот режим доступен только в случае использования программы Microsoft OLE DB Provider для Jet. Его невозможно установить с помощью объектов доступа к данным (DAO). Новые средства относятся преимущественно к языку определения данных (DDL). Поддержка подстановочных знаков ANSI, т.е. знак процента (%) и символа подчеркивания (_), также является частью режима ANSI SQL-92.


запрос на добавление <термины Jet>

запрос на добавление

Запрос на изменение, который добавляет новые записи в конец существующей таблицы или запроса. Запросы на добавление не возвращают записи (строки). В синтаксисе SQL запрос содержит ключевое слово INSERT.


аргумент <термины Jet>

аргумент

Константа, переменная или выражение, которые передают дополнительные сведения в макрокоманду, процедуру или метод. Пользователь использует аргументы в выражении для передачи дополнительных сведений, необходимых для некоторых макрокоманд.


массив <термины Jet>

массив

Переменная, содержащая конечный набор элементов, имеющих общее имя и тип данных. Каждый элемент массива имеет определяющий его уникальный номер (индекс). Изменение одного элемента массива не приводит к изменению других элементов.


набор символов ASCII <термины Jet>

набор символов ASCII

7-битовый стандартный набор символов (American Standard Code for Information Interchange), который широко используется для представления букв и цифр, расположенных на стандартной американской клавиатуре. Символы кодировки ASCII совпадает с первыми 128 символами (с кодами 0 ѕ 127) набора символов ANSI.


звездочка <термины Jet>

звездочка

Знак «звездочка» (*) используется как подстановочный символ в выражениях LIKE языка SQL для обеспечения приема любой строки символов. Например, выражение LIKE "*град*" позволяет принять любое имя, содержащее строку «град».

Используйте знак звездочки при создании запросов или вводе инструкций на языке SQL, чтобы включить все поля основной таблицы или запроса. Например, инструкция SELECT * FROM МояТаблица возвращает все поля (столбцы) из указанной таблицы.

При отправке запроса с помощью Microsoft® OLE DB Provider для Jet звездочку нельзя использовать как подстановочный знак. Подстановочным знаком ANSI является знак процента (%). На сохраненные процедуры это влияния не оказывает, но новые запросы (представления), создаваемые с помощью Microsoft OLE DB Provider для Jet, потребуют использования подстановочных знаков ANSI, знака процента (%) и символа подчеркивания (_), для получения результатов, аналогичных получаемых с использованием звездочки (*) и вопросительного знака (?). Microsoft OLE DB Provider для Jet транслирует звездочку и вопросительный знак как литералы; поэтому возвращаемый результирующий набор записей будет отличаться от полученного через интерфейс пользователя Microsoft Access UI или объекты доступа к данным (DAO).


асинхронный запрос <термины Jet>

асинхронный запрос

Тип запроса, в котором немедленно происходит возвращение из запросов SQL, даже при наличии ожидаемых результатов. Это позволяет выполнять в приложении другие процессы по мере ожидания результатов завершения запроса.


поле счетчика <термины Jet>

поле счетчика (AutoNumber)

Тип данных поля, в котором сохраняется уникальный номер каждой записи при добавлении записи в таблицу. Значения в поле счетчика всегда имеют тип данных Long. Значения, генерируемые в поле счетчика, не могут быть изменены пользователем, если не предоставлено специальное разрешение на таблицу с помощью инструкции Grant или Revoke в синтаксисе SQL DDL. Поля с типом AutoNumber часто называют полями с типом данных Counter или Identity. При использовании языка определения данных SQL DDL этот тип данных теперь поддерживает изменяемые начальные значения и величину инкремента. Это отличается от предыдущих версий, в которых использовались начальное значение 1 и инкремент 1.

См. также

атрибут Identity

начальное значение

инкремент


основная таблица <термины Jet>

основная таблица

Таблица базы данных Microsoft® Jet. Таблицы являются основными объектами структуры реляционной базы данных, в которых данные сохраняются в виде записей и полей. Для изменения или использования структуры основной таблицы используются объекты доступа к данным или инструкции SQL языка определения данных (DDL). Для изменения данных в основной таблице используются объекты Recordset или запросы на изменение.


тип данных Big Integer <термины Jet>

тип данных Big Integer

Тип данных для сохранения точных числовых значений с 19 разрядами (со знаком) или с 20 разрядами (без знака) с фактором масштабирования n (со знаком: -263 ≤ n ≤ 263-1; без знака: 0 ≤ n ≤ 264-1).


тип данных Binary <термины Jet>

тип данных Binary

Тип данных для сохранения двоичных данных фиксированной длины. Максимальная длина составляет 255 байт.


закладка (Bookmark) <термины Jet>

закладка (Bookmark)

Свойство объекта Recordset, которое содержит двоичную строку, указывающую на текущую запись. Если присвоить значение свойства Bookmark переменной, а затем перейти к другой записи, то имеется возможность вновь сделать предыдущую запись текущей, задав для свойства Bookmark значение этой строковой переменной.


логическое выражение <термины Jet>

логическое выражение

Выражение, результатом вычисления которого является значение True или False.


тип данных Boolean <термины Jet>

тип данных Boolean

Значения Истина/Ложь (True/False) или «Да»/«Нет». В базе данных Microsoft® Jet значения типа Boolean обычно хранятся в полях типа Bit. Однако некоторые базы данных не поддерживают этот тип данных.


тип данных Byte <термины Jet>

тип данных Byte

Основной тип данных, который используется для хранения положительных целых чисел в диапазоне от 0 до 255.


скалярное произведение <термины Jet>

скалярное произведение

Результат объединения двух реляционных таблиц, содержащий все возможные упорядоченные комбинации строк первой таблицы со всеми строками второй таблицы.

Обычно скалярное произведение является результатом выполнения инструкции SELECT языка SQL, использующей не менее двух таблиц в предложении FROM и не включающей предложения WHERE или JOIN, которые задают способ объединения этих таблиц.


каскад <термины Jet>

каскад

Процесс запуска одного действия с помощью другого. Например, когда для нескольких таблиц определены связи с каскадными обновлениями, обновление ключевого поля главной таблицы вызывает автоматический запуск (каскад) изменений во внешней таблице с ключом.

Теперь такие процессы можно определить в инструкциях SQL DDL.


каскадное удаление <термины Jet>

каскадное удаление

Средство поддержания целостности данных двух связанных таблиц. Благодаря ему удаление записи из главной таблицы приводит к автоматическому удалению всех связанных записей из одной или нескольких внешних таблиц с ключами.

Например, можно установить связь между таблицей «Клиенты» (главной) и «Заказы» (внешней) и разрешить каскадное удаление. Тогда при удалении записи в таблице «Клиенты» из внешней таблицы «Заказы» будут удалены все записи, связанные с этим клиентом.

Теперь такие процессы можно определить в инструкциях SQL DDL.


каскадное обновление <термины Jet>

каскадное обновление

Средство поддержания целостности данных двух связанных таблиц. Благодаря ему внесение изменений в ключевое поле записи, находящейся в главной таблице, приводит к автоматическому обновлению ключевого поля в связанных записях одной или нескольких связанных внешних таблиц с ключами.

Например, можно установить связь между таблицей «Клиенты» (главной) и «Заказы» (внешней) и разрешить каскадное обновление. Тогда при изменении первичного ключа в записи в таблице «Клиенты» во внешней таблицы «Заказы» будут обновлены все записи, связанные с этим клиентом.

Теперь такие процессы можно определить в инструкциях SQL DDL.


каскадные значения NULL <термины Jet>

каскадные значения NULL

Средство поддержания целостности данных двух связанных таблиц. Благодаря ему удаление строки в главной таблице приводит к автоматическому заполнению ключевых полей в связанных записях одной или нескольких связанных внешних таблиц значениями NULL.

Теперь такие процессы можно определить в инструкциях SQL DDL.

Например, можно установить связь между таблицей «Клиенты» (главной) и «Заказы» (внешней) и включить каскадные значения NULL. Тогда при удалении первичного ключа в таблице «Клиенты» во внешней таблицы «Заказы» все записи, связанные с этим клиентом, получать значения NULL в ключевых полях.


учет регистра <термины Jet>

учет регистра

Учет различия прописных и строчных букв. Поиск с учетом регистра обеспечивает поиск только того текста, прописные и строчные буквы которого полностью совпадают с искомыми. При таком поиске строки «месяц январь» и «Месяц январь» будут считаться разными. Операции базы данных Microsoft® Jet проводятся без учета регистра. Однако учет регистра используется в некоторых других системах управления базами данных.


тип данных Char <термины Jet>

тип данных Char

Тип данных для сохранения строковых значений фиксированной длины. Длина строки задается в свойстве Size.


ограничение CHECK <термины Jet>

ограничение CHECK

Средство ANSI SQL-92, позволяющее накладывать правила, действующее на всю таблицу или на многие создаваемые таблицы. Примером может служить создание таблиц «Заказчики и «Заказы». На таблицу «Заказы» можно наложить ограничение CHECK, запрещающее клиентам заказы на сумму, превышающую их кредитный лимит, определенный в таблице «Заказчики».


класс <термины Jet>

класс

Формальное определение объекта. Класс является шаблоном, на основе которого во время выполнения программы создается объект. Класс определяет свойства объекта и методы, используемые для управления поведением объекта.


библиотека пакетных указателей клиента <термины Jet>

библиотека пакетных указателей клиента

Библиотека, обеспечивающая поддержку указателя набора записей на стороне клиента для приложений баз данных ODBCDirect. Такая библиотека поддерживает все четыре типа указателей набора записей (ключевой, статический, динамический и с последовательным доступом), а также ряд других средств, включая возможность разрыва подключений и выполнение пакетного обновления с нежесткой блокировкой.


кластерный индекс <термины Jet>

кластерный индекс

Обеспечивает совпадение физического порядка набора строк с порядком строк в индексе.


семейство <термины Jet>

семейство

Объект, содержащий набор связанных объектов. Положение объекта в семействе может изменяться при внесении изменений в семейство. Поэтому положение каждого конкретного объекта в семействе не является постоянным.


конфликт обновления <термины Jet>

конфликт обновления

Конфликт, возникающий при пакетном обновлении.

Конфликт обновления имеет место, когда клиент читает данные с сервера, а затем пытается изменить эти данные в операции пакетного обновления. Однако до фактического выполнения попытки обновления другой клиент успел изменить исходные данные на сервере. В этой ситуации первый клиент пытается изменить данные на сервере, фактически не зная точно, какие данные обновляются.


столбец <термины Jet>

столбец

Визуальное представление поля при выводе таблицы в формате строк и столбцов. Столбец определяет тип данных, размер и другие характеристики одного поля в строке (записи) данных. Все столбцы, взятые вместе, определяют строку (запись) базы данных. Конкретный столбец содержит данные подходящего типа, который используется во всей таблице; т.е. определение столбца не меняется от строки к строке.


отслеживание на уровне столбцов <термины Jet>

отслеживание на уровне столбцов

Механизм отслеживания на уровне столбцов, в котором в обнаружении и устранении конфликта участвует каждый столбец в строке. Если одна и та же строка оказывается измененной в нескольких репликах, но в каждой из конфликтующих реплик изменен уникальный столбец, конфликт не возникает, и все изменения объединяются.


завершение транзакции <термины Jet>

завершение транзакции

Завершение текущей транзакции. Если начать транзакцию, используя DAO, ADO или SQL, ни одно изменение не будет записано в базу данных, пока транзакция не будет завершена.


составной запрос <термины Jet>

составной запрос

Запрос, в состав которого входят по крайней мере один запрос на изменение (копирующий или изменяющий данные) и по крайней мере один запрос на выборку (возвращающий объект Recordset без изменения данных). В объектах доступа к данным (DAO) составной запрос образуется путем объединения в значении свойства SQL объекта QueryDef двух или нескольких инструкций SQL (разделяемых символом точки с запятой).


строка подключения <термины Jet>

строка подключения

Строка, используемая для определения источника данных во внешней базе данных. Обычно строка подключения помещается в значение свойства Connect объекта QueryDef, TableDef, Connection или Database, или становится аргументом метода OpenDatabase.


согласованный <термины Jet>

согласованный

Состояние многотабличного объекта Recordset, которое позволяет выполнять только те обновления, при котором сохраняется согласованность между данными. Например, для объекта Recordset, являющегося результатом объединения двух или нескольких таблиц (в отношении «один-ко-многим»), в правильном запросе невозможно задать для ключа таблицы со стороны «многие» значение, которое не содержится в таблице со стороны «один».


константа <термины Jet>

константа

Именованный элемент, значение которого не изменяется во время выполнения программы, в отличие от переменной. В каждом главном приложение может быть определен собственный набор констант. Дополнительные константы определяются пользователем с помощью инструкции Const. Константы могут использоваться в любых местах программы вместо указания реальных значений. Существуют строковые и числовые константы в явном представлении (литералы), константы других типов или произвольные комбинации констант, использующие арифметические или логические операторы, за исключением оператора Is и возведения в степень. Например:

Const strdb = "c:\Program Files\Microsoft Office\Access\Samples\Борей.mdb"


ограничение <термины Jet>

ограничение

Ограничение на значения, которые пользователь может ввести в поле. Ограничение CHECK языка определения данных (DDL) ANSI SQL включается в ядро Microsoft® Jet версии 4.X в случае использования приложения Microsoft OLE DB Provider для Jet. Ограничение CHECK позволяет определять правила, действующие на всю таблицу или на несколько других таблиц.


буфер копирования <термины Jet>

буфер копирования

Область, создаваемая ядром базы данных Microsoft® Jet, в которой хранится содержимое записи, открытой для внесения изменений. Метод Edit копирует текущую запись в буфер копирования; метод AddNew очищает буфер для новой записи и устанавливает стандартные значения; метод Update сохраняет в базе данных данные из буфера копирования, заменяя текущую запись или вставляя новую запись. Любая инструкция, перемещающая указатель текущей записи, удаляет содержимое буфера копирования. Например, применение метода MoveNext или изменение значения свойства Index таблицы приводят к сбросу содержимого буфера копирования.


корреляционное имя <термины Jet>

корреляционное имя

Определение ANSI для имени, используемого для ссылки на столбец в таблице или представлении (сохраненном запросе). Используется также термин «псевдоним».


тип данных AutoNumber <термины Jet>

тип данных AutoNumber

Атрибут поля, задающий автоматическое сохранение уникального номера при добавлении записи в таблице. Поле счетчика является полем таблицы с типом данных Long, у которого в свойстве Attributes задана константа dbAutoIncrement. Значения, генерируемые в поле счетчика, не могут быть изменены пользователем, если не предоставлено специальное разрешение на таблицу с помощью инструкции Grant или Revoke в синтаксисе SQL DDL. Поля с типом AutoNumber часто называют полями с типом данных Counter или Identity.

Примечание. Для реплицированных таблиц в реплицированной базе данных значение поля счетчика не увеличивается на единицу. Вместо этого полю присваивается уникальное случайное значение в диапазоне от -2 000 000 000 до 2 000 000 000.

См. также

атрибут Identity


условие отбора <термины Jet>

условие отбора

Набор ограничивающих условий, например, = "Россия" (означает: равно строке «Россия») или > 30000, который используется при создании запроса или фильтра для отображения конкретного набора записей.


перекрестный запрос <термины Jet>

перекрестный запрос

Запрос, в котором рассчитывается сумма, среднее значение, число записей или другие типы итоговых значений, а затем данные возвращаются в виде электронной таблицы, используя указанные поля как заголовки строк и столбцов. Например, в базе данных «Борей» перекрестным является запрос, демонстрирующий поквартальное распределение заказов.


управляющий символ <термины Jet>

управляющий символ

Любое сочетание клавиш с начальной клавишей CTRL или ESC.


тип данных Currency <термины Jet>

тип данных Currency

Этот тип данных используется в вычислениях, включающих денежные величины или величины с фиксированной точкой, для которых особенно важна точность вычислений. Этот тип данных позволяет хранить числа, имеющие до 15 цифр в целой части и до 4 в дробной. Поскольку тип данных Currency использует масштабируемые целочисленные значения, округление при вычислении итоговых значений не существенно.


текущая база данных <термины Jet>

текущая база данных

Объект Database, возвращаемый функцией CurrentDB( ). Ссылка DBEngine.Workspaces(0).Databases(0) возвращает первую открытую базу данных. Это понятие применимо только в Microsoft® Access.


текущий индекс <термины Jet>

текущий индекс

Для индексированного объекта Recordset типа таблицы, последний индекс, установленный с помощью свойства Index. Данный индекс является основой для упорядочивания записей в Recordset и используется в методе Seek для поиска записей. Для объекта Recordset возможно задание более одного индекса, но допускается использование только одного индекса одновременно (хотя для объекта TableDef возможно определение нескольких индексов). Ядро базы данных Microsoft Jet может использовать несколько индексов для вычисления результатов запроса.


текущая запись <термины Jet>

текущая запись

Запись в объекте Recordset, данные которой можно изменять или просматривать. Для переходов к другой записи набора пользуйтесь методами группы Move. Для изменения позиции текущей записи в соответствии с заданным условием отбора пользуйтесь методами группы Find (с объектами Recordset типа динамического и статического наборов) или методом Seek (с объектом Recordset типа таблицы).

В объекте Recordset только одна запись может быть текущей; однако, объект Recordset может не иметь текущей записи. Например, после удаления записи из динамического набора Recordset или, когда объект Recordset не содержит записи, текущая запись не определена. В этом случае, операции, относящиеся к текущей записи, приводят к возникновению перехватываемой ошибки.


текущая транзакция <термины Jet>

текущая транзакция

Все изменения, сделанные в объекте Recordset после последнего вызова метода BeginTrans и до вызова метода Rollback или CommitTrans.


объекты доступа к данным (DAO) <термины Jet>

объекты доступа к данным (DAO)

Программный интерфейс, обеспечивающий доступ и управление объектами базы данных.


объект доступа к данным (DAO) <термины Jet>

объект доступа к данным (DAO)

Объект, определенный в библиотеке объектов доступа к данным (DAO). Объекты доступа к данным, такие как Database, TableDef, Recordset и QueryDef, предназначены для представления объектов, используемых в тексте программы для организации и обработки данных, например, таблиц или запросов.


ядро базы данных <термины Jet>

ядро базы данных

Часть системы управления базами данных, которая отвечает за загрузку и сохранение данных в пользовательских и системных базах данных.


язык определения данных (DDL) <термины Jet>

язык определения данных (DDL)

Язык, используемый для описания атрибутов базы данных, особенно таблиц, полей, индексов и способов сохранения данных. ANSI определяет конструкции DDL как имеющие ключевые слова CREATE, DROP и ALTER.


управляющий запрос <термины Jet>

управляющий запрос

Запрос SQL, предназначенный для создания, изменения, удаления таблицы или для создания или удаления индекса в базе данных. ANSI определяет такие запросы как запросы DDL и использует ключевые слова CREATE, DROP и ALTER.

См. также

язык определения данных (DDL)


источник данных <термины Jet>

источник данных

Источник с именем, поддерживающий протокол ODBC, который определяет место сохранения, тип драйвера и другие параметры, необходимые драйверу ODBC для доступа к базе данных ODBC. Источник данных может быть любым источником со сведениями для базы данных.


тип данных <термины Jet>

тип данных

Характеристики переменной, определяющие тип данных, которые могут храниться в этой переменной. Предусмотрены следующие типы данных: Big Integer, Binary, Byte, Boolean, Char, Currency, Date, Decimal, Double, Float, GUID, Integer, Long, Long Binary (OLE Object), Memo, Numeric, Single, String, Text, Time, TimeStamp, VarBinary, Variant (используемый по умолчанию), типы, определенные пользователем (создаваемые с помощью инструкции Type), и объектные типы данных, которые включают объектные типы данных приложения и типы объектов доступа к данным.


литерал даты <термины Jet>

литерал даты

Любая последовательность символов в допустимом формате, которая окружена знаками номера (#). К допустимым форматам относятся формат дат, заданный в локальной национальной настройке, и стандартный формат дат.

Например, #31.12.94# является литералом (константой в явном представлении) даты, обозначающим дату 31 декабря 1994 года, если в локальной настройке данного приложения указан русский язык. Литералы даты следует применять для облегчения переносимости программы с одного языка на другой.


дата и время <термины Jet>

дата и время

Во внутреннем представлении значения даты и времени сохраняются в разных частях действительного числа.

Значение целой части означает дату от 30 декабря 1899 г. до 30 декабря 9999 г. (включительно). Отрицательные числа представляют даты до 30 декабря 1899 г.

Значение дробной части числа означает время от 0:00:00 до 23:59:59 (включительно). Полдень обозначается величиной 0,5.


тип данных Decimal <термины Jet>

тип данных Decimal

Тип данных для сохранения точных числовых значений со знаком с p разрядами и фактором масштабирования s (1 ≤ p ≤ 15; 0 ≤ s ≤ p).


стандартная рабочая область <термины Jet>

стандартная рабочая область

Объект Workspace, который программное обеспечение объектов доступа к данным (DAO) автоматически устанавливает при первом обращении приложения к любому объекту доступа к данным. Для ссылки на этот объект Workspace используется синтаксис DBEngine.Workspaces(0) или Workspaces(0).


запрос на удаление записей <термины Jet>

запрос на удаление записей

Запрос на изменение, который удаляет набор строк, соответствующих указанному условию отбора. Запрос на удаление не возвращает строки.


время разработки <термины Jet>

время разработки

Время, в течение которого в среде разработчика создается структура приложения, т.е. добавляются элементы управления, задаются значения свойств элементов управления и форм и т.п. В отличие от этого, во время выполнения взаимодействие с программой происходит на уровне пользователя.


выходное поле <термины Jet>

выходное поле

Поле в запросе, которое будет содержать результаты запроса.


прямая синхронизация <термины Jet>

прямая синхронизация

Тип синхронизации, при котором две реплики одновременно могут быть открыты в процессе синхронизации.


библиотека динамической компоновки (DLL) <термины Jet>

библиотека динамической компоновки (DLL)

Библиотека подпрограмм, загружаемых и связываемых в приложении во время выполнения.


тип данных Double <термины Jet>

тип данных Double

Основной тип данных, предназначенный для сохранения плавающих чисел с двойной точностью в формате IEEE. Переменная типа Double запоминается в виде чисел длиной 64 бит (8 байт) со значениями от -1.79769313486231E308 до -4.94065645841247E-324 для отрицательных значений, от 4.94065645841247E-324 до 1.79769313486231E308 для положительных значений и значения 0.


динамический указатель набора записей <термины Jet>

динамический указатель набора записей

Динамический набор строк, которые могут быть использованы для добавления, изменения или удаления строк в базовой таблице или таблицах. Динамический указатель может содержать столбцы из одной или нескольких таблиц в базе данных. Состав при этом не является фиксированным.


динамический набор записей <термины Jet>

динамический набор записей

Тип объекта Recordset, который возвращает динамический набор указателей на существующие данные в базе данных. Как табличный или статический набор записей объекта Recordset, динамический набор возвращает данные в записях (строках) и полях (столбцах). В отличие от табличного объекта Recordset, динамический объект Recordset может быть результатом запроса, объединяющего несколько таблиц. Записи динамических объектов Recordset можно изменять, если для их свойства Updatable задано значение True, изменяемый объект Field является обновляемым, и не заблокирована страница данных, содержащая текущую запись. Страница данных блокируется при вызове метода Update (когда свойство LockEdits имеет значение False) или при вызове метода Edit (когда свойство LockEdits имеет значение True).


симметричное объединение <термины Jet>

симметричное объединение

Объединение, при котором записи двух таблиц объединяются и добавляются в объект Recordset только в том случае, если они имеют равные значения в связанных полях. Это объединение называют также внутренним объединением.


монопольный доступ <термины Jet>

монопольный доступ

Тип доступа, обеспечивающий защиту данных при работе в сети. Если база данных открыта для монопольного доступа, другие пользователи открыть эту базу данных.


выражение <термины Jet>

выражение

Комбинация операторов, констант, констант в явном представлении (литералов), функций, а также имен полей, элементов управления и свойств, в результате вычисления которых получается одно значение. Выражения можно использовать для задания значений многих свойств и аргументов макрокоманд, для задания условий отбора или определения вычисляемых полей в запросе.


внешняя база данных <термины Jet>

внешняя база данных

Или база данных, поддерживающая протокол ODBC, такая как база данных Microsoft® SQL Server™, расположенная на удаленном сервере, или одна из внешних баз данных, таких как база данных Paradox, dBASE, Microsoft FoxPro®, Microsoft Excel, Microsoft Access, Lotus 1-2-3, HTML или база данных в текстовом формате.


внешняя таблица <термины Jet>

внешняя таблица

Таблица из базы данных, находящаяся вне открытой базы данных Microsoft® Jet. Внешняя таблица может существовать в виде файла или быть таблицей из другой реляционной базы данных.


поле <термины Jet>

поле

Категория сведений, которая хранится в таблице базы данных, образующих столбец данных. Элемент таблицы базы данных, который содержит конкретные сведения, например фамилию.


свойства поля <термины Jet>

свойства поля

Атрибуты поля, которые определяют вид содержащихся в нем данных. Примерами могут служить свойства Size и Type.


фильтр <термины Jet>

фильтр

Набор условий отбора, применяемых к записям для создания подчиненного набора записей.


тип данных Float <термины Jet>

тип данных Float

Тип данных для сохранения приближенных числовых значений со знаком с мантиссой из 15 разрядов (нуль или с абсолютными значениями в интервале от 10E-308 до 10E308).


внешний ключ <термины Jet>

внешний ключ

Одно или несколько полей таблицы, которые содержат ссылку на ключевое поле или поля другой таблицы. Внешний ключ определяет способ связывания таблиц, при котором значения полей внешнего ключа и ключа должны совпадать. Например, список допустимых кодов товаров может содержать внешний ключ таблицы товаров, со ссылками на допустимые коды товаров. Применяется для установления условий целостности данных в базе данных.


внешняя таблица с ключом <термины Jet>

внешняя таблица с ключом

Таблица базы данных, которая содержит внешний ключ к другой таблице. Обычно внешняя таблица с ключом используется для установления или поддержания целостности данных. Как правило, внешняя таблица с ключом находится на стороне «многие» отношения «один-ко-многим». Примером внешней таблицы с ключом является таблица заказов клиентов.


форма <термины Jet>

форма

Окно или диалоговое окно. Формы содержат элементы управления. Форма с многооконным интерфейсом (MDI) является контейнером для подчиненных форм и некоторых элементов управления.


указатель с последовательным доступом <термины Jet>

указатель с последовательным доступом

Результирующий набор записей, в котором указатель текущей записи можно перемещать только вперед на указанное число записей или на последнюю запись. Указатель текущей записи нельзя сдвинуть назад к началу набора записей или к предыдущим записям. Записи, принадлежащие этому указателю, их порядок и значения обычно являются фиксированными на момент открытия указателя. Если другие пользователи обновляют, удаляют или изменяют записи, эти изменения не отражаются в указателе до его закрытия и последующего открытия.


последовательный доступ <термины Jet>

последовательный доступ

Последовательное перемещение к концу (EOF) объекта Recordset.


статический набор записей с последовательным доступом <термины Jet>

статический набор записей с последовательным доступом

Объект Recordset статического типа, поиск записей в котором выполняется только от начала к концу. Указатель текущей записи нельзя передвинуть назад к первой записи. Статические наборы записей с последовательным доступом сокращают загрузку процессора при работе с удаленными базами данных. Например, объект Recordset с последовательным доступом, созданный для присоединенной удаленной таблицы, используется для быстрой обработки данных за один проход при создании отчета.


протокол FTP <термины Jet>

протокол FTP

File Transfer Protocol. Протокол, позволяющий пользователям передавать файлы из одного места хранения в другое через Интернет. Вызов адресов URL или файлов на серверах FTP начинается с команды ftp://.


процедура Function <термины Jet>

процедура Function

Процедура, которая выполняет конкретную задачу в программе Microsoft® Visual Basic® и возвращает значение. Процедура Function начинается с инструкции Function и заканчивается End Function.


группа <термины Jet>

группа

Семейство учетных записей пользователей в объекте Workgroup, определяемых именем группы и личным кодом (PID). Разрешения, которые имеет группа, относятся ко всем пользователям группы.


тип данных GUID <термины Jet>

тип данных GUID

Globally Unique Identifier/Universally Unique Identifier. Уникальная строка, которая используется для удаленных вызовов процедур. Идентификаторы каждого класса интерфейса и объектов имеют тип данных GUID. Значение GUID хранится в 128 битах. Например, 12345678-1234-1234-1234-123456789ABC является синтаксически правильным идентификатором GUID. Для установления связи клиента и сервера их идентификаторы GUID должны совпадать. Изготовители объектов могут запросить у Microsoft выделение одного или нескольких наборов из 256 идентификаторов GUID для своего исключительного пользования. С другой стороны, при наличии сетевой карты можно запустить служебную программу с именем Uuidgen.exe, которое создает набор 256 идентификаторов GUID на основе времени дня, даты и уникального числа, содержащегося в конкретной сетевой карте.


протокол HTTP <термины Jet>

протокол HTTP

Hypertext Transfer Protocol. Работающий в фоновом режиме протокол Интернета, управляющий передачей данных через сеть Web. Протокол позволяет пользователю использовать программу клиента для входа в адрес URL (или выбрать гиперссылку), чтобы загружать текст, графику, звукозапись и другие данные в цифровом формате с сервера Web. Вызов адресов URL или файлов на сервере Web начинается с команды http://.


тип данных hyperlink <термины Jet>

тип данных hyperlink

Тип данных поля, используемый для полей, в которых сохраняются гиперссылки. В полях гиперссылки содержится текст или комбинация текста и чисел, сохраняемая как текст и используемая как адрес гиперссылки. Адрес гиперссылки может содержать до трех компонентов (каждый длиной до 2048 символов) со следующим синтаксисом:

отображаемыйТекст#адрес#подчиненныйАдрес


атрибут Identity <термины Jet>

атрибут Identity

Добавлен для обеспечения эквивалентности с синтаксисом сервера SQL. Доступен только в случае использования программы Microsoft® OLE DB Provider для Jet. Функционально это тип данных совпадает с типами Counter и AutoNumber. Этот атрибут фактически является синонимом и не несет дополнительных характеристик.

См. также

поле счетчика (AutoNumber)


несогласованный <термины Jet>

несогласованный

Состояние многотабличного объекта Recordset, в котором позволено проводить обновление всех полей (столбцов). Например, в объекте Recordset, созданном с помощью объединения двух таблиц с отношением «один-ко-многим» (таких как таблицы «Клиенты» и «Заказы» из базы данных «Борей»), имеется возможность изменять значения поля Заказы.КодКлиента так, что они не будут согласованы со значениями полей Клиенты.КодКлиента, если такое обновление не запрещено условиями целостность данных.


инкремент <термины Jet>

инкремент

Необязательный параметр, используемый в типах данных Counter или Identity. Доступен в SQL DDL только в случае использования программы Microsoft® OLE DB Provider для Jet. Представляет значение, используемое для присвоения значения столбца типа Counter или Identity в новой строке таблицы. Инкремент является вторым из двух необязательных параметров в типах данных Counter и Identity.

См. также

начальное значение


индекс <термины Jet>

индекс

Динамическая перекрестная ссылка одного или нескольких полей данных таблицы (столбцов), которая ускоряет процесс извлечения из таблицы конкретных записей. При добавлении, изменении или удалении записей система управления базой данный автоматически обновляет индекс, отражая все внесенные изменения.

Если текущий индекс используется с объектом Recordset табличного типа, этот индекс определяет порядок возвращения данных в объекте Recordset. Для данных таблицы можно определить несколько индексов.

Объект Index объектов доступа к данным (DAO) является индексом для объекта TableDef.


косвенная синхронизация <термины Jet>

косвенная синхронизация

Тип синхронизации, при котором один синхронизатор оставляет в банке данных изменения, которые принимаются другим синхронизатором и вносятся в реплику, управляемую вторым синхронизатором.


внутреннее объединение <термины Jet>

внутреннее объединение

Объединение, при котором записи двух таблиц объединяются и добавляются в объект Recordset только в том случае, если значения связанных полей соответствуют определенному условию. Например, симметричное объединение является внутренним объединением, в котором значения связанных полей должны быть равными.


устанавливаемый драйвер ISAM <термины Jet>

устанавливаемый драйвер ISAM

Специально задаваемый драйвер, который позволяет получить доступ к внешним базам данных в таких форматах как dBASE, Microsoft® Excel и Paradox. ISAM является сокращением от Indexed Sequential Access Method. Ядро базы данных Microsoft Jet устанавливает (загружает) эти драйверы ISAM, когда на них ссылается конкретное приложение. Расположение этих драйверов регистрируется в реестре Microsoft Windows®.


экземпляр <термины Jet>

экземпляр

Любой из набора объектов, использующих один и тот же класс. Например, несколько экземпляров класса Form используют одну и ту же программу и загружаются с теми же элементами управления, с какими был спроектирован класс Form. Во время выполнения отдельные свойства элементов управления каждого экземпляра могут получать разные значения.


тип данных Integer <термины Jet>

тип данных Integer

Основной тип данных, предназначенный для сохранения целых значений. Переменная типа Integer запоминается в виде чисел длиной 16 бит (2 байта) со значениями от -32768 до 32767.


Интернет <термины Jet>

Интернет

Всемирная сеть, объединяющая тысячи компьютерных сетей и миллионы коммерческих, учебных, правительственных и личных компьютеров. Интернет можно представить как электронный город с виртуальными библиотеками, витринами, офисами, картинными галереями и т.д.


синхронизация через Интернет <термины Jet>

синхронизация через Интернет

Способ синхронизации за счет обмена между репликами сообщениями, оставленными в папке банка данных. Общий банк данных имеется только у той реплики, которая управляется синхронизатором на сервере Интернета. Этот банк данных доступен через подключение по протоколу HTTP или FTP.


интрасеть <термины Jet>

интрасеть

Внутренняя сеть организации, в которой используются технологии Интернета (такие как протоколы HTTP или FTP). Интрасеть позволяет перемещаться по объектам, документам, Web-страницам и другим местам с использованием гиперссылок.


внутренняя константа <термины Jet>

внутренняя константа

Константа, значение которой поступает из приложения. Например, константы объектов доступа к данным (DAO) перечислены в библиотеке объектов DAO и доступны для просмотра в окне просмотра модели объектов.


источник данных ODBC, подключенный к ядру Microsoft Jet <термины Jet>

источник данных ODBC, подключенный к ядру Microsoft Jet

Источник данных ODBC, доступ к которому осуществляется с помощью объектов доступа к данным (DAO) и ядра базы данных Microsoft® Jet.


объединение <термины Jet>

объединение

Операция с базой данных, которая позволяет объединить некоторые или все записи из двух или более таблиц, например, симметричное объединение, внутреннее объединение, внешнее объединение или самообъединение. Обычно объединением называют связь поля одной таблицы с полем такого же типа данных из другой таблицы. Объединение задается с помощью инструкции SQL.

Чтобы задать отношение между двумя таблицами, нужно создать их объединение, указав поля главной таблицы и внешней таблицы с ключом. При добавлении таблицы в запрос нужно создать объединение между соответствующими полями инструкции SQL, определяющей запрос.


указатель ключевого набора записей <термины Jet>

указатель ключевого набора записей

Набор строк, которые могут быть использованы для добавления, изменения или удаления строк в базовой таблице или таблицах. Перемещения внутри набора не ограничиваются. Указатель ключевого набора записей может содержать столбцы из одной или нескольких таблиц в базе данных. Состав при этом является фиксированным.


левое объединение <термины Jet>

левое объединение

Левое внешнее объединение, которое включает все записи из первой (левой) таблицы, даже, если нет совпадающих значений для записей из второй (правой) таблицы.


левое внешнее объединение <термины Jet>

левое внешнее объединение

Внешнее объединение, при котором все записи из левой части операции LEFT JOIN инструкции SQL выполняемого запроса добавляются в объект Recordset, даже если в связанных полях таблицы, расположенной справа, нет совпадающих полей. Записи расположенной справа таблицы объединяются с записями из расположенной слева таблицы только при наличии совпадающих значений в связанных полях. Если для записи, расположенной слева, нет совпадающей, то ей сопоставляется строка значений Null с правой стороны.


присоединенная таблица <термины Jet>

присоединенная таблица

Таблица из другой базы данных, присоединенная к базе данных Microsoft® Jet. Данные присоединенных таблиц остаются во внешних базах данных, где их могут использовать другие приложения. (Используется также термин связанная таблица.)


блокировка <термины Jet>

блокировка

Состояние страницы данных, объекта Recordset или объекта Database, открывающее его только для чтения для всех пользователей за исключением одного, выполняющего в данный момент ввод данных.


тип данных Long Binary <термины Jet>

тип данных Long Binary

Тип данных поля, позволяющий сохранять до 2.14 Гбайт данных. Поля типа Long Binary могут содержать любые данные в двоичном формате. В Microsoft® Access для этого типа данных используется имя «Поле объекта OLE» (OLE Object).


тип данных Long <термины Jet>

тип данных Long

Основной тип данных, хранящий значения длинных целых чисел. Переменная типа Long сохраняется как 32-битовое (4 байта) число с диапазоном значений от -2 147 483 648 до 2 147 483 647 включительно.


запрос на создание таблицы <термины Jet>

запрос на создание таблицы

Запрос на изменение, позволяющий создать новую таблицу на основе объекта Recordset, создаваемого в существующем запросе.


таблица только со стороны «многие» <термины Jet>

таблица только со стороны «многие»

Таблица, которая не может находиться на стороне «один» любого объединения в запросе.


тип данных Memo <термины Jet>

тип данных Memo

Тип данных поля. Поля этого типа могут содержать до 2.14 Гбайт данных в текстовом формате.


сообщение <термины Jet>

сообщение

Набор сведений, пересылаемых из одного приложения в другое.


метод <термины Jet>

метод

Зарезервированное слово, определяющее действие, аналогичное инструкции или функции. Метод применяется к конкретным объектам.


база данных Microsoft Jet <термины Jet>

база данных Microsoft Jet

База данных, созданная с помощью ядра Microsoft® Jet. Файлы баз данных Microsoft Jet имеют расширение имени .mdb.


рабочая область Microsoft Jet <термины Jet>

рабочая область Microsoft Jet

Рабочая область, использующая для прямого доступа к источнику данных ядро базы данных Microsoft® Jet. Источником данных может служить файл базы данных Microsoft Jet (.mdb), база данных ODBC, например, база данных Paradox, или база данных ISAM.


тип данных поля <термины Jet>

тип данных поля

Следующая таблица содержит список типов данных полей.

Тип данных DAO | Константа
Big Integer | DbBigInt
Binary | DbBinary
Boolean | DbBoolean
Byte | DbByte
Char | DbChar
Currency | DbCurrency
Date/Time | DbDate
Decimal | DbDecimal
Double | DbDouble
Float | DbFloat
GUID | DbGUID
Integer | DbInteger
Long | DbLong
Long Binary (OLE Object) | DbLongBinary
Memo | DbMemo
Numeric | DbNumeric
Single | DbSingle
Text | DbText
Time | dbTime
TimeStamp | dbTimeStamp
VarBinary | dbVarBinary


ядро базы данных Microsoft Jet <термины Jet>

ядро базы данных Microsoft Jet

Часть системы управления базами данных, которая отвечает за загрузку и сохранение данных в пользовательских и системных базах данных. Ядро базы данных Microsoft® Jet можно рассматривать как диспетчер данных, на основе которого строятся другие системы доступа к данным, такие как Microsoft Access и Visual Basic®.


сетевая база данных <термины Jet>

сетевая база данных

База данных, которая позволяет нескольким пользователям осуществлять совместный доступ и вносить изменения в один и тот же набор данных. В некоторых случаях, дополнительный «пользователь» может быть другим экземпляром вашего приложения или другим приложением, которое выполняется на том же компьютере и обращается к тем же данным, что и прочие приложения.


нормализация <термины Jet>

нормализация

Способ уменьшения количества повторяющихся сведений в реляционной базе данных за счет создания удобной структуры таблицы.


значениt NULL <термины Jet>

значение Null

Значение, которое указывает на отсутствующие или неизвестные данные. Значения Null могут быть введены в поля, для которых данные не известны, а также в выражения и запросы. В Visual Basic зарезервированное слово Null указывает на значение Null. Некоторые поля, например ключевые, не могут содержать значения Null.


пустое поле <термины Jet>

пустое поле

Поле, не содержащее значений или символов. Пустое поле не совпадает с пустой строкой ("") или полем со значением 0. Поле получает пустое значение, если его значение неизвестно. Например, поле «Дата выполнения» в таблице «Задания» будет оставаться пустым до выполнения работы.


тип данных Numeric <термины Jet>

тип данных Numeric

Тип данных для сохранения точных числовых значений со знаком с p разрядами и фактором масштабирования s (1 ≤ p ≤ 15; 0 ≤ s ≤ p).


числовое выражение <термины Jet>

числовое выражение

Любые выражения, результатом которых является число. Элементы выражения могут включать любую комбинацию ключевых слов, переменных, констант и операторов, которая дает числовое значение.


окно просмотра объектов <термины Jet>

окно просмотра объектов

Диалоговое окно, которое используется для просмотра содержимого библиотеки объектов, чтобы получить сведения об имеющихся объектах.


объектное выражение <термины Jet>

объектное выражение

Выражение, определяющее конкретный объект. Это выражение может включать любой контейнер объекта. Например, если приложение содержит объект Application, включающий объект Document, который в свою очередь содержит объект Text, то следующие выражения являются допустимыми объектными выражениями:

Application.Document.Text

Application.Text

Document.Text

Text


библиотека объектов <термины Jet>

библиотека объектов

Файл библиотеки динамической компоновки (DLL), содержащий ресурсы библиотеки типов, который обычно имеет расширение имени .olb. Окно просмотра объектов позволяет исследовать содержимое библиотеки объектов для получения сведений об имеющихся объектах.


объектная переменная <термины Jet>

объектная переменная

Переменная, которая содержит ссылку на объект.


протокол ODBC <термины Jet>

протокол ODBC

Стандартный протокол, который обеспечивает подключение приложений к различным внешним серверам или файлам баз данных. Драйверы ODBC, используемые ядром базы данных Microsoft® Jet, обеспечивают доступ к Microsoft SQL Server™ и некоторым другим внешним базам данных.

Программный интерфейс приложений ODBC (API) может быть также использован для получения доступа к драйверам ODBC и базам данных, к которым они присоединяются, без обращения к ядру Microsoft Jet.


источник данных ODBC <термины Jet>

источник данных ODBC

Термин используется для ссылки на базу данных или сервер баз данных, которые являются источниками данных. К источникам данных, поддерживающим протокол ODBC, нужно обращаться по их именам DSN. Источники данных создаются с помощью панели инструментов Microsoft® Windows® или метода RegisterDatabase.


драйвер ODBC <термины Jet>

драйвер ODBC

Библиотека динамической компоновки (DLL), используемая для присоединения специфического источника данных ODBC к другому приложению (клиенту).


диспетчер драйверов ODBC <термины Jet>

диспетчер драйверов ODBC

Приложение, управляющее подключением между источниками данных ODBC и драйверами, используемыми для доступа к этим источникам.


механизм OLE <термины Jet>

механизм OLE

Механизм работы с составными документами: разработанная Microsoft объектная технология, которая позволяет создавать приложения, содержащие компоненты из других приложений.


объект ActiveX <термины Jet>

объект ActiveX

Объект, допускающий использование другими приложениями или программами, использующими механизм программирования объектов (ранее применялся термин механизм управления объектами OLE). Например, Microsoft® Access позволяет создавать и использовать объекты Microsoft ActiveX® в Microsoft Word или Microsoft Excel.


тип данных OLE Object <термины Jet>

тип данных OLE Object

Тип данных поля, который применяется для объектов, созданных в других приложениях, допускающих связывание или внедрение в базу данных Microsoft® Jet. Например, в полях типа OLE Object (поле объекта OLE) могут сохраняться наборы рисунков.


отношение «один-ко-многим» <термины Jet>

отношение «один-ко-многим»

Связь между двумя таблицами, при которой:

  • значение первичного ключа каждой записи главной таблицы соответствует значению соответствующего поля или полей нескольких записей связанной таблицы;
  • значение первичного ключа каждой записи связанной таблицы соответствует значению соответствующего поля или полей одной и только одной записи главной таблицы.


отношение «один-к-одному» <термины Jet>

отношение «один-к-одному»

Связь между двумя таблицами, при которой:

  • значение первичного ключа каждой записи главной таблицы соответствует значению соответствующего поля или полей одной и только одной записи из связанной таблицы;
  • значение первичного ключа каждой записи связанной таблицы соответствует значению соответствующего поля или полей одной и только одной записи главной таблицы.


нежесткая блокировка <термины Jet>

нежесткая блокировка

Тип блокировки, при котором страница данных, содержащая одну или несколько записей, включая изменяемую запись, оказывается недоступной для других пользователей при обновлении этой записи с помощью метода Update, но доступной в промежутке времени между использованием методов Edit и Update. Нежесткая блокировка используется во время работы с базами данных, поддерживающими протокол ODBC, или в ситуации, когда свойство LockEdits объекта Recordset имеет значение False.


внешнее объединение <термины Jet>

внешнее объединение

Объединение, при котором все записи одной таблицы добавляются в объект Recordset, даже если нет совпадающих значений в связанном поле из второй таблицы. Записи из второй таблицы объединяются с записями первой таблицы только при наличии совпадающих значений в связанных полях. Пустые записи объединяются при отсутствии совпадений.


страница <термины Jet>

страница

Часть базы данных, в которой сохраняются данные записей. В зависимости от размера записей страница может содержать более одной записи. В базах данных Microsoft® Jet (.mdb) размер страницы равен 2048 (2K) байт. В форматах файлов Jet 4.X страница имеет размер 4K (4096 байт).


параметр <термины Jet>

параметр

Элемент, содержащий значение, которое можно изменять, чтобы воздействовать на результаты запроса. Например, запрос, возвращающий данные о сотруднике, может включать параметр, предназначенный для задания фамилии сотрудника. Тогда с помощью объекта QueryDef можно искать сведения о любом сотруднике, задавая перед запуском запроса конкретную фамилию как значение этого параметра.

При использовании программы Microsoft® OLE DB Provider для Jet в Microsoft Jet версии 4.X параметры можно получать из процедур с помощью вопросительных знаков (?), являющихся в ANSI маркерами параметров. В синтаксисе SQL можно создавать эквиваленты объектов QueryDef.


запрос с параметрами <термины Jet>

запрос с параметрами

Запрос, в который пользователь перед выполнением запроса должен ввести одно или несколько значений, предназначенных для включения в условия отбора, например «Москва» для параметра «Город». Строго говоря, запрос с параметрами не является особым видом запроса; скорее, он является расширением возможностей других запросов.

При использовании программы Microsoft® OLE DB Provider для Jet в Microsoft Jet версии 4.X параметры можно получать из процедур с помощью вопросительных знаков (?), являющихся в ANSI маркерами параметров. В синтаксисе SQL можно создавать эквиваленты объектов QueryDef.


интерпретация <термины Jet>

интерпретация

Синтаксический разбор частей инструкции или выражения с последующей проверкой этих частей на соответствие с правилами используемого языка.


частичная реплика <термины Jet>

частичная реплика

База данных, содержащая ограниченное подмножество записей полной реплики. В частичной реплике пользователь имеет возможность создавать фильтры и устанавливать связи, определяющие отбираемое подмножество записей.


запрос к серверу <термины Jet>

запрос к серверу

Запрос SQL, который используется для прямой отправки команд на сервер базы данных SQL (например, Microsoft® SQL Server™). Запросы к серверу позволяют непосредственно работать с таблицами на сервере вместо того, чтобы присоединять их. Запросы к серверу используются для выполнения запросов на языке SQL и системных команд, написанных на варианте языка SQL, который поддерживается на конкретном сервере.

Запрос к серверу может возвращать или не возвращать записи. Если записи возвращаются, они входят в статический набор записей.


разрешение <термины Jet>

разрешение

Один или несколько атрибутов, которые определяют тип доступа пользователя к данным или объектам базы данных. Например, если пользователь имеет разрешение «Чтение данных» для таблицы или запроса, то он может просматривать или загружать данные из таблицы или запроса, но не изменять их.


постоянный объект <термины Jet>

постоянный объект

Объект, хранящийся в базе данных; например, таблица базы данных или объект QueryDef. Объекты Recordset динамического или статического типа не являются постоянными объектами, потому что они создаются в памяти по мере необходимости.


жесткая блокировка <термины Jet>

жесткая блокировка

Тип блокировки, при котором страница данных, содержащая одну или несколько записей, включая изменяемую запись, оказывается недоступной другим пользователям с момента вызова метода Edit и остается недоступной до вызова метода Update. Жесткая блокировка включается, когда свойство Lockedits объекта Recordset имеет значение True.


код учетной записи (PID) <термины Jet>

код учетной записи (PID)

Строка букв и цифр длиной 4-20 символов, в которой учитывается регистр букв, и которую ядро базы данных Microsoft® Jet использует вместе с именем учетной записи для определения пользователя или группы в объекте Workgroup. При создании нового пользователя или группы нужно задать имя и код учетной записи.


первичный ключ <термины Jet>

первичный ключ

Одно или несколько полей, значения которых однозначно определяют каждую запись таблицы. При определении связи первичный ключ используется для ссылок на конкретные записи в определенной таблице из другой таблицы. Первичный ключ, на который имеется ссылка в другой таблице, называют внешним ключом. Таблица может иметь только один первичный ключ. Например, в таблице «Сотрудники» полем первичного ключа может быть поле «КодСотрудника».


главная таблица <термины Jet>

главная таблица

Таблица, находящаяся на стороне «один» в установленном отношении «один-ко-многим» с внешней таблицей с ключом. Обычно, главную таблицу используют для определения условий целостности данных.


приоритет <термины Jet>

приоритет

Длинное значение, указывающее приоритет реплики, который используется при устранении конфликтов синхронизации. Для глобальной реплики допустимыми значениями приоритета являются значения от 0 до 100, включительно. Локальные и анонимные реплики могут иметь нулевое значение приоритета. В случае конфликта синхронизации победителем оказывается реплика, имеющая большее значение приоритета. Отвергнутые данные помещаются в таблицу конфликтов.


процедура <термины Jet>

процедура

Аналогична представлению, с тем лишь исключением, что синтаксис SQL предусматривает использование инструкций SELECT (запросы с возвращением строк) для передачи параметров и использование инструкций DML (запросы без возвращения строк) UPDATE, INSERT, DELETE и SELECT INTO. Фактически процедура совпадает с объектом querydef, с тем лишь исключением, что ее можно создать с использованием синтаксиса SQL без обращения к модели объектов доступа к данным (DAO).


процедурный запрос <термины Jet>

процедурный запрос

Инструкция SQL, которая выполняет сохраненную процедуру.


свойство <термины Jet>

свойство

Атрибут объекта, имеющий собственное имя. Свойства определяют такие характеристики объекта как размер, цвет или расположение на экране, а также состояние объекта, например, включенное или отключенное.


временный индекс <термины Jet>

временный индекс

Динамическая перекрестная ссылка на одно или несколько полей таблицы (столбцов), которая позволяет вносить изменения в таблицу ODBC (таблица на сервере) без изменения уникального индекса. Временный индекс не является настоящим индексом в таблице на сервере. Это перекрестная ссылка, которую ядро базы данных Microsoft® Jet использует для поддержки процесса обновления таблицы. Временный индекс необходим только в том случае, если таблица ODBC не имеет уникального индекса, позволяющего вносить в нее изменения. Временный индекс не нужен, если таблица имеет уникальный индекс, или в таблицу не нужно вносить изменения. (Таблицы не могут иметь уникальный индекс, если они предназначены только для чтения). В предыдущих версиях для временных индексов использовался термин «спецификации индекса».


запрос <термины Jet>

запрос

Формализованная инструкция к базе данных с требованием загрузить набор записей или выполнить конкретные действия с набором записей. Например, следующая инструкция запроса SQL возвращает записи:

SELECT Название FROM Клиенты WHERE Область = 'Тульская'

Пользователь имеет возможность создавать и выполнять запросы следующих типов: запрос на выборку, запрос на изменение, перекрестный запрос, запрос с параметрами и запросы SQL.


только чтение <термины Jet>

только чтение

Тип доступа к данным, при котором данные можно загружать, но нельзя изменять.


запись <термины Jet>

запись

Набор конкретных сведений о человеке, месте, событии и т.п. Данные таблицы хранятся в записях (строках) базы данных. Каждая строка состоит из набора родственных полей (столбцов). Каждое поле записи определяет один атрибут данных. Вся запись целиком определяет в базе данных одну конкретную единицу извлекаемых данных.

Запись также часто называют строкой.

См. также

строка


целостность данных <термины Jet>

целостность данных

Правила, которые задаются для установки и сохранения отношений между таблицами при добавлении, изменении или удалении записей. Включение режима поддержания целостности данных не позволяет пользователям добавлять в связанную таблицу записи, для которых нет первичного ключа; вносить в главную таблицу изменения, приводящие к возникновению потерянных записей в связанной таблице, и удалять записи из главной таблицы при наличии соответствующих им записей в связанной таблице.

При включении для отношения режимов «Каскадное удаление связанных записей» или «Каскадное обновление связанных полей» с помощью констант dbRelationDeleteCascade или dbRelationUpdateCascade, ядро базы данных Microsoft® Jet разрешает внесение изменений в записи и их удаление, но для сохранения целостности данных изменяет или удаляет связанные записи.

Версия Microsoft Jet 4.X с помощью программы Microsoft OLE DB Provider для Jet делает доступным расширенную версию ANSI SQL, а также каскадные операции ANSI со значениями NULL.


отношение <термины Jet>

отношение

Отношение (связь), установленное между общими полями (столбцами) двух таблиц. Существуют отношения «один-к-одному», «многие-ко-многим» и «один-ко-многим».


повторный запрос <термины Jet>

повторный запрос

Повторное выполнение запроса, чтобы отобразить изменения, внесенные в записи, загрузить вновь добавленные записи и исключить удаленные записи.


зарезервированное слово <термины Jet>

зарезервированное слово

Слово, являющееся частью языка, например, языка SQL ядра базы данных Microsoft® Jet. Зарезервированные слова включают имена инструкций, встроенных функций и типов данных, методов, операторов и объектов. Примерами зарезервированных слов могут служить SELECT, UPDATE, BETWEEN, SET и INSERT. Не разрешается использовать зарезервированные слова в качестве имен переменных или объектов.

При использовании программы Microsoft OLE DB Provider для Jet список зарезервированных слов для Microsoft Jet версии 4.X расширяется, чтобы обеспечить совместимость с ANSI SQL-92.


правое объединение <термины Jet>

правое объединение

Правое внешнее объединение, которое включает все записи из второй (правой) таблицы, даже если нет совпадающих значений с записями из первой (левой) таблицы.

Например, можно использовать операцию LEFT JOIN с таблицей «Отделы» (левой) и «Сотрудники» (правой) для отбора всех отделов, включая те, в которых нет сотрудников. Чтобы отобрать всех сотрудников, включая не приписанных ни к какому отделу, используйте операцию RIGHT JOIN.


правое внешнее объединение <термины Jet>

правое внешнее объединение

Внешнее объединение, при котором все записи из правой части операции RIGHT JOIN инструкции SQL, используемой в запросе, добавляются в объект Recordset, даже если нет совпадающих значений в связанном поле левой таблицы. Записи из левой таблицы объединяются с записями из правой таблицы, только при наличии совпадающих значений в связанных полях.


откат <термины Jet>

откат

При использовании Microsoft® OLE DB Provider для Jet теперь имеется возможность запустить (BeginTrans), завершить (CommitTrans) или выполнить откат (RollBack) транзакции без использования модели объектов DAO или ADO. При откате (RollBack) транзакция (запущенная инструкцией BeginTrans) может быть закончена или удалена.


строка <термины Jet>

строка

Набор столбцов или полей, используемых для хранения данных. Строка является синонимом записи в ядре базы данных Microsoft® Jet. Таблица состоит из нулевого или большего количества строк данных.


блокировка низкого уровня <термины Jet>

блокировка низкого уровня

Новое средство версии Microsoft® Jet 4.X, позволяющее пользователю при обновлении или удалении строки блокировать строку вместо блокировки страницы. Блокировка низкого уровня не применяется к индексированным столбцам или к столбцам с типами данных для длинных (Long) значений (например, Memo).


отслеживание на уровне строк <термины Jet>

отслеживание на уровне строк

Механизм отслеживания на уровне строк, в котором в обнаружении и устранении конфликта участвует целая строка. Конфликт возникает в случаях, когда одна и та же строка оказывается измененной в нескольких репликах, даже если данные при этом были изменены в разных столбцах.


ошибка выполнения <термины Jet>

ошибка выполнения

Ошибка, возникающая во время выполнения программы. Ошибка выполнения наступает, когда инструкция пытается выполнить недопустимое действие.


время выполнения <термины Jet>

время выполнения

Время выполнения программы. В это время взаимодействие с программой происходит на уровне пользователя.


область определения <термины Jet>

область определения

Атрибут переменной или процедуры, определяющий в каких разделах и в каких модулях распознается данная переменная. Существует три уровня области определения: общедоступный (глобальный), уровень модуля и уровень процедуры. К переменным, описанным с ключевым словом Public, можно получить доступ из любого модуля, в то время как к переменным, описанным в конкретном модуле, возможен доступ только из этого модуля. Переменные, описанные в процедуре Sub или Function, могут использоваться только в этой процедуре.


защищенная рабочая группа <термины Jet>

защищенная рабочая группа

Объект Workgroup базы данных Microsoft® Jet, к которому пользователи присоединяются с помощью имени пользователя и пароля, и в котором доступ к объектам базы данных ограничен разрешениями, заданными в учетных записях пользователей и групп.


защита <термины Jet>

защита

Набор средств, используемый для задания или ограничения доступа, который конкретные пользователи или группы пользователей имеют к данным и объектам базы данных.


начальное значение <термины Jet>

начальное значение

Необязательный параметр, используемый в типах данных Counter или Identity. Доступен в SQL DDL только в случае использования программы Microsoft® OLE DB Provider для Jet. Используется также термин «стартовое значение». Начальное значение является первым из двух необязательных параметров в типах данных Counter и Identity.

Примером использования параметров служит приведенная ниже инструкция SQL:

CREATE TABLE Клиенты (КодКлиента IDENTITY (100, 10) CONSTRAINT ключКлиенты PRIMARY KEY, CFrstNm VARCHAR(10), CLstNm VARCHAR(15));

В первой строке в столбец «КодКлиента» будет введено значение 100. Вторая строка получит значение 110.

Если используются необязательные параметры, не представляющие пару значений (1,1), Jet не сбрасывает начальное значение до максимального значения в таблице. Это отличается от предыдущих версий Jet. Если необязательные параметры не передаются или представляют пару значений (1,1), то при сжатии базы данных начальное значение сбрасывается до максимального значения в таблице в столбце типа Counter или Identity.

См. также

инкремент


запрос на выборку <термины Jet>

запрос на выборку

Запрос, который отвечает на вопрос о данных, хранящихся в таблицах, и возвращает объект Recordset, не изменяя данные. После загрузки данных в объект Recordset становится возможным их просмотр и изменение в базовых таблицах. В отличие от запросов на выборку, запросы на изменение позволяют вносить изменения в данные, но не возвращают записи с данными.


самообъединение <термины Jet>

самообъединение

Объединение, при котором записи из одной таблицы объединяются с другими записями той же таблицы, имеющими совпадающие значения в связанных полях. Самообъединение может быть внутренним или внешним объединением. Самообъединение полезно при задании иерархических вопросов, таких как запрос, отображающий фамилии всех руководителей и подчиненных им сотрудников.


сервер <термины Jet>

сервер

Система управления базой данных, разработанная для совместного использования данных приложениями-клиентами. Серверы и клиенты часто объединяются с помощью сети. Сервер базы данных обычно содержит и управляет центральным хранилищем данных. Приложения-клиенты извлекают и используют эти данные.


указатель на стороне сервера <термины Jet>

указатель на стороне сервера

Указатели набора записей, находящиеся на сервере, в отличие от находящихся на клиентском компьютере. В то время как указатели на стороне клиента копируют указатель на рабочие станции, указатели на стороне сервера используют ресурсы сервера базы данных для управления указателями.


сеанс <термины Jet>

сеанс

Сеанс определяет последовательность операций, выполняемых ядром базы данных Microsoft® Jet. Он начинается при подключении пользователя и заканчивается при его отключении. Все операции во время сеанса образуют область определения одной транзакции и определяются разрешениями, установленными при регистрации с данным именем пользователя и паролем. В программном обеспечении объектов доступа к данным (DAO) сеансы реализуются как объекты Workspace.


тип данных Short <термины Jet>

тип данных Short

Основной тип данных ядра базы данных Microsoft Jet, который соответствует типу данных Integer, определенному в языке Microsoft® Visual Basic® для приложений (VBA). Переменная типа Short сохраняет 16-разрядное (2-байтовое) число в диапазоне от -32768 до 32767.


тип данных Single <термины Jet>

тип данных Single

Основной тип данных, в котором числа сохраняются как числа с плавающей точкой обычной точности в формате IEEE. Переменная типа Single сохраняет 32-разрядное (4 байт) число в диапазоне от -3,402823E38 до -1,401298E-45 для отрицательных значений, от 1,401298E-45 до 3,402823E38 для положительных значений, и значение 0.


статический набор записей <термины Jet>

статический набор записей

Статическая копия набора записей, извлеченных из базы данных и скопированных в память. Статические наборы записей, созданные на основе подключения ядра Microsoft® Jet к внешнему источнику данных, не допускают обновления. Объекты Recordset статического типа создаются из основной таблицы, запроса или другого набора записей. Все запросы к серверу SQL возвращают статические наборы записей.


порядок сортировки <термины Jet>

порядок сортировки

Принцип расположения элементов, используемый для упорядочивания данных; например, алфавитный или числовой. Сортировка выполняется либо по возрастанию, либо по убыванию.


запрос SQL <термины Jet>

запрос SQL

Запрос, который создается только путем написания инструкции SQL. Специфическими запросами SQL являются подчиненные запросы и запросы к серверу, запросы на объединение и управляющие запросы.


инструкция/строка SQL <термины Jet>

инструкция/строка SQL

Выражение, которое определяет команды на языке SQL (Structured Query Language), такие как SELECT, UPDATE или DELETE, и может включать такие предложения как WHERE и ORDER BY. Строки и инструкции на языке SQL обычно используются в запросах, объектах Recordset и статистических функциях, но также могут применяться для создания или изменения структуры базы данных.


среднеквадратичное отклонение <термины Jet>

среднеквадратичное отклонение

Параметр, который указывает величину разброса функции распределения около среднего значения. Он равен квадратному корню из момента для квадрата отклонений от среднего. Этот параметр используется для описания набора значений, чтобы определить величину отклонений значений от среднего арифметического.


стандартные правила именования <термины Jet>

стандартные правила именования

Набор конкретных правил, применяемых при создании имен объектов доступа к данным (DAO). Имена могут иметь длину до 64 символов и включать любой набор букв, цифр, пробелов и специальных символов, за исключением точки (.), восклицательного знака (!), символа обратной кавычки (`) и квадратных скобок ([ ]). В начале имени нельзя использовать пробелы или управляющие символы (с кодами ASCII от 0 до 31).


указатель статического набора записей <термины Jet>

указатель статического набора записей

Результирующий набор, в котором состав, порядок и значения обычно определяются при открытии указателя набора записей. Если другие пользователи обновляют, удаляют или изменяют записи, эти изменения не отражаются в курсоре до его закрытия и последующего открытия.


сравнение строк <термины Jet>

сравнение строк

Использование инструкции для определения способа сравнения строк. Инструкция Option Compare Text в разделе описаний модуля задает сравнение строк без учета регистра. Инструкция Option Compare Binary задает сравнение строк с учетом регистра. При использовании инструкции Option Compare Database метод сравнения задается в текущей базе данных.


тип данных String <термины Jet>

тип данных String

Основной тип данных, предназначенный для хранения символьных данных. Переменная типа String содержит по одному символу на байт и может иметь как фиксированную, так и переменную длину. Для строк фиксированной длины при их описании задается конкретная длина от 1 до приблизительно 64 Кбайт (2^16). Строки переменной длины могут иметь любую длину до 2 миллиардов символов (2^31) (примерно до 64 Кбайт [2^16] символов в Microsoft® Windows® версии 3.1 или более ранней), за вычетом небольшого количества, требуемого для хранения.


строковое выражение <термины Jet>

строковое выражение

Любое выражение, дающее непрерывную последовательность символов. Элементы этого выражения могут включать функции, которые возвращают строки, строковые константы в явном представлении (литералы), строковые константы, строковые переменные, значения Variant строкового подтипа, или функции, возвращающие значения Variant строкового подтипа (VarType 8).


язык SQL <термины Jet>

язык SQL

Structured Query Language. Язык, используемый для запросов, обновления и управления реляционными базами данных. Язык SQL применяется для загрузки, сортировки и отбора конкретных данных, извлекаемых из базы данных.

Инструкции SELECT языка SQL используются в любых местах, где принимаются имена таблиц, имена запросов или имена полей. Например, инструкцию SQL можно использовать вместо имени таблицы в методе OpenRecordset.


подчиненный запрос <термины Jet>

подчиненный запрос

Инструкция SELECT, вложенная в инструкцию SELECT, SELECT...INTO, INSERT...INTO, DELETE, или UPDATE или в другой подчиненный запрос.


ошибка синтаксиса <термины Jet>

ошибка синтаксиса

Ошибка, которая возникает при вводе строки исходной программы, не распознаваемой языком Microsoft® Visual Basic.

Примечание. Синтаксические правила для конкретных ключевых слов приведены в разделе «Синтаксис» в соответствующих этим словам разделах справки. Чтобы при разработке программы получить справку о конкретном ключевом слове, выберите это слово и нажмите клавишу F1.


системный объект <термины Jet>

системный объект

Объект базы данных, определяемый ядром базы данных Microsoft® Jet, например таблица «MSysIndexes».


таблица <термины Jet>

таблица

Основная единица хранения данных в реляционной базе данных. Данные хранятся в таблице в записях (строках) и полях (столбцах) и обычно относятся к конкретной теме, например «сотрудники». Другим используемым термином является «основная таблица».

Объект Recordset табличного типа является логическим представлением основной таблицы в базе данных.


переменная среды TEMP <термины Jet>

переменная среды TEMP

Значение переменной среды TEMP задается при запуске файла autoexec.bat во время загрузки системы. Обычно переменная TEMP указывает на область жесткого диска, которую Microsoft® Windows® и другие программы, такие как ядро базы данных Microsoft Jet, используют для хранения сведений, которые не нужно сохранять после выключения системы. Например, следующая строка в файле autoexec.bat помещает в переменную среды TEMP значение, указывающее на папку D:\TempArea:

SET TEMP=D:\TempArea


временный диск <термины Jet>

временный диск

Диск или каталог, заданный в переменной среды TEMP операционной системы, в котором ядро базы данных Microsoft® Jet хранит временные файлы и результирующие наборы записей. Его также часто называют временным диском. Хотя переменная среды TEMP может указывать на электронный диск, делать это не рекомендуется.


тип данных Text(n) (с указанием длины) <термины Jet>

тип данных Text(n) (с указанием длины)

Тип данных поля. Текстовые поля содержат до 255 символов или количество символов, заданное в свойстве Size объекта Field. Если свойство Size имеет значение 0, поле может содержать до 255 символов.


тип данных Text (без спецификации длины) <термины Jet>

тип данных Text (без спецификации длины)

Тип данных поля. Текстовые поля, определенные без явного указания длины, совпадают с полями Memo и могут содержать до 2,14 Гбайт символьных данных.


тип данных Time <термины Jet>

тип данных Time

Тип данных для сохранения значений времени. Вид значений определяется настройкой часов в источнике данных.


транзакция <термины Jet>

транзакция

Серия изменений, проделанная с данными и схемой базы данных. Начало транзакции задается инструкцией BeginTrans, а завершение транзакции – инструкцией CommitTrans. Если требуется отменить все изменения, проделанные со времени запуска транзакции BeginTrans, следует вызвать инструкцию Rollback.

Транзакции не являются обязательными и могут быть вложенными. Транзакции обычно увеличивают скорость обработки данных и позволяют легко обратить проведенные изменения.

Транзакции являются глобальными по отношению к объектам базы данных в рабочей области Workspace.


формат представления Unicode <термины Jet>

формат представления Unicode

16-битовый набор символов, поддерживаемый Unicode Consortium, который содержит все символы, необходимые для отображения любого языка. Unicode широко используется в программном обеспечении, предназначенном для работы в многоязычной среде.


запрос на объединение <термины Jet>

запрос на объединение

Запрос SQL, выполняющий выборку данных, который создает объект Recordset статического типа, содержащий данные из всех указанных записей нескольких таблиц, причем повторяющиеся записи удаляются. Чтобы включить повторяющиеся записи, следует добавить ключевое слово ALL.

Например, запрос на объединение таблицы «Клиенты» с таблицей «Поставщики» создает объект Recordset статического типа, содержащий записи обо всех поставщиках, которые одновременно являются клиентами.


неуправляемая реплика <термины Jet>

неуправляемая реплика

Реплика, не управляемая синхронизатором. Неуправляемая реплика отображается в окне синхронизации со специальным значком. Невозможно задать расписание синхронизации для неуправляемой реплики, однако, пользователь имеет возможность выполнить синхронизацию этой реплики в программе или с помощью другого синхронизатора.


обновление <термины Jet>

обновление

Процесс сохранения изменений, внесенных в запись. Пока запись не сохранена, изменения хранятся во временной записи, называемой буфером копирования. Предложение UPDATE инструкции на языке SQL изменяет значения данных одной или нескольких записей (строк) в таблице базы данных.


запрос на обновление <термины Jet>

запрос на обновление

Запрос на изменение, изменяющий набор записей в соответствии с указанным условием отбора. Запрос на обновление записей не возвращает записи.


учетная запись пользователя <термины Jet>

учетная запись пользователя

Запись, определяемая именем и кодом (PID) пользователя, которая создается для обеспечения доступа к объектам базы данных в объекте Workgroup базы данных Microsoft® Jet.


проверка условий на значения <термины Jet>

проверка условий на значения

Процесс проверки соответствия вводимых данных конкретным условиям или ограничениям.


свойства для задания условий на значения <термины Jet>

свойства для задания условий на значения

Свойства, используемые для задания условий на значения данных в полях и записях таблицы. Свойства для задания условий на значения включают свойства ValidationRule, Required и AllowZeroLength.


условие на значение <термины Jet>

условие на значение

Правило, которое задает условия или ограничения на ввод данных в одно или несколько полей. Условия на значения задаются для объектов Field или TableDef. Условия на значения проверяются при обновлении записей, содержащих поля, для которых определены условия на значения. Если правило нарушено, возникает перехватываемая ошибка.


тип данных VarBinary <термины Jet>

тип данных VarBinary

Тип данных для сохранения двоичных данных переменной длины. Максимальная длина составляет 255 байт.


переменная <термины Jet>

переменная

Именованное место хранения, содержащее данные, которые могут изменяться во время выполнения программы. Каждая переменная имеет уникальное имя, которое идентифицирует ее в области ее определения. Тип данных может быть указан или не указан.

Имя переменной:

  • должно начинаться с буквы;
  • не может содержать символы пробела или символы описания типа;
  • должно быть уникальным внутри одной области определения;
  • длина имени не должна превышать 255 символов.


дисперсия <термины Jet>

дисперсия

Квадрат значения среднеквадратичного отклонения. Мера отличия значений в группе от среднего значения.


тип данных Variant <термины Jet>

тип данных Variant

Особый тип данных, предназначенный для хранения чисел, строк, дат, а также специальных значений Empty и Null. Функция VarType определяет способы обработки данных из переменной типа Variant. Все переменные получают этот тип, если их тип не задан явным образом.


выражение типа Variant <термины Jet>

выражение типа Variant

Любое выражение, результатом вычисления которого является число, строка, дата, а также специальные значения Empty и Null.


представление <термины Jet>

представление

Представление — это определение виртуальной таблицы в ANSI. Представление является синонимом сохраненного запроса в Access, образуемого инструкцией SELECT без параметров. Представление является сохраненным описанием, которое реализуется при выполнении. В отличие от таблицы, представление не сохраняет данные. Данные только возвращаются.

Представление можно создать с помощью нового синтаксиса ANSI SQL CREATE VIEW, доступного через Microsoft® OLE DB Provider для Jet. В отличие от этого, в процедурах допускаются инструкции SQL DML и инструкции SELECT с параметрами. Это делается с помощью нового синтаксиса CREATE PROCEDURE, доступного через Microsoft® OLE DB Provider для Jet.


подстановочные знаки <термины Jet>

подстановочные знаки

Подстановочными знаками являются: знак звездочки (*), знак процента (%), вопросительный знак (?), символ подчеркивания (_), знак номера (#), восклицательный знак (!), дефис (-) и квадратные скобки ([ ]). Эти знаки используются в запросах и выражениях, чтобы включить все записи, имена файлов или конкретные названия, начинающиеся с определенных символов или соответствующие определенному образцу. Подстановочные знаки и символы совпадения можно также применять для дальнейшего уточнения поиска с помощью инструкции SQL.

Примечание. При использовании программы Microsoft OLE DB Provider для Jet как подстановочные знаки используются только знак процента (%) и символ подчеркивания (_). Они не поддерживаются средствами DAO или в интерфейсе пользователя Microsoft Access. При работе с Microsoft Access или DAO эти подстановочные знаки воспринимаются как строковые константы.

Символ | Пример | Использование
* or % | ст* находит «стол», «стул» и «стакан» *ка находит «лампочка», «папка» и «краска» | Соответствует любому количеству символов и может быть использован в любом месте текстовой строки.
? or _ | л?па находит «лапа», «липа» и «лупа» | Соответствует любому одиночному символу.
# | 1#3 находит 103, 113, 123 | Соответствует любой одиночной цифре.
[ ] | л[аи]па находит «лапа» и «липа», но не «лупа» | Соответствует любому символу, расположенному в квадратных скобках.
! | л[!аи]па находит «лупа», но не «лапа» и не «липа» | Соответствует любому символу, не включенному в список.
- | б[а-в]д находит «бад», «ббд» и «бвд» | Соответствует любому символу из диапазона символов. Примечание.

Примечание. Подстановочные знаки * (звездочка), ? (вопросительных знак), # (знак числа) и [ (открывающая квадратная скобка) рассматриваются как образец для поиска этого символа только при заключении их в квадратные скобки.


рабочая группа <термины Jet>

рабочая группа

Группа пользователей сети, работающих с одними и теми же данными и с одной и той же системной базой данных (обычно с файлом System.mdw).


администратор рабочей группы <термины Jet>

администратор рабочей группы

Член группы «Admins» в объекте Workgroup базы данных Microsoft® Jet. Администратор рабочей группы всегда имеет полные разрешения на любой объект базы данных, созданный в объекте Workgroup.


пустая строка <термины Jet>

пустая строка

Строка, не содержащая символов. Функция Len, примененная к пустой строке, возвращает значение 0.


базовый таблица <термины Jet>

базовый компьютер

Компьютер, включенный в сеть со звездообразной топологией. Реплика копируется с сервера разветвителя и помещается на базовый компьютер. Эта реплика может использоваться для создания новых реплик на других компьютерах.

См. также
сервер разветвителя звездообразная топология


конфликтная таблица <термины Jet>

конфликтная таблица

Таблица, которая создается при возникновении конфликтов во время синхронизации двух реплик. Конфликтная таблица создается только в реплике, измененная запись из которой не была принята другой репликой в процессе синхронизации.


репликация базы данных <термины Jet>

репликация базы данных

Процесс создания одной или нескольких копий базы данных (реплик), допускающих синхронизацию. Изменения данных в реплицируемой таблице в одной из реплик могут быть переданы в другие реплики и в основную реплику в наборе. Допускается также передача из основной реплики в другие реплики, входящие в набор, изменений структуры базы данных.


стандартная частичная реплика <термины Jet>

стандартная частичная реплика

Синхронизатор, используемый для автоматической синхронизации частичной реплики с другими репликами в наборе. При создании реплики синхронизатор, используемый для управления исходной репликой, используется по умолчанию для новой частичной реплики.


стандартное расписание <термины Jet>

стандартное расписание

Шаблон, используемый синхронизатором для определения расписания синхронизации новой реплики и стандартной частичной реплики, если новой реплики в явном виде не определено расписание синхронизации. Пользователь имеет возможность изменить ранее определенное расписание.


основная реплика <термины Jet>

основная реплика

База данных, в которую добавляются системные таблицы, системные поля и свойства репликации. Основная реплика является главным компонентом набора реплик и используется для создания первой реплики в наборе. Изменение структуры базы данных допускается только в основной реплике. Другие реплики в том же наборе также могут быть назначены основными репликами, но в каждый момент в наборе должна быть только одна основная реплика.


банк данных <термины Jet>

банк данных

Общая сетевая папка, с помощью которой синхронизатор сохраняет и принимает изменения структуры и данных.


глобальный уникальный идентификатор (GUID) <термины Jet>

глобальный уникальный идентификатор (GUID)

16-байтовое поле, используемое для создания уникального идентификатора при репликации. Значения типа GUID широко используются для идентификации реплик, наборов реплик, таблиц, записей и других объектов.

Примечание. В Microsoft® Access тип данных GUID называется «Код репликации».


сервер разветвителя <термины Jet>

сервер разветвителя

Компьютер, включенный в сеть со звездообразной топологией. Реплика, находящаяся на данном компьютере, может быть использована для синхронизации других реплик.

См. также
базовый компьютер | звездообразная топология
периферийный компьютер |


локальный объект <термины Jet>

локальный объект

Объект (таблица или запрос), который существует только в реплике, в которой он был создан. Ни сам объект, ни его изменения не распространяются на другие компоненты набора реплик.


обрабатываемая реплика <термины Jet>

обрабатываемая реплика

Реплика, связанная с синхронизатором. Синхронизатор передает все изменения в другие реплики в наборе и принимает из них изменения.

Примечание. Если реплике не назначен синхронизатор, пользователь имеет возможность выполнить синхронизацию этой реплики в программе или с помощью другого синхронизатора. Однако невозможно задать расписание синхронизации для реплики, не имеющей присвоенного синхронизатора.


репликация объектов <термины Jet>

репликация объекта

Процесс создания синхронизируемых копий объекта базы данных (таблицы или запроса). Допускается также передача изменений структуры объекта из основной реплики в другие реплики, входящие в набор.


синхронизация по запросу <термины Jet>

синхронизация по запросу

Обмен данными между двумя репликами, который выполняется по явной команде пользователя.


реплика <термины Jet>

реплика

Копия базы данных, включающая все таблицы, запросы, формы, отчеты, макросы и модули. Отдельная реплика является компонентом набора реплик и допускает синхронизацию с другими репликами в наборе. Изменения данных в таблице в одной из реплик могут быть переданы в другие реплики и в основную реплику в наборе.

Примечание. Основная реплика также является репликой.


реплицируемая база данных <термины Jet>

реплицируемая база данных

База данных, в которую добавляются системные таблицы, поля и свойства, позволяющие регистрировать изменения данных и структуры реплицируемых объектов базы данных.


реплицируемый объект <термины Jet>

реплицируемый объект

Объект базы данных (таблица или запрос), который включается во все реплики в наборе. Изменение реплицируемого объекта допускается только в основной реплике. Эти изменения передаются затем в другие реплики в наборе реплик в процессе синхронизации.


набор реплик <термины Jet>

набор реплик

Основная реплика и все остальные реплики, имеющие общую структуру базы данных и уникальный идентификатор набора реплик. Компоненты набора реплик допускают взаимную синхронизацию.


компонент набора реплик <термины Jet>

компонент набора реплик

Реплика, входящая в набор реплик. Компоненты набора реплик имеют общую структуру базы данных и допускают взаимную синхронизацию.


создание реплики <термины Jet>

создание реплики

Создание копий базы данных или объектов, допускающих синхронизацию.


репликация <термины Jet>

репликация

Процесс создания и синхронизации реплик, сохраняемых в разных местах. При репликации в базу данных добавляются системные поля и таблицы, обеспечивающие взаимную передачу данных и изменений структуры между всеми компонентами набора реплик.


диспетчер репликации <термины Jet>

диспетчер репликации

Приложение, поддерживающее графический интерфейс пользователя, с помощью которого осуществляется управление местом сохранения, расписанием синхронизации и отношениями между одной или несколькими репликами и другими репликами в наборе. Диспетчер репликации осуществляет управление настройкой синхронизатора, непосредственно управляющего репликацией. Диспетчер репликации является частью комплекта Microsoft® Office 97, выпуск для разработчиков.


период автономности <термины Jet>

период автономности

Число дней, в течение которых в системе сохраняются определенные системные сведения о реплике. Если в течение периода автономности не была выполнена синхронизация реплики, синхронизация становится невозможной.


периферийный компьютер <термины Jet>

периферийный компьютер

Компьютер в сети со звездообразной топологией, на котором находится реплика. Такая реплика копируется с базового компьютера и по умолчанию синхронизируется с репликой на сервере разветвителя.

См. также
базовый компьютер | звездообразная топология
сервер разветвителя |


расписание <термины Jet>

расписание

Расписание, по которому синхронизатор выполняет синхронизацию реплики с другими репликами. Минимальный промежуток времени между двумя запланированными операциями синхронизации составляет 15 минут. Пользователь имеет возможность установить различные расписания синхронизации для любых двух синхронизаторов.


синхронизация по расписанию <термины Jet>

синхронизация по расписанию

Обмен данными между двумя репликами в указанное время.


общая сетевая папка <термины Jet>

общая сетевая папка

См. банк данных.


звездообразная топология <термины Jet>

звездообразная топология

Возможная структура соединения компьютеров сети. Для репликации существенными компонентами сети с такой структурой являются сервер разветвителя, базовый компьютер, а также распределение реплик набора по другим периферийным компьютерам. Топология сети существенна для определения схем синхронизации.

См. также
базовый компьютер | периферийный компьютер
сервер разветвителя |


конфликт синхронизации <термины Jet>

конфликт синхронизации

Ситуация, возникающая, когда пользователи двух реплик по-разному изменили одну и ту же запись. Одна из двух обновленных записей считается «правильной», а другая «неправильная» запись обновляется запись из другой таблицы помещается в конфликтную таблицу. Обновленная «неправильная» запись помещается в конфликтную таблицу.


ошибка синхронизации <термины Jet>

ошибка синхронизации

Ошибка, возникшая при синхронизации и не сводящаяся к конфликту записей, которая не позволяет успешно выполнить изменение записей. Ошибка синхронизации должна разрешаться немедленно.


синхронизация <термины Jet>

синхронизация

Процесс обновления двух реплик, при котором происходит взаимная передача обновленных записей и объектов. Обмен данных между репликами может быть как односторонним, так и двухсторонним. Кроме того, возможна синхронизация реплик под управлением синхронизатора.


топология набора реплик <термины Jet>

топология набора реплик

Порядок, согласно которому происходит передача изменений от одной реплики в наборе к другой. Топология определяет, как быстро изменения, внесенные в другую реплику, станут видимыми в конкретной реплике.


синхронизатор <термины Jet>

синхронизатор

Программа, контролирующая изменение реплик и управляющее фактическим обменом данными между репликами. Синхронизатор работает в фоновом режиме и отображается на панели задач. Состояние синхронизатора отражается в окне синхронизации диспетчера репликации.

Примечание. Синхронизатор существенно изменен по сравнению с предыдущими версиями диспетчера репликации.


окно синхронизации <термины Jet>

окно синхронизации

Область окна диспетчера репликации, в которой отображаются синхронизаторы. Пользователь имеет возможность перемещать синхронизаторы, а также изменять масштаб, что позволяет видеть больше или меньше синхронизаторов. Для изменения расписания синхронизации следует выбрать линию, связывающую два синхронизатора. Чтобы получить описание других значков в окне синхронизации, выберите в меню View команду Legend.