Мастер создания куба OLAP: обзор

С помощью данного мастера осуществляется пошаговый процесс организации внешних данных, выбранных в запросе, в куб OLAP, представляющий собой способ представления данных для последующего анализа. Мастер помогает подготовить данные для использования в отчете базы данных, например в сводной таблице, форме сводной таблицы или списке сводных таблиц на Web-странице.

Данный мастер предназначен для пользователей, которые занимаются управлением базами данных и созданием отчетов на их основе. Если вы не знакомы с управлением базами данных или являетесь новичком в создании отчетов данных типов и нуждаетесь в помощи, обратитесь за консультацией к пользователю, осуществляющему управление сетевой базой данных, с которой вам требуется работать.

Как этот мастер организует данные?

Описание шагов мастера

Подготовка к использованию мастера

Дополнительные сведения

Как этот мастер организует данные?

По окончании работы мастера создается куб, на основе которого можно строить отчеты. Если после создания и просмотра отчетов возникает необходимость перестроить куб или включить в него другие данные, для внесения изменений можно снова воспользоваться этим мастером.

Что такое OLAP? Электронная аналитическая обработка данных (On-Line Analytical Processing -- OLAP) является способом организации данных в иерархические категории с использованием предварительно рассчитанных итоговых значений для облегчения их последующего анализа. Куб OLAP предоставляет для отчетов только сводные результаты вместо большого числа отдельных записей, что обеспечивает возможность анализа большего объема данных, чем в противном случае позволяли бы ресурсы системы. При создании куба OLAP на основе данных из реляционной базы данных выполняются начальные шаги создания отчетов, которые требуются пользователям.

Поля данных и размерности. Данный мастер позволяет, взяв в качестве основы набор записей, организовать поля в иерархическую структуру и определить итоговые значения, которые требуется вычислить.

Получающийся в результате куб содержит два типа данных: итоговые значения и описательные сведения, относящиеся к этим значениям. Значения, для которых требуется подвести итог, например количество проданных позиций товара, называются полями данных. Описательные сведения, такие как, например, дата и место каждой продажи, распределяются по уровням, называемым размерностями.

При организации полей можно использовать те же типы категорий, которые применяются при анализе данных в отчетах. Поля данных и размерности облегчают отображение в отчетах итоговых значений высокого уровня, таких как общий объем продаж по стране или региону, а также отображение подробных сведений более низкого уровня, таких как области, где уровень продаж является наиболее высоким или низким.

Возврат в начало

Описание шагов мастера

Ниже приведено краткое описание использования мастера. Для получения более подробных инструкций см. Дополнительные сведения далее в этом разделе.

Шаг 1: определение полей данных. На первом шаге мастера определяются поля, которые будут использоваться в качестве полей данных, выбирается функция для расчета итоговых значений по каждому полю, а также имена полей.

Шаг 2: определение размерностей и уровней. На втором шаге остальные поля организуются в размерности и уровни, и задаются имена размерностей и уровней.

Шаг 3: выбор типа куба. Наличие или отсутствие третьего шага в данном мастере определяется тем, какая программа использовалась для доступа к данных и запуска мастера. На третьем шаге принимается решение о том, следует ли построить куб в памяти или сохранить его в соответствующем файле куба. Если данный шаг отсутствует, для выяснения типа создаваемого куба обратитесь к справочной системе программы, из которой запущен мастер.

Изменение созданного куба. По окончании работы мастера значения любых параметров можно изменять. Можно добавлять или удалять поля, изменять способ подведения итогов для полей данных, а также изменять способ организации размерностей. Сведения об изменении имеющегося куба см. в справочной системе программы, использовавшейся для доступа к данным, для которых создается куб.

Возврат в начало

Подготовка к использованию мастера

Перед созданием куба необходимо определить, какие поля в имеющейся структуре данных содержат значения, для которых будут подводиться итоги (для использования их в качестве полей данных), и какие поля содержат описательные данные (для использования в качестве размерностей).

Какие поля должны быть полями данных. Поля данных, содержащие значения, для которых можно подвести итог или вычислить сумму, составляют основу отчетов, создаваемых на основе куба. Например, если в базу данных по продажам включены поля, отражающие доход с продаж и имеющееся в наличии количество позиций товара, для каждого товара можно создать отчет об итоговых продажах и имеющихся на складах количествах (полях данных) по регионам (размерностям).

Итог для полей данных куба может подводиться четырьмя способами, с использованием следующих функций подведения итогов: вычисления суммы, количества значений, определения минимума и максимума.

Если требуется подвести итог по полю более чем одним способом, при запросе или выборе исходных данных необходимо каждый раз добавлять поле для каждого типа итогов. Например, если требуется вычислить итоговый доход с продаж (сумму) и число продаж (количество) для поля Продажи, поле Продажи необходимо добавить дважды. Для выполнения задач может потребоваться выйти из мастера и добавить большее количество полей данных.

Какие поля должны быть размерностями. Определите, как информация в отчете могла бы быть распределена по уровням детализации. Описательные поля, которые можно организовать в иерархическую структуру с использованием категорий, составляют размерность. Например, в базе данных по продажам могут иметься отдельные поля, определяющие страну, область, город и место каждой продажи. Размерность позволяет распределить эту географическую информацию по уровням детализации, от низшего к высшему, как показано ниже.

Уровни в размерности географических данных

Уровни в размерности географических данных

Если данные содержат поля даты или времени, мастер может настроить размерности для этих полей автоматически, организуя данные по соответствующим годам, полугодиям, кварталам, месяцам, неделям и дням, или по часам, минутам и секундам.

Поля, содержащие изолированные или обособленные данные, и не принадлежащие к иерархии, — например, поле, определяющее, облагается товар налогом или нет — можно определить как размерности с одним уровнем.

Эффективный отбор исходных данных. Все поля в кубе должны быть либо полями данных, либо размерностями, и каждое поле в структуре данных должно быть приписано к тому или другому типу. Для более эффективного выполнения запроса или выбора исходных данных и ускорения обновления отчетов, основанных на этих данных, следует включать в куб только те поля, которые будут использоваться. Перед запуском мастера убедитесь, что в запрос или выбор исходных данных включены те и только те данные, которые следует использовать.

Выбор требуемого типа куба. Позволяет мастер указать тип создаваемого куба или нет, зависит от программы, использовавшейся для создания запроса или выбора исходных данных. Чтобы определить, имеется ли в мастере этот шаг, или же этот выбор выполняется автоматически, обратитесь к справочной системе программы, из которой запущен мастер.

На этом шаге, если он присутствует, имеется возможность выбора из трех вариантов, каждый из которых предлагает различные сочетания производительности и использования памяти и дискового пространства.

  • Можно создать временный куб в памяти, связанной с отчетом, используемым в данный момент, и единовременно извлекать все данные для куба из исходной базы данных.

  • Можно также создать временный куб того же типа, что и в первом варианте, однако извлекать данные только тогда, когда они требуются отчету.

  • Кроме того, имеется возможность создать куб, который можно будет использовать для других отчетов.

Возможно, для определения наилучшего сочетания производительности и использования ресурсов оперативной и дисковой памяти для отчетов потребуется поэкспериментировать с этими параметрами. Оптимальный выбор зависит от объема данных, которые требуется включить в куб, и сложности создаваемых отчетов.

Дополнительные сведения об этих типах куба, а также о преимуществах и недостатках каждого из них приведены в разделе Мастер создания куба: шаг 3.

Возврат в начало

Дополнительные сведения

В следующих разделах приведены сведения, относящиеся к каждому из шагов мастера.

Шаг 1: определение полей данных.

Шаг 2: определение размерностей и уровней.

Шаг 3: выбор типа куба. (Наличие или отсутствие этого шага определяется тем, из какой программы запущен мастер.)

Возврат в начало


Мастер создания куба: шаг 1

На данном шаге определяется, какие поля исходных данных будут использоваться в качестве полей данных. Поля данных содержат значения, для которых требуется подвести итог, например объемы продаж. Необходимо выбрать хотя бы одно поле в качестве поля данных.

Мастер определяет, какие поля могут содержать этот тип данных, и предлагает их в качестве полей данных. Предлагаемыми являются отмеченные поля, расположенные в начале списка. Пользователь должен проверить, правильны ли предположения мастера, и внести необходимые изменения.

На данном шаге необходимо оставить неотмеченным хотя бы одно поле. Поля, не отмеченные на данном шаге, будут доступны для использования в качестве полей размерностей, т.е. полей, которые содержат описательные данные и сведения и выступают в отчетах в качестве категорий и строк данных. Выбор и организация полей размерностей выполняется на следующем шаге.

Для завершения этого шага выполните следующие действия.

  1. Установите флажки для любых дополнительных полей, которые будут использоваться в качестве полей данных, и снимите флажки, соответствующие полям, которые использоваться не будут. Хотя бы одно поле должно выбрано.

  2. Чтобы выбрать функцию подведения итогов, отличающуюся от предлагаемой мастером, щелкните предлагаемую функцию в столбце Операция и затем щелкните требуемую функцию. Функциями подведения итогов являются сумма, количество значений, минимум (возвращает наименьшее значение из данных, для которых вычисляется итог) и максимум (возвращает наибольшее значение).

    Для подведения итогов по тому же полю с использованием более одной функции запрос или выбор исходных данных должен содержать по одному вхождению поля для каждой требуемой функции. Чтобы добавить поля, нажмите кнопку Отмена для выхода из мастера; затем добавьте поля в запрос или выбор и снова запустите мастер.

  3. Чтобы изменить предлагаемое мастером имя поля, щелкните имя в столбце Имя поля данных и введите новое имя.

    Имена полей, назначаемые при работе мастера, отображаются в отчетах, создаваемых на основе куба. Возможность изменения имен полей в отчете зависит от типа создаваемого отчета.

Дополнительные сведения

Мастер создания куба OLAP: обзор


Мастер создания куба: шаг 2

На данном шаге выполняется организация описательных данных в размерности. Каждая размерность становится полем в отчетах, создаваемых на основе куба. Распределение полей по уровням детализации позволяет пользователям, работающим с отчетами, выбирать требуемый уровень детализации для просмотра, начиная с итоговых данных высокого уровня, и затем переходя к более подробному представлению, и наоборот.

Для куба должна быть задана хотя бы одна размерность. Поля, содержащие изолированные или обособленные данные, и не принадлежащие к иерархии, — например, поле, определяющее, облагается товар налогом или нет — можно определить как размерности с одним уровнем. Однако использование куба в создании отчетов будет более эффективным, если некоторые из полей организованы в уровни. Например, можно организовать три поля в размерность Товар, которая включает три уровня: подразделение товаров, группа товаров в составе подразделения и отдельный товар.

Если в качестве размерностей используются поля даты или времени, мастер автоматически создает уровни для этих размерностей. Пользователь может затем выбрать, какие уровни должны присутствовать в отчетах. Например, можно выбрать недели, кварталы и годы, или же недели, месяцы и годы.

Для завершения этого шага выполните следующие действия.

  1. Из списка Исходные поля перетащите каждое поле размерности верхнего уровня в поле Размерности в области, помеченной (Перетащите сюда поля для создания размерности). Необходимо создать хотя бы одну размерность.

    Каждое поле можно включить лишь один раз. Для использования одного и того же поля в более чем одной размерности, запрос или выбор исходных данных должен включать по одному вхождению поля для каждой размерности, в которой его требуется использовать. Чтобы добавить поля, нажмите кнопку Отмена для выхода из мастера; затем добавьте поля в запрос или выбор и снова запустите мастер.

  2. Чтобы создать уровень в составе размерности, перетащите поле из списка Исходные поля на имеющуюся размерность или уровень в поле Размерности, как показано в следующем примере.

    Пример перетаскивания поля на уровень

    Чтобы создать подуровень Город уровня Область, перетащите поле Город на уровень Область.

    Для отображения или скрытия уровней щелкните соответственно значок «плюс» или значок «минус».

    Поля, содержащие более подробные сведения, должны располагаться на более низких уровнях. Чтобы переместить поле на более низкий или более высокий уровень, щелкните поле в размерности и перетащите его на более низкое или более высокое поле в составе размерности.

    Для полей даты и времени мастер создает уровни автоматически только при создании с использованием поля новой размерности верхнего уровня. При добавлении этих полей в качестве уровней в имеющиеся размерности мастер не создает уровни даты и времени.

  3. Для размерностей даты и времени установите флажки, соответствующие уровням, которые должны быть доступны в отчетах, и снимите флажки уровней, которые включать в отчеты не требуется. При этом можно включить либо уровень Неделя, либо уровень Месяц, но не оба эти уровня, поскольку месяцы содержат неравное количество недель.

  4. Для изменения имени размерности или уровня щелкните имя один раз чтобы выбрать его, и затем щелкните его еще раз для ввода нового имени. Изменение имен уровней в размерностях даты и времени не допускается.

    Имена полей, назначаемые при работе мастера, отображаются в отчетах, создаваемых на основе куба. Возможность изменения имен полей в отчете зависит от типа создаваемого отчета.

Дополнительные сведения

Сочетания клавиш, используемые на данном шаге мастера создания куба

Мастер создания куба OLAP: обзор


Мастер создания куба: шаг 3

На данном шаге выполняется выбор типа куба, создаваемого мастером. Наилучший выбор определяется несколькими факторами, включая тот объем данных, который будет содержать куб, тип и сложность отчетов, которые будут создаваться на основе куба, и ресурсы (память и дисковое пространство), доступные в системах, используемых пользователями при создании и просмотре отчетов. При этом может потребоваться поэкспериментировать с этими параметрами для определения того, какой тип куба лучше всего подходит для создаваемых отчетов.

Вариант 1: извлечение данных по запросу

Описание. При выборе данного варианта инструкции по созданию куба хранятся вместе с запросом или отчетом, и сам куб создается только при открытии отчета. Первоначально куб извлекает только данные, необходимые для отображения отчета, остальные данные извлекаются по мере необходимости при просмотре отчета.

Когда следует использовать. Данный вариант следует использовать для отчетов, открываемых и просматриваемых пользователями, однако редко изменяемых, а также при нехватке памяти или дискового пространства при использовании других типов куба.

Производительность и использование ресурсов. Поскольку для куба извлекаются только те данные, которые первоначально отображаются в отчете, затраты времени на открытие отчета минимальны. Например, если в кубе организованы данные о продажах в четырех регионах, но первоначально в отчете отображены только данные, относящиеся к продажам в западном регионе, куб извлекает только данные по западному региону. Однако каждый раз, когда пользователь изменяет область данных, отображаемых в отчете, возникает задержка, связанная с извлечением новых данных, поэтому изменение отчета может потребовать больше времени.

Вариант 2: единовременное извлечение всех данных

Описание. Как и в первом варианте, инструкции по созданию куба хранятся вместе с запросом или отчетом, и сам куб создается только при открытии отчета. Однако в этом случае куб извлекает сразу все данные для отчета при первом открытии этого отчета, и изменение области отображаемых данных происходит без потерь времени на ожидание извлечения кубом необходимых данных.

Когда следует использовать. Данный вариант следует использовать для интенсивно используемых или постоянно изменяемых отчетов, когда нежелательно выделение для отчетов постоянного дискового пространства

Производительность и использование ресурсов. Поскольку при выборе данного варианта все данные будут доступны сразу же при открытии отчета, изменение области и просмотр других данных будут происходить с более высокой скоростью. Однако для данного типа куба требуется больший объем памяти и временного дискового пространства, чем для куба, извлекающего данные по запросу, что может привести к нехватке ресурсов в случае, если куб включает большой объем данных.

Вариант 3: сохранение куба в файле

Описание. При выборе данного варианта извлекаются все данные для куба и на диске создается отдельный файл куба, в котором хранятся эти данные.

Когда следует использовать. Данный вариант следует использовать для часто изменяемых интерактивных отчетов при наличии достаточного дискового пространства для отчета, или в случае, когда требуется сохранить куб на сетевом сервере для обеспечения доступа к нему других пользователей при создании отчетов. Файл куба может предоставить определенные данные из исходной базы данных, опуская при этом секретные или конфиденциальные данные, доступ к которым для других пользователей требуется закрыть. Файл куба позволяет также работать с отчетами в автономном режиме с использованием снимка исходной базы данных.

Производительность и использование ресурсов. Для первоначального создания файла куба может потребоваться больше времени, чем при выборе других вариантов, однако открытие и изменение отчетов может происходить быстрее. На скорость открытия и изменения отчетов оказывает влияние размер файла куба. Размер файла определяется объемом данных, включенных в куб, и способом организации куба в поля данных и размерностей. Если имеется ограниченное дисковое пространство, для уменьшения размера файла куба поэкспериментируйте с различными типами организации и выбора данных; если нехватка ресурсов не устранена, вместо создания файла куба следует использовать другие варианты.

Файлы кубов и файлы определения кубов

Сохранение файла куба. При использовании третьего варианта в указываемом пользователем местоположении создается файл куба с расширением .cub. Данный файл содержит все данные для куба. Создание данного файла не происходит немедленно при нажатии кнопки Готово; файл создается либо при сохранении определения куба в файле, либо при создании отчета на основе куба.

Сохранение в файле определения куба. Данная процедура применима только в том случае, если мастер создания куба запущен из Microsoft Query. При использовании всех трех вариантов Microsoft Query выдает запрос на сохранение файла определения куба (.oqy), который может быть открыт в программе Excel для создания отчетов на основе этого куба. Данный файл хранится отдельно от всех файлов .cub, создаваемых для хранения фактических данных куба. При необходимости внесения изменений в куб можно открыть соответствующий файл .oqy в программе Query для повторного запуска мастера создания куба. Дополнительные сведения о работе с файлами .oqy приведены в справочной системе Microsoft Query.

Дополнительные сведения

Мастер создания куба OLAP: обзор


Клавиши, используемые при работе с мастером создания куба

Данные клавиши используются при выполнении шага 2 мастера создания куба.

Чтобы переместить поле из списка Исходные поля в окно размерностей

  1. Нажмите клавишу TAB, чтобы выбрать список Исходные поля.

  2. Чтобы выбрать поле, которое требуется переместить, нажимайте клавиши СТРЕЛКА ВВЕРХ или СТРЕЛКА ВНИЗ.

  3. Нажмите клавишу TAB, чтобы выбрать кнопку > и затем нажмите клавишу ENTER.

  4. Для перемещения других полей повторите шаги 1 - 3.

Чтобы переместить поле в окне размерностей на более низкий или более высокий уровень в составе размерности

  1. Нажмите клавишу TAB, чтобы выбрать поле Размерности.

  2. Чтобы выбрать поле, которое требуется переместить, нажимайте клавиши СТРЕЛКА ВВЕРХ или СТРЕЛКА ВНИЗ.

  3. Нажмите клавиши CTRL+X.

  4. Чтобы выбрать место, в которое требуется переместить поле, нажимайте клавиши СТРЕЛКА ВВЕРХ или СТРЕЛКА ВНИЗ.

  5. Нажмите клавиши CTRL+V.