О Web-диаграммах

Содержание раздела

Обзор

Приступая к работе

Подготовка исходных данных

Создание диаграммы с помощью мастера

Изменение диаграммы

Проверка и опубликование

Обзор

Диаграммы представляют данные в наглядном виде, упрощают их восприятие и анализ. Соответствующий Web-компонент позволяет создавать динамические, интерактивные диаграммы, которые можно разместить на Web-узле и просматривать с помощью обозревателя. После изменения данных диаграмма обновляется автоматически.

Диаграмма и электронная таблица на Web-странице.

Пример Web-диаграммы, отображающей данные Web-компонента — размещенной на Web-странице электронной таблицы. Если при просмотре такой Web-страницы с помощью обозревателя изменить значения в электронной таблице, то диаграмма обновится и наглядно отобразит внесенные изменения.

На Web-диаграммах можно отображать данные, извлеченные запросами, либо хранящиеся в таблицах баз данных, электронных таблицах и сводных таблицах. Web-диаграммы создаются на Web-страницах с помощью Web-компонентов Microsoft Office или публикуются из Microsoft Excel.

Создание диаграммы. Создание диаграммы включает в себя несколько шагов. Более подробно они будут рассмотрены ниже. В целом создание диаграммы сводится к следующему.

  • Приступая к работе

  • Подготовка данных, которые должны быть представлены на диаграмме.

  • Размещение на Web-странице элемента управления диаграммой, выбор типа диаграммы и источника данных с помощью мастера диаграмм.
  • Изменение диаграммы.

  • Опубликование диаграммы на Web-странице.

Возврат в начало

Приступая к работе

Как пользователи будут работать с данными? Прежде чем создавать диаграмму, следует позаботиться о том, чтобы пользователи были обеспечены надлежащим средством просмотра и Web-компонентами Microsoft Office.

Для просмотра диаграмм и работы с ними требуются Web-компоненты Microsoft Office. Их можно установить при установке пакета Microsoft Office 2000. Пользователи, организации которых имеют лицензию на доступ к Web-узлу Office 2000, могут загрузить Web-компоненты Microsoft Office через корпоративную интрасеть. Для работы с диаграммами также необходим обозреватель Microsoft Internet Explorer версии 4.01 или более поздней. См. также Использование обозревателя для работы с Web-диаграммами.

Какую программу-конструктор использовать? Программа-конструктор — это программа для создания и изменения диаграмм. Программы-конструкторы отличаются своими возможностями. Например, мощные средства программы Microsoft Excel позволяют создавать, сохранять и публиковать как статические (рисунки), как и интерактивные диаграммы. Программа Microsoft FrontPage 2000 позволяет создавать динамические Web-страницы с диаграммами и публиковать эти страницы на Web-узле. Для автоматического подключения к базам данных можно воспользоваться средствами конструктора страницы доступа к данным Microsoft Access. С помощью Microsoft FrontPage 2000 или конструктора страницы доступа к данным Microsoft Access можно открыть Web-страницу, содержащую диаграмму, и изменять эту диаграмму. Excel не позволяет открывать и изменять опубликованные на Web-страницах диаграммы.

См. Возможности программ-конструкторов.

Возврат в начало

Подготовка данных, которые должны быть представлены на диаграмме

Для диаграмм на Web-страницах можно использовать данные из баз данных, а также из элементов управления Web-компонентов Microsoft Office: электронных таблиц и сводных диаграмм.

Если требуется отобразить на диаграмме данные электронной таблицы или сводной таблицы, то вначале следует открыть Web-страницу, содержащую какой-либо из этих элементов управления, либо создать новый элемент управления с данными для Web-страницы.

Если на диаграмме нужно отобразить данные, содержащиеся в базе данных, то вначале следует подключиться кэтой базе данных, а затем, если необходимо, выполнить запрос для извлечения данных. Например, таблица базы данных содержит сведения о годовых продажах за пятилетний период, а на диаграмме требуется отобразить данные только за один год. В этом случае следует выполнить запрос для извлечения из таблицы данных за этот год, а затем использовать их в качестве источника данных для диаграммы. См. сведения об источниках данных для Web-диаграмм.

Возврат в начало

Создание диаграммы с помощью мастера

После подготовки данных для диаграммы, с помощью программы-конструктора следует разместить на Web-странице элемент управления диаграммой.

При размещении на Web-странице элемента управления диаграммой автоматически запускается мастер диаграмм, с помощью которого выбираются подходящий тип диаграммы и данные из списка открытых и доступных источников данных. Для некоторых типов данных выбирается также способ отображения данных.

Возврат в начало

Изменение диаграммы

Панель свойств диаграммы. После создания диаграммы можно изменять ее тип, добавлять подписи и названия, изменять шрифт, стиль текста и другие параметры. Выполняется это с помощью панели свойств диаграммы.

Панель свойств диаграммы

На панели свойств диаграммы находятся кнопки и другие элементы управления внешним видом диаграммы. Они позволяют изменять цвет маркеров данных, расположение легенды, цену деления осей и прочие характеристики диаграммы. Содержимое панели свойств диаграммы зависит от выбранного элемента диаграммы.

Команды и свойства панели свойств распределены по разделам, имена которых отображаются на соответствующих панелях. Набор доступных разделов определяется выбранным элементом диаграммы. При первом вызове панели свойств диаграммы отображаются Общие команды и свойства. Для вызова или скрытия содержимого раздела достаточно щелкнуть панель этого раздела. См. Использование панели свойств.

Ввод описания. Диаграмму можно сопроводить пояснительным текстом, который вводится на свободном месте Web-страницы. См. Ввод описания диаграммы.

Сценарии. Изменять вид диаграммы средствами обозревателя пользователи не могут. Однако им можно предоставить доступ ко многим возможностям соответствующего элемента управления Web-компонента, добавив к диаграмме сценарий. Сценарии для Web-страниц пишутся на таких языках как Visual Basic Scripting Edition (VBScript) и JavaScript. Сценарии изменяют вид диаграммы и передают пользователю данные, когда он выполняет заданные действия в обозревателе.

В некоторых программах-конструкторах предусмотрены средства для создания сценариев. В пакете программ Microsoft Office таким средством является редактор сценариев (Microsoft). Сведения о создании сценариев содержатся в справке программы-конструктора. О средствах доступа к диаграммам из сценариев см. справку по программированию для Web-диаграмм.

Возврат в начало

Проверка и опубликование

Проверка диаграммы в обозревателе. Прежде чем представить доступ к диаграмме пользователям, ее следует проверить в обозревателе. Для работы с диаграммами, опубликованными в Интернете, рекомендуется Internet Explorer 5. Просматривать диаграммы в интерактивном режиме можно также с помощью Internet Explorer 4.01 и более поздних версий. Если диаграмма предназначена для пользователей с разными версиями обозревателя, то ее необходимо проверить во всех этих версиях. Диаграмма должна правильно отображаться и обновляться в обозревателе каждого пользователя. См. использование обозревателя для работы с диаграммами в Интернете.

Опубликование Web-страницы. После проверки Web-страница может быть сделана доступной пользователям. Сведения об опубликовании Web-страниц содержатся в справке программы-конструктора. При необходимости обратитесь к Web-мастеру или администратору сети.

Возврат в начало


Создание Web-диаграммы

Конкретные шаги при создании Web-диаграммы зависят от программ, используемых для конструирования Web-страницы. Дополнительные сведения содержатся в справке этих программ. Если программа-конструктор не способна создавать управляющие элементы, такие как диаграмма, выполните следующее:

  1. С помощью программы-конструктора откройте или создайте базу данных, проект или Web-страницу с данными, которые будут отображаться на диаграмме.

  2. Перейдите на страницу, на которой требуется поместить диаграмму.

  3. Используя процедуру программы-конструктора по добавлению управляющего элемента к Web-странице, обозначьте на Web-странице положение и начальный размер элемента управления.

  4. Следуйте инструкциям мастера диаграмм Microsoft Office.

Советы

  • Если в качестве источника данных используется электронная таблица Web-диаграммы Microsoft Office, то в этой таблице можно выбрать диапазон ячеек с данными, которые требуется отобразить на Web-диаграмме. В это случае диапазон данных автоматически запоминается мастером диаграмм.

  • Для вызова справки по любому из шагов мастера диаграмм нажмите кнопку Справка [image] в мастере диаграмм.

  • После создания диаграммы нельзя изменить ее параметры или источники данных путем повторного запуска мастера диаграмм. Некоторые параметры диаграммы можно изменить с помощью панели свойств диаграммы. Чтобы изменить источник данных, создайте новую диаграмму.


Программы для создания Web-диаграмм

Для создания и изменения Web-диаграмм существует несколько программ-конструкторов. Можно создать диаграмму с помощью одной программы, а затем изменять эту диаграмму или содержащую ее Web-страницу с помощью других программ. При выборе программы-конструктора следует принять во внимание следующее: объем предстоящей работы по конструированию и администрированию Web-страницы, тип исходных данных, степень знакомства с той или иной программой-конструктором. Например, если исходные данные содержатся на листе Microsoft Excel, то создать и опубликовать диаграмму можно с помощью Microsoft Excel 2000. Если исходные данные содержатся в базе данных, удобнее воспользоваться конструктором страниц доступа к данным Microsoft Access 2000. Если Web-страницу нужно оформить специальными эффектами или разместить на Web-узле, то желательно воспользоваться программой Microsoft FrontPage 2000. Программисты могут создавать диаграммы в формах, а затем автоматизировать диаграммы с помощью Microsoft Visual Basic. Далее представлены сведения о создании и изменении диаграмм с использованием следующих программ:

Microsoft Excel 2000

Microsoft FrontPage 2000

Microsoft Access 2000

Microsoft Visual Basic

Microsoft Excel 2000

Microsoft Excel удобно использовать в случае, если исходные данные содержатся на листе, либо перед опубликованием диаграммы требуется подобрать ее тип и исходные данные. При опубликовании диаграммы из Excel исходные данные автоматически присоединяются к диаграмме и публикуются на Web-странице вместе с интерактивной электронной таблицей или сводной таблицей. При этом сохраняются многие возможности, предусмотренные для диаграмм в Excel. См. Работа с диаграммой, опубликованной из Excel.

С помощью Excel нельзя изменить опубликованную диаграмму, но можно изменить исходную диаграмму (если она была сохранена в файле .xls), а затем опубликовать ее вместо прежней. Открыть Web-страницу с опубликованной диаграммой, изменить диаграмму и Web-страницу позволяют FrontPage 2000 и конструктор страниц доступа к данным Microsoft Access. См. вызов справки об опубликовании диаграммы из Excel и работа с диаграммой, опубликованной из Excel.

Возврат в начало

Microsoft FrontPage 2000

FrontPage 2000 используется для создания и изменения Web-диаграмм. Большие возможности FrontPage позволяют добавлять к Web-страницам элементы управления, рисунки, темы и проч., размещать Web-страницы на Web-узле. См. Вызов справки в FrontPage.

Microsoft FrontPage 2000 содержится в Microsoft Office 2000 Premium.

Возврат в начало

Microsoft Access 2000

В Microsoft Access 2000 предусмотрены средства для создания Web-страниц и отображения на них данных из баз данных. Access позволяет установить связь между базой данных Access и исходными данными для диаграммы, а затем связать эти данные с диаграммой с помощью автоматических средств конструктора страниц доступа к данным. Например, поместить на Web-страницу таблицу, используя Список полей, затем создать на Web-странице диаграмму, отображающую данные из этой таблицы. Можно также установить связь между диаграммами и элементами управления, которые позволяют манипулировать на Web-странице данными, извлекаемыми из базы данных. Конструктор страниц доступа к данным в Access используется для создания диаграмм, которые будут просматриваться с помощью Internet Explorer 5 или более поздних версий. См. Вызов справки в Access.

Microsoft Access 2000 содержится в Microsoft Office 2000 Professional и Microsoft Office 2000 Premium.

Возврат в начало

Microsoft Visual Basic

Язык программирования Visual Basic используется для создания диаграммы в случае, когда требуются дополнительные средства программирования, отсутствующие в редакторе сценариев (Microsoft), Excel и Access. Поскольку программная среда Visual Basic не обеспечивает доступа ни к мастеру диаграмм Microsoft Office, ни к панели свойств диаграммы, то все операции создания и изменения диаграммы, а также привязка данных выполняются программным путем. См. Вызов справки по программированию Web-диаграммы.

Возврат в начало


Исходные данные для Web-диаграмм

Прежде чем приступить к созданию Web-диаграммы, следует подготовить данные, которые будут на ней отображены. Обычно эти данные размещаются на той же Web-странице, где предполагается разместить диаграмму. Для диаграммы можно использовать данные из следующих источников:

Элемент управления электронными таблицами. Элемент управления электронными таблицами — это Web-компонент Microsoft Office, используемый для отображения на Web-странице значений, вычисляемых в электронной таблице. Пользователи могут просматривать и изменять содержащиеся в электронной таблице данные с помощью своих Web-обозревателей. При изменении отображаемых на диаграмме данных она обновляется. Электронная таблица и диаграмма должны находиться на одной Web-странице.

Электронная таблица создается с помощью любой программы-конструктора, поддерживающей Web-компоненты Microsoft Office, такой как конструктор страниц доступа к данным в Microsoft Access 2000. Если данные уже существуют на листе Microsoft Excel 2000, то их можно опубликовать в виде интерактивной электронной таблицы. Можно также создать диаграмму, использующую данные листа Microsoft Excel. Если она публикуется в виде интерактивной диаграммы, то вместе с ней также публикуется интерактивная электронная таблица. Дополнительные сведения об опубликовании элементов управления электронными таблицами содержится в справке программы-конструктора.

Элемент управления сводными таблицами. Элемент управления сводными таблицами — это Web-компонент Microsoft Office, используемый для представления на Web-странице данных, извлекаемых из базы данных или иного источника. Пользователи могут просматривать и изменять сводную таблицу с помощью своих Web-обозревателей. При изменении сводной таблицы автоматически обновляются отображающая ее данные диаграмма. Сводная таблица и диаграмма должны находиться на одной Web-странице.

Прежде чем создавать диаграмму, следует подготовить все необходимые данные для сводной таблицы. Она создается с помощью программы-конструктора, поддерживающей Web-компоненты Microsoft Office, такой как конструктор страниц доступа к данным в Microsoft Access 2000. Уже существующую сводную таблицу можно опубликовать из Microsoft Excel. Дополнительные сведения о создании сводной таблицы содержатся в справке программы-конструктора.

Таблица базы данных или запрос. Диаграмма может отображать данные, извлеченные из базы данных запросом, а также данные, хранящиеся в таблице базы данных (или представлении). Программа-конструктор должна иметь доступ к этим данным. Их можно извлекать, например, из базы данных Access или из проекта, подключенного к базе данных Microsoft SQL Server. При обновлении данных обновляется и отображающая их диаграмма.

Для доступа к данным, хранящимся в базе данных, иногда требуются привилегии и специальные средства, такие как источник данных, которые зависят от типа базы данных и программы-конструктора. Источник данных — это файл, иногда текстовый, который содержит имя драйвера базы данных и прочие сведения, необходимые для подключения к базе данных и извлечении из нее данных. Сведения о доступе к базам данных содержатся в справке программы-конструктора.

Дополнительные сведения

Создание Web-диаграммы

Как создать Web-диаграмму


Элементы Web-диаграммы

Содержание раздела

Представление данных на диаграмме

Оси диаграмм

Заголовки и подписи диаграмм

Элементы диаграмм: представление данных

Примеры элементов диаграмм, представляющих данные

Категория. Группа связанных точек данных, в которую входит по одной точке данных из каждого ряда данных, отображаемых на диаграмме. На большинстве диаграмм категории отображаются вдоль оси категорий (оси X), обычно расположенной горизонтально. Однако на некоторых диаграммах ось категорий вертикальна. Примером может служить линейчатая диаграмма. На приведенной диаграмме «Кв.1», «Кв.2», «Кв.3» и «Кв.4» являются категориями, каждая из которых образована одним значением из ряда «Плановые» и одним — из ряда «Фактические».

Маркер данных. Используется для представления точки данных, отдельное значение которой отображено на диаграмме. Взаимосвязанные точки данных образуют ряды данных. Примерами маркеров данных являются полоски, точки и треугольники.

Ряд данных. Группа связанных точек данных, отображаемых на диаграмме. Каждый ряд данных имеет уникальный цвет или узор фона, который расшифровывается ключом легенды и названием ряда. На приведенной для примера диаграмме, изображены два ряда: «Плановые» и «Фактические». На большинстве диаграмм могут отображаться как один, так и несколько рядов данных.

Сетка на диаграмме. Линии, которые можно добавить к диаграмме, чтобы упростить просмотр и оценку данных. Сетка проходит от делений на оси диаграммы через всю область построения.

Легенда. Расшифровывает обозначения и цвета различных рядов или категорий, отображаемых на диаграмме.

Ключи легенды. Изображения на легенде, показывающие, какие обозначения и цвета фона назначены рядам и категориям. Ключи легенды отображаются слева от ее записей.

Область построения. Область диаграммы, ограниченная осями, в которой располагаются все ряды данных.

Возврат в начало

Элементы диаграммы: оси

Оси на диаграмме

Ось значений (ось Y). Линия, ограничивающая одну из сторон области построения, обеспечивающая систему отсчета для измерения и сравнения данных на диаграмме. На большинстве диаграмм значения данных размещаются вдоль оси значений (оси Y), которая обычно вертикальна. Однако в некоторых случаях ось значений может располагаться горизонтально, например на линейчатых диаграммах. Также существуют диаграммы, на которых значения данных отображаются по обеим осям, например на точечной диаграмме.

Подписи меток делений оси значений (оси Y). Также называются подписями оси значений. Они описывают величины, отложенные на оси значений.

Заголовок оси значений (оси Y). Заголовок обычно описывает то, что отображено по оси значений.

Основные и промежуточные метки делений. Штрихи, которые пересекают ось как деления линейки. Интервал между основными метками делений равен основному шагу шкалы, а метки промежуточных делений делят этот шаг на части. Оба типа меток могут располагаться как внутри области построения, так и за ее пределами, а также пересекать ось.

Ось категорий (ось X). Линия, ограничивающая одну из сторон области построения, обеспечивающая систему отсчета для измерения и сравнения данных диаграммы. Категория — это группа точек данных, в которую входит по одной точке данных из каждого ряда диаграммы. На большинстве диаграмм категории размещаются вдоль оси категорий (оси X), обычно расположенной горизонтально. Однако на некоторых диаграммах ось X может быть вертикальна, например на линейчатых диаграммах. Существуют также типы диаграмм, которые не имеют оси категорий, например точечные диаграммы.

Подписи меток делений оси категорий (оси X). Также называются подписями категорий. Показывают имена категорий на оси категорий.

Заголовок оси категорий (оси X). Заголовок, обычно используемый для названия того, что отображается по оси категорий.

Возврат в начало

Элементы диаграммы: заголовки и подписи

Заголовки и подписи на диаграмме

Заголовок диаграммы. Заголовок описывает диаграмму. Может располагаться над диаграммой, под ней, слева или справа.

Подписи оси значений. Также называются подписями меток делений оси. Показывают отложенные на оси значений величины.

Заголовок оси значений. Заголовок описывает то, что отображено на оси значений.

Подписи категорий. Также называются подписями делений. Показывают названия категорий, расположенных на оси категорий. Категория — это группа точек данных, в которую входит по одной точке данных из каждого ряда данных, отображаемых на диаграмме.

Заголовок оси категорий. Заголовок обычно описывает то, что отображается по оси категорий.

Имя ряда. Имя описывает группу связанных точек данных, образующих ряд данных. Имена рядов указываются в легенде рядом с ключами легенды. В приведенном примере диаграммы названиями рядов являются «Плановые» и «Фактические» , им соответствуют маркеры данных на диаграмме.

Подпись данных. Подпись обеспечивает дополнительные сведения о маркере данных, представляющем определенную точку или значение данных. В зависимости от типа диаграммы подписи данных могут показывать значения, названия рядов данных или категорий, процентные отношения или комбинацию всего упомянутого.

Возврат в начало


Способы выбора элементов на Web-диаграмме

Переход на диаграмму. Чтобы выбрать элемент Web-диаграммы, необходимо прежде всего активизировать данную диаграмму. Для этого необходимо щелкнуть диаграмму один или два раза в зависимости от используемой программы-конструктора. На страницах доступа к данным достаточно щелкнуть один раз. При этом на границах диаграммы появятся белые метки выделения.

Диаграмма, выделенная на странице доступа к данным

Диаграмма, выделенная на странице доступа к данным

Повторный щелчок активизирует диаграмму. Вокруг нее появляется граница выделения.

Диаграмма, активизированная на странице доступа к данным

Диаграмма, активизированная на странице доступа к данным

После активизации диаграммы можно выбрать расположенные на ней элементы.

Выделение элементов диаграммы

Выделение элемента. Чтобы выбрать ряд или группу элементов, щелкните один раз. Для выбора одного конкретного элемента внутри ряда или группы элементов щелкните элемент второй раз.

Диаграмма с выделенными маркерами данных

Диаграмма с выделенными маркерами данных

Использование списка выделения. Элемент можно выделить иначе — выбрать его имя в списке выделения в разделе Общие на панели свойств диаграммы. Например, чтобы выбрать первый ряд диаграммы, перейдите на нее, а затем выберите в списке выделения Диаграмма 1 Ряд 1.


Использование обозревателя для работы с Web-диаграммами

Для просмотра Web-диаграмм и работы с ними у пользователей должны быть установлены: обозреватель Microsoft Internet Explorer версии 4.01 или более поздней, Web-компоненты Microsoft Office. Их можно установить при установке пакета Microsoft Office 2000. Пользователи, организации которых имеют лицензию на доступ к Web-узлу Office 2000, могут загрузить Web-компоненты Microsoft Office через корпоративную интрасеть. За дополнительными разъяснениями обратитесь к Web-мастеру или администратору сети.

Обозреватель позволяет просматривать диаграммы, автоматически обновляемые при изменении отображаемых на них данных. Например, если диаграмма отображает курсы акций, то изменение курсов автоматически вызывает изменение диаграммы.

Изменение данных, отображаемых на диаграмме. В некоторых случаях пользователи могут изменять отображаемые на диаграмме данные. Эта возможность зависит от типа исходных данных и предоставленного пользователям уровня доступа. Например, можно разместить на Web-странице электронную таблицу с данными, а рядом — построенную на ее основе диаграмму, и разрешить пользователям изменять часть этих данных. В этом случае пользователи получают возможность изменять диаграмму путем изменения данных.

Изменение диаграммы. Пользователи, просматривающие диаграмму в обозревателе, не имеют доступа к панели свойств диаграммы и справке по Web-диаграммам. Это означает, что они не могут изменить тип диаграммы и форматирование ее элементов. Однако пользователям можно предоставить дополнительные возможности работы с диаграммой, написав сценарий с командами, которые изменяют диаграмму в ответ на заданные действия пользователей. Например, можно добавить на Web-страницу кнопку, нажимая на которую пользователи смогут изменять диаграмму. См. Вызов справки по программированию Web-диаграммы.

Версия обозревателя, необходимая для работы с диаграммами. Работать с диаграммой интерактивно — это значит изменять исходные данные и изучать обновленную диаграмму. Для этого пользователю необходим обозреватель Microsoft Internet Explorer версии 4.01 или более поздней. Рекомендуется Internet Explorer 5, который входит в состав Microsoft Office 2000 и позволяет пользоваться всеми интерактивными возможностями в полной мере. Более полные сведения о возможностях изменения исходных данных с помощью различных версий обозревателя содержатся в справке по работе с исходными данными.

Справка, доступная в обозревателе. Из обозревателя можно вызвать справку, содержащуюся в нем самом, а также справку о работе с исходными данными для Web-диаграмм. Например, если исходные данные для Web-диаграммы содержатся в сводной Web-таблице, то из обозревателя можно вызвать справку по сводным таблицам. См. Ввод описания Web-диаграмм.


Примеры типов Web-диаграмм

Далее кратко описаны следующие типы диаграмм:

С областями

Гистограмма

Линейчатая

График

Гладкий график

Круговая

Кольцевая

Биржевая

Точечная

Пузырьковая

Лепестковая

Полярная

С областями

Диаграмма с областями подчеркивает изменение с течением времени. Отображая сумму значений рядов, такая диаграмма наглядно показывает вклад каждого ряда.

Диаграмма с областями

В данном примере диаграмма с областями показывает увеличение продаж в штате Вашингтон, а также иллюстрирует вклад каждого штата в общий объем продаж.

Возврат в начало

Гистограмма

Гистограмма показывает изменение данных за определенный период времени и иллюстрирует соотношение отдельных значений данных. категории располагаются по горизонтали, а значения — по вертикали.

Гистограмма с накоплением демонстрирует вклад отдельных элементов в общую сумму.

Гистограмма с накоплением

Возврат в начало

Линейчатая

Линейчатая диаграмма иллюстрирует соотношение отдельных величин. Категории расположены по горизонтали, значения — по вертикали. Таким образом внимание переносится на соотношение величин, а не на их изменение во времени.

Линейчатая диаграмма с накоплением показывает вклад отдельных элементов в общую сумму.

Линейчатая диаграмма с накоплением

Возврат в начало

График

График наглядно показывает изменение величин через равные промежутки времени.

Возврат в начало

Гладкий график

Гладкий график наглядно показывает изменение величины через равные промежутки времени, а также позволяет оценить величину внутри этих промежутков благодаря гладкой кривой, проведенной через точки данных.

Возврат в начало

Круговая

Круговая диаграмма показывает вклад элементов ряда данных в общую сумму. На круговой диаграмме можно отобразить только один ряд данных, поэтому она особенно полезна в случае, когда нужно подчеркнуть вклад основного элемента.

Для отображения нескольких рядов можно воспользоваться многоуровневой круговой диаграммой.

Многоуровневая круговая диаграмма

Возврат в начало

Кольцевая

Как и круговая диаграмма, кольцевая диаграмма показывает вклад элементов в общую сумму, но может отобразить несколько рядов данных. Каждый ряд отображается в виде кольца.

Возврат в начало

Биржевая

Существуют два типа биржевых диаграмм, которые обычно используется для отображения курсов акций — либо четырех курсов (курс при открытии торгов, максимальный, минимальный, курс при закрытии торгов), либо трех курсов (максимальный, минимальный, курс при закрытии торгов). На этих диаграммах можно также отображать научные данные, например, минимальную, максимальную и среднюю температуру. Для построения биржевой диаграммы необходимо правильно расположить данные в таблице. Ниже приведен пример диаграммы с тремя курсами — минимальным, максимальным и курсом при закрытии торгов.

Данные и отображающая их биржевая диаграмма.

Возврат в начало

Точечная

Точечная диаграмма показывает взаимосвязь между числовыми значениями нескольких рядов данных, либо отображает две группы чисел как один ряд точек с координатами x, y. На приведенной ниже диаграмме приведена температура, измеренная через неравные промежутки времени, а также расчетная температура. Такие диаграммы часто используются в науке для иллюстрации экспериментальных данных.

Данные, предназначенные для отображения на диаграмме, располагаются в таблице одним из следующих способов: значения x — в столбце, а соответствующие им значения y — в смежном столбце; либо значения x — в строке, а соответствующие им значения y — в смежной строке.

Данные для построения диаграммы

Возврат в начало

Пузырьковая

Пузырьковая диаграмма — это разновидность точечной диаграммы. Размер маркера данных отображает значение третьей переменной.

Данные, предназначенные для отображения на диаграмме, располагаются в таблице одним из следующих способов: значения x — в столбце, а соответствующие им значения y и размеры пузырьков — в смежных столбцах; либо значения x — в строке, а соответствующие им значения y и размеры пузырьков — в смежных строках.

Данные для построения диаграммы

Возврат в начало

Лепестковая

На лепестковой диаграмме каждая категория имеет собственную ось, исходящую из начала координат. Значения одного ряда соединяются одной ломаной линией, значения другого ряда — другой ломаной линией, и так далее.

Лепестковая диаграмма позволяет сравнить несколько рядов данных по единственному показателю — площади, охватываемой ломаной линией. На диаграмме, приведенной в качестве примера, ясно видно, что больше всего витаминов содержится в сорте А, поскольку соответствующая ему ломаная линия охватывает наибольшую площадь.

Возврат в начало

Полярная

Полярная диаграмма отображает зависимость расстояния от угла. На приведенном примере показаны углы возвышения и соответствующие им высоты радиоантенны.

Возврат в начало


Открытие содержания справки по программе-конструктору

При открытии раздела справки по Web-диаграммам, на вкладке Содержание в окне справки показаны разделы справки только по Web-диаграммам.

Чтобы открыть разделы справки по программе-конструктору:

  1. Выберите вкладку Мастер ответов в окне справки, введите какой-нибудь не относящийся к Web-диаграммам вопрос, затем нажмите Поиск.

  2. Выберите раздел справки по программе-конструктору и нажмите кнопку Вывести.

  3. Щелкните вкладку Содержание, чтобы увидеть содержание справки по программе-конструктору.


Вызов дополнительной справки о Web-диаграммах

Далее представлены сведения по следующим темам:

Вызов справки в других программах-конструкторах

Вызов справки по написанию сценариев и о программах, использующих Web-диаграммы

Вызов справки в других программах-конструкторах

При работе с программой-конструктором справку по разработке диаграмм можно получить одним из двух способов:

  • Справка программы-конструктора. Чтобы получить сведения об имеющихся в программе-конструкторе командах работы с диаграммами и их параметрах, обратитесь к справке программы. Например, в Microsoft Access щелкните «Помощник» или вызовите Справку Microsoft Access [image].

    Microsoft Excel обеспечивает как общую справку о сохранении данных Excel для использования на Web-страницах, так и конкретные сведения о сохранении диаграмм для использования на Web-страницах. Для доступа к этой справке в Excel, щелкните помощник или вызовите Справку Microsoft Excel [image].

  • Справка при разработке диаграмм. При наличии доступа к панели свойств диаграммы из другой программы-конструктора появляется возможность обращаться и к разделам настоящей справки. Создав или открыв в программе-конструкторе диаграмму, щелкнитеСправка [image] на панели свойств диаграммы или выберите пункт Справка в контекстном меню диаграммы.

Возврат в начало

Вызов справки по написанию сценариев и о программах, использующих Web-диаграммы

Можно использовать сценарии и программы для автоматизации диаграмм или включать диаграммы в другие выполняемые программные модули, помимо Web-обозревателей, разработанные в таких средах программирования, как Microsoft Visual Basic.

Создание сценариев. В программы Microsoft Office 2000 включен редактор сценариев (Microsoft), полезный при создании сценариев. Например, редактор сценариев можно использовать из конструктора страниц доступа к данным Microsoft Access для настройки диаграммы. Сведения о редакторе сценариев содержатся в справках программ-конструкторов Microsoft Office. В редакторе сценариев также можно вызвать дополнительную справку о его возможностях работы со сценариями.

Справка по объектной модели. При разработке программы или сценария для работы со списком диаграмм можно вызвать справку об объектной модели, свойствах и методах, используемых при создании диаграмм. Такая справка по объектной модели устанавливается вместе с Web-компонентами Microsoft Office, к которым относятся Web-диаграммы. В зависимости от используемой программы-конструктора возможен доступ к этой справке одним из двух способов:

  • Справка в Microsoft Visual Basic. В Visual Basic (или Visual Basic для приложений) можно создать ссылку на библиотеку Web-компонентов Microsoft Office. При этом появляется возможность обращаться к справке с помощью обозревателя объектов, а также вызывать ее нажатием клавиши F1 после выбора ключевого слова. Сведения о создании ссылок и использовании справки по объектной модели содержатся в справке Visual Basic (Visual Basic для приложений).

  • Справка в других средах. Если используется другая среда разработки, найдите и дважды щелкните файл справки Msowcvba.chm.

Возврат в начало


Изменение данных, отображаемых на Web-диаграмме

  • Чтобы изменить данные, отображаемые на диаграмме, измените их в источнике данных, на котором основана диаграмма (в электронной таблице, сводной таблице, таблице базы данных или запросе, указанных при создании диаграммы). При этом диаграмма автоматически обновится.

Примечание. После создания диаграммы ни с помощью мастера диаграмм Microsoft Office, ни каким-либо иным способом нельзя указать для нее другой источник данных (например, указать другую таблицу). Если необходимо отобразить данные другого источника, то воспользуйтесь мастером диаграмм для создания новой диаграммы.


Создание и использование Web-диаграммы на основе сводной таблицы

На диаграмме, созданной на основе сводной таблицы, отображаются все данные, отображающиеся в этой таблице. При изменении сводной таблицы диаграмма динамически обновляется. Если, например, к сводной таблице добавить поле строки или столбца, то диаграмма обновится и отобразит новое поле соответственно как данные категории или данные ряда. Диаграмма обновляется также при фильтрации или скрытии данных. Например, если из сводной таблицы вытащить мышью поле, сделав его невидимым, то соответствующая информация перестанет отображаться и на диаграмме.

Приступая к работе. Прежде чем создавать диаграмму на основе сводной таблицы, следует решить, какие строки и столбцы должны быть отображены на диаграмме. Поля строк и столбцов сводной таблицы служат данными для категорий и рядов диаграммы. Например, если все отображаемые поля находятся только в области сведений, то на диаграмме не будет построено категорий и рядов. Из области данных или списка полей сводной таблицы перетащите мышью не менее чем по одному полю в область строк и область столбцов. Мастер диаграмм Microsoft Office позволяет указать, где именно — в строках или столбцах списка сводной таблицы — содержатся данные ряда, который должен быть построен на диаграмме. В сводную таблицу также необходимо добавить хотя бы одно поле итогов, иначе будут отсутствовать данные для отображения на диаграмме.

Сведения о работе со сводной таблицей содержатся в справке о соответствующем Web-компоненте.

Пример. Ниже приведена диаграмма, построенная на основе сводной таблицы. В поле итогов «Сумма: Продажи» отображается итоговая сумма, вырученная продавцом с продажи указанного типа товара. Синяя стрелка справа от подписи поля «Продавец» означает фильтрацию данных, в результате которой суммы продаж показаны только для четырех продавцов.

Сводная таблица и построенная на ее основе диаграмма.

Диаграмма, построенная на основе сводной таблицы. Поле столбца сводной таблицы, названное «Тип», отображено на диаграмме как данные категорий (напитки, молоко и так далее). Поле строки «Продавец» отображено на диаграмме как данные ряда. Названия рядов показаны на легенде (Батурин, Белов и так далее).

При добавлении полей к сводной таблице, а также при удалении из таблицы полей, диаграмма обновляется, наглядно показывая изменения.

Сводная таблица и построенная на ее основе диаграмма, обновленные в результате изменения сводной таблицы.

В предыдущем примере поле «Продавец» в сводной таблице было перемещено из области строк в область столбцов, а поле «Тип» — из области столбцов в область строк. В область столбцов было добавлено поле «Регион». Его фильтр отображает только «Восточный» и «Северный» регионы. На обновленной диаграмме поле «Тип» отображено в легенде как данные рядов, а поля «Продавец» и «Регион» отложены по горизонтальной оси как категории.


Ввод описания Web-диаграмм

Справка обозревателя. Пользователи, имеющие Internet Explorer 4.01 или более поздней версий и лицензию Microsoft Office 2000, могут получить справку по диаграммам только в разделах справки по электронным таблицам и сводным таблицам. Отдельной справки по диаграммам в обозревателе не предусмотрено.

Ввод дополнительного описания. При необходимости описание, инструкции или иные сведения о диаграммах размещаются на Web-странице. Описание можно разместить на той же Web-странице, где находится диаграмма, либо на отдельной Web-странице, указав к ней путь гиперссылкой. Дополнительные сведения о размещении на Web-страницах текста и гиперссылок содержатся в справке программы-конструктора Web-страниц.


Работа с диаграммами, опубликованными из Microsoft Excel

После опубликования на Web-странице диаграммы с поддержкой интерактивных функций из Microsoft Excel, некоторые ее свойства, а также существующие в Excel возможности работы с диаграммами могут исчезнуть или измениться. Эти свойства и возможности перечислены далее.

Web-страницу, созданную в Excel, можно открывать и изменять другими программами-конструкторами, например, Microsoft FrontPage 2000, конструктором страниц доступа к данным Microsoft Access 2000. Но при этом некоторые свойства диаграмм исчезают. Далее описаны свойства, которые сохраняются после опубликования диаграмм из Excel, но становятся недоступными для других программ-конструкторов. См. также Программы для создания Web-диаграмм.

Далее представлены сведения по следующим темам:

Свойства диаграммы Excel, которые исчезают или изменяются после ее опубликования на Web-странице.

Свойства диаграммы Excel, которые нельзя создавать или изменять с помощью других программ-конструкторов.

Свойства, которые исчезают или изменяются

Следующие свойства диаграмм Excel не сохраняются после опубликования диаграмм на Web-страницах, либо изменяются в соответствии со стандартными параметрами Web-диаграмм.

Типы диаграмм

Свойства диаграммы Excel | Опубликованная диаграмма
Трехмерная диаграмма. | Превращается в двухмерную диаграмму.
Диаграммы типа «поверхность». | Превращается в гистограмму.

Форматирование

Свойства диаграммы Excel | Опубликованная диаграмма
Отображаются только данные в видимых ячейках. | Отображаются все данные, даже в скрытых ячейках.
Автомасштабирование шрифтов. | Размер шрифта по умолчанию.
Форматирование подписей данных. | Форматирование подписей данных по умолчанию.
По умолчанию подписи оси категорий размещаются на графике между точками категорий. | Выравниваются по центру точек данных.
Настраиваются размеры и положение элементов диаграммы. | Размер и положение приняты по умолчанию.
В легенде может быть несколько столбцов. | Разметка легенды по умолчанию.
Ось времени. | Ось категорий по умолчанию с текстовыми подписями.
Коридор колебания. | Не сохраняется.
Линии рядов. | Не сохраняется.
Тени. | Не сохраняется.
Рисование на диаграмме объектов, надписей и рисунков. | Не сохраняется.
Полупрозрачные заливки. | Не сохраняется.

Анализ

Свойства диаграммы Excel | Опубликованная диаграмма
Линии тренда. | Линии тренда проходят от одной границы области построения до другой, а в Excel линии тренда не достигают границ, проходя только по точкам данных.
Перемещение линий тренда, построенных по средним значениям. | Не сохраняется.
Вычисление размеров планок погрешностей по формуле для стандартной погрешности. | Размер планок погрешностей вычисляется по умолчанию.
Вычисление размеров планок погрешностей по формуле для стандартного отклонения. | Размер планок погрешностей вычисляется по умолчанию.

Возврат в начало

Сохраняющиеся свойства диаграммы, которые нельзя создавать или изменять с помощью других программ-конструкторов

Далее описаны свойства диаграммы Microsoft Excel, которые сохраняются после ее обубликования из Excel с интерактивными возможностями. Однако перечисленные ниже свойства нельзя создавать и изменять в случае, если Web-страница открыта с помощью другой программы-конструктора, потому что изменение свойства или соответствующего ему ряда становится необратимым.

  • Вспомогательная ось значений, которая используется для отображения данных, изменяющихся в широком диапазоне, а также данных, отличающихся от основных данных по типу. Шкала вспомогательной оси отличается от шкалы основной оси.

  • Некоторые смешанные диаграммы, например, комбинация гистограммы с круговой диаграммой.

  • Различные цвета точек данных одного ряда. Обычно эта возможность применятся в случае, если на диаграмме Excel отображается единственный ряд. Если же рядов несколько, то маркеры каждого ряда обычно окрашиваются одним цветом. Если в Excel выбрана возможность Разноцветные точки, то различными цветами окрашиваются маркеры одного ряда.

Возврат в начало

Дополнительные сведения

Вызов справки об опубликовании диаграмм из Microsoft Excel.

Работа с диаграммой, опубликованной из Microsoft Excel.


Работа с Web-диаграммой, сохраненной или опубликованной с помощью Excel

Используйте эту процедуру только для интерактивных диаграмм, сохраненных или опубликованных с использованием Microsoft Excel. Дополнительные сведения о сохранении и публикации интерактивных диаграмм в Excel смотрите в справке этой программы.

  1. Используя рекомендации программы-конструктора, откройте Web-страницу, созданную при сохранении или опубликовании диаграммы в Microsoft Excel.

  2. Убедитесь, что диаграмма в окне программы конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  3. Измените диаграмму с помощью панели свойств диаграммы.

    См. Вызов панели свойств диаграммы.

Примечания

  • Интерактивная диаграмма, которая была сохранена и опубликована с использованием Excel, может выглядеть иначе, если ее открыть с помощью другой программы-конструктора или Microsoft Internet Explorer. Некоторые возможности, такие как трехмерные типы диаграмм, текст и графические объекты, размещенные поверх диаграммы, не сохраняются на Web-диаграмме.

  • Некоторые свойства диаграммы, созданные в Excel, включая вспомогательные оси значений, разноцветные точки данных одного ряда, а также некоторые типы диаграмм сохраняются при открытии диаграммы с помощью других программ-конструкторов. Однако в других программах-конструкторах создать их нельзя, поэтому попытки изменить эти свойства, либо изменить ряды с этими свойствами приводят к утрате этих свойств. См. Работа с диаграммой, сохраненной или опубликованной в Excel.


Изменение внешнего вида подписей, заголовков, легенды, сетки и осей Web-диаграммы

Перечисленные ниже возможности доступны не для всех типов диаграмм и элементов диаграмм.

Возможные действия:

Добавление элементов к диаграмме

Добавление подписей данных к диаграмме

Добавление заголовка к диаграмме

Добавление легенды к диаграмме

Добавление оси к диаграмме

Изменение элементов диаграммы

Изменение типа диаграммы

Отображение и скрытие сетки

Поворот или зеркальное отображение области построения

Изменение цвета границ и цвета фона

Изменение легенды

Изменение осей

Поворот кольцевых и круговых диаграмм

Отделение секторов на круговых и кольцевых диаграммах

Изменение размера отверстия в кольцевой диаграмме

Изменение размера, цвета или формы маркеров данных на графиках, точечных и лепестковых диаграммах

Перекрытие маркеров или интервал между маркерами на гистограммах и линейчатых диаграммах

Изменение внешнего вида текста и значений

Изменение заголовка

Изменение подписей данных

Изменение шрифта и размера текста

Изменение формата чисел

Удаление элементов

Удаление заголовка, легенды, осей и подписей данных


Вызов панели свойств диаграммы

  1. Переход к диаграмме.

    Чтобы перейти к диаграмме, необходимо щелкнуть ее один или два раза в зависимости от используемой программы-конструктора. Дополнительные сведения смотрите в справке программы-конструктора.

  2. Щелкните диаграмму правой кнопкой мыши, затем в появившемся контекстном меню выберите панель свойств.

Примечание. При использовании страниц доступа к данным Microsoft Access 2000, панель свойств диаграммы доступна только в конструкторе страниц. Дополнительные сведения смотрите в справке по Access.


Использование панели свойств диаграмм для изменения Web-диаграммы

  1. Откройте панель свойств диаграммы.

    Инструкции

  2. Выберите часть диаграммы, которую необходимо изменить.

    Инструкции

  3. Чтобы показать или скрыть содержимое раздела, щелкните панель с названием этого раздела.

Примечание. Если выделялись различные элементы диаграммы, а панель свойств диаграммы при этом оставалась на экране, то ее открытые разделы и их содержимое будут изменяться, отображая свойства текущего выделения.


Форматы чисел для Web-диаграмм

Диаграммы Microsoft Office используют национальные стандарты, заданные в диалоговом окне Свойства: Язык и стандарты панели управления Windows. Эти стандарты определяют, какие форматы цифр, денежных единиц, даты и времени отображаются на Web-диаграммах в программах-конструкторах и при просмотре диаграмм в обозревателе. Например, они определяют, надо ли отображать год двумя цифрами или четырьмя. Чтобы проверить текущие установки или изменить их, дважды щелкните Язык и стандарты на панели управления Windows. Дополнительные сведения об этих форматах смотри в справке Windows.

В Microsoft Visual Basic или в сценариях данным можно назначать нестандартные числовые форматы. Дополнительные сведения смотрите в справке по написанию сценариев и программ, использующих Web-диаграммы.

Из списка Формат чисел в разделе Шрифт на панели свойств диаграммы можно выбрать следующие форматы чисел:

Формат | Описание
Основной | Число отображается без разделителя разрядов, перед отрицательным числом ставится минус. Например: –36403. Отображает до 11 цифр или 10 цифр и десятичную точку, округляя цифры после десятичной точки. Числа, имеющие больше 11 цифр слева от десятичной точки, отображаются в экспоненциальном формате. При выводе на экран числа выравниваются по правому краю, а текст — по левому.
Полный формат даты | Отображает дату и/или время, преобразуя их из числового формата. Например: число 36403,24583 приобретает вид 8/31/99 05:54. Десятичная часть числа воспринимается как время. Если у числа нет десятичной части, формат отображает только дату. Например: 35920 преобразуется в 5/5/98. Если у числа есть только десятичная часть, формат отображает только время. Пример: 0.77 преобразуется в 18:28.
Длинный формат даты | Отображает календарную дату, используя длинный формат даты, заданный в разделе «Язык и стандарты» панели управления. Например: четверг, 25 января, 2001.
Средний формат даты | Отображает календарную дату, разделяя месяц и число в соответствии с национальными стандартами, принятыми в Windows, для года отводится две цифры. Например: 25 янв 01.
Краткий формат даты | Отображает календарную дату, используя краткий формат, заданный в разделе «Язык и стандарты» панели управления. Например: 25.01.01.
Длинный формат времени | Отображает время суток, используя длинный формат, заданный в разделе «Язык и стандарты» панели управления. Например: 20:45:36.
Средний формат времени | Отображает время суток в 12-часовом формате, включая указатели AM и PM, но без указания секунд. Например: 8:45 PM.
Краткий формат времени | Отображает время суток в 24-часовом формате, не включая указатели AM и PM и без указания секунд. Например: 8:45 PM показывается как 20:45.
Денежный | Отображает число, используя для денежной единицы национальные стандарты, заданные на панели управления: обозначение денежной единицы, разделитель групп разрядов, если он задан, а также два десятичных знака. Например: $2,532.75.
Евро | Отображает число как денежную сумму в евро, с разделителями групп разрядов и двумя десятичными знаками. Обозначение евро размещается перед или после числа, согласно национальным стандартам для денежных единиц, установленным на панели управления Windows. Например, в соответствии с национальными стандартами для английского языка, США: 12.35.
Фиксированный | Отображает число с двумя десятичными знаками. Например: число 68,3 приобретает вид 68,30.
Стандартный | Отображает число с двумя десятичными знаками, используя разделитель групп разрядов, указанный в поле «Разделитель групп разрядов» диалогового окна «Свойства: Язык и стандарты», которое вызывается из панели управления. Например: 1800 примет вид 1800,00.
Процентный | Отображает число, умноженное на 100, с двумя десятичными знаками и знаком процента. Например: 0,8914 преобразуется в 89,14%.
Процентная ось | Отображает число, умноженное на 100 и со знаком процента. Например: число 5 преобразуется в 500%.
Экспоненциальный | Отображает числа в экспоненциальном представлении. Например: 1,25E+10.
Да/нет | Если число равно 0, отображает «Нет», а во всех остальных случаях — «Да».
Истина/ложь | Если число равно 0, отображает «Ложь», а во всех остальных случаях показывает «Истина».
Вкл/Выкл | Если число равно 0, отображает «Выкл», а во всех остальных случаях — «Вкл».


Изменение формата чисел на Web-диаграмме

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Выберите мышью ось значений или подписи данных, которые необходимо изменить.

  3. Если раздел Шрифт на панели свойств диаграммы еще не развернут, щелкните панель Шрифт.

  4. Выберите требуемый формат чисел в списке Формат чисел.

Примечание. Формат чисел для подписей оси категорий изменить нельзя.

Дополнительные сведения о форматах чисел.


Отображение и скрытие легенды Web-диаграммы

Следующим способом можно показать или скрыть легенду на Web-диаграмме. Легенда показывает название и цвет рядов данных на диаграмме, а в случае круговой диаграммы — название и цвет точек данных ряда.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните диаграмму, на которой необходимо отобразить или скрыть легенду.

  3. Если раздел Диаграмма на панели свойств диаграммы еще не развернут, щелкните панель Диаграмма.

  4. Установите или снимите флажок Показать легенду.

Примечания

  • Размеры диаграммы будут изменены автоматически, чтобы вместить легенду. Нельзя изменить размер легенды вручную.

  • Есть возможность изменить положение и внешний вид легенды.


Изменение легенды на Web-диаграмме

Инструкции

Перемещение легенды

Изменение толщины границ или цвета фона легенды

Изменение шрифта, размера или цвета текста легенды


Перемещение легенды на Web-диаграмме

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните легенду, которую необходимо изменить.

  3. Если раздел Легенда на панели свойств диаграммы еще не развернут, щелкните панель Легенда.

  4. Выберите нужный вариант в списке Размещение.

Примечание. Переместить легенду с помощью мыши нельзя.

Советы

  • Есть возможность изменить толщину и цвет границ, а также цвет фона легенды.

  • Есть возможность изменить размер, тип, цвет и атрибуты шрифта текста легенды.


Удаление заголовка, легенды, осей и подписей данных Web-диаграммы

  1. Щелкните элемент, который необходимо удалить.

  2. Нажмите клавишу DELETE.

Примечание. Вместе с осью диаграммы также удаляются подписи и деления этой оси.


Изменение диаметра отверстия кольцевой Web-диаграммы

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните кольцевую диаграмму, которую необходимо изменить.

  3. Если раздел Параметры на панели свойств диаграммы еще не развернут, щелкните панель Параметры.

  4. Ведите в поле Диаметр отверстия любое значение от 10 до 90, указывающее диаметр отверстия в процентах от общего диаметра кольцевой диаграммы.


Отделение секторов на круговой и кольцевой Web-диаграммах

На кольцевых диаграммах и многоуровневых круговых диаграммах существует возможность отделения секторов, но только из внешнего круга.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Дважды щелкните сектор круговой или кольцевой диаграммы, который необходимо отделить.

  3. Если раздел Точка на панели свойств диаграммы еще не развернут, щелкните панель Точка.

  4. В поле Выдвижение введите число (процент от радиуса диаграммы), которое определит расстояние между сектором и центром круговой или кольцевой диаграммы.

Совет. Чтобы отодвинуть все сектора на одинаковое расстояние от центра диаграммы, щелкните круговую или кольцевую диаграмму так, чтобы оказался выбран ряд, затем щелкните панель Ряд. Введите число в поле Выдвижение, определяющее расстояние между центром и секторами в процентах от радиуса диаграммы.


Поворот круга или кольца на круговой и кольцевой Web-диаграммах

Порядок, в котором ряды данных отображаются на круговой и кольцевой диаграммах, определяется порядком исходных данных. Поворот колец круговых и кольцевых диаграмм вокруг оси на любой угол выполняется следующим образом.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните круговую или кольцевую диаграмму, которую необходимо изменить.

  3. Если раздел Параметры на панели свойств диаграммы еще не развернут, щелкните панель Параметры.

  4. В поле Угол поворота введите число от 0 (нуля) до 360, которое определит угол поворота первого кольца диаграммы.


Добавление названия к Web-диаграмме

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните диаграмму, к которой необходимо добавить название.

  3. Если раздел Диаграмма на панели свойств диаграммы еще не развернут, щелкните панель Диаграмма.

  4. Установите флажок Показать название.

    К диаграмме добавится название, принятое по умолчанию.

  5. Выберите щелчком мыши название, принятое по умолчанию.

  6. Если раздел Название на панели свойств диаграммы еще не развернут, щелкните панель Название.

  7. Замените текст в поле Подпись.

Примечания

  • Есть возможность изменить текст, внешний вид и расположение названия.

  • Нельзя вручную вставить разрыв строки в название диаграммы.


Добавление подписей данных к Web-диаграмме

Тип диаграммы, связанный с выделенными рядом или точкой данных, определяет тип подписей данных, которые могут быть добавлены к диаграмме. Также существует возможность изменить подписи данных после их добавления.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните ряд данных, для которого необходимо добавить подписи данных.

  3. Если раздел Ряд на панели свойств диаграммы еще не развернут, щелкните панель Ряд.

  4. Выберите Добавить подписи значений [image] возле поля Добавить к ряду.

Примечание Нельзя добавить подпись к отдельной точке данных.


Добавление подписи к оси Web-диаграммы

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните ось, к которой необходимо добавить подпись.

  3. Если раздел Ось на панели свойств диаграммы еще не развернут, щелкните панель Ось.

  4. Щелкните Показать подпись оси [image].

    К оси добавится подпись, заданная по умолчанию.

  5. Выберите щелчком мыши заданную по умолчанию подпись.

  6. Если раздел Название на панели свойств диаграммы еще не развернут, щелкните панель Название.

  7. Замените текст в поле Подпись необходимой подписью.

Совет. Есть возможность изменить формат и содержание подписи.


Изменение заголовка на Web-диаграмме

Имеется возможность изменить название или содержимое заголовка оси или заголовка диаграммы. Также можно изменить размещение этого заголовка на диаграмме.

Инструкции

Изменение текста заголовка

Изменение размещения заголовка (невозможно для заголовков осей)

Изменение шрифта, цвета или размера заголовка

Изменение ширины и цвета границы и цвета фона заголовка


Изменение шрифта и размера текста на Web-диаграмме

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните заголовок оси, подписи данных, подпись R-квадрат, подпись уравнения или заголовок диаграммы, которые необходимо изменить.

  3. Если раздел Шрифт в панели свойств диаграммы еще не развернут, щелкните панель Шрифт.

  4. Выберите необходимые параметры.
    Параметр выделенного текста | Выберите
    Шрифт | Требуемый шрифт в списке Шрифт
    Размер шрифта | Требуемый размер шрифта в списке Размер
    Полужирный шрифт | Полужирный
    Курсив | Курсив
    Подчеркнутый шрифт | Подчеркнутый
    Цвет | Стрелку раскрывающегося списка Цвет шрифта, [image] затем выберите необходимый цвет.


Изменение размещения названия Web-диаграммы

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните название, которое необходимо изменить.

  3. Если раздел Название на панели свойств диаграммы еще не развернут, щелкните панель Название.

  4. Выберите нужный вариант в списке Размещение.

Примечание. Размещение названия оси изменить нельзя.


Изменение положения подписей значений на Web-диаграмме

Подписи значений на круговых и кольцевых диаграммах всегда выравниваются по центру. Изменить их положение нельзя.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. С помощью мыши выберите в группе ту подпись значений, которую требуется изменить.

  3. Если раздел Подпись данных на панели свойств диаграммы еще не развернут, щелкните панель Подпись данных.

  4. Выберите вариант из списка Положение.


Изменение текста названия Web-диаграммы

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните название, которое необходимо изменить.

  3. Если раздел Название на панели свойств диаграммы еще не развернут, щелкните панель Название.

  4. Замените текст в поле Подпись.

Советы

  • Вставить в название разрыв строки нельзя.

  • Есть возможность изменить шрифт, размер, цвет и атрибуты названия.


Выбор элементов, отображаемых в подписях значений на Web-диаграмме

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните подпись в группе подписей данных, которую требуется изменить.

  3. Если раздел Подпись данных на панели свойств диаграммы еще не развернут, щелкните панель Подпись данных.

  4. Чтобы показать или скрыть названия категорий, рядов и/или значений точек данных в подписях данных, установите или снимите соответствующие флажки.

  5. Если на шаге 4 установлено более одного флажка, то текст разделяется знаками, указанными в поле Разделитель. Чтобы изменить знак, введите новый вариант а поле Разделитель.

Примечания

  • Также можно изменить формат чисел в подписях данных.

  • Нельзя вносить изменения в отдельные подписи данных. Изменения отражаются на всех подписях данных ряда.


Изменение подписей данных на Web-диаграмме

Можно изменить содержание подписей данных, чтобы включить в них значения: точек данных, названия категорий, названия рядов или их комбинацию. Также существует возможность изменить размещение подписей данных: внутри, снаружи, сверху или снизу от маркеров данных. Изменения? сделанные для отдельного маркера данных? будут применены ко всем маркерам этого ряда.

Инструкции

Изменение отображаемого в подписях данных

Изменение положения подписей данных

Изменение шрифта, размера и цвета текста подписей данных

Изменение формата чисел в подписях данных


Изменение интервала меток и подписей делений на оси категорий Web-диаграммы

Каждая категория на оси категорий обозначается подписью и отделяется от других категорий метками делений. Можно изменить интервал, с которым выводятся подписи и деления, а также указать, в каком месте должны пересекаться ось значений (ось Y) и ось категорий (осьX).

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните ось категорий, которую необходимо изменить.

  3. Если раздел Шкала на панели свойств диаграммы еще не развернут, щелкните панель Шкала.

  4. Выполните одно или несколько из указанных ниже действий:

    В разделе число категорий между введите число в поле Подписи меток, которое определяет частоту подписей категорий. Например, число 1 означает подпись у каждой категории; число 2, означает подпись у каждой второй категории. Число в поле метки, определяет число категорий, которые размещаются в интервале между двумя метками делений. Например, число 1 означает одну категорию между метками делений, число 2 — две категории между метками делений.

    В поле пересекает ось, выберите ось, которая должна пересекать ось категорий.

    В разделе пересекает в значении, щелкните автоматически, чтобы диаграмма сама определила место пересечения оси с осью категорий. Чтобы определить это место явно, щелкните пункт Настройка, затем введите нужное значение в поле Настройка.

    Чтобы изменить направление оси, установите флажок обратный порядок значений.

Совет. Если имеется несколько линий подписей оси категорий (многоуровневые подписи оси категорий), нельзя изменять число категорий между подписями делений, число категорий между метками делений или место пересечения оси значений (ось Y) и оси категорий.


Изменение типа Web-диаграммы

Можно изменить тип диаграммы как для всей диаграммы вцелом, так и для ее отдельных рядов данных.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните диаграмму или ряд данных, которые необходимо изменить.

  3. Если раздел Общие на панели свойств диаграммы еще не развернут, щелкните панель Общие.

  4. Щелкните кнопку Тип диаграммы [image].

  5. В списке Тип выберите тип диаграммы, затем в списке Дополнительный тип выберите необходимую разновидность диаграммы.


Сочетание типов диаграмм на одной Web-диаграмме

Смешанные диаграммы. На смешанной диаграмме совмещаются различные типы диаграмм, что подчеркивает различие данных. На следующей диаграмме один ряд данных (фактические данные) представлен в виде гистограммы, а другой ряд (прогноз) — в виде графика. Такое совмещение создается путем изменения типа диаграммы для одного или нескольких рядов данных.

Составная ось. Если диапазоны значений рядов данных настолько отличаются, что их восприятие на одной диаграмме затруднено, удобно воспользоваться составной осью, то есть вырезать пустой или малозначимый участок диаграммы, чтобы лучше отобразить минимальные и максимальные значения.

Смешанная диаграмма с составной осью.


Изменение цвета фона и цвета границ Web-диаграммы

Есть возможность изменить толщину и цвет линий границ, а также цвет фона области построения, легенды, маркера данных и рядов маркеров данных.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните элемент диаграммы, который необходимо изменить.

  3. Если раздел Формат на панели свойств диаграммы еще не развернут, щелкните панель Формат.

  4. Толщину границы маркера можно выбрать в списке Толщина границы.

    Чтобы изменить цвет границы, щелкните стрелку раскрывающегося списка Цвет границы, [image] а затем выберите необходимый цвет.

    Чтобы изменить цвет фона объекта, щелкните стрелку раскрывающегося списка Цвет фона, [image] а затем выберите требуемый цвет.


Изменение цвета и толщины линий на Web-диаграмме

Можно изменить цвет и толщину линий для рядов, осей, сетки, линий тренда и границ диаграммы.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните линию или границу, которую необходимо изменить.

  3. Если раздел Формат на панели свойств диаграммы еще не развернут, щелкните панель Формат.

  4. Чтобы изменить толщину линии, выберите требуемое значение в списке Толщина линии.

    Чтобы изменить цвет линии, выберите требуемый цвет из раскрывающегося списка Цвет линии [image].


Отображение и скрытие сетки на Web-диаграмме

На круговых и кольцевых диаграммах не может быть сетки.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните ось, для которой необходимо показать или скрыть сетку.

  3. Если раздел Деления и сетка на панели свойств диаграммы еще не развернут, щелкните панель Деления и сетка.

  4. Установите либо снимите один или оба флажка: основные линии, промежуточные линии.

Совет. Есть возможность изменить толщину и цвет линий сетки.


Изменение размера, цвета и формы маркеров данных на графиках, точечных и лепестковых диаграммах.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Варианты действий:

    Чтобы изменить форму или размер всех маркеров данных ряда, либо изменить толщину, цвет границы или цвет фона всех маркеров ряда, щелкните по линии с маркерами данных, которые необходимо изменить.

    Чтобы изменить толщину, цвет границы или цвет фона отдельного маркера данных, выберите его мышью.

  3. Если раздел Формат на панели свойств диаграммы еще не развернут, щелкните панель Формат.

  4. Толщину границы маркера можно выбрать в списке Толщина границы.

    Чтобы изменить цвет границы, щелкните стрелку раскрывающегося списка Цвет границы [image] и выберите необходимый цвет.

    Чтобы изменить цвет фона, щелкните мышью стрелку раскрывающегося списка Цвет фона [image], затем выберите цвет.

    Если выбран весь ряд данных, и необходимо изменить форму всех его маркеров, щелкните стрелку раскрывающегося списка Маркер, [image] затем выберите требуемую форму.

    Если выбран весь ряд данных, и необходимо изменить размеры маркера этого ряда, выберите нужное значение в списке Размер.

Совет. Чтобы отключить отображение маркеров для определенного ряда, необходимо изменить тип диаграммы. Выберите подтип диаграммы, на котором маркеры отсутствуют.


Поворот или зеркальное отражение области построения Web-диаграммы

Область построения диаграммы можно зеркально отразить (вертикально или горизонтально), развернуть как по часовой стрелке, так и в обратную сторону шагами по 90 градусов.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните область построения, которую необходимо изменить.

  3. Если раздел Область построения на панели свойств диаграммы еще не развернут, щелкните панель Область построения.

  4. Чтобы зеркально отразить область построения, щелкните Отразить слева направо [image] или Отразить сверху вниз [image].

    Чтобы повернуть область построения, щелкните Поворот по часовой стрелке [image] или Поворот против часовой стрелки [image].


Перекрытие и ширина зазора между маркерами данных на гистограммах и линейчатых Web-диаграммах

Для изменения перекрытия или ширины зазора между маркерами всех рядов данных на диаграммах такого же типа необходимо выделить всего один ряд данных.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните диаграмму, которую необходимо изменить.

  3. Если раздел Параметры на панели свойств диаграммы еще не развернут, щелкните панель Параметры.

  4. Чтобы изменить перекрытие маркеров данных во всех категориях, введите число от –100 до 100 в поле Перекрытие. Чем больше это значение, тем больше перекрытие маркеров одной категории.

    Чтобы изменить ширину зазора между маркерами различных категорий, введите число от 0 (нуль) до 500 в поле Ширина зазора. Чем больше это значение, тем больше расстояние между категориями.


Изменение оси на Web-диаграмме

Инструкции

Сведения об элементах оси

Добавление и удаление осей

Добавление оси к диаграмме

Удаление оси

Форматирование осей

Изменение положения оси

Добавление заголовка к оси

Изменение заголовка оси

Изменение шрифта и размера текста элементов оси

Изменение толщины и цвета оси

Изменение внешнего вида делений оси

Изменение интервала и подписей делений на оси категорий

Изменение значений оси

Составные оси

Изменение числового формата значений оси

Изменение масштаба оси


Изменение шкалы оси значений Web-диаграммы

Шкала определяет диапазон значений оси, способ отображения этих значений, интервал между делениями и место пересечения осей.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните ось значений, которую необходимо изменить.

  3. Если раздел Шкала на панели свойств диаграммы еще не развернут, щелкните панель Шкала.

  4. Выполните одно или несколько из указанных ниже действий:

    Установите флажок максимальное значение и введите необходимое максимальное значение для отображения на этой оси в поле максимальное значение.

    Установите флажок минимальное значение и введите требуемое минимальное значение для отображения на этой оси в поле минимальное значение.

    Установите флажок цена основных делений. В поле цена основных делений введите значение, указывающее промежуток между основными делениями и основными линиями сетки.

    Установите флажок цена промежуточных делений. В поле цена промежуточных делений введите значение, указывающее промежуток между основными делениями и основными линиями сетки.

    В поле пересекает ось выберите ось, которая будет пересекать ось значений.

    В разделе пересекает в значении, выберите вариант автоматически, чтобы диаграмма сама определила место пересечения оси с осью значений. Чтобы определить это место явно, щелкните Настройка, затем введите значение в поле Настройка.

    Чтобы изменить направление оси, установите флажок обратный порядок значений.

    Для пересчета значений оси в степени чисел 10, 2 или e, установите флажок логарифмическая шкала, затем выберите нужное значение в списке основание.

Совет. Чтобы зеркально изменить направление полос или столбиков на линейчатой диаграмме или гистограмме, установите флажок обратный порядок значений.


Изменение внешнего вида делений на оси Web-диаграммы

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните ось, на которой необходимо изменить деления.

  3. Если раздел Деления и сетка на панели свойств диаграммы еще не развернут, щелкните панель Деления и сетка.

  4. Выберите требуемые параметры в списках Основные деления и Промежуточные деления.

Совет. Чтобы скрыть деления, выберите пункт нет.


Применение составной оси для уменьшения размера Web-диаграммы

При наличии очень больших и очень маленьких значений на диаграмме можно воспользоваться составной осью значений, чтобы все ее значения были видны отчетливо. Пусть, например, имеются значения в диапазоне от 0 до 100, причем большинство значений лежит между 0 и 20, а также между 80 и 100. Можно разбить ось диаграммы таким образом, чтобы на ней было две шкалы: нижняя шкала с диапазоном от 0 до 20 и верхняя шкала с диапазоном от 80 до 100. Таким образом, бесполезное пространство между 20 и 80 будет с диаграммы убрано.

Диаграмма с составной осью значений

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните ось значений, которую необходимо сделать составной.

  3. Если раздел Составная ось на панели свойств диаграммы еще не развернут, щелкните панель Составная ось.

  4. Установите флажок Составная ось, а затем введите значения в поле Начало разделения (конец первой шкалы) и в поле Конец разделения (начало второй шкалы).


Изменение положения оси на Web-диаграмме

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните мышью ось, которую необходимо изменить.

  3. Если раздел Ось на панели свойств диаграммы еще не развернут, щелкните панель Ось.

  4. Выберите нужный вариант в списке Положение оси.


Добавление оси к Web-диаграмме

Круговые и кольцевые диаграммы не имеют осей.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните диаграмму, которую необходимо изменить.

  3. Если раздел Диаграмма на панели свойств диаграммы еще не развернут, щелкните панель Диаграмма.

  4. Выберите Добавить ось категорий [image] или Добавить ось значений [image].

Советы

  • Изменять ось можно следующим образом: изменить ее расположение, добавить заголовок, изменить толщину и цвет линии, изменить формат чисел для значений оси, сделать ось составной и так далее.

  • Чтобы повысить удобочитаемость диаграммы, есть возможность добавить к ней несколько одинаковых осей. Например, можно добавить вторую ось значений и изменить ее расположение так, чтобы иметь по одной оси с левой и с правой сторон диаграммы. При таком размещении осей намного проще будет определять значения точек данных на диаграмме. Аналогично, если диаграмма в высоту намного больше, чем в ширину, удобно будет иметь по одной горизонтальной оси сверху и снизу диаграммы.


Линии тренда на Web-диаграммах

Линии тренда графически отображают данные, облегчая их анализ и прогнозирование. Такой анализ также называется регрессионным. Например, на следующей диаграмме простейшая линия тренда — линейная — наглядно показывает стабильный рост продаж от квартала к кварталу.

Диаграмма с линейной аппроксимацией

Типы диаграмм, на которых можно строить линии тренда. Проводить линии тренда через ряды данных можно на гистограммах, графиках, диаграммах с областями, точечных, биржевых, полярных и пузырьковых диаграммах. При изменении типа диаграммы линии тренда исчезают, если новый тип диаграммы не способен их отображать. См. Примеры типов диаграмм.

Дополнительные сведения

Выбор наилучшего типа аппроксимации данных.

Создание линии тренда для ряда данных.

Формулы для вычисления линий тренда.


Выбор наилучшей линии тренда для аппроксимации данных на Web-диаграмме

Содержание раздела

Определение наилучшей линии тренда по величине R-квадрат

Линейная аппроксимация

Логарифмическая аппроксимация

Полиномиальная аппроксимация

Степенная аппроксимация

Экспоненциальная аппроксимация

Определение наилучшей линии тренда по величине R-квадрат

Отображаемые на диаграмме данные можно аппроксимировать пятью способами. Способ следует выбирать в зависимости от типа данных. См. Добавление линии тренда на диаграмму.

Надежность аппроксимации и значение R-квадрат. Кривая хорошо описывает данные, если значение R-квадрат равно единице или близко к ней. Величина R-квадрат, иногда называемая квадратом смешанной корреляции, принимает значение от 0 до 1. По нему можно судить, насколько хорошо аппроксимирующая кривая описывает фактические данные. При построении этой кривой значение R2 рассчитывается автоматически. Его можно отобразить на диаграмме.

Возврат в начало

Линейная аппроксимация

Линейная аппроксимация описывает данные прямой линией. Она применяется в самых простых случаях, когда точки данных ложатся приблизительно на прямую. Говоря другими словами, линейная аппроксимация хороша для величины, которая увеличивается или убывает с постоянной скоростью.

В следующем примере прямая линия описывает стабильный рост продаж холодильников на протяжении 13 лет. Обратите внимание, что значение R-квадрат = 0,9036, то есть близко к единице, что свидетельствует о хорошем совпадении расчетной линии с данными.

Диаграмма с линейной аппроксимацией

Возврат в начало

Логарифмическая аппроксимация

Логарифмическая аппроксимация хорошо описывает величину, которая вначале быстро растет или убывает, а затем постепенно стабилизируется. Описывает как положительные, так и отрицательные величины.

В следующем примере логарифмическая кривая описывает прогнозируемый рост популяции животных, обитающих в ареале с фиксированными границами. Скорость роста популяции падает из-за ограниченности их жизненного пространства. Кривая довольно хорошо описывает данные, поскольку значение R-квадрат, равное 0,9407, близко к единице.

Диаграмма с логарифмической аппроксимацией

Возврат в начало

Полиномиальная аппроксимация

Полиномиальная аппроксимация используется для описания величин, попеременно возрастающих и убывающих. Она полезна, например, для анализа большого набора данных о нестабильной величине. Степень полинома определяется количеством экстремумов (максимумов и минимумов) кривой. Полином второй степени может описать только один максимум или минимум. Полином третьей степени имеет один или два экстремума. Полином четвертой степени может иметь не более трех экстремумов.

В следующем примере полином второй степени (один максимум) описывает зависимость расхода бензина от скорости автомобиля. Близкое к единице значение R-квадрат = 0,9474 свидетельствует о хорошем совпадении кривой с данными.

Диаграмма с полиномиальной аппроксимацией

Возврат в начало

Степенная аппроксимация

Степенная аппроксимация полезна для описания монотонно возрастающей либо монотонно убывающей величины, например, расстояния, пройденного разгоняющимся автомобилем. Степенной аппроксимацией можно пользоваться только для положительных значений. При попытке применить ее для данных, содержащих 0 или отрицательное значение, будет выдано сообщение «Ошибка линии тренда».

В следующем примере показана зависимость пройденного разгоняющимся автомобилем расстояния от времени. Расстояние выражено в метрах, время — в секундах. Эти данные точно описываются степенной зависимостью, о чем свидетельствует очень близкое к единице значение R-квадрат, равное 0,9923.

Диаграмма со степенной аппроксимацией

Возврат в начало

Экспоненциальная аппроксимация

Экспоненциальная аппроксимация полезна для описания величины, скорость роста которой быстро растет, либо величины, убывающей с уменьшающейся скоростью. Экспоненциальной аппроксимацией можно пользоваться только для положительных значений. При попытке применить ее для данных, содержащих 0 или отрицательное значение, будет выдано сообщение «Ошибка линии тренда».

В следующем примере экспоненциальная линия тренда описывает содержание радиоактивного углерода-14 в зависимости от возраста органического объекта. Значение R-квадрат равно 1, что означает полное совпадение кривой с аппроксимируемыми данными.

Диаграмма с экспоненциальной аппроксимацией

Возврат в начало


Добавление линии тренда к ряду данных на Web-диаграмме

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните ряд данных, к которому необходимо добавить линию тренда (кривую аппроксимации).

  3. Если раздел Ряд на панели свойств диаграммы еще не развернут, щелкните панель Ряд.

  4. Нажмите кнопку Добавить линию тренда [image] около поля Добавить к ряду.

Примечание. Прямая линейной аппроксимации, ее уравнение и значение R-квадрат отображаются вместе с рядом. Доступны также другие типы линий тренда: логарифмическая, полиномиальная, степенная, экспоненциальная. Изменение типа и параметров линий тренда.


Изменение линии тренда на Web-диаграмме

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните линию тренда, которую необходимо изменить.

  3. Если раздел Линии тренда на панели свойств диаграммы еще не развернут, щелкните панель Линии тренда.

  4. Чтобы изменить тип линии тренда, щелкните стрелку раскрывающегося списка Тип линии тренда [image] и выберите тип. Можно выбрать следующие типы аппроксимации: линейная, логарифмическая, полиномиальная, степенная и экспоненциальная. Чтобы увидеть названия линий тренда, задержите курсор мыши на соответствующей кнопке. См. Выбор наилучшей линии тренда для аппроксимации данных на Web-диаграмме.

    Чтобы изменить степень полиномиальной линии тренда, выберите в поле Степень максимальную степень независимой переменной.

    Чтобы изменить название линии тренда, отображаемое в легенде, установите флажок Пользовательское имя, затем введите имя в поле справа.

    Чтобы показать или скрыть формулу, используемую для вычисления линии тренда, установите или снимите флажок Вывести формулу. См. Формулы для вычисления линий тренда.

    Чтобы показать или скрыть значение R-квадрат, установите или снимите флажок Показать значение R-квадрат.

Совет. Есть возможность изменить цвет и толщину линии тренда, а также изменить шрифт или размер текста, используемого для формулы линии тренда или значения R-квадрат.


Отображение и скрытие значения R-квадрат для линии тренда на Web-диаграмме

Величина R-квадрат, иногда называемая квадратом смешанной корреляции, принимает значение от 0 до 1. По ней можно судить, насколько хорошо линия тренда (кривая аппроксимации) описывает фактические данные. Чем ближе значение R-квадрат к единице, тем более достоверна аппроксимация. При построении кривой, значение R-квадрат автоматически рассчитывается Web-диаграммой Microsoft Office.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните линию тренда, для которой необходимо показать или скрыть значение R-квадрат.

  3. Если раздел Линии тренда на панели свойств диаграммы еще не развернут, щелкните панель Линии тренда.

  4. Установите или снимите флажок Показать значение R-квадрат.

Советы

  • Также можно показать или скрыть формулу, по которой вычислена линия тренда.

  • Есть возможность изменить начертание и размер шрифта текста для отображаемых на диаграмме формулы и значения R-квадрат.

Дополнительные сведения

Формулы для вычисления линий тренда


Удаление линии тренда на Web-диаграмме

  1. Щелкните линию тренда, которую необходимо удалить.

  2. Нажмите клавишу DELETE.


Отображение и скрытие формулы для вычисления линии тренда на Web-диаграмме

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните линию тренда, для которой необходимо показать или скрыть формулу.

  3. Если раздел Линии тренда на панели свойств диаграммы еще не развернут, щелкните панель Линии тренда.

  4. Установите или снимите флажок Вывести формулу.

Советы

  • Имеется возможность показать или скрыть значение R-квадрат для кривой аппроксимации.

  • Есть возможность изменить начертание и размер шрифта текста для отображаемых на диаграмме формулы и значения R-квадрат.

Дополнительные сведения

Формулы для вычисления линий тренда


Формулы для вычисления линий тренда Web-диаграммы

Линейная

Аппроксимирует данные методом наименьших квадратов по формуле:

где m - угол наклона, а b - координата пересечения с осью абсцисс.

Полиномиальная

Используется для аппроксимации данных методом наименьших квадратов по формуле:

где b и Переменная — константы.

Логарифмическая

Используется для аппроксимации данных методом наименьших квадратов по формуле:

где c и b — константы, а ln — функция натурального логарифма.

Экспоненциальная

Используется для аппроксимации данных методом наименьших квадратов по формуле:

где c и b — константы, а e — основание натурального логарифма.

Степенная

Используется для аппроксимации данных методом наименьших квадратов по формуле:

где c и b — константы.

Значение R-квадрат

Величина R-квадрат, иногда называемая квадратом смешанной корреляции, принимает значение от 0 до 1. По ней можно судить, насколько хорошо линия тренда описывает фактические данные. Чем ближе значение R-квадрат к единице, тем более достоверна кривая аппроксимации. При построении этой кривой, Microsoft Office автоматически рассчитывает значение R-квадрат для нее, используя следующее уравнение:

Примечание. Отображаемое вместе с кривой аппроксимации значение R-квадрат не является корректным. Для логарифмической, степенной и экспоненциальной линий тренда Microsoft Office использует несколько видоизмененную модель регрессии.


Планки погрешностей на Web-диаграмме

Планки погрешностей графически иллюстрируют погрешности значений, соответствующих маркерам данных ряда данных, например, 5-ти процентные положительные и отрицательные погрешности результатов научного эксперимента:

Диаграмма с планками погрешностей

Диаграммы, поддерживающие планки погрешностей. Планки погрешностей можно отобразить на диаграммах с областями, на линейчатых, точечных и пузырьковых диаграммах, а также на гистограммах и графиках. На точечных, полярных и пузырьковых диаграммах можно отобразить планки погрешностей как по оси X, так и по оси Y. См. Примеры типов диаграмм.

Дополнительные сведения

Создание планок погрешностей для ряда данных.

Формулы для расчета погрешностей.


Добавление планок погрешностей к ряду данных Web-диаграммы

Планки погрешностей графически иллюстрируют погрешности значений, соответствующих маркерам данных ряда данных. См. Планки погрешностей на Web-диаграмме.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните ряд данных, для которого необходимо добавить планки погрешностей.

  3. Если раздел Ряд на панели свойств диаграммы еще не развернут, щелкните панель Ряд.

  4. Щелкните Добавить планки погрешностей [image] рядом с полем Добавить к ряду.

Примечания

  • Изменение типа маркера, вычислений погрешностей и других параметров панели погрешностей.

  • При изменении исходных данных, связанных с точками данных в ряду диаграммы, панели погрешностей автоматически настраиваются и отражают сделанные изменения.


Изменение параметров планок погрешностей на Web-диаграмме

Если выделить на диаграмме одну планку погрешностей и внести в нее какие-либо изменения, то эти изменения отразятся на всех планках погрешностей соответствующего ряда данных.

  1. Откройте панель свойств диаграммы, если ее еще нет на экране.

    Инструкции

  2. Щелкните мышью любую планку погрешности на диаграмме.

  3. Если раздел Планка погрешностей на панели свойств диаграммы еще не развернут, щелкните панель Планка погрешностей.

  4. Чтобы выбрать вид планки погрешности (плюс или минус), щелкните стрелку справа от поля Вывести на экран [image] и выберите нужный вид планки погрешности.

    Чтобы выбрать планку погрешности в виде отрезка с граничными штрихами или без них, щелкните стрелку справа от поля Маркер [image] и выберите нужный вид планки.

    Нужный способ вычисления погрешности выберирается из списка Вычисление погрешности. Соответствующее число вводится в поле фиксированное значение: или в поле относительное значение:.

    Направление планок погрешности для отображения X-погрешностей или Y-погрешностей на точечных, полярных и пузырьковых диаграммах выбирается щелчком X или Y в списке Направление.


Удаление планок погрешностей на Web-диаграмме

Отдельную планку погрешностей удалить нельзя. При удалении одной планки удаляются планки всего ряда данных.

  1. Щелкните планку погрешностей.

  2. Нажмите клавишу DELETE.


Формулы для вычисления погрешностей для Web-диаграмм

Стандартное отклонение

где:

s = номер ряда,

i = номер точки в ряду s,

m = номер ряда для точки y на диаграмме,

n = количество точек в каждом ряду,

Переменная = значение i-ой точки в ряду s,

Переменная = общее количество значений во всех рядах,

M = среднее арифметическое.

Стандартная погрешность


Клавиши для выбора элементов на Web-диаграммах

Если Web-диаграмма активна, ее элементы можно выбирать не только мышью, но и клавишами. Сведения об активизации Web-диаграммы содержатся в справке программы-конструктора.

Клавиша | Действие
СТРЕЛКА ВПРАВО | Выбор следующего элемента диаграммы.
СТРЕЛКА ВЛЕВО | Выбор предыдущего элемента диаграммы.
СТРЕЛКА ВНИЗ | Выбор следующей группы элементов.
СТРЕЛКА ВВЕРХ | Выбор предыдущей группы элементов.


Разрешение вопросов, возникающих при работе с Web-диаграммами

Список вопросов

Создание диаграмм

Не удается изменить существующую Web-диаграмму с помощью мастера.

После отмены создания диаграммы с помощью мастера на Web-странице осталась пустая диаграмма.

Появилось сообщение об отсутствии на Web-странице источника данных, диаграмма на Web-странице оказалась пустой.

Отсутствует текст по горизонтальной оси (оси Х) диаграммы.

Диаграмма неверно отображает данные.

На точечной Web-диаграмме по горизонтальной оси (оси X) оказались неверные значения.

Не удается переместить элементы Web-диаграммы или изменить их размеры с помощью мыши.

Не удается добавить или форматировать подписи для отдельных данных диаграммы.

Не удается добавить текст к диаграмме.

Не удается создать на Web-диаграмме вспомогательную ось значений с другой шкалой.

На Web-диаграмме не удается изменить цвет отдельного маркера ряда.

Не удается объединить некоторые типы диаграмм в одной Web-диаграмме.

В подписи формулы для кривой аппроксимации появляется сообщение «Ошибка аппроксимации».

Web-диаграмма, основанная на сводной таблице, пуста или не отображает данных.

Просмотр обозревателем или другой программой

Вместо диаграммы на Web-странице оказалось пустое место.

На диаграмме, опубликованной из Microsoft Excel, отсутствуют данные, если просматривать ее обозревателем или программой-конструктором.

Пользователи не могут просматривать диаграмму или работать с ней в своих обозревателя.

Web-диаграмма не обновляется в обозревателе.

Внешний вид диаграммы, опубликованной из Microsoft Excel, отличается от исходного.

После опубликования диаграммы из Excel на ней стало больше данных.

При нажатии на кнопку Правка Web-обозревателя Web-страница открывается не тем приложением.


Не удается изменить существующую Web-диаграмму с помощью мастера.

Мастер диаграмм Microsoft Office позволяет создавать новые Web-диаграммы, но изменять уже существующие диаграммы с его помощью нельзя.

Использование панели свойств диаграммы. При необходимости изменить тип диаграммы, а также параметры ее форматирования и отображения на экране, используйте панель свойств диаграммы.

Изменение данных. Если необходимо изменить отображаемые на диаграмме данные, измените их в источнике данных (в электронной таблице, сводной таблице, таблице базы данных или запросе). Диаграмма автоматически обновится.

Создание новой диаграммы. Если для диаграммы потребовался другой источник данных (например, вместо одной таблицы необходимо использовать другую), то следует создать новую диаграмму.


После отмены создания диаграммы с помощью мастера на Web-странице осталась пустая диаграмма.

После запуска мастера диаграмм Microsoft Office на Web-странице всегда появляется новая диаграмма, даже если ее создание было отменено. После отмены у диаграммы прерывается связь с источником данных, поэтому она становится пустой.

Удалите пустую диаграмму, подготовьте исходные данные, если они не готовы, затем вызовите мастер диаграмм [image] и создайте новую диаграмму.


Появилось сообщение об отсутствии на Web-странице источника данных, затем диаграмма на Web-странице оказалась пустой.

Источник данных для Web-диаграммы должен либо находиться Web-странице, либо быть доступным для нее. Таким источником данных могут служить: таблица базы данных, представление, сводная таблица и электронная таблица. См. Источники данных для Web-диаграмм.

Удалите пустую диаграмму, подготовьте исходные данные для диаграммы, затем вызовите мастера диаграмм [image] и создайте новую диаграмму.


Отсутствует текст по горизонтальной оси (оси X) Web-диаграммы.

Возможно, на диаграмме отсутствует место для отображения всех подписей оси. Если имена каких-либо категорий на горизонтальной оси не видны, попробуйте выполнить следующие действия:

  • Увеличьте диаграмму. Дополнительные сведения об элементах управления для выбора и изменения размеров диаграммы, можно получить в справке программы-конструктора.

  • Уменьшите размер шрифта текста на горизонтальной оси (оси X).

  • Укоротите имена категорий в исходных данных, если это возможно.


Web-диаграмма неверно отображает данные.

Различные типы диаграмм подчеркивают различные характеристики данных. Например, круговая диаграмма наглядно показывает вклад частей в общую сумму, а на гистограмме удобнее сравнить эти части, либо проследить изменение величины во времени.

Дополнительные сведения

Изменение типа диаграммы

Примеры типов диаграмм


На точечной Web-диаграмме по горизонтальной оси (оси X) оказались неверные значения.

Если по оси категорий (оси X) вместо требуемых отображаются иные значения, например 1, 2, 3, 4, то при создании диаграммы, возможно, вместо точечного типа ошибочно был выбран график. Удалите диаграмму, а затем вызовите мастер диаграмм [image] . В диалоговом окне Мастер диаграмм Microsoft Office — шаг 1 из 3 в поле Тип диаграммы щелкните Точечная. Если необходимо, чтобы маркеры данных диаграммы были соединены линиями, задайте подтип точечной диаграммы, имеющий такие линии.


Не удается переместить элементы Web-диаграммы или изменить их размеры с помощью мыши.

Перемещение элементов диаграммы (таких как легенда, область построения, подписи данных и заголовки) изменение их размеров с помощью мыши невозможно.

Перемещение

Большинство элементов диаграммы перемещаются с помощью параметров Положение или Размещение в соответствующем разделе панели свойств диаграммы. Например, можно повернуть или зеркально отразить область построения диаграммы, выдвинуть сектор на круговой и кольцевой диаграммах.

Дополнительные сведения

Изменение положения подписей данных

Изменение размещения названия

Изменение положения оси

Перемещение легенды

Поворот и зеркальное отражение области построения

Отделение секторов на круговой и кольцевой диаграммах

Изменение размеров элементов диаграмм

С помощью панели свойств диаграммы можно изменить: размер шрифта, используемого для подписей данных, заголовков и легенды; размер отверстия в кольцевой диаграмме; размер маркеров данных для некоторых типов диаграмм. Размеры других элементов будут изменяться автоматически при изменении размеров диаграммы.

Дополнительные сведения

Изменение шрифта и размера текста

Изменение размера отверстия в кольцевой диаграмме

Изменение размера, цвета и формы маркеров данных на графиках, точечных и лепестковых диаграммах.


Не удается добавить или форматировать подписи для отдельных данных Web-диаграммы.

Можно добавить подпись только ко всему ряду данных. Изменение отдельной подписи данных вызывает изменение всех подписей данных этого ряда. См. Изменение подписей данных на Web-диаграмме.


Не удается добавить текст к Web-диаграмме.

Можно добавить к диаграмме заголовки, а также добавить заголовки к осям диаграммы. Также имеется возможность добавить подписи значений к маркерам данных. Нельзя добавить к диаграмме не связанный с нею текст. Если такой текст необходим, то разместите его на Web-странице, содержащей диаграмму.


Не удается создать на Web-диаграмме вспомогательную ось значений с другой шкалой.

Microsoft Excel позволяет создать диаграмму с вспомогательной осью значений (ось со шкалой, отличной от основной оси значений), а затем опубликовать такую диаграмму на Web-странице с поддержкой интерактивных функций. Чтобы сохранить вспомогательную ось значений, не изменяйте диаграмму другими программами-конструкторами после ее опубликования.

При создании Web-диаграммы в Microsoft FrontPage 2000 или конструктором страниц доступа к данным Microsoft Access 2000 можно добавить вспомогательную ось значений, имеющую ту же шкалу, что и основная ось значений. Вспомогательную ось, имеющую другую шкалу, в этом случае добавить нельзя.


На Web-диаграмме не удается изменить цвет отдельного маркера ряда.

Microsoft Excel позволяет создать диаграмму с различными цветами маркеров одного ряда. Для этого следует установить флажок Разноцветные точки. Затем такую диаграмму можно опубликовать из Excel на Web-странице с поддержкой интерактивных функций. Чтобы сохранить вышеупомянутую возможность, не изменяйте диаграмму другими программами-конструкторами после ее опубликования.

После создания Web-диаграммы в Microsoft FrontPage 2000 или конструктором страниц доступа к данным Microsoft Access 2000, цвета отдельных маркеров ряда данных изменять нельзя. См. Работа с диаграммами, опубликованными из Excel.


Не удается объединить типы Web-диаграмм в одной диаграмме.

При создании Web-диаграммы в Microsoft FrontPage 2000 или конструктором страниц доступа к данным Microsoft Access 2000 можно объединить диаграммы следующих типов: гистограммы, графики, линейчатые, точечные, диапазонные, биржевые и диаграммы с областями. Другие типы диаграмм не совмещаются.

При необходимости объединить диаграммы других типов, например, круговую диаграмму с гистограммой, можно создать диаграмму в Microsoft Excel, а затем опубликовать ее на Web-странице с поддержкой интерактивных функций. Для сохранения таких комбинаций не изменяйте рядов диаграммы другими программами-конструкторами. См. Работа с диаграммами, опубликованными из Excel.


В подписи формулы для линии тренда появляется сообщение «Ошибка аппроксимации».

Если данные содержат нулевые или отрицательные значения, в подписи формулы для степенной и экспоненциальной линий тренда появляется сообщение «Ошибка аппроксимации». Используйте другой, подходящий для этих данных тип аппроксимации. См. выбор наилучшей линии тренда для аппроксимации данных.


Web-диаграмма, основанная на сводной таблице, пуста или не отображает данных

Добавьте поля итогов. Для диаграммы, отображающей данные сводной таблицы, необходимо добавить в сводную таблицу не менее одного поля итогов.

Переместите поля в области строк и столбцов. Поля строк и столбцов сводной таблицы образуют данные рядов и категорий на диаграмме. Например, если все видимые поля находятся только в области сведений, на диаграмме не будет построено категорий и рядов. Из области сведений или списка полей сводной таблицы переместите не менее чем по одному полю в области строк и столбцов.

Сведения о работе со сводной таблицей содержатся в справке о соответствующем Web-компоненте.


Вместо диаграммы на Web-странице оказалось пустое место.

В обозревателе. Просматривать Web-диаграммы и работать с ними можно в Microsoft Internet Explorer 4.01 и более поздней версии. В более ранних версиях обозревателя диаграммы могут быть не видны. В этом случае рекомендуется закрыть страницу, затем открыть ее с помощью Internet Explorer версии 4.01 или более поздней.

В программе-конструкторе. Просматривать и изменять опубликованные Web-диаграммы можно с помощью Microsoft FrontPage 2000 и конструктора страниц доступа к данным Microsoft Access 2000. В других программах-конструкторах, включая Microsoft FrontPage 98, диаграммы могут отображаться как пустые прямоугольники. Если последней версией FrontPage, установленной на вашем компьютере, является FrontPage 98, то эта программа, вероятно, запустится при выборе команды Правка в меню Файл обозревателя Internet Explorer 5. В этом случае закройте страницу, затем откройте ее программой, поддерживающей Web-диаграммы.


На диаграмме, опубликованной из Microsoft Excel, отсутствуют данные, если просматривать ее обозревателем или программой-конструктором.

Перед опубликованием Web-диаграммы из Microsoft Excel необходимо включить в нее значения обеих осей X и Y, если это точечная диаграмма, а также значения размеров пузырьков, если это пузырьковая диаграмма. Excel обеспечивает значения по умолчанию для оси X, если они отсутствуют в исходных данных. Эти значения отображаются на диаграмме в Excel, но не сохраняются при опубликовании диаграммы на Web-странице.

Если все необходимые значения не были включены в диаграмму, введите их в столбец, смежный с исходными данными, а затем создайте диаграмму заново и опубликуйте ее.


Пользователи не могут просматривать диаграмму или работать с диаграммой в своих обозревателях.

Установите Web-компоненты Microsoft Office. Для просмотра Web-диаграмм и работы с ними у пользователей должны быть установлены Web-компоненты Office. Это можно выполнить при установке Microsoft Office 2000 или, если у организации имеется лицензия на работу с Web-узлом Microsoft Office 2000, можно загрузить Web-компоненты через корпоративную интрасеть.

Проверьте версию обозревателя. Для работы с диаграммами необходимо иметь Microsoft Internet Explorer версии 4.01 или более поздней версии. Рекомендуется использовать Internet Explorer 5, который поставляется вместе с Microsoft Office 2000, чтобы полностью использовать все преимущества интерактивной работы с диаграммами и их данными. Дополнительную сведения об уровнях интерактивного использования исходных данных диаграмм в различных версиях обозревателей смотрите в справке по работе с исходными данными.

См. Использование обозревателя для работы с Web-диаграммами.


Web-диаграмма не обновляется в обозревателе.

Если диаграмма опубликована из Microsoft Excel без поддержки интерактивных функций, то отображаемая обозревателем диаграмма статична и не связана с исходными данными. См. Вызов справки об опубликовании диаграмм из Microsoft Excel.


Внешний вид диаграммы, опубликованной из Microsoft Excel, отличается от исходного.

Некоторые параметры диаграмм Microsoft Excel после опубликования их на Web-страницах не сохраняются или замещаются параметрами по умолчанию. Например, не сохраняются рисунки на диаграммах. См. Изменение свойств диаграммы, созданной в Excel, после ее опубликования на Web-странице.

Дополнительные сведения

Диаграмма, опубликованная из Microsoft Excel, при просмотре ее обозревателем оказалась пустой.

После опубликования диаграммы из Excel на ней стало больше данных.


После опубликования диаграммы из Excel на ней стало больше данных

В Microsoft Excel можно отображать на диаграмме только видимые ячейки. Если эта возможность используется, то данные скрытых строк или столбцов не отображаются на диаграмме. После опубликования диаграммы все данные, включая скрытые, отображаются.

Если отображение данных, содержащихся в скрытых строках и столбцах, нежелательно, то перед опубликованием диаграммы необходимо открыть эти строки и столбцы на листе Excel и переместить их за пределы диапазона, выбранного при создании диаграммы. Дополнительные сведения о перемещении данных на листе смотрите в справке Excel. Если нужно изменить диаграмму после ее опубликования, откройте и удалите строки или столбцы, данные которых нежелательно показывать в электронной таблице, опубликованной вместе с диаграммой. О том, как удалять строки и столбцы, смотрите в справке по электронным таблицам.


Выбор рядов данных либо в строках, либо в столбцах

На диаграмме ряды данных выглядят как упорядоченные множества цветных маркеров. Имена рядов данных содержатся в легенде.

Предположим, данные содержатся в электронной таблице, как в приведенном ниже примере:

Данные в электронной таблице.

Если на диаграмме нужно отобразить данные, содержащиеся в столбцах А и B, а также элемент легенды «Европа» и подписи категорий «Кв.1», «Кв.2», «Кв.3», «Кв.4», то после Ряды в: следует установить флажок столбцах. Диаграмма примет следующий вид:


Задание значений с помощью мастера диаграмм

В этом разделе описано, как с помощью мастера диаграмм задавать значения для следующих типов диаграмм:

С областями

Гистограмма

Линейчатая

График и гладкий график

Круговая

Кольцевая

Биржевая

Точечная

Пузырьковая

Лепестковая

Полярная

С областями

Диаграмма с областями

Для каждого ряда, отображаемого на диаграмме с областями, можно задать следующие значения:

Имя (Имена рядов). Если данные для диаграммы находятся в электронной таблице, то в это поле вводится ссылка на ячейку, которая содержит имя ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Вместо ссылки можно ввести любой текст, который будет служить названием ряда. Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Имена рядов и выберите поле, содержащее имена рядов. В приведенном примере именами рядов являются названия стран (Австралия, Бразилия и так далее). Все они отображены в легенде.

Значения. В этом поле следует указать значения для каждого ряда. Если данные содержатся в электронной таблице, то значения указываются ссылкой на диапазон, который содержит значения ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения и укажите в списке поле, содержащее значения ряда, выбранного в поле Имена рядов. На приведенной выше диаграмме каждому ряду значений соответствует свой цвет.

Подписи оси X (категорий). Категория — это группа точек данных, в которую входит по одной точке данных из каждого ряда данных, отображаемых на диаграмме. Если эти данные хранятся в электронной таблице, то в это поле вводится диапазон, содержащий подписи категорий. Диапазон предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Подписи оси X (категорий) и выберите поле, содержащее подписи категорий. В приведенном примере подписями оси X являются годы, расположенные вдоль нижней части диаграммы.

Возврат в начало

Гистограмма

Для каждого ряда, отображаемого на гистограмме, можно задать следующие значения:

Имя (Имена рядов). Если данные для диаграммы хранятся в электронной таблице, то в это поле вводится ссылка на ячейку, которая содержит имя ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Вместо ссылки можно ввести любой текст, который будет служить названием ряда. Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Имена рядов и выберите поле, содержащее имена рядов. В приведенном примере именем ряда является Европа. На гистограмме можно отобразить несколько рядов.

Значения. В этом поле следует указать значения для каждого ряда. Если данные содержатся в электронной таблице, то значения указываются ссылкой на диапазон, который содержит значения ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения и укажите в списке поле, содержащее значения ряда, выбранного в поле Имена рядов. В приведенном примере группа синих маркеров представляет один ряд значений.

Подписи оси X (категорий). Категория — это группа точек данных, в которую входит по одной точке данных из каждого ряда данных, отображаемых на диаграмме. Если эти данные хранятся в электронной таблице, то в это поле вводится диапазон, содержащий подписи категорий. Диапазон предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Подписи оси X (категорий) и выберите поле, содержащее подписи категорий. В приведенном примере подписями оси X являются кварталы («Кв.1», «Кв.2»), расположенные вдоль нижней части диаграммы.

Возврат в начало

Линейчатая

Для каждого ряда, отображаемого на линейчатой диаграмме, можно задать следующие значения:

Имя (Имена рядов). Если данные для диаграммы находятся в электронной таблице, то в это поле вводится ссылка на ячейку, которая содержит имя ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Вместо ссылки можно ввести любой текст, который будет служить названием ряда. Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Имена рядов и выберите поле, содержащее имена рядов. В приведенном примере именами рядов являются «Собственность» и «Бензин».

Значения. В этом поле следует указать значения для каждого ряда. Если данные содержатся в электронной таблице, то значения указываются ссылкой на диапазон, который содержит значения ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения и укажите в списке поле, содержащее значения ряда, выбранного в поле Имена рядов. В приведенном выше примере каждая группа маркеров, окрашенная одним цветом, представляет один ряд значений.

Подписи оси Y. Ось Y в этом случае является осью категорий. Категория — это группа точек данных, в которую входит по одной точке данных из каждого ряда данных, отображаемых на диаграмме. Если эти данные хранятся в электронной таблице, то в это поле вводится диапазон, содержащий подписи категорий. Диапазон предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Подписи оси Y и выберите поле, содержащее подписи категорий. В приведенном примере подписями оси Y являются те подписи (1 год, 2 год и 3 год), которые расположены вдоль левой части диаграммы.

Возврат в начало

График и гладкий график

Для каждого ряда, отображаемого на графике или гладком графике, можно задать следующие значения:

Имя (Имена рядов). Если данные для диаграммы хранятся в электронной таблице, то в это поле вводится ссылка на ячейку, которая содержит имя ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Вместо ссылки можно ввести любой текст, который будет служить названием ряда. Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Имена рядов и выберите поле, содержащее имена рядов. На графике можно отобразить несколько рядов. В приведенном примере именами рядов являются Европа, США и Азия.

Значения. В этом поле следует указать значения для каждого ряда. Если данные содержатся в электронной таблице, то значения указываются ссылкой на диапазон, который содержит значения ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения и укажите в списке поле, содержащее значения ряда, выбранного в поле Имена рядов. В приведенном примере группа ряды значений представлены группами зеленых, синих и сиреневых маркеров.

Подписи оси X (категорий). Категория — это группа точек данных, в которую входит по одной точке данных из каждого ряда данных, отображаемых на диаграмме. Если эти данные хранятся в электронной таблице, то в это поле вводится диапазон, содержащий подписи категорий. Диапазон предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Подписи оси X (категорий) и выберите поле, содержащее подписи категорий. В приведенном примере подписями оси X являются кварталы («Кв.1», «Кв.2»), расположенные вдоль нижней части диаграммы.

Возврат в начало

Круговая

Многоуровневая круговая диаграмма

Для каждого ряда, отображаемого на круговой диаграмме или многоуровневой круговой диаграмме, можно задать следующие значения:

Имя (Имена рядов). Если данные для диаграммы хранятся в электронной таблице, то в это поле вводится ссылка на ячейку, которая содержит имя ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Вместо ссылки можно ввести любой текст, который будет служить названием ряда. Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Имена рядов и выберите поле, содержащее имена рядов. На обычной круговой диаграмме можно отобразить только один ряд. На многоуровневой круговой диаграмме можно отобразить несколько рядов, как это сделано в приведенном выше примере. В заголовке диаграммы указаны имена рядов: «Продано единиц» (внутренний круг) и «Сумма продаж» (внешний круг).

Значения. В этом поле следует указать значения для каждого ряда. Если данные содержатся в электронной таблице, то значения указываются ссылкой на диапазон, который содержит значения ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения и укажите в списке поле, содержащее значения ряда, выбранного в поле Имена рядов. В приведенном выше примере каждый круг представляет свой ряд значений.

Подписи оси X (категорий). Ось X также называется осью категорий. Категория — это группа точек данных, в которую входит по одной точке данных из каждого ряда данных, отображаемых на диаграмме. Если эти данные хранятся в электронной таблице, то в это поле вводится диапазон, содержащий подписи категорий. Диапазон предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Подписи оси X (категорий) и выберите поле, содержащее подписи категорий. В приведенном примере подписями оси X являются подписи в легенде (бутерброды, салаты, суп).

Возврат в начало

Кольцевая

Для каждого ряда, отображаемого на кольцевой диаграмме, можно задать следующие значения:

Имя (Имена рядов). Если данные для диаграммы хранятся в электронной таблице, то в это поле вводится ссылка на ячейку, которая содержит имя ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Вместо ссылки можно ввести любой текст, который будет служить названием ряда. Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Имена рядов и выберите поле, содержащее имена рядов. На кольцевой диаграмме ряды представляются кольцами. В приведенном выше примере в заголовке диаграммы указаны имена рядов: «НДС» (внешнее кольцо) и «Доходы от продаж соков» (внутреннее кольцо).

Значения. В этом поле следует указать значения для каждого ряда. Если данные содержатся в электронной таблице, то значения указываются ссылкой на диапазон, который содержит значения ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения и укажите в списке поле, содержащее значения ряда, выбранного в поле Имена рядов. В приведенном выше примере каждое кольцо представляет свой ряд значений.

Подписи оси X (категорий). Категория — это группа точек данных, в которую входит по одной точке данных из каждого ряда данных, отображаемых на диаграмме. Если эти данные хранятся в электронной таблице, то в это поле вводится диапазон, содержащий подписи категорий. Диапазон предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Подписи оси X (категорий) и выберите поле, содержащее подписи категорий. В приведенном примере подписями оси X являются подписи в легенде («1 год» и «2 год»).

Возврат в начало

Биржевая

Данные и отображающая их биржевая диаграмма.

Для каждого ряда, отображаемого на биржевой диаграмме, можно задать следующие значения:

Имя (Имена рядов). Если данные, которые требуется отобразить на диаграмме, хранятся в электронной таблице, то в это поле вводится ссылка на ячейку, которая содержит имя ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Вместо ссылки можно ввести любой текст, который будет служить названием ряда. Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, то щелкните стрелку справа от поля Имена рядов и выберите поле, содержащее имена рядов. На биржевой диаграмме каждый ряд может включать в себя до четырех подмножеств — значения при открытия торгов, максимальные значения, минимальные значения, значения при закрытии торгов. В приведенном выше примере построенный на диаграмме ряд называется «Закрытие».

Значения при открытии. Это поле доступно лишь для биржевой диаграммы с четырьмя наборами значений: курс при открытии, максимальный курс, минимальный курс, курс при закрытии. Если данные содержатся в электронной таблице, то в этом поле указывается ссылка на диапазон столбца, содержащего значения курса при открытии торгов. Эта ссылка предваряется знаком равенства (=). Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения при открытии и выберите поле, содержащее значения при открытии. (В приведенном примере эти значения не отображены на диаграмме.)

Наибольшие значения. Эти значения содержатся в столбце «Макс». Если данные содержатся в электронной таблице, то в этом поле указывается ссылка на диапазон этого столбца. Ссылка предваряется знаком равенства (=). Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Наибольшие значения и выберите поле, содержащее наибольшие значения. В приведенном примере наибольшие значения ряда соответствуют верхушкам вертикальных отрезков.

Наименьшие значения. Эти значения содержатся в столбце «Мин». Если данные содержатся в электронной таблице, то в этом поле указывается ссылка на диапазон этого столбца. Ссылка предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Наименьшие значения и выберите поле, содержащее наименьшие значения. В приведенном примере наименьшие значения ряда соответствуют нижним краям вертикальных отрезков.

Значения при закрытии. Эти значения содержатся в столбце «Закрытие». Если данные содержатся в электронной таблице, то в этом поле указывается ссылка на диапазон этого столбца. Ссылка предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения при закрытии и выберите поле, содержащее значения при закрытии. В приведенном примере этим значениям соответствуют синие горизонтальные отрезки, пересекающие вертикальные отрезки ряда.

Подписи оси X (категорий). Категория — это группа точек данных, в которую входит по одной точке данных из каждого ряда данных, отображаемых на диаграмме. Если эти данные хранятся в электронной таблице, то в это поле вводится диапазон, содержащий подписи категорий. Диапазон предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Подписи оси X (категорий) и выберите поле, содержащее подписи категорий. В приведенном примере подписями оси X являются даты.

Возврат в начало

Точечная

Данные для построения диаграммы

Для каждого ряда, отображаемого на точечной диаграмме, можно задать следующие значения:

Имя (Имена рядов). Если данные для построения диаграммы находятся в электронной таблице, то в это поле вводится ссылка на ячейку, которая содержит имя ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Вместо ссылки можно ввести любой текст, который будет служить названием ряда. Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Имена рядов и выберите поле, содержащее имена рядов. В приведенном примере именами рядов являются «Эксперимент» (температура) и «Теория» (прогноз температуры).

Значения X. Это значения, откладываемые по оси X. В приведенном выше примере значениями X являются моменты времени. Если данные хранятся в электронной таблице, то в это поле вводится ссылка на диапазон, содержащий значения X. Ссылка предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения X и выберите поле, содержащее значения X.

Значения Y. Это значения, откладываемые по оси Y. В приведенном выше примере значения y являются температурой. Если данные хранятся в электронной таблице, то в это поле вводится ссылка на диапазон, содержащий значения y. Ссылка предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения Y и выберите поле, содержащее значения y.

Подписи категорий. Эти значения (как правило, текст) используются для подписей данных. Их можно добавлять на диаграмму и изменять после создания диаграммы. Эти значения указываются в случае, когда вместе с подписями данных на диаграмме необходимо отобразить имена категорий. Задание подписей категорий не означает, что на диаграмме автоматически будут отображены подписи данных. Если данные хранятся в электронной таблице, то в поле подписей категории вводится ссылка на диапазон, содержащий требуемые значения. Ссылка предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Подписи категорий и выберите поле, содержащие требуемые значения.

Возврат в начало

Пузырьковая

Данные для построения диаграммы

Для каждого ряда, отображаемого на пузырьковой диаграмме, можно задать следующие значения:

Имя (Имена рядов). Если данные для диаграммы находятся в электронной таблице, то в это поле вводится ссылка на ячейку, которая содержит имя ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Вместо ссылки можно ввести любой текст, который будет служить именем ряда. Если данные для диаграммы хранятся в таблице базы данных, либо извлекаются запросом, щелкните стрелку справа от поля Имена рядов и выберите поле, содержащее имя ряда или имена рядов. В приведенном выше примере построен один ряд без имени. Если имя ряда не задано, то в легенде отображается имя «Ряд», которое принято по умолчанию. Поскольку в этом примере легенда на диаграмме отсутствует, слово «Ряд» также не отображается.

Значения X. Это значения, откладываемые по оси X. В приведенном выше примере значениями X являются номера товаров. Если данные хранятся в электронной таблице, то в поле вводится ссылка на диапазон, содержащий значения X. Ссылка предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения X и выберите поле, содержащее значения X.

Значения Y. Это значения, откладываемые по оси Y. В приведенном выше примере значениями y являются суммы продаж в миллиардах рублей. Если данные хранятся в электронной таблице, то в это поле вводится ссылка на диапазон, содержащий значения Y. Ссылка предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения Y и выберите поле, содержащее значения Y.

Размеры. Эти значения определяют размеры пузырьков. Если данные хранятся в электронной таблице, в это поле вводится ссылка на диапазон, содержащий размеры пузырьков. Ссылка предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Размеры и выберите поле, содержащее значения размеров.

Подписи категорий. Эти значения (как правило, текст) используются для подписей данных. Их можно добавлять на диаграмму и изменять после создания диаграммы. Эти значения указываются в случае, когда вместе с подписями данных на диаграмме необходимо отобразить имена категорий. Задание подписей категорий не означает, что на диаграмме автоматически будут отображены подписи данных. Если данные хранятся в электронной таблице, то в поле подписей категории вводится ссылка на диапазон, содержащий требуемые значения. Ссылка предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Подписи категорий и выберите поле, содержащие требуемые значения.

Возврат в начало

Лепестковая

Для каждого ряда, отображаемого на лепестковой диаграмме, можно задать следующие значения:

Имя (Имена рядов). Если данные для диаграммы находятся в электронной таблице, то в это поле вводится ссылка на ячейку, которая содержит имя ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Вместо ссылки можно ввести любой текст, который будет служить названием ряда. Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Имена рядов и выберите поле, содержащее имена рядов. В приведенном примере именами рядов являются «Сорт А», «Сорт Б» и «Сорт В».

Значения. В этом поле следует указать значения для каждого ряда. Если данные хранятся в электронной таблице, то в это поле вводится ссылка на диапазон, содержащий значения ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения и укажите в списке поле, содержащее значения ряда, выбранного в поле Имена рядов. В приведенном выше примере каждая цветная линия представляет свой ряд значений.

Подписи оси X (категорий). Категория — это группа точек данных, в которую входит по одной точке данных из каждого ряда данных, отображаемых на диаграмме. Если эти данные хранятся в электронной таблице, то в это поле вводится диапазон, содержащий подписи категорий. Диапазон предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Подписи оси X и выберите поле, содержащее подписи категорий. В приведенном выше примере подписями оси X являются подписи «Витамин C», «Витамин B2».

Возврат в начало

Полярная

Для каждого ряда, отображаемого на полярной диаграмме, можно задать следующие значения:

Имя (Имена рядов). Если данные для диаграммы находятся в электронной таблице, то в это поле вводится ссылка на ячейку, которая содержит имя ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Вместо ссылки можно ввести любой текст, который будет служить названием ряда. Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Имена рядов и выберите поле, содержащее имена рядов. В приведенном выше примере именами рядов являются «высота 1/2 лямбда, угол возвышения 30 градусов» и «высота 1 лямбда, угол возвышения 15 градусов».

Значения R. Это значения R для каждого ряда. Если данные хранятся в электронной таблице, то в это поле вводится ссылка на диапазон, который содержит значения R для ряда, выбранного в поле Значения R. Ссылка предваряется знаком равенства (=). Если данные для диаграммы хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Значения R и выберите в списке поле, содержащее значения ряда, выбранного в поле Имена рядов.

Тета-значения. Это значения угла «тета». Если данные хранятся в электронной таблице, то в это поле вводится ссылка на диапазон, содержащий значения угла «тета» для ряда, выбранного в списке Ряд. Ссылка предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Тета-значения и выберите в списке поле, содержащее значения ряда, выбранного в поле Имена рядов.

Подписи категорий. Эти значения (как правило, текст) используются для подписей данных. Их можно добавлять на диаграмму и изменять после создания диаграммы. Эти значения указываются в случае, когда вместе с подписями данных на диаграмме необходимо отобразить имена категорий. Задание подписей категорий не означает, что на диаграмме автоматически будут отображены подписи данных. Если данные хранятся в электронной таблице, то в поле подписей категории вводится ссылка на диапазон, содержащий требуемые значения. Ссылка предваряется знаком равенства (=). Если данные хранятся в таблице базы данных или извлекаются запросом, щелкните стрелку справа от поля Подписи категорий и выберите поле, содержащие требуемые значения.

Возврат в начало


Мастер диаграмм Microsoft Office — шаг 3а

На этом шаге с помощью мастера следует указать, где находятся данные для построения рядов данных — в строках или столбцах электронной таблицы, либо извлечены запросом. Названия рядов данных отображаются в легенде.

Этим выбором определяется набор параметров, выбираемых на следующем шаге.

Записи для легенды в одном столбце

Как видно из приведенного мастером примера, в этом случае значения для каждого ряда данных берутся из строк с именем этого ряда. Имя отображается в легенде вместе с цветным ключом. В этом примере именами рядов являются значения в строках второго столбца («Джаз» и «Рок»). Значения в строках третьего столбца являются значениями соответствующих им рядов. Значения в строках первого столбца (1995 и 1996 годы) являются подписями категорий. После выбора этого варианта на следующем шаге мастера выбираются столбцы таблицы, содержащие строки с именами и значениями рядов.

Записи для легенды в нескольких столбцах

Этот вариант выбирается в случае, если данные организованы в виде перекрестной таблицы. При этом значения каждого ряда содержатся в соответствующем ему столбце. На диаграмме, приведенной мастером в качестве примера, «Джаз» и «Рок» являются именами столбцов и отображаются в легенде. Содержащиеся в этих столбцах значения являются значениями соответствующих им рядов. Значения в первом столбце (1995 и 1996 годы) являются подписями категорий. После выбора этого варианта на следующем шаге мастера указываются строки таблицы или запрос с именами и значениями рядов, а также столбец, содержащий подписи категорий.


Мастер диаграмм Microsoft Office — шаг 3

На этом шаге следует указать как именно — в строках или столбцах сводной таблицы — расположены ряды данных, которые предполагается отобразить на диаграмме.

На диаграмме ряды данных выглядят как упорядоченные множества цветных маркеров. Имена рядов данных содержатся в легенде.

Пусть сводная таблица имеет следующий вид:

Пусть на диаграмме требуется отобразить поле «Тип» (напитки, молоко и так далее) как записи легенды, а поле «Продавец» (Батурин, Белов и так далее) — как категории. В этом случае после надписи Ряды в: следует установить флажок строках. Мастер построит следующую диаграмму:

Диаграмма, построенная на основе сводной таблицы.

См. Создание и использование диаграмм, основанных на сводных таблицах.


Пример: использование мастера диаграмм для добавления на Web-диаграмму ряда данных

Ряд данных — это группа значений, название которой отображается в легенде. Каждый ряд данных содержит значения, иногда — подписи категорий. Если значения ряда хранятся в электронной таблице, то при добавлении этого ряда на диаграмму с помощью мастера диаграмм Microsoft Office следует указать ссылки на ячейки, в которых содержатся значения ряда и подпись.

На рисунке приведен пример электронной таблицы:

Электронная таблица с данными.

Для построения следующей диаграммы:

необходимо добавить в список Ряд пустой ряд, выбрать его в списке, а затем указать следующее.

Список | Запись
Имя | =B1 (или текст, например «Европа»)
Значения | =B2:B5
Подписи оси X | =A2:A5

Примечание. Дополнительные сведения об использовании ссылок на ячейки электронных таблиц содержатся в справке по компонентам электронных таблиц Microsoft Office.


Мастер диаграмм Microsoft Office — шаг 1

Мастер диаграмм Microsoft Office помогает создавать диаграмму на Web-странице. Если Web-страницу сделать доступной пользователям, то они смогут просматривать ее с помощью своих обозревателей. При изменении отображаемых данных диаграмма обновляется, что позволяет снабжать пользователей самыми свежими сведениями.

С помощью мастера шаг за шагом выбирается тип диаграммы, исходные данные и способ их отображения на диаграмме. См. Создание Web-диаграммы.

Выбор типа диаграммы

На этом шаге мастера выбираются тип и подтип диаграммы. Каждый тип диаграмм подразделяется на несколько подтипов. При выборе следует учесть тип данных, которые должны быть отображены на диаграмме, а также те их особенности, которые желательно подчеркнуть или скрыть. См. Примеры типов диаграмм.


Мастер диаграмм Microsoft Office — шаг 2

Выбор источника данных для диаграммы

На этом шаге мастера выбираются данные, которые будет отображены на диаграмме. Вначале в списке Доступные источники данных выбирается источник данных, затем в следующем списке выбираются сами данные. Например, если в качестве источника данных выбирается таблица базы данных или запрос, то в списке Доступные таблицы базы данных выбирается таблица или запрос, который извлекает данные из базы данных.

Если ожидаемые данные в списке не обнаруживаются, то следует проверить, действительно ли они существуют, а если существуют, то предоставлено ли вам к ним право на доступ. В списке видны лишь те электронные таблицы и сводные таблицы, которые существуют на той же Web-странице, где создается диаграмма. Если выяснится, что данные для диаграммы не подготовлены, то следует прервать работу мастера нажатием кнопки «Отмена», а затем удалить с Web-страницы пустую диаграмму.

См. Исходные данные для Web-диаграмм.


Мастер диаграмм Microsoft Office — шаг 3

На этом шаге мастера указываются те данные электронной таблицы, которые должны быть отображены на диаграмме.

Если в электронной таблице диапазон данных был выбран до запуска мастера, то мастер покажет диаграмму, предварительно построенную по этим данным. Если она отображает данные правильно, значит диапазон данных был выбран верно.

Если же предварительная диаграмма построена неверно, либо вообще не построена, поскольку диапазон данных не выбран, то его следует выбрать одним из следующих способов:

  • Выбор диапазона данных в один шаг. Указывается ссылка на весь диапазон данных для диаграммы. Это самый простой способ, при котором нет необходимости указывать диапазоны для каждого ряда данных по отдельности. Но таким образом можно указать лишь один диапазон данных.

  • Выбор данных отдельно для каждого ряда. Этот способ позволяет добавлять и удалять ряды по одному, для каждого из них указывать имя, значения, подписи категорий (подписи оси X) и другие значения, доступные для выбранного типа диаграммы. Построение диаграммы таким способом требует больше времени, но возможностей при этом больше. Например, можно отобразить на диаграмме несмежные диапазоны данных. Рекомендуется для опытных пользователей.

См. Выбор значений для различных типов диаграмм.


Мастер диаграмм Microsoft Office — шаг 3b

На этом шаге мастера указываются строки или столбцы таблицы (либо запрос), содержащие имена и значения рядов данных, а также некоторые другие значения, например, подписи категорий.

Если на предыдущем шаге выбран вариант Записи для легенды содержатся в одном столбце, то для каждого элемента диаграммы щелкните стрелку справа от соответствующего поля и выберите в списке нужные имена или значения.

Если на предыдущем шаге выбран вариант Записи для легенды содержатся в нескольких столбцах, то каждый ряд добавляется следующим способом. Щелкните кнопку Добавить под списком Ряд, введите имя ряда в списке Имена рядов, выберите в соответствующих списках доступные значения и подписи.

Конкретные действия зависят от типа диаграммы, который выбирается с помощью мастера на первом шаге. Выбор того или иного варианта иллюстрируется мастером на предварительной диаграмме, что значительно облегчает построение диаграммы.

См. Выбор значений для различных типов диаграмм.


Задание данных диаграммы в один шаг

  1. Нажмите кнопкуЗадать данные для диаграммы за один шаг, если это еще не было сделано.

  2. Введите ссылку на диапазон данных, необходимых для создания диаграммы, предварив ее знаком равенства (=) и разделив двоеточием (:). Например, если требуемые данные, являются строками 1 и 2 в столбцах A и B электронной таблицы, введите:

    =A1:B2

  3. Чтобы указать, должны ли ряды данных основываться на значениях строк или столбцов исходной электронной таблицы, после поля Ряды в: установите флажок строках или столбцах.

  4. Нажмите кнопку OK для возврата к шагу 3 мастера диаграмм.

Дополнительные сведения

Выбор рядов данных либо в строках, либо в столбцах


Назначение данных для ряда диаграммы

  1. Варианты действий:

    Чтобы изменить ряд данных, выберите его название в поле Ряд.

    Чтобы добавить ряд, нажмите кнопку Добавить под списком Ряд.

  2. В поле Имя введите текстовое значение или ссылку на ячейку, содержащую имя ряда. Перед ссылкой на ячейку поставьте знак равенства (=).

  3. В поле Значения, укажите диапазон ячеек, содержащих значения данных ряда, предварительно поставив знак равенства (=) и разделив адреса граничных ячеек двоеточием (:).

    Например, если значения для ряда находятся в строках 1-5 столбца B, введите следующее:

    =B1:B5

  4. В каждом из остающихся полей укажите диапазон ячеек, содержащих необходимые значения.

    Доступные значения зависят от типа диаграммы, выбранного на шаге 1 мастера диаграмм.

Примечание. В поле Значения, а также в полях Подписи оси Y, Подписи оси X и Подписи категорий можно использовать только ссылки на ячейки, но не текстовые значения или числа.

Дополнительные сведения

Пример: добавление ряда с помощью мастера диаграмм

Дополнительные сведения о выборе значений для различных типов диаграмм


При нажатии кнопки «Правка» в обозревателе Web-страница открывается не той программой.

Вызов той или иной программы нажатием кнопки Правка в Web-обозревателе зависит от того, как была опубликована открываемая Web-страница.

Если при нажатии кнопки Правка вызвалась неверная программа, закройте ее, запустите нужную программу и откройте в ней Web-страницу.