Создание и опубликование сводной таблицы на Web-странице

В этом разделе подробно рассматривается схема создания сводной таблицы и ее опубликования на Web-странице.

Обзор

Приступая к работе

Шаг 1: Подготовка исходных данных

Шаг 2: Создание или открытие сводной таблицы

Шаг 3: Подсоединение исходных данных к сводной таблице

Шаг 4: Выделение места для сводной таблицы

Шаг 5: Создание макета данных

Шаг 6: Ограничение доступа в обозревателе

Шаг 7: Использование других элементов управления, справки и сценариев

Шаг 8: Проверка и опубликование

Терминология сводных таблиц

Обзор

К сведению начинающих. Сводная таблица является элементом управления Web-компонентами Microsoft Office, который используется для представления на Web-странице итоговых данных, извлекаемых из баз данных и других источников. Пользователи, просматривающие Web-страницу в своих обозревателей, могут работать со сводными таблицами в интерактивном режиме. Для более подробного ознакомления с возможностями этого элемента управления см. Что такое сводная таблица? и Как работать со сводной таблицей в обозревателе.

Общие сведения о создании Web-страниц содержатся в справке программы-конструктора, используемой для создания Web-страниц или Web-узла. Сводные таблицы на Web-страницах можно создать с помощью Microsoft FrontPage(содержится в Office 2000 Premium) и конструктора страниц доступа к данным Microsoft Access 2000 (содержится в Microsoft Office 2000 Professional и в Office 2000 Premium).

Создание сводной таблицы. Включает в себя несколько шагов. Более подробно они рассмотрены ниже. В целом создание сводной таблицы сводится к следующему:

  • Подготовка: Перед началом работы необходимо убедиться в том, что сводная таблица позволит наилучшим образом выполнить предстоящую задачу и сможет удовлетворить ожидания пользователей, работающих из своих обозревателей. После этого следует выбрать такую программу-конструктор, которая соответствует требованиям предстоящей задачи.

  • Подготовка исходных данных (соответствует 1-му шагу): Включает идентификацию исходных данных и установление связи между исходными данными и создаваемой сводной таблицей, через которую будет поддерживаться доступ к этим данным.

  • Подготовка элемента управления сводной таблицы (шаги 2, 3 и 4): Чтобы подготовить элемент управления сводной таблицы, необходимо создать сводную таблицу на Web-странице или в любом другом документе, присоединить к ней исходные данные и выделить для нее место.

  • Создание макета данных (шаг 5): Включает создание первоначального представления данных, их компоновку и форматирование.

  • Настройка сводной таблицы (шаги 6 и 7, необязательные): Предусматривает ограничение доступа к подробным сведениям или к отдельным функциям, создание сопроводительной диаграммы, сценариев, а также собственных справок.

  • Проверка и опубликование (шаг 8): Включает проверку внешнего вида сводной таблицы и ее работы в обозревателе, внесение необходимых изменений и поправок, открытие доступа к Web-странице пользователям Web-узла.

Возврат в начало

Приступая к работе

Определите режим работы с данными. При создании сводной таблицы необходимо решить, каким образом пользователи будут работать с данными: интерактивно или в режиме просмотра.

  • Опубликование на Web-странице. Перед публикацией сводной таблицы на Web-странице следует учитывать тот факт, что возможность интерактивной работы со сводными таблицами из обозревателя зависит от версии бозревателя. Для обеспечения интерактивного режима работы со сводными таблицами нужно порекомендовать пользователям обозреватели, которые полностью поддерживают сводные таблицы.

  • Прсмотр таблицы в другой программе. При создании сводной таблицы для программы, не являющейся Web-обозревателем, следует убедиться в том, что все возможности сводной таблицы доступны в этой программе. См. Программы, позволяющие работать со сводными таблицами.

Подберите подходящий элемент управления для решения задачи. Сводные таблицы применяются для эффективного представления таблиц и списков, извлекаемых из баз данных, с целью интерактивного использования. В зависимости от типа задачи и предполагаемых результатов, вместо сводной таблицы можно использовать любой другой элемент управления Web-компонентами Microsoft Office или же использовать сводную таблицу вместе с другими элементами управления. См. Использование сводной таблицы.

Выберите подходящую программу-конструктор. Для создания сводной таблицы существуют программы-конструкторы с различными возможностями. Например, чтобы разместить на Web-странице диаграмму, отображающую данные сводной таблицы, необходимо воспользоваться конструктором страниц доступа к данным Microsoft Access. См. Выбор программы-конструктора для сводной таблицы.

Возврат в начало

Шаг 1: Подготовка исходных данных

Исходными данными называются сведения, которые требуется отобразить и проанализировать в сводной таблице. Перед включением исходных данных в сводную таблицу следует, исходя из типа исходных данных и программы-конструктора, сделать запрос или выполнить установку источника данных. Источник данных представляет собой средство записи информации, необходимой для подключения сводной таблицы к базе данных, а запрос определяет, какие сведения должны извлекаться из базы данных. См. Типы исходных данных для сводных таблиц. Более подробные сведения и инструкции по подключению программы-конструктора к исходным данным смотрите в справке программы-конструктора.

Публикация отчета сводной таблицы из Microsoft Excel. Подготовленный в Microsoft Excel отчет сводной таблицы можно опубликовать на Web-странице из Excel. Однако некоторые элементы отчета изменятся, если его сохранить как сводную Web-таблицу. Существуют элементы, например, пользовательские вычисления, которые следует предварительно изменить, чтобы на экран выводились верные результаты. См. Работа со сводной таблицей, опубликованной из Excel.

Возврат в начало

Шаг 2: Создание или открытие сводной таблицы

Конкретные шаги по созданию элемента управления сводной таблицы различны для различных программ-конструкторов. Более подробные сведения по этому вопросу можно найти в справке программы-конструктора. Если в справке программы-конструктора сведений о создании сводной таблицы нет, обратитесь к разделу Создание сводной таблицы.

Если сводная таблица уже создана, например, в результате сохранения отчета сводной таблицы Microsoft Excel, либо в результате копирования ее из другой Web-страницы, то ее можно изменить. Для этого следует открыть файл сводной таблицы в программе-конструкторе, затем активизировать элемент управления сводной таблицы в соответствии с инструкциями, содержащимися в этой программе. Обычно элемент управления сводной таблицы активизируется щелчком или двойным щелчком по сводной таблице. Подробности смотрите в справке программы-конструктора.

Задание размеров сводной таблицы и ее размещение. Сводную таблицу обычно размещают на Web-странице, указывая для нее начальную область относительно других элементов страницы. После присоединения к сводной таблице исходных данных (шаг 3), ей задают нужные размеры и перемещают в более удобное расположение (см. шаг 4).

Работа над сводной таблицей. Созданную или выделенную в программе-конструкторе сводную таблицу можно продолжать конструировать с помощью панели инструментов и панели свойств сводной таблицы.

Возврат в начало

Шаг 3: Подсоединение исходных данных к сводной таблице

При работе с уже существующей сводной таблицей можно не заботиться о исходных данных. Они должны быть связаны с элементом управления сводной таблицы и даже храниться в нем самом. Напротив, использование новой сводной таблицы требует установления связи с исходными данными, подготовленными программой-конструктором. См. Подсоединение исходных данных к сводной таблице.

Возврат в начало

Шаг 4: Выделение места для сводной таблицы

Задание начального размера. С помощью элемента управления сводной таблицы можно установить габаритный размер, задавая в нем фиксированную высоту и ширину сводной таблицы, в пределах которых можно просматривать данные. Установка габаритного размера позволяет разворачивать сводную таблицу до заданного максимального размера с выводом на экран полос прокрутки. Габаритный размер отменяет первоначальный размер прямоугольника, который рисуется или задается каким-либо другим способом при создании сводной таблицы. Помимо этого, сводную таблицу можно настроить таким образом, чтобы ее размер автоматически принимал значения, необходимые для отображения данных. В дополнение к сказанному, элемент управления сводной таблицы позволяет изменять размер области сведений и высоту строк в сводной таблице.

Дальнейшее изменение размера. Перечисленные выше установки задают размер сводной таблицы в обозревателе, а также размер рабочей области, используемой при разработке макета данных в программе-конструкторе. В дальнейшем эти установки можно изменить, если возникнет необходимость в дополнительном пространстве для сводной таблицы или же потребуется другая настройка обозревателя.

Возврат в начало

Шаг 5: Создание макета данных

После создания сводной таблицы и установки связи с исходными данными, следует определить, каким образом лучше всего представить данные в сводной таблице, чтобы пользователи, впервые входящие на Web-страницу, смогли легко с ними работать.

Макетирование данных в соответствии с пожеланиями пользователей. Перед макетированием данных следует определить уровень подготовки пользователей и их умение работать с данными в интерактивном режиме. Если пользователи имеют опыт работы со сводными таблицами и хотят создавать свои собственные макеты и подводить итоги, достаточно вывести на экран некоторые поля исходных данных. Если же пользователи нуждаются в особом типе итогов или обзоре данных или рассчитывают воспользоваться готовым макетом, или, наконец, различаются по уровню профессиональной подготовки, необходимо выполнить всю работу по макетированию данных от начала до конца: разметить, скомпоновать и отформатировать данные до получения приемлемого макета. См. Возможности работы со сводной таблицей в обозревателе.

Следует помнить, что в некоторых обозревателях, например, в 3.x, версии Microsoft Internet Explorer просмотр сводных таблиц и работа с ними невозможна. Для работы со сводными таблицами паользователи должны иметь обозреватели, поддерживающие сводные таблицы.

Настройка исходного макета. Для отображения данных в сводной таблице необходимо добавить поля исходных данных в области с различными типами полей. После чего следует определить, каким образом с помощью создания и отображения итогов будут подытоживаться данные.

Компоновка данных. После добавления полей и итогов в сводную таблицу иногда следует перекомпоновать отображенные результаты с помощью нескольких специальных функций таких, как функция сортировки данных, изменяющей порядок элементов данных поля сводной таблицы. Для отображения подмножества данных используется функция фильтрации полей, которая отображает только те элементы данных, значения которых нужно отобразить. Существует также функция, позволяющая выборочно показывать и скрывать сведения любого поля или элемента данных.

Форматирование данных. Форматирование данных сводной таблицы предполагает настройку шрифтов и цвета ячеек, изменение форматов чисел, выравнивание текста в ячейках, изменение ширины колонок, показ и скрытие областей перемещения полей, изменение форматов подписей этих областей, скрытие и отображение индикаторов развертывания ( Плюс и Минус) рядом с элементами данных. См. Форматирование сводной таблицы. Есть возможность добавлять и форматировать название сводной таблицы.

Возврат в начало

Шаг 6: Ограничение доступа в обозревателе

Даже в таком обозревателе, как Microsoft Internet Explorer 5, который полностью поддерживает сводные таблицы, пользователь не имеет доступа к ряду команд и возможностей, доступных в программе-конструкторе. Чтобы запретить пользователям вносить изменения в данные, либо ограничить доступ к тем фрагментам исходных данных, которые необходимо скрыть, следует увеличить количество ограничений. См. Ограничение доступа к сводной таблице в обозревателе.

Возврат в начало

Шаг 7: Использование других элементов управления, справки и сценариев

Использование диаграмм. Чтобы вывести на экран диаграмму, построенную по данным сводной таблицы, следует воспользоваться еще одним Web-компонентом Microsoft Office, а именно Web-диаграммой Microsoft Office. Когда пользователь, работая из Web-обозревателя, изменяет данные сводной таблицы, соответствующая диаграмма автоматически обновляется. Например, чтобы наглядно показать динамику цен по данным сводной таблицы, отображающих изменения курса акций, следует вывести соответствующую диаграмму на Web-страницу. Когда пользователь просматривает в сводной таблице курсы интересующих его акций, диаграмма автоматически обновляется, отражая сделанные изменения. См. Создание и использование элемента управления Web-диаграммы.

Написание сценариев. Используя Web-сценарии или другие программы, пользователь может изменять и управлять параметрами и функциями сводных таблиц. Сценарии для Web-страниц пишутся на таких языках, как Visual Basic Scripting Edition (VBScript) и JavaScript. Использование сценариев позволяет прямо из обозревателя автоматически выполнять на Web-странице определенный ряд задач. Например, можно написать сценарий выбора макета для сводной таблицы из стандартного набора наиболее полезных макетов и затем поместить на Web-странице кнопки макетов.

В некоторых программах-конструкторах предусмотрены средства для создания сценариев. В пакете программ Microsoft Office таким средством является редактор сценариев. Сведения о создании сценариев содержатся в справке программы-конструктора. Сведения о работе с функциями сводных таблиц с использованием сценариев см. справку по программированию для сводных таблиц.

Предоставление справочных сведений. Работая в обозревателе, пользователи могут получить справку из сводной таблицы. Эта справка достаточно информативна и может помочь пользователям разобраться в возможностях сводной таблицы, если только доступ к ней не будет ограничен. Она также позволяет получать подсказки в процессе работы со сводными таблицами и может дополняться конкретными инструкциями и сведениями, которые для этой цели следует заносить на Web-страницу. В качестве примера справочных сведений можно привести сообщение о базе данных, поддерживающей исходные данные, и адрес администратора, у которого можно узнать пароль, позволяющий войти в эту базу данных. См. Ввод описания сводных таблиц.

Возврат в начало

Шаг 8: Проверка и опубликование

Проверка сводной таблицы в обозревателе. Перед тем, как открыть доступ к сводной таблице, рекомендуется протестировать ее в Web-обозревателе. Для интерактивной работы со сводными таблицами необходимо иметь Microsoft Internet Explorer 5 и его более поздние версии. Если пользователи работают с различными версиями обозревателя, можно протестировать сводную таблицу в каждой из них, чтобы все пользователи выполнили в срок поставленные задачи. Перед занесением справочных сведений на Web-страницу необходимо проверять их на достоверность и качество работы. См. сведения о работе со сводными таблицами в различных обозревателях.

Внесение изменений. Если Web-страница вместе со сводной таблицей признаны неудовлетворительными, можно вернуться в программу-конструктор и внести необходимые изменения, которые достигаются переустановкой старых параметров сводной таблицы, заданных еще во время создания макета данных и настройки таблицы. О том, как это сделать, смотрите выше. Кроме того для улучшения структуры сводной таблицы можно выполнить следующие шаги:

  • Изменить макет сводной таблицы

  • Удалить лишние поля

Публикация Web-страницы. Проверенную Web-страницу можно сделать доступной пользователям. Сведения об опубликовании Web-страниц можно найти в справке программы-конструктора. В случае затруднений обращайтесь к Web-мастеру.

Возврат в начало


Что такое сводная таблица?

Сводная таблица — это интерактивная таблица, позволяющая просматривать в Web-обозревателе данные, хранящиеся в списках или базах данных, а также компоновать и анализировать эти данные, создавать по ним собственные итоги и отчеты. Однако изменять и удалять отображаемые в этой таблице данные невозможно. Она также не позволяет добавлять данные в списки и базы данных.

Пример: сводная таблица.

Эта простая сводная таблица отображает итоги, вычисленные по данным, хранящимся в базе данных.

Анализ данных

Создание исходной сводной таблицы. Для создания сводной таблицы необходимо выбрать для нее исходные данные из внешней базы данных или какого-либо другого источника. Они станут доступны пользователям, когда сводная таблица будет опубликована на Web-странице. Таблица компонует данные лишь одним из множества способов, как это видно из приведенного выше примера. Сводная таблица создается с помощью программы-конструктора, такой как Microsoft Excel 2000, Microsoft FrontPage 2000, конструктор страниц доступа к данным Microsoft Access 2000.

Анализ данных в обозревателе. Анализировать данные опубликованной на Web-странице сводной таблицы могут только пользователи, обозреватели которых поддерживают сводные таблицы. С помощью обозревателя или другой подходящей программы пользователи могут изменять исходную сводную таблицу по своему усмотрению, отображая в ней те или иные поля. Определенные программы-конструкторы и методы позволяют создавать сводные таблицы, для работы с которыми не требуется обозреватель.

Создание итогового отчета

Первый шаг: основной список. На следующих примерах показано, как записи, хранящиеся в базе данных или ином источнике, с помощью программы-конструктора или обозревателя преобразуются в итоговые отчеты. В простейшей сводной таблице исходные данные отображаются в виде столбцов с заголовками — именами полей. В следующем примере именами полей являются «Спорт», «Квартал» и «Продажи».

Пример: сводная таблица со всеми полями сведений.

Простейшая сводная таблица, отображающая записи базы данных в виде набора полей сведений.

Создание полей строк. Отчет создается путем перемещения полей в различные области с последующей сортировкой полей. Так можно подобрать необходимую структуру отчета. Если в сводной таблице, приведенном в предыдущем примере, поле «Спорт» переместить в область строк, а затем выполнить сортировку по полю «Квартал», то получится приведенный ниже отчет о продажах спортивных товаров в хронологическом порядке.

Пример: сводная таблица с полем строки.

Перемещение поля «Спорт» в область строк упорядочивает данные, отображая записи «Гольф» и «Теннис» не хаотически, а группами одна за другой.

Создание полей столбцов. Суммы продаж спортивных товаров по кварталам будет удобно сравнивать, если переместить поле «Квартал» в область столбцов, как показано в следующем примере.

Пример: сводная таблица с полем столбца.

Создание поля столбца придает сводной таблице вид перекрестной таблицы, с помощью которой удобно анализировать продажи спортивных товаров по кварталам.

Добавление итогов и скрытие сведений. Чтобы просматривать и анализировать итоговые, а не подробные данные о продажах, следует добавить поле итогов «Сумма: Продажи», а затем скрыть сведения для полей «Спорт» и «Квартал». Поле итогов позволяет суммировать значения. Например, в приведенной ниже сводной таблице в самой нижней крайней справа ячейке отображена сумма продаж группы товаров «Теннис» в четвертом квартале.

Пример: сводная таблица с итоговыми данными.

Добавление поля итогов позволяет подытожить данные о продажах.

Другие возможности анализа. Для создания отчета, приведенного в начале этого раздела, следует отобразить общие итоги для полей «Спорт» и «Квартал».

Провести более подробный анализ и поиск данных позволяет фильтрация полей. Например, можно отобразить в таблице только данные по товарам для тенниса, проданным в третьем квартале. Можно также добавить другие вычисления, например, отобразить максимальные суммы продаж для каждого типа товаров.

Дополнительные сведения

Возможности работы со сводной таблицей в обозревателе.

Создание и опубликование сводной таблицы на Web-странице.


Работа со сводной таблицей в обозревателе

Ниже описаны возможности, предусмотренные в Web-обозревателе Microsoft Internet Explorer для работы со сводной таблицей. Учет этих возможностей необходим при создании сводной таблицы для пользователей, которые будут просматривать ее в своих Web-обозревателях. См. сведения о сводных таблицах и создании сводной таблицы.

Далее представлены сведения по следующим темам:

Сравнение возможностей обозревателя и программы-конструктора

Средства обозревателя для работы со сводными таблицами

Возможности обозревателя

Ограничение возможностей пользователей

Терминология

Сравнение возможностей обозревателя и программы-конструктора

С помощью программы-конструктора и соответствующего Web-компонента можно создать сводную таблицу, которую пользователи смогут просматривать Web-обозревателями или иными подобными средствами просмотра. Одной из таких программ-конструкторов является конструктор страниц доступа к данным Microsoft Access 2000. См. сведения о программах-конструкторах.

Обсуждаемые далее возможности интерактивного просмотра доступны пользователям, у которых установлены Web-компоненты Microsoft Office 2000. Эти компоненты можно установить при установке Microsoft Office 2000. Пользователи, организации которых имеют лицензию на доступ к Web-узлу Office 2000, могут загрузить Web-компоненты Microsoft Office через корпоративную интрасеть. следует также использовать Web-обозреватель, полностью поддерживающий сводные таблицы. Иногда возникает необходимость создать сводные таблицы, которые должны просматриваться не Web-обозревателем, а иной программой, такой как форма Microsoft Visual Basic, являющейся частью пользовательского решения (форма, разработанная по заказу пользователя, либо им самим). В этом случае полезно обратиться к справке программы-конструктора, где содержатся сведения о том, как пользователи могут получить доступ к сводной таблице и интерактивно просматривать ее.

Возврат в начало

Средства обозревателя для работы со сводными таблицами

Для активизации списка таблицы и работы с ней в обозревателе используются те же панель инструментов и панель свойств, которые используются при создании макета данных. Но в обозревателе недоступны некоторые из возможностей программы-конструктора.

Пример: сводная таблица на Web-странице

Для интерактивного просмотра сводной таблицы в обозревателе служат панель инструментов и панель свойств сводной таблицы.

В обозревателе можно отобразить тот же список полей сводной таблицы, который используется в программе-конструкторе. В списке полей, который открывается с помощью панели инструментов списка сводной таблицы, перечислены все доступные поля с исходными данными.

Пример списка полей

В обозревателе пользователи могут просмотреть список всех доступных полей с данными, хранящимися в базе данных, на основе которой создан список сводной таблицы.

Возврат в начало

Возможности обозревателя

Пользователи могут просматривать и анализировать данные. В рамках ограничений, установленных создателем сводной таблицы, пользователи могут выполнять те же действия, что и в программе-конструкторе, а именно: добавлять поля из списка полей, изменять способ организации и отображения данных, анализировать их и подводить итоги.

Прежде чем публиковать результаты, желательно выполнить полный анализ данных в программе-конструкторе, а также учесть навыки и пожелания пользователей. Если результаты предназначены для обычных пользователей, то полезно опубликовать на Web-странице окончательные итоги в виде отдельных сводных таблиц. Опытным пользователям можно предоставить возможность самостоятельно анализировать данные в сводной таблице, разрешив доступ не только к итоговым, но и к исходным данным. См. создание итогов.

Возможности различных версий обозревателя. Чтобы в полной мере пользоваться всеми возможностями, предусмотренными при работе со сводными таблицами, пользователю необходим обозреватель Microsoft Internet Explorer версии 4.01 или более поздней. В обозревателе Microsoft Internet Explorer версии 4.0 некоторые из этих возможностей отсутствуют. Просматривать сводные таблицы с помощью других обозревателей невозможно. См. об уровнях поддержки сводных таблиц различными версиями обозревателей.

Доступ к исходной базе данных из обозревателя. При создании сводной таблицы указывается исходная база данных, а также подмножество данных, которые должны быть доступны в качестве исходных данных для создаваемой сводной таблицы. Создатель такого списка может также просматривать сведения о полях исходной базы данных.

В обозреватели пользователи могут просматривать лишь те данные, доступ к которым был открыт при создании сводной таблицы. Если для доступа к базе данных нужен пароль, то пользователи могут просматривать данные лишь после ввода пароля. Обозреватель не позволяет просматривать ни имя, ни тип исходной базы данных, ни сведения о ее полях. Он позволяет обновлять сводную таблицу после изменения исходных данных, но не позволяет изменять эти данные.

См. Исходные данные для сводных таблиц.

Справка, доступная в обозревателе. В обозревателе пользователи могут получить два вида справки: справку самого обозревателя и дополнительную справку, автоматически предоставляемую вместе со сводной таблицей. В этой дополнительной справке содержатся сведения о том, как пользоваться командами и средствами для работы со сводной таблицей в обозревателе. Для вызова этой справки следует открыть Web-страницу со сводной таблицей, затем щелкнуть кнопку Справка [image] на панели инструментов сводной таблицы. См. Ввод описания Web-диаграмм.

Возврат в начало

Ограничение возможностей пользователей в обозревателе

Работа пользователей со сводной таблицей в обозревателе упрощается, если количество параметров, которые они могут изменять, уменьшается. Это достигается, например, запретом просматривать подробные сведения. В некоторых случаях полезно также запретить пользователям изменять структуру итоговых данных, созданную в результате анализа данных в программе-конструкторе. Например, запретить перемещать поля строк и столбцов. См. Ограничение доступа в обозревателе.

Возврат в начало


Элементы сводной таблицы

Примеры сводной таблицы, показывающие ее элементы

Поля. Каждое поле соответствует столбцу данных и может выполнять групповую обработку нескольких строк данных. По своему типу поля могут быть полями строк, столбцов, а также полями данных и фильтра.

Элемент. Уникальный элемент данных внутри поля. Элементы данных полей строк располагаются в столбцах, а элементы данных полей столбцов — в строках. Ячейка, в которой пересекаются строка и столбец, отображает итоговые данные для элементов, указанных вверху столбца и слева от строки.

Если для элемента существуют дополнительные подробные сведения, которые могут быть отображены, перед элементом появляется индикатор развертывания Плюс .

Поле строки. Поле в области строк. В предыдущем примере, «Товар» и «Продавец» — это поля строк. Элементы в полях строк выводятся сверху вниз в левой части сводной таблицы. Внутренние поля строк, такие как «Продавец», расположены ближе к области данных; внешние поля, такие как «Товар», располагаются слева от внутренних полей.

Поле столбца. Поле в области столбцов. Элементы в полях столбцов выводятся в верхней части сводной таблицы над областью данных, строками слева направо. В приведенном примере в поле столбца «Квартал» имеется два элемента: Кв.2 и Кв.3. Внутренние поля столбцов располагаются ближе к области данных, а внешние поля столбцов располагаются над внутренними.

Поле фильтра. Поле расположенное в области фильтра, которое можно использовать для фильтрации всей сводной таблицы, чтобы отображались итоговые данные только для определенного элемента. В приведенном примере, «Регион» — это поле фильтра, которое можно использовать для отображения данных только для одного конкретного региона или для всех сразу. Поля фильтра выполняют ту же функцию, что и поля страниц в отчетах сводных таблиц Microsoft Excel и формах сводных таблиц Microsoft Access.

Область данных. Часть сводной таблицы, содержащая поля данных.

Поле данных. Поле, содержащее итоговые значения исходных данных. В рассматриваемом примере, поля «Продажи» являются полями данных, содержащими итоговые суммы продаж, причем каждое из значений этих полей данных — это сумма записей в поле «Продажи» или столбце исходных данных.

В полях данных обычно подытоживаются числовые данные, такие как статистики или число продаж, используя функцию групповой обработки СУММ (суммирование). В приведенном примере, ячейка со значением 30,984 отображает итоговую сумму, на которую Беловым продано молочных продуктов во втором квартале. Эта ячейка объединяет суммы продаж для всех записей исходных данных, имеющих значения: «Молоко» — для товара, «Белов» — для продавца и «Кв.1» — для квартала.

Базовые данные также могут быть текстовыми и обрабатываться по умолчанию функцией групповой обработки СЧЁТ, подсчитывающей число элементов. Например, поля данных, содержащие типы проданных продуктов, могут использоваться для подсчета числа продаж молока, выполненных Беловым во втором квартале. Сводная таблица также может подытоживать данные, используя функции групповой обработки МИН и МАКС, отображающие минимальное и максимальное значения соответственно.

Область сведений. Часть сводной таблицы (не показана на примере), которая может отображать все строки или записи исходных данных. Сводная таблица может отображать строки подробных данных и итоговые значения одновременно. Поля в области сведений принято называть полями сведений.

Стрелка раскрывающегося списка поля. Стрелка Стрелка поля по правую сторону от каждого из полей. Щелкните стрелку, чтобы вывести на экран раскрывающийся список, из которого можно выбрать, какие элементы необходимо отобразить, а какие скрыть.

В сводных таблицах, основанных на исходных данных OLAP, можно выбирать элементы на разных уровнях в поле измерений. Поля даты и времени обеспечивают разные уровни для всех типов исходных данных. Например, щелкнув стрелку раскрывающегося списка для поля «Год», можно отобразить следующее:

Раскрывающийся список для поля измерений OLAP.

Пример раскрывающегося списка для поля измерений OLAP.

На приведенном примере, снятый флажок рядом со значением 1998 показывает, что 1998 год скрыт. Затененный флажок рядом со значением 1999 показывает, что хотя 1999 год и выбран для отображения в данный момент, некоторые из относящихся к нему данных не показываются. Первый квартал (Кв.1)1999 года скрыт. Установленный флажок рядом со значением 2000 означает, что 2000 год выбран для показа. Установка флажка Показать все отображает все элементы на всех уровнях.


Вывод на экран содержания справки по программе-конструктору

При открытии раздела справки о сводной таблице, на вкладке Содержание в окне справки показаны только соответствующие разделы справки.

Чтобы открыть разделы справки по программе-конструктору:

  1. Выберите вкладку Мастер ответов в окне справки, введите какой-нибудь не относящийся к сводной таблице вопрос, затем нажмите Поиск.

  2. Выберите раздел справки по программе-конструктору и нажмите кнопку Вывести.

  3. Щелкните вкладку Содержание, чтобы увидеть содержание справки по программе-конструктору.


Вызов справки по написанию программ и сценариев для сводных таблиц

Для автоматизации сводных таблиц используются сценарии и программы. Можно также включать сводные таблицы в программы, не предназначенные для создания сводных таблиц (помимо Web-обозревателей), разработанные в таких средах программирования, как Microsoft Visual Basic.

Создание сценариев. В программы Microsoft Office 2000 включен редактор сценариев (Microsoft), полезный при создании сценариев. Например, редактор сценариев можно использовать из конструктора страниц доступа к данным Microsoft Access для настройки сводной таблицы. Сведения о редакторе сценариев содержатся в справках программ-конструкторов Microsoft Office. В редакторе сценариев также можно вызвать дополнительную справку о его возможностях работы со сценариями.

Справка по объектной модели. В справке по Web-компонентам Microsoft Office для Visual Basic содержатся сведения об объектной модели, свойствах и методах, используемых при разработке программ и сценариев для сводных таблиц. Такая справка по объектной модели устанавливается при установке Web-компонентов Microsoft Office, одним из которых являются сводные таблицы. В зависимости от используемой программы-конструктора, справка вызывается одним из двух способов:

  • Справка в Microsoft Visual Basic. В Visual Basic (или Visual Basic для приложений) можно создавать ссылки на библиотеку Web-компонентов Microsoft Office. При этом появляется возможность обращаться к справке с помощью обозревателя объектов, а также вызывать ее нажатием клавиши F1 после выбора ключевого слова. Сведения о создании ссылок и использовании справки по объектной модели содержатся в справке Visual Basic (Visual Basic для приложений).

  • Справка в других средах. Если используется другая среда разработки, найдите и дважды щелкните файл справки Msowcvba.chm.


Сочетания клавиш для сводных таблиц

За информацией о включении и выключении сводной таблицы с помощью клавиатуры, обратитесь к справке программы-конструктора.

Инструкции по использованию сочетаний клавиш.

Выделение элементов сводной таблицы.

Выполнение команд.

Отображение, скрытие, фильтрация и сортировка данных.

Добавление полей и итогов, изменение макета сводной таблицы.

Форматирование сводной таблицы.


Выделение элементов в сводной таблице с помощью сочетаний клавиш

Клавиши | Действия
Клавиша TAB | Выделение поля, затем — всей сводной таблицы, затем выделение следующего поля и т. д.
SHIFT+TAB | Выделение предыдущего поля или всей сводной таблицы.
Клавиши со стрелками | Переход в направлении стрелки. Если выделено поле строки или столбца, нажатие клавиши со стрелкой вниз выделяет первый элемент данных этого поля; затем с помощью клавиш со стрелками можно переходить к следующему или предыдущему элементу данных, а также обратно к полю. Если выделено поле сведений, либо выделен элемент данных, то с помощью стрелки вниз или стрелки вправо можно перейти к первой ячейке в области сведений или области данных.
SHIFT + клавиша со стрелкой | Расширение выделение в направлении стрелки. Расширение выделения возможно вниз и вправо.
SHIFT+PAGE DOWN | Расширение выделения вниз на один экран. Под экраном подразумевается та часть данных сводной таблицы, которая видна на экране.
SHIFT+PAGE UP | Сокращение выделения на один экран.
CTRL + пробел | Выделение поля, соответствующего выделенному элементу данных, итогу или ячейке подробных сведений.
SHIFT + пробел | Выделение всей строки, содержащей выделенную ячейку.
CTRL+A | Выделение всей сводной таблицы.
PAGE DOWN | Отображение следующего экрана. Под экраном подразумевается та часть данных сводной таблицы, которая видна на экране.
PAGE UP | Отображение предыдущего экрана.
ALT+PAGE DOWN | Сдвиг отображения на один экран вправо.
ALT+PAGE UP | Сдвиг отображения на один экран влево.


Выполнение команд в сводной таблице с помощью сочетаний клавиш

Клавиши | Действия
F1 | Выводит на экран разделы справки. Сведения о сочетаниях клавиш для работы в окне справки смотрите в справке программы-конструктора.
SHIFT+F10 | Вызывает контекстное меню для выделенного элемента сводной таблицы. В контекстном меню содержатся команды сводной таблицы.
Подчеркнутая буква. | Нажатие буквы, подчеркнутой в контекстном меню, вызывает выполнение соответствующей команды. Сведения, касающиеся панели свойств сводной таблицы, содержатся в пояснениях к сочетанию клавиш ALT+ENTER.
ESC | Закрывает контекстное меню, не выполняя команды.
CTRL+7 | Отображает или скрывает панель инструментов.
ALT+ENTER | Вызывает на экран панель свойств сводной таблицы. Для выполнения команд, а также для изменения свойств сводной таблицы с помощью этой панели, сочетаний клавиш не предусмотрено.
ALT+F4 | Закрывает панель свойств сводной таблицы.
F9 | Обновляет сводную таблицу с использованием текущих исходных данных.
ESC | Отменяет обновление, если оно еще не завершено.
CTRL+C | Копирует выделенные данные из сводной таблицы в буфер обмена.
CTRL+E | Выполняет экспорт сводной таблицы в Microsoft Excel.


Отображение, скрытие, фильтрация и сортировка данных в сводной таблице с помощью сочетаний клавиш

Клавиши | Действия
CTRL+8 | Отображает или скрывает индикаторы развертывания Плюс и Минус около элементов данных.
CTRL + знак «плюс» | Отображает подробные сведения для выделенного элемента данных.
CTRL + знак «минус» | Скрывает подробные сведения для выделенного элемента данных.
ALT + Стрелка вниз | Раскрывает список выделенного поля.
Клавиша TAB | Циклически перемещает выделение в раскрывающемся списке поля от выделенного элемента к кнопке OK, кнопке Отмена и т. д.
Клавиши со стрелками | Переход к следующему элементу в раскрывающемся списке поля.
ПРОБЕЛ | Устанавливает или снимает флажок для текущего элемента в раскрывающемся списке поля.
Знак «плюс» (цифровая клавиатура) | Отображает нижние уровни сведений (если они доступны) для текущего элемента в раскрывающемся списке поля.
Знак «минус» (цифровая клавиатура) | Скрывает нижние уровни сведений для текущего элемента в раскрывающемся списке поля.
ENTER | Закрывает раскрытый список поля и вводит в действия выполненные в нем изменения.
ESC | Закрывает раскрытый список поля с отменой выполненных в нем изменений.
CTRL+T | Включает и отключает фильтрацию.
CTRL+SHIFT+A | Сортирует данные выделенного поля или итога по возрастанию. Текст сортируется в алфавитном порядке.
CTRL+SHIFT+Z | Сортирует данные выделенного поля или итога по убыванию. Текст сортируется в порядке, обратном алфавитному.


Изменение формата сводной таблицы с помощью сочетаний клавиш

В следующей таблице первые семь сочетаний клавиш изменяют формат чисел выделенного элемента. См. сведения о форматах чисел.

Для применения следующих сочетаний клавиш вначале необходимо выделить поле сведений или ячейку поля итогов.

Клавиши | Действия
CTRL+SHIFT+~ (тильда) | Установка основного формата для значений в выделенном поле итогов или поле сведений.
CTRL+SHIFT+$ | Для значений в выделенном поле итогов или поле сведений устанавливается денежный формат с двумя десятичными знаками, причем отрицательные числа отображаются в скобках.
CTRL+SHIFT+% | Установка процентного формата без десятичных знаков для значений в выделенном поле итогов или поле сведений.
CTRL+SHIFT+^ | Установка экспоненциального формата с двумя десятичными знаками для значений в выделенном поле итогов или поле сведений.
CTRL+SHIFT+# | Для значений в выделенном поле итогов или поле сведений устанавливается формат даты, включающий в себя день недели, месяц и год.
CTRL+SHIFT+@ | Для значений в выделенном поле итогов или поле сведений устанавливается формат времени, включающий часы, минуты, AM или PM.
CTRL+SHIFT+! | Для значений в выделенном поле итогов или поле сведений устанавливается числовой формат с двумя десятичными знаками, разделителем разрядов, знаком минус для отрицательных значений.
CTRL+B | Для выбранного элемента сводной таблицы устанавливается полужирный шрифт.
CTRL+U | Для выбранного элемента сводной таблицы устанавливается подчеркнутый шрифт.
CTRL+I | Для выбранного элемента сводной таблицы устанавливается курсив.


Сочетания клавиш для добавления полей и итогов, изменения макета сводной таблицы

Содержание раздела:

Клавиши для рабты в диалоговом окне Список полей сводной таблицы.

Клавиши для добавления полей и итогов.

Клавиши для изменения макета.

Клавиши для рабты в диалоговом окне списка полей сводной таблицы

Клавиши | Действия
CTRL+L | Вывод на экран диалогового окна Список полей сводной таблицы, либо его активизация, если оно уже на экране.
Клавиши со стрелками | Переход к следующему элементу в списке полей.
Знак «плюс» (цифровая клавиатура) | Развертывание текущего элемента в списке полей и отображение его содержимого, либо развертывание Итогов и отображение доступных полей итогов.
Знак «минус» (цифровая клавиатура) | Свертывание текущего элемента в списке полей и скрытие его содержимого, либо свертывание Итогов и скрытие полей итогов.
Клавиша TAB | Последовательный переход к ранее выделенному элементу, кнопке Добавить в, списку, расположенному в окне списка полей справа от кнопки Добавить в.
ALT + Стрелка вниз | Раскрытие списка, расположенного справа от кнопки Добавить в в окне списка полей. Переходить от элемента к элементу в этом списке можно с помощью клавиш со стрелками. Нажатие клавиши ENTER выбирает выделенный элемент.
ENTER | Добавление поля, выделенного в списке полей, в ту область сводной таблицы, которая указана в списке Добавить в.
ALT+F4 | Закрывает список полей.

Возврат в начало.

Клавиши для добавления полей и итогов

Клавиши | Действия
CTRL+SHIFT+S | Добавление к полю сводной таблицы поля итогов с функцией итогов СУММ.
CTRL+SHIFT+C | Добавление к полю сводной таблицы поля итогов с функцией итогов СЧЁТ (Кол-во значений).
CTRL+SHIFT+M | Добавление к полю сводной таблицы поля итогов с функцией итогов МИН (Минимум).
CTRL+SHIFT+X | Добавление к полю сводной таблицы поля итогов с функцией итогов МАКС (максимум).
CTRL+SHIFT+B | Включение и отключение промежуточных итогов для выделенного поля сводной таблицы.

Возврат в начало.

Клавиши для изменения макета

Клавиши | Действия
CTRL+1 | Перемещение поля, выделенного в списке полей, в область строк.
CTRL+2 | Перемещение поля, выделенного в списке полей, в область столбцов.
CTRL+3 | Перемещение поля, выделенного в списке полей, в область фильтров.
CTRL+4 | Перемещение поля, выделенного в списке полей, в область сведений.
CTRL + Стрелка влево | Перемещение поля строк или столбцов на более высокий уровень в списке полей.
CTRL + Стрелка вправо | Перемещение поля строк или столбцов на более низкий уровень в списке полей.

Возврат в начало.


Использование сводной таблицы

Web-компоненты Microsoft Office снабжены инструментарием, с помощью которого можно создавать интерактивные сводные таблицы, электронные таблицы и диаграммы на Web-страницах. Каждый из компонентов имеет свои особенности и возможности, служащие определенным целям. В этом разделе содержится несколько рекомендаций, которые помогают определить, когда оптимальным выбором для выполнения предполагаемых задач пользователей Web-страницы, будут сводная таблица, электронная таблица или диаграмма.

Случаи, в которых следует применять сводные таблицы

Отображение информации из отдельной базы данных. Используйте сводную таблицу, если необходимо создать форму для интерактивного доступа и анализа пользователем обозревателя записей из базы данных, такой как Microsoft Access или Microsoft SQL Server, а также для доступ к данным OLAP в базе данных Microsoft SQL Server OLAP Services.

Просмотр и анализ данных без обновления. Пользователи сводной таблицы никак не могут обновить или изменить данные в обозревателе. Используйте сводную таблицу, если требуется только просмотреть и проанализировать существующие данные, а у пользователей нет необходимости вносить в них какие-либо изменения для выполнения собственных вычислений. Например, в Microsoft Access, сводная таблица необходима для публикации на Web-странице данных из перекрестных таблиц.

Примеры. Здесь приведены несколько примеров правильного использования сводных таблиц:

  • Обеспечение доступа к базе данных о продажах товаров пользователей, которым необходимо сравнивать данные о продажах по различным продуктам и регионам.

  • Публикация показателей курсов акций из часто обновляемой базы данных, чтобы пользователи могли просматривать и сравнивать характеристики интересующих их ценных бумаг.

  • Создание каталога продуктов, позволяющем пользователям самим выбирать продукты, для которых необходимо просматривать цены, наличие и транспортные затраты.

Случаи, в которых необходимо использовать другие элементы управления

Если необходимо выполнять ввод и вычисления данных. В случаях, когда пользователям требуется вносить изменения в данные или вводить формулы для вычисления значений, вместо сводных таблиц на Web-странице следует использовать интерактивные электронные таблицы. Например, выполненный в виде электронной таблицы подсчет выплат по займам, в котором пользователи смогут сами вводить суммы финансирования и изменять вычисления процентных ставок, будет более функционален, чем сводная таблица. В тоже время, в отличии от сводных таблиц, из электронных таблиц невозможен доступ к данным из внешних источников.

Если требуется обновлять записи в базе данных. Если на Web-странице необходим элемент управления, который можно будет использовать для доступа и обновления записей базы данных, посмотрите поддерживаются ли такие элементы программой-конструктором. Обратитесь к справке программы-конструктора за дополнительными сведениями. Например, Microsoft Access, имеет элементы управления базами данных в составе конструктора страниц доступа к данным, которые можно использовать для задач, связанных с вводом данных.

Если нет необходимости в интерактивном взаимодействии с данными. Если пользователи будут только просматривать данные, никак не взаимодействуя с ними, наиболее простым способом для отображения таких статичных данных может быть неинтерактивная таблица. За информацией о других способах публикации данных на Web-странице, обратитесь к справке программы-конструктора Web-страниц.

Дополнительные сведения

Что такое сводная таблица?

Возможности работы со сводной таблицей в обозревателе.

Поддержка сводных таблиц различными версиями обозревателя.


Поддержка сводных таблиц различными версиями обозревателя

Для просмотра сводных таблиц и работы с ними у пользователей должны быть установлены Web-компоненты Microsoft Office. Это можно выполнить при установке Microsoft Office 2000. Если у организации имеется лицензия на работу с Web-узлом Microsoft Office 2000, то Web-компоненты можно загрузить через корпоративную интрасеть.

Не все Web-обозреватели предоставляют полный набор возможностей работы со сводными таблицами, опубликованными на Web-страницах. К числу таких возможностей относится интерактивная работа с данными, содержащимися в сводных таблицах.

Обозреватель Microsoft Internet Explorer 5 или более поздней версии. Этот обозреватель обеспечивает все доступные для обозревателя возможности. Выполненные пользователем изменения в сводной таблице, например изменение форматов или макета таблицы, при завершении работы с этой таблицей сохраняются в течение сеанса работы в обозревателе. Это означает, что при возвращении к сводной таблице остаются в силе все выполненные в ней изменения.

Microsoft Internet Explorer версий 4.01, 4.1x и 4.2x. Эти версии обозревателя обеспечивают все доступные для обозревателя возможности работы со сводными таблицами. Выполненные пользователем изменения сохраняются при завершении работы со сводной таблицей и возвращении к ней в течение сеанса работы в обозревателе. В некоторых случаях для просмотра на Web-страницах сводных таблиц, созданных с помощью конструктора страниц доступа к данным Microsoft Access 2000, необходим Internet Explorer 5.

Microsoft Internet Explorer 4.0. Эта версия обозревателя обеспечивает те возможности работы со сводной таблицей, которые доступны из панели инструментов сводной таблицы и контекстных меню, вызываемых нажатием правой кнопки мыши. Не обеспечиваются возможности, доступные из панели свойств сводной таблицы. Выполненные пользователем изменения не сохраняются при завершении работы со сводной таблицей. В некоторых случаях для просмотра на Web-страницах сводных таблиц, созданных с помощью конструктора страниц доступа к данным Microsoft Access 2000, необходим Internet Explorer 5.

Другие обозреватели. В более ранних версиях Microsoft Internet Explorer и других обозревателях просмотр сводных таблиц невозможен. На Web-странице сводная таблица выглядит как очерченный границей прямоугольник, либо вообще не видна.


Выбор программы-конструктора для сводной таблицы

Сводная таблица — это компонент, проектируемый и создаваемый в программе-конструкторе, для использования в других программах, программах конечного пользователя. Сводные таблицы изначально предназначены для просмотра в Web-обозревателе Microsoft Internet Explorer. См. Поддержка различных обозревателей.

Поддерживаемые программы-конструкторы. Для создания сводных таблиц рекомендуется использовать следующие программы-конструкторы: Microsoft Excel, Microsoft FrontPage 2000, Microsoft Access 2000 и среду программирования Microsoft Visual Basic. В любой из этих программ-конструкторов можно писать Web-сценарии, автоматизирующие создание сводных таблиц. Microsoft Word не подходит в качестве программы-конструктора для создания сводных таблиц.

Работа в нескольких программах-конструкторах. В зависимости от содержимого Web-страницы и задач, которые будут выполняться пользователями с помощью сводной таблицы, предпочтительнее использовать при разработке те или иные программы. Можно начать создание Web-страницы, добавив компоненты, в том числе сводные таблицы, в одной программе-конструкторе, а затем открыть ее для продолжения работы в другой программе.

Например, если отчет сводной таблицы был подготовлен в Microsoft Excel, можно, используя Excel, сохранить или опубликовать этот отчет как сводную таблицу для Web-страницы. (Отчет сводной таблицы является аналогом сводной таблицы в Excel.) При необходимости настроить создаваемую сводную таблицу, чтобы изменить параметры заданные по умолчанию, а также если требуется добавить к странице другие элементы управления, можно открыть и изменить данную Web-страницу в FrontPage 2000.

Microsoft Excel. В случае, если необходимо попробовать различные макеты и настроить исходные данные, которые будут доступны для сводной таблицы, Excel является превосходной средой разработки. Можно использовать инструментарий Excel, такой как Microsoft Query, для доступа к внешним данным и создания отчета сводной таблицы Excel. Из Excel, отчеты сводных таблиц сохраняются или публикуются как сводные таблицы для Web-страниц. Исходные данные, указанные в Excel, будут автоматически присоединены к сводной таблице, а большинство функциональных возможностей отчета сводной таблицы Excel после публикации сохранятся. См. Возможности Excel, не сохраняемые при публикации сводной таблицы.

При необходимости можно отформатировать сводную таблицу, настроить ее размеры и внешний вид в другой программе-конструкторе. Если кто-либо из пользователей данной страницы использует Internet Explorer версии 4.x, лучше для изменения сводной таблицы, опубликованной из Excel, использовать FrontPage 2000. Поскольку Excel публикует сводные таблицы в формате, поддерживаемом Internet Explorer 4.x, а FrontPage 2000 поддерживает этот формат. Однако, при изменении Web-страницы, опубликованной из Excel, в Microsoft Access с использованием конструктора страницы доступа к данным, пользователям может понадобиться установить Internet Explorer 5 в дополнение к Internet Explorer 4.x прежде чем они смогут работать с этой Web-страницей.

Microsoft FrontPage 2000. FrontPage — рекомендуемая программа-конструктор, которая создает сводные таблицы для пользователей, имеющих Internet Explorer версии 4.x, а также для изменения сводных таблиц, сохраненных и опубликованных из Excel. С помощью FrontPage можно создавать сводные таблицы для Web-страниц (выберите пункт Компонент в меню Вставка, а затем щелкните Сводная таблица Office), изменять сводные таблицы, созданные другими программами, а затем использовать функциональные возможности FrontPage для создания Web-узла и управления им.

Microsoft FrontPage 2000 содержится в Microsoft Office 2000 Premium.

Конструктор страниц доступа к данным Microsoft Access. Access обеспечивает специальные возможности по созданию Web-страниц, которые обрабатывают и отображают данные из баз данных Microsoft Access и Microsoft SQL Server. Например, можно использовать команду Список полей (в меню Вид), чтобы обозначить данные и включить их в сводную таблицу. Есть возможность устанавливать связи между сводными таблицами и другими управляющими элементами, отображающими и обрабатывающими содержимое баз данных на Web-страницах. Если страница содержит какие-либо данные помимо сводной таблицы или другие управляющие Web-компоненты Microsoft Office, для работы с этой страницей пользователям необходимо иметь Internet Explorer 5 или более поздней версии.

Microsoft Access содержится в Microsoft Office 2000 Professional и Microsoft Office 2000 Premium.

Visual Basic. Если необходимо иметь более совершенную среду программирования, чем та, что обеспечивает возможность написания сценариев в Excel, FrontPage и Access, при разработке сводных таблиц можно применять систему разработки Microsoft Visual Basic. Используйте Visual Basic, когда необходимо включить сводную таблицу в какое-либо из пользовательских решений. При этом пользователи смогут просматривать и взаимодействовать со сводными таблицами, созданными формами Visual Basic, внутри своих программ. В отличии от обозревателя, эти формы являются готовыми выполняемыми приложениями и с их помощью пользовательская программа сможет обеспечить большинство возможностей сводных таблиц.

Получение дополнительных сведений по разработке. Смотрите справку программы-конструктора, которую планируете использовать, чтобы определить поддерживает ли она разработку сводных таблиц и какие операции этой программы используются для их создания и изменения.


Создание сводной таблицы

Конкретные шаги при создании сводной таблицы зависят от программы, используемой для конструирования Web-страницы. Например, в Microsoft Access предусмотрена возможность автоматического добавления данных в сводную таблицу. За дополнительными сведениями обратитесь к справке программы-конструктора. Если в справке программы-конструктора нет сведений о создании таких элементов управления как сводная таблица, выполните следующее:

  1. С помощью программы-конструктора откройте или создайте Web-страницу, на которой предполагается разместить сводную таблицу.

  2. Используя предусмотренную в программе-конструкторе процедуру добавления управляющего элемента на Web-страницу, выберите элемент управление сводной таблицей и отметьте на Web-странице положение и исходный размер сводной таблицы.

  3. Добавьте в сводную таблицу исходные данные.

Примечание. После создания сводной таблицы можно изменить ее размер и другие параметры. См. сведения о конструировании сводной таблицы.


Изменение размеров сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы. Если данные в сводную таблицу еще не добавлены, щелкните сводную таблицу.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  5. Варианты действий:

    Чтобы размеры области Web-страницы, предназначенной для сводной таблицы, изменялись автоматически так, чтобы вместить все отображаемые данные, установите флажок Автоподбор. Если для размеров таблицы необходимо установить пределы, введите числа (количества пикселов) в поля Максимальная высота и Максимальная ширина.

    Если размеры сводной таблицы должны быть фиксированными, снимите флажок Автоподбор, затем введите высоту и ширину таблицы (в пикселах) в поля Высота и Ширина.

Примечания

  • Изменить эти параметры в обозревателе невозможно.

  • Если размеры сводной таблицы зафиксированы, либо на них наложены ограничения, и эти размеры не вмещают всех данных, появляются полосы прокрутки.

  • Размеры области сведений устанавливаются независимо от размеров сводной таблицы.


Исходные данные для сводных таблиц

Сводная таблица — это средство переноса данных из внешних источников на Web-страницу для отображения и анализа. При проектировании сводной таблицы задаются используемые элементом управления исходные данные, которые будут доступны из обозревателя, а также определяется подключение к этим исходным данным. После этого пользователи обозревателя получают возможность обновления сводной таблицы для отображения изменений в исходных данных.

Конструктор страниц доступа к данным Microsoft Access 2000 обеспечивает набор команд и функциональных возможностей для подготовки данных к использованию в сводных таблицах. Чтобы получить сведения о методах и процедурах, используемых в Access для работы с данными на страницах доступа к данным, смотрите справку Access. См. Программы, пригодные для создания сводных таблиц.

Этот раздел применим ко всем программам-конструкторам сводных таблиц и содержит следующие сведения:

Типы исходных данных.

Подключение к исходным данным.

Обновление при изменении исходных данных.

Типы исходных данных

Сводные таблицы могут отображать данные из источников трех типов: реляционных баз данных, листов Microsoft Excel и баз данных для интерактивного анализа (OLAP-базы данных).

Реляционные базы данных. Сводная таблица может отображать и подытоживать данные, содержащиеся в реляционной базе данных, такой как Microsoft Access или Microsoft SQL Server. Если исходные данные берутся из реляционной базы данных, можно создавать новые поля итогов в сводной таблице, отображать подробные сведения для элементов в полях, а также перемещать поля в область сведений.

Данные листов Microsoft Excel. При создании отчета сводной таблицы Excel, основанного на данных из листов Excel, а затем сохранении этого отчета как сводной таблицы на Web-странице, эти данные преобразуются в отдельный HTML-файл в назначенной для Web-страницы папке. Если исходные данные — листы Microsoft Excel, есть возможность создавать новые поля итогов в сводной таблице, отображать подробные сведения для элементов в полях, а также перемещать поля в область сведений.

Чтобы получить сведения о публикации отчетов сводных таблиц Excel на Web-страницах, обратитесь к справке Excel. См. Работа со сводными таблицами, опубликованными из Microsoft Excel.

Базы данных OLAP. Технология OLAP — особый подход к работе серверов баз данных, организующий большие объемы данных таким образом, что они становятся доступны и понятны пользователям, которым необходимо анализировать тенденции и результаты в своих предметных областях. OLAP-данные хранятся в структурах, называемых кубами и упорядочиваются внутри этих кубов по уровням детализации. Множества уровней, такие как страна, регион, город и сведения об узлах, называются измерениями и могут быть использованы в качестве набора полей для сводной таблицы. В зависимости от используемого OLAP-сервера и клиентского программного обеспечения, кубом OLAP может быть серверная база данных, а также извлекаемый из нее файл куба или же куб, созданный в оперативной памяти на основе записей реляционной базы данных.

В сводных таблицах, имеющих в качестве исходных данных базы данных OLAP, поля измерений (также называемые наборами полей) могут отображать различные уровни сведений. Если исходные данные являются базой данных OLAP, нельзя создавать произвольных полей итогов, нельзя перемещать поля в область сведений, невозможно отображать подробные сведения. Между тем, базы данных OLAP снабжены собственным инструментарием для создания итоговых данных и вычислений. Благодаря тому что выполняется предварительная групповая обработка, вместо того, чтобы выводить большие объемы подробных сведений и подводить итоги в сводной таблице пользователя, базы данных OLAP позволяют анализировать в сводной таблице большие объемы данных, чем это было бы возможно с другим источником данных.

Для получения дополнительных сведений о создании вычисляемых полей в кубе или базе данных OLAP, которые затем могут быть отображены в сводной таблице, обратитесь к администратору базы данных OLAP, или загляните в справку по OLAP-инструментарию Microsoft Office (например, мастеру куба OLAP или мастеру автономного куба, которые поставляются вместе с Microsoft Excel).

Возврат в начало

Подключение к исходным данным

Если в качестве программы-конструктора используется конструктор страниц доступа к данным Microsoft Access 2000, для подготовки данных и установки соединения можно использовать методы и команды Access. За дополнительными сведениями и методиками обращайтесь к справке Access.

Настройка источника данных. Чтобы пользоваться внешним источником данных из программы-конструктора, он должен быть установлен на уровне системы. Источник данных — это именованный набор хранимых сведений, требуемый для подключения программы-конструктора к внешней базе данных и извлечении из нее данных. Для установки источника данных, необходимо иметь программу-драйвер, соответствующую данному типу исходных данных. Microsoft Office поставляется с набором драйверов для наиболее распространенных типов баз данных. Дополнительные драйверы также могут быть найдены в программе-конструкторе, а кроме того их можно получить от большинства поставщиков баз данных.

Если в программе-конструкторе требуется работать и с OLAP, и с реляционной базами данных, необходимо установить источники данных для обоих типов. Средство для установки источников данных может обеспечиваться программой-конструктором, а также для выполнения этой настройки можно использовать инструментарий Microsoft Office или Windows.

Можно использовать команду 32bit ODBC на панели управления Windows для установки нескольких драйверов, поставляемых с Microsoft Office. Например, чтобы установить драйвер Microsoft SQL Server, щелкните Добавить на вкладке DSN пользователя (DSN означает имя источника данных), дважды щелкните SQL Server, а затем следуйте инструкциям, указав имена источников данных и обеспечив сведения для подключения к базе данных. Также можно установить источник данных при добавлении данных к сводной таблице.

Для настройки источников данных, в том числе баз данных OLAP, можно также использовать Microsoft Query (компонент Microsoft Office). За дополнительной информацией о настройке источников данных, обратитесь к справке программы-конструктора или драйвера источника данных.

Создание запроса для выборки данных. Для исходных данных из реляционных баз данных, после настройки источника необходимо создать запрос, либо написать на языке SQL оператор SELECT или процедуру, для определения и выборки необходимых групп записей. Дополнительную информацию по выполнению этой операции, смотрите в справке программы-конструктора и документации к базе данных. Например, Microsoft Access имеет инструментарий как для создания запросов, так и для создания групп записей, доступных в списке полей Access (к ним можно обращаться из меню Вид Access) без создания запроса. Затем этот список полей можно использовать для выбора данных, используемых в сводных таблицах. Также с помощью Microsoft Query можно создавать запросы к данным в различных поддерживаемых базах данных.

Источники данных куба OLAP. Чтобы использовать данные OLAP, необходимы серверная база данных OLAP, а также файл или определение куба. В настройке запроса для доступа к данным куба нет необходимости, требуется установить только драйвер и источник данных. Дополнительные сведения смотрите в документации производителя программного обеспечения OLAP или в справках к Microsoft Excel, Microsoft Query или Microsoft Access, где описана работа с базами данных OLAP.

Добавление данных к сводной таблице. При добавлении данных к незаполненной сводной таблице, устанавливается соединение между ней и источником данных. Вместе с добавленными данными сводной таблице передаются все сведения, которые необходимы для установления соединения и выборки данных при каждом ее открытии пользователями обозревателя.

Программа-конструктор может иметь инструментарий, помогающий настраивать такие соединения. Например, если используется конструктор страниц доступа к данным Microsoft Access 2000, можно выбрать и перетащить данные в сводную таблицу, таким образом автоматически добавив их к этому элементу управления. Дополнительные инструкции о настройке соединения из программы-конструктора, смотрите в справке к ней.

Если программа-конструктор не имеет инструментария или инструкций по установке соединения, можно создать строку соединения для источника данных, используя панель свойств сводной таблицы. За сведениями о синтаксисе этой строки соединения обращайтесь к справке используемого для источника данных драйвера и справке по программированию сводных таблиц.

Инструкция по применению панели свойств сводной таблицы для добавления данных к сводной таблице.

Влияние драйверов и источников данных на пользователей Web-страницы. Пользователи, которым необходимо взаимодействовать со сводной таблицей из обозревателя, должны установить ODBC-драйвер или определенный для исходной базы данных драйвер источника данных, прежде чем обращаться к сводной таблице. Это применимо ко всем источникам данных, за исключением данных из листов Excel. Если для используемой исходной базы данных драйвер установлен не как часть Microsoft Office, убедитесь в том, что пользователи этой сводной таблицы имеют доступ к драйверу.

Вместе с тем, пользователям обозревателя нет необходимости настраивать источники данных для внешней базы данных. При добавлении данных к сводной таблице в программе-конструкторе, необходимые обозревателю сведения о соединении с базой данных добавляются к сводной таблице и сохраняются на Web-странице. Должен ли пользователь вводить идентификатор сеанса и пароль для доступа ко внешней базе данных, зависит от того, как был настроен используемый источник данных при разработке этой сводной таблицы.

Возврат в начало

Обновление при изменении исходных данных

После подключения к базе данных, если необходимо отобразить обновления или изменения сделанные в исходных данных, можно выполнить обновление сводной таблицы.

Реляционные базы данных. Если исходные данные взяты из реляционных баз данных, для обновления требуется выполнить запрос к этим исходным базам данных, при этом будут выбираться как обновленные, так и вновь добавленные данные, отвечающие указанным условиям. Если необходимо, чтобы запрос, оператор SELECT или хранимая процедура выбирали различные группы записей или полей из базы данных, за сведениями о внесении изменений обратитесь к документации для базы данных или программы, используемой при создании запроса.

Базы данных OLAP. Для исходных данных OLAP, обновления выполняются с сервера или из файла куба всякий раз, когда в сводную таблицу вносятся изменения, влияющие на отображение данных. Например, если в область строк добавляется новое поле, итоговые значения будут выбраны уже для новых отображаемых элементов данных. При работе с файлом куба OLAP, обратитесь к документации программы, использованной для его создания, чтобы получить сведения о том, как выполнять обновление файла при изменении данных в исходной базе данных на сервере.

Данные листов Microsoft Excel. Если требуется опубликовать отчет сводной таблицы Excel, лучше всего вначале сохранить копию книги Excel, а затем опубликовать отчет сводной таблицы как сводную таблицу на Web-странице. Если необходимо выполнить обновление опубликованной из Excel сводной таблицы, чтобы отобразить новые или измененные данные исходной книги Excel, либо чтобы выбрать для сводной таблицы другую группу данных Excel, можно изменить исходный отчет сводной таблицы Excel, а затем вновь опубликовать его как сводную таблицу. Для получения инструкций, обратитесь к справке Excel.

Метод обновления данных в обозревателе. В обозревателе, данные выбираются при первом отображении пользователем сводной таблицы. Если пользователь переходит на другую Web-страницу, а затем возвращается к странице со сводной таблицей, внесенные им в сводную таблицу изменения сохраняются, но сама страница не перезагружается с Web-сервера и данные на ней не обновляются. Пользователь может обновить данные, щелкнув кнопку Обновить [image] , а также в процессе выполнения может отменить это обновление, нажатием клавиши ESC.

Возврат в начало


Добавление данных в сводную таблицу

В программах-конструкторах, как правило, предусмотрены удобные средства для добавления данных в сводную таблицу. Например, в конструкторе страниц доступа к данным Microsoft Access 2000 можно просто перетащить данные мышью в сводную таблицу. О том, как пользоваться конструктором страниц доступа к данным, смотрите в справке Access. Процедура, описанная в этом разделе, в этом случае не используется.

Если в программе-конструкторе не предусмотрены средства добавления данных, воспользуйтесь описанной далее процедурой. За дополнительной информацией обратитесь к справке используемой вами программы-конструктора.

Прежде чем добавлять данные в сводную таблицу, необходимо установить драйвер ODBC, либо драйвер источника данных (программное обеспечение OLE-DB или OLAP), а затем указать параметры источника данных для соединения с базой данных. См. сведения об источниках данных.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните сводную таблицу. Если данные в сводную таблицу уже добавлены, щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Источник данных не развернут, щелкните панель Источник данных.

  5. В блоке Средство получения данных выполните одно из следующего:

    Если на Web-странцу добавлен элемент управления источником данных, обеспечивающий доступ к исходным данным, щелкните кнопку Элемент управления источником данных, затем выберите в списке элемент управления. Элементы управления источниками данных — средства Microsoft Access. Сведения о создании элементов управления источниками данных и работе с ними содержатся в справке Access.

    Если Web-страница не имеет элемента управления источником данных, а также при необходимости подключиться к другому источнику данных, щелкните кнопку Подключение, затем — кнопку Редактор подключений. В диалоговом окне свойств источника данных введите сведения об источнике данных, необходимые для подключения к базе данных. Подробности о параметрах подключения содержатся в справке драйвера ODBC или драйвера выбранного источника данных, а также в справке программы-конструктора о работе с источниками данных. См. Исходные данные для сводных таблиц.

  6. В разделе Использовать данные из выполните одно из следующего:

    Если необходимо использовать данные, хранящиеся в конкретном элементе базы данных, таком как существующая таблица или запрос, щелкните кнопку Компонент данных и выберите из списка нужный элемент.

    Если для извлечения данных требуется ввести запрос или команду, например команду языка SQL, щелкните кнопку Текст команды, затем введите в соответствующее поле запрос или команду. Сведения о запросах и синтаксисе команд содержатся в документации по базе данных.

Примечание. Изменить эти параметры в обозревателе невозможно.


Ограничение доступа к сводной таблице в обозревателе

Некоторые возможности сводной таблицы доступны только при работе в программе-конструкторе, другие — могут быть изменены пользователями сводной таблицы в обозревателе. И если возникает необходимость запретить внесение этих изменений, есть возможность ограничить доступ пользователей к некоторым из оперативных возможностей обозревателя.

Возможность доступа зависит от версии обозревателя. Могут пользователи или нет вносить оперативные изменения в сводную таблицу, зависит и от того, какие обозреватели они используют.

Недоступные в обозревателе возможности. В обозревателе пользователи не могут использовать следующие возможности сводных таблиц, доступные только при работе в программе-конструкторе:

  • Изменение размера сводной таблицы.

  • Изменение размера области сведений.

  • Добавление исходных данных к сводной таблице.

  • Автоматическое отображение подробных сведений для всех элементов.

  • Форматирование строки названия.

  • Форматирование или изменение подписей областей.

  • Отображение сводной таблицы справа налево.

  • Отображение сведений о полях и исходных данных.

Возможности, обычно доступные в обозревателе. Если используемый обозреватель полностью поддерживает работу со сводными таблицами, пользователи могут сделать в обозревателе большую часть тех изменений, что и создатель сводной таблицы в программе-конструкторе. См. Работа со сводной таблицей в обозревателе.

Настраиваемые ограничения. Чтобы запретить пользователям вносить изменения в сводную таблицу или ограничить их доступ к определенным фрагментам исходных данных, которые необходимо скрыть, можно использовать следующие ограничения:

  • Сделать панель свойств сводной таблицы недоступной.

  • Запретить перемещение и добавление полей строк и столбцов.

  • Запретить отображение подробных сведений.

  • Запретить изменение фильтров пользователями.


Ввод описания сводных таблиц

Из сводной таблицы, просматриваемой в обозревателе, доступна справка о свойствах сводных таблиц, а также о возможностях работы с такими таблицами. В некоторых случаях, например, когда сводная таблица создается в расчете на неопытных пользователей, полезно снабдить ее дополнительными инструкциями.

Справка обозревателя. Справка обозревателя по сводным таблицам автоматически доступна пользователям, у которых установлены Microsoft Internet Explorer версии 4.01 или более поздней версии и Web-компоненты Microsoft Office. Справка, доступная во время работы со сводной таблицей, отличается от справки, доступной из меню обозревателя Справка.

В разделах справки, доступных всем пользователям при просмотре сводной таблицы в обозревателе, содержатся общие сведения о работе со сводными таблицами в обозревателе. Эти разделы справки отличаются от настоящих разделов справки, доступных в режиме конструктора сводной таблицы. Другие элементы управления Web-компонентами Microsoft Office, такие как элементы управления электронными таблицами, также имеют собственные отдельные справки, доступные из обозревателя.

Для просмотра справки, доступной из обозревателя, создайте на Web-странице сводную таблицу, откройте эту Web-страницу в обозревателе Internet Explorer, щелкните сводную таблицу, затем на ее панели инструментов щелкните кнопку Справка [image]. В окне справки можно просмотреть ее содержание и выбрать нужный раздел. Помощника, отвечающего на вопросы, в обозревателе нет.

Эта справка недоступна пользователям, у которых не установлены Web-компоненты Microsoft Office и обозреватель Internet Explorer версии 4.01 или более поздней. См. сведения о работе со сводными таблицами в различных обозревателях.

Ввод описания сводных таблиц. Если необходимо предоставить пользователям дополнительные сведения об исходных данных сводной таблицы, а также в случае, если сводная таблица предназначена для просмотра в обозревателе Internet Explorer 4.0, дополнительные сведения следует разместить на Web-странице. Поскольку эту дополнительную справку нельзя встроить в интерактивную справку, доступную из панели инструментов сводной таблицы, текст дополнительной справки следует разместить либо на той же Web-странице, где находится сводная таблица, либо на отдельной Web-странице, указав к ней путь гиперссылкой. Сведения о том, как размещать текст на Web-страницах различных типов, содержатся в справке программы-конструктора Web-страниц.


Работа со сводными таблицами, опубликованными из Microsoft Excel

Некоторые возможности отчетов сводных таблиц Microsoft Excel теряются при сохранении или публикации этих отчетов как сводных таблиц для Web-страниц. В результате, может потребоваться использование другой программы-конструктора для внесения дополнительных изменений после публикации. Важным критерием при выборе программы-конструктора при разработке Web-страницы является знание того, какой обозреватель наиболее вероятно будет установлен у пользователей. См. Выбор программы-конструктора.

Следующие возможности отчета сводной таблицы подвергаются изменению при его публикации как сводной таблицы для Web-страниц:

Вычисления.

Форматирование.

Макет.

Параметры вывода на экран.

Исходные данные и параметры обновления.

Вычисления.

Следующие возможности вычислений изменяются или теряются при публикации или сохранении отчета сводной таблицы Excel как сводной таблицы для Web-страниц:

Вычисляемые поля. Не сохраняются. Сводные таблицы не поддерживают вычисляемые поля Excel. Любое такое поле отображается в сводной таблице как поле итогов, по умолчанию используяя для него функцию суммирования. Формулы вычисляемых полей также не сохраняются.

Вычисляемые элементы. Не сохраняются. Сводные таблицы не поддерживают вычисляемых элементов.

Функции групповой обработки. Сохраняются только функции суммирования (СУММ), подсчета количества значений (СЧЁТ), а также минимума (МИН) и максимума (МАКС). Поля данных Excel, обрабатываемые другими функциями групповой обработки, будут утеряны. Поля без групповой обработки доступны в списке полей сводной таблицы, их можно использовать в программе-конструкторе для добавления полей итогов, основанных на одной из поддерживаемых функций групповой обработки.

Произвольные вычисления. Не сохраняются. Сводные таблицы не поддерживают произвольных вычислений. Любые поля Excel, имеющие произвольные вычисления, при публикации не сохраняются. Исходные поля, используемые как поля данных, доступны в списке полей сводной таблицы, их можно обрабатывать в программе-конструкторе для добавления полей итогов, основанных на одной из поддерживаемых функций групповой обработки.

Произвольные итоги. Не сохраняются. В сводной таблице, итоги и общие итоги всегда используют одни и те же функции групповой обработки, что и поля итогов. При изменении в Excel таких функций групповой обработки для итогов или общих итогов, они преобразуются в функции групповой обработки полей итогов в опубликованной сводной таблице.

Звездочки, отмечающие итоги. Звездочки всегда появляются рядом с итогами и общими итогами в сводных таблицах, основанных на исходных данных из баз данных OLAP, даже если они были выключены в отчетах сводных таблиц. Вычисления итогов и общих итогов в сводных таблицах могут включать или исключать любые элементы данных, скрытые фильтрацией.

Возврат в начало

Форматирование

Следующие возможности форматирования изменяются или теряются при публикации или сохранении отчета сводной таблицы из Excel:

Форматирование символов и ячеек. Не сохраняется. Изменения сделанные для щрифта, размера, цвета текста и фона ячеек в Excel, включая любые применяемые автоформаты, теряются. Форматирование сводной таблицы в программе-конструкторе.

Форматы чисел . Частично сохраняются. Используемые в полях сводной таблицы Excel форматы чисел сохраняются, а форматы чисел для индивидуальных ячеек будут утеряны. При форматировании поля сводной таблицы Excel с произвольным форматом чисел, либо форматом отличным от форматов чисел в сводных таблицах, опубликованные результаты отображаются в том же формате чисел, что и отчет сводной таблицы Excel. Однако, если потом поменять формат чисел для данного поля в программе-конструкторе или обозревателе, изменить его обратно на произвольный формат будет невозможно. В сводной таблице числовые форматы можно настраивать только с помощью программы или сценария в программе-конструкторе. См. Вызов справки по написанию программ и сценариев.

Параметры печати. Не сохраняются. Параметры Excel, задающие повторение названий строк и столбцов на каждой странице, а также подписи повторяющихся элементов после разрывов страницы и установку этих разрывов между разделами, не влияют на то, как сводная таблица будет печататься из программы-конструктора или обозревателя. См. Печать сводной таблицы.

Возврат в начало

Макет

Следующие возможности макета изменяются или теряются при публикации или сохранении отчета сводной таблицы Excel как сводной таблицы:

Поля с группируемыми элементами. Частично сохраняются. Любые выделенные элементы и числовые элементы сгруппированные в Excel, при публикации в сводной таблице будут разгруппированы, а групповые поля Excel не сохранятся. Сводные таблицы не имеют возможности группировки элементов в полях.

Поля данных с группируемыми элементами сохраняются, а сами элементы в этих полях автоматически упорядочиваются по уровням, так что можно выбрать необходимый уровень упорядочивания (неделя, месяц, квартал и так далее) в программе-конструкторе или обозревателе.

Определяемый пользователем порядок сортировки. Не сохраняется. Если в поле сводной таблицы используется заданный пользователем порядок сортировки, данные в сводной таблице размещаются в том порядке, в котором они были выбраны из исходной базы данных. В программе-конструкторе или обозревателе можно сортировать данные в сводной таблице, но создавать или использовать пользовательские порядки сортировки нельзя, как нельзя и перераспределять элементы данных вручную.

Формат с отступом. Не сохраняется. Если для создания формата с отступом в отчете сводной таблицы используется команда Excel Формат отчета, сводная таблица будет выполнена в формате без отступа. Поля сохраняют свои позиции, но форматирование символов и ячеек теряется, также если между группами элементов в Excel вставлены пустые строки, они не будут отображены в опубликованной сводной таблице.

Отображение итогов над группами элементов. Не сохраняются. Если итоги отображаются над каждой из заданных групп элементов в Excel, в сводной таблице они будут отображены соответственно под каждой из групп. Можно изменить выравнивание итоговых элементов по горизонтали в программе-конструкторе или обозревателе, но изменить их вертикальное положение нельзя.

Возврат в начало

Параметры вывода на экран

Следующие параметры вывода на экран изменяются или теряются при публикации или сохранении отчета сводной таблицы Excel как сводной таблицы:

Отображение первого/последнего элементов. Не сохраняется. Если назначено поле в отчете сводной таблицы Excel для отображения подмножества элементов (диалоговое окно Дополнительные параметры поля сводной таблицы Excel), все элементы этого поля отображаются в сводной таблице. В программе-конструкторе можно сортировать элементы поля так, чтобы вначале отображался первый или последний элемент подмножества, а затем отфильтровать поле оставив на экране только требуемые элементы. Автоматическая возможность выбора первого или последнего элемента подмножества в сводной таблице отсутствует.

Ошибки и пустые ячейки. Не сохраняются. Если в Excel были определены настройки того, как отображать ошибки и пустые ячейки, эти настройки будут потеряны при публикации сводной таблицы. В опубликованных из Excel сводных таблицах ошибки и незаполненные ячейки отображаются как чистые ячейки.

Поля страниц в строках и столбцах. Не сохраняются. При изменении параметров Разметка страницы и Число полей в столбце (в диалоговом окне Параметры сводной таблицы Excel), изменения не окажут никакого влияния на публикуемую сводную таблицу. Поля фильтра всегда размещаются в верхней части сводной таблицы.

Возврат в начало

Исходные данные и параметры обновления.

Следующие параметры исходных данных и их обновления изменяются или теряются при публикации или сохранении отчета сводной таблицы Excel как сводной таблицы:

Настройки пароля. Не сохраняются. В Excel, даже при сохранении созданного для выборки внешних данных в отчет сводной таблицы запроса вместе с паролем, пользователям обозревателя, открывшим Web-страницу с опубликованной сводной таблицеей, будет предложено ввести пароль.

Настройки обновления данных. Не сохраняются. Если были установлены фоновое обновление или параметры выборки полей страниц в Excel, эти настройки не повлияют на публикуемую сводную таблицу. Сводные таблицы не поддерживают фоновое обновление или индивидуальную выборку данных для каждого элемента в поле фильтра. См. Обновление сводной таблицы.

Изменение исходных данных. Невозможно. Пользователь не может переопределять диапазоны исходных данных или изменять запрос для выборки других внешних данных из сводной таблицы в обозревателе. При необходимости изменить исходные данные, можно выполнить эти изменения в Excel, а затем заново опубликовать сводную таблицу. См. Исходные данные для сводных таблиц.

Настройка "клиент-сервер". Невозможна. При публикации отчета сводной таблицы, соединенного с автономным файлом куба, из опубликованного отчета нельзя заново подключиться к исходному серверу базы данных, как нельзя и внести изменения в содержимое автономного файла куба из программы-конструктора или обозревателя. При необходимости выполнить любую из этих операций, можно сделать это в Excel, а затем заново опубликовать сводную таблицу.

Возврат в начало


Создание и использование диаграммы на основе сводной таблицы

Диаграмма, созданная на основе сводной таблицы, отображает только те данные, которые отображает сводная таблица. Если данные в сводной таблице изменяются, то диаграмма обновляется. Например, если в область столбцов сводной таблицы добавить поле, то на диаграмме новое поле отобразится в виде данных категорий, либо данных рядов. Если отключить отображение какой-либо части данных в сводной таблице, например, профильтровать данные, скрыть сведения или удалить поле, то эти данные перестанут отображаться и на диаграмме.

Приступая к работе. Прежде чем приступить к созданию диаграммы, следует переместить все данные, которые требуется отобразить на диаграмме, в области строк и столбцов сводной таблицы. Данные, содержащиеся в полях строк, по умолчанию изображаются на диаграмме как ряды данных, а данные в полях столбцов — как данные категорий. Следует также добавить в сводную таблицу не менее одного поля итогов. Если полей итогов добавлено несколько, то на диаграмме отображаются данные крайнего левого поля итогов. Отсутствие полей итогов означает отсутствие данных для диаграммы.

Создание диаграммы. Для создания диаграммы необходимо добавить на Web-страницу элемент управления. Это выполняется той же программой-конструктором, с помощью которой диаграмма создается. Например, в Microsoft FrontPage 2000 в меню Вставка выбирается пункт Компонент, затем — Диаграмма. После добавления элемента управления, диаграмма создается с помощью мастера диаграмм Microsoft Office. Он позволяет выбрать тип диаграммы, а также данные рядов — либо в полях строк, либо в полях столбцов.

Ниже приведена диаграмма, построенная на основе сводной таблицы. В поле итогов «Сумма: Продажи» отображается итоговая сумма, вырученная продавцом с продажи указанного типа товара. Синяя стрелка справа от подписи поля «Продавец» означает фильтрацию данных, в результате которой суммы продаж показаны только для четырех продавцов.

Диаграмма, построенная на основе сводной таблицы.

Диаграмма, построенная на основе сводной таблицы. Поле столбца сводной таблицы, названное «Тип», отображено на диаграмме как данные категорий (напитки, молоко и так далее). Поле строки «Продавец» отображено на диаграмме как данные ряда. Названия рядов показаны на легенде (Батурин, Белов и так далее).

Использование диаграммы. При добавлении полей в сводную таблицу, а также при удалении полей, диаграмма обновляется.

Диаграмма, обновленная после изменения сводной таблицы.

Диаграмма, обновленная после изменения сводной таблицы.

В приведенном примере поле «Продавец» в сводной таблице было перемещено в область столбцов, а поле «Тип» — в область строк. Поле «Регион» было добавлено в область столбцов и профильтровано с целью отобразить только «Восточный» и «Северный» регионы. На обновленной диаграмме поле «Тип» показано в легенде как ряд, а поля «Продавец» и «Регион» отложены по горизонтальной оси как категории.

Дополнительные сведения

Создание диаграммы на основе сводной таблицы.


Создание Web-диаграммы на основе сводной таблицы

Конкретные шаги при создании Web-диаграммы зависят от программы-конструктора, используемой для создания Web-страницы. Дополнительные сведения содержатся в справке этой программы. Если программа-конструктор не способна создавать управляющие элементы, такие как диаграммы, выполните следующее:

  1. С помощью программы-конструктора откройте или создайте Web-страницу, на которой предполагается разместить диаграмму.

  2. Если на этой Web-странице еще нет сводной таблицы, создайте сводную таблицу.

    В таблице должно быть хотя бы одно поле итогов. Данные для построения диаграммы переместите в области сток и столбцов. Данные в полях строк и столбцов используются диаграммой как ряды и категории.

  3. Используя предусмотренную в программе-конструкторе процедуру добавления управляющего элемента на Web-страницу, выберите и отметьте на Web-странице положение и исходный размер диаграммы.

  4. Следуйте инструкциям мастера диаграмм Microsoft Office.

Примечание. На шаге 3 мастера диаграмм укажите, если это необходимо, расположение данных в сводной таблице для построения рядов — либо в строках, либо в столбцах.


Сохранение изменений в сводной таблице

Для сохранения изменений в сводной таблице сохраните в программе-конструкторе файл, содержащий эту таблицу. Сведения о том, как сохранять файлы, содержатся в справке программы-конструктора.


Удаление сводной таблицы

Нельзя удалить сводную таблицу с загруженной в обозреватель Web-страницы.

  1. В программе-конструкторе выберите управляющий элемент сводной таблицы. Дополнительные инструкции смотрите в справке программы-конструктора.

  2. Нажмите клавишу DELETE.


Вызов и использование панели свойств сводной таблицы и панели инструментов

Инструкции

Панель инструментов

Кнопки и команды панели инструментов.

Скрытие панели инструментов.

Вызов скрытой панели инструментов.

Панель свойств сводной таблицы

Использование панели свойств.

Кнопки и команды панели свойств.

Запрет на вызов панели свойств в обозревателе.

Пояснения.


Панель свойств сводной таблицы и панель инструментов

Панель инструментов. В сводной таблице панель инструментов располагается в верхней части листа и обеспечивает набор команд, которые можно использовать при работе с данными сводной таблицы в процессе ее разработки. Пользователи обозревателя также могут использовать панель инструментов для работы со сводной таблицей. Остановите указатель мыши над любой из кнопок панели инструментов, чтобы отобразить имя выполняемой ею команды.

Панель свойств сводной таблицы. Эта панель содержит команды, такие как Показать панель инструментов, а также настраиваемые параметры, такие как цвет фона или ширина столбцов. Содержимое панели изменяется, в зависимости от выбора одной из частей сводной таблицы. Если на Web-странице выбрана не сводная таблица или Web-компонент Microsoft Office, а другой элемент управления, панель будет скрыта до тех пор, пока вновь не будет выбран Web-компонент Microsoft Office. Панель включает в себя некоторые команды, отсутствующие в панели управления и в контекстном меню. Чтобы вывести панель на экран, щелкните кнопку Панель свойств [image] на панели инструментов сводной таблицы.

Команды и свойства панели свойств распределены по разделам, имена которых отображаются на соответствующих панелях. Набор доступных разделов определяется выбранным элементом сводной таблицы. При первом вызове панели свойств сводной таблицы отображаются Общие команды и свойства. Чтобы отобразить или скрыть содержимое раздела, достаточно щелкнуть его панель. См. Использование панели свойств сводной таблицы.

Некоторые свойства и команды доступны на панели и при разработке сводной таблицы, и при последующем просмотре ее в обозревателе. Другие можно использовать только при работе в программе-конструкторе. См. Команды и свойства панели свойств сводной таблицы.

Доступ к панели инструментов и панели свойств сводных таблиц в обозревателе. Если нет необходимости в доступе пользователей к командам и параметрам свойств панели, можно сделать эту панель недоступной в обозревателе.

Если необходимо запретить доступ пользователей к панели инструментов обозревателя, можно скрыть панель инструментов. Чтобы убедиться в том, что пользователи не смогут вновь вывести на экран панель инструментов, необходимо еще закрыть доступ и к панели свойств, поскольку она содержит команду отображения панели инструментов. Кроме того, следует также скрыть строку названия, чтобы запретить доступ к команде контекстного меню, позволяющей отобразить панель инструментов. Скрытие строки названия не запрещает доступ к тем командам панели инструментов, которые доступны из контекстных меню, предусмотренных для полей, элементов данных и других объектов.

Если нет необходимости во внесении изменений в сводную таблицу пользователями обозревателя, рассмотрите возможность публикации данных как неинтерактивной HTML-таблицы. См. сведения о разработке сводной таблицы, включая ограничения доступа пользователей и различные способы публикации данных на Web-странице.


Отображение панели инструментов сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните правой кнопкой строку названия сводной таблицы. В появившемся контекстном меню выберите пункт Панель инструментов.

Примечания

  • Если панель инструментов скрыта, и необходимо отобразить ее на экране, щелкните сводную таблицу правой кнопкой, затем выберите в контекстном меню Панель свойств. Если раздел Отображение не развернут, щелкните панель Отображение, затем щелкните кнопку Панель инструментов [image].

  • Если панель инструментов отображена в программе-конструкторе, то она также доступна при просмотре сводной таблицы в обозревателе.


Скрытие панели инструментов сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выделите сводную таблицу.

  3. Щелкните кнопку Панель свойств [image].

  4. Если раздел Отображение еще не развернут, щелкните панель Отображение.

  5. Щелкните кнопку Панель инструментов [image].

Примечание. Чтобы запретить пользователям отображать панель инструментов сводной таблицы в обозревателе, сделайте панель свойств сводной таблицы недоступной, поскольку она содержит команду отображения панели инструментов. Необходимо также скрыть строку названия, чтобы запретить доступ к команде контекстного меню, позволяющей отобразить панель инструментов. Скрытие строки названия не запрещает доступ к тем командам панели инструментов, которые доступны из контекстных меню, предусмотренных для полей, элементов данных и некоторых других разделов.


Кнопки и команды для сводных таблиц

При конструировании сводной таблицы и и ее просмотре в обозревателе используются одни и те же кнопки и команды панели инструментов.

Эмблема Office Эмблема Office. Вызывает диалоговое окно О Microsoft Office Web Components, в котором содержатся сведения об установленной на компьютере версии. Эта эмблема вращается во время извлечения данных и вычислений.

Копировать Копирует выделенные в сводной таблице данные в буфер обмена, что позволяет вставить их в другую программу. Если нужна интерактивная копия сводной таблицы в Microsoft Excel, воспользуйтесь кнопкой Экспорт в Excel [image].

Сортировка по возрастанию. Сортирут данные в выделенном поле по алфавиту и в порядке возрастания чисел.

Сортировка по убыванию. Сортирут данные в выделенном поле в обратном порядке.

Автофильтр. Включает и отключает фильтрацию полей. Фильтры позволяют отображать не все столбцы и строки, а лишь необходимые.

Автовычисления. Добавляет в список полей поле итогов, вычисляет итоги по данным выделенного поля с использованием функции итогов СУММ, СЧЁТ, МИН или МАКС. Эа кнопка недоступна в сводных таблицах, исходные даные которых содержатся в базах данных OLAP.

Промежуточные итоги. Отображает промежуточные итоги или скрывает промежуточные итоги выделенного поля.

Перейти в область строк. Перемещает выделенное поле в область строк, после чего оно становится полем строк. Поля строк отображают итоговые данные поля в строках сводной таблицы, соответствующих элементам данных поля.

Перейти в область столбцов. Перемещает выделенное поле в область столбцов, после чего оно становится полем столбцов. Поля солбцов отображают итоговые данные поля в столбцах сводной таблицы, соответствующих элементам данных поля.

Перейти в область фильтра. Перемещает выделенное поле в область фильтров, в результате чего оно становится полем фильтра. Поля фильтров фильтруют всю сводную таблицу, отображая только данные, удовлетворяющие условию фильтра.

Перейти в область сведений. Перемещеет выделеное поле в область сведений, в результате чего все данные этого поля отображаются в виде подробных, а не итоговых сведений. Эта команда недоступна в сводных таблицах, исходные данных которых хранятся в базах данных OLAP.

Повышение. Перемещает выделенное поле строк или столбцов на уровень выше. Если сводная таблица содержит несколько полей строк или столбцов, внешними полями называются те, которые расположены соответственно слева или сверху.

Понижение. Перемещает выделенное поле строк или столбцов на уровень ниже. Если сводная таблица содержит несколько полей строк или столбцов, внешними полями называются те, которые расположены соответственно слева или сверху. Остальные поля называются внутренними.

Свернуть или Развернуть. Скрывает или отображает подробные сведения для выделенного поля, элемента данных или ячейки области данных.

Обновить. Обновляет сводную таблицу, используя текущие данные из базы данных, отображает новые данные и добавляет новые поля в список полей.

Экспорт в Excel. Запускает Excel или вызывает переход к Excel, затем копирует сводную таблицу в новую книгу в виде отчета сводной таблицы Excel, который является интерактивным эквивалентом сводной таблицы.

Панель свойств. Отображает панель свойств сводной таблицы, которая позволяет выполнять команды и задавать свойства.

Список полей. Отображает список полей, доступных для сводной таблицы из исходных данных. Позволяет добавлять поля в сводную таблицу.

Справка. В программе-конструкторе выводит на экран справочные сведения о конструировании и использовании сводных таблиц. В обозревателе выводит на экран справочные сведения об использовании сводных таблиц в обозревателе.


Использование панели свойств сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выделите ту часть сводной таблицы, свойства которой необходимо просмотреть или изменить, либо часть, необходимую для выполнения команды.

    Инструкции

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

    Если панель инструментов не отображена, щелкните сводную таблицу правой кнопкой, затем выберите в появившемся контекстном меню пункт Панель свойств.

  4. Чтобы развернуть или скрыть содержимое раздела, щелкните панель с названием этого раздела.

    См. сводку команд и свойств, доступ к которым открывает панель свойств сводной таблицы.

Примечания

  • Если на экране отображена панель свойств сводной таблицы, то ее разделы и их содержимое изменяются при выделении различных частей сводной таблицы или элементов управления Web-компонентами Microsoft Office.

  • Изменение свойств итогов изменяет свойства всех итогов сводной таблицы.

  • Чтобы запретить доступ к панели свойств сводной таблицы в обозревателе, следует сделать панель свойств недоступной. В программе-конструкторе панель свойств доступна всегда.

  • См. сведения о панели свойств сводной таблицы.


Команды и параметры панели свойств сводной таблицы

Далее перечислены все свойства и команды панели свойств сводной таблицы. Доступность той или иной команды определяется выделенной частью сводной таблицы. См. сведения об элементах сводной таблицы. См. также Выделение части сводной таблицы.

Справочные сведения о составлении программ и сценариев для сводной таблицы, в том числе об объектах, методах и свойствах, используемых в командах и параметрах панели свойств сводной таблицы, содержатся в справке по Web-компонентам Microsoft Office для Visual Basic.

Быстрый поиск команд и свойств. Для быстрого поиска сведений о нужной команде или свойстве щелкните вкладку Поиск панели справки, введите имя команды или свойства в поле Введите искомое слово (это поле расположено в верхней части этой вкладки), затем щелкните кнопку Список разделов. выберите название раздела и щелкните кнопку Вывести. Искомое слово будет выделено во всем тексте выведенной справки. Для отключения этого выделения щелкните кнопку Параметры [image] на панели инструментов окна справки, затем щелкните кнопку Выделить искомое. Для включения выделения щелкните кнопку Снять выделение.

Поиск команды или свойства с помощью следующего списка. Выберите в списке название выделенной части сводной таблицы.

Любая часть.

Вся сводная таблица.

Поле сведений.

Поле строки или столбца.

Поле фильтра.

Поле итогов.

Элемент данных в поле.

Промежуточный или общий итог.

Возврат в начало.

Любая часть

Следующие кнопки и параметры доступны при открытой панели свойств сводной таблицы вне зависимости от того, что именно выбрано в сводной таблице — одна ячейка, диапазон ячеек, либо нечто иное. Эти кнопки доступны как в программе-конструкторе, так и в обозревателе.

Параметр | Описание
Панель Общие
Поле Выделение. | В этом поле отображается название выделенной части сводной таблицы.
Справка. | Вывод разделов справки.
Панель Отображение.
Строка названия | Отображение строки названия в верхней части сводной таблицы. Эта команда становится доступной при добавлении данных в создаваемую сводную таблицу.
Панель инструментов | Отображение панели инструментов сводной таблицы.
Список полей | Отображение списка полей для сводной таблицы.
Индикаторы развертывания | Индикаторы развертывания, находящиеся слева от элементов данных в полях строк и столбцов, позволяют скрывать и отображать подробные сведения.
Области | Отображение структуры областей сводной таблицы и их подписей. Эта команда становится доступной при добавлении данных в создаваемую сводную таблицу.

Возврат в начало.

Вся сводная таблица

Разделы Источник данных и Дополнительные доступны также в создаваемой сводной таблице до добавления данных.

Параметр | Описание
Панель Формат
Поле Название сводной таблицы. | В это поле вводится текст названия, которое отображается в верхней части сводной таблицы.
Фон | Выбор цвета фона для всей сводной таблицы.
Панель Источник данных (недоступна в обозревателе)
Кнопка Источник данных и список. | Выбор элемента управления источником данных для Web-страницы.
Кнопка Подключение и соответствующее поле. | Позволяет указать строку подключения для добавления данных в сводную таблицу.
Кнопка Редактор подключений. | Создание строки подключения на основе сведений об источнике данных, указанных в диалоговом окне Свойства источника данных.
Кнопка Компонент данных и соответствующий список. | Выбор элемента базы данных, такого как таблица, из которого будут извлекаться исходные данные.
Кнопка Текст команды и соответствующее поле. | В это поле вводится запрос или команда, например команда языка SQL, извлекающая данные из базы данных.
Панель Итоги
Флажок Итоги по всем элементам. | Если этот флажок установлен, то при вычислении промежуточных и общих итогов учитываются все элементы данных, в том числе скрытые фильтром.
Список Ориентация итогов. | Отображение полей итогов в строках, либо в столбцах.
Панель Отображать пустые элементы
Флажок Строка. | Отображение элементов, не содержащих данных в полях строк.
Флажок Столбец. | Отображение элементов, не содержащих данных в полях столбцов.
Панель Формат области данных (недоступна в обозревателе)
Флажок Автоподбор области сведений. | Если этот флажок установлен, то размеры области сведений автоматически принимают значения, необходимые для отображения данных.
Поле Максимальная ширина. | В этом поле указывается максимальная ширина, до которой может расширяться область сведений при установленном флажке Автоподбор.
Поле Максимальная высота. | В этом поле указывается максимальная высота области сведений. Это ограничение действует при установленном флажке Автоподбор.
Поле Ширина области данных. | В этом поле указывается фиксированная ширина области сведений. Действует только в случае, если флажок Автоподбор снят.
Поле Высота строки данных. | В этом поле указывается фиксированная высота строк в области сведений.
Панель Формат строки названия (недоступна в обозревателе)
Формат текста | Отображение строки названия полужирным шрифтом, курсивом или подчеркнутым; выбор цвета шрифта.
Список Шрифт. | Выбор шрифта текста строки названия из списка доступных шрифтов.
Список Размер. | Выбор размера шрифта текста строки названия из списка доступных размеров.
Фон | Выбор цвета фона строки названия.
Панель Подписи областей (недоступна в обозревателе)
Поле Область строк. | В этом поле указывается текст подписи области строк.
Поле Область столбцов. | В этом поле указывается текст подписи области столбцов.
Поле Область данных. | В этом поле указывается текст подписи области сведений.
Поле Область фильтра. | В этом поле указывается текст подписи области фильтра.
Формат текста | Отображение текста подписей областей полужирным шрифтом, курсивом или подчеркнутым; выбор цвета шрифта.
Список Шрифт. | Выбор шрифта текста подписей областей из списка доступных шрифтов.
Список Размер. | Выбор размера шрифта текста подписей областей из списка доступных размеров.
Фон | Выбор цвета фона подписей областей.
Панель Дополнительные (недоступна в обозревателе)
Список Развертывать элементы по умолчанию. | Автоматически разворачивает подробные сведения для всех элементов при первом отображении сводной таблицы.
Флажок Разрешить сведения. | Установка этого флажка разрешает просмотр подробных сведений в обозревателе.
Флажок Разрешить панель свойств. | Установка этого флажка разрешает доступ к панели свойств сводной таблицы в обозревателе.
Флажок Блокировать фильтры. | Установка этого флажка запрещает изменять фильтрацию данных в обозревателе, как отображаемых, так и скрытых.
Флажок Блокировать поля строк/столбцов. | Установка этого флажка запрещает перемещение полей между областью строк и областью столбцов в обозревателе.
Флажок Автоподбор. | Если этот флажок установлен, то размеры сводной таблицы автоматически принимают значения, необходимые для отображения данных.
Поле Максимальная высота. | В этом поле указывается максимальная высота всей сводной таблицы. Это ограничение действует при установленном флажке Автоподбор.
Поле Максимальная ширина. | В этом поле указывается максимальная ширина всей сводной таблицы. Это ограничение действует при установленном флажке Автоподбор.
Поле Высота. | В этом поле указывается фиксированная высота всей сводной таблицы. Действует только в случае, если флажок Автоподбор снят.
Поле Ширина. | В этом поле указывается фиксированная ширина всей сводной таблицы. Действует только в случае, если флажок Автоподбор снят.
Флажок Отображать справа налево. | Отображение сводной таблицы справа налево. Эта возможность предусмотрена для пользователей, которые желают просматривать сводную таблицу в соответствующей языковой среде.
Текст Доступна область данных. | Служит для сообщения о том, включены ли в исходные данные подробные сведения.

Возврат в начало.

Поле сведений

Параметр | Описание
Панель Формат
Формат текста | Отображение содержимого ячеек поля сведений полужирным шрифтом, курсивом или подчеркнутым шрифтом; выбор цвета шрифта.
Список Шрифт. | Выбор шрифта для ячеек поля сведений из списка доступных шрифтов.
Список Размер. | Выбор размера шрифта для ячеек поля сведений из списка доступных размеров шрифта.
Фон | Выбор цвета фона ячеек поля сведений.
Список Выравнивание по горизонтали. | Выбор способа выравнивания текста в ячейках поля сведений.
Список Формат чисел. | Выбор формата чисел в ячейках поля сведений. См. список доступных форматов чисел.
Поле Ширина. | Выбор ширины столбцов поля сведений. Ширина указывается в пикселах.
Флажок Автоподбор. | Если этот флажок установлен, то ширина столбца поля сведений автоматически принимает значение, необходимое для отображения данных.
Панель Подписи
Поле Подпись. | В это поле вводится подпись поля.
Поле Подпись набора полей. | В это поле вводится подпись измерения в случае, если поле является частью измерения OLAP.
Панель Сортировка
Список Направление сортировки. | Сортировка элементов данных поля по возрастанию, по убыванию, либо по умолчанию, то есть в том порядке, в котором элементы получены из исходной базы данных.
Панель Дополнительные (недоступна в обозревателе)
Текст Имя поля в базе данных. | Отображение имени, которое поле имеет в исходной базе данных.
Текст Поле данных. | Отображение того имени, которое поле имеет в исходных данных, если исходные данные для сводной таблицы хранятся не в базе данных куба OLAP.
Текст Тип данных. | Отображение типа данных поля в исходной базе данных.
Текст Имя поля. | Отображение имени поля в сводной таблице.
Текст Тип поля. | Отображение типа поля: Обычный, Время, Неизвестно, Определяется пользователем.
Текст Ориентация набора полей. | Указывается область, в которой отображается поле в данных момент.
Текст Тип набора полей. | Для поля, являющегося частью измерения OLAP, отображается тип измерения: Время, Другое, Неизвестно, Определяется пользователем.
Текст Имя набора полей. | Отображается имя измерения в случае, если поле является частью измерения OLAP.

Возврат в начало.

Поле строки или столбца

Параметр | Описание
Панель Формат
Формат текста | Отображение текста подписи поля полужирным шрифтом, курсивом, либо подчеркнутым шрифтом; выбор цвета шрифта.
Список Шрифт. | Выбор шрифта подписи поля из списка доступных шрифтов.
Список Размер. | Выбор размера шрифта подписи поля из списка доступных размеров шрифта.
Фон | Выбор цвета фона подписи поля.
Поле Ширина. | Выбор ширины столбца поля. Ширина указывается в пикселах.
Флажок Автоподбор. | Если этот флажок установлен, то ширина столбца поля автоматически принимают значение, необходимое для отображения данных.
Панель Подписи
Поле Подпись. | В это поле вводится текст подписи поля.
Поле Подпись набора полей. | В это поле вводится подпись измерения в случае, если поле является частью измерения OLAP.
Панель Сортировка
Список Направление сортировки. | Сортировка элементов данных поля по возрастанию, по убыванию, либо по умолчанию, то есть в том порядке, в котором элементы получены из исходной базы данных.
Панель Дополнительные (недоступна в обозревателе)
Текст Имя поля в базе данных. | Отображение имени, которое поле имеет в исходной базе данных.
Текст Поле данных. | Отображение того имени, которое поле имеет в исходных данных, если исходные данные для сводной таблицы хранятся не в базе данных куба OLAP.
Текст Тип данных. | Отображение типа данных поля в исходной базе данных.
Текст Имя поля. | Отображение имени поля в сводной таблице.
Текст Тип поля. | Отображение типа поля: Обычный, Время, Неизвестно, Определяется пользователем.
Текст Ориентация набора полей. | Указывается область, в которой отображается поле в данных момент.
Текст Тип набора полей. | Для поля, являющегося частью измерения OLAP, отображается тип измерения: Время, Другое, Неизвестно, Определяется пользователем.
Текст Имя набора полей. | Отображается имя измерения в случае, если поле является частью измерения OLAP.

Возврат в начало.

Поле фильтра

Параметр | Описание
Панель Формат
Формат текста | Отображение текста подписи поля полужирным шрифтом, курсивом, либо подчеркнутым шрифтом; выбор цвета шрифта.
Список Шрифт. | Выбор шрифта подписи поля из списка доступных шрифтов.
Список Размер. | Выбор размера шрифта подписи поля из списка доступных размеров шрифта.
Фон | Выбор цвета фона подписи поля.
Панель Подписи
Поле Подпись. | В это поле вводится подпись поля.
Поле Подпись набора полей. | В это поле вводится подпись измерения в случае, если поле является частью измерения OLAP.
Панель Дополнительные (недоступна в обозревателе)
Текст Имя поля в базе данных. | Отображение имени, которое поле имеет в исходной базе данных.
Текст Поле данных. | Отображение того имени, которое поле имеет в исходных данных, если исходные данные для сводной таблицы хранятся не в базе данных куба OLAP.
Текст Тип данных. | Отображение типа данных поля в исходной базе данных.
Текст Имя поля. | Отображение имени поля в сводной таблице.
Текст Тип поля. | Отображение типа поля: Обычный, Время, Неизвестно, Определяется пользователем.
Текст Ориентация набора полей. | Указывается область, в которой отображается поле в данных момент.
Текст Тип набора полей. | Для поля, являющегося частью измерения OLAP, отображается тип измерения: Время, Другое, Неизвестно, Определяется пользователем.
Текст Имя набора полей. | Отображается имя измерения в случае, если поле является частью измерения OLAP.

Возврат в начало.

Поле итогов

Параметр | Описание
Панель Формат
Формат текста | Отображение содержимого ячеек поля итогов полужирным шрифтом, курсивом или подчеркнутым шрифтом; выбор цвета шрифта.
Список Шрифт. | Выбор шрифта для ячеек поля итогов из списка доступных шрифтов.
Список Размер. | Выбор размера шрифта для ячеек поля итогов из списка доступных размеров шрифта.
Фон | Выбор цвета фона ячеек поля итогов.
Список Выравнивание по горизонтали. | Выбор выравнивания текста в ячейках поля итогов.
Список Формат чисел. | Выбор формата чисел в ячейках поля итогов. См. список доступных форматов чисел.
Поле Ширина. | Выбор ширины столбцов поля итогов. Ширина указывается в пикселах.
Флажок Автоподбор. | Если этот флажок установлен, то ширина столбца поля итогов автоматически принимают значение, необходимое для отображения данных.
Панель Подпись итогов
Поле Подпись. | В это поле вводится подпись поля итогов.
Список Выравнивание строк. | Выравнивание элементов промежуточных и общих итогов в поле итогов относительно области сведений, если она отображена. Существуют следующие типы выравнивания: Автоматически, По левому краю, По центру, По правому краю. Автоматическое выравнивание означает выравнивание по умолчанию (по левому краю).
Панель Функция итогов
Список Функция. | Выбор итоговой функции для поля итогов.
Панель Дополнительные (недоступна в обозревателе)
Текст Поле итогов. | Отображение имени поля в исходных данных, из которых берутся значения для вычисления итогов.
Текст Имя итогов. | Отображение имени поля итогов.
Текст Тип итогов. | Отображение типа итога. Вычисляемый итог вычисляется с помощью встроенной итоговой функции. Определяемый пользователемитог вычисляется программой или сценарием, написанными пользователем.

Возврат в начало.

Элемент данных в поле

Параметр | Описание
Панель Формат
Формат текста | Отображение подписи элемента полужирным шрифтом, курсивом, либо подчеркнутым шрифтом; выбор цвета шрифта.
Список Шрифт. | Выбор шрифта подписи элемента из списка доступных шрифтов.
Список Размер. | Выбор размера шрифта подписи элемента из списка доступных размеров шрифта.
Фон | Выбор цвета фона подписи элемента.
Список Выравнивание по горизонтали. | Выбор выравнивания текста в ячейке с подписью элемента.
Панель Дополнительные (недоступна в обозревателе)
Текст Имя элемента. | Отображение имени, которое элемент имеет в исходных данных.
Текст Уникальное имя элемента. | Отображение полного имени элемента, включая имя поля. Если данные элемента хранятся в базе данных OLAP, то отображается также имя измерения.
Текст Подпись элемента. | Отображение подписи элемента в сводной таблице.

Возврат в начало.

Промежуточный или общий итог

Параметр | Описание
Панель Формат
Формат текста | Отображение содержимого ячеек промежуточных или общих итогов полужирным шрифтом, курсивом, либо подчеркнутым шрифтом; выбор цвета шрифта.
Список Шрифт. | Выбор шрифта для ячеек промежуточных или общих итогов из списка доступных шрифтов.
Список Размер. | Выбор размера шрифта для ячеек промежуточных или общих итогов из списка доступных размеров шрифта.
Фон | Выбор цвета фона ячеек промежуточных или общих итогов.

Возврат в начало.


Запрет на доступ к панели свойств сводной таблицы

Описанным ниже способом можно запретить отображение в обозревателе панели свойств сводной таблицы. При этом доступ к панели свойств сводной таблицы в программе-конструкторе сохраняется.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  5. Снимите флажок Разрешить панель свойств.

Примечание. Этот параметр невозможно изменить в обозревателе. В программе-конструкторе панель свойств сводной таблицы доступна всегда.


Добавление полей в сводную таблицу

Инструкции

Добавление полей

Поле строки или столбца.

Поле данных.

Поле фильтра.

Поле сведений.

Поле итогов.

Параметры полей

Просмотр сведений о поле и его исходных данных.

Запрет перемещения и добавления полей строк и столбцов.

Пояснения.


О добавлении полей в сводную таблицу

Для добавления данных в сводную таблицу необходимо указать базу данных, в которой хранятся анализируемые данные, и подмножество данных, которые будут доступны в качестве исходных данных для сводной таблицы. Из этих исходных данных выбираются поля для отображения в сводной таблице. См. Исходные данные для сводных таблиц.

Просмотр доступных полей. Для просмотра доступных полей с исходными данными, а также для добавления полей в области строк, столбцов, фильтров, данных и сведений сводной таблицы, щелкните Список полей [image] на панели инструментов сводной таблицы. В этом списке поля, названия которых не выделены полужирным шрифтом, доступны, но не отображены в сводной таблице. Остальные поля отображены. Список полей просматривается с помощью полосы прокрутки. Индикаторы развертывания Плюс и Минус позволяют раскрывать и скрывать поля щелчками мыши.

Ограничения, связанные с источником данных. Если источником данных для сводной таблицы является база данных OLAP, например, база данных, созданная с помощью служб Microsoft SQL Server OLAP Services, то перемещать поля в область сведений нельзя. Некоторые поля можно перемещать только в области строк, столбцов и фильтров. Поля, которые в списке полей перечислены в узле Итоги, могут использоваться только как поля данных.

Добавление полей

Поля сведений. Чтобы отобразить все доступные поля сведений и просмотреть, какие данные можно подытожить, воспользуйтесь полями сведений. При добавлении полей в область сведений отображаются все записи этих полей, содержащиеся в исходных данных. Имена полей становится подписями столбцов, а в строках под ними располагаются записи сведений.

Пример: поля сведений

Поля строк и столбцов. Поля строк и столбцов служат для подытоживания и сравнения данных. Такие поля позволяют отображать уникальные элементы данных (имена) в полях, расположенных слева от строк или над столбцами. В каждой ячейке, расположенной в месте пересечения строки и столбца, содержатся итоговые данные соответствующего элемента. См. сведения о добавлении полей строк и столбцов.

Пример: поля строк и столбцов

Поля данных. Поля данных служат для указания значений, которые должны быть подытожены в сводной таблице. Если поле добавить в область данных, то значения этого поля для элементов полей строк и столбцов просуммируются.

Пример: поле данных

Поля фильтров. Поле фильтра похоже на поле страницы в отчете сводной таблицы Microsoft Excel. Оно используется для отображения лишь необходимой части доступных данных. В эту часть включаются итоговые данные всех элементов поля фильтра. Если в поле фильтра выбрать какой-либо элемент, то отображаются итоговые данные лишь для выбранного элемента. Например, если добавить поле фильтра «Регион», то в сводной таблице отобразятся итоговые данные лишь для одного региона. См. Добавление поля фильтра.

Пример: поле фильтра

Перемещение полей. Поле, добавленное в сводную таблицу, можно переместить в другую область. При перемещении поля изменяется макет сводной таблицы, а вместе с ним — отображение данных и вычисляемые итоги.

Добавление вычислений итогов. Новые поля данных создаются путем добавления в сводную таблицу полей итогов. Поля итогов позволяют суммировать данные, которые используются в качестве полей данных. Например, если в исходных данных содержится поле «Продажи», показывающее суммы отдельных продаж, можно добавить поле итогов «Сумма: Продажи» для вычисления итоговых сумм продаж, либо поле итогов «Число продаж» для вычисления количества проданных единиц товара. См. сведения об итогах в сводных таблицах.

Удаление полей. Если некоторые данные требуется не отображать, либо не суммировать, то из сводной таблицы следует удалить поля, соответствующие этим данным. После удаления поля из сводной таблицы оно не отображается в ней, но остается в исходных данных и в списке полей.

Ограничение работы с полями

В обозревателе тоже можно добавлять поля и создавать итоги, если эти действия пользователям не запрещены. См. сведения о работе со сводными таблицами и создании итогов в обозревателе.

Просмотр сведений о полях. В сводной таблице можно просматривать сведения о полях, включая сведения о полях исходной базы данных и типе исходных данных. В обозревателе эти сведения недоступны.

Ограничение изменения макета в обозревателе. Запрет перемещения и добавления полей строк и столбцов в обозревателе лишает пользователей возможности изменять макет сводной таблицы путем перетаскивания полей. В некоторых случая полезно также ограничить доступ к сведениям, чтобы пользователи не могли перетаскивать поля в область сведений, и ограничить доступ к фильтрации, чтобы пользователи не могли перетаскивать поля в область фильтров.


Добавление нового поля строки или столбца к сводной таблице

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов сводной таблицы щелкните значок Список полей [image].

  3. Для поиска поля, которое необходимо добавить в сводную таблицу, пользуйтесь полосами прокрутки и индикаторами развертывания Плюс и Минус.

  4. Выберите нужное поле.

  5. В списке, расположенном в нижнем правом углу списка полей, выберите один из следующих вариантов действий:

    Чтобы добавить новое поле строки, выберите Область строк.

    Чтобы добавить новое поле столбца, выберите Область столбцов.

  6. Щелкните кнопку Добавить в.

Примечания.

  • Если кнопка Добавить в стала недоступной после выбора пункта Область строк или Область столбцов, то выбранное поле, вероятно, нельзя использовать в качестве поля строк или столбцов. Если исходные данные сводной таблицы хранятся в базе данных OLAP, обратите внимание, что в качестве полей строк и столбцов нельзя использовать поля, перечисленные в списке полей в группе Итоги.

  • Если добавление пользователями новых полей строк и столбцов нежелательно, можно запретить добавлять и перемещать поля строк и столбцов в обозревателе.


Добавление нового поля данных к сводной таблице

По умолчанию поля данных, подытоживающие числовые данные, используют функцию групповой обработки СУММ. Поля выполняющие групповую обработку других типов данных — используют функцию СЧЕТ. См. инструкцию, как просмотреть тип данных поля.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов сводной таблицы щелкните значок Список полей [image].

  3. Для поиска поля, которое необходимо добавить в сводную таблицу, пользуйтесь полосами прокрутки и индикаторами развертывания Плюс и Минус.

  4. Выберите нужное поле. В списке, расположенном в нижнем правом углу списка полей, выберите Область данных.

  5. Щелкните кнопку Добавить в.

Примечание. Если кнопка Добавить в стала недоступной после выбора пункта Область данных, это может означать, что выбранное поле нельзя использовать в качестве поля данных. Если исходные данные сводной таблицы хранятся в базе данных OLAP, то в качестве полей фильтра можно использовать только поля, перечисленные в списке полей в группе Итоги.


Добавление в сводную таблицу поля фильтра

После добавления поля фильтра появляется возможность профильтровать всю сводную таблицу, то есть отобразить в ней данные лишь для элемента, выбранного в раскрывающемся списке поля фильтра.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов сводной таблицы щелкните кнопку Список полей [image].

  3. Для поиска поля, которое необходимо добавить в сводную таблицу, пользуйтесь полосами прокрутки и индикаторами развертывания Плюс и Минус.

  4. Выберите нужное поле. В списке, расположенном в нижнем правом углу списка полей, выберите Область фильтра.

  5. Щелкните кнопку Добавить в.

Примечания

  • Если кнопка Добавить в стала недоступной после выбора пункта Область фильтра, то выбранное поле, вероятно, нельзя использовать в качестве поля фильтра. Если исходные данные сводной таблицы хранятся в базе данных OLAP, то в качестве полей фильтра нельзя использовать поля, которые в списке полей перечислены в группе Итоги.

  • Если требуется запретить пользователям добавлять в сводную таблицу поля фильтров, то следует запретить доступ к командам фильтрации в обозревателе.


Добавление в сводную таблицу нового поля сведений

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов сводной таблицы щелкните кнопку Список полей [image].

  3. Для поиска поля, которое необходимо добавить в сводную таблицу, пользуйтесь полосами прокрутки и индикаторами развертывания Плюс и Минус.

  4. Выберите нужное поле. В списке, расположенном в нижнем правом углу списка полей, выберите Сведения.

  5. Щелкните кнопку Добавить в.

Примечания

  • Если кнопка Добавить в стала недоступной после выбора пункта Сведения, то к сведениям, вероятно, нет доступа. Например, если исходные данные сводной таблицы хранятся в базе данных OLAP, то, как правило, доступны только итоговые, а не подробные данные.

  • Если требуется запретить пользователям добавлять в сводную таблицу поля сведений, то следует ограничить доступ к сведениям в обозревателе.


Запрет на добавление и удаление полей столбцов и строк в сводной таблице

Описанным ниже способом можно запретить пользователям добавлять в обозревателе поля строк и столбцов в сводную таблицу, а также удалять из нее эти поля. Однако это приводит также к невозможности добавления и удаления полей строк и столбцов в программе-конструкторе.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  5. Установите флажок Блокировать поля строк/столбцов.

Примечания

  • Изменить эту установку в обозревателе невозможно.

  • Если требуется запретить пользователям добавлять поля в область фильтров, а также удалять из нее поля, запретите команды фильтрации в обозревателе.

  • Если требуется запретить пользователям добавлять поля в область сведений, а также удалять из нее поля, запретите доступ к сведениям в обозревателе.

  • Это ограничение не действует в Excel. Выполнив экспорт сводной таблицы из обозревателя в Excel, пользователи могут добавлять и удалять все поля, содержащиеся в исходных данных. Чтобы лишить пользователей этой возможности, запретите доступ к команде обозревателя Экспорт в Excel следующим образом: отключите панель инструментов и запретите доступ к панели свойств сводной таблицы. См. Запреты при работе со сводной таблицей в обозревателе.


Просмотр сведений о поле и его исходных данных в сводной таблице

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробные сведения содержатся в справке программы-конструктора.

  2. Щелкните поле, сведения о котором необходимо просмотреть.

    Для просмотра сведений об элементе данных, щелкните этот элемент.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

    См. сведения о выводе сведений о полях и элементах.

Примечание. Просматривать эти сведения в обозревателе невозможно.


Удаление поля из сводной таблицы

Когда из макета сводной таблицы удаляется поле, его данные больше не отображаются, но само поле по прежнему остается доступным в списке полей для просмотра.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните подпись поля, которое необходимо удалить из сводной таблицы.

  3. Переместите поле за пределы сводной таблицы, чтобы указатель принял вид Указатель с красным X.

Примечание. Чтобы удалить поле итогов одновременно из сводной таблицы и из списка полей, щелкните его правой кнопкой мыши, а затем выберите в контекстном меню пункт Удалить.


Изменение макета сводной таблицы

Инструкции.

Укажите, как могут перемещаться поля.

Показать области для перемещения и добавления полей.

Запрет на перемещение и добавление полей строк и столбцов.

Перемещение полей

Перемещение поля в область строк или столбцов.

Перемещение поля в область данных.

Перемещение поля в область фильтра.

Перемещение поля строки или столбца с повышением уровень.

Перемещение поля строки или столбца с понижением уровня.

Перемещение поля в область сведений.

Добавление или удаление полей

Добавить новые поля.

Удалить поле.

Пояснения.


Об изменении макета сводной таблицы

Изменяя макет, можно изменить итоговое представление данных в сводной таблицы. Различные макеты позволяют вычислять и сравнивать итоговые значения для различных элементов данных или отображать результаты операций суммирования для отдельных подмножеств данных. После того, как сводная таблица становится доступна пользователям, они сами определяют изменения, вносимые в исходный макет.

Использование областей в сводной таблице. Макет изменяется перемещением полей в заранее определенные области в рабочем пространстве сводной таблицы. Для просмотра структуры отобразите эти области на экране если они были скрыты.

После перемещения в эти области полей, названия областей будут скрыты, но возможность перетаскивать в них поля сохранится, что также можно сделать, используя команды панели инструментов.

Перемещение полей в области строк и столбцов. При перемещении поля в область строк уникальные элементы данных этого поля отображаются в строках сводной таблицы, а при перемещении поля в область столбцов – в столбцах.

Изменение уровня полей строк и столбцов. Если сводная таблица содержит несколько полей строк и столбцов, те из них, что расположены ближе к итоговым данным, принято называть внутренними, а остальные — внешними полями. Более подробные сведения отображаются вначале для внутренних, а затем для внешних полей.

Пример внутренних и внешних полей строк

Существует возможность перемещать поля с повышением уровня или с понижением уровня, изменяя их структуру так, чтобы внутренние поля становились внешними.

Перемещение полей в область фильтра. Поле фильтра похоже на поле страницы в отчете сводной таблицы Microsoft Excel. Оно используется для отображения лишь необходимой части доступных данных. Например, если добавить в область фильтра поле «Продукт», то в сводной таблице отобразятся итоговые данные лишь для одного продукта. См. Перемещение поля в область фильтра.

Перемещение полей в область данных. Поля данных служат для указания значений, которые должны быть подытожены в сводной таблице. Если переместить поле в область данных, то значения этого поля для элементов полей строк и столбцов будут суммироваться.

Перемещение полей в область сведений. Для просмотра подробных записей исходных данных из сводной таблицы, существует возможность перемещать поля в область сведений. Если необходимо сохранить порядок полей или значения итоговых данных, можно просматривать подробные сведения совместно с итоговыми данными.

Добавление и удаление данных. Макет сводной таблицы может не содержать всех полей источника данных. Если имеются дополнительные данные, разрешено добавлять поля к макету сводной таблицы. Например, в сводной таблицы суммируется выручка от продаж, а в исходных данных также содержатся сведения о количестве продаж. В этом случае можно добавить поле “Количество” в качестве поля данных, чтобы подсчитывать и выручку с продаж, и количество проданных продуктов. Также есть возможность удалять из макета сводной таблицы поля, которые больше не требуются.

Перемещение полей не влияет на фильтрацию. Когда выполняется фильтрация по полю, установки фильтра для этого поля сохраняются при перемещении поля в область данных или область фильтра, где все элементы видимы. Это означает, что когда поле вернется на прежнее место в область строк, столбцов или область сведений, фильтр будет работать и скрытые элементы опять будут невидимы. Также, если удалить поле, а затем вновь добавить это поле к макету, опять будут скрыты те же самые элементы. Признаком того, что элементы в поле скрыты фильтром, является синий цвет стрелки раскрывающегося списка поля.

Ограничения по добавлению и перемещению полей. При работе со сводной таблицей, источником данных для которой является база данных OLAP, например, база данных, созданная с помощью Microsoft SQL Server OLAP Services, перемещать поля в область сведений нельзя. Некоторые поля можно перемещать только в области строк, столбцов и фильтра, а поля в области данных нельзя переместить ни в какие другие области.

Ограничение изменений макета обозревателем. Можно ограничить возможность пользователя изменять макет сводной таблицы, наложив запрет на добавление и перемещение полей строк и столбцов в обозревателе.


Отображение областей для перемещения и добавления полей в сводную таблицу

Прежде чем отобразить области, необходимо добавить в сводную таблицу данные.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните правой кнопкой строку названия сводной таблицы. В появившемся контекстном меню выберите пункт Области.

Примечания

  • Если строка названия скрыта, и необходимо отобразить ее на экране, щелкните сводную таблицу правой кнопкой, затем выберите в контекстном меню Панель свойств. Если раздел Отображение не развернут, щелкните панель Отображение. Щелкните кнопку Области [image].

  • Если поля содержатся во всех областях, их очертания и подписи не отображаются, однако возможность перемещения полей сохраняется.


Перемещение поля в область строк или столбцов сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выведите на экран области сводной таблицы.
  3. Задержите указатель мыши на подписи поля, которое необходимо переместить, чтобы указатель принял следующий вид Указатель мыши в виде четырех стрелок.

  4. Варианты действий:

    Чтобы сделать поле полем строки, переместите его подпись в область строк в левой части сводной таблицы, чтобы указатель принял следующий вид Указатель с выделенной областью строк.

    Чтобы сделать поле полем столбца, переместите его подпись в область столбцов в верхней части сводной таблицы, чтобы указатель принял следующий вид Указатель с выделенной областью столбцов.

Подсказка. Чтобы просмотреть только итоговые данные для нового поля строки или столбца, щелкните значок Минус для элементов данных этого поля.


Изменения уровня поля строки или столбца в сводной таблице

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните подпись поля, которое необходимо переместить на другой уровень.

  3. На панели инструментов сводной таблицы выполните одно из следующих действий:

    Для перемещения поля вверх щелкните кнопку Повышение [image].

    Для перемещения поля вниз щелкните кнопку Понижение [image].


Перемещение поля в область данных сводной таблицы

Разрешено перемещать поля из областей строк, столбцов и фильтра в область данных только, если исходные данные для сводной таблицы не являются базами данных OLAP.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выведите на экран области сводной таблицы.
  3. Задержите указатель мыши на подписи поля, которое необходимо переместить, чтобы указатель принял следующий вид Указатель мыши в виде четырех стрелок.

  4. Перетащите поле в область данных, располагающейся в правой нижней части сводной таблицы. Указатель мыши должен принять следующий вид: Указатель в виде знака «Сигма».

Примечание. То, какая функция используется для групповой обработки перемещенного в область данных поля, зависит от типа данных в этом поле. Поля содержащие цифровые данные обрабатываются функцией СУММ. Поля, содержащие данные других типов, подытоживаются с помощью функции СЧЕТ. Можно изменять функцию групповой обработки для некоторых полей.


Перемещение поля в область фильтров сводной таблицы

После перемещения поля в область фильтров появляется возможность профильтровать всю сводную таблицу, то есть отобразить в ней данные лишь для элемента, выбранного в раскрывающемся списке поля фильтра.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выведите на экран области сводной таблицы.
  3. Задержите указатель мыши на подписи поля, которое необходимо переместить, чтобы указатель принял следующий вид Указатель мыши в виде четырех стрелок.

  4. Перетащите поле в область фильтров, которая расположена в верхней части сводной таблицы. Указатель мыши должен принять следующий вид: Указатель с выделенной областью фильтров.

Примечание. Если требуется запретить пользователям добавлять поля в область фильтров, а также удалять из нее поля, то следует запретить команды фильтрации в обозревателе.


Перемещение поля в область сведений сводной таблицы

Если исходные данные для сводной таблицы извлекаются из базы данных OLAP, перемещать поля в область сведений невозможно.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните подпись поля, которое необходимо переместить в область сведений.

  3. На панели инструментов сводной таблицы щелкните кнопку Перейти в область сведений [image].

Совет. Если необходимо запретить пользователям перемещать поля в область сведений, ограничьте доступ к сведениям в обозревателе.


Изменение порядка отображения столбцов сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Задержите указатель мыши на подписи поля или элемента в верхней части столбца, чтобы указатель принял следующий вид Указатель мыши в виде четырех стрелок.

  3. Перетащите столбец в новое положение.

Подсказка. Чтобы быстро изменить порядок полей, когда имеется множество полей строк или столбцов, выберите поле, которое необходимо изменить, а затем щелкните кнопку Повышение [image] или Понижение [image].


Отображение итогов в сводной таблице

Инструкции

Добавление и форматирование полей итогов

Добавление поля итогов в сводную таблицу.

Изменение итоговой функции для поля итогов.

Итоговые функции.

Отображение полей итогов либо горизонтально, либо вертикально.

Отображение и форматирование промежуточных и общих итогов

Отображение промежуточных и общих итогов для поля.

Изменение выравнивания элементов промежуточных и общих итогов в поле.

Включение в промежуточные и общие итоги, либо исключение из них данных, скрытых фильтрацией.

Пояснения.


Об отображении итогов в сводной таблице

Для отображения в сводных таблицах итоговых значений используются два типа итогов. Первый тип обеспечивается полями итогов. При наличии полей итогов можно отобразить итоги второго типа — промежуточные итоги и общие итоги для полей строк и полей столбцов.

Далее приводятся сведения о полях итогов, промежуточных и общих итогах, в том числе о способах их отображения.

Поля итогов

Промежуточные и общие итоги

Поля итогов

Что такое поля итогов. Поля итогов — это поля данных, которые содержатся в исходных данных, либо вычисляются по полям исходных данных. Например, если исходные данные содержат поле «Продажи», в котором записаны суммы отдельных продаж, то можно просуммировать эти числа по категориям списка таблицы в поле итогов «Суммы: Продажи», либо подсчитать количество этих чисел в каждой из категорий сводной таблицы в поле итогов «Число продаж». В списке полей такие поля итогов отображаются в его верхней части в узле Итоги.

Пример: список полей, содержащий поля итогов

Поля «Продажи» и «Единицы» можно включить в сводную таблицу в качестве полей итогов.

Исходные данные и поля итогов. В сводных таблицах, исходные данные которых хранятся в базе данных OLAP, значения полей итогов рассчитываются на сервере этой базы данных, поэтому в этом случае недоступны следующие действия: добавление новых полей итогов; перемещение полей итогов в область сведений; изменение итоговой функции, используемой для вычисления значений в поле итогов. См. сведения об исходных данных для сводных таблиц.

Добавление новых полей итогов. Если для отображение требуемых итогов недостаточно тех полей итогов, которые существуют в списке полей, а исходные данные позволяют отобразить нужные данные, то в сводную таблицу следует добавить новые поля итогов. Обычно поля итогов добавляются в область данных. Например, в следующей сводной таблице поле итогов «Сумма: продажи», добавленное в область данных, отображает итоговые данные для полей «Спорт» и «Квартал».

Пример: поле итогов всводной таблице.

Поле итогов «Сумма: Продажи», добавленное в область данных, отображает итоговые значения для полей «Спорт» и «Квартал».

Можно также добавлять поля итогов в область сведений, если это позволяют исходные данные. Например, чтобы отобразить суммы отдельных продаж в приведенном выше примере, в область сведений можно добавить поле итогов «Сумма: Продажи». Однако поля итогов нельзя добавлять в области фильтров, строк и столбцов.

Функции групповой обработки для полей итогов. Для поля итогов можно использовать любую из четырех функций групповой обработки — сумма (СУММ), количество значений (СЧЁТ), минимум (МИН) и максимум (МАКС). Если позволяют исходные данные и тип поля, то функцию групповой обработки можно изменять, отображая тот или иной тип итогов. Например, если поле содержит текст, то для него можно использовать только функцию СЧЁТ. В некоторых случаях при подведении итогов для одного и того же поля можно добавить несколько полей итогов с различными функциями групповой обработки.

Изменение направления расположения полей итогов . В сводной таблице поля итогов могут вычислять итоги в одном из двух направлений — либо в направлении строк, либо в направлении столбцов. В первом случае поля итогов располагаются в последнем столбце напротив полей строк. Во втором случае поля итогов располагаются в нижней строке под полями столбцов.

Возврат в начало

Промежуточные и общие итоги

Отображение промежуточных и общих итогов. Отображение промежуточных итогов для любого поля строки или поля столбца сводной таблицы возможно в том случае, если в этой таблице существует хотя бы одно поле итогов и не менее двух полей строк или полей столбцов. Если для поля задано отображение промежуточных итогов, то отображаются также общие итоги. Промежуточные и общие итоги отображаются для каждого внесенного в сводную таблицу поля итогов в месте пересечения этого поля итогов с полем строки или полем столбца. См. Отображение промежуточных и общих итогов для поля.

В следующем примере промежуточный и общий итоги подсчитаны по обоим полям строк с использованием значений поля итогов «Сумма: Продажи».

Пример: промежуточный итог и общий итог в сводной таблице.

В этом примере в сводной таблице вычислены промежуточный итог для поля «Квартал» и общий итог для поля «Спорт».

Перемещение и скрытие промежуточных и общих итогов. Если поле, для которого отображены промежуточные или общие итоги, переместить за пределы области строк или столбцов, то промежуточные и/или общие итоги становятся скрытыми, но их параметры не изменяются. При возвращении поля в область строк или столбцов промежуточные и/или общие итоги снова отображаются.

Если скрыть промежуточные или общие итоги поля, то они остаются скрытыми при любых перемещениях этого поля, в том числе при удалении и возвращении поля в сводную таблицу.

Изменение выравнивания относительно сведений. Текст в строках промежуточных и общих итогов можно выровнять либо по левому краю, либо по правому краю, либо по центру. Отличие от выравнивания сведений легко заметить, если отобразить сведения хотя бы одного элемента поля, для которого отображены промежуточные и общие итоги.

Включение и исключение скрытых данных. В некоторых случаях исходные данные и тип данных, используемые всводной таблице, позволяют либо включить в промежуточные и общие итоги скрытые фильтром элементы данных, либо исключить из промежуточных и общих итогов эти данные. При этом все промежуточные и общие итоги будут либо включать, либо исключать скрытые данные.

Возврат в начало


Добавление поля итогов в сводную таблицу

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните поле, содержащее значения, по которым необходимо вычислить итоги.

  3. На панели инструментов сводной таблицы щелкните кнопку Автовычисления [image], затем выберите нужную итоговую функцию.

    Если кнопка Автовычисления недоступна, значит исходные данные сводной таблицы не позволяют добавлять в нее поля итогов. Это происходит, например, если источником данных для сводной таблицы служит база данных OLAP. См. Исходные данные для сводных таблиц.

Примечания

  • После удаления поля итогов из сводной таблицы, оно остается в списке полей, что дает возможность вернуть его сводную таблицу. Для удаления поля итогов одновременно из сводной таблицы и из списка полей, щелкните поле итогов правой кнопкой мыши и выберите в контекстном меню пункт Удалить.

  • Можно также добавлять поля итогов в область данных. Поля итогов нельзя добавлять в области строк, столбцов, сведений, фильтров.


Изменение итоговой функции для поля итогов сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выберите поле итогов, итоговую функцию которого необходимо изменить.

    Инструкции

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Функция итогов не развернут, щелкните панель Функция итогов.

    Если панель Функция итогов недоступна, значит исходные данные сводной таблицы не позволяют изменить функцию итогов. Это происходит, например, если источником данных для сводной таблицы служит база данных OLAP. См. Исходные данные для сводных таблиц.

  5. В списке Функция выберите нужную итоговую функцию для поля итогов.


Функции итогов для сводных таблиц

Команда Автовычисления [image] панели инструментов сводной таблицы используется при создании полей итогов. Она позволяет выбрать следующие функции:

СУММ. Вычисляет сумму значений.

СЧЁТ. Вычисляет количество значений. При этом учитываются также пустые значения, например строки с нулевым количеством знаков (не содержащие знаков), но не учитываются неопределенные значения (отсутствие данных или неизвестные данные).

МИН. Возвращает наименьшее в поле значение.

МАКС. Возвращает наибольшее в поле значение.

Примечание. Список доступных функций итогов зависит от типа данных поля. Например, для поля с датами нельзя использовать функцию СУММ. Если поле содержит текст, то нельзя использовать функции СУММ, МИН и МАКС, но можно использовать функцию СЧЁТ.


Изменение ориентации полей итогов сводной таблицы

Описанные ниже действия отражаются на всех поля итогов сводной таблицы, и не влияют на промежуточные и общие итоги. См. Изменение выравнивания элементов промежуточных и общих итогов относительно подробных сведений.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Итоги не развернут, щелкните панель Итоги.

  5. В списке Ориентация итогов выберите одно из следующего:

    Щелкните Строка, если необходимо отобразить поля итогов в столбце, расположенном справа от столбца с полями строк, либо в крайнем левом столбце, если полей строк нет.

    Щелкните Столбец, если необходимо отобразить поля итогов в строке, расположенной под строкой с полями столбцов, либо в верхней строке, если полей столбцов нет.


Отображение промежуточных и общих итогов для поля сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку или столбец, для которой (которого) требуется отобразить промежуточные и общие итоги.

  3. На панели инструментов сводной таблицы щелкните кнопку Промежуточные итоги [image].

Примечания

  • См. сведения о промежуточных и общих итогах, и полях итогов в сводной таблице.

  • Промежуточные и общие итоги не отображаются для полей, помещенных в область сведений (область, в которой отображаются исходные данные, а не вычисленные с помощью итоговых функций).

  • Если включено отображение промежуточных и общих итогов, то они отображаются для всех полей итогов сводной таблицы. Отключить их отображение для отдельных полей итогов невозможно.

  • Все промежуточные и общие итоги могут либо включать, либо исключать данные, скрытые фильтром.


Изменение выравнивания элементов промежуточных и общих итогов в поле итогов сводной таблицы

Элементы промежуточных и общих итогов для поля итогов являются подписями в строке или столбце промежуточных или общих итогов, например «Сумма: Продажи», «Число продаж». Элементы промежуточных и общих итогов выравниваются относительно других ячеек области сведений. Чтобы видеть изменения в выравнивании, следует отобразить подробные сведения для одного или нескольких элементов поля, для которого отображены промежуточные и общие итоги.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выделите поле итогов, для которого необходимо изменить выравнивание элементов промежуточных и общих итогов.

    Инструкции

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Подпись итогов не развернут, щелкните панель Подпись итогов.

  5. В списке Выравнивание строк выберите необходимое выравнивание по горизонтали (автоматически, по левому краю, по центру или по правому краю).


Включение и исключение скрытых данных из промежуточных и общих итогов сводной таблицы

Описанные ниже действия отражаются на всех промежуточных и общих итогах сводной таблицы.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробные сведения содержатся в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Итоги не развернут, щелкните панель Итоги.

  5. Варианты действий:

    Для включения скрытых данных в итоги установите флажок Итоги по всем элементам.

    Для исключения скрытых данных из итогов снимите флажок Итоги по всем элементам.

Примечания

  • От этого флажка зависит включение и исключение данных, скрытых фильтрацией полей строк и столбцов. Данные, скрытые полями фильтра, исключаются из итогов всегда.

  • После установки флажка Итоги по всем элементам, в промежуточных и общих итогах появляются звездочки, которые указывают, что в итоги включены не только отображенные, но и скрытые элементы данных.


Скрытие промежуточных и общих итогов для поля сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку или столбец, для которой (которого) требуется скрыть промежуточные и общие итоги.

  3. На панели инструментов сводной таблицы отожмите кнопку Промежуточные итоги [image].


Отображение сведений для итоговых данных в сводной таблице

Инструкции

Выбор сведений для отображения

Отображение индикаторов развертывания рядом с элементами.

Развертывание данных для отображения их нижнего уровня.

Отображение подробных сведений для элемента или ячейки.

Автоматическое отображение подробных сведений для всех элементов.

Отображение элементов, не содержащих данных.

Определение порядка отображения сведений

Установка размера области сведений.

Запрет на отображение дополнительных сведений в обозревателе.

Пояснения.


Об отображении сведений для итоговых данных в сводной таблице

Сводную таблицу разрешено настраивать таким образом, чтобы она показывала любую степень детализации исходных данных. Можно подробно отобразить все данные, либо только итоговые вычисления верхнего уровня, а также любой другой промежуточный уровень детализации данных. Есть возможность показать для элементов данных выделенные сведения, которые необходимо подчеркнуть. До тех пор, пока доступ не будет ограничен, пользователи могут изменять сводную таблицу в обозревателе, отображая различные уровни и степени детализации данных.

Выбор сведений для отображения

Индикаторы развертывания. Чтобы изменить уровень детализации каждого из элементов данных, отображаемых в поле, используйте индикаторы развертывания. Они представляют собой прямоугольные значки Плюс и Минус появляющиеся перед элементами. Например, если поле строки с названием «Продукты» включает элементы «Молоко» и «Мясо», индикаторы развертывания будут выглядеть следующим образом:

Пример индикаторов развертывания

Можно показать индикаторы развертывания, если они были скрыты. Если же для определенного элемента индикаторы развертывания так и не появились, вероятно этот элемент является нижним уровнем детализации доступным для данного источника данных.

Отображение данных нижнего уровня. Если индикаторы развертывания включены, перед элементами, имеющими отображаемые данные нижнего уровня, появляется значок Плюс . Можно отображать данные нижнего уровня для всего поля или для отдельных элементов, разворачивая только те из них, которые необходимо показать.

Отображение подробных сведений. Сводная таблица, в которой все поля находятся в области сведений, дает подробное, развернутое представление всех строк и столбцов исходных данных. Например, такие подробные сведения могут отображать записи отдельных счетов. При перемещении полей из области сведений в области строк и столбцов, можно создавать итоговые вычисления данных или отображать конкретные подробные строки или записи, образующие итоговые значения элемента или ячейки. Подробные сведения могут отображаться только в том случае, если они существуют в исходных данных. Например, базы данных OLAP часто содержат только итоговые, а не подробные данные. См. Исходные данные для сводных таблиц.

По умолчанию, подробные сведения не показываются в обозревателе сразу после добавления полей к сводной таблице, но при необходимости, можно установить автоматическое отображение подробных сведений для всех элементов.

Если в отображении подробных сведений нет надобности, можно скрыть их.

Отображение итогов верхнего уровня. Перед элементами, отображающими данные нижнего уровня, выводится значок Минус . Можно свернуть эти элементы, если необходимо отобразить только данные верхнего уровня.

Элементы, не имеющие данных. По умолчанию, сводная таблица не отображает элементы, исходные данные которых не имеют значений. Например, если показывается распределение продаж по месяцам, а в Апреле продаж не было, поле “Месяц” не будет содержать элемента “Апрель”. При необходимости включить элементы всех двенадцати месяцев с пустыми значениями для тех из них, в которых не было продаж, можно отобразить элементы не имеющие данных.

Определение порядка отображения сведений

Настройка размера области сведений. При отображении подробных сведений для элемента или ячейки, чтобы отобразить строки этих данных, область сведений разворачивается внутри сводной таблицы. По умолчанию, эта развернутая область принимает размер, необходимый для требуемых данных, но с учетом ограничений, установленных для размера сводной таблицы в целом. Чтобы указать, как много свободного пространства области сведений разрешено использовать для отображения подробных сведений в обозревателе, можно установить максимальный размер области сведений и высоту строки.

Ограничение доступа к подробным сведениям в обозревателе. Можно задать отображаемым данным необходимые уровень и степень детализации, а затем запретить пользователям отображать дополнительные подробности в обозревателе.

Экспорт в Microsoft Excel открывает доступ ко всем сведениям. Любые ограничения установленные для просмотра данных, в Excel не действуют. Путем экспорта сводной таблицы из обозревателя в Excel, пользователи получают возможность просмотра исходных данных во всех подробностях. Чтобы запретить доступ пользователей к подробным сведениям таким способом, можно ограничить доступ к команде обозревателя Экспорт в Excel, отключив панель инструментов, а также ограничив доступ к панели свойств сводной таблицы. См. Ограничение доступа к сводной таблице в обозревателе.


Изменение размеров области сведений и высоты строк в сводной таблице

Область сведений — это та часть сводной таблицы, в которой отображаются подробные сведения. Если сведения отображены для нескольких элементов данных, в сводной таблице может быть несколько областей сведений. Изменение размера области сведений выполняется независимо от изменения размера сводной таблицы как единого целого.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Формат области сведений не развернут, щелкните панель Формат области сведений.

  5. Варианты действий:

    Чтобы размер области сведений изменялся автоматически так, чтобы полностью вместить отображаемые данные, установите флажок Автоподбор области сведений. Если для размера области необходимо установить пределы, введите значения (в пикселах) в поля Максимальная высота и Максимальная ширина.

    Если необходимо зафиксировать размеры области сведений, снимите флажок Автоподбор ширины области сведений, затем введите ширину (в пикселах) в поле Ширина области сведений.

  6. Если требуется зафиксировать высоту всех строк в области сведений введите высоту (в пикселах) в поле Высота строки сведений.

Примечания

  • Изменить эти параметры в обозревателе невозможно.

  • Есть также возможность изменить размеры всей сводной таблицы.


Отображение индикаторов развертывания возле элементов данных сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выделите сводную таблицу.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Отображение не развернут, щелкните панель Отображение.

  5. Щелкните кнопку Индикаторы развертывания [image].

Примечания

  • У элементов данных, не имеющих данных более нижнего уровня, не могут иметь индикаторов развертывания.

  • Если необходимо запретить пользователям отображать и скрывать индикаторы развертывания, запретите доступ к панели свойств сводной таблицы в обозревателе.


Автоматическое отображение подробных сведений для всех элементов сводной таблицы

Подробные сведения для элементов в обозревателе по умолчанию скрыты, но пользователь может отобразить их для поля, щелкнув значок Развернуть [image].

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  5. В списке Развертывать элементы по умолчанию выберите Всегда.

Примечания.

  • Чтобы скрыть подробные сведения для всех элементов, выберите Никогда или Автоматически в списке Развертывать элементы по умолчанию.

  • Изменить эти параметры в обозревателе невозможно.

  • Обычно подробные сведения не отображаются в сводных таблицах, источниками данных для которых служат базы данных OLAP. Если подробные сведения недоступны, изменение параметра Развертывать элементы по умолчанию не повлияет на отображение данных. См. Исходные данные для сводных таблиц.


Развертывание элемента в сводной таблице для отображения подробностей

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Убедитесь, что индикаторы развертывания отображены.

  3. Щелкните индикатор Плюс того элемента, для которого требуется показать подробности.

Примечания.

  • Чтобы развернуть все элементы поля, выберите подпись поля, а затем щелкните кнопку Развернуть [image] в панели инструментов сводной таблицы.

  • Если у элемента нет индикатора развертывания, он, вероятно, является самым нижним уровнем детализации исходных данных. Если позволяют исходные данные, можно отобразить подробные сведения для элементов самого нижнего уровня. См. Исходные данные для сводных таблиц.

  • Если требуется запретить пользователям разворачивать элементы ниже установленного уровня, можно ограничить доступ к сведениям в обозревателе.


Отображение сведений для элемента или ячейки сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните элемент данных или ячейку, сведения которой необходимо просмотреть.

  3. На панели инструментов сводной таблицы щелкните кнопку Развернуть [image].

Примечания

  • Если кнопка Развернуть [image] недоступна, то элемент данных или ячейка находятся на самом нижнем уровне исходных данных, либо нижний уровень исходных данных недоступен. Например, сводная таблица, исходные данные для которой извлекаются из базы данных OLAP, позволяет просматривать различные уровни данных, но чаще всего для просмотра доступны лишь уровни итоговых данных, а не самый нижний уровень подробных сведений. См. Исходные данные для сводных таблиц.

  • Если требуется запретить пользователям просматривать подробные сведения, то следует ограничить доступ к сведениям в обозревателе.


Отображение в сводной таблице элементов, не содержащих данных

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Отображать пустые элементы не развернут, щелкните панель Отображать пустые элементы.

  5. Для отображение элементов поля сроки, не содержащих данных, установите флажок Строка.

    Для отображение элементов поля столбца, не содержащих данных, установите флажок Столбец.


Сворачивание элемента в сводной таблице для скрытия подробностей

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Убедитесь, что индикаторы развертывания отображены.

  3. Щелкните индикатор Минус того элемента, для которого требуется скрыть подробности.


Скрытие сведений в сводной таблице

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните элемент данных, для которого подробные сведения отображены.

  3. На панели инструментов сводной таблицы щелкните кнопку Свернуть [image].

Примечание. Чтобы скрыть сведения для всех элементов поля, щелкните это поле, затем — кнопку Свернуть [image].


Запрет доступа к дополнительным сведениям сводной таблицы

Описанным ниже способом можно запретить отображение в обозревателе тех сведений, которые не отображены в сводной таблице. Однако такой запрет приводит к невозможности отображения дополнительных сведений и в программе-конструкторе.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  5. Снимите флажок Разрешить сведения.

Примечания

  • Изменить эту установку в обозревателе невозможно.

  • Это ограничение не действует в Excel. Путем экспорта сводной таблицы из обозревателя в Excel можно просмотреть все сведения, содержащиеся в исходных данных. Чтобы запретить пользователям такой способ доступа к сведениям, следует запретить доступ к команде обозревателя Экспорт в Excel, отключив панель инструментов, а также ограничив доступ к панели свойств сводной таблицы. См. Запреты при работе со сводной таблицей в обозревателе.


Сортировка данных в сводной таблице

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробные сведения содержатся в справке программы-конструктора.

  2. Варианты действий:

    Для сортировки данных поля по подписям элементов данных щелкните подпись этого поля.

    Для сортировки данных поля по итоговым значениям, содержащимся в столбце, щелкните ячейку этого столбца.

    Для сортировки данных поля по промежуточным или общим итогам, щелкните значение промежуточного или общего итога для этого поля. Если щелкните значение общего итога в самой нижней строке сводной таблицы, то будет выполнена сортировка столбцов, а не строк.

  3. На панели инструментов сводной таблицы выполните следующее:

    Для сортировки по алфавиту, а чисел — по возрастанию, нажмите кнопку Сортировка по возрастанию [image].

    Для сортировки в обратном порядке нажмите кнопку Сортировка по убыванию [image].

Примечания

  • Чтобы отменить сортировку и вернуть прежний порядок расположения данных, отожмите кнопку Сортировка по возрастанию [image], либо кнопку Сортировка по убыванию [image].
  • Порядок сортировки чисел, текста и специальных символов зависит от исходных данных и национальных стандартов, установленных с помощью панели управления Windows в разделе «Язык и стандарты». В обозревателях с различными национальными стандартами сортировка данных может привести к различным результатам.

  • Если исходные данные сводной таблицы хранятся в базе данных OLAP, то при сортировке полей промежуточных уровней сортируются только текущий и нижние уровни, а более высокие уровни не сортируются. Высшие уровни определяют способ сортировки элементов нижних уровней. См. Разрешение вопросов при сортировке данных из баз данных OLAP.

  • Для сортировки по нескольким столбцам следует выполнить сортировку в каждом столбце по отдельности.


Сортировка данных по нескольким столбцам сводной таблицы

Для сортировки данных по нескольким столбцам следует выполнить сортировку отдельно по каждому столбцу. Порядок сортировки столбцов зависит от способа организации данных.

Пример: сортировка данных по двум столбцам.

В приведенном примере за основу организации данных в таблице взят столбец «Продавец». Вначале сортировка в алфавитном порядке выполнена в столбце «Товар», затем — в столбце «Продавец».

Прежде чем сортировать несколько столбцов, следует определить порядок сортировки столбцов. Первым сортируется внутренний столбец, последним — внешний столбец. В приведенном примере для сортировки товаров в алфавитном порядке для каждого продавца вначале была выполнена сортировка во внутреннем столбце «Товар», затем — во внешнем столбце «Продавец».

Сортировка данных в сводной таблице.


Фильтрация сводной таблицы для отображения определенных данных

Инструкции.

Фильтровать поле для отображения только требуемых данных.

Отображать только совпадающие с ячейкой данные.

Добавить новое поле фильтра.

Использовать существующее поле как поле фильтра.

Запретить изменение фильтров сводной таблицы пользователями обозревателя.

Пояснения.


Фильтрация данных в сводной таблице

Для сводных таблиц нет команды «Поиск». Здесь поиск данных выполняется с помощью фильтра и сортировки. Сортировку и фильтрацию с использованием полей и команд можно выполнять как при создании сводной таблицы программой-конструктором, так и во время ее просмотра в обозревателе. Однако некоторые возможности фильтрации в обозревателе могут быть ограничены на этапе создания сводной таблицы.

Поиск данных с помощью фильтра. Фильтр помогает быстро найти в сводной таблице требуемое подмножество данных. Фильтр применим к полям в областях строк, столбцов и сведений. Чтобы профильтровать поле, необходимо развернуть те элементы данных, которые необходимо просмотреть, и скрыть остальные элементы данных.

Примеры фильтрации сводной таблицы.

В первой сводной таблице фильтр поля «Спорт» отображает только продажи для группы товаров «Гольф». Во второй таблице профильтровано также поле «Квартал», в результате чего отображаются только продажи группы товаров «Гольф» в третьем квартале.

При включении фильтра поля сводной таблицы, черная стрелка раскрывающегося списка Стрелка поля становится синей, а кнопка Автофильтр [image] на панели инструментов сводной таблицы — нажатой.

Выбор элементов в нескольких полях. Фильтрация особенно полезна при работе с большими объемами исходных данных, когда требуется просмотреть небольшую часть данных, удовлетворяющих заданным условиям. Для фильтрации поля можно развернуть либо один его элемент, либо несколько элементов, а остальные — скрыть. Чтобы еще больше сузить подмножество данных, можно профильтровать несколько полей одновременно. См. Фильтрация поля.

Фильтрация по данным одной ячейки. Для фильтрации поля предусмотрена возможность отобразить только данные, соответствующие значению выделенной ячейки. Фильтр по выделенному особенно полезно применять для полей в области сведений в случае, когда необходимо просмотреть все строки, содержащие заданное значение.

Отключение фильтра. Для отображения данных всех полей сводной таблицы следует отключить фильтрацию. При этом настройки фильтра сохраняются, то есть при повторном включении фильтра скрываются те же данные, которые были скрыты до отключения фильтра. Настройки фильтра сохраняются также при перемещении полей для изменения макета сводной таблицы.

Фильтрация накапливается. Это означает, что при включении фильтра нажатием кнопки Автофильтр [image] все фильтры действуют одновременно. Например, если применить фильтр для какого-либо поля, затем применить фильтр по выделенному для другого поля, то отображенными останутся лишь те данные, которые удовлетворяют условиям всех этих фильтров. Фильтры действуют постоянно, до их отключения. Для удаления существующих фильтров и создания новых следует вначале отключить фильтрацию, а затем выбрать для фильтрации новые элементы.

Фильтрация всей сводной таблицы с помощью поля фильтра. Для фильтрации также служат поля фильтров. При выборе какого-либо элемента поля фильтра в сводной таблице отображаются и вычисляются лишь данные, соответствующие этому элементу. В сводную таблицы можно добавлять новые поля фильтров. Существующие поля можно перемещать в область фильтров.

Зависимость вычислений от фильтрации. В итоги можно включить либо только отображаемые данные, либо все данные списка сводной таблицы, включая скрытые. По умолчанию в итоги не включаются скрытые данные. Исключение из этого правила составляют сводные таблицы, для которых источником данных служат базы данных OLAP, а также опубликованные из Microsoft Excel сводные таблицы, содержащие скрытые данные в общих итогах. См. Типы исходных данных. Эту настройку можно изменить, то есть включить в итоги и исключить из итогов скрытые данные. Эти изменения касаются только данных, скрытых фильтрацией полей строк и полей столбцов. Данные, скрытые полями фильтров, исключаются из итогов всегда.

Запрещение пользователям изменять фильтрацию. Если необходимо лишить пользователей возможности изменять фильтрацию данных, то следует запретить фильтрацию в обозревателе.


Фильтрация поля в сводной таблице

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните стрелку раскрывающегося списка Стрелка поля в поле, содержащем элементы данных, которые нужно профильтровать.
  3. Установите флажки для тех элементов данных, которые нужно отобразить, и снимите флажки для тех элементов данных, которые нужно скрыть.

Примечания

  • Чтобы отобразить или скрыть сразу все данные поля, соответственно установите или снимите флажок Показать все.

  • Затененное поле флажка свидетельствует о том, что часть или все элементы нижнего уровня скрыты. Для просмотра скрытых элементов щелкните значок Плюс возле элемента с затененным флажком.
  • Для отображение всех данных всех полей отожмите кнопку Автофильтр [image]. Параметры фильтра при этом сохраняются, поэтому после нажатия кнопки Автофильтр поля фильтруются ранее установленным способом. Если параметры фильтра запоминаться не должны, то прежде чем выбирать параметры фильтра, следует отжать кнопку Автофильтр. В случае выбора новых элементов автоматически включается фильтрация и сбрасываются прежние параметры фильтра.

  • После перемещения отфильтрованного поля, параметры фильтра для этого поля сохраняются, если оно перемещается в область данных или область фильтров, где элементы не скрыты. Это означает, что при возврате поля в область строк, область столбцов или область сведений, фильтр будет работать прежним образом, то есть ранее скрытые элементы снова будут скрыты. Если удалить поле из макета, а затем вновь добавить поле в макет, то будут скрыты те же самые элементы, которые были скрыты до удаления поля. Признаком того, что в поле есть скрытые фильтром элементы, является синий цвет стрелки раскрывающегося списка Стрелка поля в подписи поля.
  • Если необходимо запретить пользователям пользоваться этими возможностями, запретите фильтрацию в обозревателе.


Отображать в сводной таблице только совпадающие с ячейкой данные

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните правой кнопкой мыши ячейку, содержащую требуемое для отображения значение, а затем выберите команду Фильтровать по выделению в контекстном меню.

Примечания.

  • После перемещения отфильтрованного поля, параметры фильтра для этого поля сохраняются, если оно перемещается в область данных или область фильтров, где элементы не скрыты. Это означает, что при возврате поля в область строк, область столбцов или область сведений, фильтр будет работать прежним образом, то есть ранее скрытые элементы снова не будут отображены. Если удалить поле из макета, а затем вновь добавить поле в макет, то будут скрыты те же самые элементы, которые не отображались до удаления поля. Признаком того, что в поле есть скрытые фильтром элементы, является синий цвет стрелки раскрывающегося списка Стрелка поля в подписи поля.
  • Если нажата кнопка Автофильтр [image] на панели инструментов, фильтрация по выбору накапливается; то есть, к ранее действующим фильтрам добавляются новые. Если же кнопка Автофильтр не нажата, фильтрация по выделению автоматически удаляет любые ранее установленные фильтры и начинает фильтрацию с новым накоплением фильтров.

  • Для отображение всех данных всех полей отожмите кнопку Автофильтр [image]. Параметры фильтра при этом сохраняются, поэтому после нажатия кнопки Автофильтр поля фильтруются ранее установленным способом. Если параметры фильтра запоминаться не должны, то прежде чем выбирать параметры фильтра, следует отжать кнопку Автофильтр. В случае выбора новых элементов автоматически включается фильтрация и сбрасываются прежние параметры фильтра.

  • Если доступ пользователей к этим командам нежелателен, можно запретить фильтрацию в обозревателе.


Отключение фильтров для отображения в сводной таблице всех данных

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов сводной таблицы отожмите кнопку Автофильтр [image].

Примечания

  • Следующий щелчок нажмет кнопку Автофильтр [image], что приведет к восстановлению прежней фильтрации.

  • Если требуется запретить пользователям отключать фильтры, запретите доступ к командам фильтрации в обозревателе.


Запрет на изменение фильтрации сводной таблицы пользователями

Описанным ниже способом можно запретить пользователям изменять фильтрацию сводной таблицы в обозревателе. Этот запрет распространяется также на программу-конструктор.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  5. Установите флажок Блокировать фильтры.

Примечание. Изменить этот параметр в обозревателе невозможно.


Форматирование сводной таблицы

Инструкции

Форматирование ячеек и данных

Выделение частей сводной таблицы для форматирования.

Выбор шрифта и стиля текста.

Выбор цвета фона ячеек.

Выравнивание текста в ячейке.

Отображение сводной таблицы справа налево.

Изменение формата чисел.

Задание формата для отдельного элемента сводной таблицы.

Изменение формата заголовков и подписей

Отображение и скрытие строки названия.

Изменение подписей и имен.

Изменение формата строки названия.

Изменение формата полей, промежуточных и общих итогов

Отображение полей итогов горизонтально, либо вертикально.

Изменение выравнивания элементов промежуточных и общих итогов в поле.

Изменение формата областей

Скрытие областей.

Изменение формата подписей областей.

Пояснения.


О форматировании сводной таблицы

Средства форматирования сводной таблицы

Скрытие областей. Специальные текстовые области, такие как «Перетащите сюда поля фильтра», в которые перетаскиваются поля фильтров, столбцов и строк, используются для изменения макета сводной таблицы. При необходимости эти области можно скрыть, например, чтобы при печати сводной таблицы не вывести находящийся в ней текст. Если области скрыты, то все области, не содержащие полей, будут удалены из таблицы как в программе-конструкторе, так и в обозревателе. Например, если в сводной таблице нет полей фильтров, то область фильтров будет скрыта.

Форматирование подобных элементов. Изменение формата одного элемента может отразиться на формате подобных ему элементов. Например, если изменить цвет текста какого-либо итога, то все итоги в сводной таблице приобретут новый цвет. Любой элемент таблицы автоматически переформатируется при переносе его в новую область таблицы. Например, при перемещении поля сведений в область строк оно потеряет свой прежний формат и приобретет тот формат, который установлен для области строк. См. Выбор элементов сводной таблицы для форматирования.

Задание формата текста. При работе со сводной таблицей можно изменять шрифт, размер шрифта, цвет текста, а также выбирать начертание текста на полужирное, курсив и подчеркивание. Формат текста в сводной таблице не зависит от параметров шрифта и его цвета в обозревателе. См. Изменение формата текста.

Выравнивание текста в ячейке. Запись данных в ячейке можно выровнять либо по центру, либо по левому или правому краю ячейки. Выравнивание текста по вертикали внутри ячейки задается автоматически и не изменяется. См. Выравнивание текста в ячейке. Есть также возможность выравнивания записей промежуточных и общих итогов относительно сведений.

Выбор цвета фона. Позволяет изменять цвет фона ячеек. Цвет фона в сводной таблице не зависит от настройки цвета в обозревателе.

Изменение формата чисел. Позволяет выбирать форматы чисел, дат и времен, отображенных в полях сводной таблицы, из стандартных форматов чисел. Например, число можно представить в виде процентов или денежной единицы, а календарную дату — отобразить либо в длинном формате с названием месяца и дня недели, либо в сокращенном формате. Изменение числовых форматов не затрагивает значения данных, а только преобразует их вид. Настройки, установленные в диалоговом окне Свойства: Язык и стандарты панели управления Windows, влияют на отображение числовых форматов в сводной таблице. См. Изменение формата чисел.

Форматирование элементов сводной таблицы

Чтобы все элементы сводной таблицы приняли нужный вид, необходимо временно изменить макет таблицы, чтобы отформатировать те элементы, которые не войдут в окончательную таблицу. Например, чтобы задать какому-либо полю формат области сведений при отсутствии поля сведений в первоначальном макете таблицы, нужно это полеперетащить в область сведений, отформатировать и вернуть на прежнее место. Перемещение полей в различные области сводной таблицы из обозревателя автоматически задает перемещаемым полям и их данным новые форматы, действующие в каждой из этих областей.

Выбор форматов текста и фона для всех элементов сводной таблицы производится следующим образом: сначала выделяется форматируемый элемент таблицы, после чего над ним проводится ряд последовательных операций, общих для всех форматов.

Выбор элементов сводной таблицы.

Выбор формата текста и цвета фона ячеек.

Форматирование сводной таблицы

  1. Выберите поле в области строк, столбцов или фильтров, затем выберите нужные формат текста и фон для подписей поля.

  2. Выберите элемент данных в поле строки или столбца, затем выберите формат, выравнивание текста и фон подписей элементов, полей сведений, промежуточных итогов, общих итогов и полей итогов.

    См. Выравнивание по горизонтали.

  3. Выберите поле итогов, затем задайте формат и выравнивание текста, фон и формат чисел для ячеек в полях итогов.

    Если в сводной таблице отсутствуют поля итогов, можно создать поле итогов, отформатировать его и переместить за пределы макета таблицы.

    См. сведения об изменении формата чисел для данных.

  4. Выберите общий итог поля, установите нужные формат текста и фон ячеек с промежуточными и общими итогами этого поля.

    Чтобы вывести на экран общий итог для какого-либо поля, перетащите это поле в область строк или область столбцов. В этом случае промежуточные и общие итоги этого поля будут отображены в сводной таблице.

  5. Если исходные данные позволяют выводить на экран подробные сведения, установите выравнивание элементов промежуточных и общих итогов относительно сведений для каждого поля итогов.

  6. Если исходные данные позволяют выводить на экран подробные сведения, переместите поле в область сведений, затем выберите для него фон, формат текста и чисел, выравнивание по горизонтали.

  7. Выделите всю сводную таблицу и выберите фон области, расположенной над полями строк и слева от полей столбцов. Выберите фон и формат текста строки названия.

  8. Отображение областей и выбор фона и формата текста областей.


Выделение элементов сводной таблицы

На панели свойств сводной таблицы в разделе Общие в поле Выделение отображается название выделенного элемента сводной таблицы. Панель свойств вызывается щелчком значка Панель свойств [image] на панели инструментов сводной таблицы. См. сведения об элементах сводной таблицы.

Выделение нескольких элементов. Выделение нескольких элементов в некоторых случаях невозможно. Например, невозможно выделить несколько полей. Однако формат, выбранный для одного элемента, обычно распространяется на все подобные элементы сводной таблицы, как описано в следующей таблице.

Выделение | Действие
Вся сводная таблица. | Щелкните строку названия. Если у сводной таблицы нет строки названия, щелкните правой кнопкой мыши сводную таблицу, затем в появившемся контекстном меню щелкните пункт Панель свойств. Щелкните панель Отображение, затем — кнопку Строка названия [image] . Прежде чем отобразить строку названия, необходимо добавить в сводную таблицу данные.
Ячейки. | Щелкните ячейку. Для выделения нескольких ячеек щелкните по одной из них, затем проведите указателем мыши по остальным ячейкам, не отпуская кнопку мыши. Невозможно изменить формат только одной ячейки, не изменив формат связанных с ней ячеек.
Строка, столбец, поле фильтра. | Щелкните подпись поля. Выделение поля строки или поля столбца вызывает выделение всех элементов данных этого поля. Изменение формата одного поля затрагивает все подписи полей строк, столбцов и фильтров сводной таблицы.
Поле сведений. | Щелкните подпись поля. Если сведения отображены для нескольких элементов данных, из-за чего отображается несколько экземпляров подписи поля, то выделение одного экземпляра подписи поля вызывает выделение всех экземпляров. Изменение формата поля сведений отражается на ячейках данных только этого поля.
Поле итогов. | Щелкните любую подпись поля итогов. Чтобы отобразить подписи поля итогов, необходимо переместить хотя бы одно поле в область строк или область столбцов. Иногда также требуется скрыть подробные сведения для полей строк и столбцов. Изменение формата поля итогов на формате ячеек данных только этого поля, а также на формате всех полей итогов сводной таблицы. Для изменения формата подписи поля итогов выделите элемент данных поля строки или столбца. См. пример поля итогов.
Элемент данных поля. | Щелкните подпись элемента. При этом постарайтесь не задеть индикатор развертывания Плюс или Минус . Выделение элемента данных вызывает выделение всех данных этого элемента. Изменение формата одного элемента данных вызывает изменение формата всех подписей элементов, полей данных, полей промежуточных и общих итогов, а также подписей полей итогов сводной таблицы.
Промежуточный или общий итог. | Щелкните промежуточный или общий итог. Выделение одного промежуточного или общего итога вызывает выделение всех данных, использованных при вычислении этого промежуточного или общего итога. Изменение формата промежуточного или общего итога приводит к изменению формата всех ячеек данных, используемых при вычислении промежуточных и общих итогов для поля строки или столбца. Для изменение формата подписей промежуточных и общих итогов выделите элемент данных поля строки или столбца. См. пример промежуточных и общих итогов.


Изменение шрифта и стиля текста для данных в сводной таблице

Задать шрифт и стиль сразу для всей сводной таблицы в одно действие невозможно. Однако формат, заданный для одного элемента таблицы, обычно распространяется на все элементы такого же типа.

Для изменения шрифта и стиля необходимо выделить поле строк, столбцов или фильтра; либо элемент данных в поле строки или столбца; либо поле итогов. Если для поля строк или столбцов отображаются промежуточные или общие итоги, их формат тоже можно изменять. Если в сводной таблице отображены поля сведений, то формат каждого из полей задается независимо от других полей.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выберите элемент, формат которого необходимо изменить.

    Инструкции

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. Выберите необходимые параметры формата.

    Чтобы выбрать полужирный шрифт, щелкните кнопку Полужирный [image].

    Чтобы выбрать курсив, щелкните кнопку Курсив [image].

    Чтобы подчеркнуть текста, щелкните кнопку Подчеркнутый [image].

    Чтобы изменить цвет текста, щелкните стрелку справа от кнопки Цвет шрифта [image] и выберите нужный цвет.

    Шрифт выбирается в списке, который раскрывается щелчком кнопки Шрифт.

    Размер шрифта выбирается в списке Шрифт.

Примечания

  • Если цвет текста совпадет с цветом фона, то текст станет невидимым.

  • В списках шрифтов и их размеров содержатся только те шрифты и размеры, которые установлены в системе компьютера.


Выравнивание текста в ячейке сводной таблицы

Задать способ выравнивания одним действием сразу для всей сводной таблицы невозможно. Однако выравнивание, заданное для отдельного элемента таблицы, в большинстве случаев распространяется на все элементы подобного типа.

Чтобы задать способ выравнивания текста для всех тех элементов сводной таблицы, выравнивание которых допустимо изменять, следует изменить выравнивание для отдельного элемента данных в поле строки или столбца, а также для поля итогов. Если сводная таблица может отобразить поля сведений, то можно выбрать различные способы выравнивания текста для различных полей сведений.

Для подписей полей строк, полей столбцов и полей фильтров изменить выравнивание по горизонтали нельзя.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выберите элемент, который необходимо изменить.

    Инструкции

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. В списке Выравнивание по горизонтали выберите способ выравнивания: По левому краю, По центру, По правому краю или Автоматически. При автоматическом выравнивании числа и даты выравниваются по правому краю, а текст — по левому краю.

Примечание. Можно также изменить выравнивание элементов промежуточных и общих итогов относительно сведений.


Выбор цветов фона для ячеек сводной таблицы

Нельзя установить цвет фона для всех элементов сводной таблицы одной операцией. Однако, в большинстве случаев, цвета выбранные для одного элемента применяются ко всем элементам того же типа. Например, поля строк, столбцов и фильтра это один тип элементов, так что когда будет выбран цвет для подписей полей фильтра, подписи поле строк и столбцов приобретут тот же цвет.

Чтобы задать цвета фона для всех элементов сводной таблицы, поочередно выберите и установите цвет фона для всей таблицы; для полей строк, столбцов или фильтра; для элементов данных в полях строк или столбцов; для полей итогов. Для каждого поля строк или столбцов, для которых отображены промежуточные или общие итоги, установите цвет фона для этих итогов. Если сводная таблица может отображать подробные сведения, установите цвет фона для каждого из полей сведений по отдельности.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выберите элемент, который необходимо изменить.

    Инструкции

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. Щелкните стрелку раскрывающегося списка Цвет фона, [image] а затем выберите необходимый цвет.

Примечание. Если цвет фона будет выбран таким же как и цвет текста, невозможно будет увидеть этот текст.


Изменение подписей и имен в сводной таблице

В сводной таблице можно изменить ее название, имена полей, их элементов данных, а также имена полей итогов. Эти изменения не затрагивают исходные данные.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выберите подпись или имя, которые необходимо изменить.

    Инструкции

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Подписи не развернут, щелкните панель Подписи.

  5. Введите в поле Подпись новое имя.

Примечание. Для изменения текста строки названия щелкните ее, затем введите новое название в поле Название сводной таблицы. Это поле находится на панели свойств в разделе Формат.


Изменение ширины столбца сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Задержите указатель мыши на правой границе подписи поля, чтобы указатель принял следующий вид Указатель с двумя горизонтальными стрелками.

  3. Варианты действий:

    Перетащите границу до нужной ширины столбца.

    Чтобы ширина столбца приняла значение, соответствующее ширине данных, дважды щелкните границу столбца.

Примечание. Есть также возможность изменить высоту всех строк в области сведений. Высоту строк вне области сведений изменить нельзя.


Изменение формата чисел в сводной таблице

Формат чисел можно изменять в полях сведений и полях итогов. Для изменения формата чисел в областях строк, столбцов и фильтров необходимо временно переместить поле в область сведений (если это позволяют исходные данные), изменить формат его чисел, а затем переместить это поле обратно.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните поле сведений или поле итогов, формат чисел которых необходимо изменить.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. Выберите требуемый формат чисел в списке Формат чисел.

    См. сведения о форматах чисел.


Форматы чисел для сводных таблиц

Национальные стандарты, заданные в диалоговом окне Свойства: Язык и стандарты панели управления Windows, определяют способ отображения чисел, денежных единиц, дат и времени в программах-конструкторах и в обозревателе. Например, в зависимости от этих стандартов год отображается с двумя или четырьмя цифрами. Дополнительные сведения об этих форматах содержатся в справке системы Windows.

В Microsoft Visual Basic или в сценариях данным можно назначать нестандартные форматы чисел. Дополнительные сведения смотрите в справке по написанию сценариев и программ для сводных таблиц.

Из списка Формат чисел в разделе Формат на панели свойств сводной таблицы можно выбрать следующие форматы чисел.

Формат | Описание
Основной | Этот формат отображает число с выравниванием по правому краю без разделителя разрядов. Перед отрицательным числом ставится знак минус. Отображает до 11 цифр без точки, либо до 10 цифр с разделителем целой и дробной части. Число, содержащее более 11 цифр перед разделителем целой и дробной части, отображается в экспоненциальном формате. Текст выравнивается по левому краю.
Полный формат даты | Отображает число как дату и/или время. Например: число 36403,24583 отображается как 8/31/99 05:54 AM. Дробная часть числа считается временем. Если число не содержит дробной части, отображается только дата. Если число содержит только дробную часть, отображается только время.
Длинный формат даты | Отображает дату, используя длинный формат даты, заданный в разделе «Язык и стандарты» панели управления Windows. Пример: четверг, 25 января, 2001.
Средний формат даты | Отображает дату, разделяя месяц и число в соответствии с национальными стандартами, принятыми в Windows. Для года отводятся две цифры. Пример: 25 янв 01.
Краткий формат даты | Отображает дату, используя краткий формат даты, заданный в разделе «Язык и стандарты» панели управления Windows. Пример: 1/25/01.
Длинный формат времени | Отображает время, используя длинный формат времени, заданный в разделе «Язык и стандарты» панели управления Windows. Пример: 8:45:36 PM.
Средний формат времени | Отображает время суток в 12-часовом формате с указателем AM или PM, без указания секунд. Пример: 8:45 PM.
Краткий формат времени | Отображает время суток в 24-часовом формате, без указания секунд. Пример: 20:45.
Денежный | Отображает число в соответствии с национальными стандартами, заданными в разделе «Язык и стандарты» панели управления Windows, с разделителем групп разрядов и двумя десятичными знаками. Например, для русского языка по умолчанию принят стандарт, в соответствии с которым денежная сумма отображается в виде 2,532.75 р.
Евро | Отображает число как денежную сумму, выраженную в евро, с разделителями групп разрядов и двумя десятичными знаками. Знак евро помещается перед числом или после числа в соответствии с национальными стандартами для денежных единиц, установленным на панели управления Windows. Пример, соответствующий национальным стандартам английского языка, США: 12.35.
Фиксированный | Отображает число с двумя десятичными знаками. Пример: 68,30.
Стандартный | Отображает число с разделителем групп разрядов и двумя цифрами справа от десятичного разделителя. В качестве разделителя групп разрядов обычно используется точка или запятая в зависимости от национальных стандартов, заданных с помощью панели управления Windows в разделе «Язык и стандарты». Пример использования точки в качестве разделителя групп разрядов: 1.800,00.
Процентный | Отображает число, умноженное на 100, с двумя десятичными знаками и знаком процента. Например, число 0,8914 отображается как 89,14%.
Экспоненциальный | Отображает числа в экспоненциальном представлении. Пример: 1,25E+10.
Логический | Отображает «Нет», если число равно 0, а во всех остальных случаях — «Да».
Истина/ложь | Отображает «Ложь», если число равно 0, во всех остальных случаях — «Истина».
Вкл/Выкл | Отображает «Выкл», если число равно 0, в остальных случаях — «Вкл».


Скрытие областей сводной таблицы

Скрытие областей делает их невидимыми как в программе-конструкторе, так и при просмотре в обозревателе. Когда области скрыты, а сводная таблица уже не содержит ни одной области строк, столбцов, данных или фильтра, переместить другие поля в эти области нельзя. Между тем, еще можно будет добавлять и перемещать поля с помощью кнопок панели инструментов сводной таблицы.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  3. Если раздел Отображение не развернут, щелкните панель Отображение.

  4. Отожмите кнопку Области [image].


Изменение формата подписей областей сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Подписи областей не развернут, щелкните панель Подписи областей.

  5. В рамках Области строк, Области столбцов, Области сведений и Области фильтров внесите необходимые изменения в тексты подписей.

    Если в отображении подписей областей не требуется, вместо того, чтобы удалять текст в областях, можно скрыть сами области.

  6. Выберите необходимые параметры формата.

    Чтобы выбрать для текста подписи полужирный шрифт, щелкните кнопку Полужирный [image].

    Чтобы выбрать для текста подписи курсив, щелкните кнопку Курсив [image].

    Для подчеркивания текста подписи щелкните кнопку Подчеркнутый [image].

    Для изменения цвета текста подписи щелкните стрелку справа от значка Цвет шрифта [image], а затем выберите нужный цвет. Если цвет шрифта совпадет с цветом фона, текст подписи нельзя будет увидеть.

    Шрифт выбирается в списке Шрифт. В этом списке содержатся шрифты, установленные в операционной системе компьютера.

    Размер шрифта выбирается в списке Размер. В этом списке содержатся размеры шрифтов, установленных в операционной системе компьютера.

    Для изменения цвета фона щелкните стрелку справа от значка Цвет фона [image], а затем выберите нужный цвет. Если цвет фона совпадет с цветом шрифта, текст подписи нельзя будет увидеть.

Примечание. Изменить эти параметры в обозревателе невозможно.


Отображение или скрытие строки названия сводной таблицы

Чтобы отобразить строку названия, необходимо прежде всего добавить данные к сводной таблице.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  3. Если раздел Отображение не развернут, щелкните панель Отображение.

  4. Варианты действий:

    Чтобы отобразить строку названия, щелкните кнопку Строка названия [image] и оставьте ее в нажатом состоянии.

    Чтобы скрыть строку названия, отожмите кнопку Строка названия [image].

Примечание. В обозревателе пользователи могут скрыть строку названия или изменить ее текст лишь в том случае, если не был ограничен их доступ к панели свойств сводной таблицы. В обозревателе нельзя изменять параметры раздела Формат строки названия. См. Форматирование строки названия.


Форматирование строки названия сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. Введите в поле Название сводной таблицы текст названия таблицы.

    Команда Фон в разделе Формат позволяет выбрать фон для данных сводной таблицы, но не фон ее названия.

  6. Если раздел Формат строки названия не развернут, щелкните панель Формат строки названия.

  7. Выберите необходимые параметры формата.

    Чтобы выбрать для текста названия полужирный шрифт, щелкните кнопку Полужирный [image].

    Чтобы текст названия отображался курсивом, щелкните кнопку Курсив [image].

    Для подчеркивания текста названия щелкните кнопку Подчеркнутый [image].

    Для изменения цвета текста названия щелкните стрелку справа от значка Цвет шрифта [image], затем выберите нужный цвет. Если цвет шрифта совпадет с цветом фона, то текст станет невидимым.

    Шрифт выбирается в списке Шрифт. В этом списке содержатся шрифты, установленные в операционной системе компьютера.

    Размер шрифта выбирается в списке Размер. В этом списке содержатся размеры шрифтов, установленных в операционной системе компьютера.

    Для изменения цвета фона щелкните стрелку справа от значка Цвет фона [image], затем выберите нужный цвет. Если цвет фона совпадет с цветом текста, то текст станет невидимым. Если необходимо использовать стандартные цвета операционной системы Windows (как в программе-конструкторе, так и в обозревателе), чтобы цвет строки названия сводной таблицы соответствовал цвету строк названий других окон, щелкните пункт По умолчанию.

Примечания

  • Чтобы скрыть строку названия сводной таблицы, щелкните панель Отображение и отожмите кнопку Строка названия [image].
  • В обозревателе пользователи могут скрыть строку названия или изменить ее текст лишь в том случае, если для них не ограничен доступ к панели свойств сводной таблицы. В обозревателе нельзя изменять параметры в разделе Формат строки названия.


Отображение сводной таблицы справа налево и наоборот

Отображение сводной таблицы справа налево необходимо в случае, если она предназначена для пользователей, в рабочем языке которых принято читать справа налево. После выполнения команды отображения таблицы справа налево она как бы зеркально отражается, поля оказываются в крайнем правом столбце, а элементы данных в полях столбцов перечисляются справа налево.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Панель свойств [image].

  4. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  5. Варианты действий:

    Для отображения сводной таблицы справа налево установите флажок Отображать справа налево.

    Для отображения сводной таблицы слева направо снимите флажок Отображать справа налево.

Примечание. Изменить этот параметр в обозревателе невозможно.


Обновление сводной таблицы после обновления исходных данных

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выделите сводную таблицу.

  3. На панели инструментов сводной таблицы щелкните кнопку Обновить [image].

Примечания

  • Вращение эмблемы Office Эмблема Office прекращается после завершения обновления сводной таблицы. Во время обновления выполнять с таблицей какие-либо действия невозможно. Невозможно также отменить операцию обновления во время извлечения исходных данных. Для отмены обновления нажмите клавишу ESC после извлечения данных, но до завершения пересчета сводной таблицы.

  • Разрешение вопросов при обновлении сводной таблицы.


Отмена обновления сводной таблицы

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Не дожидаясь завершения вычислений, нажмите клавишу ESC.

Примечания

  • Отменить операцию обновления можно лишь во время пересчета сводной таблицы. Во время извлечения исходных данных отмена невозможна.

  • После отмены обновления сводная таблица временно не отображает данные. Чтобы отобразить их, щелкните кнопку Обновить [image] на панели инструментов сводной таблицы.

  • Разрешение вопросов при обновлении сводной таблицы.


Использование сводной таблицы в Microsoft Excel или Microsoft Word

Инструкции.

Экспорт сводной таблицы в отчет сводной таблицы Microsoft Excel.

Копирование всей сводной таблицы в Microsoft Excel или Microsoft Word.

Копирование части сводной таблицы в Microsoft Excel или Microsoft Word.

Пояснения.


Использование сводных таблиц в Microsoft Excel или других программах

Работая с данными в Excel и имея представление об отчетах сводных таблиц Microsoft Excel, можно создавать их несколькими способами. Однако, если Web-страница, содержащая сводную таблицу, была открыта в Microsoft Excel, возможность просмотра и изменения сводной таблицы отсутствует. Далее в этом разделе обсуждаются пути переноса сводной таблицы в Excel или другие программы и содержатся сведения о:

Экспорт в интерактивный отчет сводной таблицы Excel

Копирование данных в другую программу для неинтерактивного использования

Пользователи обозревателя имеют возможности экспорта и копирования, сходные с теми, что есть у разработчиков в программе-конструкторе.

Экспорт в интерактивный отчет сводной таблицы Excel

Для просмотра и изменения сводной таблицы на Web-странице с помощью Excel, существует возможность экспортировать сводную таблицу в Excel. Отчет сводной таблицы Excel будет связан с теми же исходными данными, что и первоначальная сводная таблица. Таким образом все поля и данные этой исходной таблицы будут доступны в Excel и появится возможность обновления отчета сводной таблицы при изменении исходных данных.

Подготовка экспорта в Excel. Отчеты сводных таблиц Excel не могут отображать полей подробных сведений. После экспорта в Excel, поля подробных сведений будут доступны из панели инструментов Сводная таблица Excel, но они не буду отображены в отчете. Если необходимо, чтобы отчет сводной таблицы полностью соответствовал Web-варианту сводной таблицы, прежде чем экспортировать его, уберите все поля сводной таблицы из области сведений, а затем скройте подробности для элементов и ячеек, чтобы области сведений не отображались.

Возможности сводной таблицы, не подлежащие экспорту. Следующие функциональные возможности сводной таблицы не поддерживаются в отчетах сводных таблиц, а значит не могут быть экспортированы:

  • Поля чведений. Отчеты сводных таблиц Excel не могут отображать поля подробных сведений. Однако все исходные данные по прежнему будут доступны, а все поля подробных сведений будут показаны в списке панели инструментов Сводная таблица Excel. Дополнительные сведения об отображении подробных сведений для ячеек отчета сводной таблицы смотрите в справке Excel.

  • Параметры фильтра. Для некоторых типов исходных данных, если выполняется фильтрация по выделенному, параметры фильтра не экспортируются. Также как не экспортируются и параметры фильтра для скрытых полей. Однако в Excel можно будет повторить операцию фильтрации этих полей.

  • Отображение дней недели в полях дат. При экспорте сводной таблицы с указанными для дат обозначениями дней недели, в отчете сводной таблицы все они будут заменены соответствующими числами месяца. В Excel можно сгруппировать поля дней так, чтобы они отображались группам по семь дней. Дополнительные сведения о группировании полей в отчетах сводной таблицы смотрите в справке Excel.

  • Параметры ограничений. Любые ограничения, установленные для перемещаемых полей, которые используются для фильтрации и просмотра подробных сведений в сводной таблицы, теряются при экспорте. Поскольку пользователи также смогут экспортировать сводную таблицу из обозревателя в Excel, они получат возможность использовать Excel для просмотра исходных данных во всех подробностях. Чтобы предотвратить доступ пользователей к подробным сведениям таким способом, необходимо запретить доступ к команде обозревателя Экспорт в Excel, отключив инструментальную панель и строку названия, а также ограничив доступ к панели свойств сводной таблицы. См. Ограничение доступа к сводной таблице в обозревателе.

Возврат в начало

Копирование данных в другую программу для неинтерактивного использования

Копирование в Microsoft Word или Excel. Если необходимо работать с фиксированной копией данных, отображаемых в текущий момент в сводной таблице, можно скопировать и вставить данные в Excel или Word. Когда выполняется копирование всей сводной таблицы в другую программу, либо копирование выделенных ее фрагментов данных, текст и значения сводной таблицы становятся частью документа Word или книги Excel. Между исходными данными сводной таблицы и их копией в документе или книге не создается никаких связей, а значит невозможно и обновление этой копии при изменении исходных данных.

Копирование в другие программы. Можно также скопировать данные, представленные в сводной таблице, в другие программы, такие как Microsoft FrontPage или Microsoft Access. Когда данные копируются в программы, которые в отличии от Excel или Word не поддерживают формат HTML, используемый сводными таблицами, эти данные копируются как неформатированный текст.

Возврат в начало


Копирование всей сводной таблицы в Microsoft Excel или Microsoft Word

Описанным ниже способом сводная таблица копируется и вставляется в Excel или Word как не интерактивная таблица. Если же требуется скопировать таблицу как интерактивный отчет сводной таблицы, то следует экспортировать сводную таблицу в Excel.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните строку названия сводной таблицы.

  3. На панели инструментов сводной таблицы щелкните кнопку Копировать [image].

  4. Перейдите в окно Excel или Word, щелкните в том месте, куда необходимо вставить сводную таблицу.

  5. Щелкните кнопку Вставить [image].

Примечания

  • При копировании сводной таблицы копируются только значения данных и их форматы, из-за чего теряется связь между копией сводной таблицы в Word или Excel и базой данных, служившей для этой сводной таблицы источником данных. Поэтому копия сводной таблицы в Word или Excel не интерактивна, обновить ее невозможно.

  • Можно также копировать часть сводной таблицы в Word или Excel.


Копирование части сводной таблицы в Microsoft Excel или Microsoft Word

Описанным ниже способом выделенные значения сводной таблицы копируются и вставляются в Excel или Word как неинтерактивная таблица. Если же требуется скопировать данные как интерактивный отчет сводной таблицы, то следует экспортировать сводную таблицу в Excel.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Выберите часть сводной таблицы, которую необходимо скопировать.

    Инструкции

  3. На панели инструментов сводной таблицы щелкните кнопку Копировать [image].

  4. Перейдите в окно Excel или Word, щелкните в том месте, куда необходимо вставить данные из сводной таблицы.

  5. Щелкните кнопку Вставить [image].

Примечания.

  • При копировании части сводной таблицы копируются только значения данных и их форматы, из-за чего теряется связь между копией сводной таблицы в Word или Excel и базой данных, служившей для этой сводной таблицы источником данных. Поэтому копия сводной таблицы в Word или Excel не интерактивна, обновить ее невозможно.

  • Также можно скопировать часть сводной таблицы в другие программы, такие как Microsoft Access, как неформатированный текст.

  • В Word или Excel можно также скопировать всю сводную таблицу.


Экспорт сводной таблицы в отчет сводной таблицы Microsoft Excel

Описанным ниже способом сводная таблица экспортируется из программы-конструктора в Excel как интерактивный отчет сводной таблицы. При этом сохраняется связь между этим отчетом и базой данных, которая служит для сводной таблицы источником данных.

Прежде чем выполнять экспорт сводной таблицы в Excel, рекомендуется переместить все поля за пределы области сведений, а также скрыть сведения для элементов и ячеек.

  1. Убедитесь, что сводная таблица в окне программы-конструктора активизирована. Подробности смотрите в справке программы-конструктора.

  2. Щелкните сводную таблицу.

  3. Щелкните кнопку Экспорт в Excel [image] на панели инструментов сводной таблицы. Это вызовет запуск Excel (или переход к Excel, если он уж открыт) и отображение данных в отчете сводной таблицы.

Примечание. Внешний вид отчета сводной таблицы в Excel может отличаться от вида сводной таблицы в программе-конструкторе, поскольку отчет не может отобразить некоторые части макета сводной таблицы и некоторые вычисления. Все поля и данные, доступные в списке полей в программе-конструкторе, также доступны в отчете сводной таблицы Excel, в том числе скрытые поля. Однако поля сведений не отобразятся в отчете, а в некоторых полях вычисления могут дать иные результаты. Более подробные сведения о работе с отчетами сводных таблиц и о добавлении к ним полей содержатся в справке Excel.


Вопросы, возникающие при работе со сводными таблицами

Обновление

Сводная таблица не обновляется при изменении исходных данных.

Ошибка запроса сводной таблицы.

Фильтрация и сортировка

Данные не фильтруются нужным способом.

Данные поля сводной таблицы неверно сортируются.

Перемещение полей

В сводную таблицу невозможно добавить поле, также невозможно переместить поле.

После изменения макета приходится долго ждать появления данных.

Исчезли панель свойств сводной таблицы и список полей.

Данные

Не удается подключиться к источнику данных сводной таблицы.

Невозможно отобразить подробные сведения.

Поля существуют, а их данные отсутствуют.

После копирования сводной таблицы в Microsoft Excel или Microsoft Word исчезают данные.

Вместо числа в ячейке отображается #####.

Диаграмма, основанная на сводной таблице, пуста или не отображает данных.

Почему в итогах сводной таблицы содержатся звездочки?


Вместо числа в ячейке сводной таблицы отображается #####

Если ячейка слишком укая, из-за чего число в ней не помещается, вместо числа отображаются знаки #. Исправить это можно следующими способами:

  • Увеличить ширину столбца, чтобы число поместилось.

  • Уменьшить размер шрифта числа, чтобы уменьшить ширину числа.

  • Выбрать такой формат чисел, чтобы число занимало меньше места.


Диаграмма, основанная на сводной таблице, пуста или не отображает данных

Добавьте поля итогов. Чтобы диаграмма отображала данные сводной таблицы, необходимо добавить в сводную таблицу хотя бы одно поле итогов.

Переместите поля в области строк и столбцов. Поля строк и столбцов сводной таблицы образуют на диаграмме данные рядов и категорий. Например, если все поля находятся только в области сведений, на диаграмме не будет построено категорий и рядов. Из области сведений или из списка полей переместите не хотя бы одно поле в область строк или столбцов.


Данные поля сводной таблицы неверно сортируются

Вероятно, в поле измерения скрыты уровни. При сортировке поля сводной таблицы, исходные данные которой хранятся в базе данных OLAP, сортируются текущий и нижние уровни. Более высокие уровни определяют, какие из нижних уровней сортируются совместно. Если в поле нижнего уровня есть скрытые уровни измерения, то при сортировке данных учитываются скрытые уровни.

Пусть, например, поле измерения включает в себя уровни «Страна», «Регион» и «Город», причем уровень «Регион» в сводной таблице не отображен. В этом случае элементы данных в поле «Город» сортируются отдельно по каждому региону, хотя сведения о регионах в сводной таблице не отображены. Если в стране есть регионы «Север» и «Юг», то элементы «Город» сортируются отдельно для региона «Север» и отдельно для региона «Юг». По этой причине сортировка элементов уровня «Город» по регионам, а не по всей стране, выглядит неверной, если скрыт уровень «Регион».

Прежде чем выполнять сортировку, включите все уровни. Чтобы понять порядок сортировки данных, удалите все уровни измерения, переместите поле измерения обратно в сводную таблицу, затем отобразите все его уровни, чтобы над сортируемым уровнем присутствовали все более высокие уровни.


После копирования сводной таблицы в Microsoft Excel или Microsoft Word исчезли данные

При копировании данных из сводной таблицы в буфер обмена и вставке этих данных в Microsoft Excel или Microsoft Word копируются только видимые столбцы и строки. Данные, скрытые фильтром или иным образом, не копируются.

Копирование всех данных. Прежде чем копировать данные, следует отключить фильтры, чтобы отобразить в сводной таблице все данные, а также отобразить подробные сведения.

Экспорт в Microsoft Excel. Вместо того, чтобы вначале отобразить в сводной таблице все данные, а затем скопировать их, можно воспользоваться другим способом — экспортировать сводную таблицу в Excel. При экспорте сводной таблицы в Excel автоматически экспортируются все данные, включая параметры фильтров. Из Excel сохраняется такой же доступ к дополнительным полям исходных данных, как из сводной таблицы. Сохраняются также прежние возможности фильтрации. Из Excel данные можно копировать в Word и другие программы, а также опубликовать эти данные в виде сводной таблицы. Подробные сведения о работе с отчетами сводных таблиц в Excel и их опубликовании на Web-страницах содержатся в справке Excel.


В сводную таблицу невозможно добавить поле, также невозможно переместить поле

Вероятно, поле уже отображено. Одно и то же поле невозможно отобразить одновременно в нескольких областях. См. сведения об изменении макета сводной таблицы.

Вероятно, исходные данные ограничивают возможности использования поля. Исходные данные, хранящиеся в базах данных OLAP (интерактивная аналитическая обработка), содержат наборы полей для различных уровней подробности сведений. Эти наборы полей позволяют скрывать уровни сведений, однако отобразить различные поля одного и того же набора в различных областях невозможно.


Не удается подключиться к источнику данных, указанному для сводной таблицы

Исходная база данных недоступна. Например, может отсутствовать сетевое соединение, а также могут быть необходимы привилегии доступа или пароль для подключения к серверу. Пользователям обозревателя, которым необходимо отображать сводную таблицу и работать с ней, требуются такие же привилегии доступа к исходной базе данных, что и пользователям программы-конструктора. Обратитесь за помощью к администраторам сети или базы данных.

Отсутствует поддержка исходной базы данных Microsoft Office. Если исходные данные находятся в базе данных, неподдерживаемой Microsoft Office, возможно понадобится установка совместимого с Office 2000 программного обеспечения, поставляемого производителем данной базы данных. Такое же программное обеспечение необходимо установить пользователям, чтобы иметь возможность работы со сводной таблицей в обозревателе. За сведениями о необходимом программном обеспечении обращайтесь к производителю используемой базы данных.

Неправильно настроено сетевое соединение. Для подключения к исходным данным необходимо прежде всего настроить источник данных или сетевое соединение между исходной базой данных и программой-конструктором. Убедитесь в том, что источник данных установленный в программе-конструкторе работает и обеспечивает доступ к базе данных. За сведениями о настройке обратитесь к справке программы конструктора и драйвера источника данных или ODBC-драйвера. Выполняя добавление данных к сводной таблице, убедитесь в том, что были включены все необходимые параметры сетевого соединения. См. Исходные данные для сводных таблиц.


В сводной таблице невозможно отобразить подробные сведения

Вероятно, индикаторы развертывания отключены. Если значки Плюс около элементов данных полей строк и столбцов не отображены, включите отображение индикаторов развертывания.

Вероятно, более подробные сведения недоступны. Если элемент данных находится на самом нижнем уровне детализации исходных данных, около элемента данных не будет значка Плюс даже в том случае, если отображение индикаторов развертывания включено.

Вероятно, исходные данные не содержат подробных сведений. Иногда исходные данные не содержат записей подробных сведений, которые можно отобразить, например, базы данных OLAP (On-Line Analytical Processing, интерактивная аналитическая обработка). См. сведения о типах исходных данных для сводных таблиц.


Данные в сводной таблице не фильтруются нужным способом

Ограничения на фильтрацию. Возможности фильтрации, предусмотренные для электронных таблиц Microsoft Excel и отчетов сводных таблиц Excel, включая настраиваемый автофильтр и отображение первых десяти пунктов списка, недоступны в сводных таблицах, опубликованных на Web-страницах. Недоступна также фильтрация, основанная на части данных ячейки, доступная для всех форм и таблиц в Microsoft Access. См. сведения о возможностях фильтрации в сводных таблицах.

Просмотр данных с помощью Microsoft Access. Если возникла необходимость фильтрации по части данных ячейки, то с исходными данными следует работать в Microsoft Access, а не с использованием сводной таблицы. Как правило, данные можно просматривать в форме или таблице непосредственно в Microsoft Access, которые позволят фильтровать данные по части ячейки. После выполнения такой фильтрации можно воспользоваться конструктором страниц доступа к данным для создания новой сводной таблицы, либо изменения существующей сводной таблицы с использованием профильтрованных данных. Дополнительные сведения по этому вопросу содержатся в справке Access.


Поля в сводной таблице существуют, а их данные отсутствуют

Вычисление сводной таблицы было либо отменено, либо прервано. Чтобы отобразить данные, нажмите кнопку Обновить [image] на панели инструментов сводной таблицы.

Совет. Прежде чем обновлять данные, можно изменить макет сводной таблицы и профильтровать элементы данных поля.


Сводная таблица не обновляется при изменении исходных данных

Некоторые сводные таблицы невозможно обновить. Сводные таблицы, сохраненные или опубликованные из электронной таблицы Microsoft Excel, Web-запросов Excel и текстовых запросов Excel, при обновлении исходных данных не обновляются ни в программе-конструкторе, ни в обозревателе. В этих случаях для обновления сводной таблицы необходимо обновить исходную книгу Excel, а затем снова опубликовать данные.

Вероятно, исходная база данных недоступна. Например, отсутствует сетевое соединение, либо отсутствуют необходимые привилегии на доступ, либо не указан пароль для подключения к серверу. Пользователям в обозревателе для отображения сводной таблицы и работы с ней требуются такие же привилегии доступа к исходной базе данных, что и пользователям в программе-конструкторе. Обратитесь за помощью к администратору сети или базы данных.

Вероятно, Microsoft Office не поддерживает исходную базу данных. Если исходные данные находятся в базе данных, не поддерживаемой Microsoft Office, то необходимо установить совместимое с Office 2000 программное обеспечение, поставляемое поставщиком базы данных. Такое же программное обеспечение необходимо установить пользователям, которые желают обновлять сводную таблицу в обозревателе.

Вероятно, исходная база данных изменена. В некоторых случаях изменения структуры базы данных на сервере приводят к невозможности обновления сводной таблицы. Например, если исходные данные хранятся в базе данных OLAP (On-Line Analytical Processing, интерактивная аналитическая обработка), и эта база данных была перестроена с изменением доступных данных, то необходимо создать новую сводную таблицу. За дополнительными сведениями обратитесь к администратору базы данных.


Исчезли панель свойств сводной таблицы и список полей

Панель свойств и список полей могут исчезнуть, если на Web-странице щелкнуть элемент управления, отличный от элемента Web-компонента Microsoft Office, а также после сворачивания и разворачивания окна конструктора.

Для вывода на экран панели свойств и списка полей щелкните сводную таблицу, чтобы она снова активизировалась.


Ошибка в запросе сводной таблицы

Возможно недоступна исходная база данных. Если источником данных для сводной таблицы является удаленная база данных, сервер этой базы данных может быть недоступен или возникают сбои в сетевом соединении. Свяжитесь с администраторами сети или сервера для проверки работоспособности последних.

Могут отсутствовать необходимые привилегии. Даже при удачном подключении к базе данных возможны проблемы, связанные с отсутствием необходимых привилегий для выполнения запроса сводной таблицы. Обратитесь к администратору базы данных для получения сведений о привилегиях.

Проверьте фильтрацию сводной таблицы. Возможно, сводная таблица отфильтрована для отображения определенных элементов, а изменения в исходных данных, удалив один из этих элементов, вызвали сбой при выполнении запроса. Если это так, есть возможность отключить фильтрацию, чтобы отобразить все элементы, а затем, щелкнув значок Обновить [image] на панели инструментов сводной таблицы, выполнить запрос.


Почему в итогах сводной таблицы содержатся звездочки?

Звездочки появляются в итогах в следующих случаях:

  • При вычислении итогов учтены скрытые элементы данных. Звездочки в итогах показывают, что при вычислении итогов учтены не только отображенные, но и скрытые элементы.

  • Сводная таблица опубликована из Microsoft Excel. В отчетах сводных таблиц, основанных на базах данных OLAP (On-Line Analytical Processing, интерактивная аналитическая обработка), при вычислении промежуточных и общих итогов всегда учитываются значения всех элементов поля, как отображенных, так и скрытых. В Excel предусмотрена возможность включать и отключать отображение звездочек. Однако при сохранении или опубликовании отчета Excel в виде сводной Web-таблицы, звездочки отображаются в сводной таблице всегда, даже если их отображение отключено в Excel.

Исключение скрытых данных из итогов. Вне зависимости от источника данных сводной таблицы (база данных OLAP или иной источник) сохраняется возможности включить в промежуточные и общие итоги только отображенные данные, исключив данные, скрытые фильтрами. При этом звездочки в итогах не отображаются.


После изменения макета сводной таблицы приходится долго ждать появления данных

Если пересчет сводной таблицы потребовал много времени, значит ее макет был значительно изменен, после чего понадобилось время для извлечения данных.

  1. Когда появляется сообщение «Вычисление сводной таблицы», вычисления можно отменить нажатием клавиши ESC. После отмены вычислений в сводной таблице отображаются только имена полей.

  2. Измените макет путем добавления, удаления и перемещения полей.

  3. Чтобы извлечь данные и выполнить вычисления для нового макета, щелкните кнопку Обновить [image] на панели инструментов сводной таблицы.


Печать сводной таблицы

Для печати сводной таблицы воспользуйтесь командой печати, предусмотренной в программе-конструкторе. Результаты печати зависят от возможностей этой программы. За дополнительными сведениями обратитесь к справке программы-конструктора.

Примечание. В Microsoft FrontPage 2000 сводные таблицы иногда распечатываются неверно.