Конструирование и опубликование таблицы

Обзор.

Приступая к работе.

Создание и настройка таблицы.

Проверка и опубликование.

Обзор

Электронные таблицы, для краткости называемые также листами, используются для ввода и обработки данных. Лист состоит из строк и столбцов, а их пересечения называются ячейками. Данные можно вводить прямо в ячейки. Вычисления выполняются по формулам, которые также вводятся в ячейки. Интерактивная электронная таблица, созданная с помощью любой из программ-конструкторов, входящих в состав Microsoft Office 2000, и размещенная (опубликованная) на Web-странице, становится доступной пользователям, и они получают возможность просматривать и обрабатывать данные в обозревателе интерактивно. Более того, пользователи получают возможность вводить собственные данные и просматривать результаты их автоматической обработки.

Электронная таблица на Web-странице.

Выше приведен пример опубликованной на Web-странице электронной таблицы, которая используется как калькулятор для расчета ежемесячных выплат по погашению ссуды, выданной под залог недвижимости. Любой пользователь может просмотреть эту таблицу в обозревателе, ввести в определенные ячейки интересующие его значения, и сразу же увидеть автоматически вычисляемую сумму выплат.

Создание и конструирование. Конструирование интерактивной таблицы (Web-листа) включает в себя несколько шагов. Более подробно они рассмотрены ниже. В целом создание листа сводится к следующему:

  • Приступая к работе.

  • Создание и настройка таблицы в программе-конструкторе.

  • Проверка и публикование таблицы на Web-странице.

Возврат в начало.

Приступая к работе

Обеспечены ли пользователи обозревателями и лицензией? Для работы с интерактивными таблицами (листами) у пользователей должны быть установлены Web-компоненты Microsoft Office. Это можно сделать при установке Microsoft Office 2000. Пользователи, организации которых имеют лицензию на доступ к Web-узлу Office 2000, могут загрузить Web-компоненты Microsoft Office через корпоративную интрасеть. Кроме того, пользователям необходим обозреватель Microsoft Internet Explorer версии 4.01 или более поздней. См. сведения об обозревателях, полностью поддерживающих Web-таблицы.

Какую программу-конструктор использовать? Программа-конструктор — это программа для создания и изменения интерактивных таблиц. Интерактивную таблицу можно опубликовать из Microsoft Excel 2000, Microsoft Access 2000, либо Microsoft FrontPage 2000. Программисты могут также создавать электронные таблицы в Microsoft Visual Basic.

В различных программах-конструкторах предусмотрены различные возможности. Примеры:

  • Excel обладает богатыми возможностями для вычислений с помощью встроенных формул, позволяет создать интерактивный лист, а затем опубликовать или сохранить его как интерактивную таблицу. Excel также позволяет создавать на основе таблиц интерактивные диаграммы и публиковать их вместе таблицами.

  • С помощью FrontPage 2000 можно создать электронную таблицу на Web-странице, красиво оформить ее и разместить на Web-узле.

  • Программа Access позволяет создать электронную таблицу, отображающую данные, хранящиеся в базе данных. Между таблицей и базой данных устанавливается связь. В электронной таблице можно создавать формулы, использующие для вычислений значения из базы данных. Если значения в базе данных изменяются, электронная таблица пересчитывается.

  • Программисты могут вставлять электронные таблицы в формы Visual Basic и автоматизировать их, используя программную среду Visual Basic.

После создания на Web-странице электронной таблицы, эту страницу можно совершенствовать с помощью той или иной программы-конструктора. Например, интерактивную Web-страницу, созданную конструктором страниц доступа к данным в Microsoft Access, можно открыть и изменить с помощью программы FrontPage 2000. Электронную таблицу можно экспортировать в Excel, чтобы проанализировать ее аналитическими средствами Excel, изменить, а затем сохранить эти данные на своем компьютере в книге Excel.

См. Возможности программ-конструкторов.

Возврат в начало.

Создание и настройка таблицы

При создании электронной таблицы руководствуйтесь инструкциями программы-конструктора по размещению на Web-странице элементов управления электронными таблицами. В созданную таблицу можно вводить данные и формулы, а также импортировать данные. Сведения о создании таблицы в Microsoft Excel содержатся в справке о сохранении листов Excel и их опубликовании из Excel.

Панель инструментов и панель свойств листа. После создания электронной таблицы, для краткости иногда называемой листом, можно изменить ее параметры, размеры, защитить ячейки. Эти и многие другие операции выполняются с помощью панели свойств листа и панели инструментов листа. См. Панель свойств листа и панель инструментов.

Ограничение доступа в обозревателе. Даже в таком обозревателе, как Internet Explorer 5, который полностью поддерживает электронные таблицы, пользователь не имеет доступа к ряду команд и возможностей, доступных в программе-конструкторе. Если требуется запретить пользователям вносить изменения в данные или формулы, следует ввести дополнительные ограничения на доступ к таблице в обозревателе. См. сведения о защите таблиц.

Ввод описания. Таблицу можно сопроводить пояснительным текстом и инструкциями, разместив их на свободном месте в таблице или на Web-странице. См. Ввод описания таблицы.

Сопровождающая диаграмма. Некоторые сведения желательно показать не только в таблице, но и на диаграмме. Диаграмма будет наглядно иллюстрировать данные, если ее разместить на Web-странице рядом с таблицей. Когда пользователь изменяет данные в таблице, диаграмма в обозревателе автоматически обновляется. Пусть, например, таблица на Web-странице содержит сведения о выплатах для погашения ссуды, выданной под залог недвижимости, и формулы для расчета ежемесячных выплат. В этом случае рядом с таблицей полезно разместить интерактивную диаграмму, на которой клиенты банка смогут ясно увидеть, как суммы выплат по погашению основной части долга и процентов зависят от сроков. Если пользователь введет в таблицу значения процентной ставки и первого взноса, то формулы Web-таблицы автоматически вычислят результаты, а диаграмма покажет их в наглядном виде. См. сведения о создании и использовании диаграмм.

Сценарии. Сценарии позволяют воспользоваться дополнительными возможностями электронных таблиц. Сценарии для Web-страниц пишутся на таких языках как Microsoft Visual Basic Scripting Edition (VBScript) и JavaScript. Добавление к таблице сценариев позволяет, среди прочего, извлекать значения из базы данных и обрабатывать сведения в фоновом режиме.

В пакет Microsoft Office 2000 включен редактор сценариев Microsoft Script Editor, позволяющий создавать и изменять сценарии. Сведения о создании сценариев содержатся в справке программы-конструктора. О средствах доступа к электронным таблицам из сценариев содержатся в справке по программированию для электронных таблиц.

Возврат в начало.

Проверка и опубликование

Проверка таблицы в обозревателе. Прежде чем предоставить доступ к таблице пользователям, ее следует проверить в обозревателе. Для работы с электронным таблицами, опубликованными в Интернете, рекомендуется обозреватель Internet Explorer 5, включенный в пакет Microsoft Office 2000. Он обеспечивает все возможности интерактивной работы с таблицами. Просматривать таблицы в интерактивном режиме можно также с помощью обозревателя Internet Explorer 4.01 и более поздних версий. Если таблица предназначена для пользователей с другими версиями обозревателя, то ее необходимо проверить во всех этих версиях и убедиться, что она верно отображает и обновляет данные. См. сведения о поддержке электронных таблиц различными версиями обозревателя.

Внесение изменений. Если в электронную таблицу, уже опубликованную на Web-странце, необходимо внести изменения, то следует вначале изменить с помощью программы-конструктора исходную таблицу, а затем опубликовать ее вместо прежней таблицы. Например, если таблица была опубликована из Microsoft Excel, то следует внести изменения в исходный лист Excel, а затем опубликовать его.

Опубликование Web-страницы. После проверки Web-страницу можно сделать доступной пользователям. Сведения об опубликовании Web-страниц содержатся в справке программы-конструктора. При необходимости проконсультируетесь у Web-мастера.

Возврат в начало.


Программы-конструкторы для создания листов электронных таблиц

Для создания и изменения листов существует несколько программ-конструкторов. Можно создать лист с помощью одной программы, а затем изменять этот лист или содержащую его Web-страницу с помощью других программ. При выборе программы-конструктора следует принять во внимание следующее: объем предстоящей работы по конструированию и администрированию Web-страницы, используемый тип данных, степень знакомства с той или иной программой-конструктором. Например, если исходные данные содержатся на листе Microsoft Excel, то создать и опубликовать лист электронной таблицы можно с помощью Microsoft Excel 2000. Если необходимо импортировать или сделать ссылку на данные, хранимые в базе данных, удобнее воспользоваться конструктором страниц доступа к данным Microsoft Access 2000. Если Web-страницу нужно оформить специальными эффектами или разместить на Web-узле, то желательно воспользоваться программой Microsoft FrontPage 2000. Программисты могут использовать Microsoft Visual Basic для создания и автоматизации своих листов. Далее представлены сведения о:

Microsoft Excel 2000

Microsoft FrontPage 2000

Microsoft Access 2000

Microsoft Visual Basic

Получение дополнительных сведений о разработке. Чтобы узнать больше о процедурах разработки и их возможностях, обратитесь к справке программы-конструктора, которая будет использоваться. См. Вызов справки в программе-конструкторе.

Microsoft Excel 2000

Если необходимо использование различных формул, настройка ссылок, импорт данных из других источников или разработка интерактивных диаграмм, отражающих данные листа, Microsoft Excel будет лучшим выбором в качестве среды разработки для создания такого листа. Если необходимо изменить лист опубликованный из Excel, придется использовать другие программы-конструкторы. См. Работа с листом, опубликованным из Excel.

При необходимости можно отформатировать лист, настроив его размеры и внешний вид в другой программе-конструкторе. Если кто-либо из пользователей использует Internet Explorer версии 4.01, для изменения листа, опубликованного из Excel, лучше использовать FrontPage 2000. Поскольку Excel публикует листы в формате, поддерживаемом Internet Explorer 4.01 и более поздних версиях, а FrontPage 2000 поддерживает этот формат. Однако, если при изменении Web-страницы, опубликованной из Excel, в Microsoft Access используется конструктор страниц доступа к данным, пользователям может понадобиться установка Internet Explorer 5, прежде чем они смогут работать с этой Web-страницей.

Возврат в начало

Microsoft FrontPage 2000

FrontPage — рекомендованная программа-конструктор для создания Web-страниц и изменения листов, которые были опубликованы из Excel. Используя FrontPage, можно не только изменять листы, разработанные в других программах, но и создавать на Web-странице новые, а также использовать широкий набор средств редактирования и администрирования Web-страниц для добавления других управляющих элементов, графиков, тем и проч., затем размещая эти Web-страницы на Web-узле. FrontPage 2000 содержится в Microsoft Office 2000 Premium.

Возврат в начало

Microsoft Access 2000

Используйте конструктор страниц доступа к данным Access для создания листов пользователям, имеющим Microsoft Internet Explorer 5 или более поздней версии. В Access предусмотрены особые возможности по созданию Web-страниц, извлекающих и обрабатывающих данные из баз данных. Используя Access, можно установить соединение между базой данных Access и Web-страницей, а затем использовать формулы листа, для извлечения в него значений из этой базы данных.

Microsoft Access 2000 содержится в Microsoft Office 2000 Professional и Microsoft Office 2000 Premium.

Возврат в начало

Microsoft Visual Basic

Если необходимо иметь более совершенную среду программирования, чем та, что обеспечивает возможность написания сценариев в Excel, FrontPage и Access, при разработке листов можно применять систему разработки Microsoft Visual Basic. Используйте Visual Basic, когда необходимо включить лист или механизм вычислений в какое-либо из пользовательских решений. При этом пользователи смогут просматривать и взаимодействовать с листами, созданными формами Visual Basic, внутри программ. В отличии от обозревателя, эти формы являются готовыми выполняемыми приложениями и с их помощью пользовательская программа сможет обеспечить большинство возможностей листов электронных таблиц или вычислений. См. Вызов справки по программированию листов.

Возврат в начало


Работа с листами электронных таблиц, опубликованными из Microsoft Excel 2000

При публикации листа из Microsoft Excel 2000, можно открыть Web-страницу и внести необходимые конструкционные изменения, используя Microsoft FrontPage 2000 или конструктор страниц доступа к данным Microsoft Access 2000. Также можно открыть оригинальный лист (файл .xls) в Microsoft Excel (если он сохранился), внести изменения и заново опубликовать лист на той же самой странице. Если исходная копия не сохранилась, можно экспортировать лист в Microsoft Excel, внести изменения, а затем либо сохранить копия, либо опубликовать измененный лист.

При публикации листа из Microsoft Excel, большинство функциональных возможностей Excel сохраняются и продолжают работать также как и раньше. Далее приведен список тех возможностей, которые изменяют свои свойства или вообще перестают работать после публикации или сохранения листа Excel, как листа электронной таблицы для Web-страницы.

Возможность использования формул, функций и вычислений Excel. | Изменения, происходящие при публикации или сохранении как Web-страницы.
Формулы массива. | Преобразуются в значения.
Подписи к формулам. | Преобразуются в ссылки на ячейки.
Ячейки или диапазоны, имеющие названия. | Преобразуются с использованием ссылок вместо имен ячеек и диапазонов.
Именованные константы. | Преобразуются в значения.
Ссылки на данные в других листах. | Ссылки преобразуются в значения.
Промежуточные итоги. | Числа и вычисления переносятся корректно. Не сохраняются возможности группирования и структурирования.
Система дат 1904. | Отображаются те же самые данные, но их численное представление преобразуется в систему дат 1900.
Точность как на экране. | Не поддерживается. Точность показываемых значений соответствует точности при публикации.
Стиль ссылок R1C1 | Преобразуется в стиль ссылок A1.

Форматирование, рисунки и особенности отображения в Excel. | Изменения, происходящие при публикации или сохранении как Web-страницы.
Повернутый или вертикальный текст. | Преобразуется в горизонтальный текст.
Выравнивание по ширине. | Не сохраняется.
Тайское выравнивание. | Не сохраняется.
Выравнивание с отступом. | Не сохраняется.
Переносы текста в ячейках. | Не сохраняются.
Рисунки. | Не сохраняются.
Узорные заливки. | Не сохраняются.
Пунктирные или разорванные рамки. | Преобразуются в сплошные рамки.
Несколько шрифтов в одной ячейке. | Не сохраняются. Используется шрифт первого символа ячейки.
Условное форматирование. | Сохраняется текущее форматирование ячейки. Оно перестает быть условным.
Примечания. | Не сохраняются.
Ограничения и сообщения проверки данных. | Не сохраняются.
Аудит стрелок трассировщика. | Не сохраняется.
Структура. | Свернутые строки публикуются как скрытые. Развернутые строки публикуются в обычном порядке.
Особенности печати или параметров страницы. | Не сохраняются.

Возможности совместной работа и импорта файлов Excel. | Изменения, происходящие при публикации или сохранении как Web-страницы.
Сведения из общей книги. | Не сохраняются.
Совместимость с Lotus. | Стиль ссылок R1C1 преобразуется в A1.
Внешние диапазоны данных. | Публикуются только значения. Возможность обновления данных из внешних источников утрачивается.
Web-запросы. | Публикуются только значения. Возможность обновления данных из внешних источников утрачивается.
Пароли. | Защищенный лист следует публиковать не задавая пароля (или вообще без него).


Панель свойств листа и панель инструментов

Панель инструментов. Панель инструментов располагается в верхней части листа (электронной таблицы) и обеспечивает набор команд, использоуемых при работе с данными таблицы при ее конструировании. Пользователи также могут пользоваться панелью инструментов для работы с таблицей в обозревателе. Если задержать указатель мыши над какой-либо кнопкой панели инструментов, то на экране появится название команды, выполняемой этой кнопкой.

Панель свойств листа. Панель свойств листа открывает доступ к командам, таким как Найти далее (поиск данных на листе), и свойствам листа, таким как цвет фона ячеек, ширина столбцов. Некоторые команды панели свойств отсутствуют на панели инструментов и в контекстных меню. Чтобы вывести панель свойств на экран, щелкните кнопку Панель свойств [image] на панели инструментов листа.

Команды и свойства панели свойств листа распределены по разделам, имена которых отображаются на соответствующих панелях. При первом вызове панели свойств отображаются разделы Общие и Формат. Чтобы отобразить или скрыть содержимое раздела, достаточно щелкнуть его панель. См. Отображение и использование панели свойств листа.

Доступ к некоторым командам и свойствам через панель свойств возможен как в программе-конструкторе, так и в обозревателе. Остальные команды и свойства доступны только в программе-конструкторе.

Ограничение доступа к панели инструментов и панели свойств. Если необходимо запретить пользователям доступ к командам панели свойств листа и отображаемым ею свойствам листа, следует запретить доступ к панели свойств в обозревателе.

Если необходимо запретить пользователям доступ к панели инструментов в обозревателе, следует скрыть панель инструментов. Чтобы пользователи не могли отобразить ее в обозревателях, следует также запретить доступ к панели свойств листа, поскольку она содержит команду отображения панели инструментов.


Команды и параметры панели свойств листа электронной таблицы

Быстрый поиск команд и свойств. Для быстрого поиска сведений о нужной команде или свойстве щелкните вкладку Поиск в окне Справка, введите имя команды или свойства в поле Введите искомое слово, а затем щелкните кнопку Список разделов. Выберите название раздела и щелкните кнопку Вывести. Искомое слово будет выделено во всем тексте выведенной справки. Для включения или отключения этого выделения щелкните кнопку Параметры [image] на панели инструментов окна справки, а затем щелкните кнопку Выделить искомое или Снять выделение.

Чтобы найти команду или свойство используя следующий список, щелкните имя раздела по которому необходимы сведения:

Доступны и из обозревателя, и из программы-конструктора.

Общий раздел.

Раздел Формат.

Раздел Отображение.

Раздел Вычисления.

Раздел Найти.

Доступны только в программе-конструкторе.

Раздел Импорт данных.

Раздел Защита.

Раздел Строка названия.

Раздел Дополнительные.

Общий раздел

Параметр | Описание
Отменить. | Отменяет последнюю команду или удаляет последние введенные данные. Можно выполнить отмену нескольких действий.
Справка. | Выводит разделы справки.

Возврат в начало

Раздел «Формат»

Параметр | Описание
Формат текста. | Отображает содержимое выделенных ячеек полужирным шрифтом, курсивом или подчеркнутым шрифтом и задает цвета шрифта.
Список Шрифт. | Выбор шрифта текста в выделенных ячейках из списка доступных в системе шрифтов.
Список Размер. | Выбор размера шрифта текста для выделенных ячеек из списка доступных размеров.
Команды форматирования ячеек
Цвет заливки. | Выбор цвета фона для выделенных ячеек.
Объединение ячеек. | Соединяет выделенные ячейки в одну.
Отмена объединения ячеек. | Разделяет ранее объединенную ячейку на составляющие ее отдельные ячейки.
Граница. | Устанавливает заданные цвет и толщину границ для выделенных ячеек.
Поле Ширина столбца. | Выбор ширины для выделенных столбцов, в пикселях.
Поле Высота строки. | Выбор высоты для выделенных строк, в пикселях.
Список Выравнивание по горизонтали. | Устанавливает один из типов выравнивания текста в ячейках: Общий, По левому краю, По центру или По правому краю. Общий тип предполагает выравнивание теста по левому краю, а чисел и дат — по правому.
Список Выравнивание по вертикали. | Устанавливает выравнивание текста в ячейках: По верхнему краю, По центру или По нижнему краю.
Список Формат чисел. | Устанавливает формат отображения чисел в ячейках. См. список доступных форматов чисел.

Возврат в начало

Раздел «Отображение»

Параметр | Описание
Панель инструментов. | Отображает панель инструментов листа.
Линии сетки. | Выводит на экран линии сетки между ячейками листа.
Строка названия. | Отображает строку названия в верхней части листа.
Названия столбцов. | Показывает буквы, служащие названиями столбцов, в верхней части листа.
Названия строк. | Выводит на экран номера строк сбоку от листа.

Возврат в начало

Раздел «Вычисления»

Параметр | Описание
Поле Формула в активной ячейке (ссылка активной ячейки). | Отображает формулу в активной ячейке. Результат выполнения формулы показывается рядом с ячейкой. Можно вносить изменения в формулу, но только в самой ячейке, а не в панели инструментов.
Кнопка Пересчет. | Выполняет перерасчет вычислений, когда выбран режим Вычисление по запросу.
Режим Автоматическое вычисление. | Автоматически пересчитывает вычисления листа всякий раз, когда изменяются данные.
Режим Вычисление по запросу. | Вычисления пересчитываются только при нажатии кнопки Пересчет или клавиши F9.

Возврат в начало

Раздел «Найти»

Параметр | Описание
Поле «Найти». | Позволяет задавать текст или значение для поиска в выбранном диапазоне ячеек или во всем листе, если выбрана только одна ячейка.
Кнопка Найти далее. | Выполняет поиск текста или значения, ранее указанного в поле «Найти».

Возврат в начало

Раздел «Импорт данных»

Параметр | Описание
Поле URL. | Служит для ввода адреса URL Web-страницы или имени текстового файла, содержащего данные, которые необходимо импортировать в лист электронной таблицы.
Кнопка Импортировать. | Выбирает данные с Web-страницы или из текстового файла, указанных в поле URL.
Флажок Обновление с адреса URL во время выполнения. | Выполняет выборку данных в лист по указанному адресу всякий раз, когда пользователь открывает в обозревателе Web-страницу, содержащую этот лист.

Возврат в начало

Раздел «Защита»

Параметр | Описание
Флажок Включить защиту. | Предотвращает внесение изменений в любые ячейки, которые были заблокированы с помощью флажка Блокировка ячеек, как в обозревателе, так и в программе-конструкторе. Но лишь в обозревателе существует возможность установить защиту на сортировку и фильтрацию, очистив флажки Разрешить сортировку или Разрешить фильтр, соответственно.
Флажок Блокировка ячеек. | Предотвращает внесение изменений в выделенные ячейки, если установлен режим Включить защиту, как в обозревателе, так и в программе-конструкторе.
Флажок Разрешить отображение панели свойств во время выполнения. | Установка этого флажка разрешает доступ к панели свойств листа в обозревателе.
Флажок Разрешить сортировку. | Обеспечивает пользователям обозревателя возможность сортировать данные в листе.
Флажок Разрешить фильтр. | С его помощью пользователи обозревателя могут включать или выключать режим «Автофильтр».

Возврат в начало

Раздел «Строка названия»

Параметр | Описание
Поле Название. | Служит для ввода текста строки названия.
Формат текста. | Выводит на экран текст строки названия полужирным, курсивом или подчеркнутым шрифтом, устанавливает цвет шрифта.
Список Шрифт. | Выбор шрифта текста строки названия из списка доступных шрифтов.
Список Размер. | Выбор размера шрифта текста строки названия из списка доступных размеров.
Фон. | Выбор цвета фона строки названия.

Возврат в начало

Раздел «Дополнительные»

Параметр | Описание
Список Автоподбор листа. | Дает возможность разворачивать и свертывать лист, как того требует отображение данных (если установлено Истина), или отображает лист в области фиксированного размера (если установлено значение Ложь).
Поле Максимальная высота. | Если для Автоподбора листа установлено Истина, выбирается максимально возможная для листа высота или в пикселях, или в процентах от высоты всей Web-страницы.
Поле Максимальная ширина. | Если для Автоподбора листа установлено Истина, выбирается максимально возможная для листа ширина или в пикселях, или в процентах от высоты всей Web-страницы.
Список Горизонтальная полоса прокрутки. | Если для Автоподбора листа установлено Ложь, полоса прокрутки в нижней части листа будет отображена (Истина) или скрыта (Ложь).
Список Вертикальная полоса прокрутки. | Если для Автоподбора листа установлено Ложь, полоса прокрутки по правую сторону листа будет отображена (Истина) или скрыта (Ложь).
Поле Отображаемый диапазон. | Выбор диапазона отображаемых на листе ячеек.
Список Перейти после возврата. | Определяет, переходить ли выделению в другую ячейку после нажатия клавиши ENTER (Истина) или остаться текущей выделенной ячейке (Ложь).
Список Направление перехода. | Устанавливает направление в котором перемещается выделение ячеек при нажатии клавиши ENTER, если в параметре Переход после возврата установлено Истина.
Список Закрепить области. | Удерживает на экране столбцы слева от выделенной ячейки (Слева) или строки над ней (Сверху), либо разрешает прокрутку всех строк и столбцов (Снять закрепление).
Список Включить события. | Разрешает программам и сценариям отслеживать события на листе (Истина) или запрещает эту возможность (Ложь).
Список Отображать справа налево. | Подготавливает лист к просмотру для языков с обратным порядком чтения (Истина) или возвращает его в обычное состояние (Ложь).

Возврат в начало


Кнопки и команды панели инструментов листа

Эмблема Office Эмблема Office. Отображает сведения о компонентах листа, включая номер установленной версии. При импорте данных с Web-страницы, эмблема вращается все время, пока идет выборка данных.

Отменить. Отменяет последнюю команду или удаляет последние введенные данные. Можно выполнить отмену нескольких действий.

Вырезать. Удаляет выделенные данные из листа и помещает их в буфер обмена.

Копировать. Копирует выделенные данные из листа в буфер обмена.

Вставить. Вставляет содержимое буфера обмена в указанную точку, заменяя любые выделенные данные. Команда доступна для выполнения только, когда в буфере обмена находятся скопированные или вырезанные данные.

Автосумма. Автоматически складывает числа, используя функцию СУММ.

Сортировка по возрастанию. Сортирует выделенные ячейки по алфавиту и в порядке возрастания чисел.

Сортировка по убыванию. Сортирует выделенные ячейки в обратном алфавитном порядке и в порядке убывания чисел.

Автофильтр. Включает или отключает фильтрацию. Фильтры позволяют отображать не все столбцы и строки, а лишь те, что отвечают указанным значениям.

Экспорт в Excel. Активизирует или запускает Microsoft Excel и копирует весь лист в новую книгу Excel.

Панель свойств. Отображает панель свойств листа, которая позволяет выполнять команды и задавать свойства.

Справка. Отображает разделы справки о том, как пользоваться листом электронной таблицы.


Работа с листом в интерактивном режиме

Далее описаны возможности, предусмотренные в Web-обозревателе Microsoft Internet Explorer при работе с Web-листом, созданным с помощью программы-конструктора. Понимание этих возможностей полезно конструкторам Web-листов, желающим учитывать пожелания пользователей.

Далее представлены сведения по следующим темам:

Сравнение возможностей обозревателя и программы-конструктора.

Интерфейс обозревателя, используемый для Web-листов.

Возможности обозревателя.

Ограничение возможностей пользователей в обозревателе.

Сравнение возможностей обозревателя и программы-конструктора

В Microsoft Office предусмотрен Web-компонент, позволяющий с помощью программы-конструктора создать электронную таблицу (Web-лист), которую можно просматривать в Web-обозревателе или другом подходящем средстве просмотра. Создавать и изменять Web-листы можно с помощью следующих программ-конструкторов: Microsoft Excel 2000, Microsoft FrontPage 2000 и Microsoft Access 2000. См. Выбор программы-конструктора.

Обсуждаемые далее возможности интерактивного просмотра доступны пользователям, у которых установлены Web-компоненты Microsoft Office 2000. Эти компоненты можно установить при установке Microsoft Office 2000. Пользователи, организации которых имеют лицензию на доступ к Web-узлу Office 2000, могут загрузить Web-компоненты Microsoft Office через корпоративную интрасеть. Следует также использовать Web-обозреватель, полностью поддерживающий сводные таблицы. Иногда возникает необходимость создать электронные таблицы, которые должны просматриваться не Web-обозревателем, а иной программой, такой как форма Microsoft Visual Basic, являющейся частью пользовательского решения. В этом случае обратитесь к справке программы-конструктора, где содержатся сведения о том, как пользователи могут получить доступ к электронной таблице и просматривать ее в интерактивном режиме.

Возврат в начало.

Интерфейс обозревателя, используемый для Web-листов

У пользователей есть возможность просматривать Web-лист в интерактивном режиме с помощью тех же панели инструментов и панели свойств, которые используются в программе-конструкторе при создании и конструировании листа. Однако в обозревателе недоступны некоторые возможности, доступные в программе-конструкторе, например, импорт данных, установка и снятие защиты, отображение и скрытие строки названия, а также дополнительные возможности, такие как установка отображаемых размеров листа.

Электронная таблица и панель свойств на Web-странице.

Для интерактивного просмотра электронной таблицы в обозревателе служат панель инструментов и панель свойств листа.

Возврат в начало.

Возможности обозревателя

Пользователи могут вводить данные и выполнять вычисления. В пределах ограничений, установленных конструктором Web-листа, пользователи могут добавлять, удалять и изменять данные, создавать и изменять формулы, выбирать формат некоторых элементов.

Возможности различных версий обозревателя. Для просмотра Web-листа в интерактивном режиме пользователям необходим обозреватель Microsoft Internet Explorer версии 4.01 или более поздней версии. См. сведения о поддержке электронных таблиц различными версиями обозревателя.

Справка, доступная в обозревателе. В обозревателе пользователи могут получить два вида справки: справку самого обозревателя и дополнительную справку, предоставляемую вместе с Web-листом. В этой дополнительной справке содержатся сведения о том, как пользоваться командами и средствами для работы с листом в обозревателе. Для вызова этой справки следует активизировать таблицу и щелкнуть кнопку Справка [image] на панели инструментов листа. См. сведения о вводе описания Web-листов.

Возврат в начало.

Ограничение возможностей пользователей в обозревателе

В некоторых случаях ограничения упрощают пользователям работу в обозревателе. Например, блокировка определенных ячеек запрещает пользователям изменять содержащиеся в них значения и формулы. Скрытие определенного диапазона листа запрещает пользователям фильтрацию и сортировку данных. Есть также возможность запретить отображение панели свойств листа. См. сведения о защите листа.

Возврат в начало.


Вывод на экран содержания справки по программе-конструктору

При открытии раздела справки о Web-листах, на вкладке Содержание в окне справки показаны только разделы справки о Web-листах.

Чтобы открыть разделы справки по программе-конструктору:

  1. Выберите в окне справки вкладку Мастер ответов, введите какой-нибудь не относящийся к Web-листам (электронным таблицам) вопрос, затем нажмите кнопку Поиск.

  2. Выберите раздел справки по программе-конструктору, нажмите кнопку Вывести.

  3. Щелкните вкладку Содержание, чтобы увидеть содержание справки по программе-конструктору.


Вызов дополнительной справки при создании листов электронных таблиц

Далее представлены сведения по следующим темам:

Вызов справки в других программах-конструкторах.

Вызов справки при написании сценариев или программ использующих листы.

Вызов справки в других программах-конструкторах

При работе с программой-конструктором справку по разработке листов можно получить одним из двух способов:

  • Справка программы-конструктора. Чтобы получить сведения об имеющихся в программе-конструкторе командах работы с Web-листами и их параметрами, обратитесь к справке программы. Например, в Microsoft FrontPage 2000 щелкните «Помощник» или вызовите Справку Microsoft FrontPage [image].

    Microsoft Excel обеспечивает как общую справку о сохранении данных Excel для использования на Web-страницах, так и конкретные сведения о сохранении листов для использования на Web-страницах. Для доступа к этой справке в Excel, щелкните помощник или вызовите Справку Microsoft Excel [image].

  • Справка при разработке диаграмм. При наличии доступа к панели свойств листа из другой программы-конструктора, появляется возможность обращаться и к разделам настоящей справки. Создав или открыв в программе-конструкторе Web-лист, щелкните кнопку Справка [image] на панели свойств листа или выберите пункт Справка на панели инструментов листа.

Возврат в начало

Вызов справки при написании сценариев или программ использующих листы

Можно использовать сценарии и программы для автоматизации Web-листов, а также включать их в другие выполняемые программные модули, помимо Web-обозревателей, разработанные в таких средах программирования, как Microsoft Visual Basic.

Создание сценариев. В программы Microsoft Office 2000 входит редактор сценариев (Microsoft), очень полезный при их создании. Например, этот редактор можно использовать из Microsoft FrontPage 2000 для настройки листа. Сведения о редакторе сценариев содержатся в справках программ-конструкторов Microsoft Office. В редакторе сценариев также можно вызвать дополнительную справку о возможностях его работы со сценариями.

Справка по объектной модели. При разработке программы или сценария для работы с Web-листом можно вызвать справку об объектной модели, свойствах и методах, используемых при создании листа. Такая справка по объектной модели устанавливается вместе с Web-компонентами Microsoft Office, к которым относятся и Web-листы. В зависимости от используемой программы-конструктора возможен доступ к этой справке одним из двух способов:

  • Справка в Microsoft Visual Basic. В Visual Basic (или Visual Basic для приложений) можно создать ссылку на библиотеку Web-компонентов Microsoft Office. При этом появляется возможность обращаться к справке с помощью обозревателя объектов, а также вызывать ее нажатием клавиши F1 после выбора ключевого слова. Сведения о создании ссылок и использовании справки по объектной модели содержатся в справке Visual Basic (Visual Basic для приложений).

  • Справка в других средах. Если используется другая среда разработки, найдите и дважды щелкните файл справки Msowcvba.chm.

Возврат в начало


Сочетания клавиш для листов

Содержание раздела:

Клавиши для выделения и перехода.

Клавиши для выполнения команд.

Клавиши для ввода, правки и копирования данных.

Клавиши для работы с раскрывающимися списками автофильтра.

Клавиши для выделения и перехода

Сведения о сочетаниях клавиш, применяемых для активизации и сворачивания листа, содержатся в справке программы-конструктора.

Клавиши | Действия
Клавиша TAB | Выделение ячейки листа.
SHIFT+TAB | Выделение предыдущей ячейки листа.
Клавиши со стрелками | Перемещение выделения в направлении стрелки.
SHIFT + клавиша со стрелкой | Расширение выделения в направлении стрелки.
CTRL + пробел | Выделение столбца.
SHIFT + пробел | Выделение строки.
SHIFT+PAGE DOWN | Расширение выделения вниз на один экран. Под экраном подразумевается та часть данных листа, которая видна на экране.
SHIFT+PAGE UP | Расширение выделения вверх на один экран. Под экраном подразумевается та часть данных листа, которая видна на экране.
HOME | Перемещения выделения к первой ячейке строки.
CTRL+HOME | Перемещение выделения к ячейке A1, либо в верхний левый угол видимого диапазона.
CTRL+END | Перемещение выделения к последней ячейке листа, содержащей данные и не скрытой фильтром.
CTRL + клавиша со стрелкой | Перемещение выделения в направлении стрелки к крайней ячейке диапазона, содержащего данные. Границами диапазона являются пустые столбцы и строки.
SCROLL LOCK + клавиша со стрелкой | Прокрутка листа в направлении стрелки.
PAGE DOWN | Пролистывание вниз на один экран. Под экраном подразумевается та часть данных листа, которая видна на экране.
PAGE UP | Пролистывание вверх на один экран. Под экраном подразумевается та часть данных листа, которая видна на экране.
CTRL+A | Выделение всех ячеек листа.

Возврат в начало.

Клавиши для выполнения команд

Клавиши | Действия
F1 | Вывод на экран разделов справки. Сведения о сочетаниях клавиш для работы в окне справки смотрите в справке Web-обозревателя.
SHIFT+F10 | Вызов контекстного меню листа.
Подчеркнутая буква. | Нажатие буквы, подчеркнутой в контекстном меню, когда оно вызвано на экране, вызывает выполнение соответствующей команды. Сведения, касающиеся панели свойств листа, содержатся в пояснениях к сочетанию клавиш ALT+ENTER.
ESC | Закрывает контекстное меню, не выполняя команды.
ALT+ENTER | Вызывает на экран панель свойств листа. Для выполнения команд, а также для изменения свойств листа с помощью панели свойств листа, сочетаний клавиш не предусмотрено.
ALT+F4 | Закрывает панель свойств листа.
CTRL+7 | Отображает или скрывает панель инструментов листа.
CTRL+Z | Отмена последней команды либо удаление последней введенной записи.
ALT+= | Автоматически суммирует числа с использованием функции СУММ.
CTRL+T | Включает и отключает фильтрацию.
CTRL+E | Выполняет экспорт листа в Microsoft Excel.
F9 | Пересчет листа.

Возврат в начало.

Клавиши для ввода, правки и копирования данных

Клавиши | Действия
F2 | Правка содержимого выделенной ячейки.
ENTER | Завершение ввода данных в текущую ячейку.
CTRL+ENTER | Ввод данных в выделенный диапазон ячеек.
ESC | Отмена ввода или изменения данных в ячейке.
BACKSPACE | Удаление содержимого текущей ячейки.
DELETE | Удаление содержимого выделенных ячеек.
CTRL+X | Удаление с листа выделенных данных в буфер обмена.
CTRL+C | Копирование выделенных данных из листа в буфер обмена.
CTRL+V | Вставка содержимого буфера обмена с заменой выделенных данных.
CTRL+B | Шрифт текста выделенных ячеек становится полужирным.
CTRL+U | Шрифт текста выделенных ячеек становится подчеркнутым.
CTRL+I | Отображение текста выделенных ячеек курсивом.
ALT+0128 на цифровой клавиатуре (следует включить NUM LOCK). | Ввод знака «евро» [image] .

Возврат в начало.

Клавиши для работы с раскрывающимися списками автофильтра

Клавиши | Действия
ALT + Стрелка вниз | Раскрывает список автофильтра для выделенной ячейки.
Клавиша TAB | Циклически перемещает выделение в раскрывающемся списке автофильтра от выделенного элемента к кнопке OK, кнопке Отмена и т. д.
Клавиши со стрелками | Переход к следующему элементу в раскрывающемся списке автофильтра.
Клавиша с буквой или цифрой | Перемещает к тому элементу раскрывающегося списка автофильтра, который начинается с этой буквы или цифры.
SHIFT + клавиша со стрелкой | Расширяет выделение в раскрывающемся списке автофильтра.
ПРОБЕЛ | Устанавливает или снимает флажки для выделенных элементов раскрывающегося списка автофильтра.
ENTER | Закрывает раскрытый список автофильтра и сохраняет выполненные изменения.
ESC | Закрывает раскрытый список автофильтра без сохранения изменений.

Возврат в начало.


Создание листа Microsoft Office

Конкретные шаги при создании Web-листа зависят от программ, используемых для конструирования этой Web-страницы. Дополнительные сведения содержатся в справке этих программ. Если программа-конструктор не способна создавать управляющие элементы, такие как лист, выполните следующее:

  1. С помощью программы-конструктора откройте или создайте Web-страницу, на которой предполагается разместить лист.

  2. Используя предусмотренную в программе-конструкторе процедуру добавления управляющего элемента на Web-страницу, выберите и отметьте на Web-странице положение и исходный размер листа.

  3. Введите данные и формулы на лист илиимпортируйте данные для использования в нем.

  4. Используйте панель свойств листа и панель инструментов для настройки листа.

  5. Следуя инструкциям программы-конструктора, опубликуйте лист.


Создание диаграммы, иллюстрирующей данные листа

Если лист (электронную таблицу) предполагается опубликовать из Microsoft Excel, то в вместе с листом можно опубликовать диаграмму, которая будет иллюстрировать данные. В Microsoft Excel предусмотрены богатые возможности для построения разнообразных типов диаграмм.

Для создания Web-диаграмм и Web-листов в других программах-конструкторах необходимы два Web-компонента Microsoft Office — компонент для Web-листов и компонент для Web-диаграмм.

Диаграмма для листа создается следующим способом.

  1. Следуя инструкциям программы-конструктора, с помощью соответствующего Web-компонента создайте на Web-странице Web-лист, затем введите в него данные, которые необходимо показать на Web-диаграмме.

  2. Выделите на листе диапазон ячеек с данными, которые необходимо показать на диаграмме.

  3. Следуя инструкциям программы-конструктора, с помощью соответствующего Web-компонента создайте диаграмму на той же Web-странице, где находится Web-лист.

  4. Следуйте инструкциям мастера диаграмм.

    Для вызова справки на любом шаге мастера диаграмм щелкните кнопку «Справка» [image].

Совет. Для вызова справки по конструированию диаграмм и использованию панели свойств диаграммы щелкните диаграмму правой кнопкой мыши, затем выберите в появившемся контекстном меню пункт Справка.


Сохранение изменений в листе

Для сохранения сделанных изменений, сохраните в программе-конструкторе Web-страницу или файл, содержащие данный лист. Сведения о том, как сохранять файлы, содержатся в справке программы-конструктора.

Примечания

  • Если лист был опубликован из листа Microsoft Excel, а затем Web-страница была открыта в другой программе-конструкторе, сохранение Web-страницы не сообщит изменений исходному листу Microsoft Excel.

  • Если нужно сохранить копию листа как лист Microsoft Excel, можно выполнить экспорт листа в Excel. Также, есть возможность просто скопировать данные листа в Excel и другие программы.

  • В обозревателе пользователи не могут сохранить Web-страницу, но они могут экспортировать и копировать данные из обозревателя.


Экспорт листа в книгу Microsoft Excel

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа нажмите кнопку Экспорт в Excel [image]. Это вызовет запуск или активизацию Excel, на экране отобразятся данные в книге Excel.

Примечания

  • Столбцы с IW по ZZ не экспортируются из листа, поскольку на листе Excel не может содержаться более 256 столбцов. Однако эти данные можно копировать на лист Excel.

  • Из листа в Excel экспортируются только значения и формулы. Гиперссылки в Excel сохраняются, но связи с оставшимися на Web-страницах данными теряются. Например, если в лист импортировать данные из Web-страницы или текстового файла, а затем экспортировать эти данные из листа в Excel, то их связь с Web-страницей или текстовым файлом будет утеряна.

  • Некоторые форматы чисел экспортированных данных отображаются в Excel как данные нестандартного формата чисел. Например, форматы «Логический», «Истина/Ложь», «Вкл/Выкл» отображаются в Excel как нестандартные форматы чисел. Сведения о нестандартных форматах чисел в Excel смотрите в справке Excel. См. сведения о форматах чисел для листов (электронных таблиц).


Печать листа

Лист в окне программы-конструктора можно распечатать только вместе со всей Web-страницей. Подробнее о печати Web-страниц смотрите в справке программы-конструктора.

Для печати листа из обозревателя выберите команду Печать в меню Файл обозревателя Microsoft Internet Explorer.

Примечания

  • Если лист шире области печати бумаги принтера, то правая часть листа не распечатывается.

  • Если необходима регулировка печати, например, для распечатки большого листа на многих бумажных страницах, экспортируйте лист в Microsoft Excel. Сведения о печати из Excel содержатся в справе Excel.


Отмена изменений в листе

  • Чтобы отменить последнее изменение, сделанное в листе, щелкните Отменить [image]. Можно выполнить отмену для нескольких изменений.

  • Чтобы отменить все изменения, внесенные в лист со времени последнего сохранения Web-страницы, закройте ее без сохранения в программе-конструкторе.


Отображение панели инструментов листа

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Правой кнопки мыши выберите на листе ячейку, а затем щелкните Панель свойств.

  3. Если раздел Отображение не развернут, щелкните панель Отображение.

  4. Щелкните кнопку Панель инструментов [image].


Скрытие панели инструментов листа

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Отображение не развернут, щелкните панель Отображение.

  4. Щелкните кнопку Панель инструментов [image].


Вызов панели свойств листа

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Чтобы развернуть или скрыть содержимое раздела, щелкните панель с названием этого раздела.


Отображение или скрытие заголовков столбцов на листе

Заголовки столбцов — это буквы в серых ячейках (цвет может быть другим, в зависимости от параметров отображения, заданных в Windows) в верхней части листа.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Отображение не развернут, щелкните панель Отображение.

  4. Варианты действий:

    Для отображения заголовка для каждого из столбцов убедитесь, что кнопка Заголовки столбцов [image] нажата.

    Для скрытия заголовков всех столбцов, отожмите кнопку Заголовки столбцов [image].


Отображение и скрытие на листе номеров строк

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Отображение не развернут, щелкните панель Отображение.

  4. Варианты действий:

    Для отображения номеров строк нажмите кнопку Названия строк [image]. Убедитесь, что эта кнопка находится в нажатом положении.

    Для скрытия номеров строк отожмите кнопку Названия строк [image].


Отображение и скрытие строки названия листа

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Отображение не развернут, щелкните панель Отображение.

  4. Варианты действий:

    Чтобы отобразить строку названия листа, нажмите кнопку Строка названия [image]. Убедитесь, что кнопка находится в нажатом положении.

    Чтобы скрыть название листа, отожмите кнопку Строка названия [image].

Примечание. Есть возможность настроить строку названия, изменив ее текст и формат.


Отображение части листа

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  4. В поле Отображаемый диапазон введите диапазон для отображения.

    Например, чтобы отобразить все строки с 1 по 15, введите 1:15. А чтобы отобразить все столбцы от A до F, введите A:F. Для отображения ячеек с A1 до B20, укажитеA1:B20.

Примечания

  • Эта процедура позволяет скрыть данные и вычисления. Чтобы запретить пользователям изменять отображение разделов листа в обозревателе, есть возможность защитить лист.

  • Если выделенная для листа область больше чем отображаемый диапазон, неиспользуемая область выводится с серой заливкой. Чтобы убрать эту неиспользуемую область, следует изменить размеры места, выделяемого листу..

  • Если панель инструментов листа отображена, то ширина листа будет либо равна ширине панели инструментов, либо больше ее.

  • Изменить эту установку с помощью панели инструментов обозревателя невозможно.


Отображение и скрытие сетки на листе

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Отображение не развернут, щелкните панель Отображение.

  4. Варианты действий:

    Для отображения сетки нажмите кнопку Сетка [image]. Убедитесь, что кнопка находится в нажатом положении.

    Для скрытия сетки отожмите кнопку Сетка [image].


Отображение и скрытие на листе полос прокрутки

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  4. В списке Автоподбор листа выберите пункт Ложь.

  5. Чтобы отобразить полосу прокрутки на нижнем крае листа, выберите пункт Истина в списке Горизонтальная полоса прокрутки.

    Чтобы скрыть полосу прокрутки на нижнем крае листа, выберите пункт Ложь в списке Горизонтальная полоса прокрутки.

    Чтобы отобразить полосу прокрутки на правом крае листа, выберите пункт Истина в списке Вертикальная полоса прокрутки.

    Чтобы скрыть полосу прокрутки на правом крае листа, выберите пункт Ложь в списке Вертикальная полоса прокрутки.

Примечания

  • Если в списке Автоподбор листа выбрано значение Ложь, а линии прокрутки скрыты, то после вставки в лист строк или столбцов, некоторые из строк или столбцов в обозревателе окажутся скрытыми за краями листа.

  • Изменить эти настройки с помощью панели инструментов обозревателя невозможно.


Выбор ячейки, активизирующейся при нажатии клавиши ENTER

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  4. В списке Перейти после возврата выберите следующее:

    Чтобы после ввода данных в ячейку осуществлялся переход к следующей ячейке, выберите пункт Истина, затем в списке Направление перехода выберите направление: Вниз, Влево, Вправо или Вверх.

    Если после ввода данных в ячейку она должна остаться активной, выберите пункт Ложь.

Примечания

  • Выбранное направление перехода вступает в силу после выбора в списке Перейти после возврата пункта Истина.

  • Если активная ячейка находится на краю листа, то перехода к следующей ячейке после нажатия клавиши ENTER не происходит. Например, если выбрано направление перехода «Вниз», а текущая ячейка находится в самой нижней строке, то после нажатия клавиши ENTER выделенной остается текущая ячейка.

  • Изменить эту установку с помощью панели инструментов обозревателя невозможно.


Выбор направления письма при отображении листа

Display a spreadsheet so that it reads right to left, or vice versa

Сведения, относящиеся к конкретным языкам

Use right-to-left display when your spreadsheet will be viewed in languages that read from right to left. When you select right-to-left display, the elements of the spreadsheet are displayed as a mirror image of the default left-to-right display: The row numbers are displayed on the right side of the spreadsheet and the vertical scroll bars appear on the left side.

  1. In the design window, make sure the spreadsheet is activated. For instructions, see Help for your design program.

  2. On the toolbar in the spreadsheet, click Property Toolbox [image].

  3. If the Advanced section is not expanded, click the Advanced bar.

  4. In the Display right to left list, do one of the following:

    To display the spreadsheet right to left, click True.

    To display the spreadsheet left to right, click False.

Note This setting cannot be changed from the toolbox in the browser.


Возможности, доступные листам электронных таблиц в различных обозревателях

Для просмотра интерактивных листов и работы с ними у пользователей должны быть установлены Web-компоненты Microsoft Office. Это достигается путем установки Microsoft Office 2000. Также, если у организации есть лицензия на работу с Web-узлом Microsoft Office 2000, эти Web-компоненты можно загружать через корпоративную интрасеть.

Полный набор поддерживаемых Web-листами возможностей доступен не во всех обозревателях.

Microsoft Internet Explorer 5 и более поздних версий. С помощью этого обозревателя, пользователи имеют доступ ко всем доступным из обозревателя возможностям листа. Internet Explorer 5 требуется в случаях, если для создания листа использовался конструктор страниц доступа к данным Microsoft Access 2000 или когда лист изменялся и Web-страница сохранялась с помощью Access.

Microsoft Internet Explorer версий 4.01, 4.1x и 4.2x. Пользователи имеют доступ ко всем возможностям, доступным из обозревателя. В некоторых случаях, пользователи должны также иметь установленный Internet Explorer 5, чтобы просматривать листы Web-страниц, созданных с использованием конструктора страниц доступа к данным Microsoft Access.

Microsoft Internet Explorer 4.0. Эта версия обозревателя обеспечивает все возможности листа, которые доступны из панели инструментов листа и контекстных меню, вызываемых нажатием правой кнопки мыши. Не обеспечиваются только возможности, доступные из панели свойств листа. В некоторых случаях для просмотра листов на Web-страницах, созданных с помощью конструктора страниц доступа к данным Microsoft Access 2000, необходим Internet Explorer 5.

Другие обозреватели. В более ранних версиях Microsoft Internet Explorer и других обозревателях просмотр интерактивных листов невозможен. На Web-странице лист выглядит очерченным границей прямоугольником.


Ввод описания электронных таблиц

В обозревателе пользователям доступна справка о свойствах и возможностях работы с электронными таблицами. Но в некоторых случаях, например, если электронная таблица создается в расчете на неопытных пользователей, полезно снабдить ее дополнительными инструкциями, доступными во время работы с таблицей.

Справка обозревателя. Справка обозревателя по электронным таблицам автоматически доступна пользователям, у которых установлены обозреватели Microsoft Internet Explorer версии 4.01 или более поздних версий, а также установлены Web-компоненты Microsoft Office. Справка, доступная во время работы с таблицей, отличается от справки, доступной из меню обозревателя Справка.

В разделах справки, доступных всем пользователям при просмотре таблиц в обозревателе, содержатся общие сведения о работе с электронными таблицами в обозревателе. Эти разделы справки отличаются от настоящих разделов справки, предназначенных для конструкторов таблиц. Другие элементы управления Web-компонентами Microsoft Office, такие как элементы управления сводными таблицами, также имеют отдельные справки, доступные в обозревателе.

Для просмотра справки, доступной из обозревателя, создайте на Web-странице электронную таблицу, откройте эту Web-страницу в обозревателе Internet Explorer, щелкните электронную таблицу, затем на ее панели инструментов щелкните кнопку Справка [image]. В окне справки можно просмотреть ее содержание и выбрать нужный раздел. Помощника, отвечающего на вопросы, в обозревателе нет.

Пользователям, у которых не установлены Web-компоненты Microsoft Office, справка опубликованной таблицы недоступна. См. сведения о поддержке электронных таблиц различными версиями обозревателя.

Ввод описания таблицы. Дополнительные сведения об электронной таблице можно разместить на Web-странице. Поскольку эту дополнительную справку нельзя встроить в интерактивную справку, доступную из панели инструментов таблицы, текст дополнительной справки следует разместить либо на той же Web-странице, где находится таблица, либо на отдельной Web-странице, указав к ней путь гиперссылкой. Сведения о том, как размещать сведения на Web-страницах различных типов, содержатся в справке программы-конструктора Web-страниц.


Сохранение на экране определенных строк и столбцов при прокрутке листа

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите ячейку в строке ниже строк, которые необходимо закрепить на экране при прокрутке, или выберите ячейку в столбце, справа от столбцов, которые необходимо закрепить.

  3. На панели инструментов листа щелкните кнопку Панель свойств [image].

  4. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  5. В списке Закрепить области, выберите одно из следующего:

    Чтобы закрепить на экране столбцы слева от выбранной ячейки, щелкните Слева.

    Чтобы закрепить на экране строки над выбранной ячейкой, щелкните Сверху.

    Чтобы сохранить и строки над ячейкой и столбцы слева от нее, сначала щелкните Слева, а затем Сверху.

    Чтобы разрешить прокрутку всех строк и столбцов, щелкните Снять закрепление.

Примечание. Изменить этот параметр из панели инструментов обозревателя невозможно.


Включение и отключение автоматического подбора размеров листа

Если автоматический подбор размеров листа (электронной таблицы) включен, то размеры листа на Web-странице автоматически изменяются при вставке и удалении строк и столбцов, а также при изменении высоты строк и ширины столбцов.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  4. В списке Автоподбор листа выберите одно из следующего:

    Для включения автоматического подбора размеров листа выберите пункт Истина. Если на размеры листа необходимо наложить ограничения, введите максимально допустимые значения высоты и ширины в поля Максимальная высота и Максимальная ширина. Можно ввести значение только в одно из этих полей. Значения вводятся либо в пикселах, либо в процентах от высоты и ширины Web-страницы. Например, чтобы лист не занимал более половины ширины Web-страницы, введите значение 50% в поле Максимальная ширина. Если ширина листа не должна превышать 300 пикселов, введите в поле Максимальная ширина число 300.

    Если размеры листа должны быть зафиксированы и равны его размерам в программе-конструкторе, выберите в списке пункт Ложь.

Примечания

  • Если в списке Автоподбор листа выбрано значение Ложь, а линии прокрутки скрыты, то после вставки в лист строк или столбцов, некоторые из строк или столбцов будут в обозревателе не видны. См. Отображение полос прокрутки.

  • Если панель инструментов листа отображена, то ширина листа будет либо равна ширине панели инструментов, либо больше ее.

  • Эта установка действует только при просмотре листа в обозревателе, а не в программе-конструкторе.

  • Изменить эту установку с помощью панели инструментов обозревателя невозможно.


О вводе в электронные таблицы чисел, текстов, значений даты и времени

Далее представлены советы по вводу:

Текста.

Чисел.

Значений даты и времени.

Значений даты в 2000 году и позже.

Ввод текста

Символы, обрабатываемые как текст. В электронной таблице текстом считается любая комбинация из чисел, пробелов и нечисловых символов. Например, электронная таблица воспримет в качестве текста следующие вводимые данные:

10AA109, 127AXY, 12-976, 208 4675.

Ввод чисел и дат как текста. Для ввода числа и данных так, чтобы они хранились как текстовые данные, перед началом текста введите апостроф ('). Например, чтобы ввести шифр компонента 02-01-23 в качестве текста, а не значения времени, введите '02-01-23.

Выравнивание текста. По умолчанию, все текстовые данные выравниваются по левому краю ячейки. Можно изменить выравнивание, выполнив его по правую сторону или по центру ячейки.

Текст не может быть разорван внутри ячейки. Нельзя отобразить в одной ячейке несколько строк текста или задать внутри нее «жестких» возвратов каретки.

Знак евро. Чтобы ввести знак евро, [image], убедитесь, что включен режим NUM LOCK клавиатуры, а затем наберите ALT+0128 на цифровой клавиатуре. Если используется Microsoft Windows 95 или Microsoft Windows NT 4.0 с Service Pack 3 или более ранней версии, возможно потребуется установка обновления для поддержки евро с Web-узла Microsoft. Для получения дополнительных сведений о подключении к Web-узлу Microsoft обратитесь к справке программы-конструктора. Далее указаны шрифты, поддерживающие знак евро.

Операционная система | Шрифты
Microsoft Windows 95 с обновлением для поддержки евро | Arial Black, Arial, Comic Sans (обычный или полужирный), Courier New, Impact, MS Sans Serif, Tahoma (обычный или полужирный), Times New Roman, Verdana
Microsoft Windows 98 | Arial, Courier New, Tahoma (обычный и полужирный), Times New Roman
Microsoft Windows NT 4.0 с Service Pack 3 или более ранней версии и обновление для поддержки евро | Arial, Courier New, Times New Roman
Microsoft Windows NT 4.0 с Service Pack 4 | Arial, Courier New, Lucida Console, Lucida Sans Unicode, Times New Roman

Возврат в начало

Ввод чисел

Символы, которые могут использоваться в числах. В электронных таблицах число может содержать только следующие символы:

0 1 2 3 4 5 6 7 8 9 + – ( ) , / $ % . E e

Электронные таблицы не воспринимают знаки (+), предваряющие числа, а все одиночные точки внутри строки чисел расценивают как десятичные точки. Все остальные строки, содержащие числа вместе с нецифровыми символами, обрабатываются как текст.

Ввод дробей. Чтобы избежать обработки дроби как даты, введите перед ней нуль с пробелом; например, 0 1/2.

Ввод отрицательных чисел. Предваряйте отрицательные числа знаком минус (–), или заключайте их в скобки ( ).

Выравнивание чисел. По умолчанию, все числовые данные выравниваются по правому краю ячейки. Можно изменить выравнивание, выполнив его по левую сторону или по центру ячейки.

Формат отображения чисел. Заданный для ячейки формат чисел определяет, каким образом отображаются числа в этой ячейке. При вводе числа в ячейку с основным форматом, автоматически может применяться один из форматов чисел. Например, если вводится $14.73, автоматически будет применен денежный формат. Есть возможность изменить этот формат чисел.

Основной формат. В ячейках листа, по умолчанию имеющих основной формат, числа отображаются как целые числа (789), десятичные дроби (7.89) или как экспоненциальные представления чисел (7.89E+08), если их длина превышает ширину ячейки. Основной формат чисел отображает до 11 знаков, включая десятичные точки и символы, такие как «E» и «+». Чтобы использовать числа, содержащие более 11, можно применять экспоненциальный формат чисел (экспоненциальное представление).

Ограничение в 15 знаков. Независимо от числа отображаемых цифр, электронные таблицы хранят числа с точностью до пятнадцати знаков. Если число содержит большее число значимых цифр, электронная таблица преобразует все цифры сверх установленного предела в нули (0).

Национальные стандарты. Восприятие символов как чисел зависит от параметров, заданных в разделе Язык и стандарты панели управления. Выбранные параметры также определяют формат для чисел по умолчанию, например точка (.) используется как десятичный разделитель в системах, основанных на английском языке, США. Если пользователи имеют национальные стандарты, отличные от тех, что использовались при создании листа, числа неправильно могут быть отображены в обозревателе.

Повторяющиеся данные. Чтобы ввести одни и те же данные в несколько ячеек, выделите ячейки, наберите данные, а затем нажмите CTRL+ENTER.

Возврат в начало

Ввод значений даты и времени

Дата и время являются числами. Электронные таблицы обрабатывают значения даты и времени как числа. Таким образом то, как дата и время отображаются в ячейке зависит от заданного для нее формата чисел. Если электронная таблица распознает во водимых значениях дату и время, формат ячеек автоматически меняется с Основного на формат даты или времени. По умолчанию, значения даты и времени выравниваются по правому краю ячейки. Если не удается распознать формат значений даты и времени, они вводятся как текст, выравниваемый по левому краю ячейки.

Панель управления. Выбранные в разделе Язык и стандарты панели управления Windows параметры определяют формат по умолчанию для текущих даты и времени, а также символы, которые будут использованы как разделители даты и времени. Например, косая черта (/) и дефис (–) для дат, двоеточие (:) для времени в англоязычных (США) системах. Пользователи могут иметь национальные стандарты, отличные от тех, что использовались при создании листа, в этом случае обозреватель будет распознавать как разделители даты и времени неверные символы.

Указание года четырехзначным числом. Для обработки неоднозначных дат установлены определенные правила. Одним из этих правил является следующее: если введенная дата содержит месяц и целое двузначное число (две цифры), то двузначное число в диапазоне от 1 до 31 считается днем месяца текущего года. Например, дата «Декабрь 01» распознается как «1 декабря текущего года», а не как «Декабрь 2001 года». Дата «Декабрь 32» — как «1 декабря 1932 года. «1/12/30» распознается как «1 Декабря 1930», но «1/12/29» — как «1 декабря 1929», до тех пор пока системный администратор не изменит значение по умолчанию для пороговой даты.

Чтобы быть уверенными в том, что вводимые даты правильно восприняты электронной таблицей, всегда указывайте год четырехзначным числом.

Даты в 2000 году и позже. См. Обработка листами дат 2000 года и более поздних.

Совместный ввод даты и времени. Чтобы ввести значения даты и времени в одну ячейку, разделите их пробелом.

12-часовой или 24-часовой форматы времени. Для ввода времени в 12-часовом формате, после значения введите пробел, а затем AM или PM. В противном случае, лист обработает заданное значение как время в 24-часовом формате. Например, если ввести 3:00 вместо 3:00 PM, лист запоминает время как 3:00 AM. Если, работая в Excel, ввести 3:00 p, лист сохранит символы просто как тест.

Просмотр числового представления даты и времени. Независимо от формата, используемого для отображения значений даты и времени, лист хранит все даты в числовом формате, а все значения времени — как десятичные дроби. Чтобы отобразить дату числом, а время десятичной дробью, выберите ячейки, содержащие значения даты или времени и измените формат чисел на фиксированный. В этом формате часть числа, расположенная слева от десятичной точки, будет соответствовать значению даты, а справа — времени.

Вычисления с использованием дат и времени. Можно добавлять или вычитать значения даты и времени, а также включать их в другие вычисления. Чтобы использовать дату или время в формуле, введите их значение как текст, заключенный в кавычки. Например, следующая формула отобразила бы разность, равную 68:

="5/12/2004"-"3/5/2004"

Система дат. Для представления даты в числовом формате на листе электронной таблице порядковый номер дня вычисляется с начала двадцатого века, где номер 1 соответствует 1 января 1900 года.

Возврат в начало


Ввод чисел, текста, значений даты и времени на лист электронной таблицы

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Щелкните ячейку, в которую необходимо ввести данные.

  3. Введите данные и нажмите клавиши ENTER или TAB.

    Для отделения различных частей даты используйте точку или пробел; например, введите 9.5.2002 или 5 сен 2002.

    Для ввода времени в 12-часовом формате, после значения сделайте пробел и укажите AM или PM; например, 9:00 PM. Иначе, лист интерпретирует время как AM. Если ввести только a или p, например 9:00p, значение будет сохранено не как время, а как текст.

Советы

  • Чтобы ввести одни и те же данные в несколько ячеек, выделите ячейки, наберите данные, а затем нажмите CTRL+ENTER.

  • См. Советы по вводу чисел, текста, значений даты и времени.

  • См. Обработка листами дат 2000 года и более поздних.

  • Инструкции по вводу формул.

  • Инструкции по вводу гиперссылок.


Изменение данных на листе

  1. Убедитесь, что лист (электронная таблица) в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Щелкните ячейку, которую необходимо изменить.

  3. Варианты действий:

    Если необходимо заменить в ячейке число или текст, просто введите в нее новое число или текст.

    Если необходимо изменить только часть содержимого ячейки, дважды щелкните ячейку, затем выполните нужные изменения.

  4. Для сохранения выполненных изменений нажмите клавишу ENTER.

Примечания

  • Установить различные форматы и шрифты для различных частей значения одной ячейки невозможно.

  • Чтобы запретить пользователям изменять данные в обозревателе, заблокируйте ячейки, данные в которых изменять нежелательно.
  • Если при попытке изменить данные появляется сообщение о том, что диапазон защищен, то изменение данных в ячейке возможно только после отключения защиты.


Перемещение и копирование данных в электронной таблице

Ячейка копируется целиком, включая формулу, результирующее значение и формат. При вставке или перемещении в диапазон прежние данные в диапазоне заменяются новыми.

Изменение формулы при перемещении и копировании. Перемещение формулы не изменяет ссылки внутри нее. Копирование формулы сохраняет абсолютные ссылки, а относительные ссылки изменяет в зависимости от положения вставленной ячейки. См. Абсолютные и относительные ссылки.

Влияние фильтрации на копирование и перемещение. Ячейки, скрытые фильтром, не копируются. Чтобы в диапазоне, куда вставляются данные, содержатся скрытые фильтром строки, то нужно отключить фильтрацию, чтобы отобразить все вставленные данные. Перемещение данных из диапазона, содержащего скрытые фильтром строки, невозможно, если предварительно не отключить фильтрацию.

Копирование в другие программы. Копируемые ячейки листа (электронной таблицы) помещаются в буфер обмена в формате HTML. При вставке ячеек в лист Microsoft Excel все формулы и числовые значения, содержащиеся в ячейках, а также их форматы воспроизводятся на этом листе. Вставленные в документ Microsoft Word ячейки принимают вид таблицы с тем же форматом и значениями, что были в ячейках, но без скопированных формул. Копировать ячейки можно в любые программы, которые интерпретируют или допускают формат HTML.

Отличия от копирования в Excel. Копирование и перемещение данных на листе отличается от аналогичных операций в Excel следующими особенностями:

  • Нет индикатора копирования. Скопированный диапазон Web-листа не помечается рамкой с бегущим пунктиром, как это происходит на листе Excel.

  • Нет команды специальной вставки. Ячейки Web-листа копируются целиком, включая формулы, значения и форматы. В отличие от Excel, эти элементы нельзя копировать по отдельности. Также нельзя при вставке транспонировать строки в столбцы, выполнять операции сложения, вычитания, умножения и деления.

  • Нельзя добавлять вставляемые ячейки. При вставке в диапазон листа прежние ячейки всегда заменяются новыми. При копировании в Excel вставляемые ячейки можно добавить, не затрагивая существующие ячейки. Чтобы дополнить лист новыми данными, следует вставить пустые строки и столбцы, а затем вставить в них данные.

  • Копируемые данные остаются в буфере. Операция копирования заносит данные в буфер обмена. Там они остаются до очистки буфера или до следующего копирования, что позволяет перед вставкой выполнить ряд операций. В Excel содержимое буфера обмена удаляется сразу после выполнения каких-либо операций или нажатия клавиши ESC, даже если вставка копируемых данных еще не произошла.

  • Вырезанные данные удаляются сразу. При перемещении данных в Excel вырезанные данные остаются на прежнем месте до самой вставки, что позволяет многократно вставлять их. При перемещении данных на Web-листе вырезанные данные сразу же удаляются, поэтому вставка производиться только один раз (копируемые данные можно вставлять многократно).

Дополнительные сведения

Перемещение и копирование ячеек

Перемещение и копирование содержащихся в ячейке знаков


Перемещение и копирование данных листа

Инструкции по перемещению и копированию.

Всех ячеек.

Содержащихся в ячейке знаков.

Пояснения.


Перемещение и копирование содержащихся в ячейке знаков

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Дважды щелкните ячейку, содержащую знаки, которые необходимо переместить или скопировать.

  3. Выделите в ячейке знаки, которые необходимо переместить или скопировать.

  4. Варианты действий:

    Если выделенные знаки необходимо переместить, щелкните кнопку Вырезать [image].

    Если выделенные знаки необходимо скопировать в буфер обмена, щелкните кнопку Копировать [image].

  5. Выберите в ячейке место, в которое необходимо вставить знаки.

  6. Щелкните кнопку Вставить [image].

  7. Нажмите клавишу ENTER.


Перемещение и копирование ячейки листа

При операциях копирования, вырезания и вставки ячейка копируется или перемещается целиком, включая формулу, результирующее значение и формат.

Если в копируемом диапазоне содержатся ячейки, скрытые фильтром, то копируются только видимые ячейки. Если диапазон, куда вставляются данные, сдержит строки, скрытые фильтром, то необходимо отключить фильтрацию, чтобы отобразить все вставленные данные. Переместить данные из диапазона, содержащего скрытые фильтром строки, невозможно. Перемещение возможно только после отключения фильтрации.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выделите ячейки, которые необходимо переместить или скопировать.

  3. Варианты действий:

    Если выделенные ячейки необходимо переместить, щелкните кнопку Вырезать [image].

    Если выделенные ячейки необходимо скопировать, щелкните кнопку Копировать [image].

  4. Выделите ячейку в левом верхнем углу диапазона, в который необходимо вставить данные.

  5. Щелкните кнопку Вставить [image].

Примечания

  • При вставке и перемещении данных в диапазон ячеек прежние данные удаляются и заменяются новыми.

  • При перемещении ячейки с формулой, содержащиеся в формуле ссылки не изменяются. При копировании формулы не изменяются только абсолютные ссылки, а относительные ссылки изменяются. См. сведения об абсолютных и относительных ссылках.

  • Вырезанные данные можно вставить только один раз. Скопированные данные можно вставлять многократно. Поэтому вставить данные в несколько ячеек или диапазонов можно быстрее, если воспользоваться кнопкой Копировать. После завершения вставки, исходные данные можно выделить и удалить.


Вставка в лист строки или столбца

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите ячейку справа от того места, где необходимо вставить новый столбец или в строке ниже того места, где необходимо вставить новую строку.

    Чтобы вставить несколько строк или столбцов, необходимо выбрать несколько ячеек. Например, для вставки трех строк, выберите в столбце три ячейки.

  3. Варианты действий:

    Для вставки строки щелкните правой кнопкой мыши выделенную ячейку или выделенный диапазон ячеек, в появившемся контекстном меню выберите пункт Добавить, затем щелкните пункт Строки.

    Для вставки столбца щелкните правой кнопкой мыши выделенную ячейку или выделенный диапазон ячеек, в появившемся контекстном меню укажите на пункт Добавить, а затем щелкните пункт Столбцы.


Удаление из листа строк и столбцов

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Если необходимо удалить одну строку или один столбец, щелкните ячейку, принадлежащую строке или столбцу соответственно.

    Если необходимо удалить несколько строк или столбцов, выделите соответствующий диапазон ячеек.

  3. Варианты действий:

    Для удаления строки (или строк) щелкните правой кнопкой мыши выделенную ячейку или выделенный диапазон ячеек, в появившемся контекстном меню укажите на пункт Удалить, затем щелкните пункт Строки.

    Для удаления столбца (или столбцов) щелкните правой кнопкой мыши выделенную ячейку или выделенный диапазон ячеек, в появившемся контекстном меню укажите на пункт Удалить, затем щелкните пункт Столбцы.

Примечания

  • Если диапазон содержит строки, скрытые фильтром, то удалить строки или столбцы этого диапазона невозможно. В этом случае для удаления строк или столбцов необходимо вначале отключить фильтрацию нажатием на кнопку Автофильтр [image].

  • После удаления данных, используемых оставшейся на листе формулой, в ячейке с формулой появится сообщение об ошибке в виде #ССЫЛКА.


Очистка содержимого ячеек листа

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите ячейки, которые необходимо очистить.

  3. Нажмите клавишу DELETE.

Подсказка. При очистке содержимого ячеек удаляются только значения и формулы этих ячеек, но сохраняется их форматирование. Чтобы удалить значения и формулы вместе с форматированием, выберите ячейки, а затем нажмите Вырезать [image].


Использование формул в листе

Далее представлены сведения по следующим темам:

Что такое формула?

Элементы формулы.

Вычисление.

Константы и зависимые ячейки.

Функции.

Что такое формула?

Формула выполняет операции с данными, содержащимися на листе, а также с иными данными. К числу этих операций относятся арифметические операции (сложение, умножение и т. д.), операции сравнения значений, сочленения текста и прочие. Например, следующая формула складывает значение, содержащееся в ячейке А1, со значением, содержащимся в ячейке А2:

=A1+A2

См. сведения о наиболее часто используемых для листов формулах.

В формулах можно использовать константы (числовые и текстовые значения), ссылки на ячейки листа, а также данные Web-страницы, на которой находится лист.

Возврат в начало.

Элементы формулы

Любая формула листа начинается со знака равенства (=). За знаком равенства следуют операнды, между которыми ставятся операторы (знаки операций, таких как умножение, сложение и вычитание). См. сведения об операторах и выражениях.

Возврат в начало

Вычисление

Формулы вычисляются слева направо в порядке, установленном для операций. Например, операция умножения приоритетнее операции сложения. Рассмотрим следующий пример:

=5+2*3*4

Вначале выполняется операция умножения 2*3. Затем получившийся результат (6) умножается на 4. Последней выполняется операция сложения 5+24, в результате чего получается 29. См. сведения о порядке вычислений.

Для изменения порядка вычисления следует применяются скобки. Если, например, в приведенном выше примере поставить скобки, как показано ниже, то вначале будет выполнена операция сложения (5+2), а затем — операция умножения 7*3*4, в результате чего получится 84.

=(5+2)*3*4

Результат, вычисляемый формулой, обновляется автоматически, то есть пересчитывается после каждого изменения значений в ячейках, на которые в формуле содержатся ссылки. См. сведения о вычислении на листе.

Примечание. Если используется возможность Отображать справа налево, то знак равенства, которым начинается формула, ставится справа, и вычисления производятся справа налево.

Возврат в начало.

Константы и зависимые ячейки

В формуле можно использовать как константы, так и ссылки на другие ячейки. Ячейка с формулой называется зависимой, если ее значение зависит от значений других ячеек. Например, ячейка B2 является зависимой, если содержит формулу =C2.

По умолчанию принято следующее: значение в зависимой ячейке пересчтывается после любого изменения значений в ячейках, на которые в формуле содержатся ссылки. Например, значение в ячейке с формулой =B2+C2+D2 пересчитывается при изменении значения в любой из ячеек B2, C2, D2.

Данные на листе.

Если в формуле в ячейке не содержится ссылок на другие ячейки (например, формула имеет вид =30+70+110), то значение в такой ячейке изменяется только после изменения формулы.

Возврат в начало.

Функции

Web-компонент для листов содержит множество заранее определенных, то есть встроенных формул, называемых функциями. Эти функции позволяют выполнять как простые, так и сложные вычисления. Наиболее часто используется функция СУММ, которая суммирует числа, содержащиеся в диапазоне ячеек. См. сведения об использовании функций для вычислений на листе.

Возврат в начало.


Ссылки на ячейки и диапазоны листа

Ссылка является адресом ячейки или диапазона. Она указывает формуле, где искать данные. Благодаря ссылкам, в одной формуле можно использовать значения, находящиеся в различных частях листа, а также использовать в нескольких формулах значение, содержащееся в одной ячейке.

Адрес ячейки состоит из адреса столбца и адреса строки. Столбцы обозначаются буквами (от А до ZZ, всего 702 столбца), а строки — числами (от 1 до 65536). Вначале указывается адрес столбца, затем — адрес строки. Например, D50 обозначает ячейку, находящуюся на пересечении столбца D и строки номер 50. Для обозначения диапазона ячеек вначале указывается ячейка, находящаяся в левом верхнем углу диапазона, затем указывается двоеточие (:), затем — ячейка, находящаяся в правом нижнем углу диапазона. Ниже приведены примеры ссылок.

Ячейка или диапазон | Ссылка
Ячека в столбце А, строке 10. | A10
Диапазон ячеек: столбец А, строки 10-20. | A10:A20
Диапазон ячеек: строка 15, столбцы B-E. | B15:E15
Все ячейки в строке 5. | 5:5
Все ячейки в строках с 5 по 10. | 5:10
Все ячейки в столбце H. | H:H
Все ячейки в столбцах с H по J. | H:J
Диапазон ячеек: столбцы А-E, строки 10-20. | A10:E20

Примечание. Можно использовать как абсолютные, так и относительные ссылки. Относительная ссылка указывает адрес относительно формулы. См. сведения об абсолютных и относительных ссылках.


Абсолютные и относительные ссылки

Относительные ссылки. При создании формул, содержащих ссылки на ячейки или диапазоны ячеек, эти ссылки как правило основаны на расположении указанных ячеек относительно ячеек содержащих формулы. В следующем примере ячейка B6 содержит формулу =A5. Значение находится на одну ячейку выше и на одну левее, чем B6. Это и будет называться относительной ссылкой..

Формула с относительной ссылкой.

При копировании формулы, использующей относительные ссылки, ссылки во вставленной формуле автоматически будут настроены на работу с другими ячейками, в соответствии с изменением позиции ячейки с формулой. В следующем примере в ячейке B6, хранится формула =A5, указывающая на ячейку, расположенную на одну ячейку выше и левее чем B6. Будучи скопированной в ячейку B7, формула автоматически преобразуется в =A6, указывая на ячейку, расположенную на одну ячейку выше и левее чем B7.

Копирование формулы с относительной ссылкой.

Абсолютная ссылка. Если требуется запретить перенастройку ссылок после копирования формулы в другие ячейки, используйте абсолютную ссылку. Чтобы создать ее, введите знак доллара ($) перед неизменной частью ссылки. Например, для создания абсолютной ссылки на ячейку C1 в формуле =A5*C1, добавьте к формуле знаки доллара, как это показано ниже:

=A5*$C$1

Смешанные ссылки. Можно также сделать абсолютную ссылку только на строку или только на столбец. Получится так называемая смешанная ссылка. Например, если необходимо скопировать формулу, в которой ссылка на столбец должна обновляться, а ссылка на строку нет, поставьте знак доллара только перед номером строки:

=C$1

Дополнительные сведения

См. Ссылки на ячейки и их диапазоны.


Вычисления в листе

Вычисления — механизм, с помощью которого рассчитываются формулы ячеек листа электронной таблицы, а полученные результаты выводятся как значения в этих ячейках. По умолчанию, если происходят изменения в ячейках, на которые ссылаются формулы, они автоматически пересчитываются. Однако, есть возможность изменить порядок обсчета листа.

См. сведения о использовании формул в листах.

Отличия между хранимыми и отображаемыми значениями. Иногда значения по разному хранятся и отображаются. Даты и время, например, хранятся в числовом формате, но отображаются как правило в одном из установленных для даты и времени форматов. Лист использует хранимые числовые представления даты и времени для вычислений, именно поэтому не составляет труда рассчитать число дней между двумя датами.

Формат в котором отображаются хранимые значения иногда зависит от выбора пользователя. Например, можно отформатировать ячейку, содержащую число 123456789, для отображения его как 1.23E+08, используя экспоненциальный формат. Также можно отформатировать ячейку с датой, числовое представление которой 36699 так, чтобы она отображалась как "22.06.2000" или как "22 июн 2000". Изменение представления значения не влияет на само хранимое значение. См. Изменение формата чисел в ячейках листа.

Национальные стандарты, заданные в диалоговом окне Свойства: Язык и стандарты панели управления Windows, определяют способ отображения чисел, денежных единиц, дат и времени. Например, в зависимости от этих стандартов год отображается с двумя или четырьмя цифрами. Дополнительные сведения об этих форматах содержатся в справке Windows.


Операторы и выражения в формулах для вычислений на листе

Операторы служат для выполнения операций над элементами формулы. Web-компонент для электронных таблиц (листов) содержит четыре типа операторов: арифметические операторы, операторы сравнения, текстовые и операторы ссылок.

Арифметические операторы. Служат для выполнения арифметических операций, таких как сложение, вычитание, умножение. Операции выполняются над числами. Используются следующие арифметические операторы.

Арифметический оператор | Операция | Пример
+ (знак «плюс») | Сложение | 3+3
– (знак «минус») | Вычитание Отрицание | 3–1 –1
* (звездочка) | Умножение | 3*3
/ (косая черта) | Деление | 3/3
% (знак процента) | Проценты | 20%
^ (шляпка) | Возведение в степень | 3^2 (эквивалентно 3*3)

Операторы сравнения. Используются для сравнения двух значений. Результатом сравнения является логическое значение: либо ИСТИНА, либо ЛОЖЬ.

Оператор сравнения | Операция | Пример
= (знак равенства) | Равно | A1=B1
> (знак «больше») | Больше | A1>B1
< (знак «меньше») | Мешьне | A1<B1
>= (знак «больше или равно») | Больше или равно | A1>=B1
<= (знак «меньше или равно») | Меньше или равно | A1<=B1
<> (знак «не равно») | Не равно | A1<>B1

Текстовый оператор конкатенации. Амперсанд (&) используется для объединения нескольких текстовых строк в одну строку.

Текстовый оператор | Операция | Пример
& (амперсанд) | Конкатенация | "Северный " & "ветер" = "Северный ветер"

Оператор ссылки. Для описания ссылок на диапазоны ячеек используются следующие операторы.

Оператор сссылки | Операция | Пример
: (двоеточие) | Ставится между ссылками на первую и последнюю ячейки диапазона. Такое сочетание является ссылкой на диапазон. | B5:B15
, (запятая) | Оператор объединения. Объединяет несколько ссылок в одну ссылку. | СУММ(B5:B15,D5:D15)
(один пробел) | Оператор пересечения множеств, служит для ссылки на общие ячейки двух диапазонов. | СУММ(B5:B15 A7:D7) В этом примере общей ячейкой двух диапазонов является ячейка B7.


Порядок расположения операторов в формулах листа

Если в формуле содержится несколько операторов, то порядок вычислений определяется приоритетом операторов. Вначале выполняются операции с более высоким приоритетом, затем — с менее высоким. Если формула содержит операторы с одинаковым приоритетом, например, операторы умножения и деления, то операции выполняются слева направо. Для изменения порядка выполнения операций используются скобки. Вначале вычисляются те части формулы, которые заключены в скобки, затем — остальные части. См. сведения об операторах для вычислений.

Оператор | Описание
: (двоеточие) (один пробел) , (запятая) | Эти операторы применяются в ссылках.
– | Знак «минус»
% | Процентный
^ | Оператор возведения в степень.
* и / | Умножение и деление.
+ и – | Сложение и вычитание.
& | Конкатенация (объединение двух строк текста в одну).
= < > <= >= <> | Операторы сравнения.


Создание формул на листе

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Щелкните ячейку, к которой необходимо добавить формулу.

  3. Введите знак равенства (=).

  4. Введите формулу.BR>
  5. Нажмите клавишу ENTER.

Подсказка. Можно автоматически добавить сумму для диапазона ячеек с помощью кнопки Автосумма.

Дополнительные сведения

См. Использование формул на листе.

См. Использование функций на листе.

Разрешение вопросов, связанных с ошибочными значениями в формулах.


Изменение формул в листе

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Дважды щелкните ячейку с формулой, которую необходимо изменить. Формула отобразится в этой ячейке.

    Если ячейка содержит гиперссылку, щелкните соседнюю ячейку, затем вернитесь к ячейке с формулой, используя клавишу со стрелкой. Щелкните по этой ячейке один раз.

  3. Измените формулу в ячейке.

  4. Нажмите клавишу ENTER.


Создание формулы, использующей данные на той же Web-странице

Формула в ячейке может использовать для вычислений данные, находящиеся на той же Web-странице, где размещена диаграмма. Выполняется это с помощью функции HTML «Документ». Например, если на Web-странице существует элемент управления текстовым полем с именем «Text1», следующая формула отобразит в ячейке значение, содержащееся в этом текстовом поле.

=document.text1.value

Есть также возможность использовать в формулах значения, содержащиеся на Web-странице. Например, если в текстовом поле на Web-странице содержится сумма продаж, а ячейка C1 листа содержит процентную норму комиссионного вознаграждения, то следующая формула вычислит сумму комиссионного вознаграждения, умножив сумму продаж на значение, содержащееся в ячейке C1:

=$C$1*document.text1.value

Можно также ссылаться на ячейки другого Web-листа, размещенного на той же Web-странице. Например, если на Web-странице находятся два листа spreadsheet1 и spreadsheet2, то следующая формула листа spreadsheet1 отобразит значение, содержащееся в ячейке A1 листа spreadsheet2:

=document.spreadsheet2.range("a1").value

Более подробные сведения о функциях, элементах управления и свойствах, которые можно использовать при работе с Web-листом, содержатся в справке по программированию Web-листов.


Одновременный просмотр формулы и результата

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Щелкните ячейку с формулой, которую необходимо просмотреть.

  3. На панели инструментов листа щелкните кнопку Панель свойств [image].

  4. Если раздел Вычисления не развернут, щелкните панель Вычисления.

  5. Формула отображается в поле Формула в активной ячейке (ссылка). Результат вычисления по этой формуле отображается рядом.

Примечания

  • Для просмотра формулы в другой ячейке щелкните ячейку, не сворачивая раздел Вычисления.

  • Длинные формулы и значения могут не поместиться в разделе Вычисления. В этом случае, для просмотра всей формулы щелкните ячейку с формулой и нажмите клавишу F2. По завершении просмотра формулы можно вернуться к листу нажатием клавиши ESC.


Добавление суммы для диапазона ячеек листа

Можно добавить сумму диапазону ячеек автоматически с помощью кнопки Автосумма.

Применение “Автосуммы” для вычисления суммы диапазона ячеек.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. В столбце ниже данных, которые необходимо просуммировать, или в строке правее их выберите первую незаполненную ячейку.

  3. На панели инструментов листа щелкните кнопку Автосумма [image].

    Предполагаемый вариант формулы отобразится в выделенной ячейке (для строки) или в ячейке под выбранным диапазоном (для столбца).

  4. Варианты действий:

    Для подтверждения варианта формулы нажмите кнопку ENTER.

    Чтобы изменить вариант формулы, выберите диапазон, который необходимо просуммировать и нажмите кнопку ENTER.

Примечание. Если суммируется столбец данных, можно вначале выбрать диапазон ячеек, который необходимо просуммировать, а затем щелкнуть кнопку Автосумма [image].


Примеры наиболее часто применяемых формул

Далее приведены примеры формул, часто применяемых для вычислений на Web-листах (электронных таблицах). См. Использование формул в листе.

Суммирование значений, сопровождающихся заданным условием.

Подсчет количества значений, удовлетворяющих заданному условию.

Вычисление текущего остатка.

Конкатенация имени и фамилии.

Конкатенация даты и текста.

Увеличение числа на заданное количество процентов.

Суммирование значений, сопровождающихся заданным условием

Формул СУММЕСЛИ суммирует только те значения диапазона ячеек, которым соответствует заданное значение в другом диапазоне ячеек. Приведенная ниже формула суммирует те значения диапазона F5:F25, которым соответствует значение «Борей» в диапазоне B5:B25.

=СУММЕСЛИ(B5:B25,"Борей",F5:F25)

Возврат в начало.

Подсчет количества значений, удовлетворяющих заданному условию

Формула СЧЁТЕСЛИ вычисляет количество ячеек в диапазоне, содержащих заданное значение, например количество ячеек в диапазоне B5:B25, содержащих текст «Борей».

=СЧЁТЕСЛИ(B5:B25,"Борей")

Возврат в начало.

Вычисление текущего остатка

С помощью формул на листе удобно вести учет банковских операций, например, подсчитывать текущий остаток на банковском счету. Пусть в ячейке F6 содержится предыдущий остаток, в ячейке D7 — сумма поступления, в ячейке E7 — снятая со счета сумма наличными.

Для вычисления текущего остатка этой операции введите в ячейку F7 следующую формулу:

=СУММ(F6,D7,–E7)

Для вычисления текущих остатков следующих операций можно просто копировать эту формулу в соответствующие ячейки.

Возврат в начало.

Конкатенация имени и фамилии

Оператор & (амперсанд) конкатенирует два текстовых значения, то есть объединяет их в одно значение. Его можно использовать, например, для конкатенации имен с фамилиями, содержащимися в разных столбцах. Пусть ячейка D5 содержит имя, а ячейка E5 — фамилию.

Чтобы отобразить в одной ячейке имя и фамилию в формате «имя фамилия» (например, Иван Петров), следует ввести в эту ячейку следующую формулу:

=D5&" "&E5

Чтобы отобразить в одной ячейке имя и фамилию в формате «фамилия имя» (например, Петров Иван), следует ввести в эту ячейку следующую формулу:

=E5&", "&D5

Возврат в начало.

Конкатенация даты и текста

Оператор & (амперсанд) конкатенирует два текстовых значения, то есть объединяет их в одно текстовое значение. Для объединения в одной ячейке текста с числом, датой или временем служит функция ТЕКСТ, которая преобразует аргумент в текстовое значение. Пусть ячейка F5 содержит дату выставления счета 5 июня 2000. В этом случае приведенная ниже формула позволяет отобразить в одной ячейке текст «Дата выставления счета: 5-июн-2000».

="Дата выставления счета: "&ТЕКСТ(F5, "d-mmm-yyyy")

Возврат в начало.

Увеличение числа на заданное количество процентов

Следующий пример показывает простой способ увеличения числа на заданное количество процентов. Пусть число, содержащееся в ячейке F5, необходимо увеличить на 5%. Для этого вводится следующая формула:

=F5*(1+5%)

Если количество процентов, на которое нужно увеличить число, содержится в ячейке F2, то формула записывается в следующем виде:

=F5*(1+$F$2)

В приведенном примере ссылка на ячейку F2 является абсолютной, поэтому эту формулу можно копировать в другие ячейки, не изменяя ссылку на ячейку F2.

Возврат в начало.


Изменение порядка пересчета листа

Если в листе содержится много формул, может потребоваться достаточно продолжительное время для их пересчета. Чтобы ускорить работу, можно изменить порядок пересчета формул с автоматического на ручной так, чтобы пользователь сам мог решать, когда необходимо пересчитывать лист.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Вычисления не развернут, щелкните панель Вычисления.

  4. Варианты действий:

    Чтобы пересчитывать лист всякий раз, когда изменяются данные, выберитеАвтоматические вычисления.

    Чтобы вычислять данные только при нажатии клавиши F9 или кнопки Пересчет, выберите режим Вычисление по запросу.


Использование функций в электронной таблице

Функции

Функция — это встроенная в лист (электронную таблицу) формула для вычисления значения на основе других значений, которые называются аргументами. Результат вычисления иногда зависит от порядка аргументов. Примеры функций: СУММ суммирует значения, содержащиеся в диапазоне ячеек; функция ППЛАТ вычисляет суммы выплат для погашения ссуды в зависимости от процентной ставки, срока и суммы ссуды. См. список доступных функций.

Аргументы. Существуют различные типы аргументов: число, текст, логическое значение (ИСТИНА и ЛОЖЬ), значение ошибки (например #Н/Д), ссылка на ячейку или диапазон ячеек. В качестве аргументов используются константы, формулы, функции. В каждом конкретном случае необходимо использовать соответствующий тип аргумента.

Структура. Функция имеет следующую структуру: имя функции, открывающая скобка, список аргументов, разделенных запятыми, закрывающая скобка. Если формула начинается с функции, то перед именем функции следует поставить знак равенства (=).

Вложенные функции

Допускается использование функции в качестве аргумента другой функции. В следующей формуле функция СРЗНАЧ вложена в функцию ЕСЛИ для сравнения среднего значения нескольких значений с числом 50.

Допустимые типы вычисляемых значений. Вложенная функция, используемая в качестве аргумента, должна вычислять соответствующий этому аргументу тип данных. Например, если аргумент должен быть логическим, то есть иметь значение либо ИСТИНА, либо ЛОЖЬ, то вложенная функция в результате вычислений тоже должна давать логическое значение либо ИСТИНА, либо ЛОЖЬ. Иначе появится сообщение об ошибке «#ЗНАЧ!».

См. Сообщения об ошибках функций.


Изменение внешнего вида данных в листе

Изменение формата данных

Изменение шрифта, стиля и размера текста.

Изменение формата чисел.

Дополнительные сведения о встроенных форматах чисел.

Изменение выравнивания данных

Выравнивание данных по левому краю, по центру или по правому краю ячейки.

Выравнивание данных по верхнему краю, по нижнему краю либо по центру ячейки.


Изменение формата числа в ячейке листа

При изменении формата числа в ячейке, хранимое значение для числа не изменяется. Например, для даты 22.06.2000, хранимое значение — 36699 и оно остается таким даже когда формат даты изменяется на Четверг, 22 Июня, 2000.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите ячейки, формат которых необходимо изменить.
  3. На панели инструментов листа щелкните кнопку Панель свойств [image] .

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. Выберите требуемый формат чисел в списке Формат чисел.

См. сведения о форматах чисел.


Форматы чисел

Для изменения формат чисел на листе используется панель свойств листа как в программе-конструкторе, так и в обозревателе. Национальные стандарты, заданные в диалоговом окне Свойства: Язык и стандарты панели управления Windows, также определяют способ отображения чисел, денежных единиц, дат и времени Например, в зависимости от этих стандартов год отображается либо двузначным, либо четырехзначным числом. Дополнительные сведения об этих форматах содержатся в справке системы Windows.

С помощью Microsoft Visual Basic и сценариев можно создавать нестандартные форматы чисел. См. сведения о вызове справки по программирования для электронных таблиц.

Из списка Формат чисел в разделе Формат на панели свойств листа можно выбрать следующие форматы чисел. См. также Изменение формата числа в ячейке.

Формат | Описание
Полный формат даты | Отображает число как дату и/или время. Например: число 36403,24583 отображается как 8/31/99 05:54 AM. Дробная часть числа считается временем. Если число не содержит дробной части, отображается только дата. Если число содержит только дробную часть, отображается только время.
Длинный формат даты | Отображает дату, используя длинный формат даты, заданный в разделе «Язык и стандарты» панели управления Windows. Пример: четверг, 25 января, 2001.
Средний формат даты | Отображает дату, разделяя месяц и число в соответствии с национальными стандартами, принятыми в Windows. Для года отводятся две цифры. Пример: 25 янв 01.
Краткий формат даты | Отображает дату, используя краткий формат даты, заданный в разделе «Язык и стандарты» панели управления Windows. Пример: 1/25/01.
Длинный формат времени | Отображает время, используя длинный формат времени, заданный в разделе «Язык и стандарты» панели управления Windows. Пример: 8:45:36 PM.
Средний формат времени | Отображает время суток в 12-часовом формате с указателем AM или PM, без указания секунд. Пример: 8:45 PM.
Краткий формат времени | Отображает время суток в 24-часовом формате, без указания секунд. Пример: 20:45.
Основной | Этот формат отображает число с выравниванием по правому краю, без разделителя разрядов. Перед отрицательным числом ставится знак минус. Отображает до 11 цифр без точки, либо до 10 цифр с разделителем целой и дробной части. Число, содержащее более 11 цифр перед разделителем целой и дробной части, отображается в экспоненциальном формате. Текст выравнивается по левому краю.
Денежный | Отображает число в соответствии с национальными стандартами, заданными в разделе «Язык и стандарты» панели управления Windows, с разделителем групп разрядов и двумя десятичными знаками. Например, для русского языка по умолчанию принят стандарт, в соответствии с которым денежная сумма отображается в виде 2,532.75 р.
Евро | Отображает число как денежную сумму, выраженную в евро, с разделителями групп разрядов и двумя десятичными знаками. Знак евро помещается перед числом или после числа в соответствии с национальными стандартами для денежных единиц, установленным на панели управления Windows. Пример, соответствующий национальным стандартам английского языка, США: 12.35.
Фиксированный | Отображает число с двумя десятичными знаками. Пример: 68,30.
Стандартный | Отображает число с разделителем групп разрядов и двумя цифрами справа от десятичного разделителя. В качестве разделителя групп разрядов обычно используется точка или запятая в зависимости от национальных стандартов, заданных с помощью панели управления Windows в разделе «Язык и стандарты». Пример использования запятой в качестве разделителя групп разрядов: 1,800.00.
Процентный | Отображает число, умноженное на 100, с двумя десятичными знаками и знаком процента. Например, число 0,8914 отображается как 89,14%.
Экспоненциальный | Отображает числа в экспоненциальном представлении. Пример: 1,25E+10.
Логический | Отображает «Нет», если число равно 0, во всех остальных случаях — «Да».
Истина/ложь | Отображает «Ложь», если число равно 0, во всех остальных случаях — «Истина».
Вкл/Выкл | Отображает «Выкл», если число равно 0, в остальных случаях — «Вкл».


Изменение шрифта и его размера на листе

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите ячейки, формат которых необходимо изменить.

  3. На панели инструментов листа щелкните кнопку Панель свойств [image].

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. Варианты действий:

    Для изменения начертания текста щелкните соответствующую кнопку в группе Формат текста.

    Шрифт текста выбирается в списке Шрифт.

    Размер шрифта выбирается в списке Шрифт.


Изменение ширины столбца

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Убедитесь, что названия столбцов отображены.

  3. Задержите указатель мыши на правой границе названия столбца, чтобы указатель принял следующий вид Указатель с двумя горизонтальными стрелками.

  4. Варианты действий:

    Перетащите границу до нужной ширины столбца.

    Чтобы ширина столбца приняла значение, соответствующее ширине данных, дважды щелкните правую границу столбца.

Примечания

  • Чтобы изменить ширину нескольких столбцов, выделите эти столбцы, затем измените ширину столбцов либо перетаскиванием мышью границы любого из выделенных столбцов, либо двойным щелчком по границе столбца.

  • Ширину столбца можно задать в пикселах с помощью команды Ширина столбца в разделе Формат панели свойств листа. В этом случае предварительно отображать названия столбцов необязательно.


Изменение высоты строки в листе

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Убедитесь, что на экране видны номера строк.

  3. Задержите указатель мыши на нижней границе заголовка строки, которую необходимо изменить, чтобы указатель принял следующий вид Указатель мыши в виде четырех стрелок.

  4. Варианты действий:

    Перетащите границу до нужной высоты строки.

    Чтобы высота строки приняла значение, соответствующее высоте данных, дважды щелкните нижнюю границу строки.

Примечания

  • Чтобы одновременно изменить высоту нескольких строк, выделите их, прежде чем выполнять одно из вышеуказанных действий.

  • Можно изменить высоту строки согласно заданному числу пикселов, используя команду Высота строки в разделе Формат на панели свойств листа. При использовании этого метода предварительное отображение номеров строк не обязательно.


Границы диапазона ячеек

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите диапазон ячеек, который необходимо очертить границами.

  3. На панели инструментов листа щелкните кнопку Панель свойств [image].

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. В группе Формат ячейки нажмите кнопку Границы [image].

  6. Щелчками мыши по линиям на рисунке со схемой границ установите нужные границы, уберите лишние границы. Для установки или снятия всех границ внутри диапазона щелкните точку пересечения границ.

    Схема границ зависит от выделенного диапазона. Например, если выделена только одна ячейка, то на схеме будут четыре границы, по одной на каждую сторону ячейки. Если выделено несколько ячеек, то появляется возможность установить на схеме границы внутри этого диапазона ячеек.

Примечание. Есть возможность изменить цвет и толщину границ.


Изменение цвета или ширины границ листа

Эта процедура предусмотрена только для границ, размещаемых вокруг ячеек. Нельзя изменить цвет или ширину линий сетки на листе.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите ячейки, границы которых необходимо изменить.

  3. На панели инструментов листа щелкните кнопку Панель свойств [image].

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. В группе Формат ячейки нажмите кнопку Границы [image].

  6. Чтобы изменить цвет, щелкните кнопку Цвет границы [image], а затем выберите другой цвет.

    Чтобы изменить ширину, выберите требуемый размер из списка.

  7. На диаграмме границ, щелкните по существующим линиям границ, чтобы выключить их. Повторный щелчок этих же линий вновь включит их, но уже с новыми установками для цвета и ширины.

    При нажатии на границу в диаграмме границ, с ней не происходит видимых изменений. Однако соответствующая граница в выделенном диапазоне или ячейке будет изменена.


Выравнивание данных по верхнему краю, по центру или по нижнему краю ячейки

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите ячейки, данные в которых необходимо выровнять.

  3. На панели инструментов листа щелкните кнопку Панель свойств [image].

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. Выберите требуемый способ выравнивания в списке Выравнивание по горизонтали.

Примечание. Общий тип выравнивания предполагает выравнивание текста по левому краю ячейки, а даты, числа и время — по правому краю.


Выравнивание данных в ячейке по верхнему краю, по нижнему краю либо по центру

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите ячейки, данные в которых необходимо выровнять.

  3. На панели инструментов листа щелкните кнопку Панель свойств [image].

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. Выберите способ выравнивания в списке Выравнивание по вертикали.


Изменение цвета фона ячеек листа

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите ячейки, которые необходимо изменить.

  3. На панели инструментов листа щелкните кнопку Панель свойств [image].

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. В группе Формат ячейки щелкните стрелку справа от кнопки Цвет заливки [image].

  6. Выберите в палитре цветов нужный цвет.


Объединение нескольких ячеек листа в одну

Внимание! Когда несколько ячеек объединяются в одну, сохраняются только данные из верхней левой ячейки. Данные всех других участвующих в объединении ячеек теряются.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите ячейки, которые необходимо обединить.
  3. На панели инструментов листа щелкните кнопку Панель свойств [image] .

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. В группе Формат ячеек выберите Объединение ячеек [image].


Разделение объединенных ячеек листа

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Щелкните объединенную ячейку, которую необходимо разделить.

  3. На панели инструментов листа щелкните кнопку Панель свойств [image].

  4. Если раздел Формат не развернут, щелкните панель Формат.

  5. В группе Формат ячейки нажмите кнопку Отменить объединение ячеек [image].


Изменение строки названия листа

Инструкции.

Изменение текста строки названия.

Изменение шрифта и стиля текста.

Изменение цвета фона.


Изменение текста строки названия листа

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Строка названия не развернут, щелкните панель Строка названия.

  4. В поле Название измените текст названия.

Примечания

  • Если длина введенного текста превысит длину строки названия, то часть текста будет скрыта за краем строки названия.

  • В обозревателе у пользователей есть возможность либо скрыть, либо отобразить строку названия. Однако команды раздела Строка названия в обозревателе недоступны.


Изменение шрифта и стиля строки названия листа

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Строка названия не развернут, щелкните панель Строка названия.

  4. Выберите необходимые параметры формата.

    Чтобы выбрать для текста названия полужирный шрифт, щелкните кнопку Полужирный [image].

    Чтобы текст названия отображался курсивом, щелкните кнопку Курсив [image].

    Для подчеркивания текста названия щелкните кнопку Подчеркнутый [image].

    Для изменения цвета текста названия щелкните стрелку справа от значка Цвет шрифта [image], затем выберите нужный цвет. Если цвет шрифта совпадет с цветом фона, то текст станет невидимым.

    Шрифт выбирается в списке Шрифт. В этом списке содержатся шрифты, установленные в операционной системе компьютера.

    Размер шрифта выбирается в списке Размер. В этом списке содержатся размеры шрифтов, установленных в операционной системе компьютера.

Примечание. В обозревателе у пользователей есть возможность либо скрыть, либо отобразить строку названия. Однако команды раздела Строка названия в обозревателе недоступны.


Изменение цвета фона строки названия листа

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Строка названия не развернут, щелкните панель Строка названия.

  4. Щелкните стрелку раскрывающегося списка Цвет фона [image], затем выберите необходимый цвет.

    Если цвет текста совпадет с цветом фона, то текст станет невидимым.

Примечание. В обозревателе у пользователей есть возможность либо скрыть, либо отобразить строку названия. Однако команды раздела Строка названия в обозревателе недоступны.


Запрет и разрешение сортировки на листе в обозревателе

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Защита не развернут, щелкните панель Защита.

  4. Варианты действий:

    Чтобы разрешить сортировку, установите флажок Разрешить сортировку.

    Чтобы запретить сортировку, снимите флажок Разрешить сортировку и установите флажок Включить защиту.

Примечание. Установка и снятие флажка Включить защиту влияет на все параметры защиты, в том числе на действие флажков Разрешить фильтр и Блокировка ячеек. Если требуется разрешить пользователям в обозревателе изменять содержимое ячеек листа, необходимо указать ячейки, изменение которых допустимо после защиты листа.


Сортировка данных на листе

Данные, которые необходимо отсортировать, должны быть скомпонованы в виде списка. В первой строке каждого столбца списка содержится название столбца, а в остальных строках столбца содержатся элементы данных одного типа. Пустые строки и столбцы в списке недопустимы.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Варианты действий:

    Для сортировки всего списка выделите в нем ячейку. Названия столбцов в сортировке не участвуют.

    Для сортировки части листа выделите диапазон ячеек. Если названия столбцов не должны сортироваться, не выделяйте названия.

  3. Варианты действий:

    Для сортировки строк в порядке возрастания (текст сортируется в алфавитном порядке) нажмите кнопку Сортировка по возрастанию [image] на панели инструментов листа, затем выберите столбец, по которому должна выполняться сортировка.

    Для сортировки строк в порядке убывания (текст сортируется в порядке, обратном алфавитному) нажмите кнопку Сортировка по убыванию [image], затем выберите столбец, по которому должна выполняться сортировка.

Примечания

  • Строки, скрытые фильтром, не сортируются.

  • Сортировать можно только строки. Сортировать в тои или ином порядке столбцы невозможно.

  • При сортировке не учитывается регистр букв. Например, при сортировке в порядке возрастания строки со словами «АРБУЗ» и «арбуз» окажутся выше строк со словами «БАНАН» и «банан».

  • Для сортировки по нескольким столбцам следует выполнить несколько сортировок, по одной сортировке на каждый столбец.


Сортировка данных по нескольким столбцам листа

Для сортировки данных по нескольким столбцам следует выполнить сортировку отдельно по каждому из столбцов. Порядок сортировки столбцов зависит от способа организации данных.

Пример: сортировка данных по двум столбцам.

В приведенном примере за основу организации данных в таблице взят столбец «Продавец». Вначале сортировка в алфавитном порядке выполнена в столбце «Товар», затем — в столбце «Продавец».

Прежде чем сортировать несколько столбцов, следует прежде всего определить требуемый порядок категоризации, а затем выполнять работу в обратном порядке, в последнюю очередь сортируя столбец с наивысшей категорией. Например, если сортировка выполняется по двум столбцам, вначале определите какой из столбцов имеет высшую, а какой низшую категории друг относительно друга. Первым сортируется столбец с низшей категорией, последним — столбец с высшей категорией. В приведенном примере для сортировки товаров в алфавитном порядке для каждого продавца вначале была выполнена сортировка в столбце «Товар»(низшая категория), а затем — в столбце «Продавец»(высшая категория).

Сортировка данных в листе.


Поиск данных на листе

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Варианты действий:

    Для поиска по всему листу выделите одну ячейку.

    Для поиска в диапазоне ячеек выделите этот диапазон.

  3. На панели инструментов листа щелкните кнопку Панель свойств [image].

  4. Если раздел Найти не развернут, щелкните панель Найти.

  5. Введи в поле поиска текст или значение, которое необходимо найти.

  6. Щелкните кнопку Найти далее.

Примечания

  • Возможности поиска. С помощью команды Найти можно искать текст, числа, даты и время. Команда Найти позволяет найти как значения, введенные в ячейки с клавиатуры, так и значения, вычисленные по формулам. Ниже приведены примеры поиска.
Искомые значения | Найденные значения
Джон | Джон Джонсон Малютка Джон
сын | сынок пасынок
Джонс | Джонс Джонсон
5201 | 5201 (число) Улица Ленина 5201 (текст)

  • Знаки подстановки. Команда Найти не поддерживает знаки подстановки, такие как ? и *.
  • Значения заданного формата. Команда Найти ищет значения, а не форматы. Пусть, например, для ячейки установлен логический формат. Если эта ячейка содержит значение 0 (ноль), то в ячейке отображается слово Нет. Но если с помощью команды Найти выполнить поиск текста Нет, то упомянутая логическая ячейка не будет найдена.
  • Направление поиска. Команда Найти ищет значение слева направо вначале в первой строке, затем слева направо во второй строке и так далее.

  • Скрытые данные. Команда Найти не ищет данные в скрытых ячейках, а также в ячейках, скрытых фильтром.


Фильтрация листа для отображения только требуемых данных

Данные, которые необходимо отфильтровать, должны быть скомпонованы в виде списка. В первой строке каждого столбца списка содержится название столбца, а в остальных строках столбца содержатся элементы данных одного типа. Пустые строки и столбцы в списке недопустимы.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите из списка ячейку, которую необходимо отфильтровать.

  3. На панели инструментов листа щелкните кнопку Автофильтр [image].

  4. Щелкните стрелку в столбце, содержащем данные, которые необходимо отобразить.

  5. Варианты действий:

    Чтобы отобразить выделенные элементы, снимите флажок Показать все, а затем установите флажки для каждого из элементов, которые необходимо отображать.

    Чтобы показать все элементы, установите флажок Показать все.

Примечания

  • Чтобы заново отобразить все элементы отфильтрованного столбца, щелкните стрелку столбца и установите флажок Показать все.

  • Чтобы отключить фильтрацию, заново отобразив все элементы листа, повторно щелкните кнопку Автофильтр [image].

  • Нельзя перемещать или удалять данные в диапазоне, включающем отфильтрованные строки. Чтобы переместить или удалить такие данные, прежде выключите фильтрацию.

  • Чтобы отфильтровать диапазон данных, не скомпонованных в виде списка, выберите диапазон, а затем щелкните кнопку Автофильтр [image].

  • Нельзя отфильтровать диапазон, включающий объединенные ячейки. См. Разделение объединенных ячеек.

  • Если требуется запретить пользователям включение или выключение фильтрации при работе с листом, есть возможность запретить фильтрацию в обозревателе.


Суммирование отфильтрованных данных на листе

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Отфильтруйте данные, чтобы отобразить на листе только те строки, которые нужно просуммировать.

  3. Щелкните ячейку по данными, которые необходимо просуммировать.

  4. На панели инструментов листа щелкните кнопку Автосумма [image], затем нажмите клавишу ENTER.

Примечание. Команда Автосумма суммирует только данные в видимых строках. Если необходимо просуммировать все строки, то вначале отобразите на листе все строки, а затем просуммируйте их.


Вставка в лист гиперссылки на Web-страницу

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выделите ячейку, в которую необходимо вставить гиперссылку.

  3. Введите Адрес URL, предварив его текстом http://, затем нажмите клавишу ENTER. Пример: http://example.microsoft.com.

Примечания

  • Если гиперссылку щелкнуть в программе-конструкторе, запустится обозреватель (или активизируется, если он уже открыт) и откроет Web-страницу, на которую указывает гиперссылка.
  • Адрес URL отображается в ячейке синим подчеркнутым текстом. Если цвет текста, сопровождающего гиперссылку, должен отличаться от цвета адреса URL, воспользуйтесь функцией листа ГИПЕРССЫЛКА.


Изменение гиперссылки на листе

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите ячейку, следующую за гиперссылкой, а затем используйте клавиши перемещения курсора для перехода в саму ячейку гиперссылки.

  3. Нажмите F2, чтобы начать редактирование ячейки.

  4. Внесите свои изменения в адрес гиперссылки или в формулу, использующую функцию листа ГИПЕРССЫЛКА.

Примечание. Если изменяются опубликованные из Microsoft Excel гиперссылки, которые изначально были созданы с помощью диалогового окна Excel Добавить гиперссылку, допустимо изменение текста, отображаемого для гиперссылки, но не изменение адреса, на который она указывает.


Вставка в лист данных из различных источников

Самым простым способом вставить в лист данные является следующий: копирование данных из какого-либо источника (текстовый файл, лист Microsoft Excel, документ Microsoft Word) в буфер обмена и вставка этих данных в лист. Для вставки необходимо выделить ячейку, затем нажать кнопку Вставить [image] на панели инструментов листа. Другие способы: импорт данных из Web-страницы или текстового файла, создание формул со ссылками на данные, размещенные на той же Web-странице, где находится Web-лист.

Инструкции

Импорт данных из Web-страницы или текстового файла.

Создание формулы, которая использует данные, находящиеся на той же Web-странице.


Импорт в лист данных из Web-страницы или текстового файла

Данные Web-страницы или текстового файла, которые необходимо импортировать, должны быть таблицей в формате HTML на том же Web-узле или компьютере, что и сам лист. Нельзя выполнить импорт данных с Web-страницы или из текстового файла, которые были сохранены на вашу машину с другого Web-сервера или компьютера.

Внимание! Данные всегда импортируются начиная с ячейки листа A1. Существующие данные будут переписаны без предупреждения.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Импорт данных не развернут, щелкните панель Импорт данных.

  4. В поле URL введите адрес или путь к Web-странице, текстовому файлу содержащему HTML-таблицу, которую необходимо импортировать.

    Пример адреса Web-страницы — http://example.microsoft.com/example.htm

    Пример пути к файлу — file://c:\windows\example.txt

  5. Щелкните кнопку Импортировать.

  6. Если необходимо обновлять лист самыми последними данными Web-страницы или текстового файла, всякий раз когда страница с листом открывается в обозревателе, установите флажок Обновление с адреса URL во время выполнения.

Примечания

  • Нельзя использовать этот метод для импорта изображений или управляющих элементов. Так можно импортировать только HTML-таблицы.

  • Эта команда работает только в программе-конструкторе и не может запускаться при выполнении в обозревателе.


Защита листа

Можно защитить лист так, что пользователи обозревателя будут ограничены или вообще не смогут вносить изменения в ячейки, сортировать, фильтровать данные или использовать панель свойств листа. Параметры защиты можно устанавливать только во время разработки. После установки, они применяются в основном при выполнении в обозревателе и почти совсем не используются в процессе разработки листа.

Запрет на внесение изменений в ячейки пользователями. Если необходимо заблокировать отдельные ячейки, например те, что содержат формулы, можно защитить лист таким образом, что определенная часть или вообще все ячейки будут недоступны для изменения пользователям обозревателя. По умолчанию, все ячейки листа заблокированы. Однако, эти установки не вступят в силу, пока не будет включена защита. Зато когда она будет включена, пользователи не смогут изменить ни одной ячейки в обозревателе, до тех пор пока не будутуказаны ячейки, которые могут изменяться в защищенном листе.

Запрет на фильтрацию и сортировку пользователями. По умолчанию пользователи обозревателя могут выполнять сортировку и фильтрацию даже при включенной защите. Чтобы запретить эти действия, необходимо выбрать соответствующие режимы в разделе Защита на панели свойств листа, а затем включить защиту, чтобы установки вступили в силу. См. сведения о том, как запретить сортировку и запретить фильтрацию при выполнении листа в обозревателе.

Отображение части листа. Есть возможность отобразить только ту часть листа, которая требуется пользователям, закрыв доступ к остальным сведениям.

Запрет отображения панели свойств листа. По умолчания панель свойств листа доступна при выполнении независимо от того была включена защита листа или нет. Существует возможность запретить отображение панели свойств при выполнении без включения защиты.

Примечания

  • Нельзя устанавливать пароли для листов.

  • Если требуется запретить пользователям выполнение каких-либо изменений в листе, попробуйте опубликовать его неинтерактивную HTML-версию. Обратитесь к справке Microsoft Excel за дополнительной информацией.


Запрет и разрешение на включение и отключение фильтрации листа в обозревателе

После запрета включения и отключения фильтрации листа в обозревателе, команда Автофильтр становится недоступной пользователям, поэтому они не могут включать и отключать фильтр. Однако у пользователей остается возможность изменять условия фильтрации списка. Пусть, например, отфильтрованный в программе-конструкторе список показывает сведения о продажах только за определенный месяц. После введения запрета на включение и отключение фильтра, пользователи не могут отключить фильтр, но могут изменять условие фильтрации, отображая в своих обозревателях сведения о продажах за различные месяцы. Если же таблица опубликована без фильтра, то пользователи не смогут включить фильтр.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Защита не развернут, щелкните панель Защита.

  4. Варианты действий:

    Чтобы разрешить пользователям включать и отключать фильтр, установите флажок Разрешить фильтр.

    Чтобы запретить пользователям включать и отключать фильтр, снимите флажок Разрешить фильтр и установите флажок Включить защиту.

Примечание. Установка и снятие флажка Включить защиту влияет на все параметры защиты, в том числе на действие флажков Разрешить сортировку и Блокировка ячеек. Если требуется разрешить пользователям в обозревателе изменять содержимое ячеек листа, необходимо указать ячейки, изменение которых допустимо после защиты листа.


Как разрешить или запретить программам и сценариям отслеживать события на листе

Сведения об автоматизации операций на листе с помощью программ и сценариев смотрите в справке по программам и сценариям.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Дополнительные не развернут, щелкните панель Дополнительные.

  4. В списке Включить события выберите одно из следующего:

    Чтобы разрешить программам и сценариям отслеживать события на листе, выберите пункт Истина.

    Чтобы запретить программам и сценариям отслеживать события на листе, выберите пункт Ложь.

Примечания

  • Сведения о событиях на листе смотрите в справке по Microsoft Visual Basic.

  • Изменить эту установку с помощью панели инструментов обозревателя невозможно.


Запрет отображения панели свойств листа в обозревателе

Описанным ниже способом можно запретить пользователям отображать панель свойств листа в обозревателе. Изменить эту установку средствами обозревателя невозможно.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Защита не развернут, щелкните панель Защита.

  4. Снимите флажок Разрешить отображение панели свойств во время выполнения.

Примечание. В программе-конструкторе панель свойств листа доступна всегда.


Снятие защиты листа

Снять защиту листа можно только в программе-конструкторе. Пользователи, просматривающие лист в обозревателе, снять защиту листа не могут.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. На панели инструментов листа щелкните кнопку Панель свойств [image].

  3. Если раздел Защита не развернут, щелкните панель Защита.

  4. Снимите флажок Включить защиту.


Назначение ячеек, которые могут изменяться после включения защиты листа

По умолчанию ячейки листа заблокированы, однако эти установки реализуются только после того, как защита листа будет включена. Прежде чем сделать это, следует указать ячейки, которые могут быть изменены в защищенном листе. См. Защита листа.

  1. Убедитесь, что лист в окне программы конструктора активизирован. Подробности смотрите в справке программы-конструктора.

  2. Выберите ячейки, которые могут быть изменены после включения защиты листа.

  3. На панели инструментов листа щелкните кнопку панель свойств [image].

  4. Если раздел Защита не развернут, щелкните панель Защита.

  5. Установите флажок Блокировать ячейки.
  6. Чтобы указать ячейки, которые могут быть изменены после включения защиты листа, повторите шаги со 2-го по 5-ый.

  7. Для включения защиты, так чтобы все ячейки, кроме указанных, были заблокированы, установите флажок Включить защиту.

Примечание. Нельзя установить пароль для листа. Однако, может быть возможность установить защиту паролем для Web-страницы, на которой расположен лист с помощью возможностей защиты Web-сервера. Обратитесь к Web-администратору за дополнительной информацией.


Обработка дат 2000 года и более поздних в электронных таблицах

При вводе дат очень важно соблюдать точность формата, поскольку правила обработки дат в программах довольно сложны. Небрежности при вводе дат могут привести к неверным результатам. Самые свежие новости о том, как программные продукты Майкрософт подготовлены к наступлению 2000 года, содержатся на Web-узле Информационного центра Майкрософт по проблеме 2000 года.

Обработка неоднозначных дат. Для обработки неоднозначных дат установлены определенные правила. Одним из этих правил является следующее: если введенная дата содержит месяц и целое двузначное число (две цифры), то двузначное число в диапазоне от 1 до 31 считается днем месяца текущего года. Например, дата «Декабрь 01» распознается как «1 декабря текущего года», а не как «Декабрь 2001 года». Дата «Декабрь 32» распознается как «1 декабря 1932 года», а не как «32 декабря».

Обработка года, заданного двузначным числом. Год, заданный двумя цифрами, по умолчанию обрабатывается по следующим правилам:

  • От 00 до 29. Год, заданный двузначным числом в диапазоне от 00 до 29 включительно, обрабатывается как год двадцать первого века, то есть год в диапазоне от 2000 до 2029. Например, дата 5/28/19 обрабатывается как «28 мая 2019 года».
  • От 30 до 99. Год, заданный двузначным числом в диапазоне от 30 до 99 включительно, обрабатывается как год двадцатого века, то есть год в диапазоне от 1930 до 1999. Например, дата 5/28/99 обрабатывается как «28 мая 1998 года».

Указывайте год четырехзначным числом. Годы, указанные четырехзначными числами, всегда обрабатываются однозначно, что полностью исключает ошибки при обработке дат. Поэтому четырехзначное число для указания года предпочтительнее двузначного. Например, для указания 2001 года рекомендуется вводить 2001, а не 01.

Дата, введенная пользователем в обозревателе, может быть распознана иначе, чем та же дата, введенная в программе-конструкторе, если система пользователя обрабатывает даты по правилам, отличающимся от правил вашей системы. Единственный способ обеспечить верное распознавание дат в обозревателе — вводить годы четырехзначными числами.

Изменение правил распознавания года. Системный администратор может изменить правила, по которым Office распознает даты, например, отнести к двадцатому веку двузначные годы в диапазоне от 35 до 99, а не от 30 до 99. У администратора также есть возможность изменить формат даты, принятый по умолчанию, чтобы год отображался четырехзначным, а не двузначным числом.

О правилах, используемых для распознавания дат вашим компьютером, осведомитесь у системного администратора. Дополнительные сведения о правилах обработки дат и их настройке содержатся в издании Ресурсы Microsoft Office 2000.

Примечание. Если ваш компьютер работает под управлением операционной системы Microsoft Windows 98 или Microsoft Windows 2000, то у вас есть возможность самостоятельно, не прибегая к помощи системного администратора, изменить принятый по умолчанию формат дат, чтобы они отображались с четырехзначным годом. Для этой цели служит панель управления, раздел Язык и стандарты (Windows 98), либо раздел Язык и стандарты (Windows 2000). За дополнительными сведениями обратитесь к справке системы Windows.


Поиск и исправление ошибок на листе

Сообщения об ошибках. Если хотя бы часть формулы содержит ошибку, из-за которой вычисления невозможны, а также в результате некоторых других ошибок, то в ячейке появляется сообщение об ошибке, такое как «#ИМЯ?» или «#ДЕЛ/0!». Для поиска и устранения ошибок смотрите Сообщения об ошибках.

Ввод и исправление данных и формул

Ячейки листа невозможно изменить.

Не удается исправить формулу с помощью панели свойств листа.

Не удается установить перенос текста внутри ячейки.

Отсутствует строка формул.

Не удается использовать имя ячейки или диапазона ячеек.

В некоторых ячейках с функциями вместо значения отображается ошибка #ИМЯ?

Невозможно добавить пустую строку или пустой столбец на краю листа.

Не удается установить пароль для листа.

Не удается изменить гиперссылку, опубликованную из Microsoft Excel.

Размеры листа невозможно изменить.

Невозможно скрыть или отобразить полосы прокрутки листа.

Фильтрация, сортировка и поиск данных

Сортировка данных на листе выполняется неверно.

На листе отображаются не все данные.

На листе есть объединенные ячейки, из-за чего не работает фильтр.

Команда Найти далее не находит данные на листе.

После опубликования листа из Excel, раскрывающийся список автофильтра оказался неверным.

Импорт и экспорт

Фильтр листа неверно экспортирует данные в Excel.

При попытке импорта данных в лист появляется сообщение «Невозможен импорт данных с адреса URL...».

При попытке экспорта листа в Excel появилось сообщение о том, что лист содержит слишком много строк или столбцов.

Работа с листом в обозревателе

Когда обозреватель открывает Web-страницу, содержащую Web-лист, появляется сообщение «Не удается открыть адрес URL».

Не удается опубликовать из Microsoft Excel лист, защищенный паролем.

При нажатии на кнопку Правка Web-обозревателя Web-страница открывается не тем приложением.


Сообщения об ошибках на листе

Если формула содержит ошибку, не позволяющую выполнить вычисления или отобразить результат, то вместо результата в ячейке отображается сообщение об ошибке. Примеры таких ошибок: вместо числа в формулу подставлен текст; удалена ячейка, на которую в формуле содержится ссылка; ширина ячейки недостаточна для отображения значения.

Сообщение об ошибке в ячейке не всегда означает, что ошибка содержится именно в этой ячейке. Например, сообщения #Н/Д и #ЗНАЧ! могут означать, что ошибка содержится в ячейке, на которую ссылается формула.

Список сообщений об ошибках

#####

#ЦИКЛ!

#ДЕЛ/0!

#Н/Д

#ИМЯ?

#ПУСТО!

#ЧИСЛО!

#ССЫЛКА!

#ЗНАЧ!


Ячейки листа невозможно изменить

Вероятно, эти ячейки заблокированы или защищены. Снять блокировку и защиту можно только в программе-конструкторе.

Дополнительные сведения

Защита листа.

Выбор ячеек, изменение которых разрешено после защиты листа.

Снятие защиты листа.


Не удается исправить формулу с помощью панели свойств листа

Панель свойств листа не предназначена для изменения формул. Формулу следует изменять в ячейке, содержащей эту формулу.


Не удается установить перенос текста внутри ячейки

Web-компонент для электронных таблиц (листов) не поддерживает перенос текста внутри ячеек. Если лист Microsoft Excel 2000 содержит в ячейках текст с переносом, то после опубликования этого листа из Excel, текст в каждой ячейке будет выстроен в одну строку. Чтобы отобразить в ячейке весь текст, необходимо либо укоротить текст, либо записать его по частям в несколько ячеек, либо увеличить ширину столбца.


Отсутствует строка формул

В отличие от Microsoft Excel, Web-компонент не предусматривает для листов строки формул для изменения содержимого ячейки. Изменение содержимого ячейки возможно либо после двойного щелчка ячейки, либо после выделения ячейки и нажатия клавиши F2. Просмотр формулы возможен также с помощью панели свойств листа.


Не удается использовать имя ячейки или диапазона ячеек

Web-листы не поддерживают имена ячеек и диапазонов. Если опубликовать из Microsoft Excel 2000 данные, содержащие имена ячеек или именованные диапазоны, то имена преобразуются в значения или диапазоны.


В некоторых ячейках с функциями вместо значения отображается ошибка #ИМЯ?

Некоторые функции Web-компонента для электронных Web-таблиц (листов) выполняют вычисления с использованием файла Msowcf.dll — библиотеки динамической компоновки. Если этот файл отсутствуют, то при открытии листа в программе-конструкторе или обозревателе в соответствующих ячейках появляется ошибка «#ИМЯ?». Выполните поиск файла Msowcf.dll на своем компьютере. Если этот файл отсутствует, переустановите Microsoft Office 2000, либо обратитесь к системному администратору.


Невозможно добавить пустую строку или пустой столбец на краю листа

Лист не может содержать более 65536 строк. Максимально допустимое количество столбцов также ограничено — последним является столбец ZZ. Если на листе содержится меньше строк и столбцов (например, 10 строк), то в программе-конструкторе следует изменить отображаемый диапазон листа.


Не удается установить пароль для листа

Для листа, опубликованного на Web-странице, нельзя установить пароль. В некоторых случаях возможна установка пароля, используемого для открытия Web-страницы. При этом вместе со страницей открывается и находящийся на ней лист. Например, можно установить пароль для доступа к Web-серверу. За дополнительными сведениями обратитесь к администратору Web-узла.


Не удается изменить гиперссылку, опубликованную из Microsoft Excel

Введите гиперссылку заново. Если опубликованная из листа Microsoft Excel гиперссылка была создана с помощью диалогового окна Excel Добавить гиперссылку, то можно изменить только текст гиперссылки. Изменить адрес, на который она указывает, невозможно. Чтобы изменить адрес, удалите гиперссылку, затем вставьте новую гиперссылку.

Измените адрес в Excel и опубликуйте данные повторно. На исходном листе Excel можно изменить как текст гиперссылки, так и ее адрес. После этого данные публикуются на Web-странице повторно. Подробности содержатся в справке Excel.


Размеры листа невозможно изменить

Вероятно, для этого листа задан автоматический подбор размеров. Если команда Автоподбор на панели свойств листа включена, то размеры листа на Web-странице изменяются автоматически при вставке и удалении строк и столбцов, а также при изменении высоты строк и ширины столбцов. Листы, опубликованные из Microsoft Excel, по умолчанию снабжены автоподбором размеров листа (команда Автоподбор действует). Включать и отключать автоподбор размеров можно только в программе-конструкторе с помощью панели свойств листа.


Невозможно скрыть или отобразить полосы прокрутки листа

Если для листа установлено автоматическое изменение его размеров (команда Автоподбор на панели свойств листа), полосы прокрутки появляются всегда, как только размеры листа (ширина и высота) начинают превосходить максимально допустимые размеры, установленные на панели свойств листа, независимо от того, включено или отключено отображение полос прокрутки. Если необходимо иметь возможность включать и отключать отображение полос прокрутки в любом случае, следует отключить автоматический подбор размеров.


Сортировка данных на листе выполняется неверно

Если результаты сортировки кажутся неверными, то проверьте следующее:

Проверьте правильность выделения диапазона. Если перед сортировкой выделен диапазон ячеек, то сортировка выполняется только в этом диапазоне, причем сортируются все данные, находящиеся в этом диапазоне. Это означает, что если в выделенный диапазон включена строка названия, то она также будет отсортирована. Если выделен один столбец, то сортировка будет выполнена только в этом столбце, не затронув остальные столбцы. Попробуйте выделить только одну ячейку диапазона, в котором требуется выполнить сортировку, причем эта ячейка не должна быть строкой названия. Лист автоматически определит подлежащий сортировке диапазон, исключив из него строку названия. Если это не приведет к желаемому результату, выделите нужный диапазон, не включая в него строку названия, затем выполните сортировку.

Убедитесь, что для чисел установлен числовой, а не текстовый формат. Причиной неверной сортировки может оказаться текстовый формат ячейки, содержащей число. Например, при импорте данных в лист из некоторых систем учета отрицательные числа превращаются в текст. Для выбора верного формата ячейки щелкните ее, затем выберите нужный формат чисел.

Проверьте форматы ячеек, содержащих дату и время. Дата и время обрабатываются как числа. При вводе даты или времени в ячейку, имеющую основной формат чисел, она приобретает встроенный формат даты или времени соответственно. Сортировка дат и времени будет выполнятся верно, если все ячейки столбца имеют одинаковые форматы даты или времени. Чтобы установить верный формат ячейки, щелкните ее, затем выберите нужный формат.

Удалите начальные пробелы. Убедитесь, что перед данными в ячейке нет пробелов. Если пробелы есть, удалите их до сортировки данных.

Проверьте выбор языка. В некоторых случаях порядок сортировки зависит от языка, выбранного в диалоговом окне Язык и стандарты, которое вызывается из панели управления Windows. Сведения о том, как изменять параметры в этом окне, смотрите в справке операционной системы Windows.

Проверьте порядок сортировки столбцов. Если сортируется несколько столбцов, то порядок их сортировки определяется компоновкой данных. Смотрите сведения о сортировке по нескольким столбцам.


На листе отображаются не все данные

Включен автофильтр. Вероятно, часть данных скрыта фильтром. Если в правой части самой верхней ячейки столбца есть стрелка, сделайте следующее:

  • Щелкните стрелку, затем щелкните в списке пункт Показать все.

  • Убедитесь, что кнопка Автофильтр [image] на панели инструментов отжата.


На листе есть объединенные ячейки, из-за чего не работает фильтр

Для Web-листов не предусмотрена сортировка списков, содержащих объединенные ячейки. Если на листе содержатся объединенные ячейки, вначале разделите их, а затем повторите команду Автофильтр.


Команда «Найти далее» не находит данные на листе

Если выделен диапазон данных, то команда Найти далее выполняет поиск только в этом диапазоне. Если необходимо выполнить поиск по всему листу, выделите только одну ячейку, а затем нажмите кнопку Найти далее.

Дополнительные сведения

Поиск данных на листе


После опубликования листа из Excel, раскрывающийся список автофильтра оказался неверным

Microsoft Excel позволяет создавать условия автофильтра, которые невозможно отобразить в раскрывающемся списке Автофильтр. Например, для Web-листов нет эквивалента условиям «Первые 10...» и «начинается с».

Если из Excel опубликовать диапазон, отфильтрованный по условию, которое не может быть отображено в списке Автофильтр Web-листа, то отфильтрованные данные отобразятся на Web-странице верно, а условие фильтра в списке Автофильтр — неверно.

Для сброса раскрывающегося списка нужно отжать кнопку Автофильтр [image] на панели инструментов листа, что приведет к отключению фильтра. Повторное нажатие кнопки Автофильтр [image] включит фильтр. В этом случае раскрывающийся список также сбрасывается.


Фильтр листа неверно экспортирует данные в Excel

Для Web-листа можно создать такие условия автофильтра, которые невозможно отобразить в раскрывающемся списке Автофильтр и диалоговом окне Пользовательский автофильтр в Microsoft Excel. Например, в Microsoft Excel нет прямого эквивалента фильтру, содержащему три снятых флажка. При экспорте Web-листа в Excel такие условия фильтра не поддерживаются, поэтому в Excel отображается весть диапазон автофильтра.

Чтобы экспортированные данные отображались так же, как на Web-листе, рекомендуется установить для всех фильтров не менее чем по три набора условий, то есть по три флажка или более с параметрами (установленными или снятыми), отличными от параметров других флажков.


При попытке импорта данных в лист появляется сообщение «Невозможен импорт данных с адреса URL...»

Предназначенные для импорта данные должны находиться в таблице HTML. В противном случает откройте файл редактором HTML, таким как Microsoft FrontPage 2000, и скомпонуйте данные в виде таблицы. Сведения о компоновке данных в таблицах HTML содержатся в справке редактора HTML.


При попытке экспорта листа в Excel появилось сообщение о том, что лист содержит слишком много строк или столбцов

Web-лист может содержать данные в столбцах с A до ZZ включительно. Лист Microsoft Excel может содержать данные в меньшем количестве столбцов — с A по IV. Поэтому прежде чем экспортировать лист в Excel, следует удалить или переместить данные из столбцов, расположенных правее столбца IV.


Когда обозреватель открывает Web-страницу, содержащую Web-лист, появляется сообщение «Не удается открыть адрес URL»

Исходные данные Web-страницы неверны. Если Web-лист содержит данные, находящиеся на другой Web-странице, то она должна быть доступной пользователям. В противном случае появится сообщение об ошибке.

Web-страница расположена не в локальной сети. Если Web-лист содержит формулу со ссылкой на другую Web-страницу, то эта Web-страница должна находится на компьютере локальной сети или интрасети, и быть доступной пользователям.


Не удается опубликовать из Microsoft Excel лист, защищенный паролем

Из Microsoft Excel можно публиковать только незащищенные паролем листы, то есть с пустым паролем. Откройте исходную книгу в Microsoft Excel, удалите пароль, затем опубликуйте лист повторно.


При нажатии кнопки «Правка» в обозревателе Web-страница открывается не той программой

Вызов той или иной программы при нажатии кнопки Правка в Web-обозревателе зависит от того, как была опубликована открываемая Web-страница.

Если при нажатии кнопки Правка вызвается неверная программа, закройте ее, запустите нужную программу, затем откройте в ней Web-страницу.


Причины возникновения ошибки #####

Слишком мала ширина столбца. Сообщение об ошибке ##### означает, что содержащееся в ячейке значение (число, дата или время) шире ячейки. В этом случае следует увеличить ширину столбца, перетащив мышью границу между названиями столбцов.


Причины возникновения ошибки #ЦИКЛ!

Ошибка #ЦИКЛ! возникает в том случае, если формула прямо или косвенно ссылается на саму себя.

Возможная причина | Предлагаемые действия
Формула содержит прямую ссылку на ячейку, в которой сама находится. Пример такой ошибки: ячейка B10 содержит формулу =СУММ(B5:B10). | Проверьте в формуле все ссылки. Убедитесь, что среди них нет ссылок на ячейку, в которой содержится эта формула.
Формула содержит косвенную ссылку на ячейку, в которой сама находится. Пример такой ошибки: ячейка B10 содержит формулу =СУММ(B5:B9), а ячейка B5 содержит формулу =B10*0.5. | Проверьте ячейки, на которые ссылается формула. Ни одна из них не должна содержать ссылки на ячейку, в которой появилось сообщение об ошибке #ЦИКЛ! Если хотя бы одна из ячеек, на которые ссылается формула, тоже содержит формулу, проверьте ссылки и в этой формуле. Среди них не должно быть ни одной ссылки на ячейку, содержащую ошибку #ЦИКЛ!


Причины возникновения ошибки #ДЕЛ/0!

Ошибка #ДЕЛ/0! при попытке деления на 0 (ноль).

Возможная причина | Предлагаемые действия
Делитель является ссылкой на пустую ячейку, либо на ячейку, содержащую 0. (Если вместо операнда подставляется пустая ячейка, то такой операнд считается равным нулю.) | Измените ссылку, либо введите ненулевое число в ячейку, используемую в качестве делителя. Можно также ввести в эту ячейку значение «#Н/Д», в результате чего в ячейке с формулой тоже появится сообщение «#Н/Д», означающее, что в формуле использовано неизвестное или неопределенное значение. Избежать сообщения об ошибке можно с помощью функции ЕСЛИ. Пример такой формулы: =IF(B5=0,"",A5/B5). Если в ячейке B5, являющейся делителем, появится ноль, то в ячейке с функцией не отобразится ничего, поскольку в кавычки заключена пустая текстовая строка.
Делитель равен 0. Пример: =5/0. | Измените делитель, чтобы он не был равным 0.
Выполняется макрос, использующий функцию или формулу, в которой содержится делитель, равный 0. | Исправьте функцию, формулу или делитель, чтобы он не был равным 0 или пустым.


Причины возникновения ошибки #Н/Д

Сообщение об ошибке #Н/Д появляется, когда какие-либо данные недоступны для вычислений.

Введите в ячейки электронной таблицы значение #Н/Д, если они должны содержать пока еще недоступные данные. Тогда формулы при ссылке на эти ячейки будут выдавать сообщение об ошибке #Н/Д, не производя вычислений.

Если же все необходимые данные доступны, но в ячейке с функцией или формулой появилось сообщение об ошибке #Н/Д, то либо требуются аргументы иного типа данных, либо ссылки на ячейки были сделана неверно.

Возможная причина | Предлагаемые действия
В функциях ГПР, ПРОСМОТР, ПОИСКПОЗ или ВПР указано неверное значение аргумента «искомое_значение». | Задайте верный аргумент «искомое_значение», который может быть значением или ссылкой на ячейку, но не ссылкой на диапазон.
В функции ПОИСКПОЗ неверно задан аргумент «тип_сопоставления». | Аргумент «тип_сопоставления» функции ПРОИСКПОЗ задает способ нахождения требуемого элемента, содержащегося в «просматриваемом_массиве», по аргументу функции «искомое_значение». Правильно заданный «тип_сопоставления» позволяет отыскать в «просматриваемом_массиве» тот элемент, значение которого или равно «искомому_значению», или же является ближайшим к нему. При этом «тип_сопоставления» упорядочивает «просматриваемый_массив», сортируя его элементы по возрастанию или убыванию значений, или же оставляет его неупорядоченным. Если функция ПОИСКПОЗ не находит решения и выдает сообщение об ошибке #Н/Д, проверьте, упорядочен ли «просматриваемый_массив» в соответствии с «типом_сопоставления», и, если нет, выберите другое значение этого аргумента.
Аргумент «диапазон_просмотра» функций ГПР и ВПР имеет значение ЛОЖЬ, когда в таблице нет искомого значения. | Аргумент «диапазон_просмотра» функций ВПР и ГПР определяет, какое значение в таблице будет искать функция. Если этот аргумент опущен или имеет значение ИСТИНА, функция будет искать в таблице значение, равное аргументу «искомое_значение» или наиболее близкое к нему. При его отсутствии в таблице функция выберет ближайшее меньшее значение. Если же аргумент «диапазон_просмотра» определен, как ЛОЖЬ, то функция ВПР будет искать в таблице только то значение, которое равно аргументу «искомое_значение», и при его отсутствии выдаст сообщение об ошибке #Н/Д. Поэтому, если «диапазон_просмотра» определен, как ЛОЖЬ, следует обязательно проверить, имеется ли искомое значение в таблице.
В функции электронной таблицы опущен один или несколько аргументов. | Задайте все необходимые аргументы.


Причины возникновения ошибки #ИМЯ?

Ошибка #ИМЯ? появляется, когда используемый в формуле текст невозможно распознать.

Возможная причина | Предлагаемые действия
Ошибка в написании имени функции. | Исправьте написание имени функции.
В формулу введен текст, не заключенный в двойные кавычки. Такая запись не распознается как текст. | Заключите в двойные кавычки содержащийся в формуле текст. Пример правильной записи формулы, объединяющей текстовый фрагмент «Всего: » со значением ячейки B50: ="Всего: "&B50
В ссылке на диапазон ячеек пропущено двоеточие (:). | Поставьте двоеточие (:) во всех ссылках на диапазоны ячеек. Пример правильной ссылки: СУММ(A1:C10).
Формула ссылается на другой лист или на данные этой же Web-страницы. | Во время конструирования Web-страницы вычисление по формуле не выполняется. Чтобы выполнить вычисление, загрузите в обозреватель Web-страницу с электронной таблицей и данными, на которые в формуле содержатся ссылки.
Отсутствует файл Msowcf.dll — библиотека динамической компоновки. | Попробуйте найти файл Msowcf.dll на жестком диске компьютера. Если он отсутствует, переустановите Microsoft Office 2000 или обратитесь к системному администратору.


Причины возникновения ошибки #ПУСТО!

Ошибка #ПУСТО! появляется, когда задано пересечение двух областей, которые в действительности не пересекаются.

Возможная причина | Предлагаемые действия
Использован ошибочный оператор диапазона. | Для создания ссылки на две непересекающиеся области используйте оператор объединения, обозначаемый запятой (,). Например, если формула суммирует два диапазона, то между диапазонами должна быть поставлена запятая: СУММ(A1:A10,C1:C10). Для создания ссылки на две пересекающиеся области используйте оператор пересечения, обозначаемый пробелом. Например, формула =СУММ(B5:С15 A10:D10) вычисляет сумму двух значений, содержащихся в ячейках B10 и C10, которые являются общими ячейками пересекающихся диапазонов B5:С15 и A10:D10.
Использована ошибочная ссылка. | Проверьте, нет ли ошибок в ссылках на диапазоны.


Причины возникновения ошибки #ЧИСЛО!

Ошибка #ЧИСЛО! появляется, когда возникают ошибки при использовании числа в формуле или функции.

Возможная причина | Предлагаемые действия
В функции с числовым аргументом используется аргумент другого типа. | Проверьте правильность аргументов функции.
При вычислении рекурсивной функции, такой как ВНДОХ или НОРМА, нельзя получить решение с заданной точностью за определенное число итераций. | Задайте другие значения для аргумента прогноза.
Результат вычислений слишком велик или слишком мал, поэтому его невозможно представить в электронной таблице. | Значения в электронной таблице должны быть в диапазоне от -(10 в степени 307) до 10 в степени 307 .


Причины возникновения ошибки #ССЫЛКА!

Ошибка #ССЫЛКА! появляется, когда используется недопустимая ссылка на ячейку.

Возможная причина | Предлагаемые действия
Ячейки, на которые ссылаются формулы, были удалены, либо в эти ячейки было помещено содержимое других ячеек. | Сразу после удаления ячеек или вставки скопированных ячеек, щелчком кнопки Отменить [image] восстановите ячейки электронной таблицы, либо исправьте формулы, содержащие ссылки на удаленные ячейки.


Причины возникновения ошибки #ЗНАЧ!

Ошибка #ЗНАЧ! появляется, когда используется недопустимый тип аргумента или операнда.

Возможная причина | Предлагаемые действия
В формулу вместо числа или логического значения (ИСТИНА или ЛОЖЬ) введен текст. Текст не может быть преобразован в нужный тип данных. | Проверьте правильность задания операнда или аргумента в функции или формуле, а также значений ячеек, на которые ссылается формула. Например, если в ячейке A5 содержится число, а в ячейке A6 содержится текстовое значение «Недоступно», формула =A5+A6 выдаст ошибку «#ЗНАЧ!». Чтобы сложить два значения, используйте в формуле функцию листа СУММ (функция СУММ игнорирует текстовые значения): =СУММ(A5:A6)
В оператор или функцию вместо одного значения аргумента введен диапазон. | Введите вместо диапазона одно значение.
В функцию не включен необходимый диапазон. | Существуют функции, например, СЧЕТЕСЛИ или СУММЕСЛИ, которые работают только с диапазонами. Проверьте, заданы ли в функции все необходимые диапазоны.
В функции листа АДРЕС аргументу А1 приписано значение, отличное от 1. | Функция АДРЕС задает ссылкам стиль A1. Измените аргумент А1 на 1.
В текстовый аргумент функции АДРЕС введено имя листа. | В Microsoft Excel текстовой аргумент функции АДРЕС задает имя листа для формирования адреса внешней ссылки. Элемент управления электронными таблицами работает только с одним листом. Удалите из функции текстовой аргумент.
Используется вычисляемый критерий — формула как условие — для функций баз данных (так называемые «БДфункции»). | В Web-листах функции баз данных не поддерживают вычисляемый критерий (например, «=Поле1<Поле2»). Измените критерий, чтобы упростить условия. В приведенном примере вычисляемый критерий можно заменить на «Поле1».
В функции ОБЛАСТИ введена ссылка на несколько диапазонов. | В функции Webлиста ОБЛАСТИ можно сослаться только на один диапазон. Введите ссылку на один диапазон ячеек.


Поиск данных на листе

В электронной таблице (для краткости называемой также листом) предусмотрены две возможности поиска данных: либо поиск конкретного значения, либо фильтрация данных для отображения на листе только строк, содержащих нужные значения.

Инструкции.

Поиск конкретного значения.

Отображение строк, содержащих нужные значения.


Сведения, относящиеся к конкретным языкам

Разделы справки, относящиеся к конкретным языкам, доступны только тогда, когда доступны возможности, относящиеся к конкретным языкам. Работа с другим языком, установка средств проверки правописания для другого языка.