Страницы доступа к данным: что это такое и как они работают

Страница доступа к данным - это Web-страница особого типа, позволяющая просматривать данные из базы данных и работать с ними. Также может включать данные из других источников, таких как Microsoft Excel. Возможности взаимодействия со страницей зависят от того, для чего она используется.

  • Составление отчетов в интерактивном режиме. Страницы доступа к данным этого типа часто используются для объединения и группировки сведений, хранящихся в базе данных, а также для публикации сводок данных. Например, страница может публиковать сводки по продажам для каждого региона, в котором проводятся операции. С помощью маркеров развертывания можно перейти от общей сводки данных, такой как список всех регионов и общий объем продаж по ним, к подробностям по продажам отдельных товаров в каждом регионе. Поскольку страница может также содержать кнопки панели инструментов, позволяющие сортировать и фильтровать данные, редактировать данные на страницах этого типа невозможно. См. пример страницы для составления отчетов в интерактивном режиме.

  • Ввод данных. Этот тип страниц доступа к данным используется для просмотра, добавления и редактирования записей или только для добавления записей. См. пример страницы для ввода данных.

  • Анализ данных Страницы доступа к данным этого типа могут включать сводные списки - аналог форм Microsoft Access или отчетов Microsoft Excel - которые позволяют реорганизовывать данные для их анализа различными способами. Страница может содержать диаграммы для анализа тенденций, закономерностей и выполнения сравнений между данными в базе данных или электронные таблицы, в которые можно вводить и редактировать данные, а также использовать формулы для выполнения некоторых вычислений, выполняемых в Microsoft Excel. См. пример страницы для анализа данных.

Страница доступа к данным непосредственно связана с базой данных. При просмотре в Microsoft Internet Explorer отображается копия страницы. Поэтому любой отбор данных, сортировка и другие изменения способа отображения данных - включая изменения в сводном списке или электронной таблице - влияют только на копию страницы. Однако, изменения в самих данных - изменение значений, добавление или удаление данных - сохраняются в исходной базе данных и впоследствии доступны всем, кто просматривает страницу.

Примечание. Страницы доступа к данным поддерживаются в Microsoft Internet Explorer версии 5 или более поздней.

Дополнительные сведения

Составные части страницы доступа к данным


Составные части страницы доступа к данным

Страница доступа к данным может состоять из большого числа различных компонентов; однако набор компонентов варьируется в зависимости от цели создания страницы. Некоторые из наиболее часто используемых компонентов перечислены ниже. (Поля и записи всегда входят в состав страницы доступа к данным; однако представлены они могут быть по-разному.)

Составные части страницы доступа к данным

Данный раздел содержит справочные сведения по следующим вопросам.

Текстовые поля или поля ввода

Записи

Группы

Панель перехода по записям

Сводные списки

Электронные таблицы.

Диаграммы

Текстовые поля или поля ввода. Отображают существующие данные из базы данных или, если разрешено, принимают вводимые пользователем новые данные для хранения в базе данных.

Возврат в начало

Записи. Наборы связанных фактов об одном хранящемся в базе данных элементе, таком как клиент, заказ от клиента или сотрудник. Например, клиентский заказ 15900, сделанный компанией Ernst Handel 11 января 98 года, представляет собой одну запись.

Возврат в начало

Группы. Объединяют данные в наборы. Например, записи клиентских заказов на странице доступа к данным могут быть сгруппированы по странам. Название каждой страны - заголовок группы. В зависимости от того, как разработана страница, на ней либо отображаются все группы (обычно со скрытием входящих в них записей), либо ни одна конкретная группа не отображается до тех пор, пока не будет выбрана в списке доступных групп. Если на странице отображаются все группы, то можно отобразить все записи конкретной группы, щелкнув маркер ее развертывания. В нижней части каждой развернутой группы может находиться собственная панель перехода по записям. Редактировать данные на странице с группами невозможно.

Возврат в начало

Панель перехода по записям. Позволяет быстро выполнять переходы между записями либо добавлять, удалять, сохранять, отменять изменения, сортировать или фильтровать записи. На странице доступа с группами каждая группа может иметь собственную панель перехода по записям, расположенную в нижней части развернутой группы. Если панель на странице не включает в себя некоторые из кнопок, показанных на следующем рисунке, или включает кнопки, не перечисленные здесь, значит, она была специально настроена разработчиком страницы.

Панель перехода по записям и кнопки

Возврат в начало

Сводные списки. Аналог сводных таблиц Microsoft Excel; отображают данные в виде строк и столбцов, которые можно реорганизовывать для анализа данных различными способами. Это делается путем перемещения строк в столбцы и столбцов в строки, отображения итоговых сумм на пересечении строки столбцов, а также с использованием других способов упорядочения и суммирования данных. Сводный список содержит собственную панель инструментов и встроенную справку.

Возврат в начало

Электронные таблицы Аналог листа Microsoft Excel; позволяют вводить и редактировать данные или выполнять вычисления с данными. Электронная таблица содержит собственную панель инструментов и встроенную справку.

Возврат в начало

Диаграммы. Используют базу данных для визуального отображения тенденций, закономерностей и сравнений. При изменении базы данных происходит соответствующее изменение диаграммы. Если диаграмма связана со сводным списком или электронной таблицей на странице доступа к данным, то диаграмма изменяется при изменении связанного сводного списка или электронной таблицы.


Справка по конкретным областям страницы доступа к данным

Разделы справки по странице доступа к данным описывают общие способы просмотра страницы и работы с ней; однако авторы страниц могут предоставлять справочные сведения, относящиеся к конкретной просматриваемой странице. Например, на страницу могут быть добавлены собственно инструкции, либо специальная кнопка «Справка» или гиперссылка на справочные сведения о странице.

Страница доступа к данным также может включать компоненты с собственной встроенной справкой. Например, сводный список или электронная таблица имеют собственную справку, описывающую приемы работы с соответствующим компонентом страницы.

  • Для получения справки по использованию сводного списка или электронной таблицы нажмите кнопку Справка [image] на панели инструментов сводного списка или электронной таблицы.

  • Для получения справки по использованию Microsoft Internet Explorer выберите пункт Содержание и указатель в меню Справка Internet Explorer.

  • Чтобы вывести справку по главному окну доступа к данным, закройте окно справки по электронной таблице или сводному списку, а затем нажмите кнопку Справка [image] на панели перехода по записям страницы доступа к данным.

Примечание. Другие компоненты, такие как Универсальный проигрыватель Microsoft Windows, также имеют собственную справочную систему, которая доступна, если щелкнуть соответствующий компонент правой кнопкой мыши.


Устранение неполадок при работе со страницами доступа к данным

Возникающие вопросы

Отсутствуют кнопки на панели перехода по записям

Поля на странице доступа к данным пусты

Возникли трудности при редактировании данных в поле страницы доступа к данным

Страница доступа к данным была отправлена в виде сообщения электронной почты, но получатель не смог ее прочесть

Получено сообщение об ошибке при попытке ввода данных на странице доступа к данным

Примечание. Страница доступа к данным может содержать сводный список или электронную таблицу, разрешение вопросов по которым описано отдельно. Для получения дополнительных сведений нажмите кнопку Справка [image] на панели инструментов сводного списка или электронной таблицы и выполните поиск по ключевым словам «разрешение вопросов».


Термины

Microsoft Office Web Components

Компоненты, которые можно использовать для помещения на страницу доступа к данным интерактивных электронных таблиц, сводных списков и диаграмм. Для просмотра и работы с объектами, созданными с использованием этих компонентов необходимо иметь лицензию на узел Microsoft Office 2000.

адрес URL (Uniform Resource Locator)

Адрес объекта, документа, страницы или другого элемента (например, группы новостей или Web-страницы) в Интернете или интрасети. Адрес URL указывает используемый протокол (например, FTP или HTTP) и местоположение конечного объекта. Адрес URL также может указывать адрес электронной почты Интернета. Ниже приведено несколько примеров адресов URL.

http://www.someones.homepage/default.html

ftp://ftp.server.somewhere/ftp.file

news:alt.hypertext

база данных

Набор данных, относящихся к конкретной теме или служащий для определенной цели. Страница доступа к данным может быть связана с базой данных Microsoft Access или Microsoft SQL Server.

диаграмма

Графическое представление базы данных, используемое для визуального отображения тенденций, закономерностей и сравнений. При изменении базы данных происходит соответствующее изменение диаграммы. Если диаграмма связана со сводным списком или электронной таблицей на странице доступа к данным, то диаграмма изменяется при изменении связанного сводного списка или электронной таблицы.

маркер развертывания

Кнопка, используемая для развертывания или свертывания записей на странице доступа к данным; отображается в виде символа плюс (+) или минус (-).

панель перехода по записям

Панель инструментов, содержащая кнопки для добавления, удаления, сохранения, отмены изменений, сортировки, фильтрации записей, а также для перехода между ними. На странице доступа к данным с группами каждая группа может иметь собственную панель перехода по записям, расположенную в нижней части развернутой группы. Если панель на странице не включает в себя некоторые из кнопок, показанных на следующем рисунке, или включает кнопки, не перечисленные здесь, значит, она была специально настроена разработчиком страницы.

сводный список

Аналогично сводной таблице Microsoft Excel, сводный список отображает данные в виде строк и столбцов. Сводный список предоставляет возможности интерактивной работы в Microsoft Internet Explorer, позволяя реорганизовывать данные путем перемещения строк в столбцы и столбцов в строки, отображения итоговых сумм на пересечении строки столбцов, а также с использованием других приемов упорядочения и суммирования данных для их анализа различными способами. Сводный список содержит собственную панель инструментов и встроенную справку.

стандартный формат записи пути (UNC — Universal Naming Convention)

Соглашение об именах файлов, обеспечивающее аппаратно-независимые средства обнаружения файла. Адрес UNC обычно включает ссылку на общую папку и файл, доступный через сеть, а не имя папки и файла, заданное буквой диска и путем. Например, база данных с именем Northwind.mdb в общем каталоге Samples на компьютере MyWorkstation будет иметь следующий адрес UNC: \\MyWorkstation\Samples\Northwind.mdb.

Формат записи пути UNC особенно полезен в приложениях для Web, поскольку позволяет ссылаться на данные, которые не обязательно хранятся на определенном Web-сервере.

страница доступа к данным с группами

Страница доступа к данным, группирующая данные от общих категорий к конкретным деталям с использованием двух или более уровней иерархии. На страницах со сгруппированными записями данные можно просматривать, но нельзя добавлять, редактировать или удалять.

страница доступа к данным

Web-страница, имеющая связь с базой данных; с помощью страницы доступа к данным можно просматривать, добавлять, редактировать, управлять данными, хранящимися в базе данных. Страница доступа к данным также может включать данные из других источников, таких как Microsoft Excel.

фильтр

Набор условий, применяемых к данным для отображения подмножества данных. На странице доступа к данным можно фильтровать записи с помощью фильтра по выделенному. Фильтр по выделенному использует значение, выбранное в поле, в качестве условия для ограничения записей, отображаемых на странице доступа к данным. До удаления фильтра на странице доступа к данным будут доступны только записи, содержащие выбранное значение.

Примечание. Страница доступа к данным также может иметь встроенный фильтр. На страницах такого типа записи не отображаются до тех пор, пока не будет выбрано значение в раскрывающемся списке на странице. До выбора другого значения для фильтрации будут отображаться только записи, содержащие выбранное значение.

электронная таблица

Компонент страницы доступа к данным, аналогичный листу Microsoft Excel. С помощью электронной таблицы можно вводить исходные данные, добавлять формулы, применять фильтры и выполнять дополнительные операции электронных таблиц. Электронная таблица содержит собственную панель инструментов и встроенную справку.


Адреса гиперссылок на страницах доступа к данным

Адрес гиперссылки может содержать до четырех компонентов, разделенных знаком #:

отображаемый_текст#адрес#дополнительный_адрес#подсказка

Каждый компонент описан в приведенной ниже таблице.

Компонент | Описание | Обязательный?
отображаемый_текст | Текст, отображаемый в поле гиперссылки на странице. Например, описательное имя узла Web или адрес и дополнительный_адрес, определяющие объект. | Нет
адрес | Абсолютный или относительный путь к документу. Абсолютным является полностью определенный путь URL или UNC к документу. Относительным является путь, связанный с сохраненным расположением документа. | Да
дополнительный_адрес | Положение в файле или документе. Например, определенная закладка в документе Word. Прочтите также о правильном синтаксисе для каждого типа документа. | Нет
подсказка | Текст, появляющийся при удержании указателя мыши на гиперссылке. | Нет

На странице доступа к данным поле, в которое вводится адрес гиперссылки, не форматирует адрес как гиперссылку. Адрес, отформатированный как гиперссылка, следует искать в других частях страницы.

Примечание. Когда адрес отформатирован как гиперссылка, на странице доступа к данным не отображаются все четыре компонента.

  • Если введен отображаемый_текст, следующая за ним часть адреса не отображается.

  • Если отображаемый_текст не вводится, то отображается только адрес.

  • 67Дополнительный_адрес отображается только если отсутствует отображаемый_текст или адрес.

См. список примеров адресов гиперссылок.


Ввод адреса гиперссылки на страницу доступа к данным

Существует несколько способов ввода адреса гиперссылки для записей, каждая из которых имеет гиперссылку, отличную от других.

Предполагаемые действия

Вставка гиперссылки или адреса гиперссылки

Перетаскивание ярлыка Интернета

Ввод адреса гиперссылки


Примеры адресов гиперссылок на страницах доступа к данным

В следующей таблице приведены примеры адресов гиперссылок. Обратите внимание, что в адресах URL используется обычная косая черта, а в адресах UNC обратная.

Адрес гиперссылки | Описание
Корпорация Майкрософт#http://www.microsoft.com# | Основная Web-страница корпорации Майкрософт. Отображается как «Корпорация Майкрософт».
#http://www.microsoft.com# | Основная Web-страница корпорации Майкрософт.
#http://www.microsoft.com#образец# | Именованная ссылка «образец» в документе HTML для основной страницы корпорации Майкрософт.
#\\northwind\public\товары.doc##Список товаров со скидкой | Файл Word с именем Товары.doc в общем каталоге public на сервере Northwind. Всплывающая подсказка «Список товаров со скидкой».
Записка#c:\windows\Избранное \Записка.doc# | Файл Word с названием Записка.doc, расположенный в папке \Windows\Избранное. Отображается строка «Записка».
#c:\windows\личные\резюме.doc# | Файл Резюме.doc, расположенный в папке \Windows\Личные. Поскольку отображаемый текст отсутствует, будет отображаться путь.

  • При вводе http://www.microsoft.com распознается протокол «http:» и адрес преобразуется в форму #http://www.microsoft.com# (пользователю не придется самому вводить знак #).

  • Если введенный текст не содержит знак #, протокол (например «http:») и ссылку на объект текущей базы данных, то введенный текст воспринимается как отображаемый текст и в качестве адреса к «http://» добавляется тот же текст. Например, при вводе example.microsoft.com адрес воспринимается как example.microsoft.com#http://example.microsoft.com#.


Синтаксис дополнительных адресов гиперссылок на страницах доступа к данным

Для перехода по месту в файлах данного типа | Введите
Microsoft Word | Имя закладки
Microsoft Excel | Определенное имя или лист!диапазон. Например, введите sheet1!A2 для перемещения в ячейку A2 на листе 1.
Microsoft PowerPoint | Номер слайда
Документ HTML | Имя закладки (определяется с помощью атрибута NAME тега A)


Переход по гиперссылке на странице доступа к данным

  • Поместите указатель на объект, содержащий гиперссылку. Когда указатель примет форму руки, щелкните гиперссылку.

    По умолчанию не просмотренная гиперссылка выделена синим цветом и подчеркнута. Просмотренная гиперссылка по умолчанию выделена красным цветом и подчеркнута. Дополнительные сведения об изменении установленного по умолчанию режима форматирования см. в справочной системе Web-обозревателя.


Переход между записями на странице доступа к данным с помощью кнопок перехода

  • Пользуйтесь кнопками перехода, расположенными на панели перехода по записям, для быстрого перехода между записями или группами записей на странице доступа к данным с группами.

    Кнопки перехода по записям


Отображение или скрытие записей группы данных на странице доступа к данным

  • Щелкните маркер развертывания рядом с заголовком группы.


Сортировка данных на странице доступа к данным

Существует возможность сортировки данных на странице доступа к данным, включая сгруппированные данные. На страницах с группами можно сортировать список групп или записи в группе.

  1. На странице доступа к данным щелкните поле, которое будет использоваться для сортировки записей. Для страниц с группами отобразите записи конкретной группы, которые требуется отсортировать, а затем выберите значение, по которому будет выполняться сортировка.

  2. Выполните одно из следующий действий.
    • Для сортировки по возрастанию нажмите кнопку Сортировка по возрастанию [image].

    • Для сортировки по убыванию нажмите кнопку Сортировка по убыванию [image].

Примечания

  • При сортировке записей группы порядок сортировки применяется только к данной группе. Он не влияет на порядок записей в других группах. Например, пусть страница доступа к данным сгруппирована по регионам, названия регионов перечислены в порядке возрастания, а сотрудники по каждому региону перечислены в порядке возрастания по фамилии. Если вывести записи о сотрудниках в Мексике, а затем отсортировать их по фамилии в порядке убывания, то записи о сотрудниках в других регионах останутся отсортированными по возрастанию, как и сам список регионов.

  • Чтобы изменить порядок сортировки, щелкните поле, которое требуется отсортировать, а затем нажмите нужную кнопку сортировки.

  • При переходе к другой странице доступа к данным и возвращении на исходную страницу порядок сортировки утрачивается.

  • Порядок сортировки чисел, текста и специальных символов в базе данных зависит от настроек языка и стандартов на панели управления Windows.

  • Данная процедура не применима к сводному списку или электронной таблице. Эти компоненты могут быть отсортированы независимо от остальных данных на странице доступа к данным и, кроме того, могут поддерживать дополнительные возможности сортировки. Для получения дополнительных сведений нажмите кнопку Справка [image] на панели инструментов сводного списка или электронной таблицы, а затем выполните поиск по ключевому слову «сортировка».


Поиск конкретных данных на странице доступа к данным с помощью фильтра

С помощью фильтра можно находить записи по определенному значению, которое они содержат в конкретном поле. Например, можно найти все записи, содержащие в поле «Страна» значение «Германия». При применении фильтра на странице доступа к данным отображаются только записи, содержащие выбранное значение. После удаления фильтра вновь выводятся все записи. На страницах с группами можно проводить отбор в списке групп (в заголовках групп) или отбирать записи в группах.

  1. Выберите в поле на странице доступа к данным значение, которое будет использоваться для отбора записей, а затем нажмите кнопку Фильтр по выделенному [image] на панели перехода по записям.

    Для страниц доступа к данным с группами отбразите записи группы, которые требуется отфильтровать, выберите значение, по которому будет выполняться отбор записей, а затем нажмите кнопку Фильтр по выделенному [image] на панели перехода по записям для этой группы. Фильтр применяется только к текущей группе. Другими словами, если на странице сгруппированы заказы клиентов по странам и выполняется отбор записей для Бразилии по конечной дате 6 февраля 98 года, то фильтр будет применен только к записям для Бразилии, не затрагивая записи по другим странам.

  2. Можно еще более сузить подмножество записей, продолжая выбирать значения и нажимать кнопку Фильтр по выделенному [image] до тех пор, пока не останутся только нужные записи. Например, если требуется просмотреть только записи по клиентам в Германии с конечной датой 5 декабря 98 года, то нужно выбрать «Германия» в поле «Страна», нажать кнопку Фильтр по выделенному [image], выбрать «05.12.98» в поле «Конечная дата» и еще раз нажать кнопку Фильтр по выделенному [image].

Примечания

  • Если выбрана только часть значения поля, страница доступа к данным все равно использует для отбора записей полное значение поля.

  • Фильтр можно удалять и повторно применять в течение одного и того же сеанса работы.

  • В случае перехода к другой странице доступа к данным фильтр будет утерян.

  • Данная процедура не применима к сводному списку или электронной таблице. Эти компоненты могут быть отфильтрованы независимо от остальных данных на странице доступа к данным и, кроме того, могут поддерживать дополнительные возможности отбора данных. Для получения дополнительных сведений нажмите кнопку Справка [image] на панели инструментов сводного списка или электронной таблицы, а затем выполните поиск по ключевому слову «фильтры».


Применение существующего фильтра к странице доступа к данным

Существует возможность применения фильтра, созданного ранее во время текущего сеанса работы. Однако, если после создания фильтра выполнялся переход к другой странице доступа к данным, то по возвращении на исходную страницу фильтр будет недоступен. Придется создать его заново.

  • Нажмите кнопку Применить фильтр [image] на панели перехода по записям. Для страниц доступа к данным с группами: отобразите записи группы, которую требуется отфильтровать, а затем нажмите кнопку Применить фильтр [image] на панели перехода по записям для этой группы.

Примечание. Данная процедура не применима к сводному списку или электронной таблице. Эти компоненты могут быть отфильтрованы независимо от остальных данных на странице доступа к данным и, кроме того, могут поддерживать дополнительные возможности фильтрации. Для получения дополнительных сведений нажмите кнопку Справка [image] на панели инструментов для сводного списка или электронной таблицы, а затем выполните поиск по ключевому слову «фильтры».


Удаление фильтра для вывода всех записей на странице доступа к данным

  • Нажмите кнопку Удалить фильтр [image] на панели перехода по записям.

Примечания

  • Удаление фильтра не приводит к его уничтожению. Фильтр можно применить повторно, нажав кнопку Применить фильтр [image] на панели перехода по записям. Однако, при переходе к другой странице доступа к данным фильтр будет утерян.

  • Данная процедура не применима к сводному списку или электронной таблице. Эти компоненты могут быть отфильтрованы независимо от остальных данных на странице доступа к данным и, кроме того, могут поддерживать дополнительные возможности фильтрации. Для получения дополнительных сведений нажмите кнопку Справка [image] на панели инструментов для сводного списка или электронной таблицы, а затем выполните поиск по ключевому слову «фильтры».


Добавление новой записи на страницу доступа к данным

  1. Нажмите на панели перехода по записям кнопку Новая запись [image].

  2. Введите данные в первое поле и нажмите клавишу TAB для перехода к следующему полю.

  3. Добавив данные во все поля нажмите кнопку Сохранить запись [image], чтобы сохранить запись.

Примечание. Запись автоматически сохраняется при начале изменений следующей записи, применении или удалении фильтра или переходе к другой странице доступа к данным.


Добавление, изменение или удаление пути к рисунку на странице доступа к данным

Примечание Рисунок не хранится в базе данных. Вместо этого в базе данных хранится путь расположения рисунка, а сам рисунок хранится в файловой системе компьютера.

  1. Перейдите к записи или используйте фильтр для поиска записи, содержащей путь к рисунку, который требуется добавить, изменить или удалить.

  2. Щелкните поле, содержащее путь к рисунку.

  3. Выполните одно из следующий действий.

    Чтобы добавить путь к рисунку, введите с клавиатуры путь расположения рисунка.

    Чтобы изменить путь к рисунку, отредактируйте путь. Прочтите о редактировании поля.

    Чтобы удалить путь к рисунку, выделите все содержимое поля и нажмите клавишу DEL.

Примечания

  • Чтобы просмотреть результаты на странице доступа к данным, сохраните запись явным образом, а затем обновите страницу доступа к данным.

  • Путь может быть относительным, путем на локальном компьютере, путем в стандартном формате записи (UNC) или путем URL. Тип пути зависит от требований базы данных.

  • Для физического удаления рисунка необходимо удалить его из файловой системы. Со страницы эта возможность может быть недоступна, в зависимости от структуры страницы. Дополнительные сведения по удалению файлов см. в справочной системе Microsoft Windows.


Вывод самых свежих данных на странице доступа к данным

Если ввод данных выполняется несколькими пользователями одновременно, то на странице доступа к данным могут не отображаться самые последние изменения в базе данных. Самые последние данные можно загрузить из базы данных.

  • Нажмите кнопку Обновить [image] на панели инструментов Microsoft Internet Explorer или клавишу F5.

Внимание! Если кнопка Обновить нажата до сохранения изменений, Microsoft Internet Explorer выводит предупреждение о возможности утери внесенных изменений. В этом случае во избежание утери изменений текущей записи следует нажать кнопку Отмена.

Примечания

  • Если загрузка данных занимает много времени и операцию требуется отменить, нажмите кнопку Остановить [image] на панели инструментов Microsoft Internet Explorer или клавишу ESC.

  • Страница доступа к данным может содержать сводный список, для которого существует собственный способ обновления. Для вывода справки по сводному списку нажмите кнопку Справка [image] на панели инструментов сводного списка.


Удаление записи на странице доступа к данным

Важно! После удаления записи отменить удаление из базы данных невозможно.

  1. Перейдите к записи или используйте фильтр для поиска записи, которую требуется удалить.

  2. Нажмите кнопку Удалить запись [image] на панели перехода по записям.


Выбор полей и записей на странице доступа к данным

Следующая таблица содержит описание действий с мышью, обеспечивающих выделение данных или записей на странице доступа к данным.

Выделение | Щелкнуть
Данные в поле | В месте начала выделения. Для расширения области выделения перемещайте указатель при нажатой кнопке мыши.
Целое поле | Три раза
Запись | Любое поле на странице доступа к данным с группами.

Следующая таблица содержит описание действий с клавиатурой, обеспечивающих выделение данных или записей на странице доступа к данным.

Выделение | Действие
Данные в поле | Поместите курсор в начало выделяемого текста и, удерживая клавишу SHIFT, нажимайте клавиши со стрелками для перехода в конец выделяемого текста.
Целое поле | Поместите курсор в поле и нажмите клавиши HOME, SHIFT+END.
Запись | На странице доступа к данным с группами нажмите клавишу TAB.

Примечание. Страница доступа к данным может содержать сводный список или электронную таблицу, для которых имеются собственные способы выделения. Для вывода справки по сводному списку или электронной таблице нажмите кнопку Справка [image] на панели управления соответствующего компонента.


Редактирование данных в поле страницы доступа к данным

  1. Перейдите к записи или используйте фильтр для поиска записи, которую требуется отредактировать.

  2. Выберите поле, содержимое которого требуется изменить.

  3. Введите текст с клавиатуры.

Примечания

  • Если при вводе текста допущена ошибка, нажмите клавишу BACKSPACE. Для отмены изменений, внесенных в текущее поле, нажмите клавишу ESC. Для того чтобы отменить изменения, внесенные во всю запись, нажмите кнопку Восстановить запись [image] на панели перехода по записям.

  • Изменения автоматически сохраняются при переходе к следующей записи, применении или удалении фильтра или переходе к другой странице доступа к данным.


Сохранение записи на странице доступа к данным

  • Для сохранения данных в записи во время ее изменения нажмите кнопку Сохранить запись [image] на панели перехода по записям.

Примечание. Запись автоматически сохраняется при переходе к следующей записи, применении или удалении фильтра или переходе к другой странице доступа к данным.


Отмена изменений при добавлении или редактировании записей на странице доступа к данным

  • Для отказа от последних несохраненных изменений нажмите на панели перехода по записям кнопку Восстановить запись [image].

Отмена изменений становится невозможной при начале изменений следующей записи, применении или удалении фильтра или переходе к другой странице доступа к данным.


Использование сочетаний клавиш на странице доступа к данным

Примечание. Для использования следующих клавиш несколько раз нажмите клавишу TAB для перевода фокуса на маркер развертывания или панель перехода по записям. Если фокус в данный момент находится на сводном списке или электронной таблице, нажмите клавиши CTRL+TAB.

Сочетание клавиш | Действие
ПРОБЕЛ или ENTER | Развертывание или свертывание группы записей, в соответствии с видом маркера развертывания на странице доступа к данным с группами
СТРЕЛКА ВПРАВО или ВЛЕВО | Выбор кнопки на панели перехода по записям
ПРОБЕЛ или ENTER | Активизация выбранной кнопки на панели перехода по записям


Печать страницы доступа к данным

При печати страницы доступа к данным распечатка содержит только сведения, отображаемые в данный момент на экране, включая маркеры развертывания и панели перехода по записям.

  1. Прокрутите страницу доступа к данным до той части, которую требуется распечатать.

  2. Если нужно, разверните или сверните любые группы, которые не требуется печатать.

  3. Выберите в меню Файл Internet Explorer команду Печать.

Примечание. Страница доступа к данным может содержать сводный список или электронную таблицу, печать которых требует дополнительного рассмотрения. Для получения дополнительных сведений нажмите кнопку Справка [image] на панели инструментов сводного списка или электронной таблицы и выполните поиск по ключевому слову «печать».


Пример страницы доступа к данным для анализа данных

Страница доступа к данным для анализа


Пример страницы доступа к данным для ввода данных

Страница доступа к данным для ввода данных


Пример страницы доступа к данным для составления отчетов в интерактивном режиме

Страница доступа к данным для составления отчетов в интерактивном режиме


Работа с данными на странице доступа к данным

Предполагаемые действия

Добавление, редактирование и удаление данных

Переход между записями на странице доступа к данным с помощью кнопок перехода

Добавление новой записи на страницу доступа к данным

Выбор полей и записей на странице доступа к данным

Редактирование данных в поле страницы доступа к данным

Отмена изменений при добавлении или редактировании записей на странице доступа к данным

Вывод самых свежих данных на странице доступа к данным

Ввод адреса гиперссылки на страницу доступа к данным

Добавление, изменение или удаление пути к рисунку на странице доступа к данным

Сохранение и удаление записей

Сохранение записи на странице доступа к данным

Удаление записи на странице доступа к данным

Сортировка и фильтрация данных

Сортировка данных на странице доступа к данным

Поиск конкретных данных на странице доступа к данным с помощью фильтра

Применение существующего фильтра к странице доступа к данным

Удаление фильтра для вывода всех записей на странице доступа к данным

Использование сочетаний клавиш

Использование сочетаний клавиш на странице доступа к данным


Ввод гиперссылки путем перетаскивания ярлыка Интернета

  1. Перейдите на ярлык Интернета (значок на рабочем столе или элемент в папке «History», вложенной в папку Windows).

  2. Выделите ярлык Интернета, щелкните его правой кнопкой, а затем, не отпуская кнопку, перетащите ярлык в принимающее гиперссылки поле на странице доступа к данным.

    Поле страницы доступа к данным, в которое вводится адрес гиперссылки, не форматирует адрес как гиперссылку. Адрес, отформатированный как гиперссылка, следует искать в других частях страницы.

Совет. Нажмите кнопку Обновить на панели инструментов Microsoft Internet Explorer, чтобы отобразить адрес гиперссылки в виде отформатированной гиперссылки.


Ввод гиперссылки путем копирования гиперссылки или ее адреса

  1. Откройте гиперссылку одним из следующих способов.
    • Откройте документ, содержащий гиперссылку или ее адрес.

    • В Web-обозревателе, таком как Microsoft Internet Explorer, перейдите к странице, содержащей гиперссылку или ее адрес.
  2. Выполните одно из следующий действий.
    • В документе выделите гиперссылку или ее адрес, а затем выберите команду Копировать в меню Правка.

    • В Web-обозревателе выделите содержимое поля Адрес или адрес гиперссылки на странице, щелкните его правой кнопкой, а затем выберите в контекстном меню команду Копировать.
  3. Откройте страницу доступа к данным в Web-обозревателе.

  4. Поместите курсор в поле, принимающее гиперссылки.

  5. Выберите в меню Правка команду Вставить.

    Поле страницы доступа к данным, в которое вводится адрес гиперссылки, не форматирует адрес как гиперссылку. Адрес, отформатированный как гиперссылка, следует искать в других частях страницы.

Совет. Нажмите кнопку Обновить на панели инструментов Microsoft Internet Explorer, чтобы отобразить адрес гиперссылки в виде отформатированной гиперссылки.


Получено сообщение об ошибке при попытке ввода данных на странице доступа к данным

При попытке выйти из поля после ввода данных база данных проверяет, являются ли введенные данные допустимыми для этого поля. Если значение не является допустимым, появляется предупреждающее сообщение. Для того чтобы выйти из поля, следует ввести правильное значение или отменить внесенные изменения.

Значение поля может оказаться недопустимым по следующим причинам.

  • Значение несовместимо с типом данных поля. Если введено значение, не соответствующее типу данных поля, база данных пытается преобразовать его в правильный тип данных. Однако некоторые данные нельзя автоматически преобразовать в данные другого типа. Например, нельзя хранить текстовое значение в числовом поле.

  • Данные нарушают правило проверки условий на значение поля. Например, поле «Минимальный запас» может требовать значение не меньше 10, а введено 5.

  • В поле необходимо ввести данные, а была сделана попытка оставить его пустым. Например, поле «Цена» может требовать значения больше 0, но в него ничего не введено.

Данные проверяются также при выходе из записи. Перед сохранением записи база данных проверяет, чтобы внесенные изменения не нарушали правила проверки условий на значения записей. Кроме того, проверяется, чтобы значение поля идентификатора изменяемой записи не совпадало со значениями идентификаторов других записей таблицы. Если запись не удается сохранить, внесите необходимые изменения или отмените все изменения, внесенные в запись.


Ввод адреса гиперссылки в поле на странице доступа к данным

  1. Поместите курсор в поле, принимающее адреса гиперссылок.

  2. Введите соответствующий адрес гиперссылки. Адрес гиперссылки может содержать до четырех частей, разделенных знаком #:

    отображаемый_текст#адрес#дополнительный_адрес#подсказка

    Следующий пример содержит компоненты отображаемый_текст, адрес и подсказка. Обратите внимание, что он также содержит знак # для компонента дополнительный_адрес, который опущен: Корпорация Майкрософт#http://example.microsoft.com/##Страница примеров Корпорации Майкрософт

Примечания

  • Поле страницы доступа к данным, в которое вводится адрес гиперссылки, не форматирует адрес как гиперссылку. Адрес, отформатированный как гиперссылка, следует искать в других частях страницы.

  • Нажмите кнопку Обновить на панели инструментов Microsoft Internet Explorer, чтобы отобразить адрес гиперссылки в виде отформатированной гиперссылки.

  • Всплывающая подсказка, отображаемая для гиперссылки на странице доступа к данным, определяется для рисунка или гиперссылки при разработке страницы, поэтому вводимая подсказка не будет отображаться на странице доступа к данным. Тем не менее, она сохраняется в поле базы данных.

  • Дополнительные сведения по вводу адресов гиперссылок.


Страница доступа к данным была отправлена в виде сообщения электронной почты, но получатель не смог ее прочесть

Для просмотра страницы доступа к данным, отправленной как сообщение электронной почты, получатель должен прочесть сообщение с помощью одного из следующих приложений:

  • Microsoft Outlook 2000;

  • Microsoft Outlook Express версии 5.0;

  • сочетание Microsoft Outlook 98 и Microsoft Internet Explorer версии 5 или более поздней;

  • сочетание Microsoft Outlook Express и Microsoft Internet Explorer версии 5 или более поздней.

Получатели электронной почты могут обратиться к системному администратору за дополнительными сведениями об установке и обновлении этого программного обеспечения.


Трудности при редактирование данных в поле страницы доступа к данным

На странице доступа к данным есть несколько типов полей, которые нельзя изменять. Следующие поля отображают значения так же, как и обычные поля, но при попытке ввода в них данных ничего не происходит.

  • Поля с автоматическим вводом числа. База данных автоматически назначает в этом поле номер для каждой добавляемой записи. Поля этого типа часто используются в качестве кода записи. База данных автоматически заполняет значение этого поля.

  • Поля автоматических вычислений. Поля данного типа отображают значения, автоматически вычисляемые базой данных. Эти поля часто основываются на других полях базы данных, но не хранятся в базе данных.

  • Заблокированные или недоступные поля. Поле может быть заблокировано или недоступно для вода данных.

  • Поля в блокированной записи. Если при работе в сети запись заблокирована другим пользователем, данные в этой записи изменять нельзя до тех пор, пока этот пользователь не завершит редактирование записи.

  • Поле только для чтения. Базовые данные в базе данных доступны только для чтения.

  • Поля страницы доступа к данным с группами. Страница доступа к данным с группами предназначена только для отображения данных.

  • Поля сводных списков Сводный список предназначен только для отображения данных.

Возможны трудности с вводом дат в поля, хранящие даты и значения времени. При вводе данных в формате с разделением косой чертой (/) не вводите косую черту в конце. Например, дата 1/3 является допустимой, а 1/3/ недопустимой.


Пустые поля на странице доступа к данным

Возможны следующие причины.

  • Отображаемая страница доступа к данным может представлять собой форму для ввода данных. В пустые поля можно ввести свои данные.

  • Страница доступа к данным содержит раскрывающийся список, определяющий записи для отображения. Выберите значение в списке для просмотра конкретной группы или подмножества записей.

  • Страница доступа к данным утратила связь с базой данных, являющейся источником данных. Обновите страницу чтобы восстановить ее подключение к базе данных.

  • База данных заблокирована другим пользователем.


Отсутствуют кнопки на панели перехода по записям

Разработчик страницы доступа к данным удалил кнопки для этой страницы или группы.