Сводные таблицы

Содержание раздела

Обзор

Анализ данных в сводной таблице

Исходные данные

Дополнительные сведения

Обзор

Сводная таблица является интерактивной таблицей, позволяющей анализировать данные из Web-обозревателя. Пользователи имеют возможность использовать эти таблицы для просмотра и компоновки данных из больших баз данных, поиска информации, а также создания сводок и отчетов.

Источники данных для сводных таблиц. В сводной таблице могут быть представлены существующие данные из любого сетевого источника. Разработчик сводной таблицы определяет, какой источник данных используется и какое подмножество данных из исходной базы данных является доступным. Пользователи не могут вводить новые значения в вычисляемые ячейки сводной таблицы или переопределить источник данных, но могут изменять способ отображения и компоновки данных. Кроме того, имеется возможность обновлять сводную таблицу, чтобы она отображала любые изменения в исходных данных.

Сводные таблицы и диаграммы. Разработчик сводной таблице может присоединить к таблице диаграмму, графически отображающую те же данные. Если просматриваемая Web-страница содержит такую диаграмму, то при изменении или обновлении сводной таблицы эти изменения будут отражены на диаграмме. Работа с диаграммой, присоединенной к сводной таблице.

Терминология. В сводных таблицах для описания данных используются термины «поле» и «область сведений». Пользователи, имеющие опыт работы со сводными отчетами Microsoft Excel или сводными формами Microsoft Access, найдут терминологию сводных таблиц привычной.

Возврат в начало

Анализ данных в сводной таблице

Разработчик сводной таблицы выбирает один из многих возможных способов представления данных. Пользователи имеют возможность использовать панель инструментов и окно Панель свойств: Сводная таблица для изменения способа отображения данных. Можно проводить поиск конкретных данных, отображать большее или меньшее количество сведений, а также перемещать строки и столбцы в другие области для расчета других сводных значений.

Способы отображения данных в сводной таблице. В простейшем виде в сводных таблицах данные отображаются в строках и столбцах, причем однотипные данные размещаются в одном столбце. Каждый столбец называют полем — в следующем примере представлены поля «Спорт», «Квартал» и «Продажи».

Пример сводной таблицы со всеми полями сведений

Простейшая сводная таблица похожа на таблицу, содержащую записи из базы данных, или на набор строк электронной таблицы.

У пользователей имеются следующие возможности анализа данных.

  • Применение фильтров к полям для поиска данных. Например, можно отобразить только данные, относящиеся к продажам теннисного инвентаря в третьем квартале.

  • Сортировка для переупорядочения строк. Например, можно отсортировать поле «Продажи», чтобы увидеть, какой спортивный инвентарь и в каком квартале обеспечил наивысший доход объем продаж.

  • Добавление промежуточных итогов или добавление других расчетов в таблицу. Например, можно отобразить максимальную сумму продаж для каждого типа товаров.

В сводной таблице имеются различные области, в которые пользователи могут перетаскивать поля для расчета в них сводных значений или для полного просмотра их содержимого (сведений). Можно представить сводную таблицу аналогично предыдущему примеру, переместив все поля в область сведений, если источник данных это позволяет.

Суммарные данные. Создав поле итогов и переместив поля в другие области, можно быстро обобщить данные. Например, начните работу со сводной таблицей из предыдущего примера. Если создать итоговое поле «Сумма: Продажи», переместить поле «Спорт» в область строк, а поле «Квартал» в область столбцов, как показано в следующем примере, можно легко сравнить результаты продаж инвентаря для гольфа с данными по другим товарам или кварталам, а также увидеть общие итоги продаж.

Пример суммарных данных в сводной таблице

В ячейке, отображающей данные продаж для гольфа в третьем квартале, суммируются суммы продаж из каждой записи, содержащей значения «Гольф» и «Кв. 3» в соответствующих полях.

Сохранение изменений. Если используется Microsoft Internet Explorer 4.01 или более поздняя версия, изменения, внесенные в сводную таблицу, удерживаются в течение сеанса обозревателя, даже после возвращения в сводную таблицу после просмотра других Web-страниц. Однако, после нового открытия Web-страницы — например, после перехода в поле адресов Internet Explorer и нажатия клавиши ENTER — изменения будут потеряны.

Вне зависимости от используемого Web-обозревателя, внесенные пользователем изменения не затрагивают исходную сводную таблицу. Таким образом, другие пользователи, просматривающие ту же сводную таблицу одновременно с вами, эти изменения не увидят.

Работа с другими программами. Пользователи имеют возможность копировать данные из сводной таблицы в другие программы, такие как Microsoft Word, или, если требуется провести дальнейший анализ данных или напечатать измененную версию таблицы, экспортировать таблицу в сводный отчет Microsoft Excel. Если требуется создать собственную сводную таблицу или изменить макет существующей, можно использовать режим конструктора страниц доступа к данным Microsoft Access 2000 или FrontPage 2000 для открытия Web-страницы и использования дополнительных средств работы со сводными таблицами. Дополнительные сведения см. в справке Access или FrontPage.

Возврат в начало

Исходные данные

Базы данных. Сводные таблицы позволяют отображать данные из сетевых баз данных, включая и базы данных OLAP, и реляционные базы данных, такие как Microsoft Access или Microsoft SQL Server. Для получения дополнительных сведений о базах данных OLAP см. раздел об источниках данных OLAP. Сводные таблицы позволяют также отображать данные из сетевых баз данных других типов, а также данные из баз данных электронных таблиц, например, из Excel. Тип исходной базы данных и типы данных, включенных в просматриваемую сводную таблицу, определяют, какие представления и сводные результаты можно создавать из Web-обозревателя.

Когда исходная база данных изменяется или обновляется новыми данными, пользователь имеет возможность обновить сводную таблицу, чтобы получить последние данные.

Исходные данные определяет разработчик сводной таблицы. Это означает, что разработчик решает, какую исходную базу данных использовать и какое подмножество данных следует сделать доступным. Это подмножество в свою очередь определяет, какие данные могут обрабатывать пользователи. Например, если требуется суммировать результаты продаж по товарам и по количеству для каждой категории, источник даных должен обеспечивать суммы продаж и количественные данные по товарам в каждом заказе.

Просмотр полей, доступных в источнике данных. Просматриваемая сводная таблица может не включать все поля, доступные в источнике данных. Если имеются другие доступные поля, пользователь имеет возможность добавить поля в сводную таблицу. Для добавления полей в таблицу используют диалоговое окно Список полей, которое открывается кнопкой Список полей [image] на панели инструментов.

Пример списка полей

Пример списка полей

Для того чтобы отображать или скрывать поля, можно выполнять прокрутку или щелкнуть индикатор развертывания Плюс или Минус . Поля, уже отображаемые в сводной таблице, представлены в списке полужирным шрифтом.

Источники данных OLAP. Технология On-Line Analytical Processing (OLAP) представляет подход к обработке данных на сервере баз данных, позволяющий организовать большие объемы данных таким образом, чтобы сделать их доступными и понятными для потребителей, заинтересованных в анализе деловых тенденций и результатов. В таких базах данных различные категории данных распределяются по измерениям и уровням сведений.

Например, географическое измерение может включать уровни «Страна», «Регион» и «Город», временное измерение уровни «Год», «Квартал», «Месяц» и «День». Эти измерения преобразуются в строки, столбцы или поля фильтра в сводной таблице. Поле каждого измерения в сводной таблице позволяет отображать данные из верхних или нижних уровней сведений.

При работе со сводными таблицами, основанными на базах данных OLAP, например, созданными с помощью служб Microsoft SQL Server OLAP Services, пользователи могут заметить, что невозможно перемещать поля в область сведений, а некоторые поля можно использовать только в области данных. Кроме того, при этом поля измерений отображаются в виде наборов; поэтому при перемещении одного поля из набора другие поля перемещаются вместе с ним. В списке полей рядом с такими полями выводятся значки Поле измерения , а рядом с полями данных значки Поле данных .

Возврат в начало

Дополнительные сведения

Просмотр сведений для сводных данных

Форматирование сводной таблицы

Печать сводной таблицы

Возврат в начало


Элементы сводной таблицы

Пример сводной таблицы с именами элементов

Поля. Поля, соответствующие столбцам данных, позволяют обрабатывать многие строки информации. К различным типам полей принадлежат поля строк, поля столбцов, поля данных и поля фильтра.

Элемент. Элементами называют уникальный элементы данных в поле. Элементы полей строк и столбцов выводятся вдоль строк и вдоль столбцов. В ячейке на пересечении строки и столбца выводятся сводные данные для элементов, имена которых отображаются над столбцом и слева от строки.

Когда для элемента имеются доступные для отображения исходные данные (сведения), рядом с элементом выводится индикатор развертывания Плюс.

Поле строк. Поле в области строк. В предыдущем примере полями строк являются поля «Товар» и «Продавец». Элементы полей строк перечислены вдоль левого края сводной таблицы. Внутренние поля строк, такие как поле «Продавец», находятся ближе к области данных; внешние поля строк, такие как поле «Товар», выводятся слева от внутренних полей строк.

Поле столбцов. Поле в области столбцов. Элементы полей столбцов перечислены вдоль верхнего края сводной таблицы над полями данных. В предыдущем примере полем столбцов является поле «Квартал» с двумя элементами «Кв.2» и «Кв.3». Внутренние поля столбцов находятся ближе к области данных; внешние поля столбцов выводятся над внутренними полями столбцов.

Поле фильтра. Поле в области фильтра можно использовать для отбора данных, отображаемых в сводной таблице. В данном примере таким полем является поле «Регион», которое позволяет отобразить данные для всех регионов или для выбранного региона. Поля фильтра выполняют те же функции, что и поля страницы в сводных отчетах Microsoft Excel и сводных формах Microsoft Access.

Область данных. Часть сводной таблицы, содержащая поля данных.

Поле данных. Поле, содержащее сводные значения по исходным данным. В приведенном примере полем данных является поле «Продажи», содержащее суммарные данные по объемам продаж. Каждое значение в поле данных представляет сумму значений поля или столбца «Продажи» в источнике данных.

В поле данных обычно суммируются числовые данные, такие как количество или объем продаж, с использованием статистической функции Sum. В приведенном примере ячейка, содержащая значение 30 984, представляет сумму продаж конкретного типа товаров конкретным продавцом. В этой ячейке суммируются значения из всех записей в источнике данных, относящихся к указанному типу товаров, продавцу и кварталу.

Базовый источник данных может также содержать текстовые значения, которые по умолчанию обрабатываются функцией Count, позволяющей подсчитать число элементов — например, провести подсчет числа продаж для определенного типа товаров, выполненных определенным продавцом в конкретном квартале. В сводной таблице могут также использоваться функции Min и Max, позволяющие найти наименьшее и наибольшее значение, соответственно.

Область сведений. Часть сводной таблицы (не показанная на рисунке), в которой могут отображаться все строки или записи из источника данных. Сводная таблица позволяет отображать исходные строки одновременно с суммарными данными. Поля в области сведений называют полями сведений.

Стрелка развертывания поля. Стрелка Стрелка поля справа от имени каждого поля. Щелчок по этой стрелке открывает список, в котором выбираются элементы для отображения и скрытия.

В сводных таблицах, базирующихся на источнике из базы данных OLAP, пользователь имеет возможность выбирать элементы на различных уровнях в поле измерений. Поля даты/времени образуют различные уровни исходных данных. Например, щелкнув стрелку развертывания поля «Год», можно отобразить следующую структуру:

Раскрывающийся список для поля измерений OLAP

Пример раскрывающегося списка для поля измерений OLAP

Серый флажок для 1999 года указывает, что он отобран для отображения, но некоторые из элементов, находящихся ниже, не выбраны для отображения. 1998 год является скрытым. Для 1999 года скрытым является первый квартал. При установленном флажке Показать все все элементы поля на всех уровнях выбираются для отображения.


Печать сводной таблицы

  • В меню Файл Internet Explorer выберите команду Печать.

Примечания

  • Если ширина сводной таблицы превышает ширину листа бумаги, не умещающаяся на листе правая часть таблицы не печатается.

  • Web-обозреватель печатает только те части сводной таблицы, которые не являются скрытыми и на которые пользователь выполнил прокрутку в сеансе обозревателя. Например, если отобразить только сведения верхнего уровня или скрыть сведения, то скрытые сведения не печатаются. Если выполнена прокрутка от начала и до конца данных, то печатается вся сводная таблица.

  • Чтобы получить больше возможностей управления печатью данных, в том числе возможность полностью печатать длинную сводную таблицу и устанавливать разрывы страниц, можно экспортировать сводную таблицу в Microsoft Excel. Для получения сведений о печати из Excel см. справку Excel.


Сохранение изменений сводной таблицы

Если используется Microsoft Internet Explorer 4.01 или более поздняя версия, изменения, внесенные в сводную таблицу, удерживаются в течение сеанса обозревателя, даже после возвращения в сводную таблицу после просмотра других Web-страниц. Однако после нового открытия Web-страницы — например, после перехода в поле адресов Internet Explorer и нажатия клавиши ENTER — изменения будут потеряны. Невозможно сохранить изменения в файле.

Чтобы внести изменения в сводную таблицу и сохранить изменения в файле, необходимо открыть сводную таблицу в программе-конструкторе, например, в Microsoft FrontPage 2000 или режиме конструктора страниц доступа к данным Microsoft Access. См. сведения о программах-конструкторах сводных таблиц. Имеется также возможность экспортировать сводную таблицу в сводный отчет Excel, а затем сохранить отчет Excel. Дополнительные сведения см. в справке Excel.


Отмена всех изменений

  • Для восстановления сводной таблицы в том состоянии, которая она имела при начале ее просмотра в Microsoft Internet Explorer, следует закрыть, а потом снова запустить Internet Explorer.

Примечание. Невозможно отменить отдельные изменения в сводной таблице. См. сведения о работе со сводными таблицами в разных обозревателях.


Работа со сводными таблицами в разных обозревателях

Для просмотра и работы со сводными таблицами необходимо установить Microsoft Office Web Components. Это можно сделать при установке Microsoft Office 2000 или, если у вашей организации имеется лицензия на узел Office 2000, можно загрузить Office Web Components из интрасети организации. Полный набор средств, обеспечиваемых сводными таблицами в Web, например, возможность обработки данных в сводной таблице из Web-обозревателя, может оказаться доступным не во всех обозревателях.

Microsoft Internet Explorer 5 и более поздние версии. Этот обозреватель обеспечивает доступ ко всем средствам сводной таблицы, которые могут использоваться в обозревателе. Внесенные пользователем изменения, такие как форматирование или изменение макета, сохраняются при выходе из сводной таблицы и последующем возвращении в нее в том же сеансе обозревателя.

Microsoft Internet Explorer 4.01, 4.1x и 4.2x. Обеспечивается доступ ко всем средствам сводной таблицы, которые могут использоваться в обозревателе. Внесенные пользователем изменения, такие как форматирование или изменение макета, сохраняются при выходе из сводной таблицы. В некоторых случаях требуется установить Internet Explorer 5 для просмотра сводных таблиц на Web-страницах, созданных или измененных в режиме конструктора страниц доступа к данным Microsoft Access.

Microsoft Internet Explorer 4.0. Обеспечивается доступ ко всем средствам сводной таблицы, доступным с панели инструментов и контекстных меню сводной таблицы, но при этом недоступна Панель свойств: Сводная таблица. При выходе из сводной таблицы изменения не сохраняются. В некоторых случаях требуется установить Internet Explorer 5 для просмотра сводных таблиц на Web-страницах, созданных или измененных в режиме конструктора страниц доступа к данным Microsoft Access.

Другие обозреватели. В более ранних версиях Microsoft Internet Explorer и в других обозревателях просмотр сводных таблиц невозможен. Сводной таблица на Web-странице либо отображается как ограниченное поле, либо не отображается вообще.


Просмотр диаграммы, базирующейся на сводной таблице

Разработчик Web-страницы, которую вы открываете, мог создать диаграмму, графически представляющую данные из сводной таблицы. В настоящем разделе объясняется, как работают диаграммы и что происходит с диаграммой, когда пользователь вносит изменения в сводную таблицу.

Автоматическое обновление. Когда пользователь изменяет сводную таблицу, по которой построена диаграмма, диаграмма автоматически обновляется для отражения изменений в сводной таблице. Например, если переместить поле в область строк или столбцов, диаграмма автоматически будет обновлена, чтобы отразить содержимое поля как данные категории или данные ряда. При скрытии информации (например, при применении фильтра или удалении поля из сводной таблицы), в результате чего данные более не включаются в представление сводной таблицы, эта информация исключается из диаграммы.

Обязательные поля. Необходимо добавить по крайней мере одно поле итогов в сводную таблицу для отображения данных в диаграмме. Если сводная таблица содержит несколько итоговых полей, на диаграмме отображаются данные из крайнего левого поля итогов. Поля строк и столбцов сводной таблицы образуют на диаграмме данные категорий и рядов. Если все отображаемые поля находятся в области сведений сводной таблицы, в диаграмме нет категорий и рядов для построения. Необходимо переместить по крайней мере одно поле из области сведений или списка полей в область строк или столбцов.

Пример. Ниже приведена диаграмма, построенная на основе сводной таблицы. В поле «Сумма: Продажи» отображается итоговая сумма, вырученная продавцом с продажи указанного типа товара. Синяя стрелка справа от подписи поля «Продавец» показывает, что к данным применен фильтр, в результате чего суммы продаж показаны только для четырех продавцов.

Диаграмма, построенная на основе сводной таблицы.

Диаграмма, построенная на основе сводной таблицы. Поле столбцов сводной таблицы, названное «Тип», отображено на диаграмме как данные категорий (напитки, молоко и так далее). Поле строк «Продавец» отображено на диаграмме как данные ряда. Названия рядов показаны на легенде (Батурин, Белов и так далее).

При добавлении или перемещении полей в сводной таблице диаграмма автоматически обновляется, отображая внесенные изменения.

Обновленная диаграмма, построенная на основе измененной сводной таблицы

Обновленная диаграмма, отражающая изменения сводной таблицы.

В предыдущем примере в сводной таблице поле «Продавец» было перемещено в область столбцов, а поле «Тип» — в область строк. Поле «Регион» было добавлено в область столбцов и был применен фильтр для отображения только регионов «Восточный» и «Северный». Диаграмма автоматически обновилась, поэтому поле «Тип» показано в легенде как ряд, а поля «Продавец» и «Регион» показаны как категории.


Получение помощи при разработке сводной таблицы

Когда пользователь просматривает или изменяет сводную таблицу в Web-обозревателе, работа осуществляется с элементом управления, созданным в другой программе, которую называют программой конструктора. В программе конструктора разработчик имеет возможность выбрать данные, которые будут отображаться в сводной таблице, добавить сводную таблицу на создаваемую Web-страницу и опубликовать Web-страницу на Web-сервере. Справку по разработке сводной таблицы следует вызывать из программы конструктора.

Данный раздел содержит сведения о начале разработки сводной таблицы и вызове дополнительной справки.

Разработка сводной таблицы

Вызов справки при разработке сводных таблиц

Вызов справки при написании сценариев и программ для сводных таблиц

Разработка сводной таблицы

Перед началом разработки сводной таблицы следует сначала выбрать программу-конструктор. Пользователь имеет возможность начать разработку таблицы в любом из поддерживаемых конструкторов, а затем, если требуются другие средства разработки, продолжить работу с этой сводной таблицей в другом конструкторе.

Использование Microsoft FrontPage 2000 в качестве конструктора. Чтобы создать новую сводную таблицу для пользователей, имеющих Microsoft Internet Explorer 4 или более позднюю версию, или изменить макет сводной таблицы, опубликованной из Microsoft Excel, рекомендуется Microsoft FrontPage 2000. Для работы со сводными таблицами, созданными в FrontPage, пользователи должны иметь Internet Explorer 4 или более позднюю версию и Microsoft Office Web Components. Версия FrontPage 2000 доступна в пакете Microsoft Office 2000, расширенный выпуск. Компоненты Office Web Components доступны в стандартном, профессиональном и расширенном выпусках Office 2000.

Использование Microsoft Access в качестве конструктора. Используйте режим конструктора страниц доступа к данным, чтобы создать в Microsoft Access 2000 новую сводную таблицу для пользователей, имеющих Microsoft Internet Explorer 5 или более позднюю версию, а также для пользователей, имеющих Internet Explorer, которые могут также установить Internet Explorer 5. Microsoft Access содержит специализированные средства для создания Web-страниц, обеспечивающих доступ и обработку данных из баз данных. Для работы со сводными таблицами, созданными в Access, пользователи должны установить Internet Explorer 5 или более позднюю версию и Microsoft Office Web Components. Microsoft Access 2000 входит в профессиональный и расширенный выпуски Microsoft Office 2000. Компоненты Office Web Components доступны в стандартном, профессиональном и расширенном выпусках Office 2000.

Использование Microsoft Excel в качестве конструктора. Используйте Microsoft Excel 2000, если вы имеете опыт работы со сводными отчетами Excel или работаете со сводным отчетом, который требуется опубликовать на Web-странице. Для работы со сводными таблицами, опубликованными из Excel, пользователи должны иметь Internet Explorer 4 или более позднюю версию и Microsoft Office Web Components.

Использование Microsoft Visual Basic или языка сценариев. Если вы имеете опыт программирования, то для создания сводной таблицы можно написать программы или сценарии. Возможность писать сценарии дают FrontPage 2000 и режим конструктора страниц доступа к данным. Если требуется разработать сводную таблицу для использования в пользовательском приложении, а не в Web-обозревателе, можно использовать среду программирования, например, Microsoft Visual Basic.

Возврат в начало

Вызов справки при разработке сводных таблиц

Работа со сводной таблицей в программе конструктора. При создании или открытии сводной таблицы в программе конструктора, например, в FrontPage 2000 или режиме конструктора страниц доступа к данным Access 2000 Панель свойств: сводная таблица обеспечивает доступ к дополнительным командам и свойствам, обеспечивающим настройку сводной таблицы для использования в обозревателе. Конструктор может также обеспечивать собственные команды и средства для подготовки исходных данных и связывания их со сводной таблицей.

Вызов справки в программе конструктора. При работе в конструкторе у пользователя имеется два способа вызова справки по разработке сводной таблицы.

  • Справка программы-конструктора. Чтобы получить сведения о доступных в конструкторе командах и средствах работы со сводными таблицами, следует обращаться к справке этой программы. Например, в Microsoft Access вызовите помощника или нажмите кнопку Справка по Microsoft Access [image].

    В Microsoft Excel наряду с общей справкой о публикации и сохранении данных Excel для использования на Web-страницах имеется специальная информация о подготовке данных для использования в сводном отчете и последующей публикации сводного отчета в виде сводной таблицы на Web-странице. Для вызова справки Excel вызовите помощника или нажмите кнопку Справка по Microsoft Excel [image].

  • Справка конструктора сводной таблицы. В сводной таблице, созданной или открытой в программе-конструкторе, нажмите кнопку Справка [image] на панели инструментов сводной таблицы. При этом будут открыты разделы справки о свойствах и командах, которые можно использовать в конструкторе сводной таблицы. Эта справка не совпадает со справкой, доступной в обозревателе, т.е. с текущей просматриваемой справкой).

Возврат в начало

Написание сценариев и программ для сводных таблиц

Можно использовать сценарии и программы для автоматизации сводных таблиц или включать сводные таблицы в другие выполняемые программные модули, помимо Web-обозревателей, разработанные в таких средах программирования, как Microsoft Visual Basic.

Написание сценариев. Программы Microsoft Office 2000 содержат редактор сценариев Microsoft Script Editor, помогающий писать сценарии. Например, редактор сценариев может использоваться из конструктора страницы доступа к данным Microsoft Access для изменения сводной таблицы. Сведения о работе с редактором сценариев смотрите в справке программы-конструктора Office. Кроме того, в самом редакторе можно вызвать дополнительную справку об использовании средств редактора и написании сценариев.

Справка модели объектов. Чтобы получить справку о разработке программы или сценария для работы со сводной таблицей, можно использовать справочник Microsoft Office Web Components Visual Basic Reference, содержащий сведения о модели объектов, свойствах и методах, специфических для сводных таблиц. Эта справка модели объектов устанавливается при установке Office Web Components. Сводные таблицы являются одним из таких компонентов. В зависимости от используемой программы-конструктора, пользователь имеет возможность получить доступ к этой справке одним из двух способов.

  • Справка в Visual Basic. В Visual Basic или Visual Basic для приложений, можно создавать ссылки на библиотеку Microsoft Office Web Components. При этом появляется возможность обращаться к справке через средство просмотра объектов или с помощью клавиши F1, предварительно выделив ключевое слово. Сведения о создании ссылок и использовании справки модели объектов см. в справке Visual Basic или Visual Basic для приложений.

  • Справка в других средах. Если используется другая среда разработки, найдите и дважды щелкните файл справки Msowcvba.chm.

Возврат в начало


Сочетания клавиш для сводных таблиц

Действия, выполняемые с помощью сочетаний клавиш

Активизация, перемещение по сводной таблице и отключение сводной таблицы

Выделение элементов в сводной таблице

Выполнение команд

Отображение, скрытие, отбор и сортировка данных

Добавление полей и итоговых значений и изменение макета сводной таблицы

Форматирование сводной таблицы


Активизация, переходы и деактивизация сводной таблицы с помощью клавиатуры

Клавиши | Действия
Клавиша TAB | Последовательное выделение каждого элемента управления на Web-странице. После активизации сводной таблицы нажатие клавиши TAB приводит к выделению элементов сводной таблицы.
CTRL+TAB | Деактивизация (т.е. выход из) сводной таблицы и выделение или активизация следующего элемента управления на Web-странице.


Выделение элементов внутри сводной таблицы с помощью клавиатуры

Клавиши | Действия
Клавиша TAB | После активизации сводной таблицы последовательные нажатия клавиши TAB приводят к циклическому выделению каждого поля и сводной таблицы в целом.
SHIFT+TAB | Выделение предыдущего поля или сводной таблицы в целом.
Клавиши со стрелками Перемещение выделения в направлении стрелки.

Если выделено поле строк или столбцов, нажмите клавишу СТРЕЛКА ВНИЗ для перехода на элемент данных в поле, а затем нажимайте клавишу со стрелкой для перехода на следующий или предыдущий элемент или возврат на поле.

Если выделено поле сведений или элемент данных, нажмите клавишу СТРЕЛКА ВНИЗ или СТРЕЛКА ВПРАВО для перехода на первую ячейку в области сведений или область данных.
SHIFT+клавиша со стрелкой | Расширение или сокращение выделенного фрагмента в направлении стрелки. Пользователь имеет возможность расширять выделенный фрагмент вниз и вправо.
SHIFT+PAGE DOWN | Расширение выделенного фрагмента вниз на один экран. Экраном являются все текущие данные, отображаемые в сводной таблице.
SHIFT+PAGE UP | Сокращение выделенного фрагмента на один экран.
CTRL+ПРОБЕЛ | Выделения поля для текущего выделенного элемента данных, итога или ячейки сведений.
SHIFT+ПРОБЕЛ | Выделение строки, содержащей текущую выделенную ячейку.
CTRL+A | Выделение сводной таблицы в целом.
PAGE DOWN | Отображение следующего экрана. Экраном являются все текущие данные, отображаемые в сводной таблице.
PAGE UP | Отображение предыдущего экрана.
ALT+PAGE DOWN | Отображение следующего экрана справа.
ALT+PAGE UP | Отображение предыдущего экрана слева.


Выполнение команд с помощью клавиатуры

Клавиши | Действия
F1 | Отображение разделов справки. Для получения сведений о работе с клавиатуры в окне справки см. справку Web-обозревателя.
SHIFT+F10 | Открытие контекстного меню для выделенного элемента сводной таблицы. Пользуйтесь контекстным меню для выполнения команд в сводной таблице.
Подчеркнутая буква. | Выполнение команды из контекстного меню. См. в описании сочетания клавиш ALT+ENTER сведения о панели свойств Сводная таблица.
ESC | Закрытие контекстного меню без выполнения команды.
CTRL+7 | Отображение или скрытие панели инструментов.
ALT+ENTER | Открытие окна Панель свойств: Сводная таблица. Клавиши быстрого вызова для выполнения команд в этом окне отсутствуют.
ALT+F4 | Закрытие окна Панель свойств: Сводная таблица.
F9 | Обновление сводной таблицы по исходным данным.
ESC | Отмена выполняющейся операции обновления.
CTRL+C | Копирование выделенных в сводной таблице данных в буфер обмена.
CTRL+E | Экспорт сводной таблицы в Microsoft Excel.


Отображение, скрытие, применение фильтра и сортировка данных с помощью клавиатуры

Клавиши | Действия
CTRL+8 | Отображение и скрытие индикаторов развертывания Плюс и Минус рядом с элементами.
CTRL+ПЛЮС | Отображение сведений для текущего выделенного элемента.
CTRL+МИНУС | Скрытие сведений для текущего выделенного элемента.
ALT+СТРЕЛКА ВНИЗ | Открытие раскрывающегося списка для текущего выделенного поля.
Клавиша TAB | Циклические переходы на текущий выделенный элемент, кнопку OK и кнопку Отмена в раскрывающемся списке для поля.
Клавиши со стрелками | Переход на следующий элемент в раскрывающемся списке для поля.
ПРОБЕЛ | Установка или снятие флажка для текущего элемента в раскрывающемся списке поля.
Клавиша ПЛЮС на цифровой клавиатуре | Отображение нижнего уровня сведений, если доступен, для текущего элемента в раскрывающемся списке поля.
Клавиша МИНУС на цифровой клавиатуре | Скрытие нижнего уровня сведений для текущего элемента в раскрывающемся списке поля.
ENTER | Закрытие раскрывающегося списка для поля и применение любых внесенных изменений.
ESC | Закрытие раскрывающегося списка для поля без применения внесенных изменений.
CTRL+T | Включение и отключение автофильтра.
CTRL+SHIFT+A | Сортировка данных в выбранном поле или итогов по возрастанию (А-Я 0-9).
CTRL+SHIFT+Z | Сортировка данных в выбранном поле или итогов по убыванию (Я-А 9-0).


Форматирование сводной таблицы с помощью клавиатуры

Первые семь сочетаний клавиш в следующей таблице изменяют числовой формат выделенного элемента. См. сведения о числовых форматах.

Для использования следующих клавиш необходимо сначала выделить поле сведений или ячейку данных в поле итогов.

Клавиши | Действия
CTRL+SHIFT+~ (тильда) | Применение общего числового формата к значениям в выделенном поле итогов или сведений.
CTRL+SHIFT+$ | Применение денежного формата с двумя десятичными знаками и отображением отрицательных значений в скобках к значениям в выделенном поле итогов или сведений.
CTRL+SHIFT+% | Применение процентного формата без отображения десятичных знаков к значениям в выделенном поле итогов или сведений.
CTRL+SHIFT+^ | Применение экспоненциального формата с двумя десятичными знаками к значениям в выделенном поле итогов или сведений.
CTRL+SHIFT+# | Применение формата даты с отображением дня, месяца и года к значениям в выделенном поле итогов или сведений.
CTRL+SHIFT+@ | Применение формата времени с отображением часов, минут и индикаторов AM или PM к значениям в выделенном поле итогов или сведений.
CTRL+SHIFT+! | Применение числового формата с двумя десятичными знаками, разделителями групп разрядов и отображением отрицательных значений со знаком минус к значениям в выделенном поле итогов или сведений
CTRL+B | Форматирование текста полужирным шрифтом в выделенном элементе сводной таблицы.
CTRL+U | Форматирование текста подчеркнутым шрифтом в выделенном элементе сводной таблицы.
CTRL+I | Форматирование текста курсивом в выделенном элементе сводной таблицы.


Добавление полей и итоговых значений и изменение макета сводной таблицы с помощью клавиатуры

В данном разделе перечислены следующие сочетания клавиш.

Клавиши для работы со списком полей

Клавиши для добавления полей и итогов

Клавиши для изменения макета

Клавиши для работы со списком полей

Клавиши | Действия
CTRL+L | Отображение списка полей или его активизация, если список уже отображается.
Клавиши со стрелками | Переход на следующий элемент в списке полей.
Клавиша ПЛЮС на цифровой клавиатуре | Развертывание текущего элемента в списке полей для отображения его содержимого или развертывание элемента Итоги для отображения доступных итоговых полей.
Клавиша МИНУС на цифровой клавиатуре | Сжатие текущего элемента в списке полей для скрытия его содержимого или свертывание элемента Итоги для скрытия доступных итоговых полей.
Клавиша TAB | Циклические переходы между последним выделенным элементом, кнопкой Добавить в и полем со списком рядом с кнопкой Добавить в.
ALT+СТРЕЛКА ВНИЗ | Открытие раскрывающегося списка рядом с кнопкой Добавить в. С помощью клавиш со стрелкой перейдите на нужный элемент в списке и нажмите клавишу ENTER для выделения элемента.
ENTER | Добавление выделенного в списке полей поля в область сводной таблицы, отображаемую в поле раскрывающегося списка Добавить в.
ALT+F4 | Закрытие списка полей.

Возврат в начало

Клавиши для добавления полей и итогов

Клавиши | Действия
CTRL+SHIFT+S | Добавление нового поля итогов для поля, выделенного в списке полей сводной таблицы, с использованием статистической функции Sum.
CTRL+SHIFT+C | Добавление нового поля итогов для поля, выделенного в списке полей сводной таблицы, с использованием статистической функции Count.
CTRL+SHIFT+M | Добавление нового поля итогов для поля, выделенного в списке полей сводной таблицы, с использованием статистической функции Min.
CTRL+SHIFT+X | Добавление нового поля итогов для поля, выделенного в списке полей сводной таблицы, с использованием статистической функции Max.
CTRL+SHIFT+B | Включение и отключение промежуточных и общих итогов для поля, выделенного в списке полей сводной таблицы.

Возврат в начало

Клавиши для изменения макета

Клавиши | Действия
CTRL+1 | Перемещение поля, выделенного в списке полей сводной таблицы, в область строк.
CTRL+2 | Перемещение поля, выделенного в списке полей сводной таблицы, в область столбцов.
CTRL+3 | Перемещение поля, выделенного в списке полей сводной таблицы, в область фильтра.
CTRL+4 | Перемещение поля, выделенного в списке полей сводной таблицы, в область сведений.
CTRL+СТРЕЛКА ВЛЕВО | Перемещение поля строк или столбцов, выделенного в списке полей сводной таблицы, на более высокий уровень.
CTRL+СТРЕЛКА ВПРАВО | Перемещение поля строк или столбцов, выделенного в списке полей сводной таблицы, на более низкий уровень.

Возврат в начало


Панель инструментов и панель свойств сводной таблицы

Панель инструментов. Панель инструментов сводной таблицы, которая выводится на верхней границе таблицы, содержит набор команд, которые можно использовать для работы с данными в сводной таблице. Чтобы увидеть имя команды, задержите указатель над кнопкой.

Если панель инструментов не видна, ее мог скрыть разработчик сводной таблицы. Отображение скрытой панели инструментов.

Панель свойств: Сводная таблица. Панель свойств включает команды, такие как Отображение: Панель инструментов, и свойства, такие как цвет фона или ширина столбца. Содержимое панели свойств изменяется, когда пользователь выделяет различные части сводной таблицы. Панель свойств включает некоторые команды, отсутствующие на панели инструментов или в контекстных меню.

Команды и свойства панели свойств распределены по разделам, имена которых отображаются на соответствующих кнопках. Набор доступных разделов определяется выбранным элементом сводной таблицы. При первом вызове панели свойств отображаются команды и свойства раздела Общие. Для вызова или скрытия содержимого раздела достаточно нажать кнопку этого раздела. См. сведения, как использовать Панель свойств: Сводная таблица.

Если панель свойств не отображается, нажмите кнопку Панель свойств [image] на панели инструментов. Если кнопка недоступна, это означает, что разработчик сводной таблицы мог отключить доступ к панели свойств. Обратитесь за помощью к разработчику сводной таблицы.


Отображение панели инструментов сводной таблицы

  • Щелкните правой кнопкой строку заголовка сводной таблицы и выберите в контекстном меню команду Панель инструментов.

Примечания

  • Если строка заголовка сводной таблицы не отображается, щелкните правой кнопкой сводную таблицу и выберите в контекстном меню команду Панель свойств. Если раздел Отображение не развернут, нажмите кнопку Отображение, а затем щелкните значок Панель инструментов [image].

  • Если команда Панель свойств недоступна в контекстном меню, это означает, что разработчик сводной таблицы мог отключить доступ к панели свойств. Обратитесь за помощью к разработчику сводной таблицы.


Кнопки и команды панели инструментов

Эмблема Office Эмблема Office. Открывает диалоговое окно О Microsoft Office Web Components, демонстрирующее установленную версию. Куб вращается во время загрузки данных.

Копировать. Копирует выделенные данные из сводной таблицы в буфер обмена для последующей вставки в другие программы. Если требуется создать интерактивную копию в Microsoft Excel, следует использовать кнопку Экспорт в Excel [image].

Сортировка по возрастанию. Сортирует данные в выделенном поле в порядке А-Я 0-9.

Сортировка по убыванию. Сортирует данные в выделенном поле в порядке Я-А 9-0.

Автофильтр. Включает или отключает фильр для всех полей. Применение фильтра позволяет отображать только строки и столбцы, соответствующие указанным значениям.

Автовычисления. Добавляет поле итогов в список полей; данные обрабатываются с использованием статистической функции Sum, Count, Min или Max.

Промежуточные итоги. Отображает промежуточные итоги или скрывает промежуточные итоги для выделенного поля.

Перейти в область строк. Перемещает выделенное поле, превращая его в поле строк. Сводные данные полей строк отображаются в размещающихся сверху вниз строках сводной таблицы.

Перейти в область столбцов. Перемещает выделенное поле, превращая его в поле столбцов. Сводные данные полей строк отображаются в размещающихся слева направо столбцах сводной таблицы.

Перейти в область фильтра. Перемещает выделенное поле, превращая его в поле фильтра. Поля фильтра задают фильтр для всей сводной таблицы таким образом, чтобы отображались данные для выбранного в поле фильтра элемента.

Перейти в область сведений Перемещает выделенное поле в область сведений для отображения всех необработанных данных этого поля.

Повышение. Переводит выделенное внутреннее поле строк или столбцов на следующий уровень сверху. Когда в сводной таблице имеется несколько полей строк или полей столбцов, внешними полями являются поля, находящиеся дальше от данных, слева или сверху.

Понижение. Переводит выделенное внутреннее поле строк или столбцов на следующий уровень снизу. Когда в сводной таблице имеется несколько полей строк или полей столбцов, внутренними полями являются поля, находящиеся ближе к данным, справа или снизу.

Развернуть или Свернуть. Скрывает сведения или отображает сведения для выделенного поля, элемента данных или ячейки в области данных.

Обновить. Обновляет сводную таблицу по исходному файлу или базе данных, отображая любые новые данные и добавляя все новые поля в список полей.

Экспорт в Excel. Запускает или выполняет переход в Excel и копирует сводную таблицу в новую книгу в виде сводного отчета Excel, который в Excel является интерактивным эквивалентом сводной таблицы.

Панель свойств. Открывает окно Панель свойств: Сводная таблица, в котором можно выполнять команды и задавать свойства.

Список полей. Открывает список полей из источника данных, доступных в сводной таблице, который используют для добавления данных в сводную таблицу.

Справка. Отображает разделы справки по работе со сводной таблицей.


Скрытие панели инструментов сводной таблицы

  1. Щелкните сводную таблицу.

  2. Нажмите кнопку Панель свойств [image].

  3. Если раздел Отображение не развернут, нажмите кнопку Отображение.

  4. Щелкните значок Панель инструментов [image].

Примечание. Если кнопка Панель свойств [image] на панели инструментов недоступна, это означает, что разработчик сводной таблицы мог отключить доступ к панели свойств. Обратитесь за помощью к разработчику сводной таблицы.


Использование панели свойств сводной таблицы

  1. Выделите часть сводной таблицы, для которой требуется просмотреть или задать свойства или выполнить команды.

    Инструкции

  2. На панели инструментов сводной таблицы нажмите кнопку Панель свойств [image].

    Если панель свойств не отображается, щелкните правой кнопкой строку заголовка сводной таблицы и выберите в контекстном меню команду Панель инструментов.

  3. Чтобы развернуть или скрыть содержимое раздела, нажмите кнопку с названием этого раздела.

Примечания

  • Панель свойств содержит кнопки для выполнения команд, такие как Панель инструментов, и свойства, которые может задать пользователь, такие как цвет фона или ширина столбца.

  • Когда пользователь вводит или изменяет элементы в панели свойств, то для вступления изменений в силу следует щелкнуть другую часть панели свойств или нажать клавишу ENTER.

  • Если кнопка Панель свойств [image] и команда в контекстном меню недоступны одновременно, то, возможно, разработчик сводной таблицы ограничил к ним доступ.

  • Свойства, заданные для поля итогов, применяются ко всем итогам в сводной таблице.

  • Если оставить панель свойств открытой и выделять другие части сводной таблицы или другие элементы управления Microsoft Office Web Components, то доступные разделы и их содержимое будут изменяться в соответствии с выделенным элементом. Если выделить часть Web-страницы, отличную от элемента управления Office Web Components, панель свойств скрывается.


Поиск данных

В сводных таблицах отсутствуют команды поиска. Однако пользователь имеет возможность использовать фильтры и сортировку для поиска конкретных значений или всех данных, отвечающих определенному значению.

Поиск данных с помощью фильтра. Применение фильтра позволяет быстро отобрать подмножество данных в сводной таблице. Фильтр можно применять к полям строк, столбцов и области данных. Когда фильтр применяется к полю, отбирается один или несколько элементов данных в поле для просмотра, а остальные элементы скрываются.

Примеры применения фильтра в сводной таблице

Сначала в поле «Спорт» отбираются продажи, относящиеся к категории «Гольф», а затем в поле «Квартал» отбираются для отображения только данные, относящиеся к третьему кварталу.

Когда к просматриваемой сводной таблице применен фильтр, стрелка развертывания поля Стрелка поля , к которому применяется фильтр, из черной становится синей.

Выбор нескольких элементов в нескольких полях. Применение фильтра особенно полезно, когда у сводной таблицы имеется большой объем исходных данных и требуется сосредоточить внимание на интересующих пользователя областях. Фильтр позволяет отобразить данные для единственного элемента или выбрать несколько элементов для отображения и скрытия. Чтобы сузить область отображаемых данных, можно применить фильтр к нескольким полям одновременно. Применение фильтра к полю.

Фильтр по данным в одной ячейке. Фильтр позволяет отобразить данные, отвечающие значению в выбранной ячейке. Фильтр по выделенному является особенно удобным для полей в области сведений, в которой можно просмотреть все строки, содержащие конкретное значение.

Отключение фильтра. Чтобы отобразить все данные для всех полей в сводной таблице, пользователь имеет возможность отключить фильтр. Настройки фильтра сохраняются. Поэтому после повторного включения фильтра те же данные снова станут отображаемыми или скрытыми. Настройки фильтра также сохраняются, когда пользователь перемещает поля для изменения макета сводной таблицы. Однако, если начать создание новых настроек при отключенном фильтре, предыдущие настройки будут очищены.

Использование поля фильтра для применения фильтра ко всей сводной таблице. Можно применить фильтр к данным с помощью полей фильтра. Когда выбирается другой элемент в поле фильтра, данные, рассчитываемые и отображаемые во всей сводной таблице, изменяются. Пользователь имеет возможность добавить новые поля фильтра в сводную таблицу или переместить существующие поля в область фильтра.

Влияние фильтра на расчеты. По умолчанию в промежуточные и общие итоги включаются все данные из поля, в том числе, отображаемые и скрытые. Если требуется исключить скрытые данные из расчетов промежуточных и общих итогов, можно установить параметр включения только отображаемых данных.

Если требуется команда поиска. Для поиска данных без применения фильтра или для обнаружения данных, отвечающих некоторому образцу, можно экспортировать сводную таблицу в Microsoft Excel. Для получения сведений об использовании в Excel команды Найти см. справку Excel.


Применение фильтра к полю для отображения только требуемых данных

  1. Щелкните стрелку развертывания поля Стрелка поля , содержащего элементы данных, к которым требуется применить фильтр.

  2. Установите флажки для элементов, которые требуется отобразить, и снимите флажки для элементов данных, которые требуется скрыть.

Примечания

  • Чтобы отобразить или скрыть все данные для всех полей, установите или снимите флажок Все.

  • Затененный флажок показывает, что некоторые или все элементы на нижнем уровне являются скрытыми. Чтобы увидеть, какие из элементов на нижнем уровне скрыты, щелкните индикатор Плюс рядом с элементом с затененным флажком.

  • Чтобы отобразить все данные для всех полей, нажмите кнопку Автофильтр [image] еще раз, чтобы она стала не нажатой. Ранее установленный фильтр по выделенному будет сохранен и при следующем нажатии кнопки Автофильтр снова будет применен к полям. Если сохранять фильтр по выделенному не требуется, проверьте перед началом выделения элементов, что кнопка Автофильтр не нажата. Если кнопка не нажата, то при выборе новых элементов фильтр включается автоматически и снимаются предыдущие настройки фильтр.

  • Когда пользователь перемещает поле, к которому применяется фильтр, настройки фильтра сохраняются, если поле находится в области данных или области фильтра, где элементы не являются скрытыми. Это означает, что когда поле будет возвращено в строку, столбец или область сведений, ранее скрытые элементы останутся скрытыми. Кроме того, если удалить поле, а затем добавить это поле в макет, ранее скрытые элементы останутся скрытыми. О наличии скрытых полей в результате применения фильтра свидетельствует синий цвет стрелки в подписи поля.


Отображение данных, соответствующих значению в ячейке

  • Щелкните правой кнопкой ячейку, содержащую значение, которое требуется отобразить, и выберите в контекстном меню команду Фильтр по выделенному.

Примечания

  • Если кнопка Автофильтр [image] на панели инструментов нажата, то фильтр по выделенному является совокупным. Это означает, что фильтр действует дополнительно к уже применяющимся. Если кнопка Автофильтр не нажата, то фильтр по выделенному автоматически снимает ранее примененные фильтры и включается новое накопление данных.

  • Чтобы отобразить все данные для всех полей, нажмите кнопку Автофильтр [image] еще раз, чтобы она стала не нажатой. Ранее установленный фильтр по выделенному будет сохранен и при следующем нажатии кнопки Автофильтр снова будет применен к полям. Если сохранять фильтр по выделенному не требуется, проверьте перед началом выделения элементов, что кнопка Автофильтр не нажата.

  • Когда пользователь перемещает поле, к которому применяется фильтр, настройки фильтра сохраняются, если поле находится в области данных или области фильтра, где элементы не являются скрытыми. Это означает, что когда поле будет возвращено в строку, столбец или область сведений, ранее скрытые элементы останутся скрытыми. Кроме того, если удалить поле, а затем добавить это поле в макет, ранее скрытые элементы останутся скрытыми. О наличии скрытых полей в результате применения фильтра свидетельствует синий цвет стрелки Стрелка поля в подписи поля.


Удаление фильтров для отображения всех данных

  • На панели инструментов сводной таблицы нажмите кнопку Автофильтр [image] еще раз, чтобы она стала не нажатой.

Совет. Если затем снова нажать кнопку Автофильтр [image] для включения фильтра, будут восстановлены предыдущие настройки фильтров.


Сортировка данных в поле

  1. Выполните одно из следующих действий.

    Для сортировки данных в поле по подписям элементов щелкните подпись поля, которое требуется сортировать.

    Для сортировки данных в поле по сводным значениям в столбце, щелкните ячейку в столбце, содержащем данные, которые требуется сортировать.

    Для сортировки данных в поле по промежуточным или общим итоговым значениям щелкните промежуточное или общее итоговое значение для поля, которое требуется сортировать. Если щелкнуть общее итоговое значение в нижней строке сводной таблицы, будут отсортированы столбцы, а не строки.

  2. На панели инструментов сводной таблицы нажмите одну из следующих кнопок.

    Для сортировки поля по возрастанию нажмите кнопку Сортировка по возрастанию [image].

    Для сортировки поля по убыванию нажмите кнопку Сортировка по убыванию [image].

Примечания

  • Чтобы отменить сортировку и вернуться к предыдущему порядку элементов данных в поле, снова нажмите кнопку Сортировка по возрастанию [image] или Сортировка по убыванию [image] , чтобы отпустить нажатую кнопку.

  • Когда выполняется сортировка поля, для которого имеются доступные сведения на верхнем или нижнем уровне, то сортируются данные на текущем и более низких уровнях. Данные на более высоких уровнях не сортируются.

  • Порядок сортировки чисел, текста и специальных символов определяется исходными данными и национальными настройками, заданными на панели управления Windows.

  • При сортировке поля в сводной таблице, основанной на источнике данных из базы данных OLAP, сортируются данные на текущем и более низких уровнях. Более высокие уровни определяют, какие элементы нижних уровней сортируются совместно. Устранение неполадок при сортировке данных из баз данных OLAP.

  • Имеется возможность выполнить сортировку по нескольким столбцам, выполняя сортировку каждого столбца по отдельности.


Сортировка данных по нескольким столбцам

Чтобы выполнить сортировку по нескольким столбцам, имеется возможность выполнить сортировку каждого столбца по отдельности. Порядок, в котором сортируются столбцы, определяет способ организации данных.

Пример данных, отсортированных по двум столбцам

В данном примере таблица упорядочивается по продавцам. Сначала сортируется столбец «Товар», чтобы товары отображались в алфавитном порядке, а затем выполняется сортировка по столбцу «Продавец».

При сортировке по нескольким столбцам следует прежде всего определить порядок сортировки столбцов, а затем выполнять сортировку так, чтобы внешний столбец сортировался последним. Например, при сортировке по двум столбцам следует определить, какой столбец будет внешним, а какой внутренним. Выполните сначала сортировку по внутреннему столбцу, а затем по внешнему. Чтобы для каждого продавца перечислять товары в алфавитном порядке, следует отсортировать сначала внутренний столбец «Товар», а затем внешний столбец «Продавец».

Сортировка данных в сводной таблице.


Изменение макета сводной таблицы

Пользователь имеет возможность изменить макет сводной таблицы для изменения способа представления результатов. Изменение макета позволяет рассчитывать и сравнивать обработанные значения для различных элементов данных, а также отображать итоговые значения для подмножества данных.

Использование областей. Макет изменяют путем перемещения полей в заранее определенные области в рабочей области сводной таблицы. Для просмотра структуры областей, если они скрыты, следует отобразить области.

После перемещения поля в область таким образом, чтобы оно закрывало надпись области, можно и далее перетаскивать поля в области. Можно также использовать для перемещения полей команды на панели инструментов.

Перемещение полей в области строк и столбцов. Когда пользователь перемещает поле в область строк, уникальные элементы данных в поле отображаются в строках сводной таблицы. Когда пользователь перемещает поле в область столбцов, уникальные элементы отображаются в столбцах.

Изменение уровня полей в строках и столбцах. Когда в сводной таблице имеются множественные поля строк и столбцов, то поля, ближайшие к обрабатываемым данным, называют внутренними полями . Остальные поля называют внешними полями. Для внутренних полей возможным является отображение большего количества данных, чем для внешних полей.

Пример внутренних и внешних полей в строке

Пользователь имеет возможность изменить способ организации полей, выполнив перемещение полей на более высокий уровень, в результате чего внутренние поля станут внешними полями, или перемещение полей на более низкий уровень.

Перемещение полей в область фильтра. Поле фильтра аналогично полю страницы в сводном отчете Microsoft Excel. Поля фильтра позволяют ограничить представление определенной частью доступных данных. Например, перемещение поля «Товар» в область фильтра позволяет отобразить в сводной таблице итоговые данные по одному товару. Перемещение поля в область фильтра.

Перемещение полей в область данных. Поля данных обеспечивают значения, которые обрабатываются в сводной таблице. Когда пользователь перемещает поле в область данных, значения поля обрабатываются в строках и столбцах.

Перемещение полей в область сведений. Для просмотра всех записей данных из источника данных сводной таблицы пользователь имеет возможность переместить поля в область сведений. Если не требуется перегруппировывать поля или изменять сводные данные, пользователь имеет возможность просмотреть данные из строк вместе со сводными данными.

Добавление и удаление данных. Макет сводной таблицы может не включать все поля, доступные в источнике данных. Если имеются другие доступные данные, можно добавить поля в макете сводной таблицы. Например, если в сводной таблице суммируются доходы от продаж, а источник данных включает также сведения о количестве проданных товаров, можно добавить поле количества как поле данных и суммировать как доходы от продаж, так и количество проданных товаров. Можно также удалить поля, которые более не требуется просматривать, из макета сводной таблицы.

Перемещение полей не влияет на фильтр. Когда фильтр применяется к полю, настройки фильтра сохраняются при перемещении поля в область данных или область фильтра. Это означает, что когда поле будет возвращено в область строк, столбцов или сведений, ранее скрытые элементы останутся скрытыми. Кроме того, если удалить поле, а затем добавить это поле в макет, ранее скрытые элементы останутся скрытыми. О наличии скрытых полей в результате применения фильтра свидетельствует синий цвет стрелки в подписи поля.

Ограничения на добавление и перемещение полей. При работе со сводной таблицей, базирующейся на источнике данных из базы данных OLAP, такой как база данных, созданная с помощью служб Microsoft SQL Server OLAP Services, перемещение полей в область сведений становится невозможным. Кроме того, некоторые поля при этом можно перемещать только в область строк, столбцов и фильтра, а перемещение полей из области данных в другие области является невозможным.


Отображение областей для перемещения и добавления полей

  • Щелкните правой кнопкой строку заголовка сводной таблицы и выберите в контекстном меню команду Области.

Примечания

  • Если строка заголовка сводной таблицы не отображается, щелкните правой кнопкой сводную таблицу и выберите в контекстном меню команду Панель свойств. Если раздел Отображение не развернут, нажмите кнопку Отображение, а затем щелкните значок Панель инструментов [image].

  • Когда в каждую из этих областей помещены поля, контуры и подписи областей не видны. Однако пользователь по-прежнему имеет возможность перемещать поля в эти области.


Перемещение поля в область строк или столбцов

  1. Установите указатель на подпись поля, которое требуется переместить. Указатель примет следующий вид Четырехсторонняя стрелка.

  2. Варианты действий:

    Чтобы сделать поле полем строк, перетаскивайте подпись поля в область строк на левой стороне сводной таблицы, пока указатель не примет следующий вид Указатель с выделенной областью строк.

    Чтобы сделать поле полем столбцов, перетаскивайте подпись поля в область столбцов на верхней стороне сводной таблицы, пока указатель не примет следующий вид Указатель с выделенной областью столбцов.

Совет. Чтобы просматривать только сводные данные для нового поля строк или столбцов, щелкните значки Минус для элементов данных в поле.


Изменение уровня поля строк или столбцов

  1. Щелкните подпись поля, которое требуется переместить на другой уровень.

  2. На панели инструментов сводной таблицы выполните одно из следующих действий.

    Чтобы переместить поле на более высокий уровень, нажмите кнопку Повышение [image].

    Чтобы переместить поле на более низкий уровень, нажмите кнопку Понижение [image].


Перемещение поля в область данных

Поля из областей строк, столбцов и фильтра можно перемещать только в область данных, если сводная таблица базируется на источнике данных, не являющемся базой данных OLAP.

  1. Отобразите области сводной таблицы.

  2. Установите указатель на подпись поля, которое требуется переместить. Указатель примет следующий вид Четырехсторонняя стрелка.

  3. Перетаскивайте поле в область данных на правой нижней стороне сводной таблицы, пока указатель не примет следующий вид Стрелка с символом «Сигма».

Примечание. Способ обработки данных в поле, перетаскиваемом в область данных, определяется типом данных поля. В полях данных, содержащих числовые значения, используется статистическая функция Sum. В полях данных, отображающих данные другого типа, используется статистическая функция Count. Имеется возможность заменить статистическую функцию для некоторых полей.


Перемещение поля в область фильтра

Когда пользователь перемещает поле фильтра, имеется возможность применить фильтр ко всей сводной таблице для отображения только тех данных, которые относятся к элементу, выбранному в раскрывающемся списке поля фильтра.

  1. Отобразите области сводной таблицы.

  2. Установите указатель на подпись поля, которое требуется переместить. Указатель примет следующий вид Четырехсторонняя стрелка.

  3. Перетаскивайте поле в область фильтра на верхней стороне сводной таблицы, пока указатель не примет следующий вид Указатель с выделенной областью фильтра.

Примечание. Если не удается переместить поле в область или из области фильтра, то, возможно, разработчик сводной таблицы ограничил доступ к фильтру.


Перемещение поля в область сведений

Невозможно переместить поля в область сведений, если разработчик сводной таблицы ограничил доступ к области сведений или если сводная таблица создана на основе источника данных из базы данных OLAP.

  1. Щелкните подпись поля, которое требуется переместить в область сведений.

  2. На панели инструментов сводной таблицы нажмите кнопку Перейти в область сведений [image].


Изменение порядка столбцов

  1. Установите указатель на подпись поля или элемента над столбцом. Указатель примет следующий вид Четырехсторонняя стрелка.

  2. Перетащите столбец в новое расположение.

Совет. Чтобы быстро изменить порядок полей, когда имеется много полей строк или столбцов, выберите поле, а затем нажмите кнопку Повышение [image] или Понижение [image] на панели инструментов сводной таблицы.


Отображение итоговых значений в сводной таблице

В сводных таблицах для отображения сводных данных используются два различных типа итоговых полей. Поля первого типа — итоговые поля — обеспечивают вывод суммарных значений в сводной таблице. Когда сводная таблица содержит итоговое поле, пользователь имеет возможность отобразить поля второго типа — промежуточные итоговые значения и общие итоги — для полей строк и столбцов.

В настоящем разделе объясняются принципы работы итоговых полей, принципы работы полей промежуточных и общих итогов, а также доступные пользователям способы изменения отображения таких полей.

Итоговые поля

Промежуточные и общие итоги

Итоговые поля

Принципы работы итоговых полей. Итоговые поля являются полями данных, которые либо извлекаются из источника данных, либо рассчитываются по другим полям в источнике данных. Например, если источник содержит поле «Продажи», в котором выводится значение каждой продажи, можно добавить итоговое поле «Сумма: Продажи», в котором для каждой категории товаров в сводной таблице рассчитывается суммарное значение, или поле «Количество: Продажи», в котором рассчитывается суммарное количество проданных единиц товара. В списке полей итоговые поля отображаются сверху под значком Итого.

Пример списка полей с итоговыми полями

Поля «Продажи» и «Единицы» доступны для в включения в сводную таблицу как итоговые поля.

В некоторых сводных таблицах значения итоговых полей могут быть заранее рассчитаны на сервере базы данных, из которой поступают исходные данные. В подобном случае становятся недоступными команды добавления новых полей, перемещения итоговых полей в область сведений и изменения функции, используемой для расчета значений в итоговом поле. Чтобы узнать, исходные данные какого типа используются в просматриваемой сводной таблице, следует обратиться к разработчику сводной таблицы.

Добавление новых итоговых полей. Если итоговые поля, доступные в списке, не обеспечивают требуемые сводные данные, а источник данных позволяет это, пользователь имеет возможность добавить новые итоговые поля в сводную таблицу. Чаще всего итоговые поля добавляют в область данных. Например, в следующей сводной таблице итоговое поле «Сумма: Продажи» добавлено в область данных для отображения сводных данных по каждому типу товаров и кварталу.

Пример итогового поля в сводной таблице

Итоговое поле «Сумма: Продажи», добавленное в область данных, отображает сводные данные по каждому типу товаров и кварталу.

Если источник данных это позволяет, можно также добавить итоговые поля в область сведений. Например, для просмотра суммы каждой отдельной продажи в предыдущем примере пользователь имеет возможность добавить итоговое поле «Сумма: Продажи» в область сведений. Необходимо отметить, что нельзя добавлять итоговые поля в области строк, столбцов или фильтра.

Статистические функции для итоговых полей. В итоговом поле допускается использование любой из четырех статистических функций — Sum, Count, Min или Max. Пользователь имеет возможность заменить статистическую функцию для отображения сводных данных другого типа, если источник данных это позволяет. Например, если поле содержит текст, то доступной для использования в этом поле является статистическая функция Count. Если позволяет тип исходных данных, пользователь имеет возможность использовать несколько статистических функций для обработки данных в одном поле. Для этого следует добавить несколько итоговых полей, в каждом из которых используется отдельная статистическая функция.

Смена места отображения подписей итоговых полей. Пользователь имеет возможность изменить ориентацию итоговых полей в сводной таблице. Отображение полей в строках приводит к тому, что имена полей отображаются в первом столбце справа от имен полей строк. Отображение полей в столбцах приводит к тому, что имена полей отображаются в первой строке под именами полей столбцов.

Возврат в начало

Промежуточные и общие итоги

Отображение промежуточных и общих итогов. Пользователь имеет возможность отобразить промежуточные итоги для любого поля строк или столбцов в сводной таблице, если таблица включает по крайней мере одно итоговое поле и несколько полей строк или несколько полей столбцов. Если для поля выбирается отображение промежуточных итогов, то общий итог тоже отбирается для отображения. Промежуточные и общие итоги отображаются для каждого итогового поля в сводной таблице там, где оно пересекает выбранное поле строки или столбца. Отображение промежуточных и общих итогов для поля.

В следующем примере промежуточные и общие итоги отображаются для обоих полей строк с помощью значений в итоговом поле «Сумма: Продажи».

Пример промежуточных и общих итогов в сводной таблице

Когда промежуточные и общие итоги отображаются для полей «Спорт» и «Квартал», в сводной таблице отображаются промежуточные итоги для поля «Квартал» и общий итог для поля «Спорт».

Перемещение и скрытие промежуточных и общих итогов. Если пользователь перемещает поле, для которого отображаются промежуточные или общие итоги, из области строк или столбцов, то промежуточные или общие итоги становятся скрытыми, но данная настройка сохраняется. Промежуточные или общие итоги снова отображаются, если вернуть поле обратно в область строк или столбцов.

Когда пользователь скрывает промежуточные и общие итоги для поля, они остаются скрытыми вне зависимости от того, куда перемещается поле, даже при удалении поля из сводной таблицы и его последующем возвращении в нее.

Изменение выравнивания относительно области сведений. Пользователь имеет возможность изменить выравнивание текста в строках промежуточных и общих итогов таким образом, чтобы текст выравнивался по левому или по правому краю или по центру. Различие в выравнивании становится видимым, когда отображаются сведения для одного или нескольких элементов в поле, в котором имеются отображаемые промежуточные или общие итоги.

Включение и исключение скрытых данных. В зависимости от исходных данных и типов данных, которые просматриваются в сводной таблице, может возникнуть необходимость включить или не включать в промежуточные и общие итоги значения для элементов данных, которые делаются скрытыми при применении фильтра. Пользователь имеет возможность указать, что во все промежуточные и общие итоги включаются или не включаются любые скрытые данные.

Возврат в начало


Добавление поля итогов в сводную таблицу

  1. Выберите поле, содержащее значения, которые требуется обработать.

  2. На панели инструментов сводной таблицы нажмите кнопку Автовычисления [image] и выберите статистическую функцию.

    Если кнопка Автовычисления недоступна, то, возможно, источник данных не позволяет добавлять итоговые поля. За дополнительными сведениями обращайтесь к разработчику сводной таблицы.

Примечания

  • Если пользователь удаляет итоговое поле, это поле остается доступным в списке полей, и существует возможность вернуть его в сводную таблицу. Чтобы удалить итоговое поле и из сводной таблицы, и из списка полей, щелкните правой кнопкой итоговое поле и выберите в контекстном меню команду Удалить.

  • Пользователь имеет возможность добавлять итоговые поля в область данных и, если источник данных это позволяет, добавлять итоговые поля в область сведений. Однако не допускается добавление таких полей в области строк, столбцов и фильтра.


Замена статистической функции для поля итогов

  1. Выберите поле итогов, для которого требуется заменить статистическую функцию.

    Инструкции

  2. На панели инструментов сводной таблицы нажмите кнопку Панель свойств [image].

  3. Если раздел Функция итогов не развернут, нажмите кнопку Функция итогов.

    Если кнопка Функция итогов не отображается, то, возможно, источник данных не позволяет заменять статистическую функцию. За дополнительными сведениями обращайтесь к разработчику сводной таблицы.

  4. В поле со списком Функция выберите статистическую функцию для поля итогов.


Статистические функции

Кнопка Автовычисления [image] на панели инструментов сводной таблицы обеспечивает следующие статистические функции для использования в полях итогов.

Sum Рассчитывает сумму значений.

Count Подсчитывает число значений. Пустые строки включаются в подсчет, а пустые значения (null) не включаются.

Min Возвращает минимальное значение в поле.

Max Возвращает максимальное значение в поле.

Примечание. Доступные для поля статистические функции определяются типом данных в поле. Например, если поле содержит даты, невозможно использовать в этом поле функцию Sum. Если поле содержит текст, невозможно использовать функции Sum, Min или Max. Для таких полей можно применять только функцию Count.


Изменение ориентации итоговых полей

Данная процедура затрагивает все итоговые поля в сводной таблице. Она не влияет на промежуточные или общие итоги. См. сведения по изменению выравнивания промежуточных и общих итогов относительно данных в полях сведений.

  1. Выделите всю сводную таблицу, щелкнув строку заголовка.

    Инструкции

  2. На панели инструментов сводной таблицы нажмите кнопку Панель свойств [image].

  3. Если раздел Итоги не развернут, нажмите кнопку Итоги.

  4. В поле со списком Ориентация итогов выберите нужный элемент.

    Выберите элемент Строка для отображения итоговых полей сверху вниз в первом столбце справа от полей строк или в крайнем левом столбце, если полей строк нет.

    Выберите элемент Столбец для отображения итоговых полей в первой строке под полями столбцов или в верхней строке, если полей столбцов нет.


Отображение промежуточных и общих итогов для поля

  1. Щелкните поле строки или столбца, для которого требуется отобразить промежуточные или общие итоги.

  2. На панели инструментов сводной таблицы нажмите кнопку Промежуточные итоги [image].

Примечания

  • См. объяснение принципов работы итоговых полей и принципов работы полей промежуточных и общих итогов в сводной таблице.

  • Промежуточные и общие итоги не отображаются для полей в области сведений (области, в которой могут отображаться все отдельные записи).

  • Когда пользователь выбирает отображение этих полей, промежуточные и общие итоговые значения отображаются для каждого поля итогов в сводной таблице. Исключить отдельные поля невозможно.

  • В расчеты промежуточных и общих итогов могут включаться или не включаться элементы данных, которые являются скрытыми в результате применения фильтра.


Изменение выравнивания элементов промежуточных и общих итоговых значений в итоговом поле

Элементы промежуточных и общих итоговых значений в итоговом поле представляются подписями, такими как «Сумма продаж» или «Количество на складе» в строке или столбце промежуточных и общих итогов. Выравнивание элементов промежуточных и общих итоговых значений задается относительно других ячеек в области данных. Чтобы увидеть результаты изменения выравнивания, следует отобразить сведения для одного или нескольких элементов в поле, для которого отображаются промежуточные и общие итоги.

  1. Выберите итоговое поле, для которого требуется изменить выравнивание промежуточных или общих итогов.

    Инструкции

  2. На панели инструментов сводной таблицы нажмите кнопку Панель свойств [image].

  3. Если раздел Подпись итогов не развернут, нажмите кнопку Подпись итогов.

  4. В поле со списком Выравнивание строк выберите нужный тип выравнивания (автоматически, по левому краю, по центру или по правому краю).


Включение и исключение скрытых данных в предварительных и общих итогах

Данная процедура затрагивает все поля предварительных и общих итогов в сводной таблице.

  1. Выделите всю сводную таблицу, щелкнув строку заголовка.

    Инструкции

  2. Нажмите кнопку Панель свойств [image] на панели инструментов сводной таблицы.

  3. Если раздел Итоги не развернут, нажмите кнопку Итоги.

  4. Выполните одно из следующих действий.

    Чтобы включить скрытые данные, установите флажок Итоги по всем элементам.

    Чтобы исключить скрытые данные, снимите флажок Итоги по всем элементам.

Примечания

  • Данная настройка затрагивает данные, скрытые из-за применения фильтра к полям строк и столбцов; данные, скрытые с помощью полей фильтра, всегда исключаются из итогов.

  • После установки флажка Итоги по всем элементам рядом с именами элементов общих и предварительных итогов появляется звездочка, показывающая, что значения включают как скрытые, так и отображаемые элементы.


Скрытие промежуточных и общих итогов для поля

  1. Щелкните поле строки или столбца, для которого требуется отобразить промежуточные или общие итоги.

  2. На панели инструментов сводной таблицы нажмите кнопку Промежуточные итоги [image] еще раз, чтобы она стала не нажатой.


Просмотр сведений для сводных данных

Отображаемое количество подробных данных определяется разработчиком сводной таблицы. Пользователь имеет возможность изменить сводную таблицу и отобразить любые данные, доступные в источнике данных. Можно также отображать все доступные исходные данные, только сводные данные высшего уровня или любое промежуточное количество исходных данных, а также просматривать исходные данные для интересующих вас элементов.

Индикаторы развертывания. Для изменения уровня отображения сведений для каждого элемента данных в поле используют индикаторы развертывания. Индикаторы развертывания имеют вид флажка Плюс или Минус рядом с элементом. Например, если имеется поле строк «Товар», включающее элементы «Мясо» и «Молоко», индикаторы развертывания будут выглядеть так:

Пример индикаторов развертывания

Если индикаторы развертывания не видны, пользователь имеет возможность отобразить их. Если отобразить индикаторы не удается, данный элемент может находиться на самом низком уровне данных, доступных в источнике данных.

Просмотр данных на нижнем уровне. Когда индикаторы развертывания включены, рядом с элементами, у которых имеются элементы на нижнем уровне, появляется значок Плюс. Имеется возможность просматривать данные на нижнем уровне для всего поля или для отдельных элементов, развертывая только нужные элементы.

Просмотр сведений. В сводной таблице, в которой все поля находятся в области сведений, отображаются все необработанные данные из строк или записей источника данных. Когда в сводной таблице имеются поля строк и столбцов, пользователь имеет возможность просматривать сводные данные или просматривать отдельные строки или записи, на основании которых рассчитывается сводное значение для элемента или ячейки. Сведения можно просматривать только в том случае, если разработчик сводной таблицы не ограничил доступ к сведениям, и только при наличии доступных сведений в источнике данных. Например, из баз данных OLAP часто предоставляются только сводные данные без подробных исходных данных.

Если исходные данные просматривать не требуется, имеется возможность скрыть область сведений.

Просмотр сводных данных на верхнем уровне. Рядом с элементами, у которых отображаются данные нижнего уровня, выводится значок Минус. Пользователь имеет возможность свернуть эти элементы, если требуется просматривать только данные на верхнем уровне.

Элементы, не имеющие данных. По умолчанию в сводной таблице не отображаются элементы, для которых значения в источнике данных отсутствуют. Например, если просматриваются продажи за каждый месяц, а продаж в апреле не было, то результат за апрель не будет отображаться в поле «Месяц». Если требуется включить элементы для всех двенадцати месяцев с пустыми ячейками для случаев отсутствия продаж, можно отобразить элементы, не имеющие данных.


Отображение индикаторов развертывания рядом с элементами

  1. Щелкните сводную таблицу.

  2. На панели инструментов сводной таблицы нажмите кнопку Панель свойств [image].

  3. Если раздел Отображение не развернут, нажмите кнопку Отображение.

  4. Нажмите кнопку Индикаторы развертывания [image].

Примечание. У элементов, не имеющих доступных данных на более низком уровне, индикаторов развертывания нет.


Развертывание элемента для отображения данных на нижнем уровне

  1. Проверьте, что отображаются индикаторы развертывания.

  2. Щелкните значок Плюс рядом с элементом, для которого требуется просматривать данные на следующем уровне снизу.

Примечания

  • Чтобы развернуть все элементы в поле, щелкните подпись поля и нажмите кнопку Развернуть [image] на панели инструментов сводной таблицы.

  • Если у элемента нет индикатора развертывания, то, возможно, элемент находится на самом нижнем уровне, доступном в источнике данных. Если источник данных это позволяет, можно отобразить исходные данные для элементов на нижнем уровне.


Отображение сведений для элемента или ячейки

  1. Выберите элемент или ячейку, для которой требуется просматривать данные сведений.

  2. На панели инструментов сводной таблицы нажмите кнопку Развернуть [image].

Примечание. Если кнопка Развернуть [image] недоступна, то, возможно, создатель сводной таблицы ограничил доступ к данным сведений. Возможно также, элемент или ячейка находится на нижнем уровне, доступном в источнике данных, или данные сведений недоступны из источника данных. Например, сводные таблицы, созданные на основе источника данных из базы данных OLAP, позволяют просматривать различные уровни данных, но в них обычно выводятся только сводные данные, а не исходные сведения.


Отображение элементов, на содержащих данные

  1. Выделите всю сводную таблицу, щелкнув строку заголовка.

    Инструкции

  2. На панели инструментов сводной таблицы нажмите кнопку Панель свойств [image].

  3. Если раздел Отобразить пустые элементы не развернут, нажмите кнопку Отобразить пустые элементы.

  4. Чтобы отобразить элементы полей строк, не содержащие данные, установите флажок Строка.

    Чтобы отобразить элементы полей столбцов, не содержащие данные, установите флажок Столбец.


Свертывание элемента для отображения данных только на верхнем уровне

  1. Проверьте, что отображаются индикаторы развертывания.

  2. Щелкните значок Минус рядом с элементом, для которого требуется просматривать данные только на верхнем уровне.


Скрытие сведений

  1. Выберите элемент данных, для которого отображаются сведения.

  2. На панели инструментов сводной таблицы нажмите кнопку Свернуть [image].

Примечание. Чтобы скрыть сведения для всех элементов в поле, выберите поле и нажмите кнопку Свернуть [image].


Добавление и удаление данных

В зависимости от способа организации данных разработчиком сводной таблицы, пользователь может иметь возможность отобразить дополнительные данные или удалить данные, которые не требуется просматривать или обрабатывать.

Первоначальный отбор данных. Разработчик сводной таблицы определяет базу данных, из которой поступают данные, и подмножество данных, доступных в источнике данных сводной таблицы. Из источника данных разработчик выбирает поля, первоначально отображаемые в сводной таблице, и определяет способ обработки данных.

Отображение дополнительных данных. Пользователь не может сменить доступный источник данных, однако при наличии в источнике полей, которые первоначально не отображаются в сводной таблице, пользователь имеет возможность добавить эти поля для отображения дополнительных данных.

Например, если в сводной таблице суммируются доходы от продаж, а источник данных включает также сведения о количестве проданных товаров, можно добавить поле количества как поле данных и суммировать как доходы от продаж, так и количество проданных товаров. Если в сводной таблице сводные данные по товарам приводятся по типам и продавцам, и имеется поле «Регион», можно добавить это поля для просмотра продаж по регионам. Если добавить поле «Регион» как поле фильтра, можно отображать в сводной таблице только данные, относящиеся к выбранному региону.

Просмотр и добавление доступных полей. Нажмите кнопку Список полей [image] для просмотра списка полей, доступных в источнике данных, и для добавления полей в области строк, столбцов, фильтра, данных и сведений сводной таблицы. В списке полей доступные поля, которые еще не отображаются в сводной таблице, представлены обычным шрифтом. Отображаемые поля представлены полужирным шрифтом. Можно осуществить прокрутку и щелкнуть значок Плюс для просмотра дополнительных полей или значок Минус для просмотра меньшего числа полей.

Если вам известно, что в исходной базе данных существуют данные, не включенные в список полей, это означает, что разработчик сводной таблицы не включил эти данные в список.

Добавление полей со сведениями. Для просмотра данных, доступных для обработки, следует использовать список полей со сведениями. Когда пользователь добавляет поле в область сведений, становится возможным просмотр исходных данных для этого поля в источнике. Имена полей становятся заголовками столбцов, а содержимое записей отображается в строках под именами столбцов.

Пример полей со сведениями

Добавление полей строк и столбцов. Поля строк и столбцов используются для представления и сравнения сводных данных. В этих полях уникальные элементы данных для полей представляются вдоль столбцов или строк. Сводные данные для каждого элемента представляются в ячейке на пересечении строки и столбца. См. инструкции по добавлению полей строк и столбцов.

Пример полей строк и столбцов

Добавление полей данных. Поля данных обеспечивают значения, которые обрабатываются в сводной таблице. Когда пользователь добавляет поле в область данных, значения поля обрабатываются в строках и столбцах. Можно также создать новые поля данных с помощью добавления итоговых полей в сводную таблицу. Итоговые поля обеспечивают сводные данные, которые используются как поля данных. Например, если источник содержит поле «Продажи», в котором выводится значение каждой продажи, можно добавить итоговое поле «Сумма продаж», в котором рассчитывается суммарное значение, или поле «Количество продаж», в котором рассчитывается суммарное количество проданных единиц товара. См. сведения об итоговых значениях в сводных таблицах.

Пример поля данных

Добавление полей фильтра. Поле фильтра аналогично полю страницы в сводном отчете Microsoft Excel. Поля фильтра позволяют ограничить данные, отображаемые в конкретном элементе данных. Когда пользователь добавляет поле фильтра, первоначально обрабатываются данные для всех элементов в этом поле. Когда пользователь выбирает значение в поле фильтра, отображаются и рассчитываются данные только для этого элемента. Например, если добавить поле «Регион» как поле фильтра, можно обрабатывать и отображать в сводной таблице только данные, относящиеся к каждому региону по отдельности. Добавление поля фильтра.

Пример поля фильтра

Перемещение полей. После добавления поля в сводную таблицу можно переместить поле в другие области. Когда пользователь перемещает поле, изменяется макет сводной таблицы и, соответственно, изменяются отображаемые данные и рассчитанные сводные значения.

Ограничения на добавление и перемещение полей. При работе со сводной таблицей, базирующейся на источнике данных из базы данных OLAP, такой как база данных, созданная с помощью служб Microsoft SQL Server OLAP Services, перемещение полей в область сведений становится невозможным. Кроме того, некоторые поля при этом можно перемещать только в область строк, столбцов и фильтра. Другие поля, имена которых перечислены под элементом Итого, можно использовать только как поля данных.

Удаление полей. Чтобы исключить поля, которые не требуется просматривать или обрабатывать, пользователь имеет возможность удалить поля из макета сводной таблицы. Исключение поля не приводит к его удалению из доступного источника данных. Удаленное поле более не отображается в сводной таблице, но остается при этом доступным в списке полей и может быть возвращено в сводную таблицу.


Добавление нового поля строк или столбцов

  1. На панели инструментов сводной таблицы нажмите кнопку Список полей [image].

  2. С помощью полос прокрутки и индикаторов развертывания Плюс и Минус найдите поле, которое требуется добавить в сводную таблицу.

  3. Выберите поле.

  4. В раскрывающемся списке в правом нижнем углу списка полей выберите один из следующих элементов.

    Чтобы добавить новое поле строк, выберите Строки.

    Чтобы добавить новое поле столбцов, выберите Столбцы.

  5. Нажмите кнопку Добавить в.

Примечание. Если кнопка Добавить в оказывается недоступной после выбора элемента Строки или Столбцы, то, возможно, выбранное поле не подходит для использования в качестве поля строк или столбцов, или создатель сводной таблицы ограничил перемещение полей в эти области. Если сводная таблица создана на основе источника данных из базы данных OLAP, то в качестве полей строк и столбцов можно использовать только поля, имена которых не перечислены под элементом Итого.


Добавление нового поля данных

По умолчанию в полях данных отображаются суммарные числовые данные, рассчитанные с помощью статистической функции Sum. В полях данных, отображающих данные другого типа, используется статистическая функция Count.

  1. На панели инструментов сводной таблицы нажмите кнопку Список полей [image].

  2. С помощью полос прокрутки и индикаторов развертывания Плюс и Минус найдите поле, которое требуется добавить в сводную таблицу.

  3. Выберите поле и в раскрывающемся списке в правом нижнем углу списка полей выберите Данные.

  4. Нажмите кнопку Добавить в.

Примечание. Если кнопка Добавить в оказывается недоступной после выбора элемента Данные, то, возможно, выбранное поле не подходит для использования в качестве поля данных. Если сводная таблица создана на основе источника данных из базы данных OLAP, то в качестве полей данных можно использовать только поля, имена которых перечислены под элементом Итого.


Добавление нового поля фильтра

Когда пользователь добавляет поле фильтра, имеется возможность применить фильтр ко всей сводной таблице для отображения только тех данных, которые относятся к элементу, выбранному в раскрывающемся списке поля фильтра.

  1. На панели инструментов сводной таблицы нажмите кнопку Список полей [image].

  2. С помощью полос прокрутки и индикаторов развертывания Плюс и Минус найдите поле, которое требуется добавить в сводную таблицу.

  3. Выберите поле и в раскрывающемся списке в правом нижнем углу списка полей выберите Фильтр.

  4. Нажмите кнопку Добавить в.

Примечание. Если кнопка Добавить в оказывается недоступной после выбора элемента Фильтр, то, возможно, выбранное поле не подходит для использования в качестве поля фильтра или создатель сводной таблицы ограничил доступ к фильтру. Если сводная таблица создана на основе источника данных из базы данных OLAP, то в качестве полей фильтра можно использовать только поля, имена которых не перечислены под элементом Итого.


Добавление нового поля сведений

  1. На панели инструментов сводной таблицы нажмите кнопку Список полей [image].

  2. С помощью полос прокрутки и индикаторов развертывания Плюс и Минус найдите поле, которое требуется добавить в сводную таблицу.

  3. Выберите поле и в раскрывающемся списке в правом нижнем углу списка полей выберите Сведения.

  4. Нажмите кнопку Добавить в.

Примечание. Если кнопка Добавить в оказывается недоступной после выбора элемента Сведения, то, возможно, создатель сводной таблицы ограничил доступ к области сведений или область сведений недоступна из источника данных. Например, если сводная таблица создана на основе источника данных из базы данных OLAP, то часто доступными являются только сводные данные.


Удаление поля

При удалении поля из макета сводной таблицы данные из этого поля более не отображаются, но поле остается доступным в списке полей. Пользователь имеет возможность вернуть это поле в сводную таблицу.

  1. Щелкните подпись поля, которое требуется удалить из сводной таблицы.

  2. Перетаскивайте поле за границы сводной таблиц, пока указатель не примет следующий вид Стрелка с красным символом X.

Примечание. Чтобы удалить итоговое поле и из сводной таблицы, и из списка полей, щелкните правой кнопкой итоговое поле и выберите в контекстном меню команду Удалить.


Обновление сводной таблицы для отображения обновленных исходных данных

  1. Щелкните сводную таблицу.

  2. На панели инструментов сводной таблицы нажмите кнопку Обновить [image].

Примечания

  • Эмблема Office Эмблема Office перестает вращаться при завершении операции обновления. Во время операции обновления сводной таблицы пользователь не может работать с ней и вносить изменения. Во время загрузки данных отменить операцию обновления невозможно. Для отмены обновления во время пересчета сводной таблицы нажмите клавишу ESC.

  • См. инструкции по устранению неполадок при обновлении сводной таблицы.


Отмена обновления сводной таблицы

  • Нажмите клавишу ESC.

Примечания

  • Пользователь имеет возможность отменить операцию обновления только во время пересчета сводной таблицы. Во время загрузки данных из источника отменить загрузку невозможно.

  • После отмены обновления сводной таблицы данные в ней временно не отображаются. Чтобы снова вывести данные, нажмите кнопку Обновить [image] на панели инструментов сводной таблицы или выполните любую операцию, которая приводит к изменению макета сводной таблицы.

  • См. инструкции по устранению неполадок при обновлении сводной таблицы.


Использование сводных таблиц в Microsoft Excel или Microsoft Word

Содержание раздела

Экспорт в интерактивный сводный отчет Excel

Копирование данных в другую программу для использования в неинтерактивном режиме

Экспорт в интерактивный сводный отчет Excel

Если имеется опыт работы со сводными отчетами Excel и требуется работать с данными в этой форме, пользователь имеет возможность экспортировать сводную таблицу в Excel. (Сводный отчет является версией Excel сводной таблицы). Сводный отчет Excel будет подключен к тому же источнику данных, поэтому в Excel будут доступны все поля и данные исходной сводной таблицы. Пользователь сможет обновлять отчет после изменения источника данных.

Подготовка к экспорту в Excel. Если сводный отчет Excel должен иметь тот же вид, что и сводная таблица в Web, то перед экспортом в сводный отчет Excel следует переместить все поля сводной таблицы из области сведений и скрыть область сведений для элементов и ячеек, чтобы эта область не отображалась.

Не экспортируемые характеристики сводной таблицы. В сводных отчетах Excel невозможно отобразить поля сведений. Все исходные данные из источника данных будут по-прежнему доступными, и все исходные поля сведений можно будет увидеть в списке на панели инструментов Excel Сводные таблицы. Сведения об отображение содержимое исходных полей для сводных отчетов Excel см. в справке Excel.

Для исходных данных некоторых типов невозможно экспортировать настройки фильтра, если применяется фильтр по выделенному. Кроме того, не экспортируются настройки фильтра для полей, которые не отображаются после экспорта. Однако пользователь имеет возможность повторно применить фильтр к этим полям в Excel.

Возврат в начало

Копирование данных в другую программу для использования в неинтерактивном режиме

Копирование в Microsoft Word или Excel. Если требуется работать со снимком текущих данных, отображаемых в сводной таблице, имеется возможность скопировать и вставить данные в Word или Excel. Когда пользователь копирует всю сводную таблицу в другую программу или копирует выделенный фрагмент данных, текст и значения сводной таблицы становятся частью документа Word или книги Excel. При этом не создается связь между источником данных сводной таблицы и копией данных в документе или книге, поэтому обновление данных, скопированных в Word или Excel, невозможно.

Копирование в другие программы. Можно также скопировать данные, отображаемые в сводной таблице, в любые другие программы, поддерживающие формат HTML, используемый сводными таблицами, такие как Microsoft FrontPage и Microsoft Access. Если скопировать данные в программу, не поддерживающую этот формат, то данные будут скопированы как неформатированный текст.

Возврат в начало


Копирование всей сводной таблицы в Microsoft Excel или Microsoft Word

Для копирования сводной таблицы и ее вставки в Excel или Word в качестве отформатированной неинтерактивной таблицы используйте следующую процедуру. Чтобы скопировать таблицу в виде интерактивного сводного отчета Excel, выполните экспорт сводной таблицы в Excel.

  1. Выделите всю сводную таблицу, щелкнув строку заголовка.

    Инструкции

  2. На панели инструментов сводной таблицы нажмите кнопку Копировать [image].

  3. Переключитесь в Excel или Word и щелкните место, где должны отображаться данные из сводной таблицы.

  4. Нажмите кнопку Вставить [image].

Примечания

  • При копировании сводной таблицы копируются только элементы форматирования и элементы данных. Связь между копией в Word или Excel и исходной базой данных не поддерживается. Копия в Word или Excel не является интерактивной и не может обновляться.

  • Можно также скопировать часть сводной таблицы в Word или Excel.


Копирование части сводной таблицы в Microsoft Excel или Microsoft Word

Для копирования выбранных в сводной таблице значений и их вставки в Excel или Word в качестве отформатированной неинтерактивной таблицы используйте следующую процедуру. Чтобы скопировать данные в виде интерактивного сводного отчета Excel, выполните экспорт сводной таблицы в Excel.

  1. Выделите фрагмент сводной таблицы, который требуется скопировать.

    Инструкции

  2. На панели инструментов сводной таблицы нажмите кнопку Копировать [image].

  3. Переключитесь в Excel или Word и щелкните место, где должны отображаться данные из сводной таблицы.

  4. Нажмите кнопку Вставить [image].

Примечания

  • При копировании фрагмента сводной таблицы копируются только элементы форматирования и значения. Связь между копией в Word или Excel и исходной базой данных не поддерживается. Копия в Word или Excel не является интерактивной и не может обновляться.

  • Имеется также возможность скопировать фрагмент сводной таблицы в другие программы, такие как Microsoft Access, в виде неформатированного текста.

  • Можно также скопировать всю сводную таблицу в Word или Excel.


Экспорт сводной таблицы из Web-обозревателя в Microsoft Excel

Данную процедуру используют для экспорта сводной таблицы, открытой в Web-обозревателе, в Excel в виде интерактивного сводного отчета. При этом поддерживается связь между сводным отчетом Excel и исходной базой данных.

Чтобы получить лучшие результаты, перед экспортом в Excel переместите все поля из области сведений и скройте сведения для элементов и ячеек.

  1. Щелкните сводную таблицу.

  2. На панели инструментов сводной таблицы нажмите кнопку Экспорт в Excel [image] для запуска или переключения в Excel и отображения данных в сводном отчете.

Примечание. Поскольку сводные отчеты в Excel не позволяют отображать некоторые элементы макета сводной таблицы и результаты расчетов, вид сводного отчета может отличаться от вида сводной таблицы в Web-обозревателе. Все поля и данные, доступные в списке полей в Web — в том числе, поля, не включенные в макет сводной таблицы — будут доступны для включения в сводный отчет Excel. Однако поля сведений не будут отображаться в отчете, а расчет значений в некоторых полях может оказаться невозможным. Для получения сведений о работе со сводными отчетами Excel и добавлении полей см. справку Excel.


Форматирование сводной таблицы для улучшения ее внешнего вида и удобства чтения

Если используется Microsoft Internet Explorer 4.01 или более поздняя версия, изменения форматирования сохраняются при выходе из сводной таблицы и возвращении в нее во время сеанса обозревателя. При выходе из Internet Explorer с последующим повторным открытием и возвращением в сводную таблицу изменения будут потеряны.

Скрытие областей. Областями называют заключенные в рамку поля, содержащие текст, такой как «Перетащите сюда поля фильтра», которые используются для изменения макета. Пользователь имеет возможность скрыть области, например, когда требуется напечатать сводную таблицу без текста, содержащегося в этих областях. При скрытии областей из представления удаляются любые области, в которых не содержатся поля. Например, если сводная таблица не имеет полей фильтра, область полей фильтра скрывается.

Форматирование подобных элементов. Форматы, применяемые к одному элементу, могут применяться к подобным элементам. Например, если изменить цвет текста для итогового значения, все итоговые значения в сводной таблице будут отформатированы с новым цветом текста. Если переместить элемент из одной области в другую, например, переместить поле данных в область строк, то к перемещенному элементу будет применено форматирование, заданное для новой области. Выбор элементов сводной таблицы для форматирования.

Задание текстовых форматов. Пользователь имеет возможность указать имя, размер и цвет шрифта, а также использовать полужирный или подчеркнутый шрифт или курсив. Эти настройки являются отдельными от настроек цвета и шрифта обозревателя, которые не влияют на сводные таблицы. Задание текстовых форматов.

Выравнивание текста в ячейках. Имеется возможность отображать значения в ячейках с выравниванием по горизонтали по левому и правому краю или по центру ячейки. Изменение выравнивания по вертикали не допускается. Выравнивание текста в ячейках. Имеется также возможность выравнивать промежуточные и общие итоговые значения относительно данных.

Задание фоновых цветов. Пользователь имеет возможность изменить цвет фона ячеек. Эти настройки являются отдельными от цветовых настроек обозревателя, которые не влияют на сводные таблицы.

Изменение числовых форматов. Пользователь имеет возможность заменить форматы отображения в поле чисел, дат и времени на любой из нескольких заранее определенных числовых форматов. Например, можно отображать число как денежное или процентное значение, а также отобразить дату в длинном формате с текстовым представлением дня недели и месяца или в кратком формате. Изменение числовых форматов не влияет на фактические значения; изменяется только способ их отображения. Изменение числовых форматов.

Дополнительные возможности форматирования. Для расширения возможностей форматирования, включая дополнительные параметры выравнивания, пользовательские числовые форматы и параметры форматирования при выводе на печать, следует экспортировать сводную таблицу в Microsoft Excel. В Excel сводная таблица будет преобразована в сводный отчет, который можно форматировать, настраивать для вывода на печать и сохранять в файле книги. Для получения дополнительных сведений о работе с отчетами сводных таблиц, см. справку Excel.


Выделение элементов сводной таблицы

В поле Выделение раздела Общие окна Панель свойств: Сводная таблица отображается текущий выделенный элемент сводной таблицы. Чтобы открыть панель свойств, нажмите кнопку Панель свойств [image] на панели инструментов сводной таблицы. См. инструкции по определению элементов сводной таблицы.

Выделение нескольких элементов. Невозможно выделить несколько элементов одновременно. Например, невозможно одновременно выделить несколько полей. Однако в большинстве случаев форматирование, примененное к одному элементу, применяется ко всем однотипным элементам сводной таблицы, как показано в следующей таблице.

Выделение Действия
Вся сводная таблица Щелкните строку заголовка.

Если строка заголовка сводной таблицы не отображается, щелкните правой кнопкой сводную таблицу и выберите в контекстном меню команду Панель свойств. Нажмите кнопку Отображение, а затем щелкните значок Строка названия [image].

Если команда Панель свойств недоступна в контекстном меню, то, возможно, разработчик сводной таблицы ограничил к ней доступ.
Ячейки данных Для выделения ячейки, щелкните ее. Для выделения группы ячеек перетаскивайте указатель.

Форматирование отдельных ячеек невозможно.
Поле строк, столбцов или фильтра Щелкните подпись поля.

При выделении поля строк или столбцов выделяются все элементы данных в поле.

Форматирование, примененное к одному полю, применяется ко всем подписям полей строк, столбцов и фильтра.
Поле сведений Щелкните подпись поля.

Если сведения отображаются для нескольких элементов так, что подпись поля отображается несколько раз, выделение одного экземпляра подписи приведет в выделению всех остальных.

Форматирование, примененное к полю сведений, затрагивает только ячейки данных одного этого поля.
Поле итогов Щелкните подпись любого поля итогов.

Чтобы отобразить подписи полей итогов, необходимо переместить по крайней мере одно поле в область строк или столбцов; может также возникнуть необходимость скрыть сведения для этих полей.

Форматирование, примененное к полю итогов, затрагивает все итоговые поля в сводной таблице и применяется только к ячейкам данных поля. Для форматирования надписей полей итогов, выберите элемент данных в поле строк или столбцов.

См. пример поля итогов.
Элемент данных в поле Щелкните подпись элемента, но будьте осторожны, чтобы не щелкнуть значок индикатора развертывания Плюс или Минус , если таковой у элемента имеется.

При выделении элемента выделяются также все данные для этого элемента.

Форматирование, примененное к одному элементу, затрагивает подписи всех элементов, подписи полей сведений, подписи промежуточных и общих итогов и подписи полей итогов в сводной таблице.
Промежуточные или общие итоги Щелкните подпись поля промежуточных или общих итогов.

При выделении подписи промежуточных или общих итогов выделяются также все данные для промежуточных или общих итогов.

Форматирование, примененное к полю промежуточных или общих итогов, затрагивает все ячейки данных для промежуточных или общих итогов в поле строк или столбцов, для которого отображаются промежуточные или общие итоги. Для форматирования надписей полей промежуточных или общих итогов выделите элемент данных в поле строк или столбцов.

См. пример полей промежуточных или общих итогов.


Задание шрифта и начертания для текста данных

Невозможно задать шрифт и начертание текста для всей сводной таблицы в одной операции. Однако в большинстве случаев форматирование, примененное для одного элемента, применяется ко всем элементам этого типа.

Чтобы задать шрифт и начертание для всех элементов во всей сводной таблице, выберите и по отдельности задайте формат для поля строк, столбцов или фильтра, для элемента данных в поле строки или столбца, а также для поля итогов. Для каждого поля строки или столбца, в котором отображаются промежуточные или общие итоги, задайте формат для итоговых полей. Если сводная таблица позволяет отображать поля сведений, отформатируйте каждое поле сведений по отдельности.

  1. Выделите элемент, который требуется отформатировать.

    Инструкции

  2. Нажмите кнопку Панель свойств [image] на панели инструментов сводной таблицы.

  3. Если раздел Формат не развернут, нажмите кнопку Формат.

  4. Выберите нужные параметры форматирования.

    Чтобы сделать текст полужирным, нажмите кнопку полужирный [image].

    Чтобы сделать текст курсивным, нажмите кнопку курсив [image].

    Чтобы сделать текст подчеркнутым, нажмите кнопку подчеркнутый [image].

    Чтобы изменить цвет текста, щелкните стрелку раскрывающегося списка Цвет шрифта, [image] а затем выберите необходимый цвет.

    Чтобы сменить шрифт, выберите имя шрифта в раскрывающемся списке Шрифт.

    Чтобы изменить размер шрифта, выберите размер в раскрывающемся списке Размер.

Примечания

  • Если выбирается цвет текста, совпадающий с цветом фона, прочитать текст будет невозможно.

  • Шрифты и размеры, доступные в раскрывающихся списках, определяются шрифтами, установленными на компьютере.


Выравнивание текста в ячейке

Невозможно задать выравнивание текста для всей сводной таблицы в одной операции. Однако в большинстве случаев выравнивание, примененное для одного элемента, применяется ко всем элементам этого типа.

Чтобы задать выравнивание текста для всех элементов во всей сводной таблице, в которой разрешено изменение выравнивания, выберите и по отдельности измените выравнивание для элемента данных в поле строк или столбцов, а также в поле итогов. Если сводная таблица позволяет отображать поля сведений, выровняйте текст в каждом поле сведений по отдельности. Невозможно изменить выравнивание по горизонтали для надписей полей строк, столбцов или фильтра.

  1. Выберите изменяемый элемент.

    Инструкции

  2. Нажмите кнопку Панель свойств [image] на панели инструментов сводной таблицы.

  3. Если раздел Формат не развернут, нажмите кнопку Формат.

  4. В поле со списком Выравнивание по горизонтали выберите требуемый тип выравнивания: по левому краю, по центру, по правому краю или автоматически. При автоматическом выравнивании числа и даты отображаются с выравниванием по правому краю, а текст с выравниванием по левому краю.

Примечание. Пользователь имеет также возможность выравнивать промежуточные и общие итоги относительно данных в области сведений.


Задание цветов фона для ячеек

Невозможно задать цвета фона для всех элементов сводной таблицы в одной операции. Однако в большинстве случаев цвет фона, заданный для одного элемента, применяется ко всем элементам этого типа. Например, поля строк, столбцов и фильтра принадлежат к одному типу; поэтому при задании цвета для подписей полей фильтра тот же цвет приобретают подписи строк и столбцов.

Чтобы задать цвета фона для всех элементов во всей сводной таблице, выберите и по отдельности задайте цвет фона для всей сводной таблицы, для полей строк, столбцов или фильтра, для элемента данных в поле строки или столбца, а также для поля итогов. Для каждого поля строки или столбца, в котором отображаются промежуточные или общие итоги, задайте цвет фона для итоговых полей. Если сводная таблица позволяет отображать поля сведений, задайте цвет фона для каждого поля сведений по отдельности. Невозможно изменить цвет фона для областей, в которые перетаскиваются поля.

  1. Выберите изменяемый элемент.

    Инструкции

  2. Нажмите кнопку Панель свойств [image] на панели инструментов сводной таблицы.

  3. Если раздел Формат не развернут, нажмите кнопку Формат.

  4. Щелкните стрелку раскрытия палитры Цвет фона [image] и выберите необходимый цвет.

Примечание. Если выбирается цвет фона, совпадающий с цветом текста, прочитать текст будет невозможно.


Изменений подписей и имен

Пользователь имеет возможность изменить заголовок сводной таблицы, имена полей, имена элементов в полях и имена итоговых полей. Внесенные изменения не затрагивают исходные данные.

  1. Выберите подпись или имя для изменения.

    Инструкции

  2. Нажмите кнопку Панель свойств [image] на панели инструментов сводной таблицы.

  3. Если раздел Подписи не развернут, нажмите кнопку Подписи.

  4. Введите новое имя в поле Подпись.

Примечание. Чтобы изменить текст строки заголовка, щелкните строку заголовка и введите новое имя в поле Название сводной таблицы в разделе Формат панели свойств.


Изменение ширины столбца

  1. Установите указатель на правую границу поля. Указатель примет следующий вид Указатель с горизонтальной двухсторонней стрелкой.

  2. Выполните одно из следующих действий.

    Перетащите границу до нужной ширины столбца.

    Чтобы установить ширину столбца по содержимому, дважды щелкните границу столбца.


Изменение числовых форматов

Пользователь имеет возможность изменить формат чисел в полях сведений и полях итогов. Если поле, для которого требуется изменить числовой формат, находится в области строк, столбцов или фильтра — и перемещение полей в сводной таблице разрешено — можно временно переместить поле в область сведений, изменить формат, а затем переместить поле обратно.

  1. Выберите поле сведений или итоговое поле, для которого требуется изменить числовой формат.

  2. Нажмите кнопку Панель свойств [image] на панели инструментов сводной таблицы.

  3. Если раздел Формат не развернут, нажмите кнопку Формат.

  4. Выберите требуемый формат в списке Числовой формат.

    См. сведения о доступных числовых форматах.


Числовые форматы

Настойки, задаваемые в окне Свойства: Язык и стандарты панели управления Windows, определяют форматы отображения чисел, денежных значений, дат и времени. Например, эти настройки определяют отображение года двумя или четырьмя цифрами. См. описание форматов в справке Windows.

Разработчик сводной таблицы мог определить для данных пользовательские числовые форматы. Создать пользовательские числовые форматы в обозревателе невозможно. Следующие форматы доступны в поле со списком Формат чисел в разделе Формат окна Панель свойств: сводная таблица.

Формат | Описание
Общий числовой | Число отображается с выравниванием по правому краю без разделителя групп разрядов, перед отрицательным числом ставится минус. Отображается до 11 цифр или 10 цифр и десятичный разделитель, с округлением дробной части. Числа, имеющие больше 11 разрядов в целой части, отображаются в экспоненциальном формате.
Полный формат даты | Отображается дата и/или время с преобразованием из числового формата. Например: 8/31/99 05:54 AM. Дробная часть исходного числа представляет значение времени. Если число не имеет дробной части, выводится только дата. Если число имеет только дробную часть, выводится только время.
Длинный формат даты | Отображение календарной даты с использованием длинного формата даты, заданного в панели управления Windows. Например: 25 января 2001 г.
Средний формат даты | Отображение календарной даты с разделителем месяца и числа в соответствии с национальными стандартами, принятыми в Windows. Для года отводится две цифры. Например: 25 янв 01.
Краткий формат даты | Отображение календарной даты с использованием краткого формата даты, заданного в панели управления Windows. Например: 1/25/01.
Длинный формат времени | Отображение времени соответственно длинному формату даты, заданному в панели управления Windows. Например: 8:45:36.
Средний формат времени | Отображение времени суток в 12-часовом формате с индикаторами AM и PM, но без указания секунд. Например: 8:45 PM.
Краткий формат времени | Отображение времени суток в 24-часовом формате без указания секунд. Например: 20:45.
Денежный формат | Отображение числа соответственно формату денежных значений, заданному в панели управления Windows, с разделителем групп разрядов и двумя десятичными знаками. Например, в настройке по умолчанию для России, 2 532,75р.
Евро | Отображение числа как денежного значения в евро с разделителями групп разрядов и двумя десятичными знаками. Символ евро размещается перед или после числа, согласно национальному стандарту для денежных значений, установленному в панели управления Windows. Например, в соответствии с национальным стандартом для России: 12,35 [image] .
Фиксированный | Отображение числа с двумя десятичными знаками. Например: 68,30.
Стандартный | Отображение числа с разделителями групп разрядов и двумя десятичными знаками. Разделитель разрядов определяется в панели управления Windows. Например, с использованием пробела 1 800 000.00.
Процентный | Отображение числа с умножением на 100, двумя десятичными знаками и знаком процента. Например: значение 0,8914 отображается как 89,14%.
Экспоненциальный | Отображение числа в экспоненциальном представлении. Например: 1,25E+10.
Да/Нет | Если число равняется 0, отображается «Нет», а во всех остальных случаях — «Да».
Истина/ложь | Если число равняется 0, отображается «Ложь», а во всех остальных случаях — «Истина».
Вкл./выкл. | Если число равняется 0, отображается «Выкл.», а во всех остальных случаях — «Вкл.».


Скрытие областей

Когда области скрыты и сводная таблица не имеет полей строк, столбцов, данных или фильтра, невозможно перетаскивать поля в эти области. Однако пользователь по-прежнему имеет возможность добавлять и перемещать поля с помощью кнопок панели инструментов сводной таблицы.

  1. На панели инструментов сводной таблицы нажмите кнопку Панель свойств [image].

  2. Если раздел Отображение не развернут, нажмите кнопку Отображение.

  3. Нажмите кнопку Области [image] , чтобы эта кнопка стала не нажатой.


Устранение неполадок в сводных таблицах

Список вопросов

Обновление

Невозможно обновить сводную таблицу по данным из источника.

После обновления сводной таблицы изменяются другие сводные таблицы на Web-странице.

Сбой запроса в сводной таблице.

Фильтры и сортировка

Команды фильтров не работают.

Не удается применить фильтр к данным так, как требуется.

Данные в поле сортируются неправильно.

Перемещение полей

Команды перемещения полей не работают.

Не удается добавить или переместить поле.

Когда я изменяю макет, данные долго не появляются.

Исчезла Панель свойств: Сводная таблица или список полей.

Данные

Невозможно выделить нужные данные.

Невозможно отобразить сведения.

Данные трудно читать.

Когда я перехожу на экран вниз, не виден выделенный блок.

Поля присутствуют, но отсутствуют данные.

Отсутствуют данные при печати сводной таблицы.

Отсутствуют данные после копирования сводной таблицы в Microsoft Excel или Word.

В ячейке вместо числа отображаются символы #####.

Диаграмма, созданная по сводной таблице, пуста или не содержит данных.

При нажатии кнопки Правка в Web-обозревателе Web-страница открывается не в том приложении.

Почему рядом с итогами в сводной таблице появляются звездочки?


В ячейке вместо числа отображаются символы #####.

Когда ячейка является слишком узкой для отображения числа, в сводной таблице вместо числа отображаются символы номера. Устранить эту неполадку можно несколькими способами.

  • Увеличьте ширину столбца, чтобы число умещалось в ячейке.

  • Выберите шрифт с меньшим размером, если расширять столбец нежелательно.

  • Измените числовой формат, чтобы для отображения чисел требовалось меньше места.


Диаграмма, созданная по сводной таблице, пуста или не содержит данных.

Добавьте поля итогов. Для диаграммы, отображающей данные сводной таблицы, необходимо добавить не менее одного итогового поля в сводную таблицу.

Переместите поля в области строк и столбцов. Поля строк и столбцов сводной таблицы образуют данные рядов и категорий на диаграмме. Например, если все отображаемые поля находятся только в области сведений, на диаграмме не будет категорий и рядов. Из области сведений или окна Список полей сводной таблицы перетащите не менее одного поля в область строк или область столбцов.


При нажатии кнопки «Правка» в обозревателе Web-страница открывается не той программой.

Вызов той или иной программы нажатием кнопки Правка в Web-обозревателе зависит от того, как была опубликована открываемая Web-страница.

Если при нажатии кнопки Правка в Web-обозревателе вызывается неверная программа, закройте ее, запустите нужную программу и откройте в ней Web-страницу.


Данные в поле сортируются неправильно.

Возможно, отсутствуют уровни из поля измерений. При сортировке поля в сводной таблице, основанной на источнике данных из базы данных OLAP, сортируются данные на текущем и более низких уровнях. Более высокие уровни определяют, какие элементы нижних уровней сортируются совместно. Если один или несколько уровней в данном измерении оказываются скрытыми во время сортировки данных в поле нижнего уровня, данные сортируются так, как будто недостающие уровни присутствуют.

Например, если поле измерений включает уровни «Страна», «Регион» и «Город», а уровень «Регион» не отображается в сводной таблице, то при сортировке элементов в поле «Город» элементы сортируются по отдельности для каждого региона, даже когда данные о регионах не отображаются. В результате, если страна подразделяется на Северный и Южный регионы, то элементы поля «Город», относящиеся к Северному региону, сортируются совместно, равно как и элементы, относящиеся к Южному региону. Таким образом, при сортировке не будут объединены все города для отдельной страны, как могло бы показаться при скрытом уровне «Регион».

Включение всех уровней перед сортировкой. Чтобы понять, как осуществляется сортировка данных, удалите все уровни для конкретного измерения, верните поле измерения в сводную таблицу, а затем снова отобразите уровни таким образом, чтобы ни один уровень не отсутствовал над уровнем, для которого выполняется сортировка.


Отсутствуют данные после копирования сводной таблицы в Excel или Word.

Когда данные из сводной таблицы копируются в буфер обмена и вставляются в Microsoft Excel или Microsoft Word, копируются только видимые строки и столбцы. Данные, скрытые разработчиком или в результате применения фильтра, не копируются.

Копирование всех данных. Перед копированием отключите фильтр для отображения всех данных в сводной таблице и отобразите данные в области сведений, которые требуется скопировать.

Экспорт в Microsoft Excel. Во избежание необходимости предварительно отображать все данные, можно не копировать, а экспортировать сводную таблицу. При экспорте копии сводной таблицы в Excel автоматически включаются все данные с применением того же фильтра. Пользователь получает тот же доступ к дополнительным полям в источнике данных, что и в сводной таблице. Имеется также возможность изменить фильтр в Excel. Из Excel можно затем скопировать данные в Word или другие программы. Дополнительные сведения см. в справке Excel.


Отсутствуют данные при печати сводной таблицы.

Проверьте, что данные не являются скрытыми. Если требуется напечатать данные, которые скрыты в результате применения фильтра, следует отобразить данные перед выводом на печать. Чтобы напечатать данные из области сведений, следует отобразить сведения перед выводом на печать.

Проверьте, не отображается ли сводная таблица в фиксированной области. Сводные таблицы могут расширяться или сжиматься на Web-странице для использования пространства, необходимого для отображения данных, или могут отображаться в области с фиксированными размерами, в зависимости от того, какой макет был задан для сводной таблицы ее разработчиком. Если сводная таблица отображается в фиксированной области, то печатаются только текущие отображаемые данные.

Прокрутите всю сводную таблицу. При печати сводной таблицы, которая расширяется и сжимается по мере необходимости для отображения данных, печатаются только данные, на которые выполнена прокрутка в текущем сеансе обозревателя. С помощью полос прокрутки выполните переход в начало, а затем в конец сводной таблицы перед печатью Web-страницы.

Печатайте из Microsoft Excel. Чтобы получить больше возможностей управления печатью данных, в том числе возможность полностью печатать длинную сводную таблицу и устанавливать разрывы страниц, можно экспортировать копию сводной таблицы в Microsoft Excel. Для получения сведений о печати из Excel см. справку Excel.


Не удается добавить или переместить поле.

Возможно, поле уже отображается. Невозможно отобразить одно и то же поле в нескольких областях. См. сведения об изменении макета сводной таблицы.

Источник данных может ограничивать использование полей. Источники данных из баз данных OLAP (On-Line Analytical Processing) обеспечивают наборы полей для различных уровней сведений. В этих наборах пользователь имеет возможность скрывать уровни сведений, но не может разделять поля в наборе для их отображения в других областях. Чтобы узнать, является ли источник данных сводной таблицы источником из базы данных OLAP, обращайтесь к разработчику сводной таблицы.

Перемещение полей может быть ограничено. Разработчик сводной таблицы мог отключить возможность перемещать поля. За дополнительными сведениями обращайтесь к разработчику сводной таблицы.

Экспорт в Microsoft Excel. Если требуется перемещать поля, можно экспортировать копию сводной таблицы в Excel. В сводном отчете Excel перемещение полей не ограничивается и допускается одновременное отображение поля в области фильтра (страницы) и в области данных. Однако в сводных отчетах Excel действую те же ограничения, если используется источник данных OLAP. Сведения о перемещении полей в сводном отчете и информацию об источниках данных OLAP см. в справке Excel.


Невозможно отобразить сведения.

Индикаторы развертывания могут быть отключены. Если отсутствуют индикаторы развертывания Плюс рядом с элементами данных в полях строк и столбцов, проверьте, что индикаторы развертывания включены.

Дополнительные сведения могут быть недоступны. Когда элемент данных находится на нижнем уровне сведений, доступных из источника данных, рядом с элементом не появляется индикатор развертывания Плюс даже в том случае, когда пользователь включает индикаторы развертывания.

Исходные данные могут не включать сведения. Некоторые типы источников данных, такие как источники данных из баз данных OLAP (On-Line Analytical Processing), не имеют исходных записей (сведений), доступных для отображения. Чтобы узнать, является ли источник данных сводной таблицы источником из базы данных OLAP, а также выяснить объем доступных сведений, обращайтесь к разработчику сводной таблицы.

Отображение сведений может быть ограничено. Если команды включения индикаторов развертывания и отображения сведений недоступны, то , возможно, отображение сведений ограничено разработчиком сводной таблицы. За дополнительной информацией обращайтесь к разработчику сводной таблицы. Если требуется просмотреть данные сведений, можно экспортировать копию сводной таблицы в Microsoft Excel. В сводном отчете Excel отображение сведений не ограничивается. Информацию об отображении сведений в сводном отчете см. в справке Excel.


Не удается применить фильтр к данным так, как требуется.

Ограничения на фильтры. Возможности фильтров, доступные в листах Microsoft Excel и сводных отчетах Excel, в том числе пользовательский автофильтр и отбор десяти старших значений, недоступны в сводных таблицах. Также не поддерживается фильтр по части значения в ячейке; это средство является доступным в формах и объектах в режиме таблицы в Microsoft Access. См. сведения о возможностях фильтров в сводных таблицах.

Экспорт в Excel. Чтобы использовать возможности фильтров Excel, экспортируйте копию сводной таблице в Excel.

Просмотр данных в Access. Если требуется применять фильтр по части значений в ячейках, обратитесь к разработчику сводной таблицы, чтобы узнать, откуда берется источник данных. Возможно, удастся просмотреть данные непосредственно в форме или объекте в режиме таблицы в Access, где такие фильтры поддерживаются.


Команды перемещения полей не работают.

Перемещение полей может быть ограничено. Разработчик сводной таблицы мог отключить возможность перемещать поля. За дополнительными сведениями обращайтесь к разработчику сводной таблицы.

Экспорт в Microsoft Excel. Если требуется перемещать поля, можно экспортировать копию сводной таблицы в Excel. В сводном отчете Excel перемещение полей не ограничивается. Сведения о перемещении полей см. в справке Excel.


Данные трудно читать.

Используйте крупный шрифт. Настройки шрифта в обозревателе не влияют на размер текста в сводной таблице. Чтобы увеличить мелкий и трудный для чтения шрифт, можно изменить размеры шрифтов для элементов сводной таблицы.

Используйте контрастные цвета. Цветовые настройки в обозревателе не влияют на цвета в сводной таблице. Чтобы цвет лучше выделялся на фоне, можно задать цвет текста, а затем задать контрастный цвет фона для каждого элемента сводной таблицы.

Экспорт в Microsoft Excel. Когда пользователь экспортирует копию сводной таблицы в Excel, можно увеличить масштаб отображения данных. Сведения о работе со сводными отчетами Excel см. в справке Excel.


Поля присутствуют, но отсутствуют данные.

Вы отменили расчет сводной таблицы или расчет был прерван до его завершения. Чтобы отобразить данные, нажмите кнопку Обновить [image] на панели инструментов сводной таблицы.

Совет. Перед обновлением данных можно изменить макет или применить фильтр к элементам в полях.


Команды фильтров не работают.

Применение фильтров может быть ограничено. Разработчик сводной таблицы мог отключить возможность изменять фильтры. За дополнительными сведениями обращайтесь к разработчику сводной таблицы.

Экспорт в Microsoft Excel Если требуется применить фильтр к данным, можно экспортировать копию сводной таблицы в Excel. В сводном отчете Excel применение фильтров не ограничивается. Сведения о применение фильтров к данным см. в справке Excel.


Невозможно обновить сводную таблицу по данным из источника.

Некоторые сводные таблицы не могут обновляться. Сводные таблицы, опубликованные из листов Microsoft Excel, Web-запросов Excel и текстовых запросов Excel не могут обновляться. В подобных случаях необходимо обновить книгу Excel и снова опубликовать сводную таблицу. Обратитесь к разработчику сводной таблицы, чтобы узнать, какой тип источника данных используется и можно ли снова опубликовать обновленную версию сводной таблицы, если источник принадлежит к одному из перечисленных выше типов.

Исходная база данных может быть недоступна. Если сводная таблица создана на основе источника данных из сетевой базы данных, то сервер базы данных может оказаться недоступным или у вас может отсутствовать право на доступ к серверу. Например, возможно, отсутствует подключение к сети или для подключения к серверу требуются привилегии доступа или пароль. Обратитесь к разработчику сводной таблицы, чтобы узнать, какой тип источника данных и какую базу данных использует сводная таблица. Если возникают затруднения при подключении к серверу, обращайтесь к администратору базы данных.

Microsoft Office может не поддерживать исходную базу данных. Если источник данных находится в базе данных, которая не поддерживается Microsoft Office, может потребоваться установка совместимого с Office программного обеспечения от поставщика базы данных. Обратитесь к разработчику сводной таблицы, чтобы узнать, поддерживает ли Office исходную базу данных и какое программное обеспечение использовал разработчик при создании сводной таблицы, если база данных не поддерживается.

Исходная база данных могла быть изменена. В некоторых случаях изменения способа организации данных в базе данных на сервере могут сделать невозможным обновление сводной таблицы. Например, если источник данных находится в базе данных OLAP (On-Line Analytical Processing) и при реорганизации базы данных изменяются доступные данные, необходимо создавать новую сводную таблицу. За дополнительными сведениями обращайтесь к разработчику сводной таблицы.


Исчезла панель свойств «Сводная таблица» или список полей.

Когда пользователь выбирает элемент управления на Web-странице, отличный от элемента управления Microsoft Office Web Components, или после свертывания и последующего восстановления окна обозревателя панель элементов и список полей оказываются скрытыми.

Чтобы снова отобразить панель элементов или список полей, щелкните сводную таблицу для ее активизации.


Сбой запроса в сводной таблице.

Исходная база данных может быть недоступна. Если сводная таблица создана на основе источника данных из сетевой базы данных, то сервер базы данных может оказаться недоступным. Возможно также прерывание подключения к сети. Обратитесь к администратору сервера или администратору сети, чтобы проверить доступность сервера или сети.

Возможно, отсутствуют необходимые разрешения. Вы можете подключаться к базе данных, но не иметь разрешений на запуск запроса для сводной таблицы. Проверьте имеющиеся у вас разрешения у администратора базы данных.

Проверьте фильтр в сводной таблице. В некоторых случаях, когда в сводной таблице применяется фильтр для отображения конкретных элементов, изменения в исходной базе данных могут привести к удалению таких элементов, что приводит к сбою запроса. В этом случае можно отключить фильтр для отображения всех элементов, а затем нажать кнопку Обновить [image] на панели инструментов сводной таблицы для запуска запроса.


Когда я изменяю макет, данные долго не появляются.

Если пересчет сводной таблицы занимает много времени, можно внести в макет сразу несколько изменений, а затем загрузить данные после окончания изменений макета.

  1. При появлении сообщения «Вычисление сводной таблицы» нажмите клавишу ESC для отмены расчета. В сводной таблице после этого будут отображаться только имена полей.

  2. Измените макет, добавляя и перемещая все необходимые поля.

  3. Чтобы загрузить и пересчитать данные для нового макета, нажмите кнопку Обновить [image] на панели инструментов сводной таблицы.


Когда я перехожу на экран вниз, не виден выделенный блок.

Пользуйтесь полосами прокрутки в обозревателе. Создатель сводной таблицы разработал ее таким образом, чтобы при изменении макета таблица расширялась или сжималась для использования на Web-странице места, достаточного для отображения данных. Чтобы увидеть дополнительные данные, пользуйтесь полосами прокрутки в обозревателе для прокрутки всей Web-страницы.


После обновления сводной таблицы изменяются другие сводные таблицы на Web-странице.

Просматриваемая Web-страница была разработана так, чтобы при обновлении одной сводной таблицы обновлялись и другие сводные таблицы.

Для получения сведений о способах связывания сводных таблиц обращайтесь к создателю Web-страницы.


Почему рядом с итогами в сводной таблице появляются звездочки?

Звездочки рядом с итогами появляются в следующих случаях.

  • В итоги включены любые скрытые элементы. Когда выбран параметр включения всех элементов в итоги, рядом с итогами появляются звездочки, показывающие, что наряду с отображаемыми элементами в итоги включаются скрытые значения.

  • Сводная таблица была опубликована из Microsoft Excel. В сводных отчетах Excel созданных по источнику данных из базы данных OLAP (On-Line Analytical Processing), в расчеты промежуточных и общих итогов всегда включаются значения всех элементов в поле, как отображаемых, так и скрытых. Excel дает возможность отключить отображение звездочек. Однако, если сохранить или опубликовать сводный отчет Excel как сводную таблицу для Web, звездочки будут отображаться в сводной таблице, даже если они были отключены в Excel.

Можно изменить способ расчета итогов. В сводной таблице, независимо от того, создана ли она на основе источника данных из базы данных OLAP, можно исключить из промежуточных и общих итогов скрытые данные с помощью фильтра. Для этого следует выбрать параметр включения только отображаемых данных. Выбор этого параметра приводит также к отключению отображения звездочек.


Выделение всей сводной таблицы

  • Щелкните строку заголовка.

    Если строка заголовка сводной таблицы не отображается, щелкните правой кнопкой сводную таблицу и выберите в контекстном меню команду Панель свойств. Если раздел Отображение не развернут, нажмите кнопку Отображение, а затем щелкните значок Строка названия [image].

Примечание. Если команда Панель свойств недоступна в контекстном меню, то, возможно, разработчик сводной таблицы ограничил к ней доступ.