Извлечение внешних данных с помощью Microsoft Query

Для отображения данного раздела выберите рисунок.

Для отображения данного раздела выберите рисунок


Получение справочных сведений о Microsoft Query

  • В меню Справка приложения Microsoft Query выберите пункт О программе.

    Отобразится диалоговое окно О программе, содержащее сведения о программе, в частности, номер версии.


Отобразить, скрыть или отключить помощника

  • Выберите Справка по Microsoft Query в меню Справка.

Примечание. Для отключения помощника щелкните помощника, нажмите кнопку Параметры, а затем снимите флажок Использовать помощника. Тем не менее остается возможность получения справки без помощника.


Перемещение помощника по Office и его окна

  • Используя мышь, перетащите окно помощника в нужное место на экране.


Выбор помощника

  1. Щелкните помощника.

  2. Нажмите кнопку Параметры.

  3. Перейдите на вкладку Коллекция и используйте кнопки Назад и Далее для просмотра имеющихся персонажей.


Включение и отключение звука помощника

Для того, чтобы услышать звук при использовании помощника, установите звуковую карту и включите помощника.

  1. Щелкните помощника.

  2. Нажмите кнопку Параметры.

  3. На вкладке Параметры установите или снимите флажок звуковое сопровождение.


Разрешение вопросов: помощник

Инструкции

Помощник отвлекает от работы

Помощник не находит нужную справку

Отсутствует окно помощника


Отображение сообщений без помощника

Когда помощник отключен, сообщения автоматически отображаются без помощника. Чтобы произвести данную процедуру, надо включить помощника .

  1. Щелкните помощника.

  2. Нажмите кнопку Параметры.

  3. На вкладке Параметры снимите флажок отображать сообщения помощника.


Получение справки без помощника

Чтобы не пользоваться помощником для получения справки необходимо отключить помощника.

  1. Выберите Справка по Microsoft Query в меню Справка.

    Если вкладки Содержание, Мастер ответов и Указатель недоступны, то нажмите кнопку Показать [image].

  2. В окне «Справка» выполните одно из следующих действий:

    Для просмотра оглавления справочной системы перейдите на вкладку Содержание.

    Для ввода вопроса с клавиатуры о программе Microsoft Office перейдите на вкладку Мастер ответов.

    Для поиска конкретных слов и словосочетаний или выбора из списка ключевых слов перейдите на вкладку Указатель. Добавляя или удаляя ключевые слова ограничьте поиск и список найденных тем, чтобы только актуальные темы и ключевые слова остались в списке.


Комбинации клавиш в Microsoft Query

Инструкции

Перемещение по областям Microsoft Query с использованием клавиатуры

Выделение данных и условий с использованием клавиатуры

Изменение данных и условий с использованием клавиатуры

Функциональные клавиши Microsoft Query

Использование помощника по Office

Используйте сочетание клавиш в мастере создания куба


Перемещение по областям Microsoft Query с использованием клавиатуры

Перемещение в области таблиц

Клавиши | Действие
TAB | Перемещение между таблицами
СТРЕЛКА ВВЕРХ или СТРЕЛКА ВНИЗ | Перемещение к полю и выделение имен полей в таблице
SHIFT+СТРЕЛКА ВВЕРХ или SHIFT+СТРЕЛКА ВНИЗ | Выбор смежных полей в таблице или отмены выбора

Переходы между столбцами и строками в области данных и в области условий

Клавиши | Действие
F5, введите номер записи в поле Запись и нажмите клавишу ENTER | Переход к определенной записи (строке) в области данных
TAB, ENTER или СТРЕЛКА ВПРАВО (из выделенной ячейки) | Переход к следующему столбцу в области данных
SHIFT+TAB, SHIFT+ENTER или СТРЕЛКА ВЛЕВО (из выделенной ячейки) | Переход к предыдущему столбцу в текущей строке или к последнему полю предыдущей записи
END | Переход к последнему столбцу текущей строки
CTRL+END | Переход к последнему столбцу последней строки
HOME | Переход к первому столбцу текущей строки
CTRL+HOME | Переход к первому столбцу первой строки
СТРЕЛКА ВНИЗ | Переход к текущему столбцу следующей строки
CTRL+СТРЕЛКА ВНИЗ | Переход к текущему столбцу последней строки
СТРЕЛКА ВВЕРХ | Переход к текущему столбцу предыдущей строки
CTRL+СТРЕЛКА ВВЕРХ | Переход к текущему столбцу первой строки

Перемещение точки вставки в ячейке области данных или области условий

Клавиши | Действие
F2 | Отмена выделения и отображение точки вставки в выделенной ячейке
СТРЕЛКА ВПРАВО | Перемещение на один символ вправо
CTRL+СТРЕЛКА ВПРАВО | Перемещение на одно слово вправо
СТРЕЛКА ВЛЕВО | Перемещение на один символ влево
CTRL+СТРЕЛКА ВЛЕВО | Перемещение на одно слово влево
END | Перемещение к концу текущей строки в однострочных или многострочных значениях
CTRL+END | Перемещение к концу значения в многострочных значениях
HOME | Перемещение к началу текущей строки в однострочных или многострочных значениях
CTRL+HOME | Перемещение к началу значения в многострочных значениях

Переходы между экранами области данных или области условий

Клавиши | Действие
PAGE DOWN | Переход на один экран вниз
PAGE UP | Переход на один экран вверх
CTRL+PAGE DOWN | Переход на один экран вправо
CTRL+PAGE UP | Переход на один экран влево


Выделение данных и условий с использованием клавиатуры

Выделение значений в столбце

Клавиши | Действие
F2 | Выделение текущего значения или отмена выделения и отображение точки вставки
TAB, ENTER или СТРЕЛКА ВПРАВО (из выделенной ячейки) | Выделение значения в следующем столбце
SHIFT+HOME | Выделение значения от точки вставки до начала строки
SHIFT+END | Выделение значения от точки вставки до конца строки
SHIFT+СТРЕЛКА ВПРАВО | Расширение выделения или отмена выделения на один символ вправо
CTRL+SHIFT+СТРЕЛКА ВПРАВО | Расширение выделения или отмена выделения на одно слово вправо
SHIFT+СТРЕЛКА ВЛЕВО | Расширение выделения или отмена выделения на один символ влево
CTRL+SHIFT+СТРЕЛКА ВЛЕВО | Расширение выделения или отмена выделения на одно слово влево

Выделение строки

Клавиши | Действие
SHIFT+ПРОБЕЛ | Выделение текущей строки
СТРЕЛКА ВНИЗ | Выделение следующей строки, если выделена текущая строка
СТРЕЛКА ВВЕРХ | Выделение предыдущей строки, если выделена текущая строка
SHIFT+СТРЕЛКА ВНИЗ | Расширение выделения или отмена выделения на одну строку вниз
SHIFT+СТРЕЛКА ВВЕРХ | Расширение выделения или отмена выделения на одну строку вверх
SHIFT+PAGE DOWN | Расширение выделения на один экран вниз
SHIFT+PAGE UP | Расширение выделения на один экран вверх
CTRL+SHIFT+ПРОБЕЛ | Выделение всей таблицы результатов

Выделение столбца

Клавиши | Действие
CTRL+ПРОБЕЛ | Выделение текущего столбца
СТРЕЛКА ВПРАВО | Выделение столбца, расположенного справа от выделенного текущего столбца
СТРЕЛКА ВЛЕВО | Выделение столбца, расположенного слева от выделенного текущего столбца
SHIFT+СТРЕЛКА ВЛЕВО | Расширение или отмена выделения на один столбец влево
SHIFT+СТРЕЛКА ВПРАВО | Расширение или отмена выделения на один столбец вправо
CTRL+SHIFT+PAGE DOWN | Расширение выделения на один экран вправо
CTRL+SHIFT+PAGE UP | Расширение выделения на один экран влево


Изменение данных и условий с использованием клавиатуры

Копирование, вырезание, вставка или удаление

Клавиши | Действие
CTRL+C | Копирование текущего выделения в буфер обмена
CTRL+V | Вставка содержимого буфера обмена в место, определяемое точкой вставки
CTRL+X | Вырезание текущего выделения и копирование его в буфер обмена
BACKSPACE | Удаление текущего выделения или символа, расположенного слева от точки вставки
DEL | Удаление текущего выделения или символа, расположенного справа от точки вставки

Область ввода в области данных

Клавиши | Действие
SHIFT+F2 | Открытие диалогового окна Область ввода для удобства ввода значений в малые области ввода области данных


Функциональные клавиши Microsoft Query

Клавиши | Действие
F1 | Вызов справочной системы
SHIFT+F1, после чего нажмите клавишу ENTER | Получение контекстной справки по выделенному элементу
F2 | Выделение или отмена выделения текущего значения
ALT+SHIFT+F2 или SHIFT+F12 | Сохранение запроса с помощью команды Сохранить
ALT+F2 или F12 | Сохранение запроса с помощью команды Сохранить как
SHIFT+F2 | Открытие диалогового окна Область ввода для удобства ввода значений в малые области ввода области данных
CTRL+F4 | Закрытие активного запроса
ALT+F4 | Выход из Microsoft Query
F5, введите номер записи в поле Запись и нажмите клавишу ENTER | Переход к определенной записи (строке) области данных
F6 | Переход к следующей области в окне запроса
SHIFT+F6 | Переход к предыдущей области в окне запроса
CTRL+F6 | Переход к следующему открытому окну запроса
CTRL+SHIFT+F6 | Переход к предыдущему открытому окну запроса
F9 | Выполнение открытого запроса


Используйте сочетание клавиш в мастере создания куба

Воспользуйтесь этими клавишами для завершения второго шага мастера создания куба.

Переместите поле из списка исходных полей в окно размерностей

  1. Для выбора списка исходных полей нажмите клавишу TAB.

  2. Для выбора перемещаемого поля нажмите клавишу СТРЕЛКА ВВЕРХ или СТРЕЛКА ВНИЗ.

  3. Для выбора кнопки > нажмите клавишу TAB и затем ENTER.

  4. Для перемещения других полей повторите шаги с первого по третий.

Для перемещения поля внутри окна размерностей в нижний или верхних уровень.

  1. Для выбора окна размерностей нажмите клавишу TAB.

  2. Для выбора перемещаемого поля нажмите клавишу СТРЕЛКА ВВЕРХ или СТРЕЛКА ВНИЗ.

  3. Нажмите клавиши CTRL+X.

  4. Для выбора места для перемещаемого поля нажмите клавишу СТРЕЛКА ВВЕРХ или СТРЕЛКА ВНИЗ.

  5. Нажмите клавиши CTRL+V.


Клавиши, используемые при работе с помощником

Клавиши | Действие
F1 | Получение справки у помощника
ALT+цифра (1 — первый раздел, 2 — второй раздел и т.д.) | Выбор одного из предлагаемых помощником разделов справки
ALT+СТРЕЛКА ВНИЗ | Переход к следующему экрану списка разделов справочной системы
ALT+СТРЕЛКА ВВЕРХ | Переход к предыдущему экрану списка разделов справочной системы
ESC | Закройте сообщение или окно помощника


 Установка драйвера ODBC для доступа к внешнему источнику данных

Установка драйвера ODBC для доступа к внешнему источнику данных

Драйверы ODBC, поставляемые компанией Microsoft вместе с Microsoft Query, полностью установлены в момент установки Query. Обратитесь к списку драйверов поставляемых с Query.

Если требуемая внешняя база данных не поддерживается этими драйверами ODBC, необходимо получить и установить драйвер ODBC совместимый с Microsoft Office от сторонних производителей, например от производителя базы данных. Для получения дополнительных инструкций по установке драйверов свяжитесь с поставщиком базы данных.

Примечание. Базам данных OLAP не требуются драйверы ODBC. Драйверы и поддержка для доступа к базам данных, которые были созданы при помощи Microsoft SQL Server OLAP Services, уже установлены вместе с Query. Для подключения к другим базам данных OLAP, требуется установить драйвер источника данных и программное обеспечение клиента. См. раздел о сторонних поставщиках данных для куба.


 Установка поставщиков данных для куба

Установка поставщиков данных для куба

Для подключения сторонних продуктов, которые предоставляют услуги и данные OLAP, необходимо установить программное обеспечение поставщика данных куба OLAP. Оно включает в себя дополнительные драйверы источника данных и программное обеспечение клиента, позволяющее подключиться на сервере к базе данных OLAP сторонних производителей.

Для использования возможностей Microsoft Office по работе с данными OLAP, поставщик данных для куба от сторонних производителей должен быть совместимым с Microsoft Office. Поставщик данных может как поддерживать, так и не поддерживать создание и работу с файлами автономного куба. Проверить поддержку можно создав Отчет сводной таблицы Microsoft Excel из данных поставляемых базой данных OLAP от сторонних производителей. Если поставщик данных не поддерживает работу с файлами автономного куба, то в Отчете сводной таблицы, в меню Сводная таблица (панель инструментов Сводная таблица) команда Настройка "клиент-сервер" будет недоступна.

Для получения дополнительных сведений по установке поставщиков данных для куба от сторонних поставщиков, свяжитесь с системным администратором или производителем продукта. После того, как поставщик данных будет установлен, можно настроить источники данных в Microsoft Query для доступа к базе данных поставщика.


 Доступные базы данных

Доступные базы данных

Вместе с Microsoft Office поставляются драйверы, которые используются при загрузке данных из следующих источников данных:

  • Microsoft SQL Server OLAP Services (служба доступа OLAP)

  • Microsoft Access 2000

  • dBASE

  • Microsoft FoxPro

  • Microsoft Excel

  • Oracle

  • Paradox

  • SQL Server

  • Базы данных текстовых файлов

Примечание. При использовании драйверов ODBC или источника данных от сторонних производителей получите дополнительную информацию о других неуказанных здесь типах баз данных, включая другие типы баз данных OLAP. Для получения дополнительных сведений о драйверах доступных от компании Microsoft обратитесь к файлу xlreadme.txt. Для получения дополнительных сведений об установке драйверов ODBC или источника данных, которые не указаны здесь или в файле xlreadme.txt, обратитесь к документации для данной базы данных или свяжитесь с поставщиком драйвера.


 Выбор источника данных

Выбор источника данных

  1. Если на экране не открыто диалоговое окно Выбор источника данных, нажмите кнопку Новый запрос [image] .

  2. Сделайте одно из следующего:

    Для того, чтобы указать источник данных для реляционной базы данных, базы данных текстового файла или списка Microsoft Excel, выберите вкладку Базы данных.

    Для того, чтобы указать источник данных куба OLAP, выберите вкладку Кубы OLAP. Эта вкладка доступна только если Microsoft Query запущен из-под Microsoft Excel.

  3. Дважды щелкните Новый источник данных.

  4. На первом шаге введите имя источника данных.

  5. На втором шаге выберите драйвер, соответствующий типу базы данных, используемой в качестве источника данных.

    Если нужный тип отсутствует в списке, может понадобиться установка драйвера ODBC или драйвера источника данных для источника данных.

    Инструкции

  6. Нажмите кнопку Подключить и затем предоставьте данные необходимые для подключения к базе данных.

    Если была выбрана реляционная база данных, база данных текстовых файлов или список Excel, то предоставляемые данные зависят от выбранного типа базы данных. Возможно потребуется ввести идентификатор входа, пароль, версия используемой базы данных, ее местоположение или другие данные, зависящие от типа базы данных.

    Для источников данных Microsoft SQL Server OLAP Services следуйте указаниям соответствующего мастера подключений.

  7. После того, как требуемые данные введены, нажмите кнопку OK или Готово для возврата в диалоговое окно Создание нового источника данных.

  8. Если в базе данных присутствуют таблицы, одну из которых необходимо автоматически отображать в мастере запросов, на четвертом шаге щелкните рамку и затем выберите нужную таблицу.

  9. Чтобы не вводить имя и пароль при использовании источника данных, установите флажок Сохранить имя и пароль в определении источника данных. Если этот флажок недоступен, узнайте у администратора базы данных, не была ли эта функция отключена.

    После выполнения этих шагов имя источника данных появится в диалоговом окне Выбор источника данных.


 Настройка источника данных, который использует драйвер для Microsoft Access

Настройка источника данных, который использует драйвер для Microsoft Access

  1. Если на экране не открыто диалоговое окно Создание нового источника данных, нажмите кнопку Создать в меню Файл, дважды щелкните Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите Драйвер Microsoft Access.

  2. Затем нажмите кнопку Подключить.

  3. Нажмите кнопку Select в группе Database и воспользуйтесь диалоговым окном Select Database для поиска файла базы данных.

    Для открытия Microsoft Query базы данных в режиме только для чтения, установите флажок Read only.

    Чтобы запретить доступ к базе данных при использовании этого источника из других программ, кроме Microsoft Query, установите флажок Exclusive.

  4. Нажмите кнопку OK.

    Если для базы данных требуется задание дополнительных параметров связи, нажмите кнопку Advanced. Чтобы узнать, необходимо ли изменение этих параметров, свяжитесь с администратором базы данных. Для получения сведений о дополнительных параметрах нажмите кнопку Cancel, а затем нажмите кнопку Help в диалоговом окне ODBC Microsoft Access Setup.

  5. Для доступа к системной базе данных при помощи Microsoft Query выберите параметр Database в окне группы System Database, а затем нажмите кнопку System Database. Выберите файл системной базы данных в диалоговом окне Select System Database и нажмите кнопку OK.

  6. Нажмите кнопку OK, а затем введите идентификатор входа и пароль в группе Authorization. Если для доступа к базе данных не нужны идентификатор или пароль, оставьте поля окна Authorization пустыми.

Примечание. Для создания, исправления и сжатия баз данных Microsoft Access можно использовать диалоговое окно ODBC Microsoft Access Setup. При отсутствии опыта работы с этими операциями их следует выполнять только в Microsoft Access. Для получения дополнительных сведений обратитесь к справочной системе Microsoft Access.


 Настройка источника данных, который использует драйверы dBASE или FoxPro

Настройка источника данных, который использует драйверы dBASE или FoxPro

Перед выполнением следующих шагов рекомендуется поместить все файлы баз данных, которые будут использоваться, в один каталог, чтобы мастер запросов мог найти все файлы и не было необходимости вводить полный путь при добавлении таблицы в запрос. При желании файлы баз данных можно поместить в один каталог, а индексные файлы в другой.

  1. Если на экране не открыто диалоговое окно Создание нового источника данных, нажмите кнопку Создать в меню Файл, дважды щелкните Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите Драйвер Microsoft dBase или Драйвер Microsoft Visual FoxPro .

  2. Затем нажмите кнопку Подключить.

  3. Выполните одно из следующих действий.

    Для драйвера Microsoft dBase выберите версию dBASE или FoxPro в списке Version, которая была использована при создании файла базы данных. Если файл базы данных находится не в текущей папке, снимите флажок Use current directory и нажмите кнопку Select Directory для поиска папки. Если индексные файлы базы данных также находятся в другом каталоге, для поиска папки нажмите кнопку Select Indexes.

    Для драйвера Microsoft Visual FoxPro выберите базу данных FoxPro в списке Database type, затем введите путь к базе данных в поле Путь.


 Настройка источника данных, который использует драйвер для Excel

Настройка источника данных, который использует драйвер для Excel

Драйвер ODBC Microsoft Excel предоставляет доступ только к данным из книг, которые находятся в одной и той же папке. Перед выполнением следующих шагов скопируйте все книги, к которым будет осуществляться одновременный доступ, в одну папку и присвойте имя каждому диапазону книг, который будет восприниматься Microsoft Query как таблица.

Для каждой папки, доступ к данным из которой будет осуществляться, необходимо создать отдельный источник данных..

Необходимо закрыть книгу перед настройкой источника данных или выполнением запроса для доступа к данным, которые содержатся в этой книге.

  1. Если на экране не открыто диалоговое окно Создание нового источника данных, нажмите кнопку Создать в меню Файл, дважды щелкните Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите Драйвер Microsoft Excel.

  2. Затем нажмите кнопку Подключить.

  3. In the Version box, click the Excel version that was used to create the workbook. If your workbook was created with Excel 97, click Excel 97-2000. If your workbook was created with Excel 95 (Excel version 7.0), click Excel 5.0/7.0.В поле Version выберите версию Excel, которая была использована для создания книги. Если книга была создана при помощи Excel 97, выберите Excel 97-2000. Если книга создана при помощи Excel 95 (Excel версия 7.0), выберите Excel 5.0/7.0.

  4. Нажмите кнопку Select Workbook, а затем выберите нужный файл книги.


 Настройка источника данных, который использует драйвер Microsoft ODBC для Oracle

Настройка источника данных, который использует драйвер Microsoft ODBC для Oracle

Используя драйвер Microsoft ODBC для Oracle, можно подключиться к базам данных Oracle, которые поддерживают SQL*Net 2.3 или более поздние версии. Для получения дополнительных сведений о данной поддержке, обратитесь к документации по Oracle.

Прежде чем настраивать источники данных, которые используют данный драйвер, необходимо установить систему доступа Oracle и сетевые компоненты версий 7.3 или более поздние. Эти компоненты доступны через саму фирму Oracle, либо ее поставщика.

  1. Если на экране не открыто диалоговое окно Создание нового источника данных, то выберите в меню Файл команду Создать запрос, дважды щелкните Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите Microsoft ODBC for Oracle Driver.

  2. Затем нажмите кнопку Подключить.

  3. В группе База данных, нажмите кнопку Выбрать.

  4. В поле Имя пользователя введите идентификатор для входа в базу данных.

  5. Введите имя сервера Oracle и дополнительную информацию необходимую для подключения к серверу. Для получения дополнительных сведений свяжитесь с администратором базы данных Oracle. Для получения дополнительных сведений о параметрах настройки нажмите кнопку Help в диалоговом окне настройки.

  6. Введите имя пользователя и пароль, и два раза в нажмите кнопку OK.


 Настройка источника данных, который использует драйвер для Paradox

Настройка источника данных, который использует драйвер для Paradox

Перед выполнением следующих шагов желательно поместить все файлы баз данных, которые будут использоваться совместно, в одну папку, чтобы Query мог найти все файлы и не было необходимости вводить полное имя файла при добавлении таблицы в запрос.

  1. Если на экране не открыто диалоговое окно Создание нового источника данных, нажмите кнопку Создать в меню Файл, дважды щелкните Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите Microsoft Paradox Driver.

  2. Затем нажмите кнопку Подключить.

  3. Выберите номер версии Paradox, которая использовалась для создания файлов базы данных, из списка Version.

  4. Если файлы находятся не в текущем каталоге, снимите флажок Use current directory, а затем нажмите кнопку Select Directory, чтобы найти нужную папку.

  5. Если для базы данных необходима установка дополнительных параметров, нажмите кнопку Options. Чтобы узнать, необходимо ли изменение этих параметров, свяжитесь с администратором базы данных. Для получения дополнительных сведений о параметрах нажмите кнопку Help в диалоговом окне ODBC Paradox Setup.


 Настройка источника данных, который использует драйвер Microsoft SQL Server OLAP Services

Настройка источника данных, который использует драйвер Microsoft SQL Server OLAP Services

Драйвер используется для настройки источников данных для обоих серверов баз данных ифайлов автономного куба (*.cub), которые созданы из баз данных Microsoft SQL Server OLAP Services мастером создания автономного куба OLAP в Microsoft Excel или из записей реляционная базы данных мастером создания куба OLAP в Microsoft Query. См. источники данных OLAP.

  1. Если на экране не открыто диалоговое окно Создание нового источника данных, нажмите кнопку Создать в меню Файл, дважды щелкните Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите Microsoft OLE DB Provider для служб OLAP.

    Вкладка Кубы OLAP доступна, только если запустить Query из-под Excel.

  2. Нажмите кнопку Подключить в диалоговом окне Создание нового источника данных.

  3. В диалоговом окне Multi-Dimensional Connection выполните одно из следующих действий.

    Для подключения к серверу базы данных выберите OLAP Server, затем введите имя сервера, идентификатор и пароль к серверу. Для получения дополнительных сведений об этих параметров, свяжитесь с администратором сервера.

    Для подключения к автономному кубу необходимо выбрать DCube file и ввести путь к файлу куба в поле File.

  4. Сделайте одно из следующего:

    При подключении к автономному кубу, нажмите кнопку Готово.

    При подключении к серверу баз данных нажмите кнопку Далее, выберите сервер баз данных, нажмите кнопку Готово. Затем в диалоговом окне Создание нового источника данных выберите имя базы данных куба, откуда будет поступать информация.


 Настройка источника данных, который использует драйвер для текста

Настройка источника данных, который использует драйвер для текста

Для каждой папки, доступ к данным текстовых файлам из которой будет осуществляться, необходимо создать отдельный источник данных. Чтобы использовать источник данных для доступа к нескольким текстовым файлам одновременно, скопируйте все текстовые файлы в одну папку перед выполнением следующих шагов.

  1. Если на экране не открыто диалоговое окно Создание нового источника данных, нажмите кнопку Создать в меню Файл, дважды щелкните Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите Microsoft Text Driver.

  2. Затем нажмите кнопку Подключить.

  3. Если текстовые файлы находятся не в текущем каталоге, снимите флажок Use current directory, а затем нажмите кнопку Select Directory, чтобы найти нужную папку.

Примечание. Может осуществляться доступ к данным из текстовых файлов нескольких форматов, включая столбцы, разделенные пробелами, запятыми или символами табуляции. Для получения дополнительных сведений о форматах текстовых файлов, которые можно использовать, нажмите кнопку Help в диалоговом окне ODBC Text Setup.


 Настройка источника данных, который использует драйвер для SQL сервера

Настройка источника данных, который использует драйвер для SQL сервера

  1. Если на экране не открыто диалоговое окно Создание нового источника данных, нажмите кнопку Создать в меню Файл, затем дважды щелкните Новый источник данных на вкладке Базы данных. Введите имя источника данных и выберите SQL сервер.

  2. Затем нажмите кнопку Подключить.

  3. Введите имя сервера SQL, расположенного в сети, в поле Сервер. Для получения дополнительных сведений о значениях, которые можно вводить в поле Сервер, нажмите кнопку Справка.

  4. Выберите Параметры и установите другие параметры, необходимые для базы данных. Чтобы узнать, необходимо ли изменение этих параметров, свяжитесь с администратором базы данных. Для получения дополнительных сведений о параметрах нажмите кнопку Справка.

  5. Введите имя пользователя и пароль, и два раза в нажмите кнопку OK.


 О создании нового запроса

О создании нового запроса

Запрос — это средство поиска записей в базе данных по определенным условиям. Запрос может быть создан мастером создания запроса или непосредственно в Microsoft Query. Способ создания запроса определяется требованиями к отбору данных в каждом конкретном случае.

Использование мастера создания запросов. Простой запрос может быть создан с помощью мастера создания запросов. Последний позволяет отобрать необходимые таблицы и поля для включения в запрос. Внутренние объединения создаются автоматически при распознавании мастером ключевого поля в одной таблице и поля с таким же именем в другой.

При помощи мастера запросов также можно осуществлять сортировку таблицы результатов и простейший отбор данных. На завершающем шаге выполнения мастера можно передать данные в Microsoft Excel, продолжить работу с запросом в Microsoft Query, либо создать из данных куб OLAP. Выполнение готового запроса возможно как в Excel, так и в Query. Инструкции по использованию мастера создания запросов.

Создание запроса в Microsoft Query. В Query создаются более сложные виды запросов. Этот способ позволяет наиболее полно использовать возможности создания запросов. Таблица результатов в данном случае может быть уменьшена путем создания внутреннего объединения или внешнего объединения, а также за счет использования выражений и сложных условий. Выражения вычисляются при помощи операторов, функций, имен полей и констант. Работа с условиями позволяет выполнять сложные виды отбора данных.

Таблица результатов может быть просмотрена в Microsoft Query. Если таблица результатов содержит все нужные данные, ее можно передать в Microsoft Excel. Также в Query можно создавать кубы OLAP. Созданный запрос можно выполнять в Microsoft Excel или в Microsoft Query. Инструкции по созданию запросов в Microsoft Query.

Параметрические запросы. С помощью одного параметрического запроса можно извлекать данные, которые отвечают нескольким различным условиям. Так, для получения всех сведений о продажах одного изделия в качестве условия может быть указано наименование этого изделия. Параметрические запросы также удобны при извлечении части большой базы данных, если нехватка системных ресурсов не позволяет получить все содержащиеся в ней данные сразу.

При запуске параметрического запроса должны задаваться условия. Этот запрос может быть создан только в Microsoft Query. Задаваемые условия используются для выборки данных из указанных в запросе таблиц. Созданный запрос можно выполнять как в Microsoft Excel, так и в Microsoft Query. Инструкции по созданию параметрического запроса.


Создание запроса

Инструкции

Создание запроса с использованием мастера запросов

Создание сложного запроса в Microsoft Query

Создание параметрического запроса

Не можете сделать выбор?


 Создание параметрического запроса

Создание параметрического запроса

  1. Создайте запрос, содержащий таблицы и поля, для нужных записей.

    Инструкции

  2. Убедитесь, что кнопка Автоматический режим [image] не нажата.

  3. Для отображения области условий убедитесь, что кнопка Отображение условий [image] нажата.

  4. Выберите первую ячейку в строке Условие, а затем щелкните стрелку в ячейке, чтобы выбрать из списка поле, которое будет использоваться в качестве параметра запроса.

  5. Выберите первую ячейку в строке Значение. Введите [ (открывающую квадратную скобку) и текст приглашения, которое будет выводиться Microsoft Query при выполнении запроса, а затем введите ] (закрывающую квадратную скобку). Приведенный ниже пример иллюстрирует это.

    Текст приглашения не должен совпадать с именем поля, хотя и может включать его.

    Для создания нескольких параметров запроса повторите пункты 4 и 5 для каждого параметра, который добавляется в следующий свободный столбец в области условий.

    Для получения дополнительных сведений об условиях, которые могут быть использованы в запросах, нажмите кнопку [image] .

  6. Нажмите клавишу ENTER.

  7. Для выполнения запроса нажмите кнопку Выполнить запрос [image] .

Примечание. После получения необходимых данных, таблица результатов может быть передана в Microsoft Excel. Для получения дополнительных сведений нажмите кнопку [image] .


 Открытие запроса

Открытие запроса

  1. Нажмите кнопку Открыть запрос [image] , выберите нужный файл запроса и нажмите кнопку Открыть.

    Файлы запросов имеют расширение ".dqy" или ".qry".

  2. При необходимости введите идентификатор и пароль для входа, а также другие данные, необходимые источнику данных.

  3. При необходимости введите значения параметров запроса и нажмите кнопку OK. Если нужные параметры неизвестны, обратитесь к автору запроса.

Примечание. Также можно открыть файл определения куба (.oqy), который был создан при помощи мастера создания куба OLAP. Открытие данного типа файла запускает мастер, для того, чтобы изменить определение куба. Изучите создание кубов при помощи мастера создания куба OLAP.


 Сохранение запроса

Сохранение запроса

Сохраняйте запрос, чтобы запомнить текущие параметры форматирования, а также для использования запроса в другое время или из другой книги. Для получения дополнительных сведений об открытии файлов запроса в Microsoft Excel обратитесь к справочной системе Microsoft Excel. Для передачи данных в Excel не требуется сохранение запроса.

  1. Нажмите кнопку Сохранить [image] .

  2. Введите нужное имя в поле Имя файла.

  3. В диалоговом окне Сохранить как Microsoft Query автоматически выбирает тип Файлы запросов (*.dqy). Для использования запроса в более ранней версии Query, чем Microsoft Query 97, выберите тип Файлы запросов (*.qry).

    Параметрический запрос может быть сохранен только в формате *.dqy и не может быть использован в более ранней версии Query, чем Microsoft Query 97.

  4. Выберите папку, в которой будет сохранен запрос, из списка Папка.

  5. Нажмите кнопку Сохранить.

Примечания

  • При сохранении файла запроса, Query не сохраняет текущую таблицу результатов, отображенную в области данных. Таблица результатов автоматически обновляется перед появлением диалогового окна Сохранение запроса, даже если кнопка Автоматический режим [image] не нажата.

  • Чтобы запретить выполнение запроса до его сохранения или возвращения данных в Excel, в меню Правка выберите Параметры и затем снимите флажок Проверять запросы перед сохранением или возвратом данных.

  • По умолчанию файлы запросов хранятся в папке профиля пользователя в Application Data\Microsoft\Queries. При сохранении запроса в стандартной папке имя файла запроса выводится на вкладке Запросы при открытии нового запроса в Microsoft Query или при выборе команды Выполнить сохраненный запрос (меню Данные, подменю Внешние данные) в Microsoft Excel.


 Выполнение, просмотр и изменение команды, процедуры или инструкции SQL

Выполнение, просмотр и изменение команды, процедуры или инструкции SQL

Структурированный язык запросов (SQL) может быть использован при изменении инструкции SQL SELECT. Для получения дополнительных сведений по языку SQL обратитесь к документации по базе данных.

  1. Создайте новый запрос. Не передавайте результаты в Microsoft Excel.

    Инструкции

  2. Нажмите кнопку Режим SQL [image] .

    Microsoft Query отобразит диалоговое окно SQL с соответствующей запросу инструкцией SELECT языка SQL.

  3. Внесите необходимые изменения в инструкцию SQL и нажмите кнопку OK.

    Чтобы добавить строку в поле Инструкция SQL, нажмите клавишу ENTER.

Примечания

  • При изменении или замене инструкции SQL используйте тот же синтаксис, что и Microsoft Query, или синтаксис, поддерживаемый источником данных. Microsoft Query интерпретирует используемый синтаксис и выводит на экран проект запроса и таблицу результатов.

  • Если Microsoft Query не может вывести проект запроса из-за синтаксической ошибки в какой-либо его части, то таблица результатов все равно выводится. Однако может быть изменено только форматирование таблицы результатов, например шрифт экрана или ширина столбца. Изменение данных невозможно, и все изменения, вносимые в запрос, например добавление или удаление полей, должны производиться в диалоговом окне SQL.


 Выполнение запроса автоматически или вручную

Выполнение запроса автоматически или вручную

При каждом добавлении поля в область данных, а также при изменении или добавлении условий в области условий. Microsoft Query автоматически выполняет запрос и обновляет данные в таблице результатов. Если в запросе содержится большое число записей, может понадобиться отложить выполнение запроса до внесения всех изменений в запрос.

  • Для автоматического выполнения запроса при добавлении каждого нового условия или поля убедитесь, что кнопка Автоматический режим [image] нажата.

  • Чтобы отложить выполнение запроса до того, как будут добавлены все нужные поля и условия, убедитесь, что кнопка Автоматический режим [image] не нажата. Когда запрос будет готов, нажмите кнопку Выполнить запрос [image] .


 Передача таблицы результатов в Microsoft Excel

Передача таблицы результатов в Microsoft Excel

  1. Если не открыто диалоговое окно Передача внешних данных в Microsoft Excel, нажмите кнопку Вернуть данные [image] и при появлении запроса на экране введите необходимые для запроса параметры.

  2. Нажмите кнопку Свойства для установки параметров форматирования, используемых при передаче фрагмента внешних данных в Microsoft Excel. Для получения дополнительных сведений обратитесь к справочной системе Microsoft Excel.

  3. Чтобы поместить таблицу результатов на текущий лист, выберите параметр Существующий лист. Выберите ячейку листа, в которую будет помещен левый верхний элемент, из таблицы результатов и нажмите кнопку OK.

    Чтобы поместить таблицу результатов в новый лист, выберите параметр Новый лист, а затем нажмите кнопку OK. Microsoft Excel добавит новый лист к книге и автоматически поместит таблицу результатов в верхний левый угол нового листа.

    Для использования внешних данных в Отчете сводной таблице выберите параметр Отчет сводной таблицы, а затем нажмите кнопку OK.

Примечания

  • Таблица результатов автоматически обновляется в Query, перед тем, как диалоговое окно Возврат данных в Microsoft Excel будет отображено, даже когда кнопка Автоматический режим [image] не нажата. Чтобы запретить выполнение запроса до возвращения данных в Excel, в меню Query Правка выберите Параметры и затем снимите флажок Проверять запросы перед сохранением или возвратом данных.

  • Можно проверить состояние запроса, который передает данные слишком долго. Нажмите кнопку Состояние обновления [image] на панели инструментов Внешние данные. Для отмены передачи данных нажмите Отменить обновление.


 Выполнение инструкции или процедуры SQL

Выполнение инструкции или процедуры SQL

Структурированный язык запросов (SQL) может использоваться при выполнении инструкции SQL SELECT. Для получения дополнительных сведений по языку SQL обратитесь к документации по базе данных.

  1. Выберите команду Выполнить запрос SQL в меню Файл.

    Для выполнения инструкции SQL в таблице из другого источника данных нажмите кнопку Источники данных, выберите нужный источник и нажмите кнопку OK. Можно указать новый источник данных.

    Инструкции

  2. Введите инструкцию SQL, которую нужно выполнить, в поле Инструкция SQL.

    Для выполнения существующей инструкции нажмите кнопку Открыть, выберите файл, содержащий процедуру на языке SQL, и нажмите кнопку Открыть.

    Для выполнения процедуры SQL, хранящейся во внешней базе данных, нажмите кнопку Процедуры, выберите нужную процедуру из списка Запрос, а затем нажмите кнопку Вставить, чтобы скопировать процедуру в поле Инструкция SQL.

  3. Нажмите кнопку Выполнить.

    Microsoft Query начнет выполнение инструкции SQL. Для отмены запроса, занимающего слишком много времени, нажмите клавишу ESC.

    Чтобы сохранить инструкцию SQL, нажмите кнопку Сохранить.

Примечания

  • При изменении или замене инструкции SQL используйте тот же синтаксис, что и Microsoft Query, или синтаксис, поддерживаемый источником данных. Microsoft Query интерпретирует используемый синтаксис и выводит на экран проект запроса и таблицу результатов.

  • Если Microsoft Query не может вывести проект запроса из-за синтаксической ошибки в какой-либо его части, то таблица результатов все равно выводится. Однако, может быть изменено только форматирование таблицы результатов, например шрифт экрана или ширина столбца. Изменение данных невозможно, и все изменения, вносимые в запрос, например добавление или удаление полей, должны производиться в диалоговом окне SQL.

  • Если при выполнении запрос возвращает несколько таблиц результатов, то Microsoft Query выводит первую из них в области данных. Остальные таблицы результатов не отображаются.

  • Если запрос был успешно выполнен, но не вернул никакой таблицы результатов, Microsoft Query выводит сообщение об успешном выполнении запроса. Если при выполнении запроса были изменены строки в таблицах, в сообщении также указывается количество измененных строк.

  • Если при выполнении запроса произошла ошибка, Microsoft Query выводит соответствующее сообщение SQL об ошибке. Чтобы вывести диалоговое окно Выполнить запрос SQL и исправить инструкцию, нажмите кнопку OK.


 О запросах OLAP

О запросах OLAP

Microsoft Query позволяет создавать и работать с данными из баз данных OLAP (On-Line Analytical Processing — электронная аналитическая обработка данных): настраивать источники баз данных, создавать кубы OLAP из реляционной базы данных и сохранять файлы определения куба OLAP. Данный раздел объясняет использование Microsoft Query для подготовки данных OLAP для дальнейшего использования в Отчете сводной таблицы и Отчете сводной диаграммы Microsoft Excel.

Этот раздел предоставляет сведения о следующем:

Что такое OLAP?

Подключение к базам данных OLAP

Создание куба OLAP из записей запроса

Сохранение файлов запроса OLAP

Что такое OLAP?

OLAP — способ организации больших коммерческих баз данных. Данные OLAP формируются администратором базы данных, чтобы быть более приспособленными для анализа и управления, что позволяет пользователям уменьшить время и усилия для создания отчетов.

Уровни детализации. Базы данных OLAP представляют данные по уровню детализации, используя те же типы категорий, что и при обычном анализе. Например, база данных мировых продаж может иметь отдельные поля, которые будут соответствовать стране, области, городу и району каждой продажи. Эти географические данные в базах OLAP могут быть организованы с наименьшего по наивысший уровень детализации. Например как:

Уровни в географической размерности

Уровни в географической размерности

Данная организация позволяет также легко показывать итоги глобальных продаж, например продажи по стране или области, как и подробности для мест, где продажи чрезвычайно велики или малы. В Отчете суммарной таблицы или диаграммы можно вывести суммарные данные в различных уровнях, а затем увидеть уровни более подробно, только с интересующими элементами.

Размерности и кубы. Размерность — таблица уровней, охватывающая одну сторону данных, как например, географические области. Аналогично, данные о дате продажи могут быть организованы по времени с уровнями год, квартал, месяц и день. Базы данных OLAP названы кубами, потому, что они объединяют различные размерности, как например, время, географическое положение и продукты, с итоговыми данными, как например, продажи или инвентаризационные номера. Для каждого пересечения каждого уровня каждой размерности, как например суммарная продажа в течении дня, месяца, года для каждого места, области, страны для каждого продукта и группы продуктов, в базах данных OLAP вычисляются итоговые значения.

Вернуться наверх

Подключение к базам данных OLAP

Поставщик данных для куба. Для подключения к базе данных OLAP, требуется поставщик данных для куба, который поддерживает данный тип баз данных OLAP. Программное обеспечения поставщика данных для средств OLAP (Microsoft SQL Server OLAP Services) поставляется вместе с Microsoft Office. Для других продуктов, предоставляющих OLAP данные и услуги, требуется установить дополнительные драйверы и программное обеспечение клиента. Для получения дополнительных сведений об использовании поставщиков данных для куба от сторонних поставщиков, свяжитесь с системным администратором или производителем продукта. См. сведения об установке поставщиков данных для куба.

Источники данных. Программное обеспечение клиента OLAP включает в себя драйвер источника данных для базы данных OLAP. Office содержит драйвер, именуемый Microsoft OLE DB Provider for OLAP Services, предназначенный для доступа к базам данных, созданных при помощи Microsoft SQL Server OLAP Services. Также используются источники данных для доступа к кубам или файлам автономного куба, при их создании в Microsoft Query.

При запуске Microsoft Query для подключения к базе данных OLAP или файлу автономного куба, настраивается новый источник данных, такой же как и для любого другого типа данных, исключая случай, когда для подключения к базе данных используется вкладка Кубы OLAP в диалоговом окне Выбор источника данных для указания имени источника данных и драйвера для поставщика данных для куба. Как настроить источник данных.

Возврат данных в Excel. После настройки источника данных OLAP и его выбора для использования, не создавайте запрос для выбора таблиц и полей, как это делается для других видов данных. Источник данных предоставляет доступ ко всем данным в кубе. Поля данных немедленно возвращаются в Excel как Отчет сводной таблицы.

Вернуться наверх

Создание куба OLAP из записей запроса

Используя Microsoft Query и систему доступа OLAP поставляемую с Microsoft Office, можно создать из данных запрошенных из реляционной базы данных, например, как Microsoft SQL Server, собственный куб OLAP или файл автономного куба. Создание куба повышает эффективность доступа к большим объемам реляционных данных и позволяет помочь организовать данные для их использования в отчетах. Для использования данного типа кубов, нет необходимости в продукте OLAP сервер.

Извлечение данных из куба. Для создания собственного куба, настройте источник данных для реляционной базы данных, создайте запрос для извлечения данных и запустите мастер создания куба OLAP, который определит структуру куба для извлекаемых данных. При желании сохраните файл автономного куба.

Создание куба, который будет построен в памяти. При использовании мастера, можно создать временный куб, который будет строиться в памяти каждый раз при открытии отчета, основанного на данном кубе. Для получения дополнительных указаний по созданию данного вида куба, обратитесь к справочной системе мастера создания куба. Изучите работу мастера по созданию куба OLAP.

Создание автономного файла. Мастер создания кубов OLAP также позволяет создавать автономные файлы куба (.cub), которые могут быть сохранены на локальном или на сетевом диске. Сохранение на локальном диске позволяет продолжать работу с данными, даже когда машина отключена от сети или когда сервер недоступен. Сохранение на сетевом диске позволяет другим пользователям устанавливать источники данных для доступа к автономному кубу и основывать на нем отчеты. Изучите работу мастера по созданию файла автономного куба OLAP.

Вернуться наверх

Сохранение файлов запроса OLAP

Источники данных OLAP. Если источник данных настраивается в диалоговом окне Выбор источника данных (вкладка Кубы OLAP), Microsoft Query сохраняет .oqy файл в папке профиля пользователя, которая находится в каталоге Application Data\Microsoft\Queries. Этот файл может быть открыт непосредственно из приложения Excel с целью подготовки отчета сводной таблицы (содержащиеся в этом файле данные дополняют сведения об источнике, которые задаются при создании отчета сводной таблицы или сводной диаграммы в Excel) Если .oqy файл подключен к базе данных сервера OLAP или к файлу автономного куба на сетевом диске, этот файл можно сделать доступным для других пользователей. Это избавит их от необходимости самостоятельной настройки источников данных при создании отчетов.

Кубы, созданные мастером создания кубов OLAP. После завершающего шага в мастере создания куба OLAP, будет запрошено сохранение файла определения куба с расширением .oqy. Этот файл содержит данные, которые необходимы Excel или для создания куба в памяти, или для подключения к файлу автономного куба, если таковой создан. Вместо того, чтобы возвращать записи запроса в Microsoft Excel, можно открыть этот файл в Excel для создания Отчета сводной таблицы. Нет необходимости в настраивание отдельного источника данных для куба OLAP, хотя можно настроить источник данных для файла автономного куба, если требуется подключить к нему с целью создания отчетов.

Сохранение .oqy файла не совсем то, что и сохранение копии запроса к записям реляционной базы данных, которые используются для создания куба OLAP. Если необходимо сохранить копию запроса для того, чтобы впоследствии добавить данные к кубу, то надо сохранить запрос в файле запроса к базе данных (.dqy).

Вернуться наверх


 О создании куба OLAP из реляционной базы данных

О создании куба OLAP из реляционной базы данных

В данном разделе описываются методы создания куба OLAP из запроса, который загружает данные из реляционной базы данных, например такой как Microsoft Access или Microsoft SQL Server. Для использования или создания такого типа куба OLAP нет необходимости в серверных продуктах. Для понимания и использования этой возможности Microsoft Query необходимо ознакомиться с управлением баз данных и использованием Microsoft Query для загрузки данных для отчетов Сводной таблицы или отчетов Сводной диаграммы Microsoft Excel.

Этот раздел предоставляет сведения о следующем:

Что такое куб OLAP ?

Создание запроса для данных

Создание куба OLAP

Обновление и изменение куба OLAP

Что такое куб OLAP?

Электронная аналитическая обработка данных (On-Line Analytical Processing —OLAP) — способ организации данных, приспособленный для анализа и управления данными, что позволяет уменьшить время и усилия для создания отчетов. При создании куба OLAP из запроса происходит превращение линейной таблицы в структурную иерархию (куб), которая позволяет отчетам сфокусироваться на желаемом уровне детальности. Также заранее задаются итоговые значения для отчетов, что позволяет повысить скорость вычислений.

Создайте куб OLAP, когда необходимо обеспечить большой объем внешних данных для использования в отчетах Microsoft Excel, особенно если возврат записей для анализа в Excel приводит к недостатку системных ресурсов. Поскольку куб позволяет загрузить в Excel только те данные, которые необходимы для текущего вида отчета, для больших объемов данных создание и обновление отчета обычно происходит быстрее, чем при загрузки всей таблицы записей из базы данных.

В отличии от записей реляционной базы данных в запросе, которые могут быть возвращены на лист Excel как диапазон внешних данных, данные из куба OLAP могут быть возвращены в Excel только как отчет Сводной таблицы или Сводной диаграммы.

Изучите источники данных OLAP и запросы.

Вернуться наверх

Создание запроса для данных

Для создания куба OLAP из записей реляционной базы данных необходимо настроить источник данных для реляционной базы данных и затем создать запрос для извлечения полей и записей, которые послужат данными для куба.

Выбор полей для запроса. Чтобы обеспечить наибольшую эффективность выполнения запроса, необходимо включить только те таблицы и поля, которые необходимы для куба в запросе. Однако убедитесь, что добавили все необходимые поля. После создания куба невозможно добавить дополнительные поля в запрос и тем самым включить новые поля в куб. Для добавления новых полей в куб необходимо полностью заново создать куб.

Добавление полей больше чем единожды. Иногда необходимо использовать поле в кубе больше одного раза. Например, необходимо произвести две различные операции с полем «Продажи»: сложить суммы продаж и подсчитать количество продаж. Или необходимо включить две различные версии поля «Дата»: одно состоящее из кварталов и месяцев, второе — из кварталов и недель. Для того, чтобы использовать поле больше одного раза в кубе, необходимо добавить поле в запрос по одному разу для каждого использования. Например, добавьте поле «Продажи» в запрос дважды, если предполагается суммировать и подсчитывать количество значений в этом поле.

Обратитесь к справочной системе мастера создания куба OLAP для получения точных указаний когда необходимо включать поле в запрос больше одного раза. Если необходимо добавить поле в момент выполнения мастера, то отмените работу мастера, добавьте поле и запустите мастер заново.

Сохранение запроса. Если возможно позже куб будет заново создан с другими полями, убедитесь что запрос сохранен в файле базы данных запроса (.dqy). Затем можно будет открыть .dqy файл, изменить запрос и создать новые кубы из измененного запроса.

Вернуться наверх

Создание куба OLAP

Для создания куба необходимо запустить мастер создания куба OLAP. Обратитесь к справочной системе мастера создания куба OLAP для получения точных указаний по каждому шагу мастера.

Временные кубы и файлы автономного куба. Мастер позволяет создавать два типа кубов. Первый — определение куба, который сохраняется в файле .oqy. При открытии отчета сделанный на основе данного типа .oqy файла , куб временно создается в памяти. Второй — отдельный файл автономного куба, который хранится на локальном или сетевом диске. Сохранение такого типа куба на локальном диске позволяет продолжать работу с данными даже когда машина отключена от сети. Файл автономного куба может быть настроен как источник данных для отчетов.

Сохранение файла определения куба. Сохранялся или нет отдельный файл автономного куба, но мастер сохраняет файл определения куба (.oqy). Этот файл содержит данные необходимые Microsoft Query для загрузки куба, поэтому при его изменении и данные Excel требуют или создание куба в памяти, или подключение к файлу автономного куба, если таковой был создан.

Создание файла определения куба для создания отчетов. Вместо того чтобы возвращать записи реляционной базы данных в Microsoft Excel, можно открыть .oqy файл в Excel для создания Сводной таблицы отчета, которая будет основываться на кубе OLAP. Затем можно сохранить Сводную таблицу отчета в книге или создать Сводную диаграмму отчета, которая будет основываться на Сводной таблице отчета. Для получения дополнительных сведений об открытии .oqy файлов и создании отчетов обратитесь к справочной системе Microsoft Excel.

Вернуться наверх

Обновление и изменение куба OLAP

Обновление куба OLAP. Для того, чтобы обновить куб, необходимо открыть отчет, который основывается на этом кубе, в Microsoft Excel и обновить отчет. Если куб создан временно в памяти, то после этих действий новые или измененные данные из исходной базы данных будут перенесены в куб. Если куб автономный файл, то уже существующий файл будет заменен на заново созданный файл с новыми данными. Для создания и обновления кубов необходимо установить поставщик данных для куба, например такой как Microsoft SQL Server OLAP Services, который поддерживает данные возможности. Для получения дополнительных сведений о процедуре обновления отчета сводной таблицы или сводной диаграммы, основанного на кубе, обратитесь к справке Microsoft Excel.

Изменение куба OLAP. Для того чтобы систематизировать данные по-другому или удалить ненужные в отчете поля, можно изменить куб , созданные мастером создания куба OLAP. Если был создан файл автономного куба, то можно сохранить файл вместе с изменениями.

После создания куба OLAP невозможно добавить к нему еще поля из исходной реляционной базы данных. Однако можно создать новый куб из того же файла базы данных запроса (.dqy), так что будут использоваться различные поля из исходной базы данных .

Вернуться наверх


 Создание куба OLAP из реляционной базы данных

Создание куба OLAP из реляционной базы данных

Данные из куба OLAP могут быть возвращены в Microsoft Excel только как Отчет сводной таблицы, но не как диапазон внешних данных на листе.

  1. Создайте запрос для извлечения полей, необходимых для использования в кубе.

    Инструкции

  2. Запустите мастер создания куба OLAP одним из следующих способов:

    Если запрос был создан при помощи мастера, то в последнем шаге мастера нажмите кнопку Создание куба OLAP из данного запроса и затем нажмите кнопку Готово.

    Если запрос был создан в Microsoft Query, то в меню Файл нажмите кнопку Создать куб OLAP.

  3. Следуйте шагам в мастере создания куба. Обратитесь к справочной системе мастера создания куба OLAP для получения точных указаний по каждому шагу мастера.

  4. После завершения работы мастера создания куба, Query предложит сохранить файл определения куба (.oqy). Введите имя файла и затем нажмите кнопку Сохранить.

Примечания

  • Если в мастере создания куба указан файл автономного куба (.cub), то этот файл будет создан после нажатия кнопки Сохранить. В зависимости от объема данных, сохранение файла может потребовать значительного времени. Пока создание .cub файла не завершится, другая работа в Microsoft Query невозможна.

  • Для того, чтобы основывать дополнительные отчеты Microsoft Excel на данном кубе, не возвращайте данные запроса в Excel. Вместо этого откройте .oqy файл, используя команду Открыть в меню Excel Файл.

  • Также можно основывать отчеты Excel на автономном кубе. Для этого надо настроить источник данных для этого файла и затем указать этот источник при запуске мастера создания сводной таблицы и диаграммы.

  • Если предполагается в будущем добавлять поля к кубу, то убедитесь, что сохранили файл запроса к базе данных (.dqy), чтобы воспользоваться им при изменении куба.


 Изменение содержания и установок куба OLAP

Изменение содержания и установок куба OLAP

В уже существующем кубе OLAP можно изменить организацию полей и удалить более ненужные поля, но нельзя добавить дополнительные поля. Для добавления новых полей необходимо создать новый куб.

  1. Выберите Открыть в меню Файл Microsoft Query.

  2. Выберите Кубы OLAP в списке Тип файлов.

  3. Найдите и дважды щелкните файл определения куба (.oqy) для изменяемого куба.

  4. Следуйте шагам в мастере создания куба для изменения содержания и установок. Обратитесь к справочной системе мастера создания куба OLAP для получения точных указаний по каждому шагу мастера.

  5. После завершения работы мастера создания куба, Query предложит сохранить .oqy файл. Для замены уже существующего файла нажмите кнопку Сохранить. Для сохранения нового .oqy файла, введите новое имя и затем нажмите кнопку Сохранить.

Примечания

  • Если в мастере создания куба указан файл автономного куба (.cub), то этот файл будет создан после нажатия кнопки Сохранить. Изменяемый .cub файл должен быть полностью заново создан и замещен. В зависимости от объема данных, сохранение файла может потребовать значительного времени. Пока создание .cub файла не завершится, другая работа в Microsoft Query невозможна.

  • Основывание отчетов Microsoft Excel на .cub файле возможно либо открыв .oqy файл, используя команду Открыть в меню Excel Файл, либо настроив источник данных для .cub файл и затем указав его, при запуске мастера сводных таблиц и диаграмм.


 Удаление файла автономного куба

Удаление файла автономного куба

Удаление файла автономного куба (.cub) навсегда удаляет его с диска, на котором хранился файл, и освобождает часто значительное пространстве на диске. Однако, больше невозможно будет изменять отчеты, основанные на этом файле. Если были созданы источники данных, которые использовали этот файл, то их нельзя больше использовать.

  • Найдите и удалите .cub файл в Microsoft Windows.


 Добавление таблицы в запрос

Добавление таблицы в запрос

  1. Нажмите кнопку Добавить таблицу [image] .

  2. Выберите таблицу, которую требуется добавить.

  3. Нажмите кнопку Добавить.

Примечание. В запрос может быть добавлено любое число таблиц. Добавив нужные таблицы, нажмите кнопку Закрыть.


Удаление таблицы из запроса

  1. Выберите таблицу, которую нужно удалить.

  2. Выберите команду Удалить в меню Правка.


 Добавление или удаление поля

Добавление или удаление поля

Поле — категория данных, как например, имя продукта или сумма заказа, которая хранится в таблице базы данных. При добавления или удаления поля, запрос включает или исключает данные из этого поля. При этом база данных остается неизмененной.

Добавление поля. Чтобы добавить одно поле в таблицу результатов, дважды щелкните имя поля, которое нужно добавить, в области таблиц.

Пример одного поля, выбранного в Области таблиц

Удаление поля. Чтобы удалить поле из таблицы результатов, щелкните заголовок столбца полей, которые нужно удалить, в области данных, а затем выберите команду Удалить столбец в меню Записи.

Советы

  • Для добавления за один раз нескольких полей из одной и той же таблицы выберите каждое поле, удерживая клавишу CTRL, и перетащите выбранные поля в область данных.

  • Чтобы добавить все поля из таблицы в таблицу результатов, дважды щелкните * (звездочку) на верху таблицы в Области таблиц.

    Пример помеченных звездочкой (*) полей в Области таблиц


Извлечение связанных записей из нескольких таблиц с объединениями

Для отображения данного раздела выберите рисунок.

Для отображения данного раздела выберите рисунок


Извлечение записей из нескольких таблиц

Если запрос содержит больше чем одну таблицу, то извлечение связанных записей из нескольких таблиц возможно при помощи объединений. Объединение — связь двух таблиц, где поля в одной таблице содержат такие же данные, что и в другой.

Инструкции

Изучите извлечение записей при помощи внутренних и внешних объединений

Создание внутреннего объединения

Создание внешнего объединения

Создание самообъединения

Извлечение всех записей из двух таблиц

Просмотр отличающихся записей двух таблиц


 Объединение всех данных из двух таблиц

Объединение всех данных из двух таблиц

Для совмещения всех данных из двух списков, содержащих схожие, но не одинаковые данные, например из двух списков (таблиц) заказчиков, в которых содержатся разные сведения (поля) о каждом заказчике, можно создать запрос, включающий сведения обо всех заказчиках. При этом в каждом списке могут присутствовать сведения, которых нет в другом списке. Такой запрос называется полным внешним объединением. Изучите полные внешние объединения.

  1. В Microsoft Query, создайте запрос и добавьте в него обе таблицы.

  2. Создайте объединениесовпадающих полей двух таблиц (например, полей "Имя заказчика") путем перетаскивания поля из первой таблицы во вторую.

    Выберите из обеих таблиц поле, которое содержит данные во всех записях. Например, если в двух списках заказчиков содержатся совпадающие поля "Имя заказчика", объедините поля "Имя заказчика".

  3. Дважды щелкните на линию связи между двумя таблицами

  4. В диалоговом окне Объединения, выберите параметр 2, нажмите кнопку Добавить, после чего нажмите кнопку Закрыть.

  5. Добавьте нужные поля в запрос.

  6. Выберите команду SQL в меню Вид.

  7. Выберите данные в поле инструкция SQL, нажмите CTRL+C для того что бы скопировать их, после чего нажмите кнопку OK.

  8. Снова дважды щелкните на линию связи.

  9. В диалоговом окне Объединения, выберите параметр 3, нажмите кнопку Добавить, после чего нажмите кнопку Закрыть.

  10. Выберите команду SQL в меню Вид.

  11. Щелкните конец строки в поле Инструкция SQL, нажмите клавишу ENTER, введите заглавными буквами слово UNION и снова нажмите клавишу ENTER.

  12. Нажмите клавиши CTRL+V, чтобы вставить данные из буфера после слова UNION.

  13. Нажмите кнопку OK и после вывода сообщения о невозможности графического отображения запроса снова нажмите кнопку OK.


 Загрузка отличающихся записей двух таблиц

Загрузка отличающихся записей двух таблиц

При наличии двух таблиц, содержащих сходные данные, например двух списков (таблиц) заказчиков, в каждом из которых присутствуют сведения, отсутствующие в другом списке, можно создать запрос, возвращающий только те записииз первой таблицы, которые отсутствуют во второй. Такой запрос называется вычитательным объединением.

  1. В Microsoft Query, создайте запрос и добавьте в него обе таблицы.

  2. Создайте объединение совпадающих полей двух таблиц (например, полей "Имя заказчика" в двух списках) путем перетаскивания поля из первой таблицы во вторую.

  3. Дважды щелкните на линию связи между двумя таблицами

  4. В диалоговом окне Объединения, выберите параметр 2, нажмите кнопку Добавить, после чего нажмите кнопку Закрыть.

  5. Добавьте объединенные поля в запрос.

  6. Добавьте отличное от объединенного поле из второй таблицы. Выберите поле, в котором содержатся данные во всех записях второй таблицы. Например, если были объединены поля "Номер заказчика" из двух таблиц, то можно добавить поле "Имя заказчика" из второй таблицы.

  7. Выберите команду Условия в меню Вид.

  8. Из первого списка условий выберите поле, добавленное в шаге 6.

  9. В первом поле "Значение" введите Null.

  10. Для просмотра тех записей первой таблицы, которых нет во второй, нажмите кнопку Выполнить запрос [image] .

  11. Добавьте любые другие нужные поля в запрос и затем передайте данные в Microsoft Excel.

Примечание. Для просмотра записей из второй таблицы, для которых нет совпадающих в первой, создайте второй запрос, выполнив те же пункты, но поменяв местами таблицы (сделайте вторую таблицу первой и наоборот).


 Создание внешнего объединения

Создание внешнего объединения

Внешние объединения отображают все записи из одной таблицы и любые связанные записи из другой.

  1. Создайте внутреннее объединение между таблицами. Инструкции по созданию внутреннего объединения.

  2. Дважды щелкните линию объединения таблиц.

  3. Выберите = (знак равно) в списке Оператор.

  4. Сделайте одно из следующего:

    Для создания внешнего объединения, в котором используются все записи из таблицы слева, выберите параметр 2 из списка Объединение включает.

    Для создания внешнего объединения, в котором используются все записи из таблицы справа, выберите параметр 3 из списка Объединение включает.

Примечания

  • Извлечение всех записей из двух таблиц. Для объединения всех записей из двух таблицы, которые могут быть или не быть связанными, необходимо создать полное внешнее объединение.

  • Извлечение только тех записей из двух таблиц, которые не являются общими. Вместо извлечения связанных записей можно извлечь все записи из двух таблиц, которые не являются общими.


Создание самообъединения

Используйте эту процедуру для объединения данных из двух копий одной таблицы — например, когда данные работника включают в себя идентификационный номер его руководителя, и необходимо объединить идентификационный номер с именем руководителя. Тип запроса, создаваемый данной процедурой, называется самообъединением. Изучите самообъединения.

  1. Создайте запрос в Microsoft Query и добавьте таблицу, которую необходимо самообъединить.

  2. Добавьте такую же таблицу к запросу во второй раз.

  3. При сообщении, что таблица уже присутствует в запросе, нажмите кнопку OK.

  4. Если Query автоматически объединит две таблицы, то дважды щелкните линия связи, выберите Удалить, и затем нажмите кнопку Закрыть.

  5. Создайте внутреннее объединение между двумя таблицами. Например, если поле «Руководитель» использует для опознавания руководителей идентификационный номер работника, то можно объединить поле «Руководитель» из первой таблицы с полем «Идентификационный номер работника» из второй.

  6. Добавьте необходимые поля в запросе. Например, для того, чтобы видеть имена руководителей каждого работника, можно добавить поля «Имя работника» и «Руководитель» из первой таблицы, и затем поле «Имя работника» из второй.


Операторы, используемые в объединениях

В объединениях можно использовать следующие операторы.

Оператор | Описание
= (Равно) | Выбор записей, содержащих равные значения в объединенных полях.
<> (Не равно) | Выбор записей, содержащих разные значения в объединенных полях.
> (Больше) | Выбор тех записей из левой таблицы, которые содержат в объединенных полях значения большие, чем записи из правой таблицы.
>= (Больше или равно) | Выбор тех записей из левой таблицы, которые содержат в объединенных полях значения большие, либо равные значениям из записей правой таблицы.
< (Меньше) | Выбор тех записей из левой таблицы, которые содержат в объединенных полях значения меньшие, чем записи из правой таблицы.
<= (Больше или равно) | Выбор тех записей из левой таблицы, которые содержат в объединенных полях значения меньшие, либо равные значениям из записей правой таблицы.


 Удаление объединения

Удаление объединения

Если запрос содержит внутреннее объединение или внешнее объединение, но не выбирает нужные записи, может понадобиться удаление объединения.

  1. Выберите линию объединения, которую требуется удалить из области таблиц.

  2. Нажмите клавишу DELETE.

Примечания

  • Записи, включенные в таблицу результатов запроса, при удалении объединения будут изменены. В зависимости от типа удаляемого объединения, записи могут быть добавлены или удалены из таблицы результатов.

  • Удаление объединения из запроса влияет только на этот запрос. Например, если Microsoft Query автоматически создает внутреннее объединение двух таблиц в запросе и это объединение удаляется, то Microsoft Query снова автоматически создаст внутреннее объединение двух таблиц при использовании их в другом запросе.


Об использовании условий

Для отображения данного раздела выберите рисунок.

Для отображения данного раздела, выберите рисунок


 Ограничение числа обрабатываемых записей путем использования условий

Ограничение числа обрабатываемых записей путем использования условий

Путем использования условий, можно выбирать определенные записи. Microsoft Query использует условия для выбора нужных записей и вывода их в таблицу результатов. Для ограничения выбора записей можно выбрать значение в таблице результатов и затем найти другие записи, соответствующие этому значению. Или создать конкретное условие в области условий и затем выбрать записи выполняющие только это условие.

Инструкции

Изучите использование условий

Выбор записей, соответствующих определенному значению

Задание условий для выбора записей

Примеры выражений, которые можно использовать в качестве условий


 Задание условий для выбора записей

Задание условий для выбора записей

  1. Нажмите кнопку Отображение условий [image] .

    Microsoft Query выведет на экран область условий.

  2. В области условий щелкните первую ячейку в строке Условие, а затем выберите поле, к которому будет применено условие.

    Если в запросе присутствует несколько таблиц с одинаковыми названиями полей, убедитесь, что поле выбрано из нужной таблицы.

  3. Выберите ячейку, расположенную непосредственно под полем, выбранным в строке Условие, из строки Значение.

  4. Введите условия, которые будут использоваться Microsoft Query для отбора записей, и нажмите клавишу ENTER.

    Инструкции

  5. При необходимости, добавьте имена полей, которые должны присутствовать в таблице результатов.

    Инструкции

    Для отображения записей из разных таблиц, эти таблицы должны быть добавлены в область таблиц запроса. Для получения дополнительных сведений о добавлении таблиц нажмите кнопку [image] .

Примечания

  • Таблица результатов может быть ограничена путем добавления в область условий дополнительных условий. Например, можно найти все записи о поставщиках молочных продуктов из Норвегии или Италии. Для выбора этих записей введите два набора условий в области условий. Сначала выберите значение Страна из списка Условие и введите Норвегия ИЛИ Италия в поле Значение. Затем выберите значение Категория в следующем поле Условие и введите =Молочные продукты в соответствующем поле Значение.

  • Если используемое в качестве условия значение уже содержится в таблице результатов, то его можно скопировать в область условий. Выберите нужное значение из таблицы результатов, выберите команду Копировать в меню Правка, щелкните ячейку, в которую нужно вставить значение, в строке Значение, а затем выберите команду Вставить в меню Правка.

  • Чтобы избежать длительной задержки при передаче данных из каждого поля, можно отложить передачу данных до завершения добавления всех полей в таблицу результатов. Чтобы отложить передачу данных, убедитесь, что кнопка Автоматический режим [image] не нажата. Для выполнения запроса нажмите кнопку Выполнить запрос [image] .

  • Для отмены запроса, занимающего слишком много времени, нажмите клавишу ESC.


 Выбор записей, соответствующих определенному значению

Выбор записей, соответствующих определенному значению

  1. Убедитесь, что кнопка Автоматический режим [image] нажата.

  2. Добавьте в область данных поле, для которого задаются условия.

    Инструкции

    Например, для выбора записей, значением поля "Страна" которых является "Франция", добавьте поле "Страна" в область данных.

  3. Выберите ячейку, содержащую сравниваемое с условием значение, в таблицу результатов.

  4. Нажмите кнопку Условие по выделенному [image] .


 Примеры выражений

Примеры выражений

Выражением называется вычисление, использующее сочетания операторов, функций, имен полей и констант. Для выбора записей используется выражение как условие. Для использования выражения в Области условия выберите поле в списке Условие, которое содержит значения для вычислений, а затем введите оператор и значение в поле Значение.

Выберите пример

Выражения, использующие арифметические операторы

Выражения, использующие операторы сравнения

Выражения, использующие логические операторы

Выражения, использующие прочие типы операторов

Не можете сделать выбор?


 Восстановление полной таблицы результатов путем удаления условий

Восстановление полной таблицы результатов путем удаления условий

Если запрос содержит много записей, то можно сэкономить время, отложив обновление таблицы результатов до полного удаления всех условий. Чтобы отложить обновление таблицы результатов, убедитесь, что кнопка Автоматический режим [image] не нажата.

  1. Щелкните заголовок столбца условий, которые нужно удалить, в области условий.

  2. Нажмите клавишу DELETE.

    Повторите пункты 1 и 2 для каждого набора условий, который нужно удалить.

    Чтобы удалить все условия, выберите команду Удалить все условия в меню Условия.

Примечание. Если кнопка Автоматический режим не нажата, то нажмите кнопку Выполнить запрос [image] , для того, чтобы восстановить полную таблицу результатов.


 Создание вычисляемого поля

Создание вычисляемого поля

При помощи создания нового поля, называемого вычисляемым полем, можно просматривать результаты заданных вычислений. Вычисляемое поле может быть создано путем введения выражения, являющегося вычислением, использующим сочетание операторов, функций, имен полей и констант. Для вычисления суммы значений полей воспользуйтесь встроенной функцией.

Инструкции

Создание вычисляемого поля с использованием выражения

Создание вычисляемого поля с использованием встроенных функций


 Создание вычисляемого поля с использованием выражения

Создание вычисляемого поля с использованием выражения

  1. Щелкните пустой заголовок столбца в области данных.

  2. Введите выражение для вычисления и нажмите клавишу ENTER. Выражение не должно начинаться со знака "равно" (=).

    Например, если служащие получают комиссионные, равные 15-ти процентам от общего объема продаж, то можно подсчитать комиссионные, полученные каждым служащим, путем суммирования всех продаж, сделанных этим служащим, и умножения суммы на 0,15.

    Для просмотра примеров выражений, использующих арифметические операторы, нажмите кнопку [image] .


 Примеры выражений, использующих арифметические операторы

Примеры выражений, использующих арифметические операторы

Арифметические операторы выполняют основные математические действия, например сложение, вычитание, умножение и деление и возвращают числовой результат. Арифметические операторы могут использоваться в выражениях области условий или в вычисляемых полях.

Арифметический операторАрифметический оператор | Значение | Пример | Синтаксис
+ (знак "плюс") | Сложение | Общая задолженность заказчика | Стоимость_заказа+ Стоимость_перевозки
– (знак "минус") | Вычитание | Полная стоимость заказа с учетом всех скидок | Стоимость_заказа-Скидка
* ("звездочка") | Умножение | Стоимость заказа на отдельное изделие | Цена_изделия* Количество
/ (наклонная черта) | Деление | Цена изделия | Стоимость_заказа/ Количество


 Создание вычисляемого поля с использованием функции

Создание вычисляемого поля с использованием функции

  1. Добавьте поле, содержащее значения, которые нужно просуммировать.

    Инструкции

  2. Щелкните поле, которое нужно просуммировать, и нажмите кнопку Выбор групповой операции [image] .

  3. Нажимайте кнопку Выбор групповой операции до тех пор, пока Microsoft Query не выведет нужный тип суммы.

    При каждом нажатии кнопки Выбор групповой операции Microsoft Query вычисляет и выводит сумму нового типа (используемая при этом функция отображается в заголовке столбца.) Для просмотра описаний функций, которые могут использоваться при создании сумм в вычисляемых полях, нажмите кнопку [image] .

  4. После выбора функции, создающей нужный тип суммы, нажмите кнопку Выполнить запрос [image] для вывода результатов в вычисляемом поле.

Примечания

  • Для удаления вычисления из поля нажимайте кнопку Выбор групповой операции до тех пор, пока в заголовке столбца не будет выведено исходное имя поля.

  • Если запрос содержит много записей, то можно сэкономить время путем задержки вывода результатов в вычисляемом поле до выбора нужной функции. Убедитесь, что кнопка Автоматический режим [image] не нажата.


 Функции, которые можно использовать в вычисляемых полях

Функции, которые можно использовать в вычисляемых полях

Функция возвращает значение, полученное в результате вычисления или другой операции. Например, функция СУММ возвращает сумму двух или более значений. Microsoft Query поддерживает следующие функции. Доступные для источника данных функции зависят от драйвера ODBC Для просмотра доступных для источника данных функций щелкните числовое поле и нажмите кнопку Выбор групповой операции [image] .

Для возврата этого значения | Используйте функцию
Среднее арифметическое набора значений полей | СРЗНАЧ
Общее число записей | СЧЕТ
Максимальное значение из набора | МАКС
Минимальное значение из набора | МИН
Сумма набора значений полей | СУММ


 Изменение таблицы результатов

Изменение таблицы результатов

После вставки полей или изменения порядка их расположения, эти изменения сохраняются при работе в Microsoft Query и передаче таблицы результатов в Microsoft Excel.

Инструкции

Изменение порядка расположения полей в таблице результатов

Вставка поля в таблицу результатов


 Форматирование данных в Microsoft Query

Форматирование данных в Microsoft Query

При сохранении запроса, Microsoft Query сохраняет изменения. Если данные были форматированы в Query, то форматирование не будет отображено в таблице результатов по возвращение её в Microsoft Excel. Если был изменен порядок полей запроса или таблицы результатов, то эти изменения будут сохранены по возвращении данных в Excel.

Инструкции

Изменение заголовка столбца

Изменение ширины столбца или высоты строк

Изменение шрифта, стиля или размера текста в таблице результатов

Скрытие или отображение поля в таблице результатов

Изменение таблицы результатов


 Переход к указанной записи таблицы результатов

Переход к указанной записи таблицы результатов

  1. Выберите команду Перейти в меню Записи.

  2. Введите номер записи, к которой нужно перейти.


 Сортировка записей в запросе

Сортировка записей в запросе

  1. Убедитесь, что кнопка Автоматический режим [image] нажата.

  2. Выберите поле, которое нужно отсортировать, в таблице результатов.

  3. Чтобы расположить записи в возрастающем порядке, нажмите кнопку Сортировка по возрастанию [image] .

    Для сортировки по убыванию нажмите кнопку Сортировка по убыванию [image] .

Примечания

  • Чтобы выполнить сортировку нескольких столбцов одновременно, расположите их слева направо в области данных в том порядке, в каком они должны быть отсортированы. Нажав SHIFT, выберите заголовки столбцов, чтобы выбрать те столбцы, которые необходимо отсортировать, и нажмите кнопку Сортировка по возрастанию или Сортировка по убыванию.

  • Для возврата к исходному порядку записей выберите в меню Записи команду Сортировка. Выберите из списка Сортировки в запросе поле, для которого требуется отменить сортировку, а затем нажмите кнопку Удалить.

  • При изменении расположения столбцов в таблице результатов после сортировки записей порядок сортировки не изменяется.


 Просмотр разных полей в запросе

Просмотр разных полей в запросе

  1. Выберите команду Показать столбцы в меню Формат.

  2. Чтобы временно запретить отображение столбца в области данных, выберите соответствующий столбец и нажмите кнопку Скрыть.

    Чтобы вывести столбец, щелкните название столбца и нажмите кнопку Показать.

Примечание. При передаче таблицы результатов в Microsoft Excel передаются все поля, включая скрытые. Чтобы отменить передачу скрытых полей в Microsoft Excel, удалите эти поля из области данных перед тем, как передать таблицу результатов в Microsoft Excel.


 Об изменении данных в базе данных, используемой для запроса

Об изменении данных в базе данных, используемой для запроса

Изменение базы данных, из которой загружаются данные. В некоторых случаях можно использовать Microsoft Query для изменения или для удаления данных во внешней базе данных . При изменении результатов запроса, Microsoft Query также изменяет данные в базовой таблице, которая используется для запроса.

Условия, при которых нельзя изменять базу данных. Нельзя изменять данные в базе данных, используемой для запроса, в следующих ситуациях:

  • Источник данных защищен от изменений или не допускает изменений.

  • Запрос содержит несколько таблиц.

  • Запрос содержит групповые операции или пользовательские выражения.

  • Изменяемое поле заблокировано, недоступно или находится в заблокированной записи.

  • Тип вводимых данных является запрещенным для базы данных. Значения, которые можно вводить в поле, зависят от того, в какую базу данных вносятся изменения.

  • Администратор базы данных запретил изменение содержимого базы данных.


Изменение содержимого базы данных, участвующей в запросе

Инструкции

См. сведения о внесении изменений в содержимое базы данных, участвующей в запросе

Изменение содержимого базы данных, участвующей в запросе

Удаление содержимого базы данных, участвующей в запросе

Отмена изменений базы данных, участвующей в запросе


Использование динамического обмена данными (DDE) в Microsoft Query

Microsoft Query поддерживает динамический обмен данными (DDE) между программами. DDE может использоваться в Visual Basic для приложений для связи и передачи данных между Microsoft Query и другой программой, например Microsoft Excel.

Инструкции

Инструкции по использованию DDE

Открытие канала DDE

Выполнение команд DDE

Команды DDE

Запрос состояния и других сведений

Доступ к данным

Выход из Microsoft Query с использованием DDE

Закрытие канала DDE

Использование Microsoft Query совместно с другими приложениями


Команды DDE

Для отображения ссылочной информации выберите команду или запрос.

Activate

AddParameters

AllowEdit

BuildODBC

BuildSQL

Close

Команда

EnableParameters

EnableTensor

Exit

Fetch и Fetch.Advise

Fetch.Unadvise

Logoff

Logon

LogonNow

ODBCLogon

Open

ParameterNames2

QueryNow

QueryType

SaveAs

SetParameterName

SetQueryName

SetQueryType

SetWindowState

UserControl

UserControl2

ViewPane


Как Microsoft Query обрабатывает даты 2000 года

Рекомендуется использовать четырехзначные года. Для обеспечения правильной загрузки и интерпретации значения года убедитесь, где это возможно, что значение года во внешних базах данных хранится в виде четырех цифр (2001 вместо 01).

Query и Microsoft Excel интерпретируют двузначные года одинаково. И Query, и Excel интерпретируют год, состоящий из двух цифр, одинаково. Данные, которые содержат значения года в виде двух цифр, при просмотре в Query и после их передачи в Excel, значения будут одинаковыми в обоих программах.

Как Query интерпретирует двузначные года. При загрузке двузначного года из внешней базы данных, Query интерпретирует год следующим образом:

  • Значения года с 00 по 29. Двузначные значения года с 00 по 29 интерпретируются как года с 2000 по 2029. Например, если Query загружает из внешней базы данных дату 28.05.19, то дата будет интерпретирована как 28 мая 2019 г.

  • Значения года с 30 по 99. Двузначные значения года с 30 по 99 интерпретируются как года с 1930 по 1999. Например, если Query загружает из внешней базы данных дату 28.05.99, то дата будет интерпретирована как 28 мая 1998 г.

Возможность выбора способа интерпретации даты администратором. Правила интерпретации дат в Microsoft Office могут быть настроены системным администратором. Например, если в качестве наименьшего значения года, до которого даты рассматриваются как будущие, по умолчанию используется 29, администратор может выбрать другое число (оно должно состоять из двух цифр). Для того, чтобы узнать, как настроена интерпретация, свяжитесь с системным администратором. Дополнительные сведения по этому вопросу можно найти в издании «Ресурсы Microsoft Office 2000» (Microsoft Office 2000 Resource Kit).


Разрешение вопросов: Microsoft Query

Инструкции

Создание и использование источников данных

Невозможно создать новый источник данных.

Невозможно найти или удалить источник данных.

Почему источник данных помечен звездочкой?

Ранее используемый драйвер ODBC не работает.

Создание запросов

Не удается найти нужную таблицу

Невозможно создать требуемый тип объединения.

При использовании объединений не возвращаются те записи, которые ожидались.

Невозможно изменение типов параметров процедуры SQL в Microsoft Query.

Невозможно редактирование запроса.

Получение данных

Выводится сообщение о том, что задан неверный путь к базе данных

Microsoft Query не может подключиться к базе данных в течение заданного интервала времени.

Невозможен доступ к данным списка Microsoft Excel в Microsoft Query.

Microsoft Query продолжает использовать ресурсы связи, даже когда я не работаю с базой данных.

Microsoft Query не возвращает все доступные записи.

Работа в Microsoft Query

Не удается продолжить работу с Microsoft Query

Изменения запроса не отображаются при его следующем выполнении.

Microsoft Query не может напечатать таблицу результатов.

Невозможно создать почтовые наклейки в Microsoft Query.

Таблица результатов не может быть сохранена как таблица базы данных.

Невозможно добавить, копировать или переместить запись в базе данных.


Разрешение вопросов: запросы и кубы OLAP

Инструкции

Чтобы в итоге данные куба были недоступны.

Поля даты или времени повреждены или неверны.

Недостаточно места на диске при попытке сохранения автономного куба.

Невозможно добавить поля в куб OLAP.

Невозможно изменить куб OLAP.

В момент изменения куба OLAP, получено сообщение о потере данных.

Получено сообщение о невозможности открытия .oqy файла мастером создания куба OLAP.


Невозможно выполнить запрос. Показать инструкцию SQL?

Microsoft Query не может выполнить инструкцию SQL, так как инструкция SQL ссылается на недоступный в настоящее время объект. Например, она может ссылаться на несуществующую таблицу. Для просмотра инструкции SQL и внесения необходимых изменений нажмите кнопку OK.


Об использовании условий

Что такое условие
Выполнение одиночного условия
Выполнение нескольких условий
Поиск похожих записей
Выбор диапазона значений
Использование вычислений
Исключение определенных записей
Поиск незавершенных записей


Об использовании условий


Об извлечении внешних данных с помощью Microsoft Query

Что такое Microsoft Query?
Настройка источников данных
Определение запросов
Работа с данными в Microsoft Excel


Извлечение внешних данных с помощью Microsoft Query


Таблица <имя> уже в запросе; добавить еще раз?

Попытка добавить в область таблиц уже присутствующую в ней таблицу.

  • Чтобы добавить таблицу для создания внутреннего объединения, нажмите кнопку OK.

  • Чтобы отменить добавление таблицы, нажмите кнопку Отмена.


Ошибка в формате данных; вставка невозможна

Microsoft Query не может вставить данные из буфера обмена из-за недостатка свободной памяти.

Попытайтесь закрыть другие приложения или другие окна в Microsoft Query. Если ошибка повторяется, перезапустите Microsoft Windows и повторите копирование и вставку.


Невозможно сохранить в файл, который уже открыт.

Файл, в который производится сохранение, открыт. Перед сохранением в файл закройте его.


Другое приложение занято.

Другая программа — участник сеанса динамического обмена данными (DDE) — занята и не может выполнить запрашиваемую операцию DDE. Подождите, пока программа не освободится.


Требуется BY после GROUP.

Инструкция SQL содержит выражение "GROUP" вместо "GROUP BY". Окончание "BY" неправильно введено или отсутствует.


Требуется BY после ORDER.

Инструкция SQL содержит выражение "ORDER" вместо "ORDER BY". Окончание "BY" неправильно введено или отсутствует.


Невозможно открытие буфера обмена

Буфер обмена не отвечает, так как он, возможно, используется другим приложением. Закройте это приложение и повторите операцию.


Невозможно открыть файл <имя>

Microsoft Query не может открыть или прочитать указанный файл, или файл не был сохранен. Возможно, произошел сбой диска или файл поврежден.


Невозможен запуск Microsoft Query. Повторите попытку

Произошла системная ошибка или недостаточно памяти для запуска Microsoft Query.

Повторно запустите Microsoft Query или закройте другие приложения. Если ошибка повторяется, перезапустите Microsoft Windows и повторите операцию.


Столбец <имя> не может использоваться с оператором <оператор>.

Источник данных не разрешает использование поля данного типа вместе с указанным оператором. Чтобы определить, какие операторы могут использоваться с полями этого типа данных, обратитесь к документации на источник данных.


Столбец <имя> не может быть использован в условии.

Для столбца (поля) этого типа данных не могут быть заданы условия.


Невозможен вывод справки из-за недостатка памяти, неправильной установки Windows или Microsoft Query.

Чтобы освободить память, закройте окна или приложения. При необходимости выполните повторную установку Microsoft Windows или Microsoft Query.


Вставка невозможна

Буфер обмена не отвечает. Он может использоваться другой программой, данные из него могут иметь формат, несовместимый с Microsoft Query, или недостаточно памяти для вставки данных.

Попытайтесь закрыть другие приложения или другие окна в Microsoft Query. Если ошибка повторяется, перезапустите Microsoft Windows и повторите копирование и вставку.


Невозможно завершить работу Microsoft Query

Microsoft Query производит динамический обмен данными (DDE) с другим приложением. Подождите завершения операции DDE, а затем завершите работу с Microsoft Query.


Невозможно показать условие.

Неправильно задано условие.


Невозможно добавить выражение <имя> в список сортировки.

Используемый источник данных не разрешает сортировку полей, содержащих результаты выражения.


Невозможно применение статистических функций к таблицам.

Вместо указания конкретного поля, для которого нужно выполнить групповые операции, в качестве параметра в поле Поле введена звездочка (*). Удалите символ "*" и введите имя поля.


Невозможно задать * в качестве поля. Для добавления всех полей перетащите * в бланк запроса.

В ячейке Поле области условий введена звездочка (*). Вместо этого при задании условий для всех полей запроса используйте один из следующих способов:

  • Перетащите "*" из таблицы в область условий.

  • Дважды щелкните звездочку в таблице.

  • Вручную добавьте каждое поле.


Функция <имя> не может использоваться в <имя столбца>.

Выбрана функция, которая не может быть использована для вычислений с полем этого типа данных. Например, невозможно вычислить среднее значение поля "Страна назначения", если оно содержит текст.


Формат буфера обмена не поддерживается

Формат данных из буфера обмена несовместим с Microsoft Query.


Некоторые запросы используют <имя соединения>, закрыть?

Удаляемый источник данных используется одним или несколькими запросами.

  • Чтобы удалить источник данных и закрыть запросы, нажмите кнопку OK.

  • Чтобы оставить источник данных в списке, а запросы открытыми, нажмите кнопку Отмена.


Удалить следующее число записей: <число>?

Запрошено удаление указанного числа записей.

Примечание. Если число записей больше заданного, то Microsoft Query были найдены одинаковые по полям в области данных записи. Чтобы избежать повторения записей, перед удалением добавьте все поля в область данных.

  • Чтобы удалить записи, нажмите кнопку OK.

  • Для отмены удаления нажмите кнопку Отмена.


Найдено следующее число подходящих записей: <число>. Удалить?

Так как область данных не содержит поле, однозначно описывающее каждую запись, например "Номер заказчика" или "Номер заказа", в таблице результатов есть другие записи, совпадающие с той, которую нужно удалить. При удалении выбранной записи Microsoft Query удалит все одинаковые с ней записи.

Чтобы различать записи перед изменением данных, убедитесь, что выбраны все поля таблицы или для нее создан уникальный индекс.


Будет обновлено записей: <число>

В области данных содержатся другие записи, совпадающие с измененной. Microsoft Query автоматически внесет те же изменения в совпадающие записи.

  • Чтобы избежать повторения записей в области данных, перед изменением данных добавьте в нее все поля.

  • Чтобы обновить записи, нажмите кнопку OK.

  • Для отмены обновления нажмите кнопку Отмена.


Невозможно создать файл.

Microsoft Query не может создать указанный файл запроса. Возможно, произошел сбой диска или файл поврежден.


Таблица <имя> создана.

Microsoft Query была создана таблица, указанная в описании источника данных.


Невозможно создать уникальный индекс. Создать индекс вручную?

Microsoft Query не может создать уникальный индекс для этой таблицы, несмотря на то, что таблица результатов, которую нужно сохранить как новую таблицу, получена из имеющей уникальный индекс таблицы.

  • Чтобы вывести диалоговое окно Создание индекса для создания уникального индекса таблицы, нажмите кнопку Да.

  • Чтобы отменить создание уникального индекса, нажмите кнопку Нет.


Указанная длина должна быть больше нуля.

Длина, заданная в поле Длина диалогового окна Просмотр определения таблицы, должна быть больше 0 (нуля).


 Команда Activate (DDE)

Команда Activate (DDE)

Активизация указанного окна запроса. Эта команда используется для смены активного окна, когда открыто несколько окон. Она доступна только в системном канале.

Синтаксис

Activate(имя запроса)

имя запроса Имя активизируемого окна запроса.

Пример

В этом примере выполняется два запроса, которые создают два окна запроса. После выполнения второго запроса, делается активным окно, созданное первым запросом.

DDEExecute chan, "[BuildSQL('Select * From ЗАКАЗЧИКИ')]"
DDEExecute chan, "[QueryNow()]"
stQueryname1 = DDERequest(chan, "Запрос")
DDEExecute chan, "[BuildSQL('Select * From ЗАКАЗЫ')]"
DDEExecute chan, "[QueryNow()]"
stQueryName2 = DDERequest(chan, "Запрос")
DDEExecute chan, "[Activate('" & stQueryname1(1) & "')]"


Команда AddParameters (DDE)

Добавление параметров в активный запрос для использования в сводных таблицах.

Синтаксис

AddParameters(поле1, поле2, …)

поле1, поле2, … Имена столбцов таблицы, которые должны быть добавлены в качестве параметров к условиям. Имена новых параметров становятся именами полей. Если задаваемое имя не может быть использовано в активном запросе, возникает ошибка.

Замечания

AddParameters может использоваться даже в том случае, когда ввод параметров в Microsoft Query запрещен.

Измененная строка SQL может быть получена при запросе элемента ODBCSQLStatement.

Для восстановления параметров необходимо восстановление всей строки SQL.


 Команда AllowEdit (DDE)

Команда AllowEdit (DDE)

Определение возможности внесения изменений в окне запроса. Команда доступна как в системном канале, так и в канале запроса. Эквивалентна команде Разрешить правку в меню Записи.

Синтаксис 1

AllowEdit(разрешитьправку, отменитьправку)

Синтаксис 2

Allow.Edit(разрешитьправку, отменитьправку)

Обе формы синтаксиса равноправны.

разрешитьправку Определение возможности внесения изменений в окне запроса. Аргумент может принимать значения True или False.

отменитьправку Отключение команды Разрешить правку в меню Записи во время действия команды UserControl. Аргумент может принимать значения True или False.

Пример

В примере выполняется предварительно созданная инструкция SQL, после чего в Microsoft Query посылаются команды AllowEdit и UserControl. В результате этого пользователь имеет возможность просматривать, но не изменять данные в источнике данных (команда меню Разрешить правку становится неактивной после выполнения команды UserControl).

DDEExecute chan,"[BuildSQL(""" & sql & """)]")
DDEExecute chan,"[QueryNow()]")
DDEExecute chan,"[AllowEdit(False, True)]")
DDEExecute chan,"[UserControl(""&Данные"", 3, False)]")


Команда BuildODBC (DDE)

Пошаговое построение строки соединения произвольной длины.

Синтаксис

BuildODBC([стрсоедин])

стрсоедин Сегмент допустимой строки соединения. Если стрсоедин равен 0 (нулю) или опущен, строка соединения очищается.


 Команда BuildSQL (DDE)

Команда BuildSQL (DDE)

Пошаговое построение инструкции SQL для создания запроса в канале DDE. Команда доступна только в системном канале.

Синтаксис

BuildSQL[(SqlText)]

SqlText Допустимая инструкция SQL. Если аргумент SqlText не задан или равен 0 (нулевой), инструкция SQL очищается.

Замечания

Команда BuildSQL удобна при создании длинных инструкций SQL. Например, если инструкция SQL настолько длинная, что не может быть отправлена в виде отдельного оператора, она может быть отправлена по частям.

После построения инструкция SQL может быть выполнена при помощи команды QueryNow.

Пример

В данном примере показывается использование элемента QueryDefinition, чтобы получить инструкцию SQL для запроса.

sql = DDERequest(chan,"QueryDefinition")

В этом примере команда BuildSQL используется для повторной отправки полученной строки SQL с дополнительным оператором WHERE.

DDEExecute chan, "[BuildSQL(""" & sql & """)]"
DDEExecute chan, "[BuildSQL("WHERE Фрахт > 10")]"
DDEExecute chan, "[QueryNow()]


 Команда Close (DDE)

Команда Close (DDE)

Закрытие текущего запроса. Команда доступна как в системном канале, так и в канале запроса.

Синтаксис

Close( )


 Закрытие канала DDE

Закрытие канала DDE

Для закрытия канала DDE используется метод DDETerminate. Этот метод принимает только один аргумент — номер закрываемого канала DDE. Все запросы, открытые на данном канале, при использовании DDETerminate автоматически закрываются и происходит отсоединение от всех источников данных.

При использовании неверного номера канала возвращается ошибка.


 Команда Command (DDE)

Команда Command (DDE)

Передача команды Open в Microsoft Query. Эта команда предназначена для использования в программах, для которых установлено ограничение длины строк, используемых с DDEExecute.

Команда доступна только в системном канале.

Синтаксис

Command(режим, выпстрока)

режим Определение способа получения команд Microsoft Query. Аргумент может принимать следующие значения.

Значение | Описание
1 | Инициализация буфера в Microsoft Query строкой выпстрока (с очисткой существующего буфера). Запрос при этом не выполняется.
2 | Добавление выпстрока в конец буфера.
3 | Добавление выпстрока в конец буфера и выполнение команд буфера. Поскольку после выполнения буфер команд очищается, повторное выполнение выпстрока невозможно.

выпстрока Фрагменты команды Open. Вся строка должна быть заключена в одинарные или двойные кавычки.

С использованием команды Command в Microsoft Query может быть отправлена только команда Open.

Замечания

Эта команда предусмотрена только для совместимости Q+E. Для посылки длинных инструкций SQL рекомендуется по возможности использовать команду BuildSQL.


Команда EnableParameters (DDE)

Определение возможности задания пользователем параметров в области условий и окна SQL. По умолчанию параметры задаваться не могут. Задание параметров не может быть отменено, после того, как оно было выполнено пользователем.

Синтаксис

EnableParameters(флаг)

флаг Определение возможности задания параметров пользователем. Если указано значение 0 (ноль), пользователь не может задавать параметры, а если 1 - может.


 Команда EnableTensor (DDE)

Команда EnableTensor (DDE)

Показывает какая из программ, в которую передаются данные, поддерживает источники данных OLAP. Данная команда доступна только в системном канале.

Синтаксис

EnableTensor(флаг)

флаг Если указано значение TRUE, то источник данных OLAP будет возвращен в программу-приемник. Если значение отсутствует или указано FALSE, то в программу-приемник будет возвращен источник данных, отличный от OLAP.


Выполнение команд DDE

При помощи DDEExecute команда может быть передана в Microsoft Query. Команды являются специфичными для Microsoft Query и могут не совпадать с командами меню Microsoft Query. Например, команды Открыть и Сохранить как выполняют те же функции, что и соответствующие команды меню Microsoft Query, но команды ODBCLogon и UserControl нет. Для получения списка доступных команд нажмите кнопку [image] .

Инструкция DDEExecute принимает два аргумента.

Аргумент | Описание
канал | Значение канала DDE, возвращаемое DDEInitiate.
команда | Команда, посланная Microsoft Query.

Чтобы пользователь мог строить запросы в Microsoft Query, выполняется команда UserControl. В следующем примере показано присвоение команде My Exit Command функций команды Выход в меню Файл Windows.

DDEExecute Chan,"[UserControl('&Выход',3,True)]"

Значение канала DDE ранее было присвоено переменной Chan, а командой, посылаемой Microsoft Query, является UserControl. Обратите внимание на то, что команда UserControl и ее аргументы заключены в двойные кавычки ( " " ) и квадратные скобки ( [ ] ).


 Команда Exit (DDE)

Команда Exit (DDE)

Завершение Microsoft Query. Команда доступна только в системном канале.

Синтаксис

Exit(завершить)

завершить Завершение Microsoft Query при наличии открытых запросов на каналах, кроме канала, выполняющего команду Exit. Аргумент может принимать значения True или False.

Значение True используется для завершения Microsoft Query независимо от наличия открытых запросов. При пользовательском управлении Microsoft Query с использованием другого канала (в результате выполнения команды UserControl), данное значение параметра приводит к закрытию канала и передаче управления приложению, запустившему Microsoft Query под управлением пользователя.

Значение False используется для завершения Microsoft Query только при условии, что все открытые запросы были открыты на канале, выполняющем команду Exit.

Замечания

Эта команда DDE используется также для завершения Microsoft Query на Macintosh.


Выход из Microsoft Query с использованием DDE

Для выхода из Microsoft Query приложение может использовать команду Exit вместо выполнения пользователем команды Выход в меню Файл.

Команда | Описание
Exit (Ложь) | Выход из Microsoft Query только при условии отсутствия открытых запросов на других каналах
Exit (Истина) | Выход из Microsoft Query независимо от наличия других открытых запросов


 Команды Fetch и Fetch.Advise (DDE)

Команды Fetch и Fetch.Advise (DDE)

Команда Fetch извлекает данные из Microsoft Query и передает их непосредственно в приложение.

Команда Fetch.Advise выполняет автоматическое обновление в приложении при изменении значений в Microsoft Query, а не в момент отправки команды Fetch.Advise.

Команды доступны как в системном канале, так и в канале запроса.

Синтаксис 1

Fetch.Advise(имяприл, раздел, область, значения)

Синтаксис 2

Fetch(имяприл, раздел, область, значения)

имяприл Имя программы, в которую передаются данные. Для приложений Office аргументы имяприл могут принимать следующие значения:

Приложение | Значение
Microsoft Access | MSAccess
Microsoft Excel | Excel
Microsoft Word | WinWord

раздел Имя таблицы, документа или элемента управления, которым передаются данные.

область Область в таблице, документе, элементе управления, которым передаются данные.

значения Значения, получаемые из Microsoft Query. (Допустимые значения для этого аргумента перечислены в приведенной ниже таблице).

Примечание. Команда Fetch.Advise выполняет автоматическое обновление только данных запроса, а не элементы или ссылки стр#кол#.

Допустимые значения аргумента.

Значение | Описание
Request_item | Тип возвращаемых данных; например, QueryDefinition.
стр#кол# | Ссылка для нахождения указанных строк и столбцов, например, R3C5 в Microsoft Excel.
/Headers | Загрузка имен столбцов.
/Rownum | Номера строк.
All | Загрузка всех записей.

Замечания

При использовании команды Fetch.Advise канал, созданный для возврата данных в приложение, не закрывается, пока не будет послана команда Fetch.Unadvise или Close.

Пример

В данном примере показано использование требуемых элементов NumRows и NumCols для получения количества строк и столбцов в запросе и передачи этих значений с заголовками столбцов в таблицу Microsoft Excel "Лист1."

rows=ЗАПРОС(Chan,"NumRows")
cols=ЗАПРОС(Chan,"NumCols")
DDEExecute chan, "[Fetch(""Excel"", ""Data.xls!Лист1"", _
        ""R1C1:R"&строки&"C"&столбцы&""", ""All/Headers"")]"


Доступ к данным

В то время как DDERequest возвращает данные в программу, команды Fetch и Fetch.Advise заслуживают специального упоминания, так как они получают данные из Microsoft Query и передают их непосредственно в лист книги или документ. Fetch и Fetch.Advise используются в качестве аргументов DDEExecute.

Команда Fetch.Advise аналогична Fetch с тем исключением, что канал, созданный при первой передаче данных, не закрывается сразу. Microsoft Query продолжает пересылать любые изменения данных до тех пор, пока не закроется исходный канал DDE или Microsoft Query не получит команду Fetch.Unadvise.


 Команда Fetch.Unadvise (DDE)

Команда Fetch.Unadvise (DDE)

Отмена автоматического обновления, установленного командой Fetch.Advise и закрытие канала, открытого Microsoft Query для передачи данных приложению. Команда доступна как в системном канале, так и в канале запроса.

Примечание Аргументы команды Fetch.Unadvise должны совпадать с аргументами, которые перед этим использовались командой Fetch.Advise.

Синтаксис

Fetch.Unadvise(имяприл, раздел, область, значения)

имяприл Имя программы, которой передаются данные. (См. команду Fetch.Advise).

раздел Имя таблицы, документа или элемента управления, которым передаются данные.

область Область в таблице, документе, элементе управления, которым передаются данные.

значения Значения, получаемые из Microsoft Query. (Таблица допустимых значений аргумента приводится в описании команды Fetch.Advise).


Несовместимая версия <имя файла>. Запуск Microsoft Query невозможен

Используется устаревшая версия файла "Ddeml.dll" или файл отсутствует. Попытайтесь переустановить Microsoft Query или Microsoft Windows.


 Команда Logoff (DDE)

Команда Logoff (DDE)

Отсоединение указанного источника данных. Команда доступна только в системном канале.

Синтаксис

Logoff(источник)

источник Имя источника данных, от которого требуется отсоединиться.


 Команда Logon (DDE)

Команда Logon (DDE)

Отображение диалогового окна, позволяющего подсоединиться к источнику данных. Команда доступна только в системном канале.

Синтаксис

Logon(источник)

источник Имя источника данных, к которому необходимо подсоединиться.


 Команда LogonNow (DDE)

Команда LogonNow (DDE)

Если для построения строки соединения использовалась команда BuildODBC, данная команда выполняет подсоединения, используя строку соединения из буфера. Если буфер не содержит строки соединения, возникает ошибка.

Синтаксис

LogonNow([диалог])

диалог Отображение диалогового окна при подсоединении. Аргумент может принимать следующие значения.

Значение | Описание
0 (ноль) | Окна диалога не отображаются. Если аргумент опущен, используется значение по умолчанию 0 (ноль).
1 | Отображаются окна диалога для получения от пользователя дополнительных сведений, не предусмотренных строкой соединения.
2 | Отображаются окна диалога со значениями из строки соединения, введенные, как значения по умолчанию.
3 | То же, что 1, но сведения, которые не являются обязательными для соединения с источником данных, отображаются затененными.


 Команда ODBCLogon (DDE)

Команда ODBCLogon (DDE)

Подсоединение приложения к источнику данных. Можно указать, будут ли при подсоединении отображаться диалоговые окна. Команда доступна только в системном канале.

Синтаксис

ODBCLogon(стрсоедин, диалог)

стрсоедин Строка, содержащая данные (например, имя источника данных, идентификатор пользователя и пароль), необходимые драйверу для соединения с источником данных. Этот аргумент должен иметь формат, требуемый используемым драйвером. (Дополнительные сведения о строке соединения приводятся в документации по программе, которая является источником данных).

Примечание. В связи с тем, что Microsoft Query использует файлы DSN, элемент ConnectionString может использоваться для получения строки соединения без DSN для запроса, созданного из файла DSN. Впоследствии эта строка соединения может быть использована для восстановления соединения с источником данных с любого компьютера.

диалог Отображение диалогового окна при подсоединении. Аргумент может принимать следующие значения.

Значение | Описание
0 (ноль) | Диалоговые окна не отображаются.
1 | Отображаются диалоговые окна для получения от пользователя дополнительных сведений, не предусмотренных строкой соединения.
2 | Отображаются диалоговые окна со значениями из строки соединения, введенные, как значения по умолчанию.
3 | То же, что 1, но сведения, которые не являются обязательными для соединения с источником данных, отображаются затененными.

Пример

В примере показано использование элемента ConnectionString для получения строки, необходимой для соединения с источником данных. Эта строка сохраняется после того, как пользователь подсоединился к источнику данных, после чего используется команда ODBCLogon для соединения с источником данных без ввода данных пользователем.

connstr = DDERequest(chan, "ConnectionString")
' intervening code
DDEExecute chan, "[ODBCLogon (connstr(1), 0)]"


 Открытие канала DDE

Открытие канала DDE

Для открытия канала DDE используется метод DDEInitiate. Функция DDEInitiate принимает два аргумента: имя программы-источника и раздел сеанса DDE. Именем Microsoft Query является "MSQuery".

Разделы Microsoft Query могут быть следующими.

Раздел | Описание
query_window_name | Имя открытого окна запроса. Имя окна может быть указано только при условии, что загружено приложение Microsoft Query и окно открыто.
System | Общий раздел, позволяющий программе-приемнику установить связь с Microsoft Query, а не с окном запроса, файлом или инструкцией SQL SELECT.

При получении Microsoft Query запроса на открытие сеанса DDE по известному разделу возвращается ответ и открывается канал. Метод DDEInitiate возвращает номер канала DDE, который может быть присвоен переменной и использован для выполнения последующих операций на канале.

Для открытия нескольких окон на одном канале используйте раздел "System". При использовании раздела "System" для открытия канала DDE могут быть развернуты только окна, открытые на этом канале.


 Команда Open (DDE)

Команда Open (DDE)

Открывает и выполняет запрос, отображает данные в области данных. Команда доступна только в системном канале.

Синтаксис

Open(запрос)

запрос Имя файла Microsoft Query (для Windows файл имеет расширение .dqy) или Q+E (только для Windows файл имеет расширение .qef), который содержит запрос или SQL инструкцию SELECT.

Пример

В примере демонстрируется открытие запроса «Продажи».

DDEExecute chan, "[Open(""c:\msquery\sales.dqy"")]")

Такой же пример, но для Macintosh.

DDEExecute chan, "[Open(""drivename:msquery:sales"")]")

Для выполнения нового запроса это предложение использует инструкцию SQL SELECT

DDEExecute chan, "[Open(""SELECT * FROM pubs.dbo.titles"")]")


 Запрос ParameterNames2 (DDE)

Запрос ParameterNames2 (DDE)

Возвращает сведения о параметрах запроса. Данный запрос доступен только в системном канале.

Синтаксис

ParameterNames2( )

Для каждого параметра ParameterNames2 возвращает имя, тип данных и максимально часто используемое значение. ParameterNames2 возвращает массив из трех столбцов по N строк в формате xlTable. Например как:

Столбец 1 | Столбец 2 | Столбец 3
Имя параметра | Тип данных колонки | Если возможно установить, то максимально часто используемое значение параметра, иначе пусто.

Для получения дополнительной информации о формате xlTable обратитесь к справочной системе Visual Basic для Microsoft Excel.

Запрос к ParameterNames2 может быть произведен в любое время, даже если параметры для данного запроса отключены командой EnableParameters. Если у запроса отсутствуют параметры, то ParameterNames2 возвратит пустой массив.


 Команда QueryNow (DDE)

Команда QueryNow (DDE)

Выполнение активного запроса в открытом канале DDE. При использовании команды BuildSQL для построения запроса эта команда выполняет предложение SQL в буфере и открывает окно запроса. Команда доступна как в системном канале, так и в канале запроса.

Синтаксис

QueryNow( )

Пример

Пример иллюстрирует сохранение инструкции SQL из запроса и отправку этой инструкции для повторного выполнения запроса.

sql = DDERequest(Chan, "QueryDefinition")
DDEExecute chan, "[BuildSQL(""" & sql & """)]"
DDEExecute chan, "[QueryNow()]"


 Запрос QueryType (DDE)

Запрос QueryType (DDE)

Возвращает сведения об источнике данных для запроса. Данный запрос доступен только в системном канале.

Синтаксис

QueryType( )

Запрос QueryType возвращает массив из двух элементов в формате xlTable. Первый элемент содержит в себе тип запроса: ODBC или OLE/DB. Второй — тип команд допустимых источником данных: SQL, Cube или Cancel. Например как:

QueryType | CommandType | Описание
ODBC | SQL | Источник данных — SQL-совместимый ODBC.
OLEDB | Cube | Источник данных — куб OLAP. Имя куба содержится в инструкции SQL.
ODBC | Cancel | Запрос отменен и возвращен в программу-приемник.

Для получения сведений о формате xlTable обратитесь к справочной системе Visual Basic для Microsoft Excel.

Используйте запрос QueryType только как первый запрос после завершения выполнения команды UserControl2.

Если QueryType показывает, что источник данных куб OLAP, то возможно использование запросов ODBCSQLStatement и ConnectionString для загрузки информации источника данных. Изучите использование DDE запросов.


 Запрос состояния и других сведений

Запрос состояния и других сведений

После открытия канала DDE в Microsoft Query можно вернуть таблицу результатов или другие данные при помощи DDERequest.

Метод DDERequest принимает два аргумента.

Аргумент | Описание
channel | Значение канала DDE, возвращаемое DDEInitiate.
request_item | Данные, которые нужно вернуть. Это может быть содержимое поля или группы полей в окне запроса, или другие данные, например число записей в окне запроса.

Запрашивать объекты можно как по каналу запросов, так и по системному каналу. По каналу запросов можно вернуть только сведения о запросе, например число строк (столбцов) или описание запроса. По системному каналу можно передать общие сведения о Microsoft Query, например текущие сеансы связи, имена разделов и состояния программ, а также данные, специфичные для активного запроса.

Запрашиваемые по каналу запросов или по системному каналу для текущего запроса объекты могут быть следующими.

Запрашиваемый объект | Возвращаемые данные
ColumnTitles | Массив заголовков столбцов. Заголовок столбца совпадает с именем поля, если он не был изменен пользователем в Microsoft Query.
ConnectionString | Массив сегментов строк связи (каждая длиной до 255 символов), из которого получается строка связи с активным окном запроса. Если запрос был создан файловым источником данных (DSN), то возвращается строка связи без имени источника.
ConnectionString/n | Массив сегментов строк связи (каждая длиной до n символов), из которого получается строка связи с активным окном запроса. Если запрос был создан файловым источником данных (DSN), то возвращается строка связи без имени источника.
DataSourceName | Имя источника данных (DSN), используемое активным запросом.
ErrorText | Текст сообщения об ошибке (если была), возникшей при выполнении последней инструкции SQL. Этот объект может запрашиваться несколько раз для получения сведений обо всех имевших место ошибках. После получения данных обо всех ошибках объект возвращает пустую строку. Если последняя инструкция SQL была выполнена успешно, то возвращается нулевая строка, даже если предыдущие инструкции не были выполнены успешно.
FieldDef | Массив значений, описывающих выражения и типы данных из столбцов (полей) в окне запроса. Каждая строка массива описывает поле в запросе. В массив в виде столбцов возвращаются следующие данные: имя поля, тип данных Q+E поля, ширина поля, точность значения поля и тип данных SQL.
GetUniqueItems | Массив элементов, уникальных для данного столбца результатов. Запрашиваемый объект должен быть порядковым номером столбца (начиная с нулевого), добавленным к строке "GetUniqueItems" (например, уникальные объекты из второго столбца возвращаются при помощи "GetUniqueItems1"). Объекты, не включенные в запрос, не могут быть запрошены. Этот объект возвращает то же значение, что и инструкция SELECT DISTINCT для запрашиваемого столбца при условии действия всех объединений и условий. Любые условия, использующие параметры, не учитываются.
NameSeparator | Одиночный символ, используемый в качестве разделителя имен ODBC.
NumCols | Число столбцов (полей) в запросе.
NumRows | Число строк (записей) в запросе.
ODBCSQLStatement | Массив сегментов SQL (каждый длиной до 255 символов), из которого получается инструкция ODBC SQL для запроса. При помощи этой строки можно передавать инструкции ODBC SQL непосредственно для обработки ODBC, минуя Microsoft Query.
ODBCSQLStatement/n | Массив сегментов SQL (каждый длиной до n символов), из которого получается инструкция ODBC SQL для запроса. Этот объект может использоваться для хранения инструкции ODBC SQL в нескольких сегментах меньшей длины.
ParameterNames | Массив параметров запроса. При отсутствии параметров возвращается пустой массив. Этот объект может быть запрошен в любое время, даже если у запроса нет параметров.
Query | Имя запроса.
QueryDefinition | Массив сегментов описаний запросов (каждый длиной до 255 символов), из которого получается описание запроса (инструкция SQL), заданное Microsoft Query. Этот объект можно сохранить для последующих запросов.
QueryDefinition/n | Массив сегментов описаний запросов (каждый длиной до n символов), из которого получается описание запроса (инструкция SQL).
Recest | Примерная оценка числа строк, которые можно получить одновременно.
TierType | Единичное число, указывающее тип источника данных: 1 указывает на файл, содержащий только одну таблицу; 2 указывает на файл базы данных, содержащий одну или несколько таблиц; 3 указывает на то, что данные недоступны для просмотра. Этот объект используется программой при открытии окна "Открытие документа" для просмотра содержимого диска.

При использовании перечисленных объектов на системном канале данные возвращаются для окна запроса, который последним использовался при выполнении операций DDE.

Для системного канала дополнительно можно запрашивать следующие объекты.

Запрашиваемый объект | Возвращаемые данные
Database/source | Все базы данных для указанного соединения с источником. При этом имя источника должно являться допустимым именем DSN.
Logoff | Все удаленные базы данных, с которыми установлена связь (только DSN).
Logon | Все удаленные базы данных, с которыми можно установить соединение (элементы DSN из реестра).
Sources | Все связи с источниками данных (только DSN).
Status | Состояние программы ("Готов" или "Занят"). "Готов" означает, что программа может участвовать в сеансе DDE с Microsoft Query. "Занят" означает, что Microsoft Query не может в данный момент открыть сеанс DDE.
Tables/source/user/database | Все таблицы для указанного соединения с источником, пользователя и базы данных. При этом имя источника должно являться допустимым именем DSN.
Topics | Названия разделов, открытых на системном канале, включая раздел "System".
Username/source/database | Имя пользователя для указанного соединения с источником и базы данных. При этом имя источника должно являться допустимым именем DSN.
Users/source/database | Все пользователи для указанного соединения с источником и базы данных. При этом имя источника должно являться допустимым именем DSN.

В данном примере значение, возвращаемое объектом NumRows, вставляется в ячейку A10 Microsoft Excel.

ActiveWorksheet.Range("A10").Value = DDERequest(chan, "NumRows")


 Команда SaveAs (DDE)

Команда SaveAs (DDE)

Сохранение конструкции нового или существующего запроса с другим именем. Действие аналогично выполнению команды Сохранить как в меню Файл. Команда доступна как в системном канале, так и в канале запроса.

Синтаксис 1

SaveAs(имязапроса)

Синтаксис 2

Save.As(имязапроса)

Обе формы синтаксиса равноправны.

имязапроса Новое имя запроса.


Команда SetParameterName (DDE)

Задание имени параметра, получаемого через передаваемую в Microsoft Query строку запроса. SetParameterName должна посылаться после команды BuildSQL.

Синтаксис

SetParameterName(индекс, имя)

индекс Индекс параметра.

имя Имя параметра.

Замечания

Если переданная командой BuildSQL инструкция SQL содержит параметры, однако команды SetParameterName не были получены, Query присваивает в форме "Parameter n" имена параметров по умолчанию, где n — приращение счетчика. Если переданное с помощью команды SetParameterName количество имен параметров не существенно, оставшиеся параметры имеют имя "Parameter n". Если отправлено слишком много имен параметров, лишние имена игнорируются.


Команда SetQueryName (DDE)

Задание имени активного запроса или создание запроса с этим именем при отсутствии активного запроса. Имя отображается в заголовке окна запроса.

Синтаксис

SetQueryName(имя)

имя Имя запроса.


 Команда SetQueryType (DDE)

Команда SetQueryType (DDE)

Определяет действие производимое Microsoft Query с запросами построенными на источниках данных других типов. Данная команда доступна только в системном канале.

Синтаксис

SetQueryType(QueryType, CommandType)

Допустимым сочетанием параметров QueryType и CommandType является следующее:

QueryType | CommandType | Описание
ODBC | SQL | Редактирование запроса в Microsoft Query. Если отсутствуют параметры, то присваиваются эти значения.
OLEDB | Cube | Запуск мастера создания куба OLAP для изменения определения куба.

При использовании SetQueryType(OLEDB, Cube), Microsoft Query игнорирует все команды LogonNow, EnableParameters, SetQueryName и аргументыUserControl2, которые не являются допустимыми внутри контекста редактирования определения куба в мастере создания куба OLAP.


 Команда SetWindowState (DDE)

Команда SetWindowState (DDE)

Задание нормального, свернутого или развернутого вида активного окна при открытии. Команда доступна как в системном канале, так и в канале запроса.

Синтаксис

SetWindowState(состояние)

состояние Состояние активного окна. Аргумент может иметь следующие значения.

Значение | Описание
1 | Нормальное
2 | Свернутое (только для Windows)
3 | Развернутое


 Команда UserControl2 (DDE)

Команда UserControl2 (DDE)

Активизация Microsoft Query и обеспечение возможности создания, открытия или изменения запроса пользователем, как при выполнении Microsoft Query в качестве отдельного приложения.

Команда доступна только в системном канале.

Примечание Отличие команды UserControl от UserControl2 состоит в том, что UserControl2 позволяет задавать команду, добавляемую в меню Файл, закрывающую все запросы Microsoft Query и возвращающую управление приложению, не передавая при этом данных.

Синтаксис

UserControl2(текствыход, текстзаверш, состприл, новыйзапрос)

текствыход Имя команды Выход, используемой для выхода из Microsoft Query после сеанса DDE. Если аргумент опущен, используется "Return".

текстзаверш Имя команды меню, используемой для завершения текущего сеанса. Команда добавляется в конец меню Файл в Microsoft Query. Если аргумент опущен, создание нового пункта меню не происходит.

состприл Состояние приложения. Может принимать следующие значения.

Значение | Описание
1 | Нормальное
2 | Свернутое (только для Windows)
3 | Развернутое

Если этот аргумент опущен, используется текущее состояние Microsoft Query.

новыйзапрос Определяет, отображается ли диалоговое окно Выбор источника данных при запуске Microsoft Query в диалоге DDE. Может принимать значения True и False.

Если новыйзапрос имеет значение True, отображается диалоговое окно Выбор источника данных, в котором следует выбрать источник данных. Если новыйзапрос имеет значение False (используется по умолчанию), то диалоговое окно не отображается и все открытые запросы в этом канале доступны.


 Команда UserControl (DDE)

Команда UserControl (DDE)

Активизация Microsoft Query и обеспечение возможности создания, открытия или изменения запроса пользователем, как при выполнении Microsoft Query в качестве отдельного приложения.

Команда доступна только в системном канале.

Синтаксис

UserControl(текствыход, состприл, новыйзапрос)

текствыход Имя команды Выход, используемой для выхода из Microsoft Query после сеанса DDE. Если аргумент опущен, используется "Return".

состприл Состояние приложения. Может принимать следующие значения.

Значение | Описание
1 | Нормальное
2 | Свернутое (только для Windows)
3 | Развернутое

Если этот аргумент опущен, используется текущее состояние Microsoft Query.

новыйзапрос Определяет, отображается ли диалоговое окно Выбор источника данных при запуске Microsoft Query в диалоге DDE. Может принимать значения True и False.

Если новыйзапрос имеет значение True, отображается диалоговое окно Выбор источника данных, в котором следует выбрать источник данных. Если новыйзапрос имеет значение False (используется по умолчанию), то диалоговое окно не отображается и все открытые запросы в этом канале доступны.

Замечания

Управление пользователя завершается при выборе команды Выход в меню Файл в Microsoft Query. После этого Microsoft Query возвращается в свое прежнее состояние и возвращает управление приложению.

Важно! Нельзя допускать тайм-аут приложения, имеющего тайм-аут, до завершения управления пользователем.

При выполнении Microsoft Query под управлением пользователя все новые или существующие запросы открываются в одном канале DDE.

Пример

В примере показан запуск Microsoft Query как развернутого приложения и замена команды Выход в меню Файл в Microsoft Query командой Передать данные в Microsoft Excel. После этого отображается диалоговое окно Выбор источника данных.

DDEExecute chan, "[UserControl(""&Передать данные в Microsoft Excel"",3,True)]")


 Использование DDE

Использование DDE

Две программы могут обмениваться данными путем открытия сеанса DDE, открытого на канале DDE. Программа может создать несколько сеансов DDE с Microsoft Query, но каждый из них будет открыт на своем канале.

Приложение, открывающее сеанс, называется приемником, а отвечающее на запрос — источником. В сеансе DDE Microsoft Query всегда является источником. Это значит, что другие приложения всегда должны сами открывать сеанс DDE с Microsoft Query.

Примечание. Не все программы поддерживают DDE. Чтобы выяснить, поддерживает ли его данное приложение, обратитесь к документации на программу.

Каналы DDE

Существует два типа каналов DDE: системные каналы и каналы запросов.

Системный канал используется в сеансе DDE между программой-приемником и Microsoft Query для получения общих и связанных с запросами сведений. Помимо сведений о запросах системный канал дает возможность получения сведений о системе, например текущие сеансы связи, открытые запросы и состояние программы-приемника.

Канал запросов используется в сеансе DDE между программой-приемником и определенным запросом (например, "Запрос1") Microsoft Query. Перед использованием канала запросов окно запроса должно быть открыто при помощи системного канала.

Как работает DDE

Сеанс DDE можно сравнить с обычным разговором двух людей. Например, во время собеседования при приеме на работу работодатель может задать соискателю набор определенных вопросов. Работодатель (приемник) запрашивает сведения у соискателя (источника) и записывает их на листе бумаги (лист Excel или документ). Соискатель также может задавать вопросы работодателю и установить двустороннюю связь.

Аналогичным образом программы-участники сеанса DDE передают данные в двух направлениях. Например, чтобы использовать DDE для связи с Microsoft Query, процедура Visual Basic для приложений должна выполнить следующие шаги:

  1. Открыть канал при помощи метода DDEInitiate.

  2. При необходимости процедура может передать некоторые данные, например, имена доступных источников данных или текущих сеансов связи, в Microsoft Query.

  3. Загрузить Microsoft Query. Этот шаг необходим для того, чтобы разрешить Microsoft Query выполнять команды. На этом этапе пользователь или процедура могут построить или изменить запрос. Процедура может передавать команды непосредственно Microsoft Query при помощи метода DDEExecute.

  4. После того, как пользователь или процедура завершат работу с Microsoft Query, управление возвращается в программу-приемник. Процедура может получить данные запроса и послать их обратно приемнику при помощи метода DDERequest, либо передать данные в Microsoft Query.

  5. Закрыть канал при помощи DDETerminate.

Для получения дополнительных сведений о конкретных методах DDE в Visual Basic для приложений обратитесь к справочной системе Visual Basic.


 Использование Microsoft Query совместно с другими приложениями

Использование Microsoft Query совместно с другими приложениями

Как правило, приложения используют Microsoft Query для выполнения следующих задач:

  • Создание нового запроса.

  • Обновление существующих данных.

  • Изменение описания запроса или данных.

Microsoft Query как средство создания запросов к данным

При помощи DDE можно использовать Microsoft Query в качестве инструмента получения данных. После того, как макрос или программа откроют канал DDE, можно вызвать Microsoft Query. Затем можно указать, какая команда заменяет команду Выход в меню Файл Windows, в каком состоянии (свернутом, развернутом или восстановленном) находится Microsoft Query и нужно ли выводить какие-либо диалоговые окна.

Затем можно создавать, открывать или изменять запрос, как если бы Microsoft Query была загружена как самостоятельное приложение. После построения запроса можно выполнить команду Выход или нажать кнопку Выход на панели инструментов.

После возвращения управления в программу-приемник (документ, таблицу или другой объект) данные могут быть запрошены у Microsoft Query. Например, можно запросить число строк или столбцов в запросе, строку SQL, описывающую запрос, строку связи с источником данных или имя источника данных. Данные могут быть возвращены в программу-приемник до закрытия канала DDE и завершения работы макроса или программы.

Обновление полученных данных

После выполнения запроса и возвращения таблицы результатов может понадобиться обновление данных, полученных из источника. При помощи DDE можно обновить данные без участия пользователя: программа может послать инструкцию SQL в Microsoft Query, которая затем будет выполнена и вернет таблицу результатов в программу-приемник.

Изменение описания запроса или данных

Другим примером использования Microsoft Query программой является изменение пользователем существующего описания запроса в Microsoft Query или изменение данных источника.

Программа начинает этот процесс с открытия канала DDE, соединения с источником данных и передачи строки SQL (сохраненной при предыдущем запросе) в Microsoft Query для создания нового запроса. После открытия программой нового запроса управление передается пользователю, который может изменить запрос или данные. После окончания работы пользователя в Microsoft Query данные возвращаются в программу, сохраняется новое описание запроса и происходит закрытие запроса.

Например, пользователь, работающий в Word, может выполнить пользовательскую команду "Вывести графики продаж" для запуска соответствующего макроса. Этот макрос может вызвать Microsoft Query, построить запрос, а затем вернуть данные о продажах в документ Word без оповещения пользователя.


 Команда ViewPane (DDE)

Команда ViewPane (DDE)

Задание отображаемых областей окна запроса. Команда доступна как в системном канале, так и в канале запроса.

Синтаксис

ViewPane(область)

область Отображаемые области. Может принимать значения:

Значение | Описание
0 (ноль) | Только область данных
1 | Область данных и область таблиц
2 | Область данных и область условий
3 | Область данных, область таблиц и область условий


Таблица <имя> удалена.

Таблица и данные из нее были удалены Microsoft Query. Отмена удаления невозможна.


Удалить таблицу <имя>?

Запрошено удаление таблицы. При удалении таблицы все данные из нее будут удалены.

Внимание! Отмена удаления таблицы невозможна.

  • Чтобы удалить таблицу со всеми данными, нажмите кнопку Да.

  • Для отказа от удаления нажмите кнопку Нет.


Недопустимое состояние запроса. Операция сохранения прервана.

Неправильный запрос запроса. Например, могли быть неверно заданы условия. Если команда Автоматический режим отключена, попытайтесь выполнить запрос путем выбора в меню Записи команды Выполнить запрос.


Для запуска Microsoft Query требуется разрешение экрана не менее 400 х 350 пикселов

Драйвер экрана не поддерживает разрешение, достаточное для запуска Microsoft Query. Замените драйвер при помощи программы установки Microsoft Windows. Перед заменой драйвера экрана может понадобиться установка нового видеоадаптера, поддерживающего более высокое разрешение.


Ошибка драйвера.

Ошибка драйвера. Для получения дополнительных сведений обратитесь к документации на используемый драйвер.


Найдена повторяющаяся запись.

Таблица результатов содержит одинаковые записи, так как в область данных не включено поле, единственным образом описывающее каждую запись, например "Номер заказчика" или "Номер заказа". Любые изменения в одной из одинаковых записей влияют на все такие записи.

Чтобы различать записи, перед началом изменения убедитесь, что все поля таблицы добавлены в область данных.


Невозможно редактировать вычисляемый столбец.

Невозможно изменение столбца, для которого созданы групповые операции или в котором выводятся результаты пользовательских выражений.


Невозможно редактировать сгруппированный запрос.

Невозможно изменение данных в запросе, который содержит групповые операции или в диалоговом окне Параметры запроса которого установлен флажок Группировать записи. Для изменения данных удалите групповые операции или снимите флажок Группировать записи.


Невозможно редактировать многотабличный запрос.

Изменение данных в запросе, содержащем несколько таблиц, невозможно.

  • Для изменения данных таблицы добавьте только эту таблицу в запрос и выберите в меню Записи команду Разрешить правку.

  • Для изменения данных текущего запроса удалите из него все таблицы, кроме той, которую нужно изменить. Затем выберите меню Записи команду Разрешить правку.

Примечание. При удалении таблицы из запроса сама таблица не удаляется. Происходит только удаление таблицы и ее содержимого из текущего запроса.


Невозможно добавить источник данных.

Microsoft Query не может добавить указанный источник данных из-за трудностей с подключением к источнику данных.


Неправильное выражение столбца: <выражение>.

Выражение, указанное в операторе SELECT, неверно. Выражение должно иметь следующий формат:

SELECT employee.EMPLOY_ID, employee.HIRE_DATE
FROM C:\QT\employee employee


Требуется выражение после GROUP BY.

Отсутствует выражение после оператора GROUP BY в инструкции SQL.


Требуется выражение после ORDER BY.

Отсутствует выражение после оператора ORDER BY в инструкции SQL.


Невозможно открыть несколько копий файла.

Файл запроса не может быть открыт дважды в одно и то же время.


Невозможно добавить таблицу <имя>.

Не удается добавить указанную таблицу. Убедитесь, что:

  • Указанная таблица присутствует в базе данных.

  • Название таблицы указано правильно. Проверьте, не пропущены ли где-либо символы ( _ ) или знаки препинания.

  • Указанная таблица содержит поля (столбцы).


Для создания самообъединения необходимо иметь две копии таблицы.

Посредством задания одинаковых имен таблиц в полях Левая и Правая диалогового окна Объединения определено создание внутреннего объединения, но в области таблиц содержатся две разные таблицы.

  • Для создания внутреннего объединения необходимо поместить в область таблиц две копии одной таблицы.

  • Для объединения двух разных таблиц необходимо поместить одну из таблиц в левую часть объединения, а другую — в правую.


Длина <число> должна быть числом.

В поле Длина введено не числовое значение. Исправьте значение на числовое.


Ошибка в имени <имя>.

Имена таблицы и полей должны соответствовать стандартам имен, принятым для источника данных. Обратитесь к документации на источник данных.


Число знаков после десятичной запятой должно быть меньше или равно общей длине.

Введенное в поле Число десятичных знаков значение превышает значение, заданное в поле Длина. Измените значение поля Число десятичных знаков на меньшее или равное значению поля Длина.


Максимальная длина типа <имя типа данных> — <число>

Введенное в поле Длина значение превышает максимальную допустимую для поля этого типа данных длину.


Обновление не выполнено.

Microsoft Query не может обновить список таблиц в диалоговом окне Добавление таблиц, так как источник данных не отвечает. Убедитесь, что соединение с источником данных не прервано.


Невозможно удалить источник данных.

Microsoft Query не может удалить указанный источник данных. Для удаления источника необходимо отсоединиться от него.


Общий сбой ODBC.

Microsoft ODBC или источник данных вернули ошибку, подробные сведения о которой недоступны. Убедитесь, что база данных загружена и доступна, и повторите операцию.


Ошибка синтаксиса в предложении GROUP BY.

Инструкция SQL содержит неверный оператор GROUP BY. Возможно, неверно введено или отсутствует зарезервированное слово, или неверно расставлены знаки препинания.


Ошибка синтаксиса в предложении HAVING.

Инструкция SQL содержит неверный оператор HAVING. Возможно, неверно введено или отсутствует зарезервированное слово либо неверно расставлены знаки препинания.


Ошибка синтаксиса в операции JOIN.

За оператором ON инструкции SQL следует недопустимое выражение. Выражение должно иметь следующий формат:

{oj C:\QT\orders orders LEFT OUTER JOIN C:\QT\orddtail orddtail ON orders.ORDER_ID = orddtail.ORDER_ID}


Ошибка синтаксиса в предложении ORDER BY.

Инструкция SQL содержит неверный оператор ORDER BY. Возможно, неверно введено или отсутствует зарезервированное слово, или неверно расставлены знаки препинания.


Сначала выберите источник данных.

Попытка выполнить инструкцию SQL до указания источника данных. В диалоговом окне Выполнить запрос SQL нажмите кнопку Источники данных и выберите требуемый источник данных.


Требуется оператор join после <имя>.

В выражении "LEFT OUTER JOIN" или "RIGHT OUTER JOIN" отсутствует оператор "=" между названиями двух таблиц. Внешние объединения должны использовать оператор "=".


Требуется LEFT или RIGHT после таблицы <имя>.

В инструкции SQL содержится оператор OUTER JOIN без ключевых слов "LEFT" или "RIGHT". Оператор внешнего объединения в инструкции SQL должен иметь вид "LEFT OUTER JOIN" или "RIGHT OUTER JOIN".


Требуется выражение после HAVING.

После оператора HAVING в инструкции SQL не указано условие поиска.


Требуется выражение после WHERE.

После оператора WHERE в инструкции SQL не указано условие поиска.


Требуется имя таблицы после FROM.

После оператора FROM в инструкции SQL не содержится названия таблицы.


Слишком длинный текст; вставка отменена

Вставляемый из буфера обмена текст слишком длинный, чтобы поместиться в выбранное поле области данных или области условий. Максимальное количество символов, которое можно поместить в поле, зависит от длины поля, заданной при создании таблицы.


Ошибка ввода/вывода в процессе загрузки.

Microsoft Query не может открыть или прочитать указанный файл. Возможно, произошел сбой диска или поврежден файл.


Невозможно прочитать этот файл.

Microsoft Query не может прочитать указанный файл. Возможно, файл записан в формате, несовместимом с форматами Microsoft Query или Q+E, произошел сбой диска или файл поврежден.


Ошибка ввода/вывода в процессе сохранения.

Microsoft Query не может сохранить запрос на диск. Возможно, произошел сбой диска.


Невозможно задать условие, пока не указано поле.

Перед заданием условий для поля его необходимо добавить в область условий.


Драйвер поддерживает не все функции.

Введенное выражение содержит функции, не поддерживаемые источником данных. Чтобы выяснить, какие функции поддерживает источник данных, обратитесь к документации на драйвер источника данных или свяжитесь с поставщиком драйвера.


Невозможно создать индекс.

Источник данных таблицы не поддерживает индексы.


Индекс создан.

Индекс для указанных полей таблицы успешно создан Microsoft Query.


Сеанс DDE закрыт или изменен.

Другая программа без предупреждения закрыла сеанс динамического обмена данными (DDE), например с помощью инструкции DDETerminate или DDETerminateAll, или изменила его параметры.

Закройте текущий сеанс, а затем создайте новый сеанс обмена с этой программой.


Значение ширины должно быть от 1 до <число>.

Задайте ширину столбца в указанном диапазоне или выберите параметр Стандартная ширина в диалоговом окне Ширина столбца.


Недопустимое имя файла.

Имена файлов должны вводиться в соответствии со стандартами имен, принятыми для источника данных. Обратитесь к документации на источник данных.


Значение высоты должно быть от 1 до <число>.

Задайте значение высоты строк, находящееся в указанном диапазоне, или выберите параметр Стандартная высота в диалоговом окне Высота строк.


LEFT OUTER JOIN и RIGHT OUTER JOIN должны быть EQUI JOINS.

В выражении "LEFT OUTER JOIN" или "RIGHT OUTER JOIN" отсутствует оператор "=" между названиями двух таблиц или указан другой оператор. Внешние объединения должны использовать оператор "=".


Столбцы <имя> и <имя>, по которым требуется создать объединение, имеют разный тип. Создать объединение?

Попытка объединения полей (столбцов) с разными типами данных. Например, объединение поля, содержащего даты, с полем, содержащим текст.

  • Для отмены объединения нажмите кнопку Отмена.

  • Для создания объединения нажмите кнопку OK.

Примечание. Такое объединение может не дать требуемых результатов. Убедитесь, что в таблице результатов Microsoft Query выводятся нужные данные.


Требуется JOIN после OUTER.

Инструкция SQL содержит выражение "LEFT OUTER" или "RIGHT OUTER" вместо "LEFT OUTER JOIN" или "RIGHT OUTER JOIN". Слово "JOIN" неверно введено или отсутствует.


Транзакция DDE не выполнена. Убедитесь в правильности версии DDEML.DLL.

Установка Microsoft Query выполнена не полностью или повреждена. Для исправления ошибки переустановите Microsoft Query и выберите режим восстановления.


Невозможно создать внешние объединения, если в запросе больше двух таблиц.

При использовании внешнего объединения в области таблиц могут находиться только две таблицы. Удалите лишние таблицы из области таблиц и создайте внешнее объединение.


Очередь сообщений заполнена. Сообщение DDE потеряно.

Microsoft Query не может выполнить все запрашиваемые операции динамического обмена данными (DDE).

Закройте некоторые сеансы DDE и попытайтесь повторить операцию.


Значение должно быть числовым

При задании числового параметра введено не числовое значение. Введите числовое значение.


Другое приложение не поддерживает используемый метод или операцию DDE.

Другая программа не может выполнить требуемую операцию динамического обмена данными (DDE).

  • Программа не распознает переданные данные или команды. Чтобы определить, какие команды или данные принимает программа, обратитесь к документации на нее.

  • Программа не принимает параметр Объект на основании заданного раздела сеанса. Чтобы определить, какие объекты принимает программа, обратитесь к документации на нее.


Невозможно открыть канал DDE; Microsoft Query не находит указанное приложение или раздел.

Microsoft Query не может найти указанное приложение или раздел для сеанса динамического обмена данными (DDE). Убедитесь, что другое приложение (приемник) загружено, раздел открыт и при определении сеанса DDE были правильно указаны имя приложения и раздел.


Невозможно сохранить столбец <имя> в этом источнике данных.

Источник данных, в который записывается таблица результатов, не поддерживает тип данных какого-либо поля или не может преобразовать его в совместимый тип. Попытайтесь сохранить таблицу в другой источник данных, поддерживающий этот тип данных.


Недостаточно системных ресурсов для обновления изображения на экране

Недостаточно памяти для завершения операции Microsoft Query.

Попытайтесь закрыть другие приложения или другие окна в Microsoft Query. Если ошибка повторяется, перезапустите Microsoft Windows и повторите операцию.


Нет доступа к таблице <имя>.

Указанная таблица не найдена, блокирована другим пользователем или запросом или не содержит полей.


Не удается отобразить справку.

Файл справки Microsoft Query отсутствует в текущей папке. Перенесите или скопируйте его в текущую папку.


Невозможно получить процедуры.

Microsoft Query не может вывести список процедур из данного источника данных, так как источник не отвечает. Возможно, произошло отсоединение от источника данных.


Ни одна процедура не найдена.

Источник данных не содержит процедур. Для создания процедур обратитесь к документации на источник данных.


Невозможно удалить, некоторые запросы используют этот источник.

Удаляемый источник данных используется другими запросами. Необходимо сначала закрыть запросы, использующие этот источник данных.


Запись не существует.

Запись с указанным номером не существует. Возможно, задан слишком большой или слишком маленький номер записи. Убедитесь, что в области данных присутствуют записи, и проверьте правильность ввода номера записи.


В таблице отсутствует уникальный индекс. Создать индекс вручную?

Таблица результатов, которую требуется сохранить как новую таблицу, получена из таблицы, для которой не существует уникального индекса.

  • Чтобы вывести диалоговое окно Создание индекса для создания уникального индекса таблицы, нажмите кнопку Да.

  • Чтобы отменить создание индекса, нажмите кнопку Нет.


Невозможно найти значения.

Microsoft Query не может передать заданные в условиях значения. Возможной причиной может быть нехватка памяти или отсоединение от источника данных.

Если соединение с источником данных не прервано, попытайтесь закрыть другие приложения или другие окна Microsoft Query. Если ошибка повторяется, перезапустите Microsoft Windows.


Невозможно создать новое окно.

Microsoft Query не может вывести указанный файл. Возможно, не хватает памяти.

Закройте другие активные приложения или окна Microsoft Query. При повторении ошибки перезапустите Microsoft Windows.


 Помощник не находит нужную справку

Помощник не находит нужную справку

Получение советов и подсказок о поиске в справке. Если справочная тема не найдена, то выберите Попытаться найти дополнительную справку в Web в окне помощника. Сведения о поиске тем появляются вместе с указаниями по поиску нужной справки. Выберите советы по поиску для получения руководства по ограничению списка тем путём перефразирования вопроса или используя указатель справки.

Примечание. В зависимости от системной настройки кнопка Попытаться найти дополнительную справку в Web может быть недоступна. Для того, чтобы воспользоваться этой возможностью необходимо установить обозреватель Web с доступом в Интернет. Если это средство недоступно, то свяжитесь с системным администратором.


Помощник отвлекает от работы

Выбор менее активного персонажа помощника. Одни персонажи помощника более активны, чем другие. Для выбора другого помощника щелкните помощника правой кнопкой мыши, а затем выберите команду Выбрать помощника в контекстном меню. Перейдите на вкладку Коллекция и с помощью кнопок Назад или Далее выберите подходящий персонаж. «Эмблема Office» — самый "спокойный" персонаж.

Отключение звуков помощника. Для отключения звуков помощника щелкните помощника, выберите Параметры и снимите флажок Звуковое сопровождение.

Ограничьте перемещение персонажа помощника. Чтобы помощник не перемещался по экрану, щелкните помощника, выберите Параметры и снимите флажок не закрывать данные.


Отмена операции невозможна. Продолжать?

Для этой операции команда Отменить недоступна, так как операция слишком велика или недостаточно свободной памяти.

  • Чтобы продолжить выполнение операции без возможности отмены, нажмите кнопку OK.

  • Для отмены операции нажмите кнопку Отмена.


Требуется ON после оператора RIGHT JOIN для таблицы.

Инструкция SQL содержит оператор LEFT OUTER JOIN или RIGHT OUTER JOIN и выражение для него, но отсутствует оператор ON со своим выражением. Слово "ON" неверно введено или отсутствует.


Запрос может содержать только одно внешнее объединение.

В запросе может присутствовать только одно внешнее объединение.


Необходимо указать одно значение для оператора <оператор>.

При создании условий с использованием этого оператора должно использоваться только одно значение. Microsoft Query выбирает только записи, содержащие указанное значение в поле, для которого задано в условие. Например, при выборе пункта "начинается с" из списка Оператор Microsoft Query производит поиск значений, начиная с указанного, в заданных условиями полях. Для таблицы результатов отбираются только эти записи.


Необходимо указать два значения для оператора <оператор>.

При создании условий с помощью этого оператора необходимо использовать два значения. Например, при выборе "между" из списка Оператор, Microsoft Query производит поиск в значений, попадающих в указанный диапазон, в поле, для которого заданы условия. Для таблицы результатов отбираются только эти записи.


Невозможно открыть файл.

Microsoft Query не может открыть указанный файл запроса. Возможно, произошел сбой диска или файл поврежден.


Невозможно открыть файл.

Microsoft Query не может открыть файл Microsoft Query, указанный в диалоговом окне Выполнить запрос SQL. Возможно, файл сохранен не в текстовом формате, произошел сбой диска или файл поврежден.


Требуется OUTER после LEFT/RIGHT.

В инструкции SQL присутствует оператор внешнего объединения LEFT или RIGHT OUTER JOIN, в котором отсутствует ключевое слово "OUTER". Оператор внешнего объединения в инструкции SQL должен иметь вид "LEFT OUTER JOIN" или "RIGHT OUTER JOIN".


Для внешнего объединения требуются только две таблицы. Удалить внешнее объединение для добавления таблицы?

В области таблиц уже имеются две таблицы, связанные внешним объединением. Для использования трех и более таблиц в области таблиц необходимо удалить внешнее объединение или заменить его внутренним.


Слишком большое число

Введите меньшее значение.


Слишком длинное выражение.

Выражение слишком длинное для анализа в Microsoft Query. Попытайтесь сделать выражение короче или разбейте его на два выражения.


Нет доступа к <база данных>.

Используемый источник данных разрешает выбор таблиц только из текущей базы данных (или из эквивалента базы данных).


 О выражениях

О выражениях

Выражением называется конструкция, в которой используются операторы, функции, имена полей и константы.

Выражение может быть использовано в качестве условия выбора записей. Для использования выражения в области условий выберите поля, содержащие значения, которые будут использоваться в условиях, из списка Условие и введите нужные оператор и значение в поле Значение. При выборе поля в качестве условия убедитесь, что используется поле из нужной таблицы.

Выражения, использующие арифметические операторы. Для извлечения записей, основанных на результате вычислений, создайте выражение, использующие арифметические операторы для сложения, вычитания, умножения или деления. Примеры выражений, использующих арифметические операторы.

Выражения, использующие операторы сравнения. Операторы сравнения сравнивают одно значение с другим. Например, для того чтобы найти все заказы, где число проданных единиц больше 1000, наберите >1000 как условие в поле «Количество». Примеры выражений, использующих операторы сравнения.

Выражения, использующие логические операторы. Логические операторы сравнения похожи на операторы сравнения. Например, для выбора всех записей о продавцах, живущих не во Франции, используется фраза НЕ Франция как условие для поля «Страна». Примеры выражений, использующих логические операторы .

Выражения, использующие прочие типы операторов. Для поиска значений, равных любому из нескольких значений, для определения содержания значения в определенном поле записи или для поиска записей с использованием подстановочного знака, используются дополнительные операторы. Примеры выражений, использующих прочие типы операторов.


 Изменение заголовка столбца

Изменение заголовка столбца

  1. Дважды щелкните заголовок столбца поля, который нужно изменить.

  2. Введите заголовок в поле Заголовок столбца.


 Изменение ширины столбца или высоты всех строк

Изменение ширины столбца или высоты всех строк

Изменение ширины столбца. Чтобы изменить ширину столбца, установите указатель мыши на правую границу заголовка столбца, и перетащите ее на нужную ширину.

Совет. Чтобы установить ширину столбца равной ширине максимального из значений, содержащихся в столбце, дважды щелкните правую границу заголовка столбца.

Изменение высоты строки. Чтобы изменить высоту всех строк, установите указатель мыши на нижнюю границу любого заголовка строки и перетащите ее на нужную высоту.

Примечание. Изменение высоты строк действует на все строки в таблице результатов.


Изменение шрифта, стиля или размера текста в таблице результатов

  1. Выберите команду Шрифт в меню Формат.

  2. Сделайте нужные изменения.


 Изменение типа объединения таблиц в запросе

Изменение типа объединения таблиц в запросе

  1. Дважды щелкните линию объединения таблиц.

  2. Для выбора оператора, который будет использоваться Microsoft Query при сравнении данных в объединенных полях, выберите необходимый оператор из списка Оператор. Для получения дополнительных сведений нажмите кнопку [image] .

  3. Для создания внешнего объединения, при котором используются все записи из таблицы слева, выберите параметр 2из спискаОбъединение включает. Для создания внешнего объединения выберите оператор "=".

    Для создания внешнего объединения, в котором используются все записи из таблицы справа, выберите параметр 3 из списка Объединение включает.

    Для создания внутреннего объединения, в котором используются записи из обеих таблиц, выберите параметр 1 из списка Объединение включает.

  4. Нажмите кнопку Добавить.

  5. Нажмите кнопку Закрыть.

    Для получения дополнительных сведений о типах объединений и их влиянии на результаты запроса нажмите кнопку [image] .


 Создание сложного запроса в Microsoft Query

Создание сложного запроса в Microsoft Query

  1. Нажмите кнопку Создать запрос [image] .

  2. Выберите базу данных, из которой требуется получить данные, на вкладке Базы данных или создайте новый источник данных.

    Инструкции

  3. Сбросьте флажок Использовать мастер запросов и нажмите кнопку OK.

  4. Выберите требуемые таблицы.

    Инструкции

  5. Выберите поля, которые должны быть в таблице результатов.

    Инструкции

    Для включения в таблицу результатов определенных записей введите условия отбора записей.

    Инструкции

    Для создания параметрического запроса, который запрашивает условия при запуске, укажите параметры.

    Инструкции

    Для изменения таблицы результатов можно создать внутреннее объединение или внешнее объединение таблиц.

    Инструкции

Примечания

  • После получения необходимых данных, таблица результатов может быть передана в Microsoft Excel. Чтобы получить более подробные сведения, нажмите кнопку [image] .

  • Для остановки выполнения запроса, занимающего слишком много времени, нажмите клавишу ESC.

  • Чтобы предотвратить выполнение запроса до окончания ввода всех полей в таблицу результатов, убедитесь, что кнопка Автоматический режим [image] не нажата. Для выполнения запроса нажмите кнопку Выполнить запрос [image] .

  • Чтобы запретить выполнение запроса до его сохранения или возвращения данных в Excel, в меню Правка выберите Параметры и затем снимите флажок Проверять запросы перед сохранением или возвратом данных.


 Создание запроса с использованием мастера запросов

Создание запроса с использованием мастера запросов

  1. Нажмите кнопку Создать запрос [image] .

  2. Сбросьте флажок Использовать мастер запросов.

  3. Дважды щелкните базу данных, из которой нужно получить данные, на вкладке Базы данных.

    Для определения нового источника данных дважды щелкните значок Новый источник данных и затем укажите нужный источник данных.

  4. Следуйте инструкциям мастера запросов.

  5. В диалоговом окне Создание запроса: заключительный шаг, сделайте одно из нижеследующего:

    Для передачи данных в Microsoft Excel установите флажок Передать данные в Microsoft Excel, нажмите кнопку Готово и затем выберите, куда нужно поместить внешние данные.

    Для сохранения запроса в файле .dqy, который может быть открыт для редактирования в Microsoft Query или для запуска в Excel, нажмите кнопку Сохранить запрос. Этот необязательный шаг рекомендуется, если в будущем из запроса будет создан куб OLAP.

    Для запуска мастера создания куба OLAP, который позволяет создать куб из данных запроса, нажмите кнопки Создание куба OLAP из данного запроса и Готово. После этого следуйте дальнейшим инструкциям мастера. Этот режим рекомендован только для опытных пользователей. Изучите создание кубов OLAP.

    Для дальнейшего уточнения условий запроса выберите параметр Просмотр или изменение данных в Microsoft Query и нажмите кнопку Готово. Таблица результатов выводиться в области данных, где можно произвести изменения и затем позже вернуть ее в Microsoft Excel.

Совет. Для остановки выполнения запроса, занимающего слишком много времени, нажмите клавишу ESC.


 Удаление содержимого базы данных, участвующей в запросе

Удаление содержимого базы данных, участвующей в запросе

Внимание! Удаленная из базы данных запись полностью удаляется как из таблицы результатов, так и из самой базы данных.

  1. Убедитесь, что в меню Записи включена команда Разрешить правку.

    В некоторых случаях Microsoft Query запрещает изменение данных. Если команда Разрешить правку недоступна, или Microsoft Query выводит сообщение при выборе команды Разрешить правку, то данные не могут быть изменены. Для получения дополнительных сведений нажмите кнопку [image] .

  2. Выберите удаляемую запись, щелкнув кнопку слева от записи.

  3. Выберите команду Удалить в меню Правка.


 Изменение содержимого базы данных, участвующей в запросе

Изменение содержимого базы данных, участвующей в запросе

  1. Убедитесь, что в меню Записи Microsoft Query включена команда Разрешить правку.

    В некоторых случаях Microsoft Query запрещает изменение данных. Если команда Разрешить правку недоступна, или Microsoft Query выводит сообщение при выборе команды Разрешить правку, то данные не могут быть изменены. Для получения дополнительных сведений нажмите кнопку [image] .

  2. Выберите поле, которое нужно изменить, в таблице результатов.

  3. Сделайте нужные изменения и нажмите клавишу ENTER.

Примечание. Если при изменении данных была сделана ошибка, то можно отменить последнее изменение, выбрав команду Вернуть в меню Правка. Отменять изменения нужно до перехода в другую запись или окно.


 Вставка поля в таблицу результатов

Вставка поля в таблицу результатов

  1. Щелкните заголовок столбца полей справа от того места, куда нужно вставить новое поле.

  2. Выберите команду Вставить в меню Записи.

  3. Выберите столбец, который нужно вставить, из списка Поле.

    При необходимости введите описательный заголовок в поле Заголовок столбца.

  4. Нажмите кнопку Вставить.

Примечание. Для того, чтобы быстро вставить поле в таблицу результатов необходимо перетащить поле из области таблиц в таблицу результатов.


 Создание внутреннего объединения

Создание внутреннего объединения

  • Перетащите поле из одной таблицы на совпадающее поле (поле такого же типа, содержащее те же данные) из списка полей другой таблицы.

Примечание. При внутреннем объединении Microsoft Query выбирает записи из обеих таблиц или запросов только тогда, когда значения в объединенных полях равны. Также можно создать внешнее объединение, которое выберет все записи из одной таблицы и любые связанные записи из другой.


 Изменение порядка расположения полей в таблице результатов

Изменение порядка расположения полей в таблице результатов

  1. Щелкните заголовок столбца поля, который нужно переместить.

  2. Установите указатель мыши на заголовок столбца и перетащите столбец в нужное место.


 Скрытие или отображение поля в таблице результатов

Скрытие или отображение поля в таблице результатов

  1. Щелкните заголовок столбца поля, который нужно скрыть.

  2. Выберите команду Скрыть столбцы в меню Формат.

Чтобы отобразить скрытый столбец, выберите команду Показать столбцы в меню Формат, выберите нужный столбец и нажмите кнопку Показать.


 Отмена изменений базы данных, участвующей в запросе

Отмена изменений базы данных, участвующей в запросе

  • Выберите команду Вернуть в меню Правка.

Примечание. Можно отменить последнее изменение данных. Отменять изменения нужно до перехода в другую запись или окно.


(Untitled)

Вместо поиска записей совпадающих с указанным значением, можно найти записи несовпадающие со значением. Например, можно воспользоваться оператором НЕ для поиска всех записей о поставщиках, живущих не в России.

Условие использующее оператор НЕ

Воспользуйтесь оператором НЕ для исключения записей.

Дополнительные сведения

Примеры выражений, использующих логические операторы


(Untitled)

Можно найти записи, содержащие отсутствующие или незаконченные значения. Например, воспользуйтесь оператором Is Null для поиска всех записей работников, где отсутствует значения для имени инспекторов.

Условие, использующее оператор Is Null

Воспользуйтесь оператором Is Null для поиска записей с пустыми полями.

Дополнительные сведения

Примеры выражений, использующих прочие типы операторов


(Untitled)

Можно найти записи, где значения в одном поле схожи, как например номера телефонов с одинаковыми кодами страны или области. Например, найдем всех заказчиков, чьи телефонные номера начинаются с кода области (171) или кода страны (1) и (11).

Условие, использующее оператор «Похоже на»

Для использования оператора Похоже на введите слово Похоже на и затем введите в одинарных кавычках значение, которое необходимо найти.

Примечание. Знак процента (%) из примера выше — это подстановочный знак, соответствующий любому количеству символов. Для обозначения только одного символа используется знак подчеркивания (_). В зависимости от источника данных, используемые подстановочные знаки меняются. Для получения дополнительных сведений о подстановочный знаках, которые поддерживаются драйвером источника данных, обратитесь к документации по этому драйверу.

Дополнительные сведения

Примеры выражений, использующих прочие типы операторов


(Untitled)

Можно найти все записи со значениями, которые выполняют одиночное условие — например, определенную страну или продукт. Следующий пример показывает условие, извлекающее все записи, которые содержат «Швеция» в поле «Страна».

Пример использования одиночного условия

Для указания одиночного условия выберите имя поля из списка Условие и затем введите значение для поиска в поле Значение.

Дополнительные сведения

Примеры выражений, использующих логические операторы


(Untitled)

Выполнение условий в двух и более полях. Можно найти все записи со значениями, выполняющими одно условие в одном поле и другое условие в другом поле. Для примера, найдем все записи о всех заказчиках, проживающих в Московской области на территории России. Для выбора этих записей введите две таблицы условий в области условий. Для указания нескольких условий, где все условия истинны, создайте условие «И».

Условия выполняющие условие «И»

Для поиска записей выполняющих два и более условий укажите поле для каждого условия, которое используется в качестве условия.

Выполнение нескольких условий в одном и том же поле. Можно найти все записи со значениями выполняющими несколько условий в одном и том же поле. Для примера найдем все записи о всех заказчиках проживающих не только в России, но и в Мексике. Для выбора этих записей введите две таблицы условий в области условий. Для указания нескольких условий, где одно из условий истинно, создайте условие «ИЛИ». В условии «ИЛИ» только одно из двух (или более) условий должно быть истинным.

Условия выполняющие условие «ИЛИ»

Вышеуказанное условие ищет всех заказчиков из России или Мексики.

Примечание. Также можно использовать оператор ИЛИ внутри значения условия. Например, вместо ввода Мексика в поле ИЛИ можно ввестиРоссия ИЛИ Мексика в поле Значение.

Дополнительные сведения

Примеры выражений, использующих логические операторы


(Untitled)

Можно найти все записи попадающие в диапазон значений или дат. Для примера, извлеките все записи заказов, подписанных между 1 ноября 1998 и 31 декабря 1998. Для указания двух или более условий, которые должны быть выполнены, создайте условие «И». Для определения диапазона значений укажите условие «И».

Пример диапазона двух условий

Условие «И», которое использует две копии одного и того же поля в области условий.

Диапазон, содержащий оператор «И».

Условие «И», в котором нижняя и верхняя граница разделены оператором И.

Примечание. При вводе даты в области условий, Query преобразует дату в формат, который он понимает. Например, при вводе условия >31.10.1998, Query преобразует его к виду >#31.10.98#.

Дополнительные сведения

Примеры выражений, использующих операторы сравнения


(Untitled)

Для поиска записей, совпадающих с результатами вычислений, например как все записи, где сумма заказа превышает число, равное помноженному значению поля цена на значения поля количества.

Пример использования рассчитанного условия

Для поиска записей, где сумма заказа превышает 500 р., создайте формулу вычисляющую сумму заказа и затем укажите условие.

Дополнительные сведения

Примеры выражений, использующих арифметические операторы


 (Untitled)

Условие — это параметры, указанные для поиска определенных записей в базе данных или списке. Использование условий позволяет ограничить записи (или строки), которые включены в таблицу результатов запроса. Например, условие ЦенаЗаШтуку > 30 выбирает записи, где значение в поле ЦенаЗаШтуку больше 30. Добавьте условие в область условий в Microsoft Query либо непосредственно введя условие в поле, либо используя Добавление условия в меню Условия. Поля, используемые для указания условия, не должны включаться в таблицу результатов.

Так как запрос может содержать несколько таблиц с одинаковыми именами полей, убедитесь, что используются поля из нужной таблицы. Например, если необходимо найти всех поставщиков для определенной страны, выберите поле «Страна» из таблицы «Поставщики», а не из таблицы «Заказчики».

Дополнительные сведения

Задание условий для выбора записей


 (Untitled)

Microsoft Query — это программа для переноса данных из внешних источников в программы Microsoft Office, в частности Microsoft Excel. Используя Query для извлечения данных из общей базы данных и файлов, не необходимости в повторном вводе данных для анализа в Excel. Также можно автоматически обновить отчеты и документы Excel данными из исходной базы данных, при их изменении.

Типы доступных баз данных. Загрузка данных возможна из нескольких типов баз данных, включая Microsoft Access, Microsoft SQL Server и Microsoft SQL Server OLAP Services. Также возможна загрузка данных из списков Excel и из текстовых файлов. Обратитесь к списку типов доступных баз данных.

Также в Excel можно загружать данные из Web-страниц, но для этого не требуется Query. Для получения сведений о загрузке данных из Web-страниц обратитесь к справочной системе Microsoft Excel.

Выбор данных из базы данных. Извлечение данных из базы данных производится путем создания запроса, который является вопросом о данных хранящихся во внешней базе данных. Например, если данные хранятся в базе данных Access и необходимо узнать размеры продаж по указанному продукту по определенной области, то можно извлечь только часть данных, выбрав только данные по продукту и области, которые будут анализироваться, и опустив ненужные данные.

Пример выбора данных в Query

В Query можно выбрать необходимые столбцы данных и перенести только эти данные в Excel.

Обновление листа за одну операцию. После использования внешних данных в книге Excel всякий раз, когда база данных изменяется, можно обновить данные для анализа , без необходимости создания заново итогового отчета и диаграмм. Например, можно создать месячный отчет по продажам и обновлять его ежемесячно при поступлении новых данных по продажам.

Использование Query для загрузки данных. Перенос внешних данных в Excel при помощи Query требует трех шагов: Вначале производится настройка источника базы данных для подключения к базе данных, затем при использовании мастера создания запроса выбираются необходимые данные, и в конце возвращаются данные в Excel, где их можно отформатировать, сгруппировать и создать из них отчет.


 (Untitled)

Что такое источник данных? В источнике данных хранится таблица данных, которая позволяет Microsoft Excel и Microsoft Query подключиться к внешней базе данных. При использовании Query для настройки источника данных, дайте имя источнику данных и затем введите имя и местоположение базы данных или сервера, тип базы данных, идентификатор и пароль для входа. Данные также должны включать имя драйвера ODBC или драйвера источника данных. Эти драйверы позволяют произвести соединение с указанным типом базы данных. Для некоторых типов внешних баз данных (кубы OLAP) для загрузки данных необходимо только настроить источник данных.

Как Query использует источники данных. После настройки источника данных для указанной базы данных, его можно использовать всякий раз, когда нужно создать запрос для выбора или извлечения данных из базы данных, без ввода всех данных, необходимых для подключения. Query использует источник данных для подключения к базе данных и показывает доступные данные. После создания запроса и возврата данных в Excel, Query загружает данные и поставляет в книгу Excel данные по запросу и источнику данных, таким образом при обновлении данных возможно повторное подключение к базе данных.

Схема использования Query источников данных

Источник данных является средством, через которое Query и Excel подключаются к указанной базе данных и загружают данные.


 (Untitled)

При наличии двух таблиц, содержащих сходные данные, например две таблицы заказчиков, в каждой из которых присутствуют сведения, отсутствующие в другой таблице, можно создать вычитательное объединение. Вычитательное объединение возвращает только записи из первой таблицы, которые не совпадают с записями из второй таблицы.

Таблицы с похожими данными до вычитательного объединения

Две таблицы с похожими данными о заказчиках

Пример вычитательного объединения

Дополнительные сведения

Загрузка отличающихся записей двух таблиц


 (Untitled)

Для объединения всех данных из двух таблиц необходимо создать запрос полного внешнего объединения. Данный тип запроса возвратит все данные из обоих таблиц, даже если данные не связанны.

Таблицы с похожими данными до проведения полного внешнего объединения

Например, можно воспользоваться полным внешним объединением двух таблиц («Заказчики» и «Заказы») для возврата всех ожидающий решения заказов (из таблицы «Заказы») и всех заказчиков (из таблицы «Заказчики»), кто не сделал заказа.

Таблица результатов покажет заказчиков, кто не разместил заказы

Первые два имени в этой таблице не разместили заказы.

Примечание. При создании полного внешнего объединения, Query показывает только таблицу результатов запроса, а не таблицы используемые в запросе.

Дополнительные сведения

Объединение всех данных из двух таблиц


(Untitled)

Внутреннее объединение (тип объединения по умолчанию) извлекает только записи, которые имеют одинаковые значения в связанных полях. Microsoft Query объединяет совпадающие записи из каждой таблицы и показывает их в таблице результатов.

Пример внутреннего объединения

Дополнительные сведения

Объединение таблиц в запросе

Изменение типа объединения таблиц в запросе


(Untitled)

Внешнее объединения извлекает все записи из одной таблицы и любые совпадающие записи из другой таблицы. Когда значения из двух таблиц одинаковы, Microsoft Query объединяет совпадающие записи и показывает их в таблице результатов как одну запись. Когда запись из таблицы, которая предоставила все свои записи, не совпадает с записью из другой таблицы, то эта запись тем не менее появится в таблице результатов. Однако, Query показывает пустые ячейки, где нет совпадающих записей, в другой таблице.

Пример внешнего объединения

Дополнительные сведения

Объединение таблиц в запросе

Изменение типа объединения таблиц в запросе


 (Untitled)

Базы данных содержат несколько таблиц со связанными данными. При добавлении двух (и более) таблиц к запросу, Microsoft Query автоматически создает «запрос» между таблицами при обнаружении ключевого поля в одной таблице и поля с таким же именем в другой. Линии связи показывают схему данных в таблицах.

Линии связи между таблицами

Линии связи устанавливают связь между таблицей «Продукты» и таблицей «Подробности заказов», связывая поле «ИдентификационныйНомерПродукта» в каждой таблице. Таблицы «Подробности заказов» и «Продукты» также связаны полями «ИдентификационныйНомерЗаказа».

Для извлечения записей из нескольких таблиц существует два основных типа объединений. Внутреннее объединение извлекает только связанные записи из таблиц. Внешнее объединение извлекает все записи из одной таблицы и связанные записи из другой.

В дополнение к внутренним и внешним объединениям существует еще три других типа объединений: самообъединения, полное внешнее объединение и вычитательное объединение. Самообъединения возвращают таблицу результатов, которая объединяет данные содержащиеся в одной таблице. Полное внешнее объединение возвращает все записи из обоих таблиц, даже если записи не связаны. Вычитательное объединение возвращает только те записи из первой таблицы, которые не совпадают с записями из второй.


 (Untitled)

После создания запроса или в мастере создания запросов, или в Microsoft Query, можно вернуть данные в лист Microsoft Excel. Данные становятся Внешним диапазоном данных или Отчетом сводной таблицы, которые могут быть отформатированы, проанализированы и обновлены.

Форматирование и анализ данных. В Excel можно воспользоваться знакомыми инструментами, такими как Мастер диаграмм или автоматические итоги, для представления и группирования данных. При обновлении внешних данных из исходной базы данных, произведенное форматирование будет сохранено. При добавлении столбцов формул к внешнему диапазону данных, формулы автоматически могут быть скопированы в любую новую строку, которая добавлена к диапазону при обновлении данных. Вместо имен полей можно использовать собственные подписи к столбцам и автоматически добавлять номера сток. Для получения сведений по поводу установки параметров форматирования внешнего диапазона данных, обратитесь к справочной системе Microsoft Excel.

Обычное и совместное использование запросов. И в мастере запросов и в Query можно сохранить файл запроса .dqy, который может быть изменен и использован, в том числе и совместно. Excel непосредственно открывает файлы .dqy, что позволяет так же и другим пользователям создавать дополнительные диапазоны внешних данных из того же запроса.

Для совместного использования итогов или отчета Excel, основанного на внешних данных, необходимо дать другим пользователям книгу Excel, содержащую диапазон внешних данных, или создать шаблон отчета. Шаблон отчета позволяет сохранять итоги или отчет без сохранения внешних данных, что приводит к уменьшению размера файла. Внешние данные загружаются при открытии шаблона отчета. Для получения сведений о создании шаблонов отчета, обратитесь к справочной системе Microsoft Excel.

Обновление внешних данных. Для обновления внешних данных запустите запрос для загрузки любых новых или измененных данных, подпадающих под определение. Обновление запроса может производиться и в Query, и в Excel. Excel предоставляет несколько параметров для обновления запросов, включая обновление данных при открытии книги и автоматическое обновление с определенными интервалами времени. Пока происходит обновление данных, можно продолжать работать в Excel. Также можно проверить состояние обновления. Для получения сведений об обновлении внешних данных в Microsoft Excel, обратитесь к справочной системе.


 (Untitled)

Использования мастера создания запросов для большинства запросов. Мастер создания запросов, который является частью Microsoft Query, предназначен для новичков в деле создания запросов. Мастер позволяет легко выбрать и собрать вместе данные из различных таблиц и полей в базе данных. После выбора данных, также можно воспользоваться мастером для отбора и сортировки результатов запроса. Используйте мастер создания запросов либо для создания полного запроса, либо для запуска запроса, который будет в дальнейшем изменен непосредственно в Query.

Непосредственная работа в Query с прочими типами запросов. При обладании опытом создания запросов или необходимости создания более сложных запросов, поработайте непосредственно с Query. Воспользуйтесь Query для просмотра и изменения запросов, которые были изначально созданы в мастере создания запросов, или для создания новых запросов без использования мастера.

Используйте непосредственно Query для создания запросов, которые делают следующее:

  • Выбор указанных данных из поля. В больших базах данных иногда возникает необходимость выбрать некоторые поля с данными и пропустить ненужные. Например, если необходимы данные по двум продуктам в поле, которое содержит данные по многим продуктам, то воспользуйтесь условием для выбора данных только для двух необходимых продуктов. Изучите использование условий.

  • Извлечение данных, основанных на различных условиях при каждом запуске запроса. Если необходимо создать схожий отчет Excel или итог для нескольких областей со схожими внешними данными, например как отдельный отчет по продажам для каждой области, то создайте параметрический запрос. При запуске параметрического запроса, будут запрошены данные, которые будут использоваться как условие при выборе запросом записей. Например, параметрический запрос может запросить указать область. Этот запрос может быть использован для создания отчета по продажам для каждой области. Изучите параметрические запросы.

  • Объединение данных различными способами. Воспользуйтесь Query для объединения или связывания данных из различных таблиц в базе данных. Например, можно объединить две таблицы, с данными о продажах продуктов и заказчиках, способами показывающими заказчиков, которые не производили закупки в последнее время. Изучите объединение таблиц.

Создание куба OLAP из данных запроса. Электронная аналитическая обработка данных (On-Line Analytical Processing — OLAP) является способом организации данных для создания запросов и отчетов, вместо обработки транзакций. В базе данных OLAP данные организованы иерархически и хранятся в кубах вместо таблиц.

Для создания куба OLAP из данных запроса, можно воспользоваться Query, что позволит затратить меньше времени и усилий для создания отчетов Microsoft Excel, основанных на этих данных. Для создания куба OLAP запустите мастер создания кубов OLAP из мастера запросов или непосредственно из Query. Данные можно вернуть в Excel как Отчет сводной таблицы. Изучите создание куба OLAP из запрашиваемых данных.

Дополнительные сведения

Когда использовать мастер запросов вместо Microsoft Query


(Untitled)

Используйте самообъединения для объединения данных в одной таблице. Например, в таблице работников каждая запись включает идентификационный номер его руководителя, которому отчитывается работник. Записи о руководителях находятся в той же таблице работников, поэтому можно объединить таблицу с собой же, для возврата и имени, и идентификационного номера руководителя.

Объединяя таблицу с собой же, можно загрузить и идентификационный номер, и имя руководителя.

Дополнительные сведения

Загрузка нескольких полей при помощи самообъединений


 Примеры выражений, использующих операторы сравнения

Примеры выражений, использующих операторы сравнения

Операторы сравнения используются в выражениях, которые используются в качестве условий выбора записей для ограничения таблицы результатов.

Оператор сравнения | Значение | Пример | Выберите из списка Условие | Введите в поле Значение
= (знак равенства) | Равно | Поиск записей о покупателях из Германии | Страна | =Германия
<> (знак неравенства) | Не равно | Поиск записей о поставщиках, живущих не в России | Страна | <>Россия
> (знак "больше") | Больше | Поиск записей о заказах, сделанных после указанной даты | Дата_заказа | >6/30/2000
< (знак "меньше") | Меньше | Поиск записей о заказах, сделанных до указанной даты | Дата_заказа | <6/30/2000
>= (знак "больше или равно") | Больше или равно | Поиск записей о заказах, сделанных не раньше указанной даты | Дата_заказа | >=6/30/2000
<= (знак "меньше или равно") | Меньше или равно | Поиск записей о заказах, сделанных не позже указанной даты | Дата_заказа | <=6/30/2000


Примеры выражений, использующих логические операторы

Логические операторы сравнения.

Логический оператор | Значение | Пример | В Выберите из списка Условие | Введите в поле Значение
И | В таблице результатов все значения в соответствующих полях должны быть истинными. | Поиск записей о заказах, сделанных в определенный промежуток времени | Дата_заказа | >05.06.2000 И <23.06.2000
ИЛИ | В таблице результатов условия для всех полях должны быть истинными. | Поиск записей о поставщиках, живущих в одном из двух мест. | Страна | Россия ИЛИ Бразилия
Не | В таблице результатов это условие не будет истинным. | Поиск записей о поставщиках, не живущих в указанной стране | Страна | НЕ Канада


Примеры выражений, использующих прочие типы операторов

В приведенной ниже таблице перечислены операторы, которые можно использовать для выбора диапазона значений, поиска значений, равных одному из заданного набора, определения наличия некоторого значения в поле записи или для поиска записей с использованием символов подстановки.

Оператор | Значение | Пример | Выберите в поле Условие | Введите в поле Значение
"между" | Вывод значений, лежащих в заданном диапазоне | Поиск записей, в которых сумма заказа лежит в промежутке от 1000 р. до 3000 р. | Сумма_заказа | между 1000 и 3000
"содержится в" | Определяет, равно ли значение любому из списка | Поиск записей о заказчиках из Пскова, Курска и Орла | Город | содержится в ('Псков', 'Курск', 'Орел')
"Null" | Проверяет отсутствие значения в указанном поле записи | Поиск записей о служащих, не содержащих сведений о руководителе | Руководитель | "Null"
"не Null" | Проверяет наличие значения в указанном поле записи | Поиск записей о служащих, содержащих сведения о руководителе | Руководитель | "не Null"
Похоже на | Сравнение значений при помощи оператора Похоже на и подстановочного символа "%" | Поиск записей о служащих, фамилии которых начинаются на "См", например "Смехов" или "Смирнов" | Фамилии | содержит 'См%'


 Выводится сообщение о том, что задан неверный путь к базе данных.

Выводится сообщение о том, что задан неверный путь к базе данных.

Проверьте подключение сетевых дисков. Если база данных находится в сетевом каталоге, то при создании источника данных и выборе файла базы данных ее путь мог быть записан с именем используемого в тот момент подключенного диска. Например, если база данных называется Inventory.mdb и диску G был поставлен в соответствие сетевой каталог, в котором находится база данных, то это местоположение могло быть записано в источник данных как "G:\public\Inventory.mdb". Если диску G не будет поставлен в соответствие тот же сетевой каталог, то при использовании этого источника данных или выполнении запросов к нему драйвер ODBCвыведет сообщение о том, что указан неправильный путь.

Не используйте имена подключенных сетевых дисков. При работе с драйвером для Microsoft Access или Microsoft Excel этот вопрос можно решить путем создания нового источника данных.При задании расположения файла базы данных не выбирайте диск, поставленный в соответствие сетевому каталогу. Вместо этого введите UNC адрес сетевого каталога и найдите файл базы данных. Например, если файл базы данных находится на сервере «Общий», то следует ввести \\Общий\public, а затем выбрать файл Inventory.mdb.

Сопоставляйте тот же диск, что и до использования источника данных. При использовании других драйверов ODBC перед использованием источника данных или выполнением запроса к этому источнику убедитесь, что сетевому каталогу поставлен в соответствие тот же диск, что и при создании источника данных.


 Ранее используемый драйвер ODBC не работает

Ранее используемый драйвер ODBC не работает

Использование нового драйвера в Microsoft Query 2000 может понадобиться в следующих случаях:

Убедитесь, что используете 32-разрядный драйвер ODBC. Microsoft Query 2000 необходимы 32-разрядные драйверы ODBC, например поставляемые с Microsoft Query 2000 и Microsoft Query 97. Например, если вы создаете в Visual Basic программу для получения внешних данных из Microsoft Excel 2000 и передаете ее пользователям Microsoft Excel версии 5.x, то эта программа может не работать с 16-разрядными драйверами ODBC Microsoft Excel версии 5.x.

Убедитесь, что драйверы имеют версию 3.0 или выше. При установке драйверов Microsoft ODBC, отличных от поставляемых с Microsoft Excel 2000 или Microsoft Office 2000, убедитесь, что используется версия 3.0 или выше этих драйверов. Ранние версии драйверов Microsoft ODBC могут не работать с Microsoft Query 2000. Драйвера поставляемые с Microsoft Excel 97 и Microsoft Office 97 имеют версию 3.0 или выше. При установки этих драйверов, старые драйвера будут автоматически замещены.

Убедитесь в правильности версии драйвера от сторонних производителей. При использовании драйверов ODBC от сторонних производителей также может понадобиться установка нового драйвера ODBC для Microsoft Query при обновлении или установке новой версии базы данных. Чтобы определить, необходимо ли это, обратитесь к документации на базу данных.


 Поля даты или времени повреждены или неверны

Поля даты или времени повреждены или неверны

Проверка полей даты и времени в исходной базе данных. Если не видны уровни ожидаемые в размерностях даты или времени в кубе OLAP, то проверьте поля даты и времени из базовой реляционной базы данных, которая поставляет записи для запроса. Дата или время в записях могут быть сохранены как текст вместо форматов даты или времени, которые могут быть опознаны мастером создания куба. При подобных сомнениях, свяжитесь с администратором реляционной базы данных для проверки и исправления формата даты и времени для поля.

Проверьте верхний уровень размерности. Когда мастер создания куба OLAP добавляет поля даты и времени как нижний уровень существующей размерности, он автоматически не разбивает дату на уровни год/квартал/месяц/неделю и час/минута/секунда. Мастер производит это только когда поле даты или времени добавлено с верхним уровнем новой размерности. Если поле даты или времени не имеет верхний уровень, то измените куб.


 Изменения запроса не отображаются при его следующем выполнении

Изменения запроса не отображаются при его следующем выполнении

Excel не сохраняет изменений форматирования в запросах. При возврате данных в Excel определение запроса сохраняется как часть листа, но автоматического сохранения отдельного файла запроса при этом не происходит. При редактировании запроса в Microsoft Query для внешнего диапазона данных изменения форматирования или изменения заголовков столбцов не сохраняются.

Изменения форматирования не сохраняются в файлах запросов .dqy. При сохранении файла в формате .dqy изменения форматирования или изменения заголовков столбцов не сохраняются.

Изменения форматирования сохраняются в файлах запросов .qry. Для сохранения измененного форматирования в Microsoft Query выберите в меню Microsoft Query Файл команду Сохранить как, а затем Файлы запросов (*.qry) в списке Тип файла. При открытии сохраненного файла запроса форматирование Query будет видно.


 В момент изменения куба OLAP, получено сообщение о потере данных.

В момент изменения куба OLAP, получено сообщение о потере данных.

Поле включенное в куб больше недоступно в исходной базе данных.

Проверка изменений в исходной базе данных. Если был сохранен запрос, созданный после создания куба, то можно открыть запрос к базе данных, иначе только создать новый запрос. В запросе проверьте область данных для того чтобы быть уверенным, что все изначально включенные поля все еще находятся в запросе. Прокручивая список полей, можно посмотреть, какие поля доступны в области таблицы.

Если невозможно открыть уже существующий запрос или создать новый, свяжитесь с администратором базы данных для получения дополнительных сведений об изменении базы данных.

Создание нового куба. Если поля были удалены из базы данных, то можно создать новый куб.


Невозможно добавить поля в куб OLAP

После определения куба в мастере создания, невозможно вставить новые поля из исходной реляционной базы данных. Для добавления новых полей необходимо изменить файл запроса к базе данных (.dqy) и создать заново куб.

Открытие или создание запроса. Если созданный запрос к базе данных сохранен, то можно открыть файл .dqy. Если запрос не сохранен, то можно создать новый запрос.

Добавление полей к запросу. Добавьте необходимые поля. Если в будущем куб с другими полями не понадобится, то сохраните копию запроса, для того чтобы не создавать заново запрос каждый раз.

Создание нового куба. После создания запроса со всеми полями необходимыми для куба, возможно создание нового куба.


 Необходимая функция суммирования для данных куба недоступна.

Необходимая функция суммирования для данных куба недоступна.

При использовании мастера для создания куба из записей в реляционной базе данных, только функции суммирования, такие как «Сумма», «Число», «Минимум» и «Максимум», доступны для вычислении значений полей данных.

Создание отчетов непосредственно из записей базы данных. Если возможно уточнить запрос так, чтобы количество возвращаемых данных не было больше того количества, к которому может обратиться система, и нет необходимости создавать куб OLAP для данных, то попробуйте вернуть записи запроса в Microsoft Excel вместо того, чтобы создавать куб.

В Excel при создании отчета сводной таблицы или сводной диаграммы, основанного непосредственно на запросе к реляционной базе данных (без участия куба), будет доступно большее число функций суммирования: СУММ, СЧЁТ, СРЗНАЧ, МАКС, МИН, ПРОИЗВЕД, СТАНДОТКЛОН, СТАНДОТКЛОНПА, ДИСП, ДИСПР и др. Дополнительные сведения о функциях суммирования можно найти в справке Microsoft Excel.

Обдумайте настройку сервера OLAP для базы данных. Серверные средства OLAP, Microsoft SQL Server OLAP Services, позволяют настраивать более широкий диапазон суммарных полей чем система доступа OLAP включенная в Microsoft Office.


Недостаточно места на диске при попытке сохранения автономного куба

Реляционная база данных, для которых создается запрос, может быть очень большой. Если задан большой поднабор данных для автономного куба, то возможно, что недостаточно места на локальном диске.

Освободите пространство на диске или найдите другой диск. Удалите ненужные файлы с диска, прежде чем сохранять файл, или попробуйте сохранить файл на сетевом диске.

Включайте меньше данных в автономный куб. Обдумайте как можно уменьшить количество данных в фалах, которые необходимы для отчетов сводной таблицы и сводной диаграммы Microsoft Excel. Попробуйте следующее:

  • Включайте только самые необходимые поля. На первом шаге мастера создания куба выберите только те поля данных, которые необходимы для показа отчетом.

  • Включайте только те размерности, которые будут использоваться. На втором шаге мастера создания куба добавьте только поля , которые необходимы для показа отчетом как размерности и уровни. Для получения дополнительных указаний по созданию размерностей обратитесь к справочной системе мастера создания куба.

Используйте временный куб вместо файла автономного куба. Если все возможные данные исключены и все еще невозможно сохранить файл автономного куба, то попробуйте использовать первый параметр (использование меньшего дискового пространства) в третьем шаге мастера создания куба. Этот параметр перестраивает куб в памяти, когда открывается отчет построенный на данном кубе, и загружаются только те данные , которые необходимы для показа отчетом.


 Невозможно добавить, копировать или переместить запись в базе данных

Невозможно добавить, копировать или переместить запись в базе данных

В Microsoft Query 2000 можно изменять и удалять записи, уже присутствующие в базе данных, но нельзя добавлять новые записи или изменять порядок расположения записей, а также нельзя использовать Query для добавления записей в базы данных, доступ к которым обеспечивается драйверами для Excel или для текста.

Непосредственная работа с базой данных. Если необходимо скопировать запись, то откройте базу данных непосредственно и используйте команды предоставляемые базой данных. Для получения дополнительных сведений и указаний обратитесь к администратору базы данных.

Сортировка записей запроса в Query. Порядок расположения записей в таблице результатов можно изменить при помощи команды Сортировка в меню Записи. Сортировка в Microsoft Query не влияет на саму базу данных, а только на таблицу результатов. Для получения дополнительных сведений нажмите кнопку [image] .


 Невозможно создать требуемый тип объединения

Невозможно создать требуемый тип объединения

Для внешних объединений убедитесь, что запрос содержит не более двух таблиц. Если запрос содержит более двух таблиц, то невозможно произвести внешнее объединение в запросе. Параметры 2 и 4 в диалоговом окне Объединения соответствуют внешним объединениям.

Запрос может содержать только одно внешнее объединение. Возможно создать сколько угодно внутренних объединений (параметр 1 в диалоговом окне Объединения), но только одно внешнее объединение в каждом запросе. При навыках программирования на языке SQL, возможно попытаться изменить инструкцию SQL в диалоговом окне SQL (меню Вид, команда SQL) для создания более чем одного внешнего объединения.

Информация об объединениях. Для получения дополнительных сведений об использовании внешних объединений при объединении записей нажмите кнопку [image] .


 Таблица результатов не может быть сохранена как таблица базы данных

Таблица результатов не может быть сохранена как таблица базы данных

Microsoft Query 2000 не позволяет сохранять таблицу результатов как таблицу в базе данных.

Импорт данных в базу данных из Excel. Если в базу возможен импорт данных из Microsoft Excel, то можно передать таблицу результатов в Microsoft Excel, а затем импортировать данные из Microsoft Excel в таблицу. Например, в Microsoft Access имеется мастер импорта таблиц, который может быть использован для создания таблиц из данных Microsoft Excel. Для получения дополнительных сведений обратитесь к документации или справочной системе базы данных.

Импорт текстовых файлов в базу данных. Если в базу данных возможен импорт текстовых файлы, то можно передать таблицу результатов в Microsoft Excel, сохранить ее как текстовый файл, а затем импортировать в базу данных. Для получения дополнительных сведений о преобразовании текстовых данных обратитесь к справочной системе Microsoft Excel.


 Невозможно найти или удалить источник данных.

Невозможно найти или удалить источник данных.

Источники данных, созданные более ранними версиями Query. Источники данных, созданные при помощи более ранних версий Microsoft Query, чем Query 97, помечены знаком «звездочка» после имени источника данных. Все источники данных, включая также те, которые созданы при помощи Query 2000, хранятся в файлах с расширением .dsn. Для получения списка источников данных, которые созданы более ранними версиями Query, выберите Параметры в диалоговом окне Выбор источника данных (меню файл Файл, команда Создать), и тогда установите флажок Источники из реестра в список доступных баз данных. Если источники данных сохранены в стандартной папке, то можно выбрать их в диалоговом окне Выбор источника данных и нажать кнопку Удалить.

Местоположение файлов источников данных. Файлы источников данных из предыдущих версий Microsoft Query обычно хранятся в папке «Источники данных ODBC» в папке Common Files. Список файлов источников данных для Query 2000 хранится в папке профиля пользователя в Application Data\Microsoft\Queries. Для того, чтобы увидеть папки, где хранятся файлы источников данных, необходимо нажать кнопку Создать запрос [image] , выбрать вкладку Базы данных и нажать кнопку Параметры.

Поиск и удаление файлов источников данных. Для поиска и удаления файлов источников данных необходимо сделать следующее:

  • Использование панели управления Windows. Если все файлы источников данных находятся в папке Common Files\ODBC Datasources или в папке профиля пользователя, дважды щелкните на значок Источники данных ODBC (32bit) в панели управления, нажмите на вкладку Файл DSN и затем кнопку Удалить для удаления ненужных .dsn файлов.

  • Поиск .dsn файлов. Если файлы источников данных находятся в нескольких папках Windows, то воспользуйтесь командой Microsoft Windows Поиск для поиска всех файлов с расширением .dsn с последующим удалением ненужных .


Невозможно редактировать запрос.

Убедитесь, что редактирование разрешено. В меню Правка выберите Параметры и затем снимите флажок Запретить изменение результатов запроса.


 Не удается найти нужную таблицу

Не удается найти нужную таблицу

Если список таблиц не включает таблицы, которые ожидалось увидеть, проверьте следующее, в зависимости от параметров доступных для источника данных:

  • Проверка владельца. Таблицы могут принадлежать другому владельцу. В диалоговом окне Добавление таблиц выберите другого владельца в поле Владелец. Перед использованием таблиц может понадобиться получить разрешение их владельца.

  • Проверьте типы отображаемых таблиц. Нужные таблицы могут иметь тип, который не выбран для просмотра. В диалоговом окне Добавление таблиц нажмите кнопку Параметры. Убедитесь, что в группе Показывать выбраны все типы таблиц.

  • Обновление списка таблицы. Нужные таблицы могли быть добавлены в базу данных за время, прошедшее после присоединения к ней Microsoft Query. Чтобы просмотреть список недавно добавленных таблиц, нажмите кнопку Параметры в диалоговом окне Добавление таблиц, а затем нажмите кнопку Обновить.


 Не удается создать новый источник данных

Не удается создать новый источник данных

Проверьте драйвер. Убедитесь, что установлен нужный драйвер ODBC или драйвер источника данных для источника данных. Драйверы ODBC расширяют возможности Microsoft Query, и подключение к новым базам данных становится возможно сразу после установки нового драйвера. Однако сначала следует убедиться, что нужный для базы данных драйвер установлен и настроен.

Убедитесь, что драйвер работает с Microsoft Query. В дополнение к драйверам, поставляемым с Microsoft Query, могут использоваться драйверы ODBC и источников данных от сторонних производителей. Перед использованием такого драйвера желательно убедиться, что изготовитель протестировал этот драйвер с Microsoft Query 2000. Для некоторых баз данных лучшим выбором будут драйверы, поставляемые вместе с программным обеспечением базы данных. Свяжитесь с администратором базы данных и узнайте, какие драйверы доступны и что лучше всего использовать при работе с этой базой. Обратитесь к списку драйверов поставляемых с Query.

Проверьте адрес сервера и информацию для идентификации. Перед настройкой источника данных убедитесь, что адрес размещения базы данных в сети известен и у вас есть необходимые для подключения и входа в базу данных разрешения. Обратитесь к администратору базы данных для получения идентификатора входа, пароля или любых других необходимых разрешений, а также чтобы убедиться, что разрешенный доступ к базе данных возможен.

Убедитесь, что драйвер установлен правильно. Чтобы показать список доступных ODBC драйверов, нажмите кнопку Создать запрос [image] , дважды щелкните Новый источник данных на вкладке Базы данных или Кубы OLAP, введите имя в диалоговом окне Создание нового источника данных и выберите драйвер из списка. Если вкладка Кубы ОLAP недоступна, запустите Query из-под Microsoft Excel, указав в меню Excel Данные на пункт Внешние данные и выбрав команду Новый источник данных. Дважды щелкните Новый источник данных на вкладке Кубы OLAP, затем введите имя в диалоговом окне Создание нового источника данных и выберите драйвер из списка. Если нужный драйвер не виден, то необходимо убедиться, что нужный драйвер правильно установлен. См. способы установки драйверов.

Убедитесь, что введена вся конфигурационная информация. После установки драйвера и выбора его в диалоговом окне Создание нового источника данныхубедитесь, что следующим шагом были введены все необходимые данные. Для получения сведений о драйвере Microsoft нажмите кнопку Подключить, а затем нажмите кнопку Справка в диалоговом окне установки драйвера. Для драйверов сторонних производителей, обратитесь к справочной системе или документации на драйвер.

При создании источника данных с драйвером ODBC или драйвером источника данных от Microsoft щелкните имя драйвера для получения сведений о параметрах, которые нужно установить в диалоговом окне Создание нового источника данных.

Драйверы ODBC

Драйвер для Microsoft Access

Драйвер для dBASE

Драйвер для Microsoft FoxPro

Драйвер для Microsoft Excel

Драйвер Microsoft ODBC для Oracle

Драйвер для Paradox

Драйвер для текстов (Microsoft)

Драйвер для SQL Server

Драйвер источника данных

Драйвер для Microsoft SQL Server OLAP Services


 При использовании объединений не возвращаются те записи, которые ожидались

При использовании объединений не возвращаются те записи, которые ожидались

Запрос использует по умолчанию внутренние объединения. По умолчанию объединение,которое используется Microsoft Query для объединения таблиц автоматически является внутренние объединение (вариант 1 в диалоговом окне Объединения). Когда две таблицы объединены внутренним объединением, записи из второй таблицы, которые не соответствуют записям из первой, не будут включены в таблицу результатов.

Создание внешнего объединения. Для загрузки всех записей из обоих таблиц, когда одна из них содержит записи не представленные в другой, необходимо использовать внешнее объединение (варианты 2 и 3 в диалоговом окне Объединения). Для получения информации о использовании внешних объединений записей нажмите на [image] .

Проверка множественных объединений между однообразными таблицами. Внешнее объединение между двумя таблицами иногда не возвращает никаких записей из второй таблицы. Если тогда добавить внутренние объединение между этими таблицами, Microsoft Query не загрузит никаких записей из обоих таблиц. Для того чтобы показать записи, необходимо удалить одно из объединений.

Сведения об объединениях. Для получения дополнительных сведений об объединениях нажмите на [image] .


 Microsoft Query не возвращает все доступные записи

Microsoft Query не возвращает все доступные записи

Убедитесь, что не установлено ограничение на число возвращаемых записей. Убедитесь, что не установлено ограничение на число возвращаемых записей. В меню Правка выберите команду Параметры и убедитесь, что сброшен флажок Максимальное число возвращаемых записей в группе Параметры.

Проверьте условия. Убедитесь, что все заданные условия введены правильно. Для получения дополнительных сведений о задании условий нажмите кнопку [image] .

Проверьте объединения. Убедитесь, что все созданные объединения дают нужные результаты. Для получения дополнительных сведений об объединениях нажмите кнопку [image] .


 Microsoft Query не может подключиться к базе данных в течение заданного интервала времени

Microsoft Query не может подключиться к базе данных в течение заданного интервала времени

Установите более долгое время для подключения. По умолчанию Microsoft Query пытается подключиться к базе данных в течение интервала времени, определенного драйвером ODBC для источника данных. Если подключение к базе данных требует больше времени, то можно установить более длинный интервал. Выберите в меню Microsoft Query Правка команду Параметры и убедитесь, что установлен флажок Разрывать связь при отсутствии активности через, а затем задайте время в секундах, в течение которого должно производиться подключение.

Разрешение Query пытаться произвести подключение неограниченно долго. Чтобы отключить ограничение на период времени, в течение которого должно произойти подключение, снимите флажок Разрывать связь при отсутствии активности через. Если Microsoft Query не может подключиться к базе данных, то можно отменить соединение путем нажатия клавиши ESC.


 Невозможен доступ в Microsoft Query к данным списка Microsoft Excel.

Невозможен доступ в Microsoft Query к данным списка Microsoft Excel.

Закрытие книги. Прежде чем пытаться получить доступ к данным, убедитесь, что книга не открыта в Microsoft Excel.

Проверка листа. Проверьте следующее на листе Microsoft Excel:

  • Проверка формата списка. Убедитесь, что список соответствует формату списка Microsoft Excel. Для получения дополнительных сведений о создании списка на листе книги обратитесь к справочной системе Microsoft Excel. Присвойте имена диапазонам, которые представлены как таблицы, и убедитесь, что имена диапазонов не совпадают.

  • Присвоение имени списку. Microsoft Query распознает как таблицы только именованные диапазоны. Чтобы присвоить имя списку, отметьте весь список в Microsoft Excel и введите его имя в поле Имя на панели формул.

  • Не получайте доступ к списку как к системной таблице. Не пытайтесь получить доступ к таблицам Microsoft Excel, установив параметр Системные таблицы под списком Показать в диалоговом окне Параметры таблицы. При использовании такого способа Microsoft Query может принять пустые ячейки листа за данные и не распознать некоторых реальных данных, а также может неправильно выбрать данные.

  • Форматируйте списки для объединения данных схожим образом. Используйте один и тот же формат для столбцов всех списков, которые нужно объединить. Например, если в каждом списке содержится столбец дат, форматируйте все эти столбцы одинаково. При использовании текстовых и числовых форматов внутри столбца драйвер для Microsoft Excel не сможет найти и объединить все данные.

  • Не используйте в списках такие имена столбцов, как "Таблица" или "База данных". Microsoft Query использует некоторые подписи для служебных целей и не распознает их при использовании в данных.

  • Переместите все книги в одну и ту же папку. Возможно, источник данных, определенный для Microsoft Excel, может одновременно обеспечить доступ только к книгам из одной папки. Если списки находятся в разных книгах, убедитесь, что книги находятся в папке, заданной при определении источника данных.

  • Переместите книги в папку, ожидаемую источником данных. Перед загрузкой Microsoft Query скопируйте все необходимые книги в указанную в источнике данных папку. Microsoft Query не распознает автоматически новые книги, добавленные в папку при создании запроса. Доступ к новым книгам может быть получен нажатием кнопки Параметры в диалоговом окне Добавление таблиц, а затем — кнопки Обновить.

Используйте Excel для объединения данных. Microsoft Query может использоваться для объединения данных из двух и более списков Microsoft Excel. При работе с данными одного листа или использовании простых условий для выбора строк из одного листа удобнее использовать команды Автофильтр и Расширенный фильтр (меню Данные, подменю Фильтр) Microsoft Excel. Для получения дополнительных сведений о автофильтрах и расширенных фильтрах обратитесь к справочной системе Microsoft Excel.


Невозможно изменение типов параметров процедуры SQL в Microsoft Query

Чтобы создать параметры сохраняемой процедуры SQL и задать типы данных, выполните следующее:

  1. Выберите команду Выполнить запрос SQL в меню Файл.

  2. Создайте запрос с использованием фиксированных аргументов процедуры в поле Инструкция SQL, а затем нажмите кнопку Сохранить.

  3. Выберите команду SQL в меню Вид.

  4. В поле Инструкция SQL замените каждый фиксированный аргумент символом "?".

  5. Нажмите кнопку OK, а затем выберите в меню Вид команду Параметры.

  6. Чтобы изменить тип данных параметра, выберите параметр и нажмите кнопку Изменить.


 Невозможно создать почтовые наклейки в Microsoft Query

Невозможно создать почтовые наклейки в Microsoft Query

Загрузка Query данных для почтовых наклеек. Microsoft Query является средством выбора данных из базы данных и не может создавать почтовые наклейки. Однако данные из Microsoft Query могут быть переданы в Microsoft Excel или Microsoft Word для создания почтовых наклеек.

Создание почтовых наклеек в Word. Сначала передайте данные в Microsoft Excel путем выбора в меню Файл команды Вернуть данные в Microsoft Excel. После передачи таблицы результатов в Microsoft Excel эти данные могут быть использованы как почтовый список в Word. Для получения дополнительных сведений о почтовых наклейках обратитесь к справочной системе Microsoft Excel или Word.


 Microsoft Query не может напечатать таблицу результатов

Microsoft Query не может напечатать таблицу результатов

Query не способен самостоятельно печатать. Microsoft Query является средством выбора данных из базы данных и не может самостоятельно печатать отчеты.

Печать записей из Excel. Чтобы напечатать таблицу результатов, передайте ее в Microsoft Excel, выбирая в меню Файл команды Вернуть данные в Microsoft Excel. После передачи таблицы результатов в Microsoft Excel можно использовать все команды форматирования и печати Microsoft Excel. Для получения дополнительных сведений о печати в Microsoft Excel обратитесь к справочной системе Microsoft Excel.


 Microsoft Query продолжает использовать ресурсы связи, даже когда я не работаю с базой данных

Microsoft Query продолжает использовать ресурсы связи, даже когда я не работаю с базой данных

Каналы связи остаются открытыми на протяжении всего сеанса работы Query. По умолчанию, Microsoft Query открывает один канал связи с базой данных, который не закрывается до выхода из Microsoft Query, независимо от того, сколько окон запросов к базе данных открыто на протяжении этого времени. При создании запросов к нескольким базам данных во время работы с Microsoft Query, открытые каналы связи могут использовать ресурсы и дорогое время связи.

Закрытие каналов связи в момент закрытия окна запросов. Для сокращения времени связи Microsoft Query может закрыть канал связи при отсутствии открытого окна запроса к базе данных. Чтобы канал связи был открыт только при наличии открытого окна запроса, выберите команду Параметры в меню Правка, а затем снимите флажок Поддерживать открытые каналы связи до закрытия MS Query.


 Почему источник данных помечен звездочкой?

Почему источник данных помечен звездочкой?

Источник данных, созданный при помощи предыдущих версий Microsoft Query. Форматы источников данных Query 2000 и Query 97 отличны от форматов источников данных, созданных при помощи предыдущих версий Query. Источники данных и запросы, созданные в более ранних версиях Microsoft Query чем Query 97, по-прежнему могут использоваться в Query 2000, но запросы созданные с использованием этих источников данных не могут использоваться совместно с другими пользователями. Более ранние версии Microsoft Query чем Query 97 сохраняют сведения источника данных как часть операционной системы Microsoft Windows, тем самым информация доступна только в данной системе

Описание совместно неиспользуемых источников данных. Чтобы использовать источники данных, созданные более ранними версиями Query, нажмите кнопку Параметры в диалоговом окне Выбор источника данных (меню Файл, команда Создать), и установите флажок Источники из реестра в список доступных баз данных. Все источники данных, созданные более ранними версиями Query, чем Query 97, будут помечены звездочкой в диалоговом окне Выбор источника данных.

Cоздание совместно используемых источников данных. Для совместного доступа к запросам или шаблонам отчетов, которые используют данные из внешних баз, указанных в источниках данных, которые не используются совместно, создайте новые источники данных Microsoft Query 2000 для этих баз данных, и используйте новые источники данных для создания запросов и шаблонов отчетов.

Удаление старых источников данных. Способ удаления источников данных, которые не используются совместно.


Невозможно изменить куб OLAP

Удостоверение в доступности исходной базы данных. Для изменения куба OLAP необходимо иметь доступ к исходной базе данных сервера, которая содержит данные для куба. Проверьте расположение базы данных для того, чтобы убедиться, что она не переименована или передвинута. Убедитесь, что сервер доступен и что вы можете подключиться к нему.

Проверка изменений исходной базы данных. Таблицы в базе данных могут быть изменены или переименованы, поэтому куб не может больше находить исходные данные. Проверьте наличие изменений в организации или схеме базы данных. Для этого можно открыть уже существующий запрос к базе данных или создать новый запрос. В меню Таблица, нажмите кнопку Добавить таблицу для того, чтобы увидеть какие таблицы доступны. Если невозможно открыть уже существующий запрос или создать новый, свяжитесь с администратором базы данных для получения дополнительных сведений об изменении базы данных.


 Получено сообщение о невозможности открытия .oqy файла мастером создания куба OLAP

Получено сообщение о невозможности открытия .oqy файла мастером создания куба OLAP

Удостоверьтесь, что файл изначально создан мастером создания. Открытие и изменение файлов .oqy возможно только если они созданы и сохранены мастером создания куба OLAP. Невозможно использовать мастер для открытий и изменения других файлов .oqy, которые не содержат описания куба, например подключенные к базе данных сервера OLAP или к файлу автономного куба.

Создание заново файла .oqy. Если невозможно открыть файл .oqy, который был создан мастером создания куба OLAP, то возможно файл поврежден. Попробуйте открыть резервную копию файла или создайте куб заново, если резервная копия файла отсутствует.


Поскольку база данных доступна только для чтения, создание или удаление таблиц невозможно. Продолжить?

В базе данных, доступной только для чтения, можно просмотреть описание таблицы, но нельзя создать новые или удалить существующие.


Нет доступа к записи: другой пользователь внес изменения или столбцов задано недостаточно.

Microsoft Query не может найти запись таблицы, совпадающую с удаленной или измененной в запросе записью. Запрос может содержать число столбцов, недостаточное для того, чтобы выделить запись, которую требуется обновить. С момента последнего запроса запись также могла быть изменена другим пользователем. Перед обновлением записи выполните одно из следующих действий:

  • Добавьте в запрос большее число столбцов или столбец, который единственным образом описывает запись.

  • Для получения последних данных из таблицы повторно выполните запрос, выбрав в меню Записи команду Выполнить запрос.


Существуют удаленные связи; закрыть?

С данными запроса установлена связь из других приложений, например Microsoft Excel или Microsoft Word.

  • Чтобы закрыть запрос и прервать связь, нажмите кнопку OK. После закрытия запроса связь не может быть восстановлена.

  • Чтобы оставить открытым запрос и не прерывать связь, нажмите кнопку Отмена.


Сохранить большое содержимое буфера обмена из <имя>?

В буфер обмена помещен большой объем данных.

  • Чтобы сохранить данные из буфера обмена и закрыть запрос или выйти из Microsoft Query, нажмите кнопку Да.

  • Чтобы удалить данные и закрыть запрос или выйти из Microsoft Query, нажмите кнопку Нет.

  • Чтобы продолжить работу с Microsoft Query с данными в буфере обмена, нажмите кнопку Отмена.


Отсутствует окно помощника

  • Одно окно может заслоняться другим окном. Чтобы показать окно, скрытое за другим окном, закройте окно, расположенное на переднем плане.

  • Советы, сообщения и напоминания автоматически исчезают при выводе на экран справки и отображаются вновь, если закрыть окно справки или щелкнуть любое место окна запроса.

  • Окно помощника, которое отображалось до переключения в другую программу, больше не показывается. Все сообщения относятся только к программе, активной в настоящий момент.

  • Некоторые виды окон помощника закрываются автоматически, если щелкнуть окно запроса. Это сообщения информативного характера, не требующие ответа пользователя. Например, после завершения проверки орфографии на экран выводится сообщение о ее окончании. Для повторного отображения такого сообщения необходимо повторить действия, которые привели к его появлению, например, еще раз выполнить проверку орфографии.


Не удается продолжить работу с Microsoft Query

При отображении некоторых видов сообщений (помощником или без его помощи) продолжение работы с Microsoft Query может быть невозможно до тех пор, пока окно сообщения не будет закрыто. Это важные сообщения, для которых необходим ответ пользователя.

Нажмите требуемую кнопку в окне сообщения. После закрытия окна сообщения можно продолжать работать с Microsoft Query. Если сообщение больше не отображается, а отображается совет или справка, щелкните любое место окна запроса, чтобы сообщение отображалось на экране.


Извлечение связанных записей из нескольких таблиц с объединениями

Объединение таблиц
Внутренние объединения
Внешние объединения
Самообъединения
Полные внешние объединения
Вычитательные объединения


Извлечение связанных записей из нескольких таблиц с объединениями


Сохранить изменения в запросе <имя>?

С момента последнего сохранения в проект или форматирование запроса внесены изменения.

  • Для сохранения изменений перед закрытием запроса нажмите кнопку Да.

  • Чтобы отменить изменения и закрыть запрос, нажмите кнопку Нет.

  • Чтобы оставить запрос открытым без сохранения изменений, нажмите кнопку Отмена.


Инструкция SQL выполнена. Обработано строк: <число>.

Указанная инструкция SQL выполнена Microsoft Query. При этом обработано указанное число строк (записей).


Выполнить запрос SQL не удалось.

Microsoft Query не может выполнить инструкцию SQL. Убедитесь, что инструкция введена корректно.


Таблица <имя> уже существует; заменить?

Таблица с указанным именем уже существует.

  • Чтобы заменить существующую таблицу новой, нажмите кнопку Да.

  • Для отмены нажмите кнопку Нет, а затем введите другое имя для новой таблицы.


Сохранить файл как <имя>.

Попытка сохранить таблицу результатов с неверно указанным или отсутствующим расширением.

  • Чтобы сохранить таблицу результатов в файле с верным для источника данных расширением, нажмите кнопку OK.

  • Чтобы вернуться в Microsoft Query без сохранения таблицы результатов, нажмите кнопку Отмена.


Другое приложение закончило работу.

Другая программа — участник сеанса динамического обмена данными (DDE) — неожиданно прервала работу. Перезапустите эту программу перед началом нового сеанса DDE.


Запрос SQL не может быть представлен графически. Продолжить?

Microsoft Query не может вывести область таблиц для этого запроса. Если запрос возвращает записи, то изменение этих записей или проекта запроса в окне запроса невозможно. Однако возможно изменение проекта запроса путем выбора в меню Вид команды Запрос SQL и непосредственного изменения инструкции SQL.


Истек период ожидания отклика DDE.

Второй участник сеанса динамического обмена данными (DDE) не ответил на запрос в течение времени, определяемого параметром DDE Timeout.

  • Другая программа может ожидать ввода данных пользователем. Переключитесь в эту программу и закройте диалоговое окно или ответьте на сообщение, выданное другой программой.

  • Другая программа может быть слишком занята, чтобы ответить на сообщение DDE.

Примечание. Параметр DDE Timeout не может быть изменен.


Не требовалось <текст> после списка столбцов в инструкции GROUP BY.

После списка столбцов в операторе GROUP BY задано неверное выражение.


Не требовалось <текст> после инструкции HAVING.

После оператора HAVING в инструкции SQL задано неверное выражение.


Не требовалось <текст> после списка столбцов в инструкции ORDER BY.

После оператора ORDER BY в инструкции SQL задано неверное выражение.


Не требовалось <текст> после списка в инструкции SELECT.

После списка отбора в операторе SELECT задано неверное выражение.


Не требовалось <текст> после оператора WHERE.

Неверное выражение после оператора WHERE в инструкции SQL.


Выделено слишком много значений.

Недостаточно памяти для хранения всех значений, заданных в условиях для этого поля. Введите меньшее число значений.


Неизвестная единица измерения

Microsoft Query не может распознать символы, введенные при задании данного параметра. Введите число единиц измерения, но не включайте описатели типа, например «"» (двойная кавычка), «in» (дюймы), или «см» (сантиметры).


Обновление не выполнено. Продолжить изменение записи?

Microsoft Query не может обновить измененные данные, так как таблица или источник данных доступны только для чтения, таблица повреждена или для сохранения изменений недостаточно места на диске.


<Значение> - слишком много знаков после десятичного разделителя.

Количество десятичных позиций, расположенных справа от десятичной запятой превышает наибольшее допустимое значение для данного поля. Задайте число с меньшим количеством цифр после запятой.


<Значение> - не является логическим значением.

В поле, допускающем ввод только логических значений, введено значение другого типа. Например, в поле, допускающем только ввод значений "0" или "1", была введена дата.


<Значение> - не является правильной датой.

В поле введено значение недопустимого типа. Например, мог быть введен текст в поле, допускающем только ввод дат.


<Значение> - не является правильным числом.

В поле введено значение недопустимого типа. Например, мог быть введен текст в числовом поле.


<Значение> превышает числовой диапазон столбца.

Значение превышает максимальное допустимое для значений столбца (поля). Введите меньшее значение.


Существующая таблица не может быть изменена. Изменения могут быть использованы для создания новой таблицы.

Чтобы создать новую таблицу из существующей, необходимо изменить имя таблицы в диалоговом окне Просмотр определения таблицы. Новая таблица не будет содержать данных из существующей таблицы. Описания существующих таблиц не могут быть изменены в Microsoft Query.


Ошибочное расширение <расширение>.

Расширение файла таблицы базы данных задано неверно. Чтобы узнать правильное расширение файла, обратитесь к документации на источник данных.


Выражение слишком сложное.

Выражение слишком сложное для анализа. Попытайтесь упростить выражение.


Синтаксическая ошибка.

В выражении содержится синтаксическая ошибка. Например, не введен требуемый оператор, введен неверный символ или запятая, или введен текст, не заключенный в кавычки ( " или ' ). Проверьте правильность задания выражения.


Синтаксическая ошибка в дате.

Выражение содержит неверное значение даты. Проверьте правильность задания выражения.


Недопустимое использование '.', '!' или '()'.

Выражение содержит неверные операторы "." (точка), "!" или скобку. Например, мог быть введен неверный идентификатор или скобка после константы Null. Проверьте правильность задания выражения.


Синтаксическая ошибка в числе.

Выражение содержит неверное число. Проверьте правильность задания выражения.


Синтаксическая ошибка в строке.

Выражение содержит неверную строку. Например, могла быть превышена максимальная длина строки. Проверьте правильность задания выражения.


Оператор "Между" без "и".

При использовании оператора Между...и необходимо ввести зарезервированное слово и. Используйте следующий синтаксис:

выражение Между значение1 и значение2


Лишняя ')'.

Выражение содержит слишком много закрывающих скобок. Удалите все скобки, для которых нет парных открывающих скобок.


Не хватает памяти при вычислении.

Недостаточно памяти для выполнения расчетов.

Закройте окна в Microsoft Query или другие приложения. При повторном возникновении ошибки перезапустите Microsoft Windows и повторите вычисление.


Отсутствует ')', ']' или '|'.

В выражении не хватает закрывающей скобки, квадратной скобки или вертикальной черты. Проверьте правильность задания выражения.