О средствах статистического анализа данных

Пакет анализа. В состав Microsoft Excel входит набор средств анализа данных (так называемый пакет анализа), предназначенный для решения сложных статистических и инженерных задач. Для проведения анализа данных с помощью этих инструментов следует указать входные данные и выбрать параметры; анализ будет проведен с помощью подходящей статистической или инженерной макрофункции, а результат будет помещен в выходной диапазон. Другие средства позволяют представить результаты анализа в графическом виде.

Доступные средства. Чтобы просмотреть список доступных инструментов анализа, выберите команду Анализ данных в меню Сервис. Если команда Анализ данных в меню Сервис отсутствует — необходима установка пакета анализа. Как установить пакет анализа.

Необходимые знания. Для успешного применения процедур анализа необходимы начальные знания в области статистических и инженерных расчетов, для которых эти инструменты были разработаны.

Другие функции. В Microsoft Excel представлено большое число статистических, финансовых и инженерных функций. Некоторые из них являются встроенными, другие доступны только после установки пакета анализа. Ознакомьтесь со списком доступных статистических функций, доступных финансовых функций и доступных инженерных функций.

Дополнительные сведения

Дисперсионный анализ

Корреляционный анализ

Ковариационный анализ

Описательная статистика

Экспоненциальное сглаживание

Анализ Фурье

Двухвыборочный F-тест для дисперсий

Гистограмма

Скользящее среднее

Проведение t-теста

Генерация случайных чисел

Ранг и персентиль

Регрессия

Выборка

Двухвыборочный z-тест для средних


Установка и применение статистического пакета анализа данных

Для работы с инструментами анализа данные следует представить в виде строк или столбцов листа Excel. Совокупность ячеек, содержащих анализируемые данные, называется входным диапазоном.

Если команда Анализ данных отсутствует в меню Сервис, в Microsoft Excel необходимо установить статистический пакет анализа данных.

Чтобы установить пакет анализа данных

  1. В меню Сервис выберите команду Надстройки.

    Если список в диалоговом окне Надстройки не содержит пакета анализа данных, нажмите кнопку Обзор и укажите диск, папку и имя файла для этой надстройки, Analys32.xll (как правило, папка Microsoft Office\Office\Library\Analysis) или запустите программу Setup, чтобы установить эту надстройку.

  2. Установите флажок Пакет анализа.

Чтобы запустить пакет анализа

  1. В меню Сервис выберите команду Анализ данных.

  2. В списке Инструменты анализа выберите нужную строку.

  3. Введите входной и выходной диапазоны, затем выберите необходимые параметры.

Примечание. Надстройки, которые выбираются в диалоговом окне Надстройки, остаются активными до тех пор, пока не будут удалены. Как удалить надстройку.


Дополнительные сведения о статистических методах и алгоритмах

Подробные сведения об алгоритмах, использованных при создании функций анализа Microsoft Excel, можно найти в следующей книге:

  • Strum, Robert D., and Donald E. Kirk. First Principles of Discrete Systems and Digital Signal Processing. Reading, Mass.: Addison-Wesley Publishing Company, 1988.

Ниже приведен список литературы, в которой можно найти подробные сведения об алгоритмах, использованных при создании функций анализа Microsoft Excel:

  • Abramowitz, Milton, and Irene A. Stegun, eds. Handbook of Mathematical Functions, with Formulas, Graphs, and Mathematical Tables. Washington, D.C.: U.S. Government Printing Office, 1972.

  • Box, George E.P., William G. Hunter, and J. Stuart Hunter. Statistics for Experimenters: An Introduction to Design, Data Analysis, and Model Building. New York: John Wiley and Sons, 1978.

  • Devore, Jay L. Probability and Statistics for Engineering and the Sciences. 4th ed. Wadsworth Publishing, 1995.

  • McCall, Robert B. Fundamental Statistics for the Behavioral Sciences. 5th ed. New York: Harcourt Brace Jovanovich, 1990.

  • Press, William H., Saul A. Teukolsky, William T. Vetterling, and Brian P. Flannery. Numerical Recipes in C: The Art of Scientific Computing. 2nd ed. New York: Cambridge University Press, 1992.


Дисперсионный анализ

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Пакет анализа включает в себя три средства дисперсионного анализа. Выбор конкретного инструмента определяется числом факторов и числом выборок в исследуемой совокупности данных.

Подробности

Однофакторный дисперсионный анализ

Двухфакторный дисперсионный анализ с повторениями

Двухфакторный дисперсионный анализ без повторения


Корреляционный анализ

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Используется для количественной оценки взаимосвязи двух наборов данных, представленных в безразмерном виде. Коэффициент корреляции выборки представляет собой ковариацию двух наборов данных, деленную на произведение их стандартных отклонений.

Формулы расчета корреляции

Корреляционный анализ дает возможность установить, ассоциированы ли наборы данных по величине, то есть, большие значения из одного набора данных связаны с большими значениями другого набора (положительная корреляция), или, наоборот, малые значения одного набора связаны с большими значениями другого (отрицательная корреляция), или данные двух диапазонов никак не связаны (корреляция близка к нулю). Чтобы получить более подробные сведения о параметрах диалогового окна Корреляционный анализ, нажмите кнопку [image] .

Примечание. Для вычисления коэффициента корреляции между двумя наборами данных на листе используется статистическая функция КОРРЕЛ.


Ковариационный анализ

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Используется для вычисления среднего произведения отклонений точек данных от относительных средних. Ковариация является мерой связи между двумя диапазонами данных.

Формула расчета ковариации

Ковариационный анализ дает возможность установить, ассоциированы ли наборы данных по величине, то есть, большие значения из одного набора данных связаны с большими значениями другого набора (положительная ковариация), или, наоборот, малые значения одного набора связаны с большими значениями другого (отрицательная ковариация), или данные двух диапазонов никак не связаны (ковариация близка к нулю). Чтобы получить более подробные сведения о параметрах диалогового окна Ковариационный анализ, нажмите кнопку [image] .

Примечание. Вычисления ковариации для отдельной пары данных производятся с помощью статистической функции КОВАР.


Описательная статистика

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Это средство анализа служит для создания одномерного статистического отчета, содержащего информацию о центральной тенденции и изменчивости входных данных. Чтобы получить более подробные сведения о параметрах диалогового окна Описательная статистика, нажмите кнопку [image] .


Экспоненциальное сглаживание

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Предназначается для предсказания значения на основе прогноза для предыдущего периода, скорректированного с учетом погрешностей в этом прогнозе. Использует константу сглаживания a, по величине которой определяет, насколько сильно влияют на прогнозы погрешности в предыдущем прогнозе.

Формула экспоненциального сглаживания

Чтобы получить более подробные сведения о параметрах диалогового окна Экспоненциальное сглаживание, нажмите кнопку [image] .

Примечание. Для константы сглаживания наиболее подходящими являются значения от 0,2 до 0,3. Эти значения показывают, что ошибка текущего прогноза установлена на уровне от 20 до 30 процентов ошибки предыдущего прогноза. Более высокие значения константы ускоряют отклик, но могут привести к непредсказуемым выбросам. Низкие значения константы могут привести к сдвигу аргумента для предсказанных значений.


Двухвыборочный F-тест для дисперсий

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Двухвыборочный F-тест применяется для сравнения дисперсий двух генеральных совокупностей. Например, F-тест можно использовать для выявления различия в дисперсиях временных характеристик, вычисленных по двум выборкам. Чтобы получить более подробные сведения о параметрах диалогового окна Двухвыборочный F-тест для дисперсии, нажмите кнопку [image] .


Анализ Фурье

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Предназначается для решения задач в линейных системах и анализа периодических данных, используя метод быстрого преобразования Фурье (БПФ). Эта процедура поддерживает также обратные преобразования, при этом, инвертирование преобразованных данных возвращает исходные данные. Чтобы получить более подробные сведения о параметрах диалогового окна Анализ Фурье, нажмите кнопку [image] .

Входной и выходной диапазоны для анализа Фурье


Гистограмма

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Используется для вычисления выборочных и интегральных частот попадания данных в указанные интервалы значений, при этом, генерируются числа попаданий для заданного диапазона ячеек. Например, необходимо выявить тип распределения успеваемости в группе из 20 студентов. Таблица гистограммы состоит из границ шкалы оценок и количеств студентов, уровень успеваемости которых находится между самой нижней границей и текущей границей. Наиболее часто повторяемый уровень является модой интервала данных. Чтобы получить более подробные сведения о параметрах диалогового окна Гистограмма, нажмите кнопку [image] .


Скользящее среднее

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Используется для расчета значений в прогнозируемом периоде на основе среднего значения переменной для указанного числа предшествующих периодов. Каждое прогнозируемое значение основано на формуле:

Формула расчета скользящего среднего

где

  • N число предшествующих периодов, входящих в скользящее среднее

  • Aj фактическое значение в момент времени j

  • Fj прогнозируемое значение в момент времени j

Скользящее среднее, в отличие от простого среднего для всей выборки, содержит сведения о тенденциях изменения данных. Процедура может использоваться для прогноза сбыта, инвентаризации и других процессов. Чтобы получить более подробные сведения о параметрах диалогового окна Скользящее среднее, нажмите кнопку [image] .


Генерация случайных чисел

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Используется для заполнения диапазона случайными числами, извлеченными из одного или нескольких распределений. С помощью данной процедуры можно моделировать объекты, имеющие случайную природу, по известному распределению вероятностей. Например, можно использовать нормальное распределение для моделирования совокупности данных по росту индивидуумов, или использовать распределение Бернулли для двух вероятных исходов, чтобы описать совокупность результатов бросания монетки. Чтобы получить более подробные сведения о параметрах диалогового окна Генерация случайных чисел, нажмите кнопку [image] .

Примечание. Чтобы в результате выполнения на листе вычислений вернуть равномерно распределенное случайное число, большее или равное 0 и меньшее 1, используйте функцию СЛЧИС(). Чтобы вернуть случайное число, лежащее между произвольными заданными значениями, используйте функцию СЛУЧМЕЖДУ().


Ранг и персентиль

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Используется для вывода таблицы, содержащей порядковый и процентный ранги для каждого значения в наборе данных. Данная процедура может быть применена для анализа относительного взаиморасположения данных в наборе. Чтобы получить более подробные сведения о параметрах диалогового окна Ранг и персентиль, нажмите кнопку [image] .


Регрессия

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Линейный регрессионный анализ заключается в подборе графика для набора наблюдений с помощью метода наименьших квадратов. Регрессия используется для анализа воздействия на отдельную зависимую переменную значений одной или более независимых переменных. Например, на спортивные качества атлета влияют несколько факторов, включая возраст, рост и вес. Регрессия пропорционально распределяет меру качества по этим трем факторам на основе данных функционирования атлета. Результаты регрессии впоследствии могут быть использованы для предсказания качеств нового, непроверенного атлета. Чтобы получить более подробные сведения о параметрах диалогового окна Регрессия, нажмите кнопку [image] .


Выборка

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Создает выборку из генеральной совокупности, рассматривая входной диапазон как генеральную совокупность. Если совокупность слишком велика для обработки или построения диаграммы, можно использовать представительную выборку. Кроме того, если предполагается периодичность входных данных, то можно создать выборку, содержащую значения только из отдельной части цикла. Например, если входной диапазон содержит данные для квартальных продаж, создание выборки с периодом 4 разместит в выходном диапазоне значения продаж из одного и того же квартала. Чтобы получить более подробные сведения о параметрах диалогового окна Выборка, нажмите кнопку [image] .


Проведение t-теста

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Пакет анализа включает в себя три средства анализа среднего для совокупностей различных типов.

Подробности

Двухвыборочный t-тест с одинаковыми дисперсиями

Двухвыборочный t-тест с неодинаковыми дисперсиями

Парный двухвыборочный t-тест для средних


Двухвыборочный z-тест для средних

Один из инструментов пакета анализа. Чтобы получить дополнительные сведения об установке и применении пакета анализа, нажмите кнопку [image] .

Двухвыборочный z-тест для средних с известными дисперсиями используется для проверки гипотезы о различии между средними двух генеральных совокупностей. Например, этот тест может использоваться для определения различия между характеристиками двух моделей автомобилей. Чтобы получить более подробные сведения о параметрах диалогового окна Двухвыборочный z-тест для средних, нажмите кнопку [image] .


Данные выводятся только на первый лист

Функции анализа данных можно применять только на одном листе. Если анализ данных проводится в группе, состоящей из нескольких листов, то результаты будут выведены на первом листе, на остальных листах будут выведены пустые диапазоны, содержащие только форматы. Чтобы провести анализ данных на всех листах, повторите процедуру для каждого листа в отдельности.


 Диалоговое окно "Мастер шаблонов - шаг 1 из 5"

Диалоговое окно "Мастер шаблонов - шаг 1 из 5"

Мастер шаблонов с функцией автоматического сбора данных служит для создания шаблона, который можно использовать в качестве формы для ввода записей в базу данных. Базой данных может быть книга Microsoft Excel или база данных Microsoft Access, Microsoft FoxPro, dBASE или Paradox. Всякий раз, когда на основе шаблона создается новая книга, все введенные в эту книгу данные автоматически копируются в базу данных, связанную с шаблоном.

Чтобы создать шаблон, откройте книгу, которая организована и отформатирована так, что в нее удобно вводить собираемые данные. Если шаблон формы уже создан, но требуется соединить его с базой данных, нажмите кнопку Отмена в диалоговом окне Мастер шаблонов. Выберите команду Создать в меню Файл, чтобы создать новую книгу на основе этого шаблона формы, а затем перезапустите мастер шаблонов, выбрав команду Мастер шаблонов в меню Данные. Таким образом, книга, которая использовалась для создания шаблона, не будет изменена.

Укажите книгу, на основе которой следует создать шаблон

Все открытые книги включены в раскрывающийся список. Если в нем нет нужной книги, нажмите кнопку Отмена, откройте книгу, а затем перезапустите мастер шаблонов.

Укажите имя шаблона

Введите требуемую последовательность символов, если название шаблона должно отличаться от названия книги. К этому имени будет автоматически добавлено расширение .xlt. По умолчанию шаблоны хранятся в папке "Шаблоны", которая находится в папке Microsoft Office или Microsoft Excel. Чтобы сохранить шаблон в отдельной папке каталога "Шаблоны", включите имя папки в путь.


 Диалоговое окно "Мастер шаблонов - Шаг 2 из 5"

Диалоговое окно "Мастер шаблонов - Шаг 2 из 5"

Данные, которые вводятся в книгу, созданную на основе шаблона, автоматически копируются в базу данных, формат и положение которой определяются на этом шаге. Здесь можно создать новую или указать существующую базу данных. Чтобы использовать уже существующую базу данных, категории данных книги, которая будет создана на основе шаблона, должны соответствовать полям базы данных.

Укажите формат базы данных, в которую следует помещать записи

Выберите формат используемой базы данных. Это может быть книга Microsoft Excel, а также база данных Microsoft Access, Microsoft FoxPro, dBASE или Paradox. Соответствующий ODBC-драйвер должен быть установлен и зарегистрирован в системе.

Укажите имя и местоположение базы данных

Чтобы создать новую базу данных, введите полный путь и название. Чтобы использовать существующую базу данных, нажмите кнопку обзора, а затем укажите местоположение нужного файла.

Примечание. Если для создания базы данных использовался мастер шаблонов с функцией автоматического сбора данных, такая база данных будет состоять из одной таблицы или одного листа. Чтобы собирать данные в многотабличную базу данных, создайте ее с помощью соответствующего приложения (база данных может содержать до 25 таблиц или листов). Затем запустите мастер шаблонов Microsoft Excel, чтобы установить соответствие ячеек книги и полей базы данных.


 Диалоговое окно "Мастер шаблонов - Шаг 3 из 5"

Диалоговое окно "Мастер шаблонов - Шаг 3 из 5"

На этом шаге устанавливается соответствие между полями базы данных и ячейками листа, из которых следует копировать данные. Данные, которые вводятся в книгу, созданную на основе шаблона, помещаются в новую запись базы данных.

Лист или таблица

Название листа книги или таблицы базы данных, для которых устанавливается соответствие с ячейками шаблона. При создании новой базы данных можно ввести произвольное имя. Если данные будут собираться в существующую многотабличную базу данных, выберите необходимое название.

Код

Номер поля (если считать справа), в которое будут копироваться данные из указанной ячейки.

Ячейка

Ячейка листа, из которой будут копироваться данные. Чтобы ввести ссылку, перейдите в поле Ячейка, а затем укажите ячейку листа. Разрешается вводить только абсолютную ссылку на отдельную ячейку. Можно ссылаться на ячейки разных листов, при этом в ссылку необходимо включать название листа — например, 'Лист1'!$B$3 — в многостраничной книге.

Имя поля

Поле базы данных, в которое будут копироваться данные из указанной ячейки. Если указанная ячейка находится ниже или правее текстового заголовка, при создании новой базы данных перейдите в поле Имя поля и либо подтвердите предложенный вариант названия, либо введите собственный. Имя поля должно удовлетворять требованиям к названиям полей базы данных выбранного формата.

Для существующей базы данных имена полей отобразятся автоматически, при этом изменить их нельзя.


 Окно диалога "Мастер шаблонов - шаг 4 из 5"

Окно диалога "Мастер шаблонов - шаг 4 из 5"

Возможно, существуют другие книги, содержащие данные, похожие на данные текущей книги. Если расположение ячеек в этих книгах, включая имена листов, идентично ссылке на ячейки, заданной на предыдущем шаге, можно собрать данные в книгах и поместить в базу данных. Если расположение ячеек не совпадает, в базу данных могут быть введены пустые или ошибочные записи. Установите необходимое положение переключателя и нажмите кнопку Далее.


 Окно диалога "Мастер шаблонов - шаг 4 из 5"

Окно диалога "Мастер шаблонов - шаг 4 из 5"

Здесь отображается список книг, данные которых следует поместить в базу данных. Чтобы удостовериться в соответствии копируемых данных полям базы данных, воспользуйтесь областью предварительного просмотра.

Включить

Чтобы включить книгу в перечень Список файлов, нажмите кнопку Включить, а затем найдите требуемый файл. Книга, которая использовалась для создания шаблона, также может быть включена в список, если она содержит нужные данные.

Чтобы включить несколько книг, выберите требуемые книги в диалоговом окне выбора файлов для преобразования, удерживая клавишу CTRL. Чтобы включить группу находящихся рядом файлов выберите первый и последний файл в группе, удерживая клавишу SHIFT.

Удалить

Чтобы удалить книгу из перечня Список файлов, укажите книгу и нажмите кнопку Удалить.

Просмотр

Чтобы проверить правильность копирования данных книги в поля базы данных, укажите книгу в перечне Список файлов и нажмите кнопку Просмотр. Если данные появляются в неверных полях, нажмите кнопку Удалить, чтобы убрать файл из перечня Список файлов.

Область предварительного просмотра

Представление данных, копируемых из указанной книги в поля базы данных. Чтобы просмотреть все поля, используйте полосу прокрутки.

Таблица

Имя таблицы, в которой определены названия полей собираемых данных. Если для сбора данных используется многотабличная база данных, выберите необходимое название из раскрывающегося списка.


 Окно диалога "Мастер шаблонов - шаг 5 из 5"

Окно диалога "Мастер шаблонов - шаг 5 из 5"

Новый шаблон создан. Он сохранен в папке "Шаблоны" папки Microsoft Office или Microsoft Excel. Чтобы создать книгу на основе шаблона, выберите команду Создать в меню Файл.

Чтобы изменить шаблон — например, чтобы скопировать дополнительные данные из ячеек книги в базу данных или переместить ячейки, в которые данные вводятся — выполните команду Открыть из меню Файл, выберите шаблон, затем выполните команду Мастер шаблонов из меню Данные.

Чтобы изменить данные в определенной записи базы данных, необходимо открыть и внести изменения в связанную с этой записью книгу. При сохранении отредактированной книги можно либо обновить существующую запись, либо сохранить исправленные данные в новой записи. Для редактирования записи также может быть использована программа, работающая с базой данных. В ней же производится удаление записи; удаление связанной с записью книги к удалению записи не приводит.

Добавить маршрут

Чтобы автоматически послать по почте новую книгу, созданную на основе шаблона, указанным адресатам, нажмите кнопку Добавить маршрут, а затем укажите необходимые информационные службы. Выбранная служба должна работать с Microsoft Exchange.


Параметры диалогового окна автосохранения

Сохранять каждые

Устанавливается для того, чтобы через определенные интервалы времени книги автоматически сохранялись. В окне минут указывается величина интервала (от 1 до 120 минут). Очистите флажок для отмены автоматического сохранения книг.

Только активную

Автоматическое сохранение только активной книги.

Все открытые

Автоматическое сохранение всех открытых книг.

Запрашивать разрешение

Если параметр выбран, то перед каждым автоматическим сохранением будет появляться подсказка, позволяющая либо выполнить, либо пропустить это сохранение.


 Команда "Диспетчер отчетов" (меню "Вид")

Команда "Диспетчер отчетов" (меню "Вид")

Используется для объединения последовательности листов, видов и сценариев в отчет, который может быть распечатан.

Отчеты

Чтобы распечатать, отредактировать или удалить отчет, выберите его из списка Отчеты.

Печать

Чтобы распечатать выбранный отчет, нажмите кнопку Печать.

Добавить

Чтобы создать новый отчет, нажмите кнопку Добавить.

Редактировать

Чтобы отредактировать выбранный отчет, нажмите кнопку Редактировать.

Удалить

Чтобы удалить выбранный отчет, нажмите кнопку Удалить.


 Диалоговые окна "Добавить отчет" и "Редактировать отчет"

Диалоговые окна "Добавить отчет" и "Редактировать отчет"

С помощью диалогового окна Добавить отчет создаются новые отчеты. В диалоговом окне Редактировать отчет редактируются ранее созданные отчеты. Имеется возможность изменения названий отчетов, создания и удаления разделов, изменения порядка следования разделов и включения сквозной нумерации страниц отчета.

Имя отчета

Чтобы присвоить отчету название, наберите последовательность символов в поле Имя отчетов.

Раздел для добавления

Чтобы создать раздел отчета, установите значения полей в наборе полей Раздел для добавления.

Лист

Чтобы задать лист активной книги, который должен быть использован в разделе отчета, выберите его из списка Лист.

Вид

Чтобы добавить в раздел вид, выберите его из списка Вид.

Сценарий

Чтобы добавить в раздел сценарий, выберите его из списка Сценарий.

Добавить

Чтобы добавить текущий раздел в список Разделы в этом отчете, нажмите кнопку Добавить.

Разделы в этом отчете

Используется для отображения списка разделов в текущем отчете. Разделы выводятся на печать в том порядке, в котором они следуют в списке.

Вверх

Используется для перемещения выбранного раздела вверх, чтобы он был распечатан раньше других разделов.

Вниз

Используется для перемещения выбранного раздела вверх, чтобы он был распечатан позже других разделов.

Последовательная нумерация страниц

Установите сквозную нумерацию страниц отчета. Если данный флажок не установлен, то каждый раздел отчета нумеруется с 1.

Удалить

Чтобы удалить раздел, выбранный из списка Разделы в этом отчете, нажмите кнопку Удалить.


Обновление связей с надстройками

Команда обновления связей со встроенными средствами Microsoft Excel 2000, которые являлись надстройками для более ранних версий программы. Чтобы обновить ссылки только в активной книге, выберите Активный документ. Чтобы ссылки обновились во всех открытых книгах, выберите Все открытые документы.


Диалоговое окно "Добавить ограничение" и "Изменить ограничение"

Ссылка на ячейку

Служит для указания ячейки или диапазона, на значения которых необходимо наложить ограничение.

Ограничение

Служит для задания условия, которое накладывается на значения ячейки или диапазона, указанного в поле Ссылка на ячейку. Выберите необходимый условный оператор ( <=, =, >=, Int или Bin ). Введите ограничение — число, формулу, ссылку на ячейку или диапазон — в поле справа от раскрывающегося списка.

Добавить

Нажмите на кнопку, чтобы, не возвращаясь в окно диалога Параметры поиска решения, наложить новое условие на поиск решения задачи.


Однофакторный дисперсионный анализ

Однофакторный дисперсионный анализ используется для проверки гипотезы о сходстве средних значений двух или более выборок, принадлежащих одной и той же генеральной совокупности. Этот метод распространяется также на тесты для двух средних (к которым относится, например, t-критерий). Чтобы получить более подробные сведения о параметрах диалогового окна Однофакторный дисперсионный анализ, нажмите кнопку [image] .


Параметры диалогового окна "Однофакторный дисперсионный анализ"

Входной диапазон

Ссылка на диапазон, содержащий анализируемые данные. Ссылка должна состоять не менее чем из двух смежных диапазонов данных, данные в которых расположены по строкам или столбцам.

Группирование

Установите переключатель в положение По столбцам или По строкам в зависимости от расположения данных во входном диапазоне.

Метки в первой строке/Метки в первом столбце

Если первая строка исходного диапазона содержит названия столбцов, установите переключатель в положение Метки в первой строке. Если названия строк находятся в первом столбце входного диапазона, установите переключатель в положение Метки в первом столбце. Если входной диапазон не содержит меток, то необходимые заголовки в выходном диапазоне будут созданы автоматически.

Альфа

Введите уровень значимости, необходимый для оценки критических параметров F-статистики. Уровень альфа связан с вероятностью возникновения ошибки типа I (опровержение верной гипотезы).

Выходной диапазон

Введите ссылку на ячейку, расположенную в левом верхнем углу выходного диапазона. Размеры выходной области будут рассчитаны автоматически, и соответствующее сообщение появится на экране в том случае, если выходной диапазон занимает место существующих данных или его размеры превышают размеры листа.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.


Двухфакторный дисперсионный анализ без повторения

Представляет собой двухфакторный анализ дисперсии, не включающий более одной выборки на группу. Используется для проверки гипотезы о том, что средние значения двух или нескольких выборок одинаковы (выборки принадлежат одной и той же генеральной совокупности). Этот метод распространяется также на тесты для двух средних, такие как t-критерий. Чтобы получить более подробные сведения о параметрах диалогового окна Двухфакторный дисперсионный анализ без повторения, нажмите кнопку [image] .


Параметры диалогового окна "Двухфакторный дисперсионный анализ без повторения"

Входной диапазон

Ссылка на диапазон, содержащий анализируемые данные. Ссылка должна состоять не менее чем из двух смежных диапазонов данных, данные в которых расположены по строкам или столбцам.

Заголовки

Снимите флажок, если входной диапазон не содержит названий строк или столбцов, в этом случае подходящие заголовки в выходном диапазоне будут созданы автоматически.

Альфа

Введите уровень значимости, необходимый для оценки критических параметров F-статистики. Уровень альфа связан с вероятностью возникновения ошибки типа I (опровержение верной гипотезы).

Выходной диапазон

Введите ссылку на ячейку, расположенную в левом верхнем углу выходного диапазона. Размеры выходной области будут рассчитаны автоматически, и соответствующее сообщение появится на экране в том случае, если выходной диапазон занимает место существующих данных или его размеры превышают размеры листа.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.


Двухфакторный дисперсионный анализ с повторениями

Представляет собой более сложный вариант однофакторного анализа, включающее более чем одну выборку для каждой группы данных. Чтобы получить более подробные сведения о параметрах диалогового окна Двухфакторный дисперсионный анализ с повторениями, нажмите кнопку [image] .

Определение входного диапазона для дисперсионного анализа


Параметры диалогового окна "Двухфакторный дисперсионный анализ с повторениями"

Входной диапазон

Ссылка на диапазон, содержащий анализируемые данные. Ссылка должна состоять не менее чем из двух смежных диапазонов данных, данные в которых расположены по строкам или столбцам.

Число строк на выборку

Введите число строк, содержащихся в одной выборке. Поскольку каждая строка представляет повторение данных, то каждая выборка должна содержать одно и тоже количество строк.

Альфа

Введите уровень значимости, необходимый для оценки критических параметров F-статистики. Уровень альфа связан с вероятностью возникновения ошибки типа I (опровержение верной гипотезы).

Выходной диапазон

Введите ссылку на ячейку, расположенную в левом верхнем углу выходного диапазона. Размеры выходной области будут рассчитаны автоматически, и соответствующее сообщение появится на экране в том случае, если выходной диапазон занимает место существующих данных или его размеры превышают размеры листа.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.


Параметры диалогового окна "Корреляционный анализ"

Входной диапазон

Ссылка на диапазон, содержащий анализируемые данные. Ссылка должна состоять не менее чем из двух смежных диапазонов данных, данные в которых расположены по строкам или столбцам.

Группирование

Установите переключатель в положение По столбцам или По строкам в зависимости от расположения данных во входном диапазоне.

Метки в первой строке/Метки в первом столбце

Если первая строка исходного диапазона содержит названия столбцов, установите переключатель в положение Метки в первой строке. Если названия строк находятся в первом столбце входного диапазона, установите переключатель в положение Метки в первом столбце. Если входной диапазон не содержит меток, то необходимые заголовки в выходном диапазоне будут созданы автоматически.

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Поскольку коэффициент корреляции двух наборов данных не зависит от последовательности их обработки, то выходная область занимает только половину предназначенного для нее места. Ячейки выходного диапазона, имеющие совпадающие координаты строк и столбцов, содержат значение 1, так как каждая строка или столбец во входном диапазоне полностью коррелирует с самим собой.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.


Параметры диалогового окна "Ковариационный анализ"

Входной диапазон

Ссылка на диапазон, содержащий анализируемые данные. Ссылка должна состоять не менее чем из двух смежных диапазонов данных, данные в которых расположены по строкам или столбцам.

Группирование

Установите переключатель в положение По столбцам или По строкам в зависимости от расположения данных во входном диапазоне.

Метки в первой строке/Метки в первом столбце

Если первая строка исходного диапазона содержит названия столбцов, установите переключатель в положение Метки в первой строке. Если названия строк находятся в первом столбце входного диапазона, установите переключатель в положение Метки в первом столбце. Если входной диапазон не содержит меток, то необходимые заголовки в выходном диапазоне будут созданы автоматически.

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Поскольку ковариация двух наборов данных не зависит от последовательности их обработки, то выходная область занимает только половину предназначенного для нее места. Диагональные ячейки выходной области содержат значения дисперсий входных диапазонов.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.


Параметры диалогового окна "Описательная статистика"

Входной диапазон

Ссылка на диапазон, содержащий анализируемые данные. Ссылка должна состоять не менее чем из двух смежных диапазонов данных, данные в которых расположены по строкам или столбцам.

Группирование

Установите переключатель в положение По столбцам или По строкам в зависимости от расположения данных во входном диапазоне.

Метки в первой строке/Метки в первом столбце

Если первая строка исходного диапазона содержит названия столбцов, установите переключатель в положение Метки в первой строке. Если названия строк находятся в первом столбце входного диапазона, установите переключатель в положение Метки в первом столбце. Если входной диапазон не содержит меток, то необходимые заголовки в выходном диапазоне будут созданы автоматически.

Уровень надежности

Установите флажок, если в выходную таблицу необходимо включить строку для уровня надежности. В поле введите требуемое значение. Например, значение 95% вычисляет уровень надежности среднего со значимостью 0.05.

К-ый наибольший

Установите флажок, если в выходную таблицу необходимо включить строку для k-го наибольшего значения для каждого диапазона данных. В соответствующем окне введите число k. Если k равно 1, эта строка будет содержать максимум из набора данных.

К-ый наименьший

Установите флажок, если в выходную таблицу необходимо включить строку для k-го наименьшего значения для каждого диапазона данных. В соответствующем окне введите число k. Если k равно 1, эта строка будет содержать минимум из набора данных.

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Этот инструмент анализа выводит два столбца сведений для каждого набора данных. Левый столбец содержит метки статистических данных; правый столбец содержит статистические данные. Состоящий их двух столбцов диапазон статистических данных будет выведен для каждого столбца или для каждой строки входного диапазона в зависимости от положения переключателя Группирование.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.

Итоговая статистика

Установите флажок, если в выходном диапазоне необходимо получить по одному полю для каждого из следующих видов статистических данных: Среднее, Стандартная ошибка (среднего), Медиана, Мода, Стандартное отклонение, Дисперсия выборки, Эксцесс, Асимметричность, Интервал, Минимум, Максимум, Сумма, Счет, Наибольшее (#), Наименьшее (#), Уровень надежности.


Параметры диалогового окна "Экспоненциальное сглаживание"

Входной диапазон

Введите ссылку на ячейки, содержащие анализируемые данные. Входной диапазон должен состоять из одного столбца или одной строки, содержащих данные как минимум в четырех ячейках.

Фактор затухания

Введите фактор затухания, который будет использоваться в качестве константы экспоненциального сглаживания. Фактором затухания называется корректировочный фактор, минимизирующий нестабильность данных генеральной совокупности. Значение фактора по умолчанию равно 0,3.

Заголовки

Установите флажок, если первая строка или первый столбец входного интервала содержит заголовки. Снимите флажок, если заголовки отсутствуют; в этом случае подходящие названия для данных выходного диапазона будут созданы автоматически.

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Если установлен флажок Стандартные погрешности, то выходной диапазон состоит из двух столбцов, и значения стандартных погрешностей содержатся в правом столбце. Если недостаточно исходных значений для построения прогноза или для вычисления стандартной ошибки, Microsoft Excel возвратит ошибочное значение #Н/Д.

Примечание. Выходной диапазон и данные входного диапазона должны быть расположены на одном листе. По этой причине параметры Новый лист и Новая книга недоступны.

Вывод графика

Установите флажок, чтобы построить встроенную диаграмму для фактических и прогнозируемых значений.

Стандартные погрешности

Установите флажок, чтобы включить в выходной диапазон столбец стандартных погрешностей. Снимите флажок, чтобы получить выходной диапазон в виде одного столбца без значений стандартных погрешностей.


Параметры диалогового окна "Анализ Фурье"

Входной диапазон

Введите ссылку на диапазон вещественных или комплексных данных, которые необходимо преобразовать. Комплексные данные должны быть представлены в формате x+yi или x+yj. Число значений во входном диапазоне должно быть четной степенью 2. Если x является отрицательным числом, поставьте перед ним апостроф ('). Максимальное число значений во входном диапазоне равно 4096.

Метки в первой строке

Установите флажок, если первая строка входного диапазона содержит заголовки. Снимите флажок, если заголовки во входном диапазоне отсутствуют; в этом случае подходящие названия в выходном диапазоне будут созданы автоматически.

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Размер выходного диапазона будет определен автоматически, и на экран будет выведено сообщение в случае возможного наложения выходного диапазона на исходные данные.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.

Инверсия

Если флажок установлен, то данные во входном диапазоне считаются преобразованными, и выполняется обратное преобразование, возвращающее их в выходной диапазон в исходном состоянии. Если флажок снят, то в выходной диапазон выводятся преобразованные данные.


Параметры диалогового окна "Двухвыборочный F-тест для дисперсии"

Интервал переменной 1

Введите ссылку на первую строку или первый столбец анализируемых данных.

Интервал переменной 2

Введите ссылку на вторую строку или второй столбец анализируемых данных.

Заголовки

Установите флажок, если первая строка или первый столбец входного интервала содержит заголовки. Снимите флажок, если заголовки отсутствуют; в этом случае подходящие названия для данных выходного диапазона будут созданы автоматически.

Альфа

Введите уровень надежности для теста. Его значение должно находиться в диапазоне 0...1. Уровень альфа связан с вероятностью возникновения ошибки типа I (опровержение верной гипотезы).

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Размер выходного диапазона будет определен автоматически, и на экран будет выведено сообщение в случае возможного наложения выходного диапазона на исходные данные.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.


Параметры диалогового окна "Гистограмма"

Входной диапазон

Введите ссылку на диапазон исследуемых данных.

Интервал карманов (необязательный)

Введите в поле диапазон ячеек и необязательный набор граничных значений, определяющих отрезки (карманы). Эти значения должны быть введены в возрастающем порядке. В Microsoft Excel вычисляется число попаданий данных между текущим началом отрезка и соседним большим по порядку, если такой есть. При этом включаются значения на нижней границе отрезка и не включаются значения на верхней границе.

Если диапазон карманов не был введен, то набор отрезков, равномерно распределенных между минимальным и максимальным значениями данных, будет создан автоматически.

Заголовки

Установите флажок, если первая строка или первый столбец входного интервала содержит заголовки. Снимите флажок, если заголовки отсутствуют; в этом случае подходящие названия для данных выходного диапазона будут созданы автоматически.

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Размер выходного диапазона будет определен автоматически, и на экран будет выведено сообщение в случае возможного наложения выходного диапазона на исходные данные.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.

Парето (отсортированная диаграмма)

Установите флажок, чтобы представить данные в порядке убывания частоты. Если флажок снят, то данные в выходном диапазоне будут представлены в порядке возрастания отрезков, а трех самых правых столбцов с отсортированными данными не будет.

Интегральный процент

Установите флажок для генерации интегральных процентных отношений включения в гистограмму графика интегральных процентов. Снимите флажок, чтобы не вычислять интегральные процентные соотношения.

Вывод графика

Установите флажок для автоматического создания встроенной диаграммы на листе, содержащем выходной диапазон.


Параметры диалогового окна "Скользящее среднее"

Входной диапазон

Введите ссылку на диапазон исследуемых данных. Входной диапазон должен состоять из одного столбца или одной строки, содержащих не менее четырех ячеек с данными.

Метки в первой строке

Установите флажок, если первая строка входного интервала содержит заголовки. Снимите флажок, если заголовки отсутствуют; в этом случае подходящие названия для данных выходного диапазона будут созданы автоматически.

Интервал

Введите число значений, необходимое для расчета скользящего среднего. Значение по умолчанию равно 3.

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Если установлен флажок Стандартные погрешности, то выходной диапазон состоит из двух столбцов, и значения стандартных погрешностей содержатся в правом столбце. Если недостаточно исходных значений для построения прогноза или для вычисления стандартной ошибки, Microsoft Excel возвратит ошибочное значение #Н/Д.

Выходной диапазон и исходные данные должны находиться на одном листе. По этой причине параметры Новый лист и Новая книга недоступны.

Вывод графика

Установите флажок для автоматического создания встроенной диаграммы на листе, содержащем выходной диапазон.

Стандартные погрешности

Установите флажок, чтобы включить в выходной диапазон столбец стандартных погрешностей. Снимите флажок, чтобы получить выходной диапазон в виде одного столбца без значений стандартных погрешностей.


Параметры диалогового окна "Генерация случайных чисел"

Число переменных

Введите число столбцов значений, которые необходимо разместить в выходном диапазоне. Если это число не введено, то все столбцы в выходном диапазоне будут заполнены.

Число случайных чисел

Введите число случайных значений, которое необходимо вывести для каждой переменной. Каждое случайное значение будет помещено в строке выходного диапазона. Если число случайных чисел не будет введено, все строки выходного диапазона будут заполнены.

Распределение

Выберите распределение, которое необходимо использовать для генерации случайных переменных.

Равномерное

Характеризуется верхней и нижней границами. Переменные извлекаются с одной и той же вероятностью для всех значений интервала. Обычно приложения используют равномерное распределение в интервале 0...1.

Нормальное

Характеризуется средним значением и стандартным отклонением. Обычно приложения для этого распределения используют среднее значение 0 и стандартное отклонение 1.

Бернулли

Характеризуется вероятностью успеха (величина p) в данной попытке. Случайные переменные Бернулли имеют значение 0 или 1. Например, можно выбрать равномерную случайную переменную в интервале 0...1. Если переменная меньше или равна вероятности успеха, то случайной переменной Бернулли присваивается значение 1, а в противном случае, она принимает значение 0.

Биномиальное

Характеризуется вероятностью успеха (величина p) для некоторого числа попыток. Например, можно сгенерировать случайные переменные Бернулли число попыток, сумма которых будет биномиальной случайной переменной.

Пуассона

Характеризуется значением лямбда, равным 1/среднее. Распределение Пуассона часто используется для характеристики числа случайных событий, происходящих в единицу времени, например, среднее количество автомобилей, приезжающих на платную стоянку.

Модельное

Характеризуется нижней и верхней границей, шагом, числом повторений значений и числом повторений последовательности.

Дискретное

Характеризуется значением и соответствующим ему интервалом вероятности. Диапазон должен состоять из двух столбцов: левого, содержащего значения, и правого, содержащего вероятности, связанные со значением в данной строке. Сумма вероятностей должна быть равна 1.

Параметры

Введите параметры выбранного распределения.

Случайное рассеивание

Введите произвольное значение, для которого необходимо генерировать случайные числа. Впоследствии можно снова использовать это значение для получения тех же самых случайных чисел.

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Размер выходного диапазона будет определен автоматически, и на экран будет выведено сообщение в случае возможного наложения выходного диапазона на исходные данные.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.


Параметры диалогового окна "Ранг и персентиль"

Входной диапазон

Введите ссылку на диапазон исследуемых данных.

Группирование

Установите переключатель в положение По столбцам или По строкам в зависимости от расположения данных во входном диапазоне.

Метки в первой строке/Метки в первом столбце

Установите переключатель в положение Подписи в первой строке, если выбраны Столбцы, и первая строка во входном диапазоне содержит названия столбцов. Установите переключатель в положение Подписи в первом столбце, если выбраны Строки, и заголовки строк находятся в первом столбце входного диапазона. Если входной диапазон не содержит подписей, то необходимые заголовки в выходном диапазоне будут созданы автоматически.

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Для каждого набора данных во входном диапазоне генерируется один выходной диапазон, состоящий из четырех столбцов: порядковый номер точки, исходное значение, порядковый ранг, процентный ранг. Строки сортируются в порядке возрастания рангов.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.


Параметры диалогового окна "Регрессия"

Входной интервал Y

Введите ссылку на диапазон анализируемых зависимых данных. Диапазон должен состоять из одного столбца.

Входной интервал X

Введите ссылку на диапазон независимых данных, подлежащих анализу. Microsoft Excel располагает независимые переменные этого диапазона слева направо в порядке возрастания. Максимальное число входных диапазонов равно 16.

Заголовки

Установите флажок, если первая строка или первый столбец входного интервала содержит заголовки. Снимите флажок, если заголовки отсутствуют; в этом случае подходящие названия для данных выходного диапазона будут созданы автоматически.

Уровень надежности

Установите флажок, чтобы включить в выходной диапазон дополнительный уровень. В соответствующее поле введите уровень надежности, который будет использован дополнительно к уровню 95%, применяемому по умолчанию.

Константа - ноль

Установите флажок, чтобы линия регрессии прошла через начало координат.

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Отведите, по крайней мере, семь столбцов для итогового диапазона, который будет включать в себя: результаты дисперсионного анализа, коэффициенты регрессии, стандартную погрешность вычисления Y, среднеквадратичные отклонения, число наблюдений, стандартные погрешности для коэффициентов.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.

Остатки

Установите флажок, чтобы включить остатки в выходной диапазон.

Стандартизированные остатки

Установите флажок, чтобы включить стандартизированные остатки в выходной диапазон.

График остатков

Установите флажок, чтобы построить диаграмму остатков для каждой независимой переменной.

График подбора

Установите флажок, чтобы построить диаграммы наблюдаемых и предсказанных значений для каждой независимой переменной.

График нормальной вероятности

Установите флажок, чтобы построить диаграмму нормальной вероятности.


Параметры диалогового окна "Выборка"

Входной диапазон

Введите ссылку на блок данных на рабочем листе, содержащем значения генеральной совокупности, из которой необходимо извлечь выборку. Выборка будет извлечена сначала из первого столбца, затем из второго столбца и так далее.

Заголовки

Установите флажок, если первая строка или первый столбец входного диапазона содержит заголовки. Снимите флажок, если заголовки во входном диапазоне отсутствуют; в этом случае подходящие названия в выходном диапазоне будут созданы автоматически.

Метод выборки

Установите переключатель в положение Периодический или Случайный, чтобы задать необходимый диапазон выборки.

Период

Введите периодический интервал, в соответствии с которым будет произведена выборка. Входное значение, номер которого совпадает с номером, заданным в поле периода, и каждое последующее с номером, кратным периоду, будет скопировано в выходной столбец. Процесс создания выборки прекратится при достижении конца входного диапазона.

Число выборок

Введите в поле число случайных значений, которые необходимо разместить в выходном столбце. Позиция каждой извлекаемой переменной во входном диапазоне выбирается случайно, и любое исходное значение может быть выбрано более одного раза.

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Выходные данные будут записаны в виде одного столбца. Если установить переключатель в положение Периодический, число значений в выходном диапазоне будет равно числу значений во входном диапазоне, деленному на значение периода. Если установить переключатель в положение Случайный, то число значений в выходном диапазоне будет равно числу выборок.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.


Диалоговые окна "Сохранить модель" и "Загрузить модель"

Область модели

В зависимости от активной ячейки отображает в диалоговом окне Сохранить модель область по умолчанию для сохранения модели. Предлагаемый диапазон содержит ячейку для каждого ограничения, а также еще три ячейки. Можно также ввести ссылку на верхнюю ячейку столбца, в котором следует сохранить модель.

Диалоговое окно Загрузить модель используется для задания ссылки на область загружаемой модели оптимизации. Ссылка должна адресовать область модели целиком — не достаточно указать только первую ячейку.


Диалоговые окна "Текущее состояние поиска решения" и "Сохранить сценарий"

Сохранить сценарий

Служит для отображения на экране диалогового окна Сохранить сценарий, в котором можно выполнить сохранение сценария решения задачи, чтобы использовать его в дальнейшем с помощью диспетчера сценариев Microsoft Excel. Если сценарий не определен, диспетчер сценариев использует ссылку, указанную в поле Изменяя ячейки диалогового окна Поиск решения.

В поле Название сценария диалогового окна Сохранение сценария введите имя сценария, который следует сохранить и нажмите кнопку OK.

Продолжить

Служит для запуска следующей итерации.

Стоп

Служит для остановки поиска решения и отображения на экране диалогового окна Результаты поиска решения.


Диалоговое окно "Параметры поиска решения"

Можно изменять условия и варианты поиска решения для линейных и нелинейных задач, а также загружать и сохранять оптимизируемые модели. Значения и состояния элементов управления, используемые по умолчанию, подходят для решения большинства задач.

Максимальное время

Служит для ограничения времени, отпускаемого на поиск решения задачи. В поле можно ввести время (в секундах) не превышающее 32767; значение 100, используемое по умолчанию, подходит для решения большинства простых задач.

Итерации

Служит для управления временем решения задачи, путем ограничения числа промежуточных вычислений. В поле можно ввести время (в секундах) не превышающее 32767; значение 100, используемое по умолчанию, подходит для решения большинства простых задач.

Точность

Служит для задания точности, с которой определяется соответствие ячейки целевому значению или приближение к указанным границам. Поле должно содержать десятичную дробь от 0 (нуля) до 1. Чем больше десятичных знаков в задаваемом числе, тем выше точность — например, число 0,0001 представлено с более высокой точностью, чем 0,01.

Допустимое отклонение

Служит для задания допуска на отклонение от оптимального решения, если множество значений влияющей ячейки ограничено множеством целых чисел. При указании большего допуска поиск решения заканчивается быстрее.

Сходимость

Когда относительное изменение значения в целевой ячейке за последние пять итераций становится меньше числа, указанного в поле Сходимость, поиск прекращается. Сходимость применяется только к нелинейным задачам, условием служит дробь из интервала от 0 (нуля) до 1. Лучшую сходимость характеризует большее количество десятичных знаков — например, 0,0001 соответствует меньшему относительному изменению по сравнению с 0,01. Лучшая сходимость требует больше времени на поиск оптимального решения.

Линейная модель

Служит для ускорения поиска решения линейной задачи оптимизации.

Показывать результаты итераций

Служит для приостановки поиска решения для просмотра результатов отдельных итераций.

Автоматическое масштабирование

Служит для включения автоматической нормализации входных и выходных значений, качественно различающихся по величине — например, максимизация прибыли в процентах по отношению к вложениям, исчисляемым в миллионах рублей.

Значения не отрицательны

Позволяет установить нулевую нижнюю границу для тех влияющих ячеек, для которых она не была указана в поле Ограничение диалогового окна Добавить ограничение.

Оценка

Служит для указания метода экстраполяции — линейная или квадратичная — используемого для получения исходных оценок значений переменных в каждом одномерном поиске.

Линейная. Служит для использования линейной экстраполяции вдоль касательного вектора.

Квадратичная. Служит для использования квадратичной экстраполяции, которая дает лучшие результаты при решении нелинейных задач.

Производные

Служит для указания метода численного дифференцирования — прямые или центральные производные — который используется для вычисления частных производных целевых и ограничивающих функций.

Прямые. Используется в большинстве задач, где скорость изменения ограничений относительно невысока.

Центральные. Используется для функций, имеющих разрывную производную. Данный способ требует больше вычислений, однако его применение может быть оправданным, если выдается сообщение о том, что получить более точное решение не удается.

Метод

Служит для выбора алгоритма оптимизации — метод Ньютона или сопряженных градиентов — для указания направление поиска.

Метод Ньютона. Реализация квазиньютоновского метода, в котором запрашивается больше памяти, но выполняется меньше итераций, чем в методе сопряженных градиентов.

Метод сопряженных градиентов. Реализация метода сопряженных градиентов, в котором запрашивается меньше памяти, но выполняется больше итераций, чем в методе Ньютона. Данный метод следует использовать, если задача достаточно велика и необходимо экономить память, а также если итерации дают слишком малое отличие в последовательных приближениях.

Загрузить модель

Служит для отображения на экране диалогового окна Загрузить модель, в котором можно задать ссылку на область ячеек, содержащих загружаемую модель.

Сохранить модель

Служит для отображения на экране диалогового окна Сохранить модель, в котором можно задать ссылку на область ячеек, предназначенную для хранения модели оптимизации. Данный вариант предусмотрен для хранения на листе более одной модели оптимизации — первая модель сохраняется автоматически.


Диалоговое окно "Поиск решения"

Установить целевую ячейку

Служит для указания целевой ячейки, значение которой необходимо максимизировать, минимизировать или установить равным заданному числу. Эта ячейка должна содержать формулу.

Равной

Служит для выбора варианта оптимизации значения целевой ячейки (максимизация, минимизация или подбор заданного числа). Чтобы установить число, введите его в поле.

Изменяя ячейки

Служит для указания ячеек, значения которых изменяются в процессе поиска решения до тех пор, пока не будут выполнены наложенные ограничения и условие оптимизации значения ячейки, указанной в поле Установить целевую ячейку.

Предположить

Используется для автоматического поиска ячеек, влияющих на формулу, ссылка на которую дана в поле Установить целевую ячейку. Результат поиска отображается в поле Изменяя ячейки.

Ограничения

Служит для отображения списка граничных условий поставленной задачи.

Добавить

Служит для отображения диалогового окна Добавить ограничение.

Изменить

Служит для отображения диалоговое окна Изменить ограничение.

Удалить

Служит для снятия указанного ограничения.

Выполнить

Служит для запуска поиска решения поставленной задачи.

Закрыть

Служит для выхода из окна диалога без запуска поиска решения поставленной задачи. При этом сохраняются установки сделанные в окнах диалога, появлявшихся после нажатий на кнопки Параметры, Добавить, Изменить или Удалить.

Параметры

Служит для отображения диалогового окна Параметры поиска решения, в котором можно загрузить или сохранить оптимизируемую модель и указать предусмотренные варианты поиска решения.

Восстановить

Служит для очистки полей окна диалога и восстановления значений параметров поиска решения, используемых по умолчанию.


Диалоговое окно "Результаты поиска решения"

Используется для вывода итогового сообщения и найденного решения. См. также Итоговые сообщения процедуры поиска решения.

Сохранить найденное решение

Служит для сохранения найденного решения во влияющих ячейках модели.

Восстановить исходные значения

Служит для восстановления исходных значений влияющих ячеек модели.

Отчеты

Служит для указания типа отчета, размещаемого на отдельном листе книги.

Результаты. Используется для создания отчета, состоящего из целевой ячейки и списка влияющих ячеек модели, их исходных и конечных значений, а также формул ограничений и дополнительных сведений о наложенных ограничениях.

Устойчивость. Используется для создания отчета, содержащего сведения о чувствительности решения к малым изменениям в формуле (поле Установить целевую ячейку, диалоговое окно Поиск решения) или в формулах ограничений. Такой отчет не создается для моделей, значения в которых ограничены множеством целых чисел. В случае нелинейных моделей отчет содержит данные для градиентов и множителей Лагранжа. В отчет по нелинейным моделям включаются ограниченные затраты, фиктивные цены, объективный коэффициент (с некоторым допуском), а также диапазоны ограничений справа.

Ограничения. Используется для создания отчета, состоящего из целевой ячейки и списка влияющих ячеек модели, их значений, а также нижних и верхних границ. Такой отчет не создается для моделей, значения в которых ограничены множеством целых чисел. Нижним пределом является наименьшее значение, которое может содержать влияющая ячейка, в то время как значения остальных влияющих ячеек фиксированы и удовлетворяют наложенным ограничениям. Соответственно, верхним пределом называется наибольшее значение.

Сохранить сценарий

Служит для отображения диалогового окна Сохранение сценария, в котором можно сохранить сценарий решения задачи, чтобы использовать его в дальнейшем с помощью диспетчера сценариев Microsoft Excel. Чтобы получить более подробные сведения о диалоговом окне Сохранение сценария, нажмите кнопку [image] .


Парный двухвыборочный t-тест для средних

Парный двухвыборочный t-тест Стьюдента используется для проверки гипотезы о различии средних для двух выборок данных. В нем не предполагается равенство дисперсий генеральных совокупностей, из которых выбраны данные. Парный тест используется, когда имеется естественная парность наблюдений в выборках, например, когда генеральная совокупность тестируется дважды. Чтобы получить более подробные сведения о параметрах диалогового окна Парный двухвыборочный t-тест для средних, нажмите кнопку [image] .

Примечание. Одним из результатов теста является совокупная дисперсия (совокупная мера распределения данных вокруг среднего значения), вычисляемая по следующей формуле.

Формула расчета совокупной дисперсии


Параметры диалогового окна "Парный двухвыборочный t-тест для средних"

Интервал переменной 1

Введите ссылку на первый диапазон анализируемых данных. Диапазон должен состоять из одного столбца или одной строки, содержащих одинаковое со вторым диапазоном количество данных.

Интервал переменной 2

Введите ссылку на второй диапазон анализируемых данных. Диапазон должен состоять из одного столбца или одной строки, содержащих одинаковое с первым диапазоном количество данных.

Гипотетическая средняя разность

Введите число, равное предполагаемой разности средних. Значение 0 (нуль) указывает, что средние принимаются равными.

Заголовки

Установите флажок, если первая строка или первый столбец входного интервала содержит заголовки. Снимите флажок, если заголовки отсутствуют; в этом случае подходящие названия для данных выходного диапазона будут созданы автоматически.

Альфа

Введите уровень надежности для теста. Его значение должно находиться в диапазоне 0...1. Уровень альфа связан с вероятностью возникновения ошибки типа I (опровержение верной гипотезы).

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Размер выходного диапазона будет определен автоматически, и на экран будет выведено сообщение в случае возможного наложения выходного диапазона на исходные данные.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.


Двухвыборочный t-тест с одинаковыми дисперсиями

Двухвыборочный t-тест Стьюдента служит для проверки гипотезы о равенстве средних для двух выборок. Эта форма t-теста предполагает совпадение дисперсий генеральных совокупностей и обычно называется гомоскедастическим t-тестом. Чтобы получить более подробные сведения о параметрах диалогового окна Двухвыборочный t-тест с одинаковыми дисперсиями, нажмите кнопку [image] .


Параметры диалогового окна "Двухвыборочный t-тест с одинаковыми дисперсиями"

Интервал переменной 1

Введите ссылку на первый диапазон анализируемых данных. Диапазон должен состоять из одного столбца или одной строки.

Интервал переменной 2

Введите ссылку на второй диапазон анализируемых данных. Диапазон должен состоять из одного столбца или одной строки.

Гипотетическая средняя разность

Введите число, равное предполагаемой разности средних. Значение 0 (нуль) указывает, что средние принимаются равными.

Заголовки

Установите флажок, если первая строка или первый столбец входного интервала содержит заголовки. Снимите флажок, если заголовки отсутствуют; в этом случае подходящие названия для данных выходного диапазона будут созданы автоматически.

Альфа

Введите уровень надежности для теста. Его значение должно находиться в диапазоне 0...1. Уровень альфа связан с вероятностью возникновения ошибки типа I (опровержение верной гипотезы).

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Размер выходного диапазона будет определен автоматически, и на экран будет выведено сообщение в случае возможного наложения выходного диапазона на исходные данные.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.


Двухвыборочный t-тест с разными дисперсиями

Двухвыборочный t-тест Стьюдента используется для проверки гипотезы о равенстве средних для двух выборок данных из разных генеральных совокупностей. Эта форма t-теста предполагает несовпадение дисперсий генеральных совокупностей и обычно называется гетероскедастическим t-тестом. Если тестируется одна и та же генеральная совокупность, используйте парный тест. Чтобы получить более подробные сведения о параметрах диалогового окна Двухвыборочный t-тест с разными дисперсиями, нажмите кнопку [image] .

Для определения тестовой величины t используется формула:

Формула расчета значения t

Приведенная ниже формула применяется для аппроксимации числа степеней свободы. Как правило, результатом вычислений является вещественное число, поэтому проводите округление до ближайшего целого, чтобы получить критическое значение t из таблицы.

Формула аппроксимации числа степеней свободы


Параметры диалогового окна "Двухвыборочный t-тест с разными дисперсиями"

Интервал переменной 1

Введите ссылку на первый диапазон анализируемых данных. Диапазон должен состоять из одного столбца или одной строки.

Интервал переменной 2

Введите ссылку на второй диапазон анализируемых данных. Диапазон должен состоять из одного столбца или одной строки.

Гипотетическая средняя разность

Введите число, равное предполагаемой разности средних. Значение 0 (ноль) указывает, что средние принимаются равными.

Заголовки

Установите флажок, если первая строка или первый столбец входного интервала содержит заголовки. Снимите флажок, если заголовки отсутствуют; в этом случае подходящие названия для данных выходного диапазона будут созданы автоматически.

Альфа

Введите уровень надежности для теста. Его значение должно находиться в диапазоне 0...1. Уровень альфа связан с вероятностью возникновения ошибки типа I (опровержение верной гипотезы).

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Размер выходного диапазона будет определен автоматически, и на экран будет выведено сообщение в случае возможного наложения выходного диапазона на исходные данные.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.


Параметры диалогового окна "Двухвыборочный z-тест для средних"

Интервал переменной 1

Введите ссылку на первый диапазон анализируемых данных. Диапазон должен состоять из одного столбца или одной строки.

Интервал переменной 2

Введите ссылку на второй диапазон анализируемых данных. Диапазон должен состоять из одного столбца или одной строки.

Гипотетическая средняя разность

Введите число, равное предполагаемой разности средних. Значение 0 (нуль) указывает, что средние принимаются равными.

Дисперсия переменной 1 (известная)

Введите известную дисперсию генеральной совокупности для входного интервала переменной 1.

Дисперсия переменной 2 (известная)

Введите известную дисперсию генеральной совокупности для входного интервала Переменной 2.

Заголовки

Установите флажок, если первая строка или первый столбец входного интервала содержит заголовки. Снимите флажок, если заголовки отсутствуют; в этом случае подходящие названия для данных выходного диапазона будут созданы автоматически.

Альфа

Введите уровень надежности для теста. Его значение должно находиться в диапазоне 0...1. Уровень альфа связан с вероятностью возникновения ошибки типа I (опровержение верной гипотезы).

Выходной диапазон

Введите ссылку на левую верхнюю ячейку выходного диапазона. Размер выходного диапазона будет определен автоматически, и на экран будет выведено сообщение в случае возможного наложения выходного диапазона на исходные данные.

Новый лист

Установите переключатель, чтобы открыть новый лист в книге и вставить результаты анализа, начиная с ячейки A1. Если в этом есть необходимость, введите имя нового листа в поле, расположенном напротив соответствующего положения переключателя.

Новая книга

Установите переключатель, чтобы открыть новую книгу и вставить результаты анализа в ячейку A1 на первом листе в этой книге.