 Надстройка «Пересчет в евро» для Microsoft Excel 2000

Надстройка «Пересчет в евро» для Microsoft Excel 2000

Далее представлены сведения по следующим темам:

Что из себя представляет надстройка «Пересчет в евро»?

Загрузка надстройки

Курсы пересчета

Новые страны, принявшие евро в качестве денежной единицы

Работа с более ранними версиями Excel

Что из себя представляет надстройка «Пересчет в евро»?

Надстройка Microsoft Excel «Пересчет в евро» включает в себя следующие средства для работы с валютой евро и национальными валютами стран-членов Европейского союза (ЕС), принявшх евро в качестве денежной единицы.

  • Кнопка панели инструментов для форматирования значений в единицах евро.

  • Функция EUROCONVERT.

Возврат в начало

Загрузка надстройки

Чтобы загрузить надстройку «Пересчет в евро», выберите команду Надстройки в меню Сервис Microsoft Excel и затем установите флажок Пересчет в евро. Если надстройка отсутствует в списке, то для того чтобы получить возможность загрузить ее, необходимо сначала установить надстройку.

Возврат в начало

Курсы пересчета

При использовании функции EUROCONVERT для преобразования значений валют эта функция использует фиксированные курсы и правила пересчета, установленные ЕС. Для получения подробных сведений о действующих правилах и курсах следует обращаться к публикациям Европейской комиссии, касающимся евро, или на Web-узел корпорации Майкрософт, посвященный валюте евро.

Возврат в начало

Новые страны, принявшие евро в качестве денежной единицы

Для просмотра текущего списка национальных валют стран, использующих евро, следует обращаться к функции EUROCONVERT. При принятии евро в качестве денежной единицы другими странами, а также при изменении Европейской комиссией курсов или правил пересчета Майкрософт будет вносить доступные обновления в надстройку «Пересчет в евро». Сведения о всех доступных для загрузки из Web обновлениях можно найти на Web-узле корпорации Майкрософт, который посвящен валюте евро. Для получения сведений о других способах получения обновлений следует обратиться в службу технической поддержки Майкрософт или в организацию, где был приобретен Microsoft Office.

Возврат в начало

Работа с более ранними версиями Excel

Инструменты для работы с евро в версиях Excel более ранних, чем Excel 2000 доступны на Web-узле корпорации Майкрософт, посвященном валюте евро. Пользователи более ранних версий Excel, не имеющие этих инструментов, могут просматривать значения в единицах евро в книгах, созданных в Excel 2000 и сохраненных в совместимом с этими версиями формате. См. сведения о работе с евро в более ранних версиях Excel.

Возврат в начало

Дополнительные сведения

Распознавание значений в единицах евро в Microsoft Excel

Разрешение вопросов при пересчете значений в единицах евро

Возврат в начало


Выполнение в Microsoft Excel пересчета значений, содержащих евро

Важно. Курсы пересчета, используемые в данном разделе, приведены в качестве примеров; пояснение правил пересчета является кратким изложением, а не полным описанием. Фактические курсы и правила, используемые в функции EUROCONVERT, являются конкретными курсами и правилами пересчета, устанавливаемыми Европейским союзом (EU).

В данном разделе приведены общие сведения о расчете функцией EUROCONVERT значений в соответствии с правилами ЕС, включая описание пересчета значений из одной национальной валюты в другую для валют стран, использующих евро, с использованием промежуточного пересчета значения в единицы евро. Валюты стран, использующих евро, являются национальными денежными единицами стран-членов ЕС, принявших в качестве денежной единицы евро.

Пересчет значения в национальной валюте страны, использующей евро, в единицы евро

Пересчет значения из одной национальной валюты в другую для валют стран, использующих евро

Пересчет значения в национальной валюте страны, использующей евро, в единицы евро

Коэффициенты пересчета. Функция EUROCONVERT использует курсы пересчета ЕС, или коэффициенты пересчета, выражающие единицу евро в единицах национальных валют стран, использующих евро. Каждый курс пересчета имеет шесть значащих цифр. Например, 1 евро может равняться 6,55957 французского франка или 1,95583 немецкой марки.

Точность расчета. При пересчете значений в валютах в евро и обратно функция EUROCONVERT всегда использует все шесть значащих цифр курса пересчета, без округления или усечения курса, независимо от того, сколько значащих цифр используется для отображения результата. Например, в соответствии с правилами ЕС, использование таких курсов пересчета, как 1 евро за 6,56 французского франка или 2,00 немецкой марки, не допускается.

Обратные курсы пересчета. В соответствии с правилами ЕС не допускается использование обратных курсов пересчета, в которых единица национальной валюты выражается в процентах от одного евро, поскольку использование данного метода может привести к округлению курса пересчета. Правила требуют использования при всех пересчетах установленного курса евро к национальной валюте. С учетом приведенных в качестве примера курсов пересчета, правильными являются следующие способы пересчета, используемые функцией EUROCONVERT.

1,00 немецкая марка = 1,00 / 1,95583 = 0,51 евро

0,51 евро = 0,51 * 1,95583 = 1,00 немецкая марка

Округление результатов. При пересчете значений в единицы евро функция EUROCONVERT округляет итоговые значения до ближайшего цента с сохранением двух десятичных разрядов (100 центов в 1 евро). При пересчете значений в единицах евро в национальную валюту страны, использующей евро, функция EUROCONVERT округляет итоговый результат до наименьшей единицы данной валюты. Например, при пересчете происходит округление немецких марок до ближайшего пфеннига с сохранением двух десятичных разрядов (100 пфеннигов в 1 марке). Если в результате пересчета присутствует ровно половина наименьшей единицы, результат округляется с избытком.

Расхождения в результате округления. В некоторых случаях округление может внести расхождения. Например, при пересчете трех значений в испанских песетах в евро и последующем суммировании полученных значений результат может не совпадать с результатом, который был бы получен при первоначальном суммировании трех значений в песетах и последующем пересчете итогового значения в евро. Правилами ЕС предусматривается определение представителями национальной администрации и деловых кругов стандартов и способов устранения таких расхождений. С помощью Excel и функции EUROCONVERT пользователь может создать формулы, учитывающие национальные стандарты и способы выполнения подобных расчетов.

Возврат в начало

Пересчет значения из одной национальной валюты в другую для валют стран, использующих евро

В соответствии с правилами ЕС при пересчете значения в одной национальной валюте в значение в другой национальной валюте для стран, использующих евро, следует сначала выполнить пересчет в единицы евро значения в первой валюте, с сохранением при округлении не менее трех десятичных разрядов. Затем для результирующего значения в единицах евро следует выполнить пересчет во вторую валюту. С учетом приведенных выше примеров курсов пересчета, для выполнения пересчета между французскими франками и немецкими марками правильными являются следующие способы пересчета, используемые функцией EUROCONVERT.

5,00 французских франков = 5,00 / 6,55957 = 0,7622451, с округлением до 0,762 евро

0,762 евро = 0,762 * 1,95583 = 1,4903425, с округлением до 1,49 немецкой марки (округление в меньшую сторону до ближайшего пфеннига)

Функция EUROCONVERT по умолчанию округляет промежуточное значение в единицах евро до трех десятичных разрядов, или значащих цифр. Тем не менее, при необходимости можно выполнять округление с сохранением более чем трех десятичных разрядов.

Возврат в начало

Дополнительные сведения

Для получения подробных сведений о действующих правилах и курсах следует обращаться к публикациям Европейской комиссии, касающимся евро. Для получения сведений о приобретении этих публикаций следует подключиться к Web-узлу корпорации Майкрософт, посвященному валюте евро.

Возврат в начало


 Распознавание значений в единицах евро в Microsoft Excel

Распознавание значений в единицах евро в Microsoft Excel

При вводе после какого-либо значения стандартного символа валюты (например, знака доллара $) Excel распознает значение как значение в денежном формате, а не как, например, текст. Стандартный символ валюты для системы устанавливается в приложении Язык и стандарты Панели управления Windows. Excel может таким же образом распознавать и символ евро, даже если евро не указано в качестве стандартной денежной единицы в Панели управления.

Поддержка на уровне операционной системы. Для того чтобы Excel 2000 распознавал значения евро, операционная система должна обеспечивать поддержку символа евро. Microsoft Windows 98 и Microsoft Windows 2000 Professional имеют встроенную поддержку символа евро. Пользователи Microsoft Windows 95 и Microsoft Windows NT Workstation 4.0 могут загрузить пакет поддержки символа евро.

Примечание. Значения в национальных валютах стран, использующих евро, можно также преобразовывать в значения евро с помощью функции EUROCONVERT, входящей в состав надстройки для работы с валютой евро, поставляемой с Excel 2000. (Валюты стран, использующих евро, – это национальные денежные единицы стран, входящих в Европейский союз (ЕС) и принявших евро в качестве валюты.) Тем не менее, устанавливать и загружать эту надстройку для распознавания программой Excel как значений евро, так и значений в стандартной национальной валюте, не требуется.

Ввод значений в единицах евро. Символ евро [image] в значениях можно вводить как до, так и после числа, включая или опуская пробел между числом и символом евро. На клавиатуре с американской раскладкой при установленных по умолчанию региональных стандартах Windows для ввода символа евро следует набрать комбинацию ALT+0128 на цифровой клавиатуре. См. сведения о вводе символа евро при использовании других раскладок клавиатуры.

Например, при вводе любого из следующих значений Excel распознает это значение как 1 евро.

Евро 1 1 Евро Евро 1 1 Евро

Форматы для денежной единицы евро. При вводе в Microsoft Excel значения в единицах евро ячейке присваивается денежный формат и в значение включается два десятичных разряда. Например, если введено значение Евро 1,2, в Excel отображается значение Евро 1,20. При вводе значения 2,359 Евро Excel сохраняет все три десятичных разряда, но отображает значение как 2,36 Евро, с округлением последнего десятичного разряда.

Если после ввода значения в единицах евро выполняется команда Отменить [image] , Excel удаляет денежный формат вместе с данными ячейки.

Также имеется возможность присваивать ячейкам с денежный формат с использованием валюты евро до или после ввода значений. При форматировании ячеек отпадает необходимость ввода символа евро.

Перенос в Excel данных, содержащих значения в единицах евро. При копировании данных из другой программы в Excel, использовании для извлечения внешних данных программы Microsoft Query или Web-запроса, а также при импорте текстового файла Excel распознает значения, выраженные в единицах евро и стандартной национальной валюте так же, как и при вводе их вручную.

Значения в единицах евро в макросах. Запись и выполнение макросов, включающих значения евро, осуществляется так же, как и запись и выполнение макросов, включающих значения в стандартной национальной валюте.

Дополнительные сведения

Способы извлечения внешних данных

Открытие текстового файла в Microsoft Excel


 Работа со значениями и формулами, содержащими символ валюты евро, в более ранних версиях Microsoft Excel

Работа со значениями и формулами, содержащими символ валюты евро, в более ранних версиях Microsoft Excel

Для просмотра и работы с листами Excel 2000, включающими значения и формулы, в которые входит евро, на компьютере, где установлена более ранняя версия Excel, прежде всего необходимо проверить, поддерживается ли символ евро используемой операционной системой. Microsoft Windows 98 и Microsoft Windows 2000 Professional имеют встроенную поддержку символа евро. Пользователи Microsoft Windows 95 и Microsoft Windows NT Workstation 4.0 могут загрузить пакет поддержки символа евро. Для получения сведений о поддержке символа евро в операционной системе Макинтош следует обращаться к поставщику оборудования Макинтош.

В данном разделе содержатся сведения о работе с евро в следующих версиях Excel.

Microsoft Excel 97

Microsoft Excel 95

Microsoft Excel 98 для компьютеров Макинтош

Более ранние версии Microsoft Excel

Microsoft Excel 97

Наличие надстройки «Пересчет в евро» и поддержки символа евро в Windows. Надстройка «Пересчет в евро» для Excel 97 доступна на Web-узле корпорации Майкрософт, посвященном валюте евро. Если данная надстройка установлена и загружена, и в используемой операционной системе Windows имеется поддержка символа евро, то можно просматривать и работать с листами Excel 2000, содержащими значения евро и формулы с функцией EUROCONVERT. Значения, содержащие символ евро, будут отображаться так же, как и в Excel 2000, а также будет осуществляться расчет значений в евро и значений в национальных валютах стран, использующих евро в качестве денежной единицы, по формулам, содержащим функцию EUROCONVERT.

Наличие надстройки для евро при отсутствии поддержки символа евро в Windows. Если надстройка для Excel 97 установлена и загружена в системе при отсутствии поддержки символа евро для операционной системы Windows, значения по формулам, включающим функцию EUROCONVERT, будут рассчитываться верно, но вместо символа Символ евро символ евро будет отображаться как Прямоугольник.

Отсутствие надстройки для евро при наличии поддержки символа евро в Windows. Если надстройка, обеспечивающая поддержку евро для Excel 97, отсутствует, но при этом имеется поддержка символа евро в используемой операционной системе Windows, значения на листах, содержащие евро, будут отображаться правильно, однако при обновлении связей и расчете значений по формулам, включающим функцию EUROCONVERT, будет отображаться ошибка #ИМЯ?.

Отсутствие как надстройки для евро, так и поддержки символа евро в Windows. Если надстройка, обеспечивающая поддержку евро, так же как и поддержка евро в операционной системе Windows, отсутствуют, вместо символа Символ евро символ евро будет отображаться как Прямоугольник; кроме того, при обновлении связей и расчете значений по формулам, включающим функцию EUROCONVERT, будет отображаться ошибка #ИМЯ?.

Возврат в начало

Microsoft Excel 95

Для работы с листами Excel 2000, содержащими значения и формулы, в которые входит евро, необходимо сначала сохранить книгу в Microsoft Excel 97-2000 в формате Книга Microsoft Excel 5.0/95, с тем чтобы книга могла быть открыта в Excel 95. Если поддержка символа евро в операционной системе Windows отсутствует, вместо символа Символ евро символ евро будет отображаться как Прямоугольник. Независимо от того, имеется ли поддержка символа евро в используемой операционной системе Windows или нет, при обновлении связей и расчете значений по формулам, включающим функцию EUROCONVERT, будет отображаться ошибка #ИМЯ?.

Возврат в начало

Microsoft Excel 98 для компьютеров Макинтош

Для получения сведений о доступности возможности поддержки евро в Excel 98 для компьютеров Макинтош следует подключиться к Web-узлу корпорации Майкрософт, посвященному валюте евро.

Для работы с листами Excel 2000, содержащими значения и формулы, в которые входит евро, необходимо сначала сохранить книгу в Microsoft Excel 97-2000 в формате Книга Microsoft Excel 5.0/95, с тем чтобы книга могла быть открыта в Excel 98. Сведения о работе с файлами Excel для Windows на компьютерах Макинтош см. в справочной системе Microsoft Excel 98.

Для отображения символа евро необходимо сначала установить шрифты, включающие символ евро. Шрифты для используемой версии операционной системы Макинтош можно получить от корпорации Apple. При открытии книги на компьютере Макинтош, не имеющем шрифтов, включающих символ евро, вместо символа Символ евро символ евро будет отображаться как знак подчеркивания ( _ ). Независимо от того, установлены ли шрифты, поддерживающие символ евро, или нет, при обновлении связей и расчете значений по формулам, включающим функцию EUROCONVERT, будет отображаться ошибка #ИМЯ?.

Возврат в начало

Более ранние версии Microsoft Excel

Для версий Microsoft Excel более ранних, чем Excel 95, как для системы Windows, так и для системы Макинтош, соответствующая надстройка, обеспечивающая поддержку символа евро, недоступна. Для получения сведений о шрифтах, включающих символ евро, для Windows 3.x следует подключиться к Web-узлу корпорации Майкрософт, посвященному валюте евро. Если книга Microsoft Excel 2000 со значениями и формулами, включающими символ евро, сохраняется в формате, совместимом с версией Microsoft Excel более ранней, чем Excel 95, и затем открывается в этой версии программы, и при этом операционная система не обеспечивает поддержку символа евро, вместо символа Символ евро символ евро будет отображаться как Прямоугольник или знак подчеркивания ( _ ). При обновлении связей и расчете значений по формулам, включающим функцию EUROCONVERT, будет отображаться ошибка #ИМЯ?.

Возврат в начало

Дополнительные сведения

Чтобы получить возможность работать с листом, содержащим формулы, включающие функцию EUROCONVERT, в версии Excel, не поддерживающей эту функцию, следует открыть книгу в Excel 2000, скопировать значения в ячейках и вставить их в новый лист и затем сохранить книгу в формате, совместимом с более ранней версией Excel.

Использование файлов Microsoft Excel 2000 в более ранних версиях Excel

Непреобразуемые свойства и формат документов

Причины возникновения ошибки #ИМЯ?

Возврат в начало


 Форматирование значений в единицах евро с применением соответствующего денежного стиля

Форматирование значений в единицах евро с применением соответствующего денежного стиля

Данная процедура используется для применения к выделенным ячейкам денежного стиля валюты евро. Если ячейки, которые требуется отформатировать, содержат значения не в единицах евро, необходимо преобразовать эти значения в единицы евро с помощью функции EUROCONVERT.

Если кнопка Евро не отображается на панели инструментов Форматирование, выберите команду Надстройки в меню Сервис и затем установите флажок Пересчет в евро для того, чтобы подключить соответствующую надстройку. Если надстройка отсутствует в списке, необходимо сначала установить надстройку.

  1. Выделите ячейки, которые требуется отформатировать с применением денежного стиля валюты евро.

  2. Нажмите кнопку Евро [image].

Примечания

  • Чтобы ввести в ячейку символ евро [image] , на клавиатуре с американской раскладкой наберите комбинацию ALT+0128 на цифровой клавиатуре. См. сведения о вводе символа евро на клавиатурах с другими раскладками.

  • Положение символа евро [image] (то есть отображается ли символ до или после числа и включается ли разделительный пробел между числом и символом) определяется установленными стандартами для денежной единицы в Панели управления Microsoft Windows. Чтобы изменить расположение символа, следует создать пользовательский денежный стиль.

  • Региональные стандарты, установленные для денежной единицы в Панели управления Windows, также определяют разделитель целой и дробной частей числа и разделитель групп разрядов.


EUROCONVERT

См. также

Преобразует число в значение в единицах евро, преобразует значение в единицах евро в значение в национальной валюте стран, использующих евро, или преобразует число из одной национальной валюты в другую с использованием в качестве промежуточного результата значения в евро. Валютами, доступными для пересчета, являются валюты стран-членов Европейского союза (ЕС), принявших евро в качестве денежной единицы. При преобразовании используются фиксированные курсы пересчета, устанавливаемые ЕС.

Синтаксис

EUROCONVERT(number,source,target,full_precision,triangulation_precision)

Number - значение в валюте, которое требуется преобразовать, или ссылка на ячейку, содержащую значение.

Source - строка из трех символов или ссылка на ячейку, содержащую строку, соответствующую коду ISO исходной валюты. В функции EUROCONVERT доступны следующие коды валют.

Страна | Основная единица валюты | Код ISO
Бельгия | франк | BEF
Люксембург | франк | LUF
Германия | немецкая марка | DEM
Испания | песета | ESP
Франция | франк | FRF
Ирландия | фунт | IEP
Италия | лира | ITL
Нидерланды | гульден | NLG
Австрия | шиллинг | ATS
Португалия | эскудо | PTE
Финляндия | финская марка | FIM
Страны, использующие евро | евро | EUR

Следующие страны могут принять евро в качестве денежной единицы после разработки первоначальной версии функции EUROCONVERT; в этом случае Майкрософт внесет обновления в функцию EUROCONVERT. Для получения сведений о новых странах, принявших евро в качестве денежной единицы, и об обновлениях для функции EUROCONVERT следует подключиться к Web-узлу корпорации Майкрософт, посвященному валюте евро.

Страна | Основная единица валюты | Код ISO
Дания | крона | DKK
Греция | драхма | GRD
Швеция | крона | SEK
Великобритания | фунт стерлингов | GBP

Target - строка из трех символов или ссылка на ячейку, содержащую строку, соответствующую коду ISO валюты, в которую требуется пересчитать значение. Коды ISO см. в приведенной таблице.

Full_precision - логическое значение (ИСТИНА или ЛОЖЬ) или выражение, результатом которого является логическое значение, указывающее, как выполняется округление результата.

Используйте значение | Если требуется
ЛОЖЬ | Использовать правила округления, относящиеся к конкретной валюте; подробности см. в приведенной ниже таблице. Excel использует значение точности расчета для расчета результата и значение точности отображения для отображения результата. ЛОЖЬ является значением по умолчанию в случае, если аргумент full_precision опущен.
ИСТИНА | Игнорировать относящиеся к конкретной валюте правила округления и вместо них воспользоваться коэффициентом пересчета с шестью значащими цифрами без последующего округления.

В следующей таблице приведены правила округления, относящиеся к конкретным валютам, то есть значения, соответствующие количеству десятичных разрядов, используемых Excel при пересчете и отображении результата.

Код ISO | Точность расчета | Точность отображения
BEF | 0 | 0
LUF | 0 | 0
DEM | 2 | 2
ESP | 0 | 0
FRF | 2 | 2
IEP | 2 | 2
ITL | 0 | 0
NLG | 2 | 2
ATS | 2 | 2
PTE | 1 | 2
FIM | 2 | 2
EUR | 2 | 2

Triangulation_precision - целое число, равное или большее 3, соответствующее числу значащих цифр, которое должно использоваться в промежуточном значении, выраженном в единицах евро, при перерасчете из одной валюты в другую. Если этот аргумент опущен, Excel не округляет промежуточное значение в единицах евро. Если данный аргумент указан при перерасчете из валюты страны, использующей евро, в значение евро, Excel рассчитывает промежуточное значение в единицах евро, которое может быть затем пересчитано в требуемую валюту.

Замечание

  • Excel отсекает конечные нули в возвращаемом значении.

  • Если исходный код ISO совпадает с конечным кодом ISO, Excel возвращает исходное значение числа.

  • При использовании недопустимых параметров возвращается ошибка #ЧИСЛО.

  • Данная функция не применяет числовой формат.

Примеры

В данных примерах принимаются курсы пересчета 1 евро = 6,55957 французского франка и 1,95583 немецкой марки. Функция EUROCONVERT использует текущие курсы, устанавливаемые ЕС; при изменении курсов Майкрософт будет вносить обновления в данную функцию. Для получения подробных сведений о действующих правилах и курсах следует обращаться к публикациям Европейской комиссии, касающимся евро. Для получения сведений о приобретении этих публикаций и получении обновлений для функции EUROCONVERT следует подключиться к Web-узлу корпорации Майкрософт, посвященному валюте евро.

В примерах приведены результирующие значения, хранящиеся в ячейке, без применения форматирования.

EUROCONVERT(1.20,"DEM","EUR") равняется 0,61 евро. Поскольку аргументы full_precision и triangulation_precision не указаны, в результате используется точность расчета для евро, составляющая 2 десятичных разряда.

EUROCONVERT(1,"FRF","EUR",ИСТИНА,3) равняется 0,152 евро. Если при пересчете в евро значением full_precision является ИСТИНА, результат имеет точность, определяемую аргументом triangulation_precision.

EUROCONVERT(1,"FRF","EUR",ЛОЖЬ,3) равняется 0,15 евро. Если при пересчете в евро значением full_precision является ЛОЖЬ, для вычисления результата используется точность расчета для евро, составляющая 2 десятичных разряда.

EUROCONVERT(1,"FRF","DEM",ИСТИНА,3) равняется 0,29728616 немецкой марки. Поскольку triangulation_precision равняется 3, промежуточное значение в евро округляется до трех разрядов. Так как значением full_precision является ИСТИНА, результирующее значение в немецких марках сохраняется со всеми значащими цифрами.

EUROCONVERT(1,"FRF","DEM",ЛОЖЬ,3) равняется 0,30 немецкой марки. Поскольку triangulation_precision равняется 3, промежуточное значение в евро округляется до трех разрядов. Так как значением full_precision является ЛОЖЬ, результирующее значение в немецких марках округляется в соответствии точностью расчета для немецкой марки, составляющей 2 десятичных разряда.


Разрешение вопросов при пересчете значений, содержащих евро

Выберите требуемый раздел справки:

Отсутствует кнопка Евро.

Значение, полученное в результате использования функции EUROCONVERT, округляется неправильно или имеет неверное число цифр.

Значения, содержащие евро, отображаются иначе на другом компьютере.

Функция EUROCONVERT не выполняет операции пересчета для требуемой валюты.

После форматирования значений с помощью кнопки Евро недоступна команда Отменить.

После импорта или экспорта текстового файла валюты отображаются неправильно.

Символ евро печатается неправильно.


 Значения, содержащие евро, отображаются иначе на другом компьютере.

Значения, содержащие евро, отображаются иначе на другом компьютере.

Для правильного выполнения пересчета значений, содержащих евро, на используемом компьютере должна быть установлена и загружена надстройка «Пересчет в евро», а также должна использоваться соответствующая версия Microsoft Excel. См. сведения о работе со значениями, содержащими евро, в более ранних версиях Excel.

Кроме того, необходима поддержка символа евро операционной системой. Например, при использовании Microsoft Windows 95 или Microsoft Windows NT 4.0 для ввода и отображения символа евро в программах, поддерживающих этот символ, может потребоваться загрузка обновления средств поддержки валюты евро для Windows 95. Дополнительные сведения можно найти на Web-узле корпорации Майкрософт, который посвящен валюте евро.


 Не удается найти кнопку Евро.

Не удается найти кнопку Евро.

Если кнопка Евро [image] не отображается на панели инструментов Форматирование, выберите команду Надстройки в меню Сервис и затем установите флажок Пересчет в евро для того, чтобы подключить соответствующую надстройку. Если надстройка отсутствует в списке, необходимо сначала установить надстройку.


После форматирования значений с помощью кнопки Евро недоступна команда Отменить.

После присвоения значениям денежного формата евро ни команда Отменить, ни кнопка Отменить не доступны. Для возвращения книги в исходное состояние закройте книгу без сохранения изменений. Однако при этом также будут утеряны все остальные изменения, внесенные со времени последнего сохранения.


После импорта или экспорта текстового файла валюты отображаются неправильно.

Импорт. При импорте текстового файла в Microsoft Excel распознаются только символ валюты, установленный в качестве стандартного для денежной единицы в Панели управления Windows, и символ евро. Если при импорте текстового файла требуется отобразить символы национальных валют, отличающихся от стандартной валюты и евро, следует создать пользовательские числовые форматы и применить требуемое форматирование к нужным значениям после импорта файла. Для сохранения изменений следует сохранить файл как книгу Excel.

Экспорт. Для получения сведений о том, как программа, в которую выполняется импорт, работает с евро, следует обратиться к справочной системе этой программы.

Более ранние версии Excel. См. сведения о работе со значениями и формулами, содержащими евро.


Значение, полученное в результате использования функции EUROCONVERT, округляется неправильно или имеет неверное число цифр.

Функция EUROCONVERT использует курсы пересчета Европейского союза, или коэффициенты пересчета, выражающие одну единицу евро в единицах национальных валют каждой из стран, использующих евро. Каждый коэффициент пересчета имеет шесть значащих цифр.

Если требуется отображение другого числа цифр или другое округление результата, можно задать один из необязательных аргументов функции, full_precision или triangulation_precision, или создать пользовательский числовой формат и применить его к результату.

См. сведения о функции EUROCONVERT и о выполнении в Microsoft Excel пересчета значений, содержащих евро.


Символ евро печатается неправильно.

Поддержка, необходимая для правильной печати символа евро на большинстве принтеров, обеспечивается Microsoft Excel и используемой операционной системой. Тем не менее, символ евро может печататься неправильно на некоторых принтерах при использовании определенных шрифтов. Для получения подробных сведений обратитесь к производителю принтера.

Для получения дополнительных сведений о поддержке символа евро операционными системами следует обратиться на Web-узел корпорации Майкрософт, посвященный валюте евро.


 Функция EUROCONVERT не выполняет операции пересчета для требуемой валюты.

Функция EUROCONVERT не выполняет операции пересчета для требуемой валюты.

Надстройка Microsoft Excel «Пересчет в евро» предоставляет для работы с евро и национальными денежными единицами стран, являющихся членами Европейского союза (ЕС) и принявшими в качестве валюты евро, функцию EUROCONVERT. Эта функция не выполняет пересчет для валют стран, не использующих евро. По мере принятия евро другими странами Майкрософт будет вносить обновления в функцию. Проверить, используется ли евро какой-либо конкретной страной, а также получить соответствующую обновленную версию надстройки «Пересчет в евро» можно на Web-узле корпорации Майкрософт, посвященном валюте евро.