Важные сведения для новых пользователей и пользователей, переходящих с предыдущих версий

Для пользователей, переходящих с предыдущих версий Microsoft Excel

Новые возможности Microsoft Excel 2000

Новые возможности Microsoft Excel 2000 для разработчиков

Обновление и преобразование файлов старых версий в формат Microsoft Excel 2000

Компоненты, устанавливаемые с Microsoft Excel

Для новичков в работе с электронными таблицами

Обзор новых возможностей

Получение справки по Microsoft Excel 2000

Книги издательства Microsoft Press о Microsoft Excel

Для пользователей, переходящих с других программ электронных таблиц

Переход с Lotus 1-2-3

Переход с Quattro Pro


Необходимые сведения об обновлении и преобразовании файлов в формат Microsoft Excel 2000

Формат файлов Microsoft Excel 2000 не отличается от формата файлов Microsoft Excel 97, но отличается от формата файлов более ранних версий.

Рекомендуется просмотреть следующие разделы:

Использование файлов Microsoft Excel 2000 с предыдущими версиями Microsoft Excel

Работа с книгами старого формата в Microsoft Excel 2000

Работа старых макросов и диалоговых окон в Microsoft Excel 2000

Часто задаваемые вопросы о переходе от Microsoft Excel 97

Часто задаваемые вопросы о переходе от Microsoft Excel 95

Часто задаваемые вопросы о переходе от Microsoft Excel 5.0


Технические характеристики Microsoft Excel

Выберите нужный раздел

Параметры листов и книг Excel

Параметры диаграмм

Параметры для рабочих групп

Информационный центр Майкрософт по проблеме 2000 года


Компоненты, устанавливаемые вместе с Microsoft Excel

Этот раздел содержит ссылки на компоненты, устанавливаемые вместе с Excel, и места, где эти компоненты могут быть найдены программами установки Excel 2000 и Office 2000.

Компоненты, которые устанавливаются (по умолчанию)

Компоненты, которые устанавливаются при первом использовании (по умолчанию)

Компоненты, которые устанавливаются только при настраиваемой установке

Текущая информация о компонентах, включенных в Excel 2000, может быть получена из файла Xlread9.txt в папке Microsoft Office\Office (или папке Microsoft Office при установке отдельной версии Microsoft Excel).

Компоненты, которые устанавливаются (по умолчанию)

Возможности | Место в программе установки
Файлы программы Microsoft Excel | Microsoft Excel для Windows
Справка по Microsoft Excel | Microsoft Excel для Windows; Справка
Коллекция рисунков | Средства Office
Цифровая подпись для проектов VBA | Средства Office
Выбор языка | Средства Office
Сведения о системе | Средства Office
Проверка правописания | Средства Office; Проверка правописания
Помощники по Office (1 помощник) | Средства Office; Помощник
Панель Microsoft Office | Средства Office
Публикации в Web | Средства Office; Поддержка серверных расширений
Web-компонеты Office (включая справку) | Средства Office; Web-компонеты Office
Web-обсуждения | Средства Office; Поддержка серверных расширений
Графические фильтры (Office: 18 фильтров; Excel: 8 фильтров) | Конвертеры и фильтры; Графические фильтры
Конвертер Microsoft Excel | Конвертеры и фильтры; Конвертеры текстовых файлов

Возврат в начало

Компоненты, которые устанавливаются при первом использовании (по умолчанию)

Возможности | Место в программе установки
Справка по Visual Basic | Средства Office; Справка по Visual Basic
Помощники по Office (7 дополнительных Помощников) | Средства Office; Помощник
Надстройка «Связь с Access» | Microsoft Excel для Windows; Надстройки
Пакет анализа | Microsoft Excel для Windows; Надстройки
Надстройка «Автосохранение» | Microsoft Excel для Windows; Надстройки
Мастер суммирования | Microsoft Excel для Windows; Надстройки
Мастер подстановок | Microsoft Excel для Windows; Надстройки
Надстройка «ODBC» | Microsoft Excel для Windows; Надстройки
Диспетчер отчетов | Microsoft Excel для Windows; Надстройки
Надстройка «Поиск решения» | Microsoft Excel для Windows; Надстройки
Мастер шаблонов с функцией сбора данных | Microsoft Excel для Windows; Надстройки
Надстройка «Обновление связей» | Microsoft Excel для Windows; Надстройки
Шаблон «Авансовый отчет» | Microsoft Excel для Windows; Шаблоны таблиц
Шаблон «Счет» | Microsoft Excel для Windows; Шаблоны таблиц
Шаблон «Заказ» | Microsoft Excel для Windows; Шаблоны таблиц
Microsoft Map | Microsoft Excel для Windows
«Village Software» | Microsoft Excel для Windows; Шаблоны таблиц
Поиск файлов | Средства Office; Поиск файлов
Организационная диаграмма | Средства Office
Microsoft Query (включая справку и драйверы) | Средства Office
Работа со сканерами и фотокамерами | Средства Office
Редактор сценариев Web | Средства Office; Редактор HTML-файлов

Возврат в начало

Компоненты, которые устанавливаются только при настраиваемой установке

Возможности | Место в программе установки
Примеры | Microsoft Excel для Windows; Примеры
Конвертер Quattro Pro | Microsoft Excel для Windows
Популярные картинки | Средства Office; Коллекция картинок; Каталог картинок
Microsoft PhotoDraw | Средства Office
Файлы программы Microsoft Binder | Средства Office
Справка по программе Microsoft Binder | Средства Office; Microsoft Binder
Конвертеры для использования Lotus Notes | Конвертеры и фильтры; Конвертеры текстовых файлов

Возврат в начало


Новые возможности Microsoft Excel 2000

Выбрав следующие категории, можно найти информацию о новых и улучшенных возможностях — и Excel 2000, и более ранних версий программы.

Основные возможности

Установка, графика, настройки Интернета и интеграция в Microsoft Office

Технические возможности и производительность

Ввод формул и данных

Функции

Форматирование и оформление

Управление списками и работа с итоговыми данными

Анализ и презентация данных с помощью диаграмм

Microsoft Excel и Интернет

Анализ данных с помощью отчетов сводных таблиц

Совместное использование книг, отображение изменений и журнал изменений

Извлечение данных из внешних баз данных

Защита

Поддержка пользователей и другие технические ресурсы Microsoft

Новые возможности для разработчиков


 Использование файлов Microsoft Excel 2000 в предыдущих версиях Excel

Использование файлов Microsoft Excel 2000 в предыдущих версиях Excel

Изменение формата файла, используемого по умолчанию По умолчанию Excel сохраняет книги в формате Microsoft Excel 2000. Если другие пользователи книг используют более ранние версии Excel или работают с другими программами электронных таблиц, имеется возможность изменить формат файлов, который Excel 2000 будет использовать по умолчанию при сохранении книг. Например, если многие в компании по-прежнему используют Excel версии 5.0, можно сохранять книги Excel 2000 в формате Microsoft Excel 5.0/95. Таким образом все книги будут сохраняться в формате Excel 5.0/95, если в диалоговом окне Сохранить как (меню Файл) не будет задан другой формат файла.

Использование двойного формата Если Excel 5.0 или Excel 95 по-прежнему широко распространены на предприятии, допускается сохранение книги Microsoft Excel 2000 в особом двойном формате.

  • Двойной формат файла Когда книга сохраняется в формате Microsoft Excel 97-2000 & 5.0/95 , книга сохраняется в одном файле, который включает и формат Excel 97/2000, и формат Excel 5.0/95. (Excel 5.0 и Excel 95 имеют идентичный формат файла.) Пользователи Excel 2000 могут продолжать работу с книгой, сохраненной в двойном формате, без потери каких бы то ни было возможностей уникальных для этой версии. Когда пользователи Excel 5.0 или Excel 95 открывают книгу, появляется сообщение, рекомендующее использовать этот файл в режиме только чтение. Однако, если пользователи проигнорируют рекомендацию и сохранят книгу в формате более ранней версии Excel, возможности, доступные только в Excel 2000 и Excel 97, будут утеряны.

  • Защита книги Для избежания потери изменений, внесенных в Excel 2000, можно защитить книгу от изменений с помощью пароля или установки для книги режима «только для чтения».

Отдельные книги могут быть сохранены в двойном формате с помощью команды Сохранить как меню Файл, можно так же задать двойной формат в качестве формата, используемого по умолчанию, при сохранении всех книг. Размер книг, сохраненных в двойном формате, превышает размер книг, сохраненных в одиночном формате.

Дополнительные сведения

Возможности Microsoft Excel 2000, недоступные в более ранних версиях Microsoft Excel и других программах.


Часто задаваемые вопросы о переходе от Microsoft Excel 97 к новой версии

Отсутствует окно помощника

Теперь помощник находится вне окна, занимает на экране меньше места, но по-прежнему охотно помогает, если у вас возникают какие-либо затруднения. Если он вам не нравится, отключите его и пользуйтесь предметным указателем или содержанием справки.

Что произошло с меню и панелями инструментов?

В новых индивидуализированных меню и панелях инструментов выделены только наиболее часто используемые элементы.

Меню можно легко расширить, включив в него все команды. Использованная команда немедленно появляется в персональном меню. Если хотите увидеть все команды сразу, запретите короткие меню. В меню Сервис выберите команду Настройка. На вкладке Параметры сбросьте флажок В меню сначала отображаются последние использованные команды.

Панели инструментов располагаются на экране в одном ряду, оставляя больше места для работы. Нажатая на панели инструментов кнопка автоматически добавляется к настраиваемым панелям инструментов. Можно легко настроить панели инструментов, перетаскивая мышью управляющие элементы команд на панель инструментов.

Почему при использовании некоторых возможностей задается вопрос о необходимости их установки?

В программе установки при выборе команды Установить устанавливаются не все возможности. Это сделано для повышения производительности и экономии места на жестком диске. При использовании Excel 2000 появляются ярлыки, значки и команды для программ и компонентов, которые еще не были установлены. Для их использования достаточно выбрать команду, а Excel 2000 сам установит необходимые программы и компоненты.

Что произошло с командами «Открыть» и «Сохранить» в меню «Файл»?

В улучшенных диалоговых окнах, вызываемых командами Открыть и Сохранить, теперь видно больше файлов, чем в диалоговых окнах прежней версии. Чтобы быстрее добираться до часто используемых папок, можно воспользоваться новой панелью адресов. Щелкнув кнопку Журнал, увидите список 20-50 недавно открывавшихся документов и папок. Щелчок кнопки Назад [image] на панели инструментов возвращает к последней открывавшейся папке.

Почему открытие некоторых файлов теперь требует больше времени?

Открывая книги, Excel 2000 их полностью пересчитывает и проверяет. Поэтому для открытия файлов, созданных более ранними версиями Excel, теперь требуется больше времени. Если файл сохранить в формате Excel 2000, то он будет открываться быстрее.

Изменилось ли что-нибудь в форматировании чисел?

Появились новые числовые форматы со знаком денежной единицы евро знак евро. Дополнительные форматы дат включают форматы, отображающие год четырьмя цифрами.

Почему изменилось выделение?

Теперь при выделении ячейки с цветным текстом его цвет не изменяется. В прежней версии цвет изменять на противоположный. Неизменность цвета шрифта и фона ячейки позволяет легко и быстро подбирать нужные цвета, не снимая выделения.

Почему исчезла команда «Сохранить в формате HTML»?

Команда Сохранить в формате HTML заменена командой Сохранить как Web-страницу. С помощью команды Сохранить как Web-страницу можно сохранить как Web-страницу либо всю книгу, либо только часть книги. После нажатия кнопки Опубликовать появляется выбор. Например, можно сохранить выделенную часть листа как интерактивный лист, который можно использовать на Web-странице.

Что произошло с мастером отчетов сводных таблиц?

Теперь отчет можно макетировать прямо на листе с помощью мастера отчетов сводных таблиц и диаграмм, перетаскивая мышью поля с панели инструментов в различные области сводной таблицы.

Почему при вводе данных Excel дописывает числа и формулы?

Для упрощения ввода формул и форматирования, Excel 2000 автоматически предлагает пользователю продолжение вводимых им данных.

Можно ли запустить в Excel 2000 макросы Lotus?

Excel 2000 не позволяет выполнить макросы Lotus 1-2-3 и Quattro Pro. Макросы можно переписать с помощью Microsoft Visual Basic для приложений. За справкой по написанию макросов Excel обращайтесь к справке по Visual Basic.


Часто задаваемые вопросы о переходе от Microsoft Excel 95

Как вставить диаграмму в отдельный лист?

Команда Диаграмма в меню Вставка запускает Мастер диаграмм. На шаге 4 можно определить способ создания диаграммы: как встроенный объект на листе или на отдельном листе диаграммы. По-прежнему можно создать диаграмму стандартного типа и со стандартным форматированием за один шаг. Для этого нужно нажать клавишу F11.

Почему открытие некоторых файлов требует больше времени?

Всякий раз, когда Excel 2000 открывает книги, они полностью пересчитываются для проверки правильности вычислений в них. Это означает, что может потребоваться больше времени для открытия файлов в формате более ранних версий. Если файл будет сохранен в формате Excel 2000, в следующий раз он будет открыт гораздо быстрее.

Где найти Мастер ответов и Мастер подсказок?

Помощник заменяет мастера подсказок из версий 5.0 и 95 и включает технологию IntelliSense из версии . Если пользователь нуждается в помощи, он может нажать кнопку Справка Microsoft Excel [image] и задать помощнику вопрос на естественном языке. Когда подсказка доступна, появляется желтая лампочка, на которую надо нажать, чтобы увидеть подсказку.

Что произошло с меню и панелями инструментов?

Только наиболее часто используемые элементы выделены в новых индивидуализированных меню и панелях инструментов.

Можно легко расширить меню для показа всех команд. После того как команда выбрана, она появляется в индивидуализированном меню. Если должны быть видны все сразу команды, следует запретить короткие меню. В меню Сервис выберите команду Настройка. На вкладке Параметры сбросьте флажок В меню сначала отображаются последние использованные команды.

Панели инструментов располагаются в одном ряду на экране, поэтому на экране остается больше места для работы. Та кнопка, которая выбрана на панели инструментов, автоматически добавляется к настраиваемым панелям инструментов на экране. Можно легко настроить панели инструментов, перетаскивая мышью управляющие элементы команд на панель инструментов.

Почему при использовании некоторых возможностей задается вопрос о необходимости их установки?

В программе установки при выборе команды Установить устанавливаются не все возможности. Это сделано для повышения производительности и экономии дискового пространства. При использовании Excel 2000 появляются ярлыки, значки и команды для программ и компонентов, которые еще не были установлены. Для их использования достаточно выбрать команду, а Excel 2000 сам установит программы и компоненты.

Что произошло с командами Файл Открыть и Файл Сохранить?

Улучшенные диалоговые окна Открыть и Сохранить позволяют просматривать за один раз большее количество файлов. Можно использовать новую Панель Адресов для перехода к наиболее часто используемым папкам и адресам; выбрать Журнал для просмотра от 20 до 50 последних документов, к которым обращались или нажать кнопку «Назад» [image] на панели инструментов для легкого перехода к папкам, к которым обращались в последнее время.

Как работать с примечаниями к ячейкам?

Ячейки могут быть снабжены примечаниями. Для создания примечания в меню Вставка выберите команду Примечание. Примечания могут быть просмотрены следующим образом: навести указатель мыши на ячейку с индикатором примечания ( в Excel 2000 — это красный треугольник) в правом верхнем углу ячейки.

Где находится «Окно информации»?

В Microsoft Excel 2000 «Окно информации» недоступно. Для обнаружения влияющих ячеек можно использовать панель инструментов Зависимости. Если к ячейке добавлены примечания, надо просто оставить указатель мыши на ячейке, чтобы просмотреть примечание.

В меню Файл отсутствует команда «Список Доступа». Как организовать совместный доступ в Excel 2000?

Списки доступа в Excel 95 обеспечивали ограниченные возможности одновременной работы нескольких пользователей с книгами. В Excel 2000 совместно используемые книги дают возможность создания и редактирования формул, изменения форматирования, создания и редактирования диаграмм и даже добавления листов. Для открытия доступа к книге выберите команду Доступ к книге в меню Сервис.

Изменилось ли что-нибудь в форматировании чисел?

Доступны дополнительные числовые форматы с символом валюты евро символ валюты евро. Дополнительные форматы дат включают форматы, отображающие год четырьмя цифрами.

Почему изменился цвет выделения?

Когда выделяется окрашенный текст, цвет остается тем же самым, а не изменяется на обратную цветовую схему. При работе с выбранным диапазоном становится проще увидеть новый цвет ячейки после изменения шрифта или цвета ячейки.

Что случилось со звуковыми заметками?

Звуковые заметки не поддерживаются в Excel 2000.

Как запустить Мастера сводных таблиц?

Используйте команду Сводная таблица в меню Данные для запуска Мастера сводных таблиц и диаграмм. Можно не использовать мастера для получения макета сводного отчета, а сформировать макет прямо на листе, перетаскивая поля с панели инструментов в соответствующие области размещения.

В меню Вид отсутствует команда Диспетчер Видов. Как создать представление?

Используйте команду Представления в меню Вид для сохранения представлений книги и для переключения на другое представление. Представления включены в состав Excel; поэтому эта команда больше не требует программы надстройки.

Можно ли запустить в Excel 2000 макросы Lotus?

Excel 2000 не позволяет выполнить макросы Lotus 1-2-3 и Quattro Pro. Макросы могут быть переписаны с помощью Microsoft Visual Basic для приложений. За справкой по написанию макросов Excel обращайтесь к справке по Visual Basic.


Часто задаваемые вопросы о переходе от Microsoft Excel 5.0

Что произошло с меню и панелями инструментов?

Только наиболее часто используемые элементы выделены в новых индивидуализированных меню и панелях инструментов

Можно легко расширить меню для показа всех команд. После того как команда выбрана, она появляется в индивидуализированном меню. Если должны быть видны все сразу команды, следует запретить короткие меню. В меню Сервис выберите команду Настройка. На вкладке Параметры сбросьте флажок В меню сначала отображаются последние использованные команды.

Панели инструментов располагаются в одном ряду на экране, поэтому на экране остается больше места для работы. Та кнопка, которая выбрана на панели инструментов, автоматически добавляется к настраиваемым панелям инструментов на экране. Можно легко настроить панели инструментов, перетаскивая мышью управляющие элементы команд на панель инструментов.

В меню Файл отсутствует команда Найти Файл. Как найти книгу?

Используйте команду Открыть в меню Файл для поиска книг. Поиск можно производить по слову или фразе, содержащимся в книге, или свойству файла (автор, тема, название).

Почему открытие некоторых файлов требует больше времени?

Всякий раз, когда Excel 2000 открывает книги, они полностью пересчитываются для проверки правильности вычислений в них. Это означает, что может потребоваться больше времени для открытия файлов в формате более ранних версий. Если файл будет сохранен в формате Excel 2000, в следующий раз он будет открыт гораздо быстрее.

В меню Файл отсутствует команда Сводка. Как просмотреть и установить информацию о файле?

Используйте команду Свойства в меню Файл для просмотра статистики файла и установки свойств файла: автор, тема, название.

В меню Вид отсутствует команда Диспетчер видов. Как создать представление?

Используйте команду Представления в меню Вид для сохранения представлений книги и для переключения на другое представление. Представления включены в состав Excel; поэтому эта команда больше не требует программы надстройки.

Как работать с примечаниями к ячейкам?

Ячейки могут быть снабжены примечаниями. Для создания примечания в меню Вставка выберите команду Примечание. Примечания могут быть просмотрены следующим образом: навести указатель мыши на ячейку с индикатором примечания (красный треугольник) в правом верхнем углу ячейки.

Как вставить диаграмму в отдельный лист?

Команда Диаграмма в меню Вставка запускает Мастер диаграмм. На шаге 4 можно определить способ создания диаграммы: как встроенный объект на листе или на отдельном листе диаграммы. По-прежнему можно создать диаграмму стандартного типа и со стандартным форматированием за один шаг. Для этого нужно нажать клавишу F11.

Почему при использовании некоторых возможностей задается вопрос о необходимости их установки?

В программе установки при выборе команды Установить устанавливаются не все возможности. Это сделано для повышения производительности и экономии дискового пространства. При использовании Excel 2000 появляются ярлыки, значки и команды для программ и компонентов, которые еще не были установлены. Для их использования достаточно выбрать команду, а Excel 2000 сам установит программы и компоненты.

Изменилось ли что-нибудь в форматировании чисел?

Доступны дополнительные числовые форматы с символом валюты евро символ валюты евро. Дополнительные форматы дат включают форматы, отображающие год четырьмя цифрами.

Почему изменился цвет выделения?

Когда выделяется окрашенный текст, цвет остается тем же самым, а не изменяется на обратную цветовую схему. При работе с выбранным диапазоном становится проще увидеть новый цвет ячейки после изменения шрифта или цвета ячейки.

В меню Вставка отсутствует подменю Макрос. Как создать макрос?

В меню Сервис выберите команду Макрос, а затем команду Редактор Visual Basic. После этого в среде Visual Basic можно создать и отредактировать макросы с помощью Visual Basic для приложений. Новый XLM макрос не может быть записан в Microsoft Excel 97.

Можно ли запустить в Excel 2000 макросы Lotus?

Excel 2000 не позволяет выполнить макросы Lotus 1-2-3 и Quattro Pro. Макросы могут быть переписаны с помощью Microsoft Visual Basic для приложений. За справкой по написанию макросов Excel обращайтесь к справке по Visual Basic.

Что случилось со справкой по Multiplan?

Excel больше не включает справку по Multiplan. Для обмена документами с Microsoft Multiplan рекомендуется воспользоваться форматом SYLK (Symbolic Link). За информацией о форматах файлов обратитесь к справке по Microsoft Excel.

Где найти мастера подсказок?

Помощник заменяет мастера подсказок из версий 5.0 и 95 и включает технологию IntelliSense из версии Excel 95. Если пользователь нуждается в помощи, он может нажать кнопку Справка Microsoft Excel [image] и задать помощнику вопрос на естественном языке. Когда подсказка доступна, появляется желтая лампочка, на которую надо нажать, чтобы увидеть подсказку.


Работа с книгами старого формата в Microsoft Excel 2000

Книги, созданные в более ранних версиях Excel, могут быть открыты непосредственно в Excel 2000. Excel 2000 поддерживает все данные, формулы и форматы, созданные в предыдущих версиях, за исключением звуковых примечаний к ячейкам.


Работа старых макросов и диалоговых окон в Microsoft Excel 2000

Переход от Microsoft Excel версий 97 и 95

Excel 2000 поддерживает макросы Visual Basic для приложений из Excel 97 и Excel 95. Для получения сведений о совместимости макросов Excel 95 и Excel 2000 выберите команду Office на Web в меню Справка Excel 2000.

Переход от Excel версии 5.0

Большинство макросов Visual Basic для приложений и макросов XLM не требуют внесения изменений для работы в Microsoft Excel 2000. В Microsoft Excel 2000 нельзя записывать новые макросы XLM. Более подробные сведения об обновлении макросов могут быть найдены в книге Microsoft Office 2000 Resource Kit издательства Microsoft Press. Также можно загрузить Microsoft Office Resource Kit с сервера фирмы Microsoft в Интернете.

Для создания новых макросов в Microsoft Excel 2000 следует записывать их в Visual Basic для приложений или с помощью редактора Visual Basic. Дополнительную информацию о записи макросов можно найти в справочной системе по Microsoft Excel.

Листы диалогов в Excel версий 5.0 и 95

В большинстве случаев листы диалогов не требуют изменений для запуска их в Microsoft Excel 2000.

Для создания новых диалогов в Microsoft Excel 2000 следует использовать команду UserForm в меню Insert редактора Visual Basic. Более подробные сведения о создании диалогов могут быть найдены в справочной системе по Visual Basic.


Переход с Lotus 1-2-3

Microsoft Excel 2000 и Lotus 1-2-3 имеют отличия, о которых следует знать. Например правила вычисления формул и функций в Excel и Lotus 1-2-3 различны. Кроме того Excel 2000 не может выполнять макросы Lotus 1-2-3. Чтобы получить справку по использованию какой-либо команды в Excel, следует ввести команду Lotus 1-2-3 и просмотреть пример использования той же команды в Excel.

Сведения об отличиях Lotus 1-2-3

Различия между Microsoft Excel и Lotus 1-2-3

Различия в функциях Lotus 1-2-3 и Microsoft Excel

Использование справочной системы Lotus 1-2-3 для изучения возможностей Microsoft Excel

Терминология Lotus 1-2-3 и эквивалентные понятия Microsoft Excel

Использование листов и команд Lotus 1-2-3 в Excel

Взаимные преобразования электронных таблиц форматов Lotus 1-2-3 и Microsoft Excel

Перемещение по листу с помощью клавиш Lotus 1-2-3

Ввод и вычисление формул с помощью методов ввода формул Lotus 1-2-3


 Преобразование электронных таблиц форматов Lotus 1-2-3 и Microsoft Excel

Преобразование электронных таблиц форматов Lotus 1-2-3 и Microsoft Excel

Преобразование файлов

Сохранение в формате файлов Microsoft Excel. Excel сохраняет формат любого открытого файла. При сохранении файла Excel использует исходный формат. Если в Excel открыт файл Lotus 1-2-3, и требуется сохранить все вносимые изменения, то при сохранении файла необходимо изменить его формат. Выберите в меню Файл команду Сохранить как. Выберите в поле Тип файла вариант Книга Microsoft Excel, а затем нажмите кнопку Сохранить.

Изменение расширения имени файла. При сохранении книги в виде файла другого типа путем изменения формата файла в поле Тип файла изменять имя файла не нужно, поскольку Excel сохраняет эту копию файла книги с другим расширением. Например, файл Lotus 1-2-3 версии 4.0 имеет расширение .wk4; формат «Книга Microsoft Excel» использует расширение .xls.

Для того чтобы изменить тип файла, недостаточно ввести новое расширение в поле Имя файла или переименовать файл в окне папки с указанием нового расширения. Необходимо также выбрать нужный вариант в поле Тип файла. Инструкции по изменению формата файла при сохранении.

Применение форматирования из связанных файлов. При открытии листа или книги Lotus 1-2-3 в Excel к данным применяется форматирование, хранящееся в файле с расширением .fmt, .fm3 или .all. Этот файл должен находиться в той же папке, что и файл с расширением .wk?. При сохранении файла Lotus 1-2-3 в формате Microsoft Excel, данные и параметры форматирования сохраняются в одном файле книги.

Преобразование нескольких файлов к формату Excel. При помощи команды Открыть (меню Файл) можно также открыть сразу несколько электронных таблиц Lotus 1-2-3. Для того чтобы выделить несмежные файлы, щелкните имя одного файла, а затем, удерживая нажатой клавишу CTRL, имена остальных файлов. Для выделения смежных файлов щелкните имя первого файла, а затем, удерживая нажатой клавишу SHIFT, имя последнего файла последовательности. Для того чтобы преобразовать открытие файлы в формат Microsoft Excel, сохраните каждый файл как книгу Microsoft Excel при помощи команды Сохранить как (меню Файл).

Преобразование формул

Использование правил Lotus 1-2-3 для вычисления формул. При открытии таблицы Lotus 1-2-3 в Excel для листа автоматически устанавливается флажок Производить вычисления по правилам Lotus 1-2-3 (меню Сервис, команда Параметры, вкладка Переход), что гарантирует вычисление формул в Excel в соответствии с правилами Lotus 1-2-3.

При сохранении электронной таблицы Lotus 1-2-3 в формате книги Microsoft Excel, флажок Производить вычисления по правилам Lotus 1-2-3 остается установленным до тех пор, пока не будет явно снят.

Использование ячеек в формулах. После преобразования файла Lotus 1-2-3 в книгу Microsoft Excel можно проверить связи между ячейками и формулами в пределах листа при помощи команд проверки зависимостей. См. сведения о поиске влияющих ячеек.

Некоторые формулы могут не преобразовываться. Если формула не может быть преобразована к формату Microsoft Excel, на листе отображаются последние значения, вычисленные для этой формулы в Lotus 1-2-3. См. сведения о затруднениях при преобразовании формул.

Преобразование макросов

Excel 2000 не выполняет макросы Lotus 1-2-3. Все нужные макросы можно написать заново на языке Visual Basic для приложений. Сведения о написании макросов Excel см в справке по Visual Basic.


 Различия между Microsoft Excel и Lotus 1-2-3

Различия между Microsoft Excel и Lotus 1-2-3

Для перехода с Lotus 1-2-3 на Microsoft Excel 2000 необходимо знать о некоторых различиях, существующих между ними.

Особенности окна Excel В Excel книги содержат листы и отображаются в окне. По умолчанию в верхней части окна отображаются строка меню, строка формул и панели инструментов Стандартная и Форматирование. В нижней части окна находится строка состояния, отображающая текущее состояние рабочей среды. Более подробные сведения об областях окна можно получить, выбрав Что это такое? из меню Справка и затем щелкнув нужную область или элемент. Чтобы получить справку по параметру диалогового окна, щелкните вопросительный знак [image] в области заголовка и укажите нужный параметр.

Сначала выделение, потом команда В Lotus 1-2-3 сначала выбирается команда, а затем диапазон, над которым осуществляется действие. В Excel сначала выделяется нужная ячейка, диапазон или объект, а затем над ними выполняется действие. Например, чтобы изменить формат диапазона ячеек следует сначала выделить эти ячейки, а затем выбрать команду Ячейки из меню Формат.

Разница в записи формул Также существуют важные различия в написании формул в Microsoft Excel:

  • В Excel формула начинается со знака равенства (=). Можно начать формулу и со знака плюс (+), как это делается в Lotus 1-2-3.

  • Символ амперсанта (@) перед именем функции Excel не обязателен.

  • В Excel для задания диапазона ячеек используется двоеточие (:), а в Lotus 1-2-3 две точки (..).

Клавиши перемещения по электронной таблице Клавиши перемещения в Excel и Lotus 1-2-3 также не совпадают. Например, нажатие клавиши HOME в Lotus 1-2-3 приводит к выделению ячейки в верхнем левом углу листа, а в Excel выделяется первая ячейка текущей строки. Excel может быть настроен так, чтобы использовались те же клавиши перехода, что и в Lotus 1-2-3. Преобразование клавиш перемещения.

Разбиение текста из одного столбца в несколько столбцов При необходимости разбить данные в одном столбце на несколько столбцов следует использовать команду Текст по столбцам (меню Данные). Разбиение текста на столбцы.

В Lotus 1-2-3 для разбиения текстовых строк из одного столбца на несколько столбцов используется команда Parse. При открытии текстового файла в Excel мастер текстов помогает разбить данные на столбцы. Импорт текстовых файлов в Excel.

Макросы Excel 2000 не выполняет макросы Lotus 1-2-3.


Различия в функциях Lotus 1-2-3 и Microsoft Excel

Большинство функций Lotus 1-2-3 имеют в Microsoft Excel свои эквиваленты. Если на вкладке Переход (меню Сервис, команда Параметры) установлен флажок Преобразование формул в формат Excel при вводе, прямо в ячейки допускается ввод большинства функций Lotus 1-2-3, доступных в версиях, более ранних чем версия 3.0, а эти функции преобразуются в эквивалент Microsoft Excel.

Предполагаемые действия

Эквиваленты функций Lotus 1-2-3 в Microsoft Excel

Функции Microsoft Excel, не имеющие эквивалентов в Lotus 1-2-3


 Справка о том, как команда Lotus 1-2-3 выполняется в Microsoft Excel

Справка о том, как команда Lotus 1-2-3 выполняется в Microsoft Excel

Сведения, относящиеся к конкретным языкам

  1. Выберите в меню Справка команду Справка по Lotus 1-2-3.

    Демонстрация

  2. Для того чтобы просмотреть пример выполнения команды Lotus 1-2-3 в Microsoft Excel, установите переключатель в группе Режим в положение Демонстрация.

    Для того чтобы просмотреть пошаговые инструкции по выполнению команды Lotus 1-2-3 в Microsoft Excel, установите переключатель в группе Режим в положение Инструкции.

  3. Нажмите клавиши, используемые для выполнения команды в Lotus 1-2-3.

  4. Если для завершения команды требуются дополнительные сведения, Microsoft Excel отобразит диалоговое окно.

Примечание. Команда Справка по Lotus 1-2-3 моделирует сочетания клавиш, используемые в Lotus 1-2-3 версии 2.10.


 Ввод и вычисление формул с помощью методов ввода формул Lotus 1-2-3

Ввод и вычисление формул с помощью методов ввода формул Lotus 1-2-3

В Microsoft Excel можно вводить формулы и работать с именами так, как будто это происходит в Lotus 1-2-3. Кроме этого, можно обрабатывать формулы и выражения в соответствии с правилами Microsoft Excel или Lotus 1-2-3.

Предполагаемые действия

Ввод формулы с помощью методов Lotus 1-2-3

Обработка формул в Microsoft Excel по правилам Lotus 1-2-3

Различия в вычислениях формул в Microsoft Excel и Lotus 1-2-3


 Связывание электронных таблиц Lotus 1-2-3 и Microsoft Excel

Связывание электронных таблиц Lotus 1-2-3 и Microsoft Excel

Преимущества связей. Предоставляется возможность использовать данные таблицы Lotus 1-2-3 на листе Microsoft Excel без преобразования таблицы Lotus 1-2-3 в формат книги Microsoft Excel. При изменении данных в таблице Lotus 1-2-3 лист Excel автоматически обновляется.

Например, можно связать размеры продаж из различных таблиц Lotus 1-2-3 с одним листом Excel. Затем можно создать отчет сводной таблицы для обобщения этих данных, создать диаграмму для привлечения внимания к итоговым значениям, либо использовать средства форматирования и печати Excel для создания итогового отчета о продажах.

Инструкции по созданию формулы для связи с данными таблицы Lotus 1-2-3.

Типы файлов, с которыми возможна связь. Листы Microsoft Excel можно связывать с файлами Lotus 1-2-3 следующих форматов: WKS, WK1, WK3 и WK4. Если для редактирования таблицы Lotus 1-2-3, связанной с книгой Microsoft Excel, используется Lotus 1-2-3, то связанные ячейки будут обновлены при открытии книги Microsoft Excel.

Поиск исходного файла для связывания. Если имя и местонахождение таблицы Lotus 1-2-3, данные которой используются на листе Excel, неизвестны, можно открыть книгу Excel, а затем с помощью команды Связи (меню Правка) открыть нужную таблицу Lotus 1-2-3.

Изменение и переназначение связей. Команду Связи можно также использовать для изменения или переназначения связей на листе Excel для связывания с другим листом. Инструкции по изменению связи или ссылки на переименованную или перемещенную книгу.


 Создание формул для вычисления данных в таблице Lotus 1-2-3

Создание формул для вычисления данных в таблице Lotus 1-2-3

  1. Откройте таблицу Lotus 1-2-3, содержащую исходные данные.

    Инструкции

  2. В таблице Lotus 1-2-3 выделите ячейки, с которыми необходимо установить связь.

  3. Нажмите кнопку Копировать [image] .

  4. Переключитесь на книгу Microsoft Excel, которая будет содержать формулу связи.

  5. Выделите первую ячейку, из которой необходимо установить связь.

  6. В меню Правка выберите команду Специальная вставка.

    Демонстрация

  7. Выберите Связать.

  8. Если не предполагается преобразовывать таблицу Lotus 1-2-3 в формат Excel, переключитесь на таблицу Lotus 1-2-3 и закройте ее без сохранения изменений.


 Макросы Lotus 1-2-3 и Quattro Pro не выполняются в Microsoft Excel

Макросы Lotus 1-2-3 и Quattro Pro не выполняются в Microsoft Excel

Выполнение макросов Lotus 1-2-3 и Quattro Pro в Excel 2000 не предусмотрено.

Создание макросов в Visual Basic для приложений (VBA). Все необходимые макросы можно создать заново на языке Visual Basic для приложений (Microsoft). Сведения по написанию макросов Excel см. в справке по Visual Basic.


Переход с Quattro Pro

Для открытия файлов Quattro Pro для Windows необходимо в Excel установить конвертер Quattro Pro. Сохранение листа в формате Quattro Pro для MS-DOS.

Ограничения при открытии листов Microsoft Excel 2000 и Quattro Pro имеют ряд существенных отличий. Хотя файлы Quattro Pro для MS-DOS и Quattro Pro для Windows могут быть открыты, существуют ограничения по открытию листов. Excel 2000 не может выполнить макросы Quattro Pro для MS-DOS.

Предполагаемые действия

Открытие электронных таблиц Quattro Pro в Microsoft Excel

Ограничения на открытие и преобразование файлов Quattro Pro в Microsoft Excel


 Открытие электронных таблиц Quattro Pro в Microsoft Excel

Открытие электронных таблиц Quattro Pro в Microsoft Excel

При открытии файла Quattro Pro в Microsoft Excel некоторые данные могут быть неправильно преобразованы. Открыть в Microsoft Excel файл Quattro Pro для Windows версии 6.0 невозможно. Для получения дополнительных сведений нажмите кнопку [image] .

  1. Выберите в меню Файл команду Открыть [image] .

  2. Для того чтобы открыть файл Quattro Pro для MS-DOS, выберите Файлы Quattro Pro/DOS в поле Тип файлов.

    Для того чтобы открыть файл Quattro Pro для Windows, выберите в поле Тип файлов вариант Quattro Pro 1.0/5.0, Quattro Pro 6.0 или Quattro Pro 7.0. Если эти варианты отсутствуют, необходимо установить конвертер Quattro Pro, компонент Excel.

  3. В поле Папка выберите диск или папку, в которой содержится нужная книга.

  4. В списке папок откройте двойным щелчком папку с нужной книгой.

  5. Дважды щелкните книгу, которую требуется открыть.

Примечание. После открытия файла Quattro Pro в Microsoft Excel для завершения преобразования следует сохранить его в формате книги Microsoft Excel. При сохранении файла в поле Тип файла следует выбрать Книга Microsoft Excel (или другой формат Microsoft Excel).


 Ограничения на открытие и преобразование файлов Quattro Pro в Microsoft Excel

Ограничения на открытие и преобразование файлов Quattro Pro в Microsoft Excel

Для открытия файлов Quattro Pro для Windows необходимо в Excel установить конвертер Quattro Pro. Сохранение листа в формате Quattro Pro для MS-DOS.

Файлы, защищенные паролем. Microsoft Excel 2000 не способен открыть файлы Quattro Pro, защищенные паролем. Перед открытием файла в Excel следует удалить из него все пароли. См. сведения о паролях и способах ограничения доступа к книгам и листам.

Поддерживаемые версии Quattro Pro. Excel может непосредственно открыть файл Quattro Pro для Windows версии 8.0 или более ранней. Для того чтобы открыть в Excel файл более поздней версии Quattro Pro, следует сохранить его либо в формате более ранней версии Quattro Pro, либо в другом формате, например в формате Lotus 1-2-3 (*.wk?).

Диаграммы Quattro Pro. Способы хранения диаграмм в Quattro Pro для Windows и в Excel различны. При импортировании файла Quattro Pro для Windows в Microsoft Excel диаграммы не импортируются. См. сведения о создании диаграмм.

Диспетчер сценариев Quattro Pro. Диспетчер сценариев Microsoft Excel не полностью идентичен диспетчеру сценариев Quattro Pro для Windows. Поэтому Microsoft Excel импортирует из сценария только те данные, которые были отображены при последнем сохранении файла в Quattro Pro для Windows. Инструкции по созданию сценария.

Связи с внешними данными. Гиперссылки на таблицы внешних баз данных или в окне моделирования не импортируются, поскольку они несовместимы с ODBC, Microsoft Query и сводными таблицами Microsoft Excel.

Объекты OLE. Excel не импортирует внедренные объекты OLE из файлов Quattro Pro для Windows.

Градиентное заполнение. В случае градиентного заполнения объекты форматируются с использованием основного цвета заполнения. Инструкции по добавлению градиентного заполнения.

Макросы. Excel 2000 не выполняет макросы Quattro Pro. Все нужные макросы можно написать заново на языке Microsoft Visual Basic для приложений. Сведения по написанию макросов Excel см. в справке по Visual Basic.


Разрешение вопросов по открытию, сохранению и работе с файлами Lotus 1-2-3 в Microsoft Excel

Microsoft Excel не может открыть файл Lotus 1-2-3

Потеря сведений о форматировании при открытии файла Lotus 1-2-3

Даты и телефонные номера из файла Lotus 1-2-3 отображаются как числа

Не удается выполнить преобразование формул Lotus 1-2-3

Ссылки на другие таблицы Lotus 1-2-3 не преобразуются правильно или содержат ошибки #ССЫЛКА!

Макросы Lotus 1-2-3 и Quattro Pro не выполняются в Microsoft Excel

Преобразованный файл имеет очень большой размер и открывается очень долго


Способы получения справки во время работы

Этот раздел содержит ссылки на:

Получение справки от помощника

Получение справки с помощью меню Справка

Получение справки с Web-узла обновления Microsoft Office

Новые возможности Excel 2000

Дополнительные сведения

Получение справки от помощника

Ввод вопроса Если возникает вопрос о программе, входящей в состав Microsoft Office, можно задать его помощнику. Например, для получения справки о форматировании диаграммы напечатайте Как отформатировать диаграмму? в окне помощника.

Автоматическое получение справки Помощник автоматически предлагает разделы справки и советы по выполняемым задачам — еще до того, как вопрос был задан. Например, когда устанавливаются параметры печати листа, помощник предлагает раздел справки, который поможет подготовить лист к печати.

Отображение полезных советов Помощник также отображает советы по более эффективному использованию возможностей Microsoft Excel. Нажмите на электрическую лампочку электрическая лампочка рядом с помощником и увидите совет.

Настройка помощника Можно выбрать другого помощника и настроить его соответственно своим нуждам и стилю работы. Например, если используется преимущественно клавиатура, помощник может отображать советы по нажатию сочетания клавиш. Поскольку помощник используется всеми программами Office, установка любых параметров помощника будет также действовать и в других программах Office.

Возврат в начало

Получение справки с помощью меню Справка

Отображение и использование окна справки В меню Справка выберите команду Справка по Microsoft Excel. Если помощник включен, то он появится на экране. Если помощник отключен, то появится окно справки. Для ввода вопросов в окно справки выберите вкладку Мастер ответов. Для просмотра оглавления справки выберите вкладку Содержание. Если нужно искать определенные слова или выражения, перейдите на вкладку Указатель.

Отображение подсказок Для того чтобы отображались подсказки для команд меню, кнопок панелей инструментов и областей экрана, в меню Справка выберите команду Что это такое? и затем щелкните интересующий элемент.

Чтобы увидеть подсказки для параметров диалогового окна, щелкните кнопку с вопросительным знаком вопросительный знак в диалоговом окне, а затем выберите параметр. (Если кнопка с вопросительным знаком не видна, щелкните параметр, а затем нажмите SHIFT+F1.)

Просмотр названий кнопок панелей инструментов Для того чтобы увидеть название кнопки панели инструментов, наведите указатель мыши на кнопку и оставьте его в таком положении, пока не появится надпись.

Возврат в начало

Получение справки с Web-узла обновления Microsoft Office

Через меню Справка Можно соединиться с Web-узлом обновления Office и другими Web-узлами Microsoft непосредственно из программ Office, выбрав Office на Web в меню Справка. Например, можно получить доступ к техническим ресурсам или загрузить бесплатные программные продукты — все это не выходя из Excel.

Из окна помощника Если нужный раздел не появляется в окне помощника, выберите Попытаться найти дополнительную справку в Web внизу списка тем. Будут выведены рекомендации по формулировке вопроса к помощнику и сужению круга поиска при помощи ключевых слов. Если требуемую информацию по-прежнему не удается получить, можно послать сообщение, которое будет учтено при разработке следующих версий справки, и автоматически подключиться к Web-узлу обновления Microsoft Office для поиска требуемой информации на нем.

Возврат в начало

Дополнительные сведения

Подключение к техническим ресурсам Microsoft

Получение справки, советов и сообщений с помощью помощника

Получение справки без помощника

Возврат в начало


 Изменение шрифта и цветов разделов справки

Изменение шрифта и цветов разделов справки

Шрифт, размер текста, цвета текста и цвет фона окна справки соответствуют аналогичным параметрам, установленным для Web-обозревателя, имеющегося на компьютере. Доступные параметры и возможности настройки зависят от обозревателя.

Изменение шрифта и цветов текста разделов справки. Параметры шрифта и цветового оформления Web-обозревателя (а следовательно, и разделов справки), указываются в таблице каскадных стилей. Имеется возможность переопределить любой из этих параметров, если требуется изменить внешний вид разделов в окне справки, что может быть полезно, если пользователь имеет ослабленное зрение. Изменить можно как шрифт, так и цвета текста и цвет фона.

Изменение размера текста. Размеры шрифтов в разделах справки можно переопределить, сделав текст более крупным.

Изменения затрагивают другие программы. Вносимые изменения влияют на вид разделов справки во всех программах Microsoft Office. Необходимо также иметь в виду, что изменения шрифта, размера текста, цветов текста или цвета фона разделов в окне справки влияют также на вид Web-страниц, просматриваемых в обозревателе. Для получения дополнительных сведений о доступных параметрах и возможностях настройки обратитесь к справочной системе обозревателя.

Специальные возможности. В Microsoft Excel имеются дополнительные специальные возможности для людей с нарушениями подвижности, зрения и слуха.


 Печать раздела справки

Печать раздела справки

Печать текущего раздела

  1. Нажмите кнопку Печать [image].

  2. Установите требуемые параметры печати.

Печать семейства разделов

  1. Выберите вкладку Содержание.

    Если вкладка Содержание не отображается, нажмите кнопку Показать [image] для отображения кнопок перехода.

  2. Выберите заголовок раздела, который требуется напечатать, и нажмите кнопку Печать [image].

  3. Выполните одно из следующих действий:

    Чтобы напечатать текущую страницу, выберите Напечатать текущий раздел.

    Чтобы напечатать все разделы под выбранным заголовком, выберите Напечатать все содержимое текущего заголовка.

  4. Установите требуемые параметры печати.


 Получение справки по Visual Basic из Microsoft Excel

Получение справки по Visual Basic из Microsoft Excel

  1. В меню Сервис выберите команду Макрос, а затем — Редактор Visual Basic.

  2. Если помощник не отображается на экране, нажмите кнопку Помощник [image] .

  3. Если выноска помощника не отображается, щелкните помощника.

  4. В окне помощника введите метод, свойство, функцию, инструкцию или объект, о котором требуется получить справочные сведения, или запрос.

  5. Нажмите кнопку Найти, а затем выберите нужный раздел.

Советы

  • Чтобы во время работы с редактором Visual Basic просмотреть список методов, свойств, функций и объектов Visual Basic для Microsoft Excel, нажмите кнопку Просмотр объектов [image] . В списке библиотек выберите библиотеку нужной программы. Чтобы получить справку по отдельному элементу списка, выделите его, а затем нажмите кнопку с вопросительным знаком в диалоговом окне Просмотр объектов.

  • Чтобы вызвать справку по редактору Visual Basic, выберите команду Справка по Microsoft Visual Basic в меню Help.


 Получение справки по редактору сценариев (Microsoft Script Editor) в Microsoft Excel

Получение справки по редактору сценариев (Microsoft Script Editor) в Microsoft Excel

Выполните одно из следующих действий:

  1. Если создается новый сценарий , выберите пункт Макрос в меню Сервис, а затем — команду Редактор сценариев.

    Если редактируется существующий сценарий, дважды щелкните ссылку сценария, который нужно просмотреть.

  2. В меню Help в окне Microsoft Development Environment выберите требуемый параметр:

    Для получения содержимого справки редактора сценариев выберите Contents.

    Для поиска по предметному указателю — Index.

    Для поиска конкретных слов — Search.


 Получение сведений о программе и компьютере

Получение сведений о программе и компьютере

  1. В меню Справка выберите пункт О программе...

    На экран будет выведено диалоговое окно О программе, содержащее сведения о программе.

    Демонстрация

  2. Для получения сведений о компьютере нажмите кнопку О системе.


Отображение, скрытие и отключение помощника

  • В меню Справка выберите команду Показать помощника или Скрыть помощника.

Примечания

  • Чтобы отключить помощника, щелкните изображение помощника, нажмите кнопку Параметры, и затем снимите флажок Использовать помощника. Справочные сведения можно получить также без использования помощника.

  • Чтобы совсем избавиться от помощника, необходимо удалить его.


Получение справки, советов и сообщений с помощью помощника

Предполагаемые действия

Включение помощника

Советы помощника

Отображение совета дня

Автоматический подбор разделов справки помощником

Отображение помощником справки по мастерам

Отображение системных сообщений с помощью помощника

Дополнительные сведения


Использование клавиатуры при работе с помощником Office

Нажмите | Чтобы
F1 | Получить справку; при этом, если помощник включен, отображается выноска помощника.
ALT+цифра (ALT+1 — первый раздел, ALT+2 — второй и т.д.) | Выбрать раздел справки из списка разделов, отображаемого помощником
ALT+СТРЕЛКА ВНИЗ | Просмотреть следующие разделы справки
ALT+СТРЕЛКА ВВЕРХ | Просмотреть предыдущие разделы справки
ESC | Закрыть сообщение или совет помощника


Перемещение окна помощника

  • Используя мышь, перетащите окно помощника в нужное место на экране.


Включение и отключение звука помощника

Для прослушивания звукового сопровождения помощника на компьютере должна быть установлена звуковая плата.

  1. Щелкните изображение помощника.

    Если помощник не отображается на экране, выберите команду Показать помощника в меню Справка.

  2. Нажмите кнопку Параметры.

  3. На вкладке Параметры установите или снимите флажок звуковое сопровождение.


 Выбор помощника

Выбор помощника

  1. Щелкните изображение помощника.

    Если помощник не отображается на экране, выберите команду Показать помощника в меню Справка.

  2. Нажмите кнопку Параметры.

  3. Перейдите на вкладку Коллекция и используйте кнопки Назад и Далее для просмотра имеющихся персонажей.

Note. При наличии доступа к Интернету можно загрузить дополнительных помощников с Web-узла обновления Microsoft Office. Для этого в меню Справка выберите команду Office на Web и следуйте появляющимся инструкциям.


Получение справки без помощника

Для получения справки без использования помощника Office, помощника следует отключить. Отключение помощника.

  1. В меню Справка выберите команду Справка по Microsoft Excel.

    Если вкладки Содержание, Мастер ответов и Указатель не отображаются, нажмите кнопку Показать [image].

  2. В окне справки выполните какое-либо из следующих действий:

    Чтобы просмотреть содержание справки, выберите вкладку Содержание.

    Чтобы ввести вопрос о программе Microsoft Office, выберите вкладку Мастер ответов.

    Чтобы выполнить поиск по конкретным словам или словосочетаниям, или выбрать ключевые слова из списка, выберите вкладку Указатель. Добавляя или удаляя ключевые слова, можно уточнять запрос и управлять списком найденных разделов, с тем чтобы в списке остались только нужные разделы и ключевые слова.


Отображение сообщений с использованием помощника или без него

  1. Щелкните изображение помощника.

    Если помощник не отображается на экране, выберите команду Показать помощника в меню Справка.

  2. Нажмите кнопку Параметры.

  3. На вкладке Параметры установите или снимите флажок отображать сообщения помощника.


Подключение к техническим ресурсам Microsoft

Если во время работы с программой Microsoft Office возникли вопросы, прежде всего следует попробовать разрешить их с помощью помощника, а затем обратиться к руководству Знакомство с Microsoft Office 2000 или к файлу с последними сведениями, поставляемому вместе с программой. Если нужные сведения не найдены, их можно получить, обратившись к техническим ресурсам, перечисленным в приведенном ниже списке.

См. также

Обновление Microsoft Office. Регулярно обновляемый Web-узел, предоставляющий сведения и ответы на вопросы о всех продуктах семейства Microsoft Office. См. сведения о Web-узле обновления Microsoft Office.

База данных Microsoft Knowledge Base. Данный ресурс содержит сведения о продуктах Майкрософт для сотрудников служб поддержки и клиентов. См. сведения о Базе данных Microsoft Knowledge Base.

Библиотека Microsoft Software Library. Данный ресурс позволяет с помощью Интернета получить различные бесплатные двоичные (не текстовые) файлы для продуктов Майкрософт. См. сведения о Microsoft Software Library.

Компакт-диски Microsoft TechNet и Microsoft Developer Network. На этих компакт-дисках содержатся исчерпывающие сведения по поддержке продуктов Майкрософт для делового применения, а также полная информация по программированию и соответствующие пакеты для разработки. См. сведения о Microsoft TechNet и Microsoft Developer Network.

Издательство Microsoft Press. Издательство Microsoft Press предлагает учебные и справочные материалы по продуктам Майкрософт. См. сведения о Microsoft Press.

Служба Microsoft Download Service. Данная служба предлагает демонстрационные программы, пакеты исправлений и другие вспомогательные средства. См. сведения о Microsoft Download Service.

Служба FastTips. Эта автоматизированная бесплатная служба предоставляет ответы на общие технические вопросы круглосуточно, 7 дней в неделю. См. сведения о FastTips.


 Не удается получить доступ к Web-узлу обновления Microsoft Office.

Не удается получить доступ к Web-узлу обновления Microsoft Office.

  • Убедитесь в наличии доступа к Интернету. Для подключения при выборе команды Office на Web (меню Справка) к Web-узлу обновления Office необходимо иметь доступ к Интернету либо через сеть интранет компании, либо через модем, подключенный к компьютеру или сети, а также учетную запись поставщика услуг Интернета. Дополнительные сведения содержатся в руководстве Ресурсы Microsoft Office 2000 (Microsoft Office 2000 Resource Kit). См. сведения о получении руководства «Ресурсы Microsoft Office 2000».

  • Проверьте параметры подключения к Интернету в Windows. Параметры подключения к Интернету могу быть установлены неправильно. Чтобы проверить установленные значения параметров и внести необходимые исправления, дважды щелкните значок «Интернет» в Панели управления Windows.

  • Проверьте модем. Убедитесь, что модем работает правильно. Для получения дополнительных сведений обратитесь к разделу устранения неполадок при работе с модемом в справочной системе Microsoft Windows.

  • Попробуйте подключиться позже. Узел World Wide Web корпорации Майкрософт может быть недоступен. Если приведенные выше рекомендации не помогают устранить неполадку, и при этом другие Web-узлы доступны, подождите некоторое время и затем попытайтесь подключиться снова.


Разрешение вопросов: помощник

В чем именно заключаются сложности?

Помощник отвлекает от работы

Помощник не находит нужную справку

Не отображается фигурная выноска помощника


Сочетания клавиш

Выберите интересующий вас раздел.

Клавиши для работы на листе

Клавиши для перемещения по листу или в книге, для прокрутки листа.

Клавиши для предварительного просмотра и печати документа.

Клавиши для работы с листами, диаграммами и макросами.

Клавиши для работы с данными

Клавиши для ввода данных.

Клавиши для форматирования данных.

Клавиши для изменения данных.

Клавиши для выделения данных и ячеек.

Клавиши для выделения диаграмм и их элементов.

Клавиши для работы с базами данных и списками.

Клавиши для структурирования данных.

Клавиши для работы с отчетами сводных таблиц и диаграмм.

Клавиши для работы с мастером куба OLAP.

Клавиши для работы в Microsoft Office

Клавиши для работы с меню и панелями инструментов.

Клавиши для работы с окнами документов, диалоговыми окнами и полями ввода.

Клавиши для работы с помощником.

Клавиши для работы с диалоговыми окнами Открыть и Сохранить как.

Клавиши для отправки сообщений по электронной почте.

Клавиши для работы с графическими объектами, автофигурами, объектами WordArt и другими объектами.


Печать списка сочетаний клавиш

  1. Если вкладка Содержание не отображается, нажмите клавиши ALT+С, чтобы открыть ее.

  2. Выберите заголовок Сочетания клавиш, нажмите клавиши ALT+П, а затем клавишу Е.

  3. Выберите Напечатать все содержимое текущего заголовка.

  4. Установите требуемые параметры печати.


Специальные возможности Microsoft Excel для людей с нарушениями подвижности, зрения и слуха

Microsoft Excel включает возможности, облегчающие чтение для слепых и людей с ослабленным зрением, а также ввод текста и данных для людей с ограниченными возможностями письма. См. сведения об использовании специальных возможностей.

Предполагаемые действия

Изменение масштаба отображения и цвета текста

Настройка панелей инструментов и меню

Использование клавиатуры

Автоматизирование процесса ввода и редактирования текста и данных

Изменение масштаба отображения и цвета текста

Увеличение или уменьшение экрана

Увеличение размера кнопок панели инструментов

Прокрутка и масштабирование листа Microsoft Excel с помощью устройства указания Microsoft IntelliMouse

Изменение цветовой палитры, используемой в книге

Изменение шрифта и цветов разделов справки

Настройка панелей инструментов и меню

Создание панели инструментов

Группировка связанных кнопок и меню на панели инструментов

Добавление кнопки на панель инструментов

Добавление команды в меню

Использование клавиатуры

Использование сочетаний клавиш

Печать списка сочетаний клавиш

Автоматизирование процесса ввода и редактирования текста и данных

Исправление в процессе ввода орфографических ошибок и опечаток

Быстрое заполнение повторяющихся записей в столбце


О специальных возможностях для людей с нарушениями подвижности, зрения и слуха

Изменение масштаба отображения и цвета текста

Для облегчения чтения с экрана можно изменить масштаб отображения электронной таблицы. Также можно увеличить размер кнопок панелей инструментов, сделав их более заметными и удобными для использования. При работе с указывающим устройством Microsoft IntelliMouse прокрутку и изменение масштаба можно выполнять непосредственно с этого устройства, не нажимая экранные кнопки. Например, одним щелчком мыши можно выполнить прокрутку к концу документа. Кроме того можно создать пользовательскую палитру цветов, чтобы использовать только определенные цвета.

В разделах справки можно изменять шрифты и цвета.

Настройка панелей инструментов и меню

При использовании только ограниченного набора кнопок и команд панелей инструментов можно создать панель инструментов, содержащую только те кнопки и меню, которые используются чаще всего. Также можно сгруппировать кнопки панели инструментов и команды меню наиболее удобным для себя образом.

Использование сочетаний клавиш

Многие возможности и команды доступны непосредственно с клавиатуры. Кроме того, можно просмотреть и распечатать списки всех доступных сочетаний клавиш.

Автоматизирование процесса ввода и редактирования текста и данных

Microsoft Excel может исправлять распространенные орфографические ошибки и опечатки при вводе, а также по нескольким введенным символам автоматически завершать повторяющиеся записи в столбце.

Настройка операционной системы

Существует возможность установки и изменения специальных возможностей системы. Например, в Windows есть возможность управления указателем мыши с помощью цифровой клавиатуры. Нажмите кнопку Windows Пуск, выберите пункт Настройка, а затем выберите команду Панель управления. Дважды щелкните значок Специальные возможности, перейдите на нужную вкладку, а затем выберите нужные параметры. Для получения справки по конкретному параметру выберите нужный параметр и нажмите клавиши SHIFT+F1.

Дополнительные сведения

При наличии доступа к Интернету можно получить дополнительные сведения об использовании специальных возможностей операционных систем и других продуктов корпорации Майкрософт.


 Клавиши для перехода и прокрутки в пределах листа или книги

Клавиши для перехода и прокрутки в пределах листа или книги

Примечание. Для того чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу В. Для того чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем клавишу Е.

В данном разделе перечислены:

Клавиши для перехода и прокрутки в пределах листа или книги

Клавиши для перехода в пределах листа при включенном режиме «КНЦ»

Клавиши для перехода в пределах листа при включенном режиме «SCROLL LOCK»

Клавиши для перехода и прокрутки в пределах листа или книги

Нажмите | Чтобы
Клавиши со стрелками | Перейти на одну ячейку вверх, вниз, влево или вправо
CTRL+клавиша со стрелкой | Перейти к краю текущей области данных
HOME | Перейти в начало строки
CTRL+HOME | Перейти в начало листа
CTRL+END | Перейти в последнюю ячейку на листе, расположенную на пересечении крайнего справа используемого столбца и самой нижней используемой строки (в левом нижней углу)
PAGE DOWN | Перейти на один экран вниз
PAGE UP | Перейти на один экран вверх
ALT+PAGE DOWN | Перейти на один экран вправо
ALT+PAGE UP | Перейти на один экран влево
CTRL+PAGE DOWN | Перейти на следующий лист книги
CTRL+PAGE UP | Перейти на предыдущий лист книги
CTRL+F6 или CTRL+TAB | Перейти в следующую книгу или окно
CTRL+SHIFT+F6 или CTRL+SHIFT+TAB | Перейти в предыдущую книгу или окно
F6 | Перейти к следующей области в окне книги, разделенном на несколько областей
SHIFT+F6 | Перейти к предыдущей области в окне книги, разделенном на несколько областей
CTRL+BACKSPACE | Прокрутить окно до текущей ячейки
F5 | Отобразить диалоговое окно Переход
SHIFT+F5 | Отобразить диалоговое окно Найти
SHIFT+F4 | Повторить последнее действие Найти (аналогично нажатию кнопки Найти далее)
TAB | Перейти между незащищенными ячейками на защищенном листе

Возврат в начало

Клавиши для перехода в пределах листа при включенном режиме «КНЦ»

Нажмите | Чтобы
END | Включить или выключить режим «КНЦ»
END, клавиша со стрелкой | Переместиться на один блок данных внутри строки или столбца
END, HOME | Перейти в последнюю ячейку на листе, расположенную на пересечении крайнего справа используемого столбца и самой нижней используемой строки (в левом нижней углу)
END, ENTER | Перейти к последней непустой ячейке в текущей строке; это действие недоступно, если на вкладке Переход установлен флажок Клавиши перемещения, использовавшиеся в Lotus 1-2-3 (меню Сервис, команда Параметры)

Возврат в начало

Клавиши для перехода в пределах листа при включенном режиме «SCROLL LOCK»

Нажмите | Чтобы
SCROLL LOCK | Включить или выключить режим SCROLL LOCK
HOME | Перейти к ячейке в левом верхнем углу окна
END | Перейти к ячейке в правом нижнем углу окна
СТРЕЛКА ВВЕРХ или СТРЕЛКА ВНИЗ | Прокрутить окно на одну строку вверх или вниз
СТРЕЛКИ ВПРАВО или ВЛЕВО | Прокрутить окно на один столбец влево или вправо

Возврат в начало

Совет. При использовании клавиш прокрутки (например, PAGE UP и PAGE DOWN) выделение перемещается. Если при прокрутке необходимо сохранять текущее выделение, включите режим SCROLL LOCK.


Клавиши для печати и просмотра документа

Примечание. Чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем — клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем — клавишу С. Чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем — клавишу Е.

Нажмите | Чтобы
CTRL+P или CTRL+SHIFT+F12 | Отобразить диалоговое окно Печать

Клавиши перемещения при предварительном просмотре страниц

Нажмите | Чтобы
Клавиши со стрелками | Перемещаться по странице при просмотре в увеличенном масштабе
PAGE UP или PAGE DOWN | Перейти на одну страницу вперед или назад при просмотре в нормальном масштабе
CTRL+СТРЕЛКА ВВЕРХ или CTRL+СТРЕЛКА ВЛЕВО | Перейти к первой странице при просмотре в нормальном масштабе
CTRL+СТРЕЛКА ВНИЗ или CTRL+СТРЕЛКА ВПРАВО | Перейти к последней странице при просмотре в нормальном масштабе


Клавиши для работы с листами, диаграммами и макросами

Примечание. Для того чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу В. Для того чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем клавишу Е.

Нажмите | Чтобы
SHIFT+F11 или ALT+SHIFT+F1 | Вставить новый лист
F11 или ALT+F1 | Создать диаграмму на основе текущего диапазона
ALT+F8 | Отобразить диалоговое окно Макрос
ALT+F11 | Открыть окно редактора Visual Basic
CTRL+F11 | Вставить лист макроса Microsoft Excel 4.0
CTRL+PAGE DOWN | Перейти на следующий лист книги
CTRL+PAGE UP | Перейти на предыдущий лист книги
SHIFT+CTRL+PAGE DOWN | Выделить текущий и следующий листы книги
SHIFT+CTRL+PAGE UP | Выделить текущий и предыдущий листы книги


 Клавиши для ввода данных

Клавиши для ввода данных

Примечание. Для того чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу В. Для того чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем клавишу Е.

В данном разделе перечислены:

Клавиши для ввода данных на листе

Клавиши для работы с содержимым ячеек или строки формул

Клавиши для ввода данных на листе

Нажмите | Чтобы
ENTER | Завершить ввод в ячейку и перейти ниже по выделенной области
ALT+ENTER | Начать новую строку в текущей ячейке
CTRL+ENTER | Заполнить выделенные ячейки текущим значением
SHIFT+ENTER | Завершить ввод в ячейку и перейти вверх по выделенной области
TAB | Завершить ввод в ячейку и перейти вправо по выделенной области
SHIFT+TAB | Завершить ввод в ячейку и перейти влево по выделенной области
ESC | Отменить ввод в ячейку
BACKSPACE | Удалить выделенный фрагмент или символ слева от курсора
DELETE | Удалить выделенный фрагмент или символ справа от курсора
CTRL+DELETE | Удалить текст до конца строки
Клавиши со стрелками | Переместить курсор на один символ вверх, вниз, влево или вправо
HOME | Перейти в начало строки
F4 или CTRL+Y | Повторить последнее действие
SHIFT+F2 | Перейти к правке примечания ячейки
CTRL+SHIFT+F3 | Создать имена из подписей строки и столбца
CTRL+D | Заполнить вниз
CTRL+R | Заполнить вправо
CTRL+F3 | Присвоить имя

Возврат в начало

Клавиши для работы с содержимым ячеек или строки формул

Нажмите | Чтобы
BACKSPACE | Войти в активную ячейку для редактирования и очистить ее либо, при редактировании содержимого активной ячейки, удалить символ слева от курсора
ENTER | Завершить ввод в ячейку
CTRL+SHIFT+ENTER | Ввести формулу как формулу массива
ESC | Отменить ввод в ячейку или строку формул
CTRL+A | После ввода имени функции в формулу отобразить панель формул
CTRL+SHIFT+A | Вставить имена аргументов функции и скобки после ввода имени функции
CTRL+K | Вставить гиперссылку
ENTER (в ячейке гиперссылки) | Активизировать гиперссылку
F2 | Открыть активную ячейку для редактирования и поместить курсор в конец строки
F3 | Вставить в формулу определенное имя
SHIFT+F3 | Вставить функцию в формулу
F9 | Вычислить все листы всех открытых книг
CTRL+ALT+F9 | Вычислить все листы в активной книге
SHIFT+F9 | Вычислить текущий лист
= (знак равенства) | Начать запись формулы
ALT+= (знак равенства) | Вставить формулу автосуммы
CTRL+; (точка с запятой) | Ввести текущую дату
CTRL+SHIFT+: (двоеточие) | Ввести текущее время
CTRL+SHIFT+" (двойная кавычка) | Скопировать содержимое верхней ячейки в текущую ячейку или в строку формул
CTRL+` (знак левой кавычки) | Переключить режимы отображения значения ячейки и формулы ячейки
CTRL+' (апостроф) | Скопировать формулу верхней ячейки в текущую ячейку или в строку формул
ALT+СТРЕЛКА ВНИЗ | Отобразить список автоввода

Возврат в начало


Клавиши для форматирования данных

Примечание. Для того чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу В. Для того чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем клавишу Е.

Нажмите | Чтобы
ALT+' (апостроф) | Отобразить диалоговое окно Стиль
CTRL+1 | Отобразить диалоговое окно Формат ячеек
CTRL+SHIFT+~ | Применить общий числовой формат
CTRL+SHIFT+$ | Применить денежный формат с двумя десятичными знаками (отрицательные числа отображаются в круглых скобках)
CTRL+SHIFT+% | Применить процентный формат с отсутствующей дробной частью
CTRL+SHIFT+^ | Применить экспоненциальный числовой формат с двумя десятичными знаками
CTRL+SHIFT+# | Применить формат дат с указанием дня, месяца и года
CTRL+SHIFT+@ | Применить формат времени с отображением часов и минут и индексами A.M. или P.M.
CTRL+SHIFT+! | Применить числовой формат с двумя десятичными знаками, разделителем групп разрядов и знаком минус (–) для отрицательных значений
CTRL+SHIFT+& | Вставить рамку структуры
CTRL+SHIFT+_ | Удалить границы рамки
CTRL+B | Применить или удалить полужирное начертание
CTRL+I | Применить или удалить курсивное начертание
CTRL+U | Применить или удалить подчеркивание
CTRL+5 | Перечеркнуть текст или удалить линию перечеркивания
CTRL+9 | Скрыть строки
CTRL+SHIFT+( (открывающая скобка) | Показать строки
CTRL+0 (нуль) | Скрыть столбцы
CTRL+SHIFT+) (закрывающая скобка) | Показать столбцы


 Клавиши для редактирования данных

Клавиши для редактирования данных

Примечание. Для того чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу В. Для того чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем клавишу Е.

В данном разделе перечислены:

Клавиши для редактирования данных

Клавиши для вставки, удаления и копирования выделенной области

Клавиши для перемещения в пределах выделенной области

Клавиши для редактирования данных

Нажмите | Чтобы
F2 | Открыть активную ячейку для редактирования и поместить курсор в конец строки
ESC | Отменить результаты правки ячейки или строки формул
BACKSPACE | Очистить строку формул после указания ячейки или удалить в строке формул символ слева от курсора
F3 | Вставить в формулу определенное имя
ENTER | Завершить правку ячейки
CTRL+SHIFT+ENTER | Ввести формулу как формулу массива
CTRL+A | После ввода имени функции в формулу отобразить панель формул
CTRL+SHIFT+A | Вставить в круглых скобках список аргументов, после набора в формуле имени функции
F7 | Отобразить диалоговое окно Проверка орфографии

Возврат в начало

Клавиши для вставки, удаления и копирования выделенной области

Нажмите | Чтобы
CTRL+С | Скопировать выделенную область
CTRL+Ч | Вырезать выделенную область
CTRL+М | Вставить выделенную область
DELETE | Очистить выделенную область
CTRL+ДЕФИС | Удалить выделенную область
CTRL+Z | Отменить последнее действие
CTRL+SHIFT+ЗНАК ПЛЮС | Вставить пустые ячейки

Возврат в начало

Клавиши для перемещения в пределах выделенной области

Нажмите | Чтобы
ENTER | Перейти от начала к концу выделенной области (вниз) или перейти в направлении, выбранном на вкладке Правка (меню Сервис, команда Параметры)
SHIFT+ENTER | Перейти от конца к началу выделенной области (вверх) или в направлении, противоположном выбранному на вкладке Правка (меню Сервис, команда Параметры)
TAB | Перейти слева направо в пределах выделенной области или вниз на одну ячейку, если выделен только один столбец
SHIFT+TAB | Перейти справа налево в пределах выделенной области или вверх на одну ячейку, если выделен только один столбец
CTRL+ТОЧКА | Перейти к следующему углу выделенной области по часовой стрелке
CTRL+ALT+СТРЕЛКА ВПРАВО | Перейти вправо к следующей несмежной выделенной области
CTRL+ALT+СТРЕЛКА ВЛЕВО | Перейти влево к следующей несмежной выделенной области

Возврат в начало


 Клавиши для выделения данных и ячеек

Клавиши для выделения данных и ячеек

Примечание. Если необходимо увеличить размер окна справки до размера экрана, нажмите клавиши ALT + ПРОБЕЛ, затем — клавишу X. Для возврата к исходным размеру и положению окна справки, нажмите клавиши ALT + ПРОБЕЛ, затем — клавишу R. Чтобы распечатать этот раздел справки, нажмите клавиши ALT + O, затем — клавишу P.

Содержание раздела:

Клавиши для выделения ячеек, столбцов и строк.

Клавиши для расширения выделения в режиме КНЦ.

Клавиши для выделения ячеек с особыми атрибутами.

Клавиши для выделения ячеек, столбцов и строк

Нажмите | Чтобы
CTRL+SHIFT+* (звездочка) | Выделить текущую область вокруг активной ячейки. Текущей областью называется диапазон ячеек, ограниченный пустыми столбцами и строками.
SHIFT + клавиша со стрелкой | Расширить выделенную область на одну ячейку.
CTRL+SHIFT+клавиша со стрелкой | Расширить выделенную область до последней непустой ячейки строки или столбца, содержащих активную ячейку.
SHIFT+HOME | Расширить выделенную область до начала строки.
CTRL+SHIFT+HOME | Расширить выделенную область до начала листа.
CTRL+SHIFT+END | Расширить выделенную область до последней ячейки листа (нижний правый угол).
CTRL+ПРОБЕЛ | Выделить столбец целиком.
SHIFT+ПРОБЕЛ | Выделить строку целиком.
CTRL+Ф | Выделить лист целиком.
SHIFT+BACKSPACE | Выделить только активную ячейку, сняв выделение остальных ячеек.
SHIFT+PAGE DOWN | Расширить выделенную область на один экран вниз.
SHIFT+PAGE UP | Расширить выделенную область на один экран вверх.
CTRL+SHIFT+ПРОБЕЛ | Оставаясь на текущем объекте, выделить все объекты листа.
CTRL+6 | Переключить режимы скрытия объектов, отображения объектов и отображения контуров объектов.
CTRL+7 | Отобразить или скрыть стандартную панель инструментов.
F8 | Разрешить расширение выделения клавишами со стрелками.
SHIFT+F8 | Добавить к выделенному еще один диапазон ячеек; либо перейти с помощью клавиш со стрелками к началу добавляемого диапазона, затем нажать клавишу F8 и выделить клавишами со стрелками следующий диапазон.
SCROLL LOCK, SHIFT+HOME | Расширить выделенную область до ячейки в верхнем левом углу окна.
SCROLL LOCK, SHIFT+END | Расширить выделенную область до ячейки в нижнем правом углу окна.

Возврат в начало.

Совет. При нажатии клавиш прокрутки (например, PAGE UP и PAGE DOWN) и отключенном индикаторе SCROLL LOCK, выделение перемещается на расстояние, эквивалентное прокрутке. Если при прокрутке необходимо сохранять выделение на прежнем месте, с помощью клавиши SCROLL LOCK включите ее индикатор.

Клавиши для расширения выделения

Нажмите | Чтобы
END | Включить или отключить режим КНЦ.
END, SHIFT+клавиша со стрелкой | Расширить выделенную область до последней непустой ячейки строки или столбца, содержащих активную ячейку.
END, SHIFT+HOME | Расширить выделенную область до последней ячейки листа (нижнего правого угла).
END, SHIFT+ENTER | Расширить выделение до последней ячейки текущей строки. Это сочетание клавиш не работает, если установлен флажок Клавиши перемещения, использовавшиеся в Lotus 1-2-3 на вкладке Переход (меню Сервис, команда Параметры).

Возврат в начало.

Клавиши для выделения ячеек с особыми атрибутами

Нажмите | Чтобы
CTRL+SHIFT+* (звездочка) | Выделить текущую область вокруг активной ячейки. Текущей областью называется диапазон ячеек, ограниченный пустыми столбцами и строками.
CTRL+/ | Выделите текущий массив. Текущим массивом называется массив, к которому принадлежит активная ячейка.
CTRL+SHIFT+O (буква O) | Выделить все ячейки вместе с примечаниями.
CTRL+\ | Выделить в строке ячейки, не соответствующие значению в активной ячейке.
CTRL+SHIFT+| | Выделить в столбце ячейки, не соответствующие значению в активной ячейке.
CTRL+[ (открывающая прямоугольная скобка) | Выделить ячейки, на которые прямо ссылаются формулы, содержащиеся в выделенной области.
CTRL+SHIFT+{ (открывающая фигурная скобка) | Выделить ячейки, на которые прямо или косвенно ссылаются формулы, содержащиеся в выделенной области.
CTRL+] (закрывающая прямоугольная скобка) | Выделить ячейки, формулы которых прямо ссылаются на активную ячейку.
CTRL+SHIFT+} (закрывающая фигурная скобка) | Выделить все ячейки, формулы которых прямо или косвенно ссылаются на активную ячейку.
ALT+; (точка с запятой) | Выделить только видимые ячейки текущей выделенной области.

Возврат в начало.


 Клавиши для выделения диаграмм и элементов диаграмм

Клавиши для выделения диаграмм и элементов диаграмм

Клавиши для выбора листа диаграммы

Нажмите | Чтобы
CTRL+PAGE DOWN | Перейти на следующий лист книги. Нажимайте до тех пор, пока не дойдете до листа нужной диаграммы.
CTRL+PAGE UP | Перейти на предыдущий лист книги. Нажимайте до тех пор, пока не дойдете до листа нужной диаграммы.

Клавиши для выбора внедренных диаграмм

Примечание. Панель инструментов Рисование должна все время отображаться.

  1. Нажмите клавишу F10, чтобы активизировать строку меню.

  2. С помощью клавиш CTRL+TAB или CTRL+SHIFT+TAB выберите панель инструментов Рисование.

  3. С помощью клавиши СТРЕЛКА ВПРАВО выделите кнопку Выбор объектов [image] на панели инструментов Рисование.

  4. Нажмите клавиши CTRL+ENTER, чтобы выделить первый объект.

  5. Нажмите клавишу TAB для перемещения по объектам в прямом порядке (или клавиши SHIFT+TAB для перемещения в обратном порядке) до появления маркеров изменения размера на внедренной диаграмме, которую требуется выделить.

  6. Нажмите клавиши CTRL+ENTER, чтобы активизировать диаграмму.

Клавиши для выделения элементов диаграмм

Нажмите | Чтобы
СТРЕЛКА ВНИЗ | Выделить предыдущую группу элементов
СТРЕЛКА ВВЕРХ | Выделить следующую группу элементов
СТРЕЛКА ВПРАВО | Выделить следующий элемент в группе
СТРЕЛКА ВЛЕВО | Выделить предыдущий элемент в группе

Существуют также клавиши для использования в отчетах сводных диаграмм.


Клавиши для работы с базами данных и списками

Примечание. Для того чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу В. Для того чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем клавишу Е.

В данном разделе перечислены:

Клавиши для работы с формами данных

Клавиши для работы с автофильтром

Клавиши для работы с формами данных

Нажмите | Чтобы
ALT+ клавиша; где клавиша — подчеркнутый символ имени поля или команды | Выбрать поле или кнопку
СТРЕЛКА ВНИЗ | Перейти к тому же полю следующей записи
СТРЕЛКА ВВЕРХ | Перейти к тому же полю предыдущей записи
TAB | Перейти к следующему полю следующей записи
SHIFT+TAB | Перейти к предыдущему полю следующей записи
ENTER | Перейти к первому полю текущей записи
SHIFT+ENTER | Перейти к первому полю предыдущей записи
PAGE DOWN | Перейти к тому же полю на 10 записей вперед
CTRL+PAGE DOWN | Перейти к новой записи
PAGE UP | Перейти к тому же полю на 10 записей назад
CTRL+PAGE UP | Перейти к первой записи
Клавиши HOME или END | Перейти в начало или в конец текущего поля
SHIFT+END | Выделить символы от текущей позиции до конца поля
SHIFT+HOME | Выделить символы от текущей позиции до начала поля
СТРЕЛКИ ВПРАВО или ВЛЕВО | Перейти на один символ влево или вправо в текущем поле
SHIFT+СТРЕЛКА ВЛЕВО | Выделить символ слева от текущей позиции
SHIFT+СТРЕЛКА ВПРАВО | Выделить символ справа от текущей позиции

Возврат в начало

Клавиши для работы с автофильтром

Нажмите | Чтобы
Клавиши со стрелками для выбора ячейки, содержащей поле, а затем — ALT+СТРЕЛКА ВНИЗ | Раскрыть список текущего заголовка столбца
СТРЕЛКА ВНИЗ | Перейти к следующему элементу списка
СТРЕЛКА ВВЕРХ | Перейти к предыдущему элементу списка
ALT+СТРЕЛКА ВВЕРХ | Закрыть список текущего заголовка столбца
HOME | Перейти к первому элементу списка (Все)
END | Перейти к последнему элементу списка (“Непустые”)
ENTER | Отфильтровать список

Возврат в начало


Клавиши для структурирования данных

Примечание. Для того чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу В. Для того чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем клавишу Е.

Нажмите | Чтобы
ALT+SHIFT+СТРЕЛКА ВПРАВО | Сгруппировать строки или столбцы
ALT+SHIFT+СТРЕЛКА ВЛЕВО | Разгруппировать строки или столбцы
CTRL+8 | Отобразить или скрыть символы структуры
CTRL+9 | Скрыть выделенные строки
CTRL+SHIFT+( (открывающая скобка) | Показать выделенные строки
CTRL+0 (нуль) | Скрыть выделенные столбцы
CTRL+SHIFT+) (закрывающая скобка) | Показать выделенные столбцы


 Клавиши для использования в отчетах сводных таблиц и сводных диаграмм

Клавиши для использования в отчетах сводных таблиц и сводных диаграмм

Примечание. Для того чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем клавишу В. Для того чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем клавишу Е.

В данном разделе перечислены:

Клавиши для мастера сводных таблиц и сводных диаграмм

Клавиши для работы с полями страниц в отчете сводной таблицы или сводной диаграммы

Клавиши для работы с макетом отчета сводной таблицы или сводной диаграммы

Клавиши для группирования и разгруппирования элементов сводной таблицы

Клавиши для мастера сводных таблиц и сводных диаграмм

Нажмите | Чтобы
СТРЕЛКА ВВЕРХ или СТРЕЛКА ВНИЗ | Перейти к предыдущей или следующей кнопке в списке
СТРЕЛКИ ВПРАВО или ВЛЕВО | Перейти в левый или правый столбец в многостолбцовом списке кнопок полей
ALT+Л | Переместить выбранное поле в область полей столбца
ALT+А | Переместить выбранное поле в область данных
ALT+L | Вывести на экран диалоговое окно Вычисление поля сводной таблицы
ALT+P | Переместить выбранное поле в область полей страницы
ALT+Т | Переместить выбранное поле в область полей строки

Возврат в начало

Клавиши для работы с полями страниц в отчете сводной таблицы или сводной диаграммы

Нажмите | Чтобы
CTRL+SHIFT+* (звездочка) | Выделить весь отчет сводной таблицы
Клавиши со стрелками для выбора ячейки, содержащей поле, а затем — ALT+СТРЕЛКА ВНИЗ | Отобразить список для текущего поля отчета сводной таблицы
Клавиши со стрелками для выбора поля страницы в отчете сводной диаграммы, а затем — ALT+СТРЕЛКА ВНИЗ | Отобразить список для текущего поля страницы в отчете сводной диаграммы
СТРЕЛКА ВВЕРХ | Перейти к предыдущему элементу списка
СТРЕЛКА ВНИЗ | Перейти к следующему элементу списка
HOME | Перейти к первому элементу списка
END | Перейти к последнему элементу списка
ENTER | Выбрать текущий элемент
ПРОБЕЛ | Установить или снять флажок в списке

Возврат в начало

Клавиши для работы с макетом отчета сводной таблицы или сводной диаграммы

  1. Нажмите клавишу F10, чтобы активизировать строку меню.

  2. С помощью клавиш CTRL+TAB или CTRL+SHIFT+TAB выберите панель инструментов Сводная таблица.

  3. Клавиши СТРЕЛКА ВЛЕВО или СТРЕЛКА ВПРАВО используются для выбора меню слева или справа либо, при открытом подменю, для переключения между основным меню и подменю.

  4. Нажав клавишу ENTER (на кнопке поля), можно с помощью клавиш СТРЕЛКА ВНИЗ и СТРЕЛКА ВВЕРХ выбрать область, в которую требуется переместить выбранное поле.

Примечание. Для прокрутки вниз или вверх по списку полей нажмите клавишу ENTER на кнопке Другие поля Стрелка вверх или Стрелка вниз .

Возврат в начало

Клавиши для группирования и разгруппирования элементов сводной таблицы

Нажмите | Чтобы
ALT+SHIFT+СТРЕЛКА ВПРАВО | Сгруппировать выделенные элементы сводной таблицы
ALT+SHIFT+СТРЕЛКА ВЛЕВО | Разгруппировать выделенные элементы сводной таблицы

Возврат в начало


Клавиши для использования в мастере куба OLAP

Следующие клавиши используются на втором шаге выполнения мастера.

Перемещение поля из списка «Исходные поля» в поле «Размерности»

  1. С помощью клавиши TAB перейдите в список Исходные поля.

  2. С помощью клавиш СТРЕЛКА ВВЕРХ и СТРЕЛКА ВНИЗ выделите поле, которое требуется переместить.

    Поскольку изменить порядок полей после их перемещения невозможно, выберите сначала поле, которое должно отображаться в верхней части поля Размерности.

  3. С помощью клавиши TAB выделите кнопку > и нажмите клавишу ENTER.

  4. Для перемещения других полей повторите шаги с 1 по 3.

Изменение уровня поля в поле «Размерности»

  1. С помощью клавиши TAB перейдите в поле Размерности.

  2. С помощью клавиш СТРЕЛКА ВВЕРХ и СТРЕЛКА ВНИЗ выделите поле, которое требуется переместить.

  3. Нажмите клавиши CTRL+X.

  4. С помощью клавиш СТРЕЛКА ВВЕРХ и СТРЕЛКА ВНИЗ выберите место, куда требуется переместить поле.

  5. Нажмите клавиши CTRL+V.


 Клавиши для работы с меню и панелями инструментов

Клавиши для работы с меню и панелями инструментов

Примечание. Чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем — клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем — клавишу С. Чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем — клавишу Е.

Нажмите | Чтобы
F10 или ALT | Активизировать строку меню или закрыть открытое меню (вместе с подменю, если оно открыто)
TAB или SHIFT+TAB (при активизации панели инструментов или строки меню) | Выбрать следующую или предыдущую кнопку или меню на панели инструментов
CTRL+TAB или CTRL+SHIFT+TAB (при активизации панели инструментов или строки меню) | Выбрать следующую или предыдущую панель инструментов
ENTER | Открыть выделенное меню или выполнить действие, связанное с выделенной кнопкой
SHIFT+F10 | Отобразить контекстное меню
ALT+ПРОБЕЛ | Вывести меню окна программы (значок, расположенный в строке заголовка программы)
СТРЕЛКИ ВВЕРХ И ВНИЗ, если меню или подменю выведено на экран | Выбрать следующую или предыдущую команду в меню или подменю
СТРЕЛКИ ВПРАВО или ВЛЕВО | Выбрать меню справа или слева, либо при выведенном на экран подменю перейти от главного меню к подменю и обратно
Клавиши HOME или END | Выбрать первую или последнюю команду меню или подменю
ESC | Закрыть открытое меню или, если на экран выведено подменю, закрыть только подменю
CTRL+СТРЕЛКА ВНИЗ | Отобразить полный набор команд выбранного меню

Совет. С помощью клавиатуры можно выбрать любую команду в строке меню или на видимой панели инструментов. Для выбора строки меню следует нажать клавишу ALT. (Для последующего выбора панели инструментов нужно нажимать клавиши CTRL+TAB до тех пор, пока не будет выбрана нужная панель.) Чтобы открыть меню, содержащее нужную команду, следует нажать букву, которая подчеркнута в названии меню. Чтобы выбрать команду, следует нажать букву, подчеркнутую в имени нужной команды.


Клавиши для работы с окнами документов, диалоговыми окнами и полями ввода

Примечание. Чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем — клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем — клавишу С. Чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем — клавишу Е.

В данном разделе приведены следующие сочетания клавиш:

Клавиши для работы с окнами документов

Клавиши для работы с диалоговыми окнами

Клавиши для работы с полями ввода в диалоговых окнах

Клавиши для работы с окнами документов

Находясь в окне документа, нажмите клавиши | Чтобы
ALT+TAB | Переключиться на следующую программу
ALT+SHIFT+TAB | Переключиться на предыдущую программу
CTRL+ESC | Отобразить меню Пуск Windows
CTRL+W или CTRL+F4 | Закрыть окно активной книги
CTRL+F5 | Восстановить размеры окна активной книги
F6 | Перейти к следующей области в окне книги, разделенном на несколько областей
SHIFT+F6 | Перейти к предыдущей области в окне книги, разделенном на несколько областей
CTRL+F6 | Перейти к следующей книге
CTRL+SHIFT+F6 | Перейти к предыдущей книге
CTRL+F7 | Выполнить команду Переместить (меню окна книги, строка меню) для перемещения окна с помощью клавиш со стрелками
CTRL+F8 | Выполнить команду Размер (меню окна книги, строка меню) для изменения размеров окна с помощью клавиш со стрелками
CTRL+F9 | Свернуть окно книги в значок
CTRL+F10 | Развернуть или восстановить окно книги
PRINT SCREEN | Скопировать изображение экрана в буфер обмена
ALT+PRINT SCREEN | Скопировать изображение активного окна экрана в буфер обмена

Возврат в начало

Клавиши для работы с диалоговыми окнами

В диалоговом окне нажмите клавиши | Чтобы
TAB | Перейти к следующему параметру или группе параметров
SHIFT+TAB | Перейти к предыдущему параметру или группе параметров
CTRL+TAB или CTRL+PAGE DOWN | Переключиться на следующую вкладку в диалоговом окне
CTRL+SHIFT+TAB или CTRL+PAGE UP | Переключиться на предыдущую вкладку в диалоговом окне
Клавиши со стрелками | Перейти к следующему или предыдущему параметру в выбранном раскрывающемся списке или в группе параметров
ПРОБЕЛ | Выполнить действие, связанное с активной кнопкой (кнопка, выделенная пунктирной рамкой), или установить или снять активный флажок
Клавишу с буквой, соответствующей первой букве названия требуемого параметра (при выборе раскрывающегося списка) | Перейти к соответствующему параметру в раскрывающемся списке
ALT+буква, где буква — клавиша, соответствующая подчеркнутой букве в названии параметра | Выбрать параметр, или установить или снять флажок
ALT+СТРЕЛКА ВНИЗ | Открыть выбранный раскрывающийся список
ENTER | Выполнить действие, связанное с основной кнопкой в диалоговом окне (кнопка с выделенной границей — часто кнопка OK)
ESC | Отменить команду и закрыть диалоговое окно

Возврат в начало

Клавиши для работы с полями ввода в диалоговых окнах

В поле ввода диалогового окна нажмите клавиши | Чтобы
HOME | Перейти к началу вводимой строки
END | Перейти в конец вводимой строки
СТРЕЛКИ ВПРАВО или ВЛЕВО | Переместить курсор на один символ влево или вправо
CTRL+СТРЕЛКА ВЛЕВО | Перейти на одно слово влево
CTRL+СТРЕЛКА ВПРАВО | Перейти на одно слово вправо
SHIFT+СТРЕЛКА ВЛЕВО | Выделить один символ слева от курсора или снять выделение
SHIFT+СТРЕЛКА ВПРАВО | Выделить один символ справа от курсора или снять выделение
CTRL+SHIFT+СТРЕЛКА ВЛЕВО | Выделить одно слово слева от курсора или снять выделение
CTRL+SHIFT+СТРЕЛКА ВПРАВО | Выделить одно слово справа от курсора или снять выделение
SHIFT+HOME | Выделить символы, начиная от текущей позиции курсора до начала строки
SHIFT+END | Выделить символы, начиная от текущей позиции курсора до конца строки

Возврат в начало


 Клавиши для работы с диалоговыми окнами «Открытие документа» и «Сохранение документа»

Клавиши для работы с диалоговыми окнами «Открытие документа» и «Сохранение документа»

Примечание. Чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем — клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем — клавишу В. Чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем — клавишу Е.

Нажмите | Чтобы
CTRL+F12 или CTRL+O | Отобразить диалоговое окно Открытие документа
ALT+F2, F12 или CTRL+S | Сохранить активную книгу
ALT+SHIFT+F2 или SHIFT+F12 | Отобразить диалоговое окно Сохранить как
ALT+1 | Перейти к предыдущей папке ( [image] )
ALT+2 | Открыть папку, находящуюся на один уровень выше текущей папки (кнопка Переход на один уровень вверх [image] )
ALT+3 | Закрыть диалоговое окно и открыть страницу поиска World Wide Web (кнопка Найти в Web [image] )
ALT+4 | Удалить выбранную папку или файл (кнопка Удалить [image] )
ALT+5 | Создать новую подпапку в открытой папке (кнопка Создать папку [image] )
ALT+6 | Переключиться между различными представлениями списка файлов
ALT+7 | Вывести меню Сервис (кнопка Сервис)


Использование клавиатуры при отправке сообщений электронной почты

Для использования при отправке сообщений электронной почты приведенных ниже сочетаний клавиш необходимо установить Microsoft Outlook в качестве почтовой программы по умолчанию. Если почтовой программой по умолчанию является Outlook Express, использовать большинство из этих сочетаний клавиш нельзя.

Примечание. Чтобы развернуть окно справки на весь экран, нажмите клавиши ALT+ПРОБЕЛ, а затем — клавишу Р. Для восстановления размеров окна нажмите клавиши ALT+ПРОБЕЛ, а затем — клавишу С. Чтобы напечатать этот раздел справки, нажмите клавиши ALT+П, а затем — клавишу Е.

Нажмите | Чтобы
SHIFT+TAB | Перейти к заголовку сообщения электронной почты. При нажатии этих клавиш активной должна быт ячейка A1.
ALT+S | Отправить активную таблицу в качестве сообщения электронной почты
CTRL+SHIFT+B | Открыть адресную книгу
ALT+K | Проверить по адресной книге имена в полях Кому, Копия и СК
ALT+ПРОБЕЛ | Открыть адресную книгу в поле Кому
ALT+С | Открыть адресную книгу в поле Копия
ALT+B | Открыть адресную книгу в поле СК
ALT+J | Перейти к полю Тема
ALT+P | Открыть диалоговое окно Параметры сообщения Microsoft Outlook (меню Вид, команда Параметры в окне сообщения)
CTRL+SHIFT+G | Отметить сообщение


Использование клавиатуры для работы с графическими объектами, объектами WordArt, автофигурами и другими объектами

Добавление графических объектов

Добавление автофигуры

Добавление надписи

Добавление объекта WordArt

Выделение графических объектов

Выделение графических объектов

Изменение графических объектов

Поворот графического объекта

Изменение размеров графического объекта

Копирование атрибутов размеров графического объекта


Добавление автофигуры с помощью клавиатуры

  1. Нажмите клавиши ALT+Г, чтобы выделить меню Автофигуры на панели инструментов Рисование.

  2. С помощью клавиш перемещения курсора перейдите к требуемой категории автофигур, а затем нажмите клавишу СТРЕЛКА ВПРАВО.

  3. С помощью клавиш перемещения курсора выберите требуемую автофигуру.

  4. Нажмите клавиши CTRL+ENTER.

Примечание. Для изменения автофигуры выделите автофигуру, а затем, используя клавиатуру, выберите команду Автофигура в меню Формат. Установите требуемые параметры на соответствующих вкладках.


 Добавление надписи с помощью клавиатуры

Добавление надписи с помощью клавиатуры

  1. Используя клавиатуру, выделите кнопку Надпись [image] на панели инструментов Рисование.

  2. Нажмите клавиши CTRL+ENTER.

  3. Введите требуемый текст надписи.

  4. По окончании ввода текста для возврата на лист дважды нажмите клавишу ESC.

Примечание. Для форматирования надписи (например, добавления заливки или изменения размера) выделите надпись, выберите команду Надпись в меню Формат, а затем установите требуемые параметры на соответствующих вкладках.


Добавление объекта WordArt с помощью клавиатуры

  1. Используя клавиатуру, выберите команду Объект WordArt (меню Вставка, подменю Рисунок).

  2. С помощью клавиш перемещения курсора выберите нужный стиль надписи WordArt, а затем нажмите клавишу ENTER.

  3. Введите текст надписи, а затем с помощью клавиши TAB выделите и установите требуемые параметры текста в диалоговом окне.

  4. Нажмите клавишу ENTER, чтобы вставить объект WordArt.

Примечание. Для изменения объекта WordArt выделите объект, выберите команду Объект WordArt в меню Формат, а затем установите требуемые параметры на соответствующих вкладках.


 Выделение графических объектов с помощью клавиатуры

Выделение графических объектов с помощью клавиатуры

Если точка ввода находится на листе, выполните следующие действия.

  1. Нажмите клавишу F10, чтобы активизировать строку меню.

  2. Нажмите клавиши CTRL+TAB, чтобы выбрать панель инструментов Рисование.

  3. Нажмите клавишу СТРЕЛКА ВПРАВО, чтобы выделить кнопку Выбор объектов [image] на панели инструментов Рисование.

  4. Нажмите клавиши CTRL+ENTER, чтобы выделить первый графический объект.

  5. Нажмите клавишу TAB для перемещения по объектам в прямом порядке (или клавиши SHIFT+TAB для перемещения в обратном порядке) до появления маркеров изменения размера на объекте, который требуется выделить.

Если точка ввода находится в тексте на графическом объекте, выполните следующие действия.

  • Нажмите клавишу TAB для перемещения по объектам в прямом порядке (или клавиши SHIFT+TAB для перемещения в обратном порядке) до появления маркеров изменения размера на объекте, который требуется выделить.

Примечание. Для переключения из режима выделения объектов к работе в ячейках нажмите клавишу ESC.


Поворот графического объекта с помощью клавиатуры

  1. Используя клавиатуру, выделите графический объект, который требуется повернуть.

  2. В меню Формат выберите команду, соответствующую типу выделенного объекта — например, Автофигура или Надпись, — а затем откройте вкладку Размер.

  3. В поле «Поворот» введите требуемый угол поворота.


Изменение размеров графического объекта с помощью клавиатуры

  1. Используя клавиатуру, выделите графический объект, размеры которого требуется изменить.

  2. В меню Формат выберите команду, соответствующую типу выделенного объекта — например, Автофигура или Надпись, — а затем откройте вкладку Размер.

    Установите требуемые параметры. Для получения справки по параметру выделите его и затем нажмите клавиши SHIFT+F1.


Копирование атрибутов графического объекта с помощью клавиатуры

  1. Используя клавиатуру, выделите графический объект, атрибуты которого требуется скопировать.

    При выборе автофигуры с добавленным к ней текстом вместе с атрибутами автофигуры копируются также атрибуты (вид и стиль) шрифта.

  2. Нажмите клавиши CTRL+SHIFT+C, чтобы скопировать атрибуты объекта.

  3. Чтобы выделить объект, которому требуется присвоить скопированные атрибуты, нажмите клавиши TAB или SHIFT+TAB.

  4. Нажмите клавиши CTRL+SHIFT+V, чтобы присвоить скопированные атрибуты выделенному объекту.


Эквиваленты в Microsoft Excel для назначений клавиш в Lotus 1-2-3

Примечание. Чтобы развернуть окно справки на весь экран, нажмите кнопку Развернуть [image] в строке заголовка справки. Чтобы вернуть окно к предыдущему размеру и положению, нажмите Восстановить [image]. Чтобы распечатать этот раздел, нажмите, Печать [image] на панели инструментов Справка.

В приведенной ниже таблице перечислены стандартные сочетания клавиш Microsoft Excel, эквивалентные командам Lotus 1-2-3.

Эквиваленты функциональных клавиш

Lotus 1-2-3 | Excel
F1 (Справка) | F1
F2 (Редактирование) | F2
F3 (Имя) | F3
F4 (Абсолютные/относительные ссылки) | F4
F5 (Переход) | F5
F6 (следующее окно) | CTRL+F6
F7 (Запрос) | Для поиска строк в списке воспользуйтесь командой Автофильтр (меню Сервис). Для создания списка автофильтра воспользуйтесь клавишами ALT, Д, Ф, Ф. Чтобы выбрать значение из списка автофильтра, укажите ячейку, содержащую имя столбца, и нажмите клавиши ALT+СТРЕЛКА ВНИЗ.
F8 (Таблица) | Если переключатель на вкладке Вычисления (меню Сервис, команда Параметры) не установлен в положение Автоматически кроме таблиц, таблицы пересчитываются автоматически.
F9 (Вычисление) | F9
F10 (Диаграмма) | F11 или ALT+F1

Клавиши перемещения

Используйте клавиши Excel, если не установлено преобразование клавиш перемещения.

Lotus 1-2-3 | Excel
СТРЕЛКА ВВЕРХ, СТРЕЛКА ВНИЗ | СТРЕЛКА ВВЕРХ, СТРЕЛКА ВНИЗ
СТРЕЛКА ВЛЕВО, СТРЕЛКА ВПРАВО | СТРЕЛКА ВЛЕВО, СТРЕЛКА ВПРАВО
End, СТРЕЛКА ВВЕРХ | CTRL+СТРЕЛКА ВВЕРХ или END+СТРЕЛКА ВВЕРХ
End, СТРЕЛКА ВНИЗ | CTRL+СТРЕЛКА ВНИЗ или END+СТРЕЛКА ВНИЗ
End, СТРЕЛКА ВЛЕВО | CTRL+СТРЕЛКА ВЛЕВО или END+СТРЕЛКА ВЛЕВО
End, СТРЕЛКА ВПРАВО | CTRL+СТРЕЛКА ВПРАВО или END+СТРЕЛКА ВПРАВО
Home | CTRL+HOME
Tab | CTRL+PAGE DOWN
Shift+Tab | CTRL+PAGE UP
PgUp, PgDn | PAGE UP или PAGE DOWN


Клавиши перемещения, использовавшиеся в Lotus 1-2-3

Примечание. Если необходимо увеличить размеры окна справки до размеров экрана, щелкните кнопку Развернуть [image] на строке названия. Для возвращения прежних размеров и положения окна, щелкните кнопку Восстановить [image]. Чтобы напечатать этот раздел справки, щелкните кнопку Печать [image] на панели инструментов справки.

Можно изменить назначения клавиш в Microsoft Excel на эквивалентные команды Lotus 1-2-3. При нажатии нижеперечисленных клавиш будут выполняться указанные действия, если на вкладке Переход (меню Сервис, команда Параметры) установлен флажок Клавиши перемещения, использовавшиеся в Lotus 1-2-3.

Клавиши перемещения

Нажмите | Чтобы перейти
SHIFT+TAB или CTRL+СТРЕЛКА ВЛЕВО | На один экран влево.
TAB или CTRL+СТРЕЛКА ВПРАВО | На один экран вправо.
CTRL+PAGE DOWN | На следующий лист книги.
CTRL+PAGE UP | На предыдущий лист книги.
HOME | К левой верхней ячейке листа.

Префиксы для выравнивания текста

При вводе можно использовать нижеследующие префиксы для автоматического выравнивания в ячейках набранного текста.

Нажмите | Чтобы
' (апостроф) | Выровнять данные в ячейке по левому краю.
" (кавычки) | Выровнять данные в ячейке по правому краю.
^ (крышка) | Выровнять данные по центру ячейки.
\ (обратная косая черта) | Циклически повторять символы для заполнения ячейки.

Примечание. При вводе в формуле ссылок на ячейки путем выделения ячеек, скрытые столбцы временно отображаются на экране.


Установка или удаление отдельных компонентов Microsoft Office или Microsoft Excel

В большинстве случаев при первой попытке использования не установленного компонента Microsoft Excel автоматически устанавливает требуемый компонент. Например, при выборе в меню Данные команды Выполнить запрос к базе данных устанавливается Microsoft Query. Описанная ниже процедура применяется в случае, если требуемый компонент не устанавливается автоматически.

  1. Нажмите кнопку Печать [image] на панели инструментов Справка, чтобы напечатать этот раздел. Кроме того, можно выбрать ссылку в конце этой процедуры и напечатать также раздел, связанный с этой ссылкой.

  2. Закройте все программы.

  3. Нажмите кнопку Пуск на панели задач Windows, выберите меню Настройка и затем — пункт Панель управления.

  4. Дважды щелкните значок Установка и удаление программ [image] , а затем выполните одно из следующих действий:

    Если Microsoft Excel установлен в составе Office, выберите пункт Microsoft Office 2000 на вкладке Установка/удаление, а затем нажмите кнопку Добавить/удалить.

    Если Microsoft Excel был установлен отдельно, выберите пункт Microsoft Excel 2000 на вкладке Установка/удаление, а затем нажмите кнопку Добавить/Удалить.

  5. Следуйте инструкциям, выводимым на экран.

    См. сведения о расположении компонентов в составе программе установки.

Примечания

  • Если Microsoft Office или Microsoft Excel были установлены с компакт-диска, но после этого было изменено имя диска устройства чтения компакт-дисков, снова запустите программу установки с компакт-диска. Если какие-либо файлы Office или Excel запускались с компакт-диска, необходимо удалить Office или Excel, а затем снова установить их с компакт-диска.

  • Если исходная установка Office или Excel проводилась с файлового сервера сети или из общей папки, то следует запустить ту же копию программу установки.


Автоматическое восстановление Microsoft Office или программы Office

Данная процедура позволяет найти и устранить неполадки, связанные с установленными программами Microsoft Office, такие как нарушения в значениях параметров реестра и отсутствие файлов установки. Она не позволяет восстановить личные файлы, например таблицы или шаблоны.

  • В меню Справка выберите команду Найти и устранить.

    Для восстановления ярлыков программ в меню Пуск Windows установите флажок Восстановить ярлыки.

Примечание. Если команда Найти и устранить не помогает устранить неполадки, возможно, придется выполнить восстановление или переустановку Microsoft Office.


 Надстройки для Microsoft Excel

Надстройки для Microsoft Excel

Программы надстроек, перечисленные в следующей таблице, устанавливаются по умолчанию в одном из двух мест: в папке Library или одной из ее подпапок в папке Microsoft Office\Office или в папке Profiles\имя пользователя\Application Data\Microsoft\AddIns в папке Windows. Администратор сети организации может указать другие местоположения для надстроек. Для получения дополнительных сведений обратитесь к администратору.

Если какую-либо надстройку не удается найти на локальном или сетевом диске, ее можно установить. После установки программы надстройки для ее загрузки в Excel необходимо использовать команду Надстройки из меню Сервис.

Примечания

  • Не все дополнительные компоненты являются надстройками. См. сведения о компонентах, которые можно установить с Excel.

  • Microsoft Query можно использовать без установки соответствующей надстройки. Инструкции по установке Microsoft Query.

  • Мастер Web-форм, поставлявшийся с Excel 97, теперь доступен на Web-узле корпорации Майкрософт. Другие надстройки бывают доступны через Интернет время от времени. Инструкции по получению надстроек от корпорации Майкрософт через Интернет.

  • Мастер преобразования файлов, поставлявшийся с Excel 97, недоступен для Excel 2000. Вместо него можно использовать мастер преобразования файлов Office, входящий в издание Ресурсы Microsoft Office 2000, для преобразования групп файлов в формат Excel 2000. Инструкции по получению издания «Ресурсы Microsoft Office 2000».
Надстройка | Описание
AccessLinks | Создает формы и отчеты Microsoft Access для использования с данными Excel, а также импортирует данные Excel в Access. Для использования надстройки AccessLinks на компьютере необходимо установить Access 2000.
Пакет анализа | Дополняет Microsoft Excel финансовыми, статистическими и инженерными функциями.
Автосохранение | Автоматически сохраняет книги через заданные интервалы времени.
Мастер суммирования | Создает формулу для суммирования тех данных в списке, которые удовлетворяют заданному условию.
Пересчет в евро | Форматирует значения как суммы в евро и предоставляет функцию EUROCONVERT для пересчета валют.
Мастер подстановок | Создает формулу для поиска данных в списке по другому значению в этом же списке.
Надстройка ODBC | Использует функции ODBC для доступа к внешним источникам данных с помощью установленных драйверов ODBC.
Диспетчер отчетов | Создает отчеты по различным областям печати, пользовательским представлениям книги и сценариям.
Поиск решения | Вычисляет решения для сценариев «что-если» на основе ячеек перебора и ячеек ограничений.
Надстройка MS Query для MS Excel 5.0 | Преобразует диапазоны внешних данных из формата Microsoft Excel 97 и Microsoft Excel 2000 в формат Microsoft Excel версии 5.0/95; позволяет использовать макросы, написанные на Visual Basic для приложений в предыдущих версиях Excel.
Программы для шаблонов | Предоставляет служебные программы, используемые встроенными шаблонами Excel. Доступ к этим программам осуществляется автоматически при использовании встроенного шаблона.
Мастер шаблонов | Создает шаблоны, позволяющие автоматически собирать записи в базу данных для отслеживания и анализа.
Обновление связей | Обновляет связи с надстройками Excel версии 4.0 для непосредственного доступа к встроенной функциональности Excel версий 5.0 и 7.0, Excel 97 и Excel 2000.
Помощник по Интернету | Позволяет разработчикам публиковать данные Excel в Интернете с использованием синтаксиса мастера Web-страниц Excel 97.


Код регистрации

После получения и проверки корпорацией Майкрософт сведений о регистрации пользователю с помощью того же способа, который использовался для регистрации, возвращается код регистрации (если только регистрация не проводилась через Интернет; в этом случае код регистрации не требуется). При следующем запуске Microsoft Excel или другой программы Microsoft Office будет выведен запрос на ввод кода регистрации для завершения процесса регистрации. Если до момента следующего запуска Excel или Office код регистрации не получен, пользователю предоставляется возможность завершить процесс регистрации по телефону.


Не удается зарегистрировать Microsoft Excel или Microsoft Office

Вы могли отказаться от регистрации. В некоторых странах регистрация не требуется. В этом случае при первом запуске Excel или другой программы Office пользователю предоставляется возможность заполнить форму для электронной регистрации и отправить ее в корпорацию Майкрософт с использованием Интернета или иного канала электронной почты. В случае, если доступ к Интернет и иным каналам отсутствует, можно распечатать форму и затем отправить ее в Майкрософт по почте или по факсу. Кроме того, зарегистрироваться можно по телефону, следуя указаниям в Мастере регистрации Office. Возможность заполнить форму для электронной регистрации предоставляется только при первом запуске Excel или другой программы Office. Если при этом вы решили отказаться от регистрации, единственным доступным методом регистрации является регистрация через Web-узел обновления Microsoft Office (Microsoft Office Update).

На компьютере может отсутствовать учетная запись для работы с Интернетом или электронной почтой. Для отправки формы регистрации в Майкрософт по электронным каналам необходимо наличие модема и учетной записи для работы с Интернетом или электронной почтой. Получить учетную запись можно через поставщика услуг Интернета или через сеть организации. Если доступ к Интернету или электронной почте отсутствует, можно распечатать форму и затем отправить ее в Майкрософт по почте или по факсу. Кроме того, зарегистрироваться можно по телефону, следуя указаниям в Мастере регистрации Office. Если в данном регионе регистрация не требуется, и вы отказались от регистрации при первом запуске Excel или другой программы Office, единственным доступным методом регистрации является регистрация через Web-узел обновления Microsoft Office (Microsoft Office Update).

Сеть может быть занята. Проверьте сетевые подключения и попробуйте отправить форму регистрации позже, при снижении активности в сети. Также можно распечатать форму и затем отправить ее в Майкрософт по почте или по факсу. Кроме того, зарегистрироваться можно по телефону, следуя указаниям в Мастере регистрации Office. Если в данном регионе регистрация не требуется, и вы отказались от регистрации при первом запуске Excel или другой программы Office, единственным доступным методом регистрации является регистрация через Web-узел обновления Microsoft Office (Microsoft Office Update).


После установки не удается найти программу Office

Программа Office отсутствует в меню Программы. Некоторые программы данной версии Microsoft Office находятся в подменю Средства Microsoft Office (меню Пуск Windows, команда Программы). Если найти программу все же не удается, можно найти и устранить неполадки, и восстановить ярлыки программ Office.


Сведения, относящиеся к конкретным языкам

Разделы справки, относящиеся к конкретным языкам, доступны только тогда, когда доступны возможности, относящиеся к конкретным языкам. Работа с другим языком, установка средств проверки правописания для другого языка.


Работа с фонетическими руководствами

The phonetic guide function

Сведения, относящиеся к конкретным языкам

Add phonetic guides You can add phonetic guides to Japanese data that has been entered in a cell. The phonetic character string that was used to enter the Japanese data is used to apply phonetic guides. To display the phonetic guides on the screen, point to Phonetic Guide on the Format menu, and then click Show or Hide.

Modify phonetic guides If the displayed phonetic guides are incorrect, you can revise them. Select the cell that shows the incorrect phonetic guides. On the Format menu, point to Phonetic Guide, and then click Edit. You can now change the phonetic guides by using the same method you use to enter a character string.

Change phonetic guide formats You can change the type, alignment, and font of phonetic guides. The three types of phonetic guides available are hiragana, full-width katakana, and half-width katakana. Their default alignment is left alignment (that is, placed along the left edge of the kanji to which the phonetic guides apply). You can change the alignment to no alignment (all phonetic guides are combined and aligned along the left edge of the cell), center alignment (centered against the kanji to which the guides apply), or distributed alignment (set with equal spacing against both edges of the kanji to which the guides apply). To change the type, alignment, or font of phonetic guides, point to Phonetic Guide on the Format menu, and then click Settings.

Sort data by using phonetic guides When worksheet data is sorted, Japanese data is sorted by its phonetic guides by default. If the correct phonetic guides have been used, Japanese terms are sorted in the same order as they would occur in a Japanese dictionary. If the phonetic guides are not entered correctly, make the necessary corrections.


Отображение и скрытие фонетических руководств

Show or hide phonetic guides

Сведения, относящиеся к конкретным языкам

In Microsoft Excel, you can use this procedure to display or hide phonetic guides. When you display phonetic guides in the Japanese version of Microsoft Excel and enter kanji (Chinese characters that are used in the Japanese language), Excel automatically adds the phonetic symbols to the guides. When you display phonetic guides in non-Japanese versions of Excel, phonetic symbols are not added automatically when you enter kanji in cells. You can add the phonetic symbols manually by modifying the phonetic guides.

  1. Select the cells whose phonetic guides you want to show or hide.

  2. On the Format menu, point to Phonetic Guide, and then click Show or Hide.

    When phonetic guides are displayed, the button next to Show or Hide is pressed in.

Note Excel automatically adds phonetic symbols only to new data entered in the Japanese version of Excel. If you open files that were created in earlier versions of Excel or in other programs, phonetic symbols are not generated automatically.


Изменение фонетических руководств

Modify phonetic guides

Сведения, относящиеся к конкретным языкам

  1. Double-click the cell that contains the phonetic guides you want to modify, and then click the phonetic guides.

  2. Modify the phonetic guides.

  3. Выполните одно из следующих действий:

    To confirm the modified phonetic guides, press ENTER twice.

    To cancel the changes, press ESC twice.

Combine phonetic guides

Select the target parent character string, and then click Phonetic Guide on the Format menu. For example, the phonetic guides for Tokyo to Shibuya ku Tokyo to Shibuya ku Tokyo to Tokyo to Shibuya ku Tokyo to Shibuya ku Tokyo to Shibuya ku would normally be split into toukyouto toukyouto toukyouto toukyouto toukyouto toukyouto and shibuyaku shibuyaku shibuyaku shibuyaku. To combine these into one string of toukyoutoshibuyaku toukyoutoshibuyaku [image] toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyouto shibuyaku, use the mouse to select the Tokyo to Shibuya ku Tokyo to Shibuya ku Tokyo to Shibuya ku Tokyo to Shibuya ku Tokyo to Shibuya ku Tokyo to Shibuya ku parent string within the cell, point to Phonetic Guide on the Format menu, and then click Edit.

Divide phonetic guides

Select the target parent character string whose phonetic guides you want to change. On the Format menu, point to Phonetic Guide, and then click Edit. The existing (combined) phonetic guides will be set as the phonetic guides for the selected character string only, so they cannot be applied to any other character string. For example, the parent character string Tokyo to Shibuya ku Tokyo to Shibuya ku Tokyo to Shibuya ku Tokyo to Shibuya ku Tokyo to Shibuya ku Tokyo to Shibuya ku has a combined phonetic guide of toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku. Divide these into Tokyo to Tokyo to Tokyo to and Shibuya ku Shibuya ku Shibuya ku. If you select Tokyo to Tokyo to Tokyo to and then point to Phonetic Guide and click Edit, the phonetic guide toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku toukyoutoshibuyaku will be applied to Tokyo to Tokyo to Tokyo to and no phonetic guides will be applied to Shibuya ku Shibuya ku Shibuya ku. In this case, modify the phonetic guides for Tokyo to Tokyo to Tokyo to, and then add new phonetic guides to Shibuya ku Shibuya ku Shibuya ku.

Tip To use the keyboard to move the pointer to the phonetic guides, press ALT+SHIFT+UP ARROW. To return to the parent string that the phonetic guides apply to, press ALT+SHIFT+DOWN ARROW. The color of the parent character string changes while the phonetic guides are being modified.


Изменение шрифта или типа фонетического руководства

Change phonetic guide font or type

Сведения, относящиеся к конкретным языкам

You can change the font of phonetic guides. You can also choose between three types of phonetic guides: full-width katakana, half-width katakana, and hiragana.

  1. Select the cells that contain the phonetic guides whose font or type you want to change.

  2. On the Format menu, point to Phonetic Guide, and then click Setting.

    The Phonetic Properties dialog box appears.

  3. To change the font, click the Font tab, and then click the font you want in the Font box. To change the font size, click the size you want in the Size box.

  4. To change the phonetic guide type, click the Setting tab, and then click the phonetic guide type you want under Type.

Tip You can apply formatting (such as bold or italic formatting), colors, underlining, or character effects to phonetic guides on the Font tab.


Исправление настройки клавиатуры

About the Correct Keyboard Setting feature

Сведения, относящиеся к конкретным языкам

Correct Keyboard Setting is a feature that automatically corrects words that are entered in English mode but were meant to be entered in Hangul mode, and vice versa. For example, if you enter eogksalsrnr in English mode, it is corrected to tae han min kuk; and if you enter yo u ya p d gya nya syo in Hangul mode, it is corrected to university.

Correct Keyboard Setting also automatically corrects English words that have a Hangul ending and are entered in English mode. For example, if you enter optiondmf in English mode, it is automatically corrected to option ul.

Correct Keyboard Setting works even when Hangul and English are mixed. For example, if you enter rntjddnjs ppyo mi ya syo, it is automatically corrected to ku song won quality.


Автоматическое исправление английского письма на корейское (хангыль) и наоборот

Automatically correct words that are entered in English to Hangul and vice versa

Сведения, относящиеся к конкретным языкам

  1. On the Tools menu, click AutoCorrect.

  2. On the AutoCorrect tab, select the Correct Keyboard Setting check box.


Выбор выравнивания фонетического руководства

Set phonetic guide alignment

Сведения, относящиеся к конкретным языкам

You can set the alignment of phonetic guides to no alignment (which applies phonetic guides to every character), left alignment, center alignment, or distributed alignment. The default setting is left alignment.

  1. Select the cells that contain the phonetic guides whose alignment you want to change.

  2. On the Format menu, point to Phonetic Guide, and then click Setting.

  3. Under Alignment, click the alignment you want to apply.


Повторное преобразование определенной строки символов

Reconvert a determined character string

Сведения, относящиеся к конкретным языкам

Microsoft Excel allows you to reconvert a character string that has already been input and converted.

  1. Select the cell that contains the character string you want to reconvert, click within that character string (the target of the reconversion), and then double-click.

    The highlighted string becomes the target range for the reconversion.

  2. Right-click the cell, and then click Reconversion on the shortcut menu.

    A list of conversion options appears.

  3. Click the desired kanji, and press ENTER twice.

Note Some Japanese Input Method Editors might not be able to perform reconversions.


 Поддержка письма справа налево

About right-to-left language features

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

When languages such as Arabic, Farsi, Hebrew, or Urdu are enabled for editing, you have several features available to you to make working in a right-to-left or bidirectional environment easier.

Дополнительные сведения

Learn about right-to-left features compatibility

Switch between Gregorian and Hijri calendars

Learn about bidirectional fonts

Learn about checking the spelling of bidirectional text

Choose a worksheet direction

Use right-to-left features in a worksheet

Change the default for a right-to-left feature

Enter right-to-left data in worksheets

Import and export right-to-left worksheets in text formats

Use right-to-left charts and maps

Use right-to-left features in Excel Web pages


 Поддержка письма справа налево при работе с книгами из прежних версий

About right-to-left features compatibility

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

Excel 2000 provides full forward compatibility for workbooks that were saved in all previous versions of Microsoft Excel and Microsoft Excel with right-to-left support; however, workbooks that are saved in Excel 2000 file format are not compatible with any previous versions of Microsoft Excel.


 Шрифты для двунаправленного письма

Шрифты для двунаправленного письма

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

Any version of Excel with right-to-left support is designed to display and print both right-to-left and left-to-right text. To do this, the program should use a font that contains both right-to-left and left-to-right language characters. Most fonts available with bidirectional Microsoft Windows operating systems contain both right-to-left and left-to-right characters. If you choose a font that does not contain both right-to-left and left-to-right characters, existing text in one or both languages may be displayed incorrectly using the default secondary font, Tahoma. To correct this problem, choose a different font.

Дополнительные сведения

Изменение размера, шрифта и других форматов текста

Set the font for a Web page

Изменение шрифта и выравнивание текста на диаграмме


Отображение карты Ближнего Востока

Display a map of the Middle East region

Сведения, относящиеся к конкретным языкам

  1. Create a map of the world by using the World Countries and Regions map.

  2. On the Map toolbar, zoom and pan to your desired location.


 Выбор направления письма на листе

Choose a worksheet direction

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

Even though a workbook has a certain direction, you can display its individual worksheets in either a right-to-left or left-to-right view.

Unlike workbooks, in which the change is not apparent until a new workbook is created, worksheets display the direction change immediately.

When you switch worksheet directions, Excel with right-to-left features simply reorients the data from left-to-right or right-to-left. All underlying formulas and values remain intact. Cells with the General alignment attribute will left align left-to-right text and right align right-to-left text, regardless of worksheet direction.

Предполагаемые действия

Change the direction of the current worksheet

Set the direction for new worksheets and charts

Learn about differences between right-to-left and left-to-right worksheets


 Отличия листов с различными направлениями письма

About differences between right-to-left and left-to-right worksheets

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

Some specific differences you will notice in a right-to-left worksheet compared to a left-to-right worksheet are:

Visual differences

  • Cell A1 appears in the upper-right corner of the worksheet. Column letters progress from A on the right to IV on the left.

  • Row numbers appear on the right side of the document window, and the vertical scroll bar appears on the left side.

  • The fill handle appears in the lower-left corner of the cell.

  • Cell note indicators appear in the upper-left corner of the cell.

  • In Outline view, outline buttons and document symbols appear at the right side of the worksheet.

  • The horizontal split box appears at the left side of the spreadsheet, above the vertical scroll bar. The vertical split box appears next to the right horizontal scroll arrow.

Functional differences

  • Ranges are referred to by the cell in the upper-right corner of the range to the cell in the lower-left corner.

  • The AutoSum tool looks up and to the right for cells to total.

  • AutoFormat formats row headings in a selected range on the right side of a table. Totals appear at the bottom and left sides of the selected range.

  • You can enter button labels, text box entries, and cell notes by using right-to-left, left-to-right, or bidirectional text.


Изменение направления письма на текущем листе

Change the direction of the current worksheet

Сведения, относящиеся к конкретным языкам

  • Выполните одно из следующих действий:

    Click the Sheet Right-To-Left [image] or Sheet Left-To-Right [image] button.

    On the Tools menu, click Options, click the View tab, and select or clear the Right to Left check box.


 Выбор направления письма на вновь создаваемых листах и диаграммах

Set the direction for new worksheets and charts

Сведения, относящиеся к конкретным языкам

  1. Click Options on the Tools menu, and then click the Right-To-Left tab.

  2. Do one of the following in the Default Orientation option group:

    Click Left-To-Right to have new objects displayed in a direction familiar to left-to-right users.

    Click Right-To-Left to have new objects displayed in a direction familiar to right-to-left users.


 Выбор направления письма на диаграмме

Change the direction of a chart

Сведения, относящиеся к конкретным языкам

When right-to-left editing is enabled in Microsoft Excel, and the default orientation for new charts is right-to-left, charts are automatically configured with a right-to-left view. This means that the horizontal (category) axis origin and the vertical (value) axis appear to the right side of the chart, and the chart legend appears to the left of the chart.

You can manually move chart objects to a position that supports the direction you are trying to achieve — for example, to change a left-to-right chart to a right-to-left chart:

  1. Click the horizontal (category) axis to select it, then right-click the axis and click Format Axis on the shortcut menu.

  2. Click the Scale tab and select the Categories In Reverse Order option. The horizontal (category) axis origin and the vertical (value) axis appear at the right side of the chart.

  3. Click the legend border to select it, then right-click the border and click Format Legend on the shortcut menu.

  4. Click the Placement tab and select Left in the Placement group. The chart legend will appear to the left of the chart.


 Выбор установленных по умолчанию параметров для письма справа налево

Change the default for a right-to-left feature

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

You can set the default behavior for several right-to-left features.

Предполагаемые действия

Set the direction for new worksheets and charts

Set insertion point behavior

Display or hide control characters


 Выбор способа перемещения точки ввода

Set insertion point behavior

Сведения, относящиеся к конкретным языкам

  1. Click Options on the Tools menu, and then click the Right-to-Left tab.

  2. Do one of the following in the Cursor Movement option group:

    Click Logical to have insertion point movement that moves in the logical order of bidirectional text.

    Click Visual to have insertion point movement that ignores text language and moves contiguously to the right or left.


 Отображение и скрытие непечатаемых знаков

Display or hide control characters

Сведения, относящиеся к конкретным языкам

  1. Click Options on the Tools menu, and then click the Right-to-Left tab.

  2. Select or clear the Show control characters check box.


 Выбор направления чтения для ячеек

Set the reading order for cells

Сведения, относящиеся к конкретным языкам

  1. Click the down arrow next to the Paragraph [image] button.

  2. Выполните одно из следующих действий:

    For right-to-left reading order, click Right-to-Left.

    For left-to-right reading order, click Left-to-Right.

    For reading order that is consistent with the language of the first entered character, click Context.

Note You can also set reading order on the Format menu by clicking Cells and then clicking the Alignment tab.


 Переключение между григорианским и мусульманским календарями

Switch between Gregorian and Hijri calendars

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

  1. On the Format menu, click Cells, and then click the Number tab.

  2. Select Custom from the list of number categories.

  3. Select a number format code as a starting point for your date format.

  4. Выполните одно из следующих действий:

    To display dates using the Gregorian calendar, regardless of the Regional Settings control panel setting, type B1 before the date code — for example, B1dd/mm/yy.

    When Arabic editing is enabled, to display dates using the Hijri calendar, regardless of the Regional Settings control panel setting, type B2 before the date code — for example, B2dd/mm/yy.


 Диаграммы и карты для письма справа налево

Use right-to-left charts and maps

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

Предполагаемые действия

Change the direction of a chart

Display a map of the Middle East region


 Использование возможностей письма справа налево на листе Excel

Use right-to-left features in a worksheet

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

Here are some examples of using right-to-left features.

Предполагаемые действия

Create a repeating series on a right-to-left worksheet

Resize a column on a right-to-left worksheet

Set a column to Best Fit on a right-to-left worksheet

Change paragraph direction by using shortcut keys


 Ввод данных на листе Excel при письме справа налево

Enter right-to-left data in worksheets

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

  • General is the default alignment, regardless of worksheet direction.

  • When entering right-to-left text in a worksheet, characters will appear from the right side of the Formula bar and move to the left.

  • In addition to entering right-to-left, left-to-right, or bidirectional text in a cell, you can also change the reading order and alignment of cell text.

Предполагаемые действия

Set the reading order for cells

Switch between entering right-to-left and left-to-right text in a cell

Learn about entering formulas containing right-to-left text in worksheets

Learn about printing and previewing data on right-to-left worksheets


Изменение ширины столбца на листе при направлении письма справа налево

Resize a column of a right-to-left worksheet

Сведения, относящиеся к конкретным языкам

  • Drag the left column border in the column header.


Выбор оптимальной ширины столбца на листе при письме справа налево

Set a column to Best Fit on a right-to-left worksheet

Сведения, относящиеся к конкретным языкам

  • Double-click the left column border in the column header.


 Переключение направления письма при вводе текста в ячейку

Switch between entering right-to-left and left-to-right text in a cell

Сведения, относящиеся к конкретным языкам

  • Click the Language [image] icon on the taskbar, then choose the desired keyboard language.

    The text insertion pointer will change to indicate the direction of the selected language; text can be entered in the chosen language.

Note Text is displayed in the default font, Arial, unless another font is chosen. You can override the default font for the selected cell (or range) by using the Cells command (Format menu). Click the Font tab, select the appropriate font, and click OK.


 Ввод на листе Excel формул, текст в которых имеет направление справа налево

Enter formulas containing right-to-left text in worksheets

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

Understanding formula entry in Excel with right-to-left features is slightly more complex than understanding text entry, especially because you have the ability to enter both right-to-left and left-to-right text in formulas. Here are a few pointers to help you:

  • Formulas appear left aligned in the Formula bar and cells, with left-to-right reading order, for both right-to-left and left-to-right worksheets.

  • Formula function names are always left-to-right, although the arguments can contain bidirectional text.

  • The reading order and alignment of formula results depend on the reading order and alignment chosen for that cell. The default settings for reading order and alignment are Context and General, respectively.


 Автоматическое заполнение ячеек листа значениями прогрессии при направлении письма справа налево

Create a repeating series on a right-to-left worksheet

Сведения, относящиеся к конкретным языкам

  • Выполните одно из следующих действий:

    Drag the fill handle down or to the left to create a progressive series.

    Drag the fill handle to the right to create a regressive series.

Note When you use the fill handle to create a date series, dates will appear as Gregorian or Hijri. Hijri date calculations, however, only support days; they do not support month and year calculations.


 Проверка орфографии в двунаправленном тексте

About checking the spelling of bidirectional text

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

You can check the spelling of both your English and right-to-left text in cells. Simply choose a dictionary whose language corresponds to the text used.

Примечания

  • You must install a version of Microsoft Excel that includes a right-to-left language dictionary to be able to check spelling of right-to-left text.

  • When checking text with a right-to-left language dictionary, English words are ignored and not flagged as misspelled. Similarly, when checking text with an English dictionary, right-to-left language words are ignored and not flagged as misspelled.

  • To change dictionaries, deliberately misspell a word so that the Spelling dialog box will open; otherwise, you are just informed that you have no misspelled words.

Дополнительные сведения

Check the spelling of text in another language

Learn about checking spelling and correcting errors as you type


 Печать и предварительный просмотр данных на листе при выборе направления письма справа налево

About printing and previewing data on right-to-left worksheets

Сведения, относящиеся к конкретным языкам

The tabs within the Page Setup dialog box provide right-to-left characteristics that give you a true representation of your data.

Поля

The page layout sample in the center of the tab reflects the current worksheet direction setting.

The sample worksheet displayed on the Margins tab shows the direction of the first worksheet in the workbook. There might be worksheets with both right-to-left and left-to-right directions in the same workbook.

Лист

Worksheets that are too large to print on a single page are printed according to an order established by the direction of the current worksheet. Right-to-left worksheets print down or across, starting in the upper-right corner of the worksheet. The following example shows the page numbering and printing order for a worksheet that is three pages wide and requires six pages to print.

Worksheet direction | Multiple-page printing order
Left-to-right | Left-to-right printing order
Right-to-left | Right-to-left printing order

Print Preview

The Print Preview button displays a right-to-left or left-to-right page direction, depending on the direction of the current worksheet.


 Использование возможностей письма справа налево на Web-страницах

Use right-to-left features in Excel Web pages

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

Предполагаемые действия

Learn about right-to-left features in Web pages

Set the direction for new worksheets and charts

Specify the direction of a Web page

Specify the direction of a control on a Web page


 Письмо справа налево на Web-страницах

About right-to-left features on Web pages

Сведения, относящиеся к конкретным языкам

Right-to-left features on Web pages are set according to a two-level hierarchy: page level and control level.

Page level

A Web page that's published from Microsoft Excel will have the same display direction, either left-to-right or right-to-left, as the corresponding Microsoft Excel worksheet it was created from. That direction appears as a setting of the Dir property of the Web page.

Примечания

  • Web page direction is included in the underlying HTML code of the Web page through the use of the standard HTML Direction (DIR) attribute. For example, the code <HTML DIR=RTL>, placed at the beginning of the <HTML> element, identifies a right-to-left Web page.

  • Controls that are placed on a Web page inherit the directionality of the Web page itself, depending on whether the control has right-to-left features. Controls without right-to-left features appear in a left-to-right direction.

Control level

Controls with right-to-left features initially appear on a Web page according to the direction of the Web page. After you place a control on a Web page, you may be able to change the control display direction to give it right-to-left appearance and functionality. The property name that controls the display direction varies with the control type. The properties in the following table control directionality for Web page controls.

Control type Описание
Microsoft Office Web Component controls The Office Web Component controls are the spreadsheet, the chart, and the PivotTable list.

For the spreadsheet and PivotTable list, set or change in a design program, such as Microsoft FrontPage 2000 or Microsoft Access data access page Design view, by using the Advanced section of the property toolbox for the control. No setting is available for the chart.

The direction setting property is RightToLeft.

Note Office Web Component controls each have a property toolbox that can be used both while designing the control and working with it in the browser; however, the right-to-left setting can't be changed in the browser.
Intrinsic browser controls Examples of intrinsic browser controls include Table, Label, TextBox, ComboBox, ListBox, OptionGroup, and ScrollingText.

Set or change the direction by using an HTML editor, such as the Microsoft Script Editor, that exposes control properties in a properties window.

The direction setting property is typically Dir.
Элементы ActiveX These are other controls that are available with Microsoft Office 2000 programs or Microsoft Visual Basic.

Set or change the direction by using an HTML editor, such as the Microsoft Access 2000 data access page Design view or the Microsoft Script Editor, to add controls and expose control properties in a properties window.

The direction setting property is typically RightToLeft.


 Выбор направления письма на Web-странице

Specify the direction of a Web page

Сведения, относящиеся к конкретным языкам

  • Выполните одно из следующих действий:

    Before publishing a new Web page, set the direction of the worksheet to match the desired direction of the Web page. A new Web page will automatically assume the direction of the worksheet on which it is based.

    For a published Web page that is running in a browser, do one of the following:

    • Edit the HTML source directly as text. Click HTML Source on the View menu, and then modify the <HTML> element to <HTML DIR=RTL> for a right-to-left page direction, or to <HTML DIR=LTR> for a left-to-right page direction.

    • Use an HTML editor that exposes document properties in a properties window — such as the Microsoft Script Editor — to change the Dir property setting (LTR or RTL) of the Web page at the beginning of the <HTML> element. Click Properties [image], click the perimeter of the Web page until the document properties are displayed, click the All tab if available, and then change the Dir property setting to the Web page direction you want: either RTL or LTR.


 Выбор направления письма для элемента управления на Web-странице

Specify the direction of a control on a Web page

Сведения, относящиеся к конкретным языкам

  • Выполните одно из следующих действий:

    Before publishing a new Web page, set the direction of the worksheet to match the desired direction of the control. A new control will automatically assume the direction of the worksheet on which it is based.

    For a published Web page, do one of the following:

    • For the Microsoft Office Web Component controls You cannot set the direction of the control in the browser. Open the Web page in a design program such as Microsoft FrontPage 2000 or Microsoft Access data access page Design view, activate the control, click Property Toolbox [image] on the control’s toolbar, and expand the Advanced section.

      For a PivotTable list control, select or clear the Display right to left check box.

      For a spreadsheet control, click True or False in the Display right to left list.

      No direction control settings are available for a chart control.

      For information about activating the controls, see Help in the design program. For information about displaying the toolbar and using the property toolbox, see Help in the control when it's activated in the design program.

    • For intrinsic browser controls For controls that are used when publishing static Web pages (that is, pages without interactivity), edit the HTML source code directly as text, or use an HTML editor, such as the Microsoft Script Editor, to expose control properties in a properties window and change the Dir property setting (LTR or RTL) of the control.

    • For an ActiveX control that is added separately Edit the HTML source directly as text, or use an HTML editor — such as the Microsoft Access 2000 data access page Design view or the Microsoft Script Editor — to expose control properties in a properties window and change the RightToLeft property setting, or equivalent (typically True or False).


 Поддержка кодовой страницы и разметки текста в HTML-файлах Web-страниц для письма справа налево

About code page and text layout support for right-to-left HTML Web page files

Сведения, относящиеся к конкретным языкам

Microsoft Excel supports several code pages used in importing, saving, and exporting HTML Web pages that contain right-to-left text.

Язык | Code page
Арабский | UTF-8 (default) ISO-8859-6 DOS-720 ASMO-708
Иврит | UTF-8 (default) ISO-8859-8 DOS-862

Note Microsoft Excel supports editing and saving of HTML Web page files in logical text layout. HTML Web page files stored in visual text layout can be viewed, but not edited or saved, in logical text layout.

Дополнительные сведения

Preview Excel data as a Web page

I can’t export my Web page to Excel

Cells are missing when I publish or save as a Web page


 Импорт листов с направлением письма справа налево в текстовые форматы и экспорт из этих форматов

Import and export right-to-left worksheets in text formats

Сведения, относящиеся к конкретным языкам

To enable the right-to-left features in Microsoft Excel, you must be running a 32-bit Microsoft Windows operating system that has right-to-left support — for example, the Arabic version of Microsoft Windows 95.

Excel stores all characters as Unicode code page values in logical text layout, but can import and export worksheets saved as text files if these files contain right-to-left text stored in the appropriate Windows code page and logical text layout. For example, a text file containing Arabic text must be stored in the Arabic Windows code page 1256 to be successfully imported by Excel.

To create text files that are recognized by Excel, use ConvText, a stand-alone text-file conversion utility included with Excel. ConvText provides both logical and visual text layout options and an extensive list of supported bidirectional code pages to create a new file in a recognizable text format. Subsequently, choose Windows (ANSI) as the file origin setting in the Text Import Wizard when importing an appropriately formatted text file.

Note A worksheet in Lotus or Quattro Pro format that requires code page and/or text layout conversion can still be imported into Excel by saving the worksheet in text file format prior to importing it. The ability to save a worksheet in text file format is a standard feature of most database or spreadsheet products. ConvText can then be used to create a recognizable text file. When Excel imports the text file, data from the original worksheet will be fully recreated in a new Excel worksheet.

Предполагаемые действия

Convert bidirectional text files to ANSI

Convert bidirectional text files from ANSI

Learn about code page and text layout support for right-to-left HTML Web page files


 Преобразование файлов с двунаправленным текстом в кодировку ANSI

Convert bidirectional text files to ANSI

Сведения, относящиеся к конкретным языкам

The ConvText utility provides more support (additional code pages and visual text layout options) than the Microsoft Excel Text Import Wizard for converting right-to-left characters in bidirectional files to ANSI characters with logical text layout. ConvText is installed as part of Excel.

  1. In the \Program Files\Microsoft Office\Office folder, double-click the ConvText.exe icon.

  2. Click Convert To Windows ANSI Code Page.

  3. Type file names in the Source and Target boxes, or click Browse.

  4. Select the code page, text layout, file type, and file type parameters that match the source text file you are converting.

  5. Click Load. You can also click Save to retain the conversion specifications.

  6. Click Convert.

  7. Follow the instructions in the Text Import Wizard.

All field names and records from the original worksheet are fully recreated in a new worksheet.


 Преобразование файлов с двунаправленным текстом из кодировки ANSI

Convert bidirectional text files from ANSI

Сведения, относящиеся к конкретным языкам

The ConvText utility provides more support (additional code pages and visual text layout options) than the Microsoft Excel Save As command (File menu) for converting from ANSI characters with logical text layout to other bidirectional file formats. ConvText is installed as part of Microsoft Excel.

  1. Save a copy of the worksheet you want to convert to a non-ANSI code page.

  2. In the \Program Files\Microsoft Office\Office folder, double-click the ConvText.exe icon.

  3. Click Convert From Windows ANSI Code Page.

  4. Type file names in the Source and Target boxes, or click Browse.

  5. Select the code page, text layout, file type, and file type parameters that match the target text file you are converting to.

  6. Click Load. You can also click Save to retain the conversion specifications.

  7. Click Convert.


Ввод, отображение и печать символа евро

Поддержка символа евро. Excel 2000 обеспечивает полную поддержку отображения, ввода и печати символа евро Символ валюты евро, а также работы с денежными значениями, выраженными в евро. Однако при использовании Microsoft Windows 95 или Microsoft Windows NT 4.0 с пакетом обновления 3 или более ранним может потребоваться установка обновления с поддержкой евро.

Надстройка «Пересчет в евро». Дополнительная поддержка евро, включая функцию EUROCONVERT для пересчета в евро национальных валют стран-членов Европейского Союза (ЕС), принявших евро, доступна в надстройке «Пересчет в евро». Для того чтобы загрузить эту надстройку, выберите команду Надстройки в меню Excel Сервис, а затем установите флажок Пересчет в евро. Если этот флажок отсутствует, то необходимо сначала установить надстройку.

Форматирование значений в евро. Для того чтобы применить денежный формат евро к данным на листе, сначала выделите данные, которые требуется отформатировать. Выберите команду Ячейки в меню Формат и перейдите на вкладку Число. В списке Числовые форматы выберите Денежный, а затем выберите нужный формат евро в списке Обозначение.

Ввод символа евро. Для ввода символа евро используются следующие клавиши.

Клавиши | Раскладка клавиатуры
ALT+0128 (цифровая клавиатура, индикатор NUM LOCK должен быть включен) | Арабская, иврит, турецкая, США (101 клавиша)
ALT+0136 (цифровая клавиатура, индикатор NUM LOCK должен быть включен) | Кириллическая
AltGr+E | Бельгийская, Belgian Dutch 120, хорватская, чешская, чешская (101 клавиша), чешская' (программистская), датская, голландская (KBD143), эстонская, фарерские о-ва, финская, французская, немецкая (IBM), немецкая (стандартная), исландская, итальянская, итальянская 142, латышская, литовская, литовская (новая), македонская (кириллица), норвежская, португальская-KBD163, сербская (кириллица), сербская (латиница), словацкая, словацкая (QWERTY), словенская, испанская, шведская, швейцарская (французская), швейцарская (немецкая), турецкая (тип F), турецкая (тип Q)
AltGr+ эпсилон | Греческий
AltGr+4 | Ирландская, латышская (QWERTY), британская
AltGr+5 | Греческая (латиница) США (международная)
AltGr+U | Венгерская, венгерская (101 клавиша), польская, польская (программистская)

Отображение значений с символом евро. Ниже перечислены шрифты, в которых возможно отображение символа евро. Для Microsoft Windows 95 и Microsoft Windows NT Workstation 4.0 с пакетом обновления 3 или более ранним может потребоваться установка обновления с поддержкой евро.

Операционная система | Шрифты
Microsoft Windows 95 обновлением для поддержки евро | Arial Black, Arial, Comic Sans (обычное и полужирное начертание), Courier New, Impact, MS Sans Serif, Tahoma (обычное и полужирное начертание), Times New Roman, Verdana
Microsoft Windows 98 | Arial, Courier New, Tahoma (обычное и жирное начертание), Times New Roman
Microsoft Windows NT 4.0 с пакетом обновления 3 или более ранним и с обновлением для поддержки евро | Arial, Courier New, Times New Roman
Microsoft Windows NT 4.0 с пакетом обновления 4 | Arial, Courier New, Lucida Console, Lucida Sans Unicode, Times New Roman

Примечание. Для того чтобы Excel 2000 должным образом распознавал символ валюты при его вводе (не в случае применения формата), необходимо выбрать символ валюты и определить его формат на вкладке Денежная единиц диалогового окна Язык и стандарты (Regional Options в Microsoft Windows 2000) на панели управления Windows. Исключением из этого правила является символ евро, который всегда распознается в Excel.

Печать значений с символом евро. Если символ евро отсутствует в резидентных шрифтах принтера, то вместо символа евро печатается квадратик. За сведениями по приобретению обновленных шрифтов, включающих символ валюты евро, обращайтесь к поставщику принтера. Также можно отключить использование резидентных шрифтов в настройках принтера. Для этого найдите в настройках принтера параметр наподобие Печатать шрифты в виде графики.


 Добавление и удаление обозначения денежной единицы

Добавление и удаление обозначения денежной единицы

  1. Выделите ячейки, формат которых требуется изменить.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Число.

    Демонстрация

  3. В поле Числовые форматы выберите Денежный.

  4. В списке Обозначение выполните одно из следующих действий.

    Чтобы добавить обозначение денежной единицы, выберите требуемое обозначение.

    Чтобы удалить обозначение денежной единицы, выберите Нет.

Примечания

  • Чтобы быстро добавить обозначение денежной единицы, используемое по умолчанию, выделите ячейки, которые необходимо отформатировать, и нажмите кнопку Денежный формат [image] на панели инструментов Форматирование.

  • Чтобы быстро вставить символ валюты евро символ валюты евро, можно использовать сочетание клавиш.

  • Можно использовать числовые форматы для изменения отображения чисел, включая дату и время, без изменения внутреннего представления чисел.


 Создание книги

Создание книги

  1. Выберите команду Создать в меню Файл.

  2. Чтобы создать новую пустую книгу, выберите вкладку Общие и дважды щелкните значок " Книга" .

    Для создания книги по шаблону выберите вкладку Решения или вкладку со списком пользовательских шаблонов, а затем дважды щелкните шаблон, по которому создается книга.

    Примечание. Если нужный шаблон не отображается в диалоговом окне Создать, убедитесь, что шаблон установлен и существует в нужной папке. Для получения дополнительных сведений нажмите [image] .

    Совет. Чтобы создать новую книгу по стандартному шаблону книги, нажмите кнопку Создать [image] .


Создание формы

Можно создать формы для сбора данных из Интернета и от пользователей электронной почты.

Предполагаемые действия

Создание экранной или печатной формы

Создание формы для ввода данных в список

Создание шаблона формы, копирующего данные листа в базу данных

Не можете сделать выбор?


Установка рабочей папки по умолчанию для диалоговых окон "Открытие документа" и "Сохранение документа"

Предполагаемые действия

Изменение рабочей папки по умолчанию для Microsoft Office

Изменение рабочей папки по умолчанию только для Microsoft Excel

Не можете сделать выбор?


Просмотр и сохранение файлов, созданных другими программами

Предполагаемые действия

Открытие файла в другом формате и сохранение его в формате книги Microsoft Excel

Сохранение книги Microsoft Excel в формате другой программы

Потеря свойств при сохранении файла в другом формате

Открытие текстового файла в Microsoft Excel

Разделение текста на столбцы

Открытие книги

Не можете сделать выбор?


Открытие книги

Предполагаемые действия

Открытие файлов

Открытие книги на жестком диске или в сети

Открытие книги во внутренней сети предприятия или в World Wide Web

Открытие книги на Web-сервере

Открытие файла, созданного в другой программе

Способы открытия книг и файлов HTML

Открытие копии книги

Открытие книги только для чтения

Открытие в обозревателе файла HTML с помощью Microsoft Excel

Одновременное открытие нескольких книг

Сохранение и открытие группы книг в пользовательской рабочей области

Открытие файлов с помощью панели Web

Открытие начальной Web-страницы

Открытие Web-страницы поиска

Дополнительные сведения


 Одновременное открытие нескольких книг

Одновременное открытие нескольких книг

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск, папку или адрес FTP, где находятся книги, которые требуется открыть.

  3. В списке папок дважды щелкните папку, содержащую нужные книги.

    Если файла нет в папках, указанных в списке, можно воспользоваться процедурой поиска файлов.

    Инструкции

  4. Для выбора файлов из списка в произвольном порядке щелкните имя какого-либо файла. Затем нажмите клавишу CTRL и, не отпуская ее, щелкните оставшиеся файлы.

    Для выбора файлов, стоящих подряд в списке, щелкните имя первого файла. Удерживая клавишу SHIFT, щелкните имя последнего файла.

  5. Нажмите кнопку Открыть.

Совет. При ошибочном выборе файла нажмите клавишу CTRL и, удерживая ее, повторно щелкните имя файла.


 Открытие книги только для чтения

Открытие книги только для чтения

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск, папку или адрес FTP, где находится книга, которую требуется открыть, и затем найдите и дважды щелкните папку, содержащую книгу.

    Если найти книгу не удается, можно воспользоваться процедурой поиска файлов.

    Инструкции

  3. Выберите книгу, которую нужно открыть только для чтения.

  4. Нажмите стрелку рядом с кнопкой Открыть и затем выберите Открыть для чтения.

Советы

  • Для сохранения изменений в файле, открытом только для чтения, выберите команду Сохранить как в меню Файл и сохраните книгу под новым именем.

  • Открыть только для чтения папку или ярлык книги нельзя.


 Автоматическое открытие книги при запуске Excel

Автоматическое открытие книги при запуске Excel

  1. В проводнике Windows переместите значок книги, которую требуется открывать, в папку XLStart.

    Для того чтобы книга оставалась в текущем местоположении, воспользуйтесь командой Создать ярлык из меню Файл для создания ярлыка книги, а затем переместите ярлык в папку XLStart.

  2. Перезапустите Microsoft Excel.

Совет. Для того чтобы при запуске Microsoft Excel открывать группу связанных книг, сохраните эти книги в файле рабочей области, а затем поместите файл рабочей области в папку XLStart


 Открытие резервной копии книги

Открытие резервной копии книги

Восстановление ранее сохраненной версии книги после сбоя в электросети или при возникновении других проблем возможно в том случае, если диалоговом окне Параметры сохранения был предварительно установлен флажок Всегда создавать резервную копию (меню Файл, команда Сохранить как, меню Сервис, команда Общие параметры), а книга была сохранена более одного раза.

  1. Нажмите кнопку Открыть [image] .

  2. В списке Тип файлов выберите Резервные копии.

  3. В поле Папка выберите папку, в которой содержится нужная книга.

  4. Выберите резервную копию.

  5. Нажмите кнопку Открыть.


Просмотр всех типов файлов и их расширений

  1. В окне "Мой компьютер" или проводнике Windows откройте папку, в которой необходимо просмотреть файлы.

  2. В меню Вид выберите команду Параметры (или Свойства папки в Microsoft Windows 2000), а затем откройте вкладку Вид.

  3. Выполните одно из следующих действий:

    Для просмотра всех типов файлов выберите параметр Показать все файлы в пункте Скрытые файлы.

    Для просмотра всех расширений файлов снимите флажок Не показывать расширения для зарегистрированных типов файлов.


 Создание ярлыка в папке Избранное

Создание ярлыка в папке Избранное

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск, на котором находится файл или папка, для которой требуется создать ярлык, а затем найдите и дважды щелкните папку, содержащую нужный файл или папку.

  3. Щелкните файл или каталог, для которого создается ярлык.

  4. Выберите в меню Сервис команду Добавить в папку "Избранное".

Совет. Чтобы открыть файл или папку, нажмите кнопку Избранное [image] на панели адресов, и затем дважды щелкните ярлык нужного файла или папки.


 Подключение сетевого диска

Подключение сетевого диска

  1. Нажмите кнопку Открыть [image] .

  2. В меню Сервис выберите команду Подключить сетевой диск.

  3. Выберите нужный диск из списка Диск.

  4. Введите путь к папке, которую вы хотите подключить, в поле Путь.

Совет. Для автоматического подключения этого сетевого диска при следующей загрузке Windows установите флажок Автоматически подключать при входе в систему.


Совместный доступ к книгам Excel

Для получения сведений об организации совместного доступа к книгам на диске в среде Windows NT Workstation 3.51 см. документацию Windows NT Workstation.

  1. Нажмите кнопку Пуск на панели задач Windows, выберите меню Настройка, а затем — пункт Панель управления.

  2. Дважды щелкните значок "Сеть" [image].

  3. На вкладке Конфигурация нажмите кнопку Доступ к файлам и принтерам.

  4. Установите флажок Файлы этого компьютера можно сделать общими и дважды нажмите кнопку OK.

  5. Дважды щелкните значок Мой компьютер на рабочем столе Windows и переместите или скопируйте книгу, предназначенную для общего доступа, в пустую папку или в папку, содержащую другие книги для общего доступа.

  6. В окне папки "Мой компьютер" дважды щелкните значок диска, на котором находится книга, предназначенная для общего доступа.

  7. Выберите папку, содержащую книгу, предназначенную для совместного доступа, и выберите команду Доступ в контекстном меню.

  8. На вкладке Доступ выберите параметр Общий ресурс.

    Для обозначения папки для общего доступа в сети можно использовать имя текущей папки или ввести другое имя в поле Сетевое имя. Чтобы сделать описание папки более подробным, следует ввести примечание в поле Примечание.

  9. В режиме доступа на уровне пользователей нажмите кнопку Добавить и выберите имена пользователей, которым следует разрешить доступ к книге для общего доступа.

    В режиме доступа на уровне ресурсов выберите тип доступа для папки, содержащей книгу, предназначенную для общего доступа.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  10. При работе в среде Windows NT 4.0, если имеется диск, отформатированный с использованием файловой системы NTFS, выберите вкладку Защита, а затем нажмите кнопку Разрешения и установите требуемые права доступа.

Советы

  • Описанный выше метод позволяет установить совместный доступ к различным дискам.

  • Чтобы дать возможность другим пользователям одновременно работать в одной книге, следует создать книгу для общего доступа. Для получения дополнительных сведений нажмите кнопку [image] .


 Отображение или скрытие в меню "Файл" списка последних использовавшихся книг

Отображение или скрытие в меню "Файл" списка последних использовавшихся книг

  1. Выберите команду Параметры в меню Сервис, а затем выберите вкладку Общие.

  2. Установите или снимите флажок Список ранее открывавшихся файлов.

    Можно выбрать количество файлов, которые будут отображаться в списке в меню.

Примечание. В меню Файл будет выведен список только тех файлов, которые были открыты и сохранены после установки данного флажка.


Изменение программы, используемой для открытия файла

Операционная система Windows позволяет поставить в соответствие типам файлов программы, автоматически запускаемые при попытке открытия файлов такого типа. Так, при двойном щелчке кнопки мыши текстового файла запускается приложение Блокнот. Программу, с помощью которой автоматически открывается файл, можно изменить.

  1. В окне «Мой компьютер» или в проводнике Windows выберите команду Параметры в меню Вид (или команду Свойства папки в Microsoft Windows 2000).

  2. Перейдите на вкладку Типы файлов.

  3. В поле Зарегистрированные типы файлов выберите тип файла, который должен открываться другой программой.

  4. Нажмите кнопку Изменить.

  5. Нажмите кнопку Изменить еще раз.

  6. В поле Приложение, исполняющее действие введите путь к программе, которая должна использоваться для открытия файлов выбранного типа. Для выбора папки можно воспользоваться кнопкой Обзор.

Примечание. Не все зарегистрированные типы файлов имеют действие Open.


Использование свойств при поиске файлов

Свойствами называются присваиваемые книге сведения, такие как название, тема, автор, руководитель и учреждение, которые используются при описании и поиске файлов.

Предполагаемые действия

Задание свойств для текущей книги

Задание свойств для любого файла Microsoft Excel или Office

Создание пользовательских свойств для текущей книги

Создание пользовательских свойств, связанных с содержимым текущей книги

Автоматический вывод диалогового окна Свойства при первом сохранении книги

Дополнительные сведения


 Поиск файлов по их свойствам

Поиск файлов по их свойствам

  1. Нажмите кнопку Открыть [image] .

  2. В меню Сервис выберите пункт Найти.

  3. Укажите условия поиска, выбрав нужные параметры в полях Свойство, Отношение и Значение, а затем нажмите кнопку Добавить.

    Например, чтобы найти документы, содержащие фразу "яблочный пирог", выберите в поле Свойство пункт Текст или свойство, а затем введите в поле Значение фразу "яблочный пирог", заключив ее в кавычки.

    Для задания дополнительных условий поиска установите параметр И или ИЛИ и повторите пункт 3.

  4. Чтобы просмотреть все вложенные папки в выбранных папках, установите флажок Просмотреть вложенные.

  5. Чтобы начать поиск, нажмите кнопку Найти.

Совет. Для одновременного поиска на нескольких дисках введите имена дисков через точку с запятой в поле Папка диалогового окна Найти. Например, введите C:\;D:\.


 Изменение имени автора книги

Изменение имени автора книги

Имя автора используется в свойствах файла, а также при работе с общими книгами.

  1. Выберите команду Параметры в меню Сервис, а затем выберите вкладку Общие.

  2. Введите имя в поле Имя пользователя.

    Введенное имя будет выводиться в поле Автор на вкладке Документ (команда Свойства в меню Файл) при создании каждого нового файла.

    Совет. Чтобы изменить имя автора только для активного файла, выберите команду Свойства в меню Файл, а затем введите новое имя в поле Автор на вкладке Документ.


 Предварительный просмотр содержимого и свойств файла

Предварительный просмотр содержимого и свойств файла

Примечание. Предварительный просмотр не доступен для файлов, сохраненных в версиях Microsoft Excel, не поддерживающих возможность предварительного просмотра, а также в случае, если при сохранении файла не был установлен флажок Создать рисунок для предварительного просмотра на вкладке Документ диалогового окна Свойства (меню Файл, команда Свойства).

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск, на котором находится файл, который требуется просмотреть, а затем найдите и дважды щелкните папку, содержащую этот файл.

    Если файл найти не удается, можно воспользоваться процедурой поиска файлов.

  3. Выберите нужный файл.

  4. Нажмите стрелку рядом с кнопкой Представления [image] и выберите требуемое представление.

    Для просмотра содержимого файла перед его открытием выберите Просмотр.

    Для просмотра таких свойств файла, как размер, тип и дата последнего изменения, выберите Таблица.

    Для просмотра таких свойств файла, как заголовок и статистика, выберите Свойства.


 Задание свойств для любого файла Microsoft Excel или Office

Задание свойств для любого файла Microsoft Excel или Office

Следующая процедура применима только к файлам, не открытым в данный момент. Инструкции по заданию свойств файла для открытой книги.

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск, на котором находится требуемый файл, а затем найдите и дважды щелкните папку, содержащую файл.

    Если файл найти не удается, можно воспользоваться процедурой поиска файлов.

  3. Выберите файл, для которого нужно задать свойства.

  4. В меню Сервис выберите команду Свойства.

  5. Чтобы добавить или изменить свойства, введите нужные значения и выберите необходимые параметры, а затем нажмите кнопку OK.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  6. Чтобы закрыть диалоговое окно Открыть, не открывая файл, нажмите кнопку Отмена.

Примечание. Для файлов, не являющихся файлами Office, например для текстовых файлов, свойства не могут быть заданы.


 Задание свойств для текущей книги

Задание свойств для текущей книги

  1. Выберите команду Свойства в меню Файл.

  2. Выберите вкладку Документ.

  3. В полях задания свойств файла введите нужные значения.

Примечания

  • Свойства присваиваются файлу только после его сохранения.

  • Команда Свойства недоступна, если книга защищена от изменений. Для получения сведений об отключении защиты для книг нажмите [image] .


 Установка режима "только для чтения" для файла

Установка режима "только для чтения" для файла

При установке для книги режима только для чтения изменения, сделанные в книге, не могут быть сохранены. Для сохранения измененного файла под другим именем или в другом месте, воспользуйтесь командой Сохранить как (меню Файл).

  1. Выберите пункт Программы в меню Windows Пуск, а затем выберите команду Проводник.

  2. Выберите в окне Обзор диск и папку, которые содержат нужный файл.

  3. Щелкните нужный файл.

  4. Выберите команду Свойства в меню Файл.

  5. Установите флажок Только для чтения на вкладке Общие.


 Создание пользовательских свойств для текущей книги

Создание пользовательских свойств для текущей книги

  1. Выберите команду Свойства в меню Файл.

  2. Выберите вкладку Дополнительно.

  3. Введите название пользовательского свойства в поле Название или выберите его из списка.

  4. Выберите тип данных для создаваемого свойства из списка Тип.

  5. Введите значение свойства в поле Значение.

    Вводимое значение должно соответствовать типу файла, выбранному из списка Тип. Например, если из списка Тип выбрано значение Число, то в поле Значение должны быть введены числовые данные. Значения, не соответствующие типу свойства, сохраняются как текстовые.

  6. Нажмите кнопку Добавить.


 Создание пользовательских свойств, связанных с содержимым текущей книги

Создание пользовательских свойств, связанных с содержимым текущей книги

Перед выполнением этой процедуры следует присвоить имя ячейке или диапазону, на который будет ссылаться свойство. В противном случае флажок Связь с содержимым будет недоступен. Для получения дополнительных сведений о присвоении имени ячейке или диапазону нажмите [image] .

  1. Выберите команду Свойства в меню Файл.

  2. Выберите вкладку Прочие.

  3. Введите название пользовательского свойства в поле Название или выберите его из списка.

  4. Установите флажок Для объекта.

  5. Выберите заданный элемент из списка Источник, а затем нажмите кнопку Добавить.

Примечание. При разрыве связи — например при удалении ячейки или диапазона ячеек из книги — свойство файла будет содержать последние сохраненные данные.


 Автоматический вывод диалогового окна Свойства при первом сохранении книги

Автоматический вывод диалогового окна Свойства при первом сохранении книги

  1. Выберите команду Параметры в меню Сервис, а затем выберите вкладку Общие.

  2. Установите флажок Предлагать заполнение свойств файла.


 Определение местоположения файлов

Определение местоположения файлов

Если файл, который требуется открыть, не удается найти с помощью ярлыков панели адресов или в тех папках, где вы обычно сохраняете файлы, можно задать условия для поиска файла в диалоговом окне Найти (для этого в диалоговом окне Открытие документа откройте меню Сервис и выберите команду Найти), или воспользоваться одним из следующих способов поиска файлов.

Предполагаемые действия

Поиск файлов

Поиск файлов по их свойствам

Сохранение условий поиска

Изменение сохраненных условий поиска

Задание свойств файла

Поиск файлов с помощью Outlook

Дополнительные сведения


 О поиске файлов

О поиске файлов

Поиск файлов. Диалоговое окно Открытие документа (меню Файл) позволяет искать файлы на локальном диске и любых сетевых дисках. Поиск файлов можно выполнять по имени, типу файла, дате последнего изменения, а также по содержимому или свойствам файла. См. Поиск файлов.

Поиск с использованием свойств файлов. Свойства файла — это сведения о файле, помогающие идентифицировать его — например, подробное название документа, имя автора, тема, присвоенные файлу ключевые слова, или другая важная информация. См. Поиск файлов по их свойствам. Некоторые свойства, такие как размер файла, дата создания и тип файла присваиваются автоматически при создании файла. Пользователь может добавить дополнительные свойства, например подробное название или ключевые слова. См. сведения о задании свойств для файла.

Поиск с использованием особых условий. Поиск файлов можно выполнять с использованием нетекстовых условий или расширенных комбинаций условий. Например, можно найти файлы, содержащий слово «бюджет» или имеющий ключевое слово «Бюджет99». См. сведения о поиске файлов с использованием особых условий.

Сохранение условий поиска. Если постоянно приходится искать одну и ту же информацию, или если имеется сложный набор, включающий несколько условий поиска, можно сохранить условия поиска для использования в дальнейшем.

Изменение сохраненных условий поиска. Если сохранен набор условий поиска, можно открыть и изменить сохраненные условия поиска.

Ускорение поиска с помощью программы быстрого поиска файлов. Для ускорения поиска в диалоговом окне Найти в Microsoft Office включена программа быстрого поиска, доступ к которой можно получить, дважды щелкнув значок Поиск файлов [image] на панели управления Windows. Программа быстрого поиска создает индексы для ускорения поиска файлов по их содержимому и свойствам. См. сведения о способах ускорения поиска файлов с помощью программы быстрого поиска файлов.


 Возврат на предыдущий дисковод, папку или адрес FTP

Возврат на предыдущий дисковод, папку или адрес FTP

  • В диалоговом окне Открыть нажмите кнопку Назад [image].

Совет. Когда указатель мыши остается на кнопке Назад, в подсказке появляется имя дисковода, папки или адрес FTP, просмотренных ранее.


 Сортировка списка файлов

Сортировка списка файлов

Для сортировки списка файлов в диалоговом окне Открыть (меню Файл) выполните следующую процедуру.

  1. Нажмите кнопку Открыть [image] .

  2. Раскройте список Представления [image] , выберите пункт Упорядочить значки, а затем задайте способ упорядочения.


 Поиск файлов

Поиск файлов

  1. Нажмите кнопку Открыть [image] .

  2. В меню Сервис выберите пункт Найти.

  3. В области Условие введите нужные условия поиска и нажмите кнопку Добавить.

    См. сведения об использовании условий и значений в диалоговом окне Найти.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  4. Чтобы просмотреть все вложенные папки в выбранных папках, установите флажок Просмотреть вложенные.

  5. Чтобы начать поиск, нажмите кнопку Найти.

Советы

  • Чтобы использовать уже существующие (сохраненные ранее) условия поиска, нажмите кнопку Открыть в диалоговом окне Найти, а затем выберите имя набора условий поиска, которым нужно воспользоваться. Инструкции по сохранению условий поиска.

  • Для одновременного поиска на нескольких дисках введите буквы дисков через точку с запятой в поле Папка диалогового окна Найти. Например, введите C:\;D:\.


 Сохранение условий поиска

Сохранение условий поиска

  1. Нажмите кнопку Открыть [image] .

  2. В меню Сервис выберите пункт Найти.

  3. Укажите условия поиска.

Инструкции

  4. Нажмите кнопку Сохранить условия поиска.

  5. Введите название сохраняемых условий поиска в поле Название условий поиска.

Совет. Можно использовать длинные описательные имена длиной до 250 знаков, включающие пробелы.


 Изменение сохраненных условий поиска

Изменение сохраненных условий поиска

  1. Нажмите кнопку Открыть [image] .

  2. Выберите в меню Сервис команду Найти.

  3. Нажмите кнопку Открыть условия поиска.

  4. Выберите сохраненные условия, которые требуется изменить, и нажмите кнопку Открыть.

  5. Выполните одно из следующих действий:

    Для того чтобы очистить условия поиска и использовать значения, устанавливаемые по умолчанию, нажмите кнопку Сброс.

    Для того чтобы изменить некоторые условия, выберите условия, которые требуется изменить, из списка Найти файлы, отвечающие набору условий и нажмите кнопку Удалить. Параметры удаленных условий поиска появятся в окне Условие. Для отмены удаления условий поиска нажмите кнопку Добавить.

  6. Укажите новые условия поиска в поле Условие.

  7. Нажмите кнопку Добавить.

  8. Нажмите кнопку Сохранить условия поиска, введите название сохраняемых условий и нажмите кнопку OK.

  9. Нажмите кнопку Да, чтобы заменить уже существующие условия поиска.

    Чтобы присвоить измененным условиям поиска новое название, введите его и нажмите кнопку OK.


 Удаление сохраненных условий поиска

Удаление сохраненных условий поиска

  1. Нажмите кнопку Открыть [image] .

  2. В меню Сервис выберите пункт Найти.

  3. Нажмите кнопку Открыть условия поиска.

  4. Выберите название условий поиска и нажмите кнопку Удалить.


 Способы ускорения поиска файлов с помощью программы быстрого поиска

Способы ускорения поиска файлов с помощью программы быстрого поиска

Создание индексов на дисках компьютера программой быстрого поиска файлов. Программы Microsoft Office используют индексы, созданные программой поиска файлов, для ускорения поиска по содержимому и свойствам файла в диалоговом окне Найти (меню Сервис в диалоговом окне Открытие документа). При установке программы быстрого поиска файлов в составе Office на каждом локальном диске компьютера автоматически создаются индексы для всех документов Office. (Индексы для быстрого поиска файлов не могут быть созданы на сменных дисках и носителях, предназначенных только для чтения, например компакт-дисках.) После создания индекс автоматически обновляется. Это означает, что для использования всех преимуществ быстрого поиска не нужно предпринимать никаких дополнительных действий.

Изменение или создание новых индексов. Чтобы создать индексы для сетевых папок или изменить существующий индекс, дважды щелкните значок Поиск файлов [image] на панели управления Windows. При этом выводятся сведения о каждом процессе индексирования, включая имя диска, ресурса и папки, где находятся индексированные документы, а также дату последнего обновления индекса. С помощью кнопки Сведения в диалоговом окне Обновление индекса (меню Индекс) можно просмотреть дополнительные сведения об индексах программы быстрого поиска файлов, например сведения о количестве проиндексированных документов и размере индекса.

Для получения дополнительных сведений о создании, удалении и обновлении индексов при использовании программы быстрого поиска файлов нажмите кнопку Справка в диалоговом окне Поиск файлов.


 Настройка основных параметров книги или листа с помощью шаблона

Настройка основных параметров книги или листа с помощью шаблона

Для создания новых книг, обладающих необходимыми параметрами форматирования, можно использовать в качестве основы шаблон. Шаблон — это книга, имеющая определенное содержимое и параметры форматирования, которую можно использовать как образец при создании других подобных книг. Шаблон может включать в себя параметры форматирования, стили, стандартный текст, например заголовки страниц и подписи строк и столбцов, формулы, макросы Visual Basic для приложений и пользовательские панели инструментов. См. сведения об элементах форматирования и параметрах, которые можно сохранить в шаблоне.

Создание стандартного шаблона книги. Для изменения элементов форматирования или содержимого новых пустых книг, открывающихся при запуске Microsoft Excel, можно создать стандартный шаблон книги. В качестве стандартного шаблона книги Excel использует шаблон Book.xlt. Книги, создаваемые с помощью кнопки Создать [image] или с помощью выбора шаблона книги в диалоговом окне Создание документа (меню Файл), также основываются на стандартном шаблоне книги. Можно создать дополнительные пользовательские шаблоны, предназначенные для определенных задач и проектов. См. Создание шаблона для новых книг.

После того как шаблон создан, можно открыть его, как и любую книгу, и внести любые необходимые изменения. См. Изменение формата или содержимого существующего шаблона.

Изменение стандартного листа. Чтобы изменить стандартные листы, вставляемые с помощью команды Лист (меню Вставка), следует создать стандартный шаблон листа. В качестве стандартного шаблона листа Excel использует шаблон Sheet.xlt. Если в книгах используются листы различных типов, можно создать дополнительные пользовательские шаблоны листов. См. Создание шаблона листа для новых листов.


 Изменение формата или содержимого существующего шаблона

Изменение формата или содержимого существующего шаблона

  1. Нажмите кнопку Открыть [image] , а затем откройте шаблон, который необходимо изменить.

    Шаблоны обычно хранятся в папке «Шаблоны», в папке XLStart или в дополнительной папке автозагрузки. Папка «Шаблоны» обычно находится
    C:\операционная_система\Profiles\имя_пользователя\Application Data\Microsoft\Шаблоны
    , а папка XLStart —
    C:\операционная_система\Profiles\имя_пользователя\Application Data\Microsoft\Excel\XLStart
    , где операционная_система — папка операционной системы, например Windows.

  2. Внесите необходимые изменения в содержимое, формат, макросы и другие параметры шаблона.

  3. Нажмите кнопку Сохранить [image] .

    Эти изменения влияют только на новые книги или листы, созданные после смены шаблона. На существующие книги или таблицы, основанные на предыдущей версии шаблона, никакого влияния не оказывается.

Примечание. Существует возможность ввода данных в лист настройки встроенных шаблонов в папке «Решения», расположенной в папке «Шаблоны». Не следует изменять шаблоны другими способами, так как последующие изменения могут отрицательно повлиять на корректность работы формул и макросов.


 Формы и шаблоны, входящие в комплект поставки Microsoft Excel

Формы и шаблоны, входящие в комплект поставки Microsoft Excel

Заполнение формы В комплект поставки Microsoft Excel входят шаблоны, автоматизирующие решение задач, связанных с заполнением счетов, авансовых отчетов и заказов. При заполнении этих форм имеется возможность добавления введенных данных в связанную с шаблоном базу данных в качестве новой записи. Чтобы использовать базу данных, необходимо установить надстройку «Мастер шаблонов с функцией сбора данных». Мастер шаблонов.

Доступ к шаблонам Для использования шаблонов выберите команду Создать в меню Файл, а затем дважды щелкните шаблон на вкладке Решения. Если необходимого шаблона в диалоговом окне Создать нет, то его следует установить. Установка шаблонов.

Поиск дополнительных шаблонов Если имеется доступ к Интернету, то существует возможность получить дополнительные шаблоны Excel, разработанные для решения таких задач, как планирование личных финансов. Дополнительную информацию можно получить, выбрав команду Office на Web в меню Справка.

Примечания

  • При переходе от Microsoft Office 97 или Microsoft Excel 97 существующие шаблоны доступны на вкладке Шаблоны Office 97 в диалоговом окне Создать.

  • При переходе от Microsoft Office 95 или Microsoft Excel 95 существующие шаблоны доступны на вкладке Шаблоны Office 95 в диалоговом окне Создать.

  • Если Microsoft Office 2000 или Microsoft Excel 2000 установлены в той же папке, что и предыдущие версии, программа установки перемещает существующие шаблоны в папку "Шаблоны", которая обычно размещена
    C:\Windows\Profiles\имя_пользователя\Application Data\Microsoft\Templates
    для Windows NT или Windows 95 или более поздней версии с многопользовательскими возможностями или
    C:\Windows\Application Data\Microsoft\Templates
    для Windows 95 или более поздней версии без многопользовательских возможностей.

  • Если текущая версия установлена в другую папку, программа установки помещает ярлык на существующие шаблоны в папку Application Data\Microsoft\Templates.


 Вставка нового листа, основанного на пользовательском шаблоне

Вставка нового листа, основанного на пользовательском шаблоне

Для выполнения данной операции необходимо иметь уже созданный пользовательский шаблон листа. Для получения сведений о создании шаблона листа нажмите кнопку [image] .

  1. Щелкните правой кнопкой мыши ярлычок листа и выберите команду Вставка.

  2. Выберите нужный шаблон для листа.


 Создание шаблона формы, копирующего данные листа в базу данных

Создание шаблона формы, копирующего данные листа в базу данных

Если в меню Данные отсутствует команда Мастер шаблонов, необходимо установить надстройку мастера шаблонов с функцией автоматического сбора данных. Для получения сведений об установке надстроек нажмите кнопку [image] .

  1. Откройте книгу, в которую будут вводиться данные, копируемые в базу данных.

  2. Введите подписи для вводимых данных.

    Подписи следует вводить в ячейку над или слева от той, которая содержит данные. Эти подписи будут использованы как имена полей в базе данных.

  3. Выберите команду Мастер шаблонов в меню Данные.

  4. Следуйте указаниям мастера.

Примечание. Базой данных, связанной с шаблоном формы, может быть список Microsoft Excel или база данных Microsoft Access, Microsoft FoxPro или dBase, для которой установлен необходимый драйвер ODBC и другие компоненты доступа к данным. Для получения сведений о компонентах доступа к данным нажмите кнопку [image] .


 Рекомендации по хранению шаблонов

Рекомендации по хранению шаблонов

Хранение стандартных шаблонов книг и листов

Храните стандартные шаблоны для новых книг и листов в папке XLStart, полный путь к которой обычно выглядит
C:\операционная_система\Profiles\имя_пользователя\Application Data\Microsoft\Excel\XLStart
где операционная_система — папка операционной системы, например Windows. Если шаблон с именем Book.xlt или Sheet.xlt создан и сохранен в папке XLStart, то Microsoft Excel использует его для создания новых стандартных книг или для вставки новых листов после выполнения команды Лист в меню Вставка. Для использования шаблонов, сохраненных в файле, размещенном в сети, это размещение указывается в качестве дополнительной папки автозагрузки. Пользовательские шаблоны хранятся в папке XLStart или в дополнительной папке автозагрузки. Имена этих папок показаны на вкладке Общие в диалоговом окне Создать (меню Файл).

Хранение пользовательских шаблонов

Сохраняйте созданные пользовательские шаблоны книг в папке «Шаблоны», расположенной обычно
C:\операционная_система\Profiles\имя_пользователя\Application Data\Microsoft\Templates
где операционная_система — это папка операционной системы, например Windows. Файлы шаблонов (.xlt), сохраненные в папке «Шаблоны», указываются на вкладке Общие диалогового окна Создать (меню Файл). Встроенные шаблоны выводятся на вкладке Решения. Чтобы сгруппировать пользовательские шаблоны на отдельной вкладке, следует сохранить их в каталоге, расположенном внутри папки «Шаблоны». Любой файл книги Microsoft Excel (.xls), сохраненный в папке «Шаблоны» или в одной из папок, расположенных внутри нее, также действует как шаблон.

При работе с Microsoft Windows 95 (или более поздней версии) или Windows NT версии 4.0 (или более поздней версии) имеется возможность сделать пользовательский шаблон доступным остальным пользователям с помощью размещения его в сети. Например, все пользователи рабочей группы, занимающиеся определенным проектом, должны иметь доступ к шаблону без необходимости хранения его копии на своих компьютерах. Для этого шаблон следует поместить в папку в сети, сделав его, тем самым, доступным для всех пользователей группы. Затем требуется создать ярлык для папки или шаблона, а пользователи, в свою очередь, должны поместить этот ярлык в свою папку «Шаблоны».


 Параметры, сохраняемые в шаблоне

Параметры, сохраняемые в шаблоне

Параметры, сохраняемые в шаблоне, определяют следующие свойства новых книг и листов, основанных на шаблоне:

Форматирование

  • Форматы ячеек и листов, устанавливаемые с помощью команд меню Формат.

  • Форматы страниц и параметры области печати для каждого листа.

  • Стили ячеек.

  • Число и тип листов в книге.

  • Защищенные и скрытые области книги. Например, имеется возможность скрыть страницы, строки и столбцы и, тем самым, предотвратить внесение в ячейки листа каких-либо изменений.

Повторяющиеся текстовые строки, данные, рисунки и формулы

  • Текст, который необходимо повторять в каждой книге или листе, например заголовки страниц и подписи строк и столбцов.

  • Данные, формулы, графика, диаграммы и другие данные, которые должны содержаться в создаваемой по данному шаблону книге.

Панели инструментов и параметры настройки

  • Пользовательские панели инструментов, макросы, гиперссылки и элементы ActiveX в формах. Чтобы пользовательская панель инструментов была доступна в новых книгах, основанных на шаблоне, следует присоединить ее к шаблону.

  • Параметры вычислений и просмотра, установленные с помощью команды Параметры (меню Сервис).


Использование Microsoft Office Binder

Microsoft Office Binder можно использовать для объединения связанных файлов в подшивки. Например, при если в отчет входят документы Microsoft Word, книги Microsoft Excel и слайды PowerPoint, их удобно поместить в подшивку, с тем чтобы работать со всеми файлами вместе. В подшивке можно выполнить следующее:

  • проверить орфографию во всем составном документе;

  • применить составной стиль;

  • осуществить сквозную нумерацию страниц в разнородных файлах (разделах подшивки);

  • напечатать весь документ целиком;

  • работать с каждым разделом отдельно;

  • выполнить предварительный просмотр или напечатать несколько выбранных разделов или всю подшивку;

  • напечатать единый заголовок или колонтитул для всех разделов подшивки или создать различные заголовки или колонтитулы для каждого раздела.

Чтобы запустить Office Binder, укажите на пункт Программы в меню Пуск Windows, затем — на пункт Средства Microsoft Office и выберите Microsoft Binder. Если команда Microsoft Binder или значок Binder отсутствуют, необходимо установить Office Binder.

Чтобы открыть новую подшивку, выберите в Office Binder команду Создать подшивку в меню Файл или просто откройте Office Binder. При работе в окне Office Binder в левой части окна отображаются все разделы, образующие текущую подшивку, а в правой части — активный раздел. В подшивку можно добавить пустые новые файлы или уже существующие. Чтобы добавить существующий файл, перетащите его с помощью мыши из проводника Windows в левую часть окна Office Binder или выберите команду Добавить из файла в меню Раздел.


 Присвоение имен книгам

Присвоение имен книгам

Длинные описательные имена файлов используются для упрощения операции поиска необходимых книг. Полный путь к файлу, включая имя устройства, имя сервера, путь к папке, имя файла и его трехсимвольное расширение, может содержать до 218 символов. Имена файлов не должны включать ни один из следующих символов: косая черта (/), обратная косая черта (\), знак «больше» (>), знак «меньше» (<), звездочка (*), вопросительный знак (?), двойные кавычки ("), вертикальная черта (|), двоеточие (:) или точка с запятой (;).

Если используются программы, не поддерживающие длинные имена файлов, то следует ограничить длину имени восемью символами.


Сохранение книги

При первом сохранении книги указывается имя файла и место, куда он будет помещен. Во время каждого последующего сохранения книга будет обновляться в соответствии с внесенными в нее изменениями.

Примечание. Имеется возможность использования книги Microsoft Excel 2000 в более ранней версии Microsoft Excel или в другой программе, сохранив эту книгу в формате, который программа может открыть. Для получения более подробных сведений нажмите кнопку [image] .

Предполагаемые действия

Сохранение новой книги, не имеющей имени

Сохранение существующей книги

Сохранение копии книги с другим именем или в другом каталоге

Автоматическое сохранение книг в процессе работы

Сохранение предыдущей версии книги в качестве резервной копии

Сохранение данных Excel в виде Web-страницы


 Создание резервной копии книги

Создание резервной копии книги

  1. В меню Файл выберите команду Сохранить как.

    Демонстрация

  2. В меню Сервис выберите команду Общие параметры.

  3. Установите флажок Всегда создавать резервную копию.

  4. Нажмите кнопку OK, а затем кнопку Сохранить.


 Автоматическое сохранение книг в процессе работы

Автоматическое сохранение книг в процессе работы

  1. Выберите команду Автосохранение в меню Сервис.

    Если в меню Сервис команда Автосохранение отсутствует, то необходимо установить надстройку " Автосохранение" .

    Инструкции

  2. Установите флажок Сохранять каждые.

  3. В поле минут введите интервал времени, через который Microsoft Excel периодически будет сохранять книги.

  4. Выберите любые необходимые параметры.


Рекомендации по сохранению или опубликованию Web-страницы

Перед сохранением или опубликованием книги или листа Excel в виде Web-страницы следует учесть некоторые соображения.

Предполагаемые действия.

Сведения о требованиях, которые необходимо выполнить для размещения данных Excel на Web-странице

Подготовка данных перед размещением их на Web-странице

Сведения об ограничениях на размещение данных Excel на Web-странице


 Сохранение книги для использования в другом приложении

Сохранение книги для использования в другом приложении

Внимание! При сохранении книги Microsoft Excel 2000 в другом формате все свойства, специфичные для книг Excel 2000, будут утеряны. См. сведения о параметрах форматирования и свойствах, не сохраняющихся при преобразовании файлов.

  1. Откройте книгу, которую нужно сохранить для использования в другом приложении.

  2. В меню Файл выберите команду Сохранить как.

    Демонстрация

  3. Введите новое имя книги в поле Имя файла.

  4. Выберите формат файлов, с которым может работать другое приложение, из списка Тип файла.

  5. Нажмите кнопку Сохранить.


 Создание копии книги

Создание копии книги

  1. Откройте книгу, копию которой нужно создать.

  2. Выберите команду Сохранить как в меню Файл.

    Демонстрация

  3. Введите новое имя книги в поле Имя файла.

  4. Нажмите кнопку Сохранить.

Совет. Чтобы сохранить копию книги в другой папке, выберите диск и папку в поле Папка. Чтобы сохранить копию в новой папке, нажмите кнопку Создать папку [image].


Закрытие книги

  • Выберите команду Закрыть в меню Файл.

    Чтобы закрыть все открытые книги без выхода из программы, нажмите клавишу SHIFT и, не отпуская ее, выберите команду Закрыть все в меню Файл.


Сохранение группы книг в пользовательской рабочей области

Путем создания файла рабочей области достигается возможность открытия нескольких книг за один шаг. Этот файл хранит информацию обо всех открытых книгах, например, их расположение, размеры окон и позиции относительно экрана. При открытии файла рабочей области с помощью команды Открыть (меню Файл) Microsoft Excel открывает все книги, сохраненные в рабочей области. Этот файл не содержит самих книг, и, поэтому, необходимо сохранять изменения отдельно для каждой книги.

  1. Откройте книги, которые должны открываться в качестве группы.

  2. Измените размеры окон книг и разместите их так, как они должны появляться при дальнейшем их использовании.

  3. Выберите команду Сохранить рабочую область в меню Файл.

  4. В поле Имя файла введите имя файла рабочей области.

Совет. Чтобы при каждом запуске Microsoft Excel открывать необходимые книги, сохраните файл рабочей области в папке XLStart, расположенной в папке Microsoft Excel. В папке XLStart следует сохранять только файл рабочей области, а не сами файлы книг.


 Изменение стандартного формата файлов для сохранения книг

Изменение стандартного формата файлов для сохранения книг

По умолчанию книги сохраняются в формате Microsoft Excel 97-2000. Если необходимо работать с более ранними версиями Microsoft Excel или с другими электронными таблицами, то существует возможность изменения этого формата. Для получения более подробных сведений нажмите кнопку [image] .

  1. В меню Сервис выберите команду Параметры и откройте вкладку Переход.

  2. Выберите нужный формат файла из списка Сохранять файлы Excel как.

    После установления стандартного формата файлов все книги будут сохраняться в этом формате, если только при сохранении книги в диалоговом окне Сохранить как (меню Файл) не будет указан другой формат.

Примечание. Свойства и элементы форматирования книги Microsoft Excel 2000 могут быть недоступны, если она сохранена в формате более ранней версии Microsoft Excel или формате другой программы.


 Копирование файла

Копирование файла

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск или папку, содержащую копируемый файл.

  3. В списке папок дважды щелкните папку, в которой находится нужный файл.

    Если файла нет в папках, указанных в списке, можно воспользоваться процедурой поиска файлов.

    Инструкции

  4. Щелкните правой кнопкой мыши файл, который необходимо скопировать, а затем в контекстном меню выбрать команду Копировать.

  5. В поле Папка выберите диск или папку, в которую необходимо скопировать файл.

  6. Выберите из списка папку, в которую нужно скопировать файл.

  7. Убедитесь, что не выбрано никаких файлов, а затем в контекстном меню выберите команду Вставить.

    Если в списке выбран какой-нибудь файл, то команда Вставить недоступна.


 Удаление файла

Удаление файла

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск или папку с файлом, который нужно удалить.

  3. В списке папок дважды щелкните папку, в которой находится нужный файл.

    Если файла нет в папках, указанных в списке, можно воспользоваться процедурой поиска файлов.

    Инструкции

  4. Щелкните правой кнопкой мыши удаляемый файл и затем в контекстном меню выберите команду Удалить.

Примечание. Чтобы одновременно удалить несколько идущих подряд файлов, щелкните имя первого файла, затем, нажав клавишу SHIFT, щелкните имя последнего файла и нажмите клавишу DELETE. Чтобы удалить несколько файлов, расположенных в разных частях списка, щелкните имя одного файла, затем, нажав клавишу CTRL, щелкните имена всех требуемых файлов и нажмите клавишу DELETE. Если файл выбран ошибочно, нажмите клавишу CTRL и снова щелкните имя файла.


 Перемещение файла

Перемещение файла

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск или папку, содержащую файл, который необходимо переместить.

  3. В списке папок дважды щелкните папку, в которой находится нужный файл.

    Если файла нет в папках, указанных в списке, можно воспользоваться процедурой поиска файлов.

    Инструкции

  4. Щелкните правой кнопкой мыши файл, который необходимо переместить, а затем в контекстном меню выберите команду Вырезать.

  5. В поле Папка выберите диск или папку, в которую необходимо скопировать файл.

  6. Выберите из списка папку, в которую необходимо переместить файл.

  7. Убедитесь, что не выбрано никаких файлов, а затем в контекстном меню выберите команду Вставить.

    Если в списке выбран какой-нибудь файл, то команда Вставить недоступна.


 Переименование файла

Переименование файла

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск или папку, содержащую файл, который необходимо переименовать.

  3. В списке папок дважды щелкните папку, в которой находится нужный файл.

    Если файла нет в папках, указанных в списке, можно воспользоваться процедурой поиска файлов.

    Инструкции

  4. Щелкните правой кнопкой мыши файл, который необходимо переименовать, затем в контекстном меню выберите команду Переименовать.

  5. Введите новое имя файла и нажмите клавишу ENTER.

Примечание. Переименование открытого файла невозможно.


 Где лучше всего держать книги

Где лучше всего держать книги

При первом открытии диалоговых окон Открытие документа и Сохранить как после запуска Microsoft Excel, в качестве стандартной рабочей, или активной, папки отображается папка Мои документы (Личная папка в Windows NT 4.0). Изменение используемой по умолчанию рабочей папки.

Папка Мои документы (Личная папка в Windows NT 4.0)

Папка Мои документы находится в корневом каталоге (Личная папка в Windows NT 4.0 обычно находится по адресу C:\Winnt\Profiles\имя_пользователя) и является оптимальным местом для хранения книг, баз данных, документов, презентаций и других файлов, которые используются в текущее время. Для быстрого доступа к файлам, находящимся в папке Мои документы (Личной папке в Windows NT 4.0), нажмите кнопку Открыть, а затем нажмите кнопку Мои документы (Личная папка в Windows NT 4.0) на панели адресов.

Папка Избранное

Папка Избранное является оптимальным местом для хранения ярлыков для часто используемых файлов и папок, в том числе для файлов и папок, расположенных по удаленным адресам в сети. Ярлык обеспечивает быстрый доступ к любому файлу, при этом нет необходимости помнить его местоположение. При создании ярлыка в папке Избранное не происходит перемещения исходного файла или папки. Для быстрого доступа к файлам в папке Избранное нажмите кнопку Открыть, а затем нажмите кнопку Избранное на панели адресов. См. сведения о добавлении ярлыка для файла или папки в папку Избранное.

Web-папки

Web-папки являются оптимальным местом для хранения файлов, предназначенных для публикации в Интернете. Эти файлы находятся на Web-сервере для обеспечения доступа к ним других пользователей. Для быстрого доступа к файлам, хранящимся на Web-сервере, нажмите кнопку Web-папки на панели адресов. См. сведения о публикации файлов в Web.


О выборе рабочей папки для использования по умолчанию в диалоговых окнах «Открытие документа» и «Сохранение документа»

Изменение рабочей папки, используемой по умолчанию в Microsoft Excel. При работе в Windows или в Windows NT Workstation 4.0 можно изменить рабочую папку, которая будет использоваться по умолчанию только в Excel. Однако после выбора новой рабочей папки для одного из приложений Office в системе Windows NT Workstation 4.0, изменение используемой по умолчанию рабочей папки для всех приложений Office становится невозможным.

Изменение рабочей папки, используемой по умолчанию приложениями Office. Если ни для одного отдельного приложения Office не задавалась новая папка, которая должна использоваться по умолчанию, можно выбрать новую рабочую папку, которая будет использоваться по умолчанию всеми приложениями Office при выборе кнопки или команды Открыть документ Office. Для этого следует соответствующим образом переименовать или переместить папку «Мои документы».


Изменение установленной по умолчанию активной папки для Office

  1. Сначала сохраните и закройте все файлы Office, а затем закройте все программы Office.

  2. Для быстрого поиска файлов в проводнике Windows переместите или скопируйте их в папку Мои документы (Личная папка в Windows NT 4.0).

  3. Чтобы переименовать папку Мои документы, выберите ее в проводнике, а затем в контекстном меню выберите команду Переименовать. Введите новое имя папки и нажмите клавишу ENTER.

  4. Чтобы переместить папку Мои документы, в проводнике Windows перетащите эту папку на новое место.


 Изменение устанавливаемой по умолчанию текущей папки только для Microsoft Excel

Изменение устанавливаемой по умолчанию текущей папки только для Microsoft Excel

  1. Выберите команду Параметры в меню Сервис, а затем выберите вкладку Общие.

  2. В поле Рабочий каталог введите путь к папке, которая по умолчанию должна выводиться на экран как текущая.

    Например, введите c:\work


 Создание ярлыков для файлов, папок и Web-страниц

Создание ярлыков для файлов, папок и Web-страниц

Ярлыки для файлов, папок или Web-страниц могут быть созданы с помощью гиперссылок и папки «Избранное».

Гиперссылки Можно добавить гиперссылку в книгу и затем использовать ее для перехода во множество мест — например, к документу Microsoft Word, к другой книге Microsoft Excel, в Интернет, во внутреннюю сеть предприятия или по адресу электронной почты. Гиперссылка может быть создана из любого текста или рисунка в книге. Можно также назначить гиперссылку кнопке панели инструментов так, чтобы нажатие этой кнопки приводило к переходу к определенному файлу, Web-странице или адресу электронной почты, которыми пользуются наиболее часто.

Папка Избранное Можно использовать папку Избранное для хранения ярлыков для файлов и папок, которыми пользуются наиболее часто, включая и те, что находятся в удаленной сети. Нет необходимости перемещать или копировать оригиналы — вместо этого создается ярлык для перехода к ним. Хранение ярлыков в папке «Избранное» дает быстрый доступ к любому файлу без необходимости запоминать где этот файл находится.

Для быстрого доступа к файлам в папке «Избранное» нажмите кнопку Избранное [image] на панели адресов в диалоговом окне Открыть или выберите меню Избранное на панели инструментов Web и затем выберите команду Открыть папку "Избранное".

Можно добавить ярлык для текущего файла в папку «Избранное».


Создание ярлыков для файлов, папок и Web-страниц

Предполагаемые действия

Создание гиперссылок в книге

Назначение гиперссылки кнопке на панели инструментов

Создание ярлыка для каталога или файла в папке «Избранное»

Добавление активного файла в папку «Избранное»

Не можете сделать выбор?


Просмотр и сохранение файлов других приложений

Открытие и сохранение файла, созданного в другом приложении. Файл, созданный в другом приложении, например Quattro Pro или Lotus 1-2-3, можно открыть с помощью команды Открыть из меню Microsoft Excel Файл. Затем файл можно сохранить в исходном формате или сохранить файл как книгу Excel.

Существует возможность открытия файлов Quattro Pro версий более ранних, чем 5.0, с помощью конвертера Quattro Pro; также можно открывать файлы Lotus 1-2-3 версий более ранних, чем 5.0.

Сохранение книги для использования в другом приложении. С помощью команды Сохранить как из меню Файл можно сохранить книгу Excel для использования в другом приложении. Файлы, сохраненные как книги Excel, могут утрачивать некоторые исходные параметры форматирования, а свойства и параметры форматирования книги Excel 2000 могут быть недоступны в предыдущих версиях или других приложениях. См. сведения о возможностях, которые утрачиваются при сохранении файла в другом формате.

Открытие текстового файла в Excel. Если данные, которые требуется использовать в Excel, имеют текстовый формат с разделением данных символами табуляции, запятыми, пробелами или подобными символами, можно просто открыть соответствующий файл в Excel. Excel использует мастер текста для интерпретации текста в соответствии с инструкциями пользователя и распределяет данные по строкам и столбцам листа. Также возможно копирование разделенных текстовых данных из текстового или другого документа в книгу и их разбиение на столбцы. Инструкции по открытию текстового файла в Microsoft Excel.

Также существует возможность обновления данных из текстового файла.

Копирование данных из другого приложения и вставка их в Excel. Если требуется использовать только некоторую часть текста из текстового файла, можно скопировать нужные данные в Excel, а затем разбить скопированные текстовые данные на столбцы.

Примечания

  • Изменение формата файлов, используемого для сохранения книг по умолчанию. Если другие пользователи используют более ранние версии Excel или другие редакторы электронных таблиц, можно изменить формат файлов, используемый по умолчанию для сохранения книг, создаваемых в Excel 2000, чтобы другие пользователи могли работать с вашими файлами.

  • Установка конвертера файлов Quattro Pro. Если конвертер файлов Quattro Pro не был установлен при установке Excel, его необходимо установить перед открытием файлов этого формата. Использовать конвертер Quattro Pro для сохранения файлов невозможно.


 Открытие файла в другом формате и сохранение его в формате книги Microsoft Excel

Открытие файла в другом формате и сохранение его в формате книги Microsoft Excel

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск, папку или адрес ресурса Интернета, содержащего файл, который требуется открыть.

  3. Выберите текущий формат файлов из списка Тип файлов.

  4. Найдите нужный файл, а затем выполните одно из следующих действий.

    Если в последний раз файл был сохранен в другом приложении Office, щелкните стрелку рядом с кнопкой Открыть и выберите Открыть в Microsoft Excel.

    Если файл в последний раз был сохранен не в приложении Office, дважды щелкните файл.

    Файл будет открыт в Excel, но фактический формат файла не будет изменен на .xls.

  5. Выберите команду Сохранить как в меню Файл.

    Демонстрация

  6. В списке Тип файла выберите Книга Microsoft Excel (*.xls).

  7. Нажмите кнопку Сохранить.

Советы

  • Для сохранения изменений в файле в его первоначальном формате, нажмите кнопку Сохранить [image] вместо выбора команды Сохранить как из меню Файл и подтвердите замену существующей версии файла.

  • Если открыть файл в Excel не удается из-за недоступности соответствующего конвертера, откройте файл в том приложении, в котором он был создан, а затем сохраните файл в формате, который может быть открыт в Excel — например, как текстовый файл.

  • Для открытия файла другого приложения можно также выбрать команду Найти из меню Сервис (меню Файл, команда Открыть), а затем выполнить поиск нужного файла. Например, для того чтобы найти файл Lotus 1-2-3, выберите Тип файлов в списке Свойство, а затем Файлы Lotus 1-2-3 в списке Отношение. Удалите все элементы из поля Найти файлы, отвечающие набору условий, нажмите кнопку Добавить, а затем кнопку Найти.


 Открытие файла HTML в Microsoft Excel

Открытие файла HTML в Microsoft Excel

При открытии Web-страниц в Excel для анализа данных содержимое может отображаться в Excel не так, как на Web-странице. Например, сценарии, файлы изображений формата .gif и списки данных в одной ячейке таблицы не отображаются в Excel должным образом. Наилучшие результаты достигаются в случаях, когда Web-страница изначально представляла собой книгу Excel, сохраненную в виде Web-страницы, или когда данные находятся в таблице.

  1. В Excel нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск, папку, папку Web, Web-сервер или адрес FTP, содержащий файл HTML, который требуется открыть.

  3. Дважды щелкните файл HTML, который требуется открыть.

Примечание. Для того чтобы открыть недавно использовавшийся файл, хранящийся на Web-сервере, щелкните ярлык Журнал на панели адресов или Web-папки (в Microsoft Windows 2000 — My Network Places).


 Конвертеры форматов файлов, поставляемые вместе с Microsoft Excel

Конвертеры форматов файлов, поставляемые вместе с Microsoft Excel

Перечень форматов файлов в диалоговом окне Сохранение документа, изменяется в зависимости от типа активного листа: электронная таблица, диаграмма или другой тип листа. Для большинства форматов файлов Microsoft Excel преобразовывает только активный лист. Для преобразования остальных листов следует перейти на каждый лист сохранить его отдельно.

Microsoft Excel содержит большинство необходимых конвертеров. Если нужный формат файлов отсутствует в диалоговом окне Открытие документа (меню Файл), можно установить соответствующий конвертер. Для получения дополнительных сведений нажмите кнопку [image] .

Форматы Microsoft Excel

При выборе формата «Книга Microsoft Excel 97-2000 & 5.0/95» в одном файле .xls сохраняется книга в форматах Excel версий 97-2000 и Excel версий 5.0/95. Пользователи Microsoft Excel 2000 могут продолжать работу с такой книгой и использовать все возможности или параметры форматирования, уникальные для этой версии. Пользователи Microsoft Excel версии 5.0 или Microsoft Excel 95 могут открывать и использовать такую книгу без необходимости преобразовывать файл; для них рекомендуется использовать книгу только для чтения. В случае сохранения такой книги в более ранней версии Microsoft Excel возможности и форматирование, уникальные для Microsoft Excel 2000, утрачиваются. Для получения дополнительных сведений нажмите кнопку [image] .

Форматы для сохранения книг | Расширение имени файла (только Windows)
Книга Microsoft Excel (Microsoft Excel 97-2000) | .xls
Шаблон (Microsoft Excel 97-2000) | .xlt
Рабочие области (Microsoft Excel 97-2000) | .xlw
Книга Microsoft Excel 97-2000 & 5.0/95 | .xls
Книга Microsoft Excel 5.0/95 | .xls
Книга Microsoft Excel 4.0 (сохраняются только листы электронных таблиц, диаграмм и макросов) | .xlw
Форматы для сохранения только активного листа
Форматы листа Microsoft Excel версии 4.0 (включая макрос Microsoft Excel и международные листы макросов) | .xls, .xlc, .xlm
Форматы Microsoft Excel версии 3.0 | .xls, .xlc, .xlm
Форматы Microsoft Excel версии 2.x | .xls, .xlc, .xlm

Форматы файлов для Lotus 1-2-3

При открытии файла .wk1 или .wk3 Microsoft Excel использует элементы форматирования в связанном файле .fmt, .fm3 или .all. Если файл Lotus 1-2-3 сохраняется в формате Microsoft Excel, то Microsoft Excel сохраняет данные электронной таблицы и форматирование в одном файле книги.

В форматах WK1 (1-2-3) (*.wk1) и WK3 (1-2-3) (*.wk3) сохраняются не все элементы форматирования электронной таблицы. Чтобы записать книгу Microsoft Excel в формате Lotus 1-2-3 с сохранением границ, заливки ячеек, шрифтов и другого форматирования, выберите формат Lotus 1-2-3, сохраняющий форматирование в отдельном файле .fmt, .fm3 или .all.

Формат файла Lotus 1-2-3 | Версия | Примечания
WK4 (*.wk4) | 4.0 | Сохраняет книгу целиком
WK3 (*.wk3) WK3, FM3 (*.wk3) | 3.x и Lotus 1-2-3/W | Сохраняет только листы электронных таблиц и диаграмм
WK1 (*.wk1) WK1 (FMT) (*.wk1) WK1 (ALL) (*.wk1) | 2.x | Сохраняет только активный лист
WKS (FMT) (*.wks) | 1.0 и 1.0A | Сохраняет только активный лист
.pic (когда включен в файл .all) | 3.x и Lotus 1-2-3/W | Открывает, но не может сохранить этот формат

Форматы текстовых файлов

Существует возможность открытия и сохранения файлов следующих текстовых форматов. При сохранении книги в текстовом формате теряются все элементы форматирования.

Формат | Примечания
Форматированный текст (разделитель - пробел) (*.prn) | Формат Lotus с разделителем - пробелом Сохраняет только активный лист
Текст (с разделителями табуляции) (*.txt) (Windows) Текст (Macintosh) Текст (OS/2 или MS-DOS) CSV (разделители - запятые) (*.csv) (Windows) CSV (Macintosh) CSV (OS/2 или MS-DOS) | При сохранении книги в виде текстового файла с разделением запятыми или знаками табуляции для использования в другой операционной системе выберите соответствующий конвертер, чтобы гарантировать корректную интерпретацию знаков табуляции, разрывов строк и других символов. Сохраняет только активный лист.
DIF (формат обмена данными) (*.dif) | Сохраняет только активный лист
SYLK (формат символьной связи) (*.slk) | Сохраняет только активный лист

Другие электронные таблицы и базы данных

Формат | Программа | Примечания
DBF 2, DBF 3, DBF 4 (*.dbf) | DBASE II, III и IV | Открывает и сохраняет только активный лист
WQ1 (*.wq1) | Quattro Pro для MS-DOS | Открывает и сохраняет только активный лист
.wb1 | Quattro Pro версии 5.0 для Windows | Только открывает
.wb2 | Quattro Pro версии 6.0 для Windows | Только открывает
.wb3 | Quattro Pro версии 7.0 для Windows | Только открывает
.wks | Microsoft Works версии 2.0 для Windows и Microsoft Works для MS-DOS | Открывает только электронные таблицы Microsoft Works версии 2.0 для Windows или Microsoft Works для MS-DOS

Форматы буфера обмена

Следующие форматы буфера обмена вставляются в Microsoft Excel с помощью команды Вставить или Специальная вставка из меню Правка.

Формат | Типы буфера обмена
Рисунок | Рисунок (метафайл Windows, EMF) Примечание. При копировании метафайла Windows (WMF) из другой программы Microsoft Excel вставляет элемент в качестве метафайла (EMF).
Точечный рисунок | Точечный рисунок (BMP)
Форматы файлов Microsoft Excel | Форматы двоичных файлов для Microsoft Excel версий 3.0, 4.0, 5.0/95 и Microsoft Excel 97-2000(BIFF, BIFF3, BIFF4, BIFF5 и BIFF8)
Формат SYLK | SYLK
Формат Lotus 1-2-3 версии 2.x | .wk1
Формат обмена данными | .dif
Текстовый формат (с разделителями табуляции) | Текстом
Формат с разделителями - запятыми | .csv
Форматированный текст (только из Microsoft Excel) | RTF
Внедренный объект | Объекты Microsoft Excel, объекты корректно зарегистрированных программ, поддерживающих OLE 2.0, а также «Рисунок» или другой формат представления
Связанный объект | OwnerLink, ObjectLink, Link, Picture или другой формат
Рисованный объект Office | Формат рисованного объекта Office или «Рисунок (EMF)»
Текстом | Отображаемый текст, текст OEM
HTML | .htm Примечание. При копировании текста из другой программы Microsoft Excel вставляет этот текст в формате HTML, независимо от формата исходного текста.


Непреобразуемые свойства и форматы документов

В файле книги Microsoft Excel 2000 сохраняются не только данные листа и диаграммы, но и форматы, макросы и другие свойства. Поскольку в других форматах возможность хранения таких сведений не предусмотрена, то при сохранении книги, созданной в Microsoft Excel 2000, часть этих данных может быть утрачена.

Возможные форматы сохраняемого файла

Excel

Книга Microsoft Excel 97-2000 & 5.0/95

Открытие и сохранение книги Excel 2000 в Excel 97

Книга Microsoft Excel 5.0/95

Книга Microsoft Excel 4.0

Лист Microsoft Excel 4.0

Лист Microsoft Excel 3.0

Лист Microsoft Excel 2.x

Lotus

Формат Lotus 1-2-3 версии 4 (WK4)

Формат Lotus 1-2-3 версии 3 (WK3)

Формат Lotus 1-2-3 версии 3 (WK3, FM3)

Lotus 1-2-3 версии 2.x (WK1)

Lotus 1-2-3 версии 2.x (WK1, FMT)

Lotus 1-2-3 версии 2.x (WK1, ALL)

Lotus 1-2-3 версии 1.x (WKS)

Другие

Формат HTML

Quattro Pro для MS-DOS (WQ1)

Форматы файла dBASE (DBF 2, DBF 3, DBF 4)

Формат SYLK (Symbolic Link)

Формат DIF (Data Interchange Format)

Формат CSV (разделители — запятые) (*.csv)

Текстовый формат (разделители — символы табуляции) (*.txt)

Формат текст Юникод

Форматированный текст (разделители — пробелы)

Шаблон

Примечание. Для преобразования книги Excel в формат Microsoft Multiplan рекомендуется воспользоваться форматом SYLK (Symbolic Link), поскольку сам Excel 2000 не содержит средств прямого преобразования в формат Multiplan.


Перемещение файлов между Microsoft Windows и Macintosh

На компьютере Macintosh необходимо наличие системного программного обеспечения версии 7.5 или более поздней, установленного программного обеспечения PC Exchange, а также дисковода, позволяющего работать с дискетами формата MS-DOS. Версия Microsoft Excel для Macintosh должна соответствовать версии Microsoft Excel для Windows. Например, для перемещения файлов Microsoft Excel 2000 на Macintosh необходимо использовать Microsoft Office 98, выпуск для Macintosh.

  1. Сохраните файл Windows на дискете.

  2. Вставьте дискету в дисковод Macintosh.

  3. В Excel для Macintosh выберите команду Open в меню File.

  4. Найдите и дважды щелкните нужный файл.

Примечания

  • При наличии доступа к общей сети, к которой подсоединены компьютеры, работающие под управлением Windows, и компьютеры Macintosh, можно поместить файлы в сеть, а затем открыть их на любом из компьютеров. Также можно легко перемещать файлы между Windows и Macintosh при наличии доступа к серверу Windows NT, на котором установлены соответствующие службы для Macintosh. Дополнительные сведения содержатся в документации по Windows NT.

  • Фильмы в формате QuickTime можно просматривать только на Macintosh. Такие возможности Microsoft Excel, как построение карт, мастер Web-форм, конвертеры Quattro Pro и надстройка AccessLinks не доступны в версии для Macintosh.

  • Поскольку файлы Macintosh не имеют расширений, для поиска файлов следует использовать подстановочные символы *.*.


Разрешение вопросов, связанных с поиском и открытием файлов

В чем именно заключаются сложности?

При использовании сохраненных условий поиска многие из ранее найденных файлов не были обнаружены

При поиске выводятся неверные имена файлов

Поиск файлов занимает много времени

В диалоговом окне Открытие файла имя искомого файла не отображается

Пароль, введенный при открытии файла, не принят

В качестве начальной страницы установлен файл Office; требуется установить в качестве начальной страницы файл HTML

При попытке открытия в Excel файла HTML этот файл открывается в другой программе Office

При открытии Web-страницы в Excel страница не отображается

Книга открывается только для чтения

Открытие книги занимает много времени


Разрешение вопросов, связанных с сохранением и закрытием книг

В чем именно заключаются сложности?

Формат файла, в котором должна быть сохранена книга, не появляется в диалоговом окне Сохранить как

При попытке сохранения книги на экране появляется сообщение о том, что книга доступна только для чтения

При сохранении книги автоматически добавляется расширение .xls

Сохраненный файл содержит две точки в имени файла


Разрешение вопросов: шаблоны

В чем именно заключаются сложности?

Шаблон отсутствует в диалоговом окне Создание документа

Восстановление исходных параметров для новых книг и листов

Файл, сохраненный с расширением .xlt, невозможно использовать в качестве шаблона.

Книга не использует режим вычислений, сохраненный в шаблоне, на котором она была основана.


Разрешение вопросов по преобразованию форматов файлов

В чем именно заключаются сложности?

До преобразования файлов

Ограничения на открытие и преобразование файлов Quattro Pro в Microsoft Excel

В диалоговом окне Открыть имя искомого файла не отображается.

Не удается открыть файл, созданный в Microsoft Works.

Открытие файлов, созданных в Quattro Pro

Преобразование электронных таблиц форматов Lotus 1-2-3 и Microsoft Excel

После преобразования файлов

Преобразованный файл имеет очень большой размер и открывается очень долго.

Значения преобразованного листа отличаются от значений исходного листа.

Некоторые формулы были заменены на текст или значения.

Макросы Lotus 1-2-3 и Quattro Pro не выполняются в Microsoft Excel

Весь текст в файле появляется в одном столбце

При сохранении данных в формате dBASE некоторые данные исчезают


Не удается открыть Web-страницу в Excel

В Microsoft Excel не будет открываться созданная в другом приложении Web-страница, если она содержит рамки. Рамками называются разделы Web-страницы, которые сами, в свою очередь, являются самостоятельными Web-страницами. Страницу, на которой расположена группа таких страниц в рамках, называют страницей с рамками. Открытие подобных страниц в Excel невозможно.

Если имеются навыки работы с исходным текстом на языке HTML, можно в соответствующем редакторе скопировать нужные данные (без рамок) в новый файл. Этот файл будет открываться в Excel.


 Общие сведения о книгах и листах Microsoft Excel

Общие сведения о книгах и листах Microsoft Excel

Книги Книга в Microsoft Excel представляет собой файл, используемый для обработки и хранения данных. Каждая книга может состоять из нескольких листов, поэтому в одном файле можно поместить разнообразные сведения и установить между ними необходимые связи.

Листы Листы служат для организации и анализа данных. Можно вводить и изменять данные одновременно на нескольких листах, а также выполнять вычисления на основе данных из нескольких листов. При создании диаграммы ее можно поместить на лист с соответствующими данными или на отдельный лист диаграммы.

Вкладки листов Имена листов отображаются на вкладках в нижней части окна книги. Для перехода с одного листа на другой следует выбрать соответствующую вкладку.

Листы макросов и листы диалогов Работа с листами макросов и листами диалогов из более ранних версий Excel.


 Перемещение и прокрутка внутри листа

Перемещение и прокрутка внутри листа

Для перехода между ячейками листа используется мышь или клавиши со стрелками. При переходе на ячейку она становится активной. Для перехода в другую область листа используются полосы прокрутки.

Чтобы перейти | Сделайте следующее
На одну строку вверх или вниз | Нажмите кнопку на вертикальной полосе прокрутки.
На один столбец влево или вправо | Нажмите кнопку на горизонтальной полосе прокрутки.
На один экран вверх или вниз | Щелкните вертикальную полосу прокрутки выше или ниже бегунка.
На один экран влево или вправо | Щелкните горизонтальную полосу прокрутки слева или справа от бегунка.
На большое расстояние | Перетащите бегунок на нужную позицию. Если лист слишком большой, удерживайте при перетаскивании клавишу SHIFT.

Примечания

  • Размер бегунка показывает соотношение отображаемой части листа и общей используемой области. Положение бегунка указывает относительное положение видимой части на листе.

  • Для прокрутки и масштабирования листа Microsoft Excel также можно использовать указывающее устройство Microsoft IntelliMouse.


Переход на другой лист книги

  • Укажите ярлычок листа, содержащего нужные данные.

    Ярлычки листов. Лист2 выделен

    Если ярлычок нужного листа не виден, то для его отображения используйте кнопки прокрутки листов. Затем укажите необходимый ярлычок.

    Кнопки прокрутки ярлычков

Совет. Если в книге содержится большое количество листов, щелкните правой кнопкой мыши кнопку прокрутки ярлычков. Затем выберите в открывшемся списке необходимый лист.


 Выделение листов в книге

Выделение листов в книге

Если выделено несколько листов, изменения, сделанные на текущем листе, повторяются на всех остальных листах. Это может привести к потере данных.

Чтобы выделить | Сделайте следующее
Отдельный лист | Укажите ярлычок листа. Ярлычки листа. Лист2 выделен
Два или более смежных листа | Щелкните ярлычок первого листа, затем, удерживая клавишу SHIFT, щелкните ярлычок последнего листа.
Два или более несмежных листа | Щелкните ярлычок первого листа, затем, удерживая клавишу CTRL, щелкните ярлычки остальных листов.
Все листы книги | Установите указатель на произвольный ярлычок листа и нажмите правую кнопку мыши. Затем выберите команду Выбрать все листы в контекстном меню.


Изменение количества отображаемых ярлычков листов

  1. Установите указатель на маркер разделения области ярлычков.

    Маркер разделения области ярлычков

  2. Когда указатель превратится в двухстороннюю стрелку Двухсторонняя стрелка, переместите маркер разделения влево или вправо и затем используйте кнопки прокрутки для перехода между вкладками листов.

    Кнопки прокрутки ярлычков

    Чтобы вернуть маркер разделения в его исходное стандартное положение, дважды щелкните маркер разделения.

Совет Чтобы сделать лист активным, выбирая его из списка доступных листов, щелкните правой кнопкой мыши любую кнопку прокрутки ярлычков и выберите лист из контекстного меню.


 Прокрутка и масштабирование листа Microsoft Excel с помощью устройства указания Microsoft IntelliMouse

Прокрутка и масштабирование листа Microsoft Excel с помощью устройства указания Microsoft IntelliMouse

Microsoft IntelliMouse — это устройство типа «мышь», позволяющее выполнять прокрутку и изменение масштаба листа книги или диаграммы Microsoft Excel. Сведения о настройке устройства Microsoft IntelliMouse и разрешении вопросов, возникающих при работе с ним, можно найти в электронном руководстве IntelliPoint Online User's Guide. (Нажмите кнопку Пуск, выберите пункт Программы, затем Microsoft Input Devices.)

Чтобы | Сделайте следующее
Прокрутка на несколько строк вверх или вниз | Поворачивайте колесо вверх или вниз.
Панорамирование (прокрутка изображения вверх или вниз) | Удерживая колесо, перемещайте указатель мыши вверх или вниз относительно метки начала метка начала . С увеличением расстояния указателя от этой метки скорость прокрутки увеличивается.
Автоматическая прокрутка листа | Используйте колесо для прокрутки вниз. Для прокрутки вверх перемещайте указатель мыши вверх относительно метки начала на вертикальной полосе прокрутки. С увеличением расстояния указателя от этой метки скорость прокрутки увеличивается. Остановите автоматическую прокрутку нажатием любой кнопки мыши или клавиши на клавиатуре.
Уменьшение или увеличение масштаба | Поворачивайте колесо вперед или назад, одновременно удерживая клавишу CTRL.
Отображение подробных данных в структурах | Поместив указатель на ячейку суммирования данных структуры и удерживая клавишу SHIFT, поверните колесо вперед.
Скрытие подробных данных в структурах | Поместив указатель на ячейку подробных данных в структуре и удерживая клавишу SHIFT, поверните колесо назад.

Советы

  • Чтобы перейти в другое место листа Excel, уменьшите масштаб изображения, выберите новое местоположение на листе и увеличьте масштаб.

  • Если Microsoft IntelliMouse используется в основном для изменения масштаба, а не для прокрутки листа Excel, можно настроить колесо на панорамирование вместо прокрутки. Для этого в меню Сервис выберите команду Параметры, перейдите на вкладку Общие и установите флажок Панорамирование с помощью IntelliMouse.


Вставка нового листа

  • Чтобы добавить один лист, выберите команду Лист в меню Вставка.

    Чтобы вставить несколько листов, выберите необходимое количество листов, удерживая нажатой клавишу SHIFT, затем выполните команду Лист из меню Вставка.


Перемещение и копирование листов

Внимание! При перемещении и копировании листов следует быть осторожным, так как это может повлечь за собой появление неточностей в вычислениях или диаграммах, основанных на данных листа. Например, при размещении листа внутри трехмерного диапазона, на который ссылается формула, результат возвращаемый формулой может измениться.

  1. Откройте книгу, в которую нужно переместить или скопировать листы.

  2. Переключитесь в книгу, содержащую копируемые или перемещаемые листы, и выделите в ней нужные листы.

    Инструкции

  3. В меню Правка выберите команду Переместить/скопировать.

  4. Выберите соответствующую книгу в поле Переместить выбранные листы в книгу.

    Чтобы переместить или скопировать выбранные листы в новую книгу, выберите пункт Новая книга.

  5. В поле Перед листом выберите лист, перед которым нужно вставить перемещаемые или копируемые листы.

  6. Чтобы только скопировать, а не переместить листы, установите флажок Создавать копию.

Совет. Перемещать выбранные листы в пределах текущей книги можно перетаскивая их с помощью мыши вдоль ряда ярлычков листов. Чтобы копировать листы, нажмите и удерживайте клавишу CTRL, переместите листы в нужное положение, затем отпустите кнопку мыши и только после этого — клавишу CTRL.


Удаление листов из книги

  1. Выберите листы, которые нужно удалить.

    Инструкции

  2. Выберите команду Удалить лист в меню Правка.


 Переименование листа

Переименование листа

  1. Выберите двойным нажатием кнопки мыши нужный ярлычок листа.

  2. Введите новое имя поверх старого.


Скрытие книги или ее части

Когда скрывается часть книги, данные убираются из представления, но не удаляются из книги. Если книга сохранена и закрыта, скрытые данные остаются скрытыми при следующем открытии книги. Скрытые части книги на печать не выводятся.

Скрытие книг и листов Книги и листы можно скрыть для уменьшения числа окон и листов и предотвращения нежелательных изменений. Например, можно скрыть листы с важными данными или книгу, содержащую макросы. Макросы остаются доступными для выполнения, но для книги с макросами не появляется окно. Скрытая книга или лист остаются открытыми, другие документы могут использовать информацию, находящуюся в них.

Скрытие строк и столбцов Можно также скрыть выделенные строки или столбцы, которые не используются или которые не должны быть видны другим пользователям.

Использование пароля Чтобы предотвратить отображение скрытых листов, столбцов или строк, книга или лист могут быть защищены паролем.

Скрытие элементов окна Чтобы использовать максимальную площадь экрана для отображения данных на листе, большинство элементов окна может быть скрыто. Эти элементы окна включают панель задач Windows, заголовок окна Excel, панели инструментов, строку формул и строку состояния. Эти элементы остаются скрытыми пока книга открыта; после закрытия книги и ее повторного открытия эти элементы снова отображаются.

Дополнительные сведения

Скрытие книги

Скрытие листа

Скрытие строки или столбца

Защита книги или листа

Скрытие элементов экрана


Скрытие листа

  1. Выберите листы, которые нужно скрыть.

    Инструкции

  2. В меню Формат установите указатель на пункт Лист и выберите команду Скрыть.


Скрытие книги

  1. Откройте нужную книгу.

  2. Выберите команду Скрыть в меню Окно.

Примечание. При выходе из Microsoft Excel на вопрос о сохранении изменений в скрытой книге следует отвечать Да. При следующем открытии данная книга остается скрытой.


Отображение скрытой книги

  1. Выберите команду Показать в меню Окно.

  2. Выберите имя скрытой книги, которую нужно вывести на экран, в поле Показать скрытое окно книги.


Отображение скрытого листа

  1. Выберите в меню Формат команду Лист и подкоманду Отобразить.

  2. В окне Вывод на экран скрытого листа дважды щелкните имя скрытого листа, который требуется отобразить.

Примечание. Если листы были скрыты программой на Visual Basic для приложений (путем назначения свойства xlSheetVeryHidden), использование команды Показать не приведет к желаемому результату. При работе с книгой, которая содержит макросы на языке Visual Basic вопросы, связанные со скрытыми листами, следует разрешать с владельцем такой книги.


Отображение скрытых строк или столбцов

  1. Чтобы вывести на экран скрытые строки, выделите ячейки в строках над и под скрытыми строками.

    Чтобы вывести на экран скрытые столбцы, выделите ячейки в столбцах слева и справа от скрытых столбцов.

  2. В меню Формат установите указатель на пункт Строка или Столбец и выберите команду Показать.

Совет. Если первая строка или столбец листа являются скрытыми, выберите команду Перейти в меню Правка. В поле Ссылка введите A1 и нажмите кнопку OK. Установите указатель на пункт Строка или Столбец в меню Формат и выберите команду Показать.


Скрытие строки или столбца

  1. Выберите строки или столбцы, которые нужно скрыть.

    Инструкции

  2. В меню Формат установите указатель на пункт Строка или Столбец и выберите команду Скрыть.


Создание связей для присоединения данных и файлов

Предполагаемые действия

Создание гиперссылок

Создание связи с данными других файлов с использованием формул

Создание запроса для выборки данных из другого файла или базы данных

Обмен данными между программами Microsoft Office


 Вставка связи с данными листа во внутренней сети предприятия или Интернете

Вставка связи с данными листа во внутренней сети предприятия или Интернете

В книгу может быть вставлена связь с другой книгой, расположенной во внутренней сети предприятия или в Интернете. Книга должна быть файлом в формате .xls, а не файлом HTML.

  1. Выделите данные, которые необходимо скопировать в качестве связанного объекта.

  2. Нажмите кнопку Копировать [image] .

  3. Выберите лист, на который необходимо поместить данные, а затем выберите позицию, в которой данные должны находиться.

  4. В меню Правка выберите команду Специальная вставка.

  5. Установите переключатель в положение Связать.

    Примечание. Чтобы установить связь, не открывая книгу в Интернете, щелкните ячейку, которую требуется связать с книгой, и введите знак равенства (=) и адрес URL с указанием нужной области в книге. Например:
    ='[http://www.someones.homepage/file.xls]Лист1'!A1 или
    ='[ftp://ftp.server.somewhere/file.xls]Лист1'!ИменованныеЯчейки


 Обновление связи с данными внутренней сети предприятия или Интернета

Обновление связи с данными внутренней сети предприятия или Интернета

При открытии книги Microsoft Excel, содержащей связи, автоматически выдается запрос, предлагающий обновить все связи с данными Интернета или Web. С помощью этой процедуры можно загрузить в открытую книгу самую свежую версию связанных данных.

  1. В меню Правка выберите команду Связи.

    Недоступность команды Связи в меню означает, что данный файл не содержит связанных данных.

  2. Из списка Исходный файл выберите источник для связанного объекта, а затем выберите команду Обновить.

    Для выделения нескольких связанных объектов, удерживая нажатой клавишу CTRL, выберите каждый объекты.

Примечание. Чтобы прервать процесс обновления, выберите имя обновляемой связи в диалоговом окне Связи и нажмите кнопку Прервать.


 Настройка основных параметров книги или листа с помощью шаблона

Настройка основных параметров книги или листа с помощью шаблона

Можно создать шаблон для использования в книгах и листах, имеющих похожий формат и стили или содержимое и функциональность.

Предполагаемые действия.

Элементы форматирования и параметры, сохраняемые в шаблоне

Создание шаблона для новых книг

Создание шаблона для новых листов

Изменение формата или содержимого существующего шаблона

Не можете сделать выбор?


 Изменение количества листов, установленного по умолчанию

Изменение количества листов, установленного по умолчанию

  1. Выберите команду Параметры в меню Сервис, а затем выберите вкладку Общие.

  2. Введите нужное число листов в поле Листов в новой книге.


 Изменение шрифта и его размера, установленного по умолчанию в новых книгах

Изменение шрифта и его размера, установленного по умолчанию в новых книгах

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. В поле Стандартный шрифт выберите шрифт.

  3. В поле Размер выберите размер шрифта.

Примечание. Для использования по умолчанию нового шрифта и его размера необходимо перезагрузить Microsoft Excel. Установленные по умолчанию шрифт и размер используются только в новых книгах, создаваемых после перезапуска Microsoft Excel; изменение данных установок на существующие книги не влияет.


 Установка ширины столбца по умолчанию

Установка ширины столбца по умолчанию

  1. Для установки по умолчанию ширины столбцов всех листов в книге выделите все листы.

    Инструкции

  2. В меню Формат выберите команду Столбец, а затем — Стандартная ширина.

    Демонстрация

  3. Введите новое измерение.

    Число, показанное в поле Стандартная ширина столбца указывает среднее число символов 0-9 стандартного шрифта, необходимое для заполнения ячейки.

Совет. Для определения ширины столбца для всех новых книг и листов создайте шаблоны книги и листа. Для получения дополнительных сведений нажмите кнопку [image] .


 Создание шаблона для новых книг

Создание шаблона для новых книг

  1. Создайте книгу, содержащую листы, стандартный текст (например, заголовки страниц, подписи строк и столбцов), формулы, макросы, стили и другие элементы форматирования, которые должны быть в книгах, основанных на шаблоне.

  2. Выберите команду Сохранить как в меню Файл.

    Демонстрация

  3. В окне Тип файла выберите пункт Шаблон (*.xlt).

  4. В окне Папка укажите папку, в которой должен быть сохранен шаблон.

    Для создания шаблона по умолчанию выберите или папку XLStart, или дополнительную папку автозагрузки. Папка XLStart обычно находится в
    C:\операционная_система\Profiles\имя_пользователя\Application Data\Microsoft\Excel\XLStart
    где операционная_система — папка операционной системы, например Windows.

    Для создания пользовательского шаблона выберите папку «Шаблоны», которая находится обычно в
    C:\операционная_система\Profiles\имя_пользователя\Application Data\Microsoft\Templates
    где операционная_система — папка операционной системы, например Windows.

  5. В поле Имя файла введите Книга, чтобы создать стандартный шаблон книги.

    Для создания пользовательского шаблона введите любое допустимое имя файла.

    Совет. Чтобы просматривать рисунок первой страницы шаблона в поле Просмотр диалогового окна Создать (меню Файл), в меню Файл выберите команду Свойства, нажмите вкладку Документ, а затем установите флажок Создать рисунок для предварительного просмотра.


 Создание шаблона для новых листов

Создание шаблона для новых листов

  1. Создайте книгу, содержащую один лист. Поместите на этот лист элементы форматирования, стили, текст и другие данные, которые должны появляться на всех новых листах того же типа.

  2. Выберите команду Сохранить как в меню Файл.

    Демонстрация

  3. В поле Тип файла выберите пункт Шаблон (*.xlt).

  4. В поле Папка укажите папку, в которой должен быть сохранен шаблон.

    Для создания шаблона по умолчанию, выберите или папку XLStart, или дополнительную папку автозагрузки. Папка XLStart обычно находится в папке
    C:\операционная_система\Profiles\имя_пользователя\Application Data\Microsoft\Excel\XLStart
    где операционная_система папка операционной системы, например Windows.

    Для создания пользовательского шаблона, выберите папку «Шаблоны», которая находится обычно в
    C:\операционная_система\Profiles\имя_пользователя\Application Data\Microsoft\Templates
    , где операционная_система папка операционной системы, например Windows.

  5. Чтобы создать шаблон для стандартных листов, в поле Имя файла введите Лист.

    Для создания пользовательского шаблона листа введите любое допустимое имя файла.

  6. В меню Файл выберите команду Сохранить, а затем — Закрыть.


Восстановление исходных параметров для новых книг и листов

  • В проводнике Windows откройте папку XLStart и удалите все файлы шаблонов, перечисленные в следующей таблице. Папка XLStart обычно имеет расположение
    C:\ОС\Profiles\имя_пользователя\Application Data\Microsoft\Excel\XLStart
    где ОС — папка операционной системы, например, Windows.

    Если эти файлы отсутствуют в папке XLStart, откройте папку, которая указана в поле Каталог автозагрузки на вкладке Общие диалогового окна Параметры (меню Сервис).
    Чтобы восстановить исходные параметры для | Удалите этот файл
    книг | Book.xlt
    листов | Sheet.xlt

    Если требуется сохранить файлы Book.xlt или Sheet.xlt, переименуйте их и сохраните в папке Templates, которая обычно имеет расположение
    C:\ОС\Profiles\имя_пользователя\Application Data\Microsoft\Шаблоны
    где ОС — папка операционной системы, например, Windows.


 Изменение масштаба окна

Изменение масштаба окна

  • В раскрывающемся списке Масштаб [image] , выберите нужный размер или введите число от 10 до 400.

    Чтобы вывести выделенный диапазон на весь экран, выберите по выделению.

Примечание. Изменение масштаба изображения не отражается на функции печати. Страницы распечатываются в натуральную величину, пока не будет изменен масштаб печати в диалоговом окне Параметры страницы на вкладке Страница (меню Файл).


Скрытие элементов окна для отображения на экране большего объема данных

  • В меню Вид выберите команду Во весь экран.

Примечание. Чтобы отобразить панели инструментов и другие скрытые элементы окна, нажмите кнопку Вернуть обычный режим на панели инструментов Во весь экран. Если панель инструментов Во весь экран скрыта, отобразить панели инструментов и другие скрытые элементы можно с помощью команды Во весь экран в меню Вид.


 Скрытие и отображение отдельных элементов экрана

Скрытие и отображение отдельных элементов экрана

  1. В меню Сервис выберите команду Параметры, а затем перейдите к вкладке Вид.

  2. Установите флажки для тех элементов, которые нужно отобразить, и снимите флажки для тех элементов, которые нужно скрыть.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.


 Изменение цвета сетки ячеек

Изменение цвета сетки ячеек

  1. Укажите листы, цвет сетки которых следует изменить.

    Инструкции

  2. В меню Сервис выберите команду Параметры, а затем перейдите к вкладке Вид.

  3. В списке Цвет группы Параметры окна укажите нужный цвет.

    Чтобы использовать цвет, установленный в панели управления Windows, выберите Авто.


 Скрытие линий сетки

Скрытие линий сетки

  1. Выделите листы, на которых требуется крыть линии сетки.

    Инструкции

  2. В меню Сервис выберите команду Параметры, а затем перейдите на вкладку Вид.

  3. В группе Параметры окна снимите флажок Сетка.


 Отображение панели инструментов

Отображение панели инструментов

  • Щелкните любую панель инструментов правой кнопкой мыши, а затем установите или снимите флажок рядом с именем нужной панели инструментов в контекстном меню.

Советы

  • Если требуемая панель инструментов отсутствует в контекстном меню, выберите пункт Настройка в меню Сервис, перейдите на вкладку Панели инструментов и установите флажок для панели инструментов.

  • Чтобы быстро скрыть перемещаемую панель инструментов, нажмите на ней кнопку Закрыть [image].


Свертывание окна книги

  • Нажмите кнопку Свернуть [image] в строке меню или в области заголовка окна активной книги.

    Окно книги будет отображаться в виде значка в левом нижнем углу окна программы.

Примечание. При нажатии кнопки Свернуть [image] в области заголовка программы окно программы отображается в виде кнопки на панели задач Windows.


Развертывание окна книги, свернутого в значок

  • В меню Окно выберите имя книги, которое нужно восстановить.

Совет. Чтобы быстро развернуть окно, дважды щелкните его мышью.


Упорядочивание значков в окне Microsoft Excel

  • В меню Окно выберите команду Упорядочить значки.

    Минимизированные книги будут упорядочены слева направо в нижней части окна Microsoft Excel.

Примечание. Команду Упорядочить значки доступно, только если все книги в окне программы минимизированы или при нажатии кнопки мыши на значке для минимизированной книги.


 Минимизация всех окон программ в рабочем столе Windows

Минимизация всех окон программ в рабочем столе Windows

  • Щелкните правой кнопкой мыши панель задач Windows, а затем в контекстном меню выберите команду Свернуть все.


Отображение всех окон на рабочем столе Windows

  • Щелкните правой кнопкой мыши фон панели задач Windows и выберите команду Окна слева направо или Окна сверху вниз в контекстном меню.


Одновременный просмотр различных частей листа

Предполагаемые действия

Одновременный просмотр двух частей листа

Отображение заголовков строк и столбцов при прокрутке листа

Дополнительные сведения


 Об одновременном просмотре различных частей листа

Об одновременном просмотре различных частей листа

Разделение листа на части. Для того чтобы независимо просматривать и прокручивать различные части листа, можно разделить лист по горизонтали и по вертикали на отдельные области. Разделение листа на области позволяет просматривать различные части одного и того же листа друг рядом с другом и полезно, например, при необходимости вставки данных из одной области большого листа в другую. В следующем примере можно просматривать в верхней области строки по различным городам, в то время как в нижних областях будут отображаться итоги за февраль.

Окно листа, разделенное на области

Две правых области прокручиваются одновременно, как и две нижние области

Инструкции по разделению листа на области.

Отображение заголовков или данных. Для того чтобы заголовки строк и столбцов или другие данные оставались видимыми при прокрутке листа, можно закрепить верхние строки и/или левые столбцы. Закрепленные строки и столбцы не прокручиваются, оставаясь видимыми при перемещении по остальной части листа.

Окно листа с закрепленной строкой 1

Заголовки в первой строке остаются закрепленными при вертикальной прокрутке остальной части листа

Одновременно разделить лист и закрепить части листа невозможно

Инструкции по закреплению областей листа.

Печать заголовков на каждой странице. При печати листа заголовки разделенных или закрепленных областей не печатаются на каждой странице автоматически. Необходимо указать заголовки, которые требуется выводить на печать.


Одновременный просмотр нескольких листов или книг

  1. Откройте книгу, которую нужно просмотреть.

    Чтобы вывести несколько листов текущей книги, выберите команду Новое в меню Окно. Перейдите к новому окну и выберите лист, который нужно просмотреть. Таким же образом выведите на экран все необходимые листы.

  2. В меню Окно выберите команду Расположить.

  3. В группе Расположить выберите требуемый параметр.

    Чтобы отобразить только те листы, которые находятся в текущей книге, установите флажок Только окна текущей книги.

Совет. Чтобы развернуть окно книги на весь экран, нажмите кнопку Развернуть [image] в правом верхнем углу окна книги.


 Снятие разделения окна

Снятие разделения окна

  • Чтобы восстановить окно, которое было разделено на две области, установите указатель на полосу разделения областей и дважды нажмите кнопку мыши.

    Чтобы снять закрепление областей, выберите команду Снять закрепление областей в меню Окно.


Закрытие окон книг

Чтобы закрыть | Сделайте следующее
Окно текущей книги | Нажмите кнопку Закрыть [image] в правом верхнем углу окна. Если это единственное открытое окно книги, книга будет закрыта.
Все открытые окна книги | Выберите команду Закрыть в меню Файл.
Все открытые книги | Удерживая клавишу SHIFT, выберите команду Закрыть все в меню Файл.


 Представления

Представления

Представления изменяют способ отображения книг, листов, объектов и окон. Имеется возможность определить установки конкретных параметров отображения и печати и сохранить их как представление. При необходимости отображать или печатать книгу другим способом можно в любой момент переключиться в одно из этих представлений.

Что может быть сохранено в представлениях Хранимые установки включают: ширины столбцов, параметры вывода на экран, размеры и расположение окна на экране, разбиение окон и закрепление областей, активный лист и ячейки, выделенные во время создания представления. Можно также, по желанию, сохранять скрытые строки, скрытые столбцы, установки фильтров и параметры печати.

Представление включает всю книгу целиком. Если лист скрыт до создания представления, то Microsoft Excel скрывает этот лист при каждом переключении в данное представление.

Перед созданием представления Книга должна быть настроена. Ей должен быть придан не только необходимый внешний вид, но и установлены все нужные параметры печати. Если в представление вводятся параметры печати, в него будут автоматически включены и текущие области печати каждого листа или весь лист, если для него область печати не определена.

Дополнительные сведения

Создание представления

Отображение представления

Печать представления

Удаление представления

Сохранение представления для общей книги


 Создание представления

Создание представления

  1. Измените параметры, которые должны быть сохранены в представлении.

    Параметры, сохраняемые при создании представления.

  2. В меню Вид выберите команду Представления.

    Демонстрация

  3. Нажмите кнопку Добавить.

  4. В поле Имя введите имя представления.

  5. В области Вид сохраняет установите нужные параметры.

Совет При отображении представления Microsoft Excel переключается на лист, который был активен при создании представления. Поскольку Excel отображает список всех представлений в книге в диалоговом окне Представления, включайте в имя представления название активного листа. Это облегчит поиск нужного представления.


 Просмотр вида

Просмотр вида

  1. В меню Вид выберите команду Представления.

    Демонстрация

  2. В поле Виды выберите нужный вид.

  3. Нажмите кнопку Вывести.


 Печать представления

Печать представления

  1. В меню Вид выберите команду Представления.

    Демонстрация

  2. В поле Виды выберите представление для печати.

  3. Нажмите кнопку Показать.

  4. Нажмите кнопку Печать [image] .

Примечание. В представлении сохраняются области печати, установленные ранее для листов книги Microsoft Excel. Если лист не содержит областей печати, он будет напечатан целиком.


 Удаление представления

Удаление представления

  1. В меню Вид выберите команду Представления.

    Демонстрация

  2. В поле Виды выберите нужное представление.

  3. Нажмите кнопку Удалить.


Разрешение вопросов при работе с книгами и листами

В чем именно заключаются сложности?

Что означают цифры 1 или 2 в заголовке книги?

Ярлычки не видны в нижней части экрана

Апостроф ('), знак вставки (^) или кавычки (") отображаются в строке формулы, но их нет в ячейках

Листы макросов и диалоговых окон прежних версий Microsoft Excel

Не удается переименовать лист

Не удается развернуть или закрыть окно книги


Ввод данных в ячейки листа

Предполагаемые действия

Ввод чисел, текста, даты или времени суток

Ввод формулы

Ввод одного и того же значения в несколько ячеек одновременно

Ввод и изменение одного и того же значения на нескольких листах

Быстрое заполнение повторяющихся записей в столбце


 Отмена ошибочных действий

Отмена ошибочных действий

  • Чтобы последовательно отменять ошибочные действия, нажимайте кнопку Отменить [image] .

    Чтобы отменить сразу несколько действий, наведите указатель на стрелку, находящуюся рядом с кнопкой Отменить [image] , нажмите кнопку мыши и выберите нужное действие из списка. Microsoft Excel отменяет указанное действие, а также все действия, перечисленные в этом списке выше.

    Чтобы отменить ввод в ячейку или строку формул до того, как нажата клавиша ENTER, нажмите клавишу ESC.

Совет. Чтобы возвратить действие, нажмите кнопку Вернуть [image] .


 Ввод чисел, текста, даты или времени суток

Ввод чисел, текста, даты или времени суток

  1. Укажите ячейку, в которую необходимо ввести данные.

  2. Наберите данные и нажмите клавишу ENTER или клавишу табуляции.

    При вводе даты используйте точку или дефис в качестве разделителя, например 09.05.2002 или Янв-2002.

    Для отображения времени суток в 12-часовом формате введите букву a или p, отделенную пробелом от значения времени, например 9:00 p. В противном случае время будет интерпретировано на основе 24-часового формата.

Для получения более подробных сведений о вводе чисел нажмите кнопку [image] .

Для получения более подробных сведений о вводе текста нажмите кнопку [image] .

Для получения более подробных сведений о вводе дат или времени суток нажмите кнопку [image] .

Советы

  • Чтобы ввести данные в строки в виде списка, заполните ячейку первого столбца, а затем нажмите клавишу табуляции для перемещения в следующую ячейку. После ввода данных в первую строку нажмите клавишу ENTER, чтобы перейти на начало следующей. Если ячейка, расположенная в начале следующей строки не становится активной, выберите команду Параметры в меню Сервис, а затем — вкладку Правка. В группе Параметры установите флажок Переход к другой ячейке после ввода, а затем из списка в направлении выберите Вниз.

  • Чтобы ввести текущую дату, нажмите клавиши CTRL+; (точка с запятой).

  • Чтобы ввести текущее время, нажмите клавиши CTRL+SHIFT+: (двоеточие).


 Ввод чисел с заданным количеством десятичных разрядов или конечных нулей

Ввод чисел с заданным количеством десятичных разрядов или конечных нулей

Используйте данную операцию при вводе множества чисел с фиксированным количеством десятичных разрядов или больших целых чисел с фиксированным количеством конечных нулей (0).

  1. Выберите команду Параметры в меню Сервис, а затем – вкладку Правка.

  2. Установите флажок Фиксированный десятичный формат при вводе, десятичных разрядов.

  3. Введите необходимое количество десятичных разрядов, которые должны располагаться справа от десятичной точки, в поле десятичных разрядов.

    Чтобы автоматически добавлять нули (0) при вводе больших целых чисел, укажите отрицательное число, обозначающее количество нулей. Например, для автоматического ввода 283000 при наборе 283 введите -3 в поле десятичных разрядов.

    При вводе чисел в указанное место вставляется десятичная точка или добавляется определенное количество нулей. Изменение параметра Фиксированный десятичный формат при вводе не оказывает влияния на введенные до этого данные.

    После того как будет закончен ввод чисел с десятичными разрядами или конечными нулями, снимите флажок Фиксированный десятичный формат при вводе.

Совет. Чтобы параметр Фиксированный десятичный формат при вводе при наборе числа не использовался, введите десятичную точку.


Ввод одного и того же значения в несколько ячеек одновременно

  1. Выделите ячейки, в которые необходимо ввести данные.

    Выделенные ячейки могут быть как смежными, так и несмежными.

  2. Введите данные и клавиши CTRL+ENTER.


 Ввод и изменение одного и того же значения на нескольких листах

Ввод и изменение одного и того же значения на нескольких листах

Если выделено несколько листов, то вносимые в активный лист изменения отображаются в соответствующих ячейках всех остальных выбранных листов. Данные в других листах могут быть заменены.

  1. Выберите листы, на которые необходимо ввести данные.

    Инструкции

  2. Укажите ячейку или выделите диапазон ячеек, в которые необходимо ввести данные.

  3. Введите или измените данные в первой выделенной ячейке.

  4. Нажмите клавишу ENTER или клавишу табуляции.

    Данные будут автоматически введены во все выделенные листы.

  5. Чтобы отменить выделение нескольких листов книги, укажите любой невыделенный лист.

    Если на экране видны только выделенные листы, наведите указатель на выделенный лист и нажмите правую кнопку мыши. Затем выберите команду Разгруппировать листы в контекстном меню.

Примечания

  • Если данные были введены на одном листе, то их можно быстро скопировать в соответствующие ячейки других листов. Выберите лист, содержащий введенные данные, и листы, на которые их необходимо скопировать. Выделите ячейки, содержащие копируемые данные. Выберите команду Заполнить в меню Правка, а затем — команду По листам.

  • Можно также сослаться на одни и те же ячейки на нескольких листах, не вводя данные.


 Ввод символов ¢, £, ¥, ® и других символов, которых нет на клавиатуре

Ввод символов ¢, £, ¥, ® и других символов, которых нет на клавиатуре

  1. В меню Windows Пуск выберите команду Программы, затем команду Стандартные, а потом пункт Таблица символов.

    Если программа Таблица символов недоступна, то для получения сведений по установке компонентов Windows см. справку Windows.

  2. В поле Шрифт выберите шрифт, содержащий необходимый символ.

  3. Выберите из сетки необходимый символ.

  4. Выберите команду Выбрать, а затем нажмите кнопку Копировать.

    Можно выбрать и скопировать несколько символов.

  5. Переключитесь в нужную книгу и установите указатель в то место, куда необходимо вставить символ.

  6. Нажмите кнопку Вставить [image] .

    Если вставленный символ отличается от выбранного, то выделите его и установите тот шрифт, который был выбран в таблице символов.

Совет. Программа Таблица символов показывает комбинацию клавиш, которую можно использовать в Microsoft Excel для вставки символов. Для ввода цифр в комбинациях клавиш необходимо использовать цифровую, а не основную клавиатуру.


Ввод чисел

Символы, используемые в числах В Microsoft Excel числа могут включать только следующие символы:

0 1 2 3 4 5 6 7 8 9 + - ( ) , / $ % . E e

Стоящие перед числом знаки плюс (+) игнорируются, а запятая интерпретируется как разделитель десятичных разрядов. Все другие сочетания клавиш, состоящие из цифр и нецифровых символов, рассматриваются как текст.

Ввод дробей Перед рациональной дробью следует вводить 0 (нуль), чтобы избежать ее интерпретации как формата даты; например, вводите 0 1/2

Ввод отрицательных чисел Перед отрицательным числом необходимо вводить знак минус (-) или заключать его в круглые скобки ( ).

Выравнивание чисел Введенные числа выравниваются в ячейке по правому краю. Чтобы изменить выравнивание, выделите ячейки, выберите команду Ячейки в меню Формат, а затем на вкладке Выравнивание установите необходимые параметры.

Отображение чисел Формат числа, назначаемый ячейке, определяет способ просмотра числа на листе. Если число вводится в ячейку, имеющую общий числовой формат, то может быть использован другой формат. Например, если вводится 14,73р., то будет использован денежный формат. Чтобы изменить числовой формат, выделите ячейки, которые содержат числа, выберите команду Ячейки в меню Формат, а затем на вкладке Число выберите необходимый формат.

Общий числовой формат В ячейках, имеющих общий числовой формат, отображаются целые числа (789), десятичные дроби (7,89) или числа, представленные в экспоненциальной форме (7,89E+08), если число длиннее ширины ячейки. Используя общий формат, можно просматривать до 11 разрядов, включая десятичные запятые и такие символы, как "E" и "+." Чтобы использовать числа с большим количеством разрядов, используйте встроенный экспоненциальный числовой формат (экспоненциальное представление числа) или пользовательский формат.

Ограничение 15 разрядов Независимо от количества отображаемых разрядов, числа хранятся с точностью до 15 разрядов. Если число имеет больше 15 значащих знаков, то разряды после 15-го преобразуются в нули (0).

Ввод чисел как текста Число хранится в числовом формате, даже если была использована команда Ячейки, чтобы назначить текстовый формат ячейкам, содержащим числа. Для интерпретации чисел, например, инвентаризационных номеров, как текста, необходимо назначить текстовый формат незаполненным ячейкам. Только после этого следует вводить числа. Если числа уже введены, то назначьте ячейкам текстовый формат и, выделяя каждую ячейку, нажимайте клавишу F2, а затем – клавишу ENTER, чтобы ввести заново данные.

Языки и стандарты Символы, воспринимаемые как числа, зависят от выбранных установок в свойствах «Языки и стандарты» на панели управления. Выбранные параметры также определяют стандартный формат для чисел — например, в системе с американским стандартом точка (.) используется как десятичный разделитель.


Ввод дат и времени суток

Даты и время суток — это числа В Microsoft Excel даты и время суток интерпретируются как числа. Внешнее представление времени или даты на листе зависит от числового формата, назначенного ячейке. При вводе значений даты или времени происходит их автоматическое распознавание, и общий формат ячейки заменяется на встроенный формат даты или времени. По умолчанию значения даты и времени выравниваются в ячейке по правому краю. Если не происходит автоматического распознавания формата даты или времени, то введенные значения интерпретируются как текст, который выравнивается в ячейке по левому краю.

Панель управления Параметры, установленные с помощью значка «Язык и стандарты» на панели управления, определяют формат для текущей даты и времени и символы, использующиеся в качестве разделителей, например двоеточие (:) и точка (/) в стандарте России.

Использование 4-значного года При вводе дат, например 01 Декабря, Excel сопоставляет сначала день, а потом год. Например, 01 Декабря вводится как 1 декабря текущего года, а не декабрь 2001 года.

Ввод одновременно и дат и времени суток Для ввода и даты и времени суток в одну ячейку разделите их пробелом.

12- и 24-часовой формат Чтобы ввести время с использованием 12-часового формата, введите после значения времени отделенные пробелом буквы AM или PM (A или P). В противном случае, время будет интерпретировано с использованием 24-часового формата. Например, при вводе значения 3:00 вместо 3:00 PM, время будет хранится в ячейке в виде 3:00 AM.

Просмотр даты и времени суток в числовом формате Независимо от формата, используемого для представления даты или времени, в Excel все даты сохраняются как целые числа, а время сохраняется в виде десятичной дроби. Чтобы показать дату в виде числа или время в виде дроби, выделите ячейки, содержащие дату или время, выберите команду Ячейки в меню Формат, а затем на вкладке Число из списка Числовые форматы выберите элемент Общий.

Вычисления с датами и временем Время суток и даты можно складывать, вычитать и производить с ними другие вычисления. В формулы они могут быть введены в виде текста, заключенного в двойные кавычки. Например, приведенная ниже формула возвращает результат, равный 68:

="12/5/2004"-"5/3/2004"

Система дат 1904 В Excel для Windows (и Lotus 1-2-3) используется система отсчета дат с начала столетия; в этой системе числу 1 соответствует дата 1 января 1900 г. В Microsoft Excel для Macintosh используется система отсчета дат, начиная с 1904 года; в ней числу 1 соответствует 2 января 1904 г. Чтобы изменить систему отсчета дат, выберите команду Параметры в меню Сервис, а затем – вкладку Вычисления. В группе Параметры книги установите флажок Система дат 1904. Установите систему дат 1904 в книге, используемой совместно с другими книгами, в которых эта система отсчета дат была установлена ранее.

При открытии в Excel для Windows файла, созданного в Microsoft Excel для Macintosh версии 2.0 или более поздней, происходит автоматическое распознавание формата файла и преобразование его в систему отсчета дат с 1900 г. Аналогично, при открытии файла Microsoft Excel для Windows в системе Macintosh произойдет преобразование дат в систему отсчета с 1904 г.


Хранение дат и времени суток в Microsoft Excel

Microsoft Excel хранит дату в виде последовательных чисел, а время в виде десятичной части этого значения (время является частью даты). Даты и значения времени представляются числами; поэтому их можно складывать и вычитать, а также использовать в других вычислениях. Например, чтобы определить число дней между двумя датами, можно вычесть одну дату из другой. При использовании основного формата для ячеек, содержащих дату и время, можно отобразить дату в виде числа или время в виде дробной части числа с десятичной точкой.

Excel поддерживает две системы дат: 1900 и 1904. По умолчанию, Microsoft Excel для Windows использует систему дат 1900. Чтобы воспользоваться системой дат 1904, выберите команду Параметры в меню Сервис, а затем на вкладке Вычисления установите флажок Система дат 1904.

В следующей таблице представлены первая и последняя даты для каждой системы, а также соответствующие им значения.

Система дат | Первая дата | Последняя дата
1900 | 1 января 1900 г. (значение 1) | 31 декабря 9999 г. (значение 2958465)
1904 | 2 января 1904 г. (значение 1) | 31 декабря 9999 г. (значение 2957003)

Примечания

Две цифры года. Если при вводе даты указаны только две последние цифры года, Excel добавит первые две по следующим правилам:

  • Если число лежит в интервале от 00 до 29, то оно интерпретируется как год с 2000 по 2029. Например, если в ячейку введена дата 28.5.19, Microsoft Excel распознает ее как 28 мая 2019 г.

  • Если число лежит в интервале от 30 до 99, то оно интерпретируется как год с 1930 по 1999. Например, если в ячейку введена дата 28.5.98, Excel распознает ее как 28 мая 1998 г.

Если используется Microsoft Windows 98 или Microsoft Windows 2000, можно без помощи системного администратора изменить способ интерпретации дат, заданных двумя цифрами года.

Четыре цифры года Для обеспечения правильной интерпретации значений года вводите четыре цифры года (2001 вместо 01). При вводе четырех цифр года Excel не будет определять столетие по описанным выше правилам.

Функция ДАТА Если необходимо манипулировать частями даты — например год или месяц — внутри формулы, можно использовать функцию ДАТА.

Функция ВРЕМЯ Если необходимо манипулировать частями времени — например час или минута — внутри формулы, можно использовать функцию ВРЕМЯ.

Отображение четырех цифр года по умолчанию По умолчанию даты, вводимые в книгу, форматируются с двумя цифрами года. можно использовать панель управления Windows для изменения стандартного формата даты для отображения года четырьмя цифрами, а не двумя.

2000 год Информационный центр Майкрософт по проблеме 2000 года предоставляет информацию о том, как наступление 2000 года повлияет на работу программных продуктов Microsoft. См. сведения об информационном центре Майкрософт по проблеме 2000 года.


Ввод текста

  • В Microsoft Excel текстом является любая последовательность, состоящая из цифр, пробелов и нецифровых символов, например, приведенные ниже записи интерпретируются как текст:

    10AA109, 127AXY, 12-976, 208 4675.

  • Введенный текст выравнивается в ячейке по левому краю. Чтобы изменить выравнивание, выберите команду Ячейки (вкладка Выравнивание) в меню Формат, а затем измените необходимые параметры.

  • Чтобы просмотреть весь текст, занимающий в ячейке несколько строк, установите флажок Переносить по словам на вкладке Выравнивание.

  • Чтобы начать в ячейке новую строку, нажмите клавиши ALT+ENTER.


 Включение и выключение режима правки с помощью перетаскивания и автозаполнения

Включение и выключение режима правки с помощью перетаскивания и автозаполнения

  1. Выберите команду Параметры в меню Сервис, а затем – вкладку Правка.

  2. Чтобы разрешить редактирование и заполнение данных с помощью перетаскивания, установите флажок Разрешить перетаскивание ячеек.

    Чтобы запретить перетаскивание, снимите флажок.


 Выбор ячейки, которая становится активной после нажатия клавиши ENTER

Выбор ячейки, которая становится активной после нажатия клавиши ENTER

  1. Выберите команду Параметры в меню Сервис, а затем – вкладку Правка.

  2. Чтобы переместиться в смежную ячейку, установите флажок Переход к другой ячейке после ввода, а затем из списка в направлении выберите направление.

    Чтобы сохранить текущую ячейку активной после ввода, снимите данный флажок.


 Включение и выключение автозаполнения ячеек в столбце

Включение и выключение автозаполнения ячеек в столбце

  1. Выберите команду Параметры в меню Сервис, а затем – вкладку Правка.

  2. Чтобы разрешить автозаполнение, установите флажок Автозаполнение значений ячеек.

    Чтобы запретить автозаполнение, снимите флажок.


 Включение и выключение вывода сообщения о перезаписи непустых ячеек

Включение и выключение вывода сообщения о перезаписи непустых ячеек

  1. Выберите команду Параметры в меню Сервис, а затем — вкладку Правка.

  2. Чтобы при переносе с помощью мыши выбранных ячеек или маркера заполнения на то место, где уже имеются данные, выдавалось соответствующее предупреждение, установите флажок Предупреждать перед перезаписью ячеек.

    Снимите флажок для отключения предупреждающего сообщения.


Автозаполнение, основанное на смежных ячейках

Предполагаемые действия

Копирование данных внутри строки или столбца

Заполнение рядов чисел, дат или других элементов

Создание пользовательского списка автозаполнения

Дополнительные сведения


 О заполнении смежных ячеек

О заполнении смежных ячеек

Чтобы заполнить несколько ячеек прогрессией, следует либо перетащить маркер заполнения выделенного диапазона ячеек, либо воспользоваться командой Прогрессия (выберите пункт Заполнить в меню Правка, затем щелкните пункт Прогрессия).

Копирование данных в строке или столбце. При перетаскивании маркера заполнения ячейки, содержимое этой ячейки копируется в ячейки вдоль стоки, либо вдоль столбца.

Заполнение прогрессии числами, датами либо другими элементами. Если в выделенном диапазоне содержатся числа, даты или время, то есть возможность продолжить прогрессию. В таблице ниже приведены примеры продолжения прогрессии по ее начальным элементам. Элементы, разделенные запятыми, находятся в соседних ячейках.

Начальное значение | Продолжение ряда
1, 2, 3 | 4, 5, 6
9:00 | 10:00, 11:00, 12:00
пн | вт, ср, чт
понедельник | вторник, среда, четверг
янв | фев, мар, апр
янв, апр | июл, окт, янв
янв-99, янв-99 | июл-99, окт-99, янв-00
15-янв, 15-янв | 15-июл, 15-окт
1999, 2000 | 2001, 2002, 2003
1-янв, 1-мар |  | 1-май, 1-июл, 1-сен,...
кв.3 (или квартал3) | кв.4, кв.1, кв.2...
товар 1, заказ | товар 2, заказ, товар 3, заказ,...
текст1, текстA |  | текст2, текстA, текст3, текстA,...
1-й период | 2-й период, 3-й период,...
товар 1 | товар 2, товар 3,...

Если выделенный диапазон содержит числа, то можно создать либо арифметическую прогрессию, либо геометрическую прогрессию.

Создание пользовательской прогрессии. Для заполнения ячеек часто используемыми текстовыми записями можно создавать пользовательские прогрессии.


 Быстрое заполнение повторяющихся записей в столбце

Быстрое заполнение повторяющихся записей в столбце

Если несколько первых символов, вводимых в ячейку, совпадают с символами записи, ранее введенной в этом столбце, то недостающая часть набора будет произведена автоматически. В Microsoft Excel автоматический ввод производится только для тех записей, которые содержат текст или текст в сочетании с числами. Записи, полностью состоящие из чисел, дат или времени, необходимо вводить самостоятельно.

  • Для подтверждения предлагаемого варианта, нажмите клавишу ENTER.

    Законченная запись по формату полностью совпадает с существующей записью, включая символы верхнего и нижнего регистра.

  • Для замены автоматически введенных символов продолжите ввод самостоятельно.

  • Для удаления автоматически введенных символов нажмите клавишу BACKSPACE.

Вариант ввода также можно выбрать из списка записей, которые уже имеются в столбце. Чтобы просмотреть список, нажмите клавиши ALT+СТРЕЛКА ВНИЗ, или укажите ячейку с помощью правой кнопки мыши, а затем выберите команду Выбор из списка в контекстном меню.


 Заполнение рядов чисел, дат или других элементов

Заполнение рядов чисел, дат или других элементов

  1. Выделите первую ячейку диапазона, который требуется заполнить, и введите начальное значение.

    Чтобы задать для ряда конкретное приращение, выберите следующую ячейку диапазона и введите следующий элемент ряда. Величина приращения ряда определяется разностью значений двух начальных его элементов.

  2. Выделите ячейку или ячейки, содержащие начальные значения.

  3. Перетащите маркер заполнения через заполняемые ячейки.

    Для заполнения в возрастающем порядке перетащите маркер вниз или вправо.

    Для заполнения в убывающем порядке перетащите маркер вверх или влево.

Примечания

  • Чтобы задать тип ряда, воспользуйтесь для перетаскивания маркера заполнения правой кнопкой мыши, а затем выберите соответствующую команду в контекстном меню. Например, если начальное значение — дата «янв-2002», то для получения ряда «фев-2002», «мар-2002» и т.д. выберите команду Заполнить по месяцам, а для получения ряда «янв-2003», «янв-2004» и т.д. выберите команду Заполнить по годам.

  • Для того чтобы управлять созданием ряда вручную или использовать для заполнения ряда значений клавиатуру, используйте команду Ряд.


 Создание пользовательского списка автозаполнения или порядка сортировки

Создание пользовательского списка автозаполнения или порядка сортировки

Существует возможность создания пользовательского списка автозаполнения или порядка сортировки либо из существующих на листе элементов, либо с помощью непосредственного ввода списка.

  1. Если ряд элементов, который необходимо представить в виде пользовательского списка автозаполнения, был набран заранее, то выделите его на листе.

  2. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Списки.

  3. Чтобы использовать выделенный список, нажмите кнопку Импорт.

    Чтобы создать новый список, выберите Новый список из списка Списки, а затем введите данные в поле Элементы списка, начиная с первого элемента. После ввода каждой записи нажимайте клавишу ENTER. Нажмите кнопку Добавить после того, как список будет набран полностью.

    Примечание. Пользовательский список может содержать текст или текст в сочетании с числами. Чтобы создать пользовательский список, состоящий только из чисел, например, инвентаризационных номеров, выделите сначала достаточное количество свободных ячеек, предназначенных для его размещения. Выберите команду Ячейки в меню Формат, а затем – вкладку Число. Свободным ячейкам назначьте текстовый формат и введите в них список чисел.


 Изменение или удаление пользовательского списка автозаполнения или порядка сортировки

Изменение или удаление пользовательского списка автозаполнения или порядка сортировки

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Списки.

  2. Укажите необходимый список в поле Списки.

  3. Сделайте необходимые изменения в поле Элементы списка, а затем нажмите кнопку Добавить.

    Чтобы удалить список, нажмите кнопку Удалить.

Примечание. Стандартные списки, содержащие названия дней недели и месяцев, нельзя удалить или отредактировать.


 Заполнение рядов данных на основе формулы

Заполнение рядов данных на основе формулы

  1. Укажите первую ячейку заполняемого диапазона и введите начальную формулу.

  2. Выделите ячейку, содержащую начальную формулу.

  3. Перетащите маркер заполнения через заполняемые ячейки.

Примечания

  • По мере ввода данных в список Microsoft Excel автоматически заполняет формулы для рядов при превышении исходных размеров диапазона. Для этого диапазоны рядов должны состоять по меньшей мере из четырех строк данных, и каждая формула должна содержать ссылки на ячейки только из одной строки.

  • Все существовавшие ранее значения или формулы в заполняемых ячейках будут замещены.

  • Чтобы быстро заполнить активную ячейку содержимым ячейки, расположенной выше, нажмите клавиши CTRL+D. Чтобы заполнить содержимым ячейки слева, нажмите клавиши CTRL+R.

  • Чтобы удалить содержимое диапазона ячеек, выделите диапазон, а затем перетащите маркер заполнения через диапазон.


 Выделение текста, ячеек, диапазонов, строк и столбцов

Выделение текста, ячеек, диапазонов, строк и столбцов

Чтобы выделить | Сделайте следующее
Текст в ячейке | Если режим редактирования в ячейке включен, выделите ячейку, дважды щелкните ее и выделите текст в ячейке. Если режим редактирования в ячейке выключен, выделите ячейку и выделите текст в строке формул.
Отдельную ячейку | Укажите ячейку или перейдите к ней, используя клавиши перемещения.
Диапазон ячеек | Протащите указатель от первой ячейки диапазона к последней.
Все ячейки листа | Нажмите кнопку Выделить все. Кнопка «Выделить все»
Несмежные ячейки или диапазоны ячеек | Выделите первую ячейку или первый диапазон ячеек, затем, удерживая нажатой клавишу CTRL, выделите остальные ячейки или диапазоны.
Большой диапазон ячеек | Укажите первую ячейку, затем, удерживая нажатой клавишу SHIFT, укажите последнюю ячейку диапазона. Для перемещения к последней ячейке можно использовать полосы прокрутки.
Всю строку | Щелкните заголовок строки. Лист с заголовком строки
Весь столбец | Щелкните заголовок столбца. Лист с заголовком столбца
Смежные строки или столбцы | Протащите указатель по заголовкам строк или столбцов. Другой способ: выделите первую строку или первый столбец, затем, удерживая нажатой клавишу SHIFT, выделите последнюю строку или последний столбец.
Несмежные строки или столбцы | Выделите первую строку или первый столбец, затем, удерживая нажатой клавишу CTRL, выделите остальные строки или столбцы.
Большее или меньшее количество ячеек по сравнению с текущим диапазоном | Удерживая нажатой клавишу SHIFT, укажите последнюю ячейку, которую необходимо включить во вновь выделяемый диапазон. Прямоугольная область между текущей ячейкой и указанной ячейкой образует новый диапазон выделения.


 Выделение пустых ячеек

Выделение пустых ячеек

  1. Выделите диапазон, включающий ячейки, которые нужно выбрать.

    Чтобы выбрать все ячейки этого типа, щелкните любую ячейку.

  2. В меню Правка выберите команду Перейти.

    Демонстрация

  3. Нажмите кнопку Выделить.

  4. Установите переключатель в положение пустые ячейки.


 Выделение ячеек, содержащих примечания

Выделение ячеек, содержащих примечания

  1. Выделите диапазон, включающий ячейки, которые нужно выбрать.

    Чтобы выбрать все ячейки этого типа, щелкните любую ячейку.

  2. В меню Правка выберите команду Перейти.

    Демонстрация

  3. Нажмите кнопку Выделить.

  4. Установите переключатель в положение Примечания.


 Выделение ячеек, содержащих константы

Выделение ячеек, содержащих константы

  1. Выделите диапазон, включающий ячейки, которые нужно выбрать.

    Чтобы выбрать все ячейки этого типа, щелкните любую ячейку.

  2. В меню Правка выберите команду Перейти.

    Демонстрация

  3. Нажмите кнопку Выделить.

  4. Установите переключатель в положение Константы.


 Выделение ячеек, содержащих формулы

Выделение ячеек, содержащих формулы

  1. Выделите диапазон, включающий ячейки, которые нужно выбрать.

    Чтобы выбрать все ячейки этого типа, щелкните любую ячейку.

  2. В меню Правка выберите команду Перейти.

    Демонстрация

  3. Нажмите кнопку Выделить.

  4. Установите переключатель в положение Формулы и установите флажки, соответствующие типам данных, которые нужно выбрать.

Примечание. Можно также выделить диапазон, содержащий формулу массива.


 Выделение именованных диапазонов или ссылок на ячейки

Выделение именованных диапазонов или ссылок на ячейки

Чтобы выделить | Сделайте следующее
Поименованный диапазон ячеек | Выберите диапазон из списка в поле Имя.
Более одного поименованного диапазона | Введите имя первого диапазона в поле Имя. Затем, удерживая клавишу CTRL нажатой, укажите в списке имена остальных диапазонов.
Отдельные ячейки, не входящие в поименованный диапазон | В меню Правка, выберите команду Перейти. В поле ссылка введите ссылку на ячейку или диапазон ячеек.

Совет. В Microsoft Excel сохраняются ссылки на диапазоны, выделенные с помощью поля Имя или команды Перейти. Чтобы вернуться к ранее выделенному диапазону, выберите команду Перейти в меню Правка, а затем укажите необходимую ссылку в списке Перейти и дважды нажмите кнопку мыши.


 Выделение только видимых ячеек

Выделение только видимых ячеек

Эта процедура используется только для выделения диапазона, который пересекает скрытые строки или столбцы, но не включает в себя содержащиеся в них скрытые ячейки.

  1. Выделите диапазон.

  2. В меню Правка выберите команду Перейти.

    Демонстрация

  3. Выберите Дополнительный.

  4. Установите переключатель в положение Только видимые ячейки.


Отмена выделения ячеек

  • Чтобы отменить выделение ячеек, щелкните любую ячейку листа.


 Отмена выделения нескольких листов

Отмена выделения нескольких листов

  • Чтобы отменить выделение нескольких листов книги, укажите любой невыделенный лист.

    Если на экране видны только выделенные листы, наведите указатель на выделенный лист и нажмите правую кнопку мыши. Затем выберите команду Разгруппировать листы в контекстном меню.


Разрешение вопросов, возникающих при вводе данных

В чем именно заключаются сложности?

Числа, даты и время отображаются не так, как должны.

Вводимый в ячейку текст не отображается на экране

При вводе значений по столбцам автозаполнение происходит не всегда

Маркер заполнения отсутствует

Копирование ячеек с помощью маркера заполнения приводит к появлению неправильных данных

Перетаскивание маркера заполнения приводит к удалению содержимого ячеек

При назначении числам текстового формата числовые данные не преобразуются в текст


Разрешение вопросов, возникающих при выделении и перемещении по книге

В чем именно заключаются сложности?

Ярлычки не видны в нижней части экрана

Не функционируют клавиши перемещения

Как выбрать один лист, если несколько листов уже выбрано

Сохраняя первоначально выделенный диапазон, необходимо добавить к нему или исключить из него несколько ячеек

Выделенная область увеличивается при нажатии кнопки мыши на ячейке или прокрутке.


Обработка дат 2000 года в Microsoft Excel

Поскольку правила, которые задают способ интерпретации дат в разных вычислительных программах, довольно сложны, следует быть предельно конкретным при вводе дат. Это обеспечит наивысшую точности в вычислении дат.

Интерпретация неоднозначных дат При интерпретации неоднозначных дат Excel использует некоторые предположения. Например, если вводится дата, содержащая месяц и одну или две цифры, Excel предполагает, что числа от 1 до 31 соответствуют дню, а дата соответствует текущему году. Скажем, Excel предполагает, что «1 декабрь» — это 1 декабря текущего года, а не декабрь 2001 года. Excel предполагает, что «Декабрь 32» — это 1 декабря 1932.

Интерпретация двухзначных лет Когда введены две цифры года, Excel по умолчанию интерпретирует год следующим образом:

  • Значение года от 00 до 29 Двухзначные значения года от 00 до 29 Excel интерпретирует как годы с 2000 по 2029. Например, если в вводится дата 28/5/19, Microsoft Excel распознает ее как 28 мая 2019 г.

  • Значение года от 30 до 99 Двухзначные значения года от 30 до 99 Excel интерпретирует как годы с 1930 по 1999. Например, если в вводится дата 28/5/98, Microsoft Excel распознает ее как 28 мая 1998 г.

Использование четырех цифр в записи года Чтобы быть уверенным в правильной интерпретации Excel значений лет, можно вводить четыре цифры года (например, 2001 вместо 01).

Изменение способа распознавания года Системный администратор может изменить правила, по которым Microsoft Office интерпретирует год. Например, администратор может изменить число, соответствующее максимальному году в следующем столетии, с 29 на любое другое число. Сведения о настройке интерпретации дат могут быть получены из Microsoft Office 2000 Resource Kit.

Примечания

  • Можно изменить стандартный формат для отображения даты четырьмя цифрами вместо двух. Если используется Microsoft Windows 98 или Microsoft Windows 2000, можно самостоятельно, без помощи системного администратора, изменить способ интерпретации дат, заданных двумя цифрами года.

  • Информационный центр Майкрософт по проблеме 2000 года предоставляет информацию о том, как наступление 2000 года повлияет на работу программных продуктов Microsoft. Информационный центр Майкрософт по проблеме 2000 года.


Изменение способа интерпретации дат, заданных двумя цифрами года

По умолчанию Excel интерпретирует заданные двумя цифрами годы с 00 по 29 как годы с 2000 по 2029, а годы с 30 по 99 — как годы с 1930 по 1999. При использовании Windows 95 или ранних версий Windows NT Workstation 4.0 и при работе в сети обратитесь к системному администратору, если хотите изменить способ интерпретации года, который задается с помощью двух цифр.

При использовании Microsoft Windows 98 или Microsoft Windows 2000 можете использовать панель управления Windows для изменения способа распознавания года, введенного двумя цифрами. Эта процедура изменяет интерпретацию года, заданного с помощью двух цифр, для всех программ, установленных под Windows.

  1. В меню Windows Пуск выберите команду Настройка и затем — Панель управления.

  2. Выполните одно из следующих действий:

    Если установлена операционная система Windows 98, дважды нажмите щелкните значок Язык и стандарты [image] и затем выберите вкладку Дата.

    Если установлена операционная система Windows 2000, дважды нажмите кнопку мыши на значке Язык и стандарты [image] и затем выберите вкладку Дата.

  3. В поле При вводе цифр года воспринимать их как год между: измените верхний предел для года, относящегося к следующему столетию.

    Когда изменяется верхний предел для года, нижний предел изменяется автоматически.

Примечание. По умолчанию дата при вводе в книгу форматируется для отображения года двумя цифрами. Можно использовать панель управления Windows для изменения формата, установленного по умолчанию, для отображения года четырьмя цифрами вместо двух.


Изменение стандартного формата даты для отображения года четырьмя цифрами

Даты, введенные в книгу, по умолчанию по умолчанию отображаются с двумя цифрами года. Когда стандартный формат даты будет изменен на другой с помощью описанной ниже процедуры, введенные ранее даты будут отображаться в соответствии с новым форматом, если формат дат не был изменен с помощью команды Ячейки (меню Формат).

  1. В меню Windows Пуск выберите команду Настройка и затем — Панель управления.

  2. Дважды щелкните значокЯзык и стандарты [image] (или Regional Options [image], если используется Windows 2000) и затем выберите вкладку Дата.

  3. В списке Краткий формат выберите формат, который использует четыре цифры для отображения года ("гггг").


Изменение содержимого ячейки

  1. Дважды щелкните ячейку, содержимое которой необходимо изменить.

  2. Измените содержимое ячейки.

  3. Для сохранения изменений нажмите клавишу ENTER.

    Для отмены изменений нажмите клавишу ESC.

Советы

  • Чтобы включить или выключить редактирование непосредственно в ячейке, выберите команду Параметры в меню Сервис, выберите закладку Правка и затем установите или сбросьте флажок Правка прямо в ячейке.

  • Чтобы быстро добавить в конец содержимого ячейки, выделите ее и нажмите клавишу F2.

  • Можно также отредактировать формулу массива и отредактировать гиперссылку.


Очистка и удаление ячеек, строк и столбцов

При удалении ячейки Microsoft Excel так перемещает соседние ячейки, чтобы они заполнили освободившееся место. При очистке ячейки удаляется ее содержимое (формулы и данные), форматы (включая числовые, условные форматы и границы) и примечания, но пустые ячейки остаются на листе.

Предполагаемые действия

Очистка ячейки

Удаление ячеек, строк и столбцов


Очистка ячейки

  1. Выделите ячейки, строки или столбцы, которые следует очистить.

  2. В меню Правка выберите команду Очистить, а затем — Все, Содержимое, Форматы или Примечания.

Примечания

  • При нажатии клавиш DELETE и BACKSPACE Microsoft Excel удаляет содержимое ячейки, оставляя без изменения ее формат и примечания.

  • При очистке ячейки можно раздельно удалить ее содержимое, форматы, примечания или сразу все перечисленное. Значение очищенной ячейки равно 0 (нулю). Именно такое значение получает формула, содержащая ссылку на эту ячейку.

Совет. Чтобы удалить с листа все примечания, выберите команду Перейти в меню Правка, выберите Дополнительный, а затем — Примечания. Наведите указатель на команду Очистить в меню Правка и выберите Примечания.


Повторное выполнение последнего действия

  • В меню Правка выберите команду Вернуть.

    Если повторить действие невозможно, вместо команды Вернуть появляется надпись Нельзя повторить.


Разделение текста на столбцы

  1. Выделите диапазон ячеек, содержащих текстовые значения.

    Выделенная область может содержать любое число строк, но только один столбец.

  2. В меню Данные выберите команду Текст по столбцам.

  3. Следуйте инструкциям мастера текстов для указания способа разбиения текста на столбцы.


 Поиск и замена данных

Поиск и замена данных

Существует возможность находить указанный текст или числа и автоматически замещать найденные данные. Можно найти все ячейки, содержащие один и тот же вид данных, например, формулы, а также ячейки, чье содержимое не совпадает с содержимым текущей ячейки.

Для поиска данных в списке служат фильтры, которые позволяют отобразить строки, содержащие нужные данные. Например, из списка, включающего данные по международным продажам, можно извлечь данные по национальным продажам.

Предполагаемые действия.

Поиск и замена текста и чисел

Поиск текста и чисел

Замена текста и чисел

Выделение ячеек с особыми данными

Выделение пустых ячеек

Выделение ячеек, содержащих формулы

Выделение ячеек, содержащих константы

Выделение ячеек, содержащих примечания

Поиск ячеек, отличных от активной ячейки, в строке или столбце

Использование фильтра

Поиск данных с помощью фильтрации списка


 Выделение ячеек, удовлетворяющих определенным условиям

Выделение ячеек, удовлетворяющих определенным условиям

  1. Выделите ячейки, которые необходимо выделить.

  2. В меню Формат выберите команду Условное форматирование.

  3. Выполните одно из следующих действий:

    Чтобы в качестве условия форматирования использовать значения выделенных ячеек, выберите параметр значение, выберите операцию сравнения, а затем в необходимое поле введите значение. Ввести можно заданное значение или формулу, но перед формулой необходимо поставить знак равенства (=).

    Формула используется в качестве критерия форматирования для оценки данных или условий, отличных от значений выделенных ячеек. Слева из поля выберите параметр формула, а затем в поле справа введите формулу. Формула должна принимать логическое значение ИСТИНА или ЛОЖЬ.

  4. Выберите команду Формат.

  5. Выберите тип шрифта, его цвет, подчеркивание, рамку и затенение ячеек или узоры.

    Выбранные форматы будут применены, только если значение ячейки отвечает поставленному условию или если формула принимает значение ИСТИНА.

  6. Для добавления условия выберите команду Добавить, а затем повторите шаги 3-5.

    Может быть задано до трех условий. Если ни одно из заданных условий не принимают истинного значения, то формат ячеек остается прежним. Существующий формат можно использовать для определения четвертого условия.

Советы

  • Копирование форматов в другие ячейки Выделите ячейки, содержащие копируемый условный формат. Нажмите кнопку Формат по образцу [image] на панели инструментов Стандартная, а затем выделите ячейки, которые должны иметь тот же условный формат. Чтобы скопировать только условный формат, вместе с ячейками, которые необходимо отформатировать, выделите одну, имеющую условный формат, который необходимо скопировать. В меню Формат выберите команду Условное форматирование и нажмите кнопку OK.

  • Использование нескольких условий Если из нескольких указанных условий и более одного принимают истинное значение, то применяется только тот формат, который соответствует первому истинному условию.


 Просмотр группы строк списка с помощью фильтров

Просмотр группы строк списка с помощью фильтров

Фильтры могут быть использованы только для одного списка на листе.

  1. Укажите ячейку в фильтруемом списке.

  2. Выберите пункт Фильтр в меню Данные, а затем — команду Автофильтр.

  3. Чтобы отфильтровать строки, содержащие определенное значение, нажмите кнопку со стрелкой в столбце, в котором содержатся искомые данные.

  4. Выберите значение в списке.

  5. Повторите шаги 3 и 4, чтобы ввести дополнительные ограничения для значений в других столбцах.

    Чтобы отфильтровать список по двум значениям в одном столбце или применить отличные от равно операторы сравнения, нажмите кнопку со стрелкой, а затем выберите пункт Условие. Чтобы получить более подробные сведения об отображении строк с использованием условий сравнения, нажмите кнопку [image] .

Примечания

  • Если данные уже отфильтрованы по одному из столбцов, то при использовании фильтра для другого столбца будут предложены только те значения, которые видны в отфильтрованном списке.

  • С помощью команды Автофильтр на столбец можно наложить до двух условий. Используйте расширенный фильтр, если требуется наложить три или более условий, скопировать записи в другое место или отобрать данные на основе вычисленного значения. Для получения более подробных сведений о расширенных фильтрах нажмите [image] .


Подстановочные знаки, используемые при поиске текста и чисел

Для поиска текста или чисел, содержащих общие символы или цифры, используйте подстановочные знаки. Подстановочный знак заменяет один или несколько неуказанных символов.

Используйте | Чтобы найти
? (вопросительный знак) | Любой одиночный символ в той же позиции, что и вопросительный знак Например, «д?м» позволяет найти «дым» и «дом»
* (звездочка) | Любое число символов в той же позиции, что и звездочка Например, «секр*» позволяет найти «секрет» и «секретер»
~ (тильда), за которой следует ?, * или ~ | Вопросительный знак, звездочку или тильду Например, «что~?» позволяет найти «что?»


Вставка ячеек, строк и столбцов

Можно вставить пустые ячейки, строки и столбцы и заполнить их данными. Если ячейки перемещаются или копируются, их можно вставить между существующими ячейками, чтобы не стереть уже занесенную информацию.

Предполагаемые действия.

Вставка пустых ячеек

Вставка строк

Вставка столбцов

Вставка скопированных или перемещенных ячеек между существующими ячейками


 Вставка пустых ячеек

Вставка пустых ячеек

  1. Выделите диапазон, в который следует поместить новые ячейки. Его размер должен совпадать с количеством вставляемых ячеек.

  2. В меню Вставка выберите команду Ячейки.

  3. Выберите ячейки, со сдвигом вправо или ячейки, со сдвигом вниз.


Вставка столбцов

  1. Для вставки одного столбца щелкните ячейку в столбце, слева от которого следует разместить новый столбец. Например, если щелкнуть ячейку в столбце B, то слева от него будет вставлен новый столбец.

    Чтобы вставить несколько столбцов, выделите столбцы, справа от которых следует вставить новые столбцы. Количество выделенных и вставляемых столбцов должно совпадать.

  2. В меню Вставка выберите команду Столбец.


Вставка строк

  1. Для вставки одной строки щелкните ячейку в строке, над которой следует вставить новую строку. Например, если щелкнуть ячейку в строке 5, то над ней будет вставлена новая строка.

    Чтобы вставить несколько строк, выделите строки, над которыми следует вставить новые строки. Количество выделенных и вставляемых строк должно совпадать.

  2. В меню Вставка выберите команду Строка.


 Перемещение и копирование ячеек

Перемещение и копирование ячеек

При перетаскивании, а также при выборе команд Вырезать [image] или Копировать [image] и Вставить [image] , Microsoft Excel полностью копирует ячейку, включая формулы и возвращаемые ими значения, примечания и форматы.

Если область копирования содержит скрытые ячейки, они также будут скопированы. Существует возможность просмотреть все ячейки, которые содержатся в скрытых строках или столбцах области вставки.

Предполагаемые действия

Перемещение и копирование символов внутри ячейки

Перемещение и копирование части содержимого ячейки в другую ячейку

Перемещение и копирование всего содержимого ячейки

Копирование ячеек в строке или столбце

Копирование диапазона в несколько областей

Выбор и вставка нескольких элементов

Вставка скопированных или перемещенных ячеек между существующими ячейками

Предотвращение замещения данных при копировании пустых ячеек

Копирование только видимых ячеек


 Раздельное копирование значений, формул, примечаний и форматов ячейки

Раздельное копирование значений, формул, примечаний и форматов ячейки

Вместо копирования содержимого ячеек целиком можно скопировать только часть содержимого ячейки — например возвращаемое формулой значение, без копирования самой формулы.

  1. Выделите ячейки, которые нужно скопировать.

  2. Нажмите кнопку Копировать [image] .

  3. Укажите левый верхний угол области вставки.

  4. В меню Правка выберите команду Специальная вставка.

    Демонстрация

  5. Выберите параметр в группе Вставить, а затем нажмите кнопку OK.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечания

  • Не нажимайте клавишу ENTER после кнопки OK. В противном случае все ячейки, находящиеся внутри движущихся границ, будут скопированы в область вставки. Чтобы отменить движущуюся границу, нажмите клавишу ESC.

  • При копировании примечаний все примечания в области вставки замещаются.


 Копирование только видимых ячеек

Копирование только видимых ячеек

Если на листе есть скрытые ячейки, строки или столбцы, существует возможность исключить их из области копирования — например, скопировать только видимые итоговые данные на структуре листа.

  1. Выделите ячейки, которые нужно скопировать.

  2. В меню Правка выберите команду Перейти.

    Демонстрация

  3. Выберите Дополнительный.

  4. Выберите параметр только видимые ячейки и нажмите кнопку OK.

  5. Нажмите кнопку Копировать [image] .

  6. Укажите левый верхний угол области вставки.

  7. Нажмите кнопку Вставить [image] .

Примечание. Поскольку копируемые данные последовательно вставляются в строки и столбцы, может возникнуть необходимость просмотреть все скрытые строки и столбцы области вставки. .


 Транспонирование строк и столбцов при вставке данных

Транспонирование строк и столбцов при вставке данных

Данные из верхней строки области копирования отобразятся в левом столбце области вставки, и, соответственно, данные из левого столбца копируемой области отобразятся в верхней строке области вставки.

  1. Выделите ячейки, которые необходимо транспонировать.

  2. Нажмите кнопку Копировать [image] .

  3. Укажите левую верхнюю ячейку области вставки.

    Область вставки не должна совпадать с областью копирования.

  4. В меню Правка выберите команду Специальная вставка.
  5. Установите флажок Транспонировать.


 Предотвращение замещения данных при копировании пустых ячеек

Предотвращение замещения данных при копировании пустых ячеек

Описанная ниже процедура позволяет предотвратить потерю данных при копировании диапазона, содержащего пустые ячейки.

  1. Выделите ячейки, которые нужно скопировать.

  2. Нажмите кнопку Копировать [image] .

  3. Укажите левый верхний угол области вставки.

  4. В меню Правка выберите команду Специальная вставка.
  5. Установите флажок пропускать пустые ячейки.


 Хранение и вставка нескольких объектов с помощью буфера обмена Office

Хранение и вставка нескольких объектов с помощью буфера обмена Office

С помощью буфера обмена Office можно хранить несколько объектов и вставлять их в документы по мере надобности. Например, можно скопировать текст из документа Microsoft Word, переключиться в Excel и скопировать рисунок, переключиться в PowerPoint и скопировать маркированный список, затем переключиться в Access и скопировать таблицу, а после этого переключиться обратно в Word и вставить весь набор скопированных объектов.

Данный раздел содержит следующие сведения:

Автоматическое копирование нескольких объектов

Использование панели инструментов Буфер обмена

Сравнение буфера обмена Office и буфера обмена Windows

Емкость буфера обмена Office

Дополнительные сведения

Автоматическое копирование нескольких объектов

При выполнении любого из следующих действий в буфер обмена Office автоматически копируются несколько объектов.

  • Последовательное копирование или вырезание двух разных объектов в одной программе.

  • Копирование одного объекта, его вставка и затем копирование другого объекта в одной программе.

  • Последовательное копирование одного и того же объекта дважды.

Возврат в начало

Использование панели инструментов «Буфер обмена»

Для копирования нескольких объектов можно также воспользоваться кнопкой Копировать [image] панели инструментов Буфер обмена. При открытии буфера обмена Office в одной из программ Office он также будет отображаться при переключении в другую программу Office. Панель инструментов Буфер обмена недоступна в режимах просмотра, не допускающих использование команд Копировать, Вырезать и Вставить.

Если панель инструментов Буфер обмена доступна, то чтобы вставить все скопированные объекты, следует нажать кнопку Вставить все [image] , а чтобы вставить отдельный объект, следует щелкнуть этот объект. При использовании команды Вставить из меню Правка вставляется только последний скопированный объект. Однако после вставки отдельного объекта или всех объектов с помощью панели инструментов Буфер обмена при выборе команды Вставить происходит вставка объекта, вставленного последним из панели инструментов Буфер обмена.

Примечание. Настраивать панель инструментов Буфер обмена нельзя.

Возврат в начало

Сравнение буфера обмена Office и буфера обмена Windows

Буфер обмена Office работает отдельно от буфера обмена Windows. Если в буфер обмена Office копируется несколько объектов, то последний скопированный объект копируется также в буфер обмена Windows. При очистке буфера обмена Office происходит также очистка буфера обмена Windows. При использовании команды Вставить из меню Правка, кнопки Вставить или соответствующего сочетания клавиш (CTRL+V) происходит вставка содержимого буфера обмена Windows.

Возврат в начало

Емкость буфера обмена Office

В буфере обмена Office может содержаться до 12 объектов. Если в буфер обмена копируется тринадцатый объект, то отображается диалоговое окно с сообщением, что при копировании этого объекта из буфера обмена будет удален первый объект; при этом копирование тринадцатого объекта можно отменить. Находящиеся в буфере обмена Office объекты хранятся в нем до закрытия всех открытых программ Office.

Возможности вставки нескольких объектов и отображения буфера обмена Office доступны только в программах Office — Microsoft Excel, Word, Access, Outlook и PowerPoint. Тем не менее, если буфер обмена отображается в любой из программ Office, все вырезаемые или копируемые в любой программе объекты автоматически помещаются в этот буфер.

Возврат в начало

Дополнительные сведения

Выбор и вставка нескольких объектов

Вставка конкретного объекта из буфера обмена Office

Удаление всех элементов из буфера обмена Office

Возврат в начало


 Выбор и вставка нескольких объектов

Выбор и вставка нескольких объектов

  1. Выделите первый объект, который требуется скопировать.

  2. На панели инструментов Буфер обмена нажмите кнопку Копировать

  3. Если следующий объект, который требуется скопировать, находится в другой программе, переключитесь в эту программу.

  4. Выделите следующий объект, который требуется скопировать.

  5. На панели инструментов Буфер обмена нажмите кнопку Копировать.

    Если панель инструментов Буфер обмена недоступна, выберите команду Копировать в меню Правка.

  6. Повторите шаги 3 - 5 для копирования всех нужных объектов (до 12 объектов).

  7. Щелкните в том месте, куда требуется вставить объекты.

  8. Чтобы вставить все скопированные объекты, нажмите кнопку Вставить все [image] на панели инструментов Буфер обмена.

    Если вставлять все скопированные объекты не требуется, можно вставить отдельные объекты.

Примечания

  • Если панель инструментов Буфер обмена недоступна, это означает, что вы находитесь в программе или в режиме просмотра, не поддерживающем отображение и вставку нескольких объектов с помощью буфера обмена Office. Тем не менее, если буфер обмена Office отображается в любой из программ Office, все вырезаемые или копируемые в любой программе объекты будут автоматически помещаться в буфер обмена Office.

  • При использовании буфера обмена Office для копирования и вставки формулы в Microsoft Excel из буфера обмена Office вставляется значение, а не формула.

  • Если в Excel копируется несколько диапазонов и затем нажимается кнопка Вставить все, диапазоны вставляются в столбец один под другим.

  • В Excel кнопка Вставить все недоступна, если какой-либо из элементов, находящихся в буфере обмена, является графическим объектом или рисунком.


 Вставка конкретного объекта из буфера обмена Office

Вставка конкретного объекта из буфера обмена Office

  1. Щелкните в том месте, куда требуется вставить объект.

  2. На панели инструментов Буфер обмена щелкните объект, который требуется вставить.

    Если панель инструментов Буфер обмена закреплена, нажмите кнопку Элементы, а затем выберите элемент, который требуется вставить.

  3. Повторите шаг 2 для каждого объекта, который требуется вставить.

Совет. Чтобы просмотреть первые 50 текстовых символов элемента, установите указатель мыши над элементом. Если элемент не содержит текста для просмотра или является графическим объектом или рисунком, будет отображен текст "Объект n" или "Рисунок n", где n — число от 1 до 12, обозначающее очередность копирования элемента.


 Просмотр содержимого буфера обмена Office

Просмотр содержимого буфера обмена Office

  • В меню Вид выберите пункт Панели инструментов, а затем — панель инструментов Буфер обмена.

    Если панель инструментов Буфер обмена закреплена, нажмите кнопку Элементы.

Совет. Чтобы просмотреть первые 50 текстовых символов элемента, установите указатель мыши над элементом. Если элемент не содержит текста для просмотра или является графическим объектом или рисунком, будет отображен текст "Объект n" или "Рисунок n", где n — число от 1 до 12, обозначающее очередность копирования элемента.


 Удаление всех элементов из буфера обмена Office

Удаление всех элементов из буфера обмена Office

  • На панели инструментов Буфер обмена нажмите кнопку Очистить буфер обмена [image] .


Объединение текста и чисел в нескольких ячейках

Объединение текста

Объединение текста и чисел

Распределение текста по нескольким столбцам

Для объединения, или сцепления, нескольких строк текста или текста и чисел используется оператор конкатенации (&). Например, чтобы создать список имен, объединяющий имена в одном столбце с фамилиями в другом, следует создать формулу с оператором конкатенации.

Объединение текста

Имена в столбце полных имен являются комбинацией элементов столбца имен и элементов столбца фамилий.

В приведенном примере каждый элемент столбца имен объединяется с соответствующим элементом столбца фамилий для получения полного имени в столбце C. В формуле в ячейке C2 используется оператор конкатенации (&) для объединения текста ячейки A2 с текстом ячейки B2:

=A2&" "&B2

Обратите внимание на то, что в формулу между ячейками имени и фамилии с помощью кавычек вставлен пробел. Кавычки можно использовать для включения в результат любого текста.

Чтобы на первое место в полных именах поставить фамилию, следует изменить порядок формулы и поместить в кавычки запятую.

Чтобы изменить порядок элементов в результате, в ячейку C2 следует ввести формулу =B2&", "&A2.

Возврат в начало

Объединение текста и чисел

С помощью оператора конкатенации можно также объединять текст и значений, таких как числа и даты. Например, можно объединить имена продавцов с объемами продаж в процентах.

Объединенные вместе текст и значения

Формулы в области итогов объединяют значения столбца «Продавец» и столбца «% продаж».

В ячейке B19 в приведенном примере используется следующая формула:

=A14&" продал "&ТЕКСТ(B14,"0%")&" от всего объема продаж."

Обратите внимание на использование в формуле функции ТЕКСТ. Функция ТЕКСТ применяется для преобразования числа в текст в заданном формате при объединении численного значения с текстовой строкой с помощью оператора конкатенации. В формуле использовано исходное значение ячейки, включенной в ссылку (0,4 в данном примере), а не форматированное значение, отображаемое в ячейке (40%). Функция ТЕКСТ восстанавливает числовой формат.

Возврат в начало

Распределение текста по нескольким столбцам

Если требуется разделить столбец текста на два или более столбца, следует использовать Мастер текстов.

Дополнительные сведения

Примеры часто используемых формул

Применение операторов в формулах

Функция СЦЕПИТЬ

Возврат в начало


 Разбиение скопированного текста на столбцы

Разбиение скопированного текста на столбцы

  1. Переключитесь на программу и файл, из которого следует скопировать данные.

  2. Выделите копируемые данные.

  3. В меню программы Правка выберите команду Копировать.

  4. Переключитесь на книгу Microsoft Excel, щелкните верхнюю левую ячейку области вставки и затем нажмите кнопку Вставить [image] .

  5. Выделите ячейки, содержащие вставленные данные.

    Выделенная область может содержать любое число строк, но только один столбец.

  6. В меню Данные выберите команду Текст по столбцам.

  7. Следуйте инструкциям мастера текстов для указания способа разбиения текста на столбцы.


Проверка орфографии и автоматическое исправление ошибок

Предполагаемые действия

Проверка орфографии

Исправление в процессе ввода орфографических ошибок и опечаток

Добавление слов в дополнительный словарь

Добавление автоматически исправляемого слова при проверке орфографии

Дополнительные сведения


Проверка орфографии и исправление ошибок в процессе ввода

Проверка орфографии Орфография проверяется на текущем листе в значениях в ячейках и примечаниях к ним, во внедренных диаграммах и надписях, а также в кнопках и колонтитулах. Орфография не проверяется на защищенных листах, в формулах или в тексте, возвращаемом формулой.

Если в момент запуска проверки орфографии строка формул активна, то Excel проверяет только содержимое строки формул. Если выделен диапазон, то проверяются только ячейки внутри диапазона. Полная проверка орфографии.

Исправление орфографических ошибок и опечаток при вводе Возможность автозамены в Excel позволяет исправить часто встречающиеся ошибки при вводе слов. Например, можно изменить «авш» на «ваш» и «чтоыб» на «чтобы».

Добавление слов во вспомогательный словарь Если используются слова, не занесенные в основной словарь — например акронимы и собственные имена — можно добавить слова во вспомогательный словарь. После этого слово будет считаться ошибочным, если оно написано неправильно.

Добавление элемента списка замены при проверке орфографии Если слово часто пишется неправильно, можно добавить неправильное написание в качестве элемента списка замены. Всякий раз, когда слово будет написано таким же образом, оно будет автоматически исправлено.

Примечания

  • Формат словарей и списка автозамены Excel соответствует другим приложениям Microsoft Office.

  • Язык используемого списка автозамены зависит от раскладки клавиатуры.


 Запрет автоматической замены

Запрет автоматической замены

  1. Выберите команду Автозамена в меню Сервис.

    Демонстрация

  2. Чтобы запретить автозамену, снимите флажок Заменять при вводе.

    Снимите остальные флажки, чтобы запретить другие виды изменений.


 Правка элемента списка автозамены

Правка элемента списка автозамены

  1. Выберите команду Автозамена в меню Сервис.

    Демонстрация

  2. Чтобы изменить ключевые буквы, выберите запись в списке и нажмите кнопку Удалить. Введите новое сокращение в поле заменять и нажмите кнопку Добавить.

    Чтобы изменить автоматически заменяемое слово, выберите его в списке. Сделайте необходимое в поле на и нажмите кнопку Заменить.


 Удаление элемента списка автозамены

Удаление элемента списка автозамены

  1. Выберите команду Автозамена в меню Сервис.

    Демонстрация

  2. Укажите удаляемую запись в списке.

  3. Нажмите кнопку Удалить.


 Запрет автоматического преобразования сокращений или слов, написанных прописными буквами

Запрет автоматического преобразования сокращений или слов, написанных прописными буквами

  1. Выберите команду Автозамена в меню Сервис.

    Демонстрация

  2. Нажмите кнопку Исключения.

  3. Чтобы запретить преобразование первой буквы слова, являющегося сокращением, в прописную, выберите вкладку Первая буква и введите сокращенное слово, включая точку, в поле Не заменять на прописную после.

    Чтобы запретить преобразование слова, содержащего и строчные и прописные буквы, выберите вкладку ДВе ПРописные и введите слово в поле Не заменять.

  4. Нажмите кнопку Добавить, а затем — кнопку OK.


 Добавление слов в дополнительный словарь

Добавление слов в дополнительный словарь

  1. Нажмите кнопку Орфография [image] .

  2. При появлении слова, отсутствующего в словаре, укажите дополнительный словарь в поле с раскрывающимся списком Добавлять слова в.

  3. Нажмите кнопку Добавить.

Советы

  • Для правильного распознавания слов, написанных строчными и прописными буквами, необходимо добавлять в словарь слова, состоящие только из строчных букв.

  • Чтобы создать новый вспомогательный словарь, введите его имя в поле с раскрывающимся списком Добавлять слова в, а затем нажмите кнопку Добавить.

  • Чтобы добавить в словарь список новых слов, откройте словарь, используемый в Microsoft Excel, в Microsoft Word или Блокноте. Введите каждое новое слово в отдельной строке (после ввода слова нажмите клавишу ENTER). Сохраните файл в текстовом формате, присвоив расширение ".dic", например "custom.dic". Переместите словарь в папку, содержащую основной словарь.


 Добавление автоматически исправляемого слова при проверке орфографии

Добавление автоматически исправляемого слова при проверке орфографии

  1. Нажмите кнопку Орфография [image] .

  2. При появлении слова, отсутствующего в словаре, введите правильное слово в поле Заменить на.

    Если в написании слова возможны варианты, установите флажок Предлагать варианты и выберите правильное слово в списке Варианты.

  3. Чтобы ошибочное слово автоматически исправлялось при вводе, нажмите кнопку Автозамена.


 Проверка орфографии на иностранном языке

Проверка орфографии на иностранном языке

Для выполнения этой процедуры необходимо установить требуемый язык с помощью Пакета многоязыковой поддержки Microsoft Office 2000.

  1. Выделите диапазон ячеек, в которых необходимо проверить орфографию.

    Укажите любую ячейку, чтобы проверить орфографию на всем листе.

  2. Нажмите кнопку Орфография [image] .

  3. В поле Язык словаря выберите язык, словарь которого будет использоваться.


Разрешение вопросов, возникающих при изменении данных

В чем именно заключаются сложности?

Вставка неверных данных при нажатии клавиши ENTER

При копировании или перемещении формул изменяются содержащиеся в них ссылки

Не работают команды Найти и Заменить

Не удается отменить последнее действие.

После вырезания с последующей вставкой выделение пропадает


Разрешение вопросов при выборе и вставке объектов

Не удается добавить дополнительные объекты в буфер обмена Office

Панель Буфер обмена не отображается при копировании и вставке объектов с помощью сочетаний клавиш

Панель инструментов Буфер обмена недоступна


Разрешение вопросов, возникающих при выполнении проверки орфографии

В чем именно заключаются сложности?

Слово, добавленное в дополнительный словарь, считается ошибочным при проверке орфографии

Орфография проверяется только в части листа

Даже если нажать кнопку Заменить все, при проверке орфографии исправляются не все слова


 Форматирование листа

Форматирование листа

Используйте эти возможности форматирования для эффективного отображения данных.

Форматирование текста и отдельных символов Чтобы выделить текст, можно отформатировать весь текст в ячейке или только отдельные символы. Выделите символы, которые нужно отформатировать, и нажмите кнопку на панели инструментов Форматирование.

Кнопки форматирования текста на панели инструментов «Форматирование»

Вращение текста и границ Данные в столбце занимают, как правило, гораздо меньше места, чем нужно для подписи столбца. Чтобы не создавать неоправданно широкие столбцы или использовать сокращенные обозначения в подписях столбцов, можно повернуть текст и наложить границы, которые будут повернуты на тот же угол, что и текст.

Текст и границы повернуты на 45 градусов

Добавление границ, цветов и узоров Для разделения различных типов информации на листе можно обвести границы ячеек, затенить фон ячейки или затенить ячейки цветным узором.

Текст с обведенной границей и цветным фоном

Использование наилучшего числового формата Числовые форматы позволяют изменять внешний вид чисел, включая даты и время, не изменяя внутреннее представление чисел.

Строка формул и связанная с ней ячейка

Быстрое форматирование ячеек и списков Если данные организованы в виде списка, существует несколько способов быстрого форматирования списка с помощью автоформатов, стилей или кнопки Формат по образцу.


 Копирование форматов одних ячеек на другие

Копирование форматов одних ячеек на другие

  1. Выделите ячейку или диапазон ячеек, формат которых необходимо скопировать.

  2. На панели инструментов Стандартная нажмите кнопку Формат по образцу [image] .

  3. Выделите ячейку или диапазон ячеек, в который необходимо скопировать формат.

Советы

  • Копирование в несколько мест. Для копирования формата выбранной ячейки или диапазона ячеек в несколько мест дважды щелкните кнопку Формат по образцу. После завершения копирования снова нажмите эту кнопку.

  • Копирование ширины столбца. Выделите заголовок столбца, ширину которого необходимо копировать и нажмите кнопку Формат по образцу, а затем выделите заголовок столбца, ширину которого нужно изменить.


Изменение размера, шрифта и других форматов текста

Предполагаемые действия

Изменение шрифта и его размера

Сжатие текста для отображения в ячейке всех данных

Изменение шрифта и его размера, установленного по умолчанию в новых книгах

Изменение цвета текста

Изменение начертания выделенного текста


 Отображение нескольких строк текста внутри ячейки

Отображение нескольких строк текста внутри ячейки

  1. Выделите ячейки, формат которых необходимо изменить.

  2. В меню Формат выберите команду Ячейки, а затем откройте вкладку Выравнивание.

    Демонстрация

  3. В поле Отображение установите флажок переносить по словам.

Советы

  • Для начала новой строки текста с определенного места на панели формул (или в ячейке, если редактирование производится в ячейке) выберите место, где строка должна прерваться, а затем нажмите клавиши ALT+ENTER.

  • Можно также уменьшить размер шрифта для отображения всех данных в ячейке.


 Изменение шрифта и его размера

Изменение шрифта и его размера

  1. Выделите ячейки или определенный текст в ячейке, формат которого необходимо изменить.

    Инструкции

  2. Выберите нужный шрифт в списке Шрифт [image] на панели инструментов Форматирование.

    В поле Размер [image] выберите требуемый размер шрифта.


 Сжатие текста для отображения в ячейке всех данных

Сжатие текста для отображения в ячейке всех данных

Если в ячейке видны не все данные, то чтобы не пришлось изменять ширину столбца, размер шрифта этих данных можно уменьшить.

Для отображения в ячейке нескольких строк на вкладке Выравнивание установите флажок переносить по словам.

  1. Выделите ячейки, формат которых необходимо изменить.

  2. В меню Формат выберите команду Ячейки, а затем откройте вкладку Выравнивание.

    Демонстрация

  3. Установите флажок автоподбор ширины.


 Изменение цвета текста

Изменение цвета текста

  1. Выделите ячейки или определенный текст в ячейке, формат которого необходимо изменить.

    Инструкции

  2. Чтобы использовать последний выбранный цвет, выберите мышью элемент Цвет текста [image] на панели инструментов Форматирование.

    Для использования другого цвета нажмите стрелку рядом с кнопкой Цвет шрифта [image] , а затем выберите необходимый цвет.


 Изменение начертания выделенного текста

Изменение начертания выделенного текста

  1. Выделите ячейки или определенный текст в ячейке, формат которого необходимо изменить.

    Инструкции

  2. Нажмите нужную кнопку на панели инструментов Форматирование.
    Цель | Действие
    Жирный текст | Нажмите кнопку Ж на панели форматирования
    Выделение текста курсивом | Нажмите кнопку К на панели форматирования
    Подчеркивание текста | Нажмите на панели форматирования кнопку подчеркивание


Форматирование отчета сводной таблицы

Предполагаемые действия.

Изменение формата

Изменение форматирования символов и ячеек сводной таблицы

Изменение числового формата в области данных отчета сводной таблицы

Изменение способа отображения ошибок и пустых ячеек отчетом сводной таблицы

Использование объединенных и обычных ячеек для подписей крайних столбцов и строк в отчете сводной таблицы

Изменение макета

Вставка пустой строки после каждой группы элементов в последнем поле строки сводной таблицы

Преобразование отчета сводной таблицы в структурированный или неструктурированный формат

Изменение макета отчета сводной таблицы

Не можете сделать выбор?


 Использование рамок в ячейках

Использование рамок в ячейках

  1. Выделите ячейки, в которые необходимо добавить рамку.

  2. Чтобы использовать последний выбранный цвет, нажмите кнопку Границы [image] на панели инструментов Форматирование.

    Для использования другого типа рамки нажмите стрелку рядом с кнопкой Границы [image] и выберите требуемый тип рамки.

Советы

  • Дополнительные параметры границы Чтобы использовать дополнительные типы рамок, в меню Формат выберите команду Ячейки, а затем перейдите к вкладке Граница. Выберите требуемый тип линии, а затем укажите место применения выбранной рамки.

  • Границы и повернутый текст Для применения рамок к выделенным ячейкам, содержащим повернутый текст, используйте кнопки Внешние [image] и Внутренние [image] на вкладке Границы. Рамка будет использована на границах ячеек, повернутых на тот же угол, что и текст.

  • Типы линий границы Для изменения типа линии уже существующей рамки выделите ячейки, на которых рамка отображена. На вкладке Граница в поле Тип линии выберите необходимый тип, а затем в диаграмме, расположенной ниже поля Отдельные, укажите границу, которую необходимо изменить.


 Затенение фона ячеек цветом

Затенение фона ячеек цветом

  1. Выделите ячейки, которые необходимо затенить.

  2. Чтобы использовать последний выбранный цвет, выберите мышью элемент Цвет заливки [image] на панели инструментов Форматирование.

    Для использования другого цвета нажмите стрелку рядом с кнопкой Цвет заливки [image] , а затем выберите необходимый цвет.


Затенение ячеек узором

  1. Выделите ячейки, которые необходимо затенить.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Вид.

  3. Для использования цвета фона с узором выберите необходимый цвет в поле Заливка ячеек.

  4. Нажмите стрелку рядом с полем Узор, а затем выберите необходимый узор и цвет.

    Если цвет узора не выбран, то он будет черным.


 Удаление границ

Удаление границ

  1. Выделите ячейки, границы которых требуется удалить.

  2. На панели инструментов Форматирование щелкните стрелку рядом с кнопкой Границы [image] и нажмите на открывшейся панели кнопку [image].


 Удаление затенения

Удаление затенения

  1. Выделите ячейки, для которых необходимо удалить затенение.

  2. На панели инструментов Форматирование, щелкните стрелку Цвет заливки [image] , и выберите Нет заливки.


 Добавление рисунка подложки на весь лист

Добавление рисунка подложки на весь лист

  1. Выделите лист, на который необходимо добавить рисунок подложки.

  2. В меню Формат выберите команду Лист, а затем — Подложка.

    Демонстрация

  3. Выберите графический файл, который будет использоваться в качестве узора подложки.

    Выделенный рисунок повторяется для заполнения всего листа. К ячейкам, содержащим данные, можно применить цветовое затенение.

Примечания

  • Если команда Подложка недоступна, убедитесь, что был выбран только один лист.

  • Подложка не печатается и не сохраняется на отдельных страницах при сохранении их как Web-страницы. Однако при сохранении всей книги как Web-страницы подложка сохраняется.


Удаление рисунка подложки листа

  1. Выберите лист с подложкой, которую необходимо удалить.

  2. В меню Формат выберите команду Лист, а затем команду Подложка. .


Выделение ячеек, удовлетворяющих определенным условиям

Если ячейка содержит результат формулы или другие значения, которые необходимо контролировать, можно выявить ячейки применением условных форматов. Например, можно залить ячейку зеленым цветом, если объем продаж превосходит прогноз, и красным — если продажи упали.

Значения в ячейках, выделенные согласно условиям

Изменение условий Если значение ячейки изменилось и больше не удовлетворяет заданному условия, Microsoft Excel временно скрывает форматы, соответствующие этому условию. Условные форматы остаются примененными к ячейки до тех пор, пока они не будут удалены, даже если не выполняется ни одно из условий и ни один из указанных форматов ячейки не отображается.

Общие книги и отчеты сводных таблиц В общей книге работают условные форматы, примененные до открытия доступа к книге. Однако невозможно изменить существующие условные форматы или применить новые. Попытка применить условные форматы к ячейкам отчета сводной таблицы может привести к непредсказуемым результатам.


 Изменение, добавление и удаление условных форматов

Изменение, добавление и удаление условных форматов

  1. Выделите ячейку, имеющую условный формат, который необходимо удалить или изменить.

  2. В меню Формат выберите команду Условное форматирование.

    Демонстрация

  3. Для каждого условия измените оператор, значения или формат.

    Для изменения формата выберите команду Формат для каждого условия, которое необходимо изменить. Для повторного выбора форматов на текущей вкладке диалогового окна Формат ячеек выберите команду Очистить.

    Для добавления нового условия выберите команду Добавить.

    Для удаления одного или нескольких условий выберите команду Удалить, а затем установите флажки для тех условий, которые необходимо удалить.

Совет. Чтобы для выделенных ячеек удалить как условные, так и другие форматы, в меню Формат установите указатель на пункт Очистить и выберите команду Форматы.


 Поиск ячеек, имеющих условный формат

Поиск ячеек, имеющих условный формат

  1. Для поиска ячеек, имеющий особый условный формат, выберите условный критерий поиска и формат, который необходимо найти.

    Для поиска всех ячеек на листе, имеющий условный формат, выберите любую ячейку.

  2. В меню Правка выберите команду Перейти.

    Демонстрация

  3. Выберите Дополнительный.

  4. Выберите условные форматы.

  5. Для поиска ячеек с одинаковым условным форматом выберите параметр этих же в окне Проверка вводимых значений.

    Для поиска всех ячеек, имеющих условный формат, выберите всех.


 Формулы в качестве критерия форматирования

Формулы в качестве критерия форматирования

Значения выделенных ячеек можно сравнивать с константой или с результатами вычислений по формуле. Чтобы определить критерий форматирования при оценке данных в ячейках, не входящих в выделенный диапазон, или при проверке нескольких критериев, можно использовать логическую формулу.

  • Использование значения ячейки в качестве условия Чтобы при выбранном параметре значение сравнить значения выделенных ячеек с результатом формулы, формула должна начинаться со знака равенства (=).

  • Использование формулы в качестве условия Если был выбран параметр формула, то указанная формула должна принимать значения ИСТИНА (1) или ЛОЖЬ (0). Формула должна начинаться со знака равенства (=). Вычисления по данной формуле могут производиться только на активном листе. Чтобы оценить данные на другом листе или в другой книге, на активном листе необходимо определить имя для данных на другом листе или в другой книге либо ввести ссылку на эти данные в ячейке активного листа, затем сослаться на указанную ячейку или имя в формуле. Например, чтобы оценить данные, содержащиеся в ячейке A5 на Листе1 книги Fiscal Year.xls, в ячейку активного листа введите следующую ссылку, включая знак равенства (=): =[Fiscal Year.xls]ЛИСТ1!$A$5

    При помощи формулы можно также оценивать критерии, не основанные на данных листа. Например, формула =ДЕНЬНЕД("12.5.99")=1 принимает значение ИСТИНА, если дата 12 мая 1999 г. является воскресеньем. Значение ячейки никак не влияет на истинность условия только в том случае, если в формуле нет специальных ссылок на форматируемые выделенные ячейки. Если же формула ссылается на выделенные ячейки, то в нее необходимо ввести ссылки на ячейки.

  • Использование ссылок на ячейки в качестве условия Ссылки на ячейки можно ввести в формулу, выделив ячейки непосредственно на листе. Выделение ячеек на листе вставляет абсолютные ссылки. Если необходимо, чтобы ссылки для каждой ячейки в выделенном диапазоне были согласованы, используйте относительные ссылки.

  • Использование дат Даты и время рассматриваются как числа. Например, при сравнении содержимого ячейки с датой 7 января 2001, дата будет представлена в виде числа 36898.

Пример 1: Использование даты в ячейке

В приведенном ниже примере условные форматы, примененные к ячейкам B2:E3, используются для анализа вклада ежеквартальных вложений в общий годовой итог. Если вложения, сделанные в течение квартала, составили 30 и более процентов от общего годового итога, то результаты отображаются полужирным зеленым шрифтом. Если же вложения, сделанные в течение квартала, составили 20 и менее процентов, то результаты отображаются полужирным красным шрифтом.

Значения в ячейках, форматированные согласно условиям

Приведенная ниже таблица указывает условные форматы для ячеек B2:E3. В формуле определяется относительная часть (номер строки) ссылки на ячейку $F2, чтобы каждая ячейка из диапазона B2:E3 сравнивалась с соответствующим значением итога в столбце F.

 | Значение ячейки | Формула | Форматы
Условие 1 | Больше или равно | =$F2*0.3 | Полужирный зеленый шрифт
Условие 2 | Меньше или равно | =$F2*0.2 | Полужирный красный шрифт

Пример 2: Использование формулы и ссылки на внешние ячейки

В приведенном ниже примере формула проверяет данные, находящиеся за пределами выделенного диапазона, к которым применено условное форматирование. Если среднее значение диапазона $A$1:$A$5 превышает 3,000 и если значения в диапазоне больше или равны 1800, то формула принимает значение ИСТИНА, а ячейки заливаются зеленым цветом. Отформатированные ячейки могут содержать как текст, так и любые другие значения, так как они не используются в формуле.

 | Формула | Форматы
Условие 1 | =И(СРЗНАЧ($A$1:$A$5)>3000, МИН($A$1:$A$5)>=1800) | Заливка зеленым цветом

Пример 3: Использование формулы и ссылки на ячейку

В приведенном ниже примере условный формат выделяет синим шрифтом четные числа из выделенного диапазона A4:D20. При помощи функции ОСТАТ все числа делятся на 2 и, если остаток равен 0, то формула принимает значение ИСТИНА.

 | Формула | Форматы
Условие 1 | =ОСТАТ(A4,2)=0 | Синий шрифт

Эта формула должна оценивать все ячейки в диапазоне. При вводе такой формулы в диалоговом окне Условное форматирование рекомендуется вводить ссылку только на активную ячейку в выделенном диапазоне. Microsoft Excel устанавливает ссылки для других ячеек относительно активной.

Проверка условного формата перед его применением Убедиться в правильности ссылок в формуле можно, применив сначала условный формат к одной из ячеек в диапазоне. А затем, выделив весь диапазон, в меню Формат выберите команду Условное форматирование и нажмите кнопку OK. Примененный к первой ячейке условный формат будет использован на всем диапазоне, а формула для каждой ячейки будет настроена правильно.


 Изменение ширины столбца

Изменение ширины столбца

  • Перемещайте правую границу заголовка столбца до тех пор, пока его ширина не достигнет необходимого размера.

    Граница столбца перемещена

Отображаемая ширина столбца говорит о среднем числе символов 0-9 стандартного шрифта, помещающихся в ячейке.

Советы

  • Подбор ширины столбца Для подбора ширины столбца в соответствии с содержимым его ячеек, дважды щелкните правую границу заголовка. Чтобы выполнить эту операцию со всеми столбцами на странице, нажмите кнопкуВыделить все и дважды щелкните правую границу заголовка любого из столбцов.

  • Изменение нескольких столбцов Чтобы изменить ширину нескольких столбцов, выделите столбцы, которые необходимо изменить, затем переместите правую границу заголовка столбца. Чтобы изменить ширину всех столбцов на листе, нажмите кнопку Выделить все, а затем переместите границу заголовка любого столбца.

  • Изменение ширины столбцов вручную. Чтобы изменить ширину столбца вручную, выделите столбец, выберите команду Столбец в меню Формат, затем — команду Ширина и введите необходимую ширину.

  • Копирование ширины столбца . Чтобы столбцы имели одинаковую ширину, выделите ячейку в одном из столбцов, нажмите кнопку Копировать [image] на панели инструментов Стандартная и затем выделите столбец, ширина которого изменяется. В меню Правка выберите команду Специальная вставка и затем выберите Ширины столбцов.


 Изменение высоты строки

Изменение высоты строки

  • Перемещайте с помощью мыши нижнюю границу заголовка строки до тех пор, пока высота строки не достигнет необходимого размера.

    Граница строки перемещена

Советы

  • Подбор высоты строки . Чтобы подобрать высоту строки в соответствии с содержимым, поместите указатель на нижнюю границу заголовка и дважды нажмите кнопку мыши.

  • Изменение нескольких строк Чтобы изменить высоту нескольких строк, выделите строки, которые необходимо изменить, а затем переместите нижнюю границу заголовка строки. Чтобы изменить высоту всех строк на листе, нажмите кнопку Выделить все, а затем переместите нижнюю границу заголовка любой строки.


 Объединение ячеек для охватывания нескольких столбцов или строк

Объединение ячеек для охватывания нескольких столбцов или строк

В объединенную ячейку Microsoft Excel помещает только данные верхнего левого угла из выделенного диапазона. Для включения в объединенную ячейку всех данных диапазона скопируйте все данные в верхнюю левую ячейку внутри диапазона. Для получения дополнительных сведений о копировании данных нажмите кнопку [image] .

  1. Выделите ячейки, которые необходимо объединить.

  2. Для объединения ячеек и выравнивания по центру содержимого ячеек нажмите кнопку Объединить и поместить в центре [image] на панели инструментов Форматирование.

    Чтобы объединить все выделенные ячейки в строке или столбце, в меню Формат выберите команду Ячейки, затем перейдите к вкладке Выравнивание и установите флажок объединение ячеек.

Совет. В объединенной ячейке текст можно выровнять при помощи кнопок По левому краю [image] , По центру [image] или По правому краю [image] на панели инструментов Форматирование. Для внесения других изменений в форматирование текста, включая выравнивание по вертикали, используйте параметры вкладки Выравнивание (команда Ячейки в меню Формат).


 Разбивка объединенной ячейки на несколько ячеек

Разбивка объединенной ячейки на несколько ячеек

  1. Выберите объединенную ячейку.

  2. В меню Формат выберите команду Ячейки, а затем откройте вкладку Выравнивание.

    Демонстрация

  3. Снимите флажок объединение ячеек.


 Центрироваание, выравнивание, сдвиг и вращение данных в ячейке

Центрироваание, выравнивание, сдвиг и вращение данных в ячейке

В ячейках, в которых по умолчанию установлен общий формат, текст выровнен по левому краю, а числа, даты, время - по правому. При изменении выравнивания тип данных не меняется.

Для центрирования или выравнивания данных, занимающих несколько столбцов или строк, например, название столбца или строки, выделенный диапазон ячеек можно объединить и в полученной объединенной ячейке выровнять текст.

Предполагаемые действия

Центрирование данных или выравнивание по левому или правому краю

Сдвиг текста от левого края ячейки

Вращение текста в ячейке

Выравнивание данных наверху, в центре и внизу ячейки


 Числовые форматы

Числовые форматы

Данный раздел содержит следующие сведения:

Общий числовой формат

Встроенные числовые форматы

Пользовательские числовые форматы

В Microsoft Excel можно изменить формат числа, включая дату и время, без изменения формата других чисел. Применяемый числовой формат не влияет на значение в ячейке (отображается в строке формул), которое Excel будет использовать при вычислениях.

Строка формул и связанная с ней ячейка

Общий числовой формат

Общий числовой формат используется по умолчанию. В большинстве случаев отображается то, что вводится в ячейку, имеющую общий формат. Однако если ширины ячейки недостаточно для отображения всего числа, общий числовой формат округляет число или использует научное представление для больших чисел. Можно восстановить общий числовой формат.

Возврат в начало

Встроенные числовые форматы

Excel содержит множество встроенных числовых форматов. Для просмотра полного списка форматов, выберите команду Ячейки в меню Формат и перейдите на вкладку Число. Форматы объединены в категории: денежный, дата, время, дробный, текстовый или экспоненциальный. Категория Дополнительный формат включает в себя почтовые индексы и телефонные номера. Параметры каждой категории можно посмотреть справа от листа Категории.

Возврат в начало

Пользовательские числовые форматы

При необходимости, можно создать пользовательский числовой формат. Используйте категорию Все форматы на вкладке Число (меню Формат, команда Ячейки) для создания пользовательского числового формата. Пользовательский числовой формат использует коды, описывающие отображение числа, даты, времени или текста.

Возврат в начало

Дополнительные сведения

Основные коды, используемые в пользовательских числовых форматах

Пользовательские форматы даты и времени

Пользовательские денежные, процентные и экспоненциальные форматы

Пользовательские форматы текста


 Сброс числового формата

Сброс числового формата

  1. Выделите ячейки, формат которых требуется изменить.

  2. Выберите в меню Формат команду Ячейки и перейдите на вкладку Число.
  3. В поле Числовые форматы выберите Общий.


 Изменение внешнего вида числа без изменения самого числа

Изменение внешнего вида числа без изменения самого числа

В Microsoft Excel можно использовать числовые форматы для изменения внешнего вида чисел, включая даты и значения времени, не изменяя при этом внутреннее представление чисел. Например, число 0,08 можно отобразить как 8%.

  1. Выделите ячейки, формат которых требуется изменить.

  2. Выберите в меню Формат команду Ячейки, а затем перейдите на вкладку Число.

    Демонстрация

  3. В поле Числовые форматы выберите формат, а затем укажите нужные параметры.

Примечание. Если нужный формат найти не удалось, можно создать пользовательский числовой формат.


 Увеличение или уменьшение числа отображаемых десятичных знаков

Увеличение или уменьшение числа отображаемых десятичных знаков

  1. Выделите ячейки, формат которых требуется изменить.

  2. На панели инструментов Форматирование нажмите одну из следующих кнопок.

    Для того чтобы после запятой отображалось меньшее число цифр, нажмите кнопку Уменьшить разрядность [image] .

    Для того чтобы после запятой отображалось большее число цифр, нажмите кнопку Увеличить разрядность [image] .

Примечания

  • Числовые форматы. Числовые форматы позволяют изменять внешний вид чисел, включая даты и время, не изменяя внутреннее представление чисел.

  • Встроенные числовые форматы. Число десятичных знаков можно также задать во встроенном числовом формате. Для этого выберите в меню Формат команду Ячейки и перейдите на вкладку Число. В списке Числовые форматы выберите Денежный, Финансовый, Процентный или Экспоненциальный. В поле Число десятичных знаков введите нужное число десятичных знаков.

  • Фиксированное число десятичных знаков. Также можно задать число десятичных знаков, используемое при вводе чисел в книгу.


 Отображение чисел в виде почтового индекса, телефонного номера и тому подобное

Отображение чисел в виде почтового индекса, телефонного номера и тому подобное

  1. Выделите ячейки, формат которых требуется изменить.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Число.

    Демонстрация

  3. В списке Числовые форматы выберите Дополнительный и затем требуемый формат.

Примечания

  • Если диапазон ячеек включает как пяти-, так и девятизначный код товара, можно применить пользовательский формат, который будет правильно отображать любой тип кода. В списке Числовые форматы выберите (все форматы) и в поле Тип введите следующую строку:

[<=99999]00000;00000-0000

  • Если нужный формат найти не удалось, можно создать пользовательский числовой формат.

  • Можно использовать числовые форматы для изменения отображения чисел, включая дату и время, без изменения внутреннего представления чисел.


 Отображение чисел в виде дробей

Отображение чисел в виде дробей

  1. Выделите ячейки, формат которых требуется изменить.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Число.

    Демонстрация

  3. В списке Числовые форматы выберите Дробный и затем выберите тип дроби, который будет использоваться.

Примечание. Числовые форматы позволяют изменять внешний вид чисел, включая даты и время, не изменяя внутреннее представление чисел.


 Отображение чисел в виде процентов

Отображение чисел в виде процентов

  1. Выделите ячейки, формат которых требуется изменить.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Число.

    Демонстрация

  3. В поле Числовые форматы выберите Процентный.

Примечания

  • Числа большие 1 автоматически вводятся как проценты; а числа, меньшие 1, преобразуются в проценты умножением на 100. Например, вводя 10, получаем 10%, вводя 0,1 — 10%. Чтобы все числа преобразовывались умножением на 100, в меню Сервис выберите команду Параметры и на вкладке Правка сбросьте флажок Автоматический ввод процентов.

  • Чтобы быстро отображать числа в виде процентов от 100, нажмите кнопку Процентный формат [image] на панели инструментов Форматирование.

  • Можно использовать числовые форматы для изменения отображения чисел, включая дату и время, без изменения внутреннего представления чисел.


 Отображение или скрытие разделителя групп разрядов в числе

Отображение или скрытие разделителя групп разрядов в числе

  1. Выделите ячейки, формат которых требуется изменить.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Число.

    Демонстрация

  3. В поле Числовые форматы выберите Числовой.

  4. Установите или снимите флажок Разделять группы разрядов (000).

Примечания

  • Чтобы быстро добавить разделители групп разрядов, выделите ячейки и нажмите кнопку Формат с разделителями [image] на панели инструментов Форматирование.

  • Можно использовать числовые форматы для изменения отображения чисел, включая дату и время, без изменения внутреннего представления чисел.


 Отображение начальных и конечных нулей в числах

Отображение начальных и конечных нулей в числах

Для сохранения вводимых начальных и конечных нулей можно использовать пользовательские числовые форматы.

  1. Выделите ячейки, формат которых требуется изменить.

  2. Выберите в меню Формат команду Ячейки, а затем перейдите на вкладку Число.

    Демонстрация

  3. В поле Числовые форматы выберите (все форматы).

  4. В меню Тип отредактируйте формат числа для создания своего формата.

    Редактирование встроенного формата не удаляет его.

    Для отображения | Используйте шаблон
    12 в виде 00012 и 123 в виде 00123 | 00000
    12 в виде 00012 и 123 в виде 000123 | "000"#
    123 в виде 0123 | "0"#
    8,9 в виде 8,900 | #,000
    0,631 в виде 0,6 | 0,#

Примечания

  • Можно использовать числовые форматы для изменения отображения чисел, включая дату и время, без изменения внутреннего представления чисел.

  • См. сведения об использовании пользовательских форматов для десятичных разрядов и значащих цифр.

  • Также можно использовать текстовый оператор & (амперсанд), чтобы сцепить (объединить) два значения для получения одного непрерывного текстового значения.


Отображение и скрытие нулевых значений

По умолчанию нулевые значения представлены в виде 0 (нулей). Для вывода на экран нулевых значений листа в виде пустых ячеек или для скрытия нулей необходимо изменить соответствующий параметр.

Предполагаемые действия

Отображение и скрытие нулевых значений на всем листе

Скрытие нулевых значений или других данных в выделенном диапазоне


 Отображение и скрытие нулевых значений на всем листе

Отображение и скрытие нулевых значений на всем листе

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Вид.

    Демонстрация

  2. Выполните одно из следующих действий:

    Для отображения в ячейках нулевых (0) значений установите флажок Нулевые значения.

    Для отображения нулевых значений в виде пустых ячеек снимите данный флажок.


 Скрытие нулевых значений в выделенном диапазоне

Скрытие нулевых значений в выделенном диапазоне

Внимание! В данном разделе описывается скрытие нулевых значений в выделенном диапазоне посредством применения формата. Если значение в одной из ячеек такого диапазона меняется на ненулевое, формат этого значения будет аналогичен общему числовому формату.

  1. Выделите ячейки, содержащие нули (0), которые требуется скрыть.

  2. Выберите в меню Формат команду Ячейки, а затем перейдите на вкладку Число.

    Демонстрация

  3. В поле Числовые форматы выберите (все форматы).

  4. В поле Тип введите 0;-0;;@.

Примечания

  • Скрытые значения отображаются только в строке формул или в ячейке при ее редактировании. На печать эти значения не выводятся.

  • Для того чтобы отобразить скрытые значения, выделите ячейки, выберите в меню Формат команду Ячейки и перейдите на вкладку Число. Чтобы применить стандартный числовой формат, выберите в поле Числовые форматы значение Общий. Для повторного отображения даты, времени или значений в определенных числовых форматах выберите на вкладке Число соответствующий формат.


 Скрытие и отображение формул

Скрытие и отображение формул

Для того чтобы формулы не отображались в строке формул, необходимо отформатировать ячейки, содержащие эти формулы, как скрытые, а затем защитить лист. Процедура скрытия формул описана ниже. Для того чтобы отобразить скрытые формулы, снимите с листа защиту.

  1. Выделите диапазон ячеек, в которых нужно скрыть формулы. При необходимости можно выделить несмежные диапазоны ячеек или весь лист.

  2. В меню Формат выберите команду Ячейки, а затем перейдите на вкладку Защита.

    Демонстрация

  3. Установите флажок Скрыть формулы.

  4. Нажмите кнопку OK.

  5. В меню Сервис откройте подменю Защита и выберите команду Защитить лист.

  6. Убедитесь, что в открывшемся диалоговом окне установлен флажок Содержимого.


 Скрытие всех значений в ячейке

Скрытие всех значений в ячейке

  1. Выделите ячейки, содержащие значения, которые требуется скрыть.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Число.

    Демонстрация

  3. В поле Числовые форматы выберите (все форматы).

  4. Выделите имеющиеся в поле Тип коды и нажмите клавишу BACKSPACE.

  5. В поле Тип введите ;;; (три символа точки с запятой).

    Скрытые значения отображаются только в поле формул или в ячейке при ее редактировании. На печать эти значения не выводятся.

Совет. Для того чтобы отобразить скрытые значения, выделите ячейки, выберите в меню Формат команду Ячейки и перейдите на вкладку Число. Чтобы применить стандартный числовой формат, выберите в поле Числовые форматы значение Общий. Для повторного отображения даты, времени или значений в определенных числовых форматах выберите на вкладке Число соответствующий формат.


 Отображение дат с косыми чертами или тире

Отображение дат с косыми чертами или тире

  1. Выделите ячейки, формат которых требуется изменить.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Число.

    Демонстрация

  3. В списке Числовые форматы выберите Дата и затем требуемый формат.

Примечания

  • Можно использовать числовые форматы для изменения отображения чисел, включая дату и время, без изменения внутреннего представления чисел.

  • Если необходимый формат не найден, можно создать пользовательский числовой формат с помощью подстановочных знаков для дат и времени.


 Отображение времени с точками, двоеточиями и значками AM и PM

Отображение времени с точками, двоеточиями и значками AM и PM

  1. Выделите ячейки, формат которых требуется изменить.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Число.

    Демонстрация

  3. В списке Числовые форматы выберите Время и затем требуемый формат.

Примечания

  • Можно использовать числовые форматы для изменения отображения чисел, включая дату и время, без изменения внутреннего представления чисел.

  • Если необходимый формат не найден, можно создать пользовательский числовой формат с помощью подстановочных знаков для дат и времени.


 Добавление текста до или после числового значения

Добавление текста до или после числового значения

Если столбец, который нужно сортировать, содержит и числа, и текст (например: продукт #15, продукт #100, продукт #200), то, возможно, не удастся правильно его отсортировать. Используйте числовой формат для добавления текста без изменения способа сортировки чисел.

  1. Выделите ячейки, формат которых необходимо изменить.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Число.

    Демонстрация

  3. В поле Числовые форматы выберите категорию, а затем укажите встроенный формат, похожий на требуемый.

  4. В поле Числовые форматы выберите (все форматы).

  5. В поле Тип отредактируйте формат числа для создания своего формата.

    Для вывода в ячейке текста вместе с числами заключите текст в двойные кавычки (" ") или поставьте перед числами косую черту (\). Изменение встроенного формата не удаляет его.
    Для отображения | Используйте шаблон
    12 как продукт #12 | "продукт # " 0
    12:00 как 12:00 центральноевропейское время | ч:мм “центральноевропейское время”
    -12 как -12р. дефицит и 12 как 12р. избыток | 0.00р. "избыток";-0.00р. "дефицит"

Примечания

  • Можно использовать числовые форматы для изменения отображения чисел, включая дату и время, без изменения внутреннего представления чисел.

  • См. сведения об использовании пользовательского формата для текста.

  • Также можно использовать текстовый оператор & (амперсант) для сцепления (объединения) двух значений, получая одно непрерывное текстовое значение.


 Форматирование чисел в виде текста

Форматирование чисел в виде текста

  1. Выделите ячейки, формат которых необходимо изменить.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Число.

    Демонстрация

  3. В списке Числовые форматы выберите Текстовый и нажмите кнопку OK.

  4. В отформатированные ячейки введите числа.


 Форматирование существующих чисел в виде текста

Форматирование существующих чисел в виде текста

Числа в Microsoft Excel хранятся в виде числовых данных, даже если позже к содержащим их ячейкам был применен текстовый формат. Если такие данные, как коды товара, необходимо интерпретировать как текст, то сначала желательно применить текстовый формат к пустым ячейкам, а затем вводить числа. Если же числа уже введены, то их можно преобразовать в текстовые данные.

  1. Выделите ячейки, содержащие числа, которые необходимо отформатировать в виде текста.

  2. В меню Формат выберите команду Ячейки , а затем перейдите к вкладке Число.

  3. В списке Числовые форматы выберите Текстовый и нажмите кнопку OK.

  4. Для повторного ввода данных щелкните кнопкой мыши в каждой ячейке, нажмите клавишу F2, в затем клавишу ENTER.


 Создание пользовательского числового формата

Создание пользовательского числового формата

  1. Выделите ячейки, формат которых необходимо изменить.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Число.

    Демонстрация

  3. В поле Числовые форматы выберите формат, а затем укажите встроенный формат, отвечающий требованиям.

  4. В поле Числовые форматы выберите (все форматы).

  5. В меню Тип отредактируйте формат числа для создание своего формата.

    Редактирование встроенного формата не удаляет его.

    Могут быть указаны до четырех разделов кодов формата. Разделы, отделяемые друг от друга точками с запятыми, определяют форматы для положительных, отрицательных чисел, нулевых значений и текстов в указанном порядке. Если указаны только два раздела, то первый из них используется для форматирования положительных чисел и нулевых значений, а второй — для отрицательных чисел. Если указан один раздел, то ко всем числам применяется этот формат. Если раздел пропущен, завершающая точка с запятой должна быть вставлена для него.

    Пользовательский числовой формат с четырьмя разделами # ##,00_);[Красный] (# ###,00);0,00;"sales "@

    Используйте коды форматов, описывающие способ отображения числа, даты или времени, денежных единиц, процентов или научного представления и текста или интервалов.


Коды числовых форматов даты и времени

Дни, месяцы и годы. Для отображения дней, месяцев и лет в раздел следует включить следующие коды формата. Если «м» стоит сразу после кода «ч» или «чч», либо непосредственно перед кодом «сс», Microsoft Excel отображает не месяцы, а минуты.

Для отображения | Используйте шаблон
Месяцев в виде чисел от 1 до 12 | M
Месяцев в виде чисел от 01 до 12 | ММ
Месяцев в виде Янв-Дек | МММ
Месяцев в виде Январь-Декабрь | ММММ
Месяцев первой буквой месяца | МММММ
Дней в виде чисел от 1 до 31 | Д
Дней в виде чисел от 01 до 31 | ДД
Дней в виде Пн-Вс | ДДД
Дней в виде Понедельник-Воскресенье | ДДДД
Лет в виде 00-99 | ГГ
Лет в виде 1900-9999 | ГГГГ

Часы, минуты и секунды. Для отображения часов, минут и секунд включите в раздел следующие коды форматов.

Для отображения | Используйте шаблон
Часов в виде чисел от 0 до 23 | Ч
Часов в виде чисел от 00 до 23 | ЧЧ
Минут в виде чисел от 0 до 59 | м
Минут в виде чисел от 00 до 59 | мм
Секунд в виде чисел от 0 до 59 | с
Секунд в виде чисел от 00 до 59 | сс
Часов в виде 4 AM | ч AM/PM
Время в виде 4:36 PM | ч:мм AM/PM
Время в виде 4:36:03 P | ч:мм:сс A/P
Прошедшее время в часах; например, 25:02 | [ч]:мм
Прошедшее время в минутах; например, 63:46 | [мм]:сс
Прошедшее время в секундах | [сс]
Доли секунд | ч:мм:сс.00

AM и PM. Если формат содержит обозначения AM или PM, применяется 12-часовая система, где «AM» или «A» указывает на время суток от полуночи до полудня, а «PM» или «P» указывает на время суток от полудня до полуночи. В противном случае используется 24-часовая система. Коды «м» или «мм» должны стоять непосредственно после кодов «ч» или «чч» или непосредственно перед кодом «сс», в противном случае Microsoft Excel отображает месяц, а не минуты.


Коды для денежного, процентного и экспоненциального числовых форматов

Символы валют. Для указания одного из перечисленных ниже символов валют в числовом формате включите режим NUM LOCK и введите с цифровой клавиатуры код ANSI для символа валюты.

Для ввода | Не отпуская клавишу ALT, введите
ў | 0162
Ј | 0163
Ґ | 0165
 | 0128

Примечание. Пользовательские форматы сохраняются вместе с книгой. Для того чтобы Microsoft Excel всегда использовал заданный символ валюты, измените символ валюты, выбранный на панели управления Язык и стандарты до запуска Excel.

Процентные значения. Для отображения чисел в виде процента от 100 включите в числовой формат знак процента (%). Например, такие числа как ,08 будут представлены в виде 8%; число 2.8 будет представлено в виде 280%.

Экспоненциальная нотация. Для того чтобы отображать числа в экспоненциальном формате, необходимо включить в раздел коды "E-," "E+," "e-" или "e+". Если формат содержит коды 0 (нуль) или # (знак номера) справа от кода экспоненты, Microsoft Excel отображает числа в экспоненциальном формате и включает символы "E" или "e." Количество знаков 0 или # справа от кода соответствует количеству цифр в показателе степени. При задании кодов E- или e- перед отрицательным показателем степени отражается знак минус. При задании кодов E+ или e+ перед отрицательными показателями степени ставится знак минус, а перед положительными — плюс.


 Коды форматов чисел для задания числа десятичных разрядов, пробелов, цветов и условий

Коды форматов чисел для задания числа десятичных разрядов, пробелов, цветов и условий

Используйте коды форматов чисел для создания пользовательских форматов чисел.

Десятичная запятая и значащие цифры. Для форматирования дробей и чисел с десятичной запятой необходимо включить в раздел следующие шаблоны. Если дробная часть числа содержит цифр больше, чем формат содержит шаблонов, число округляется так, чтобы количество разрядов соответствовало количеству шаблонов. Если же целая часть числа содержит цифр больше, чем формат содержит шаблонов, отображаются все значащие разряды. Если в целой части числа содержатся только знаки номера (#), то числа, меньшие 1, начинаются с десятичной запятой.

  • При использовании шаблона # выводятся только значащие числа, незначащие нули не отображаются.

  • При использовании шаблона 0 (нуль) незначащие нули отображаются, если количество разрядов числа меньше количества нулей в формате.

  • При использовании шаблона ? до и после десятичной запятой вместо незначащих нулей отображаются пробелы. Таким образом в числах достигается выравнивание положения десятичной запятой при форматировании с использованием моноширинного шрифта, например, Courier New. Этот шаблон можно также применять для выравнивания символа деления в дробях с различным количеством цифр.
Для отображения | Используйте шаблон
1234,59 в виде 1234,6 | ####,#
8,9 в виде 8,900 | #,000
0,631 в виде 0,6 | 0,#
12 в виде 12,0 и 1234,568 в виде 1234,57 | #,0#
44,398, 102,65 и 2,8 с выровненной десятичной запятой | ???,???
5,25 в виде 5 1/4 и 5,3 в виде 5 3/10 с выровненными символами деления | # ???/???

Разделитель разрядов. Чтобы использовать пробел в качестве разделителя тысяч, а также при необходимости представлять число в масштабе тысяч, включите в формат пробелы.

Для отображения | Используйте шаблон
12000 в виде 12 000 | # ###
12000 в виде 12 | # (пробел)
12200000 в виде 12,2 | 0,0 (два пробела)

Цвет. Чтобы установить цвет, введите в раздел формата название одного из следующих восьми цветов в квадратных скобках. Код цвета должен быть первым элементом в разделе.

[Черный] | [Синий]
[Голубой] | [Зеленый]
[Розовый] | [Красный]
[Белый] | [Желтый]

Условия. Для определения числовых форматов, используемых только для чисел, отвечающих заданному условию, заключите данное условие в квадратные скобки. Оно должно состоять из оператора сравнения и значения. Например, следующий формат отображает числа меньшие или равные 100 красным шрифтом, а числа больше 100 — синим.

[Красный][<=100];[Синий][>100]

Для того чтобы применить к ячейкам условные форматы — например, цветную заливку в зависимости значения ячейки — пользуйтесь командой Условное форматирование из меню Формат.


Коды числовых форматов для включения текста и интервалов

Добавление символов. Для того чтобы в ячейке отображались числа и текст, заключите текстовые символы в двойные кавычки (" ") или поставьте перед одиночным символом обратную косую черту (\). Вставьте нужные символы в соответствующий раздел кодов формата. Например, для отображения отрицательных сумм в виде "Дефицит -125,74р." задайте формат "Избыток" 0,00р.; "Дефицит" -0,00р.. Для отображения пробела и следующих символов кавычки использовать не нужно: $ - + / ( ) : ! ^ & ' (левая одинарная кавычка) ' (правая одинарная кавычка) ~ { } = < >

Включение раздела для текста. Текстовый раздел, если он включен в числовой формат, всегда является последним разделом. Если требуется отобразить текст, вводимый в ячейку, включите в нужную позицию текстового раздела знак @. Если знак @ в текстовом разделе опущен, вводимый текст не будет отображаться. Если наряду с вводимым текстом требуется всегда отображать конкретные символы, заключите дополнительный текст в двойные кавычки (" ") — например, "общие поступления для "@

Если текстовая секция не включена в формат, то форматирование никак не влияет на вводимый текст.

Добавление интервала. Чтобы задать в числовом формате интервал, имеющий ширину символа, включите в код формата соответствующий символ, предваренный символом подчеркивания (_). Например, если за символом подчеркивания идет закрывающая скобка (_)), положительные числа будут расположены в одну колонку с отрицательными, заключенными в скобки.

Повторяющиеся символы. Для заполнения повторяющимся символом всей ширины ячейки используйте в числовом формате символ (*). Например, для заполнения дефисами пустой области ячейки справа от числа следует указать 0*-.


 Удаление пользовательского числового формата

Удаление пользовательского числового формата

  1. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Число.

    Демонстрация

  2. В поле Числовые форматы выберите (все форматы).

  3. Из списка Тип выберите пользовательский формат, который требуется удалить.

  4. Нажмите кнопку Удалить.

    Удалять можно только пользовательские форматы. К ячейкам, имеющим удаленный пользовательский формат, в Microsoft Excel применяется общий формат, установленный по умолчанию.


Даты, введенные на листе, отображаются неправильно

При вводе даты в ячейку дата отображается либо в формате даты по умолчанию, либо в формате, назначенном для ячейки перед тем как была введена дата. Формат даты по умолчанию основан на формате, указанном на вкладке Дата диалогового окна Язык и стандарты (доступного из панели управления Windows). Если в этом окне были выбраны другие параметры, все даты в книгах Excel, формат которых не был задан при помощи команды Ячейки в меню Формат, также изменяются.


 О быстром форматировании ячеек и списков

О быстром форматировании ячеек и списков

Применение автоформата к диапазону. Для форматирования целого списка или другого большого диапазона ячеек, содержащего различные элементы — например, заголовки столбцов или строк, общие итоги и подробные данные — применяется автоформат. При этом для разных элементов диапазона используются отдельные форматы.

Создание и применение стиля. Чтобы применить за один шаг несколько параметров форматирования и обеспечить согласованность форматов ячеек, следует применить к ячейкам стиль. В Microsoft Excel имеются стили, которые можно использовать для присвоения числам денежного формата, процентного формата или формата с разделителями. Можно создать собственные стили, применяемые для задания шрифта и размера шрифта, присвоения ячейкам числовых форматов, создания границ и заливки, и для защиты ячеек от изменений. Если данные находятся в структуре, можно применять стили в соответствии с уровнями структуры.

Копирование параметров форматирования одних ячеек или диапазонов в другие. Если некоторые ячейки на листе уже отформатированы с применением необходимых параметров, то с помощью кнопки Формат по образцу можно скопировать параметры форматирования в другие ячейки.

Автоматическое расширение форматов в списке. При добавлении строк в конец отформатированного списка форматирование автоматически распространяется на эти строки. Автоматическое форматирование можно включить или отключить.


Быстрое форматирование ячеек и списков

Предполагаемые действия

Применение автоформата к диапазону

Создание нового стиля

Применение существующего стиля

Применение стилей к структуре

Копирование форматов одних ячеек на другие

Включение и выключение продолжающихся форматов в конце списка

Не можете сделать выбор?


 Применение автоформата к диапазону

Применение автоформата к диапазону

  1. Выберите диапазон, который нужно отформатировать.

  2. В меню Формат выберите команду Автоформат.

    Демонстрация

  3. Выберите нужный формат.

    Для частичного применения автоформата нажмите кнопку Параметры и снимите флажки для форматов, которые не нужно применять.


 Удаление автоформата диапазона ячеек

Удаление автоформата диапазона ячеек

  1. Выделите диапазон с удаляемым автоформатом.

  2. В меню Формат выберите команду Автоформат.

    Демонстрация

  3. В конце списка, выберите формат с подписью Нет.


 Создание нового стиля

Создание нового стиля

  1. Выберите ячейку отформатированную с помощью комбинации форматов, которые необходимо включить в новый стиль.

  2. В меню Формат выберите команду Стиль.

    Демонстрация

  3. Введите имя для стиля в поле Имя стиля.

  4. Для того чтобы определить стиль, а затем применить его к выбранным ячейкам, нажмите кнопку OK.

    Чтобы определить стиль без его последующего применения, нажмите кнопку Добавить, а затем кнопку Закрыть.

Совет. Если нет ячеек, имеющих формат, который должен быть включен в создаваемый стиль, можно самостоятельно указать форматы при указании имени стиля. Для получения дополнительных сведений нажмите кнопку [image] .


 Применение стиля

Применение стиля

  1. Выделите ячейки, формат которых необходимо изменить.

  2. В меню Формат выберите команду Стиль.

    Демонстрация

  3. В поле Имя стиля выберите нужный стиль.

Совет . Для быстрого применения стандартных стилей к числам в выделенных ячейках нажмите кнопку Формат с разделителями [image] , Денежный формат [image] или Процентный формат [image] на панели инструментов Форматирование.


 Применение стилей к структуре

Применение стилей к структуре

Это процедура автоматически применяет стили для структурированных данных или данных, которые будут структурированы.

  1. Выделите ячейки, к которым необходимо применить стили.

  2. В меню Данные выберите команду Группа и структура и затем — Настройки.

    Демонстрация

  3. Установите флажок Автоматические стили.

  4. Выполните одно из следующих действий:

    Чтобы применить стили к уже структурированным данным, нажмите кнопку Применить стили.

    Для создания структуры и применения к ней стилей нажмите кнопку Создать.

Примечания

  • Если данные структурированы по строкам, то Microsoft Excel использует стили Уровеньстрок_1, Уровеньстрок_2 и так до четвертого. Для данных, структурированных по столбцам, используются стили Уровеньстолб_1, Уровеньстолб_2 и так до четвертого. Можно изменить эти стили, включая необходимые форматы.

  • Excel форматирует автоматические промежуточные итоги при вставке их в список. Этот формат можно изменить при применении его к структуре.

  • Можно форматировать структурированные данные, используя автоформаты. См. сведения о применении автоформатов.


 Удаление стиля выбранных ячеек

Удаление стиля выбранных ячеек

  1. Выберите ячейки, отформатированные с помощью стиля, который нужно удалить.

  2. В меню Формат выберите команду Стиль.

    Демонстрация

  3. В поле Список форматов выберите Обычный стиль.


 Изменение форматов для существующего стиля

Изменение форматов для существующего стиля

  1. Выберите ячейку, содержащую форматы, которые следует использовать для стиля.

  2. В меню Формат выберите команду Стиль.

    Демонстрация

  3. В поле Имя стиля введите имя изменяемого стиля.

    Необходимо именно ввести имя, а не выбрать его из списка.

  4. Нажмите кнопку Добавить.

Совет. Если на листе нет ячеек, имеющих нужный формат, то можно самостоятельно указать форматы. Для получения дополнительных сведений нажмите кнопку [image] .


 Указание форматов для стиля

Указание форматов для стиля

  1. В меню Формат выберите команду Стиль.

    Демонстрация

  2. Введите в поле Имя стиля имя нового стиля.

    При изменении форматов для существующего стиля выберите изменяемый стиль из списка.

  3. Нажмите кнопку Изменить.

  4. Выберите нужные форматы на вкладках окна диалога и нажмите кнопку OK.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  5. Снимите флажки для тех форматов, которые не должны быть включены в данный стиль.

  6. Для того чтобы определить стиль, а затем применить его к выбранным ячейкам, нажмите кнопку OK.

    Чтобы определить стиль без его последующего применения, нажмите кнопку Добавить, а затем кнопку Закрыть.


 Удаление стиля из списка стилей

Удаление стиля из списка стилей

  1. В меню Формат выберите команду Стиль.

    Демонстрация

  2. В поле Имя стиля выберите стиль, который нужно удалить.

  3. Нажмите кнопку Удалить.

Примечание. Нельзя удалить обычный стиль. При удаление остальных стилей нельзя будет использовать кнопки С разделителем групп разрядов [image] , Денежный формат [image] или Процентный формат [image] на панели инструментов Форматирование.


 Копирование стилей из другой книге

Копирование стилей из другой книге

  1. Откройте книгу, содержащую стили, которые нужно скопировать.

  2. Откройте книгу, в которую необходимо скопировать стили, а затем выберите команду Стиль в меню Формат.

  3. Нажмите кнопку Объединить.

  4. В поле Объединить стили из документа выберите имя книги, из которой необходимо скопировать стили.

Примечание. Если текущая книга содержит некоторые стили, совпадающие по имени с копируемыми стилями, то необходимо подтверждение для замещения стилей, имеющих совпадающие имена. Нажмите кнопку Да, если следует заменить стили. Нажмите кнопку Нет, если необходимо сохранить существующие стили. Предупреждающее сообщение появляется на экране только один раз, независимо от количества совпадающих имен стилей.


 Сохранение стилей для использования в новых книгах

Сохранение стилей для использования в новых книгах

  1. Откройте новую книгу.

  2. Откройте книгу со стилями, которые нужно сохранить.

  3. Скопируйте стили из старой книги в пустую.

  4. В новой книге выберите команду Сохранить как в меню Файл.

    Демонстрация

  5. В поле Имя файла введите слово Книга

  6. В списке Тип файла выберите пункт Шаблон (*.xlt).

  7. В списке Папка укажите папку XLStart.

  8. Нажмите кнопку Сохранить.

    Сохраненные стили будут доступны во всех новых книгах, создаваемых впоследствии с помощью нажатия кнопки Создать [image] .


Разрешение вопросов при форматировании ячеек

В чем именно заключаются сложности?

Текст не повернут на нужный угол.

Параметр поворота текста не действует, или он не отображен на экране.

Неверное отображение рамок.

Косые рамки накладываются на повернутый текст.

Почему не все форматы могут быть использованы в качестве условных?

Автоматическое изменение таких форматов как цвет шрифта и затенение ячейки.

Условные форматы применены неверным образом.

Настройки, примененные в диалоговом окне Условное форматирование, сейчас пустые.


Разрешение вопросов при форматировании чисел, дат и времени

В чем именно заключаются сложности?

Числа не отображаются или не вычисляются как числовые значения.

Предшествующие нули не отображаются в таких числах, как почтовые коды.

Необходимо отформатировать числа в виде текстовых данных.

Внезапно числа изменяются на знак #####.

Десятичная запятая появляется во всех вводимых данных.

Число в ячейке листа отличается от числа в поле формул.

Текст или другие вводимые данные не отображаются в ячейках.


Подготовка к печати (обзор)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Печать листа, выделенного диапазона или книги целиком

Печать листа, выделенного диапазона или книги целиком

Если на листе Excel задана область печати, будет распечатана только эта область. Если выделен диапазон ячеек и установлен флажок Выделенный диапазон, будут распечатаны ячейки из этого диапазона, а определенные на листе Excel области печати будут пропущены.

  1. Выберите команду Печать в меню Файл.

    Демонстрация

  2. В группе Вывести на печать выберите необходимый параметр.

Совет. При необходимости распечатать несколько листов за один раз, следует выделить их перед печатью. Для получения более подробных сведений о способах выделения нескольких листов нажмите [image] .


Просмотр состояния печатаемых файлов

  • Дважды щелкните значок принтера [image] , отображаемый на панели задач Windows.

    Когда печать файла завершена, значок принтера исчезает.


 Отправка документа по факсу

Отправка документа по факсу

Для отправки документа по факсу на компьютере должны быть установлены соответствующее оборудование и программное обеспечение.

  1. Создайте или откройте документ, который нужно переслать по факсу.

  2. Выберите команду Печать в меню Файл.

    Демонстрация

  3. В поле Имя выберите имя устройства (факса), например Microsoft Fax.

  4. Установите по необходимости другие параметры печати и нажмите кнопку OK.


 Печать отчета сводной таблицы

Печать отчета сводной таблицы

В Microsoft Excel имеются специальные параметры печати, относящиеся к отчетам сводных таблиц. Эти параметры особенно полезны при печати больших отчетов сводных таблиц в структурированном формате.

Использование названий строк и столбцов в качестве заголовков печати. В отчете сводной таблицы заголовки строк и столбцов могут печататься на каждой странице. Заголовки строк и столбцов сводной таблицы включают подписи полей и элементов для всех полей строк, столбцов и данных. Поскольку эти параметры применяются ко всем заголовкам строк и столбцов в отчете, то в случае изменения макета отчета таким образом, что подписи полей и элементов содержатся в других строках и столбцах, при следующей печати отчета будут автоматически печататься новые заголовки строк и столбцов.

Заголовки строк и столбцов повторяются при печати только в том случае, если на вкладке Лист диалогового окна Параметры страницы (меню Файл) не заданы никакие заголовки печати. Для обеспечения печати заголовков строк и столбцов сводной таблицы перед печатью отчета следует удалить все заголовки, заданные в диалоговом окне Параметры страницы.

Повторение подписей. Если имеется два или более полей строк, и разрыв страницы проходит по группе элементов, можно автоматически повторять подписи элементов для внешних полей в верхней части следующей страницы. Подписи элементов повторяются для всех полей слева от поля, группа элементов которого разделена разрывом страницы.

Повторение подписей элементов после разрыва страницы

Если разрыв страницы попадает между элементами поля «Продукты», текущие элементы полей «Продавец» и «Регион» повторно печатаются вверху следующей страницы.

Установка разрывов страниц. Имеется возможность установки автоматических разрывов страниц после каждого элемента внешнего поля строки (внешние поля строк включают все поля строк кроме самого внутреннего). Данный параметр применяется ко всем элементам поля. Для настройки вида печатаемых страниц можно перемещать разрывы страниц, удалять их и добавлять новые разрывы страниц вручную.

Несколько отчетов сводных таблиц на листе. Если на листе имеется несколько отчетов сводных таблиц, и при этом для печати отчета требуется воспользоваться параметрами печати сводных таблиц, следует установить область печати, включающую только тот отчет сводной таблицы, который требуется напечатать. В противном случае строки и столбцы с подписями полей и элементов не будут повторяться при печати, и, кроме того, разрывы страниц из одного отчета могут оказать влияние на другие отчеты сводных таблиц.

Печать отчета сводной таблицы. Excel использует установленные параметры печати сводных таблиц всякий раз при печати любой части отчета сводной таблицы. На вид отчета сводной таблицы на печатных страницах также влияют другие параметры печати Excel.


Установка нового принтера

  1. На панели задач Windows нажмите кнопку Пуск, выберите меню Настройка, а затем команду Принтеры.

  2. Дважды щелкните мышью значок «Установка принтера» [image].

  3. Следуйте инструкциям, выводимым мастером.

    Если необходимо распечатать пробную страницу, убедитесь, что принтер включен и готов к печати.

Совет. При использовании сетевого принтера для быстрой его установки необходимо дважды щелкнуть значок " Сетевое окружение" на рабочем столе Windows. Щелкните значок "Принтеры", а затем в меню Файл выберите команду Установить.


Установка принтера по умолчанию

Для выполнения этой процедуры необходимо иметь установленный принтер.

  1. На панели задач Windows нажмите кнопку Пуск, выберите меню Настройка, а затем команду Принтеры.

  2. Правой кнопкой мыши щелкните значок принтера, который должен использоваться по умолчанию, а затем в контекстном меню выберите команду Использовать по умолчанию.

    Если эта команда отмечена галочкой, то данный принтер уже установлен в качестве принтера по умолчанию.


 Печать номеров строк и буквенных обозначений столбцов на каждой странице

Печать номеров строк и буквенных обозначений столбцов на каждой странице

Заголовки столбцов и строк отражают положение данных на листе Excel. Заголовки строк - номера строк, отображаемые в левой части листа Excel; заголовки столбцов - буквы или числа, отображаемые в верхней части столбцов листа Excel.

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Лист.

  3. Установите флажок Заголовки строк и столбцов.


 Печать подписей строк и столбцов

Печать подписей строк и столбцов

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Лист.

  3. Для печати подписей столбцов на каждой странице, в поле Сквозные строки введите строки, содержащие подписи столбцов.

    Для печати подписей строк на каждой странице, в поле Сквозные столбцы введите столбцы, содержащие подписи строк.

Примечание Microsoft Excel печатает подписи строк и столбцов только на тех страницах, которые включают подписываемые строки и столбцы. Страницы со строками ниже подписанных строк и столбцами справа от подписанных столбцов печатаются без подписей. Печать подписей дополнительных строк и столбцов на каждой странице.


 Печать листа с линиями сетки

Печать листа с линиями сетки

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Лист.

  3. Установите флажок Сетка.

Примечание. Большие листы печатаются быстрее при сброшенном флажке Сетка.


 Печать листа без линий сетки

Печать листа без линий сетки

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Лист.

  3. Снимите флажок Сетка.


 Печать листа с примечаниями

Печать листа с примечаниями

Если нужно распечатать примечания на тех местах, в которых они появляются на листе, необходимо отобразить примечания, которые будут распечатаны. Для отображения всех примечаний выберите команду Примечания в меню Вид. В случае необходимости переместите и поменяйте размер примечаний.

Для отображения отдельного примечания щелкните правой кнопкой мыши ячейку, содержащую это примечание, и выберите команду Отобразить примечание в контекстном меню.

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Лист.

  3. Выполните одно из следующих действий:

    Чтобы распечатать примечания в конце листа, выберите значение В конце листа из списка в поле Примечания.

    Чтобы распечатать примечания в том виде, в каком они отображаются на листе Excel, выберите значение Как на листе из списка в поле Примечания.

Примечание. Для печати примечаний необходимо также распечатать лист, содержащий их.


 Печать нескольких копий листа или книги

Печать нескольких копий листа или книги

  1. Выберите команду Печать в меню Файл.

    Демонстрация

  2. В поле Число копий введите необходимое число копий.

Примечание. Для сортировки страниц при печати нескольких копий листа Excel или книги установите флажок Разобрать по копиям. В этом случае будет распечатана полная копия прежде чем начнется печать первой страницы следующей копии. Если необходимо распечатать все копии первой страницы, затем все копии последующих, следует снять этот флажок.


 Печать нескольких книг

Печать нескольких книг

Все файлы печатаемых книг должны находиться в одной папке.

  1. Выберите команду Открыть в меню Файл.

    Демонстрация

  2. Удерживая клавишу CTRL, выберите мышью все выводимые на печать книги.

  3. Выберите команду Печать в меню Сервис.


 Печать книги в файл

Печать книги в файл

При печати книги в файл с целью ее последующей печати на принтере, отличном от используемого при создании документа, могут измениться разрывы страниц и размеры шрифта.

  1. Выберите команду Печать в меню Файл.

    Демонстрация

  2. В группе Принтер выберите принтер, на котором будет печататься файл.

  3. Установите флажок Печать в файл и нажмите кнопку OK.

  4. В поле Имя файла диалогового окна Печать в файл введите имя создаваемого файла печати.


Ускорение печати листа Excel

Печать черновика Печать листа Excel можно ускорить, временно изменив качество печати. Если известно разрешение принтера, качество печати для принтера может быть изменено. Если разрешение (или качество) принтера неизвестно, можно распечатать документ в режиме черновика. Скорость печати увеличится, но не будет отображено форматирование текста и большинство рисунков.

Печать в черно-белом режиме На черно-белых принтерах цвета отображаются в виде оттенков серого. Сократить время печати листа Excel, содержащего цветовое оформление, можно путем печати цветов в черно-белом режиме. При печати листа Excel с использованием только черного и белого цветов цветные текст и рамки выводятся черными, а не в виде оттенков серого. Excel выводит фон ячеек и автофигур белым и печатает другие рисунки и диаграммы оттенками серого цвета.

Печать без линий сетки Если не печатать линии сетки, то большие листы печатаются быстрее.

Предполагаемые действия

Установка качества печати

Черновая печать

Черно-белая печать

Печать без линий сетки

Вывод на печать в Excel


 Изменение размера и положения диаграммы на странице при печати

Изменение размера и положения диаграммы на странице при печати

  • Если диаграмма внедрена на текущий лист, ее можно переместить или установить для нее необходимый размер с помощью мыши в режиме разметки страницы. Для этого необходимо нажать кнопку мыши на листе за пределами области диаграммы, а затем в меню Вид выбрать команду Разметка страницы.

  • При работе с листом диаграммы можно изменить размер и масштаб области диаграммы, определить место расположения диаграммы на печатной странице и посмотреть ее в окне предварительного просмотра. Для установки параметров печати листа диаграммы выберите ярлычок листа, затем в меню Файл выберите команду Параметры страницы, а потом на вкладке Диаграмма установите необходимые параметры.

    Чтобы переместить и изменить размер области диаграммы на листе при помощи мыши, необходимо на вкладке Диаграмма выбрать команду Настройка. Для возвращения на лист диаграммы нажмите кнопку OK.

Советы

  • Для вывода на печать внедренной диаграммы без вывода данных листа выделите внедренную диаграмму и следуйте приведенным выше инструкциям. Переместить и изменить размер области диаграммы во внедренной диаграмме можно, и не используя параметра Настройка на вкладке Диаграмма (меню Файл, команда Параметры страницы).

  • Перед печатью отчета сводной диаграммы можно скрыть кнопки полей.


 Окно предварительного просмотра

Окно предварительного просмотра

Чтобы увидеть, как будет выглядеть лист, выведенный на печать, перед печатью листа нажмите кнопку Предварительный просмотр [image] . Вид страниц в окне предварительного просмотра зависит от доступных шрифтов, разрешения принтера и количества доступных цветов.

Предварительный просмотр конкретных листов или страниц

Диапазон страниц. Для предварительного просмотра конкретного диапазона страниц выберите команду Печать. В области Печатать выберите Страницы, укажите номера страниц в полях в полях с и по, а затем нажмите кнопку Просмотр.

Встроенная диаграмма. Если лист содержит встроенную диаграмму, в окне предварительного просмотра отображается как сам лист, так и диаграмма. Перемещение и изменение размеров диаграммы возможно в обычном режиме или в режиме разметки страницы. Если перед нажатием кнопки Предварительный просмотр [image] была выделена встроенная диаграмма, Microsoft Excel отобразит только эту диаграмму.

Номер страницы и число страниц. В строке состояния в нижней части экрана отображается номер текущей страницы и общее число страниц, которые будут напечатаны.

Команды режима предварительного просмотра

Кнопка | Действие
Далее | Отображает следующую страницу. Если выделено несколько листов, то при нажатии кнопки Далее по достижении последней страницы текущего листа Excel отображает первую страницу следующего выделенного листа.
Назад | Отображает предыдущую страницу. Если выделено несколько листов, то при нажатии кнопки Назад по достижении первой страницы текущего листа Excel отображает последнюю страницу предыдущего выделенного листа.
Масштаб | Позволяет переключаться между полностраничным режимом просмотра и режимом увеличения. Данная кнопка не влияет на размер печатаемых страниц. Перейти из полностраничного режима просмотра в режим увеличения и обратно можно также щелкнув любую область листа. В зависимости от разрешения монитора в полностраничном режиме просмотра могут не отображаться некоторые графические элементы, например тонкие границы.
Печать | Позволяет установить параметры печати и затем напечатать выделенный лист. Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.
Страница | Позволяет установить параметры страницы для печатаемых листов. Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.
Поля | Отображает или скрывает маркеры полей, которые можно перетаскивать для настройки полей страницы, полей верхнего и нижнего колонтитулов и ширины столбцов.
Разметка страницы | Позволяет переключиться в режим разметки страницы, в котором можно настраивать положение разрывов страниц на активном листе. Кроме того, можно изменить область печати и данные на листе. Если при нажатии кнопки Предварительный просмотр [image] был выбран режим разметки страницы, название этой кнопки изменяется с Разметка страницы на Обычный режим.
Обычный режим | Отображает активный лист в обычном режиме.
Закрыть | Закрывает окно предварительного просмотра и возвращает к предыдущему режиму просмотра активного листа.


 Печать листа на одной странице в ширину

Печать листа на одной странице в ширину

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Страница.

  3. Выберите Разместить не более чем на.

  4. В первом поле параметра Разместить не более чем на введите 1 (для печати на 1 странице в ширину).

  5. Удалите значение во втором поле параметра Разместить не более чем на, с тем чтобы снять ограничение на число страниц в высоту.

Примечания

  • При использовании параметра Разместить не более чем на принудительные разрывы страниц не учитываются. Учет разрывов страниц при печати с использованием параметра Разместить не более чем на.

  • При изменении значений в полях Разместить не более чем на Excel по необходимости уменьшает печатаемое изображение или увеличивает его вплоть до 100 процентов от натуральной величины. Для того чтобы посмотреть, как новые значения скажутся на размере изображения, нажмите кнопку OK, затем в меню Файл выберите команду Параметры страницы. Поле Установить на вкладке Страница показывает, какой процент от натуральной величины будет установлен для печатаемого изображения.


Изменение области листа Excel, отображаемой на странице при печати

Если лист Excel не умещается на требуемом числе печатных страниц, допускается изменение масштаба, чтобы печатная копия документа занимала больше или меньше страниц, чем при нормальном размере. Возможно также задание числа страниц, на которых будет распечатан документ.

Предполагаемые действия

Печать листа на одной странице в ширину

Печать листа Excel на заданном числе страниц

Вставка разрыва страницы

Перемещение разрыва страницы

Печать заданной области на листе

Добавление ячеек к существующей области печати

Вывод на печать в Excel


Печать указанной области листа

  1. В меню Вид выберите команду Разметка страницы.

  2. Выберите нужную область.

  3. Щелкните правой кнопкой мыши одну из выделенных ячеек и в контекстном меню выберите Задать.

Совет Дополнительные ячейки могут быть добавлены к области печати в режиме разметки страницы. Если добавляемая ячейка находится рядом с текущей областью печати, перетащите толстую синюю линию границы, чтобы она охватывала добавляемые ячейки. Для включения других ячеек выделите их, щелкните правой кнопкой мыши ячейку в выделенной области и выберите Добавить в область печати в контекстном меню.


Добавление ячеек к существующей области печати

  1. В меню Вид выберите команду Разметка страницы.

  2. Выделите ячейки, которые необходимо добавить в область печати.

  3. Щелкните правой кнопкой мыши одну из выделенных ячеек и в контекстном меню выберите Добавить в область печати.

Примечание. Если область печати содержит несколько диапазонов, то по мере необходимости их можно удалять. Выделите удаляемый диапазон, щелкните правой кнопкой мыши одну из выделенных ячеек и выберите Исключить из области печати в контекстном меню.


Удаление области печати

  • В меню Файл выберите Область печати и затем Убрать.


 Изменение ориентации страницы

Изменение ориентации страницы

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Страница.

  3. В группе Ориентация выберите Книжная или Альбомная.


 Задание размера бумаги

Задание размера бумаги

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Страница.

  3. В поле Размер бумаги выберите необходимый размер бумаги.


 Расположение данных листа Excel по центру печатаемой страницы

Расположение данных листа Excel по центру печатаемой страницы

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, а затем откройте вкладку Поля.

  3. Для горизонтального центрирования данных листа Excel на странице между левым и правым полями, в группе Центрирование установите флажок Горизонтальное.

    Для вертикального центрирования данных листа Excel на странице между верхним и нижним полями, в группе Центрирование установите флажок Вертикальное.


 Задание порядка печати страниц

Задание порядка печати страниц

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Лист.

  3. В группе Последовательность вывода страниц выберите необходимый порядок печати.


 Задание номера начальной страницы

Задание номера начальной страницы

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, затем вкладку Страница.

  3. В поле Номер первой страницы введите номер, который появится на первой странице листа Excel.

    Значение Авто, введенное в поле Номер первой страницы, позволяет Microsoft Excel автоматически выполнить нумерацию страниц листа Excel.

Примечание. Excel печатает номера страниц только в том случае, когда номера страниц включены в колонтитулы.


 Печать листа Excel на заданном числе страниц

Печать листа Excel на заданном числе страниц

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Страница.

  3. Выберите Разместить не более чем на.

  4. Введите число страниц, на которых должен уместиться распечатанный документ.

    Заданное число страниц не будет превышено при печати. Документ не будет увеличен, чтобы заполнить все страницы.

Примечания

  • При размещении листа Excel на заданном числе листов принудительные разрывы страниц не учитываются.

  • При изменении значения в полях Разместить не более чем на Excel по необходимости уменьшает образ печати или увеличивает его вплоть до 100 процентов от натуральной величины. Для того, чтобы посмотреть как новые значения скажутся на размере изображения, щелкните кнопку OK, затем в меню Файл выберите команду Параметры страницы. Поле Установить на вкладке Страница показывает какой процент от натуральной величины будет установлен для образа печати.


 Установка полей страницы

Установка полей страницы

  1. Чтобы установить поля для одного листа щелкните лист Excel.

    Чтобы установить поля для нескольких листов, выделите эти листы.

    Инструкции

  2. В меню Файл выберите команду Параметры страницы, а затем откройте вкладку Поля.

  3. Введите необходимые значения в поля Верхнее, Нижнее, Левое и Правое.

Советы

  • Чтобы увидеть, как сделанные установки влияют на печатаемый документ, перед печатью следует выбрать команду Предварительный просмотр [image] . Для изменения полей в окне предварительного просмотра достаточно нажать кнопку Поля и перетащить соответствующие маркеры.

  • Чтобы устанавливать одинаковые поля во всех новых листах и книгах , можно создать шаблон листа или создать шаблон книги.


 Задание полей для верхнего и нижнего колонтитулов

Задание полей для верхнего и нижнего колонтитулов

  1. Выполните одно из следующих действий:

    Чтобы задать поля для верхнего и нижнего колонтитулов для одного листа щелкните лист Excel.

    Чтобы задать их для нескольких листов, выделите эти листы.

    Инструкции

  2. В меню Файл выберите команду Параметры страницы, а затем откройте вкладку Поля.

  3. Чтобы изменить расстояние от края бумаги до верхнего колонтитула введите новое значение отступа в поле Для верхнего колонтитула.

    Чтобы изменить расстояние от края бумаги до нижнего колонтитула введите новое значение отступа в поле Для нижнего колонтитула.

    Эти параметры должны быть меньше, чем значения верхнего и нижнего полей для листа, но больше или равны минимальным полям принтера.

Совет. Чтобы увидеть, как сделанные установки влияют на печатаемый документ, перед печатью следует выбрать команду Предварительный просмотр [image] . Чтобы изменить поля для верхнего и нижнего колонтитулов в окне предварительного просмотра достаточно нажать кнопку Поля и перетащить соответствующие маркеры.


Вставка разрыва страницы

Для вывода на печать листа Excel, занимающего несколько страниц, Microsoft Excel разбивает его на страницы, вставляя автоматические разрывы страниц. Их положение зависит от выбранных размера бумаги, настроек полей и параметров масштабирования. Для изменения количества печатаемых на странице строк следует вставить в таблицу горизонтальный разрыв страницы, для изменения количества печатаемых столбцов — вертикальный.

Предполагаемые действия

Вставка горизонтального разрыва страницы

Вставка вертикального разрыва страницы

Вывод на печать в Excel


 Просмотр разрывов страниц

Просмотр разрывов страниц

  • В меню Вид выберите команду Разметка страницы.

    Разрывы страниц, вставленные вручную, отображаются как сплошные линии. Пунктирные линии показывают разрывы страниц, вставленные автоматически.


Переход к новой странице с помощью вставки разрыва страницы

  1. Укажите ячейку, в том месте, где должен находиться верхний левый угол новой страницы.

    Если выбрана ячейка в первой строке, будет вставлен только вертикальный разрыв страницы.

    Если выбрана ячейка в столбце A, будет вставлен только горизонтальный разрыв страницы.

    При выборе любой другой ячейки листа Excel, будут вставлены как вертикальный, так и горизонтальный разрывы страницы.

  2. В меню Вставка выберите команду Разрыв страницы.


 Перемещение разрыва страницы

Перемещение разрыва страницы

Перемещение разрыва страницы возможно только в режиме разметки страницы. При перемещении автоматического разрыва страницы он будет изменен на принудительный.

  1. В меню Вид выберите команду Разметка страницы.

  2. С помощью мыши переместите разрыв страницы в нужное положение.


 Удаление разрывов страницы

Удаление разрывов страницы

  • Для того чтобы удалить принудительный горизонтальный или вертикальный разрыв страницы, щелкните ячейку под горизонтальным разрывом страницы или справа от вертикального разрыва страницы и выберите команду Убрать разрыв страницы в меню Вставка.

    Для того чтобы удалить все принудительные разрывы страниц, выберите команду Разметка страницы в меню Вид. Щелкните правой кнопкой мыши любую ячейку листа и выберите в контекстном меню команду Сброс разрывов страниц.

Совет. Любой разрыв страницы в режиме предварительного просмотра разрывов страниц также можно удалить, перетащив его за пределы области печати.


 Использование встроенного верхнего или нижнего колонтитула

Использование встроенного верхнего или нижнего колонтитула

  1. Выберите лист Excel.

  2. Выберите в меню Вид команду Колонтитулы.

  3. В поле Верхний колонтитул или Нижний колонтитул выберите нужный верхний или нижний колонтитул.


 Создание настраиваемых колонтитулов

Создание настраиваемых колонтитулов

На каждом листе может быть только один настраиваемый верхний колонтитул и один настраиваемый нижний колонтитул. Если создается новый настраиваемый колонтитул, то он замещает существующий верхний или нижний колонтитул на листе.

  1. Выберите лист Excel.

  2. Выберите в меню Вид команду Колонтитулы.

  3. Для того чтобы использовать существующий встроенный колонтитул как основу настраиваемого колонтитула, выберите колонтитул в поле Верхний колонтитул или в поле Нижний колонтитул.

  4. Нажмите кнопку Создать верхний колонтитул или Создать нижний колонтитул.

  5. Выберите одно из полей Слева, В центре или Справа, а затем нажмите на кнопки для вставки информацию, например номер страницы, которая должна быть включена в этот раздел.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  6. Дополнительный текст в колонтитулы вводится в поля Слева, В центре или Справа.

    Для перехода на новую строку в полях разделов нажмите клавишу ENTER.

    Для удаления раздела колонтитула выделите раздел, который должен быть удален, в поле раздела и затем нажмите клавишу BACKSPACE.

Примечание. Убедитесь в том, что поля колонтитулов оставляют достаточно места для настраиваемого колонтитула. Установка полей колнтитулов.

Советы

  • Для вставки одиночного амперсанта (&) внутри текста колонтитула используйте два амперсанта. Например, для включения в верхний колонтитул текста "Субподрядчики & Услуги" введите Субподрядчики && Услуги.

  • Для нумерации страниц, начиная не с 1, используйте &[Страница]+ или &[Страница]- и затем число, которое нужно прибавить или вычесть из текущего номера страницы. Например, для печати номера страницы 3 на первой странице введите &[Страница]+2. Для печати страницы 4 с номером 3 наберите &[Страница]-1.

  • Ссылка на ячейку или рисунок не могут быть вставлены в колонтитулы. Если на каждой печатной странице повторяется содержимое ячеек или рисунок, используйте заголовки печати. Использование заголовков печати.


 Изменение шрифта для текста верхнего и нижнего колонтитулов

Изменение шрифта для текста верхнего и нижнего колонтитулов

Изменить цвет верхнего и нижнего колонтитулов невозможно.

  1. Выберите в меню Вид команду Колонтитулы.

  2. Нажмите кнопку Создать верхний колонтитул или Создать нижний колонтитул.

  3. Выделите текст в поле Слева, В центре или Справа, и затем нажмите кнопку Шрифт [image] .

  4. Укажите необходимые параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.


 Объединение видов и сценариев в отчет

Объединение видов и сценариев в отчет

  1. Выберите команду Диспетчер отчетов в меню Вид.

    Если в меню Вид нет команды Диспетчер отчетов, то загрузите надстройку " Диспетчер отчетов" .

    Инструкции

  2. Нажмите кнопку Добавить.

  3. В поле Имя отчета введите название отчета.

  4. Из списка Лист выберите лист, который должен являться первым разделом отчета.

  5. Установите флажок Вид. Из списка Вид выберите вид (если это необходимо) для первого раздела отчета.

  6. Установите флажок Сценарий. Из списка Сценарий выберите сценарий (если это необходимо) для первого раздела отчета.

  7. Чтобы добавить раздел в список Разделы в этом отчете, нажмите кнопку Добавить.

  8. Повторяйте шаги с 4 по 7 до тех пор, пока не будут созданы все необходимые разделы отчета.

Примечание. Разделы отчета распечатываются в том порядке, в котором они следуют в списке.


 Редактирование отчета, созданного с помощью диспетчера отчетов

Редактирование отчета, созданного с помощью диспетчера отчетов

  1. Выберите команду Диспетчер отчетов в меню Вид.

  2. Из списка Отчеты выберите отчет, который необходимо отредактировать, а затем нажмите кнопку Редактировать.

  3. Чтобы добавить новый раздел, выберите необходимый лист, представление и сценарий в списке Раздел для добавления, а затем нажмите кнопку Добавить.

    Чтобы удалить раздел, укажите его название в списке Разделы в этом отчете, а затем нажмите кнопку Удалить.

    Чтобы изменить порядок следования разделов, укажите название перемещаемого раздела, а затем нажимайте кнопки Вверх или Вниз.

    Чтобы последовательно пронумеровать страницы отчета, установите флажок Последовательная нумерация страниц.

Примечание. Microsoft Excel печатает разделы отчета в порядке, указанном в списке Разделы в этом отчете.


Печать отчета, созданного с помощью диспетчера отчетов

  1. Выберите команду Диспетчер отчетов в меню Вид.

  2. Из списка Отчеты выберите отчет, который необходимо распечатать.

  3. Нажмите кнопку Печать.

  4. В поле Копий введите необходимое число экземпляров отчета.


 Отчеты, сформированные с помощью представлений и сценариев

Отчеты, сформированные с помощью представлений и сценариев

Листы, представления и сценарии могут быть объединены в отчеты, которые затем могут быть распечатаны с помощью надстройки «Диспетчер отчетов». Сформированный отчет сохраняется вместе с книгой, поэтому его можно распечатать позднее.

Например, если существуют сценарий «Лучший случай», сценарий «Худший случай» и два различных пользовательских представления «Итоги» и «Подробности», то существует возможность создания отчета со сценарием «Лучший случай» и представлением «Подробности» и отчета со сценарием «Лучший случай» и представлением «Итоги».

Дополнительные сведения

Создание представления

Создание сценария

Объединение представлений и сценариев в печатном отчете


Разрешение вопросов, возникающих при печати

Печать неправильных данных

При попытке распечатать документ ничего не происходит

При печати на бумагу выводится только часть листа

Распечатка выглядит неправильно

Верхний или нижний колонтитулы не соответствуют пожеланиям

Страница должна быть напечатана на одной странице в ширину (или в высоту).

Необходимо изменить масштаб диаграммы или разместить несколько диаграмм на одной печатной странице

Отсутствие подписей при печати некоторых страниц.

Фоновый рисунок листа не выводится на печать.

Ошибки при разбиении на страницы

Пользовательские разрывы страниц игнорируются при печати

Некоторые строки и столбцы переносятся при печати на другую страницу

Не удается вывести несколько областей печати на одной странице.


 Создание формы

Создание формы

Чтобы создать собственную форму, необходимо добавить на лист нужный текст и графику с требуемыми параметрами форматирования, а затем сохранить книгу в качестве шаблона. Чтобы заполнить экземпляр формы, необходимо создать новую форму на основе этого шаблона с помощью команды Создать в меню Файл. См. Создание экранной или печатной формы.

Разработка печатных или экранных форм. Пользователи могут напечатать лист и заполнить бумажную копию формы или же заполнить пустые поля на экране и затем распечатать полученную форму. Если форма заполняется в электронном виде с помощью Microsoft Excel, можно включить в форму возможности, автоматизирующие ввод и анализ информации. См. сведения о создании печатных или экранных форм.

Разработка и использование форм для ввода данных. Если требуется использовать форму для ввода данных в список Excel или базу данных, можно либо воспользоваться встроенной формой, либо создать настраиваемую форму или шаблон. См. сведения о создании и использовании форм для ввода данных.

Примечание. Чтобы просмотреть примеры форм, которые можно создать в Excel, выберите команду Создать в меню Файл и создайте новую книгу из шаблона заказа, счета или авансового отчета. Эти встроенные формы представляют собой отформатированные листы со специальными элементами управления и формулами, автоматизирующими заполнение формы и обработку введенных данных.

Дополнительные сведения

Создание шаблона формы, копирующего данные листа в базу данных


Форматирование листа с целью использования в качестве формы

Чтобы создать привлекательную и легкую для заполнения форму, достаточно простых способов форматирования. Например, для установки рамки для формы можно изменить сетку листа путем изменения ширины столбцов и высоты строк, а также объединяя ячейки. Объемное затенение и рамки позволяют выделить ячейки, в которые пользователи должны вводить данные. Как образец для создания собственной формы можно использовать стандартную профессиональную форму.

Совет. В Microsoft Excel существуют дополнительные кнопки панели инструментов для работы с объединенными ячейками и другие полезные средства форматирования форм. Для получения сведений о добавлении кнопок на панель инструментов нажмите кнопку [image] .

Предполагаемые действия

Форматирование ячеек

Порядок просмотра форм на экране и их вывода на печать

Объединение ячеек по горизонтали или вертикали в одну большую ячейку

Добавление рамок к ячейкам

Цветное затенение ячеек

Изменение ширины столбца и высоты строки

Добавление графических объектов, примечаний и элементов управления

Добавление раскрывающихся списков, флажков и других элементов управления

Добавление к форме линий, стрелок, текстовых эффектов и другой графики

Добавление повторяющихся рисунков в качестве фона для формы

Добавление примечаний к ячейкам

Форматирование текста

Изменение шрифта, размера шрифта или цвета текста

Вращение и выравнивание текста ячейки по центру, левому или правому краям

Выравнивание текста по вертикали вверху, в середине или внизу ячейки

Отображение нескольких строк текста в ячейке


Порядок просмотра форм на экране и их вывода на печать

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Создание экранной или печатной формы

Создание экранной или печатной формы

Прежде чем создать форму необходимо решить, как она будет заполняться. Либо пользователь должен будет заполнять ее на компьютере, либо заполнять распечатанную копию. Рекомендации по созданию форм.

  1. Нажмите кнопку Создать [image] .

  2. Добавьте необходимые вопросы, названия, формулы и другие данные, которые должны присутствовать в форме.

  3. Отформатируйте ячейки листа.

    Инструкции

  4. Для добавления флажков, переключателей и других элементов управления к форме, которая будет использоваться в Microsoft Excel, служат элементы управления на панели инструментов Формы.

    Если форма будет использоваться в специальной программе Visual Basic для приложений, связанной с другими программами Microsoft Office, Интернетом или Web, элементы управления добавляются с помощью панели инструментов Элементы управления.

    Инструкции

  5. Если пользователи будут заполнять форму на компьютере, можно указать информацию, допустимую для каждого элемента.

    Инструкции

  6. Для предотвращения нежелательных изменений электронной формы можно разрешить пользователям изменять и вводить данные только в указанные ячейки.

    Инструкции

  7. Удалите все неиспользованные листы из книги.

    Инструкции

  8. После завершения составления формы выберите команду Сохранить как в меню Файл.

  9. В окне Тип файла выберите пункт Шаблон.

  10. В поле Папка выберите папку Шаблоны или одну из ее подпапок.

  11. В поле Имя файла введите имя шаблона.

Примечания

  • Для создания бланка, печатной копии или заполнения экранной формы, основанной на шаблоне, выберите команду Создать в меню Файл и укажите шаблон формы.

  • Чтобы сделать форму доступной другим пользователям в сети, необходимо сохранить форму в сети и установить место сохранения шаблона как дополнительную папку автозагрузки. Другим вариантом является создание ярлыка шаблона формы и копирование пользователями ярлыка в папку шаблонов. Формы можно также пересылать по электронной почте.

  • Если необходимо сохранять каждый набор данных, введенных в форму, в виде записи базы данных, можно связать ячейки в форме с полями базы данных. Для получения более подробных сведений кнопку [image] .


Пример листа-формы

Для просмотра этого раздела щелкните рисунок:

Для просмотра этого раздела щелкните рисунок.

Чтобы вывести справку по данному разделу с помощью клавиатуры, нажмите клавишу F6 для активизации окна раздела, выделите рисунок клавишей TAB и нажмите ENTER.


 Заполнение экранной формы

Заполнение экранной формы

При заполнении формы на компьютере создается новая пустая копия формы на основе шаблона формы. Если нужный шаблон не отображается на одной из вкладок в окне диалога Создание документа, следует проверить, что шаблоны хранятся в папке Шаблоны, и обратиться к администратору системы.

  1. Выберите команду Создать в меню Файл.

  2. Выберите вкладку, содержащую шаблон для формы, и выберите этот шаблон двойным нажатием кнопки мыши.

  3. Введите нужную информацию и следуйте другим инструкциям на форме.

  4. Нажмите кнопку Сохранить [image] .

  5. В поле Папка откройте папку, в которой следует сохранить данную копию формы.

  6. В поле Имя файла введите имя формы.

    Примечание. Если форма используется другими пользователями и нужно сохранить ее копию в сети, узнайте у администратора системы, где следует сохранить данную копию формы и под каким именем. Если форма была спроектирована таким образом, чтобы копировать введенные данные в базу данных, то при сохранении формы будет задаваться вопрос о том, следует ли добавить данные в базу как новую запись. Проконсультируйтесь у администратора системы по поводу целесообразности добавления сведений в базу данных.


Ввод данных в список Microsoft Excel с использованием форм

Microsoft Excel предоставляет несколько возможностей для создания и использования форм для ввода данных.

Предполагаемые действия

Использование встроенной формы Microsoft Excel для работы со списком

Создание формы для ввода данных в список с помощью мастера шаблонов

Создание в Microsoft Excel новой формы Microsoft Access

Использование формы Microsoft Access для ввода данных в список

Не можете сделать выбор?


 Формы

Формы

Форма представляет собой диалоговое окно, предлагающее удобный способ ввода и отображения сразу целой строки информации (или записи) в списке. Формы могут также быть использованы для поиска и удаления записей.

Чтобы можно было использовать формы для добавления записей в новый список, вверху каждого столбца списка должна быть расположена подпись. Microsoft Excel использует подписи для создания полей на форме. Создание списка на листе.

Примечание. Форма позволяет одновременно отображать до 32 полей списка.

Дополнительные сведения

Вставка записей в список с помощью формы

Изменение записей в списке с помощью формы

Поиск записей в списке с помощью формы

Удаление записи из списка с помощью формы


 Создание в Microsoft Excel новой формы Microsoft Access

Создание в Microsoft Excel новой формы Microsoft Access

Чтобы создать форму Microsoft Access, необходимо наличие на компьютере системы Microsoft Access. Если команда Форма Access отсутствует в меню Данные Microsoft Excel, установите надстройку AccessLinks, обеспечивающую связь с Microsoft Access. Для получения дополнительных сведений нажмите эту кнопку: .

  1. Укажите ячейку из списка.

  2. Выберите команду Форма MS Access в меню Данные.

  3. Если Microsoft Excel предложит сохранить книгу, нажмите кнопку Сохранить [image] , а затем снова выберите команду Форма MS Access в меню Данные.

  4. Чтобы создать форму в новой базе данных Access, выберите переключатель в новой базе данных.

    Чтобы создать форму в существующей базе данных Access, выберите переключатель в имеющейся базе данных, а затем введите полный путь к базе данных в поле под переключателем в имеющейся базе данных. Для поиска файла воспользуйтесь кнопкой Обзор.

  5. Нажмите кнопку OK и следуйте инструкциям мастера отчета Access. Не изменяйте предлагаемые мастером имена таблицы и отчета.

Примечания

  • Когда мастер формы Access завершит создание и отображение формы, можно использовать форму для ввода данных в список Excel. Всякий раз когда вводится новая запись, Access обновляет список Excel. Дополнительную информацию о форме и мастере формы Access можно получить из справки по Access.

  • В Excel можно использовать форму для ввода дополнительных данных в список, нажав кнопку Форма MS Access,которую AccessLinks помещает на листе сверху от списка.


 Добавление кнопок, флажков и других элементов управления

Добавление кнопок, флажков и других элементов управления

При создании пользовательской формы с использованием листа с данными или листа диаграммы можно добавлять в форму элементы управления, позволяющие пользователю работать с формой в интерактивном режиме. Элементы управления — это графические объекты, размещаемые на форме для отображения или ввода данных, выполнения действий или облегчения восприятия формы. Эти объекты включают текстовые поля, окна списков, группы переключателей, кнопки и т.п. Элементы управления позволяют пользователю выбирать различные параметры или запускать макросы или Web-сценарии, служащие для автоматизации задач.

Добавить элементы управления на лист можно любым из двух способов: с помощью панели Элементы управления или панели инструментов Формы.

Изменение свойств. При добавлении элемента управления можно изменять его свойства. Свойствами определяется внешний вид элемента управления, ячейка или диапазон ячеек, на которые он ссылается, и его состояние (например, установлен или снят флажок по умолчанию).

Панель «Элементы управления»: элементы управления ActiveX для макросов и Web-сценариев

Использование элементов управления ActiveX. Если требуется добавить элемент управления, в большинстве ситуаций следует использовать элемент управления ActiveX с панели Элементы управления, особенно в случае, если требуется управлять возникновением различных событий при выборе элемента управления. Например, на лист можно добавить окно списка, а затем написать макрос, выполняющий различные действия в зависимости от того, какое значение выбрано пользователем из списка.

Добавление элементов ActiveX с панели Элементы управления

Возможности элементов управления ActiveX. Элементы управления ActiveX аналогичны элементам управления, имеющимся в языках программирования, например в Microsoft Visual Basic, и их точно так же можно добавить в пользовательскую форму, созданную с помощью редактора Visual Basic. При добавлении на лист элемента ActiveX создается макрос, хранящийся вместе с самим элементом управления, в отличие от макроса, который запускается при выборе элемента.

Ограничения элементов управления ActiveX. Элементы управления ActiveX нельзя использовать на листах макросов XLM из более ранних версий Microsoft Excel и на листах диаграмм. В этих случаях следует использовать элементы управления с панели инструментов Формы. Если требуется создать элемент управления и затем связать с ним макрос, выполняемый при выборе элемента, также следует использовать элемент панели инструментов Формы. Если требуется назначить макрос имеющемуся элементу управления ActiveX, можно записать или написать макрос и затем изменить исходный код элемента ActiveX, с тем чтобы при выборе элемента происходил запуск макроса.

Использование элементов управления ActiveX при разработке собственных решений. Элементы управления ActiveX обладают свойствами, с помощью которых можно выполнять настройку элемента. Например, можно задать режим переноса по словам текста переключателя при изменении размеров этого элемента. Для элементов ActiveX имеется несколько различных действий, или событий, которые могут возникать при выборе элемента. Например, можно задать вид, который будет принимать указатель при остановке его над элементом. Элементы ActiveX можно также использовать для создания форм и диалоговых окон для программ, создаваемых с помощью Visual Basic для приложений.

Элементы управления ActiveX на Web-страницах. При публикации Web-страницы, включающей данные Excel, можно обеспечить интерактивную работу пользователей с этими данными, добавив на страницу элементы управления ActiveX. При добавлении элементов ActiveX создаются Web-сценарии (а не код макросов), выполняемые при выборе элементов в Web-обозревателе. Написать сценарии можно на языках VBScript или JavaScript. См. сведения о создании и изменении Web-сценариев. См. сведения о сохранении данных Excel в качестве Web-страницы.

Панель «Элементы управления». Элементы, имеющиеся на панели Элементы управления, являются элементами управления ActiveX. Некоторые из этих элементов выглядят так же, как и соответствующие элементы панели инструментов Формы, а другие, например выключатель и элемент-рисунок, недоступны на панели инструментов Формы. Помимо этого, имеется возможность использования дополнительных элементов управления, устанавливаемых другими программами, таких как, например, элемент управления, позволяющий проигрывать фильмы ActiveX, устанавливаемый Microsoft Internet Explorer. Для получения дополнительных сведений о свойствах элементов управления ActiveX обратитесь к справочной системе Visual Basic. См. сведения о типах элементов ActiveX, имеющихся на панели Элементы управления.

Панель инструментов «Формы»: элементы управления для форм на листах

Использование элементов управления панели инструментов «Формы». Элементы управления, имеющиеся на панели инструментов Формы, совместимы с более ранними версиями Excel, начиная с Excel версии 5.0, и могут использоваться на листах макросов XLM. Элементы управления панели инструментов Формы следует использовать в случае, если требуется записать все макросы для формы без написания или изменения кода макросов в Visual Basic для приложений. Элементы управления панели инструментов Формы можно также использовать на листах диаграмм. Эти элементы управления предназначены для использования в формах на листах, заполняемых пользователями с помощью Microsoft Excel. Элементу управления можно назначить имеющийся макрос либо написать или записать новый макрос.

Панель инструментов Формы содержит инструменты для создания кнопок, флажков, окон списков, полос прокрутки и других типов элементов управления. См. Добавление элементов управления на лист с помощью панели инструментов Формы. См. сведения о типах элементов управления, имеющихся на панели инструментов Формы.

Примечание. При назначении макроса кнопке на листе она будет доступна только тогда, когда лист открыт. Для запуска макроса с помощью кнопки, доступной независимо от того, какие книги открыты, следует запускать макрос с помощью кнопки пользовательской панели инструментов.


 Добавление кнопок, флажков и других элементов управления на лист

Добавление кнопок, флажков и других элементов управления на лист

В Microsoft Excel можно добавить элементы управления на лист двумя разными способами. Элементы ActiveX на панели инструментов Элементы управления позволяют создать специальные элементы управления и управляющие события. Элементы управления на панели инструментов Формы используются вместе с уже имеющимися макросами Excel.

Элементы управления панели инструментов “Элементы управления”

Добавление элементов ActiveX из панели инструментов Элементы управления

См. сведения о видах элементов ActiveX на панели инструментовЭлементы управления

Элементы управления панели инструментов “Формы”

Добавление элементов управления на лист с помощью панели инструментов Формы

См. сведения о видах элементов управления на панели инструментов Формы

Не можете сделать выбор?


Автоматизация решения задач с помощью элемента управления ActiveX

Для просмотра этого раздела щелкните рисунок.


 Добавление элемента ActiveX с панели инструментов «Элементы управления»

Добавление элемента ActiveX с панели инструментов «Элементы управления»

  1. Откройте лист, к которому следует добавить элемент ActiveX.

  2. Если панели инструментов Элементы управления на экране нет, установите указатель на пункт Панели инструментов в меню Вид, а затем выберите команду Элементы управления.

  3. Нажмите кнопку, соответствующую добавляемому элементу управления.

  4. С помощью мыши придайте элементу управления на листе нужный размер.

    5. Чтобы установить свойства для элемента управления, щелкните его правой кнопкой мыши, а затем выберите команду Свойства в контекстном меню. Для получения дополнительных сведений о свойствах элементов ActiveX нажмите кнопку [image] .

  5. Выполните одно из следующих действий:

    Чтобы добавить макрос для использования элемента управления в книге Microsoft Excel, щелкните элемент управления правой кнопкой мыши и выберите команду Исходный текст в контекстном меню. В редакторе Visual Basic напишите текст макроса. За информацией о написании макросов обратитесь к справочной системе Visual Basic. Для выхода выберите команду Close and Return to Microsoft Excel в меню File.

    Чтобы добавить Web-сценарий для использования элемента управления на Web-странице, выберите лист, укажите команду Макрос в меню Сервис и затем выберите Редактор сценариев. В редакторе сценариев запишите сценарий. За информацией по разработке Web-сценариев обратитесь к справочной системе редактора сценариев. Для возврата в Excel из редактора сценариев выберите команду Exit в меню File.

  6. Чтобы выйти из режима конструктора и сделать доступным элемент ActiveX, нажмите кнопку выхода из режима конструктора [image] .

Примечание. Web-сценарий использует идентификатор элемента управления для обработки событий элемента управления ActiveX. Следовательно, сценарий может быть включен в любое место в данных, которые будут опубликованы на Web-странице.


 Виды элементов ActiveX

Виды элементов ActiveX

В следующей таблице перечислены элементы ActiveX, находящиеся на панели инструментов Элементы управления. Дополнительные сведения об элементах ActiveX приведены в справочных файлах по Visual Basic.

Вид элемента ActiveX | Описание
Флажок | Включает или выключает действие определенного параметра. На листе может быть установлено несколько флажков одновременно.
Текстовое поле | Поле, в которое можно ввести текст.
Кнопка | При нажатии кнопки выполняется запрограммированное действие.
Переключатель | Кнопка, используемая для выбора только одного параметра из группы.
Список | Поле, содержащее список элементов.
Поле со списком | Текстовое поле с раскрывающимся списком. Можно ввести или выбрать нужное значение из списка.
Выключатель | Кнопка, которая остается нажатой после нажатия на нее. Чтобы отжать такую кнопку, нужно нажать ее еще раз.
Счетчик | Кнопка, которая может быть вложена в ячейку или текстовое поле. Стрелка вверх служит для увеличения значения, а стрелка вниз — для уменьшения.
Полоса прокрутки | Элемент ActiveX, прокручивающий список значений при нажатии стрелок прокрутки или перемещении бегунка. Чтобы пролистать лист на одну страницу, достаточно щелкнуть мышью между бегунком и стрелкой прокрутки.
Надпись | Текст, добавляемый к листу или форме, описывающий элемент ActiveX, лист или форму.
Рисунок | Элемент ActiveX, позволяющий внедрить рисунок в форму.
Дополнительные элементы | Список дополнительных элементов ActiveX.


 Перемещение и изменение размера элемента управления ActiveX

Перемещение и изменение размера элемента управления ActiveX

  1. Чтобы изменить элемент ActiveX на листе или форме, убедитесь, что панель инструментов Элементы управления выведена на экран. Чтобы отобразить панель инструментов Элементы управления, выберите команду Панели инструментов в меню Вид и установите флажок Элементы управления.

  2. Нажмите кнопку Режим конструктора [image] .

  3. Чтобы изменить свойства элемента ActiveX, щелкните его правой кнопкой мыши и выберите команду Свойства в контекстном меню.

    Чтобы переместить элемент ActiveX, перетащите его с помощью мыши в нужное место. Чтобы выровнять элемент ActiveX с линиями сетки ячеек, при перетаскивании элемента удерживайте нажатой клавишу ALT.

    Чтобы изменить размер элемента управления, перетащите с помощью мыши один из маркеров выделения. Чтобы изменить размер элемента управления, но сохранить его пропорции, при перетаскивании удерживайте нажатой клавишу SHIFT.

    Чтобы изменить привязку элемента ActiveX к ячейкам, находящимся под ним, при изменении их размера и перемещении, щелкните правой кнопкой мыши элемент, выберите команду Формат элемента управления, а затем вкладку Свойства.

  4. После завершения правки элемента нажмите кнопку Выход из режима конструктора [image] .


 Добавление элементов управления на лист с помощью панели инструментов «Формы»

Добавление элементов управления на лист с помощью панели инструментов «Формы»

Чтобы запустить существующий макрос из элемента управления листа, убедитесь, что открыта книга, содержащая этот макрос.

  1. Откройте лист, к которому нужно добавить элементы управления.

  2. Убедитесь, что панель инструментов Формы выведена на экран.

  3. На панели инструментов Формы нажмите кнопку, соответствующую добавляемому элементу управления.

  4. С помощью мыши придайте элементу управления на листе нужный размер.

  5. При добавлении кнопки после ее нажатия выберите нужный макрос в поле Имя макроса.

    При добавлении другого элемента управления щелкните его правой кнопкой мыши и выберите команду Назначить макрос в контекстном меню.

    Если макрос не существует, можно записать или написать новый. Чтобы записать новый макрос, нажмите кнопку Записать или кнопку Создать для открытия модуля Visual Basic, в котором нужно написать макрос.

Примечание. Кнопка, добавленная на лист, будет доступна только тогда, когда лист открыт. Чтобы запустить макрос с помощью кнопки, независимо от того, какая книга открыта в данный момент, можно сделать это с помощью кнопки на настраиваемой панели инструментов. Для получения дополнительных сведений о запуске макроса с помощью кнопки панели инструментов нажмите кнопку [image] .


 Виды кнопок, флажков и других элементов управления на панели инструментов формы

Виды кнопок, флажков и других элементов управления на панели инструментов формы

Кнопки, флажки и другие элементы управления, доступные на панели инструментов Формы, позволяют использовать некоторые параметры при работе с формой. Например, при создании личной формы можно добавить два переключателя, чтобы указать, работает служащий полный или неполный рабочий день. Так как одновременно не могут быть выбраны два переключателя, то служащий может работать либо полный рабочий день, либо неполный.

Свойства большинства элементов можно изменять. У кнопки и надписи элемента управления можно изменять только свойства, касающиеся формата.

Вид элемента ActiveX | Описание
Надпись | Текст, добавляемый к листу или форме, и описывающий элемент ActiveX, лист или форму.
Рамка группы | Надпись и рамка, объединяющая в группу связанные между собой элементы ActiveX, такие как переключатели или флажки.
Кнопка | Кнопка, запускающая макрос.
Флажок | Включает или выключает действие определенного параметра. На листе или в группе может быть установлено несколько флажков одновременно. Для получения дополнительных сведений о свойствах элемента управления для флажка нажмите кнопку [image] .
Переключатель | Кнопка, с помощью которой может быть выбран только один параметр из группы. Нельзя выбрать одновременно несколько переключателей в группе. Переключатели используются тогда, когда разрешена только одна из существующих возможностей. Для получения дополнительных сведений о свойствах элемента управления для переключателя нажмите кнопку [image] .
Список | Поле, содержащее список элементов. Для получения дополнительных сведений о свойствах элемента управления списком нажмите кнопку [image] .
Поле со списком | Раскрывающийся список. После выбора в списке какого-либо элемента, этот элемент остается в текстовом поле списка. Дополнительные сведения о свойствах раскрывающегося списка вызываются нажатием кнопки [image] .
Полоса прокрутки | Элемент управления, прокручивающий список значений при нажатии стрелок прокрутки или перемещении бегунка. Чтобы прокрутить список на одну страницу, достаточно щелкнуть между бегунком и стрелкой прокрутки. Для получения дополнительных сведений о свойствах полосы прокрутки нажмите кнопку [image] .
Счетчик | Кнопка, со стрелками вверх и вниз, которые располагаются на краю ячейки. Стрелка вверх служит для увеличения значения, а стрелка вниз — для уменьшения. Для получения дополнительных сведений о свойствах счетчика нажмите кнопку [image] .

Примечание. Поле ввода, поле со списком и Поле с раскрывающимся списком в книгах Microsoft Excel 2000 не применяются. Эти элементы управления позволяют работать с листами диалоговых окон Excel версии 5.0.


 Изменение, перемещение и изменение размера кнопки, флажка и других элементов управления

Изменение, перемещение и изменение размера кнопки, флажка и других элементов управления

В Microsoft Excel существует два вида элементов управления, которые можно разместить на листе: элементы управления, добавляемые с помощью панели инструментов Формы, и объекты ActiveX. Для изменения элемента управления, добавленного с помощью панели инструментов Формы, используется описанная ниже процедура. Для получения сведений об изменении элементов ActiveX нажмите кнопку [image] .

  1. Щелкните правой кнопкой мыши изменяемый элемент управления и выберите команду Формат объекта в контекстном меню.

  2. Чтобы изменить свойства элемента, выберите вкладку Элемент управления. Для получения сведений о том, какие свойства элемента управления могут быть изменены, нажмите кнопку [image] .

    Чтобы изменить степень привязки элемента управления к ячейкам при изменении размера и перемещении, выберите вкладку Свойства.

  3. Нажмите кнопку OK.

  4. Чтобы переместить элемент ActiveX, перетащите его с помощью мыши в нужное место. Чтобы выровнять элемент ActiveX с линиями сетки ячеек, при перетаскивании элемента удерживайте нажатой клавишу ALT.

    Чтобы изменить размер элемента управления, перетащите с помощью мыши один из маркеров выделения. Чтобы изменить размер элемента управления, но сохранить его пропорции, при перетаскивании удерживайте нажатой клавишу SHIFT.

  5. Чтобы удалить маркеры выделения, щелкните мышью любую ячейку на листе.


 Общие сведения о мастере шаблонов с функцией автоматического сбора данных

Общие сведения о мастере шаблонов с функцией автоматического сбора данных

Надстройка мастера шаблонов с функцией автоматического сбора данных создает шаблон, связывающий выбранные ячейки книги с полями базы данных. При вводе данных в связанные ячейки новой книги, основанной на шаблоне, при сохранении книги автоматически создается новая запись в базе данных и данные копируются в соответствующие поля.

Примечание. В отличие от традиционных баз данных Microsoft Excel сохраняет каждый экземпляр шаблона, а не использует шаблон как точку входа для добавления информации непосредственно в базу данных.

Например, предположим, что необходимо собрать данные о связанных с работой повреждениях с различных производственных узлов, соединенных сетью. Для этого сначала следует создать форму на листе, запрашивающую информацию, необходимую для каждого отчета о повреждении. Затем с помощью мастера шаблонов нужно создать шаблон из данной формы и связать его с основной базой данных. При заполнении нового отчета о повреждении, основанного на шаблоне, автоматически будет создаваться запись в базе данных.

Мастер шаблонов с функцией автоматического сбора данных выполняет следующие функции:

  • Автоматическое добавление данных из существующих книг Если существующие книги содержат данные, которые нужно включить в новую базу данных, мастер шаблонов может автоматически добавить их. Однако расположение данных в существующих книгах должно соответствовать расположению ячеек, выбранных для полей данных. Например, если на шаге 3 мастера шаблонов указать, что поле «Идентификатор служащего» вводится в ячейке $D$4 листа «Личные_данные», то номер служащего должен содержаться во всех существующих книгах в ячейке Личные_данные!$D$4. Если соответствие нарушено, то в базу данных могут быть добавлены неполные или пустые записи.

  • Хранение данных в выбранной базе данных База данных может представлять собой список Microsoft Excel или базу данных Microsoft Access, Microsoft FoxPro, dBase или Paradox, для которой установлен драйвер ODBC и другие компоненты доступа к данным. Рекомендуется хранить базу данных в сети так, чтобы все пользователи формы могли иметь к ней доступ. Для получения дополнительных сведений нажмите кнопку [image] .

  • Обновление записей и создание отчетов Из сохраненных данных можно создавать отчеты или использовать их как любую базу данных. Чтобы изменить данные в записи, следует повторно открыть и изменить сохраненную копию формы, связанной с этой записью. При удалении копии формы соответствующая запись остается в базе данных. Удалить эту запись можно как любую другую в базе данных данного типа.

Упрощение доступа к шаблонам Для того чтобы шаблон стал доступным всем пользователям, сохраните шаблон в доступном месте в сети. Затем создайте ярлык для шаблона, а пользователи, в свою очередь, должны скопировать этот ярлык в папку с шаблонами. Она расположена в папке Microsoft.

Для получения дополнительных сведений об использовании мастера шаблонов нажмите кнопку [image] .


 Изменение записи в связанной базе данных, созданной с помощью мастера шаблонов

Изменение записи в связанной базе данных, созданной с помощью мастера шаблонов

Если шаблон, использованный для создания формы был связан с базой данных с помощью надстройки мастера шаблонов с функцией автоматического сбора данных, каждый набор вводимых и сохраняемых в базе данных сведений представляет собой уникальную запись. Чтобы изменить данные в записи, следует переоткрыть и изменить сохраненную копию формы, соответствующую данной записи. Можно либо обновить текущую запись, либо создать новую.

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка откройте папку, содержащую изменяемую копию формы.

  3. Сделайте необходимые изменения.

  4. Нажмите кнопку Сохранить [image] .

  5. Выберите нужный параметр в ответ на сообщение и нажмите кнопку OK.

    Если базу данных изменять не следует, нажмите кнопку Продолжить без обновления.


Разрешение вопросов при создании форм

Вопросы

К базе данных, созданной с помощью мастера шаблонов, добавляются пустые записи.

При выборе базы данных для мастера шаблонов выдается сообщение "Непредвиденная ошибка".

Возникновение проблем при форматировании листа.


Разрешение вопросов при работе с кнопками, флажками и другими элементами управления

В чем именно заключаются сложности?

При выборе элемента управления некоторые команды Microsoft Excel становятся недоступными

После установки объекты ActiveX отсутствуют в списке Дополнительные элементы

Не отображается контекстное меню при выборе элемента управления правой кнопки мыши

При выборе мышью элемента управления выдается сообщение об ошибке, что Microsoft Excel не может найти файл


Быстрые вычисления на листе (просмотр итога)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Ввод формулы для вычисления значения

Предполагаемые действия

Ввод формулы

Ввод формулы, содержащей функцию

Формулы массива и их ввод

Вычисления в формулах

Дополнительные сведения


 Использование панели формул для ввода и изменения формул

Использование панели формул для ввода и изменения формул

Ввод формул. Панель формул облегчает ввод функций при создании формул, содержащих функции. При вводе функции в формулу панель формул отображает имя функции, все ее аргументы, описание функции и каждого аргумента, текущий результат функции и всей формулы. Для отображения панели формул нажмите кнопку Изменить формулу [image] в строке формул.

В данном примере с помощью панели формул редактируется вложенная функция СУММ. Диапазон K10:K19 является единственным аргументом функции и отображается в поле ввода Число1. Справа от поля ввода отображаются значения всех ячеек диапазона. Результат функции СУММ (935) отображается под списком аргументов. Результат всей формулы отображается в нижней части окна; поскольку сумма значений диапазона K10:K19 меньше или равна 5 000, результат равен 0,05, или 5%.

Изменение формул. Панель формул можно использовать для изменения функций в формулах. Для этого следует выделить ячейку, содержащую формулу, а затем нажать кнопку Изменить формулу [image] для отображения панели формул. На панели будут отображены первая функция формулы и все ее аргументы. Можно изменить либо первую функцию, либо другую функцию той же формулы, щелкнув ее в строке формул.


Расчет значений с помощью формул (понятие формулы)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Построение формул

Построение формул

Структура или порядок элементов в формуле определяет конечный результат вычислений. Формулы в Microsoft Excel подчиняются определенному синтаксису, или порядку, согласно которому в формулу включается знак равенства (=), за которым идут вычисляемые элементы (операнды), разделенные операторами. В качестве операндов могут выступать постоянные значения (константы), ссылки на ячейки или диапазоны ячеек, заголовки, имена или функции.

В Excel действия выполняются слева направо — с учетом приоритета операторов — начиная от знака равенства (=). Порядком вычисления можно управлять с помощью скобок, группируя действия, которые должны выполняться в первую очередь. Например, результатом следующей формулы будет число 11, поскольку Excel выполняет умножение до сложения. В данной формуле число 2 умножается на 3, а затем к результату добавляется число 5.

=5+2*3

Если же с помощью скобок изменить синтаксис, Excel сложит 5 и 2, а затем умножит результат на 3; результатом этих действий будет число 21.

=(5+2)*3

Дополнительные сведения

Применение операторов в формулах


 Примеры часто используемых формул

Примеры часто используемых формул

Ниже приведены примеры наиболее часто используемых формул в Microsoft Excel.

Вычисление баланса

Объединение имени и фамилии

Объединение даты с текстом

Увеличение числа на несколько процентов

Создание итогового значения на основе одного условия

Создание итогового значения на основе нескольких условий

Подсчет числа вхождений условия

Подсчет числа вхождений нескольких условий

Вычисление баланса

В Excel можно создать кассовую книгу для отслеживания банковских операций. В качестве части листа можно создать формулу для вычисления баланса. В данном примере предполагается, что ячейка F6 содержит предыдущий баланс, ячейка D7 содержит промежуточный итог приходной части по первой операции, а ячейка E7 содержит сумму полученной наличности.

Для того чтобы рассчитать текущий баланс для первой операции, введите в ячейку F7 следующую формулу:

=СУММ(F6,D7,–E7)

Для расчета баланса следующей операции скопируйте формулу в ячейку, содержащую баланс этой сделки.

Возврат в начало

Объединение имени и фамилии

Список имен из одного столбца можно объединить со списком фамилий из другого столбца с помощью формулы. В этих примерах предполагается, что ячейка D5 содержит имя, а ячейка E5 содержит фамилию.

Для того чтобы отобразить полное имя в формате «имя фамилия» (например, «Петр Иванов»):

=D5&" "&E5

Для того чтобы отобразить полное имя в формате «фамилия, имя» (например, «Иванов, Петр»):

=E5&", "&D5

Возврат в начало

Объединение даты с текстом

Для того чтобы объединить, или сцепить, два значения с целью получения одного непрерывного текстового значения, используется текстовый оператор & (амперсанд). Для того чтобы присоединить число, дату или значение времени, хранящееся в ячейке, к текстовой строке, используется функция ТЕКСТ. Например, если ячейка F5 содержит дату 05.06.96, можно с помощью следующей формулы отобразить текст «Дата отчета: 05.06.96»:

="Дата отчета: "&TEXT(F5, "dd.mm.yy")

Возврат в начало

Увеличение числа на несколько процентов

Числовое значение, хранящееся в ячейке, можно увеличить на несколько процентов, например, на 5. В данном примере исходное значение содержится в ячейке F5.

=F5*(1+5%)

Если значение процента находится в ячейке (например в ячейке F2):

=F5*(1+$F$2)

Ссылка на ячейку F2 является абсолютной ссылкой, поэтому формулу можно скопировать в другую ячейку без изменения ссылки на ячейку F2.

Возврат в начало

Создание итогового значения на основе одного условия

Для создания итогового значения по одному диапазону, основываясь на значении другого диапазона, используется функция СУММЕСЛИ. Например, следующая формула вычисляет по каждой ячейке диапазона B5:B25, содержащей значение "СеверныйВетер" итоговое значение соответствующих ячеек диапазона F5:F25.

=СУММЕСЛИ(B5:B25,"СеверныйВетер",F5:F25)

Возврат в начало

Создание итогового значения на основе нескольких условий

Следующая формула используется для вычисления итогового значения ячеек F5:F25, для которых ячейки диапазона B5:B25 содержат значение "СеверныйВетер", а ячейки диапазона C5:C25 содержат название региона "Западный".

=СУММ(ЕСЛИ((B5:B25="СеверныйВетер")*(C5:C25="Западный"),F5:F25))

Для расчета итогового значения по ячейкам F5:F25, для которых ячейки B5:B25 содержат одно из значений "СеверныйВетер" или "Борей", используется следующая формула.

=СУММ(ЕСЛИ((B5:B25="СеверныйВетер")+(B5:B25="Борей"),F5:F25))

Обе эти формулы являются формулами массива и должны вводиться нажатием клавиш CTRL+SHIFT+ENTER. См. сведения о формулах массива.

Возврат в начало

Подсчет числа вхождений условия

Функция СЧЁТЕСЛИ подсчитывает вхождения значения в диапазон ячеек, например, число ячеек в диапазоне B5:B25, содержащих текст "СеверныйВетер".

=СЧЁТЕСЛИ(B5:B25,"СеверныйВетер")

Возврат в начало

Подсчет числа вхождений нескольких условий

В следующей формуле при обнаружении текста "СеверныйВетер" в диапазоне B5:B25 Excel проверяет наличие значения "Западный" в той же строке столбца C (диапазон C5:C25). Затем Excel вычисляет число строк, содержащих оба значения.

=SUM(IF(B5:B25="СеверныйВетер",IF(C5:C25="Западный",1,0)))

Эта формула является формулой массива и должна вводиться нажатием клавиш CTRL+SHIFT+ENTER. См. сведения о формулах массива.

Возврат в начало


Применение операторов в формулах

Операторами обозначаются операции, которые следует выполнить над операндами формулы. В Microsoft Excel включено четыре вида операторов: арифметические, текстовые, операторы сравнения и операторы ссылок.

Арифметические операторы. Служат для выполнения арифметических операций, таких как сложение, вычитание, умножение. Операции выполняются над числами. Используются следующие арифметические операторы.

Арифметический оператор | Значение | Пример
+ (знак плюс) | Сложение | 3+3
– (знак минус) | Вычитание Унарный минус | 3–1 –1
* (звездочка) | Умножение | 3*3
/ (косая черта) | Деление | 3/3
% (знак процента) | Процент | 20%
^ (крышка) | Возведение в степень | 3^2 (аналогично 3*3)

Операторы сравнения. Используются для сравнения двух значений. Результатом сравнения является логическое значение: либо ИСТИНА, либо ЛОЖЬ.

Оператор сравнения | Значение | Пример
= (знак равенства) | Равно | A1=B1
> (знак больше) | Больше | A1>B1
< (знак меньше) | Меньше | A1<B1
>= (знак больше и знак равенства) | Больше или равно | A1>=B1
<= (знак меньше и знак равенства) | Меньше или равно | A1<=B1
<> (знак «не равно») | Не равно | A1<>B1

Текстовый оператор конкатенации. Амперсанд (&) используется для объединения нескольких текстовых строк в одну строку.

Текстовый оператор | Значение | Пример
& (амперсанд) | Объединение последовательностей символов в одну последовательность. | Выражение "Северный " & " ветер" эквивалентно строке "Северный ветер".

Оператор ссылки. Для описания ссылок на диапазоны ячеек используются следующие операторы.

Оператор сссылки | Значение | Пример
: (двоеточие) | Оператор диапазона используется для ссылки на все ячейки между крайними ячейками диапазона, включая эти ячейки. | B5:B15
, (запятая) | Оператор объединения объединяет несколько ссылок в одну ссылку. | СУММ(B5:B15,D5:D15)


Порядок выполнения действий в формулах

Если в формуле содержится несколько операторов, то порядок вычислений в Microsoft Excel определяется приоритетом операторов. Вначале выполняются операции с более высоким приоритетом, затем — с менее высоким. Если формула содержит операторы с одинаковым приоритетом, например, операторы умножения и деления, то операции выполняются слева направо. Для изменения порядка выполнения операций используются скобки. Вначале вычисляются те части формулы, которые заключены в скобки, затем — остальные части. Чтобы получить об операторах более подробные сведения, щелкните кнопку [image].

Оператор | Описание
: (двоеточие) (пробел) , (запятая) | Операторы ссылок.
– | Унарный минус (например –1).
% | Процент
^ | Возведение в степень.
* и / | Умножение и деление.
+ и – | Сложение и вычитание.
& | Объединение двух текстовых строк в одну.
= < > <= >= <> | Сравнение.


 Преобразование операндов и аргументов формул

Преобразование операндов и аргументов формул

Операнды каждого оператора в формуле, должны быть определенного типа. Если операнд не соответствует оператору, выполняется, если возможно, преобразование типа операнда. Таким образом, удается избежать появления значения ошибки.

Формула | Результат | Пояснения
="1"+"2" | 3 | При использование знака плюс (+), предполагается, что операнды являются числами. Даже если взять числа в кавычки ("1" и "2" — текстовые значения), Microsoft Excel автоматически преобразует их в числа.
=1+"$4.00" | 5 | Когда операнды должны быть числами, текстовые значения преобразуются, если это возможно, в числа.
="6/1/2001"-"5/1/2001" | 31 | Microsoft Excel интерпретирует текст как даты, записанные в формате " dd.mm.yy" , а затем преобразует их в числа для вычисления количества дней между этими двумя датами.
=КОРЕНЬ("8+1") | #ЗНАЧ! | Текстовое значение "8+1" не преобразуется в число. Для правильного выполнения формулы необходимо указать следующие варианты: "9" или "8"+"1"; тогда формула выполнит преобразование текста в число и вернет в качестве результата 3.
="A"&ИСТИНА | AИСТИНА | Когда операнды должны быть текстовыми значениями, выполняется преобразование чисел и логических значений (ИСТИНА и ЛОЖЬ) в текст.


Просмотр формул или значений на листе

  • Для переключения режимов просмотра формул и просмотра значений формул нажмите CTRL+` (левая кавычка).


 Правка формулы

Правка формулы

  1. Укажите ячейку, содержащую изменяемую формулу.

    Если в ячейке содержится гиперссылка, выберите ячейку справа от изменяемой ячейки и выберите ячейку с изменяемой формулой, используя клавишу стрелки.

  2. Измените формулу в строке формул.

    Если в формуле необходимо отредактировать функцию, измените аргументы функции.

  3. Нажмите клавишу ENTER.

    Если формула является формула массива, нажмите комбинацию клавиш CTRL+SHIFT+ENTER.


 Изменение формулы массива

Изменение формулы массива

  1. Укажите любую ячейку массива, содержащую формулу.

  2. Укажите строку формул. При переходе в строку формул фигурные скобки массива ( { } ) исчезнут.

  3. Измените формулу.

  4. Нажмите клавиши CTRL+SHIFT+ENTER.


 Перемещение или копирование формулы

Перемещение или копирование формулы

При перемещении формулы ссылки, расположенные внутри формулы, не изменяются. При копировании формулы абсолютные ссылки не изменяются, а относительные ссылки изменяются. Для получения дополнительных сведений по абсолютным и относительным ссылкам нажмите кнопку [image] .

  1. Выберите ячейку, содержащую копируемую или перемещаемую формулу.

  2. Установите указатель на рамку выделения и нажмите кнопку мыши.

  3. Для перемещения ячейки перетащите выделение, удерживая нажатой кнопку мыши, в необходимую область. Microsoft Excel заменит все существующие данные во вставляемой области.

    Чтобы скопировать ячейку, при перетаскивании удерживайте нажатой клавишу CTRL.

Совет. Кроме того, можно скопировать формулы в соседние ячейки при помощи маркера заполнения. Выделите ячейку, содержащую формулу, и перетащите маркер заполнения в примыкающий диапазон.


Замена формулы или ее части на возвращаемое значение

Можно "зафиксировать" формулу так, что она не будет осуществлять вычисления при внесении изменений в ячейки, на которые она ссылается. При замене формулы на возвращаемое значение Microsoft Excel всегда удаляет формулу. Если нет необходимости пересчитывать какое либо значение формулы, замените его возвращаемым значением.

Предполагаемые действия

Замена формулы на возвращаемое значение

Замена части формулы на возвращаемое значение


 Удаление формулы или формулы массива

Удаление формулы или формулы массива

Внимание. При удалении формулы Microsoft Excel удаляет не только формулу, но и ее значение. Для получения дополнительных сведений по удалению формулы и сохранению ее значения нажмите кнопку [image] .

  1. Укажите ячейку, содержащую формулу.

    Если формула является формулой массива, выделите массив.

    Инструкции

  2. Нажмите клавишу DELETE.


 Ссылки на ячейки и диапазоны ячеек

Ссылки на ячейки и диапазоны ячеек

Ссылка указывает на ячейку или диапазон ячеек листа и передает в Microsoft Excel сведения о расположении значений или данных, которые требуется использовать в формуле. При помощи ссылок можно использовать в одной формуле данные, находящиеся в разных частях листа, а также использовать в нескольких формулах значение одной ячейки. Кроме того, можно задавать ссылки на ячейки других листов той же книги, на другие книги, а также на данные других приложений. Ссылки на ячейки других книг называются внешними. Ссылки на данные других приложений называются удаленными.

Сравнение стилей ссылок A1 и R1C1

Стиль ссылок A1. По умолчанию Excel использует стиль ссылок A1, определяющий столбцы буквами (от A до IV, всего не более 256 столбцов), а строки номерами (от 1 до 65536). Эти буквы и номера называются заголовками строк и столбцов. Для ссылки на ячейку введите букву столбца, а следом номер строки. Например, ссылка D50 указывает на ячейку, расположенную на пересечении столбца D и строки 50. Для ссылки на диапазон ячеек введите адрес ячейки, находящейся в левом верхнем углу диапазона, двоеточие (:), а затем адрес ячейки, находящейся в правом нижнем углу диапазона. Ниже приведены примеры ссылок.

Формула со ссылками B4:D4

Для указания ссылки на | Введите
Ячейку в столбце A и строке 10 | A10
Диапазон ячеек в столбце А и строках с 10 по 20 | A10:A20
Диапазон ячеек в строке 15 и столбцах с B по E | B15:E15
Все ячейки в строке 5 | 5:5
Все ячейки в строках с 5 по 10 | 5:10
Все ячейки в столбце H | H:H
Все ячейки в столбцах с H по J | H:J
Диапазон ячеек в столбцах с А по E и строках с 10 по 20 | A10:E20

Стиль ссылок R1C1. Также можно использовать стиль ссылок, в котором нумеруются как строки, так и столбцы. Стиль ссылок R1C1 полезен при вычислении положения столбцов и строк в макросах. В стиле ссылок R1C1 Excel указывает положение ячейки буквой "R", за которой идет номер строки, и буквой "C", за которой идет номер столбца. См. сведения о ссылках R1C1.

Дополнительные сведения о ссылках

Относительные и абсолютные ссылки. В зависимости от выполняемых задач в Excel можно использовать относительные ссылки, определяющие положение ячейки относительно положения ячейки формулы, или абсолютные ссылки, которые всегда указывают на конкретные ячейки. Если перед буквой или номером стоит знак доллара, например, $A$1, то ссылка на столбец или строку является абсолютной. Относительные ссылки автоматически корректируются при их копировании, а абсолютные ссылки — нет. Дополнительные сведения об относительных и абсолютных ссылках.

Заголовки и имена. Для ссылки на ячейки в столбцах и строках можно использовать заголовки этих столбцов и строк листа. Примерами заголовков являются «Цена», «Количество» и «Итого». Также для представления ячеек, диапазонов ячеек, формул или констант можно создавать описательные имена. Дополнительные сведения об использовании заголовков и имен в формулах.

Трехмерные ссылки. Трехмерные ссылки используются при необходимости анализа данных из одной и той же ячейки или диапазона ячеек на нескольких листах одной книги. Трехмерная ссылка включает в себя ссылку на ячейку или диапазон, перед которой ставятся имена листов. Excel использует все листы, хранящиеся между начальным и конечным именами, указанными в ссылке. Например, формула =СУММ(Лист2:Лист13!B5) суммирует все значения, содержащиеся в ячейке B5 на всех листах в диапазоне от Лист2 до Лист13 включительно. См. сведения о создании трехмерной ссылки.


 Различия между относительными и абсолютными ссылками

Различия между относительными и абсолютными ссылками

Относительные ссылки При создании формулы ссылки обычно учитывают расположение относительно ячейки, содержащей формулу. В следующем примере ячейка B6 содержит формулу =A5; искомое значение находится на одну ячейку выше и левее ячейки B6. Такая ссылка называется относительной.

Формула с относительной ссылкой

При копировании формулы с относительными ссылками Excel автоматически изменяет ссылки во вставляемой формуле для указания на другие ячейки в соответствии с положением формулы. В приведенном ниже примере формула в ячейке B6 ( =A5), которая ссылается на ячейку, расположенную на одну строку выше и на один столбец левее, скопирована в ячейку B7. Excel изменил формулу в ячейке B7 на =A6, ссылаясь на ячейку, которая расположена на одну строку выше и на один столбец левее ячейки B7.

Скопированная формула с относительной ссылкой

Абсолютные ссылки Если необходимо, чтобы ссылки не изменялись при копировании формулы в другую ячейку, воспользуйтесь абсолютными ссылками. Например, если имеется формула, умножающая содержимое ячейки A5 на ячейку C1 (=A5*C1), то при копировании формулы в другую ячейку изменятся обе ссылки. Для создания абсолютной ссылки на ячейку C1, поставьте знак доллара ($) перед той частью ссылки, которая не должна изменяться. Чтобы создать абсолютную ссылку на ячейку C1, поместите знак доллара так, как показано в примере:

=A5*$C$1

Переключение между относительными и абсолютными ссылками Если формула записана, но необходимо поменять относительные ссылки на абсолютные (и наоборот), выберите ячейку с формулой. В строке формул выделите ссылку, которую необходимо изменить, и нажмите F4. Каждое нажатие F4 переключает тип ссылки в следующей последовательности: абсолютный столбец и абсолютная строка (например, $C$1); относительный столбец и абсолютная строка (C$1); абсолютный столбец и относительная строка ($C1); относительный столбец и относительная строка (C1). Например, если в формуле выбран адрес $A$1 и нажата F4, ссылка становится A$1. Нажав F4 еще раз, получаем $A1 и т. п.

Дополнительные сведения

Ссылки на ячейки и диапазоны ячеек


 Ссылки R1C1

Ссылки R1C1

В стиле R1C1 расположение ячейки указывается следующим образом: после буквы R ставится номер строки ячейки, а после буквы С — номер столбца. Например, абсолютная ссылка R1C1 эквивалентна абсолютной ссылке $A$1 в стиле A1. Если ячейка A1 является текущей, то относительная ссылка R[1]C[1] указывает на ячейку, расположенную на одну строку ниже и на один столбец правее, то есть на ячейку B2.

В следующей таблице содержатся примеры ссылок R1C1.

Ссылка | Значение
R[-2]C | Относительная ссылка на ячейку, расположенную на две строки выше и в том же столбце
R[2]C[2] | Относительная ссылка на ячейку, расположенную на две строки ниже и на два столбца правее
R2C2 | Абсолютная ссылка на ячейку, расположенную во второй строке и во втором столбце
R[-1] | Относительная ссылка на строку, расположенную выше текущей ячейки
R | Абсолютная ссылка на текущую строку

При записи макроса Excel записывает некоторые команды с использованием стиля ссылок R1C1. Например, если записывается такая команда как нажатие кнопки Автосумма для вставки формулы, суммирующей диапазон ячеек, Excel использует при записи формулы стиль ссылок R1C1, а не A1.

Совет. Для того чтобы включить или выключить стиль ссылок R1C1, выберите команду Параметры в меню Сервис, а затем перейдите на вкладку Общие и установите или снимите флажок Стиль ссылок R1C1 в группе Параметры.


Ввод ссылки на одну и ту же ячейку или группу ячеек в нескольких листах при помощи трехмерной ссылки

Книга должна содержать несколько листов. Для получения дополнительных сведений по использованию трехмерных ссылок нажмите кнопку [image] .

  1. Укажите ячейку, в которую следует ввести функцию.

  2. Наберите = (знак равенства), введите имя функции, а затем введите открывающую круглую скобку.

  3. Укажите ярлычок первого листа, на который нужно сослаться.

  4. Удерживая нажатой клавишу SHIFT, укажите последний лист, на который необходимо сослаться.

  5. Выделите ячейки, на которые необходимо сослаться.

  6. Формула готова.


 Рекомендации по использованию трехмерных ссылок

Рекомендации по использованию трехмерных ссылок

  • Трехмерные ссылки могут быть использованы для создания ссылок на ячейки на других листах, определения имен и создания формул с использованием следующих функций: СУММ, СРЗНАЧ, СРЗНАЧА, СЧЁТ, СЧЁТЗ, МАКС, МАКСА, МИН, МИНА, ПРОИЗВЕД, СТАНДОТКЛОН, СТАНДОТКЛОНА, СТАНДОТКЛОНП, СТАНДОТКЛОНПА, ДИСП, ДИСПА, ДИСПР и ДИСПРА.

  • Трехмерные ссылки нельзя использовать в формулах массива.

  • Трехмерные ссылки нельзя использовать вместе с оператором пересечения (пробел), а также в формулах, использующих неявное пересечение.


Изменения в трехмерных ссылках при перемещении, копировании, вставке или удалении листов

Нижеследующие примеры поясняют, какие изменения происходят в трехмерных ссылках при перемещении, копировании, вставке и удалении листов, на которые такие ссылки указывают. Предположим, что используется формула " =СУММ(Лист2:Лист6!A2:A5)", суммирующая содержимое ячеек с A2 по A5 с лист2 по лист6 включительно.

Вставка или копирование Если между листом 2 и листом 6 книги вставить новые листы, Microsoft Excel добавит в сумму содержимое ячеек с A2 по A5 на новых листах.

Удаление Если между листом 2 и листом 6 книги удалить листы, Microsoft Excel исключит из суммы содержимое ячеек удаленных листов.

Перемещение Если переместить листы, находящиеся между листом 2 и листом 6 книги, и разместить их таким образом, что они будут расположены перед листом 2 или после листа 6, Microsoft Excel исключит из суммы содержимое ячеек перемещенных листов.

Перемещение граничного листа Если переместить лист 2 или лист 6 в новое место книги, Microsoft Excel включит в сумму содержимое ячеек листов, находящихся между листом 2 и листом 6 включительно.

Удаление граничного листа Если удалить лист 2 или лист 6, Microsoft Excel включит в сумму содержимое ячеек листов, находившихся между ними.


 Использование функций для вычисления значений

Использование функций для вычисления значений

Функции — заранее определенные формулы, которые выполняют вычисления по заданным величинам, называемым аргументами, и в указанном порядке. Например, функция СУММ суммирует значения в диапазоне ячеек, а функция ППЛАТ вычисляет величину выплаты за один период годовой ренты на основе постоянных выплат и постоянной процентной ставки.

Аргументы Список аргументов может состоять из чисел, текста, логических величин (например ИСТИНА или ЛОЖЬ), массивов, значений ошибок (например #Н/Д) или ссылок. Необходимо следить за соответствием типов аргументов. Кроме того, аргументы могут быть как константами, так и формулами. Эти формулы, в свою очередь, могут содержать другие функции. Для получения дополнительных сведений по использованию функций в качестве аргументов другой функции (вложенные функции) нажмите кнопку [image] .

Структура Структура функции начинается с указания имени функции, затем вводится открывающая скобка, указываются аргументы, отделяющиеся точками с запятыми, а затем — закрывающая скобка. Если написание формулы начинается с функции, перед именем функции вводится знак равенства (=). В процессе создания формулы, содержащей функцию, можно использовать палитру формул. Для получения дополнительных сведений по использованию палитры формул нажмите кнопку [image] . Для получения дополнительных сведений по созданию формулы, содержащей функцию, нажмите кнопку [image] .


 Вложенные функции

Вложенные функции

В некоторых случаях необходимо использовать функцию как один из аргументов другой функции. Например, формула на рисунке 1 использует вложенную функцию СРЗНАЧ и сравнивает результат со значением 50.

Рис. 1

Возвращение правильного значения Если вложенная функция используется как аргумент, то она должна возвращать значение, соответствующее типу аргумента. Например, если аргумент принимает значения ИСТИНА или ЛОЖЬ, то и вложенная функция должна возвращать значение ИСТИНА или ЛОЖЬ. Если функция возвращает значение другого типа, отобразится ошибка #ЗНАЧ!.

Ограничение количества уровней вложения функций В формулах можно использовать до семи уровней вложения функций. Когда «функция Б» является аргументом «функции А», то «функция Б» считается вторым уровнем вложенности. Например, функции СРЗНАЧ и СУММ на рис. 1 считаются функциями второго уровня, потому что обе являются аргументами функции ЕСЛИ. Функция, вложенная в качестве аргумента в функцию СРЗНАЧ, будет третьим уровнем и так далее.

Использование функций в качестве аргумента. Чтобы использовать функцию в качестве аргумента, можно воспользоваться палитру формул. Например, на рис. 2, чтобы сделать функцию СУММ аргументом функции ЕСЛИ, нажмите значение_если_истина в поле ввода, нажмите стрелку вниз на панели формул в меню Функция и выберите СУММ.

Функции, вложенные с помощью палитры формул

Рис. 2

Чтобы переключаться между функциями на палитре формул, нажмите кнопку мыши на имени формулы в списке формул. Например, чтобы сменить диапазон функции СРЗНАЧ на рис. 2, щелкните имя этой формулы на панели формул. См. сведения об использовании палитры формул для ввода и правки формул.


Арифметические и тригонометрические функции

Арифметические и тригонометрические функции позволяют производить простые и сложные вычисления, например вычисление суммы диапазона ячеек, вычисление суммы ячеек диапазона, удовлетворяющих указанному условию, округление чисел и прочее.

Выберите нужную функцию:

ABS

ACOS

ACOSH

ASIN

ASINH

ATAN

ATAN2

ATANH

COS

COSH

EXP

LN

LOG

LOG10

SIN

SINH

TAN

TANH

ГРАДУСЫ

ДВФАКТР

ЗНАК

КОРЕНЬ

КОРЕНЬПИ

МОБР

МОПРЕД

МУЛЬТИНОМ

МУМНОЖ

НЕЧЁТ

НОД

НОК

ОКРВВЕРХ

ОКРВНИЗ

ОКРУГЛ

ОКРУГЛ

ОКРУГЛВВЕРХ

ОКРУГЛВНИЗ

ОКРУГЛТ

ОСТАТ

ОТБР

ПИ

ПРОИЗВЕД

ПРОМЕЖУТОЧНЫЕ.ИТОГИ

РАДИАНЫ

РЯД.СУММ

СЛУЧМЕЖДУ

СЛЧИС

СТЕПЕНЬ

СУММ

СУММЕСЛИ

СУММКВ

СУММКВРАЗН

СУММПРОИЗВ

СУММРАЗНКВ

СУММСУММКВ

СЧЁТЕСЛИ

ФАКТР

ЦЕЛОЕ

ЧАСТНОЕ

ЧЁТН

ЧИСЛКОМБ


Инженерные функции

Инженерные функции служат для выполнения инженерного анализа. Инженерные функции можно разделить на три группы:

  • Функции для работы с комплексными числами

  • Функции для преобразования чисел из одной системы счисления в другую (десятичную, шестнадцатеричную, восьмеричную и двоичную)

  • Функции для преобразования величин из одной системы мер и весов в другую

Примечание. Функции инженерного анализа входя в «Пакет анализа». Если инженерная функция недоступна, установите «Пакет анализа».

Выберите нужную функцию:

БЕССЕЛЬ.I

БЕССЕЛЬ.J

БЕССЕЛЬ.K

БЕССЕЛЬ.Y

ВОСЬМ.В.ДВ

ВОСЬМ.В.ДЕС

ВОСЬМ.В.ШЕСТН

ДВ.В.ВОСЬМ

ДВ.В.ДЕС

ДВ.В.ШЕСТН

ДЕЛЬТА

ДЕС.В.ВОСЬМ

ДЕС.В.ДВ

ДЕС.В.ШЕСТН

ДФОШ

КОМПЛЕКСН

МНИМ.ABS

МНИМ.COS

МНИМ.EXP

МНИМ.LN

МНИМ.LOG10

МНИМ.LOG2

МНИМ.SIN

МНИМ.АРГУМЕНТ

МНИМ.ВЕЩ

МНИМ.ДЕЛ

МНИМ.КОРЕНЬ

МНИМ.ПРОИЗВЕД

МНИМ.РАЗН

МНИМ.СОПРЯЖ

МНИМ.СТЕПЕНЬ

МНИМ.СУММ

МНИМ.ЧАСТЬ

ПОРОГ

ПРЕОБР

ФОШ

ШЕСТН.В.ВОСЬМ

ШЕСТН.В.ДВ

ШЕСТН.В.ДЕС


Информационные функции

Информационные функции предназначены для определения типа данных, хранимых в ячейке. Информационные функции проверяют выполнение какого-то условия и возвращают в зависимости от результата значение ИСТИНА или ЛОЖЬ. Так, если ячейка содержит четное значение,функция ЕЧЁТН возвращает значение ИСТИНА. Если в диапазоне функций имеется пустая ячейка, можно воспользоваться функцией СЧИТАТЬПУСТОТЫ, либо ЕПУСТО.

Выберите нужную функцию:

ЕЛОГИЧ

ЕНД

ЕНЕТЕКСТ

ЕНЕЧЁТ

ЕОШ

ЕОШИБКА

ЕПУСТО

ЕССЫЛКА

ЕТЕКСТ

ЕЧЁТН

ЕЧИСЛО

ИНФОРМ

НД

СЧИТАТЬПУСТОТЫ

ТИП.ОШИБКИ

ТИП

Ч

ЯЧЕЙКА


Логические функции

Логические функции предназначены для проверки выполнения условия или для проверки нескольких условий. Так, функция ЕСЛИ позволяет определить, выполняется ли указанное условие, и возвращает одно значение если условие истинно, и другое — если оно ложно.

Выберите нужную функцию:

ЕСЛИ

И

ИЛИ

ИСТИНА

ЛОЖЬ

НЕ


 Нестандартные функции

Нестандартные функции

Если необходимо выполнить сложные вычисления, можно воспользоваться возможностью создания своих собственных функций. Свои собственные функции могут быть созданы с помощью языка VBA. Для получения дополнительных сведений о создании нестандартных функций, обращайтесь к разделу Справка по Visual Basic.


Статистические функции

Статистические функции позволяют выполнять статистический анализ диапазонов данных. Например, с помощью статистической функции можно провести прямую по группе значений, вычислить угол наклона и точку пересечения с осью Y и прочее.

Выберите нужную функцию:

FРАСП

FРАСПОБР

ZТЕСТ

БЕТАОБР

БЕТАРАСП

БИНОМРАСП

ВЕЙБУЛЛ

ВЕРОЯТНОСТЬ

ГАММАНЛОГ

ГАММАОБР

ГАММАРАСП

ГИПЕРГЕОМЕТ

ДИСП

ДИСПА

ДИСПР

ДИСПРА

ДОВЕРИТ

КВАДРОТКЛ

КВАРТИЛЬ

КВПИРСОН

КОВАР

КОРРЕЛ

КРИТБИНОМ

ЛГРФПРИБЛ

ЛИНЕЙН

ЛОГНОРМОБР

ЛОГНОРМРАСП

МАКС

МАКСА

МЕДИАНА

МИН

МИНА

МОДА

НАИБОЛЬШИЙ

НАИМЕНЬШИЙ

НАКЛОН

НОРМАЛИЗАЦИЯ

НОРМОБР

НОРМРАСП

НОРМСТОБР

НОРМСТРАСП

ОТРБИНОМРАСП

ОТРЕЗОК

ПЕРЕСТ

ПЕРСЕНТИЛЬ

ПИРСОН

ПРЕДСКАЗ

ПРОЦЕНТРАНГ

ПУАССОН

РАНГ

РОСТ

СКОС

СРГАРМ

СРГЕОМ

СРЗНАЧ

СРЗНАЧА

СРОТКЛ

СТАНДОТКЛОН

СТАНДОТКЛОНА

СТАНДОТКЛОНП

СТАНДОТКЛОНПА

СТОШYX

СТЬЮДРАСП

СТЬЮДРАСПОБР

СЧЁТ

СЧЁТЗ

ТЕНДЕНЦИЯ

ТТЕСТ

УРЕЗСРЕДНЕЕ

ФИШЕР

ФИШЕРОБР

ФТЕСТ

ХИ2ОБР

ХИ2РАСП

ХИ2ТЕСТ

ЧАСТОТА

ЭКСПРАСП

ЭКСЦЕСС


 Финансовые функции

Финансовые функции

С помощью финансовых функций осуществляются такие типичные финансовые расчеты, как вычисление суммы платежа по ссуде, объем периодической выплаты по вложению или ссуде, стоимость вложения или ссуды по завершении всех отложенных платежей.

Аргументами финансовых функций часто являются следующие величины:

  • Будущее значение – стоимость вложения или ссуды по завершении всех отложенных платежей.

  • Выплата – объем периодической выплаты по вложению или ссуде.

  • Режим выплат – режим, в котором осуществляются выплаты (в конце или в начале месяца).

  • Ставка – процентная ставка или норма скидки по вложению или ссуде.

  • Текущее значение – начальная стоимость вложения или ссуды. Например, начальная стоимость ссуды равна сумме займа.

  • Число периодов – общее количество платежей или периодов выплат.

Выберите нужную функцию:

АМГД

АМОРУВ

АМОРУМ

АМР

БЗ

БЗРАСПИС

ВНДОХ

ДАТАКУПОНДО

ДАТАКУПОНПОСЛЕ

ДДОБ

ДЛИТ

ДНЕЙКУПОН

ДНЕЙКУПОНДО

ДНЕЙКУПОНПОСЛЕ

ДОБ

ДОХОД

ДОХОДКЧЕК

ДОХОДПЕРВНЕРЕГ

ДОХОДПОГАШ

ДОХОДПОСЛНЕРЕГ

ДОХОДСКИДКА

ИНОРМА

КПЕР

МВСД

МДЛИТ

НАКОПДОХОД

НАКОПДОХОДПОГАШ

НОМИНАЛ

НОРМА

НПЗ

ОБЩДОХОД

ОБЩПЛАТ

ОСНПЛАТ

ПДОБ

ПЗ

ПЛПРОЦ

ПОЛУЧЕНО

ППЛАТ

РАВНОКЧЕК

РУБЛЬ.ДЕС

РУБЛЬ.ДРОБЬ

СКИДКА

ЦЕНА

ЦЕНАКЧЕК

ЦЕНАПЕРВНЕРЕГ

ЦЕНАПОГАШ

ЦЕНАПОСЛНЕРЕГ

ЦЕНАСКИДКА

ЧИСЛКУПОН

ЧИСТВНДОХ

ЧИСТНЗ

ЭФФЕКТ


 Функции для работы с базами данных

Функции для работы с базами данных

Если необходимо убедиться в том, что значения списка удовлетворяют условию, можно использовать функции для работы с базами данных. С их помощью, например, можно определить количество записей в таблице о продажах или извлечь те записи, в которых значение поля «Сумма» больше 1000, но меньше 2500.

Имена многих функций работы с базами данных часто начинаются с буквы " Д" . Эти функции, которые иногда также называются «Дфункциями», имеют три аргумента — база данных, поле и условие.

  • Аргументом «база данных» является диапазон, содержащий список. Этот диапазон должен включать строку с названиями полей.

  • Аргумент «поле» должен содержать имя столбца, по которому следует вычислить итог.

  • Аргумент «условие» является адресом диапазона, содержащего условия.

Для получения более подробных сведений нажмите эту кнопку: .

Выберите нужную функцию:

БДДИСП

БДДИСПП

БДПРОИЗВЕД

БДСУММ

БИЗВЛЕЧЬ

БСЧЁТ

БСЧЁТА

ДМАКС

ДМИН

ДСРЗНАЧ

ДСТАНДОТКЛ

ДСТАНДОТКЛП

ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ


Функции обработки текста

С помощью функций обработки текста можно с помощью формул производить действия над строкам текста — например, изменить регистр или определить длину строки. Можно также объединить несколько строк в одну. В примере ниже показано, как с помощью функций СЕГОДНЯ и ТЕКСТ создать сообщение, содержащее текущую дату и привести его к виду "дд-ммм-гг".

="Балансовый отчет от "&ТЕКСТ(СЕГОДНЯ(),"дд-мм-гг")

Выберите нужную функцию:

ДЛСТР

ЗАМЕНИТЬ

ЗНАЧЕН

КОДСИМВ

ЛЕВСИМВ

НАЙТИ

ПЕЧСИМВ

ПОВТОР

ПОДСТАВИТЬ

ПОИСК

ПРАВСИМВ

ПРОПИСН

ПРОПНАЧ

ПСТР

РУБЛЬ

СЖПРОБЕЛЫ

СИМВОЛ

СОВПАД

СТРОЧН

СЦЕПИТЬ

Т

ТЕКСТ

ФИКСИРОВАННЫЙ


Функции работы с датой и временем

Функции работы с датой и временем позволяют анализировать и работать со значениями даты и времени в формулах. Например, если требуется использовать в формуле текущую дату, воспользуйтесь функцией СЕГОДНЯ, возвращающей текущую дату по системных часов.

Выберите нужную функцию:

ВРЕМЗНАЧ

ВРЕМЯ

ГОД

ДАТА

ДАТАЗНАЧ

ДАТАМЕС

ДЕНЬ

ДЕНЬНЕД

ДНЕЙ360

ДОЛЯГОДА

КОНМЕСЯЦА

МЕСЯЦ

МИНУТЫ

РАБДЕНЬ

СЕГОДНЯ

СЕКУНДЫ

ТДАТА

ЧАС

ЧИСТРАБДНИ


Функции ссылки и автоподстановки

Если необходимо осуществлять поиск в списках или таблицах или если необходимо найти ссылку к ячейке, воспользуйтесь функциями ссылки и автоподстановки. Например, для поиска значения в таблице используйте функцию ВПР, а для поиска положения значения в списке — функцию ПОИСКПОЗ.

Выберите нужную функцию:

АДРЕС

ВПР

ВЫБОР

ГИПЕРССЫЛКА

ГПР

ДВССЫЛ

ИНДЕКС

ОБЛАСТИ

ПОИСКПОЗ

ПРОСМОТР

СМЕЩ

СТОЛБЕЦ

СТРОКА

ТРАНСП

ЧИСЛСТОЛБ

ЧСТРОК


Функции баз данных

См. также

В Microsoft Excel имеется 12 функций рабочего листа, используемых для анализа данных из списков или баз данных. Каждая из этих функций, которые из соображений совместимости имеют обобщенное название БДФункция, использует три аргумента: база_данных, поле и критерий. Эти три аргумента ссылаются на интервалы ячеек на рабочем листе, которые используются данной функцией.

Синтаксис

БДФункция(база_данных;поле;критерий)

База_данных — это интервал ячеек, формирующих список или базу данных.

  • База данных в Microsoft Excel — это список связанных данных, в котором строки данных являются записями, а столбцы - полями. Верхняя строка списка содержит названия каждого столбцов. Ссылка может быть задана как диапазон ячеек либо как имя, соответствующее диапазону списка. Чтобы узнать, как создавать списки на рабочих листах, нажмите кнопку [image] .

  • Во всех функциях баз данных в том случае, если база данных ссылается на ячейку в сводной таблице, вычисления производятся только для данных в сводной таблице.

  • Для вычисления и добавления промежуточных итогов в список следует пользоваться командой Итоги меню Данные. Автоматический расчет промежуточных итогов.

Поле определяет столбец, используемый функцией. Поля данных в списке должны содержать идентифицирующее имя в первой строке. Аргумент поле может быть задан как текст с названием столбца в двойных кавычках, например «Возраст» или «Урожай» в приведенном ниже примере базы данных, или как число, задающее положение столбца в списке: 1 — для первого поля (Дерево), 2 — для второго поля (Высота) и так далее.

Критерий — это ссылка на интервал ячеек, задающих условия для функции. Функция возвращает данные из списка, которые удовлетворяют условиям, определенным диапазоном критериев. Диапазон критериев включает копию названия столбца в списке, для которого выполняется подведение итогов. Ссылка на критерий может быть введена как интервал ячеек, например A1:F2 в приведенном ниже примере базы данных, или как имя интервала, например "Критерии". Для получения дополнительных сведений об условиях, которые могут быть использованы в качестве аргумента критерий нажмите кнопку [image] .

Советы

  • Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий БДФункции.

    Например, если интервал G1:G2 содержит название столбца «Доход» в ячейке G1 и величину 10 000 в ячейке G2, то можно определить интервал «СоответствуетДоходу» и использовать это имя как аргумент критерий в функции баз данных.

  • Несмотря на то, что диапазон критериев может располагаться в любом месте таблицы, не стоит помещать его внизу списка. Это связано с тем, что данные, добавляемые в список командой Форма меню Данные, вставляются с первой строки после списка. Если эта строка не пустая, Microsoft Excel не сможет добавить данные в список.

  • Диапазон критериев не должен перекрываться со списком.

  • Чтобы выполнить операцию над целым столбцом базы данных, нужно ввести пустую ячейку под названием столбца в диапазоне критерия.

Примеры

Следующий рисунок является примером базы данных для небольшого фруктового сада. Каждая запись содержит информацию об одном дереве. Диапазон A5:E11 имеет название «БазаДанных», а диапазон A1:F3 — «Критерий».

БСЧЁТ(БазаДанных;"Возраст";A1:F2) равняется 1. Эта функция просматривает записи о яблонях, которые имеют высоту от 10 до 16 и подсчитывает количество числовых полей «Возраст» в этих записях.

БСЧЁТА(БазаДанных;"Доход";A1:F2) равняется 1. Эта функция просматривает записи о яблонях, которые имеют высоту от 10 до 16 и подсчитывает количество непустых полей «Доход» в этих записях.

ДМАКС(БазаДанных;"Доход";A1:A3) равняется 105,00 руб., максимальный доход от яблонь и груш.

ДМИН(БазаДанных;"Доход";A1:B2) равняется 75,00 руб., минимальный доход от яблонь выше 10.

БДСУММ(БазаДанных;"Доход";A1:A2) равняется 225,00 руб., суммарный доход от яблонь.

БДСУММ(БазаДанных;"Доход";A1:F2) равняется 75,00 руб., суммарный доход от яблонь высотой от 10 до 16 .

БДПРОИЗВЕД(БазаДанных;"Урожай";A1:F2) равняется 140, урожай яблонь высотой от 10 до 16.

ДСРЗНАЧ(БазаДанных;"Урожай";A1:B2) равняется 12, средний урожай яблонь высотой более 10.

ДСРЗНАЧ(БазаДанных;3;БазаДанных) равняется 13, средний возраст всех деревьев.

ДСТАНДОТКЛ(БазаДанных;"Урожай";A1:A3) равняется 2,97, оценка стандартного отклонения урожайности яблонь и груш, если считать, что данные в базе данных — это только выборка из генеральной совокупности всех деревьев в саду.

ДСТАНДОТКЛP(БазаДанных;"Урожай";A1:A3) равняется 2,65, точное стандартное отклонение в урожайности яблонь и груш, если считать, что данные в базе данных описывают генеральную совокупность всех деревьев в саду.

БДДИСП(БазаДанных;"Урожай";A1:A3) равняется 8,8, оценка дисперсии урожайности яблонь и груш, если считать, что данные в базе данных — это только выборка из генеральной совокупности всех деревьев в саду.

БДДИСПП(БазаДанных;"Урожай";A1:A3) равняется 7,04, точная дисперсия урожайности яблонь и груш, если считать, что данные в базе данных описывают генеральную совокупность всех деревьев в саду.

БИЗВЛЕЧЬ(БазаДанных;"Урожай";Критерий) возвращает значение ошибки #ЧИСЛО!, потому что критерию удовлетворяет более чем одна запись.


БДДИСП

См. также

Оценивает дисперсию генеральной совокупности по выборке, используя числа в столбце списка или базы данных, которые удовлетворяют заданным условиям.

Для просмотра подробностей и примеров нажмите на кнопку [image] .

Синтаксис

БДДИСП(база_данных;поле;критерий)

База_данных - это интервал ячеек, формирующих список или базу данных. База данных представляет собой список связанных данных, в котором строки данных являются записями, а столбцы - полями. Верхняя строка списка содержит названия каждого столбцов.

Поле определяет столбец, используемый функцией. Аргумент " поле" может быть задан как текст с названием столбца в двойных кавычках, например "Возраст" или "Урожай" в приведенном ниже примере базы данных, или как число, задающее положение столбца в списке: 1 - для первого поля, 2 - для второго поля и так далее.

Критерий - это интервал ячеек, который содержит задаваемые условия. Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий БДФункции.


БДДИСПП

См. также

Вычисляет дисперсию генеральной совокупности, используя числа в столбце списка или базы данных, которые удовлетворяют заданным условиям.

Для просмотра подробностей и примеров нажмите на кнопку [image] .

Синтаксис

БДДИСПП(база_данных;поле;критерий)

База_данных - это интервал ячеек, формирующих список или базу данных. База данных представляет собой список связанных данных, в котором строки данных являются записями, а столбцы - полями. Верхняя строка списка содержит названия каждого столбцов.

Поле определяет столбец, используемый функцией. Аргумент " поле" может быть задан как текст с названием столбца в двойных кавычках, например "Возраст" или "Урожай" в приведенном ниже примере базы данных, или как число, задающее положение столбца в списке: 1 - для первого поля, 2 - для второго поля и так далее.

Критерий - это интервал ячеек, который содержит задаваемые условия. Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий БДФункции.


БДПРОИЗВЕД

См. также

Перемножает значения в столбце списка или базы данных, которые удовлетворяют заданным условиям.

Для просмотра подробностей и примеров нажмите на кнопку [image] .

Синтаксис

БДПРОИЗВЕД(база_данных;поле;критерий)

База_данных - это интервал ячеек, формирующих список или базу данных. База данных представляет собой список связанных данных, в котором строки данных являются записями, а столбцы - полями. Верхняя строка списка содержит названия каждого столбцов.

Поле определяет столбец, используемый функцией. Аргумент " поле" может быть задан как текст с названием столбца в двойных кавычках, например "Возраст" или "Урожай" в приведенном ниже примере базы данных, или как число, задающее положение столбца в списке: 1 - для первого поля, 2 - для второго поля и так далее.

Критерий - это интервал ячеек, который содержит задаваемые условия. Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий БДФункции.


БДСУММ

См. также

Суммирует числа в столбце списка или базы данных, которые удовлетворяют заданным условиям.

Для просмотра подробностей и примеров нажмите на кнопку [image] .

Синтаксис

ДМАКС(база_данных;поле;критерий)

База_данных - это интервал ячеек, формирующих список или базу данных. База данных представляет собой список связанных данных, в котором строки данных являются записями, а столбцы - полями. Верхняя строка списка содержит названия каждого столбцов.

Поле определяет столбец, используемый функцией. Аргумент " поле" может быть задан как текст с названием столбца в двойных кавычках, например "Возраст" или "Урожай" в приведенном ниже примере базы данных, или как число, задающее положение столбца в списке: 1 - для первого поля, 2 - для второго поля и так далее.

Критерий - это интервал ячеек, который содержит задаваемые условия. Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий БДФункции.


БИЗВЛЕЧЬ

См. также

Извлекает отдельное значение из столбце списка или базы данных, которое удовлетворяет заданным условиям.

Для просмотра подробностей и примеров нажмите на кнопку [image] .

Синтаксис

БИЗВЛЕЧЬ(база_данных;поле;критерий)

База_данных - это интервал ячеек, формирующих список или базу данных. База данных представляет собой список связанных данных, в котором строки данных являются записями, а столбцы - полями. Верхняя строка списка содержит названия каждого столбцов.

Поле определяет столбец, используемый функцией. Аргумент " поле" может быть задан как текст с названием столбца в двойных кавычках, например "Возраст" или "Урожай" в приведенном ниже примере базы данных, или как число, задающее положение столбца в списке: 1 - для первого поля, 2 - для второго поля и так далее.

Критерий - это интервал ячеек, который содержит задаваемые условия. Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий БДФункции.

Замечания

  • Если ни одна из записей не удовлетворяет критерию, то функция БИЗВЛЕЧЬ возвращает значение ошибки #ЗНАЧ!.

  • Если более чем одна запись удовлетворяет критерию, то функция БИЗВЛЕЧЬ возвращает значение ошибки #ЧИСЛО!.


БСЧЁТ

См. также

Подсчитывает количество ячеек, содержащих числа, в столбце списка или базы данных указанном поле всех записей, удовлетворяющих заданным условиям.

Аргумент поле не является обязательным. Если аргумент поле опущен, то функция БСЧЁТ подсчитывает количество записей в базе данных, отвечающих критериям.

Для просмотра подробностей и примеров нажмите на кнопку [image] .

Синтаксис

БСЧЁТ(база_данных;поле;критерий)

База_данных - это интервал ячеек, формирующих список или базу данных. База данных представляет собой список связанных данных, в котором строки данных являются записями, а столбцы - полями. Верхняя строка списка содержит названия каждого столбцов.

Поле определяет столбец, используемый функцией. Аргумент " поле" может быть задан как текст с названием столбца в двойных кавычках, например "Возраст" или "Урожай" в приведенном ниже примере базы данных, или как число, задающее положение столбца в списке: 1 - для первого поля, 2 - для второго поля и так далее.

Критерий - это интервал ячеек, который содержит задаваемые условия. Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий БДФункции.


БСЧЁТА

См. также

Подсчитывает все непустые ячейки в столбце списка или базы данных, которые удовлетворяют заданным условиям.

Для получения дополнительной информации и примеров нажмите на кнопку [image] .

Синтаксис

БСЧЁТА(база_данных;поле;критерий)

База_данных — это интервал ячеек, формирующих список или базу данных. База данных представляет собой список связанных данных, в котором строки данных являются записями, а столбцы — полями. Верхняя строка списка содержит названия столбцов.

Поле показывает столбец, используемый в функции. Аргумент может быть задан названием поля, заключенного в кавычки, например "Возраст" или "Урожай", или числом, соответствующим номеру столбца в списке: 1 для первого столбца, 2 — для второго и так далее. Если аргумент опущен, функция возвращает количество всех записей, удовлетворяющих условию. Если аргумент задан, функция возвращает количество записей, содержащих значения в поле и удовлетворяющих условию.

Критерий — это интервал ячеек, который содержит задаваемые условия. Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий функции.


ДМАКС

См. также

Возвращает наибольшее число в столбце списка или базы данных, которое удовлетворяет заданным условиям.

Для просмотра подробностей и примеров нажмите на кнопку [image] .

Синтаксис

ДМАКС(база_данных;поле;критерий)

База_данных - это интервал ячеек, формирующих список или базу данных. База данных представляет собой список связанных данных, в котором строки данных являются записями, а столбцы - полями. Верхняя строка списка содержит названия каждого столбцов.

Поле определяет столбец, используемый функцией. Аргумент " поле" может быть задан как текст с названием столбца в двойных кавычках, например "Возраст" или "Урожай" в приведенном ниже примере базы данных, или как число, задающее положение столбца в списке: 1 - для первого поля, 2 - для второго поля и так далее.

Критерий - это интервал ячеек, который содержит задаваемые условия. Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий БДФункции.


ДМИН

См. также

Возвращает наименьшее число в столбце списка или базы данных, которое удовлетворяет заданным условиям.

Для просмотра подробностей и примеров нажмите на кнопку [image] .

Синтаксис

ДМИН(база_данных;поле;критерий)

База_данных - это интервал ячеек, формирующих список или базу данных. База данных представляет собой список связанных данных, в котором строки данных являются записями, а столбцы - полями. Верхняя строка списка содержит названия каждого столбцов.

Поле определяет столбец, используемый функцией. Аргумент " поле" может быть задан как текст с названием столбца в двойных кавычках, например "Возраст" или "Урожай" в приведенном ниже примере базы данных, или как число, задающее положение столбца в списке: 1 - для первого поля, 2 - для второго поля и так далее.

Критерий - это интервал ячеек, который содержит задаваемые условия. Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий БДФункции.


ДСРЗНАЧ

См. также

Усредняет значения в столбце списка или базы данных, удовлетворяющих заданным условиям.

Для просмотра подробностей и примеров нажмите на кнопку [image] .

Синтаксис

ДСРЗНАЧ(база_данных;поле;критерий)

База_данных - это интервал ячеек, формирующих список или базу данных. База данных представляет собой список связанных данных, в котором строки данных являются записями, а столбцы - полями. Верхняя строка списка содержит названия каждого столбцов.

Поле определяет столбец, используемый функцией. Аргумент " поле" может быть задан как текст с названием столбца в двойных кавычках, например "Возраст" или "Урожай" в приведенном ниже примере базы данных, или как число, задающее положение столбца в списке: 1 - для первого поля, 2 - для второго поля и так далее.

Критерий - это интервал ячеек, который содержит задаваемые условия. Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий БДФункции.


ДСТАНДОТКЛ

См. также

Оценивает стандартное отклонение на основе выборки из генеральной совокупности, используя числа в столбце списка или базы данных, которые удовлетворяют заданным условиям.

Для просмотра подробностей и примеров нажмите на кнопку [image] .

Синтаксис

ДСТАНДОТКЛ(база_данных;поле;критерий)

База_данных - это интервал ячеек, формирующих список или базу данных. База данных представляет собой список связанных данных, в котором строки данных являются записями, а столбцы - полями. Верхняя строка списка содержит названия каждого столбцов.

Поле определяет столбец, используемый функцией. Аргумент " поле" может быть задан как текст с названием столбца в двойных кавычках, например "Возраст" или "Урожай" в приведенном ниже примере базы данных, или как число, задающее положение столбца в списке: 1 - для первого поля, 2 - для второго поля и так далее.

Критерий - это интервал ячеек, который содержит задаваемые условия. Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий БДФункции.


ДСТАНДОТКЛП

См. также

Вычисляет стандартное отклонение генеральной совокупности, используя числа в столбце списка или базы данных, которые удовлетворяют заданным условиям.

Для просмотра подробностей и примеров нажмите на кнопку [image] .

Синтаксис

ДСТАНДОТКЛП(база_данных;поле;критерий)

База_данных - это интервал ячеек, формирующих список или базу данных. База данных представляет собой список связанных данных, в котором строки данных являются записями, а столбцы - полями. Верхняя строка списка содержит названия каждого столбцов.

Поле определяет столбец, используемый функцией. Аргумент " поле" может быть задан как текст с названием столбца в двойных кавычках, например "Возраст" или "Урожай" в приведенном ниже примере базы данных, или как число, задающее положение столбца в списке: 1 - для первого поля, 2 - для второго поля и так далее.

Критерий - это интервал ячеек, который содержит задаваемые условия. Любой интервал, который содержит по крайней мере одно название столбца и по крайней мере одну ячейку под названием столбца с условием, может быть использован как аргумент критерий БДФункции.


ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ

См. также

Возвращает данные, хранящиеся в отчете сводной таблицы. Функция ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ может быть использована для извлечения итоговых данных из отчета сводной таблицы, если итоговые данные отображены в отчете.

Синтаксис

ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ(сводная_таблица;имя)

Аргумент сводная_таблица представляет собой ссылку на ячейку в сводной таблице, содержащую извлекаемые данные. Аргумент может быть ячейкой или диапазоном ячеек в отчете, именем диапазона, содержащего отчет сводной таблицы, а также подписью в ячейке над сводной таблицей.

Имя — это заключенная в двойные кавычки текстовая строка, описывающая ячейку сводной таблицы, содержащую извлекаемое значение. Например, если отчет сводной таблицы содержит поле строки "Продавец" и требуется извлечь итоговую сумму для продавца Иванов, данный аргумент будет содержать значение "Иванов". Если поле столбца в сводной таблице содержит наименования товаров и требуется получить итоговую сумму по продажам напитков продавцом Ивановым, данный аргумент будет содержать "Иванов Напитки". Правила использования имен сводных таблиц и сводных диаграмм в формулах.

Замечания

  • Вычисляемые поля или элементы и дополнительные вычисления включаются в расчеты ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ.

  • Если аргумент сводная_таблица представляет собой интервал, включающий несколько сводных таблиц, данные будут извлекаться из той сводной таблицы, которая была создана последней.

  • Если аргумент имя содержит описание отдельной ячейки, возвращается значение, содержащееся в этой ячейке, независимо от того, что это — строка, число, ошибка и т.п.

  • Если аргумент сводная_таблица не является интервалом, содержащим сводную таблицу, функция ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ возвращает значение ошибки #ЗНАЧ!.

  • Если синтаксис аргумента имя не описывает видимое поле, если этот аргумент опущен или в имя входит неотображаемое поле страницы, функция ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ возвращает значение ошибки #ССЫЛКА!.

Примеры

Предположим, что на листе находится отчет сводной таблицы и имя СТ1 ссылается на ячейки A2:E12. Интервал, содержащий сводную таблицу:

ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ(СТ1;"Итог по продажам") возвращает общий итог по полю "Продажи", 49 325 р.

ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ(СТ1;"Март") возвращает общий итог за март, 30 337 р.

В примерах, приведенных ниже, фигурирует та же самая сводная таблица, а в качестве аргумента сводная_таблица используется ячейка из сводной таблицы:

ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ(A4;"Производство в марте") возвращает 10 201 р.

ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ(A4;"Март Юг") возвращает #ССЫЛКА!, поскольку данные южного региона не видимы.

ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ(A4;"Иванов Напитки") возвращает #ССЫЛКА!; поскольку для Иванова итоговые данные по продажам напитков отсутствуют.


ВРЕМЗНАЧ

См. также

Возвращает время в числовом формате для времени, заданного текстовой строкой. Время в числовом формате — это десятичная дробь в интервале от 0 до 0,99999999, представляющая время от 0:00:00 (12:00:00 ночи) до 23:59:59 (11:59:59 вечера).

Синтаксис

ВРЕМЗНАЧ(время_как_текст)

Время_как_текст — это текстовая строка, задающая время в любом из форматов времени Excel. Например, текстовые строки в кавычках "18:45" и "18:45:00" представляют время. Информация о дате в аргументе игнорируется.

Замечания

Microsoft Excel для Windows и Excel для Макинтош используют разные системы дат по умолчанию. Время представляет собой дробную часть значения даты и задается десятичным числом (например, 12:00 представляется как 0,5). Хранение даты и времени в Microsoft Excel.

Примеры

ВРЕМЗНАЧ("2:24") равняется 0,1

ВРЕМЗНАЧ("22 Авг 55 6:35") равняется 0,274305556


ВРЕМЯ

См. также

Возвращает время в числовом формате для заданного времени. Время в числовом формате, возвращаемое функцией ВРЕМЯ — это десятичная дробь в интервале от 0 до 0,99999999, представляющая время от 0:00:00 (12:00:00 ночи) до 23:59:59 (11:59:59 вечера).

Синтаксис

ВРЕМЯ(часы;минуты;секунды)

Часы — это число от 0 (нуля) до 23, указывающее час.

Минуты — это число от 0 до 59, указывающее минуты.

Секунды — это число от 0 до 59, указывающее секунды.

Замечания

Microsoft Excel для Windows и Excel для Макинтош используют разные системы дат по умолчанию. Время представляет собой дробную часть значения даты и задается десятичным числом (например, 12:00 представляется как 0,5). Хранение даты и времени в Microsoft Excel.

Примеры

ВРЕМЯ(12; 0; 0) равняется 0,5, что эквивалентно 12:00:00

ВРЕМЯ(16; 48; 10) равняется 0,700115741, что эквивалентно 16:48:10

ТЕКСТ(ВРЕМЯ(23; 18; 14); "ЧЧ:ММ:СС") равняется "23:18:14"


ГОД

См. также

Возвращает год, соответствующий аргументу дата_в_числовом_формате. Год определяется как целое в интервале 1900-9999.

Синтаксис

ГОД(дата_в_числовом_формате)

Дата_в_числовом_формате — это дата, год которой необходимо найти. Даты могут вводиться как текстовые строки в двойных кавычках (например "30.1.1998"), как числа (например 35825 представляет 30 января 1998 г. при использовании системы дат 1900) или как результат других формул или функций (например ДАТАЗНАЧ("30.1.2001")). За более полной информацией по представлению дат числами обратитесь к разделу Замечания.

Замечания

  • Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Microsoft Excel для Windows и Microsoft Excel для Макинтош используют по умолчанию различные системы дат. Для получения более подробной информации, см. справку по функции ТДАТА.

Примеры

ГОД("5.7.1998") равняется 1998

ГОД("1.5.2005") равняется 2005

Если используется система дат 1900:

ГОД(0,007) равняется 1900

ГОД(35981.007) равняется 1998

Если используется система дат 1904:

ГОД(0,007) равняется 1904

ГОД(35981.007) равняется 2002


ДАТА

См. также

Возвращает число, представляющее определенную дату

Более подробная информация об использовании чисел для хранения дат в Microsoft Excel приведена в разделе Замечания.

Синтаксис

ДАТА(год;месяц;день)

Год Аргумент может иметь от одной до четырех цифр. Excel интерпретирует аргумент год в соответствии с используемой системой дат. По умолчанию Excel для Windows использует систему дат 1900, а Excel для Макинтош — систему 1904.

Для системы дат 1900:

  • Если аргумент год находится в диапазоне от 0 (ноль) до 1899 (включительно), Excel прибавляет это значение к числу 1900 для вычисления года. Например, ДАТА(100;1;2) возвращает 2 января 2000 (1900+100) года.

  • Если аргумент год находится в диапазоне от 1900 до 9999 (включительно), Excel использует это значение как год. Например, ДАТА(2000;1;2) возвращает 2 января 2000 года.

  • Если значение аргумента меньше 0 или больше 9999, Excel возвращает значение ошибки #ЧИСЛО!.

Для системы дат 1904:

  • Если аргумент год находится в диапазоне от 4 до 1899 (включительно), Excel прибавляет это значение к числу 1900 для вычисления года. Например, ДАТА(100;1;2) возвращает 2 января 2000 (1900+100) года.

  • Если аргумент год находится в диапазоне от 1904 до 9999 (включительно), Excel использует это значение как год. Например, ДАТА(2000;1;2) возвращает 2 января 2000 года.

  • Если значение аргумента меньше 4 или больше 9999 или находится в диапазоне от 1900 до 1903(включительно), Excel возвращает значение ошибки #ЧИСЛО!

Месяц — число, представляющее месяц года. Если значение аргумента больше 12, введенное число месяцев отсчитывается от первого месяца указанного года. Например, ДАТА(1998;14;2) возвращает число, соответствующее 2 февраля 1999 г.

День — число, представляющее день месяца. Если значение аргумента больше числа дней в указанном месяце, введенное число дней отсчитывается от первого дня месяца. Например, ДАТА(1998;1;35) возвращает число, соответствующее 4 февраля 1998 г.

Замечания

  • Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Функция ДАТА полезна в тех формулах, где год, месяц и день представлены формулами, а не константами.

Примеры

При использовании системы дат 1900 (стандартная для Excel для Windows), ДАТА(1998;1;1) возвращает 35796, что соответствует 1 января 1998 г.

При использовании системы дат 1904 (стандартная для Excel для Макинтош), ДАТА(1998;1;1) возвращает 34334, что соответствует 1 января 1998 г.


ДАТАЗНАЧ

См. также

Возвращает числовой формат даты, представленной в виде текста. Функция ДАТАЗНАЧ используется для преобразования даты из текстового представления в числовой формат.

Более подробная информация об использовании чисел для хранения дат в Microsoft Excel приведена в разделе Замечания.

Синтаксис

ДАТАЗНАЧ(дата_как_текст)

Дата_как_текст — это текст, представляющий дату в формате даты Excel. Например, "1.30.1998" или "30 янв 1998" являются текстовыми строками в кавычках, которые представляют даты. При использовании стандартной системы дат в Excel для Windows аргумент дата_как_текст должен соответствовать дате в интервале от 1 января 1900 до 31 декабря 9999. При использовании стандартной системы дат в Excel для Макинтош диапазон допустимых дат составляет от 1 января 1904 до 31 декабря 9999. Если значение аргумента находится вне диапазона допустимых значений, функция ДАТАЗНАЧ возвращает значение ошибки #ЗНАЧ!.

Если в аргументе дата_как_текст опущен год, то ДАТАЗНАЧ использует текущий год из встроенных часов компьютера. Информация о времени в аргументе дата_как_текст игнорируется.

Замечания

  • Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Excel для Windows и Excel для Macintosh используют по умолчанию различные системы дат. Для получения более подробной информации, см. ТДАТА.

  • Большинство функций автоматически преобразует даты в числовой формат.

Примеры

Следующие примеры используют систему дат 1900:

ДАТАЗНАЧ("22.8.55") равняется 36029

ДАТАЗНАЧ("22 АВГ 1998") равняется 36029

ДАТАЗНАЧ("23.2.02") равняется 37310

Пусть встроенные часы компьютера установлены на 1998 год и используется Система дат 1900:

ДАТАЗНАЧ("5 ИЮЛ") равняется 35981


ДАТАМЕС

См. также

Возвращает в числовом формате дату, отстоящую на заданное количество месяцев вперед или назад от заданной даты (нач_дата). Функция ДАТАМЕС используется для вычисления срока погашения или даты платежа, приходящуюся на тот же день месяца, что и дата выпуска. Более подробная информация об использовании чисел для хранения дат в Microsoft Excel приведена в разделе Замечания.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДАТАМЕС(нач_дата;число_месяцев)

Нач_дата — это начальная дата. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30/1/1998" или "1998/1/30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ("30/1/1998")).

Число_месяцев — это количество месяцев до или после даты нач_дата. Положительное значение аргумента число_месяцев означает будущие даты; отрицательное значение — прошедшие даты.

Замечания

  • Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Если нач_дата не являются допустимой датой, то функция ДАТАМЕС возвращает значение ошибки #ЧИСЛО!.

  • Если число_месяцев не целое число, то оно усекается.

Примеры

ДАТАМЕС("15.1.98";1) равняется 35841 или 15 февраля 1998

ДАТАМЕС(ДАТАЗНАЧ("31.3.98");-1) равняется 35854 или 28 февраля 1998

ДАТАМЕС("9.1.2002";2) равняется 37324 или 9 марта 2002


ДЕНЬ

См. также

Возвращает день в дате, заданной в числовом формате. День возвращается как целое число диапазоне от 1 до 31.

Более подробная информация об использовании чисел для хранения дат в Microsoft Excel приведена в разделе Замечания.

Синтаксис

ДЕНЬ(дата_в_числовом_формате)

Дата_в_числовом_формате — это дата, день которой необходимо найти. Даты могут вводиться как текстовые строки в двойных кавычках (например "30.1.1998"), как числа (например 35825 представляет 30 января 1998 г. при использовании системы дат 1900) или как результат других формул или функций (например ДАТАЗНАЧ("30.1.2001")). За более полной информацией по представлению дат числами обратитесь к справке по функции ТДАТА.

Замечания

  • Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Excel для Windows и Excel для Макинтош используют по умолчанию различные системы дат. Для получения более подробной информации, см. справку по функции ТДАТА.

Примеры

ДЕНЬ("4-Янв") равняется 4

ДЕНЬ("15-Апр-1998") равняется 15

ДЕНЬ("11.8.93") равняется 11

ДЕНЬ("10.10.2001") равняется 10


ДЕНЬНЕД

См. также

Возвращает день недели, соответствующий аргументу дата_в_числовом_формате. День недели определяется как целое в интервале от 1 (воскресенье) до 7 (суббота).

Синтаксис

ДЕНЬНЕД(дата_в_числовом_формате;тип)

Дата_в_числовом_формате — это число, соответствующее дате, день недели которой необходимо найти. Даты могут вводиться как текстовые строки в двойных кавычках (например "30.1.1998"), как числа (например 35825 представляет 30 января 1998 г. при использовании системы дат 1900) или как результат других формул или функций (например ДАТАЗНАЧ("30.1.2001")). За более полной информацией по представлению дат числами обратитесь к разделу Замечания.

Тип — это число, которое определяет тип возвращаемого значения.

Тип | Возвращаемое число
1 или опущен | Число от 1 (воскресенье) до 7 (суббота). Аналогично предыдущей версии Microsoft Excel.
2 | Число от 1 (понедельник) до 7 (воскресенье)
3 | Число от 0 (понедельник) до 6 (воскресенье)

Замечания

  • Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Microsoft Excel для Windows и Microsoft Excel для Макинтош используют по умолчанию различные системы дат. Для получения более подробной информации, см. справку по функции ТДАТА.

  • Можно использовать функцию ТЕКСТ, чтобы преобразовать значение в нужный числовой формат:

    ТЕКСТ("16.4.98"; "ДДДД") равняется "четверг"

Примеры

ДЕНЬНЕД("14.2.98") равняется 7 (суббота)

ДЕНЬНЕД("14.2.98";2) равняется 6 (суббота)

ДЕНЬНЕД("23.2.2003";3) равняется 6 (воскресенье)

Если используется система дат 1900:

ДЕНЬНЕД(35981,007) равняется 1 (воскресенье)

Если используется система дат 1904:

ДЕНЬНЕД(35981,007) равняется 7 (суббота)


ДНЕЙ360

См. также

Возвращает количество дней между двумя датами на основе 360-дневного года (двенадцать 30-дневных месяцев). Эта функция используется для расчета платежей, если бухгалтерия основана на двенадцати 30-дневных месяцах.

Синтаксис

ДНЕЙ360(нач_дата; кон_дата; метод)

Нач_дата и кон_дата — это две даты, количество дней между которыми необходимо вычислить. Если нач_дата соответствует дате более поздней, чем кон_дата, функция возвращает отрицательное значение. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Метод — это логическое значение, которое определяет, какой метод, Европейский или Американский, должен использоваться при вычислениях

Метод | Определение
ЛОЖЬ или опущено | Американский метод (NASD). Если начальная дата является 31-м числом месяца, то она полагается равной 30-ому числу того же месяца. Если конечная дата является 31-м числом месяца и начальная дата меньше, чем 30-ое число, то конечная дата полагается равной 1-ому числу следующего месяца, в противном случае конечная дата полагается равной 30-ому числу того же месяца.
ИСТИНА | Европейский метод. Начальная и конечная даты, которые приходятся на 31-ое число месяца, полагаются равными 30-ому числу того же месяца.

Совет Для определения числа дней между двумя датами в обычном (365- или 366-дневном) году просто вычтите из конечной даты начальную дату — например, ="31/12/1998"-"1/1/1998" равняется 364.

Замечания

Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

Пример

ДНЕЙ360("30.1.1998";"2.1.1998") равняется 1

Если ячейка D10 содержит дату 30.1.98, а ячейка D11 содержит дату 1.2.98, то:

ДНЕЙ360(D10;D11) равняется 1


ДОЛЯГОДА

См. также

Возвращает долю года, которую составляет количество дней между двумя датами (начальной и конечной). Функция ДОЛЯГОДА служит для определения доли годовых гонораров или обязательств, приходящихся на указанный период.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДОЛЯГОДА(нач_дата;кон_дата;базис)

Нач_дата — это начальная дата. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30/1/1998" или "1998/1/30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ("30/1/1998")).

Кон_дата — это дата, которая представляет конечную дату.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Все аргументы усекаются до целых.

  • Если нач_дата или кон_дата не являются допустимой датой, то функция ДОЛЯГОДА возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция то функция ДОЛЯГОДА возвращает значение ошибки #ЧИСЛО!.

Примеры

ДОЛЯГОДА("01.01.98";"30.06.98";2) равняется 0,5

ДОЛЯГОДА("01.01.98";"30.06.98";0) равняется 0,497222

ДОЛЯГОДА("01.01.2001";"27.09.2001") равняется 0,67222


КОНМЕСЯЦА

См. также

Возвращает числовой формат последнего дня месяца, отстоящего на указанное количество месяцев от даты нач_дата. Функция КОНМЕСЯЦА используется для вычисления даты вступления в силу или даты платежа, которая приходится на конец месяца.

Более подробная информация об использовании чисел для хранения дат в Microsoft Excel приведена в разделе Замечания.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

КОНМЕСЯЦА(нач_дата; число_месяцев)

Нач_дата — это начальная дата. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30/1/1998" или "1998/1/30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ("30/1/1998")).

Число_месяцев — это количество месяцев до или после даты нач_дата. Положительное значение аргумента число_месяцев означает будущие даты; отрицательное значение — прошедшие даты.

Замечания

  • Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Если нач_дата не является допустимой датой в числовом формате, то КОНМЕСЯЦА возвращает значение ошибки #ЧИСЛО!.

  • Если число_месяцев не целое, то производится усечение.

  • Если нач_дата плюс число_месяцев дают недопустимую дату в числовом формате, то КОНМЕСЯЦА возвращает значение ошибки #ЧИСЛО!.

Примеры

КОНМЕСЯЦА("1.1.98";1) равняется 35854 или 28 февраля 1998

КОНМЕСЯЦА("1.1.98";-1) равняется 35795 или 31 декабря 1997

КОНМЕСЯЦА("30.1.2000",3) равняется 36646 или 30 апреля 2000


МЕСЯЦ

См. также

Возвращает месяц в дате, заданной в числовом формате. Месяц возвращается как целое число диапазоне от 1 (январь) до 12 (декабрь).

Более подробная информация об использовании чисел для хранения дат в Microsoft Excel приведена в разделе Замечания.

Синтаксис

МЕСЯЦ(дата_в_числовом_формате)

Дата_в_числовом_формате — это дата, месяц которой необходимо найти. Даты могут вводиться как текстовые строки в двойных кавычках (например "30.1.1998"), как числа (например 35825 представляет 30 января 1998 г. при использовании системы дат 1900) или как результат других формул или функций (например ДАТАЗНАЧ("30.1.2001")).

Замечания

  • Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Excel для Windows и Microsoft Excel для Макинтош используют по умолчанию различные системы дат. Для получения более подробной информации, см. справку по функции ТДАТА.

Примеры

МЕСЯЦ("6-Май") равняется 5

МЕСЯЦ(35795) равняется 12

МЕСЯЦ(35796) равняется 1

МЕСЯЦ("1.4.2004") равняется 4


МИНУТЫ

См. также

Возвращает минуты, соответствующие аргументу время_в_числовом_формате. Минуты определяются как целое в интервале от 0 до 59.

Синтаксис

МИНУТЫ(время_в_числовом_формате)

Время_в_числовом_формате — это время, для которого нужно выделить минуты. Время может быть задано текстовой строкой в кавычках (например "18:45"), десятичным числом (например 0,78125 — соответствует 18:45) или результатом других формул или функций (например ВРЕМЯЗНАЧ("18:45")).

Замечания

Microsoft Excel для Windows и Microsoft Excel для Макинтош используют разные системы дат по умолчанию. Время представляет собой дробную часть значения даты и задается десятичным числом (например, 12:00 представляется как 0,5). Хранение даты и времени в Microsoft Excel.

Примеры

МИНУТЫ("16:48:00") равняется 48

МИНУТЫ(0,01) равняется 14

МИНУТЫ(4,02) равняется 28


НОМНЕДЕЛИ

См. также

Возвращает число, которое указывает, на какую неделю года приходится указанная дата.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

НОМНЕДЕЛИ(дата_в_числовом_формате;начало_недели)

Дата_в_числовом_формате — это дата, относящаяся к неделе. Более подробная информация об использовании чисел для хранения дат в Microsoft Excel приведена в разделе Замечания.

Начало_недели — это число, которое определяет, с какого дня начинается неделя. По умолчанию 1.

Начало_недели | Первым днем недели считается
1 | Воскресенье. Дни недели нумеруются от 1 до 7.
2 | Понедельник. Дни недели нумеруются от 1 до 7.

Замечания

Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Методы хранения даты и времени в Microsoft Excel.

Примеры

Если дата — это 10 января 1999 года, воскресенье, то

НОМНЕДЕЛИ("10.1.1999";1) равняется 3

НОМНЕДЕЛИ("10.1.1999";2) равняется 2

НОМНЕДЕЛИ("31.8.2005") равняется 36


РАБДЕНЬ

См. также

Возвращает число, представляющее дату, отстоящую на заданное количество рабочих дней вперед или назад от даты нач_дата. Рабочими днями не считаются выходные дни и дни, определенные как праздничные. Функция РАБДЕНЬ используется, чтобы исключить выходные дни или праздники при вычислении дат платежей, ожидаемых дат доставки или количества фактически отработанных дней. Чтобы отобразить число в виде даты, выберите команду Ячейки меню Формат, выберите Дата в списке Числовые форматы, а затем выберите формат даты в поле Тип.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

РАБДЕНЬ(нач_дата;количество_дней;праздники)

Нач_дата — это начальная дата. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30/1/1998" или "1998/1/30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ("30/1/1998")).

Количество_дней - это количество не выходных и не праздничных дней до или после нач_дата. Положительное значение аргумента количество_дней означает будущую дату; отрицательное значение — прошедшую дату.

Праздники — это необязательный список из одной или нескольких дат, которые требуется исключить из рабочего календаря, например государственные праздники. Список может представлять собой группу ячеек или массив чисел, являющихся датами. Массивы констант. Более подробная информация об использовании чисел для хранения дат в Microsoft Excel приведена в разделе Замечания.

Замечания

  • Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Если нач_дата не является допустимой датой в числовом формате, то функция РАБДЕНЬ возвращает значение ошибки #ЧИСЛО!.

  • Если нач_дата плюс количество_дней не является допустимой датой, то функция РАБДЕНЬ возвращает значение ошибки #ЧИСЛО!.

  • Если количество_дней не целое, то оно усекается.

Примеры

РАБДЕНЬ(ДАТАЗНАЧ("3.1.1998");5) равняется 35804 или 9 февраля 1998.

Если 7 и 8 января 1998 года являются праздниками, то:
РАБДЕНЬ(ДАТАЗНАЧ("03.01.91");5;{35802,35803}) равняется 35808 или 13.01.91


РАЗНДАТ

См. также

Вычисляет число дней, месяцев и лет между двумя датами. Эта функция обеспечивает совместимость с Lotus 1-2-3.

Синтаксис

РАЗНДАТ(нач_дата;кон_дата;единица)

Нач_дата — это дата, представляющая начало периода. Даты могут вводиться как текстовые строки в двойных кавычках (например "30.1.2001"), как числа (например 39921 представляет 30 января 2001 г. апри использовании системы дат 1900) или как результат других формул или функций (например ДАТАЗНАЧ("30.1.2001")). За более полной информацией по представлению дат числами обратитесь к справке по функции ТДАТА.

Кон_дата — дата, представляющая конец периода.

Единица — это тип возвращаемой информации.

Единица | Возвращаемое значение
"Y" | Количество полных лет в указанном периоде.
"M" | Количество полных месяцев в указанном периоде.
"D" | Количество дней в периоде.
"MD" | Разница в днях между нач_дата и кон_дата. Месяцы и годы в датах игнорируются.
"YM" | Разница в месяцах между нач_дата и кон_дата. Дни и годы в датах игнорируются.
"YD" | Разница в днях между нач_дата и кон_дата. Годы в датах игнорируются.

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Excel для Windows и Excel для Макинтош используют по умолчанию различные системы дат. Для получения более подробной информации, см. справку по функции ТДАТА.

Примеры

РАЗНДАТ("1.1.2001";"1.1.2003";"Y") равняется 2 — в периоде два полных года.

РАЗНДАТ("6.1.2001";"15.8.2002";"D") равняется 440 или 440 дней между 1 июня 2001 и 15 августа 2002.

РАЗНДАТ("6.1.2001";"15.8.2002";"YD") равняется 75, или 75 дней между 1 июня и 15 августа, годы в датах проигнорированы.

РАЗНДАТ("6.1.2001";"15.8.2002";"MD") равняется 14, разность между 1 и 15 — днем нач_дата и днем кон_дата — месяцы и годы в датах проигнорированы.


СЕГОДНЯ

См. также

Возвращает текущую дату в числовом формате. Числовой формат даты - это код дата-время, используемый в Microsoft Excel для вычислений с датами и периодами времени. Для получения более подробной информации о числовом формате даты см. справку по функции ТДАТА.

Синтаксис

СЕГОДНЯ( )


СЕКУНДЫ

См. также

Возвращает секунды, соответствующие аргументу время_в_числовом_формате. Секунды определяются как целое в интервале от 0 до 59.

Синтаксис

СЕКУНДЫ(время_в_числовом_формате)

Время_в_числовом_формате — это время, для которого нужно выделить секунды. Время может быть задано текстовой строкой в кавычках (например "18:45"), десятичным числом (например 0,78125 — соответствует 18:45) или результатом других формул или функций (например ВРЕМЯЗНАЧ("18:45")).

Замечания

Microsoft Excel для Windows и Excel для Макинтош используют разные системы дат по умолчанию. Время представляет собой дробную часть значения даты и задается десятичным числом (например, 12:00 представляется как 0,5). Хранение даты и времени в Microsoft Excel.

Примеры

СЕКУНДЫ("16:48:18") равняется 18

СЕКУНДЫ(0,01) равняется 24

СЕКУНДЫ(4,02) равняется 48


ТДАТА

См. также

Возвращает текущую дату и время в числовом формате.

Синтаксис

ТДАТА( )

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Microsoft Excel для Windows и Microsoft Excel для Макинтош используют различные системы дат по умолчанию. Excel для Windows использует систему дат 1900, в которой дата в числовом формате соответствует дате в интервале от 1 января 1900 года до 31 декабря 9999 года. Excel для Макинтош использует систему дат 1904, в которой дата в числовом формате соответствует дате в интервале от 1 января 1904 года до 31 декабря 9999 года.

  • В числовом формате даты цифры справа от десятичной запятой представляют время; цифры слева от десятичной запятой представляют дату. Например, в системе дат 1900, дата в числовом формате 367,5 представляет код даты и времени: соответствующий 12 часам дня 1 января 1901 года.

  • Чтобы изменить систему дат, установите или снимите флажок система дат 1904 на вкладке Вычисления в пункте Параметры (меню Сервис).

  • При открытии документа, подготовленного на другой аппаратной платформе, смена системы дат происходит автоматически. Например, при открытии в Excel для Windows документа, созданного в Excel для Макинтош, параметр система дат 1904 будет выбран автоматически.

  • Функция ТДАТА меняет свое значение только при расчете листа Excel или при выполнении макроса, содержащего эту функцию. Значение этой функции не обновляется непрерывно.

Примеры

Если используется система дат 1900 и встроенные часы компьютера установлены на 12:30:00 1 января 1987 года, то:

ТДАТА() равняется 31778,52083

Десять минут спустя:

ТДАТА() равняется 31778,52778


ЧАС

См. также

Возвращает час, соответствующий заданному времени в числовом формате. Час определяется как целое в интервале от 0 до 23.

Синтаксис

ЧАС(время_в_числовом_формате)

Время_в_числовом_формате — это время, для которого нужно выделить часы. Время может быть задано текстовой строкой в кавычках (например "18:45"), десятичным числом (например 0,78125 — соответствует 18:45) или результатом других формул или функций (например ВРЕМЯЗНАЧ("18:45")).

Замечания

Microsoft Excel для Windows и Excel для Макинтош используют разные системы дат по умолчанию. Время представляет собой дробную часть значения даты и задается десятичным числом (например, 12:00 представляется как 0,5). Хранение даты и времени в Microsoft Excel.

Примеры

ЧАС(0,7) равняется 16

ЧАС(29747,7) равняется 16

ЧАС("15:30:30") равняется 15


ЧИСТРАБДНИ

См. также

Возвращает количество рабочих дней между нач_дата и кон_дата. Праздники и выходные в это число не включаются. Функцию ЧИСТРАБДНИ можно использовать для вычисления оплаты работника на основе количества дней, отработанных в указанный период.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЧИСТРАБДНИ(нач_дата;кон_дата;праздники)

Нач_дата — это начальная дата. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30/1/1998" или "1998/1/30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ("30/1/1998")).

Кон_дата — это дата, которая представляет конечную дату.

Праздники — это необязательный список из одной или нескольких дат, которые требуется исключить из рабочего календаря, например государственные праздники. Список может представлять собой группу ячеек или массив чисел, являющихся датами. Массивы констант. Более подробная информация об использовании чисел для хранения дат в Microsoft Excel приведена в разделе Замечания.

Замечания

  • Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Если любой из аргументов не является допустимой датой, то функция ЧИСТРАБДНИ возвращает значение ошибки #ЧИСЛО!.

Примеры

Проект был начат 1 февраля 1999 и завершен 1 апреля 1999. В приведенном примере рассчитывается число рабочих дней во время выполнения проекта. 8 марта 1999 года является праздником и исключается из подсчета.

ЧИСТРАБДНИ("1.2.1999";"1.4.1999";"8.3.1999") равняется 43

В следующем примере рассчитывается число рабочих дней в проекте, продолжающемся с 1 октября 1999 по 15 февраля 2000; дни с 31 декабря 1999 по 2 января 2000 исключены из рассмотрения.

ЧИСТРАБДНИ("1.10.1999";
"15.2.2000",{"31.12.1999","2.1.2000"}) равняется 97

Следующий пример вычисляет число рабочих дней с 1 марта 2002 г. по 31 марта 2002 г. включительно, исключая 8 марта 2002 г.

ЧИСТРАБДНИ("1.3.2002","31.3.2002","8.3.2002") равняется 20


 Использование динамического обмена данными (DDE) с Microsoft Query

Использование динамического обмена данными (DDE) с Microsoft Query

Microsoft Query поддерживает возможность динамического обмена данными(DDE), как вид связи, с помощью которой два приложения обмениваются друг с другом данными. Существует возможность использования методов DDE в Visual Basic for Applications, чтобы организовать взаимный обмен данными между Microsoft Query и другим приложением, например, Microsoft Excel.

Для получения сведений об использовании DDE с Microsoft Query смотрите справочную систему Microsoft Query.

Для получения сведений об установке Microsoft Query нажмите кнопку [image] .


SQL.REQUEST

См. также

Связывается с внешним источником данных и выполняет запрос из рабочего листа. Затем функция SQL.REQUEST возвращает результат в виде массива, при этом не требуется дополнительного программирования. Если эта функция недоступна, следует установить надстройку Microsoft Excel ODBC (XLODBC.XLA).

Синтаксис

SQL.REQUEST(строка_связи;ссылка_на_код_возврата;показ_драйвера;текст_запроса;нужны_имена_столбцов)

Строка_связи содержит необходимую для установления связи информацию, такую как имя источника данных, идентификатор пользователя, пароли. Эта информация требуется используемому драйверу для установления связи, и поэтому должна иметь предусмотренный драйвером формат. В следующей таблице приводятся три примера строки связи для трех драйверов.

Драйвер | Строка_связи
dBASE | DSN=NWind;PWD=test
SQL Server | DSN=MyServer;UID=dbayer;PWD=123;Database=Pubs
ORACLE | DNS=MyOracleDataSource;DBQ=MYSERVER;UID=JohnS;PWD=Sesame

  • Имя источника данных (DSN), указанное в аргументе строка_связи, должно быть определено до того, как делается попытка установить связь.

  • Аргумент строка_связи может быть введен как массив или как строка. Если строка_связи превышает 250 символов, то ее нужно ввести как массив.

  • Если SQL.REQUEST не может получить доступ к данным, используя аргумент строка_связи, то возвращается значение ошибки #Н/Д.

Ссылка_на_код_возврата - это ссылка на ячейку, в которую нужно поместить выполненную строку связи.

  • Аргумент ссылка_на_код_возврата используется, когда нужно, чтобы функция SQL.REQUEST вернула выполненную строку связи.

  • Если ссылка_на_код_возврата опущена, то функция SQL.REQUEST не возвращает выполненную строку связи.

Показ_драйвера указывает, в каких случаях должно появляться диалоговое окно драйвера, и какие параметры доступны. Следует использовать одно из чисел, описанных в следующей таблице. Если показ_драйвера опущен, то функция SQL.REQUEST использует по умолчанию значение 2.

Показ_драйвера | Описание
1 | Диалоговое окно драйвера выводится всегда.
2 | Диалоговое окно драйвера выводится только в том случае, если информации в аргументе строка_связи недостаточно для установления связи. Доступны все параметры диалогового окна.
3 | Диалоговое окно драйвера выводится, только если информации в аргументе строка_связи недостаточно для установления связи. Параметры диалогового окна недоступны, если они не являются необходимыми.
4 | Диалоговое окно драйвера не выводится. Если установление связи неуспешно, то возвращается ошибка.

Текст_запроса - это оператор на языке SQL, который нужно выполнить над источником данных.

  • Если SQL.REQUEST не может выполнить текст_запроса над указанным источником данных, то возвращается значение ошибки #Н/Д.

  • Можно модифицировать запрос, сцепляя несколько ссылок в текст_запроса. В следующем примере, каждый раз, когда меняется ячейка $A$3, функция SQL.REQUEST использует новое значение для модификации запроса.

    "SELECT Name FROM Customers WHERE Balance > "'&$A$3'.

    Microsoft Excel допускает строки длиной до 255 символов. Если текст_запроса превышает эту длину, то следует ввести запрос в вертикальный интервал ячеек и использовать весь интервал как текст_запроса. Значения ячеек сцепляются, с тем чтобы образовать законченный оператор SQL.

Нужны_имена_столбцов - этот аргумент указывает, должны ли имена столбцов возвращаться в качестве первой строки результата. Для этого аргумента следует задать значение ИСТИНА, если нужно, чтобы имена столбцов были первой строкой результата, и следует задать значение ЛОЖЬ, если имена столбцов не нужны. Если нужны_имена_столбцов опущено, то функция SQL.REQUEST не возвращает имен столбцов.

Возвращаемое ЗначЕние

  • Если эта функция успешно завершает все свои действия, то она возвращает массив результатов запроса или число строк, на которые подействовал запрос.

  • Если SQL.REQUEST не может получить доступ к данным, используя аргумент строка_связи, то возвращается значение ошибки #Н/Д.

Замечания

  • Функция SQL.REQUEST может быть введена как массив. Если функция SQL.REQUEST введена как массив, то она возвращает массив, который соответствует данному интервалу.

  • Если интервал ячеек больше, чем результирующее множество, то функция SQL.REQUEST добавляет пустые ячейки к возвращаемому массиву, увеличивая его до нужного размера.

  • Если результирующее множество больше, чем интервал, введенный как массив, то функция SQL.REQUEST возвращает весь полученный массив.

  • Порядок расположения аргументов SQL.REQUEST отличается от порядка аргументов функции SQLRequest в Visual Basic для приложений.

Пример

Предположим, что Вы хотите сделать запрос к базе данных пакета dBASE, которая называется DBASE4. Если ввести следующую формулу в ячейку, то будет возвращен массив результатов запроса, причем в первой строке будут имена столбцов.

SQL.REQUEST("DSN=NWind;DBQ=c:\msquery;FIL=dBASE4", c15, 2,
"Select Custmr_ID; Due_Date from Orders WHERE order_Amt>100"; ИСТИНА)


ВЫЗВАТЬ

См. также

Вызывает процедуру из динамически связываемой библиотеки (DLL) или программный ресурс. Имеются две синтаксические формы этой функции. Синтаксис 1 используется только с предварительно зарегистрированным программным ресурсом, который использует аргументы полученные с помощью функции РЕГИСТРАТОР. Синтаксис 2а и 2б используется для одновременной регистрации и вызова программного ресурса.

Важно! Эта функция предназначена только для опытных пользователей. Некорректное использование функции ВЫЗВАТЬ может привести к ошибкам, которые потребуют перезагрузки компьютера.

Синтаксис 1

Используется с функцией РЕГИСТРАТОР

ВЫЗВАТЬ(идентификатор_регистрации;аргумент1;...)

Синтаксис 2а

Используется отдельно (в Microsoft Excel для Windows)

ВЫЗВАТЬ(имя_модуля;процедура;типы_данных;аргумент1;...)

Синтаксис 2б

Используется отдельно (в Microsoft Excel для Макинтош)

ВЫЗВАТЬ(имя_файла;ресурс;типы_данных;аргумент1;...)

Идентификатор_регистрации — это значение, которое вернула ранее выполненная функция РЕГИСТРАТОР или РЕГИСТРАТОР.ИД.

Аргумент1, ... — это аргументы, которые должны быть переданы процедуре.

Имя_модуля — это текст в кавычках, задающий в Microsoft Excel имя динамически связываемой библиотеки (DLL), которая содержит процедуру.

Имя_файла — это имя файла, содержащего программный ресурс (Microsoft Excel для Макинтош).

Процедура — это текст, задающий имя процедуры из DLL в Microsoft Excel для Windows. Можно использовать порядковый номер функции из оператора EXPORTS в файле определения модуля (.DEF). Порядковый номер не должен задаваться в форме текста.

Ресурс — это имя программного ресурса (Microsoft Excel для Макинтош). Можно использовать идентификационный номер ресурса. Идентификационный номер ресурса не должен быть в форме текста.

Типы_данных — это текст, задающий тип данных возвращаемого значения и типы данных всех аргументов для процедуры из DLL или программного ресурса. Первая буква аргумента типы_данных задает тип возвращаемого значения. Коды, используемые для задания аргумента типы_данных, подробно описаны в разделе справочной системы Использование функций ВЫЗВАТЬ и РЕГИСТРАТОР. Для автономно используемой DLL или программного ресурса (XLL) этот аргумент может быть опущен.

Пример

Синтаксис 1 (32-разрядное приложение Microsoft Excel)

В 32-разрядном Microsoft Excel для Windows 95 приведенная ниже макроформула регистрирует функцию GetTickCount из 32-разрядного Microsoft Windows. Функция GetTickCount возвращает число миллисекунд, прошедших с момента запуска Microsoft Windows.

РЕГИСТРАТОР("Kernel32";"GetTickCount";"J")

Предположим, что функция РЕГИСТРАТОР находится в ячейке A5, тогда после того, как функция GetTickCount будет зарегистрирована, можно использовать функцию ВЫЗВАТЬ, чтобы вернуть число прошедших миллисекунд:

ВЫЗВАТЬ(A5)

Синтаксис 1 (16-разрядное приложение Microsoft Excel)

В 16-разрядном Microsoft Excel для Windows 95 приведенная ниже формула регистрирует функцию GetTickCount из 16-разрядного Microsoft Windows. Функция GetTickCount возвращает число миллисекунд, прошедших с момента запуска Microsoft Windows.

РЕГИСТРАТОР("User";"GetTickCount";"J")

Предположим, что функция РЕГИСТРАТОР находится в ячейке A5, тогда после того, как функция GetTickCount будет зарегистрирована, можно использовать функцию ВЫЗВАТЬ, чтобы вернуть число прошедших миллисекунд:

ВЫЗВАТЬ(A5)

Пример

Синтаксис 2a (32-разрядное приложение Microsoft Excel)

На рабочем листе можно использовать следующую форму функции ВЫЗВАТЬ (синтаксис 2a), чтобы вызвать функцию GetTickCount:

ВЫЗВАТЬ("Kernel32";"GetTickCount";"J!")

Символ ! в аргументе типы_данных заставляет Microsoft Excel вычислять функцию ВЫЗВАТЬ каждый раз, когда рабочий лист пересчитывается. Таким образом, величина прошедшего времени будет обновляться при каждом пересчете рабочего листа.

Синтаксис 2a (16-разрядное приложение Microsoft Excel)

На рабочем листе можно использовать следующую форму функции ВЫЗВАТЬ (синтаксис 2a), чтобы вызвать функцию GetTickCount:

ВЫЗВАТЬ("User";"GetTickCount";"J!")

Символ ! в аргументе типы_данных заставляет Microsoft Excel вычислять функцию ВЫЗВАТЬ каждый раз, когда рабочий лист пересчитывается. Таким образом, величина прошедшего времени будет обновляться при каждом пересчете рабочего листа.

Совет. Можно использовать необязательные аргументы функции РЕГИСТРАТОР, чтобы присвоить функции пользовательское имя. Это имя будет появляться в диалоговом окне Вставка функции и функцию можно будет вызывать в формулах, указывая пользовательское имя. Для получения более подробных сведений см. справку по функции РЕГИСТРАТОР.


РЕГИСТРАТОР.ИД

См. также

Возвращает идентификатор регистрации указанной динамически связываемой библиотеки (DLL) или ранее зарегистрированного программного ресурса. Если DLL или программный ресурс еще не были зарегистрированы, то эта функция регистрирует DLL или программный ресурс и возвращает идентификатор регистрации.

Функция РЕГИСТРАТОР.ИД может быть использована на листах (в противоположность функции РЕГИСТРАТОР), но нельзя задать имя функции и имена аргументов с помощью РЕГИСТРАТОР.ИД.

Для получения более подробной информации о DLL и программных ресурсах см. раздел справочной системы Использование функций ВЫЗВАТЬ и РЕГИСТРАТОР.

Примечание. Поскольку Microsoft Excel для Windows и Microsoft Excel для Макинтош используют различные типы программных ресурсов, функция РЕГИСТРАТОР.ИД имеет несколько различный синтаксис для разных операционных сред.

Синтаксис 1

Microsoft Excel для Windows

РЕГИСТРАТОР.ИД(имя_модуля;процедура;типы_данных)

Синтаксис 2

Microsoft Excel для Макинтош

РЕГИСТРАТОР.ИД(имя_файла;ресурс;типы_данных)

Имя_модуля — это текст, задающий имя DLL, которая содержит функцию в Microsoft Excel для Windows.

Процедура — это текст, задающий имя функции DLL в Microsoft Excel для Windows. Можно также использовать порядковый номер функции из оператора EXPORTS файла определения модуля (.DEF). Порядковый номер не должен быть в текстовой форме.

Типы_данных — это текст, задающий типы данных возвращаемого значения и типы данных всех аргументов функции DLL. Первая буква аргумента типы_данных задает тип возвращаемого значения. Если функция или программный ресурс уже зарегистрированы, то этот аргумент можно опустить.

Имя_файла — это текст, задающий имя файла, содержащего ресурс в Microsoft Excel для Макинтош.

Ресурс — это текст, задающий имя функции в ресурсе в Microsoft Excel для Макинтош. Можно также использовать порядковый номер ресурса. Порядковый номер не должен быть в текстовой форме.

Примеры (32-разрядное приложение Microsoft Excel)

Следующая формула регистрирует функцию GetTickCount из 32-разрядного Microsoft Windows и возвращает регистрационный идентификатор:

РЕГИСТРАТОР.ИД("Kernel32"; "GetTickCount"; "J!")

Допустим, что функция GetTickCount уже зарегистрирована на другом листе с использованием предыдущей формулы, тогда следующая формула вернет регистрационный идентификатор для GetTickCount:

РЕГИСТРАТОР.ИД("Kernel32"; "GetTickCount")

Примеры (16-разрядное приложение Microsoft Excel)

Следующая формула регистрирует функцию GetTickCount из 16-разрядного Microsoft Windows и возвращает регистрационный идентификатор:

РЕГИСТРАТОР.ИД("User"; "GetTickCount"; "J!")

Допустим, что функция GetTickCount уже зарегистрирована на другом листе с использованием предыдущей формулы, тогда следующая формула вернет регистрационный идентификатор для GetTickCount:

РЕГИСТРАТОР.ИД("User"; "GetTickCount")


Использование функций ВЫЗВАТЬ и РЕГИСТРАТОР

Ниже описаны аргументы и типы возвращаемых значений функций ВЫЗВАТЬ, РЕГИСТРАТОР.ИД и РЕГИСТРАТОР. Аргументы и возвращаемые значения зависят от операционной среды, и эти отличия отражены в таблице типов данных.

"Microsoft Excel 97 Developer's Kit" содержит подробную информацию о библиотеках динамической компоновки (DLL) и кодовых ресурсах, интерфейсу программирования приложений (API), форматах файлов и множестве других технических аспектов Microsoft Excel. Он включает также примеры программ и программных средств, которые можно использовать при разработке приложений. "Руководство программиста по Visual Basic для Microsoft Office 2000 (Microsoft Office 2000/Visual Basic Programmer's Guide)" содержит подробную информацию о создании пользовательских приложений с помощью языка Visual Basic для приложений.

Типы данных

В функциях ВЫЗВАТЬ, РЕГИСТРАТОР.ИД и РЕГИСТРАТОР аргумент типы_данных задает типы данных возвращаемых значений и типы данных для всех аргументов функции из динамической библиотеки или кодового ресурса. Первый символ определяет тип данных возвращаемого значения. Оставшиеся символы показывают типы данных всех аргументов. Например, функция DLL, возвращающая число с плавающей запятой и требующая целого числа и числа с плавающей запятой в качестве аргументов, требует в качестве аргумента типы_данных строку "BIB".

Приведенная ниже таблица содержит полный список кодов типов данных, распознаваемых Microsoft Excel, описание каждого типа данных и способ передачи значения, а также типичные объявления типов данных в языке программирования C.

Код | Описание | Передается | Объявление в языке C
A | Логическое значение (ЛОЖЬ = 0), ИСТИНА = 1) | Значение | short int
B | 8-байтное число с плавающей запятой | Значение (Windows) Ссылка (Макинтош) | double (Windows) double * (Макинтош)
C | Строка, заканчивающаяся кодом 0 (максимальная длина строки = 255) | Ссылка | char *
D | Строка со счетчиком байтов (первый байт содержит длину строки, максимальная длина строки = 255 символов) | Ссылка | Unsigned char *
E | 8-байтное число с плавающей запятой | Ссылка | double *
F | Строка, заканчивающаяся кодом 0 (максимальная длина строки = 255 символов) | Ссылка (изменяется на месте) | char *
G | Строка со счетчиком байтов (первый байт содержит длину строки, максимальная длина строки = 255 символов) | Ссылка (изменяется на месте) | unsigned char *
H | 2-байтовое беззнаковое целое | Значение | unsigned short int
I | 2-байтовое целое со знаком | Значение | short int
J | 4-байтовое целое со знаком | Значение | long int
K | Массив | Ссылка | FP *
L | Логическое значение (ЛОЖЬ = 0, ИСТИНА = 1) | Ссылка | short int *
M | 2-байтовое целое со знаком | Ссылка | short int *
N | 4-байтовое целое со знаком | Ссылка | long int *
O | Массив | Ссылка | Передаются три аргумента: unsigned short int * unsigned short int * double [ ]
P | Структура данных Microsoft Excel OPER | Ссылка | OPER *
R | Структура данных Microsoft Excel XLOPER | Ссылка | XLOPER *

Замечания

  • Объявления для языка C основаны на предположении, что компилятор использует по умолчанию 8 байт для хранения чисел с двойной точностью, 2 байта — для коротких целых и 4 — для длинных целых.

  • В среде программирования Microsoft Windows все указатели являются дальними. Например, в Microsoft Windows тип данных D должен быть объявлен как unsigned char far *.

  • Все функции в динамических библиотеках и кодовых ресурсах вызываются, используя соглашения о вызове Pascal. Большинство компиляторов C позволяют использовать соглашения Pascal о вызове, добавив ключевое слово "Pascal" в описание функции, как показано на примере:

    pascal void main (rows,columns,a)

  • Если функция использует для возвращаемого значения тип данных, передаваемый по ссылке, можно передать нулевой указатель как возвращаемое значение. Microsoft Excel воспримет нулевой указатель как значение ошибки #ЧИСЛО!.

Дополнительная информация о типах данных

Раздел содержит подробную информацию о типах данных F, G, K, O, P и R, а также другую информацию об аргументе типы_данных.

Типы данных F и G

При работе с типами данных F и G функция может модифицировать буфер строки, выделенный Microsoft Excel. Если код типа возвращаемого значения — F и G, Microsoft Excel игнорирует значение, возвращаемое функцией. Вместо этого в списке аргументов функции ищется первый соответствующий тип данных (F или G) и рассматривает текущее содержимое выделенного буфера строки как возвращаемое значение. Microsoft Excel выделяет 256 байт для аргумента, поэтому функция может возвращать более длинную строку, чем она была получена.

Тип данных K

Тип данных K использует указатель на структуру FP, имеющую переменную длину. Необходимо следующим образом определить эту структуру в динамической библиотеке или программном ресурсе:

typedef struct _FP
{
    unsigned short int rows;
    unsigned short int columns;
    double array[1];        /* Actually, array[rows][columns] */
} FP;

Объявление double array[1] выделяет память под массив, содержащий всего один элемент. Число элементов в реальном массиве равно числу строк, умноженному на число столбцов.

Тип данных O

Тип данных O может быть использован только как аргумент, но не как возвращаемое значение. Этот тип передает три элемента: указатель на число строк в массиве, указатель на число столбцов в массиве и указатель на двухмерный массив чисел с плавающей запятой.

Вместо возвращения значения функция может модифицировать массив, переданный типом данных O. Для этого можно использовать в качестве аргумента типы_данных ">O". Дополнительная информация приведена ниже в разделе "Изменение на месте — Функции, объявленные как Void"

Тип данных O был создан для прямой совместимости с динамическими библиотеками Fortran, которые передают аргументы по ссылке.

Тип данных P

Тип данных P представляет собой указатель на структуру OPER. Структура OPER содержит 8 байт данных, за которыми следует 2-байтный идентификатор, который определяет тип данных. При работе с типом данных P функция DLL или программный ресурс могут возвращать любой тип данных Microsoft Excel.

Структура OPER определена следующим образом:

typedef struct _oper

{
    union
    {
        double num;
        unsigned char *str;
        unsigned short int bool;
        unsigned short int err;
        struct
        {
            struct _oper *lparray;
            unsigned short int rows;
            unsigned short int columns;
        } array;
    } val;
    unsigned short int type;
} OPER;

Поле type содержит одно из следующих значений.

Type | Описание | Используемое поле в val
1 | Число | num
2 | Строка (первый байт содержит длину строки) | str
4 | Логическое значение | bool
16 | Ошибка: значения ошибок равны: 0#ПУСТО! 7#ДЕЛ/0! 15#ЗНАЧ! 23#ССЫЛ! 29#ИМЯ? 36#ЧИСЛО! 42#Н/Д | err
64 | Массив | array
128 | Пропущенный аргумент |
256 | Пустая ячейка |

Последние два значения могут быть использованы только как аргументы, а не возвращаемые значения. Значение 128 (пропущенный аргумент) передается тогда, когда при вызове аргумент опущен. Значение 256 (пустая ячейка) передается тогда, когда при вызове функции ссылаются на пустую ячейку.

Тип данных R — Вызов функций Microsoft Excel из динамических библиотек

Тип данных R — это указатель на структуру XLOPER, которая является расширенной версией структуры OPER. В Microsoft Excel версии 4.0 и более поздних тип данных R можно использовать для написания динамических библиотек и программных ресурсов, которые вызывают функции Microsoft Excel. Используя структуру XLOPER, функции DLL могут передавать ссылки на лист и осуществлять передачу управления помимо передачи данных. Полное описание типа данных R и интерфейса программирования приложений (API) Microsoft Excel находится за рамками данного раздела. Пакет "Microsoft Excel Developer's Kit" содержит подробную информацию о типе данных R, Microsoft Excel API и многих других технических аспектах Microsoft Excel.

Временные функции и повторные вычисления

Microsoft Excel обычно вычисляет функцию из динамической библиотеки (или программный ресурс) тогда, когда она вводится в ячейку, когда изменяется одна из влияющих ячеек или когда ячейка вычисляется в процессе выполнения макроса. Можно сделать функцию DLL или программный ресурс на листе временными, то есть они будут вычисляться всякий раз, когда пересчитывается лист. Для этого в конец аргумента типы_данных надо добавить восклицательный знак (!).

Например, в Microsoft Excel для Windows приведенная ниже формула будет пересчитываться всякий раз, когда будет пересчитываться лист:

ВЫЗВАТЬ("Kernel32";"GetTickCount";"J!")

Изменение на месте — Функции, объявленные как Void

Можно использовать однозначное число n (от 1 до 9) в качестве типа возвращаемого значения в аргументе типы_данных. Это свидетельствует о необходимости изменить переменную, указанную аргументом номер n в аргументе типы_данных, а не возвращать значение. Этот прием называется также редактирование на месте. n-ый аргумент должен иметь тип, передаваемый по ссылке (C, D, E, F, G, K, L, M, N, O, P, или R). Функция DLL или программный ресурс при работе с языком C должны быть объявлены с ключевым словом "void" (или ключевым словом "procedure" при программировании на Pascal).

Например, функция DLL, которая получает строку, заканчивающуюся символом 0, и два указателя на целые числа в качестве аргументов, может редактировать строку на месте. Используйте "1FMM" в качестве аргумента типы_данных и объявите функцию как "void".

Версии до Microsoft Excel 4.0 используют символ > для изменения первого аргумента на месте; не существует способа изменять любой аргумент кроме первог Символ > эквивалентен n = 1 в Microsoft Excel версии 4.0 и позднее.


Библиография финансовых, статистических и инженерных методов

См. также

Перечисленные ниже книги содержат подробные сведения о финансовых, статистических и инженерных методах.

Abramowitz, Milton, and Irene A. Stegun. Handbook of Mathematical Functions with Formulas, Graphs, and Mathematical Tables. 10th ed. Washington, D.C.: U.S. Government Printing Office, 1972.

Devore, Jay L. Probability and Statistics for Engineering and the Sciences. 4th ed. Belmont, Calif..: Wadsworth, 1991.

Fabozzi, Frank J. The Handbook of Fixed-Income Securities. 3rd ed. Homewood, Ill.: Irwin Professional, 1990.

Hewlett-Packard, HP-12C Owner's Handbook and Problem-Solving Guide. N.p.: Hewlett-Packard, 1981.

Lynch, John J., Jr., and Jan H. Mayle. Standard Securities Calculation Methods, Fixed Income Securities Formulas. New York: Securities Industry Association, 1994.

McCall, Robert B. Fundamental Statistics for the Behavioral Sciences. 6th ed. Belmont, Calif.: Wadsworth, 1994.

Monks, Joseph G. Operations Management: Theory and Problems. 3rd ed. New York: McGraw-Hill, 1987.

Press, W. H., B. P. Flannery, S. A. Teukolsky, and W. T. Vetterling. Numerical Recipes in C: The Art of Scientific Computing. 2nd ed. New York: Cambridge University Press, 1992.

Sokal, Robert R., and F. James Rohlf. Biometry: The Principles and Practice of Statistics in Biological Research. 2nd ed. New York: W. H. Freeman, 1995.

Stigum, Marcia, and John Mann. Money Market Calculations: Yields, Break-Evens, & Arbitrage. 2nd ed. Homewood, Ill.: Irwin Professional, 1989.


БЕССЕЛЬ.I

См. также

Возвращает модифицированную функцию Бесселя, что эквивалентно вычислению функции Бесселя для чисто мнимого аргумента.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

БЕССЕЛЬ.I(x; n)

X - это значение, для которого вычисляется функция.

N - это порядок функции Бесселя. Если n не целое, то производится усечение.

Замечания

  • Если x не число, то БЕССЕЛЬ.I возвращает значение ошибки #ЗНАЧ!.

  • Если n не число, то БЕССЕЛЬ.I возвращает значение ошибки #ЗНАЧ!.

  • Если n < 0, то БЕССЕЛЬ.I возвращает значение ошибки #ЧИСЛО!.

  • Модифицированная функция Бесселя порядка n от переменной x это:

Пример

БЕССЕЛЬ.I(1,5; 1) равняется 0,981666


БЕССЕЛЬ.J

См. также

Возвращает функцию Бесселя.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

БЕССЕЛЬ.J(x; n)

X - это значение, для которого вычисляется функция.

N - это порядок функции Бесселя. Если n не целое, то производится усечение.

Замечания

  • Если x не число, то БЕССЕЛЬ.J возвращает значение ошибки #ЗНАЧ!.

  • Если n не число, то БЕССЕЛЬ.J возвращает значение ошибки #ЗНАЧ!.

  • Если n < 0, то БЕССЕЛЬ.J возвращает значение ошибки #ЧИСЛО!.

  • Функция Бесселя порядка n от переменной x это:

    где:

    это Гамма-функция.

Пример

БЕССЕЛЬ.J(1,9; 2) равняется 0,329926


БЕССЕЛЬ.K

См. также

Возвращает модифицированную функцию Бесселя, что эквивалентно вычислению функции Бесселя для чисто мнимого аргумента.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

БЕССЕЛЬ.K(x; n)

X - это значение, для которого вычисляется функция.

N - это порядок функции. Если n не целое, то производится усечение.

Замечания

  • Если x не число, то БЕССЕЛЬ.K возвращает значение ошибки #ЗНАЧ!.

  • Если n не число, то БЕССЕЛЬ.K возвращает значение ошибки #ЗНАЧ!.

  • Если n < 0, БЕССЕЛЬ.K возвращает значение ошибки #ЧИСЛО!.

  • Модифицированная функция Бесселя порядка n от переменной x это:

    где Jn и Yn являются функциями Бесселя J и Y соответственно.

Пример

БЕССЕЛЬ.K(1,5; 1) равняется 0,277388


БЕССЕЛЬ.Y

См. также

Возвращает функцию Бесселя, которая также называется функцией Вебера или функцией Неймана.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

БЕССЕЛЬ.Y(x; n)

X - это значение, для которого вычисляется функция.

N - это порядок функции. Если n не целое, то производится усечение.

Замечания

  • Если x не число, то БЕССЕЛЬ.Y возвращает значение ошибки #ЗНАЧ!.

  • Если n не число, то БЕССЕЛЬ.Y возвращает значение ошибки #ЗНАЧ!.

  • Если n < 0, БЕССЕЛЬ.Y возвращает значение ошибки #ЧИСЛО!.

  • Функция Бесселя порядка n от переменной x это:

    где:

Пример

БЕССЕЛЬ.Y(2,5; 1) равняется 0,145918


ВОСЬМ.В.ДВ

См. также

Преобразует восьмеричное число в двоичное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ВОСЬМ.В.ДВ(число;разрядность)

Число - это преобразуемое восьмеричное число. Число не должно содержать более 10 символов. Первый значащий бит числа является знаковым битом. Остальные 29 битов являются битами значения. Отрицательные числа записываются в дополнительном коде.

Разрядность - это количество используемых разрядов. Если разрядность опущена, то функция ВОСЬМ.В.ДВ использует минимальное необходимое количество разрядов. Разрядность используется, если нужно приписать к возвращаемому значению ведущие нули.

Замечания

  • Если число отрицательно, то функция ВОСЬМ.В.ДВ игнорирует разрядность и возвращает 10-разрядное двоичное число.

  • Если число отрицательно, то оно не может быть меньше 7777777000, а если число положительно, то оно не может быть больше 777.

  • Если число не является допустимым восьмеричным числом, то функция ВОСЬМ.В.ДВ возвращает значение ошибки #ЧИСЛО!.

  • Если ВОСЬМ.В.ДВ требуется больше символов, чем указанная разрядность, то функция возвращает значение ошибки #ЧИСЛО!.

  • Если разрядность не целое, то производится усечение.

  • Если разрядность не является числом, то функция ВОСЬМ.В.ДВ возвращает значение ошибки #ЗНАЧ!.

  • Если разрядность отрицательна, то функция ВОСЬМ.В.ДВ возвращает значение ошибки #ЧИСЛО!.

Примеры

ВОСЬМ.В.ДВ(3; 3) равняется 011

ВОСЬМ.В.ДВ(7777777000) равняется 1000000000


ВОСЬМ.В.ДЕС

См. также

Преобразует восьмеричное число в десятичное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ВОСЬМ.В.ДЕС(число)

Число - это преобразуемое восьмеричное число. Число не должно содержать более 10 восьмеричных цифр (30 бит). Самый первый бит числа является знаковым битом. Остальные 29 битов являются битами значения. Отрицательные числа записываются в дополнительном коде.

Замечания

Если число не является допустимым восьмеричным числом, то функция ВОСЬМ.В.ДЕС возвращает значение ошибки #ЧИСЛО!.

Примеры

ВОСЬМ.В.ДЕС(54) равняется 44

ВОСЬМ.В.ДЕС(7777777533) равняется -165


ВОСЬМ.В.ШЕСТН

См. также

Преобразует восьмеричное число в шестнадцатеричное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ВОСЬМ.В.ШЕСТН(число;разрядность)

Число - это преобразуемое восьмеричное число. Число не должно содержать более 10 восьмеричных цифр (30 бит). Самый первый бит числа является знаковым битом. Остальные 29 битов являются битами значения. Отрицательные числа записываются в дополнительном коде.

Разрядность - это количество используемых разрядов. Если разрядность опущена, то функция ВОСЬМ.В.ШЕСТН использует минимальное необходимое количество разрядов. Разрядность используется, если нужно приписать к возвращаемому значению ведущие.

Замечания

  • Если число отрицательно, то функция ВОСЬМ.В.ШЕСТН игнорирует разрядность и возвращает 10-разрядное шестнадцатеричное число.

  • Если число не является допустимым восьмеричным числом, то функция ВОСЬМ.В.ШЕСТН возвращает значение ошибки #ЧИСЛО!.

  • Если ВОСЬМ.В.ШЕСТН требуется больше символов, чем указанная разрядность, то она возвращает значение ошибки #ЧИСЛО!.

  • Если разрядность не целое, то производится усечение.

  • Если разрядность не является числом, то функция ВОСЬМ.В.ШЕСТН возвращает значение ошибки #ЗНАЧ!.

  • Если разрядность отрицательна, то функция ВОСЬМ.В.ШЕСТН возвращает значение ошибки #ЧИСЛО!.

Примеры

ВОСЬМ.В.ШЕСТН(100; 4) равняется 0040

ВОСЬМ.В.ШЕСТН(7777777533) равняется FFFFFFFF5B


ДВ.В.ВОСЬМ

См. также

Преобразует двоичное число в восьмеричное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДВ.В.ВОСЬМ(число; разрядность)

Число - это преобразуемое двоичное число. Число не должно содержать более 10 символов (10 бит). Первый значащий бит числа является знаковым битом. Остальные 9 бит являются битами значения. Отрицательные числа записываются в дополнительных кодах.

Разрядность - это допустимое количество символов в записи числа. Если разрядность опущена, то ДВ.В.ВОСЬМ использует минимальное необходимое количество символов. Разрядность используется, чтобы приписать возвращаемому значению ведущие нули.

Замечания

  • Если число не является допустимым двоичным числом или содержит более 10 символов (10 бит), то ДВ.В.ВОСЬМ возвращает значение ошибки #ЧИСЛО!.

  • Если число отрицательно, то ДВ.В.ВОСЬМ игнорирует разрядность и возвращает 10-разрядное восьмеричное число.

  • Если ДВ.В.ВОСЬМ требуется больше символов, чем указанная разрядность, то возвращается значение ошибки #ЧИСЛО!.

  • Если разрядность не целое, то производится усечение.

  • Если разрядность не число, то ДВ.В.ВОСЬМ возвращает значение ошибки #ЗНАЧ!.

  • Если разрядность отрицательна, то ДВ.В.ВОСЬМ возвращает значение ошибки #ЧИСЛО!.

Примеры

ДВ.В.ВОСЬМ(1001; 3) равняется 011

ДВ.В.ВОСЬМ(01100100) равняется 144

ДВ.В.ВОСЬМ(1111111111) равняется 7777777777


ДВ.В.ДЕС

См. также

Преобразует двоичное число в десятичное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДВ.В.ДЕС(число)

Число - это преобразуемое двоичное число. Число не должно содержать более 10 символов (10 бит). Первый значащий бит числа является знаковым битом. Остальные 9 бит являются битами значения. Отрицательные числа записываются в дополнительных кодах.

Замечания

Если число не является допустимым двоичным числом или содержит более 10 символов (10 бит), то ДВ.В.ДЕС возвращает значение ошибки #ЧИСЛО!.

Примеры

ДВ.В.ДЕС(1100100) равняется 100

ДВ.В.ДЕС(1111111111) равняется -1


ДВ.В.ШЕСТН

См. также

Преобразует двоичное число в шестнадцатеричное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДВ.В.ШЕСТН(число; разрядность)

Число - это преобразуемое двоичное число. Число не должно содержать более 10 символов (10 бит). Первый значащий бит числа является знаковым битом. Остальные 9 бит являются битами значения. Отрицательные числа записываются в дополнительных кодах.

Разрядность - это допустимое количество символов в записи числа. Если разрядность опущена, то ДВ.В.ШЕСТН использует минимальное необходимое количество символов. Разрядность используется, чтобы приписать возвращаемому значению ведущие нули.

Замечания

  • Если число не является допустимым двоичным числом или содержит более 10 символов (10 бит), то ДВ.В.ШЕСТН возвращает значение ошибки #ЧИСЛО!.

  • Если число отрицательно, то ДВ.В.ШЕСТН игнорирует разрядность и возвращает 10-разрядное шестнадцатеричное число.

  • Если ДВ.В.ШЕСТН требуется больше символов, чем указанная разрядность, то возвращается значение ошибки #ЧИСЛО!.

  • Если разрядность не целое, то производится усечение.

  • Если разрядность не число, то ДВ.В.ШЕСТН возвращает значение ошибки #ЗНАЧ!.

  • Если разрядность отрицательна, то ДВ.В.ШЕСТН возвращает значение ошибки #ЧИСЛО!.

Примеры

ДВ.В.ШЕСТН(11111011; 4) равняется 00FB

ДВ.В.ШЕСТН(1110) равняется E

ДВ.В.ШЕСТН(1111111111) равняется FFFFFFFFFF


ДЕЛЬТА

См. также

Проверяет равенство двух значений. Возвращает 1, если число1 = число2; возвращает 0 в противном случае. Эта функция используется для фильтрации множества значений. Например, суммируя несколько функций ДЕЛЬТА, можно подсчитать количество равных пар. Эта функция известна также как Дельта-функция Кронекера.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДЕЛЬТА(число1; число2)

Число1 - это первое число.

Число2 - это второе число, если оно опущено, то полагается равным нулю.

Замечания

  • Если аргумент число1 не число, то ДЕЛЬТА возвращает значение ошибки #ЗНАЧ!.

  • Если аргумент число2 не число, то ДЕЛЬТА возвращает значение ошибки #ЗНАЧ!.

Примеры

ДЕЛЬТА(5; 4) равняется 0

ДЕЛЬТА(5; 5) равняется 1

ДЕЛЬТА(0,5; 0) равняется 0


ДЕС.В.ВОСЬМ

См. также

Преобразует десятичное число в восьмеричное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДЕС.В.ВОСЬМ(число; разрядность)

Число - это преобразуемое десятичное число. Если число отрицательно, то разрядность игнорируется и ДЕС.В.ВОСЬМ возвращает 10-разрядное (30 бит) восьмеричное число, в котором самый значащий бит - это знаковый бит. Остальные 29 бит - это биты значения. Отрицательные числа записываются в дополнительных кодах.

Разрядность - это допустимое количество символов в записи числа. Если разрядность опущена, то ДЕС.В.ВОСЬМ использует минимальное необходимое количество символов. Разрядность используется, чтобы приписать возвращаемому значению ведущие нули.

Замечания

  • Если число < -536 870 912 или если число > 536 870 911, то ДЕС.В.ВОСЬМ возвращает значение ошибки #ЧИСЛО!.

  • Если аргумент число числом не является, то ДЕС.В.ВОСЬМ возвращает значение ошибки #ЗНАЧ!.

  • Если ДЕС.В.ВОСЬМ требуется больше символов, чем указанная разрядность, то возвращается значение ошибки #ЧИСЛО!.

  • Если разрядность не целое, то производится усечение.

  • Если разрядность не число, то ДЕС.В.ВОСЬМ возвращает значение ошибки #ЗНАЧ!.

  • Если разрядность отрицательна, то ДЕС.В.ВОСЬМ возвращает значение ошибки #ЧИСЛО!.

Примеры

ДЕС.В.ВОСЬМ(58; 3) равняется 072

ДЕС.В.ВОСЬМ(-100) равняется 7777777634


ДЕС.В.ДВ

См. также

Преобразует десятичное число в двоичное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДЕС.В.ДВ(число; разрядность)

Число - это преобразуемое десятичное число. Если число отрицательно, то разрядность игнорируется и ДЕС.В.ДВ возвращает 10-символьное (10-бит) двоичное число, в котором самый значащий бит - это знаковый бит. Остальные 9 бит являются битами значения. Отрицательные числа записываются в дополнительных кодах.

Разрядность - это допустимое количество символов в записи числа. Если разрядность опущена, то ДЕС.В.ДВ использует минимальное необходимое количество символов. Разрядность используется, чтобы приписать возвращаемому значению ведущие нули.

Замечания

  • Если число < -512 или если число > 511 то, ДЕС.В.ДВ возвращает значение ошибки #ЧИСЛО!.

  • Если аргумент число числом не является, то ДЕС.В.ДВ возвращает значение ошибки #ЗНАЧ!.

  • Если ДЕС.В.ДВ требуется больше символов, чем указанная разрядность, то возвращается значение ошибки #ЧИСЛО!.

  • Если разрядность не целое, то производится усечение.

  • Если разрядность не число, то ДЕС.В.ДВ возвращает значение ошибки #ЗНАЧ!.

  • Если разрядность отрицательна, то ДЕС.В.ДВ возвращает значение ошибки #ЧИСЛО!.

Примеры

ДЕС.В.ДВ(9; 4) равняется 1001

ДЕС.В.ДВ(-100) равняется 1110011100


ДЕС.В.ШЕСТН

См. также

Преобразует десятичное число в шестнадцатеричное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДЕС.В.ШЕСТН(число; разрядность)

Число - это преобразуемое десятичное число. Если число отрицательно, то разрядность игнорируется и ДЕС.В.ШЕСТН возвращает 10-символьное (40-бит) шестнадцатеричное число, в котором старший бит является знаковым битом. Остальные 39 бит являются битами значения. Отрицательные числа записываются в дополнительных кодах.

Разрядность - это допустимое количество символов в записи числа. Если разрядность опущена, то ДЕС.В.ШЕСТН использует минимальное необходимое количество символов. Разрядность используется, чтобы приписать возвращаемому значению ведущие нули.

Замечания

  • Если число < -549 755 813 888 или если число > 549 755 813 887, то ДЕС.В.ШЕСТН возвращает значение ошибки #ЧИСЛО!.

  • Если аргумент число числом не является, то ДЕС.В.ШЕСТН возвращает значение ошибки #ЗНАЧ!.

  • Если ДЕС.В.ШЕСТН требуется больше символов, чем указанная разрядность, то возвращается значение ошибки #ЧИСЛО!.

  • Если разрядность не целое, то производится усечение.

  • Если разрядность не число, то ДЕС.В.ШЕСТН возвращает значение ошибки #ЗНАЧ!.

  • Если разрядность отрицательна, то ДЕС.В.ШЕСТН возвращает значение ошибки #ЧИСЛО!.

Примеры

ДЕС.В.ШЕСТН(100; 4) равняется 0064

ДЕС.В.ШЕСТН(-54) равняется FFFFFFFFCA


ДФОШ

См. также

Возвращает дополнительную функцию ошибки, проинтегрированную от x до ∞ (бесконечность).

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДФОШ(x)

X - это нижний предел интегрирования для ФОШ.

Замечания

  • Если x не число, то ДФОШ возвращает значение ошибки #ЗНАЧ!.

  • Если x отрицательно, то ДФОШ возвращает значение ошибки #ЧИСЛО!.

Пример

ДФОШ(1) равняется 0,1573


КОМПЛЕКСН

См. также

Преобразует коэффициенты при вещественной и мнимой частях комплексного числа в комплексное число в форме x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

КОМПЛЕКСН(действительная_часть;мнимая_часть;мнимая_единица)

Действительная_часть - это действительная часть комплексного числа.

Мнимая_часть - это мнимая часть комплексного числа.

Мнимая_единица - это обозначение мнимой единицы в комплексом числе. Если аргумент мнимая_единица опущен, то предполагается, что он равен "i".

Примечание Все функции работы с комплексными числами допускают обозначение для мнимой единицы "i" или "j", но не "I" или "J". Использование верхнего регистра приводит к получению значения ошибки #ЗНАЧ!. Все функции, которые используют два или больше комплексных числа, требуют, чтобы обозначение мнимой единицы было одно и то же.

Замечания

  • Если действительная_часть не число, то функция КОМПЛЕКСН возвращает значение ошибки #ЗНАЧ!.

  • Если мнимая_часть не число, то функция КОМПЛЕКСН возвращает значение ошибки #ЗНАЧ!.

  • Если мнимая_единица ни "i" ни "j", то функция КОМПЛЕКСН возвращает значение ошибки #ЗНАЧ!.

Примеры

КОМПЛЕКСН(3;4) равняется 3 + 4i

КОМПЛЕКСН(3;4;"j") равняется 3 + 4j

КОМПЛЕКСН(0;1) равняется i

КОМПЛЕКСН(1;0) равняется 1


МНИМ.ABS

См. также

Возвращает абсолютную величину (модуль) комплексного числа в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.ABS(компл_число)

Компл_число - это комплексное число, для которого находится абсолютная величина.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число не представлено в форме x + yi или x + yj, то функция МНИМ.ABS возвращает значение ошибки #ЧИСЛО!.

  • Абсолютная величина комплексного числа определяется следующим образом:

    где:

    z = x + yi

Пример

МНИМ.ABS("5+12i") равняется 13


МНИМ.COS

См. также

Возвращает косинус комплексного числа в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.COS(компл_число)

Компл_число - это комплексное число, для которого определяется косинус.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число не текст, то функция МНИМ.COS возвращает значение ошибки #ЗНАЧ!.

  • Если компл_число не представлено в форме x + yi или x + yj, то функция МНИМ.COS возвращает значение ошибки #ЧИСЛО!.

  • Косинус комплексного числа определяется следующим образом:

Пример

МНИМ.COS("1+i") равняется 0,83373 - 0,988898i


МНИМ.EXP

См. также

Возвращает экспоненту комплексного числа в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.EXP(компл_число)

Компл_число - это комплексное число, для которого определяется экспонента.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число не представлено в форме x + yi или x + yj, то функция МНИМ.EXP возвращает значение ошибки #ЧИСЛО!.

  • Экспонента комплексного числа определяется следующим образом:

Пример

МНИМ.EXP("1+i") равняется 1,468694 + 2,287355i


МНИМ.LN

См. также

Возвращает натуральный логарифм комплексного числа в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.LN(компл_число)

Компл_число - это комплексное число, для которого определяется натуральный логарифм.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число не представлено в форме x + yi или x + yj, то функция МНИМ.LN возвращает значение ошибки #ЧИСЛО!.

  • Натуральный логарифм комплексного числа определяется следующим образом:

    где:

Пример

МНИМ.LN("3+4i") равняется 1,609438 + 0,927295i


МНИМ.LOG10

См. также

Возвращает обычный логарифм (десятичный) комплексного числа, представленного в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.LOG10(компл_число)

Компл_число - это комплексное число, для которого определяется обычный логарифм.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число не представлено в форме x + yi или x + yj, то функция МНИМ.LOG10 возвращает значение ошибки #ЧИСЛО!.

  • Обычный логарифм комплексного числа может быть вычислен через натуральный логарифм следующим образом:

Пример

МНИМ.LOG10("3+4i") равняется 0,69897 + 0,402719i


МНИМ.LOG2

См. также

Возвращает двоичный логарифм комплексного числа в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.LOG2(компл_число)

Компл_число - это комплексное число, для которого определяется двоичный логарифм.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число не представлено в форме x + yi или x + yj, то функция МНИМ.LOG2 возвращает значение ошибки #ЧИСЛО!.

  • Двоичный логарифм комплексного числа может быть вычислен через натуральный логарифм следующим образом:

Пример

МНИМ.LOG2("3+4i") равняется 2,321928 + 1,337804i


МНИМ.SIN

См. также

Возвращает синус комплексного числа в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.SIN(компл_число)

Компл_число - это комплексное число, для которого определяется синус.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число не представлено в форме x + yi или x + yj, то функция МНИМ.SIN возвращает значение ошибки #ЧИСЛО!.

  • Синус комплексного числа определяется следующим образом:

Пример

МНИМ.SIN("3+4i") равняется 3,853738 - 27,016813i


МНИМ.АРГУМЕНТ

См. также

Возвращает значение аргумента комплексного числа Тета, то есть угол, выраженный в радианах, который определяется следующим образом:

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.АРГУМЕНТ(компл_число)

Компл_число — это комплексное число, для которого определяется аргумент Тета.

Замечания

  • Для преобразования коэффициентов при действительной и мнимой части в комплексное число используйте функцию КОМПЛЕКСН.

  • Если компл_число представлено не в форме x + yi или x + yj, то функция МНИМ.АРГУМЕНТ возвращает значение ошибки #ЧИСЛО!.

  • МНИМ.АРГУМЕНТ вычисляется следующим образом:

    где:

    Формула и

    z = x + yi

Пример

МНИМ.АРГУМЕНТ("3+4i") равняется 0,927295


МНИМ.ВЕЩ

См. также

Возвращает коэффициент при вещественной части комплексного числа в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.ВЕЩ(компл_число)

Компл_число - это комплексное число, для которого определяется коэффициент при вещественной (действительной) части.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число не представлено в форме x + yi или x + yj, то функция МНИМ.ВЕЩ возвращает значение ошибки #ЧИСЛО!.

Пример

МНИМ.ВЕЩ("6-9i") равняется 6


МНИМ.ДЕЛ

См. также

Возвращает частное от деления двух комплексных чисел в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.ДЕЛ(компл_число1;компл_число2)

Компл_число1 - это комплексный числитель или делимое.

Компл_число2 - это комплексный знаменатель или делитель.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число1 или компл_число2 не представлено в форме x + yi или x + yj, то функция МНИМ.ДЕЛ возвращает значение ошибки #ЧИСЛО!.

  • Частное двух комплексных чисел определяется следующим образом:

Пример

МНИМ.ДЕЛ("-238+240i";"10+24i") равняется 5 + 12i


МНИМ.КОРЕНЬ

См. также

Возвращает значение квадратного корня комплексного числа в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.КОРЕНЬ(компл_число)

Компл_число - это комплексное число, для которого определяется квадратный корень.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число не представлено в форме x + yi или x + yj, то функция МНИМ.КОРЕНЬ возвращает значение ошибки #ЧИСЛО!.

  • Квадратный корень комплексного числа определяется следующим образом:

    где:

    и:

    и:

Пример

МНИМ.КОРЕНЬ("1+i") равняется 1,098684 + 0,45509i


МНИМ.ПРОИЗВЕД

См. также

Возвращает произведение от 2 до 29 комплексных чисел в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.ПРОИЗВЕД(компл_число1; компл_число2; ...)

Компл_число1, компл_число2 - это от 1 до 29 перемножаемых комплексных чисел.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число1 или компл_число2 не представлено в форме x + yi или x + yj, то функция МНИМ.ПРОИЗВЕД возвращает значение ошибки #ЧИСЛО!.

    Произведение двух комплексных чисел определяется следующим образом:

Примеры

МНИМ.ПРОИЗВЕД("3+4i";"5-3i") равняется 27 + 11i

МНИМ.ПРОИЗВЕД("1+2i";30) равняется 30 + 60i


МНИМ.РАЗН

См. также

Возвращает разность двух комплексных чисел в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.РАЗН(компл_число1;компл_число2)

Компл_число1 - это уменьшаемое комплексное число.

Компл_число2 - это вычитаемое комплексное число.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если любое из комплексных чисел не представлено в форме x + yi или x + yj, то функция МНИМ.РАЗН возвращает значение ошибки #ЧИСЛО!.

  • Разность двух комплексных чисел определяется следующим образом:

Пример

МНИМ.РАЗН("13+4i";"5+3i") равняется 8 + i


МНИМ.СОПРЯЖ

См. также

Возвращает комплексно-сопряженное комплексное число в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.СОПРЯЖ(компл_число)

Компл_число - это комплексное число, для которого определяется сопряженное комплексное число.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число не представлено в форме x + yi или x + yj, то функция МНИМ.СОПРЯЖ возвращает значение ошибки #ЧИСЛО!.

  • Сопряженное комплексное число определяется следующим образом:

Пример

МНИМ.СОПРЯЖ("3+4i") равняется 3 - 4i


МНИМ.СТЕПЕНЬ

См. также

Возвращает комплексное число в формате x + yi или x + yj возведенное в степень.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.СТЕПЕНЬ(компл_число;число)

Компл_число - это комплексное число, возводимое в степень.

Число - это степень, в которую возводится комплексное число.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число не представлено в форме x + yi или x + yj, то функция МНИМ.СТЕПЕНЬ возвращает значение ошибки #ЧИСЛО!.

  • Если аргумент число не является числом, то функция МНИМ.СТЕПЕНЬ возвращает значение ошибки #ЗНАЧ!.

  • Число может быть целым, дробным или отрицательным.

  • Комплексное число возведенное в степень вычисляется следующим образом:

    где:

    и:

    и:

Пример

МНИМ.СТЕПЕНЬ("2+3i"; 3) равняется -46 + 9i


МНИМ.СУММ

См. также

Возвращает сумму двух или более комплексных чисел в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.СУММ(компл_число1;компл_число2;...)

Компл_число1, компл_число2,... - это от 1 до 29 суммируемых комплексных чисел.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если любое из комплексных чисел не представлено в форме x + yi или x + yj, то функция МНИМ.СУММ возвращает значение ошибки #ЧИСЛО!.

  • Сумма двух комплексных чисел определяется следующим образом:

Пример

МНИМ.СУММ("3+4i";"5-3i") равняется 8 + i


МНИМ.ЧАСТЬ

См. также

Возвращает коэффициент при мнимой части комплексного числа в формате x + yi или x + yj.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МНИМ.ЧАСТЬ(компл_число)

Компл_число - это комплексное число, для которого определяется коэффициент при мнимой части.

Замечания

  • Функция КОМПЛЕКСН используется для преобразования коэффициентов при действительной и мнимой части в комплексное число.

  • Если компл_число не представлено в форме x + yi или x + yj, то функция МНИМ.ЧАСТЬ возвращает значение ошибки #ЧИСЛО!.

Примеры

МНИМ.ЧАСТЬ("3+4i") равняется 4

МНИМ.ЧАСТЬ("0-j") равняется -1

МНИМ.ЧАСТЬ(4) равняется 0


ПОРОГ

См. также

Возвращает 1, если число ≥ порог; возвращает 0 в противном случае. Эта функция используется для фильтрации множества значений. Например, суммируя несколько функций ПОРОГ, можно определить количество значений, превосходящих некоторый порог.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ПОРОГ(число; порог)

Число - это проверяемое значение.

Порог - это пороговое значение. Если порог опущен, то ПОРОГ полагает его равным нулю.

Замечания

Если любой из аргументов не число, то ПОРОГ возвращает значение ошибки #ЗНАЧ!.

Примеры

ПОРОГ(5; 4) равняется 1

ПОРОГ(5; 5) равняется 1

ПОРОГ(-4; -5) равняется 1

ПОРОГ(-1; 0) равняется 0


ПРЕОБР

См. также

Преобразовывает число из одной системы мер в другую. Например, ПРЕОБР может перевести таблицу расстояний в милях в таблицу расстояний в километрах.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ПРЕОБР(число;старые_единицы;новые_единицы)

Число — значение в старых единицах измерения, которое нужно преобразовать.

Старые_единицы — единицы измерения для аргумента число.

Новые_единицы — единица измерения результата. ПРЕОБР допускает следующие значения для аргументов старые_единицы и новые_единицы.

Вес и масса | Старые_единицы или новые_единицы
Грамм | "g"
Слаг (slug) | "sg"
Фунт массы (англ.) | "lbm"
U (атомная единица массы) | "u"
Унция (англ.) | "ozm"

Расстояние | Старые_единицы или новые_единицы
Метр | "m"
Уставная миля | "mi"
Морская миля | "Nmi"
Дюйм | "in"
Фут | "ft"
Ярд | "yd"
Ангстрем | "ang"
Пика (1/72 дюйма) | "Pica"

Время | Старые_единицы или новые_единицы
Год | "yr"
День | "day"
Час | "hr"
Минута | "mn"
Секунда | "sec"

Давление | Старые_единицы или новые_единицы
Паскаль | "Pa"
Атмосфера | "atm"
Миллиметр ртутного столба | "mmHg"

Сила | Старые_единицы или новые_единицы
Ньютон | "N"
Дина | "dyn"
Фунт силы | "lbf"

Энергия | Старые_единицы или новые_единицы
Джоуль | "J"
Эрг | "e"
Термодинамическая калория | "c"
IT калория | "cal"
Электрон-вольт | "eV"
Лошадиная сила-час | "HPh"
Ватт-час | "Wh"
Фунт-фут | "flb"
БТЕ (Британская тепловая единица) | "BTU"

Мощность | Старые_единицы или новые_единицы
Лошадиная сила | "HP"
Ватт | "W"

Магнетизм | Старые_единицы или новые_единицы
Тесла | "T"
Гаусс | "ga"

Температура | Старые_единицы или новые_единицы
Градус Цельсия | "C"
Градус Фаренгейта | "F"
Градус Кельвина | "K"

Меры жидкостей | Старые_единицы или новые_единицы
Чайная ложка | "tsp"
Столовая ложка | "tbs"
Унция жидкая | "oz"
Чашка | "cup"
Американская пинта | "pt"
Британская пинта | "uk_pt"
Кварта | "qt"
Галлон | "gal"
Литр | "l"

Указанные ниже сокращенные префиксы могут быть использованы перед любой метрической единицей.

Префикс | Множитель | Сокращение
экза | 1E+18 | "E"
пета | 1E+15 | "P"
тера | 1E+12 | "T"
гига | 1E+09 | "G"
мега | 1E+06 | "M"
кило | 1E+03 | "k"
гекто | 1E+02 | "h"
дека | 1E+01 | "e"
деци | 1E-01 | "d"
санти | 1E-02 | "c"
милли | 1E-03 | "m"
микро | 1E-06 | "u"
нано | 1E-09 | "n"
пико | 1E-12 | "p"
фемто | 1E-15 | "f"
атто | 1E-18 | "a"

Замечания

  • Если входные данные имеют недопустимый тип, то функция ПРЕОБР возвращает значение ошибки #ЗНАЧ!.

  • Если единица измерения не существует, то ПРЕОБР возвращает значение ошибки #Н/Д.

  • Если единица измерения не поддерживает сокращенный префикс, то ПРЕОБР возвращает значение ошибки #Н/Д.

  • Если единицы измерения относятся к разным группам, то ПРЕОБР возвращает значение ошибки #Н/Д.

  • Названия единиц и префиксы учитывают регистр ввода.

Примеры

ПРЕОБР(1,0; "lbm"; "kg") равно 0,453592

ПРЕОБР(68; "F"; "C") равно 20

ПРЕОБР(2.5; "ft"; "sec") равно #Н/Д


ФОШ

См. также

Возвращает функцию ошибки, проинтегрированную от значения аргумента нижний_предел до значения аргумента верхний_предел.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ФОШ(нижний_предел; верхний_предел)

Нижний_предел - это нижний предел интегрирования ФОШ.

Верхний_предел - это верхний предел интегрирования ФОШ. Если верхний_предел опущен, то ФОШ интегрирует от 0 до нижний_предел.

Замечания

  • Если нижний_предел не число, то ФОШ возвращает значение ошибки #ЗНАЧ!.

  • Если нижний_предел отрицателен, то ФОШ возвращает значение ошибки #ЧИСЛО!.

  • Если верхний_предел не число, то ФОШ возвращает значение ошибки #ЗНАЧ!.

  • Если верхний_предел отрицателен, то ФОШ возвращает значение ошибки #ЧИСЛО!.

Примеры

ФОШ(0,74500) равняется 0,70793

ФОШ(1) равняется 0,84270


ШЕСТН.В.ВОСЬМ

См. также

Преобразует шестнадцатеричное число в восьмеричное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ШЕСТН.В.ВОСЬМ(число; разрядность)

Число - это преобразуемое шестнадцатеричное число. Число не может содержать более 10 разрядов. Первый значащий бит числа является знаковым битом. Остальные 39 бит являются битами значения. Отрицательные числа записываются в дополнительных кодах.

Разрядность - это допустимое количество символов в записи числа. Если разрядность опущена, то ШЕСТН.В.ВОСЬМ использует минимальное необходимое количество символов. Разрядность используется, чтобы приписать возвращаемому значению ведущие нули.

Замечания

  • Если число отрицательно, то ШЕСТН.В.ВОСЬМ игнорирует разрядность и возвращает 10-разрядное восьмеричное число.

  • Если число отрицательно, то оно не может быть меньше, чем FFE0000000, а если число положительно, то оно не может быть больше, чем 1FFFFFFF.

  • Если число не является допустимым шестнадцатеричным числом, то ШЕСТН.В.ВОСЬМ возвращает значение ошибки #ЧИСЛО!.

  • Если ШЕСТН.В.ВОСЬМ требуется больше символов, чем указанная разрядность, то возвращается значение ошибки #ЧИСЛО!.

  • Если разрядность не целое, то производится усечение.

  • Если разрядность не число, то ШЕСТН.В.ВОСЬМ возвращает значение ошибки #ЗНАЧ!.

  • Если разрядность отрицательна, то ШЕСТН.В.ВОСЬМ возвращает значение ошибки #ЧИСЛО!.

Примеры

ШЕСТН.В.ВОСЬМ("F"; 3) равняется 017

ШЕСТН.В.ВОСЬМ("3B4E") равняется 35516

ШЕСТН.В.ВОСЬМ("FFFFFFFF00") равняется 7777777400


ШЕСТН.В.ДВ

См. также

Преобразует шестнадцатеричное число в двоичное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ШЕСТН.В.ДВ(число; разрядность)

Число - это преобразуемое шестнадцатеричное число. Число не может содержать более 10 разрядов. Первый значащий бит числа является знаковым битом (40-ой бит справа). Остальные 39 бит являются битами значения. Отрицательные числа записываются в дополнительных кодах.

Разрядность - это допустимое количество символов в записи числа. Если разрядность опущена, то ШЕСТН.В.ДВ использует минимальное необходимое количество символов. Разрядность используется, чтобы приписать возвращаемому значению ведущие нули.

Замечания

  • Если число отрицательно, то ШЕСТН.В.ДВ игнорирует разрядность и возвращает 10-разрядное двоичное число.

  • Если число отрицательно, то оно не может меньше, чем FFFFFFFE00, а если число положительно, оно не может быть больше, чем 1FF.

  • Если число не является допустимым шестнадцатеричным числом, то ШЕСТН.В.ДВ возвращает значение ошибки #ЧИСЛО!.

  • Если ШЕСТН.В.ДВ требуется больше символов, чем указанная разрядность, то возвращается значение ошибки #ЧИСЛО!.

  • Если разрядность не целое, то производится усечение.

  • Если разрядность не число, то ШЕСТН.В.ДВ возвращает значение ошибки #ЗНАЧ!.

  • Если разрядность отрицательна, то ШЕСТН.В.ДВ возвращает значение ошибки #ЧИСЛО!.

Примеры

ШЕСТН.В.ДВ("F"; 8) равняется 00001111

ШЕСТН.В.ДВ("B7") равняется 10110111

ШЕСТН.В.ДВ("FFFFFFFFFF") равняется 1111111111


ШЕСТН.В.ДЕС

См. также

Преобразует шестнадцатеричное число в десятичное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ШЕСТН.В.ДЕС(число)

Число - это преобразуемое шестнадцатеричное число. Число не может содержать более 10 разрядов (40 бит). Первый значащий бит числа является знаковым битом. Остальные 39 бит являются битами значения. Отрицательные числа записываются в дополнительных кодах.

Замечания

Если число не является допустимым шестнадцатеричным числом, то ШЕСТН.В.ДЕС возвращает значение ошибки #ЧИСЛО!.

Примеры

ШЕСТН.В.ДЕС("A5") равняется 165

ШЕСТН.В.ДЕС("FFFFFFFF5B") равняется -165

ШЕСТН.В.ДЕС("3DA408B9") равняется 1034160313


АМГД

См. также

Возвращает годовую амортизацию имущества для указанного периода.

Синтаксис

АМГД(стоимость;остаточная_стоимость;время_эксплуатации;период)

Нач_стоимость - это начальная стоимость имущества.

Ост_стоимость - это стоимость в конце периода амортизации (иногда называется остаточной стоимостью имущества).

Время_эксплуатации - это количество периодов, за которые собственность амортизируется (иногда называется периодом амортизации).

Период - это период (должен быть измерен в тех же единицах, что и время полной амортизации).

Замечания

  • АМГД вычисляется следующим образом:

Примеры

Если Вы купили грузовик за 30 000 руб., который имеет срок эксплуатации 10 лет и остаточную стоимость 7 500 руб., то годовая амортизация за первый год составит:

АМГД(30000;7500;10;1) равняется 4090,91 руб.

Годовая амортизация за десятый год составит:

АМГД(30000;7500;10;10) равняется 409,09 руб.


АМОРУВ

См. также

Возвращает величину амортизации для каждого периода. Эта функция предназначена для французской системы бухгалтерского учета. Если имущество приобретается в середине бухгалтерского периода, то учитывается пропорционально распределенная амортизация.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

АМОРУВ(стоимость;дата_приобретения;первый_период; остаточная_стоимость;период;ставка;базис)

Стоимость — это стоимость имущества.

Дата_приобретения — это дата приобретения имущества.

Первый_период — это дата окончания первого периода.

Остаточная_стоимость — это остаточная стоимость имущества в конце периода амортизации.

Период — это период.

Ставка — это процентная ставка амортизации.

Базис — это используемый способ вычисления дат.

Базис | Система дат
0 | 360 дней (метод NASD)
1 | Фактический
3 | 365 дней в году
4 | 360 дней в году (Европейский метод)

Замечания

Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Методы хранения даты и времени в Microsoft Excel.

Пример

Предположим, что оборудование было куплено 19 августа 1998 года за 2 400 руб. и имеет остаточную стоимость 300 руб. при 15 процентах амортизации. Первый период кончается 31 декабря 1998 года.

АМОРУВ(2400;"19/8/1998";"31/12/1998";300;1;0,15;1) равняется 360 руб.— амортизация за первый период.


АМОРУМ

См. также

Возвращает величину амортизации для каждого периода. Эта функция предназначена для французской системы бухгалтерского учета. Если имущество приобретается в середине бухгалтерского периода, то учитывается пропорционально распределенная амортизация. Эта функция подобна функции АМОРУВ, за тем исключением, что применяемый в вычислениях коэффициент амортизации зависит от периода амортизации имущества.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

АМОРУМ(стоимость;дата_приобретения;первый_период;остаточная_стоимость;период; ставка;базис)

Стоимость — это стоимость имущества.

Дата_приобретения — это дата приобретения имущества.

Первый_период — это дата окончания первого периода.

Остаточная_стоимость — это остаточная стоимость имущества в конце периода амортизации.

Период — это период.

Ставка — это процентная ставка амортизации.

Базис — это используемый способ вычисления дат.

Базис | Система дат
0 | 360 дней (метод NASD)
1 | Фактический
3 | 365 дней в году
4 | 360 дней в году (Европейский метод)

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Эта функция возвращает амортизацию вплоть до последнего периода амортизации или пока суммарная величина амортизации не станет больше разности между начальной стоимостью и остаточной стоимостью имущества.

  • Коэффициенты амортизации:
    Срок эксплуатации | Коэффициент амортизации
    От 3 до 4 лет | 1.5
    От 5 до 6 лет | 2
    Больше 6 лет | 2.5

  • Ставка амортизации вырастет до 50 процентов для предпоследнего периода и до 100 процентов для последнего периода.

  • Если срок эксплуатации находится между 0 (нулем) и 1, 1 и 2, 2 и 3, 4 и 5, то возвращается значение ошибки #ЧИСЛО!.

Пример

Предположим, что оборудование было куплено 19 августа 1998 года за 2 400 руб. и имеет остаточную стоимость 300 руб. при 15 процентах амортизации. Первый период кончается 31 декабря 1998 года.

АМОРУМ(2400;"19/8/1998";"31/12/1998";300;1;0,15;1) равняется 776 руб. — амортизация за первый период.


АМР

См. также

Возвращает величину непосредственной амортизации имущества за один период.

Синтаксис

АМР(стоимость;остаток;период)

Нач_стоимость - это начальная стоимость имущества.

Ост_стоимость - это стоимость в конце периода амортизации (иногда называется остаточной стоимостью имущества).

Время_эксплуатации - это количество периодов, за которые собственность амортизируется (иногда называется периодом амортизации).

Пример

Предположим Вы купили за 30 000 руб. грузовик, который имеет срок эксплуатации 10 лет, после чего оценивается в 7 500 руб. Снижение стоимости для каждого года эксплуатации составит:

АМР(30000; 7500; 10) равняется 2 250 руб.


БЗ

См. также

Возвращает будущее значение вклада на основе периодических постоянных платежей и постоянной процентной ставки.

Синтаксис

БЗ(ставка;кпер;плата;нз;тип)

Для получения более подробной информации об аргументах функции БЗ и более подробной информации о других функциях выплат по ренте, см. справку по функции ПЗ.

Ставка — это процентная ставка за период.

Кпер — это общее число периодов выплат годовой ренты.

Плата — это выплата, производимая в каждый период; это значение не может меняться в течении всего периода выплат. Обычно плата состоит из основного платежа и платежа по процентам, но не включает других налогов и сборов. Если аргумент опущен, должно быть указано значение аргумента нз.

Нз — это текущая стоимость, или общая сумма всех будущих платежей с настоящего момента. Если аргумент нз опущен, то он полагается равным 0. В этом случае должно быть указано значение аргумента плата.

Тип — это число 0 или 1, обозначающее, когда должна производиться выплата. Если аргумент тип опущен, то он полагается равным 0.

Тип | Когда нужно платить
0 | В конце периода
1 | В начале периода

Замечания

  • Убедитесь, что для аргументов ставка и кпер используются согласованные единицы измерения. Если производятся ежемесячные платежи по четырехгодичному займу из расчета 12% годовых, то ставка должна быть 12%/12 , а кпер должно быть 4*12. Если производятся ежегодные платежи по тому же займу, то ставка должна быть 12%, а кпер должно быть 4.

  • Все аргументы, означающие деньги, которые платятся (например, депозитные вклады), представляются отрицательными числами; деньги, которые получены (например, дивиденды), представляются положительными числами.

Примеры

БЗ(0,5%; 10; -200; -500; 1) равняется 2581,40 р.

БЗ(1%; 12; -1000) равняется 12 682,50 р.

БЗ(11%/12; 35; -2000; ; 1) равняется 82 846,25 р.

Предположим, необходимо зарезервировать деньги для специального проекта, который будет осуществлен через год. Предположим, предполагается вложить 1000 рублей под 6% годовых (что составит в месяц 6%/12 или 0,5%) и вкладывать по 100 рублей в начале каждого следующего месяца в течение следующих 12 месяцев. Сколько денег будет на счету в конце 12 месяцев?

БЗ(0,5%; 12; -100; -1000; 1) равняется 2301,40 р.


БЗРАСПИС

См. также

Возвращает будущее значение основного капитала после начисления сложных процентов. Функция БЗРАСПИС используется для вычисления будущего значения инвестиции с переменной процентной ставкой.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

БЗРАСПИС(основной_капитал;ставки)

Основной_капитал - это текущая стоимость инвестиции.

Ставки - это массив применяемых процентных ставок.

Замечания

Значения в аргументе ставки могут быть числами или пустыми ячейками; любые другие значения дают в результате значение ошибки #ЗНАЧ! при работе функции БЗРАСПИС. Пустые ячейки трактуются как нули (нет дохода).

Пример

БЗРАСПИС(1;{0,09;0,11;0,1}) равняется 1,33089


ВНДОХ

См. также

Возвращает внутреннюю скорость оборота для ряда последовательных операций с наличными, представленными числовыми значениями. Объемы операций не обязаны быть одинаковыми, как в случае ренты. Однако они должны происходить через равные промежутки времени, например, ежемесячно или ежегодно. Внутренняя скорость оборота - это процентная ставка дохода, полученного от инвестиции, состоящий из выплат (отрицательные значения) и поступлений (положительные значения), которые происходят в регулярные периоды времени.

Синтаксис

ВНДОХ(значения;прогноз)

Значения - это массив или ссылка на ячейки, содержащие числовые величины, для которых вычисляется внутренняя скорость оборота средств.

  • Значения должны включать по крайней мере одно положительное значение и одно отрицательное значение, для того, чтобы можно было вычислить внутреннюю скорость оборота.

  • ВНДОХ использует порядок значений для интерпретации порядка денежных выплат или поступлений. Убедитесь, что Вы ввели значения выплат и поступлений в правильном порядке.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются.

Прогноз - это величина, о которой предполагается, что она близка к результату ВНДОХ.

  • Microsoft Excel использует метод итераций для вычисления ВНДОХ. Начиная со значения прогноз, функция ВНДОХ выполняет циклические вычисления, пока не получит результат с точностью 0,00001 процента. Если функция ВНДОХ не может получить результат после 20 попыток, то возвращается значение ошибки #ЧИСЛО! .

  • В большинстве случаев нет необходимости задавать прогноз для вычислений с помощью функции ВНДОХ. Если прогноз опущен, то он полагается равным 0,1 (10 процентов).

  • Если ВНДОХ выдает значение ошибки #ЧИСЛО! , или если результат далек от ожидаемого, можно попытаться выполнить вычисления еще раз с другим значением аргумента прогноз.

Замечания

Функция ВНДОХ тесно связана с функцией НПЗ, используемой для вычисления чистого текущего объема вклада. Скорость оборота, вычисляемая ВНДОХ является процентной ставкой, соответствующей 0 (нулевому) чистому текущему объему вклада. Взаимосвязь функций НПЗ и ВНДОХ отражена в следующей формуле:

НПЗ(ВНДОХ(B1:B6),B1:B6) равняется 3.60E-08 [Учитывая точность расчета для функции ВНДОХ, значение 3.60E-08 можно считать 0 (нулевым).]

Примеры

Предположим, что Вы хотите заняться ресторанным бизнесом. Вы оценили первоначальный взнос в 70 000 руб. и ожидаете получить чистый доход в течение пяти лет в следующих размерах: 12 000 руб., 15 000 руб., 18 000 руб., 21 000 руб. и 26 000 руб. Ячейки B1:B6 содержат следующие значения: -70 000, 12 000, 15 000, 18 000, 21 000 и 26 000 соответственно.

Следующая формула вычисляет внутреннюю скорость оборота инвестиции после четырех лет:

ВНДОХ(B1:B5) равняется -2,12 процентам

Внутренняя скорость оборота после пяти лет:

ВНДОХ(B1:B6) равняется 8,66 процентам

Чтобы вычислить внутреннюю скорость оборота после двух лет, придется задать аргумент прогноз:

ВНДОХ(B1:B3;-10%) равняется -44,35 процентам


ДАТАКУПОНДО

См. также

Возвращает число, соответствующее предыдущей дате купона перед датой соглашения. Для просмотра числа в виде даты в меню Формат выберите команду Ячейки, в поле Числовые форматы выберите Дата, а затем выберите требуемый формат в поле Тип. Более подробная информация об использовании чисел для хранения дат в Microsoft Excel приведена в разделе Замечания.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДАТАКУПОНДО(дата_соглашения;дата_вступления_в_силу;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Все аргументы усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не являются допустимой датой, то функция ДАТАКУПОНДО возвращает значение ошибки #ЧИСЛО!.

  • Если периодичность является любым числом, отличным от 1, 2 или 4, то функция ДАТАКУПОНДО возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ДАТАКУПОНДО возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, то функция ДАТАКУПОНДО возвращает значение ошибки #ЧИСЛО!.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 25 января 1998 года
Срок погашения 15 ноября 1999 года
Полугодовые купоны
Фактический базис

Предыдущая дата купона перед датой соглашения (в системе дат 1900) составит:

ДАТАКУПОНДО("25.1.98";"15.11.99";2;1) равняется 35749 или 15 ноября 1997


ДАТАКУПОНПОСЛЕ

См. также

Возвращает число, представляющее следующую дату купона после даты соглашения. Для просмотра числа в виде даты в меню Формат выберите команду Ячейки, в поле Числовые форматы выберите Дата, а затем выберите требуемый формат в поле Тип.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДАТАКУПОНПОСЛЕ(дата_соглашения;дата_вступления_в_силу;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Все аргументы усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не являются допустимой датой, то функция ДАТАКУПОНПОСЛЕ возвращает значение ошибки #ЧИСЛО!.

  • Если периодичность является любым числом, отличным от 1, 2 или 4, то функция ДАТАКУПОНПОСЛЕ возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ДАТАКУПОНПОСЛЕ возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, то функция ДАТАКУПОНПОСЛЕ возвращает значение ошибки #ЧИСЛО!.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 25 января 1998 года
Срок погашения 15 ноября 1999 года
Полугодовые купоны
Фактический базис

Дата следующего купона после даты соглашения (в системе дат 1900) составит:

ДАТАКУПОНПОСЛЕ("25.1.93";"15.11.94";2;1) равняется 35930 или 15 мая 1998


ДДОБ

См. также

Возвращает значение амортизации имущества за данный период, используя метод двойного процента со снижающегося остатка или иной явно указанный метод.

Синтаксис

ДДОБ(стоимость;остаточная_стоимость;время_эксплуатации;период;коэффициент)

Стоимость — это начальная стоимость имущества.

Остаточная_стоимость — это стоимость в конце периода амортизации (иногда называется остаточной стоимостью имущества).

Время_эксплуатации — это количество периодов, за которые собственность амортизируется (иногда называется периодом амортизации).

Период — это период, для которого требуется вычислить амортизацию. Период должен быть измерен в тех же единицах, что и время_эксплуатации.

Коэффициент — это норма снижения балансовой стоимости (амортизации). Если аргумент опущен, то он полагается равным 2 (метод удвоенного процента со снижающегося остатка)

Все пять аргументов должны быть положительными числами.

Замечания

  • Метод двойного процента со снижающегося остатка вычисляет амортизацию, используя увеличенный коэффициент. Амортизация максимальна в первый период, в последующие периоды уменьшается. Функция ДДОБ использует следующую формулу для вычисления амортизации за период:

    ((стоимость - остаточная_стоимость) - суммарная амортизация за предшествующие периоды) * (коэффициент/время_эксплуатации)

  • Если нужно использовать другой метод вычисления амортизации, измените значение аргумента коэффициент.

  • Используйте функцию ПДОБ, если необходимо использовать прямую амортизацию в том случае, когда амортизация превышает вычисленную величину амортизации.

Примеры

Предположим, что предприятие приобрело новую машину. Машина стоит 2 400 руб. и имеет срок службы 10 лет. Остаточная стоимость составляет 300 руб. Следующие примеры показывают амортизацию за несколько периодов. Результаты округляются до двух знаков после запятой.

ДДОБ(2400;300;3650;0;1)) равняется 1,32 руб., амортизация за первый день. Microsoft Excel автоматически предполагает, что коэфф равен 2.

ДДОБ(2400;300;120;0;1) равняется 40,00 руб., амортизация за первый месяц.

ДДОБ(2400;300;10;1;2) равняется 480.00 руб., амортизация за первый год.

ДДОБ(2400;300;10;2;1,5) равняется 306,00 руб., амортизация за второй год при использования коэффициента равного 1,5 (а не метода двойного процента).

ДДОБ(2400;300;10;10) равняется 22.12 руб., амортизация за десятый год. Microsoft Excel автоматически предполагает, что коэффициент равен 2.


ДЛИТ

См. также

Возвращает длительность Макалея для предполагаемой номинальной стоимости 100 руб. Продолжительность определяется как взвешенное среднее текущих значений выплат и является мерой зависимости цены облигации от изменения доходности.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МДЛИТ(дата_соглашения;дата_вступления_в_силу;купон;доход;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Купон — это годовая процентная ставка для купонов по ценным бумагам.

Доход — это годовой доход по ценным бумагам.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу, периодичность и базис усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не являются допустимой датой, то функция ДЛИТ возвращает значение ошибки #ЧИСЛО!.

  • Если купон < 0 или доход < 0, то функция ДЛИТ возвращает значение ошибки #ЧИСЛО!.

  • Если периодичность является любым числом, отличным от 1, 2 или 4, то функция ДЛИТ возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ДЛИТ возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, то функция ДЛИТ возвращает значение ошибки #ЧИСЛО!.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 1 января 1998 года
Срок погашения 1 января 2006 года
8 процентный купон
9,0 процентный доход
Периодичность полугодовая
Фактический базис

Продолжительность (в системе дат 1900) составит:

ДЛИТ("1.1.1998";"1.1.2006";0,08;0,09;2;1) равняется 5,993775


ДНЕЙКУПОН

См. также

Возвращает число дней в периоде купона, который содержит дату соглашения.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДНЕЙКУПОН(дата_соглашения;дата_вступления_в_силу;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например, облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Все аргументы усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не являются допустимой датой, то функция ДНЕЙКУПОН возвращает значение ошибки #ЧИСЛО!.

  • Если периодичность является любым числом, отличным от 1, 2 или 4, то функция ДНЕЙКУПОН возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ДНЕЙКУПОН возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, то функция ДНЕЙКУПОН возвращает значение ошибки #ЧИСЛО!.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 25 января 1998 года
Срок погашения 15 ноября 1999
Полугодовые купоны
Фактический базис

Количество дней в периоде купона, который включает дату соглашения (в системе дат 1900) составит:

ДНЕЙКУПОНДО("25.1.98";"15.11.99";2;1) равняется 181


ДНЕЙКУПОНДО

См. также

Возвращает количество дней от начала действия купона до даты соглашения.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДНЕЙКУПОНДО(дата_соглашения;дата_вступления_в_силу;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Все аргументы усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не являются допустимой датой, то функция ДНЕЙКУПОНДО возвращает значение ошибки #ЧИСЛО!.

  • Если периодичность является любым числом, отличным от 1, 2 или 4, то функция ДНЕЙКУПОНДО возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ДНЕЙКУПОНДО возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, то функция ДНЕЙКУПОНДО возвращает значение ошибки #ЧИСЛО!.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 25 января 1998 года
Срок погашения 15 ноября 1999
Полугодовые купоны
Фактический базис

Количество дней от начала периода купона до срока погашения (в системе дат 1900) составит:

ДНЕЙКУПОНДО("25.1.98";"15.11.99";2;1) равняется 71


ДНЕЙКУПОНПОСЛЕ

См. также

Возвращает число дней от даты соглашения до срока следующего купона.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДНЕЙКУПОНПОСЛЕ(дата_соглашения;дата_вступления_в_силу;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Все аргументы усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не являются допустимой датой, то функция ДНЕЙКУПОНПОСЛЕ возвращает значение ошибки #ЧИСЛО!.

  • Если периодичность является любым числом, отличным от 1, 2 или 4, то функция ДНЕЙКУПОНПОСЛЕ возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ДНЕЙКУПОНПОСЛЕ возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, то функция ДНЕЙКУПОНПОСЛЕ возвращает значение ошибки #ЧИСЛО!.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 25 января 1998 года
Срок погашения 15 ноября 1999 года
Полугодовые купоны
Фактический базис

Количество дней от даты соглашения до даты следующего купона (в системе дат 1900) составит:

ДНЕЙКУПОНДО("25.1.98";"15.11.99";2;1) равняется 110


ДОБ

См. также

Возвращает амортизацию имущества на заданный период, используя метод постоянного учета амортизации.

Синтаксис

ДОБ(нач_стоимость;ост_стоимость;время_эксплуатации;период;месяц)

Нач_стоимость - это начальная стоимость имущества.

Ост_стоимость - это стоимость в конце периода амортизации (иногда называется остаточной стоимостью имущества).

Время_эксплуатации - это количество периодов, за которые собственность амортизируется (иногда называется периодом амортизации).

Период - это период, для которого требуется вычислить амортизацию. Период должен быть измерен в тех же единицах, что и время_эксплуатации.

Месяц - это количество месяцев в первом году. Если аргумент месяц опущен, то предполагается, что он равен 12.

Замечания

Метод постоянного учета амортизации вычисляет амортизацию, используя фиксированную процентную ставку. ДОБ использует следующие формулы для вычисления амортизации за период:

(нач_стоимость - суммарная амортизация за предшествующие периоды) * ставка

где:

ставка = 1 - ((ост_стоимость / нач_стоимость) ^ (1 / время_эксплуатации)), округленное до трех десятичных знаков после запятой

Особым случаем является амортизация за первый и последний периоды. Для первого периода ДОБ использует такую формулу:

нач_стоимость * ставка * месяц / 12

Для последнего периода ДОБ использует такую формулу:

((нач_стоимость - суммарная амортизация за предшествующие периоды) * ставка * (12 - месяц)) / 12

Примеры

Предположим, что предприятие приобрело новое оборудование. Оборудование стоит 1000000 руб. и имеет срок эксплуатации шесть лет. Остаточная стоимость оборудования 100000 руб. Следующие примеры показывают величину амортизации за время эксплуатации оборудования. Результаты округлены до целых.

ДОБ(1000000;100000;6;1;7) равняется 186 083 руб.
ДОБ(1000000;100000;6;2;7) равняется 259 639 руб.
ДОБ(1000000;100000;6;3;7) равняется 176 814 руб.
ДОБ(1000000;100000;6;4;7) равняется 120 411 руб.
ДОБ(1000000;100000;6;5;7) равняется 82 000 руб.
ДОБ(1000000;100000;6;6;7) равняется 55 842 руб.
ДОБ(1000000;100000;6;7;7) равняется 15 845 руб.


ДОХОД

См. также

Возвращает доход от ценных бумаг, который составляет периодические процентные выплаты. Функция ДОХОД используется для вычисления дохода по облигациям.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДОХОД(дата_соглашения;дата_вступления_в_силу;ставка;цена;погашение;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Ставка — это годовая процентная ставка для купонов по ценным бумагам.

Цена — это цена ценных бумаг за 100 руб. номинальной стоимости.

Выкуп — это выкупная цена ценных бумаг за 100 руб. номинальной стоимости.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу, периодичность и базис усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не является допустимой датой, то функция ДОХОД возвращает значение ошибки #ЧИСЛО!.

  • Если ставка < 0, то функция ДОХОД возвращает значение ошибки #ЧИСЛО!.

  • Если цена ≤ 0 или погашение ≤ 0, то функция ДОХОД возвращает значение ошибки #ЧИСЛО!.

  • Если частота — любое число отличное от 1, 2 или 4, то функция то функция ДОХОД возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ДОХОД возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, то функция ДОХОД возвращает значение ошибки #ЧИСЛО!.

  • Если только один или менее периодов купона укладываются до даты погашения, то функция ДОХОД вычисляется следующим образом:

    где:

    A = количество дней от начала периода купона до даты соглашения (накопленные дни).

    DSR = количество дней от даты соглашения до даты погашения.

    E = количество дней в периоде купона.

  • Если до погашения укладывается более одного периода купона, то функция ДОХОД вычисляется итерационным методом (не более 100 итераций). Используется метод Ньютона на основе формулы для функции ЦЕНА. Доход меняется до тех пор, пока вычисляемая цена для данного дохода не станет близкой к значению аргумента цена.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 15 февраля 1999 года
Срок погашения 15 ноября 2007 года
Купон 5,75 процентов
Цена 95,04287 руб.
Цена при погашении 100 руб.
Полугодовая периодичность
Базис 30/360

Доход от облигаций (в системе дат 1900) составит:

ДОХОД("15.2.1999";"15.11.2007";0,0575;95,04287;100;2;0) равняется 0,065 или 6,5 процентам


ДОХОДКЧЕК

См. также

Возвращает доход по казначейскому чеку.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДОХОДКЧЕК(дата_соглашения;дата_вступления_в_силу;цена)

Дата соглашения — это дата соглашения для казначейского чека. Эта дата, более поздняя, чем дата выпуска, когда казначейский чек был продан покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — это срок погашения для казначейского чека. Соответствует дате истечения срока действия чека.

Цена — это цена казначейского чека на 100 руб. номинальной стоимости.

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Дата_соглашения и дата_вступления_в_силу усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не является допустимой датой, то функция ДОХОДКЧЕК возвращает значение ошибки #ЧИСЛО!.

  • Если цена ≤ 0, то функция ДОХОДКЧЕК возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, или если дата_вступления_в_силу более чем на год превосходит дата_соглашения, ДОХОДКЧЕК возвращает значение ошибки #ЧИСЛО!.

  • ДОХОДКЧЕК вычисляется следующим образом:

    где:

    DSM = количество дней от даты соглашения до даты вступления в силу, исключая дату вступления в силу, которая более чем на один календарный год больше даты соглашения.

Пример

Чек казначейства выпущен на следующих условиях:

Дата соглашения 31 марта 1999 года
Срок погашения 1 июня 1999 года
Цена 98,45 руб. на 100 руб. номинальной стоимости

Доход по казначейскому чеку (в системе дат 1900) составит:

ДОХОДКЧЕК("31.3.99";"1.6.99";98,45) равняется 0,091417 или 9,1417 процентам


ДОХОДПЕРВНЕРЕГ

См. также

Возвращает доход по ценным бумагам с нерегулярным (коротким или длинным) первым периодом.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДОХОДПЕРВНЕРЕГ(дата_соглашения;дата_вступления_в_силу;дата_выпуска;первый_купон;ставка;цена;выкуп;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Дата_выпуска — это дата выпуска ценных бумаг.

Первый_купон — это дата первого купона для ценных бумаг.

Ставка — это процентная ставка для ценных бумаг.

Цена — это стоимость ценных бумаг.

Выкуп — это выкупная цена ценных бумаг за 100 р. номинальной стоимости.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу, дата_выпуска, первый_купон и базис усекаются до целых.

  • Если дата_соглашения, дата_вступления_в_силу, дата_выпуска или первый_купон не является допустимой датой, то функция ДОХОДПЕРВНЕРЕГ возвращает значение ошибки #ЧИСЛО!.

  • Если ставка < 0 или цена ≤ 0, то функция ДОХОДПЕРВНЕРЕГ возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ДОХОДПЕРВНЕРЕГ возвращает значение ошибки #ЧИСЛО!.

  • Должны быть выполнены следующие условия, в противном случае функция ДОХОДПЕРВНЕРЕГ возвращает значение ошибки #ЧИСЛО!:

    дата_вступления_в_силу > первый_купон > дата_соглашения > дата_выпуска

  • Microsoft Excel вычисляет функцию ДОХОДПЕРВНЕРЕГ методом итераций. Используется метод Ньютона на основе формулы для функции ЦЕНАПЕРВНЕРЕГ. Доход вычисляется за 100 итераций, до тех пор, пока вычисляемая цена для заданного дохода не станет близкой к значению аргумента цена. Формула, используемая функцией ДОХОДПЕРВНЕРЕГ, описана в справке по функции ЦЕНАПЕРВНЕРЕГ.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 25 января 1999 года
Срок погашения 1 января 2004 года
Дата выпуска 18 января 1999 года
Дата первого купона 15 июля 1999 года
Купон 5,75 процентов
Цена 84,50 р.
Стоимость при погашении 100 р.
Частота полугодовая
Базис 30/360

Доход по ценным бумагам с нерегулярным (длинным или коротким) первым периодом составит:

ДОХОДПЕРВНЕРЕГ("25.1.1999";"1.1.2004";"18.1.1999";"15.7.1999";0,0575;84,50;100;2;0) равняется 0,097581 или 9,76 процентов


ДОХОДПОГАШ

См. также

Возвращает годовой доход от ценных бумаг, который составляет доход в срок вступления в силу.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДОХОДПОГАШ(дата_соглашения;дата_вступления_в_силу;дата_выпуска;ставка;цена;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Дата_выпуска — это дата выпуска ценных бумаг.

Ставка — это процентная ставка дохода по ценным бумагам на дату выпуска.

Цена — это стоимость ценных бумаг за 100 руб. номинальной стоимости.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу, дата_выпуска и базис усекаются до целых.

  • Если дата_соглашения, дата_вступления_в_силу, или дата_выпуска не является допустимой датой, то функция ДОХОДПОГАШ возвращает значение ошибки #ЧИСЛО!.

  • Если ставка < 0 или цена ≤ 0, то функция ДОХОДПОГАШ возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ДОХОДПОГАШ возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, ДОХОДПОГАШ возвращает значение ошибки #ЧИСЛО!.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 15 марта 1999 года
Срок погашения 3 ноября 1999 года
Дата выпуска 8 ноября 1998 года
Полугодовой купон 6,25 процентов
Цена 100,0123 р.
Базис 30/360

Доход (в системе дат 1900) составит:

ДОХОДПОГАШ("15.3.99";"3.11.99";"8.11.98";0,0625;100,0123;0) равняется 0,060954 или 6,0954 процентам


ДОХОДПОСЛНЕРЕГ

См. также

Возвращает доход по ценным бумагам с нерегулярным (коротким или длинным) последним периодом.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДОХОДПОСЛНЕРЕГ(дата_соглашения;дата_вступления_в_силу;последняя_выплата;ставка;цена;выкуп;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Последняя_выплата — это дата последнего купона для ценных бумаг.

Ставка — это процентная ставка для ценных бумаг.

Цена — это стоимость ценных бумаг.

Выкуп — это выкупная цена ценных бумаг за 100 р. номинальной стоимости.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу, последняя_выплата и базис усекаются до целых.

  • Если дата_соглашения, дата_вступления_в_силу или последняя_выплата не является допустимой датой, то функция ДОХОДПОСЛНЕРЕГ возвращает значение ошибки #ЧИСЛО!.

  • Если ставка < 0 или цена ≤ 0, то функция ДОХОДПОСЛНЕРЕГ возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ДОХОДПОСЛНЕРЕГ возвращает значение ошибки #ЧИСЛО!.

  • Должны быть выполнены следующие условия, в противном случае функция ДОХОДПОСЛНЕРЕГ возвращает значение ошибки #ЧИСЛО!:

    дата_вступления_в_силу > дата_соглашения > последняя_выплата

  • ДОХОДПОСЛНЕРЕГ вычисляется следующим образом:

    где:

    Ai = количество накопленных дней для i-ого или последнего квазикупонного периода в нерегулярном периоде, отсчитанное вперед от даты последней выплаты перед погашением.

    DCi = количество дней, сосчитанных для i-ого или последнего квазикупонного периода, разделенное на продолжительность фактического купонного периода.

    NC = количество квазикупонных периодов, укладывающихся в нерегулярный период. Если это число является дробным, то оно округляется с избытком до ближайшего целого.

    NLi = нормальная продолжительность в днях i-ого или последнего квазикупонного периода в нерегулярном купонном периоде.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 20 апреля 1999 года
Срок погашения 15 июня 1999 года
Дата последней выплаты 24 декабря 1998 года
Купон 3,75 процентов
Цена 99,875 р.
Стоимость при погашении 100 р.
Периодичность полугодовая
Базис 30/360

Доход по ценным бумагам с нерегулярным (длинным или коротким) последним периодом составит:

ДОХОДПОСЛНЕРЕГ("20.4.1999";"15.6.1999";"24.12.1998";0,0375;99,875;100;2;0) равняется 0,045192.


ДОХОДСКИДКА

См. также

Возвращает годовой доход по ценным бумагам, на которые сделана скидка.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДОХОДСКИДКА(дата_соглашения;дата_вступления_в_силу;цена;погашение;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Цена — это цена ценных бумаг за 100 руб. номинальной стоимости.

Выкуп — это выкупная цена ценных бумаг за 100 руб. номинальной стоимости.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу и базис усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не является допустимой датой, то функция ДОХОДСКИДКА возвращает значение ошибки #ЧИСЛО!.

  • Если цена ≤ 0 или погашение ≤ 0, то функция ДОХОДСКИДКА возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ДОХОДСКИДКА возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, ДОХОДСКИДКА возвращает значение ошибки #ЧИСЛО!.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 15 февраля 1999 года
Срок погашения 1 марта 1999 года
Цена 99,795 руб.
Цена при погашении 100 руб.
Базис фактический/360

Доход от облигаций (в системе дат 1900) составит:

ДОХОДСКИДКА("15.2.1999";"1.3.1999";99,795;100;2) равняется 0,052823 или 5,2823 процентам


ИНОРМА

См. также

Возвращает процентную ставку для полностью инвестированных ценных бумаг.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ИНОРМА(дата_соглашения;дата_вступления_в_силу;инвестиция;погашение;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Инвестиция — это объем инвестиции в ценные бумаги.

Погашение — это объем средств, которые должны быть получены на дату вступления в силу ценных бумаг.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу и базис усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не является допустимой датой, то функция ИНОРМА возвращает значение ошибки #ЧИСЛО!.

  • Если инвестиция ≤ 0 или погашение ≤ 0, то функция ИНОРМА возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция то функция ИНОРМА возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, то функция ИНОРМА возвращает значение ошибки #ЧИСЛО!.

  • ИНОРМА вычисляется следующим образом:

    где:

    B = число дней в году (зависит от выбранного значения аргумента базис).

    DIM = количество дней от даты соглашения до даты вступления в силу.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 15 февраля 1999 года
Срок погашения 15 мая 1999 года
Инвестиция 1 000 000 р.
Объем погашения 1 014 420 р.
Фактический базис

Норма скидки (в системе дат 1900) составит:

ИНОРМА("15.2.99";"15.5.99";1000000;1014420;2) равняется 0,058328 или 5,8328 процентов


КПЕР

См. также

Возвращает общее количество периодов выплаты для данного вклада на основе периодических постоянных выплат и постоянной процентной ставки.

Синтаксис

КПЕР(ставка;платеж;нз;бз;тип)

Для получения более полного описания смысла аргументов функции КПЕР и для получения более подробной информации о функциях платежей по ссуде см. ПЗ.

Ставка - это процентная ставка за период.

Плата - это выплата, производимая в каждый период; это значение не может меняться в течении всего периода выплат. Обычно плата состоит из основного платежа и платежа по процентам, но не включает других налогов и сборов.

Нз - это текущая стоимость, или общая сумма всех будущих платежей с настоящего момента.

Бз - это будущая стоимость или баланс наличности, который нужно достичь после последней выплаты. Если аргумент бз опущен, то предполагается, что он равен 0 (например, бз для займа равно 0).

Тип - это число 0 или 1, обозначающее, когда должна производиться выплата.

Тип | Когда нужно платить
0 или опущен | В конце периода
1 | В начале периода

Примеры

КПЕР(12%/12; -100; -1000; 10000; 1) равняется 60

КПЕР(1%; -100; -1000; 10000) равняется 60

КПЕР(1%; -100; 1000) равняется 11


МВСД

См. также

Возвращает модифицированную внутреннюю скорость оборота средств для ряда последовательных периодических операций с наличными. Функция МВСД учитывает как стоимость инвестиции, так и доход получаемый от реинвестирования.

Синтаксис

МВСД(значения;ф_ставка;р_ставка)

Значения - это массив или ссылка на ячейки, содержащие числовые величины. Эти числа представляют ряд денежных выплат (отрицательные значения) и поступлений (положительные значения), происходящие в регулярные периоды времени.

  • Аргумент значения должен содержать по крайней мере одно положительное и одно отрицательное значение для того, чтобы можно было вычислить модифицированную внутреннюю скорость оборота. В противном случае функция МВСД возвращает значение ошибки #ДЕЛ/0!.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

Ф_ставка - это норма прибыли, выплачиваемой за деньги, находящиеся в наличном обороте.

Р_ставка - это норма прибыли, получаемой за деньги, находящиеся в наличном обороте при реинвестировании.

Замечания

  • МВСД использует порядок расположения чисел в аргументе значения для определения порядка выплат и поступлений. Убедитесь, что значения выплат и поступлений введены в нужной последовательности и с правильными знаками (положительные значения для получаемых денег и отрицательные значения для выплачиваемых).

  • Если n - это количество чисел в аргументе значения, f - это ф_ставка, а r - это р_ставка, то формула для вычисления функции МВСД будет иметь вид:

Примеры

Предположим, что Вы занимаетесь рыболовным промыслом и только что завершили пятый год работы. Пять лет назад вы взяли 120 000 руб. под 10 процентов годовых для покупки лодки. Ваши годовые уловы принесли прибыль в 39 000 руб., 30 000 руб., 21 000 руб., 37 000 руб. и 46 000 руб. соответственно. За эти годы Вы реинвестировали получаемую прибыль под 12 процентов годовых. Пусть на рабочем листе Ваш заем введен как -120 000 в ячейку B1 и в ячейки B2:B6 введены значения Вашей прибыли за каждый год.

Тогда модифицированная внутренняя скорость оборота за пять лет вычисляется следующим образом:

МВСД(B1:B6; 10%; 12%) равняется 12,61 процентам

Модифицированная внутренняя скорость оборота за три года вычисляется следующим образом:

МВСД(B1:B4; 10%; 12%) равняется -4,80 процентам

Модифицированная внутренняя скорость оборота за пять лет, если значение аргумента р_ставка равно 14%, вычисляется следующим образом:

МВСД(B1:B6; 10%; 14%) равняется 13,48 процентам


МДЛИТ

См. также

Возвращает модифицированную длительность для ценных бумаг с предполагаемой номинальной стоимостью 100 руб.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МДЛИТ(дата_соглашения;дата_вступления_в_силу;купон;доход;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Купон — это годовая процентная ставка для купонов по ценным бумагам.

Доход — это годовой доход по ценным бумагам.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу, периодичность и базис усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не является допустимой датой, то функция МДЛИТ возвращает значение ошибки #ЧИСЛО!.

  • Если доход < 0 или купон < 0, то функция МДЛИТ возвращает значение ошибки #ЧИСЛО!.

  • Если частота — любое число, отличное от 1, 2 или 4, то функция то функция МДЛИТ возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 если базис > 4, то функция МДЛИТ возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, то функция МДЛИТ возвращает значение ошибки #ЧИСЛО!.

  • Модифицированная длительность определяется следующим образом:

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 1 января 1999 года
Срок погашения 1 января 2007 года
8 процентный купон
9,0 процентный доход
Периодичность полугодовая
Фактический базис

Модифицированная длительность (в системе дат 1900) составит:

МДЛИТ("1.1.1999";"1.1.2007";0,08;0,09;2;1) равняется 5,73567


НАКОПДОХОД

См. также

Возвращает накопленный доход по ценным бумагам с периодической выплатой процентов.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

НАКОПДОХОД(дата_выпуска;дата_первой_выплаты;дата_соглашения;ставка;номинал;периодичность;базис)

Дата_выпуска — это дата выпуска ценных бумаг. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30/1/1998" или "1998/1/30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900), либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ("30/1/1998")).

Дата_первой_выплаты — это дата первой выплаты по ценным бумагам.

Дата_соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю.

Ставка — это годовая процентная ставка для купонов по ценным бумагам.

Номинал — это номинальная стоимость ценных бумаг. Если номинал опущен, то функция НАКОПДОХОД использует значение 1000 руб.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Методы хранения даты и времени в Microsoft Excel.

  • Дата_выпуска, дата_первой_выплаты, дата_соглашения, периодичность и базис усекаются до целых.

  • Если дата_выпуска, дата_первой_выплаты или дата_соглашения не являются допустимой датой, то функция НАКОПДОХОД возвращает значение ошибки #ЧИСЛО!.

  • Если ставка ≤ 0 или если номинал ≤ 0, то функция НАКОПДОХОД возвращает значение ошибки #ЧИСЛО!.

  • Если периодичность является любым числом, отличным от 1, 2 или 4, то функция НАКОПДОХОД возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция НАКОПДОХОД возвращает значение ошибки #ЧИСЛО!.

  • Если дата_выпуска ≥ дата_соглашения, НАКОПДОХОД возвращает значение ошибки #ЧИСЛО!.

  • НАКОПДОХОД вычисляется следующим образом:

    где:

    Ai = число накопленных дней для i-ого квазикупонного периода в оставшемся периоде выплат.

    NC = число квазикупонных периодов, которые укладываются в оставшийся период. Если это число содержит дробную часть, то оно округляется с избытком до следующего целого.

    Nli = нормальная продолжительность в днях i-ого квазикупонного периода в оставшемся периоде.

Пример

Долговое обязательство казначейства выпускается на следующих условиях:

Дата выпуска 28 февраля 1998 года
Дата соглашения 1 мая 1998 года
Дата первой выплаты 31 августа 1998 года
Ставка 10,0%
Номинал 1000 руб.
Периодичность выплат полугодовая
Базис для вычисления дней 30/360

Накопленный доход (в системе дат 1900) составит:

НАКОПДОХОД("28.2.93";"31.8.93";"1.5.93";0,1;1000;2;0) равняется 16,94444.


НАКОПДОХОДПОГАШ

См. также

Возвращает накопленный доход по ценным бумагам, процент по которым выплачивается в срок погашения.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

НАКОПДОХОДПОГАШ(дата_выпуска;дата_вступления_в_силу;ставка;номинал;базис)

Дата_выпуска — это дата выпуска ценных бумаг. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30/1/1998" или "1998/1/30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900), либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30/1/1998”)).

Дата_вступления_в_силу — это срок погашения ценных бумаг.

Ставка - это годовая процентная ставка для купонов по ценным бумагам.

Номинал - это номинальная стоимость ценных бумаг. Если номинал опущен, то функция НАКОПДОХОДПОГАШ использует значение 1000 руб.

Базис - это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Методы хранения даты и времени в Microsoft Excel.

  • Дата_выпуска, дата_вступления_в_силу и базис усекаются до целых.

  • Если дата_выпуска или дата_вступления_в_силу не являются допустимой датой, то функция НАКОПДОХОДПОГАШ возвращает значение ошибки #ЧИСЛО!.

  • Если ставка ≤ 0 или номинал ≤ 0, то функция НАКОПДОХОДПОГАШ возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция НАКОПДОХОДПОГАШ возвращает значение ошибки #ЧИСЛО!.

  • Если дата_выпуска ≥ дата_вступления_в_силу, то функция НАКОПДОХОДПОГАШ возвращает значение ошибки #ЧИСЛО!.

  • НАКОПДОХОДПОГАШ вычисляется следующим образом:

    где:

    A = Число накопленных дней в соответствии с месячным базисом. Для вычисления дохода на дату погашения используется число дней между датой выпуска и сроком погашения.

    D = Базис.

Пример

Вексель выдан на следующих условиях:

Дата выпуска 1 апреля 1998 года
Срок погашения 15 июня 1998 года
Ставка 10,0 процентов
Номинал 1000 руб.
Базис Фактический/365

Накопленный доход (в системе дат 1900) составит:

НАКОПДОХОДПОГАШ("1.4.93";"15.6.93";0,1;1000;3) равняется 20,54795


НОМИНАЛ

См. также

Возвращает номинальную годовую процентную ставку, если известны фактическая ставка и число периодов, составляющих год.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

НОМИНАЛ(фактическая_ставка;кпер_год)

Фактическая_ставка - это фактическая процентная ставка.

Периодов_в_году - это количество периодов, составляющих год.

Замечания

  • Аргумент периодов_в_году усекается до целого.

  • Если любой из аргументов не является числом, то функция НОМИНАЛ возвращает значение ошибки #ЗНАЧ!.

  • Если фактическая_ставка 0 или если кпер_год < 1, то функция НОМИНАЛ возвращает значение ошибки #ЧИСЛО!.

  • Функция НОМИНАЛ связана с функцией ЭФФЕКТ как показано в следующем уравнении:

Пример

НОМИНАЛ(5,3543%;4) равняется 0,0525 или 5,25 процентов


НОРМА

См. также

Возвращает процентную ставку за один период при выплате ренты. Функция НОРМА вычисляется методом последовательного приближения и может не иметь решения или иметь несколько решений. Если после 20 итераций погрешность определения ставки превышает 0,0000001, то функция НОРМА возвращает значение ошибки #ЧИСЛО!.

Синтаксис

НОРМА(кпер;выплата;нз;бз;тип;нач_прибл)

Полное описание смысла аргументов кпер, выплата, нз, бз и тип см. в справке по функции ПЗ.

Кпер — это общее число периодов выплат годовой ренты.

Плата — это выплата, производимая в каждый период; это значение не может меняться в течение всего периода выплат. Обычно плата состоит из основного платежа и платежа по процентам, но не включает других налогов и сборов. Если аргумент опущен, должно быть указано значение аргумента бз.

Нз — это текущее значение — общая сумма, которую составят будущие платежи .

Бз — это требуемое значение будущей стоимости или остатка средств после последней выплаты. Если аргумент бз опущен, то он полагается равным 0 (например, бз для займа равно 0).

Тип — это число 0 или 1, обозначающее, когда должна производиться выплата.

Тип | Когда нужно платить
0 или опущен | В конце периода
1 | В начале периода

Нач_прибл — это предполагаемая величина нормы.

  • Если нач_прибл опущено, то оно полагается равным 10 процентам.

  • Если функция НОРМА не сходится, следует попытаться использовать различные значения нач_прибл. Обычно функция НОРМА сходится, если нач_прибл имеет значение между 0 и 1.

Замечания

Убедитесь, что вы последовательны в выборе единиц измерения для задания аргументов нач_прибл и кпер. Если делаются ежемесячные выплаты по четырехгодичному займу под 12 процентов годовых, используйте 12%/12 для задания аргумента нач_прибл и 4*12 для задания аргумента кпер. Если вы делаются ежегодные платежи по тому же займу, то используйте 12% для задания аргумента нач_прибл и 4 для задания аргумента кпер.

Пример

Чтобы определить процентную ставку для четырехлетнего займа в 8 000 р. с ежемесячной выплатой в 200 р. можно использовать следующую формулу:

НОРМА(48; -200; 8000) равняется 0,77 процентов

Это месячная процентная ставка, так как период равен месяцу. Годовая процентная ставка составит 0,77%*12, что равняется 9,24 процентам.


НПЗ

См. также

Вычисляет чистый текущий объем вклада, используя учетную ставку, а также объемы будущих платежей (отрицательные значения) и поступлений (положительные значения).

Синтаксис

НПЗ(ставка;значение1;значение2; ...)

Ставка - это учетная ставка за один период.

Значение1, значение2, ... - это от 1 до 29 аргументов, представляющих расходы и доходы.

  • Значение1, значение2, ... должны быть равномерно распределены во времени, выплаты должны осуществляться в конце каждого периода.

  • НПЗ использует порядок аргументов значение1, значение2, ... для определения порядка поступлений и платежей. Убедитесь в том, что Ваши платежи и поступления введены в правильном порядке.

  • Аргументы, которые являются числами, пустыми ячейками, логическими значениями или текстовыми представлениями чисел учитываются; аргументы, которые являются значениями ошибки или текстами, которые не могут быть преобразованы в числа, игнорируются.

  • Если аргумент является массивом или ссылкой, то учитываются только числа. Пустые ячейки, логические значения, тексты или значения ошибок в массиве или ссылке игнорируются.

Замечания

  • Считается , что инвестиция, значение которой вычисляет функция НПЗ, начинается за один период до даты денежного взноса значение1 и заканчивается с последним денежным взносом в списке. Вычисления функции НПЗ базируются на будущих денежных взносах. Если первый денежный взнос приходится на начало первого периода, то первое значение следует добавить к результату функции НПЗ, но не включать в список аргументов. Для получения более подробной информации, см. примеры ниже.

  • Если n - это количество денежных взносов в списке значений, то формула для функции НПЗ имеет вид:

  • НПЗ аналогична функции ПЗ (текущее значение). Основное различие между функциями ПЗ и НПЗ заключается в том, что ПЗ допускает, чтобы денежные взносы происходили либо в конце, либо в начале периода. В отличие от денежных взносов переменной величины в функции НПЗ, денежные взносы в функции ПЗ должны быть постоянны на весь период инвестиции. Для получения информации о функциях платежей по ссуде и финансовых функциях, см. ПЗ.

  • НПЗ также связана с функцией ВНДОХ (внутренняя скорость оборота). ВНДОХ - это скорость оборота, для которой НПЗ равняется нулю: НПЗ(ВНДОХ(...); ...) = 0.

Примеры

Рассмотрим инвестицию, при которой Вы выплачиваете 10 000 рублей через год после сегодняшнего дня и получаете годовые доходы 3 000 руб., 4 200 руб. и 6 800 руб. в последующие три года. Предположим, что учетная ставка составляет 10 процентов, в таком случае чистый текущий объем инвестиции составит:

НПЗ(10%; -10000; 3000; 4200; 6800) равняется 1188,44 руб.

В предыдущем примере начальный платеж 10 000 руб. был включен как одно из значений, поскольку выплата производилась в конце первого периода.

Рассмотрим инвестиции, которые начинаются в начале первого периода. Допустим Вы интересуетесь покупкой обувного магазина. Стоимость предприятия - 40 000 руб. и Вы ожидаете получить следующие доходы за первые пять лет: 8 000 руб., 9 200 руб., 10 000 руб., 12 000 руб. и 14 500 руб. Годовая учетная ставка равна 8 процентов. Она может представлять степень инфляции или учетную ставку конкурирующих инвестиций.

Если стоимость и доходы от обувного магазина введены в ячейки от B1 до B6 соответственно, то чистый текущий объем инвестиции в обувной магазин составит:

НПЗ(8%; B2:B6)+B1, что равняется 1922,06.

В предыдущем примере начальная цена 40 000 руб. не включалась в список значений, поскольку выплата пришлась на начало периода.

Предположим, что на шестой год ваши дела шли менее удачно, и ожидается убыток в 9 000 руб. для шестого года. Чистый текущий объем инвестиции в обувной магазин после шести лет составит:

НПЗ(8%; B2:B6; -9000)+B1, что равняется -3749,47.


ОБЩДОХОД

См. также

Возвращает основные выплаты по займу между двумя периодами.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ОБЩДОХОД(ставка;кпер;нз;нач_период;кон_период;тип)

Ставка это процентная ставка.

Кпер - это общее количество периодов выплат.

Нз - это текущее значение инвестиции.

Нач_период - это номер первого периода, участвующего в вычислениях. Периоды выплат нумеруются начиная с 1.

Кон_период - это номер последнего периода, участвующего в вычислениях.

Тип - определяет, в какой момент производится выплата.

Введите | Когда нужно платить
0 | В конце периода
1 | В начале периода

Замечания

  • Убедитесь, что Вы последовательны в выборе единиц измерения аргументов ставка и кпер. Если по четырехгодичному займу при ставке 12 процентов годовых делаются ежемесячные выплаты, то нужно использовать значение 12%/12 для задания аргумента ставка и значение 4*12 для задания аргумента кпер. Если по тому же займу делаются ежегодные выплаты, то нужно использовать значение 12% для задания аргумента ставка и значение 4 для задания аргумента кпер.

  • Кпер, нач_период, кон_период и тип усекаются до целых.

  • Если ставка ≤ 0, кпер ≤ 0 или нз ≤ 0, то функция ОБЩДОХОД возвращает значение ошибки #ЧИСЛО!.

  • Если нач_период < 1, кон_период < 1, или нач_период > кон_период, то функция ОБЩДОХОД возвращает значение ошибки #ЧИСЛО!.

  • Если тип является любым числом, кроме 0 и 1, то функция ОБЩДОХОД возвращает значение ошибки #ЧИСЛО!.

Пример

Пусть заем под недвижимость сделан на следующих условиях:

Процентная ставка 9,00 процентов годовых (ставка = 9,00% ч 12 = 0,0075)
Срок 30 лет (кпер = 30 Ч 12 = 360)
Текущая стоимость 125 000 руб.

Общая выплата за второй год платежей (периоды от 13 до 24) составит:

ОБЩДОХОД(0,0075;360;125000;13;24;0) равняется -934,1071

Одна выплата за первый месяц составит:

ОБЩДОХОД(0,0075;360;125000;1;1;0) равняется -68,27827


ОБЩПЛАТ

См. также

Возвращает накопленный доход по займу между двумя периодами выплат.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ОБЩПЛАТ(ставка;кпер;нз;нач_период;кон_период;тип)

Ставка это процентная ставка.

Кпер - это общее количество периодов выплат.

Нз - это текущее значение инвестиции.

Нач_период - это номер первого периода, участвующего в вычислениях. Периоды выплат нумеруются начиная с 1.

Кон_период - это номер последнего периода, участвующего в вычислениях.

Тип - определяет, в какой момент производится выплата.

Введите | Когда нужно платить
0 | В конце периода
1 | В начале периода

Замечания

  • Убедитесь, что Вы последовательны в выборе единиц измерения аргументов ставка и кпер. Если по четырехгодичному займу при ставке 12 процентов годовых делаются ежемесячные выплаты, то нужно использовать значение 12%/12 для задания аргумента ставка и значение 4*12 для задания аргумента кпер. Если по тому же займу делаются ежегодные выплаты, то нужно использовать значение 12% для задания аргумента ставка и значение 4 для задания аргумента кпер.

  • Кпер, нач_период, кон_период и тип усекаются до целых.

  • Если ставка ≤ 0, кпер ≤ 0 или нз ≤ 0, то функция ОБЩПЛАТ возвращает значение ошибки #ЧИСЛО!.

  • Если нач_период < 1, кон_период < 1 или нач_период > кон_период, то функция ОБЩПЛАТ возвращает значение ошибки #ЧИСЛО!.

  • Если тип является любым числом, кроме 0 и 1, то функция ОБЩПЛАТ возвращает значение ошибки #ЧИСЛО!.

Пример

Пусть заем под недвижимость сделан на следующих условиях:

Процентная ставка 9,00 процентов годовых (ставка = 9,00% ч 12 = 0,0075)
Срок 30 лет (кпер = 30 Ч 12 = 360)
Текущая стоимость 125 000 руб.

Общая выплата за второй год (периоды от 13 до 24) составит:

ОБЩПЛАТ(0,0075;360;125000;13;24;0) равняется -11135,23

Одна выплата за первый месяц составит:

ОБЩПЛАТ(0,0075;360;125000;1;1;0) равняется -937,50


ОСНПЛАТ

См. также

Возвращает величину выплаты на данный период на основе периодических постоянных платежей и постоянной процентной ставки.

Синтаксис

ОСНПЛАТ(ставка;период;кпер;нз;бз;тип)

Более подробное описание аргументов функции ОСНПЛАТ см. в описании функции ПЗ.

Ставка - это процентная ставка за период.

Период - задает период, значение должно быть в интервале от 1 до кпер.

Кпер - это общее число периодов выплат годовой ренты.

Нз - это текущее значение — общая сумма, которую составят будущие платежи .

Бз - это будущая сумма или баланс наличности, которой нужно достичь после последней выплаты. Если бз опущено, оно полагается равным 0 (нулю), т.е. будущая сумма ссуды, например, равна 0.

Тип - это число 0 или 1, обозначающее, когда должна производиться выплата.

Тип | Когда нужно платить
0 или опущен | В конце периода
1 | В начале периода

Замечания

Убедитесь, что Вы последовательны в выборе единиц измерения для задания аргументов ставка и кпер. Если Вы делаете ежемесячные выплаты по четырехгодичному займу из расчета 12 процентов годовых, то используйте 12%/12 для задания аргумента ставка и 4*12 для задания аргумента кпер. Если Вы делаете ежегодные платежи по тому же займу, то используйте 12% для задания аргумента ставка и 4 для задания аргумента кпер.

Примеры

Следующая формула возвращает значение основного платежа для первого месяца двухгодичного займа в 2 000 руб. под 10 процентов годовых:

ОСНПЛАТ(10%/12; 1; 24; 2000) равняется -75,62 руб.

Следующая функция возвращает значение основного платежа по 10-летнему займу в 200000 руб. под 8 процентов годовых:

ОСНПЛАТ(8%; 10; 10; 200000) равняется -27 598,05 руб


ПДОБ

См. также

Возвращает значение амортизации имущества за данный период, включая конкретные периоды, используя метод двойного процента со снижающегося остатка или иной явно указанный метод. ПДОБ представляет метод со снижающегося остатка.

Синтаксис

ПДОБ(стоимость;остаток;период;нач_период;кон_период;коэфф;без_переключения)

Нач_стоимость - это начальная стоимость имущества.

Ост_стоимость - это стоимость в конце периода амортизации (иногда называется остаточной стоимостью имущества).

Время_эксплуатации - это количество периодов, за которые собственность амортизируется (иногда называется периодом амортизации).

Нач_период - это начальный период, для которого вычисляется амортизация. Нач_период должен быть задан в тех же единицах, что и период.

Кон_период - это конечный период, для которого вычисляется амортизация. Кон_период должен быть задан в тех же единицах, что и период.

Коэфф - это норма снижения балансовой стоимости (амортизации). Если коэфф опущен, то он полагается равным 2 (метод удвоенного процента со снижающегося остатка). Измените коэфф, если Вы не хотите использовать метод удвоенного процента со снижающегося остатка. Описание метода удвоенного процента со снижающегося остатка см. ДДОБ.

Без_переключения - это логическое значение, определяющее следует ли использовать прямую амортизацию в том случае, когда амортизация превышает вычисленную величину амортизации.

  • Если аргумент без_переключения имеет значение ИСТИНА, то Microsoft Excel не переключается на метод равномерного начисления амортизации, даже если амортизация больше вычисленного снижающегося остатка.

  • Если аргумент без_переключения имеет значение ЛОЖЬ или опущен, то Microsoft Excel переключается на метод равномерного начисления амортизации, если амортизация больше вычисленного снижающегося остатка.

Все аргументы, за исключением аргумента без_переключения, должны быть положительными числами.

Примеры

Предположим, что предприятие приобрело новую машину. Машина стоит 2 400 руб. и имеет срок службы 10 лет. Остаточная стоимость составляет 300 руб. Следующие примеры показывают амортизацию за несколько периодов. Результаты округляются до двух знаков после запятой.

ПДОБ(2400; 300; 3650; 0; 1) равняется 1,32 руб., амортизация за первый день. Microsoft Excel автоматически предполагает, что коэфф равен 2.

ПДОБ(2400; 300; 120; 0; 1) равняется 40,00 руб., амортизация за первый месяц.

ПДОБ(2400; 300; 10; 0; 1) равняется 480,00 руб., амортизация за первый год.

ПДОБ(2400; 300; 120; 6; 18) равняется 396,31 руб., амортизация за период между 6-м и 18-м месяцами эксплуатации.

ПДОБ(2400; 300; 120; 6; 18; 1,5) равняется 311,81 руб., амортизация за период между шестым и восемнадцатым месяцами эксплуатации при использовании аргумента коэфф равного 1,5, вместо метода удвоенного процента со снижающегося остатка.

Предположим теперь, что машина за 2 400 руб. была приобретена в середине первого квартала финансового года. Следующая формула определяет амортизацию за первый финансовый год владения имуществом, причем налоговые законы ограничивают обесценивание 150 процентов по методу снижающегося остатка:

ПДОБ(2400; 300; 10; 0; 0,875; 1,5) равняется 315,00 руб.


ПЗ

См. также

Возвращает текущий объем вклада. Текущий объем — это общая сумма, которую составят будущие платежи. Например, когда деньги берутся взаймы, заимствованная сумма и есть текущий объем для заимодавца.

Синтаксис

ПЗ(ставка;кпер;выплата;бз;тип)

Ставка — это процентная ставка за период. Например, если получена ссуда под автомобиль под 10 процентов годовых и делаются ежемесячные выплаты, то процентная ставка за месяц составит 10%/12, или 0,83%. В качестве значения аргумента ставка нужно ввести в формулу 10%/12 или 0,83% или 0,0083.

Кпер — это общее число периодов выплат годовой ренты. Например, если получена ссуда на 4 года под автомобиль и делаются ежемесячные платежи, то ссуда имеет 4*12 (или 48) периодов. В качестве значения аргумента кпер в формулу нужно ввести число 48.

Выплата — это выплата, производимая в каждый период и не меняющаяся за все время выплаты ренты. Обычно выплаты включают основные платежи и платежи по процентам, но не включают других сборов или налогов. Например, ежемесячная выплата по четырехгодичному займу в 10 000 руб. под 12 процентов годовых составит 263,33 руб. В качестве значения аргумента выплата нужно ввести в формулу число -263,33.

Бз — требуемое значение будущей стоимости или остатка средств после последней выплаты. Если аргумент опущен, он полагается равным 0 (будущая стоимость займа, например, равна 0). Например, если предполагается накопить 50000 руб. для оплаты специального проекта в течение 18 лет, то 50 000 руб. это и есть будущая стоимость. Можно сделать предположение о сохранении заданной процентной ставки и определить, сколько нужно откладывать каждый месяц.

Тип — это число 0 или 1, обозначающее, когда должна производиться выплата.

Тип | Когда нужно платить
0 или опущен | В конце периода
1 | В начале периода

Замечания

  • Убедитесь, что для аргументов ставка и кпер используются согласованные единицы измерения. Если производятся ежемесячные платежи по четырехгодичному займу из расчета 12% годовых, то ставка должна быть 12%/12 , а кпер должно быть 4*12. Если производятся ежегодные платежи по тому же займу, то ставка должна быть 12%, а кпер должно быть 4.

  • Следующие функции используются для вычислений, связанных с интервалами выплат:
    ОБЩПЛАТ | ОСНПЛАТ
    ОБЩДОХОД | ПЗ
    БЗ | НОРМА
    БЗРАСПИС | ЧИСТВНДОХ
    ПЛПРОЦ | ЧИСТНЗ
    ППЛАТ

    Интервал выплат - это последовательность постоянных денежных платежей, делаемых в непрерывный период. Например, заем под автомобиль или заклад являются интервалами выплат. Для получения более подробных сведений см. описание каждой функции, связанной с интервалом выплат.

  • В функциях, связанных с интервалами выплат, выплачиваемые деньги, такие как депозит на накопление, представляются отрицательным числом; полученные деньги, такие как чеки на дивиденды, представляются положительным числом. Например, депозит в банк на сумму 1 000 руб. представляется аргументом -1000, для вкладчика и представляется аргументом 1000, если для банка.

  • Microsoft Excel выражает каждый финансовый аргумент через другие. Если ставка не равна 0, то:

    Если ставка равна 0, то:

    (выплата * кпер) + нз + бз = 0

Пример

Предположим, что выкупается страховка, по которой выплачивается по 500 руб. в конце каждого месяца в течение 20 последующих лет. Стоимость ренты составляет 60 000 руб. и выплачиваемые деньги принесут 8 процентов годовых. Необходимо определить, будет ли это хорошим способом инвестировать капитал. Используя функцию ПЗ получаем, что настоящий объем вклада составит:

ПЗ(0,08/12; 12*20; 500; ; 0) равняется -59 777,15 руб,

Результат получается отрицательный, поскольку он представляет деньги, которые необходимо выплатить. Настоящий объем вклада (59 777,15 руб.) меньше, чем запрашиваемая цена (60 000 руб.). Следовательно, можно сделать вывод, что это не самый лучший способ инвестирования денег.


ПЛПРОЦ

См. также

Возвращает платежи по процентам за данный период на основе периодических постоянных выплат и постоянной процентной ставки. Для получения более полного описания смысла аргументов функции ПЛПРОЦ и более подробной информации о функциях, связанных с ежегодными выплатами, см. справку по функции ПЗ.

Синтаксис

ПЛПРОЦ(ставка;период;кпер;нз;бз;тип)

Ставка — это процентная ставка за период.

Период — это период, для которого требуется найти платежи по процентам; должен находиться в интервале от 1 до кпер.

Кпер — это общее число периодов выплат годовой ренты.

Нз — это текущая стоимость, или общая сумма всех будущих платежей с настоящего момента.

Бз — это будущая стоимость или баланс наличности, который нужно достичь после последней выплаты. Если аргумент бз опущен, то предполагается, что он равен 0 (например, бз для займа равно 0).

Тип — это число 0 или 1, обозначающее, когда должна производиться выплата. Если аргумент тип опущен, то он полагается равным 0.

Тип | Когда нужно платить
0 | В конце периода
1 | В начале периода

Замечания

  • Убедитесь, что для аргументов ставка и кпер используются согласованные единицы измерения. Если производятся ежемесячные платежи по четырехгодичному займу из расчета 12% годовых, то ставка должна быть 12%/12 , а кпер должно быть 4*12. Если производятся ежегодные платежи по тому же займу, то ставка должна быть 12%, а кпер должно быть 4.

  • Все аргументы, означающие деньги, которые платятся (например, депозитные вклады), представляются отрицательными числами; деньги, которые получены (например, дивиденды), представляются положительными числами.

Примеры

Следующая формула вычисляет выплаты по процентам за первый месяц для трехгодичного займа в 800000 рублей из расчета 10 процентов годовых:

ПЛПРОЦ(0,1/12; 1; 36; 800000) равняется -6667 рублей

Следующая формула вычисляет доход за последний год от трехгодичного займа в 800000 рублей из расчета 10 процентов годовых при ежегодных выплатах:

ПЛПРОЦ(0,1; 3; 3; 800000) равняется -29245 рублей.


ПОЛУЧЕНО

См. также

Возвращает сумму, полученную к сроку вступления в силу полностью обеспеченных ценных бумаг.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ПОЛУЧЕНО(дата_соглашения;дата_вступления_в_силу;инвестиция;скидка;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Инвестиция — это объем инвестиции в ценные бумаги.

Скидка — это норма скидки для ценных бумаг.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу и базис усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не является допустимой датой, то функция ПОЛУЧЕНО возвращает значение ошибки #ЧИСЛО!.

  • Если инвестиция ≤ 0 или скидка ≤ 0, то функция ПОЛУЧЕНО возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ПОЛУЧЕНО возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, ПОЛУЧЕНО возвращает значение ошибки #ЧИСЛО!.

  • ПОЛУЧЕНО вычисляется следующим образом:

    где:

    B = число дней в году (зависит от выбранного значения аргумента базис).

    DIM = количество дней от даты выпуска до даты вступления в силу.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения (выпуска) 15 февраля 1999 года
Срок погашения 15 мая 1999 года
Инвестиция 1 000 000 р.
Норма скидки 5,75 процентов
Базис фактический/360

Общая сумма, которая будет получена на дату вступления в силу (в системе дат 1900), составит:

ПОЛУЧЕНО("15.2.1999";"15.5.1999";1000000;0,0575;2) равняется 1014420,266 или 1 014 420,27 р.


ППЛАТ

См. также

Вычисляет величину выплаты по ссуде на основе постоянных выплат и постоянной процентной ставки.

Синтаксис

ППЛАТ(ставка;кпер;нз;бз;тип)

Более подробное описание аргументов функции ППЛАТ см. в описании функции ПЗ.

Ставка - это процентная ставка по ссуде.

Кпер - это общее число выплат по ссуде.

Нз - это текущее значение или общая сумма, которую составят будущие платежи, называемая также основной суммой.

Бз - это будущая сумма или баланс наличности, которой нужно достичь после последней выплаты. Если бз опущено, оно полагается равным 0 (нулю), т.е. будущая сумма ссуды, например, равна 0.

Тип - это число 0 (ноль) или 1, обозначающее, когда должна производиться выплата.

Тип | Когда нужно платить
0 или опущен | В конце периода
1 | В начале периода

Замечания

  • Выплаты, возвращаемые функцией ППЛАТ включают основные платежи и платежи по процентам, но не включают налогов, резервных платежей или гонораров, иногда связываемых со ссудой.

  • Убедитесь, что Вы последовательны в выборе единиц измерения для задания аргументов "ставка" и "кпер" . Если вы делаете ежемесячные выплаты по четырехгодичному займу из расчета 12 процентов годовых, то используйте 12%/12 для задания аргумента "ставка" и 4*12 для задания аргумента "кпер" . Если вы делаете ежегодные платежи по тому же займу, то используйте 12 процентов для задания аргумента ставка и 4 для задания аргумента "кпер" .

Совет. Для нахождения общей суммы, выплачиваемой на протяжении интервала выплат, умножьте возвращаемое функцией ППЛАТ значение на "кпер".

Примеры

Следующая формула возвращает ежемесячные выплаты по займу в 10 000 руб. и годовой процентной ставке 8 процентов, которые можно выплачивать в течении 10 месяцев:

ППЛАТ(8%/12; 10; 10000) равняется -1037,03 руб.

Для того же займа, если выплаты должны делаться в начале периода, то выплата составит:

ППЛАТ(8%/12; 10; 10000; 0; 1) равняется -1030,16 руб.

Следующая формула возвращает сумму, которую необходимо выплачивать Вам каждый месяц, если Вы дали взаймы 5000 руб. под 12 процентов годовых и хотите получить назад деньги за пять месяцев:

ППЛАТ(12%/12; 5; -5000) равняется 1030,20 руб.

Функцию ППЛАТ можно использовать для расчета платежей не только в случае ссуд. Например, если требуется накопить 50 000 руб. за 18 лет, накапливая постоянную сумму каждый месяц, с помощью этой функции можно определить размер откладываемых сумм. Если предположить, что удастся обеспечить 6 процентов годовых на накопления, можно использовать функцию ППЛАТ, чтобы определить, сколько нужно откладывать каждый месяц.

ППЛАТ(6%/12; 18*12; 0; 50000) равняется -129,08 руб.

При ежемесячной выплате 129,08 руб. с 6 процентным накоплением в течение 18 лет, Вы получите 50000 руб.


ПРОЦПЛАТ

См. также

Вычисляет выплаты за указанный период выплат. Эта функция обеспечивает совместимость с Lotus 1-2-3.

Синтаксис

ПРОЦПЛАТ(ставка;период;кпер;нз)

Ставка — это процентная ставка для вклада.

Период — это период, для которого требуется найти прибыль; должен находиться в интервале от 1 до кпер.

Кпер — это общее число периодов выплат для данного вклада.

Нз — это текущее значение вклада. Для займа нз — это сумма кредита.

Замечания

  • Убедитесь, что Вы последовательны в выборе единиц измерения аргументов ставка и кпер. Если по четырехгодичному займу при ставке 12 процентов годовых делаются ежемесячные выплаты, то нужно использовать значение 12%/12 для задания аргумента ставка и значение 4*12 для задания аргумента кпер. Если по тому же займу делаются ежегодные выплаты, то нужно использовать значение 12% для задания аргумента ставка и значение 4 для задания аргумента кпер.

  • Все аргументы, означающие деньги, которые вы платите (например, депозитные вклады), представляются отрицательными числами; деньги, которые Вы получаете (например, дивиденды), представляются положительными числами.

  • За дополнительной информацией по финансовым функциям обратитесь к справке по функции ПЗ.

Примеры

Следующий пример вычисляет сумму первого из ежемесячных платежей за трехлетний кредит размером в 8 миллионов рублей, полученный под 10% годовых.

ПРОЦПЛАТ(0,1/12;1;36;8000000) = -64814,8

Следующий пример вычисляет сумму процентов, выплаченных в первом году за трехлетний кредит размером в 8 миллионов рублей, полученный под 10% годовых.

ПРОЦПЛАТ(0,1;1;3;8000000) = -533333


РАВНОКЧЕК

См. также

Возвращает эквивалентный облигации доход по казначейскому чеку.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

РАВНОКЧЕК(дата_соглашения;дата_вступления_в_силу;скидка)

Дата соглашения — это дата соглашения для казначейского чека. Эта дата, более поздняя, чем дата выпуска, когда казначейский чек был продан покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — это срок погашения для казначейского чека. Соответствует дате истечения срока действия чека.

Скидка — это норма скидки для казначейского чека.

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Дата_соглашения и дата_вступления_в_силу усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не является допустимой датой, то функция РАВНОКЧЕК возвращает значение ошибки #ЧИСЛО!.

  • Если скидка ≤ 0, то функция РАВНОКЧЕК возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения > дата_вступления_в_силу или дата_вступления_в_силу более чем на год превосходит дату_соглашения, то функция РАВНОКЧЕК возвращает значение ошибки #ЧИСЛО!.

  • РАВНОКЧЕК вычисляется следующим образом: РАВНОКЧЕК = (365 x ставка)/360-(ставка x DSM), где DSM — это количество дней между аргументами дата_соглашения и дата_вступления_в_силу, вычисленное на базе 360-дневного года.

Пример

Чек казначейства выпущен на следующих условиях:

Дата соглашения 31 марта 1999 года
Срок погашения 1 июня 1999 года
Норма скидки 9,14 процентов

Эквивалентный облигации доход по казначейскому чеку (в системе дат 1900) составит:

РАВНОКЧЕК("31.3.93";"1.6.93";0,0914) равняется 0,094151 или 9,4151 процентам


РУБЛЬ.ДЕС

См. также

Преобразует цену в рублях, выраженную в виде дроби, в цену в рублях, выраженную десятичным числом. Функция РУБЛЬ.ДЕС используется для преобразования дробных значений денежных сумм, например, стоимость ценных бумаг, в десятичное число.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

РУБЛЬ.ДЕС(дробь;знаменатель)

Дробь - это число, выраженное в виде дроби.

Знаменатель - это целое, которое нужно использовать в качестве знаменателя.

Замечания

  • Если знаменатель не целое число, то оно усекается.

  • Если знаменатель ≤ 0, то функция РУБЛЬ.ДЕС возвращает значение ошибки #ЧИСЛО!.

Примеры

РУБЛЬ.ДЕС(1,02;16) равняется 1,125

РУБЛЬ.ДЕС(1,1;8) равняется 1,125


РУБЛЬ.ДРОБЬ

См. также

Преобразует цену в рублях, выраженную десятичным числом, в цену в рублях, выраженную в виде дроби. Функция РУБЛЬ.ДРОБЬ используется для преобразования десятичных чисел в дробные цены, например, стоимость ценных бумаг.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

РУБЛЬ.ДРОБЬ(десятичное_число;знаменатель)

Десятичное_число - это десятичное число

Знаменатель - это целое число, которое нужно использовать в качестве знаменателя дроби.

Замечания

  • Если знаменатель не целое число, то оно усекается.

  • Если знаменатель ≤ 0, то функция РУБЛЬ.ДРОБЬ возвращает значение ошибки #ЧИСЛО!.

Примеры

РУБЛЬ.ДРОБЬ(1,125;16) равняется 1,02

РУБЛЬ.ДРОБЬ(1,125;8) равняется 1,1


СКИДКА

См. также

Возвращает норму скидки для ценных бумаг.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

СКИДКА(дата_соглашения;дата_вступления_в_силу;цена;выкуп;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Цена — это стоимость ценных бумаг за 100 руб. номинальной стоимости.

Выкуп — это выкупная цена ценных бумаг за 100 руб. номинальной стоимости.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу и базис усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не являются допустимой датой, то функция СКИДКА возвращает значение ошибки #ЧИСЛО!.

  • Если цена ≤ 0 или выкуп ≤ 0, то функция СКИДКА возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция СКИДКА возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, то функция СКИДКА возвращает значение ошибки #ЧИСЛО!.

  • СКИДКА вычисляется следующим образом:

    где:

    B = число дней в году (зависит от выбранного значения аргумента базис).

    DSM = число дней между датами дата_соглашения и дата_вступления_в_силу.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 15 февраля 1998 года
Срок погашения 10 июня 1998 года
Цена 97,975 руб.
Выкупная цена 100 руб.
Базис фактический/360

Норма скидки (в системе дат 1900) составит:

СКИДКА("15.2.98";"6.10.98";97,975;100;2) равняется 0,063391 или 6,3391%


ЦЕНА

См. также

Возвращает цену за 100 рублей нарицательной стоимости ценных бумаг, по которым выплачивается периодический процент.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЦЕНА(дата_соглашения;дата_вступления_в_силу;ставка;доход;выкуп;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Ставка — это годовая процентная ставка для купонов по ценным бумагам.

Доход — это годовой доход по ценным бумагам.

Выкуп — это выкупная цена ценных бумаг за 100 р. номинальной стоимости.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу, периодичность и базис усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не является допустимой датой, то функция ЦЕНА возвращает значение ошибки #ЧИСЛО!.

  • Если доход < 0 или ставка < 0, то функция ЦЕНА возвращает значение ошибки #ЧИСЛО!.

  • Если погашение ≤ 0, то функция ЦЕНА возвращает значение ошибки #ЧИСЛО!.

  • Если частота любое число отличное от 1, 2 или 4, то функция то функция ЦЕНА возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или если базис > 4, то функция ЦЕНА возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, то функция ЦЕНА возвращает значение ошибки #ЧИСЛО!.

  • ЦЕНА вычисляется следующим образом:

    где:

    DSC = количество дней от даты соглашения до даты следующего купона.

    E = количество дней в периоде купона, на который приходится дата соглашения.

    N = количество оплачиваемых купонов между датой соглашения и датой погашения.

    A = количество дней от начала периода купона до даты соглашения.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 15 февраля 1999 года
Срок погашения 15 ноября 2007 года
Полугодовой купон 5,75 процентов
Доход 6,50 процентов
Цена при погашении 100 р.
Полугодовая периодичность
Базис 30/360

Цена облигаций (в системе дат 1900) составит:

ЦЕНА("15.2.1999";"15.11.2007";0,0575;0,065;100;2;0) равняется 95,04287


ЦЕНАКЧЕК

См. также

Возвращает цену на 100 руб. номинальной стоимости для казначейского чека.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЦЕНАКЧЕК(дата_соглашения;дата_вступления_в_силу;скидка)

Дата соглашения — это дата соглашения для казначейского чека. Эта дата, более поздняя, чем дата выпуска, когда казначейский чек был продан покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — это срок погашения для казначейского чека. Соответствует дате истечения срока действия чека.

Скидка — это норма скидки для казначейского чека.

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Дата_соглашения и дата_вступления_в_силу усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не является допустимой датой, то функция ЦЕНАКЧЕК возвращает значение ошибки #ЧИСЛО!.

  • Если скидка ≤ 0, то функция ЦЕНАКЧЕК возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения > дата_вступления_в_силу или дата_вступления_в_силу более чем на год превосходит дату_соглашения, то функция ЦЕНАКЧЕК возвращает значение ошибки #ЧИСЛО!.

  • ЦЕНАКЧЕК вычисляется следующим образом:

    где:

    DSM = количество дней от даты соглашения до даты вступления в силу, исключая дату вступления в силу, которая более чем на один календарный год больше даты соглашения.

Пример

Чек казначейства выпущен на следующих условиях:

Дата соглашения 31 марта 1999 года
Дата погашения 1 июня 1999 года
Норма скидки 9%

Цена казначейского чека (в системе дат 1900) составит:

ЦЕНАКЧЕК("31.3.93";"1.6.93";0,09) равняется 98,45

ЦЕНАКЧЕК("31.8.2001";"30.1.2002";0,07) равняется 97,04


ЦЕНАПЕРВНЕРЕГ

См. также

Возвращает цену за 100 рублей номинальной стоимости ценных бумаг для нерегулярного (короткого или длинного) первого периода.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЦЕНАПЕРВНЕРЕГ(дата_соглашения;дата_вступления_в_силу;дата_выпуска;первый_купон;ставка;доход;выкуп;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Дата_выпуска — это дата выпуска ценных бумаг.

Первый_купон — это дата первого купона для ценных бумаг.

Ставка — это процентная ставка для ценных бумаг.

Доход — это годовой доход по ценным бумагам.

Выкуп — это выкупная цена ценных бумаг за 100 р. номинальной стоимости.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу, дата_выпуска, первый_купон и базис усекаются до целых.

  • Если дата_соглашения, дата_вступления_в_силу, дата_выпуска или первый_купон не является допустимой датой, то функция ЦЕНАПЕРВНЕРЕГ возвращает значение ошибки #ЧИСЛО!.

  • Если ставка < 0 или доход < 0, то функция ЦЕНАПЕРВНЕРЕГ возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ЦЕНАПЕРВНЕРЕГ возвращает значение ошибки #ЧИСЛО!.

  • Должны быть выполнены следующие условия, в противном случае функция ЦЕНАПЕРВНЕРЕГ возвращает значение ошибки #ЧИСЛО!:

    дата_вступления_в_силу > первый_купон > дата_соглашения > дата_выпуска

  • ЦЕНАПЕРВНЕРЕГ вычисляется следующим образом:

    Нерегулярный короткий первый купон:

    где:

    A = количество дней от начала периода купона до даты соглашения (накопленные дни).

    DSC = количество дней от даты соглашения до даты следующего купона.

    DFC = количество дней от начала нерегулярного купона до даты первого купона.

    E = количество дней в периоде купона.

    N = количество оплачиваемых купонов между датой соглашения и датой погашения. (Если это число является дробным, то оно округляется с избытком до ближайшего целого).

    Нерегулярный длинный первый купон:

    где:

    Ai = количество дней от начала i-ого или последнего квазикупонного периода в нерегулярном периоде.

    DCi = количество дней от указанной даты (или даты выпуска) до первого квазикупона (i = 1) или количество дней в квазикупоне (i = 2,..., i = NC).

    DSC = количество дней от даты соглашения до даты следующего купона.

    E = количество дней в периоде купона.

    N = количество оплачиваемых купонов от даты первого фактического купона до даты погашения. (Если это число является дробным, то оно округляется с избытком до ближайшего целого).

    NC = количество периодов квазикупонов, укладывающихся в нерегулярный период. Если это число является дробным, то оно округляется с избытком до ближайшего целого.

    NLi = нормальная продолжительность в днях полного i-ого или последнего квазикупонного периода в нерегулярном периоде.

    Nq = количество полных периодов квазикупонов от даты соглашения до первого купона.

Пример

Долговое обязательство казначейства выпускается на следующих условиях:

Дата соглашения 11 ноября 1999 года
Срок погашения 1 марта 2012 года
Дата выпуска 15 октября 1999 года
Дата первого купона 1 марта 2000 года
Купон 7,85 процентов
Доход 6,25 процентов
Стоимость при погашении 100 р.
Периодичность полугодовая
Фактический базис

Цена за 100 р. нарицательной стоимости ценных бумаг для нерегулярного (короткого или длинного) первого периода (в Системе дат 1900) составит:

ЦЕНАПЕРВНЕРЕГ("11.11.1999";"1.3.2012";"15.10.1999";"3.1.2000";0,0785;0,0625;100;2;1) равняется 113.5985


ЦЕНАПОГАШ

См. также

Возвращает цену за 100 рублей нарицательной стоимости ценных бумаг, по которым доход выплачивается в срок вступления в силу.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЦЕНАПОГАШ(дата_соглашения;дата_вступления_в_силу;дата_выпуска;ставка;доход;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Дата_выпуска — это дата выпуска ценных бумаг.

Ставка — это процентная ставка дохода по ценным бумагам на дату выпуска.

Доход — это годовой доход по ценным бумагам.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу, дата_выпуска и базис усекаются до целых.

  • Если дата_соглашения, дата_вступления_в_силу, или дата_выпуска не является допустимой датой, то функция ЦЕНАПОГАШ возвращает значение ошибки #ЧИСЛО!.

  • Если ставка < 0 или доход < 0, то функция ЦЕНАПОГАШ возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ЦЕНАПОГАШ возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, ЦЕНАПОГАШ возвращает значение ошибки #ЧИСЛО!.

  • ЦЕНАПОГАШ вычисляется следующим образом:

    где:

    B = количество дней в году, зависит от используемого базиса.

    DSM = количество дней от даты соглашения до даты вступления в силу.

    DIM = количество дней от даты выпуска до даты вступления в силу.

    A = количество дней от даты выпуска до даты соглашения.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 15 февраля 1999 года
Срок погашения 13 апреля 1999 года
Дата выпуска 11 ноября 1998 года
Полугодовой купон 6,1 процентов
Доход 6,1 процентов
Базис 30/360

Цена (в системе дат 1900) составит:

ЦЕНАПОГАШ("15.2.1999";"13.4.1999";"11.11.1998";0,061;0,061;0) равняется 99,98449888


ЦЕНАПОСЛНЕРЕГ

См. также

Возвращает цену за 100 рублей нарицательной стоимости ценных бумаг для нерегулярного (короткого или длинного) последнего периода купона.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЦЕНАПОСЛНЕРЕГ(дата_соглашения;дата_вступления_в_силу;последняя_выплата;ставка;доход;выкуп;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Последняя_выплата — это дата последнего купона для ценных бумаг.

Ставка — это процентная ставка для ценных бумаг.

Доход — это годовой доход по ценным бумагам.

Выкуп — это выкупная цена ценных бумаг за 100 р. номинальной стоимости.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу, последняя_выплата и базис усекаются до целых.

  • Если дата_соглашения, дата_вступления_в_силу или последняя_выплата не является допустимой датой, то функция ЦЕНАПОСЛНЕРЕГ возвращает значение ошибки #ЧИСЛО!.

  • Если ставка < 0 или доход < 0, то функция ЦЕНАПОСЛНЕРЕГ возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ЦЕНАПОСЛНЕРЕГ возвращает значение ошибки #ЧИСЛО!.

  • Должны быть выполнены следующие условия, в противном случае функция ЦЕНАПОСЛНЕРЕГ возвращает значение ошибки #ЧИСЛО!:

    дата_вступления_в_силу > дата_соглашения > последняя_выплата

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 7 февраля 1999 года
Срок погашения 15 июля 1999 года
Дата последней выплаты 15 октября 1998 года
Купон 3,75 процентов
Доход 4,05 процентов
Стоимость при погашении 100 р.
Частота полугодовая
Базис 30/360

Цена на 100 р. нарицательной стоимости ценных бумаг для нерегулярного (короткого или длинного) последнего периода купона составит:

ЦЕНАПОСЛНЕРЕГ("7.2.1999";"15.6.1999";"15.10.1998";0,0375;0,0405;100;2;0) равняется 99,87829


ЦЕНАСКИДКА

См. также

Возвращает цену за 100 рублей номинальной стоимости ценных бумаг, на которые сделана скидка.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЦЕНАСКИДКА(дата_соглашения;дата_вступления_в_силу;скидка;выкуп;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Скидка — это норма скидки для ценных бумаг.

Выкуп — это выкупная цена ценных бумаг за 100 р. номинальной стоимости.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Дата_соглашения, дата_вступления_в_силу и базис усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не является допустимой датой, то функция ЦЕНАСКИДКА возвращает значение ошибки #ЧИСЛО!.

  • Если скидка ≤ 0 или погашение ≤ 0, то функция ЦЕНАСКИДКА возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ЦЕНАСКИДКА возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, ЦЕНАСКИДКА возвращает значение ошибки #ЧИСЛО!.

  • ЦЕНАСКИДКА вычисляется следующим образом:

    где:

    B = количество дней в году, зависит от используемого базиса.

    DSM = количество дней от даты соглашения до даты вступления в силу.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 15 февраля 1999 года
Срок погашения 1 марта 1999 года
Норма скидки 5,25 процентов
Цена при погашении 100 р.
Базис фактический/360

Цена облигаций (в системе дат 1900) составит:

ЦЕНАСКИДКА("15.2.99";"1.3.99";0,0525;100;2) равняется 99,79583


ЧИСЛКУПОН

См. также

Возвращает количество купонов, которые могут быть оплачены между датой соглашения и сроком погашения, округленное до ближайшего целого количества купонов.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЧИСЛКУПОН(дата_соглашения;дата_вступления_в_силу;периодичность;базис)

Дата соглашения — это дата соглашения для ценных бумаг. Эта дата, более поздняя, чем дата выпуска, когда ценные бумаги были проданы покупателю. Даты могут вводиться как текстовые строки в двойных кавычках (например, "30.1.1998" или "1998.1.30"), как даты в числовом формате (например, 35825, что соответствует 30 января 1998 г., если используется система дат 1900) либо как вычисленные значения, возвращаемые другими формулами или функциями (например, ДАТАЗНАЧ(“30.1.1998”)).

Дата_вступления_в_силу — срок погашения ценных бумаг. Эта дата определяет истечение срока действия ценных бумаг.

Периодичность — это количество выплат по купонам за год. Для ежегодных выплат периодичность = 1; для полугодовых выплат периодичность = 2; для ежеквартальных выплат периодичность = 4.

Базис — это используемый способ вычисления дня.

Базис | Способ вычисления дня
0 или опущен | Американский (NASD) 30/360
1 | Фактический/фактический
2 | Фактический/360
3 | Фактический/365
4 | Европейский 30/360

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

  • Дата соглашения является датой продажи покупателю купона, например облигации. Срок платежа представляет собой дату истечения срока действия купона. Пусть, например, облигация со сроком действия 30 лет выпущена 1 января 1996 года и была приобретена покупателем через шесть месяцев после своего выпуска. Датой выпуска будет являться 1 января 1996 года, датой соглашения — 1 июля 1996, а срок погашения такой облигации — 1 января 2026 года, то есть через 30 лет после даты выпуска.

  • Все аргументы усекаются до целых.

  • Если дата_соглашения или дата_вступления_в_силу не являются допустимой датой, то функция ЧИСЛКУПОН возвращает значение ошибки #ЧИСЛО!.

  • Если периодичность является любым числом, отличным от 1, 2 или 4, то функция ЧИСЛКУПОН возвращает значение ошибки #ЧИСЛО!.

  • Если базис < 0 или базис > 4, то функция ЧИСЛКУПОН возвращает значение ошибки #ЧИСЛО!.

  • Если дата_соглашения ≥ дата_вступления_в_силу, то функция ЧИСЛКУПОН возвращает значение ошибки #ЧИСЛО!.

Пример

Облигации выпущены на следующих условиях:

Дата соглашения 25 января 1998 года
Срок погашения 15 ноября 1999 года
Полугодовые купоны
Фактический базис

Количество выплат по купонам (в системе дат 1900) составит:

ЧИСЛКУПОН("25.1.98";"15.11.99";2;1) равняется 4


ЧИСТВНДОХ

См. также

Возвращает внутреннюю скорость оборота для расписания денежных поступлений, которые не обязательно периодические. Для периодических поступлений используется функция ВНДОХ

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЧИСТВНДОХ(значения;даты;прогноз)

Значения — это ряд поступлений наличных, соответствующий расписанию платежей, приведенному в аргументе даты. Первый платеж является необязательным и соответствует выплате в начале инвестиции. На все последующие выплаты делается скидка на основе 365-дневного года. Ряд значений должен содержать по крайней мере одно положительное и одно отрицательное значение.

Даты — это расписание дат платежей, которое соответствует ряду операций с наличными. Первая дата означает начало расписания платежей. Все другие даты должны быть позже этой даты, но могут идти в произвольном порядке.

Прогноз — это предполагаемое значение результата функции ЧИСТВНДОХ.

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Числа в аргументе даты усекаются до целых.

  • ЧИСТВНДОХ предполагает по крайне мере одну положительную и одну отрицательную операцию с наличными (то есть, по крайней мере один платеж и одно поступление); в противном случае ЧИСТВНДОХ возвращает значение ошибки #ЧИСЛО!.

  • Если любое число в аргументе даты не является допустимой датой, то функция ЧИСТВНДОХ возвращает значение ошибки #ЧИСЛО!.

  • Если любое число в аргументе даты предшествует начальной дате, то функция ЧИСТВНДОХ возвращает значение ошибки #ЧИСЛО!.

  • Если значения и даты содержат различное количество значений, то функция ЧИСТВНДОХ возвращает значение ошибки #ЧИСЛО!.

  • В большинстве случаев нет необходимости задавать аргумент прогноз для функции ЧИСТВНДОХ. Если это аргумент опущен, то прогноз полагается равным 0,1 (10 процентов).

  • ЧИСТВНДОХ тесно связана с функцией ЧИСТНЗ. Скорость оборота, вычисленная функцией ЧИСТВНДОХ — это процентная ставка дохода, соответствующая ЧИСТНЗ = 0.

  • Microsoft Excel использует итеративный метод для вычисления ЧИСТВНДОХ. Используя меняющуюся скорость оборота (начиная со значения прогноз), функция ЧИСТВНДОХ производит циклические вычисления, пока не получит результат с точностью до 0,000001 процента. Если функции ЧИСТВНДОХ не удается найти результат за 100 попыток, то возвращается значение ошибки #ЧИСЛО!. Скорость оборота меняется до тех пор, пока:

    где:

    di = дата i-ой или последней операции с наличными.

    d1 = дата 0-ой операции (начальная дата).

    Pi = сумма i-ой или последней операции.

Пример

Рассмотрим инвестицию, при которой предполагается выплата наличными 10 000 руб. 1 января 1998 года и поступления: 2750 руб. 1 марта 1998 года, 4250 руб. 30 октября 1998 года, 3250 руб. 15 февраля 1999 года и 2750 руб. 1 апреля 1999 года. Внутренняя скорость оборота (в системе дат 1900) составит:

ЧИСТВНДОХ({-10000;2750;4250;3250;2750};
{"1.1.98";"1.3.98";"30.10.98";"15.2.99";"1.4.99"};0,1) равняется 0,374859 или 37,4859 процентам


ЧИСТНЗ

См. также

Возвращает чистую текущую стоимость инвестиции, вычисляемую на основе ряда поступлений наличных, которые не обязательно периодические. В случае периодических поступлений следует пользоваться функцией НПЗ.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЧИСТНЗ(ставка;значения;даты)

Ставка — это норма скидки, применяемая к операциям с наличными.

Значения — это ряд поступлений наличных, соответствующий расписанию платежей, приведенному в аргументе даты. Первый платеж является необязательным и соответствует выплате в начале инвестиции. На все последующие выплаты делается скидка на основе 365-дневного года. Ряд значений должен содержать по крайней мере одно положительное и одно отрицательное значение.

Даты — это расписание дат платежей, которое соответствует ряду операций с наличными. Первая дата означает начало расписания платежей. Все другие даты должны быть позже этой даты, но могут идти в произвольном порядке.

Замечания

  • Microsoft Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней.Хранение даты и времени в Microsoft Excel.

  • Числа в аргументе даты усекаются до целых.

  • Если любой из аргументов не является числом, то функция ЧИСТНЗ возвращает значение ошибки #ЗНАЧ!.

  • Если какое-либо число в аргументе даты не является допустимой датой, то функция ЧИСТНЗ возвращает значение ошибки #ЧИСЛО!.

  • Если какое-либо число в аргументе даты предшествует начальной дате, то функция ЧИСТНЗ возвращает значение ошибки #ЧИСЛО!.

  • Если значения и даты содержат различное количество значений, то функция ЧИСТНЗ возвращает значение ошибки #ЧИСЛО!.

  • ЧИСТНЗ вычисляется следующим образом:

    где:

    di = дата i-ой или последней операции с наличными.

    d1 = дата 0-ой операции (начальная дата).

    Pi = сумма i-ой или последней операции.

Пример

Рассмотрим капиталовложение, которое предполагает выплату 10 000 руб. наличными 1 января 1998 и поступления:

2 750 руб. 1 марта 1998;
4 250 руб. 30 октября 1998;
3 250 руб. 15 февраля 1999 и
2 750 руб. 1 апреля 1999.
Предположим, что норма скидки, применяемая к операциям с наличными, равна 9 процентам. Чистая текущая стоимость составит:

ЧИСТНЗ(0,09;{-10000;2750;4250;3250;2750}; {35796,35855,36098,36206,36251}) равняется 2089,5016 или 2089,50 руб.


ЭФФЕКТ

См. также

Возвращает фактическую годовую процентную ставку, если заданы номинальная годовая процентная ставка и количество периодов, составляющих год.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЭФФЕКТ(номинальная_ставка;периодов_в_году)

Номинальная_ставка - это номинальная годовая процентная ставка.

Периодов_в_году - это количество периодов, составляющих год.

Замечания

  • Аргумент периодов_в_году усекается до целого.

  • Если один из аргументов - не число, функция ЭФФЕКТ возвращает значение ошибки #ЗНАЧ!.

  • Если номинальная_ставка ≤ 0 или если периодов_в_году < 1, то функция ЭФФЕКТ возвращает значение ошибки #ЧИСЛО!.

  • ЭФФЕКТ вычисляется следующим образом:

Пример

ЭФФЕКТ(5,25%;4) равняется 0,053543 или 5,3543 процентов


ЕНЕЧЁТ

См. также

Возвращает значение ИСТИНА, если число нечетное и значение ЛОЖЬ, если число четное.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЕНЕЧЁТ(число)

Число - это проверяемое значение. Если число не целое, то производится усечение.

Замечания

Если аргумент число не является числом, то функция ЕНЕЧЁТ возвращает значение ошибки #ЗНАЧ!.

Примеры

ЕНЕЧЁТ(-1) равняется ИСТИНА

ЕНЕЧЁТ(2,5) равняется ЛОЖЬ

ЕНЕЧЁТ(5) равняется ИСТИНА


ЕЧЁТН

См. также

Возвращает значение ИСТИНА, если число четно и значение ЛОЖЬ, если число нечетно.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЕЧЁТН(число)

Число - это проверяемое значение. Если число не целое, то производится усечение.

Замечания

Если аргумент число не является числом, то функция ЕЧЁТН возвращает значение ошибки #ЗНАЧ!.

Примеры

ЕЧЁТН(-1) равняется ЛОЖЬ

ЕЧЁТН(2,5) равняется ИСТИНА

ЕЧЁТН(5) равняется ЛОЖЬ


ИНФОРМ

См. также

Возвращает информацию о текущей операционной среде.

Синтаксис

ИНФОРМ(тип_инфо)

Тип_инфо - это текст, задающий тип возвращаемой информации.

Тип_инфо | Возвращаемое значение
"directory" | Путь текущего каталога
"memavail" | Количество свободной памяти в байтах
"memused" | Количество памяти, используемой для данных
"numfile" | Количество активных рабочих листов
"origin" | Абсолютная ссылка в стиле A1 в виде текста, с префиксом "$A:" для совместимости с пакетом Lotus 1-2-3 версий 3.x. Возвращается ссылка на самую левую верхнюю видимую в окне ячейку с учетом текущего состояния прокрутки.
"osversion" | Текущая версия операционной системы в виде текста
"recalc" | Текущий режим повторного вычисления; возвращается "Автоматически" или "Вручную"
"release" | Версия Microsoft Excel в виде текста
"system" | Название операционной среды:
 | Macintosh = "mac"
 | Windows = "pcdos"
"totmem" | Общее количество доступной памяти в байтах, включая уже используемую

Примеры

Следующая формула возвращает 2, если в текущий момент открыты два рабочих листа:

ИНФОРМ("numfile")


НД

См. также

Возвращает значение ошибки #Н/Д. #Н/Д - это значение ошибки, которое означает, что "нет доступного значения". Функция НД используется для пометки пустых ячеек. Если ввести #Н/Д в ячейки, в которых отсутствует информация, то можно избежать проблем, связанных с непреднамеренным включением пустых ячеек в вычисления. (Если формула ссылается на ячейку, содержащую #Н/Д, то формула возвращает значение ошибки #Н/Д.)

Синтаксис

НД( )

Замечания

  • Пустые скобки после наименования функции обязательны. В противном случае Microsoft Excel не сможет распознать имя функции.

  • Можно непосредственно вводить значение #Н/Д в ячейку. Функция НД в основном служит для совместимости с другими системами электронных таблиц.


СЧИТАТЬПУСТОТЫ

См. также

Подсчитывает количество пустых ячеек в заданном интервале.

Синтаксис

СЧИТАТЬПУСТОТЫ(интервал)

Интервал - это интервал, в котором требуется подсчитать количество пустых ячеек.

Замечания

Ячейки с формулами, которые возвращают значение "" (пустой текст), учитываются при подсчете. Ячейки с нулевыми значениями не учитываются.

Пример

Пусть в рассмотренном выше рабочем листе ячейка B3 содержит следующую формулу: ЕСЛИ(C3<30;"";C3), которая возвращает "" (пустой текст). Тогда

СЧИТАТЬПУСТОТЫ(B2:C5) равняется 2


ТИП

См. также

Возвращает тип значения. Функция ТИП используется, когда результаты вычисления другой функции зависят от типа значения в конкретной ячейке.

Синтаксис

ТИП(значение)

Значение — это любое допустимое значение Microsoft Excel, например, число, текст, логическое значение и т. д.

Если значение является | то функция ТИП возвращает
Числом | 1
Текстом | 2
Логическим значением | 4
Значением ошибки | 16
Массивом | 64

Замечания

  • Функция ТИП особенно полезна, когда используются такие функции, как АРГУМЕНТ и ВВОД, которые допускают данные различных типов. Функция ТИП используется для выяснения того, какой тип данных был возвращен функцией.

  • Функцию ТИП нельзя использовать для определения наличия формулы в ячейке. ТИП только определяет тип результирующего (или отображаемого) значения. Если значение является ссылкой на ячейку, содержащую формулу, ТИП возвращает тип результата вычисления формулы.

Примеры

Если ячейка A1 содержит текст "Кузнецов", то:

ТИП(A1) равняется ТИП("Кузнецов") равняется 2

ТИП("Г-н "&A1) равняется 2

ТИП(2+A1) равняется ТИП(#ЗНАЧ!) равняется 16

ТИП({1;2:3;4}) равняется 64


ТИП.ОШИБКИ

См. также

Возвращает номер, соответствующий одному из возможных ошибочных значений в Microsoft Excel, или значение ошибки #Н/Д, если ошибка отсутствует. Функция ТИП.ОШИБКИ может быть использована в функции ЕСЛИ для проверки значения ошибки и возврата строки текста вместо соответствующего значения ошибки.

Синтаксис

ТИП.ОШИБКИ(значение_ошибки)

Значение_ошибки — это значение ошибки, для которого определяется номер. Хотя значение_ошибки и может быть фактическим значением ошибки, обычно это бывает ссылка на ячейку, содержащую формулу, значение которой необходимо проверить.

Значение_ошибки | Возвращаемый номер
#ПУСТО! | 1
#ДЕЛ/0! | 2
#ЗНАЧ! | 3
#ССЫЛ! | 4
#ИМЯ? | 5
#ЧИСЛО! | 6
#Н/Д | 7
Любое другое | #Н/Д

Пример

Приведенная ниже формула проверяет ячейку E50 для проверки не содержит ли ячейка значение ошибки #ПУСТО! или #ДЕЛ/0!. Если содержит, то номер значения ошибки используется в функции ВЫБОР для отображения одного из двух сообщений , в противном случае возвращается значение ошибки #Н/Д.

ЕСЛИ(ТИП.ОШИБКИ(E50)<3;ВЫБОР(ТИП.ОШИБКИ(E50);"Диапазоны не пересекаются";"Делитель равен нулю"))


Функции проверки типа

См. также

Этот раздел описывает девять функций рабочего листа, которые используются для проверки типа значения или ссылки.

Каждая из этих функций проверяет тип значения и возвращает значение ИСТИНА или ЛОЖЬ в зависимости от типа. Например, функция ЕПУСТО возвращает логическое значение ИСТИНА, если проверяемое значение является ссылкой на пустую ячейку; в противном случае возвращается логическое значение ЛОЖЬ.

Синтаксис

ЕПУСТО(значение)
ЕОШ(значение)
ЕОШИБКА(значение)
ЕЛОГИЧ(значение)
ЕНД(значение)
ЕНЕТЕКСТ(значение)
ЕЧИСЛО(значение)
ЕССЫЛКА(значение)
ЕТЕКСТ(значение)

Значение - это проверяемое значение. Значение может быть пустой ячейкой, значением ошибки, логическим значением, текстом, числом, ссылкой или именем объекта любого из перечисленных типов.

Операция | Возвращает ИСТИНА, если
ЕПУСТО | Значение ссылается на пустую ячейку.
ЕОШ | Значение ссылается на любое значение ошибки, кроме #Н/Д.
ЕОШИБКА | Значение ссылается на любое значение ошибки (#Н/Д, #ЗНАЧ! , #ССЫЛ! , #ДЕЛ/0! , #ЧИСЛО! , #ИМЯ? или #ПУСТО!).
ЕЛОГИЧ | Значение ссылается на логическое значение.
ЕНД | Значение ссылается на значение ошибки #Н/Д (значение недоступно).
ЕНЕТЕКСТ | Значение ссылается на любой элемент, который не является текстом. (Заметим, что функция возвращает ИСТИНА, если значение ссылается на пустую ячейку.)
ЕЧИСЛО | Значение ссылается на число.
ЕССЫЛКА | Значение ссылается на ссылку.
ЕТЕКСТ | Значение ссылается на текст.

Замечания

  • Аргумент этих функций не преобразуется. Для большинства других функций, например, если в качестве аргумента требуется число, то текстовое значение "19" преобразуется в число 19. Однако, в формуле ЕЧИСЛО("19"), "19" не преобразуется из текста в число, и функция ЕЧИСЛО возвращает значение ЛОЖЬ.

  • Эти функции полезны в формулах и макросах для проверки результатов вычислений. Комбинируя эти функции с функцией ЕСЛИ, можно локализовать ошибки в формулах (см. следующие примеры).

Примеры

ЕЛОГИЧ(ИСТИНА) равняется ИСТИНА

ЕЛОГИЧ("ИСТИНА") равняется ЛОЖЬ

ЕЧИСЛО(4) равняется ИСТИНА

Предположим, что на рабочем листе, который описывает цены на золото в различных регионах, ячейки C1:C5 содержат следующие текстовые, числовые значения и значения ошибок: "Золото", "Регион1", #ССЫЛ! , 330,92 руб. и #Н/Д соответственно.

ЕПУСТО(C1) равняется ЛОЖЬ

ЕОШИБКА(C3) равняется ИСТИНА

ЕНД(C3) равняется ЛОЖЬ

ЕНД(C5) равняется ИСТИНА

ЕОШ(C5) равняется ЛОЖЬ

ЕЧИСЛО(C4) равняется ИСТИНА (если значение 330,92 руб. было введено как число, а не как текст)

ЕССЫЛКА(Регион1) равняется ИСТИНА (если Регион1 определено как имя интервала)

ЕТЕКСТ(C2) равняется ИСТИНА (если Регион1 отформатировано как текст)

Предположим, что в другом рабочем листе требуется вычислить среднее диапазона A1:A4, но нет уверенности в том, что ячейки содержат числа. Формула СРЗНАЧ(A1:A4) возвращает значение ошибки #ДЕЛ/0! , если интервал A1:A4 не содержит чисел. Применительно к этому случаю, можно использовать следующую формулу для локализации потенциальной ошибки:

ЕСЛИ(ЕОШИБКА(СРЗНАЧ(A1:A4));"Нет чисел";СРЗНАЧ(A1:A4))


Ч

См. также

Возвращает значение, преобразованное в число.

Синтаксис

Ч(значение)

Значение — это значение, которое необходимо преобразовать. Функция Ч преобразует значения, приведенные в таблице.

Аргумент значение равен или ссылается на | Возвращаемое значение
Число | Это же число
Дата в одном из встроенных форматов Microsoft Excel | Указанная дата в числовом формате
ИСТИНА | 1
ЛОЖЬ | 0
Значение ошибки, например #ДЕЛ/0! | Значение ошибки
Любое другое | 0

Замечания

  • В общем случае нет необходимости использовать функцию Ч в формулах, поскольку Microsoft Excel в случае необходимости автоматически преобразует значения. Эта функция предназначена для совместимости с другими программами электронных таблиц.

  • Excel хранит даты как целые числа и может выполнять над ними вычисления. Если в книге используется система дат 1900, в числовом формате Excel хранит 1 января 1900 г. как 1. Если в книге используется система дат 1904, в числовом формате Excel хранит 1 января 1904 г. как 0 (в числовом формате 2 января 1904 г. — это 1). Например, в системе дат 1900 Excel хранит в числовом формате 1 января 1998 г. как 35796, так как между этим днем и 1 января 1900 г. прошло 35795 дней. Хранение даты и времени в Microsoft Excel.

Примеры

Если ячейка A1 содержит "7", A2 — "Четный", а A3 — "ИСТИНА", то:

Ч(A1) равняется 7

Ч(A2) равняется 0, поскольку A2 содержит текст

Ч(A3) равняется 1, поскольку A3 содержит ИСТИНА

Ч("7") равняется 0, поскольку "7" является текстом

Ч("4/17/91") равняется 0, поскольку "4/17/91" является текстом


ЯЧЕЙКА

См. также

Возвращает информацию о форматировании, положении или содержимом левого верхнего угла в ссылке.

Синтаксис

ЯЧЕЙКА(тип_информации,ссылка)

Тип_информации — это текстовое значение, задающее требуемый тип информации о ячейке. Приведенный ниже список показывает возможные значения аргумента тип_информации и соответствующие результаты.

Тип_информации | Возвращаемое значение
"Адрес" | Ссылка на первую ячейку в аргументе ссылка в виде текстовой строки.
"столбец" | Номер столбца ячейки в аргументе ссылка.
"цвет" | 1, если ячейка изменяет цвет при выводе отрицательных значений; во всех остальных случаях — 0 (ноль).
"содержимое" | Содержимое левой верхней ячейки в аргументе ссылка.
"имяфайла" | Имя файла (включая полный путь), который содержит ссылку, в виде текстовой строки. Если лист, содержащий ссылку, еще не был сохранен, возвращается пустая строка ("").
"формат" | Текстовое значение, соответствующее числовому формату ячейки. Значения для различных форматов показаны в приведенной ниже таблице. Если ячейка изменяет цвет при выводе отрицательных значений, в конце текстового значения добавляется "-". Если положительные или все числа отображаются в круглых скобках, конце текстового значения добавляется "()".
"скобки" | 1, если положительные или все числа отображаются в круглых скобках; во всех остальных случаях — 0 (ноль).
"префикс" | Текстовое значение, соответствующее префиксу метки ячейки. Символ одиночной кавычки (') соответствует тексту, выровненному влево, двойные кавычки (") — тексту, выровненному вправо, знак вставки (^) — тексту, выровненному по центру, обратная косая черта (\) — тексту с заполнением и пустой текст ("") — любому другому содержимому ячейки.
"защита" | 0, если ячейка разблокирована ,и 1, если ячейка заблокирована.
"строка" | Номер строки ячейки в аргументе ссылка.
"тип" | Текстовое значение, соответствующее типу данных в ячейке. Пустой ячейке соответствует "b", текстовой константе в ячейке соответствует "l" и "v" — любому другому значению в ячейке.
"ширина" | Ширина столбца ячейки, округленная до целого. Единица измерения равна ширине одного символа для шрифта стандартного размера.

Ссылка — это ячейка, информацию о которой необходимо получить. Если аргумент опущен, возвращается требуемая информация о последней измененной ячейке.

Приведенный ниже список описывает текстовые значения, возвращаемые функцией ЯЧЕЙКА, если аргумент тип_информации равен "формат", а ячейка форматирована встроенным числовым форматом.

Формат Microsoft Excel | Значение, возвращаемое функцией ЯЧЕЙКА
Общий | "G"
0 | "F0"
#,##0 | ",0"
0.00 | "F2"
#,##0.00 | ",2"
$#,##0_);($#,##0) | "C0'
$# ##0_);[Красный]($# ##0) | "C0-"
$#,##0.00_);($#,##0.00) | "C2"
$# ##0,00_);[Красный]($# ##0,00) | "C2-"
0% | "P0"
0.00% | "P2"
0,00E+00 | "S2"
# ?/? или # ??/?? | "G"
д.м.гг или ДД.ММ.ГГ ч:мм или дд.мм.гг | "D1"
Д МММ ГГ или ДД МММ ГГ | "D1"
д.м или дд.ммм или Д МММ | "D2"
ммм.гг или ммм.гггг или МММ ГГ или МММ ГГГГ | "D3"
дд.мм | "D1"
ч:мм AM/PM | "D7"
ч:мм:сс AM/PM | "D6"
ч:мм | "D9"
ч:мм:сс | "D8"

Если аргумент тип_информации функции ЯЧЕЙКА равен "формат", а формат ячейки был изменен, необходимо пересчитать лист для обновления значения функции.

Замечания

Функция ЯЧЕЙКА обеспечивает совместимость с другими программами электронных таблиц.

Примеры

ЯЧЕЙКА("сторока";A20) равняется 20

Если ячейка B12 имеет формат "д ммм", то:

ЯЧЕЙКА("формат";B12) равняется "D2"

Если A3 содержит "Всего", то:

ЯЧЕЙКА("содержимое"; A3) равняется "ВСЕГО"


ЕСЛИ

См. также

Возвращает одно значение, если заданное условие при вычислении дает значение ИСТИНА, и другое значение, если ЛОЖЬ.

Функция ЕСЛИ используется при проверке условий для значений и формул.

Синтаксис

ЕСЛИ(лог_выражение;значение_если_истина;значение_если_ложь)

Лог_выражение — это любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. Например, A10=100 — это логическое выражение; если значение в ячейке A10 равно 100, то выражение принимает значение ИСТИНА. В противном случае — ЛОЖЬ. Этот аргумент может быть использован в любом операторе сравнения.

Значение_если_истина — это значение, которое возвращается, если лог_выражение равно ИСТИНА. Например, если этот аргумент — строка "В пределах бюджета" и лог_выражение равно ИСТИНА, тогда функция ЕСЛИ отобразит текст "В пределах бюджета". Если лог_выражение равно ИСТИНА, а значение_если_истина пусто, то возвращается значение 0. Чтобы отобразить слово ИСТИНА, необходимо использовать логическое значение ИСТИНА для этого аргумента. Значение_если_истина может быть формулой.

Значение_если_ложь — это значение, которое возвращается, если лог_выражение равно ЛОЖЬ. Например, если этот аргумент — строка "Превышение бюджета" и лог_выражение равно ЛОЖЬ, то функция ЕСЛИ отобразит текст "Превышение бюджета". Если лог_выражение равно ЛОЖЬ, а значение_если_ложь опущено (то есть после значение_если_истина нет точки с запятой), то возвращается логическое значение ЛОЖЬ. Если лог_выражение равно ЛОЖЬ, а значение_если_ложь пусто (то есть после значение_если_истина стоит точка с запятой с последующей закрывающей скобкой), то возвращается значение 0. Значение_если_ложь может быть формулой.

Замечания

  • До 7 функций ЕСЛИ могут быть вложены друг в друга в качестве значений аргументов значение_если_истина и значение_если_ложь для конструирования более сложных проверок. См. последний из приведенных ниже примеров.

  • Когда значения аргументов значение_если_истина и значение_если_ложь вычислены, функция ЕСЛИ возвращает полученное значение.

  • Если любой из аргументов функции ЕСЛИ является массивом, все элементы массива вычисляются при выполнении функции ЕСЛИ.

  • Microsoft Excel предлагает дополнительные функции, которые можно применять для анализа данных с использованием условий. Например, для вычисления числа появлений текстовой строки или числа в диапазоне ячеек используйте функцию СЧЁТЕСЛИ. Для вычисления суммы значений, попадающих в интервал, заданный текстовой строкой или числами, используйте функцию СУММАЕСЛИ. Вычисление значений с использованием условия.

Примеры

На листе бюджетного отчета ячейка A10 содержит формулу для расчета текущего бюджете. Если результат вычислений по формуле в ячейке A10 меньше или равен 100, то приведенная ниже функция отображает "В пределах бюджета". В противном случае функция отображает "Превышение бюджета".

ЕСЛИ(A10<=100;"В пределах бюджета";"Превышение бюджета")

В следующем примере, если значение ячейки A10 — 100, то лог_выражение имеет значение ИСТИНА и вычисляется сумма для ячеек B5:B15. В противном случае лог_выражение имеет значение ЛОЖЬ и возвращается пустой текст (""), очищающий ячейку, которая содержит функцию ЕСЛИ.

ЕСЛИ(A10=100;СУММ(B5:B15);"")

Предположим, что рабочий лист по расходам содержит в ячейках B2:B4 фактические расходы за январь, февраль, март: 1500, 500 и 500 соответственно. Ячейки C2:C4 содержат данные по предполагаемым расходам за те же периоды: 900, 900 и 925.

Можно написать формулу для проверки соответствия бюджету расходов определенного месяца, генерируя тексты сообщений с помощью следующих формул:

ЕСЛИ(B2>C2;"Превышение бюджета";"OK") равняется "Превышение бюджета"

ЕСЛИ(B3>C3;"Превышение бюджета";"OK") равняется "OK"

Предположим, что нужно назначить буквенную категорию числам, на которые ссылаются по имени «СреднийБалл». Категории приведены в следующей таблице.

СреднийБалл | Категория
Больше 89 | A
От 80 до 89 | B
От 70 до 79 | C
От 60 до 69 | D
Меньше 60 | F

Тогда можно использовать вложенные функции ЕСЛИ:

ЕСЛИ(СреднийБалл>89;"A";ЕСЛИ(СреднийБалл>79;"B";
ЕСЛИ(СреднийБалл>69;"C";ЕСЛИ(СреднийБалл>59;"D";"F"))))

В предыдущем примере второе предложение ЕСЛИ является в то же время аргументом значение_если_ложь для первого предложения ЕСЛИ. Аналогично, третье предложение ЕСЛИ является аргументом значение_если_ложь для второго предложения ЕСЛИ. Например, если первое лог_выражение (Среднее>89) имеет значение ИСТИНА, то возвращается значение "A". Если первое лог_выражение имеет значение ЛОЖЬ, то вычисляется второе предложение ЕСЛИ и так далее.


И

См. также

Возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА; возвращает значение ЛОЖЬ, если хотя бы один аргумент имеет значение ЛОЖЬ.

Синтаксис

И(логическое_значение1; логическое_значение2; ...)

Логическое_значение1, логическое_значение2, ... — это от 1 до 30 проверяемых условий, которые могут иметь значение либо ИСТИНА, либо ЛОЖЬ.

  • Аргументы должны быть логическими значениями, массивами или ссылками, которые содержат логические значения.

  • Если аргумент, который является ссылкой или массивом, содержит тексты или пустые ячейки, то такие значения игнорируются.

  • Если указанный интервал не содержит логических значений, то И возвращает значение ошибки #ЗНАЧ!.

Примеры

И(ИСТИНА; ИСТИНА) равняется ИСТИНА

И(ИСТИНА; ЛОЖЬ) равняется ЛОЖЬ

И(2+2=4; 2+3=5) равняется ИСТИНА

Если интервал B1:B3 содержит значения ИСТИНА, ЛОЖЬ, и ИСТИНА, то:

И(B1:B3) равняется ЛОЖЬ

Если ячейка B4 содержит число между 1 и 100, то:

И(1<B4; B4<100) равняется ИСТИНА

Предположим, что нужно вывести на экран содержимое ячейки B4, если она содержит число строго между 1 и 100 и сообщение "Значение вне интервала" в противном случае. Тогда, если ячейка B4 содержит число 104, то выражение:

ЕСЛИ(И(1<B4; B4<100); B4; "Значение вне интервала") равняется "Значение вне интервала",

а если ячейка B4 содержит 50, то:

ЕСЛИ(И(1<B4; B4<100); B4; "Значение вне интервала") равняется 50


ИЛИ

См. также

Возвращает ИСТИНА, если хотя бы один из аргументов имеет значение ИСТИНА; возвращает ЛОЖЬ, если все аргументы имеют значение ЛОЖЬ.

Синтаксис

ИЛИ(логическое_значение1;логическое_значение2; ...)

Логическое_значение1, логическое_значение2, ... — это от 1 до 30 проверяемых условий, которые могут иметь значение либо ИСТИНА, либо ЛОЖЬ.

  • Аргументы должны принимать логические значения (ИСТИНА или ЛОЖЬ) или быть массивами или ссылками, которые содержат логические значения.

  • Если аргумент, который является ссылкой или массивом, содержит тексты или пустые ячейки, то такие значения игнорируются.

  • Если заданный интервал не содержит логических значений, то функция ИЛИ возвращает значение ошибки #ЗНАЧ!.

  • Можно использовать функцию ИЛИ как формулу массива, чтобы проверить, имеются ли значения в массиве. Для того, чтобы ввести формулу массива, нажмите CTRL+SHIFT в Microsoft Excel для Windows или COMMAND +ENTER в Microsoft Excel для Макинтош.

Примеры

ИЛИ(ИСТИНА) равняется ИСТИНА

ИЛИ(1+1=1;2+2=5) равняется ЛОЖЬ

Если ячейки A1:A3 содержат значения ИСТИНА, ЛОЖЬ и ИСТИНА, то:

ИЛИ(A1:A3) равняется ИСТИНА

См. также пример для функции СОВПАД.


ИСТИНА

См. также

Возвращает логическое значение ИСТИНА.

Синтаксис

ИСТИНА( )

Замечания

Можно непосредственно ввести значение ИСТИНА в ячейки и формулы без использования этой функции. Функция ИСТИНА предназначена для совместимости с другими системами электронных таблиц.


ЛОЖЬ

См. также

Возвращает логическое значение ЛОЖЬ.

Синтаксис

ЛОЖЬ( )

Замечания

Можно непосредственно ввести слово ЛОЖЬ в рабочий лист или в формулу, и Microsoft Excel будет интерпретировать его как логическое значение ЛОЖЬ.


НЕ

См. также

Меняет на противоположное логическое значение своего аргумента. Функция НЕ используется в тех случаях, когда необходимо быть уверенным в том, что значение не равно некоторой конкретной величине.

Синтаксис

НЕ(логическое_значение)

Логическое_значение - это значение или выражение, которое при вычислении дает ИСТИНА или ЛОЖЬ. Если логическое_значение имеет значение ЛОЖЬ, то функция НЕ возвращает значение ИСТИНА; если логическое_значение имеет значение ИСТИНА, то функция НЕ возвращает значение ЛОЖЬ.

Примеры

НЕ(ЛОЖЬ) равняется ИСТИНА

НЕ(1+1=2) равняется ЛОЖЬ


АДРЕС

См. также

Создает адрес ячейки в виде текста, используя номер строки и номер столбца.

Синтаксис

АДРЕС(номер_строки;номер_столбца;тип_ссылки;а1;имя_листа)

Номер_строки - это номер строки, используемый в ссылке ячейки.

Номер_столбца - это номер столбца, используемый в ссылке ячейки.

Тип_ссылки - это задание типа возвращаемой ссылки.

Тип_ссылки | Возвращаемый тип ссылки
1 или опущен | Абсолютный
2 | Абсолютная строка; относительный столбец
3 | Относительная строка; абсолютный столбец
4 | Относительный

А1 - это логическое значение, которое определяет стиль ссылок: А1 или С1К1. Если а1 имеет значение ИСТИНА или опущено, то функция АДРЕС возвращает ссылку в стиле А1; если этот аргумент имеет значение ЛОЖЬ, то функция АДРЕС возвращает ссылку в стиле С1К1.

Имя_листа - это текст, определяющий имя рабочего листа, который используется для формирования внешней ссылки. Если имя_листа опущено, то внешние листы не используются.

Примеры

АДРЕС(2;3) равняется "$C$2"

АДРЕС(2;3;2) равняется "C$2"

АДРЕС(2;3;2;ЛОЖЬ) равняется "С2К[3]"

АДРЕС(2;3;1;ЛОЖЬ;"[Book1]Лист1") равняется "[Book1]Лист1!С2К3"

АДРЕС(2;3;1;ЛОЖЬ;"EXCEL SHEET") равняется "'EXCEL SHEET'!С2К3"


ВПР

См. также

Ищет значение в крайнем левом столбце таблицы и возвращает значение в той же строке из указанного столбца таблицы. Функция ВПР используется вместо функции ГПР, когда сравниваемые значения расположены в столбце слева от искомых данных.

Синтаксис

ВПР(искомое_значение;инфо_таблица;номер_столбца;интервальный_просмотр)

Искомое_значение - это значение, которое должно быть найдено в первом столбце массива. Искомое_значение может быть значением, ссылкой или текстовой строкой.

Инфо_таблица - это таблица с информацией, в которой ищутся данные. Можно использовать ссылку на интервал или имя интервала, например, БазаДанных или Список.

  • Если интервальный_просмотр имеет значение ИСТИНА, то значения в первом столбце аргумента инфо_таблица должны быть расположены в возрастающем порядке: ..., -2, -1, 0, 1, 2, ..., A-Z, ЛОЖЬ, ИСТИНА; в противном случае функция ВПР может выдать неправильный результат. Если интервальный_просмотр имеет значение ЛОЖЬ, то инфо_таблица не обязана быть сортированной.

  • Данные можно упорядочить следующим образом: в меню Данные выбрать команду Сортировка и установить переключатель По Возрастанию.

  • Значения в первом столбце аргумента инфо_таблица могут быть текстами, числами или логическими значениями.

  • Регистр не учитывается (т. е. строчные и заглавные буквы не различаются).

Номер_столбца - это номер столбца в массиве инфо_таблица, в котором должно быть найдено соответствующее значение. Если номер_столбца равен 1, то возвращается значение из первого столбца аргумента инфо_таблица; если номер_столбца равен 2, то возвращается значение из второго столбца аргумента инфо_таблица и так далее. Если номер_столбца меньше 1, то функция ВПР возвращает значение ошибки #ЗНАЧ!; если номер_столбца больше, чем количество столбцов в аргументе инфо_таблица, то функция ВПР возвращает значение ошибки #ССЫЛ!.

Интервальный_просмотр - это логическое значение, которое определяет, нужно ли, чтобы ВПР искала точное или приближенное соответствие. Если этот аргумент имеет значение ИСТИНА или опущен, то возвращается приблизительно соответствующее значение; другими словами, если точное соответствие не найдено, то возвращается наибольшее значение, которое меньше, чем искомое_значение. Если этот аргумент имеет значение ЛОЖЬ, то функция ВПР ищет точное соответствие. Если таковое не найдено, то возвращается значение ошибки #Н/Д.

Замечания

  • Если ВПР не может найти искомое_значение и интервальный_просмотр имеет значение ИСТИНА, то используется наибольшее значение, которое меньше, чем искомое_значение.

  • Если искомое_значение меньше, чем наименьшее значение в первом столбце аргумента инфо_таблица, то функция ВПР возвращает значение ошибки #Н/Д.

  • Если ВПР не может найти искомое_значение и интервальный_просмотр имеет значение ЛОЖЬ, то ВПР возвращает значение ошибки #Н/Д.

Примеры

На приведенном рабочем листе, где интервал A4:C12 имеет имя Интервал:

ВПР(1;Интервал;1;ИСТИНА) равняется 0,946

ВПР(1;Интервал;2) равняется 2,17

ВПР(1;Интервал;3;ИСТИНА) равняется 100

ВПР(0,746;Интервал;3;ЛОЖЬ) равняется 200

ВПР(0,1;Интервал;2;ИСТИНА) равняется #Н/Д, поскольку 0,1 меньше, чем наименьшее значение в столбце A

ВПР(2;Интервал;2;ИСТИНА) равняется 1,71


ВЫБОР

См. также

Использует номер_индекса, чтобы выбрать и вернуть значение из списка аргументов-значений. Функция ВЫБОР используется, чтобы выбрать одно значение из списка, в котором может быть до 29 значений. Например, если значения от значение1 до значение7 — это дни недели, то функция ВЫБОР возвращает один из дней при использовании числа от 1 до 7 в качестве аргумента номер_индекса.

Синтаксис

ВЫБОР(номер_индекса;значение1;значение2;…)

Номер_индекса — это номер выбираемого аргумента-значения. Номер_индекса должен быть числом от 1 до 29, формулой или ссылкой на ячейку, содержащую число в диапазоне от 1 до 29.

  • Если номер_индекса равен 1, то функция ВЫБОР возвращает значение1; если он равен 2, то функция ВЫБОР возвращает значение2 и так далее.

  • Если номер_индекса меньше 1 или больше, чем номер последнего значения в списке, то функция ВЫБОР возвращает значение ошибки #ЗНАЧ!.

  • Если номер_индекса является дробным, то он усекается до меньшего целого.

Значение1, значение2 ... — это от 1 до 29 аргументов-значений, из которых ВЫБОР, используя номер_индекса, выбирает значение или выполняемое действие. Аргументы могут быть числами, ссылками на ячейки, именами, формулами, функциями или текстами.

Замечания

  • Если номер_индекса является массивом, то каждое значение вычисляется при выполнении функции ВЫБОР.

  • Аргументы-значения функции ВЫБОР могут быть как ссылками на интервал, так и отдельными значениями. Например, формула:

    СУММ(ВЫБОР(2;A1:A10;B1:B10;C1:C10))

    эквивалентна формуле:

    СУММ(B1:B10),

    которая возвращает значение, вычисленное на основе значений в интервале ячеек B1:B10.

    В этом примере сначала вычисляется функция ВЫБОР, которая возвращает ссылку на интервал B1:B10. Затем вычисляется функция СУММ, используя интервал B1:B10, то есть результат функции ВЫБОР, в качестве своего аргумента.

Примеры

ВЫБОР(2;"1-ый";"2-ой";"3-ий";"Последний") равняется "2-ой"

СУММ(A1:ВЫБОР(3;A10;A20;A30)) равняется СУММ(A1:A30)

Если ячейка A10 содержит 4, то:

ВЫБОР(A10;"Гвозди";"Винты";"Гайки";"Болты") равняется "Болты"

Если A10-3 равняется 3, то:

ВЫБОР(A10-3;"1-ый";"2-ой";"3-ий";"Последний") равняется "3-ий"

Если ПрошлыеПродажи - это имя, ссылающееся на значение 10 000, то:

ВЫБОР(2;НовыеПродажи;ПрошлыеПродажи;БюджетПродаж) равняется 10 000


ГИПЕРССЫЛКА

См. также

Создает ярлык или переход, который открывает документ, расположенный на сетевом сервере, во внутренней сети или в Интернете. Если выбрать ячейку, содержащую функцию ГИПЕРССЫЛКА, и нажать левую кнопку мыши, Microsoft Excel 97 откроет файл, местоположение которого определено аргументом адрес.

Синтаксис

ГИПЕРССЫЛКА (адрес;имя)

Адрес — это путь и имя файла для открываемого документа. Аргумент представляет собой текст. Адрес может ссылаться на место в документе — например, на определенную ячейку или именованный интервал на листе книги Microsoft Excel или на закладку в документе Microsoft Word. Путь может представлять собой путь к файлу, записанному на жестком диске, может также адресом в формате UNC сервера (в Microsoft Excel для Windows) или адресом URL в Интернет или внутренней сети.

Имя — текст перехода или численное значение, отображаемое в ячейке. Имя отображается синим цветом и с линией подчеркивания. Если аргумент опущен, ячейка в качестве текста перехода отображает аргумент адрес.

Замечания

  • Аргумент адрес может быть заключенной в кавычки текстовой строкой или ячейкой, содержащей адрес ссылки в виде текстовой строки.

  • Аргумент имя может быть представлен значением, текстовой строкой, именем или ячейкой, содержащей текст или значение для перехода.

  • Если аргумент имя возвращает значение ошибки (например, #ЗНАЧ!), вместо текста перехода в ячейке отображается значение ошибки.

  • Если определенного аргументом адрес перехода не существует или переход не может быть выполнен, выбор соответствующей ячейки приводит к появлению сообщения об ошибке.

  • Для выделения ячейки, содержащей функцию ГИПЕРССЫЛКА, выберите мышью соседнюю с ней ячейку, нажмите клавишу стрелки для перехода к нужной ячейке.

Примеры

Ниже дается пример открытия листа бюджетного отчета "Budget Report.xls", находящегося в Интернете по адресу www.business.com/report, и отображения текста "Щелкните мышкой для получения отчета":

ГИПЕРССЫЛКА("http://www.business.com/report/budget report.xls";"Щелкните мышкой для получения отчета")

В следующем примере создается гиперссылка на ячейку F10 листа "Годовой" книги "Budget Report.xls", адрес которой в Интернете — www.business.com/report. В ячейке листа, содержащей гиперссылку, в качестве текста перехода отображается содержимое ячейки D1:

ГИПЕРССЫЛКА("[http://www.business.com/report/budget report.xls]Годовой!F10"; D1)

В следующем примере создается гиперссылка на интервал "Итоги_по_отделу" на листе "Первый квартал" рабочей книги "Budget Report.xls", адрес которой в Интернете — www.business.com/report. В ячейке листа, содержащей гиперссылку, отображается текст "Щелкните мышкой для вывода Итогов по отделу за первый квартал":

ГИПЕРССЫЛКА("[http://www.business.com/report/budget report.xls]Первый квартал!Итоги_по_отделу";"Щелкните мышкой для вывода Итогов по отделу за первый квартал")

Чтобы создать гиперссылку в определенное место документа Microsoft Word, необходимо сначала с помощью закладки определить место в документе, куда должен выполняться переход. В приведенном ниже примере формируется гиперссылка на закладку «КвартПриб» документа "Annual Report.doc", находящегося по адресу www.business.com:

ГИПЕРССЫЛКА("[http://www.business.com/Annual Report.doc]КвартПриб"; "Отчет о квартальной прибыли")

Следующий пример демонстрирует вывод в Microsoft Excel для Windows содержимого ячейки D5 как текста перехода и открытие файла "1stqtr.xls", расположенного на сервере FINANCE в каталоге общего доступа Statements. Данный пример использует адрес в формате UNC:

ГИПЕРССЫЛКА("\\FINANCE\Statements\1stqtr.xls"; D5)

В приведенном ниже примере в Microsoft Excel для Windows открывается файл "1stqtr.xls", который находится в каталоге Finance на жестком диске D, после чего выводится число, которое содержится в ячейке H10:

ГИПЕРССЫЛКА("D:\FINANCE\1stqtr.xls"; H10)

В следующем примере Excel для Windows создает гиперссылку на область «Итоги» в другой (внешней) книге Mybook.xls:

ГИПЕРССЫЛКА("[C:\My Documents\Mybook.xls]Итоги")

В следующем примере Microsoft Excel для Макинтош отображает "Щелкните здесь" в ячейке и открывает файл First Quarter из папки Budget Reports на жестком диске Macintosh HD:

ГИПЕРССЫЛКА("Macintosh HD:Budget Reports:First Quarter";"Щелкните здесь")

Гиперссылки можно создавать внутри листа для перехода от одной ячейки к другой. Например, если в книге Budget имя активного листа "Июнь", следующая формула создаст гиперссылку на ячейку E56. Текст перехода — это значение в ячейке E56.

ГИПЕРССЫЛКА("[Budget]Июнь!E56";E56)

Для перехода на другой лист в той же книге измените имя листа в ссылке. В предыдущем примере для создания ссылки на ячейку E56 на листе "Сентябрь" измените слово "Июнь" на слово "Сентябрь".


ГПР

См. также

Ищет значение в верхней строке таблицы или массива значений и возвращает значение в том же столбце из заданной строки таблицы или массива. Функция ГПР используется, когда сравниваемые значения расположены в верхней строке таблицы данных, а возвращаемые значения расположены на несколько срок ниже. Если сравниваемые значения расположены в столбце слева от искомых данных, то следует использовать функцию ВПР.

Синтаксис

ГПР(искомое_значение;инфо_таблица;номер_строки;интервальный_просмотр)

Искомое_значение - это значение, которое требуется найти в первой строке таблицы. Искомое_значение может быть значением, ссылкой или текстовой строкой.

Инфо_таблица - это таблица с информацией, в которой ищутся данные. Можно использовать ссылку на интервал или имя интервала.

  • Значения в первой строке аргумента инфо_таблица могут быть текстами, числами или логическими значениями.

  • Если интервальный_просмотр имеет значение ИСТИНА, то значения в первой строке аргумента инфо_таблица должны быть расположены в возрастающем порядке: ...-2, -1, 0, 1, 2,... , A-Z, ЛОЖЬ, ИСТИНА; в противном случае функция ГПР может выдать неправильный результат. Если интервальный_просмотр имеет значение ЛОЖЬ, то инфо_таблица не обязана быть сортированной.

  • Регистр не учитывается (т.е. строчные и заглавные буквы не различаются).

  • Данные можно упорядочить по возрастанию, слева направо. Для этого выделите эти данные, в меню Данные и выполните команду Сортировка. Нажмите кнопку Параметры и выберите столбцы диапазона. Нажмите кнопку ОК. В поле Сортировать по выберите строку в списке и установите переключатель по возрастанию.

Номер_строки - это номер строки в массиве инфо_таблица, из которой будет возвращено сопоставляемое значение. Если номер_строки равен 1, то возвращается значение из первой строки аргумента инфо_таблица, если номер_строки равен 2, то возвращается значение из второй строки аргумента инфо_таблица, и так далее. Если номер_строки меньше 1, то функция ГПР возвращает значение ошибки #ЗНАЧ!; если номер_строки больше, чем количество строк в аргументе инфо_таблица, то функция ГПР возвращает значение ошибки #ССЫЛ!.

Интервальный_просмотр - это логическое значение, которое определяет, нужно ли, чтобы функция ГПР искала точное или приближенное соответствие. Если этот аргумент имеет значение ИСТИНА или опущен, то возвращается приблизительно соответствующее значение; другими словами, если точное соответствие не найдено, то возвращается наибольшее значение, которое меньше, чем искомое_значение. Если этот аргумент имеет значение ЛОЖЬ, то функция ГПР ищет точное соответствие. Если таковое не найдено, то возвращается значение ошибки #Н/Д.

Замечания

  • Если ГПР не может найти искомое_значение и интервальный_просмотр имеет значение ИСТИНА, то используется наибольшее значение, которое меньше, чем искомое_значение.

  • Если искомое_значение меньше, чем наименьшее значение в первой строке аргумента инфо_таблица, то функция ГПР возвращает значение ошибки #Н/Д.

Примеры

Предположим, что имеется рабочий лист с перечнем автомобильных деталей. Ячейки A1:A4 содержат "Оси", 4, 5, 6. Ячейки B1:B4 содержат "Подшипники", 4, 7, 8. Ячейки C1:C4 содержат "Болты", 9, 10, 11.

ГПР("Оси"; A1:C4;2;ИСТИНА) равняется 4

ГПР("Подшипники";A1:C4;3;ЛОЖЬ) равняется 7

ГПР("Подшипники";A1:C4;3;ИСТИНА) равняется 7

ГПР("Болты";A1:C4;4;) равняется 11

Инфо_таблица может быть также массивом констант:

ГПР(3;{1;2;3:"а";"б";"в":"г";"д";"е"};2;ИСТИНА) равняется "в"


ДВССЫЛ

См. также

Возвращает ссылку, заданную текстовой строкой. Ссылки немедленно вычисляются для вывода их содержимого. Функция ДВССЫЛ используется, если требуется изменить ссылку на ячейку в формуле, не изменяя саму формулу.

Синтаксис

ДВССЫЛ(ссылка_на_ячейку;a1)

Ссылка_на_ячейку - это ссылка на ячейку, которая содержит либо ссылку в стиле А1, либо ссылку в стиле С1К1, либо имя, определенное как ссылка, либо ссылку на ячейку в виде текстовой строки. Если ссылка_на_ячейку не является допустимой ссылкой, то функция ДВССЫЛ возвращает значение ошибки #ССЫЛ!.

A1 - это логическое значение, указывающее, какого типа ссылка содержится в ячейке ссылка_на_текст.

  • Если a1 имеет значение ИСТИНА или опущена, то ссылка_на_ячейку интерпретируется как ссылка в стиле A1.

  • Если a1 имеет значение ЛОЖЬ, то ссылка_на_ячейку интерпретируется как ссылка в стиле С1К1.

Замечания

  • Если ссылка_на_ячейку является ссылкой на другую рабочую книгу (внешней ссылкой), другая рабочая книга должна быть открытой. Если это не так, функция ДВССЫЛ возвратит значение ошибки #ССЫЛКА!.

Примеры

Если ячейка A1 содержит текст "B2", а ячейка B2 содержит значение 1,333, то:

ДВССЫЛ($A$1) равняется 1.333

Если вы изменяете текст в ячейке A1 на "C5", а ячейка C5 содержит значение 45, то:

ДВССЫЛ($A$1) равняется 45

Если рабочее пространство настроено на вывод ссылок в стиле С1К1, и ячейка С1К1 содержит С2К2, а ячейка С2К2 содержит значение 1,333, то:

ЦЕЛОЕ(ДВССЫЛ(С1К1;ЛОЖЬ)) равняется 1

Если ячейка B3 содержит текст "Кира Давлетовна", а ячейка с этим именем содержит значение 10, то:

ДВССЫЛ($B$3) равняется 10

При создании формулы, содержащей ссылку на ячейку, ссылка на ячейку будет обновлена, если ячейка перемещалась с помощью команды Вырезать, использовавшейся для удаления ячейки или перемещение ячейки связано с вставкой или удалением строк или столбцов. Если требуется, чтобы формула ссылалась на одну и ту же ячейку, независимо от удаления расположенных над ячейкой строк или перемещения ячеек, используйте функцию рабочего листа ДВССЫЛ. Например, для подобной ссылки на ячейку A10 используйте следующий синтаксис:

ДВССЫЛ("A10")


ИНДЕКС

См. также

Возвращает значение или ссылку на значение из таблицы или интервала. Функция ИНДЕКС() имеет две синтаксические формы: ссылка и массив. Ссылочная форма всегда возвращает ссылку; форма массива всегда возвращает значение или массив значений.

  • ИНДЕКС(массив;номер_строки;номер_столбца) возвращает значение указанной ячейки или массив значений в аргументе массив.

  • ИНДЕКС(ссылка;номер_строки;номер_столбца;номер_области) возвращает ссылку на указанную ячейку или ячейки в аргументе ссылка.

Синтаксис 1 (массив)

Синтаксис 2 (ссылка)


ОБЛАСТИ

См. также

Возвращает количество областей в ссылке. Область - это интервал смежных ячеек или отдельная ячейка.

Синтаксис

ОБЛАСТИ(ссылка)

Ссылка - это ссылка на ячейку или интервал ячеек; может относиться к нескольким областям. Если нужно задать несколько ссылок как один аргумент, то следует использовать дополнительные пары скобок, с тем, чтобы Microsoft Excel не интерпретировал точку с запятой как разделитель аргументов. См. ниже второй пример.

Примеры

ОБЛАСТИ(B2:D4) равняется 1

ОБЛАСТИ((B2:D4;E5;F6:I9)) равняется 3

Если имя Цены ссылается на области B1:D4, B2 и E1:E10, то:

ОБЛАСТИ(Цены) равняется 3


ПОИСКПОЗ

См. также

Возвращает относительное положение элемента массива, который соответствует заданному значению указанным образом. Функция ПОИСКПОЗ используется вместо функций типа ПРОСМОТР, если нужна позиция элемента в диапазоне, а не сам элемент.

Синтаксис

ПОИСКПОЗ(Искомое_значение,просматриваемый_массив,тип_сопоставления)

Искомое_значение — это значение, используемое при поиске значения в таблице.

  • Искомое_значение — это значение, которое сопоставляется со значениями в аргументе просматриваемый_массив. Например, при поиске номера в телефонной книге имя абонента указывается в качестве искомого значения, а требуемым значением будет номер телефона.

  • Искомое_значение может быть значением (числом, текстом или логическим значением) или ссылкой на ячейку, содержащую число, текст или логическое значение.

Просматриваемый_массив - это непрерывный интервал ячеек, возможно, содержащих искомые значения. Просматриваемый_массив может быть массивом или ссылкой на массив.

Тип_сопоставления - это число -1, 0 или 1. Тип_сопоставления указывает, как Microsoft Excel сопоставляет искомое_значение со значениями в аргументе просматриваемый_массив.

  • Если тип_сопоставления равен 1, то функция ПОИСКПОЗ находит наибольшее значение, которое равно или меньше, чем искомое_значение. Просматриваемый_массив должен быть упорядочен по возрастанию: ..., -2, -1, 0, 1, 2, ..., A-Z, ЛОЖЬ, ИСТИНА.

  • Если тип_сопоставления равен 0, то функция ПОИСКПОЗ находит первое значение, которое в точности равно аргументу искомое_значение. Просматриваемый_массив может быть в любом порядке.

  • Если тип_сопоставления равен -1, то функция ПОИСКПОЗ находит наименьшее значение, которое равно и больше чем искомое_значение. Просматриваемый_массив должен быть упорядочен по убыванию: ИСТИНА, ЛОЖЬ, Z-A, ..., 2, 1, 0, -1, -2, ..., и так далее.

  • Если тип_сопоставления опущен, то предполагается, что он равен 1.

Замечания

  • ПОИСКПОЗ возвращает позицию соответствующего значения в аргументе просматриваемый_массив, а не само значение. Например: ПОИСКПОЗ("б";{"а";"б";"в"};0) возвращает 2 -- относительную позицию буквы "б" в массиве {"а";"б";"в"}.

  • ПОИСКПОЗ не различает регистры при сопоставлении текстов.

  • Если функция ПОИСКПОЗ не находит соответствующего значения, то возвращается значение ошибки #Н/Д.

  • Если тип_сопоставления равен 0 и искомое_значение является текстом, то искомое_значение может содержать символы шаблона, звездочка (*) и знак вопроса (?). Звездочка соответствует любой последовательности символов, знак вопроса соответствует любому одиночному символу.

Примеры

Заметим, что ячейки C2:C8 содержат текст, отформатированный как проценты.

В предшествующем рабочем листе:

ПОИСКПОЗ(39000;B2:B8;1) равняется 3

ПОИСКПОЗ(38000;B2:B8;0) равняется 2

ПОИСКПОЗ(39000;B2:B8;-1) равняется значению ошибки #Н/Д, поскольку интервал B2:B8 неправильно упорядочен для значения аргумента тип_сопоставления, равного -1 (порядок должен быть убывающим для такого сопоставления).

Предположим, что имя Иена ссылается на ячейки A2:A8, имя ИенаДоллар ссылается на ячейки A2:C8, а имя МойДоход ссылается на ячейку, содержащую число 6 301 126,33. Тогда формула:

"Ваша ставка налога равняется "&ПРОСМОТР(МойДоход;ИенаДоллар)&", что относит Вас к категории налогоплательщиков номер "&ПОИСКПОЗ(МойДоход;Иена)&"."

выдает следующий результат:

"Ваша ставка налога равняется 22,41%, что относит Вас к категории налогоплательщиков номер 7."


ПРОСМОТР

См. также

Возвращает значение из строки, из столбца или из массива. Функция ПРОСМОТР имеет две синтаксические формы: вектор и массив. Векторная форма функции ПРОСМОТР просматривает диапазон, в который входят значения только одной строки или одного столбца (так называемый вектор) в поисках определенного значения и возвращает значение из другого столбца или строки. Форма массива функции ПРОСМОТР просматривает первую строку или первый столбец массива, находит указанное значение и возвращает значение из аналогичной позиции последней строки или столбца массива.

Синтаксис 1 (вектор)

Синтаксис 2 (массив)


СМЕЩ

См. также

Возвращает ссылку на диапазон, отстоящий от ячейки или диапазона ячеек на заданное число строк и столбцов Возвращаемая ссылка может быть отдельной ячейкой или диапазоном ячеек. Можно задавать количество возвращаемых строк и столбцов.

Синтаксис

СМЕЩ(ссылка;смещ_по_строкам;смещ_по_столбцам;высота;ширина)

Ссылка - это ссылка, от которой вычисляется смещение. Аргумент " ссылка" должен быть ссылкой на ячейку или на диапазон смежных ячеек, в противном случае функция СМЕЩ возвращает значение ошибки #ЗНАЧ!.

Смещ_по_строкам - это количество строк, которые нужно отсчитать вверх или вниз, так чтобы верхняя левая ячейка результата ссылалась на это место. Если задать, например, число 5 в качестве значения аргумента смещ_по_строкам, то тем самым указывается, что левая верхняя ячейка возвращаемой ссылки должна быть на пять строк ниже аргумента ссылка. Смещ_по_строкам может быть положительным (ниже начальной ссылки) или отрицательным (выше начальной ссылки).

Смещ_по_столбцам - это количество столбцов, которые нужно отсчитать влево или вправо, так чтобы левая верхняя ячейка результата ссылалась на это место. Если задать, например, число 5 в качестве значения аргумента смещ_по_столбцам, то тем самым указывается, что левая верхняя ячейка возвращаемой ссылки должна быть на пять столбцов правее аргумента ссылка. Смещ_по_столбцам может быть положительным (вправо от начальной ссылки) или отрицательным (влево от начальной ссылки).

Если смещ_по_строкам и смещ_по_столбцам выводят ссылку за границы рабочего листа, то функция СМЕЩ возвращает значение ошибки #ССЫЛ!.

Высота - это высота (число строк) возвращаемой ссылки. Высота должна быть положительным числом.

Ширина - это ширина (число столбцов) возвращаемой ссылки. Ширина должна быть положительным числом.

Если высота или ширина опущена, то предполагается, что используется такая же высота или ширина как в аргументе ссылка.

Замечания

СМЕЩ фактически не передвигает никаких ячеек и не меняет выделения; она только возвращает ссылку. Функция СМЕЩ может быть использована с любой функцией, в которой ожидается аргумент типа ссылка. Например, формула СУММ(СМЕЩ(C2,1,2,3,1)) вычисляет суммарное значение диапазона, состоящего из 3 строк и 1 столбца и расположенного 1 строкой ниже и 2 столбцами правее ячейки C2.

Примеры

СМЕЩ(C3;2;3;1;1) равняется F5. Если ввести эту формулу в рабочий лист, то Microsoft Excel выведет значение в ячейке F5.

СМЕЩ(C3:E5;-1;0;3;3) равняется C2:E4

СМЕЩ(C3:E5;0;-3;3;3) равняется #ССЫЛ!


СТОЛБЕЦ

См. также

Возвращает номер столбца по заданной ссылке.

Синтаксис

СТОЛБЕЦ(ссылка)

Ссылка - это ячейка или интервал ячеек, для которых определяется номер столбца.

  • Если ссылка опущена, то предполагается, что это ссылка на ячейку, в которой находится сама функция СТОЛБЕЦ.

  • Если ссылка является интервалом ячеек, и если функция СТОЛБЕЦ введена как горизонтальный массив, то функция СТОЛБЕЦ возвращает номера столбцов в ссылке в виде горизонтального массива.

  • Ссылка не может ссылаться на несколько областей.

Примеры

СТОЛБЕЦ(A3) равняется 1

При вводе в виде массива в любые три горизонтальные смежные ячейки:

СТОЛБЕЦ(A3:C5) равняется {1;2;3}

Если функция СТОЛБЕЦ введена в ячейку C5, то:

СТОЛБЕЦ() равняется СТОЛБЕЦ(C5) равняется 3


СТРОКА

См. также

Возвращает номер строки, определяемой ссылкой.

Синтаксис

СТРОКА(ссылка)

Ссылка - это ячейка или интервал ячеек, для которых определяется номер строки.

  • Если ссылка опущена, то предполагается, что это ссылка на ячейку, в которой находится сама функция СТРОКА.

  • Если ссылка является интервалом ячеек, и если функция СТРОКА введена как вертикальный массив, то функция СТРОКА возвращает номера строк в аргументе ссылка в виде вертикального массива.

  • Ссылка не может ссылаться на несколько областей.

Примеры

СТРОКА(A3) равняется 3

Когда эта функция вводится как формула массива в три вертикальные ячейки:

СТРОКА(A3:B5) равняется {3:4:5}

Если функция СТРОКА введена в ячейку C5, то:

СТРОКА() равняется СТРОКА(C5) равняется 5


ТРАНСП

См. также

Возвращает вертикальный диапазон ячеек в виде горизонтального и наоборот. Функция ТРАНСП должна быть введена как формула массива в интервал, который имеет столько же строк и столбцов, соответственно, сколько столбцов и строк имеет аргумент массив. Функция ТРАНСП используется для того, чтобы поменять ориентацию массива на рабочем листе с вертикальной на горизонтальную и наоборот. Например, некоторые функции, такие как ЛИНЕЙН, возвращают горизонтальные массивы. Функция ЛИНЕЙН возвращает горизонтальный массив, содержащий данные о наклоне прямой и ее пересечении с осью координат y. Следующая формула возвращает вертикальный массив, получаемый из горизонтального массива, возвращаемого функцией ЛИНЕЙН:

ТРАНСП(ЛИНЕЙН(ЗначенияY;ЗначенияX))

Синтаксис

ТРАНСП(массив)

Массив — это транспонируемый массив или диапазон ячеек на рабочем листе. Транспонирование массива заключается в том, что первая строка массива становится первым столбцом нового массива, вторая строка массива становится вторым столбцом нового массива и так далее.

Пример

Предположим, что ячейки A1:C1 содержат 1, 2 и 3 соответственно. Если следующая формула введена как формула массива в ячейки A3:A5, то:

ТРАНСП($A$1:$C$1) равняется тем же значениям 1, 2, 3 в ячейках A3:A5


ЧИСЛСТОЛБ

См. также

Возвращает количество столбцов в ссылке или массиве.

Синтаксис

ЧИСЛСТОЛБ(массив)

Массив - это либо массив, либо формула, вырабатывающая массив, либо ссылка на интервал ячеек, для которых определяется количество столбцов.

Примеры

ЧИСЛСТОЛБ(A1:C4) равняется 3

ЧИСЛСТОЛБ({1;2;3:4;5;6}) равняется 3


ЧСТРОК

См. также

Возвращает количество строк в ссылке или массиве.

Синтаксис

ЧСТРОК(массив)

Массив - это массив, формула массива или ссылка на интервал ячеек, для которого определяется число строк.

Примеры

ЧСТРОК(A1:C4) равняется 4

ЧСТРОК({1;2;3:4;5;6}) равняется 2


ABS

См. также

Возвращает модуль (абсолютную величину) числа. Абсолютная величина числа - это число без знака.

Синтаксис

ABS(число)

Число - это действительное число, абсолютную величину которого требуется найти.

Примеры

ABS(2) равняется 2

ABS(-2) равняется 2

Если ячейка A1 содержит -16, то:

КОРЕНЬ(ABS(A1)) равняется 4


ACOS

См. также

Возвращает арккосинус числа. Арккосинус числа — это угол, косинус которого равен числу. Угол определяется в радианах в интервале от 0 до «пи».

Синтаксис

ACOS(число)

Число — это косинус искомого угла, значение должно находиться в диапазоне от -1 до 1.

Если нужно преобразовать результат из радиан в градусы, то умножьте его на 180/ПИ().

Примеры

ASIN(-0,5) равняется 2.094395 (2*«пи»/3 радиан)

ACOS(-0,5)*180/ПИ() равняется 120 (градусов)


ACOSH

См. также

Возвращает гиперболический арккосинус числа. Число должно быть больше или равно 1. Гиперболический арккосинус числа - это значение, гиперболический косинус которого равен числу, так что ACOSH(COSH(x)) равняется x.

Синтаксис

ACOSH(число)

Число - это любое вещественное число, большее или равное 1.

Примеры

ACOSH(1) равняется 0

ACOSH(10) равняется 2,993223


ASIN

См. также

Возвращает арксинус числа. Арксинус числа — это угол, синус которого равняется числу. Угол определяется в радианах в диапазоне от -«пи»/2 до «пи»/2.

Синтаксис

ASIN(число)

Число — это синус искомого угла, значение должно быть в диапазоне от -1 до 1.

Замечания

Чтобы выразить арксинус в градусах, умножьте результат на 180/ПИ( ).

Примеры

ASIN(-0,5) равняется -0,5236 (-«пи»/6 радиан)

ASIN(-0,5)*180/ПИ() равняется -30 (градусов)


ASINH

См. также

Возвращает гиперболический арксинус числа. Гиперболический арксинус числа - это значение, гиперболический синус которого равен числу, так что ASINH(SINH(x)) равняется x.

Синтаксис

ASINH(число)

Число - это любое вещественное число.

Примеры

ASINH(-2,5) равняется -1,64723

ASINH(10) равняется 2,998223


ATAN

См. также

Возвращает арктангенс числа. Арктангенс числа — это угол, тангенс которого равняется числу. Угол определяется в радианах в диапазоне от -«пи»/2 до «пи»/2.

Синтаксис

ATAN(число)

Число — это тангенс искомого угла.

Замечания

Чтобы выразить арктангенс в градусах, умножьте результат на 180/ПИ( ).

Примеры

ATAN(1) равняется 0,785398 («пи»/4 радиан)

ATAN(1)*180/ПИ() равняется 45 (градусов)


ATAN2

См. также

Возвращает арктангенс для заданных координат x и y. Арктангенс — это угол между осью x и линией, проведенной из начала координат (0, 0) в точку с координатами (x, y). Угол определяется в радианах в диапазоне от -«пи» до «пи», исключая -«пи».

Синтаксис

ATAN2(x; y)

X — это x-координата точки.

Y — это y-координата точки.

Замечания

  • Положительный результат соответствует отсчету угла против часовой стрелки от оси x; отрицательный результат соответствует отсчету угла по часовой стрелке.

  • ATAN2(x;y) равняется ATAN(y/x), за исключением того, что в ATAN2 аргумент x может равняться 0.

  • Если оба аргумента x и y равны 0, то функция ATAN2 возвращает значение ошибки #ДЕЛ/0!.

  • Чтобы выразить арктангенс в градусах, умножьте результат на 180/ПИ( ).

Примеры

ATAN2(1; 1) равняется 0,785398 («пи»/4 радиан)

ATAN2(-1; -1) равняется -2,35619 (-3*«пи»/4 радиан)

ATAN2(-1; -1)*180/ПИ() равняется -135 (градусов)


ATANH

См. также

Возвращает гиперболический арктангенс числа. Число должно быть в интервале от -1 до 1 (исключая -1 и 1). Гиперболический арктангенс числа - это значение, гиперболический тангенс которого равен числу, так что ATANH(TANH(x)) равняется x.

Синтаксис

ATANH(число)

Число - это любое вещественное число строго между -1 и 1.

Примеры

ATANH(0,76159416) приближенно равняется 1

ATANH(-0,1) равняется -0,10034


COS

См. также

Возвращает косинус заданного угла.

Синтаксис

COS(число)

Число - это угол в радианах, для которого определяется косинус. Если угол задан в градусах, умножьте его на ПИ()/180, чтобы преобразовать в радианы.

Примеры

COS(1,047) равняется 0,500171

COS(60*ПИ()/180) равняется 0,5, косинус 60 градусов


COSH

См. также

Возвращает гиперболический косинус числа.

Синтаксис

COSH(число)

Число — любое действительное число, от которого требуется найти гиперболический косинус.

Формула гиперболического косинуса:

Примеры

COSH(4) равняется 27,30823

COSH(EXP(1)) равняется 7,610125, где EXP(1) - это число «e», основание натурального логарифма.


EXP

См. также

Возвращает число «e» возведенное в указанную степень. Число «e» равняется 2,71828182845904, основанию натурального логарифма.

Синтаксис

EXP(число)

Число - это число, для которого вычисляется экспоненциальная функция с основанием «e».

Замечания

  • Чтобы вычислить степень с другим основанием, используется операция возведения в степень (^).

  • Функция EXP является обратной к функции LN, то есть натуральному логарифму числа.

Примеры

EXP(1) равняется 2,718282 (приближенное значение «e»)

EXP(2) равняется e^2, или 7,389056

EXP(LN(3)) равняется 3


LN

См. также

Возвращает натуральный логарифм числа. Натуральный логарифм - это логарифм по основанию «e» (2,71828182845904).

Синтаксис

LN(число)

Число - это положительное вещественное число, для которого вычисляется натуральный логарифм.

Замечания

LN является обратной функцией к EXP.

Примеры

LN(86) равняется 4,454347

LN(2,7182818) равняется 1

LN(EXP(3)) равняется 3

EXP(LN(4)) равняется 4


LOG

См. также

Возвращает логарифм числа по заданному основанию.

Синтаксис

LOG(число;основание)

Число - это положительное вещественное число, для которого вычисляется логарифм.

Основание - это основание логарифма. Если основание опущено, то оно полагается равным 10.

Примеры

LOG(10) равняется 1

LOG(8; 2) равняется 3

LOG(86; 2,7182818) равняется 4,454347


LOG10

См. также

Возвращает десятичный логарифм числа.

Синтаксис

LOG10(число)

Число - это положительное вещественное число, для которого вычисляется десятичный логарифм.

Примеры

LOG10(86) равняется 1,934498451

LOG10(10) равняется 1

LOG10(1E5) равняется 5

LOG10(10^5) равняется 5


SIN

См. также

Возвращает синус заданного угла.

Синтаксис

SIN(число)

Число - это угол в радианах, для которого вычисляется синус. Если аргумент задан в градусах, то умножьте его на ПИ()/180 чтобы преобразовать в радианы.

Примеры

SIN(ПИ()) равняется 1,22E-16, что приблизительно равно 0 (нулю) (синус числа "пи" равен нулю)

SIN(ПИ()/2) равняется 1

SIN(30*ПИ()/180) равняется 0,5 (синус 30 градусов)


SINH

См. также

Возвращает гиперболический синус числа.

Синтаксис

SINH(число)

Число - это любое вещественное число.

Формула для гиперболического синуса числа:

Примеры

SINH(1) равняется 1,175201194

SINH(-1) равняется -1,175201194

Гиперболический синус можно использовать для аппроксимации интегрального распределения вероятности. Предположим, что значения лабораторных измерений меняются от 0 до 10 секунд. Эмпирический анализ собранных экспериментальных данных показывает, что вероятность получения результата x, не превосходящего t секунд, аппроксимируется следующим уравнением:

P(x<t) = 2,868 * SINH(0,0342 * t), где 0<t<10

Для вычисления вероятности получения результата, меньшего чем 1,03 сек., вместо t следует подставить 1,03:

2,868*SINH(0,0342*1,03) равняется 0,101049063

Получение такого результата будет ожидаться в 101 случае из каждых 1000 проделанных экспериментов.


TAN

См. также

Возвращает тангенс заданного угла.

Синтаксис

TAN(число)

Число - это угол в радианах, для которого определяется тангенс. Если аргумент задан в градусах, то умножьте его на ПИ()/180, чтобы преобразовать в радианы.

Примеры

TAN(0,785) равняется 0,99920

TAN(45*ПИ()/180) равняется 1


TANH

См. также

Возвращает гиперболический тангенс числа.

Синтаксис

TANH(число)

Число - это любое вещественное число

Формула гиперболического тангенса имеет следующий вид:

Примеры

TANH(-2) равняется -0,96403

TANH(0) равняется 0 (нулю)

TANH(0,5) равняется 0,462117


ГРАДУСЫ

См. также

Преобразует радианы в градусы.

Синтаксис

ГРАДУСЫ(угол)

Угол - это угол в радианах, преобразуемый в градусы.

Пример

ГРАДУСЫ(ПИ()) равняется 180


ДВФАКТР

См. также

Возвращает двойной факториал числа.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ДВФАКТР(число)

Число - это значение, для которого вычисляется двойной факториал. Если число не целое, то производится усечение.

Замечания

  • Если аргумент число числом не является, то ДВФАКТР возвращает значение ошибки #ЗНАЧ!.

  • Если число отрицательно, то ДВФАКТР возвращает значение ошибки #ЧИСЛО!.

  • Если число четно:

  • Если число нечетно:

Примеры

ДВФАКТР(6) равняется 48

ДВФАКТР(7) равняется 105


ЗНАК

См. также

Определяет знак числа. Возвращает 1, если число положительное, ноль (0), если число равно 0 и -1, если число отрицательное.

Синтаксис

ЗНАК(число)

Число - это любое вещественное число.

Примеры

ЗНАК(10) равняется 1

ЗНАК(4-4) равняется 0

ЗНАК(-0,00001) равняется -1


КОРЕНЬ

См. также

Возвращает положительное значение квадратного корня.

Синтаксис

КОРЕНЬ(число)

Число - это число, для которого вычисляется квадратный корень. Если число отрицательно, то функция КОРЕНЬ возвращает значение ошибки #ЧИСЛО!.

Примеры

КОРЕНЬ(16) равняется 4

КОРЕНЬ(-16) равняется #ЧИСЛО!

КОРЕНЬ(ABS(-16)) равняется 4


КОРЕНЬПИ

См. также

Возвращает квадратный корень из значения выражения (число * ПИ).

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

КОРЕНЬПИ(число)

Число - это число, которое умножается на число p.

Замечания

Если число < 0, то функция КОРЕНЬПИ возвращает значение ошибки #ЧИСЛО!.

Примеры

КОРЕНЬПИ(1) равняется 1,772454

КОРЕНЬПИ(2) равняется 2,506628


МОБР

См. также

Возвращает обратную матрицу для матрицы, хранящейся в массиве.

Синтаксис

МОБР(массив)

Массив - это числовой массив с равным количеством строк и столбцов.

  • Массив может быть задан как диапазон ячеек, например A1:C3; как массив констант, например {1;2;3: 4;5;6: 7;8;9} или как имя диапазона или массива.

  • Если какая-либо из ячеек в массиве пуста или содержит текст, то функция МОБР возвращает значение ошибки #ЗНАЧ!.

  • МОБР также возвращает значение ошибки #ЗНАЧ!, если массив имеет неравное число строк и столбцов.

Замечания

  • Формулы, которые возвращают массивы, должны быть введены как формулы массива.

  • Обратные матрицы, как и определители, обычно используются для решения систем уравнений с несколькими неизвестными. Произведение матрицы на ее обратную — это единичная матрица, то есть квадратный массив, у которого диагональные элементы равны 1, а все остальные элементы равны 0.

  • В качестве примера того, как вычисляется обратная матрица, рассмотрим массив из двух строк и двух столбцов A1:B2, который содержит буквы a, b, c и d, представляющие любые четыре числа. В следующей таблице приведена обратная матрица для A1:B2:
    Столбец A | Столбец B
    Строка 1 | d/(a*d-b*c) | b/(b*c-a*d)
    Строка 2 | c/(b*c-a*d) | a/(a*d-b*c)

  • МОБР производит вычисления с точностью до 16 значащих цифр, что может привести к небольшим численным ошибкам округления.

  • Некоторые квадратные матрицы не могут быть обращены, в таких случаях функция МОБР возвращает значение ошибки #ЧИСЛО!. Определитель такой матрицы равен 0.

Примеры

МОБР({4; -1 : 2; 0}) равняется {0; 0,5 : -1; 2}

МОБР({1; 2; 1 : 3; 4; -1 : 0; 2; 0}) равняется {0,25; 0,25; -0,75 : 0; 0; 0,5 : 0,75; -0,25; -0,25}

Совет Для доступа к отдельным элементам обратной матрицы следует использовать функцию ИНДЕКС.


МОПРЕД

См. также

Возвращает определитель матрицы (матрица хранится в массиве).

Синтаксис

МОПРЕД(массив)

Массив - это числовой массив с равным количеством строк и столбцов.

  • Массив может быть задан как интервал ячеек, например, A1:C3 или как массив констант, например {1;2;3:4;5;6:7;8;9} или как имя, именующее интервал или массив.

  • Если какая-либо ячейка в массиве пуста или содержит текст, то функция МОПРЕД возвращает значение ошибки #ЗНАЧ!.

  • МОПРЕД также возвращает значение ошибки #ЗНАЧ!, если массив имеет неравное количество трок и столбцов.

Замечания

  • Определитель матрицы - это число, вычисляемое на основе значений элементов массива. Для массива A1:C3, состоящего из трех сток и тех столбцов, определитель вычисляется следующим образом:

    МОПРЕД(A1:C3) равняется
    A1*(B2*C3-B3*C2) + A2*(B3*C1-B1*C3) + A3*(B1*C2-B2*C1)

  • Определители матриц обычно используются при решении систем уравнений с несколькими неизвестными.

  • МОПРЕД производит вычисления с точностью примерно 16 значащих цифр, что может в некоторых случаях приводить к небольшим численным ошибкам. Например, определитель сингулярной матрицы отличается от нуля на 1E-16.

Примеры

МОПРЕД({1; 3; 8; 5 : 1; 3; 6; 1 : 1; 1; 1; 0 : 7; 3; 10; 2}) равняется 88

МОПРЕД({3; 6; 1 : 1; 1; 0 : 3; 10; 2}) равняется 1

МОПРЕД({3; 6 : 1; 1}) равняется -3

МОПРЕД({1; 3; 8; 5 : 1; 3; 6; 1}) равняется #ЗНАЧ!, так как массив имеет неравное количество строк и столбцов.


МУЛЬТИНОМ

См. также

Возвращает отношение факториала суммы значений к произведению факториалов.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

МУЛЬТИНОМ(число1;число2; ...)

Число1, число2, ... - это от 1 до 29 значений, для которых определяется мультиномиальный коэффициент.

Замечания

  • Если любой из аргументов не является числом, то функция МУЛЬТИНОМ возвращает значение ошибки #ЗНАЧ!.

  • Если любой из аргументов меньше единицы, то функция МУЛЬТИНОМ возвращает значение ошибки #ЧИСЛО!.

  • Мультиномиальный коэффициент определяется следующим образом:

Пример

МУЛЬТИНОМ(2; 3; 4) равняется 1260


МУМНОЖ

См. также

Возвращает произведение матриц (матрицы хранятся в массивах). Результатом является массив с таким же числом строк, как массив1 и с таким же числом столбцов, как массив2.

Синтаксис

МУМНОЖ(массив1;массив2)

Массив1, массив2 - это перемножаемые массивы.

  • Количество столбцов аргумента массив1 должно быть таким же, как количество сток аргумента массив2, и оба массива должны содержать только числа.

  • Массив1 и массив2 могут быть заданы как интервалы, массивы констант или ссылки.

  • Если хотя бы одна ячейка в аргументах пуста или содержит текст, или если число столбцов в аргументе массив1 отличается от числа строк в аргументе массив2, то функция МУМНОЖ возвращает значение ошибки #ЗНАЧ!.

Замечания

  • Массив a, который является произведением двух массивов b и c определяется следующим образом:

    где i - это номер строки, а j - это номер столбца.

  • Формулы, которые возвращают массивы, должны быть введены как формулы массива.

Примеры

МУМНОЖ({1; 3 : 7; 2}; {2; 0 : 0; 2}) равняется {2; 6 : 14; 4}

МУМНОЖ({3; 0 : 2; 0}; {2; 0 : 0; 2}) равняется {6; 0 : 4; 0}

МУМНОЖ({1; 3; 0 : 7; 2; 0 : 1; 0; 0}; {2; 0 : 0; 2}) равняется #ЗНАЧ!, поскольку первый массив имеет три столбца, а второй массив имеет только две строки.


НЕЧЁТ

См. также

Возвращает число, округленное до ближайшего нечетного целого.

Синтаксис

НЕЧЁТ(число)

Число - это округляемое значение.

Замечания

  • Если аргумент число не является числом, то функция НЕЧЁТ возвращает значение ошибки #ЗНАЧ!.

  • Независимо от знака числа, округление всегда производится с избытком. Если число является нечетным целым, то округления не происходит.

Примеры

НЕЧЁТ(1,5) равняется 3

НЕЧЁТ(3) равняется 3

НЕЧЁТ(2) равняется 3

НЕЧЁТ(-1) равняется -1

НЕЧЁТ(-2) равняется -3


НОД

См. также

Возвращает наибольший общий делитель двух или более целых чисел. Наибольший общий делитель - это наибольшее целое, на которое делятся число1 и число2 без остатка.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

НОД(число1; число2; ...)

Число1, число2, ... - это от 1 до 29 значений. Если любое из значений не целое, то производится усечение.

Замечания

  • Если какой-либо из аргументов не число, то НОД возвращает значение ошибки #ЗНАЧ!.

  • Если любой из аргументов меньше нуля, то НОД возвращает значение ошибки #ЧИСЛО!.

  • Единица является делителем любого числа.

  • Простое число имеет в качестве делителей только себя и единицу.

Примеры

НОД(5; 2) равняется 1

НОД(24; 36) равняется 12

НОД(7; 1) равняется 1

НОД(5; 0) равняется 5


НОК

См. также

Возвращает наименьшее общее кратное целых чисел. Наименьшее общее кратное - это наименьшее положительное целое, которое кратно всем целым аргументам число1, число2 и так далее. Функция НОК используется для сложения дробей с различными знаменателями.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

НОК(число1;число2; ...)

Число1, число2, ... - это от 1 до 29 значений, для которых определяется наименьшее общее кратное. Если значение не целое, то производится усечение.

Замечания

  • Если любой из аргументов не является числом, то функция НОК возвращает значение ошибки #ЗНАЧ!.

  • Если любой из аргументов меньше единицы, то функция НОК возвращает значение ошибки #ЧИСЛО!.

Примеры

НОК(5; 2) равняется 10

НОК(24; 36) равняется 72


ОКРВВЕРХ

См. также

Возвращает результат округления с избытком до ближайшего числа, кратного точности. Например, если Вы хотите избежать рублей в своих ценах и Ваш товар стоит 442 рубля, используйте формулу =ОКРВВЕРХ(442;10), чтобы округлить цену с точностью до 10 рублей.

Синтаксис

ОКРВВЕРХ(число; точность)

Число - это округляемое значение.

Точность - это кратное, до которого требуется округлить.

Замечания

  • Если любой из аргументов не число, то ОКРВВЕРХ возвращает значение ошибки #ЗНАЧ!.

  • Независимо от знака числа, округление производится с избытком. Если число уже кратно точности, то никакого округления не производится.

  • Если число и точность имеют разные знаки, то функция ОКРВВЕРХ возвращает значение ошибки #ЧИСЛО!.

Примеры

ОКРВВЕРХ(2,5; 1) равняется 3

ОКРВВЕРХ(-2,5; -2) равняется -4

ОКРВВЕРХ(-2,5; 2) равняется #ЧИСЛО!

ОКРВВЕРХ(1,5; 0,1) равняется 1,5

ОКРВВЕРХ(0,234; 0,01) равняется 0,24


ОКРВНИЗ

См. также

Округляет число до кратного заданной точности с недостатком.

Синтаксис

ОКРВНИЗ(число; точность)

Число - это округляемое числовое значение.

Точность - это кратное, до которого требуется округлить.

Замечания

  • Если любой из аргументов не число, то ОКРВНИЗ возвращает значение ошибки #ЗНАЧ!.

  • Если число и точность имеют разные знаки, то ОКРВНИЗ возвращает значение ошибки #ЧИСЛО!.

  • Независимо от знака числа, округление всегда производится с недостатком. Если число уже кратно точности, то никакого округления не производится.

Примеры

ОКРВНИЗ(2,5; 1) равняется 2

ОКРВНИЗ(-2,5; -2) равняется -2

ОКРВНИЗ(-2,5; 2) равняется #ЧИСЛО!

ОКРВНИЗ(1,5; 0,1) равняется 1,5

ОКРВНИЗ(0,234; 0,01) равняется 0,23


ОКРУГЛ

См. также

Округляет число до указанного количества десятичных разрядов.

Синтаксис

ОКРУГЛ(число;число_разрядов)

Число - это округляемое число.

Число_разрядов - это количество десятичных разрядов, до которого нужно округлить число.

  • Если число_разрядов больше 0, то число округляется до указанного количества десятичных разрядов справа от десятичной запятой.

  • Если число_разрядов равно 0, то число округляется до ближайшего целого.

  • Если число_разрядов меньше 0, то число округляется слева от десятичной запятой.

Примеры

ОКРУГЛ(2,15; 1) равняется 2,2

ОКРУГЛ(2,149; 1) равняется 2,1

ОКРУГЛ(-1,475; 2) равняется -1,48

ОКРУГЛ(21,5; -1) равняется 20


ОКРУГЛВВЕРХ

См. также

Округляет число по модулю до ближайшего большего целого.

Синтаксис

ОКРУГЛВВЕРХ(число;количество_цифр)

Число - это любое вещественное число, которое нужно округлить с избытком.

Количество_цифр - это количество цифр, до которого округляется число.

Замечания

  • Функция ОКРУГЛВВЕРХ подобна функции ОКРУГЛ, за тем исключением, что округление всегда производится с избытком.

  • Если количество_цифр больше 0 (нуля), то число округляется с избытком до заданного количества десятичных разрядов после десятичной запятой.

  • Если количество_цифр равно 0 или опущено, то число округляется с избытком до ближайшего целого.

  • Если количество_цифр меньше 0, то число округляется с избытком, с учетом десятичных разрядов слева от десятичной запятой.

Примеры

ОКРУГЛВВЕРХ(3,2;0) равняется 4

ОКРУГЛВВЕРХ(76,9;0) равняется 77

ОКРУГЛВВЕРХ(3,14159; 3) равняется 3,142

ОКРУГЛВВЕРХ(-3,14159; 1) равняется -3,2

ОКРУГЛВВЕРХ(31415,92654; -2) равняется 31500


ОКРУГЛВНИЗ

См. также

Округляет число до ближайшего меньшего по модулю целого.

Синтаксис

ОКРУГЛВНИЗ(число;количество_цифр)

Число - это любое вещественное число, которое нужно округлить с недостатком.

Количество_цифр - это количество цифр, до которого округляется число.

Замечания

  • Функция ОКРУГЛВНИЗ подобна функции ОКРУГЛ, за тем исключением, что число всегда округляется с недостатком.

  • Если количество_цифр больше 0 (нуля), то число округляется с недостатком до заданного количество десятичных разрядов после запятой.

  • Если количество_цифр равно 0 или опущено, то число округляется с недостатком до ближайшего целого.

  • Если количество_цифр больше 0, то число округляется с недостатком до заданного количеств десятичных разрядов слева от запятой.

Примеры

ОКРУГЛВНИЗ(3,2; 0) равняется 3

ОКРУГЛВНИЗ(76,9;0) равняется 76

ОКРУГЛВНИЗ(3,14159; 3) равняется 3,141

ОКРУГЛВНИЗ(-3,14159; 1) равняется -3,1

ОКРУГЛВНИЗ(31415,92654; -2) равняется 31400


ОКРУГЛТ

См. также

Возвращает число, округленное с желаемой точностью.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ОКРУГЛТ(число;точность)

Число - это округляемое значение.

Точность - это точность, с которой требуется округлить число.

Замечания

ОКРУГЛТ производит округление с избытком. Округление производится, если остаток от деления числа на точность больше или равен половине точности.

Примеры

ОКРУГЛТ(10; 3) равняется 9

ОКРУГЛТ(-10; -3) равняется -9

ОКРУГЛТ(1,3; 0,2) равняется 1,4

ОКРУГЛТ(5; -2) равняется #ЧИСЛО!


ОСТАТ

См. также

Возвращает остаток от деления аргумента число на делитель. Результат имеет такой же знак, как и делитель.

Синтаксис

ОСТАТ(число;делитель)

Число - это число, остаток от деления которого определяется.

Делитель - это число, на которое нужно разделить (делитель). Если делитель равен 0, то функция ОСТАТ возвращает значение ошибки #ДЕЛ/0!.

Замечания

Функция ОСТАТ может быть выражена через функцию ЦЕЛОЕ:

ОСТАТ(n; d) = n - d*ЦЕЛОЕ(n/d)

Примеры

ОСТАТ(3; 2) равняется 1

ОСТАТ(-3; 2) равняется 1

ОСТАТ(3; -2) равняется -1

ОСТАТ(-3; -2) равняется -1


ОТБР

См. также

Усекает число до целого, отбрасывая дробную часть числа, так что остается целое число.

Синтаксис

ОТБР(число;число_разрядов)

Число - это усекаемое число.

Число_разрядов - это число, определяющее точность усечения. Значение по умолчанию аргумента число_разрядов - 0 (ноль).

Замечания

ОТБР и ЦЕЛОЕ подобны в том, что возвращают целые. ОТБР отбрасывает дробную часть числа. ЦЕЛОЕ округляет число до ближайшего целого с недостатком с учетом значения дробной части. Эти функции различаются только при использовании отрицательных чисел: ОТБР(-4,3) возвращает -4, но ЦЕЛОЕ(-4,3) возвращает -5, поскольку -5 это ближайшее снизу число.

Примеры

ОТБР(8,9) равняется 8

ОТБР(-8,9) равняется -8

ОТБР(ПИ()) равняется 3


ПИ

См. также

Возвращает число 3,14159265358979, математическую константу "пи" с точностью до 15 цифр.

Синтаксис

ПИ( )

Примеры

ПИ()/2 равняется 1,57079...

SIN(ПИ()/2) равняется 1

Если радиус окружности содержится в ячейке с именем Радиус, то следующая формула вычисляет площадь круга:

ПИ()*(Радиус^2)


ПРОИЗВЕД

См. также

Перемножает числа, заданные в качестве аргументов и возвращает их произведение.

Синтаксис

ПРОИЗВЕД(число1;число2; ...)

Число1, число2,... - это от 1 до 30 перемножаемых чисел.

Замечания

  • Аргументы, которые являются числами, логическими значениями или текстовыми представлениями чисел учитываются; аргументы, которые являются значениями ошибки или текстами, не преобразуемыми в числа, вызывают ошибки.

  • Если аргумент является массивом или ссылкой, то в массиве или ссылке учитываются только числа. Пустые ячейки, логические значения, тексты и значения ошибок в массиве или ссылке игнорируются.

Примеры

Если ячейки A2:C2 содержат 5, 15 и 30, то:

ПРОИЗВЕД(A2:C2) равняется 2250

ПРОИЗВЕД(A2:C2; 2) равняется 4500


ПРОМЕЖУТОЧНЫЕ.ИТОГИ

См. также

Возвращает промежуточный итог в список или базу данных. Обычно проще создать список с промежуточными итогами, используя команду Итоги в меню Данные. Но если список с промежуточными итогами уже создан, его можно модифицировать, редактируя формулу с функцией ПРОМЕЖУТОЧНЫЕ.ИТОГИ.

Синтаксис

ПРОМЕЖУТОЧНЫЕ.ИТОГИ(номер_функции;ссылка1;ссылка2;...)

Номер_функции - это число от 1 до 11, которое указывает, какую функцию использовать при вычислении итогов внутри списка.

Номер_функции | Операция
1 | СРЗНАЧ
2 | СЧЁТ
3 | СЧЁТЗ
4 | МАКС
5 | МИН
6 | ПРОИЗВЕД
7 | СТАНДОТКЛОН
8 | СТАНДОТКЛОНП
9 | СУММ
10 | ДИСП
11 | ДИСПР

Ссылка1; Ссылка2; - от 1 до 29 интервалов или ссылок, для которых подводятся итоги.

Замечания

  • Если уже имеются формулы подведения итогов внутри аргументов ссылка1;ссылка2;... (вложенные итоги), то эти вложенные итоги игнорируются, чтобы избежать двойного суммирования.

  • Функция ПРОМЕЖУТОЧНЫЕ.ИТОГИ игнорирует все скрытые строки, которые получаются в результате фильтрации списка. Это важно в том случае, когда нужно подвести итоги только для видимых данных, которые получаются в результате фильтрации списка.

  • Если среди ссылок есть трехмерные ссылки, функция SUBTOTAL возвращает значение ошибки #ЗНАЧ!.

Пример

ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;C3:C5) подведет итоги для ячеек C3:C5, используя функцию СУММ


РАДИАНЫ

См. также

Преобразует градусы в радианы.

Синтаксис

РАДИАНЫ(угол)

Угол - это угол в градусах, который нужно преобразовать.

Пример

РАДИАНЫ(270) равняется 4,712389 (3π/2 радиан)


РИМСКОЕ

См. также

Преобразует число в арабской записи к числу в римской, как текст.

Синтаксис

РИМСКОЕ(число;форма)

Число - это преобразуемое число в арабской записи.

Форма - это число, указывающее, какая форма римской записи чисел требуется. Форма записи римских чисел варьируется от классической до упрощенной, и становится все более наглядной с увеличением значения аргумента форма. См. ниже пример для РИМСКОЕ(499;0).

Форма | Введите
0 или опущен | Классический
1 | Более наглядный. См. пример ниже
2 | Более наглядный. См. пример ниже
3 | Более наглядный. См. пример ниже
4 | Упрощенный
ИСТИНА | Классический
ЛОЖЬ | Упрощенный

Замечания

  • Если число отрицательно, то возвращается значение ошибки #ЗНАЧ!.

  • Если число больше 3999, то возвращается значение ошибки #ЗНАЧ!.

Примеры

РИМСКОЕ(499;0) равняется "CDXCIX"

РИМСКОЕ(499;1) равняется "LDVLIV"

РИМСКОЕ(499;2) равняется "XDIX"

РИМСКОЕ(499;3) равняется "VDIV"

РИМСКОЕ(499;4) равняется "ID"

РИМСКОЕ(1993;0) равняется "MCMXCIII"


РЯД.СУММ

См. также

Возвращает сумму степенного ряда, вычисленную по формуле:

Многие функции могут быть аппроксимированы разложениями в степенные ряды.

Если эта функция недоступна, следует установить надстройку «Пакет Анализа», а затем подключить его с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

РЯД.СУММ(x;n;m;коэффициенты)

X — это значение переменной степенного ряда.

N — это показатель степени x для первого члена степенного ряда.

M — это шаг, на который увеличивается показатель степени n для каждого следующего члена степенного ряда.

Коэффициенты — это набор коэффициентов при соответствующих степенях x. Количество значений в аргументе коэффициенты определяет количество членов степенного ряда. Например, если в аргументе коэффициенты три значения, то степенной ряд содержит три слагаемых.

Замечания

Если какой-либо из аргументов не является числом, то функция РЯД.СУММ возвращает значение ошибки #ЗНАЧ!.

Пример

Допустим, что ячейка A1 содержит формулу =ПИ()/4, а ячейки E1:E4 содержат следующий набор значений аргумента коэффициенты (вычисленные с использованием функции ФАКТР):

Следующая формула возвращает аппроксимацию косинуса «пи»/4 радиан (45 градусов):

РЯД.СУММ (A1;0;2;E1:E4) равняется 0,707103.


СЛУЧМЕЖДУ

См. также

Возвращает случайное число между двумя заданными числами. Каждый раз, когда рабочий лист перевычисляется, возвращается новое случайное число.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

СЛУЧМЕЖДУ(нижн_граница;верхн_граница)

Нижн_граница - это наименьшее целое число, которое возвращает функция СЛУЧМЕЖДУ.

Верхн_граница - это наибольшее целое число, которое возвращает функция СЛУЧМЕЖДУ.


СЛЧИС

См. также

Возвращает равномерно распределенное случайное число большее либо равное 0 и меньшее 1. Новое случайное число возвращается каждый раз, когда рабочий лист вычисляется повторно.

Синтаксис

СЛЧИС( )

Замечания

  • Чтобы получить случайное вещественное число между a и b, можно использовать следующую формулу:

    СЛЧИС()*(b-a)+a

  • Если вы хотите использовать функцию СЛЧИС для генерации случайного числа, но не хотите, чтобы это число менялось каждый раз при вычислении значения ячейки, то вы можете ввести =СЛЧИС() в строку формул и нажать F9 для изменения значения случайного числа.

Примеры

Для генерации случайного числа большего или равного 0, но меньшего 100 можно использовать формулу:

СЛЧИС()*100


СТЕПЕНЬ

См. также

Возвращает результат возведения в степень.

Синтаксис

СТЕПЕНЬ(число;степень)

Число - это основание. Оно может быть любым вещественным числом.

Степень - это показатель степени, в которую возводится основание.

Замечания

Вместо функции СТЕПЕНЬ для возведения в степень можно использовать операцию "^", например 5^2

Примеры

СТЕПЕНЬ(5;2) равняется 25

СТЕПЕНЬ(98,6;3,2) равняется 2401077

СТЕПЕНЬ(4;5/4) равняется 5,656854


СУММ

См. также

Суммирует все числа в интервале ячеек.

Синтаксис

СУММ(число1;число2; ...)

Число1, число2, ... - это от 1 до 30 аргументов, для которых требуется определить итог или сумму.

  • Учитываются числа, логические значения и текстовые представления чисел, которые непосредственно введены в список аргументов. См. ниже первый и второй примеры.

  • Если аргумент является массивом или ссылкой, то только числа учитываются в массиве или ссылке. Пустые ячейки, логические значения, тексты и значения ошибок в массиве или ссылке игнорируются. См. ниже третий пример.

  • Аргументы, которые являются значениями ошибки или текстами, не преобразуемыми в числа, вызывают ошибки.

Примеры

СУММ(3; 2) равняется 5

СУММ("3"; 2; ИСТИНА) равняется 6, так как текстовые значения преобразуются в числа, а логическое значение ИСТИНА преобразуется в число 1.

В дополнение к предыдущему примеру: если ячейка A1 содержит "3", а ячейка B1 содержит ИСТИНА, то:

СУММ(A1; B1; 2) равняется 2, так как нечисловые значения в ссылке не преобразуются.

Если ячейки A2:E2 содержат числа 5, 15, 30, 40 и 50, то:

СУММ(A2:C2) равняется 50

СУММ(B2:E2; 15) равняется 150


СУММЕСЛИ

См. также

Суммирует ячейки, заданные критерием.

Синтаксис

СУММЕСЛИ(интервал; критерий;сумм_интервал)

Интервал — это интервал вычисляемых ячеек.

Критерий — это критерий в форме числа, выражения или текста, который определяет, какая ячейка добавляется. Например, критерий может быть выражен как 32, "32", ">32", "яблоки".

Сумм_интервал — это фактические ячейки для суммирования. Ячейки в сумм_интервал суммируются, только если соответствующие им ячейки в аргументе интервал удовлетворяют критерию. Если сумм_интервал опущен, то суммируются ячейки в аргументе интервал.

Замечания

Microsoft Excel предлагает дополнительные функции, которые можно применять для анализа данных с использованием условий. Например, для вычисления числа значений, попадающих в интервал, заданный текстовой строкой или числами, используйте функцию СЧЁТЕСЛИ. Для получения формулы, возвращающей в зависимости от выполнения условия одно из двух значений, например вознаграждение по указанному объему продаж, используйте функцию ЕСЛИ. Вычисление значений с использованием условия.

Пример

Пусть ячейки A1:A4 содержат следующие величины стоимости для четырех домов: 100 000 руб., 200 000 руб., 300 000 руб., 400 000 руб., соответственно. Пусть ячейки B1:B4 содержат следующие величины комиссионных при продаже соответствующих домов: 7 000 руб., 14000 руб., 21 000 руб., 28 000 руб.

СУММЕСЛИ(A1:A4;">160000";B1:B4) равняется 63 000 руб.


СУММКВ

См. также

Возвращает сумму квадратов аргументов.

Синтаксис

СУММКВ(число1;число2; ...)

Число1, число2, ... - это от 1 до 30 аргументов, квадраты которых суммируются. Можно использовать отдельный массив или ссылку на массив вместо аргументов, разделяемых точкой с запятой.

Пример

СУММКВ(3; 4) равняется 25


СУММКВРАЗН

См. также

Возвращает сумму квадратов разностей соответствующих значений в двух массивах.

Синтаксис

СУММКВРАЗН(массив_x;массив_y)

Массив_x - это первый массив или интервал значений.

Массив_y - это второй массив или интервал значений.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, которые содержат числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если массив_x и массив_y имеют различное количество элементов, то функция СУММКВРАЗН возвращает значение ошибки #Н/Д.

  • Уравнение суммы квадратов разностей имеет следующий вид:

Пример

СУММКВРАЗН({2; 3; 9; 1; 8; 7; 5}; {6; 5; 11; 7; 5; 4; 4}) равняется 79


СУММПРОИЗВ

См. также

Перемножает соответствующие элементы заданных массивов и возвращает сумму произведений .

Синтаксис

СУММПРОИЗВ(массив1;массив2;массив3; ...)

Массив1, массив2, массив3, ... - это от 2 до 30 массивов, чьи компоненты нужно перемножить, а затем сложить.

  • Аргументы, которые являются массивами, должны иметь одинаковые размерности. Если это не так, то функция СУММПРОИЗВ возвращает значение ошибки #ЗНАЧ!.

  • СУММПРОИЗВ трактует нечисловые элементы массивов как нулевые.

Пример

Следующая формула перемножает все компоненты двух массивов, а затем складывает полученные произведения, то есть выполняются следующие вычисления: 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3.

СУММПРОИЗВ({3;4:8;6:1;9}; {2;7:6;7:5;3}) равняется 156

Замечания

Приведенный выше пример возвращает тот же самый результат, что и формула СУММ(A1:B3*D1:E3), введенная как массив. Использование массивов дает более общее средство для выполнения действий, подобных функции СУММПРОИЗВ. Например, можно вычислить сумму квадратов элементов в массиве A1:B3, используя формулу СУММ(A1:B3^2), вводимую как массив.


СУММРАЗНКВ

См. также

Возвращает сумму разностей квадратов соответствующих значений в двух массивах.

Синтаксис

СУММРАЗНКВ(массив_x;массив_y)

Массив_x - это первый массив или интервал значений.

Массив_y - это второй массив или интервал значений.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, которые содержат числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если массив_x и массив_y имеют различное количество элементов, то функция СУММРАЗНКВ возвращает значение ошибки #Н/Д.

  • Уравнение для суммы разностей квадратов имеет следующий вид:

Пример

СУММРАЗНКВ({2; 3; 9; 1; 8; 7; 5}; {6; 5; 11; 7; 5; 4; 4}) равняется -55


СУММСУММКВ

См. также

Возвращает сумму сумм квадратов соответствующих элементов двух массивов. Сумма сумм квадратов - это распространенный термин во многих статистических вычислениях.

Синтаксис

СУММСУММКВ(массив_x;массив_y)

Массив_x - это первый массив или интервал значений.

Массив_y - это второй массив или интервал значений.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, которые содержат числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если массив_x и массив_y имеют различное количество значений, то функция СУММСУММКВ возвращает значение ошибки #Н/Д.

  • Уравнения для суммы сумм квадратов имеет следующий вид:

Пример

СУММСУММКВ({2; 3; 9; 1; 8; 7; 5}; {6; 5; 11; 7; 5; 4; 4}) равняется 521


СЧЁТЕСЛИ

См. также

Подсчитывает количество ячеек внутри диапазона, удовлетворяющих заданному критерию.

Синтаксис

СЧЁТЕСЛИ(диапазон;критерий)

Диапазон — это диапазон, в котором нужно подсчитать ячейки.

Критерий — это критерий в форме числа, выражения или текста, который определяет, какие ячейки надо подсчитывать. Например, критерий может быть выражен следующим образом: 32, "32", ">32", "яблоки".

Замечания

Microsoft Excel предлагает дополнительные функции, которые можно применять для анализа данных с использованием условий. Например, для вычисления суммы значений, попадающих в интервал, заданный текстовой строкой или числами, используйте функцию СУММЕСЛИ. Для получения формулы, возвращающей в зависимости от выполнения условия одно из двух значений, например вознаграждение по указанному объему продаж, используйте функцию ЕСЛИ. Вычисление значений с использованием условия.

Примеры

Пусть ячейки A3:A6 содержат "яблоки", "апельсины", "персики", "яблоки" соответственно:

СЧЁТЕСЛИ(A3:A6;"яблоки") равняется 2

Пусть ячейки B3:B6 содержат 32, 54, 75 и 86 соответственно:

СЧЁТЕСЛИ(B3:B6;">55") равняется 2


ФАКТР

См. также

Возвращает факториал числа. Факториал числа - это значение, которое равно 1*2*3*...* число.

Синтаксис

ФАКТР(число)

Число - это неотрицательное число, факториал которого вычисляется. Если число не целое, то производится усечение.

Примеры

ФАКТР(1) равняется 1

ФАКТР(1,9) равняется ФАКТР(1) равняется 1

ФАКТР(0) равняется 1

ФАКТР(-1) равняется #ЧИСЛО!

ФАКТР(5) равняется 1*2*3*4*5 равняется 120


ЦЕЛОЕ

См. также

Округляет число до ближайшего меньшего целого.

Синтаксис

ЦЕЛОЕ(число)

Число - это вещественное число, округляемое до ближайшего меньшего целого.

Примеры

ЦЕЛОЕ(8,9) равняется 8

ЦЕЛОЕ(-8,9) равняется -9

Следующая формула возвращает дробную часть вещественного числа в ячейке A1:

A1-ЦЕЛОЕ(A1)


ЧЁТН

См. также

Возвращает число, округленное до ближайшего четного целого. Эту функцию можно использовать при обработке объектов, которые поступают парами. Например, упаковочный ящик позволяет упаковывать по два объекта в ряд. Ящик будет заполнен, если количество объектов, округленное до ближайшего четного числа, равняется вместимости ящика.

Синтаксис

ЧЁТН(число)

Число - это округляемое значение.

Замечания

  • Если аргумент число числом не является, то ЧЁТН возвращает значение ошибки #ЗНАЧ!.

  • Независимо от знака числа округление производится с избытком. Если число уже является четным целым, то никакого округления не производится.

Примеры

ЧЁТН(1,5) равняется 2

ЧЁТН(3) равняется 4

ЧЁТН(2) равняется 2

ЧЁТН(-1) равняется -2


ЧАСТНОЕ

См. также

Возвращает частное от деления нацело. Эта функция используется, когда нужно отбросить остаток от деления.

Если эта функция недоступна, следует установить надстройку "Пакет анализа", а затем подключить ее с помощью команды Надстройки меню Сервис.

Инструкции

Синтаксис

ЧАСТНОЕ(числитель;знаменатель)

Числитель - это делимое.

Знаменатель - это делитель.

Замечания

Если любой из аргументов не является числом, то функция ЧАСТНОЕ возвращает значение ошибки #ЗНАЧ!.

Примеры

ЧАСТНОЕ(5; 2) равняется 2

ЧАСТНОЕ(4,5; 3,1) равняется 1

ЧАСТНОЕ(-10; 3) равняется -3


ЧИСЛКОМБ

См. также

Возвращает количество комбинаций для заданного числа объектов. Функция ЧИСЛКОМБ используется для определения числа всех возможных сочетаний объектов в группы.

Синтаксис

ЧИСЛКОМБ(число; число_выбранных)

Число - это число объектов.

Число_выбранных - это число объектов в каждой комбинации.

Замечания

  • Числовые аргументы усекаются до целых.

  • Если любой из аргументов не число, то ЧИСЛКОМБ возвращает значение ошибки #ИМЯ?.

  • Если число < 0 или число_выбранных < 0 или число < число_выбранных, то функция ЧИСЛКОМБ возвращает значение ошибки #ЧИСЛО!.

  • Комбинацией считается любое множество или подмножество объектов, безотносительно к их порядку. Комбинации отличаются от перестановок, для которых порядок существен.

  • Число комбинаций определяется следующим образом, где число = n и число_выбранных = k:

    где:

Пример

Допустим, нужно сформировать команду из двух человек, а имеется восемь кандидатов. Тогда общее число различных команд определяется выражением ЧИСЛКОМБ(8; 2) и равняется 28 командам.


FРАСП

См. также

Возвращает F-распределение вероятности. Эту функцию можно использовать, чтобы определить, имеют ли два множества данных различные степени плотности. Например, можно исследовать результаты тестирования мужчин и женщин, окончивших высшую школу и определить отличается ли разброс результатов для мужчин и женщин.

Синтаксис

FРАСП(x;степени_свободы1;степени_свободы2)

X - это значение, для которого вычисляется функция.

Степени_свободы1 - это числитель степеней свободы.

Степени_свободы2 - это знаменатель степеней свободы.

Замечания

  • Если какой-либо из аргументов не является числом, то функция FРАСП возвращает значение ошибки #ЗНАЧ!.

  • Если x отрицательно, то функция FРАСП возвращает значение ошибки #ЧИСЛО!.

  • Если степени_свободы1 или степени_свободы2 не целое, то оно усекается.

  • Если степени_свободы1 < 1 или степени_свободы1 ≥ 1010, FРАСП возвращает значение ошибки #ЧИСЛО!.

  • Если степени_свободы2 < 1 или степени_свободы2 ≥ 1010, FРАСП возвращает значение ошибки #ЧИСЛО!.

  • FРАСП вычисляется следующим образом: FРАСП=P( F<x ), где F - это случайная величина, которая имеет F-распределение.

Пример

FРАСП(15,20675;6;4) равняется 0,01


FРАСПОБР

См. также

Возвращает обратное значение для F-распределения вероятностей. Если p = FРАСП(x;...), то FРАСПОБР(p;...) = x.

F-распределение может быть использовано в F-тесте, который сравнивает степени разброса двух множеств данных. Например, можно проанализировать распределение доходов США и Канады, чтобы определить, имеют ли две страны подобные степени плотности.

Синтаксис

FРАСПОБР(вероятность;степени_свободы1;степени_свободы2)

Вероятность - это вероятность, связанная с F-распределением.

Степени_свободы1 - это числитель степеней свободы.

Степени_свободы2 - это знаменатель степеней свободы.

Замечания

  • Если какой-либо из аргументов не является числом, то функция FРАСПОБР возвращает значение ошибки #ЗНАЧ!.

  • Если вероятность < 0 или вероятность > 1, то функция FРАСПОБР возвращает значение ошибки #ЧИСЛО!.

  • Если степени_свободы1 или степени_свободы2 не целое, то оно усекается.

  • Если степени_свободы1 < 1 или степени_свободы1 ≥ 10^10, FРАСПОБР возвращает значение ошибки #ЧИСЛО!.

  • Если степени_свободы2 < 1 или степени_свободы2 ≥ 10^10, FРАСПОБР возвращает значение ошибки #ЧИСЛО!.

FРАСПОБР можно использовать, чтобы определить критические значения F-распределения. Например, результаты дисперсионного анализа обычно включают данные для F-статистики, F-вероятности и F-критическое значение с уровнем значимости 0,05. Чтобы определить критическое значение F, нужно использовать уровень значимости s как аргумент вероятность для FРАСПОБР.

FРАСПОБР использует метод итераций для вычисления значения. Если задано значение вероятности, то функция FРАСПОБР производит итерации, пока не получит результат с точностью ± 3x10^-7. Если FРАСПОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

FРАСПОБР(0,01;6;4) равняется 15,20675


ZТЕСТ

См. также

Возвращает двустороннее P-значение z-теста. Z-тест определяет стандартную оценку для x по отношению к массиву данных и возвращает двустороннюю вероятность для нормального распределения. Можно использовать эту функцию, чтобы оценить вероятность того, что конкретное наблюдение взято из конкретной генеральной совокупности.

Синтаксис

ZТЕСТ(массив;x;сигма)

Массив - это массив или интервал данных, с которыми сравнивается x.

X - это проверяемое значение.

Сигма - это известное стандартное отклонение генеральной совокупности. Если этот параметр опущен, то используется стандартное отклонение выборки.

Замечания

  • Если массив пуст, то функция ZТЕСТ возвращает значение ошибки #Н/Д.

  • ZТЕСТ вычисляется следующим образом:

Пример

ZТЕСТ({3;6;7;8;6;5;4;2;1;9};4) равняется 0,090574


БЕТАОБР

См. также

Возвращает обратную функцию к интегральной функции плотности бета-вероятности. То есть, если вероятность = БЕТАРАСП(x;...), то БЕТАОБР(вероятность;...) = x. Интегральное бета-распределение используется при планировании для определения вероятного времени завершения работы, если заданы ожидаемое время завершения и его вариативность.

Синтаксис

БЕТАОБР(вероятность;альфа;бета;A;B)

Вероятность - это вероятность, связанная с бета распределением.

Альфа - это параметр распределения.

Бета - это параметр распределения.

A - это необязательная нижняя граница интервала изменения x.

B - это необязательная верхняя граница интервала изменения x.

Замечания

  • Если какой-либо из аргументов не является числом, то функция БЕТАОБР возвращает значение ошибки #ЗНАЧ!.

  • Если альфа ≤ 0 или бета ≤ 0, то функция БЕТАОБР возвращает значение ошибки #ЧИСЛО!.

  • Если вероятность ≤ 0 или вероятность > 1, то функция то функция БЕТАОБР возвращает значение ошибки #ЧИСЛО!.

  • Если опущены значения аргументов A и B, то функция БЕТАОБР использует стандартное интегральное бета-распределение, так что A = 0 и B = 1.

  • БЕТАОБР использует метод итераций для вычисления значения. Если задано значение вероятности, то функция БЕТАОБР производит итерации, пока не получит результат с точностью ±3x10-7. Если БЕТАОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

БЕТАОБР(0,685470581;8;10;1;3) равняется 2


БЕТАРАСП

См. также

Возвращает интегральную функцию плотности бета-вероятности. Интегральная функция плотности бета-вероятности обычно используется для изучения вариации в процентах какой-либо величины, например, доли дня, которую люди проводят у телевизора.

Синтаксис

БЕТАРАСП(x;альфа;бета;A;B)

X - это значение в интервале между A и B, для которого вычисляется функция.

Альфа - это параметр распределения.

Бета - это параметр распределения.

A - это необязательная нижняя граница интервала изменения x.

B - это необязательная верхняя граница интервала изменения x.

Замечания

  • Если какой-либо из аргументов не является числом, то функция БЕТАРАСП возвращает значение ошибки #ЗНАЧ!.

  • Если альфа ≤ 0 или бета ≤ 0, то функция БЕТАРАСП возвращает значение ошибки #ЧИСЛО!.

  • Если x < A, x > B или A = B, то функция БЕТАРАСП возвращает значение ошибки #ЧИСЛО!.

  • Если значения A и B опущены, то функция БЕТАРАСП использует стандартное интегральное бета-распределение, так что A = 0 и B = 1.

Пример

БЕТАРАСП(2;8;10;1;3) равняется 0,685470581


БИНОМРАСП

См. также

Возвращает отдельное значение биномиального распределения. Функция БИНОМРАСП используется в задачах с фиксированным числом тестов или испытаний, когда результатом любого испытания может быть только успех или неудача, испытания независимы, и вероятность успеха постоянна на протяжении всего эксперимента. Например, БИНОМРАСП может вычислить вероятность того, что двое из трех следующих новорожденных будут мальчиками.

Синтаксис

БИНОМРАСП(число_успехов;число_испытаний;вероятность_успеха;интегральная)

Число_успехов - это количество успешных испытаний.

Число_испытаний - это число независимых испытаний.

Вероятность_успеха - это вероятность успеха каждого испытания.

Интегральная - это логическое значение, определяющее форму функции. Если аргумент интегральная имеет значение ИСТИНА, то функция БИНОМРАСП возвращает интегральную функцию распределения, то есть вероятность того, что число успешных испытаний не менее значения аргумента число_успехов; если этот аргумент имеет значение ЛОЖЬ, то возвращается функция распределения, то есть вероятность того, что число успешных испытаний в точности равно значению аргумента число_успехов.

Замечания

  • Число_успехов и число_испытаний усекаются до целых.

  • Если число_успехов, число_испытаний или вероятность_успеха не является числом, то функция БИНОМРАСП возвращает значение ошибки #ЗНАЧ!.

  • Если число_успехов < 0 или число_успехов > число_испытаний, то функция БИНОМРАСП возвращает значение ошибки #ЧИСЛО!.

  • Если вероятность_успеха < 0 или вероятность_успеха > 1, то функция то функция БИНОМРАСП возвращает значение ошибки #ЧИСЛО!.

  • Биномиальная функция распределения имеет следующий вид:

    где:

    есть ЧИСЛКОМБ(n;x).

    Интегральное биномиальное распределение имеет следующий вид:

Пример

При бросании монеты может выпасть орел или решка. Вероятность того, что при первом бросании выпадет орел, равна 0,5, а вероятность того, что в точности 6 раз из 10 выпадет орел составит:

БИНОМРАСП(6;10;0,5;ЛОЖЬ) равняется 0,205078


ВЕЙБУЛЛ

См. также

Возвращает распределение Вейбулла. Это распределение используется при анализе надежности, например, для вычисления среднего времени наработки на отказ какого-либо устройства.

Синтаксис

ВЕЙБУЛЛ(x;альфа;бета;интегральная)

X - это значение, для которого вычисляется функция.

Альфа - это параметр распределения.

Бета - это параметр распределения.

Интегральная - определяет форму функции.

Замечания

  • Если x, альфа, или бета не является числом, то функция ВЕЙБУЛЛ возвращает значение ошибки #ЗНАЧ!.

  • Если x < 0, то функция ВЕЙБУЛЛ возвращает значение ошибки #ЧИСЛО!.

  • Если альфа ≤ 0 или бета ≤ 0, то функция ВЕЙБУЛЛ возвращает значение ошибки #ЧИСЛО!.

  • Уравнение для интегральной функции распределения Вейбулла имеет следующий вид:

  • Уравнение для функции плотности распределения Вейбулла имеет следующий вид:

  • Если альфа = 1, то функция ВЕЙБУЛЛ возвращает экспоненциальное распределение:

Примеры

ВЕЙБУЛЛ(105;20;100;ИСТИНА) равняется 0,929581

ВЕЙБУЛЛ(105;20;100;ЛОЖЬ) равняется 0,035589


ВЕРОЯТНОСТЬ

См. также

Возвращает вероятность того, что значение из интервала находится внутри заданных пределов. Если верхний_предел не задан, то возвращается вероятность того, что значения в аргументе x_интервал равняются значению аргумента нижний_предел.

Синтаксис

ВЕРОЯТНОСТЬ(x_интервал;интервал_вероятностей;нижний_предел;верхний_предел)

X_интервал - это интервал числовых значений x, с которыми связаны вероятности.

Интервал_вероятностей - это множество вероятностей, соответствующих значениям в аргументе x_интервал.

Нижний_предел - это нижняя граница значения, для которого вычисляется вероятность.

Верхний_предел - это необязательная верхняя граница значения, для которого требуется вычислить вероятность.

Замечания

  • Если любое значение в аргументе интервал_вероятностей ≤ 0, или если какое-либо значение в аргументе интервал_вероятностей > 1, то функция ВЕРОЯТНОСТЬ возвращает значение ошибки #ЧИСЛО!.

  • Если сумма значений в аргументе интервал_вероятностей № 1, то функция ВЕРОЯТНОСТЬ возвращает значение ошибки #ЧИСЛО!.

  • Если верхний_предел опущен, то функция ВЕРОЯТНОСТЬ возвращает вероятность равенства значению аргумента нижний_предел.

  • Если x_интервал и интервал_вероятностей содержат различное количество точек данных, то функция ВЕРОЯТНОСТЬ возвращает значение ошибки #Н/Д.

Примеры

ВЕРОЯТНОСТЬ({0;1;2;3};{0,2;0,3;0,1;0,4};2) равняется 0,1

ВЕРОЯТНОСТЬ({0;1;2;3};{0,2;0,3;0,1;0,4};1;3) равняется 0,8


ГАММАНЛОГ

См. также

Возвращает натуральный логарифм гамма функции, G(x).

Синтаксис

ГАММАНЛОГ(x)

X - это значение, для которого вычисляется ГАММАНЛОГ.

Замечания

  • Если x не является числом, то функция ГАММАНЛОГ возвращает значение ошибки #ЗНАЧ!.

  • Если x ≤ 0, то функция ГАММАНЛОГ возвращает значение ошибки #ЧИСЛО!.

  • Число e, возведенное в степень ГАММАНЛОГ(i), где i - целое число, возвращает такой же результат, как и (i - 1)!.

  • ГАММАНЛОГ вычисляется следующим образом:

    где:

Примеры

ГАММАНЛОГ(4) равняется 1,791759

EXP(ГАММАНЛОГ(4)) равняется 6 или (4 - 1)!


ГАММАОБР

См. также

Возвращает обратное гамма распределение. Если p = ГАММАРАСП(x;...), то ГАММАОБР(p;...) = x

Эта функция используется для изучения переменных, которые, возможно, имеют асимметричное распределение.

Синтаксис

ГАММАОБР(вероятность;альфа;бета)

Вероятность - это вероятность, связанная с гамма-распределением.

Альфа - это параметр распределения.

Бета - это параметр распределения. Если бета = 1, то функция ГАММАОБР возвращает стандартное гамма-распределение.

Замечания

  • Если какой-либо из аргументов не является числом, то функция ГАММАОБР возвращает значение ошибки #ЗНАЧ!.

  • Если вероятность < 0 или вероятность > 1, то функция ГАММАОБР возвращает значение ошибки #ЧИСЛО!.

  • Если альфа ≤ 0 или если бета ≤ 0, то функция ГАММАОБР возвращает значение ошибки #ЧИСЛО!.

  • Если бета ≤ 0, то функция ГАММАОБР возвращает значение ошибки #ЧИСЛО!.

  • ГАММАОБР использует метод итераций для вычисления функции. Если задано значение вероятности, то функция ГАММАОБР производит итерации, пока не получит результат с точностью ±3x10^-7. Если ГАММАОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

ГАММАОБР(0,068094;9;2) равняется 10


ГАММАРАСП

См. также

Возвращает гамма-распределение. Эту функцию можно использовать для изучения переменных, которые имеют асимметричное распределение. Гамма-распределение обычно используется в теории очередей.

Синтаксис

ГАММАРАСП(x;альфа;бета;интегральная)

X - это значение, для которого требуется вычислить распределение.

Альфа - это параметр распределения.

Бета - это параметр распределения. Если бета = 1, то функция ГАММАРАСП возвращает стандартное гамма-распределение.

Интегральная - это логическое значение, определяющее форму функции. Если интегральная имеет значение ИСТИНА, то функция ГАММАРАСП возвращает интегральную функцию распределения; если этот аргумент имеет значение ЛОЖЬ, то возвращается функция плотности распределения.

Замечания

  • Если x, альфа, или бета не является числом, то функция ГАММАРАСП возвращает значение ошибки #ЗНАЧ!.

  • Если x < 0, то функция ГАММАРАСП возвращает значение ошибки #ЧИСЛО!.

  • Если альфа ≤ 0 или если бета ≤ 0, то функция ГАММАРАСП возвращает значение ошибки #ЧИСЛО!.

  • Уравнение для гамма-распределения имеет следующий вид:

    Стандартное гамма-распределение имеет следующий вид:

  • Если альфа = 1, то функция ГАММАРАСП возвращает экспоненциальное распределение:

  • Для целого положительного n, если альфа = n/2, бета = 2 и интегральная = ИСТИНА, функция ГАММАРАСП возвращает (1 - ХИ2РАСП(x)) с n степенями свободы.

  • Если альфа целое положительное, то ГАММАРАСП также называется распределением Эрланга.

Примеры

ГАММАРАСП(10;9;2;ЛОЖЬ) равняется 0,032639

ГАММАРАСП(10;9;2;ИСТИНА) равняется 0,068094


ГИПЕРГЕОМЕТ

См. также

Возвращает гипергеометрическое распределение. ГИПЕРГЕОМЕТ возвращает вероятность заданного количества успехов в выборке, если заданы размер выборки, количество успехов в генеральной совокупности и размер генеральной совокупности. Функция ГИПЕРГЕОМЕТ используется для задач с конечной генеральной совокупностью, где каждое наблюдение - это успех или неудача, а каждое подмножество заданного размера выбирается с равной вероятностью.

Синтаксис

ГИПЕРГЕОМЕТ(число_успехов_в_выборке;размер_выборки;число_успехов_в_совокупности;размер_совокупности)

Число_успехов_в_выборке - это количество успешных испытаний в выборке.

Размер_выборки - это размер выборки.

Число_успехов_в_совокупности - это количество успешных испытаний в генеральной совокупности.

Размер_совокупности - это размер генеральной совокупности.

Замечания

  • Все аргументы усекаются до целых.

  • Если любой из аргументов не является числом, то функция ГИПЕРГЕОМЕТ возвращает значение ошибки #ЗНАЧ!.

  • Если число_успехов_в_выборке < 0 или число_успехов_в_выборке больше, чем меньшее из чисел размер_выборки и число_успехов_в_совокупности, то функция ГИПЕРГЕОМЕТ возвращает значение ошибки #ЧИСЛО!.

  • Если число_успехов_в_выборке меньше, чем большее из чисел 0 и (размер_выборки - размер_совокупности + число_успехов_в_совокупности), то функция ГИПЕРГЕОМЕТ возвращает значение ошибки #ЧИСЛО!.

  • Если размер_выборки < 0 или размер_выборки > размер_совокупности, то функция ГИПЕРГЕОМЕТ возвращает значение ошибки #ЧИСЛО!.

  • Если число_успехов_в_совокупности < 0 или число_успехов_в_совокупности > размер_совокупности, то функция ГИПЕРГЕОМЕТ возвращает значение ошибки #ЧИСЛО!.

  • Если размер_совокупности < 0, то функция ГИПЕРГЕОМЕТ возвращает значение ошибки #ЧИСЛО!.

  • Уравнение для гипергеометрического распределения имеет следующий вид:

    где:

    x = число_успехов_в_выборке

    n = размер_выборки

    M = число_успехов_в_совокупности

    N = размер_совокупности

    ГИПЕРГЕОМЕТ используется для выборок без повторений из конечной генеральной совокупности.

Пример

В коробке 20 конфет. Восемь из них карамельки, а остальные 12 - орешки. Если некто выбирает 4 конфеты наугад, то следующая функция вернет вероятность того, что в точности одна конфета окажется карамелькой.

ГИПЕРГЕОМЕТ(1;4;8;20) равняется 0,363261


ДИСП

См. также

Оценивает дисперсию по выборке.

Синтаксис

ДИСП(число1;число2; ...)

Число1, число2, ... - это от 1 до 30 числовых аргументов, соответствующих выборке из генеральной совокупности.

Замечания

  • ДИСП предполагает, что аргументы являются только выборкой из генеральной совокупности. Если данные представляют всю генеральную совокупность, вычисляйте дисперсию, используя функцию ДИСПР.

  • Логические значения, такие как ИСТИНА или ЛОЖЬ, а также текст игнорируются. Если они не должны игнорироваться, пользуйтесь функцией рабочего листа ДИСПА.

  • ДИСП использует следующую формулу:

Пример

Предположим, что из инструментов, отштампованных одной и той же машиной, выбраны наугад 10 штук и испытаны на излом. Значения выборки (1345, 1301, 1368, 1322, 1310, 1370, 1318, 1350, 1303, 1299) сохранены в ячейках A2:E3 соответственно. Тогда функция ДИСП оценивает дисперсию сопротивления на излом для всех инструментов.

ДИСП(A2:E3) равняется 754,3


ДИСП

См. также

Оценивает дисперсию по выборке. В расчете помимо численных значений учитываются также текстовые и логические значения, такие как ИСТИНА или ЛОЖЬ.

Синтаксис

ДИСПА(значение1,значение2,...)

Значение1,значение2,... - это от 1 до 30 числовых аргументов, соответствующих выборке из генеральной совокупности.

Замечания

  • ДИСПА предполагает, что аргументы являются только выборкой из генеральной совокупности. Если данные представляют всю генеральную совокупность, вычисляйте дисперсию, используя функцию ДИСПРА.

  • Аргументы, содержащие значение ИСТИНА интерпретируются как 1, аргументы, содержащие текст или значение ЛОЖЬ интерпретируются как 0 (ноль). Если текст и логические значения должны игнорироваться, следует использовать функцию рабочего листа ДИСП.

  • ДИСПА использует следующую формулу:

Пример

Предположим, что из инструментов, отштампованных одной и той же машиной, выбраны наугад 10 штук и испытаны на излом. Значения выборки (1345, 1301, 1368, 1322, 1310, 1370, 1318, 1350, 1303, 1299) сохранены в ячейках A2:E3 соответственно. Тогда функция ДИСПА оценивает дисперсию сопротивления на излом для всех инструментов.

ДИСПА(A2:E3) равняется 754,3


ДИСПР

См. также

Вычисляет дисперсию для генеральной совокупности.

Синтаксис

ДИСПР(число1;число2; ...)

Число1, число2, ... - это от 1 до 30 числовых аргументов, соответствующих генеральной совокупности.

  • Логические значения, например ИСТИНА и ЛОЖЬ, а также текст игнорируются. Если они не должны игнорироваться, используйте функцию листа Excel ДИСПРА.

Замечания

  • ДИСПР предполагает, что аргументы представляют всю генеральную совокупность. Если данные представляют только выборку из генеральной совокупности, то дисперсию следует вычислять используя функцию ДИСП.

  • Уравнение для ДИСПР имеет следующий вид:

Пример

Будем использовать данные из примера для функции ДИСП и положим, что всего было произведено 10 инструментов. Функция ДИСПР измеряет дисперсию сопротивления на излом для всех инструментов.

ДИСПР(A2:E3) равняется 678,8


ДИСПР

См. также

Вычисляет дисперсию для генеральной совокупности. В расчете помимо численных значений учитываются также текстовые и логические значения, такие как ИСТИНА или ЛОЖЬ.

Синтаксис

ДИСПРА(значение1,значение2,...)

Значение1,значение2,... - это от 1 до 30 числовых аргументов, соответствующих генеральной совокупности.

Замечания

  • ДИСПРА предполагает, что аргументы представляют всю генеральную совокупность. Если данные представляют только выборку из генеральной совокупности, то дисперсию следует вычислять используя функцию ДИСПА.

  • Аргументы, содержащие значение ИСТИНА интерпретируются как 1, аргументы, содержащие текст или значение ЛОЖЬ интерпретируются как 0 (ноль). Если текст и логические значения должны игнорироваться, следует использовать функцию рабочего листа ДИСПР.

  • ДИСПРА использует следующую формулу:

Пример

Будем использовать данные из примера для функции ДИСПА и положим, что всего было произведено 10 инструментов. Функция ДИСПРА измеряет дисперсию сопротивления на излом для всех инструментов.

ДИСПРА(A2:E3) равняется 678,8


ДОВЕРИТ

См. также

Возвращает доверительный интервал для среднего генеральной совокупности. Доверительный интервал - это интервал с обеих сторон от среднего выборки. Например, если Вы заказали товар по почте, то Вы можете определить с определенным уровнем достоверности самую раннюю и самую позднюю даты прибытия товара.

Синтаксис

ДОВЕРИТ(альфа;станд_откл;размер)

Альфа - это уровень значимости используемый для вычисления уровня надежности. Уровень надежности равняется 100*(1 - альфа) процентам, или, другими словами, альфа равное 0,05 означает 95-процентный уровень надежности.

Станд_откл - это стандартное отклонение генеральной совокупности для интервала данных, предполагается известным.

Размер - это размер выборки.

Замечания

  • Если какой-либо из аргументов не является числом, то функция ДОВЕРИТ возвращает значение ошибки #ЗНАЧ!.

  • Если альфа ≤ 0 или альфа ≥ 1, то функция ДОВЕРИТ возвращает значение ошибки #ЧИСЛО!.

  • Если станд_откл ≤ 0, то функция ДОВЕРИТ возвращает значение ошибки #ЧИСЛО!.

  • Если размер не целое, то оно усекается.

  • Если размер < 1, то функция ДОВЕРИТ возвращает значение ошибки #ЧИСЛО!.

  • Если предположить, что альфа равняется 0,05, то нужно определить ту часть стандартной нормальной кривой, которая равняется (1 - альфа), или 95 процентам. Это значение равно ± 1,96. Доверительный интервал, следовательно, определяется следующим образом:

Пример

Предположим, что в нашем примере с 50 пассажирами, пользующимися сезонными билетами, средняя продолжительность поездки на работу составляет 30 минут со стандартным отклонением для генеральной совокупности равным 2,5. В таком случае, мы можем быть на 95 процентов уверены в том, что среднее для генеральной совокупности находится в интервале:

или:

ДОВЕРИТ(0,05;2,5;50) равняется 0,692951. Другими словами, средняя продолжительность поездки на работу составляет 30 ± 0.692951 минут или от 29,3 до 30,7 минут.


КВАДРОТКЛ

См. также

Возвращает сумму квадратов отклонений точек данных от их среднего.

Синтаксис

КВАДРОТКЛ(число1;число2;...)

Число1, число2, ... - это от 1 до 30 аргументов, для которых вычисляется сумма квадратов отклонений. Можно использовать массив или ссылку на массив вместо аргументов, разделяемых точкой с запятой.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Уравнение для суммы квадратов отклонений имеет следующий вид:

Пример

КВАДРОТКЛ(4;5;8;7;11;4;3) равняется 48


КВАРТИЛЬ

См. также

Возвращает квартиль множества данных. Квартиль часто используются при анализе продаж, чтобы разбить генеральную совокупность на группы. Например, можно использовать функцию КВАРТИЛЬ, чтобы найти 25 процентов наиболее доходных предприятий среди всех.

Синтаксис

КВАРТИЛЬ(массив;часть)

Массив - это массив или интервал ячеек с числовыми значениями, для которых определяется значения квартилей.

Часть - это значение, которое нужно вернуть.

Если часть равна | То КВАРТИЛЬ возвращает
0 | Минимальное значение
1 | Первую квартиль (25-ую персентиль)
2 | Значение медианы (50-ую персентиль)
3 | Третью квартиль (75-ую персентиль)
4 | Максимальное значение

Замечания

  • Если массив пуст или содержит более 8191 точек данных, то функция КВАРТИЛЬ возвращает значение ошибки #ЧИСЛО!.

  • Если часть не целое, то оно усекается.

  • Если часть < 0 или часть > 4, то функция КВАРТИЛЬ возвращает значение ошибки #ЧИСЛО!.

  • МИН, МЕДИАНА и МАКС возвращают то же значение, что и функция КВАРТИЛЬ, если аргумент часть равен 0 (нулю), 2 или 4 соответственно.

Пример

КВАРТИЛЬ({1;2;4;7;8;9;10;12};1) равняется 3,5


КВПИРСОН

См. также

Возвращает квадрат коэффициента корреляции Пирсона для точек данных в аргументах известные_значения_y и известные_значения_x. Для получения более подробной информации см. ПИРСОН. Значение r-квадрат можно интерпретировать как отношение дисперсии для y к дисперсии для x.

Синтаксис

КВПИРСОН(известные_значения_y;известные_значения_x)

Известные_значения_y - это массив или интервал точек данных.

Известные_значения_x - это массив или интервал точек данных.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если известные_значения_y и известные_значения_x пусты или содержат различное число точек данных, то функция КВПИРСОН возвращает значение ошибки #Н/Д.

  • Уравнение коэффициента r линии регрессии имеет следующий вид:

Пример

КВПИРСОН({2;3;9;1;8;7;5};{6;5;11;7;5;4;4}) равняется 0,05795


КОВАР

См. также

Возвращает ковариацию, то есть среднее произведений отклонений для каждой пары точек данных. Ковариация используется для определения связи между двумя множествами данных. Например, можно проверить, соответствует ли более высокому уровню доходов более высокий уровень образования.

Синтаксис

КОВАР(массив1; массив2)

Массив1 - это первый массив или интервал данных.

Массив2 - это второй массив или интервал данных.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если массив1 и массив2 имеют различное число данных, то КОВАР возвращает значение ошибки #Н/Д.

  • Если либо массив1, либо массив2 пуст, то КОВАР возвращает значение ошибки #ДЕЛ/0!.

  • Ковариация определяется следующим образом:

Пример

КОВАР({3; 2; 4; 5; 6}; {9; 7; 12; 15; 17}) равняется 5,2


КОРРЕЛ

См. также

Возвращает коэффициент корреляции меду интервалами ячеек массив1 и массив2. Коэффициент корреляции используется для определения наличия взаимосвязи между двумя свойствами. Например, можно установить зависимость между средней температурой в помещении и использованием кондиционера.

Синтаксис

КОРРЕЛ(массив1;массив2)

Массив1 - это ячейка интервала значений.

Массив2 - это второй интервал ячеек со значениями.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если массив1 и массив2 имеют различное количество точек данных, то функция КОРРЕЛ возвращает значение ошибки #Н/Д.

  • Если массив1 либо массив2 пуст, или если σ (стандартное отклонение) их значений равно нулю, то функция КОРРЕЛ возвращает значение ошибки #ДЕЛ/0!.

  • Уравнение для коэффициента корреляции имеет следующий вид:

    где:

    и:

Пример

КОРРЕЛ({3;2;4;5;6};{9;7;12;15;17}) равняется 0,997054


КРИТБИНОМ

См. также

Возвращает наименьшее значение, для которого интегральное биномиальное распределение больше или равно заданному критерию. Эта функция используется в приложениях, связанных с контролем качества. Например, функция КРИТБИНОМ используется для определения наибольшего допустимого числа дефектных комплектующих, которые можно удалять со сборочной линии без отбраковки всего изделия.

Синтаксис

КРИТБИНОМ(число_испытаний;вероятность_успеха;альфа)

Число_испытаний - это число испытаний Бернулли.

Вероятность_успеха - это вероятность успеха в каждом испытании.

Альфа - это значение критерия.

Замечания

  • Если какой-либо из аргументов не является числом, то функция КРИТБИНОМ возвращает значение ошибки #ЗНАЧ!.

  • Если число_испытаний не целое, то оно усекается.

  • Если число_испытаний < 0, то функция КРИТБИНОМ возвращает значение ошибки #ЧИСЛО!.

  • Если вероятность_успеха < 0 или вероятность_успеха > 1, то функция то функция КРИТБИНОМ возвращает значение ошибки #ЧИСЛО!.

  • Если альфа < 0 или альфа > 1, то функция то функция КРИТБИНОМ возвращает значение ошибки #ЧИСЛО!.

Пример

КРИТБИНОМ(6;0,5;0,75) равняется 4


ЛГРФПРИБЛ

См. также

В регрессионном анализе вычисляется экспоненциальная кривая, аппроксимирующая данные и возвращается массив значений, описывающий эту кривую. Поскольку данная функция возвращает массив значений, она должна вводиться как формула массива. Для получения более подробных сведений о формулах массива, нажмите кнопку [image] .

Уравнение кривой следующее:

y = b*m^x или y = (b*(m1^x1)*(m2^x2)*_) (при наличии нескольких значений x),

где зависимые значения y являются функцией независимых значений x. Значения m являются основанием, возводимым в степень x, а значения b постоянны. Заметим, что y, x и m могут быть векторами. Функция ЛГРФПРИБЛ возвращает массив {mn;mn-1;...;m1;b}.

Синтаксис

ЛГРФПРИБЛ(известные_значения_y;известные_значения_x;конст;статистика)

Известные_значения_y — это множество значений y, которые уже известны в соотношении y = b*m^x.

  • Если массив известные_значения_y имеет один столбец, то каждый столбец массива известные_значения_x интерпретируется как отдельная переменная.

  • Если массив известные_значения_y имеет одну строку, то каждая строка массива известные_значения_x интерпретируется как отдельная переменная.

Известные_значения_x — это необязательное множество значений x, которые уже известны для соотношения y = b*m^x.

  • Массив известные_значения_x может включать одно или более множеств переменных. Если используется только одна переменная, то известные_значения_y и известные_значения_x могут быть диапазонами любой формы, если только они имеют одинаковые размерности. Если используется более одной переменной, то аргумент известные_значения_y должен быть диапазоном ячеек высотой в одну строку или шириной в один столбец (так называемым вектором).

  • Если известные_значения_x опущены, то предполагается, что это массив {1;2;3;...} такого же размера, как и известные_значения_y.

Конст — это логическое значение, которое указывает, требуется ли, чтобы константа b была равна 1.

  • Если конст имеет значение ИСТИНА или опущено, то b вычисляется обычным образом.

  • Если конст имеет значение ЛОЖЬ, то b полагается равным 1 и значения m подбираются так, чтобы удовлетворить соотношению y = m^x.

Статистика — это логическое значение, которое указывает, требуется ли вернуть дополнительную статистику по регрессии.

  • Если статистика имеет значение ИСТИНА, то функция ЛГРФПРИБЛ возвращает дополнительную статистику по регрессии, то есть возвращает массив {mn;mn-1;...;m1;b:sen;sen-1;...;se1;seb:r 2;sey;F;df:ssreg;ssresid}.

  • Если статистика имеет значение ЛОЖЬ или опущено, то функция ЛГРФПРИБЛ возвращает только коэффициенты m и константу b.

Для получения более подробной информации о дополнительной статистике по регрессии, см. справку по функции ЛИНЕЙН.

Замечания

  • Чем больше график Ваших данных напоминает экспоненциальную кривую, тем лучше вычисленная кривая будет аппроксимировать данные. Так же, как функция ЛИНЕЙН, функция ЛГРФПРИБЛ возвращает массив, который описывает зависимость между значениями, но ЛИНЕЙН подгоняет прямую линию к имеющимся данным, а ЛГРФПРИБЛ подгоняет экспоненциальную кривую. Для получения более подробной информации, см. справку по функции ЛИНЕЙН.

  • Если имеется только одна независимая переменная x, то значения наклона (m) и пересечения с осью y (b) можно получить непосредственно, используя следующие формулы:

    Наклон (m):
    ИНДЕКС(ЛГРФПРИБЛ(известные_значения_y;известные_значения_x);1)

    Пересечение с осью y (b):
    ИНДЕКС(ЛГРФПРИБЛ(известные_значения_y;известные_значения_x);2)

    Можно использовать уравнение y = b*m^x для предсказания будущих значений y, но в Microsoft Excel предусмотрена функция РОСТ для этой цели. Для получения более подробной информации, см. справку по функции РОСТ.

  • Формулы, которые возвращают массивы, должны быть введены как формулы массивов. Для получения дополнительных сведений о формулах массивов нажмите кнопку [image] .

  • При вводе массива констант, такого как известные_значения_x, в качестве аргумента, следует использовать точки с запятой для разделения значений в одной строке и двоеточия для разделения строк. Символы-разделители могут быть разными, в зависимости от национальных установок.

  • Следует помнить, что значение y, предсказанное с помощью уравнения регрессии, может быть недостоверным, если оно находится вне диапазона значений y, которые использовались для определения коэффициентов уравнения.

Пример

После 10 месяцев, во время которых торговля шла вяло, компания обнаружила экспоненциальный рост количества продаж, выбросив на рынок новый товар. В последующие 6 месяцев количество продаж возросло до 33100, 47300, 69000, 102000, 150000 и 220000 штук в месяц. Предположим, что эти значения введены в шесть ячеек с именем «ШтукПродано». Тогда формула:

ЛГРФПРИБЛ(ШтукПродано; {11:12:13:14:15:16}; ИСТИНА; ИСТИНА)

сгенерирует следующий результат, например, в ячейках D1:E5:

{1,46327563; 495,30477: 0,0026334; 0,03583428: 0,99980862; 0,01101631: 20896,8011; 4: 2,53601883; 0,00048544}

y = b*m1^x1 или, используя значения из массива:

y = 495,3 * 1,4633x

Можно оценить количество продаж в последующие месяцы либо подставив номер месяца в качестве x в это уравнение, либо воспользовавшись функцией РОСТ. Для получения более подробной информации см. справку по функции РОСТ.

Можно использовать дополнительную статистику по регрессии (ячейки D2:E5 в приведенном выше примере), чтобы оценить, насколько полезно полученное уравнение для предсказания будущих значений.

Важно! Методы, которые используются для проверки уравнений, полученных с помощью функции ЛГРФПРИБЛ, такие же, как и для функции ЛИНЕЙН. Однако, дополнительная статистика, которую возвращает функция ЛГРФПРИБЛ, основана на следующей линейной модели:

ln y = x1 ln m1 + ... + xn ln mn + ln b

Это следует помнить при оценке дополнительной статистики, особенно значений sei и seb, которые следует сравнивать с ln mi и ln b, а не с mi и b. Для получения более подробной информации, см. любой справочник по математической статистике.


ЛИНЕЙН

См. также

Расчитывает статистику для ряда с применением метода наименьших квадратов, чтобы вычислить прямую линию, которая наилучшим образом аппроксимирует имеющиеся данные. Функция возвращает массив, который описывает полученную прямую. Поскольку возвращается массив значений, функция должна задаваться в виде формулы массива. Для получения дополнительных сведений о формулах массива нажмите кнопку [image] .

Уравнение для прямой линии имеет следующий вид:

y = mx + b или y = m1x1 + m2x2 + ... + b (в случае нескольких диапазонов значений x)

где зависимое значение y является функцией независимого значения x. Значения m — это коэффициенты, соответствующие каждой независимой переменной x, а b — это постоянная. Заметим, что y, x и m могут быть векторами. Функция ЛИНЕЙН возвращает массив {mn;mn-1;...;m1;b}. ЛИНЕЙН может также возвращать дополнительную регрессионную статистику.

Синтаксис

ЛИНЕЙН(известные_значения_y;известные_значения_x;конст;статистика)

Известные_значения_y — это множество значений y, которые уже известны в соотношении y = mx + b.

  • Если массив известные_значения_y имеет один столбец, то каждый столбец массива известные_значения_x интерпретируется как отдельная переменная.

  • Если массив известные_значения_y имеет одну строку, то каждая строка массива известные_значения_x интерпретируется как отдельная переменная.

Известные_значения_x — это необязательное множество значений x, которые уже известны в соотношении y = mx + b.

  • Массив известные_значения_x может содержать одно или несколько множеств переменных. Если используется только одна переменная, то известные_значения_y и известные_значения_x могут иметь любую форму, при условии, что они имеют одинаковую размерность. Если используется более одной переменной, то известные_значения_y должны быть вектором (то есть диапазоном высотой в одну строку или шириной в один столбец).

  • Если известные_значения_x опущены, то предполагается, что это массив {1;2;3;...} такого же размера, как и известные_значения_y.

Конст — это логическое значение, которое указывает, требуется ли, чтобы константа b была равна 0.

  • Если аргумент конст имеет значение ИСТИНА или опущено, то b вычисляется обычным образом.

  • Если аргумент конст имеет значение ЛОЖЬ, то b полагается равным 0 и значения m подбираются так, чтобы выполнялось соотношение y = mx.

Статистика — это логическое значение, которое указывает, требуется ли вернуть дополнительную статистику по регрессии.

  • Если аргумент статистика имеет значение ИСТИНА, то функция ЛИНЕЙН возвращает дополнительную регрессионную статистику, так что возвращаемый массив будет иметь вид: {mn;mn-1;...;m1;b:sen;sen-1;...;se1;seb:r2;sey:F;df:ssreg;ssresid}.

  • Если аргумент статистика имеет значение ЛОЖЬ или опущена, то функция ЛИНЕЙН возвращает только коэффициенты m и постоянную b.

Дополнительная регрессионая статистика:

Величина | Описание
se1,se2,...,sen | Стандартные значения ошибок для коэффициентов m1,m2,...,mn.
seb | Стандартное значение ошибки для постоянной b (seb = #Н/Д, если конст имеет значение ЛОЖЬ).
r2 | Коэффициент детерминированности. Сравниваются фактические значения y и значения, получаемые из уравнения прямой; по результатам сравнения вычисляется коэффициент детерминированности, нормированный от 0 до 1. Если он равен 1, то имеет место полная корреляция с моделью, т.е. нет различия между фактическим и оценочным значениями y. В противоположном случае, если коэффициент детерминированности равен 0, то уравнение регрессии неудачно для предсказания значений y. Для получения информации о том, как вычисляется r2, см. "Замечания" в конце данного раздела.
sey | Стандартная ошибка для оценки y.
F | F-статистика, или F-наблюдаемое значение. F-статистика используется для определения того, является ли наблюдаемая взаимосвязь между зависимой и независимой переменными случайной или нет.
df | Степени свободы. Степени свободы полезны для нахождения F-критических значений в статистической таблице. Для определения уровня надежности модели нужно сравнить значения в таблице с F-статистикой, возвращаемой функцией ЛИНЕЙН.
ssreg | Регрессионая сумма квадратов.
ssresid | Остаточная сумма квадратов.

На приведенном ниже рисунке показано, в каком порядке возвращается дополнительная регрессионная статистика.

Замечания

  • Любую прямую можно описать ее наклоном и пересечением с осью y:

    Наклон (m):
    Для того, чтобы определить наклон прямой, обычно обозначаемый через m, нужно взять две точки прямой (x1,y1) и (x2,y2); тогда наклон равен (y2 - y1)/(x2 - x1).

    Y-пересечение (b):
    Y-пересечением прямой, обычно обозначаемым через b, является значение y для точки, в которой прямая пересекает ось y.

    Уравнение прямой имеет вид y = mx + b. Если известны значения m и b, то можно вычислить любyю точку на прямой, подставляя значения y или x в уравнение. Можно также использовать функцию ТЕНДЕНЦИЯ. Для получения более подробной информации см. справку по функции ТЕНДЕНЦИЯ.

  • Если имеется только одна независимая переменная x, можно получить наклон и y-пересечение непосредственно, используя следующие формулы:

    Наклон:
    ИНДЕКС(ЛИНЕЙН(известные_значения_y;известные_значения_x);1)

    Y-пересечение:
    ИНДЕКС(ЛИНЕЙН(известные_значения_y;известные_значения_x);2)

  • Точность аппроксимации с помощью прямой, вычисленной функцией ЛИНЕЙН, зависит от степени разброса данных. Чем ближе данные к прямой, тем более точной является модель, используемая функцией ЛИНЕЙН. Функция ЛИНЕЙН использует метод наименьших квадратов для определения наилучшей аппроксимации данных. Когда имеется только одна независимая переменная x, m и b вычисляются по следующим формулам:

  • Функции аппроксимации ЛИНЕЙН и ЛГРФПРИБЛ могут вычислить прямую или экспоненциальную кривую, наилучшим образом описывающую данные. Однако они не дают ответа на вопрос, какой из двух результатов в наибольшей степени подходит для решения поставленной задачи. Можно также вычислить функцию ТЕНДЕНЦИЯ(известные_значения_y; известные_значения_x) для прямой или функцию РОСТ(известные_значения_y; известные_значения_x) для экспоненциальной кривой. Эти функции, если не задавать аргумент новые_значения_x, возвращают массив вычисленных значений y для фактических значений x в соответствии с прямой или кривой. Теперь можно сравнить вычисленные значения с фактическими значениями. Можно также построить диаграммы для визуального сравнения.

  • Проводя регрессионный анализ, Microsoft Excel вычисляет для каждой точки квадрат разности между прогнозируемым значением y и фактическим значением y. Сумма этих квадратов разностей называется остаточной суммой квадратов. Затем Microsoft Excel подсчитывает сумму квадратов разностей между фактическими значениями y и средним значением y, которая называется общей суммой квадратов (регрессионая сумма квадратов + остаточная сумма квадратов). Чем меньше остаточная сумма квадратов по сравнению с общей суммой квадратов, тем больше значение коэффициента детерминированности r2, который показывает, насколько хорошо уравнение, полученное с помощью регрессионного анализа, объясняет взаимосвязи между переменными.

  • Формулы, которые возвращают массивы, должны быть введены как формулы массивов. Для получения дополнительных сведений о формулах массивов нажмите кнопку [image] .

  • При вводе массива констант в качестве, например, аргумента известные_значения_x, следует использовать точку с запятой для разделения значений в одной строке и двоеточие для разделения строк. Знаки-разделители могут быть различными и зависят от установок для разных стран.

  • Заметьте, что значения y, предсказанные с помощью уравнения регрессии, возможно не будут правильными, если они располагаются вне интервала значений y, которые использовались для определения уравнения.

Пример 1 Наклон и Y-пересечение

ЛИНЕЙН({1;9;5;7};{0;4;2;3}) равняется {2;1}, наклон = 2 и y-пересечение = 1.

Пример 2 Простая Линейная Регрессия

Предположим, что небольшая фирма имела продажи на сумму 3100 р., 4500 р., 4400 р., 5400 р., 7500 р. и 8100 р. за первые шесть месяцев отчетного года. Пусть эти значения находятся в интервале ячеек B2:B7. Тогда можно использовать следующую простую линейную регрессионную модель для оценки объема продаж в девятом месяце.

СУММ(ЛИНЕЙН(B2:B7)*{9;1}) равняется СУММ({1000;2000}*{9;1}) равняется 11 000 р.

В общем случае СУММ({m;b}*{x;1}) равняется mx + b, то есть значению y для данного значения x. Для этих же целей можно использовать функцию ТЕНДЕНЦИЯ.

Пример 3 Множественная Линейная Регрессия

Предположим, что застройщик оценивает стоимость группы небольших офисных зданий в традиционном деловом районе.

Застройщик может использовать множественный регрессионный анализ для оценки цены офисного здания в заданном районе на основе следующих переменных.

Переменная | Смысл переменной
y | Оценочная цена здания под офис
x1 | Общая площадь в квадратных метрах
x2 | Количество офисов
x3 | Количество входов
x4 | Время эксплуатации здания в годах

В этом примере предполагается, что существует линейная зависимость между каждой независимой переменной (x1, x2, x3 и x4) и зависимой переменной (y), то есть ценой здания под офис в данном районе.

Застройщик наугад выбирает 11 зданий из имеющихся 1500 и получает следующие данные.

"Пол-входа" (1/2) означает вход только для доставки корреспонденции. При вводе в качестве функции массива приведенная ниже формула:

ЛИНЕЙН(E2:E12;A2:D12;TRUE;TRUE)

возвращает следующие результаты.

Уравнение множественной регрессии y = m1*x1 + m2*x2 + m3*x3 + m4*x4 + b теперь может быть получено из строки 14:

y = 27,64*x1 + 12530*x2 + 2553*x3+ 234,24*x4 + 52318

Теперь застройщик может определить оценочную стоимость здания под офис в том же районе, которое имеет площадь 2500 квадратных метров, три офиса, два входа, зданию 25 лет, используя следующее уравнение:

y = 27,64*2500 + 12530*3 + 2553*2 - 234,24*25 + 52318 = 158 261 р.

Это значение может быть также вычислено с помощью функции ТЕНДЕНЦИЯ. Для получения более подробной информации см. справку по функции ТЕНДЕНЦИЯ.

Пример 4 Использование статистик F и R2

В предыдущем примере коэффициент детерминированности r2 равен 0,99675 (см. ячейку A16 в результатах функции ЛИНЕЙН), что указывает на сильную зависимость между независимыми переменными и продажной ценой. Можно использовать F-статистику, чтобы определить, является ли этот результат (с таким высоким значение r2 ) случайным.

Предположим, что на самом деле нет взаимосвязи между переменными, а просто были выбраны редкие 11 образцов зданий, для которых статистический анализ вывел сильную взаимозависимость. Величина Альфа используется для обозначения вероятности ошибочного вывода о том, что имеется сильная взаимозависимость.

Если F-наблюдаемое больше, чем F-критическое, то взаимосвязь между переменными имеется. F-критическое можно получить из таблицы F-критических значений в любом справочнике по математической статистике. Для того, чтобы найти это значение, используя односторонний тест, положим величину Альфа равной 0,05, а для числа степеней свободы (обозначаемых обычно v1 и v2), положим v1 = k = 4 и v2 = n - (k + 1) = 11 - (4 + 1) = 6, где k - это число переменных, а n - число точек данных. Из таблицы справочника F-критическое равно 4,53.

Наблюдаемое F-значение равно 459,753674 (ячейка A17), что заметно больше чем F-критическое значение 4,53. Следовательно, полученное регрессионное уравнение полезно для предсказания оценочной стоимости зданий в данном районе.

Пример 5 Вычисление T-статистики

Другой гипотетический эксперимент определит, полезен ли каждый коэффициент наклона для оценки стоимости здания под офис в примере 3. Например, для проверки того, что срок эксплуатации здания имеет статистическую значимость, разделим -234,24 (коэффициент наклона для срока эксплуатации здания) на 13,268 (оценка стандартной ошибки для коэффициента времени эксплуатации из ячейки A15). Ниже приводится наблюдаемое t-значение:

t = m4 ч se4 = -234.24 ч 13.268 = -17.7

Если посмотреть в таблицу справочника по математической статистике, то окажется, что t-критическое с 6 степенями свободы и Альфа = 0,05 равно 1,94. Поскольку абсолютная величина t, равная 17,7, больше, чем 1,94, срок эксплуатации - это важная переменная для оценки стоимости здания под офис. Аналогичным образом можно протестировать все другие переменные на статистическую значимость. Ниже приводятся наблюдаемые t-значения для каждой из независимых переменных:

Переменная | t-наблюдаемое значение
Общая площадь | 5.1
Количество офисов | 31.3
Количество входов | 4.8
Срок эксплуатации | 17.7

Все эти значения имеют абсолютную величину большую, чем 1,94; следовательно, все переменные, использованные в уравнении регрессии, полезны для предсказания оценочной стоимости здания под офис в данном районе.


ЛОГНОРМОБР

См. также

Возвращает обратную функцию логарифмического нормального распределения x, где ln(x) имеет нормальное распределение с параметрами среднее и стандартное_отклонение. Если p = ЛОГНОРМРАСП(x;...), то ЛОГНОРМОБР(p;...) = x.

Логарифмическое нормальное распределение используется для анализа логарифмически преобразованных данных.

Синтаксис

ЛОГНОРМОБР(вероятность;среднее;стандартное_отклонение)

Вероятность - это вероятность, связанная с нормальным логарифмическим распределением.

Среднее - это среднее ln(x).

Стандартное_отклонение - это стандартное отклонение ln(x).

Обратная функция логарифмического нормального распределения имеет следующий вид:

Замечания

  • Если любой из аргументов не является числом, то функция ЛОГНОРМОБР возвращает значение ошибки #ЗНАЧ!.

  • Если вероятность < 0 или вероятность > 1, то функция ЛОГНОРМОБР возвращает значение ошибки #ЧИСЛО!.

  • Если стандартное_отклонение <= 0, то функция ЛОГНОРМОБР возвращает значение ошибки #ЧИСЛО!.

Пример

ЛОГНОРМОБР(0,039084; 3,5; 1,2) равняется 4,000014


ЛОГНОРМРАСП

См. также

Возвращает интегральное логарифмическое нормальное распределение для x, где ln(x) является нормально распределенным с параметрами среднее и стандартное_откл. Эта функция используется для анализа данных, которые были логарифмически преобразованы.

Синтаксис

ЛОГНОРМРАСП(x;среднее;стандартное_откл)

X - это значение, для которого вычисляется функция.

Среднее - это среднее ln(x).

Стандартное_отклонение - это стандартное отклонение ln(x).

Замечания

  • Если какой-либо из аргументов не является числом, то функция ЛОГНОРМРАСП возвращает значение ошибки #ЗНАЧ!.

  • Если x ≤ 0 или стандартное_откл ≤ 0, то функция ЛОГНОРМРАСП возвращает значение ошибки #ЧИСЛО!.

  • Уравнение для функции интегрального логарифмического нормального распределения имеет следующий вид:

Пример

ЛОГНОРМРАСП(4;3,5;1,2) равняется 0,039084


МАКС

См. также

Возвращает наибольшее значение из набора значений.

Синтаксис

МАКС(число1;число2; ...)

Число1, число2, ... - это от 1 до 30 чисел, среди которых ищется максимальное значение.

  • Можно задавать аргументы, которые являются числами, пустыми ячейками, логическими значениями или текстовыми представлениями чисел. Аргументы, которые являются значениями ошибки или текстами, не преобразуемыми в числа, вызывают значения ошибок.

  • Если аргумент является массивом или ссылкой, то в нем учитываются только числа. Пустые ячейки, логические значения или текст в массиве или ссылке игнорируются. Если логические значения или текст не должны игнорироваться, следует использовать функцию МАКСА.

  • Если аргументы не содержат чисел, то функция МАКС возвращает 0 (ноль).

Примеры

Если ячейки A1:A5 содержат числа 10, 7, 9, 27 и 2, то:

МАКС(A1:A5) равняется 27

МАКС(A1:A5;30) равняется 30


МАКС

См. также

Возвращает наибольшее значение в списке аргументов. Наряду с числовыми значениями выполняется также сравнение текстовых и логических, таких как ИСТИНА и ЛОЖЬ, значений.

Функция МАКСА родственна функции МИНА. Дополнительные сведения содержатся в примерах к функции МИНА.

Синтаксис

MAXA(значение1,значение2,...)

Значение1, значение2,... ... - это от 1 до 30 значений, среди которых ищется наибольшее.

Замечания

  • Можно задавать аргументы, которые являются числами, пустыми ячейками, логическими значениями или текстовыми представлениями чисел. Аргументы, которые являются значениями ошибки, приводят к ошибке. Если логические значения и тексты должны игнорироваться не должны следует пользоваться функцией рабочего листа МАКС.

  • Если аргументом является массив или ссылка, учитываются только значения массива или ссылки. Пустые ячейки и тексты в массиве или ссылке игнорируются.

  • Аргументы, содержащие значение ИСТИНА, интерпретируются как 1, аргументы, содержащие текст или значение ЛОЖЬ, интерпретируются как 0 (ноль).

  • Если аргументы не содержат значений, то функция МАКСА возвращает 0 (ноль).

Примеры

Если ячейки A1:A5 содержат числа 10, 7, 9, 27 и 2, то:

МАКСА(A1:A5) равняется 27

МАКСА(A1:A5,30) равняется 30

Если A1:A5 содержит значения 0; 0,2; 0,5; 0,4 и ИСТИНА, то:

МАКСА(A1:A5) равняется 1


МЕДИАНА

См. также

Возвращает медиану заданных чисел. Медиана - это число, которое является серединой множества чисел, то есть половина чисел имеют значения большие, чем медиана, а половина чисел имеют значения меньшие, чем медиана.

Синтаксис

МЕДИАНА(число1;число2; ...)

Число1, число2, ... - это от 1 до 30 чисел, для которых определяется медиана.

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа. Microsoft Excel проверяет все числа, содержащиеся в аргументах, которые являются массивами или ссылками.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

Замечания

Если в множестве четное количеств чисел, то функция МЕДИАНА вычисляет среднее двух чисел, находящихся в середине множества. См. второй из следующих примеров.

Примеры

МЕДИАНА(1; 2; 3; 4; 5) равняется 3

МЕДИАНА(1; 2; 3; 4; 5; 6) равняется 3,5, среднее 3 и 4


МИН

См. также

Возвращает наименьшее значение в списке аргументов.

Синтаксис

МИН(число1;число2; ...)

Число1, число2, ... — это от 1 до 30 чисел, среди которых ищется минимальное значение.

  • Можно задавать аргументы, которые являются числами, пустыми ячейками, логическими значениями или текстовыми представлениями чисел. Аргументы, которые являются значениями ошибки или текстами, не преобразуемыми в числа, вызывают значения ошибок.

  • Если аргумент является массивом или ссылкой, то учитываются только числа. Пустые ячейки, логические значения или тексты в массиве или ссылке игнорируются. Если логические значения или тексты игнорироваться не должны, следует пользоваться функцией МИНА.

  • Если аргументы не содержат чисел, то функция МИН возвращает 0.

Примеры

Если ячейки A1:A5 содержат числа 10, 7, 9, 27 и 2, то:

МИН(A1:A5) равняется 2

МИН(A1:A5; 0) равняется 0

МИН подобна функции МАКС. См. также примеры к функции МАКС.


МИН

См. также

Возвращает наименьшее значение в списке аргументов. Наряду с числовыми значениями выполняется также сравнение текстовых и логических, таких как ИСТИНА и ЛОЖЬ, значений.

Синтаксис

МИНА (значение1,значение2,...)

Значение1, значение2,... ... - это от 1 до 30 значений, среди которых ищется наименьшее.

  • Можно задавать аргументы, которые являются числами, пустыми ячейками, логическими значениями или текстовыми представлениями чисел. Аргументы, которые являются значениями ошибки, приводят к ошибке. Если логические значения и тексты должны игнорироваться не должны следует пользоваться функцией рабочего листа МИН.

  • Если аргументом является массив или ссылка, учитываются только значения массива или ссылки. Пустые ячейки и тексты в массиве или ссылке игнорируются.

  • Аргументы, содержащие значение ИСТИНА, интерпретируются как 1, аргументы, содержащие текст или значение ЛОЖЬ, интерпретируются как 0 (ноль).

  • Если аргументы не содержат значений, то функция МИНА возвращает 0 (ноль).

Примеры

Если ячейки A1:A5 содержат числа 10, 7, 9, 27 и 2, то:

МИНА(A1:A5) равняется 2

МИНА(A1:A5, 0) равняется 0

Если A1:A5 содержит значения ЛОЖЬ, 0,2; 0,5; 0,4 и 0,8, то:

МИНА(A1:A5) равняется 0

Функция МИНА родственна функции МАКСА. См. также примеры для МАКСА.


МОДА

См. также

Возвращает наиболее часто встречающееся или повторяющееся значение в массиве или интервале данных. Также как и функция МЕДИАНА, функция МОДА является мерой взаимно расположения значений

Синтаксис

МОДА(число1;число2; ...)

Число1, число2, ... - это от 1 до 30 аргументов, для которых вычисляется мода. Можно использовать один массив или одну ссылку на массив вместо аргументов, разделяемых точкой с запятой.

Замечания

  • Аргументы должны быть числами, именами, массивами или ссылками, которые содержат числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если множество данных не содержит одинаковых данных, то функция МОДА возвращает значение ошибки #Н/Д.

В наборе значений мода - это наиболее часто встречающееся значение; медиана - это значение в середине массива; среднее - это среднее арифметическое значение. Ни одно из этих чисел не характеризует в полной мере то, в какой степени центрированы данные. Пусть данные сгруппированы в трех областях, одна половина данных близка к некоторому малому значению, а другая половина данных близка к двум другим большим значениям. Обе функции СРЗНАЧ и МЕДИАНА могут вернуть значение из относительно пустой середины, а функция МОДА скорее всего вернет доминирующее малое значение.

Пример

МОДА({5,6; 4; 4; 3; 2; 4}) равняется 4


НАИБОЛЬШИЙ

См. также

Возвращает k-ое наибольшее значение из множества данных. Эта функция используется, чтобы выбрать значение по его относительному местоположению. Например, функцию НАИБОЛЬШИЙ можно использовать, чтобы определить наилучший, второй или третий результат в баллах, показанный при тестировании.

Синтаксис

НАИБОЛЬШИЙ(массив;k)

Массив - это массив или интервал данных, для которых определяется k-ое наибольшее значение.

K - это позиция (начиная с наибольшей) в массиве или интервале ячеек данных.

Замечания

  • Если массив пуст, то функция НАИБОЛЬШИЙ возвращает значение ошибки #ЧИСЛО!.

  • Если k ≤ 0 или если k больше, чем число точек данных, то функция НАИБОЛЬШИЙ возвращает значение ошибки #ЧИСЛО!.

Если n - это число точек данных в интервале, то функция НАИБОЛЬШИЙ(массив;1) возвращает наибольшее значение, а НАИБОЛЬШИЙ(массив;n) возвращает наименьшее значение.

Примеры

НАИБОЛЬШИЙ({3;4;5;2;3;4;5;6;4;7};3) равняется 5

НАИБОЛЬШИЙ({3;4;5;2;3;4;5;6;4;7};7) равняется 4


НАИМЕНЬШИЙ

См. также

Возвращает k-ое наименьшее значение в множестве данных. Эта функция используется для определения значения, занимающего определенное относительное положение в множестве данных.

Синтаксис

НАИМЕНЬШИЙ(массив;k)

Массив - это массив или диапазон числовых данных, для которого определяется k-ое наименьшее значение.

K - это позиция (начиная с наименьшей) в массиве или интервале ячеек данных.

Замечания

  • Если массив пуст, то функция НАИМЕНЬШИЙ возвращает значение ошибки #ЧИСЛО!.

  • Если k ≤ 0 или k больше, чем число точек данных, то функция НАИМЕНЬШИЙ возвращает значение ошибки #ЧИСЛО!.

  • Если n - это количество точек данных в аргументе массив, то НАИМЕНЬШИЙ(массив;1) равняется наименьшему значению, а НАИМЕНЬШИЙ(массив;n) равняется наибольшему значению.

Пример

НАИМЕНЬШИЙ({3;4;5;2;3;4;5;6;4;7};4) равняется 4

НАИМЕНЬШИЙ({1;4;8;3;7;12;54;8;23};2) равняется 3


НАКЛОН

См. также

Возвращает наклон линии линейной регрессии для точек данных в аргументах известные_значения_y и известные_значения_x. Наклон определяется как частное от деления расстояния по вертикали на расстояние по горизонтали между двумя любыми точками прямой, то есть наклон - это скорость изменения значений вдоль прямой.

Синтаксис

НАКЛОН(известные_значения_y;известные_значения_x)

Известные_значения_y - это массив или интервал ячеек, содержащих числовые зависимые точки данных.

Известные_значения_x - это множество независимых точек данных.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если известные_значения_y и известные_значения_x пусты или содержат различное число точек данных, то функция НАКЛОН возвращает значение ошибки #Н/Д.

  • Уравнение наклона линии регрессии имеет следующий вид:

Пример

НАКЛОН({2;3;9;1;8;7;5};{6;5;11;7;5;4;4}) равняется 0,305556


НОРМАЛИЗАЦИЯ

См. также

Возвращает нормализованное значение для распределения, характеризуемого средним и стандартным отклонением.

Синтаксис

НОРМАЛИЗАЦИЯ(x;среднее;стандартное_откл)

X - это нормализуемое значение.

Среднее - это среднее арифметическое распределения.

Стандартное_откл - это стандартное отклонение распределения.

Замечания

  • Если стандартное_откл ≤ 0, то функция НОРМАЛИЗАЦИЯ возвращает значение ошибки #ЧИСЛО!.

  • Уравнение для нормализованного значения имеет следующий вид:

Пример

НОРМАЛИЗАЦИЯ(42;40;1,5) равняется 1,333333


НОРМОБР

См. также

Возвращает обратное нормальное распределение для указанного среднего и стандартного отклонения.

Синтаксис

НОРМОБР(вероятность;среднее;стандартное_откл)

Вероятность - это вероятность, соответствующая нормальному распределению.

Среднее - это среднее арифметическое распределения.

Стандартное_откл - это стандартное отклонение распределения.

Замечания

  • Если какой-либо из аргументов не является числом, то функция НОРМОБР возвращает значение ошибки #ЗНАЧ!.

  • Если вероятность < 0 или вероятность > 1, то функция НОРМОБР возвращает значение ошибки #ЧИСЛО!.

  • Если стандартное_откл ≤ 0, то функция НОРМОБР возвращает значение ошибки #ЧИСЛО!.

НОРМОБР использует стандартное нормальное распределение, если среднее = 0 и стандартное_откл = 1 (см. НОРМСТОБР).

НОРМОБР использует метод итераций для вычисления функции. Если задано значение вероятности, то функция НОРМОБР производит итерации, пока не получит результат с точностью ± 3x10^-7. Если НОРМОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

НОРМОБР(0,908789;40;1,5) равняется 42


НОРМРАСП

См. также

Возвращает нормальную функцию распределения для указанного среднего и стандартного отклонения. Эта функция имеет очень широкий круг приложений в статистике, включая проверку гипотез.

Синтаксис

НОРМРАСП(x;среднее;стандартное_откл;интегральная)

X - это значение, для которого строится распределение.

Среднее - это среднее арифметическое распределения.

Стандартное_откл - это стандартное отклонение распределения.

Интегральная - это логическое значение, определяющее форму функции. Если интегральная имеет значение ИСТИНА, то функция НОРМРАСП возвращает интегральную функцию распределения; если это аргумент имеет значение ЛОЖЬ, то возвращается функция плотности распределения.

Замечания

  • Если среднее или стандартное_откл не является числом, то функция НОРМРАСП возвращает значение ошибки #ЗНАЧ!.

  • Если стандартное_откл ≤ 0, то функция НОРМРАСП возвращает значение ошибки #ЧИСЛО!.

  • Если среднее = 0 и стандартное_откл = 1, то функция НОРМРАСП возвращает стандартное нормальное распределение, то есть НОРМСТРАСП.

  • Уравнение для плотности нормального распределения имеет следующий вид:

Пример

НОРМРАСП(42;40;1,5;ИСТИНА) равняется 0,908789


НОРМСТОБР

См. также

Возвращает обратное значение стандартного нормального распределения. Это распределение имеет среднее равное нулю и стандартное отклонение равное единице.

Синтаксис

НОРМСТОБР(вероятность)

Вероятность - это вероятность, соответствующая нормальному распределению.

Замечания

  • Если вероятность не является числом, то функция НОРМСТОБР возвращает значение ошибки #ЗНАЧ!.

  • Если вероятность < 0 или вероятность > 1, то функция НОРМОБР возвращает значение ошибки #ЧИСЛО!.

НОРМСТОБР использует метод итераций для вычисления функции. Если задано значение вероятности, то функция НОРМСТОБР производит итерации, пока не получит результат с точностью ± 3x10^-7. Если НОРМСТОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

НОРМСТОБР(0,908789) равняется 1,3333


НОРМСТРАСП

См. также

Возвращает стандартное нормальное интегральное распределение. Это распределение имеет среднее равное нулю и стандартное отклонение равное единице. Эта функция используется вместо таблицы для стандартной нормальной кривой.

Синтаксис

НОРМСТРАСП(z)

Z - это значение, для которого строится распределение.

Замечания

  • Если z не является числом, то функция НОРМСТРАСП возвращает значение ошибки #ЗНАЧ!.

  • Уравнение плотности стандартного нормального распределения имеет следующий вид:

Пример

НОРМСТРАСП(1,333333) равняется 0,908789


ОТРБИНОМРАСП

См. также

Возвращает отрицательное биномиальное распределение. ОТРБИНОМРАСП возвращает вероятность того, что случится число_неудач неудачных испытаний, прежде чем будет достигнуто число_успехов успешных испытаний, при том условии, что вероятность успешного испытания постоянна и равна значению аргумента вероятность_успеха. Эта функция подобна биномиальному распределению, за тем исключением, что количество успехов фиксированное, а количество испытаний -- переменное. Как и в случае биномиального распределения, испытания считаются независимыми.

Например, вам нужно найти 10 человек с блестящими способностями, и вы знаете, что вероятность того, что кандидат обладает такими способностями, равна 0,3. Тогда функция ОТРБИНОМРАСП вычислит вероятность того, что придется провести собеседования с определенным количеством неподходящих кандидатов, прежде чем будут найдены все 10 подходящих кандидатов.

Синтаксис

ОТРБИНОМРАСП(число_неудач;число_успехов;вероятность_успеха)

Число_неудач - это количество неудачных испытаний.

Число_успехов - это пороговое значение числа успешных испытаний.

Вероятность_успеха - это вероятность успеха.

Замечания

  • Число_неудач и число_успехов усекаются до целых.

  • Если какой-либо из аргументов не является числом, то функция ОТРБИНОМРАСП возвращает значение ошибки #ЗНАЧ!.

  • Если вероятность_успеха < 0 или вероятность > 1, то функция ОТРБИНОМРАСП возвращает значение ошибки #ЧИСЛО!.

  • Если (число_неудач + число_успехов - 1) ≤ 0, то функция ОТРБИНОМРАСП возвращает значение ошибки #ЧИСЛО!.

  • Уравнение для отрицательного биномиального распределения имеет следующий вид:

    где:

    x - это число_неудач, r - это число_успехов, а p - это вероятность_успеха.

Пример

ОТРБИНОМРАСП(10;5;0,25) равняется 0,055049


ОТРЕЗОК

См. также

Вычисляет точку пересечения линии с осью y, используя известные_значения_x и известные_значения_y. Точка пересечения находится на оптимальной линии регрессии, проведенной через известные_значения_x и известные_значения_y. Функция используется, когда нужно определить значение зависимой переменной при значении независимой переменной равном 0 (нулю). Например, функцию ОТРЕЗОК можно использовать, чтобы предсказать электрическое сопротивление металла при температуре 0°C, если имеются данные измерений при комнатной температуре и выше.

Синтаксис

ОТРЕЗОК(известные_значения_x;известные_значения_y)

Известные_значения_y - это зависимое множество наблюдений или данных.

Известные_значения_x - это независимое множество наблюдений или данных.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, которые содержат числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если известные_значения_y и известные_значения_x содержат различное количество точек данных или вовсе не содержат точек данных, то функция ОТРЕЗОК возвращает значение ошибки #Н/Д.

  • Уравнение для точки пересечения линии линейной регрессии имеет следующий вид:

    где наклон вычисляется следующим образом:

Пример

ОТРЕЗОК({2; 3; 9; 1; 8}; {6; 5; 11; 7; 5}) равняется 0,0483871


ПЕРЕСТ

См. также

Возвращает количество перестановок для заданного числа объектов, которые выбираются из общего числа объектов. Перестановка - это любое множество или подмножество объектов или событий, в котором существен внутренний порядок. Этим перестановки отличаются от сочетаний, для которых внутренний порядок не существен. Эта функция используется, например, для вычисления вероятностей в лотереях.

Синтаксис

ПЕРЕСТ(число;число_выбранных)

Число - это целое число, задающее количество объектов.

Число_выбранных - это целое число, задающее количество объектов в каждой перестановке.

Замечания

  • Оба аргумента усекаются до целых.

  • Если число или число_выбранных не является числом, то функция ПЕРЕСТ возвращает значение ошибки #ЗНАЧ!.

  • Если число ≤ 0 или число_выбранных < 0, то функция ПЕРЕСТ возвращает значение ошибки #ЧИСЛО!.

  • Если число < число_выбранных, то функция ПЕРЕСТ возвращает значение ошибки #ЧИСЛО!.

  • Уравнение для числа перестановок имеет следующий вид:

Пример

Предположим, что нужно определить шансы угадать выигрышный лотерейный номер. Лотерейный номер состоит из трех чисел, каждое из которых может быть от 0 (ноль) до 99 включительно. Тогда следующая функция вычисляет количество возможных перестановок.

ПЕРЕСТ(100;3) равняется 970 200


ПЕРСЕНТИЛЬ

См. также

Возвращает k-ую персентиль для значений из интервала. Эта функция используется для определения порога приемлемости. Например, можно принять решение экзаменовать только тех кандидатов, которые набрали баллов более, чем 90-ая персентиль.

Синтаксис

ПЕРСЕНТИЛЬ(массив;k)

Массив - это массив или интервал данных с численными значениями, который определяет относительное положение.

K - это значение персентили в интервале от 0 до 1 включительно.

Замечания

  • Если массив пуст или содержит более 8191 точек данных, то функция ПЕРСЕНТИЛЬ возвращает значение ошибки #ЧИСЛО!.

  • Если k не является числом, то функция ПЕРСЕНТИЛЬ возвращает значение ошибки #ЗНАЧ!.

  • Если k < 0 или k > 1, то функция ПЕРСЕНТИЛЬ возвращает значение ошибки #ЧИСЛО!.

  • Если k не кратно 1/(n - 1), то функция ПЕРСЕНТИЛЬ производит интерполяцию для определения значения k-ой персентили.

Пример

ПЕРСЕНТИЛЬ({1;2;3;4};0,3) равняется 1,9


ПИРСОН

См. также

Возвращает коэффициент корреляции Пирсона r, безразмерный индекс в интервале от -1,0 до 1,0 включительно, который отражает степень линейной зависимости между двумя множествами данных.

Синтаксис

ПИРСОН(массив1;массив2)

Массив1 - это множество независимых значений.

Массив2 - это множество зависимых значений.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если массив1 или массив2 пуст, или они содержат различное число точек данных, то функция ПИРСОН возвращает значение ошибки #Н/Д.

  • Значение r линии регрессии имеет следующий вид:

Пример

ПИРСОН({9;7;5;3;1};{10;6;1;5;3}) равняется 0,699379


ПРЕДСКАЗ

См. также

Вычисляет или предсказывает будущее значение по существующим значениям. Предсказываемое значение - это y-значение, соответствующее заданному x-значению. Известные значения - это x- и y-значения, а новое значение предсказывается с использованием линейной регрессии. Эту функцию можно использовать для предсказания будущих продаж, потребностей в оборудовании или тенденций потребления.

Синтаксис

ПРЕДСКАЗ(x;известные_значения_y;известные_значения_x)

X - это точка данных, для которой предсказывается значение.

Известные_значения_y - это зависимый массив или интервал данных.

Известные_значения_x - это независимый массив или интервал данных.

Замечания

  • Если x не является числом, то функция ПРЕДСКАЗ возвращает значение ошибки #ЗНАЧ!.

  • Если известные_значения_y и известные_значения_x пусты или содержат различное количество точек данных, то функция ПРЕДСКАЗ возвращает значение ошибки #Н/Д.

  • Если дисперсия аргумента известные_значения_x равна нулю, то функция ПРЕДСКАЗ возвращает значение ошибки #ДЕЛ/0!.

  • Уравнение для ПРЕДСКАЗ имеет вид a+bx, где:

    и:

Пример

ПРЕДСКАЗ(30;{6;7;9;15;21};{20;28;31;38;40}) равняется 10,60725


ПРОЦЕНТРАНГ

См. также

Возвращает категорию значения в наборе данных как процентное содержание в наборе данных. Эта функция используется для оценки относительного положения точки данных в множестве данных. Например, можно использовать функцию ПРОЦЕНТРАНГ, чтобы оценить положение подходящего результата тестирования среди всех результатов тестирования.

Синтаксис

ПРОЦЕНТРАНГ(массив;x;разрядность)

Массив - это массив или интервал данных с численными значениями, который определяет относительное положение.

X - это значение, для которого определяется процентное содержание.

Разрядность - это необязательное значение, которое определяет количество значащих цифр в возвращаемой величине процентного содержания значения. Если этот аргумент опущен, то функция ПРОЦЕНТРАНГ использует три цифры (0,xxx%).

Замечания

  • Если массив пуст, то функция ПРОЦЕНТРАНГ возвращает значение ошибки #ЧИСЛО!.

  • Если разрядность < 1, то функция ПРОЦЕНТРАНГ возвращает значение ошибки #ЧИСЛО!.

  • Если x не соответствует ни одному из значений аргумента массив, то функция ПРОЦЕНТРАНГ производит интерполяцию и возвращает корректное значение процентного содержания.

Пример

ПРОЦЕНТРАНГ({1;2;3;4;5;6;7;8;9;10};4) равняется 0,333


ПУАССОН

См. также

Возвращает распределение Пуассона. Обычное применение распределения Пуассона состоит в предсказании количества событий, происходящих за определенное время, например, количество машин, появляющихся на площади за 1 минуту.

Синтаксис

ПУАССОН(x;среднее;интегральная)

X - это количество событий.

Среднее - это ожидаемое численное значение.

Интегральная - это логическое значение, определяющее форму возвращаемого распределения вероятностей. Если аргумент интегральная имеет значение ИСТИНА, то функция ПУАССОН возвращает интегральное распределение Пуассона, то есть вероятность того, что число случайных событий будет от 0 до x включительно; если этот аргумент имеет значение ЛОЖЬ, то возвращается функция плотности распределения Пуассона, то есть вероятность того, что событий будет в точности x.

Замечания

  • Если x не целое, то оно усекается.

  • Если x или среднее не является числом, то функция ПУАССОН возвращает значение ошибки #ЗНАЧ!.

  • Если x ≤ 0, то функция ПУАССОН возвращает значение ошибки #ЧИСЛО!.

  • Если среднее ≤ 0, то функция ПУАССОН возвращает значение ошибки #ЧИСЛО!.

  • Функция ПУАССОН вычисляется следующим образом.

    Если аргумент интегральная = ЛОЖЬ:

    Если аргумент интегральная = ИСТИНА:

Примеры

ПУАССОН(2;5;ЛОЖЬ) равняется 0,084224

ПУАССОН(2;5;ИСТИНА) равняется 0,124652


РАНГ

См. также

Возвращает ранг числа в списке чисел. Ранг числа - это его величина относительно других значений в списке. (Если список отсортировать, то ранг числа будет его позицией.)

Синтаксис

РАНГ(число;ссылка;порядок)

Число - это число, для которого определяется ранг.

Ссылка - это массив или ссылка на список чисел. Нечисловые значения в ссылке игнорируются.

Порядок - это число, определяющее способ упорядочения.

  • Если порядок равен 0 (нулю) или опущен, то Microsoft Excel определяет ранг числа так, как если бы ссылка была списком, отсортированным в порядке убывания.

  • Если порядок - это любое ненулевое число, то Microsoft Excel определяет ранг числа так, как если бы ссылка была списком, отсортированным в порядке возрастания.

Замечания

РАНГ присваивает повторяющимся числам одинаковый ранг. Однако, наличие повторяющихся чисел влияет на ранг последующих чисел. Например, для списка целых, если число 10 появляется дважды и имеет ранг 5, то 11 будет иметь ранг 7 (и никакое число не будет иметь ранг 6).

Примеры

Если ячейки A1:A5 содержат числа 7, 3,5, 3,5, 1 и 2 соответственно, то:

РАНГ(A2;A1:A5;1) равняется 3
РАНГ(A1;A1:A5;1) равняется 5


РОСТ

См. также

Расчитывает прогнозируемый экспоненциальный рост на основании имеющихся данных. Функция РОСТ возвращает значения y для последовательности новых значений x, задаваемых с помощью существующих x- и y-значений. Функция рабочего листа РОСТ может применяться также для для аппроксимации существующих x- и y-значений экспоненциальной кривой.

Синтаксис

РОСТ(известные_значения_y;известные_значения_x;новые_значения_x;конст)

Известные_значения_y - это множество значений y, которые уже известны для соотношения y = b*m^x.

  • Если массив известные_значения_y имеет один столбец, то каждый столбец массива известные_значения_x интерпретируется как отдельная переменная.

  • Если массив известные_значения_y имеет одну строку, то каждая строка массива известные_значения_x интерпретируется как отдельная переменная.

  • Если какие-либо числа в массиве известные_значения_y равны 0 или отрицательны, то функция РОСТ возвращает значение ошибки #ЧИСЛО!.

Известные_значения_x - это необязательное множество значений x, которые уже известны для соотношения y = b*m^x.

  • Массив известные_значения_x может содержать одно или несколько множеств переменных. Если используется только одна переменная, то известные_значения_y и известные_значения_x могут иметь любую форму, при условии, что они имеют одинаковую размерность. Если используется более одной переменной, то известные_значения_y должны быть вектором (то есть интервалом высотой в одну строку или шириной в один столбец).

  • Если известные_значения_x опущены, то предполагается, что это массив {1;2;3;...} такого же размера как и известные_значения_y.

Новые_значения_x - это новые значения x, для которых РОСТ возвращает соответствующие значения y.

  • Новые_значения_x должны содержать столбец (или строку) для каждой независимой переменной, как и известные_значения_x. Таким образом, если известные_значения_y - это один столбец, то известные_значения_x и новые_значения_x должны иметь такое же количество столбцов. Если известные_значения_y - это одна строка, то известные_значения_x и новые_значения_x должны иметь такое же количество строк.

  • Если аргумент новые_значения_x опущен, то предполагается, что он совпадает с аргументом известные_значения_x.

  • Если оба аргумента известные_значения_x и новые_значения_x опущены, то предполагается, что это массив {1;2;3;...} такого же размера как и известные_значения_y.

Конст - это логическое значение, которое указывает, требуется ли, чтобы константа b была равна 1.

  • Если конст имеет значение ИСТИНА или опущено, то b вычисляется обычным образом.

  • Если конст имеет значение ЛОЖЬ, то b полагается равном 1, а значения m подбираются так, чтобы y = m^x.

Замечания

  • Формулы, которые возвращают массивы, должны быть введены как формулы массивов после выделения подходящего числа ячеек. Для получения дополнительных сведений о вводе формул массивов нажмите кнопку [image] .

  • При вводе константы массива для аргумента, такого как известные_значения_x, следует использовать точку с запятой для разделения значений в одной строке и двоеточие для разделения строк.

Примеры

В этом примере используются те же данные, что и в примере для функции ЛГРФПРИБЛ. Продажи от 11-ого до 16-ого месяца составляют 33 100, 47 300, 69 000, 102 000, 150 000 и 220 000 штук соответственно. Допустим, что эти значения введены в шесть ячеек, названных ПроданоШтук.

Следующая формула, если ее ввести как формулу массива, предсказывает количество продаж для 17-ого и 18-ого месяцев на основе данных о продажах за предыдущие шесть месяцев:

РОСТ(ПроданоШтук;{11:12:13:14:15:16};{17:18}) равняется {320 197:468 536}

Если экспоненциальная тенденция сохранится, то продажи для 17-ого и 18-ого месяцев составят 320 197 и 468 536 штук соответственно.

Можно использовать другие последовательные числа в качестве значений x, а предсказанные значения будут такими же. Например, можно использовать значения по умолчанию для аргумента известные_значения_x -- {1:2:3:4:5:6}:

РОСТ(ПроданоШтук;;{7:8};) равняется {320 197:468 536}


СКОС

См. также

Возвращает асимметрию распределения. Асимметрия характеризует степень несимметричности распределения относительно его среднего. Положительная асимметрия указывает на отклонение распределения в сторону положительных значений. Отрицательная асимметрия указывает на отклонение распределения в сторону отрицательных значений.

Синтаксис

СКОС(число1;число2; ...)

Число1, число2, ... - это от 1 до 30 аргументов, для которых вычисляется асимметричность. Можно использовать массив или ссылку на массив вместо аргументов, разделяемых точкой с запятой.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если имеется менее трех точек данных, или стандартное отклонение равно нулю, то функция СКОС возвращает значение ошибки #ДЕЛ/0!.

  • Уравнение для асимметрии определяется следующим образом:

Пример

СКОС(3;4;5;2;3;4;5;6;4;7) равняется 0,359543


СРГАРМ

См. также

Возвращает среднее гармоническое множества данных. Среднее гармоническое - это величина, обратная к среднему арифметическому обратных величин.

Синтаксис

СРГАРМ(число1;число2; ...)

Число1, число2, ... - это от 1 до 30 аргументов, для которых вычисляется среднее геометрическое. Можно использовать массив или ссылку на массив вместо аргументов, разделяемых точкой с запятой.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если любая из точек данных ≤ 0, то функция СРГАРМ возвращает значение ошибки #ЧИСЛО!.

  • Среднее гармоническое всегда меньше среднего геометрического, которое всегда меньше среднего арифметического.

  • Уравнение для среднего гармонического имеет следующий вид:

Пример

СРГАРМ(4;5;8;7;11;4;3) равняется 5,028376


СРГЕОМ

См. также

Возвращает среднее геометрическое значений массива или интервала положительных чисел. Например, функцию СРГЕОМ можно использовать для вычисления средних темпов роста, если задан составной доход с переменными ставками.

Синтаксис

СРГЕОМ(число1;число2; ...)

Число1, число2, ... - это от 1 до 30 аргументов, для которых вычисляется среднее геометрическое. Можно использовать массив или ссылку на массив вместо аргументов, разделяемых точкой с запятой.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если какой-либо из аргументов ≤ 0, то функция СРГЕОМ возвращает значение ошибки #ЧИСЛО!.

  • Уравнение для среднего геометрического имеет следующий вид:

Пример

СРГЕОМ(4;5;8;7;11;4;3) равняется 5,476987


СРЗНАЧ

См. также

Возвращает среднее (арифметическое) своих аргументов.

Синтаксис

СРЗНАЧ(число1; число2; ...)

Число1, число2, ... - это от 1 до 30 аргументов, для которых вычисляется среднее.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения, учитываются.

Совет. Вычисляя средние значения ячеек, следует учитывать различие между пустыми ячейками и ячейками, содержащими нулевые значения, особенно если не установлен флажок Нулевые значения на вкладке Вид (команда Параметры, меню Сервис). Пустые ячейки не учитываются, но нулевые ячейки учитываются.

Примеры

Если ячейки A1:A5 имеют имя Баллы и содержат числа 10, 7, 9, 27 и 2, то:

СРЗНАЧ(A1:A5) равняется 11

СРЗНАЧ(Баллы) равняется 11

СРЗНАЧ(A1:A5; 5) равняется 10

СРЗНАЧ(A1:A5) равняется СУММ(A1:A5)/СЧЁТ(A1:A5) и равняется 11

Если ячейки C1:C3 имеют имя ДругиеБаллы и содержат числа 4, 18 и 7, то:

СРЗНАЧ(Баллы; ДругиеБаллы) равняется 10,5


СРЗНАЧ

См. также

Вычисляет среднее арифметическое значений, заданных в списке аргументов. Помимо чисел в расчете могут участвовать текст и логические значения, такие как ИСТИНА и ЛОЖЬ.

Синтаксис

СРЗНАЧА(значение1,значение2,...)

Значение1, значение2,... - это от 1 до 30 ячеек, интервалов ячеек или значений, для которых вычисляется среднее.

Замечания

  • Аргументы должны быть числами, именами, массивами или ссылками.

  • Массивы и ссылки, содержащие текст, интерпретируются как 0 (ноль). Пустой текст ("") интерпретируется как 0 (ноль). Если при расчете не требуется учитывать текстовые значения следует использовать функцию СРЗНАЧ.

  • Аргументы, содержащие значение ИСТИНА, интерпретируются как 1, Аргументы, содержащие значение ЛОЖЬ, интерпретируются как 0 (ноль).

Совет. Вычисляя средние значения ячеек, следует учитывать различие между пустыми ячейками и ячейками, содержащими нулевые значения, особенно если не установлен флажок Нулевые значения на вкладке Вид (команда Параметры, меню Сервис). Пустые ячейки не учитываются, но нулевые ячейки учитываются.

Примеры

Если ячейки A1:A5 имеют имя Баллы и содержат значения 10, 7, 9, 2 и " Неопределенные данные" , то:

СРЗНАЧА(A1:A5) равняется 5.6

СРЗНАЧА(Баллы) равняется 5,6

СРЗНАЧА(A1:A5) равняется СУММ(A1:A5)/СЧЁТЗ(A1:A5) равняется 5,6

Если A1:A4 содержат значения 10, 7, 9 и 2, а A5 - пуста, то:

СРЗНАЧА(A1:A5) равняется 7


СРОТКЛ

См. также

Возвращает среднее абсолютных значений отклонений точек данных от среднего. СРОТКЛ является мерой разброса множества данных.

Синтаксис

СРОТКЛ(число1; число2; ...)

Число1, число2, ... - это от 1 до 30 аргументов, для которых определяется среднее абсолютных отклонений. Можно использовать массив или ссылку на массив вместо аргументов, разделяемых точкой с запятой.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Уравнение для среднего отклонения следующее:

    На результат СРОТКЛ влияют единицы измерения входных данных.

Пример

СРОТКЛ(4;5;6;7;5;4;3) равняется 1,020408


СТАНДОТКЛОН

См. также

Оценивает стандартное отклонение по выборке. Стандартное отклонение - это мера того, насколько широко разбросаны точки данных относительно их среднего.

Синтаксис

СТАНДОТКЛОН(число1; число2; ...)

Число1, число2, ... - это от 1 до 30 числовых аргументов, соответствующих выборке из генеральной совокупности. Можно использовать массив или ссылку на массив вместо аргументов, разделяемых точкой с запятой.

  • Логические значения, такие как ИСТИНА или ЛОЖЬ, а также текст игнорируются. Если текст и логические значения игнорироваться не должны, следует использовать функцию рабочего листа СТАНДОТКЛОНА.

Замечания

  • СТАНДОТКЛОН предполагает, что аргументы являются только выборкой из генеральной совокупности. Если данные представляют всю генеральную совокупность, то стандартное отклонение следует вычислять с помощью функции СТАНДОТКЛОНП.

  • Стандартное отклонение вычисляется с использованием "несмещенного" или "n-1" метода.

  • СТАНДОТКЛОН использует следующую формулу:

Пример

Предположим, что из инструментов, отштампованных одной и той же машиной, выбраны наугад 10 штук и испытаны на излом. Значения выборки (1345, 1301, 1368, 1322, 1310, 1370, 1318, 1350, 1303, 1299) сохранены в ячейках A2:E3 соответственно. Тогда функция СТАНДОТКЛОН оценивает стандартное отклонение сопротивлению на излом для всех инструментов.

СТАНДОТКЛОН(A2:E3) равняется 27,46


СТАНДОТКЛОН

См. также

Оценивает стандартное отклонение по выборке. Стандартное отклонение - это мера того, насколько широко разбросаны точки данных относительно их среднего. В расчете также учитываются текстовые и логические значения, такие как ИСТИНА или ЛОЖЬ.

Синтаксис

СТАНДОТКЛОН(значение1,значение2,...)

Значение1, значение2,... - это от 1 до 30 значений, соответствующих выборке из генеральной совокупности. Можно использовать массив или ссылку на массив вместо аргументов, разделяемых точкой с запятой.

Замечания

  • СТАНДОТКЛОНА предполагает, что аргументы являются только выборкой из генеральной совокупности. Если данные представляют всю генеральную совокупность, то стандартное отклонение следует вычислять с помощью функции СТАНДОТКЛОНПА.

  • Аргументы, содержащие значение ИСТИНА интерпретируются как 1, Аргументы, содержащие значение ЛОЖЬ интерпретируются как 0 (ноль). Если текст и логические значения должны игнорироваться, следует использовать функцию рабочего листа СТАНДОТКЛОН.

  • Стандартное отклонение вычисляется с использованием "не Байесовского" или "n-1" метода.

  • СТАНДОТКЛОНА использует следующую формулу:

Пример

Предположим, что из инструментов, отштампованных одной и той же машиной, выбраны наугад 10 штук и испытаны на излом. Значения выборки (1345, 1301, 1368, 1322, 1310, 1370, 1318, 1350, 1303, 1299) сохранены в ячейках A2:E3 соответственно. Тогда функция СТАНДОТКЛОН оценивает стандартное отклонение сопротивлению на излом для всех инструментов.

СТАНДОТКЛОН(A2:E3) равняется 27,46


СТАНДОТКЛОНП

См. также

Вычисляет стандартное отклонение по генеральной совокупности. Стандартное отклонение - это мера того, насколько широко разбросаны точки данных относительно их среднего.

Синтаксис

СТАНДОТКЛОНП(число1; число2; ...)

Число1, число2, ... - это от 1 до 30 числовых аргументов, соответствующих генеральной совокупности. Можно использовать массив или ссылку на массив вместо аргументов, разделяемых точкой с запятой.

  • Логические значения, такие как ИСТИНА или ЛОЖЬ, а также текст игнорируются. Если текст и логические значения игнорироваться не должны, следует использовать функцию рабочего листа СТАНДОТКЛОНА.

Замечания

  • СТАНДОТКЛОНП предполагает, что аргументы образуют всю генеральную совокупность. Если данные являются только выборкой из генеральной совокупности, то стандартное отклонение следует вычислять с использованием функции СТАНДОТКЛОН.

  • Для больших выборок СТАНДОТКЛОН и СТАНДОТКЛОНП возвращают примерно равные значения.

  • Стандартное отклонение вычисляется с использованием "смещенного" или "n" метода.

  • СТАНДОТКЛОНП использует следующую формулу:

Пример

Будем использовать данные из примера для функции СТАНДОТКЛОН и положим, что всего было произведено 10 инструментов. Функция СТАНДОТКЛОНП измеряет стандартное отклонение сопротивления на излом для всех инструментов.

СТАНДОТКЛОНП(A2:E3) равняется 26,05


СТАНДОТКЛОНП

См. также

Вычисляет стандартное отклонение по генеральной совокупности, заданной аргументами, которые могут включать текст и логические значения. Стандартное отклонение - это мера того, насколько широко разбросаны точки данных относительно их среднего.

Синтаксис

СТАНДОТКЛОНПА(значение1,значение2,...)

Значение1,значение2,... это от 1 до 30 значений, соответствующих генеральной совокупности. Можно использовать массив или ссылку на массив вместо аргументов, разделяемых точкой с запятой.

Замечания

  • СТАНДОТКЛОНПА предполагает, что аргументы образуют всю генеральную совокупность. Если данные являются только выборкой из генеральной совокупности, то стандартное отклонение следует вычислять с использованием функции СТАНДОТКЛОНА.

  • Аргументы, содержащие значение ИСТИНА интерпретируются как 1, аргументы, содержащие значение ЛОЖЬ интерпретируются как 0 (ноль). Если текст и логические значения должны игнорироваться, следует использовать функцию рабочего листа СТАНДОТКЛОНП.

  • Для больших выборок СТАНДОТКЛОНА и СТАНДОТКЛОНПА возвращают примерно равные значения.

  • Стандартное отклонение вычисляется с использование "Байесовского" или "n" метода.

  • СТАНДОТКЛОНПА использует следующую формулу:

Пример

Будем использовать данные из примера для функции СТАНДОТКЛОНА и положим, что всего было произведено 10 инструментов. Функция СТАНДОТКЛОНПА измеряет стандартное отклонение сопротивления на излом для всех инструментов.

СТАНДОТКЛОНП(A2:E3) равняется 26,05


СТОШYX

См. также

Возвращает стандартную ошибку предсказанных значений y для каждого значения x в регрессии. Стандартная ошибка - это мера ошибки предсказанного значения y для отдельного значения x.

Синтаксис

СТОШYX(известные_значения_y;известные_значения_x)

Известные_значения_y - это массив или интервал зависимых точек данных.

Известные_значения_x - это массив или интервал независимых точек данных.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если известные_значения_y и известные_значения_x пусты или содержат различное число точек данных, то функция СТОШYX возвращает значение ошибки #Н/Д.

  • Уравнение для стандартной ошибки предсказанного y имеет следующий вид:

Пример

СТОШYX({2;3;9;1;8;7;5};{6;5;11;7;5;4;4}) равняется 3,305719


СТЬЮДРАСП

См. также

Возвращает процентные точки (вероятность) для t-распределения Стьюдента, где численное значение (x) — это вычисленное значение , для которого должны быть вычислены вероятности. T-распределение используется для проверки гипотез при малом объеме выборки. Данную функцию можно использовать вместо таблицы критических значений t-распределения.

Синтаксис

СТЬЮДРАСП(x;степени_свободы;хвосты)

X — это численное значение, для которого требуется вычислить распределение.

Степени_свободы — это целое, указывающее число степеней свободы.

Хвосты — это число возвращаемых хвостов распределения. Если хвосты = 1, то функция СТЬЮДРАСП возвращает одностороннее распределение. Если хвосты = 2, то функция СТЬЮДРАСП возвращает двухстороннее распределение.

Замечания

  • Если какой-либо из аргументов не является числом, то функция СТЬЮДРАСП возвращает значение ошибки #ЗНАЧ!.

  • Если степени_свободы < 1, то функция СТЬЮДРАСП возвращает значение ошибки #ЧИСЛО!.

  • Аргументы степени_свободы и хвосты усекаются до целых.

  • Если хвосты — любое значение, отличное от 1 и 2, то функция СТЬЮДРАСП возвращает значение ошибки #ЧИСЛО!.

  • СТЬЮДРАСП вычисляется следующим образом: СТЬЮДРАСП=p( x<X ), где X — это случайная величина, соответствующая t-распределению.

Пример

СТЬЮДРАСП(1,96;60;2) равняется 0,054645 или 5,46 процентов


СТЬЮДРАСПОБР

См. также

Возвращает t-значение распределения Стьюдента как функцию вероятности и числа степеней свободы.

Синтаксис

СТЬЮДРАСПОБР(вероятность;степени_свободы)

Вероятность — это вероятность, соответствующая двустороннему распределению Стьюдента.

Степени_свободы — это число степеней свободы, характеризующее распределение.

Замечания

  • Если любой из аргументов не является числом, то функция СТЬЮДРАСПОБР возвращает значение ошибки #ЗНАЧ!.

  • Если вероятность < 0 или вероятность > 1, то функция СТЬЮДРАСПОБР возвращает значение ошибки #ЧИСЛО!.

  • Если степени_свободы не целое, то оно усекается.

  • Если степени_свободы < 1, то функция СТЬЮДРАСПОБР возвращает значение ошибки #ЧИСЛО!.

  • СТЬЮДРАСПОБР вычисляется следующим образом: СТЬЮДРАСПОБР=p(t<X ), где X - это случайная величина, соответствующая t_распределению.

  • Одностороннее t-значение может быть получено при замене аргумента вероятность на 2*вероятность. Для вероятности 0,05 и числа степеней свободы равного 10 двухсторонее значение вычисляется СТЬЮДРАСПОБР(0,05;10) и равно 2,28139. Одностороннее значение для той же вероятности и числа степеней свободы может быть вычислено формулой СТЬЮДРАСПОБР(2*0,05;10) и равняется 1,812462.

    Примечание. В некоторых таблицах вероятность описана как (1-p).

СТЬЮДРАСПОБР использует метод итераций для вычисления функции. Если задано значение вероятности, то функция СТЬЮДРАСПОБР производит итерации, пока не получит результат с точностью ± 3x10^-7. Если СТЬЮДРАСПОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

СТЬЮДРАСПОБР(0,054645;60) равняется 1,96


СЧЁТ

См. также

Подсчитывает количество чисел в списке аргументов. Функция СЧЁТ используется для получения количества числовых ячеек в интервалах или массивах ячеек.

Синтаксис

СЧЁТ(значение1; значение2; ...)

Значение1, значение2, ... - это от 1 до 30 аргументов, которые могут содержать или ссылаться на данные различных типов, но в подсчете участвуют только числа.

  • Учитываются аргументы, которые являются числами, пустыми значениями, логическими значениями, датами, или текстами, изображающими числа; аргументы, которые являются значениями ошибки или текстами, которые нельзя интерпретировать как числа, игнорируются.

  • Если аргумент является массивом или ссылкой, то подсчитываются только числа в этом массиве или ссылке. Пустые ячейки, логические значения, тексты и значения ошибок в массиве или ссылке игнорируются.

Примеры

В примере ниже:

СЧЁТ(A1:A7) возвращает 3

СЧЁТ(A4:A7) возвращает 2

СЧЁТ(A1:A7, 2) возвращает 4


СЧЁТЗ

См. также

Подсчитывает количество непустых значений в списке аргументов. Функция СЧЁТЗ используется для подсчета количества ячеек с данными в интервале или массиве.

Синтаксис

СЧЁТЗ(значение1; значение2; ...)

Значение1, значение2, ... - это от 1 до 30 аргументов, количество которых требуется сосчитать. В данном случае значением считается значение любого типа, включая пустую строку (""), но не включая пустые ячейки. Если аргументом является массив или ссылка, то пустые ячейки в массиве или ссылке игнорируются.

Примеры

В примере ниже:

COUNTA(A1:A7) возвращает 6

COUNTA(A4:A7) возвращает 4

COUNTA(A1:A7, 2) возвращает 7

COUNTA(A1:A7, "Два") возвращает 7


ТЕНДЕНЦИЯ

См. также

Возвращает значения в соответствии с линейным трендом. Аппроксимирует прямой линией (по методу наименьших квадратов) массивы известные_значения_y и известные_значения_x. Возвращает значения y, в соответствии с этой прямой для заданного массива новые_значения_x.

Синтаксис

ТЕНДЕНЦИЯ(известные_значения_y;известные_значения_x;новые_значения_x;конст)

Известные_значения_y - это множество значений y, которые уже известны для соотношения y = mx + b.

  • Если массив известные_значения_y имеет один столбец, то каждый столбец массива известные_значения_x интерпретируется как отдельная переменная.

  • Если массив известные_значения_y имеет одну строку, то каждая строка массива известные_значения_x интерпретируется как отдельная переменная.

Известные_значения_x - это необязательное множество значений x, которые уже известны для соотношения y = mx + b.

  • Массив известные_значения_x может содержать одно или несколько множеств переменных. Если используется только одна переменная, то известные_значения_y и известные_значения_x могут иметь любую форму, при условии, что они имеют одинаковую размерность. Если используется более одной переменной, то известные_значения_y должны быть вектором (то есть интервалом высотой в одну строку или шириной в один столбец).

  • Если известные_значения_x опущены, то предполагается, что это массив {1;2;3;...} такого же размера как и известные_значения_y.

Новые_значения_x - это новые значения x, для которых ТЕНДЕНЦИЯ возвращает соответствующие значения y.

  • Новые_значения_x должны содержать столбец (или строку) для каждой независимой переменной, как и известные_значения_x. Таким образом, если известные_значения_y - это один столбец, то известные_значения_x и новые_значения_x должны иметь такое же количество столбцов. Если известные_значения_y - это одна строка, то известные_значения_x и новые_значения_x должны иметь такое же количество строк.

  • Если новые_значения_x опущены, то предполагается, что они совпадают с известные_значения_x.

  • Если опущены оба массива известные_значения_x и новые_значения_x, то предполагается, что это массив {1;2;3;...} такого же размера, что и известные_значения_y.

Конст - это логическое значение, которое указывает, требуется ли, чтобы константа b была равна 1.

  • Если конст имеет значение ИСТИНА или опущено, то b вычисляется обычным образом.

  • Если конст имеет значение ЛОЖЬ, то b полагается равным 0, и значения m подбираются таким образом, чтобы выполнялось соотношение y = mx.

Замечания

  • Для получения информации о том, как Microsoft Excel аппроксимирует данные прямой, см. ЛИНЕЙН.

  • Можно использовать функцию ТЕНДЕНЦИЯ для аппроксимации полиномиальной кривой, проводя регрессионный анализ для той же переменной, возведенной в различные степени. Например, пусть столбец A содержит значения y, а столбец B содержит значения x. Можно ввести x^2 в столбец C, x^3 в столбец D, и так далее, а затем провести регрессионный анализ столбцов от B до D со столбцом A.

  • Формулы, которые возвращают массивы, должны быть введены как формулы массива.

  • При вводе константы массива для аргумента, такого как известные_значения_x, следует использовать точку с запятой для разделения значений в одной строке и двоеточие для разделения строк.

Пример

Предположим, что фирма желает приобрести земельный надел в июле, начале следующего финансового года. Фирма собирает информацию о ценах за последние 12 месяцев на типичный земельный надел. Известные_значения_y содержатся в ячейках B2:B13; эти значения равны соответственно 133 890 руб., 135 000 руб., 135 790 руб., 137 300 руб., 138 130 руб., 139 100 руб., 139 900 руб., 141 120 руб., 141890 руб., 143 230 руб., 144 000 руб., 145 290 руб.

Приведенная ниже формула, введенная как формула вертикального массива в интервал C2:C6, возвращает ожидаемые цены на март, апрель, май, июнь и июль:

ТЕНДЕНЦИЯ(B2:B13;;{13:14:15:16:17}) равняется {146172:147190:148208:149226:150244}

Фирма может ожидать цену около 150 244 руб., если она будет ждать до июля. В предшествующей формуле используется массив по умолчанию {1:2:3:4:5:6:7:8:9:10:11:12} для аргумента известные_значения_x, соответствующий 12 месяцам, для которых имеются данные по продажам. Массив {13:14:15:16:17} соответствует следующим пяти месяцам.


ТТЕСТ

См. также

Возвращает вероятность, соответствующую критерию Стьюдента. Функция ТТЕСТ используется, чтобы определить, насколько вероятно, что две выборки взяты из генеральных совокупностей, которые имеют одно и то же среднее.

Синтаксис

ТТЕСТ(массив1;массив2;хвосты;тип)

Массив1 - это первое множество данных.

Массив2 - это второе множество данных.

Хвосты - это число хвостов распределения. Если хвосты = 1, то функция ТТЕСТ использует одностороннее распределение. Если хвосты = 2, то функция ТТЕСТ использует двустороннее распределение.

Тип - это вид исполняемого t-теста.

Тип | Выполняемый тест
1 | Парный
2 | Двухвыборочный с равными дисперсиями (гомоскедастический)
3 | Двухвыборочный с неравными дисперсиями (гетероскедастический)

Замечания

  • Если массив1 и массив2 имеют различное число точек данных, а тип = 1 (парный), то функция ТТЕСТ возвращает значение ошибки #Н/Д.

  • Аргументы хвосты и тип усекаются до целых.

  • Если хвосты или тип не является числом, то функция ТТЕСТ возвращает значение ошибки #ЗНАЧ!.

  • Если хвосты имеет значение, отличное от 1 и 2, то функция ТТЕСТ возвращает значение ошибки #ЧИСЛО!.

Пример

ТТЕСТ({3;4;5;8;9;1;2;4;5};{6;19;3;2;14;4;5;17;1};2;1)
равняется 0,196016


УРЕЗСРЕДНЕЕ

См. также

Возвращает среднее внутренности множества данных. УРЕЗСРЕДНЕЕ вычисляет среднее, отбрасывания заданный процент данных с экстремальными значениями. Можно использовать эту функцию, чтобы исключить из анализа выбросы.

Синтаксис

УРЕЗСРЕДНЕЕ(массив;доля)

Массив - это массив или интервал усредняемых значений.

Доля - это доля точек данных, исключаемых из вычислений. Например, если доля = 0,2, то 4 точки исключаются из множества данных, содержащих 20 точек (20 x 0,2), 2 точки с наибольшими значениями и 2 точки с наименьшими значениями в множестве данных.

Замечания

  • Если доля < 0 или доля > 1, то функция УРЕЗСРЕДНЕЕ возвращает значение ошибки #ЧИСЛО!.

  • УРЕЗСРЕДНЕЕ округляет количество выбрасываемых точек данных с недостатком до ближайшего целого, кратного 2. Если доля = 0,1, то 10 процентов от 30 точек данных составляют 3 точки, но из соображений симметрии функция УРЕЗСРЕДНЕЕ исключит по одному значению из начала и конца множества.

Пример

УРЕЗСРЕДНЕЕ({4;5;6;7;2;3;4;5;1;2;3};0,2) равняется 3,777778


ФИШЕР

См. также

Возвращает преобразование Фишера для аргумента x. Это преобразование строит функцию, которая имеет приблизительно нормальное, а не асимметрическое распределение. Эта функция используется для тестирования гипотез с помощью коэффициента корреляции.

Синтаксис

ФИШЕР(x)

X - это числовое значение, которое желательно преобразовать.

Замечания

  • Если x не является числом, то функция ФИШЕР возвращает значение ошибки #ЗНАЧ!.

  • Если x ≤ -1 или x ≥ 1, то функция ФИШЕР возвращает значение ошибки #ЧИСЛО!.

Уравнение для преобразования Фишера имеет следующий вид:

Пример

ФИШЕР(0,75) равняется 0,972955


ФИШЕРОБР

См. также

Возвращает обратное преобразование Фишера. Это преобразование используется при анализе корреляции между массивами или интервалами данных. Если y = ФИШЕР(x), то ФИШЕРОБР(y) = x.

Синтаксис

ФИШЕРОБР(y)

Y - это значение, для которого производится обратное преобразование.

Замечания

  • Если y не является числом, то функция ФИШЕРОБР возвращает значение ошибки #ЗНАЧ!.

Уравнение для обратного преобразования Фишера имеет следующий вид:

Пример

ФИШЕРОБР(0,972955) равняется 0,75


ФТЕСТ

См. также

Возвращает результат F-теста. F-тест возвращает одностороннюю вероятность того, что дисперсии аргументов массив1 и массив2 различаются несущественно. Эта функция используется для того, чтобы определить, имеют ли две выборки различные дисперсии. Например, если даны результаты тестирования для частных и общественных школ, то можно определить, имеют ли эти школы различные уровни разнородности учащихся.

Синтаксис

ФТЕСТ(массив1;массив2)

Массив1 - это первый массив или интервал данных.

Массив2 - это второй массив или интервал данных.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения, учитываются.

  • Если количество точек данных в аргументе массив1 или массив2 меньше 2, или если дисперсия аргумента массив1 или массив2 равна нулю, то функция ФТЕСТ возвращает значение ошибки #ДЕЛ/0!.

Пример

ФТЕСТ({6;7;9;15;21};{20;28;31;38;40}) равняется 0,648318


ХИ2ОБР

См. также

Возвращает значение обратное к односторонней вероятности распределения γ2 (хи-квадрат). Если вероятность = ХИ2РАСП(x;...), то ХИ2ОБР(вероятность;...) = x. функция используется для сравнения наблюдаемых результатов с ожидаемыми, для того, чтобы решить была ли исходная гипотеза обоснованной.

Синтаксис

ХИ2ОБР(вероятность;степени_свободы)

Вероятность - это вероятность, связанная с распределением c2 (хи-квадрат).

Степени_свободы - это число степеней свободы.

Замечания

  • Если какой-либо из аргументов не является числом, то функция ХИ2ОБР возвращает значение ошибки #ЗНАЧ!.

  • Если вероятность < 0 или вероятность > 1, то функция то функция ХИ2ОБР возвращает значение ошибки #ЧИСЛО!.

  • Если степени_свободы не целое, то оно усекается.

  • Если степени_свободы < 1 или степени_свободы ≥ 10^10, ХИ2ОБР возвращает значение ошибки #ЧИСЛО!.

ХИ2ОБР использует метод итераций для вычисления значения. Если задано значение вероятности, то функция ХИ2ОБР производит итерации, пока не получит результат с точностью ± 3x10^-7. Если ХИ2ОБР не сходится после 100 итераций, то функция возвращает значение ошибки #Н/Д.

Пример

ХИ2ОБР(0,05;10) равняется 18,30703


ХИ2РАСП

См. также

Возвращает одностороннюю вероятность распределения хи-квадрат. Распределение γ2 связано с критерием γ2. Критерий γ2 используется для сравнения предполагаемых и наблюдаемых значений. Например, в генетическом эксперименте выдвигается гипотеза, что следующее поколение растений будет обладать определенной окраской. Сравнивая наблюдаемые результаты с предполагаемыми, можно определить, была ли исходная гипотеза обоснованной.

Синтаксис

ХИ2РАСП(x;степени_свободы)

X - это значение, для которого требуется вычислить распределение.

Степени_свободы - это число степеней свободы.

Замечания

  • Если какой-либо из аргументов не является числом, то функция ХИ2РАСП возвращает значение ошибки #ЗНАЧ!.

  • Если x отрицательно, то функция ХИ2РАСП возвращает значение ошибки #ЧИСЛО!.

  • Если степени_свободы не целое, то оно усекается.

  • Если степени_свободы < 1 или степени_свободы ≥ 10^10, ХИ2РАСП возвращает значение ошибки #ЧИСЛО!.

  • ХИ2РАСП вычисляется как ХИ2РАСП = P(X>x), где X - это γ2 случайная величина.

Пример

ХИ2РАСП(18,307;10) равняется 0,050001


ХИ2ТЕСТ

См. также

Возвращает тест на независимость. ХИ2ТЕСТ возвращает значение для распределения хи-квадрат (γ2). Критерий γ2 используется для определения того, подтверждается ли гипотеза экспериментом.

Синтаксис

ХИ2ТЕСТ(фактический_интервал;ожидаемый_интервал)

Фактический_интервал - это интервал данных, которые содержат наблюдения, подлежащие сравнению с ожидаемыми значениями.

Ожидаемый_интервал - это интервал данных, который содержит отношение произведений итогов по строкам и столбцам к общему итогу.

Замечания

  • Если фактический_интервал и ожидаемый_интервал имеют различное количество точек данных, то функция ХИ2ТЕСТ возвращает значение ошибки #Н/Д.

  • Критерий γ2 сначала вычисляет γ2 статистику, а затем суммирует разности между фактическими значениями и ожидаемыми значениями. Уравнение для этой функции имеет следующий вид: ХИ2ТЕСТ=p( X>γ2 ), где:

    и где:

    Aij = фактическая частота в i-ой строке, j-ом столбце

    Eij = ожидаемая частота в i-ой строке, j-ом столбце

    r = число строк

    c = число столбцов

    ХИ2ТЕСТ возвращает вероятность для γ2 статистики и степеней свободы df, где df = (r - 1)(c - 1).

Пример

γ2 статистика для вышеприведенных данных равна 16,16957 с 2 степенями свободы.

ХИ2ТЕСТ(B3:C5;B9:C11) равняется 0,000308


ЧАСТОТА

См. также

Вычисляет частоту появления значений в интервале значений и возвращает массив цифр. Функция ЧАСТОТА может быть использована, например, для подсчета количества результатов тестирования, попадающих в интервалы результатов. Поскольку данная функция возвращает массив, она должна задаваться в качестве формулы массива.

Синтаксис

ЧАСТОТА(массив_данных;массив_карманов)

Массив_данных — это массив или ссылка на множество данных, для которых вычисляются частоты. Если массив_данных не содержит значений, то функция ЧАСТОТА возвращает массив нулей.

Массив_карманов — это массив или ссылка на множество интервалов, в которые группируются значения аргумента массив_данных. Если массив_карманов не содержит значений, то функция ЧАСТОТА возвращает количество элементов в аргументе массив_данных.

Замечания

  • ЧАСТОТА вводится как формула массива после выделения интервала смежных ячеек, в которые нужно вернуть полученный массив распределения.

  • Количество элементов в возвращаемом массиве на единицу больше числа элементов в массив_карманов. Дополнительный элемент в возвращаемом массиве содержит количество значений, больших чем максимальное значение в интервалах. Например, при подсчете трех диапазонов значений (интервалов), введенных в три ячейки, убедитесь в том, что функция ЧАСТОТА возвращает значения в четырех ячейках. Дополнительная ячейка возвращает число значений в массив_данных, больших чем значение границы третьего интервала.

  • ЧАСТОТА игнорирует пустые ячейки и тексты.

  • Формулы, которые возвращают массивы, должны быть введены как формулы массивов. Для получения дополнительных сведений о вводе формул массивов нажмите кнопку [image] .

Пример

Предположим, что на рабочем листе перечислены результаты тестирования в баллах. Баллы 79, 85, 78, 85, 83, 81, 95, 88 и 97 введены в ячейки A1:A9 соответственно. Тогда аргумент массив_данных содержит столбец этих баллов. Аргумент массив_карманов будет другим столбцом, задающим интервалы, в которые должны быть сгруппированы данные В данном примере массив_карманов — это интервал ячеек C4:C6, который будет содержать значения 70, 79, 89. Если ввести функцию ЧАСТОТА как формулу массива, то можно подсчитать количество результатов тестирования, попадающих в интервалы 0-70, 71-79, 80-89 и 90-100. В этом примере предполагается, что все баллы — целые числа. Следующая формула вводится как формула массива после выделения четырех вертикально смежных ячеек для результата. Четвертое число (2) представляет собой счетчик значений (95 и 97), которые больше чем граница наибольшего интервала (89).

ЧАСТОТА(A1:A9;C4:C6) равняется {0:2:5:2}


ЭКСПРАСП

См. также

Возвращает экспоненциальное распределение. Функция ЭКСПРАСП используется для моделирования временных задержек между событиями, например, сколько времени займет денежный перевод в автоматизированном банке. Например, можно использовать функцию ЭКСПРАСП, чтобы определить вероятность того, что этот процесс займет не более 1 минуты.

Синтаксис

ЭКСПРАСП(x;лямбда;интегральная)

X - это значение функции.

Лямбда - это значение параметра.

Интегральная - это логическое значение, которое указывает, какую форму экспоненциальной функции использовать. Если интегральная имеет значение ИСТИНА, то функция ЭКСПРАСП возвращает интегральную функцию распределения; если этот параметр имеет значение ЛОЖЬ, то возвращается функция плотности распределения.

Замечания

  • Если x или лямбда не является числом, то функция ЭКСПРАСП возвращает значение ошибки #ЗНАЧ!.

  • Если x < 0, то функция ЭКСПРАСП возвращает значение ошибки #ЧИСЛО!.

  • Если лямбда ≤ 0, то функция ЭКСПРАСП возвращает значение ошибки #ЧИСЛО!.

  • Уравнение для функции плотности вероятности имеет следующий вид:

  • Уравнение для интегральной функции распределения имеет следующий вид:

Примеры

ЭКСПРАСП(0,2;10;ИСТИНА) равняется 0,864665

ЭКСПРАСП(0,2;10;ЛОЖЬ) равняется 1,353353


ЭКСЦЕСС

См. также

Возвращает эксцесс множества данных. Эксцесс характеризует относительную остроконечность или сглаженность распределения по сравнению с нормальным распределением. Положительный эксцесс обозначает относительно остроконечное распределение. Отрицательный эксцесс обозначает относительно сглаженное распределение.

Синтаксис

ЭКСЦЕСС(число1;число2; ...)

Число1, число2, ... - это от 1 до 30 аргументов, для которых вычисляется эксцесс. Можно использовать массив или ссылку на массив вместо аргументов, разделяемых точкой с запятой.

Замечания

  • Аргументы должны быть числами или именами, массивами или ссылками, содержащими числа.

  • Если аргумент, который является массивом или ссылкой, содержит тексты, логические значения или пустые ячейки, то такие значения игнорируются; однако, ячейки, которые содержат нулевые значения учитываются.

  • Если задано менее четырех точек данных или если стандартное отклонение выборки равняется нулю, то функция ЭКСЦЕСС возвращает значение ошибки #ДЕЛ/0!.

  • Эксцесс определяется следующим образом:

    где:

    σ - стандартное отклонение выборки.

Пример

ЭКСЦЕСС(3;4;5;2;3;4;5;6;4;7) равняется -0,1518


ASC

Сведения, относящиеся к конкретным языкам

See also

Changes full-width (double-byte) English letters or katakana within a character string to half-width (single-byte) characters.

См. также

ASC(text)

Text is the text or a reference to a cell that contains the text you want to change. If text does not contain any full-width English letters or katakana, text is not changed.

Примеры

ASC("EXCEL") equals "EXCEL"

ASC(" [image] [image] [image] [image] ") equals " [image] [image] [image] [image] "


JIS

Сведения, относящиеся к конкретным языкам

See also

Changes half-width (single-byte) English letters or katakana within a character string to full-width (double-byte) characters.

Syntax

JIS(text)

Text is the text or a reference to a cell that contains the text you want to change. If text does not contain any half-width English letters or katakana, text is not changed.

Examples

JIS("EXCEL") equals "EXCEL"

JIS(" [image] [image] [image] [image] ") equals " [image] [image] [image] [image] "


PHONETIC

Сведения, относящиеся к конкретным языкам

See also

Extracts the phonetic (furigana) characters from a text string.

Syntax

PHONETIC(reference)

Reference is a text string or a reference to a single cell or a range of cells that contain a furigana text string.

  • If reference is a range of cells, the furigana text string in the upper-left corner cell of the range is returned.

  • If the reference is a range of nonadjacent cells, the #N/A error value is returned.

Examples

If cells C4 contains " [image] [image] [image] " and cell B7 contains " [image] [image] [image] ", the following are true:

PHONETIC(C4) equals " [image] [image] [image] [image] [image] [image] "

PHONETIC(B7) equals " [image] [image] [image] [image] [image] "


YEN

См. также

Преобразовывает число в текст, используя формат йены (Ґ) и округляя число до указанного количества знаков.

В Microsoft Excel для Windows стиль формата йены может быть изменен с помощью свойства Язык и стандарты на панели управления Windows.

В Excel для Макинтош стиль числового формата йены может быть изменен с помощью Control Panel for Numbers.

Синтаксис

YEN(число; число_знаков)

Число — это число, которое необходимо преобразовать в текст, ссылка на ячейку, содержащую число или формула, принимающая числовые значения.

Число_знаков — это количество цифр, до которого округляется число. Если аргумент — положительное число, то число округляется до указанного количества десятичных разрядов справа от десятичной запятой. Если число_знаков отрицательно, то число округляется слева от десятичной запятой. Если аргумент опущен, он полагается равным 0 и число не округляется.

Замечания

Наибольшее различие между форматированием ячейки, содержащей число, с помощью команды Ячейка в меню Формат и форматированием числа непосредственно с помощью функции состоит в том, что функция преобразует свой результат в текст. Число, которое форматируется с помощью команды Ячейка по-прежнему остается числом. Однако, можно продолжать использовать числа, отформатированные функцией в формулах, потому что Microsoft Excel преобразует числа, введенные как текст, в числовые значения в процессе вычислений.

Примеры

(1234,567;2) равняется "Ґ1 234,57"

YEN(1234,567; -2) равняется "Ґ1 200"

YEN(-1234,567; -2) равняется "Ґ-1 200"

YEN(-0.123; 4) равняется "Ґ-0,1230"

YEN(99,888) равняется "Ґ100"


ДЛСТР

Сведения, относящиеся к конкретным языкам

См. также

Также относится к:

ДЛИНБ

Функция ДЛСТР возвращает количество символов в текстовой строке.

Функция ДЛИНБ возвращает количество байтов в текстовой строке. Эта функция используется при работе с символами, занимающими два байта.

Синтаксис

ДЛСТР(текст)

ДЛИНБ(текст)

Текст — это текст, длина которого определяется. Пробелы считаются как символы.

Примеры

ДЛСТР("Москва; Россия") равняется 14

ДЛСТР("") равняется 0

ДЛИНБ(" Токио—Сибуя Токио—Сибуя Токио—Сибуя ") равняется 6


ЗАМЕНИТЬ

См. также

Также применимо к:

ЗАМЕНИТЬБ

Функция ЗАМЕНИТЬ замещает указанную часть символов текстовой строки другой строкой текста.

Функция ЗАМЕНИТЬБ замещает указанную часть байтов текстовой строки другой строкой текста. . Эта функция используется при работе с символами, занимающими два байта.

Синтаксис

ЗАМЕНИТЬ(старый_текст;нач_ном;число_символов;новый_текст)

ЗАМЕНИТЬ(старый_текст;нач_ном;число_байтов;новый_текст)

Старый_текст — это текст, в котором желательно заменить некоторые символы.

Нач_ном — это позиция символа в тексте старый_текст, начиная с которой символы заменяются текстом нов_текст.

Число_символов — это число символов в тексте старый_текст, которые заменяются текстом новый_текст.

Число_байтов — это число байтов в тексте старый_текст, которые заменяются текстом новый_текст.

Новый_текст — это текст, который заменяет символы в тексте старый_текст.

Примеры

Следующая формула заменяет текстом новый_текст пять символов начиная с шестого в тексте старый_текст:

ЗАМЕНИТЬ("абвгдежзийк";6,5;"*") равняется "абвгд*к"

Символы с шестого по десятый заменены на "*".

Следующая формула заменяет две последние цифры в тексте 1990 на 91:

ЗАМЕНИТЬ("1990";3;2;"91") равняется 1991

Если ячейка A2 содержит "123456", то:

ЗАМЕНИТЬ(A2;1;3;"@") равняется "@456"

Если функция ПРАВСИМВ возвращает текст "ABCDEF", то:

ЗАМЕНИТЬ(ПРАВСИМВ(A3;6);1;6;"*") равняется "*"

В следующем примете три первых двухбайтных символа в ячейке C4 заменяются на " Токио—Сибуя Токио—Сибуя Токио—Сибуя ":

ЗАМЕНИТЬБ(C4;1;6" Токио—Сибуя Токио—Сибуя Токио—Сибуя ")


ЗНАЧЕН

См. также

Преобразует строку текста, отображающую число, в число.

Синтаксис

ЗНАЧЕН(текст)

Текст - это текст в кавычках или ссылка на ячейку, содержащую текст, который нужно преобразовать. Текст может быть в любом формате, допускаемом Microsoft Excel для числа, даты и времени. Если текст не удовлетворяет ни одному из этих форматов, то функция ЗНАЧЕН возвращает значение ошибки #ЗНАЧ!.

Замечания

Обычно нет необходимости использовать функцию ЗНАЧЕН в формулах, поскольку Microsoft Excel автоматически преобразует текст в число при необходимости. Эта функция предназначена для совместимости с другими программами электронных таблиц.

Примеры

ЗНАЧЕН("1000 р.") равняется 1000

ЗНАЧЕН("16:48:00")-ЗНАЧЕН("12:00:00") равняется "16:48:00"-"12:00:00" равняется 0,2, то есть времени в числовом формате, эквивалентному 4 часам 48 минутам.


КОДСИМВ

См. также

Возвращает числовой код первого символа в текстовой строке. Возвращаемый код соответствует таблице символов, используемой на данном компьютере.

Операционная среда | Таблица символов
Macintosh | Таблица символов Macintosh
Windows | ANSI

Синтаксис

КОДСИМВ(текст)

Текст - это текст, в котором требуется узнать код первого символа.

Примеры

КОДСИМВ("A") равняется 65

КОДСИМВ("Alphabet") равняется 65


ЛЕВСИМВ

Сведения, относящиеся к конкретным языкам

См. также

Также относится к:

ЛЕВБ

Функция ЛЕВСИМВ возвращает указанное число первых символов текстовой строки.

ЛЕВБ возвращает указанное число первых байтов из текстовой строки. Эта функция используется при работе с символами, занимающими два байта.

Синтаксис

ЛЕВСИМВ(текст;количество_символов)

ЛЕВБ(текст;число_байтов)

Текст — это текстовая строка, которая содержит извлекаемые символы.

Количество_символов — определяет сколько символов должна извлечь функция ЛЕВСИМВ.

  • Количество_символов должно быть больше или равно нулю.

  • Если количество_символов больше длины текста, то функция ЛЕВСИМВ возвращает весь текст.

  • Если количество_символов опущено, то оно полагается равным 1.

Количество_байтов — определяет сколько байтов должна извлечь функция ЛЕВБ.

Примеры

ЛЕВСИМВ("Цена Товара"; 4) равняется "Цена"

Если ячейка A1 содержит "Швеция", то:

ЛЕВСИМВ(A1) равняется "Ш"

Некоторые бухгалтерские программы представляют отрицательные значения со знаком минус (–), расположенным справа от числа. При импорте созданного такой программой файла, содержащего отрицательные значения, Microsoft Excel может воспринять эти значения как текст. Для преобразования текстовых строк в численные величины необходимо преобразовать в число всю строку, кроме крайнего правого символа (знака минуса) и умножить это число на -1. В качестве аргумента количество_символов следует использовать функцию ДЛСТР, вычисляющую количество символов в строке текста, результат, возвращенный этой функции нужно уменьшить на 1. Например, если значение ячейки A2 — "156–", то преобразование текстового значения в число –156 выполняется следующей формулой:

ЛЕВСИМВ(A2,ДЛСТР(A2)–1)*–1 равняется – 156

ЛЕВБ(" Токио—Сибуя Токио—Сибуя Токио—Сибуя Токио—Сибуя Токио—Сибуя Токио—Сибуя ";4) равняется " Токио—Сибуя Токио—Сибуя "


НАЙТИ

См. также

Также относится к:

НАЙТИБ

Функция НАЙТИ находит вхождение одной текстовой строки (искомый_текст) в другую текстовую строку (просматриваемый_текст) и возвращает положение начала искомого текста относительно крайнего левого символа просматриваемого текста. Для поиска вхождений одной текстовой строки в другую текстовую строку можно использовать также функцию ПОИСК, но в отличие от функции ПОИСК, функция НАЙТИ учитывает регистр и не допускает символов шаблона.

Функция НАЙТИБ находит вхождение одной текстовой строки (искомый_текст) в другую текстовую строку (просматриваемый_текст) и возвращает положение начала искомого текста относительно крайнего левого символа просматриваемого текста с учетом числа байтов, используемых каждым символом. Эта функция используется при работе с символами, занимающими два байта. Для поиска вхождений одной текстовой строки в другую текстовую строку можно использовать также функцию ПОИСКБ.

Синтаксис

НАЙТИ(искомый_текст;просматриваемый_текст;нач_позиция)

НАЙТИБ(искомый_текст;просматриваемый_текст;нач_позиция)

Искомый_текст — это искомый текст.

  • Если искомый_текст — это "" (пустая строка), то функция НАЙТИ считает подходящим первый символ в просматриваемой строке (то есть возвратит значение аргумента нач_позиция или 1).

  • Искомый_текст не должен содержать никаких символов шаблона.

Просматриваемый_текст — это текст, включающий искомый текст.

Нач_позиция — это позиция символа, с которой следует начинать поиск. Первый символ в аргументе просматриваемый_текст имеет номер 1. Если аргумент нач_позиция опущен, то он полагается равным 1.

Совет. Аргумент нач_позиция можно использовать, чтобы пропустить нужное количество символов. Например, задана текстовая строка "МДС0093.МесячныеПродажи". Чтобы найти первое вхождение "М" в описательную часть текстовой строки, укажите, что нач_позиция равна 8, так что в той части текста, которая является серийным номером, поиск производиться не будет. Функция НАЙТИ начинает с символа 8, находит искомый_текст в следующем символе и возвращает число 9. Функция НАЙТИ всегда возвращает номер символа, считая от левого края текста, а не от значения аргумента нач_позиция.

Замечания

  • Если искомый_текст не входит в просматриваемый_текст, то функции НАЙТИ и НАЙТИБ возвращают значение ошибки #ЗНАЧ!.

  • Если нач_позиция меньше или равна нулю, то функции НАЙТИ и НАЙТИБ возвращают значение ошибки #ЗНАЧ!.

  • Если нач_позиция больше длины строки просматриваемый_текст, то функции НАЙТИ и НАЙТИБ возвращают значение ошибки #ЗНАЧ!.

Примеры

НАЙТИ("М";"Мадам Смирнова") равняется 1

НАЙТИ("м";"Мадам Смирнова") равняется 5

НАЙТИ("м";"Мадам Смирнова";6) равняется 8

В приведенных ниже примерах НАЙТИ возвращает 2, так как "" находится во второй позиции в строке, а НАЙТИБ возвращает 3, поскольку каждый символ учитывается со своей длиной (первый символ занимает 2 байта, поэтому второй символ начинается с байта 3).

НАЙТИ(" Токио—Сибуя ";" Токио—Сибуя Токио—Сибуя Токио—Сибуя ") равняется 2

НАЙТИБ(" Токио—Сибуя ";" Токио—Сибуя Токио—Сибуя Токио—Сибуя ") равняется 3

Предположим, что на листе хранится список деталей с их серийными номерами, и нужно выделить список наименований деталей без серийных номеров. Можно использовать функцию НАЙТИ для поиска символа #, а затем функцию ПСТР, чтобы исключить серийный номер. Пусть ячейки A2:A4 содержат следующий список деталей с серийными номерами: "Керамические изоляторы #124-6745-87", "Медные катушки #12-671-6772", "Переменные сопротивления #116010".

ПСТР(A2;1;НАЙТИ(" #";A2;1)-1) возвращает "Керамические изоляторы"

ПСТР(A3;1;НАЙТИ(" #";A3;1)-1) возвращает "Медные катушки"

ПСТР(A4;1;НАЙТИ(" #";A4;1)-1) возвращает "Переменные сопротивления"


ПЕЧСИМВ

См. также

Удаляет все непечатаемые символы из текста. Функция ПЕЧСИМВ используется в том случае, когда текст, импортированный из другого приложения, содержит символы, которые не могут быть напечатаны операционной системой. Например, можно использовать функцию ПЕЧСИМВ, чтобы удалить низкоуровневые компьютерные коды, которые часто встречаются в начале или в конце файла данных и не могут быть напечатаны.

Синтаксис

ПЕЧСИМВ(текст)

Текст - это любая информация на рабочем листе, из которой удаляются непечатаемые символы.

Пример

Поскольку СИМВОЛ(7) возвращает непечатаемый символ:

ПЕЧСИМВ(СИМВОЛ(7)&"текст"&СИМВОЛ(7)) равняется "текст"


ПОВТОР

См. также

Повторяет текст заданное число раз. Функция ПОВТОР используется, чтобы заполнить ячейку некоторым количеством вхождений текстовой строки.

Синтаксис

ПОВТОР(текст;сколько_раз)

Текст - это повторяемый текст.

Сколько_раз - это положительное число, определяющее, сколько раз нужно повторить текст. Если сколько_раз равно 0 (нулю), то функция ПОВТОР возвращает "" (пустой текст). Если сколько_раз не целое, то оно усекается. Результат функции ПОВТОР не должен превышать 255 символов.

Совет. Эту функцию можно использовать для создания простых гистограмм на рабочем листе.

Примеры

ПОВТОР("*-"; 3) равняется "*-*-*-"

Если A3 содержит "Продажи", то:

ПОВТОР($A$3; 2,9) равняется "ПродажиПродажи"


ПОДСТАВИТЬ

См. также

Подставляет текст нов_текст вместо текста стар_текст в текстовой строке. Функция ПОДСТАВИТЬ используется, когда нужно заменить определенный текст в текстовой строке; функция ЗАМЕНИТЬ используется, когда нужно заменить любой текст, начиная с определенной позиции.

Синтаксис

ПОДСТАВИТЬ(текст;стар_текст;нов_текст;номер_вхождения)

Текст - это либо текст, либо ссылка на ячейку, содержащую текст, в котором подставляются символы.

Стар_текст - это заменяемый текст.

Нов_текст - это заменяющий текст.

Номер_вхождения - определяет, какое вхождение текста стар_текст нужно заменить на нов_текст. Если номер_вхождения определен, то только это вхождение текста стар_текст заменяется. В противном случае, каждое вхождение текста стар_текст в текстовой строке заменяется на текст нов_текст.

Примеры

ПОДСТАВИТЬ("Годовой отчет"; "Годовой"; "Недельный") равняется "Недельный отчет"

ПОДСТАВИТЬ("Квартал 1, 1991"; "1"; "2"; 1) равняется "Квартал 2, 1991"

ПОДСТАВИТЬ("Квартал 1, 1991"; "1"; "2"; 3) равняется "Квартал 1, 1992"

Чтобы заменить каждое вхождение текстовой константы, названной Разделитель, в ячейке с именем ИмяЯч на квадратные скобки, можно использовать формулу:

ПОДСТАВИТЬ(ИмяЯч; Разделитель; "] [")


ПОИСК

См. также

Также применимо к:

ПОИСКБ

Возвращает позицию первого вхождения символа или текстовой строки при поиске слева направо, начиная с нач_позиция. Функция ПОИСК используется для поиска вхождения символа или строки текста в другую строку текста, с тем чтобы применить функции ПСТР или ЗАМЕНИТЬ для изменения текста.

Функция ПОИСКБ находит вхождение одной текстовой строки (искомый_текст) в другую текстовую строку (просматриваемый_текст) и возвращает положение начала искомого текста относительно крайнего левого символа просматриваемого текста с учетом числа байтов, используемых каждым символом. Эта функция используется при работе с символами, занимающими два байта. Для поиска вхождений одной текстовой строки в другую текстовую строку можно использовать также функцию НАЙТИБ.

Синтаксис

ПОИСК(искомый_текст;текст_для_поиска;нач_позиция)

ПОИСКБ(искомый_текст;текст_для_поиска;нач_позиция)

Искомый_текст — это искомый текст. Можно использовать символы шаблона знак вопроса (?) и звездочка (*) в аргументе искомый_текст. Знак вопроса соответствует любому символу; звездочка соответствует любой последовательности символов. Если нужно найти символ знак вопроса или звездочку, то следует поставить перед ними знак тильда (~). Если искомый_текст не найден, то возвращается значение ошибки #ЗНАЧ!.

Текст_для_поиска — это текст, в котором нужно найти искомый_текст.

Нач_позиция — это номер символа в тексте текст_для_поиска, с которого следует начать поиск.

  • Если аргумент опущен, то он полагается равным 1.

  • Если нач_позиция не больше 0 или больше, чем длина аргумента текст_для_поиска, то возвращается значение ошибки #ЗНАЧ!.

Совет. Аргумент нач_позиция можно использовать, чтобы пропустить нужное количество символов. Например, задана текстовая строка "МДС0093.МесячныеПродажи". Чтобы найти первое вхождение "М" в описательную часть текстовой строки, укажите, что нач_позиция равна 8, так что в той части текста, которая является серийным номером, поиск производиться не будет. Функция ПОИСК начинает с символа 8, находит искомый_текст в следующем символе и возвращает число 9. Функция ПОИСК всегда возвращает номер символа, считая от левого края текста, а не от значения аргумента нач_позиция.

Замечания

  • ПОИСК и ПОИСКБ не различают регистра при поиске (то есть строчные и заглавные буквы не различаются).

  • Функции ПОИСК и ПОИСКБ аналогичны функциям НАЙТИ и НАЙТИБ за исключением того, что НАЙТИ и НАЙТИБ работают с учетом регистра.

Примеры

ПОИСК("р";"Операторы";6) равняется 8

Если ячейка B17 содержит слово "доход", а ячейка A14 содержит "Сумма Доходов", то:

ПОИСК($B$17;$A$14) равняется 7

Функции ПОИСК и ПОИСКБ используются совместно с функцией ЗАМЕНИТЬ для того, чтобы задать функции ЗАМЕНИТЬ корректное значение аргумента нач_позиция, с которой нужно вставить новый текст. Используя ячейки предыдущего примера, получим:

ЗАМЕНИТЬ($A$14;ПОИСК($B$17;$A$14);7;"Расходов") возвращает текст "Сумма Расходов".

В приведенных ниже примерах ПОИСК возвращает 2, так как "" находится во второй позиции в строке, а ПОИСКБ возвращает 3, поскольку каждый символ учитывается со своей длиной (первый символ занимает 2 байта, поэтому второй символ начинается с байта 3).

ПОИСК(" Токио—Сибуя ";" Токио—Сибуя Токио—Сибуя Токио—Сибуя ") равняется 2

ПОИСКБ(" Токио—Сибуя ";" Токио—Сибуя Токио—Сибуя Токио—Сибуя ") равняется 3


ПРАВСИМВ

Сведения, относящиеся к конкретным языкам

См. также

Также относится к:

ПРАВБ

Функция ПРАВСИМВ возвращает указанное число последних символов текстовой строки.

ПРАВБ возвращает указанное число последних байтов из текстовой строки. Эта функция используется при работе с символами, занимающими два байта.

Синтаксис

ПРАВСИМВ(текст;число_символов)

ПРАВБ(текст;число_байтов)

Текст — это текстовая строка, содержащая извлекаемые символы.

Количество_символов — определяет сколько символов должна извлечь функция ПРАВСИМВ.

  • Количество_символов должно быть больше или равно нулю.

  • Если число_символов больше, чем длина текста, то функция ПРАВСИМВ возвращает весь текст.

  • Если количество_символов опущено, то оно полагается равным 1.

Количество_байтов — определяет сколько байтов должна извлечь функция ПРАВБ.

Примеры

ПРАВСИМВ("Продажная Цена"; 4) равняется "Цена"

ПРАВСИМВ("Ассортиментный Номер") равняется "р"

ПРАВБ(" Токио—Сибуя Токио—Сибуя " Токио—Сибуя ";2) равняется " Токио—Сибуя "

Функции ПРАВСИМВ и ПРАВБ похожи на функции ЛЕВСИМВ и ЛЕВБ; см. также примеры к функции ЛЕВСИМВ.


ПРОПИСН

См. также

Делает все буквы в тексте прописными.

Синтаксис

ПРОПИСН(текст)

Текст - это текст, преобразуемый в верхний регистр. Текст может быть ссылкой на текст или текстовой строкой.

Примеры

ПРОПИСН("всего") равняется "ВСЕГО"

Если ячейка E5 содержит строку "доход", то:

ПРОПИСН(E5) равняется "ДОХОД"


ПРОПНАЧ

См. также

Первая буква в строке текста и все первые буквы, следующие за символами, отличными от букв, делаются прописными (верхний регистр). Все прочие буквы в тексте делаются строчными (нижний регистр).

Синтаксис

ПРОПНАЧ(текст)

Текст - это либо текст в кавычках, либо формула, выдающая текст, либо ссылка, содержащая текст, в котором некоторые буквы заменяются на прописные.

Примеры

ПРОПНАЧ("это ЗАГОЛОВОК ") равняется "Это Заголовок "

ПРОПНАЧ("10-кратное увеличение ") равняется "10-Кратное Увеличение "

ПРОПНАЧ("76БюдЖет") равняется "76Бюджет"


ПСТР

См. также

Также относится к:

ПСТРБ

ПСТР возвращает указанное число символов из текстовой строки, начиная с указанной позиции.

ПСТРБ возвращает указанное число байтов из текстовой строки, начиная с указанной позиции. Эта функция используется при работе с символами, занимающими два байта.

Синтаксис

ПСТР(текст; начальная_позиция;количество_символов)

ПСТРБ(текст; начальная_позиция;количество_байтов)

Текст — это текстовая строка, содержащая извлекаемые символы.

Начальная_позиция — это позиция первого символа, извлекаемого из текста. Первый символ в тексте имеет начальную позицию 1 и так далее.

  • Если начальная_позиция больше, чем длина текста, то функция ПСТР возвращает строку "" (пустой текст).

  • Если начальная_позиция меньше, чем длина текста, но начальная_позиция плюс количество_символов превышают длину текста, то функция ПСТР возвращает символы вплоть до конца текста.

  • Если начальная_позиция меньше 1, то функция ПСТР возвращает значение ошибки #ЗНАЧ!.

Количество_символов указывает, сколько символов нужно вернуть. Если количество_символов отрицательно, то функция ПСТР возвращает значение ошибки #ЗНАЧ!.

Количество_байтов указывает, сколько байтов нужно вернуть. Если количество_байтов отрицательно, то функция ПСТРБ возвращает значение ошибки #ЗНАЧ!.

Примеры

ПСТР("Поток жидкости"; 1; 5) равняется "Поток"

ПСТР("Поток жидкости"; 7; 20) равняется "жидкости"

ПСТР("1234"; 5; 5) равняется "" (пустой текст)

См. также примеры для функций КОДСИМВ и НАЙТИ.

ПСТРБ(" Токио—Сибуя Токио—Сибуя Токио—Сибуя Токио—Сибуя Токио—Сибуя Токио—Сибуя ";1;6) равняется " Токио—Сибуя Токио—Сибуя Токио—Сибуя "


РУБЛЬ

См. также

Преобразует число в текст, используя денежный формат с округлением до заданного числа десятичных знаков. Используется следующий формат: # ##0,00 р.;- # ##0,00 р.

Синтаксис

РУБЛЬ(число; число_знаков)

Число - это либо число, либо ссылка на ячейку, содержащую число, либо формула, вычисление которой дает число.

Число_знаков - это число цифр справа от десятичной запятой. Если число_знаков отрицательно, то число округляется слева от десятичной запятой. Если число_знаков опущено, то оно полагается равным 2.

Замечания

Наибольшее различие между форматированием ячейки, содержащей число, с помощью команды Ячейка в меню Формат и форматированием числа непосредственно с помощью функции РУБЛЬ состоит в том, что функция РУБЛЬ преобразует свой результат в текст. Число, которое форматируется с помощью команды Ячейка по-прежнему остается числом. Однако, можно продолжать использовать числа, отформатированные функцией РУБЛЬ в формулах, потому что Microsoft Excel преобразует числа, введенные как текст, в числовые значения в процессе вычислений.

Примеры

РУБЛЬ(1234,567; 2) равняется "1234,57 р."

РУБЛЬ(1234,567; -2) равняется "1200 р."

РУБЛЬ(-1234,567; -2) равняется "-1200 р."

РУБЛЬ(-0,123; 4) равняется "-0,1230 р."

РУБЛЬ(99,888) равняется "99,89 р."


СЖПРОБЕЛЫ

См. также

Удаляет из текста все пробелы, за исключением одиночных пробелов между словами. Функция СЖПРОБЕЛЫ используется для обработки текстов, полученных из других прикладных программ, если эти тексты могут содержать избыточные пробелы.

Синтаксис

СЖПРОБЕЛЫ(текст)

Текст - это текст, из которого удаляются пробелы.

Пример

СЖПРОБЕЛЫ(" Доход   за первый    квартал   ") равняется "Доход за первый квартал"


СИМВОЛ

См. также

Возвращает символ с заданным кодом. Функция СИМВОЛ используется, чтобы преобразовать числовые коды символов, которые получены из файлов с других компьютеров, в символы данного компьютера.

Операционная среда | Таблица символов
Macintosh | Таблица символов Macintosh
Windows | ANSI

Синтаксис

СИМВОЛ(число)

Число - это число от 1 до 255, указывающее нужный символ. Символы выбираются из таблицы символов Вашего компьютера.

Примеры

СИМВОЛ(65) равняется "A"

СИМВОЛ(33) равняется "!"


СОВПАД

См. также

Сравнивает две строки текста и возвращает значение ИСТИНА, если они в точности совпадают и ЛОЖЬ в противном случае. Функция СОВПАД учитывает регистр, но игнорирует различия в форматировании. Функция СОВПАД используется для того, чтобы проверить, входит ли некоторый текст в документ.

Синтаксис

СОВПАД(текст1;текст2)

Текст1 — это первая текстовая строка.

Текст2 — это вторая текстовая строка.

Примеры

СОВПАД("слово";"слово") равняется ИСТИНА

СОВПАД("Слово";"слово") равняется ЛОЖЬ

СОВПАД("с лово";"слово") равняется ЛОЖЬ

Чтобы проверить, соответствует ли введенное пользователем значение одному из значений в интервале, следует ввести следующую формулу в ячейку как массив. Чтобы ввести формулу как массив в отдельную ячейку, нажмите клавиши CTRL+SHIFT+ENTER в Microsoft Excel для Windows или COMMAND +ENTER в Microsoft Excel для Макинтош. Имя «ПроверяемоеЗначение» ссылается на ячейку, содержащую введенное пользователем значение; имя «ИнтервалДляСравнений» ссылается на список текстовых значений, с которыми производится сравнение.

{=ИЛИ(СОВПАД(ПроверяемоеЗначение;ИнтервалДляСравнений))}


СТРОЧН

См. также

Преобразует символы в текстовой строке из верхнего регистра в нижний.

Синтаксис

СТРОЧН(текст)

Текст - это текст, преобразуемый в нижний регистр. Функция СТРОЧН не меняет символов, которые не являются буквами.

Примеры

СТРОЧН("И. И. Иванов") равняется "и. и. иванов"

СТРОЧН("Арт. 2А") равняется "арт. 2а"

СТРОЧН родственна функциям ПРОПНАЧ и ПРОПИСН. См. также примеры к функции ПРОПНАЧ.


СЦЕПИТЬ

См. также

Объединяет несколько текстовых строк в одну.

Синтаксис

СЦЕПИТЬ (текст1;текст2;...)

Текст1, текст2, ... - это от 1 до 30 элементов текста, объединяемых в один элемент текста. Элементами текста могут быть текстовые строки, числа или ссылки, которые ссылаются на одну ячейку.

Замечания

Вместо функции СЦЕПИТЬ для объединения текстов можно использовать оператор "&".

Примеры

СЦЕПИТЬ("Суммарное "; "Значение") равняется "Суммарное Значение". Это эквивалентно выражению
"Суммарное"&" "&"Значение"

Пусть имеется рабочий лист, в котором собраны данные о видах рыб, обитающих в реке, и пусть ячейка C2 содержит "вида", ячейка C5 содержит " речная форель" и ячейка C8 содержит 32. Тогда

СЦЕПИТЬ("Численность популяции ";C2;" ";C5;" составляет ";C8;" на километр.") равняется "Численность популяции вида речная форель составляет 32 на километр."


T

См. также

Возвращает текст, ссылка на который задается аргументом значение.

Синтаксис

Т(значение)

Значение - это проверяемое значение. Если значение является текстом или ссылается на текст, то функция Т возвращает само это значение. Если значение не является текстом и не ссылается на текст, то функция Т возвращает "" (пустой текст).

Замечания

В общем случае нет необходимости использовать функцию Т в формулах, поскольку Microsoft Excel в случае необходимости автоматически преобразует значения. Эта функция предназначена для совместимости с другими системами электронных таблиц.

Примеры

Если ячейка B1 содержит текст "Снегопад", то:

Т(B1) равняется "Снегопад"

Если ячейка B2 содержит число 19, то:

Т(B2) равняется ""

Т("Истина") равняется "Истина"

Т(ИСТИНА) равняется ""


ТЕКСТ

См. также

Преобразует значение в текст в заданном числовом формате.

Синтаксис

ТЕКСТ(значение;формат)

Значение — это либо числовое значение, либо формула, вычисление которой дает числовое значение, либо ссылка на ячейку, содержащую числовое значение.

Формат — это числовой формат в текстовой форме из списка Числовые форматы с вкладки Число диалогового окна Формат ячеек. Формат не может содержать звездочку (*) и не может быть общим числовым форматом .

Замечания

Форматирование ячейки с помощью вкладки Число (команда Ячейки меню Формат) меняет только формат, но не значение. Использование функции ТЕКСТ преобразует значение в форматированный текст, и результат больше не участвует в вычислениях как число.

Примеры

ТЕКСТ(2,715; "0,00 р.") равняется "2,72 р."

ТЕКСТ("15.4.91"; "Д МММ, ГГГГ") равняется "15 апр, 1991"


ФИКСИРОВАННЫЙ

См. также

Округляет число до заданного количества десятичных цифр, форматирует число в десятичном формате с использованием запятых и точек и возвращает результат в виде текста.

Синтаксис

ФИКСИРОВАННЫЙ(число; число_знаков; без_разделителей)

Число - это число, которое округляется и преобразуется в текст.

Число_знаков - это число цифр справа от десятичной запятой.

Без_разделителей - это логическое значение, причем если аргумент без_разделителей имеет значение ИСТИНА, то ФИКСИРОВАННЫЙ не включает разделители тысяч в возвращаемый текст. Если аргумент без_разделителей имеет значение ЛОЖЬ или опущен, то возвращаемый текст будет включать разделители как обычно.

  • Числа в Microsoft Excel не могут иметь более 15 значащих цифр, но число_знаков может быть задано вплоть до 127.

  • Если число_знаков отрицательно, то число округляется слева от десятичной запятой.

  • Если число_знаков опущено, то оно полагается равным 2.

Замечания

Наибольшее различие между форматированием ячейки, содержащей число, с помощью команды Ячейка в меню Формат и форматированием числа непосредственно с помощью функции ФИКСИРОВАННЫЙ состоит в том, что функция ФИКСИРОВАННЫЙ преобразует свой результат в текст. Число, которое форматируется с помощью команды Ячейка, по-прежнему остается числом.

Примеры

ФИКСИРОВАННЫЙ(1234,567; 1) равняется "1234,6"

ФИКСИРОВАННЫЙ(1234,567; -1) равняется "1230"

ФИКСИРОВАННЫЙ(-1234,567; -1) равняется "-1230"

ФИКСИРОВАННЫЙ(44,332) равняется "44,33"


 Заголовки и имена в формулах

Заголовки и имена в формулах

Рабочий лист может содержать заголовки, размещенные вверху столбца и слева от строки, с помощью которых описываются данные внутри листа. При ссылке на необходимые данные можно использовать эти заголовки в формулах. Кроме того, можно создать имя для ячейки, группы ячеек, формулы или константы, не пользуясь заголовками.

Примечание. По умолчанию Microsoft Excel не распознает заголовки в формулах. Чтобы использовать заголовки в формулах, выберите команду Параметры в меню Сервис. На вкладке Вычисления в группе Параметры книги, установите флажок Допускать названия диапазонов.

Использование заголовков для представления ячеек При создании формулы, ссылающейся на данные из листа, можно использовать заголовки строк и столбцов для указания данных. Следующий пример содержит столбцы, помеченные «Изделие 1», «Изделие 2», «Изделие 3». Для подсчета общей суммы для столбца «Изделие 1» используйте формулу =СУММ(Изделие 1).

Если нужно сослаться на количество «Изделия 3» в Восточном филиале (значение которого равно 110,00), можно использовать формулу =Изделие 3 Восток. Пробел в формуле между «Изделие 3» и «Восток» — это оператор пересечения диапазонов. Этот оператор предписывает Microsoft Excel вернуть значение из ячейки, находящейся на пересечении строки, помеченной «Восток», и столбца, помеченного «Изделие 3». Использование нескольких заголовков в формулах.

Определение имен для представления ячеек Если данные не имеют заголовков или размещены на другом листе книги, можно создать имя, описывающее ячейку или группу ячеек. Использование имен может упростить понимание формулы. Например, формула " =СУММ(Продано_в_первом_квартале)" проще для понимания, чем формула " =СУММ(Продажа!C20:C30)". В этом примере имя «Продано_в_первом_квартале» представляет группу ячеек "C20:C30" на листе «Продажа».

Имена можно использовать в любом листе книге. Например, если имя «Контракты» ссылается на группу ячеек "A20:A30" в первом листе рабочей книге, то это имя можно применить в любом другом листе той же рабочей книги для ссылки на эту группу. Имя можно присвоить формуле или постоянному значению (константе). Например, имя «ПроцентнаяСтавка», которому присвоено значение 6,2 процента, можно использовать в любом месте для вычисления процентов.

Примечание. По умолчанию имена являются абсолютными ссылками.


Создание заголовков диапазонов с помощью диалогового окна «Заголовки диапазонов»

Указание заголовков. Если при создании формул выделяются ячейки диапазонов, имеющих заголовки, то вместо ссылок на ячейки Microsoft Excel может вставлять в формулы соответствующие заголовки. Использование заголовков делает формулу более наглядной. Задать диапазоны, содержащие заголовки строк и столбцов листа, можно с помощью диалогового окна Заголовки диапазонов (меню Вставка, подменю Имя, команда Заголовки диапазонов).

Использование дат в качестве заголовков. Если с помощью диалогового окна Заголовки диапазонов создаются заголовки, содержащие год или дату, то при вводе формулы Excel определяет дату как заголовок путем заключения ее в одинарные кавычки. Например, пусть лист содержит два заголовка «1996» и «1997», определенных в диалоговом окне Заголовки диапазонов. При вводе формулы =СУММ(1997) год автоматически заключается в кавычки: =СУММ('1997').

Для получения дополнительных сведений о параметрах диалогового окна Заголовки диапазонов нажмите кнопку с вопросительным знаком [image] и щелкните требуемый параметр.

Совет. Если списку присвоен заголовок с помощью команды Заголовки диапазонов, то при просмотре листа в масштабе менее 39 процентов Excel добавляет синюю рамку вокруг заголовков, указанных на листе с использованием диалогового окна команды Заголовки диапазонов. Синяя рамка не печатается и не отображается на экране при просмотре листа в масштабе более 39 процентов.


 Рекомендации по присвоению имен ячейкам, формулам и константам в Microsoft Excel

Рекомендации по присвоению имен ячейкам, формулам и константам в Microsoft Excel

Допустимые символы Первый символ в имени должен быть буквой или символом подчеркивания. Остальные символы имени могут быть: буквами, числами, точками и символами подчеркивания.

Ссылки на ячейки как имена Имена не могут иметь такой же вид, как и ссылки на ячейки, например Z$100 или R1C1.

Использование нескольких слов В имени может быть больше одного слова, но пробелы недопустимы. В качестве разделителей слов могут быть использованы символы подчеркивания и точки — например, Налог_на_продажи или Первый.Квартал.

Число символов Имя может содержать до 255 символов.

Примечание. Если имя диапазона содержит больше 253 символов, оно не может быть выбрано из поля Имя.

Учет регистра в именах Имя может состоять из строчных и прописных букв, но Microsoft Excel их не различает. Например, если создано имя «Продажа», а затем в той же книге создано другое имя «ПРОДАЖА», то второе имя заменит первое.


Присваивание имен ячейкам рабочей книги

Предполагаемые действия

Заголовки и имена в формулах

Присваивание имени ячейке или группе ячеек

Присваивание ячейкам имени при помощи существующих заголовков строк и столбцов

Присваивание ячейкам имени в нескольких листах при помощи трехмерной ссылки

Дополнительные сведения


 Присваивание имен константам и формулам

Присваивание имен константам и формулам

  1. Выберите команду Имя в меню Вставка, а затем — команду Присвоить.

    Демонстрация

  2. Введите имя формулы в поле Имя.

  3. Введите знак равенства (=) в поле Формула, после которого введите формулу или константу.


 Проверка ссылки имени

Проверка ссылки имени

  1. Выберите команду Имя в меню Вставка, а затем — команду Присвоить.

    Демонстрация

  2. Выделите имя, для которого необходимо проверить ссылку, в списке Имя.

    Для выделенного имени в поле Формула отобразится ссылка, формула или константа.

Совет. Кроме того, можно создать список всех доступных имен книги. Этот список будет состоять из двух столбцов — в первом имена, а во втором краткие описания имен. Укажите ячейку, с которой будет начинаться список. Выберите команду Имя в меню Вставка, а затем — команду Вставка. Нажмите кнопку Все имена в диалоговом окне Вставка имени.


 Замена ссылок именами в ячейке или формуле

Замена ссылок именами в ячейке или формуле

  1. Выделите группу ячеек, содержащих формулы, в которых необходимо заменить ссылки именами.

    Чтобы заменить ссылки именами во всех формулах листа, выделите одну ячейку.

  2. Выберите команду Имя в меню Вставка, а затем — команду Применить.
  3. Выберите необходимые имена в списке Применить имена.


 Изменение ссылки, формулы или константы по имени

Изменение ссылки, формулы или константы по имени

  1. Выберите команду Имя в меню Вставка, а затем — команду Присвоить.

    Демонстрация

  2. Выделите имя, для которого необходимо изменить ссылку, формулу или константу в списке Имя.

  3. Измените ссылку, формулу или константу в поле Формула.


 Изменение имени ссылки, формулы или константы

Изменение имени ссылки, формулы или константы

  1. Выберите команду Имя в меню Вставка, а затем — команду Присвоить.

    Демонстрация

  2. Выделите изменяемое имя в списке Имя.

  3. Выделите имя в поле Имя.

  4. Введите новое имя и нажмите кнопку Добавить.

  5. Удалите старое имя. Выделите его в списке и нажмите кнопку Удалить.


 Создание имени, ссылающегося на ячейки в другой книге

Создание имени, ссылающегося на ячейки в другой книге

Когда определяется имя, ссылающееся на ячейки в другой книге, создается связь, называемая внешней ссылкой. При выполнении этой процедуры убедитесь в том, что книга, на которую будут ссылаться, открыта и все изменения в ней сохранены.

  1. В книге, которая будет содержать внешнюю ссылку, в меню Вставка выберите команду Имя, а затем — команду Присвоить.

    Демонстрация

  2. Введите имя внешней ссылки в поле Имя.

  3. Если в поле Формула содержится ссылка, выделите ссылку вместе со знаком равенства (=) и нажмите клавишу BACKSPACE.

  4. Сделайте активной книгу, содержащую ячейки, на которые будет сделана ссылка, щелкнув имя книги в менюОкно.

  5. Укажите ячейку или выделите диапазон ячеек, на которые необходимо сослаться.

  6. В диалоговом окне Присвоение имени нажмите кнопку Добавить.


 Формулы массива и их ввод

Формулы массива и их ввод

Формула массива может выполнить несколько вычислений, а затем вернуть одно значение или группу значений. Формула массива обрабатывает несколько наборов значений, называемых аргументами массива. Каждый аргумент массива должен включать одинаковое число строк и столбцов. Формула массива создается так же, как и другие формулы, с той разницей, что для ввода такой формулы используются клавиши CTRL+SHIFT+ENTER.

Вычисление одного значения. Иногда для получения одного результата Microsoft в Excel необходимо выполнить несколько вычислений. Например, следующий лист показывает, что компания имеет региональные представительства в Европе и Серверной Америке, торгующие тремя типами товаров. Для расчета среднего дохода по каждому типу товаров в Европе за 1992 год необходимо использовать формулу массива.

Формула массива, вычисляющая одно значение

Ячейка C16 содержит формулу массива =СРЗНАЧ(ЕСЛИ(C5:C14="Европа",D5:D14)), которая отбирает из диапазона C5:C14 ячейки, содержащие текст "Европа", а затем вычисляет среднее значение по соответствующим ячейкам диапазона D5:D14.

Вычисление нескольких значений. Для вычисления нескольких значений с помощью формулы массива необходимо ввести массив в диапазон ячеек, состоящий из того же числа строк или столбцов, что и аргументы массива. В следующем примере по заданному ряду из трех значений продаж (в строке 5) и ряду из трех месяцев (в строке 3) функция ТЕНДЕНЦИЯ определяет продолжение линейного ряда объемов продаж. Для отображения всех вычисляемых значений формула введена в три ячейки строки 6 (C6:E6).

Формула массива, вычисляющая несколько значений

Формула =ТЕНДЕНЦИЯ(C5:E5,C3:E3), введенная как формула массива, возвращает три значения, вычисленные по трем объемам продаж за три месяца.

Использование постоянных значений. Формулу массива можно также использовать для вычисления одного или нескольких результатов для ряда значений, еще не введенных на лист. Формулы массива принимают константы так же, как и другие формулы, но константы массива необходимо вводить в определенном формате. Например, имея те же три значения продаж, что и в предыдущем примере, можно спрогнозировать объемы продаж на следующие два месяца.

Формула массива, использующая постоянное значение

Для прогнозирования четвертого и пятого значений в ежемесячной последовательности на основе первых трех значений используется формула =ТЕНДЕНЦИЯ(C5:E5,,{4,5}).

Дополнительные сведения

Постоянные значения в массиве

Создание формулы массива


 Константы в формулах массива

Константы в формулах массива

Обычно формула при обработке одного или нескольких аргументов возвращает одно значение; в качестве аргумента формулы может при этом выступать либо ссылка на ячейку, содержащую значение, либо само значение. В формуле массива, которая обычно используется для ссылки на диапазон ячеек, можно ввести массив значений в одну ячейку. Этот массив значений называется массивом констант; удобен он тем, что при этом не требуется заносить по одному значению в ячейку на листе. Чтобы создать массив констант, выполните следующие действия:

  • Введите значения непосредственно в формулу, заключив в фигурные скобки ( { } )

  • Столбцы разделяются запятыми (,)

  • Строки разделяются точками с запятой (;)

Например, вместо ввода четырех чисел (10, 20, 30, 40) в отдельные ячейки их можно ввести в массив, в одну ячейку в фигурных скобках: {10,20,30,40}. Такой массив констант является матрицей размерности 1 на 4 и соответствует ссылке на 1 строку и 4 столбца. Чтобы представить значения 10, 20, 30, 40 и 50, 60, 70, 80, находящиеся в расположенных друг под другом ячейках, можно создать массив констант размерностью 2 на 4, причем строки будут отделены друг от друга точкой с запятой, а значения в столбцах — запятыми: {10,20,30,40;50,60,70,80}. См. сведения о типах значений, которые могут быть использованы в массиве констант.

Дополнительные сведения

Инструкции по вводу формулы массива


 Из чего может состоять массив констант

Из чего может состоять массив констант

  • Массив констант может включать числа, текст, логические значения (например ИСТИНА или ЛОЖЬ) или значения ошибок (например #Н/Д).

  • Числа в массиве могут быть целыми, с десятичной точкой или в экспоненциальном формате.

  • Текст должен быть взят в двойные кавычки, например "Вторник".

  • Массив констант может состоять из элементов разного типа, например {1,3,4;ИСТИНА,ЛОЖЬ,ИСТИНА}.

  • Элементы массива должны быть константами, но не формулами.

Массив констант не может содержать

  • $ (знак доллара), скобки или % (знак процента).

  • Ссылки на ячейки.

  • Столбцы или строки разной длины.

Дополнительные сведения

Константы в формулах массива

Инструкции по вводу формулы массива


 Выделение группы ячеек, содержащих формулу массива

Выделение группы ячеек, содержащих формулу массива

  1. Укажите любую ячейку массива.

  2. В меню Правка выберите команду Перейти.

    Демонстрация

  3. Выберите Дополнительный.

  4. Установите флажок Текущий массив.


 Пересчет формул в книгах

Пересчет формул в книгах

Пересчет — это процесс обработки формул и отображения возвращаемых ими значений в ячейках, содержащих формулы. По умолчанию Microsoft Excel автоматически пересчитывает все открытые книги. Процессом пересчета можно управлять.

Пересчет существующих формул Excel пересчитывает те ячейки, которые зависят от других ячеек, значения в которых изменились. Этот тип пересчета позволяет избежать ненужных вычислений. При открытии или сохранении книги также производится пересчет. Управление способом пересчета листа или книги.

В вычислениях используются хранимые, а не отображаемые, значения Отображаемые и печатаемые значения зависят от формата, отображающего хранимые значения. Например, ячейка, в которой отображается дата "22.6.96", содержит число, которое является хранимым значением даты в ячейке. Задавая другой формат ячейки, можно изменять отображение на экране (например "22/6/96"), но хранимое значение в ячейке не изменяется. Изменение способа отображения чисел, дат и времени в Excel.

Фоновые вычисления Во время пересчета можно выбирать команды и выполнять ввод чисел или формул. Для выполнения команд или других действий пересчет прерывается и затем возобновляется снова. Если книга содержит большое число формул или листы содержат таблицы данных, а также автоматически вычисляемые функции, то процесс пересчета может затянуться на долгое время. Также процесс вычислений может потребовать существенно больше времени, если лист содержит связи с другими листами или книгами. См. сведения об изменении способа пересчета формул.

Дополнительные сведения

Подстановочные символы в форматах чисел, дат и времени, задаваемых пользователем

Изменение точности вычислений в книге


Способ пересчета книг, созданных более ранними версиями Excel

Microsoft Excel 2000 пересчитывает книги, созданные более ранними версиями Excel, по другому, чем книги формата Excel 2000. Эта возможность является новой; более ранние версии Excel пересчитывали все книги, независимо от версии, одним способом.

Пересчет новых и старых книг в Excel 2000 Когда открывается книга, созданная в Excel 2000, Excel пересчитывает только формулы, которые зависят от измененных ячеек. Таким же образом поступают и более ранние версии Excel.

Однако если в Excel 2000 открывается книга, созданная более ранней версией Excel, книга пересчитывается полностью. Excel 2000 пересчитывает все формулы в книге — и те, которые зависят от измененных ячеек, и все остальные. Это гарантирует полную оптимизацию книги для использования в Excel 2000.

Поскольку полный пересчет требует больше времени, чем частичный, открытие книги, которая не была сохранена в формате Excel 2000, может потребовать больше времени. Однако после сохранения книги в формате Excel 2000 все последующие открытия книги будут занимать существенно меньше времени.

Полный пересчет книги вручную Если необходимо гарантировать полный пересчет книги, можно произвести пересчет с помощью кнопки Вычислить все. Чтобы использовать эту кнопку, необходимо сначала добавить ее на панель инструментов. При нажатии этой кнопки Excel 2000 полностью пересчитывает активную книгу, включая все зависимые и независимые формулы.

Примечание. Другим способом полного пересчета книги является одновременное нажатие клавиш CTRL+ALT+F9.


Изменение способа пересчета формул

По умолчанию Microsoft Excel автоматически пересчитывает формулы при изменении ячеек, влияющих на формулу.

Предполагаемые действия

Выбор способа пересчета листа или книги

Изменение точности вычислений в книге

Изменение числа итераций расчета формулы

Не можете сделать выбор?


 Пересчет формул всех открытых книг

Пересчет формул всех открытых книг

  • Нажмите клавишу F9.

Примечание. Если выделить формулу или ее часть в строке формул, а затем нажать клавишу F9, то отобразится возвращаемое значение всей формулы или ее части. Чтобы оставить формулу без изменений, нажмите клавишу ESC. Чтобы восстановить формулу после случайного нажатия клавиши ENTER, нажмите кнопку Отменить [image] .


 Циклические ссылки в формулах

Циклические ссылки в формулах

Циклической ссылкой называется последовательность ссылок, при которой формула ссылается (через другие ссылки или напрямую), сама на себя. Чтобы обработать такую формулу, необходимо вычислить значение каждой ячейки, включенной в замкнутую последовательность, используя результаты предыдущих итераций. По умолчанию, до тех пор пока не будут изменены соответствующие параметры, вычисления прекращаются после выполнения 100 итераций или после того, как изменение каждой величины не будет превышать 0,001 за одну итерацию.

Поиск циклических ссылок с помощью панели инструментов «Циклические ссылки» Excel не может вычислить формулы с циклическими ссылками, используя обычные вычисления. Когда формируется циклическая ссылка, появляется сообщение, предупреждающее об этом. Если циклическая ссылка является случайной, нажмите кнопку OK. появится панель инструментов Циклические ссылки и стрелки слежения укажут на все ячейки, на которые ссылается эта циклическая ссылка. Можно использовать панель инструментов Циклические ссылки для обхода всех ячеек в ссылке, чтобы переопределить формулы или логику вычислений и таким образом разорвать циклическую ссылку. (Некоторые научные и инженерные формулы требуют циклических ссылок.) Инструкции по обнаружению ячеек, формирующих циклическую ссылку.

Изменение числа итераций Поскольку некоторые формулы требуют циклических ссылок, может возникнуть необходимость изменить число итераций. Инструкции по изменению числа итераций при расчете формулы в Microsoft Excel.


 Поиск ячеек, содержащих циклическую ссылку

Поиск ячеек, содержащих циклическую ссылку

Microsoft Excel не может автоматически рассчитать все открытые книги, если одна из них содержит циклическую ссылку, т.е. формулу, которая прямо или косвенно ссылается на свою ячейку.

Для поиска таких ячеек служит панель инструментов Циклические ссылки. Она позволяет последовательно просмотреть каждую ячейку в циклической ссылке, чтобы внести необходимые исправления в формулу.

  1. На панели инструментов Циклические ссылки щелкните первую ячейку в поле Найти циклическую ссылку.

  2. Проверьте формулу в ячейке. Если она не является причиной ошибки, выберите в поле Найти циклическую ссылку следующую ячейку.

  3. Продолжайте правку формул до тех пор, пока в строке состояния отображается слово «Цикл».

Советы

  • Чтобы вручную отобразить панель инструментов Циклические ссылки, выберите в меню Сервис команду Настройка, а затем перейдите на вкладку Панели инструментов и установите флажок Циклические ссылки.

  • В строке состояния отображается слово «Цикл», за которым следует ссылка на одну из ячеек, содержащихся в циклической ссылке. Если слово «Цикл» отображается без ссылки, то данная циклическая ссылка содержится не на текущем листе.

  • При открытой панели инструментов Циклические ссылки ячейки, зависимые от формулы, отмечены стрелками слежения.

  • Дважды щелкая стрелки слежения, можно переходить между ячейками в циклической ссылке.

  • Для получения дополнительных сведений о циклических ссылках нажмите кнопку [image] .


Использование в формулах данных других листов и книг

Можно совместно использовать данные, хранимые на различных листах и в различных книгах, с помощью связывания или внешних ссылок. Связывание особенно полезно, если не целесообразно хранить большие модели и системы расчетов в одной книге. Создание формулы, использующей значения другого листа или книги.

Ссылка на другой лист в той же книге В приведенном ниже примере функция СРЗНАЧ используется для расчета среднего значения в диапазоне B1:B10 на листе «Маркетинг» в той же самой книге.

Ссылка на другой лист в той же книге

Обратите внимание на то, что имя листа и восклицательный знак (!) предшествуют ссылке на диапазон ячеек.

Ссылка на лист в другой книге Можно не только создать ссылки между разными листами, но и организовать иерархию связанных книг. Например, группа отделов продаж может хранить данные в отдельных книгах; данные затем сводятся в книгу, обобщающую данные на районном уровне, которые затем сводятся в книгу, обобщающую данные на региональном уровне.

Примечание Если ячейки, на которые имеются ссылки, изменяются, Excel автоматически обновляет ссылки только для открытых книг, содержащих связи. Если книги связаны, проверяйте обновление зависимых книг после обновления или изменения данных в исходных книгах. Если зависимая книга открыта при изменении данных в исходной книге, Excel обновляет зависимую книгу автоматически. Если зависимая книга не открыта, можно обновить связи вручную. Ручное обновление связанной книги.

Excel отображает формулы со ссылками на другую книгу двумя способами, в зависимости от состояния исходной книги — той, что предоставляет данные для формулы — открыта она или закрыта. Когда она открыта, ссылка включает имя книги в квадратных скобках, за которым следует имя листа, восклицательный знак ( ! ) и ячейки, влияющие на формулу. Когда книга закрыта, ссылка включает полный путь.

Ссылка на лист в другой книге

Исходная книга для этой формулы не открыта, поэтому ссылка включает полный путь. Если бы Бюджет.xls был открыт, формула имела бы вид =СУММ([Бюджет.xls]Годовой!C10:C25).

Примечание. Если имя листа или книги содержит символы, не являющиеся буквами, необходимо заключить имя (или путь) в одиночные кавычки.

Эффективное использование ссылок

  • Слияние данных нескольких книг С помощью связывания книг отдельных пользователей или коллективов распределенные данные можно интегрировать в одну итоговую книгу. Исходные книги по-прежнему могут изменяться независимо от итоговой книги.

  • Создание различных представлений одних и тех же данных Все данные и формулы можно ввести в одну книгу или несколько книг и затем создать книгу отчетов, содержащую ссылки только на требуемые данные.

  • Последовательная разработка больших и сложных моделей обработки данных Если разделить сложную модель обработки данных на последовательность взаимосвязанных книг, можно работать с отдельными частями модели без открытия всех составляющих модель книг. При работе с небольшими книгами легче вносить изменения, открывать и сохранять файлы, выполнять пересчет листов; при этом размер памяти, запрашиваемой у компьютера для выполнения указанных действий, может быть незначительным.


 Создание формулы, использующей значения другого листа или книги

Создание формулы, использующей значения другого листа или книги

Перед связыванием новой книги ее необходимо сохранить.

  1. Укажите ячейку, которая будет содержать внешнюю ссылку.

  2. Если создается новая формула, введите знак равенства (=).

    Если внешняя ссылка является частью формулу, то перед ней можно ввести оператор или функцию.

  3. Если связываются листы рабочей книги, укажите лист, содержащий связываемые ячейки.

    Если листы связываются с другой книгой, перейдите в эту книгу и укажите лист, содержащий связываемые ячейки.

  4. Выделите связываемые ячейки.

  5. Для завершения ввода формулы нажмите клавишу ENTER.


 Открытие книги, на которую ссылается формула

Открытие книги, на которую ссылается формула

  1. Откройте книгу, содержащую формулу с внешней ссылкой.

  2. В меню Правка выберите команду Связи.

  3. Выберите имя книги, которую необходимо открыть, в списке Исходный файл.

  4. Нажмите кнопку Открыть.


 Изменение ссылки на перемещенную или переименованную книгу

Изменение ссылки на перемещенную или переименованную книгу

  1. Откройте книгу, содержащую формулу с внешней ссылкой, указывающей на переименованную или перемещенную книгу.

  2. В меню Правка выберите команду Связи.

  3. Выберите имя книги, для которой необходимо обновить ссылку, в списке Исходный файл.

  4. Выберите команду Изменить.

  5. Выберите книгу, на которую необходимо сослаться, в диалоговом окне Изменить связи.


Зависимости: прослеживание связей между формулами и ячейками (обзор)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Поиск влияющих ячеек

Предполагаемые действия

Поиск (или трассировка) ячеек, значения которых используются в формуле (зависимые ячейки)

Поиск ячеек, ставших причиной ошибок в формуле

Поиск и правка с помощью поиска диапазонов

Не можете сделать выбор?


 Поиск ячеек, ставших причиной ошибок в формуле

Поиск ячеек, ставших причиной ошибок в формуле

  1. Выведите на экран панель инструментов Зависимости, выбрав в меню Сервис команду Зависимости, а затем — Панель зависимостей.

    Перед тем как использовать панель инструментов Зависимости, установите флажки Отображать или Только очертания в группе Объекты на вкладке Вид диалогового окна Параметры (меню Сервис).

  2. Наведите указатель на ячейку, содержащую ошибку.

  3. Нажмите кнопку Источник ошибки [image] .

Примечание. Чтобы выбрать ячейку, находящуюся на другом конце стрелки, наведите указатель на стрелку и дважды щелкните левую кнопку мыши.


 Поиск ячеек, отличных от определенной ячейки

Поиск ячеек, отличных от определенной ячейки

Эта процедура находит ячейки на том же листе, что и сравниваемая ячейка.

  1. Выделите диапазон, в котором следует сравнить ячейки.

  2. В меню Правка выберите команду Перейти.

    Демонстрация

  3. Нажмите кнопку Выделить.

  4. Чтобы сравнить ячейки по строкам, установите переключатель в положение Отличия по строкам.

    Чтобы сравнить ячейки по столбцам, установите переключатель в положение Отличия по столбцам.


 Поиск влияющих ячеек

Поиск влияющих ячеек

  1. Выведите на экран панель инструментов Зависимости, выбрав в меню Сервис команду Зависимости, а затем — Панель зависимостей.

    Перед использованием панели инструментов Зависимости установите переключатель Объекты на вкладке Вид диалогового окна Параметры (меню Сервис) в положение Отображать или Только очертания.

  2. Укажите ячейку, для которой следует найти влияющие ячейки.

  3. Чтобы отобразить стрелку слежения от каждой влияющей ячейки, нажмите кнопку Влияющие ячейки [image] на панели инструментов Зависимости.

    Чтобы продолжить поиск следующего уровня влияющих ячеек, снова нажмите кнопку Влияющие ячейки [image] .

Примечания

  • Синие стрелки показывают ячейки того же листа, значения в которых используются при вычислении формулы в выделенной ячейке. Красные стрелки показывают ячейки, вызывающие ошибки. Если выделенная ячейка содержит ссылку на другой лист или другую книгу, черная стрелка идет от значка листа значок листа к выделенной ячейке.

  • Чтобы выбрать ячейку на другом конце стрелки, дважды щелкните стрелку. Чтобы выделить влияющую ячейку на другом листе или в другой книге, дважды щелкните черную стрелку и затем дважды щелкните требуемую ссылку в списке Перейти.

  • Если влияющая ячейка расположена в другой книге, эта книга должна быть открыта, чтобы можно было выделить влияющую ячейку.


 Поиск зависимых ячеек

Поиск зависимых ячеек

  1. Выведите на экран панель инструментов Зависимости, выбрав в меню Сервис команду Зависимости, а затем — Панель зависимостей.

    Перед использованием панели инструментов Зависимости установите переключатель Объекты на вкладке Вид диалогового окна Параметры (меню Сервис) в положение Отображать или Только очертания.

  2. Укажите ячейку, для которой следует найти зависимые ячейки.

  3. Чтобы отобразить стрелку зависимостей к каждой зависимой ячейке, нажмите кнопку Зависимые ячейки [image] на панели инструментов Зависимости.

    Чтобы продолжить поиск следующего уровня зависимых ячеек, снова нажмите кнопку Зависимые ячейки [image] .

Примечания

  • Синие стрелки показывают ячейки того же листа, которые зависят от выделенной ячейки. Красные стрелки показывают ячейки, вызывающие ошибки. Если на выделенную ячейку ссылаются с другого листа или другой книги, черная стрелка идет от выделенной ячейки к значку листа значок листа.

  • Если зависимая ячейка располагается в другой книге, эта книга должна быть открыта, чтобы можно было выделить зависимую ячейку.

  • Чтобы выбрать ячейку на другом конце стрелки, дважды щелкните стрелку. Чтобы выделить зависимую ячейку на другом листе или в другой книге, дважды щелкните черную стрелку и затем дважды щелкните требуемую ссылку в списке Перейти.


 Поиск и правка с помощью поиска диапазонов

Поиск и правка с помощью поиска диапазонов

  1. Дважды щелкните ячейку, содержащую формулу, которую следует изменить. Каждую ячейку или их диапазон Microsoft Excel выделяет своим цветом.

  2. Чтобы изменить ссылку на ячейку или диапазон, перетащите цветную границу к новым ячейке или диапазону.

    Перетащите указатель, расположенный в нижнем правом углу границы, который служит для изменения количества ячеек в ссылке.

  3. После обновления ссылок, нажмите клавишу ENTER.

    Если формула является формулой массива, нажмите комбинацию клавиш CTRL+SHIFT+ENTER.


 Удаление стрелок слежения

Удаление стрелок слежения

  1. Выведите на экран панель инструментов Зависимости, выбрав в меню Сервис команду Зависимости, а затем — Панель зависимостей.

    Перед тем как использовать панель инструментов Зависимости, установите флажки Отображать или Только очертания в группе Объекты на вкладке Вид диалогового окна Параметры (меню Сервис).

  2. Чтобы удалить первый уровень стрелок слежения начиная с самой дальней зависимой ячейки, нажмите кнопку Убрать стрелки к зависимым ячейкам [image] . Чтобы удалить следующий уровень, снова нажмите эту кнопку.

    Чтобы удалить первый уровень стрелок слежения начиная с самой дальней влияющей ячейки, нажмите кнопку Убрать стрелки к влияющим ячейкам [image] . Чтобы удалить следующий уровень, снова нажмите эту кнопку.

    Чтобы удалить все стрелки на листе, нажмите кнопку Убрать все стрелки [image] на панели инструментов Зависимости.


 Обведение ячеек с неверно введенными данными

Обведение ячеек с неверно введенными данными

Во время проверки листа Microsoft Excel находит все ячейки, которые содержат значения, противоречащие ограничениям, заданным с помощью команды Проверка в меню Данные. Сюда входят значения, непосредственно введенные в ячейку, значения, полученные в результате вычислений по формулам, копирования или автозаполнения, а также значения, которые были помещены в ячейки макросами.

  1. Убедитесь, что отображается панель инструментов Зависимости. Для этого выберите Зависимости в меню Сервис, а затем проверьте, что установлен флажок для отображения панели Зависимости.

  2. На панели инструментов Зависимости нажмите кнопку Обвести неверные данные [image] .

Примечания

  • Если в листе имеется более 255 ячеек с неверными данными, обводятся только первые 255 ячеек. Чтобы были обведены дополнительные ячейки, исправьте некоторые из неправильных ячеек и затем снова нажмите кнопку Обвести неверные данные [image] .

  • В режиме ручного пересчета таблицы при установлении диапазона допустимых данных границы в виде формулы может появиться сообщение, требующее пересчитать лист в случае обнаружения неверных данных. Чтобы избежать вывода этого сообщения, выберите Параметры в меню Сервис, а затем выберите вкладку Вычисления. В группе Вычисления установите переключатель в положение Автоматически.

Совет. Чтобы узнать, какие сообщения и ограничения на данные имеет ячейка, выберите ячейку, а затем — команду Проверка в меню Данные.


Разрешение вопросов, возникающих при появлении ошибок в формулах

Microsoft Excel отображает ошибку, если формула обработана неправильно. Например, если формуле требуются числовые значения, а на самом деле указаны текстовые, то отобразится ошибка. Ошибка появляется при удалении ячейки, на которую ссылается функция, а также при использовании ячейки, ширины которой не хватает для вывода результата.

Ошибки могут возникать не только из-за неправильной обработки формулы. Например, если отображается ошибка #Н/Д или #ЗНАЧ!, то, возможно, ошибка содержится в ячейке, на которую ссылается формула. Для определения ячеек, с которыми связаны ошибки, можно воспользоваться средствами поиска зависимостей. См. Сведения об поиске ячеек, ставших причиной ошибок в формуле.

Возможные значения ошибки

Ошибка #####

Ошибка #ЗНАЧ!

Ошибка #ДЕЛ/0!

Ошибка #ИМЯ?

Ошибка #Н/Д

Ошибка #ССЫЛКА!

Ошибка #ЧИСЛО!

Ошибка #ПУСТО!

Дополнительные сведения об ошибках в формулах


Разрешение вопросов, возникающих при проверке листов

В чем именно заключаются сложности?

Команды проверки недоступны

Недоступны кнопки панели инструментов Зависимости

Стрелки слежения исчезают при правке листа.

Не функционируют кнопки Зависимые ячейки и Влияющие ячейки.

Преждевременно прекращается поиск ошибки.

Ошибка при попытке перехода к ячейке другой книги.

Что случилось с Окном сведений?


Диаграммы

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Создание диаграммы

Создание диаграммы

Можно создать либо внедренную диаграмму, либо лист диаграммы.

  1. Выделите ячейки, содержащие данные, которые должны быть отражены на диаграмме.

    Чтобы заголовок столбца или строки для новых данных появился в диаграмме, в выбираемые ячейки нужно включить те, которые содержат этот заголовок.

  2. Нажмите кнопку Мастер диаграмм [image] .

  3. Следуйте инструкциям мастера диаграмм.

Советы

  • Можно быстро создать диаграмму без использования мастера диаграмм.

  • Можно создать диаграмму по отчету сводной таблицы, называемую отчетом сводной диаграммы, которая позволяет отображать различные представления данных.

  • Можно создать диаграмму из несмежных диапазонов ячеек.

  • Если на листе присутствуют многоуровневые названия строк или столбцов, то их также можно отразить на диаграмме. При создании диаграммы выделите названия строк и столбцов для каждого уровня. Чтобы при добавлении данных в диаграмму была сохранена заданная иерархия, измените диапазон ячеек, использованных при создании диаграммы.


 Создание диаграммы за один шаг

Создание диаграммы за один шаг

  • Для создания листа диаграммы, использующего стандартный тип диаграммы, выделите необходимые данные и нажмите клавишу F11.

  • Для создания внедренной диаграммы, использующей стандартный тип диаграммы, выделите необходимые данные, а затем нажмите кнопку Создать диаграмму текущего типа [image] . Если кнопка Создать диаграмму текущего типа отсутствует, добавьте ее на панель инструментов.

    Инструкции

Примечания

  • При использовании быстрой процедуры создания диаграммы используется стандартный тип диаграммы в Microsoft Excel. В качестве стандартного типа будет использоваться гистограмма, если не былизменен стандартный тип или не создается отчет сводной диаграммы. Стандартным типом для отчета сводной диаграммы является гистограмма с накоплением.

  • Внедренный отчет сводной диаграммы создать за один шаг невозможно. Отчеты сводных диаграмм всегда первоначально располагаются на листах диаграмм. После создания можно изменить положение отчета сводной диаграммы, сделав его внедренным в лист.


 Создание диаграмм из несмежных диапазонов

Создание диаграмм из несмежных диапазонов

  1. Выделите первую группу ячеек, содержащих необходимые данные.

  2. Удерживая клавишу CTRL, выделите необходимые дополнительные группы ячеек.

    Выделенные несмежные диапазоны должны образовывать прямоугольник.

    Несмежные диапазоны обрабатываются как прямоугольное выделение

  3. Нажмите кнопку Мастер диаграмм [image] .

  4. Следуйте инструкциям мастера диаграмм.

Примечание. Описанное выше не относится к отчетам сводных диаграмм.


Способы настройки диаграммы

Предполагаемые действия

Выделение элемента диаграммы, который необходимо изменить

Изменение подписей, заголовков и других текстов диаграммы

Отображение или скрытие подписей значений, таблиц данных, легенд, сеток и осей

Изменение цвета, узора, линий и рамок на диаграмме

Изменение способа отображения данных на диаграмме

Изменение значений, отображаемых на диаграмме

Добавление данных к диаграмме


Организация данных в диаграмме

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Добавление данных к диаграмме

Добавление данных к диаграмме

Наиболее простым способом добавления данных к листу диаграммы является их копирование и вставка из рабочего листа на лист диаграммы.

Наиболее простым способом добавления данных к внедренной диаграмме, построенной на основе непрерывного диапазона, является перетаскивание маркера выделенного цветом диапазона исходных данных диаграммы. Данные к внедренной диаграмме можно добавить также путем их перетаскивания с помощью мыши из рабочего листа в диаграмму. Если внедренная диаграмма создана из несмежных диапазонов, следует использовать процедуры копирования и вставки.

Примечание. Описанное выше не относится к отчетам сводных диаграмм. Использование нескольких источников данных в отчетах сводных диаграмм.

Предполагаемые действия

Добавление данных к диаграмме путем копирования и вставки

Добавление данных к диаграмме путем изменения выделенного цветом диапазона исходных данных

Добавление данных к внедренной диаграмме путем перетаскивания с помощью мыши


 Изменение диапазона ячеек, используемого для создания диаграммы

Изменение диапазона ячеек, используемого для создания диаграммы

  1. Выберите изменяемую диаграмму.

  2. Выберите команду Исходные данные в меню Диаграмма, а затем выберите вкладку Диапазон данных.

  3. Убедитесь, что выделена полностью вся ссылка в поле Диапазон данных.

  4. На рабочем листе выберите ячейки, содержащие данные, которые должны появиться в диаграмме.

    Чтобы название столбца или строки для новых данных появилось в диаграмме, в выбираемые ячейки нужно включить те, которые содержат это название.

Примечание. Описанное выше не относится к отчетам сводных диаграмм. Ознакомьтесь с разделом Использование нескольких источников данных в отчетах сводных диаграмм.


 Защита диаграммы

Защита диаграммы

Защитить диаграмму от изменений можно с помощью команды Защита из меню Сервис.

Если данная диаграмма является внедренной, ее можно защитить также как любой другой графический объект листа. Если диаграмма создана на листе диаграммы, можно защитить этот лист или книгу целиком. Чтобы снять существующую защиту, необходимо знать пароль, если он был задан при установке защиты.

Если не удается изменить диаграмму, возможно установлена защита. Чтобы получить более подробные сведения о защите данных, нажмите кнопку [image] .


 Изменение способа отображения данных на диаграмме

Изменение способа отображения данных на диаграмме

В диаграмме можно изменить порядок, ориентацию листа и размещение рядов данных.

Предполагаемые действия

Построение рядов данных из строк листа вместо столбцов, и наоборот

Отображение рядов данных на вспомогательной оси

Обратный порядок отображения категорий, значений или рядов

Изменение порядка отображения рядов данных

Отображение пустых ячеек на диаграмме

Дополнительные сведения


Изменение элементов, расположенных во вторичных диаграммах

  1. Выберите сектор круга, который нужно изменить.

  2. Выберите команду Выделенный элемент данных в меню Формат, а затем откройте вкладку Параметры.

  3. Укажите необходимые параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Совет. Также путем перемещения можно определить, какие доли диаграммы должны быть выведены во вторичную диаграмму. Выберите часть основной диаграммы, а затем переместите ее во вторичную диаграмму и наоборот.


 Изменение значений, отображаемых на диаграмме

Изменение значений, отображаемых на диаграмме

Значения, отображаемые на диаграмме, связаны с листом, из которого создавалась диаграмма. При изменении данных на листе диаграмма обновляется автоматически.

  1. Откройте лист, содержащий данные, отображенные на диаграмме.

  2. Введите новые данные в ячейки, значения которых необходимо изменить.

  3. Нажмите клавишу ENTER.

Примечание. Данная процедура неприменима к отчету сводных диаграмм. Для изменения значений в отчете сводных диаграмм используйте другие исходные данные.


 Изменение значений, отображаемых на диаграмме, путем перетаскивания маркеров данных и с помощью подбора параметров формул ячеек

Изменение значений, отображаемых на диаграмме, путем перетаскивания маркеров данных и с помощью подбора параметров формул ячеек

Чтобы изменить значения, полученные из формул ячеек листа, в плоских гистограммах, линейчатых, круговых и кольцевых диаграммах, графиках, точечных и пузырьковых диаграммах, перетащите маркер данных в диаграмме и используйте подбор параметров. Когда при перетаскивании маркера данных его значение изменяется, автоматически изменяется и исходное значение на листе.

Чтобы изменить значения, полученные из формул ячеек листа, на объемных поверхностных, лепестковых диаграммах и диаграммах с областями следует использовать подбор параметров на листе. Для получения дополнительных сведений нажмите кнопку [image] .

  1. Выберите ряд данных, содержащий маркер данных, который нужно изменить, а затем выберите сам маркер.

  2. Для пузырьковых графиков, точечных диаграмм и линий перетащите маркер данных с помощью мыши.

    Для линейчатых диаграмм и гистограмм перетащите с помощью мыши верхний центральный маркер выделения.

    Для круговых и кольцевых диаграмм перетащите с помощью мыши наибольший маркер выделения на внешней границе маркера данных.

    Если значение маркера данных получено из формулы, появится диалоговое окно Подбор параметра. Выберите ячейку, значение которой нужно изменить, и нажмите кнопку ОК. Ссылка на эту ячейку отобразится в поле Изменяя значение ячейки. При этом в поле Установить в ячейке отображается ссылка на ячейку, содержащую формулу, а в поле Значение — требуемая величина. При подборе можно изменять только одну ячейку.

Примечание. Описанное выше не относится к отчетам сводных диаграмм.


 Удаление рядов данных

Удаление рядов данных

Чтобы удалить данные с листа и диаграммы одновременно, достаточно удалить их с листа, а диаграмма будет изменена автоматически. Следующая процедура используется для удаления рядов данных только из диаграммы, не удаляя при этом соответствующие данные с листа.

  1. Выберите удаляемые ряды данных.

  2. Нажмите клавишу DELETE.

Примечание. Эта процедура не применима к отчетам сводных диаграмм. Чтобы удалить ряд из отчета сводной диаграммы, можно использовать другой источник данных для отчета сводной диаграммы или скрыть подробные данные для ряда в отчете.


 Отображение только видимых ячеек листа на диаграмме

Отображение только видимых ячеек листа на диаграмме

Иногда может понадобиться скрыть или отобразить некоторые подробности в структуре с промежуточными итогами или отфильтровать данные по особому условию поиска, используя одну из команд Фильтр в меню Данные. Когда данные на листе скрываются, отображаются или фильтруются, соответствующая диаграмма отображает только видимые строки и столбцы.

  1. Выберите нужную диаграмму.

  2. В меню Сервис выберите команду Параметры и перейдите к вкладке Диаграмма.

  3. Установите флажок Отображать только видимые ячейки.

Примечания

  • Для отображения всех данных листа в диаграмме, даже если некоторые ячейки скрыты, следует снять флажок Отображать только видимые ячейки.

  • Описанное выше не относится к отчетам сводных диаграмм.


 Добавление текста к диаграмме

Добавление текста к диаграмме

  1. Выберите диаграмму, к которой нужно добавить текст.

  2. На панели инструментов Рисование нажмите кнопку Надпись [image] .

  3. Выделите на листе область для размещения текста.

  4. Введите необходимый текст (внутри надписи текст будет свернут).

    Чтобы начать новую строку в надписи, нажмите клавишу ENTER.

  5. После завершения ввода текста нажмите клавишу ESC или щелкните мышью за пределами надписи.


 Изменение подписей, заголовков и других текстов диаграммы

Изменение подписей, заголовков и других текстов диаграммы

Большая часть текстов диаграммы — например, подписи делений оси категорий, имена рядов данных, текст легенды и подписи данных — связана с ячейками рабочего листа, используемого для создания диаграммы. Если изменить текст этих элементов на диаграмме, они потеряют связь с ячейками листа. Чтобы сохранить связь, следует изменять текст этих элементов на рабочем листе.

Предполагаемые действия

Изменение подписей делений на оси категорий

Изменение имен рядов данных или текста легенды

Изменение подписей значений

Изменение заголовков диаграммы и осей


Изменение заголовков диаграммы и осей

  1. Выберите изменяемый заголовок.

  2. Введите новый текст.

  3. Нажмите клавишу ENTER.


 Связывание заголовка диаграммы или надписи с ячейкой листа

Связывание заголовка диаграммы или надписи с ячейкой листа

С ячейкой листа можно связать существующий заголовок диаграммы или создать новую надпись, связанную с ячейкой листа.

  1. Выполните одно из следующих действий:

    Для того чтобы связать заголовок, щелкните заголовок.

    Для создания связанной надписи щелкните область диаграммы.

  2. В строке формул введите знак равенства (=).

  3. Выберите ячейку листа, содержащую данные или текст, которые должны отображаться в диаграмме.

    Ссылку на ячейку листа можно также ввести с клавиатуры. В ссылку следует включить имя листа с восклицательным знаком, например:

    Лист1!F2

  4. Нажмите клавишу ENTER.


 Восстановление связей между подписями значений и ячейками листа

Восстановление связей между подписями значений и ячейками листа

При изменении текста подписи значений на диаграмме связь с ячейкой листа теряется.

  1. Выберите маркер данных в ряду данных, соответствующий подписи, связь которой следует восстановить.

  2. Выберите команду Ряды данных в меню Формат, а затем — вкладку Подписи.

  3. Установите флажок Автоматический текст.

Примечания

  • Чтобы восстановить связь между подписями и ячейками листа для всех рядов данных в диаграмме, выберите нужную диаграмму, а затем — команду Параметры в меню Диаграмма. На вкладке Подписи установите флажок Автоматический текст.

  • В результате выполнения описанных действий будут восстановлены связи подписей данных с исходными данными (но не ячейками листа) в отчетах сводных диаграмм.


 Изменение подписей делений на оси категорий

Изменение подписей делений на оси категорий

  • Чтобы изменить подписи делений оси категорий на листе, укажите ячейку, содержащую изменяемую подпись, введите новое значение, а затем нажмите клавишу ENTER.

  • Чтобы изменить подписи делений оси категорий на диаграмме, выберите нужную диаграмму, а затем выберите команду Исходные данные в меню Диаграмма. На вкладке Ряды в поле подписи оси X (категорий) укажите диапазон листа, который нужно использовать как подписи делений оси категорий. Также можно ввести подписи, которые следует использовать, разделяя их запятыми, например:

    Деление A, Деление B, Деление C

    Если в поле подписи оси X (категорий) ввести текст подписи, то он потеряет связь с ячейкой листа.

Примечание°°. Данная процедура не применима к отчетам сводных диаграмм. См. переименование полей и элементов в отчете сводной диаграммы.


 Изменение подписей значений

Изменение подписей значений

  • Чтобы изменить подписи значений на листе, выберите ячейку, содержащую изменяемые данные, введите новый текст или значение и нажмите клавишу ENTER.

  • Чтобы изменить подписи значений на диаграмме, один раз щелкните мышью изменяемую подпись, чтобы выбрать подписи для всего ряда, и щелкните еще раз, чтобы выбрать отдельную подпись значения. Введите новый текст или значение и нажмите клавишу ENTER.

    Если изменить текст подписи значений на диаграмме, то связь с ячейкой листа будет потеряна.

Примечание. Нельзя изменять подписи значений на странице для отчета сводной диаграммы. Однако можно изменять отдельные подписи значений в отчете сводной диаграммы. Изменения подписей значений не остаются в отчете сводной диаграммы при последующем изменении представления диаграммы или связанного отчета сводной таблицы. До изменения подписи значений или других изменений в отчете сводной таблицы убедитесь, что макет отвечает всем требованиям.


 Изменение имен рядов данных или текста легенды

Изменение имен рядов данных или текста легенды

  • Чтобы изменить текст легенды или имя ряда данных на листе, выберите ячейку, содержащую изменяемое имя ряда, введите новое имя и нажмите клавишу ENTER.

  • Чтобы изменить текст легенды или имя ряда данных на диаграмме, выберите нужную диаграмму, а затем выберите команду Исходные данные в меню Диаграмма. На вкладке Ряды выберите изменяемые имена рядов данных. В поле Имя укажите ячейку листа, которую следует использовать как легенду или имя ряда. Также можно просто ввести нужное имя.

    Если в поле Имя ввести имя, то текст легенды или имя ряда потеряют связь с ячейкой листа.

Примечание°°. Данная процедура не применима к отчетам сводных диаграмм. См. переименование полей и элементов в отчете сводной диаграммы.


 Использование дат в диаграммах

Использование дат в диаграммах

Когда диаграмма создается по данным из листа и даты задают ось категорий (x) диаграммы, Microsoft Excel автоматически использует ось времени.

Отображение дат Ось времени отображает даты в хронологическом порядке с определенными интервалами или единицами измерения, даже если даты на листе не упорядочены или имеют другую единицу измерения.

Диаграммы, использующие ось времени

Excel первоначально устанавливает единицу измерения (дни, месяцы или годы) в соответствии с наименьшим расстоянием между двумя датами в данных. Установка единицы измерения может быть изменена, в этом случае диаграмма будет перерисована. Например, если есть данные по ценам акций на бирже с минимальной разницей между датами, равной семи дням, Excel установит единицу измерения равной дням.

Можно изменить единицу измерения на месяцы для оценки поведения биржи за более длительный период, как на первой диаграмме в примере. Для изменения единицы измерения выберите ось, выберите команду Выделенная ось в меню Формат, а затем нужный вариант на вкладке Шкала.

Диаграммы с осью времени и время Диаграмма с осью времени не может быть создана по данным, измеряющим промежутки в часах, минутах и секундах. Только дни, месяцы и годы рассматриваются как единицы измерения в диаграммах с осью времени.

Типы диаграмм, которые могут использовать ось времени Ось времени доступна для биржевых диаграмм, графиков, трехмерных графиков, гистограмм, линейчатых диаграмм и заполненных диаграмм за исключением тех случаев, когда диаграммы имеют многоуровневые названия категорий. Оси времени также недоступны в отчетах сводных диаграмм.

Совет. Невозможно использовать ось времени, если данные появляются в легенде. Можно изменить способ представления данных на диаграмме, чтобы даты вместо этого появлялись на оси категорий.


 Изменение внедренной диаграммы на лист диаграммы и наоборот

Изменение внедренной диаграммы на лист диаграммы и наоборот

  1. Выберите диаграмму, которую необходимо изменить или переместить.

  2. В меню Диаграмма выберите пункт Расположение.

  3. Чтобы поместить диаграмму на новый лист диаграммы, в группе Поместить диаграмму на листе выберите параметр отдельном, а затем укажите имя нового листа диаграммы.

    Для помещения диаграммы в качестве внедренного объекта на лист выберите параметр имеющемся, затем выберите название листа в поле имеющемся, а потом нажмите кнопку OK. Переместите внедренную диаграмму в желаемую позицию на листе.


 Отображение или скрытие подписей значений, таблиц данных, легенд, сеток и осей

Отображение или скрытие подписей значений, таблиц данных, легенд, сеток и осей

Заголовки, сетки, оси, подписи значений, легенды или таблицу данных в диаграмме можно либо вывести на экран, либо скрыть. Некоторые из этих элементов присутствуют только в определенных типах диаграмм. Вывести на экран или скрыть некоторые из этих элементов можно при помощи кнопок на панели инструментов Диаграмма.

Предполагаемые действия

Добавление и изменение элементов диаграммы

Добавление подписей значений

Добавление или изменение заголовка диаграммы или оси

Добавление легенды в диаграмму

Изменение цены деления на оси значений

Отображение и скрытие элементов диаграммы

Отображение или скрытие сетки в диаграмме

Отображение и скрытие осей в диаграмме

Отображение или скрытие таблицы данных в диаграмме

Удаление элементов диаграммы

Удаление подписей значений, заголовков и легенд


Удаление подписей значений, заголовков и легенд

  1. Выберите элемент, который необходимо удалить.

  2. Нажмите клавишу DELETE.


 Отображение и скрытие сведений об элементах диаграммы

Отображение и скрытие сведений об элементах диаграммы

Если поместить курсор на элемент диаграммы, то в окне мастера подсказок появится имя или значение этого элемента.

  1. В меню Сервис выберите команду Параметры и перейдите к вкладке Диаграмма.

  2. Для вывода названия или значения элемента при указании на него курсором установите флажок названия.

    Если необходимо выводить значения маркеров данных при помещении на них курсора, то установите флажок значения.

    Для скрытия всех советов уберите оба флажка.


 Изменение размера листа диаграммы

Изменение размера листа диаграммы

  1. Выберите вкладку для листа диаграммы.

  2. Для приближения или удаления листа диаграммы в меню Вид выберите команду Масштаб, а затем укажите необходимый параметр.

    Для увеличения размера листа диаграммы до размера окна книги в меню Вид выберите команду Во весь экран. Если лист диаграммы увеличен до размера окна, его нельзя приблизить или удалить.


Просмотр внедренных диаграмм в отдельном окне

  1. Выберите внедренную диаграмму, которая должна быть выведена в отдельном окне.

  2. В меню Вид выберите команду Окно диаграммы.


 Изменение типа диаграммы

Изменение типа диаграммы

Для большинства плоских диаграмм можно изменить тип диаграммы как ряда данных, так и диаграммы в целом. Для пузырьковых диаграмм можно изменить только тип диаграммы в целом. Для большинства объемных диаграмм изменение типа затрагивает всю диаграмму. Для объемных линейчатых диаграмм и гистограмм есть возможность преобразовывать отдельные ряды данных к конусному, цилиндрическому или пирамидальному типу.

  1. Выполните одно из следующих действий:

    Для того чтобы изменить тип диаграммы в целом, щелкните диаграмму.

    Для того чтобы изменить типа ряда данных, щелкните ряд данных.

  2. Выберите в меню Диаграмма команду Тип диаграммы.

  3. Щелкните нужный тип диаграммы на вкладке Стандартные или Нестандартные.

    Для того чтобы применить конический, цилиндрический или пирамидальный тип к ряду данных объемной линейчатой диаграммы или гистограммы, щелкните Цилиндрическая, Коническая или Пирамидальная в поле Тип на вкладке Стандартные, а затем установите флажок Применить.

Примечания

  • Если флажок Применить снят, Microsoft Excel изменяет тип диаграммы в целом, даже если выделен один ряд данных.

  • Преобразовать отчет сводной диаграммы в точечную, пузырьковую или биржевую диаграмму невозможно.

  • Изменение типа диаграммы для отдельного ряда данных не сохраняется в отчетах сводных диаграмм при последующем изменении представления диаграммы или связанного отчета сводной таблицы. Прежде чем изменять тип диаграммы для одного или нескольких отдельных рядов данных в отчете сводной диаграммы, убедитесь, что макет отвечает всем требованиям.


Примеры диаграмм различных типов

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Использование комбинированных диаграмм для отображения смешанных данных

Комбинированные диаграммы Комбинированная диаграмма использует два или более типа диаграмм, чтобы подчеркнуть использование различных типов информации. Приведенная выше диаграмма показывает один ряд данных («План») на гистограмме, а другой («Факт.») — в виде графика. Чтобы получить такой тип эффекта перекрытия, выберите нестандартный тип диаграмм на шаге 1 мастера диаграмм. Инструкции по созданию диаграммы. Этот пример использует тип диаграммы «График|Гистограмма». Чтобы превратить существующую диаграмму в комбинированную, выберите ряд данных и измените тип диаграммы для этого ряда.

Комбинированная диаграмма со вспомогательными осями

Вспомогательная ось. Если значения различных рядов данных на диаграмме значительно отличаются друг от друга или если на диаграмме представлены данные различных типов, целесообразно вывести один или несколько рядов данных на вспомогательной оси значений (Y). Масштаб вспомогательной оси выбирается с учетом значений соответствующего ряда. В приведенном выше примере диаграммы по левой оси Y откладывается число продаж жилья, а по правой — средняя цена.


Создание собственных типов диаграмм

При создании диаграммы или изменении типа диаграммы можно выбирать между стандартными и нестандартными типами диаграмм. При необходимости использовать нестандартный тип диаграммы можно выбрать встроенный нестандартный тип диаграммы или создать свой собственный.

Встроенные нестандартные типы диаграмм Microsoft Excel поставляется с несколькими встроенными типами диаграмм, которые основаны на стандартных типах, но включают дополнительное форматирование и параметры (например легенда, сетка, подписи данных, вспомогательные оси, цвета, шаблоны, заливки и места расположения различных элементов диаграммы). Эти типы диаграмм могут быть найдены на вкладке Нестандартные в диалоговом окне Тип диаграммы. Выбор другого типа диаграммы.

Создание собственных типов диаграмм Имеется также возможность создать собственные нестандартные типы диаграмм, изменяя любой из типов диаграмм, предоставляемых Excel. Эти нестандартные типы диаграмм можно использовать совместно с другими пользователями. Например, если один и тот же заголовок должен появляться во всех диаграммах, формируемых в компании, можно создать диаграмму с этим заголовком, сохранить диаграмму как нестандартный тип диаграммы, определенный пользователем, а затем открыть доступ сотрудникам компании для использования в качестве шаблона.

Примечание. Нестандартные типы диаграмм хранятся в книгах. Встроенные нестандартные типы диаграмм хранятся в файле Xl8galry.xls. При добавлении собственных нестандартных типов диаграмм Excel хранит их в файле Xlusrgal.xls.


Сохранение нестандартного типа диаграммы для использования в других диаграммах

  1. Выберите диаграмму, которую необходимо сохранить в качестве нестандартного типа диаграммы.

  2. В меню Диаграмма выберите пункт Тип диаграммы.

  3. На вкладке Нестандартные выберите команду дополнительные.

  4. Нажмите кнопку Добавить.

  5. В поле Имя введите нужное имя.

    Если необходимо добавить описание, то введите его в поле Описание.

  6. Нажмите кнопку OK.


Совместное использование нестандартного типа диаграммы несколькими пользователями

  1. На компьютере каждого пользователя откройте книгу, содержащую нестандартный тип диаграммы, к которому необходим совместный доступ.

  2. Добавьте необходимый нестандартный тип диаграммы как новый нестандартный тип диаграммы.

    Инструкции


Удаление нестандартного типа диаграммы, определенной пользователем

Встроенный нестандартный тип диаграммы удалить невозможно.

  1. Чтобы активизировать меню Диаграмма, выберите диаграмму.

  2. В меню Диаграмма выберите пункт Тип диаграммы.

  3. На вкладке Нестандартные выберите команду дополнительные.

  4. В поле Тип диаграммы выберите формат, который необходимо удалить.

  5. Выберите команду Удалить, а затем нажмите кнопку OK.


 Изменение типа диаграммы, установленного по умолчанию

Изменение типа диаграммы, установленного по умолчанию

Стандартным типом диаграммы в Microsoft Excel установлена гистограмма. Для отчета сводной диаграммы по умолчанию установлена гистограмма с наполнением. При регулярном создании диаграмм другого типа, например линейных, можно изменить тип диаграммы, используемый по умолчанию. Если уже существует диаграмма требуемого типа, с необходимыми элементами и форматированием, можно использовать эту диаграмму в качестве стандартного типа диаграммы.

Предполагаемые действия.

Изменение типа диаграммы, установленного по умолчанию

Использование выбранной диаграммы в качестве типа диаграммы по умолчанию


Форматирование диаграмм

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Выбор элементов диаграммы

Выбор элементов диаграммы

  • Чтобы выбрать элемент диаграммы с помощью мыши, выполните одно из следующих действий.
    • Выберите нужный элемент диаграммы. Ряды данных, подписи значений и легенды можно изменять поэлементно. Например, чтобы выбрать отдельный маркер данных в ряде данных, выберите нужный ряд данных и укажите маркер данных. Имя элемента диаграммы будет выводится в подсказке в случае, если установлен флажок Показывать имена (меню Сервис, команда Параметры, вкладка Диаграмма).

    • Выберите нужную диаграмму, щелкните мышью стрелку рядом с полем Объекты диаграмм [image] на панели инструментов Диаграмма, а затем выберите нужный элемент.
  • Чтобы выбрать элемент диаграммы с помощью клавиатуры, пользуйтесь клавишами со стрелками.

  • Чтобы отменить сделанный выбор, нажмите клавишу ESC.


 Перемещение и изменение размеров диаграммы и ее элементов с помощью мыши

Перемещение и изменение размеров диаграммы и ее элементов с помощью мыши

Мышь можно использовать для изменения размеров и перемещения области диаграммы, области построения и легенды в большинстве диаграмм. Размер названий изменяется автоматически в соответствии с текстом. Названия можно переместить, но нельзя изменить их размер с помощью мыши.

  1. Выберите элемент диаграммы, который необходимо изменить или переместить.

  2. Чтобы переместить данный элемент, выделите его и перетащите с помощью мыши в нужное положение.

    Перемещение элемента диаграммы

    Чтобы изменить размер элемента диаграммы, установите указатель на маркер изменения размера. Указатель примет форму двухсторонней стрелки. Нажмите кнопку мыши и перетащите указатель для получения необходимого размера.

    Изменение размера элемента диаграммы

Примечания

  • Невозможно передвинуть сектор в круговой или кольцевой диаграмме и переместить или изменить размер маркеров данных с помощью мыши.

  • С помощью мыши нельзя переместить или изменить размер легенды, названий осей, заголовка диаграммы и области построения в отчете сводной диаграммы.


 Изменение цвета, узора, линий и рамок на диаграмме

Изменение цвета, узора, линий и рамок на диаграмме

Следующая процедура используется для изменения цветов, узора, ширины линии или типа рамки для маркеров данных, области диаграммы, области построения, сетки, осей и подписей делений на плоских и объемных диаграммах, линиях тренда и планках погрешностей на плоских диаграммах, а также стенках и основаниях на объемных диаграммах.

  1. Дважды щелкните изменяемый элемент диаграммы.

  2. При необходимости выберите вкладку Узор и укажите нужные параметры.

    Для указания эффекта заливки выберите команду Способы заливки, а затем укажите нужные параметры на вкладках Градиентная, Текстура и Узор. Для получения дополнительных сведений о добавлении рисунка к элементу диаграммы нажмите кнопку [image] .

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечания

  • Форматирование оси отражается и на метках делений этой оси. Линии сетки форматируются независимо от осей.

  • В отчете сводной диаграммы параметры форматирования и другие изменения, применяемые к рядам данных, не сохраняются при последующем изменении представления диаграммы или связанного отчета сводной таблицы. Перед изменением параметров форматирования в отчете сводной диаграммы необходимо выбрать требуемый макет диаграммы.


 Изменение размера, цвета или формы маркеров данных на графике, точечной или лепестковой диаграммах

Изменение размера, цвета или формы маркеров данных на графике, точечной или лепестковой диаграммах

  1. Выделите линию с изменяемыми маркерами данных.

  2. Выберите команду Выделенный ряд в меню Формат, а затем — вкладку Узор.

  3. Укажите нужные параметры в группе Маркер.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечание. В отчете сводной диаграммы форматирование и другие изменения рядов данных не сохраняются при последующем изменении представления диаграммы или связанного отчета сводной таблицы. До изменения ряда данных в отчете сводных таблиц убедитесь, что макет соответствует необходимым требованиям.


 Изменение цвета в поверхностной диаграмме

Изменение цвета в поверхностной диаграмме

Для изменения цветов уровней в поверхностной диаграмме следует изменить ключ легенды.

  1. Добавьте к диаграмме легенду, если таковой нет.

    Инструкции

  2. Выберите легенду, а затем — ключ легенды, соответствующий изменяемому уровню поверхности.

  3. В меню Формат выберите команду Ключ легенды, а затем — вкладку Узор.

  4. Выберите нужный цвет и повторите шаги 2 и 3 для каждого форматируемого уровня.

Примечания

  • Чтобы удалить легенду, выделите ее и нажмите клавишу DELETE. После удаления легенды указанные цвета останутся в поверхностной диаграмме.

  • В отчете сводной диаграммы параметры форматирования и другие изменения, применяемые к рядам данных, не сохраняются при последующем изменении вида диаграммы или связанного отчета сводной таблицы. Перед изменением параметров форматирования в отчете сводной диаграммы необходимо выбрать требуемый вид диаграммы.


 Использование разных цветов для маркеров одного ряда данных

Использование разных цветов для маркеров одного ряда данных

Можно окрасить в разные цвета маркеры данных внутри одного ряда данных кольцевых диаграмм и диаграмм, построенных по единственному ряду данных. Сектора в круговых и кольцевых диаграммах имеют разные цвета по умолчанию.

  1. Выберите ряд данных, для которого нужно изменить цвет маркера.

  2. В меню Формат выберите команду Выделенный ряд или Точки данных, а затем — вкладку Параметры.

  3. Установите флажок Разноцветные точки или Разноцветные дольки.

Примечание°°. В отчете сводной диаграммы форматирование и другие изменения данных ряда не сохраняются при последующем изменении представления диаграммы или связанного отчета сводной таблицы. До изменения ряда данных в отчете сводных таблиц убедитесь, что макет соответствует необходимым требованиям.


 Изменение размера области построения вторичной диаграммы

Изменение размера области построения вторичной диаграммы

  1. Выберите изменяемые ряды данных на круговой диаграмме.

  2. Выберите команду Ряды данных в меню Формат, а затем — вкладку Параметры.

  3. В поле Размер второй части введите значение от 5 до 200, соответствующее нужному размеру второго круга или полосы, в процентах от размера первой части диаграммы. Например, 105 делает вторичный круг или полосу на 5 процентов больше, чем основная диаграмма.


 Изменение диаметра отверстия кольцевой диаграммы

Изменение диаметра отверстия кольцевой диаграммы

  1. Выберите изменяемые ряды данных на кольцевой диаграмме.

  2. Выберите команду Ряды данных в меню Формат, а затем — вкладку Параметры.

  3. Введите в поле Диаметр отверстия, в % от общего диаметра любое значение от 10 до 90, соответствующее нужному диаметру отверстия.


 Сглаживание линий на графиках

Сглаживание линий на графиках

Сглаживание линий на графике на сами данные никак не влияет.

  1. Выберите ряд данных на графике, который нужно сгладить.

  2. Выберите команду Выделенный ряд в меню Формат, а затем — вкладку Вид.

  3. Установите флажок Сглаженная линия.

Примечание°°. В отчете сводной диаграммы форматирование и другие изменения рядов данных не сохраняются при последующем изменении представления диаграммы или связанного отчета сводной таблицы. До изменения ряда данных в отчете сводных таблиц убедитесь, что макет соответствует необходимым требованиям.


 Добавление к диаграмме полос повышения и понижения, линий проекции, линий рядов и коридора колебания

Добавление к диаграмме полос повышения и понижения, линий проекции, линий рядов и коридора колебания

При отображении рядов данных на двумерных линейчатых диаграммах и гистограммах с накоплением удобно добавить линии рядов. Линии проекции используются на плоских и объемных диаграммах с областями и графиках для определения соответствия между значениями данных и делениями осей. Коридор изменения и полосы повышения и понижения могут быть использованы на двумерных графиках. Полосы повышения и понижения и коридор колебания берут свое начало от биржевых диаграмм, для которых являются стандартными и отображаются по умолчанию.

Для добавления этих линий и маркеров ко всем рядам данных одного и того же типа диаграммы достаточно выбрать один ряд данных.

  1. Выберите на диаграмме ряд данных, к которому нужно добавить маркеры или линии.

  2. Выберите команду Ряды данных в меню Формат, а затем — вкладку Параметры.

  3. Укажите параметры для типа линий или маркеров.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.


 Использование рисунков в диаграммах

Использование рисунков в диаграммах

Следующая процедура используется для добавления рисунка — например, точечного — к определенным типам маркеров данных, области диаграммы, области построения или легенде на плоских и объемных диаграммах, а также к стенкам и основанию на объемных диаграммах.

Данная процедура позволяет добавить рисунок к маркерам данных на гистограмме, линейчатой диаграмме, заполненной диаграмме, пузырьковой диаграмме, объемном графике и заполненной лепестковой диаграмме.

  1. Выберите элемент диаграммы, к которому нужно добавить рисунок.

  2. Нажмите на стрелку рядом с кнопкой Цвет заливки [image] , выберите Способы заливки, а затем — вкладку Рисунок.

  3. Чтобы указать нужный рисунок, нажмите кнопку Выбор рисунка.

  4. В поле Папка выберите диск, папку или адрес Интернета, где находится нужный рисунок, а затем дважды щелкните его.

  5. Укажите нужные параметры на вкладке Рисунок.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечания

  • Команда Способы заливки недоступна для графика, точечной или незаполненной лепестковой диаграммы. Чтобы использовать рисунок в качестве маркера данных в этих типах диаграмм, выберите рисунок на рабочем листе, листе диаграммы или в программе редактирования рисунков, выберите команду Копировать (в меню Правка), укажите ряд данных и выберите команду Вставить (в меню Правка).

  • В отчете сводной диаграммы параметры форматирования и другие изменения, применяемые к рядам данных, не сохраняются при последующем изменении представления диаграммы или связанного отчета сводной таблицы. Перед изменением параметров форматирования в отчете сводной диаграммы необходимо выбрать требуемый вид диаграммы.


 Удаление рисунка или заливки из ряда данных

Удаление рисунка или заливки из ряда данных

При использовании данной процедуры для удаления рисунка или заливки из рядов данных автоматически удаляются все форматы, применявшиеся с использованием вкладки Узор (меню Формат, команда Ряды данных).

  1. Выберите изменяемые ряды данных..

  2. В меню Правка установите указатель мыши на команду Очистить, а затем выберите команду Форматы.


 Удаление рисунка или заливки из элемента диаграммы

Удаление рисунка или заливки из элемента диаграммы

Данная процедура используется для удаления рисунка или заливки из области диаграммы, области построения или легенды на плоских и объемных диаграммах, а также стенок и основания на объемных диаграммах.

  1. Дважды щелкните мышью изменяемый элемент диаграммы и выберите вкладку Узор.

  2. Чтобы удалить рисунок или заливку и вернуть объекту исходный формат, выберите под пунктом Заливка параметр Автоматическая.

    Чтобы удалить все форматы, включая рисунок или заливку, под пунктом Заливка выберите параметр Нет.


 Изменение шрифта и выравнивание текста на диаграмме

Изменение шрифта и выравнивание текста на диаграмме

Если название диаграммы или надпись связаны с ячейками листа, форматировать их можно только целиком. Отдельные символы текста в этом случае форматировать нельзя.

  1. Щелкните текст диаграммы или выберите отдельные символы, которые требуется отформатировать.

    Для того чтобы изменить форматирование сразу всего текста диаграммы, щелкните в любом месте между рамкой диаграммы и областью построения, чтобы выбрать область диаграммы.

  2. На панели инструментов Форматирование нажмите нужную кнопку.
    Цель | Действие
    Изменение шрифта | Выберите нужный шрифт в поле со списком Шрифт
    Изменение размера шрифта | Выберите нужный размер шрифта в поле со списком Размер шрифта
    Жирный текст | Нажмите кнопку Ж на панели форматирования
    Выделение текста курсивом | Нажмите кнопку К на панели форматирования
    Подчеркивание текста | Нажмите кнопку Ч на панели форматирования
    Изменение цвета шрифта | Щелкните стрелку рядом с кнопкой Цвет шрифта [image] , а затем выберите нужный цвет на палитре

Примечания

  • Чтобы получить доступ к другим параметрам шрифта, таким как верхний и нижний индекс, следует выбрать изменяемый текст и в меню Формат выбрать команду для форматируемого элемента диаграммы — например, Выделенная ось или Выделенный объект. (Название команды зависит от выбранного элемента диаграммы.) Затем нужно указать необходимые параметры на вкладке Шрифт.

  • В отчете сводной диаграммы параметры форматирования и другие изменения, применяемые к отдельным рядам данных, элементам данных и подписям данных, не сохраняются при последующем изменении вида диаграммы или связанного отчета сводной таблицы. Перед изменением параметров форматирования в отчете сводной диаграммы необходимо выбрать требуемый вид диаграммы.


 Выравнивание текста на диаграмме

Выравнивание текста на диаграмме

  1. Выберите название или границу текста, который нужно выровнять.

  2. При указании названия оси выберите команду Название оси в меню Формат.

    При указании названия диаграммы выберите команду Название диаграммы в меню Формат.

    При указании текста выберите команду Выделенный объект в меню Формат.

  3. Выберите вкладку Выравнивание.

    Если вкладки Выравнивание нет на экране, нажмите кнопку Отмена, щелкните мышью место вне форматируемого текста и повторите шаги 1-3.

  4. Укажите необходимые параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Совет. Чтобы быстро изменить выравнивание по горизонтали выделенного текста, следует нажать кнопку По левому краю [image] , По центру [image] или По правому краю [image] на панели инструментов Форматирование.


 Изменение положения текста в названии диаграммы или на оси

Изменение положения текста в названии диаграммы или на оси

Текст названия диаграммы или текст на оси можно «вращать». Однако текст легенды «вращать» нельзя.

  1. Щелкните ось или название, которое требуется отформатировать.

  2. Если выделена ось, выберите в меню Формат команду Выделенная ось.

    Если выделено название оси, выберите в меню Формат команду Выделенное название оси.

    Если выделено название диаграммы, выберите в меню Формат команду Выделенное название диаграммы.

  3. Перейдите на вкладку Выравнивание.

    Если вкладки Выравнивание нет на экране, нажмите кнопку Отмена, щелкните мышью за пределами форматируемого текста и повторите шаги 1-3.

  4. Для того чтобы повернуть текст, щелкните маркер нужного угла в поле Ориентация или перетащите маркер в нужное положение.

Примечание. При наличии более одного уровня подписей оси категорий повернуть можно только первый уровень (ближайший к оси).

Совет. Для того чтобы быстро перевернуть выделенный текст на 45 градусов в ту или другую сторону, нажмите кнопку Текст снизу вверх [image] или Текст сверху вниз [image] на панели инструментов Диаграммы.


 Изменение формата чисел в диаграммах

Изменение формата чисел в диаграммах

При изменении формата чисел на диаграмме теряется связь с ячейками листа. Инструкции по восстановлению связей между форматами чисел на листе и в диаграммах.

  1. Чтобы изменить формат подписи значений, дважды щелкните нужную ось.

    Чтобы изменить формат подписи значений или подписи линий тренда, дважды щелкните соответствующий элемент.

  2. На вкладке Число выберите нужные параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Совет. Если значения оси являются большими числами, можно сделать текст короче и более читаемым с помощью изменения отображения единиц измерения. Например, если значения оси лежат от 1 000 000 до 50 000 000, можно написать числа от 1 до 50 на оси и указать, что единицы измерения — миллионы.

Примечание. В отчете сводной диаграммы форматирование и другие изменения подписей данных ряда или подписей линий тренда не сохраняются при последующем изменении представления диаграммы или связанного отчета сводной таблицы. До изменения подписей данных или подписей линий тренда в отчете сводных таблиц убедитесь, что макет отвечает необходимым требованиям.


 Автоматическое изменение расположения подписей значений

Автоматическое изменение расположения подписей значений

Изменить расположение отдельной подписи значений можно путем ее перетаскивания. Данная процедура используется для помещения всех подписей для рядов данных в стандартное положение на соответствующих маркерах данных на плоских линейчатых диаграммах, гистограммах и графиках; плоских и объемных круговых диаграммах, а также на точечной и кольцевой диаграммах.

  1. Щелкните диаграмму за пределами подписи значений, которую требуется изменить.

  2. Щелкните одну из подписей значений в ряде, который требуется изменить.

  3. Выберите в меню Формат команду Выделенные подписи данных и перейдите на вкладку Выравнивание.

  4. Выберите нужное расположение в поле Положение подписи.

Примечание.°° В отчете сводной диаграммы форматирование и другие изменения подписей данных на отдельных рядах не сохраняются при последующем изменении представления диаграммы или связанного отчета сводной таблицы. Прежде чем изменять подписи данных в отчете сводных таблиц, убедитесь, что макет отвечает необходимым требованиям.


 Перекрывание или зазоры между маркерами данных на круговой и кольцевой диаграммах

Перекрывание или зазоры между маркерами данных на круговой и кольцевой диаграммах

Достаточно выбрать один ряд данных, чтобы изменить степень перекрывания или ширину зазора между всеми рядами данных одного типа диаграммы.

  1. Выберите на диаграмме изменяемый ряд данных.

  2. Выберите команду Ряды данных в меню Формат, а затем — вкладку Параметры.

  3. Чтобы изменить степень перекрывания маркера данных для каждой группы, введите в поле Перекрытие число в диапазоне от -100 до 100. Чем больше введенное значение, тем сильнее перекрываются маркеры в пределах данной группы.

  4. Чтобы изменить промежуток между группами маркеров, введите в поле Ширина зазора число в диапазоне от 0 до 500. Чем больше введенное значение, тем больше расстояние между группами.


 Отделение секторов на круговой и кольцевой диаграммах

Отделение секторов на круговой и кольцевой диаграммах

На кольцевой диаграмме можно отделить только сектора внешнего круга.

  • Чтобы отделить друг от друга все сектора в круговой диаграмме, выберите круг и, удерживая нажатой клавишу мыши, перетащите его от центра диаграммы.

    Чтобы отделить один сектор круговой диаграммы, выберите круг, отделяемый сектор и, удерживая нажатой клавишу мыши, перетащите его от центра диаграммы в нужное положение.

  • Чтобы отделить друг от друга все сектора внешнего круга кольцевой диаграммы, выделите внешний круг и перетащите его от центра диаграммы.

    Чтобы отделить один сектор внешнего круга кольцевой диаграммы, выделите внешний круг, отделяемый сектор и, удерживая нажатой клавишу мыши, перетащите его от центра диаграммы в нужное положение.

Примечание°°. В отчете сводной диаграммы форматирование и другие изменения данных ряда не сохраняются при последующем изменении представления диаграммы или связанного отчета сводной таблицы. До изменения ряда данных в отчете сводных таблиц убедитесь, что макет соответствует необходимым требованиям.


 Изменение угла для первого сектора на круговой и кольцевой диаграммах

Изменение угла для первого сектора на круговой и кольцевой диаграммах

Порядок отображения рядов данных в круговой и кольцевой диаграммах определяется порядком данных на листе. Следующая процедура используется для " вращения" секторов в пределах 360 градусов по кругу на круговой и кольцевой диаграммах.

  1. Выберите изменяемый ряд данных на круговой и кольцевой диаграммах.

  2. Выберите команду Ряды данных в меню Формат, а затем — вкладку Параметры.

  3. В поле Угол поворота первого сектора введите число от 0 до 360, чтобы установить угол, задающий положение первого сектора.


 Изменение выравнивания и интервалов в многоуровневых подписях категорий

Изменение выравнивания и интервалов в многоуровневых подписях категорий

При наличии многоуровневых подписей категорий на диаграмме можно изменить выравнивание для всех уровней, кроме первого. Также можно изменить расстояние между каждым уровнем подписей.

  1. Выберите изменяемую ось категорий.

  2. Выберите команду Автоформат в меню Формат, а затем — вкладку Узор.

  3. Для изменения выравнивания подписи выберите мышью необходимую позицию на вкладке Выравнивание.

    Для изменения расстояния между уровнями выберите значение во вкладке Смещение. Большее значение соответствует большему расстоянию между уровнями.


 Изменение масштаба числовой оси

Изменение масштаба числовой оси

Масштаб определяет диапазон значений на оси, интервалы между делениями и место пересечения осей.

  1. Выберите изменяемую числовую ось.

  2. Выберите команду Выделенная Ось в меню Формат, а затем — вкладку Шкала.

  3. Укажите необходимые параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Советы

  • Чтобы поменять порядок столбцов на гистограммах, установите флажок Обратный порядок значений.

  • Если значения оси являются большими числами, можно сделать текст короче и более читаемым, меняя цену деления. Например, если значения данных лежат в диапазоне от 1 000 000 до 50 000 000, то можно написать на оси числа от 1 до 50 и указать, что единицы измерения — миллионы.


 Изменение расстояния между метками и подписями делений на оси категорий

Изменение расстояния между метками и подписями делений на оси категорий

Каждая категория на оси категорий обозначается подписью и отделяется от других категорий метками делений. Расстояние между метками и подписями делений может быть изменено. Для плоских диаграмм можно указать место пересечения оси значений y с осью категорий x.

  1. Выберите изменяемую ось категорий.

  2. Выберите команду Выделенная Ось в меню Формат, а затем — вкладку Шкала.

  3. Укажите необходимые параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечание. При наличии более чем одного уровня подписей категорий нельзя изменять количество категорий между метками делений и место пересечения осью значений (у) оси категорий.

Советы

  • При наличии более одного уровня подписей категорий можно изменить расстояние, или смещение, между уровнями.

  • Чтобы границы области диаграммы соединились с границами области построения, снимите флажок Пересечение с осью Y (значений) между категориями.


Изменение цены деления оси значений

Если числа на оси диаграммы велики, можно сделать текст короче и более читаемым, меняя цену деления оси. Например, если значения лежат в диапазоне от 1 000 000 до 50 000 000, можно отображать числа от 1 до 50 и указывать, что единицы измерения — миллионы.

  1. Выберите ось значений, которую необходимо изменить.

  2. Выберите команду Выделенная Ось в меню Формат, а затем — вкладку Шкала.

  3. В списке Цена деления выберите величину деления или введите числовое значение.

  4. Чтобы отобразить подпись единицы измерения, усановите флажок Отображать на диаграмме.


 Изменение вида и расположения подписей делений оси

Изменение вида и расположения подписей делений оси

  1. Выберите ось, подписи делений которой нужно изменить.

  2. Выберите команду Ось в меню Формат, а затем — вкладку Узор.

  3. Выберите соответствующие параметры для типов делений и подписей делений .

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Советы

  • Чтобы скрыть все подписи делений, установите флажок Нет.

  • Если используется несколько уровней подписей оси категорий, можно изменить промежутки между уровнями и выравнивание всех уровней, кроме первого.


 Изменение глубины и ширины объемной диаграммы

Изменение глубины и ширины объемной диаграммы

Глубина устанавливается на объемных диаграммах, имеющих оси, кроме этого, на объемных диаграммах с перспективой можно задать глубину зазора, а на объемных линейчатых диаграммах и гистограммах - ширину зазора.

  1. Выберите изменяемые ряды данных на объемной диаграмме.

  2. Выберите команду Ряды данных в меню Формат, а затем — вкладку Параметры.

  3. Укажите необходимые параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.


Изменение высоты и перспективы объемной диаграммы

В зависимости от типа диаграммы и выбранных параметров можно изменить высоту и перспективу объемной диаграммы.

  1. Выберите изменяемую объемную диаграмму.

  2. Выберите команду Объемный вид в меню Диаграмма.

  3. Укажите необходимые параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечания

  • Если флажок Перпендикулярные оси снят, то можно задать параметры Перспектива и Высота.

  • Если флажок Перпендикулярные оси установлен, то можно либо задать параметр Высота, либо установить флажок Автомасштаб.

  • Параметр Перспектива недоступен на объемных диаграммах, в которых всегда установлен флажок Перпендикулярные оси.


Изменение глубины и ширины объемной диаграммы

  1. Выберите изменяемую объемную диаграмму.

  2. Выберите команду Объемный вид в меню Диаграмма.

  3. Укажите необходимые параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечание. Чтобы изменить угол поворота диаграммы с помощью мыши, выберите пересечение любых двух осей или углы диаграммы и перетащите любой из выделенных углов, чтобы задать возвышение и угол поворота диаграммы. Чтобы сделать видимыми маркеры, удерживайте нажатой клавишу CTRL.


Форматирование элементов и изменение перспективы объемной диаграммы

В зависимости от имеющегося типа объемной диаграммы можно изменить некоторые параметры этой диаграммы.

Предполагаемые действия

Изменение высоты и перспективы объемной диаграммы

Изменение глубины и ширины объемной диаграммы

Изменение глубины и ширины объемной диаграммы

Изменение ориентации рядов данных таким образом, чтобы большие объемные маркеры не перекрывали меньшие маркеры


 Планки погрешностей в диаграммах

Планки погрешностей в диаграммах

Планки погрешностей графически выражают возможную ошибку, соответствующую каждому значению из ряда данных. Например, можно показать 5-процентную положительную и отрицательную ошибку в результатах научного эксперимента:

Диаграмма с планками погрешностей

Типы диаграмм, поддерживающие планки погрешностей Планки погрешностей могут быть добавлены к рядам данных в плоских диаграммах с областями, гистограммах, линейчатых диаграммах, графиках, точечных и пузырьковых диаграммах. На точечных и пузырьковых диаграммах планки погрешности можно изобразить для значений X и Y по отдельности или одновременно.

Примечание. Планки погрешностей не поддерживаются в отчетах сводных диаграмм, если впоследствии изменяется вид диаграммы или связанный отчет сводной таблицы. Перед добавлением планок погрешностей или другим форматированием отчета сводной диаграммы убедитесь в том, что макет диаграммы удовлетворяет всем требованиям.

Дополнительные сведения

Добавление планок погрешностей к рядам данных

Формулы для расчета погрешности


 Добавление планок погрешностей к рядам данных

Добавление планок погрешностей к рядам данных

  1. Выберите ряд данных, к которому нужно добавить планки погрешностей.

  2. Выберите команду Ряды данных в меню Формат.

  3. На вкладке X-погрешности или Y-погрешности выберите нужные параметры.

Примечания

  • Если в значения или формулы на листе, связанные с данным ряда, будут внесены изменения, то эти изменения отразятся на размере планок погрешностей.

  • Планки погрешностей не сохраняются в отчетах сводных диаграмм, если впоследствии изменяется представление диаграммы или связанный отчет сводной таблицы. Перед добавлением планок погрешностей или другим форматированием отчета сводной диаграммы убедитесь в том, что макет диаграммы удовлетворяет всем требованиям.


 Форматирование планок погрешностей

Форматирование планок погрешностей

Если выделить на диаграмме одну планку погрешности и внести в нее какие-либо изменения, то эти изменения отразятся на внешнем виде планок погрешностей для всех значений ряда данных.

  1. Выберите ряд данных, планки погрешностей которого требуется изменить.

  2. Выберите команду Выделенный ряд в меню Формат.

  3. Перейдите на вкладку Y-погрешности или X-погрешности, в зависимости от типа планок погрешностей, которые требуется изменить.

    Для того чтобы изменить вид планки погрешности, щелкните нужный тип в группе Показать планки погрешностей.

    Для того чтобы изменить способ, используемый для определения величины погрешности, установите в необходимое положение переключатель Величина погрешности. Чтобы применить нестандартный способ, установите переключатель в положение Пользовательская. В полях + и - укажите диапазон ячеек, содержащих величины погрешностей, или введите нужные значения через точку с запятой, например 0,4; 0,3; 0,8.

Примечание. Планки погрешностей и их настройки не сохраняются в отчетах сводных диаграмм, если впоследствии изменяется вид диаграммы или связанный отчет сводной таблицы. Перед добавлением или изменением планок погрешностей или других элементов форматирования отчета сводной диаграммы убедитесь в том, что макет диаграммы удовлетворяет всем требованиям.


 Удаление планок погрешностей

Удаление планок погрешностей

Нельзя удалить отдельную планку погрешностей. При удалении одной планки погрешностей удаляются все планки погрешностей для всего ряда данных.

  1. Выберите любую планку погрешностей.

  2. Нажмите клавишу DELETE.


Формулы для расчета погрешности

Стандартное отклонение

где:

s = номер ряда,

i = номер точки в ряду s,

m = номер ряда для точки y на диаграмме,

n = количество точек в каждом ряду,

Переменная = значение i-ой точки в ряду s,

Переменная = общее количество значений во всех рядах,

M = арифметическое среднее

Стандартная погрешность


 Линии тренда на диаграмме

Линии тренда на диаграмме

Линии тренда позволяют графически отображать тенденции данных и прогнозировать данные. Подобный анализ называется также регрессионный анализ. Используя регрессионный анализ, можно продлить линию тренда в диаграмме за пределы реальных данных для предсказания будущих значений. Например, приведенная ниже диаграмма использует простую линейную линию тренда, которая является прогнозом на четыре квартала вперед, для демонстрации тенденции увеличения дохода.

Диаграмма с линейной линией тренда

Скользящее среднее Можно вычислить скользящее среднее, которое сглаживает отклонения в данных и более четко показывает форму линии тренда.

Типы диаграмм, поддерживающие линии тренда Линиями тренда можно дополнить ряды данных, представленные на ненормированных плоских диаграммах с областями, линейчатых диаграммах, гистограммах, графиках, биржевых, точечных и пузырьковых диаграммах. Нельзя дополнить линиями тренда ряды данных на объемных диаграммах, нормированных диаграммах, лепестковых диаграммах, круговых и кольцевых диаграммах. При замене типа диаграммы на один из вышеперечисленных — например, изменении типа диаграммы на объемную диаграмму или изменении представления отчета сводной диаграммы или связанного отчета сводной таблицы — линии тренда, соответствующие данным, будут потеряны.

Создание линии тренда без диаграммы Использование автозаполнения или одной из статистических функций, например РОСТ или ТЕНДЕНЦИЯ

Дополнительные сведения

Выбор наиболее подходящей линии тренда для данных

Формулы для расчета линий тренда

Добавление линии тренда к рядам данных


Выбор наиболее подходящей линии тренда для данных

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Добавление линии тренда к рядам данных

Добавление линии тренда к рядам данных

  1. Выберите ряд данных, к которому нужно добавить линию тренда или скользящее среднее.

  2. Выберите команду Добавить линию тренда в меню Диаграмма.

  3. На вкладке Тип выберите нужный тип регрессионной линии тренда или линии скользящего среднего.

    При выборе типа Полиномиальная введите в поле Степень наибольшую степень для независимой переменной.

    При выборе типа Скользящее среднее введите в поле Период число периодов, используемых для расчета скользящего среднего.

Примечания

  • В поле Построен на ряде перечислены все ряды данных диаграммы, поддерживающей линии тренда. Для добавления линии тренда к другим рядам выберите нужное имя в поле, а затем выберите нужные параметры.

  • Если вариант «Скользящее среднее» выбран для точечной диаграммы, результат будет зависеть от порядка расположения значений X во входном диапазоне. Чтобы получить правильный результат, необходимо отсортировать значения X перед построением линии скользящего среднего.

  • Линии тренда не сохраняются в отчетах сводных диаграмм при последующем изменении представления диаграммы или связанного отчета сводной таблицы. До проведения линии тренда или другого форматирования отчета сводных диаграмм, убедитесь, что макет удовлетворяет необходимым требованиям.


 Редактирование линий тренда

Редактирование линий тренда

Данная процедура доступна только для регрессионных линий тренда.

  1. Щелкните линию тренда, которую требуется изменить.

  2. Выберите в меню Формат команду Выделенная линия тренда.

  3. На вкладке Параметры выберите нужные параметры.

    Для изменения имени линии тренда или скользящего среднего введите имя в поле Другое.

Примечание. Линии тренда и их настройки не сохраняются в отчетах сводных диаграмм, если впоследствии изменяется вид диаграммы или связанный отчет сводной таблицы. Перед добавлением или изменением линии тренда или других элементов форматирования отчета сводной диаграммы убедитесь в том, что макет диаграммы удовлетворяет всем требованиям.


 Удаление линии тренда

Удаление линии тренда

  1. Выберите удаляемую линию тренда.

  2. Нажмите клавишу DELETE.


 Вывод значения R-квадрат для линии тренда

Вывод значения R-квадрат для линии тренда

  1. Щелкните линию тренда, для которой нужно вывести величину R-квадрат.

  2. Выберите команду Выделенная линия тренда в меню Формат.

  3. На вкладке Параметры установите флажок поместить на диаграмму величину достоверности аппроксимации (R^2).

Примечания

  • Для скользящего среднего значение R-квадрат не может быть отображено.

  • Линии тренда и их установки не сохраняются в отчетах сводных диаграмм при последующем изменении представления диаграммы или связанного отчета сводной таблицы. До проведения линии тренда или другого форматирования отчета сводных диаграмм, убедитесь, что макет удовлетворяет необходимым требованиям.


Формулы для расчета линий тренда

арифметическая

Используется для аппроксимации данных по методу наименьших квадратов в соответствии с уравнением:

где m - угол наклона и b - координата пересечения оси абсцисс.

Полиномиальная

Используется для аппроксимации данных по методу наименьших квадратов в соответствии с уравнением:

где b и переменная — константы.

Логарифмическая

Используется для аппроксимации данных по методу наименьших квадратов в соответствии с уравнением:

где c и b - константы, ln - функция натурального логарифма.

Экспоненциальная

Используется для аппроксимации данных по методу наименьших квадратов в соответствии с уравнением:

где c и b - константы, e - основание натурального логарифма.

Степенная

Используется для аппроксимации данных по методу наименьших квадратов в соответствии с уравнением:

где c и b - константы.

Величина R-квадрат

Примечание. Отображаемое вместе с линией тренда значение величины R-квадрат не является корректным. Для логарифмической, степенной и экспоненциальной линий тренда в Microsoft Excel используется несколько видоизмененная модель регрессии.

Скользящее среднее

Примечание. Число точек, образующих линию скользящего среднего, равно числу точек в исходном ряде минус значение периода.


Отчеты сводных диаграмм

Для просмотра этого раздела щелкните рисунок:

Для просмотра этого раздела щелкните рисунок.

Чтобы отобразить сведения этого раздела с помощью клавиатуры, нажмите клавишу F6 для перехода к области раздела, клавишей TAB выделите рисунок и нажмите ENTER.


 Элементы отчета сводной диаграммы

Элементы отчета сводной диаграммы

Кроме элементов обычной диаграммы Microsoft Excel, отчет сводной диаграммы содержит поля рядов, поля категорий, поля данных и, возможно, поля страниц. Элементы содержатся внутри полей.

Элементы отчета сводной диаграммы

Поле страницы Это поле используется для фильтрации данных по конкретному элементу. В приведенном примере «Продавец» — это поле страницы, которое используется для отображения данных по всем продавцам. Для отображения данных только по определенной персоне можно щелкнуть стрелку списка и выбрать соответствующее имя.

Поле данных Поле из исходного списка или таблицы, которое содержит данные. В примере «Сумма продаж » — это поле данных, которое обобщает для каждого типа продажи по регионам. Маркер данных первой категории (Восток) достигает почти 140 000 на оси значений (y). Это значение является суммой продаж продуктов, мясных, молочных изделий и напитков в восточном регионе. В зависимости от данных, используемых в поле данных, можно изменить итоговую функцию поля данных для усреднения, подсчета количества значений, определения произведения значений или применения другой итоговой функции.

Поле ряда Поле, которому присваивается ориентация ряда в отчете сводной диаграммы. В примере «Тип» — это поле ряда с четырьмя элементами: «Продукты», «Мясо», «Молоко», «Напитки».

Стрелка списка поля Стрелка [image] расположена в правой части каждого поля. Нажмите стрелку и выберите элементы, которые должны быть отображены или скрыты.

В отчетах сводных диаграмм, основанных на исходных данных OLAP, можно выбирать элементы на различных уровнях в поле измерения. Выбор стрелки списка для поля «Год» может привести к следующему результату:

Раскрывающийся список для поля измерения OLAP

Данные по 1998 году скрыты. В 1999 году «Кв1» скрыт. Двойная галочка в полях 1999 и «Кв2» означает, что все или некоторые из элементов нижнего уровня для 1999 и «Кв2» отображены. Одиночная галочка в поле 2000 означает, что информация по этому году выбрана для отображения.

Щелкните плюс (+) или минус (-) для отображения или скрытия деталей.

Элемент Элемент представляет уникальные значения в том же поле и появляется в раскрывающихся списках в полях страницы, полях категории и полях рядов. В примерах «Восток», «Север», «Юг» и «Запад» представляют собой элементы поля категории «Регион», тогда как «Продукты», «Мясо», «Молоко», «Напитки» являются элементами поля ряда «Тип».

Поле категории Поле из текущего источника данных, которому присваивается ориентация категории в отчете сводной диаграммы. В примере «Регион» — это поле категории.


 Создание отчетов сводных диаграмм

Создание отчетов сводных диаграмм

Отчет сводной диаграммы должен быть связан с отчетом сводной таблицы в той же книге. Если книга не содержит отчета сводной таблицы, то при создании отчета сводной диаграммы Microsoft Excel создает также отчет сводной таблицы. При изменении отчета сводной диаграммы изменяется и отчет сводной таблицы, и наоборот.

Создание отчета сводной диаграммы. Чтобы создать отчет сводной диаграммы, воспользуйтесь мастером отчетов сводных таблиц и сводных диаграмм. В мастере можно указать тип исходных данных, которые требуется использовать, установить параметры использования этих данных и создать макет расположения элементов диаграммы. Выполнить расположение элементов диаграммы можно также на самом листе диаграммы.

При использовании мастера Excel создает связанный отчет сводной таблицы в указанном местоположении (на имеющемся листе или на новом листе в той же книге). В отчете сводной таблицы используется макет, разработанный для отчета сводной диаграммы: поля категорий и рядов на диаграмме являются соответственно полями строк и столбцов в таблице.

Создание отчета сводной диаграммы, основанного на существующем отчете сводной таблицы. При создании отчета сводной диаграммы на основе имеющегося отчета сводной таблицы поля на диаграмме соответствуют полям в отчете сводной таблицы: поля строк в таблице становятся полями категорий на диаграмме, а поля столбцов — соответственно полями рядов.

Если в отчете сводной диаграммы требуется использовать стандартный макет и параметры форматирования, можно создать отчет за один шаг. При использовании этого способа Excel создает многоуровневую гистограмму на отдельном листе диаграммы. После этого можно изменить тип диаграммы и другие параметры — такие как заголовки, расположение легенды, подписи данных, расположение диаграммы и т.п. — с помощью команд в меню Диаграмма. Если же эти параметры необходимо указать непосредственно в процессе создания отчета сводной диаграммы, то в этом случае можно воспользоваться пошаговым мастером диаграмм.


 Создание отчета сводной диаграммы

Создание отчета сводной диаграммы

Исходная точка — отчет сводной таблицы Отчет сводной диаграммы может быть создан по любому отчету сводной таблицы. Однако при создании отчета сводной диаграммы по структурированному отчету сводной таблицы (специально отформатированному отчету, не содержащему полей столбцов) диаграмма не будет содержать поля рядов.

При создании отчета сводной диаграммы по отчету сводной таблицы поля строк в таблице становятся полями категорий в диаграмме, а поля столбцов таблицы становятся полями рядов в диаграмме. Поскольку структурированный отчет сводной таблицы содержит только поля строк, сопутствующий отчет сводной диаграммы будет иметь несколько полей категорий и ни одного поля рядов. Можно изменить макет сводной диаграммы, перетаскивая поля в область размещения; однако связанный структурированный отчет сводной таблицы также изменится, и он не будет больше структурированным. Перед созданием отчета сводной диаграммы можно преобразовать структурированный отчет сводной таблицы в неструктурированный формат.

Типы диаграмм Могут быть использованы любые типы диаграмм кроме точечной, пузырьковой и биржевой диаграмм. Примеры типов диаграмм.

Форматирование Форматирование рядов данных в отчете сводной диаграмме не поддерживается после изменения макета диаграммы. Следовательно, перед тем как форматировать ряды данных, убедитесь в том, что макет диаграммы удовлетворяет всем требованиям.

Использование полей страниц Использование полей страниц является удобным способом обобщения и выделения подмножества данных без необходимости изменения сведений о рядах и категориях. Например, чтобы во время презентации показать продажи за все годы следует в поле страницы «Год» выбрать (Все); выбирая затем определенные годы можно сфокусироваться на информации по отдельным годам. Каждое представление или страница показывают одну и ту же категорию и ряд данных (например объем продаж по продавцам в каждом регионе) для каждого года, поэтому представления легко сравнимы. Кроме того, обеспечивая доступ только к подмножеству большого набора данных, поля страниц экономят память при использовании диаграммой внешних источников данных.


Создание отчета сводной диаграммы

Предполагаемые действия

Создание отчета сводной диаграммы

Создание отчета сводной диаграммы, отражающего представление существующего отчета сводной таблицы

Создание отчетов сводных диаграмм


 Создание отчета сводной диаграммы по существующему отчету сводной таблицы в помощью мастера диаграмм

Создание отчета сводной диаграммы по существующему отчету сводной таблицы в помощью мастера диаграмм

При использовании этого метода создания отчета сводной диаграммы диаграмма использует макет отчета сводной таблицы для определения размещения полей. Поля строк в таблице становятся полями категорий в диаграмме, а поля столбцов в таблице — полями рядов в диаграмме.

  1. Выберите ячейку вне диапазона отчета сводной таблицы.

  2. Нажмите кнопку Мастер диаграмм [image] на панели инструментов Стандартная.

  3. Выберите тип диаграммы на шаге 1 мастера. Не могут быть использованы точечная, пузырьковая и биржевая диаграммы.

  4. На шаге 2 мастера щелкните отчет сводной таблицы.

    Ссылка в поле Диапазон должна включать весь диапазон отчета сводной таблицы.

  5. Следуйте дальнейшим инструкциям мастера диаграмм.

Примечание. Отчет сводной диаграммы изменяется при изменении отчета сводной таблицы, и наоборот.


 Создание обычных диаграмм, которые используют данные отчета сводной таблицы

Создание обычных диаграмм, которые используют данные отчета сводной таблицы

Для создания обычной статической диаграммы, которая использует данные отчета сводной таблицы, необходимо сначала скопировать данные отчета сводной таблицы, которые будут использованы, и вставить их в виде статических данных в другую область.

  1. Выделите в отчете сводной таблицы данные (включая поля столбцов и поля строк), которые будут использованы в диаграмме.

  2. Нажмите кнопку Копировать [image] на панели инструментов Стандартная.

  3. Щелкните левый верхний угол области, в которой должны размещаться статические данные.

  4. В меню Правка выберите команду Специальная вставка, а затем в диалоговом окне Специальная вставка установите переключатель Значения.

  5. Оставив диапазон выделенным, нажмите кнопку Мастер диаграмм [image] на панели инструментов Стандартная и следуйте инструкциям мастера для создания статической диаграммы.

Совет Чтобы выделить с помощью мыши первую строку и первый столбец отчета сводной таблицы, начните выделение правого нижнего угла данных.


 Создание макета отчета сводной диаграммы на листе диаграммы

Создание макета отчета сводной диаграммы на листе диаграммы

Следующая процедура используется после создания отчета сводной диаграммы с помощью мастера сводных таблиц и сводных диаграмм, если макет отчета не был создан с помощью кнопки Макет на шаге 3 выполнения мастера.

  1. Из группы кнопок полей на панели инструментов Сводная таблица перетащите поля, которые должны отображаться в категориях, в область сводной диаграммы с надписью «Перетащите сюда другие поля категорий».

    Если кнопки полей на панели инструментов не видны, убедитесь, что панель инструментов не закреплена, щелкните в пределах сводной диаграммы, а затем убедитесь, что кнопка Отобразить поля [image] нажата.

    При использовании исходных данных OLAP в качестве полей категорий, рядов или страниц могут использоваться только поля, помеченные значком Значок поля размерности в начале строки на панели инструментов Сводная таблица. Эти поля находятся в начале списка полей. Для прокрутки к началу списка используется кнопка Другие поля [image] . Поля, которые должны отображаться в рядах (элементы, отображаемые в легенде), перетащите в область с надписью «Перетащите сюда другие поля рядов».

  2. Поля, содержащие данные, которые требуется сравнить или измерить, перетащите в область с надписью «Перетащите сюда элементы данных».

    При использовании исходных данных OLAP в качестве полей данных можно использовать только поля, помеченные значком Значок поля данных в начале строки на панели инструментов. Эти поля находятся в конце списка полей. Для прокрутки в конец списка используется кнопка Другие поля [image] . Поля, которые требуется использовать в качестве полей страниц, перетащите в область с надписью «Перетащите сюда поля страниц».

  3. Для изменения расположения полей перетащите их из одной области в другую. Для того чтобы удалить поле, перетащите его к внешнему краю отчета сводной диаграммы. Удаленные поля остаются доступными в списке полей на панели инструментов.

Примечание. Поля категорий, рядов и страниц из источника данных OLAP изначально отображают данные верхнего уровня. Имена полей наивысшего уровня в отчете сводной диаграммы могут не совпадать с именами на кнопках полей. Например, кнопка поля для размерности с названием «География» может иметь в отчете сводной диаграммы имя поля наивысшего уровня, «Страна», но изначально может отображать элементы уровня «Страна», например «США», «Канада» и т.п. После перетаскивания полей в отчет сводной диаграммы можно отобразить данные нижнего уровня этих полей.


 Изменение макета отчета сводной диаграммы путем перемещения полей

Изменение макета отчета сводной диаграммы путем перемещения полей

Для данной процедуры флажок Скрыть кнопки полей сводной диаграммы должен быть сброшен, чтобы эти поля были видны.

  • Выполните одно из следующих действий:

    Чтобы переместить поле и все элементы, связанные с ним, перетащите кнопку поля с панели инструментов Сводные таблицы (или области диаграммы) на новое место.

    Для преобразования полей рядов в поля категорий, перетащите кнопку поля ряда в область полей категорий. Затем переместите предыдущие поля категорий в область полей рядов. Для обратного изменения повторите процедуру в обратном порядке.

    Для создания поля страницы переместите кнопку поля в область полей страниц.

    Для удаления поля страницы, ряда или категории перетащите кнопку из области размещения.

Примечания

  • Данные отображаются с задержкой Если при перетаскивании поля на другое место данные отображаются с задержкой, используйте мастер сводных таблиц и сводных диаграмм, чтобы изменить макет.

  • Поля измерений OLAP и поля данных В отчетах сводных диаграмм, основанных на исходных данных OLAP, поля измерений могут быть использованы только как поля категорий, рядов или страниц в сводной диаграмме. Эти поля обозначаются значком Поле размерности в начале строки списка полей на панели инструментов Сводные таблицы. Поля, имеющие значок Поле данных в начале строки на панели инструментов, могут быть использованы только как поля данных.

  • Поля измерений OLAP управляются как одно целое Когда поле размерности перемещается при изменении макета, все уровни и все элементы в измерении перемещаются вместе с ним.

  • Некоторые поля не могут быть перемещены В некоторых случаях нельзя переместить определенные поля.

  • Поля страниц, устанавливающие запрос для каждого элемента Если в поле страницы устанавливается запрос к внешним данным только при выборе элемента поля, перемещение поля страницы в другое место приводит к обращению к внешним данным для всех элементов поля одновременно. См. сведения о параметрах поля страницы.

  • Форматирование сводных диаграмм При изменении макета отчета сводных диаграмм некоторые параметры форматирования могут быть утеряны.


 Преобразование отчета сводной диаграммы в статическую диаграмму

Преобразование отчета сводной диаграммы в статическую диаграмму

Для преобразования отчета сводной диаграммы в статическую, или обычную, диаграмму, необходимо удалить связанный отчет сводной таблицы.

  1. Щелкните ячейку связанного отчета сводной таблицы.

  2. На панели инструментов Сводные таблицы выберите команду Выделить в меню Сводные таблицы, а затем — команду Таблица целиком.

  3. Нажмите клавишу DELETE.

Советы

  • При отсутствии ценных данных в отчете сводной таблицы можно удалить лист целиком вместо удаления одного отчета.

  • Если необходимо сохранить отчет сводной таблицы в другом месте, можно переместить или скопировать лист в новую книгу. При перемещении листа в другую книгу отчет сводной диаграммы станет статическим. При копировании необходимо удалить скопированный отчет сводной таблицы, чтобы отчет сводной диаграммы стал статическим.


Подробные данные отчета сводной диаграммы и выполняемые над ними действия

Предполагаемые действия

Скрытие и отображение элементов

Отображение или скрытие элементов поля сводной диаграммы

Отображение или скрытие элементов поля страницы сводной диаграммы

Отображение максимальных или минимальных элементов в поле сводной диаграммы. Например, 10 крупных сделок или пять мелких сделок.

Отображение или скрытие подробных данных

Отображение различных уровней детализации в сводной диаграмме

Отображение и скрытие подробностей для рядов в отчете сводной диаграммы

Отображение и скрытие подробностей для категорий в отчете сводной диаграммы

Предотвращение доступа к подробным данным в сводной таблице или сводной диаграмме


 Отображение и скрытие кнопок полей в отчете сводной диаграммы

Отображение и скрытие кнопок полей в отчете сводной диаграммы

При печати или подготовке презентации может возникнуть необходимость скрыть кнопки поля в отчете сводной диаграммы. Когда кнопки поля скрыты, размер диаграммы увеличивается, но при этом ее макет не может быть изменен.

  1. Щелкните отчет сводной таблицы или сводной диаграммы.

  2. На панели инструментов Сводная таблица выберите Сводная диаграмма и выполните одно из следующих действий:

    Чтобы скрыть кнопки,установите флажок Скрыть кнопки полей сводной диаграммы.

    Чтобы отобразить кнопки, сбросьте флажок Скрыть кнопки полей сводной диаграммы.

Совет. Если кнопки полей скрыты, но необходимо подписать элементы диаграммы, обозначаемые ранее названиями кнопок полей, можно добавить заголовки осей или надписи на диаграмму.


Переименование поля или элемента отчета сводной диаграммы

Для того чтобы переименовать поле, выполните следующую процедуру. Для того чтобы переименовать элемент, необходимо переименовать соответствующий элемент в связанном отчете сводной таблицы.

  1. В отчете сводной диаграммы дважды щелкните кнопку того поля, которое требуется переименовать.

  2. В диалоговом окне Вычисление поля сводной таблицы введите новое имя в поле Имя.


 Формулы в отчетах сводных диаграмм

Формулы в отчетах сводных диаграмм

В отчетах сводных диаграмм можно создавать дополнительные формулы для выполнения различных операций анализа данных. В отчетах сводных диаграмм используются те же методы и правила создания формул, что и в отчетах сводных таблиц. При создании вычисляемого элемента или вычисляемого поля в отчете сводной диаграммы формулы и результаты отражаются в связанном отчете сводной таблицы, и наоборот. Если при работе с отчетом сводной диаграммы требуется создать сложные формулы, рекомендуется создать формулы в связанном отчете сводной таблицы, где можно просматривать отдельные значения в составе данных, а затем просмотреть результаты, отображаемые в отчете сводной диаграммы.

Пример формулы в отчете сводной диаграммы. Следующий пример отчета сводной диаграммы отображает объемы продаж для каждого продавца по регионам:

Отчет сводной диаграммы, отображающий объемы продаж для каждого продавца по регионам

Если требуется узнать, каковы будут объемы продаж при увеличении их на 10 процентов, можно создать вычисляемое поле с использованием следующей формулы:

=Продажи * 1,10

Результат будет отображен на диаграмме следующим образом:

Отчет сводной диаграммы, отображающий объемы продаж по регионам, увеличенные на 10 процентов

В отчетах сводных диаграмм можно также создавать вычисляемые элементы. Например, если требуется отобразить отдельный маркер данных для продаж в восточном регионе за вычетом стоимости транспортировки, составляющей 8 процентов, можно создать вычисляемый элемент в поле «Продажи» с использованием следующей формулы:

=Восток–(Восток * ,08)

В приведенном выше примере данная формула будет отображена в виде отдельной категории и маркера данных на оси категорий. Однако вычисляемый элемент, созданный в поле «Продавец», будет отображаться как ряд, отображаемый в легенде и представляемый на диаграмме в виде точки данных в каждой категории.

Если сначала создан вычисляемый элемент, формула будет той же во всех категориях или во всех рядах данных, в которых отображается элемент. Например, если в поле «Регион», являющемся полем категории, создана формула =Восток–(Восток * ,08), то эта же формула будет использоваться во всех рядах. Чтобы изменить формулу с учетом отдельных рядов или отдельных категорий, измените формулы в связанном отчете сводной таблицы с учетом всех ячеек.

Дополнительные сведения

См. дополнительные сведения о выполнении вычислений в сводных таблицах и сводных диаграммах

Обобщение и вычисление данных в сводной таблице и отчете сводной диаграммы


Разрешение вопросов в диаграммах

В чем именно заключаются сложности?

Работа с данными

Диаграмма не измеряет или не выводит на экран данные требуемым образом.

В диаграмме с датами отсутствует ось времени

Вдоль горизонтальной оси диаграммы отсутствует текст

Точечная диаграмма не использует заданные значения вдоль горизонтальной (x) оси

В лист был введен новый текст или новые цифры, а диаграмма не была обновлена

Форматирование и вывод на экран

Почему постоянно изменяется размер шрифта в диаграмме?

Промежуток между датами, представленными на диаграмме

Опубликованную точечную диаграмму не удается просмотреть в обозревателе

Смещение многоуровневых подписей категорий на диаграмме

Невозможно найти созданную или перемещенную диаграмму

Надпись, рисунок или перемещаемый текст не включаются в диаграмму пользовательского типа

Печать и команды

Необходимо изменить масштаб диаграммы или разместить несколько диаграмм на одной печатной странице

Невозможно найти необходимое меню, команду, кнопку панели инструментов, вкладку или параметр диалогового окна

Отчеты сводных диаграмм

Разрешение вопросов при работе с отчетами сводных диаграмм


Разрешение вопросов при работе с отчетами сводных диаграмм

В чем именно заключаются сложности?

Создание отчета сводной диаграммы

Форматирование отчета сводной диаграммы

Работа с макетом отчета сводной диаграммы

Работа с данными отчета сводной диаграммы

Создание отчета сводной диаграммы

Сообщение о нехватке памяти для создания отчета.

Отчет сводной таблицы, на основе которого создается отчет сводной диаграммы, не отображается в списке мастера

Возврат в начало

Форматирование отчета сводной диаграммы

В отчете сводной диаграммы отсутствуют форматирование, линии тренда и планки погрешностей

Не удается переместить или изменить размеры легенды, подписей или области построения в отчете сводной диаграммы

Определенные в диаграмме пользовательского типа местоположение и размеры элементов не используются в созданном отчете сводной диаграммы

Отсутствует числовое форматирование данных в отчете сводной диаграммы

Возврат в начало

Работа с макетом отчета сводной диаграммы

Не отображаются кнопки полей в отчете сводной диаграммы и возможность изменения макета диаграммы отсутствует

Изменение макета или представления отчета сводной таблицы или сводной диаграммы занимает много времени

Параметры поля страницы недоступны

При перетаскивании поля в отчет сводной диаграммы данные появляются с задержкой

При закреплении панели инструментов сводной таблицы не удается отобразить список полей

Не удается перетащить поле сводной диаграммы

Отсутствует стрелка в поле отчета сводной таблицы или диаграммы

Возврат в начало

Работа с данными отчета сводной диаграммы

Недоступна команда Исходные данные в меню Диаграмма

Не удается изменить лист во время выполнения запроса сводной таблицы или сводной диаграммы

Для вычислений в поле данных в качестве итоговой функции вместо функции «Сумма» используется функция «Количество значений» и наоборот

Отсутствуют данные отчета сводной диаграммы после обновления

Отчет сводной диаграммы выглядит совершенно иначе после обновления, либо обновить отчет больше не удается

Возврат в начало


Работа с графическими объектами в Microsoft Excel

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Добавление рисунков на листы или в диаграммы

Предполагаемые действия

Добавление рисунка

Использование графики в Microsoft Excel

Добавление круга, квадрата или другой автофигуры

Вставка и изменение рисунка или картинки

Добавление текста в автофигуру

Добавление текста в рисунок

Добавление и изменение фигурного текста

Добавление линии

Добавление кривой

Добавление полилинии


 Создание изображений ячеек, диаграмм и других объектов

Создание изображений ячеек, диаграмм и других объектов

Создание изображения. Имеется возможность создать изображения данных на листах, диаграмм и других объектов и использовать их в качестве иллюстраций на листе или в документе, созданном в другой программе. При этом можно изменять размеры этих изображений, перемещать и изменять их как и любые рисованные объекты. См. Создание изображений ячеек, диаграмм и других объектов, не связанных с исходными данными.

Также можно создать изображение данных листа (но не диаграммы), обновляемое при изменении исходных данных. См. Создание изображения ячеек, привязанного к исходным данным.

Привязка изображения диаграммы. Связать изображение диаграммы с исходными данными невозможно. Для того чтобы на диаграмме автоматически отражались изменения, вносимые в исходные данные, необходимо скопировать диаграмму и вставить ее в качестве связанного объекта в конечный файл. См. Копирование диаграммы Microsoft Excel в документ Word или PowerPoint.

Преимущества использования формата рисунка. Изображение можно скопировать в формате рисунка или точечного рисунка. Формат рисунка требует меньше памяти и дискового пространства, чем формат точечного рисунка, и позволяет Microsoft Excel отображать изображение быстрее. Изображения в формате рисунка выглядят хорошо при любом разрешении и позволяют добиться высокого качества как при печати, так и при отображении на экране, например при создании диаграммы для презентации. Вид точечных изображений изменяется в зависимости от разрешения экрана и могут требовать больше памяти, чем изображения в формате рисунка.


 Отображение панели инструментов "Рисование"

Отображение панели инструментов "Рисование"

  • Нажмите кнопку Рисование [image] .


 Сохранение атрибутов графического объекта для использования по умолчанию

Сохранение атрибутов графического объекта для использования по умолчанию

Для применения атрибутов к выбранным объектам выполните следующие действия:

  1. Выделите графический объект с атрибутами, которые следует использовать по умолчанию.

  2. На панели инструментов Рисование нажмите кнопку Действия, а затем выберите команду По умолчанию для автофигур.


 Добавление автофигуры, круга или квадрата

Добавление автофигуры, круга или квадрата

  1. Чтобы добавить автофигуру на лист или лист диаграммы, щелкните ярлычок нужного листа.

    Чтобы добавить автофигуру на внедренную диаграмму, щелкните внедренную диаграмму.

  2. На панели инструментов Рисование нажмите кнопку Автофигуры, укажите категорию, а затем выберите необходимую фигуру.

  3. Для вставки фигуры стандартного размера щелкните лист, лист диаграммы или внедренную диаграмму.

    Для изменения размеров фигуры используйте перетаскивание.

    Для сохранения пропорций фигуры во время перетаскивания удерживайте нажатой клавишу SHIFT.

    Для выравнивания фигуры по линиям сетки во время перетаскивания удерживайте нажатой клавишу ALT.

Советы

  • Чтобы нарисовать круг или квадрат, нажмите кнопку Овал [image] или Прямоугольник [image] на панели инструментов Рисование, а затем щелкните лист.

  • Для изменения границ, вращения, добавления цвета, тени или объемных эффектов к автофигуре выделите объект, а затем используйте кнопки на панели инструментов Рисование.

  • При выборе команды Другие автофигуры отображаются автофигуры, содержащиеся в коллекции клипов. Чтобы вставить автофигуру, перетащите нужную автофигуру из коллекции на лист.


 Добавление линии

Добавление линии

  1. На панели инструментов Рисование нажмите кнопку Автофигуры, затем выберите пункт Линии и выберите требуемый тип линии.

  2. Перемещайте курсор, удерживая левую кнопку мыши.

    Для придания прямой линии фиксированного угла наклона, кратного 15 градусам, при построении линии нажмите и удерживайте клавишу SHIFT.

    Для построения прямой одновременно в двух противоположенных направлениях по отношению к начальной точке при построении линии нажмите и удерживайте клавишу CTRL.

Совет. Для построения прямой линии нажмите кнопку Линия [image] на панели инструментов Рисование.


 Добавление и удаление стрелок

Добавление и удаление стрелок

  1. Выделите линию, которую требуется изменить.

  2. На панели инструментов Рисование нажмите кнопку Вид стрелки [image] .

  3. Чтобы добавить стрелку, выберите требуемый тип стрелки или нажмите кнопку Дополнительные стрелки, а затем выберите тип стрелки.

    Для удаления стрелки выберите линию без стрелок в верхней части меню.


 Рисование полилиний и кривых

Рисование полилиний и кривых

Меню Автофигуры на панели инструментов Рисование включает несколько категорий инструментов. Инструменты категории Линии, например Кривая, Рисованная кривая и Полилиния, можно использовать для рисования линий, кривых и фигур, сочетающих линии и кривые.

Инструмент | Пример | Описание
Рисованная кривая | Объект, нарисованный с помощью инструмента «Рисованная кривая» | Объект, созданный с помощью данного инструмента, выглядит как нарисованный от руки. Получающийся рисунок соответствует тому, что рисуется на экране.
Полилиния | Объект, нарисованный с помощью инструмента «Полилиния» | Данный инструмент создает более аккуратные фигуры без зазубрин и шероховатостей
Кривая | Объект, нарисованный с помощью инструмента «Кривая» | Данный инструмент позволяет достичь более высокой точности при рисовании кривых

Примечание. Над полилиниями и кривыми можно выполнять те же действия, что и над другими автофигурами — например, добавлять цвет или заливку, изменять тип линии и выполнять отражение и поворот. Однако добавить текст или преобразовать полилинию, рисованную или обычную кривую в другую автофигуру нельзя.

Дополнительные сведения

Добавление полилинии или рисованной кривой

Добавление кривой


 Добавление полилинии

Добавление полилинии

  1. На панели инструментов Рисование нажмите кнопку Автофигуры, а затем - кнопку Линии.

  2. Нажмите кнопку Полилиния [image] , чтобы создать объект, образованный кривыми и прямыми отрезками. При рисовании участков произвольной формы удерживайте левую кнопку мыши, при рисовании прямых участков щелкайте только в месте расположения узлов.

    Для рисования объектов от руки нажмите кнопку Рисованная кривая [image] .

  3. Для завершения построения разомкнутой полилинии дважды щелкните мышью в любой точке.

    Для того, чтобы полилиния получилась замкнутой, завершите построение около ее начала.

Совет. После завершения построения разомкнутую полилинию можно замкнуть и наоборот. Для этого щелкните кривую правой кнопкой мыши и в контекстном меню выполните соответственно команду Замкнуть кривую или Разомкнуть кривую.


 Добавление кривой

Добавление кривой

  1. На панели инструментов Рисование нажмите кнопку Автофигуры, выберите Линии, а затем - Кривая [image] .

  2. Щелкните мышью в том месте, где должна начинаться кривая, после чего перемещайте указатель и нажимайте левую кнопку мыши в тех точках, через которые должна проходить кривая.

  3. Для завершения построения разомкнутой кривой дважды щелкните мышью в любой точке.

    Для того, чтобы кривая получилась замкнутой, завершите построение около ее начала.

Совет. После завершения построения разомкнутую кривую можно замкнуть и наоборот. Для этого щелкните кривую правой кнопкой мыши и в контекстном меню выполните соответственно команду Замкнуть кривую или Разомкнуть кривую.


 Добавление или перемещение соединительной линии

Добавление или перемещение соединительной линии

  1. На панели инструментов Рисование нажмите кнопку Автофигуры, а затем на кнопку Соединительные линии, после чего выберите требуемый вид соединительной линии.

  2. Выберите первый соединяемый объект.

    Узлы, к которым проводятся соединительные линии, помечаются синими квадратиками.

  3. Выберите первый узел, затем укажите на другой объект и выберите второй соединительный узел.

    Узлы, между которыми проведены соединительные линии, отображаются в виде красных квадратиков. Линии, соединяющие такие узлы, будут перемещаться вместе с соединяемыми объектами. Свободные концы соединительных линий отображаются в виде зеленых квадратиков.

    Чтобы провести соединительную линию к другому узлу, переместите с помощью мыши один из концов соединительной линии. Чтобы отделить всю соединительную линию, следует перетаскивать ее среднюю часть. Если соединительная линия имеет желтый маркер изменения формы, то перетаскивание его позволяет изменить форму объекта.

    Закрепленные соединительные линии


Замена автофигуры

  1. Выделите автофигуру, которую необходимо заменить.

  2. На панели инструментов Рисование нажмите кнопку Действия, выберите команду Изменить автофигуру, укажите категорию, а затем щелкните необходимую фигуру.


 Отображение и скрытие рисованных и импортированных графических объектов

Отображение и скрытие рисованных и импортированных графических объектов

Для ускорения прокрутки экрана и печати отмените отображение на экране рисованных и импортированных графических объектов.

  1. В меню Сервис выберите пункт Параметры и перейдите на вкладку Вид.

  2. Для отображения рисованных и импортированных графических объектов выберите параметр Показывать все.

    Чтобы не показывать на экране рисованные и импортированные графические объекты, выберите параметр Скрывать все.


Удаление автофигуры или другого графического объекта

  1. Выделите автофигуру или графический объект, которые нужно удалить.

  2. Нажмите клавишу DELETE.


Символы, используемые при работе с графическими объектами

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок.


Добавление, изменение или удаление заливки в графическом объекте

Можно заполнить объекты цветом, узором, текстурой или рисунком, выполнить градиентную заливку. Каждая новая заливка заменяет предыдущую.

Предполагаемые действия.

Выбор заливки

Изменение цвета заливки

Удаление заливки


 Изменение формы полилинии и кривой

Изменение формы полилинии и кривой

  1. Выделите полилинию или кривую, которую требуется изменить.

  2. На панели инструментов Рисование нажмите кнопку Действия, а затем выполните команду Начать изменение узлов.

  3. Чтобы изменить форму полилинии, достаточно перетащить один из ее узлов.

    Для добавления узла полилинии, укажите место, куда следует поместить узел и, удерживая левую кнопку мыши, переместите указатель мыши.

    Для удаления узла, нажимая клавишу CTRL, щелкните ее мышью.

Совет. Чтобы сделать работу с кривой линией более удобной, после выбора команды Начать изменение узлов, укажите на узел и нажмите правую кнопку мыши. Отобразится контекстное меню, в котором можно выбрать различные типы узлов с целью улучшения формы кривой.


 Изменение размеров и обрезка графического объекта

Изменение размеров и обрезка графического объекта

Изменение размеров. При выделении графического объекта по периметру рамки выделения появляются маркеры изменения размера. Размеры объекта изменяются путем перетаскивания маркеров изменения размера или точного задания его высоты и ширины.

Изменение размеров объекта путем перетаскивания маркеров изменения размера

Задание точных размеров графического объекта

Сохранение пропорций графического объекта при изменении его размеров

Обрезка. Если объект является рисунком — например, фотографией, точечным рисунком или картинкой, — то объект можно обрезать, то есть уменьшить его по вертикали или по горизонтали. Фотографии часто обрезают для привлечения внимания к конкретной области изображения. Обрезка рисунка.

Восстановление исходных размеров. После обрезки или изменения размеров рисунок можно восстановить. Независимо от того, сколько раз изменялся рисунок, Microsoft Excel сохраняет сведения об исходных размерах, которые рисунок имел при первоначальной вставке его на лист или в диаграмму. Восстановление исходных размеров рисунка.


 Изменение цвета линии или границы рисованного объекта

Изменение цвета линии или границы рисованного объекта

  1. Выделите графический объект, который необходимо изменить.

  2. На панели инструментов Рисование нажмите стрелку, расположенную справа от кнопки Цвет линии [image] .

  3. Выберите необходимый цвет.

    Для выбора дополнительных цветов нажмите кнопку Дополнительные цвета линий. После этого можно как выбрать цвет на вкладке Обычные, так и создать собственный цвет с помощью вкладки Спектр, а затем нажать кнопку OK.


 Изменение типа линии или границы рисованного объекта

Изменение типа линии или границы рисованного объекта

  1. Выделите линию или границу, которые требуется изменить.

  2. На панели инструментов Рисование нажмите кнопку Тип линии [image] .

  3. Выберите тип линии или нажмите кнопку Дополнительные линии, а затем выберите необходимые параметры линии.


 Изображение штриховой линии или границы вокруг рисованного объекта

Изображение штриховой линии или границы вокруг рисованного объекта

  1. Выделите линию или границу, которые требуется изменить.

  2. На панели инструментов Рисование нажмите кнопку Тип штриха [image] и выберите требуемый тип линии.


 Удаление линии или границы рисованного объекта

Удаление линии или границы рисованного объекта

  1. Выделите объект, линию или границу которого требуется удалить.

  2. На панели инструментов Рисование нажмите стрелку, расположенную справа от кнопки Цвет линии [image] , а затем нажмите кнопку Нет линий.


Спрямление соединительной линии

  1. Выделите один из соединенных объектов.

  2. На панели инструментов Рисование нажмите кнопку Действия и выполните команду Спрямить соединения.

    Спрямленная соединительная линия

Совет. Если выполнить команду Спрямить соединения для двух объектов с несколькими соединительными линиями, все соединительные линии будут направлены к одним и тем же узлам объектов. Чтобы не спрямлять все соединительные линии, сначала выделите нужную соединительную линию, а затем выполните команду Спрямить соединения.


 Добавление тени или объема для графического объекта

Добавление тени или объема для графического объекта

Прямоугольник с тенью и прямоугольник с эффектом объема

Тень. Можно добавлять тени к автофигурам (включая надписи), а также изменять размер, направление и цвет тени. Изменение цвета тени не отражается на цвете самого объекта. Кроме того, можно добавлять специальные тени, например, смещенные тени, к рамкам рисунков. Инструкции по добавлению тени к рисованным объектам.

Объем. Объемный эффект может использоваться почти со всеми линиями, автофигурами и полилиниями. Параметры объема позволяют управлять глубиной и цветом объекта, вращать объект, а также выбирать угол, направление освещения и текстуру поверхности. При изменении цвета объемного оформления цвет самого объекта не изменяется. Добавление объема рисованного объекта.

Примечание. Объект не может иметь одновременно и тень, и объем — при выборе объемного эффекта тень объекта исчезает.

Совет. Для создания объемного текста служит кнопка Добавить объект WordArt [image] на панели инструментов Рисование.


 Добавление тени к графическому объекту

Добавление тени к графическому объекту

  1. Выделите графический объект, к которому необходимо добавить тень.

  2. На панели инструментов Рисование нажмите кнопку Тень [image] , а затем выберите нужный вид тени.

Совет. Для изменения цвета или направления тени нажмите кнопку Тень [image] , выберите команду Настройка тени, а затем выберите нужные настройки на панели инструментов Настройка тени.


 Добавление или изменение объема для графического объекта

Добавление или изменение объема для графического объекта

  1. Выделите графический объект, который необходимо изменить.

  2. На панели инструментов Рисование нажмите кнопку Объем [image] .

    Для добавления объема выберите нужный вид объема.

    Для изменения параметров объема — глубины, угла поворота, угла наклона, направления освещения и текстуры поверхности — еще раз нажмите кнопку Объем [image] , нажмите кнопку Настройка объема, а затем выберите нужные настройки на панели инструментов Настройка объема.

Совет. Чтобы добавить одинаковый эффект сразу к нескольким объектам, перед добавлением эффекта выделите эти объекты или объедините их в группу.


 Изменение цвета объема для графического объекта

Изменение цвета объема для графического объекта

  1. Выделите графический объект, который необходимо изменить.

  2. На панели инструментов Рисование нажмите кнопку Объем [image] , а затем нажмите кнопку Настройка объема.

  3. На панели инструментов Настройка объема щелкните стрелку рядом с полем Цвет объема [image] .

  4. Выберите необходимый цвет.

    Если нужный цвет отсутствует в предложенном списке, выберите команду Дополнительные цвета для объема, а затем выберите цвет на вкладке Обычные или используйте вкладку Спектр для создания нового цвета. По окончании нажмите кнопку OK.

    Чтобы восстановить используемый по умолчанию цвет объема, выберите параметр Авто.


 Изменение цвета тени графического объекта

Изменение цвета тени графического объекта

  1. Выделите графический объект, который необходимо изменить.

  2. На панели инструментов Рисование нажмите кнопку Тень [image] , а затем выберите команду Настройка тени.

  3. На панели инструментов Настройка тени щелкните стрелку рядом с кнопкой Цвет тени [image] .

  4. Выберите необходимый цвет.

    Если нужный цвет отсутствует в предложенном списке, выберите команду Другие цвета тени, а затем выберите цвет на вкладке Обычные или используйте вкладку Спектр для создания нового цвета. По окончании нажмите кнопку OK.

Совет. Чтобы сделать тень полупрозрачной, нажмите кнопку Цвет тени [image] , а затем выберите команду Полупрозрачная тень.


 Изменение направления тени графического объекта

Изменение направления тени графического объекта

  1. Выделите графический объект, который необходимо изменить.

  2. На панели инструментов Рисование нажмите кнопку Тень [image] , а затем выберите команду Настройка тени.

  3. На панели инструментов Настройка тени выберите любую из кнопок Сдвинуть тень для создания необходимого эффекта.

    Нажатие кнопки Сдвинуть тень сдвигает тень на 1 пункт. Для перемещения тени на 6 пунктов во время нажатия кнопки Сдвинуть тень удерживайте нажатой клавишу SHIFT.


 Удаление объемного эффекта из графического объекта

Удаление объемного эффекта из графического объекта

  1. Выделите графический объект, который необходимо изменить.

  2. На панели инструментов Рисование нажмите кнопку Объем [image] , а затем выберите параметр Нет объема.


 Удаление тени графического объекта

Удаление тени графического объекта

  1. Выделите графический объект, который необходимо изменить.

  2. На панели инструментов Рисование нажмите кнопку Тень [image] , а затем выберите параметр Нет тени.


 Добавление текста к графическому объекту

Добавление текста к графическому объекту

Для добавления "перемещаемого" текста, не привязанного к конкретной ячейке — например, при создании подписи для импортированного рисунка или размещении текста поверх рисунка — воспользуйтесь кнопкой Надпись [image] панели инструментов Рисование. Также можно добавить текст почти во все автофигуры, исключая линии, соединительные линии и полилинии. Чтобы добавить к тексту на листе специальный эффект, воспользуйтесь кнопкой Добавить объект WordArt.

Предполагаемые действия

Добавление текста с помощью кнопки Надпись

Добавление текста в автофигуру

Отображение содержимого ячейки листа в автофигуре или надписи

Добавление фигурного текста


 Изменение параметров отображения текста автофигур или надписей

Изменение параметров отображения текста автофигур или надписей

  1. Выделите текст автофигуры или надписи, для которых необходимы изменения.

  2. Если выбрана автофигура, выполните команду Автофигура меню Формат и перейдите на вкладку Шрифт.

    Если выбрана надпись, выполните команду Надпись меню Формат и перейдите на вкладку Шрифт.

  3. Укажите необходимые параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.


 Задание полей и выравнивание текста автофигуры или надписи

Задание полей и выравнивание текста автофигуры или надписи

Для текста автофигуры — например, выноски или элемента блок-схемы — имеется возможность изменения выравнивания текста, размера объекта в соответствии с размером текста или полей между текстом и краем объекта.

Предполагаемые действия

Выравнивание текста автофигуры или надписи

Автоматический подбор размера автофигуры или надписи в соответствии с размером текста

Изменение полей текста автофигуры или надписи


 Добавление графического объекта WordArt

Добавление графического объекта WordArt

  1. На панели инструментов Рисование нажмите кнопку Добавить объект WordArt [image] .

  2. Дважды щелкните нужный текстовый эффект.

  3. Введите текст, который необходимо отформатировать, в диалоговое окно Изменение текста WordArt, выберите необходимые параметры, а затем нажмите кнопку OK.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  4. Для изменения фигурного текста используйте кнопки на панелях инструментов WordArt и Рисование.


Изменение текста графического объекта WordArt

  1. Щелкните объект WordArt, который требуется изменить.

  2. На панели инструментов WordArt нажмите кнопку Изменить текст.

  3. Внесите необходимые изменения, а затем нажмите кнопку OK.


Задание замещающего текста описания объекта на Web-странице

Замещающий текст появляется в обозревателе Web во время загрузки изображений или при отсутствии картинки. Задайте замещающий текст, если планируется сохранить книгу или лист как Web-страницу.

  1. Выберите графический объект или изображение, к которому будет добавлено текстовое описание.

  2. В меню Формат выберите команду Автофигура или Рисунок, а затем вкладку Web.

  3. Введите требуемый текст в поле Замещающий текст. Текст может быть произвольной длины, но некоторые Web-обозреватели могут отображать только определенное число символов.

Примечание. По умолчанию текст в объекте WordArt используется как замещающий текст.


Отражение графического объекта сверху вниз или слева направо

  1. Выделите объект, который следует отразить.

  2. На панели инструментов Рисование нажмите кнопку Действия, а затем выполните команду Повернуть/отразить.

  3. Чтобы отразить объект относительно горизонтальной оси, выберите команду Отразить сверху вниз.

    Чтобы отразить объект относительно вертикальной оси, выберите команду Отразить слева направо.


 Свободное вращение графического объекта

Свободное вращение графического объекта

  1. Выделите объект, который следует повернуть.

  2. На панели инструментов Рисование нажмите кнопку Свободное вращение [image] .

  3. Перетащите угол объекта в направлении поворота.

  4. Для завершения поворота щелкните за пределами объекта.

Советы

  • Чтобы угол поворота объекта был кратен 15 градусам, при использовании кнопки Свободное вращение удерживайте нажатой клавишу SHIFT.

  • Чтобы повернуть объект вокруг маркера, противоположного используемому, при использовании кнопки Свободное вращение удерживайте нажатой клавишу CTRL.


Поворот графического объекта на 90 градусов влево или вправо

  1. Выделите объект, который следует повернуть.

  2. На панели инструментов Рисование нажмите кнопку Действия, а затем выполните команду Повернуть/отразить.

  3. Чтобы повернуть объект на 90 градусов влево, выберите команду Повернуть влево.

    Чтобы повернуть объект на 90 градусов вправо, выберите команду Повернуть вправо.


Выравнивание и размещение графических объектов

Существует несколько способов выравнивания графических объектов. Они могут быть выровнены относительно других объектов, например относительно центров объектов, их сторон, или относительно ячеек.

Предполагаемые действия

Выравнивание графических объектов относительно других графических объектов

Выравнивание графических объектов относительно ячеек

Размещение графических объектов на равных расстояниях друг от друга


Распределение графических объектов

  1. Выделите графические объекты, которые необходимо распределить.

  2. На панели инструментов Рисование нажмите кнопку Действия, а затем выберите команду Выровнять/распределить.

  3. Для размещения графических объектов на одинаковом расстоянии друг от друга установите флажок Распределить по горизонтали или Распределить по вертикали.


 Перемещение одного или нескольких графических объектов

Перемещение одного или нескольких графических объектов

  1. Выделите графический объект, несколько объектов или группу для перемещения.

    На внедренной диаграмме выделите область диаграммы, щелкнув пустую область между границами диаграммы и областью построения.

  2. Перетащите объект на новое место.

Совет. Чтобы объект перемещался строго по горизонтали или по вертикали, во время его перетаскивания удерживайте нажатой клавишу SHIFT.


Перемещение надписи

  • Выделите надпись и перетаскивайте ее границу.

    Необходимо перемещать границу, а не маркеры изменения размера. При перетаскивании маркера изменения размера будет изменяться форма надписи, в то время как сама надпись будет оставаться на месте.


Сдвиг графического объекта

  1. Выделите графический объект, который необходимо переместить.

  2. На панели инструментов Рисование выберите команду Сдвиг в меню Действия, а затем выберите нужное направление перемещения объекта.

Совет. Также существует возможность сдвига объекта на листе путем его выделения и нажатия клавиш перемещения курсора. Для сдвига объекта маленькими шагами необходимо нажимать клавиши перемещения курсора при нажатой клавише CTRL. Объекты, размещенные на диаграмме, нельзя сдвигать с помощью клавиш перемещения курсора.


 Отключение привязки объектов к ячейкам

Отключение привязки объектов к ячейкам

  1. Выделите графический объект, несколько объектов или группу для изменения.

    На внедренной диаграмме выделите область диаграммы, щелкнув пустую область между границами диаграммы и областью построения.

  2. В меню Формат выполните команду для выбранного типа объекта — например, Автофигура или Выделенная область диаграммы — и перейдите на вкладку Свойства.

  3. Выберите соответствующий параметр в окне группы Привязка объекта к фону.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.


 Группирование графических объектов

Группирование графических объектов

Часто бывает удобно объединить несколько графических объектов в группу и работать с ними, как с одним объектом. При этом можно осуществлять отражение, вращение, а также пропорциональное или непропорциональное изменение размеров сгруппированных объектов. Атрибуты всех объектов в группе изменяются одновременно, например, можно добавить заливку или тень сразу ко всем объектам в группе. При создании сложных рисунков допускается группирование уже существующих групп. В результате образуется сложная иерархия графических объектов. Сгруппированные объекты можно разгруппировать или перегруппировать.

Предполагаемые действия

Группирование графических объектов

Разгруппирование графических объектов

Перегруппировка графических объектов


Изменение порядка графических объектов

По мере добавления на лист или диаграмму объекты автоматически распределяются по слоям. Порядок объектов становится заметен при их перекрытии, когда верхний объект закрывает часть объекта, расположенного ниже. Для создания различных эффектов используйте перекрытие объектов. При этом последовательность рисования объектов не имеет значения, так как относительный порядок объектов в любой момент может быть изменен.

  1. Выделите объект, который следует переместить.

    Если объект скрыт, для его выделения нажмите клавиши TAB или SHIFT+TAB.

  2. На панели инструментов Рисование нажмите кнопку Действия и выберите команду Порядок.

  3. Выберите нужную команду.
    Действие | Действие
    Перемещение объекта на передний план | На передний план
    Перемещение объекта на задний план | На задний план
    Перемещение объекта на один слой вперед | Переместить вперед
    Перемещение объекта на один слой назад | Переместить назад


Типы графических файлов, поддерживаемые Microsoft Excel

В книги Microsoft Excel напрямую или с использованием специальных графических фильтров можно вставлять графические файлы многих распространенных форматов. Специальные графические фильтры не требуется устанавливать для вставки графических файлов следующих форматов: Enhanced Metafile (.emf), Joint Photographic Experts Group (.jpg), Portable Network Graphics (.png), точечный рисунок Windows (.bmp, .rle, .dib), Graphics Interchange Format (.gif), а также метафайл Windows (.wmf). Однако для вставки файлов других графических форматов, перечисленных ниже в этом разделе, необходимо установить соответствующие графические фильтры. Если для файлов какого-либо графического формата фильтр не установлен, запустите программу установки и добавьте недостающий фильтр. Для получения сведений об установке программы или компонента нажмите кнопку [image] .

Примечание. Следующие фильтры устанавливаются только при установке Microsoft Office: Computer Graphics Metafile (.cgm), Enhanced Metafile (.emf), Kodak Photo CD (.pcd), точечный рисунок Windows (.bmp, .rle, .dib), метафайл Windows (.wmf) и WordPerfect Graphics (.wpg).

См. также

Computer Graphics Metafile (.cgm)

CorelDRAW (.cdr)

Encapsulated PostScript (.eps)

Enhanced Metafile (.emf)

Graphics Interchange Format (.gif)

JPEG File Interchange Format (.jpg)

Kodak Photo CD (.pcd)

Macintosh PICT (.pct)

PC Paintbrush (.pcx)

Portable Network Graphics (.png)

Tagged Image File Format (.tif)

Точечные рисунки Windows (.bmp, .rle, .dib)

Метафайлы Windows (.wmf)

WordPerfect Graphics (.wpg)

Hanako (.jsh, jah, и .jbh)

FlashPix (.fpx)

Другие графические фильтры


 Вставка графического объекта

Вставка графического объекта

На лист Microsoft Excel можно вставить картинку, рисунок или сканированную фотографию, импортированные из других программ и файлов. Также можно добавить автофигуры или рисованные графические объекты.

Предполагаемые действия

Дополнительные сведения об использовании графических объектов

Вставка импортированного рисунка или картинки

Вставка рисунка со сканера

Добавление круга, квадрата или другой автофигуры


 Вставка анимированного рисунка в формате GIF на лист

Вставка анимированного рисунка в формате GIF на лист

Для воспроизведения анимированных рисунков в формате GIF следует сохранить книгу или лист как Web-страницу, а затем просмотреть ее в Web-обозревателе.

  1. Перейдите на лист, на который требуется добавить анимированный рисунок в формате GIF.

  2. Выполните одно из следующих действий:

    Для того чтобы вставить рисунок из коллекции клипов, нажмите кнопку Добавить картинку [image] на панели инструментов Рисование, а затем перейдите на вкладку Фильмы.

    Для того чтобы вставить рисунок из файла, откройте в меню Вставка подменю Рисунок и выберите команду Из файла.

  3. Если на шаге 2 была выбрана вкладка Фильмы, щелкните нужный рисунок, а затем нажмите кнопку Вставить клип [image] в появившемся меню.

    Если на шаге 2 была выбрана команда Из файла, найдите и откройте папку, в которой содержится нужный рисунок, а затем дважды щелкните соответствующий файл.

  4. Для того чтобы посмотреть, как будет выглядеть анимированный рисунок в формате GIF, выберите команду Предварительный просмотр Web-страницы в меню Файл.

Примечание. Выполнить обрезку, изменить заливку, границу, тень или прозрачность анимированного рисунка в формате GIF с помощью панели инструментов Настройка изображения или диалогового окна Формат рисунка в Microsoft Excel нельзя. Для внесения изменений в такие рисунки следует воспользоваться соответствующей программой для редактирования анимированных рисунков в формате GIF, а затем снова вставить файл в книгу.


Разгруппирование и изменение картинки

  1. Выберите картинку, которую необходимо изменить.

  2. На панели инструментов Рисование в меню Действия выберите команду Разгруппировать.

  3. Нажмите кнопку Да для подтверждения своих действий.

  4. Для изменения отдельного объекта изображения разгруппировывайте объекты до тех пор, пока необходимый объект не станет доступным.

  5. Измените объект, используя панель инструментов Рисование.

    Например, можно изменить расположение отдельных элементов изображения, совместить несколько изображений или изменить цвет линий и заливки.

  6. Чтобы восстановить отдельные объекты в одном изображении, выберите соответствующие объекты и выполните команду Сгруппировать меню Действия.


 Редактирование рисунка

Редактирование рисунка

  1. Выделите рисунок, который необходимо отредактировать.

  2. Выберите нужные параметры на панели инструментов Настройка изображения.

    Для получения сведений о кнопке панели инструментов выберите команду Что это такое? в меню Справка, а затем щелкните эту кнопку.

Примечание. Выполнить обрезку, изменить заливку, границу, тень или прозрачность анимированного рисунка в формате GIF с помощью панели инструментов Настройка изображения Microsoft Excel нельзя. Для внесения изменений в такие рисунки следует воспользоваться соответствующей программой для редактирования анимированных рисунков в формате GIF, а затем снова вставить файл в книгу.


 Создание прозрачных областей на рисунке

Создание прозрачных областей на рисунке

Прозрачные зоны используются для создания специальных эффектов при размещении рисунка на листе. Например, таким образом можно вставить рисунок человека, сделав невидимым его фоновый цвет.

  1. Выделите рисунок, в котором необходимо создать прозрачные зоны.

  2. На панели инструментов Настройка изображения нажмите кнопку Установить прозрачный цвет [image] .

  3. Выберите нужный цвет.

Примечания

  • Кнопка Установить прозрачный цвет [image] доступна для точечных рисунков, которые еще не содержат прозрачных зон, а также для некоторых, хотя и не для всех, картинок.

  • Прозрачным можно сделать только один цвет. В печатном документе прозрачные зоны имеют тот же цвет, что и бумага, на которой напечатан рисунок, а в электронном документе — тот же цвет, что и фон.

  • Обычно эффект прозрачности слабо проявляется на цветных фотографиях, так как относительное содержание любого цвета на них не велико. То, что кажется одним цветом, например голубое небо, на самом деле оказывается набором разнообразных оттенков.

  • Нельзя изменить прозрачность анимированного рисунка в формате GIF с помощью панели инструментов Настройка изображения Microsoft Excel. Для внесения изменений в такие рисунки следует воспользоваться соответствующей программой для редактирования анимированных рисунков в формате GIF и затем снова вставить файл в книгу.


 Отмена всех изменений, внесенных в рисунок

Отмена всех изменений, внесенных в рисунок

Используйте эту процедуру для отмены любых изменений контраста, цвета, яркости или размера рисунка, сделанных с помощью кнопок на панели инструментов Настройка изображения.

  1. Выделите рисунок, который следует восстановить.

  2. Нажмите на панели инструментов Настройка изображения кнопку Сброс параметров рисунка [image] .


 Восстановление исходных размеров рисунка

Восстановление исходных размеров рисунка

  1. Выделите рисунок, размеры которого следует восстановить.

  2. Выберите команду Автофигура в меню Формат, а затем — вкладку Размер.

  3. Нажмите кнопку Сброс.

Совет. Для восстановления размеров и параметров форматирования рисунка выделите рисунок, а затем нажмите кнопку Сброс параметров рисунка [image] на панели инструментов Настройка изображения.


Отображение данных на карте

Для просмотра этого раздела щелкните рисунок:

Для просмотра этого раздела щелкните рисунок.

Чтобы отобразить сведения этого раздела с помощью клавиатуры, нажмите клавишу F6 для активизации области раздела, клавишей TAB выделите рисунок и нажмите ENTER.


Ввод данных в географическую карту

  1. Чтобы ввести данные нового географического района, вставьте новую строку в диапазон ячеек, уже представленных на карте.

    Инструкции

    Чтобы ввести новый вид сведений для каждого географического района, введите в лист новый столбец, справа от столбца, содержащего географические сведения (например, названия стран или штатов).

    Инструкции

  2. Введите данные в новую строку или столбец.

  3. Если на этапе 1 в лист был вставлен столбец, щелкните дважды карту, а затем выберите команду Данные в меню Вставка. Затем выделите в листе все ячейки, содержащие географические данные и новые данные.

    Если на первом этапе была введена строка, карта будет обновлена автоматически.

Примечание. Если введенные данные не появились на карте автоматически, щелкните карту дважды, а затем убедитесь, что установлен флажок автоматически в окне группы Обновление данных (меню Сервис, команда Параметры в Microsoft Map).


 Добавление кнопки «Карта» на панель инструментов

Добавление кнопки «Карта» на панель инструментов

  1. Выведите на экран панель инструментов, на которую нужно добавить кнопку Карта [image] .

  2. В меню Сервис выберите команду Настройка, а затем откройте вкладку Команды.

  3. Выберите категорию Вставка из списка Категории.

  4. Перетащите строку Карта из списка Команды на панель инструментов.


 Создание географической карты

Создание географической карты

Если кнопка Карта [image] отсутствует на нужной панели инструментов, можно добавить кнопку Карта на панель инструментов.

  1. Чтобы создать географическую карту, на которой будут изображены элементы карты и связанные с ними данные, выделите на листе диапазон ячеек, содержащих географические данные, например названия стран или областей. Для получения наилучших результатов следуйте рекомендациям по настройке данных для создания карты.

    Чтобы получить карту, на которой элементы карты будут изображены без данных, не выделяйте ячейки.

  2. Нажмите кнопку Карта [image].

  3. На листе посредством перетаскивания рамки придайте области карты нужную форму и размеры.

    Если программа Microsoft Map не установлена, на экран выводится приглашение установить ее. Инструкции по установке Microsoft Map.

  4. При выводе приглашения выберите нужную карту.

Примечание. Для получения дополнительных сведений о работе с картами, о картах, входящих в комплект поставки Microsoft Map и дополнительных картах, которые можно приобрести за отдельную плату, дважды щелкните имеющуюся карту, а затем выберите команду Вызов справки в меню ?.


Получение дополнительных справочных сведений о географических картах

Для получения дополнительных сведений о работе с географическими картами — например, об изменении цвета и формата элементов карты, вводе дополнительных подписей или изменении легенды — обратитесь к справочной системе Microsoft Map.

  1. Щелкните дважды имеющуюся карту.

    Чтобы получить сведения о создании географических карт, нажмите кнопку [image] .

  2. В меню Справка выберите справку по Microsoft Map.


Рекомендации по настройке данных для создания карты

Первым этапом создания географической карты является настройка и выбор данных, которые будут изображены на карте.

  • Расположите данные на листе книги в виде столбцов. В одном из столбцов должны быть перечислены географические данные, например, названия стран или областей.

    Лист, содержащий географические данные

  • Если на листе имеются дополнительные данные для каждого элемента карты, например, данные по сбыту для каждой страны, введите эти данные в ячейки, которые будут выделены при создании карты.

  • Если в верхней части столбцов имеются заголовки, их следует включить в выделяемую область.

Советы

  • Правописание и сокращения Чтобы ознакомиться со списком стандартных вариантов написания названий и сокращений географических объектов, обратитесь к книге Mapstats.xls (подпапка Data папки, в которую производилась установка Microsoft Map).

  • Почтовые индексы Если данные содержат цифровые почтовые индексы (например почтовые индексы США), убедитесь в том, что почтовые индексы имеют формат текста или формат почтового индекса. Это позволит избежать удаления нулей, которые могут быть частью почтового индекса.


Разрешение вопросов: графические объекты

В чем именно заключаются сложности?

Внешний вид

Рисунок содержит неровные линии

У графического объекта неравномерные цвета

Не удается выровнять нарисованные полилинии

Текст не отражается и не вращается вместе с графическим объектом

Рисование

Трудно рисовать кривые линии

Перемещение и выделение

Команда Автофигура, Надпись, Рисунок, Объект WordArt или Объект отсутствует в меню Формат

Не удается выполнить повторное группирование рисованных объектов

Запуск макроса при выборе рисованного или графического объекта для перемещения или изменения

Изменение размеров при перемещении объекта и наоборот

Графический или рисованный объект не перемещается вместе с внедренной диаграммой, в которую он был добавлен

Рисованные объекты и импортированная графика не сортируется

Вывод на печать

Не удается напечатать рисунок


Разрешение вопросов: рисунки

В чем именно заключаются сложности?

Импорт

Не удается импортировать рисунок.

Редактирование

Невозможно изменить цвет отдельных областей рисунка.

Невозможно разгруппировать импортированный рисунок.

Невозможно изменить анимированный рисунок в формате GIF.

Перемещение и выделение

Команда Автофигура, Надпись, Рисунок, Объект WordArt или Объект отсутствует в меню Формат menu.

Не удается повернуть рисунок.

Графический или рисованный объект не перемещается вместе с внедренной диаграммой, в которую он был добавлен.

Запуск макроса при выборе рисованного или графического объекта для перемещения или изменения.

Вывод на печать

Не удается напечатать рисунок.


Разрешение вопросов при работе со сканером или фотоаппаратом

В чем именно заключаются сложности?

При попытке добавить отсканированный рисунок или фотографию выдается сообщение

Сканирование занимает слишком много времени

Сканируется слишком большая или слишком малая часть рисунка

Сканированное изображение выглядит иначе, чем требовалось

Не удается добавить отсканированный рисунок или фотографию

При выборе сканера кнопка Insert становится недоступной

При нажатии кнопки Custom Insert ничего не происходит


Разрешение вопросов: добавление границ, заливки, теней и объема к графическим объектам

В чем именно заключаются сложности?

При добавлении к графическому объекту объема исчезает его тень

Граница графического объекта не отображается на экране

После изменения заливки, границы, тени или объема при создании нового объекта все равно восстанавливаются старые настройки

При изменении цвета заливки графического объекта цвет его тени или объема не меняется

Тень графического объекта не сплошная


Разрешение вопросов по выравниванию и расположению графических объектов

В чем именно заключаются сложности?

Взаимное перекрытие графических объектов при выравнивании.

Команды в меню Выровнять/распределить недоступны и не могут быть выбраны.


 Команда "Автофигура", "Надпись", "Рисунок", "Объект WordArt" или "Объект" отсутствует в меню "Формат"

Команда "Автофигура", "Надпись", "Рисунок", "Объект WordArt" или "Объект" отсутствует в меню "Формат"

Команды Автофигура, Надпись, Рисунок, Объект WordArt и Объект можно использовать, если сперва выделить рисованный объект, надпись, импортированную диаграмму, текст WordArt, рисунок или другой форматируемый объект.


 Использование списка в качестве базы данных

Использование списка в качестве базы данных

В Microsoft Excel в качестве базы данных можно использовать список. При выполнении обычных операций с данными, например при поиске, сортировке или обработке данных, списки автоматически распознаются как базы данных. Перечисленные ниже элементы списков учитываются при организации данных.

  • Столбцы списков становятся полями базы данных.

  • Заголовки столбцов становятся именами полей базы данных.

  • Каждая строка списка преобразуется в запись данных.

Просмотр идентифицирующих столбцов, заголовков столбцов и строк


 Рекомендации по созданию списка на листе книги

Рекомендации по созданию списка на листе книги

В Microsoft Excel имеется набор функций, облегчающих обработку и анализ данных в списке. Чтобы использовать эти функции, введите данные в список в соответствии с приведенными ниже рекомендациями.

Организация списка

Использование только одного списка на листе Избегайте создания более чем одного списка на листе. Некоторые возможности управления списком, например фильтрация, могут быть использованы только для одного списка.

Помещайте подобные объекты в один столбец Спроектируйте список таким образом, чтобы все строки содержали подобные объекты в одном столбце.

Держите список отдельно Между списком и другими данными листа необходимо оставить, по меньшей мере, одну пустую строку и один пустой столбец. Это позволяет Excel быстрее обнаружить и выделить список при выполнении сортировки, наложении фильтра или вставке вычисляемых автоматически итоговых значений.

Располагайте важные данные сверху или снизу от списка Избегайте размещения важных данных слева или справа от списка; данные могут быть скрыты при фильтрации списка.

Отображение строк и столбцов Перед внесением изменений в список убедитесь в том, что все скрытые строки и столбцы отображены. Если строки или столбцы списка скрыты, данные могут быть непреднамеренно удалены.

Формат списка

Использование форматированных подписей столбцов Создайте подписи столбцов в первой строке списка. Excel использует подписи при создании отчетов, поиске и оформлении данных. Шрифт, выравнивание, формат, шаблон, граница и формат прописных и строчных букв, присвоенные заголовкам столбцов списка, должны отличаться от формата, присвоенного строкам данных. Перед вводом подписей столбцов ячейкам должен быть присвоен текстовый формат.

Использование границ ячеек Для отделения подписей от данных следует использовать границы ячеек, а не пустые строки или прерывистые линии. Использование рамок в ячейках.

Отсутствие пустых строк и столбцов В самом списке не должно быть пустых строк и столбцов. Это упрощает идентификацию и выделение списка.

Отсутствие начальных и конечных пробелов Дополнительные пробелы в начале и конце ячейки влияют на поиск и сортировку. Вместо ввода пробелов рекомендуется использовать сдвиг текста внутри ячейки.

Расширенный список форматов и формул При добавлении новых строк в конец списка Excel использует согласованные форматы и формулы. Чтобы это произошло, три из пяти предыдущих ячеек должны иметь тот же формат или содержать ту же формулу. Включение расширенного списка форматов и функций.

Дополнительные сведения

Использование списка в качестве базы данных

Дополнение и изменение списка с использованием формы


 Включение и выключение расширения форматов и формул

Включение и выключение расширения форматов и формул

Если расширение форматов и формул включено, новые данные в конце списка форматируются так же, как и предыдущие ряды, а формулы, повторяющиеся в каждой строке, копируются в новую строку. Чтобы форматы и формулы расширялись, они должны появляться, по крайней мере, в трех из пяти вышестоящих строках списка.

  1. Выберите команду Параметры в меню Сервис, а затем — вкладку Правка.

  2. Выполните одно из следующих действий:

    Чтобы автоматически форматировать новые элементы, добавляемые в конец списка, установите флажок Расширять форматы и формулы в списках.

    Чтобы запретить автоматическое форматирование, снимите флажок.


Сортировка списка (возрастающий порядок)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Сортировка списков

Предполагаемые действия

Сортировка строк по возрастанию данных в одном столбце

Сортировка данных по убыванию данных в одном столбце

Сортировка строк по двум или или более столбцам

Сортировка столбцов по содержимому строк

Сортировка месяцев, дней недели или списков, которые требуется отсортировать в порядке, отличном от алфавитного

Сведения о порядке сортировки, который используется по умолчанию

Дополнительные сведения


 Порядок сортировки, используемый по умолчанию

Порядок сортировки, используемый по умолчанию

Для упорядочения ячеек по значениям (без учета формата) в Microsoft Excel предусмотрен определенный порядок сортировки.

При сортировке по возрастанию Excel использует следующий порядок (при сортировке по убыванию этот порядок заменяется на обратный за исключением пустых ячеек, которые всегда помещаются в конец списка):

Числа. Числа сортируются от наименьшего отрицательного до наибольшего положительного числа.

Алфавитно-цифровая сортировка. При сортировке алфавитно-цифрового текста Excel сравнивает значения посимвольно слева направо. Например, если ячейка содержит текст "A100", Excel поместит ее после ячейки, содержащей запись "A1", и перед ячейкой, содержащей запись "A11".

Текст, в том числе содержащий числа, сортируется в следующем порядке:

0 1 2 3 4 5 6 7 8 9 (пробел) ! " # $ % & ( ) * , . / : ; ? @ [ \ ] ^ _ ` { | } ~ + < = > A B C D E F G H I J K L M N O P Q R S T U V W X Y Z А Б В Г Д Е Ё Ж З И Й К Л М Н О П Р С Т У Ф Х Ц Ч Ш Щ Ъ Ы Ь Э Ю Я

Апострофы (') и дефисы (-) игнорируются с единственным исключением: если две строки текста одинаковы, не считая дефиса, текст с дефисом ставится в конец.

Логические значения. Логическое значение ЛОЖЬ ставится перед значением ИСТИНА.

Значения ошибки. Все значения ошибки равны.

Пустые значения. Пустые значения всегда ставятся в конец.


 Поиск данных в списке

Поиск данных в списке

В Microsoft Excel предусмотрены различные методы анализа данных в списке. К списку можно применить фильтр, чтобы отобрать только записи, соответствующие определенным условиям. Для этого служат команды Автофильтр и Расширенный фильтр. Чтобы определить значение из списка по другому значению — например, определить цену для изделия, указанного в списке изделий и цен — можно воспользоваться мастером подстановок.

Предполагаемые действия

Просмотр группы строк списка с помощью фильтров

Поиск значения в списке с помощью мастера подстановок


Способы поиска значений на листе с помощью фильтров(обзор)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Отображение подмножества строк с использованием условий отбора с помощью пользовательского автофильтра

Отображение подмножества строк с использованием условий отбора с помощью пользовательского автофильтра

Чтобы отобрать строки из списка с использованием одного или двух условий отбора для одного столбца, выберите команду Фильтр в меню Данные, затем команду Автофильтр. Нажмите кнопку со стрелкой в столбце, в котором находятся сравниваемые данные, а затем из раскрывающего списка выберите пункт Условие.

  • Чтобы отобразить строки, удовлетворяющие одному условию отбора, выберите необходимый оператор сравнения в первом поле под надписью Показать только те строки, значения которых и значение для сравнения справа от него.

  • Чтобы отобразить строки, удовлетворяющие одновременно двум условиям отбора, введите оператор и значение для сравнения в первой группе полей, установите переключатель И, а затем введите второй оператор и значение для сравнения во второй группе полей.

  • Чтобы отобразить строки, удовлетворяющие одному из двух условий отбора, введите оператор и значение для сравнения в первой группе полей, нажмите кнопку Или, а затем введите второй оператор и значение для сравнения во второй группе полей.

Для получения дополнительных сведений об условиях отбора нажмите [image] .


Удаление фильтра из списка

  • Чтобы удалить фильтр для одного столбца списка, нажмите на кнопку со стрелкой, а затем выберите из развернувшегося списка Все.

  • Чтобы удалить фильтры для всех столбцов списка, выберите пункт Фильтр в меню Данные, а затем — команду Показать все.

  • Чтобы удалить автофильтр из списка, выберите пункт Фильтр в меню Данные, а затем — команду Автофильтр.


Условия отбора автофильтра

Чтобы | Действие
Все строки списка | Все
Заданное число строк с максимальными или минимальными значениями ячеек текущего столбца (например, можно отобразить 10% строк, имеющих максимальные значения суммы покупки) | Первые 10
Строки, удовлетворяющие двум условиям или одному условию с оператором сравнения, отличным от И (оператор по умолчанию) | Условие
Все строки, имеющие пустые ячейки в текущем столбце | Пустые
Все строки, имеющие непустые ячейки в текущем столбце | Непустые

Примечание. Условия Пустые и Непустые можно использовать, только если в столбце содержатся пустые ячейки.


 Фильтрация списка с помощью расширенного фильтра

Фильтрация списка с помощью расширенного фильтра

Чтобы отфильтровать список с помощью расширенного фильтра, столбцы списка должны иметь заголовки. На листе также должно быть не менее трех пустых строк сверху от списка. Эти строки будут использованы в качестве диапазона условий отбора.

  1. Выделите заголовки фильтруемых столбцов списка и нажмите кнопку Копировать [image] .

  2. Выделите первую пустую строку диапазона условий отбора и нажмите кнопку Вставить [image] .

  3. Введите в строки под заголовками условий требуемые критерии отбора. Убедитесь, что между значениями условий и списком находится как минимум одна пустая строка.

    Чтобы ознакомиться с примерами условий отбора, нажмите [image] .

  4. Укажите ячейку в списке.

  5. В меню Данные выберите команду Фильтр, а затем — команду Расширенный фильтр.

    Демонстрация

  6. Чтобы показать результат фильтрации, скрыв ненужные строки, установите переключатель «Обработка» в положение Фильтровать список на месте.

    Чтобы скопировать отфильтрованные строки в другую область листа, установите переключатель «Обработка» в положение Скопировать результаты в другое место, перейдите в поле Поместить результат в диапазон, а затем укажите верхнюю левую ячейку области вставки.

  7. Введите в поле Диапазон условий ссылку на диапазон условий отбора, включающий заголовки столбцов.

    Чтобы убрать диалоговое окно Расширенный фильтр на время выделения диапазона условий отбора, нажмите кнопку свертывания диалогового окна [image] .

Советы

  • Если присвоить диапазону имя Критерии, то ссылка на диапазон будет автоматически появляться в поле Диапазон условий. Можно также определить имя База_данных для диапазона фильтруемых данных и имя Извлечь для области вставки результатов, и ссылки на эти диапазоны будут появляться автоматически в полях Исходный диапазон и Поместить результат в диапазон соответственно.

  • Когда отобранные строки копируются в другое место, можно указать столбцы, включаемые в копию. Перед фильтрованием скопируйте заголовки нужных столбцов в первую строку области вставки результатов. При фильтровании введите ссылку на скопированные заголовки столбцов в поле Поместить результат в диапазон. Скопированные строки будут включать только столбцы, заголовки которых были скопированы.


 Примеры условий отбора расширенного фильтра

Примеры условий отбора расширенного фильтра

В условия отбора расширенного фильтра может входить несколько условий, накладываемых на один столбец, несколько условий, накладываемых на несколько столбцов, а также условия, создаваемые как результат выполнения формулы.

Несколько условий для одного столбца. При наличии для одного столбца двух и более условий отбора введите эти условия отбора непосредственно друг под другом в отдельные строки. Например, следующий диапазон условий отбора отбирает строки, содержащие в столбце «Продавец» значения "Белов", "Батурин" или "Сушкин".

Диапазон из трех условий отбора для одного столбца

Одно условие для нескольких столбцов. Для того чтобы найти в нескольких столбцах данные, отвечающие одному условию отбора, введите все условия отбора в одну строку диапазона условий отбора. Например, следующий диапазон условий отбора возвращает все строки, содержащие значения "Продукты" в столбце «Товар», "Белов" в столбце «Продавец» и объем продаж более 1 000р.

Диапазон условий отбора для трех столбцов

Примечание. Для наложения ограничений на значения в различных столбцах и отображения только нужных строк также можно использовать команду Автофильтр из меню Данные.

Разные условия для разных столбцов. Для того чтобы найти данные, отвечающие одному условию, в одном столбце, или отвечающие другому условию, в другом столбце, ведите условия отбора в разные строки диапазона условий отбора. Например, следующий диапазон условий отбора отображает все строки, содержащие значение "Продукты" в столбце «Товар», "Белов" в столбце «Продавец», либо объем продаж, превышающий 1 000р.

Диапазон условий отбора с условиями ИЛИ

Один из двух наборов условий для дух столбцов. Для того чтобы найти строки, отвечающие одному из двух наборов условий, каждый из которых содержит условия для более чем одного столбца, введите эти условия отбора в отдельные строки. Например, следующий диапазон условий отбора отображает строки, содержащие как значение "Белов" в столбце «Продавец», так и объем продаж, превышающий 3 000р., а также строки по продавцу Батурину с объемами продаж более 1 500р.

Диапазон двух условий отбора для двух столбцов

Условия, создаваемые как результат выполнения формулы. В качестве условия отбора можно использовать вычисляемое значение, являющееся результатом выполнения формулы. При создании условия отбора с помощью формулы не используйте заголовок столбца в качестве заголовка условия; либо оставьте условие отбора без заголовка, либо используйте заголовок, не являющийся заголовком столбца на листе. Например, следующий диапазон условий отбора отображает строки, которые содержат в столбце G значение, превышающее среднее значение ячеек диапазона E5: E14; заголовок условия отбора не используется.

Диапазон условий отбора, использующий формулу

Примечания

  • Формула, используемая для создания условия отбора, должна использовать для ссылки на подпись столбца (например, «Продажи») или на соответствующее поле в первой записи относительную ссылку. Все остальные ссылки в формуле должны быть абсолютными, а формула должна возвращать результат ИСТИНА или ЛОЖЬ. В примере формулы "G5" является ссылкой на поле (столбец G) первой записи (строка 5) списка.

  • При использовании заголовка столбца в формуле условия вместо ссылки или имени диапазона в ячейке будет выведено значение ошибки #ИМЯ? или #ЗНАЧ!. Эту ошибку можно не исправлять, так как она не повлияет на результаты фильтрации.


 Виды условий отбора

Виды условий отбора

При настройке автофильтра или вводе условий отбора в диапазоне условий расширенного фильтра можно использовать перечисленные ниже элементы условий.

Последовательности символов

Чтобы отобрать строки, содержащие ячейки с заданным значением, введите требуемые число, дату, текстовую или логическую константу в ячейку ниже названия столбца диапазона условий. Например, чтобы отобрать строки, в которых индекс отделения связи равен 119136, введите в диапазоне условий число 119136 ниже заголовка «Индекс отделения связи».

При использовании текстовой константы в качестве условия отбора будут отобраны все строки с ячейками, содержащими текст, начинающийся с заданной последовательности символов. Например, при вводе условия Бел будут отобраны строки с ячейками, содержащими слова Белов, Беляков и Белугин. Чтобы получить точное соответствие отобранных значений заданному образцу, например текст, следует ввести следующую формулу:

=''=текст''

Подстановочные знаки

Чтобы отобрать строки с ячейками, содержащими последовательность символов, в некоторых позициях которой могут стоять произвольные символы, следует использовать знаки подстановки. Знак подстановки эквивалентен одному символу или произвольной последовательности символов.

Используется | Чтобы найти
? (знак вопроса) | Любой символ в той же позиции, где указан знак вопроса. Например, для поиска «барин» или «барон» следует ввести «бар?н».
* (звездочка) | Любое количество символов в той же позиции, где указана звездочка. Например, для поиска слов «северо-восток» и «юго-восток» следует указать «*восток».
~ (тильда), за которой следует ?, * или ~ | Знак вопроса, звездочку или тильду. Например, для поиска «ан91?» следует указать «ан~?».

Значения в заданных пределах

Чтобы отобрать строки с ячейками, имеющими значения в заданных пределах, следует использовать оператор сравнения. Условие отбора с оператором сравнения следует ввести в ячейку ниже заголовка столбца в диапазоне условий. Например, чтобы отобрать строки, имеющие значения ячеек большие или равные 1000, введите условие отбора >=1000 ниже заголовка «Количество».

Примечания

  • При вычислениях Microsoft Excel не учитывает регистр букв.

  • В Microsoft Excel подстановочные знаки и операторы сравнения, содержащиеся в начале, середине или конце строки, допустимы только для текстовых значений, но не для числовых.


 Поиск значений в списках

Поиск значений в списках

Мастер подстановок. В списках, содержащих заголовки строк и столбцов, можно выполнять поиск значений. Мастер подстановок помогает найти другие значения в строке, если известно значение в одном столбце, и наоборот.

Например, если имеется список номеров товаров, их описаний и цен, можно быстро найти описание или цену товара, введя соответствующий номер продукта. Необходимая для этого формула создается мастером подстановок.

Результаты формулы мастера подстановок

Поиск значения в списке с помощью мастера подстановок

Формулы. Если для поиска значений в списках требуется создать собственные формулы, в них можно использовать следующие функции.

  • ПРОСМОТР — находит значение в одной строке или одном столбце значений, отсортированных по возрастанию, и возвращает значение из соответствующей позиции другой строки или столбца. Функцию ПРОСМОТР можно использовать для поиска значений в списках, не имеющих заголовков строк или столбцов.

  • ВПР — находит значение в списке с заголовками строк. Функцию ВПР следует использовать в случае, если список включает заголовки строк в левом столбце, и требуется найти значение в другом столбце на основе заголовка строки. По умолчанию перед использованием функции ВПР список должен быть отсортирован.

  • ГПР — находит значение в списке с заголовками столбцов. Функцию ГПР следует использовать в случае, если список включает заголовки столбцов в верхней строке, и требуется найти значение в другой строке на основе заголовка столбца. По умолчанию перед использованием функции ГПР список должен быть отсортирован.

  • Функции ИНДЕКС и ПОИСКПОЗ можно использовать вместе для поиска значения на основе заголовка строки или столбца или обоих заголовков. Функция ИНДЕКС возвращает ссылку на ячейку, находящуюся на пересечении отдельных строки и столбца внутри диапазона, а функция ПОИСКПОЗ находит относительную позицию ячейки внутри диапазона на основе значения, которое требуется найти. В сочетании эти функции возвращают значение на основе заголовка строки или столбца. Функции ИНДЕКС и ПОИСКПОЗ используются в формулах, создаваемых мастером подстановок.

    Дополнительные сведения о функциях ссылок и поиска


 Поиск значения в списке с помощью мастера подстановок

Поиск значения в списке с помощью мастера подстановок

Мастер подстановок является надстройкой; если в подменю Мастер меню Сервис отсутствует команда Подстановка, необходимо установить и загрузить программу надстройки. Чтобы получить дополнительные сведения о надстройках, а также об их установке и загрузке, нажмите кнопку [image] .

  1. Укажите ячейку списка.

  2. В меню Сервис выберите пункт Мастер и выполните команду Подстановка.

  3. Следуйте инструкциям мастера.


 Вставка записей с помощью формы

Вставка записей с помощью формы

  1. Укажите ячейку списка, начиная с которой следует добавлять записи.

  2. В меню Данные выберите команду Форма.

    Демонстрация

  3. Нажмите кнопку Создать.

  4. Введите данные новой записи.

    Используйте клавишу TAB для перемещения к следующему полю формы и сочетание клавиш SHIFT+TAB для перемещения к предыдущему полю.

  5. Чтобы добавить запись в список, нажмите клавишу ENTER.

    По завершении набора последней записи нажмите кнопку Закрыть, чтобы добавить набранную запись и выйти из формы.

Примечания

  • Если поле списка содержит формулу, то в форме выводится ее результат. Изменять это поле в форме нельзя.

  • При добавлении записи, содержащей формулу, результат формулы не будет вычислен до нажатия клавиши ENTER или кнопки Закрыть.

  • Чтобы отменить добавление записи, нажмите кнопку Вернуть перед нажатием клавиши ENTER или кнопки Закрыть.

  • Microsoft Excel автоматически добавляет запись при переходе к другой записи или закрытии формы.


 Изменение записей в списке с помощью формы

Изменение записей в списке с помощью формы

  1. Выделите ячейку в списке, который требуется изменить.

  2. В меню Данные выберите команду Форма.

    Демонстрация

  3. Найдите запись, которую необходимо изменить.

    Инструкции

  4. Измените данные в записи.

    Используйте клавишу TAB для перемещения к следующему полю формы и сочетание клавиш SHIFT+TAB для перемещения к предыдущему полю.

  5. После изменения данных нажмите клавишу ENTER для обновления текущей записи и перехода к следующей записи.

    По завершению изменения записей нажмите кнопку Закрыть для обновления текущей записи и выхода из формы.

Примечания

  • Если поле списка содержит формулу, то в форме выводится ее результат. Изменять это поле в форме нельзя.

  • При изменении записи, содержащей формулу, результат формулы не будет вычислен до нажатия клавиши ENTER или кнопки Закрыть.

  • Чтобы отменить изменения записи, нажмите кнопку Вернуть пока эта запись активна в форме.

  • Microsoft Excel автоматически обновляет запись при переходе к другой записи или закрытии формы.


 Удаление записи с помощью формы

Удаление записи с помощью формы

Внимание! Удаление записи с помощью формы нельзя отменить. Запись удаляется окончательно.

  1. Укажите ячейку списка.

  2. В меню Данные выберите команду Форма.

    Демонстрация

  3. Найдите запись, которую требуется удалить.

    Инструкции

  4. Нажмите кнопку Удалить.


Разрешение вопросов, возникающих при сортировке

Если сортировка не дает требуемых результатов, выполните следующие проверки.

Установленные по умолчанию правила сортировки. В Microsoft Excel данные упорядочиваются по особым правилам сортировки. Для расположения названий месяцев и дней в хронологическом или другом порядке, необходимо создать пользовательский порядок сортировки.

Задание чисел в соответствующем формате. Нарушение порядка сортировки может свидетельствовать о наличии ячейки с текстовым или другим форматом, отличным от числового. Так, при импорте из некоторых бухгалтерских программ отрицательные числа могут восприниматься как текстовые значения. Для задания правильного формата необходимо выбрать ячейку, выбрать пункт Ячейки в меню Формат и открыть вкладку Число. Если ячейка имеет текстовый формат, выберите для нее числовой формат в списке Числовые форматы. После изменения формата необходимо дважды щелкнуть ячейку, повторно ввести в нее нужное значение, а затем нажать клавишу ENTER.

Если диапазон ячеек был отформатирован как текст и был неверно отсортирован, установите числовой формат ячеек, а затем преобразуйте текст в числа с помощью команды Специальная вставка (меню Правка). Для этого введите значение 1 в произвольную пустую ячейку. Скопируйте ячейку со значением 1. Выберите ячейки, для которых требуется изменить формат, а затем выберите команду Специальная вставка в меню Правка и установите переключатель Операция в позицию Умножить.

Проверка того, что смешанные данные имеют текстовый формат. Если предназначенный для сортировки столбец содержит как числа, так и числа с текстом (например, 100, 100а, 200, 200а), все они должны быть отформатированы как текст. В противном случае после сортировки первыми будут располагаться числа, а за ними числа с текстом. Для определения текстового формата выберите пункт Ячейки (меню Формат), откройте вкладку Число и выберите Текстовый в списке Числовые форматы. Чтобы вновь вводимые числа воспринимались как текст, необходимо предварительно определить для соответствующих ячеек текстовый формат.

Правильность форматирования дат и времени. Даты и время рассматриваются в Excel как числа. При вводе распознаваемой программой даты или времени формат ячейки изменяется с общего на встроенный формат даты или времени. Для правильной сортировки данных все представленные в столбце значения даты и времени должны иметь формат даты или времени. Если значение не может быть воспринято как дата, время или число, оно будет отформатировано как текст. Для выбора надлежащего форматирования необходимо выделить соответствующую ячейку, выбрать пункт Ячейки (меню Формат) и открыть вкладку Число). Если ячейка была отформатирована как текст, выберите формат Дата или Время, выберите подходящий тип, нажмите кнопку OK, а затем введите еще раз значение в ячейку с выбранным форматом.

Сортировка отображаемых строк и столбцов. Скрытые столбцы и строки при сортировке не перемещаются. Тем не менее, при сортировке строк данные скрытых столбцов также упорядочиваются, а при сортировке столбцов упорядочиваются данные скрытых строк. Прежде чем приступать к сортировке, следует сделать видимыми скрытые строки и столбцы.

Удаление начальных пробелов. В отдельных случаях импортируемые из других приложений данные могут дополняться слева пробелами. До начала сортировки следует удалить из данных начальные пробелы.

Проверка настроек языка и стандартов. Порядок сортировки зависит от настроек языка. Эти настройки задаются в диалоговом окне Языки и стандарты (панель управления Microsoft Windows). Сведения об изменении данных параметров приводятся в документации по Microsoft Windows.

Ввод заголовков столбцов только в одной строке. Если необходимо использовать заголовки из нескольких строк, установите перенос слов в ячейке.

Параметры графических объектов. См. сведения о сортировке рисованных и импортированных графических объектов вместе ячейками, в которых они расположены.


Получение внешних данных с помощью Microsoft Query

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Доступные базы данных

Доступные базы данных

Драйверы Microsoft Office позволяют получать сведения из следующих источников данных:

  • Microsoft SQL Server OLAP Services (поставщик данных OLAP)

  • Microsoft Access 2000

  • dBASE

  • Microsoft FoxPro

  • Microsoft Excel

  • Oracle

  • Paradox

  • SQL Server

  • Текстовые файлы баз данных

Примечания

  • С помощью средств DAO для Microsoft Visual Basic можно получать данные из Microsoft Exchange или Lotus 1-2-3.

  • Можно использовать драйверы ODBC или драйверы источники данных от других производителей можно получать сведения из других типов баз данных, не перечисленных здесь, включая другие типы баз данных OLAP. Сведения о других драйверах, которые можно получить через корпорацию Майкрософт, см. в файле xlreadme.txt. Для получения сведений об установке драйверов ODBC или драйверов источников данных, не перечисленных здесь или в файле xlreadme.txt, обращайтесь к документации по соответствующей базе данных или к поставщику этой базы данных.


 Получение внешних данных

Получение внешних данных

Чтобы импортировать внешние данные в Microsoft Excel, необходимо:

Доступ к данным Если внешний источник данных. находится на другом компьютере, может возникнуть необходимость узнать у администратора внешней базы данных пароль, получить разрешение пользователя или другие сведения, требующиеся для доступа к базе данных.

Установка Microsoft Query Microsoft Query — это необязательная возможность Excel, которая включает Мастер запросов. Для настройки источника данных или создания запроса в Query необходимо отдельно установить Query.

Установка драйверов ODBC Драйвер ODBC необходим для извлечения данных из реляционных баз данных, текстовых файлов или Excel. При установке Query автоматически устанавливается и набор драйверов ODBC. Список драйверов, устанавливаемых вместе с Query. Если предполагается использование драйвера, который не был установлен с Query, необходимо установить драйвер отдельно.

Установка драйверов источника данных Драйвер источника данных требуется для доступа к источнику данных OLAP. Query поддерживает соединение с базами данных, созданными с помощью Microsoft SQL Server OLAP Services; поэтому при установке Query автоматически устанавливается поддержка этого типа баз данных OLAP. Для соединения с другими базами данных OLAP необходимо установить драйвер источника данных и клиентское программное обеспечение. Поставщики данных куба от третьих производителей.

Примечания

  • Поддержка Microsoft Visual Basic Получение внешних данных с помощью макроса Visual Basic.

  • Web-запросы Внешние данные из узла Web можно получить, не устанавливая Microsoft Query. Для этого нужно иметь доступ к сети World Wide Web через внутреннюю сеть компании или модем, установленный на компьютере или в сети. Кроме того, поставщик услуг доступа к Интернету должен зарегистрировать вас как пользователя. Наконец, требуется или запустить Web-запрос (файл с расширением .iqy), или создать Web-запрос.


Установка Microsoft Query

По умолчанию Microsoft Query устанавливается автоматически при первом использовании команды или компонента, извлекающего внешние данные. Эту процедуру следует использовать, если установка Microsoft Office или Microsoft Excel сделала Microsoft Query недоступным.

  1. Закройте все выполняемые программы.

  2. Нажмите кнопку Пуск, выберите команду Настройка и выберите Панель управления.

  3. Дважды щелкните Установка и удаление программ.

  4. На вкладке Установка/Удаление выберите Microsoft Office 2000 или Microsoft Excel 2000, а затем нажмите кнопку Добавить/Удалить.

  5. В появившемся окне диалога нажмите кнопку Добавить или удалить компоненты.

  6. Нажмите индикатор расширения поле рядом с Средства Office и затем значок рядом с Microsoft Query для выбора требуемого типа установки.

  7. Нажмите кнопку Обновить и следуйте инструкциям для завершения установки.

Примечания

  • Справка по Query Справочная система Microsoft Query автоматически устанавливается при установке самой программы.

  • Доступные источники данных См. сведения о базах данных, к которым можно получить доступ и из которых можно извлекать данные.

  • Извлечение внешних данных См. сведения о том, что необходимо для извлечения внешних данных.


 Установка драйвера ODBC

Установка драйвера ODBC

Все драйверы ODBC, поставляемые корпорацией Майкрософт вместе с Microsoft Query, устанавливаются при установке Query. Для установки этих драйверов следует установить Query на компьютер. См. список драйверов ODBC, устанавливаемых с Query.

Если внешняя база данных, к которой требуется получить доступ, не поддерживается этими драйверами ODBC, необходимо приобрести и установить совместимые с Microsoft Office драйверы ODBC от сторонних поставщиков, например, от производителя соответствующей базы данных. За инструкциями по установке обращайтесь к поставщику базы данных.

Примечание. Для баз данных OLAP драйверы ODBC не требуются. При установке Query устанавливаются драйверы и поддержка, обеспечивающие доступ к базам данных, созданным с помощью Microsoft SQL Server OLAP Services. Для подключения к другим базам данных OLAP необходимо установить драйвер источника данных и клиентское программное обеспечение. См. сведения об установке поставщиков данных для куба от сторонних производителей.


 Указание внешнего источника данных

Указание внешнего источника данных

В этой процедуре внешний источник данных задается с помощью Microsoft Query. Query — дополнительный компонент Microsoft Excel, по умолчанию автоматически устанавливается при первом использовании команды или компонента, извлекающих внешние данные. Если установка Microsoft Office или Microsoft Excel сделала Microsoft Query недоступным, установите Microsoft Query.

  1. Если диалоговое окно Выбор источника данных не отображено, поместите указатель на Внешние данные в меню Данные и выберите Создать запрос.

  2. Выполните одно из следующих действий:

    Чтобы указать источник данных для реляционной базы данных, текстового файла или списка Excel, перейдите на вкладку Базы данных.

    Чтобы указать источник данных куба OLAP, перейдите на вкладку Кубы OLAP.

  3. Дважды щелкните Новый источник данных.

  4. На шаге 1 введите название источника.

  5. На шаге 2 выберите драйвер, соответствующий типу базы, используемой в качестве источника данных.

    Если требуемый тип базы данных отсутствует, установите соответствующий драйвер ODBC или драйвер источника данных.

    Инструкции

  6. Выберите Связь и установите информацию, необходимую для установки соединения с базой данных.

    Для реляционных баз данных, текстовых файлов и списков Excel необходимая информация зависит от типа выбранной базы данных. Может быть задан вопрос об имени пользователя и пароле, версии используемой базы данных, расположении базы данных и т. п.

    Для источника данных Microsoft SQL Server OLAP Services следуйте инструкциям мастера соединения.

  7. После ввода требуемой информации нажмите кнопку OK или Готово для возврата в диалоговое окно Создание нового источника данных.

  8. Если база данных содержит таблицы и необходимо автоматически отображать одну из них в мастере запросов, на шаге 4 щелкните список и выберите требуемую таблицу.

  9. Чтобы не вводить элемент и пароль для доступа к источнику данных, установите флажок Сохранить имя и пароль в определении источника данных. Если флажок недоступен, обратитесь к администратору базы.

    Когда эти шаги выполнены, имя источника данных появится в диалоговом окне Выбор источника данных. Для источников данных OLAP можно дважды щелкнуть имя источника данных и передать данные в Excel. Из других типов источников данных можно извлечь данные с помощью Query.


 Настройка источника данных с использованием драйвера Microsoft Access

Настройка источника данных с использованием драйвера Microsoft Access

  1. Если диалоговое окно Создание нового источника данных не отображено на экране, выберите пункт Внешние данные в меню Данные, а затем — команду Создать запрос. Откройте вкладку Базы данных и дважды щелкните пункт Новый источник данных. Введите имя источника данных в поле 1, а затем выберите Microsoft Access Driver в поле 2.

  2. На шаге 3 создания источника данных нажмите кнопку Связь.

  3. В группе Database нажмите кнопку Select и с помощью диалогового окна Select Database выберите файл базы данных.

    Если требуется, чтобы база данных была открыта в Microsoft Query только для чтения, установите флажок Read only.

    Если необходимо, чтобы при использовании источника данных соответствующая база данных использовалась только Microsoft Query, установите флажок Exclusive.

  4. Нажмите кнопку OK.

    Если база данных требует установки дополнительных параметров подключения, то нажмите кнопку Advanced. Выясните у администратора базы, следует ли изменить какие-либо из этих параметров. Чтобы получить сведения о дополнительных параметрах, нажмите кнопку Cancel, а затем – кнопку Help в диалоговом окне ODBC Microsoft Access Setup.

  5. Если требуется, чтобы Microsoft Query обратился к системной базе данных, выберите параметр Database в группе System database, а затем нажмите кнопку System Database. В диалоговом окне Select System Database укажите файл базы данных и нажмите кнопку OK.

  6. Нажмите кнопку OK и введите имя для входа и пароль в области Authorization. Если для получения доступа к базе данных имя для входа или пароль не используются, то поля области Authorization заполнять не следует.

Примечание. Диалоговое окно ODBC Microsoft Access Setup можно использовать для создания, восстановления и сжатия баз данных Access. Если вы недостаточно хорошо знакомы с этими операциями, следует выполнять их исключительно в Access. Для получения дополнительных сведений обратитесь к справочной системе Microsoft Access.


 Настройка источника данных с использованием драйвера dBASE или FoxPro

Настройка источника данных с использованием драйвера dBASE или FoxPro

Перед тем как выполнять описанные ниже действия, поместите все используемые файлы базы данных в одну и ту же папку, чтобы Microsoft Query мог найти их, и не нужно было бы вводить полный путь всякий раз при добавлении таблицы в запрос. При необходимости можно поместить все файлы баз данных в одну папку, а индексные файлы — в другую.

  1. Если диалоговое окно Создание нового источника данных не отображено на экране, выберите пункт Внешние данные в меню Данные, а затем — команду Создать запрос. Откройте вкладку Базы данных и дважды щелкните пункт Новый источник данных. Введите имя источника данных в поле 1, а затем выберите Microsoft dBase Driver или Microsoft Visual FoxPro Driver в поле 2.

  2. На шаге 3 создания источника данных нажмите кнопку Связь.

  3. Выполните одно из следующих действий:

    Для драйвера Microsoft dBase Driver выберите версию dBASE или FoxPro, использовавшуюся для создания файлов базы данных, из списка Version. Если файлы базы данных находятся не в текущей папке, снимите флажок Use current directory, а затем нажмите кнопку Select Directory для указания папки.

    Для драйвера Microsoft Visual FoxPro Driver выберите соответствующий тип базы данных FoxPro в области Database, а затем введите путь к базе данных в поле Path.

  4. Если индексные файлы базы данных также находятся в другой папке, нажмите кнопку Select Indexes для указания папки.


 Настройка источника данных с использованием драйвера Microsoft Excel

Настройка источника данных с использованием драйвера Microsoft Excel

С помощью драйвера ODBC Microsoft Excel существует возможность обращения к данным только из книг, сохраненных в одной папке. Перед тем как выполнять описанные ниже действия, скопируйте все книги, из которых необходимо одновременно обращаться к данным, в одну папку, и задайте имя для каждого диапазона листа, играющего роль таблицы.

Для каждой папки, из которой будет осуществляться доступ к данным, необходимо настроить отдельный источник данных.

Перед тем как настраивать источник данных или выполнять запрос для получения доступа к данным в книге Excel, закройте книгу в Excel.

  1. Если диалоговое окно Создание нового источника данных не отображено на экране, выберите пункт Внешние данные в меню Данные, а затем — команду Создать запрос. Откройте вкладку Базы данных и дважды щелкните пункт Новый источник данных. Введите имя источника данных в поле 1, а затем выберите Microsoft Excel Driver в поле 2.

  2. На шаге 3 создания источника данных нажмите кнопку Связь.

  3. В поле Version выберите версию, использовавшуюся для создания книги. Если книга была создана в Excel 97, выберите Excel 97-2000. Если книга была создана в Excel 95 (Excel версии 7.0), выберите Excel 5.0/7.0.

  4. Нажмите кнопку Select Workbook, а затем укажите файл книги.


 Настройка источника данных с использованием драйвера Microsoft ODBC для Oracle

Настройка источника данных с использованием драйвера Microsoft ODBC для Oracle

Драйвер Microsoft ODBC для Oracle позволяет подключаться к базам данных Oracle с поддержкой SQL*Net 2.3 (или более поздних версий). Дополнительные сведения об этой поддержке можно найти в документации по Oracle.

Для настройки источников данных, которые используют указанный драйвер, необходимо предварительно установить клиент Oracle и компоненты сетевого программного обеспечения версии 7.3 или более поздней. Эти компоненты можно получить у поставщика программных средств Oracle или в самой корпорации Oracle.

  1. Если диалоговое окно Создание нового источника данных не отображено на экране, выберите пункт Внешние данные в меню Данные, а затем — команду Создать запрос. Откройте вкладку Базы данных и дважды щелкните пункт Новый источник данных. Введите имя источника данных (на первом шаге), а затем выберите Microsoft ODBC for Oracle Driver (на втором шаге).

  2. На шаге 3 создания источника данных нажмите кнопку Подключить.

  3. В окне Базы данных нажмите кнопку Выбрать.

  4. Укажите имя сервера Oracle и другие дополнительные сведения, которые необходимы для подключения к этому серверу. За разъяснениями по этому вопросу можно обратиться к администратору баз данных Oracle. Чтобы получить дополнительные сведения о параметрах настройки, воспользуйтесь в диалоговом окне кнопкой Справка.

  5. Введите имя для входа и пароль, а затем два раза нажмите кнопку OK.


 Настройка источника данных с использованием драйвера Paradox

Настройка источника данных с использованием драйвера Paradox

Перед тем как выполнять описанные ниже действия, поместите все файлы базы данных, которые необходимо использовать вместе, в одну папку, чтобы Microsoft Query мог найти их, и не нужно было бы вводить полный путь всякий раз при добавлении в запрос таблицы.

  1. Если диалоговое окно Создание нового источника данных не отображено на экране, выберите пункт Внешние данные в меню Данные, а затем — команду Создать запрос. Откройте вкладку Базы данных и дважды щелкните пункт Новый источник данных. Введите имя источника данных в поле 1, а затем выберите Microsoft Paradox Driver в поле 2.

  2. На шаге 3 создания источника данных нажмите кнопку Связь.

  3. В поле Version выберите версию Paradox, использовавшуюся для создания файлов базы данных.

  4. Если файлы базы данных находятся не в текущей папке, снимите флажок Use current directory, а затем нажмите кнопку Select Directory для указания местоположения файлов.

  5. Нажмите кнопку Options, если необходимо установить дополнительные параметры базы данных. Чтобы получить сведения о том, следует ли изменять какие либо из этих параметров, обратитесь к администратору базы данных. Для получения информации о значениях параметров нажмите кнопку Help в диалоговом окне ODBC Paradox Setup.


 Настройка источника данных с использованием драйвера Microsoft SQL Server OLAP Services

Настройка источника данных с использованием драйвера Microsoft SQL Server OLAP Services

С помощью этого драйвера может выполняться настройка как находящихся на сервере баз данных, так и автономных файлов куба (*.cub). Последние могут создаваться на основе баз данных Microsoft SQL Server OLAP Services в Microsoft Excel мастером автономного куба либо из записей реляционной базы данных мастером куба OLAP в Microsoft Query. См. сведения об источниках данных OLAP.

  1. Если диалоговое окно Создание нового источника данных не отображено на экране, выберите пункт Внешние данные в меню Данные, а затем — команду Создать запрос. Откройте вкладку Кубы OLAP и дважды щелкните пункт Новый источник данных. Введите имя источника данных, а затем выберите Microsoft OLE DB Provider for OLAP Services.

  2. Нажмите кнопку Подключить на шаге 3 диалогового окна Создание нового источника данных.

  3. На шаге 1 в диалоговом окне Multi-Dimensional Connection выполните одно из следующих действий.

    Чтобы подключиться к находящейся на сервере базе данных, выберите мышью OLAP Server и укажите имя сервера, соответствующее имя пользователя и пароль. Дополнительные разъяснения по подключению к базе данных можно получить у администратора сервера.

    Чтобы подключиться к автономному кубу, щелкните мышью DCube file и задайте путь к файлу (.cub) в поле File.

  4. Выполните одно из следующих действий:

    В случае подключения к автономному кубу нажмите кнопку Готово.

    В случае подключения к базе данных на сервере нажмите кнопку Далее, и выберите нужную базу данных. Нажмите кнопку Готово. На четвертом шаге в диалоговом окне Создание нового источника данных укажите имя базы данных куба, которая будет использоваться в качестве источника.


 Настройка источника данных с использованием драйвера для текстовых файлов

Настройка источника данных с использованием драйвера для текстовых файлов

Следует настроить отдельный источник данных для каждой папки, содержащей текстовые файлы, из которых требуется получать данные. Если необходимо использовать один источник данных для одновременного доступа более чем к одному текстовому файлу, то перед тем как выполнять описанные ниже действия, скопируйте все файлы в одну папку.

  1. Если диалоговое окно Создание нового источника данных не отображено на экране, выберите пункт Внешние данные в меню Данные, а затем — команду Создать запрос. Откройте вкладку Базы данных и дважды щелкните пункт Новый источник данных. Введите имя источника данных в поле 1, а затем выберите Microsoft Text Driver в поле 2.

  2. На шаге 3 создания источника данных нажмите кнопку Связь.

  3. Если текстовые файлы находятся не в текущей папке, снимите флажок Use current directory, а затем нажмите кнопку Select Directory для указания папки.

Примечания

  • Существует возможность доступа к данным в текстовых файлах разных форматов, включая формат с данными в столбцах, разделенных пробелами, запятыми или символами табуляции. Для получения дополнительных сведений о форматах текстовых файлов, которые допускается использовать, нажмите кнопку Help в диалоговом окне ODBC Text Setup.

  • Драйвер для текста позволяет создавать запрос для выбора требуемых данных из текстового файла. Кроме того, можно импортировать весь текстовый файл в качестве диапазона внешних данных, допускающего обновление, без создания источника данных или запроса.


 Настройка источника данных с использованием драйвера SQL Server

Настройка источника данных с использованием драйвера SQL Server

  1. Если диалоговое окно Создание нового источника данных не отображено на экране, выберите пункт Внешние данные в меню Данные, а затем — команду Создать запрос. Откройте вкладку Базы данных и дважды щелкните пункт Новый источник данных. Введите имя источника данных в поле 1, а затем выберите SQL Server в поле 2.

  2. На шаге 3 создания источника данных нажмите кнопку Связь.

  3. В поле Server введите имя сервера Microsoft SQL Server, расположенного в сети. Для получения сведений о доступных для настройки параметрах сервера, указанного в поле Server, нажмите кнопку Help.

  4. Нажмите кнопку Options и установите любые другие параметры, необходимые для базы данных. Чтобы получить сведения о том, следует ли изменять какие-либо из этих параметров, обратитесь к администратору базы данных. Для получения информации о значениях параметров нажмите кнопку Help.

  5. Введите имя для входа и пароль, а затем дважды нажмите кнопки OK.


 Источники данных OLAP для отчетов сводных таблиц и сводных диаграмм

Источники данных OLAP для отчетов сводных таблиц и сводных диаграмм

Microsoft Excel включает клиентское программное обеспечение, позволяющее работать с данными из баз данных OLAP посредством создания и использования отчетов сводных таблиц и сводных диаграмм. Данный раздел содержит описание процедуры настройки источников данных, являющихся сохраненными наборами данных, используемых Excel для доступа к исходным данным OLAP для отчетов.

Данный раздел содержит следующие сведения:

Необходимое программное обеспечение и компоненты

Создание источника данных

Создание собственного куба OLAP

Дополнительные сведения

Необходимое программное обеспечение и компоненты

Microsoft Query. Для настройки источников данных OLAP для Excel используется Microsoft Query, инструмент общего назначения, предназначенный для установления подключения к внешним базам данных и создания запросов для извлечения данных. Microsoft Query входит в состав дополнительных компонентов Microsoft Office. См. Установка Microsoft Query.

Поставщик данных для куба OLAP. Также необходимо наличие одного из следующих поставщиков данных для куба OLAP:

  • Поставщик данных для куба производства корпорации Майкрософт. Excel включает драйвер источника данных и клиентское программное обеспечение, необходимые для доступа к базам данных, созданным с использованием OLAP-продукта Майкрософт, Microsoft SQL Server OLAP Services.

  • Поставщики данных для куба от сторонних производителей. При использовании других продуктов, обеспечивающих возможность работы с данными OLAP, необходимо установить дополнительные драйверы и клиентское программное обеспечение. Для использования возможностей отчетов сводных таблиц и сводных диаграмм Excel при работе с данными OLAP продукты сторонних производителей должны соответствовать стандарту OLE-DB для OLAP и быть совместимыми с Office. Для получения сведений об установке и использовании поставщиков данных OLAP от сторонних производителей обратитесь к системному администратору или поставщику OLAP-продукта.

Серверные базы данных и файлы кубов. Включенное в Excel клиентское программное обеспечение для работы с данными OLAP поддерживает подключение к двум типам источников данных OLAP. Если в сети доступна база данных на сервере OLAP, можно извлечь исходные данные непосредственно из нее. В случае, если имеется файл автономного куба, содержащий данные OLAP, или файлопределения куба, можно подключиться к этому файлу и извлечь исходные данные с его помощью.

Возврат в начало

Создание источника данных

Для подключения к данным OLAP в Microsoft Query создается источник данных. Источник данных предоставляет сведения, необходимые Excel для подключения к базе данных OLAP или файлу, включая имя и местоположение базы данных или файла, драйвер, используемый для подключения, и любую дополнительную информацию, необходимую для работы с базой данных.

Как работает источник данных OLAP. Источник данных предоставляет доступ ко всем данным в базе данных OLAP или файле автономного куба, что исключает необходимость создания запроса для выбора данных в Microsoft Query. После создания источника данных OLAP можно создавать отчеты, основанные на этом источнике, однако данные OLAP могу быть возвращены в Excel только в форме отчета сводной таблицы или сводной диаграммы, но не в виде диапазона внешних данных.

Способы создания источника. Источник данных можно создать при использовании мастера сводных таблиц и диаграмм или с помощью Microsoft Query, а затем этим источником можно воспользоваться при создании отчетов в Excel. При создании источника данных для него можно указать базу данных, находящуюся на сервере, или файл автономного куба. Если источник данных создается для прямого подключения к файлу автономного куба, то этот источник данных может не обеспечивать доступ к исходной серверной базе данных, на основе которой был создан файл автономного куба. Для получения сведений об исходном источнике и данных, содержащихся в нем, обратитесь к лицу, предоставившему вам файл автономного куба.

Чтобы запустить Microsoft Query для создания источника данных, выберите пункт Получить внешние данные в меню Данные, а затем — команду Создать запрос. Для получения сведений о процедуре создания источника данных OLAP обратитесь к справочной системе Microsoft Query.

Возврат в начало

Создание собственного куба OLAP

Пользователи, имеющие опыт управления базами данных и организации доступа к ним, могут воспользоваться предоставляемыми Excel возможностями для создания собственных кубов OLAP и работы с ними. Для создания собственных кубов необходимо наличие поставщика данных для куба, поддерживающего такую возможность, например Microsoft SQL Server OLAP Services.

Создание файлов автономных кубов на основе данных OLAP. На основе отчета сводной таблицы или сводной диаграммы, включающего внешние данные из серверной базы данных OLAP, можно создать собственный файл автономного куба (.cub), содержащий набор данных, полученных с сервера (или все данные, если для их извлечения имеется достаточное дисковое пространство). При хранении на локальном диске файл .cub позволяет продолжать работу с данными при отключении от сети или недоступности сервера. После создания файла .cub можно обновлять его при изменении серверной базы данных; при работе с отчетом можно переключаться с файла куба на серверную базу данных.

Для использования файла автономного куба не требуется создавать отдельный источник данных, однако сохранение файла на сетевом диске даст возможность другим пользователям создавать источники данных для доступа к файлу и отчеты на его основе. Некоторые поставщики данных для куба от сторонних производителей могут не поддерживать создание файлов автономных кубов; в этом случае команды, предназначенные для создания файлов, будут недоступны. См. сведения о создании файлов автономных кубов.

Кубы, создаваемые на основе реляционных баз данных. Также имеется возможность создания собственного куба OLAP или файла автономного куба на основе данных, полученных из реляционной базы данных, например Microsoft SQL Server. Создание куба OLAP может обеспечить более эффективный доступ к большим объемам реляционных данных и организацию данных для использования их в отчетах. Для создания и использования этого типа куба не требуется наличие серверного продукта OLAP.

Для создания куба такого типа прежде всего необходимо настроить источник данных для реляционной базы данных и создать в Microsoft Query запрос для извлечения данных, а затем запустить мастер создания куба OLAP в Microsoft Query для определения структуры данных и, при необходимости, сохранения файла автономного куба (.cub). По завершении этого процесса в вашем распоряжении появится файл определения куба (.oqy), который можно открыть в Microsoft Excel для создания отчета сводной таблицы. Для этого куба OLAP не требуется настраивать отдельный источник данных. См. сведения о файлах .oqy и о создании куба OLAP на основе полученных данных.

Возврат в начало

Дополнительные сведения

Использование Microsoft Query

Создание отчетов сводных таблиц и сводных диаграмм на основе исходных данных OLAP

Использует ли отчет сводной таблицы или сводной диаграммы данные OLAP

Возврат в начало


 Установка поставщиков данных для куба

Установка поставщиков данных для куба

Для подключения к СУБД сторонних производителей, предоставляющих данные и службы OLAP, необходимо установить дополнительные драйверы источников данных и клиентское программное обеспечение.

Для получения дополнительных сведений об установке и использовании поставщиков данных для куба от сторонних производителей обращайтесь к системному администратору или к поставщику соответствующего продукта OLAP. После установки поставщика можно настроить источники данных в Microsoft Query для доступа к базам данных этого поставщика.

Для того чтобы использовать средства Microsoft Office для работы с данными OLAP, продукт стороннего производителя должен быть совместим с Office. Продукт стороннего производителя может поддерживать или не поддерживать создание файлов автономного куба и работу с ними. Проверить наличие такой поддержки можно путем создания в Microsoft Excel отчета сводной таблицы, отображающего исходные данные из базы данных стороннего производителя. Если поставщик не поддерживает файлы автономного куба, то в отчете сводной таблицы команда Настройка «клиент-сервер» из меню Сводная таблица (панель инструментов Сводная таблица) будет недоступна.


 Создание файла .oqy для соединения с базой данных OLAP

Создание файла .oqy для соединения с базой данных OLAP

  1. Создайте новый источник данных, который использует требуемое имя файла .oqy в качестве имени источника данных.

  2. В диалоговом окне Выбор источника данных выберите Параметры на вкладке Кубы OLAP для определения имени папки, в которой был создан файл .oqy. Стандартная папка — это папка профилей пользователя в папке Application Data\Microsoft\Queries.

Примечания

  • Когда используется команда Открыть в меню Файл Microsoft Excel для открытия файла .oqy, Excel отображает лист с пустым отчетом сводной таблицы для данных OLAP. Этот отчет можно использовать для отображения требуемых данных и затем сохранить в файле книги Excel. Отображение данных в отчете сводной таблицы.

  • Для создания файла .oqy, который соединяется с файлом куба или определяет куб, созданный из результатов запроса, можно использовать также мастер куба OLAP в Microsoft Query. Создание куба OLAP по результатам выполнения запроса.


 Указание способа обновления исходных данных OLAP для сводной таблицы или отчета сводной диаграммы

Указание способа обновления исходных данных OLAP для сводной таблицы или отчета сводной диаграммы

Если неизвестен способ создания куба: с помощью мастера куба OLAP или другим способом, обратитесь к лицу, от которого были получены сводная таблица, отчет сводной диаграммы или файл .oqy.

Предполагаемые действия

Обновление данных с сервера OLAP или файла автономного куба

Поскольку новые данные выбираются всякий раз когда изменяется отчет, основанный непосредственно на исходных данных с сервера базы данных OLAP, обычно нет необходимости обновлять данные после открытия отчета.

Обновление автономного файла куба из исходной базы данных OLAP

Повторное соединение с исходной базой данных OLAP после использования файла автономного куба

Повторное соединение с файлом автономного куба после использования исходной базы данных OLAP

Работа с файлами автономного куба

Обновление данных из источника данных мастера куба OLAP

Обновление куба из исходной реляционной базы данных

Работа с источниками данных мастера куба OLAP


 Копирование исходных данных OLAP для автономного использования

Копирование исходных данных OLAP для автономного использования

Данный раздел содержит описание процедур создания и работы с файлами автономных кубов. Для создания этих файлов необходимо наличие поставщика данных для куба, например Microsoft SQL Server OLAP Services, поддерживающего такую возможность. Чтобы освоить и использовать эту возможность Microsoft Excel, необходимо иметь опыт управления базами данных и организации доступа к внешним данным для отчетов сводных таблиц или сводных диаграмм. См. сведения об источниках данных OLAP.

Что такое файл автономного куба?

Использование мастера автономного куба

Работа с файлом автономного куба

Дополнительные сведения

Что такое файл автономного куба?

Если имеется отчет сводной таблицы или сводной диаграммы, основанный на исходных данных из базы данных OLAP на сервере, можно скопировать исходный данные в отдельный файл, называемый файлом автономного куба (.cub), на локальном диске. С помощью этого файла можно вносить в отчет изменения при отключении от сети или при недоступности сервера OLAP. Этот файл можно также использовать для того, чтобы сделать данные из базы данных OLAP доступными на сетевом диске, с тем чтобы другие пользователи могли создавать отчеты на их основе.

Баланс между быстрым доступом к данным и использованием дискового пространства. При частом изменении отчетов использование файла автономного куба может ускорить внесение изменений, особенно если сетевое подключение к серверу OLAP работает медленно. Однако базы данных OLAP часто имеют очень большие размеры, поэтому следует уделять особое внимание выбору данных, помещаемых в файл автономного куба. Первоначальное сохранение большого файла автономного куба может занять значительное время.

Доступность возможностей файла автономного куба. Наличие возможности создания и использования файлов автономных кубов зависит от того, поддерживается ли она поставщиком данных для куба. Поддержка, обеспечиваемая Excel для баз данных Microsoft SQL Server OLAP Services, включает поддержку создания файлов автономных кубов, однако другие поставщики данных для кубов OLAP могут ее не иметь. Если используемый поставщик данных для куба не позволяет создавать файлы автономных кубов, команда Настройка клиент-сервера в меню Сводная таблица (панель инструментов Сводные таблицы) будет недоступна в отчетах, основанных на базах данных OLAP поставщиков данных от сторонних производителей (для использования этой команды в отчете сводной диаграммы следует обратиться к связанному отчету сводной таблицы). Для получения дополнительных сведений обратитесь к поставщику соответствующего продукта.

Для некоторых типов внешних не-OLAP исходных данных файл автономного куба можно создать, запустив соответствующий мастер в Microsoft Query. См. сведения о создании файла автономного куба на основе реляционной базы данных.

Возврат в начало

Использование мастера автономного куба

Для создания файла автономного куба в Excel используется мастер для пошагового выполнения процесса выбора подмножества данных в базе данных OLAP и сохранения этого подмножества в отдельном файле. Данный раздел содержит описание шагов мастера.

Подготовка к запуску мастера. Для запуска мастера автономного куба необходимо прежде всего создать отчет сводной таблицы или отчет сводной диаграммы, основанный на исходных данных из серверной базы данных OLAP, а затем создать файл автономного куба на основе этого отчета.

В отчете не обязательно должны отображаться все поля, которые требуется включить в файл. Мастер позволяет выбрать данные из всех измерений и полей данных, доступных в базе данных OLAP. Тем не менее, чтобы сохранить размер файла минимальным, следует включить в него только те данные, которые необходимо отобразить в отчете. В то же время проследите, чтобы в отчет были включены все необходимые поля. См. Использование мастера автономного куба.

При нажатии кнопки Готово мастер сохраняет файл автономного куба и переключает отчет к файлу вместо серверной базы данных. Размер файла и количество времени, необходимое для его сохранения, зависят от объема выбранных данных, выбранных для включения в файл. Если неизвестно, какой объем данных доступен в базе данных OLAP, обратитесь к системному администратору.

Возврат в начало

Работа с файлом автономного куба

Обновление файла автономного куба. После создания файла автономного куба можно обновлять файл для извлечения новых или измененных данных из исходной базы данных OLAP, если используемый поставщик данных для куба поддерживает такую возможность. См. Обновление файла автономного куба.

Переключение между сервером и файлом автономного куба. Если файл куба используется для автономной работы, то потом можно снова подключить отчет к серверной базе данных OLAP. Если впоследствии вновь требуется работать автономно, создавать новый файл автономного куба не требуется. Следует переключить отчет на файл автономного куба и при необходимости обновить файл.

Изменение содержимого файла автономного куба. Если требуется создать отчет сводной таблицы или сводной диаграммы, основанный на других данных из серверной базы данных OLAP, можно изменить файл автономного куба. Изменение файла приводит к изменению исходных данных, которые файл может предоставить для создаваемых отчетов, а также влияет на все отчеты, основанные на этом файле автономного куба.

Возврат в начало

Дополнительные сведения

Создание отчетов сводных таблиц на основе исходных данных OLAP

Использует ли отчет сводной таблицы или сводной диаграммы данные OLAP

Удаление файла автономного куба

Возврат в начало


 Создание куба OLAP на основе реляционных данных

Создание куба OLAP на основе реляционных данных

Данный раздел описывает создание куба OLAP на основе данных во внешней реляционной базе данных, например Microsoft Access или Microsoft SQL Server, для использования в отчете сводной таблицы или сводной диаграммы. Для создания и использования этого типа куба OLAP не требуется серверный продукт OLAP. Чтобы освоить и использовать эту возможность Microsoft Excel, необходимо иметь опыт управления базами данных и организации доступа к внешним данным для отчетов сводных таблиц и сводных диаграмм с использованием Microsoft Query.

Что такое куб OLAP?

Электронная аналитическая обработка данных (On-Line Analytical Processing — OLAP) — это способ организации данных в соответствии с методами анализа и управления ими, снижающий затраты времени и усилий на создание необходимых отчетов. При создании куба OLAP из запроса набор записей преобразуется в упорядоченную структуру, или куб, позволяющий сфокусировать отчеты на требуемом уровне детализации. Также выполняется предварительное определение итоговых значений для отчетов, что увеличивает скорость вычислений.

Создание куба OLAP следует выполнять в случае, если требуется работать с большим объемом внешних данных в отчетах, особенно при необходимости анализа числа записей большего, чем позволяют вернуть в Excel системные ресурсы. Поскольку куб позволяет Excel извлекать только данные, которые требуются для текущего просмотра отчета, создание и обновление отчета для больших объемов данных обычно происходит быстрее, чем при извлечении полного набора записей из базы данных.

Данные из куба OLAP могут быть возвращены в Excel только в виде отчета сводной таблицы или сводной диаграммы, в отличие от записей реляционных баз данных в запросе, которые могут быть возвращены в Excel также в виде диапазона внешних данных листа.

См. сведения об исходных данных OLAP для отчетов сводных таблиц и сводных диаграмм.

Создание и работа с кубом OLAP

Создание кубов OLAP для записей реляционных баз данных выполняется с помощью Microsoft Query, программы, которая извлекает данные для их последующего использования в Microsoft Excel. Для получения подробных сведений и инструкций обратитесь к справочной системе Microsoft Query. См. Установка Microsoft Query.

Создание куба OLAP. Чтобы создать куб OLAP, прежде всего необходимо создать запрос в Microsoft Query. Начать создание запроса можно из мастера сводных таблиц и сводных диаграмм или запустив Microsoft Query непосредственно из Microsoft Excel. После создания запроса, включающего все поля, которые требуется использовать в кубе OLAP, следует запустить мастер куба OLAP для создания самого куба. Для получения подробных сведений об использовании этого мастера обратитесь к справочной системе мастера создания куба OLAP.

Данный мастер позволяет создавать два типа кубов. Первый тип представляет собой определение куба, которое мастер сохраняет в файле .oqy. При открытии отчета, основанного на этом типе файла .oqy, выполняется построение временного куба в памяти. Второй тип — это отдельный файл автономного куба, хранящийся на локальном диске или сетевом ресурсе. Если этот файл хранится на локальном диске, он позволяет продолжать работу с данными при отключении от сети. Можно установить файл автономного куба в качестве источника данных для отчетов. Чтобы выбрать, какой тип куба следует создать, обратитесь к справочной системе мастера куба OLAP.

Сохранение файла определения куба. Независимо от того, сохраняется ли отдельный файл автономного куба или нет, мастер сохраняет файл определения куба (.oqy). Этот файл содержит информацию, необходимую Excel для построения куба в памяти или подключения к файлу автономного куба, если он создан.

Использование файла определения куба для создания отчетов. Вместо возврата записей, содержащихся в запросе, в Microsoft Excel, можно открыть в Excel файл запроса .oqy для создания отчета сводной таблицы, основанного на кубе OLAP. Затем можно сохранить отчет сводной таблицы в книге или создать отчеты сводных диаграмм, основанные на отчете сводной таблицы.

Обновление куба OLAP. При обновлении отчета, основанного на кубе OLAP, новые и измененные данные из исходной базы данных добавляются в куб, если он является временным кубом, созданным в памяти. Если куб представляет собой файл автономного куба, выполняется обновление с добавлением новых данных и замещением старого файла.

Изменение куба OLAP. Можно изменить куб OLAP, созданный с помощью мастера создания куба, для изменения способа организации данных или удаления полей, которые не требуется использовать в отчетах. Для получения подробных сведений обратитесь к справочной системе Microsoft Query.

После создания куба OLAP в Microsoft Query дополнительные поля из исходной реляционной базы данных добавить в куб нельзя. Тем не менее, можно использовать тот же запрос для создания нового куба OLAP, включающего другие поля. Если вероятно, что необходимость в этом возникнет, сохраните файл запроса к базе данных (.dqy) при создании запроса в Microsoft Query. После этого можно будет открыть файл запроса и запустить мастер создания куба OLAP для создания нового куба, включающего дополнительные поля из исходной базы данных. Для получения сведений о сохранении и открытии файлов запросов обратитесь к справочной системе Microsoft Query.


 Создание файла автономного куба по исходным данным для отчета сводной таблицы или сводной диаграммы

Создание файла автономного куба по исходным данным для отчета сводной таблицы или сводной диаграммы

Эта процедура может быть использована для создания файла автономного куба только для отчетов, основанных на данных из базы данных OLAP . Если отчет использует другой тип исходных данных или поставщик данных для куба не поддерживает создание файлов автономного куба, команда Настройка клиент-сервера в меню Сводная таблица (панель инструментов Сводная таблица) недоступна. Однако для некоторых типов внешних не-OLAP исходных данных возможно создание файла автономного куба с помощью мастера в Microsoft Query.

  1. Щелкните отчет сводной таблицы, для которой будет создаваться файл автономного куба.

    Для отчета сводной диаграммы щелкните связанный отчет сводной таблицы.

  2. На панели инструментов Сводные таблицы выберите меню Сводная таблица и далее — Настройка "клиент-сервер".

  3. Выполните одно из следующих действий:

    Если файл автономного куба для отчета еще не создавался, выберите Создать локальный файл данных.

    Если файл автономного куба существует, выберите Локальный файл данных, а затем — Изменить файл.

  4. Следуйте инструкциям мастера автономного куба по выбору данных, указанию имени и положения файла.

    Инструкции

  5. После завершения сохранения файла мастером отчет связан с файлом. Снова появляется диалоговое окно Настройка "клиент-сервер". Чтобы вернуться в отчет, нажмите кнопку OK.

Примечания

  • Чтобы отменить сохранение файла, нажмите кнопку Остановить в диалоговом окне создания файла куба.

  • Если изменились исходные данные в базе данных на сервере OLAP, можно обновить файл автономного куба.

  • После завершения этой процедуры отчет извлекает исходные данные из файла автономного куба. Если необходимо возобновить использование исходной базы данных OLAP для извлечения данных для отчета, можно заново подключиться к исходной базе данных.


 Включение в файл автономного куба других данных

Включение в файл автономного куба других данных

Эту процедуру следует использовать для файла автономного куба, который был создан в Microsoft Excel. Если нет уверенности в том, что изменяемый куб OLAP был создан в Microsoft Excel или в Microsoft Query, используя мастер куба OLAP, проконсультируйтесь со специалистом, создававшим файл автономного куба, отчет сводной таблицы, или файл .oqy. Инструкции по изменению содержимого и параметров куба или файла автономного куба, который был создан с помощью мастера куба OLAP.

До внесения изменений в файл автономного куба убедитесь, что существует соединение с сетью и вам доступен сервер базы данных OLAP, которая снабжает файл автономного куба данными.

  1. Щелкните отчет сводной таблицы, который основывается на изменяемом файле автономного куба.

    Для отчета сводной диаграммы щелкните связанный отчет сводной таблицы.

  2. На панели инструментов Сводные таблицы выберите Сводная таблица и далее нажмите кнопку Настройка "клиент-сервер".

  3. Нажмите кнопку Локальный файл данных и далее вызовите Изменить локальный файл данных.

  4. Следуйте указаниям мастера автономных кубов для выбора данных для файла. На последнем шаге укажите тоже самое имя и путь, как и у изменяемого файла.


 Удаление файла автономного куба

Удаление файла автономного куба

Удаление файла автономного куба (.cub) необратимо удаляет его с диска, на котором он был сохранен, и освобождает дисковое пространство, использованное этим файлом (зачастую довольно значительное).

Если необходимо продолжать работу с отчетами, использующими файл автономного куба, можно заново подключить отчеты к исходной базе данных OLAP. Однако если для файла автономного куба был создан источник данных и этот источник был использован для построения отчетов непосредственно по файлу автономного куба, эти отчеты не могут быть повторно подключены к исходной базе данных и не могут быть больше изменены.

  • В Microsoft Windows найдите и удалите файл .cub.


 Использование мастера автономного куба

Использование мастера автономного куба

Этот раздел содержит информацию об использовании мастера автономного куба для определения содержимого файлов автономного куба. Этот мастер предназначен для пользователей, которые знакомы с управлением базами данных и доступом к внешним данным из Microsoft Excel. Запуск мастера автономного куба. Создание файлов автономного куба.

Шаг 1 включает обзор мастера.

Шаг 2: Выбор измерений и уровней

Выбор измерений На шаге 2 показываются все доступные на сервере измерения куба. Можно выбрать Поле плюс поле, расположенное рядом с измерением, для просмотра уровней в иерархическом порядке от высшего к низшим. Если измерение не должно быть включено в файл, флажок должен быть сброшен.

Выбор уровней внутри измерений В пределах измерения с помощью установки флажков можно указать уровни детализации, которые должны быть включены в файл. Чем больше измерений и уровней включено, тем больше будет файл автономного куба, особенно при включении нижних уровней, для которых объем подробной информации может быть существенно больше, чем для верхних уровней.

Можно отбросить нижние уровни, но нельзя пропустить уровни внутри измерения. Например, в географическом измерении имеются уровни «Страна», «Регион» и «Город». Если в файл включен уровень «Город», то уровни «Регион» и «Страна» не могут быть опущены. Однако в отчетах, построенных по файлу автономного куба, можно сосредоточить внимание на уровне «Город» и скрыть данные уровня «Регион».

Шаг 3: Выбор полей данных и дальнейшее уточнение сведений об измерениях

На шаге 3 выполняются две задачи: выбор полей, содержащих обобщенные данные для отчета, и выбор элементов данных, которые нужно получать с верхнего уровня каждого измерения.

Выбор полей данных Первый элемент экрана Меры содержит перечень типов обобщенных значений, которые предоставляет сервер OLAP. Эти поля становятся полями данных в сводной таблице или отчете сводной диаграммы. Например, сервер OLAP может содержать меры «Доход от продаж» для обобщения всех данных продаж, «Объемы продаж» для подсчета всех продаж каждого изделия и т. п. Выберите Поле плюс поле рядом с Меры для просмотра всех соответствующих доступных элементов. Необходимо выбрать по крайней мере один такой элемент. Чем больше их выбрано, тем больше будет файл автономного куба.

Выбор элементов для измерений В списке мер представлены измерения, выбранные на предыдущем шаге. Выберите Поле плюс поле рядом с измерением для просмотра всех элементов на верхнем уровне измерения. Например, если верхним уровнем географического измерения является «Страна», можно увидеть Канада, Мексика, США и т. п. Для удаления элемента из файла, сбросьте соответствующий флажок. Удаление элемента из файла пропускает все данные для элемента на всех уровнях, что приводит к уменьшению размера файла автономного куба.

Если список на шаге 3 не включает все требуемые измерения, вернитесь к шагу 2 и выберите измерения.

Шаг 4: Присвоение и имени и размещение файла

На шаге 4 сохраняется файл автономного куба. Предполагаемое расширение имени файла автономного куба —.cub. При открытии отчета, построенного по файлу автономного куба, предполагается, что файл расположен в месте, назначенном на этом шаге. Если файл в указанном месте не найден, Excel позволяет найти его. Однако при создании источника данных для прямого доступа к файлу отчеты, использующие этот источник данных, не смогут обнаружить файл, если он был впоследствии перемещен.

Сохранение файла автономного куба может потребовать много времени, но работа во время сохранения файла невозможна. Можно отменить сохранение, нажав кнопку Остановить в диалоговом окне создания файла куба.

Разрешение вопросов, возникающих при сохранении файла автономного куба.


 Создание и использование файлов запросов

Создание и использование файлов запросов

Файлы запросов представляют собой текстовые файлы, содержащие сведения об источнике данных, включая местоположение базы данных и информацию о подключении, вводимую при создании источника данных.

Данный раздел содержит следующие сведения:

Работа с файлами запросов

Создание файлов запросов

Другие форматы файлов запросов

Работа с файлами запросов

Использование файлов запросов. Для открытия файла запроса можно воспользоваться командой Открыть в меню Файл Microsoft Excel. При открытии файла запроса с расширением .dqy выполняется запрос и отображается лист, содержащий извлеченные данные. При открытии файла запроса с расширением .oqy происходит подключение к базе данных OLAP или кубу и отображается лист с пустым отчетом сводной таблицы для данных OLAP. После открытия файла запроса можно сохранить файл книги Excel с полученными внешними данными. Однако сохранять файлы запросов в формате .dqy or .oqy с помощью команды Сохранить в меню Файл Excel нельзя.

Совместное использование файлов запросов. Файлы запросов можно предоставлять в совместное использование, что обеспечивает возможность доступа к внешней базе данных для других пользователей. При этом не нужно будет настраивать источник данных для открытия файла запроса, но тем не менее они должны будут установить драйвер ODBC или драйвер источника данных, требующийся для доступа к внешним данным. См. сведения о том, что необходимо для доступа к внешним данным.

Если при создании источника данных для файла запроса не был сохранен пароль, любой пользователь, открывающий файл в Excel, должен будет ввести пароль для доступа к базе данных.

Возврат в начало

Создание файлов запросов

Создание файлов запросов .dqy. Для сохранения файлов запросов .dqy, содержащих запросы для извлечения данных из реляционных баз данных, текстовых файлов или списков Excel следует использовать приложение Microsoft Query. При открытии этих файлов в Query можно просматривать данные в запросе и отбирать различные данные для извлечения. Файл .dqy можно сохранить для любого запроса, созданного с помощью мастера запросов или непосредственно в Query. См. сведения о создании запросов с помощью Microsoft Query.

Создание файлов запросов .oqy. Имеется возможность сохранять файлы .oqy, предназначенные для подключения к данным в базе данных OLAP на сервере или в файле автономного куба (.cub). При использовании Query для создания источника данных для базы данных OLAP или куба автоматически создается файл .oqy. Поскольку в базах данных OLAP данные не организованы в записи или таблицы, для доступа к этим базам данных нельзя создать запросы или файлы .dqy.

Кроме того, можно использовать мастер куба OLAP в Query для сохранения файла .oqy, предназначенного для подключения к файлу куба или для определения куба, создаваемого на основе извлеченных данных. Данный тип файла .oqy может включать как информацию, определяющую содержимое куба, так и информацию о подключении к реляционной базе данных. При открытии этого типа файла .oqy в Query запускается мастер куба OLAP, позволяющий изменить определение куба. См. сведения о создании куба OLAP на основе извлеченных данных.

Возврат в начало

Другие форматы файлов запросов

Файлы запросов .rqy. В Excel можно открывать файлы запросов в формате .rqy, обеспечивающие поддержку драйверов источников данных OLE-DB, использующих этот формат. Для получения дополнительных сведений обратитесь к документации по драйверу.

Файлы запросов .qry. В Query можно открывать и сохранять файлы запросов в формате .qry, используемые с предыдущими версиями Query, не позволяющими открывать файлы .dqy. Если имеется файл запроса в формате .qry, который требуется использовать в Excel, следует открыть файл в Query, а затем сохранить его как файл .dqy. Для получения сведений о сохранении файлов .dqy обратитесь к справочной системе Microsoft Query.

Файлы Web-запросов .iqy. Excel позволяет открывать файлы Web-запросов .iqy, предназначенные для извлечения данных из Web. Для создания и открытия в Excel файлов .iqy Query устанавливать не требуется. См. сведения о Web-запросах.

Возврат в начало


 Получение внешних данных с помощью Microsoft Query

Получение внешних данных с помощью Microsoft Query

Когда Microsoft Query используется для извлечения внешних данных, можно или использовать мастер запросов, или работать непосредственно в Query. Способ создания запроса зависит от средств, необходимых для извлечения требуемых данных. См. сведения о Microsoft Query.

Когда использовать мастер запросов Используйте мастер запросов, если необходимо создать простой запрос. С помощью мастера запросов можно выбрать таблицы и поля, которые нужно включить в запрос. Внутреннее объединение создается автоматически, когда мастер распознает поле первичного ключа в одной таблице и поле с тем же именем в другой таблице.

Можно также использовать мастер для сортировки внешних данных и простой фильтрации данных до передачи их в Microsoft Excel. Если запрос создавался с помощью мастера, его можно и редактировать с помощью мастера. Созданный запрос можно выполнить или в Excel, или в Query. Инструкции по использованию мастера запросов.

Когда использовать Microsoft Query Используйте Query для создания более сложных запросов. Этот метод дает наибольшую возможность управления, поскольку позволяет сузить таблицу результатов созданием внутреннего или внешнего объединения или с помощью выражений и сложных условий. Выражениями называются вычисления, в которых применяются операторы, функции, имена полей и константы. С помощью условий можно выполнить более сложную фильтрацию.

Таблицу результатов можно просмотреть в Query. Убедившись, что она содержит все необходимые данные, можно передать данные в Excel. Созданный запрос можно выполнить или в Excel, или в Query. Инструкции по созданию запросов в Microsoft Query.

Когда использовать запрос с параметрами Используйте запрос с параметрами, если необходимо создать один запрос, извлекающий данные, удовлетворяющие разным условиям. Например, чтобы извлечь данные по продажам для одного изделия за один запрос, можно использовать название изделия в качестве условия. Запросы с параметрами полезны для извлечения части данных из очень большой базы данных, все данные из которой не могут быть извлечены за один раз из-за ограниченности системных ресурсов.

Запросом с параметрами при запуске требует ввести условия выборки данных. Создать запрос с параметрами можно только в Microsoft Query, но не в мастере запросов. Условие служит для выборки данных из таблиц. Созданный запрос можно выполнить или в Excel, или в Query. Инструкции по созданию запроса с параметрами.

Другие способы извлечения данных Существуют способы получения внешних данных в Microsoft Excel без использования Microsoft Query.


 Создание запроса с условиями

Создание запроса с условиями

Существует возможность создавать запросы, которые при запуске требуют ввести условия. В запросе с параметрами вводимые условия служат для выборки данных из таблиц. При запуске запроса или обновлении диапазона внешних данных Microsoft Excel выводит сообщение, в котором указывается, какие условия следует ввести. Например, для запроса об общем количестве заказов можно создать сообщение с просьбой ввести имя продавца. После ввода имени запрос возвращает все записи по заказам указанного продавца.

При многократном обновлении диапазона внешних данных с использованием постоянного значения параметра Microsoft Excel может применять те же условия для запроса, пока они не будут изменены. Microsoft Excel может также использовать условия, содержащиеся в ячейке вашей книги.

Использовать запрос с параметрами для извлечения данных из баз данных OLAP нельзя. Запросы с параметрами могут использоваться для извлечения данных из всех остальных баз данных, к которым можно получить доступ с помощью драйверов ODBC, которые корпорация Майкрософт поставляет вместе с Query. Для получения сведений о поддержке запросов с параметрами драйверами других производителей обратитесь к поставщику драйверов.

Предполагаемые действия

Создание запроса с параметрами, требующего ввода условий при каждом запуске.

Изменение сообщения запроса с параметрами в Microsoft Excel

Использование постоянного значения параметра в запросе

Использование данных из ячейки листа в качестве значения параметра


Получение внешних данных с помощью Microsoft Query

Если Microsoft Query еще не установлен, то необходимо установить Microsoft Query.

Предполагаемые действия

Получение внешних данных с помощью мастера запросов

Создание сложного запроса с помощью Microsoft Query

Создание запроса с условиями

Работа с Microsoft Query

Не можете сделать выбор?

Примечание. Существуют способы получения внешних данных в Microsoft Excel без использования Microsoft Query.


Обработка дат 2000 года в Microsoft Query

Использование четырех цифр для записи года Для обеспечения правильной выборки и интерпретации значений года убедитесь в том, что внешние базы данных, там где это возможно, хранят значение года в четырехзначном формате (2001 вместо 01).

Согласованная интерпретация двухзначного года в Query и в Microsoft Excel Query и Excel одинаково воспринимают значение года, заданного двумя цифрами. Данные, которые содержат двухзначное значение года, при просмотре в Query и передаче в Excel —это одно и то же значение. Обработка дат 2000 года в Excel.

Интерпретация двухзначных значений года в Query Двухзначные значения года, полученные Query из внешних баз данных, интерпретируются следующим образом:

  • Значение года от 00 до 29 Двухзначные значения года от 00 до 29 интерпретируются как годы с 2000 по 2029. Например, полученная из внешней базы данных дата 28/5/19 интерпретируется Query как 28 мая 2019.

  • Значение года от 30 до 99 Двухзначные значения года от 30 до 99 интерпретируются как годы с 1930 по 1999. Например, полученная из внешней базы данных дата 28/5/98 интерпретируется Query как 28 мая 1998.

Администратор может изменить способ распознавания года Системный администратор может изменить правила, по которым Microsoft Office интерпретирует год. Например, администратор может изменить число, соответствующее максимальному году в следующем столетии, с 29 на любое другое число. Для того чтобы выяснить, использует ли система настроенную интерпретацию дат, обратитесь к системному администратору. Сведения о настройке интерпретации дат могут быть получены из Microsoft Office 2000 Resource Kit.


 Запуск запроса

Запуск запроса

  1. Щелкните ячейку, с которой требуется начать диапазон внешних данных.

  2. Выберите в меню Данные команду Внешние данные и подкоманду Выполнить сохраненный запрос.

    Демонстрация

  3. Выберите запрос, который требуется выполнить.

    Файлы запросов к базе данных имеют расширение .dqy; файлы Web-запросов — расширение .iqy; а файлы запросов OLAP — расширение .oqy.

  4. Нажмите кнопку Получить данные.

    Для запросов к базе данных и Web-запросов на экран выводится диалоговое окно Возврат данных в Microsoft Excel.

    Для запросов OLAP выводится диалоговое окно Мастер сводных таблиц и диаграмм - шаг 3 из 3. Данные из баз данных OLAP могут быть возвращены в Excel только в виде отчета сводной таблицы, но не в виде диапазона внешних данных.

  5. Для запросов к базе данных или Web-запросов нажмите кнопку Свойства, чтобы задать параметры форматирования и разметки для диапазона внешних данных в Excel.

  6. Выполните одно из следующих действий:

    Для того чтобы вернуть внешние данные на выбранный лист, установите переключатель в положение Существующий лист. Щелкните на листе ячейку, в которую требуется поместить верхний левый угол диапазона внешних данных или отчета сводной таблицы, а затем нажмите кнопку OK или Готово.

    Для того чтобы поместить данные на новый лист, установите переключатель в положение Новый лист и нажмите кнопку OK или Готово. Excel добавит в книгу новый лист и автоматически поместит диапазон внешних данных или отчет сводной таблицы в левый верхний угол нового листа.

    Для того чтобы вернуть внешние данные в виде отчета сводной таблицы (для запросов к базе данных или Web-запросов), установите переключатель в положение Отчет сводной таблицы и нажмите кнопку OK.

  7. Если появится приглашение, введите параметры для запроса. Если допустимые параметры неизвестны, может понадобиться помощь пользователя, создавшего запрос.

    Excel выполняет запрос. Во время выполнения запроса в строке состояния вращается значок обновления значок фонового обновления.

Примечания

  • Если запрос, выполняемый в фоновом режиме, долго не возвращает данные, можно проверить его состояние, нажав кнопку Состояние обновления [image] на панели инструментов Внешние данные. Для того чтобы отменить запрос, нажмите кнопку Прервать.

  • Для выполнения запроса также можно открыть файл этого запроса, если таковой имеется. В меню Excel Файл выберите команду Открыть, выберите в списке Тип файлов вариант Файлы Query, а затем найдите и дважды щелкните файл, который требуется открыть. См. сведения о типах файлов запросов и способах их создания и использования.


 Получение данных из внешних баз данных

Получение данных из внешних баз данных

Внешние данные могут быть получены из баз данных следующими способами:

С помощью Microsoft Query

С помощью Microsoft Visual Basic

С помощью Web-запросов

С помощью Microsoft Query

Microsoft Query можно использовать для задания источников данных и загрузки данных. Можно использовать мастер запросов для создания простых запросов или использовать расширенные возможности Query для создания более сложных запросов. Можно получить доступ к Query непосредственно из Excel или создать запрос в Мастере сводных таблиц и сводных диаграмм.

Реляционные базы данных, списки и текстовые файлы Query можно использовать для извлечения данных, хранящихся в реляционной базе, например Microsoft Access или Microsoft SQL Server. В дополнение могут быть извлечены данные, хранящиеся в списке Microsoft Excel или текстовом файле.

Когда данные извлекаются из реляционной базы данных, списка Excel или текстового файла, можно объединить данные, представленные в нескольких таблицах. Могут быть также заданы условия, которым должны удовлетворять данные, включаемые во внешний диапазон данных. Это позволяет исключить данные, не относящиеся к конкретной задаче. Например, могут представлять интерес объемы продаж, но только за определенный месяц.

Для извлечения всех данных из текстового файла можно импортировать текстовый файл как внешний диапазон данных, не создавая запроса.

Базы данных OLAP Query может быть использован для соединения с базой данных OLAP и передачи в Excel данных в виде отчета сводной таблицы. При извлечении данных из базы данных OLAP Query используется для настройки источника данных, но запрос для данных не создается. Вместо этого в Excel возвращается пустой отчет сводной таблицы; после этого задаются данные, которые должны быть извлечены и отображены в отчете.

Установка Query и драйверов Для использования Query для извлечения данных необходимо установить Query и некоторые дополнительные драйверы ODBC или драйверы источника данных, которые требует внешняя база данных. Извлечение внешних данных.

Возврат в начало

С помощью Microsoft Visual Basic

Макрос Visual Basic может быть использован для получения доступа к внешним источникам данным. Для написания макроса, извлекающего данные, должен быть установлен Microsoft Query. Создание макроса на языке Visual Basic для получения внешних данных.

Возврат в начало

С помощью Web-запросов

Web-запросы могут быть созданы и использованы без установки Microsoft Query. Извлечение данных из Интернета. Получение данных из источника в Интернете.

Возврат в начало


 Об извлечении данных с Web-страниц

Об извлечении данных с Web-страниц

Данный раздел содержит следующие сведения:

Обзор

Использование диалогового окна Создание запроса Web

Изменение и обновление данных

Обзор

При анализе данных на Web-странице можно воспользоваться Web-запросом для извлечения отдельной таблицы, нескольких таблиц или всего текста с Web-страницы. После извлечения данных можно провести их анализ с помощью инструментов и возможностей Microsoft Excel.

Web-запрос используется в случае, если требуется получить данные из Web для использования их в Excel, — например, для извлечения и анализа биржевых котировок. Поскольку при использовании Web-запроса в Excel переносятся только данные, а не все содержимое Web-страницы, Web-запрос не рекомендуется использовать для открытия Web-страницы, данные с которой нужно скопировать для публикации на собственной Web-странице. См. сведения о публикации данных Excel в Web.

Web-страница с таблицей

Web-запрос извлекает данные с Web-страницы и возвращает их в Excel для последующего анализа.

Установка обозревателя. Для получения возможности извлечения данных с Web-страницы необходимо установить Web-обозреватель — например, обозреватель Microsoft Internet Explorer, входящий в состав Microsoft Office. Для получения данных с узла World Wide Web необходимо наличие доступа к Интернету через сеть организации или модем и учетной записи поставщика услуг Интернета.

Выполнение или создание Web-запроса. Если для требуемых данных имеется файл Web-запроса .iqy, то для извлечения данных следует выполнить Web-запрос. В Excel включены примеры Web-запросов; кроме того, можно создать новый Web-запрос.

Возврат в начало

Использование диалогового окна «Создание запроса Web»

Шаг 1: поиск требуемых данных. При создании Web-запроса необходимо знать адрес URL требуемой Web-страницы. Чтобы определить адрес Web-страницы, можно найти ее с использованием обозревателя, запустить который позволяет кнопка Обзор Интернета. По возвращении в диалоговое окно после нахождения Web-страницы Excel автоматически заполняет поле адреса. Если данная кнопка не используется, и в оформлении Web-узла присутствуют кадры, убедитесь, что введенный адрес является адресом Web-страницы, содержащей данные, а не адресом кадра или страницы кадров. Если неизвестно, какой адрес следует использовать, обратитесь к владельцу данного Web-узла.

Шаг 2: выбор данных для извлечения. Для указания вида данных, которые необходимо извлечь, следует использовать один из следующих трех параметров.

  • Страница целиком. Данный параметр следует использовать в случае, если требуется извлечь все содержимое Web-страницы, включая текст, заголовки и другие данные.

  • Только таблицы. Данный параметр следует использовать в случае, если Web-страница содержит как данные, которые требуется проанализировать в Excel, например таблицу или другой раздел данных, так и данные, которые возвращать в Excel не требуется, такие как текст вне таблиц и форматированные разделы. Форматированные разделы представляют собой части Web-страницы, созданные с применением форматирования, которое позволяет использовать их в другой программе, такой как Excel — например, с использованием символов табуляции и пробелов вместо кода HTML. Для получения сведений о наличии на Web-странице форматированных разделов, которые можно использовать в Excel, следует обратиться к разработчику Web-страницы.

  • Одна или несколько специальных таблиц на странице. Данный параметр следует использовать в случае, если Web-страница содержит несколько таблиц или форматированных разделов и извлечь нужно только некоторые из них. Извлечение и обновление только необходимых данных может занимать меньше времени, чем извлечение всех данных. Для указания таблиц и разделов, которые требуется извлечь, следует ввести номера или имена таблиц, если Web-страница содержит такие имена. Чтобы включить имя таблицы, являющееся номером, введите номер в кавычках — например, номер "5". Таблицы и форматированные разделы извлекаются в порядке их расположения на Web-странице, а не в порядке, указанном на данном шаге.

    Определение таблиц и форматированных разделов. Если обозреватель позволяет просматривать исходный код HTML для Web-страницы, эту возможность можно использовать для нахождения таблиц и форматированных разделов. Таблицы начинаются с тега <TABLE> и заканчиваются тегом </TABLE>. Форматированные разделы начинаются тегом <PRE> и заканчиваются тегом </PRE>. Если эти разделы не имеют имен, можно определить их количество на основе кода HTML.

    Например, в Microsoft Internet Explorer можно щелкнуть Web-страницу правой кнопкой мыши, а затем выбрать команду Просмотр в виде HMTL в контекстном меню для отображения кода HTML в программе «Блокнот» или другом указанном текстовом редакторе. В «Блокноте» для поиска разделов <TABLE> и <PRE> следует выбрать команду Найти в меню Поиск.

Шаг 3: выбор формата данных. При извлечении данных, включающих таблицы, данные, находящиеся в столбах таблиц, распределяются по ячейкам автоматически. Можно указать, должно ли сохраняться форматирование Web-страницы, включая шрифты и цвета, при извлечении данных в Excel. При сохранении форматирования можно полностью сохранить формат HTML либо сохранить только формат RTF, являющийся форматом, который Excel может воспроизвести наиболее близко.

Использование дополнительных параметров форматирования. Кнопка Подробнее позволяет установить дополнительные параметры форматирования для форматированных разделов. Например, можно выделять форматированный текст в столбцы. Если этот параметр установлен, и разделы имеют символы, которые определяют, или ограничивают, текст для каждого столбца, можно указать, как должны обрабатываться эти символы. Чтобы узнать, какой код использован в форматированном разделе, просмотрите код HTML этого раздела в обозревателе либо обратитесь к разработчику Web-страницы.

Сохранение файла Web-запроса .iqy. Если требуется добавить те же Web-данные в другие книги или использовать файл Web-запроса совместно с другими пользователями, следует сохранить запрос с помощью кнопки Сохранить запрос. Если не указано иное местоположение, файл .iqy сохраняется в папке профиля пользователя в папке Application Data\Microsoft\Queries. Если не сохранен файл Web-запроса, то запрос сохраняется в качестве части книги Excel, и выполнять запрос можно будет только из этой книги.

Параметры в Web-запросах. Некоторые Web-запросы, включенные в Excel, допускают ввод параметров при выполнении запроса. Например, при выполнении запроса «Биржевые котировки Microsoft Investor» можно вводить символы котировок для извлечения данных по конкретным котировкам. Диалоговое окно Создание запроса Web не позволяет создавать Web-запросы, требующие ввода параметров. Для создания Web-запроса такого типа необходимо знание языка HTML, и соответствующая Web-страница должна допускать ввод параметров. В этом случае можно сохранить файл Web-запроса, который возвращает данные с нужной Web-страницы, а затем изменить файл .iqy в текстовом редакторе, например в редакторе «Блокнот». Для получения дополнительных сведений обратитесь к разработчику Web-страницы, запрос к которой требуется создать.

Возврат в начало

Изменение и обновление данных

Изменение Web-запроса. В случае, если Web-запрос не возвращает данные требуемым образом, то для его изменения следует щелкнуть ячейку в диапазоне внешних данных, а затем нажать кнопку Изменить запрос [image] на панели инструментов Внешние данные.

Обновление Web-запроса. При обновлении диапазона внешних данных, созданного Web-запросом, с исходной Web-страницы извлекаются соответствующие данные и загружаются все новые данные. Имеется возможность установить параметры, управляющие обновлением диапазона внешних данных.

Переход к Web-странице для Web-запроса. Если при обновлении внешнего диапазона данных требуемые данные не загружаются, просмотрите Web-страницу с помощью обозревателя, чтобы узнать, какие в нее были внесены изменения. Для определения адреса требуемой страницы щелкните ячейку в диапазоне внешних данных, а затем нажмите кнопку Изменить запрос [image] на панели инструментов Внешние данные. При использовании Microsoft Internet Explorer можно скопировать адрес из поля в верхней части диалогового окна Создание запроса Web: выделите адрес и нажмите клавиши CTRL+C чтобы скопировать его, щелкните поле Адрес в Internet Explorer, нажмите клавиши CTRL+V чтобы вставить адрес, а затем нажмите клавишу ENTER для перехода к Web-странице.

Возврат в начало


 Создание запроса Web

Создание запроса Web

Web-запрос может быть создан для извлечения текста или данных из таблиц или отформатированных областей на Web-странице. (Таблицы задаются тегом HTML <TABLE>; отформатированные облати — тегом HTML <PRE>). Извлеченные данные не включают рисунки, например изображения формате .gif, и содержимое сценариев. Извлечение данных с Web-страницы.

  1. В меню Данные выберите команду Внешние данные, а затем команду Создать Web-запрос.

  2. Следуйте указаниям в диалоговом окне Создание запроса Web.

    Инструкции

Примечания

  • Чтобы проверить состояние фонового запроса, длительное время не возвращающего данные, нажмите кнопку Состояние обновления [image] на панели инструментов Внешние данные. Чтобы отменить запрос, выберите Отменить обновление.

  • Чтобы изменить Web-запрос после его создания, выберите ячейку во внешнем диапазоне данных и нажмите кнопку Изменить запрос [image] на панели инструментов Внешние данные.


 Извлечение данных с Web-страницы

Извлечение данных с Web-страницы

С помощью Web-запроса данные могут быть получены с узла внутренней сети предприятия или с узлов, работающих по протоколам HTTP или FTP в Интернете. можно использовать Web-запросы, предоставляемые Microsoft Excel или создать новый Web-запрос.

Чтобы получить данные с узла Web, необходимо иметь доступ к Интернету или через внутреннюю сеть предприятия, или через модем с помощью учетной информации, полученной от поставщика услуг Интернета.

  1. В меню Данные выберите Внешние данные, а затем выберите Выполнить сохраненный запрос.

  2. Выберите запрос Web, который нужно запустить.

    Файлы запроса Web имеют расширение .iqy.

  3. Нажмите кнопку Получить данные.

    На экране появится диалоговое окно Возврат данных в Microsoft Excel.

  4. Выполните одно из следующих действий:

    Чтобы передать данные с Web-страницы на выбранный лист, выберите Имеющийся лист. На листе выберите команду ячейку, в которую вы хотите поместить верхний левый угол диапазона внешних данных, и нажмите кнопку OK.

    Чтобы поместить данные на новый лист, выберите Новый лист и нажмите кнопку OK. Excel добавит новый лист в вашу книгу и автоматически поместит диапазон внешних данных в левый верхний угол нового листа.

  5. Иногда требуется ввести параметры запроса. Если они неизвестны, наведите справки у автора запроса.

    Excel запускает запрос. Вращающийся значок обновления индикатор обновления , показывающий, что запрос выполняется, появится в строке состояния.

Примечания

  • Microsoft Excel включает примеры Web-запросов. Эти примеры содержатся в папке Queries.

  • Чтобы проверить состояние фонового запроса, длительное время не возвращающего данные, нажмите кнопку Состояние обновления [image] на панели инструментов Внешние данные. Чтобы отменить запрос, выберите Отменить обновление.


 Импорт текстового файла в обновляемый диапазон Microsoft Excel

Импорт текстового файла в обновляемый диапазон Microsoft Excel

Данная процедура используется для обновления данных в Excel при изменении исходного текстового файла. Если требуется скопировать данные в Excel без сохранения подключения к исходному файлу, можно открыть текстовый файл в Excel.

  1. Щелкните ячейку, в которую требуется поместить данные из текстового файла.

    Для того чтобы убедиться, что внешние данные не заменят существующие данные, проверьте отсутствие данных на листе ниже и правее выбранной ячейки.

  2. Выберите в меню Данные команду Внешние данные и подкоманду Импорт текстового файла.

  3. В списке Папка найдите и дважды щелкните текстовый файл, который требуется импортировать в качестве диапазона внешних данных.

  4. Следуйте инструкциям мастера текстов для указания способа разбиения текста на столбцы.

  5. Нажмите кнопку Готово, а затем нажмите кнопку Свойства в диалоговом окне Импортировать данные, чтобы задать параметры форматирования и разметки диапазона внешних данных в Microsoft Excel.

  6. В диалоговом окне Импортировать данные выполните одно из следующих действий.

    Для того чтобы передать данные в место, выбранное на шаге 1, нажмите кнопку Имеющийся лист и затем кнопку OK.

    Для того чтобы поместить данные на новый лист, выберите Новый лист и нажмите кнопку OK. Microsoft Excel добавит в книгу новый лист и автоматически поместит диапазон внешних данных в левый верхний угол нового листа.

Примечания

  • Для того чтобы обновить диапазон внешних данных при изменении исходного текстового файла, нажмите кнопку Обновить данные [image] на панели инструментов Внешние данные. В диалоговом окне Импорт текстового файла выберите нужный текстовый файл и нажмите кнопку Импорт.

  • Для того чтобы изменить настройки, сделанные в мастере текстов, нажмите кнопку Изменить импорт текста [image] на панели инструментов Внешние данные. Выберите нужный текстовый файл, нажмите кнопку Импорт, а затем внесите нужные изменения в мастере.

  • Если в качестве обновляемого диапазона данных требуется импортировать только часть данных из текстового файла, можно создать запрос для извлечения нужных данных.


 Изменение имени диапазона внешних данных

Изменение имени диапазона внешних данных

  1. Если диалоговое окно Свойства внешнего диапазона не отображено, щелкните одну из ячеек диапазона внешних данных, а затем нажмите кнопку Свойства диапазона данных [image] на панели инструментов Внешние данные.

  2. В поле Имя введите имя диапазона внешних данных.

Примечания

  • Если имя диапазона внешних данных не было изменено, диапазоны внешних данных именуются автоматически. Диапазоны внешних данных, извлеченных из баз данных, называются по имени запроса, по умолчанию «запрос_из_источник», где источник — имя источника данных, использованного в запросе. Диапазоны внешних данных из текстовых файлов называются по имени этих файлов, из Web-запросов — по имени Web-страницы. Если на листе находится более одного диапазона внешних данных из одного источника, то диапазоны нумеруются. Например MyText, MyText_1, MyText_2, и так далее.

  • Инструкции по поиску на листе диапазона внешних данных


Изменение запроса на внешние данные

Для просмотра этого раздела выберите мышью соответствующий графический объект.


 Контроль обновления диапазона внешних данных

Контроль обновления диапазона внешних данных

Существует несколько способов управления обновлением данных во внешнем диапазоне данных.

Предполагаемые действия

Обновление данных

Запуск запроса в фоновом режиме и в режиме ожидания

Обновление данных с заданным интервалом времени

Обновление внешних данных

Указание параметров обновления

Запрос пароля при обновлении диапазона внешних данных

Добавление новых данных при изменении размера диапазона внешних данных

Копирование формул из соседних ячеек при расширении диапазона внешних данных

Не можете сделать выбор?


 Форматирование и вид диапазона внешних данных

Форматирование и вид диапазона внешних данных

Когда данные извлекаются из внешнего диапазона данных, форматирование и макет данных могут быть настроены. Например, можно настроить заголовки столбцов, применить к данным различные форматы и сохранять форматирование при обновлении данных, добавить номера строк для определения числа извлеченных записей и автоматически копировать формулы, анализирующие данные.

Также могут быть установлены параметры, управляющие обновлением внешнего диапазона данных.

Предполагаемые действия

Настройка имен полей во внешнем диапазоне данных

Сохранение форматирования ячеек при обновлении внешнего диапазона данных

Добавление номеров строк к диапазону внешних данных

Копирование формул при расширении диапазона внешних данных


 Копирование диапазона внешних данных и его фонового запроса в другую книгу

Копирование диапазона внешних данных и его фонового запроса в другую книгу

  1. Выберите диапазон внешних данных, который нужно скопировать, щелкнув стрелку рядом с полем Имя в строке формул и выбрав имя диапазона внешних данных.

    По умолчанию Microsoft Excel автоматически именует диапазоны внешних данных. Диапазоны внешних данных из баз данных именуются по имени запроса, "запрос_из_источник", где источник — имя источника данных, который использовался в запросе. Диапазоны внешних данных из текстовых файлов называются по имени этих файлов, из Web-запросов — по имени Web-страницы. Если на странице находится более одного диапазона внешних данных из одного источника, то диапазоны нумеруются. Например «МойТекст», «МойТекст_1», «МойТекст_2» и так далее.

    Чтобы скопировать подписи столбцов или формулы, которые не принадлежат диапазону внешних данных, выделите содержащие их ячейки. Удерживая клавишу SHIFT, щелкните стрелку рядом с полем Имя в строке формул, а затем укажите имя диапазона внешних данных, который следует скопировать.

  2. Нажмите кнопку Копировать [image] .

  3. Перейдите к книге, в которую следует вставить диапазон внешних данных.

  4. Щелкните левый верхний угол области вставки.

  5. Нажмите кнопку Вставить [image] .

Примечания

  • Так как при копировании части диапазона внешних данных фоновый запрос не копируется, перенесенные данные нельзя обновить.

  • Чтобы отменить отображение бегущей рамки после завершения копирования, нажмите клавишу ESC.


 Поиск диапазона внешних данных на листе

Поиск диапазона внешних данных на листе

  • Щелкните стрелку, находящуюся рядом с полем Имя в строке формул, а затем укажите имя нужного диапазона внешних данных.

Примечания

  • Если имя диапазона внешних данных не было изменено, диапазоны внешних данных именуются автоматически. Диапазоны внешних данных, извлеченных из баз данных называются по имени запроса, по умолчанию "запрос_из_источник”, где источник — имя источника данных, использованного в запросе. Диапазоны внешних данных из текстовых файлов называются по имени этих файлов, из Web-запросов — по имени Web-страницы. Если на листе находится более одного диапазона внешних данных из одного источника, то диапазоны нумеруются. Например MyText, MyText_1, MyText_2, и так далее.

  • Изменение имени внешнего диапазона данных.


 Обновление внешних данных

Обновление внешних данных

  1. Щелкните ячейку диапазона внешних данных, который требуется обновить.

  2. На панели инструментов Внешние данные нажмите кнопку Обновить данные [image] .

Примечания

  • Проверка состояния обновления Чтобы проверить состояние фонового запроса, длительное время не возвращающего данные, выберите Состояние обновления [image] на панели инструментов Внешние данные. Чтобы отменить запрос, выберите Отменить обновление.

  • Автоматическое обновление Чтобы автоматически обновлять диапазон внешних данных при открытии книги, на панели инструментов Внешние данные выберите Свойства диапазона данных [image] , а затем установите флажок обновление при открытии файла. Чтобы вместе с книгой сохранять определение запроса, но опускать внешние данные, уменьшая тем самым размер файла книги, установите флажок удалить внешние данные с листа перед сохранением.

  • Управление способом обновления данных Существует несколько способов управления обновлением внешних данных. Сюда входит замораживание внешних данных, непосредственный и фоновый запуск запроса, а также способ добавления новых данных при изменении размера диапазона внешних данных. Чтобы получить более подробные сведения, нажмите кнопку [image] .

  • Управление форматами и макетами Также можно контролировать форматирование и вид диапазона внешних данных. Чтобы получить более подробные сведения, нажмите кнопку [image] .

  • Обновление нескольких диапазонов внешних данных Если книга содержит несколько обновляемых диапазонов внешних данных, выберите Обновить все [image] на панели инструментов Внешние данные. Если открыто несколько книг, необходимо выбрать Обновить все в каждой книге.

  • Управление порядком обновлений Чтобы указать порядок обновления, щелкните ячейку того диапазона внешних данных, который нужно обновить первым, и выберите Обновить данные. Таким образом же образом задается последовательность обновления диапазонов внешних данных.


 Обновление данных с заданным интервалом времени

Обновление данных с заданным интервалом времени

  1. Если диалоговое окно Свойства внешнего диапазона не отображено, щелкните одну из ячеек диапазона внешних данных, а затем нажмите кнопку Свойства диапазона данных [image] на панели инструментов Внешние данные.

  2. Установите флажок Обновлять каждые, а затем введите число минут между обновлениями.


 Удаление диапазона внешних данных с листа

Удаление диапазона внешних данных с листа

  1. Перейдите на лист, содержащий диапазон внешних данных, который требуется удалить.

  2. Щелкните стрелку рядом с полем Имя в строке формул, а затем выберите диапазон внешних данных, который требуется удалить.

    Microsoft Excel автоматически присваивает имена диапазонам внешних данных. Диапазоны внешних данных из баз данных получают имя запроса, по умолчанию Запрос_из_источник, где источник — имя источника данных, использовавшегося при создании запроса. Диапазоны внешних данных из текстовых файлов получают имена соответствующих текстовых файлов. Диапазоны внешних данных из Web-запросов получают имена Web-страниц, с которых были извлечены данные. Если лист содержит более одного диапазона внешних данных из одного источника, эти диапазоны нумеруются — например, MyText, MyText_1, MyText_2 и т.д. Существует возможность изменения имен диапазонов внешних данных.

  3. В меню Правка выберите команду Удалить.

Примечания

  • Если вместо выбора команды Удалить из меню Правка нажать клавишу DELETE на клавиатуре, Excel также очистит диапазон внешних данных.

  • Можно создать шаблон отчета, который удаляет диапазон внешних данных, но сохраняет базовый запрос при закрытии листа. Инструкции по сохранению книги в качестве шаблона отчета.

  • Для удаления диапазона внешних данных также можно удалить лист, содержащий эти внешние данные.


 Запрос пароля при обновлении диапазона внешних данных

Запрос пароля при обновлении диапазона внешних данных

Если для подключения к источнику данных требуется пароль, можно сделать так, чтобы этот пароль запрашивался для обновления диапазона внешних данных. Данная процедура не применима к данным, извлеченным из текстового файла (*.txt) или Web-запроса (*.iqy).

  1. Если диалоговое окно Свойства внешнего диапазона не отображено, щелкните одну из ячеек диапазона внешних данных, а затем нажмите кнопку Свойства диапазона данных [image] на панели инструментов Внешние данные.

  2. В группе Определение запроса снимите флажок Сохранить пароль.

Примечание. Microsoft Excel запрашивает пароль только при первом обновлении диапазона внешних данных в каждом сеансе Excel. При следующем запуске Excel пароль будет запрошен вновь, если открыть книгу, содержащую запрос, и нажать кнопку Обновить данные [image] .


 Создание макроса на языке Visual Basic для получения внешних данных

Создание макроса на языке Visual Basic для получения внешних данных

Для получения доступа к внешним источникам данных при помощи макросов на языке Visual Basic необходимо установить объекты DAO для Visual Basic.

Для того чтобы использовать макрос, созданный в Microsoft Excel версии 5.0 или более ранней, выберите команду Надстройки в меню Сервис и установите флажок Надстройка ODBC.

Для получения дополнительных сведений о создании макросов на языке Visual Basic см. справку по Visual Basic.

Примечание. Во время записи макроса, содержащего запрос, Excel не может выполнить этот запрос в фоновом режиме, даже если выбрать этот способ выполнения. Для того чтобы записанный макрос мог выполняться в фоновом режиме, замените с помощью редактора Visual Basic строку "BackgroundQuery:= False" на "BackgroundQuery := True".


Устранение проблем, связанных с получением внешних данных

В чем именно заключаются сложности?

Создание и использование источников данных

Невозможно создать новый источник данных.

Используемый ранее драйвер ODBC не работает.

Не удается найти или удалить источник данных.

Почему рядом с именем источника данных отображается звездочка?

Извлечение данных

Сообщение о неверном пути к базе данных.

После обновления внешнего диапазона данных нарушаются сортировка и форматирование.

Запрос выполняется слишком долго, компьютер не реагирует на внешние воздействия.

При передаче данных в Microsoft Excel возвращаются пустые ячейки.

Не хватает пространства на диске при попытке получить внешние данные.

Попытки подключения к базе данных часто оказываются безуспешными.

Макрос, предназначенный для получения данных, не выполняется.

Изменение порядка столбцов в Microsoft Query не отражается на диапазоне внешних данных.

Нарушение порядка столбцов диапазона внешних данных после изменения запроса.

Web-запрос возвращает даты вместо чисел.


Разрешение вопросов по источникам данных OLAP для отчетов сводных таблиц и сводных диаграмм

В чем именно заключаются сложности?

Создание источников данных куба OLAP

Неправильно отображаются поля даты или времени

Итоговая функция для данных куба недоступна

Не удается изменить куб OLAP

Сообщение о потере данных во время изменения куба OLAP

Не хватает места на диске при попытке сохранения автономного файла куба

Работа с источниками данных куба OLAP

После создания автономного куба отсутствуют данные в отчете сводной таблицы или сводной диаграммы

После создания куба в Microsoft Query Microsoft Excel по-прежнему использует поля базы данных

Отсутствует доступ к базе данных через источник данных куба

В автономном файле куба отсутствуют необходимые данные

Не обновляются данные сводной таблицы или сводной диаграммы

Excel не может найти автономный файл куба


 Web-запрос возвращает даты вместо чисел

Web-запрос возвращает даты вместо чисел

Числа, формат представления которых подобен формату даты, как, например, в серийном номере 01-01-23, в Microsoft Excel могут восприниматься как даты.

Чтобы этого не происходило, выберите мышью ячейку внешнего диапазона данных и нажмите кнопку Изменение запроса [image] на панели инструментов Внешние данные. В диалоговом окне Изменить Web-запрос нажмите кнопку Подробнее и установите флажок Отключить распознавание дат. В результате при запуске Web-запроса даты на Web-странице будут отображаться в Excel как даты, а числа не будут распознаваться как даты.


 Обобщение значений на листе

Обобщение значений на листе

Этот раздел содержит ссылки на:

Быстрые вычисления на листе

Обзор промежуточных итогов в списках

Создание интерактивных итоговых отчетов

В Microsoft Excel предусмотрены различные методы обобщения данных на листе. Можно записать формулы, обобщающие данные в столбцах, использовать инструменты, которые обобщают данные в списках, или создать отчеты сводной таблицы или сводной диаграммы, которые обобщают данные и позволяют интерактивно изменять представление данных.

Быстрые вычисления на листе

Отображение итогов для диапазона Когда необходимо выбрать диапазон ячеек и быстро просмотреть итоги для значений (без занесения суммы на лист), посмотрите на строку состояния. В ней отображается вычисленная с помощью автовычисления сумма значений в выбранном диапазоне. Если выделенный диапазон содержит скрытые ячейки или ячейки, скрытые фильтрованием, скрытые значения не включаются в вычисления.

Вставка итогов Кнопка Автосумма позволяет вставить формулу, вычисляющую итоговое значение для диапазона. Вставка итогов.

Создание простой формулы, использующей условие Могут быть написаны формулы, которые вычисляют итоговые значения в зависимости от определенного условия, например сумму всех продаж, в которых накладные выписаны на сумму большую 500 руб.

Возврат в начало

Обзор промежуточных итогов в списках

Создание промежуточных итогов, обобщающих данные Промежуточные итоги для значений в списке могут быть вычислены автоматически. Например, если список содержит суммы продаж для продавцов в различных регионах, можно вычислить промежуточные итоги для каждого региона и каждого продавца. Создание списков на листах.

Использование Мастера суммирования Если необходимо вычислить итоги для значений в списке, удовлетворяющих определенному условию, можно использовать мастера суммирования. Он облегчает построение формул.

Использование функций базы данных для обобщения данных в столбцах Если данные на листе похожи на базу данных (аналогичная информация располагается в одних и тех же столбцах), Excel предлагает несколько функций базы данных, которые суммируют только те значения, которые удовлетворяют сложному критерию, например «посчитать число записей, в которых сумма продажи больше 1000, но меньше 2500».

Создание отчета Microsoft Access Для тех, кто знаком с разработкой отчетов Access, предлагается возможность создать отчет Access из списка Excel.

Возврат в начало

Создание интерактивных итоговых отчетов

Обобщение данных в отчетах сводных таблиц Отчет сводной таблицы представляет собой интерактивную таблицу, используемую для обобщения данных в больших списках. Макет и формат сводной таблицы могут быть быстро изменены перетаскиванием элементов в требуемое место. Отчеты сводных таблиц.

Графическое обобщение данных с помощью отчетов сводных диаграмм Отчет сводной диаграммы объединяет наглядность диаграммы с интерактивными преимуществами (макет и суммирование) отчета сводной таблицы. Отчеты сводных диаграмм.

Возврат в начало


 Суммирование значений, удовлетворяющих определенным условиям, с помощью мастера суммирования

Суммирование значений, удовлетворяющих определенным условиям, с помощью мастера суммирования

Для суммирования значений в списке по заданным условиям может быть использован мастер суммирования. Например, с помощью мастера суммирования можно создать формулу для вычисления общей суммы продаж по определенному продавцу в списке, представляющем суммы продаж по продавцам.

Мастер суммирования является надстройкой; если в подменю Мастер меню Сервис отсутствует команда Суммировать по условию, необходимо установить и загрузить программу надстройки. Чтобы получить дополнительные сведения о надстройках, а также об их установке и загрузке, нажмите кнопку [image] .

  1. Укажите ячейку в списке.

  2. В меню Сервис выберите пункт Мастер и выполните команду Суммировать по условию.

  3. Следуйте инструкциям мастера.

Примечания

  • Формулы, созданные мастером суммирования, являются формулами массива. после редактирования формул необходимо нажать одновременно клавиши CTRL+SHIFT+ENTER для блокировки формул.

  • См. сведения о вычислениях по формулам с условиями.


Обзор промежуточных итогов в списках (автоматическая вставка промежуточных итогов)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Вычисление общих и промежуточные итогов

Вычисление общих и промежуточные итогов

Промежуточные итоги Для вычисления значений промежуточных итогов используется итоговая функция, например, СУММ или СРЗНАЧ. Промежуточные итоги могут быть отображены в списке с помощью нескольких типов вычислений одновременно.

Общие итоги Общие итоги подводятся с помощью подробных данных, а не с помощью значений промежуточных итогов. Например, итоговая функция СРЗНАЧ возвращает среднее значение для всех подробных данных списка, а не для промежуточных итоговых значений.

Автоматические вычисления Значения общих и промежуточных итогов пересчитываются автоматически при каждом изменении подробных данных.

Дополнительные сведения

Итоговые функции для промежуточных итогов

Подведение промежуточных итогов


 Подведение промежуточных итогов

Подведение промежуточных итогов

  1. Отсортируйте список по столбцу, для которого необходимо подвести промежуточный итог. Например, чтобы просуммировать единицы продукции, проданные каждым продавцом, в списке продавцов, объемов продаж и количества проданного, отсортируйте список по столбцу продавцов.

    Инструкции

  2. Укажите ячейку в списке.

  3. Выберите команду Итоги в меню Данные.

  4. Выберите столбец, содержащий группы, по которым необходимо подвести итоги, из списка При каждом изменении в. Это должен быть тот столбец, по которому проводилась сортировка списка на шаге 1.

  5. Выберите функцию, необходимую для подведения итогов, из списка Операция. Для получения более подробных сведений по итоговым функциям нажмите кнопку [image] .

  6. Выберите столбцы, содержащие значения, по которым необходимо подвести итоги, в списке Добавить итоги по.

Примечания

  • Можно также «вкладывать» промежуточные итоги для более мелких групп внутри групп, для которых подведены промежуточные итоги.

  • Можно удалить промежуточные итоги из списка, не оказывая влияния на исходные данные.


Итоговые функции для промежуточных итогов

Для подведения итогов данных списка можно использовать следующие операции. Укажите используемую функцию в раскрывающемся списке Операция диалогового окна Промежуточные итоги (команда Итоги, меню Данные).

Операция | Результат
Сумма | Сумма чисел. Эта операция используется по умолчанию для подведения итогов по числовым полям.
Кол-во значений | Количество записей или строк данных. Эта операция используется по умолчанию для подведения итогов по нечисловым полям.
Среднее | Среднее для значений в списке.
Максимум | Максимальное число.
Минимум | Минимальное число.
Произведение | Результат произведения всех значений в списке.
Кол-во чисел | Количество записей или строк, содержащих числа.
Несмещенное отклонение | Несмещенная оценка среднего квадратического отклонения генеральной совокупности по выборке данных.
Смещенное отклонение | Смещенная оценка среднего квадратического отклонения генеральной совокупности по выборке данных.
Несмещенная дисперсия | Несмещенная оценка дисперсии генеральной совокупности по выборке данных.
Смещенная дисперсия | Смещенная оценка дисперсии генеральной совокупности по выборке данных.


 Подведение " вложенных" или многоуровневых итогов

Подведение " вложенных" или многоуровневых итогов

Чтобы " вложить" или вставить итог для групп, находящихся внутри уже существующих групп, необходимо отсортировать список.

  1. Отсортируйте список по двум или более столбцам, для которых необходимо подвести итог. Например, чтобы просуммировать проданные единицы продукции по регионам и по лицам внутри каждого региона, в первую очередь, следует отсортировать список по столбцу регионов, а затем - по столбцу продавцов лицами. При подведении промежуточных итогов, значения итогов по продавцам вкладываются в итоги по регионам.

    Инструкции

  2. Вставьте автоматические итоги для первого столбца, содержащего группы суммируемых данных. Этот столбец при сортировке списка должен быть указан в поле Сортировать по. (В примере, приведенном на шаге 1, первым столбцом должен быть столбец регионов.)

    Инструкции

  3. После создания автоматических итогов в первом столбце, повторите процедуру для следующего столбца.

  4. Укажите ячейку в этом списке.

  5. Выберите команду Итоги в меню Данные.

  6. Выберите следующий столбец, по которому необходимо подвести итоги, из списка При каждом изменении в.

  7. Снимите флажок Заменить текущие итоги, а затем нажмите кнопку OK.

  8. Повторите шаги с 4 по 7 для каждого столбца, по которому необходимо подвести итоги.


 Удаление промежуточных итогов

Удаление промежуточных итогов

При удалении промежуточных итогов из списка, удаляется структура и все разрывы страниц, которые были вставлены в список при подведении итогов.

  1. Выделите ячейку в списке, содержащую промежуточный итог.

  2. Выберите команду Итоги в меню Данные.

  3. Нажмите кнопку Убрать все.


 Создание структуры листа

Создание структуры листа

Использование структуры

Когда данные представлены в виде списка, Microsoft Excel может создать структуру, что позволяет скрыть и отобразить уровни детализации простым нажатием кнопки мыши. Структура позволяет быстро отобразить только строки или столбцы с итоговыми значениями, заголовки разделов листа или отобразить области подробных данных, подчиненных итоговым строкам или столбцам.

Отображение и скрытие подробных данных Структура может иметь до 8 уровней детализации, в которых каждый уровень обеспечивает подробную информацию для предыдущего уровня. В приведенном ниже примере строка, содержащая общий итог для всех строк, имеет уровень 1, строки, содержащие итоги для южного и западного регионов, имеют уровень 2 и конкретные данные для областей имеют уровень 3. Для отображения только строк на определенном уровне достаточно щелкнуть номер уровня, который нужно просмотреть. Строки с подробностями для западного региона скрыты, но можно щелкнуть символ структуры + для их отображения.

Способы структурирования данных

Вставка автоматических промежуточных итогов также создает структуру При использовании команды Итоги (меню Данные) для добавления промежуточных итогов в список, представленный в виде строк, Excel структурирует лист, давая возможность отобразить ровно столько подробной информации, сколько необходимо.

Автоматическое создание структуры листа Если данные на листе обобщены формулами, которые используют функции, например СУММ, Excel позволяет автоматически структурировать данные, как в приведенном выше примере. Итоговые данные должны располагаться рядом с подробными данными.

Ручное создание структуры листа Если данные не организованы так, что Excel может создать структуру автоматически, структура может быть создана вручную. Пример ручного создания структуры данных, если строки или столбцы с итоговыми данными содержат не формулы, а значения, приведен ниже. Если необходимо скрыть строки с подробными данными за апрель и май, это можно сделать, структурируя лист вручную.

Список с итогами, введенными как значения

Поскольку итоги в этом списке введены как числа, а не вычисляются по формулам, автоматическое создание структуры не будет работать.

Дополнительные сведения

Создание списка с заголовками

Автоматическое структурирование листа

Структурирование листа вручную

Подведение промежуточных итогов

Использование символов структуры для отображения и скрытия подробных данных


 Просмотр или скрытие детальных данных в структуре

Просмотр или скрытие детальных данных в структуре

Если на листе отсутствуют символы структуры, то установите флажок Символы структуры вкладки Вид диалогового окна Параметры (меню Сервис).

Чтобы просмотреть | Действие
детальные данные внутри группы | кнопку
определенный уровень структуры | символ уровня строки или столбца
все детальные данные в структуре | символ самого нижнего уровня строки или столбца. Например, если существует три уровня, то нажмите кнопку [image] .

Чтобы скрыть | Действие
детальные данные внутри группы | панель уровня строки панель уровня столбца Щелкните мышью в любом месте на панели уровня или символ скрытия детальных данных [image] .
определенный уровень структуры | символ предыдущего уровня строки или столбца [image] . Например, если в структуре четыре уровня, то скрыть четвертый можно, нажав на кнопку [image] .
все детальные данные в структуре | символ первого уровня


 Отображение или скрытие символов структуры без ее удаления

Отображение или скрытие символов структуры без ее удаления

  1. В меню Сервис выберите команду Параметры, а затем перейдите к вкладке Вид.

  2. Чтобы сделать символы структуры видимыми, установите флажок Символы структуры.

    Чтобы скрыть соответствующие символы, снимите этот флажок.


 Автоматическое создание структуры листа

Автоматическое создание структуры листа

Убедитесь, что страница имеет иерархическую структуру и все итоговые формулы, которые необходимо структурировать, расположены там же, где и сведения. Это значит, что все итоговые столбцы должны быть справа или слева от сведений, но не смешаны с ними. Все итоговые строки должны быть ниже или выше, но не смешаны со сведениями.

  1. Выделите диапазон ячеек, для которых необходимо создать структуру.

    Для структурирования листа целиком укажите любую ячейку.

  2. Выберите команду Группа и структура в меню Данные,а затем — Создание структуры.

    См. сведения о создании структуры листа, включая отображение и скрытие сведений в структуре.


 Структурирование листа вручную

Структурирование листа вручную

Убедитесь, что итоговые строки или столбцы во всех областях, которые требуется структурировать, расположены в одном направлении относительно детальных данных. Другими словами, все итоговые столбцы должны находиться либо справа, либо слева от детальных данных, но не вперемешку. Все итоговые строки должны находиться либо под данными, либо над ними, но не вперемешку.

  1. Выделите строки или столбцы, содержащие детальные данные.

    Инструкции

    Строки или столбцы детальных данных обычно прилегают к строке или столбцу, содержащему соответствующие итоговые данные. Например, если строка 6 содержит суммы для строк с 3 по 5, то выделите строки 3 - 5.

  2. Выберите в меню Данные команду Группа и структура и подкоманду Группировать.

    Рядом с группой на экране появятся символы структуры.

  3. Продолжайте выделение детальных строк или столбцов и выполнение команды Группировать до тех пор, пока не будут созданы все необходимые уровни структуры.

Примечание. По умолчанию итоговые строки располагаются под детальными строками, а итоговые столбцы —справа от детальных столбцов. Если итоговые строки или столбцы располагаются по-другому, перед структурированием можно изменить эти настройки. Для этого выберите в меню Данные команду Группа и структура и подкоманду Настройка, а затем установите флажки в группе В направлении.

См. дополнительные сведения о создании структуры листа, включая отображение и скрытие подробных данных в структуре.


 Разгруппировка строк или столбцов в структуре

Разгруппировка строк или столбцов в структуре

  1. Выделите строки или столбцы, которые необходимо разгруппировать.

  2. Выберите команду Структура в меню Данные, а затем — команду Разгруппировать.

Примечание. Когда разгруппировываются строки или столбцы в структуре, имеющей несколько уровней, строки и столбцы становятся частью группы более высокого уровня. Например, если разгруппировывается группа уровня 3, она становится группой уровня 2. Продолжайте разгруппирование выделенной части листа, пока она не окажется на требуемом уровне.

Совет. Чтобы внутри структуры выделить определенную группу данных, удерживая клавишу SHIFT щелкните мышью обозначение «Показать детали» [image] или обозначение «Скрыть детали» [image] или линию уровня раздела структуры.


Удаление структуры полностью

При удалении структуры данные в листе не изменяются.

  1. Укажите любую ячейку на листе.

  2. Выберите команду Структура в меню Данные, а затем – Удалить структуру.


Консолидация данных с использованием трехмерных ссылок

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Консолидация данных

Консолидация данных

Предусмотрено несколько способов консолидации:

С помощью трехмерных ссылок (наиболее предпочтительный способ). При использовании трехмерных ссылок отсутствуют ограничения на расположение данных в исходных областях. См. Консолидация данных с использованием трехмерных ссылок.

По расположению. Консолидацию по расположению следует использовать в случае, если данные всех исходных областей находятся в одном месте и размещены в одинаковом порядке; например, этот способ можно использовать для консолидации данных нескольких листов, созданных на основе одного шаблона.

Если данные вводятся с помощью нескольких листов-форм, основанных на одном шаблоне, и при этом требуется выводить данные из каждой формы на отдельный лист, следует воспользоваться мастером шаблонов с функцией автоматического сбора данных.

По категории. Консолидацию по категории следует использовать в случае, если требуется обобщить набор листов, имеющих одинаковые заголовки, но с различной организацией данных. Этот способ позволяет консолидировать данные с одинаковыми заголовками со всех листов.

С помощью отчета сводной таблицы. Данный метод сходен с консолидацией по категории, однако обладает большей гибкостью в отношении реорганизации категорий. См. Консолидация данных путем создания отчета сводной таблицы.


Консолидация данных

Предполагаемые действия

Консолидация данных с использованием трехмерных ссылок

Консолидация данных по расположению

Использование мастера шаблонов

Консолидация данных по категориям

Консолидация данных путем создания отчета сводной таблицы

Дополнительные сведения


 Задание исходных областей консолидируемых данных

Задание исходных областей консолидируемых данных

Исходные области консолидируемых данных задаются либо трехмерными формулами, либо в поле Ссылка диалогового окна Консолидация (команда Консолидация, меню Данные). Источники данных могут находиться на том же листе, что и таблица консолидации, на других листах той же книги, в других книгах или в файлах Lotus 1-2-3.

Приступая к работе

Присвойте имена исходным областям Чтобы упростить слежение за исходными областями, поименуйте каждый диапазон и используйте имена в поле Ссылка. См. сведения о подписях и именах в формулах.

Ссылки на исходные области

На том же листе Если исходные области и область назначения находятся на одном листе, используйте имена или ссылки на диапазоны.

На разных листах Если исходные области и область назначения находятся на разных листах, используйте имя листа и имя или ссылку на диапазон. Например, чтобы включить диапазон с заголовком «Бюджет», находящийся в книге на листе «Бухгалтерия», введите Бухгалтерия!Бюджет.

В разных книгах Если исходные области и область назначения находятся в разных книгах, используйте имя книги, имя листа, а затем — имя или ссылку на диапазон. Например, чтобы включить диапазон «Продажи» с листа «Дальний Восток» книги «1996», введите:

'[1996.xls]Дальний Восток'!Продажи

На разных устройствах Если исходные области и область назначения находятся в разных книгах разных каталогов диска, используйте полный путь к файлу книги, имя книги, имя листа, а затем — имя или ссылку на диапазон. Например, чтобы включить диапазон «Оборот» листа «Февраль» в книге «Отдел продаж», которая находится в папке «Бюджет», введите:

'[C:\Бюджет\Отдел продаж.xls]Февраль'!Оборот

Примечание. Если диапазонам назначены уникальные, не присвоенные автоматически имена, то в ссылке можно не указывать имена листов. Например '[1996.xls]'!Продажи или '[C:\Бюджет\Отдел продаж.xls]'!Оборот в предыдущих примерах.

Совет. Чтобы задать описание источника данных, не нажимая клавиш клавиатуры, укажите поле Ссылка, а затем выделите исходную область. Чтобы задать исходную область в другой книге, нажмите кнопку Обзор. Чтобы убрать диалоговое окно Консолидация на время выбора исходной области, нажмите кнопку Свернуть диалоговое окно [image] .

Дополнительные сведения

Консолидация данных по расположению

Консолидация данных по категориям


 Изменение итоговой таблицы консолидации данных

Изменение итоговой таблицы консолидации данных

После создания итоговой таблицы с помощью команды Консолидация можно добавлять, удалять или изменять исходные области данных. Кроме этого, можно создать связи итоговой таблицы с исходными данными, с тем чтобы данные области назначения автоматически обновлялись при изменении данных в исходных областях.

Предполагаемые действия

Добавление области данных в итоговую таблицу

Изменение области данных в итоговой таблице

Удаление области данных из итоговой таблицы

Создание связей итоговой таблицы с исходными данными для ее автоматического обновления

Примечание. Если консолидация данных производилась с помощью трехмерных ссылок, то изменение итоговой таблицы осуществляется посредством изменения формул (например, для добавления исходных областей) или удаления листа из списка листов, используемых в формулах.


Интерактивный анализ данных по отчетам сводных таблиц

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Создание отчета сводной таблицы

Создание отчета сводной таблицы

Когда отчет сводной таблицы основывается на внешних не-OLAP исходных данных, может потребоваться загрузка внешних данных до создания отчета. См. сведения о способах загрузки внешних данных для отчета сводной таблицы.

  1. Откройте книгу, в которой требуется создать отчет сводной диаграммы.

    Если отчет создается на основе списка Microsoft Excel или базы данных, щелкните ячейку в этом списке или базе данных.

  2. Выберите в меню Данные команду Сводная таблица.

  3. На шаге1 выполнения мастера сводных таблиц и диаграмм установите переключатель Вид создаваемого отчета в положение Сводная таблица.

  4. Следуйте инструкциям на шаге 2 мастера.

  5. На шаге 3 решите, нужно ли нажимать кнопку Макет.

  6. Выполните одно из следующих действий:

    Если на шаге 3 была нажата кнопка Макет, выполните формирование макета отчета, нажмите кнопку OK в диалоговом окне Мастер сводных таблиц и диаграмм – Макет, а затем кнопку Готово для создания отчета.

    Если кнопка Макет на шаге 3 не была нажата, нажмите кнопку Готово, а затем сформируйте макет отчета на листе.

Примечание. При создании отчета сводной диаграммы Excel автоматически создает связанный отчет сводной таблицы. См. сведения о создании отчетов сводных диаграмм.


 Отображение отчета сводной таблицы в структурированном формате

Отображение отчета сводной таблицы в структурированном формате

Когда используется эта процедура для изменения способа отображения из неструктурированного (перекрестная таблица) формата в структурированный, любое поле столбца в отчете сводной таблицы становится внешнимполем строки.

  1. Щелкните отчет сводной таблицы.

  2. На панели инструментов Сводная таблица нажмите кнопку Формат отчета [image] .

  3. В списке форматов отчета выберите структурированный макет

    Макеты с Отчет 1 до Отчет 10 являются структурированными. См. сведения о доступных форматах и макетах.

Примечания

  • Восстановление предыдущего макета отчета сводной таблицы Нажмите кнопку Отмена [image] сразу после нажатия кнопки Формат отчета [image] .

  • Влияние на связанные отчеты сводных диаграмм Когда формат отчета сводной таблицы, связанного с отчетом сводной диаграммы, изменяется с неструктурированного на структурированный, поля рядов в диаграмме становятся полями категорий. Кроме того, некоторые форматирования диаграммы могут быть утеряны.

  • Ручная установка структурированного формата Перетащите мышью все поля столбцов в область полей строк, дважды щелкнитекнопку поля для самого левого поля строки, нажмите кнопку Макет и затем установите переключатель в виде структуры. Параметры макета сохраняются для поля даже при его перемещении в другую область отчета сводной таблицы, но поле отображается с отступом только тогда, когда оно является полем строки.


Создание отчета Microsoft Access на основе данных списка Microsoft Excel

Для просмотра этого раздела выберите мышью соответствующий графический объект.


 Разрешение вопросов, возникающих при консолидации данных

Разрешение вопросов, возникающих при консолидации данных

Здесь приводятся советы только для тех случаев, когда консолидация данных осуществлялась с использованием команды Консолидация в меню Данные. Они неприменимы, если использовались трехмерные ссылки. См. сведения о расчете значений с помощью формул.

Все консолидации

Проверьте ссылки на исходные области Убедитесь, что ссылки на все исходные области введены правильно.

Проверьте итоговую функцию Убедитесь, что выбрана подходящая итоговая функция в диалоговом окне Консолидация.

Проверьте область назначения Убедитесь, что заданная область назначения достаточно велика, чтобы включать все консолидированные данные. Чтобы избежать проблем с формой области назначения, при создании таблицы консолидации укажите левый верхний угол области назначения. Убедитесь, что справа и выше левой верхней ячейки таблицы оставлено достаточное количество ячеек, поскольку команда Консолидация заполняет такую область, какая ей нужна.

Дополнительные сведения о разрешении вопросов, связанных с формулами.

Консолидация данных по расположению

Убедитесь, что в каждой исходной области содержатся данные одинакового типа и в надлежащем порядке.

Консолидация данных по категории

Включение подписей строк и столбцов В диалоговом окне Консолидация в группе Использовать в качестве имен должен быть установлен флажок Подписи верхней строки или Подписи левого столбца или оба одновременно. Убедитесь, что соответствующие подписи включены в исходные области.

Проверка идентичности подписей категорий Убедитесь, что заголовки категорий одинаковы (включая регистр букв) во всех исходных областях. Например, заголовки "Ср. за год" и "Средний за год" различаются и не будут объединены в таблице консолидации.

Проверка уникальности категорий Убедитесь, что любая категория, по которой не будет производиться консолидация, имеет уникальное имя, которое встречается только в одной исходной области.


Разрешение вопросов, возникающих при создании структуры

В чем именно заключаются сложности?

При копировании итоговых строк копируются также отдельные строки

В структуре, состоящей из нескольких уровней, данные не группируются должным образом

Символы структуры на отображаются на листе

После разгруппировки данных или удаления структуры данные остаются скрытыми


Элементы отчета сводной таблицы

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Различия между сводными таблицами и отчетами сводных диаграмм, основанными на различных типах источников данных (OLAP и не-OLAP)

Различия между сводными таблицами и отчетами сводных диаграмм, основанными на различных типах источников данных (OLAP и не-OLAP)

При работе со сводной таблицей или отчетом сводной диаграммы, которые основаны на исходных данных OLAP и с отчетами, основанными на не-OLAP исходных данных, следует обратить внимание на доступные возможности и на то, как эти возможности работают. База данных OLAP обеспечивает выполнение некоторых возможностей анализа на сервере, включая предварительный расчет итоговых значений и иерархическую организацию данных.

Обзор: организация и предоставление данных базами данных OLAP

Отличия в получении и обновлении данных

Отличия в макете и разработке

Отличия в вычислениях

Обзор: организация и предоставление данных базами данных OLAP

Базы данных OLAP организованы таким образом, чтобы облегчить получение и обновление больших объемов данных. До того как Microsoft Excel отображает обобщенные данные в сводной таблице или отчете сводной диаграммы, сервер OLAP выполняет вычисления для обобщения данных. Только требуемые обобщенные данные возвращаются в Excel. При работе с не-OLAP внешней базой данных передаются все отдельные записи, а Excel выполняет обобщение. Следовательно, базы данных OLAP дают Excel возможность анализировать значительно большие объемы внешних данных.

Сервер OLAP передает новые данные в Excel при каждом изменении макета или представления сводной таблицы или отчета сводной диаграммы. При использовании не-OLAP исходных данных используется другой способ, имеющий параметры обновления. Обновление данных сводной таблицы и сводной диаграммы.

Не-OLAP данные могут быть переданы в Excel в виде внешнего диапазона данных, сводной таблицы или отчета сводной диаграммы. Данные OLAP могут быть переданы в Excel только в виде сводной таблицы или отчета сводной диаграммы.

Сводная таблица и отчет сводной диаграммы, построенные по не-OLAP исходным данным, делают доступными возможности Excel по анализу данных, например задание требуемой итоговой функции. При использовании исходных данных OLAP некоторые возможности анализа предоставляются непосредственно сервером OLAP, а не Excel. Например, для исходных данных OLAP итоговые функции определены на сервере. Для расширения функциональных возможностей базы данных OLAP необходимо обратиться к администратору сервера OLAP.

Создание отчета сводной таблицы по данным OLAP

Использует ли отчет сводной таблицы данные OLAP

Возврат в начало

Отличия в получении и обновлении данных

Обновление Сводная таблица и отчеты сводных диаграмм, основанные на исходных данных OLAP, обновляются автоматически всякий раз при изменении отображаемых данных. Для отчетов, основанных на не-OLAP исходных данных, доступен ряд параметров обновления. Обновление данных сводной таблицы и сводной диаграммы.

Параметры поля страницы В сводной таблице и отчетах сводной диаграммы, основанных на не-OLAP исходных данных, можно использовать параметры поля страницы для извлечения данных для каждого элемента поля страницы индивидуально или для всех элементов сразу. Эти параметры поля страницы недоступны для отчетов, основанных на исходных данных OLAP. Исходные данные OLAP всегда выбираются для каждого элемента по необходимости, что позволяет отчетам отображать информацию из баз данных больших объемов. Параметры поля страницы.

Фоновый запрос Эта возможность, которая позволяет продолжать работу в Excel во время выборки данных для сводной таблицы или отчета сводной диаграммы, доступна только для отчетов, основанных на не-OLAP исходных данных.

Запросы с параметрами К не-OLAP исходным данным можно обратиться посредством запроса с параметрами, поместить возвращаемые данные во внешний диапазон данных и построить по этому диапазону сводную таблицу или отчет сводной диаграммы. Для извлечения данных из базы данных OLAP запрос с параметрами не может быть использован. Запросы, формирующие исходные данные для сводных таблиц.

Параметр оптимизации использования памяти Эта установка (панель инструментов Сводная таблица, меню Сводная таблица, команда Параметры таблицы или меню Сводная диаграмма, команда Параметры) доступна только для сводных таблиц и отчетов сводных диаграмм, которые основаны на не-OLAP исходных данных.

Возврат в начало

Отличия в макете и разработке

Раскладка полей Для исходных данных OLAP поля размерности идентифицируются Значок поля размерности в начале строки на панели инструментов Сводная таблица. Эти поля могут быть использованы только как поля строк, столбцов и страниц в сводной таблице и как поля рядов, категорий и страниц в отчетах сводных диаграмм. Поля, идентифицируемые Значок поля данных в начале строки на панели инструментов, могут быть использованы только как поля данных. Любое поле из не-OLAP исходных данных может быть использовано как любая часть сводной таблицы или отчета сводной диаграммы, поскольку отсутствуют ограничения на использование полей в программах на языке Visual Basic для приложений (VBA) и в макросах в книге.

Переименование полей и элементов Для исходных данных OLAP переименование полей и элементов возвращает к их исходным именам при повторном отображении и добавляет к отчету при удалении их из представления. Для не-OLAP исходных данных в аналогичных ситуациях сводная таблица и отчет сводной диаграммы поддерживают новые имена полей и элементов.

Группирование и разгруппирование элементов в полях Команды Группировать и Разгруппировать доступны только для полей из не-OLAP исходных данных. Поля размерностей OLAP обеспечивают функциональность, аналогичную группированию.

Доступ к подробным данным Для отчетов сводных таблиц и сводных диаграмм, основанных на не-OLAP исходных данных, можно отобразить подробные данные, соответствующие значениям поля данных и элементов. Отображение подробных данных для значений полей данных может быть запрещено. В базах данных OLAP итоговые значения вычисляются на сервере. Отчет позволяет отобразить самый нижний уровень деталей, доступный на сервере OLAP, но соответствующие подробные записи не могут быть отображены в отчете.

Отображение элементов, не содержащих данные Эта команда доступна только для отчетов сводных таблиц и сводных диаграмм, основанных на не-OLAP исходных данных.

Исходный порядок сортировки Для не-OLAP исходных данных элементы в новых отчетах сводных таблиц и сводных диаграмм появляются первоначально отсортированными по возрастанию имен элементов. Для исходных данных OLAP элементы появляются в том порядке, в котором сервер OLAP извлекает их. Впоследствии элементы могут быть переставлены или отсортированы вручную, если они должны находиться в другом порядке.

Элемент Все в полях страниц Для не-OLAP исходных данных элемент Все, который объединяет значения для каждого элемента в поле, доступен, несмотря на то, что поле страницы устанавливается для отдельного доступа к данным для каждого элемента. Поля размерностей OLAP не могут включать элемент Все.

Команда Отобразить Страницы Эта команда доступна только для отчетов сводных таблиц и сводных диаграмм, основанных на не-OLAP исходных данных.

Возврат в начало

Отличия в вычислениях

Итоговые функции Для отчетов сводных таблиц, основанных на не-OLAP исходных данных, итоговая функция для поля данных может быть изменена, может быть использовано и несколько итоговых функций для одного поля данных. Серверы OLAP обеспечивают обобщение значений непосредственно в отчет сводной таблицы. Итоговая функция для поля данных из источника данных OLAP не может быть изменена. Если сервер OLAP обеспечивает несколько полей данных для разных итогов, то можно использовать несколько итоговых функций.

Вычисляемые поля и элементы В отчете сводной таблицы, основанном на исходных данных OLAP, вычисляемые поля или вычисляемые элементы не могут быть созданы.

Промежуточные итоги В отчетах сводных таблиц, основанных на не-OLAP исходных данных, промежуточные итоги могут быть отображены для всех полей строк и столбцов. Для отчетов сводных таблиц, основанных на исходных данных OLAP, итоговая функция для промежуточных итогов не может быть изменена и промежуточные итоги не могут быть отображены для внутренних полей строк и столбцов. Поскольку итоги вычисляются на сервере OLAP, нельзя изменить установки для включения и исключения скрытых элементов поля страницы в итоги. Подсчет итоговых значений в отчетах сводных таблиц.

Отличия в методах вычислений.

Возврат в начало


Выбор источника данных для сводной таблицы и отчета сводной диаграммы

При создании сводной таблицы или отчета сводной диаграммы могут использоваться разные источники данных.

Типы исходных данных

Списки или базы данных Microsoft Excel

Другой отчет сводной таблицы

Внешние источники данных

Несколько диапазонов данных для консолидации


 Использование Мастера сводных таблиц и сводных диаграмм - диалоговое окно Макет

Использование Мастера сводных таблиц и сводных диаграмм - диалоговое окно Макет

Всегда когда возможно производите раскладку сводной таблицы или отчета сводной диаграммы прямо на листе, так чтобы можно было видеть данные при выстраивании полей. Нажмите Макет на шаге 3 Мастера сводных таблиц и сводных диаграмм для создания макета сводной таблицы или отчета сводной диаграммы в следующих случаях:

  • Используются некоторые внешние источники данных Для некоторых типов внешних источников данных, включая большие базы данных, создание макета на листе может потребовать значительного времени. Например, отчет, основанный на кубе, созданном с помощью Мастера куба OLAP в Microsoft Query, будет медленно отображать изменения в макете. Если при создании макета на листе после перетаскивания полей на место данные отображаются с задержкой, можно выбрать Мастера сводных таблиц [image] на панели инструментов Сводная таблица, перейти на шаг 3 и затем нажать Макет.

  • Необходимо изменить установки поля страницы Используйте Макет, если сводная таблица или отчет сводной диаграммы основан на внешних не-OLAP исходных данных и необходимо создать поле страницы, которое извлекает данные для каждого элемента отдельно. Использование полей страниц для работы с большими базами данных. Параметры поля страницы недоступны для сводных таблиц и отчетов сводных диаграмм, основанных на исходных данных из баз данных OLAP.

Предполагаемые действия

Создание макета новой сводной таблицы или отчета сводной диаграммы с помощью Мастера сводных таблиц и сводных диаграмм – диалоговое окно Макет

Создание макета нового отчета сводной таблицы на листе

Создание макета нового отчета сводной диаграммы на листе


 Создание макета нового отчета с помощью диалогового окна «Мастер сводных таблиц и диаграмм – макет»

Создание макета нового отчета с помощью диалогового окна «Мастер сводных таблиц и диаграмм – макет»

Следующая процедура используется после нажатия кнопки Макет на шаге 3 выполнения мастера сводных таблиц и диаграмм.

  1. Из группы кнопок полей, расположенной справа, перетащите нужные поля в области диаграммы СТРОКА и СТОЛБЕЦ.

    В отчетах сводных таблиц подписи полей строк и элементов отображаются слева. Подписи полей столбцов и элементов отображаются сверху.

    В отчетах сводных диаграмм элементы полей строк отображаются на оси категорий, а элементы полей столбцов — в виде рядов данных.

    При использовании исходных данных OLAP в качестве полей строк, столбцов или страниц могут использоваться только поля, помеченные значком Значок поля размерности в начале строки на панели инструментов Сводная таблица.

  2. Поля, содержащие данные, которые требуется обобщить, перетащите в область ДАННЫЕ.

    В отчетах сводных диаграмм поля данных определяют значения для оси значений.

    При использовании исходных данных OLAP в качестве полей данных можно использовать только поля, помеченные значком Значок поля данных в начале строки на панели инструментов. Эти поля отображаются в нижней части группы кнопок полей.

  3. В отчетах сводных таблиц или сводных диаграмм, основанных на не-OLAP исходных данных, для полей данных можно использовать различные итоговые функции. Для этого следует дважды щелкнуть поле в области ДАННЫЕ, выбрать нужную функцию в списке Операция, а затем нажать кнопку OK. См. сведения о доступных итоговых функциях.

    Для того чтобы включить поле данных несколько раз, чтобы можно было использовать дополнительные итоговые функции, перетащите поле в область ДАННЫЕ повторно.

  4. Поля, которые требуется использовать как поля страниц, перетащите в область СТРАНИЦА.

    По умолчанию Microsoft Excel получает данные сразу для всех элементов полей страниц . Для того чтобы данные загружались для каждого из элемента полей страниц по отдельности (при использовании внешних не-OLAP исходных данных), дважды щелкните каждое поле в области СТРАНИЦА, нажмите кнопку Далее, установите переключатель в положение Обновлять внешние данные при выборе каждого элемента, а затем два раза нажмите кнопку OK. См. сведения об использовании полей страниц для работы с большими базами данных.

  5. Для изменения расположения полей перетащите их из одной области в другую. Для того чтобы удалить поле, перетащите его за пределы диаграммы. Получив нужный макет, нажмите кнопку OK, а затем кнопку Готово.

    Существует два способа изменения расположения полей после создания отчета в Excel. Можно попробовать изменить порядок полей на листе, либо щелкнуть завершенный отчете сводной таблицы (или связанный отчет сводной таблицы для отчета сводной диаграммы), нажать кнопку Мастер сводных таблиц [image] на панели инструментов Сводные таблицы, чтобы вернуться к шагу 3, а затем нажать кнопку Макет.

Примечание. Поля строк, столбцов и страниц из источника данных OLAP изначально отображают данные верхнего уровня. Имена полей наивысшего уровня в отчете сводной таблицы или сводной диаграммы могут не совпадать с именами на кнопках полей. Например, кнопка поля для размерности с названием «География» может иметь в отчете имя поля наивысшего уровня, «Страна», но изначально может отображать элементы уровня «Страна», например «США», «Канада» и т.п. После перетаскивания полей в отчет можно отобразить данные нижнего уровня этих полей.


 Об использовании других исходных данных для отчета сводной таблицы или сводной диаграммы

Об использовании других исходных данных для отчета сводной таблицы или сводной диаграммы

Изменения в исходных данных сводных таблиц и сводных диаграмм могут привести к тому, что для анализа будут доступны другие данные. Обновив отчет сводной таблицы или сводной диаграммы, можно включить в него новые данные, отвечающие первоначальной спецификации исходных данных.

Если требуется проанализировать другие данные в имеющемся отчете сводной таблицы или сводной диаграммы, следует переопределить включаемые в него исходные данные. Способ переопределения исходных данных зависит от типа источника. В случае, если требуется использовать существенно отличающиеся исходные данные со множеством других или дополнительных полей, может быть легче создать новый отчет сводной таблицы или новый отчет сводной диаграммы.

Изменение создаваемых кубов OLAP. Если в Microsoft Excel создан файл автономного куба, или с помощью мастера создания куба OLAP в Microsoft Query определен куб для не-OLAP исходных данных, можно изменить имеющийся файл куба или определение куба для включения других данных.

Включение других поле или записей из исходных данных Microsoft Excel. Для отчетов сводных таблиц и сводных диаграмм, основанных на данных Microsoft Excel, можно с помощью мастера сводных таблиц и диаграмм переопределить исходную область для включения других данных.

Изменение запроса для извлечения других исходных данных. Если во внешней не-OLAP базе данных становятся доступными новые столбцы или поля, или если требуется выбрать другие внешние данные для отчета сводной таблицы или сводной диаграммы, можно изменить запрос для выбора других данных.

При обновлении могут также извлекаться другие исходные данные. Обновление отчета сводной таблицы или сводной диаграммы может также изменить данные, доступные для отображения. Для отчетов сводных таблиц и сводных диаграмм, основанных на данных списков Excel, Excel извлекает новые поля из исходного диапазона или указанного именованного диапазона. Для отчетов сводных таблиц и сводных диаграмм, основанных на внешних данных, Excel извлекает новые данные, отвечающие условиям соответствующего запроса или добавленные в куб OLAP. В Microsoft Excel имеется несколько способов обновления отчета сводной таблицы или сводной диаграммы.

Влияние использования различных исходных данных на форматирование отчета сводной диаграммы. При изменении исходных данных, используемых для отчета сводной диаграммы или отчета сводной таблицы, связанного с отчетом сводной диаграммы, некоторые параметры форматирования диаграммы могут быть утеряны.


 Использование другого источника данных для сводной таблицы или отчета сводной диаграммы

Использование другого источника данных для сводной таблицы или отчета сводной диаграммы

Если исходные данные, указанные для сводной таблицы или отчета сводной диаграммы, не включают данные, которые необходимо отобразить, можно изменить исходные данные, используемые отчетом.

Обновление сводной таблицы или отчета сводной диаграммы может также изменить данные, доступные для отображения. Microsoft Excel предлагает несколько способов обновления сводной таблицы или отчета сводной диаграммы.

Предполагаемые действия

Изменение содержимого и установок источника данных куба OLAP

Изменение данных или полей, включенных в исходный диапазон для сводной таблицы или отчета сводной диаграммы

Изменение запроса для сводной таблицы или отчета сводной диаграммы с целью получения других данных или полей

Не можете сделать выбор?


 Использование отчетов сводных таблиц Excel, импортированных из списков сводных таблиц в Интернете.

Использование отчетов сводных таблиц Excel, импортированных из списков сводных таблиц в Интернете.

При экспорте списков сводных таблиц из обозревателя Web в отчет сводной таблицы Microsoft Excel, следует обратить внимание на ряд отличий. Некоторые макеты списков сводных таблиц не могут быть отображены как отчет сводной таблицы Excel и некоторые вычисления в списках сводных таблиц не могут отображены в отчетах Excel. Этот раздел обобщает указанные отличия. За информацией о подготовке списков сводных таблиц в Интернете для успешного экспорта в Excel следует обратиться к справке по спискам сводных таблиц, доступной в обозревателе Web.

Имена команд и компонентов

Отличия в компонентах

Отличия в вычислениях

Компоненты списков сводных таблиц, не поддерживаемые Excel

Дополнительные сведения

Имена команд и компонентов

Доступ к командам В отчетах сводных таблиц Excel доступ к командам и компонентам осуществляется по-другому, чем в обозревателе Web. Вместо панели инструментов и панели свойств, как в обозревателе Web, в Excel используется панель инструментов Сводная таблица и другие команды. Многие команды имеют другие имена. Для поиска нужных команд Excel воспользуйтесь услугами Помощника.

Поля данных Отчет сводной таблицы Excel включает поля данных вместо полей итогов.

Поля страниц В отчетах сводных таблиц поля фильтров называются полями страниц.

Возврат в начало

Отличия в компонентах

Макеты Список сводной таблицы на Web-странице может одновременно отображать обобщенные данные и соответствующие подробные данные. Отчет сводной таблицы Excel не может отобразить и то, и другое одновременно, в результате чего некоторые макеты списков сводных таблиц не могут быть экспортированы в Excel. Однако, отчеты сводных таблиц Excel позволяют создавать структурированные макеты, которые недоступны в списках сводных таблиц в Интернете.

Отображение и скрытие детелей Объекты в списках сводных таблиц в Интернете имеют индикаторы расширения Поле плюс для отображения деталей и Поле минус для скрытия деталей. В отчетах сводных таблиц Excel детали могут быть отображены или скрыты либо с помощью стрелок, раскрывающих поля Стрелка поля , либо с помощью кнопок Отобразить детали [image] и Скрыть детали [image] на панели инструментов Сводная таблица.

Порядок сортировки Объекты нового списка сводной таблицы на Web-странице отображаются в том порядке, в каком они получены из исходных данных. Сортировка объектов автоматически выполняется всякий раз, когда производится обновление списка или изменение макета. В отчете сводной таблицы Excel, основанном на источнике данных OLAP, объекты сортируются в том же порядке, что и в списке сводной таблицы. В отчете сводной таблицы, основанном на не-OLAP источнике данных, объекты первоначально сортируются в возрастающем порядке. Объекты могут быть отсортированы вручную (при этом объекты не будут сортироваться при обновлении отчета) или автоматически (при обновлении объекты будут вновь отсортированы).

Фильтрация В списках сводных таблиц в Интернете, которые основаны на источнике данных OLAP, при отборе элементов на нижних уровнях полейразмерности, отбор будет действовать и тогда, когда эти поля не будут отображаться. В отчетах сводных таблиц Excel эти параметры фильтра не поддерживаются, но можно произвести повторный отбор нижних уровней при их отображении.

Переименование элементов В списке сводной таблицы на Web-странице можно переименовывать поля, но не объекты. В отчете сводной таблицы Excel можно переименовывать и поля, и объекты. (В отчетах сводных таблиц, основанных на источнике данных OLAP, изменение имен не поддерживается, если после переименования полей или объектов они повторно отображаются после удаления их из представления.)

Форматирование В списке сводной таблицы на Web-странице форматирование применяется к выбранным частям отчета, а не к ячейкам. Можно выбрать и отформатировать поля, объекты и итоги с помощью форматов символов и форматов ячеек. В отчете сводной таблицы Excel имеется более широкий набор возможностей: можно отформатировать ячейки или выбранные элементы сводной таблицы, кроме того можно изменить отображение ошибок и пустых ячеек.

Поля фильтра, называемые в Excel полями страниц В списке сводной таблицы на Web-странице эти поля всегда расположены вверху. В отчете сводной таблицы Excel поля страниц могут быть отображены вдоль верхней или левой сторон экрана с указанием числа полей, отображаемых в строке или столбце.

Обновление Списки сводных таблиц в Интернете не имеют параметров обновления и поддерживаются в обновленном состоянии, пока они открыты в обозревателе. Отчеты сводных таблиц Excel имеют несколько параметров, которые определяют время и способ обновления данных.

Справка Справка по спискам сводных таблиц в Интернете предоставляется как список тем, в котором можно производить поиск. В Excel можно воспользоваться услугами Помощника для получения справки.

Возврат в начало

Отличия в вычислениях

Итоговые функции В списке сводной таблицы на Web-странице доступны следующие итоговые функции для полей данных и промежуточных итогов: сумма, количество значений, минимальное и максимальное значение. В отчетах сводных таблиц Excel, которые основаны на не-OLAP источнике данных, доступны одиннадцать итоговых функций. Для отчетов сводных таблиц в Excel и списков сводных таблиц в Интернете, основанных на источнике данных OLAP, доступны итоговые функции, определяемые полями данных, доступных на сервере OLAP.

Возврат в начало

Компоненты списков сводных таблиц, не поддерживаемые Excel

Отображение деталей В списке сводной таблицы на Web-странице могут быть отображены все доступные исходные данные в формате списка, без обобщения этих данных. Когда данные обобщены, список может показать все соответствующие детали для любой ячейки, если детали доступны на источнике данных (обычно детали доступны только для не-OLAP исходных данных). В отчетах сводных таблиц Excel, которые основаны на не-OLAP исходных данных, одновременно могут быть отображены детали только для одной ячейки в области данных, а Excel помещает эти данные на отдельные листы. Однако, можно отобразить детали для объектов отчета сводной таблицы.

Скрытые объекты в промежуточных итогах В списках сводных таблиц в Интернете можно включать и исключать скрытые объекты из вычислений промежуточных итогов для всех полей. В отчетах сводных таблиц Excel,основанных на не-OLAP исходных данных, можно включать или исключать скрытые объекты из промежуточных итогов только для итогов полей страниц.

Фильтр по выбранному В списках сводных таблиц в Интернете можно отбирать данные, совпадающие с выбранной ячейкой. В отчетах сводных таблиц Excel можно фильтровать данные только отображением или скрытием объектов.

Установка размера отчета Список сводной таблицы на Web-странице заполняет окно определенного размера на Web-странице. Отчеты сводных таблиц, помещаемые на листе Excel, используют столько ячеек на листе, сколько необходимо для отображения данных.

Диаграммы Если Web-страница содержит и список сводной таблицы, и связанную с ним диаграмму, невозможно экспортировать и список, и диаграмму в Excel и сохранить связь между ними. Однако, можно экспортировать сводный список в Excel и создать отчет сводной диаграммы Excel, основаннвй на отчете сводной таблицы.

Возврат в начало

Дополнительные сведения

Отчеты сводных таблиц

Элементы отчета сводной таблицы Excel (терминология и определения)

Отображение отчета сводной таблицы Excel на Web-странице

Возврат в начало


 Отображение отчетов сводных таблиц Microsoft Excel в Web

Отображение отчетов сводных таблиц Microsoft Excel в Web

Если требуется поместить отчет сводной таблицы Microsoft Excel в Web, следует либо сохранить отчет в формате HTML и опубликовать его в виде неинтерактивной таблицы, либо воспользоваться Web-компонентом Microsoft Office Сводная таблица. Пользователи, просматривающие Web-страницу, могут использовать интерактивные возможности сводной таблицы с помощью Web-обозревателя, изменяя макет и отображаемые данные.

Пример сводной таблицы

Компонент сводных таблиц для Web-страниц доступен в обозревателе только в том случае, если установлены Web-компоненты Office. Для установки этих компонентов необходимо установить Microsoft Office 2000 или, если организация обладает лицензией, позволяющей работать с узлом Office 2000, загрузить Web-компоненты Office из интрасети организации. Если у пользователей имеются Web-компоненты Office, они могут просматривать сводные таблицы и использовать их интерактивные возможности с помощью Web-обозревателя Microsoft Internet Explorer версии 4.01 или более поздней. Пользователи, не имеющие этих компонентов или использующие другие обозреватели, не могут просматривать сводные таблицы и работать с ними. Отчеты сводных таблиц Excel можно опубликовать в Web либо в виде интерактивных сводных таблиц, либо в виде неинтерактивных таблиц, которые можно просматривать в других обозревателях.

Сводная таблица на Web-странице обладает практически теми же возможностями и командами, что и отчеты сводных таблиц Excel, однако она не имеет заголовков строк и столбцов, отображаемых на листах Excel. Для получения справочных сведений по командам и возможностям сводных таблиц следует обращаться к справочной системе обозревателя, а не Excel.

В дополнение к публикации отчетов сводных таблиц в виде интерактивных таблиц, компонент сводных таблиц можно использовать для публикации интерактивных версий списков данных в строках и столбцах. Сводные таблицы можно использовать для публикации фильтрованных списков Excel, при этом пользователи Web-страницы также получат возможность фильтровать данные в обозревателе.

Дополнительные сведения

Размещение отчета сводной таблицы на Web-странице

Различия между отчетами сводных таблиц и сводными таблицами на Web-страницах


 Создание отчета сводной таблицы по отчету сводной диаграммы

Создание отчета сводной таблицы по отчету сводной диаграммы

Когда создается отчет сводной диаграммы, Microsoft Excel автоматически создает связанный отчет сводной таблицы, который отражает все изменения, внесенные в диаграмму. Непосредственно из отчета сводной диаграммы невозможно создать независимый отчет сводной таблицы, но можно создать независимый отчет сводной таблицы по тем же данным, что и отчет сводной диаграммы. Независимый отчет сводной таблицы не связан с диаграммой. На таблице не сказываются изменения представления в диаграмме, и можно изменить представление в отчете сводной таблицы, не оказывая влияние на диаграмму.

Предполагаемые действия

Создание отчета сводной диаграммы со связанным отчетом сводной таблицы

Создание независимого отчета сводной таблицы по тем же данным, что и отчет сводной диаграммы


 Преобразование перекрестной таблицы Microsoft Excel версии 4.0 в отчет сводной таблицы

Преобразование перекрестной таблицы Microsoft Excel версии 4.0 в отчет сводной таблицы

Внимание! Если нужно провести обратное преобразование отчета сводной таблицы в перекрестную таблицу Microsoft Excel, нажмите кнопку Отменить [image] . Если хотите сохранить перекрестную таблицу, сделайте ее копию до преобразования.

  1. Выделите ячейку на листе, содержащем перекрестную таблицу.

  2. Выберите команду Сводная таблица в меню Данные.

  3. На шаге 3 мастера сводных таблиц и сводных диаграмм нажмите кнопку Готово и следуйте инструкциям для создания отчета сводной таблицы.

  4. Сохраните файл как книгу Microsoft Excel 2000.

Примечания

  • Созданный отчет сводной таблицы заменит на листе перекрестную таблицу.

  • Созданный отчет сводной таблицы не поддерживает структуру, которая была связана с перекрестной таблицей. Можно удалить эту структуру со страницы.


 Удаление отчета сводной таблицы

Удаление отчета сводной таблицы

  1. Щелкните отчет сводной таблицы.

  2. На панели инструментов Сводные таблицы в меню Сводные таблицы выберите команду Выделить, а затем — команду Таблица целиком.

  3. Выберите пункт Очистить в меню Правка, а затем – команду Все.

Примечания

  • Когда удаляется отчет сводной таблицы, который связан с отчетом сводной диаграммы, данные, которые отображает диаграмма, на могут быть изменены и в диаграмме нельзя использовать возможности сводной диаграммы.

  • При выполнении данной процедуры исходные данные не изменяются.


 Создание макета нового отчета сводной таблицы на листе

Создание макета нового отчета сводной таблицы на листе

Данная процедура используется после создания отчета сводной таблицы с помощью мастера сводных таблиц и сводных диаграмм, если макет отчета не был создан с помощью кнопки Макет на шаге 3 выполнения мастера.

  1. Из группы кнопок полей на панели инструментов Сводная таблица перетащите поля, которые должны отображаться в строках, в область диаграммы сводной таблицы с надписью «Перетащите сюда поля строк».

    Если кнопки полей на панели инструментов не видны, убедитесь, что панель инструментов не закреплена, щелкните в пределах диаграммы сводной таблицы, а затем убедитесь, что кнопка Отобразить поля [image] нажата.

    При использовании исходных данных OLAP в качестве полей строк, столбцов или страниц могут использоваться только поля, помеченные значком Значок поля размерности в начале строки на панели инструментов Сводная таблица. Эти поля находятся в начале списка полей. Для прокрутки к началу списка используется кнопка Другие поля [image] .

  2. Поля с данными, которые должны отображаться в столбцах, перетащите в область с надписью «Перетащите сюда поля столбцов».

  3. Поля, содержащие данные, которые требуется обобщить, перетащите в область с надписью «Перетащите сюда элементы данных».

    При использовании исходных данных OLAP в качестве полей данных можно использовать только поля, помеченные значком Значок поля данных в начале строки на панели инструментов. Эти поля находятся в конце списка полей. Для прокрутки в конец списка используется кнопка Другие поля [image] .

  4. При перетаскивании нескольких полей данных задайте порядок, в котором эти поля будут отображаться: щелкните поле данных правой кнопкой, выберите в контекстном меню команду Порядок, а затем переместите поле в нужную позицию с помощью команд подменю Порядок.

  5. Поля, которые требуется использовать как поля страниц, перетащите в область с надписью «Перетащите сюда поля страниц».

  6. Для изменения расположения полей перетащите их из одной области в другую. Для того чтобы удалить поле, перетащите за пределы отчета сводной таблицы. Удаленные поля остаются доступными в списке полей на панели инструментов.

    Для того чтобы скрыть структуру и надписи диаграммы, нажмите кнопку Скрыть поля [image] для скрытия списка полей, или щелкните ячейку за пределами отчета сводной таблицы.

Примечание. Поля строк, столбцов и страниц из источника данных OLAP изначально отображают данные верхнего уровня. Имена полей наивысшего уровня в отчете сводной таблицы могут не совпадать с именами на кнопках полей. Например, кнопка поля для размерности с названием «География» может иметь в отчете сводной таблицы имя поля наивысшего уровня, «Страна», но изначально может отображать элементы уровня «Страна», например «США», «Канада» и т.п. После перетаскивания полей в отчет можно отобразить данные нижнего уровня этих полей.


Изменение макета отчета сводной таблицы или сводной диаграммы

Изменение макета сводной таблицы или сводной диаграммы не затрагивает исходные данные.

Предполагаемые действия.

Изменение макета

Изменение макета сводной таблицы перетаскиванием полей или элементов

Изменение макета сводной диаграммы перетаскиванием полей или элементов

Изменение макета сводной таблицы или сводной диаграммы с помощью мастера

Добавление или удаление поля в отчете сводной таблицы или сводной диаграммы

Расположение полей страниц сводной таблицы в строках или столбцах

Изменение формата

Преобразование отчета сводной таблицы в структурированный или неструктурированный формат

Форматирование отчета сводной таблицы


Подробные данные отчета сводной таблицы и выполняемые над ними действия

Предполагаемые действия

Скрытие и отображение элементов

Отображение или скрытие элементов поля

Отображение или скрытие элементов поля страницы

Отображение максимальных или минимальных элементов в поле. Например, 10 крупных сделок или пять мелких сделок.

Отображение или скрытие подробных данных

Отображение разных уровней детализации

Отображение и скрытие подробных данных

Запрет доступа к подробным данным


 Сортировка данных в сводной таблице и отчете сводной диаграммы

Сортировка данных в сводной таблице и отчете сводной диаграммы

В новой сводной таблице и отчетах сводных диаграмм, основанных на не-OLAP исходных данных, Microsoft Excel автоматически сортирует элементы полей в возрастающем порядке в соответствии с их подписями. Однако если при обновлении отчета извлекаются новые элементы, они помещаются в конец строк или столбцов для их полей.

И в новых, и в обновленных отчетах, основанных на исходных данных из базы данных OLAP, элементы отображаются в том порядке, в каком они получены с сервера OLAP.

В Excel предусмотрен следующий порядок для сортировки данных по возрастанию: числа, текст, логические значения, значения ошибок (например #ССЫЛКА! и #ЗНАЧ!) и пустые ячейки. Для сортировки по убыванию используется обратная очередность, за исключением пустых ячеек, которые всегда помещаются в конец отсортированного списка. Если необходим другой порядок сортировки, например по названиям месяцев, можно воспользоваться специальным порядком сортировки или определить собственную последовательность сортировки.

Предполагаемые действия

Сортировка элементов сводной таблицы или сводной диаграммы по подписям

Сортировка элементов сводной таблицы или сводной диаграммы по значениям ячеек в области данных

Использование специального порядка сортировки в сводной таблице или отчете сводной диаграммы


 Использование полей страниц в сводной таблице и сводной диаграмме

Использование полей страниц в сводной таблице и сводной диаграмме

Поля страниц сводной таблицы можно использовать для отображения данных одного элемента поля независимо от других элементов поля или размерности. При смене элемента поля страницы изменяется весь отчет.

Предполагаемые действия

Создание поля страницы

Отображение другого элемента поля страницы

Отображение итоговых данных для всех элементов поля страницы

Отображение страниц поля страницы сводной таблицы на отдельных листах

Установки поля страницы


 Группирование и разгруппирование данных в отчетах сводных таблиц и сводных диаграмм

Группирование и разгруппирование данных в отчетах сводных таблиц и сводных диаграмм

Для чего используется группирование данных. Группирование данных можно использовать для получения обобщенных итогов — например, для просмотра данных по кварталам вместо просмотра по неделям или для просмотра числовых элементов по десяткам, а не по отдельности. Группирование позволяет исключить беспорядок и получить менее раздробленное представление данных. Если нужно просмотреть данные в более подробном виде или если требуется использовать возможности, недоступные для сгруппированного поля, данные можно разгруппировать.

Типы элементов, которые можно группировать. В отчете сводной таблицы или сводной диаграммы можно группировать даты, значения времени или числа, а также выбранные элементы. Например, можно сгруппировать месяцы для просмотра итоговых значений по кварталам. Если требуется сгруппировать выделенные элементы в отчете сводной диаграммы, следует сгруппировать их в связанном отчете сводной таблицы.

Данные в сводных таблицах и отчетах сводных диаграмм, основанных на базе данных OLAP, не могут быть сгруппированы. Использует ли отчет сводной таблицы данные OLAP.

Влияние группирования на связанные отчеты сводных таблиц и сводных диаграмм. Выполнение группирования и разгруппирования данных влияет на все отчеты сводных таблиц и сводных диаграмм, основанные на одном и том же отчете сводной таблицы. Пока элементы поля сгруппированы, добавить в поле вычисляемые элементы нельзя. При группировании и разгруппировании данных в отчете сводной таблицы, связанном с отчетом сводной диаграммы, некоторые элементы форматирования отчета сводной диаграммы могут быть утеряны.

Дополнительные сведения

Группирование или разгруппирование выделенных элементов поля

Группирование или разгруппирование числовых элементов поля

Группирование или разгруппирование дат и значений времени в поле

Группирование или разгруппирование элементов поля страницы


 Группирование и разгруппирование данных в сводной таблице и отчете сводной диаграммы

Группирование и разгруппирование данных в сводной таблице и отчете сводной диаграммы

Данные в сводных таблицах и отчетах сводных диаграмм, основанных на базе данных OLAP, не могут быть сгруппированы. Использует ли отчет сводной таблицы данные OLAP.

Данные, которые должны быть сгруппированы или разгруппированы

Выделенные элементы полей сводной таблицы или отчета сводной диаграммы

Числовые элементы полей сводной таблицы или отчета сводной диаграммы

Даты или времена в полях сводной таблицы или сводной диаграммы

Элементы полей страниц сводной таблицы или сводной диаграммы

Не можете сделать выбор?


 Форматирование отчета сводной таблицы

Форматирование отчета сводной таблицы

Изменение формата

Сохранение форматирования. По умолчанию большинство параметров форматирования отчета сводной таблицы при обновлении отчета или изменении его макета сохраняется. Для сохранения форматирования должен быть установлен флажок Сохранять форматирование. Чтобы воспользоваться этим параметром, нажмите кнопку Сводная таблица на панели инструментов Сводные таблицы, а затем выберите команду Параметры таблицы.

Форматирование сохраняется при использовании выделения части сводной таблицы или обычного выделения. (В версиях, предшествующих Microsoft Excel 2000, форматирование сохраняется только при использовании выделения части сводной таблицы.) См. Выделение данных в отчете сводной таблицы.

Изменение форматирования символов и ячеек. Для ячеек в отчете сводной таблице можно изменить такие параметры форматирования, как шрифт, цвет фона и выравнивание. На применение и сохранение форматирования при обновлении отчета или изменении его макета влияют несколько параметров сводной таблицы. Эти параметры можно установить в диалоговом окне Параметры сводной таблицы (нажмите кнопку Сводная таблица на панели инструментов Сводные таблицы, а затем выберите команду Параметры таблицы; либо нажмите кнопку Параметры на шаге 3 мастера сводных таблиц и диаграмм). См. Изменение форматирования символов и ячеек сводной таблицы.

Изменение числовых форматов. Значения в области данных отчета сводной таблицы не всегда отображаются в тех же числовых форматах, что и исходные данные. Можно изменить числовые форматы на любые форматы Microsoft Excel.

Отображение значений для ошибок и пустых ячеек. Вместо отображения в ячейках ошибок, например #ССЫЛКА! или #Н/Д!, и пустых значений, можно задать определенные значения для отображения в таких ячейках в отчете сводной таблицы.

Использование объединенных ячеек. По умолчанию заголовки для элементов во внешней строке и полях столбцов отображаются слева с выравниванием по верхней границе группы элементов. Можно указать объединенные ячейки для этих элементов, с тем чтобы заголовки элементов выравнивались по горизонтали и по вертикали в объединенных ячейках.

Изменение макета

Добавление пустых строк между группами элементов. Если в конце групп элементов для поля отображаются итоговые значения, то для всех полей строк, за исключением внутреннего поля строки, после каждого элемента или его итоговой строки можно добавить пустую строку.

Отображение отчета сводной таблицы в структурированном или неструктурированном формате. По умолчанию вновь создаваемые отчеты сводных таблиц отображаются в неструктурированном формате. Для отображения отчета сводной таблицы в формате, соответствующем формату стандартных отчетов баз данных, можно преобразовать его в структурированный формат. Преобразование в структурированный формат может привести к изменению макета отчета сводной таблицы со взаимным изменением положения полей столбцов и строк; кроме того, при выполнении преобразования к отчету применяется автоформат. См. сведения о типах форматов отчетов.

Чтобы реорганизовать отчет сводной таблицы для изменения расположения полей, добавления или удаления полей или изменения расположения полей страниц по отношению к другим полям, следует изменить макет сводной таблицы.


 Выделение данных в отчете сводной таблицы

Выделение данных в отчете сводной таблицы

Выделение части сводной таблицы и обычное выделение

Обычное выделение Microsoft Excel Обычное выделение Excel используется тогда, когда вносимые изменения форматов и формул должны быть применены к выбранным ячейкам, а не частям сводной таблицы. Для использования обычного выделения Excel щелкните и протяните через ячейки так, чтобы указатель не изменился на Стрелка вниз или Стрелка вправо.

Выделение части сводной таблицы Выделение части сводной таблицы используются тогда, когда изменения в форматах или формулах вычисляемых объектов должны быть применены к выбранным частям отчета сводной таблицы.

Для выделения части сводной таблицы выберите в меню Сводная таблица на панели инструментов Сводная таблица команду Выделить и убедитесь в том, что нажата кнопка Разрешить выделение [image] . При выделении укажите кнопки полей или названия объектов (указатель изменится на Стрелка вниз или Стрелка вправо ), а затем нажмите кнопку мыши.

Использование выделения части сводной таблицы

Отчет сводной таблицы целиком Для выделения всего отчета сводной таблицы щелкните отчет , в меню Сводная таблица на панели инструментов Сводная таблица выберите команду Выделить ,а затем команду Таблица целиком.

Все объекты в поле Чтобы выделить все метки объектов в поле, укажите верхнюю границу кнопки поля ( указатель изменится на Стрелка вниз, а затем нажмите кнопку. В приведенном ниже примере можно указать верхнюю границу кнопки «Дата заказа» и щелкнуть один раз для выделения меток «Кв.2» и «Кв.3». Выделение кнопки поля по умолчанию выделяет только заголовки объектов. Для выделения не только заголовков, но и данных, в меню Сводная таблица на панели инструментов Сводная таблица выберите команду Выделить, а затем (после выделения заголовков) команду Заголовки и данные [image] .

По умолчанию выделение объекта выделяет и заголовки, и связанные с ними данные. После выделения объекта для выделения одних заголовков выберите команду Только заголовки [image] или команду Только данные [image] для выбора только данных, а не заголовков.

Все экземпляры объекта Для выделения всех экземпляров объекта укажите верхнюю границу объекта поля столбца (указатель изменится на Стрелка вниз )или укажите левую границу объекта поля строки (указатель изменится на Стрелка вправо ) и затем щелкните. Например, щелкните левую границу объекта поля «Батурин» для выбора обоих строк для «Батурин»:

Сводный отчет, у которого выбраны все экземпляры объекта

Указатель Стрелка вправо около «Батурин»в строке 5 показывает выделение части сводной таблицы.

Один экземпляр объекта Чтобы снять выделение всех одинаковых объектов поля и оставить только одно, укажите верхнюю границу объекта поля столбца (указатель поменяется на Стрелка вниз ) или укажите левую границу объекта поля строки (указатель поменяется на Стрелка вправо ). Щелкните один раз. Последующие щелчки будут снимать выделение. Между щелчками необходимо выдерживать паузу, чтобы эти нажатия не воспринимались как двойной щелчок мыши. Например, после второго щелчка левой границы первого экземпляра объекта «Батурин» , выделится только строка «Батурин» для объекта поля «Мясные».

Если в отчете сводной таблицы содержится несколько полей строк, для выделения необходимых объектов нужно выполнить данную процедуру несколько раз. Например, если в сводной таблице содержится четыре поля строки, для выделения только одного объекта необходимо щелкнуть внутренний объект в поле строки четыре раза.

Итоги Чтобы выделить итоги, укажите верхнюю границу итогов в поле столбца (указатель изменится на Стрелка вниз ) или укажите левую границу итогов в поле строки (указатель изменится на Стрелка вправо ). Щелкните один раз для выделения всех итогов для поля, а затем щелкните еще раз для выделения только текущего итога.

Несколько объектов поля В сводной таблице можно выделить несколько объектов поля. Сначала щелкните столько раз, сколько необходимо для выделения одного объекта. Нажмите клавишу SHIFT или CTRL и, удерживая ее нажатой, выделите остальные объекты внутри одного поля. Чтобы снять выделение с объекта, нажмите клавишу CTRL и, удерживая ее нажатой, снимите выделение с этого объекта.


Преобразование отчета сводной таблицы в структурированный или неструктурированный формат

По умолчанию Мастер сводных таблиц и сводных диаграмм создает отчет сводной таблицы в неструктурированном формате (перекрестная таблица).

Предполагаемые действия

Форматы и макеты сводной таблицы

Отображение отчета сводной таблицы в структурированном формате

Отображение промежуточных итогов сводной таблицы сверху или снизу от суммируемой группы элементов

Возвращение структурированной сводной таблицы в неструктурированный формат


 Форматы и макеты команды «Формат отчета»

Форматы и макеты команды «Формат отчета»

Макеты всех отчетов сводных таблиц, создаваемых мастером сводных таблиц и диаграмм, вначале имеют неструктурированный формат. Если необходимо изменить макет и форматирование, щелкните кнопку Формат отчета [image] на панели инструментов сводной таблицы. Эта команда раскрывает список автоформатов для отчетов сводных таблиц. Автоформаты, предназначенные для областей листов (меню Формат, команда Автоформат), в отчетах сводных таблиц не применяются.

Структурированные форматы. Если для отчета сводной таблицы необходим структурированный формат, часто используемый для отчетов баз данных, выберите любой из десяти автоформатов типа «Отчет» — с Отчет 1 по Отчет 10.

После выбора любого из этих автоформатов, отчет приобретает структурированный формат, изменяются макет, форматы ячеек и знаков. Все поля столбцов отчета сводной таблицы становятся полями строк. Поля данных перемещаются вправо от полей строк. Если в имени поля данных указана функция итогов этого поля, то из имени поля удаляется название функции. Например, имя «Сумма: Продажи» заменяется именем «Продажи».

Если отчет сводной таблицы связан с отчетом сводной диаграммы, то изменение макета отчета сводной таблицы приводит к измению макета отчета сводной диаграммы.

Неструктурированные форматы. Если выбран формат Классическая сводная таблица, либо один из десяти форматов типа «Таблица» — с Таблица 1 по Таблица 10, — из имен полей данных удаляется имя функции итогов. Эти форматы предназначены для отчетов сводных таблиц, содержащих поля столбцов.

  • Как установить неструктурированный формат. Выберите либо формат Классическая сводная таблица, либо один из форматов типа «Таблица»: с Таблица 1 по Таблица 10.

  • Как сохранить поля столбцов. Чтобы поля столбцов не преобразовались в поля строк, используйте любой из десяти форматов типа «Таблица» — с Таблица 1 до Таблица 10.

  • Добавление пустых строк. Форматы с Таблица 1 по Таблица 5 и формат Таблица 7 используются для вставки по одной пустой строки после каждого элемента в самом внешнем поле строк, а также для установки соответствующих форматов ячеек и знаков.

Переход от структурированного к неструктурированному формату. Выбор формата в диапазоне Таблица 1 — Таблица 10 изменяет макет, вызывая переход от структурированного формата отчета сводной таблицы к неструктурированному формату. Крайнее левое поле строк становится полем столбцов. Формат «Классическая сводная таблица» не изменяет макет.

Снятие форматов. Для снятия форматов, установленных для знаков и ячеек любым способом — вручную или с помощью кнопки Формат отчета [image] — выберите формат Нет. Этот формат не удаляет пустые строки, вставленные между элементами внешних полей строк, не вызывает перехода от структурированного формата к неструктурированному (а также перехода в обратную сторону), и не перемещает поля.

Дополнительные сведения

Отображение отчета сводной таблицы в структурированном формате.

Отображение промежуточных итогов сводной таблицы сверху или снизу от суммируемой группы.

Возвращение структурированного отчета сводной таблицы в неструктурированный формат.

Форматирование отчета сводной таблицы.


 Изменение способа отображения ошибок и пустых ячеек отчетом сводной таблицы

Изменение способа отображения ошибок и пустых ячеек отчетом сводной таблицы

  1. Щелкните отчет сводной таблицы.

  2. На панели инструментов Сводные таблицы нажмите кнопку Сводная таблица и выберите команду Параметры таблицы.

  3. Установите флажок Для ошибок отображать в группе Формат, чтобы изменить способ отображения ошибок. Введите в поле значение, которое будет отображаться вместо ошибок.

    Чтобы отображать пустыми ячейки с ошибочными значениеми, установите флажок Для ошибок отображать и удалите любые символы в поле.

    Установите флажок Для пустых ячеек отображать, чтобы задать вид отображения пустых ячеек. Введите в поле значение, которое будет отображаться в пустых ячейках.

    Чтобы отображать в пустых ячейках пустое значение, установите флажок Для пустых ячеек отображать и удалите любые символы в поле.

    Чтобы значения пустых ячеек воспринимались как нули, снимите флажок Для пустых ячеек отображать.

Примечание. По умолчанию отчет сводных таблиц не отображает элементы в поле, не связанном с данными. Для отображения таких объектов щелкните поле, нажмите кнопку Параметры поля [image] на панели инструментов Сводные таблицы и установите флажок Отображать пустые элементы.


 Отображение промежуточных итогов сводной таблицы сверху или снизу от суммируемой группы

Отображение промежуточных итогов сводной таблицы сверху или снизу от суммируемой группы

Для того чтобы изменить место отображения промежуточных итогов, поле или отчет сводной таблицы должны отображаться в структурированном формате, а также необходимо отобразить промежуточные итоги для поля.

  1. Дважды щелкните поле строки, для которого требуется изменить отображение промежуточных итогов.

    Изменение отображения промежуточных итогов возможно для внешних полей строк, но не для внутреннего (крайнего справа) поля строк.

  2. Нажмите кнопку Макет.

  3. В группе Параметры вывода на экран установите переключатель в положение В виде структуры, а затем установите или снимите флажок Промежуточные итоги в заголовке группы.

  4. Дважды нажмите кнопку OK.


 Изменение названий полей и элементов полей сводной таблицы

Изменение названий полей и элементов полей сводной таблицы

  1. Выделите поле или элемент, которые следует переименовать.

  2. Введите новое имя.

  3. Нажмите клавишу ENTER.

Примечания

  • Переименование не сохраняется для исходных данных OLAP В отчете сводной таблицы, построенном на данных из базы данных OLAP, при переименовании полей или объектов полей и дальнейшем отображении их на экране или возвращении их в отчет измененное имя превращается опять в оригинальное, присвоенное в базе данных OLAP. Например, если переименовать «район» в «область», далее перейти к более высокому уровню «страна», а затем вернуться назад к более низкому уровню, то поле опять будет названо «район».

  • Переименование не меняет исходные данные Переименование поля или элемента сводной таблицы не отражается на исходных данных.

  • Переименование числовых элементов преобразовывает их в текстовые При переименовании числовых элементов Microsoft Excel форматирует их как текст. Excel сортирует числовые объекты отдельно от текстовых. Даже если восстановить исходное имя, объект остается форматирован как текст и не может быть сортирован или сгруппирован как числовой объект.


 Использование объединенных и обычных ячеек для подписей крайних столбцов и строк в отчете сводной таблицы

Использование объединенных и обычных ячеек для подписей крайних столбцов и строк в отчете сводной таблицы

Подписи элементов в обычных ячейках выравниваются по левому краю верхней ячейки, а в объединенных ячейках выравниваются по центру горизонтально и вертикально. Эти позиции можно изменить, последовательно изменяя форматирование.

  1. Щелкните отчет сводной таблицы.

  2. На панели инструментов Сводные таблицы нажмите кнопку Сводная таблица и выберите команду Параметры таблицы.

  3. Выполните одно из следующих действий:

    Для того чтобы использовать объединенные ячейки, установите флажок Объединять ячейки заголовков.

    Для того чтобы использовать обычные ячейки, снимите флажок Объединять ячейки заголовков.


 Расчет данных сводной таблицы и сводной диаграммы

Расчет данных сводной таблицы и сводной диаграммы

Этот раздел содержит сведения о том, как вычисляются:

Значения в области данных

Отчеты, основанные на данных из источников, не являющихся базами данных OLAP

Отчеты, основанные на данных куба OLAP

Значения в области данных

Значения в области данных обобщают соответствующие данные в отчете сводной таблицы или отчете сводной диаграммы.

Пример отчета сводной таблицы Сводная таблица может содержать кнопку поля столбца, имеющую название «Месяц», и отображающую элементы поля в виде столбцов «Март», «Апрель» и «Май»; кнопку поля строки, имеющую название «Регион», и отображающую элементы поля в виде строк «Северный», «Южный», «Восточный» и «Западный», а также поле данных, отображающее итоговые данные и имеющее название «Общий доход». Значение, являющееся пересечением столбца «Май» и строки «Северный», будет итоговым доходом по элементам полей «Май» и «Северный».

Пример отчета сводной диаграммы В отчете сводной диаграммы поле «Месяц» может быть полем категории, которое показывает «Март», «Апрель» и «Май» как категории. Поле «Регион» может быть полем ряда, которое показывает «Северный», «Южный», «Восточный» и «Западный» как ряды, представленные в легенде. Поле данных, называемое «Общий доход» может содержать маркеры данных , которые представляют общий доход по каждому региону за каждый месяц. Например, маркер данных может отмечать позицией на оси значений общий доход в мае в северном регионе.

Значения и вычисления значений в отчете сводной диаграммы отражаются в связанном отчете сводной таблицы и наоборот. Следовательно, изменения, внесенные в один отчет, отображаются и в другом.

Отличия, зависящие от исходных данных Способы вычислений и доступные возможности зависят от источника данных — база данных OLAP или другой тип базы данных. Указание типа источника внешних данных для отчета сводной таблицы и отчета сводной диаграммы.

Возврат в начало

Отчеты, основанные на данных из источников, не являющихся базами данных OLAP

Изменение итоговых функций Для подсчета итогов для значений в области данных в отчете используется итоговая функция. Для обработки числовых данных применяется итоговая функция «Сумма», а для текстовых данных — итоговая функция «Кол-во значений». Кроме того, для анализа данных можно воспользоваться и другими итоговыми функциями (например «Среднее», «Максимум», «Минимум» или «Несмещенное отклонение»). Полный список доступных итоговых функций.

Использование дополнительных вычислений Можно использовать также дополнительные вычисления, которые вычисляют значения на основании других элементов или ячеек в области данных; например, можно отобразить значения в процентах от заданной строки в отчете сводной таблицы или в процентах от заданной категории в отчете сводной диаграммы. Использование дополнительных вычислений в сводной таблице и отчете сводной диаграммы.

Вставка собственных формул Если необходимо создать собственные формулы, использующие элементы отчета или другие данные листа, можно создать вычисляемое поле или вычисляемый элемент внутри поля. Если при работе с отчетом сводной диаграммы планируется создать сложные формулы, рекомендуется создавать формулы в связанном отчете сводной таблицы (в котором могут быть просмотрены отдельные значения, формирующие результаты), а отображенные результаты просматривать в отчете сводной диаграммы. Создание вычисляемых полей. Создание вычисляемых элементов. Формулы в отчетах сводных диаграмм.

Возврат в начало

Отчеты, основанные на данных куба OLAP

Итоговые значения вычисляются заранее Для отчетов, основанных на данных куба OLAP, обобщенные значения вычисляются заранее сервером, который хранит данные, а Excel только отображает результаты. Следовательно, значения, вычисляемые в отчете, не могут быть изменены. В отчетах, построенных на данных OLAP, невозможно изменить итоговую функцию, вычисляющую поля данных или промежуточные итоги, или добавить вычисляемые поля и вычисляемые элементы.

Дополнительные вычисления основываются на значениях, вычисленных заранее Дополнительные вычисления могут быть использованы для вычисления значений, например процентов, которые используют другие элементы или ячейки в области данных. Дополнительные вычисления производятся Excel, но используют значения, вычисленные ранее не сервере. Например, если данные OLAP обеспечивают поле, которое вычисляет сумму продаж, можно использовать дополнительные вычисления Excel для вычисления доли каждой суммы от сумм в указанной строке отчета сводной таблицы. Проценты вычисляются по итоговым значениям, предоставляемым сервером OLAP, а не отдельным значениям, формирующим сумму. Использование дополнительных вычислений в сводной таблице и отчете сводной диаграммы.

Другие типы вычислений В случае необходимости других итоговых функций или вычислений в отчетах, основанных на данных OLAP, свяжитесь с администратором базы данных OLAP для добавления этих вычислений в куб на сервере. Для кубов, созданных с помощью Microsoft Query, можно использовать Мастер куба OLAP для добавления к кубу вычислений в полях данных. Создание куба OLAP по результатам запроса.

Возврат в начало


 Использование общих и промежуточных итогов в отчете сводной таблицы

Использование общих и промежуточных итогов в отчете сводной таблицы

В отчетах сводных таблиц, основанных на исходных данных OLAP, сервер OLAP предоставляет промежуточные и общие итоги. Можно отобразить или скрыть общие итоги и вставить автоматические итоги, если они доступны в исходных данных, но возможность вставки настраиваемых промежуточных итогов или изменения итоговой функции для итогов отсутствует. Использует ли отчет сводной таблицы данные OLAP.

Предполагаемые действия

Отображение или скрытие общих итогов в отчете сводной таблицы

Вставка или удаление промежуточных итогов в отчете сводной таблицы

Изменение итоговой функции, используемой в вычислениях промежуточных итогов сводной таблицы

Отображение промежуточных итогов сводной таблицы сверху или снизу от суммируемой группы

Вычисление итогов


 Подсчет итоговых значений в отчетах сводных таблиц

Подсчет итоговых значений в отчетах сводных таблиц

Итоги для источника данных OLAP

В отчетах сводной таблицы, которая построена по данным из источника данных OLAP, сервер OLAP вычисляет промежуточные итоги и итоги. Эти итоги включают все объекты, которые администратор базы данных OLAP включил в поле, включая объекты, которые в настоящий момент скрыты в отчете сводной таблицы. Указание типа источника внешних данных для отчета сводной таблицы.

Итоги для источников, отличных от базы данных OLAP

Поля столбцов и строк В отчете сводной таблицы, которая основана на не-OLAP исходных данных, Microsoft Excel рассчитывает промежуточные итоги и итоги для полей строк и полей столбцов, включая только видимые объекты. Excel пересчитывает итоги и промежуточные итоги при скрытии и отображении различных строк и столбцов.

Поля страниц Для полей страниц Excel рассчитывает итоги и промежуточные итоги для объектов, которые отображены в настоящий момент. При отображении другого объекта Excel рассчитывает и отображает новые итоги и промежуточные итоги.

Объект «Все» в полях страниц По умолчанию для объекта «Все» Excel подсчитывает итоги и промежуточные итоги, которые включают только видимые объекты. Excel рассчитывает и отображает различные итоги и промежуточные итоги при скрытии и отображении различных объектов поля страницы. Если итоги и промежуточные итоги должны включать скрытые объекты, можно установить параметр Включать скрытые значения.

Дополнительные сведения

Отображение или скрытие объектов поля сводной таблицы

Отображение верхнего или нижнего объекта в поле сводной таблицы

Изменение объекта поля страницы, отображаемого в отчете сводной таблицы

Обработка данных сводной таблицы


 Обобщение и расчет данных сводной таблицы или сводной диаграммы

Обобщение и расчет данных сводной таблицы или сводной диаграммы

Исходные данные OLAP

Итоговые значения для данных OLAP вычисляются на сервере и затем отображаются в отчете сводной таблицы или сводной диаграммы. В силу этого некоторые типы вычислений являются недоступными. В отчетах, основанных на исходных данных OLAP, нельзя изменять или использовать несколько итоговых функций, а также создавать вычисляемые поля и элементы. Тем не менее, для выполнения в Microsoft Excel дальнейшей обработки данных на основе значений с сервера OLAP можно использовать дополнительные вычисления.

Использует ли отчет сводной таблицы или сводной диаграммы данные OLAP

Сведения о доступных дополнительных вычислениях

Использование дополнительных вычислений для поля данных сводной таблицы или сводной диаграммы

Для получения сведений о вычислениях, доступных для исходных данных, обратитесь к администратору базы данных OLAP.

Данные из источников, отличных от баз данных OLAP

Поля данных в отчетах, основанных на не-OLAP исходных данных, можно настраивать требуемым образом с использованием вычислений, отличающихся от стандартных итоговых функций, используемых Excel, или дополняющих их. При необходимости выполнения более сложных вычислений, чем позволяют возможности итоговых функций, можно создать собственные формулы.

Основные вычисления. Для выполнения основных вычислений — например, суммирования, нахождения среднего, минимального или максимального значения — следует использовать итоговые функции.

Сведения о доступных итоговых функциях

Изменение итоговой функции в поле данных сводной таблицы или сводной диаграммы

Использование нескольких итоговых функций для обработки данных сводной таблицы или сводной диаграммы

Дополнительные вычисления. Для сравнения или индексирования двух полей или отображения процентного значения следует использовать возможности дополнительных вычислений.

Сведения о доступных дополнительных вычислениях

Использование дополнительных вычислений для поля данных сводной таблицы или сводной диаграммы

Дополнительные формулы. Для создания собственной формулы, использующей данные сводной таблицы или сводной диаграммы, следует использовать вычисляемое поле или вычисляемый элемент в поле.

Синтаксис формул сводных таблиц и сводных диаграмм

Создание вычисляемого поля в сводной таблице или сводной диаграмме

Создание вычисляемого элемента в сводной таблице или сводной диаграмме


 Обобщение и вычисление данных в сводной таблице и отчете сводной диаграммы

Обобщение и вычисление данных в сводной таблице и отчете сводной диаграммы

Возможности, недоступные для данных OLAP Можно изменять используемую итоговую функцию, а также создавать вычисляемые поля и элементы только для отчетов, основанных на не-OLAP исходных данных. Эти возможности недоступны для отчетов, основанных на данных OLAP. Информацию о вычислениях, доступных для исходных данных, можно получить у администратора базы данных OLAP. Указание типа источника внешних данных для отчета сводной таблицы и отчета сводной диаграммы.

Формулы в отчетах сводных диаграмм Формулы в отчетах сводных диаграмм могут быть созданы таким же образом, как и в отчетах сводной таблицы. Когда в отчете сводной диаграммы создается формула, формула и результат ее вычисления отражаются и в связанном отчете сводной таблицы, и наоборот. Если при работе с отчетом сводной диаграммы планируется создавать сложные формулы, рекомендуется создавать формулы в связанном отчете сводной таблицы (в котором могут быть просмотрены отдельные значения, формирующие результаты), а отображенные результаты просматривать в отчете сводной диаграммы. Формулы в отчетах сводных диаграмм.

Предполагаемые действия

Изменение итоговой функции в области данных сводной таблицы или сводной диаграммы

Использование нескольких итоговых функций для обработки данных сводной таблицы или сводной диаграммы

Использование дополнительных вычислений для поля данных сводной таблицы или сводной диаграммы

Создание вычисляемого поля в сводной таблице или сводной диаграмме

Создание вычисляемого элемента в сводной таблице или сводной диаграмме

Не можете сделать выбор?


 Итоговые функции для анализа данных

Итоговые функции для анализа данных

Итоговые функции используются для вычисления автоматических промежуточных итогов, для консолидации данных, а также в отчетах сводных таблиц и сводных диаграмм. Следующие итоговые функции доступны для отчетов сводных таблиц и сводных диаграмм, основанных на не-OLAP исходных данных. Для отчетов, основанных на данных OLAP круг доступных итоговых функций зависит от способа определения куба на сервере. Для получения сведений об итоговых полях, доступных для используемых исходных данных, обратитесь к администратору базы данных OLAP.

Операция | Результат
Сумма | Сумма чисел. Эта операция используется по умолчанию для подведения итогов по числовым полям.
Кол-во значений | Количество записей или строк данных. Эта операция используется по умолчанию для подведения итогов по нечисловым полям. Операция " Кол-во значений" работает так же, как и функция СЧЁТЗ.
Среднее | Среднее чисел.
Максимум | Максимальное число.
Минимум | Минимальное число.
Произведение | Произведение чисел.
Кол-во чисел | Количество записей или строк, содержащих числа. Операция «Кол-во чисел» работает так же, как и функция СЧЁТ.
Несмещенное отклонение | Несмещенная оценка стандартного отклонения генеральной совокупности по выборке данных.
Смещенное отклонение | Смещенная оценка стандартного отклонения генеральной совокупности по выборке данных.
Несмещенная дисперсия | Несмещенная оценка дисперсии генеральной совокупности по выборке данных.
Смещенная дисперсия | Смещенная оценка дисперсии генеральной совокупности по выборке данных.


 Дополнительные вычисления в полях данных сводной таблицы и сводной диаграммы

Дополнительные вычисления в полях данных сводной таблицы и сводной диаграммы

Следующие функции можно использовать для дополнительных вычислений в полях данных. Чтобы воспользоваться формулой, использующей данные сводной таблицы или сводной диаграммы, следует создать вычисляемое поле или вычисляемый элемент поля. Для получения дополнительных сведений по созданию вычисляемых полей нажмите кнопку [image] . Для получения дополнительных сведений по созданию вычисляемых элементов полей нажмите кнопку [image] .

Операция | Результат
Отличие | Значения ячеек области данных отображаются в виде разности с заданным элементом, указанным в списках поле и элемент. Поле и элемент определяют данные, используемые в дополнительных вычислениях.
Доля | Значения ячеек области данных отображаются в процентах к заданному элементу, указанному в списках поле и элемент. Поле и элемент определяют данные, используемые в дополнительных вычислениях.
Приведенное отличие | Значения ячеек области данных отображаются в виде разности с заданным элементом, указанным в списках поле и элемент, нормированной к значение этого элемента. Поле и элемент определяют данные, используемые в дополнительных вычислениях.
С нарастающим итогом в поле | Значения ячеек области данных отображаются в виде нарастающего итога для последовательных элементов. Следует выбрать поле, элементы которого будут отображаться в нарастающем итоге.
Доля от суммы по строке | В отчете сводной таблицы значения ячеек каждой строки отображаются в процентах от итогового значения по строке. В отчете сводной диаграммы значения отображаются в процентах от итогового значения по категории.
Доля от суммы по столбцу | В отчете сводной таблицы значения ячеек каждого столбца отображаются в процентах от итогового значения по столбцу. В отчете сводной диаграммы значения отображаются в процентах от итогового значения по ряду.
Доля от общей суммы | В отчете сводной таблицы значения ячеек в области данных отображаются в процентах от общего итога по всем значениям в отчете. В отчете сводной диаграммы значения отображаются в процентах от общего итога по всем значениям.
Индекс | При определении значений ячеек области данных используется следующий алгоритм: ((Значение в ячейке) x (Общий итог)) / ((Итог строки) x (Итог столбца))


 Синтаксис формул для вычисляемого поля или элемента отчета сводной таблицы или сводной диаграммы

Синтаксис формул для вычисляемого поля или элемента отчета сводной таблицы или сводной диаграммы

Доступность формул. Формулы доступны только для отчетов, основанных на не-OLAP исходных данных. Для получения сведения о вычислениях, доступных для исходных данных OLAP, обратитесь к администратору базы данных OLAP.

Формулы доступны в отчетах сводных диаграмм и используют тот же синтаксис, что и формулы в отчетах сводных таблиц. При создании формулы в отчете сводной диаграммы формула и ее результаты отражаются в связанном отчете сводной таблицы и наоборот. Если при работе с отчетом сводной диаграммы планируется создание сложных формул, рекомендуется создавать формулы в связанном отчете сводной таблицы, где можно просматривать отдельные значения, образующие данные, а затем просмотреть результаты в отчете сводной диаграммы. См. дополнительные сведения о формулах в отчетах сводных диаграмм.

Элементы формул. В формулах, создаваемых для вычисляемых полей и вычисляемых элементов, можно использовать операторы и выражения, как в других формулах на листе. Можно использовать константы и ссылаться на данные из отчета, но нельзя использовать ссылки на ячейки или определенные имена. Также нельзя использовать функции, требующие использования ссылок на ячейки, и функции обработки массивов.

Имена в отчетах

Синтаксис имен. Microsoft Excel назначает элементам отчета имена, что позволяет использовать в формулах ссылки на данные из отчета. Имена составляются из имен поля и элемента. В следующем примере данным в диапазоне D3:D11 присвоено имя Кв.3.

Имена полей и элементов в отчете сводной таблицы

В отчете сводной таблицы имена полей отображаются на кнопках полей, а имена элементов можно увидеть в раскрывающихся списках каждого поля. Не путайте эти имена с именами, отображаемыми на подсказках диаграммы, в которых отражаются имена рядов и точек.

Пример. Вычисляемое поле с именем «Прогноз» позволяет спрогнозировать будущие заказы с помощью формулы наподобие следующей:

='Сумма по доходу' * 1,2

Вычисляемый элемент в поле «Продукты», оценивающий продажи нового товара на основе продаж рыбных продуктов, может использовать формулу наподобие следующей:

=Рыбные * 115%

Формулы оперируют итоговыми суммами, а не отдельными записями. Формулы для вычисляемых полей оперируют суммами базовых данных для любого поля, используемого в формуле. Например, формула 'Сумма по доходу' * 1,2 умножает сумму заказов по каждому продукту и продавцу на 1,2; умножение каждого отдельного заказа на 1,2 с последующим суммированием произведений не выполняется. Однако формулы для вычисляемых элементов оперируют отдельными записями. Формула вычисляемого элемента 'Рыбные'*115% увеличивает каждый заказ по рыбным продуктам на 115%, после чего полученные значения суммируются в области данных.

Дополнительные сведения

Правила использования имен сводных таблиц и сводных диаграмм в формулах (например, когда использовать кавычки)

Использование операторов в формулах


Использование данных сводной таблицы в формуле, размещенной вне отчета сводной таблицы

  • Чтобы передать данные отчета сводной таблицы в формулу, размещенную вне сводной таблицы, необходимо воспользоваться функцией ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ. Для получения сведений по использованию этой функции нажмите кнопку [image] .

Примечание. Для получения сведений об использовании функций в формулах нажмите кнопку [image] .


 Изменение формулы для вычисляемого поля сводной таблицы или отчета сводной диаграммы

Изменение формулы для вычисляемого поля сводной таблицы или отчета сводной диаграммы

  1. Выделите ячейку отчета сводных таблиц, или щелкните отчет сводной диаграммы.

  2. На панели инструментов Сводные таблицы выберите Сводная таблица или Сводная диаграмма, далее выберите команду Формулы, а затем команду Вычисляемое поле.

  3. Выберите вычисляемое поле, для которого необходимо изменить формулу, в поле с раскрывающимся списком Имя.

  4. Измените формулу в поле Формула.

    Чтобы использовать в формуле данные поля, выберите поле в списке Поля, а затем нажмите кнопку Добавить поле.

  5. Нажмите кнопку Изменить.

Примечания

  • Для получения сведений о синтаксисе формул для вычисляемых полей нажмите кнопку [image] .

  • Когда в отчете сводной диаграммы создается вычисляемое поле, формула и ее результаты отражаются в связанном отчете сводной таблицы и наоборот. Если при работе с отчетом сводной диаграммы планируется создавать сложные формулы, рекомендуется создавать формулы в связанном отчете сводной таблицы (в котором могут быть просмотрены отдельные значения, формирующие результаты), а отображенные результаты просматривать в отчете сводной диаграммы. Формулы в отчетах сводных диаграмм.


 Изменение формулы для вычисляемого поля сводной таблицы или отчета сводной диаграммы

Изменение формулы для вычисляемого поля сводной таблицы или отчета сводной диаграммы

  1. Выделите поле, содержащее изменяемый вычисляемый элемент.

  2. На панели инструментов Сводные таблицы выберите Сводная таблица или Сводная диаграмма, далее выберите команду Формулы, а затем команду Вычисляемый объект.

  3. Выберите вычисляемый элемент, для которого необходимо изменить формулу, в поле Имя.

  4. Измените формулу в поле Формула.

    Чтобы использовать в формуле данные элементов, выберите поле в списке Поля, а элемент поля — в списке Элементы, и нажмите кнопку Добавить элемент.

    Если элемент находится в другом поле, то его использовать нельзя.

  5. Нажмите кнопку Изменить, а затем — кнопку OK.

Примечания

  • Формулы для вычисляемого элемента можно изменять отдельно в каждой ячейке отчета сводной таблицы. Для получения дополнительных сведений нажмите кнопку [image] .

  • Для получения сведений о синтаксисе формул для вычисляемого элемента нажмите кнопку [image] .

  • Когда в отчете сводной диаграммы создается вычисляемое поле, формула и ее результаты отражаются в связанном отчете сводной таблицы и наоборот. Если при работе с отчетом сводной диаграммы планируется создавать сложные формулы, рекомендуется создавать формулы в связанном отчете сводной таблицы (в котором могут быть просмотрены отдельные значения, формирующие результаты), а отображенные результаты просматривать в отчете сводной диаграммы. Формулы в отчетах сводных диаграмм.


 Изменение порядка обработки формул для вычисляемых элементов сводной таблицы или отчета сводных диаграмм

Изменение порядка обработки формул для вычисляемых элементов сводной таблицы или отчета сводных диаграмм

Эта процедура позволяет определить порядок выполнения вычислений для вычисляемых элементов для разных полей или нескольких формул для одного вычисляемого элемента. Например, если результат вычислений в крайнем поле строки отчета сводной таблицы зависит от вычисляемого элемента во внутреннем поле строки, следует убедиться, что вычисляемый элемент во внутреннем поле строки рассчитывается до вычислений в крайнем поле строки.

  1. Выделите ячейку отчета сводных таблиц, или щелкните отчет сводной диаграммы.

  2. На панели инструментов Сводные таблицы , выберите Сводная таблица или Сводная диаграмма, далее выберите Формулы, и затем — команду Порядок вычислений.

  3. Выберите формулу и нажмите кнопку Вверх или Вниз.

  4. Продолжайте выполнять предыдущий шаг, пока выбранная формула не окажется на нужном месте.

Примечание. Чтобы удалить формулу для вычисляемого элемента, нажмите кнопку Удалить в окне Порядок выполнения вычислений.


 Удаление вычисляемого поля из сводной таблицы или отчета сводной диаграммы

Удаление вычисляемого поля из сводной таблицы или отчета сводной диаграммы

Внимание! При удалении вычисляемого поля из сводной таблицы удаляется и формула. Чтобы сохранить сведения о формуле перед удалением поля, можно отобразить и распечатать список всех формул отчета. Для получения дополнительных сведений нажмите кнопку [image] .

  1. Выделите ячейку отчета сводных таблиц или выберите отчет сводной диаграммы.

  2. На панели инструментов Сводные таблицы выберите Сводная таблица или Сводная диаграмма, далее выберите команду Формулы, а затем команду Вычисляемое поле.

  3. Выберите удаляемое поле в поле с раскрывающемся списком Имя.

  4. Нажмите кнопку Удалить.

Примечание. Чтобы удалить вычисляемое поле из отчета, но иметь возможность использовать его позднее, удалите из отчета поля данных, перетаскивая их мышью, а затем перетащите из списка полей на панели инструментов Сводная таблица в область данных поля, которые должны присутствовать в отчете. Вычисляемые поля остаются доступными на панели инструментов Сводная таблица.


 Удаление вычисляемого элемента из сводной таблицы или отчета сводной диаграммы

Удаление вычисляемого элемента из сводной таблицы или отчета сводной диаграммы

Внимание! При удалении вычисляемого элемента поля из отчета сводной таблицы удаляется и формула. Чтобы сохранить информацию перед удалением элемента поля, можно отобразить список всех формул отчета. Для получения дополнительных сведений нажмите кнопку [image] .

  1. Выделите поле, содержащее вычисляемый элемент.

  2. На панели инструментов Сводные таблицы выберите Сводная таблица или Сводная диаграмма, далее выберите команду Формулы, а затем команду Вычисляемый объект.

  3. Выберите удаляемый элемент в поле с раскрывающемся списком Имя.

  4. Нажмите кнопку Удалить.

Примечание Для того чтобы убрать вычисляемый элемент из представления, не удаляя его, скройте вычисляемый элемент.


 Создание различных формул для различных ячеек вычисляемого элемента в отчете сводной таблицы

Создание различных формул для различных ячеек вычисляемого элемента в отчете сводной таблицы

При первом создании вычисляемого элемента формула одинакова для всех полей строки, столбца и страницы по вертикали или по горизонтали в области данных отчета сводной таблицы. Впоследствии можно изменить формулу в отдельной ячейке или отдельном элементе. Например, если для всех месяцев в вычисляемом элементе "Клубника" содержится формула "Апельсины * ,25", можно заменить ее формулой "Апельсины *,5" для июня, июля и августа.

  1. Выделите ячейку в строке или столбце вычисляемого элемента, в которой необходимо изменить формулу.

    Чтобы изменить формулу в нескольких ячейках, нажмите клавишу CTRL и, удерживая ее нажатой, выделите изменяемые ячейки или элементы.

  2. Измените формулу в строке формул.

Советы

  • При создании нескольких формул для вычисляемого элемента содержимое ячеек области данных определяется последней формулой. Для получения сведений об изменении порядка выполнения формул нажмите кнопку [image] .

  • Можно отобразить список всех формул отчета сводной таблицы. Для получения дополнительных сведений нажмите кнопку . .

  • Для получения сведений о синтаксисе формулы для вычисляемого элемента нажмите кнопку [image] .


 Отображение списка формул в сводной таблице или отчете сводной диаграммы

Отображение списка формул в сводной таблице или отчете сводной диаграммы

  1. Выделите ячейку отчета сводных таблиц, или выберите мышью отчет сводной диаграммы.

  2. На панели инструментов Сводные таблицы , нажмите кнопку Сводная таблица или Сводная диаграмма, далее выберите команду Формулы, и затем — команду Порядок вычислений.

Примечание. Лист, содержащий список формул для вычисляемых полей и вычисляемых элементов, предназначен только для просмотра. Изменение формул в этом списке невозможно. Для получения сведений по изменению формул для вычисляемых полей нажмите кнопку [image] . Для получения сведений по изменению формул для вычисляемых элементов нажмите кнопку [image] .


 Использует ли отчет сводной таблицы или сводной диаграммы данные OLAP

Использует ли отчет сводной таблицы или сводной диаграммы данные OLAP

Отчеты сводных таблиц, основанные на данных OLAP, содержат поля, которые могут использоваться только как поля строк, столбцов или страниц. Отчеты сводных диаграмм, основанные на данных OLAP, могут использовать эти поля только в качестве полей рядов, категорий или страниц. Имена этих полей можно узнать по значку Значок поля размерности, стоящему в начале строки полей на панели инструментов Сводная таблица. Поля, которые могут использоваться только как поля данных, обозначаются значком Значок поля данных. Отчеты сводных таблиц и сводных диаграмм, основанные на исходных данных OLAP, обладают другими доступными возможностями, чем отчеты сводных таблиц и сводных диаграмм, основанные на данных других типов.

  1. Щелкните отчет сводной таблицы или сводной диаграммы.

  2. Убедитесь, что панель инструментов Сводная таблица не закреплена.

  3. Убедитесь, что кнопка Отобразить поля [image] на панели инструментовСводная таблица нажата.

  4. В началах строк списка полей на панели инструментов поищите значки Значок поля размерности или Значок поля данных. Если такие значки имеются, то отчет сводной таблицы или сводной диаграммы основан на данных OLAP. Если таких значков нет, то отчет основан на исходных данных, отличных от OLAP.


 Создание сводной таблицы или отчета сводных диаграмм на основе данных, находящихся во внешнем источнике

Создание сводной таблицы или отчета сводных диаграмм на основе данных, находящихся во внешнем источнике

При необходимости обобщить и проанализировать подробные данные, которые находятся вне Microsoft Excel, например базу данных по продажам компании, можно использовать сводную таблицу или отчет сводных диаграмм. Существует несколько способов получения данных из внешних источников данных, таких как база данных, текстовый файл или источник, отличный от книги Microsoft Excel, включая Интернет.

Работа с исходными данными OLAP Когда данные извлекаются из базы данных OLAP или файла куба, они могут быть переданы в Excel только как отчет сводной таблицы. Можно создать отчеты сводных диаграмм по этому отчету сводной таблицы. Создание отчетов сводных таблиц по исходным данным OLAP.

Использование мастера сводных таблиц и сводных диаграмм Можно указать требуемые данные и извлечь данные при работе с мастером. Используя мастера, можно открыть файлы запросов и также создать новые запросы с помощью мастера запросов или Microsoft Query.

В следующих ситуациях передача внешних данных с помощью мастера сводных таблиц невозможна:

  • Шаблоны отчетов и файлы запросов Если необходимо использовать файл запроса (.dqy) для извлечения данных или использовать шаблон отчета (.xlt), который не включает отчет сводной таблицы, необходимо сначала открыть файл запроса или шаблон отчета. В книге, в которой открыт файл запроса или которая основана на шаблоне, можно создать отчет сводной таблицы по диапазону, содержащему внешние данные. Создание шаблона отчета или файла запроса.

  • Запросы с параметрами Для использования запроса с параметрами для извлечения данных необходимо сначала создать запрос с параметрами, а затем создать отчет сводной таблицы по диапазону, который содержит внешние данные. Нельзя создать запрос с параметрами для извлечения данных из баз данных OLAP.

  • Web-запросы Чтобы использовать Web-запрос для передачи данных через Интернет, необходимо сначала создать Web-запрос, а затем создавать сводную таблицу на основе диапазона, содержащего внешние данные.

Дополнительные сведения

Типы внешних баз данных, к которым можно получить доступ

Создание отчета сводной таблицы

Создание отчета сводной диаграммы


 Создание сводной таблицы или отчета сводной диаграммы по данным OLAP

Создание сводной таблицы или отчета сводной диаграммы по данным OLAP

Что такое OLAP?

On-Line Analytical Processing (OLAP) — это способ организации больших коммерческих баз данных. Данные OLAP организованы администратором базы данных таким образом, чтобы облегчить анализ и управление данными и уменьшить время для получения требуемых отчетов.

Уровни детализации Базы данных OLAP организовывают данные по уровням детализации, используя те же категории, которые используются при анализе данных. Например, база данных по продажам продукции компании по всему миру может содержать отдельные поля, определяющие страну, область, город и место для каждой продажи. В базе данных OLAP эта географическая информация может быть организована от нижнего уровня к верхнему, как показано ниже:

Уровни в географическом аспекте

Уровни в географическом аспекте

Такая организация данных упрощает отображение итогов по продажам на верхнем уровне иерархии, например общие продажи по стране или области, и отображение деталей по местам продаж с особенно высоким или особенно низким уровнем продаж. В сводной таблице или отчете сводной диаграммы можно отобразить обобщенные данные на разных уровнях, а затем просматривать более детальную информацию, отображая только заинтересовавшие элементы.

Измерения и кубы Набор уровней, относящихся к одному аспекту данных, например географическому положению, называется измерением. Информация о продажах может быть организована и во временном измерении: по годам, кварталам, месяцам и дням. Базы данных OLAP называют кубами из-за того, что они сочетают несколько измерений, например время, география и изделия, с обобщением данных, например по объемам продаж или размерам складских запасов.

Другие преимущества OLAP Базы данных OLAP спроектированы так, чтобы ускорить загрузку данных. Поскольку суммирует данные сервер OLAP, а не Excel, при создании и изменении сводной таблицы или отчета сводной диаграммы требуется передача в Excel гораздо меньшего объема информации. Этот подход позволяет работать с гораздо большими объемами информации, чем при использовании не-OLAP базы данных. В этом случае Excel должен загрузить все отдельные записи и подсчитать итоговые значения.

Возможности Excel по работе с OLAP

Загрузка данных OLAP Соединение с источниками данных OLAP производится так же, как и с другими внешними источниками данных. Можно работать с базами данных, созданными Microsoft SQL Server OLAP Services. Excel позволяет работать с OLAP-изделиями третьих фирм, которые обеспечивают драйверы источника данных, совместимые с OLE-DB для OLAP.

Excel позволяет отображать данные, загруженные из источника данных OLAP, только в виде сводной таблицы или отчета сводной диаграммы. Данные OLAP не могут быть отображены как внешний диапазон данных. Сводная таблица и отчет сводной диаграммы на основе данных OLAP могут быть сохранены в шаблонах отчетов, могут быть созданы и файлы запросов OLAP. Файлы запросов OLAP имеют расширение .oqy. При открытии файла .oqy Excel отображает пустой отчет сводной таблицы, готовый для создания макета.

Для получения информации о настройке источников данных OLAP и создании файлов .oqy обратитесь к справке по Microsoft Query.

Создание кубов из реляционных баз данных Excel предлагает Мастер куба OLAP для организации данных из реляционной базы данных, например Microsoft SQL Server, в кубы OLAP. Создание куба из результатов запроса к реляционной базе данных позволяет работать с большими объемами данных в сводной таблице или отчете сводной диаграммы, с другой стороны это позволяет ускорить загрузку данных. Создание куба OLAP по результатам выполнения запроса.

Создание кубов для автономного использования Можно также использовать Мастер автономных кубов для создания файлов с подмножествами данных из куба OLAP. Файлы автономного куба позволяют работать с данными OLAP даже при работе вне сети. Можно использовать эти файла для обеспечения доступности данных OLAP в сети или Интернете, если исходная база не должна быть доступной другим пользователям.

Файлы куба могут быть созданы только в том случае, если поставщик данных для куба, например Microsoft SQL Server OLAP Services, поддерживает создание файлов куба. Создание файлов куба.

Дополнительные сведения

Типы внешних баз данных, к которым можно получить доступ

Загрузка внешних данных с помощью Microsoft Query

Источники данных OLAP для сводных таблиц и отчетов сводных диаграмм

Различия между сводными таблицами и отчетами сводных диаграмм, основанных на OLAP и не-OLAP источниках данных

Создание отчета сводной таблицы

Создание отчета сводной диаграммы


 Работа с большими внешними базами данных с помощью полей страниц в отчетах сводных таблиц и сводных диаграмм

Работа с большими внешними базами данных с помощью полей страниц в отчетах сводных таблиц и сводных диаграмм

Возможности использования полей страниц, описанные в данном разделе, недоступны в отчетах сводных таблиц и сводных диаграмм, основанных на исходных данных OLAP. См. сведения об оптимизации извлечения данных с помощью баз данных OLAP.

При работе с большими не-OLAP базами данных возврат данных по запросам может занимать много времени; кроме того, в Microsoft Excel может возникнуть недостаток памяти или других ресурсов, необходимых для создания отчетов.

Каким образом поля страниц позволяют работать с большим объемом данных. Чтобы избежать долгого ожидания возврата данных или проблем с нехваткой памяти, можно использовать поля страниц для ограничения объема единовременно извлекаемых данных. Чтобы установить параметр извлечения данных только для того элемента поля страницы, который отображается в текущий момент, нажмите кнопку Макет на шаге 3 мастера сводной таблицы или сводной диаграммы, дважды щелкните поле в области «Страница», а затем нажмите кнопку Далее. При отображении другого элемента поля страницы будет извлечен набор данных для этого элемента.

Данный параметр устанавливается отдельно для каждого поля страницы. Подобным образом можно настроить любое необходимое количество полей страниц для извлечения того объема данных, который требуется проанализировать в отчете сводной таблицы или сводной диаграммы.

Как параметры поля страницы влияют на производительность. Возможность извлечения данных для каждого элемента следует использовать только в случае, если требуется извлечь данные, объем которых больше, чем позволяют обработать ресурсы системы. Если для поля страницы установлен параметр извлечения данных для каждого элемента при его выборе, становятся недоступными элемент Все для поля страницы, а также команда Отобразить страницы. Если же, напротив, внешние данные извлекаются одновременно для всех элементов поля страницы (параметр по умолчанию), первоначальное извлечение данных может происходить медленнее, однако отображение элементов поля страницы будет более быстрым, поскольку все необходимые данные находятся в памяти.

В случае отключения от внешнего источника данных при наличии поля страницы, настроенного на получение данных для каждого элемента в отдельности, отображение другого элемента поля страницы будет невозможно до восстановления подключения к исходным данным.

Перемещение полей страниц. При перетаскивании поля страницы, настроенного на получение внешних данных для каждого элемента, в другое положение в области сведения данные для всех элементов будут извлекаться одновременно. Если поле перемещено обратно в область страницы, данные будет снова извлекаться отдельно для каждого элемента.

Ситуации, в которых параметры полей страниц недоступны. При следующих условиях изменить параметры полей страниц нельзя; извлечение внешних данных для всех элементов поля страницы должно производиться за одну операцию.

  • Наличие нескольких отчетов сводных таблиц или сводных диаграмм, основанных на отчете сводной таблицы. Если имеются другие отчеты сводных таблиц или сводных диаграмм, основанные на отчете сводной таблицы, параметры полей страниц недоступны в исходном отчете сводной таблицы и во всех отчетах сводных таблиц или сводных диаграмм, основанных на исходном отчете. Однако при наличии единственного отчета сводной диаграммы и связанного с ним отчета сводной таблицы параметры полей страниц доступны.

  • Драйверы не поддерживают запросы с параметрами. Если драйвер ODBC или драйвер источника данных для внешней базы данных, к которой выполняется запрос, не поддерживает запросы с параметрами, параметры полей страниц недоступны.

    Драйверы источников данных OLAP не поддерживают запросы с параметрами. Все драйверы ODBC, поставляемые корпорацией Майкрософт с Microsoft Query, поддерживают запросы с параметрами. Чтобы узнать, поддерживает ли запросы с параметрами драйвер стороннего производителя, обратитесь к поставщику драйвера.

  • Сгруппированные элементы в поле страницы. Если поле страницы сгруппировано, или если поле исходных данных является полем комментариев или содержит объекты OLE, параметры поля страницы недоступны. См. Разгруппировка элементов поля страницы.


 Получение данных полей страниц сводного списка или сводной диаграммы для каждого элемента или для всех элементов

Получение данных полей страниц сводного списка или сводной диаграммы для каждого элемента или для всех элементов

Данная процедура используется только для отчетов сводных таблиц и сводных диаграмм, основанных на внешних не-OLAP исходных данных.

  1. Дважды щелкните кнопку того поля страницы, которое требуется изменить.

  2. Нажмите кнопку Далее.

  3. Выполните одно из следующих действий:

    Для того чтобы получать данные для элементов поля страницы по отдельности, что позволяет работать с большими внешними наборами данных, установите переключатель Параметры поля сводной таблицы в положение Обновлять внешние данные при выборе каждого элемента.

    Для того чтобы получать внешние данные сразу для всех элементов, что снижает частоту обновления отчета сводной таблицы или сводной диаграммы и повышает скорость отображения различных элементов поля страницы, установите переключатель в положение Извлекать внешние данные для всех полей.

  4. Для того чтобы заблокировать поле, настроенное на получение данных для каждого элемента в отдельности, в позиции страницы и тем самым запретить его перетаскивание в другие части отчета сводной таблицы или сводной диаграммы, установите флажок Запретить сведения по данному полю.

Примечания

  • В случае отключения от внешнего источника данных при наличии поля страницы, настроенного на получение данных для каждого элемента в отдельности, отображение элемента другого поля страницы будет невозможно до восстановления подключения к исходным данным.

  • См. сведения о том, работают настройки поля страницы, включая сведения об использовании каждого параметра и ситуациях, в которых те или иные параметры недоступны.


 Изменение запроса для сводной таблицы или отчета сводной диаграммы

Изменение запроса для сводной таблицы или отчета сводной диаграммы

Эта процедура доступна только для отчетов, основанных на внешних не-OLAP исходных данных. Использует ли отчет сводной таблицы данные OLAP.

  1. Выделите отчет сводной таблицы. Для отчета сводных диаграмм, выберите мышью связанный отчет сводной таблицы.

  2. На панели инструментов Сводные таблицы нажмите кнопку Мастер сводных таблиц [image] .

  3. На шаге 3 мастера нажмите кнопку Назад.

  4. На шаге 2 мастера, нажмите кнопку Получить данные.

  5. Измените запрос в Microsoft Query.

    Инструкции

  6. В меню File Query выберите команду Вернуть данные в Microsoft Excel.

  7. На шаге 2 мастера сводных таблиц и сводных диаграмм нажмите кнопку Готово.

    Новые поля, извлеченные измененным запросом, появятся в списке полей на панели инструментов Сводная таблица, поэтому можно добавит поля в сводную таблицу или отчет сводной диаграммы. Поля, которые были использованы в отчете, но не извлекаются измененным запросом, автоматически удаляются из отчета.

Примечания

  • См. сведения об использовании внешнего источника данных для создания сводной таблицы или отчета сводной диаграммы.

  • При изменении запроса для отчета сводных диаграмм или сводной таблицы, связанной с отчетом сводных диаграмм, некоторые форматирования диаграммы могут быть утеряны.


 Запуск запроса для сводной таблицы или отчета сводной диаграммы в фоновом режиме или в процессе ожидания

Запуск запроса для сводной таблицы или отчета сводной диаграммы в фоновом режиме или в процессе ожидания

Данная процедура используется только для отчетов сводных таблиц и сводных диаграмм, основанных на внешних не-OLAP исходных данных.

  1. Щелкните отчет сводной таблицы или сводной диаграммы.

  2. На панели инструментов Сводные таблицы нажмите кнопку Сводная таблица (или Сводная диаграмма) и выберите команду Параметры таблицы (или Параметры).

  3. Выполните одно из следующих действий:

    Для того чтобы запустить запрос и дождаться завершения загрузки внешних данных, снимите флажок Фоновый запрос в группе Внешние данные.

    Для того чтобы запрос выполнялся в фоновом режиме, позволяя продолжать работу в Microsoft Excel, установите флажок Фоновый запрос.

Примечания

  • Запуск запроса. Запрос для отчета сводной таблицы или сводной диаграммы, основанного на внешних данных, запускается по нажатию кнопки Готово в мастере сводных таблиц и диаграмм для создания нового отчета сводной таблицы или сводной диаграммы, либо по нажатию кнопки Обновить данные [image] на панели инструментов Сводные таблицы. Также можно задать параметры, чтобы запрос выполнялся при открытии книги или через определенные интервалы времени.

  • Прерывание выполнения запроса. Для того чтобы во время ожидания результатов проверить состояние или прервать выполнение запроса, нажмите кнопку ESC. Для того чтобы прервать выполнение фонового запроса, дважды щелкните значок индикатор обновления в строке состояния, чтобы открыть диалоговое окно Состояние обновления внешних данных, а затем нажмите кнопку Прервать.

  • Запись макросов, содержащих запросы. Во время записи макроса, включающего запрос, Microsoft Excel не может выполнить этот запрос в фоновом режиме. Для того записанный макрос мог выполняться в фоновом режиме, необходимо в редакторе Visual Basic заменить инструкцию "BackgroundQuery := False" на "BackgroundQuery := True". Сведения о редактировании макросов см. в справке по Visual Basic.


 Об обновлении данных в отчете сводной таблицы или сводной диаграммы

Об обновлении данных в отчете сводной таблицы или сводной диаграммы

При обновлении отчетов сводных таблиц или сводных диаграмм, основанных на исходных данных Microsoft Excel, Excel извлекает все новые поля из исходного диапазона или именованного диапазона, указанного при создании отчета сводной таблицы или сводной диаграммы.

При обновлении отчетов, основанных на внешних исходных данных, Excel извлекает новые строки или записи из внешнего файла или базы данных, отвечающие условиям, указанным в запросе.

Обновление отчетов сводных таблиц и сводных диаграмм для отражения изменений в исходных данных.

Также можно изменить отчет сводной таблицы или сводной диаграммы для использования других исходных данных.

Обновление в случае, когда исходные данных получены из базы данных OLAP. Если отчеты сводных таблиц и сводных диаграмм основаны на данных из баз данных OLAP, Excel обновляет отчеты автоматически всякий раз, когда изменяется вид отображаемых в них данных. Если источником исходных данных является файл автономного куба, кнопка Обновить данные [image] подключает Excel к исходной базе данных OLAP, перезаписывает данные в файле куба и обновляет данные, отображаемые в отчете. См. сведения об обновлении кубов и файлов кубов.

Извлечение внешних данных при выполнении других действий. Если отчеты сводных таблиц и сводных диаграмм основаны на внешних не-OLAP исходных данных, можно извлекать данные в фоновом режиме, продолжая работу в Excel, или запустить запрос в режиме ожидания извлечения данных. См. Запуск запроса в фоновом режиме или в режиме ожидания.

Извлечение данных для одного или всех элементов поля страницы. Если отчеты сводных таблиц и сводных диаграмм основаны на внешних не-OLAP исходных данных, можно указать, как Excel должен извлекать данные для полей страниц. Можно установить режим, при котором Excel запрашивает внешние исходные данных при выборе элемента поля страницы для отображения, что требует меньше памяти, либо режим, при котором Excel извлекает данные для всех элементов поля страницы одновременно, что позволяет быстрее менять отображаемые элементы поля страницы. См. сведения об установке параметров полей страниц и сведения о различных установках для полей страниц.

Влияние обновления форматирования сводной диаграммы. При обновлении отчета сводной диаграммы или отчета сводной таблицы, который связан с отчетом сводной диаграммы, некоторые параметры форматирования диаграммы могут быть утеряны.

Обновление при открытии книги. По умолчанию Excel не обновляет данные в отчете сводной таблицы или сводной диаграммы при открытии книги, содержащей отчет. При необходимости можно установить режим автоматического обновления отчетов сводных таблиц и сводных диаграмм при открытии книги.


 Обновление сводной таблицы и отчета сводной диаграммы

Обновление сводной таблицы и отчета сводной диаграммы

Microsoft Excel обеспечивает несколько вариантов управления временем и способом обновления данных, формирующих сводную таблицу или отчет сводной диаграммы. Изменение сводной таблицы или отчета сводной диаграммы могеж также связано с использованием других исходных данных.

Предполагаемые действия

Обновление данных в сводной таблице или отчете сводной диаграммы для отражения изменений в исходных данных

Обновление сводной таблицы или отчета сводной диаграммы, основанных на файле автономного куба или других данных из источника OLAP

Запуск запроса для сводной таблицы или отчета сводной диаграммы в фоновом режиме или в процессе ожидания

Выборка данных каждого поля страницы по отдельности или выборка данных сразу всех полей

Обновление данных сводной таблицы или отчета сводной диаграммы при открытии файла книги

Не можете сделать выбор?


Подготовка отчета сводной таблицы к печати

Предполагаемые действия

Печать отчета сводной таблицы с подписями столбцов и строк, повторяющимися на каждой странице

Печать отчета сводной таблицы с элементами внешнего поля строк, повторяющимися на каждой странице

Печать разделов отчета сводной таблицы на отдельных листах

Параметры печати Microsoft Excel

Не можете сделать выбор?


Разрешение вопросов при работе с отчетами сводных таблиц

В чем именно заключаются сложности?

Данный раздел содержит ссылки на разделы со сведениями по следующим вопросам:

Создание отчета сводной таблицы

Работа с макетом отчета сводной таблицы

Форматирование и настройка отчета сводной таблицы

Получение и обновление данных

Вычисления

Создание отчета сводной таблицы

Получено сообщение о том, что недостаточно памяти для создания отчета сводной таблицы.

Отчет сводной таблицы, который требуется использовать для создания другого отчета, не отображается в списке мастера.

Сводная таблица с Web-страницы вставлена или импортирована неправильно.

Проблемы при создании или использовании источника данных куба OLAP для отчета сводной таблицы.

Возврат в начало

Работа с макетом отчета сводной таблицы

При перетаскивании поля в отчет сводной таблицы данные появляются с задержкой.

Выполнение изменений макета или вида отчета сводной таблицы занимает много времени.

Не удается переместить поле сводной таблицы в новое положение.

При перемещении полей данных сводной таблицы на лист не удается расположить их в нужном порядке.

Отсутствует список полей отчета сводной таблицы.

При закреплении панели инструментов сводной таблицы не удается отобразить список полей.

В поле строки или столбца отчета сводной таблицы отсутствует стрелка.

Возврат в начало

Форматирование и настройка отчета сводной таблицы

При обновлении отчета сводной таблицы или изменении его макета происходит изменение формата.

После применения автоформата изменился макет отчета сводной таблицы.

Числовой формат в отчете сводной таблицы отличается от числового формата исходных данных.

Числовые элементы сводной таблицы после переименования сортируются или форматируются неправильно.

В отчете сводной таблицы отсутствуют требуемые возможности.

Возврат в начало

Получение и обновление данных

Получено сообщение о том, что отчет сводной таблицы является недопустимым.

Не удается изменить лист во время выполнения запроса сводной таблицы.

После обновления отчета сводной таблицы в отчете утеряны данные.

Отчет сводной таблицы выглядит совершенно иначе после обновления, либо обновить отчет больше не удается.

Параметры поля страницы недоступны

Возврат в начало

Вычисления

Для вычислений в поле данных в качестве итоговой функции вместо функции «Сумма» используется функция «Количество значений», и наоборот.

Вычисляемое поле или элемент поля отображает неправильное значение.

Невозможно изменить итоговую функцию для вычисляемого поля

Рядом с итоговыми значениями в отчете сводной таблицы отображается звездочка

Возврат в начало


Способы прогнозирования и выполнения регрессионного анализа

Прогнозирование линейных процессов. В линейных рядах Microsoft Excel увеличивает или уменьшает значения на постоянную величину, основываясь на разнице между выбранными начальными значениями.

Начальное значение | Продолжение ряда (арифметическая прогрессия)
1, 2 | 3, 4, 5
1, 3 | 5, 7, 9
100, 95 | 90, 85

Прогнозирование экспоненциальных процессов. В экспоненциальных рядах Excel умножает начальные значения на постоянную величину.

Начальное значение | Продолжение ряда (геометрическая прогрессия)
1, 2 | 4, 8, 16
1, 3 | 9, 27, 81
2, 3 | 4.5, 6.75, 10.125

Заполнение значений с помощью команды «Прогрессия». С помощью команды Прогрессия можно вручную управлять созданием линейной или экспоненциальной зависимости, а также вводить значения с клавиатуры.

Прогнозирование значений с помощью функции ПРЕДСКАЗ. Функция ПРЕДСКАЗ позволяет сделать прогноз, применяя линейную регрессию диапазона известных данных или массивов (x,y). Например, исходя из общего дохода за каждый из предыдущих шести кварталов, функция ПРЕДСКАЗ может рассчитать ожидаемый доход за следующие два квартала.

Прогнозирование значений с помощью функций ТЕНДЕНЦИЯ или РОСТ. Сходные функции ТЕНДЕНЦИЯ и РОСТ позволяют экстраполировать значения y, продолжающие прямую линию или экспоненциальную кривую, наилучшим образом описывающую существующие данные. Эти функции возвращают значения y, соответствующие заданным значениям x. По этим данным можно построить график процесса.

Расчет прямой линии или экспоненциальной кривой по существующим данным при помощи функции ЛИНЕЙН или ЛГРФПРИБЛ. Функции ЛИНЕЙН и ЛГРФПРИБЛ возвращают данные регрессионного анализа, включая наклон и смещение графика относительно оси Y.

Использование надстройки «Пакет анализа». При необходимости выполнить более сложный регрессионный анализ — включая вычисление и отображение остатков — можно использовать средство регрессионного анализа в надстройке «Пакет анализа».

Добавление линии тренда в диаграмму. Существует также возможность создания линии тренда на диаграмме без создания данных для линии тренда.


 Прогнозирование и регрессионный анализ

Прогнозирование и регрессионный анализ

Microsoft Excel позволяет заполнить ячейки рядом значений, соответствующих простой линейной или экспоненциальной зависимости с помощью маркера заполнения. Для экстраполяции сложных и нелинейных данных применяются функции листа, перечисленные ниже, или средство регрессионного анализа из «Пакета анализа».

Можно также добавить линию тренда на диаграмму, не создавая данных для линии тренда.

Предполагаемые действия

Использование маркера заполнения или команды Прогрессия

Прогнозирование линейных процессов

Прогнозирование экспоненциальных процессов

Заполнение значений с помощью команды Прогрессия

Использование функций листа

Прогнозирование с помощью функции ПРЕДСКАЗ

Прогнозирование линейной зависимости с помощью функции ТЕНДЕНЦИЯ

Прогнозирование экспоненциальной зависимости с помощью функции РОСТ

Построение линейного приближения с помощью функции ЛИНЕЙН

Построение экспоненциального приближения с помощью функции ЛГРФПРИБЛ

Использование надстройки «Пакет анализа»

Надстройка «Пакет анализа»

Не можете сделать выбор?


 Прогнозирование линейной зависимости

Прогнозирование линейной зависимости

  1. Укажите не менее двух ячеек, содержащих начальные значения.

    Чтобы повысить точность прогноза, укажите дополнительные начальные значения.

  2. Протащите маркер заполнения в направлении возрастания или уменьшения значений.

    Например, если ячейки C1:E1 содержат начальные значения 3, 5 и 8, то при протаскивании вправо значения будут возрастать, влево — убывать.

Совет Чтобы вручную управлять созданием ряда или использовать клавиатуру для заполнения ряда значений, используйте команду Ряд.


 Прогнозирование экспоненциальной зависимости

Прогнозирование экспоненциальной зависимости

  1. Укажите не менее двух ячеек, содержащих начальные значения.

    Чтобы повысить точность прогноза, укажите дополнительные начальные значения.

  2. Удерживая правую кнопку мыши, протащите маркер заполнения в направлении возрастания или уменьшения значений.

    Например, если ячейки C1:E1 содержат начальные значения 3, 5 и 8, то при протаскивании вправо значения будут возрастать, влево — убывать.

  3. Отпустите кнопку мыши, а затем выберите Экспоненциальное приближение в контекстном меню.

Совет Чтобы вручную управлять созданием ряда или использовать клавиатуру для заполнения ряда значений, используйте команду Ряд.


Создание арифметической и геометрической прогрессии с помощью команды «Прогрессия»

Команда Прогрессия удаляет из ячеек прежние данные, заменяя их новыми. Если необходимо сохранить прежние данные, скопируйте их в другую строку или другой столбец, а затем приступайте к созданию прогрессии.

  1. Выделите ячейку, в которой находится первое значение создаваемой прогрессии.

  2. В меню Правка выберите пункт Заполнить, затем щелкните пункт Прогрессия.

  3. Варианты действий:

    Если необходимо заполнить прогрессией часть столбца, установите флажок по столбцам.

    Если необходимо заполнить прогрессией часть строки, установите флажок по строкам.

  4. В поле Шаг введите значение шага прогрессии. В арифметической прогрессии шаг — это число, добавляемое к каждому следующему члену прогрессии. В геометрической прогрессии шаг — это число, на которое умножается каждый следующий член прогрессии.

  5. В разделе Тип выберите тип прогрессии — арифметическая или геометрическая.

  6. В поле Предельное значение введите число, которое определит значение последнего члена прогрессии (он не превысит предельного значения).

Примечание. Если в ячейках уже содержатся первые члены прогрессии, и требуется, чтобы Microsoft Excel создал прогрессию автоматически, установите флажок Автоматическое определение шага. Если выбрано построение арифметической прогрессии, то вычисление ее шага производится с применением алгоритма наименьших квадратов и аппроксимацией существующих значений формулой (y=mx+b), где b — шаг прогрессии. Если выбрано построение геометрической прогрессии, то вычисление ее шага производится также с применением алгоритма наименьших квадратов, но используется формула (y=b*m^x). В обоих случаях не учитывается значение, введенное в поле «Шаг». При создании этих прогрессий получаются те же значения, которые вычисляются с помощью функций ТЕНДЕНЦИЯ и РОСТ.


Способы прогнозирования значений с помощью анализа "что-если" (таблицы данных)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Создание таблицы подстановки с одной переменной

Создание таблицы подстановки с одной переменной

Следует сформировать таблицу подстановки с одной переменной так, чтобы введенные значения были расположены либо в столбце (ориентированные по столбцу), либо в строке (ориентированные по строке). Формулы, используемые в таблицах подстановки с одной переменной должны ссылаться на ячейку ввода.

  1. Либо в отдельный столбец, либо в отдельную строку введите список значений, которые следует подставлять в ячейку ввода.

  2. Если значения расположены в столбце, то введите формулу в ячейку, расположенную на одну строку выше и на одну ячейку правее первого значения. Правее первой формулы введите любые другие формулы.

    Если значения расположены в строке, то введите формулу в ячейку, расположенную на один столбец левее и на одну строку ниже первого значения. В том же столбце, но ниже наберите любые другие формулы.

  3. Выделите диапазон ячеек, содержащий формулы и значения подстановки.

  4. В меню Данные выберите команду Таблица.

    Демонстрация

  5. Если таблица подстановки данных ориентирована по столбцам, то введите ссылку на ячейку ввода в поле Подставлять значения по столбцам в.

    Если же таблица подстановки данных ориентирована по строкам, то ссылка на ячейку ввода вводится в поле Подставлять значения по строкам в.

Совет. Имеется возможность добавления дополнительных формул в таблицу подстановки с одной переменной. Для получения более подробных сведений нажмите кнопку [image] .


 Добавление формулы в существующую таблицу подстановки с одной переменной

Добавление формулы в существующую таблицу подстановки с одной переменной

Формулы, используемые в таблице подстановки с одной переменной, должны ссылаться на одну и ту же ячейку ввода.

  1. Если значения расположены в столбце, то введите новую формулу в пустую ячейку, расположенную в верхней строке справа от существующей формулы.

    Если же значения расположены в строке, то новая формула вводится в пустую ячейку первого столбца ниже существующей формулы.

  2. Выделите таблицу подстановки, включая столбец или строку, где содержится новая формула.

  3. В меню Данные выберите команду Таблица.

    Демонстрация

  4. Если значения расположены в столбце, то ссылку на ячейку ввода введите в поле Подставлять значения по столбцам в.

    Если же данные расположены в строке, то эта ссылка вводится в поле Подставлять значения по строкам в.


 Преобразование рассчитанных значений таблицы подстановки данных в константы

Преобразование рассчитанных значений таблицы подстановки данных в константы

Преобразовать отдельное значение подстановки невозможно. Так как рассчитанные значения расположены в массиве, то необходимо преобразовать их все.

  1. Выделите в таблице все рассчитанные значения.

  2. Выберите команду Копировать в меню Правка.

  3. В меню Правка выберите команду Специальная вставка.
  4. Установите переключатель Вставить в положение Значения.


 Создание таблицы подстановки с двумя переменными

Создание таблицы подстановки с двумя переменными

Таблицы подстановки с двумя переменными используют одну формулу с двумя наборами значений. Формула должна ссылаться на две различных ячейки ввода.

  1. В ячейку листа введите формулу, которая ссылается на две ячейки ввода.

  2. В тот же столбец ниже формулы введите значения подстановки для первой переменной. Значения подстановки для второй переменной вводятся в строку правее формулы.

  3. Выделите диапазон ячеек, содержащий формулу и оба набора данных подстановки.

  4. В меню Данные выберите команду Таблица.

    Демонстрация

  5. В поле Подставлять значения по столбцам в введите ссылку на ячейку ввода для значений подстановки в строке.

  6. В поле Подставлять значения по строкам в введите ссылку на ячейку ввода для значений подстановки в столбце.


 Удаление рассчитанных значений из таблицы подстановки данных

Удаление рассчитанных значений из таблицы подстановки данных

Удаление отдельного значения невозможно. Так как рассчитанные значения содержатся в массиве, то необходимо удалить все значения. Убедитесь, что не выделены формулы и значения подстановки, если только не удаляется вся таблица.

  1. Выделите в таблице все рассчитанные значения.

  2. Выберите пункт Очистить в меню Правка, а затем – команду Содержимое.


Удаление всей таблицы подстановки данных

  1. Выделите всю таблицу подстановки данных, включая формулы, значения подстановки, рассчитанные значения, форматы и комментарии.

  2. Выберите пункт Очистить в меню Правка, а затем – команду Все.


 Ускорение пересчета листа, содержащего таблицу подстановки данных

Ускорение пересчета листа, содержащего таблицу подстановки данных

Таблицы подстановки данных пересчитываются всякий раз при пересчете листа, даже если в них не были внесены изменения. Для ускорения процесса пересчета листа, содержащего таблицу подстановки данных, следует так изменить параметр Вычисления, чтобы автоматически пересчитывался лист, но не таблицы. Когда же возникнет необходимость пересчитать таблицу, нажмите клавишу F9.

  1. В меню Сервис выберите пункт Параметры и перейдите на вкладку Вычисления.

  2. Выберите Автоматически кроме таблиц.


Способы прогнозирования значений с помощью анализа "что-если" (подбор параметров и поиск решения)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Поиск определенного результата для ячейки с помощью подбора значения другой ячейки

Поиск определенного результата для ячейки с помощью подбора значения другой ячейки

  1. Выберите команду Подбор параметра в меню Сервис.

    Демонстрация

  2. В поле Установить в ячейке введите ссылку на ячейку, содержащую необходимую формулу.

  3. Введите искомый результат в поле Значение.

  4. В поле Изменяя значение ячейки введите ссылку на ячейку, значение которой нужно подобрать. Формула в ячейке, указанной в поле Установить в ячейке должна ссылаться на эту ячейку.


Способы прогнозирования значений с помощью анализа "что-если" (сценарии)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Создание сценария

Создание сценария

  1. Выберите команду Сценарии в меню Сервис.

    Демонстрация

  2. Нажмите кнопку Добавить.

  3. Введите необходимое имя в поле Название сценария.

  4. Введите ссылки на ячейки, которые необходимо изменить, в поле Изменяемые ячейки.

  5. Установите необходимые флажки в наборе флажков Защита.

  6. Нажмите кнопку OK.

  7. Введите необходимые значения в диалоговом окне Значения ячеек сценария.

  8. Чтобы создать сценарий, нажмите кнопку OK.

    Для создания дополнительных сценариев нажмите кнопку Добавить, а затем повторите шаги с 3 по 7. После завершения создания сценариев нажмите кнопку OK, а затем — кнопку Закрыть в диалоговом окне Диспетчер сценариев.

Совет Для сохранения исходных значений изменяемых ячеек создайте сценарий, который использует исходные значения ячеек, до создания сценария, изменяющего значения.


 Просмотр сценария

Просмотр сценария

При просмотре сценария изменяют ячейки, сохраненные как часть этого сценария.

  1. Выберите команду Сценарии в меню Сервис.

    Демонстрация

  2. Выберите название сценария, который необходимо просмотреть.

  3. Нажмите кнопку Вывести.


 Правка сценария

Правка сценария

Если после внесения изменений в сценарий он будет сохранен с первоначальным именем, то новые значения изменяемых ячеек заменят значения в исходном сценарии.

  1. Выберите команду Сценарии в меню Сервис.

    Демонстрация

  2. Укажите название изменяемого сценария, а затем нажмите кнопку Изменить.

  3. Исправьте необходимое.

  4. Введите необходимые значения в диалоговом окне Значения ячеек сценария.

  5. Чтобы сохранить изменения, нажмите кнопку OK.

    Чтобы вернуться в диалоговое окно Диспетчер сценариев не изменяя текущий сценарий, нажмите кнопку Отмена.


 Объединение сценариев из других листов

Объединение сценариев из других листов

Сценарии объединять проще, если все модели что-если на листах идентичны.

  1. Откройте все книги, содержащие объединяемые сценарии.

  2. Перейдите на лист, на котором требуется объединить сценарии.

  3. Выберите команду Сценарии в меню Сервис.

    Демонстрация

  4. Нажмите кнопку Объединить.

  5. Выберите название книги из списка Книга.

  6. В поле Лист щелкните имя листа, содержащего сценарии, которые требуется объединить, и нажмите кнопку OK. Все изменяемые ячейки выбранного листа должны ссылаться на соответствующие изменяемые ячейки активного листа. Microsoft Excel копирует все сценарии с исходного листа на активный лист.

  7. Для объединения сценариев с дополнительных листов повторите шаги с 3-го по 6-й.


 Создание итогового отчета по сценариям

Создание итогового отчета по сценариям

  1. Выберите команду Сценарии в меню Сервис.

    Демонстрация

  2. Нажмите кнопку Отчет.

  3. Установите переключатель в положение Структура или Сводная таблица.

  4. В поле Ячейки результата введите ссылки на ячейки, значения которых были изменены с помощью сценариев. В качестве разделителя ссылок используется запятая.

Примечание. Не обязательно указывать ячейки результата в итоговый отчет, однако они потребуются в отчете со сводной таблицей.


 Запрещение внесения изменений в сценарий

Запрещение внесения изменений в сценарий

  1. Выберите команду Сценарии в меню Сервис.

    Демонстрация

  2. Выберите название сценария из списка Сценарии.

  3. Нажмите кнопку Изменить.

  4. Для того чтобы запретить внесение изменений в сценарий другими пользователями, установите флажок Запретить изменения.

    Для того чтобы убрать сценарий из списка в диалоговом окне Диспетчер сценариев, установите флажок Скрыть.

  5. Нажмите кнопку OK.

  6. В диалоговом окне Значения ячеек сценария нажмите кнопку OK, а затем кнопку Закрыть.

  7. В меню Сервис выберите команду Защита и подкоманду Защитить лист.

  8. Убедитесь, что установлен флажок Сценарии.

Примечание. На защищенный лист можно добавлять сценарии, но редактировать или удалять существующие сценарии при действующей защите листа нельзя, если не снят флажок Запретить изменения в диалоговом окне Изменение сценария. Если ячейки не заблокированы, возможность редактирования значений в изменяющихся ячейках сохраняется. Инструкции по снятию защиты листа.


 Удаление сценария

Удаление сценария

  1. Выберите команду Сценарии в меню Сервис.
  2. Укажите название удаляемого сценария, а затем нажмите кнопку Удалить.


Поиск значения ячейки, соответствующего экстремальному значению зависимой ячейки

Процедуру поиска решения можно использовать для определения значения влияющей ячейки, которое соответствует экстремуму зависимой ячейки — например, расходы на рекламу, обеспечивающие максимальную прибыль. Влияющая и целевая ячейки должны быть связаны формулой листа, иначе при изменении значения одной не будет изменяться другая. Чтобы получить более подробные сведения об алгоритмах, используемых для поиска, нажмите кнопку [image] .


 Постановка задачи и оптимизация модели с помощью процедуры поиска решения

Постановка задачи и оптимизация модели с помощью процедуры поиска решения

  1. В меню Сервис выберите команду Поиск решения.

    Если команда Поиск решения отсутствует в меню Сервис, установите соответствующую надстройку.

    Инструкции

  2. В поле Установить целевую ячейку введите адрес или имя ячейки, в которой находится формула оптимизируемой модели.

  3. Чтобы максимизировать значение целевой ячейки путем изменения значений влияющих ячеек, установите переключатель в положение максимальному значению.

    Чтобы минимизировать значение целевой ячейки путем изменения значений влияющих ячеек, установите переключатель в положение минимальному значению.

    Чтобы установить значение в целевой ячейке равным некоторому числу путем изменения значений влияющих ячеек, установите переключатель в положение значению и введите в соответствующее поле требуемое число.

  4. В поле Изменяя ячейки введите имена или адреса изменяемых ячеек, разделяя их запятыми. Изменяемые ячейки должны быть прямо или косвенно связаны с целевой ячейкой. Допускается установка до 200 изменяемых ячеек.

    Чтобы автоматически найти все ячейки, влияющие на формулу модели, нажмите кнопку Предположить.

  5. В поле Ограничения введите все ограничения, накладываемые на поиск решения.

  6. Нажмите кнопку Выполнить.

  7. Чтобы сохранить найденное решение, установите переключатель в диалоговом окне Результаты поиска решения в положение Сохранить найденное решение.

    Чтобы восстановить исходные данные, установите переключатель в положение Восстановить исходные значения.

Советы

  • Чтобы прервать поиск решения, нажмите клавишу ESC. Microsoft Excel пересчитает лист с учетом найденных значений влияющих ячеек.

  • Дополнительные сведения об элементах управления диалогового окна Параметры поиска решения.

  • Дополнительные сведения об элементах управления диалогового окна Результаты поиска решения.

  • Чтобы получить более подробные сведения о методах поиска решения, нажмите кнопку [image] .


 Создание модели для поиска решения

Создание модели для поиска решения

Работа Поиска решений Процедура поиска решения позволяет найти оптимальное значение формулы, содержащейся в ячейке, которая называется целевой. Эта процедура работает с группой ячеек, прямо или косвенно связанных с формулой в целевой ячейке. Чтобы получить по формуле, содержащейся в целевой ячейке, заданный результат, процедура изменяет значения во влияющих ячейках. Чтобы сузить множество значений, используемых в модели, применяются ограничения. Эти ограничения могут ссылаться на другие влияющие ячейки.

Пример поиска решения В приведенном ниже примере объем продаж в каждом квартале зависит от уровня рекламы, что косвенно определяет сумму доходов, издержки (себестоимость товаров, реклама и накладные расходы), а также прибыль. Чтобы найти максимальную возможную сумму общего дохода, процедура поиска решения может повышать ежеквартальные расходы на рекламу (ячейки B5:E5), пока общие расходы не превысят ограничения в 40 миллионов (ячейка F5). Значения во влияющих ячейках служат для вычисления дохода за каждый квартал, поэтому они связаны с формулой в целевой ячейке F7, =СУММ(Q1 Прибыль:Q4 Прибыль).

Перед вычислениями поиска решения

После выполнения процедуры получены следующие значения:

После поиска решения


 Установка и загрузка надстройки «Поиск решения»

Установка и загрузка надстройки «Поиск решения»

  1. Выберите команду Надстройки в меню Сервис.

    Демонстрация

    Если в списке диалогового окна Надстройки отсутствует пункт Поиск решения, повторно запустите программу установки и убедитесь, что выбран параметр установки надстройки «Поиск решения».

  2. В диалоговом окне Надстройки установите флажок Поиск решения и нажмите кнопку OK.

    Если на экране появится сообщение с вопросом о том, следует ли установить соответствующее средство, нажмите кнопку Да.

Примечание. Надстройки, выбранные в диалоговом окне Надстройки, остаются активными до тех пор, пока не будут удалены. См. сведения о надстройках Microsoft Excel.


 Примеры расчетов с использованием процедуры поиска решения

Примеры расчетов с использованием процедуры поиска решения

В составе Microsoft Excel в папке Office\Samples находится книга с примерами (Solvsamp.xls) использования процедуры поиска решения (Solver.xls).

Примеры, содержащиеся в книге Solvsamp.xls, помогут разрешить ваши вопросы. Чтобы прменить любой из шести примеров — " Структура производства" , " Транспортная задача" , " График занятости" , " Управление капиталом" , " Портфель ценных бумаг" и " Проектирование цепи" — откройте книгу, перейдите к нужному листу и выберите Поиск решения в меню Сервис. В примерах уже подобраны целевая и влияющие ячейки, а также ограничения.


Загрузка модели оптимизации

Перед тем как использовать данную процедуру, необходимо сохранить хотя бы одну модель.

  1. В меню Сервис выберите команду Поиск решения.

  2. Нажмите кнопку Дополнительно.

  3. Нажмите кнопку Загрузить модель.

  4. Введите ссылку на весь диапазон ячеек с областью модели.

    Дополнительные сведения об элементах управления диалогового окна Загрузить модель.


Установка параметров поиска решения

Предполагаемые действия

Наложение ограничений на поиск решения

Изменение и удаление ограничения на поиск решения

Ограничение времени поиска решения и числа итераций

Изменение погрешности и сходимость результатов поиска решения

Изменение погрешности целых величин, полученных в результате поиска решения

Восстановление стандартных значений параметров поиска решений


Просмотр промежуточных результатов поиска решения

  1. Сформулируйте задачу.

    Инструкции

  2. В диалоговом окне Поиск решения нажмите кнопку Параметры.

  3. Чтобы получить возможность просмотра текущих значений влияющих ячеек каждой итерации, установите флажок Показывать результаты итераций, нажмите кнопку OK, а затем — кнопку Выполнить.

    На экране появится диалоговое окно Текущее состояние поиска решения, а влияющие ячейки листа изменят свои значения.

  4. Чтобы остановить поиск решения и вывести на экран диалоговое окно Результаты поиска решения, нажмите кнопку Стоп.

    Чтобы выполнить следующую итерацию и просмотреть ее результаты, нажмите кнопку Продолжить.


Создание отчета по результатам поиска решения

  1. Найдите решение задачи.

    Инструкции

  2. В списке Тип отчета укажите отчет, который следует создать. Чтобы создать несколько отчетов, укажите их названия, удерживая клавишу CTRL.

    Дополнительные сведения о возможных типах отчетов.


Сохранение значений влияющих ячеек в качестве сценария

  1. В диалоговом окне Результаты поиска решения выберите Сохранить сценарий.

  2. В поле Название сценария введите имя сценария.

Советы

  • Чтобы просмотреть различные сохраненные наборы значений влияющих ячеек, просмотрите все сценарии.

  • Чтобы создать сценарий, не сохраняя результат Поиска решения или не отображая результаты на листе, сохраните сценарий в диалоговом окне Результаты поиска решения, а затем выберите Восстановить исходные значения.


Сохранение модели оптимизации

  1. Сформулируйте задачу.

    Инструкции

  2. В меню Сервис выберите команду Поиск решения.

  3. Нажмите кнопку Дополнительно.

  4. Нажмите кнопку Сохранить модель.

  5. Введите ссылку на верхнюю ячейку столбца, в котором следует разместить модель оптимизации.

Советы

  • Значения элементов управления диалогового окна Поиск решения записываются на лист при выполнении команды Сохранить в меню Файл. Чтобы использовать на листе несколько моделей оптимизации, нужно сохранить их с помощью кнопки Сохранить модель.

  • Дополнительные сведения об элементах управления диалогового окна Сохранить модель.


Итоговые сообщения процедуры поиска решения

Если поиск решения успешно завершен, в диалоговом окне Результаты поиска решения выводится одно из следующих сообщений.

  • Решение найдено. Все ограничения и условия оптимальности выполнены.

    Все ограничения соблюдены с точностью, установленной в диалоговом окне Параметры поиска решения и найдено заданное значение целевой ячейки.

  • Поиск свелся к текущему решению. Все ограничения выполнены.

    Относительное изменение значения в целевой ячейке за последние пять итераций стало меньше установленного значения параметра Сходимость в диалоговом окне Параметры поиска решения. Чтобы найти более точное решение, установите меньшее значение параметра Сходимость, но это займет больше времени.

Если поиск не может найти оптимальное решение, в диалоговом окне Результаты поиска решения выводится одно из следующих сообщений.

  • Поиск не может улучшить текущее решение. Все ограничения выполнены.

    В процессе поиска решения нельзя найти такой набор значений влияющих ячеек, который был бы лучше текущего решения. Приблизительное решение найдено, но либо дальнейшее уточнение невозможно, либо погрешность, заданная в диалоговом окне Параметры поиска решения слишком высока. Измените погрешность на меньшее число и запустите процедуру поиска решения снова.

  • Поиск остановлен (истекло заданное на поиск время).

    Время, отпущенное на решение задачи, исчерпано, но достичь удовлетворительного решения не удалось. Чтобы при следующем запуске процедуры поиска решения не повторять выполненные вычисления, установите переключатель Сохранить найденное решение или Сохранить сценарий.

  • Поиск остановлен (достигнуто максимальное число итераций).

    Произведено разрешенное число итераций, но достичь удовлетворительного решения не удалось. Увеличение числа итераций может помочь, однако следует рассмотреть результаты, чтобы понять причины остановки. Чтобы при следующем запуске процедуры поиска решения не повторять выполненные вычисления, установите переключатель Сохранить найденное решение или нажмите кнопку Сохранить сценарий.

  • Значения целевой ячейки не сходятся.

    Значение целевой ячейки неограниченно увеличивается (или уменьшается), даже если все ограничения соблюдены. Возможно следует в задаче снять одно ограничение или сразу несколько. Изучите процесс расхождения решения, проверьте ограничения и запустите задачу снова.

  • Поиск не может найти подходящего решения.

    В процессе поиска решения нельзя сделать итерацию, которая удовлетворяла бы всем ограничениям при заданной точности. Вероятно, ограничения противоречивы. Исследуйте лист на предмет возможных ошибок в формулах ограничений или в выборе ограничений.

  • Поиск остановлен по требованию пользователя.

    Нажата кнопка Стоп в диалоговом окне Текущее состояние поиска решения после прерывания поиска решения в процессе выполнения итераций.

  • Условия для линейной модели не удовлетворяются.

    Установлен флажок Линейная модель, однако итоговый пересчет порождает такие значения, которые не согласуются с линейной моделью. Это означает, что решение недействительно для данных формул листа. Чтобы проверить линейность задачи, установите флажок Автоматическое масштабирование и повторно запустите задачу. Если это сообщение опять появится на экране, снимите флажок Линейная модель и снова запустите задачу.

  • При поиске решения обнаружено ошибочное значение в целевой ячейке или в ячейке ограничения.

    При пересчете значений ячеек обнаружена ошибка в одной формуле или в нескольких сразу. Найдите целевую ячейку или ячейку ограничения, порождающие ошибку, и измените их формулы так, чтобы они возвращали подходящее числовое значение.

    Набрано неверное имя или формула в окне Добавить ограничение или в окне Изменить ограничение, либо в поле Ограничение было задано целое или двоичное ограничение. Чтобы ограничить значения ячейки множеством целых чисел, выберите оператор целого ограничения в списке условных операторов. Чтобы установить двоичное ограничение, выберите оператор для двоичного ограничения.

  • Мало памяти для решения задачи.

    Система не смогла выделить память, необходимую для поиска решения. Закройте некоторые файлы или приложения, и попытайтесь снова выполнить процедуру поиска решения.

    Другой экземпляр Excel использует SOLVER.DLL.

    Запущено несколько копий Microsoft Excel, в одном из которых используется файл Solver.dll


Алгоритм и методы поиска решения

В процедуре поиска решения Microsoft Excel используется алгоритм нелинейной оптимизации Generalized Reduced Gradient (GRG2), разработанный Леоном Ласдоном (Leon Lasdon, University of Texas at Austin) и Аланом Уореном (Allan Waren, Cleveland State University).

Алгоритмы симплексного метода и метода " branch-and-bound" для решения линейных и целочисленных задач с ограничениями разработаны Джоном Уотсоном (John Watson) и Деном Филстра (Dan Fylstra) из Frontline Systems, Inc. Чтобы получить более подробные сведения об используемых алгоритмах оптимального поиска, обратитесь по адресу:

Frontline Systems, Inc.
P.O. Box 4288
Incline Village, NV 89450-4288
(702) 831-0300
Адрес в Интернете: http://www.frontsys.com
Электронная почта: info@frontsys.com

Авторские права на исполняемый код надстройки Microsoft Excel поиска решения версий 1990, 1991 и 1992 годов принадлежат Frontline Systems, Inc. Авторские права на версию 1989 года принадлежат Optimal Methods, Inc.


Разрешение вопросов, возникающих при анализе "что-если"

В чем именно заключаются сложности?

Лист содержит таблицу данных. Как ускорить вычисление?

Как преобразовать значения таблицы данных в постоянные значения?

Как очистить таблицу данных?

Как удалить всю таблицу данных?

Как ограничить доступ к моему сценарию?


Разрешение вопросов, возникающих при поиске решения

В чем именно заключаются сложности?

Оптимальное решение не найдено.

Значения влияющих ячеек и целевой ячейки или ячейки, на которую наложены ограничения, сильно различаются.

Предпосылки для запуска процедуры поиска решения с другими начальными условиями

Итоговые сообщения процедуры поиска решения


 Способы совместного использования книги несколькими пользователями

Способы совместного использования книги несколькими пользователями

Общая книга. Если требуется, чтобы с книгой одновременно могли работать несколько пользователей, можно сохранить книгу в качестве общей книги. После этого пользователи смогут вводить данные, вставлять строки и столбцы, добавлять и изменять формулы и изменять форматирование. См. Установка общей книги.

Если требуется объединить несколько копий книги, необходимо сделать книгу общей до рассылки ее рецензентам. См. сведения об ограничениях общих книг.

Распространение книги. Распространить книгу можно несколькими способами. Можно отправить книгу по маршруту, распространить ее на дискетах или отправить копии книги по электронной почте, либо сохранить книгу на сетевом диске. См. Отправка документов другим пользователям.

  • Отправка книги по маршруту. Для получения совокупного набора замечаний и комментариев, с обеспечением для каждого пользователя возможности просмотра комментариев и изменений, внесенных предыдущими рецензентами, следует отправить книгу по маршруту. См. Отправка книги по маршруту.

  • Отправка копий книги. Если требуется получить подборки комментариев отдельно от каждого пользователя, следует отправить каждому рецензенту отдельную копию книги. См. Подготовка копий книги для просмотра и слияния.

  • Сохранение книги в сети. Если требуется, чтобы общую книгу одновременно могли редактировать несколько пользователей, следует сохранить книгу на сетевом диске.

Просмотр книги. Если имеется несколько копий книги, можно объединить изменения, внесенные в эти копии, в одну книгу. Если имеется книга, в которую внесено множество изменений, можно просмотреть и включить изменения в книгу.

  • Объединение изменений. Если требуется объединить изменения, внесенные в несколько копий книги, следует объединить книги. См. Объединение изменений нескольких копий одной книги.

  • Просмотр и подтверждение изменений. При просмотре изменений, внесенных в книгу, можно принять или отклонить отдельные изменения и просмотреть журнал всех изменений в книге. См. сведения о просмотре и подтверждении изменений в книге.

Примечание. Общие книги нельзя сохранять в общих папках Microsoft Exchange.


Настройка общей книги

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Установка общей книги

Установка общей книги

  1. В меню Сервис выберите пункт Доступ к книге, а затем откройте вкладку Правка.

  2. Установите флажок Разрешить совместный доступ и нажмите кнопку OK.

  3. Если будет предложено, сохраните книгу.

  4. В меню Файл выберите Сохранить как и сохраните общую книгу в сети так, чтобы другие пользователи имели к ней доступ.

Примечания

  • При копировании общей книги на сетевой диск, убедитесь, что все связи с другими книгами или документами не повреждены. Для изменения определений связей в меню Правка выберите команду Связи.

  • Эта процедура также начинает ведение журнала изменений, позволяющего просматривать сведения об изменениях общей книги и противоречивых изменениях, принятых или отвергнутых. Для поддержки журнала изменений предусмотрена возможность копирования общей книги с последующим слиянием ее с измененной копией.

  • Для изменения общей книги созданной в Microsoft Excel 97 или более поздней версии необходимо использовать именно эту версию продукта, а не более ранние.

  • Все пользователи, имеющие доступ к сетевому каталогу, где сохранена общая книга, имеют такой же доступ к самой книге. Чтобы предотвратить определенные виды доступа к общей книге, необходимо защитить общую книгу и журнал изменений. Для получения более подробных сведений, щелкните [image] .


 Определение частоты обновления общей книги

Определение частоты обновления общей книги

Каждому пользователю общей книги предоставляется возможность самостоятельно определить, как часто получать изменения, внесенные остальными пользователями.

  1. Откройте общую книгу.

  2. В меню Сервис выберите Доступ к книге, а затем вкладку Подробнее.

  3. Чтобы видеть изменения, внесенные другими пользователями, каждый раз при сохранении общей книги, установите флажок при сохранении файла в группе Обновлять изменения.

    Чтобы периодически видеть изменения, внесенные другими пользователями, установите флажок каждые в группе Обновлять изменения и в поле мин. укажите, как часто требуется получать обновления и затем выберите параметр только просмотреть чужие изменения. Чтобы другие пользователи могли видеть ваши изменения, перед получением обновлений необходимо сохранять общую книгу, для этого установите флажок сохранить мои изменения и просмотреть чужие.

  4. Сохраните общую книгу.


 Установка личного вида и параметров печати для общей книги

Установка личного вида и параметров печати для общей книги

Каждому пользователю общей книги предоставляется возможность самостоятельно определить области просмотра и параметры печати.

  1. Откройте общую книгу.

  2. В меню Сервис выберите Доступ к книге, а затем ярлык Подробнее.

  3. Перед тем, как сохранить свои параметры печати, убедитесь, что установлен флажок параметры печати под Включить в личное представление. Установки печати включают: разрыв страницы, область печати, установки разметки страницы (в меню Вид команда Разметка страницы), а также установки в диалоговом окне Параметры страницы (в меню Файл).

    Чтобы сохранить изменения, внесенные c помощью команд из подменю Фильтр меню Данные, включая фильтры, заданные с помощью команд Автофильтр, убедитесь, что установлен флажок фильтры в группе Включить в личное представление.

  4. Сохраните общую книгу.

Примечание. Microsoft Excel автоматически сохраняет положение отображенного листа так же, как персональные установки параметров в диалоговом окне Масштаб в меню Вид, в поле Масштаб на панели инструментов Стандартная и на ярлыке Вид диалоговом меню Параметры в меню Сервис.


 Ограничения общей книги

Ограничения общей книги

При использовании общей книги недоступны некоторые возможности Microsoft Excel. Если эти возможности необходимы, используйте их до того, как книга станет общей, или отмените общий доступ к книге. Для получения дополнительных сведений, щелкните [image] .

При работе с общей книгой нельзя делать следующее:

Ячейки

  • Сливать ячейки. Но можно просматривать ячейки, которые были слиты до того, как книга стала общей.

  • Вставлять или удалять группы ячеек. Но можно вставлять или удалять целые столбцы и строки.

Листы, диалоговые окна и меню

  • Удалять листы.

  • Изменять диалоговые окна или меню.

Условные форматы и проверка данных

  • Определять или применять средства условного форматирования. Результат условного форматирования можно увидеть, если он был применен до того, как книга стала общей.

  • Устанавливать или изменять ограничения и сообщения при проверке данных. Результаты применения ограничений и сообщения можно увидеть, если они были установлены до того, как книга стала общей.

Объекты, диаграммы, рисунки и гиперссылки

  • Вставлять или изменять диаграммы, рисунки, объекты или гиперссылки.

  • Использовать инструменты рисования.

Пароли

  • Назначать пароли для защиты определенных листов или целой книги. Если защита была установлена до того, как книга стала общей, она будет действовать и после этого.

  • Изменять или снимать пароли. Если пароль был назначен до того, как книга стала общей, он будет действовать и после установления общего доступа к книге.

Сценарии

Сохранять, просматривать или изменять сценарии.

Структуры, группы и промежуточные итоги

  • Группировать или структурировать данные.

  • Вставлять промежуточные итоги автоматически

Таблицы данных и сводные таблицы

  • Создавать таблицы данных.

  • Создавать сводные таблицы или изменять макет существующих сводных таблиц.

Макросы

Создавать, изменять, просматривать, записывать или назначать макросы. Однако можно записывать действия в общей книге в макросе, сохраняемом в другой, не являющейся общей, книге. Предоставляется возможность выполнять макрос, созданный до того, как книга стала общей, однако если он содержит недопустимую операцию, он будет остановлен при достижении этой операции.


 Ограничение прав доступа к общей книге

Ограничение прав доступа к общей книге

  1. Если книга, которую вы хотите защитить является общей, и требуется установить пароль, чтобы ограничить доступ к ней самой или к ее страницам или к свойствам, удалите книгу из общего пользования.

    Инструкции

  2. Чтобы обязать пользователя вводить пароль при открытии книги, установите его.

    Инструкции

  3. Чтобы обязать пользователя вводить пароль для изменения и сохранения общей книги, установите его.

    Инструкции

  4. Чтобы другие скрыть определенные строки или столбцы в документе от пользователей, выделите их. Затем в меню Формат выберите по строкам или по столбцам и нажмите кнопку Скрыть.

    Чтобы позволить другим пользователям изменять только определенные места в общей книге, разблокируйте их, а затем защитите книгу. (Это также ограничит просмотр другими пользователями скрытых строк и колонок.)

    Инструкции

  5. Для того чтобы скрыть определенные страницы общей книги, в меню Формат выберите Лист и затем выберите команду Скрыть. Повторите это для всех листов, которые надо скрыть.

    После того, как все листы были скрыты, необходимо защитить книгу, чтобы другие пользователи не могли просматривать скрытые страницы, предварительно сняв ограничение на просмотр. В меню Сервис выберите команду Защита и затем Защитить книгу. Установите флажок структуру и нажмите кнопку OK.

  6. Для изменения числа дней, в течение которых Microsoft Excel будет хранить журнал изменений для общей книги (по умолчанию 30 дней), в меню Сервис выберите Доступ к книге и затем выберите вкладку Правка. Установите флажок Разрешить совместный доступ, а затем выберите вкладку Подробнее. В группе Регистрация изменений убедитесь, что выбран параметр хранить журнал изменений в течение и затем в поле Дни введите число дней, в течение которых будет храниться журнал изменений. Выберите ярлык Правка, снимите флажок Разрешить совместный доступ и щелкните OK.

  7. В меню Сервис выберите Защита, а затем Защита общей книги или Защитить книгу и дать общий доступ.

  8. Установите флажок Общий доступ с исправлениями.

  9. Чтобы обязать других пользователей вводить пароль для прекращения ведения журнала изменений или удаления книги из общего пользования, введите пароль в поле Пароль, а затем повторите его, когда будет предложено.

  10. Когда будет предложено, сохраните книгу, чтобы сделать ее общей и включить ведение журнала изменений.

Примечания

  • Если защищены параметры доступа, то пользователь не может удалить книгу из общего пользования или выключить ведение журнала изменений.

  • Если книга уже является общедоступной, то можно установить права доступа и изменить журнал изменений, но нельзя установить пароль на эти права. Чтобы установить пароль, необходимо удалить книгу из общего пользования.


 Удаление пользователя из общей книги

Удаление пользователя из общей книги

При закрытии пользователем общей книги работа с общей книгой завершается. Эта процедура может быть использована для удаления пользователя, который кажется подключенным к общей книге, но на самом деле больше с ней не работает, например из-за разрыва подключения.

Предупреждение. При удалении пользователя, работающего с общей книгой, все не сохраненные данные пользователя будут потеряны.

  1. В меню Сервис выберите пункт Доступ к книге, а затем откройте вкладку Правка.

  2. В поле Файл открыт следующими пользователями выберите имя пользователя, которого следует отсоединить, а затем щелкните Удалить.

Совет. Если пользователь больше не будет работать с общей книгой, можно уменьшить размер книги, удалив персональные параметры просмотра этого пользователя. В меню Вид выберите Представления. В поле Представления выберите представление пользователя и нажмите кнопку Удалить.


 Удаление книги из общего пользования

Удаление книги из общего пользования

Чтобы другие пользователи больше не вносили изменений в общую книгу, откройте и работайте с ней как единственный пользователь. При удалении книги из общего пользования завершается связь остальных пользователей, выключается ведение журнала изменений, и удаляется сохраненный журнал изменений, таким образом, просмотр журнала и объединений данной копии с другими копиями общей книги становится невозможным.

Предупреждение. Для исключения потери не сохраненных данных остальными пользователями предупредите их, чтобы они сохранили книгу и закрыли ее, до того как книга будет удалена из общего пользования.

  1. В меню Сервис выберите пункт Доступ к книге, а затем откройте вкладку Правка.

  2. Убедитесь, что вы единственный пользователь в списке Файл открыт следующими пользователями. В противном случае, остальные пользователи потеряют не сохраненные данные.

  3. Снимите флажок Разрешить совместный доступ и нажмите кнопку OK.

  4. Если появится сообщение о воздействии на других пользователей, выберите Да.


 Управление противоречащими изменениями в общей книге

Управление противоречащими изменениями в общей книге

В Microsoft Excel имеется ряд средств для разрешения конфликтных ситуаций, связанных с внесением в общую книгу противоречащих изменений (таких как ввод в одну и ту же ячейку различных значений и сохранение книги).

Выбор сохраняемых изменений. При сохранении общей книги можно просмотреть противоречащие изменения и решить, какие из них следует сохранить, либо автоматически сохранить собственные изменения и отклонить все изменения, противоречащие им. Данный параметр устанавливается независимо каждым пользователем общей книги. См. Разрешение вопросов при просмотре противоречащих изменений в общей книге.

Просмотр всех изменений. При просмотре противоречащих изменений можно просмотреть сведения о каждом изменении и сохранить или отклонить его.

Просмотр сведений, относящихся к прошлым сеансам работы. Если для общей книги ведется журнал изменений, то можно просмотреть сведения об изменениях, сохраненных, замещенных или отклоненных во время прошлых сеансов работы с книгой, включая сведения об авторе и введенных данных, которые были затем заменены. См. сведения о ведении для общей книги журнала изменений, включающего сведения о противоречащих изменениях. Также можно просмотреть эти изменения непосредственно на листе и принять или отклонить их.


Управление противоречивыми изменениями в общей книге

Предполагаемые действия

Противоречащие изменения

Разрешение вопросов: при просмотре противоречащих изменений в общей книги

Разрешение вопросов: сохранения или отказа от противоречащих изменениях при сохранении общей книги

Просмотр сведений о противоречивых изменениях общей книги

Журнал изменений и его просмотр

Ведение журнала изменений общей книги

Просмотр объединенных изменений

Дополнительные сведения


 Разрешение вопросов при просмотре противоречащих изменений в общей книге

Разрешение вопросов при просмотре противоречащих изменений в общей книге

Пользователям общей книги предоставляется возможность устанавливать личные параметры просмотра противоречивых изменений.

  1. Откройте общую книгу.

  2. В меню Сервис выберите команду Доступ к книге, а затем выберите вкладку Подробнее.

  3. Чтобы просматривать каждое противоречивое изменение и решать, сохранять ли его при сохранении книги, выберите запрашивать, чьи изменения имеют преимущество в группе Для противоречивых изменений.

    Чтобы автоматически заменять все противоречащие изменения вашими изменениями, выберите параметр ранее сохраненные имеют преимущество.

  4. Сохраните книгу.

    Примечание. Чтобы избежать появления диалогового окна Возник конфликт доступа при сохранении общей книги, выберите параметр ранее сохраненные имеют преимущество.


 Просмотр сведений о противоречивых изменениях общей книги

Просмотр сведений о противоречивых изменениях общей книги

При создании общей книги, включается ведение журнала изменений, что позволяет просматривать сведения о противоречивых изменениях. Если отключить ведение журнала изменений, то сведения о противоречивых изменениях не будут сохраняться. Для получения дополнительных сведений о включении ведения журнала изменений, нажмите кнопку [image] .

  1. В меню Сервис выберите пункт Исправления, а затем выполните команду Выделить исправления.

    Демонстрация

  2. Установите флажок по времени, а затем в поле по времени выберите значение Все.

  3. Убедитесь, что флажки пользователем и в диапазоне сняты.

  4. Установите флажок Вносить изменения на отдельный лист, а затем нажмите кнопку OK.

  5. Когда появится лист изменений, прокрутите его направо, если требуется просмотреть столбцы «Тип действия» и «Действие».

    В столбце «Тип действия» для сохраненных противоречащих изменений отображается "выигрыш" .

    В столбце «Действие» для строк, описывающих отмененные изменения, появятся номера строк.

Примечание. Флажок Вносить изменения на отдельный лист доступен только после сохранения общей книги.


 Сохранение или отказ от противоречащих изменений при сохранении общей книги

Сохранение или отказ от противоречащих изменений при сохранении общей книги

При сохранении общей книги в случае появления диалогового окна Возник конфликт доступа выполните следующее:

  1. Прочитайте сведения об изменениях, сделанных вами и противоречащих им изменениях, сделанных остальными.

  2. Для сохранения ваших изменений щелкните Сохранить мои.

    Для сохранения изменений, введенных другими пользователями, выберите параметр Сохранить чужие.

  3. Повторите шаги 1 и 2 для каждого изменения.

    Чтобы сохранить все оставшиеся ваши изменения, выберите параметр Сохранить все мои оставшиеся изменения.

    Чтобы сохранить все оставшиеся изменения других пользователей, выберите параметр Сохранить все чужие оставшиеся изменения.

Совет. Другой способ сохранить копию книги со всеми вашими изменениями: нажмите кнопку Отмена, затем в меню Файл выберите Сохранить как и введите новое имя файла.

Примечание. Чтобы Microsoft Excel не отображал диалоговое окно Возник конфликт доступа при сохранении общей книги, необходимо установить параметр для сохранения всех противоречивых изменений автоматически, не просматривая их. Для получения дополнительных сведений щелкните [image] .


 Подготовка копий книги для просмотра и слияния

Подготовка копий книги для просмотра и слияния

При слиянии нескольких копий общей книги, в которые были внесены изменения, требуется, чтобы каждая копия общей книги поддерживала журнал изменений с момента, когда копия была сделана до момента их слияния. Если количество определенных дней было превышено, то копии будет нельзя слить. Если точно не известно, сколько времени займет просмотр, установите поддержку журнала изменений на достаточное количество дней или введите большое число дней, например, 1000.

  1. В меню Сервис выберите пункт Доступ к книге, а затем откройте вкладку Правка.

  2. Установите флажок Разрешить совместный доступ.

  3. Выберите вкладку Подробнее.

  4. В группе Регистрация изменений установите флажок хранить журнал изменений в течение. В поле дн. задайте максимально возможное количество дней для просмотра общей книги.

  5. Нажмите кнопку OK и сохраните файл.

  6. Чтобы сделать копии книги для просмотра, в меню Файл выберите Сохранить как. Каждой копии дайте уникальное имя.

Примечание. Чтобы избежать отключения журнала изменений во время просмотра, можно потребовать, чтобы журнал изменений поддерживался до возврата копии. Чтобы получить дополнительные сведения, щелкните [image] .


 Объединение изменений нескольких копий одной книги

Объединение изменений нескольких копий одной книги

Если планируется объединение копий общей книги, то перед распределением копий среди рецензентов и внесением рецензентами изменений в копии необходимо включить ведение журнала изменений. Кроме того, объединение необходимо завершить в течение заданного периода ведения журнала изменений. Для получения сведений о подготовке копий общей книги для рецензирования и объединения, включая задание периода отслеживания изменений, нажмите кнопку [image] .

  1. Откройте копию общей книги, с которой требуется объединить изменения из другого файла книги на диске.

  2. В меню Сервис выберите команду Объединить книги.

  3. Если будет предложено, сохраните книгу.

  4. В диалоговом окне Выберите, какие файлы включить в книгу выберите копию общей книги, содержащую изменения, которые требуется объединить, а затем нажмите кнопку OK.

  5. Повторите шаги со 2-го по 4-й для всех объединяемых копий общей книги.

Примечание. Если ячейка содержит примечание, в него входит имя пользователя, вставившего это примечание. Если при слиянии общих книг ячейка содержит более одного примечания, то все они располагаются друг за другом в поле примечаний.

Совет. Если слияние нескольких копий книги требуется выполнить за один шаг, можно выбрать в диалоговом окне Выберите, какие файлы включить в книгу несколько книг, щелкая имена соответствующих файлов при нажатой клавише CTRL или SHIFT.


 О просмотре изменений книги

О просмотре изменений книги

Условия просмотра изменений. Просмотр журнала изменений книги возможен только в том случае, если перед внесением изменений был включен совместный доступ к книге и режим отслеживания изменений. Инструкции по настройке общего доступа к книге.

Просмотр журнала изменений. Существует несколько способов просмотра журнала изменений, внесенных в общую книгу.

  • Изменения, внесенные другими пользователями. Существует возможность просмотра сведения об изменениях, внесенных другими пользователями со времени последнего сохранения.

  • Изменения, отвечающие определенным условиям. Можно просматривать сведения на основе даты внесения изменений, имени пользователя, внесшего изменения, или измененного диапазона ячеек. Инструкции по просмотру изменений книги по определенной дате, имени пользователя или диапазону ячеек.

  • Все изменения книги. Можно просмотреть сведения обо всех внесенных в книгу изменениях, независимо от того, кем и когда они были внесены.

Просмотр изменений с выделением ячеек цветом или на отдельном листе. Изменения можно просматривать двумя способами. В первом случае изменения выделяются цветом, а подробности отображаются при удержании указателя на измененной ячейке. Во втором случае сведения об изменениях хранятся на отдельном листе изменений. При просмотре изменений на отдельном листе существует возможность отбора сведений несколькими способами. Например, можно отобрать изменения, внесенные разными пользователями в определенный день.

Лист изменений предпочтительнее выделения цветом в случаях, когда требуется просмотреть все когда-либо сделанные изменения листа, просмотреть большое число изменений, просмотреть сведения о разрешении конфликтов изменений или распечатать сведения об изменениях.


 Включение журнала изменений книги

Включение журнала изменений книги

В режиме ведения журнала изменений книги Microsoft Excel автоматически включает режим совместного доступа к книге. Некоторые команды и операции Microsoft Excel недоступны для книг с совместным доступом. Для получения дополнительных сведений нажмите кнопку [image] .

  1. Выберите в меню Сервис команду Доступ к книге, а затем перейдите на вкладку Правка.

  2. Установите флажок Разрешить совместный доступ.

  3. Перейдите на вкладку Подробнее.

  4. В группе Регистрация изменений установите флажок хранить журнал изменений в течение и укажите в поле дн. количество дней, в течение которых следует хранить журнал изменений.

    Укажите достаточное число дней, поскольку по истечении указанного числа дней Excel уничтожает журнал без возможности восстановления.

  5. Нажмите кнопку OK и при выводе запроса подтвердите сохранение файла, нажав кнопку OK.

Примечания

  • В журнале изменений содержатся сведения о согласовании противоречащих изменений, в том числе и данные отвергнутых изменений.

  • При каждом закрытии книги Microsoft Excel удаляет части журнала изменений, которые хранятся дольше указанного числа дней. Фактические изменения при этом сохраняются.

  • При установке режима ведения журнала изменений режим выделения внесенных изменений цветом не включается автоматически. Для получения сведений о выделении изменений нажмите кнопку [image] .


 Выделение исправлений при вводе

Выделение исправлений при вводе

При включении командой Исправления режима выделения цветом внесенных в книгу изменений автоматически устанавливается и режим совместного доступа к книге (если он еще не был установлен), а также режим ведения журнала изменений. Чтобы получить дополнительные сведения о настройке параметров журнала изменений, нажмите кнопку [image] .

Некоторые команды и функции Microsoft Excel не выполняются в общих книгах. Для получения дополнительных сведений по этому вопросу нажмите кнопку [image] .

  1. В меню Сервис выберите пункт Исправления, а затем выполните команду Выделить исправления.

    Демонстрация

  2. Флажок Отслеживать исправления (книга становится общей) должен быть установлен. При этом включаются режимы ведения журнала изменений и совместного доступа.

  3. Установите флажок по времени, выберите пункт Еще не просмотрено в поле по времени, а затем нажмите кнопку OK.

  4. В случае появления запроса подтвердите сохранение книги.

  5. Внесите необходимые исправления в лист книги Microsoft Excel. Исправленные, удаленные или вставленные ячейки будут выделяться цветом.

Примечание. Некоторые изменения, например, форматирование, не выделяются в режиме выделения изменений. Чтобы получить дополнительные сведения о выделяемых и не выделяемых исправлениях, нажмите кнопку [image] .


 Отображение и скрытие выделенных исправлений и дополнительных данных

Отображение и скрытие выделенных исправлений и дополнительных данных

При включении командой Исправления режима выделения цветом внесенных в книгу изменений автоматически устанавливается и режим совместного доступа к книге (если он еще не был установлен), а также режим ведения журнала изменений. Чтобы получить дополнительные сведения о настройке параметров журнала изменений, нажмите кнопку [image] .

Некоторые команды и функции Microsoft Excel не выполняются в общих книгах. Для получения дополнительных сведений по этому вопросу нажмите кнопку [image] .

  1. В меню Сервис выберите пункт Исправления, а затем выполните команду Выделить исправления.

    Демонстрация

  2. Чтобы отменить выделение исправлений, снимите флажок Выделять исправления на экране.

    Чтобы выделить исправления, убедитесь, что установлен флажок Отслеживать исправления (книга становится общей), установите флажок Выделять исправления на экране, а затем нажмите кнопку OK.

  3. В случае появления запроса подтвердите сохранение книги.

Примечания

  • Чтобы в режиме выделения изменений просмотреть дополнительные сведения о внесенных исправлениях, поместите указатель мыши на выделенную ячейку. Откроется поле комментария с соответствующими данными.

  • Если пользователь добавил к исправленной ячейке собственные примечания, при помещении указателя на эту ячейку после сведений об исправлениях появляется примечание пользователя.

  • Выделение исправлений сохраняется при печати листов книги.


 Просмотр изменений книги

Просмотр изменений книги

Журнал изменений книги может быть просмотрен только в том случае, когда книга была объявлена общей книгой перед внесением в нее изменений.

Предполагаемые действия

Просмотр изменений, внесенных в книгу другими пользователями

Просмотр изменений, относящихся к определенной дате, пользователю или диапазону ячеек

Просмотр всех внесенных в книгу изменений

Не можете сделать выбор?


 Просмотр объединенных изменений

Просмотр объединенных изменений

  1. В меню Сервис выберите пункт Исправления, а затем выполните команду Принять/отклонить исправления.

  2. В случае появления запроса о сохранении книги нажмите кнопку OK.

  3. Выберите исправления, которые необходимо просмотреть.

    Чтобы просмотреть изменения, внесенные определенным пользователем, установите флажок пользователем, а затем выберите имя пользователя в поле пользователем.

    Чтобы просмотреть изменения, внесенные всеми пользователями, снимите флажок пользователем.

    Чтобы просмотреть исправления определенной области листа, установите флажок в диапазоне, а затем укажите нужную область.

    Чтобы просмотреть исправления во всей книге, снимите флажок в диапазоне.

  4. Нажмите кнопку OK и ознакомьтесь с данными первого исправления в диалоговом окне Просмотр исправлений. Среди этих данных имеются также сведения о связанных исправлениях, состояние которых зависит от того, какой вариант рассматриваемого исправления будет принят. Возможно, для просмотра дополнительных сведений потребуется прокрутить текст с помощью стрелок прокрутки.

  5. Чтобы подтвердить изменение и отменить его выделение, нажмите кнопку Принять.

    Чтобы отменить внесенное изменение, нажмите кнопку Отказаться.

    Если откроется запрос, предлагающий указать значение ячейки, выберите нужное значение, а затем нажмите кнопку Принять.

  6. Повторите этапы 4 и 5 для каждого исправления или нажмите кнопку Принять все или Отказ от всех чтобы подтвердить или отменить оставшиеся изменения. Прежде, чем перейти к следующему изменению, необходимо подтвердить или отменить рассматриваемое изменение.

Примечание. Данные отмененных изменений, в том числе и удаленные данные, все еще можно просмотреть. На листе изменений отмененные исправления помечены как "Отменить" или "Результат отмены действия" в столбце "Тип действия". Для получения дополнительных сведений о списке исправлений нажмите кнопку [image] .


 Отмена режима ведения журнала изменений

Отмена режима ведения журнала изменений

Если общая книга защищена паролем, то при удалении защиты (меню Сервис, команда Защита, команда Снять защиту книги) ведение журнала изменений также прекращается. Для получения сведений о снятии защиты книги нажмите кнопку [image] .

При снятии защиты с общей книги все внесенные в книгу изменения сохраняются, а журнал изменений книги удаляется при следующем сохранении книги. При этом отменяются также режим выделения изменений цветом и лист изменений.

  1. В меню Сервис выберите Доступ к книге, а затем вкладку Подробнее.

  2. Установите флажок не хранить журнал изменений и нажмите кнопку OK.

Примечание. Журнал изменений общей книги удаляется при следующем же его сохранении. Однако если снова включить режим записи изменений, последние изменения, сохраненные в книге перед отключением режима ведения журнала, будут занесены в новый журнал изменений.


 Установка для книги режима записи исправлений

Установка для книги режима записи исправлений

Если при установке режима совместного доступа книга была защищена от исправлений паролем, то внести в книгу незарегистрированные изменения можно, только отменив режим совместного доступа. Для этого необходимо ввести пароль. Для книги можно установить количество дней, в течение которых сохраняются данные журнала изменений. Чтобы уменьшить это число или отменить режим записи изменений, также необходимо ввести пароль. По умолчанию данные журнала изменений хранятся в Microsoft Excel на протяжении 30 дней или в течение времени, указанного при последней установке режима совместного использования.

  1. Перед установкой защиты для книги убедитесь, что режим совместного доступа отключен.

    Если книга не является общей, выберите команду Управление доступом к файлу в меню Сервис, а затем откройте вкладку Правка. Убедитесь, что флажок Разрешить совместный доступ установлен, и выберите вкладку Подробнее. В группе Регистрация изменений убедитесь, что установлен флажок Хранить журнал изменений в течение, а затем укажите в поле Дни количество дней, в течение которых должны храниться сведения журнала изменений. Выберите вкладку Правка, снимите флажок Управление доступом к файлу и нажмите кнопку OK.

    Если книга является общей, выберите команду Доступ к книге в меню Сервис и перейдите на вкладку Подробнее. В группе Регистрация изменений убедитесь, что флажок Хранить журнал изменений в течение установлен, и в группе Дни введите число дней, в течении которых нужно хранить изменения. Если нужно ввести пароль на шаге 4, то откройте вкладку Правка, сбросьте флажок Разрешить совместный доступ и нажмите кнопку OK.

  2. В меню Сервис выберите команду Защита и затем — команду Защитить книгу и дать общий доступ.

    Демонстрация

  3. Установите флажок Общий доступ с исправлениями.

  4. Чтобы защитить режимы совместного доступа и записи изменений паролем (для отмены этих режимов или изменения параметров необходимо будет указать пароль), введите пароль в поле Пароль, а затем введите его повторно в открывшемся диалоговом окне. Пароль нельзя установить для общей книги.

  5. В случае появления запроса подтвердите сохранение книги.

Примечание. Чтобы отменить режим записи исправлений, выберите команду Защита в меню Сервис, а затем выберите команду Снять защиту общей книги. В случае появления запроса введите пароль. При отмене пароля защиты режима совместного доступа к книге отменяется и сам режим совместного доступа.


Добавление примечаний и выделение изменений в книге

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Добавление примечания к ячейке

  1. Выберите ячейку, к которой следует добавить примечание.

  2. Выберите команду Примечание в меню Вставка.

  3. Введите текст примечания в соответствующее поле.

  4. После окончания ввода текста нажмите кнопку мыши вне области примечания.

Примечания

  • При сортировке элементов на листе примечания перемещаются на новое место вместе с сортируемыми элементами.

  • Примечания в сводной таблице остаются привязанными к самим ячейкам, к которым они были добавлены, а не к их содержанию. При внесении изменений в сводную таблицу примечания не перемещаются.


 Изменение внешнего вида или расположения примечаний

Изменение внешнего вида или расположения примечаний

  1. Щелкните правой кнопкой мыши ячейку с примечанием, которое нужно изменить, а затем выберите команду Отобразить примечание в контекстном меню.

  2. Щелкните границу области примечания, чтобы появились маркеры выделения.

  3. Чтобы изменить шрифт или цвет текста примечания, выберите команду Примечание в меню Формат.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

    Для изменения фонового цвета комментариев выделите маркер заполнения, чтобы граница комментариев изменилась на точки, а потом нажмите стрелку поля Цвета Заливки [image] на панели инструментов Формат, далее выберите необходимый цвет.

    Чтобы изменить размер примечания, перетащите с помощью мыши маркеры выделения на углах или сторонах области примечания.

    Чтобы переместить примечание, перетащите с помощью мыши границу области примечания.

Примечание. Чтобы изменить стандартный цвет фона для новых примечаний, установите цвет всплывающей подсказки, щелкнув значок «Экран» на панели управления Windows. После изменения этой установки цвет фона ранее созданных примечаний не изменится.

Совет. Для изменения внешнего вида примечаний также служит панель инструментов Рисование. Для получения дополнительных сведений об средствах рисования в Microsoft Excel нажмите кнопку [image] .


Изменение примечания

  1. Выберите ячейку, примечание к которой нужно изменить.

  2. Выберите команду Изменить примечание в меню Вставка.


 Отображение или скрытие примечаний и их индикаторов

Отображение или скрытие примечаний и их индикаторов

  1. В меню Сервис выберите команду Параметры, а затем перейдите к вкладке Вид.

  2. Чтобы примечания были скрыты, даже если указатель расположен на содержащих их ячейках, а также чтобы снять индикаторы примечаний в верхних углах ячеек, установите переключатель Не отображать в группе Примечания.

    Для отображения примечаний при расположении указателя на содержащих их ячейках, а также для отображения индикаторов примечаний установите переключатель Только индикатор.

    Для отображения и примечаний, и индикаторов, независимо от расположения указателя мыши, установите переключатель Примечание и индикатор.

Совет. Чтобы скрыть отдельное примечание, щелкните правой кнопкой мыши содержащую его ячейку и выберите команду Скрыть примечание. Чтобы вывести на экран все скрытые примечания, выберите команду Примечания в меню Вид.


 Просмотр примечаний в книге

Просмотр примечаний в книге

  1. В меню Вид выберите команду Примечания.

    Демонстрация

  2. Для просмотра примечаний в прямой последовательности нажимайте кнопку Следующее примечание [image] на панели инструментов Рецензирование.

    Для просмотра примечаний в обратной последовательности нажимайте кнопку Предыдущее примечание [image] .

Примечание. При просмотре примечания выдаются в последовательности, начиная с выбранной ячейки. Для просмотра отдельного примечания установите указатель на содержащую его ячейку.


 Защита в Microsoft Excel

Защита в Microsoft Excel

Microsoft Excel обладает следующими возможностями защиты:

  • Ограничение доступа к отдельным листам. Чтобы получить список всех элементов листа, которые могут быть защищены, нажмите кнопку [image] .

  • Ограничение возможности изменений для всей книги. Чтобы получить список всех элементов книги, которые могут быть защищены, нажмите кнопку [image] .

  • Ограничение совместного доступа к книге и ограничение доступа к списку изменений. Чтобы получить более подробные сведения, нажмите кнопку [image] .

  • Ограничение доступа к книге с помощью пароля, запрашиваемого при открытии и сохранении книги, либо установка при открытии книги посторонними режима только для чтения. Чтобы получить более подробные сведения, нажмите кнопку [image] .

  • Проверка на макросы, которые могут быть заражены вирусами, при открытии книги. Чтобы получить более подробные сведения, нажмите кнопку [image] .

  • Возможность автоматического отключения неподписанных макросов, которые могут быть заражены вирусами. Чтобы получить более подробные сведения, нажмите кнопку [image] .


 Защита книг и листов от изменений

Защита книг и листов от изменений

Предполагаемые действия

Ограничение доступа

Ограничение просмотра и изменения отдельного листа

Ограничение изменений во всей книге

Ограничение доступа к общей книге и изменений в ней

Защита ячеек

Скрытие книги

Рекомендация доступа только на чтение

Рекомендация открыть книгу в режиме доступа только на чтение

Запрос паролей

Запрос паролей на открытие или использование книги

Запрос паролей на изменение и сохранение книги

Защита

Защита от макровирусов

Не можете сделать выбор?

Примечание. Задать дополнительные ограничения на просмотр и изменение данных в книгах можно с помощью макросов, написанных на языке Visual Basic для приложений. Более подробные сведения содержатся в оперативной справке по редактору Visual Basic.


 Снятие защиты с книг и листов

Снятие защиты с книг и листов

Защиту можно снять с отдельных листов, со всей книги или с общей книги.

Если вы сомневаетесь, нужно ли снимать защиту с книги или листа для получения необходимого доступа, выберите Защита в меню Сервис. Если текущий лист защищен, в меню Защита появится команда Снять защиту листа. Если защищена книга, там будет команда Снять защиту книги. Слово [Общая] в заголовке окна показывает, что текущая книга является общей.

Предполагаемые действия

Снятие защиты с отдельных листов

Снятие защиты со всей книги

Удаление защиты с общей книги

Снятие пароля с книги


 Изменение или отключение пароля для книги

Изменение или отключение пароля для книги

Для открытия и получения доступа к данным в книге, защищенной паролем, необходимо знать этот пароль. После изменения пароля запишите его и храните в надежном месте. При утере пароля открытие и использование данных книги будет невозможным.

  1. Откройте книгу.

  2. Выберите команду Сохранить как в меню Файл.

    Демонстрация

  3. В меню Сервис выберите команду Параметры.

  4. Дважды щелкните поле Пароль для открытия файла или Пароль разрешения записи.

  5. Для изменения пароля введите новый пароль и нажмите кнопку OK.

    При вводе пароля следует различать строчные и прописные буквы. Вводите пароль в точности так, как он должен будет вводиться пользователями, учитывая регистр букв.

    Чтобы удалить пароль, нажмите клавишу DELETE, затем кнопку OK.

  6. Если пароль был изменен, введите пароль еще раз и нажмите кнопку OK.

  7. Нажмите кнопку Сохранить.

  8. При появлении диалогового окна нажмите кнопку Да, чтобы заменить существующую книгу текущей.


Разрешение вопросов, связанных с общими книгами

В чем именно заключаются сложности?

Недоступность команд, связей или функций

Необходимые команды недоступны.

Связи в общей книге не работают.

Попытка защитить общую книгу ни к чему не приводит, так как команда Защитить книгу недоступна.

При попытке защиты совместного доступа нельзя ввести пароль в поле Пароль.

Восстановление данных, открытие книг только для чтения, сохранение

Общая книга открывается только для чтения.

Другой пользователь заменил данные или изменения, которые необходимо было сохранить.

При попытке сохранения общей книги выдается сообщение об отсутствии связи.


Разрешение вопросов, связанных со слиянием книг

В чем именно заключаются сложности?

Книги, которые необходимо объединить, не удается слить.

После слияния книг не появляются ожидаемые изменения.


Разрешение вопросов, связанных с выделением изменений и с листом изменений

В чем именно заключаются сложности?

Отображение изменений

Отображаются только самые последние изменения.

Ожидаемые изменения не отображаются.

Команда Принять/отклонить исправления недоступна.

Флажок Вносить изменения на отдельный лист недоступен.

Лист изменений

Лист изменений не отображается.

В листе изменений не отображены все изменения.

Невозможно отформатировать или отредактировать лист изменений.

Во время сохранения книги лист изменений изчезает.


Разрешение вопросов, связанных с ведением журнала изменений

В чем именно заключаются сложности?

После прекращения совместного использования книги, а затем после его возобновления, не удается просмотреть журнал изменений.

Ведение журнала изменений включено, но изменения не отображаются.

При запрещении совместного использования не удается указать число дней, в течение которых необходимо вести журнал изменений.

Требуется сохранить ведение журнала изменений без разрешения совместного использования книги.


Разрешение вопросов: защита

В чем именно заключаются сложности?

Защита паролем

Уровни защиты и шифрование

Предотвращение запуска макровирусов

Настройка надежных источников

Защита паролем

Книга Microsoft Excel не открывается после ввода пароля

Пароль, которым защищена книга, неизвестен

Возврат в начало

Уровни защиты и шифрование

Не удается изменить уровень защиты в Excel

Не удается открыть книгу, поскольку недоступна использованная при ее защите схема шифрования

Возврат в начало

Предотвращение запуска макровирусов

Не работают макросы в открываемой книге или надстройке

Не отображаются макросы в книге или надстройке Excel 2000, открытой в Excel 97

Не выдается предупреждение при открытии книги с макросами

Продолжают выдаваться предупреждения о макросах

Предупреждение системы безопасности о неподтвержденной подлинности источника

Не удается отключить макрос

Возврат в начало

Настройка надежных источников

Не удается добавить разработчика макросов в список надежных источников

После подтверждения надежности удостоверения в диалоговом окне Свойства удостоверения дополнение списка надежных источников не происходит

Возврат в начало


Разрешение вопросов при создании примечаний

В чем именно заключаются сложности?

Удаление имени пользователя из примечания

Примечание отображается не полностью


 Защита книг от вирусов

Защита книг от вирусов

Этот раздел содержит ссылки на:

Общие сведения о макровирусах

Выявление вирусов в Excel

Цифровые подписи

Общие сведения о макровирусах

Макровирус — это тип компьютерного вируса, который хранится в макросе в книге или программе надстройки. Вирусы — это программы, написанные, как правило, с целью разрушить или повредить данные. При открытии зараженной книги или выполнении действия, инициирующего макровирус, вирус может стать активным, быть передан на компьютер, сохранен в Personal.xls, скрытой книге или другом неопознанном месте. После этого каждая сохраняемая книга может быть автоматически «заражена» вирусом. Точно так же открытие зараженных книг другими пользователями может привести к передаче вируса на их компьютеры. Макросы Microsoft Excel версии 4.0 и вирусы.

Возврат в начало

Выявление вирусов в Excel

Microsoft Excel предлагает три уровня безопасности для уменьшения опасности заражения макровирусами, однако они не дают возможность просмотреть дискеты, жесткие диски и сетевые устройства для поиска и удаления этих вирусов. Для обеспечения этого типа защиты необходимо приобрести и установить специальное антивирусное программное обеспечение. Защита организована на следующих уровнях:

  • Высокий Могут быть запущены только макросы, снабженные цифровой подписью и полученные из надежного источника. Перед объявлением источника надежным подтвердите, что источник несет ответственность за свои действия и использует сканер вирусов до включения цифровой подписи в макрос. Неподписанные макросы автоматически отключаются и книга открывается автоматически.

  • Средний Excel выводит предупреждение о макросе, полученном из источника, не включенного в список надежных источников. При открытии книги можно включить или отключить макросы. Если книга может содержать вирусы, следует отключить макросы.

  • Низкий Если все открываемые книги и программы надстроек гарантированно безопасны, можно выбрать уровень безопасности, выключающий защиту от макровирусов. На этом уровне при открытии книг макросы всегда включаются.

Использование надежных источников Если уровень безопасности установлен высокий или средний, можно поддерживать список надежных источников макросов. Когда открывается книга или загружается надстройка, разработанные одним их этих источников, макросы разрешаются автоматически. Уровни безопасности в Excel.

Использование установленных ранее программ надстроек При открытии программы надстройки, установленной до установки Excel 2000, макросы внутри этого файла разрешаются автоматически.

Дополнительные сведения

Изменение уровня безопасности для защиты от макровирусов

Добавление разработчика макросов в список надежных источников

Удаление разработчика макросов из списка надежных источников

Возврат в начало

Цифровые подписи

Назначение цифровой подписи Если на компьютере установлен Microsoft Internet Explorer версии 4.0 или более поздней, одним из способов определения безопасности использования макросов является цифровая подпись. Цифровая подпись на макросе похожа на печать на конверте — подтверждает, что макрос создан тем, кто его подписал, и после этого не изменялся.

Назначение сертификата Когда открывается книга или загружается программа надстройки, содержащие цифровую подпись, цифровая подпись появляется в компьютере в виде сертификата. Сертификат содержит имя источника макросов и дополнительную информацию о подлинности источника. Цифровая подпись не гарантирует безопасность макросов, поэтому необходимо решить следует ли доверять макросу с цифровой подписью. Например, можно довериться макросу, написанному известной персоной или солидной компанией. Если нет уверенности в книге или надстройке, содержащих макросы с цифровой подписью, следует тщательно изучить сертификат перед разрешением макросов или — для безопасности — запретить макросы. Если всегда можно доверять макросам, полученным из определенного источника, разработчик макросов при открытии книги или загрузке надстройки может быть включен в список надежных источников.

Разработчики могут снабдить макросы цифровой подписью в редакторе Visual Basic.

Дополнительные сведения

Разрешение вопросов безопасности книги

Возврат в начало


 О макровирусах

О макровирусах

Общие сведения о макровирусах

Какую кнопку следует нажать?

Дополнительные сведения

Общие сведения о макровирусах

Макровирус — это тип компьютерного вируса, который хранится в макросе в книге или программе надстройки. Вирусы — это программы, написанные, как правило, с целью разрушить или повредить данные. При открытии зараженной книги или выполнении действия, инициирующего макровирус, вирус может стать активным, быть передан на компьютер, сохранен в скрытой книге Personal.xls или другом неопределимом месте. После этого каждая сохраняемая книга может быть автоматически «заражена» вирусом. Точно так же открытие зараженных книг другими пользователями может привести к передаче вируса на их компьютеры.

Microsoft Excel не проверяет гибкие, жесткие или сетевые диски с целью найти и уничтожить макровирусы. При необходимости в защите такого рода необходимо приобрести и установить антивирусное программное обеспечение. Однако Excel может выводить предупреждающее сообщение при открытии книги, содержащей макросы. После этого можно либо открыть книгу, разрешив выполнение макросов, либо отключить макросы, что позволит только проверить и отредактировать их. Макровирус опасен только в активном состоянии, поэтому отключение макросов делает открытие книги безопасным.

Возврат в начало

Какую кнопку следует нажать?

  • Если предполагается, что книга содержит полезные макросы (например, используемая в организации форма заказа), можно нажать кнопку Включить макросы, чтобы открыть книгу со включенными макросами.

  • Если наличие макросов в книге не предполагается, либо если надежность ее источника вызывает сомнения, можно нажать кнопку Отключить макросы, чтобы открыть книгу с отключенными макросами. Например, книга может быть получена как вложение в сообщение электронной почты из незнакомого источника либо с незащищенного узла сети или Интернета. В этих случаях рекомендуется связаться с создателем книги, чтобы удостовериться в отсутствии вирусов в книге.

    Отключение макросов делает невозможным выполнение любых макросов, пересчет пользовательских функций или использование элементов ActiveX для инициирования событий. Сохраняется возможность проверки и редактирования макросов при помощи редактора Visual Basic. При выборе команды Сохранить в меню Файл макросы сохраняются. Затем можно закрыть книгу и открыть ее вновь со включенными макросами, если требуется их выполнение.

Возврат в начало

Дополнительные сведения

Защита книг от вирусов

Изменение уровня безопасности для защиты от макровирусов

Сведения о защите от вирусов на Web-узле корпорации Майкрософт

Возврат в начало


 Уровни защиты в Excel

Уровни защиты в Excel

Далее описано действие антивирусной защиты при различных условиях и уровнях безопасности (высокий и средний), которые устанавливаются на вкладке Уровень безопасности (меню Сервис, подменю Макрос, команда Безопасность). Если установлен низкий уровень безопасности, то проверка подписей макросов не выполняется, пользователь не получает соответствующих сообщений, и разрешается выполнение всех макросов. При любой уровне безопасности, если на компьютере установлено антивирусное программное обеспечение, совместимое с Microsoft Office 2000, перед открытием книги, содержащей макросы, выполняется их проверка на предмет зараженности известными вирусами.

Неподписанные макросы

  • Высокий уровень. Выполнение макросов запрещается, затем книга открывается.

  • Средний уровень. Пользователю предлагается выбор — либо разрешить, либо запретить выполнение макросов.

Подписанные макросы из надежного источника: подпись верна.

  • Высокий и средний уровни. Выполнение макросов разрешается, затем книга открывается.

Подписанные макросы неизвестного автора: подпись верна.

  • Высокий уровень. Появляется диалоговое окно со сведениями о сертификате. Если пользователь укажет, что он доверяет автору макросов и поставщику сертификата, то выполнение этих макросов будет разрешено. Администратор сети может заблокировать список надежных источников, чтобы запретить пользователям добавлять в этот список новых авторов; в этом случае выполнение макросов этих авторов запрещается.

  • Средний уровень. Появляется диалоговое окно со сведениями о сертификате. Пользователю предлагается выбор: запретить или разрешить выполнение макросов; доверять, либо не доверять автору макросов и поставщику сертификата.

Подписанные макросы вне зависимости от их авторства: подпись неверна, вероятны вирусы.

  • Высокий и средний уровни. Пользователь получает предупреждающее сообщение о том, что макросы, вероятно, заражены вирусами. Выполнение этих макросов запрещается.

Подписанные макросы вне зависимости от их авторства: проверка подписи невозможна из-за отсутствия общедоступного ключа, либо из-за несовместимого метода шифрования.

  • Высокий уровень. Пользователь предупреждается о невозможности проверки подписи, выполнение макросов автоматически запрещается.

  • Средний уровень. Пользователь предупреждается о невозможности проверки подписи. Ему предлагается выбор: запретить или разрешить выполнение макросов.

Подписанные макросы вне зависимости от их авторства: подпись сделана после истечения срока действия сертификата, либо после отзыва сертификата.

  • Высокий уровень. Пользователь предупреждается об истечении срока действия сертификата. Выполнение макросов автоматически запрещается.

  • Средний уровень. Пользователь предупреждается о об истечении срока действия сертификата. Предлагается выбор: запретить или разрешить выполнение макросов.


Изменение уровня безопасности для защиты от макровирусов

  1. В меню Сервис выберите пункт Макрос и затем — команду Безопасность.

  2. Выберите необходимый уровень безопасности на вкладке Уровень безопасности.

    См. сведения об уровнях безопасности.

Примечание. Можно отключать только макросы, написанные на Visual Basic для приложений. Макросы, записанные в Microsoft Excel версия 4.0, не чувствительны к различным уровням безопасности.

Разработчик макросов может получить информацию о совместном использовании уровней безопасности и цифровых подписей.


 Проверка книг на макровирусы

Проверка книг на макровирусы

Для предотвращения заражения компьютера вирусом, содержащимся в макросе, используйте следующую процедуру для вывода предупреждения при каждой попытке открыть книгу, содержащую макросы. Так как сообщение появляется независимо от наличия вируса в макросе, прежде чем начать работу необходимо убедиться в надежности источника, из которого получена книга. Например, заражение книги вирусом возможно в незащищенной сети или на сервере Интернета.

  1. В меню Сервис выберите команду Макрос и затем — Безопасность.

  2. Выберите вкладку Уровень безопасности.

  3. Установите переключатель в положение Средняя.


Предупреждение о наличии макросов в ранее установленных шаблонах и программах надстроек

  1. В меню Сервис выберите пункт Макрос и выберите команду Безопасность.

  2. Перейдите на вкладку Надежные источники.

  3. Снимите флажок Доверять всем установленным надстройкам и шаблонам.

Примечание. Microsoft Excel не рассматривает шаблоны Excel в качестве надежных источников. При открытии шаблона, поставляемого с Excel, предупреждение о макровирусе выводится даже в том случае, если флажок Доверять всем установленным надстройкам и шаблонам установлен, а на вкладке Уровень безопасности выбран параметр Высокая или Средняя.

Для предотвращения вывода предупреждения о вирусах можно установить низкий уровень безопасности, но сначала следует убедиться в том, что все книги, которые потенциально могут быть открыты, безопасны и не содержат вирусов.


 Отмена проверки книг на макровирусы

Отмена проверки книг на макровирусы

  1. В меню Сервис выберите пункт Макрос и выберите команду Безопасность.

  2. Выберите вкладку Уровень безопасности.

  3. Установите переключатель в положение Низкая.


 Цифровые подписи

Цифровые подписи

В Microsoft Office 2000 используется технология Microsoft Authenticode, дающая разработчикам возможность пописывать проекты макросов с использованием цифрового сертификата. Microsoft Excel имеет уровни безопасности, позволяющие пользователям запускать макросы исходя из того, входит или нет разработчик, которым пописан макрос, в список надежных источников. Excel также проверяет допустимость цифровой подписи, что позволяет выяснить, не был ли проект макроса изменен, был ли проект макроса подписан до истечения срока действия или отзыва цифрового сертификата, а также установить, принадлежит ли цифровой сертификат допустимой службе сертификации.

Подпись проектов макросов

После установки цифрового сертификата появляется возможность подписывать проекты макросов. Это следует делать только после соответствующего тестирования при готовности проекта к распространению, поскольку при любом изменении кода в подписанном проекте макроса его цифровая подпись удаляется. Тем не менее, если на компьютере имеется надлежащий цифровой сертификат, проект макроса будет снова автоматически подписан при его сохранении.

Если требуется предотвратить случайное изменение пользователями проекта макроса и нарушение цифровой подписи, то перед тем как подписать проект макроса, следует заблокировать его. Цифровая подпись говорит лишь о том, что гарантируется безопасность проекта — она не является подтверждением того, что проект создан именно подписавшим его лицом, — поэтому блокировка проекта макроса не позволяет избежать замены цифровой подписи другой подписью. Администраторы сети организации могут заново подписывать шаблоны и надстройки, с тем чтобы контролировать, какие макросы запускаются пользователями на компьютерах.

При создании надстройки, добавляющей код в проект макроса, следует предусмотреть возможность проверки цифровой подписи проекта и предупреждения пользователя о последствиях изменения подписанного проекта. При изменении книги, содержащей подписанный проект, цифровая подпись не нарушается, поскольку подписывается проект макроса, а не книга.

Примечание. Цифровые подписи применимы только на компьютерах, на которых установлен Microsoft Internet Explorer версии 4.0 или более поздней. При открытии книги, содержащей макросы (подписанные или нет), на компьютере, где отсутствует Internet Explorer версии 4.0 или выше, отображается стандартное диалоговое окно защиты от макровирусов, позволяющее включить или отключить макросы перед открытием книги.

Дополнительные сведения

Защита книг от вирусов


 Автоматическое отключение неподписанных макросов в книгах

Автоматическое отключение неподписанных макросов в книгах

Для предотвращения заражения компьютера вирусом, содержащемся в макросе, можно автоматически отключать все неподписанные макросы или макросы, полученные из ненадежного источника.

  1. В меню Сервис выберите команду Макрос и затем — Безопасность.

  2. Выберите вкладку Уровень безопасности.

  3. Установите переключатель в положение Высокая.

Примечание. Если необходимо проверять каждую рабочую книгу отдельно, то можно при попытке открыть книгу, содержащую макросы, отображать предупреждающее сообщение.


 Добавление разработчика макросов в список надежных источников

Добавление разработчика макросов в список надежных источников

Для этой процедуры необходимо, чтобы на компьютере был установлен Microsoft Internet Explorer версии 4.0 или поздней и установлен средний или высокий уровень безопасности.

  1. Откройте книгу или загрузите надстройку, содержащую макросы из источников, которые необходимо включить в список.

  2. В диалоговом окне Предупреждение системы безопасности установите флажок Всегда доверять макросам из этого источника.

Примечание. Если в диалоговом окне Предупреждение системы безопасности не отображен флажок Всегда доверять макросам из этого источника, то макрос не имеет цифровой подписи. Без цифровой подписи невозможно добавить этого разработчика макросов в список надежных источников.


Удаление разработчика макросов из списка надежных источников

Для выполнения данной процедуры на компьютере должно быть установлено приложение Microsoft Internet Explorer версии 4.0 или более поздней.

  1. Выберите в меню Сервис команду Макрос и подкоманду Безопасность.

  2. Перейдите на вкладку Надежные источники.

  3. Щелкните источник, который требуется удалить из списка, и нажмите кнопку Удалить.


Получение цифрового сертификата

В чем именно заключаются сложности?

Создание собственного цифрового сертификата

Запрос цифрового сертификата от организации

Запрос цифрового сертификата от коммерческой службы сертификации

Не можете сделать выбор?


 Подписание проекта, содержащего макрос

Подписание проекта, содержащего макрос

Перед тем, как подписывать макропроект убедитесь в том, что имеется по крайней мере одинцифровой сертификат

  1. Откройте книгу или шаблон, содержащие подписываемый проект.

  2. В меню Сервис выберите команду Макрос, а затем — Редактор Visual Basic.

  3. В окне проектов выберите проект, который необходимо подписать.

  4. В меню Tools выберите команду Digital Signatures.

  5. Выполните одно из следующих действий:

    Для использования текущего сертификата нажмите OK.

    Для использования другого сертификата нажмите Choose, выберите требуемый сертификат, нажмите OK, а затем снова нажмите OK.

Дополнительные сведения

Сведения о цифровых подписях

Сведения о совместном использовании уровней безопасности и цифровых подписей


Определение допустимых данных в ячейке

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Проверка вводимых в ячейку данных

Если необходимо быть уверенным в том, что в лист введены правильные данные, можно указать данные, которые являются допустимыми для отдельных ячеек или диапазонов ячеек.

Предполагаемые действия

Ограничение диапазона вводимых данных

Выбор вводимых данных из списка

Ограничение количества вводимых в ячейку символов

Определение правильности вводимых данных с помощью формулы

Поиск некорректных данных на листе

Не можете сделать выбор?


Отображение сообщений, приглашающих ввести данные и свидетельствующих о неправильном вводе

Тип данных, которые пользователь должен ввести в ячейку, можно передать с помощью сообщений, появляющихся до и после ввода данных в ячейку.

Предполагаемые действия

Вывод сообщения при переходе к ячейке

Отображение сообщения при вводе неправильных данных

Отображение сообщения и предотвращение ввода в ячейку неправильных данных

Не можете сделать выбор?


 Изменение сообщений и ограничений на данные

Изменение сообщений и ограничений на данные

  1. Если к книге разрешен общий доступ, запретите его.

    Инструкции

  2. Выберите ячейку, к которой относятся сообщения и ограничения на данные, которые требуется изменить.

  3. Выберите команду Проверка в меню Данные.

  4. На каждой вкладке выберите и измените нужные параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  5. Чтобы внести изменения в другие ячейки листа, имеющие те же ограничения и сообщения, установите флажок Распространить изменения на другие ячейки с тем же условием на вкладке Параметры.

    Если нужно, чтобы изменения относились только к текущей ячейке, снимите этот флажок.

Примечания

  • Изменить ограничения или сообщения во время ввода данных в ячейку, к которой они относятся, невозможно.

  • При совместном использовании книги нельзя внести изменения в ограничения и сообщения с помощью диалогового окна Проверка вводимых значений. Во время ввода данных в книгу, к которой предоставлен общий доступ, продолжают действовать все установленные ранее ограничения и сообщения.

  • При разблокировании ячеек, имеющих сообщения или ограничения на данные, и защите содержимого листа, можно вводить данные и отображать дополнительные сведения и сообщения об ошибке, однако нельзя изменить ограничения или сообщения с помощью диалогового окна Проверка вводимых значений. Чтобы получить более подробные сведения, нажмите кнопку [image] .


 Копирование сообщений и ограничений на вводимые данные в другие ячейки

Копирование сообщений и ограничений на вводимые данные в другие ячейки

  1. Щелкните ячейку, имеющую сообщения и ограничения, которые требуется скопировать, и выберите команду Копировать [image] .

  2. Выберите ячейки, в которые нужно скопировать эти сообщения и ограничения.

  3. В меню Правка выберите команду Специальная вставка.

    Демонстрация

  4. Выберите команду Проверка.

Примечания

  • При копировании ограничений в ячейку, данные, противоречащие этим ограничениям, не изменяются.

  • При копировании всего содержимого ячейки с помощью параметров все или без рамки команды Специальная вставка или команды Вставить [image] , Microsoft Excel автоматически копирует сообщения и ограничения на данные.


 Удаление сообщений и ограничений на данные из ячейки

Удаление сообщений и ограничений на данные из ячейки

  1. Выделите ячейки, из которых требуется удалить сообщения и ограничения на данные.

  2. Выберите команду Проверка в меню Данные, а затем откройте вкладку Параметры.

  3. Выберите Очистить все.

Примечания

  • Команда Очистить все полностью удаляет сведения со всех трех вкладок диалогового окна Проверка вводимых значений. Чтобы отменить команду Очистить все, нажмите Отмена.

  • Чтобы наряду с сообщениями и ограничениями удалить все содержимое ячейки и ее форматирование, выделите ячейки, выберите Очистить в меню Правка и затем выберите все.


 Предотвращение изменения сообщений и ограничений на данные

Предотвращение изменения сообщений и ограничений на данные

  1. Перед тем как вводить данные, необходимо разблокировать ячейки, имеющие сообщения и ограничения. Для этого выделите каждую ячейку, выберите Ячейки в меню Формат, щелкните Защита и снимите флажок Защищаемая ячейка.

  2. В меню Сервис выберите команду Защита, а затем — команду Защитить лист.

  3. Убедитесь, что в открывшемся диалоговом окне установлен флажок Содержимое.

Примечание. После выполнения указанных действий команда Проверка в меню Данные становится недоступной.


 Обведенные ячейки с неверно введенными данными

Обведенные ячейки с неверно введенными данными

  • Чтобы удалить обводку одной неверной ячейки, введите в нее правильные данные.

  • Чтобы удалить обводку всех ячеек, убедитесь в том, что на экране присутствует панель инструментов Зависимости (выберите Панель зависимостей в подменю Зависимости меню Сервис). На панели инструментов Зависимости нажмите кнопку Удалить обводку неверных данных [image] .


 Поиск ячеек, для которых заданы ограничения на вводимые данные

Поиск ячеек, для которых заданы ограничения на вводимые данные

  1. Чтобы выделить все ячейки, имеющие одинаковые ограничения на вводимые данные, выберите любую из таких ячеек.

    Чтобы выделить все ячейки, имеющие сообщения и ограничения, щелкните любое место листа.

  2. В меню Правка выберите команду Перейти.

    Демонстрация

  3. Выберите Дополнительный.

  4. Выберите параметр проверка данных.

  5. Чтобы отыскать все ячейки листа, имеющие сообщения и ограничения, щелкните на всех.

    Чтобы отыскать только те ячейки, которые имеют те же сообщения и ограничения, что и ячейка, выбранная в пункте 1, щелкните на этих же.

Совет Чтобы узнать, какие сообщения и ограничения имеет ячейка, щелкните ее, а затем выберите команду Проверка в меню Данные.


Разрешение вопросов, касающихся проверки данных

В чем именно заключаются сложности?

При изменении данных в ячейке не отображается сообщение об ошибке.

Не срабатывают сообщения и ограничения на данные.

При заполнении и копировании данных не срабатывают сообщения и ограничения на данные.

Недоступна команда Проверка в меню Данные.


 Что необходимо для просмотра данных на Web-странице

Что необходимо для просмотра данных на Web-странице

Программы для просмотра интерактивных данных. У пользователей, желающих просматривать на Web-страницах интерактивные данные Microsoft Excel, должны быть установлены следующие программы:

  • Web-компоненты Microsoft Office

  • Обозреватель Microsoft Internet Explorer версии 4.01 или более поздней. Обозреватель Microsoft Internet Explorer 5 поставляется вместе с пакетом Microsoft Office 2000.

Программы для просмотра неинтерактивных данных. У пользователей, желающих просматривать на Web-страницах неинтерактивные данные, должно быть установлено следующее:

  • Web-обозреватель любой версии.


 Размещение данных Microsoft Excel в Web

Размещение данных Microsoft Excel в Web

Данный раздел содержит следующие сведения:

Обзор

Преимущества размещения данных Microsoft Excel в Web

Требования для размещения и просмотра данных Microsoft Excel в Web

Подготовка к публикации данных в Web

Выбор интерактивного или неинтерактивного формата данных

Публикация или сохранение данных в качестве Web-страницы

Форматирование Web-страницы

Обзор

Пример сводной таблицы, созданной на основе отчета сводной таблицы

На Web-странице можно размещать графику, отчеты сводных таблиц, текст и другие элементы.

С помощью возможностей публикации и сохранения, имеющихся в Microsoft Excel, можно сохранить книгу Excel или часть книги, например отдельный элемент листа, в формате HTML и разместить сохраненные данные на узле HTTP, узле FTP, на Web-сервере или сетевом сервере. В результате размещения страницы на любом из этих серверов, за исключением сетевого сервера, в Интернете или интрасети появится Web-страница, которую пользователи смогут просматривать с помощью Web-обозревателей.

Данные можно сохранить как в интерактивной, так и неинтерактивной форме. Если данные сохраняются с интерактивными возможностями, пользователи Microsoft Office 2000 могут работать с данными и вносить в них изменения с помощью Microsoft Internet Explorer версии 4.01 или более поздней так же, как и при работе с данными в Excel. Например, они могут изменять расположение ячеек и обновлять значения ячеек таблицы, а также применять фильтр или изменять макет сводной таблицы. Интерактивные возможностями могут обладать таблицы, сводные таблицы и диаграммы. Если данные сохраняются в неинтерактивном формате, пользователи могут только просматривать данные. См. сведения о способах размещения данных Microsoft Excel в Web.

После публикации или сохранения данных Excel в качестве Web-страницы можно изменить расположение элементов на Web-странице, добавить дополнительный текст или графику и другие компоненты с помощью Microsoft FrontPage 2000 или более поздней версии или режима конструктора страницы доступа к данным в Microsoft Access 2000.

Возврат в начало

Преимущества размещения данных Microsoft Excel в Web

Для работы с данными не требуется устанавливать Excel. Преимущества размещения данных в Web заключаются в том, что пользователи могут получить доступ к данным и, если установлено соответствующее программное обеспечение, пользоваться интерактивными возможностями, не устанавливая Excel на компьютере. Все, что для того требуется — это Web-обозреватель и доступ к Интернету или интрасети. См. дополнительные сведения о требованиях для просмотра данных Excel в Web.

При объединении на одной Web-странице различных типов данных пользователи могут выполнять вычисления, просматривать и анализировать все необходимые данные в одном месте.

Данные легко обновлять. Быстро обновить Web-страницу, уже размещенную в Web, можно с помощью повторной публикации данных из Excel.

Возврат в начало

Требования для размещения и просмотра данных Microsoft Excel в Web

Размещение в Web интерактивных данных Excel. Для этого требуются Microsoft Office 2000 (стандартный, профессиональный или расширенный выпуск), Web-компоненты Microsoft Office и обозреватель Microsoft Internet Explorer 4.01 или более поздней версии. В состав Office 2000 включен Internet Explorer 5. С помощью этих инструментов можно создавать Web-страницы, содержащие формулы, функции, графику, диаграммы, элементы управления ActiveX, сводные таблицы и другие компоненты, доступные в Excel.

С помощью Microsoft FrontPage 2000 созданную Web-страницу можно редактировать, добавлять текст и графику или изменять ее макет.

Кроме того, при наличии Microsoft Access 2000 Web-страницу можно редактировать в режиме конструктора страницы доступа к данным. В этой среде разработки можно настраивать Web-страницу и соответствующий источник данных, добавлять компоненты, доступные в Access, и изменять макет и формат страницы. См. дополнительные сведения о программах, которые можно использовать для изменения Web-страниц.

См. дополнительные сведения о требованиях для размещения данных Excel на Web-странице.

Размещение в Web неинтерактивных данных Excel. Для этого требуется Office 2000 (стандартный, профессиональный или расширенный выпуск). В состав Office 2000 включен Internet Explorer 5, однако для просмотра неинтерактивных Web-страниц можно использовать любой Web-обозреватель.

Просмотр интерактивных данных в Web. Для просмотра и работы с интерактивными данными, размещенными в Web, необходимы Web-компоненты Office и Internet Explorer 4.01 или более поздней версии. Для установки Web-компонентов Office необходимо установить Office 2000 или, если организация имеет лицензию на узел Office 2000, загрузить их из внутренней интрасети. См. сведения о требованиях для просмотра данных Excel на Web-страницах.

Возврат в начало

Подготовка к публикации данных в Web

Перед размещением данных в Web убедитесь, что предприняты все необходимые шаги для обеспечения профессионального вида Web-страницы и правильного функционирования возможностей, которыми она снабжена. В зависимости от того, в каком формате требуется сохранить данные — интерактивной таблицы, сводной страницы, диаграммы или же без интерактивных возможностей, — необходимо выполнить несколько действий для обеспечения правильности отображения данных. См. сведения о подготовке данных к публикации или сохранению в качестве Web-страницы.

Некоторые параметры форматирования и свойства не сохраняются при сохранении данных Excel в качестве Web-страницы.

Возврат в начало

Выбор интерактивного или неинтерактивного формата данных

При публикации или сохранении данных в качестве Web-страницы можно выбрать, какие данные Excel требуются и какие возможности их использования следует предоставить пользователям. Способ использования данных пользователями определяет наилучший способ их публикации ил сохранения. В общем случае, если для работы с данными в Web требуется предоставить пользователям те же возможности, которыми обладает Excel, следует опубликовать данные с добавлением интерактивных возможностей.

Неинтерактивные данные. Если требуется предоставить пользователям только возможность просмотра данных, можно разместить данные на Web-странице без включения каких-либо интерактивных возможностей. Например, если необходимо просто опубликовать отчет о годовых доходах компании и пользователи не должны сортировать, фильтровать или еще каким-либо способом изменять вид данных, следует опубликовать данные без интерактивных возможностей. Такой способ публикации подобен созданию снимка данных и последующему размещению копии снимка на Web-странице. См. сведения о размещении неинтерактивных данных на Web-странице.

Интерактивные данные. Если требуется предоставить пользователям возможности интерактивного взаимодействия с данными на Web-странице, данные следует сделать интерактивными. В зависимости от того, какие данные публикуются или сохраняются и какой тип интерактивности выбран, пользователи могут выполнять такие действия, как фильтрование, ввод новых значений для выполнения вычислений или обобщение и анализ данных. Например, если имеется калькулятор для расчета платежей по закладным, можно опубликовать его с добавлением возможностей ввода и работы с данными в таблицах, с тем чтобы пользователи могли вводить собственные данные для определения ежемесячных выплат. См. сведения о размещении интерактивных данных на Web-странице.

Для публикации в качестве Web-страницы диапазона внешних данных и обеспечения возможности его обновления на основе исходных данных необходимо опубликовать его в интерактивном формате с добавлением функциональных возможностей сводных таблиц. Данные автоматически обновляются всякий раз при обновлении Web-страницы или при нажатии кнопки Обновить сводной таблицы. Если при публикации добавляются только возможности ввода и работы с данными в таблицах, внешние данные на Web-странице не могут быть обновлены.

Возврат в начало

Публикация или сохранение данных в качестве Web-страницы

Выбор места размещения Web-страницы. После создания Web-страницы в Excel можно опубликовать или сохранить данные в выбранном местоположении. Перед публикацией Web-страницы для общего использования рекомендуется протестировать страницу на собственном компьютере, с тем чтобы удостовериться в правильной работе включенных в нее возможностей. Как правило, в качестве места размещения Web-страницы выбирается Web-сервер организации.

Предварительный просмотр Web-страницы перед предоставлением доступа к ней. Если перед публикацией или сохранением требуется проверить, как будет выглядеть Web-страница в Web-обозревателе, можно просмотреть страницу в режиме предварительного просмотра Web-страницы. Интерактивные возможности при предварительном просмотре данных Excel в виде Web-страницы недоступны.

Для предварительного просмотра страницы в интерактивной форме перед нажатием кнопки Опубликовать в диалоговом окне Публикация Web-страницы следует установить флажок Открыть страницу в обозревателе. При наличии возможности протестируйте Web-страницу во всех обозревателях, которые предположительно будут использоваться для просмотра страницы. При получении удовлетворительных результатов можно опубликовать страницу для общего использования.

Размещение данных на новой или существующей странице. При сохранении или публикации данных можно либо создать новую Web-страницу, либо добавить данные на существующую Web-страницу. Путь и имя файла для Web-страницы вводятся в процессе публикации. При размещении данных на существующей странице Excel всегда добавляет новые данные в конец страницы. Чтобы переместить данные, следует отредактировать Web-страницу в другой программе.

Размещение Web-страницы на Web-сервере или в другом местоположении. Если вы работаете в корпоративной сетевой среде, и системным администратором осуществлена настройка Web-сервера с серверными расширениями FrontPage, можно создать на компьютере Web-папку и использовать эту папку для публикации или сохранения данных на Web-сервере. Web-страницу можно также разместить на узле HTTP, узле FTP или сетевом сервере.

Сохранение книги или публикация элементов. В зависимости от того, какого типа данные сохраняются — книга, лист или элементы листа, — для публикации данных можно использовать несколько различных способов размещения данных Microsoft Excel в Web,.

Возврат в начало

Форматирование Web-страницы

После публикации или сохранения данных Excel в качестве Web-страницы можно изменять способ организации данных, перемещать элементы страницы, добавлять графику или специальные эффекты и изменять общий вид Web-страницы. См. сведения о форматировании данных, размещаемых на Web-странице.

Изменение Web-страницы, помещенной в Web. Имеется возможность повторно опубликовать данные Excel, которые уже размещены в Web, путем сохранения или публикации данных заново. Чтобы повторно опубликовать целую книгу, необходимо заново сохранить исходную книгу (файл .xls) как Web-страницу. Диалоговое окне Сохранение документа (меню Файл, команда Сохранить как Web-страницу) не имеет параметра повторной публикации всей книги.

Использование другой программы для изменения Web-страницы. Для получения наилучших результатов для добавления текста и графики, изменения расположения элементов на странице или изменения интерактивных возможностей следует использовать FrontPage 2000. Также можно использовать режим конструктора страницы доступа к данным в Access, который предоставляет среду разработки, позволяющую изменять Web-страницу и осуществлять подключения для отображения и работы с данными из баз данных. См. сведения о программах, которые можно использовать для редактирования Web-страницы.

Возврат в начало


Способы публикации данных Excel в сети Web

Для получения справки этого раздела щелкните рисунок:

Для просмотра этого раздела щелкните рисунок.


 Подготовка данных Excel для публикации или сохранения в виде Web-страницы

Подготовка данных Excel для публикации или сохранения в виде Web-страницы

Прежде чем опубликовать или сохранить лист Microsoft Excel, или элементы листа, в виде Web-страницы, сохраните исходную книгу на случай, если позднее потребуется сверить или изменить и повторно опубликовать данные. Если затем выполнить публикацию или сохранение, файл .xls останется на локальном жестком диске, а Excel создаст новый файл HTML (.htm) в указанном расположении. Однако, если сохранить как Web-страницу всю книгу, ее можно будет впоследствии открыть в Excel без потерь.

Данные могут быть помещены в Web с добавлением или без добавления интерактивности. См. сведения о способах размещения данных Excel в Интернете.

Подготовка интерактивных данных

Прежде чем разместить в Инернете интерактивные данные, убедитесь, что данные, отображаемые в Excel, верны, полны и точны. Поскольку в Excel некоторые параметры форматирования отображаются не так, как в Web, лучше форматировать данные после их публикации или сохранения в Microsoft FrontPage 2000 или в режиме конструктора страниц доступа к данным в Microsoft Access. Если требуется изменить данные, используйте Excel. См. сведения об ограничениях на размещение данных Excel в Интернете.

Работа с электронными таблицами. Обратите внимание на то, что при публикации диапазона внешних данных любые изменения этих внешних данных не будут отражены на Web-странице, если добавить возможность интерактивной работы с электронными таблицами. Для того чтобы поместить на Web-страницу обновляемый диапазон внешних данных, необходимо добавить возможность интерактивной работы со сводными таблицами.

Работа со сводными таблицами. Перед публикацией или сохранением отчета сводной таблицы Microsoft Excel и добавлением возможности интерактивной работы со сводными таблицами выполните следующие действия.

  • Отключите пользовательские вычисления для полей данных.

  • Если отчет сводной таблицы основан на не-OLAP исходных данных, задайте для полей данных использование одной из следующих итоговых операций: «Сумма», «Кол-во значений», «Минимум» или «Максимум».

  • Не используйте форматирование символов или ячеек — например, цвета, шрифты или границы — поскольку это форматирование будет утрачено.

Если требуется опубликовать или сохранить диапазон внешних данных с возможностью работы со сводными таблицами, а возможность обновления опубликованной версии не нужна, можно «заморозить» данные в диапазоне внешних данных перед его публикацией или сохранением.

Работа с диаграммами. Перед размещением интерактивных диаграмм в Web убедитесь, что не используются такие свойства как объемные диаграммы, которые отображаются в Web не так, как в Excel. См. сведения об ограничениях на размещение данных Excel в Интернете.

Подготовка интерактивных данных. Обратите внимание на то, что изменения диапазонов внешних данных не будут отражаться на Web-страницах при публикации данных без добавления интерактивности. Для размещения на Web-странице обновляемого диапазона внешних данных необходимо добавить возможность работы со сводными таблицами.

Добавление гиперссылок. Если требуется, чтобы пользователи могли быстро получать доступ к сведениям на других Web-страницах, можно добавить гиперссылки в книгу перед ее публикацией или сохранением. Гиперссылки работают как на интерактивных, так и на неинтерактивных Web-страницах. Инструкции по созданию гиперссылок.

Просмотр и проверка данных перед публикацией. Если перед публикацией данных требуется просмотреть, как они будут отображаться на Web-странице, можно просмотреть данные в обозревателе. Если данные отображаются не так, как требуется, откройте исходную книгу (.xls), измените данные и вновь просмотрите Web-страницу. Не забывайте, что некоторые параметры форматирования и свойства выглядят на Web-страницах не так, как в Excel.

Если ожидается, что пользователи будут использовать обозреватели, отличные от того, в котором выполнялась проверка страницы, просмотрите перед публикацией Web-страницу в этих обозревателях.

Примечание. Если сохранение данных Excel в формате HTML нежелательно, можно непосредственно сохранить файл книги (.xls) по адресу Интернета. Например, если известно, что на компьютерах всех потенциальных пользователей книги установлен Excel, или использование формата Excel предпочтительней формата HTML, оставьте данные в формате .xls.


 Что необходимо для размещения данных на Web-странице

Что необходимо для размещения данных на Web-странице

Прежде чем размещать данные на Web-странице, убедитесь, что на компьютере установлены все необходимые программы. См. сведения о просмотре данных Microsoft Excel на Web-странице.

Что необходимо для сохранения или опубликования интерактивных данных

  • Microsoft Office 2000 Standard, Professional или Premium (стандартный, профессиональный или расширенный).

  • Microsoft Office Web Components (Web-компоненты).

  • Web-обозреватель Internet Explorer версии 4.0 или более поздней. Для использования панели свойств элементов управления Web-компонентами Microsoft Office необходим Web-обозреватель Internet Explorer версии 4.01 или более поздней. (Internet Explorer 5 поставляется вместе с пакетом Microsoft Office 2000.)

  • Подсоединение к интрасети или Интернету, поставщик услуг Интернет (провайдер).

Необходимы также следующие сведения:

  • Протокол, используемый поставщиком услуг Интернет, например FTP или HTTP (это нужно для опубликования данных в Интернете).

  • Адрес URL того Web-сервера, на который нужно поместить файлы с данными, пубкикуемыми в интрасети.

  • Имя папки Web на сервере, на котором размещаются файлы. См. сведения о папках Web.

Эти сведения можно узнать у поставщика услуг Интернет и у системного администратора.

Что необходимо для опубликования неинтерактивных данных

Для размещения на Web-странице неинтерактивных данных Excel должны быть установлены следующие программы:

  • Microsoft Office 2000 Standard, Professional или Premium (стандартный, профессиональный или расширенный), либо Microsoft Excel 2000.

  • Web-обозреватель любой версии.


Просмотр Web-страницы перед публикацией или сохранением

Существует возможность предварительного просмотра книги или страницы Microsoft Excel в виде Web-страницы

  • Выберите команду Предварительный просмотр Web-страницы в меню Файл.

Примечание. В режиме предварительного просмотра взаимодействие с данными невозможна. Для того чтобы просмотреть страницу в интерактивной форме, установите флажок Открыть страницу в обозревателе прежде чем нажать кнопку Опубликовать и сохранить страницу в папке на локальном диске. Добившись нужных результатов, можно опубликовать страницу для общего доступа.


Размещение данных Excel на Web-странице

Размещение данных Excel в Интернете.

Данные Excel, которые должны быть помещены в Интернете

Интерактивные данные

Лист

Отчет сводной таблицы

Результаты запроса (внешний диапазон данных)

Диапазон ячеек или простой список

Отфильтрованный список

Диаграмма

Область печати

Измененные данные, которые были ранее сохранены в Excel

Данные, которые будут добавлены к существующей Web-странице

Неинтерактивные данные

Книга целиком

Лист, диапазон ячеек, фильтрованный список, диаграмма, область печати или другой объект

Измененные данные, которые были ранее сохранены в Excel

Данные, которые будут добавлены к существующей Web-странице


 Размещение на Web-странице данных Microsoft Excel, которые будут неинтерактивными

Размещение на Web-странице данных Microsoft Excel, которые будут неинтерактивными

Данная процедура используется для сохранения листа, элементов листа или листа диаграммы в виде неинтерактивных данных на Web-странице. Инструкции по сохранению всей книги на Web-странице.

Прежде чем сохранить или опубликовать данные как Web-страницу, сохраните книгу как файл .xls, чтобы иметь версию, доступную для изменения на случай, если позже потребуется изменить Web-страницу.

  1. Выберите в меню Файл команду Сохранить как Web-страницу.

  2. Нажмите кнопку Опубликовать.

  3. В списке Выбрать выберите тип данных, которые требуется опубликовать, а в поле или списке под полем списка укажите нужный элемент.

  4. Убедитесь, что флажок Добавить снят.

  5. Для того чтобы добавить заголовок для публикуемого раздела, нажмите кнопку Изменить, введите нужный заголовок и нажмите кнопку OK.

  6. В поле Имя файла нажмите кнопку Обзор и найдите диск, папку, Web-папку, Web-сервер или адрес FTP, по которому требуется сохранить или опубликовать Web-страницу.

  7. Нажмите кнопку Опубликовать.

Примечание. При публикации неинтерактивной диаграммы она сохраняется в папке вспомогательных файлов как графический файл формата .gif (Graphics Interchange Format). См. дополнительные сведения о папке вспомогательных файлов.


 Размещение данных Excel на существующей Web-странице

Размещение данных Excel на существующей Web-странице

Данные Microsoft Excel можно поместить на любую существующую Web-страницу при наличии прав на изменение этой Web-страницы и доступа к соответствующему файлу HTML. При помещении данных на существующую Web-страницу можно либо заменить существующую Web-страницу переносимыми данными, либо добавить эти данные в конец Web-страницы.

  1. Выделите данные Excel, которые требуется поместить на существующую Web-страницу.

  2. Выберите в меню Файл команду Сохранить как Web-страницу.

  3. Нажмите кнопку Опубликовать.

  4. Убедитесь, что выделенные данные отображаются в поле и списке Выбрать.

  5. Если требуется добавить интерактивность, установите в группе Параметры просмотра флажок Добавить и выберите нужные возможности.

    См. сведения о различиях между возможностями электронных таблиц и сводных таблиц.

  6. Для того чтобы добавить заголовок, нажмите кнопку Изменить, введите нужный заголовок и нажмите кнопку OK.

  7. В поле Имя файла нажмите кнопку Обзор и найдите диск, папку, Web-папку, Web-сервер или адрес FTP существующей Web-страницы, на которой требуется заменить или добавить данные.

  8. Для того чтобы просмотреть Web-страницу в обозревателе после публикации, установите флажок Открыть страницу в обозревателе.

  9. Нажмите кнопку Опубликовать.

  10. Выполните одно из следующих действий:

    Для того чтобы заменить существующую Web-страницу, нажмите кнопку Заменить файл.

    Для того чтобы добавить данные в конец Web-страницы, нажмите кнопку Добавить в файл.


 Снабжение Web-страницы инструкцией пользователя

Снабжение Web-страницы инструкцией пользователя

Когда данные Excel помещаются на Web-страницу, рекомендуется рассказать пользователям об информации на Web-странице и возможных способах ее использования. Хотя инструкции нельзя реализовать в виде оперативной справки, можно включить текст непосредственно в Web-страницу, которая описывает электронную таблицу, диаграмму или список сводной таблицы, или предоставить гиперссылку на отдельную страницу инструкций. Можно использовать Microsoft FrontPage 2000 для создания отдельной Web-страницы с инструкциями.

Кроме общей информации о данных следует также обеспечить инструкции по использованию интерактивных возможностей работы с данными в дополнение к общей информации о списках сводных таблиц и электронных таблицах из справочной системы поWeb-компонентам Microsoft Office. Для отображения этой справки выберите интерактивную электронную таблицу или список сводной таблицы на Web-странице в обозревателе Web и нажмите кнопку Справка на панели инструментов элемента управления.


 Установка кодировки Web-страницы

Установка кодировки Web-страницы

Когда создается Web-страница, можно указать кодировку, которую Web-обозреватель будет использовать для отображения этой страницы. Можно также указать кодировку, которую будет использовать Microsoft Excel для загрузки Web-страницы, если начальная кодировка была неправильной.

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа, а затем выберите вкладку Кодировка.

  3. Выполните одно из следующих действий:

    Чтобы указать кодировку, в которой Excel должен отображать страницу (если она не читается), выберите элемент из списка Загрузить текущий документ как.

    Чтобы указать кодировку, в которой Excel должен сохранять страницу, выберите элемент из списка Сохранить документ как.

    Примечание. Чтобы Excel всегда сохранял Web-страницы с использованием кодировки по умолчанию, установите флажок Всегда сохранять Web-страницы в кодировке по умолчанию. Этот параметр применяется к текущей странице и ко всем страницам, которые в будущем будут сохраняться в Excel. Этот параметр полезен, если используются страницы из разных источников и необходимо хранить все страницы в единой кодировке.


Возможности, которые не поддерживаются при сохранении всей книги как Web-страницы и повторном открытии в Excel

Следующие возможности не поддерживаются при сохранении всей книги как Web-страницы и повторном открытии в Excel.

Возможности | Результат
Представления | Никакие представления не поддерживаются.
Консолидация данных | Ссылки не поддерживаются.
Подписи к формулам | Преобразуются в ссылки на ячейки.
Сценарии | Никакие сценарии не поддерживаются.
Сведения из общей книги | Не поддерживаются.
Категории функций | Никакие категории не поддерживаются.


 Ограничения на размещение интерактивных данных в Интернете

Ограничения на размещение интерактивных данных в Интернете

Когда данные Microsoft Excel сохраняются или публикуются в виде Web-страницы, некоторые компоненты и элементы форматирования могут функционировать по другому или изменить внешний вид. Это зависит от типа данных, сохраняемых в виде Web-страницы, и способа форматирования данных.

Этот раздел содержит информацию об ограничениях по опубликованию или сохранению данных при выборе следующих параметров из списка Добавить:

Работа с электронными таблицами

Работа со сводными таблицами

Работа с диаграммами

Работа с электронными таблицами

Возможности | Результат на Web-странице
Сведения из общей книги | Не поддерживаются.
Заливки с узором | Не поддерживаются.
Границы из точечных или прерывистых линий | Заменяются на сплошные линии
Рисунки | Не поддерживаются.
Поименованные ячейки или диапазоны | Формулы преобразовываются для использования ссылок, а не имен ячеек или диапазонов.
Поименованные константы | Преобразовываются в значения
Слои графических объектов | Не поддерживаются.
Тексты с переносом по словам в ячейках | Не поддерживаются.
Несколько шрифтов в одной ячейке | Не поддерживаются. Используется шрифт первого символа в ячейке.
Условное форматирование | Поддерживается текущий формат ячейки. Форматирование не является условным.
Структурирование | Свернутые строки публикуются как скрытые. Развернутые строки публикуются обычным образом.
Защита паролем | Данные в листах и книгах, защищенных паролем, не могут быть сохранены или опубликованы как Web-страница. Чтобы опубликовать защищенные данные, необходимо использовать пустой пароль.
Примечания к ячейкам | Не поддерживаются.
Ограничения проверки данных и сообщения | Не поддерживаются.
Точность как на экране | Не поддерживается. Значение публикуется с точностью как на экране.
Формулы массива | Преобразовываются в значения
Выравнивание по ширине | Не поддерживается.
Выравнивание по правилам тайского языка | Не поддерживаются.
Стрелки слежения при проверке зависимостей | Не поддерживаются.
Тексты с отступом | Не поддерживаются.
Параметры печати и параметры страницы | Не поддерживаются.
Заголовки в формулах | Преобразуются в ссылки на ячейки.
Повернутый или вертикальный текст | Преобразовывается в горизонтальный текст.
Ссылки на данные на других листах | Ссылки преобразовываются в значения.
Система дат 1904 | Отображаемая дата остается той же самой, а соответствующее число преобразовывается в систему дат 1900.
Стиль ссылок С1К1 | Преобразовывается в стиль ссылок А1
Совместимость с Lotus | Стиль ссылок С1К1 преобразовывается в стиль ссылок А1.
Диапазоны внешних данных | Преобразовываются в значения. Возможность обновления исходных данных не поддерживается.
Запросы Web | Преобразовываются в значения. Возможность обновления исходных данных не поддерживается.
Промежуточные итоги | Числа и вычисления отображаются правильно. Возможности группировки и структурирования не поддерживаются.

Возврат в начало

Работа со сводными таблицами

Возможности | Результат на Web-странице
Вычисляемые поля | Формулы не поддерживаются. Заменяются на поля итогов, которые используют стандартную итоговую функцию для поля («сумма», «кол-во значений», «минимум» или «максимум»).
Вычисляемые элементы | Не поддерживаются.
Итоговые функции | Поддерживаются только поля данных, использующие итоговые функции «сумма», «кол-во значений», «минимум» и «максимум». Поля данных, использующие другие итоговые функции, теряются.
Дополнительные вычисления | Не поддерживаются. Поля данных, использующие дополнительные вычисления, теряются.
Форматирование символов и ячеек | Не поддерживается. Изменения, касающиеся шрифтов, размера текста, цвета и фона ячейки, теряются.
Настраиваемые промежуточные итоги | Не поддерживаются. Если итоговая функция в Excel изменена, промежуточные и окончательные итоги возвращаются к итоговой функции, используемой в поле итога в сводной таблице в Интернете.
Числовые форматы | Поддерживаются частично. Числовые форматы, примененные к полям сводной таблицы в Excel, поддерживаются, а форматы, примененные к отдельным ячейкам — не поддерживаются. Если используется пользовательский числовой формат или числовой формат, не поддерживаемый сводными таблицами в Интернете, числа появляются в том же формате, что и в отчете сводной таблицы в Excel. Нельзя вернуться к пользовательскому числовому формату при последующем изменении числового формата для поля сводной таблицы в Интернете.
Звездочки, обозначающие итоги | Даже если отключить звездочки, обозначающие итоги, в Excel, звездочки отображаются в сводной таблице в Интернете.
Параметры печати | Не поддерживаются. Параметры, устанавливающие повторение подписей строк и столбцов сводной таблицы на каждой странице, повторение подписей элементов после разрыва страницы и разрывы страниц между разделами, теряются.
Сгруппированные элементы в поле | Поддерживаются частично. Сгруппированные элементы в полях данных поддерживаются, но любые выделенные элементы и числовые элементы, сгруппированные в Excel, больше не сгруппированы в сводной таблице в Интернете; групповые поля в Excel не поддерживаются.
Специальный порядок сортировки | Не поддерживается. Данные появляются в том порядке, в каком они были извлечены из исходной базы данных.
Структурированные форматы | Не поддерживаются. Поля находятся в тех же позициях, но форматирование ячеек и символов не поддерживается. Пустые строки между группами элементов теряются.
Промежуточные итоги, отображаемые сверху от группы элементов | Не поддерживаются. Промежуточные итоги появляются снизу от каждой группы.
Автоматическое отображение верхних/нижних элементов | Не поддерживается. Отображаются все элементы
Настроенные значения ошибок и значения пустых ячеек | Не поддерживаются. Ошибки и пустые ячейки отображаются как пустые ячейки.
Расположение полей страниц сводной таблицы в строках или столбцах | Не поддерживается. Поля страниц становятся полями фильтра, которые всегда отображаются вдоль верхней границы.
Установка пароля | Данные в листах и книгах, защищенных паролем, не могут быть сохранены или опубликованы как Web-страница. Чтобы опубликовать защищенные данные, необходимо использовать пустой пароль. Если пароль базы данных сохранен в Excel с помощью запроса, при открытии страницы в обозревателе пользователь должен ввести пароль.
Фоновое обновление, извлечение данных для каждого элемента на странице в отдельности | Не поддерживается. Сводная таблица в Интернете всегда обновляется в активном режиме, все данные для поля фильтра извлекаются одной операцией.
Изменения в исходных данных Excel | Не доступны. Чтобы переопределить диапазон исходных данных для Excel или изменить запрос для выбора других внешних данных, необходимо внести изменения в Excel и произвести повторное опубликование.
Источники данных автономного файла куба | Из опубликованной сводной таблицы невозможно повторно соединиться с исходной базой данных на сервере и изменить содержимое файла автономного куба. Если нужно выполнить какую-нибудь их этих операций, внесите изменения в Excel и повторно опубликуйте сводную таблицу.

Возврат в начало

Работа с диаграммами

Чтобы диаграмма правильно отображалась на Web-странице, она должна быть опубликована отдельно от других данных книги Excel. Когда диаграмма сохраняется с интерактивными возможностями, некоторые компоненты выглядят по другому, чем в Excel.

Возможности | Результат на Web-странице
Объемные диаграммы | Превращаются в плоские диаграммы.
Диаграммы типа «поверхность». | Превращаются в гистограмму.
Автоматическое масштабирование шрифтов. | Устанавливается стандартный размер шрифта.
Графические объекты, надписи и рисунки на диаграмме. | Не поддерживаются.
Полупрозрачные заливки. | Не поддерживаются.
Ось времени | Превращается в стандартную ось категорий с текстовыми подписями.
Индивидуальное форматирование подписей данных | Заменяется на форматирование подписей данных по умолчанию.
Настраиваемые размеры и положение элементов диаграммы. | Изменяются на стандартные размер и положение.
Разметка легенды в несколько столбцов | Заменяется на стандартную разметку легенды.
Коридор изменения | Не поддерживается.
Линии рядов | Не поддерживаются.
Тени | Не поддерживаются.
Линии тренда типа «скользящее среднее» | Не поддерживаются.
Планки погрешностей, вычисляемые по формуле для стандартной ошибки | При вычислении планок погрешностей используются стандартные вычисления.
Защита паролем | Данные в листах и книгах, защищенных паролем, не могут быть сохранены или опубликованы как Web-страница. Чтобы опубликовать защищенные данные, необходимо использовать пустой пароль.
Построение диаграммы по данным только в видимых ячейках. | При построении диаграммы используются все данные, включая и скрытые ячейки.
Размещение подписей оси категорий на графике по умолчанию между точками категорий | Выравниваются по центру точек данных.
Линии тренда | Линии тренда проходят от одной границы области построения до другой, а в Excel линии тренда не достигают границ области построения, проходя только по точкам данных.
Планки погрешностей, вычисляемые по формуле для стандартного отклонения | Выполняются стандартные вычисления.

Особенности диаграмм, которые не могут быть добавлены или изменены другими программами, конструирующими Web-страницы

Приведенные ниже свойства диаграмм Excel поддерживаются при опубликовании интерактивной диаграммы. Однако если Web-страница открывается в другой программе, предназначенной для разработки Web-страниц, например в Microsoft FrontPage 2000 или в режиме конструктора страницы доступа к данным в Microsoft Access, эти свойства не могут быть добавлены или изменены. Если изменяется это свойство или ряд, к которому это свойство применено, свойство больше не поддерживается:

  • Вспомогательная ось значений, которая используется для отображения данных, изменяющихся в широком диапазоне, а также данных, отличающихся от основных данных по типу. Шкала вспомогательной оси отличается от шкалы основной оси.

  • Возможность изменять цвет от точки к точке, часто используемая в диаграммах с одним рядом данных. Когда включена возможность Разноцветные точки, маркеры данных в ряду окрашены в разные цвет, в отличие от стандартного режима отображения, при котором все маркеры данных в ряду имеют один цвет.

  • Некоторые комбинированные диаграммы, например гистограмма, объединенная с круговой диаграммой.

Возврат в начало


 Работа с рисунками на Web-страницах

Работа с рисунками на Web-страницах

Вставка рисунков

Выравнивание рисунков

Графические форматы для Web-страниц

Можно добавить в книгу файлы рисунков или анимации, а затем сохранить книгу как Web-страницу. Microsoft Excel преобразует все рисунки и анимацию в файлы, корректно отображаемые в формате HTML в Web-обозревателях.

Можно использовать рисунки, поставляемые с Excel, например, картинки, автофигуры, надписи и объекты WordArt, либо создать собственные рисунки в формате GIF. При наличии доступа к Интернету можно использовать дополнительные рисунки с Web-страницы графических ресурсов корпорации Майкрософт.

Вставка рисунков

Вставка рисунков из файлов. При вставке рисунка из файла можно вставить весь рисунок, скопировав и вставив его из другого расположения, либо вставить ссылку на постоянное расположение рисунка, например, на Web-сервере, или на относительное расположение файла. Связывание рисунка облегчает его обновление и позволяет использовать один рисунок для нескольких Web-страниц.

При перемещении или копировании Web-страницы в другое расположение следует также переместить или скопировать все вспомогательные файлы (например, рисунки, фоновые текстуры и маркеры), чтобы сохранить работоспособность относительных ссылок на Web-страницу.

При использовании ссылок на рисунки других Web-страниц следует запрашивать соответствующее разрешение у владельцев этих Web-страниц.

Использование рисованных объектов. При создании книг, которые требуется разместить на Web-страницах, допускается использование рисованных объектов, таких как автофигуры и надписи.

Использование анимированных изображений в формате GIF. Допускается вставка анимированных изображений в формате GIF, но выполнять обрезку, изменять заливку, границу, тень или прозрачность анимированного рисунка в формате GIF с помощью панели инструментов Настройка изображения или диалогового окна Формат рисунка нельзя. Эти изменения следует выполнить в соответствующей программе для редактирования анимированных рисунков в формате GIF, а затем снова вставить файл в книгу.

Использование картинок, рисунков или объектов WordArt. В книги, которые будут опубликованы или сохранены как Web-страницы, можно также вставлять рисунки или картинки либо вставлять объекты WordArt.

Дополнительные сведения

Редактирование рисунка

Задание замещающего текста описания объекта на Web-странице

Возврат в начало

Выравнивание рисунков

Панели инструментов Рисование и Настройка изображения в Excel содержат команды выравнивания, помогающие упорядочить рисунки. При выделении рисунка в книге Excel автоматически отображает панель инструментов Параметры изображения. Для того чтобы отобразить панель инструментов Рисование выберите в меню Вид команду Панели инструментов и установите флажок Рисование.

Возврат в начало

Графические форматы для Web-страниц

При первом сохранении книги или листа в формате HTML Excel определяет соответствующие графические форматы для рисунков и преобразует их в формат GIF, JPEG или PNG. Эти форматы представляют собой типы изображений, поддерживаемые в Интернете.

Excel создает вспомогательную папку с именем "имя_файла.files", в которой сохраняются вспомогательные файлы. Например, если файл имеет имя Книга1.htm, Excel создаст подпапку "Книга1.files". Excel также присваивает вспомогательным файлам имена типа image001.jpg и image002.gif.

Возврат в начало


 Запрет загрузки графики с Web-страницы

Запрет загрузки графики с Web-страницы

Можно запретить загрузку графики в Microsoft Internet Explorer 4.0 или других обозревателях, не поддерживающих формат VML. Сделав это, можно быстрее сохранить Web-страницу в форматеHTML, занять меньше дискового пространства и уменьшить время загрузки.

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа, а затем выберите вкладку Картинки.

  3. Установите флажок Использовать VML при отображении графики в обозревателях.

    Примечания

    • Если используется Microsoft Internet Explorer 5.0, эта процедура уменьшает время загрузки и дисковое пространство, необходимое для хранения файлов, но графика по-прежнему будет появляться на Web-странице.

    • Этот параметр применяется к текущей странице и ко всем страницам, которые в будущем будут сохраняться в Excel.

    • Если лист отправляется в формате HTML в виде сообщения электронной почты с использованием этого режима, убедитесь в том, что получатель может просмотреть лист в программе электронной почты, которая распознает формат VML (например Microsoft Outlook 2000 или более поздней версии). В противном случае графика в сообщении будет полностью недоступна.


 Сохранение рисунка в формате PNG

Сохранение рисунка в формате PNG

Использование формата Portable Network Graphics (PNG) позволяет ускорить сохранение книги, уменьшить объем занимаемого дискового пространства и ускорить загрузку файла. чтобы просмотреть изображения в формате PNG, необходимо использовать Web-обозреватель, поддерживающий формат PNG. Перед тем, как сохранять изображения в формате PNG, уточните у системного администратора, поддерживает ли используемый Web-обозреватель формат PNG. См. сведения о фильтре PNG.

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа, а затем выберите вкладку Картинки.

  3. Установите флажок Разрешить выходной формат PNG.

Примечание. Этот параметр применяется к текущей странице и ко всем страницам, которые в будущем будут сохраняться в Excel.


 Управление гиперссылками и файлами в Интернете

Управление гиперссылками и файлами в Интернете

Этот раздел содержит ссылки на:

Относительные и абсолютные ссылки

Управление вспомогательными файлами

Проверка ссылок

Относительные и абсолютные ссылки

При создании Web-страниц Microsoft Excel автоматически управляет вспомогательными файлами и гиперссылками, поэтому ссылки могут быть использованы только после того, как страницы помещены наWeb-сервер.

Когда все файлы — маркеры, кнопки перехода, текстуры фона, рисунки и Web-страницы, на которые созданы гиперссылки — помещены или опубликованы на том же Web-сервере, Excel устанавливает относительные ссылки. Использование относительных ссылок упрощает перенос вспомогательных файлов с одного места на другое. Например, ссылка является относительной, если путь к Web-странице записан как http://Myserver/Mydoc.htm, а страница имеет ссылку на графический файл graphic1.gif.

Гиперссылки на другие узлы Web на других серверах — например, список избранных мест в интернете — устанавливаются как абсолютные — то есть положение файлов фиксируется. Например,ссылка является абсолютной, если Web-страница расположена на http://Myserver и страница содержит ссылку на http://www.example.microsoft.com.

При сохранении Web-страниц в другом месте все ссылки, которые не удается преобразовать в относительные, остаются абсолютными.

Возврат в начало

Управление вспомогательными файлами

При сохранении книги или листа как Web-страницы Excel создает вспомогательную папку с именем "имя_файла.files", в которой сохраняются вспомогательные файлы — маркеры, текстуры фона и рисунки. Например, если файл имеет имя Страница1.htm, Excel создаст подпапку "Страница1.files". Excel также присваивает вспомогательным файлам имена типа image001.jpg и image002.gif.

При удалении элементов, которые были сохранены как относительные ссылки, Excel автоматически удаляет соответствующие вспомогательные файлы из вспомогательной папки.

При перемещении или копировании Web-страницы в другое место необходимо переместить также вспомогательную папку. Таким образом будут обновлены все связи Web-страницы.

Например, создана Web-страница http://Myserver/Страница1.htm.Она включает маркеры, хранящиеся во вспомогательной папке http://Myserver/Страница1.files. Относительные пути к файлам маркеров — /Страница1.files/image001.gif и /Страница1.files/image002.gif. При перемещении Страница1.htm в новое место, например http://Myserver2, необходимо перенести папку со вспомогательными файлами (Страница1.files) на http://Myserver2.

По умолчанию имя вспомогательной папки состоит из имени Web-страницы символа подчеркивания (_), точки (.) или дефиса (-), и слова "files". Стандартные имена вспомогательных папок.

Возврат в начало

Проверка ссылок

После опубликования Web-страниц в Интернете или внутренней сети предприятия, следует проверить страницы в обозревателе Web. Убедитесь в том, что все рисунки отображаются и все гиперссылки ведут на правильные Web-страницы.

Дополнительные сведения

Размещение данных в Интернете

Возврат в начало


 Создание гиперссылок

Создание гиперссылок

Гиперссылки могут быть созданы в книгах с использованием текста или рисунков, которые указывают на диаграммы, книги, Web-страницы или другие файлы.

Предполагаемые действия?

Связывание файла или Web-страницы

Создание гиперссылки на новый файл

Создание гиперссылки на существующий файл

Создание гиперссылки на Web-страницу

Ссылка на определенное место

Создание гиперссылки на определенное место в книге

Создание гиперссылки на определенное место Web-страницы или другого файла Office

Создание настраиваемой гиперссылки с помощью функций для предоставления пользователям листа возможности выбора требуемого места назначения гиперссылки.

Связывание адреса электронной почты

Создание гиперссылки на адрес электронной почты для автоматического запуска программы электронной почты и открытия сообщения по указанному адресу щелчком гиперссылки.


 Установка базового адреса для гиперссылок в книге

Установка базового адреса для гиперссылок в книге

По умолчанию не заданные явным образом гиперссылки на файлы принимаются относительными с использованием в качестве базового адреса местоположения активной книги. Приведенная процедура позволяет установить требуемый путь по умолчанию. В этом случае при создании гиперссылки на файл в диалоговом окне Добавить гиперссылку необходимо будет ввести только имя файла, без указания полного пути.

  1. Выберите команду Свойства в меню Файл.

  2. Выберите вкладку Документ.

    Демонстрация

  3. В поле База гиперссылки введите путь, который требуется использовать.

Примечание. Базовый адрес гиперссылки можно переопределить для отдельной гиперссылки путем использования полного, или абсолютного, адреса гиперссылки в диалоговом окне Добавить гиперссылку.


 Изменение текста или рисунка гиперссылки

Изменение текста или рисунка гиперссылки

  1. Выделите ячейку или рисунок, который представляет гиперссылку.

    Чтобы выделить ячейку с текстом гиперссылки, выделите соседнюю с гиперссылкой ячейку и воспользуйтесь клавишами перемещения курсора для выбора ячейки.

    Для выбора рисунка щелкните его мышью, удерживая клавишу CTRL.

  2. Для изменения текста используйте строку формул.

    Чтобы изменить рисунок, используйте панели инструментов Рисование или Рисунок.

    Инструкции.

    Чтобы изменить текст, являющийся частью рисунка, дважды щелкните рисунок и вносите любые изменения.

Примечание. Для смены рисунка, являющегося гиперссылкой, вставьте новый рисунок и сделайте гиперссылку с тем же местом назначения. Удалите старый рисунок или удалите гиперссылку.


 Изменение внешнего вида текста гиперссылки

Изменение внешнего вида текста гиперссылки

Все изменения стилей " Гиперссылка" и " ПрГиперссылка" применяются ко всем гиперссылкам текущей книги.

  1. В меню Формат выберите команду Стиль.

    Демонстрация

  2. Чтобы изменить внешний вид гиперссылок, перед тем как они будут выбраны для перехода, щелкните Гиперссылка поле Имя стиля.

    Чтобы изменить внешний вид гиперссылок, которые уже были открыты, установите флажок Открывавшаяся гиперссылка в поле Имя стиля.

  3. Нажмите кнопку Изменить.

  4. Измените формат по своему усмотрению и нажмите кнопку OK.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  5. Снимите флажок у лишних параметров.

  6. Щелкните Добавить, а затем Закрыть.

Примечания

  • Только в случае, если в книге предварительно была создана текстовая гиперссылка, стиль " Гиперссылка" появится в списке Имя стиля. Стиль " ПрГиперссылка" появится только в том случае, если текстовая гиперссылка использовалась для входа в другой файл с последующим возвратом в исходную книгу.

  • Чтобы получить сведения о сохранении изменений, внесенных в стили " Гиперссылка" и " ПрГиперссылка" , для использования в новых книгах, нажмите кнопку [image] .


 Изменение места назначения гиперссылки

Изменение места назначения гиперссылки

  1. Щелкните правой кнопкой мыши гиперссылку, которую необходимо изменить, выберите команду Гиперссылка в контекстном меню и далее выберите Правка Гиперссылки.

  2. Внесите необходимые изменения.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечание. Если гиперссылка была создана при помощи функции ГИПЕРССЫЛКА, для изменения места назначения гиперссылки необходимо изменить формулу. Используя клавиши управления курсором, выделите ячейку, содержащую эту формулу, и щелкните строку формул для редактирования формулы.


 Перемещение или копирование гиперссылок

Перемещение или копирование гиперссылок

  1. Щелкните правой кнопкой мыши гиперссылку, которую нужно скопировать или переместить.

  2. Выполните одно из следующих действий:

    Чтобы копировать текст или рисунок гиперссылки, нажмите кнопку Копировать в контекстном меню.

    Чтобы переместить текст или рисунок гиперссылки, нажмите кнопку Вырезать в контекстном меню.

  3. Правой кнопкой мыши выделите ячейку, в которую нужно копировать или переместить гиперссылку, и нажмите кнопку Вставить в контекстном меню.


 Отмена гиперссылки

Отмена гиперссылки

  • Выберите правой кнопкой мыши гиперссылку, которую необходимо отменить, выберите Гиперссылка в контекстном меню и далее выберите Удалить гиперссылку.

Примечание. Чтобы удалить гиперссылку, созданную с помощью функции ГИПЕРССЫЛКА, используйте клавиши управления курсором для выбора ячейки, которая содержит формулу, а затем нажмите клавишу DELETE.


 Удаление гиперссылки и представляющего ее текста или рисунка

Удаление гиперссылки и представляющего ее текста или рисунка

  • Для того чтобы удалить гиперссылку и представляющий ее текст, щелкните гиперссылку правой кнопкой мыши и выберите в контекстном меню команду Очистить содержимое.

  • Для того чтобы удалить гиперссылку и представляющий ее рисунок, зафиксируйте в нажатом положении клавишу CTRL и щелкните рисунок, а затем нажмите клавишу DELETE.

Примечание. Для того чтобы удалить гиперссылку, созданную при помощи функции ГИПЕРССЫЛКА, выделите ячейку, содержащую формулу, с помощью клавиш со стрелками, а затем нажмите клавишу DELETE.


Удаление гиперссылки

Предполагаемые действия

Отмена гиперссылки

Удаление гиперссылки, а также соответствующих ей текста и графики


Об изменении данных на Web-странице

После размещения данных Microsoft Excel на Web-странице можно изменять сами данные, их формат или макет. Поскольку некоторые параметры форматирования при отображении данных на Web-странице выглядят иначе, чем в Excel, может потребоваться внести определенные корректировки. Если требуется только временно изменить вид данных, можно изменить интерактивные данные в обозревателе; если же требуется внести постоянные изменения, следует изменить Web-страницу в соответствующей программе редактирования.

Внесение изменений с помощью Web-обозревателя. Если при сохранении данных они был снабжены интерактивными возможностями, то в Web-страницу можно внести множество различных изменений непосредственно в Web-обозревателе. Однако изменения, сделанные в Web-обозревателе, являются временными и не сохраняются при выходе из обозревателя. Для получения сведений о том, какие изменения можно внести и как это сделать, щелкните интерактивную таблицу или сводную таблицу на Web-странице в обозревателе, а затем нажмите кнопку Справка на панели инструментов таблицы. Для изменения интерактивной диаграммы следует изменить данные в соответствующей таблице или сводной таблице на Web-странице.

Внесение изменений с помощью специализированной программы. Если на Web-страницу требуется добавить графику или текст, или переместить ее элементы, следует открыть страницу в соответствующей программе, предназначенной для разработки Web-страниц, например Microsoft FrontPage 2000, либо воспользоваться режимом конструктора страницы доступа к данным в Microsoft Access 2000 и внести необходимые изменения.

Использование для изменения страницы той или иной программы зависит от типа изменений, которые требуется сделать, а также от способа публикации или сохранения данных. Если опубликована или сохранена целая книга, можно изменить соответствующий файл .htm непосредственно в Excel. В случае публикации или сохранения листа или элементов листа лучше всего использовать Microsoft FrontPage 2000. См. сведения о том, как определить, какую программу следует использовать.

В некоторых случаях может потребоваться изменить код HTML Web-страницы. Однако следует учитывать, что изменения, внесенные в код HTML, могут не поддерживаться в Microsoft Excel или других программах Office.


 Организация данных Excel после сохранения (опубликования) их на Web-странице

Организация данных Excel после сохранения (опубликования) их на Web-странице

Когда данные помещаются на Web, основной файл .htm появляется по указанному адресу в Интернете или во внутренней сети предприятия, а вспомогательные файлы, например .gif, .xml, и другие файлы .htm, появляются в папке по тому же адресу. Папка, содержащая вспомогательные файлы, имеет то же имя, что и сохраненная Web-страница. Имена вспомогательных папок, используемые по умолчанию.

Если Web-страница должна быть перемещена на другое место, можно или еще раз опубликовать данные Microsoft Excel в новом месте, или переместить файл .htm и его вспомогательную папку. Можно также указать, что файлы не будут храниться во вспомогательной папке, если вспомогательные файлы будут храниться в той же папке, что и Web-страница.


 Программы, позволяющие изменять Web-страницы

Программы, позволяющие изменять Web-страницы

Для изменения Web-страниц, содержащих данные Microsoft Excel, можно использовать несколько программ. Рекомендуется использовать Microsoft FrontPage 2000, Microsoft Access 2000 и редактор Visual Basic. При необходимости внести постоянных изменений в данные следует вносить эти изменения в исходный файл Excel или в другом редакторе, но не в обозревателе. Для изменения Web-страниц, созданных с добавлением интерактивности, помимо Excel можно использовать только FrontPage 2000, режим конструктора страниц доступа к данным в Access 2000 и редактор Visual Basic. Рекомендуемые способы изменения Web-страниц перечислены ниже.

  • Изменение книги в целом. Откройте файл .htm в Excel и внесите нужные изменения в данные.

  • Изменение неинтерактивных данных или интерактивной электронной таблицы, сводной таблицы или диаграммы. Для получения наилучших результатов используйте для изменения таких данных Microsoft FrontPage 2000. Также можно использовать режим конструктора страниц доступа к данным use в Microsoft Access 2000 или Visual Basic версии 6.0.

Использование Microsoft Excel. По возможности следует открывать файл исходной книги (.xls), использованной для публикации сохранения Web-страницы, вносить изменения в эту книгу, а затем выполнять публикацию данных повторно. Если доступ к исходной книге отсутствует, можно экспортировать интерактивные электронные таблицы или сводные таблицы в Excel при помощи кнопки Экспорт в Excel панели инструментов Web-обозревателя, либо использовать для изменения Web-страницы Microsoft FrontPage 2000 или режим конструктора страниц доступа к данным в Microsoft Access 2000.

Использование Microsoft FrontPage 2000. Используйте FrontPage версии 2000 или более поздней для выполнения следующих действий.

  • Изменение порядка элементов на Web-странице и настройка интерактивности для электронных таблиц, сводных таблиц и диаграмм

  • Использование расширенных возможностей управления Web-узлом и получение доступа к другим Web-узлам

  • Использование элементов управления структурой страницы

  • Добавление элементов ActiveX, доступных только в FrontPage

Использование режима конструктора страниц доступа к данным в Microsoft Access. Используйте Microsoft Access для выполнения следующих действий.

  • Добавление элементов управления, например, полей и раскрывающихся списков, отображающих данные из базы данных Microsoft Access или Microsoft SQL Server

  • Добавление диаграммы, использующей те же данные, что и диапазон внешних данных на странице

  • Добавление элементов ActiveX, доступных только в режиме конструктора страниц доступа к данным

Если Access используется для изменения страницы путем добавления элементов управления Web-компонентами Microsoft Office или элементов управления, не привязанных к данным из базы данных, то при повторной публикации данных пользователи Internet Explorer версии 4.01 или боле ранней по-прежнему смогут просматривать страницу. Однако при добавлении элементов управления, отличных от Web-компонентов Microsoft Office или привязанных к данным из базы данных Microsoft Access или Microsoft SQL Server, пользователям для просмотра страницы потребуется Internet Explorer версии 5 или более поздней.

Использование Visual Basic 6.0. Используйте Visual Basic 6.0 для добавления элементов управления или при необходимости использования элементов управления Web-компонентами Microsoft Office в качестве элементов управления модели COM или в формах Visual Basic.

Изменение кода HTML. Для внесения таких изменений как перемещение элементов на Web-странице используется редактор HTML, например FrontPage, или текстовый редактор, например Блокнот. Однако изменения, внесенные непосредственно в код HTML, могут не поддерживаться при последующем открытии файла в Microsoft Excel или других приложениях Office.


 Изменение данных после размещения их на Web-странице

Изменение данных после размещения их на Web-странице

Если данные опубликованы или сохранены с интерактивными возможностями, можно изменить данные в исходной книге (.xls) с помощью Microsoft Excel, а затем повторно опубликовать данные. Для изменения таких аспектов Web-страницы, как форматирование или графика, можно использовать Microsoft FrontPage 2000 или режим конструктора страницы доступа к данным в Microsoft Access 2000. См. программы, которые можно использовать для изменения Web-страниц.

  1. Откройте Web-страницу с помощью Web-обозревателя.

  2. Если рядом с кнопкой Изменить появится стрелка, нажмите ее и выберите нужный редактор. Если стрелка не появится, нажмите кнопку Изменить.

Примечание. Если в обозревателе отсутствует кнопка Изменить или нажатие кнопки Изменить открывает не ту программу, которая нужна, можно открыть Web-страницу непосредственно в той программе, которая будет использована для редактирования, например Microsoft FrontPage 2000.


Измененные или повторное опубликование данных на Web-странице, которые были ранее сохранены в Excel

Когда данные Microsoft Excel сохраняются или публикуются в виде Web-страницы, Excel создает версию файла в формате HTML (с расширением .htm). Если необходимо обновить данные на Web-странице, можно открыть исходную книгу файл (.xls), а не файл .htm, внести в нее изменения. Когда данные будут повторно опубликованы, Excel заменит только выделенные данные.

  1. Откройте книгу (файл .xls), которая была ранее сохранена в виде Web-страница, а сейчас должна быть изменена.

  2. Измените данные и сохраните книгу в формате .xls.

  3. Выделите лист или элемент книги, которые необходимо обновить на Web-странице.

  4. Выберите команду Сохранить как Web-страницу в меню Файл.

  5. Нажмите кнопку Опубликовать.

  6. Если необходимо изменить тип интерактивности, заголовок или положение Web-страницы, сделайте соответствующие изменения в диалоговом окне.

  7. Для того чтобы просмотреть Web-страницу в обозревателе после публикации, установите флажок Открыть страницу в обозревателе.

  8. Нажмите кнопку Опубликовать.

Примечания

  • Повторное опубликование книги Эту процедуру нельзя использовать для повторного опубликования всей книги. Чтобы повторно опубликовать всю книгу в виде Web-страницы, откройте в Excel файл .htm и внесите требуемые изменения непосредственно в файл Web-страницы.

  • Повторное опубликование листа с интерактивной диаграммой Если повторно публикуется лист, содержащий диаграмму, и были выбраны интерактивные возможности, диаграмма не будет включена в Web-страницу. Чтобы поместить диаграмму на Web-страницу, необходимо сохранить, или опубликовать, ее отдельно.


 Уменьшение объема файла Web-страницы

Уменьшение объема файла Web-страницы

Публикуемый в Интернете или сохраняемый в виде Web-страницы (с поддержкой интерактивных возможностей работы с электронными таблицами) лист Excel может содержать формулы, которые ссылаются на данные за пределами выделенного диапазона. Чтобы уменьшить размер такого файла, данные внешнего диапазона можно не сохранять.

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа, а затем выберите вкладку Общие.

  3. Снимите флажок Сохранять скрытые данные, необходимые для обновления формул.

    Примечания

    • Этот параметр применяется к текущей странице и ко всем страницам, которые в будущем будут сохраняться в Excel.

    • При отказе от сохранения скрытых данных использующие их формулы будут заменены соответствующими вычисленными значениями.


 Сохранение или публикация файла в Интернете или интрасети

Сохранение или публикация файла в Интернете или интрасети

Порядок сохранения или публикации файлов в Интернете или интрасети зависит от желаемого порядка доступа к этим файлам.

Данный раздел содержит следующие сведения:

Предоставление доступа к файлам через интрасеть или Интернет

Управление файлами через интрасеть или Интернет

Предоставление доступа к файлам через интрасеть или Интернет

Если в вашей организации есть интрасеть, основанная на протоколах Интернета, существует несколько вариантов сохранения файлов в этой интрасети.

  • Использование папок Web. Если Web-сервер поддерживает Web-папки (на Web сервере должны быть установлены серверные расширения Microsoft FrontPage), то для сохранения копий файлов на этом Web-сервере можно использовать Web-папки. Прежде чем копировать или управлять папками и файлами на Web-сервере, обратитесь к системному администратору для получения адреса URL Web-сервера, доступного для сохранения файлов. См. сведения о папках Web.

  • Использование FTP. Если Web-сервер поддерживает протокол FTP (File Transfer Protocol), то можно сохранять файлы на узле FTP. Прежде чем использовать FTP, обратитесь к системному администратору для получения доступа к узлу, на котором можно сохранять файлы.

Возврат в начало

Управление файлами через интрасеть или Интернет

Для того чтобы наилучшим образом управлять файлами, хранящимися на Web-сервере, узнайте у поставщика услуг Интернета (ISP) или Web-администратора организации порядок размещения графических и других файлов на сервере. Например, выясните, нужно ли создавать отдельные папки для маркеров и рисунков, или следует сохранять все файлы в одной папке. Если планируется использование форм или графических схем, рекомендуется узнать об ограничениях на использование этих элементов, поскольку для них необходима дополнительная серверная поддержка.

Возврат в начало


 Папки Web

Папки Web

При создании Web-страницы на компьютере можно использовать папку Web для сохранения или публикации этой страницы непосредственно на Web-сервере, где страница сразу становится доступной по сети.

Данный раздел содержит следующие сведения:

Что такое папка Web?

Создание Web-папок

Использование Web-папок для сохранения файлов на Web-серверах

Просмотр и управление содержимым папок Web

Что такое папка Web?

Папка Web представляет собой ярлык для Web-сервера, на котором можно публиковать или сохранять файлы для просмотра в Web-обозревателях. При создании новых Web-папок они сохраняются в папке «Web-папки» в корневом каталоге компьютера. Доступ к Web-папкам возможен в проводнике Windows, в окне «Мой компьютер» или в диалоговых окнах Открытие документа и Сохранение документа (меню Файл) Microsoft Excel или любого другого приложения Microsoft Office.

С помощью Web-папок возможен доступ не ко всем Web-серверам. Сохранить файл на Web-сервере с помощью средства «Web-папки» можно только в том случае, если на этом сервере установлены серверные расширения Microsoft FrontPage, входящие в состав серверных расширений Microsoft Office.

Возврат в начало

Создание Web-папок

Для копирования, сохранения или управления папками и фалами на Web-сервере необходимо иметь доступ к этому серверу. Для того чтобы узнать, к каким серверам у вас есть доступ на запись, и на каких Web-серверах установлены серверные расширения Microsoft FrontPage, обратитесь к системному администратору или поставщику услуг Интернета.

Для создания Web-папки можно использовать мастер «Добавление папки Web», расположенный в папке «Web-папки». Инструкции по созданию Web-папки.

Возврат в начало

Использование Web-папок для сохранения файлов на Web-серверах

После создания Web-папки можно опубликовать или сохранить данные Excel на Web-сервере, указав эту Web-папку в диалоговом окне Сохранение документа или Публикация Web-страницы (меню Файл, команда Сохранить как Web-страницу). Поскольку Web-папка представляет собой ярлык, сохраняемые файлы помещаются непосредственно на Web-сервер и сразу же становятся доступными по сети.

Также существует возможность сохранения файлов на Web-сервере с помощью проводника Windows.

Возврат в начало

Просмотр и управление содержимым папок Web

Существуют следующие способы просмотра и управления папками и файлами в папках Web.

В проводнике Windows. При просмотре содержимого папки Web отображается список папок и файлов, а также связанные с ними адреса URL. Отображаемые файлы и папки можно перемещать, копировать, переименовывать и удалять, как если бы они находились на обычном файловом сервере, а также просматривать их свойства. Кроме того, допускается перетаскивание файлов между Web-серверами, между Web-сервером и файловым сервером, а также между Web-сервером и локальным жестким диском.

В приложении Office. В диалоговом окне Excel или другого приложения Office Открытие документа (меню Файл) можно просматривать и открывать содержимое папок Web.

В обозревателе. При подключении к Web-серверу, на котором установлены серверные расширения Microsoft FrontPage, можно просматривать в обозревателе содержимое Web папок и связанные свойства файловой системы.

Возврат в начало


 Создание папки Web

Создание папки Web

Перед созданием папки Web может возникнуть необходимость обратиться к системному администратору или поставщику услуг Интернет для выяснения адреса URL Web-сервера, на котором могут быть сохранены файлы.

  1. В окне проводника Windows в папке «Мой компьютер» дважды щелкните Папки Web.

  2. Дважды щелкните Добавление папки Web.

  3. Следуйте инструкциям, выводимым мастером.

Примечания

  • Чтобы создать папку Web непосредственно из Microsoft Excel выполните следующие действия: в диалоговом окне Открыть или Сохранить как (меню Файл; команды Открыть, Сохранить как или Сохранить как Web-страницу), нажмите кнопку Папки Web на панели адресов. Щелкните кнопку Создать папку [image] и следуйте инструкциям, выводимым мастером добавления папок Web.

  • Чтобы сохранить существующие файлы на Web-сервере, перетащите их и все вспомогательные папки во вновь созданную папку Web. См. сведения об именах вспомогательных папок, используемых по умолчанию.


 Сохранение копии файла на Web-сервере с помощью Microsoft Excel

Сохранение копии файла на Web-сервере с помощью Microsoft Excel

  1. Выберите команду Сохранить как в меню Файл.

  2. На панели адресов нажмите кнопку Папки Web и дважды щелкните папку Web, в которой будет сохранен файл.

  3. В списке папок найдите и дважды щелкните папку, в которой будет сохранен файл.

  4. В поле Имя файла введите имя файла.

  5. Из списка Тип файла выберите формат файла, в котором файл будет сохранен.

  6. Нажмите кнопку Сохранить.

Совет. Если необходимо сохранить книгу как Web-страницу до размещения ее на Web-сервере, можно сохранить книгу как файл .htm.


 Сохранение копии файла на Web-сервере с помощью Проводника Windows

Сохранение копии файла на Web-сервере с помощью Проводника Windows

  1. В Проводнике Windows найдите и щелкните правой кнопкой мыши файл, который необходимо сохранить Web-сервере, и выберите Копировать в контекстом меню.

  2. В папке Мой компьютер дважды щелкните Папки Web.

  3. В списке папок Web дважды щелкните требуемую папку.

  4. Найдите папку, в которой должен быть сохранен файл, щелкните ее правой кнопкой мыши и выберите команду Вставить в контекстном меню.

Примечания

  • Когда файл сохраняется как Web-страница, все вспомогательные файлы, например маркеры списков, текстуры фона и рисунки, по умолчанию размещаются во вспомогательной папке. Если Web-страница копируется или перемещается на другое место, необходимо также скопировать или переместить вспомогательную папку, чтобы можно было установить все связи Web-страницы. См. сведения об именах вспомогательных папок, используемых по умолчанию.

  • Если Web-сервер, на котором будет сохраняться файл, не виден, для него можно создать новую папку Web.


 Открытие файла на Web-сервере с помощью Microsoft Excel

Открытие файла на Web-сервере с помощью Microsoft Excel

  1. Нажмите кнопку Открыть [image] .

  2. На панели адресов щелкните ярлык Web-папки, а затем дважды щелкните папку Web, содержащую файл, которые требуется открыть.

  3. В списке папок найдите и дважды щелкните папку, содержащую файл, который требуется открыть.

    Для просмотра всех файлов в папке выберите вариант Все файлы из списка Тип файлов.

  4. Найдите и щелкните файл, который требуется открыть.

  5. Нажмите стрелку рядом с кнопкой Открыть и затем выберите Открыть в Microsoft Excel.

Примечания

  • Если файл имеет формат HTML (Web-страница), убедитесь, что папка вспомогательных файлов находится в той же папке, чтобы сохранить ссылки в рабочем состоянии.

  • Для того чтобы быстро открыть файл на Web-сервере, введите в поле Имя файла диалогового окна Открытие документа адрес файла, который требуется открыть, а затем нажмите клавишу ENTER. Например, введите http://sales/february/workbooks.xls, чтобы открыть файл на Web-сервере http://sales. Если папка Web для http://sales еще не существует, она будет создана автоматически.

  • Другим способом открытия файла на Web-сервере является использование панели инструментов Web. Для быстрого открытия файла можно ввести его адрес в поле Адрес и нажать клавишу ENTER. Файл будет открыт в обозревателе.


 Web-сценарии

Web-сценарии

Web-сценарий — это тип компьютерного кода, который опытные пользователи и разработчики могут использовать для придания данным Microsoft Excel на Web-страницах свойств динамичности. Например, сценарий может представлять собой счетчик посещений страницы, увеличивающийся на 1 при каждом обращении к Web-странице. Также сценарий может отображать сообщение "Осталось x дней" перед какими-либо событиями, где x уменьшается каждый день на 1.

Создание Web-сценариев требует знания программирования. Разработчики могут создавать и изменять сценарии в книге. Сценарии могут выполняться после публикации данных Excel, включая сами сценарии, на Web-странице. Обычно сценарии выполняются Web-обозревателем при открытии Web-страницы; при этом, как правило, отображается информация, созданная сценарием.

Работа с Web-сценариями

При использовании программы Office, например Excel, для открытия Web-страницы, содержащей Web-сценарий, на странице отображается ссылка сценария. Отображение ссылок сценариев можно включить или отключить. Ссылка сценария не отображается при просмотре данных Excel или Web-страницы в Web-обозревателе, а также при печати данных Excel или Web-страницы. При использовании Excel можно копировать и перемещать сценарии, а также удалять сценарии с Web-страницы или из книги.

Использование сценариев с других Web-страниц

Если Web-сценарий скопирован или перемещен с одной Web-страницы или книги на другую страницу или в другую книгу, или с одного места на Web-странице в другое, то он может выполняться неправильно или возвращать ошибки при просмотре Web-страницы в обозревателе. Некоторые Web-сценарии являются автономными и могут выполняться правильно в любом местоположении на любой странице, однако другие сценарии могут быть зависимыми от структуры Web-страницы.


 Создание и изменение Web-сценариев

Создание и изменение Web-сценариев

К данным Microsoft Excel, которые предполагается использовать на Web-странице, можно добавить сценарии, созданные с применением языков Microsoft Visual Basic Scripting Edition (VBScript) или JavaScript. Добавить сценарии можно с помощью команд Добавить сценарий (которую необходимо добавить в меню) и Редактор сценариев (меню Сервис, подменю Макрос).

Для чего используются сценарии. Создание сценариев является полезным при разработке собственных решений для Web. Сценарии обеспечивают полную объектную модель для Web-обозревателя и объектов на текущей странице. Это позволяет создавать код, управляющий элементами на странице, без обращения к исходному коду HTML или к деталям реализации объектов. Также можно создавать код для сценариев, предназначенных специально для обработки событий, связанных с объектами (например, элементами ActiveX) на странице. Сведения об использовании сценариев для обработки событий содержатся в справочной системе редактора сценариев.

Просмотр сценариев и кода HTML. Если требуется просмотреть код HTML для данных или Web-страницы вместе с кодом всех включенных сценариев, то для этой цели можно воспользоваться редактором сценариев (Microsoft Script Editor). С помощью редактора сценариев можно добавлять текст, изменять теги HTML и редактировать код сценариев. Также имеется возможность просматривать данные в том виде, в котором они будут отображаться в Web-обозревателе, и редактировать их непосредственно в этом режиме просмотра.

Дополнительные сведения

Создание сценария для Web-страницы

Просмотр или изменение Web-сценария


Создание сценария для Web-страницы

Для просмотра этого раздела щелкните рисунок.


 Поддержка Java-приложений

Поддержка Java-приложений

Что такое Java-приложение? Java-приложение — это небольшая программа, написанная на Java, языке программирования, разработанном корпорацией Sun Microsystems, Inc. Java-приложения используются преимущественно в World Wide Web. Каждое такое приложение — это отдельный файл, ссылка на который содержится в документе HTML, и который может использоваться, например, для добавления на Web-страницу анимации, музыкального сопровождения, операций для работы с базами данных или обновленной информации.

Значок Java-приложения. При открытии в программе Microsoft Office Web-страницы, содержащей Java-приложение, на странице отображается значок, обозначающий приложение Значок Java-приложения .

При просмотре данных Microsoft Excel или Web-страницы в обозревателе, а также при печати книги или Web-страницы значок не отображается.

Работа с Java-приложениями. Создание Java-приложений требует знания программирования. Java-приложения можно перемещать или копировать на новое место на Web-странице или в данных Excel для Web-страницы, или на другую Web-страницу. Также можно удалять Java-приложения. Кроме того, разработчики могут создавать или изменять код Java-приложений.


Разрешение вопросов при опубликовании или сохранении данных Excel на Web-странице

В чем именно заключаются сложности?

Доступ и копирование данных

Не удается обновить опубликованные или сохраненные в интерактивной таблице данные

Обозреватель не позволяет экспортировать данные Web-страницы в Microsoft Excel

При нажатии кнопки Правка в обозревателе Web-страница открывается не той программой

Не удается опубликовать или сохранить данные Excel в Web-папке

При попытке опубликовать или сохранить данные на Web-странице выдается сообщение об ошибке

Неправильное отображение на Web-странице элементов без интерактивных возможностей

Неправильное отображение узоров

Неправильное отображение текста

Текст ячейки отображается не полностью

Неправильное отображение повернутого текста

Неправильное отображение границ

Сохраняемые или публикуемые на существующей Web-странице элементы отображаются только в конце страницы

Имена отображаются как значения или диапазоны

Не удается опубликовать или сохранить защищенные паролем данные

Изменение цвета заливки ячейки

Неправильное отображение на Web-странице интерактивных элементов

Неправильное отображение узоров

Неправильное отображение текста

Текст ячейки отображается не полностью

Неправильное отображение повернутого текста

Неправильное отображение границ

Сохраняемые или публикуемые на существующей Web-странице элементы отображаются только в конце страницы

Не удается сохранить или опубликовать диаграмму на Web-странице

Не удается сохранить или опубликовать диаграмму с интерактивными возможностями

Неправильное отображение отчета сводной таблицы

Не удается просмотреть страницу в Web-обозраветеле

Вывод значения #ИМЯ? при опубликовании или сохранении данных Excel, содержащих функции пакета анализа

Не удается отфильтровать данные на Web-странице

Имена отображаются как значения или диапазоны

Не удается опубликовать или сохранить защищенные паролем данные


Разрешение вопросов, связанных с параметрами Web-страницы

Работа с файлами и ссылками

Размещение вспомогательных Web-файлов в отдельной папке нежелательно

Сохраненную на файловом сервере Web-страницу не могут найти или просмотреть некоторые пользователи

После перемещения Web-страницы часть ссылок не работает

Не получается автоматически создать резервную копию Web-страницы

Уменьшение объема файла Web-страницы

Отсутствуют ячейки при сохранении или опубликовании Web-страницы

Данные запроса отсутствуют или не обновляются должным образом

Имя вспомогательной папки Web-страницы написано на другом языке

Работа с графическими объектами

Отображение на Web-странице значка X красного цвета

Графический объект на Web-странице не отображается

При просмотре Web-страницы на другом компьютере текст и графические объекты выглядят иначе

Работа с данными

Невозможна работа с интерактивными данными Web-странице

Данные запроса отсутствуют или не обновляются должным образом

Интерактивная Web-страница не может быть открыта пользователями

Выбор кодировки или шрифта

Неправильное отображение знаков языка при просмотре самостоятельно созданной Web-страницы

Открытая Web-страница имеет неправильный шрифт или кодовую страницу


Разрешение вопросов: гиперссылки

В чем именно заключаются сложности?

Не получается выделить текст или рисунок гиперссылки для его изменения

При повторном открытии книги гиперссылки не работают

Не получается открыть файл через Интернет

При выборе гиперссылки появляется сообщение об ошибке

Не работают гиперссылки при копировании данных в книгу Excel

Не отображаются линии сетки после добавления гиперссылки на новый лист


 Перенос данных с Web-страницы в Microsoft Excel

Перенос данных с Web-страницы в Microsoft Excel

Существует несколько способов перенесения данных с Web-страницы в Excel. Некоторые данные могут в Excel выглядеть по-другому чем на Web-странице. Это зависит от способа размещения данных в Интернете и способа извлечения данных в Excel. Книги, сохраненные Excel в виде Web-страниц, всегда будут отображаться правильно, но другие данные могут отличаться, особенно интерактивные данные.

Копирование и вставка Можно копировать выделенные данные с Web-страницы с помощью команд копирования и вставки.

Экспорт данных через интерактивные элементы управления Находясь в обозревателе, можно экспортировать данные из интерактивных электронных таблиц и списков сводных таблиц в Excel с помощью кнопки Экспорт в Excel панели управления элемента управления. Более подробную информацию можно найти в справке по Web-компоненту Microsoft Office для списков сводной таблицы или электронных таблиц. Для отображения этой справки щелкните интерактивную электронную таблицу или список сводной таблицы на Web-странице в обозревателе Web и нажмите кнопку Справка на панели управления элемента управления.

Web-запрос Можно использовать Web-запросы для перенесения таблиц и отформатированных областей в Excel. Когда используется Web-запрос, можно указать нужные части Web-страницы и требуемое форматирование. Если в Excel переносится вся Web-страница, некоторые элементы, например изображения в формате .gif и страницы фреймов, не включаются.

Команда Открыть (меню Файл) Можно также открыть любой файл .htm в Excel. Когда выполняется эта операция становится доступной вся Web-страница, но возможна потеря некоторых частей страницы. Например, сценарии, графические файлы в формате .gif и списки данных, расположенные в одной ячейке, не будут отображены в Excel правильно.


 Копирование данных с Web-страницы в Microsoft Excel

Копирование данных с Web-страницы в Microsoft Excel

При копировании данных с Web-страницы в Excel возможна потеря некоторых данных. Например, сценарии, графические файлы в формате .gif и списки данных, расположенные в одной ячейке, не будут отображены в Excel правильно. Наилучшие результаты достигаются, если копируется только таблица.

  1. Находясь в Web-обозревателе, выделите данные, которые необходимо скопировать.

  2. В меню Правка выберите команду Копировать. Если обозреватель не имеет этой команды, то для получения информации о копировании обратитесь к справочной системе обозревателя.

  3. Перейдите в Excel.

  4. Укажите левый верхний угол области листа, куда следует поместить копируемые данные.

  5. Выберите в меню Правка команду Вставить.

Примечание. Находясь в обозревателе, необходимо выполнить особую процедуру для копирования данных из интерактивных электронных таблиц и списков сводных таблиц. Более подробную информацию можно найти в справке по Web-компоненту Microsoft Office для списков сводных таблиц или электронных таблиц. Для отображения этой справки щелкните интерактивную электронную таблицу или список сводной таблицы на Web-странице в Web-обозревателе и нажмите кнопку Справка на панели управления элемента управления.


Изменение данных на Web-странице

Предполагаемые действия

Изменение данных после помещения их на Web-странице

Изменение текста в формате HTML для данных в Интернете

Программы, которые могут изменять Web-страницы

Не можете сделать выбор?


Изменение текста в формате HTML для данных в Интернете

Хотя текст в формате HTML может быть изменен непосредственно на Web-странице, внесенные изменения могут не поддерживаться Microsoft Excel или другими программами Microsoft Office при последующем открытии документа в одной из этих программ.

Для получения наилучших результатов используйте Microsoft FrontPage 2000 или режим конструктора страницы доступа к данным в Microsoft Access для изменения Web-страницы или измените первоначальный файл .xls в Excel и повторно опубликуйте данные.


 Использование Microsoft Excel для изменения Web-страниц в Web-обозревателях

Использование Microsoft Excel для изменения Web-страниц в Web-обозревателях

В настройках Web-обозревателя можно указать программу, которая должна использоваться для изменения текущей Web-страницы. В параметрах обозревателя Microsoft Internet Explorer 3.0 (или более поздней версии) можно также указать, что страницы, которые были созданы приложением Microsoft Office, должны изменяться только в соответствующем приложении. См. сведения о программах для изменения Web-страниц.

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа и выберите вкладку Файлы.

  3. Выберите нужное положение флажка Office - для Web-страниц, созданных в Office.

    Чтобы Web-страницу можно было изменять только в том приложении Office, где она была создана, флажок должен быть установлен.

    Чтобы для изменения страницы использовалась программа, указанная в настройках обозревателя, флажок следует снять.

    Примечание. Этот параметр применяется к текущей странице и ко всем страницам, которые в будущем будут сохраняться в Excel.


Имена вспомогательных папок Web-страницы, используемые по умолчанию

Когда файл сохраняется как Web-страница, все вспомогательные файлы, например маркеры списков, фоновые текстуры и графические объекты, по умолчанию размещаются во вспомогательной папке. По умолчанию имя вспомогательной папки состоит из имени Web-страницы, символа подчеркивания (_) или точки (.) или дефиса (-) и слова "files", которое для языков, использующих латинский алфавит, заменяется переводом.

Например, сохраняется в виде Web-страницы файл Страница1. По умолчанию имя вспомогательной папки будет "Страница1.files".

Примечание. Если при сохранении Web-страницы снят флажок По возможности использовать длинные имена файлов в диалоговом окне Параметры Web-документа, что включает короткие имена файлов (не более восьми символов плюс трехсимвольное расширение имени файла), имя вспомогательной папки совпадает с именем Web-страницы, без слова «files».

Приведенная ниже таблица представляет перевод слова "files" в версиях Excel 2000 для различных языков.

Язык Office 2000 | Имя вспомогательной папки Web-страницы, используемое по умолчанию
Английский | "_files"
Арабский | ".files"
Баскский | "_fitxategiak"
Болгарский | ".files"
Венгерский | "_elemei"
Вьетнамский | ".files"
Голландский | "_bestanden"
Греческий | ".files"
Датский | "-filer"
Иврит | ".files"
Испанский | "_archivos"
Итальянский | "-file"
Каталанский | "_fitxers"
Китайский (традиционное письмо) | ".files"
Китайский (упрощенное письмо) | ".files"
Корейский | ".files"
Латышский | "_fails"
Литовский | "_bylos"
Немецкий | "-Dateien"
Норвежский | "-filer"
Польский | "_pliki"
Португальский | "_ficheiros"
Португальский (Бразилия) | "_arquivos"
Румынский | ".files"
Русский | ".files"
Сербский (кириллица) | ".files"
Сербский (латиница) | "_fajlovi"
Словацкий | ".files"
Словенский | "_datoteke"
Тайский | ".files"
Турецкий | "_dosyalar"
Украинский | ".files"
Финский | "_tiedostot"
Французский | "_fichiers"
Хорватский | "_datoteke"
Чешский | "_soubory"
Шведский | "-filer"
Эстонский | "_failid"
Японский | ".files"


 Занесение текущего файла в список избранных файлов на панели Web

Занесение текущего файла в список избранных файлов на панели Web

При открытии с помощью Microsoft Excel книги или другого файла в Интернете, сети World Wide Web, сети интранет или на локальном жестком диске, этот файл можно добавить в папку "Избранное" , что позволяет открывать его впоследствии существенно быстрее.

  1. На панели инструментов Web нажмите кнопку Избранное, а затем выберите Поместить в папку "Избранное".

  2. Нажмите кнопку Добавить.

Примечания

  • Чтобы быстро открыть этот файл, нажмите кнопку Избранное на панели инструментов Web, а затем выберите файл из списка.

  • Папка Избранное используется совместно всеми программами Microsoft Office и обозревателем Microsoft Internet Explorer. Поэтому файлы, добавленные в папку Избранное, будут также отображены в папках Избранное в других программах Office и в Internet Explorer.


 Открытие недавно просмотренных Web-файлов и файлов Office

Открытие недавно просмотренных Web-файлов и файлов Office

  1. Для открытия просмотренных файлов Web или Microsoft Office в порядке, обратном порядку их просмотра, нажмите кнопку Назад [image] на панели инструментов Web.

  2. После перехода к просмотренным файлам можно нажать кнопку Далее [image] на панели инструментов Web для открытия файлов в исходном порядке их просмотра.


 Открытие начальной страницы Web с помощью панели инструментов Web Microsoft Excel

Открытие начальной страницы Web с помощью панели инструментов Web Microsoft Excel

При запуске средства просмотра Web первой в окне средства просмотра появляется начальная страница. На начальной странице могут находиться инструкции по пользованию Web и гиперссылки на другие файлы.

  • На панели инструментов Web нажмите кнопку Начальная страница [image] .

Примечание. Для получения сведений об установке в качестве начальной страницы Web книги Microsoft Excel нажмите кнопку [image] .


 Открытие страницы поиска в Web с помощью панели инструментов Web

Открытие страницы поиска в Web с помощью панели инструментов Web

Страница поиска служит для поиска и открытия файлов, расположенных в интранет или на узлах Интернета. Многие страницы поиска позволяют осуществлять поиск файла по ключевым словам или теме; другие предлагают список гиперссылок, с помощью которых можно выбрать нужный файл или узел Интернета.

Чтобы просмотреть страницу поиска, которая является файлом Microsoft Office, необходимо иметь программу Microsoft Office, с помощью которой создан это файл, или программу просмотра, позволяющую открывать и просматривать файлы, созданные в программах Office. Чтобы просмотреть страницу поиска, которая является Web-страницей формата HTML, необходимо иметь совместимое с Office средство просмотра Web, например, Microsoft Internet Explorer.

  • На панели инструментов Web нажмите кнопку Найти в Web [image] .

Примечание. Для получения сведений об установке в качестве страницы поиска книги Microsoft Excel нажмите кнопку [image] .


 Скрытие всех панелей инструментов, кроме панели инструментов Web

Скрытие всех панелей инструментов, кроме панели инструментов Web

  • На панели инструментов Web нажмите кнопку Отображать только панель Web [image] .

Примечание. Чтобы снова вывести на экран скрытые панели инструментов, нажмите кнопку Отображать только панель Web [image] еще раз.


 Установка книги Microsoft Excel в качестве начальной страницы Web

Установка книги Microsoft Excel в качестве начальной страницы Web

Если новая начальная страница определена в Microsoft Excel, она станет начальной страницей для всех программ Microsoft Office и совместимых с Microsoft Office средств просмотра Web.

  1. Откройте книгу Microsoft Excel, которую требуется использовать в качестве начальной страницы.

  2. На панели инструментов Web нажмите кнопку Переход, а затем выберите команду Установить начальную страницу.

  3. Нажмите кнопку Да.

Примечания

  • Чтобы установить в качестве начальной страницы Web-страницу в формате HTML, откройте файл HTML с помощью средства просмотра Web, например обозревателя Microsoft Internet Explorer, а затем обратитесь к справочной системе Microsoft Internet Explorer.

  • Чтобы получить сведения об установке в качестве начальной страницы файлов других типов, обратитесь к справочной системе программы Office, использовавшейся для создания файла.


 Установка книги Microsoft Excel в качестве страницы поиска в Web

Установка книги Microsoft Excel в качестве страницы поиска в Web

Если новая страница поиска определена в Microsoft Excel, она станет начальной страницей для всех программ Microsoft Office и совместимых с Office средств просмотра Web.

Эта процедура позволяет использовать в качестве страницы поиска книгу Microsoft Excel. Чтобы использовать в качестве страницы поиска файл Microsoft Office другого вида, ознакомьтесь со справочными сведениями программы, в которой был создан указанный файл. Чтобы установить в качестве страницы поиска Web-страницу в формате HTML, откройте файл формата HTML с помощью Microsoft Internet Explorer или Microsoft Word, в котором имеются средства создания и редактирования файлов HTML, а затем обратитесь к справочной системе Microsoft Internet Explorer или Word.

  1. Откройте книгу Microsoft Excel, которую предстоит использовать в качестве страницы поиска.

  2. На панели инструментов Web нажмите кнопку Переход, а затем выберите Установить страницу поиска.

  3. Нажмите кнопку Да.


 Отключение автоматического завершения имен файлов и адресов URL

Отключение автоматического завершения имен файлов и адресов URL

Если используется Microsoft Internet Explorer версии 4.0 или более поздней, можно отключить возможность, автоматически предлагающую подходящие имена файлов и адреса URL при вводе их в диалоговые окна Добавить гиперссылку или Открыть в Microsoft Excel. Это также отключит автоматическое завершение адресов URL в Internet Explorer и всех других программах Microsoft Office.

  1. Запустите Internet Explorer или переключитесь в его окно.

  2. В меню Вид выберите команду Свойства обозревателя и перейдите на вкладку Дополнительно.

  3. В списке под заголовком Обзор сбросьте один из следующих флажков:

    4. Если используется обозреватель Internet Explorer 4, снимите флажок Использовать авто-завершение.

    Если используется обозреватель Internet Explorer 5, снимите флажок Использовать встроенное автозаполнение в проводнике.


 Обновление текущего файла с помощью панели инструментов Web

Обновление текущего файла с помощью панели инструментов Web

Если книга Microsoft Excel или другой файл, открываемый в World Wide Web, в сети или на Web-сервере, уже открыт другим пользователем, можно открыть этот файл только для чтения. Когда требуется просмотреть последние изменения, внесенные и сохраненные другим пользователем, следует обновить свою копию Web-страницы.

  • На панели инструментов Web нажмите кнопку Обновить текущую страницу [image] .


 Внесение узла FTP в список адресов FTP

Внесение узла FTP в список адресов FTP

Чтобы внести узел FTP в список адресов FTP, отображаемый в диалоговых окнах Сохранить как и Открытие документа, необходимо иметь доступ к этому узлу FTP. Доступ к узлу FTP можно получить через прямое подключение к Интернету, либо посредством удаленного доступа через поставщика услуг Интернета. Сведения о подключении к Интернету содержатся в справочнике Microsoft Office 2000 Resource Kit, доступном на Web-узле корпорации Майкрософт.

Примечание. Для изменения и добавления адресов FTP необходима правильная настройка параметров прокси-сервера. Для получения сведений о настройке параметров соединения через прокси-сервер следует обращаться к системному администратору.

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите Добавить/изменить адреса FTP.

  3. В поле Имя узла FTP введите имя FTP-сервера; например, ftp.microsoft.com

  4. Выполните одно из следующих действий:

    Чтобы войти в систему анонимно (если такой режим поддерживается данным узлом), выберите в режиме anonymous.

    Чтобы войти в систему в качестве зарегистрированного пользователя, при наличии пользовательского доступа, выберите под именем, а затем введите зарегистрированное имя пользователя в поле под именем.

  5. Чтобы не вводить пароль каждый раз при открытии или сохранении на узле файла, введите пароль в поле Пароль.

  6. Нажмите кнопку Добавить.


 Сохранение книги на узле FTP

Сохранение книги на узле FTP

Прежде чем сохранять книгу на узле FTP, необходимо внести этот узел FTP в список адресов FTP. Для получения дополнительных сведений по этому вопросу нажмите кнопку [image] .

Чтобы сохранить книгу на узле FTP, необходимо иметь полномочия на сохранение файлов на этом узле. Чтобы получить сведения о предоставлении полномочий, а также о любых проблемах, возникших при работе с узлом, обратитесь к администратору узла.

  1. В меню Файл выберите команду Сохранить как.

  2. В поле Папка выберите Адреса FTP.

  3. В списке адресов FTP дважды щелкните нужный узел, а затем откройте каталог, в котором требуется сохранить книгу.

  4. В поле Имя файла введите имя книги.

  5. Нажмите кнопку Сохранить.

Примечание. При сохранении книги на узле FTP недоступна возможность создания резервных копий книги с помощью установки флажка Всегда создавать резервную копию в диалоговом окне Параметры сохранения. (Чтобы получить доступ к этому параметру, выберите команду Сохранить как в меню Файл, откройте меню Сервис и выберите пункт Общие параметры.)


 Изменение имени входа или пароля, используемого для получения доступа к узлу FTP

Изменение имени входа или пароля, используемого для получения доступа к узлу FTP

Чтобы изменить имя входа или пароль, необходимо внести узел FTP в список адресов FTP. Для получения дополнительных сведений по этому вопросу нажмите кнопку [image] .

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите Добавить/изменить адреса FTP.

  3. Щелкните правой кнопкой мыши адрес FTP, для которого требуется изменить имя входа или пароль, а затем выберите Изменить в контекстном меню.

  4. Внесите необходимые изменения.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.


 Удаление узла FTP из списка адресов FTP

Удаление узла FTP из списка адресов FTP

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите Добавить/изменить адреса FTP.

  3. Щелкните правой кнопкой мыши узел FTP, который требуется удалить, и затем выберите команду Удалить в контекстном меню.


 Обсуждения в Excel

Обсуждения в Excel

Возможность проведения обсуждений доступна только в том случае, если на сервере установлены серверные расширения Microsoft Office. Для получения дополнительных сведений обратитесь к системному администратору.

Данный раздел содержит следующие сведения:

Использование структурированных обсуждений при совместной работе

Проведение и просмотр обсуждений

Изменение, удаление и ответ на комментарии обсуждения

Отбор обсуждений

Дополнительные сведения

Использование структурированных обсуждений при совместной работе

Возможность проведения обсуждений позволяет нескольким пользователям добавлять в книгу замечания и комментарии. Обсуждения являются структурированными; это означает, что ответы на замечание обсуждения располагаются непосредственно под замечанием. Одновременно можно вести несколько обсуждений. (Также можно работать прямо из обозревателя.) С помощью панели инструментов Обсуждения любой пользователь, просматривающий книгу, может просмотреть и ответить на любое замечание обсуждения. По окончании обсуждения можно просмотреть замечания обсуждения в Microsoft Excel и внести в книгу изменения на основе полученных отзывов.

Возврат в начало

Проведение и просмотр обсуждений

Когда вы начинаете обсуждение, появляется область обсуждений с вашим замечанием или вопросом, а также темой обсуждения. После добавления другими пользователями комментариев можно прокрутить замечания обсуждения в области обсуждений, чтобы просмотреть тему, имена пользователей, добавивших замечания, и содержимое обсуждения.

Возврат в начало

Изменение, удаление и ответ на комментарии обсуждения

Пользователи могут изменять только те замечания, которые добавлены в книгу ими самими, если системный администратор не установил соответствующие права на изменение и удаление всех замечаний обсуждения. Ответить же можно на любое замечание.

Возврат в начало

Отбор обсуждений

Имеется возможность отобрать замечания обсуждения в книге, с тем чтобы просмотреть только замечания, добавленные определенным пользователем в течение определенного промежутка времени. Например, можно отобразить только замечания, добавленные Петром Ивановым в течение последней недели.

Возврат в начало

Дополнительные сведения

Выбор сервера обсуждений

Ответ на замечание в обсуждении

Редактирование текста обсуждения

Удаление замечания в обсуждении

Возврат в начало


 Обсуждения на Web-страницах

Обсуждения на Web-страницах

Возможность проведения обсуждений доступна только при наличии серверных расширений Microsoft Office, настройка которых должна выполняться системным администратором.

Данный раздел содержит следующие сведения:

Использование структурированных обсуждений при совместной работе

Требования к обозревателю

Получение справочных сведений об обсуждениях

Дополнительные сведения

Использование структурированных обсуждений при совместной работе

Возможность проведения обсуждений позволяет нескольким пользователям добавлять замечания на Web-страницу. Обсуждения являются структурированными; это означает, что ответы на каждое замечание обсуждения располагаются непосредственно под замечанием. Одновременно можно вести несколько обсуждений. Начать обсуждение можно из обозревателя. (Также можно работать непосредственно из Microsoft Word, Microsoft Excel и Microsoft PowerPoint.) С помощью панели инструментов Обсуждения любой пользователь, просматривающий Web-страницу, может просмотреть обсуждение и ответить на любое замечание обсуждения. Замечания обсуждения на Web-странице можно отбирать, с тем чтобы просмотреть только замечания, добавленные определенным пользователем или в течение определенного промежутка времени. По окончании обсуждения можно просмотреть замечания обсуждения в обозревателе или программе Microsoft Office и внести в Web-страницу изменения на основе полученных отзывов.

Возврат в начало

Требования к обозревателю

Обсуждения поддерживаются большинством обозревателей, однако лучше работать в Microsoft Internet Explorer версии 4.0 (или более поздней). Если на компьютере установлена более ранняя версия Internet Explorer или другой обозреватель (например, Netscape Navigator 3.0 или более поздняя версия этого приложения), замечания обсуждений могут добавляться на Web-страницу через начальную страницу серверных расширений Microsoft Office. Чтобы перейти к этой начальной странице, в поле Адрес обозревателя следует ввести текст http://ИмяСервера/msoffice/, где ИмяСервера обозначает Web-сервер, к которому имеется доступ для сохранения файлов. Имя такого сервера можно узнать у системного администратора.

Независимо от используемого обозревателя при подключении к Web-странице с начальной страницы серверных расширений Office отображаемая панель инструментов Обсуждения будет отличаться от панели инструментов, отображаемой в Internet Explorer 4.0 или более поздней версии.

Возврат в начало

Получение справочных сведений об обсуждениях

Для отображения содержания справки нажмите кнопку Справка по Web-обсуждениям Справка по Web-обсуждениям на панели инструментов Обсуждения.

Возврат в начало

Дополнительные сведения

Обсуждения в Excel

Возврат в начало


 Выбор сервера обсуждений

Выбор сервера обсуждений

  1. Откройте книгу Microsoft Excel, в которую будет добавлено обсуждение.

  2. В меню Сервис выберите пункт Совместная работа, а затем выберите мышью команду Web-обсуждения.

  3. На панели инструментов Обсуждения выберите команду Обсуждения и затем команду Параметры обсуждений.

  4. Нажмите кнопку Добавить.

  5. В поле Введите имя сервера обсуждений, предоставленное администратором введите имя сервера обсуждений.

  6. Если администратор установил защиту, используя протокол Безопасный уровень соединения (SSL), установите флажок Требуется безопасное подключение (SSL).

  7. Можно использовать любые имена для названий серверов обсуждения, например “Мой сервер”.

  8. Дважды нажмите кнопку OK.


 Скрытие и отображение обсуждений

Скрытие и отображение обсуждений

  • На панели инструментов Обсуждения нажмите кнопку Отобразить/скрыть область обсуждений [image] .

Совет. Если панель инструментов Обсуждения отсутствует на экране, укажите в меню Сервис команду Совместная работа и выберите пункт Web-обсуждения.


Отображение и скрытие элементов заголовка замечания в обсуждении

Время, тема, краткое имя и имя пользователя появляются в заголовке замечания в обсуждении по умолчанию. Любой из этих элементов может быть отображен или скрыт. Краткое имя — это обычно имя участника обсуждения. Имя пользователя —имя домена пользователя, которое устанавливается системным администратором. Флажок Текст применяется к содержимому замечания. Если этот флажок сброшен, то само замечание становится скрытым.

  1. В меню Сервис выберите команду Совместная работа, а затем команду Web-обсуждения.

  2. На панели инструментов Обсуждения выберите команду Обсуждения и затем команду Параметры обсуждений.

  3. В группе Отображаемые поля обсуждения установите или сбросьте флажки для элементов, которые должны быть отображены или скрыты в каждом заголовке обсуждения.

Примечания. Если выбранный элемент не был отображен (или скрыт) сразу после изменения параметров заголовка, нажмите кнопку Обсуждения на панели инструментов Обсуждения и затем выберите команду Обновить обсуждения.


 Начало обсуждения книги

Начало обсуждения книги

  1. Откройте книгу Microsoft Excel, которую предстоит обсуждать.

  2. В меню Сервис выберите пункт Совместная работа, а затем выберите мышью команду Web-обсуждения.

  3. На панели инструментов Обсуждения выберите Обсуждения и далее выполните команду Добавить обсуждение рядом с книгой.

  4. В меню Тема обсуждения введите тему для обсуждения.

  5. В поле Текст обсуждения добавьте замечания.

  6. Нажмите кнопку OK.

    Появится область обсуждения.

Совет. Чтобы скрыть область обсуждения, нажмите кнопку Отобразить/скрыть область обсуждений [image] на панели инструментов Обсуждения.


Начало обсуждения в обозревателе

Требования к обозревателю для добавления обсуждений на Web-страницы

  1. Откройте в обозревателе Web-страницу, на которую требуется добавить обсуждения.

  2. Выполните одно из следующих действий:

    Если используется Microsoft Internet Explorer версии 5 или более поздней, нажмите кнопку Обсудить Обсудить.

    Если используется Internet Explorer версии 4.x, выберите Панели обозревателя в меню Вид и затем нажмите Обсудить.

    Если используется другой обозреватель, введите http://имя_сервера/msoffice/ в поле Адрес, где имя_сервера — Web-сервер, на котором могут быть сохранены файлы. Информацию об имени Web-сервера, на котором могут быть сохранены файлы, может быть получена у системного администратора.

Примечание. При переходе на Web-страницу через начальную страницу серверных расширений Office, независимо от используемого обозревателя, отображаемая панель инструментов Обсуждения будет отличаться от панели инструментов, отображаемой в Internet Explorer 5. Дополнительные сведения можно найти в справке на начальной странице серверных расширений Microsoft Office.


 Ответ на замечание в обсуждении

Ответ на замечание в обсуждении

  1. Откройте книгу, содержащую обсуждение, к которому требуется присоединиться.

  2. Выберите в меню Сервис команду Совместная работа и подкоманду Web-обсуждения.

    Если область обсуждений не отображена, нажмите кнопку Отобразить/скрыть область обсуждений [image] .

  3. В конце замечания, на которое требуется ответить, нажмите кнопку Показать меню команд Показать меню команд и выберите команду Ответ.

  4. Введите ответ в поле Текст обсуждения.


 Редактирование текста обсуждения

Редактирование текста обсуждения

  1. Откройте книгу, содержащую редактируемый текст обсуждения.

  2. В меню Сервис выберите команду Совместная работа и затем — Web-обсуждения.

    Если область обсуждения не видна, нажмите кнопку Отобразить/скрыть область обсуждений [image] .

  3. В конце замечания, которое нужно отредактировать нажмите кнопку Показать меню команд Показать меню команд, а затем нажмите Изменить.

  4. Под заголовком Текст обсуждения внесите требуемые изменения в текст.

Примечание. Только автор может редактировать вставленный текст.


Отбор обсуждений

Замечания в обсуждении могут быть отобраны таким образом, чтобы просматривать замечания, внесенные определенной персоной в течение определенного промежутка времени. Например, можно просмотреть замечания, сделанные Петром Ивановым в течение последней недели.

  1. Откройте книгу, содержащую фильтруемые замечания.

  2. В меню Сервис выберите пункт Совместная работа, а затем выберите команду Web-обсуждения.

  3. На панели инструментов Обсуждения выберите команду Обсуждения и затем команду Отбор обсуждений.

  4. В поле Созданы выберите имя пользователя, чьи замечания должны появиться в области обсуждений.

  5. В поле Имеют время создания укажите промежуток времени.


Печать обсуждений

Данная процедура используется в случаях, когда требуется вывести на печать все замечания в обсуждении из текущего файла.

  1. На панели инструментов Обсуждения нажмите кнопку Обсуждения и выберите команду Печать обсуждений.

  2. Укажите необходимые параметры.


 Удаление замечания в обсуждении

Удаление замечания в обсуждении

  1. Откройте книгу, содержащую удаляемое замечание.

  2. В меню Сервис выберите команду Совместная работа, а затем команду Web-обсуждения.

    Если область обсуждения не видна, нажмите кнопку Отобразить/скрыть область обсуждений [image] .

  3. В конце замечания, которое нужно удалить нажмите кнопку Показать меню команд Показать меню команд, а затем нажмите Удалить.

  4. Когда появится сообщение, нажмите Да.


Закрытие панели инструментов "Обсуждения"

  • На панели инструментов Обсуждения нажмите кнопку Закрыть.


 Собрания по сети

Собрания по сети

Данный раздел содержит следующие сведения:

Проведение собрания по сети

Участие в собрании по сети

Совместная работа в ходе собрания по сети

Интеграция программы Microsoft NetMeeting с Microsoft Office позволяет совместно работать с данными и обмениваться информацией с пользователями, находящимися в различных местах, в реальном времени, как если бы все участники собрания находились в одной комнате. Начать собрание по сети можно из любой программы Office. (Также можно работать непосредственно в программе NetMeeting, для запуска которой следует открыть пункт Программы меню Пуск Windows, а затем выбрать Microsoft NetMeeting.) При начале собрания по сети из программы Office NetMeeting автоматически запускается в фоновом режиме и позволяет начать совместную работу с файлом. Можно выступать как в роли ведущего собрания, так и принять участие в собрании, проводимом другим пользователем.

Проведение собрания по сети

Начало собрания. Собрание можно назначить заранее с помощью Microsoft Outlook (см. справку Outlook) или начать его непосредственно после открытия книги, с которой требуется работать совместно. Если предполагаемые участники собрания доступны, то после принятия ими приглашения собрание по сети начинается.

Управление книгой. В начале собрания по сети вы являетесь единственным лицом, имеющим возможность управления книгой, хотя остальные участники могут просматривать книгу на экране. Можно разрешить участникам собрания вносить в книгу изменения, включив режим совместной работы, который можно также отключить в любое время. Когда режим совместной работы отключен, другие участники не могут вносить свои изменения, однако они имеют возможность наблюдать за вашей работой. При включении режима совместной работы все участники собрания могут по очереди выполнять изменения и управлять книгой. Когда контроль над книгой осуществляется другим лицом, указатель будет недоступен для использования — не только в книге, но и для любых других целей. Рядом с указателем мыши отображаются инициалы пользователя, осуществляющего управление книгой.

Добавление участников к идущему собранию. На проводимое собрание в любое время можно пригласить дополнительных участников. Для получения приглашения на их компьютерах должен быть запущен NetMeeting. См. Запуск Microsoft NetMeeting.

Возврат в начало

Участие в собрании по сети

В случае приглашения на собрание по сети вы получите сообщение с запросом о принятии участия в назначенном или идущем собрании с указанием даты и времени проведения собрания. При принятии вызова отображается панель инструментов Собрание по сети и на экране появляется книга, с которой работают участники собрания.

Возврат в начало

Совместная работа в ходе собрания по сети

При проведении собрания по сети можно совместно работать с программами и документами, отправлять текстовые сообщения в приложении Разговор, передавать файлы и работать с электронной Доской. Работая совместно, участники собрания могут управлять книгой, просматривая и редактируя ее содержимое. Во время собрания осуществлять управление книгой одновременно может только один пользователь, однако в приложениях «Разговор» или «Доска» при отключении режима совместной работы могут одновременно работать несколько пользователей. Хозяин собрания — единственный пользователь, которому необходимо иметь совместно редактируемый документ и соответствующую программу для его редактирования.

Собрания по сети с использованием NetMeeting

Возврат в начало


 Использование NetMeeting для совещаний в сети

Использование NetMeeting для совещаний в сети

Microsoft NetMeeting обеспечивает возможность тесного взаимодействия с коллегами в режиме реального времени через Интернет или корпоративные интрасети. Приведенными ниже инструкциями можно воспользоваться для знакомства с NetMeeting и организации интерактивных совещаний. См. сведения о собраниях по сети.

Примечание. При первом открытии собрания по сети будет предложено выбрать сервер каталогов и подключиться к нему. Можно выбрать любой сервер каталогов из списка в поле Сервер в области Каталог. Корпоративным пользователям следует узнать у системного администратора имя сервера каталогов, к которому можно подключиться.

  1. Открытие собрания по сети

    Планирование собраний по сети из Microsoft Excel с использованием Microsoft Outlook.

    2. Открытие импровизированного собрания по сети из Microsoft Excel.

  2. Участие в собрании по сети

    Присоединение к собранию по сети.

    Удаление участников с собрания по сети.

    Добавление участников к собранию по сети.

  3. Связь во время собрания по сети

    Управление книгой при проведении собрания по сети.

    Отображение доски во время собрания по сети.

    Отправка вводимых сообщений на собрание по сети.

    Отправка файла участникам собрания по сети.

  4. Завершение собрания по сети

    Завершение собрания по сети.


 Подключение к серверам каталогов NetMeeting

Подключение к серверам каталогов NetMeeting

При первом открытии собрания по сети будет предложено выбрать сервер каталогов для подключения к нему. Можно выбрать любой сервер каталогов из списка в поле Сервер в области Каталог. Корпоративным пользователям следует узнать у системного администратора имя сервера каталогов, к которому можно подключиться.


Назначение собрания по сети в Microsoft Outlook из Microsoft Excel

  1. Откройте книгу, к которой необходимо обеспечить общий доступ.

  2. В меню Сервис укажите на команду Совместная работа и выберите пункт Назначить собрание.

  3. Укажите необходимые параметры.

Дополнительные сведения о назначении собрания по сети содержатся в справке Outlook.


Присоединение к собранию по сети

  • Выполните одно из следующих действий:

    При получении напоминания Microsoft Outlook о собрании по сети нажмите кнопку Запустить NetMeeting, чтобы присоединиться к собранию, или кнопку Прекратить, чтобы отклонить запрос на собрание.

    При получении вызова на собрание по сети нажмите кнопку Принять в диалоговом окне Microsoft NetMeeting, чтобы присоединиться к собранию, или кнопку Отказать, чтобы отклонить собрание. Для получения вызова необходимо запустить Microsoft NetMeeting.


 Отправка сообщений, вводимых с клавиатуры, в собрание по сети

Отправка сообщений, вводимых с клавиатуры, в собрание по сети

Только ведущий собрания по сети может открывать окно разговора из программ Microsoft Office. Если другие участники собрания хотят открыть окно разговора, они должны воспользоваться непосредственно программой Microsoft NetMeeting, щелкнув значок Microsoft NetMeeting на панели задач.

  1. На панели инструментов Собрание по сети нажмите кнопку Отобразить окно разговора [image] .

  2. Введите текст в поле Сообщение и нажмите клавишу Enter.

Совет. Диалог в окне разговора происходит быстрее, если ведущий отключает совместную работу. Если имеется возможность управлять книгой и необходимо отключить совместную работу, нажмите кнопку Разрешить совместное редактирование [image] на панели инструментов Собрание по сети или нажмите клавишу ESC, если управление отсутствует.


Отправка файла участникам собрания по сети

Только ведущий собрания по сети может отправлять файлы участникам собрания из программ Microsoft Office. Если другие участники собрания хотят отправить файл, они должны воспользоваться непосредственно программой Microsoft NetMeeting, щелкнув значок Microsoft NetMeeting на панели задач.

  • Укажите в меню Файл команду Отправить и выберите пункт Участник собрания по сети.

Примечание. Отправленный файл получат все участники собрания по сети. Если требуется отправить файл только одному участнику, отправьте его сообщением электронной почты.


 Отображение доску во время собрания по сети

Отображение доску во время собрания по сети

Только ведущий собрания по сети может отображать доску из программ Microsoft Office. Если другие участники собрания хотят отобразить доску, они должны воспользоваться непосредственно программой Microsoft NetMeeting, щелкнув значок Microsoft NetMeeting на панели задач.

  • На панели инструментов Собрание по сети нажмите кнопку Отобразить доску

    Появится доска, на которой участники собрания могут рисовать или писать комментарии. Для получения справки по использованию доски выберите меню Справка на доске.

Примечание. Чтобы участники имели возможность одновременно работать с доской, ведущий должен отключить совместную работу. Если имеется возможность управлять книгой, нажмите кнопку Разрешить совместное редактирование [image] на панели инструментов Собрание по сети или нажмите клавишу ESC, если управление отсутствует.


 Просмотр списка участников собрания по сети

Просмотр списка участников собрания по сети

  • На панели инструментов Собрание по сети щелкните список участников.

    Список обновляется по мере появления новых и отключения старых участников собрания.


 Управление книгой при проведении собрания по сети

Управление книгой при проведении собрания по сети

Ведущий управляет книгой в момент начала собрания. Ведущий может разрешить совместную участников и отключить совместную работу в любой момент времени. Когда совместная работа разрешена, любой участник может управлять книгой, но в каждый момент времени только один пользователь может управлять книгой. Когда совместная работа отключена, несколько пользователей могут работать одновременно в Разговоре или на Доске.

Управление книгой в качестве ведущего

  • Для разрешения совместной работы нажмите кнопку Разрешить совместное редактирование [image] на панели инструментов Собрание по сети.

  • Для возврата управления при разрешенной совместной работе щелкните любое место в книге.

  • Для отключения совместной работы еще раз нажмите кнопку Разрешить совместное редактирование [image] , если вы управляете книгой, или нажмете клавишу ESC, если управление книгой недоступно.

Управление книгой в качестве участника

  • Для получения управления книгой в первый раз дважды щелкните любое место книги. Затем управление может быть получено щелчком любого места книги.

    Только ведущий собрания может использовать панель управления Собрание по сети. Для получения дополнительных возможностей управления Microsoft NetMeeting во время собрания по сети необходимо использовать непосредственно программу NetMeeting, щелкнув значок Microsoft NetMeeting на панели задач.

Примечание. Инициалы лица, управляющего книгой, появляются рядом с указателем мыши.


 Удаление участников с собрания по сети

Удаление участников с собрания по сети

Примечание. С собрания по сети участников может удалять только организатор этого собрания.

  1. В списке на панели инструментов Собрание по сети выберите имя пользователя, которого требуется удалить с собрания.

  2. Нажмите кнопку Удалить участников [image] .


 Завершение собрания по сети

Завершение собрания по сети

  • На панели инструментов Собрание по сети нажмите кнопку Завершить собрание [image] .

Примечание. Ведущий собрания является единственным лицом, которое может завершить собрание по сети для всей группы. Участники собрания по сети могут отключиться в любой момент, нажав Microsoft NetMeeting на панели задач, а затем нажав кнопку Hang Up на панели инструментов NetMeeting. Когда ведущий завершает собрание, остальные участники автоматически отсоединяются.


 Использование личных параметров рабочей среды на другом компьютере

Использование личных параметров рабочей среды на другом компьютере

Данный раздел содержит следующие сведения:

Что такое профиль пользователя

Доступность личных установок

Дополнительные сведения

Что такое профиль пользователя

Профиль пользователя — это набор установок, определяющих значения различных параметров рабочей среды для отдельного пользователя, включая личные файлы, такие как вспомогательные словари, шаблоны пользователя и списки автозамены и автоформата. Например, в профиле пользователя содержатся такие параметры настройки рабочей среды пользователя, как установленные приложения, значки на рабочем столе и цветовое оформление. Операционная система использует информацию, содержащуюся в профиле пользователя, для конфигурирования компьютера при каждом входе в систему.

Возврат в начало

Доступность личных установок

После настройки системным администратором профиля пользователя личные установки этого пользователя, хранящиеся на сервере, будут доступны при каждом входе в систему. Это особенно удобно, если пользователь работает на различных компьютерах или использует один компьютер совместно с другим пользователем. При входе в систему профиль пользователя загружается с сервера на компьютер, на котором осуществляется вход. Профиль пользователя может использоваться только в той операционной системе, для которой он был создан — например, профиль пользователя операционной системы Microsoft Windows NT 4.0 не может быть использован на компьютере под управлением Microsoft Windows 95. При выходе из системы профиль пользователя копируется обратно на сервер, с тем чтобы все изменения, внесенные в процессе работы, были доступны при следующем входе в систему.

Возврат в начало

Дополнительные сведения

Размещение установок

Возврат в начало


 Размещение установок

Размещение установок

Размещение установок в профиле пользователя зависит от используемой операционной системы и способа конфигурирования системным администратором профиля пользователя на сервере. Профиль пользователя может быть найден в следующем месте:

Корень\Операционная_система\Profiles\Имя_пользователя

где Корень — папка на сервере или папка на диске, в которую вложены все остальные папки (например, C:\), Операционная_система — папка операционной системы (например, Windows или Winnt), а Имя_пользователя — это имя пользователя.

Все установки и специальные файлы Microsoft Office расположены в папке Application Data в папке профиля пользователя. Системный администратор должен сконфигурировать профиль пользователя таким образом, чтобы эти файлы были доступны при входе в сеть с любого компьютера. Пути приведены ниже.

Файлы профиля пользователя | Путь
Программы надстроек (расширение .xla) | Корень\Операционная_система\Profiles\Имя_пользователя\Application Data\Microsoft\Addins Корень\Program Files\Microsoft Office\Office\Library (не перемещается, используется только для обратной совместимости)
Дополнительная папка автозагрузки | Задается пользователем. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.
Списки автозамены | Корень\Операционная_система\Profiles\Имя_пользователя\Application Data\Microsoft\Office
Вспомогательный словарь (расширение .dic) | Корень\Операционная_система\Profiles\Имя_пользователя\Application Data\Microsoft\Proof
Местоположение файла по умолчанию | Может быть задано пользователем. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.
Панель Microsoft Office | Корень\Операционная_система\Profiles\Имя_пользователя\Application Data\Microsoft\Shortcut Bar
Персональные информационные профили (расширение .pip) | Корень\Операционная_система\Profiles\Имя_пользователя\Application Data\Microsoft\Office
Недавно использовавшиеся ярлыки | Корень\Операционная_система\Profiles\Имя_пользователя\Application Data\Microsoft\Office\Recent
Шаблоны (расширение .xlt) | Корень\Операционная_система\Profiles\Имя_пользователя\Application Data\Microsoft\Templates Шаблоны могут также быть расположены в папке XLStart.
Запросы | Корень\Операционная_система\Profiles\Имя_пользователя\Application Data\Microsoft\Queries
Папка XLStart | Корень\Операционная_система\Profiles\Имя_пользователя\Application Data\Microsoft\Excel\XLStart Root\Program Files\Microsoft Office\Office\XLStart
Настроенные панели инструментов (Excel.xlb) | Корень\Операционная_система\Profiles\Имя_пользователя\Application Data\Microsoft\Excel
Галерея диаграмм | Корень\Операционная_система\Profiles\Имя_пользователя\Application Data\Microsoft\Excel


 Способы организации доступа к внешним данным

Способы организации доступа к внешним данным

Данный раздел содержит следующие сведения:

Создание запроса для извлечения внешних данных

Форматирование и изменение запросов

Создание запроса

С помощью Microsoft Query можно создать файл запроса (с расширением .dqy или .oqy) для извлечения внешних данных из источников, отличных от Microsoft Excel. После извлечения данных их можно сделать доступными для других пользователей несколькими способами.

  • Создание запроса. Если внешние не-OLAP данные доступны другим пользователям, можно извлечь данные с помощью Query, а затем предоставить файл запроса .dqy в совместное пользование.

  • Создание файла для подключения к данным OLAP. Если внешние данные находятся в базах данных OLAP, можно создать файл запроса .oqy для подключения к базе данных и затем совместно использовать этот файл с другими людьми. См. сведения о типах файлов запросов, их создании и использовании.

  • Создание шаблона отчета. При создании отчетов, основанных на периодически обновляемых данных, можно создать запрос для извлечения данных и помещения их в книгу, а затем сохранить книгу в качестве шаблона отчета.

После создания запроса можно открыть файл запроса к базе данных и обновить внешние данные или использовать шаблон отчета для извлечения внешних данных.

Возврат в начало

Форматирование и изменение запросов

После сохранения запроса или шаблона отчета можно изменить как сам запрос, так и формат запроса.

  • Изменение формата и макета. Для диапазона внешних данных можно изменить формат и макет.

  • Изменение шаблона отчета. После создания шаблона отчета можно внести в отчет необходимые изменения.

Возврат в начало


 Внедрение книг в документы или формы Lotus Notes

Внедрение книг в документы или формы Lotus Notes

Для обеспечения обмена данными между Lotus Notes и Microsoft Excel можно вставить книгу Excel в качестве внедренного объекта в документ или форму Notes.

Внедренные книги в документах Lotus Notes. Если требуется вставить одну книгу в отдельный документ Notes или вставить разные книги в несколько документов Notes, можно вставить книгу в качестве внедренного объекта в редактируемое поле RTF. Если в документе Notes требуется использовать возможности обмена данными полей Notes/FX, документ уже должен содержать поля Notes/FX, которые необходимы для обмена данными. Вставлять поля в документы Notes нельзя; поля могут быть вставлены только в формы Notes.

Внедренные книги в формах Lotus Notes. Также можно вставить книгу в качестве внедренного объекта в создаваемую форму Notes. Например, если требуется создать несколько документов Notes, содержащих одну и ту же внедренную книгу, следует вставить внедренную книгу в форму Notes при ее создании. В этом случае внедренная книга будет присутствовать во всех новых документах или формах Notes, создаваемых на основе имеющейся формы. При добавлении в форму с внедренной книгой полей Notes/FX все новые документы и формы Notes, создаваемые на основе этой формы, будут обладать возможностями обмена данными полей Notes/FX. Вставить внедренную книгу в документ или форму Lotus Notes можно с использованием как Lotus Notes, так и Excel.


 Об обновлении полей Lotus Notes

Об обновлении полей Lotus Notes

В зависимости от типа используемых полей обновлять поля Lotus Notes можно либо путем изменения свойств внедренного объекта Microsoft Excel, либо посредством изменения текстового поля непосредственно в документе Lotus Notes.

Однонаправленные и двунаправленные поля. В Lotus Notes можно использовать два типа полей Notes/FX.

  • Однонаправленные поля. Некоторые поля предоставляют информацию для обмена только в одном направлении — из внедренной книги в документ Notes. Например, свойство «Создан» файла книги Excel является однонаправленным полем, соответствующим полю Notes «DateCreated». Изменения свойства «Создан» в Excel автоматически отражаются в поле «DateCreated» документа Notes; однако изменение поля «DateCreated» документа Notes не окажет влияния на свойство «Создан» файла книги Excel.

  • Двунаправленные поля. Другие поля допускают обмен информацией в двух направлениях — из внедренной книги в документ Notes и из документа Notes во внедренную книгу. Двунаправленные поля обновляются во внедренной книге при открытии или активизации книги и в документе Notes при закрытии книги и возврате к документу Notes. Например, «Название» — это двунаправленное поле. При изменении свойства «Название» файла книги Excel изменение отражается в поле «Title» документа Notes, а при изменении поля «Title» документа Notes — в свойстве файла книги Excel. Поля, соответствующие дополнительным свойствам файлов книг, задаваемых пользователем, также являются двунаправленными.

См. список однонаправленных и двунаправленных полей.

Обновление полей Notes из книги. Имеется возможность обновлять свойства во внедренной книге. Внесенные изменения автоматически отображаются в документе Lotus Notes.

Обновление свойств книги Excel из Notes. Также можно обновлять двунаправленные поля непосредственно в документе Notes. Внесенные при этом изменения будут автоматически отображены в книге.


 Создание формы Lotus Notes, содержащей внедренную книгу

Создание формы Lotus Notes, содержащей внедренную книгу

Описанная процедура относится к Lotus Notes 4.0. Чтобы ознакомиться с соответствующей процедурой для Lotus Notes 3.x, нажмите кнопку [image] .

  1. Чтобы создать новую форму в Lotus Notes, выберите нужную базу данных, в меню Create выберите Design и затем Form.

    Чтобы изменить существующую форму, выберите базу данных, содержащую форму. В меню View выберите Design. В области Design панели перехода щелкните Forms. Дважды щелкните форму.

  2. Щелкните место, в котором должен появиться внедренный объект.

  3. В меню Create выберите Object.

  4. Чтобы вставить новую пустую книгу в виде внедренного объекта, щелкните Create a new object, а затем в поле Object type выберите Microsoft Excel Worksheet.

    Чтобы вставить существующую книгу в виде внедренного объекта щелкните Create an object from a file, а затем введите имя книги или щелкните кнопку Browse и выберите имя из списка.

  5. Чтобы отобразить внедренный объект в виде значка, установите флажок Display as icon.

Примечание. Если в поле Object type выбран Microsoft Excel Worksheet в форму Lotus Notes будет вставлена целая книга Microsoft Excel. В форме Lotus Notes одновременно отображается только один лист или диаграмма. Чтобы просмотреть другие листы, следует дважды щелкнуть объект Microsoft Excel и затем выбрать нужный лист.


Внедрение книги в документ или форму Lotus Notes

Предполагаемые действия

Вставка книги Microsoft Excel в виде внедренного объекта в документ Lotus Notes

Создание формы Lotus Notes, содержащей внедренную книгу

Не можете сделать выбор?


 Импорт книги в документ или форму Lotus Notes

Импорт книги в документ или форму Lotus Notes

Чтобы эта процедура была доступна, во время установки необходимо установить флажок конвертеров для Lotus Notes (Конвертеры и фильтры, Конвертеры текстовых файлов). Более подробные сведения об установке программ и их компонентов можно получить нажав кнопку [image] .

  1. В Lotus Notes откройте нужный документ или форму.

  2. В документе щелкните форматируемое поле, затем в меню File выберите команду Import.

    Щелкните форму и в меню File выберите команду Import.

  3. В Lotus Notes 4.0 в поле Files of type выберите Microsoft Excel.

    В Lotus Notes 3.x в поле List files of type выберите Microsoft Excel.

  4. Дважды щелкните в списке файлов импортируемую книгу.


 Вставка книги Microsoft Excel в виде внедренного объекта в документ Lotus Notes

Вставка книги Microsoft Excel в виде внедренного объекта в документ Lotus Notes

Описанная процедура относится к Lotus Notes 4.0. Чтобы увидеть соответствующую процедуру для Lotus Notes 3.x нажмите кнопку [image] .

  1. Выберите необходимую базу данных в Lotus Notes, затем в меню Create выберите форму, из которой необходимо создать документ.

    Форма должна содержать изменяемое форматируемое поле.

  2. Щелкните изменяемое форматируемое поле.

  3. В меню Create выберите Object.

  4. Чтобы вставить новую пустую книгу в виде внедренного объекта выберите Create a new object, а затем в поле Object type выберите Microsoft Excel Worksheet.

    Чтобы вставить существующую книгу в виде внедренного объекта выберите Create an object from a file, а затем в поле File введите имя книги или щелкните кнопку Browse и выберите имя из списка.

  5. Чтобы отобразить внедренный объект в виде значка, установите флажок Display as icon.

Примечание. Если в поле Object type выбран Microsoft Excel Worksheet в документ Lotus Notes будет вставлена целая книга Microsoft Excel. В форме Lotus Notes одновременно отображается только один лист или диаграмма. Чтобы просмотреть другие листы, следует дважды щелкнуть объект Microsoft Excel и затем выбрать нужный лист.


Обновление полей Lotus Notes

Предполагаемые действия

Обновление одно и двунаправленных полей из внедренной книги

Обновление двунаправленных полей из Lotus Notes

Дополнительные сведения


 Использование данных из книги в представлениях Lotus Notes

Использование данных из книги в представлениях Lotus Notes

Чтобы отобразить данные книги в представлениях Lotus Notes, следует в Microsoft Excel для ячеек или диапазона ячеек определить имя, создать специальное свойство файла, связанное с именем Microsoft Excel, и затем в форме Lotus Notes создать поле с именем специального свойства файла. Кроме отображения данных книги в представлениях Lotus Notes, можно отобразить некоторые свойства файла, например название и автора книги.

Более подробные сведения о том, как задать одно- и двунаправленные поля, можно получить, нажав кнопку [image] .

  1. Вставьте книгу Microsoft Excel в документ Lotus Notes в виде внедренного объекта.

    Инструкции

    Если отсутствует документ Notes, содержащий форматируемое поле, и поля, соответствующие свойствам файла книги, следует разработать форму Lotus Notes, содержащую внедренную книгу.

    Инструкции

  2. В Lotus Notes 4.0 щелкните в документе или форме правой кнопкой мыши внедренную книгу и в контекстном меню выберите Open.

    В Lotus Notes 3.x, дважды щелкните внедренную книгу в документе или форме.

  3. В Microsoft Excel щелкните лист или диаграмму, содержащую нужные в Lotus Notes данные, и затем выделите эти данные.

  4. В поле Имя строки формул введите имя и нажмите ENTER.

  5. Выберите команду Свойства в меню Файл.

  6. Выберите вкладку Прочие.

  7. В поле Название введите имя специального свойства файла.

  8. Установите флажок Для объекта.

  9. В поле Значение введите имя, заданное на шаге 4 и нажмите Добавить.

  10. Создайте форме Lotus Notes соответствующее поле. В поле Name следует вводить имя специального свойства файла Microsoft Excel, а не определенное в Microsoft Excel имя.

  11. Выделите свойства или данные, которые нужно включить в представление.

Примечание. Поименованные ячейки или диапазоны ячеек, которые защищены или содержат формулы, обновляются только в одном направлении — от Microsoft Excel к Lotus Notes. Если поле изменяется в Lotus Notes, это никак не отражается в Microsoft Excel.


Использование меню Action Lotus NotesFlow

Lotus NotesFlow представляет собой систему управления документооборотом, обеспечивающую открытое взаимодействие между базами данных Lotus Notes и другими программами, такими как Microsoft Excel, Word и PowerPoint. Возможности NotesFlow могут быть также использованы для маршрутизации форм, отправки напоминаний, подтверждений запроса и обработки, а также для запуска запланированных пакетных заданий. Когда Microsoft Excel принимает участие в NotesFlow, слева от меню Окно появляется меню Action. Команды, содержащиеся в меню Action, отражают все возможные действия. Доступные в меню Action команды определяются способом разработки формы Lotus Notes. Если форма Lotus Notes разрабатывается для использования возможностей NotesFlow, объявляются действия, которые будут доступны в других программах, поддерживающих NotesFlow.

Для использования возможностей Lotus NotesFlow необходимо наличие Lotus Notes 4.0 или более поздней версии. Более подробные сведения об использовании Lotus NotesFlow содержатся в документации по Lotus Notes.


 О получении уведомлений об изменениях файла или папки на Web-сервере

О получении уведомлений об изменениях файла или папки на Web-сервере

Возможность проведения обсуждений доступна только в том случае, если на сервере установлены серверные расширения Microsoft Office. Для получения дополнительных сведений обратитесь к системному администратору.

Данный раздел содержит следующие сведения:

Подписка на файл или папку

Получение уведомлений об изменениях файлов на удаленных Web-серверах

Отмена подписки на файл или папку

Дополнительные сведения

Подписка на файл или папку

Имеется возможность получать по электронной почте сообщения об изменениях, внесенных в файл или папку на Web-сервере с серверными расширениями Office. Такая возможность становится доступной при подписке на файл или папку. При осуществлении подписки вам будут автоматически по определенному расписанию доставляться уведомления об изменении, удалении или перемещении файла или папки, а также о создании новых файлов в папке, на которую осуществлена подписка. Кроме того, имеется возможность получать уведомления об удалении из файла комментариев обсуждения и добавлении новых комментариев.

Возврат в начало

Получение уведомлений об изменениях файлов на удаленных Web-серверах

Обсуждения хранятся отдельно от соответствующего файла в базе данных на Web-сервере с серверными расширениями Office. Это позволяет добавлять замечания и комментарии в файл, хранящийся на любом Web-сервере. При подписке на файл, который находится не на вашем сервере с серверными расширениями Office, уведомления об изменении содержимого файла доставляться не будут, однако вы будете получать уведомления при изменении любых комментариев, связанных с этим файлом.

Возврат в начало

Отмена подписки на файл или папку

Чтобы отказаться от получения уведомлений об изменениях файла или папки, следует щелкнуть гиперссылку в одном из таких сообщений. Другим способом отказа от получения уведомлений является удаление подписки на начальной странице серверных расширений Microsoft Office с помощью обозревателя. Для получения доступа к начальной странице серверных расширений Office из обозревателя следует ввести в поле Адрес адрес http://ИмяСервера/msoffice/, где ИмяСервера — это имя вашего Web-сервера.

Возврат в начало

Дополнительные сведения

Отмена получения уведомления об изменениях в файле или папке на Web-сервере

Возврат в начало


 Получение уведомлений об изменениях файла или папки на Web-сервере

Получение уведомлений об изменениях файла или папки на Web-сервере

  1. Откройте файл или папку, о которых требуется сообщать.

  2. Выберите в меню Сервис команду Совместная работа и подкоманду Web-обсуждения.

  3. На панели инструментов Обсуждения нажмите кнопку Подписаться.

  4. В группе Подписка на выполните одно из следующих действий.

    Для того чтобы подписаться на файл, открытый в данный момент, выберите вариант Файл.

    Для того чтобы подписаться на все файлы в Web-папке, либо выберите вариант Папку и задайте нужные параметры, либо введите адрес другой папки на Web-сервере.

  5. В поле В случае выберите условия, при возникновении которых требуется уведомление об изменениях.

  6. В поле Адрес введите адрес электронной почты.

  7. В поле Время выберите частоту уведомления.

Примечание. При подписке на файл, расположенный не на данном сервере, использующем серверные расширения Microsoft Office, уведомления об изменениях содержимого файла приходить не будут, но будут приходить уведомления об изменениях замечаний в ходе обсуждения, связанного с этим файлом.


Отмена получения уведомления об изменениях в файле или папке на Web-сервере

  1. Откройте в Microsoft Outlook одно из сообщений, уведомляющих об изменениях.

  2. Для отмены получения уведомлений щелкните гиперссылку в конце сообщения.

Совет. Отменить получение уведомлений также можно, выбрав Управление Web-подписками начальной странице серверных расширений Office. Чтобы получить доступ к начальной странице серверных расширений Office, наберите http://имя_сервера/msoffice/, где имя_сервера — это имя Web-сервера организации, в поле Адрес в Web-обозревателе.


Разрешение вопросов, связанных с собранием по сети

В чем именно заключаются сложности?

Не удается вывести на печать или сохранить открытую в собрании по сети книгу Excel

Отображение клетчатого узора на экранах других участников собрания по сети

Отсутствие некоторых объектов, доступных другим участникам собрания по сети

Имя предполагаемого участника собрания по сети отсутствует в списке

Подключение к серверам каталогов NetMeeting


Разрешение вопросов: обсуждения в книгах

В чем именно заключаются сложности?

В книгу не удается добавить замечание

В заголовке обсуждения не отображается имя текущего пользователя

Не отображаются данные обсуждений в книге

Вывод на панели обсуждений сообщения о потере или несоответствии данных

Выбор обозревателя для обсуждений на Web-страницах


Разрешение вопросов при использовании личных параметров настройки на другом компьютере

В чем именно заключаются сложности?

Личные параметры настройки недоступны при входе в систему.

Пользовательские шаблоны не отображаются на соответствующей вкладке.


 Общие сведения о связанных и внедренных объектах

Общие сведения о связанных и внедренных объектах

Создание связанных или внедренных объектов. При копировании данных между Microsoft Excel и любой программой, поддерживающей OLE, такой как программы Microsoft Office, данные можно вставлять в документы как связанные объекты или внедренные объекты.

Связанные и внедренные объекты в документе

Использование связанных объектов. Связанные объекты используются в случае, если необходимо, чтобы данные в конечном файле обновлялись при изменении данных в исходном файле. При использовании связанного объекта исходные данные хранятся в исходном файле. В конечном файле отображается представление связанных данных, однако хранится в нем только информация о местоположении исходных данных (и размере, если объект является диаграммой Excel). Для поддержания связи с исходными данными файл, в котором они хранятся, должен быть доступен на локальном диске или в сети. Связанные данные обновляются автоматически при изменении данных в исходном файле. Например, если в книге Excel выделяется диапазон ячеек, который затем вставляется в качестве связанного объекта в документ Word, то при изменении данных в книге данные, находящиеся в документе Word, также будут изменены.

Использование внедренных объектов. Внедренные объекты используются в случае, если обновление скопированных данных при изменении их в исходном файле не требуется. При отсутствии доступа к исходным данным можно открыть файл на любом компьютере и просмотреть внедренный объект. Поскольку внедренный объект не связан с исходным файлом, он не обновляется при изменении исходных данных. Чтобы изменить внедренный объект, дважды щелкните его для открытия и редактирования в исходной программе. Исходная программа (или другая программа, позволяющая редактировать объект) должна быть установлена на компьютере. При копировании данных в качестве внедренного объекта конечный файл занимает больше дискового пространства, чем при связывании данных.

Как связать или внедрить объект. Если при использовании команды Специальная вставка (меню Правка) выбран параметр Вставить связь, данные вставляются как связанный объект. Если выбраны параметры Объект тип объекта и вставить, данные вставляются как внедренный объект. Команда Объект и большинство команд подменю Рисунок (меню Вставка) также позволяют вставлять данные в качестве связанных или внедренных объектов. Основными различиями между связанными и внедренными объектами являются место хранения данных и способ обновления объекта после помещения его в конечный файл.

Примечание. Если при использовании команды Специальная вставка (меню Правка) выбраны параметр Вставить связь и формат, отличающийся от Объект тип объекта, то связь данных осуществляется с помощью средств динамического обмена данными (Dynamic Data Exchange, DDE). Для получения дополнительных сведений о DDE обратитесь к изданию Ресурсы Microsoft Office 2000.

Дополнительные сведения

Обмен данными между программами Office с использованием связывания и внедрения объектов


 Перемещение данных между программами

Перемещение данных между программами

При работе с документами из различных программ при помощи мыши можно перемещать и копировать данные, а также создавать связанные объекты, ярлыки, или гиперссылки. Программы, между которыми перемещаются данные, должны поддерживать механизм ОLE.

  1. Расположите окна программ на экране так, чтобы были видны и исходный файл, и конечный файл. Необходимо одинаково хорошо видеть и данные, которые нужно переместить, и место, куда их нужно переместить.

  2. Выделите данные и затем перетащите их с помощью правой кнопки мыши на новое место в другой программе. При перетаскивании данных из Microsoft Excel следует устанавливать указатель на границу выделения.

  3. В контекстном меню выберите необходимую команду.

Совет. Чтобы предотвратить прокрутку при перетаскивании данных, следует быстро перенести данные в окно другой программы или держать при перетаскивании нажатой клавишу ALT. Перед помещением данных на нужное место отпустите клавишу ALT. (Этот способ не работает при перемещении данных из Microsoft Word или Microsoft Access.)


 Формат данных, вставленных из буфера обмена

Формат данных, вставленных из буфера обмена

Отображение вставленных данных в документе. Скопированные или вырезанные данные в другую программу вставляются, если это возможно, в формате, позволяющем их редактировать. Например, ячейки рабочих листов Microsoft Excel и записи баз данных Microsoft Access вставляются в Word как таблицы Word, с сохранением ширины столбцов и параметров форматирования шрифта. Текст Word, содержащий символы табуляции, вставляется в ячейки листа Microsoft Excel с распределением по строкам и столбцам; записи из Microsoft Access вставляются на лист Microsoft Excel в виде строк, с отображением каждого поля в отдельном столбце.

Если программа не позволяет редактировать данные, то они вставляются в качестве внедренного объекта, который можно редактировать в исходной программе, открыв объект двойным щелчком мыши. Если данные не могут быть вставлены в качестве внедренного объекта (например, при копировании данных из программы, не поддерживающей механизм ОLE), то они вставляются в виде неизменяемого рисунка, изменить который нельзя.

Форматирование вставленных данных. Для управления форматом данных, вставляемых из буфера обмена, следует вместо команды Вставить [image] использовать команду Специальная вставка (меню Правка).


 Использование формулы для связи с данными в программах на других компьютерах

Использование формулы для связи с данными в программах на других компьютерах

Если команды Копировать и Специальная вставка нельзя использовать для создания удаленной ссылки, связь с данными в других приложениях можно установить с помощью формулы с удаленными ссылками. При этом данные будут отображаться на листе как результат формулы.

Формула состоит из трех частей: имени приложения; имени файла или раздела документа; диапазона ячеек, значения, поля или данных, на которые сделана ссылка. Приведенный ниже пример иллюстрирует различные части формулы с удаленными ссылками и используемые в ней разделители.

Формула с разделителями

Символ (|) разделяет имя программы и имя документа или раздела. Восклицательный знак (!) отделяет имя документа или раздела от диапазона, значения поля или данных, на которые установлена ссылка.

Использование одиночных кавычек Если имя приложения, документа, раздела или элемента данных содержит пробелы или специальные символы формул, например двоеточие (:) или знак минуса ( – ), либо если имя имеет вид ссылки на ячейку, заключите его в одиночные кавычки.

Необходимость поддержки DDE Приложение, с данными которого требуется установить связь, должно поддерживать динамический обмен данными (DDE). Чтобы узнать, поддерживает ли приложение DDE, а также для выяснения имени DDE и данных раздела для приложения, обратитесь к поставщику программы. Чтобы получить более подробные сведения о DDE, обратитесь к руководству Microsoft Office 2000 Resource Kit.


 Панель Microsoft Office

Панель Microsoft Office

Если установлен Microsoft Office, то для удобства доступа к наиболее часто используемым программам можно воспользоваться панелью Office. Эта панель позволяет быстро начать разработку нового плана бюджета, найти и открыть книгу, послать сообщение по электронной почте, запланировать встречу, создать задачу, заметку, контакт или запись в дневнике Microsoft Outlook.

Работа с панелью Microsoft Office

Панель Office можно переместить в любое положение на экране. Если панель закреплена, то ее можно скрыть, выбрав в меню Панель Office [image] команду Автоматически убирать с экрана. Когда потребуется снова воспользоваться панелью Office, для ее отображения нужно подвести указатель к тому краю экрана, на котором она закреплена.

Для быстрого создания файла любого типа при помощи панели Microsoft Office — например, подшивки Office Binder или книги Microsoft Excel — следует нажать кнопку Создать документ Microsoft Office [image] . Перейдите на вкладку, содержащую нужный тип файла, а затем дважды щелкните мышью нужный файл или шаблон. Необходимая программа загружается автоматически.

Для быстрого поиска и открытия файлов из панели Office нажмите кнопку Открыть документ Microsoft Office [image] , найдите в списке нужный файл и дважды щелкните его.

Настройка панели Microsoft Office

При первом запуске Microsoft Office на панели Microsoft Office отображается только панель инструментов Office. Для того чтобы добавить на панель Office другие кнопки и панели инструментов, выберите в меню Панель Microsoft Office [image] команду Настройка. Например, чтобы добавить на панель Office панель инструментов Рабочий стол, установите флажок Рабочий стол на вкладке Панели инструментов. Это позволит легко открывать файлы и программы, находящиеся на рабочем столе Windows, даже если его не видно. Для того чтобы переключиться на другую панель инструментов в панели Office, щелкните значок нужной панели инструментов. Название кнопки или панели инструментов отображается при удержании указателя на значке этой кнопки или панели инструментов.

На панель Microsoft Office можно также добавлять свои собственные кнопки и панели инструментов. Для того чтобы добавить часто используемый файл или программу в качестве кнопки панели инструментов, перетащите на панель Office соответствующий файл из проводника Windows или окна «Мой компьютер».

Если панель Microsoft Office недоступна, возможно, она не установлена. При установке панели Office она настраивается для автоматического запуска при запуске Windows. Инструкции по установке программы или компонента Office.


 Работа со временем, встречами, заданиями и сообщениями при помощи панели Office

Работа со временем, встречами, заданиями и сообщениями при помощи панели Office

Если на компьютере установлен Microsoft Office и Microsoft Outlook, в панели инструментов Office на панели Office есть шесть ярлыков, представляющих наиболее распространенные свойства Microsoft Outlook.

Действие | Чтобы
Создать сообщение | Отправки почты из Outlook
Создать встречу | Добавления в календарь новой встречи в Outlook
Создать задачу | Добавления новой задачи в список заданий в Outlook
Создать контакт | Создания контакта в Outlook
Создать запись в журнале | Записи действий вручную в журнале в Outlook
Создать примечание | Создания примечаний в Outlook


Обмен данными между программами Office

Предполагаемые действия

Создание нового внедренного объекта и его вставка в книгу

Вставка содержимого существующего файла в качестве связанного или внедренного объекта

Копирование данных из существующего файла в качестве связанного или внедренного объекта

Дополнительные сведения


 Способы обмена данными между Microsoft Excel и другими программами Office

Способы обмена данными между Microsoft Excel и другими программами Office

При работе с Microsoft Excel и другими программами Microsoft Office данные, созданные в Microsoft Excel, могут быть использованы в других программах Office, и наоборот. Обмениваться данными можно различными способами в зависимости от того, в каком виде они должны быть представлены, должны ли они изменяться при редактировании исходного файла, с каким приложением должен происходить обмен. Для получения дополнительных сведений об использовании свойств и команд, приведенных ниже, обратитесь к помощнику Office или к команде Вызов справки в меню справки Microsoft Excel.

Чтобы | Использовать
Скопировать данные из одной программы в другую | Копирование и вставку
Быстро скопировать или переместить данные между двумя открытыми файлами | Редактирование с помощью мыши для перемещения выделенных данных в другой файл (с использованием правой кнопки мыши)
Использовать в Microsoft Excel файл, созданный в другой программе | Команду Открыть (меню Файл) — для открытия файла после сохранения его в формате, с которым может работать Excel, например в текстовом (*.txt) формате
Использовать книгу Microsoft Excel в другой программе | Команду Сохранить как (меню Файл) — для сохранения книги в формате, позволяющем использовать книгу в другой программе, например в текстовом (*.txt) формате для Microsoft PowerPoint или в формате Книга Microsoft Excel (*.xls) для Microsoft Word или Microsoft Access
Перейти к данным в другом файле | Команду Вставить как гиперссылку (меню Правка) — для вставки гиперссылки на данные
Скопировать данные из другого файла с автоматическим их обновлением при каждом изменении данных в исходном файле | Кнопку Вставить связь в диалоговом окне Специальная вставка (меню Правка) — для вставки данных в качестве связанного объекта
Скопировать данные из файла, созданного в другой программе, так чтобы данные можно было легко редактировать в исходной программе, не покидая текущую книгу | Параметры вставить и Объект тип объекта в диалоговом окне Специальная вставка (меню Правка) — для вставки данных в качестве связанного объекта
Одновременно работать с книгой вместе с другими пользователями | Установить книгу как общую книгу
Сделать данные доступными для общего использования | Поместить книгу в общую папку на сервер Microsoft Exchange
Отправить файл по очереди нескольким получателям, чтобы они могли просмотреть его внести комментарии | Отправить файл по маршруту с помощью электронной почты
Отправить файл одновременно всем получателям | Отправить файл по электронной почте
Совместно работать с файлом вместе с одним или несколькими пользователями при проведении собрания по сети | Назначить собрание по сети


Копирование данных Microsoft Excel в Word или PowerPoint

Ячейки листа и диаграммы могут быть скопированы из Microsoft Excel в документы Word и PowerPoint. Для включения результата расчета в текст документа или в слайд можно копировать ячейку с формулой. При этом имеется возможность выбрать вставку в Word или PowerPoint только текущих данных или установить связь копируемых данных с исходными данными в Microsoft Excel. Если устанавливается такая связь, данные, скопированные в Word или PowerPoint, обновляются при каждом обновлении исходных данных в Microsoft Excel.

Предполагаемые действия

Копирование диаграммы Microsoft Excel в документ Word или PowerPoint

Копирование ячеек листа Excel в документ Word или PowerPoint

Копирование результатов в документ Word или в документ PowerPoint


Использование данных Microsoft Excel при создании почтовых документов в Word

Для просмотра этого раздела щелкните рисунок:

Для просмотра этого раздела щелкните рисунок.

Чтобы вывести справку по данному разделу с помощью клавиатуры, нажмите клавишу F6 для активизации окна раздела, выделите рисунок клавишей TAB и нажмите ENTER.


Копирование таблицы Word на лист Microsoft Excel

Для просмотра этого раздела щелкните рисунок:

Для просмотра этого раздела щелкните рисунок.

Чтобы вывести справку по данному разделу с помощью клавиатуры, нажмите клавишу F6 для активизации окна раздела, выделите рисунок клавишей TAB и нажмите ENTER.


Использование Microsoft Outlook для поиска файлов и документов Outlook

Для выполнения этой процедуры необходимо установить на компьютере и настроить Microsoft Outlook.

  • Нажмите кнопку Пуск на панели задач Windows, выберите команду Найти, а затем — команду Работа с Microsoft Outlook.

Примечание. Для поиска всех файлов на компьютере должна быть установлена система интегрированного управления файлами Microsoft Outlook. Установка программы или компонента.


Добавление имен и адресов из книги Microsoft Excel в список контактных лиц Outlook

Для выполнения этой процедуры необходимо установить на компьютере и выполнить настройку программы Microsoft Outlook.

  1. Закройте книгу, содержащую список имен и адресов.

  2. Запустите Outlook.

  3. Выберите команду Импорт и Экспорт в меню Файл.

  4. Из списка выберите Импорт из другой программы или файла.

  5. Следуйте инструкциям мастера.


Добавление имен и адресов из списка контактных лиц Outlook в книгу Microsoft Excel

Для выполнения этой процедуры необходимо установить на компьютере и выполнить настройку программы Microsoft Outlook.

  1. Запустите Outlook.

  2. Выберите команду Импорт и Экспорт в меню Файл.

  3. Выберите Экспорт в файл.

  4. Следуйте инструкциям мастера.


Приложения, необходимые для отправки книг по электронной почте и просмотра сообщений с вложенными книгами

Приложения, необходимые для отправки сообщений электронной почты и книг

Отправка сообщения электронной почты или файла HTML. Требуются Excel 2000 и Outlook 2000.

Отправка книги по электронной почте в качестве вложения в формате Excel (.xls). Требуется Excel 2000 и одно из следующих приложений для работы с электронной почтой:

  • Outlook, Outlook Express, клиент Microsoft Exchange или другое 32-разрядное приложение для работы с электронной почтой, совместимое с интерфейсом MAPI (Messaging Application Programming Interface). Убедитесь, что в папке System каталога Windows имеется файл Mapi32.dll.

  • Lotus cc:Mail или другое 16-разрядное приложение для работы с электронной почтой, совместимое с протоколом VIM (Vendor Independent Messaging). Убедитесь, что в папке System каталога Windows имеются файлы Mapivi32.dll, Mapivitk.dll и Mvthksvr.exe.

Примечания

  • Создание маршрута или отправка книги по электронной почте может не выполняться при использовании некоторых шлюзов.

  • Некоторые параметры отправки сообщений, например отслеживание сообщения и голосование, доступны только при использовании Microsoft Exchange Server.

Приложения, необходимые для просмотра сообщений электронной почты и вложенных документов

Сообщение электронной почты или книга в формате HTML. Для просмотра сообщения или книги необходимы Outlook 2000 или Web-обозреватель, либо почтовая система (например, Outlook 98 или более поздняя версия), позволяющая читать документы в формате HTML.

Книга, отправленная по маршруту или в качестве вложения сообщения в формате Excel (.xls). Для просмотра книги, отправленной в качестве вложения, необходима программа Excel 97 или ее более поздняя версия.


Отправка документов другим пользователям

Требования, которым должна удовлетворять система для отправки документов

Предполагаемые действия

Отправка листа или книги по электронной почте в качестве вложения

Отправка данных листа в качестве текста сообщения

Отправка книги по маршруту

Помещение книги в папку Microsoft Exchange

Работа с книгой при проведении собрания по сети

Совместный доступ к книге

Дополнительные сведения


 Отправка документов другим пользователям

Отправка документов другим пользователям

Данный раздел содержит следующие сведения:

Использование электронной почты для отправки книг

Отправка книг по маршруту

Помещение книг в общие папки Microsoft Exchange

Работа с книгой при проведении собрания по сети

Использование общих книг

Использование электронной почты для отправки книг

Так же, как и сообщение электронной почты, можно отправить копию книги или листа прямо из Excel. Чтобы отправить книгу по электронной почте непосредственно из Excel, нажмите кнопку Сообщение [image] на панели инструментов Стандартная. Отправить сообщение можно следующими способами.

Отправка листа в качестве текста сообщения. При отправке копии листа по электронной почте лист отправляется в формате HTML в качестве текста сообщения. Это означает, что получатель может только просматривать данные и не может, например, использовать формулы, сортировать данные или фильтровать их.

Можно отправить целый лист или вырезать и вставить в сообщение данные из имеющейся книги.

Получатели могут просматривать полученный лист в любой программе электронной почты, позволяющей читать сообщения в формате HTML. Для просмотра листа не требуется, чтобы на компьютерах получателей был установлен Excel; тем не менее, имеются другие системные требования для просмотра книги или листа, отправки его в сообщении или по маршруту или помещения в общую папку. При отправке копии листа по электронной почте заголовок сообщения отображается в Excel, что позволяет указать адресатов сообщения и установить любые необходимые параметры сообщения.

После отправки листа заголовок сообщения закрывается и книга остается открытой. Список получателей, а также параметры сообщения и вложения сохраняются в книге. При новой отправке копии книги введенные при предыдущей отправке сведения отображаются в заголовке сообщения. Это свойство является полезным при отправке обновленных версий листа одни и тем же людям.

Отправка листа в качестве вложения. Если требуется сопроводить лист вводными или описательными сведениями, следует либо отправить лист в качестве вложения и добавить необходимые сведения в текст сообщения, либо внести описательные сведения непосредственно на лист при отправке листа в качестве основного текста сообщения.

Если получатель использует Office 97 или более ранней версии, лучше отправить лист в качестве вложения в сообщении электронной почты. При отправке листа в качестве текста сообщения будут утеряны параметры форматирования.

Отправка книги в качестве вложения. Для отправки книги по электронной почте необходимо вложить ее в сообщение. Это может потребоваться также в случае, если получатель не имеет HTML-совместимой программы электронной почты. Вложение не преобразуется в формат HTML, поэтому его можно просмотреть с помощью Excel 97 или более поздней версии.

Дополнительные сведения

Отправка нескольких вложений в сообщении электронной почты

Возврат в начало

Отправка книг по маршруту

Если требуется, чтобы книгу просмотрели другие пользователи, можно отправить ее по маршруту с помощью электронной почты. Можно либо направить книгу от одного получателя к другому, с тем чтобы каждый получатель видел комментарии, внесенные предыдущими получателями, либо отправить ее членам списка рассылки, чтобы все адресаты получили книгу одновременно. (Если требуется отправить книгу членам списка рассылки одному за другим, вместо указания псевдонима списка следует отправить ее по маршруту, указав членов списка по отдельности.) По мере продвижения книги по маршруту можно отслеживать ее состояние. После того, как все получатели просмотрели книгу, она автоматически возвращается обратно.

Возврат в начало

Помещение книг в общие папки Microsoft Exchange

Если книгу требуется сделать доступной другим пользователям без рассылки ее по электронной почте, можно поместить книгу в общую папку Microsoft Exchange. См. Помещение книги в папку Microsoft Exchange.

Возврат в начало

Работа с книгой при проведении собрания по сети

Если требуется, чтобы несколько пользователей могли работать с книгой одновременно, можно провести собрание по сети, позволяющее нескольким пользователям вместе просматривать книгу и работать с ней.

Возврат в начало

Использование общих книг

Если требуется, чтобы книга могла редактироваться более чем одним пользователем одновременно, можно сделать книгу общей.

Возврат в начало


Установка параметров для отправки сообщения электронной почты

Предполагаемые действия

Установка уровня важности и пометок

Установка уровня важности

Установка флага сообщения

Пометка сообщения как личное, частное или ДСП

Установка уровня безопасности

Повышение безопасности сообщения

Отслеживание сообщений и ответов

Получение уведомления о доставке сообщения

Получение уведомления о прочтении сообщения

Добавление кнопок голосования в сообщение электронной почты

Установка параметров доставки

Сохранение копии отправленного сообщения

Запрет отправки сообщения после указанной даты

Откладывание доставки сообщения

Пересылка ответов на сообщение другим пользователям

Назначение категории сообщения

Не можете сделать выбор?


 Установка параметров для передачи сообщений электронной почты

Установка параметров для передачи сообщений электронной почты

Могут быть установлены параметры сообщения, устанавливающие время и способ доставки сообщения и требуемый ответ от получателя.

Установка уровня важности и пометок Можно установить уровень важности сообщения, показывающий необходимость немедленного прочтения сообщения. Если ответ необходимо получить до определенного времени, можно установить флаг для напоминания о необходимости ответить на сообщение. Можно также пометить сообщение как личное, частное или ДСП.

Установка уровня безопасности Если используется сервер Microsoft Exchange Server, можно повысить безопасность сообщения, добавляя цифровую подпись или запечатывая (кодируя) сообщения для получения уверенности в том, что оно не может быть прочитано никем кроме получателя сообщения.

Отслеживание сообщений и ответов Чтобы проследить доставку сообщения можно установить получение уведомления о доставке сообщения и получение уведомления о прочтении сообщения.

Установка параметров доставки Для задания времени и способа доставки сообщения можно установить параметры доставки. Чтобы сообщить получателям, что сообщение теряет актуальность после определенного срока, можно установить срок годности для сообщения.

Для сохранения копий отправленных сообщений можно автоматически сохранять после пересылки сообщение в заданной папке в Outlook.

Для указания получателя ответов на сообщения, не совпадающего с отправителем сообщения, можно пересылать ответы на сообщения другим пользователям.

Если сообщения формируются, но должны быть отправлены адресату в другое время, можно отложить доставку сообщения.

Для сопровождения и систематизации отправленных сообщений по общим разделам можно присвоить сообщению категорию, например «Бизнес», «Важные покупатели», «Персонал», «Подарки » или «Цели». Более подробную информацию о категориях можно получить из справки по Outlook.


 Добавление к сообщениям средств защиты

Добавление к сообщениям средств защиты

К отправляемым сообщениям можно добавить два средства защиты. Можно подписать сообщение с использованием цифровой подписи, чтобы получатель был уверен в том, что сообщение не было кем-нибудь изменено. Также можно зашифровать сообщение для того, чтобы сообщение и его вложения не могли быть прочитаны никем кроме указанных получателей.

Для того чтобы зашифровать или подписать сообщение, необходимо получить у системного администратора пароль к файлу защиты; получатели сообщения для открытия зашифрованного сообщения или проверки цифровой подписи должны будут указать свой пароль.

Примечание. Указанные средства защиты применимы только внутри организации и только в том случае, если и отправитель и получатели сообщения используют Microsoft Exchange Server. Средства защиты на компьютерах должен настроить системный администратор.


 Присвоение сообщениям категорий Outlook

Присвоение сообщениям категорий Outlook

Категория — это ключевое слово или фраза, помогающая отслеживать элементы и легко находить и сортировать их, применять к ним фильтры или группировать. Категории можно использовать для отслеживания различных типов элементов, которые являются связанными, однако хранятся в разных папках.

Категории также позволяют отслеживать объекты, не помещая их в отдельные папки. Например, деловые и личные задачи можно хранить в одном списке задач, а для раздельного их просмотра использовать категории «Деловые» и «Личные».

В Microsoft Outlook имеется список категорий, которые можно присваивать сообщениям, называемый главным списком категорий. Этот список можно использовать в исходном виде или добавить в него свои собственные категории; элементам можно присваивать более одной категории.

Дополнительные сведения о категориях содержатся в справочной системе Outlook.


 Добавление цифровой подписи ко всех исходящим сообщениям

Добавление цифровой подписи ко всех исходящим сообщениям

Эта возможность применима внутри организации, а также если и отправитель и адресаты используют Microsoft Exchange Server. В этом случае системный администратор обязан установить защиту на компьютер.

Требования, которым должна удовлетворять система для отправки документов

  1. Откройте в Microsoft Excel лист, который следует отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Параметры.

  5. В группе Безопасность установите флажок Добавить цифровую подпись к исходящему сообщению.


Создание маршрута

  1. Откройте книгу, которую требуется отправить по маршруту.

  2. Выберите в меню Файл команду Отправить и подкоманду По маршруту.

  3. Для выбора адресатов нажмите кнопку Адрес.

  4. Введите имя адресата в поле Введите или выберите имя, а затем нажмите кнопку Кому. По завершении ввода имен адресатов в поле Кому нажмите кнопку OK.

    Вместо имени конкретного адресата может использоваться личный список рассылки. Все члены списка рассылки рассматриваются как один адресат. При необходимости отправить книгу не всем членам списка рассылки сразу, а по маршруту от одного члена списка другому, в маршруте следует перечислить всех адресатов по отдельности.

    Чтобы изменить порядок следования сообщения от одного адресата другому, достаточно изменить соответствующим образом порядок расположения их имен в списке. Выберите имя адресата для перемещения его вверх или вниз в списке, а затем нажмите соответствующую стрелку.

  5. Установите другие необходимые параметры маршрутизации.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  6. Для отправки книги по маршруту нажмите кнопку Отправить.

  7. Чтобы закрыть диалоговое окно без отправки книги, нажмите кнопку Добавить маршрут. Для того чтобы отправить книгу позднее, откройте книгу, выберите в меню Файл команду Отправить и подкоманду Следующий адресат.

Примечание. Отправляемая по маршруту книга помещается в сообщение электронной почты в виде вложения.


Изменение маршрута книги

  1. Откройте книгу, маршрут которой следует изменить.

  2. Выберите команду Отправить в меню Файл, а затем — команду Другой адресат.

  3. Создатель книги может изменить любые параметры маршрута.

    Получатель в состоянии изменить только порядок адресатов, еще не получивших книгу. Выберите имя любого из адресатов и нажмите соответствующую кнопку.

  4. Для отправки книги по маршруту нажмите кнопку Разослать.

    Чтобы закрыть диалоговое окно без отправки книги, нажмите кнопку Добавить.


 Шифрование исходящих сообщений

Шифрование исходящих сообщений

Эта возможность применима только внутри организации или если и отправитель и адресаты используют Microsoft Exchange Server. В этом случае системный администратор обязан установить защиту на компьютер.

Требования, которым должна удовлетворять система для отправки документов

  1. Откройте в Microsoft Excel лист, который требуется отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель в положение Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Параметры.

  5. В группе Безопасность установите флажок Зашифровать сообщение и вложения.


 Проверка имен вручную перед отправкой сообщения

Проверка имен вручную перед отправкой сообщения

Требования, которым должна удовлетворять система для отправки документов

Перед отправкой листа в качестве сообщения электронной почты имена получателей, введенные в поля Кому, Копия, От и СК, автоматически сверяются с именами в адресной книге. При нахождении точного совпадения имя подчеркивается. При нахождении нескольких имен, совпадающих с введенным, на экран выводится диалоговое окно Проверка имен. Щелкните имя правой кнопкой, чтобы просмотреть другие имена, из которых можно выбрать нужное.

  1. Откройте в Microsoft Excel лист, который требуется отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель в положение Включить текущий лист в текст сообщения.

  4. В поля Кому и Копия введите имена получателей через точку с запятой.

    Для того чтобы выбрать имена получателей из списка, нажмите кнопку Кому или Копия.

  5. Выполните одно из следующих действий:
    • Для того чтобы выбрать замену для каждого из неопознанных имен по очереди, нажмите кнопку Проверить имена [image].

    • Для того чтобы выбрать замену для конкретного неопознанного имени, щелкните это имя правой кнопкой.


 Отправка нескольких вложений в сообщении электронной почты

Отправка нескольких вложений в сообщении электронной почты

Требования, которым должна удовлетворять система для отправки документов

  1. Откройте в Microsoft Excel книгу, содержащую лист, который следует отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель в положение Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Вложить.

  5. Дважды щелкните файл, который требуется отправить.

  6. Повторите шаги с 4 по 6 для каждого дополнительного файла, отправляемого как вложение.

  7. Нажмите кнопку Отправить [image] .


Запись сведений о книге с помощью Microsoft Outlook

Предполагаемые действия

Добавление задачи для книги в список задач Outlook

Автоматическая запись сведений о книгах в дневник Outlook

Запись сведений о файлах в дневник Outlook вручную

Не можете сделать выбор?


 Создание нового поручения

Создание нового поручения

Для выполнения этой процедуры необходимо установить на компьютере и выполнить настройку программы Microsoft Outlook.

  1. Запустите Outlook.

  2. В меню Файл выберите пункт Создать, а затем выберите Поручение.

  3. В поле Кому введите имя лица, которому следует назначить задачу.

    Чтобы выбрать имя из списка, нажмите кнопку Кому.

  4. В поле Тема введите имя задачи.

  5. Укажите срок выполнения задачи, состояние и важность.

  6. Установите или снимите флажки Держать обновленную копию этой задачи в списке задач и Отправить мне отчет о состоянии по завершении задачи.

  7. Чтобы создать повторяющуюся задачу, откройте меню Действия и выберите команду Повторение; установите требуемые параметры и затем нажмите кнопку OK.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  8. Введите дополнительные сведения и указания.

  9. Нажмите кнопку Отправить [image] .


 Открытие задачи

Открытие задачи

Для выполнения этой процедуры необходимо установить на компьютере и настроить Microsoft Outlook.

  1. Запустите Outlook.

  2. На панели Outlook выберите Задачи [image] или Календарь [image] .

  3. В списке задач дважды щелкните значок задачи, которую требуется открыть.


Обмен данных Microsoft Excel и Microsoft Access

Предполагаемые действия

Работа с данными Microsoft Access в Microsoft Excel

Копирование записей Microsoft Access на лист Microsoft Excel

Анализ в Microsoft Excel данных Microsoft Access

Создание запроса Microsoft Excel для извлечения данных Microsoft Access

Создание сводной таблицы Microsoft Excel на основе данных Microsoft Access

Использование возможностей Microsoft Access для работы с данными Microsoft Excel

Создание в Microsoft Excel новой формы Microsoft Access

Создание отчета Microsoft Access на основе данных списка Microsoft Excel

Перенос данных Microsoft Excel в Microsoft Access

Импорт данных Microsoft Excel в Microsoft Access

Преобразование списка Microsoft Excel в формат Microsoft Access

Публикация данных Microsoft Excel на странице доступа к данным

Дополнительные сведения


 Обмен данными между Microsoft Excel и Microsoft Access

Обмен данными между Microsoft Excel и Microsoft Access

Данный раздел содержит следующие сведения:

Работа с данными Microsoft Access в Microsoft Excel

Использование Microsoft Access для работы с данными Microsoft Excel

Перенос данных Microsoft Excel в Microsoft Access

Работа с данными Microsoft Access в Microsoft Excel

Копирование статического набора нескольких записей Access в Excel. Данные Access можно скопировать, воспользовавшись режимом таблицы или элементом управления страницей данных, и затем вставить эти данные в Excel. Данный метод следует использовать в случае, если необходимо получить статический набор нескольких выбранных записей Access, и при этом не требуется обеспечивать обновление данных в Excel при изменении базы данных Access. См. Копирование записей Access в Excel.

Анализ большого статического набора данных Access в Excel. В книге Excel можно сохранить данные из таблицы, запроса или отчета Access. Данный метод следует использовать для создания статических копий больших объемов данных Access, которые не требуется обновлять в Excel при изменении базы данных Access. См. Экспорт данных Access в Excel.

Перенос в Excel обновляемых данных Access. Если необходимо, чтобы при изменении базы данных Access данные на листе обновлялись, можно перенести данные в Excel, воспользовавшись любым из следующих двух способов.

  • Создание на листе диапазона данных Access. Можно создать запрос для переноса данных Access в Excel. После этого можно форматировать и анализировать извлеченные данные в Excel.

  • Создание отчета сводной таблицы на основе данных Access. Если требуется проанализировать данные Access в отчете сводной таблицы, можно создать в Excel отчет сводной таблицы на основе внешних данных Access. Данный метод следует использовать в случае, если при работе с отчетом сводной таблицы требуется использовать другие возможности Excel — например, если нужно использовать данные из отчета в формулах на листе.

Возврат в начало

Использование Microsoft Access для работы с данными Microsoft Excel

Если в Excel установлена надстройка связей с Access, можно создавать формы и отчеты Access для использования их с данными Excel. Например, можно создать форму Access, позволяющую вводить записи в список Excel в порядке, отличающемся от порядка столбцов на листе. См. сведения об использовании надстроек.

Создание формы Access для ввода данных Excel. Если для ввода, поиска и удаления данных из списка Excel необходимо использовать форму, можно создать для списка Excel форму Access. Данный метод следует использовать в случае, если требуется воспользоваться определенными возможностями, доступными в формах Access. Для получения дополнительных сведений о разработке и использовании форм Access обратитесь к справочной системе Access. См. сведения о способах использования форм в Excel.

Создание отчета Access на основе данных Excel. Если требуется обобщить и организовать данные Excel с помощью отчета Access, то при наличии опыта разработки отчетов такого типа можно создать отчет Access на основе списка Excel. Для получения дополнительных сведений о разработке и использовании отчетов Access обратитесь к справочной системе Access. См. сведения о дополнительных способах создания итоговых отчетов в Excel.

Связывание данных Excel с базой данных Access. Список Excel можно поместить в базу данных Access в виде таблицы. Данный подход следует использовать в случае, если планируется продолжать ведение списка в Excel, и при этом требуется, чтобы список был доступен в Access. Данные в связанном списке Excel можно просматривать и обновлять непосредственно в базе данных Access. Для получения дополнительных сведений обратитесь к справочной системе Access.

Возврат в начало

Перенос данных Microsoft Excel в Microsoft Access

Импорт данных Excel в базу данных Access. Если при работе в Access в базу данных требуется скопировать данные из книги Excel, можно импортировать данные Excel в Access. Данный метод следует использовать для переноса в Access небольших объемов данных Excel без необходимости повторного ввода.

Преобразование списка Excel в базу данных Access. Если имеется большой список Excel, который требуется перенести в базу данных Access для того, чтобы воспользоваться представляемыми Access возможностями управления данными, защиты или многопользовательскими возможностями, можно преобразовать данные Excel в базу данных Access. Для преобразования данных необходимо установить надстройку связей с Access. См. сведения об использовании надстроек.

Публикация данных Excel вместе с данными Access на странице доступа к данным. При создании страницы доступа к данным для Web-публикации можно опубликовать на Web-странице данные Excel в обычной или сводной таблице. Для получения дополнительных сведений о создании страниц доступа к данным и включении этих компонентов обратитесь к справочной системе Access.

Возврат в начало


 Анализ в Microsoft Excel данных Microsoft Access

Анализ в Microsoft Excel данных Microsoft Access

  1. В окне базы данных Microsoft Access выберите таблицу, запрос, форму или отчет, который будет использоваться в Microsoft Excel.

  2. В меню Сервис выберите пункт Связи с Office и выполните команду Анализ в MS Excel.

    Microsoft Access сохранит таблицу, запрос, форму или отчет в виде книги Microsoft Excel (.xls) и откроет этот файл в Microsoft Excel. Файл с именем таблицы, запроса или другого объекта базы данных сохраняется в текущем рабочем каталоге.

Примечание. При наличии основной формы и одной или нескольких вспомогательных форм, или основного отчета и одного или нескольких вспомогательных отчетов Microsoft Access сохраняет в книге Excel только данные основной формы или отчета.


 Копирование записей Microsoft Access на лист Microsoft Excel

Копирование записей Microsoft Access на лист Microsoft Excel

  1. В Microsoft Access выберите таблицу, запрос или форму с копируемыми записями.

  2. В меню Вид выберите команду Режим таблицы.

  3. Выделите копируемые записи.

    Для копирования определенных столбцов выделите их заголовки.

  4. Нажмите кнопку Копировать [image] .

  5. Перейдите в Microsoft Excel.

  6. Укажите левый верхний угол области листа, куда следует поместить первое имя поля.

    Ячейки вставляемой таблицы заменят данные в указанной области, если они были.

  7. Нажмите кнопку Вставить [image] .

Примечание. После вставки данных на лист Excel может потребоваться изменение высоты соответствующих строк. Выделите строки, выберите команду Ячейки меню Формат, перейдите на вкладку Выравнивание и снимите флажок переносить по словам. После этого выберите пункт Строка меню Формат и выберите команду Автоподбор высоты.


Импорт данных Microsoft Excel в Microsoft Access

На листе или в диапазоне данных Microsoft Excel, импортируемых в Microsoft Access, в каждом поле (столбце) должны содержаться данные одного типа, а в каждой строке — одни и те же поля.

  1. Закройте книгу Excel, содержащую данные, которые предполагается использовать в Access.

  2. В Microsoft Access откройте базу данных или переключитесь в окно База данных открытой базы данных.

  3. В меню Файл выберите пункт Внешние данные и выполните команду Импорт.

  4. В диалоговом окне Импорт выберите элемент Microsoft Excel в списке Тип файлов.

  5. В списке Папка выберите папку, содержащую импортируемый файл, и затем дважды щелкните его.

  6. Следуйте инструкциям программы.

Примечания

  • Если в первой строке листа или диапазона содержатся заголовки столбцов, их можно использовать в качестве имен полей в новой таблице, создаваемой в Access для хранения импортированных данных.

  • В случае, если лист содержит большую или сложную базу данных, которую требуется окончательно перенести в Access, можно преобразовать данные из формата Excel в формат Access. Преобразование данных приводит к пометке данных Excel как окончательно перенесенных в Access, а также позволяет воспользоваться возможностями Access, помогающими организовать данные Excel в реляционную базу данных Access. Преобразование данных Microsoft Excel в формат Microsoft Access.


 Использование формы для ввода данных в список Excel

Использование формы для ввода данных в список Excel

Использование встроенной формы для ввода данных. Использование формы для ввода данных является удобным в случае, если имеется широкий список, количество столбцов которого превышает число столбцов, которое может одновременно отображаться на экране. Форма отображает все заголовки столбцов списка в одном диалоговом окне, с пустым полем рядом с каждым заголовком, предназначенным для ввода данных в столбец. При этом можно ввести новые данные, найти строки на основе содержимого ячейки, обновить имеющиеся данные и удалить строки из списка. См. сведения о выводе и использовании формы для ввода данных.

Использование формы Microsoft Access. Формы Access предоставляют более гибкие возможности создания макетов и форматирования, чем формы для ввода данных Microsoft Excel, обладающие фиксированными макетами. При наличии Access можно создать настраиваемую форму Microsoft Access и затем использовать эту форму для ввода, поиска и удаления данных из списка Microsoft Excel. Для получения сведений о возможностях и параметрах форм Access обратитесь к справочной системе Access.

Одновременное создание для каждого заполненного экземпляра формы копии в книге и записи в базе данных. Можно создать шаблон формы с помощью Excel и затем использовать мастер шаблонов для создания отдельного списка Excel для сбора данных, вводимых в формы. При этом Excel автоматически осуществляет ведение списка и сохраняет копию каждого заполненного экземпляра формы в отдельной книге. Мастер шаблонов следует использовать в случае, если, например, копии формы будут заполняться несколькими пользователями. См. сведения об использовании мастера шаблонов для создания формы для ввода данных в список Excel.

Создание пользовательской формы на листе. Если требуется создать сложную или специализированную форму для ввода данных, следует создать лист или шаблон для использования его в качестве формы, и затем настроить лист формы в соответствии с необходимыми требованиями. Этот способ используется в случае, если требуется получить отдельные печатные копии формы. Например, можно создать форму отчета о расходах, которая будет заполняться в электронном виде или в виде печатных копий. Если также требуется сохранять данные из форм в списке Excel, можно скопировать данные в список вручную или воспользоваться для создания и ведения списка мастером шаблонов, либо разработать приложение для ввода данных с помощью редактора Visual Basic. См. Создание формы в Excel.


Преобразование списка Microsoft Excel в формат Microsoft Access

Для просмотра этого раздела выберите мышью соответствующий графический объект.


Редактирование связанных или внедренных объектов

Предполагаемые действия

Редактирование связанного объекта в исходной программе

Редактирование внедренного объекта в исходной программе

Редактирование внедренного объекта в программе, отличной от исходной.

Обновление связи с книгой в интрасети или в Интернете

Дополнительные сведения


Обновление связей Microsoft Excel

Предполагаемые действия

Изменение способа редактирования связанных объектов

Изменение связанных объектов вручную

Автоматическое обновление связей с другими приложениями во время проведения расчетов

Блокирование всех ссылок в Microsoft Excel

Замена формулы или ее части на возвращаемое значение

Дополнительные сведения


 Установление новых связей со связанным объектом при перемещении или переименовании исходного файла

Установление новых связей со связанным объектом при перемещении или переименовании исходного файла

  1. В меню Правка выберите команду Связи.

  2. В списке Исходный файл выберите связи, которые необходимо переустановить.

    Для выделения нескольких связей для одного исходного файла, не отпуская клавишу CTRL выберите каждый связанный объект.

  3. Выберите команду Изменить.

  4. В диалоговое окно Изменение связей поместите исходный файл для выбранных связей.


 Обновление изображения ячеек листа Excel

Обновление изображения ячеек листа Excel

Чтобы изображение ячеек листа изменялось вместе с данными источника, можно установить связь изображения с листом источника данных. В этом случае, например, при изменении нумерации исходных ячеек, которые использовались при копировании, автоматически будет изменено и связанное с ними изображение.

  1. Дважды щелкните связанное изображение.

    Excel откроет лист источника данных и выделит диапазон ячеек, с которыми установлена связь изображения.

  2. Сделав необходимые изменения на листе источника данных, нажмите кнопку Сохранить [image] .


 Изменение способа вывода на экран связанных и внедренных объектов

Изменение способа вывода на экран связанных и внедренных объектов

Связанный объект или внедренный объект в книге можно вывести на экран либо в том виде, в котором он появляется в исходной программе, либо в виде значка. Если пользователи будут просматривать книгу и не будут выводить ее на печать, то ее можно минимизировать, превратив в значок. Пользователям, которым необходимо вывести на экран данные, содержащиеся в книге, нужно дважды щелкнуть кнопкой мыши на значке.

Примечание. При выборе текста без форматирования, текста в формате RTF, рисунка или точечного рисунка в диалоговом окне Специальная вставка (меню Правка) вставленные данные можно представить на экране в виде значка.

Предполагаемые действия

Отображение содержимого связанного или внедренного объекта, представленного в виде значка

Отображение связанного или внедренного объекта в виде значка

Изменение изображения и метки значка, представляющего связанный или внедренный объект


Разрешение вопросов: связь с данными других приложений и их совместное использование

В чем именно заключаются сложности?

Обновление связей

Не удается обновить изображение ячеек Microsoft Excel в другом приложении

Не удается обновить автоматические связи на листе Microsoft Excel

При двойном нажатии кнопки мыши на связанном или внедренном объекте появляется сообщение "Нельзя изменить".

Команда недоступна

Отсутствует команда Копировать рисунок, Вставить рисунок или Вставить связь с рисунком

Открытие, просмотр, вывод на печать

Не удается вывести на печать автофигуры и объекты, скопированные или импортированные из других приложений

Не удается открыть объект Microsoft Excel из другого приложения

Отображение содержимого связанного или внедренного объекта


Разрешение вопросов: отправка книг по электронной почте

В чем именно заключаются сложности?

Приложения, необходимые для отправки книги по электронной почте

Команды Сообщение и По маршруту отсутствуют в подменю Отправить (меню Файл)

Лист, отправленный по электронной почте, отображается неправильно

Не удается отправить Web-страницу в качестве вложения в сообщении электронной почты


 На листе не работает кнопка просмотра формы или отчета MS Access.

На листе не работает кнопка просмотра формы или отчета MS Access.

Определение местонахождения базы данных Microsoft Access. База данных Microsoft Access, которая содержит форму или отчет, была перенесена в другую папку. Нажмите кнопку Обзор в диалоговом окне создания формы Microsoft Access или создания отчетов Microsoft Access, чтобы найти mdb-файл Microsoft Access. Если для формы или отчета создавалась новая база данных, то имя этого файла должно совпадать с именем книги Excel.

Проверка присутствия формы или отчета в базе данных. Листу Microsoft Excel могут соответствовать только одна форма и один отчет Microsoft Access. При создании формы (отчета) после удаления старой формы (отчета) из базы данных на листе появится вторая кнопка просмотра формы или просмотра отчета Microsoft Access. Чтобы удалить использовавшуюся ранее кнопку, нажмите ее, удерживая клавишу CTRL, а затем воспользуйтесь клавишей DELETE.

Книга, содержащая список, могла быть переименована или перемещена в другую папку. При переименовании или перемещении книги кнопка работать не будет. Измените имя книги на прежнее и переместите ее в папку, в которой она находилась при создании формы или отчета.

Снятие защиты листа. Если лист защищен, выберите команду Защита в меню Сервис, а затем — команду Снять защиту листа.

Проверка правильности имен таблицы, формы или отчета Access. Используемое на листе Excel имя таблицы, формы или отчета могло измениться в базе данных Microsoft Access. Для восстановления правильного имени следует выбрать мышью соответствующее имя в базе данных Access, а затем указать нужное имя. Это имя, используемое на листе Excel, должно иметь следующий вид:

Книга1_Лист1_Таблица

Если данные Excel находятся в именованном диапазоне, следует использовать именно это имя. Имя книги или листа не должно содержать пробелов, но может содержать подчеркивания. Например, если данные Excel находятся на листе 1 в книге «Склад», в именах таблицы, формы и отчета должно быть указано «Склад_Лист_1_Данные».


 Использование макросов для автоматизации наиболее часто выполняемых задач

Использование макросов для автоматизации наиболее часто выполняемых задач

Если какое-то действие часто повторяется, его выполнение можно автоматизировать с помощью макроса. Макрос — это последовательность команд и функций, хранящихся в модуле Visual Basic. Их можно выполнять всякий раз, когда необходимо выполнить данную задачу. При записи макроса Excel хранит информацию о каждом шаге выполнения последовательности команд. Последующий запуск макроса вызывает повторение («воспроизведение») команд.

Запись макроса для выполнения задачи за один шаг Все шаги и команды, выполняемые макросом, должны быть спланированы перед записью или написанием макроса. Если при записи макроса была допущена ошибка, сделанные исправления также будут записаны. Visual Basic хранит каждый записанный макрос в отдельном модуле, присоединенном к книге.

Например, если в ячейки часто вводятся длинные текстовые строки, можно записать макрос для форматирования этих ячеек для охватывания ими текста. Выберите ячейку, которая должна охватывать текст, и начните запись макроса. Выберите команду Ячейки в меню Формат, выберите вкладку Выравнивание, установите флажок Переносить по словам, нажмите кнопку OK, и затем кнопку Остановить запись [image] . Запись нового макроса.

Упрощение запуска макроса Можно запустить макрос, выбрав его из списка в диалоговом окне Макрос. Чтобы макрос запускался после каждого нажатия определенной кнопки или сочетания клавиш, можно назначить макрос кнопки на панели инструментов, сочетанию клавиш или графическому объекту на листе. Назначение макроса.

Просмотр и изменение макросов После записи макроса код программы можно посмотреть в редакторе Visual Basic для исправления ошибок и внесения требуемых изменений в макрос. Редактор Visual Basic разработан для упрощения написания и редактирования программ начинающими пользователями и предоставляет обширную оперативную справку. Для внесения простейших изменений в макросы нет необходимости изучать программирование на языке Visual Basic. Просмотр и редактирование макросов.

Если были выполнены описанные выше шаги по записи макроса, форматирующего ячейку, результат может выглядеть примерно следующим образом:

Пример кода макроса в окне редактора Visual Basic

Редактор Visual Basic отображает программный код записанного макроса в окне модуля.

Приведенный макрос может быть упрощен удалением строк с отступами между "With Selection" и "End With", исключая ".WrapText = True".

Управление макросами Редактор Visual Basic позволяет редактировать макросы, копировать макросы из одного модуля в другой, копировать макросы из других книг, переименовывать модули, хранящие макросы и переименовывать макросы. Например, если макрос, переносящий текст по словам должен также выделять текст полужирным шрифтом, можно записать другой макрос, выделяющий шрифт полужирным шрифтом и скопировать инструкции их этого нового макроса в старый макрос, переносящий текст по словам. Копирование макроса.

Безопасность макросов Microsoft Excel 2000 обеспечивает защиту от вирусов, которые могут передаваться макросами. Если макросы используются совместно с другими пользователями, макросы могут быть снабжены цифровой подписью, так что пользователи могут проверить надежность источника макросов. Всякий раз при открытии книги, содержащей макросы, можно проверить источник макросов, прежде чем разрешить их. Защита от макровирусов.


 Запись макроса

Запись макроса

  1. Выберите в меню Сервис команду Макрос и подкоманду Начать запись.

    Демонстрация

  2. В поле Имя макроса введите имя для макроса.

    Первым символом имени макроса должна быть буква. Остальные символы могут быть буквами, цифрами или знаками подчеркивания. В имени макроса не допускаются пробелы; в качестве разделителей слов следует использовать знаки подчеркивания.

  3. Для того чтобы запускать макрос с помощью сочетания клавиш, введите букву в поле Сочетание клавиш. Допускается использование сочетаний CTRL+ буква (для строчных букв) или CTRL+SHIFT+ буква (для прописных букв), где буква — любая буквенная клавиша на клавиатуре. В сочетаниях клавиш нельзя использовать цифры или специальные символы, такие как «@» или «#». Выбранное сочетание клавиш подавляет стандартные сочетания клавиш Microsoft Excel на то время, пока открыта книга, содержащая данный макрос.

  4. В поле Сохранить в выберите книгу, в которой требуется сохранить макрос.

    Если требуется, чтобы макрос был всегда доступен при работе в Excel, сохраните его в личной книге макросов в папке XLStart.

    Чтобы создать краткое описание макроса, введите необходимый текст в поле Описание.

  5. Нажмите кнопку OK.

    По умолчанию при записи макроса используются абсолютные ссылки. Макрос, записанный с абсолютными ссылками, при выполнении всегда обрабатывает те же ячейки, которые обрабатывались при его записи. Для того, чтобы с помощью макроса обрабатывать произвольные ячейки, следует записать его с относительными ссылками. Для этого нажмите кнопку Относительная ссылка [image] на панели инструментов Остановка записи. Относительные ссылки будут использоваться до конца текущего сеанса работы в Excel или до повторного нажатия кнопки Относительная ссылка [image] .

  6. Выполните макрокоманды, которые нужно записать.

  7. Нажмите кнопку Остановить запись [image] на панели инструментов Остановить запись.

Совет. Если требуется, чтобы макрос сначала выбирал определенную ячейку, выполнял макрокоманду, а затем выбирал другую ячейку относительно активной, можно использовать при записи макроса и абсолютную, и относительную ссылки. При записи относительных ссылок кнопка Относительная ссылка [image] должна быть нажата. При записи абсолютных ссылок кнопка Относительная ссылка [image] не должна быть нажата.


Назначение макроса клавише, графическому объекту или кнопке на панели инструментов

Предполагаемые действия

Назначение клавиши для запуска макроса

Назначение кнопки или графического объекта для запуска макроса

Назначение области графического объекта для запуска макроса

Назначение кнопки панели инструментов для запуска макроса


 Копирование макроса

Копирование макроса

Если уже существующий макрос содержит команды, которые нужно использовать в другом макросе, можно скопировать весь макрос или его часть в другой модуль. Так же можно сделать копию модуля макроса для дублирования всех макросов, хранящихся в нем.

Предполагаемые действия

Копирование части макроса для создания другого макроса

Копирование модуля макроса в другую книгу


 Удаление макроса

Удаление макроса

  1. Откройте книгу, содержащую удаляемый макрос.

  2. В меню Сервис выберите пункт Макрос, а затем выполните команду Макросы.

    Демонстрация

  3. В списке Находится в выберите Эта книга.

  4. В списке Имя выберите имя макроса, который нужно удалить.

  5. Нажмите кнопку Удалить.

Примечание Чтобы удалить все макросы из книги, удалите все макросы, перечисленные в диалоговом окне, и сохраните книгу.


 Изменение макроса

Изменение макроса

Для изменения записанного макроса необходимо знакомство с редактором Visual Basic, который используется для написания и изменения макросов Microsoft Excel.

  1. В меню Сервис выберите пункт Макрос, а затем выполните команду Макросы.

    Демонстрация

  2. Введите имя макроса в поле Имя макроса.

  3. Нажмите кнопку Изменить.


Выполнение макроса

После того как макрос записан, его можно выполнить в Microsoft Excel или из редактора Visual Basic. Обычно макросы выполняются в Microsoft Excel; однако в ходе изменения их можно выполнить из редактора Visual Basic. Для того чтобы прервать выполнение макроса, нажмите клавишу ESC.

Предполагаемые действия.

Выполнение макроса в Microsoft Excel

Выполнение макроса из модуля Visual Basic

Назначение макроса клавише, графическому объекту или кнопке на панели инструментов


Прерывание выполнения макроса

  • Для прерывания выполнения макроса нажмите кнопку ESC.


 Запуск Microsoft Excel без выполнения автоматических макросов

Запуск Microsoft Excel без выполнения автоматических макросов

Автоматические макросы, такие как макрос Авто_активизировать, выполняются при запуске Excel. Для получения дополнительных сведений о таких макросах обратитесь к справочной системе по языку программирования Visual Basic.

  • Чтобы избежать автоматического запуска макросов, при запуске Excel следует нажать и удерживать клавишу SHIFT.

Примечание. При запуске Microsoft Excel с панели Office нажмите кнопку Microsoft Excel на панели Office, сразу нажмите клавишу SHIFT и удерживайте ее в процессе запуска Microsoft Excel.


 Добавление команд для работы с Web-сценариями в меню «Сервис»

Добавление команд для работы с Web-сценариями в меню «Сервис»

  1. В меню Сервис выберите команду Настройка, а затем откройте вкладку Команды.

  2. Выберите категорию Сервис из списка Категории.

  3. Перетащите команду Добавить сценарий из списка Команды на меню Сервис. После открытия списка команд меню Сервис, не отпуская кнопку мыши, укажите на подменю Макрос. При отображении списка команд подменю Макрос поместите команду Добавить сценарий на требуемое место, а затем отпустите кнопку мыши.

  4. Повторите шаг 3 для команды Показать все сценарии.

  5. Повторите шаг 3 для команды Удалить все сценарии.

  6. Нажмите кнопку Закрыть в диалоговом окне Настройка.


Изменение стандартного языка Web-сценариев

Для просмотра этого раздела щелкните рисунок.


Просмотр и изменение Web-сценария

Для просмотра этого раздела щелкните рисунок.


 Отображение или скрытие ссылок сценария

Отображение или скрытие ссылок сценария

  1. Добавьте команды для работы с Web-сценариями в меню Сервис, если это еще не сделано.

  2. Выполните одно из следующих действий:

    Чтобы отобразить все ссылки сценария для всех Web-сценариев в книге, выберите пункт Макрос в меню Сервис, а затем — команду Показать все сценарии.

    Чтобы скрыть все ссылки сценария, снова выберите пункт Макрос в меню Сервис, а затем — команду Показать все сценарии.


 Перемещение или копирование Web-сценария

Перемещение или копирование Web-сценария

Примечание. Некоторые Web-сценарии являются зависимыми от структуры исходной Web-страницы, на которой они располагались, и могут работать неправильно при копировании или перемещении их в другое местоположение.

  1. Щелкните ссылку сценария, который требуется переместить или скопировать. Отображение ссылок сценария.

  2. Выполните одно из следующих действий:

    Чтобы переместить сценарий, нажмите кнопку Вырезать [image] .

    Чтобы скопировать сценарий, нажмите кнопку Копировать [image] .

  3. В книге, в которую требуется переместить или скопировать сценарий, щелкните новое местоположение для сценария.

  4. Нажмите кнопку Вставить [image] .


 Удаление Web-сценария

Удаление Web-сценария

  1. Добавьте команды для работы с Web-сценариями в меню Сервис, если это еще не сделано.

  2. Выполните одно из следующих действий:

    Чтобы удалить отдельный Web-сценарий, щелкните ссылку сценария, который требуется удалить, а затем нажмите клавишу DELETE. Отображение ссылок сценария.

    Чтобы удалить все Web-сценарии в книге, выберите пункт Макрос в меню Сервис, а затем — команду Удалить все сценарии.


Изменение кода Java-приложения

Для просмотра этого раздела щелкните рисунок.


 Перемещение или копирование Java-приложения

Перемещение или копирование Java-приложения

Примечание. Некоторые Java-приложения являются зависимыми от структуры исходной Web-страницы, на которой они располагались, и могут работать неправильно при копировании или перемещении их в другое местоположение.

  1. Щелкните значок Java-приложения Значок Java-приложения , которое требуется переместить или скопировать.

  2. Выполните одно из следующих действий:

    Чтобы переместить приложение, нажмите кнопку Вырезать [image] .

    Чтобы скопировать приложение, нажмите кнопку Копировать [image] .

  3. В книге, в которую требуется переместить или скопировать приложение, щелкните новое местоположение для приложения.

  4. Нажмите кнопку Вставить [image] .


 Удаление Java-приложения

Удаление Java-приложения

  1. Щелкните значок Java-приложения Значок Java-приложения , которое требуется удалить.

  2. Нажмите клавишу DELETE.


 При нажатии кнопки «Обновить» отображается сообщение о том, что изменения, внесенные в макрос, будут утеряны.

При нажатии кнопки «Обновить» отображается сообщение о том, что изменения, внесенные в макрос, будут утеряны.

Данное сообщение отображается при внесении изменений в макрос в редакторе Visual Basic и одновременном изменении копии книги в редакторе сценариев.

Чтобы сохранить изменения, внесенные в макрос, сделайте следующее:

  1. Нажмите кнопку Нет.

  2. Переключитесь в окно редактора Visual Basic.

  3. Выполните экспорт всех измененных модулей.

  4. В окне книги нажмите кнопку Обновить [image] на панели инструментов Обновить.

  5. Нажмите кнопку Да.

  6. Выполните импорт модулей для восстановления изменений, внесенных в макрос.


Не удается найти команду «Добавить сценарий», «Показать все сценарии» или «Удалить все сценарии».

Эти команды не включены в стандартные меню Microsoft Excel. Для использования этих команд необходимо сначала добавить их в меню Сервис.


 Параметры запуска Excel

Параметры запуска Excel

Автоматическое открытие книг. Если вы постоянно работаете с одной книгой или книгами, можно открывать эти книги автоматически при запуске Microsoft Excel, поместив книги — или ярлыки книг — в папку автозагрузки Excel.

Указание дополнительной папки автозагрузки. При работе с книгами, находящимися в конкретной папке, например в папке на сетевом диске, можно указать дополнительную папку автозагрузки. Все находящиеся в этой папке файлы открываются при запуске Excel.

Настройка стандартных значений с помощью шаблона. Если требуется, чтобы несколько книг или листов имели одинаковые параметры форматирования и стили или содержимое и функциональные возможности, можно создать шаблон для настройки этих параметров. См. сведения об использовании шаблона.

Отмена автоматического открытия книг. При запуске Excel автоматически открываются книги, хранящиеся в папке XLStart или дополнительной папке автозагрузки, а также заданные соответствующим параметром в свойствах ярлыка программы. См. Отмена загрузки книги при запуске Excel.

Изменение рабочей папки по умолчанию. Рабочая папка по умолчанию — это папка, отображаемая в диалоговых окнах Открытие документа и Сохранение документа. Можно установить рабочую папку по умолчанию для Microsoft Office в целом или только для Excel.

Использование ключей запуска. Изменить параметры запуска Excel при использовании ярлыка можно посредством указания ключа запуска. Например, можно запретить отображение заставки при запуске Excel и открытие новой пустой книги, а также задать стандартную рабочую папку.

Параметры настройки и личные файлы. Некоторые параметры, например используемые вспомогательные словари и дополнительные шаблоны, относятся к конкретным пользователям, и при соответствующей настройке системным администратором могут быть доступны для использования при каждом входе в сеть. См. сведения о параметрах настройки и личных файлах.


Шрифт интерфейса пользователя Microsoft Office

Шрифт, используемый в программах Microsoft Office (для отображения текста в диалоговых окнах, строках состояния, в поле Имя, на ярлычках листов, кнопках, в сообщениях и меню), является стандартным шрифтом интерфейса пользователя Microsoft Office. При необходимости для отображения этих элементов в программах Office вместо шрифта интерфейса Office можно использовать стандартный системный шрифт.

Примечание. При использовании Microsoft Office с интерфейсом на японском, корейском языках и китайском языке с традиционным или упрощенным письмом изменить шрифт интерфейса пользователя Microsoft Office нельзя.

Диалоговые окна Microsoft Office рассчитаны на использование стандартного шрифта интерфейса пользователя Microsoft Office; другие шрифты могут оказаться неподходящими для использования. Например, если в качестве шрифта интерфейса выбран стандартный системный шрифт, то в диалоговом окне, содержащем дополнительный символ, отсутствующий в стандартном системном шрифте, вместо этого символа будет отображаться пробел. Кроме того, некоторые элементы интерфейса Office могут отображаться с использованием стандартного шрифта интерфейса Office даже после переключения на стандартный системный шрифт. Изменение шрифта интерфейса Office.


 Использование надстроек Microsoft Excel

Использование надстроек Microsoft Excel

Надстройки — это программы, добавляющие в Excel дополнительные команды и возможности. Например, надстройка «Пакет анализа» предоставляет в распоряжение пользователя набор инструментов для анализа данных, полезных при проведении сложного статистического или инженерного анализа.

В Excel имеется два типа программ-надстроек: собственно надстройки Excel и дополнительные надстройки для модели компонентных объектов (COM).

Надстройки Excel

Где можно получить надстройки. Набор надстроек входит в комплект поставки Excel; дополнительные надстройки можно получить на Web-узле корпорации Майкрософт. См. сведения о надстройках, доступных в Excel.

Установка надстроек на компьютере. Перед использованием надстройки необходимо установить ее на компьютере и затем загрузить в Excel. Надстройки (файлы с расширением *.xla) по умолчанию устанавливаются в одном из двух мест: в папке Library или одной из ее подпапок в папке Microsoft Office\Office или в папке Profiles\имя пользователя\Application Data\Microsoft\AddIns в папке Windows. Администратор сети организации может указать другие местоположения для надстроек. Для получения дополнительных сведений обратитесь к администратору.

Загрузка надстроек в Excel. После установки надстройки необходимо загрузить ее в Excel. При загрузке надстройки обеспечиваемые ей возможности становятся доступными в Excel и в соответствующие меню добавляются все связанные с ними команды.

Выгрузка надстроек. Для экономии памяти и повышения производительности следует выгружать надстройки, которые используются редко. При выгрузке надстройки ее возможности и соответствующие команды удаляются из Excel, однако файл надстройки остается на компьютере и может быть загружен снова. При выгрузке надстройки она остается в памяти до перезапуска Excel.

Создание пользовательских надстроек для Excel. В качестве пользовательских надстроек можно использовать свои собственные программы, созданные на языке Visual Basic. Для получения сведений о том, как сделать программу Visual Basic надстройкой, см. Руководство программиста по Visual Basic для Microsoft Office 2000, которое можно получить от Майкрософт.

Надстройки для модели компонентных объектов (COM)

Надстройки для модели компонентных объектов — это обеспечивающие дополнительные возможности программы, созданные на различных языках программирования, включая Visual Basic, Visual C++ и Visual J++.

Использование надстроек для модели компонентных объектов. Разработчики надстроек для модели компонентных объектов обычно предоставляют программы установки и удаления для надстройки. Для получения инструкций об установке и использовании надстройки обратитесь к ее разработчику.

Разработка надстроек для модели компонентных объектов. Найти сведения о разработке надстроек для модели компонентных объектов можно в справочной системе Visual Basic. До создания окончательного варианта программы установки для надстройки, в процессе разработки и тестирования можно загружать и выгружать надстройку.


 Отображение подсказок для кнопок панелей инструментов

Отображение подсказок для кнопок панелей инструментов

В Microsoft Excel имеется возможность отображения подсказки, содержащей название кнопки, при остановке на ней указателя.

  1. В меню Сервис выберите команду Настройка, а затем откройте вкладку Параметры.

    Демонстрация

  2. Установите или снимите флажок Отображать подсказки для кнопок.

Примечание. Установка или снятие флажка Отображать подсказки для кнопок влияет на все приложения Microsoft Office.


 Перемещение панели инструментов

Перемещение панели инструментов

  • Перетащите маркер перемещения Вертикальная полоска у края закрепленной панели инструментов (он расположен у левого края закрепленной панели инструментов) или область заголовка плавающей панели инструментов в нужном направлении. Если перетащить панель инструментов к краю окна программы или к закрепленной панели, она автоматически закрепляется.

Примечание. Перемещение одной закрепленной панели инструментов может повлиять на расположение и размер других панелей инструментов, находящихся в той же строке.


 Изменение размеров панели инструментов

Изменение размеров панели инструментов

  • Чтобы изменить размеры перемещаемой панели инструментов, установите указатель на край панели (он должен принять вид двусторонней стрелки), а затем перетащите этот край.

  • Чтобы изменить размеры закрепленной панели инструментов, расположенной в одном ряду с другой панелью инструментов, щелкните маркер перемещения Вертикальная полоска на краю закрепленной панели инструментов и затем перетащите панель.

Примечания

  • Размер закрепленной панели инструментов, расположенной отдельно, являющейся самой левой в горизонтальном ряду или самой верхней в вертикальном ряду панелей инструментов, изменить нельзя.

  • Изменение размеров закрепленной панели инструментов может оказать влияние на размещение и размеры других панелей инструментов, расположенных в том же ряду.


Изменение цветовой палитры, используемой в книге

В каждой книге Microsoft Excel имеется палитра из 56 цветов, которые могут использоваться на листе для заливок и линий в диаграммах. Для каждой книги можно определить оттенки и интенсивность цветов палитры. При изменении цвета палитры изменяются все элементы книги, форматированные этим цветом. Палитра может быть скопирована из одной книги в другую.

Предполагаемые действия

Изменение цвета в палитре цветов

Копирование палитры цветов в другую книгу


 Меню и панели инструментов

Меню и панели инструментов

Для чего предназначены меню и панели инструментов?

Использование меню и панелей инструментов

Настройка меню и панелей инструментов

Для чего предназначены меню и панели инструментов?

Меню и панели инструментов позволяют выполнять различные действия в Microsoft Excel.

Меню содержит список команд. Некоторые из этих команд сопровождены изображениями, иллюстрирующими действие, выполняемое командой. Большинство меню находятся в строке меню, обычно расположенной в верхней части экрана.

Панель инструментов может содержать кнопки с изображениями (совпадающими с изображениями, отображаемыми рядом с соответствующими командами меню), меню или различные сочетания этих элементов. В Excel включено множество встроенных панелей инструментов, которые можно отображать или скрывать по мере необходимости. По умолчанию на экране отображаются встроенные панели инструментов Стандартная и Форматирование, закрепленные в одном ряду под строкой меню.

Возврат в начало

Использование меню и панелей инструментов

Отображение часто используемых команд меню и кнопок панелей инструментов. Excel автоматически настраивает меню и панели инструментов в соответствии с тем, как часто используются те или иные команды. При первом запуске Excel в меню отображаются стандартные общие команды. Затем, по мере работы с Excel, меню и панели инструментов настраиваются — Excel отображает только те команды меню и кнопки панелей инструментов, которые используются наиболее часто.

Отображение всех команд в меню. Чтобы выполнить редко используемую или прежде не использовавшуюся команду, нажмите двойную стрелку Двойная направленная вниз стрелка в нижней части меню или дважды щелкните меню, чтобы развернуть его. При развертывании одного меню все другие меню также отображаются в развернутом виде до тех пор, пока не будет выбрана команда или выполнено какое-либо иное действие. При выборе команды в развернутом меню эта команда добавляется в настраиваемый (сокращенный) вариант меню. Если команда в течение некоторого времени не используется, Excel прекращает отображать ее. При необходимости в Excel можно установить режим отображения полного набора команд каждого меню.

Расположение панелей инструментов в одном ряду. Панели инструментов можно расположить в ряд одну за другой. Например, при первом запуске Excel панель инструментов Форматирование отображается рядом со Стандартной панелью инструментов. При расположении в одном ряду нескольких панелей инструментов может быть недостаточно места для отображения всех кнопок. В этом случае отображаются только недавно использовавшиеся кнопки.

Отображение всех кнопок панели инструментов. Для отображения большего числа кнопок или отображения всех кнопок панели инструментов можно изменить размер панели инструментов. Для просмотра кнопок, не помещающихся на встроенной закрепленной панели инструментов, нажмите кнопку Дополнительные кнопки [image] в конце панели инструментов. При использовании кнопки, не отображаемой на панели инструментов, эта кнопка помещается на панель инструментов, а в список Дополнительные кнопки переносится одна из не использовавшихся в последнее время кнопок.

Возврат в начало

Настройка меню и панелей инструментов

Настройка меню и панелей инструментов. Вы можете самостоятельно настраивать меню и панели инструментов, добавляя и удаляя кнопки и меню. Также можно создавать пользовательские панели инструментов, скрывать или отображать панели инструментов, а также перемещать их. Строку меню можно настраивать так же, как и любую встроенную панель инструментов — например, можно добавлять в нее и удалять кнопки и меню — однако скрыть строку меню нельзя.

Сохранение настройки панели инструментов. При выходе из Excel изменения, внесенные в строку меню, встроенные и созданные пользователем панели инструментов, а также отображаемые панели инструментов, сохраняются в файле настроек панелей инструментов, Excel.xlb. Параметры настройки панелей инструментов, хранящиеся в этом файле, используются по умолчанию при каждом запуске Excel. В случае, если часто используется определенный набор панелей инструментов, можно сохранить параметры настройки панелей инструментов в отдельном файле с тем, чтобы избавиться от необходимости изменять вид и расположение панелей инструментов при каждом запуске Excel.

Создаваемые и настраиваемые панели инструментов доступны во всех книгах в системе пользователя. Чтобы какая-либо пользовательская панель инструментов всегда использовалась с определенной книгой, следует вложить эту панель инструментов в книгу.

Возврат в начало


 Переключение между настраиваемыми (сокращенными) и полными меню

Переключение между настраиваемыми (сокращенными) и полными меню

  1. В меню Сервис выберите команду Настройка, а затем откройте вкладку Параметры.

    Демонстрация

  2. Выполните одно из следующих действий:

    Чтобы включить настраиваемые (сокращенные) меню, установите флажок В меню сначала отображаются последние использованные команды. Для отображения полного меню после короткой задержки (при остановке указателя на открытом меню) установите флажок Показывать полные меню после короткой задержки.

    Для отображения всех команд в меню снимите флажок В меню сначала отображаются последние использованные команды.

Примечания

  • Установка или снятие флажка В меню сначала отображаются последние использованные команды влияет на все программы Microsoft Office.

  • Чтобы сбросить параметры меню и панелей инструментов, автоматически сохраняемые Microsoft Excel при выборе команд и кнопок панелей инструментов, нажмите кнопку Сброс на вкладке Параметры (меню Сервис, команда Настройка). Эта кнопка позволяет восстановить состав кнопок, отображаемых на встроенных панелях инструментов, если размер панелей недостаточен для отображения всех кнопок, и команд, отображаемых в настраиваемых (сокращенных) встроенных меню, если установлен флажок В меню сначала отображаются последние использованные команды. Кнопка Сброс не изменяет положение панелей инструментов, не удаляет какие-либо кнопки или команды, добавленные с помощью диалогового окна Настройка, а также не добавляет удаленные кнопки или команды. Восстановление исходного вида встроенных меню и панелей инструментов.


 Придание панелям инструментов и меню того вида, который они имели в Microsoft Office 97.

Придание панелям инструментов и меню того вида, который они имели в Microsoft Office 97.

  1. В меню Сервис выберите команду Настройка, а затем откройте вкладку Параметры.

    Демонстрация

  2. Снимите флажок Стандартная панель и панель форматирования в одной строке.

  3. Снимите флажок В меню сначала отображаются последние использованные команды.

Примечания

  • Снятие флажка Стандартная панель и панель форматирования в одной строке влияет только на Microsoft Excel. Этот флажок недоступен, если какая-либо из панелей инструментов Стандартная и Форматирование скрыта или если обе панели инструментов являются перемещаемыми.

  • Снятие флажка В меню сначала отображаются последние использованные команды влияет на все программы Microsoft Office.


Сохранение различных настроек для панелей инструментов

При регулярном использовании нескольких панелей инструментов с настроенными пользователем размерами и расположением на экране, эти настройки можно сохранить, что избавит пользователя от необходимости повторной настройки при каждом запуске Microsoft Excel.

  1. Сделайте необходимые настройки встроенных меню и панелей инструментов, а также создайте панели инструментов, которые требуется сохранить. После этого расположите эти панели на экране таким образом, как они должны будут отображаться в дальнейшем.

  2. Выйдите из Microsoft Excel.

  3. Найдите файл Excel.xlb.

  4. Измените имя файла, оставив прежнее расширение .xlb.

Для повторного использования сохраненных настроек откройте переименованный файл настроек панелей инструментов командой Открыть меню Файл. При выходе из Microsoft Excel будет создан новый файл настройки панелей инструментов.


 Вложение настраиваемой панели инструментов в книгу

Вложение настраиваемой панели инструментов в книгу

Чтобы пользовательская панель инструментов всегда использовалась с определенной книгой, следует вложить эту панель в книгу Excel. После этого книгу Excel необходимо сохранить.

  1. Создайте настраиваемую панель инструментов, которую следует вложить в книгу.

    Инструкции

  2. Откройте книгу, в которую следует вложить настраиваемую панель инструментов.

  3. Выберите команду Настройка в меню Сервис, а затем откройте вкладку Панели инструментов.

    Демонстрация

  4. Нажмите кнопку Вложить.

  5. Щелкните настраиваемую панель инструментов, которую следует вложить, а затем нажмите кнопку Копировать.


 Создание пользовательской панели инструментов

Создание пользовательской панели инструментов

  1. Выберите команду Настройка в меню Сервис, а затем откройте вкладку Панели инструментов.

    Демонстрация

  2. Нажмите кнопку Создать.

  3. Введите нужное имя в поле Панель инструментов, а затем нажмите кнопку OK.

  4. Оставьте окно Настройка открытым (если оно будет мешать, переместите его в другую часть экрана) и выполните следующие действия:

    Чтобы добавить кнопку на панель инструментов, перейдите на вкладку Команды. Выберите категорию команды из списка Категории, а затем перетащите нужную команду из списка Команды на панель инструментов.

    Чтобы добавить встроенное меню на панель инструментов, перейдите на вкладку Команды. Выберите категорию Встроенные меню из списка Категории, а затем перетащите нужное меню из списка Команды на панель инструментов.

    Как добавить пользовательское меню на панель инструментов.

  5. После добавления всех кнопок и меню нажмите кнопку Закрыть.


 Добавление кнопки на панель инструментов

Добавление кнопки на панель инструментов

  1. Отобразите панель инструментов, на которую требуется добавить кнопку.

  2. Выберите в меню Сервис команду Настройка, а затем перейдите на вкладку Команды.

    Демонстрация

  3. Выберите нужную категорию из списка Категории.

  4. Перетащите нужную команду или макрос из списка Команды на панель инструментов.

Совет. Чтобы быстро добавить кнопку на встроенную панель инструментов, нажмите кнопку Дополнительные кнопки [image] на закрепленной панели инструментов — или щелкните стрелку Направленная вниз стрелка в левом верхнем углу перемещаемой панели инструментов, — щелкните Добавить или удалить кнопки, а затем установите флажок рядом с кнопкой, которую требуется добавить.


 Добавление встроенного меню на панель инструментов

Добавление встроенного меню на панель инструментов

  1. Отобразите панель инструментов, на которую требуется добавить встроенное меню.

  2. В меню Сервис выберите команду Настройка, а затем откройте вкладку Команды.

    Демонстрация

  3. В списке Категории выберите категорию Встроенные меню.

  4. Перетащите меню из списка Команды на панель инструментов.


 Добавление нового меню на панель инструментов или в имеющееся меню

Добавление нового меню на панель инструментов или в имеющееся меню

  1. Отобразите панель инструментов, на которую требуется добавить новое меню.

  2. В меню Сервис выберите команду Настройка, а затем откройте вкладку Команды.

    Демонстрация

  3. Выберите категорию Новое меню из списка Категории.

  4. Перетащите строку Новое меню из списка Команды на панель инструментов.

  5. Щелкните только что созданное на панели инструментов меню правой кнопкой мыши, введите нужное имя в поле Имя контекстного меню, а затем нажмите клавишу ENTER.

  6. Чтобы добавить команду в новое меню, щелкните имя этого меню для раскрытия пустого списка, выберите нужную категорию команд из списка Категории, а затем перетащите нужную команду из списка Команды в пустой список меню.


 Добавление команды в меню

Добавление команды в меню

  1. Отобразите панель инструментов, содержащую меню, в которое требуется добавить команду.

  2. В меню Сервис выберите команду Настройка, а затем откройте вкладку Команды.

    Демонстрация

  3. Выберите нужную категорию команд из списка Категории.

  4. Перетащите нужную команду из списка Команды на то меню, в которое ее требуется добавить. При отображении списка команд меню переместите команду на нужное место, и после этого отпустите кнопку мыши.


 Назначение кнопки панели инструментов для запуска макроса

Назначение кнопки панели инструментов для запуска макроса

Макрос можно запустить с помощью кнопки на встроенной или специальной панели инструментов. Для получения сведений о создании специальной панели инструментов нажмите кнопку [image] .

  1. Выберите команду Настройка в меню Сервис.

    Демонстрация

  2. Если панель инструментов, содержащая кнопку, не отображается на экране, выберите вкладку Панели инструментов и установите флажок рядом с именем этой панели.

  3. Если на панели инструментов отсутствует кнопка, которая должна запускать макрос, выберите параметр Макросы в списке Категории на вкладке Команды. Из списка Команды перетащите с помощью мыши настраиваемую кнопку на панель инструментов.

  4. Щелкните эту кнопку правой кнопкой мыши и выберите команду Назначить макрос в контекстном меню.

  5. Введите имя макроса в поле Имя макроса.


 Удаление кнопки с панели инструментов

Удаление кнопки с панели инструментов

  1. Отобразите панель инструментов, которую требуется изменить.

  2. Нажмите клавишу ALT и, удерживая ее, перетащите кнопку за пределы панели инструментов.

Примечания

  • Выбор кнопки из списка. Чтобы быстро удалить встроенную кнопку со встроенной панели инструментов, нажмите Дополнительные кнопки [image] на закрепленной панели инструментов — или щелкните стрелку Направленная вниз стрелка в левом верхнем углу перемещаемой панели инструментов, — выберите Добавить или удалить кнопки и затем снимите флажок, соответствующий кнопке, которую требуется удалить.

  • Сохранение кнопок, созданных пользователем, для дальнейшего использования. При удалении встроенной кнопки она остается в диалоговом окне Настройка. Однако кнопки, созданные пользователем, удаляются окончательно. Чтобы удалить созданную пользователем кнопку, сохранив ее для дальнейшего использования, создайте панель инструментов для хранения таких кнопок.


 Удаление пользовательской панели инструментов

Удаление пользовательской панели инструментов

  1. Выберите в меню Сервис команду Настройка, а затем перейдите на вкладку Панели инструментов.

    Демонстрация

  2. Выберите пользовательскую панель инструментов, которую требуется удалить, из списка Панели инструментов.

  3. Нажмите кнопку Удалить.

Примечание. Встроенные панели инструментов удалять нельзя. При выделении встроенной панели инструментов становится доступной кнопка Сброс, которая восстанавливает исходный вид панели инструментов.


Удаление команды из меню

  1. Отобразите панель инструментов, содержащую команду меню, которую требуется удалить.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. На панели инструментов откройте меню, содержащее команду, которую требуется удалить.

  4. Перетащите удаляемую команду за пределы меню.


Удаление меню с панели инструментов

  1. Отобразите панель инструментов, с которой требуется удалить меню.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. Перетащите меню за пределы панели инструментов.

Совет. При удалении встроенного меню оно остается в диалоговом окне Настройка. Однако меню, созданные пользователем, удаляются окончательно. Чтобы удалить созданное пользователем меню, сохранив его для дальнейшего использования, создайте панель инструментов для хранения таких меню.


 Создание панели инструментов для хранения пользовательских меню и кнопок

Создание панели инструментов для хранения пользовательских меню и кнопок

  1. Отобразите панель инструментов, содержащую пользовательскую кнопку, которую требуется сохранить для дальнейшего использования.

  2. Выберите команду Настройка в меню Сервис, а затем откройте вкладку Панели инструментов.

    Демонстрация

  3. Нажмите кнопку Создать.

  4. Введите имя панели в поле Панель инструментов, нажмите кнопку OK, а затем — кнопку Закрыть.

    Вновь созданная панель появится на экране.

  5. Для каждой пользовательской кнопки, которую требуется сохранить, выполните одно из следующих действий:

    Чтобы переместить кнопку на новую панель инструментов, перетащите копку на эту панель, удерживая нажатой клавишу ALT.

    Чтобы скопировать кнопку, перетащите ее, удерживая нажатыми клавиши CTRL+ALT.

  6. Чтобы скрыть новую панель инструментов, щелкните ее правой кнопкой мыши, а затем снимите флажок рядом с ее именем в контекстном меню.


Изменение значка или текста на кнопке панели инструментов или команде меню

Значки на кнопках панели инструментов или командах меню могут быть изменены. Исключением являются кнопки, при нажатии которых выводятся списки или меню. Допускается копирование значков с других кнопок и команд меню, их изменение, а также создание рисунков в графическом приложении и последующее копирование этих рисунков на кнопку или команду меню. На кнопке панели инструментов можно разместить текст и/или значок. На команде меню можно разместить текст либо текст и значок.

Предполагаемые действия

Копирование значка с одной кнопки или команды меню на другую

Копирование рисунка из графического приложения на кнопку панели инструментов или команду меню

Изменение значка кнопки панели инструментов или команды меню

Выбор значка кнопки панели инструментов или команды меню

Отображение текста либо текста и значка на команде меню

Отображение текста и/или значка на кнопке панели инструментов


 Изменение размера кнопок на панели инструментов

Изменение размера кнопок на панели инструментов

  1. В меню Сервис выберите команду Настройка, а затем откройте вкладку Параметры.

    Демонстрация

  2. Установите или снимите флажок Крупные значки.

Примечание. Установка или снятие флажка Крупные значки влияет на все приложения Microsoft Office.


 Изменение ширины раскрывающегося списка на панели инструментов

Изменение ширины раскрывающегося списка на панели инструментов

  1. Отобразите панель инструментов, которую требуется изменить.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. На панели инструментов щелкните раскрывающийся список, который требуется изменить.

  4. Установите указатель на правый или левый край поля (он должен принять вид двусторонней стрелки), а затем перетащите его.


Отображение текста либо текста и значка на команде меню

  1. Отобразите панель инструментов, содержащую команду, которую требуется изменить.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. Откройте меню, содержащее нужную команду.

  4. Щелкните команду меню правой кнопкой мыши, а затем выберите требуемую команду в контекстном меню.

Примечания

  • У некоторых команд нет значка, поэтому на них может быть отображен только текст.

  • На командах меню нельзя отображать значок без текста. Однако, если в контекстном меню команды установлен флажок Основной стиль, то в случае копирования или перемещения ее на панель инструментов она будет отображаться как значок.


Отображение текста и/или значка на кнопке панели инструментов

  1. Отобразите панель инструментов, содержащую кнопку, которую требуется изменить.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. Щелкните кнопку панели инструментов, которую требуется изменить, правой кнопкой мыши, а затем выберите соответствующую команду в контекстном меню.

Примечание. Текст и значки для кнопок, нажатие которых приводит к выводу списка или меню, изменить нельзя.


Группировка связанных кнопок и меню на панели инструментов

Чтобы объединить связанные кнопки и меню в группу, следует вставить разделитель перед первым и после последнего элемента этой группы. Так, кнопки Создать, Открыть, Сохранить и Электронная почта сгруппированы на панели инструментов Стандартная с помощью разделителя, помещенного после кнопки Электронная почта.

  1. Отобразите на экране панель инструментов, на которой требуется сгруппировать связанные кнопки и меню.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. Выполните одно из следующих действий:

    Чтобы вставить разделитель, щелкните кнопку правой кнопкой мыши и затем выберите команду Начать группу в контекстном меню. Разделитель появится слева от кнопки на горизонтальной панели инструментов и над кнопкой, если панель инструментов расположена вертикально.

    Чтобы убрать разделитель между двумя кнопками, перетащите одну кнопку ближе к другой.

Совет. Чтобы быстро вставить или удалить разделитель между кнопками без использования диалогового окна Настройка, нажмите клавишу ALT и, удерживая ее, перетащите нужную кнопку панели инструментов.


Перемещение меню и команд меню

Меню можно перемещать и копировать с одной панели инструментов на другую. Кроме того, можно перемещать подменю, имеющие маркер перемещения Горизонтальная полоса в верхней части подменю, в любую область экрана для создания перемещаемой панели инструментов. Если у подменю отсутствует маркер перемещения, переместить его нельзя.

Предполагаемые действия

Перемещение или копирование меню на панель инструментов

Перемещение подменю в произвольную область экрана

Перемещение или копирование команды меню


Перемещение или копирование кнопки панели инструментов

При перемещении или копировании кнопки с одной панели инструментов на другую необходимо отобразить на экране обе панели инструментов.

  • Выполните одно из следующих действий:

    Для перемещения кнопки перетащите ее на новое место текущей или другой панели инструментов, удерживая нажатой клавишу ALT.

    Для копирования кнопки выполните те же действия, удерживая нажатыми клавиши CTRL+ALT.


Переименование меню

  1. Отобразите панель инструментов с меню, которое требуется переименовать.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. Щелкните меню, которое требуется переименовать, правой кнопкой мыши, а затем введите новое имя в поле Имя контекстного меню.


 Переименование настраиваемой панели инструментов

Переименование настраиваемой панели инструментов

  1. Выберите команду Настройка в меню Сервис, а затем откройте вкладку Панели инструментов.

    Демонстрация

  2. В конце списка Панели инструментов выберите пользовательскую панель инструментов, которую требуется переименовать.

  3. Нажмите кнопку Переименовать.

  4. Введите новое имя в поле Панель инструментов.

Примечание. Встроенную панель инструментов переименовать нельзя.


Переименование команды меню или кнопки панели инструментов

  1. Отобразите панель инструментов с командой или кнопкой, которую требуется изменить.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. Выполните одно из следующих действий:

    Чтобы переименовать команду, щелкните содержащее ее меню, а затем щелкните команду правой кнопкой мыши. Введите новое имя в поле Имя в контекстном меню и нажмите клавишу ENTER.

    Чтобы для выбора команды можно было использовать сочетание клавиши ALT и клавиши с буквой, введите символ & перед буквой, которая будет использоваться для выбора команды. Убедитесь, что эта буква не присвоена другой команде того же меню. Выбранная буква будет подчеркнута в имени команды в меню.

    Чтобы переименовать кнопку, щелкните ее правой кнопкой мыши. Введите новое имя в поле Имя в контекстном меню и нажмите клавишу ENTER.

Примечание. Если на кнопке не отображается текст, то изменение имени будет отражено только в подсказке. Отображение текста, значка или текста и значка на кнопке панели инструментов.


Восстановление исходного вида встроенных меню и панелей инструментов

Предполагаемые действия

Восстановление исходного вида встроенных кнопок панелей инструментов или команд меню

Восстановление исходного вида встроенной панели инструментов

Восстановление исходного вида встроенного меню

Придание панелям инструментов и меню того вида, который они имели в Microsoft Office 97

Не можете сделать выбор?


 Включение и отключение звукового сопровождения для кнопок, меню и других элементов экрана

Включение и отключение звукового сопровождения для кнопок, меню и других элементов экрана

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Установите или снимите флажок Звуковое сопровождение событий.

Примечание. Установка или снятие флажка Звуковое сопровождение событий влияет на все приложения Microsoft Office.


Изменение звукового сопровождения

  1. Нажмите кнопку Пуск на панели задач Windows, выберите меню Настройка и затем — пункт Панель управления.

  2. Дважды щелкните значок Звук [image].

  3. В списке События выберите событие, звуковое сопровождение для которого нужно изменить.

  4. Выберите звук из списка Файл или нажмите кнопку Обзор, чтобы найти требуемый звуковой файл.


 Отображение всех кнопок на панели инструментов

Отображение всех кнопок на панели инструментов

  • Щелкните маркер перемещения Вертикальная полоска на левом краю закрепленной панели инструментов на панели инструментов и переместите панель инструментов в отдельный ряд или перенесите ее от края окна в другое место окна программы, чтобы сделать панель инструментов перемещаемой.


 Отображение названий шрифтов тем же шрифтом

Отображение названий шрифтов тем же шрифтом

Для ускорения отображения списков шрифтов — например, списка Шрифт на панели инструментов Форматирование — названия шрифтов вместо образца шрифта могут отображаться с использованием стандартного шрифта.

  1. В меню Сервис выберите команду Настройка, а затем откройте вкладку Параметры.

    Демонстрация

  2. Снимите флажок Отображать названия шрифтов тем же шрифтом.

Примечание. Установка или снятие флажка Отображать названия шрифтов тем же шрифтом влияет на все программы Microsoft Office.


Управление запуском Microsoft Excel

Предполагаемые действия

Автоматическое открытие книги при запуске Excel

Выбор дополнительной папки автозагрузки

Настройка основных параметров книги или листа с помощью шаблона

Использование ключей автозагрузки при запуске Excel

Отмена загрузки книги при запуске Excel

Установка стандартной рабочей папки в диалоговых окнах Открыть и Сохранить как

Настройки и персонифицированные файлы

Не можете сделать выбор?


Автоматический запуск Microsoft Excel при включении компьютера

  1. В меню Windows Пуск выберите пункт Настройка, а затем Панель задач.

  2. На вкладке Настройка меню нажмите кнопку Добавить.

  3. Нажмите кнопку Обзор.

  4. В поле Папка выберите диск, на котором установлен Microsoft Excel.

  5. В списке папок найдите и откройте папку, содержащую Microsoft Excel.

  6. Дважды щелкните файл Excel.exe, а затем нажмите кнопку Далее.

  7. В списке папок выберите пункт Автозагрузка и нажмите кнопку Далее.

  8. В поле Укажите название ярлыка введите имя ярлыка — например, Excel — и нажмите кнопку Готово.


 Использование надстроек Microsoft Excel

Использование надстроек Microsoft Excel

В Excel существует два типа надстроек, обеспечивающих дополнительные команды и возможности. Надстройки Excel доступны при установке Excel или Office и доступны также в Интернете. Настраиваемые надстройки модели компонентных объектов (COM) могут быть созданы разработчиками.

Предполагаемые действия

Установка надстроек Excel на компьютер

Загрузка установленных надстроек Excel

Выгрузка надстроек Excel

Загрузка и выгрузка надстройки для модели компонентных объектов

Не можете сделать выбор?


 Загрузка и выгрузка надстройки для модели компонентных объектов

Загрузка и выгрузка надстройки для модели компонентных объектов

Разработчикам. Данную процедуру можно использовать для загрузки и выгрузки надстройки для модели компонентных объектов при выполнении тестирования до создания программ установки и удаления надстройки. Сведения о создании надстроек для модели компонентных объектов см. в издании Руководство программиста по Visual Basic для Microsoft Office 2000.

Другим пользователям Microsoft Excel. Данная процедура используется преимущественно разработчиками. Для получения инструкций по установке и удалению надстройки обращайтесь к ее поставщику.

  1. Если в меню Сервис уже присутствует команда Надстройки для модели COM, перейдите к шагу 6.

  2. В меню Сервис выберите команду Настройка, а затем перейдите на вкладку Команды.

    Демонстрация

  3. Выберите категорию Сервис из списка Категории.

  4. Перетащите команду Надстройки для модели COM из списка Команды на меню Сервис. После открытия списка команд меню Сервис, не отпуская кнопку мыши, укажите позицию, в которой следует отображать команду Надстройки для модели COM, а затем отпустите кнопку мыши.

  5. Нажмите кнопку Закрыть в диалоговом окне Настройка.

  6. Выберите команду Надстройки для модели COM в меню Сервис.

  7. В поле Список надстроек выполните одно из следующих действий.

    Для того чтобы загрузить надстройку, установите флажок рядом с ее именем. Если нужная надстройка отсутствует в списке, нажмите кнопку Добавить, найдите надстройку, а затем нажмите кнопку OK.

    Для того чтобы выгрузить надстройку, оставив ее имя в списке, снимите флажок рядом с именем надстройки.

    Для того чтобы удалить надстройку из списка и из памяти, щелкните ее имя, а затем нажмите кнопку Удалить.

Примечание. При выгрузке или удалении файл надстройки не удаляется с компьютера.


Разрешение вопросов при настройке Microsoft Excel

В чем именно заключаются сложности?

Отсутствуют некоторые команды и возможности.

В команде Параметры отсутствуют требуемые установки.

Как изменить панели инструментов и меню, если из меню была убрана команда Настройка?

Не удается найти нужную надстройку Excel.


Разрешение вопросов при работе с панелями инструментов и меню

В чем именно заключаются сложности?

Придание панелям инструментов и меню того вида, который они имели в Microsoft Office 97.

Не удается найти команду меню, кнопку панели инструментов или параметр диалогового окна.

Не удается найти команду Настройка.

При совместной работе с созданной панелью инструментов она выглядит иначе на компьютерах других пользователей.

Отображение всех команд в меню.


 При запуске Microsoft Excel с помощью ярлыка или значка отображается неверная рабочая папка по умолчанию.

При запуске Microsoft Excel с помощью ярлыка или значка отображается неверная рабочая папка по умолчанию.

При запуске Microsoft Excel с помощью ярлыка может не использоваться указанная для этого ярлыка рабочая папка. (То есть папка, указанная в поле Рабочий каталог на вкладке Ярлык. Для доступа к этой вкладке следует щелкнуть правой кнопкой мыши значок ярлыка и выбрать команду Свойства в контекстном меню.) В качестве рабочей Excel использует папку, указанную в поле Рабочий каталог на вкладке Общие в диалоговом окне Параметры (меню Сервис). Изменение рабочей папки по умолчанию.


Не удается найти нужную надстройку Excel

Проверьте файл надстройки на компьютере Файл может быть перемещен, переименован или удален. Файлы надстроек имеют расширение .xla (чтобы увидеть расширение .xla, может быть необходимо включить отображение расширений имен файлов в Windows). Надстройки по умолчанию хранятся в одном из двух мест: или в папке Library и в одной из ее подпапок (папка Microsoft Office\Office), или в папке Profiles\имя_пользователя\Application Data\Microsoft\AddIns в папке Windows. Администратор сети может указать место размещения программ надстроек. За дополнительной информацией обращайтесь к администратору.

Можно переустановить надстройку Excel с помощью той же программы, которая устанавливала Excel. Чтобы найти и загрузить надстройку, не хранящуюся в одной из стандартных папок, выберите команду Надстройки в меню Сервис, а затем нажмите кнопку Обзор.

Если надстройка хранится в сети, проверьте сетевой диск Сетевой диск может быть недоступен. Чтобы гарантировать возможность использования надстройки при автономной работе или отключенном сетевом диске, сохраните копию файла надстройки на своем компьютере.

Если используется другой компьютер, проверьте исходный компьютер Чтобы надстройка была доступна с других компьютеров, необходимо сохранить ее на исходном компьютере в подпапке Profiles\имя_пользователя\Application Data\Microsoft\AddIns папки Windows. Получите у системного администратора информацию о работе на других компьютерах.

Обратитесь к администратору Office или Excel Администратор мог запретить установку надстроек. В этом случае необходимость переустановки Office или Excel может отсутствовать. За дополнительной информацией обратитесь к администратору.


Добавление примечаний и выделение изменений в книге

Выделение изменений
Вставка дополнительных примечаний
Просмотр сведений об изменениях


Добавление примечаний и выделение изменений в книге


Определение допустимых данных в ячейке

Отображение допустимых данных
Приглашение к вводу правильных значений
Сообщение о вводе недопустимых данных
Выделение недопустимых данных


Определение допустимых данных в ячейке


Отчеты сводных диаграмм

Обзор
Представление данных в отчете сводной диаграммы
Различия между отчетами сводных диаграмм и обычными диаграммами


Отчеты сводных диаграмм


Интерактивный анализ данных по отчетам сводных таблиц

Обзор
Исходные данные
Как организованы данные в отчетах сводных таблиц
Структурированные отчеты сводных таблиц
Отчеты сводных диаграмм
Сводные таблицы на Web-страницах


Интерактивный анализ данных по отчетам сводных таблиц


Настройка общей книги

Обзор
Подготовка к совместному использованию книги
Установка книги как общей книги
Сохранение общей книги в сети


Настройка общей книги


Сортировка списка

Сортировка по возрастанию
Сортировка по убыванию
Сортировка данных в строках по нескольким столбцам
Сортировка данных по строкам
Задание порядка сортировки


Сортировка списка


Работа с графическими объектами в Microsoft Excel

Обзор
Стандартные фигуры
Картинки
Рисунки
Специальные текстовые эффекты
Рисунки на диаграммах
Создание рисунков
Использование рисунков в качестве гиперссылок
Использование рисунков для запуска макросов


Работа с графическими объектами в Microsoft Excel


Получение внешних данных с помощью Microsoft Query

Что такое Microsoft Query?
Настройка источников данных
Определение запроса
Работа с данными в Microsoft Excel


Получение внешних данных с помощью Microsoft Query


Зависимости: прослеживание связей между формулами и ячейками

Прослеживание зависимостей на листе
Влияющие ячейки
Зависимые ячейки
Источник ошибки
Изменение ссылок с помощью поиска диапазонов
Вставка примечания
Обведение неверных данных


Зависимости: прослеживание связей между формулами и ячейками


Выбор наиболее подходящей линии тренда для данных

Обзор
арифметическая
Логарифмическая
Полиномиальная
Степенная
Экспоненциальная
Скользящее среднее


Выбор наиболее подходящей линии тренда для данных


Служба FastTips

Microsoft FastTips — это автоматическая бесплатная служба, с помощью которой можно получить ответы на наиболее часто возникающие вопросы 24 часа в сутки, 7 дней в неделю. Для получения доступа к этой службе пользователям, проживающим в США, следует позвонить по телефону (800) 936-4100; при этом необходимо использовать кнопочный телефон с тоновым набором номера. Нажимая кнопки телефона в соответствии с указаниями, можно прослушать запись ответа на интересующий вопрос, получить каталог имеющихся сведений и даже заказать документы по факсу. Например, через службу FastTips можно заказать Application Notes и популярные статьи из Microsoft Knowledge Base по факсу. Пользователям, проживающим в других странах, для получения дополнительных сведений следует связаться с местным представительством корпорации Майкрософт.


Изменение связанных объектов вручную

  1. В меню Правка выберите команду Связи.

    Отсутствие команды Связи в меню означает, что данный файл не содержит связанных данных.

  2. Из списка Исходный файл выберите источник для связанного объекта, а затем выберите команду Обновить.

    Для выделения нескольких связанных объектов, не опуская клавишу CTRL, выберите каждый связанный объект.


 Добавление легенды в диаграмму

Добавление легенды в диаграмму

  1. Выберите диаграмму, в которую необходимо добавить легенду.

  2. В меню Диаграмма выберите команду Параметры диаграммы, а затем перейдите к вкладке Легенда.

  3. Установите флажок в поле Добавить легенду.

  4. В пункте Размещение выберите необходимый параметр.

Примечание. При выборе одного из параметров размещения легенда перемещается, а область построений, чтобы ее вместить, автоматически подстраивается. Если легенда была перемещена или был изменен ее размер при помощи мыши, автоматического изменения области построений не происходит. При использовании параметров размещения изменения, внесенные в легенду при помощи мыши, не сохраняются.


 Добавление заголовка в диаграмму или ось

Добавление заголовка в диаграмму или ось

  1. Выберите диаграмму, в которую необходимо добавить заголовок.

  2. В меню Диаграмма выберите команду Параметры диаграммы, а затем перейдите на вкладку Названия элементов диаграммы.

  3. Для добавления заголовка диаграммы введите необходимый текст в поле Название диаграммы.

    Для добавления одного или нескольких заголовков осей выберите соответствующее поле для каждого заголовка, а затем введите необходимый текст.

Совет. Для включения разрыва строки в заголовок диаграммы или оси выберите текст в диаграмме, укажите место, куда необходимо поместить разрыв и нажмите клавишу ENTER.


 Добавление подписей значений

Добавление подписей значений

Тип диаграммы, связанный с выделенным рядом данных или с точкой данных, определяет тип подписи, которую можно добавить.

  1. Для добавления подписей значений в ряды данных необходимо выбрать ряд.

    Для того чтобы добавить подпись одного значения, щелкните ряд данных, содержащий необходимый маркер данных, а затем щелкните маркер той точки данных, подпись которой требуется добавить.

  2. В меню Формат выберите команду Выделенный ряд или Выделенный элемент данных.

  3. На вкладке Подписи данных выберите необходимые параметры.

Совет. Для быстрого присвоения подписей всем точкам данных щелкните диаграмму, выберите в меню Диаграмма команду Параметры диаграммы, а затем выберите нужные параметры на вкладке Подписи данных.

Примечание. В отчете сводной диаграммы добавляемые или изменяемые подписи данных для отдельных рядов или элементов данных не сохраняются при последующем изменении вида диаграммы или связанного отчета сводной таблицы. Перед добавлением или изменением подписей данных в отчете сводной диаграммы необходимо выбрать нужный вид диаграммы.


 Отображение или скрытие сетки в диаграмме

Отображение или скрытие сетки в диаграмме

Круговые и кольцевые не имеют сетки.

  1. Выберите диаграмму, в которую необходимо добавить сетку.

  2. В меню Диаграмма выберите команду Параметры диаграммы, а затем перейдите к вкладке Сетка.

  3. Установите флажки для тех видов сетки, которые необходимо отобразить.

    Снимите флажки для тех видов сетки, которые необходимо скрыть.


 Редактирование внедренного объекта в программе, отличной от исходной

Редактирование внедренного объекта в программе, отличной от исходной

  1. Выделите внедренный объект, который необходимо изменить.

  2. В меню Правка выберите команду Объект имя объекта (например, Документ), а затем выберите команду Преобразовать.

  3. Для преобразования внедренного объекта в тип, определенный в списке типов объектов, установите флажок преобразовать в.

    Для открытия внедренного объекта в формате, указанном в списке, без изменения типа внедренного объекта установите флажок активизировать как.


Копирование рисунка из графического приложения на кнопку панели инструментов или команду меню

Чтобы значок был четким, копируемый рисунок должен иметь те же размеры, что и встроенные значки на кнопках и командах меню. По умолчанию встроенные кнопки имеют размер 16 на 16 пикселов. Большие рисунки могут быть искажены при их уменьшении до размера кнопки.

  1. Скопируйте в буфер обмена рисунок, который необходимо поместить на кнопку панели инструментов или команду меню.

    Если имеется возможность выбора формата для копирования рисунков, выберите формат рисунка или точечного рисунка.

  2. Перейдите в Microsoft Excel.

  3. Отобразите панель инструментов со значком кнопки или командой, которую требуется изменить.

  4. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  5. Для того чтобы вставить скопированный рисунок, выполните одно из следующих действий.

    Чтобы вставить скопированный рисунок на кнопку панели инструментов, щелкните ее правой кнопкой мыши, а затем выберите в контекстном меню команду Вставить значок для кнопки.

    Чтобы вставить скопированный рисунок в команду меню, щелкните ее правой кнопкой мыши, а затем выберите в контекстном меню команду Вставить значок для кнопки.


Копирование значка с одной кнопки или команды меню на другую

Копировать значок с одной кнопки на другую можно лишь при условии, что вторая кнопка также находится на панели инструментов (текущей или другой).

  1. Отобразите панель инструментов с кнопкой или командой меню, значок которой требуется скопировать, и панель инструментов с кнопкой или командой меню, значок которой необходимо изменить.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. Чтобы скопировать рисунок, выполните одно из следующих действий.

    Чтобы скопировать значок кнопки, щелкните кнопку, значок которой нужно скопировать, правой кнопкой мыши, а затем выберите в контекстном меню команду Копировать значок на кнопке.

    Чтобы скопировать значок команды меню, откройте меню, содержащее команду, значок которой нужно скопировать, щелкните ее правой кнопкой мыши, а затем выберите в контекстном меню команду Копировать значок на кнопке.

  4. Для того чтобы вставить скопированный рисунок, выполните одно из следующих действий.

    Чтобы вставить скопированный рисунок на кнопку панели инструментов, щелкните ее правой кнопкой мыши, а затем выберите в контекстном меню команду Вставить значок для кнопки.

    Чтобы вставить скопированный рисунок в команду меню, щелкните ее правой кнопкой мыши, а затем выберите в контекстном меню команду Вставить значок для кнопки.


Изменение значка кнопки панели инструментов или команды меню

  1. Отобразите панель инструментов с кнопкой или командой меню, значок которой требуется изменить.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. Для того чтобы изменить значок, выполните одно из следующих действий.

    Чтобы изменить значок кнопки панели инструментов, щелкните ее правой кнопкой мыши, а затем выберите в контекстном меню команду Изменить значок на кнопке.

    Чтобы изменить значок команды меню, щелкните ее правой кнопкой мыши, а затем выберите в контекстном меню команду Изменить значок на кнопке.

  4. Внесите необходимые изменения.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.


 Редактирование внедренного объекта в исходной программе

Редактирование внедренного объекта в исходной программе

  1. Для открытия дважды щелкните кнопку мыши на внедренном объекте.

  2. Внесите в объект необходимые изменения.

  3. Если редактирование объекта происходит в открытой программе, то для возвращения в конечный файл нажмите кнопку мыши где-нибудь за пределами объекта.

    Если редактирование внедренного объекта происходит в исходной программе в отдельном окне, то для возвращения в конечный файл выберите команду Выход в меню Файл.

Примечание. Двойное нажатие кнопки мыши на некоторых внедренных объектах, таких как видео и аудио клипы, проигрывает объект, а не открывает программу. Для редактирования одного из таких внедренных объектов выберите объект, в меню Правка установите курсор на тип объекта Объект, а затем выберите команду Изменить.


 Создание внедренного объекта

Создание внедренного объекта

  1. Выберите лист или лист диаграммы, на который необходимо поместить внедренный объект.

  2. В меню Вставка выберите команду Объект, а затем перейдите к вкладке Новый.

    Демонстрация

  3. В поле Тип объекта выберите необходимый тип.

  4. Если другие пользователи будут просматривать книгу, то объект можно вывести на экран в виде значка. Для этого установите флажок В виде значка. Для просмотра объекта пользователям необходимо дважды щелкнуть кнопкой мыши на значке.

Примечание. В поле Тип объекта выведены только программы, установленные на компьютере и поддерживающие механизм OLE.


 Отправка листа или книги по электронной почте в качестве вложения

Отправка листа или книги по электронной почте в качестве вложения

Требования, которым должна удовлетворять система для отправки документов

  1. Откройте в Microsoft Excel книгу или лист, который следует отправить в качестве вложения.

  2. Выберите в меню Файл команду Отправить, а затем подкоманду Сообщение (как вложение).

  3. Ввведите в поля Кому и Копия имена получателей через точку с запятой.

  4. Установите требуемые параметры для сообщения.

  5. Нажмите кнопку Отправить [image] .

Примечание. При попытке отправить в качестве вложения в сообщение электронной почты файл HTML Microsoft Excel автоматически преобразует этот файл в формат .xls.


Служба Microsoft Download Library (MSDL)

Служба Microsoft Download Library предлагает демонстрационные программы, драйверы, исправленные и обновленные версии программ, а также вспомогательные программные средства. Прямой доступ к MSDL по модему можно получить, набрав номер (206) 936-6735 в Соединенных Штатах или (905) 507-3022 в Канаде. Доступ к MSDL открыт 24 часа в сутки, 365 дней в году. Пользователям, проживающим в других странах, для получения дополнительных сведений следует связаться с местным представительством корпорации Майкрософт.

Примечание. При подключении к данной службе поддерживаются следующие параметры: скорости передачи 1200, 2400, 9600 и 14,400 бит/с, проверка четности отсутствует, 8 битов данных, 1 стоповый бит.


 Открытие книги на жестком диске или в сети

Открытие книги на жестком диске или в сети

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск, папку или адрес FTP, где находится книга, которую требуется открыть, и затем найдите и дважды щелкните папку, содержащую книгу.

    Если найти книгу не удается, можно воспользоваться процедурой поиска файлов.

    Инструкции

  3. Дважды щелкните книгу, которую нужно открыть.

Примечания

  • Чтобы открыть недавно использовавшийся файл, нажмите кнопку Журнал [image] на панели адресов.

  • При открытии файла HTML, созданного или сохраненного в программе Office, он будет открыт в той программе, в которой было выполнено последнее сохранение файла. Чтобы открыть этот файл в Microsoft Excel, нажмите стрелку справа от кнопки Открыть и выберите команду Открыть в Microsoft Excel.

  • Также можно открыть книгу в сети с использованием адреса UNC.


 Восстановление исходного вида встроенной панели инструментов

Восстановление исходного вида встроенной панели инструментов

  1. Выберите в меню Сервис команду Настройка, а затем перейдите на вкладку Панели инструментов.

    Демонстрация

  2. Выберите панель инструментов, на которой требуется восстановить исходный набор кнопок и меню.

  3. Нажмите кнопку Сброс.

Примечание. Эта команда неприменима к пользовательским панелям инструментов.


Отправка книги по маршруту

Отправитель книги, распространяемой по маршруту, должен создать этот маршрут.

Инструкции

Получатель книги должен выполнить следующие действия.

  1. Откройте книгу, которую следует отправить по маршруту.

  2. Для отправки книги следующему пользователю в маршруте выберите команду Отправить в меню Файл, а затем — команду Следующий адресат. Далее выберите параметр Отправить документ имя адресата.

    Для отправки книги пользователю, не включенному в список, выберите команду Отправить в меню Файл, а затем — команду Другой адресат.

Совет. Отправляемая по маршруту книга помещается в сообщение электронной почты в виде вложения. Открывать ее следует в соответствии с правилами, действующими для выбранной почтовой программы. При работе с Microsoft Exchange для открытия книги достаточно дважды щелкнуть ее значок.


Не удается обновить автоматические связи на листе Microsoft Excel

Для того чтобы связи с данными других программ обновлялись автоматически, выберите пункт Параметры меню Сервис, перейдите на вкладку Вычисления и выберите параметр обновлять удаленные ссылки. Если этот флажок не установлен, параметр автоматически диалогового окна Связи (меню Правка) для связанных источников данных других приложений, например, для документа Microsoft Word или базы данных Microsoft Access подавляется.


Изменение способа редактирования связанных объектов

  1. В меню Правка выберите команду Связи.

    Отсутствие команды Связи в меню означает, что данный файл не содержит связанных данных.

  2. Из списка Исходный файл выберите связанный объект, который необходимо изменить.

    Для выделения нескольких связанных объектов, не опуская клавишу CTRL, выберите каждый связанный объект.

  3. Для изменения связанного объекта каждый раз при открытии файла, содержащего данный объект, или каждый раз при изменении исходных данных при открытом файле, выберите команду Автоматически.

    Если изменения связанных объектов необходимо производить при выборе команды Обновить, выберите команду по запросу.


 Условия поиска, которые можно задавать в поле «Имя файла»

Условия поиска, которые можно задавать в поле «Имя файла»

При поиске файлов введите в поле Имя файла диалогового окна Открытие документа (меню Файл) какие-либо из следующих условий и нажмите клавишу ENTER.

Условие | Пример
Частичное имя файла | Введите region, чтобы найти все файлы, в имя которых входит слово "region".
Расширения файлов | Введите *.txt для поиска текстовых файлов.
Подстановочные знаки | Для поиска только тех файлов, которые оканчиваются на "region", введите *region; или, например, введите gr?y для поиска файлов с именами, содержащими "gray" и "grey". Звездочка (*) заменяет любое число символов, знак вопроса (?) заменяет любой одиночный символ.
Полный путь к файлу | Например, C:\Финансы\Налоги1999. При указании диска, сетевого ресурса или папки программа автоматически отображает местоположение файла в поле Папка, в поле Имя файла выводит только его имя, а затем открывает файл.
Список путей | Например, C:\Финансы;C:\Мои документы. Пути следует разделять точкой с запятой (;). При поиске отображаются все файлы, пути к которым соответствуют введенным в поле Имя файла. Однако в поле Папка отображается только первый введенный путь.
Адрес Интернета | Для подключения к серверу Интернета или интрасети организации введите адрес URL (только FTP или HTTP), например http://example.microsoft.com/.

Совет. Для повторного использования ранее введенных данных щелкните стрелку рядом с полем Имя файла и выберите нужную запись.


Присваивание имен ячейкам книги

Заголовки и имена. Для представления ячеек или диапазонов ячеек в формулах можно использовать заголовки столбцов и строк, определяющие данные на листе, или имена. Например, если диапазон C5:C20 содержит данные по продажам и этому диапазону присвоено имя Продажи, то для расчета итогового значения для диапазона вместо формулы =СУММ(C5:C20) можно воспользоваться формулой =СУММ(Продажи). Заголовки можно использовать в формулах, содержащих ссылки на данные на том же листе; для представления группы ячеек, находящейся на другом листе, этой группе следует присвоить имя. См. сведения о заголовках и именах.

Создание имен для представления ячеек. Если на рабочем листе имеется большое количество формул, в которых используется множество различных значений, то для того чтобы сделать формулы более наглядными, ячейкам и группам ячеек можно присвоить имена. Имена, представляющие ячейки, можно также использовать в формулах на других листах и в других книгах. Инструкции по заданию имени ячейки или диапазона ячеек.

Использование существующих заголовков строк и столбцов в качестве имен. Существующие заголовки строк и столбцов можно использовать в формулах на других листах или в других книгах в качестве имен, представляющих связанные ячейки. Инструкции по заданию имен ячеек с использованием существующих заголовков строк и столбцов.

Использование имен для ссылки на одни и те же ячейки на нескольких листах. Для обращения к одной и той же ячейке или диапазону ячеек на нескольких листах можно создавать трехмерные ссылки. Инструкции по заданию имен ячеек на нескольких листах с использованием трехмерной ссылки.

Дополнительные сведения

Правила задания имен ячеек


 Указание типа интерактивных действий

Указание типа интерактивных действий

Для предоставления другим пользователям возможности работать с данными на Web-странице с помощью Web-обозревателя, данные можно сделать интерактивными.

  • Чтобы сделать данные интерактивными, установите флажок Добавить и выберите нужный тип интерактивных действий из списка.

Доступные типы интерактивности зависят от того, какого типа данные публикуются. Например, если публикуется лист, содержащий формулы, выберите пункт Работа с электронными таблицами; при этом пользователи, работающие с Web-страницей, смогут вводить новые значения в ячейки, и будет проводиться автоматический расчет результатов по формулам. При публикации отчета сводной таблицы следует выбрать вариант Работа со сводными таблицами, что позволяет пользователям, работающим с Web-страницей, изменять расположение строк и столбцов для получения различных итоговых результатов на основе исходных данных. Если публикуется диапазон внешних данных, также следует выбрать вариант Работа со сводными таблицами, с тем чтобы пользователи, работающие с Web-страницей, могли обновлять данные. Способы публикации данных Microsoft Excel в Web.


Указание заголовка

При публикации листа или фрагмента листа можно добавить заголовок, который будет отображаться по центру над опубликованными данными. Если заголовок не добавлен, данные будут отображены без заголовка.

  • Чтобы добавить заголовок к листу или фрагменту листа на Web-странице, нажмите кнопку Изменить и затем введите заголовок в поле Заголовок.

Примечание. Если выбрать в меню Файл команду Сохранить как Web-страницу, затем сохранить в виде Web-страницы всю книгу с помощью диалогового окна Сохранение документа, указанный заголовок будет отображаться в строке заголовка Web-обозревателя.


 Задание данных для публикации

Задание данных для публикации

Чтобы указать лист или фрагмент листа, который требуется опубликовать, выберите соответствующий элемент в списке Выбрать. (Опубликовать одновременно более одного элемента нельзя. Для публикации другого элемента выберите в списке новый элемент и повторите процедуру публикации.)

  • Целые листы. Выберите пункт Документы Имя листа и затем выберите Все содержимое Имя листа.

  • Элементы. Выберите пункт Документы Имя листа и затем выберите элемент листа, который требуется опубликовать, например отчет сводной таблицы или диаграмму.

  • Диапазоны ячеек. Выберите пункт Диапазон ячеек и затем, если поле выбора не содержит требуемый диапазон, нажмите кнопку свертывания диалогового окна [image] справа от поля выбора, выберите диапазон ячеек из книги Microsoft Excel, и затем нажмите кнопку развертывания диалогового окна [image] .

  • Фильтрованные списки. Если требуется включить в публикацию как отображаемые, так и скрытые элементы фильтрованного списка, выберите пункт Документы Имя листа (но не Диапазон ячеек), установите флажок Добавить и выберите из списка пункт Работа с электронными таблицами.

  • Внешние диапазоны данных. Если требуется наличие возможности обновления внешнего диапазона данных на публикуемой странице, выберите пункт Документы Имя листа и выберите фрагмент, который требуется опубликовать; затем установите флажок Добавить и выберите из списка пункт Работа со сводными таблицами.

  • Повторная публикация. Для повторной публикации листа или фрагмента листа выберите пункт Опубликованные раннее документы и затем выберите лист или фрагмент листа, который требуется опубликовать повторно. Для предотвращения повторной публикации какого-либо элемента, содержащегося в списке опубликованных документов, выберите элемент и нажмите кнопку Удалить.

Примечания

  • Целые книги. Опубликовать целую книгу с помощью диалогового окна Публикация Web-страницы нельзя. Если требуется разместить на Web-странице целую книгу, выйдите из диалогового окна Публикация Web-страницы, выберите в меню Файл команду Сохранить как Web-страницу, введите имя в поле Имя файла и нажмите кнопку Сохранить.

  • Листы с интерактивными диаграммами. При публикации всего содержимого листа, диаграммы с интерактивными возможностями не будут включены в Web-страницу. Чтобы разместить интерактивную диаграмму на Web-странице, следует опубликовать диаграмму отдельно.

  • Порядок размещения элементов рисунка. При публикации рисунка с интерактивными возможностями рисунок становится единым объектом; возможность управления порядком размещения элементов рисунка не сохраняется.


 Указание места публикации

Указание места публикации

При создании Web-страницы рекомендуется сохранить ее на локальном жестком диске и вносить все необходимые изменения до публикации Web-страницы для общего использования или совместного доступа. Когда Web-страница готова к публикации, для нее можно указать расположение, например, узел HTTP, узел FTP, Web-папку, Web-сервер или сетевой сервер.

  • Чтобы указать место публикации для Web-страницы, нажмите кнопку Обзор, выберите место для публикации данных и нажмите кнопку OK. Если место публикации вводится вручную, необходимо ввести путь и имя файла в поле Имя файла. См. сведения о сохранении файлов в Web и создании Web-папок.


 В диалоговом окне «Открытие документа» не отображен нужный файл

В диалоговом окне «Открытие документа» не отображен нужный файл

В диалоговом окне Открытие документа введите имя файла в поле Имя файла; убедитесь, что выбран правильный тип файла в поле Тип файлов. В меню Сервис выберите команду Найти, установите флажок Просмотреть вложенные и нажмите кнопку Найти для выполнения поиска во всех вложенных папках текущей папки.

Проверка условий поиска. Убедитесь в том, что условия, перечисленные в области Условие диалогового окна Найти соответствуют файлам, которые требуется найти. Чтобы очистить условия поиска, нажмите кнопку Сброс. Проверьте правильность задания диска и папки, в которой выполняется поиск.

Поиск всех файлов. В поле Тип файлов (диалоговое окно Открытие документа) выберите пункт Все файлы.

Просмотр всех вложенных папок. Выберите команду Найти в меню Сервис (диалоговое окно Открытие документа) и установите флажок Просмотреть вложенные.

Отображение скрытых файлов. Чтобы отобразить все файлы, включая файлы таких типов, как *.dll и *.sys, нажмите кнопку Windows Пуск, выберите пункт Программы, а затем программу Проводник. Выберите в меню Вид команду Свойства папки; установите на вкладке Вид переключатель Показать все файлы.

Поиск по нескольким путям. Поиск может проводиться по нескольким путям, заданным в поле Имя файла. Пути следует разделять точкой с запятой — например, c:\Финансы;c:\Мои документы.

Подключение к сетевому диску. Если сетевой диск, на котором производится поиск, отсутствует в поле Папка, выберите команду Подключить сетевой диск в меню Сервис. В списке Диск выберите диск, который нужно подключить. В поле Путь введите путь к файлу, находящемуся в сети, и нажмите кнопку OK. Поиск файлов в сети также возможен в случае, если сеть поддерживает адреса UNC. Введите адрес UNC в поле Имя файла диалогового окна Открытие документа — например, \\планы\документы.

Поиск в Web-папках. Если требуется найти файлы на Web-сервере, нажмите кнопку Web-папки на панели адресов в диалоговом окне Открытие документа, чтобы отобразить папки на сервере. Откройте папку, содержащую нужный документ. Также можно ввести путь к папке в поле Имя файла диалогового окна Открытие документа — например, http://example.microsoft.com/. Установка и настройка Web-сервера выполняется системным администратором.


Команды "Сообщение" и "По маршруту" отсутствуют в подменю "Отправить" (меню "Файл")

Убедитесь, что на компьютере установлено приложение Microsoft Exchange или любая другая 32-разрядная программа электронной почты, совместимая с интерфейсом MAPI (Messaging Application Programming Interface). Допускается также использование Lotus cc:Mail или любой другой 16-разрядной программы электронной почты, совместимой с VIM (Vendor Independent Messaging). По вопросам установки нужной программы электронной почты обратитесь к системному администратору.

Если Microsoft Exchange или совместимая программа электронной почты установлена, убедитесь, что файл Mapi32.dll находится в системной папке Windows.

Если используется Lotus cc:Mail или совместимая программа электронной почты, убедитесь, что файлы Mapivi32.dll, Mapivitk.dll и Mvthksvr.exe находятся в системной папке Windows.


 При поиске выводятся неверные имена файлов

При поиске выводятся неверные имена файлов

Поиск не завершен. Программы Microsoft Office используют индексы, созданные программой быстрого поиска файлов, для ускорения поиска по содержимому или свойствам. Если при поиске используется устаревший индекс, то вначале могут выводиться неверные или несуществующие имена. После завершения поиска будут выведены верные имена файлов.

Устаревшие индексы. При установке Office программа быстрого поиска файлов автоматически создает индексный файл для каждого жесткого диска компьютера (например, C:\), в котором отражены все документы Office. Каждые два часа происходит обновление этих индексов. Чтобы убедиться в том, что индексы не устарели, дважды щелкните значок Быстрый поиск [image] на панели управления Windows. После появления диалогового окна программы поиска файлов выполните следующие действия:

  • Убедитесь, что индексы обновляются автоматически. В меню «Индекс» выберите команду Обновить индекс. Выберите нужный индекс и установите флажок Обновлять автоматически. Чаще всего индекс (если он существует) находится в корневом каталоге диска или сетевого ресурса. Если нет уверенности в существовании или местоположении индекса, создайте его в корневом каталоге диска или ресурса, где будет производиться поиск. Если индекс уже содержится в корневом каталоге или в подкаталоге, программа быстрого поиска выведет запрос об обновлении этого индексного файла.

  • Проверьте журнал на наличие ошибок. Откройте журнал индексации путем выбора команды Вывести журнал в меню Индекс. В этом журнале отражены текущие и завершенные задачи индексирования программы быстрого поиска, включая все имевшие место ошибки. Проверьте, есть ли индексный файл в папке или на диске, где содержатся искомые файлы. Например, если происходит поиск файлов на диске C, проверьте, существует ли индекс для каталога C:\. Также проверьте, не содержит ли журнал сведений об ошибках, имевших место в процессе обновления индекса. При помощи команды Обновить индекс в меню Индекс можно обновить нужный индексный файл.

  • Установите меньший интервал обновления индекса. Убедитесь, что частота обновления индекса достаточна для данных файлов. Если изменение, создание или удаление индексированных файлов происходит часто, то можно установить более короткий интервал. Для изменения интервала обновления воспользуйтесь командой Интервал обновления в меню Индекс.

  • Отключите паузу обновления индекса. Убедитесь, что команда Пауза в меню Индекс отключена. Если она включена, то можно заново начать процесс индексации путем повторного выбора команды Пауза. Программа быстрого поиска файлов автоматически перезапускает процесс индексации после перезагрузки компьютера. На портативном компьютере, работающем от аккумуляторов, программа быстрого поиска автоматически включает режим паузы для сбережения энергии батарей.

  • Создайте ярлык для программы быстрого поиска файлов. Убедитесь, что ярлык для программы поиска файлов находится в папке Автозагрузка Windows. Если нет, то следует создать его. Исполняемый файл программы быстрого поиска файлов, Findfast.exe, находится в подкаталоге Office папки Program Files\Microsoft Office. Подробные сведения об автоматической загрузке программ при каждом запуске Windows можно найти в документации по Windows.


 При попытке сохранения изменений в книге выводится сообщение о том, что книга является доступной только для чтения

При попытке сохранения изменений в книге выводится сообщение о том, что книга является доступной только для чтения

Изменения в книге, доступной только для чтения, не могут быть сохранены. Чтобы записать изменения, необходимо сохранить книгу с другим именем. При сохранении книги в новой папке можно использовать исходное имя файла.

  • В меню Файл выберите команду Сохранить как, ведите новое имя в поле Имя файла и нажмите кнопку Сохранить.


При использовании сохраненных условий поиска многие из ранее найденных файлов не были обнаружены.

Проверьте, включен ли в условия поиска сетевой диск.

Убедитесь, что сетевой диск доступен. Если сетевой диск включен в условия поиска, убедитесь, что он доступен.

Убедитесь, что файлы не были удалены. Если сетевой диск не включен в условия поиска, отсутствующие файлы могли быть удалены или переименованы с момента последнего поиска.

Обновите индекс программы быстрого поиска файлов. Если задано обновление индексов программы быстрого поиска файлов вручную, то при перемещении какого-либо файла необходимо обновить индекс. Для получения дополнительных сведений нажмите кнопку [image] .


Ввод формулы для вычисления значения

Формулы. Формулы являются уравнениями, в соответствии с которыми выполняется расчет значений на листе. Можно создавать формулы, выполняющие простые арифметические операции, например сложение чисел, или формулы для выполнения сложных операций над числами. Инструкции по вводу формулы.

Формулы, содержащие функции. В формулах можно использовать функции. Функции представляют собой встроенные формулы, выполняющие простые или сложные вычисления. Например, можно использовать функцию СУММ для нахождения суммы значений диапазона ячеек. Инструкции по вводу формулы, содержащей функцию.

Формулы массивов. Формулы массивов выполняют ряд вычислений и возвращают в качестве результата одно или несколько значений. Например, на листе, содержащем данные о продажах по нескольким регионам, формулу массива можно использовать для расчета среднего значения продаж для любого региона с помощью единственной формулы. См. сведения о формулах массивов.

Расчет значений с помощью формул. Для использования формулы необходимо иметь представление о правильном построении формул, использовании ссылок на ячейки и упрощении формул с использованием функций. См. сведения о расчете значений с помощью формул.


Элементы отчета сводной таблицы

Основной отчет сводной таблицы
Структурированный отчет сводной таблицы


Элементы отчета сводной таблицы


 Обрезка рисунка

Обрезка рисунка

  1. Выделите рисунок, который следует обрезать.

  2. Нажмите кнопку Обрезка [image] на панели инструментов Настройка изображения.

  3. Установите указатель обрезки на маркер изменения размера и перетащите его.

Примечание. Выполнить обрезку анимированного рисунка в формате GIF с помощью панели инструментов Настройка изображения Microsoft Excel нельзя. Для внесения изменений в такие рисунки следует воспользоваться соответствующей программой для редактирования анимированных рисунков в формате GIF, а затем снова вставить файл в книгу.


Группирование графических объектов

  1. Удерживая нажатой клавишу SHIFT, выделите объекты, которые следует объединить в группу.

  2. На панели инструментов Рисование нажмите кнопку Действия, а затем выберите команду Группировать.


Перегруппировка графических объектов

  1. При работе с несколькими группами графических объектов, выделите любой из ранее сгруппированных объектов.

  2. На панели инструментов Рисование нажмите кнопку Действия, а затем выберите команду Перегруппировать.


Задание точных размеров графического объекта

  1. Выделите графический объект, размеры которого следует изменить.

  2. Выберите в меню Формат команду, соответствующую типу выделенного объекта, например, Автофигура или Рисунок, а затем перейдите на вкладку Размер.

  3. Введите необходимые параметры в поля Высота и Ширина в группе Масштаб.

Совет. Для сохранения пропорций объекта при изменении его размеров установите флажок Сохранить пропорции на вкладке Размер.


Разгруппирование графических объектов

  1. Выделите группу, которую необходимо разгруппировать.

  2. На панели инструментов Рисование нажмите кнопку Действия, а затем выберите команду Разгруппировать.


Примеры диаграмм различных типов

С областями
Гистограмма
Линейчатая
График
Круговая
Кольцевая
Биржевая
Точечная
Пузырьковая
Лепестковая
Поверхность
Коническая, цилиндрическая и пирамидальная


Примеры диаграмм различных типов


 Восстановление связей между форматами чисел на листе и на соответствующей диаграмме

Восстановление связей между форматами чисел на листе и на соответствующей диаграмме

При изменении формата чисел на диаграмме теряется его связь с ячейками листа.

  1. Для восстановления форматов чисел для подписей делений на оси установите указатель на нужную ось и дважды нажмите кнопку мыши.

    Для восстановления форматов чисел для подписей значений или подписей линий тренда установите указатель на любую подпись и дважды нажмите кнопку мыши.

  2. Установите флажок Связь с источником на вкладке Число.


Порядок просмотра форм на экране и их вывода на печать

Обзор
Элементы формы
Доступ пользователей и ограничения на ввод данных
Окончательная настройка


Порядок просмотра форм на экране и их вывода на печать


Организация данных в диаграмме

Отображаемые данные
Дополнительная ось значений
Порядок категорий и значений
Порядок рядов данных
Пустые ячейки


Организация данных в диаграмме


Вычисление значений в формулах

Понятие формулы
Построение формулы
Ссылки на ячейки
Применение функций


Вычисление значений в формулах


Имя сохраненного файла содержит две точки

Хотя в именах файлов Windows 95 и Windows 98 могут содержаться знаки препинания, например точка или запятая, не следует вводить точку в конце имени файла. Microsoft Excel автоматически добавляет точку и стандартное расширение файла к указанному имени. Расширение определяет тип файла и приложение, используемое для работы с файлом.


 Флажок «Вносить изменения на отдельный лист» недоступен

Флажок «Вносить изменения на отдельный лист» недоступен

Включите выделение исправлений. В книге, для которой не организован совместный доступ, возможность выделения изменений остается недоступной, пока не установлен флажок Отслеживать исправления (команда Выделить исправления, подменю Исправления меню Сервис). При установке этого флажка книга становится общей, и включается ведение журнала изменений, что обеспечивает возможность просмотра списка изменений на новом листе (листе изменений).

Внесите какие-либо изменения и сохраните книгу. Просмотреть лист изменений нельзя, пока книга не сохранена как общая, и кто-нибудь из пользователей не внес и не сохранил какие-либо изменения. Чтобы отобразить лист изменений, установите флажок Отслеживать исправления, а затем нажмите кнопку OK. Сохраните книгу, когда это будет предложено. Внесите какие-либо изменения и снова сохраните книгу. В следующий раз при выборе команды Выделить исправления флажок Вносить изменения на отдельный лист будет доступен.


 Ошибка макроса

Ошибка макроса

Если в запущенном макросе произошла ошибка, указанный метод не может использоваться с данным объектом по одной из причин:

  • Аргумент содержит недействительную величину. Обычная причина ошибок такого рода – попытка получить доступ к несуществующему объекту; например, Книги(5), когда открыты только три книги.

  • Метод нельзя употребить в данном контексте. Например, некоторые методы объекта Диапазон требуют, чтобы диапазон содержал данные. В противном случае, произойдет ошибка.

  • Произошла ошибка извне. Например, невозможно открыть файл.

За дополнительными сведениями об использовании метода, обращайтесь к справке по Visual Basic.


Автоматическая запись сведений о книгах в дневник Outlook

Для выполнения этой процедуры необходимо установить на компьютере и выполнить настройку программы Microsoft Outlook.

  1. Запустите Outlook.

  2. В меню Сервис выберите пункт Параметры.

  3. На вкладке Настройки нажмите кнопку Параметры дневника.

  4. В списке Записывать также файлы из установите флажок Microsoft Excel.

Примечание. Автоматически записываемые в дневник Outlook книги иногда появляются в дневнике не сразу, а спустя несколько минут.


Отображение связанного или внедренного объекта в виде значка

  1. Выберите связанный или внедренный объект, который необходимо представить в виде значка.

  2. В меню Правка выберите команду Объект имя объекта (например, Документ), а затем выберите команду Преобразовать.

  3. Установите флажок показывать как значок.

  4. Для изменения изображения и метки значка, установленных по умолчанию, выберите команду Смена значка.


Отображение содержимого связанного или внедренного объекта

  1. Выберите значок, представляющий связанный или внедренный объект, который необходимо отобразить.

  2. В меню Правка выберите команду Объект тип объекта (например, Документ), а затем выберите команду Преобразовать.

  3. Снимите флажок Показывать как значок.


Включение и отключение советов помощника

  1. Щелкните изображение помощника.

    Если помощник не отображается на экране, выберите команду Показать помощника в меню Справка.

  2. Нажмите кнопку Параметры.

  3. В списке Отображать советы установите флажки для нужных типов советов и снимите флажки для тех типов советов, которые отображать не следует.


Включение и отключение справки по мастерам, выводимой помощником

  1. Щелкните изображение помощника.

    Если помощник не отображается на экране, выберите команду Показать помощника в меню Справка.

  2. Нажмите кнопку Параметры.

  3. На вкладке Параметры установите или снимите флажок отображать справку для мастеров.

Примечания

  • Помощник предоставляет справку не для всех мастеров.

  • Справка для мастеров недоступна, когда помощник отключен.


Включение и отключение автоматического подбора разделов справки помощником

Помощник может подбирать разделы справки, относящиеся к выполняемой задаче, автоматически, без специального запроса.

  1. Щелкните изображение помощника.

    Если помощник не отображается на экране, выберите команду Показать помощника в меню Справка.

  2. Нажмите кнопку Параметры.

  3. На вкладке Параметры установите или снимите флажок подбирать разделы справки.


 Запись сведений о файлах в дневник Outlook вручную

Запись сведений о файлах в дневник Outlook вручную

Для выполнения данной процедуры необходимо, чтобы Microsoft Outlook был установлен на компьютере и настроен; файл, для которого требуется внести запись в дневник, должен быть закрыт.

  1. Запустите Outlook.

  2. На панели Outlook выберите Другие или Другие ярлыки.

  3. Дважды щелкните значок Мой компьютер [image] , а затем найдите файл, сведения о котором следует записать.

    Если папка Мой компьютер недоступна, необходимо установить систему интегрированного управления файлами Microsoft Outlook. Установка программы или компонента.

  4. На панели Outlook выберите Outlook или Ярлыки Outlook; необходимо, чтобы был виден значок Дневник [image] .

  5. Перетащите файл, сведения о котором следует записать, в Дневник [image].

  6. Выберите необходимые параметры и затем нажмите кнопку Сохранить и закрыть [image] .

    Для получения сведений о каком-либо параметре выберите команду Что это такое? в меню Справка, а затем щелкните параметр.


 Перемещение подменю в произвольную область экрана

Перемещение подменю в произвольную область экрана

Перемещать можно только те подменю, которые имеют маркер перемещения Горизонтальная полоса в верхней части подменю.

  1. Отобразите панель инструментов с подменю, которое требуется переместить.

  2. Откройте подменю.

  3. Щелкните маркер перемещения Горизонтальная полоса в верхней части подменю, а затем перетащите подменю на новое место.

    Подменю будет преобразовано в перемещаемую панель инструментов.


Перемещение или копирование меню на панель инструментов

  1. Отобразите панель инструментов с нужным меню и панель инструментов, на которую его требуется перенести или скопировать.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. Выполните одно из следующих действий:

    Чтобы переместить меню, перетащите его на новое место текущей или другой панели инструментов.

    Чтобы скопировать меню, выполните те же действия, удерживая нажатой клавишу CTRL.


 Открытие книги во внутренней сети предприятия или в World Wide Web

Открытие книги во внутренней сети предприятия или в World Wide Web

В Microsoft Excel можно открывать книги, хранящиеся в интрасети, если такая сеть имеется в вашей организации. Для открытия книг, находящихся на узлах HTTP в World Wide Web, необходимо иметь доступ к Интернету либо через прямое соединение, либо посредством удаленного доступа через поставщика услуг Интернета.

  1. Нажмите кнопку Открыть [image] .

  2. В поле Имя файла введите адрес книги, которую требуется открыть, а затем нажмите клавишу ENTER. Например, для получения доступа к данным о котировках акций, хранящимся во внутренней сети предприятия, может быть введен адрес
    http://myserver/quote.xls
    .

    Если в поле Имя файла введен адрес без указания имени файла, например http://myserver/, в Microsoft Excel автоматически будет открыта начальная страница HTML указанного узла. При вводе адреса без указания имени файла и префикса http://, например адреса myserver, папка myserver будет отображена в поле Папка, и в этой папке можно будет выбрать требуемый файл.

Примечания

  • Таким же образом можно открыть книгу на узле FTP или файл на Web-сервере.

  • Также имеется возможность с помощью Microsoft Excel открывать в обозревателе документы HTML.

  • Чтобы сохранить книгу на Web-странице, следует либо скопировать файл книги Excel (.xls) с указанием соответствующего адреса HTTP, либо преобразовать файл Excel в формат HTML.

Совет. Чтобы быстро открыть книгу, введите ее адрес в поле Адрес на панели инструментов Web и нажмите клавишу ENTER.


Восстановление исходного вида встроенного меню

  1. Отобразите панель инструментов, содержащую меню, исходный вид которого требуется восстановить.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. Щелкните меню, которое требуется восстановить, правой кнопкой мыши, а затем выберите команду Сброс в контекстном меню.

Примечание. Также можно восстановить исходный набор команд в настраиваемых (сокращенных) меню, соответствующий их виду при первом запуске Microsoft Excel.


 Открытие книги в сети с помощью адреса UNC

Открытие книги в сети с помощью адреса UNC

  1. Нажмите кнопку Открыть [image] .

  2. В поле Имя файла введите сетевую часть адреса UNC, по которому находится книга, и нажмите клавишу ENTER. Например, чтобы открыть книгу на сервере "Computer1", введите \\Computer1

  3. В списке папок откройте двойным щелчком папку с нужной книгой.

  4. Дважды щелкните книгу.


 Добавление задачи для книги в список задач Outlook

Добавление задачи для книги в список задач Outlook

Для выполнения этой процедуры необходимо установить на компьютере и выполнить настройку программы Microsoft Outlook.

  1. Откройте книгу, задачу для которой следует создать и добавить в список задач Outlook.

  2. Нажмите кнопку Create Microsoft Outlook Task [image] на панели инструментов Рецензирование.

  3. Выберите необходимые параметры и затем нажмите кнопку Сохранить и закрыть [image] .

    Сведения о создании задачи и связывании с задачей контакта содержатся в разделе Создание задачи справочной системы Outlook.

Примечание. Также можно создать поручение на основе имеющейся задачи.


 Создание формы Lotus Notes 3.x, содержащей внедренную книгу

Создание формы Lotus Notes 3.x, содержащей внедренную книгу

  1. Выберите необходимую базу данных в Lotus Notes, затем в меню Design выберите команду Forms.

  2. В поле Forms щелкните существующую форму и нажмите Edit.

    Чтобы создать новую форму нажмите New или New Copy.

  3. Щелкните место, в котором должен появиться внедренный объект.

  4. В меню Edit выберите Insert и затем Object.

  5. В поле Object type выберите Microsoft Excel Worksheet.

  6. Чтобы изменить внешний вид внедренного объекта щелкните Display Format, а затем выберите нужный формат и нажмите кнопку OK.

  7. Чтобы вставить существующую книгу в виде внедренного объекта, щелкните Choose File, и затем выберите из списка нужную книгу и нажмите OK.

    Чтобы вставить новую пустую книгу, нажмите OK.

Примечание. Если в поле Object type выбран Microsoft Excel Worksheet, в форму Lotus Notes будет вставлена целая книга Microsoft Excel. В форме Lotus Notes одновременно отображается только один лист или диаграмма. Чтобы просмотреть другие листы, следует дважды щелкнуть объект Microsoft Excel и затем выбрать нужный лист.


 Копирование данных из существующего файла в качестве связанного или внедренного объекта

Копирование данных из существующего файла в качестве связанного или внедренного объекта

  1. В используемой программе выделите данные, которые требуется скопировать в качестве связанного или внедренного объекта.

  2. Нажмите кнопку Копировать [image] .

  3. Выберите лист, на который необходимо поместить данные, а затем выберите позицию, в которой данные должны находиться.

  4. В меню Правка выберите команду Специальная вставка.

  5. Для вставки данных в качестве связанного объекта выберите команду Связать.

    Для вставки данных в качестве внедренного объекта выберите команду Вставить. В поле Как выберите элемент, содержащий в своем имени слово "объект". Например, если данные были скопированы из документа Word, выберите параметр Документ Microsoft Word.

Примечание. Вставить ячейки или диаграмму в качестве связанного или внедренного объекта в книгу Microsoft Excel невозможно. Однако для создания связи с ячейками или другим листом книги можно использовать команду Копировать рисунок (для этого откройте меню Правка при нажатой клавише SHIFT). Для получения дополнительных сведений нажмите кнопку [image] .


 Вставка связанного или внедренного объекта из существующего файла

Вставка связанного или внедренного объекта из существующего файла

  1. Выберите лист, на который необходимо поместить связанный объект или внедренный объект.

  2. В меню Вставка выберите команду Объект, а затем перейдите к вкладке Из файла.

  3. В поле Имя файла введите имя файла или нажмите кнопку Обзор для выбора файла из списка.

  4. Для создания связанного объекта установите флажок Связь с файлом.

    Для создания внедренного объекта снимите флажок Связь с файлом.

  5. Если другие пользователи будут просматривать книгу, то объект можно вывести на экран в виде значка. Для этого установите флажок В виде значка. Для просмотра объекта пользователям необходимо дважды щелкнуть кнопкой мыши на значке.

Примечания

  • Для вставки графических объектов и определенных типов файлов использовать команду Объект в меню Вставка нельзя. Для вставки графических объектов в меню Вставка выберите команду Рисунок, а затем — Из файла.

  • Создание связи с данными листа во внутренней сети предприятия или Интернете


 Не удается открыть книгу через Интернет.

Не удается открыть книгу через Интернет.

Для открытия файлов через узлы Интернета, например World Wide Web или FTP, необходимо иметь доступ к Интернету либо через прямое подключение к сети, либо посредством удаленного доступа через поставщика услуг Интернета.

Если такой доступ есть, то возможно узел занят; в этом случае попробуйте открыть книгу позже.


Перемещение или копирование команды меню

  1. Отобразите панель инструментов, содержащую команду меню, которую требуется переместить или скопировать, и панель инструментов, содержащую меню, в которое требуется добавить эту команду.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. На панели инструментов откройте меню, содержащее команду, которую требуется переместить или скопировать.

  4. Выполните одно из следующих действий.

    Чтобы переместить команду, перетащите ее в нужное меню. Когда меню раскроется, укажите, не отпуская кнопки мыши, место в меню, где необходимо вставить команду, а затем отпустите кнопку мыши.

    Чтобы скопировать команду, выполните те же действия, удерживая нажатой клавишу CTRL.


 Открытие копии книги

Открытие копии книги

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск, папку или адрес FTP, где находится книга, которую требуется открыть, и затем найдите и дважды щелкните папку, содержащую книгу.

    Если найти книгу не удается, можно воспользоваться процедурой поиска файлов.

    Инструкции

  3. Выберите книгу, копию которой требуется открыть.

  4. Щелкните стрелку рядом с кнопкой Открыть и выберите команду Открыть как копию.

Примечания

  • При открытии книги в качестве копии в папке, содержащей исходную книгу, создается новая копия книги.

  • Открыть в качестве копии папку, ярлык книги или адрес FTP нельзя.


 Открытие книги на узле FTP

Открытие книги на узле FTP

Чтобы иметь возможность открывать книги на узлах FTP в Интернете, необходимо иметь доступ к Интернету либо через прямое соединение, либо посредством удаленного доступа через поставщика услуг Интернета.

Прежде чем открыть книгу на узле FTP, необходимо добавить узел FTP в список адресов FTP.

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите Добавить/изменить адреса FTP.

  3. В списке адресов FTP дважды щелкните нужный узел, а затем откройте папку, содержащую нужную книгу.

  4. Дважды щелкните книгу.


 Помещение книги в папку Microsoft Exchange

Помещение книги в папку Microsoft Exchange

Для помещения книги в папку Microsoft Exchange необходимо иметь соответствующие права, предоставляемые системным администратором.

  1. Откройте книгу, которую следует поместить в папку.

  2. Выберите команду Отправить в меню Файл, а затем — команду Папка Exchange.

  3. Выберите нужную папку из списка.

Примечание. При помещении общей книги в папку Exchange она изымается из общего пользования и для нее перестают записываться изменения. Для получения сведений о том, что происходит с книгой, когда она изымается из общего пользования, нажмите кнопку [image] .


Включение и отключение отображения совета дня

  1. Щелкните изображение помощника.

    Если помощник не отображается на экране, выберите команду Показать помощника в меню Справка.

  2. Нажмите кнопку Параметры.

  3. На вкладке Параметры установите или снимите флажок отображать полезный совет при запуске.


 Использование условий и значений в диалоговом окне поиска файлов

Использование условий и значений в диалоговом окне поиска файлов

Условия. Доступные условия зависят от выбранного свойства. Для некоторых условий необходимо задать значение. Если после выбора свойства и условия поле Значение доступно для редактирования, то для использования условия требуется ввести значение.

Значения. Для разделения нескольких значений в поле Значение можно использовать операторы И и ИЛИ. Например, чтобы найти файлы, авторами которых являются Иванов или Петров, выберите Автор в поле Свойство. Выберите содержит слова в поле Условие и введите Иванов или Петров в поле Значение. Если между вводимыми значениями поставлен пробел, то результат будет эквивалентен использованию оператора И. Например, при задании в поле Значение значения Иванов Петров будет получен такой же результат, как и при вводе строки Иванов и Петров.

При использовании текстовых полей в условии

Для условий содержит слова, содержит фразу и совпадает (точно) с поля Значение можно использовать подстановочные символы. Введите ? (знак вопроса) для поиска одинарного символа или * (звездочку) для поиска строки символов. Например, для поиска строк "sat" и "set" введите s?t, а для поиска строк "sad" и "started" введите s*d.

При использовании числовых значений в условии

Для использования условия число в диапазоне от... до... введите два значения, между которыми должно находиться искомое, в поле Значение, разделив их оператором и. Например, введите 1 и 5.

При использовании дат в условии

Для использования условия в любое время с... по... введите начальную и конечную даты в поле Значение, разделив их оператором и. Например, введите 1 Марта, 1999 и 30 Марта, 1999.


Установка разрешения экрана

Монитор и видеоадаптер определяют, можно ли изменить разрешение экрана.

  1. Нажмите кнопку Пуск в панели задач Windows, выберите меню Настройка и нажмите кнопку Панель управления.

  2. Дважды щелкните мышью значок " Экран" [image].

  3. Выберите вкладку Параметры.

  4. Для изменения разрешения экрана в поле Рабочий стол переместите ползунок.


 Вставка книги Microsoft Excel в виде внедренного объекта в документ Lotus Notes 3.x

Вставка книги Microsoft Excel в виде внедренного объекта в документ Lotus Notes 3.x

  1. Выберите необходимую базу данных в Lotus Notes, затем в меню Compose выберите форму, из которой необходимо создать документ.

    Форма должна содержать изменяемое форматируемое поле.

  2. Щелкните изменяемое форматируемое поле.

  3. В меню Edit выберите Insert и затем Object.

  4. В поле Object Type выберите Microsoft Excel Worksheet.

  5. Чтобы изменить внешний вид внедренного объекта, щелкните Display Format, а затем выберите нужный формат и нажмите кнопку OK.

  6. Чтобы вставить существующую книгу в виде внедренного объекта щелкните Choose File, и затем выберите из списка нужную книгу и нажмите OK.

    Чтобы вставить новую пустую книгу в виде внедренного объекта нажмите OK.

Примечание. Если в поле Object type выбран Microsoft Excel Worksheet в документ Lotus Notes будет вставлена целая книга Microsoft Excel. В форме Lotus Notes одновременно отображается только один лист или диаграмма. Чтобы просмотреть другие листы, следует дважды щелкнуть объект Microsoft Excel и затем выбрать нужный лист.


 Помощник не находит нужную справку

Помощник не находит нужную справку

Сведения, относящиеся к конкретным языкам

Получение советов и указаний по поиску справки. Если нужный раздел справки не отображается, щелкните ссылку Попытаться найти дополнительную справку в Web в выноске помощника. При этом будут отображены сведения о поиске разделов справки, а также советы по поиску нужной справки. Чтобы получить сведения о том, как найти узкий список разделов перефразированием вопроса или с использованием указателя справки, выберите search tips.

Поиск дополнительной справки в Web. Если получить требуемую справку все же не удается, щелкните Отправить и перейти к Web, чтобы открыть Web-обозреватель и перейти на Web-узел, где можно получить дополнительные справочные сведения. Также можно описать, какую справку требовалось получить от помощника. Заданный вопрос и любые предоставленные сведения будут использованы для улучшения будущих версий справки.

Примечание. В зависимости от конфигурации системы, ссылка Попытаться найти дополнительную справку в Web может быть недоступна. Для использования этой возможности необходимо установить на компьютере Web-обозреватель и иметь доступ к Интернету. В случае, если эта ссылка недоступна, обратитесь к системному администратору.


 Поиск файлов занимает много времени

Поиск файлов занимает много времени

Указанные условия могут увеличить время поиска файлов. Некоторые условия поиска, задаваемые в диалоговом окне Найти (меню Сервис в диалоговом окне Открытие документа), могут потребовать большего времени на поиск файлов. Например, поиск с указанием в области Условие подстановочного знака (* или ?) занимает больше времени, чем поиск по конкретному слову. Установка флажка точное совпадение также может увеличить время поиска.

Проверьте, создан ли для диска и папок индекс программы быстрого поиска фалов. Быстрый поиск — это программа Windows, создающая индексы для ускорения поиска файлов при использовании диалогового окна Открытие документа в любой программе Microsoft Office. Для получения наилучших результатов индекс программы быстрого поиска должен быть доступен в папке или на диске, где выполняется поиск. Данный индекс должен охватывать все типы файлов, которые требуется найти.

Чтобы проверить индексы, откройте меню Настройка в меню Пуск Windows, выберите команду Панель управления, а затем дважды щелкните значок Быстрый поиск [image]. Выберите команду Обновить индекс в меню Индекс и затем выберите индекс для требуемой папки. Имеющиеся индексы, как правило, находятся в корневых каталогах дисков или сетевых ресурсов.

Если вы не уверены в наличии или местоположении индекса, выберите команду Создать индекс в меню Индекс для создания индекса в корневом каталоге диска или сетевого ресурса, где будет производиться поиск. Если индекс уже существует в корневом каталоге или подкаталоге, программа быстрого поиска выведет запрос об обновлении этого индекса.

Установите поиск конкретных типов файлов. Если индекс имеется, проверьте, охватывает ли он все типы файлов, поиск которых обычно производится. Поиск файлов конкретного типа, например Документы Microsoft Office, происходит быстрее. Индекс для этого типа файлов отхватывает все документы, созданные в программах Microsoft Office, а также текстовые файлы и файлы в форматах RTF и HTML.

Если файлы, поиск которых обычно осуществляется, не включены в индекс, можно удалить индекс создать его заново. Выберите Все файлы только в том случае, если часто производится поиск файлов, не включенных в список. Поиск всех файлов обычно занимает больше времени, а индексы, охватывающие все файлы, как правило, имеют значительно больший размер. Убедитесь, что установлен флажок Автоматически обновлять индекс.

Установите поиск по содержимому и свойствам файлов. Программа быстрого поиска ускоряет поиск по содержимому файлов или их свойствам. При использовании в качестве условий поиска только имени файла программа быстрого поиска не дает выигрыша в скорости.


Помощник отвлекает от работы

Выберите другого помощника. Одни персонажи-помощники более активны, чем другие. Чтобы выбрать другого помощника, щелкните изображение помощника правой кнопкой мыши, а затем выберите команду Выбрать помощника в контекстном меню. На вкладке Коллекция с помощью кнопок Назад и Далее выберите подходящего помощника. Наименее активный из помощников — Эмблема Office.

Ограничьте перемещения помощника. Щелкните изображение помощника, а затем нажмите кнопку Параметры. На вкладке Параметры снимите флажок Не закрывать данные.

Переместите помощника. Перетащите помощника в другое место экрана.

Скройте помощника. В меню Справка выберите команду Скрыть помощника.

Отключите помощника. Щелкните помощника и затем нажмите кнопку Параметры. На вкладке Параметры снимите флажок Использовать помощника. Получение справки без использования помощника.

Отключите звуковое сопровождение. Щелкните помощника и затем нажмите кнопку Параметры. На вкладке Параметры снимите флажок Звуковое сопровождение.


 При выборе гиперссылки появляется сообщение об ошибке

При выборе гиперссылки появляется сообщение об ошибке

Проверьте, доступен ли файл, с которым связана ссылка. Файл, с которым связана гиперссылка, мог быть удален, перемещен или переименован. Чтобы восстановить гиперссылку, обновите путь для нее с указанием нового местоназначения. См. сведения об изменении местоназначения гиперссылки.

Проверьте, имеется ли доступ к Интернету. Если местоназначение гиперссылки находится в Интернете или World Wide Web, необходимо иметь доступ к Интернету либо через прямое соединение, либо посредством удаленного доступа через поставщика услуг Интернета. Если такой доступ есть, то возможно узел занят; в этом случае попробуйте открыть книгу позже.

Убедитесь, что сеть работает правильно. Если конечный файл гиперссылки находится в локальной сети или интрасети, проверьте правильность подключения сетевых дисков, а также проверьте, работает ли сервер сети. Для получения сведений о наличии доступа к местонахождению конечного файла обратитесь к системному администратору.


При сохранении файла с заданным мной расширением, ему присваивается расширение ".xls"

Чтобы сохранить книгу с расширением, отличным от стандартного расширения *.xls, необходимо заключить имя файла в кавычки, например "Budget.abc".

При изменении расширения имени файла изменяется только само отображаемое расширение, но не формат файла. См. сведения о сохранении книги в другом формате.


Не удается найти команду «Настройка»

Команда могла быть удалена из меню. Если подменю Панели инструментов удалено из меню Вид, или меню Вид или Сервис удалены из строки меню, то для настройки панели инструментов щелкните правой кнопкой мыши любую панель инструментов или строку меню, а затем выберите команду Настройка в контекстном меню.

Чтобы восстановить команду Настройка, щелкните правой кнопкой мыши любую панель инструментов или строку меню, а затем выберите команду Настройка в контекстном меню; после появления диалогового окна Настройка выполните одно из следующих действий:

  • Чтобы восстановить подменю Панели инструментов (меню Вид), щелкните меню Вид правой кнопкой мыши и затем выберите команду Сброс в контекстном меню.

  • Чтобы восстановить удаленное меню Сервис, выберите вкладку Команды в диалоговом окне Настройка. В списке Категории выберите категорию Встроенные меню, а затем перетащите меню Сервис или Вид из списка Команды на строку меню.


 Не удается открыть объект Microsoft Excel из другого приложения

Не удается открыть объект Microsoft Excel из другого приложения

  1. В Microsoft Excel выберите пункт Параметры меню Сервис и перейдите на вкладку Общие.

  2. Выберите параметр Игнорировать DDE-запросы от других приложений.

    Если этот флажок установлен, Microsoft Excel игнорирует запросы программ, связанных с Microsoft Excel через DDE, а не OLE.


Обзор промежуточных итогов в списках

Автоматическая вставка промежуточных итогов
Просмотр вложенных промежуточных итогов
Создание отчетов и диаграмм


Обзор промежуточных итогов в списках


 Вставка импортированного рисунка или картинки

Вставка импортированного рисунка или картинки

Описанный ниже порядок действий используется, если необходимо поместить рисунок на лист Excel. Рисунок может быть помещен также на определенные элементы диаграммы, например на маркеры данных. Для получения дополнительных сведений нажмите кнопку [image] .

При наличии установленной копии Clip Gallery используйте команду Картинки (меню Вставка, подменю Рисунок) для вставки картинок в книгу. Для получения сведений об установке Clip Gallery нажмите кнопку [image] .

  1. Чтобы поместить рисунок на лист Excel или на лист диаграммы, выберите ярлычок листа Excel или диаграммы.

    Чтобы добавить рисунок во внедренную диаграмму, выберите внедренную диаграмму.

  2. В меню Вставка выберите команду Рисунок, а затем — команду Из файла.

  3. Найдите папку, содержащую рисунок, который следует вставить.

  4. Дважды щелкните нужный рисунок.


 Изменение цвета заливки графического объекта

Изменение цвета заливки графического объекта

  1. Выделите графический объект, который необходимо изменить.

  2. Щелкните стрелку рядом с кнопкой Цвет заливки [image] , а затем выберите нужный цвет.

    Если нужный цвет отсутствует в предложенном списке, выберите команду Другие цвета заливки, а затем выберите цвет на вкладке Обычные или используйте вкладку Спектр для создания нового цвета. По окончании нажмите кнопку OK.


 Выбор типа заливки графического объекта

Выбор типа заливки графического объекта

  1. Выделите графический объект, который необходимо изменить.

  2. Щелкните стрелку рядом с кнопкой Цвет заливки [image] и выберите команду Способы заливки, а затем — вкладку Градиентная, Текстура, Узор или Рисунок.

  3. Укажите необходимые параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.


 Создание сценария для Web-страницы

Создание сценария для Web-страницы

Если требуется создать сценарий на другом языке создания сценариев, можно изменить язык по умолчанию.

Добавьте команды для работы с Web-сценариями в меню Сервис, если это еще не сделано.

  1. В Microsoft Excel откройте книгу Excel или Web-страницу, на которую требуется добавить сценарий, а затем щелкните мышью в любом месте данных.

  2. В меню Сервис выберите команду Макрос, а затем — Добавить сценарий.

  3. Создайте сценарий в редакторе сценариев.

  4. Чтобы сохранить изменения, выберите команду Сохранить в меню File редактора сценариев.

  5. Чтобы вернуться в Excel, выберите команду Exit в меню File редактора сценариев.

Примечания

  • Если отображение ссылок сценария включено, то при добавлении сценария в книге появляется ссылка сценария. Эта ссылка не печатается и не отображается при просмотре Web-страницы в обозревателе. Отображение и скрытие ссылок сценария.

  • При просмотре книги и включенных в нее сценариев в редакторе сценариев отображается отдельная копия книги в формате HTML. При сохранении изменений, внесенных в редакторе сценариев в эту копию книги, эти изменения не отображаются в Excel до тех пор, пока редактор сценариев не закрыт. Чтобы обновить книгу в Excel для отображения сохраненных изменений, переключитесь в окно Excel и нажмите кнопку Обновить [image] на панели инструментов Обновить.

Советы

  • Для получения сведений о создании Web-сценариев и их расположении на Web-странице обратитесь к справочной системе редактора сценариев.

  • Чтобы просмотреть первые 50 символов Web-сценария, установите указатель мыши на ссылку сценария.


 Добавление текста в автофигуру

Добавление текста в автофигуру

  • Выделите автофигуру — кроме линии, соединительной линии или полилинии — и введите требуемый текст .

Примечание. Вводимый текст становится частью автофигуры. Если текст не должен привязываться к автофигуре, следует использовать кнопку Надпись [image] панели инструментов Рисование.


 Добавление текста с помощью кнопки «Надпись»

Добавление текста с помощью кнопки «Надпись»

  1. На панели инструментов Рисование нажмите кнопку Надпись [image] .

  2. Задайте мышью необходимый размер надписи и введите текст.

Совет. Чтобы придать надписи форму автофигуры, щелкните границу надписи, нажмите кнопку Действия на панели инструментов Рисование, выберите команду Изменить автофигуру, укажите категорию, а затем выберите нужную форму фигуры.


 Автоматический подбор размера автофигуры или надписи в соответствии с размером текста

Автоматический подбор размера автофигуры или надписи в соответствии с размером текста

  1. Щелкните границу автофигуры или надписи, размер которых нужно изменить.

  2. Если выбрана автофигура, выполните команду Автофигура меню Формат и перейдите на вкладку Выравнивание.

    Если выбрана надпись, выполните команду Надпись меню Формат и перейдите на вкладку Выравнивание.

  3. Выберите параметр Автоматический размер.

Примечание. Если впоследствии размер автофигуры или надписи изменится, для выполнения автоматического подбора размеров фигуры или надписи в соответствии с размерами текста, установите повторно флажок Автоматический размер.


Выравнивание графических объектов относительно ячеек

  1. Нажмите кнопку Действия на панели инструментов Рисование и выберите команду Привязать.

  2. Для автоматического выравнивания перемещаемых или рисуемых объектов по сетке ячейки выберите команду Привязать к сетке.

    Для автоматического выравнивания перемещаемых или рисуемых объектов по вертикальным или горизонтальным сторонам других фигур выберите команду Привязать к фигуре.

Совет. Можно также привязать объект к сетке, если при перемещении, рисовании или изменении размеров этого объекта удерживать в нажатом положении клавишу ALT.


Выравнивание графических объектов относительно других графических объектов

  1. Выделите графические объекты, которые необходимо выровнять.

  2. На панели инструментов Рисование нажмите кнопку Действия, а затем выберите команду Выровнять/распределить.

  3. Выберите нужный способ выравнивания.
    Чтобы выровнять объекты | Действие
    По их левым краям | Выровнять по левому краю
    Горизонтально по их центрам | Выровнять по центру
    По их правым краям | Выровнять по правому краю
    По их верхним краям | Выровнять по верхнему краю
    Вертикально по их серединам | Выровнять по середине
    По их нижним краям | Выровнять по нижнему краю


Изменение шрифта интерфейса Microsoft Office

Действия, описанные в данном разделе, неприменимы при использовании версий Microsoft Office с интерфейсом на японском и корейском языках, а также на китайском языке с традиционным или упрощенным письмом.

Внимание! Следующие кнопки изменяют запись для шрифта интерфейса Office в файле реестра Windows. Их использование может привести к непредвиденным результатам.

Нажмите для использования системного шрифта

Нажмите для использования стандартного шрифта интерфейса Office

Примечание. Чтобы изменение шрифта интерфейса вступило в силу, закройте все открытые программы Office, а затем снова запустите их.

Возврат к разделу Шрифт интерфейса пользователя Microsoft Office.


 Изменение полей текста автофигуры или надписи

Изменение полей текста автофигуры или надписи

  1. Щелкните границу автофигуры или надписи, поля которой требуется изменить.

  2. Если выбрана автофигура, выполните команду Автофигура меню Формат и перейдите на вкладку Поля.

    Если выбрана надпись, выполните команду Надпись меню Формат и перейдите на вкладку Поля.

  3. Измените значение в окне Внутренние поля для изменения расстояния между текстом и содержащим его объектом.


Сохранение пропорций графического объекта при изменении его размеров

Изменение размеров выделенного объекта | Нажмите клавиши
Пропорционально, начиная с угла | SHIFT, а затем перетащите угловой маркер изменения размера
По вертикали, по горизонтали или по диагонали, начиная от центра | CTRL, а затем перетащите маркер изменения размера
Пропорционально, начиная от центра | CTRL+SHIFT, а затем перетащите угловой маркер изменения размера
При временном отключении сетки | ALT, а затем перетащите маркер изменения размера


Изменение стандартного языка Web-сценариев

  1. В меню Сервис выберите команду Макрос, а затем — Редактор сценариев.

  2. В рабочем окне книги щелкните ярлычок Source.

  3. В списке в нижней части окна Properties выберите свойство defaultClientScript, а затем выберите требуемый язык в списке справа от свойства.


 Изменение кода Java-приложения

Изменение кода Java-приложения

Изменение кода Java-приложения требует знания программирования.

  1. Дважды щелкните значок Java-приложения Значок Java-приложения.

  2. Внесите необходимые изменения в HTML-код под тегом <APPLET>.

  3. Чтобы сохранить внесенные изменения и вернуться в Microsoft Excel, выберите команду Save All в меню File редактора сценариев, а затем — команду Exit.

Совет. Для получения сведений о редактировании текста в редакторе сценариев обратитесь к справочной системе редактора сценариев.


Не удается выровнять нарисованные полилинии

Вместо использования команды Выровнять/распределить (в меню Действия на панели Рисование) попробуйте выровнять объекты путем их перемещения.

  • Используйте команды подменю Сдвиг (меню Действия) для сдвига полилинии с шагом в 1 пиксел. Если флажок Привязать к сетке или Привязать к фигуре (меню Действия, подменю Привязать) установлен, шаг сдвига равен одному делению сетки.

  • Если флажок Привязать к сетке (меню Действия, подменю Привязать) установлен, временно отключите его, удерживая нажатой клавишу ALT во время перетаскивания полилинии.


 Трудно рисовать кривые линии

Трудно рисовать кривые линии

  • Попробуйте увеличить масштаб изображения в поле Масштаб. При двукратном увеличении (200%) легче прорисовывать детали.

  • Используйте кнопку Полилиния [image] на панели инструментов Рисование (меню Автофигуры, подменю Линии) вместо кнопки Рисованная кривая [image] .

  • Попробуйте установить наименьшую скорость мыши на панели управления Windows. Чем ниже скорость мыши, тем легче прорисовывать детали.

  • Полилинии можно сделать более гладкими. Для получения дополнительных сведений нажмите кнопку [image] .


 Не удается повернуть рисунок

Не удается повернуть рисунок

Только графические объекты можно вращать и отражать. Если объект можно преобразовать в набор графических объектов путем разгруппирования, значит, его можно и вращать, и отражать. Невозможно преобразовать точечный рисунок в набор графических объектов.

  • Для преобразования объекта необходимо его выделить, выбрать команду Разгруппировать в меню Действия (на панели инструментов Рисование), а затем — команду Группировать.

  • Если объект невозможно преобразовать, откройте его в любом графическом редакторе, внесите необходимые изменения, а затем сохраните его. При последующем открытии в Microsoft Excel объект появится измененным.


 Выравнивание текста автофигуры или надписи

Выравнивание текста автофигуры или надписи

  1. Щелкните границу автофигуры или надписи, размер которых нужно изменить.

  2. Если выбрана автофигура, выполните команду Автофигура меню Формат и перейдите на вкладку Выравнивание.

    Если выбрана надпись, выполните команду Надпись меню Формат и перейдите на вкладку Выравнивание.

  3. Укажите необходимые параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.


 Удаление заливки графического объекта

Удаление заливки графического объекта

  1. Выделите графический объект, который необходимо изменить.

  2. Щелкните стрелку рядом с кнопкой Цвет заливки [image] , а затем выберите Нет заливки.


 Изменение размеров графического объекта

Изменение размеров графического объекта

  1. Выделите графический объект, размеры которого следует изменить.

    На внедренной диаграмме выделите область диаграммы, щелкнув пустую область между границами диаграммы и областью построения.

  2. Перетаскивайте маркеры изменения размера до тех пор, пока объект не примет необходимую форму и размер.

    Для получения сведений о сохранении пропорций объекта во время изменения его размеров нажмите кнопку [image] .


 У графического объекта неравномерные цвета.

У графического объекта неравномерные цвета.

  • Убедитесь, что в поле Масштаб установлено значение 100%. При другом масштабе изображения возможно искажение заливок.

    Демонстрация

  • Если монитор способен отображать одновременно только 16 цветов, заливка, возможно, будет неравномерной. Попробуйте установить режим, при котором одновременно отображается не менее 256 цветов.


 Рисунок содержит неровные линии

Рисунок содержит неровные линии

  • Кривые линии, а также прямые линии, которые не являются строго вертикальными или горизонтальными, на экране выглядят неровными. В напечатанном документе такие линии будут гладкими.

  • Панель инструментов Рисование (меню Автофигуры, подменю Линии) содержит кнопки Кривая [image] и Полилиния [image] , при использовании которых получаются более гладкие кривые, чем при использовании кнопки Рисованная кривая [image] .

  • Попробуйте увеличить масштаб изображения в поле Масштаб. При двукратном увеличении (200%) легче прорисовывать детали.

  • Попробуйте установить наименьшую скорость мыши на панели управления Windows. Чем ниже скорость мыши, тем легче прорисовывать детали.

  • Полилинии можно сделать более гладкими. Выделите фигуру, выберите команду Начать изменение узлов в меню Действия (панель инструментов Рисование), чтобы появились узлы, а затем перетащите любой из них. Чтобы было легче прорисовывать детали, увеличьте масштаб изображения до 200 процентов.

  • Существует возможность сглаживания полилиний путем удаления лишних узлов. Выделите фигуру, выберите команду Начать изменение узлов в меню Действия, чтобы появились узлы, а затем щелкните узел, который следует удалить, удерживая нажатой клавишу CTRL.


 Просмотр или изменение Web-сценария

Просмотр или изменение Web-сценария

  1. Добавьте команды для работы с Web-сценариями в меню Сервис, если это еще не сделано.

  2. Дважды щелкните ссылку Web-сценария, который требуется просмотреть или изменить. Отображение ссылок сценария.

  3. Чтобы сохранить внесенные изменения и вернуться в Microsoft Excel, выберите команду Сохранить в меню File редактора сценариев, а затем — команду Exit.

Примечания

  • Чтобы воспользоваться редактором сценариев для просмотра всей книги в виде кода HTML, выберите пункт Макрос в меню Сервис, а затем — команду Редактор сценариев.

  • При просмотре книги и включенных в нее сценариев в редакторе сценариев отображается отдельная копия книги в формате HTML. При сохранении изменений, внесенных в редакторе сценариев в эту копию книги, эти изменения не отображаются в Excel до тех пор, пока редактор сценариев не закрыт. Чтобы обновить книгу в Excel для отображения сохраненных изменений, переключитесь в окно Excel и нажмите кнопку Обновить [image] на панели инструментов Обновить.


 Клавиши для работы со справочной системой

Клавиши для работы со справочной системой

В окне справки

Нажмите | Чтобы
F6 | Перейти от кнопок перехода к области раздела
ALT+М | Отобразить меню Параметры, предоставляющее доступ ко всем командам панели инструментов Справка
ALT+ПРОБЕЛ | Отобразить меню окна
F5 | Обновить раздел справки

Использование кнопок перехода

CTRL+TAB | Перейти на следующую вкладку
ENTER | Открыть выделенную книгу или раздел справки
СТРЕЛКА ВНИЗ | Выделить следующую книгу или раздел справки
СТРЕЛКА ВВЕРХ | Выделить предыдущую книгу или раздел справки

В области раздела

ALT+СТРЕЛКА ВПРАВО | Перейти к следующему разделу справки
ALT+СТРЕЛКА ВЛЕВО | Перейти к предыдущему разделу справки
TAB | Перейти к первой или следующей гиперссылке
SHIFT+TAB | Перейти к последней или предыдущей гиперссылке
ENTER | Активизировать выделенную гиперссылку
СТРЕЛКА ВВЕРХ | Прокрутить раздел справки по направлению к началу
СТРЕЛКА ВНИЗ | Прокрутить раздел справки по направлению к концу
PAGE UP | Прокрутить раздел справки по направлению к началу большими отрывками
PAGE DOWN | Прокрутить раздел справки по направлению к концу большими отрывками
HOME | Перейти в начало раздела справки
END | Перейти в конец раздела справки
CTRL+P | Напечатать текущий раздел справки
CTRL+A | Выделить весь текущий раздел справки
CTRL+С | Скопировать выделенные объекты в буфер обмена


 Соответствие свойств книги Microsoft Excel полям Lotus Notes

Соответствие свойств книги Microsoft Excel полям Lotus Notes

В полях Notes могут отображаться сведения о свойствах файла Excel. Если книга Microsoft Excel вставлена в форму Notes в виде внедренного объекта, в форме Notes можно создать поля, отображающие сведения о свойствах файла книги Excel. Максимальное число полей свойств файла из диалогового окна Свойства Excel равно числу полей в форме Notes.

Соответствие полей и свойств. Звездочкой в нижеследующей таблице помечены свойства, поля которых являются двунаправленными: изменения, внесенные в книгу Excel, отражаются в поле Notes, и изменения, внесенные в поле Notes, отражаются в книге Excel. Свойства, не помеченные звездочкой, являются однонаправленными полями: изменения, внесенные во внедренную книгу, отражаются в поле Notes, однако изменения, внесенные в поля Notes, не отражаются во внедренной книге.

Поскольку для внедренного объекта не определены имя файла и папка, соответствующие поля для книги в форме Lotus Notes отображаются пустыми.

Свойство книги Microsoft Excel | Поле Lotus Notes | Lotus data type
*Название | Title | Функции по работе с текстом
*Тема | Subject | Функции по работе с текстом
*Автор | Author | Функции по работе с текстом
*Ключевые слова | Keywords | Функции по работе с текстом
*Заметки | Comments | Функции по работе с текстом
Шаблон | Шаблон | Функции по работе с текстом
*Группа | ManagerText | Функции по работе с текстом
*Организация | Company | Функции по работе с текстом
*Должность | Category | Функции по работе с текстом
Создан | DateCreated | Время
Изменен | LastSavedDate | Время
Сохранен | LastSavedBy | Функции по работе с текстом
Размер | NumberOfBytes | Функции по работе с текстом
Версия | NumberOfRevisions | Number
Общее время правки | TotalEditingTime | Number
Напечатан | LastPrintedDate | Время
Страниц | NumberOfPages | Number
Слов | NumberOfWords | Number
Символов | NumberOfCharacters | Number
Абзацев | NumberOfParagraphs | Number
Строк | NumberOfLines | Number
Пароль | Пароль | Number
Document Class | DocumentClass | Функции по работе с текстом
Имя MS-DOS | NameOfApplication | Функции по работе с текстом
*Пользовательское свойство | Имя пользовательского свойства | Функции по работе с текстом
* Поле свойства является двунаправленным.


 Панель «Буфер обмена» не отображается при копировании и вставке объектов.

Панель «Буфер обмена» не отображается при копировании и вставке объектов.

Если панель инструментов Буфер обмена закрыта три раза подряд без нажатия кнопки Вставить все или вставки какого-либо элемента с этой панели инструментов, панель больше не будет отображаться автоматически. Чтобы снова отобразить ее, выберите пункт Панели инструментов в меню Вид, а затем — Буфер обмена. Снова отобразить панель можно также, два раза подряд скопировав объект.

При выводе панели инструментов Буфер обмена на экран вручную она снова будет отображаться автоматически. Кроме того, сбросить счетчик закрытий панели можно, очистив журнал советов. Для этого в выноске помощника нажмите кнопку Параметры, а затем — кнопку Очистить журнал. Если помощник не отображается, нажмите кнопку Помощник Office [image] .


При добавлении к графическому объекту объема исчезает его тень

К объекту можно добавить тень либо объем, но не оба эффекта сразу; при добавлении объема к объекту, который имеет тень, она исчезает.


Взаимное перекрытие графических объектов при выравнивании

В зависимости от выбранного способа выравнивания графические объекты перемещаются строго вверх, вниз, вправо или влево. При этом существует возможность перекрывания объектов, уже находящихся там. В этом случае необходимо отменить выравнивание командой Отменить (меню Правка) и перед следующим выравниванием переместить объекты на новые позиции.


 Не удается добавить дополнительные объекты в буфер обмена

Не удается добавить дополнительные объекты в буфер обмена

Скопировано более 12 объектов. Буфер обмена Office может содержать не более 12 объектов. Если в буфере обмена Office находится 12 объектов, и в него копируется дополнительный объект из программы, не являющейся программой Office — Microsoft Word, Excel, Access, Outlook или PowerPoint — копирование этого объекта не производится.

Скопированы большие объекты. Добавление элементов в буфер обмена Office может прекратиться — даже если число элементов буфера меньше 12 — если в буфер скопированы большие объекты. Чтобы снова начать копирование объектов, нажмите кнопку Очистить буфер обмена [image] на панели инструментов буфера обмена.


Не удается найти команду меню, кнопку панели инструментов или параметр диалогового окна.

Меню может быть не развернуто. Если в нижней части меню отображается двойная стрелка Двойная направленная вниз стрелка , команда может быть доступна при развертывании меню. Нажмите стрелку и затем выберите требуемую команду. Для развертывания меню можно также дважды щелкнуть его; кроме того, при необходимости можно установить режим отображения полного набора команд всех меню.

Панель инструментов может находиться в одном ряду с другой панелью инструментов. Кнопка может не отображаться на панели инструментов из-за недостатка места для отображения всех кнопок. Нажмите кнопку Дополнительные кнопки [image] и затем нажмите нужную кнопку; при необходимости можно установить режим отображения всех кнопок на панели инструментов.

Компонент может быть не установлен. Запустите программу установки и установите отсутствующий компонент.

Возможно наличие несоответствия в установке языка. Команда или элемент управления могут быть недоступны, если не задействована возможность редактирования для того языка, к которому относятся команда или элемент управления. В этом случае необходимо задействовать возможность редактирования для языка, с которым требуется работать. См. сведения о работе с несколькими языками и о пакетах инструментов для проверки правописания.

Другие возможности. См. сведения о других причинах отсутствия команд, кнопок и параметров.


При совместной работе с созданной панелью инструментов она выглядит иначе на компьютерах других пользователей.

Microsoft Excel автоматически настраивает состав команд в меню и кнопок на панелях инструментов в соответствии с тем, как часто они используются, и сохраняет параметры меню и панелей инструментов в качестве личных параметров настройки для конкретного пользователя. При установке флажка В меню сначала отображаются последние использованные команды на вкладке Параметры (меню Сервис, команда Настройка) на состав команд в каждом меню влияет информация о том, какие команды используются чаще всего. Помимо этого, если на панели инструментов недостаточно места для отображения всех кнопок (например, при расположении панели инструментов в одном ряду с другой панелью инструментов), состав кнопок на этой панели также определяется информацией о том, какие кнопки используются чаще всего.

Кнопки и команды, используемые при совместной работе с другими пользователями, доступны всегда, однако наличие или отсутствие их в настраиваемом (сокращенном) варианте меню или на сжатой панели инструментов зависит от параметров настройки меню и панелей инструментов для каждого конкретного пользователя.


Не удается выполнить повторное группирование рисованных объектов

Работая с несколькими группами графических объектов, следует выбирать рисованный объект именно той группы, которую требуется перегруппировать. Если Microsoft Excel закрывается, а впоследствии требуется перегруппирование объектов, выделите объекты, выбирая их мышью и удерживая при этом клавишу SHIFT, после чего выполните команду Группировать меню Действия (панель инструментов Рисование).


 Личные параметры настройки недоступны при входе в систему.

Личные параметры настройки недоступны при входе в систему.

Профиль пользователя не соответствует операционной системе. Профиль пользователя может использоваться только в той операционной системе, для которой он был создан. Например, профиль пользователя операционной системы Microsoft Windows NT не может быть использован на компьютере под управлением Microsoft Windows 95. Если профиль пользователя создан в Windows 95, то при входе в систему на компьютере, работающем под управлением Windows NT, никакие параметры настройки доступны не будут. Для использования личных настроек операционная система компьютера, на котором осуществляется вход в систему, должна соответствовать операционной системе, в которой создавался профиль пользователя, либо должны иметься профили для каждой операционной системы.

Компьютер не сконфигурирован для работы нескольких пользователей. Если вход в систему осуществляется на компьютере под управлением Windows, параметры конфигурации компьютера могут не допускать сохранения настроек для нескольких пользователей. Чтобы задействовать возможность создания наборов личных установок для нескольких пользователей на компьютере под управлением Windows, сделайте следующее.

  1. Нажмите кнопку Пуск на панели задач Windows, выберите меню Настройка и затем — пункт Панель управления.

  2. Дважды щелкните значок Пароли Связка ключей , а затем откройте вкладку Профили пользователей.

  3. Установите переключатель Каждый пользователь устанавливает личные настройки.

Может быть не задействована учетная запись пользователя. Возможно, системный администратор не настроил учетную запись пользователя сети для использования перемещаемых профилей пользователя. Если при входе в систему личные параметры настройки недоступны, обратитесь к системному администратору.

Работа с профилями пользователей осуществляется по-разному в разных операционных системах. Из-за различий между операционными системами при работе одновременно на нескольких компьютерах изменения настроек, сделанные на одном компьютере, могут быть доступны немедленно или только при следующем входе в систему. На компьютерах под управлением Microsoft Windows 95, Windows 98 или Windows NT 4.0 изменения настроек, внесенные на последнем из использовавшихся компьютеров, копируются в профиль пользователя и используются при следующем входе в систему. На компьютерах под управлением Microsoft Windows 2000 изменения настроек будут отражены немедленно, поскольку профиль пользователя копируется на сервер регулярно через определенные интервалы времени.


Пользовательские шаблоны не отображаются на соответствующей вкладке.

Пользовательские шаблоны следует сохранять в соответствующей подпапке папки «Шаблоны». Папка «Шаблоны» находится по следующему пути:

Корневой_каталог\Операционная_система\Profiles\Имя_пользователя\Application Data\Microsoft\Шаблоны

где Корневой_каталог — папка на сервере или каталог на диске, в который вложены все остальные папки (например, C:\), Операционная_система — папка операционной системы (например, Windows), а Имя_пользователя — это имя пользователя.

Шаблоны, находящиеся в папке «Шаблоны», отображаются на вкладке Общие в диалоговом окне Создание документа (меню Файл, команда Создать); шаблоны, находящиеся в подпапках папки «Шаблоны», отображаются на вкладках с именами, соответствующими именам подпапок. Например, при создании подпапки с именем «Отчеты» в диалоговом окне Создание документа появится вкладка Отчеты.

Примечание. В Microsoft Windows 2000 путь к папке «Шаблоны» имеет следующий вид: Корневой_каталог\Documents and Settings\Имя_пользователя\Application Data\Microsoft\Шаблоны.


Невозможно выбрать необходимый пункт меню "Выровнять/распределить"

Необходимо выделить по крайней мере два графических объекта для выравнивания и не менее трех для распределения.


Интерфейс Office выглядит неправильно

Текст в диалоговых окнах отсутствует или отображается с пробелами на месте некоторых символов. Если стандартный шрифт интерфейса Microsoft Office отсутствует или поврежден, то вместо него используется другой шрифт. Однако диалоговые окна рассчитаны на использование стандартного шрифта интерфейса Office, и другие шрифты могут оказаться неподходящими для использования. Например, если стандартный шрифт интерфейса Office отсутствует или поврежден, то в диалоговых окнах вместо символов, которые не могут быть отображены с использованием другого шрифта, будут отображаться пробелы. Чтобы восстановить стандартный шрифт интерфейса Office, выберите команду Найти и устранить в меню Справка. Подобные эффекты также могут наблюдаться при переключении на стандартный системный шрифт. Возврат к стандартному шрифту интерфейса Office.

Шрифт интерфейса Office может не нравиться. При необходимости вместо стандартного шрифта интерфейса Office для программ Office можно использовать стандартный системный шрифт. Переключение на системный шрифт.


Кнопка «Вставить все» недоступна.

В некоторых случаях кнопка Вставить все [image] недоступна на панели инструментов Буфер обмена, даже если отдельные элементы доступны для вставки.

  • Во всех программах Microsoft Office. Кнопка Вставить все недоступна в случае, если какой-либо из элементов, находящихся в буфере обмена Office, не может быть вставлен в данной программе. Например, если панель инструментов Буфер обмена содержит картинку Office Art, кнопка Вставить все будет недоступна в Excel.

  • В Microsoft Excel. Кнопка Вставить все недоступна, если в буфер обмена Office скопирован объект Office Art.

Если кнопка Вставить все недоступна, можно воспользоваться возможностью вставки отдельных элементов.


Панель инструментов «Буфер обмена» недоступна

Команды «Копировать», «Вырезать» и «Вставить» могут быть недоступны. Панель инструментов Буфер обмена недоступна в режимах просмотра, не допускающих использование команд Копировать, Вырезать и Вставить.

Может использоваться программа, не входящая в состав Microsoft Office. Панель инструментов Буфер обмена доступна только в Excel, Word, Access, Outlook и PowerPoint. В редакторе Visual Basic панель инструментов Буфер обмена недоступна. Тем не менее, если буфер обмена Office отображается в любой из программ Office, все вырезаемые или копируемые в любой программе объекты автоматически помещаются в этот буфер.


При изменении цвета заливки графического объекта цвет его тени или объема не меняется

Изменение цвета заливки влияет только на сам графический объект. Для изменения цвета тени или объема используйте кнопки Тень или Объем на панели инструментов Рисование.


 Граница графического объекта не отображается на экране

Граница графического объекта не отображается на экране

  • Для улучшения вида графических объектов при добавлении объема граница объекта становится невидимой.

  • Граница графического объекта отключена, имеет тот же цвет, что и заливка, или к графическому объекту добавлена приподнятая или утопленная тень. Чтобы сделать границу видимой, выделите объект, щелкните стрелку рядом с кнопкой Цвет линий [image] на панели инструментов Рисование, а затем выберите нужный цвет границы.


 Невозможно разгруппировать импортированный рисунок

Невозможно разгруппировать импортированный рисунок

Изображение может быть точечным рисунком, который невозможно разгруппировать и преобразовать в набор графических объектов.

Для изменения точечных рисунков используйте графический редактор, например Microsoft Photo Editor. Например, чтобы выполнить отражение или поворот точечного рисунка, откройте его в графическом редакторе, внесите необходимые изменения, а затем вставьте полученный рисунок на лист или диаграмму.


После изменения заливки, границы, тени или объема при создании нового объекта все равно восстанавливаются старые настройки

К новому графическому объекту применены настройки, используемые по умолчанию. Для изменения настроек новых графических объектов выделите объект с нужными параметрами, на панели инструментов Рисование нажмите кнопку Действия, а затем выберите команду По умолчанию для автофигур.


Невозможно изменить цвет отдельных областей рисунка.

Попробуйте разгруппировать рисунок, а затем используйте кнопки на панели инструментов Рисование для изменения цветов.


 Изменение сообщения запроса с параметрами в Microsoft Excel

Изменение сообщения запроса с параметрами в Microsoft Excel

Данная процедура позволяет изменить сообщение запроса на ввод параметра только на время текущего сеанса работы с книгой. Запросы с параметрами не могут использоваться для извлечения данных из баз данных OLAP.

  1. В Microsoft Excel выделите ячейку диапазона внешних данных, полученного с помощью запроса с параметрами.

  2. На панели инструментов Внешние данные выберите Параметры запроса [image] .

  3. Из списка в левой части диалогового окна Параметры выберите параметр, который требуется изменить.

  4. В поле запрос на ввод параметра пользователем введите текст сообщения и нажмите кнопку OK. Сообщение может содержать до 100 символов.

  5. Чтобы применить новое сообщение и обновить данные, выберите Обновить данные [image] на панели инструментов Внешние данные.

Примечание. Чтобы постоянно выводить на экран новое сообщение, сохраните книгу или введите новое сообщение для запроса в Microsoft Query. Чтобы получить более подробные сведения об изменении запроса в Microsoft Query, нажмите кнопку [image] .


 Использование данных из ячейки листа в качестве значения параметра

Использование данных из ячейки листа в качестве значения параметра

Данная процедура неприменима при извлечении данных из баз данных OLAP.

  1. На листе Microsoft Excel введите значения, которые следует использовать в качестве условий запроса.

  2. Выделите ячейку диапазона внешних данных, полученного при помощи запроса с параметрами.

  3. На панели инструментов Внешние данные выберите Параметры запроса [image] .

  4. Из списка в левой части диалогового окна Параметры выберите параметр, который требуется изменить.

  5. Выберите значение параметра берется из ячейки.

  6. Выделите ячейку на листе, содержащую значение, которое требуется использовать.

    Для обновления данных при каждом изменении значения в ячейке установите флажок Автоматически обновлять при изменении значения ячейки.

  7. Нажмите кнопку OK.

  8. Чтобы обновить данные, нажмите кнопку Обновить данные [image] на панели инструментов Внешние данные.


 Получение внешних данных с помощью шаблона отчета

Получение внешних данных с помощью шаблона отчета

Для подключения к внешнему источнику данных должен быть установлен соответствующий драйвер источника данных. Если на компьютере установлена программа Microsoft Query, соответствующий драйвер ODBC или поставщик данных для куба OLAP может уже быть установлен. См. сведения об установке драйверов ODBC и поставщиков данных для куба OLAP для получения доступа к внешним источникам данных.

  1. В Microsoft Excel выберите команду Создать в меню Файл.

  2. Дважды щелкните шаблон отчета, который следует открыть.

    Файл шаблона отчета имеет расширение .xlt.

    При необходимости введите путь к источнику данных и пароль.


Быстрые вычисления на листе

Просмотр итога
Добавление итогов
Создание простой формулы


Быстрые вычисления на листе


 Получено сообщение о том, что адрес базы данных указан неверно.

Получено сообщение о том, что адрес базы данных указан неверно.

Проверьте подключение сетевого диска. Если база данных находится в общем сетевом каталоге, при настройке источника данных и указании файла базы данных адрес базы данных может быть автоматически записан в источнике данных с указанием подключенного сетевого диска, который использовался системой в тот момент. Например, если база данных называется "Inventory.mdb", а диск G подключен к тому сетевому каталогу, в котором хранится эта база данных, в источнике данных адрес базы данных будет записан в виде G:\public\Inventory.mdb. При попытке использовать этот источник данных или запустить запросы, созданные в этом источнике данных, драйвером ODBC будет выведено сообщение о том, что адрес указан неверно, если диск G не будет подключен к тому же общему сетевому каталогу.

Использование альтернативы подключению дисков. Если для работы используются драйверы Microsoft Access или Microsoft Excel, эту проблему можно устранить, создав новый источник данных. При указании местоположения файла базы данных не следует выбирать подключенный сетевой диск. Вместо этого следует ввести адрес UNC общего сетевого каталога и затем указать файл базы данных. Например, если файл базы данных хранится на сервере, который называется "Shared", следует ввести \\Shared\public, а затем выбрать файл "Inventory.mdb".

Подключите сетевой диск с назначением ему той же буквы до использования источника данных. При работе с другими драйверами ODBC перед использованием источника данных или выполнением запроса, созданного в этом источнике данных, убедитесь, что к общему сетевому каталогу, где находится база данных, подключен тот же диск, который использовался при создании источника данных.


 Используемый ранее драйвер ODBC не работает.

Используемый ранее драйвер ODBC не работает.

Может возникнуть необходимость использования с Microsoft Query 2000 другого драйвера в следующих ситуациях:

Убедитесь, что используется 32-разрядный драйвер ODBC. Для Microsoft Query 2000 требуются 32-разрядные драйверы ODBC, такие как поставляемые с Microsoft Query 2000 и Microsoft Query 97. Например, если для Microsoft Excel 2000 с использованием Visual Basic разработана программа для получения внешних данных, и эта программа используется пользователями Microsoft Excel версий 5.x, она может не работать с 16-разрядными драйверами ODBC в Microsoft Excel версий 5.x.

Убедитесь, что драйверы производства Майкрософт имеют версию 3.0 или более позднюю. При установке разработанных Майкрософт драйверов ODBC, отличных от поставляемых с Microsoft Excel 2000 или Microsoft Office 2000, убедитесь, что устанавливаемые драйверы имеют версию 3.0 или более позднюю. Более ранние версии драйверов ODBC могут не работать с Microsoft Query 2000. Драйверы, поставляемые с Microsoft Excel 97 и Microsoft Office 97 имеют версию 3.0 и выше. При установке этих драйверов все драйверы более ранних версий замещаются автоматически.

Убедитесь, что используемые драйверы сторонних производителей имеют правильную версию. Если для работы используется драйвер ODBC стороннего производителя, то при обновлении или установке новой версии базы данных может потребоваться также установить новый драйвер ODBC для Microsoft Query. Чтобы выяснить, требуется ли установка нового драйвера, обратитесь к документации по базе данных.


 Не удается найти или удалить источник данных.

Не удается найти или удалить источник данных.

Источники данных, созданные в более ранних версиях Query. Рядом с именами источников данных, созданных в версиях Microsoft Query более ранних, чем Query 97, отображается звездочка. Все источники данных, включая новые источники, созданные в Query 2000, хранятся в виде файлов с расширением .dsn. Для просмотра списка источников, созданных в более ранних версиях Query, нажмите кнопку Параметры в диалоговом окне Выбор источника данных (меню Данные, подменю Внешние данные, команда Создать запрос), а затем установите флажок Источники из реестра в список доступных баз данных. Если место хранения этих источников данных является стандартным, можно выбрать их в диалоговом окне Выбор источника данных и затем нажать кнопку Удалить.

Местоположение файлов источников данных. Файлы источников данных, созданных в более ранних версиях Microsoft Query обычно хранятся в соответствующей подпапке источников данных ODBC Datasources папки Common Files. Файлы источников данных Query 2000 хранятся в папке профиля пользователя, находящейся в папке Application Data\Microsoft\Queries. Чтобы узнать, какие папки используются для хранения файлов источников данных, выберите пункт Внешние данные в меню Данные, выберите команду Создать запрос, откройте вкладку Базы данных, а затем нажмите кнопку Параметры.

Поиск и удаление файлов источников данных. Найти и удалить файлы источников данных можно с помощью следующих средств.

  • Использование Панели управления Windows. Если все файлы источников данных находятся в папке Common Files\ODBC Datasources или в папке профиля пользователя, дважды щелкните значок ODBC Data Sources (32bit) в Панели управления, откройте вкладку File DSN, а затем удалите все ненужные файлы .dsn с помощью кнопки Remove.

  • Поиск файлов .dsn. Если файлы источников данных находятся в нескольких папках, воспользуйтесь командой Найти Microsoft Windows для поиска всех файлов с расширением .dsn, а затем удалите ненужные файлы.


 Невозможно создать новый источник данных.

Невозможно создать новый источник данных.

Проверьте драйвер. Прежде всего необходимо проверить, имеется ли для источника данных соответствующий драйвер ODBC или драйвер источника данных. Благодаря драйверам ODBC и драйверам источников данных Microsoft Query является гибким средством, позволяющим устанавливать связь с новыми базами данных, которые становятся доступными после установки новых драйверов. Однако следует убедиться в том, что для используемого типа баз данных установлен и настроен соответствующий драйвер.

Убедитесь, что драйвер работает с Query. В дополнение к драйверам, поставляемым с Microsoft Query, можно использовать драйверы ODBC и источников данных, разработанные сторонними производителями. Перед использованием драйвера стороннего производителя рекомендуется проверить, протестирован ли драйвер с Microsoft Query 2000. Для некоторых баз данных драйвер, поставляемый с программным обеспечением баз данных, может быть лучшим выбором. Для получения сведений о доступных и рекомендуемых для использования средствах обратитесь к системному администратору базы данных. См. список драйверов, поставляемых с Query.

Проверьте адрес сервера и сведения для подключения. Перед настройкой источника данных убедитесь, что известен адрес базы в сети и имеется необходимое разрешение на подключение и вход в базу. Получите от администратора базы данных имя для входа, пароль и любые другие необходимые разрешения, и убедитесь, что предоставленный доступ позволяет правильно осуществить подключение.

Убедитесь, что драйвер установлен правильно. Для отображения списка доступных драйверов откройте пункт Внешние данные в меню Данные и выберите команду Создать запрос. Дважды щелкните пункт Новый источник данных на вкладке Базы данных или Кубы OLAP, введите имя в поле 1 диалогового окна Создание нового источника данных, а затем щелкните раскрывающийся список в поле 2. Если требуемый драйвер отсутствует, следует проверить правильность установки драйвера ODBC или источника данных. См. сведения об установке драйверов.

Убедитесь, что предоставлена вся информация о конфигурации. После того, как драйвер установлен и выбран в поле 2 диалогового окна Создание нового источника данных, на третьем шаге создания источника данных необходимо предоставить всю требуемую информацию о конфигурации драйвера. Для получения информации о драйверах, разработанных Майкрософт, нажмите кнопку Связь, а затем — кнопку Help в диалоговом окне настройки драйвера. Для получения информации о драйверах сторонних производителей обратитесь к справочной системе или документации по драйверу.

Если устанавливается источник данных с драйвером ODBC или драйвером источника данных, поставляемым корпорацией Майкрософт, то для получения сведений о параметрах, которые необходимо установить на шаге 3 диалогового окна Создание нового источника данных, щелкните название драйвера.

Драйверы ODBC

Драйвер Access

Драйвер dBASE

Драйвер FoxPro

Драйвер Excel

Драйвер Microsoft ODBC для Oracle

Драйвер Paradox

Текстовый драйвер

Драйвер SQL Server

Драйвер источника данных

Драйвер Microsoft SQL Server OLAP Services


 Попытки подключения к базе данных часто оказываются безуспешными.

Попытки подключения к базе данных часто оказываются безуспешными.

Увеличьте интервал подключения. По умолчанию Microsoft Query пытается подключиться к базе данных в течение интервала времени, определяемого параметрами настройки драйвера ODBC для источника данных. Если подключение к базе данных требует большего времени, можно установить больший интервал подключения. В меню Правка Microsoft Query выберите команду Параметры, убедитесь, что установлен флажок Разрывать связь при отсутствии активности через, а затем введите число секунд, отводимое на подключение.

Подключение без ограничения времени. Если требуется, чтобы интервал времени на подключение в Microsoft Query был неограниченным, снимите флажок Разрывать связь при отсутствии активности через. Если Microsoft Query не может подключиться к базе данных, попытку можно прервать, нажав клавишу ESC.


 Почему рядом с именем источника данных отображается звездочка?

Почему рядом с именем источника данных отображается звездочка?

Источник данных создан в более ранней версии Microsoft Query. Формат источников данных Query 2000 и Query 97 отличается от формата источников данных, созданных в более ранних версиях Query. Источники данных и запросы, созданные в версиях Query более ранних, чем Query 97, могут использоваться в Query 2000, однако запросы, создаваемые с помощью этих источников данных, не могут быть использованы совместно с другими пользователями. В версиях Query более ранних, чем Query 97, информация об источниках данных хранится в качестве части операционной системы Microsoft Windows, и эта информация доступна только на том компьютере, где она хранится.

Определение источников данных, не допускающих совместного использования. Для использования источников данных, созданных в более ранних версиях Query, нажмите кнопку Параметры в диалоговом окне Выбор источника данных (меню Данные, подменю Внешние данные, команда Создать запрос) и затем установите флажок Источники из реестра в список доступных баз данных. Все источники данных, созданные в версиях Query более ранних, чем Query 97, появятся в диалоговом окне Выбор источника данных; рядом с именами источников будет отображаться звездочка.

Создание источников данных для совместного использования. Если требуется организовать совместный доступ к запросам или шаблонам отчетов, использующим данные из внешних баз данных, включенных в старые источники данных, не допускающие совместного использования, создайте новые источники данных Microsoft Query 2000 для этих баз данных, и используйте новые источники данных для создания запросов, файлов запросов и шаблонов отчетов.

Удаление старых источников данных. См. сведения об удалении источников данных, не допускающих совместного использования.


Изменение изображения и метки значка, представляющего связанный или внедренный объект

  1. Выберите значок, который необходимо изменить.

  2. В меню Правка выберите команду Объект тип объекта (например, Документ), а затем выберите команду Преобразовать.

  3. Выберите команду Смена значка.

  4. Выберите необходимый значок из списка Значки или введите текст в поле Подпись.


 Редактирование связанных объектов

Редактирование связанных объектов

  1. В меню Правка выберите команду Связи.

  2. В списке Исходные файлы выберите источник связанного объекта, а затем выберите команду Открыть.

  3. Внесите необходимые изменения в связанный объект.

  4. В исходной программе в меню Файл выберите команду Выход.


Изменение способа расчета формул в Microsoft Excel

Изменение способа выполнения вычислений. Поскольку Microsoft Excel автоматически выполняет пересчет значений во всех открытых книгах при изменении значений в ячейках, программа может при этом работать медленно. Имеется возможность изменить способ выполнения вычислений, установив параметр пересчета вручную.

Изменение точности вычислений. При выполнении вычислений по формуле Excel, как правило, использует значения, хранящиеся в ячейках, на которые ссылается формула. Например, если каждая из двух ячеек содержит значение 10,005, и ячейкам присвоен денежный формат, то в каждой ячейке отображается значение 10,01р. При сложении значений ячеек результат будет равен 20,01р., так как Excel складывает хранящиеся в ячейках значения 10,005 и 10,005, а не отображаемые значения. Можно изменить точность вычислений, с тем чтобы при пересчете формул вместо значений, хранящихся в ячейках, Excel использовал отображаемые значения.

Изменение числа пересчетов, или итераций, формулы. Excel не может автоматически рассчитать значение по формуле, которая ссылается на ячейку — как прямо, так и косвенно, — содержащую формулу. Если формула содержит обратную ссылку на одну из своих собственных ячеек, необходимо указать число раз пересчета формулы.

См. сведения о расчете формул в Excel.

Примечание. Если необходимо найти оптимальное значений в ячейке, изменяя значения в других ячейках, или определить границу изменения значений, воспользуйтесь надстройкой «Поиск решения». См. сведения об использовании надстройки «Поиск решения».


Не отображается выноска помощника.

  • Поверх выноски может отображаться другая выноска с советом или сообщением. Чтобы увидеть перекрытую выноску, закройте выноску, находящуюся поверх нее.

  • Некоторые выноски с сообщениями закрываются автоматически при щелчке в окне программы. Как правило, это информационные сообщения, не требующие ответа, такие как сообщение о завершении проверки орфографии. Сообщения такого типа отображаются снова только при повторении действий, приводящих к их появлению, в данном примере — проверки орфографии.


Не удается продолжить работу с Microsoft Excel

При отображении некоторых видов сообщений (помощником или без его помощи) продолжение работы с Microsoft Excel может быть невозможно до тех пор, пока окно сообщения не будет закрыто. Это важные сообщения, для которых необходим ответ пользователя. Нажмите требуемую кнопку в окне сообщения. После закрытия окна сообщения можно продолжать работать с Microsoft Excel. Если сообщение больше не отображается, а отображается совет или справка, щелкните любое место окна Microsoft Excel, чтобы сообщение отображалось на экране.


Не удается открыть книгу, так как схема шифрования, с использованием которой она защищена, недоступна.

Некоторые свойства защиты и шифрования книг зависят от того, какая операционная система использовалась при создании книги. Для открытия защищенной книги необходимо снять защиту с использованием той операционной системы и того языка, которые использовались при создании книги.

Например, если используется английская (США) версия Windows, и получена книга, защищенная с использованием датской версии Windows, открыть книгу можно только после снятия защиты с использованием датской версии операционной системы.


Способы поиска значений на листе с помощью фильтров

Обзор
Основной автофильтр
Пользовательский автофильтр
Фильтр по выделенному
Расширенный фильтр


Способы поиска значений на листе с помощью фильтров


Способы прогнозирования значений с помощью анализа "что-если"

Таблицы данных
Сценарии
Подбор параметров и поиск решения


Способы прогнозирования значений с помощью анализа "что-если"


Способы публикации данных Excel в сети Web

Целые книги
Неинтерактивные данные или диаграммы
Интерактивные электронные таблицы
Интерактивные сводные таблицы
Интерактивные диаграммы
Смешанные Web-страницы


Способы публикации данных Excel в сети Web


Настройка меню и панелей инструментов

Настройка меню

Настройка команд меню

Настройка панелей инструментов

Настройка кнопок панелей инструментов

Настройка меню

Добавление команды или другого элемента в меню

Удаление команды из меню

Перемещение меню и команд меню

Переименование меню

Восстановление исходного вида встроенных меню

Возврат в начало

Настройка команд меню

Изменение значка или названия команды меню

Переименование команды меню

Возврат в начало

Настройка панелей инструментов

Добавление кнопки на панель инструментов

Удаление кнопки с панели инструментов

Перемещение или копирование кнопки панели инструментов

Перемещение или копирование меню на панель инструментов

Добавление встроенного меню на панель инструментов

Добавление пользовательского меню на панель инструментов

Удаление меню с панели инструментов

Группировка связанных кнопок и меню на панели инструментов

Изменение ширины раскрывающегося списка на панели инструментов

Создание пользовательской панели инструментов

Переименование настраиваемой панели инструментов

Удаление настраиваемой панели инструментов

Восстановление исходного вида встроенных панелей инструментов

Возврат в начало

Настройка кнопок панелей инструментов

Изменение значка или текста на кнопке панели инструментов

Переименование кнопки панели инструментов

Возврат в начало


Способы восстановления исходного вида встроенных меню и панелей инструментов

При настройке встроенных меню, панелей инструментов, команд меню или кнопок панелей инструментов можно восстановить их исходный вид. Для пользовательских меню, панелей инструментов и кнопок, а также кнопок, при нажатии которых отображается список, данная операция неприменима.

Меню. При добавлении, удалении или перегруппировке команд и подменю можно восстановить исходный набор и расположение команд и подменю встроенного меню.

Панели инструментов. При добавлении, удалении или перегруппировке кнопок можно восстановить исходный набор и расположение кнопок встроенной панели инструментов.

Кнопки панелей инструментов или команды меню. При изменении текста или значка для встроенной кнопки или команды меню можно восстановить исходный вид встроенной кнопки или команды меню.


 Открытие файла, созданного в другой программе

Открытие файла, созданного в другой программе

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск, папку или адрес FTP, где находится файл, который требуется открыть, а затем откройте папку, содержащую файл. Убедитесь, что в списке Тип файлов выбран пункт Все файлы.

  3. Если найти файл не удается, можно воспользоваться процедурой поиска файлов.

    Инструкции

  4. Щелкните файл, который требуется открыть.

  5. Нажмите кнопку Открыть.


Подготовка к печати

Обзор
Форматирование листа на экране
Добавление колонтитулов
Повторение заголовков на каждой странице
Изменение макета
Предварительный просмотр и настройка полей
Проверка разрывов страниц


Подготовка к печати


Графический фильтр Graphics Interchange Format (GIF)

Фильтр Graphics Interchange Format (Gifimp32.flt) поддерживает версии форматов GIF87a (включая чересстрочный вывод) и GIF89a (включая чересстрочный вывод и прозрачность).

Фильтр GIF не требуется ни для импорта и экспорта файлов GIF, ни для сохранения книг, содержащих изображения в формате GIF, в качестве Web-страниц (с расширением *.htm или *.html). Фильтр GIF требуется для импорта и экспорта изображений в формате GIF в коллекцию картинок и для импорта изображений в Microsoft Photo Editor. Фильтр GIF также требуется для экспорта отдельных диаграмм в файлы GIF с помощью Visual Basic для приложений.

Фильтр GIF не требуется для вставки анимированных рисунков в формате GIF в книги Excel. При сохранении книги, содержащей анимированный рисунок GIF, в качестве Web-страницы, анимация сохраняется. Над анимированными рисунками в формате GIF нельзя выполнять определенные операции редактирования — такие как обрезку или изменение заливки, обрамления или тени. Для внесения изменений в такие рисунки следует воспользоваться соответствующей программой для редактирования анимированных рисунков в формате GIF и затем снова вставить файл в книгу.

Фильтр GIF имеет следующее ограничение: из файла GIF, который содержит несколько рисунков, импортируется только первый рисунок.


Графический фильтр Computer Graphics Metafile

Графический фильтр Computer Graphics Metafile (Cgmimp32.flt) поддерживает формат CGM 1992 версии 1. Фильтр поддерживает все три кодировки, а также перекодирует и поддерживает все элементы. Фильтр правильно управляет всеми графическими файлами .cgm.

Основные промышленные профили ATA (Air Transport Association) и CALS (Continuous Acquisition and Life Cycle Support) полностью поддерживаются фильтром Computer Graphics Metafile. Фильтр сертифицирован Национальным Институтом Стандартов и Технологий (NIST).

При установке фильтра с помощью программы установки устанавливаются следующие файлы: Cgmimp32.flt, Cgmimp32.fnt, Cgmimp32.cfg и Cgmimp32.hlp.

Фильтр Computer Graphics Metafile имеет следующее ограничение: не поддерживается формат CGM 1992 версий 2, 3 и 4.

Примечание. Этот фильтр устанавливается только при установке Microsoft Office.


Графический фильтр CorelDRAW

Графический фильтр CorelDRAW (Cdrimp32.flt) поддерживает форматы файлов .cdr, .cdt, .cmx и .pat, созданных в CorelDRAW 3.0, 4.0, 5.0 и 6.0. Он имеет следующие ограничения:

  • не поддерживаются некоторые параметры CorelDRAW, например размер/ориентация страницы, сетка и другие подобные характеристики;

  • не поддерживаются линзы и фигурная обрезка;

  • не поддерживаются страницы, слои и группы;

  • не поддерживаются объекты OLE;

  • не поддерживается вращение точечных рисунков;

  • текстурные заливки и заливки PostScript заменяются сплошными серыми заливками;

  • градиентные заливки разбиваются на однотонные полосы;

  • не поддерживаются векторные заливки;

  • не поддерживается многосвязный текст.


Графический фильтр Encapsulated PostScript

Графический фильтр Encapsulated PostScript (Epsimp32.flt) поддерживает формат Adobe Systems Encapsulated PostScript Specification версии 3.0 и более ранних. Фильтр поддерживает внедренные в файлы .eps эскизы в формате TIFF или метафайла Windows (.wmf).

Если графический файл Encapsulated PostScript содержит внедренный эскиз в формате TIFF или метафайла Windows, то на экране отображается именно этот эскиз. Качество эскиза зависит от разрешения рисунка в формате TIFF или метафайла Windows, внедренного в файл Encapsulated PostScript во время его создания. При создании файла EPS обычно доступны низкое, среднее и высокое разрешения. Чем выше разрешение эскиза, тем больше будет размер файла EPS. Так как эскизы предназначены главным образом для позиционирования рисунков на листе, разрешение обычно является низким. Высокое разрешение для эскиза не требуется, так как он не используется при печати файла EPS на принтере PostScript.

Если импортируемый файл Encapsulated PostScript не содержит внедренный эскиз в формате TIFF или метафайла Windows, то вместо эскиза на листе отображается сообщение. Тем не менее, рисунок правильно печатается на принтере PostScript. На принтерах, не являющихся принтерами PostScript, рисунки EPS печатаются так, как они отображаются на экране.

Рисунки Encapsulated PostScript предназначены для печати на принтерах PostScript.


Графический фильтр Kodak Photo CD

Графический фильтр Photo CD поддерживает формат Kodak Photo CD версии 3.0. Этот формат позволяет хранить в одном графическом файле несколько рисунков с разным разрешением и глубиной цвета. При импорте файла Kodak Photo CD фильтр выбирает один из этих рисунков. При импорте файла Kodak Photo CD появляется диалоговое окно Параметры, предназначенное для задания параметров импорта файла: разрешения, ориентации и глубины цвета. По умолчанию используется разрешение 768 x 512 пикселов и 24-разрядная глубина цвета.

При установке фильтра с помощью программы установки устанавливаются следующие файлы: Pcdimp32.flt и Pcdlib32.dll.

Примечание. Этот фильтр устанавливается только при установке Microsoft Office.


Графический фильтр Macintosh PICT

Графический фильтр Macintosh PICT (Pictim32.flt) используется для импорта рисунков Macintosh PICT, а также просмотра книг Macintosh, открытых в Microsoft Excel для Windows. При копировании файлов Macintosh PICT на компьютер, работающий под управлением Windows, присвойте им расширение .pct, чтобы программа Microsoft Excel для Windows распознавала эти файлы как рисунки PICT. Например, если на Macintosh графический файл имеет имя Bear, то необходимо переименовать его в файл с именем Bear.pct перед вставкой в книгу Microsoft Excel для Windows.


Графический фильтр PC Paintbrush

Графический фильтр PC Paintbrush (Pcximp32.flt) поддерживает все версии формата файлов .pcx до ZSoft версии 3.0 включительно, в том числе 256-цветные рисунки. Это — широко распространенный формат обмена, используемый Microsoft Windows Paintbrush.


Графический фильтр Tagged Image File Format (TIFF)

Графический фильтр Tagged Image File Format (Tiffim32.flt) поддерживает все типы и сжатия рисунков, соответствующие формату TIFF Specification версий 5.0 и 6.0, часть1: Baseline TIFF, в том числе монохромные, черно-белые, цветные и полноцветные RGB-изображения. Фильтр правильно обрабатывает отдельный 8-разрядный альфа-канал, сохраняемый вместе с полноцветными RGB-изображениями. Фильтр TIFF также поддерживает расширение TIFF для изображений CMYK.

Импортируется только первый из содержащихся в файле TIFF рисунков.


Графические фильтры импорта и экспорта WordPerfect Graphics

Фильтр импорта WordPerfect Graphics (Wpgimp32.flt) поддерживает формат WordPerfect Graphics версий 1.0, 1.0e и 2.0, которые соответствуют WordPerfect версий 6.x или более ранних. Для определения размера импортируемого рисунка, содержащегося в документе WordPerfect, фильтр использует размер рамки рисунка. Для рисунков .wpg, созданных в DrawPerfect, размер рамки соответствует размеру экрана.

Фильтр импорта WordPerfect Graphics имеет следующие ограничения:

  • данные PostScript теряются в рисунках Encapsulated PostScript, внедренных в файлы WordPerfect Graphics;

  • файлы WordPerfect Graphics с большими внедренными точечными рисунками порой неправильно отображаются на компьютерах, использующих видео-драйверы Mach series фирмы ATI. В этом случае попробуйте запустить программу установки Windows и заменить текущие видео-драйверы драйверами 8514/a, которые поставляются вместе с Windows.

Примечание. Этот фильтр устанавливается только при установке Microsoft Office.


 Вставка на лист изображения, полученного с помощью сканера или цифровой камеры

Вставка на лист изображения, полученного с помощью сканера или цифровой камеры

Для выполнения этой процедуры соответствующее устройство (сканер или цифровая камера) должно быть подключено к компьютеру; устройство должно быть TWAIN-совместимым. Также необходимо убедиться, что установлено программное обеспечение устройства, обеспечивающее поддержку TWAIN.

В комплект поставки некоторых устройств входит несколько программ. Если неизвестно, какая из программ является TWAIN-совместимой, просмотрите документацию на устройство или обратитесь к производителю устройства.

  1. Откройте лист, на который требуется вставить изображение.

  2. Если используется сканер, поместите в сканирующее устройство оригинал изображения.

  3. В Microsoft Excel выберите пункт Рисунок в меню Вставка, а затем — команду Со сканера или камеры.

  4. Если к компьютеру подключено более одного устройства, выберите то, которое требуется использовать, в списке Устройство.

  5. Выполните одно из следующих действий:

    Для использования низкого разрешения, а также если документ предназначен для просмотра на экране, выберите параметр для передачи по Интернету.

    Для использования высокого разрешения, а также если документ предназначен для печати, выберите параметр для печати.

  6. Выполните одно из следующих действий:

    Если используется сканер и для сканирования изображения требуется использовать стандартные установки, нажмите кнопку Вставить.

    Если используется сканер и требуется изменить параметры сканирования изображения, а также если используется цифровая камера, нажмите кнопку Специальная вставка. После этого следуйте инструкциям, поставляемым с используемым устройством.

  7. После того как изображение появится на листе, внесите необходимые изменения.

    Для внесения изменений можно воспользоваться инструментами панели Настройка изображения, позволяющими выполнить различные действия, например обрезку изображения и настройку яркости, контрастности и цвета.

Примечание. Кнопка Вставить может быть недоступна при использовании некоторых моделей сканеров, если программное обеспечение сканера не поддерживает автоматическое сканирование. В этом случае можно воспользоваться кнопкой Специальная вставка.


Графический фильтр Portable Network Graphics (PNG)

Фильтр Portable Network Graphics (Png32.flt) поддерживает формат Portable Network Graphics Tenth Specification (версия 1.0). Этот фильтр используется при вставке файлов .png в книгу Microsoft Excel в качестве объектов Microsoft Clip Gallery или Photo Editor. Однако при вставке файлов .png непосредственно в книгу Microsoft Excel этот фильтр не используется.


Графический фильтр JPEG File Interchange Format

Графический фильтр Joint Photographic Experts Group (JPEG) (Jpegim32.flt) поддерживает формат JPEG File Interchange Format (JFIF) версии 6.0. Этот фильтр поддерживает формат CMYK файлов JPEG. Фильтр JPEG требуется для вставки файлов JPEG в книги Microsoft Excel в качестве объектов Microsoft Clip Gallery или Photo Editor. Фильтр JPEG также используется для экспорта отдельных диаграмм в файлы JPEG с помощью Visual Basic для приложений. Однако для непосредственной вставки файлов JPEG в книги Microsoft Excel фильтр JPEG не требуется.

Фильтр не поддерживает формат JPEG Tagged Interchange Format (JTIF).


Точечные рисунки Windows

Графический фильтр точечных рисунков Windows (Bmpimp32.flt) поддерживает точечные рисунки Windows и OS/2, Run Length Encoded (RLE), а также точечные рисунки, не зависящие от устройств (DIB). Этот фильтр используется при вставке файлов .bmp в книгу Microsoft Excel в качестве объектов Microsoft Clip Gallery или Photo Editor. Однако при вставке файлов .bmp непосредственно в книгу Microsoft Excel этот фильтр не используется.

Примечание. Этот фильтр устанавливается только при установке Microsoft Office.


 Исправление в процессе ввода орфографических ошибок и опечаток

Исправление в процессе ввода орфографических ошибок и опечаток

Для автоматического исправления часто встречающихся ошибок необходимо предварительно создать список соответствующих слов.

  1. Выберите команду Автозамена в меню Сервис.

    Демонстрация

  2. Проверьте, что установлен флажок Заменять при вводе.

  3. Введите слово, написание которого наиболее часто ошибочно, в поле заменять. Например, слово борбьа.

  4. Введите правильное написание слова в поле на. Например, слово борьба.

  5. Нажмите кнопку Добавить.

Совет. Используя автозамену можно вводить целые фразы по ключевым буквам. Выделите фрагмент текста и скопируйте его, а затем выберите команду Автозамена в меню Сервис. Введите ключевые буквы скопированного фрагмента в поле заменять. Выберите поле на и вставьте скопированный фрагмент, нажав клавиши CTRL+М, а затем нажмите кнопку Добавить. Например, используя ключевые буквы пит можно ввести текст " По итогам торгов" .


Восстановление исходного вида кнопок панелей инструментов или команд меню

  1. Отобразите панель инструментов, содержащую кнопку или команду, исходный вид которой требуется восстановить.

  2. В меню Сервис выберите команду Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. Выполните одно из следующих действий:

    Чтобы восстановить исходный вид кнопки панели инструментов, щелкните ее правой кнопкой мыши, а затем выберите команду Сброс в контекстном меню.

    Чтобы восстановить исходный вид команды меню, откройте меню, содержащее команду, щелкните ее правой кнопкой мыши, а затем выберите команду Сброс в контекстном меню.

Примечания

  • Команда Сброс восстанавливает для встроенной кнопки панели инструментов или команды меню исходные значок, имя и выполняемую команду. Если кнопке или команде меню был назначен макрос, он больше не будет связан с кнопкой или командой, но сам макрос не удаляется.

  • Команда Сброс недоступна для кнопок, нажатие которых приводит к выводу списка.


Графический фильтр Enhanced Metafile

Графический фильтр Enhanced Metafile (Emfimp32.flt) преобразует файлы Enhanced Metafiles (.emf) в метафайлы Windows (.wmf). Этот фильтр используется при вставке файлов .emf в книгу Microsoft Excel в качестве объектов Microsoft Clip Gallery или Photo Editor. Однако при вставке файлов .emf непосредственно в книгу Microsoft Excel этот фильтр не используется.

Примечание. Этот фильтр устанавливается только при установке Microsoft Office.


 Обновление одно- и двунаправленных полей из внедренной книги

Обновление одно- и двунаправленных полей из внедренной книги

  1. В Lotus Notes 4.0 щелкните правой кнопкой мыши книгу Microsoft Excel, вставленную как внедренный объект в документ или форму Notes, а затем в контекстном меню выберите Open.

    В Lotus Notes 3.x дважды щелкните мышью книгу Microsoft Excel, вставленную как внедренный объект в документ или форму Notes.

  2. В меню Файл Microsoft Excel выберите команду Свойства.

  3. Измените информацию в определенных ранее полях свойств файла.

  4. Закройте книгу и вернитесь в Lotus Notes.


 Обновление двунаправленных полей из Lotus Notes

Обновление двунаправленных полей из Lotus Notes

  1. В Lotus Notes откройте документ, содержащий обновляемое поле.

  2. Выделите текст в обновляемом поле.

  3. Между скобками поля введите новые данные.

  4. Чтобы обновить свойства в книге дважды щелкните мышью внедренную в документ или форму Lotus Notes книгу Microsoft Excel.


Метафайлы Windows

Графический фильтр метафайлов Windows (Wmfimp32.flt) поддерживает формат метафайлов Windows. Этот фильтр используется при вставке метафайлов Windows в книгу Microsoft Excel в качестве объектов Microsoft Clip Gallery. Однако при вставке метафайлов Windows непосредственно в книгу Microsoft Excel этот фильтр не используется.

Примечание. Этот фильтр устанавливается только при установке Microsoft Office.


 При двойном щелчке на связанном или внедренном объекте появляется сообщение "Нельзя изменить"

При двойном щелчке на связанном или внедренном объекте появляется сообщение "Нельзя изменить"

Данное сообщение появляется, если исходный файл или исходная программа не могут быть открыты.

Убедитесь, что исходная программа доступна. Если исходная программа не установлена на компьютере, преобразуйте объект в формат файла той программы, которая есть на компьютере. Для получения сведений о преобразовании объекта в другой формат файла нажмите кнопку [image] .

Убедитесь, что имеется достаточно памяти. Убедитесь, что на компьютере имеется достаточно памяти для запуска исходной программы. В случае необходимости для освобождения памяти закройте другие программы.

Закройте все диалоговые окна. Если исходная программа запущена, убедитесь, что в ней нет открытых диалоговых окон. Переключитесь в исходную программу и закройте все открытые диалоговые окна.

Закройте исходный файл. Если исходный файл является связанным объектом, убедитесь, что он не открыт кем-нибудь еще.

Убедитесь, что имя исходного файла не изменилось. Если исходный файл, который требуется изменить, является связанным объектом, убедитесь, что он имеет то же имя, что и при создании связи, а также что он не был перемещен. Чтобы узнать имя исходного файла, выделите связанный объект, а затем выберите команду Связи в меню Правка. Если исходный файл был переименован или перемещен, воспользуйтесь кнопкой Изменить в диалоговом окне Связи для нахождения исходного файла и восстановления связи.


 При копировании или перемещении формул изменяются содержащиеся в них ссылки

При копировании или перемещении формул изменяются содержащиеся в них ссылки

Абсолютные и относительные ссылки. Если скопированные формулы содержат относительные ссылки, Microsoft Excel исправляет ссылки (и соответствующие части смешанных ссылок) в копиях формул. Например, пусть ячейка B8 содержит формулу =СУММ(B1:B7). При копировании формулы в ячейку C8 формула будет ссылаться на соответствующие ячейки этого столбца: =СУММ(C1:C7). Абсолютные ссылки при копировании формул не изменяются.

Если в ячейках имеются формулы. При перемещении ячеек формулы, содержащиеся в них, не исправляются. Однако в формулы, содержащие ссылки на перемещенные ячейки, вносятся исправления с указанием нового местоположения ячеек.

Повторное перемещение или копирование. Если требуемые результаты не получены, измените ссылки в исходных формулах либо на относительные, либо на абсолютные. Затем снова скопируйте ячейки. Для получения дополнительных сведений о различии между относительными и абсолютными ссылками нажмите кнопку [image] .


 Восстановление данных из поврежденного файла

Восстановление данных из поврежденного файла

Чтобы восстановить как можно больше данных из поврежденного файла, сделайте следующее (возможно, только если испорчены первые несколько байтов. Формулы и макросы восстановлению не подлежат).

  1. В меню Файл выберите команду Открыть.

  2. Выберите папку, содержащую поврежденный файл, а затем нажмите кнопку Отмена.

  3. Выберите команду Создать в меню Файл.

  4. В ячейке A1 новой книги наберите следующую комбинацию: название книги, то есть поврежденный файл, и название листа, то есть лист, данные с которого необходимо восстановить.

    =[название книги]название листа!A1

  5. Выберите маркер заполнения ячейки A1и перетащите вниз столько строк, сколько было в листе поврежденной книги.

  6. Выберите маркер заполнения последней заполненной ячейки, и перетащите вправо столько колонок, сколько было в листе поврежденной книги.

  7. Выделите все заполненные ячейки, а затем выберите команду Копировать в меню Правка.

  8. В меню Правка выберите команду Специальная вставка.

  9. Выберите Значения, а затем нажмите кнопку OK.

Примечание. Если одна из ячеек содержит значение ошибки #ССЫЛКА!, эта часть листа не подлежит восстановлению.


Преобразование списка Microsoft Excel в формат Microsoft Access

После преобразования списка в базу данных Microsoft Access данные можно вести только в Microsoft Access. Изменения, внесенные после преобразования в базу данных Microsoft Access, не будут отображаться в списке Microsoft Excel.

Для выполнения преобразования списка Excel должен быть установлен Microsoft Access. Если команда Перенести в MS Access отсутствует в меню Данные Excel, необходимо установить и загрузить надстройку AccessLinks.

  1. Выделите ячейку в списке Excel.

  2. В меню Данные выберите команду Перенести в MS Access.

  3. Чтобы создать для списка новую базу данных Access, выберите параметр В новой базе данных.

    Чтобы добавить список в имеющуюся базу данных Access, выберите параметр В имеющейся базе данных, а затем введите путь к базе данных в соответствующее поле параметра В имеющейся базе данных. Для поиска базы данных на компьютере или в сети нажмите кнопку Обзор.

  4. Нажмите кнопку OK.

    Следуйте инструкциям мастера импорта электронных таблиц Access и мастера анализа таблиц для выполнения преобразования списка Excel в базу данных Access.

Примечания

  • После преобразования надстройка AccessLinks помещает справа от исходного списка надпись с сообщением о том, что список был преобразован в данные Access. Исходные данные при этом не изменяются.

  • Для получения дополнительных сведений о мастере импорта электронных таблиц Access и мастере анализа таблиц обратитесь к справочной системе Access.


(Untitled)

С помощью примечаний к ячейкам можно добавлять различные комментарии.

Добавление примечания к ячейке.

Ячейка с примечанием

Примечания можно просматривать как по отдельности, задерживая указатель над ячейкой, так и все одновременно. Кроме того, можно напечатать примечания на тех же местах, где они отображаются на листе, или же в виде списка в конце листа.

Дополнительные сведения

Просмотр примечаний в документе


(Untitled)

Для облегчения просмотра изменений, вносимых пользователями в общую книгу, имеется возможность выделения изменений.

В Microsoft Excel изменениям, вносимым каждым из пользователей, присваивается собственный цвет выделения. Например, новая строка, вставленная одним пользователем, выделяется зеленым цветом, а две ячейки, измененные другим пользователем — желтым. Выделенные изменения можно просматривать по одному и принимать или отклонять их.

Для выделения и просмотра сведений об изменениях перед внесением изменений необходимо сделать книгу общей. См. Установка общей книги.


 Получение советов и сообщений с помощью помощника

Получение советов и сообщений с помощью помощника

Ответы на разнообразные вопросы, необходимые советы, справка по использованию многочисленных возможностей программы — все это с готовностью предоставит помощник. Чтобы воспользоваться этим средством, необходимо прежде всего включить помощника. Поскольку помощник используется совместно всеми приложениями Microsoft Office, изменение любых его параметров (например, типа выдаваемых советов) отразится на работе помощника во всех приложениях пакета. Помощник позволяет получать справку способами, которые описаны ниже.

Советы по работе с программами. Типы советов, отображаемых помощником, можно изменить. Например, можно включить или отключить отображение советов по использованию сочетаний клавиш. Когда рядом с помощником появляется желтая светящаяся лампочка, это означает, что помощник предлагает совет; чтобы увидеть совет, щелкните лампочку. Если в момент появления совета помощник не отображается, светящаяся лампочка появляется на кнопке Справка по Microsoft Excel [image] на панели инструментов Стандартная. При нажатии кнопки на экране появится помощник, и в его выноске будет отображен совет.

Кроме того, можно включить или отключить отображение полезных советов при запуске программ.

Если помощник отображает напоминание Microsoft Outlook, он не может в это время отобразить совет. Совет появится, если нажать кнопку в окне напоминания для его закрытия.

Автоматический подбор разделов справки. Помощник может автоматически подбирать разделы справки, относящиеся к действиям, выполняемым в текущий момент. Например, если щелкнуть изображение помощника во время изменения диаграммы, выдаются разделы справки о работе с диаграммами. При необходимости эту возможность можно включить или отключить.

Справка по работе с мастерами. При запуске некоторых мастеров можно получить от помощника справку по мастеру. Если эти сведения не требуются, справку для мастеров можно отключить. Предоставляемые помощником справочные сведения имеются не для всех мастеров.

Системные сообщения. Помощник может отображать системные сообщения и предупреждения. Можно выбрать, просматривать ли сообщения в выноске помощника или в стандартном диалоговом окне.


Диаграммы

Данный раздел содержит следующие сведения:

Создание диаграммы

Представление данных на диаграмме

Внедренные диаграммы и листы диаграмм

Создание диаграммы

Диаграммы являются наглядным средством представления данных и облегчают выполнение сравнений, выявление закономерностей и тенденций данных. Например, вместо анализа нескольких столбцов чисел на листе можно, взглянув на диаграмму, узнать, падают или растут объемы продаж по кварталам или как действительные объемы продаж соотносятся с планируемыми.

Диаграмму можно создать на отдельном листе или поместить в качестве внедренного объекта на лист с данными. Диаграмму можно также опубликовать на Web-странице. Чтобы создать диаграмму, необходимо прежде всего ввести данные для диаграммы на лист. Затем выделите введенные данные и воспользуйтесь мастером диаграмм для пошагового создания диаграммы с выбором типа и различных параметров диаграммы.

Данные листа и диаграмма

Данные листа и диаграмма

Кроме того, можно создать диаграмму за один шаг без использования мастера диаграмм. При создании таким способом для диаграммы используются стандартные тип и параметры форматирования, которые позже можно изменить.

Отчет сводной диаграммы представляет собой интерактивную сводку данных в формате диаграммы. Способ его создания отличается от способа создания обычных диаграмм Microsoft Excel. После создания отчета сводной диаграммы можно просматривать разные уровни детализации и изменять макет диаграммы, перетаскивая ее поля и элементы. См. сведения о создании отчетов сводных диаграмм.

Возврат в начало

Представление данных на диаграмме

Диаграмма связана с данными, на основе которых она создана, и обновляется автоматически при изменении данных.

Данные листа на диаграмме

Как данные листа отображаются на диаграмме

Значения оси. Microsoft Excel создает значения оси на основе указанных данных. Обратите внимание на то, что в приведенном примере значения оси изменяются от 0 до 140000, что соответствует значениям ячеек диапазона на листе. Если не указано иное, в качестве числового формата для оси Excel использует формат верхней левой ячейки диапазона значений.

Имена категорий. В качестве имен оси категорий Excel использует заголовки столбцов или строк данных. В приведенном примере в качестве имен оси категорий отображаются заголовки строк, соответствующие первому кварталу, второму кварталу и т.д. Имеется возможность указать, должны ли использоваться заголовки столбцов или строк в качестве имен оси категорий, а также создать другие имена.

Имена рядов данных диаграммы. Excel также использует заголовки столбцов или строк данных в качестве имен рядов данных. Имена рядов отображаются в легенде диаграммы. В приведенном примере в качестве имен рядов выступают заголовки столбцов планируемых и действительных значений. Имеется возможность указать, должны ли использоваться заголовки столбцов или строк в качестве имен рядов, а также создать другие имена.

Маркеры данных. Маркеры данных одного цвета представляют один ряд данных. Каждый маркер соответствует одному значению данных листа. В приведенном примере самый правый маркер данных соответствует действительному значению за четвертый квартал, равному 120000.

Подсказки. При остановке указателя над каким-либо элементом диаграммы появляется подсказка с названием элемента. Например, при остановке указателя над легендой появляется подсказка «Легенда».

Дополнительные сведения

Организация данных в диаграмме

Возврат в начало

Внедренные диаграммы и листы диаграмм

Диаграмму можно создать на отдельном листе или поместить в качестве внедренного объекта на лист с данными. Независимо от способа размещения диаграмма является связанной с исходными данными на листе, то есть при обновлении данных обновляется и созданная на их основе диаграмма.

Внедренные диаграммы. Внедренная диаграмма рассматривается как графический объект и сохраняется в качестве части листа, на котором она создана. Внедренные диаграммы следует использовать в случаях, когда требуется отобразить или напечатать одну или несколько диаграмм вместе с данными листа.

Внедренные круговые диаграммы

Внедренные круговые диаграммы

Листы диаграмм. Лист диаграммы — это отдельный лист в книге, имеющий собственное имя. Листы диаграмм следует использовать в случаях, когда требуется просмотреть или изменить большие или сложные диаграммы отдельно от данных, или когда требуется сохранить пространство экрана для работы с листом.

Лист диаграммы

Возврат в начало


Работа с книгами Excel совместно с другими пользователями

Microsoft Excel и другие программы Office предоставляют следующие возможности создания и хранения файлов, обеспечивающие просмотр и доступ к ним нескольких пользователей.

Общие книги. Можно сделать книгу общей, с тем чтобы несколько пользователей могли работать с книгой одновременно. Excel позволяет отслеживать изменения, внесенные в книгу, и разрешать конфликты, возникающие при помещении в одну ячейку противоречащих значений.

Рассылка книг другим пользователям. Можно разослать копию книги или листа, отправив лист или книгу в качестве вложения в сообщении электронной почты либо непосредственно в виде самого сообщения, отправив книгу по маршруту от одного лица к другому или поместив книгу в общую папку Microsoft Exchange. Кроме того, можно организовать собрание по сети, позволяющее нескольким пользователям просматривать и обсуждать книгу в интерактивном режиме.

Публикация или сохранение данных Excel в качестве Web-страницы. Можно опубликовать или сохранить данные Excel на Web-странице, чтобы другие пользователи могли просматривать и работать с этими данными, используя Web-обозреватели. Помимо этого, можно разместить копию файла в Web; однако в этом случае пользователи смогут открыть файл только имея программу, позволяющую работать с файлами данного типа.


 Управление обновлением диапазона внешних данных

Управление обновлением диапазона внешних данных

Выполнение запроса в фоновом режиме или в режиме ожидания. Запрос внешних данных можно запустить в фоновом режиме и продолжить работу в Microsoft Excel, пока данные извлекаются, либо в режиме ожидания. Если выбран режим ожидания, запрос может выполняться быстрее, поскольку на извлечение данных будет отведено больше ресурсов компьютера. См. Запуск запроса в фоновом режиме и в режиме ожидания.

Обновление данных через определенные интервалы. Можно установить режим обновления диапазона внешних данных с заданным интервалом времени — например, каждые 60 минут.

Обновление данных. Помимо выполнения запроса в фоновом режиме или с заданным интервалом времени можно в любое время выполнить обновление внешних данных вручную.

Запрос пароля. Если для доступа к данным во внешнем источнике данных требуется пароль, можно установить режим запроса пароля при каждом обновлении диапазона внешних данных. Данная возможность недоступна при извлечении данных с помощью Web-запроса или из текстового файла. См. Запрос пароля при обновлении диапазона внешних данных.

Указание способа добавления данных. При изменении размера диапазона внешних данных можно указать способ добавления новых данных из внешнего источника данных. При добавлении новых данных могут быть вставлены новые ячейки и удалены неиспользуемые, вставлена целая строка и очищены неиспользуемые ячейки или произведена замена имеющихся значений ячеек новыми данными.

Заполнение формулами ячеек, смежных с диапазоном внешних данных. При расширении диапазона внешних данных и возврате дополнительных записей Excel может заполнить формулами соседние столбцы или столбцы внутри диапазона данных, чтобы они оставались рядом с соответствующими данными.

Примечание. Также существует возможность установить параметры форматирования и вида диапазона внешних данных при его обновлении.


 Редактирование связанных или внедренных объектов

Редактирование связанных или внедренных объектов

Редактирование связанного объекта. Для изменения связанного объекта в книге следует использовать команду Связи в меню Правка. Если команда Связи недоступна, это означает, что книга не содержит связанных данных. См. сведения о редактировании связанного объекта в исходной программе.

Редактирование исходного файла. Если на компьютере установлена исходная программа, для редактирования внедренного объекта дважды щелкните его. При двойном щелчке на внедренном объекте некоторые программы временно замещают панели инструментов на панели исходной программы, с тем чтобы дать возможность редактировать внедренный объект на месте. Другие программы запускают исходную программу в отдельном окне и затем открывают объект для редактирования. См. Редактирование внедренного объекта в исходной программе.

Преобразование внедренного объекта при отсутствии исходной программы. Если исходная программа отсутствует, следует преобразовать внедренный объект в формат файла какой-либо имеющейся программы. Например, если книга содержит вставленную таблицу Microsoft Works, и на компьютере нет пакета Works, можно преобразовать данный объект в формат книги Microsoft Excel и затем редактировать его в Excel. См. Редактирование внедренного объекта в программе, отличной от исходной.


 Обновление связанных данных в Microsoft Excel

Обновление связанных данных в Microsoft Excel

Автоматическое обновление. Связанный объект по умолчанию обновляется автоматически каждый раз при открытии конечного файла либо всякий раз при изменении исходного файла пока конечный файл открыт. См. Автоматическое обновление связей с другими приложениями во время выполнения расчетов.

Изменение способа обновления. Связанная информация может обновляться как автоматически, так и вручную — то есть по специальному запросу. См. Изменение способа обновления связанных объектов.

Обновление вручную. Связанный объект можно обновить в любое время независимо от того, какой способ обновления установлен — автоматический или вручную. См. сведения об обновлении связанного объекта вручную.

Запрещение обновления связей. Чтобы предотвратить обновление связей, можно заблокировать отдельные связи или все связи в книге. При блокировке связи Microsoft Excel использует последние данные, доступные в исходной программе. См. сведения о блокировании всех связей в Microsoft Excel.

Использование формул с удаленными ссылками. Если для связи с данными из других программ используются формулы с удаленными ссылками, данные обновляются в Excel автоматически при их изменении в исходной программе. Чтобы запретить обновление и «заморозить» текущие данные на листе, можно заменить всю формулу, или только удаленную ссылку, рассчитанным по формуле значением. См. сведения о замене удаленной ссылки вычисленным значением.


 Открытие книг

Открытие книг

Открытие файлов из других папок

Книги, находящиеся на локальном диске или в сети. С помощью диалогового окна Открытие документа (меню Файл) можно открывать книги, находящиеся в различных местах. Например, можно открывать книги, хранящиеся на локальном диске или сетевых дисках, к которым имеется подключение. Кроме того, если сеть поддерживает адреса UNC, то можно открывать книги, хранящиеся в сети, без предварительного подключения к сетевому серверу.

Книги, находящиеся в Web. Если имеется доступ к Интернету, модем и учетная запись поставщика услуг Интернета либо доступ через сеть, то можно открывать книги, находящиеся в Интернете или внутренней сети интранет и книги, хранящиеся на Web-серверах.

Файлы, созданные в других программах. Если имеется файл, созданный в другой программе, например Lotus 1-2-3 или Quattro Pro, то для открытия файла можно использовать Microsoft Excel.

Способы открытия файлов

Открытия в качестве копии или в режиме только для чтения. Если требуется обеспечить неизменность книги и имеется разрешение на сохранение файлов в месте расположения книги, то можно создать копию книги и работать с этой копией вместо исходного файла или открыть книгу только для чтения независимо от местоположения книги. См. Открытие книг только для чтения.

Открытие файлов в обозревателе. С помощью Excel можно открывать файлы HTML в обозревателе.

Панель инструментов «Web». Панель инструментов Web, доступная в программах Microsoft Office, позволяет легко перемещаться по книгам и другим документам Office, содержащим гиперссылки. Панель инструментов Web можно использовать для открытия начальной страницы или страницы поиска в Web-обозревателе. При обнаружении в Web интересующих вас книг с помощью панели инструментов Web можно добавить их в папку «Избранное», с тем чтобы затем быстро открывать их. Панель инструментов Web хранит список 25 последних книг, открытых с использованием этой панели. См. Открытие начальной страницы Web и Открытие страницы поиска в Web.

Дополнительные сведения

Одновременное открытие нескольких книг

Сохранение и открытие группы книг в пользовательской рабочей области


 Обзор

Одна диаграмма — несколько видов. Отчет сводной диаграммы объединяет интерактивные обобщенные данные, предоставляемые отчетом сводной таблицы, с наглядностью визуального представления и преимуществами диаграммы.

Отчет сводной диаграммы, отображающий продажи в западном регионе Отчет сводной диаграммы, отображающий продажи фруктов

Один отчет сводной диаграммы может быть использован для отображения одних и тех же данных различными способами. Первый вид отчета представляет продажи в западном регионе. Второй вид отображает продажи фруктов.

Использование отчета сводной диаграммы. Отчет сводной диаграммы следует использовать, если требуется быстро изменять вид диаграммы и просматривать данные в различных представлениях для проведения сравнения данных и выявления тенденций.

Например, в первом из приведенных примеров диаграмм, поле «Регион» — это поле страницы, а «Запад» — элемент, выбранный в поле страницы. Поэтому на диаграмме представлены обобщенные данные о продажах только для этого региона. При выборе другого элемента из раскрывающегося списка «Регион» на диаграмме будут отображены соответствующие данные для любого выбранного региона или для всех регионов, входящих в список.

Если же требуется подробнее остановиться на продажах фруктов, как во втором примере, можно переместить поле «Тип» из области полей категорий в область полей страниц, а поле «Регион» — в область полей категорий. Если в раскрывающемся списке «Тип» выбрать элемент «Фрукты», на диаграмме будут графически отображены обобщенные данные о продажах фруктов.

Исходные данные. Отчет сводной диаграммы всегда связан с отчетом сводной таблицы, и основан на тех же типах исходных данных, что и отчет сводной таблицы.

Форматирование. Изменять типы диаграмм и применять к отчетам сводных диаграмм различные параметры форматирования можно практически так же, как и для любых диаграмм Microsoft Excel, с небольшими различиями. Поскольку форматирование радов данных, включая добавление линий тренда и планок погрешностей, не сохраняется при изменении макета отчета сводной диаграммы, перед применением к рядам данным форматирования необходимо сначала создать полностью удовлетворяющий вас макет или вид данных.

Дополнительные сведения

Создание отчета сводной диаграммы


 О защите книг и листов от изменений

О защите книг и листов от изменений

В Microsoft Excel существует несколько способов ограничения просмотра и изменения пользователями данных в книгах и листах.

  • Зашита элементов листа. Имеется возможность запретить изменение другими пользователями некоторых элементов либо всего содержимого отдельного листа, просмотр скрытых строк или столбцов, просмотр формул, изменение графических объектов или сохраненных сценариев. См. список всех элементов листа, которые можно защитить.

  • Защита элементов книги. Можно запретить изменение содержимого книги другими пользователями путем добавления или удаления листов книги или просмотра скрытых листов. Также можно запретить изменение размеров и положения окон книги, удаление общей книги из общего пользования или отключение журнала изменений. См. список всех элементов книги, которые можно защитить.

  • Защита общей книги. Для общей книги можно запретить изменение данных путем назначения пароля или скрытия строк, столбцов или листов.

  • Защита ячеек. При защите книги или листа ячейки автоматически блокируются. Если требуется изменить значение в ячейке после защиты книги, необходимо сначала разблокировать ячейку.

  • Скрытие книги. Чтобы скрыть от других пользователей всю книгу, но оставить доступ к ее содержимому, выберите команду Скрыть в меню Окно, а затем сохраните изменения в скрытой книге.

  • Рекомендация доступа только для чтения. Можно рекомендовать другим пользователям открывать книгу только для чтения путем отображения соответствующего сообщения при открытии книги.

  • Запрос пароля. Круг пользователей, имеющих возможность открывать книгу и использовать содержащиеся в ней данные, можно ограничить, установив пароль на открытие книги или сохранение внесенных в нее изменений.

    Запрос паролей на открытие или использование книги

    Запрос паролей на изменение и сохранение книги

  • Защита от макровирусов. Заражения макросов вирусами можно избежать, включив защиту от макровирусов.


 (Untitled)

Поля и элементы. Отчет сводной таблицы содержит поля, каждое из которых соответствует столбцу (или измерению OLAP) в исходных данных и обобщает данные нескольких строк исходных данных. Поля в отчете сводной таблицы содержат элементы данных, распределенные по строкам или столбцам. Ячейки на пересечении строк и столбцов отображают обобщенные данные для элементов, расположенных в верхней части столбца и левой части строки.

Отчет сводной таблицы

В данном отчете сводной таблицы поле товаров содержит элементы, соответствующие молочным и мясным продуктам.

Поля и ячейки данных. Поле данных, например поле суммарных объемов продаж, предоставляет значения, обобщаемые в отчете сводной таблицы. Например, ячейка C6 отображает итоговый объем продаж молока продавцом Беловым за май — то есть сумму значений продаж из каждой строки исходных данных, содержащей значение месяца «Май», фамилию продавца «Белов» и значение «Молоко» для товара.

Итоговые функции. Для обобщения итоговых значений полей данных в отчетах сводных таблиц используются итоговые функции, такие как функции суммы, подсчета количества значений и нахождения среднего значения. Эти функции позволяют также автоматически вычислить промежуточные и общие итоги, если эти значения требуется отобразить. В приведенном примере для данных из столбца продаж в исходном списке с помощью функции СУММ вычисляются итоговые значения с отображением промежуточных итогов по месяцам и общих итогов для строк и столбцов. Для исходных данных OLAP сервер OLAP предоставляет предварительно рассчитанные функции. См. сведения об использовании общих и промежуточных итогов в отчете сводной таблицы.

Просмотр подробных данных. В большинстве отчетов сводных таблиц можно просматривать строки подробных данных, составляющих итоговое значение в отдельной ячейке данных. Исходные данные OLAP не организованы по строкам, которые можно просматривать подобным образом, однако имеется возможность изменить уровень детализации данных для всего отчета сводной таблицы, основанного на исходных данных OLAP. См. Подробные данные отчета сводной таблицы и выполняемые над ними действия.

Изменение макета. Перемещая кнопки полей в другие части отчета сводной таблицы, можно просматривать данные разными способами и вычислять различные итоговые значения. Например, можно отобразить имена продавцов по столбцам вместо строк. См. сведения об изменении макета отчета посредством перемещения поля или элемента.

Поле сводной таблицы перемещено

Перемещение поля «Продавец» в область столбцов

Дополнительные сведения

Элементы отчета сводной таблицы


 (Untitled)

Отчет сводной таблицы в структурированном формате аналогичен стандартным отчетам баз данных. Данные для каждого поля строки располагаются с отступом подобно текстовой структуре. Используя этот формат, можно просмотреть все итоговые значения для поля данных в одном столбце. Применение этой возможности является полезным в длинных отчетах сводных таблиц или отчетах, распространяемых в виде печатных копий.

Структурированный отчет сводной таблицы

Пример структурированного отчета сводной таблицы

Создание структурированного отчета сводной таблицы. Структурированный макет — это автоформат, применяемый после создания отчета сводной таблицы. При использовании автоформата для преобразования отчета сводной таблицы в структурированный формат поля столбцов в отчете становятся полями строк, и к отчету сводной таблицы применяются различные параметры форматирования текста и ячеек. Можно изменить форматирование для настройки вида отчета.

Печать структурированного отчета сводной таблицы. В Microsoft Excel можно устанавливать специальные параметры печати, относящиеся к отчетам сводных таблиц. Имеется возможность печати заголовков строк и столбцов и подписей данных сводной таблицы на каждой странице, а также возможность автоматической вставки разрывов страниц между разделами отчета.

Дополнительные сведения

Преобразование отчета сводной таблицы в структурированный или неструктурированный формат

Печать отчета сводной таблицы


 (Untitled)

Графическое представление данных сводной таблицы. Отчет сводной диаграммы — это интерактивная диаграмма, которую можно использовать для просмотра в графическом виде и организации данных подобно отчету сводной таблицы. Отчет сводной диаграммы всегда связан с отчетом сводной таблицы в той же книге, и включает все исходные данные из связанного отчета. И так же как отчет сводной таблицы, отчет сводной диаграммы имеет кнопки полей, с помощью которых можно отображать другие данные и изменять макет диаграммы.

Отчет сводной диаграммы

Пример отчета сводной диаграммы

Дополнительные сведения

Отчеты сводных диаграмм

Создание отчета сводной диаграммы


 (Untitled)

Исходные данные для отчета сводной таблицы. Отчет сводной таблицы можно создать на основе списка Microsoft Excel, внешней базы данных, нескольких листов Excel или другого отчета сводной таблицы. Следующие исходные данные используются во всех примерах отчетов, приведенных в данном разделе, для сравнения различных представлений одних и тех же данных.

Данные для отчета сводной таблицы

Пример данных для отчета сводной таблицы

Настройка исходных данных. Исходные данные в списках Excel и большинстве баз данных организованы в строки и столбцы. Используемые исходные данные должны содержать в каждом столбце информацию одного типа. В приведенном примере регион продаж всегда отображается в столбце E, объем продаж — в столбце D и так далее.

Исходные данные OLAP. Большие объемы данных в базах данных OLAP организованы в измерения и уровни вместо строк и столбцов. Отчеты сводных таблиц можно использовать для отображения и анализа данных из баз данных OLAP. Поскольку в этом случае итоговые значения для отчета сводной таблицы вычисляются сервером OLAP, а не Excel, извлечение данных из базы данных OLAP является более эффективным и позволяет анализировать большие объемы данных, чем при работе с другими типами баз данных. В Excel можно также создавать кубы OLAP на основе данных из внешних баз данных и сохранять файлы кубов для автономной работы с данными.

Дополнительные сведения

Выбор источника данных для отчета сводной таблицы

Различия между отчетами сводных таблиц, основанными на OLAP и не-OLAP данных

Создание куба OLAP на основе данных, полученных в результате запроса


 (Untitled)

Сводные таблицы в Web. Отчет сводной таблицы можно сохранить на Web-странице и опубликовать эту страницу для общего доступа, например на Web-сервере. В этом случае отчет называется сводной таблицей и обладает большинством интерактивных возможностей, доступных для отчетов в Microsoft Excel.

Пользователи, на компьютерах которых не установлены Web-компоненты Microsoft Office, могут просматривать сводные таблицы и использовать их интерактивные возможности с помощью Web-обозревателя Microsoft Internet Explorer версии 4.01 или более поздней. Для установки Web-компонентов Office компонентов необходимо установить Microsoft Office 2000 или, если организация имеет лицензию на узел Office 2000, загрузить Web-компоненты Office из внутренней интрасети организации.

Сводная таблица на Web-странице

Пример сводной таблицы на Web-странице

Дополнительные сведения

Отображение отчетов сводных таблиц Microsoft Excel в Web


 Извлечение внешних данных для отчета сводной таблицы или сводной диаграммы с помощью Microsoft Query

Извлечение внешних данных для отчета сводной таблицы или сводной диаграммы с помощью Microsoft Query

Подготовка. Для извлечения внешних данных при использовании мастера сводных таблиц и диаграмм необходимо установить Microsoft Query и соответствующие драйверы ODBC или драйверы источников данных, позволяющие получить доступ к требуемым внешним данным. Microsoft Query используется для извлечения внешних данных для использования их в Microsoft Excel, включая данные из баз данных, таких как Microsoft SQL Server или Microsoft Access, и данные из текстовых файлов. Для данных из базах данных OLAP Microsoft Query используется для выполнения настройки источника данных для доступа к базе данных.

Запуск Microsoft Query из мастера. Запустите мастер сводных таблиц и диаграмм, и на шаге 2 мастера нажмите кнопку Получить данные. В Microsoft Query можно выбрать имеющийся источник данных или файл запроса, или создать новый запрос. Чтобы создать новый запрос с помощью мастера запросов:

  • Выберите мастер. Убедитесь, что в диалоговом окне Выбор источника данных установлен флажок Использовать мастер запросов.

  • Выберите источник данных. Укажите источник данных, который требуется использовать, или определите новый источник.

  • Выберите данные. Укажите таблицы или файлы в источнике данных, содержащие требуемые данные.

  • Организуйте данные. Отобразите, отсортируйте и отфильтруйте данные из выбранных полей во внешнем источнике данных.

Вернитесь в мастер сводных таблиц и диаграмм, выбрав параметр Вернуть данные в Microsoft Excel на заключительном шаге мастера запросов.

Настройка запроса. Если требуется создать более сложный запрос, чем позволяют возможности мастера запросов, следует запустить на заключительном шаге мастера программу Microsoft Query. См. Создание запроса в Microsoft Query.

Дополнительные сведения

Типы внешних баз данных, к которым можно получить доступ

Создание отчета сводной таблицы

Создание отчета сводной диаграммы


Установка срока действия для журнала изменений

Число дней, указанное в качестве срока хранения журнала изменений, определяет, как долго Microsoft Excel будет хранить данные на листе «Журнал». Срок по умолчанию составляет 30 дней, поэтому, если планируется хранить книгу в течение более длительного времени, необходимо установить срок, превосходящий число дней, в течение которого требуется хранить журнал изменений.

При каждом закрытии книги Microsoft Excel удаляет части журнала изменений, которые хранятся дольше указанного числа дней. Сведения об изменениях, срок хранения которых не достиг предельного, остаются в журнале.


 О записи сведений о книге с помощью Microsoft Outlook

О записи сведений о книге с помощью Microsoft Outlook

Microsoft Outlook — это настольная система для управления информацией, которую можно использовать для отправки сообщений электронной почты; назначения собраний, событий и встреч; хранения списка контактов; ведения списка задач или планирования времени; назначения задач другим пользователям; записи выполняемых действий и хранения сведений о текущем состоянии книг и листов Microsoft Excel.

Outlook входит в состав Microsoft Office 2000. Для использования Outlook необходимо выбрать его при установке Microsoft Office 2000 и воспользоваться параметром Установить. См. сведения об установке Outlook на компьютере.

Отслеживание задач. Список задач Outlook можно использовать для отслеживания личных или связанных с работой задач и поручений, включая повторяющиеся задачи, до их завершения. Если задача включает действия с книгой Excel, задачу можно добавить в список задач непосредственно из Excel. Например, если требуется рецензировать книгу к определенной дате, можно открыть книгу в Excel и затем добавить рецензирование в список задач. Outlook можно также использовать для назначения задач, которые должны быть выполнены с книгой или файлом другими пользователями.

Автоматическая запись действий с файлом. С помощью дневника Outlook можно вести автоматическую запись выполняемых действий — например, сведений о создании или рецензировании — для любого файла, создаваемого в программе Office. Эта возможность включена по умолчанию.

Запись сведений о действиях с файлами вручную. Для отслеживания действий, выполняемых с отдельным файлом Office или файлами в программах, отличных от Office, можно вручную записывать сведения о действиях с файлами в дневник Outlook.

Отслеживание элементов с помощью контактов. Имеется возможность связать задачи, записи дневника и книги с определенным контактом, с тем чтобы вести отслеживание всех элементов, относящихся к этому контакту. Например, если требуется отслеживать книгу по имени ответственного за нее пользователя, можно связать контактные сведения с книгой и другими элементами, такими как сообщения электронной почты и встречи. Для получения дополнительны сведений о связывании задач, записей дневника и книг с контактом обратитесь к справочной системе Outlook.

Также имеется возможность отслеживания изменений, внесенных в книгу.


Использование нескольких заголовков в формулах

Многоуровневые заголовки. Если на листе имеются заголовки столбцов и строк, эти заголовки можно использовать при создании формул, ссылающихся на данные листа. Если лист содержит многоуровневые заголовков столбцов — в которых за заголовком в одной ячейке ниже следуют один или более заголовков — можно использовать эти заголовки в формулах, ссылающихся на данные листа. Например, если в ячейке E5 находится заголовок «Запад», а в ячейке E6 — заголовок «Проект», то формула =СУММ(Запад;Проект) возвращает общее значение для столбца «Запад Проект».

Порядок заголовков. При использовании ссылок на данные с помощью многоуровневых заголовков вы ссылаетесь на данные в порядке , в котором отображаются заголовки, сверху вниз. Если заголовок «Запад» находится в ячейке F5, а заголовок «Фактически» — в ячейке F6, то можно для обращения к фактическим объемам продаж для запада можно использовать в формуле ссылку «Запад;Фактически». Например, чтобы вычислить среднее значение фактических объемов продаж для запада, следует использовать формулу =СРЗНАЧ(Запад;Фактически).


(Untitled)

Диаграмма с областями подчеркивает изменение с течением времени. Отображая сумму значений рядов, такая диаграмма наглядно показывает вклад каждого ряда.

Диаграмма с областями

В данном примере диаграмма с областями показывает увеличение продаж по странам, а также иллюстрирует вклад каждой страны в общий объем продаж.


(Untitled)

Линейчатая диаграмма позволяет сравнивать отдельные значения. Ось категорий расположена по вертикали, ось значений — по горизонтали. Это позволяет обратить большее внимание на сравниваемые значения, чем на время.

Линейчатая диаграмма с накоплением показывает вклад отдельных элементов в общую сумму.

Линейчатая диаграмма с накоплением


 (Untitled)

Пузырьковая диаграмма — это разновидность точечной диаграммы. Размер маркера данных показывает значение третьей переменной.

Значения, которые откладываются по оси X, должны располагаться в одной строке или в одном столбце. Соответствующие значения оси Y и значения, которые определяют размеры маркеров данных, располагаются в соседних строках или столбцах.

Данные, по которым будет построена диаграмма

Из диаграммы в этом примере видно, что организация A предлагает самый широкий ассортимент изделий и охватывает самую большую часть рынка, однако уровень продаж у нее не самый высокий.

Примечание. Нельзя использовать пузырьковую диаграмму для создания отчета сводной диаграммы.


(Untitled)

Картинки — это готовые изображения, которые можно использовать для украшения листа. Картинки могут быть получены из различных источников, включая Clip Gallery, которая может быть установлена при установке Microsoft Office.

Картинки часто хранятся в формате метафайла. Метафайлы могут быть преобразованы в графические объекты и отредактированы графическими средствами Microsoft Excel. Вставка и редактирование рисунка или картинки.


(Untitled)

Гистограмма позволяет представить изменение данных на протяжении отрезка времени. Диаграммы этого типа удобны также для наглядного сравнения различных величин. Ось категорий в гистограмме располагается по горизонтали, ось значений — по вертикали. Такое расположение осей подчеркивает характер изменения значений во времени.

Гистограмма с накоплением позволяет представить отношение отдельных составляющих к их совокупному значению. На объемной гистограмме с перспективой сравниваемые значения располагаются в плоскости (вдоль двух осей).

Объемная гистограмма с перспективой

На этой трехмерной диаграмме показатели объемов продаж по Европе за четыре квартала сравниваются с показателями продаж для двух других подразделений.


 Вычисление значения с использованием условия

Вычисление значения с использованием условия

Данный раздел содержит следующие сведения:

Обзор

Функции СУММЕСЛИ и СЧЁТЕСЛИ

Функция ЕСЛИ

Мастер суммирования

Обзор

Формула в Microsoft Excel выполняет вычисления над значениями на листе. Обычно формула задает вычисления над всеми значениями в заданном диапазоне. А как быть, если необходимо изменить формулу при выполнении некоторого условия или необходимо включать в вычисления только значения, удовлетворяющие определенным условиям? Например, необходимо проследить все заказы, размещенные продавцами, и подсчитать объемы продаж по каждому продавцу. Или определить вознаграждение за каждую продажу по общей сумме накладных. Когда формула должна выполнять проверку условия, можно использовать условные формулы в Excel.

Список продаж по продавцам. Используйте условные формулы для вычисления процента вознаграждения и получения общего числа заказов и общей суммы накладных за указанный период для каждого продавца.

Excel включает три функции, которые вычисляют результат в зависимости от выполнения условия. Чтобы подсчитать число появлений определенного значения в диапазоне ячеек, используйте функцию СЧЁТЕСЛИ. Чтобы подсчитать общее количество с использованием одного условия, применяйте функцию СУММЕСЛИ. Чтобы вернуть одно из двух значений — например как процент вознаграждения — используйте функцию ЕСЛИ.

Если использование функций вызывает затруднения, воспользуйтесь мастером суммирования, который вычисляет суммы в зависимости от выполнения условий.

Дополнительные сведения

Вычисление значений в формулах

Использование функций для вычисления значений.

Возврат в начало

Функции СУММЕСЛИ и СЧЁТЕСЛИ

Предположим, что необходимо создать сводку, которая для каждого продавца показывает общее число размещенных заказов и общую сумму накладных за указанный период. Чтобы подсчитать число заказов, используйте функцию СЧЁТЕСЛИ. Чтобы вычислить сумму накладных, используйте функцию СУММЕСЛИ.

СЧЁТЕСЛИ

Функция СЧЁТЕСЛИ подсчитывает число заказов, размещенных каждым продавцом.

Сводка по размещенным заказам

Функция СЧЁТЕСЛИ имеет два аргумента: проверяемый диапазон и значение для проверки внутри диапазона (критерий).

=СЧЁТЕСЛИ(диапазон;критерий)

Для Батурина функция ( в ячейке B32) выглядит следующим образом:

=СЧЁТЕСЛИ(A2:A26;A32)

Функция считает количество появлений имени из ячейки A32 (аргумент критерий) в списке продавцов (A2:A26, аргумент диапазон).

СУММЕСЛИ

Сводка по общему объему продаж

Функция СУММЕСЛИ вычисляет общую сумму накладных для каждого продавца.

Функция СУММЕСЛИ проверяет значения в диапазоне и суммирует все соответствующие значения в другом диапазоне. Функция имеет три аргумента: проверяемый диапазон, значение для проверки внутри диапазона (критерий) и диапазон с суммируемыми значениями.

=СУММЕСЛИ(диапазон; критерий;сумм_диапазон)

Для Батурина функция ( в ячейке C32) выглядит следующим образом:

=СУММЕСЛИ(A2:A26;A32;B2:B26)

Формула ищет текст из ячейке A32 (аргумент критерий) в списке продавцов (A2:A26, аргумент диапазон) и суммирует соответствующие величины из столбца «Сумма накладной» (B2:B26, аргумент сумм_диапазон).

Дополнительные сведения

Использование функций для вычисления значений

Сведения о функции СЧЁТЕСЛИ

Сведения о функции СУММЕСЛИ

Возврат в начало

Функция ЕСЛИ

Предположим, что компания определяет вознаграждение по скользящей шкале, выплачивая 10 или 15 процентов в зависимости от суммы накладной. Чтобы определить, какое из двух значений использовать в зависимости от условия, воспользуйтесь функцией ЕСЛИ.

Условная формула, использующая функцию ЕСЛИ

Функция ЕСЛИ возвращает вознаграждение в размере 10% или 15% в зависимости от суммы накладной.

Функция ЕСЛИ проверяет условие, которое может принимать значения ИСТИНА или ЛОЖЬ. Если условие выполняется, функция возвращает одно значение, если условие ложно — другое. Функция имеет три аргумента: проверяемое условие, значение, возвращаемое при истинном условии, и значение, возвращаемое при ложном условии.

=ЕСЛИ(лог_выражение;значение_если_истина;значение_если_ложь)

Для накладной на сумму 8 000 р., выписанной Сушкиным, функция (в ячейке C4) выглядит следующим образом:

=ЕСЛИ(B4<10000;10%;15%)

Если сумма накладной меньше 10 000 р. (аргумент лог_выражение), вознаграждение составит 10 процентов (аргумент значение_если_истина). Если сумма накладной больше или равна 10 000 р., вознаграждение равно 15 процентам (аргумент значение_если_ложь).

Дополнительные сведения

Использование функций для вычисления значений

Сведения о функции ЕСЛИ

Возврат в начало

Мастер суммирования

Предположим, что имеется несколько условий, которые нужно проверить. Мастер суммирования создаст условные формулы.

Мастер суммирования быстро создаст формулы, содержащие несколько условий. Можно использовать мышь для задания условий, а затем мастер добавит формулы на лист.

В мастере укажите положение списка, проверяемые условия и положение результата. В предыдущем примере просуммируем накладные, выписанные Батуриным, сумма которых больше 10 000 р.

Мастер создает формулу массива, которая вычисляет результат. Если необходимо изменить условие, можно снова использовать мастер и заменить результаты в месте, указанном ранее.

Мастер суммирования — это программа надстройки, которая поставляется вместе с Excel.

Дополнительные сведения

Суммирование значений, удовлетворяющих определенным условиям, с помощью мастера суммирования

Сведения о формулах массива

Возврат в начало


(Untitled)

Использование маркеров данных цилиндрической, конической и пирамидальной формы может существенно улучшить внешний вид и наглядность объемной диаграммы.

Объемная линейчатая диаграмма с маркерами данных цилиндрической формы

Объемная гистограмма с маркерами данных пирамидальной формы


 Различия между отчетами сводных диаграмм и обычными диаграммами

При использовании обычных диаграмм необходимо создавать по одной диаграмме на каждое представление итоговых данных. С помощью отчетов сводных таблиц можно создать одну единственную диаграмму и просматривать различные обобщения данных, манипулируя только мышью.

Для того, кто знаком с обычными диаграммами, видно, что большинство операций: форматирование, выбор типа диаграммы, отображение заголовков и названий категорий и осей — выполняется для отчета сводной диаграммы точно таким же способом. Однако существует и ряд отличий.

Создание диаграммы Для создания обычной диаграммы в Microsoft Excel используется Мастер диаграмм. Метод создания отчета сводной диаграммы зависит от исходных данных. Для создания отчета сводной диаграммы, отображающего представление существующего отчета сводной таблицы в той же самой книге, можно воспользоваться Мастером диаграмм. Для создания отчета сводной диаграммы, не основанного на представлении существующего отчета сводной таблицы, используйте Мастер сводных таблиц и сводных диаграмм. После завершения работы мастера Excel автоматически создает связанный отчет сводной таблицы. Создание отчета сводной диаграммы.

Исходные данные Обычные диаграммы связаны непосредственно с ячейками листа. Сводные диаграммы не связаны с ячейками листа. Они могут быть основаны на нескольких различных типах данных, включая списки Excel, базы данных, множественные диапазоны консолидации данных и внешние источники (базы данных Microsoft Access и базы данных OLAP). Типы исходных данных, которые может использовать отчет сводной диаграммы.

Элементы диаграммы Отчет сводной диаграммы содержит те же элементы, что и обычная диаграмма, но также содержит поля и объекты, которые могут быть добавлены, повернуты или удалены для отображения разных представлений данных. Категории, серии и данные из обычных диаграмм Excel стали соответственно полями категорий, полями рядов и полями данных в отчете сводной диаграмме. Отчет сводной диаграммы также включает поля страниц. Каждое из этих полей содержит объекты, которые в обычной диаграмме отображаются как названия категорий или названия рядов в легендах. Поля отчета сводной диаграммы могут быть скрыты при печати или опубликовании в Интернете.

Сохранение форматирования Потеря форматирования не является проблемой для обычных диаграмм. Однако определенные типы форматирования могут не сохраняться в отчете сводной диаграмме после изменения макета или обновления данных отчета сводной диаграммы, которое измененяет количество точек данных. Типы форматирования, которые могут не сохраняться: линии тренда и планки погрешностей, изменения в подписях данных и изменения в рядах данных. Если диаграмма форматируется для вывода на печать или создания презентации, то рекомендуется форматировать только после того, как макет (или представление данных) будет удовлетворять всем условиям.

Перемещение элементов и изменение их размеров Определенные элементы отчета сводной диаграммы не могут быть перемещены и их размеры не могут быть изменены стандартным для обычных диаграмм способом. Невозможно переместить и изменить размер области построения в отчете сводной диаграмме. С помощью мыши невозможно переместить или изменить размер легенды, но легенду можно переместить с помощью режимаРазмещение на вкладке Легенда ( команда Параметры диаграммы в меню Диаграмма). Заголовки диаграммы и осей не могут быть перемещены, но можно изменить их размер, изменяя размер шрифта.

Положение диаграммы Обычные диаграммы по умолчанию встраиваются в лист. Сводные диаграммы по умолчанию создаются на листах диаграмм. Можно изменить положение сводной диаграммы, чтобы она была встроена в лист.

Тип диаграммы по умолчанию Стандартный тип для обычной диаграммы — это сгруппированная гистограмма, которая сравнивает данные по категориям. Тип отчета сводной диаграммы по умолчанию — это гистограмма с накоплением, которая оценивает вклад величины в итог внутри категории. Тип диаграммы может быть изменен на любой тип, кроме точечной, биржевой и пузырьковой диаграммы.


(Untitled)

Как и круговая диаграмма, кольцевая диаграмма показывает отношение частей к целому, но этот тип диаграммы может включать несколько рядов данных. Каждое кольцо в кольцевой диаграмме соответствует одному ряду данных.


(Untitled)

Рисунок в форме листа

Имеются следующие возможности создавать собственные графические объекты: вставка и редактирование картинок, рисование собственных картинок с использованием объектов Paintbrush Picture, использование средств панели инструментов Рисование. Эти средства позволяют добавлять и комбинировать Автофигуры (линии, базовые формы, элементы блок-схем, стрелки, звезды, заголовки и выноски). Можно также рисовать линии, полилинии и рисованные линии.

Дополнительные сведения

Отображение и скрытие панели инструментов «Рисование»

Полилинии и кривые


Графический фильтр FlashPix

Графический фильтр FlashPix (Fpx32.flt) позволяет импортировать в книгу изображения в формате FlashPix (.fpx) и Microsoft Picture It! (.mix). Кроме того, FlashPix является широко распространенным форматом обмена, используемым многими цифровыми камерами.


(Untitled)

Использование рисунка в качестве гиперссылки

Рисунки и кнопки могут быть сделаны активными, используя их как гиперссылки. При выборе рисунка осуществляется переход в указанное место текущего документа или Web-страницы, в другую книгу Microsoft Excel, на другую Web-страницу или к файлу, созданному другой программой. Например, можно вставить рисунок с биржевым логотипом компании и использовать его для гиперссылки на страницу с текущими ценами на акции компании. Создание гиперссылок из рисунков.


(Untitled)

Диаграмма с графическими объектами в роли маркеров данных

Графические объекты могут быть добавлены во встроенные диаграммы и диаграммы на отдельном листе; они также могут быть использованы в качестве маркеров данных.


(Untitled)

Использование рисунка для запуска макроса

Макросы Макрос — программа на языке Visual Basic для приложений — может быть назначен рисунку или кнопке. Можно использовать рисунок на листе для создания интегрированного интерфейса книги в автоматизированной программе. Например, можно создать рисунок с символом валюты и назначить ему макрос для поиска и отображения текущего месячного бюджета компании. Запуск макроса с помощью кнопки или графического элемента управления.


 (Untitled)

Скрытие элементов управления книги Скройте данные, которые пользователи не должны видеть при заполнении формы. Например, можно скрыть ячейки, содержащие формулы или список выбора, связанный с элементом управления списком. Скрытие содержимого конкретных ячеек.

Размещение и изменение размера элементов управления Разместите и измените размеры элементов управления на форме таким же образом, как и графические объекты, созданные с помощью панели управления Рисование.

Только для экранных форм

Ограничения на данные, вводимые в ячейки Для ограничения информации, вводимой пользователями в конкретные ячейки листа или поля, можно использовать команду Проверка из меню Данные для указания допустимых данных.

Защита листа Для предотвращения изменения формы пользователями можно защитить лист.

Ячейки, в которые попадают вводимые данные (непосредственным вводом или через элементы управления), должны быть выделены перед установлением защиты на лист.


 (Untitled)

Удаление дополнительных листов Удалите неиспользуемые листы из книги

перед сохранением формы в качестве шаблона.

Отключение линий сетки После завершения форматирования формы отключите отображение линий сетки перед сохранением формы.

Только для экранных форм

Предотвращение автоматических изменений Для того, чтобы Microsoft Excel не вставлял символ (©) при вводе (c) и не делал других автоматических изменений, сбросьте флажок Заменять при вводе в команде «Автозамена». Предотвращение автоматических исправлений.


 (Untitled)

Добавление рисунков На форму могут быть добавлены рисунки. Например, можно добавить отсканированные изображения и графические объекты, созданные с помощью панели инструментов Рисование, включая поля и специальные текстовые эффекты, созданные с помощью WordArt. Добавление рисунков на листы и в диаграммы.

Использование элементов управления Для упрощения ввода данных, сбора и обработки введенной информации в экранные формы могут быть добавлены элементы управления. Элементы управления расположены на панели инструментов Формы.

Переключатели и флажки

Например, пользователи могут выбирать элементы из раскрывающегося списка (поля со списком), связанного с ячейками, содержащими список. Добавление кнопок, флажков и других элементов управления.

В печатных формах можно использовать флажки с надписями и переключатели. Элементы управления должны быть установлены в состояние «снят», при этом прямоугольные рамки и кружки будут выведены пустыми, что делает их удобными для внесения пометок. Для внесения нескольких строк информации используйте светло серые границы при добавлении ячеек на форму.

Для форм, предназначенных для работы с программами Visual Basic для приложений или для использования в Интернете, следует использовать более мощные и разнообразные элементы управления ActiveX с панели «Элементы управления». Общие сведения об элементах управления ActiveX.

Только для экранных форм

Создание макросов Для автоматической обработки данных и дальнейшей настройки формы в зависимости от вводимых данных можно добавить макросы. Например, если пользователь выбирает флажок с надписью «Женат/Замужем», макрос связанный с этим элементом управления может предложить ввести «Имя супруги/супруга».

Добавление комментариев Для снабжения формы инструкцией по заполнению можно добавить примечания к ячейкам.

Создание формул Поскольку форма имеет все функциональные возможности листов, можно использовать данные из ячеек в формулах. Например, пользователи заполняют в бланке заказа только инвентарные номера и количества, а формулы вычисляют итоги, налоги и стоимость доставки. Создание формул для вычисления значения.

Формулы для вычисления промежуточных итогов

Дополнительные сведения

Создание экранной или печатной формы


 (Untitled)

Экранные формы

Для обеспечения интерактивности экранных форм могут быть использованы следующие инструменты: элементы управления, формулы и макросы.

При создании форм для использования их на экране необходимо определить, будут ли собранные данные храниться в базе данных. Для связи шаблона с базой данных можно использовать надстройку Мастер шаблонов с функцией сбора данных.

Чтобы сделать форму доступной другим пользователям в сети, необходимо сохранить форму в сети и установить место сохранения шаблона как дополнительную папку автозагрузки. Другим вариантом является создание ярлыка шаблона формы и копирование пользователями ярлыка в папку шаблонов. Формы можно также пересылать по электронной почте.

Печатные формы

При создании форм, которые пользователь будет заполнять на бумаге, главным является организация и форматирование формы, чтобы она была удобочитаемой и ее было легко заполнять. Полезные средства форматирования форм.


Графические фильтры Hanako

Сведения, относящиеся к конкретным языкам

Note The Hanako graphics filters are used for the Japanese language version of Microsoft Office.

The Hanako graphics filters (Jshimp.flt, Jahimp.flt, and Jbhimp.flt) support and convert .jsh, .jah, and .jbh files from Hanako versions 2.0 and 3.0 to Windows Metafile format.

The filters have the following limitations:

  • Image data is deleted when the files are opened.

  • Files with large amounts of data either may take time to convert or may not convert at all. If this occurs, delete any unnecessary data or objects, or resave the file as multiple files, and then try reopening them.

  • Complex text formatting or image properties that cannot be expressed in the Windows Metafile format are deleted or simplified when the files are opened. This may affect the alignment of text or images.


 Представление данных в отчете сводной диаграммы

Отчет сводной диаграммы всегда связан с отчетом сводной таблицы. Оба типа отчетов имеют соответствующие друг другу поля. Изменение положения поля в одном отчете вызывает изменение соответствующго поля в другом отчете. Поля строк в таблицах соответствуют полям категорий в диаграммах; поля столбцов в таблицах соответствуют полям рядов в диаграммах. Поля страниц и поля данных в таблицах соответствуют полям страниц и полям данных в диаграммах.

Приведенный ниже пример показывает соответствие между полями в каждом типе отчета.

Соответствие полей в отчетах сводной таблицы и сводной диаграммы

Макет отчета сводной диаграммы — то есть положение его полей — при создании диаграммы из отчета сводной таблицы первоначально определяется макетом отчета сводной таблицы. Если отчет сводной диаграммы создается первым, макет диаграммы формируется перетаскиванием полей из группы кнопок на панели инструментов Сводная таблица в соответствующие области размещения на листе диаграммы. Microsoft Excel автоматически создает связанный отчет сводной таблицы, который использует соответствующий макет.


(Untitled)

Формула является основным средством для анализа данных. С помощью формул можно складывать, умножать и сравнивать данные, а также объединять значения. Формулы могут ссылаться на ячейки текущего листа, листов той же книги или других книг. В следующем примере складывается значение ячейки B4 с числом 25. Полученный результат делится на сумму ячеек D5, E5 и F5.

Формулы, часто используемые в Microsoft Excel.


(Untitled)

Одновременная работа с книгой Открытие доступа позволяет нескольким пользователям одновременно работать с одной и той же копией книги и изменять значения, форматирование и другие элементы книги.

Например, имеется книга, содержащая месячный прогноз продаж для 10 продавцов. Требуется, чтобы продавцы в кратчайший срок ввели самые последние планы продаж для передачи этой информации руководству. Выполнение этой задачи в установленный срок требует одновременной работы нескольких человек с книгой.


 В лист был введен новый текст или новые числа, а диаграмма не была обновлена

В лист был введен новый текст или новые числа, а диаграмма не была обновлена

Если вводится новый текст или значения ряда данных и категорий на вкладке Ряд диалогового окна Исходные данные (меню Диаграмма, команда Исходные данные), Microsoft Excel разрывает связь между диаграммой и данными листа, по которому построена диаграмма. Excel также разрывает связи между подписями данных и соответствующими данными на листе. Можно переустановить все эти связи, используя один из перечисленных ниже способов.

Листы диаграмм Для восстановления связи между листом и листом диаграммы переопределите диапазон ячеек, использованный для создания диаграммы.

Внедренные диаграммы Для переустановки связей между листом и внедренной диаграммой необходимо заново указать диапазон ячеек или с помощью мыши изменить размер выделенного цветом диапазона, чтобы включить требуемые данные.

Подписи значений Для восстановления связей между данными листа и подписями значений, установите флажок Автоматический текст на вкладке Подписи значений для выбранных рядов или для всей диаграммы.

Дополнительные данные Если подписи и значения были введены на листе за пределами диапазона данных, по которому диаграмма построена, то необходимо добавить новые данные в диаграмму.

Отчеты сводных диаграмм Отчеты сводных диаграмм не связаны с данными на листе. Они используют копию данных, которая хранится в памяти. Если исходные данные изменены, а отчет сводной диаграммы не изменился, попробуйте обновить отчет сводной диаграммы.


(Untitled)

На графике с равными промежутками показаны прогнозируемые значения.


(Untitled)

Управление доступом к книге Открытие доступа к книге позволяет 256 пользователям одновременно получить доступ к одной копии книги. Установка общей книги.

Включение журнала изменений и установка срока годности Журнал изменений содержит записи о том кто, когда и какие изменения внес в книгу. Однако, для ограничения размеров файла Excel, хранит историю изменений только за заданное число дней. По умолчанию — за 30 дней, поэтому если необходимо хранить журнал изменений за более длительный период, следует увеличить срок годности. Это важно, потому что после завершения срока годности Excel удаляет старые записи журнала изменений. Включение журнала изменений книги.

Защита книги Защита книги позволяет запретить другим пользователям открывать, просматривать или редактировать фрагменты листов, листы целиком или книги. Ограничение прав доступа к общей книге.

Примечание. Некоторые установки на вкладке Подробнее в диалоговом окне Доступ к книге (меню Сервис) являются персональными, которые каждый пользователь общей книги может установить индивидуально. Пользователи могут установить частоту обновления книги (то есть сохранения собственных изменений в файле и просмотра последних изменений, выполненных другими). Можно также задать способ согласования противоречащих изменений.


(Untitled)

Обеспечение общего доступа к книге После установки общей книги ее следует сохранить в том месте, где все пользователи могут получить доступ к ней. Например, можно сохранить книгу в сети так, чтобы все потенциальные пользователи могли открыть и редактировать книгу.


(Untitled)

Ограничения по форматированию Когда доступ к книге открыт, некоторые возможности Microsoft Excel становятся недоступными. Например, нельзя объединять ячейки, удалять листы и вставлять диаграммы. Можно обойти эти ограничения, спланировав и выполнив изменения перед открытием доступа к книге. Может понадобиться также временно отменить общий доступ к книге на время выполнения изменений. Ограничения общей книги

Обеспечение инструкций по обновлению книги Инструкции могут быть добавлены непосредственно в книгу, используя примечания. Примечания могут появляться автоматически при открытии книги или в том случае, когда указатель мыши указывает на определенную ячейку. Добавление примечания к ячейке


 (Untitled)

В структурированном отчете сводной таблицы данные для каждого поля строки располагаются с отступом. Обобщенные значения для каждого поля данных выводятся в одном столбце.

Пример структурированного отчета сводной таблицы

Пример структурированного отчета сводной таблицы


(Untitled)

Вставка Можно вставить рисунки и отсканированные фотографии из других программ и из других папок на лист или в качестве фонового рисунка для листа.

Если к компьютеру подключен сканер, можно отсканировать фотографию и вставить ее в лист.

Редактирование Изображения, полученные с помощью программ типа Microsoft Paint и рисунки, которые выглядят как фотографии, обычно хранятся в формате растрового рисунка. Растровые рисунки состоят из отдельных точек и не могут быть разгруппированы. Однако они могут быть отредактированы с помощью средств с панели инструментов Рисование, которая появляется при выделении рисунка. Изображение может быть обрезано, его размер может быть изменен, к нему могут быть добавлены границы, может быть подогнана яркость и контрастность и , наконец, некоторые части изображения могут быть сделаны прозрачными. Из цветного рисунка может быть получен черно-белый рисунок, рисунок в оттенках серого или подложка. Редактирование рисунка.

Использование графических фильтров Excel распознает широкий спектр графических форматов. Поскольку все программы Office используют общие графические фильтры, установив графический фильтр любой другой программе Office — например, Word — можно использовать тот же фильтр и в других программах. Форматы изображений и графические фильтры.


(Untitled)

Круговая диаграмма показывает отношение размеров элементов, образующих ряд данных, к сумме элементов. Всегда отображается только один ряд данных. Такой тип диаграммы целесообразно использовать, когда необходимо подчеркнуть важный элемент.

Для облегчения работы с маленькими секторами в основной диаграмме их можно объединить в один элемент, а затем разбить в отдельную диаграмму рядом с основной.

Круговая диаграмма, содержащая вторую круговую диаграмму


 Защищаемые элементы книги

Защищаемые элементы книги

При защите книги с помощью команды Защитить книгу (меню Сервис, подменю Защита) ограничивается доступ к ней. Для снятия этих ограничений необходимо снять защиту книги с помощью команды Снять защиту книги (меню Сервис, подменю Защита). Если для защищенного элемента был установлен пароль, то необходимо знать этот пароль, чтобы снять защиту.

Защита структуры Если установлен флажок Структура в диалоговом окне Защитить книгу, пользователи не могут выполнить следующие действия, не сняв защиту:

  • Просмотр скрытых листов.

  • Перемещение, удаление, скрытие или переименование листов.

  • Вставка новых листов или листов с диаграммами. Допускается добавление внедренных диаграмм с помощью мастера диаграмм.

  • Перемещение или копирование листов в другую книгу.

  • Отображение для ячейки в области данных в сводных таблицах исходных данных, а также отображение страниц полей страниц на отдельных листах.

  • Создание итогового отчета для сценариев с помощью диспетчера сценариев.

  • Использование инструментов анализа надстройки «Пакет анализа» для помещения результатов на новый лист.

  • Запись новых макросов. Если в макросе содержатся инструкции, которые не могут быть выполнены в защищенной книге, выдается соответствующее сообщение и выполнение макроса останавливается.

Защита окна Если установлен флажок Окна в диалоговом окне Защитить книгу, пользователи не могут выполнить следующие действия, не сняв защиту:

  • Изменение размеров и положения окон открытой книги.

  • Перемещение, изменение размеров и закрытие окон. Разрешается однако скрывать и отображать окна.

Примечание. В редакторе Visual Basic предусмотрена возможность защиты макросов от просмотра и изменения. Для этого следует воспользоваться вкладкой Protection диалогового окна Project Properties в редакторе Visual Basic (команда VBProject Properties из меню Tools). Более подробные сведения содержатся в справочной системе редактора Visual Basic.


(Untitled)

В лепестковой диаграмме все категории имеют собственные оси координат, расходящиеся лучами из начала координат. Линиями соединяются значения, относящиеся к одному ряду.

Лепестковая диаграмма позволяет сравнивать совокупные значения нескольких рядов данных. В этой диаграмме ряд данных, который охватывает наибольшую площадь, «Сорт А» представляет сорт с самым высоким содержанием витаминов.


(Untitled)

Excel поставляется с набором готовых фигур, называемых автофигурами, которые можно использовать при подготовке презентаций. На автофигуры можно сослаться как на графические объекты. Меню Автофигуры на панели инструментов Рисование содержит несколько категорий фигур. Скрытие и отображение панели инструментов Рисование. После добавления автофигуры на лист можно изменить ее размер, повернуть, зеркально отразить, раскрасить, объединить с другими фигурами для получения более сложных фигур. Добавление круга, квадрата и других автофигур.

Автофигуры круг и стрелка

Если требуемая фигура не найдена, то выберите Другие автофигуры в меню Автофигуры для отображения автофигур, хранимых в Clip Gallery.

Можно также добавить текст в Автофигуры. Введенный текст становится частью фигуры — при перемещении, вращении или отражении фигуры текст перемещается вместе с ней. Ориентация текста сохраняется.


 Запрос цифрового сертификата от коммерческой службы сертификации

Запрос цифрового сертификата от коммерческой службы сертификации

Для получения цифрового сертификата от коммерческой службы сертификации, например VeriSign, Inc., необходимо подать заявку в эту службу. В зависимости от статуса разработчика программного обеспечения может быть выдан сертификат класса 2 или класса 3.

  • Класс 2 Этот класс цифровых сертификатов разработан для индивидуальных разработчиков программного обеспечения и обеспечивает гарантии подлинности индивидуального издателя.

  • Класс 3 Этот класс цифровых сертификатов разработан для компаний и других организаций, которые издают программное обеспечение, и обеспечивает гарантии подлинности организации-издателя. Сертификат класса 3 представляет уровень гарантии, обеспечиваемый сегодня каналами розничной продажи программного обеспечения. Претендент на сертификат класса 3 должен обладать уровнем финансовой стабильности, определяемым по рейтингам финансовой службы Dun & Bradstreet.

Цифровой сертификат сопровождается инструкциями по его установке на компьютере, используемом для подписи приложений Microsoft Office.

Цифровые подписи.


 Запрос цифрового сертификата от организации

Запрос цифрового сертификата от организации

Некоторые организации или компании могут иметь администратора безопасности или группу, выполняющую функции службы сертификации и использующую средства Microsoft Certificate Server для предоставления и распространения цифровых сертификатов. Microsoft Certificate Server может функционировать как отдельная служба сертификации или быть частью иерархии службы сертификации. В зависимости от способа использования цифровой подписи внутри организации можно или подписывать проекты макросов цифровым сертификатом от внутренней службы сертификации, или подписывать проект у администратора утвержденным сертификатом. За информацией о политике организации обращайтесь к сетевому администратору.

Цифровые подписи.


 (Untitled)

Точечная диаграмма или показывает отношения между численными значениями в нескольких рядах данных, или отображает две группы чисел как один ряд координат x и y. Эта диаграмма показывает неравные промежутки — или кластеры — данных и обычно используется для научных данных.

Располагая данные, поместите значения x в один столбец или одну строку, а соответствующие значения y в соседние строки или столбцы.

Данные, по которым будет построена диаграмма

Примечание. Нельзя использовать точечную диаграмму для создания отчета сводной диаграммы.


(Untitled)

Текст на лист может быть добавлен вводом его в ячейки. При этом можно использовать возможности форматирования для изменения размера, выравнивания, цвета и начертания шрифтов текста. Если требуется вставить «плавающий» текст, не связанный с конкретными ячейками — например, для создания заголовка рисунка — можно добавить текстовое поле на лист. Можно также добавить текст к большинству автофигур, исключая линии, соединители и полилинии.

Можно добавить оформление текста с помощью средства Добавить объект WordArt на панели инструментов Рисование. Можно создать текст с тенью, наклоненный, повернутый, растянутый текст, а также текст, вписанный в определенные ранее фигуры. Поскольку оформление текста является графическим объектом, можно также использовать средства на панели инструментов Рисование для изменения эффекта — например, для заполнения текста рисунком.

Графический объект WordArt

Примечание. Средства проверки правописания Microsoft Office не могут быть использованы для проверки орфографии в графическом объекте WordArt.


 (Untitled)

Диаграмма максимальный-минимальный-закрытие часто используется для демонстрации цен на акции. Этот тип диаграммы также может быть использован для научных данных, например для отображения изменений температуры. Для построения этой и других биржевых диаграмм необходимо расположить данные в правильном порядке.

Биржевая диаграмма, которая измеряет объемы, имеет две оси значений: одну для столбцов, которые измеряют объем, и другую — для цен на акции. Можно включить объем в диаграммы максимальный-минимальный-закрытие или открытие-максимальный-минимальный-закрытие.

Биржевая диаграмма с двумя осями значений

Примечание. Нельзя использовать биржевую диаграмму для создания отчета сводной диаграммы.


(Untitled)

Диаграмму «Поверхность» целесообразно использовать для поиска наилучшего сочетания в двух наборах данных. Как на топографической карте, области, относящиеся к одному диапазону значений, выделяются одинаковым цветом или узором.

Эта диаграмма показывает зависимость предела прочности на разрыв от времени и температуры


Символы, используемые при работе с графическими объектами

Для указания состояния графического объекта и возможных способов работы с ним используются специальные символы. Поскольку работа с различными графическими объектами производится разными способами, различные графические объекты используют разные символы.

Название символа | Пример | Описание
Маркеры выделения | Объект с маркерами выделения | Появляются на графическом объекте, когда он выбран. При протаскивании этих маркеров размер изображения уменьшается или увеличивается.
Маркеры вращения | Объект с маркерами вращения | При нажатии кнопки Свободное вращение на панели инструментов Рисование на объекте появляются круглые зеленые маркеры. Перетаскивая за один из этих маркеров, можно повернуть объект.
Маркер изменения формы | Объект с маркерами изменения формы | Желтый маркер изменения формы на автофигуре разрешает манипуляции с формой. В приведенном примере маркер был перетащен к центру, чтобы сделать фигуру более тонкой.
Узел | Объект с узлами | Черные квадратики появляются на концах и пересечениях линий и кривых в выделенных графических объектах при выборе команды Начать изменение узлов в меню Рисование. Потянув за них, можно изменить форму объекта.
Заштрихованная граница | Текст с заштрихованной границей | Когда текст окружен заштрихованной границей, текст внутри рамки можно вводить, удалять, выделять и форматировать.
Точечная граница | Текст с точечной границей | Когда текст окружен точечной рамкой, можно форматировать текстовое поле. Для получения точечной границы щелкните заштрихованную границу.

Дополнительные сведения

Добавление круга, квадрата или другой автофигуры

Добавление полилинии

Добавление текста с помощью кнопки «Надпись»


Формат текст Юникод

В формате текста Юникод сохраняются данные из ячеек активного листа.

Если файл в формате текста Юникод открывается программой, которая не может читать Юникод, например «Блокнот» в Microsoft Windows 95 или программы для Microsoft MS-DOS, данные будут потеряны.

Примечание. «Блокнот» в Microsoft Windows NT читает файлы в формате текста Юникод.


Апостроф ('), знак вставки (^) или кавычки (") отображаются в строке формулы, но их нет в ячейках.

Эти символы являются кодами форматирования, которые могут отображаться в документах, созданных в Lotus 1-2-3, или при установке клавиш перехода как в Lotus 1-2-3. В форматах Lotus 1-2-3 апостроф (') означает текст, выровненный по левому краю, кавычки (") — выровненный по правому краю, а знак вставки (^) — выровненный по центру.

Для удаления кодов выберите команду Параметры в меню Сервис, выберите закладку Переход и сбросьте флажок Клавиши перемещения Lotus 1-2-3.


Автоматическое обновление связей с другими приложениями во время выполнения расчетов

  1. В меню Правка выберите команду Связи.

  2. Выберите связь, которую надо изменить. (Если необходимо изменить сразу несколько связей, нажмите клавишу CTRL и, удерживая ее нажатой, выберите изменяемые связи.)

  3. В группе параметров Обновить, выберите параметр автоматически.

  4. Нажмите кнопку OK.

  5. В меню Сервис выберите пункт Параметры и перейдите на вкладку Вычисления.

  6. Установите флажок обновлять удаленные ссылки.


Выравнивание данных наверху, в центре и внизу ячейки

  1. Выделите ячейки, формат которых необходимо изменить.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Выравнивание.

  3. В поле Вертикальное выберите необходимый параметр.


 Выбор вводимых данных из списка

Выбор вводимых данных из списка

  1. Введите список корректных данных в строку или в столбец. Не включайте в список пустые ячейки.

  2. Выделите ячейки, на которые нужно наложить ограничения.

  3. Выберите команду Проверка в меню Данные, а затем откройте вкладку Параметры.

  4. Выберите Список в окне Тип данных.

  5. Введите ссылку на список корректных данных в поле Источник.

    Чтобы воспользоваться списком для выбора имеющих ограничения ячеек, установите флажок Список допустимых значений.

    Чтобы предотвратить ввод данных если ячейки, на которые наложены ограничения, пусты или отсутствует список корректных данных, снимите флажок Игнорировать пустые ячейки.

  6. Чтобы выводить подсказку, а также давать пояснения по поводу некорректных данных или предотвращать их ввод, укажите типы сообщений на вкладках Сообщение для ввода и Сообщение об ошибке.

    Инструкции

    Чтобы отменить вывод сообщений, снимите флажок Отображать подсказку, если ячейка является текущей на вкладке Сообщение для ввода, а также флажок Выводить сообщение об ошибке на вкладке Сообщение об ошибке.

Советы

  • Если список корректных данных короток, его можно вводить в поле Источник, используя разделитель элементов списка Windows (по умолчанию запятая). Так, допустимо набрать Низкий, Средний, Высокий в поле Источник, вместо того, чтобы вводить эти три слова на листе.

  • Если существует вероятность изменения списка корректных данных, присвойте имя диапазону элементов списка и затем введите это имя в поле Источник. При увеличении или уменьшении количества элементов в результате изменения списка, находящегося на листе, соответствующие изменения будут автоматически внесены в список корректных данных ячейки.

  • Если список корректных данных находится на другом листе или в другой книге, определите имя внешних данных на активном листе. Это позволит обращаться в поле Источник к имени, находящемся на том же листе. Например, если данные, которые требуется использовать в формуле, находятся в ячейках A6:A12 на первом листе книги Бюджет.xls, на активном листе можно определить имя «Данные» как =[Бюджет.xls]Лист1!$A$6:$A$12 и затем ввести =Данные в поле Источник. Чтобы получить более подробные сведения об определении имен, нажмите кнопку [image] .


 Ограничение диапазона вводимых данных

Ограничение диапазона вводимых данных

  1. Выделите ячейки, на которые нужно наложить ограничения.

  2. Выберите команду Проверка в меню Данные, а затем откройте вкладку Параметры.

  3. Выберите тип данных в списке Тип данных.

    Чтобы установить только числа, выберите Целое число или Действительное.

    Чтобы установить только даты или время, выберите Дата или Время.

  4. Выберите нужный оператор в списке Даты и затем введите верхнюю и нижнюю границы допустимого диапазона данных или только одну из них, в зависимости от требований. Границами могут служить числовые значения, а также ссылки на ячейки или формулы.

    Флажок Игнорировать пустые ячейки позволяет оставить ячейку, на которую наложены ограничения, пустой, а также установить границы, содержащие ссылку на изначально пустую ячейку или использующие формулу, в которую входит такая ячейка.

    Чтобы задействовать ограничения, которые были наложены на пустые ячейки так, как если бы эти ячейки содержали нули, снимите флажок Игнорировать пустые ячейки.

  5. Чтобы выводить подсказку, а также давать пояснения по поводу некорректных данных или предотвращать их ввод, укажите типы сообщений на вкладках Сообщение для ввода и Сообщение об ошибке.

    Инструкции

    Чтобы отменить вывод сообщений, снимите флажок Отображать подсказку, если ячейка является текущей на вкладке Сообщение для ввода, а также флажок Выводить сообщение об ошибке на вкладке Сообщение об ошибке.

Примечания

  • Определение типа корректных данных не приводит к форматированию ячейки. Чтобы отформатировать числа, даты или время, содержащиеся в ячейке, выберите Ячейки в меню Формат и затем — вкладку Число. В списке Числовые форматы выберите нужный формат, а также требуемые параметры.

  • Используемая в качестве предела формула может анализировать данные только на том листе, на котором были установлены ограничения. Чтобы употреблять в формуле данные из других листов или книг, введите ссылку на внешние данные в ячейку активного листа или определите на нем имя внешних данных. Таким образом формула будет содержать ссылку на ячейку или имя, находящиеся на том же листе. Например, если данные, которые требуется использовать в формуле, находятся в ячейке A6 на первом листе книги Бюджет.xls, нужно определить имя «Данные» на активном листе как =[Бюджет.xls]Лист1!$A$6 и затем ввести ссылку =«Данные» во время определения ограничений на данные. Чтобы получить более подробные сведения, нажмите кнопку [image] .

  • В формулах, служащих для ограничения данных, нельзя использовать константы массивов.


 Центрирование данных или выравнивание по левому или правому краю

Центрирование данных или выравнивание по левому или правому краю

В ячейках, в которых по умолчанию установлен общий формат, текст выровнен по левому краю, а числа, даты, время - по правому. При изменении выравнивания тип данных не меняется.

  1. Выделите ячейки, формат которых необходимо изменить.

  2. Нажмите соответствующую кнопку на панели инструментов Форматирование.
    Для выравнивания текста по | Действие
    левому краю | По левому краю
    по центру | По центру
    по правому краю | По правому краю

Советы

  • Для центрирования текста, занимающего несколько столбцов, например, названия столбцов, в строке выделенные ячейки можно объединить, и центрировать текст в полученной объеденной ячейке. Для получения дополнительных сведений нажмите кнопку [image] .

  • Для восстановления выравнивания, установленного по умолчанию, выделите ячейки, в меню Формат выберите команду Ячейки, а затем перейдите к вкладке Выравнивание. В поле Горизонтальное установите флажок Обычное.


 Проверка орфографии

Проверка орфографии

  1. Выделите диапазон ячеек, в которых необходимо проверить орфографию.

    Укажите одну ячейку, чтобы проверить орфографию на всем листе.

  2. Нажмите кнопку Орфография [image] .


 Копирование диаграммы Microsoft Excel в документ Word или PowerPoint

Копирование диаграммы Microsoft Excel в документ Word или PowerPoint

  1. Выберите диаграмму в Microsoft Excel.

  2. Нажмите кнопку Копировать [image] .

  3. Перейдите в документ Word или PowerPoint.

  4. Выберите место вставки диаграммы.

  5. В меню Правка Word или PowerPoint выберите команду Специальная вставка.

  6. В списке Как выберите объект Диаграмма Microsoft Excel.

  7. Если данные диаграммы могут изменяться и при этом необходимо отображение самых последних данных, выберите параметр Связать. Диаграмма будет вставлена в виде связанного объекта.

    Если требуются только текущие данные диаграммы, выберите параметр Вставить. Диаграмма будет вставлена в виде внедренного объекта.

Примечание. Чтобы получить более подробные сведения о связанных и внедренных объектах, нажмите кнопку [image] .


 Копирование палитры цветов в другую книгу

Копирование палитры цветов в другую книгу

  1. Откройте книгу, которой присвоена нужная палитра.

  2. Перейдите к книге, в которую требуется скопировать палитру.

  3. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Цвет.

    Демонстрация

  4. В поле Копировать цвета из выберите книгу, содержащую нужную палитру, а затем нажмите кнопку OK.


 Копирование части макроса для создания другого макроса

Копирование части макроса для создания другого макроса

  1. Откройте книгу, содержащую копируемый макрос.

  2. В меню Сервис выберите пункт Макрос, а затем выполните команду Макросы.

    Демонстрация

  3. В поле Имя макроса введите имя того макроса, который нужно скопировать.

  4. Нажмите кнопку Изменить.

  5. Выберите строки макроса, которые нужно скопировать.

    При копировании всего макроса целиком, убедитесь, что строки Sub и End Sub включены в выделенную область копирования.

  6. Нажмите кнопку Копировать [image] .

  7. Переключитесь в модуль, в который нужно вставить копируемые строки.

  8. Нажмите кнопку Вставить [image] .

Совет. Чтобы получить возможность использовать макрос в любое время, сохраните его в личной книге макросов. Это скрытая книга, которая открыта всегда. Чтобы скопировать в нее макрос, необходимо отобразить ее на экране. Для получения дополнительных сведений об отображении книги на экране нажмите кнопку [image] .


 Копирование модуля макроса в другую книгу

Копирование модуля макроса в другую книгу

  1. Откройте книгу, содержащую копируемый модуль, и книгу, в которую нужно его копировать.

  2. В меню Сервис выберите команду Макрос, а затем — Редактор Visual Basic.

  3. В меню Вид выберите пункт Окно проекта Кнопка окна проекта.

  4. Перетащите с помощью мыши копируемый модуль в нужную книгу.


 Копирование результатов вычислений в документ Word или в документ PowerPoint

Копирование результатов вычислений в документ Word или в документ PowerPoint

  1. Выберите ячейку с формулой на листе Excel.

  2. Нажмите кнопку Копировать [image] .

  3. Перейдите в документ Word или презентацию PowerPoint.

  4. Выберите место вставки результатов.

  5. В меню Правка Word или PowerPoint выберите команду Специальная вставка.

  6. Для вставки результата в виде текста выберите параметр Форматированный текст (RTF) или Неформатированный текст.

    Для вставки ячеек, размеры и местоположение которых можно изменять как у рисунка, выберите параметр Лист Microsoft Excel (объект).

  7. Чтобы использовать только текущее значение формулы, выберите переключатель Вставить.

    Для обновления скопированных данных при обновлении данных источника в Microsoft Excel, выберите переключатель Связать.

Примечания

  • Переключатель Связать в PowerPoint может использоваться только если выбран параметр Лист Microsoft Excel (объект).

  • При выборе переключателя Связать результат вставляется в качестве связанного объекта. Если выбран параметр Лист Microsoft Excel (объект) и переключатель Вставить, результат будет вставлен в качестве внедренного объекта. Чтобы получить более подробные сведения о связанных и внедренных объектах, нажмите кнопку [image] .


 Копирование ячеек листа Excel в документ Word или PowerPoint

Копирование ячеек листа Excel в документ Word или PowerPoint

  1. Выделите на листе Excel соответствующий диапазон и нажмите кнопку Копировать [image] .

  2. Перейдите в документ Word или PowerPoint и выберите место вставки.

  3. В меню Правка Word или PowerPoint выберите команду Специальная вставка.

  4. Для вставки ячеек, размеры и местоположение которых можно изменять как у рисунка, выберите параметр Лист Microsoft Excel (объект).

    Чтобы вставить в Word ячейки в виде таблицы с возможностью изменения размеров и форматирования, выберите параметр Форматированный текст (RTF).

    Для вставки текста с разделителями табуляции выберите параметр Неформатированный текст.

  5. Если требуется вставить только текущий результат формулы, выберите переключатель Вставить.

    Для обновления скопированных данных при обновлении данных источника в Microsoft Excel, выберите переключатель Связать.

Примечания

Вставка связей в PowerPoint Переключатель Связать в PowerPoint может использоваться только если выбран параметр Лист Microsoft Excel (объект).

Вставка объекта листа Excel Если выбран параметр Лист Microsoft Excel (объект) и переключатель Вставить, на внедренном рисунке будут отображаться только видимые данные. Если часть данных не отображается, измените размер столбцов, дважды щелкнув объект, таким образом, чтобы данные показывались полностью. Если при вставке объекта листа был выбран переключатель Связать, связанный рисунок отражает текущее форматирование ячеек и ширину столбцов в книге источника данных.

Связывание и внедрение объектов При выборе переключателя Связать результат вставляется в качестве связанного объекта. Если выбран параметр Лист Microsoft Excel (объект) и переключатель Вставить, результат будет вставлен в качестве внедренного объекта. Чтобы получить более подробные сведения о связанных и внедренных объектах, нажмите кнопку [image] .

Последующее добавление данных Чтобы обеспечить возможность впоследствии добавлять строки и столбцы данных к связанным ячейкам, задайте имя диапазона в Microsoft Excel. После этого скопируйте диапазон и выполните вставку ячеек в Word или PowerPoint в виде связанного объекта. После того, как в диапазон Microsoft Excel были добавлены новые данные, можно переопределить имя диапазона с учетом дополнительных ячеек. После обновления связи новые данные отобразятся в соответствующем объекте Word или PowerPoint.


 Создание отчета сводной диаграммы

Создание отчета сводной диаграммы

При создании отчета сводной диаграммы Microsoft Excel автоматически создает связанный отчет сводной таблицы. Если отчет сводной таблицы уже существует, можно его использовать для создания отчета сводной диаграммы, который будет отображать представление этой таблицы.

Когда отчет сводной диаграммы основывается на внешних не-OLAP исходных данных, может понадобиться получить внешние данные до создания отчета. Создание отчета сводной диаграммы из внешнего источника данных.

  1. Откройте книгу, в которой необходимо создать отчет сводной диаграммы.

    Если отчет создается на основе данных, находящихся в списке или базе данных Excel, выделите ячейку списка или базы данных.

  2. Выберите команду Сводная таблица в меню Данные.

  3. На шаге 1 в Мастере сводных таблиц и сводных диаграмм следуйте инструкциям и укажите Сводная диаграмма (со сводной таблицей) в разделе Вид создаваемого отчета.

  4. Следуйте инструкциям на шаге 2 мастера.

  5. На шаге 3 мастера укажите место размещения связанного отчета сводной таблицы. Отчет сводной диаграммы автоматически создается на листе диаграммы. Затем решите нужно ли нажимать кнопку Макет.

  6. Выполните одно из следующих действий:

    Если нажата кнопка Макет на шаге 3 мастера, выполните формирование макета отчета сводной диаграммы в мастере, нажмите кнопку OK в диалоговом окне Макет и затем нажмите Готово для создания отчета сводной диаграммы.

    Если кнопка Макет на шаге 3 мастера не была нажата, нажмите кнопку Готово, а затем сформируйте макет отчета сводной диаграммы на листе диаграммы.

Совет Если связанный отчет сводной диаграммы не должен быть виден, можно скрыть лист, на котором расположен отчет сводной таблицы.


 Изменение цвета в палитре цветов

Изменение цвета в палитре цветов

  1. Откройте книгу, в палитре которой требуется изменить цвет.

  2. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Цвет.

    Демонстрация

  3. Выберите цвет, который нужно заменить, и нажмите кнопку Изменить.

  4. Чтобы заменить выделенный цвет одним из цветов стандартной палитры, откройте вкладку Обычные и выберите нужный цвет.

    Чтобы изменить оттенок цвета, выберите вкладку Спектр, а затем измените соответствующие параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечания

  • Чтобы восстановить используемую по умолчанию палитру цветов, нажмите кнопку Сброс на вкладке Цвет.

  • Если ячейки или объект копируются в другую книгу, им присваивается цветовая палитра этой книги. Чтобы сохранить при копировании присвоенные объектам цвета, необходимо либо скопировать в эту книгу цветовую палитру исходной книги, либо изменить соответствующие цвета палитры этой книги.

  • Чтобы изменить цвета, устанавливаемые по умолчанию в новых книгах, измените палитру стандартного шаблона книги или палитру, используемую для создания новых книг. Для получения сведений об изменении шаблона нажмите кнопку [image] .


 После обновления отчета утеряны данные в сводной таблице или отчете сводной диаграммы

После обновления отчета утеряны данные в сводной таблице или отчете сводной диаграммы

Установка полей страниц для просмотра всех данных Убедитесь в том, что выбран элемент Все в каждом из полей страниц списка до того, как сводная таблица или отчет сводной диаграммы были обновлены.

Если список поля страницы не содержит Все, то или в поле страницы устанавливается запрос к внешним данным только при выборе элемента поля, или сводная таблица и отчет сводной диаграммы основаны на исходных данных из базы данных OLAP, которые не включают информацию для элемента Все для этого поля. В любом случае данные будут обновлены после выбора другого элемента. Установки полей страниц.

Проверка местоположения недостающих данных Для сводной таблицы или отчета сводной диаграммы, основанных на списке Microsoft Excel, новые данные могли быть добавлены вне объявленного исходного диапазона или исходные данные могли быть перемещены в другое место. Изменение исходного диапазона для включения новых данных или указания нового местоположения.

Проверка правильности запроса, извлекающего данные Если сводная таблица или отчет сводной диаграммы основаны на внешних не-OLAP исходных данных, проверьте запрос в Microsoft Query, чтобы убедиться в извлечении требуемых данных.

Проверка куба или файла куба Если сводная таблица или отчет сводной диаграммы основаны на кубе, созданном мастером куба OLAP, проверьте содержимое куба, чтобы убедиться в том что он содержит требуемые данные. Если отчет основан на файле куба, проверьте содержимое файла куба. Если отчет основан на исходных данных из базы данных на сервере OLAP, обратитесь к администратору базы данных для выяснения возможных изменений в базе данных.


Вращение текста в ячейке

  1. Выделите ячейки, внутри которых необходимо перевернуть текст.

  2. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Выравнивание.

  3. В поле Ориентация выберите градус поворота либо переместите индикатор на необходимый угол.

    Для отображения текста вертикально сверху вниз в поле Ориентация выберите поле с вертикальным Текстом.


 Поиск записей в списке с помощью формы

Поиск записей в списке с помощью формы

  • Для перемещения на одну запись нажмите на стрелки полосы прокрутки в диалоговом окне. Чтобы переместиться на 10 записей, нажмите полосу прокрутки между стрелками.

  • Нажмите кнопку Далее для перехода к следующей записи списка и Назад — для перехода к предыдущей.

  • Чтобы задать условия поиска или условия сравнения, нажмите кнопку Критерии. Введите критерии в форме. Чтобы найти совпадающие с критериями записи, нажмите кнопки Далее или Назад. Чтобы вернуться к правке формы, нажмите кнопку Правка. Для получения более подробных сведений об условиях сравнения нажмите [image] .


 Происходит изменение формата при обновлении отчета сводной таблицы или изменении макета

Происходит изменение формата при обновлении отчета сводной таблицы или изменении макета

Проверка сохранения параметров форматирования Щелкните ячейку на отчете, а затем выберите Параметры таблицы (панель инструментов Сводная таблица, меню Сводная таблица). Убедитесь в том, что в разделе Формат установлен флажок Сохранять форматирование. Можно изменить форматирование, и оно будет сохранено при обновлении или изменении макета.

Границы ячеек не сохраняются При изменении структуры или обновлении сводной таблицы изменения линий по границам ячеек не сохраняются.

Условное форматирование не работает Если условные форматы применены к ячейкам отчета сводной таблицы, могут быть получены непредсказуемые результаты.


 Сдвиг текста от левого края ячейки

Сдвиг текста от левого края ячейки

  1. Выделите ячейки, содержащие текст, который необходимо сдвинуть.

  2. На панели инструментов Форматирование выберите кнопку Увеличить отступ [image] .

    Для уменьшения сдвига или его отмены нажмите кнопку Уменьшить отступ [image] .


 Создание гиперссылки на определенное место в книге

Создание гиперссылки на определенное место в книге

Для связывания места в текущей или другой книге можно присвоить ячейкам имя или использовать ссылку на ячейку.

  1. Для использования имени присвойте имя указываемым ячейкам в связываемой книге.

  2. Щелкните правой кнопкой мыши текст или рисунок, которые будут представлять гиперссылку, а затем выберите Гиперссылка в контекстном меню.

  3. Выполните одно из следующих действий:

    Для связывания места в текущей книге в разделе Связать с выберите Место в этом документе.

    Для связывания места в другой книге в разделе Связать с выберите Имеющийся файл или Web-страница.

  4. Если на шаге 3 выбран Имеющийся файл или Web-страница, найдите и выделите связываемую книгу и нажмите кнопку Закладка в разделе Найдите.

  5. Выполните одно из следующих действий:

    В списке в разделе Адрес ячейки выберите лист, который нужно связать, и введите ссылку на ячейку в поле Введите адрес ячейки. Нажмите кнопку OK.

    В списке под Определенные имена выберите имя, которое представляет связываемую ячейку или ячейки. Нажмите кнопку OK.

  6. Для назначения подсказки, которая будет отображаться при фиксации указателя мыши на гиперссылке, нажмите кнопку Подсказка и затем введите требуемый текст в поле Текст подсказки. Нажмите кнопку OK.

Примечания

  • Если подсказка не определена, в качестве подсказки будут использоваться имя книги, имя листа, адрес ячейки или имя.

  • Нельзя создавать гиперссылку из элемента управления, созданного при помощи панели инструментов Формы или из кнопки и рисунка, которые имеют прикрепленный макрос.

  • Путь к новому файлу по умолчанию устанавливается относительно положения активной книги. Можно задать другой путь, используемый по умолчанию, установкой базового адреса гиперссылки.


 Создание гиперссылки для нового файла

Создание гиперссылки для нового файла

  1. Щелкните правой кнопкой мыши текст или рисунок, которые будут представлять гиперссылку, а затем выберите Гиперссылка в контекстном меню.

  2. В разделе Связать с, выберите Создать документ.

  3. Введите имя нового файла в поле Имя нового документа.

  4. Для задания папки, отличной от указанной в поле Путь, нажмите кнопку Изменить и выберите требуемую папку. Нажмите кнопку OK.

  5. В разделе Когда вносить правку в новый документ выберите параметр, определяющий время открытия нового файла для редактирования (открывать в момент создания гиперссылки или это будет сделано позже).

  6. Для назначения подсказки, которая будет отображаться при фиксации указателя мыши на гиперссылке, нажмите кнопку Подсказка и затем введите требуемый текст в поле Текст подсказки. Нажмите кнопку OK.

Примечания

  • Если подсказка не указана, в качестве подсказки будет использоваться путь к новому файлу.

  • Если необходимо изменить текст, представляющий гиперссылку в исходной книге, введите новый текст в поле Текст.

  • Путь к новому файлу по умолчанию устанавливается относительно положения активной книги. Можно задать другой путь, используемый по умолчанию, установкой базового адреса гиперссылки.

  • Нельзя создавать гиперссылку из элемента управления созданного при помощи панели инструментов Формы или из кнопки и рисунка, которые имеют прикрепленный макрос.


Книги издательства Microsoft Press о Microsoft Excel

Издательство Microsoft Press предлагает обучающие и справочные материалы, помогающие более полно использовать возможности Excel и Microsoft Office.

Издания Microsoft Press, от простых буклетов и руководств по самостоятельному обучению до справочников, технических руководств и руководств по программированию, будут полезны как начинающим, так и опытным пользователям, специалистам технической поддержки и разработчикам программ.

Многие книги издательства Microsoft Press доступны на русском языке. Их можно приобрести в магазинах, торгующих компьютерной литературой. Дополнительные сведения об изданиях Microsoft Press можно получить на Web-узле издательства Microsoft Press.

Книги о Microsoft Excel

Тема | Книга
Практическое учебник, содержащий основные сведения о Excel. | Microsoft Excel 2000 для Windows: шаг за шагом (Microsoft Excel 2000 for Windows Step by Step) Автор: Catapult, Inc. ISBN: 1-57231-974-1
Небольшой, но полезный справочник для начинающих пользователей, рассматривающий вопросы программного обеспечения. | Путеводитель по Microsoft Excel 2000 (Microsoft Excel 2000 Field Guide) Автор: Stephen L. Nelson ISBN: 1-57231-971-2
Наглядный справочник, предлагающий пути решения конкретных задач | Microsoft Excel 2000: наглядно и конкретно (Microsoft Excel 2000 at a Glance) Автор: Perspection, Inc. ISBN: 1-57231-942-9
Полный справочник (руководство пользователя), включающий подробные сведения, примеры и рекомендации специалистов по программному обеспечению | Эффективная работа с Microsoft Excel 2000 (Running Microsoft Excel 2000) Авторы: Mark Dodge и Craig Stinson ISBN: 1-57231-935-6
Средство для быстрого обучения начинающих пользователей, ориентированное скорее на решение задач, чем на рассмотрение возможностей. | Краткий курс Microsoft Excel 2000 (Quick Course in Microsoft Excel 2000) Автор: Online Press, Inc. ISBN: 1-57231-977-1

Книги по Office 2000, содержащие сведения о Excel

Тема | Книга
Комплексное средство обучения для пользователей Office 2000, включающее печатные и мультимедийные обучающие материалы. | Microsoft Office 2000: шаг за шагом (Microsoft Office 2000 Step by Step Learning Kit) Автор: Microsoft Press ISBN: 0-7356-0508-4
Полное мультимедийное средство обучения для начинающих и опытных пользователей Office 2000, ориентированное на решение конкретных задач. | С чего начинается Microsoft Office 2000 (Microsoft Office 2000 Starts Here) Автор: Microsoft Press ISBN: 0-7356-0506-8
Средство для быстрого обучения начинающих пользователей, ориентированное скорее на решение задач, чем на рассмотрение возможностей. | Краткий курс Microsoft Office 2000, стандартный и профессиональный выпуски (Quick Course in Microsoft Office 2000 Standard and Professional) Автор: Online Press, Inc. ISBN: 1-57231-981-X
Наглядный справочник, предлагающий пути решения конкретных задач | Microsoft Office 2000, стандартный и профессиональный выпуски: наглядно и конкретно (Microsoft Office 2000 Standard and Professional At a Glance) Автор: Perspection, Inc. ISBN: 1-57231-937-2
Полный справочник (руководство пользователя), включающий подробные сведения, примеры и рекомендации специалистов по программному обеспечению | Эффективная работа с Microsoft Office 2000, стандартный и профессиональный выпуски (Running Microsoft Office 2000 Standard and Professional) Авторы: Michael Halvorson и Michael Young ISBN: 1-57231-936-4
Полный справочник (руководство пользователя), включающий подробные сведения, примеры и рекомендации специалистов по программному обеспечению. | Эффективная работа с Microsoft Office 2000, расширенный выпуск (Running Microsoft Office 2000 Premium) Авторы: Michael Halvorson и Michael Young ISBN: 1-57231-945-3
Практический учебник, содержащий основные сведения по Office. | Microsoft Office 2000, стандартный и профессиональный выпуски; книга из серии «Шаг за шагом» (Microsoft Office 2000 Standard and Professional 8-in-1 Step by Step) Авторы: Catapult, Inc., Perspection, Inc. и SES Publishing ISBN: 1-57231-984-4
Процедурный подход к программированию на Visual Basic. | Основы Visual Basic для Microsoft Office 2000 (Microsoft Office 2000 Visual Basic Fundamentals) Автор: David Boctor ISBN: 0-7356-0594-7
Изучение возможностей Visual Basic и обучение созданию компактного и эффективного кода мощным языком программирования, используемым в Office 2000. Это руководство позволяет повысить продуктивность программирования на Visual Basic для приложений. В нем рассматривается создание дополнительных команд пользователя, меню, диалоговых окон, сообщений и кнопок, а также создание оперативной справки для этих элементов пользовательских форм. | Руководство программиста по Visual Basic для Microsoft Office 2000 (Microsoft Office 2000/Visual Basic Programmer's Guide) Автор: Microsoft Corporation ISBN: 1-57231-952-6
Руководство по установке, настройке и поддержке продуктов Office 2000 в организации. Этот пакет предназначен для системных администраторов, консультантов и опытных пользователей и полностью охватывает работу Office 2000 в системах Windows 95, Windows 98 или Windows NT Workstation. | Ресурсы Microsoft Office 2000 (Microsoft Office 2000 Resource Kit) Автор: Microsoft Corporation ISBN: 0-7356-0555-6


 Создание формулы массива

Создание формулы массива

При вводе формулы массива Microsoft Excel автоматически заключает ее в фигурные скобки ( { } ).

  1. Если формула массива возвращает одно значение, укажите ячейку, в которую необходимо ввести формулу.

    Если формула массива возвращает несколько значений, выделите диапазон ячеек, в которые необходимо ввести формулу.

  2. Наберите формулу.

  3. Нажмите клавиши CTRL+SHIFT+ENTER.


 Черно-белая печать

Черно-белая печать

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Лист.

  3. Установите флажок Черно-белая.


 Черновая печать

Черновая печать

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Лист.

  3. Установите флажок Черновая.


 Ограничение количества вводимых в ячейку символов

Ограничение количества вводимых в ячейку символов

  1. Выделите ячейки, на которые нужно наложить ограничения.

  2. Выберите команду Проверка в меню Данные, а затем откройте вкладку Параметры.

  3. Выберите команду Длина текста в окне Тип данных.

  4. Выберите нужный оператор в окне Значение. Для этого оператора следует указать границы диапазона. Границами диапазона могут служить числовые значения, ссылки на ячейки и формулы.

    Флажок Игнорировать пустые ячейки позволяет оставить ячейку, на которую наложены ограничения, пустой, а также установить границы, содержащие ссылку на изначально пустую ячейку или использующие формулу, в которую входит такая ячейка.

    Чтобы задействовать ограничения, которые были наложены на пустые ячейки так, как если бы эти ячейки содержали нули, снимите флажок Игнорировать пустые ячейки.

  5. Чтобы выводить подсказку, а также давать пояснения по поводу некорректных данных или предотвращать их ввод, укажите типы сообщений на вкладках Сообщение для ввода и Сообщение об ошибке.

    Инструкции

    Чтобы отменить вывод сообщений, снимите флажок Отображать подсказку, если ячейка является текущей на вкладке Сообщение для ввода, а также флажок Выводить сообщение об ошибке на вкладке Сообщение об ошибке.

Примечания

  • Чтобы хранить в ячейке текст, не накладывая ограничений на количество символов, выберите больше или равно в окне Значение, а затем введите 0 (ноль) в поле Минимум.

  • Определение длины текста не приводит к форматированию ячейки. Чтобы отформатировать текст, содержащийся в ячейке, выберите Ячейки в меню Формат, а затем — вкладку Число в окне Числовые форматы. После этого щелкните строку текст.

  • Используемая в качестве границы формула может анализировать данные только на том листе, на котором были установлены ограничения. Чтобы употреблять в формуле данные из других листов или книг, введите ссылку на внешние данные в ячейку активного листа или определите на нем имя внешних данных. Таким образом формула будет содержать ссылку на ячейку или имя, находящиеся на том же листе. Например, если данные, которые требуется использовать в формуле, находятся в ячейке A6 на первом листе книги Бюджет.xls, нужно определить имя " Данные" на активном листе как =[Бюджет.xls]Лист1!$A$6 и затем ввести ссылку на " Данные" во время определения ограничений на данные. Чтобы получить более подробные сведения, нажмите кнопку [image] .

  • Если ввод данных в ячейку с ограничением длины текста осуществляется в виде формулы, Microsoft Excel проверяет длину результата, а не длину формулы. Например, если минимальная длина составляет три символа, то при вводе в ячейку =20+50, результат, 70, составит два символа и, следовательно, будет некорректен.

  • В формулах, служащих для ограничения данных, нельзя использовать константы массивов.


 Задание качества печати

Задание качества печати

  1. Выберите лист Excel.

  2. В меню Файл выберите команду Параметры страницы, и затем вкладку Страница.

  3. В поле Качество печати выберите требуемое разрешение.


 Определение правильности вводимых данных с помощью формулы

Определение правильности вводимых данных с помощью формулы

  1. Выделите ячейки, на которые нужно наложить ограничения.

  2. Выберите команду Проверка в меню Данные, а затем откройте вкладку Параметры.

  3. Выберите тип Другой в окне Тип данных.

  4. В поле Формула введите формулу для расчета логического значения (ИСТИНА или ЛОЖЬ). Данные, вводимые в ячейку, считаются некорректными, если результатом вычислений является значение ЛОЖЬ. Перед формулой необходимо поставить знак равенства (=).

    Например, на листе производится расчет прибыли путем вычитания суммы вводимых издержек из расчетной суммы дохода. Может возникнуть необходимость поддерживать прибыль на уровне, превышающем определенный процент издержек. В этом случае для ячеек D6:D13, служащих для ввода издержек, следует определить допустимые данные с помощью формулы следующего вида: =Прибыль > СУММ(D6:D13) * 15%, где «Прибыль» — это имя ячейки.

    Если требуется, чтобы ячейка, на которую накладываются ограничения, оставалась пустой, а также, если формула включает изначально пустые ячейки, установите флажок Игнорировать пустые ячейки.

    Чтобы задействовать ограничения, которые были наложены на пустые ячейки так, как если бы эти ячейки содержали нули, снимите флажок Игнорировать пустые ячейки.

  5. Чтобы выводить подсказку, а также давать пояснения по поводу некорректных данных или предотвращать их ввод, укажите типы сообщений на вкладках Сообщение для ввода и Сообщение об ошибке.

    Инструкции

    Чтобы отменить вывод сообщений, снимите флажок Отображать подсказку, если ячейка является текущей на вкладке Сообщение для ввода, а также флажок Выводить сообщение об ошибке на вкладке Сообщение об ошибке.

Примечания

  • Перед тем как проанализировать формулу, Microsoft Excel производит вычисления с учетом введенных в ячейку данных.

  • Используемая в качестве ограничения формула может анализировать данные только на том листе, на котором наложены ограничения. Чтобы употреблять в формуле данные из других листов или книг, введите ссылку на внешние данные в ячейку активного листа или определите на нем имя внешних данных. Таким образом формула будет содержать ссылку на ячейку или имя, находящиеся на том же листе. Например, если данные, которые требуется использовать в формуле, находятся в ячейке A6 на первом листе книги Бюджет.xls, можно определить имя «Данные» на активном листе как =[Бюджет.xls]Лист1!$A$6 и затем ввести ссылку на «Данные» в формулу. Чтобы получить более подробные сведения об определении имен, нажмите кнопку [image] .

  • В формулах, служащих для ограничения вводимых данных, нельзя употреблять константы массива.

  • Если в поле Тип данных выбран тип, отличный от Другой, значением формулы, задающей ограничение, должно быть число.


Повышение безопасности сообщения

Предполагаемые действия

Опечатывание всех исходящих сообщений

Добавление цифровой подписи ко всех исходящим сообщениям

Не можете сделать выбор?


Изменение шрифта и цветов разделов справки

Предполагаемые действия

Изменение шрифта разделов справки

Изменение размеров текста разделов справки

Изменение цветов текста и цвета фона разделов справки

Изменение других специальных возможностей

Не можете сделать выбор?


Совместная с другими пользователями работа с книгой Excel

Предполагаемые действия

Совместный доступ к книге

Отправка документов другим пользователям

Размещение данных Excel на Web-странице

Не можете сделать выбор?


Создание изображений ячеек, диаграмм и других объектов

Предполагаемые действия

Создание изображений ячеек, диаграмм и других объектов, не связанных с исходными данными

Создание изображения ячеек, привязанных к исходным данным

Не можете сделать выбор?


 Сохранение существующей книги

Сохранение существующей книги

  • Нажмите кнопку Сохранить [image] .


Даже если нажать кнопку "Заменить все", при проверке орфографии исправляются не все слова

  • Если до окончания проверки орфографии закрыть окно диалога Проверка орфографии, оставшиеся ошибки сохранятся.

  • Если орфография проверяется в выделенном диапазоне ячеек, остальные ячейки не проверяются. Для проверки орфографии на всем листе необходимо указать одну ячейку.


ИНДЕКС

См. также

Возвращает ссылку на ячейку на пересечении указанной строки и указанного столбца. Если ссылка составлена из несмежных выделений, то можно указать, какое именно выделение следует использовать.

Функция ИНДЕКС имеет две синтаксические форма: ссылка и массив. Ссылочная форма всегда возвращает ссылку; форма массива всегда возвращает значение или массив значений.

Синтаксис 2

Ссылочная форма

ИНДЕКС(ссылка;номер_строки;номер_столбца;номер_области)

Ссылка - это ссылка на один или несколько интервалов ячеек.

  • Если в качестве аргумента ссылка используется несмежное выделение, то аргумент ссылка нужно заключить в дополнительные скобки. Пример использования функции ИНДЕКС с несмежным выделением см. ниже в пятом примере.

  • Если каждая область в ссылке содержит только одну строку или один столбец, то аргумент номер_строки или номер_столбца, соответственно, является необязательным. Например, для одиночной строки следует использовать форму ИНДЕКС(ссылка;;номер_столбца).

Номер_строки - это номер строки в аргументе ссылка, на которую возвращается ссылка.

Номер_столбца - это номер столбца в аргументе ссылка, на который возвращается ссылка.

Номер_области - это интервал ссылки, из которого надо возвращать пересечение номер_строки и номер_столбца. Первая введенная или выделенная область имеет номер 1, вторая - 2, и так далее. Если номер_области опущен, то функция ИНДЕКС использует область номер 1.

Например, если аргумент ссылка описывает ячейки (A1:B4,D1:E4,G1:H4), то номер_области 1 соответствует интервалу A1:B4, номер_области 2 соответствует интервалу D1:E4 и номер_области 3 соответствует интервалу G1:H4.

После того, как с помощью аргументов ссылка и номер_области выбран конкретный интервал, с помощью аргументов номер_строки и номер_столбца выбирается конкретная ячейка: номер_строки 1 соответствует первой строке интервала, номер_столбца 1 соответствует первому столбцу интервала и так далее. Ссылка, возвращаемая функцией ИНДЕКС, это ссылка на пересечении номер_строки и номер_столбца.

Если установить номер_строки или номер_столбца равным 0 (нулю), то функция ИНДЕКС вернет ссылку на целую строку или столбец, соответственно.

Замечания

  • Номер_строки, номер_столбца, и номер_области должны указывать на ячейку внутри аргумента ссылка; в противном случае функция ИНДЕКС возвращает значение ошибки #ССЫЛ!. Если номер_строки и номер_столбца опущены, то функция ИНДЕКС возвращает область в аргументе ссылка, заданную аргументом номер_области.

  • Результатом функции ИНДЕКС является ссылка, и она интерпретируется в качестве таковой другими функциями. В зависимости от формулы, возвращаемое функцией ИНДЕКС значение может быть использована как ссылка или как значение. Например, формула ЯЧЕЙКА("width";ИНДЕКС(A1:B2;1;2)) эквивалентна ЯЧЕЙКА("width";B1). Функция ЯЧЕЙКА использует значение, возвращаемое функцией ИНДЕКС, как ссылку. С другой стороны, такая формула, как 2*ИНДЕКС(A1:B2;1;2), переводит значение, возвращаемое функцией ИНДЕКС, в число, содержащееся в ячейке B1.

Примеры

На следующем рабочем листе интервал A2:C6 назван "Фрукты", интервал A8:C11 назван "Орехи", а интервал A1:C11 назван "Склад".

ИНДЕКС(Фрукты;2;3) равняется ссылке на ячейку C3, содержащую 38

ИНДЕКС((A1:C6;A8:C11);2;2;2) равняется ссылку на ячейку B9, содержащую 3,55 руб.

СУММ(ИНДЕКС(Склад;0;3;1)) равняется СУММ(C1:C11) равняется 216

СУММ(B2:ИНДЕКС(Фрукты;5;2)) равняется СУММ(B2:B6) равняется 2,42


ИНДЕКС

См. также

Возвращает значение элемента таблицы или массива, заданного номером строки и номером столбца.

Функция ИНДЕКС имеет две синтаксические формы: ссылка и массив. Ссылочная форма всегда возвращает ссылку; форма массива всегда возвращает значение или массив значений. Если первый аргумент функции ИНДЕКС является массивом констант, то лучше использовать форму массива.

Синтаксис 1

Форма массива.

ИНДЕКС(массив;номер_строки;номер_столбца)

Массив — это диапазон ячеек или массив констант. Для получения дополнительных сведений о значениях массива констант нажмите кнопку [image] .

Номер_строки — это номер строки в массиве, из которой нужно возвращать значение. Если номер_строки опущен, то аргумент номер_столбца нужно задавать обязательно.

Номер_столбца — это номер столбца в массиве, из которого нужно возвращать значение. Если номер_столбца опущен, то аргумент номер_строки нужно задавать обязательно.

  • Если используются оба аргумента номер_строки и номер_столбца, то функция ИНДЕКС возвращает значение, находящееся в ячейке на пересечении указанных строки и столбца.

  • Если массив содержит только одну строку или один столбец, то соответствующий аргумент номер_строки или номер_столбца не является обязательным.

  • Если массив занимает больше, чем одну строку и больше, чем один столбец, а задан только один аргумент номер_строки или номер_столбца, то функция ИНДЕКС возвращает массив из целой строки или целого столбца аргумента массив.

  • Если задать номер_строки или номер_столбца равным 0 (нулю), то функция ИНДЕКС вернет массив значений для целого столбца или целой строки, соответственно. Для того, чтобы использовать значения, возвращаемые как массив, функцию ИНДЕКС нужно ввести как формулу массива в горизонтальный диапазон ячеек. Для ввода формулы массива нажмите клавиши CTRL+SHIFT+ENTER в Microsoft Excel для Windows или COMMAND +RETURN в Microsoft Excel для Макинтош.

Замечания

Номер_строки и номер_столбца должны указывать на ячейку внутри аргумента массив; в противном случае функция ИНДЕКС возвращает значение ошибки #ССЫЛ!.

Примеры

ИНДЕКС({1;2:3;4};2;2) равняется 4

Если ввести как формулу массива, то:

ИНДЕКС({1;2:3;4};0;2) равняется {2:4}

Если в ячейках B5:B6 содержится текст "Яблоки" и "Бананы", а в ячейках C5:C6 — соответственно "Лимоны" и "Груши", то:

ИНДЕКС(B5:C6,2,2) равняется "Груши"

ИНДЕКС(B5:C6,2,1) равняется "Бананы"


ПРОСМОТР

См. также

Функция ПРОСМОТР имеет две синтаксические формы: вектор и массив.

Вектор - это диапазон, который содержит только одну строку или один столбец. Векторная форма функции ПРОСМОТР просматривает диапазон, в который входят значения только одной строки или одного столбца (так называемый вектор) в поисках определенного значения и возвращает значение из другого столбца или строки. Эта форма функции ПРОСМОТР используется, когда требуется указать интервал, в котором находятся искомые значения. Другая форма функции ПРОСМОТР автоматически использует для этой цели первую строку или первый столбец.

Синтаксис 1

Векторная форма

ПРОСМОТР(искомое_значение;просматриваемый_вектор;вектор_результатов)

Искомое_значение - это значение, которое ПРОСМОТР ищет в первом векторе. Искомое_значение может быть числом, текстом, логическим значением, именем или ссылкой, ссылающимися на значение.

Просматриваемый_вектор - это интервал, содержащий только одну строку или один столбец. Значения в аргументе просматриваемый_вектор могут быть текстами, числами или логическими значениями.

Важно! Значения в аргументе просматриваемый_вектор должны быть расположены в порядке возрастания: ..., -2, -1, 0, 1, 2, ..., A-Z, ЛОЖЬ, ИСТИНА; в противном случае функция ПРОСМОТР может вернуть неверный результат. Тексты в нижнем и верхнем регистре считаются эквивалентными.

Вектор_результатов - это интервал, содержащий только одну строку или один столбец. Он должен быть того же размера, что и просматриваемый_вектор.

  • Если ПРОСМОТР не может найти искомое_значение, то подходящим считается наибольшее значение в аргументе просматриваемый_вектор, которое меньше, чем искомое_значение.

  • Если искомое_значение меньше, чем наименьшее значение в аргументе просматриваемый_вектор, то функция ПРОСМОТР возвращает значение ошибки #Н/Д.

Примеры

В предшествующем рабочем листе:

ПРОСМОТР(4,91;A2:A7;B2:B7) равняется "оранжевый"

ПРОСМОТР(5,00;A2:A7;B2:B7) равняется "оранжевый"

ПРОСМОТР(7,66;A2:A7;B2:B7) равняется "фиолетовый"

ПРОСМОТР(7,66E-14;A2:A7;B2:B7) равняется #Н/Д, поскольку 7,66E-14 меньше, чем наименьшее значение в аргументе просматриваемый_вектор A2:A7


ПРОСМОТР

См. также

Функция ПРОСМОТР имеет две синтаксические формы: вектор и массив.

Форма массива функции ПРОСМОТР просматривает первую строку или первый столбец массива, находит указанное значение и возвращает значение из соответствующей позиции последней строки или последнего столбца масива. Эта форма функции ПРОСМОТР используется, когда сравниваемые значения находятся в первой строке или в первом столбце. Если требуется указать положение столбца или строки, следует использовать другую форму функции ПРОСМОТР.

Совет. Вообще говоря, лучше использовать функции ГПР или ВПР вместо функции ПРОСМОТР, используемой в форме массива. Эта форма функции ПРОСМОТР предназначена для совместимости с другими системами электронных таблиц.

Синтаксис 2

Форма массива.

ПРОСМОТР(искомое_значение;массив)

Искомое_значение - это значение, которое ПРОСМОТР ищет в массиве. Искомое_значение может быть числом, текстом, логическим значением, именем или ссылкой, ссылающимися на значение.

  • Если ПРОСМОТР не может найти искомое_значение, то подходящим считается наибольшее значение в аргументе массив, которое меньше чем искомое_значение.

  • Если искомое_значение меньше, чем наименьшее значение в первой строке или первом столбце (в зависимости от размерности массива), то функция ПРОСМОТР возвращает значение ошибки #Н/Д.

Массив - это интервал ячеек содержащих текст, числа или логические значения, которые нужно сравнивать с искомым значением.

Форма массива функции ПРОСМОТР очень похожа на функции ГПР и ВПР. Различие заключается в том, что функция ГПР ищет искомое_значение в первой строке, функция ВПР ищет в первом столбце, а функция ПРОСМОТР ищет в соответствии с размерностями массива.

  • Если ширина массива больше его высоты (то есть имеет больше столбцов чем строк), то функция ПРОСМОТР ищет искомое_значение в первой строке.

  • Если массив больше в высоту, чем в ширину (то есть имеет больше строк, чем столбцов), то функция ПРОСМОТР ищет в первом столбце.

  • Используя функции ГПР и ВПР можно указывать индекс по направлению вниз и вправо, а функция ПРОСМОТР всегда выбирает последнюю ячейку в строке или столбце.

Важно! Значения в аргументе просматриваемый_вектор должны быть расположены в порядке возрастания: ..., -2, -1, 0, 1, 2, ..., A-Z, ЛОЖЬ, ИСТИНА; в противном случае функция ПРОСМОТР может вернуть неверный результат. Тексты в нижнем и верхнем регистре считаются эквивалентными.

Примеры

ПРОСМОТР("В";{"а";"б";"в";"г":1;2;3;4}) равняется 3

ПРОСМОТР("бак";{"а";1:"б";2:"в";3}) равняется 2


 (Untitled)

Что делает сортировка Когда список сортируется, Microsoft Excel переставляет строки в соответствии с содержимым выбранного столбца — столбца «Сортировать по».

Сортировка по возрастанию Чтобы упорядочить список в алфавитном порядке по данным одного столбца, можно задать порядок сортировки по возрастанию (цифры от 0 до 9, пробелы, знаки препинания, буквы от А до Я). В приведенном ниже примере сортировка списка по возрастанию по столбцу «Продавец» приводит фамилии продавцов в алфавитный порядок.

Список до сортировки по возрастанию Список после сортировки по возрастанию

Дополнительные сведения

Сортировка строк по возрастанию данных в одном столбце


(Untitled)

Можно также выполнить сортировку на основе содержимого строк, чтобы изменился порядок столбцов, а не строк. В приведенном ниже примере список сортируется по первой строке для упорядочения столбцов по их надписям в алфавитном порядке.

Список, отсортированный по строкам для упорядочения подписей столбцов.

Сортировка по строкам изменяет порядок столбцов.

Дополнительные сведения

Сортировка столбцов по содержимому строк


 (Untitled)

По умолчанию Microsoft Excel сортирует списки по возрастанию в алфавитно-цифровом порядке. Если необходимо сортировать месяцы и дни недели в календарном порядке, а не в алфавитном, используйте пользовательский порядок сортировки.

В следующем примере месяцы расположены в календарном порядке.

Список отсортирован по месяцам в календарном порядке

Для упорядочения месяцев в календарном порядке используйте пользовательский порядок сортировки.

Такой порядок сортировки также используется, если требуется отсортировать список в другом, особом порядке. Например, если в одном из столбцов списка содержатся значения "Низкий", "Средний" или "Высокий", можно создать такой порядок сортировки, что строки, содержащие "Низкий", будут первыми, "Средний" — следующими и "Высокий" — последними.

Дополнительные сведения

Сортировка месяцев, дней недели или списков, которые требуется отсортировать в порядке, отличном от алфавитного

Порядок сортировки, используемый по умолчанию


(Untitled)

Для сортировки списка в обратном порядке используйте сортировку по убыванию(от Я до А, от 9 до 0). Например, чтобы сортировать список продаж от наибольшей к наименьшей, необходимо сортировать столбец «Продажи» по убыванию.

Дополнительные сведения

Сортировка строк по убыванию данных в одном столбце


(Untitled)

Можно сортировать данные по содержимому двух и более столбцов. В следующем примере список сначала сортируется по региону, затем строки для каждого региона сортируются по имени продавца в алфавитном порядке.

Список сначала сортируется по содержимому одного столбца, затем по содержимому другого

Дополнительные сведения

Сортировка строк по содержимому двух или более столбцов


Использование свойств файлов для их поиска

Задание свойств для книги или файла. Свойствами называются сведения, которые могут быть использованы при поиске файлов. Статистические сведения, такие как размер файла и дата его создания и последней модификации, создаются автоматически. Другие стандартные свойства, например имя автора, описательное имя и ключевые слова, описывающие основные темы, могут быть заданы. Инструкции по установке свойств файла текущей книги и установке свойств любого файла Microsoft Excel или Microsoft Office.

Создание пользовательских свойств файла. Для записи специфической информации, которая не создается автоматически в Excel, можно создать пользовательские свойства файла для текущей книги.

Создание пользовательских свойств, связанных с содержимым текущей книги. Можно создать пользовательское свойство, ссылающееся на информацию, хранящуюся в файле, например поименованные ячейки. Например, можно создать свойство файла, связанное с ячейкой, имеющей имя «Итоги» во всех файлах, содержащих сведения по бухгалтерскому учету, а затем использовать это свойство для поиска файлов, в которых итог превышает заданное значение. Инструкции по созданию пользовательских свойств, связанных с содержимым текущей книги.

Установка свойств при сохранении книги. Для напоминания о задании свойств Microsoft Excel может автоматически выводить диалоговое окно Свойства при первом сохранении книги.


(Untitled)

Для большей наглядности на страницу или в диаграмму можно добавить рисунки. Например, можно отобразить логотип, создать блок-схему или нарисовать диаграмму. Можно сделать страницу интерактивной, используя графические объекты как гиперссылки или путем присвоения кнопкам макросов.

Типы рисунков

В Microsoft Excel могут быть использованы два типа рисунков: точечные и метафайлы.

Точечный тип рисунка. Рисунок точечного типа создается из точек или пикселей. Например, фотографии — рисунки точечного типа. При выделении точечного рисунка возникает панель инструментов Рисунок. С помощью этих инструментов можно обрезать рисунок, добавить к нему специальные эффекты, а также изменить его яркость, контрастность и цвет. В отличие от метафайла, точечные рисунки не могут быть разгруппированы.

Метафайл. Метафайлы обычно выглядят как картинка из отдельных линий и кривых, объединенных в группы. Большое число картинок и рисунков существует в формате метафайла. Можно конвертировать метафайлы в отдельные графические объекты и править их с помощью графических инструментов Excel. Например, можно вставить рисунок человека, разгруппировать рисунок, сменить цвет одежды и далее вставить измененный рисунок в другой. Встроенные автофигуры тоже являются метафайлами. При выделении графических объектов в формате метафайла в меню Рисунок становится доступной команда Разгруппировать.


Наложение ограничений на поиск решения

  1. В меню Сервис выберите команду Поиск решения.

  2. Нажмите кнопку Добавить.

  3. В поле Ссылка на ячейку введите адрес или имя ячейки, на значение которой накладываются ограничения.

  4. Выберите из раскрывающегося списка условный оператор ( <=, =, >=, цел или двоич ), который должен располагаться между ссылкой и ограничением. Если выбрано цел, в поле Ограничение появится "целое". Если выбрано двоич, в поле Ограничение появится "двоичное".

  5. В поле Ограничение введите число, формулу или имя ячейки.

  6. Чтобы принять ограничение и приступить к набору нового, нажмите кнопку Добавить.

    Чтобы принять ограничение и вернуться в диалоговое окно Поиск Решения, нажмите кнопку OK.

Примечания

  • Условные операторы типа цел и двоич можно применять только при наложении ограничений на изменяемые ячейки.

Флажок Линейная модель в диалоговом окне Параметры поиска решения позволяет задать любое количество ограничений. При решении нелинейных задач на значения изменяемых ячеек можно наложить более 100 ограничений, в дополнение к целочисленным ограничениям на переменные. См. сведения о параметрах диалогового окна Добавить ограничения.


 Добавление или удаление поля отчета сводной таблицы или сводной диаграммы

Добавление или удаление поля отчета сводной таблицы или сводной диаграммы

  1. Щелкните отчет сводной таблицы или сводной диаграммы (для появления панели инструментов Сводные таблицы) и (для отчетов сводных таблиц) структуры областей для каждого типа полей.

  2. Убедитесь, что весь список полей отображен на панели инструментов Сводные таблицы.

    Если кнопки поля не видны на панели инструментов, убедитесь, что панель разблокирована и кнопка Отобразить поля [image] находится в нажатом состоянии.

  3. Выполните одно из следующих действий:

    Чтобы добавить поле, перетащите его кнопку в область отчета сводной таблицы или сводной диаграммы, соответствующую типу создаваемого поля. Нажмите кнопку Другие поля [image] или [image] для просмотра всех доступных полей.

    В отчете сводной таблице или сводной диаграммы, основанном на базе данных OLAP, поля измерения могут использоваться в сводной таблице только как поля строк, столбцов или страниц; а в отчете сводных диаграмм как поля рядов, категорий или страниц. Поля размерности поля имеют значок Поле размерности в начале строки. Поля в конце списка имеют значок Поля данных в начале строки и могут использоваться только как поля данных в сводной таблице или как значения оси в сводной диаграмме.

    Чтобы удалить поле, перетащите его кнопку со схемы отчета сводной таблицы или области диаграммы в отчете сводных диаграмм. При удалении поля все связанные с ним данные удаляются из отчета сводной таблицы. Для полей измерений OLAP все уровни и все элементы удаляются, не затрагивая исходные данные.

Примечания

  • Данные отображаются с задержкой. Если данные отображаются с задержкой при перетаскивании поля на другое место, используйте мастер сводных таблиц и сводных диаграмм для добавления полей.

  • Поля размерности OLAP управляются как единое целое. При добавлении поля измерения в отчет сводной таблицы или сводной диаграммы все уровни и все элементы добавляются, при этом отображается верхний уровень. Далее можно отображать другие уровни и скрывать и отображать элементы.

  • Некоторые поля не могут быть перемещены. Нельзя переместить определенные поля.

  • Влияние на связанные отчеты сводных диаграмм. При добавлении или удалении поля из отчета сводной таблицы, который связан с отчетом сводной диаграммы, некоторые параметры форматирования в отчете сводной диаграммы могут быть потеряны.


 Добавление исходной области в итоговую таблицу

Добавление исходной области в итоговую таблицу

Если при консолидации не создавались связи с исходными областями, можно добавить новые исходные области и пересчитать данные в области назначения. Если были созданы связи с исходными областями, удалите итоговую таблицу, а затем удалите структуру, если она существует на листе. Для получения сведений о том, как удалить структуру, нажмите [image] .

  1. Укажите верхнюю левую ячейку существующей итоговой таблицы.

  2. В меню Данные выберите команду Консолидация.

    Демонстрация

  3. Укажите поле Ссылка.

  4. Введите новую исходную область в итоговую таблицу.

    Если лист, содержащий новую исходную область, является текущим, выделите на нем исходную область. Чтобы получить более подробные сведения об исходных областях, нажмите [image] .

  5. Нажмите кнопку Добавить.

  6. Чтобы пересчитать итоговую таблицу, нажмите кнопку OK.

    Чтобы сохранить новый набор исходных областей без пересчета итоговой таблицы, нажмите кнопку Закрыть.


 Добавление данных к диаграмме путем копирования и вставки

Добавление данных к диаграмме путем копирования и вставки

  1. Выберите ячейки, содержащие данные, которые нужно добавить к диаграмме.

    Чтобы название столбца или строки для новых данных отобразилось на диаграмме, следует выбрать также ячейки с названиями.

  2. Нажмите кнопку Копировать [image] .

  3. Выберите нужную диаграмму.

  4. Чтобы автоматически вставить данные в диаграмму, выберите команду Вставить [image] .

    Чтобы точно задать способ представления данных на диаграмме, в меню Правка выберите команду Специальная вставка, затем установите необходимые параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечание. Описанное выше не относится к отчетам сводных диаграмм. Ознакомьтесь с разделом Использование нескольких источников данных в отчетах сводных диаграмм.


 Добавление данных к внедренной диаграмме перетаскиванием

Добавление данных к внедренной диаграмме перетаскиванием

  1. Выберите ячейки, содержащие данные, которые необходимо добавить к диаграмме. Эти ячейки должны быть смежными ячейками на листе Excel.

    Чтобы название столбца или строки для новых данных отобразилось на диаграмме, следует выбрать также ячейки с названиями.

  2. Поместите указатель на рамку выделенного интервала.

    Указатель находится на рамке выделенного интервала

  3. Перетащите выделенный диапазон в изменяемую внедренную диаграмму.

    Если при добавлении данных Microsoft Excel потребуются дополнительные параметры, на экране отобразится диалоговое окно Специальная вставка.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечания

  • Если выделенный диапазон переместить не удается, убедитесь, что установлен флажок Разрешить перетаскивание ячеек. Чтобы найти этот флажок, в меню Сервис выберите команду Параметры, затем вкладку Правка.

  • Описанное выше не относится к отчетам сводных диаграмм. См. сведения об использование различных исходных данных в отчетах сводных диаграмм.


 Добавление данных к диаграмме изменением выделенного цветом диапазона исходных данных

Добавление данных к диаграмме изменением выделенного цветом диапазона исходных данных

Внедренная диаграмма должна быть создана из смежных диапазонов и быть на одной странице с используемыми данными.

  1. В ячейки, соседние с существующими данными, введите подписи значений и данные.

  2. Выделите область диаграммы, щелкнув пустую область между границами диаграммы и областью построения.

  3. Для добавления новых категорий и новых рядов данных на диаграмму перетащите синий маркер выделения, чтобы включить новые данные и их подписи в выделенный прямоугольник.

    Для добавления только новых рядов данных на страницу, перетащите зеленый маркер выделения, чтобы включить новые данные и их подписи в выделенный прямоугольник.

    Для добавления новых категорий и точек данных на странице перетащите сиреневый маркер выделения, чтобы включить новые данные и их подписи в выделенный прямоугольник.

Совет. Для изменения диапазона данных, отображенных на диаграмме, перетащите границу выделенного цветом диапазона.

Примечание. Описанное выше не относится к отчетам сводных диаграмм. См. сведения об использовании различных исходных данных в отчетах сводных диаграмм.


 Добавление номеров строк к диапазону внешних данных

Добавление номеров строк к диапазону внешних данных

Эта процедура неприменима к данным, извлеченным из текстового файла (*.txt) или из Web-запроса (*.iqy).

  1. Если диалоговое окно Свойства внешнего диапазона не отображено, щелкните ячейку в диапазоне внешних данных, а затем выберите Свойства диапазона данных [image] на панели инструментов Внешние данные.

  2. Убедитесь, что в меню Формат и разметка данных установлен флажок Включить номера строк, и нажмите кнопку OK.

  3. Чтобы отобразить номера строк и обновить диапазон внешних данных, выберите Обновить данные [image] на панели инструментов Внешние данные.


 Добавление кнопок голосования в сообщение электронной почты

Добавление кнопок голосования в сообщение электронной почты

Данная процедура применима, если и отправитель и все адресаты используют Microsoft Exchange Server. Также нужно установить Microsoft Outlook в режиме “корпоративная или для рабочих групп”. Информация об установке Microsoft Outlook.

Требования, которым должна удовлетворять система для отправки документов

  1. Откройте в Microsoft Excel лист, который следует отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Параметры.

  5. В группе Параметры голосования и отслеживания установите флажок Кнопки голосования и выберите имена кнопок.

    Для создания собственных названий кнопок для голосования удалите имена, установленные по умолчанию, и введите новые. Разделяйте текст точками с запятыми, например "маленький;большой;очень большой".

  6. Для отслеживания результатов голосования установите флажок После отправки сохранять в и введите имя папки, в которой будет храниться сообщение.

Примечание. Дополнительную информацию о просмотре результатов голосования можно получить из справки по Outlook.


Изменение ширины столбца и высоты строки

Microsoft Excel позволяет изменять ширину столбцов и высоту строк. Он также позволяет установить ширину столбцов для листа по умолчанию. При определении ширины столбца по умолчанию устанавливается одинаковая ширина всех столбцов кроме тех, которые были изменены ранее.

Предполагаемые действия

Изменение ширины столбца

Изменение высоты строки

Установка ширины столбца по умолчанию


 Расположение полей страниц сводной таблицы в строках или столбцах

Расположение полей страниц сводной таблицы в строках или столбцах

  1. Щелкните отчет сводной таблицы для вызова панели инструментов Сводные таблицы.

  2. На панели инструментов Сводные таблицы, выберите меню Сводная таблица и затем — команду Параметры таблицы.

  3. В поле Макет страницы выберите порядок появления полей страницы.

  4. Введите в поле со счетчиком Полей в строке или Полей в столбце число полей страниц, отображаемых в строке или столбце.

Примечание. Поля страниц сводной диаграммы всегда появляются вверху области диаграммы, вне зависимости от установки Макет страницы.


 Назначение кнопки или графического объекта для запуска макроса

Назначение кнопки или графического объекта для запуска макроса

Для запуска макроса можно назначить кнопку, графический объект или графический элемент управления на листе. Макрос запускается автоматически при щелчке кнопки или графического объекта, а также изменении элемента управления. Для получения дополнительных сведений о создании кнопки или графического элемента управления нажмите кнопку [image] . Для получения дополнительных сведений о создании графических объектов нажмите кнопку [image] .

Макрос можно запустить с помощью элемента управления ActiveX. См. сведения о создании элемента управления ActiveX.

  1. Щелкните кнопку или графический элемент управления, чтобы появились маркеры выделения.

  2. Щелкните правой кнопкой мыши нужный маркер выделения и выберите команду Назначить макрос в контекстном меню.

  3. Чтобы назначить ранее записанному макросу выбранный графический объект, введите название макроса в поле Имя макроса, затем нажмите кнопку OK.

    Чтобы создать новый макрос и назначить ему кнопку или графический объект, нажмите кнопку Запись.

    Чтобы написать новый макрос в редакторе Visual Basic, нажмите кнопку Создать. Чтобы отредактировать существующий макрос, выберите его имя в списке Имя макроса и нажмите кнопку Правка. Инструкции по просмотру и редактированию макросов.

Примечание. При назначении макроса объекту или кнопке, которая уже используется как гиперссылка, информация о гиперссылке удаляется. При нажатии кнопки или выделении объекта будет выполняться макрос.


 Назначение клавиши для запуска макроса

Назначение клавиши для запуска макроса

  1. В меню Сервис выберите пункт Макрос, а затем выполните команду Макросы.

    Демонстрация

  2. В поле Имя макроса введите имя того макроса, которому нужно присвоить сочетание клавиш, запускающее макрос.

  3. Нажмите кнопку Параметры.

  4. Чтобы выполнить макрос с клавиатуры с помощью сочетания клавиш, введите соответствующую букву в поле Сочетание клавиш. Для строчных букв используется сочетание CTRL+ буква, а для заглавных — CTRL+SHIFT+ буква, где буква — любая клавиша на клавиатуре. Заданное сочетание клавиш будет заменять любое установленное по умолчанию в Microsoft Excel, пока книга, содержащая данный макрос, открыта.

    Чтобы создать краткое описание макроса, введите необходимый текст в поле Описание.

  5. Нажмите кнопку OK.

  6. Нажмите кнопку Отменить.


 Назначение области графического объекта для запуска макроса

Назначение области графического объекта для запуска макроса

  1. Создайте графический объект.

    Инструкции

  2. Нарисуйте другой графический объект поверх текущего объекта в назначаемой области.

  3. Выбрав этот объект, щелкните правой кнопкой мыши маркер выделения кнопки или графического объекта.

  4. Выберите в контекстном меню команду Назначить макрос.

  5. Чтобы назначить ранее записанному макросу выбранный графический объект, введите название макроса в поле Имя макроса, затем нажмите кнопку OK.

    Чтобы создать новый макрос и назначить ему выбранный графический объект, нажмите кнопку Запись. После завершения записи макроса нажмите кнопку Остановка записи [image] на панели инструментов Остановить запись.

    Чтобы написать новый макрос в редакторе Visual Basic, нажмите кнопку Создать. Чтобы отредактировать существующий макрос, выберите его имя в списке Имя макроса и нажмите кнопку Правка. Инструкции по просмотру и редактированию макросов.

  6. В меню Формат выберите команду Автофигура, а затем вкладку — Цвет и линии.

  7. В группе Заливка выберите параметр Нет заливки в поле Цвет. В группе Линия выберите параметр Нет линий в поле Цвет.

  8. Повторите шаги с 2 по 7 для каждой назначаемой области.


 Назначение категории сообщения

Назначение категории сообщения

Требования, которым должна удовлетворять система для отправки документов

  1. Откройте в Microsoft Excel лист, который следует отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Выберите команду Параметры и затем нажмите кнопку Категории.

  5. В списке Доступные категории установите флажок нужной категории.

  6. Для создания новой категории нажмите кнопку Главный список категорий.

  7. В списке Новая категория впишите название новой категории и нажмите кнопку Добавить.

  8. Нажмите кнопку OK.

  9. Для создания других категорий повторите шаг 7.

  10. Щелкните Добавить, а затем OK.

Примечания

  • Назначить категорию сообщения можно нажатием кнопки Параметры и введением нового имени категории в списке Категории. После выполнения этой процедуры убедитесь, что написали имя категории правильно, в противном случае категория не будет присвоена сообщению в «Главном списке категорий». Категории, не включенные в этот список, не могут назначаться другим сообщениям.

  • См. дополнительные сведения о назначении категории сообщению.


Зависимости: прослеживание связей между формулами и ячейками (обведение недопустимых данных)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Зависимости: прослеживание связей между формулами и ячейками (примечания)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Зависимости: прослеживание связей между формулами и ячейками (поиск диапазона)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Зависимости: прослеживание связей между формулами и ячейками (зависимые ячейки)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Зависимости: прослеживание связей между формулами и ячейками (источник ошибки)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Зависимости: прослеживание связей между формулами и ячейками (влияющие ячейки)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Автоматизация решения задач с помощью элемента управления ActiveX

Автоматизация решения задач с помощью элемента управления ActiveX

Выполнение любой задачи может быть автоматизировано с помощью элемента управления ActiveX и макроса, присвоенного элементу управления. Дополнительные сведения о написании макросов приведены в справке по Visual Basic.

  1. Чтобы создать макрос для элемента управления ActiveX на листе или форме, убедитесь, что на экране присутствует панель инструментов Элементы управления. Чтобы вывести панель инструментов Элементы управления на экран, в меню Вид выберите команду Элементы управления и в выведенном списке установите флажок Элементы управления.

  2. Нажмите кнопку Режим конструктора [image] .

  3. Чтобы создать или изменить присвоенный элементу макрос, выберите правой кнопкой мыши данный элемент управления, а затем выберите команду Исходный текст в контекстном меню.

  4. В редакторе Visual Basic создайте макрос.

  5. Когда макрос будет создан, выберите команду Close and Return to Microsoft Excel в меню File.

  6. После завершения создания элемента управления нажмите кнопку Выход из режима конструктора [image] .


 Изменение направление письма в абзаце при помощи сочетания клавиш

Изменение направление письма в абзаце при помощи сочетания клавиш

  • Выполните одно из следующих действий:

    Для включения направления письма в абзаце справа налево, одновременно нажмите клавиши CTRL+правый SHIFT.

    Для включения направления письма слева направо в абзаце нажмите клавиши CTRL+левый SHIFT.

Примечание. Нельзя использовать CTRL+SHIFT для изменения направления чтения и выравнивания, если элемент управления содержит ключевые знаки, но когда элемент управления пустой или содержит только нейтральные знаки, использование CTRL+SHIFT возможно.


 Замена части формулы на возвращаемое значение

Замена части формулы на возвращаемое значение

  1. Укажите ячейку, содержащую формулу.

  2. В строке формул выделите часть, которую необходимо заменить возвращаемым значением. При выделении части формулы не забудьте включить все операнды. Например, если выделяется функция, то необходимо выделить имя функции, открывающие скобки, аргументы и закрывающие скобки.

  3. Для вычисления значения выделенной части нажмите клавишу F9.

  4. Для замены выделенной части формулы возвращаемым значением нажмите клавишу ENTER.

    Если формула является формулой массива, нажмите комбинацию клавиш CTRL+SHIFT+ENTER.

    Чтобы оставить формулу без изменений, нажмите клавишу ESC.


 Обработка формул в Microsoft Excel по правилам Lotus 1-2-3

Обработка формул в Microsoft Excel по правилам Lotus 1-2-3

  1. В меню Сервис выберите пункт Параметры и откройте вкладку Переход.

  2. Для вычисления формул по правилам Lotus 1-2-3 установите флажок Производить вычисления по правилам Lotus 1-2-3.

    Для вычисления формул по правилам Microsoft Excel снимите флажок Производить вычисления по правилам Lotus 1-2-3.

    Более подробные сведения о различиях в вычислении формул в Microsoft Excel и Lotus 1-2-3 можно получить нажав кнопку [image] .

    Внимание! Не стремитесь изменять значение параметра Производить вычисления по правилам Lotus 1-2-3, так как это может привести к изменению значений ячеек листа.


Изменение и удаление ограничения на поиск решения

  1. В меню Сервис выберите команду Поиск решения.

  2. В списке Ограничения укажите строку, которую следует изменить или удалить.

  3. Чтобы удалить ограничение, нажмите кнопку Удалить.

    Чтобы изменить ограничение, нажмите кнопку Изменить, а затем внесите нужные изменения.

    Сведения об элементах управления диалогового окна Изменить ограничение.


 Запуск запроса в фоновом режиме и в режиме ожидания

Запуск запроса в фоновом режиме и в режиме ожидания

При запуске запроса в режиме ожидания нельзя использовать Microsoft Excel до завершения запроса.

  1. Если диалоговое окно Свойства внешнего диапазона не отображено, щелкните одну из ячеек диапазона внешних данных, а затем нажмите кнопку Свойства диапазона данных [image] на панели инструментов Внешние данные.

  2. Выполните одно из следующих действий:

    Чтобы выполнять запрос в фоновом режиме и получить возможность продолжать работу в Microsoft Excel, установите флажок Фоновое обновление.

    Чтобы переходить после запуска запроса в состояние ожидания окончания выполнения запроса, снимите флажок Фоновое обновление.

Примечания

  • Прерывание запроса Если флажок Фоновое обновление снят, запрос прерывается нажатием клавиши ESC.

  • Прерывание фонового обновления Чтобы прервать запрос, выполняемый в фоновом режиме, дважды щелкните значок фонового обновления Фоновое обновление в строке состояния и в появившемся диалоговом окне Состояние обновления внешних данных выберите Остановить обновление.

  • Запись макроса Во время записи макроса, содержащего запрос, Excel не может запустить запрос в фоновом режиме. Чтобы получить возможность запускать записанный макрос в фоновом режиме, вызовите редактор Visual Basic и замените выражение "BackgroundQuery := False" на "BackgroundQuery := True". Чтобы получить подробные сведения о редактировании макросов, см. справку по Visual Basic.


Смена значка кнопки панели инструментов или команды меню

  1. Отобразите панель инструментов с кнопкой или командой, которую требуется изменить.

  2. В меню Сервис выберите Настройка.

    Диалоговое окно Настройка должно оставаться открытым. Если оно будет мешать, переместите его в другую часть экрана.

  3. Выполните одно из следующих действий:

    На панели инструментов щелкните правой кнопкой мыши кнопку, которую необходимо изменить, далее выберите Изменить вид кнопки в контекстном меню и выберите требуемое изображение.

    Чтобы изменить команду меню, щелкните ее правой кнопкой мыши, а затем выберите команду Выбрать значок для кнопки в контекстном меню.


 Изменение форматирования символов и ячеек сводной таблицы

Изменение форматирования символов и ячеек сводной таблицы

  1. Выделите форматируемую часть отчета сводной таблицы.

    Инструкции.

  2. Воспользуйтесь кнопками на панели инструментов Форматирование и командами меню Формат, чтобы изменить форматирование.

Примечания

  • Сохранение форматирования Можно использовать выделение сводных таблиц или обычное выделение при форматировании отчета сводной таблицы. Большинство параметров форматирования сохраняется при обновлении отчета или изменении макета, если флажок Сохранять форматирование установлен (чтобы найти его, выберите меню Сводная таблица на панели инструментов Сводные таблицы и далее выберите команду Параметры таблицы).

  • Условное форматирование и проверка вводимых значений отсутсвуют При попытке применения условного форматирования к ячейкам отчета сводной таблицы получаются непредсказуемые результаты и форматы не будут сохранены при изменении макета отчета. Нельзя проверять вводимые значения для ячеек в отчете сводной таблицы.

  • Границы ячеек не сохраняются При изменении макета или обновлении отчета сводной таблицы границы ячеек не сохраняются.

  • Отчеты сводных таблиц с полями страницы Для применения форматирования ко всем страницам в отчете сводной таблице, который содержит поля страниц, выберите элемент Все для каждого поля страницы и применяйте форматирование. Если поле страницы не содержит элемента Все, отображайте каждый элемент поля страницы отдельно и применяйте к нему форматирование.

  • Удаление всех параметров форматирования Для удаления всех параметров форматирования отчета сводной таблицы нажмите кнопку Сводная таблица на панели инструментов Сводные таблицы, выберите команду Параметры таблицы и сбросьте флажок Автоформат, нажмите OK, нажмите кнопку Формат отчета [image] , и выберите формат Нет. Для отмены форматирования отчета сводной таблицы при его обновлении нажмите кнопку Сводная таблица на панели Сводные таблицы , выберите команду Параметры таблицы и сбросьте флажок Сохранять форматирование.

  • Файлы из предыдущих версий Excel При форматировании отчета сводной таблицы, созданного в предыдущих версиях Microsoft Excel, убедитесь, что сохраняете книгу как файл Microsoft Excel 2000 и все возможности форматирования Excel 2000 будут сохранены. В меню Файл выберите Сохранить как и далее Рабочая книга Microsoft Excel (*.xls) из списка Тип файла.


 Изменение данных или полей, включенных в исходный диапазон, для отчета сводной таблицы или сводной диаграммы

Изменение данных или полей, включенных в исходный диапазон, для отчета сводной таблицы или сводной диаграммы

Применение этой процедуры возможно только для отчета сводной таблицы или сводной диаграммы, основанных на данных из листа Microsoft Excel. Для отчета сводной таблицы или сводной диаграммы, основанных на данных из внешнего источника, нажмите кнопку Обновить данные на панели инструментов Сводные таблицы, чтобы включить новые данные, удовлетворяющие критерию базового запроса, или измените запрос для извлечения дополнительных полей в исходной базе данных.

  1. Выделите отчет сводной таблицы. Для отчета сводной диаграммы щелкните связанный отчет сводной таблицы.

  2. На панели инструментов Сводные таблицы нажмите кнопку Мастер сводных таблиц [image] .

  3. На шаге 3 мастера нажмите кнопку Назад.

  4. На шаге 2 выберите новый диапазон исходных данных.

  5. Нажмите кнопку Готово.

    Если вновь определенный диапазон включает новые поля, то они возникают в списке полей на панели инструментов Сводные таблицы.

  6. Если необходимо использовать новые поля, добавьте их в отчет сводной таблицы или сводной диаграммы.

Примечания

  • Когда данные в исходном диапазоне изменяются и необходимо включить новые данные в отчет сводной таблицы или сводной диаграммы, нажмите кнопку Обновить данные [image] на панели инструментов Сводные таблицы.

  • При изменении исходных данных, использованных для отчета сводной диаграммы или отчета сводной таблицы, связанного с отчетом сводной диаграммы, некоторые параметры форматирования диаграммы могут быть утеряны.


 Изменение содержимого или установок куба, созданного с помощью Мастера куба OLAP

Изменение содержимого или установок куба, созданного с помощью Мастера куба OLAP

Используйте данную процедуру только для куба, созданного в Microsoft Query с использованием мастера создания куба. Если неизвестно, был ли создан изменяемый куб указанным способом или это — файл автономного куба, созданный в Microsoft Excel, проконсультируйтесь с тем, кто создавал файлы автономного куба, сводные таблицы, отчеты сводных диаграмм или файлы .oqy. Инструкции по изменению содержимого и установок файла автономного куба, созданного в Excel.

  1. Запустите Microsoft Query. Для этого можно или открыть сохраненный запрос, или создать новый, если нет сохраненных.

    Инструкции

  2. В Microsoft Query откройте файл .oqy и внесите необходимые изменения в мастере куба OLAP.

    Например, можно изменить итоговые функции для полей данных, внести изменения в организацию уровней и измерений, удалить ненужные уровни и измерения, сменить тип созданного куба.

Примечания

  • Создание куба по результатам выполнения запроса. Для получения полной информации обратитесь к справочной системе Microsoft Query или справке по мастеру куба OLAP.

  • После создания куба в Microsoft Query невозможно добавить в него поля из исходной реляционной базы данных. Однако можно создать новый куб из того же запроса, используя другие поля, если был сохранен файл запроса (.dqy) при его создании в Microsoft Query. За дополнительной информацией о сохранении и открытии файлов запроса обратитесь к справочной системе Microsoft Query.

  • При создании файла автономного куба мастер заменит этот файл на диске новым, содержащим сделанные изменения.


 Использование дополнительных вычислений для поля данных сводной таблицы или сводной диаграммы

Использование дополнительных вычислений для поля данных сводной таблицы или сводной диаграммы

  1. Выполните одно из следующих действий:

    В области данных отчета сводной таблицы выделите ячейку поля, для которого необходимо сделать дополнительные вычисления.

    В отчете сводной диаграммы выделите область данных, для которых нужно сделать дополнительные вычисления.

  2. На панели инструментов Сводные таблицы нажмите кнопку Параметры поля [image] .

  3. Нажмите кнопку Дополнительно.

  4. В списке Дополнительные вычисления выберите необходимые вычисления.

    Если список Поле доступен, выделите поле, данные которого будут использоваться в вычислениях. Выберите другое поле, отличное от поля, указанного на первом шаге.

    Если список Элемент доступен, выделите элемент поля, данные которого будут использоваться в вычислениях.

Примечание. Поле и элемент содержат данные, используемые в дополнительных вычислениях. См. сведения об использовании дополнительных вычислений в отчете сводной таблицы или отчете сводной диаграммы.


 Изменение числового формата в области данных отчета сводной таблицы

Изменение числового формата в области данных отчета сводной таблицы

  1. Выделите ячейку в области данных отчета сводной таблицы.

  2. На панели инструментов Сводные таблицы нажмите кнопку Параметры поля [image] .

  3. Нажмите кнопку Формат.

  4. В списке Числовые форматы выберите необходимый формат.

  5. После изменение формата нажмите кнопку OK.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечания

  • Изменение числового формата ячейки сводной таблицы приводит к изменению формата всех ячеек, принадлежащих одному и тому же полю данных. Если в сводной таблице содержится несколько полей в области данных, формат каждого поля изменяется отдельно.

  • При изменении числового формата в отчете сводной таблицы, который связан с отчетом сводной диаграммы, формат подписей оси значений на графике тоже изменится.


 Изменение порядка отображения рядов данных

Изменение порядка отображения рядов данных

  1. Выберите ряды данных в изменяемой диаграмме.

    Чтобы изменить порядок отображения рядов в поверхностной диаграмме, укажите ключ легенды.

  2. В меню Формат выберите команду Ряды данных или Ключ легенды, а затем — вкладку Порядок рядов.

  3. В списке Порядок рядов укажите ряд, порядок отображения которого следует изменить.

  4. Нажимайте кнопки Сместить вверх и Сместить вниз, чтобы установить желаемый порядок отображения ряда.


 Изменение области данных в итоговой таблице

Изменение области данных в итоговой таблице

Если при консолидации не создавались связи с исходными данными, можно изменить исходные области и пересчитать данные в области назначения. Если связи с исходными областями были созданы, удалите итоговую таблицу, а затем удалите структуру. Для получения сведений о том, как удалить структуру, нажмите [image] .

  1. Укажите верхнюю левую ячейку существующей итоговой таблицы.

  2. В меню Данные выберите команду Консолидация.

    Демонстрация

  3. В списке Список диапазонов укажите исходную область, которую следует изменить.

  4. Внесите изменения в выбранную область в поле Ссылка.

  5. Нажмите кнопку Добавить.

  6. Если старая ссылка не нужна, укажите ее в списке Список диапазонов, а затем нажмите кнопку Удалить.

  7. Чтобы пересчитать итоговую таблицу, нажмите кнопку OK.

    Чтобы сохранить новый набор исходных областей без пересчета итоговой таблицы, нажмите кнопку Закрыть.


 Изменение итоговой функции в поле данных сводной таблицы или сводной диаграммы

Изменение итоговой функции в поле данных сводной таблицы или сводной диаграммы

Можно использовать итоговую функцию только для отчетов, основанных на не-OLAP исходных данных. Для отчетов, основанных на данных OLAP, доступные итоговые функции зависят от того, как куб был определен на сервере. За подробной информацией об итоговых функциях, доступных для исходных данных, обратитесь к администратору базы данных OLAP.

  1. Выполните одно из следующих действий:

    В области данных отчета сводной таблицы выделите ячейку, для которой необходимо изменить итоговую функцию.

    В отчете сводной диаграммы выделите поле данных, для которого нужно изменить итоговую функцию.

  2. На панели инструментов Сводные таблицы нажмите кнопку Параметры поля [image] .

  3. Из списка Операция выберите итоговую функцию, которая будет использоваться для подведения итогов по полю.

См. сведения об итоговых функциях, доступных в отчетах сводных таблиц и сводных диаграмм, основанных на источниках данных, не являющихся базами данных OLAP.


 Изменение итоговой функции, используемой в вычислениях промежуточных итогов сводной таблицы

Изменение итоговой функции, используемой в вычислениях промежуточных итогов сводной таблицы

Эта процедура недоступна для отчетов сводных таблиц и сводных диаграмм, основанных на исходных данных из базы данных OLAP.

  1. Дважды щелкните кнопку поля, в котором необходимо изменить итоговую функцию для промежуточных итогов.

  2. Выберите одну или несколько итоговых функций в группе Итоги. Для получения дополнительных сведений по итоговым функциям, используемых для вычисления промежуточных итогов, нажмите кнопку [image] .

Примечания

  • Чтобы добавить промежуточные итоги к внутреннему полю строки или столбца или отобразить несколько типов промежуточных итогов (например «cумма» и «cреднее») для выбранного поля сводной таблицы, установите переключатель в положение другие.

  • Итоговая функция не может быть изменена, если она подводит итог в полях с вычисляемыми элементами.


 Изменение макета сводной таблицы перетаскиванием полей или элементов

Изменение макета сводной таблицы перетаскиванием полей или элементов

  1. Щелкните отчет сводной таблицы. Области каждого типа полей будут обведены синей рамкой.

    Если рамка не видна, нажмите кнопку Отобразить поля [image] .

  2. Чтобы переместить поле и все связанные с ним элементы, перетащите кнопку поля на новое место.

    Чтобы поменять порядок расположения элементов поля, выделите подпись элемента, а затем поместите указатель на границу ячейки. Когда указатель примет вид стрелки, перетащите ячейку на новое место.

  3. Для создания поля страницы перетащите его в область полей страниц (выше верхней левой ячейки отчета сводной таблицы). Если поля строк или столбцов в отчете начинаются на первой строке и области полей страниц отсутствует, можно использовать мастер для создания поля страницы.

  4. Чтобы удалить поле строки, столбца или страницы, перетащите кнопку поля с отчета сводной таблицы.

  5. Для изменения порядка отображения полей данных щелкните поле правой кнопкой мыши и выберите Порядок в контекстном меню. Используйте команду Порядок для перемещения поля в необходимое место.

Примечания

  • Данные отображаются с задержкой Если данные отображаются с задержкой при перетаскивании поля на другое место,используйте мастер сводных таблиц и сводных диаграмм, чтобы изменить макет.

  • Поля размерности и данных OLAP В отчетах сводных таблиц, основанных на базах данных OLAP, поля размерности могут быть использованы в сводной таблице только как поля строк, столбцов или страниц. Эти поля имеют значок Поле размерности в начале строки в списке полей на панели инструментов Сводные таблицы. Поля, имеющие значок Поле данных в начале строки на панели инструментов, могут использоваться только как поля данных.

  • Поля измерений OLAP управляются как одно целое Когда поле размерности перемещается при изменении макета, все уровни и все элементы в измерении перемещаются вместе с ним.

  • Некоторые поля не могут быть перемещены. Нельзя переместить определенные поля.

  • Поля страниц, устанавливающие запрос для каждого элемента Если в поле страницы устанавливается запрос к внешним данным только при выборе элемента поля, перемещение поля страницы в другое место приводит к обращению к внешним данным для всех элементов поля одновременно. См. сведения о параметрах поля страницы.

  • Влияние на связанные отчеты сводных диаграмм При изменении макета отчета сводных таблиц, который связан с отчетом сводной диаграммы, макет отчета сводной диаграммы также изменяется. Например, при обмене полей строк и столбцов в отчете сводных таблиц меняются местами ряды и категории в отчете сводной диаграммы. При изменении в отчете сводной таблицы некоторые параметры форматирования в отчете сводной диаграммы могут быть утеряны.


 Изменение макета сводной таблицы или сводной диаграммы с помощью мастера

Изменение макета сводной таблицы или сводной диаграммы с помощью мастера

Выполняйте эту процедуру выполняется, если данные отображаются с задержкой при переносе поля прямо на лист или при добавлении поля страницы в пустой отчет сводной таблицы, начинающийся с первой строки.

  1. Чтобы активизировать панель инструментов Сводные таблицы, щелкните отчет сводной таблицы. Для отчета сводной диаграммы щелкните связанный отчет сводной таблицы.

  2. Нажмите кнопку Мастер сводных таблиц [image] на панели инструментов Сводные таблицы.

  3. На шаге 3 мастера, нажмите кнопку Макет.

  4. Перетащите кнопки полей в требуемое место. Для изменения подписей рядов в отчете сводной диаграммы перетащите соответствующиее поле столбца. Для сортировки подписей категорий диаграмм, перетащите соответствующее поле строки.

    Инструкции.

  5. Чтобы удалить поля из сводной таблицы или сводной диаграммы, перетащите кнопки полей с макета диаграммы.

Примечания

  • Поля данных и измерений OLAP В отчетах сводной таблицы или сводной диаграммы, основанных на базах данных OLAP, поля измерений могут использоваться в сводной таблице только как поля строк, столбцов, страниц или как поля рядов данных, категорий или страниц в сводной диаграмме Эти поля имеют значок Поле измерения в начале строки на панели инструментов Сводные таблицы. Поля, имеющие значок Поля данных в начале строки на панели инструментов, могут использоваться только как поля данных или как значения оси в сводной диаграмме.

  • Поля измерений OLAP управляются как одно целое Когда поле измерения перемещается при изменении макета, все уровни и все элементы в измерении перемещаются вместе с ним.

  • Поля страниц, устанавливающие запрос для каждого объекта Если в поле страницы устанавливается запрос к внешним данным при выборе элемента поля, перемещение поля страницы в другое место в области сводной таблицы изменяет поле и Microsoft Excel извлекает внешние данные для всех элементов поля одновременно. См. сведения о параметрах поля страницы.

  • Влияние изменения макета на форматирование сводной диаграммы°°. При изменении макета отчета сводной таблицы, связанного с отчетом сводной диаграммы, макет отчета сводной диаграммы также меняется. Например, при обмене строк и столбцов в отчете сводной таблицы, меняются местами ряды и категории в отчете сводной диаграммы. При изменении отчета сводной таблицы некоторые параметры форматирования отчета сводной диаграммы могут быть утеряны.


Изменение типа диаграммы, установленного по умолчанию

  1. Чтобы активизировать меню Диаграмма, выберите диаграмму.

  2. В меню Диаграмма выберите пункт Тип диаграммы.

  3. На вкладке Стандартные или Нестандартные выберите необходимый тип.

    На вкладке Нестандартные выводится список текущих диаграмм, используемых по умолчанию, а также нестандартных типов диаграмм: встроенных и добавленных. Можно создать диаграмму, содержащую необходимый тип, элементы и формат, а затем сохранить ее в качестве нестандартного типа диаграммы.

    Инструкции

  4. Выберите команду Сделать стандартной и нажмите кнопку Да.

  5. Для выхода из диалогового окна без сохранения изменений текущего типа диаграммы нажмите кнопку Отменить.

    Для выхода из диалогового окна с сохранением изменений текущего типа диаграммы нажмите кнопку OK.


 Консолидация данных по категориям

Консолидация данных по категориям

  1. Укажите верхнюю левую ячейку конечной области консолидируемых данных.

  2. В меню Данные выберите команду Консолидация.

    Демонстрация

  3. Выберите из раскрывающегося списка Функция функцию, которую следует использовать для обработки данных. Для получения сведений об имеющихся итоговых функциях нажмите [image] .

  4. Введите исходную область консолидируемых данных в поле Ссылка. Убедитесь, что исходная область имеет заголовок. Для получения более подробных сведений об источниках данных нажмите [image] .

  5. Нажмите кнопку Добавить.

  6. Повторите шаги 4 и 5 для всех консолидируемых исходных областей.

  7. В наборе флажков Использовать в качестве имен установите флажки, соответствующие расположению в исходной области заголовков: в верхней строке, в левом столбце или в верхней строке и в левом столбце одновременно.

  8. Чтобы автоматически обновлять итоговую таблицу при изменении источников данных, установите флажок Создавать связи с исходными данными..

    Связи нельзя использовать, если исходная область и область назначения находятся на одном листе. После установки связей нельзя добавлять новые исходные области и изменять исходные области, уже входящие в консолидацию.

Примечание. Если метки в одной из исходных областей не совпадают с метками в других исходных областях, то при консолидации данных для них будут созданы отдельные строки или столбцы.


 Консолидация данных по расположению

Консолидация данных по расположению

  1. Укажите верхнюю левую ячейку конечной области консолидируемых данных.

  2. В меню Данные выберите команду Консолидация.

    Демонстрация

  3. Выберите из раскрывающегося списка Функция функцию, которую следует использовать для обработки данных. Для получения сведений об имеющихся итоговых функциях нажмите [image] .

  4. Введите в поле Ссылка исходную область консолидируемых данных. Для получения дополнительных сведений об источниках данных нажмите [image] .

  5. Нажмите кнопку Добавить.

  6. Повторите шаги 4 и 5 для всех консолидируемых исходных областей.

  7. Чтобы автоматически обновлять итоговую таблицу при изменении источников данных, установите флажок Создавать связи с исходными данными..

    Связи нельзя использовать, если исходная область и область назначения находятся на одном листе. После установки связей нельзя добавлять новые исходные области и изменять исходные области, уже входящие в консолидацию.

Примечание. При консолидации данных по расположению заголовки категорий исходных областей не копируются автоматически в область назначения. Если в области назначения требуется разместить заголовки, скопируйте или введите их вручную.


Консолидация данных с использованием трехмерных ссылок

  1. На листе консолидации скопируйте или задайте надписи для данных консолидации.

  2. Укажите ячейку, в которую следует поместить данные консолидации.

  3. Введите формулу. Она должна включать ссылки на исходные ячейки каждого листа, содержащего данные, для которых будет выполняться консолидация. Для получения сведений об источниках данных нажмите [image] .

  4. Повторите шаги 2 и 3 для каждой ячейки, в которой требуется вывести результаты обработки данных.

Совет. Чтобы ввести ссылку, не используя клавиши на клавиатуре, введите формулу до того места, где требуется вставить ссылку, а затем укажите на листе нужную ячейку. Если ячейка находится на другом листе, перейдите на этот лист и укажите нужную ячейку.


 Использование ключей автозагрузки при запуске Excel

Использование ключей автозагрузки при запуске Excel

  1. Выполните одно из следующих действий:

    Если для запуска Microsoft Excel используется меню Пуск, то с помощью Проводника Windows поместите значок ярлыка Microsoft Excel в папку автозагрузки папки Windows. Щелкните значок ярлыка правой кнопкой мыши, выберите Свойства в контекстном меню,а затем выберите вкладку Ярлык.

    Если для запуска Microsoft Excel используется панель Office, то щелкните правой кнопкой мыши кнопку Microsoft Excel, выберите команду Свойства, а затем — вкладку Ярлык.

  2. В поле Объект введите пробел после пути к программе Microsoft Excel, а затем — один или более перечисленных ключей.

    Например, для открытия книги «Страховые списки.xls» введите пробел после пути и далее введите:
    c:\Reference Data\Страховые списки.xls
    Чтобы запустить Microsoft Excel и | Введите
    открыть определенную книгу | путь_к_книге\имя_файла
    открыть определенную книгу
    только для чтения
    /r     путь_к_книге\имя_файла
    не отображать загрузочный экран и пустую новую книгу

    /e
    указать рабочую папку | /p путь_к_папке\имя_папки

Примечание. Папка, определенная в ключе автозагрузки, используется вместо папки, указанной в поле Рабочий каталог вкладки Общие диалогового окна Параметры (меню Сервис).


 Изменение числа итераций или относительной погрешности

Изменение числа итераций или относительной погрешности

Если в вычислениях используются итерации, лист пересчитывается столько раз, какое значение указано в поле Предельное число итераций, или когда все величины модели изменятся за одну итерацию на число, меньшее указанного в поле Относительная погрешность.

  1. В меню Сервис выберите пункт Параметры и перейдите на вкладку Вычисления.

  2. Установите флажок Итерации.

  3. Введите количество итераций, выполняемых при обработке формул в поле Предельное число итераций. Чем больше предельное число итераций, тем больше времени потребуется Microsoft Excel для пересчета листа.

  4. Введите относительную погрешность вычислений в поле Относительная погрешность. Чем меньше погрешность, тем больше время пересчета листа и точнее результаты обработки формул.

Примечание. Для решения сложных задач можно воспользоваться надстройкой "Поиск решения". Для получения дополнительных сведений по использованию надстройки "Поиск решения" нажмите кнопку [image] .


Отображение пустых ячеек на диаграмме

  1. Выберите нужную диаграмму.

  2. В меню Сервис выберите команду Параметры и перейдите к вкладке Диаграмма.

  3. Укажите нужные параметры в разделе Для пустых ячеек.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.


 Создание изображения ячеек, привязанного к исходным данным

Создание изображения ячеек, привязанного к исходным данным

В изображение включаются только видимые данные ячеек. При необходимости измените размер столбцов Microsoft Excel, чтобы все данные, которые должны присутствовать на изображении, стали видимыми. Если линии сетки видны, они также попадают на изображение. Чтобы убрать линии сетки, выберите пункт Параметры в меню Сервис, перейдите на вкладку Вид и снимите флажок Линии сетки.

  1. Выделите ячейки листа, которые должны быть на изображении.

  2. Нажмите кнопку Копировать [image] .

  3. Щелкните лист или документ, в который будет вставляться изображение.

  4. Для копирования на другой лист выберите команду Вставить связь с рисунком в меню Правка, одновременно удерживая клавишу SHIFT. При этом будет установлена связь изображения посредством формулы, которая ссылается на копируемые ячейки.

    Чтобы скопировать изображение в документ, созданный с помощью другого приложения Office, воспользуйтесь командой Специальная вставка меню Правка. Выберите Рисунок в списке Как, параметр связать и нажмите кнопку OK.

    Для изменения изображения может использоваться панель инструментов Настройка изображения.

Примечание. Связь изображения с копируемыми ячейками поддерживается посредством DDE. Чтобы получить более подробные сведения о DDE, обратитесь к руководству Microsoft Office 2000 Resource Kit. Инструкции по получению Office Resource Kit.


 Создание изображений ячеек, диаграмм и других объектов, не связанных с исходными данными

Создание изображений ячеек, диаграмм и других объектов, не связанных с исходными данными

Если линии сетки отображены, они также присутствуют и на изображении. Чтобы убрать линии сетки, выберите пункт Параметры меню Сервис, перейдите на вкладку Вид и снимите флажок Линии сетки.

  1. На листе Excel или на листе диаграммы выделите ячейки, диаграмму или объект, копируемые в виде рисунка.

  2. Выберите команду Копировать рисунок в меню Правка, одновременно удерживая нажатой клавишу SHIFT.

  3. Для наилучшего качества рисунка установите переключатели в положения как на экране и векторный, а затем нажмите кнопку OK.

  4. Щелкните лист или документ, в который будет вставляться изображение.

  5. Нажмите кнопку Вставить [image] .

    Для изменения изображения может использоваться панель инструментов Настройка изображения.

Совет. Чтобы вставить в Microsoft Excel скопированные из другого приложения данные в виде рисунка, выполните команду Вставить рисунок или Вставить связь с рисунком в меню Правка,удерживая нажатой клавишу SHIFT.


 Перемещение и копирование всего содержимого ячейки

Перемещение и копирование всего содержимого ячейки

  1. Выделите ячейки, которые нужно переместить или скопировать.

    Инструкции

  2. Поместите указатель на рамку выделенного интервала.

    Выделенная ячейка и указатель

  3. Чтобы переместить ячейки, перетащите диапазон к левой верхней ячейке области вставки. Все данные, содержащиеся в области вставки, будут замещены.

    Чтобы скопировать ячейки, при перетаскивании удерживайте клавишу CTRL.

    Чтобы вставить ячейку, при перетаскивании удерживайте клавиши SHIFT (для перемещения) или SHIFT+CTRL (для копирования).

    Чтобы перетащить диапазон на другой лист, удерживайте клавишу ALT.

Совет. Чтобы переместить или скопировать ячейки в другую книгу или в отдаленное место, выделите ячейки и выберите команду Вырезать [image] для перемещения или команду Копировать [image] для копирования. Перейдите на другой лист книги, укажите левый верхний угол области вставки, а затем выберите команду Вставить [image] .


 Копирование данных внутри строки или столбца

Копирование данных внутри строки или столбца

  1. Выделите ячейки, содержащие данные, которые необходимо скопировать.

  2. Протащите маркер заполнения по заполняемым ячейкам.

    Все существовавшие ранее значения или формулы, а также форматы, в заполняемых ячейках будут замещены.

Примечания

  • Чтобы быстро заполнить активную ячейку содержимым ячейки, расположенной выше, нажмите клавиши CTRL+D. Чтобы заполнить содержимым ячейки слева, нажмите клавиши CTRL+R.

  • Перетаскивание маркера заполнения влево или вверх от выделения и остановка в пределах выделенного диапазона (до пересечения левой или верхней границы листа) приведет к стиранию выделенных данных, но сохранению формата.

  • Если вместо копирования происходит приращение таких данных, как числа или даты, то заново выделите исходные значения и перетащите маркер заполнения, удерживая клавишу CTRL.


 Копирование формул при расширении диапазона внешних данных

Копирование формул при расширении диапазона внешних данных

  1. Если диалоговое окно Свойства внешнего диапазона не отображено, щелкните одну из ячеек диапазона внешних данных, а затем нажмите кнопку Свойства диапазона данных [image] на панели инструментов Внешние данные.

  2. Чтобы скопировать формулы в соседний столбец или в столбец внутри диапазона внешних данных при обновлении и изменении размеров диапазона внешних данных, установите флажок Заполнить формулами соседние столбцы.

Примечания

  • Microsoft Excel копирует только те формулы, которые непосредственно примыкают или находятся внутри диапазона внешних данных.

  • Чтобы создать новую формулу и копировать ее во все строки диапазона внешних данных, введите формулу в верхнюю ячейку соседнего столбца, выделите эту ячейку и дважды щелкните маркер выделения.


 Перемещение и копирование части содержимого ячейки в другую ячейку

Перемещение и копирование части содержимого ячейки в другую ячейку

  1. Дважды щелкните ячейку, содержимое которой нужно переместить или копировать.

  2. В ячейке выделите символы, которые нужно скопировать или переместить.

  3. Чтобы переместить выбранные символы, нажмите кнопку Вырезать [image] .

    Чтобы скопировать выделенные символы, нажмите кнопку Копировать [image] .

  4. Дважды щелкните ячейку, в которую нужно скопировать или переместить данные.

  5. Укажите в ячейке место, в которое следует вставить данные.

  6. Нажмите кнопку Вставить [image] .

  7. Нажмите клавишу ENTER.

Примечания

  • Чтобы скопировать всю ячейку или часть формулы, выделите символы и нажмите кнопку Копировать [image] , а затем нажав клавишу ESC выйдите из ячейки. Дважды щелкните ячейку, в которую нужно вставить данные, и нажмите кнопку Вставить [image] .

  • После двойного щелчка на ячейке или нажатия клавиши F2 (для перехода в режим редактирования ячейки), курсор передвигается только в пределах этой ячейке. Чтобы перейти в другую ячейку, предварительно нажмите клавишу ENTER для завершения правки текущей ячейки.


 Перемещение и копирование символов внутри ячейки

Перемещение и копирование символов внутри ячейки

  1. Дважды щелкните ячейку, содержимое которой нужно изменить.

  2. В ячейке выделите символы, которые следует переместить или скопировать.

  3. Чтобы переместить символы, выберите команду Вырезать [image] .

    Чтобы скопировать символы, выберите команду Копировать [image] .

  4. Укажите в ячейке место, в которое следует поместить символы.

  5. Выберите команду Вставить [image] .

  6. Нажмите клавишу ENTER.


 Копирование таблицы Word на лист Microsoft Excel

Копирование таблицы Word на лист Microsoft Excel

Чтобы иметь возможность использования более мощных средств работы с таблицами данных, предоставляемых Microsoft Excel, можно скопировать таблицу из документа Word в лист Excel.

  1. Выделите в Microsoft Word копируемые строки и столбцы таблицы.

    Чтобы выделить таблицу целиком, щелкните ее, выберите пункт Выделить в меню Таблица и затем — пункт Таблица.

  2. Нажмите кнопку Копировать [image] .

  3. Перейдите на лист Microsoft Excel.

  4. Укажите левый верхний угол области листа, куда следует поместить таблицу.

    Ячейки вставляемой таблицы заменят данные в указанной области.

  5. Нажмите кнопку Вставить [image] .


 Создание сводной таблицы или отчета сводных диаграмм на основе данных, находящихся в нескольких диапазонах консолидации

Создание сводной таблицы или отчета сводных диаграмм на основе данных, находящихся в нескольких диапазонах консолидации

Если есть несколько списков с одинаковыми категориями данных и необходимо их объединить, то одна из возможностей объединения — это использование сводной таблицы или отчета сводной диаграммы. Excel также обеспечивает другие способы консолидации данных, которые применимы к спискам любых форматов и макетов.

Настройка источников данных. При объединении данных из нескольких списков или листов эти списки или страницы должны иметь сопоставимые имена объединяемых строк и столбцов. При создании сводной таблицы или отчета сводной диаграммы не включайте в них любые итоговые строки или столбцы из источников данных. См. сведения о настройке данных в формате списков.

Использование поименованных диапазонов, если исходные данные планируется расширять. Чтобы сводная таблица или отчет сводных диаграмм быстрее обновлялись при внесении изменений в исходный диапазон, необходимо поименовать исходный диапазон и использовать это имя при создании сводной таблицы или отчета сводных диаграмм. Если в диапазон, которому присвоено имя, добавляются новые данные, то при обновлении отчета они будут включены в него.

Использование полей страницы при консолидации. При консолидации используются дополнительные поля страниц, содержащие элементы, которые представляют один или несколько исходных диапазонов. Например, если консолидируются бухгалтерские данные по нескольким отделам («Маркетинг», «Сбыт» и «Производство»), в поле страницы могут находиться элементы, представляющие каждый отдел или их комбинацию.

Параметры поля страницы После установки переключателя в положение в нескольких диапазонах консолидации на первом шаге мастера сводных таблиц и диаграмм, можно выбрать тип поля страницы.

  • Одно поле страницы. Для отображения одной страницы, объединяющей все диапазоны исходных данных, позволяя отображать каждый диапазон или консолидацию, установите переключатель в положение Создать одно поле страницы на шаге 2a мастера.

  • Несколько полей страниц. Можно создать до четырех полей страниц и назначить каждому элементу исходного диапазона имя, а также создать структуру, не имеющую полей страниц. Установите переключатель в положение Создать поля страницы на шаге 2a мастера. Этот возможность используется для сравнения частей исходных данных или отображения всех данных. Можно создать подмножество диапазонов данных для поля страницы таким образом, что будет отображаться только выбранный диапазон консолидации.

Дополнительные сведения

Создание отчета сводной таблицы

Создание отчета сводной диаграммы


 Создание сводной таблицы или отчета сводной диаграммы на основе данных, находящихся в списке или базе данных Microsoft Excel

Создание сводной таблицы или отчета сводной диаграммы на основе данных, находящихся в списке или базе данных Microsoft Excel

Можно использовать данные из книги Excel, как основу для создания сводной таблицы или отчета сводных диаграмм. Исходный список или база данных должны иметь заголовки столбцов, так как содержимое ячеек первой строки списка будет использовано в качестве имен полей в отчете. См. сведения об установке данных в формате списка.

Автоматическое выделение источника данных. Перед запуском мастера сводных таблиц и диаграмм выделите ячейку. В диалоговом окне мастера будет указана ссылка на список.

Использование поименованных диапазонов, если исходные данные планируется расширять. Чтобы сводная таблица или отчет сводных диаграмм быстрее обновлялись при внесении изменений в исходный диапазон, необходимо поименовать исходный диапазон и использовать это имя при создании сводной таблицы или отчета сводных диаграмм. Если в диапазон, которому присвоено имя, добавляются новые данные, то при обновлении отчета они будут включены в него.

Использование фильтрованных данных. Microsoft Excel игнорирует любые фильтры списка, созданные с помощью подменю Фильтр в меню Данные. В сводную таблицу или отчет сводной диаграммы включаются все данные списка.

Чтобы создать сводную таблицу или отчет сводных диаграмм, включающий только фильтрованные данные, воспользуйтесь командой Расширенный фильтр для извлечения фильтрованных данных в другое место листа. Эти данные можно использовать для создания сводной таблицы или отчета сводных диаграмм.

Включение итогов. В отчете сводной таблицы автоматически создаются общие и промежуточные итоги. Если исходный лист содержит автоматически созданные общие и промежуточные итоги, то удалите все итоги перед созданием сводной таблицы или отчета сводных диаграмм.

Дополнительные сведения

Создание отчета сводной таблицы

Создание отчета сводной диаграммы


 Создание отчета сводной таблицы или отчета сводной диаграммы по другому отчету сводной таблицы

Создание отчета сводной таблицы или отчета сводной диаграммы по другому отчету сводной таблицы

Экономия памяти и дискового пространства При каждом создании отчетов сводных таблиц и сводных диаграмм Microsoft Excel создает промежуточную копию данных, используемых отчетом. Эта копия создается в оперативной памяти и хранится как часть файла книги, что требует дополнительной памяти и дискового пространства. Однако при использовании существующего отчета сводной таблицы в качестве источника для нового отчета сводной таблицы или отчета сводной диаграммы оба отчета используют те же самые промежуточные данные. Поскольку используется та же копия данных, размер файла книги уменьшается и меньше данных размещается в оперативной памяти.

Использование существующего отчета сводной таблицы или сводной диаграммы

Можно построить новый отчет сводной таблицы или сводной диаграммы по существующему отчету сводной таблицы, но нельзя построить новый отчет непосредственно по отчету сводной диаграммы. Однако поскольку Excel создает связанный отчет сводной таблицы при каждом создании отчета сводной диаграммы, можно построить новый отчет сводной таблицы или сводной диаграммы по связанному отчету.

Изменения, влияющие на оба отчета Когда данные в новом отчете сводной таблицы или сводной диаграммы обновляются, Microsoft Excel автоматически обновляет данные в исходном отчете (на котором новый отчет основан) и наоборот. Группирование и разгруппирование данных в любом из отчетов сказывается на обоих отчетах. Создание вычисляемых полей или вычисляемых элементов в одном из отчетов влияет на оба отчета.

Требования к размещению Для использования отчета сводной таблицы при создании другого отчета сводной таблицы или сводной диаграммы оба отчета должны находиться в одной книге. Если исходный отчет расположен в другой книге, скопируйте его в книгу, в которой будет располагаться новый отчет. Отчеты сводных таблиц и сводных диаграмм в разных книгах используют разные промежеточные данные в памяти и в файле книги, поэтому эти отчеты обновляются по отдельности.

Параметры поля страницы. Исходная таблица не может содержать поля страниц, в которых устанавливается запрос к внешним данным при выборе элемента поля. Параметры поля страницы.

Отчеты сводных таблиц, которые независимы от отчетов сводных диаграмм Изменения в отчете сводной диаграммы влияют на связанный отчет сводной таблицы и наоборот. Если нужна возможность изменения макета или отображения данных без соответствующих изменений другого отчета, можно создать отдельный независимый отчет сводной таблицы.

Использование списка сводной таблицы с Web-страницы

Можно экспортировать список сводной таблицы из Web-обозревателя в Excel, просматривать и сохранять список как отчет сводной таблицы. Новый отчет сводной таблицы и список сводной таблицы в Интернете будут использовать те же самые исходные данные. Однако при этом не устанавливается никаких связей между отчетом сводной таблицы и исходным списком сводной таблицы на Web-странице.

При перенесении списка сводной таблицы с Web-страницы в Excel можно заметить некоторые различия в содержимом и вычислениях. Более подробную информацию можно получить из справки по спискам сводных таблиц в Web-обозревателе перед экспортом списка сводной таблицы в Excel.

Дополнительные сведения

Создание отчета сводной таблицы

Создание отчета сводной диаграммы

Списки сводных таблиц в Интернете


 Создание вычисляемого поля в сводной таблице или отчете сводной диаграммы

Создание вычисляемого поля в сводной таблице или отчете сводной диаграммы

Вычисляемое поле можно создать только в отчетах, основанных на не-OLAP исходных данных. Для отчетов, основанных на данных OLAP, доступные поля зависят от того, как куб определен на сервере. За подробной информацией о вычислениях, доступных для исходных данных, обратитесь к администратору базы данных OLAP.

  1. Выделите ячейку в отчете сводной таблицы или выберите мышью отчет сводной диаграммы.

  2. На панели инструментов Сводные таблицы выберите Сводная таблица или Сводная диаграмма, далее выберите команду Формулы, а затем команду Вычисляемое поле.

  3. Введите имя вычисляемого поля в поле Имя.

  4. Введите формулу в поле Формула.

    Чтобы использовать в формуле данные поля, выберите поле в списке Поля, а затем нажмите кнопку Добавить поле.

  5. Нажмите кнопку Добавить, а затем — кнопку OK.

  6. Расположите вычисляемое поле в требуемом месте отчета.

    Инструкции

Примечания

  • Формулы для вычисляемых полей всегда влияют на все доступные данные сводной таблицы; использование части данных в формуле невозможно. Написание формул для вычисляемых полей.

  • Когда в отчете сводной диаграммы создается вычисляемое поле, формула и ее результаты отражаются в связанном отчете сводной таблицы и наоборот. Если при работе с отчетом сводной диаграммы планируется создавать сложные формулы, рекомендуется создавать формулы в связанном отчете сводной таблицы (в котором могут быть просмотрены отдельные значения, формирующие результаты), а отображенные результаты просматривать в отчете сводной диаграммы. Формулы в отчетах сводных диаграмм.


 Создание вычисляемого элемента в сводной таблице или отчете сводной диаграммы

Создание вычисляемого элемента в сводной таблице или отчете сводной диаграммы

Вычисляемый элемент можно создать только в отчетах, основанных на не-OLAP исходных данных. Для отчетов, основанных на данных OLAP, доступные вычисления зависят от того, как куб определен на сервере. За подробной информацией о вычислениях, доступных для исходных данных, обратитесь к администратору базы данных OLAP.

Отчеты сводных диаграмм Когда в отчете сводной диаграммы создается вычисляемый элемент, формула и ее результаты отражаются в связанном отчете сводной таблицы и наоборот. Если при работе с отчетом сводной диаграммы планируется создавать сложные формулы, рекомендуется создавать формулы в связанном отчете сводной таблицы (в котором могут быть просмотрены отдельные значения, формирующие результаты), а отображенные результаты просматривать в отчете сводной диаграммы. Формулы в отчетах сводных диаграмм.

  1. Если элементы в поле, используемом для создания формулы, сгруппированы, разгруппируйте их.

    Инструкции

  2. Выделите поле или элемент поля, к которым должен быть добавлен вычисляемый элемент.

  3. На панели инструментов Сводные таблицы выберите Сводная таблица или Сводная диаграмма, далее выберите команду Формулы, а затем команду Вычисляемый объект.

  4. Введите имя вычисляемого элемента в поле с раскрывающимся списком Имя.

  5. Введите формулу для элемента в поле Формула.

    Чтобы использовать в формуле данные элемента поля, выберите поле в списке Поля, а элемент — в списке Элементы, а затем нажмите кнопку Добавить элемент.

    Если элемент находится в другом поле, то его использовать нельзя.

  6. Нажмите кнопку Добавить, а затем — кнопку OK.

  7. Если на шаге 1 элементы поля были разгруппированы, после создания вычисляемого элемента поля можно повторить группировку. В группы можно включать и вычисляемые элементы поля.

    Инструкции

Примечания

  • Написание формул вычисляемых элементов.

  • Если поля содержат вычисляемые элементы, нельзя изменять итоговую функцию.

  • Формула для вычисляемого элемента перекрывается формулой для вычисляемого поля, если ячейка в области данных находится на пересечении вычисляемого элемента и вычисляемого поля.


 Создание запроса с условиями

Создание запроса с условиями

Эта процедура не позволяет извлечь данные из баз данных OLAP. Эта процедура может быть использована для всех остальных баз данных, к которым можно получить доступ с помощью драйверов ODBC, которые корпорация Microsoft поставляет вместе с Query. Информация о поддержке запросов с параметрами драйверами третьих фирм может быть получена у поставщика драйверов.

  1. Создайте запрос, включающий таблицы и поля нужных записей. Не возвращайте результаты запроса в Microsoft Excel.

    Инструкции

  2. Убедитесь, что кнопка Автоматический режим [image] не нажата.

  3. Убедитесь, что кнопка Отображение условий [image] нажата.

  4. Выберите ячейку в строке Условие и щелкните стрелку, чтобы выбрать из списка поле, которое следует использовать в качестве параметра запроса.

  5. Выделите первую ячейку в строке Значение. Введите [ (открывающая квадратная скобка) и текст, который Microsoft Query будет выводить при запуске запроса. Затем введите ] (закрывающая квадратная скобка). Например:

    Текст сообщения должен отличаться от имени поля, однако имя поля может входить в него. Более подробные сведения о типах условий, используемых для выборки данных, можно найти в справке по Microsoft Query.

  6. Нажмите клавишу ENTER.

  7. Чтобы запустить запрос из Microsoft Query, нажмите кнопку Выполнить запрос [image] .

    Чтобы передать таблицу результатов в Microsoft Excel, нажмите кнопку выход с возвратом данных [image] .


 Создание гиперссылки на адрес электронной почты

Создание гиперссылки на адрес электронной почты

Если программа работы с электронной почтой установлена, при щелчке гиперссылки на адрес электронной почты, автоматически запускается программа работы с электронной почтой и создается сообщение с правильным адресом в поле Кому.

  1. Щелкните правой кнопкой мыши текст или рисунок, которые будут представлять гиперссылку, а затем выберите Гиперссылка в контекстном меню.

  2. В разделе Связать с нажмите кнопку Электронная почта.

  3. В поле Электронная почта введите требуемый адрес электронной почты.

  4. В поле Тема введите тему сообщения.

    Имейте в виду, что некоторые Web-обозреватели и почтовые программы могут не распознать строку с темой сообщения.

  5. Для назначения подсказки, которая будет отображаться при фиксации указателя мыши на гиперссылке, нажмите кнопку Подсказка и затем введите требуемый текст в поле Текст подсказки. Нажмите кнопку OK.

Примечания

  • Если подсказка не указана, то в качестве нее будет использован текст "mailto:", за которым следует адрес электронной почты и строка темы сообщения.

  • Геперссылка может быть создана вводом адреса электронной почты непосредственно в ячейку. Например, если ввести someone@microsoft.com, гиперссылка будет создана автоматически.


 Создание гиперссылки на существующий файл

Создание гиперссылки на существующий файл

  1. Щелкните правой кнопкой мыши текст или рисунок, которые будут представлять гиперссылку, а затем выберите Гиперссылка в контекстном меню.

  2. В разделе Связать с нажмите кнопку Имеющийся файл или Web-страница.

  3. Выполните одно из следующих действий:

    Для выбора файла из списка ранее использовавшихся нажмите кнопкуПоследние файлы, а затем щелкните файл, который нужно связать.

  4. Для выбора файла из списка существующих файлов нажмите кнопку Файл под надписью Найти, найдите и дважды щелкните файл, который нужно связать.

  5. Для назначения подсказки, которая будет отображаться при фиксации указателя мыши на гиперссылке, нажмите кнопку Подсказка и затем введите требуемый текст в поле Текст подсказки. Нажмите кнопку OK.

Примечания

  • Если подсказка не указана, в качестве нее будет использоваться путь к файлу.

  • Если необходимо изменить текст, представляющий гиперссылку в исходной книге, введите новый текст в поле Текст.

  • Путь к новому файлу по умолчанию устанавливается относительно положения активной книги. Можно задать другой путь, используемый по умолчанию, установкой базового адреса гиперссылки.

  • Нельзя создавать гиперссылку из элемента управления, созданного при помощи панели инструментов Формы, или из кнопки и рисунка, которые имеют прикрепленный макрос.


 Создание гиперссылки на определенное место Web-страницы

Создание гиперссылки на определенное место Web-страницы

Чтобы создать гиперссылку на определенное место на Web-странице, убедитесь в том, что в нужном месте Web-страницы находится закладка. Можно использовать существующую закладку или вставить новую закладку в исходный текст документа, для которого есть право на запись.

  1. Щелкните правой кнопкой мыши текст или рисунок, которые будут представлять гиперссылку, а затем выберите Гиперссылка в контекстном меню.

  2. В разделе Связать с нажмите кнопку Имеющийся файл или Web-страница.

  3. Выполните одно из следующих действий:

    Для выбора Web-страницы из списка ранее просмотренных страниц нажмите кнопку Просмотренные страницы и щелкните Web-страницу, которую нужно связать.

    Для выбора Web-страницы с помощью поиска в Web-обозревателе нажмите кнопку Web-страница под надписью Найдите, откройте искомую Web-страницу и, не закрывая обозреватель, переключитесь обратно в Excel.

  4. Нажмите кнопку Закладка и дважды щелкните требуемую закладку.

  5. Для назначения подсказки, которая будет отображаться при фиксации указателя мыши на гиперссылке, нажмите кнопку Подсказка и затем введите требуемый текст в поле Текст подсказки. Нажмите кнопку OK.

Примечания

  • Если подсказка не указана, в качестве нее будет использоваться URL связываемой Web-страницы и имя закладки.

  • Нельзя создавать гиперссылку из элемента управления, созданного при помощи панели инструментов Формы, или из кнопки и рисунка, которые имеют прикрепленный макрос.


 Создание гиперссылки на Web-страницу

Создание гиперссылки на Web-страницу

  1. Щелкните правой кнопкой мыши текст или рисунок, которые будут представлять гиперссылку, а затем выберите Гиперссылка в контекстном меню.

  2. В разделе Связать с нажмите кнопку Имеющийся файл или Web-страница.

  3. Выполните одно из следующих действий:

    Для выбора Web-страницы из списка ранее просмотренных страниц нажмите кнопку Просмотренные страницы и щелкните Web-страницу, которую нужно связать.

    Для выбора Web-страницы с помощью поиска в Web-обозревателе нажмите кнопку Web-страница под надписью Найдите, откройте искомую Web-страницу и, не закрывая обозреватель, переключитесь обратно в Microsoft Excel.

  4. Для назначения подсказки, которая будет отображаться при фиксации указателя мыши на гиперссылке, нажмите кнопку Подсказка и затем введите требуемый текст в поле Текст подсказки. Нажмите кнопку OK.

Примечания

  • Если подсказка не указана, в качестве нее будет использоваться URL связываемой Web-страницы.

  • Если необходимо изменить текст, представляющий гиперссылку в исходной книге, введите новый текст в поле Текст.

  • Гиперссылка может быть создана непосредственным вводом адреса Web-страницы в ячейку, если адрес начинается с http:// или ftp://, или \\сервер\ресурс\. Адрес становится текстом гиперссылки.

  • Нельзя создавать гиперссылку из элемента управления, созданного при помощи панели инструментов Формы, или из кнопки и рисунка, которые имеют прикрепленный макрос.


 Автоматическое обновление итоговой таблицы при изменении исходных данных

Автоматическое обновление итоговой таблицы при изменении исходных данных

Если на листе, содержащем область назначения, уже существует структура или этот лист использовался ранее для консолидации данных со связями, удалите структуру перед созданием новых связей. Для получения сведений о том, как удалить структуру, нажмите кнопку [image] .

  1. Укажите верхнюю левую ячейку существующей итоговой таблицы.

  2. В меню Данные выберите команду Консолидация.

    Демонстрация

  3. Установите флажок Создавать связи с исходными данными.

    Примечание. Итоговая таблица и исходные области должны располагаться на разных листах.


 Присваивание ячейкам имени при помощи существующих заголовков строк и столбцов

Присваивание ячейкам имени при помощи существующих заголовков строк и столбцов

  1. Выделите область, в которой следует присвоить имена строкам или столбцам. Выделенная область должна содержать строку или столбец заголовков.

  2. Выберите команду Имя в меню Вставка, а затем — команду Создать.

    Демонстрация

  3. Установите флажки В строке выше, В столбце слева, В строке ниже или В столбце справа в группе флажков По тексту, чтобы указать расположение заголовков, из которых следует создать имена.

Примечание. Созданное таким образом имя ссылается только на ячейки, содержащие значения, и не включает в себя существующих заголовков строк и столбцов.


 Создание за один шаг отчета сводной диаграммы, отражающего представление существующего отчета сводной таблицы

Создание за один шаг отчета сводной диаграммы, отражающего представление существующего отчета сводной таблицы

Когда диаграмма создается таким способом, Microsoft Excel автоматически создает гистограмму с накоплением на листе диаграммы. Диаграмма использует макет отчета сводной таблицы для определения размещения полей. Поля строк в таблице становятся полями категорий в отчете сводной диаграммы, а поля столбцов в таблице — полями рядов в диаграмме.

  1. Щелкните ячейку отчета сводной таблицы, из которой будет создаваться отчет сводной диаграммы.

  2. Нажмите кнопку Мастер диаграмм [image] на панели инструментов Стандартная.

Примечания

  • Если необходимо указать параметры диаграммы — например, тип диаграммы, заголовки, размещение легенды, метки данных, положение диаграммы и т. п. — в процессе создания, можно использовать другую процедуру, которая позволит выполнить все шаги мастера диаграмм для создания отчета сводной диаграммы.

  • Отчет сводной диаграммы изменяется при изменении отчета сводной таблицы, и наоборот.

  • Чтобы изменить тип диаграммы или положение диаграммы после создания, внести другие изменения или добавить заголовки, оси, линии сетки, легенду и т. п., убедитесь в том, что лист диаграммы активен, и нажмите кнопку Мастер диаграмм [image].


 Создание шаблона для автоматического получения внешних данных

Создание шаблона для автоматического получения внешних данных

  1. Создайте сводную таблицу или диапазон внешних данных.

    Инструкции

  2. Отформатируйте книгу.

  3. Нажмите кнопку Сохранить [image] .

  4. Введите имя в поле Имя файла.

  5. В окне Тип файла выберите пункт Шаблон (*.xlt).

  6. В поле Папка выберите папку, в которой должен храниться данный шаблон.

  7. Нажмите кнопку Сохранить.

  8. Выполните одно из следующих действий:

    Чтобы удалять диапазон внешних данных из книги и автоматически обновлять его при открытии шаблона отчета, выберите Да.

    Для отображения текущих данных внешнего диапазона при открытии копии шаблона выберите Нет.


 Создание собственного цифрового сертификата

Создание собственного цифрового сертификата

  1. Запустите программу установки Office 2000 еще раз.

  2. На экране Выбор компонентов программы установки разверните раздел Средства Office.

  3. Выберите Цифровая подпись для проектов VBA, щелкните стрелку рядом с выбранным пунктом и выберите Запускать с моего компьютера.

  4. В проводнике Windows найдите и дважды щелкните программу SelfCert.exe в папке C:\Program Files\Microsoft Office\Office.

Примечание. Поскольку созданныйцифровой сертификат не был выпущен формальной службой сертификации, макропроекты, подписанные с помощью такого сертификата, рассматриваются как проекты с автоматическим добавлением подписи. Политика организации по использованию возможностей цифровых подписей в Microsoft Office может привести к запрещению использования такого сертификата или невозможности запуска другими пользователями макросов с автоматически добавленной подписью из соображений безопасности. Цифровые подписи.

Дополнительную информацию о создании цифровых сертификатов можно получить из справки по Visual Basic для приложений.


 Создание отчета Microsoft Access на основе данных списка Microsoft Excel

Создание отчета Microsoft Access на основе данных списка Microsoft Excel

Для создания отчета Microsoft Access необходимо наличие на компьютере Microsoft Access. Если команда Отчет MS Access отсутствует в меню Данные Microsoft Excel, в системе следует установить надстройку AccessLinks. Для получения дополнительных сведений нажмите кнопку [image] .

  1. Укажите ячейку из списка.

  2. Выберите команду Отчет MS Access в меню Данные.

  3. Если Microsoft Excel сообщит о необходимости сохранения книги, нажмите кнопку Сохранить [image] ., а затем снова выберите команду Отчет MS Access в меню Данные.

  4. Чтобы создать отчет в новой базе данных Access, выберите параметр В новой базе данных.

    Чтобы создать отчет в существующей базе данных Access, установите переключатель В имеющейся базе данных, а затем введите полный путь до базы данных в поле под переключетелем В имеющейся базе данных. Для поиска файла воспользуйтесь кнопкой Обзор.

  5. Нажмите кнопку OK и следуйте инструкциям мастера отчета Access. Не изменяйте предлагаемые мастером имена таблицы и отчета.

Примечания

  • Для повторного просмотра отчета нажмите кнопку Отчет MS Accesst, которую AccessLinks помещает на листе сверху от списка. Дополнительную информацию об отчете и мастере отчета Access можно получить из справки по Access.

  • Если список Excel изменяется или к нему добавляются данные, эти изменения не отражаются в отчете. Для включения изменений и новых данных необходимо создать новый отчет. Сначала удалите кнопку Отчет MS Accesst. Для этого, удерживая нажатой клавишу CTRL key, щелкните кнопку и затем нажмите клавишу DELETE. После этого повторите последовательность действий, описанную в данном разделе, для создания нового отчета.


 Присваивание ячейкам имени в нескольких листах при помощи трехмерной ссылки

Присваивание ячейкам имени в нескольких листах при помощи трехмерной ссылки

  1. Выберите команду Имя в меню Вставка, а затем — команду Присвоить.

    Демонстрация

  2. Введите имя в диалоговом окне Присвоить имя.

  3. Если в поле Формула содержится ссылка, выделите ссылку вместе со знаком равенства (=) и нажмите клавишу BACKSPACE.

  4. Введите знак равенства (=) в поле Формула.

  5. Укажите ярлычок первого листа, на который нужно сослаться.

  6. Удерживая нажатой клавишу SHIFT, укажите последний лист, на который необходимо сослаться.

  7. Укажите диапазон ячеек, на которые необходимо сослаться.


 Откладывание доставки сообщения

Откладывание доставки сообщения

Эта возможность доступна только для Microsoft Exchange Server.

Требования, которым должна удовлетворять система для отправки документов

  1. Откройте в Microsoft Excel лист, который следует отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Параметры.

  5. В группе Параметры отправки установите флажок Не доставлять до, а затем введите нужную дату доставки.


 Удаление области данных из итоговой таблицы

Удаление области данных из итоговой таблицы

  1. Выделите верхнюю левую ячейку существующей итоговой таблицы.

  2. В меню Данные выберите команду Консолидация.

    Демонстрация

  3. В списке Список диапазонов укажите исходную область, которую следует удалить.

  4. Нажмите кнопку Удалить.

  5. Чтобы пересчитать итоговую таблицу, нажмите кнопку OK.

    Чтобы сохранить новый набор исходных областей без пересчета итоговой таблицы, нажмите кнопку Закрыть.


Удаление ячеек, строк и столбцов

  1. Выделите ячейки, строки и столбцы, которые следует удалить.

  2. В меню Правка выберите команду Удалить.

    Соседние ячейки сместятся, чтобы заполнить освободившееся место.

Примечание. Microsoft Excel обновляет формулы, содержащие абсолютные ссылки на перемещенные ячейки, с учетом их нового расположения. Формула, которая ссылается на удаленную ячейку, возвращает значение ошибки #ССЫЛКА!.


Отображение и скрытие подробных данных для категорий в отчете сводной диаграммы

  1. Щелкните правой кнопкой мыши подпись оси категорий, сектор (в круговой диаграмме) или кольцо (в кольцевой диаграмме), подробные данные для которых должны быть отображены или скрыты.

  2. В контекстном меню выберите Отобразить детали название категории или Скрыть детали название категории.

    При появлении диалогового окна дважды щелкните поле, для которого необходимо показать подробные данные.

Примечания

  • Некоторое форматирование отчета сводной диаграммы, включая линии тренда и планки погрешностей, могут не сохраняться при скрытии и отображении подробных данных.

  • Для скрытия и отображения различных уровней детализации для отчетов сводных диаграмм, построенных на исходных данных OLAP, можно использовать другую процедуру.


 Отображение и скрытие осей в диаграмме

Отображение и скрытие осей в диаграмме

Скрытие оси приводит к скрытию подписей делений оси. В круговой и кольцевой диаграммах осей нет.

  1. Выберите диаграмму, на которой необходимо отобразить или скрыть оси.

  2. В меню Диаграмма выберите команду Параметры диаграммы, а затем перейдите к вкладке Оси.

  3. Установите флажки для осей, которые необходимо отобразить.

    Снимите флажки для осей, которые необходимо скрыть.


 Отображение или скрытие таблицы данных в диаграмме

Отображение или скрытие таблицы данных в диаграмме

Таблицы данных могут быть отображены в линейчатой диаграмме, графике, заполненной диаграмме и гистограмме. В линейчатых диаграммах таблицы данных не замещают оси, но выравниваются по диаграмме.

  1. Выберите диаграмму, в которую необходимо добавить таблицу данных.

  2. В меню Диаграмма выберите команду Параметры диаграммы, а затем перейдите к вкладке Таблица данных.

  3. Для отображения данных диаграммы в сетке внизу диаграммы установите флажок Таблица данных.

    Для скрытия таблицы данных снимите флажок.

Примечание. Для присоединения таблицы данных к оси категорий в объемной диаграмме в меню Диаграмма выберите команду Объемный вид, а затем установите флажок Перпендикулярные оси.


 Отображение сообщения при вводе неправильных данных

Отображение сообщения при вводе неправильных данных

Чтобы получить более подробные сведения об определении ограничений на данные, нажмите кнопку [image] .

  1. Выделите ячейки, при вводе в которые будет отображаться сообщение.

  2. Выберите команду Проверка в меню Данные, а затем откройте вкладку Параметры.

  3. Укажите ограничения на данные, при нарушении которых будет отображаться сообщение.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  4. Выберите вкладку Сообщение об ошибке.

  5. Убедитесь, что установлен флажок Выводить сообщение об ошибке.

  6. Укажите тип сообщения в поле Вид.

    Чтобы отображать информационное сообщение, включающее кнопки OK и Отмена (кнопка OK используется по умолчанию), выберите Сообщение.

    Чтобы отображать предупреждение, содержащее запрос о продолжении и кнопки Да, Нет и Отмена (кнопка Нет используется по умолчанию), выберите Предупреждение.

    В сообщениях обоих типов с помощью кнопок OK и Да производится ввод некорректных данных в ячейку. Кнопка Нет позволяет исправить содержимое ячейки. Кнопка Отмена возвращает в ячейку старое значение.

    Чтобы отображать сообщение об остановке, включающее кнопки Повторить и Отмена(кнопка Повторить используется по умолчанию) , выберите Останов.

  7. Если заголовок должен появляться в области заголовка сообщения или в окне Помощника (если он отображен), введите текст в поле Заголовок. Если поле Заголовок пусто, появляется стандартный заголовок Microsoft Excel.

  8. Чтобы создать собственное сообщение, введите текст, содержащий до 255 символов, в поле Сообщение. Нажмите клавишу ENTER, чтобы начать следующую строку сообщения. Если поле Сообщение не содержит никакого текста, то на экране появится сообщение "Введенное значение неверно. Набор значений, которые могут быть введены в ячейку, ограничен".

Примечание. Сообщение отображается только тогда, когда данные в ячейку вводит пользователь. Если некорректные данные были получены по формуле, помещены в ячейку макросом, скопированы или получены с помощью автозаполнения, сообщение об ошибке не выводится.


 Отображение сообщения для ввода при переходе к ячейке

Отображение сообщения для ввода при переходе к ячейке

  1. Выделите ячейки, при использовании которых будет отображаться сообщение.

  2. Выберите команду Проверка в меню Данные, а затем — вкладку Сообщение для ввода.

  3. Убедитесь, что установлен флажок Отображать подсказку, если ячейка является текущей.

  4. Чтобы снабдить сообщение заголовком, имеющим полужирное начертание, введите текст в поле Заголовок.

  5. Введите текст сообщения, содержащий до 255 символов, в поле Сообщение. Нажмите клавишу ENTER, чтобы начать следующую строку сообщения.

    Чтобы сообщение выводилось на экран, необходимо ввести текст в поле Сообщение.


 Изменение элемента поля страницы, отображаемого в отчете сводной таблицы или сводной диаграммы

Изменение элемента поля страницы, отображаемого в отчете сводной таблицы или сводной диаграммы

  1. Нажмите кнопку со стрелкой Стрелка поля рядом с отображаемым элементом поля страницы.

  2. В сводной таблице и отчете сводной диаграммы, основанных на исходных данных из базы данных OLAP, может потребоваться нажимать кнопку Поле плюс рядом с уровнем (для формирования списка элементов нижнего уровня) или кнопку Поле минус (для отображения элементов более высокого уровня) до появления в списке интересующего элемента.

  3. Выберите из списка элемент, который нужно отобразить, и нажмите кнопку OK.

Примечание. При изменении элемента поля страницы в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые форматирования диаграммы могут быть потеряны.


 Отображение страниц поля страницы сводной таблицы на отдельных листах

Отображение страниц поля страницы сводной таблицы на отдельных листах

Эта процедура недоступна для отчетов сводных таблиц, основанных на исходных данных из базы данных OLAP.

  1. Выделите мышью ячейку отчета сводной таблицы.

  2. На панели инструментов Сводные таблицы нажмите кнопку Сводная таблица и затем выберите команду Отобразить страницы.

  3. Выберите поле страницы, для элементов которого следует сформировать отдельные листы.

Примечание. Microsoft Excel вставляет новый лист для каждого элемента поля страницы. Эти листы не используют никаких существующих шаблонов.


 Вставка или удаление промежуточных итогов в отчете сводной таблицы

Вставка или удаление промежуточных итогов в отчете сводной таблицы

Промежуточные итоги автоматически отображаются для последнего поля строки и поля столбца, если в сводной таблице создано несколько полей строк или столбцов. Для внутренних полей промежуточные итоги отображаются, если они были добавлены.

  1. Дважды щелкните кнопку поля, в которое необходимо поместить или из которого следует удалить промежуточные итоги.

  2. Выполните одно из следующих действий:

    Чтобы отображать промежуточные итоги для последнего поля строки или столбца, установите переключатель Итоги в положение автоматические.

    Чтобы отображать промежуточные итоги для внутренних полей, установите переключатель Итоги в положение другие и в списке справа выберите итоговую функцию. Для отчетов сводных таблиц, построенных на исходных данных из базы данных OLAP, отсутствует возможность установить переключатель в положение другие.

    Чтобы удалить промежуточные итоги, установите переключатель Итоги в положение нет.

  3. Чтобы отобразить несколько промежуточных итогов, выберите итоговые функции в списке справа от переключателя другие. См. описание доступных итоговых функций.

    В отчетах сводных таблиц, основанных на исходных данных из базы данных OLAP, итоговая функция для промежуточных итогов не может быть изменена.

Примечания

  • Итоговые функции в отчетах сводных таблиц, основанных на не-OLAP исходных данных, итоги и промежуточные итоги используют ту же самую стандартную итоговую функцию, что используется для суммирования полей данных. Итоговая функция для промежуточных итогов может быть указана только в том случае, когда суммируемое поле не содержит вычисляемого элемента.

  • Множественные промежуточные итоги Для каждой выбранной итоговой функции добавляется одна строка промежуточных итогов.

  • Включение скрытых элементов поля страницы Чтобы включить в промежуточные итоги скрытые элементы поля страницы, нажмите кнопку Сводная таблица на панели инструментов Сводная таблица, выберите команду Параметры таблицы. Установите флажок Включать скрытые значения в группе Формат. Этот параметр недоступен для отчетов сводных таблиц, основанных на исходных данных из базы данных OLAP.


 Ввод формулы

Ввод формулы

Для получения дополнительных сведений о вычислении значений в формулах нажмите кнопку [image] .

  1. Укажите ячейку, в которую необходимо ввести формулу.

  2. Введите = (знак равенства).

    Если нажать кнопку Изменить формулу Кнопка Изменить формулу или Вставка функции [image] , автоматически вставляется знак равенства.

  3. Введите формулу.

  4. Нажмите клавишу ENTER.

Советы

  • Одну и ту же формулу можно ввести сразу в несколько ячеек. Для этого необходимо выделить ячейки, ввести формулу, а затем нажать клавиши CTRL+ENTER.

  • Формула может быть введена в диапазон ячеек с помощью операций вставки-копирования. Для получения дополнительных сведений по копированию формулы нажмите кнопку [image] .


 Поиск ошибки прекращается преждевременно

Поиск ошибки прекращается преждевременно

При нажатии кнопки Источник ошибки [image] Microsoft Excel прекращает поиск источника ошибки в точке ветвления, если существуют несколько наборов зависимых ячеек. Чтобы продолжить поиск, еще раз нажмите кнопку Источник ошибки [image] .

Если формула, возвращающая ошибку, содержит ссылку на другой лист или книгу, дважды щелкните стрелку, проведенную от значка листа значок листа. В списке Перейти к дважды щелкните ссылку, которую нужно найти. Затем еще раз щелкните Источник ошибки [image] again.


 Выделение текущей смежной области

Выделение текущей смежной области

Эта процедура позволяет выделить текущую область, например список.

  1. Укажите любую ячейку диапазона данных.

  2. В меню Правка выберите команду Перейти.

    Демонстрация

  3. Нажмите кнопку Выделить.

  4. Установите переключатель в положение Текущую область.

Совет. Чтобы выделить текущую область в пределах строки или столбца, укажите первую или последнюю ячейку диапазона. Затем, удерживая клавишу SHIFT, дважды щелкните ту границу текущей ячейки, в направлении которой необходимо сделать выделение. Например, чтобы выделить содержащий данные диапазон, расположенный над текущей ячейкой, дважды щелкните верхнюю сторону этой ячейки. Обратите внимание на то, что выделение диапазона происходит только до ближайшей пустой ячейки в строке или столбце.


 Поиск текста и чисел

Поиск текста и чисел

  1. Выделите диапазон ячеек, в котором будет проводиться поиск.

    Чтобы провести поиск по всему листу, щелкните любую ячейку.

  2. В меню Правка выберите команду Найти.

  3. В поле Что введите текст или числа, которые нужно найти.

  4. В списке Область поиска выберите тип данных, среди которых будет производиться поиск.

  5. Выберите команду Найти далее.

Примечание. Чтобы остановить поиск, нажмите клавишу ESC.


 Создание независимого отчета сводной таблицы по тем же данным, что и отчет сводной диаграммы

Создание независимого отчета сводной таблицы по тем же данным, что и отчет сводной диаграммы

Когда создается отчет сводной диаграммы, Microsoft Excel автоматически создает связанный отчет сводной таблицы, который отражает все изменения, внесенные в диаграмму. Независимый отчет сводной таблицы не связан с диаграммой. На таблице не сказываются изменения представления в диаграмме, и можно изменить представление в отчете сводной таблицы, не оказывая влияние на диаграмму.

Если в книге расположены несколько отчетов сводных диаграмм, можно определить отчет сводной таблицы, связанный с диаграммой, выбрав команду Параметры в меню Сводная диаграмма (панель инструментов Сводная таблица). Название связанного отчета сводной таблицы отобразится в поле Имя.

  1. Откройте книгу, содержащую отчет сводной диаграммы, и выделите лист .

  2. Выберите команду Сводная таблица в меню Данные.

  3. На шаге 1 мастера сводных таблиц и сводных диаграмм установите переключатель создать таблицу на основе данных, находящихся в значение в другой сводной таблице или диаграмме , затем установите переключатель Вид создаваемого отчета в значение сводная таблица.

  4. На шаге 2 щелкните имя отчета, связанного с диаграммой, для которой будет создаваться независимый отчет сводной таблицы.

  5. На шаге 3 решите, нужно ли нажимать кнопку Макет.

  6. Выполните одно из следующих действий:

    Если на шаге 3 была нажата кнопка Макет, выполните формирование макета отчета сводной таблицы, нажмите кнопку OK в диалоговом окне Мастер сводных таблиц и диаграмм – Макет и затем нажмите Готово для создания отчета сводной диаграммы.

    Если кнопка Макет на шаге 3 не была нажата, нажмите кнопку Готово, а затем сформируйте макет отчета на листе.


 Отображение заголовков строк и столбцов при прокрутке листа

Отображение заголовков строк и столбцов при прокрутке листа

  1. Чтобы закрепить верхнюю горизонтальную область, укажите строку, над которой требуется разбить лист.

    Чтобы закрепить левую вертикальную область, укажите столбец, слева от которого требуется разбить лист.

    Чтобы закрепить обе области, укажите ячейку, расположенную слева и выше того места, где требуется разбить лист.

  2. В меню Окно выберите команду Закрепить области.


 Создание сложного запроса в Microsoft Query

Создание сложного запроса в Microsoft Query

  1. Укажите ячейку, с которой будет начинаться диапазон внешних данных.

    Для того чтобы убедиться, что внешние данные не заменят существующие данные, проверьте отсутствие данных на листе ниже и правее выбранной ячейки.

  2. В меню Данные выберите команду Внешние данные и затем — Создать запрос.

  3. На вкладке Базы данных выберите базу данных, из которой будут импортированы данные, или создайте новый источник данных.

    Инструкции

  4. Снимите флажок Использовать мастер запросов и нажмите кнопку OK.

  5. Добавьте нужные таблицы. Более подробные сведения можно найти в справке по Microsoft Query.

  6. Внесите поля, которые вы хотите получить в таблице результатов. Более подробные сведения можно найти в справке по Microsoft Query.

    Чтобы сузить таблицу результатов, введите выражения и условия для фильтрации данных. Более подробные сведения можно найти в справке по Microsoft Query.

    Чтобы создать запрос с параметрами, при запуске которого требуется условие, укажите это параметр.

    Инструкции

    Чтобы изменить таблицу результатов, нужно установить внутреннее объединение или внешнее объединение таблиц. Более подробные сведения можно найти в справке по Microsoft Query.

  7. Чтобы передать таблицу результатов в Microsoft Excel, нажмите кнопку Вернуть данные [image] .

    На экране появится диалоговое окно Возврат данных в Microsoft Excel.

  8. Выберите Свойства, чтобы установить параметры форматирования и вида при передаче диапазона внешних данных в Microsoft Excel. Чтобы получить более подробные сведения, нажмите кнопку [image] .

  9. Чтобы передать внешний диапазон данных в место, выбранное на шаге 1, нажмите кнопку Имеющийся лист и затем кнопку OK.

    Чтобы поместить диапазон внешних данных на новый лист, выберите Новый лист и нажмите кнопку OK. Microsoft Excel добавит новый лист в вашу книгу и автоматически поместит диапазон внешних данных в левый верхний угол листа.

    чтобы использовать внешние данные в отчете сводной таблицы, выберите Отчет сводной таблицы, нажмите кнопку OK и следуйте указаниям мастера сводных таблиц и сводных диаграмм.

Примечание.. Чтобы проверить состояние фонового запроса, длительное время не возвращающего данные, нажмите кнопку Состояние обновления [image] на панели инструментов Внешние данные. Чтобы отменить запрос, выберите Отменить обновление.


 Получение внешних данных с помощью мастера запросов

Получение внешних данных с помощью мастера запросов

  1. Укажите ячейку, с которой будет начинаться диапазон внешних данных.

  2. В меню Данные выберите команду Внешние данные и затем — Создать запрос.

  3. Установите флажок Использовать мастер запросов.

  4. На вкладке Базы данных выберите базу данных, из которой будут импортированы данные.

    Чтобы настроить новый источник данных, дважды щелкните Новый источник данных, а затем укажите источник данных.

  5. Выполните указания мастера запросов.

  6. В диалоговом окне Мастер запросов — Готово выполните одну из следующих операций:

    Чтобы непосредственно передать данные в Microsoft Excel, выберите Вернуть данные в Microsoft Excel, затем Готово и укажите, куда нужно поместить эти данные.

    Чтобы сохранить запрос в файле запроса (.dqy), который можно открыть и выполнить в Excel или открыть и отредактировать в Microsoft Query, нажмите кнопку Сохранить запрос. Этот необязательный шаг рекомендуется выполнить, если предполагается создание куба OLAP по зпросу.

    Для запуска мастера куба OLAP, с помощью которого по результатам запроса может быть создан куб, нажмите кнопку Создание куба OLAP из данного запроса, затем — Готово и выполняйте инструкции мастера куба OLAP. Рекомендуется использовать эту возможность только опытным пользователям. См. создание куба OLAP.

    Для уточнения запроса нажмите кнопку Просмотр или изменение данных в Microsoft Query, а затем — кнопку Готово. Таблица результатов отображается в Query, где можно внести изменения, сохранить файл запроса, создать куб OLAP или вернуть таблицу результатов в Excel. Более подробную информацию можно получить из справки по Microsoft Query.

Примечания

  • Чтобы проверить состояние фонового запроса, длительное время не возвращающего данные, нажмите кнопку Состояние обновления [image] на панели инструментов Excel Внешние данные. Чтобы отменить запрос, выберите Отменить обновление.

  • См. сведения о видах запросов, которые позволяет создать мастер запросов.


Получение информации об установке Microsoft Outlook

  • В меню Справка выберите пункт О программе...

    В диалоговом окне появится информация об установке: режим только электронной почты Internet или "корпоративная или для рабочих групп".


 Группировка и разгруппировка дат и времени в поле сводной таблицы или сводной диаграммы

Группировка и разгруппировка дат и времени в поле сводной таблицы или сводной диаграммы

Даты и время в отчетах сводных таблиц или сводных диаграмм, основанных на исходных данных OLAP, не могут быть сгруппированы.

Чтобы сгруппировать даты и время, выполните следующие действия:

  1. Щелкните правой кнопкой мыши поле, содержащее элементы даты и времени, которые нужно сгруппировать, укажите Группа и Структура в контекстном меню и затем нажмите Группировать.

  2. В поле Начиная с введите начальное значение, а в поле по —конечное значение, если это необходимо.

  3. В списке с шагом выберите один или несколько временных интервалов для задания шага, с которым будут создаваться группы.

    Чтобы сгруппировать элементы по неделям, выберите Дни в поле с шагом, убедитесь в том, что Дни — это единственный выбранный временной интервал, укажите 7 в поле Число дней. После этого, если необходимо, можно выбрать дополнительные промежутки времени для группировки, например Месяцы.

Примечания

  • Разгруппирование дат и времени. Щелкните группу правой кнопкой мыши, выберите Группа и Структура в контекстном меню, затем выберите Разгруппировать. При выполнении команды разгруппирования дат и времени разгруппировываются все группы в поле; разгруппировать отдельную группу невозможно.

  • Влияние на связанные отчеты сводных диаграмм. При группировании и разгруппировании данных в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые some форматирования в отчете сводных диаграмм могут быть потеряны.


 Группировка и разгруппировка элементов поля страницы сводной таблицы или сводной диаграммы

Группировка и разгруппировка элементов поля страницы сводной таблицы или сводной диаграммы

Элементы отчетов сводных таблиц или сводных диаграмм, основанных на базе данных OLAP, не могут быть сгруппированы.

Чтобы сгруппировать элементы поля страницы, выполните следующие действия:

  1. Если сводная таблица или отчет сводной диаграммы созданы из внешнего источника данных, проверьте, что в поле страницы осуществляется выборка внешних данных для всех элементов поля одновременно.

    Инструкции

  2. Перетащите с помощью мыши выбранное поле страницы в область полей строк или полей столбцов, чтобы элементы поля страницы стали подписями строк или столбцов. Для отчета сводной диаграммы перетащите поле в связанном отчете сводной таблицы.

  3. Выделите группируемые элементы.

  4. Щелкните правой кнопкой мыши выбранные элементы, выберите Группа и структура в контекстном меню и затем укажите Группировать.

  5. Перетащите группируемое поле в область страничной ориентации.

Примечания

  • Разгруппирование элементов поля страницы Перетащите сгруппированное поле страницы в область полей строк или область полей столбцов, щелкните группу правой кнопкой мыши , укажите Группа и Структура в контекстном меню, затем выберите Разгруппировать. После этого поле может быть возвращено в область полей страниц.

  • Влияние на связанные отчеты сводных диаграмм. При группировании и разгруппировании данных в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые форматирования в отчете сводных диаграмм могут быть потеряны.


 Группировка и разгруппировка числовых элементов поля сводной таблицы или сводной диаграммы

Группировка и разгруппировка числовых элементов поля сводной таблицы или сводной диаграммы

Элементы отчетов сводных таблиц или сводных диаграмм, основанных на базе данных OLAP, не могут быть сгруппированы.

Чтобы сгруппировать числовые элементы, выполните следующие действия:

  1. Щелкните правой кнопкой мыши поле, содержащее числовые элементы, которые нужно сгруппировать, укажите Группа и Структура в контекстном меню и затем нажмите Группировать.

  2. В поле Начиная с введите начальное значение, если это необходимо.

  3. В поле по введите конечное значение, если это необходимо.

  4. В поле с шагом введите значение интервала, с которым будут создаваться группы чисел.

Примечания

  • Разгруппирование чисел. Щелкните группу правой кнопкой мыши, выберите Группа и Структура в контекстном меню, затем выберите Разгруппировать. При выполнении команды разгруппирования чисел разгруппировываются все группы; разгруппировать отдельную группу невозможно.

  • Влияние на связанные отчеты сводных диаграмм. При группировании и разгруппировании данных в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые some форматирования в отчете сводных диаграмм могут быть потеряны.


 Группировка и разгруппировка элементов поля сводной таблицы или сводной диаграммы

Группировка и разгруппировка элементов поля сводной таблицы или сводной диаграммы

Элементы отчетов сводных таблиц или сводных диаграмм, основанных на исходных данных OLAP, не могут быть сгруппированы.

Чтобы сгруппировать элементы, выполните следующие действия:

  1. Выберите элементы, которые нужно сгруппировать. Для отчета сводной диаграммы выберите элементы связанного отчета сводной таблицы.

    Инструкции

  2. Щелкните правой кнопкой мыши выбранные элементы, выберите Группа и структура в контекстном меню и затем укажите Группировать.

    Создается новый элемент, который объединяет выбранные элементы, и в отчет сводной таблицы добавляется поле группы.

Примечания

  • Разгруппирование набора элементов Щелкните группу правой кнопкой мыши, выберите Группа и Структура из контекстного меню, затем выберите Разгруппировать. Нельзя разгруппировать отдельный набор чисел, дат или времен, сгруппированных одновременно; разгруппировываются все наборы в поле.

  • Разгруппирование последней группы в поле Если разгруппирован последний элемент в поле строки или поле столбца, поле группы удаляется из отчета сводной таблицы.

  • Влияние на связанные отчеты сводных диаграмм. При группировании и разгруппировании данных в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые форматирования в отчете сводных диаграмм могут быть потеряны.


 Пересылка ответов на сообщение другим пользователям

Пересылка ответов на сообщение другим пользователям

Требования, которым должна удовлетворять система для отправки документов

  1. Откройте в Microsoft Excel книгу или лист, который следует отправить в качестве вложения.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Выберите Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Параметры.

  5. В группе Параметры отправки установите флажок Отправлять ответы.

  6. Введите имя другого пользователя или нажмите кнопку Выбор имен, чтобы выбрать имя из списка.

Примечание. Отправлять ответы по личному списку рассылки нельзя.


 Изменение цветов текста и цвета фона разделов справки

Изменение цветов текста и цвета фона разделов справки

  1. На панели инструментов окна справки нажмите кнопку Параметры [image] и выберите Параметры Интернета.

  2. На вкладке Общие нажмите кнопку Оформление.

  3. Установите флажок Не учитывать цвета, указанные на веб-страницах, а затем нажмите кнопку OK.

  4. На вкладке Общие нажмите кнопку Цвета и выберите нужные параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

    Для того чтобы установить собственные цвета текста и фона, снимите флажок Использовать цвета, установленные в Windows.

Примечание. Установленные цвета будут действовать для отображения справки во всех приложениях Microsoft Office, а также Web-страниц, просматриваемых в обозревателе.


 Изменение шрифта разделов справки

Изменение шрифта разделов справки

  1. На панели инструментов окна справки нажмите кнопку Параметры [image] и выберите Параметры Интернета.

  2. На вкладке Общие нажмите кнопку Оформление.

  3. Установите флажок Не учитывать шрифты, указанные на веб-страницах, а затем нажмите кнопку OK.

  4. На вкладке Общие нажмите кнопку Шрифты и выберите нужные параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

Примечание. Установленный шрифт будет использоваться для отображения справки во всех приложениях Microsoft Office, а также Web-страниц, просматриваемых в обозревателе.


 Изменение размеров текста разделов справки

Изменение размеров текста разделов справки

Текст разделов справки нельзя сделать мельче стандартного размера. Для увеличения размера текста разделов справки используется следующая процедура.

  1. Установите в Web-обозревателе нужный размер текста для отображения Web-страниц. Для получения инструкций см. справку обозревателя.

  2. На панели инструментов окна справки нажмите кнопку Параметры [image] и выберите Параметры Интернета.

  3. На вкладке Общие нажмите кнопку Оформление.

  4. Установите флажок Не учитывать шрифты, указанные на веб-страницах, а затем нажмите кнопку OK.


 Отображение или скрытие данных в отчете сводной таблицы

Отображение или скрытие данных в отчете сводной таблицы

Данная процедура недоступна для отчетов сводных таблиц, источником данных для которых служат базы данных OLAP. В таких отчетах сводных таблиц возможно отображение и скрытие различных уровней детализации.

  1. Выделите элемент поля, детальные данные которого необходимо скрыть или показать.

    Инструкции

  2. Нажмите кнопку Отобразить детали [image] или Скрыть детали [image] на панели инструментов Сводные таблицы.

    При появлении диалогового окна выберите поле, для которого необходимо показать детали.

Примечания

  • Если требуется отобразить детали базового источника данных для ячейки отчета сводной таблицы, дважды щелкните эту ячейку. Microsoft Excel поместит детальные данные, обобщаемые в ячейке, на новый лист рабочей книги.

  • При отображении или скрытии деталей в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые параметры форматирования диаграммы могут быть утрачены.


 Отображение или скрытие общих итогов в отчете сводной таблицы

Отображение или скрытие общих итогов в отчете сводной таблицы

  1. Щелкните ячейку отчета сводной таблицы.

  2. На панели инструментов Сводные таблицы нажмите кнопку Сводная таблица и выберите команду Параметры таблицы.

  3. Для того чтобы отобразить общие итоги, установите в группе Формат флажок Общая сумма по столбцам, флажок Общая сумма по строкам, или оба этих флажка.

    Для скрытия общих итогов снимите эти флажки.

Примечание. В отчетах сводных таблиц, основанных на не-OLAP исходных данных, итоги и промежуточные итоги используют ту же стандартную итоговую функцию, которая используется для суммирования полей данных. Итоговая функция для промежуточных итогов может быть указана только в том случае, если суммируемое поле не содержит вычисляемого элемента. В отчетах сводных таблиц, основанных на исходных данных OLAP, доступность функций суммирования определяется сервером OLAP.


 Отображение или скрытие элементов поля сводной таблицы или сводной диаграммы

Отображение или скрытие элементов поля сводной таблицы или сводной диаграммы

Данная процедура используется для отображения или скрытия элементов полей строк и столбцов в отчете сводной таблицы либо элементов полей категорий и рядов в отчете сводной диаграммы. Для отображения или скрытия элементов полей страниц используется другая процедура.

  1. Щелкните стрелку Стрелка поля справа от поля, элементы которого требуется скрыть или отобразить.

  2. Установите флажки для тех элементов, которые требуется отобразить, и снимите флажки для тех элементов, которые требуется скрыть.

    Для отчетов сводных таблиц и сводных диаграмм, основанных на исходных данных OLAP, двойная галочка ( Двойная галочка ) рядом с уровнем указывает на то, что выбраны некоторые или все элементы на нижних уровнях. Для отображения всех элементов нижних уровней выберите нужный уровень, а затем отобразите или скройте отдельные элементы нижних уровней. Для скрытия всех элементов нижних уровней снимите флажок текущего уровня. Для просмотра списка элементов нижних уровней щелкните значок Плюс рядом с уровнем. Список позволяет отображать и скрывать элементы по отдельности. Последовательными щелчками флажка устанавливается одна галочка, затем вторая, а затем флажок снимается.

  3. Для того чтобы отобразить или скрыть элементы, не содержащие данных, дважды щелкните нужное поле, а затем установите или снимите флажок Отображать пустые элементы в диалоговом окне Вычисление поля сводной таблицы.

    Например, если в апреле продаж не было, элемент продаж за апрель будет отображаться только при отображении пустых элементов.

    Этот параметр недоступен для отчетов сводных таблиц и сводных диаграмм, основанных на исходных данных из баз данных OLAP.

Примечания

  • Скрытые элементы в общих и промежуточных итогах. Общие и промежуточные итоги в отчете сводной таблицы или сводной диаграммы могут включать или не включать скрытые элементы. См. сведения о том, как вычисляются общие и промежуточные итоги.

  • Скрытие элементов не меняет исходные данные. Скрытие данных в отчете сводной таблицы или сводной диаграммы не влияет на исходные данные.

  • Влияние на отображение максимальных или минимальных элементов. Для отчетов сводных таблиц или сводных диаграмм, основанных на исходных данных из баз данных OLAP, при изменении элементов, выбранных для отображения, сбрасывается отображение максимальных или минимальных элементов, и вместо них отображаются выбранные элементы.

  • Влияние на связанные отчеты сводных диаграмм. При отображении или скрытии элементов в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые параметры форматирования в отчете сводной диаграммы могут быть утрачены.


Расчет значений с помощью формул (построение формулы)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Расчет значений с помощью формул (ссылки на ячейки)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Расчет значений с помощью формул (применение функций)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Назначение гиперссылки кнопке панели инструментов или команде меню

Гиперссылка, назначаемая кнопке панели инструментов или команде меню, заменяет текущую команду, назначенную этой кнопке или команде меню. Гиперссылку нельзя назначить кнопке, по нажатию которой открывается список или меню.

  1. Отобразите панель инструментов, которую требуется изменить.

  2. Выберите команду Настройка в меню Сервис.

  3. Если панель инструментов, содержащая требуемую кнопку, не отображается на экране, перейдите на вкладку Панели инструментов и установите флажок рядом с названием этой панели.

    Если команда меню, которой требуется назначить гиперссылку, находится не на панели инструментов, добавьте ее в меню.

  4. Если кнопка, которой требуется назначить гиперссылку, находится не в меню, перейдите на вкладку Команды, а затем выберите Макросы в списке Категории. Перетащите элемент Настраиваемая кнопка из списка Команды на панель инструментов.

  5. Щелкните правой кнопкой мыши кнопку панели инструментов или команду меню, в контекстном меню откройте подменю Назначить гиперссылку и выберите команду Открыть.

  6. В области Связать с выберите источник, на который нужно создать ссылку.

  7. Выберите нужные параметры.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.


 Графический или рисованный объект не перемещается вместе с внедренной диаграммой, в которую он был добавлен

Графический или рисованный объект не перемещается вместе с внедренной диаграммой, в которую он был добавлен

Перед добавлением фигуры или графический объект следует выделить внедренную диаграмму. В противном случае фигура или графический объект будет добавлен на лист Excel, а не в диаграмму. Щелкните внедренную диаграмму, выполните требуемую команду панели инструментов Рисование, а затем щелкните диаграмму.


 Не удается найти нужное меню, команду, кнопку панели инструментов, вкладку или параметр диалогового окна

Не удается найти нужное меню, команду, кнопку панели инструментов, вкладку или параметр диалогового окна

Выделите диаграмму или элемент диаграммы. Меню Диаграмма и панель инструментов Диаграммы появляются при выделении элемента внедренной диаграммы или по щелчку ярлычка листа в нижней части окна книги для перехода на лист диаграммы.

Отобразите панель инструментов «Диаграммы». Если Microsoft Excel не выводит на экран панель инструментов Диаграммы после выделения элемента диаграммы или листа диаграммы, выберите в меню Вид команду Панели инструментов, а затем установите флажок Диаграммы. Если при появлении на экране панель инструментов не содержит нужной кнопки, нажмите кнопку Другие кнопки [image] на этой панели инструментов. Для получения справки о каком-либо параметре нажмите клавиши SHIFT+F1, а затем щелкните нужный параметр.

Посмотрите, какой элемент диаграммы выделен. Название соответствующей команды меню Формат зависит от того, какой элемент диаграммы выделен. Например, если выделен ряд данных, первой в меню Формат будет команда Выделенный ряд. Кроме того, можно дважды щелкнуть элемент диаграммы для просмотра его параметров форматирования. См. сведения о способах выделения элементов диаграммы.


Не удается развернуть или закрыть окно книги

Кнопки Развернуть и Закрыть не отображаются на защищенных окнах.

Для того чтобы снять защиту, откройте в меню Сервис подменю Защита и выберите команду Снять защиту книги. В случае появления запроса введите пароль. (Если запрашивается пароль, то, не зная его, снять защиту нельзя.)

Для того чтобы защитить книгу, не защищая окон, можно ограничить изменения всей книги, не выбирая защиту окна.


 Не отображаются макросы в книге или надстройке, открытой в Excel 97

Не отображаются макросы в книге или надстройке, открытой в Excel 97

Макросы могли быть снабжены цифровой подписью в редакторе Visual Basic в Microsoft Excel 2000. Excel 97 не распознает цифровые подписи и не может обновить подпись при изменении подписанного макроса на языке Visual Basic для приложений. Поэтому, в целях предотвращения изменений, просмотр в Excel 97 кода макросов, снабженных цифровой подписью в Excel 2000, невозможен.


При открытии шаблона Excel выводится предупреждение о наличии макровируса

Microsoft Excel не рассматривает шаблоны Excel в качестве надежных источников. При открытии шаблона, поставляемого с Excel, предупреждение о макровирусе выводится даже в том случае, если на вкладке Надежные источники установлен флажок Доверять всем установленным надстройкам и шаблонам, а на вкладке Уровень безопасности выбран параметр Высокая или Средняя (меню Сервис, подменю Макрос, команда Безопасность).

Для предотвращения вывода предупреждения о вирусах можно установить низкий уровень безопасности, но сначала следует убедиться в том, что все книги, которые потенциально могут быть открыты, безопасны и не содержат вирусов.


 Открытие текстового файла в Microsoft Excel

Открытие текстового файла в Microsoft Excel

  1. Нажмите кнопку Открыть [image] .

  2. В поле Папка выберите диск, папку или адрес ресурса Интернета, содержащего нужный файл.

  3. В поле Тип файла выберите Текстовые файлы.

  4. Дважды щелкните файл, который требуется импортировать.

  5. Следуйте инструкциям мастера текстов для указания способа разбиения текста на столбцы.

Примечание. См. инструкции по импорту текстового файла в обновляемый диапазон данных Microsoft Excel


 Ввод формулы, содержащей функцию

Ввод формулы, содержащей функцию

  1. Щелкните ячейку, в которую требуется ввести формулу.

  2. Для того чтобы начать формулу с функции, нажмите кнопку Изменить формулу кнопка «Изменить формулу» в строке формул.

  3. Нажмите кнопку со стрелкой вниз, расположенную справа от поля Функции поле «Функции».

  4. Выберите функцию, которую требуется вставить в формулу. Если функция отсутствует в списке, выберите пункт Другие функции для вывода списка дополнительных функций.

  5. Введите аргументы.

  6. По завершении набора формулы нажмите клавишу ENTER.


 Вставка пустой строки после каждой группы элементов в последнем поле строки сводной таблицы

Вставка пустой строки после каждой группы элементов в последнем поле строки сводной таблицы

Вставка пустых строк возможна для всех полей строк, кроме внутреннего (крайнего справа).

  1. Дважды щелкните кнопку внешнего поля строки, содержащего элементы, которые требуется разделить пустыми строками.

  2. Нажмите кнопку Макет.

  3. Установите флажок Пустая строка после каждого элемента.

Примечания

  • Пустые строки отображаются после каждого элемента или после строки итогов для элемента, если для поля выбрано отображение итогов в нижней части.

  • Вводить данные в эти пустые строки нельзя, но можно форматировать ячейки в пустых строках.

  • Если переместить поле таким образом, чтобы оно больше не являлось внешним полем строк, режим разделения пустыми строками будет продолжать действовать, но пустые строки не будут отображаться до тех пор, пока поле не будет перемещено обратно на место внешнего поля строки.

  • Для того чтобы удалить пустые строки, дважды щелкните кнопку поля, нажмите кнопку Макет, а затем снимите флажок Пустая строка после каждого элемента.


 Вставка скопированных или перемещенных ячеек между существующими ячейками

Вставка скопированных или перемещенных ячеек между существующими ячейками

  1. Выделите ячейки, содержащие данные, которые нужно скопировать или переместить.

  2. Чтобы переместить выбранные символы, выберите команду Вырезать [image] .

    Чтобы скопировать выбранные символы, выберите команду Копировать [image] .

  3. Укажите левый верхний угол диапазона, в который следует поместить вырезанные или скопированные ячейки.

  4. В меню Вставка выберите Вырезанные ячейки или Скопированные ячейки.

  5. Выберите направление, в котором следует сместить соседние ячейки.

Примечание. Чтобы отменить движущуюся границу после завершения копирования, нажмите клавишу ESC.


 Вставка горизонтального разрыва страницы

Вставка горизонтального разрыва страницы

  1. Выделите заголовок строки, с которой необходимо начать новую страницу.

  2. В меню Вставка выберите команду Разрыв страницы.


 Вставка вертикального разрыва страницы

Вставка вертикального разрыва страницы

  1. Щелкните заголовок столбца, слева от которого требуется вставить разрыв страницы.

  2. Выберите в меню Вставка команду Разрыв страницы.


 Установка средств DAO для Visual Basic

Установка средств DAO для Visual Basic

Средства DAO для Visual устанавливаются автоматически при установке Microsoft Query. Дополнительные сведения о создании макросов, использующих DAO для Visual Basic, см. в справке по Visual Basic.


 Загрузка надстроек в Microsoft Excel

Загрузка надстроек в Microsoft Excel

  1. Выберите команду Надстройки в меню Сервис.

    Демонстрация

    Нажмите кнопку Обзор, чтобы найти надстройку, которой нет в окне Список надстроек. Если надстройка не найдена, установите ее на компьютере.

    Инструкции

  2. Установите в окне Список надстроек флажок той надстройки, которую необходимо загрузить.


 Точечная диаграмма не использует заданные значения вдоль горизонтальной (x) оси

Точечная диаграмма не использует заданные значения вдоль горизонтальной (x) оси

  • Если вместо нужных значений на оси категорий выводятся номера типа 1, 2, 3, 4, возможно, при создании диаграммы в качестве типа был выбран график, а не точечная диаграмма. Удалите диаграмму, выделите на листе данные, на которых будет основана диаграмма, а затем нажмите кнопку Мастер диаграмм [image] . Выберите вариант Точечная в поле Тип диалогового окна Мастер диаграмм (шаг 1 из 4): тип диаграммы. Если требуется, чтобы маркеры данных были соединены линиями, выберите один из видов точечной диаграммы с линиями.

  • Убедитесь, что данные для точечной диаграммы введены в должном порядке. Верхняя строка (или левый столбец) выделенного фрагмента листа представляет ряды по оси x, а каждая последующая строка (столбец) представляет ряды по оси y. Для просмотра примера данных для точечной диаграммы нажмите кнопку [image] .

  • Убедитесь, что значения по оси x имеют числовой формат. Числа в текстовом формате могут отображаться как 0, 1, 2, 3 вместо вывода нужных значений. См. сведения о числах, не отображаемых или не вычисляемых как числовые значения.

Примечание. Можно также создать точечную диаграмму с разными значениями по оси x для каждого ряда значений по оси y. Для этого на вкладке Ряд диалогового окна Исходные данные (меню Диаграмма) выделите ряды, для которых необходимо изменить значения x. Затем в поле Значения Х введите ссылки на ячейки либо нужные значения x, разделяя их точкой с запятой, например: 0,02; 0,03; 0,04.


 Отображение содержимого ячейки листа в автофигуре или надписи

Отображение содержимого ячейки листа в автофигуре или надписи

  1. Выделите нужную автофигуру или надпись.

  2. В строке формул введите знак равенства (=).

  3. Выделите ячейку с данными или текстом, к которой должна быть привязана автофигура.

    Ссылку на ячейку листа можно также ввести с клавиатуры. В ссылку следует включить имя листа с восклицательным знаком, например:

    Лист1!F2

  4. Нажмите клавишу ENTER.

Примечание. Данную процедуру нельзя использовать для полилиний, рисованных кривых, линий или соединительных линий.


 Блокирование всех ссылок в Microsoft Excel

Блокирование всех ссылок в Microsoft Excel

  1. Перейдите на лист со ссылками.

  2. В меню Сервис выберите пункт Параметры.

  3. На вкладке Вычисления снимите флажок обновлять удаленные ссылки.

    Примечание. Запрещение обновления связей подавляет параметр автоматически (для всех удаленных ссылок) в диалоговом окне Связи (меню Правка).


Использование выбранной диаграммы в качестве типа диаграммы по умолчанию

  1. Выберите диаграмму, которую необходимо использовать в качестве типа диаграммы по умолчанию.

  2. В меню Диаграмма выберите пункт Тип диаграммы.

  3. На вкладке Нестандартные выберите команду Сделать стандартной, а затем нажмите кнопку Да.

  4. Если на экране появилось диалоговое окно Добавление нового типа диаграмм, введите имя в поле Имя, описание в поле Описание, а затем нажмите кнопку OK.


 Рекомендация открытия книги в режиме доступа только для чтения

Рекомендация открытия книги в режиме доступа только для чтения

  1. Выберите команду Сохранить как в меню Файл.

    Демонстрация

  2. Выберите в меню Сервис команду Общие параметры.

  3. Установите флажок Рекомендовать доступ только для чтения и нажмите кнопку OK.

  4. Нажмите кнопку Сохранить.

  5. При появлении диалогового окна нажмите кнопку Да, чтобы заменить существующую книгу текущей.

Примечания

  • При попытке открыть книгу Microsoft Excel предложит открыть книгу только для чтения, если в ней не требуется сохранять изменения. Excel не запрещает изменение и сохранение изменений в книге.

  • Для предотвращения внесения и сохранения другими пользователями изменений в файл книги можно сделать файл доступным только для чтения.

  • При открытии файла книги можно открыть его только для чтения независимо от того, доступен ли этот файл только для чтения или рекомендовано ли открывать его только для чтения.


 Возвращение структурированной сводной таблицы в неструктурированный формат

Возвращение структурированной сводной таблицы в неструктурированный формат

После преобразования отчета сводной таблицы в структурированный формат некоторое время сохраняется возможность восстановления его исходного формата и макета с нажатием кнопки Отменить [image] . Если были внесены дополнительные изменения и отменить преобразование в структурированный формат не удается, выполните следующую процедуру.

  1. Щелкните отчет сводной таблицы.

  2. На панели инструментов Сводная таблица нажмите кнопку Формат отчета [image] .

  3. В списке форматов отчета выберите любой из форматов с Таблица 1 по Таблица 10 или формат Классическая сводная таблица, расположенный в конце списка.

    Выбор этих форматов не восстанавливает исходный макет отчета. Форматы с Таблица 1 по Таблица 10 перемещают крайнее слева поле строки таким образом, что оно становится полем столбца; при выборе формата Классическая сводная таблица поля не перемещаются.

  4. Для того чтобы восстановить прежний макет отчета сводной таблицы, выделите поле строки, которое ранее было полем столбца, и перетащите его обратно в область столбцов.

Примечание. При преобразовании в неструктурированный формат макета отчета сводной таблицы, с которым связан отчет сводной диаграммы, поля категорий могут стать полями рядов. Кроме того, некоторые параметры форматирования диаграммы могут быть утрачены.


 Задание срока действия отправленного сообщения

Задание срока действия отправленного сообщения

Требования, которым должна удовлетворять система для отправки документов

  1. Откройте в Microsoft Excel лист, который требуется отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель в положение Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Параметры.

  5. В группе Параметры отправки установите флажок Не действительно после, а затем введите нужную дату окончания срока действия.


 Пометка сообщения как частного, личного или ДСП

Пометка сообщения как частного, личного или ДСП

Требования, которым должна удовлетворять система для отправки документов

  1. Откройте в Microsoft Excel лист, который требуется отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель в положение Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Параметры.

  5. В группе Настройки сообщения выберите нужную пометку.

Примечание. Пометка сообщения как частного запрещает изменение сообщения после его отправки, но не влияет на свойства листа.


 Изменение шаблона отчета

Изменение шаблона отчета

  1. В Microsoft Excel нажмите кнопку Открыть [image] .

  2. Найдите и выберите шаблон отчета, который требуется открыть.

    Файлы шаблонов отчетов имеют расширение .xlt.

  3. Нажмите в диалоговом окне Открытие документа кнопку Открыть.

  4. Внесите необходимые изменения.

    См. сведения о доступных изменениях форматирования и макета.

  5. Убедитесь, что обновление внешних данных завершено и нажмите кнопку Сохранить [image] .

  6. Для того чтобы удалить диапазон внешних данных из книги и автоматически обновить ее при следующем открытии шаблона, нажмите кнопку Да.


 Перемещение по листу с помощью клавиш Lotus 1-2-3

Перемещение по листу с помощью клавиш Lotus 1-2-3

  1. В меню Сервис выберите пункт Параметры и откройте вкладку Переход.

  2. Установите флажок Клавиши перемещения, использовавшиеся в Lotus 1-2-3.

    Чтобы использовать для перемещения по листу клавиши, принятые в Microsoft Excel снимите флажок Клавиши перемещения, использовавшиеся в Lotus 1-2-3.

Совет. Для быстрого перемещения от одной непустой ячейки к другой, нажмите клавишу END, а затем нужную клавишу управления курсором. Более подробные сведения о клавишах перемещения, использовавшихся в Lotus 1-2-3 можно получить, нажав кнопку [image] .


 Присваивание имени ячейке или группе ячеек

Присваивание имени ячейке или группе ячеек

  1. Выделите ячейку, группу ячеек или несмежный диапазон, которому необходимо присвоить имя.

  2. Щелкните поле Имя, которое расположено слева в строке формул.

    Пример поля имени

  3. Введите имя ячеек.

  4. Нажмите клавишу ENTER.

Примечание. При изменении содержимого ячейки ей нельзя присвоить имя.


 Отображение и скрытие различных уровней детализации в отчете сводной таблицы или сводной диаграммы

Отображение и скрытие различных уровней детализации в отчете сводной таблицы или сводной диаграммы

Данная процедура используется только для отчетов, основанных на базах данных OLAP. Использует ли отчет сводной таблицы данные OLAP.

  1. Щелкните стрелку Стрелка поля в поле, для которого требуется отобразить данные других уровней детализации.

  2. Выполните одно из следующих действий:

    Для вывода списка нижних уровней детализации поля щелкните значок Плюс рядом с элементом, а затем выберите уровень, который требуется отобразить.

    Для вывода списка только верхних уровней детализации поля щелкните значок Минус рядом с элементами, список деталей для которых отображается в данный момент.

  3. Убедитесь, что флажок рядом с элементом, который требуется отобразить, установлен.

  4. Щелкните элемент, который требуется отобразить, и нажмите кнопку OK.

Совет. Для того чтобы просмотреть следующий доступный для поля или элемента уровень детализации, щелкните нужное поле или элемент, а затем нажмите кнопку Отобразить детали [image] на панели инструментов Сводный таблицы. Для просмотра только верхних уровней детализации нажмите кнопку Скрыть детали [image] .

Примечания

  • Определение доступности уровней детализации. Доступность уровней детализации определяется способом организации базы данных OLAP на сервере. При необходимости доступа к другим уровням детализации обратитесь к администратору базы данных.

  • Скрытие и отображение верхних уровней. Для того чтобы скрыть верхние уровни детализации в полях строк и столбцов отчетов сводных таблиц, щелкните правой кнопкой мыши кнопку поля первого уровня, который требуется скрыть, а затем выберите в контекстном меню команду Скрыть уровни. Выбранный уровень и все верхние уровни размерности будут удалены из представления, а стрелка Стрелка поля больше не будет отображаться на кнопках полей данной размерности.

    Если требуется выбрать для скрытия другие уровни, необходимо сначала отобразить ранее скрытые уровни. Для того чтобы отобразить скрытые уровни и стрелку Стрелка поля в самом верхнем поле размерности, щелкните правой кнопкой мыши кнопку любого поля данной размерности, а затем выберите в контекстном меню команду Вывод уровней.

    Для того чтобы скрыть или отобразить верхние уровни детализации в полях рядов или категорий отчета сводной диаграммы, скройте или отобразите эти уровни в связанном отчете сводной таблицы.

  • Влияние переименования элементов. Если переименовать поля или элементы, а затем повторно отобразить их или добавить в отчет после удаления из представления, переименованные поля или элементы получат исходные имена, которые были им присвоены в базе данных OLAP. Например, если переименовать «Область» в «Регион»,отобразить верхний уровень, «Страна», а затем вернуться к нижнему уровню, поле вновь получит имя «Область».

  • Влияние на связанные отчеты сводных диаграмм. При отображении других уровней детализации в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые параметры форматирования в отчете сводной диаграммы могут быть утрачены.


 Открытие документа в обозревателе с помощью Microsoft Excel

Открытие документа в обозревателе с помощью Microsoft Excel

  1. Нажмите кнопку Открыть.

  2. В поле Папка выберите диск, папку или адрес FTP, где находится документ, который требуется открыть, и затем найдите и дважды щелкните папку, содержащую нужный документ.

    Если найти документ не удается, можно воспользоваться процедурой поиска файлов.

    Инструкции

  3. Щелкните документ .htm (Web-страницу), который требуется открыть в обозревателе.

  4. Нажмите стрелку рядом с кнопкой Открыть и выберите Открыть в обозревателе.


 Открытие книги на Web-сервере

Открытие книги на Web-сервере

  1. В Microsoft Excel нажмите кнопку Открыть [image] .

  2. На панели адресов нажмите кнопку Web-папки.

  3. Найдите и дважды щелкните книгу, которую требуется открыть.

Совет. Для того чтобы открыть недавно использовавшийся файл, нажмите кнопку Журнал на панели адресов.


Обзор промежуточных итогов в списках (создание отчетов и диаграмм)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Обзор промежуточных итогов в списках (просмотр вложенных промежуточных итогов)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Копирование диапазона в несколько областей

Копирование диапазона в несколько областей

  1. Выделите ячейки, которые нужно скопировать или переместить.

  2. Нажмите кнопку Копировать [image] .

  3. Удерживая клавишу CTRL, укажите левый верхний угол каждой области вставки.

  4. Нажмите кнопку Вставить [image] .

    Чтобы поместить область копирования на другой лист, перейдите на этот лист и выполните пункты 3 и 4.

Примечание. Чтобы отменить движущуюся границу после завершения копирования, нажмите клавишу ESC.


 Печать разделов отчета сводной таблицы на отдельных листах

Печать разделов отчета сводной таблицы на отдельных листах

Microsoft Excel может автоматически вставлять разрывы страниц после элементов в конкретных внешних полях строк сводной таблицы (к внешним полям строк относятся все поля, кроме внутреннего), что позволяет печатать каждый раздел отчета в каждом из таких полей на отдельной странице. Автоматическая вставка разрывов страницы невозможна для внутреннего поля строк, полей столбцов или полей страниц.

  1. Дважды щелкните поле, содержащее элементы, которые требуется печатать на отдельных страницах.

  2. Нажмите кнопку Макет.

  3. Установите флажок Разрыв страницы после каждого элемента.

Примечания

  • Расположение разрывов страниц. Excel вставляет разрывы страниц после последней строки для каждого элемента или после итоговой строки для элемента, если для поля выбрано отображение итогов в нижней части. Если установлен флажок вставки пустых строк после каждой группы элементов, Excel вставляет разрывы страниц после пустых строк.

  • Добавление других разрывов страницы. Помимо автоматических разрывов страниц можно вставлять разрывы страниц вручную.

  • Перемещение и удаление разрывов страниц. Для того чтобы изменить положение автоматических разрывов страниц, можно переместить разрыв страницы, после чего он перестанет быть автоматическим, либо уделить разрыв страницы. Для просмотра и изменения разрывов страниц используйте режим разметки страницы.

  • Отключение автоматических разрывов страниц. Для того чтобы удалить автоматические разрывы страниц для поля, снимите флажок Разрыв страницы после каждого элемента в диалоговом окне Расположение полей сводной таблицы. При этом будут удалены все перемещенные разрывы страниц, а разрывы страниц, вставленные вручную, останутся на местах.

  • Связь разрывов страниц с полем сохраняется. После включения автоматической вставки разрывов страниц для поля разрывы страниц печатаются даже при изменении положения этого поля до тех пор, пока оно не будет перемещено на место внутреннего поля строки либо поля столбца или страницы. При перемещении поля на одну из этих позиций разрывы страниц не выводятся на печать. Однако, если опять переместить поле на позицию внешнего поля строки, разрывы страниц появятся вновь.


 Построение рядов данных из строк листа вместо столбцов, и наоборот

Построение рядов данных из строк листа вместо столбцов, и наоборот

  1. Выберите нужную диаграмму.

  2. Выберите в меню Диаграмма команду Исходные данные, а затем перейдите на вкладку Диапазон данных.

  3. Установите переключатель в положение Строках или Столбцах.

Примечания

  • Для изменения ориентации рядов данных можно также нажать кнопку По строкам [image] или По столбцам [image] на панели инструментов Диаграммы.

  • Данная процедура неприменима для отчетов сводных диаграмм. Для того чтобы изменить ориентацию рядов в отчете сводной диаграммы, необходимо изменить макет отчета.


 Отображение рядов данных на вспомогательной оси

Отображение рядов данных на вспомогательной оси

При большом диапазоне изменения значений для разных рядов данных в линейчатой диаграмме или при смешении типов данных (таких как цена и объем) есть возможность отобразить один или несколько рядов данных на вспомогательной оси. Шкала этой оси соответствует значениям для соответствующих рядов.

  1. Выберите ряды данных, которые нужно отобразить на вспомогательной оси.

  2. Выберите команду Ряды данных в меню Формат, а затем — вкладку Ось.

  3. Установите переключатель в положение По вспомогательной оси.


 Использование постоянного значения параметра в запросе

Использование постоянного значения параметра в запросе

Данная процедура неприменима при извлечении данных из баз данных OLAP.

  1. В Microsoft Excel щелкните любую ячейку диапазона внешних данных, созданного с помощью запроса с параметрами.

  2. На панели инструментов Внешние данные нажмите кнопку Параметры запроса [image] .

  3. Из списка в левой части диалогового окна Параметры выберите параметр, который требуется изменить.

  4. Выберите способ Используется значение.

  5. Введите значение параметра и нажмите кнопку OK.

  6. Чтобы обновить данные, выберите Обновить данные [image] на панели инструментов Внешние данные.


 Отображение сообщения, прекращающего ввод неправильных данных

Отображение сообщения, прекращающего ввод неправильных данных

Для получения дополнительных сведений об определении ограничений на данные нажмите кнопку [image] .

  1. Выделите ячейки, на которые наложены ограничения и при использовании которых будет выводиться сообщение.

  2. Выберите в меню Данные команду Проверка, а затем перейдите на вкладку Параметры.

  3. Укажите ограничения на данные, при нарушении которых будет отображаться сообщение.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  4. Перейдите на вкладку Сообщение об ошибке.

  5. Убедитесь, что установлен флажок Выводить сообщение об ошибке.

  6. Выберите Останов в окне Вид. Сообщение будет включать кнопку Повтор для возврата к редактированию ячейки и кнопку Отмена для восстановления предыдущего значения ячейки.

  7. Если требуется, чтобы в строке заголовка сообщения или в выноске помощника (если он отображается) отображался заголовок, введите текст в поле Заголовок. Если оставить поле Заголовок пустым, по умолчанию отображается заголовок Microsoft Excel.

  8. Чтобы создать собственное сообщение, введите в поле Сообщение текст длиной до 255 символов. Нажмите клавишу ENTER, чтобы начать следующую строку сообщения. Если не ввести текст в поле Сообщение, то сообщение будет иметь вид «Введенное значение неверно. Набор значений, которые могут быть введены в ячейку, ограничен».

Примечание. Сообщение отображается только тогда, когда данные в ячейку вводит пользователь. Если некорректные данные были получены по формуле, помещены в ячейку макросом, скопированы или получены с помощью автозаполнения, сообщение об ошибке не выводится.


 Настройка имен полей в диапазоне внешних данных

Настройка имен полей в диапазоне внешних данных

Данная процедура применима только к данным, извлеченным из базы данных, но не к данным, полученным из текстового файла (*.txt) или Web-запроса (*.iqy).

  1. Убедитесь, что над диапазоном внешних данныхимеется пустая строка. Инструкции по вставке строки.

  2. Введите нужные надписи в пустую строку над диапазоном внешних данных, но не поверх имен полей.

  3. Если диалоговое окно Свойства внешнего диапазона не отображено, щелкните одну из ячеек диапазона внешних данных, а затем нажмите кнопку Свойства диапазона данных [image] на панели инструментов Внешние данные.

  4. В группе Формат и разметка данных снимите флажок Включить имена полей и нажмите кнопку OK.

  5. Для того чтобы удалить существующие имена полей и обновить диапазон внешних данных, нажмите кнопку Обновить данные [image] на панели инструментов Внешние данные.

Примечание. При извлечении данных из базы данных изменения имен столбцов, вносимые в Microsoft Query, сохраняются в диапазоне внешних данных. Сведения об изменении имен столбцов в Microsoft Query см. в справке по Microsoft Query.


 Обновление данных сводной таблицы или отчета сводной диаграммы при открытии файла книги

Обновление данных сводной таблицы или отчета сводной диаграммы при открытии файла книги

  1. Щелкните отчет сводной таблицы или сводной диаграммы.

  2. На панели инструментов Сводные таблицы нажмите кнопку Сводная таблица (или Сводная диаграмма) и выберите команду Параметры таблицы (или Параметры).

  3. В группе Источник установите флажок Обновить при открытии.

Совет. Чтобы создать неизменяемую копию отчета сводной таблицы, скопируйте отчет сводной таблицы, а затем выберите команду Специальная вставка в меню Правка и установите переключатель в положение Значения.


 Печать отчета сводной таблицы с элементами внешнего поля строк, повторяющимися на каждой странице

Печать отчета сводной таблицы с элементами внешнего поля строк, повторяющимися на каждой странице

Подписи элементов повторяются для всех полей строк слева от поля, отделенного от группы элементов разрывом страницы.

Повторение подписей элементов после разрыва страницы

Если разрыв страницы попадает между элементами поля «Продукты», текущие элементы полей «Продавец» и «Регион» повторно печатаются вверху следующей страницы.

  1. Щелкните отчет сводной таблицы.

  2. На панели инструментов Сводные таблицы нажмите кнопку Сводная таблица и выберите команду Параметры таблицы.

  3. В группе Формат установите флажок Повторять подписи на каждой странице печати.

  4. В меню Файл выберите команду Печать.

Примечание. Для того чтобы подписи элементов печатались только на первой странице, снимите флажок Повторять подписи на каждой странице печати в диалоговом окне Параметры сводной таблицы.


 Ограничение просмотра и изменения отдельного листа

Ограничение просмотра и изменения отдельного листа

При защите листа, ячейки и графические объекты, не разблокированные на шагах 2 и 3, становятся защищенными и не могут быть изменены.

  1. Переключитесь на защищаемый лист.

  2. Разблокируйте все ячейки, которые потребуется изменять после защиты листа.

    Инструкции

  3. Разблокируйте все графические объекты, которые потребуется изменять после защиты листа.

    Инструкции

  4. Скройте все формулы, которые не должны быть видимы.

    Инструкции

  5. В меню Сервис выберите команду Защита, а затем — команду Защитить лист.

  6. Чтобы запретить изменение ячеек листа, данных или других элементов диаграмм, просмотр скрытых строк, столбцов и формул, установите флажок Содержимое.

    Чтобы запретить изменение графических объектов листов или диаграмм, установите флажок Объекты.

    Чтобы запретить изменение определений сценариев листа, установите флажок Сценарии.

    Чтобы никто другой не смог снять защиту с листа, введите пароль, нажмите OK и снова введите тот же пароль в диалоговом окне Подтверждение пароля. В пароле учитывается регистр букв.

    Установленный пароль следует записать на бумаге и хранить в надежном месте. При утере пароля получить доступ к защищенным элементам листа будет невозможно.


 Ограничение изменений во всей книге

Ограничение изменений во всей книге

  1. В меню Сервис выберите пункт Защита, а затем выполните команду Защитить книгу.

  2. Для защиты структуры книги, чтобы нельзя было переместить, удалить, скрыть, показать или переименовать листы, а также вставить новые, установите флажок Структуру.

    Чтобы при каждом открытии книги местоположение и размеры окон не изменялись, установите флажок Окна.

  3. Чтобы никто другой не смог снять защиту с листа, введите пароль, нажмите OK, а затем подтвердите этот пароль в диалоговом окне Подтверждение пароля. В пароле учитывается регистр букв. Поэтому при вводе пароля следует обращать внимание на строчные и прописные буквы.

    Установленный пароль следует записать на бумаге и хранить в надежном месте. При утере пароля получить доступ к защищенным элементам книги будет невозможно.

    Примечание. При добавлении защищенной паролем книги в подшивку защита паролем снимается. Пароль будет запрошен при добавлении книги, но после того как книга станет разделом подшивки, пароль будет удален.


 Печать отчета сводной таблицы с подписями столбцов и строк, повторяющимися на каждой странице

Печать отчета сводной таблицы с подписями столбцов и строк, повторяющимися на каждой странице

Для повтора имен полей и элементов при печати отчета сводной таблицы этот отчет должен быть единственным в области печати.

  1. Щелкните отчет сводной таблицы.

  2. Выберите в меню Файл команду Параметры страницы, перейдите на вкладку Лист и убедитесь, что поля Сквозные строки и Сквозные столбцы пусты.

  3. На панели инструментов Сводные таблицы нажмите кнопку Сводная таблица и выберите команду Параметры таблицы.

  4. В группе Формат установите флажок Печать заголовков.

  5. В меню Файл выберите команду Печать.

Примечания

  • К повторяющимся подписям относятся подписи всех полей строк, столбцов и данных, а также подписи элементов в отчете сводной таблицы.

  • Увидеть, как будут выглядеть повторяющиеся подписи на каждой странице, можно в режиме предварительного просмотра.

  • Для того чтобы подписи строк и столбцов печатались только на первой странице печатаемого отчета сводной таблицы, снимите флажок Печать заголовков в диалоговом окне Параметры сводной таблицы, а затем убедитесь, что заголовки строк и столбцов выбраны для печати на вкладке Лист диалогового окна Параметры страницы (меню Файл).


 Размещение фильтрованного списка на Web-странице

Размещение фильтрованного списка на Web-странице

Данная процедура используется для размещения списка, который был отфильтрован при помощи команды Автофильтр, на Web-странице таким образом, чтобы другие пользователи могли взаимодействовать с этими данными. Фильтрованный список можно также разместить на Web-странице таким образом, что другие пользователи смогут только просматривать данные.

Прежде чем сохранить или опубликовать данные на Web-странице, сохраните книгу как файл .xls, чтобы иметь версию, доступную для изменения на случай, если позже потребуется изменить Web-страницу.

  1. Выберите фильтрованный список, который требуется поместить на Web-страницу.

  2. Выберите в меню Файл команду Сохранить как Web-страницу.

    Демонстрация

  3. Нажмите кнопку Опубликовать.

  4. В группе Параметры просмотра установите флажок Добавить и выберите нужную возможность.

    См. сведения о размещении данных Excel в Интернете.

  5. Для того чтобы добавить заголовок для публикуемых данных, нажмите кнопку Изменить, введите нужный заголовок и нажмите кнопку OK.

  6. В поле Имя файла нажмите кнопку Обзор и найдите диск, папку, Web-папку, Web-сервер или адрес FTP, по которому требуется сохранить или опубликовать Web-страницу.

  7. Для того чтобы просмотреть Web-страницу в обозревателе после публикации, установите флажок Открыть страницу в обозревателе.

  8. Нажмите кнопку Опубликовать.

Примечания

  • Некоторые параметры форматирования и свойства фильтрованного списка не сохраняются при сохранении списка в качестве Web-страницы.

  • После сохранения фильтрованного списка в виде Web-страницы открытие и изменение соответствующего файла .htm в Microsoft Excel приводит к утере форматирования и функциональности. Используйте для изменения Web-страницы приложение Microsoft FrontPage 2000 или режим конструктора страниц доступа к данным в Microsoft Access 2000.

  • Если при сохранении или публикации списка, отфильтрованного с помощью пользовательского фильтра, выбрать возможности работы с электронными таблицами или сводными списками, отфильтрованный список изначально отображается на Web-странице в том же виде, что и в Excel. Пользователи могут изменить способ фильтрации списка в обозревателе, но после использования другого фильтра использование исходного пользовательского фильтра невозможно.


 Размещение диаграммы на Web-странице

Размещение диаграммы на Web-странице

Данная процедура используется для размещения диаграммы на Web-странице таким образом, чтобы другие пользователи могли взаимодействовать с данными. Диаграмму можно также разместить на Web-странице таким образом, что другие пользователи смогут только просматривать данные.

Прежде чем сохранить или опубликовать данные на Web-странице, сохраните книгу как файл .xls, чтобы иметь версию, доступную для изменения на случай, если позже потребуется изменить Web-страницу.

  1. Щелкните диаграмму или перейдите на лист диаграммы, которую требуется поместить на Web-страницу.

  2. Выберите в меню Файл команду Сохранить как Web-страницу.

    Демонстрация

  3. Нажмите кнопку Опубликовать.

  4. В группе Параметры просмотра установите флажок Добавить (автоматически выбирается вариант Работа с диаграммами).

  5. Для того чтобы добавить заголовок для публикуемой диаграммы, нажмите кнопку Изменить, введите нужный заголовок и нажмите кнопку OK.

  6. В поле Имя файла нажмите кнопку Обзор и найдите диск, папку, Web-папку, Web-сервер или адрес FTP, по которому требуется сохранить или опубликовать Web-страницу.

  7. Для того чтобы просмотреть Web-страницу в обозревателе после публикации, установите флажок Открыть страницу в обозревателе.

  8. Нажмите кнопку Опубликовать.

Примечания

  • При добавлении возможности работы с диаграммами связанные данные для диаграммы также помещаются на Web-страницу. При сохранении диаграммы включается связанная интерактивная электронная таблица, а при сохранении отчета сводной диаграммы включается связанный сводная таблица.

  • Некоторые параметры форматирования и свойства диаграммы не сохраняются при ее сохранении в качестве Web-страницы.

  • См. дополнительные сведения о публикации диаграмм.

  • После сохранения диаграммы в виде Web-страницы открытие и изменение соответствующего файла .htm в Microsoft Excel приводит к утере форматирования и функциональности. Используйте для изменения Web-страницы приложение Microsoft FrontPage 2000 или режим конструктора страниц доступа к данным в Microsoft Access 2000.


 Размещение всей книги на Web-странице

Размещение всей книги на Web-странице

  1. Выберите в меню Файл команду Сохранить как Web-страницу.

  2. В поле Папка выберите диск, папку, Web-папку, Web-сервер или адрес FTP, по которому требуется сохранить или опубликовать Web-страницу.

  3. Установите переключатель Сохранить в положение Всю книгу.

  4. Для того чтобы добавить заголовок Web-страницы, отображаемый в строке заголовка обозревателя, нажмите кнопку Изменить, введите нужный заголовок и нажмите кнопку OK.

  5. В поле Имя файла введите имя для файла Web-страницы.

  6. Нажмите кнопку Сохранить.

Примечания

  • Большинство возможностей и параметров форматирования книги сохраняется при последующем открытии файла Web-страницы (.htm) в Microsoft Excel. См. сведения о возможностях, которые не сохраняются.

  • Всю книгу невозможно сохранить таким образом, чтобы Web-страница была интерактивной. Если требуется сделать интерактивными части книги, необходимо сохранить соответствующий лист или элементы отдельно.

  • После сохранения всей книги в виде Web-страницы файл Web-страницы (.htm) становится текущим файлом в Excel. Это позволяет вносить нужные изменения в Excel.


 Размещение формы на Web-странице

Размещение формы на Web-странице

Создав экранную форму в Microsoft Excel с помощью Microsoft Visual Basic, можно сохранить или опубликовать эту форму как интерактивную Web-страницу, но для автоматизации элементов управления, отличных от простых полей ввода данных, необходимо использовать Web-сценарии, созданные с помощью редактора сценариев. См. сведения о Web-сценариях.

Форму, которая будет использоваться в напечатанном виде, можно сохранить или опубликовать как неинтерактивную Web-страницу. Ни одна из интерактивных возможностей формы не будет работать в Web.

Инструкции по размещению данных Excel в Интернете

Примечание. Если используются элементы управления Forms3, то для просмотра и взаимодействия с Web-страницей на компьютерах пользователей должно быть установлено программное обеспечение Microsoft Office 97 или 2000 и Microsoft Internet Explorer 5.


 Размещение отчета сводной таблицы на Web-странице

Размещение отчета сводной таблицы на Web-странице

Данная процедура используется для размещения отчета сводной таблицы на Web-странице таким образом, чтобы другие пользователи могли взаимодействовать с данными. Отчет сводной таблицы можно также разместить на Web-странице таким образом, что другие пользователи смогут только просматривать данные.

Прежде чем сохранить или опубликовать данные на Web-странице, сохраните книгу как файл .xls, чтобы иметь версию, доступную для изменения на случай, если позже потребуется изменить Web-страницу.

  1. Выделите отчет сводной таблицы, который требуется поместить на Web-страницу.

    Инструкции

  2. Выберите в меню Файл команду Сохранить как Web-страницу.

    Демонстрация

  3. Нажмите кнопку Опубликовать.

  4. В группе Параметры просмотра установите флажок Добавить и выберите нужную возможность работы с отчетом сводной таблицы.

    См. сведения о различиях между возможностями электронных таблиц и сводных таблиц.

  5. Для того чтобы добавить заголовок для публикуемого отчета сводной таблицы, нажмите кнопку Изменить, введите нужный заголовок и нажмите кнопку OK.

  6. В поле Имя файла нажмите кнопку Обзор и найдите диск, папку, Web-папку, Web-сервер или адрес FTP, по которому требуется сохранить или опубликовать Web-страницу.

  7. Для того чтобы просмотреть Web-страницу в обозревателе после публикации, установите флажок Открыть страницу в обозревателе.

  8. Нажмите кнопку Опубликовать.

Примечания

  • При сохранении отчета сводной таблицы в виде Web-страницы утрачивается все форматирование и некоторые возможности отчета сводной таблицы.

  • После сохранения отчета сводной таблицы в виде Web-страницы открытие и изменение соответствующего файла .htm в Microsoft Excel приводит к утере форматирования и функциональности. Используйте для изменения Web-страницы приложение Microsoft FrontPage 2000 или режим конструктора страниц доступа к данным в Microsoft Access 2000.


 Размещение области печати на Web-странице

Размещение области печати на Web-странице

Данная процедура используется для размещения содержимого области печати на Web-странице таким образом, чтобы другие пользователи могли взаимодействовать с данными. Содержимое области печати можно также поместить на Web-страницу таким образом, что другие пользователи смогут только просматривать данные.

Прежде чем сохранить или опубликовать данные на Web-странице, сохраните книгу как файл .xls, чтобы иметь версию, доступную для изменения на случай, если позже потребуется изменить Web-страницу.

  1. Выберите в меню Файл команду Сохранить как Web-страницу.

    Демонстрация

  2. Нажмите кнопку Опубликовать.

  3. В поле Выбрать выберите лист, содержащий область печати, которую требуется поместить на Web-страницу. Например, если область печати расположена на листе с названием Продажи, выберите Документы "Продажи".

  4. В списке выберите Область печати.

  5. В группе Параметры просмотра установите флажок Добавить и выберите нужную возможность.

    См. сведения о размещении данных Excel в Интернете.

  6. Для того чтобы добавить заголовок для публикуемых данных, нажмите кнопку Изменить, введите нужный заголовок и нажмите кнопку OK.

  7. В поле Имя файла нажмите кнопку Обзор и найдите диск, папку, Web-папку, Web-сервер или адрес FTP, по которому требуется сохранить или опубликовать Web-страницу.

  8. Для того чтобы просмотреть Web-страницу в обозревателе после публикации, установите флажок Открыть страницу в обозревателе.

  9. Нажмите кнопку Опубликовать.

Примечания

  • При размещении области печати на Web-странице параметры печати Excel не сохраняются для обозревателя. Например, когда пользователи выполняют печать Web-страницы в обозревателе, заголовки печати не отображаются, и на печать выводится вся страница, а не только область печати. См. сведения о форматировании и возможностях, которые не сохраняются при сохранении или публикации на Web-странице.

  • После сохранения области печати в виде Web-страницы открытие и изменение соответствующего файла .htm в Microsoft Excel приводит к утере форматирования и функциональности. Используйте для изменения Web-страницы приложение Microsoft FrontPage 2000 или режим конструктора страниц доступа к данным в Microsoft Access 2000.


 Размещение диапазона ячеек на Web-странице

Размещение диапазона ячеек на Web-странице

Данная процедура используется для размещения диапазона ячеек на Web-странице таким образом, чтобы другие пользователи могли взаимодействовать с данными. Диапазон данных можно также разместить на Web-странице таким образом, что другие пользователи смогут только просматривать данные.

Прежде чем сохранить или опубликовать данные на Web-странице, сохраните книгу как файл .xls, чтобы иметь версию, доступную для изменения на случай, если позже потребуется изменить Web-страницу.

  1. Выделите диапазон ячеек, который требуется поместить на Web-страницу.

  2. Выберите в меню Файл команду Сохранить как Web-страницу.

    Демонстрация

  3. Нажмите кнопку Опубликовать.

  4. В группе Параметры просмотра установите флажок Добавить и выберите нужную возможность работы диапазоном ячеек. Чаще всего используется возможность работы с электронными таблицами.

    См. сведения о способах размещения данных Excel в Интернете.

  5. Для того чтобы добавить заголовок для публикуемых данных, нажмите кнопку Изменить, введите нужный заголовок и нажмите кнопку OK.

  6. В поле Имя файла нажмите кнопку Обзор и найдите диск, папку, Web-папку, Web-сервер или адрес FTP, по которому требуется сохранить или опубликовать Web-страницу.

  7. Для того чтобы просмотреть Web-страницу в обозревателе после публикации, установите флажок Открыть страницу в обозревателе.

  8. Нажмите кнопку Опубликовать.

Примечания

  • Некоторые параметры форматирования и свойства диапазона ячеек не сохраняются при сохранении диапазона в качестве Web-страницы.

  • После сохранения диапазона ячеек в виде Web-страницы открытие и изменение соответствующего файла .htm в Microsoft Excel приводит к утере форматирования и функциональности. Используйте для изменения Web-страницы приложение Microsoft FrontPage 2000 или режим конструктора страниц доступа к данным в Microsoft Access 2000.


 Размещение диапазона внешних данных на Web-странице

Размещение диапазона внешних данных на Web-странице

Данная процедура используется для размещения диапазона внешних данных на Web-странице таким образом, чтобы другие пользователи могли взаимодействовать с данными. Диапазон внешних данных можно также разместить на Web-странице таким образом, что другие пользователи смогут только просматривать данные.

Прежде чем сохранить или опубликовать данные на Web-странице, сохраните книгу как файл .xls, чтобы иметь версию, доступную для изменения на случай, если позже потребуется изменить Web-страницу.

  1. Выделите диапазон внешних данных, который требуется поместить на Web-страницу.

  2. Выберите в меню Файл команду Сохранить как Web-страницу.

    Демонстрация

  3. Нажмите кнопку Опубликовать.

  4. В группе Параметры просмотра установите флажок Добавить и выберите нужную возможность работы с диапазоном внешних данных. Если требуется возможность обновления данных на Web-странице, выберите Работа со сводными таблицами.

    См. сведения о способах размещения данных Excel в Интернете.

  5. Для того чтобы добавить заголовок для публикуемых данных, нажмите кнопку Изменить, введите нужный заголовок и нажмите кнопку OK.

  6. В поле Имя файла нажмите кнопку Обзор и найдите диск, папку, Web-папку, Web-сервер или адрес FTP, по которому требуется сохранить или опубликовать Web-страницу.

  7. Нажмите кнопку Опубликовать.

Примечания

  • Если требуется опубликовать или сохранить диапазон внешних данных с возможностью работы со сводными таблицами, а возможность обновления данных на Web-странице не нужна, закрепите данные в диапазоне внешних данных перед их публикацией или сохранением.

  • Некоторые параметры форматирования и свойства диапазона внешних данных не сохраняются при сохранении диапазона в качестве Web-страницы.

  • После сохранения диапазона внешних данных в виде Web-страницы открытие и изменение соответствующего файла .htm в Microsoft Excel приводит к утере форматирования и функциональности. Используйте для изменения Web-страницы приложение Microsoft FrontPage 2000 или режим конструктора страниц доступа к данным в Microsoft Access 2000.

  • Изменения диапазона внешних данных, выполняемые вручную на листе, не отображаются на Web-странице.


 Размещение листа на Web-странице

Размещение листа на Web-странице

Данная процедура используется для размещения листа на Web-странице таким образом, чтобы другие пользователи могли взаимодействовать с данными. Лист можно также разместить на Web-странице таким образом, что другие пользователи смогут только просматривать данные.

Прежде чем сохранить или опубликовать данные на Web-странице, сохраните книгу как файл .xls, чтобы иметь версию, доступную для изменения на случай, если позже потребуется изменить Web-страницу.

  1. Щелкните лист, который требуется поместить на Web-страницу.

  2. Выберите в меню Файл команду Сохранить как Web-страницу.

    Демонстрация

  3. Нажмите кнопку Опубликовать.

  4. Убедитесь, что в поле Выбрать выбрано Документы имя_листа, а в списке выбрано Лист Все содержимое имя_листа.

  5. В группе Параметры просмотра установите флажок Добавить и выберите нужную возможность работы с листом.

    См. сведения о различиях между возможностями электронных таблиц и сводных таблиц.

  6. Для того чтобы добавить заголовок для публикуемого листа, нажмите кнопку Изменить, введите нужный заголовок и нажмите кнопку OK.

  7. В поле Имя файла нажмите кнопку Обзор и найдите диск, папку, Web-папку, Web-сервер или адрес FTP, по которому требуется сохранить или опубликовать Web-страницу.

  8. Для того чтобы просмотреть Web-страницу в обозревателе после публикации, установите флажок Открыть страницу в обозревателе.

  9. Нажмите кнопку Опубликовать.

Примечания

  • Если выбранный лист содержит диаграмму и публикуется с возможностью интерактивной работы, диаграмма не будет включена на Web-страницу. Для того чтобы разместить интерактивную диаграмму на Web-странице, необходимо сохранить ее отдельно.

  • Некоторые параметры форматирования и свойства листа не сохраняются при его сохранении в качестве Web-страницы.

  • После сохранения листа в виде Web-страницы открытие и изменение соответствующего файла .htm в Microsoft Excel приводит к утере форматирования и функциональности. Используйте для изменения Web-страницы приложение Microsoft FrontPage 2000 или режим конструктора страниц доступа к данным в Microsoft Access 2000.


Быстрые вычисления на листе (создание простой формулы)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Быстрые вычисления на листе (добавление итогов)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Открытие книги занимает много времени

При открытии книги, созданной в более ранней версии Microsoft Excel, вся книга пересчитывается, благодаря чему все формулы полностью оптимизируются для Excel 2000. После сохранения такой книги в формате Excel 2000 ее открытие в следующий раз займет меньше времени.

См. сведения о пересчете книг, созданных в более ранних версиях Microsoft Excel.


 Получение уведомления о доставке сообщения

Получение уведомления о доставке сообщения

Данная процедура применима только в случае, если используется Microsoft Exchange Server, а приложение Microsoft Outlook установлено в корпоративном режиме или режиме рабочей группы. Инструкции по получению сведений об установленном приложении Microsoft Outlook.

Требования, которым должна удовлетворять система для отправки документов

  1. Выделите в Microsoft Excel лист, который требуется отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель в положение Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Параметры.

  5. В группе Параметры голосования и отслеживания установите флажок Уведомить о доставке этого сообщения.


 Получение уведомления о прочтении сообщения

Получение уведомления о прочтении сообщения

Данная процедура применима только в том случае, если приложение Microsoft Outlook установлено в корпоративном режиме или режиме рабочей группы. Инструкции по получению сведений об установленном приложении Microsoft Outlook.

Требования, которым должна удовлетворять система для отправки документов

  1. Выделите в Microsoft Excel лист, который требуется отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель в положение Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Параметры.

  5. В группе Параметры голосования и отслеживания установите флажок Уведомить о прочтении этого сообщения.


 Обновление автономного файла куба из исходной базы данных OLAP

Обновление автономного файла куба из исходной базы данных OLAP

Важно! Из-за того, что требуется полностью создать файл автономного куба заново, обновление куба может занимать много времени и требовать большого объема временного дискового пространства. Для того чтобы прервать выполняемое обновление, нажмите клавишу ESC.

До внесения изменений в файл автономного куба убедитесь, что существует соединение с сетью и доступ к базе данных OLAP, которая снабжает файл автономного куба данными.

  1. Щелкните отчет сводной таблицы или сводной диаграммы, основанный на обновляемом файле автономного куба.

    Если отчет, для которого создается файл автономного куба, в данный момент подключен к серверной базе данных OLAP, восстановите подключение к файлу автономного куба.

  2. На панели инструментов Сводные таблицы нажмите кнопку Обновить данные [image] .

Примечания

  • При обновлении файла автономного куба файл полностью создается заново из исходной серверной базы данных, а существующий файл на диске заменяется.

  • Если на одном файле автономного куба основано несколько отчетов сводной таблицы или сводной диаграммы, обновление затрагивает все эти отчеты.

  • Инструкции по разрешению вопросов при обновлении файла автономного куба.


 Обновление источника данных мастера куба OLAP из исходной базы данных

Обновление источника данных мастера куба OLAP из исходной базы данных

Важно! Из-за того, что требуется полностью создать весь куб заново, обновление куба может занимать много времени. Для того чтобы прервать выполняемое обновление, нажмите клавишу ESC.

Прежде чем обновлять куб, убедитесь, что имеется подключение к сети и доступ к исходной реляционной базе данных, поставляющей данные для куба. Если исходная база, использовавшаяся в качестве источника данных для куба, точно не известна, обратитесь к пользователю, создавшему данный отчет сводной таблицы или куб.

  1. Щелкните отчет сводной таблицы или сводной диаграммы, основанный на кубе, который требуется обновить.

  2. На панели инструментов Сводные таблицы нажмите кнопку Обновить данные [image] .

Примечания

  • Обновление куба не требует вносить изменения в файл определения куба (.oqy), если отчет не основан на этом файле.

  • При обновлении файла автономного куба файл полностью создается заново из исходной базы данных, а существующий файл на диске заменяется.

  • Если на одном файле автономного куба основано несколько отчетов сводной таблицы или сводной диаграммы, обновление затрагивает все эти отчеты.

  • Инструкции по разрешению вопросов при обновлении куба.


 Сохранение форматирования ячеек при обновлении внешнего диапазона данных

Сохранение форматирования ячеек при обновлении внешнего диапазона данных

  1. Если диалоговое окно Свойства внешнего диапазона не отображено, щелкните одну из ячеек диапазона внешних данных, а затем нажмите кнопку Свойства диапазона данных [image] на панели инструментов Внешние данные.

  2. Для того чтобы сохранить применяемое форматирование ячеек, установите флажок Автоформат данных в группе Формат и разметка данных.

    Для того чтобы сохранить заданную ширину столбцов, снимите флажок Задать ширину столбца в группе Формат и разметка данных.

  3. Нажмите кнопку OK.

  4. Для того чтобы обновить диапазон внешних данных, нажмите кнопку Обновить данные [image] на панели инструментов Внешние данные.


 «Замораживание» диапазона внешних данных

«Замораживание» диапазона внешних данных

При «замораживании» Microsoft Excel сохраняет данные в диапазоне внешних данных, но не сохраняет сведения базового запроса, что предотвращает дальнейшее обновление данных.

При выполнении данной процедуры сохраненные файлы запросов к базам данных (*.dqy) не удаляются. При сохранении запроса при его создании в мастере запросов или в Microsoft Query файл запроса (*.dqy) сохраняется на компьютере и может быть повторно использован для загрузки внешних данных.

  1. Если диалоговое окно Свойства внешнего диапазона не отображено, щелкните одну из ячеек диапазона внешних данных, а затем нажмите кнопку Свойства диапазона данных [image] на панели инструментов Внешние данные.

  2. В группе Определение запроса установите флажок Сохранить определение запроса.

Примечание. После сохранения книги базовый запрос удаляется из книги навсегда.


 Замена формулы на возвращаемое значение

Замена формулы на возвращаемое значение

Внимание! Microsoft Excel удаляет формулу при замене на возвращаемое значение. Для отмены случайной замены формулы ее значением немедленно после ввода или вставки значения нажмите кнопку Отменить [image] .

  1. Выделите ячейки, содержащие формулу.

    Если формула является формулой массива, выделите группу ячеек, содержащих эту формулу.

    Инструкции

  2. Нажмите кнопку Копировать [image] .

  3. В меню Правка выберите команду Специальная вставка.
  4. Установите переключатель Вставить в положение Значения.


 Замена текста и чисел

Замена текста и чисел

  1. Выделите диапазон ячеек, в котором будет проводиться поиск.

    Чтобы провести поиск по всему листу, щелкните любую ячейку.

  2. В меню Правка выберите команду Заменить.

    Демонстрация

  3. В поле Что введите текст или числа, которые нужно найти.

  4. В поле Заменить на введите символы для замещения.

    Чтобы удалить символы в поле Что оставьте поле Заменить на пустым.

  5. Выберите Найти далее.

  6. Чтобы заменить найденные символы, выберите команду Заменить.

    Чтобы заменить все вхождения, выберите Заменить все.

Примечание. Чтобы остановить поиск, нажмите клавишу ESC.


 Запрос пароля на открытие книги

Запрос пароля на открытие книги

При задании пароля следует записать его и хранить в надежном месте. В случае утери пароля невозможно будет открыть защищенную книгу или использовать данные из нее.

  1. Выберите команду Сохранить как в меню Файл.

    Демонстрация

  2. Выберите в меню Сервис команду Общие параметры.

  3. Введите пароль в поле Пароль для открытия файла и нажмите кнопку OK.

    При вводе пароля следует различать строчные и прописные буквы. Вводите пароль в точности так, как он должен будет вводиться пользователями, учитывая регистр букв.

  4. Введите пароль еще раз в поле Введите пароль еще раз и нажмите кнопку OK.

  5. Нажмите кнопку Сохранить.

  6. При появлении диалогового окна нажмите кнопку Да, чтобы заменить существующую книгу текущей.

Примечание. При добавлении защищенной паролем книги в подшивку защита паролем утрачивается. Пароль будет запрошен при добавлении книги, но после того как книга станет разделом подшивки, защита будет удалена.


 Запрос пароля на сохранение изменений в книге

Запрос пароля на сохранение изменений в книге

При задании пароля следует записать его и хранить в надежном месте.

  1. Выберите команду Сохранить как в меню Файл.

    Демонстрация

  2. Выберите в меню Сервис команду Общие параметры.

  3. Введите пароль в поле Пароль разрешения записи и нажмите кнопку OK.

    При вводе пароля следует различать строчные и прописные буквы. Вводите пароль в точности так, как он должен будет вводиться пользователями, учитывая регистр букв.

  4. Введите пароль еще раз в поле Введите пароль еще раз и нажмите кнопку OK.

  5. Нажмите кнопку Сохранить.

  6. При появлении диалогового окна нажмите кнопку Да, чтобы заменить существующую книгу текущей.

Примечания

  • Для того чтобы сохранить изменения в книге, защищенной паролем, без использования пароля, следует сначала открыть книгу только для чтения. Внесите в книгу нужные изменения, а затем сохраните ее под другим именем. Книга, сохраненная под другим именем не требует пароля и доступна для редактирования.

  • При добавлении защищенной паролем книги в подшивку защита отключается. Необходимо будет ввести пароль, но защита будет отключена после того, как книга станет разделом подшивки.


 Повторное соединение с исходной базой данных OLAP после использования файла автономного куба

Повторное соединение с исходной базой данных OLAP после использования файла автономного куба

Данная процедура используется в случаях, когда требуется, чтобы исходные данные для отчета сводной таблицы или сводной диаграммы загружались путем непосредственного подключения к исходной базе данных OLAP на сетевом сервере, а не с помощью файла автономного куба. Если требуется создать файл автономного куба заново, чтобы включить изменения и обновления из исходной базы данных, можно обновить файл автономного куба.

  1. Щелкните отчет сводной таблицы.

    Для отчета сводной диаграммы щелкните связанный отчет сводной таблицы.

  2. Нажмите на панели инструментов Сводные таблицы кнопку Сводная таблица и выберите команду Настройка клиент-сервера.

  3. Установите переключатель в положение Данные с сервера и нажмите кнопку OK.

  4. Если будет предложено найти источник данных, нажмите кнопку Найти источник, а затем найдите сервер OLAP в сети.

  5. Для того чтобы загрузить данные с сервера для текущего представления отчета, нажмите кнопку Обновить данные [image] .

Примечание. Если отчет изначально был создан при помощи источника данных, непосредственно подключенного к файлу автономного куба, подключить этот файл к серверу не удастся. Для получения сведения о подключении к серверу баз данных OLAP, с помощью которого был изначально создан файл, обратитесь к пользователю, создавшему файл автономного куба. См. сведения об источниках данных OLAP для отчетов.


 Повторное соединение с файлом автономного куба после использования исходной базы данных OLAP

Повторное соединение с файлом автономного куба после использования исходной базы данных OLAP

Данная процедура используется в случаях, когда для отчета сводной таблицы или сводной диаграммы уже имеется файл автономного куба, который будет использоваться в качестве источника данных для отчета и после непосредственного подключения к исходной базе данных OLAP на сервере сети. Если файл автономного куба отсутствует и требуется начать использование такого файла, можно создать новый файл автономного куба.

  1. Щелкните отчет сводной таблицы.

    Для отчета сводной диаграммы щелкните связанный отчет сводной таблицы.

  2. Нажмите на панели инструментов Сводные таблицы кнопку Сводная таблица и выберите команду Настройка клиент-сервера.

  3. Установите переключатель в положение Локальный файл данных и нажмите кнопку OK.

  4. Для того чтобы перенести в файл автономного куба последние изменения данных с сервера, нажмите кнопку Обновить данные [image] .


Восстановление стандартных значений параметров поиска решений

  1. В меню Сервис выберите команду Поиск решения.

  2. Нажмите кнопку Восстановить.


 Снятие защиты с общей книги

Снятие защиты с общей книги

При снятии защиты с общей книги, для совместного доступа к которой установлен пароль, книга также удаляется из совместного пользования. При удалении книги из совместного использования, Microsoft Excel отключает всех остальных пользователей от данной книги, выключает ведение журнала изменений и удаляет сохраненный журнал изменений, что делает невозможным просмотр журнала и объединение этой копии с другими копиями книги. Для того чтобы другие пользователи не потеряли не сохраненные данные, убедитесь, что они сохранили и закрыли общую книгу. Для этого выберите в меню Сервис команду Доступ к книге, перейдите на вкладку Правка и убедитесь, что вы единственный пользователь в списке Файл открыт следующими пользователями.

  1. Выберите в меню Сервис команду Защита и подкоманду Снять защиту общей книги.

  2. Если потребуется, введите пароль книги.

  3. Если появится сообщение о воздействии снятия защиты с общей книги на остальных пользователей, нажмите кнопку Да.

  4. Если снятие защиты привело к удалению книги из общего пользования, верните ее в общее пользование.

    Инструкции

Примечание. Если общая книга не защищена паролем, то при снятии защиты книга остается общей.


Снятие защиты со всей книги

  • В меню Сервис выберите Защита и затем Снять защиту книги.

    Если запрошен пароль, который был установлен при защите книги, необходимо ввести этот пароль. В пароле учитывается регистр букв. Его следует вводить точно в таком виде, в каком он был создан, включая строчные и заглавные буквы.


Снятие защиты с отдельных листов

  1. Перейдите к листу, с которого снимается защита.

  2. В меню Сервис выберите Защита и затем Снять защиту листа.

    Если запрошен пароль для листа, необходимо его ввести. В пароле учитывается регистр букв. Его следует вводить точно в таком виде, в каком он был создан, включая строчные и заглавные буквы.


 Обратный порядок отображения категорий, значений или рядов

Обратный порядок отображения категорий, значений или рядов

Можно установить обратный порядок отображения категорий или значений для большинства диаграмм, также как и для рядов данных в объемных диаграммах. Только в радиальной диаграмме нельзя установить обратный порядок отображения значений.

  1. Выберите ось, соответствующую категориям, значениям или рядам, порядок отображения которых следует изменить.

  2. Выберите команду Ось в меню Формат, а затем — вкладку Шкала.

  3. Чтобы изменить порядок отображения категорий, установите флажок Обратный порядок категорий.

    Чтобы изменить порядок отображения значений, установите флажок Обратный порядок значений.

    Чтобы изменить порядок отображения рядов на объемных диаграммах, установите флажок Обратный порядок рядов.


 Выполнение макроса в Microsoft Excel

Выполнение макроса в Microsoft Excel

Для того чтобы прервать выполнение макроса, нажмите кнопку ESC.

  1. Откройте книгу, содержащую нужный макрос.

  2. Выберите в меню Сервис команду Макрос и подкоманду Макросы.

    Демонстрация

  3. В поле Имя макроса введите имя того макроса, который требуется выполнить.

  4. Нажмите кнопку Выполнить.


 Выполнение макроса из модуля Visual Basic

Выполнение макроса из модуля Visual Basic

  1. Откройте книгу, содержащую нужный макрос.

  2. Выберите в меню Сервис команду Макрос и подкоманду Макросы.

    Демонстрация

  3. В поле Имя макроса введите имя того макроса, который требуется выполнить.

  4. Нажмите кнопку Изменить.

  5. Нажмите кнопку Run Sub/UserForm кнопка Run Sub/UserForm.

Совет. Для того чтобы выполнить другой макрос, находясь в редакторе Visual Basic, выберите команду Macros в меню Tools. В поле Macro name введите имя того макроса, который нужно выполнить, а затем нажмите кнопку Run.


 Сохранение новой книги, не имеющей имени

Сохранение новой книги, не имеющей имени

  1. Выберите команду Сохранить как в меню Файл.

  2. В поле Папка укажите диск и папку, в которую будет помещена книга.

    Чтобы сохранить книгу в новой папке, щелкните Создать папку [image].

  3. В поле Имя файла введите имя книги.

    Разрешается использовать длинные, описательные имена файлов.

  4. Нажмите кнопку Сохранить.

Советы

  • Чтобы к книге иметь быстрый доступ, сохраните ее в папке «Избранное». Для просмотра этой папки нажмите кнопку Избранное [image] на панели адресов. Чтобы сохранить книгу в другой папке, но по-прежнему иметь возможность быстрого доступа к ней, можно поместить ярлык для нее в папке Избранное.

  • Чтобы упростить поиск книги, в меню Файл выберите команду Свойства. На вкладке Документ введите заголовок книги, тему, автора, ключевые слова и примечания. Данные могут быть использованы для поиска файла с помощью команды Найти в меню Сервис (диалоговое окно Открыть).


 Сохранение копии отправленного сообщения

Сохранение копии отправленного сообщения

Требования, которым должна удовлетворять система для отправки документов

  1. Откройте в Microsoft Excel лист, который следует отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Параметры.

  5. В группе Параметры отправки установите флажок После отправки сохранить в.

    Чтобы указать папку, в которой будут храниться сообщения, нажмите кнопку Обзор.

Примечание. Этот параметр относится только к текущему сообщению.


 Размещение диапазона внешних данных

Размещение диапазона внешних данных

  1. В диалоговом окне Возврат данных в Microsoft Excel выберите Свойства, чтобы установить параметры форматирования и вида диапазона внешних данных, импортируемого в Microsoft Excel. Чтобы получить сведения, нажмите кнопку [image] .

  2. Чтобы передать данные на лист, выберите Имеющийся лист. На листе выберите команду ячейку, в которую вы хотите поместить верхний левый угол диапазона внешних данных, и нажмите кнопку OK.

    Чтобы поместить диапазон внешних данных на новый лист, выберите Новый лист и нажмите кнопку OK. Microsoft Excel добавит новый лист в вашу книгу и автоматически поместит диапазон внешних данных в левый верхний угол листа.

    Чтобы использовать внешние данные в отчете сводной таблицы, выберите Отчет сводной таблицы и нажмите кнопку ОК.

Примечание. Чтобы проверить состояние фонового запроса, длительное время не возвращающего данные, выберите Состояние обновления [image] на панели инструментов Внешние данные. Чтобы отменить запрос, выберите Отменить обновление.


 Пересылка листа в виде текста сообщения электронной почты непосредственно из Excel

Пересылка листа в виде текста сообщения электронной почты непосредственно из Excel

Требования, которым должна удовлетворять система для отправки документов

  1. В Excel нажмите кнопку Электронная почта [image] на панели инструментов Стандартная.

  2. Установите переключатель в положение Включить текущий лист в текст сообщения.

  3. В поля Кому и Копия введите имена получателей через точку с запятой.

    Чтобы выбрать получателей из списка, щелкните значок рядом с полями Кому или Копия. По умолчания в поле Тема появляется имя листа, но оно может быть заменено любым другим текстом.

  4. Установите требуемые параметры для сообщения.

  5. Нажмите кнопку Отправить лист [image] .


 Открытая Web-страница имеет неправильный шрифт или кодовую страницу.

Открытая Web-страница имеет неправильный шрифт или кодовую страницу.

Если при импорте Web-страницы в Excel используется неправильный шрифт, можно выбрать кодовую страницу, которая, предположительно, использована для кодировки данной Web-страницы. Затем, в зависимости от выбранной кодовой страницы, можно выбрать из списка подходящий шрифт.

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа, а затем выберите вкладку Шрифты.

  3. В списке Набор символов выберите кодовую страницу, которую, предположительно, использует Web-страница.

  4. В списках Пропорциональный и Размер выберите шрифт и его размер для нормального текста.

  5. В списках Моноширинный и Размер укажите шрифт и его размер для моноширинного текста.

    Примечание. Этот параметр применяется к текущей странице и ко всем страницам, которые в будущем будут импортироваться в Excel.


 Установка уровня важности для сообщения

Установка уровня важности для сообщения

Требования, которым должна удовлетворять система для отправки документов

  1. Откройте в Microsoft Excel лист, который требуется отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель в положение Включить текущий лист в текст сообщения.

  4. Выполните одно из следующих действий:

    Чтобы пометить сообщение как очень важное, нажмите кнопку Важность: высокая [image] .

    Чтобы пометить сообщение как не очень важное, нажмите кнопку Важность: низкая [image] .

    Чтобы удалить значок уровня важности, нажмите еще раз кнопку Важность: высокая или Важность: низкая.


 Установка флага сообщения

Установка флага сообщения

Требования, которым должна удовлетворять система для отправки документов

Установка флага сообщения является быстрым способом пометить сообщения, которые требуют дальнейшего сопровождения или включают какой-либо запрос. Когда адресат получает письмо с установленным флагом, вверху сообщения появляется комментарий по поводу назначения флага. Если установлена ожидаемая дата, она также появляется в комментарии.

  1. Откройте в Microsoft Excel лист, который требуется отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель в положение Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Отметить сообщение

  5. В поле Отметка укажите требуемый флаг.

    Чтобы отменить уже введенный флаг, нажмите кнопку Удалить.

  6. В поле Напоминание введите ожидаемую дату ответа.


Ограничение времени поиска решения и числа итераций

  1. В меню Сервис выберите команду Поиск решения.

  2. Нажмите кнопку Дополнительно.

  3. В поле Максимальное время введите интервал в секундах, чтобы ограничить время поиска решения задачи.

  4. В поле Итерации введите максимальное количество количество итераций, отводимое на достижение конечного результата.

Примечания

  • При достижении границы отведенного временного интервала или при выполнении отведенного числа итераций, на экране появляется диалоговое окно Текущее состояние поиска решения.

  • Дополнительные сведения об элементах управления диалогового окна Текущее состояние поиска решения.


Изменение погрешности и сходимость результатов поиска решения

  1. В меню Сервис выберите команду Поиск решения.

  2. Нажмите кнопку Дополнительно.

  3. В поле Точность введите необходимую погрешность — чем меньше введенное число, тем выше точность результатов.

  4. В поле Сходимость введите значение относительного изменения, при достижении которого в последних пяти итерациях поиск решения прекращается — чем меньше это значение, тем выше точность результатов.

    Дополнительные сведения об элементах управления диалогового окна }Параметры поиска решения.


Изменение погрешности целых величин, полученных при поиске решения

  1. В меню Сервис выберите команду Поиск решения.

  2. Нажмите кнопку Дополнительно.

  3. В поле Допустимое отклонение введите необходимый допуск.

    Дополнительные сведения об элементах управления диалогового окна }Параметры поиска решения.


 Изменение точности вычислений в книге

Изменение точности вычислений в книге

Внимание! Использование в вычислениях отображаемых на экране значений приводит к округлению значений листа книги, а также к изменению точности вычислений. После такого округления возврат к исходной точности будет невозможен.

  1. В меню Сервис выберите пункт Параметры и перейдите на вкладку Вычисления.

  2. Установите флажок Точность как на экране в группе Параметры книги.


 Отображение итоговых данных для всех элементов поля в сводной таблице или отчете сводной диаграммы

Отображение итоговых данных для всех элементов поля в сводной таблице или отчете сводной диаграммы

  1. Нажмите кнопку со стрелкой Стрелка поля рядом с отображаемым элементом поля страницы.

  2. Выберите элемент (Все).

Примечания

  • Если при выборе варианта (Все) поля страниц запрашивают внешние данные, то этот вариант недоступен. См. сведения о параметрах поля страницы.

  • В сводных таблицах и отчетах сводных диаграмм, основанных на исходных данных из базы данных OLAP, некоторые поля страниц могут не иметь варианта Все. Это определяется установками базы данных OLAP. Если элемент Все присутствует, он является первым элементом в верху списка.

  • При изменении элемента поля страницы в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые параметры форматирования диаграммы могут быть утеряны.


 Отображение или скрытие элементов поля сводной таблицы или сводной диаграммы

Отображение или скрытие элементов поля сводной таблицы или сводной диаграммы

Используйте эту процедуру для сводных таблиц и отчетов сводных диаграмм, основанных на не-OLAP исходных данных. Для сводных таблиц и отчетов сводных диаграмм, использующих исходные данные из базы данных OLAP можно временно перетащить поле страницы в область полей строк или столбцов, отобразить или скрыть элементы и перетащить поле обратно в область полей страницa. Использует ли отчет сводной таблицы данные OLAP.

  1. Если сводная таблица или отчет сводной диаграммы созданы из внешнего источника данных, проверьте, что в поле страницы осуществляется выборка внешних данных для всех элементов поля одновременно.

    Инструкции

  2. На панели инструментов Сводные таблицы нажмите кнопку Параметры поля [image] .

  3. В списке Скрыть элементы выделите каждый скрываемый элемент и снимите выделение для элементов, которые должны отображаться. Для выделения нескольких элементов щелкните их, удерживая клавишу CTRL нажатой.

  4. Чтобы отобразить или скрыть пустые элементы поля исходных данных, установите или снимите флажок Отображать пустые элементы.

Примечания

  • Примеры элементов, не содержащих данные Если продажи разбиты по месяцам, а продажи в апреле отсутствовали, элемент для апрельских продаж будет виден, только если отображаются элементы, не содержащие данные.

  • Скрытые элементы в итогах По умолчанию скрытые элементы не включаются в промежуточные и общие итоги. Для включения скрытых элементов выберите Сводная таблица или Сводная диаграмма на панели инструментов Сводная таблица, выберите Параметры таблицы или параметры и установите флажок включать скрытые значения. Чтобы исключить из расчетов скрытые элементы, сбросьте этот флажок.

  • Влияние на исходные данные Скрытие данных в отчете сводной таблицы или сводной диаграммы не влияет на исходные данные.

  • Влияние на отображение максимальных или минимальных элементов. Для отчетов сводной таблицы или сводной диаграммы, основанных на исходных данных из баз данных OLAP, при изменении элементов, выбранных для отображения, сбрасывается отображение максимальных или минимальных элементов и вместо них отображаются выбранные элементы.

  • Влияние на связанные отчеты сводных диаграмм. При отображении или скрытии элементов в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые особенности форматирования в отчете сводных диаграмм могут быть утрачены.


 Отображение и скрытие подробных данных для рядов в отчете сводной диаграммы

Отображение и скрытие подробных данных для рядов в отчете сводной диаграммы

  1. Выделите ряд, подробные данные для которого будут скрываться или отображаться.

  2. Нажмите кнопку Отобразить детали [image] или Скрыть детали [image] на панели инструментов Сводные таблицы.

    При появлении диалогового окна дважды щелкните поле, для которого необходимо показать подробные данные.

Примечания

  • Некоторые параметры форматирования отчета сводной диаграммы, включая линии тренда и планки погрешностей, могут не сохраняться при скрытии и отображении подробных данных.

  • Для скрытия и отображения различных уровней детализации для отчетов сводных диаграмм, построенных на исходных данных OLAP, можно использовать другую процедуру.

  • Можно отобразить подробные данные для отдельных секторов в круговой диаграмме, но кнопка Показать детали становится недоступной при выделении всей круговой диаграммы.


 Отображение максимальных и минимальных элементов в поле сводной таблицы или сводной диаграммы

Отображение максимальных и минимальных элементов в поле сводной таблицы или сводной диаграммы

  1. Дважды щелкните поле, для которого необходимо отобразить элементы. Для отчета сводной диаграммы дважды щелкните поле в связанном отчете сводной таблицы.

  2. В диалоговом окне Поле сводной таблицы нажмите кнопку Далее.

  3. В группе Параметры отображения установите переключатель в положение автоматические.

  4. Выберите варианты наибольших или наименьших в раскрывающемся списке отображать, а также число отображаемых элементов в поле справа от списка.

  5. Выберите поле, содержащее данные, которые необходимо использовать в качестве критерия для определения максимальных или минимальных элементов, в раскрывающемся списке с помощью поля.

Примечания

  • Влияние обновления или внесения изменений Когда отчет сводной таблицы или сводной диаграммы обновляется, изменяется его макет или отображаются другие элементы поля страницы, Microsoft Excel пересчитывает и отоборажает новые максимальные и минимальные элементы.

  • Скрытые элементы Когда Excel отображает наибольшие и наименьшие элементы, другие элементы скрыты. Чтобы восстановить отображение этих элементов, установите в положение вручную переключатель в группе Параметры отображения. Общие и промежуточные итоги в отчете сводной таблицы или сводной диаграммы могут или включать, или не включать скрытые элементы. См. сведения о том, как вычисляются общие и промежуточные итоги.

  • Скрытые уровни В отчетах, которые используют исходные данные из баз данных OLAP, когда отображаются максимальные и минимальные элементы для уровня в поле размерности, настройки влияют и на более низкие уровни в той же размерности. Например, если размерность имеет уровни «Страна», «Регион» и «Город» и отображаются 10 стран с самым большим значением указанного поля, отчет будет также включать 10 регионов для каждой страны и 10 городов в каждом регионе. Если верхние уровни детализации скрыты, убедитесь в том, что отображается самый верхний уровень, для которого отображены максимальные или минимальные элементы.

  • Влияние на связанные отчеты сводных диаграмм. При отображении максимальных и минимальных значений в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые параметры форматирования в отчете сводных диаграмм могут быть утеряны.


 Сортировка столбцов по содержимому строк

Сортировка столбцов по содержимому строк

  1. Укажите ячейку в сортируемом списке.

  2. В меню Данные выберите команду Сортировка.

    Демонстрация

  3. Нажмите кнопку Дополнительно.

  4. Установите переключатель Сортировать в положение Столбцы диапазона и нажмите кнопку OK.

  5. Выберите строки, по которым требуется отсортировать столбцы, в полях Сортировать по и Затем по.


 Сортировка строк по двум или или более столбцам

Сортировка строк по двум или или более столбцам

Лучше всего, если сортируемый список будет иметь заголовки столбцов.

  1. Укажите ячейку в сортируемом списке.

  2. В меню Данные выберите команду Сортировка.

    Демонстрация

  3. Укажите столбцы сортировки в полях Сортировать по и Затем по.

    Чтобы отсортировать данные по более, чем трем столбцам одновременно, отсортируйте список сначала по трем наименее значимым столбцам. Например, если список содержит сведения о сотрудниках и его требуется отсортировать по полям "Отдел", "Должность", "Фамилия" и "Имя", сортировку нужно будет выполнить дважды. Выберите сначала Имя в поле Сортировать по и отсортируйте список. Затем выберите Отдел в поле Сортировать по, Должность в поле Затем по, Фамилия в поле В последнюю очередь, по и отсортируйте список еще раз.

  4. Выберите другие параметры сортировки и нажмите кнопку OK.

    Повторите шаги 2 — 4 для следующих более значимых столбцов.

Примечания

  • Если сортировка ведется по нескольким столбцам, то строки с одинаковыми значениями в столбце, указанном в поле Сортировать по, сортируются в порядке, определяемом столбцом, указанным в поле Затем по. Строки с одинаковыми значениями в первых двух столбцах сортируются по столбцу, указанному в поле В последнюю очередь, по.

  • При сортировке строк, входящих в структуру, будут упорядочены группы самого верхнего (первого) уровня. Порядок расположения детальных строк или столбцов не изменится, независимо от того, являются они скрытыми или отображаются на экране.


 Сортировка элементов сводной таблицы или сводной диаграммы по подписям

Сортировка элементов сводной таблицы или сводной диаграммы по подписям

  1. Выделите сортируемое поле.

    Для отчета сводной диаграммы выберите поле в связанном отчете сводной таблицы. Чтобы отсортировать подписи рядов диаграммы, выберите соответствующее поле столбца. Чтобы отсортировать подписи категорий диаграммы, выберите соответствующее поле строки.

  2. В меню Данные выберите команду Сортировка.

  3. Установите переключатель в группе Сортировать по в положение по возрастанию или по убыванию.

  4. Проверьте, что переключатель Сортировать установлен в положение Подписи.

Примечания

  • Если при обновлении или изменении макета отчета сводной таблицы необходимо автоматически сортировать элементы, дважды щелкните сортируемое поле и нажмите кнопку Далее в диалоговом окне Поле сводной таблицы и установите переключатель Параметры сортировки в положение по возрастанию или по убыванию. Выберите то же сортируемое поле в раскрывающемся списке с помощью поля.

  • При сортировке данных в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые параметры форматирования отчета сводной диаграммы могут быть утеряны.


 Сортировка элементов сводной таблицы или сводной диаграммы по значениям ячеек в области данных

Сортировка элементов сводной таблицы или сводной диаграммы по значениям ячеек в области данных

  1. Дважды щелкните поле, содержащее сортируемые элементы. Чтобы отсортировать подписи рядов в отчете сводной диаграммы, дважды щелкните поле ряда. Чтобы отсортировать подписи категорий, дважды щелкните поле категорий.

    Если в отчете сводной таблицы выбрано поле столбца, элементы будут сортироваться слева направо. Если выбрано поле строки, элементы будут сортироваться сверху вниз.

  2. В диалоговом окне Поле сводной таблицы нажмите кнопку Далее.

  3. Установите переключатель Параметры сортировки в положение по возрастанию или по убыванию.

  4. Выделите поле данных, значения которого необходимо использовать для сортировки элементов, в раскрывающемся списке с помощью поля.

Примечания

  • Если при обновлении или изменении структуры таблицы, не нужно сохранять порядок сортировки, сортировку можно провести вручную. Установите переключатель Параметры сортировки в положение вручную и два раза нажмите кнопку OK. Выделите сортируемое поле. Выберите команду Сортировка в меню Данные. Введите ячейку сортируемой области данных в поле Сортировать по.

  • При сортировке данных в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые параметры форматирования диаграммы могут быть утеряны.

  • Если в поле размерности отчета, который основан на исходных данных из базы данныхOLAP скрываются верхние уровни, установленные Параметры сортировки для скрытых уровней больше не влияют на нижние уровни, которые все еще отображаются. Если сортируется верхний уровень, который все еще отображен, все элементы этого уровня сортируются вместе. Например, если размерность имеет уровни «Регион» и «Город», а уровень «Регион» скрыт и для уровня «Город» установлен порядок сортировки по возрастанию, города из разных регионов сортируются вместе.


 Сортировка месяцев, дней недели и списков

Сортировка месяцев, дней недели и списков

  1. Укажите ячейку или диапазон ячеек в сортируемом списке.

  2. В меню Данные выберите команду Сортировка.

    Демонстрация

  3. Нажмите кнопку Дополнительно.

  4. В поле Порядок сортировки по первому ключу выберите требуемый порядок и нажмите кнопку OK.

  5. Выберите другие необходимые параметры сортировки.

Примечания

  • Заданный на шаге 4 порядок сортировки применяется только для столбца, указанного в поле Сортировать по. Чтобы использовать нестандартный порядок для сортировки нескольких столбцов, следует последовательно выполнить несколько отдельных сортировок для каждого из столбцов. Например, чтобы сортировать данные по столбцам А и В (сначала по А, а потом по В), сначала проведите сортировку по столбцу В, задав требуемый порядок сортировки в окне Параметры сортировки. Затем проведите аналогичную сортировку списка по столбцу А.

  • Чтобы отсортировать список в порядке, отличном от алфавитного, — например, при сортировке организационных данных — используйте пользовательский порядок сортировки. Для получения более подробных сведений о пользовательском порядке сортировки нажмите [image] .


 Сортировка строк по возрастанию данных в одном столбце

Сортировка строк по возрастанию данных в одном столбце

Если список уже сортировался, то будут использоваться параметры предыдущей сортировки.

  1. Укажите ячейку в сортируемом списке.

  2. Нажмите кнопку По возрастанию [image] .

Примечание. В сводной таблице элементы в выделенном поле сортируются по алфавиту в возрастающем порядке (от А до Я). Числа сортируются от меньшего к большему.


 Сортировка данных по убыванию данных в одном столбце

Сортировка данных по убыванию данных в одном столбце

Если список уже сортировался, то будут использоваться параметры предыдущей сортировки.

  1. Укажите ячейку в сортируемом списке.

  2. Нажмите кнопку По убыванию [image] .

Примечание. В сводной таблице элементы в выделенном поле сортируются по алфавиту в убывающем порядке (от Я до А). Числа сортируются от большего к меньшему.


 Выбор дополнительной папки автозагрузки

Выбор дополнительной папки автозагрузки

Внимание! Microsoft Excel будет пытаться открыть любой файл, находящийся в дополнительной папке автозагрузки. Следует убедиться, что указана пустая папка или папка, содержащая только те файлы, которые Microsoft Excel может открыть.

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. В поле Каталог автозагрузки введите путь к дополнительной папки автозагрузки.

Примечание. Если файл с одним именем находится и в папке XLStart, и в дополнительной папке автозагрузки, будет открываться файл из папки XLStart.


 Добавление новых данных при изменении диапазона внешних данных

Добавление новых данных при изменении диапазона внешних данных

  1. Если диалоговое окно Свойства внешнего диапазона не отображено, наведите указатель на одну из ячеек диапазона внешних данных, а затем выберите Свойства диапазона данных [image] на панели инструментов Внешние данные.

  2. Чтобы указать способ добавления новых данных (вставка ячеек или целых рядов, замена существующих данных при обновлении в случае изменения диапазона внешних данных), выберите нужный параметр в группе Если количество строк в диапазоне изменится.


 Указание учетной записи электронной почты, используемой для отправки сообщений

Указание учетной записи электронной почты, используемой для отправки сообщений

Эта процедура применима, если Microsoft Outlook установлен в режиме только почты Internet. Информация об установке Microsoft Outlook.

  1. Откройте в Microsoft Excel лист, который требуется отправить.

  2. На панели инструментов Стандартная нажмите кнопку Электронная почта [image] .

  3. Установите переключатель в положение Отправить всю книгу как вложение или Включить текущий лист в текст сообщения.

  4. Нажмите кнопку Параметры.

  5. В поле Отправить сообщение на выберите учетную запись, которую требуется использовать, и нажмите кнопку Закрыть.


Одновременный просмотр двух частей листа

  1. Наведите указатель на вешку, расположенную в верхней части вертикальной полосы прокрутки или в правой части горизонтальной полосы прокрутки.

  2. Когда указатель примет вид двунаправленной стрелки [image], перетащите его вниз или влево.

Чтобы получить более подробные сведения об одновременном просмотре нескольких листов или книг, нажмите кнопку [image] .


Запуск NetMeeting

  • В меню Пуск Windows выберите пункт Программы, а затем — пункт NetMeeting.


Отмена загрузки книги при запуске Excel

Книга, хранящаяся в папке XLStart Все книги, хранящиеся в папке XLStart, загружаются автоматически при запуске Microsoft Excel. В Проводнике Windows удалите значок книги из папки XLStart.

Книга, хранящаяся в дополнительной папке автозагрузки В меню Сервис выберите команду Параметры и перейдите на вкладку Общие. Измените или удалите путь в поле Каталог автозагрузки:.

Ярлык с ключом автозагрузки, указывающим на книгу Удалите ключ автозагрузки.

Примечание. Если не должна загружаться пустая книга, используйте ключ автозагрузки.


 Использование нескольких итоговых функций для обработки данных сводной таблицы или сводной диаграммы

Использование нескольких итоговых функций для обработки данных сводной таблицы или сводной диаграммы

Эта процедура выбора нескольких итоговых функций может быть использована только для полей отчетов сводных таблиц, основанных на не-OLAP исходных данных. Для отчетов, использующих данные OLAP, каждое поле данных имеет единственную итоговую функцию, а доступные итоговые функции зависят от определения куба на сервере. Можно добавить другое поле данных с другой итоговой функцией, если такое поле доступно на сервере. Дополнительную информацию об итоговых функциях, доступных на сервере, можно получить у администратора базы данных OLAP.

Чтобы увидеть результаты различных итоговых функций в поле данных в отчете сводной диаграммы, выполните следующие действия в связанном отчете сводной таблицы. Результаты будут отображены в диаграмме.

  1. Выберите из списка полей на панели инструментов Сводные таблицы поле, по которому уже производится суммирование в области данных отчета сводной таблицы, и перетащите его в область данных еще раз.

  2. В области данных отчета сводной таблицы выберите новое поле и нажмите кнопку Параметры поля [image] на панели инструментов Сводные таблицы.

  3. Выберите другую итоговую функцию для этого поля в списке Операция.

Итоговые функции, доступные для сводных таблиц и отчетов сводных диаграмм, основанных на источниках данных, не являющихся базами данных OLAP.


Промежуток между датами, представленными на диаграмме

Если данные листа для оси категорий содержат формат дат, то Microsoft Excel автоматически использует в диаграмме особый тип оси, называемый ось времени. Ось времени выводит пустые категории для дат, по которым нет никаких данных. Если эти пустые категории выводить не нужно, например, если имеются данные на 1 января, 15 января, 3 февраля, 12 февраля и 2 марта и необходимо, чтобы даты располагались рядом друг с другом, то можно заменить ось времени на стандартную ось категорий. Для этого выделите диаграмму, а затем в меню Диаграмма выберите команду Параметры диаграммы. Потом на вкладке Оси выберите команду Категории под Осью категорий (Х).

Для получения дополнительных сведений об осях времени нажмите кнопку [image] .


 Вдоль горизонтальной оси отсутствует текст

Вдоль горизонтальной оси отсутствует текст

В диаграмме может быть недостаточно места для вывода названий осей. Если каких-либо названий категорий вдоль горизонтальной оси диаграммы не видно, то попробуйте предпринять следующее:

  • Если диаграмма является внедренной, выберите ее, а затем, чтобы увеличит размер, переместите один из черных маркеров. По умолчанию при изменении размера диаграммы размеры шрифтов изменяются пропорционально.

  • Выберите ось, затем нажмите стрелку рядом с кнопкой Размер шрифта [image] , и выберите меньший размер шрифта.

  • Дважды щелкните кнопку мыши на названии оси, а затем на вкладке Выравнивание измените угол вращения. Если угол составляет 0, 90 или – 90 градусов, то текст будет повернут.


 Не функционируют кнопки "Зависимые ячейки" и "Влияющие ячейки".

Не функционируют кнопки "Зависимые ячейки" и "Влияющие ячейки".

Если при нажатии кнопки Зависимые ячейки [image] или кнопки Влияющие ячейки [image] панели инструментов Зависимости раздается сигнал, то это означает, что найдены все уровни формулы или что объект недоступен для отслеживания. Ниже приведен список объектов, для которых невозможно проверить зависимости:

  • Ссылки на надписи, внедренные диаграммы и рисунки.

  • Отчеты сводных таблиц

  • Ссылки на именованные константы.

  • Формулы, содержащие ссылку на активную ячейку, которые находятся в закрытой книге.


Команды проверки недоступны

Команды проверки недоступны на защищенном листе. Чтобы снять защиту, выберите команду Защита в меню Сервис, а затем — Снять защиту листа.


 Стрелки слежения исчезают при правке листа

Стрелки слежения исчезают при правке листа

Все стрелки слежения исчезают при изменении формулы в проверяемой зависимости, вставке или удалении столбцов или строк, удалении или перемещении ячеек. Чтобы восстановить стрелки слежения после сделанных изменений, необходимо снова проверить зависимости.

Совет. Чтобы сохранить стрелки слежения, следует перед редактированием распечатать лист со стрелками слежения.


 Выбор способа пересчета листа или книги

Выбор способа пересчета листа или книги

  1. В меню Сервис выберите пункт Параметры и перейдите на вкладку Вычисления.

  2. Установите необходимые параметры на вкладке Вычисления.

    Для получения справки по конкретному параметру нажмите кнопку с вопросительным знаком [image] и выберите нужный параметр.

  3. Если переключатель установлен в положение, отличное от Автоматически, нажмите клавишу F9 для вычисления все листов во всех открытых книгах.

    Чтобы провести вычисления только в активном листе, нажмите клавиши SHIFT+F9.

Примечание. При обновлении связей с листами, на которых пересчет формулы выполнялся вручную, на экране появится сообщение о том, что в источнике данных не произведен пересчет формул. Чтобы обновить связь, используя текущие значения ячеек источника данных, даже если это действие неверно, нажмите кнопку OK. Чтобы прервать обновление связи и использовать значения, полученные из источника данных ранее, нажмите кнопку Отмена.


Типы сообщений, выводимых при проверке данных

Тип сообщения | Кнопки | Назначение
Сведения | OK | Вводит некорректные данные в ячейку (кнопка по умолчанию).
 | Отмена | Возвращает в ячейку старое значение.
Ошибка | Повторить | Позволяет исправить содержимое ячейки (кнопка по умолчанию).
 | Отмена | Возвращает в ячейку старое значение.
Предупреждение | Да | Вводит некорректные данные в ячейку.
 | Нет | Позволяет исправить содержимое ячейки (кнопка по умолчанию).
 | Отмена | Возвращает в ячейку старое значение.

Примечание. Предупреждение содержит запрос на продолжение работы. Если поле Сообщение не содержит никакого текста, на экране будет появляться сообщение о том, что заданное значение неверно и на допустимые для ячейки значения пользователем было наложено ограничение.


 Ограничения режима выделения исправлений в Microsoft Excel

Ограничения режима выделения исправлений в Microsoft Excel

Если с помощью команды Выделить исправления (меню Сервис, команда Исправления), установлен режим выделения исправлений, в книге Microsoft Excel выделяются цветом следующие изменения:

  • Изменения содержимого ячеек, в том числе перемещенные и вставленные значения

  • Вставленные или удаленные строки и столбцы

В Microsoft Excel не выделяются следующие изменения:

  • Форматирование

  • Скрытые и отображенные строки и столбцы

  • Изменения названий вкладок листов. Сведения об изменениях, внесенных в имена листов, записаны в лист изменений.

  • Вставленные или удаленные листы

  • Новые примечания и изменения, внесенные в примечания. Если пользователь добавил к исправленной ячейке собственные примечания, примечание пользователя появляется при помещении указателя на эту ячейку, после сведений об исправлениях.

  • Значения ячеек, изменившиеся в результате внесения изменений в зависимые ячейки или формулы. Сведения об этих изменениях можно получить с помощью панели инструментов Зависимости.

  • Если книга является общей, в ней недоступны некоторые функции и, соответственно, невозможны некоторые изменения. Для получения дополнительных сведений по тому вопросу нажмите кнопку [image] .

Примечания

  • Исправления можно просмотреть в том порядке, в котором они были занесены в книгу, а затем подтвердить или отменить каждое из них. Для получения дополнительных сведений нажмите кнопку [image] .

  • Изменения могут выделяться сразу при вводе, но в лист изменений заносятся только сохраненные изменения. Чтобы внести на лист изменений все изменения, произведенные за сеанс работы, сохраните книгу до открытия листа изменений.

  • Некоторые команды и операции Microsoft Excel не доступны в общих книгах. Для получения дополнительных сведений по этому вопросу нажмите кнопку [image] .


 Удаление надстроек из Microsoft Excel

Удаление надстроек из Microsoft Excel

  1. Выберите команду Надстройки в меню Сервис.

    Демонстрация

  2. В списке Список надстроек снимите флажок той надстройки, которую необходимо удалить из Microsoft Excel.

  3. Чтобы удалить надстройку из памяти, перезапустите Excel.

    Примечание. Когда надстройка удаляется из Excel, файлы надстройки не уничтожаются. Инструкции по удалению файлов надстроек с компьютера.


Указание изменяемых графических объектов на защищенном листе

Чтобы разблокировать графические объекты и получить возможность их изменять, лист должен быть незащищен. Сведения о способах снятия защиты с листа можно получить, нажав кнопку [image] .

Графические объекты включают внедренные диаграммы, карты, созданные с помощью надстройки Microsoft Map, кнопки, поля и другие объекты, созданные с помощью панелей инструментов Рисование и Формы. Нет необходимости разблокировать кнопку или элемент управления, чтобы иметь возможность использовать их, поскольку они выполняют назначенные им функции и после защиты листа. Однако если имеется связанная ячейка, она должна быть разблокирована при защите содержимого листа. Кнопки следует разблокировать, если предполагается изменение их текста, внешнего вида или свойств.

  1. Выделите разблокируемый графический объект, щелкнув его мышью при нажатой клавише CTRL.

  2. В меню Формат выберите команду, соответствующую выделенному объекту. В зависимости от типа графического объекта это будут команды АвтоФигура, Объект, Поле, Рисунок, Элемент управления или Объект WordArt.

  3. Выберите вкладку Защита.

  4. Снимите флажок Защищаемый объект.

    Если выбранный объект является полем, подписью, окном группы, кнопкой, флажком или переключателем, снимите флажок Скрыть текст.

Примечание. После защиты листа возможно изменение только графических объектов, разблокированных описанным выше способом.

Советы

  • Чтобы найти на листе графические объекты выберите команду Перейти в меню Правка, нажмите кнопку Выделить, а затем установите переключатель в положение Объекты.

  • Для перемещения между разблокированными графическими объектами в защищенном листе, выберите разблокированный объект и нажмите клавишу TAB для перехода к следующему объекту.

  • Если лист содержит заблокированные объекты, назначить макрос кнопке можно в случае, когда флажок Скрыть текст установлен, а флажок Защищаемый объект — сброшен.


 Задание изменяемых ячеек на защищенном листе

Задание изменяемых ячеек на защищенном листе

Чтобы разблокировать ячейки и получить возможность их изменять, лист должен быть незащищен. Сведения о способах удаления защиты с листа можно получить, нажав кнопку [image] .

  1. Выделите диапазон разблокируемых ячеек.

    Инструкции

  2. В меню Формат выберите команду Ячейки, а затем — вкладку Защита.

  3. Снимите флажок Блокировка.

Примечание. После защиты листа возможно изменение только ячеек, разблокированных описанным выше способом.

Совет. Для перемещения между разблокированными ячейками на защищенном листе, выберите разблокированную ячейку и нажмите клавишу TAB.


 Обновление данных в сводной таблице и отчете сводной диаграммы

Обновление данных в сводной таблице и отчете сводной диаграммы

  1. Щелкните отчет сводной таблицы или сводной диаграммы.

  2. На панели инструментов Сводные таблицы нажмите кнопку Обновить данные [image] .

Примечания

  • Обновление для исходных данных OLAP Если отчеты сводных таблиц и сводных диаграмм основаны на исходных данных из базы данных OLAP, Microsoft Excel автоматически обновляет их при любом изменении отображаемого отчета. Если исходные данные расположены в файле автономного куба, команда Обновить данные соединит Excel с исходной базой данных OLAP, обновит как данные в файле куба, так и данные отображаемые в отчете и отсоединится от базы данных OLAP. Инструкции по обновлению кубов и файлов куба.

  • Автоматическое обновление Excel может обновлять отчет сводной таблицы или сводной диаграммы при каждом открытии книги и/или по прошествии определенного интервала времени. Нажмите кнопку Сводная таблица (или Сводная диаграмма) на панели инструментов Сводные таблицы, выберите команду Параметры таблицы (или Параметры). В группе Данные установите флажок Обновить при открытии для обновления при каждом открытии книги. Чтобы периодически обновлять отчет, построенные по внешним данным, установите флажок Обновлять каждые и введите требуемый интервал обновления в поле минут. Этот флажок доступен для отчетов, основанных на исходных данных Excel.

  • Добавление новых полей из обновленных данных Если отчет сводной таблицы или сводной диаграммы основан на списке Microsoft Excel и добавлены новые поля в диапазоне исходных данных, новые поля появляются в списке полей на панели инструментов Сводные таблицы после обновления отчета. Затем можно добавить новые поля к отчету сводной таблицы или сводной диаграммы. Если новые поля или данные оказываются вне объявленного исходного диапазона, можно расширить исходный диапазон.

  • Автоматический ввод пароля Чтобы сохранить пароль внешней базы данных как часть запроса, чтобы не было необходимости вводить пароль при каждом обновлении отчета сводной таблицы или сводной диаграммы, нажмите кнопку Сводная таблица (или Сводная диаграмма) на панели инструментов Сводные таблицы , затем выберите Параметры таблицы (или Параметры). Установите флажок сохранить пароль в группе Внешние данные. Если эта возможность недоступна, она может быть запрещена администратором.

  • Влияние обновления форматирование сводной диаграммы. При обновлении отчета сводной диаграммы или отчета сводной таблицы, который связан с отчетом сводной диаграммы, некоторые параметры форматирования диаграммы могут быть утеряны.


 Использование специального порядка сортировки в сводной таблице или отчете сводной диаграммы

Использование специального порядка сортировки в сводной таблице или отчете сводной диаграммы

  1. Выделите сортируемое поле.

    Для отчета сводной диаграммы выберите поле в связанном отчете сводной таблицы. Чтобы отсортировать подписи рядов диаграммы, выберите соответствующее поле столбца. Чтобы отсортировать подписи категорий диаграммы, выберите соответствующее поле строки.

  2. В меню Данные выберите команду Сортировка.

  3. Нажмите кнопку Параметры.

  4. В поле Сортировка по первому ключу выберите требуемый вариант.

Примечания

  • Специальный порядок сортировки не сохраняется при обновлении Специальный порядок сортировки не сохраняется при обновлении отчета сводной таблицы. Чтобы восстановить порядок сортировки, произведите повторную сортировку по данному полю.

  • Создание нового специального порядка сортировки Для получения информации о создании специального порядка сортировки нажмите кнопку [image] .

  • Встроенные специальные порядки сортировки Если отчет сводной таблицы содержит элементы, которые обычно сортируются в хронологическом, а не в алфавитном порядке — например "Янв", "Фев", "Мар" — в Microsoft Excel автоматически используется встроенный специальный порядок сортировки. Если элементы полей были перемещены или упорядочены иначе, исходный хронологический порядок можно восстановить сортировкой с использованием специального порядка сортировки.

  • Влияние на связанные отчеты сводных диаграмм. При сортировке данных в отчете сводной таблицы, который связан с отчетом сводной диаграммы, некоторые параметры форматирования в отчете сводных диаграмм могут быть утеряны.


Использование формы Microsoft Access для ввода данных в список Microsoft Excel

Чтобы ввести данные с помощью формы Microsoft Access, которая была создана командой Форма Access в меню Данные.

  1. Нажмите на листе кнопку Форма Access, которая находится справа от списка.

  2. Введите данные с помощью появившейся формы. Для получения более подробных сведений о вводе данных в форме обратитесь к справочной системе Microsoft Access.

Примечания

  • Если форма не будет найдена автоматически, появится диалоговое окно Создание формы Microsoft Access. Для поиска файла воспользуйтесь кнопкой Обзор.

  • Для получения дополнительных сведений о формах и мастере форм Microsoft Access, обратитесь к справочной системе Microsoft Access.


 Использование данных Microsoft Excel при создании почтовых документов в Word

Использование данных Microsoft Excel при создании почтовых документов в Word

Описанный ниже порядок действий может использоваться при создании писем, почтовых наклеек и других документов, в которых список данных объединяется с документом Word. Однако предварительно необходимо создать список, в который должны быть включены названия столбцов и в котором не должно быть пустых строк. Чтобы получить более подробные сведения о создании списка, нажмите кнопку [image] .

  1. Сохраните и закройте книгу Excel, содержащую список, который должен быть объединен с документом Word.

  2. Перейдите в Microsoft Word.

  3. Откройте основной документ Word со стандартным текстом письма или другой документ, который должен быть объединен со списком.

    При создании нового документа или печати почтовых наклеек и конвертов нажмите кнопку Создать [image] для открытия нового документа.

  4. В меню Сервис приложения Word выберите команду Слияние.

  5. Нажмите кнопку Создать и выберите тип документа.

  6. Нажмите кнопку Получить данные, а затем выберите Открыть источник данных.

  7. В диалоговом окне Открытие источника данных откройте папку с соответствующей книгой Microsoft Excel.

  8. В списке Тип файлов выберите элемент Книги MS Excel (*.xls).

  9. Дважды щелкните книгу с необходимыми данными.

  10. В диалоговом окне Microsoft Excel выберите именованный диапазон или задайте ссылки на ячейки, обозначающие используемые данные, после чего нажмите кнопку OK.

  11. После того, как Word отобразит сообщение, нажмите кнопку Изменение основного документа или Настройка основного документа.

  12. При создании письма воспользуйтесь списком Вставить поле слияния (панель инструментов Слияние) для вставки в стандартный текст полей слияния. По завершении нажмите кнопку Диалоговое окно "Слияние" [image] на панели Слияние.

    Для печати наклеек или конвертов выберите принтер и задайте размер бумаги. После этого вставьте поля слияния в диалоговым окне Создание наклеек или Адрес на конверте.

  13. В диалоговом окне Диалоговое окно " Слияние" нажмите кнопку Слияние и задайте необходимые параметры.

Советы

  • Чтобы получить более подробные сведения об объединении документов в Word, воспользуйтесь справкой помощника по Office или справочной системой Word.

  • Чтобы перед выбором списка в Word отобразить только объединяемые данные и строки, необходимо сначала выполнить фильтрацию списка в Microsoft Excel. При выборе фильтрованного списка в Word, укажите соответствующий параметр в диалоговом окне Microsoft Excel. Чтобы получить более подробные сведения о фильтрации списка, нажмите кнопку [image] .


 Просмотр изменений, внесенных в книгу другими пользователями

Просмотр изменений, внесенных в книгу другими пользователями

С помощью описанной ниже процедуры можно просмотреть изменения, внесенные в книгу другими пользователями с момента последнего закрытия общей книги.

  1. В меню Сервис выберите пункт Исправления, а затем выполните команду Выделить исправления.

    Демонстрация

  2. Установите флажок Отслеживать исправления. Этот флажок служит для установки режима совместного доступа к книге и ведения журнала изменений.

    Если флажок Отслеживать исправления не установлен, никакие изменения не запоминаются.

  3. Установите флажок по времени, а затем выберите Со времени последнего сохранения в поле по времени.

  4. Убедитесь, что флажки пользователем и в диапазоне сняты.

  5. Чтобы просмотреть изменения, выделенные цветом (при этом дополнительные данные изображаются при помещении указателя мыши на соответствующую ячейку), установите флажок Выделять исправления на экране.

    Чтобы просмотреть сведения о внесенных изменениях на отдельном листе изменений, установите флажок Вносить изменения на отдельный лист.

  6. Нажмите кнопку OK и, если будет предложено, сохраните книгу.

Примечания

  • Флажок Вносить изменения на отдельный лист становится доступным только после того, как книга будет сохранена с установленным флажком Отслеживать исправления.

  • При сохранении книги Microsoft Excel лист изменений автоматически удаляется. Чтобы просмотреть лист изменений после сохранения книги, необходимо повторить шаги с 1 по 6.


 Просмотр всех внесенных в книгу изменений

Просмотр всех внесенных в книгу изменений

  1. В меню Сервис выберите пункт Исправления, а затем выполните команду Выделить исправления.

    Демонстрация

  2. Установите флажок Отслеживать исправления. Этот флажок служит для установки режима совместного доступа к книге и ведения журнала изменений.

    Если флажок Отслеживать исправления не установлен, никакие изменения не запоминаются.

  3. Установите флажок по времени, а затем в поле по времени выберите значение Все.

  4. Чтобы просмотреть сведения о внесенных изменениях на отдельном листе изменений, установите флажок Вносить изменения на отдельный лист. В листе изменений сведения о внесенных изменениях можно отбирать в соответствии с заданными условиями.

    Чтобы просмотреть изменения, выделенные цветом (при этом дополнительные данные изображаются при помещении указателя мыши на соответствующую ячейку), установите флажок Выделять исправления на экране.

  5. Нажмите кнопку OK и, если будет предложено, сохраните книгу.

Примечания

  • Флажок Вносить изменения на отдельный лист становится доступным только после того, как книга будет сохранена с установленным флажком Отслеживать исправления.

  • Из перечисленных в листе изменений можно отобрать только изменения определенного вида, соответствующие указанным условиям. На листе изменений щелкните стрелку справа от заголовка столбца, содержащего нужные сведения, а затем выберите вид данных, которые должны быть изображены в этом столбце. Условия отбора можно усложнить, добавив условия для других столбцов.

  • Лист изменений не обновляется автоматически. Чтобы обновить сведения листа изменений, так, чтобы в него вошли данные об изменениях, внесенных в книгу и сохраненных с момента последнего открытия листа изменений, сохраните книгу и повторите этапы 1 — 5. Лист изменений будет составлен снова.


 Просмотр изменений, относящихся к определенной дате, пользователю или диапазону ячеек

Просмотр изменений, относящихся к определенной дате, пользователю или диапазону ячеек

  1. В меню Сервис выберите пункт Исправления, а затем выполните команду Выделить исправления.

    Демонстрация

  2. Установите флажок Отслеживать исправления. Этот флажок служит для установки режима совместного доступа к книге и ведения журнала изменений.

    Если флажок Отслеживать исправления не установлен, никакие изменения не запоминаются.

  3. В группе «Отслеживать исправления, внесенные» выберите интересующие типы изменений. Должен быть выбран хотя бы один тип из:

    Чтобы просмотреть изменения, внесенные в книгу после указанной даты, установите флажок по времени, выберите пункт С даты в поле по времени, а затем введите нужную дату в поле по времени. Чтобы просмотреть все изменения, внесенные в книгу после установки режима ведения журнала изменений, выберите пункт все в поле по времени.

    Чтобы просмотреть изменения, внесенные определенным пользователем, установите флажок пользователем, а затем выберите имя пользователя в поле пользователем.

    Чтобы просмотреть все изменения, внесенные в определенный диапазон ячеек, установите флажок в диапазоне, а затем укажите диапазон в поле в диапазоне, или выделите его на листе книги. Чтобы просмотреть изменения во всей книге, снимите флажок в диапазоне.

  4. Чтобы просмотреть изменения, выделенные цветом (при этом дополнительные данные изображаются при помещении указателя мыши на соответствующую ячейку), установите флажок Выделять исправления на экране.

    Чтобы просмотреть сведения о внесенных изменениях на отдельном листе изменений, установите флажок Вносить изменения на отдельный лист.

  5. Нажмите кнопку OK и, если будет предложено, сохраните книгу.

Примечания

  • Флажок Вносить изменения на отдельный лист становится доступным только после того, как книга будет сохранена с установленным флажком Отслеживать исправления.

  • При сохранении книги Microsoft Excel лист изменений автоматически удаляется. Чтобы просмотреть лист изменений после сохранения книги, необходимо повторить шаги с 1 по 5.


Способы поиска значений на листе с помощью фильтров (расширенный фильтр)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Способы поиска значений на листе с помощью фильтров (основной автофильтр)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Способы поиска значений на листе с помощью фильтров (пользовательский автофильтр)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Способы поиска значений на листе с помощью фильтров (фильтр по выделенному)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Подготовка к печати (добавление верхнего и нижнего колонтитулов)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Подготовка к печати (изменение разметки страницы)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Подготовка к печати (проверка разрывов страниц)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Подготовка к печати (форматирование листа на экране)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Подготовка к печати (предварительный просмотр и настройка полей)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


Подготовка к печати (повторение заголовков на каждой странице)

Для просмотра этого раздела щелкните рисунок.

Для просмотра этого раздела щелкните рисунок


 Что необходимо знать для работы с общей книгой

Что необходимо знать для работы с общей книгой

Работа с общей книгой отличается от работы с книгой, не являющейся общей, по следующим пунктам:

Общая книга требует Microsoft Excel 97 или более поздней версии Чтобы вносить изменения в общую книгу, необходимо использовать Microsoft Excel 97 или более поздней версии. Предыдущие версии не могут быть использованы. Допускается одновременная работа с общей книгой на компьютерах с операционной системой Windows и на компьютерах Макинтош, если используется Excel для Windows, версия 97 или более поздняя, и Excel для Макинтош, версия 98 или более поздняя.

Пользователи идентифицируются по имени пользователя Когда в общую книгу вносятся изменения, Microsoft Excel использует имя пользователя для фиксации внесенных им изменений. Чтобы установить имя пользователя, в меню Сервис выберите команду Параметры и на вкладке Общие.введите свое имя пользователя в поле Имя пользователя.

Некоторые команды недоступны Некоторые команды и операции Excel недоступны для общей книги. Для получения дополнительной информации нажмите на кнопку [image] .

В ячейке может появиться несколько комментариев Если несколько пользователей добавляют примечания в одну и ту же ячейку общей книги, то когда каждый пользователь сохранит общую книгу, появятся тексты всех сохраненных примечаний для ячейки.

Изменения, сделанные другими пользователями, могут быть просмотрены По умолчанию можно просмотреть изменения, сохраненные другими пользователями общей книги, при каждом сохранении книги. Эти обновления можно получать автоматически через определенный интервал времени. Каждый пользователь может задать свой интервал обновления. Для получения дополнительной информации нажмите кнопку [image] .

Конфликты могут разрешаться автоматически или вручную По умолчанию если изменения, сохраняемые одним пользователем, будут противоречить изменениям, сохраненными другими, Microsoft Excel предложит выбрать в диалоговом окне Возник конфликт доступа сохранять или нет противоречащие изменения. Предоставляется возможность автоматического сохранения изменений даже в случае их противоречия данным, введенным ранее. Чтобы получить более подробные сведения, нажмите кнопку [image] .

Фильтры и параметры печати хранятся для каждого пользователя в отдельности По умолчанию Excel сохраняет для каждого пользователя его персональный фильтр и параметры печати для общей книги. Чтобы получить более подробные сведения, нажмите кнопку [image] .

Все изменения в общей книге могут быть просмотрены Имеется возможность просмотра полного списка изменений книги, включая имена пользователей, которые произвели эти изменения, дату удаления или перемещения и сведения о противоречивых изменениях. Чтобы получить более подробные сведения, нажмите кнопку [image] .


Слово, добавленное в дополнительный словарь, считается ошибочным при проверке орфографии

  • Слово может считаться ошибочным, если в нем сочетаются строчные и прописные буквы. Все слова в словаре должны быть написаны строчными буквами; в этом случае все комбинации написания букв в слове будут считаться правильными.

  • Слово может находиться в другом словаре. При проверке орфографии слова сверяются только с одним словарем. Если слово считается ошибочным, проверьте, что выбран правильный словарь в поле с раскрывающимся списком Добавлять слова в в диалоговом окне Проверка орфографии.

  • Дополнительный словарь может содержать скрытые символы или пропущенные слова. Чтобы открыть словарь, используемый в Microsoft Excel, воспользуйтесь программой Блокнот. Исправьте словарь и удалите скрытые символы. Сохраните словарь в папке, содержащей основной словарь. Если для правки дополнительного словаря используется Microsoft Word или другое приложение, сохраните файл в текстовом формате и оставьте без изменения расширение .dic.


Изменение внешнего вида примечания при помощи средств панели рисования

Предполагаемые действия

Изменение цвета линии или границы рисованного объекта

Изменение типа линии или границы рисованного объекта

Изображение штриховой линии или границы вокруг рисованного объекта

Добавление тени или объема для графического объекта


Изменение рисунков на листах или в диаграммах

Предполагаемые действия.

Вставка и изменение рисунка

Изменение типа линии или границы графического объекта

Изображение штриховой линии или границы вокруг графического объекта

Добавление тени или объема для графического объекта

Изменение свойств текста

Добавление и изменение фигурного текста

Замена типа автофигуры

Добавление, изменение или удаление заливки в графическом объекте

Поворот графического объекта

Зеркальное отражение графических объектов

Изменение размеров и обрезка графического объекта

Выравнивание и размещение графических объектов


(Untitled)

Можно создать список, из которого пользователь будет выбирать значения. Используйте команду Проверка в меню Данные для создания списка. Ограничение значений, вводимых в ячейку, данными из списка

Раскрывающийся список с допустимыми значениями


(Untitled)

Можно создать сообщение, которое будет появляться при вводе неправильных данных в ячейку. Можно выбирать из трех типов сообщений: «Останов», «Предупреждение» и «Сообщение». Выбранный тип сообщения определяет жесткость накладываемых ограничений. «Останов» не позволяет пользователю продолжить ввод до тех пор, пока он не введет допустимое значение. «Предупреждение» и «Сообщение» сообщают об ошибке, но позволяют ввести значение, не попадающее в диапазон ограничений.

Если Помощник включен, то он доставит сообщение.

Сообщение о неправильных данных

Отображение сообщения при вводе неправильных данных в ячейку


(Untitled)

Можно найти все ячейки, содержимое которых не удовлетворяет заданному условию, и автоматически обвести их кружками, нажав кнопку Обвести неверные данные на панели инструментов Зависимости. См. дополнительные сведения о выявлении неправильных значений в ячейках

После исправления значения кружок исчезает.

Лист с обведенными неправильными данными


(Untitled)

Сообщение, помогающее пользователю Можно создать сообщение, которое будет появляться при выделении ячейки. Сообщение описывает тип данных, которые могут быть введены в ячейку. Можно установить ограничения на данные, вводимые в ячейку, установить минимальное и максимальное значение или проверить влияние, оказываемое значением в ячейке на другие ячейки. Инструкции по выводу сообщения при переходе к ячейке

Подсказка с инструкциями


Отображение данных на карте

Данный раздел содержит следующие сведения:

Создание карты

Добавление подписей, текстов и флажков

Параметры и форматы карты

Создание карты

Карта и данные листа

Карта и данные листа

Можно создать карту для анализа продаж или исследований рынка по географическим регионам. Сначала необходимо расположить информацию в столбцах листа. Один столбец должен содержать географические данные, например названия стран или областей.

Данные листа

Можно использовать демографические данные, включенные в карту (например, население или семейный доход), вместе с другими данными для выявления тенденций и выполнения анализа на карте. Посмотрите файл Mapstats.xls, расположенный в папке Data внутри папки, в которой была установлена программа Microsoft Map

Возврат в начало

Добавление подписей, текстов и флажков

Можно автоматически добавить подписи к компонентам карты, например странам. Можно даже создать набор специальных подписей для пометки важных мест на карте и сохранить его в виде набора флажков для будущего использования. Когда используется панель инструментов Карта, можно легко добавить подписи, текст и флажки.

Кнопки панели инструментов «Карта»

Кнопки на панели инструментов «Карта» для добавления текстов, подписей и специальных флажков.

Возврат в начало

Параметры и форматы карты

Можно выполнить анализ или получить требуемое представление данных, отображая разные столбцы данных с листа на карте. Можно также указать формат данных, например плотность точек или пропорциональные символы.

Чтобы изменить данные, отображаемые на карте, перетащите кнопку заголовка столбца в поле диалогового окнаЭлемент Microsoft Map. Затем перетащите кнопку формата к заголовку столбца. Чтобы изменить параметры формата карты, дважды щелкните формат или заголовок столбца, указанные в поле.

Диалоговое окно «Элемент Microsoft Map»

Диалоговое окно «Элемент Microsoft Map»

Возврат в начало


 (Untitled)

Microsoft Excel предлагает средства, помогающие устранять затруднения, возникающие при работе на листе. Например, значение, отображаемое в ячейке, может быть может быть результатом вычисления по формуле или использоваться в формуле, дающей неправильный результат. Команды проверки зависимостей графически отображают взаимоотношения между формулами и ячейками с помощью стрелок слежения.

Когда на листе проверяются зависимости, можно выявить влияющие ячейки (ячейки, значение которых используется в указанной ячейке) или зависимые ячейки (ячейки, которые зависят от значения в указанной ячейке).

Лист со стрелками слежения

Одна синяя стрелка слежения свидетельствует о том, что ячейки с D9 по D11 являются влияющими ячейками для ячейки B5, которая содержит формулу =СУММ(D9:D11). Другая — о том, что ячейки C9, C10, и C11 являются влияющими для B6, содержащей формулу =C9+C10+C11. Обратите внимание, что ячейки D9:D11 — диапазон и, поэтому, показаны как группа.

Дополнительные сведения

Вычисление значений в формулах


 Форматирование диаграмм

Форматирование диаграмм

Данный раздел содержит следующие сведения:

Цвет, текстура и градиентная заливка

Числовые форматы, масштаб оси и деления

Шрифты и поворот текста

Дополнительные возможности форматирования для разных типов диаграмм

Диаграмма с форматированием

Рис. 1

Цвет, текстура и градиентная заливка

Выбор цвета, границ и заливки допускается в маркерах данных, в области диаграммы, в области построения и в других элементах диаграммы.

На рисунке 1 в области построения используется двухцветная градиентная заливка. Маркер первого ряда данных («Факт.») имеет текстурную заливку. Маркер второго ряда данных («План.») имеет одноцветную заливку. При оформлении маркера третьего ряда данных («Издержки») используется эффект тени.

Дополнительные сведения

Изменение цвета, узора, линий и рамок на диаграмме

Изменение цвета в поверхностной диаграмме

Добавление рисунка к элементу диаграммы

Возврат в начало

Числовые форматы, масштаб оси и деления

Имеется возможность выбора диапазона значений, выводимых вдоль оси значений, а также изменения интервала между ними. На диаграмме (рис. 1) представлены значения в диапазоне от 0 до 140 с шагом 20. При необходимости ось можно снабдить делениями.

Числа на диаграмме могут форматироваться так же, как и в таблице данных. Щелкните мышью соответствующую ось или подпись данных и с помощью кнопок на панели инструментов Форматирование выберите один из основных числовых форматов (денежный, процентный, с разделителями).

Кнопки форматирования чисел на панели инструментов «Форматирование»

Рис. 2

Дополнительные сведения

Изменение формата чисел на диаграммах

Изменение шкалы оси значений

Изменение расстояния между подписями делений на оси категорий

Изменение вида и расположения подписей делений оси

Возврат в начало

Шрифты и поворот текста

Текст на диаграмме форматируются так же, как любой другой текст. Выберите мышью соответствующий текст или элемент и измените их шрифт, размер и цвет с помощью кнопок на панели инструментов Форматирование.

Кнопки форматирования текста на панели инструментов «Форматирование»

Рис. 3

Дополнительные сведения

Изменение шрифта и выравнивание текста на диаграмме

Выравнивание текста в заголовках диаграммы и надписях

Изменение положения текста в названии диаграммы или на оси

Возврат в начало

Дополнительные возможности форматирования для разных типов диаграмм

В оформлении диаграмм различных типов допускается использование специальных линий, полос, маркеров данных и других элементов. Так, изменяя степень перекрытия для рядов данных, можно добиться эффекта многослойности в гистограммах и линейчатых диаграммах.

В графике, который представлен на рисунке 1, каждый ромбовидный маркер снабжен тенью. Кроме того здесь используется эффект сглаживания линии.

Дополнительные сведения

Перекрытие или зазоры между маркерами данных на гистограммах и линейчатых диаграммах

Сглаживание линий на графиках

Изменение размера, цвета или формы маркеров данных на графике, точечной или лепестковой диаграммах

Возврат в начало


(Untitled)

Чтобы просмотреть подробные сведения о каждом изменении, зафиксируйте указатель мыши на выделенной ячейке.

Примечание с подробными сведениями

Примечание содержит подробные сведения о выделенной ячейке.

Можно также просмотреть подробные сведение на отдельном листе изменений, на котором можно выделить конкретные изменения и распечатать их.


 Не удается переместить поле сводной таблицы или сводной диаграммы в новое положение.

Не удается переместить поле сводной таблицы или сводной диаграммы в новое положение.

Проверьте параметры поля страницы Если в перемещаемом поле внешние данные обновляются при выборе каждого элемента, можно закрепить поле в области страничной ориентации. Выделите поле и нажмите кнопку Параметры поля [image] на панели инструментов Сводные таблицы. Нажмите кнопку Далее и снимите флажок запретить сведение по данному полю (рекомендуется) в группе Параметры поля страницы. Если поле более не находится в области страничной ориентации, выборка внешних данных происходит для всех элементов одновременно; перемещение поля в область страничной ориентации отменяет выборку внешних данных для всех элементов одновременно.

Проверьте исходные данные OLAP°°. В отчетах сводных таблиц или сводных диаграмм, основанных на исходных данных из базы данных OLAP, некоторые поля могут быть использованы в отчетах сводных таблиц только как поля строк, столбцов, страниц или как поля рядов данных, категорий или страниц в отчетах сводных диаграмм. Эти поля имеют значок значок поля измерения в начале строки на панели инструментов Сводные таблицы. Поля, имеющие значок значок поля данных, могут использоваться только как поля данных. Использует ли отчет данные OLAP.

Проверьте макросы Макросы на языке Visual Basic для приложений (VBA), используемые для создания отчета сводной таблицы или сводной диаграммы, могут отключать возможность изменения макета отчета перетаскиванием полей. Отображение в качестве указателя символа недопустимости операции при попытке перемещения поля означает, что для этого поля отключена возможность перемещения. Обратитесь за консультацией к разработчику макроса.

Проверьте защиту Если отчет сводной таблицы, который связан с отчетом сводной диаграммы, защищен, перемещение полей и внесение изменений в отчет сводной диаграммы невозможны. См. сведения о снятии защиты с книг и листов.


(Untitled)

Используя проверку данных, можно ограничить допустимые данные для ячейки. Excel может обводить неправильные данные, чтобы показать ячейки, значения в которых не удовлетворяют наложенным ограничениям.

Ячейка с неправильными данными

Значение в этой ячейке обведено кружком, поскольку оно не удовлетворяет условию проверки.

Когда значение в ячейке будет исправлено, кружок исчезнет.

Следует помнить, что правила проверки не применяются к ячейкам, содержащим формулы, ячейкам, значение которых изменилось в результате копирования или автозаполнения, и ячейкам, значение которых изменено макросом. В этих случаях неправильные данные не будут обведены.

Дополнительные сведения

Поиск некорректных значений на листе

Определение допустимых данных в ячейке

Обведенные ячейки с неверно введенными данными


(Untitled)

При проверке зависимостей на листе может возникнуть необходимость документировать структуру данных на листе. Можно вставить примечание относительно данных или формулы в ячейке.

Примечание к ячейке

Когда указатель мыши находится на ячейке с примечанием, Microsoft Excel отображает примечание на экране. Примечания могут быть напечатаны либо на своих местах на листе, либо в виде списка снизу от листа.

Дополнительные сведения

Добавление примечания к ячейке

Печать примечаний

Добавление примечаний и выделение изменений в книге


(Untitled)

При редактировании формулы Microsoft Excel автоматически показывает ячейки, на которые ссылается формула. Поиск диапазонов выделяет цветом каждую ссылку на диапазон и обводит тем же цветом границы соответствующей ячейки или диапазона.

Влияющие ячейки выделены различными цветами

Цветовое выделение показывает, что формула в ячейке D9 ссылается на ячейки B9 и C9.

Если необходимо изменить ячейки, включенные в диапазон, перетащите маркер в правом нижнем углу выделенного цветом диапазона. Чтобы выбрать другой диапазон, перетащите границу выделенного цветом диапазона на другое место.

Дополнительные сведения

Поиск и изменение ячеек, на которые ссылается формула, с помощью поиска диапазонов


 (Untitled)

Любая ячейка, содержащая формулу, ссылающуюся на выделенную ячейку, называется зависимой ячейкой. Значение в зависимой ячейке меняется при изменении выделенной ячейки.

Когда выбрана определенная ячейка и нажата кнопка Зависимые ячейки [image] , синяя стрелка слежения показывает формулы на текущем листе, зависящие от этой ячейки. Если нажать кнопку Зависимые ячейки еще раз, Microsoft Excel опустится на один уровень ниже и выделит все ячейки на текущем листе, на которые ссылаются зависимые ячейки.

Если ячейка в другом листе или книге ссылается на выбранную ячейку, черная стрелка слежения указывает на значок листа значок листа. Другая книга должна быть открыта, чтобы Excel смог проследить зависимости.

Синяя стрелка слежения между ячейками B9 и D9 показывает, что общая цена акций компании «Альбатрос» зависит от цены продажи. Синяя стрелка слежения между ячейками D9 и B5 показывает, что общая цена всех акций зависит от общей стоимости акций компании «Альбатрос».

Дополнительные сведения

Поиск зависимых ячеек


 (Untitled)

Если результат формулы дает значение ошибки, например #ДЕЛ/0!, можно использовать кнопку Источник ошибки [image] для поиска всех ячеек, используемых в вычислениях по формуле. Красные стрелки соединяют ячейку, вызвавшую ошибку, с ячейкой, содержащей значение ошибки, синие стрелки показывают влияющие ячейки для ячейки, вызвавшей ошибку.

Трассировка ошибочных значений

Красные стрелки слежения показывают, что ошибка #ДЕЛ/0! в ячейке G11 вызвана ошибкой в ячейке H11, которая затем вызывает ошибку в ячейке B3. Ячейка G11 содержит формулу =E11/B11; Microsoft Excel воспринимает значение ячейки B11 как 0, поскольку она пуста.

Дополнительные сведения

Поиск ячеек, ставших причиной ошибок в формуле


 (Untitled)

Если выбранная ячейка содержит формулу, можно обнаружить все ячейки, предоставляющие данные для формулы. Такие ячейки называются влияющими. Формула в выбранной ячейке вычисляется при изменении содержимого влияющей ячейки.

Когда нажата кнопка Влияющие ячейки [image] , синие стрелки слежения показывают ячейки на текущем листе, значение которых используется в формуле. Если кнопка Влияющие ячейки нажата еще раз, Microsoft Excel опускается на один уровень ниже и находит ячейки на текущем листе, на которые ссылаются влияющие ячейки.

Если выбранная ячейка содержит ссылку на другой лист или книгу, черная стрелка слежения соединяет выбранную ячейку и значок листа значок листа.

Синий прямоугольник вокруг ячеек D9:D11 и синяя стрелка слежения, указывающая на ячейку B5, показывают, что ячейки D9:D11 предоставляют данные для формулы в ячейке B5.

Дополнительные сведения

Поиск влияющих ячеек


(Untitled)

Можно установить ориентацию печатаемого листа как книжную или альбомную.

Когда использовать альбомную ориентацию Переключитесь на альбомную ориентацию, если необходимо напечатать намного больше столбцов, чем помещается на странице с книжной ориентацией. Если использование альбомной ориентации нежелательно, измените макет распечатываемого листа для размещения данных на имеющемся месте или подгоните поля.

Размещение данных на странице Печатаемое изображение можно разместить на странице, уменьшая или увеличивая его. Другие изменения макета печатаемого листа включают установку размера бумаги, размещение данных по центру страницы при печати, управление нумерацией страниц. Эти изменения влияют только на внешний вид листа при печати и не сказываются на отображении листа на экране.

Печать части данных Чтобы напечатать выбранные части данных на листе, можно указать печатаемые области.

Дополнительные сведения

Изменение ориентации страницы

Расположение данных листа Excel по центру печатаемой страницы

Задание размера бумаги

Изменение области листа Excel, отображаемой на странице при печати

Изменение размера и положения диаграммы на странице при печати


 (Untitled)

Разметка страниц показывает, где на листе появляются разрывы страниц и какая область листа будет напечатана. Установленные пользователем разрывы страниц обозначаются сплошными синими линиями, а автоматически установленные Microsoft Excel — пунктирными.

Просмотр разметки страниц

Когда перемещать разрывы страниц Чтобы уместить на текущей странице дополнительно одну или две строки, переместите разрыв страницы. В режиме разметки страниц это автоматически сжимает данные для размещения их на одной странице. Можно еще раз выполнить предварительный просмотр страницы и убедиться, что размер шрифта не стал слишком маленьким.

Принудительные разрывы страниц Чтобы закончить страницу в определенном месте и начать новую страницу, можно установить разрыв страницы.

Порядок печати и области печати Можно также просмотреть порядок печати страниц листа Excel и, перемещая разрывы страниц, подогнать распределение данных по страницам. Чтобы напечатать различные области листа, используйте режим разметки страницы для быстрой установки области печати и добавления и удаления других областей в область печати. Инструкции по установке области печати.


(Untitled)

Форматы и макеты, которые хороши для просмотра на экране, не всегда дают хорошие результаты при выводе на печать. Возможо возникнет необходимость в проведении некоторых корректировок. Например, если на экране изображение является цветным, а печатается оно на черно-белом принтере, необходимо убедиться в том, что используемые цвета достаточно контрастны.

Список, отформатированный для просмотра на экране

Дополнительные сведения

Изменение ширины столбца и высоты строки

Перенос по словам текста в ячейках

Изменение размера, шрифта и других форматов текста

Изменение числовых форматов

Использование рамок в ячейках


(Untitled)

Чтобы поместить числа или другой текст сверху или снизу данных листа на каждой странице, можно добавить верхний и нижний колонтитулы на печатаемый лист. Верхний колонтитул печатается наверху каждой страницы, нижний — появляется внизу каждой страницы.

Отпечатанные страницы с верхними колонтитулами

Верхний и нижний колонтитулы отделены от данных на листе — они появляются только при печати или предварительном просмотре. Кроме колонтитулов на каждой странице можно выводить и данные с листа, чтобы использовать их как заголовки при печати. Для получения дополнительной информации щелкните «Повторение заголовков на каждой странице» в оглавлении в левой части этого раздела.

Можно использовать встроенные колонтитулы Microsoft Excel или создать собственные колонтитулы.

Дополнительные сведения

Изменение шрифта для текста верхнего и нижнего колонтитулов


 (Untitled)

Чтобы просмотреть каждую страницу в том виде, в каком она будет напечатана, нажмите кнопку Предварительный просмотр [image] . В режиме предварительного просмотра можно посмотреть колонтитулы и заголовки, выводимые на каждой странице.

Когда следует подгонять поля Подгоните поля или столбцы, если данные немного не помещаются на странице и нельзя их сжать. В режиме предварительного просмотра можно изменить ширину полей и столбцов, перетаскивая маркеры изменения размера. Нажмите кнопку Поля для отображения маркеров.

Маркеры изменения размера

Сетки, порядок страниц и другие параметры В режиме предварительного просмотра можно изменить способ печати листа. Используя кнопку Страница можно включить или выключить вывод линий сетки, переключиться в режим быстрой печати черновика и изменить порядок печати страниц.


(Untitled)

Повторение подписей строк и столбцов Если данные на листе имеют подписи строк или столбцов (называемые также заголовками печати), Microsoft Excel может повторять эти подписи на каждой странице при печати листа.

Лист с заголовками печати

Подписи не обязательно должны располагаться в первых строках или столбцах листа, но они не будут повторяться до тех пор, пока не будет напечатана строка или столбец, в которых они находятся. Печать подписей на каждой странице.

Повторение заголовков строк и столбцов Можно также печатать номера строк и буквы для столбцов на листе (не путайте с подписями данных).

Можно использовать комбинацию колонтитулов, повторяющихся подписей и заголовков строк и столбцов.


 (Untitled)

Существует шесть различных видов линий тренда (аппроксимация и сглаживание), которые могут быть добавлены в диаграмму Microsoft Excel. Использование линии тренда того или иного вида определяется типом данных. Добавление линии тренда в диаграмму.

Надежность линии тренда Наиболее надежна линия тренда, для которой значение R-квадрат равно или близко к 1. При подборе линии тренда к данным Excel автоматически рассчитывает значение R2. Можно отобразить это значение на диаграмме.


Консолидация данных с использованием трехмерных ссылок

Данные, консолидированные из трех листов

Консолидация собирает данные из нескольких листов.

Использование трехмерных ссылок для объединения данных Если исходные листы имеют различные разметки и различные подписи данных, необходимо создать специальную разметку или необходимо использовать специальные итоговые формулы для консолидации, используйте трехмерные ссылки. Трехмерные ссылки обновляются автоматически при изменении исходных данных.

В приведенном ниже примете формула в ячейке A2 складывает три числа, расположенные в различных местах трех разных листов.

Формула для консолидации данных в трех листах

Добавление данных в консолидацию Если все исходные листы имеют одинаковую разметку, можно использовать диапазон имен листов в трехмерных формулах. Чтобы включить другой лист в консолидацию, просто переместите лист внутрь диапазона, на который ссылается формула.

Вставка листа в консолидацию

Дополнительные сведения

Консолидация данных


 (Untitled)

Формулы вычисляют значения в определенном порядке. Формула в Microsoft Excel всегда начинается со знака равенства (=). Знак равенства свидетельствует о том, что последующие символы составляют формулу. Элементы, следующие за знаком равенства, являются операндами, разделяемыми операторами вычислений. Формула вычисляется слева направо, в соответствии с определенным порядком для каждого оператора в формуле. Порядок операций может быть изменен с помощью скобок.

В приведенном ниже примере скобки вокруг первой части формулы определяют следующий порядок вычислений: определяется значение B4+25, затем полученный результат делится на сумму значений в ячейках D5, E5 и F5.

=(B4+25)/СУММ(D5:F5)

Дополнительные сведения

Построение формул

Применение операторов в формулах

Порядок выполнения действий


(Untitled)

Формула представляет собой выражение, описывающее вычисления в ячейке. Можно создать формулу для выполнения математических операций, например сложения или умножения.

Формула в ячейке

Формула =$E$2*D5 в ячейке E5 вычисляет общую сумму зарплаты, умножая часовую ставку (ячейка E2) на число часов (ячейка D5).

Дополнительные сведения

Вычисление значений в формулах

Примеры часто используемых формул.


 (Untitled)

Пустая ячейка в диапазоне данных может быть отображена тремя различными способами. По умолчанию Excel не строит точку для этой ячейки. Это взывает разрыв в ряде данных, как показано на следующем примере, где отсутствуют данные по расходам на топливо в декабре:

Диаграмма с прерывающимся рядом данных

Чтобы ряд данных был непрерывным, следует использовать интерполяцию. В следующем примере отсутствующие данные за декабрь получаются в результате усреднения данных за ноябрь и за январь.

Диаграмма с интерполяцией

Если пустая ячейка соответствует нулевому значению, это может быть отражено на диаграмме.

Диаграмма с нулевым значением

Инструкции по управлению способом отображения пустых ячеек на диаграмме


 (Untitled)

Microsoft Query передает данные из внешних источников в Microsoft Excel. Используя Query для извлечения данных их корпоративных баз данных и файлов, нет необходимости повторно вводить данные для анализа их в Excel. Можно также при каждом занесении в базу данных новой информации автоматически обновлять отчеты и сводки.

Типы баз данных, к которым можно получить доступ Можно извлечь данные из нескольких типов баз данных, включая Microsoft Access, Microsoft SQL Server и Microsoft SQL Server OLAP Services. Можно также извлечь данные из списков Excel и текстовых файлов. См. список типов баз данных, к которым можно получить доступ.

В Excel можно также извлечь данные из Web-страниц, но для этого не нужно использовать Query.

Выбор данных из базы данных Данные извлекаются из базы данных с помощью запросов. Запрос — это вопрос, который задается о данных, хранимых во внешней базе данных. Например, если данные хранятся в базе данных Access, может возникнуть необходимость выяснить объемы продаж определенного вида продукции в регионе. Можно извлечь часть данных, выбирая данные, относящиеся только к указанному продукту и указанному региону.

Пример выбора данных в Query

Используя Query, можно выбрать нужные столбцы данных и передавать в Excel только эти данные.

Обновление листа за одну операцию После занесения внешних данных в книгу Excel при каждом изменении базы данных можно обновить данные для обновления результатов анализа — без повторного создания итоговых отчетов и диаграмм. Например, можно создать помесячный отчет о продажах и обновлять его ежемесячно при появлении новых данных.

Использование Query для извлечения данных Перенос внешних данных в Excel с помощью Query состоит из трех шагов: Сначала настраивается источник данных для соединения с базой данных, затем используется мастер запросов для выбора требуемых данных и , наконец, данные передаются в Excel, где они могут быть отформатированы, обобщены и по ним могут быть построены отчеты.


 (Untitled)

Экспоненциальное приближение следует использовать в том случае, если скорость изменения данных непрерывно возрастает. Однако для данных, которые содержат нулевые или отрицательные значения, этот вид приближения неприменим.

На приведенном ниже на примере экспоненциальное приближение иллюстрирует процесс распада углерода 14. Следует заметить, что значение R-квадрат здесь равно 1, то есть линия приближения идеально соответствует данным.

Диаграмма с экспоненциальной аппроксимацией


Пример листа-формы

Данный раздел содержит следующие сведения:

Форматирование листа с целью использования в качестве формы

Использование элементов управления для упрощения ввода данных

Вставка формул для вычисления значений

Автоматизация заполнения форм с помощью макросов

Ограничение данных, вводимых в определенные ячейки

Ниже приведен пример формы, созданной с помощью листа.

Рис. 1

Возврат в начало

Форматирование листа с целью использования в качестве формы

Чтобы получить большую ячейку, включающую несколько строк или столбцов, можно выделить ячейки, которые необходимо слить, и объединить их. Инструкции по объединению ячеек для охватывания нескольких столбцов или строк.

Чтобы подобрать расстояния между элементами на форме, можно изменить ширину столбцов и высоту строк и изменить вертикальное и горизонтальное выравнивание текста.

Используйте другие возможности форматирования для упрощения заполнения формы. В примере на рис. 1 пользователи вводят данные в белые ячейки, выделенные границами. Остальные ячейки имеют цветной фон, в качестве фонового рисунка на листе используется логотип компании. Инструкции по форматированию листа с целью использования в качестве формы.

Возврат в начало

Использование элементов управления для упрощения ввода данных

Элементы управления, например раскрывающийся список, упрощают заполнение формы на экране. Введите список возможных элементов раскрывающегося списка в произвольный диапазон в книге и свяжите этот диапазон с элементом управления. Лист, содержащий список ввода и другие данные, может быть скрыт. Можно использовать в форме переключатели и флажки.

Это относится и к экранным формам и к формам, заполняемым на бумаге.

Примеры элементов управления

Рис. 2

Возврат в начало

Вставка формул для вычисления значений

в формы, разрабатываемые для заполнения на экране, можно включить формулы для расчета итогов и других значений.

Рис. 3

Дополнительные сведения

Быстрые вычисления на листе

Вычисление значений в формулах

Автоматизация заполнения форм с помощью макросов

Для автоматизации заполнения формы на экране и обработки введенных данных элементу управления может быть назначен макрос.

Например, если устанавливается флажок Отправить менеджеру, макрос может вложить форму в сообщение электронной почты или сохранить форму в общей папке на компьютере менеджера. Если планируется использовать форму только в Microsoft Excel, можно добавлять элементы управления с панели инструментов Формы.

Если планируется использовать форму на узле Web или в специальной программе на языке Visual Basic, используйте более мощные элементы управления ActiveX с панели инструментов Элементы управления.

Дополнительные сведения

Запись макроса

Отображение панели инструментов

Автоматизация задач с помощью элемента ActiveX

Возврат в начало

Ограничение данных, вводимых в определенные ячейки

В экранных формах можно ограничить ввод данных в определенные ячейки, заблокировав эти ячейки.

Можно также ограничить типы информации, вводимой в определенные ячейки, с помощью проверки вводимых значений. Инструкции по отображению сообщений, приглашающих ввести данные и свидетельствующих о неправильном вводе.

Возврат в начало


 (Untitled)

Формула может ссылаться на значения констант и на другие ячейки. Ячейка, содержащая формулу называется зависимой ячейкой, если ее значение зависит от значений в других ячейках. Например, ячейка B2 является зависимой, если она содержит формулу =C2.

Всякий раз, когда меняется ячейка, на которую ссылается формула, по умолчанию зависимая ячейка также меняется. Например, если значение одной из следующих ячеек меняется, результат формулы =B2+C2+D2 также изменится.

Данные на листе

Если формула использует не ссылки на ячейки, а константы (например =30+70+110), результат изменится только при изменении самой формулы.

Формулы могут ссылаться на ячейки или на диапазоны ячеек, а также на имена или заголовки, представляющие ячейки или диапазоны ячеек. См. сведения о ссылках на диапазоны ячеек, имена или заголовки.


(Untitled)

Microsoft Excel содержит множество типовых, или встроенных, формул, известных также как функции. Функции могут быть использованы для выполнения простых или сложных вычислений. Самой часто используемой функцией является функцияСУММ, которая используется для сложения чисел в диапазоне ячеек.

Функция СУММ складывает значения в диапазоне D5:F5.

См. сведения об использовании функций для вычисления значений.


 (Untitled)

Линейная аппроксимация — это прямая линия, наилучшим образом описывающая набор данных. Она применяется в самых простых случаях, когда точки данных расположены близко к прямой. Говоря другими словами, линейная аппроксимация хороша для величины, которая увеличивается или убывает с постоянной скоростью.

В приведенном ниже примере линейное приближение показывает равномерное увеличение объема продаж холодильников в течение 13 лет. Следует заметить, что значение R-квадрат в данном случае составляет 0,9036. Это свидетельствует о достаточно хорошем согласовании линии аппроксимации с фактическими данными.

Диаграмма с линейной аппроксимацией


 (Untitled)

Логарифмическая аппроксимация хорошо описывает величину, которая вначале быстро растет или убывает, а затем постепенно стабилизируется. Описывает как положительные, так и отрицательные величины.

Приведенный ниже пример использует логарифмическое приближение для иллюстрации прогнозируемого роста популяции животных на ограниченной территории. По мере того как свободного пространства становится все меньше, темпы роста популяции также снижаются. Следует заметить, что значение R-квадрат в данном примере равно 0,9407; это указывает на то, что аппроксимирующая кривая описывает данные с достаточно высокой степенью достоверности.

Диаграмма с логарифмической аппроксимацией


 (Untitled)

Что такое источник данных? Источник данных — это хранимый набор информации, который позволяет Microsoft Excel соединиться с внешней базой данных. Когда для настройки источника данных используется Microsoft Query, указывается имя источника данных, имя или адрес базы данных или сервера, тип базы данных и сведения для подключения и пароль. Также указывается название драйвера ODBC или драйвера источника данных, который представляет собой программу, соединяющуюся с базой данных определенного типа. при работе с некоторыми типами внешних баз данных (кубы OLAP) для извлечения данных достаточно настроить источник данных.

Использование источников данных в Microsoft Query Если источник данных для определенной базы данных настроен, можно его использовать в любое время для создания запроса и извлечения данных из базы данных (без необходимости повторно вводить информацию, необходимую для соединения). Query использует источник данных для соединения с внешней базой данных и для оповещения о доступности данных. Когда запрос создан и данные переданы в Excel, Query помещает в книгу Excel и запрос, и информацию об источнике данных, чтобы можно было повторно соединиться с базой данных для обновления данных.

Диаграмма: использование источников данных в Query

Источник данных представляет собой средство, с помощью которого Query и Excel соединяются с конкретной базой данных и извлекают данные из нее.

Дополнительные сведения

Извлечение данных


(Untitled)

Использование в качестве приближения скользящего среднего позволяет сгладить колебания данных и таким образом более наглядно показать характер зависимости. Такая линия тренда строится по определенному числу точек (оно задается параметром Шаг). Элементы данных усредняются, и полученный результат используется в качестве среднего значения для приближения. Так, если Шаг равен 2, первая точка сглаживающей кривой определяется как среднее значение первых двух элементов данных, вторая точка — как среднее следующих двух элементов и так далее.

В следующем примере показана зависимость числа продаж на протяжении 26 недель, полученная путем расчета скользящего среднего.

Диаграмма со скользящим средним


(Untitled)

По умолчанию Microsoft Excel отображает на диаграмме категории и значения в том порядке, в котором они отображаются на листе. При необходимости этот порядок можно обратить.

В следующем примере категории располагаются на диаграмме в том же порядке, что и в таблице — «Апрель», «Март», «Февраль» и «Январь».

Расположение категорий по умолчанию

Чтобы названия месяцев выводились в хронологическом порядке, измените текущий порядок на обратный.

Расположение категорий в обратном порядке

В показанном выше примере можно расположить в обратном порядке и значения (сверху вниз, от 0 до 800).

Использование обратного порядка следования категорий, значений и рядов на диаграмме.


 (Untitled)

Пример основного отчета сводной таблицы

Пример основного отчета сводной таблицы

Поля строк. Поля из базового источника данных, которым в отчете сводной таблицы задана ориентация по строкам. В приведенном примере полями строк являются поля «Товар» и «Продавец». Если в отчете сводной таблицы содержится несколько полей строк, одно из них, ближайшее к области данных, является внутренним (в данном случае поле «Продавец»). Все остальные поля строк называются внешними. Внутреннее и внешние поля строк имеют различные атрибуты. Элементы в самом крайнем внешнем поле отображаются только один раз, но в остальных полях элементы повторяются необходимое число раз.

Поле столбца. Поле, которому в отчете сводной таблицы задана ориентация столбца. В приведенном примере поле «Кварталы» является полем столбца с двумя элементами, «Кв.2» и «Кв.3». Отчет сводной таблицы может содержать несколько полей столбцов, как и полей строк. Большинство структурированных отчетов сводных таблиц не содержат полей столбцов.

Элемент. Подкатегория или составная часть поля сводной таблицы. В приведенном примере «Молоко» и «Мясо» являются элементами поля «Товар». Элементы представляют уникальные записи в пределах одного поля или столбца исходных данных. Элементы отображаются как подписи строк или столбцов либо в раскрывающихся списках для полей страниц.

Поле страницы. Поле, которому задана ориентация страницы (фильтра). В приведенном примере полем страницы является поле «Регион», с помощью которого можно отфильтровать отчет по регионам. При помощи поля «Регион» можно отобразить обобщенные данные только по восточному региону, только по западному региону или по другим регионам. При выборе очередного элемента в поле страницы изменяется весь отчет сводной таблицы, отображая только те обобщенные данные, которые связаны с выбранным элементом.

Элемент поля страницы. Каждя уникальная запись или значение поля или столбца исходного списка или таблицы становится элементом списка в поле страницы. В приведенном примере текущим выбранным элементом поля страницы «Регион» является «Восток», и в отчете сводной таблицы отображаются обобщенные сведения только по восточному региону.

Поле данных. Поле из исходного списка или базы данных, содержащее обобщаемые данные. В приведенном примере «Сумма продаж» представляет собой поле данных, обобщающее записи из поля или столбца исходных данных с названием «Продажи». В примере структурированного отчета это поле имеет имя «Продажи», а не «Сумма продаж».

Поле данных обычно обобщает числовые данные, например, статистику или размеры продаж, но базовые данные также могут быть текстовыми. По умолчанию в Microsoft Excel для обобщения текстовых данных в отчетах сводных таблиц используется итоговая функция СЧЕТ, а для обобщения числовых данных — функция СУММ. В отчетах сводных таблиц, основанных на исходных данных OLAP, изменить итоговую функцию для поля нельзя: итоговые функции выбираются системным администратором OLAP и вычисляются на сервере OLAP.

Область данных. Часть отчета сводной таблицы, содержащая итоговые данные. Ячейки в области данных отображают обобщенные данные по элементам полей строк и столбцов. Каждое значение в области данных представляет сводку данных из исходных записей или строк.

В приведенном примере значение в ячейке C6 является сводкой продаж молока за второй квартал для Батурина — то есть, суммой продаж по всем записям или строкам исходных данных, содержащих элементы «Молоко», «Батурин» и «Кв.2». В примере структурированного отчета эти сведения отображаются в ячейке D7.

Стрелка списка поля. Стрелка Стрелка поля расположена в правой части каждого поля. Щелкнув эту стрелку можно выбрать элементы, которые требуется отобразить.

В отчетах сводных диаграмм, основанных на исходных данных из баз данных OLAP, стрелка открытия списка отображается только для поля верхнего уровня измерения, позволяя выбирать в этом поле элементы различных уровней. По щелчку стрелки поля «Год» можно увидеть следующее:

Раскрывающийся список для поля измерения OLAP

Пример раскрывающегося списка для поля измерения OLAP

Данные по 1998 году скрыты. В 1999 году «Кв.1» скрыт. Двойная галочка в полях 1999 и «Кв2.» означает, что все или некоторые из элементов нижнего уровня для 1999 и «Кв.2» отображены. Одиночная галочка в поле 2000 означает, что сведения по этому году выбраны для отображения.

Индикатор развертывания. Индикатор Плюс или Минус рядом с элементом поля. По щелчку такого индикатора отображаются или скрываются подробности для данного элемента.

Дополнительные сведения

Элементы отчета сводной диаграммы


 (Untitled)

Отчет сводной таблицы представляет собой интерактивную таблицу, с помощью которой можно быстро обобщать большие объемы данных. Можно менять местами строки и столбцы для получения различных сводок по исходным данным, фильтровать данные, отображая различные страницы, либо отображать подробности по нужным областям.

Простой отчет сводной таблицы

Пример простого отчета сводной таблицы. Исходные данные отображаются в списке слева.

Использование отчета сводной таблицы. Отчет сводной таблицы используется в случаях, когда требуется сравнить связанные итоги, особенно для сравнения нескольких фактов по каждому числу из длинного списка обобщаемых чисел. Отчеты сводных таблиц используются в Microsoft Excel для автоматического выполнения сортировки, вычисления промежуточных и общих итогов. В приведенном примере можно легко сравнить объем продаж клюшек для гольфа за третий квартал в ячейке F5 с продажами цифрами продаж по другому товару или за другой квартал, либо вычислить общий итог продаж. Благодаря интерактивности отчета сводной таблицы, вы или другие пользователи могут изменять представление данных для просмотра дополнительных подробностей или вычисления других итогов.

Создание отчета сводной таблицы. При создании отчета сводной таблицы используйте мастер сводных таблиц и диаграмм для поиска и указания исходных данных, которые требуется проанализировать, а также для создания рамки отчета. Затем с помощью панели инструментов Сводные таблицы можно упорядочить данные в пределах рамки.

Типы отчетов сводных таблиц. Основной отчет сводной таблицы выглядит как приведенный пример. Отчет сводной таблицы можно также отобразить в структурированном формате, чтобы просмотреть все итоговые значения одного типа в одном столбце. Для графического представления данных можно создать отчет сводной диаграммы. Кроме того, можно сделать отчет сводной таблицы доступным через Интернет. Для этого используется сводная таблица на Web-странице. После публикации отчета сводной таблицы Excel в сводную таблицу другие пользователи могут просматривать данные и взаимодействовать с ними в Web-обозревателях.


 (Untitled)

По умолчанию Microsoft Excel отображает ряды данных в том же порядке, в котором данные отображаются на листе. При желании можно изменить порядок рядов для повышения эффективности диаграммы. На следующем примере трехмерной гистограммы продажи по каждой республике отображаются в том же порядке, что и на листе:

Расположение рядов данных по умолчанию

Для того чтобы сделать видимыми ряды данных по России и Казахстану, не изменяя порядок данных на листе, можно изменить порядок рядов на диаграмме, придав ей, например, следующий вид:

Расположение рядов данных в измененном порядке

Инструкции по изменению порядка отображения рядов данных


 (Untitled)

Полиномиальная аппроксимация используется для описания величин, попеременно возрастающих и убывающих. Она полезна, например, для анализа большого набора данных о нестабильной величине. Степень полинома определяется количеством экстремумов (максимумов и минимумов) кривой. Полином второй степени может описать только один максимум или минимум. Полином третьей степени имеет один или два экстремума. Полином четвертой степени может иметь не более трех экстремумов.

Ниже на примере аппроксимации полиномом второго порядка (одна вершина) показана зависимость скорости от потребления топлива. Следует заметить, что значение R-квадрат в данном случае составляет 0,9474. Это достаточно хорошо согласуется с фактическими данными.

Диаграмма с полиномиальной аппроксимацией


 (Untitled)

Степенное приближение дает хорошие результаты, если зависимость, которая содержится в данных, характеризуется постоянной скоростью роста. Примером такой зависимости может служить график ускорения автомобиля. Если в данных имеются нулевые или отрицательные значения, использование степенного приближения невозможно.

Ниже показан пример зависимости пройденного расстояния от времени (в секундах). По степенной линии тренда ясно видно увеличение ускорения. Обратите внимание, что значение R-квадрат в данном примере равно 0,9923. Это говорит о высокой точности используемого приближения.

Диаграмма со степенной аппроксимацией


 Предотвращение доступа к подробным данным в сводной таблице или сводной диаграмме

Предотвращение доступа к подробным данным в сводной таблице или сводной диаграмме

Эта процедура недоступна для отчетов сводных таблиц и сводных диаграмм, основанных на исходных данных из базы данных OLAP.

Если дважды щелкнуть ячейку в области данных отчета сводной таблицы, Microsoft Excel отобразит список исходных данных, обобщаемых в этой ячейке. Выполните описанные ниже действия для отключения доступа к подробным сведениям.

  1. Щелкните отчет сводной таблицы, чтобы активизировать панель инструментов Сводные таблицы.

  2. Выполните одно из следующих действий:

    Для отчета сводной таблицы нажмите кнопку Сводная таблица на панели инструментов Сводные таблицы и выберите команду Параметры таблицы.

    Для отчета сводной диаграммы нажмите кнопку Сводная диаграмма на панели инструментов Сводные таблицы и выберите команду Параметры.

  3. В группе Данные снимите флажок Развертывание разрешено.

Примечание. В Excel существуют другие средства защиты, которые также можно использовать для предотвращения доступа или внесения изменений в отчеты сводных таблиц и сводных диаграмм.


 (Untitled)

Если в Microsoft Excel требуется отобразить итоговое значение для диапазона ячеек, используйте Автовычисление. При выделении ячеек Excel отображает сумму для диапазона в строке состояния, которая представляет собой горизонтальную область под окном листа Excel. Если строка состояния не отображается, выберите команду Строка состояния в меню Вид.

В строке состояния отображается сумма выделенного диапазона

Выделены две ячейки, сумму которых (735,00р.) средство автовычислений отображает в строке состояния.

Возможно также выполнение других типов автовычислений. По щелчку правой кнопкой мыши в строке состояния открывается контекстное меню, позволяющее найти среднее, наибольшее или наименьшее значение в выделенном диапазоне. Если выбрать команду Количество чисел, будет автоматически подсчитано число ячеек, содержащих числа. Если выбрать команду Количество значений, автоматически подсчитывается число непустых ячеек. При запуске Excel для автовычислений устанавливается функция СУММ.


 (Untitled)

Создание суммы. Существует возможность автоматически вставить сумму диапазона ячеек при помощи автосуммы. При выделении ячейки, в которую требуется вставить сумму, и нажатии кнопки Автосумма [image] , Microsoft Excel предлагает формулу. Для того чтобы принять формулу, нажмите клавишу ENTER.

Для того чтобы изменить предложенную формулу, выделите диапазон, который требуется суммировать, и нажмите клавишу ENTER.

Общие итоги. Если лист содержит несколько итоговых значений, созданных с использованием функции СУММ, можно создать общую сумму этих значений с помощью кнопки Автосумма [image] .

Создание общего итога с помощью автосуммы

Автосумма предлагает формулу =SUM(E16,E11), которая суммирует ячейки E16 (итог за июнь) и E11 (итог за май).

Для вычисления промежуточных и общих итогов по данным отчета или списка можно использовать средство вычисления промежуточных итогов. Укажите элементы, по которым нужны промежуточные итоги, нужные значения и тип промежуточных итогов (например, сумма или среднее). Инструкции по вставке промежуточных итогов на лист.

Дополнительные сведения

Обзор промежуточных итогов в списках


 (Untitled)

После создания запроса в мастере запросов или Microsoft Query можно вернуть данные на лист Microsoft Excel. Данные преобразуются в диапазон внешних данных или отчет сводной таблицы, который можно форматировать, анализировать и обновлять.

Форматирование и анализ данных. В Excel для представления и обобщения данных можно использовать такие знакомые средства как мастер диаграмм или автоматические промежуточные итоги. Можно отформатировать данные, и форматирование будет сохранено при обновлении внешних данных из исходной базы данных. Если добавить в диапазон внешних данных столбцы или формулы, эти формулы будут автоматически копироваться в новые строки, добавляемые в диапазон при обновлении данных. Можно использовать собственные подписи столбцов вместо имен полей, а также автоматически добавлять номера строк. См. сведения об управлении форматированием и макетом диапазона внешних данных.

Повторное и совместное использование запросов. Как в мастере запросов, так и в Microsoft Query можно сохранить файл запроса (.dqy), который можно изменять, а также использовать повторно или совместно. Excel может открывать файлы .dqy непосредственно, что позволяет вам или другим пользователям создавать дополнительные диапазоны вешних данных с помощью того же самого запроса.

Если требуется совместно использовать сводку или отчет, основанный на внешних данных, можно предоставить другим пользователям книгу, содержащую диапазон внешних данных, либо создать шаблон отчета. Шаблон отчета позволяет сохранить сводку или отчет без сохранения внешних данных, что уменьшает размер файла. Внешние данные загружаются при открытии шаблона отчета.

Обновление внешних данных. При обновлении внешних данных выполняется запрос для загрузки новых или измененных данных, отвечающих заданным спецификациям. Excel предоставляет несколько способов обновления запросов, включая обновление данных при каждом открытии книги и автоматическое обновление через заданные интервалы времени. Во время обновления данных можно продолжать работу в Excel, а также проверять состояние обновления. См. сведения об обновлении внешних данных.

Дополнительные сведения

Способы организации доступа к внешним данным

Управление обновлением диапазона внешних данных


 (Untitled)

Использование мастера запросов. Мастер запросов, входящий в Microsoft Query, предназначен для пользователей, не создававших запросы ранее. Мастер облегчает отбор и объединение данных из разных таблиц и полей базы данных. После отбора нужных данных можно также использовать мастер для фильтрации и сортировки результатов запроса. Мастер запросов можно использовать либо для создания запроса от начал до конца, либо для того, чтобы начать создание запроса, дальнейшие изменения в который будут вноситься непосредственно в Microsoft Query.

Непосредственная работа в Microsoft Query. Будучи знакомым с процедурой создания запросов или при необходимости создания более сложного запроса, можно работать непосредственно в Query. Query можно использовать для просмотра и изменения запросов, создание которых было начато в мастере запросов, либо для создания новых запросов без использования мастера.

Используйте Query непосредственно при необходимости создания запросов, выполняющих следующие действия.

  • Отбор конкретных данных из поля. В большой базе данных может потребоваться выбрать некоторые данные поля и опустить ненужные данные. Например, если требуются данные по двум товарам, а поле содержит сведения по большему числу товаров, можно использовать условия отбора для отбора данных только по двум интересующим товарам. Для получения сведений об использовании условий отбора запустите Microsoft Query и обратитесь к справочной системе Microsoft Query.

  • Загрузка данных на основе условий отбора, меняющихся при каждом выполнении запроса. Если требуется создать один и тот же отчет Excel или сводку по нескольким областям одного набора внешних данных — например, отдельный отчет о продажах по каждому региону — можно создать так называемый запрос с параметрами. При запуске запроса с параметрами на экран выводится приглашение на ввод данных, которые будут использоваться в качестве условий отбора записей. Например, запрос с параметрами, запрашивающий название региона, можно использовать повторно для создания отчетов о продажах в каждом конкретном регионе. См. сведения о запросах с параметрами.

  • Объединение данных различными способами. Query можно использовать для объединения данных из различных таблиц базы данных. Например, если имеются таблица сведений о продажах товаров и таблица сведений о клиентах, можно объединить эти таблицы таким образом, чтобы выявить клиентов, не делавших заказов в последнее время. Для получения сведений об объединении таблиц запустите Microsoft Query и обратитесь к справочной системе Microsoft Query.

Дополнительные сведения

Использование мастера запросов и Microsoft Query


 (Untitled)

Вспомогательную ось значений целесообразно использовать в тех случаях, когда значения различных рядов данных изменяются в широком диапазоне или когда на одной диаграмме отображаются данные различных типов. Например, для того чтобы отображать и число домов, продаваемых каждую неделю, и среднюю цену продажи за неделю, отобразите число домов по одной оси, а среднюю цену — по второй.

Диаграмма с двумя осями

Инструкции по отображению рядов данных на вспомогательной оси


 (Untitled)

При создании диаграммы в Microsoft Excel можно определить ту часть данных, на которую требуется обратить внимание. По умолчанию Excel отображает в виде рядов данных ту составляющую (строки или столбцы), которая меньше. В следующем примере Excel отображает в виде рядов данных годы (два значения), а не страны (три значения). Эта диаграмма обращает внимание на сравнение продаж по странам.

Диаграмма с годами в качестве рядов данных

Если изменить расположение по умолчанию, чтобы для построения рядов данных использовались страны, диаграмма будет обращать внимание на сравнение продаж по годам.

Диаграмма со странами в качестве рядов данных

Инструкции по отображению в качестве рядов данных строк листа вместо столбцов и наоборот


(Untitled)

В существующие группы суммируемых значений можно вставлять промежуточные итоги для более мелких групп. Например, можно вставить промежуточные итоги для каждого типа товаров в список, в котором уже вычисляются промежуточные итоги по каждому продавцу. Прежде чем вставлять вложенные итоги, выполните сортировку по всем столбцам, по которым требуется вычислять промежуточные итоги, чтобы суммируемые строки были сгруппированы.

В данном примере промежуточные итоги вычисляются по строкам «Батурин» и «Белов», а затем вставляются в строки «Молоко» и «Мясо».

Список с вложенными промежуточными итогами

Дополнительные сведения

Создание «вложенных» или многоуровневых промежуточных итогов


(Untitled)

Создание итоговых отчетов. При добавлении на лист автоматических промежуточных итогов разметка листа изменяется таким образом, что становится видна его структура. Щелкая символы структуры, можно создать итоговый отчет, скрыв подробности и отобразив только промежуточные итоги.

Структурированный список, отображающий только строки итогов

Отображение итоговых данных в виде диаграммы. Можно создать диаграмму, использующую только видимые данные списка, содержащего автоматические промежуточные итоги. Если отобразить или скрыть подробности в списке, связанная диаграмма тоже будет обновлена для отображения или скрытия соответствующих данных.

Диаграмма, созданная на основе промежуточных итогов

Дополнительные сведения

Создание итоговых отчетов

Создание диаграмм


(Untitled)

При использовании команды Автофильтр справа от подписей столбцов в фильтруемом списке появляются стрелки автофильтра. Инструкции по фильтрации списка.

Использование стрелок автофильтра. Если щелкнуть стрелку автофильтра, отображается список всех уникальных видимых элементов в столбце, включая пустые (из одних пробелов) и непустые. Выбрав элемент их списка для конкретного столбца, можно незамедлительно скрыть все строки, не содержащие выбранное значение.

Список в следующем примере отфильтрован таким образом, чтобы отображались только строки по продавцу Белову.

Список, отфильтрованный по продавцу Белову

Быстрый отбор значений. Если фильтруется список чисел, можно быстро просмотреть наибольшие значения в списке, щелкнув пункт Первые 10 в списке автофильтра. Для того чтобы вернуться к просмотру всего содержимого столбца, щелкните пункт Все. См. сведения о параметрах фильтрования.

Просмотр отфильтрованного списка. Microsoft Excel обозначает отфильтрованные элементы визуально. В данном примере стрелка автофильтра в столбце, содержащем выбранное значение, синяя. Номера отфильтрованных строк тоже синие.


 (Untitled)

Просматривая большой список, можно прокрутить его до строки, содержащей интересующие данные. После этого может потребоваться просмотр всех остальных строк, содержащих те же данные. Существует возможность отфильтровать список для отображения всех строк, содержащих значения, совпадающие со значением в выделенной ячейке.

Фильтрация по выделенному значению. Щелкните ячейку списка, а затем нажмите кнопку Автофильтр [image] , чтобы выполнить фильтрацию по выделенному. Microsoft Excel включает автофильтр и фильтрует список, отображая только нужные строки.

Список с выделенной ячейкой для фильтрации

Дополнительные сведения

Добавление кнопки на панель инструментов


 (Untitled)

Фильтрация — это быстрый и легкий способ поиска подмножества данных и работы с ним в списке. В отфильтрованном списке отображаются только строки, отвечающие условиям отбора, заданным для столбца. Microsoft Excel предоставляет две команды для фильтрации списков.

  • Автофильтр, включая фильтр по выделенному, для простых условий отбора

  • Расширенный фильтр для более сложных условий отбора

В отличие от сортировки, при фильтрации порядок записей в списке не изменяется. При фильтрации временно скрываются строки, которые не требуется отображать.

Строки, отобранные при фильтрации в Excel, можно редактировать, форматировать и выводить на печать, а также создавать на их основе диаграммы, не изменяя порядок строк и не перемещая их.


 (Untitled)

Команда Расширенный фильтр используется для применения нескольких условий отбора к одному столбцу, для применения нескольких условий отбора к нескольким столбцам, либо для создания условий отбора в результате выполнения формулы. Инструкции по фильтрации списка с помощью расширенного фильтра.

При использовании расширенного списка стрелки раскрытия списка автофильтра не отображаются. Вместо этого условия вводятся в диапазон условий отбора на листе. Для того чтобы изменить способ фильтрации данных, следует изменить значения в диапазоне условий отбора и выполнить фильтрацию еще раз.

Например, этот список отфильтрован для отбора продаж на сумму от 5 000 до 8 000, а также продаж на сумму менее 500.

Список, отфильтрованный с помощью расширенного фильтра

Дополнительные сведения

Примеры условий отбора расширенного фильтра

Виды условий отбора


(Untitled)

Пользовательский автофильтр используется для вывода строк, содержащих то или иное значение. Пользовательский автофильтр также можно использовать для вывода строк, отвечающих несколькими условиям для столбца, например, строк, содержащих значения из конкретного диапазона (например, между 2 000 и 3 000).

Список в следующем примере отфильтрован таким образом, чтобы отображались только строки, содержащие в столбце «Продавец» значения «Белов» или «Сушкин».

Список, отфильтрованный по продавцам Белов и Сушкин

Дополнительные сведения

Фильтрация списка с помощью пользовательского автофильтра

Фильтрация списка путем сравнения значений

Виды условий отбора


(Untitled)

Подготовка к печати. Microsoft Excel предоставляет множество необязательных параметров, позволяющих настроить конечный внешний вид напечатанной страницы в соответствии с предъявляемыми требованиями. Для того чтобы проверить все, что может повлиять на результаты печати, выполните перечисленные слева шаги в указанном порядке.

Просмотр листа перед печатью. Microsoft Excel предоставляет три способа просмотра и настройки внешнего вида листа перед печатью.

  • Обычный режим. Используется по умолчанию. Наилучший режим для просмотра на экране и работы.

  • Предварительный просмотр. Показывает печатную страницу и позволяет легко настраивать столбцы и поля.

  • Режиме разметки страницы. Показывает распределение данных по страницам и позволяет быстро настраивать область печати и разрывы страниц.

По мере выполнения настроек, влияющих на параметры печати листа, можно переключаться из одного режима в другой для просмотра изменений перед отправкой данных на печать.


 (Untitled)

Microsoft Excel может автоматически обобщать данные, вычисляя промежуточные и общие итоги в списке. Для использования автоматических промежуточных итогов список должен содержать столбцы с подписями и должен быть отсортирован по столбцам, для которых требуются промежуточные итоги.

При вставке автоматических промежуточных итогов Excel изменяет разметку списка, группируя строки данных с каждой связанной строкой промежуточных итогов, а строки промежуточных итогов — со строкой общих итогов.

Существует возможность выбора функции, используемой в Excel для вычисления итогов. В данном примере для вычисления промежуточных итогов для Батурина и Белова и общих итогов по всему листу используется функция СУММ.

Список с промежуточными итогами и общим итогом

Дополнительные сведения

Подведение промежуточных итогов

Создание списка с заголовками

Сортировка списков

Вычисление промежуточных и общих итогов


 (Untitled)

Таблица данных представляет собой диапазон ячеек, показывающий, как изменение определенных значений в формулах влияет на результаты этих формул. Таблицы предоставляют способ быстрого вычисления нескольких версий в рамках одной операции, а также способ просмотра и сравнения результатов всех различных вариантов на одном листе.

Таблицы данных с одной переменной. Таблица данных с одной переменной используется, например, при необходимости просмотреть, как различные процентные ставки влияют на размер ежемесячных выплат по закладной. В следующем примере ячейка D2 содержит формулу вычисления платежа, =ППЛАТ(B3/12,B4,-B5), которая ссылается на ячейку ввода B3.

Таблица данных с одной переменной

Таблицы данных с двумя переменными. Таблица данных с двумя переменными может показать влияние на размер ежемесячных выплат по закладной различных процентных ставок и сроков займа. В следующем примере ячейка C2 содержит формулу вычисления платежа, =ППЛАТ(B3/12,B4,-B5), которая ссылается на ячейки ввода B3 и B4.

Таблица данных с двумя переменными

Дополнительные сведения

Создание таблицы подстановки с одной переменной

Создание таблицы подстановки с двумя переменными


 (Untitled)

Подбор параметра

Когда желаемый результат одиночной формулы известен, но неизвестны значения, которые требуется ввести для получения этого результата, можно воспользоваться средством Подбор параметра. При подборе параметра Microsoft Excel изменяет значение в одной конкретной ячейке до тех пор, пока формула, зависимая от этой ячейки не возвращает нужный результат.

Модель, в которой размер платежа зависит от процентной ставки

Например, средство Подбор параметра используется для изменения процентной ставки в ячейке B3 в сторону увеличения до тех пор, пока размер платежа в ячейке B4 не станет равен 900,00р.

Поиск решения

Также существует возможность определения результирующего значения при необходимости изменения нескольких используемых в формуле ячеек, для которых существуют несколько ограничений. Для получения нужного результата формулы подбираются значения в указанных ячейках.

Модель, в которой на бюджет и прибыль влияют несколько ячеек

Например, средство поиска решения используется для максимизации прибыли, отображаемой в ячейке F7 путем изменения квартального бюджета рекламы (ячейки B5:E5) при ограничении общего бюджета рекламы (ячейка F5) суммой в 40 000р.

Дополнительные сведения

Поиск определенного результата для ячейки с помощью подбора значения другой ячейки

Постановка задачи и оптимизация модели с помощью процедуры поиска решения


 (Untitled)

Сценарий — это набор значений, которые Microsoft Excel сохраняется и может автоматически подставлять на листе. Сценарии можно использовать для прогноза результатов моделей и систем расчетов. Существует возможность создать и сохранить на листе различные группы значений, а затем переключаться на любой из этих новых сценариев для просмотра различных результатов.

Создание сценариев. Например, если требуется создать бюджет, но доходы точно не известны, можно определить различные значения дохода, а затем переключаться между сценариями для выполнения анализов «что-если».

Сценарий «Худший случай»

В приведенном примере можно назвать сценарий «Худший случай», установить в ячейке B1 значение 50 000р., а в ячейке B2 значение 13 200р.

Сценарий «Лучший случай»

Второй сценарий можно назвать «Лучший случай» и изменить значения в ячейке B1 на 150 000р., а в ячейке B2 на 26 000р.

Итоговый отчеты по сценариям. Для сравнения нескольких сценариев можно создать отчет, обобщающий их на одной странице. Сценарии в отчете могут располагаться один рядом с другим либо могут быть обобщены в отчете сводной таблицы.

Дополнительные сведения

Создание сценария

Просмотр сценария

Создание итогового отчета по сценариям


 Отображение элементов в поле страницы

Отображение элементов в поле страницы

Для того чтобы отобразить в поле страницы элементы, не связанные с какими-либо данными, выполните следующие действия.

  1. Нажмите кнопку поля для поля страницы.

  2. Нажмите кнопку Параметры поля [image] на панели инструментов Сводные таблицы.

  3. Установите флажок Отображать пустые элементы.

Для того чтобы включить элемент «Все» для полей страниц в отчетах сводных таблиц, основанных на внешних данных, выполните следующие действия.

  1. Нажмите кнопку поля для поля страницы.

  2. Нажмите кнопку Параметры поля [image] на панели инструментов Сводные таблицы.

  3. Нажмите кнопку Далее.

  4. В группе Параметры поля сводной таблицы установите переключатель в положение Извлекать внешние данные для всех полей.

Для изменения условий отбора таким образом, чтобы запрос для отчета сводной таблицы, основанной на внешних данных, возвращал элемент для поля страницы, выполните следующие действия.

  1. Щелкните ячейку отчета сводной таблицы.

  2. На панели инструментов Сводные таблицы нажмите кнопку Мастер сводных таблиц [image] .

  3. Нажмите кнопку Назад.

  4. Нажмите кнопку Получить данные.

  5. В Microsoft Query измените условия отбора таким образом, чтобы в столбце поля, отображаемого отчете в сводной таблицы как поле страницы, появилась по крайней мере одна запись. Сведения о настройке условий отбора см в справке по Microsoft Query.


Копирование диаграммы Microsoft Excel в документ Word или PowerPoint

Для просмотра этого раздела щелкните рисунок:

Для просмотра этого раздела щелкните рисунок.

Чтобы вывести справку по данному разделу с помощью клавиатуры, нажмите клавишу F6 для активизации окна раздела, выделите рисунок клавишей TAB и нажмите ENTER.


Копирование результатов вычислений в документ Word или в документ PowerPoint

Для просмотра этого раздела щелкните рисунок:

Для просмотра этого раздела щелкните рисунок.

Чтобы вывести справку по данному разделу с помощью клавиатуры, нажмите клавишу F6 для активизации окна раздела, выделите рисунок клавишей TAB и нажмите ENTER.


Копирование ячеек листа Excel в документ Word или PowerPoint

Для просмотра этого раздела щелкните рисунок:

Для просмотра этого раздела щелкните рисунок.

Чтобы вывести справку по данному разделу с помощью клавиатуры, нажмите клавишу F6 для активизации окна раздела, выделите рисунок клавишей TAB и нажмите ENTER.


Совместный доступ к книгам Excel

Для просмотра этого раздела щелкните рисунок:

Для просмотра этого раздела щелкните рисунок.

Чтобы вывести справку по данному разделу с помощью клавиатуры, нажмите клавишу F6 для активизации окна раздела, выделите рисунок клавишей TAB и нажмите ENTER.


Файл справки по макрофункциям не установлен

Для просмотра разделов справки по макрофункциям Microsoft Excel 4.0 необходимо загрузить и выполнить установку полной версии этой справочной системы. О получении файла справки.


 Отключение автоматической сортировки

Отключение автоматической сортировки

  1. Нажмите кнопку поля для которого требуется отключить автоматическую сортировку.

  2. Нажмите кнопку Параметры поля [image] на панели инструментов Сводные таблицы.

  3. Нажмите кнопку Далее.

  4. Выберите параметр вручную в окне группы Параметры сортировки.


 Отключение дополнительных вычислений

Отключение дополнительных вычислений

  1. Нажмите кнопку поля, для которого включены дополнительные вычисления.

  2. Нажмите кнопку Параметры поля [image] на панели инструментов Сводные таблицы.

  3. Нажмите кнопку Дополнительно.

  4. Выберите строку Обычная в списке Дополнительные вычисления.


Не удается отключить макрос

Возможно, выполняется попытка открытия книги, содержащей макрос такого типа, который не может быть отключен. В Microsoft Excel имеются да типа макросов: написанные на языке Visual Basic для приложений (VBA) и написанные на макроязыке Excel версии 4.0 (макросы XLM). Отключать можно только макросы на языке VBA.

При открытии книги, содержащей макросы XLM, можно отключить макрос Авто_открыть, но остальные макросы XLM все равно будут выполняться.

Перед открытием книги рекомендуется убедиться, что источник книги надежен.

Примечания

  • См. сведения об отключении проверки макросов, которые могут содержать вирусы.

  • Для того чтобы больше узнать о макровирусах — включая способы приобретения антивирусного программного обеспечения, проверяющего книги и уничтожающего известные макровирусы — можно загрузить сведения о макровирусах с Web-узла корпорации Майкрософт.


 Ввод формулы с помощью методов ввода Lotus 1-2-3

Ввод формулы с помощью методов ввода Lotus 1-2-3

Когда установлен флажок Преобразование формул в формат Excel при вводе, Microsoft Excel дает диапазонам имена по мере ввода в формулах ссылок на диапазоны. Кроме этого, если функция не требует аргументов, можно ввести символ @ и за ним имя функции Lotus 1-2-3, которое будет преобразовано в эквивалент Microsoft Excel.

  1. В меню Сервис выберите пункт Параметры и откройте вкладку Переход.

  2. Установите флажок Преобразование формул в формат Excel при вводе.

  3. Нажмите кнопку OK.

  4. Введите формулу.

Примечания

  • После того как флажок Преобразование формул в формат Excel при вводе был сначала установлен, а затем снят, автоматическая замена имен функций и ссылок на диапазоны не выполняется.

  • При установленном флажке Преобразование формул в формат Excel при вводе, соответствующий режим ввода формул используется для текущего листа, даже если лист Lotus 1-2-3 сохраняется как лист Microsoft Excel. Чтобы отменить этот режим, снимите флажок Преобразование формул в формат Excel при вводе.


Свойства элемента управления для флажков и переключателей на панели инструментов «Формы»

Свойства элемента управления для флажков

Свойство | Описание
Значение | Определяет состояние флажка по умолчанию: Установлен, Снят или Смешанное.
Связь с ячейкой | Отражает состояние флажка. Если флажок установлен, то в ячейке, указанной в поле Связать с ячейкой, отображается логическое значение ИСТИНА. Если флажок снят, в ячейке отображается значение ЛОЖЬ. Если состояние флажка не определено, отображается значение ошибки #Н/Д. Если связанная ячейка пуста, Microsoft Excel интерпретирует состояние этой ячейки как ЛОЖЬ.

Свойства элемента управления для переключателей

Свойство | Описание
Значение | Определяет состояние переключателя: Установлен или Снят.
Связь с ячейкой | Отражает состояние переключателя. Так как переключатель используется для выбора только одного параметра из группы, следует поместить связанные между собой переключатели в группу, а затем связать каждый из них с одной и той же ячейкой листа с помощью поля Связь с ячейкой. Когда переключатель установлен, в ячейке, с которой он связан, отображается его номер в группе. Этот номер может использоваться в формуле для вывода результата, основанного на выбранном параметре. Например, создана форма сведений о сотрудниках, в которой один переключатель имеет подпись Полный рабочий день, второй переключатель — подпись Неполный рабочий день, и оба эти переключателя связаны с ячейкой C1. Следующая формула отображает текст "Полный рабочий день" при установке первого переключателя и "Неполный рабочий день" при установке второго переключателя: =IF(C1=1,"Полный рабочий день","Неполный рабочий день")


Свойства элемента управления для списков и полей со списками на панели инструментов «Формы»

Свойства элемента управления для списков

Свойство | Описание
Формировать список по диапазону | Ссылается на список значений на листе. Из этого диапазона берутся значения для списка.
Связь с ячейкой | Ячейка, возвращающая значение, представляющее выбранный элемент списка. Это число может использоваться в формуле для возврата результата на основе выбранного элемента списка. Например, если список связан с ячейкой C1, а список формируется по диапазону D10:D15, следующая формула возвращает значение из диапазона D10:D15 на основе выбранного пункта списка: =INDEX(D10:D15,C1)
Возможен выбор | Задает способ выбора элементов в списке. Если задана возможность выбора Набора значений или Списка значений, то ячейка, указанная в поле Связь с ячейкой, игнорируется.

Свойства элемента управления для полей со списком

Поле со списком представляет собой раскрывающийся список

Свойство | Описание
Формировать список по диапазону | Ссылается на список значений на листе. Из этого диапазона берутся значения для раскрывающегося списка.
Связь с ячейкой | Ячейка, возвращающая значение, представляющее выбранный элемент списка. Это число может использоваться в формуле для возврата результата на основе выбранного элемента списка.
Количество строк списка | Задает число строк для отображения в раскрывающемся списке.


Свойства элемента управления для полос прокрутки и счетчиков на панели инструментов «Формы»

Свойства элемента управления для полос прокрутки

Свойство | Описание
Текущее значение | Отражает относительное положение бегунка в полосе прокрутки.
Минимальное значение | Отражает самое верхнее возможное положение бегунка на вертикальной полосе прокрутки и самое левое на горизонтальной.
Максимальное значение | Отражает самое нижнее возможное положение бегунка на вертикальной полосе прокрутки и самое правое на горизонтальной.
Шаг изменения | Величина изменения положения бегунка при нажатии на одну из стрелок полосы прокрутки.
Шаг изменения по страницам | Величина изменения положения бегунка при щелчке между бегунком и одной из стрелок полосы прокрутки.
Связь с ячейкой | Возвращает текущее значение, соответствующее положению бегунка. Это значение может использоваться в формуле для вывода результата, основанного на положении бегунка.

Свойства элемента управления для счетчиков

Свойства элемента управления для счетчика аналогичны свойствам для полосы прокрутки, кроме свойства Шаг изменения по страницам, которого нет у счетчика.


Новые возможности основных операций

Основные операции, используемые при работе с Microsoft Excel, такие как открытие и сохранение файлов, стали значительно проще.

Открытие и сохранение документов Microsoft Office (улучшено в Office 2000). В улучшенных диалоговых окнах Открытие документа и Сохранение документа можно одновременно просматривать большее количество файлов и быстрее получать доступ к ним в любом из приложений Office. Можно использовать новую панель адресов для перехода к наиболее часто используемым папкам и адресам; ярлык Журнал для просмотра от 20 до 50 последних использовавшихся документов или папок, а также кнопку Назад для легкого возврата к недавно открывавшимся папкам.

Выбор и вставка объектов через буфер обмена Office (введено в версии 2000). Новый буфер обмена Office позволяет выбрать несколько объектов из любых приложений, включая Web-обозреватель, а затем вставить их, когда это будет нужно. В буфере обмена Office может храниться до 12 объектов.

Прозрачное выделение (введено в версии 2000). При выделении ячеек с цветным текстом цвет остается таким же вместо отображения в инверсной схеме цветов.

Символ евро (введено в версии 2000). Доступны новые числовые форматы с символом евро.

Отмена нескольких операций (введено в версии 97). Позволяет отменить до 16 последних действий.

Упрощенный ввод ссылок на диапазоны в диалоговых окнах (введено в версии 97). В диалоговых окнах, допускающих ввод ссылок на диапазоны ячеек, теперь имеется кнопка, при нажатии на которую диалоговое окно уменьшается, освобождая тем самым больше видимого пространства на листе для выделения диапазона.

Вариант «Да для всех» при закрытии нескольких файлов (введено в версии 97). Если при выходе из Microsoft Excel 97 открыто несколько файлов, можно выбрать сохранение сразу всех файлов перед выходом, без вывода запросов на сохранение каждого файла. Реализовано по многочисленным просьбам пользователей.

Указывающее устройство IntelliMouse (введено в версии 97). Колесико устройства IntelliMouse используется для перелистывания или изменения масштаба при просмотре данных на листе, а также для свертывания и развертывания данных в отчетах сводных таблиц, структурах и списках с промежуточными итогами.

Использование заголовков строк и столбцов для указания активной ячейки (введено в версии 97). При перемещении выделения от ячейки к ячейке номер строки и буква столбца «подсвечиваются», позволяя легко определить текущее местоположение на листе.

Улучшенное редактирование с помощью мыши (введено в версии 95). Для перемещения диапазона на другой лист или в окно другой книги можно перетащить границу диапазона или, удерживая нажатой клавишу ALT, перетащить диапазон на вкладку листа в той же книге. При перетаскивании диапазона с помощью правой кнопки мыши выводится контекстное меню копирования и вставки.

Просмотр примечаний и индикаторов строк и столбцов (введено в версии 95). При удержании указателя на ячейке с индикатором примечания (красный треугольник в правом верхнем углу ячейки) автоматически отображается содержимое. При перетаскивании бегунка для просмотра других частей листа отображается индикатор строки и столбца, в который выполняется переход.


Новые возможности анализа и представления данных с помощью диаграмм

Увеличенная емкость и высококачественное отображение предоставляют мощные средства визуального анализа данных.

Отчеты сводных диаграмм (введено в версии 2000). Новые отчеты сводных диаграмм переносят мощь отчетов сводных таблиц на диаграммы. Отчеты сводных диаграмм интерактивны, снабжены кнопками, с помощью которых можно отображать и скрывать элементы диаграммы.

Цена деления (введено в версии 2000). Если на диаграмме отображаются большие числа, можно сократить текст оси и сделать его более читаемым, изменив цену деления этой оси. Например, если значения на диаграмме изменяются в диапазоне от 1 000 000 до 50 000 000, можно отобразить на оси числа от 1 до 50 и добавить подпись, указывающую, что значения выражены в миллионах.

Улучшенный мастер диаграмм (введено в версии 97). Мастер диаграмм интегрирован с разделенными на вкладки диалоговыми окнами и параметрами форматирования и редактирования диаграмм, что позволяет согласованно работать с диаграммами. Дополнительные возможности мастера и помощь от помощника по Office позволяют с первого раза получить желаемый результат при создании диаграммы.

Диалоговое окно «Тип диаграммы» и типы диаграмм (введено в версии 97). Стандартные и нестандартные типы диаграмм (ранее называвшиеся автоформатом диаграмм) собраны воедино и доступны по команде Тип диаграммы из меню Диаграмма. В список типов диаграмм включены пузырьковые, вторичные круговые диаграммы и вторичные гистограммы. Пирамидальный, конический и цилиндрический типы трехмерных гистограмм и линейчатых диаграмм делают презентации пользователя еще более выразительными.

До 32 000 точек в одном ряду плоской диаграммы (введено в версии 97). Число точек в ряду увеличено с 4 000 в более ранних версий для удобства анализа больших объемов финансовых или научных данных.

Всплывающие подсказки и список элементов диаграммы (введено в версии 97). Как и для кнопок панелей инструментов, всплывающие подсказки на элементах диаграммы помогают выбрать нужный элемент, отображая название элемента диаграммы при удержании на нем указателя. Для выделения элемента диаграммы можно щелкнуть этот элемент или его название в списке Элементы диаграммы на панели инструментов Диаграммы. Всплывающие подсказки на точках данных также могут отображать значения точек данных.

Оси времени (введено в версии 97). Специальный тип оси категорий для данных, организованных по датам. Microsoft Excel автоматически использует в диаграмме ось времени, если данные листа для диаграммы содержат числа в формате дат.

Таблицы данных в диаграммах (введено в версии 97). Данные, по которым построена диаграмма, могут быть выведены в виде таблицы под диаграммой. Таблица данных выравнивается по осям диаграммы.

Просмотр внедренной диаграммы в окне (улучшено в версии 97). Внедренную диаграмму можно открыть в отдельном окне. Щелкните внедренную диаграмму, а затем выберите команду Окно диаграммы в меню Вид.

Выделение внедренных диаграмм одним щелчком (введено в версии 97). Больше нет необходимости дважды щелкать внедренную диаграмму для получения возможности работы с ней. Достаточно щелкнуть тот элемент, который требуется изменить.

Улучшенный текст в диаграммах (введено в версии 97). Текст может быть повернуть относительно оси диаграммы — например, под углом в 45 градусов. Подписи данных могут быть автоматически расположены в виде групп в центре, на основной линии или в конце маркеров данных. Для того чтобы your диаграмма читалась в любом масштабе, шрифты на диаграмме автоматически масштабируются при изменении размера диаграммы.

Указатели диапазона во внедренных диаграммах (введено в версии 97). По щелчку внедренной диаграммы данные и надписи, используемые для диаграммы, выделяются на листе синими, зелеными и сиреневыми рамками. Можно быстро увидеть, какие ячейки образуют диаграмму, а также изменить набор данных для диаграммы, перетаскивая границы соответствующего цвета.

Дополнительные параметры форматирования для диаграмм (введено в версии 97). Для создания эффекта стен и пола для объемных диаграмм, а также для полос и столбцов можно использовать эффект заливки текстурой или изображением. Использование градиентной заливки обеспечивает внешний вид высокого класса. Маркеры диаграмм в виде графиков, точечных и лепестковых диаграмм являются масштабируемыми.

Microsoft Map (введено в версии 95). Если данные организованы по географическим регионам, можно «отобразить» их на карте — например, обозначить условными цветами объемы продаж по странам на карте Европы. Для более глубокого анализа данных можно добавить демографические данные.


Параметры диаграмм

Возможности | Максимальное число
Диаграммы, использующие данные листа | Ограничивается объемом доступной оперативной памяти
Листы, используемые диаграммой | 255
Ряды данных в диаграмме | 255
Точки данных в одном ряду данных для плоских диаграмм | 32 000
Точки данных в одном ряду данных для объемных диаграмм | 4 000
Точки данных во всех рядах данных одной диаграммы | 256 000
Стили линии | 8
Варианты толщины линии | 4
Узоры для заливки плоских фигур (отображаются на экране) | 18
Всего возможных сочетаний узора и цвета (цветной монитор) | 56 448
Сочетания узора и цвета (цветной принтер) | 56448 (в действительности определяется типом принтера и соответствующего программного обеспечения)
Поля страниц в отчете сводной диаграммы | 256 (может ограничиваться объемом доступной оперативной памяти)
Поля данных в отчете сводной диаграммы | 256
Формулы вычисляемых элементов в отчете сводной диаграммы | Ограничивается объемом доступной оперативной памяти


 Ошибка в формуле

Ошибка в формуле

Microsoft Excel исправляет большинство распространенных ошибок, возникающих при вводе формул на лист. Если средствами автоисправления формулы устранить ошибки в формуле не удается, выполните одно из следующих действий.

Проверьте согласованность открывающих и закрывающих скобок. Убедитесь, что каждая скобка является частью пары открывающих и закрывающих скобок. При создании формулы Excel отображает вводимые скобки цветом.

Используйте двоеточие для указания диапазона. При указании ссылки на диапазон ячеек используйте двоеточие (:) в качестве разделителя между первой и последней ячейками диапазона. См. сведения об операторах в формулах.

Введите все необходимые аргументы. Некоторые функции имеют обязательные аргументы. Кроме того, не вводите слишком много аргументов.

Допускается вложение не более семи функций. Число уровней вложения функций в пределах одной функции не должно превышать семи. См. сведения о создании вложенных функций.

Имена других листов следует заключать в одинарные кавычки. Если формула содержит ссылки на значения ячеек других листов или книг, а имя другой книги или листа содержит небуквенные символы, это имя необходимо заключить в одинарные кавычки ( ' ). См. сведения об использовании формул для вычисления значений других листов или книг.

Включите путь к внешним книгам. Убедитесь, что каждая внешняя ссылка содержит имя книги и путь к этой книге. См. сведения об использовании формул для вычисления значений других листов или книг.

Вводите числа без форматирования. Не задавайте формат для чисел, вводимых в формулы. Например, даже если требуется ввести значение 1 000р., введите в формулу 1000. Инструкции по изменению формата чисел, дат и значений времени.


Формат CSV (с разделителями запятыми)

В формате CSV (comma delimited values — текстовый файл с запятыми в качестве разделителей) сохраняются данные только активных листов. Сохраняются все строки и все символы каждой ячейки. Столбцы разделяются запятыми, а строки символом возврата каретки. Если ячейка содержит запятую, ее содержимое берется в кавычки.

Если в ячейке вместо результирующей величины отображена формула, эта формула становится текстом. Все виды оформления, графика, встроенные объекты утрачиваются.

Примечание. Если книга содержит специальные символы, такие как (©), и файл планируется использовать в другой операционной системе, сохраните книгу в текстовом формате, подходящем для этой операционной системы. Например, нужно перенести текстовый файл из Windows на компьютер Macintosh. В этом случае следует сохранить файл в формате CSV (Macintosh). Если используется компьютер Macintosh и нужно перенести файл в Windows или Windows NT, сохраните файл в формате CSV (Windows).


 Новые возможности анализа данных с помощью отчетов сводных таблиц

Новые возможности анализа данных с помощью отчетов сводных таблиц

Отчеты сводных таблиц позволяют получать динамические представления больших объемов данных, а новые возможности обеспечивают еще более простое составление итоговых отчетов в соответствии с потребностями пользователей. Данный раздел содержит справочные сведения по следующим вопросам.

Возможности сводных таблиц

Настройка параметров сводных таблиц

Формулы и вычисления в отчетах сводных таблиц

Возможности сводных таблиц

Создание макетов отчетов непосредственно на листах (введено в версии 2000). После нажатия кнопки Готово в мастере отчетов сводных таблиц и диаграмм на листе появляются синие рамки областей перетаскивания и панель инструментов Сводные таблицы со списком полей исходных данных. Для создания макета отчета сводной таблицы прямо на листе можно перетащить поля с панели инструментов в области перетаскивания.

Отчеты сводных диаграмм (введено в версии 2000). Новые отчеты сводных диаграмм переносят мощь отчетов сводных таблиц на диаграммы. Отчеты сводных диаграмм интерактивны, снабжены кнопками, с помощью которых можно отображать и скрывать элементы диаграммы.

Структурированные форматы (введено в версии 2000). Для отчета сводной таблицы можно задать отображение в структурированном формате, аналогичном формату стандартных отчетов базы данных, облегчающем чтение больших или сложных отчетов сводных таблиц.

Автоформаты сводных таблиц (введено в версии 2000). Автоформаты сводных таблиц можно использовать для отображения структурированных и неструктурированных отчетов сводных таблиц, а также для задания параметров печати сводных таблиц (разрывов страниц и повторяющихся подписей строк и столбцов) для отчетов сводных таблиц, отображаемых в структурированном формате.

Отображение и скрытие элементов полей (введено в версии 2000). Поля строк и столбцов теперь снабжены стрелками раскрытия списка Стрелка поля. По щелчку такой стрелки отображается список доступных элементов, из которого можно выбрать нужный. Этот список позволяет быстро отображать и скрывать элементы полей.

Выделение данных и форматирование (улучшено в версии 2000). Теперь нет необходимости выделять части сводной таблицы при форматировании отчета сводной таблицы. Форматирование, применяемое с помощью обычного выделения в Excel, сохраняется при обновлении или изменении макета.

Исходные данные OLAP (введено в версии 2000). Существует возможность создавать отчеты сводных таблиц на основе баз данных OLAP, а также создавать кубы OLAP на основе запросов к другим базам данных. Базы данных и кубы OLAP организуют данные в отчетах сводных таблиц, ускоряя загрузку и обновление данных по сравнению с использованием традиционных баз данных.

Интерактивные сводные таблицы для Web-страниц (введено в версии 2000). Отчет сводной таблицы можно сделать доступным на Web-странице в виде сводной таблицы, представляющей из себя компонент, позволяющий пользователям взаимодействовать с данными в Web-обозревателе. Пользователи также могут обновлять данные, изменять макет и выбирать различные элементы для отображения.

Поочередная загрузка данных для элементов полей страниц (введено в версии 97). При работе с внешними базами данных большого объема данные могут извлекаться по мере их вывода на экран, что обеспечивает возможность работы с еще большими объемами данных.

Автоматическая сортировка (введено в версии 97). Элементы отчета сводной таблицы могут сортироваться автоматически с сохранением порядка сортировки при обновлении данных или при изменении структуры отчета сводной таблицы.

Автоматическое отображение наибольшего или наименьшего элемента (введено в версии 97). Возможно задание вывода наибольшего или наименьшего элемента данных и указание количества выводимых наибольших и наименьших элементов.

Сохранение дат в отчетах сводных таблиц как обычных чисел (введено в версии 97). Сортировка и форматирование дат в отчетах сводных таблиц теперь выполняется так же, как и в остальной части листа.

Возврат в начало

Настройка параметров сводных таблиц

Настройка параметров сводных таблиц (введено в версии 97). Установка параметров для всего отчета сводной таблицы теперь производится в отдельном диалоговом окне Параметры сводной таблицы. Это диалоговое окно доступно как в мастере отчетов сводных таблиц и диаграмм, так и в готовых отчетах сводных таблиц.

Выполнение запросов в фоновом режиме (введено в версии 97). Запрос на получение данных отчета сводной таблицы из внешней базы данных может выполняться в фоновом режиме, что позволяет продолжать работу в Microsoft Excel во время загрузки данных.

Объединенные заголовки (введено в версии 97). Существует возможность автоматического использования объединенных заголовков для внешних полей строк и столбцов отчетов сводных таблиц.

Формат полей страниц (введено в версии 97). В сводной таблице может быть использовано несколько полей страниц. Для вывода большего количества полей страниц на экране их можно выводить по строкам или по столбцам.

Настройка отображения ошибочных значений и пустых ячеек (введено в версии 97). Способ вывода ошибочных значений и пустых ячеек может быть задан пользователем, за исключением отображения встроенных ошибок, таких как #ССЫЛКА и #ИМЯ или вывода 0 (нуля) для пустых ячеек.

Оптимизация использования памяти (введено в версии 97). Использование памяти для полей с более чем с 256 элементами оптимизировано, что позволяет небольшим сводным таблицам занимать меньше памяти.

Возврат в начало

Формулы и вычисления в отчетах сводных таблиц

Вычисляемые поля и элементы (введено в версии 97). Существует возможность создания полей и элементов полей, выполняющих вычисления по пользовательским формулам над данными отчета сводной таблицы.

Список формул в отчете сводной таблицы (введено в версии 97). Существует возможность отобразить список формул, использованных для вычисляемых полей и элементов.

Изменения порядка вычислений (введено в версии 97). Если для вычисляемого элемента задано несколько формул, может быть установлен порядок, в котором они вычисляются.

Ссылки на данные отчета сводной таблицы в формулах (введено в версии 97). Функция ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ дает возможность использовать данные отчета сводной таблицы в формулах вне отчета сводной таблицы.

Возврат в начало


Операторы проверки данных

Поля параметров служат для ввода значений, ссылок на ячейки и формул.

Оператор | Параметры
между | Вводимые значения должны быть больше или равны значениям параметров Минимум, Начальная дата и Время начала и меньше или равны значениям параметров Максимум, Конечная дата и Время конца.
вне | Вводимые значения должны быть меньше, чем значения параметров Минимум, Начальная дата, и Время начала, и больше, чем значения параметров Максимум, Конечная дата и Время конца.
равно | Вводимые значения должны быть равны значениям параметров Значение, Длина, Дата и Время.
не равно | Вводимые значения не должны быть равны значениям параметров Значение, Длина, Дата и Время.
больше | Вводимые значения должны превосходить значения параметров Минимум, Начальная дата и Время начала.
меньше | Вводимые значения должны быть меньше, чем значения параметров Максимум, Конечная дата и Время конца.
больше или равно | Вводимые значения должны быть больше или равны значениям параметров Минимум, Начальная дата и Время начала.
меньше или равно | Вводимые значения должны быть меньше или равны значениям параметров Максимум, Конечная дата и Время конца.


Типы ограничений на данные

Параметры, отображаемые в диалоговом окне Проверка вводимых значений, зависят от значений, установленных в списках Тип данных и Значение.

Введите | Описание и параметры
Любое значение | Не накладывает никаких ограничений на вводимые данные. Используйте эту настройку, чтобы выводить на экран информационные сообщения, не проверяя вводимые данные.
Условие Позволяет вводить формулу, использовать выражение и употреблять вычисление в другой ячейке, чтобы установить корректность данных.

Формула — здесь можно ввести формулу, поставив перед ней знак равенства (=). Формула должна выдавать значения Истина или Ложь.

Игнорировать пустые ячейки — позволяет оставить ячейку пустой. Чтобы задействовать ограничения, снимите флажок.
Дата Указывает, что вводимые данные должны быть датами.

Данные — служит для выбора оператора и установки параметров. Чтобы получить сведения о доступных операторах и параметрах, нажмите кнопку [image] .

Дата — служит для ввода даты.

Начальная дата — позволяет ввести начальную дату.

Конечная дата — позволяет ввести конечную дату.

Игнорировать пустые ячейки — позволяет оставить ячейку пустой. Чтобы задействовать ограничения, снимите флажок.
Действительное Указывает, что вводимые данные должны быть числами или дробями.

Данные — служит для выбора оператора и установки параметров. Чтобы получить сведения о доступных операторах и параметрах, нажмите кнопку [image] .

Значение — служит для ввода числа.

Минимум — позволяет ввести наименьшее число.

Максимум — позволяет ввести наибольшее число.

Игнорировать пустые ячейки — позволяет оставить ячейку пустой. Чтобы задействовать ограничения, снимите флажок.
Список Позволяет установить список корректных данных.

Источник — служит для ввода ссылки на диапазон, на определенное имя или тип корректных данных. В качестве разделителя используется запятая (например, низкий, средний, высокий)

Игнорировать пустые ячейки — позволяет оставить ячейку пустой. Чтобы задействовать ограничения, снимите флажок.

Список допустимых значений — позволяет отображать список при выборе ячейки. Чтобы отменить отображение списка, снимите флажок.
Длина текста Указывает допустимое количество символов.

Данные — служит для выбора оператора и установки параметров. Чтобы получить сведения о доступных операторах и параметрах, нажмите кнопку [image] .

Длина — служит для ввода числа.

Минимум — позволяет ввести наименьшее число.

Максимум — позволяет ввести наибольшее число.

Игнорировать пустые ячейки — позволяет оставить ячейку пустой. Чтобы задействовать ограничения, снимите флажок.
Время Указывает, что вводимые данные должны быть временем.

Данные — служит для выбора оператора и установки параметров. Чтобы получить сведения о доступных операторах и параметрах, нажмите кнопку [image] .

Время — служит для ввода времени.

Время начала — позволяет ввести начальное время.

Время конца — позволяет ввести конечное время.

Игнорировать пустые ячейки — позволяет оставить ячейку пустой. Чтобы задействовать ограничения, снимите флажок.
Целое число Указывает, что вводимые данные должны быть целыми числами.

Данные — служит для выбора оператора и установки параметров. Чтобы получить сведения о доступных операторах и параметрах, нажмите кнопку [image] .

Значение — служит для ввода числа.

Минимум — позволяет ввести наименьшее число.

Максимум — позволяет ввести наибольшее число.

Игнорировать пустые ячейки — позволяет оставить ячейку пустой. Чтобы задействовать ограничения, снимите флажок.


 Формат файлов dBASE

Формат файлов dBASE

Форматы файлов dBASE — DBF 2 (dBASE II), DBF 3 (dBASE III) и DBF 4 (dBASE IV) — сохраняют только текст и значения в том виде, как они отображаются в ячейках активного листа. Все форматирование, разметка страницы, рисунки, объекты и другие возможности Microsoft Excel 2000 утрачиваются. Данные, отображаемые в текущем представлении отчета сводной таблицы, сохраняются; все остальные данные отчета сводной таблицы утрачиваются.

  • Сохраняются все строки и следующее число столбцов:
    Формат | Столбцы
    DBF 2 (dBASE II) | 32
    DBF 3 (dBASE III) | 128
    DBF 4 (dBASE IV) | 256

  • Преобразуется только диапазон ячеек с именем "база_данных". Если после задания имени диапазона в него были добавлены новые записи, необходимо заново определить диапазон, чтобы включить в него новые записи до сохранения файла в формате dBASE. Если диапазон базы данных не определить заново, будет преобразован список данных текущей области.

  • Текстовые значения в первой строке диапазона используются в качестве имен полей dBASE, длина которых ограничена 10 символами; остальные символы отсекаются. Если первая строка содержит только числа, в преобразованный файл вставляются автоматически имена полей (N1, N2 и т.д.).

  • Типы данных значений в первой строке данных преобразуемого диапазона определяют типы данных каждого поля (столбца) данных. Если первая строка данных поля содержит пустое значение, поле преобразуется как текстовое, даже если последующие строки этого поля содержат числа; числа в этом случае преобразуются как текст.

  • В ячейках сохраняются только видимые данные. Прежде чем сохранять лист в формате dBASE, увеличьте ширину столбцов в Excel, чтобы были видны все данные.

  • Если ячейки содержат десятичные дроби, но имеют в Excel числовой формат «Общий», их значения округляются до ближайшего целого. Для того чтобы сохранить числа справа от десятичной запятой, задайте для ячеек формат «Числовой», а затем укажите количество десятичных разрядов, которое требуется сохранить.

  • Если ячейки преобразуемого диапазона содержат формулы, то сохраняются только результаты формул, даже если задан режим отображения в ячейках листа формул, а не значений. Для того чтобы гарантировать корректность преобразования значений формул, выберите в меню Сервис команду Параметры, перейдите на вкладку Вид и снимите флажок Формулы. Перед сохранением файла убедитесь в том, что все значения видны. Для того чтобы сохранить формулу как текст, поставьте перед ней апостроф (').


Формат DIF (Data Interchange Format)

В формате DIF (Data Interchange Format) сохраняются данные только активных листов.

  • Все строки и все символы ячеек сохраняются.

  • Если для листа задан режим отображения в ячейках результатов формул, в преобразованном файле сохраняются только результаты формул. Для того чтобы сохранить формулы, необходимо отобразить их перед сохранением файла. Для отображения формул установите флажок Формулы на вкладке Вид диалогового окна Параметры (меню Сервис).

  • Ширина столбцов и большинство числовых форматов сохраняются, но все остальные форматы утрачиваются.

  • Настройки диалогового окна Параметры страницы (меню Файл) и принудительные разрывы страниц утрачиваются.

  • Примечания ячеек, рисунки, внедренные диаграммы, объекты, элементы управления форм, гиперссылки, параметры проверки данных, условное форматирование и другие свойства листа утрачиваются.

  • Данные, отображаемые в текущем представлении отчета сводной таблицы, сохраняются. Все остальные данные сводной таблицы утрачиваются.

  • Код Visual Basic утрачивается.


 Защищаемые элементы листа

Защищаемые элементы листа

Защита листа. При защите листа с помощью команды Защитить лист (меню Сервис, подменю Защита) можно ограничить доступ к листу, как описано ниже. Для снятия этих ограничений необходимо снять защиту листа при помощи команды Снять защиту листа (меню Сервис, подменю Защита). Если для защищаемых элементов задан пароль, другим пользователям необходимо знать этот пароль для снятия защиты.

Выполнение макросов, содержащих допустимые инструкции для защищенных листов. В случае запуска макроса, содержащего инструкции, которые не могут быть выполнены на защищенном листе, выводится сообщение о прекращении выполнения макроса.

Защита содержимого. Если установить в диалоговом окне Защитить лист флажок Содержимого, пользователи не смогут выполнять следующие действия без предварительного отключения защиты.

  • Изменение ячеек, если только они не были разблокированы перед установкой защиты листа. Например, если лист используется в качестве формы, можно оставить заблокированными ячейки, содержащие метки и инструкции, и разблокировать поля ввода. Для перехода по разблокированным полям в защищенном листе служит клавиша TAB.

  • Просмотр скрытых перед защитой листа строк и столбцов.

  • Просмотр скрытых перед защитой листа формул.

  • Изменение на листах диаграмм таких элементов как ряды данных, оси и легенды. Диаграммы продолжают отображать изменения, вносимые в их исходные данные.

Защита объектов. Если установить в диалоговом окне Защитить лист флажок Объектов, пользователи не смогут выполнять следующие действия без предварительного отключения защиты.

  • Изменение графических объектов, включая созданные с помощью Microsoft Excel карты, внедренные диаграммы, формы, поля и элементы управления, если только они не были разблокированы перед защитой листа. Например, если лист содержит кнопку, запускающую макрос, ей можно пользоваться для запуска макроса, но нельзя удалить.

  • Изменение внедренных диаграмм. Однако защищенные внедренные диаграммы продолжают обновляться при изменении их исходных данных.

  • Обновление карты, если она защищена.

  • Добавление или изменение примечаний.

  • Изменение на листах диаграмм графических объектов, таких как полей, если только они не были разблокированы перед защитой листа диаграммы.

Защита сценариев. Если установить в диалоговом окне Защитить лист флажок Сценариев, пользователи не смогут выполнять следующие действия без предварительного отключения защиты.

  • Просмотр скрытых сценариев.

  • Изменение и удаление защищенных сценариев. При этом допускается изменение значений незащищенных ячеек и добавление новых сценариев.

Примечание. В редакторе Visual Basic для защиты ячеек предусмотрено свойство Visual Basic для приложений EnableSelection (защита выделенной области). Дополнительные сведения см. в справочной системе редактора Visual Basic.


Новые возможности работы с формулами и ввода данных

Создавать формулы на листах стало легче чем когда-либо. Новые средства помогают выстраивать и редактировать формулы, вводить функции и создавать пользовательские формы и шаблоны.

Форматы дат с указанием года четырьмя цифрами (введено в версии 2000). Дополнительные числовые форматы с указанием года четырьмя цифрами.

Панель формул и команда «Вставить функцию» (введено в версии 97). Панель формул облегчает создание формул, автоматически исправляя распространенные ошибки и предоставляя во время работы справочные сведения с помощью мастера ответов.

Рекомендуемые функции (введено в версии 97). Если при работе в диалоговом окне Мастер функций - шаг 1 из 2 неизвестно, какая функция возвращает нужный результат, введите краткое описание нужной операции. Помощник предложит функции для использования.

Поиск диапазона (введено в версии 97). При редактировании формулы все ячейки и диапазоны, на которые ссылается формула, выделяются цветными рамками, причем цвета рамок соответствуют цветному выделению ссылок.

Заголовки в формулах (введено в версии 97). Заголовки строк и столбцов могут быть использованы как ссылки в формулах без создания имен.

Встроенные шаблоны (введено в версии 95). Новые шаблоны обеспечивают создание интерактивных форм, с помощью которых можно вводить данные в списки или в базы данных. В число этих шаблонов входят отчет о расходах и бланк заказа.

Мастер шаблонов с функцией сбора данных (введено в версии 95). Возможно создание собственных форм для ввода данных в списки или базы данных с помощью мастера шаблонов с функцией автоматического сбора данных.

Автовычисления (введено в версии 95). При выделении диапазона сумма ячеек этого диапазона выводится в строке состояния.

Автозаполнение (Введено в версии 95). При вводе текста в ячейку производится его сравнение с текстом других ячеек данного столбца и предлагается закончить ввод на основе уже введенного текста.

Автозамена (введено в версии 95). При вводе текста в ячейки распространенные орфографические ошибки исправляются автоматически.

Проверка данных (введено в версии 97). Можно задать ограничения на тип или значения данных, вводимых в ячейки, такие как ввод только текста, целых чисел, дат или ввод только чисел, меньших заданного, или только значений из заданного списка.

Задание ограничений ввода данных и сообщений об ошибках (введено в версии 97). Проверка данных позволяет задать вывод пользовательских сообщений с правилами ввода (при переходе в ячейку с ограничениями) или сообщений об ошибках (при вводе недопустимых данных).

Поиск неверных данных на листе (введено в версии 97). Панель инструментов Зависимости содержит кнопку Обвести неверные данные, позволяющую найти ячейки, содержащие неверные данные.


Математические операторы в Lotus 1-2-3 и Microsoft Excel

В следующем списке приведено сравнение математических операторов, используемых в Microsoft Excel и Lotus 1-2-3.

Последовательность выполнения. Lotus 1-2-3 выполняет операции в формулах в следующем порядке: возведение в степень, определение знака числа, умножение и деление, сложение и вычитание, сравнение (= < > <= >= <>, #not#, #and# and #or#), а затем конкатенация. См. сведения о порядке выполнения операций в формулах в Microsoft Excel.

Описание | Оператор Lotus 1-2-3 | Оператор Microsoft Excel
Возведение в степень | ^ | ^
Знак числа | + и – | – (по умолчанию в Microsoft Excel число считается положительным)
Умножение и деление | * и / | * и /
Сложение и вычитание | + и – | + и –
Сравнение | = < > <= >= <> | = < > <= >= <>
 | #not# | функция НЕ
 | #and# и #or# | функции И и НЕ
Объединение двух текстовых строк (конкатенация) (только для версий 2.0 или более поздних) | & | &

Примечания

  • В Lotus 1-2-3 оператор возведения в степень (^) имеет преимущество над оператором унарного минуса (–), тогда как в Excel унарный минус обрабатывается первым. Например, формула =-2^4 возвращает -16 в Lotus 1-2-3, но 16 в Microsoft Excel. Чтобы скорректировать различие, следует использовать круглые скобки для указания последовательности выполнения операторов, например, =-(2^4) =-16.

  • И в Lotus 1-2-3, и в Excel операторы с одинаковым приоритетом, например, И и ИЛИ, обрабатываются слева направо.


 Не удается изменить лист или диаграмму во время выполнения запроса сводной таблицы или сводной диаграммы

Не удается изменить лист или диаграмму во время выполнения запроса сводной таблицы или сводной диаграммы

Проверьте, обновляется ли область, которую требуется изменить. Пока запрос выполняется в фоновом режиме, можно продолжать работу с другими книгами и таблицами Microsoft Excel, а также создавать и изменять другие отчеты. Однако вносить изменения в отчет сводной таблицы или диаграммы, обновляемый в данный момент, нельзя, как и изменять другие отчеты, основанные на обновляемом отчете.

Дождитесь завершения запроса или отмените его. Изменения в отчет сводной таблицы или сводной диаграммы можно вносить после завершения загрузки внешних данных. Для того чтобы проверить состояние запроса, выполняющегося в фоновом режиме, дважды щелкните значок индикатор обновления в строке состояния, чтобы отобразить диалоговое окно Состояние обновления внешних данных. Для того чтобы прервать запрос, нажмите кнопку Прервать в диалоговом окне.

Проверьте, настроен ли запрос на выполнение в режиме ожидания окончания загрузки или в фоновом режиме. Если запрос сводной таблицы или сводной диаграммы выполняется в режиме ожидания, изменение листа во время выполнения запроса невозможно, но запрос может выполняться быстрее.

Запуск запроса для сводной таблицы или отчета сводной диаграммы в фоновом режиме или в процессе ожидания


Форматированный текст (разделитель — пробел)

В формате текста с разделителями пробелами (*.prn) сохраняются данные только активных листов.

Все строки сохраняются. Если строка содержит свыше 240 символов, символы после 240 создают новую строку в конце файла. Например, если все строки документа из 10 строк содержат более 240 символов, то излишек текста строки 1 переносится в 11, излишек текста строки 2 в 12, и т. д.

Если ячейка содержит запятую, ее содержимое берется в кавычки. Если в ячейке вместо результирующей величины отображена формула, эта формула становится текстом. Все виды оформления, графика, встроенные объекты утрачиваются.

Перед сохранением листа, убедитесь, что все данные, которые нужно сохранить, видимы и между столбцами достаточно свободного места. Однако данные могут быть потеряны или неправильно разделены. Возможно, придется откорректировать ширину столбцов вручную.


Новые возможности форматирования и оформления

Расширенные возможности форматирования и оформления позволяют получать печатные отчеты и интерактивные формы желаемого вида.

Автоматическое заполнение списка (Введено в версии 2000). Microsoft Excel 2000 автоматически расширяет форматирование и формулы в списках, упрощая эту распространенную задачу.

Символ евро (введено в версии 2000). Доступны новые числовые форматы с символом евро.

Режим разметки страницы (введено в версии 97). Команда Разметка страницы в меню Вид дает возможность интуитивной настройки параметров печати листа. При перетаскивании разрывов страниц и границ области печати Microsoft Excel автоматически масштабирует данные по размерам печатаемой страницы. В этом режиме возможны и обычные операции редактирования, такие как перемещение и копирование ячеек и объектов и ввод текста.

Объединенные ячейки (введено в версии 97). С помощью объединения ячеек возможно более качественное оформление интерактивных форм. Ссылки на такие ячейки могут быть использованы в формулах.

Отступ текста в ячейках (введено в версии 97). Отступ может составлять до 15 единиц.

Поворот текста в ячейках (введено в версии 97). Текст в ячейке можно повернуть на любой угол. Перенос и поворот текста позволяет снизить горизонтальные размеры листа, сократив место для отображения длинных текстовых элементов, например, заголовков, и оставляя больше места для данных.

Условные форматы (введено в версии 97). Microsoft Excel может динамически применять различные стили шрифтов, заливку и границы для ячеек, значения которых лежат или не лежат в заданных пределах. Это позволяет быстро выделить важные данные без просмотра большого количества ячеек.

Упрощенное форматирование чисел (введено в версии 95). В Microsoft Excel можно легко изменять форматы чисел без использования кодов. Выберите в меню Формат команду Ячейки и перейдите на вкладку Число. Выберите нужный числовой формат, ориентируясь на пример отображения числа. В программу встроены форматы чисел для наиболее распространенных случаев.


Новые возможности поддержки пользователей и технические ресурсы Microsoft

Разделы справочного руководства, ориентированные на выполнение практических задач, помогают пользователю шаг за шагом осваивать возможности программы. Мощь сети Web дает пользователю возможность получить поддержку от Microsoft на своем рабочем месте.

Помощник появляется не в окне(Улучшено в версии 2000) Помощник по Office теперь появляется не в окне. Он использует меньше места на экране, но по-прежнему оказывает большую помощь, когда он нужен. Но если он не может ответить на вопрос, можно предложить ему поискать требуемую информацию в Интернете. Можно также сообщить в Microsoft о тех вопросах, на которые не было получено ответа (это поможет улучшить следующие версии Office). Если вам не нравится помощник, можно его отключить и использовать содержание и указатель справочной системы.

Техническая поддержка по сети Web (Введено в версии 97) Если имеется доступ к Интернету, используйте команду Office на Web (меню Справка) для получения свободно распространяемых программ, сведений о продуктах и доступа к техническим ресурсам, таким как Microsoft Knowledge Base.

Информативные подсказки о кнопках на панели инструментов, параметрах диалогового окна, командах и элементах экрана (Улучшено в версии 95) Когда указатель мыши задерживается на кнопки панели инструментов, во вплывающем окне выводится имя кнопки. Не прерывая работы, можно выяснить назначение каждого элемента диалогового окна. Чтобы увидеть подсказку, нажмите кнопку со знаком вопроса [image] в заголовке диалогового окна, а затем щелкните интересующий элемент. Чтобы увидеть описание команды меню, кнопки на панели инструментов или элемента экрана, выберите команду Что это такое? в меню Справка, а затем щелкните команду или элемент.


Скрытая функция

В версии Microsoft Excel для текущего языка эта функция недоступна.


Отсутствует команда "Копировать рисунок", "Вставить рисунок" или "Вставить связь с рисунком"

Выберите меню Правка, одновременно удерживая клавишу SHIFT.


Новые возможности установки, графики, национальных настроек и интеграции с Microsoft Office

Использование одних и тех же инструментов во всех программах Office означает, что достаточно изучить только один способ выполнения того или иного задания. Данный раздел содержит следующие сведения:

Подготовка и запуск Office 2000

Использование рисунков и Clip Gallery

Использование Office по всему миру

Упрощение использования рабочего стола Office 2000

Подготовка и запуск Office 2000

Установка Office 2000 (Улучшено в версии 2000) Office 2000 определяет оптимальные пеараметры установки для компьютера, учитывая установленные и используемые программные компоненты. Если уже установлена более ранняя версия Office, Office 2000 использует мастер профилей Office для сохранения большинства настроек пользователя. Office 2000 может также удалить предыдущие версии.

Получение программы тогда, когда она нужна (Введено в версии 2000) При использовании Office видны ярлыки, значки и команды для программ и компонентов, которые не были установлены при первоначальной установке Office. Когда нужно их использовать, просто выберите команду и 2000 установит программу или компонент.

Поддержание работоспособности Office 2000 (Введено в версии 2000) Office может разрешать затруднения, связанные с некритичными файлами (например шрифты или шаблоны), если будет выбрана команда Найти и устранить в меню Справка. Эта команда переустановит потерянные или поврежденные файлы. Проблемы с существенно важными файлами и записями в системном реестре автоматически выявляются и устраняются при открытии программы Office.

Перенесение установок Office на другой компьютер (Введено в версии 2000) Системный администратор может сконфигурировать профиль пользователя, чтобы он всегда был доступен при входе в систему. Профиль пользователя содержит информацию о вспомогательных словарях, пользовательских шаблонах, списках автозамены и автоформата. При подключении к компьютеру, содержащему профиль пользователя, становится доступным набор установок, определяющих значения различных параметров рабочей среды для отдельного пользователя, например установленные приложения, значки на рабочем столе и цветовое оформление.

Возврат в начало

Использование рисунков и Clip Gallery

Clip Gallery (Улучшено в версии 2000) Когда используется Clip Gallery, картинки могут быть объединены в специальные категории, картинкам могут быть присвоены ключевые слова, изображения могут быть вставлены в документы Office. При работе с документами Clip Gallery может быть открыта в окне меньшего размера. В Clip Gallery можно хранить также звуки и видеофрагменты. Если какие-то картинки, звуки или видеофрагменты используются часто, чтобы упростить доступ н ним, они могут быть добавлены в Clip Gallery.

Панель инструментов Рисование (Введено в версии 97) В Microsoft Excel используются общие для программ Office средства рисования. Они позволяют выбирать фигуры из палитр стандартных фигур и создавать текстовые эффекты.

Дополнительные графические фильтры (Введено в версии 97) Фильтры форматов Graphics Interchange Format (.gif) и JPEG File Interchange Format (.jpg) позволяют отображать диаграммы, хранящиеся в стандартных графических форматах, в Интернете.

Возврат в начало

Использование Office по всему миру

Использование нескольких языков (Введено в версии 2000) Можно вводить, отображать и редактировать тексты на любом поддерживаемом языке в любой национальной версии Office 2000. Поддерживаются европейские языки, японский, китайский, корейский, арабский языки и иврит.

Изменение языка интерфейса (Введено в версии 2000) Office 2000 упрощает изменение языка интерфейса пользователя. Например, если компания предпочитает использовать стандартную английскую установку Office 2000, языки пользовательского интерфейса и оперативной справки могут быть настроены на предпочтаемый язык без помощи системного администратора.

Поддержка кодировки Юникод(Введено в версии 2000) Все программы Office 2000 поддерживают кодировку Юникод для упрощения создания многоязыковых документов. Теперь текст на любом из поддерживаемых языков может быть введен и отображен в одной версии Office. (В отношении Outlook это справедливо только для электронной почты, но не относится к другим элементам, например контактам, запросам на собрание, задачам и т. п.)

Возврат в начало

Упрощение использования рабочего стола Office 2000

Индивидуальные настройки меню и панелей инструментов Office 2000(Введено в версии 2000) Только наиболее часто используемые элементы выделены в новых индивидуализированных меню и панелях инструментов. Меню могут быть легко расширены, чтобы отображать все команды. Выбранная команда она появляется в настраиваемом меню. Панели инструментов размещаются в одном ряду на экране, поэтому на экране остается больше рабочего пространства. Когда нажимается кнопка на панели инструментов, она добавляется к настраиваемой панели инструментов на экране. Панели инструментов могут быть легко настроены. Для этого достаточно перетащить управляющие элементы команд на панель инструментов.

Просмотр открытых документов (Введено в версии 2000) Можно использовать панель задач Windows для переключения между открытыми документами Office (каждый представлен на панели задач значком).

Создание ярлыков для быстрого перехода (Введено в версии 2000) Пользователь или системный администратор могут создать ярлыки для файлов, папок, Web-страниц с помощью гиперссылок или папки «Избранное». Кнопки на панелях инструментов Office могут быть настроены на переход к информации, характерной для компании, или к наиболее часто используемым ресурсам Интернета.

Office Binder (Введено в версии 95, улучшено в версии 97) Сгруппируйте все файлы проекта: документы, книги и презентации, в одном месте. Файлы, собранные в подшивку, могут быть объединены и распечатаны в виде одного документа, с едиными колонтитулами и сквозной нумерацией страниц.

Панель Office(Введено в версии 95) Позволяет быстро найти и открыть документы или базы данных, назначать встречи и даже посылать сообщения электронной почты. Панель Office может быть настроена для вывода часто используемых файлов в виде кнопок

Возврат в начало


 Эквиваленты функций Lotus 1-2-3 в Microsoft Excel

Эквиваленты функций Lotus 1-2-3 в Microsoft Excel

Многие функции Lotus 1-2-3 имеют в Microsoft Excel свои эквиваленты. Однако в Microsoft Excel используются иные правила вычисления. Это касается использования текста в формулах, определенных условий в базе данных, а также значений некоторых логических операторов.

Более подробные сведения о функциях в приведенной ниже таблице можно получить, щелкнув мышью имя нужной функции Microsoft Excel. Для получения информации о способах ввода формул, содержащих функции, нажмите кнопку [image] .

Функция Lotus | Эквивалент в Microsoft Excel | Примечания
@@ | ДВССЫЛ |
@ABS | ABS |
@ACOS | ACOS |
@ASIN | ASIN |
@ATAN | ATAN |
@ATAN2 | ATAN2 |
@AVG | СРЗНАЧА |
@CELL | ЯЧЕЙКА |
@CELLPOINTER | ЯЧЕЙКА | При вызове без указания второго аргумента возвращает сведения о ячейке, содержащей функцию.
@CHAR | СИМВОЛ |
@CHOOSE | ВЫБОР |
@CLEAN | ПЕЧСИМВ |
@CODE | КОДСИМВ |
@COLS | ЧИСЛСТОЛБ |
@COS | COS |
@COUNT | СЧЁТЗ |
@CTERM | КПЕР | Требуется указать периодические выплаты вместо будущего значения.
@D360 | ДНЕЙ360 | Функция @D360 доступна только в Lotus 1-2-3 версии 3 или более поздней.
@DATE | ДАТА |
@DAVG | ДСРЗНАЧ |
@DAY | ДЕНЬ |
@DCOUNT | БСЧЁТА |
@DDB | ДДОБ |
@DGET | БИЗВЛЕЧЬ |
@DMAX | ДМАКС |
@DMIN | ДМИН |
@DSTD | ДСТАНДОТКЛП |
@DSTDS | ДСТАНДОТКЛ | Функция @DSTDS доступна только в Lotus 1-2-3 версии 3 или более поздней.
@DSUM | БДСУММ |
@DVAR | БДДИСПП |
@DVARS | БДДИСП | Функция @DVARS доступна только в Lotus 1-2-3 версии 3 или более поздней.
@ERR |  | Эквивалент не предусмотрен, однако значения ошибок (например #N/A и #VALUE!) можно ввести непосредственно в ячейку или формулу Microsoft Excel.
@EXACT | СОВПАД |
@EXP | EXP |
@FALSE | ЛОЖЬ |
@FIND | НАЙТИ |
@FV | БЗ |
@HLOOKUP | ГПР |
@HOUR | ЧАС |
@IF | ЕСЛИ | В Microsoft Excel два последних аргумента могут быть величинами любого типа или содержать другую функцию, а в @IF используются только числа и строки.
@INDEX | ИНДЕКС | Предусмотрен вариант для выбора значений из массива.
@INT | ОТБР |
@IRR | ВНДОХ | Аргументы передаются в обратном порядке.
@ISERR | ЕОШ | Используется для определения любого из шести значений ошибки, предусмотренных в Microsoft Excel.
@ISNA | ЕНД |
@ISNUMBER | ЕНЕТЕКСТ |
@ISRANGE | ЕССЫЛКА | Функция доступна только в Lotus 1-2-3 версии 3 или более поздней.
@ISSTRING | ЕТЕКСТ |
@LEFT | ЛЕВСИМВ |
@LENGTH | ДЛСТР |
@LN | LN |
@LOG | LOG |
@LOWER | СТРОЧН |
@MAX | МАКСА |
@MID | ПСТР |
@MIN | МИНА |
@MINUTE | МИНУТЫ |
@MOD | ОСТАТ |
@MONTH | МЕСЯЦ |
@N | Ч |
@NA | НД |
@NOW | ТДАТА |
@NPV | НПЗ |
@PI | ПИ |
@PMT | ППЛАТ | В Microsoft Excel используется другой порядок аргументов, чем в @PMT.
@PROPER | ПРОПНАЧ |
@PUREAVG | СРЗНАЧ | Функция @PUREAVG доступна только в Lotus 1-2-3 версии 4 или более поздней.
@PURECOUNT | СЧЁТ | Функция @PURECOUNT доступна только в Lotus 1-2-3 версии 4 или более поздней.
@PUREMAX | МАКС | Функция @PUREMAX доступна только в Lotus 1-2-3 версии 4 или более поздней.
@PUREMIN | МИН | Функция @PUREMIN доступна только в Lotus 1-2-3 версии 4 или более поздней.
@PURESTD | СТАНДОТКЛОНП | Функция @PURESTD доступна только в Lotus 1-2-3 версии 4 или более поздней.
@PURESTDS | СТАНДОТКЛОН | Функция @PURESTDS доступна только в Lotus 1-2-3 версии 4 или более поздней.
@PUREVAR | ДИСПР | Функция @PUREVAR доступна только в Lotus 1-2-3 версии 4 или более поздней.
@PUREVARS | ДИСП | Функция @PURVARS доступна только в Lotus 1-2-3 версии 4 или более поздней.
@PV | ПЗ | В Microsoft Excel используется другой порядок аргументов, чем в @PV.
@RAND | СЛЧИС | Возвращает новое случайное число при каждом вычислении функции. (@RAND возвращает случайные числа из одинаковой последовательности в разных сеансах работы.)
@RATE | НОРМА | В Microsoft Excel используется другой порядок аргументов, чем в @RATE.
@REPEAT | ПОВТОР |
@REPLACE | ЗАМЕНИТЬ |
@RIGHT | ПРАВСИМВ |
@ROUND | ОКРУГЛ |
@ROWS | ЧСТРОК |
@S | T |
@SECOND | СЕКУНДЫ |
@SIN | SIN |
@SLN | АМР |
@SQRT | КОРЕНЬ |
@STD | СТАНДОТКЛОНПА |
@STDS | СТАНДОТКЛОНА |
@STRING | ФИКСИРОВАННЫЙ |
@SUM | СУММ |
@SYD | АМГД |
@TAN | TAN |
@TERM | КПЕР | В Microsoft Excel используется другой порядок аргументов, чем в @TERM.
@TIME | ВРЕМЯ |
@TIMEVALUE | ВРЕМЗНАЧ |
@TODAY | СЕГОДНЯ |
@TRIM | СЖПРОБЕЛЫ |
@TRUE | ИСТИНА |
@UPPER | ПРОПИСН |
@VALUE | ЗНАЧЕН |
@VAR | ДИСПРА |
@VARS | ДИСПА |
@VDB | ПДОБ |
@VLOOKUP | ВПР |
@YEAR | ГОД |


 Терминология Lotus 1-2-3 и эквивалентные понятия Microsoft Excel

Терминология Lotus 1-2-3 и эквивалентные понятия Microsoft Excel

В следующей таблице перечислены понятия Lotus 1-2-3 и эквивалентные понятия Microsoft Excel. Понятия Microsoft Excel не всегда в точности соответствуют понятиям Lotus 1-2-3, но могут быть использованы для поиска нужных сведений в справочной системе Microsoft Excel.

Понятие Lotus 1-2-3 | Понятие или принцип Microsoft Excel
@ Function | Операция
Address | Ссылка
Anchor cell | Выделение диапазона ячеек
Border | Заголовки строк и столбцов
CALC indicator | Строка состояния
Cell pointer | Активная ячейка
Control panel | Строка меню, строка формул, строка состояния
Copy | Копирование и последующая вставка
Crosshatching | Узор диаграммы
Current cell | Активная ячейка
Current worksheet | Активный лист или лист диаграмм
Cursor | Место вставки
Data range | Ряды данных
Data table 1 | Таблица с одним входом
Data table 2 | Таблица с двумя входами
Date format | Числовой формат
Erase | Вырезать
Formula criteria | Вычисляемые условия
Global | Рабочая область
Graph labels | Текст диаграммы
Graph titles | Заголовок диаграммы
Highlight | Выделенный фрагмент
Indicator | Строка состояния
Input range | Ссылка на список или диапазон (для пакета анализа)
Label | Надпись, подпись, текст
Label-prefix | Выравнивание по горизонтали
Label/matching criteria | Условие сравнения
Logical 0 | ЛОЖЬ
Logical 1 | ИСТИНА
Menu pointer | Выбор в меню
Mode indicator | Строка состояния
Numbering/matching criteria | Условие сравнения
Numeric format | Числовой формат
Output range | Диапазон выборки
Picture file | Диаграмма, лист диаграмм (не отдельный файл)
Pointer movement keys | Клавиши со стрелками
Print range | Область печати
Protected cell | Заблокированная/защищенная ячейка
Range highlight | Выделенный диапазон
Repeating label | Горизонтальное выравнивание с заполнением (меню Формат, команда Ячейки, вкладка Выравнивание)
Retrieve a file | Открытие документа
Row numbers | Заголовки строк
Stacked bar graph | Гистограмма с накоплением, линейчатая диаграмма с накоплением, нормированная гистограмма с накоплением, нормированная линейчатая диаграмма с накоплением
Status indicator, status line | Строка состояния
String | Текст
Target cell | Подчиненная ячейка
Target file | Подчиненный документ
Time format | Числовой формат
Titles | Разделенное окно листа Excel
Translate utility | Команды Открыть и Сохранить как из меню Файл
Value | Число
Window | Многочисленные окна, панели
Диаграмма | Диаграмма
Заголовки столбцов | Заголовок столбца


Формат Lotus 1-2-3 версии 1.x (WKS)

В формате Lotus 1-2-3 версии 1.x (WKS) сохраняются данные только текст, значения и формулы на активном листе.

Не сохраняются: программы на Visual Basic, примечания к ячейкам, импортированные графические и рисованные объекты, встроенные диаграммы, сценарии, элементы управления формы, гиперссылки, условия, назначенные для данных, а также условное форматирование.

Остальные элементы сохраняются следующим образом:

  • Строки после 2048 отбрасываются; в ячейке сохраняется до 240 символов.

  • Сохраняется большинство формул. Если формула содержит функцию, не поддерживаемую Lotus 1-2-3 версии 1.x, Microsoft Excel вычисляет функцию до сохранения файла и заменяет формулу результатом вычисления.

  • Не сохраняются операторы пересечения (пробел) и объединения (запятая).

  • Имена диапазонов сохраняются.

  • Ссылки на строки ниже 2048 переносятся в начало листа; например, ссылка A2049 становится ссылкой A1в файле WKS.

  • Формулы, содержащие трехмерные ссылки или ссылки на несмежные диапазоны ячеек, не могут быть сохранены в формате Lotus 1-2-3. Формулы, содержащие ссылки на другие книги, заменяются результатами вычислений.

  • Данные, отображаемые в текущем представлении отчета сводной таблицы, сохраняются. Все остальные данные сводной таблицы утрачиваются.

  • Ширина колонок сохраняется. Все другие форматы ячеек и текста утрачиваются. Шрифты заменяются на Courier размером 10 пунктов.

  • Установки диалогового окна Параметры страницы (меню Файл) и разрывы страниц, установленные вручную, утрачиваются.

  • Отображение линий сетки отключается.

  • Большинство числовых форматов сохраняется:
    • Отрицательные числа, представленные в Microsoft Excel с помощью знака минус (например, -1234), заключаются в круглые скобки. Отрицательные числа, выделенные красным цветом, меняют цвет на стандартный.

    • Знак денежной единицы в финансовом формате из положения в левой части ячейки переходит в нормальное.

    • Специальные форматы, такие как телефонные номера и почтовые коды, не сохраняются.

    • Комбинированные форматы времени и даты (например, 12.9.2000 2:45) преобразовываются в формат, отображающий только дату.

    • Форматы с дробными частями секунд сохраняются в общем формате.

    • Дробные форматы (например, 13/64) преобразуются в десятичные дроби.

    • Обозначения месяцев первой буквой (например, "Я" для января) заменяются на соответствующий порядковый номер.

Чтобы получить сведения о преобразовании книг Microsoft Excel в формат Lotus 1-2-3, обратитесь к Microsoft Office 2000 Resource Kit, доступному на узле Web корпорации Майкрософт.


Формат Lotus 1-2-3 версии 2.x (WK1)

В формате Lotus 1-2-3 версии 2.x (WK1) сохраняются текст, значения и формулы только активного листа.

Не сохраняются: тексты программ на Visual Basic, примечания к ячейкам, импортированные графические и рисованные объекты, встроенные объекты, сценарии, элементы управления формы, гиперссылки, условия, назначенные для данных ячейки, а также условное форматирование.

Остальные элементы Microsoft Excel сохраняются следующим образом:

  • Строки после 8192 отбрасываются, в ячейке сохраняется до 240 символов.

  • Сохраняется большинство формул. Если формула содержит функцию, не поддерживаемую Lotus 2-2-3 версии 2.x, Microsoft Excel вычисляет функцию до сохранения файла и заменяет формулу результатом вычисления.

  • Не сохраняются операторы пересечения (пробел) и объединения (запятая).

  • Имена диапазонов сохраняются.

  • Ссылки на строки, большие 8192 переносятся в начало листа; например, ссылка A8193 становится ссылкой A1 в файле WK1.

  • Трехмерные ссылки и ссылки на несмежные диапазоны ячеек не сохраняются в формате Lotus 1-2-3. Однако если формула содержит ссылки на смежные диапазоны ячеек на том же листе или в другой книге, ссылки сохраняются.

  • Данные, отображаемые в текущем представлении отчета сводной таблицы, сохраняются. Все остальные данные сводной таблицы утрачиваются.

  • Сохраняется ширина столбцов, остальные форматы ячеек и текста утрачиваются. Шрифты заменяются на Courier размером 10 пунктов. Чтобы сохранить больше средств форматирования, сохраните лист в форматах Lotus WK1,ALL (1-2-3) или WK1,FMT (1-2-3).

  • Большинство числовых форматов сохраняется:
    • Отрицательные числа, представленные в Microsoft Excel с помощью знака минус (например, -1234), заключаются в круглые скобки. Отрицательные числа, выделенные красным цветом, меняют цвет на стандартный.

    • Знак денежной единицы в финансовом формате из положения в левой части ячейки переходит в нормальное.

    • Специальные форматы, такие как телефонные номера и почтовые коды, не сохраняются.

    • Комбинированные форматы времени и даты (например, 12.9.2000 2:45) преобразовываются в формат, отображающий только дату.

    • Форматы с дробными частями секунд сохраняются в общем формате.

    • Дробные форматы (например, 13/64) преобразуются в десятичные дроби.

    • Обозначения месяцев первой буквой (например, "Я" для января) заменяются на соответствующий порядковый номер.

Чтобы получить сведения о преобразовании книг Microsoft Excel в формат Lotus 1-2-3, обратитесь к Microsoft Office 2000 Resource Kit, доступному на узле Web корпорации Майкрософт.


Формат Lotus 1-2-3 версии 2.x (WK1, ALL)

Если книга Microsoft Excel 2000 сохраняется в формате Lotus 1-2-3 WK1,ALL (1-2-3), форматирование хранится отдельно в файле ALL. Файл ALL используется надстройкой ALLWAYS в Lotus 1-2-3 для форматирования листов. Если открыть файл WK1 в Microsoft Excel, сведения из файла ALL используются автоматически.

Встроенные диаграммы, которые не сохраняются в формате WK1, сохраняются на листах в формате WK1,ALL. Диаграммы и отчеты сводных диаграмм сохраняются в форматах диаграмм, наиболее близких из доступных в Lotus 1-2-3. Градиентные заполнения, узоры и штриховки заменяются на наиболее близкие цвета. Не сохраняются: таблицы данных на листах диаграмм; линии тренда и планки погрешностей; заливки; объемные маркеры данных. Повернутые тексты вдоль осей и подписи данных становятся горизонтальными.

Чтобы получить сведения об элементах листа, сохраняемых в файле WK1, нажмите кнопку [image] .

Форматы Microsoft Excel сохраняются следующим образом:

  • Ширина столбцов и высота строк сохраняются.

  • В ячейках, содержащих символы с различным форматированием, весь текст получает формат первого символа в ячейке.

  • Выделение полужирным шрифтом, курсивом, подчеркиванием сохраняются; подчеркивание по значению заменяется на обычное подчеркивание. Верхний, нижний индексы и перечеркивание не сохраняются.

  • Шрифты заменяются в соответствии с правилами подстановки шрифтов в системе. Цвет шрифта заменяется на наиболее близкий из доступных в Lotus 1-2-3. Размеры шрифтов преобразуются.

  • Текст, отформатированный при установленном параметре автоподбор ширины на вкладке Выравнивание (меню Формат, команда Ячейки), возвращается в исходное (до установки параметра автоподбор ширины) положение.

  • Все повернутые и вертикальные тексты становятся горизонтальными.

  • Выравнивание по центру, вправо и влево сохраняется. Перенос текста по словам не сохраняется.

  • Вертикально текст выравнивается по нижнему краю.

  • Отступы внутри ячеек удаляются, содержимое ячеек выравнивается влево.

  • Объединенные ячейки разъединяются. Содержимое перемещается в левую верхнюю ячейку.

  • Условное форматирование удаляется и ячейки форматируются общим стилем.

  • Фон листа не сохраняется.

  • Рамки ячеек преобразуются в наиболее близкий стиль рамки, например двойные и точечные рамки превращаются в рамки, обведенные одной линией. Цветные рамки заменяются черными.

  • Заливка ячейки заменяется на черную заливку. Заполнение узором заменяется серой заливкой.


Формат Lotus 1-2-3 версии 2.x (WK1, FMT)

При сохранении книг Microsoft Excel в формате Lotus 1-2-3 версии 2.x (WK1, FMT), данные сохраняются в файле WK1, а сведения о форматировании документа —отдельно, в файле FMТ. Если открыть файл WK1 в Microsoft Excel, сведения из файла FMТ используются автоматически.

Встроенные диаграммы, которые не сохраняются в формате WK1, сохраняются на листах в формате WK1,FMT. Диаграммы и отчеты сводных диаграмм сохраняются в форматах диаграмм, наиболее близких из доступных в Lotus 1-2-3. Градиентные заполнения, узоры и штриховки заменяются на наиболее близкие цвета. Не сохраняются: таблицы данных на листах диаграмм; линии тренда и планки погрешностей; заливки; объемные маркеры данных. Повернутые тексты вдоль осей и подписи данных становятся горизонтальными.

Чтобы получить сведения об элементах листа, сохраняемых в файле *.wk1, нажмите кнопку [image] .

Чтобы получить сведения о форматировании ячеек и текста, сохраняемом в файлах FMТ, нажмите кнопку [image] .


Формат Lotus 1-2-3 версии 3 (WK3)

В формате Lotus 1-2-3 версии 3 (WK3) сохраняются только текст, значения и формулы.

Не сохраняются: тексты программ на Visual Basic, примечания к ячейкам, импортированные графические и рисованные объекты, встроенные объекты, сценарии, элементы управления формы, гиперссылки, условия, назначенные для данных ячейки, а также условное форматирование.

  • Количество сохраняемых листов зависит от объема доступной памяти. По умолчанию даются имена A, B, C и т. д.

  • На одном листе сохраняется до 8192 строк, не более 255 символов в ячейке.

  • Большинство формул сохраняется. Если в формуле есть функция, не поддерживаемая Lotus 1-2-3 версии 3, Microsoft Excel заменит эту функцию результатом вычислений.

  • Функции, доступные в Microsoft Excel 97 и Microsoft Excel 2000, заменяются на соответствующие в Lotus 1-2-3; например, функция Excel СРЗНАЧА заменяется на функцию @AVG.

  • Не сохраняются операторы пересечения (пробел) и объединения (запятая).

  • Имена диапазонов сохраняются.

  • Ссылки на строки большие 8192 переносятся в начало листа; например, ссылка A8193 становится ссылкой A1 в файле WK3.

  • Трехмерные и внешние ссылки на другие листы и книги в формулах сохраняются.

  • Встроенные диаграммы сохраняются в отдельных листах диаграмм в форматах наиболее близких из доступных в Lotus 1-2-3. Градиентные заполнения, узоры и штриховки заменяются на наиболее подходящие цвета. Не сохраняются: линии тренда и планки погрешностей; заливки; объемные маркеры данных. Повернутые тексты вдоль осей и подписи данных становятся горизонтальными.

    Встроенные диаграммы сохраняются только в формате WK3, FM3 (1-2-3).

  • Данные, отображаемые в текущем представлении отчета сводной таблицы, сохраняются. Все остальные данные сводной таблицы утрачиваются.

  • В книгах, сохраненных в формате WK3 без связи с FM3 файлами, ширина столбцов и большинство средств числовых форматов сохраняются. Остальные форматы ячеек и текста утрачиваются. Шрифт заменяется на Courier размером 10 пунктов.

  • Установки диалогового окна Параметры страницы (меню Файл) и разрывы страниц, установленные вручную, утрачиваются.

  • Большинство числовых форматов сохраняется:
    • Отрицательные числа, представленные с помощью знака минуса (например, -1234), заключаются в круглые скобки.

    • Знак денежной единицы в финансовом формате из положения в левой части ячейки переходит в нормальное.

    • Специальные форматы, такие как телефонные номера и почтовые коды, не сохраняются.

    • Комбинированные форматы времени и даты (например, 12.9.2000 2:45) преобразовываются в формат, отображающий только дату.

    • Форматы с дробными частями секунд сохраняются в общем формате.

    • Дробные форматы (например, 13/64) преобразуются в десятичные дроби.

    • Обозначения месяцев первой буквой (например, "Я" для января) заменяются на соответствующий порядковый номер.

Чтобы получить сведения о преобразовании книг Microsoft Excel в формат Lotus 1-2-3, обратитесь к Microsoft Office 2000 Resource Kit, доступному на узле Web корпорации Майкрософт.


Формат Lotus 1-2-3 версии 3 (WK3, FM3)

При сохранении книг Microsoft Excel в формате Lotus 1-2-3 версии 3 (WK3, FM3) данные сохраняются в файле WK3, а сведения о свойствах в файле FM3. Если открыть файл WK3 в Microsoft Excel, сведения из файла FM3 переносятся автоматически.

Чтобы получить более подробные сведения о данных, сохраняемых в файлах типа WK3, нажмите кнопку [image] .

Чтобы получить сведения о свойствах документа, сохраняемых в файлах типа FM3, нажмите кнопку [image] .


Формат Lotus 1-2-3 версии 4 (WK4)

В формате Lotus 1-2-3 версии 4.0 (WK4) данные и сведения о свойствах сохраняются в одном файле.

Не сохраняются: тексты программ на Visual Basic, примечания к ячейкам, импортированные графические и рисованные объекты, встроенные объекты, сценарии, элементы управления формы, гиперссылки, условия, назначенные для данных ячейки, а также условное форматирование.

Чтобы получить сведения о преобразовании книг Microsoft Excel в формат Lotus 1-2-3, обратитесь к Microsoft Office 2000 Resource Kit, доступному на узле Web корпорации Майкрософт.

Данные, формулы и другие элементы листа

Текст, величины, формулы и другие элементы листа сохраняются следующим образом:

  • Количество листов зависит от объема доступной памяти. Названия листов могут составлять не более 15 символов.

  • На одном листе сохраняется до 8192 строк, не более 255 символов в ячейке.

  • Большинство формул сохраняется. Если в формуле есть функция, не поддерживаемая Lotus 1-2-3 версии 4, Microsoft Excel заменит эту функцию результатом вычислений.

  • Функции, доступные в Microsoft Excel 97 и Microsoft Excel 2000, заменяются на соответствующие в Lotus 1-2-3; например, функция Excel СРЗНАЧА заменяется на функцию @AVG.

  • Не сохраняются операторы пересечения (пробел) и объединения (запятая).

  • Имена диапазонов сохраняются.

  • Трехмерные и внешние ссылки на другие листы и книги в формулах сохраняются.

  • Встроенные диаграммы сохраняются в виде наиболее близких из доступных в Lotus 1-2-3 диаграмм. Градиентные заполнения, узоры и заливки преобразуются в наиболее близкие цвета. Не сохраняются: линии тренда и планки погрешности; штриховки; объемные маркеры данных. Повернутые тексты вдоль осей и подписи данных становятся горизонтальными.

  • Данные, отображаемые в текущем представлении отчета сводной таблицы, сохраняются. Все остальные данные сводной таблицы утрачиваются.

  • Разрывы страниц и почти все установки диалогового окна Параметры страницы (меню Файл) сохраняются.

  • Большинство числовых форматов сохраняется:
    • Отрицательные числа, представленные с помощью знака минуса (например, -1234), заключаются в круглые скобки.

    • Знак денежной единицы в финансовом формате из положения в левой части ячейки переходит в нормальное.

    • Специальные форматы, такие как телефонные номера и почтовые коды, не сохраняются.

    • Комбинированные форматы времени и даты (например, 12.9.2000 2:45) преобразовываются в формат, отображающий только дату.

    • Форматы с дробными частями секунд сохраняются в общем формате с двумя цифрами после запятой.

    • Дробные форматы (например, 13/64) преобразуются в десятичные дроби.

    • Обозначения месяцев первой буквой (например, "Я" для января) заменяются на соответствующий порядковый номер.

Возможности форматирования

Форматы Microsoft Excel сохраняются следующим образом:

  • Ширина столбцов и высота строк сохраняются.

  • Выделения полужирным шрифтом, курсивом и подчеркиванием сохраняются; подчеркивание по значению заменяется на обычное подчеркивание. Верхний, нижние индексы и перечеркивание не сохраняются. Если в тексте в ячейке используются разные стили, весь текст оформляется в стиле первого символа.

  • Шрифты, их размеры и цвета сохраняются.

  • Текст, отформатированный при установленном параметре автоподбор ширины на вкладке Выравнивание (меню Формат, команда Ячейки), возвращается в исходное (до установки параметра автоподбор ширины) положение.

  • Угол поворота текста сохраняется.

  • Выравнивание вправо, влево и по центру сохраняется.

  • Вертикальные выравнивания по центру, верхнему и нижнему краям сохраняются.

  • Отступы внутри ячеек удаляются, содержимое ячеек выравнивается влево.

  • Объединенные ячейки разъединяются. Содержимое перемещается в левую верхнюю ячейку.

  • Условное форматирование удаляется и ячейки форматируются общим стилем.

  • Фон листа не сохраняется.

  • Сохраняются все виды рамок, кроме диагональных и штрихованных. Цвета заливки и узоры заменяются на наиболее похожие из доступных в Lotus 1-2-3.


Новые возможности работы со списками и итоговыми данными

Поиск данных и сортировка списков являются наиболее частыми задачами при работе с Microsoft Excel. Теперь возможен еще более быстрый поиск необходимых данных и подсчет итоговых значений.

Автоматическое заполнение списка (Введено в версии 2000) Excel 2000 автоматически расширяет форматирование и формулы в списках, упрощая эту распространенную задачу.

Автофильтр (Улучшено в версиях 95 и 97) Автофильтр отображает строки данных из списка в соответствии с выбором, сделанным пользователем. В Microsoft Excel 95 используйте возможность «Первые 10» для поиска максимальных и минимальных значений в списке. В Microsoft Excel 97 и 2000 автофильтр отображает только фильтры, основанные на примененных фильтрах.

Автозаполнение (Введено в версии 95) При вводе текста в ячейку производится его сравнение с текстом других ячеек данного столбца и предлагается закончить ввод на основе уже введенного текста.


 Формат листов Microsoft Excel 2.x

Формат листов Microsoft Excel 2.x

В формате Excel 2.x можно сохранять данные только активного листа. Данные сохраняются в *.xls файле. Если лист содержит формулу с трехмерной ссылкой на другие листы книги, сохранение в формате версии 2.x будет невозможно.

Свойства и параметры книги

Свойство Microsoft Excel 2000 | В формате листа Microsoft Excel 2.x
65536 строк в листе | Строки после 16384 пропадают.
32767 символов в ячейке | Символы после 255 пропадают.
Модули Visual Basic для приложений (VBA) 97, листы модулей VBA | Не сохраняются.
Диалоговые листы, элементы управления диалоговым окном Формы Office | Не сохраняются.

Возможности форматирования и разметки

Свойство Microsoft Excel 2000 | В формате листа Microsoft Excel 2.x
Ячейки содержат текст в разных форматах | Весь текст принимает вид первого символа в ячейке.
Текст, отформатированный при установленном параметре автоподбор ширины на вкладке Выравнивание диалогового окна Ячейки (меню Формат) | Текст возвращается в исходное положение (бывшее до применения команды автоподбор ширины).
Виды выравнивания текста | Сохраняются выравнивание по центриру, влево, вправо. Остальные, включая вертикальное по центру, верхнему краю и формат с переносом слов, пропадают. Поворот текста на любой угол утрачивается.
Отступы в ячейках | Отступы в ячейках удаляются, и содержимое ячеек выравнивается влево.
Объединенные ячейки | Объединенные ячейки разъединяются. Содержимое помещается в левую верхнюю ячейку.
Условное форматирование | Условное форматирование снимается, и ячейки форматируются в общем стиле.
Фон листа | Не сохраняется.
Новые стили оформления рамок | Стили оформления рамок заменяются на наиболее близкие из доступных в Microsoft Excel 2.x. Диагональные рамки не сохраняются.
Выровненное подчеркивание нескольких шрифтов | Подчеркивание может быть не выровненным.

Диаграммы

В этом формате встроенные диаграммы не сохраняются. Чтобы сохранить диаграмму, перенесите ее в лист диаграмм, а затем сохраните его в формате Microsoft Excel 2.x. Сохранять можно только активный лист диаграммы.

Свойство Microsoft Excel 2000 | В формате диаграммы Microsoft Excel 2.x
Вторичная диаграмма в круговой диаграмме | Становится круговой диаграммой типа 1.
Пузырьковая диаграмма | Становится точечной диаграммой типа 1.
Диаграмма типа «Поверхность» | Становится гистограммой.
Трехмерная гистограмма с маркерами данных в виде геометрических объектов (цилиндр, пирамида, и конус) | Становится двумерной столбчатой диаграммой.
Комбинированные диаграммы | Все данные выводятся, используя единую ось значений, в основном типе диаграмм.
Линии тренда и планки погрешностей | Не сохраняются.
Таблицы данных в диаграммах | Не сохраняются.
Повернутые тексты вдоль оси и подписи | Становятся горизонтальными.
Градиентное заполнение и узор на элементах диаграммы | Сохраняются в виде наиболее близкого цвета или узора.
Ось времени (ось х в формате времени) | Специальные масштабирование теряется, ось принимает стандартный вид.
Затенение рядов и точек | Не сохраняется.
Масштабируемые маркеры на линейчатой и точечной диаграммах | Не сохраняются.
Особое расположение подписей данных | Надписи возвращаются в стандартное положение.
Отчеты сводных диаграмм | Отображаются как обычные диаграммы. Многоуровневые подписи категорий изменяются и цены делений оси значений преобразуются в литеральные значения

Анализа и доступ к данным сводных таблиц

Свойство Microsoft Excel 2000 | В формате листа Microsoft Excel 2.x
Отчеты сводных таблиц | Сохраняются только данные, отображенные в текущей структуре сводной таблицы.
Запросы Web (меню Данные, подменю Внешние данные) | Результат последнего запроса сохраняется; но сам запрос не сохраняется.
Общие запросы (соединение без имени источника данных) | Не сохраняются.
Запросы с параметрами | Не сохраняются.
Шаблоны отчетов | Средства создания отчета не сохраняются.
Текстовые ссылки в формулах | Ссылки к строкам и столбцам преобразуются в формат ссылки типа A1. Имена ячеек и диапазонов сохраняются.
Функции, не поддерживаемые Excel версии 2.x | Microsoft Excel пересчитывает функции перед сохранением файла и заменяет их результатом вычислений.
Сценарии | Не сохраняются.
Диапазоны внешних данных | Не сохраняются.
Отчеты, сводных таблиц и сводных диаграмм, построенные по данным OLAP | Доступны только для чтения.
Структурированные отчеты сводных таблиц | При редактировании в Excel 97 отчет переводится в неструктурированный формат, но форматирование ячеек и символов сохраняется.

Графика и объекты OLE

Свойство Microsoft Excel 2000 | В формате листа Microsoft Excel 2.x
Объекты OLE | Не сохраняются.
Карты и объекты организационной диаграммы | Не сохраняются.
Графические объекты и рисунки | Не сохраняются.

Средства для работы в группах и Internet

Свойство Microsoft Excel 2000 | В формате листа Microsoft Excel 2.x
Примечания | Сохраняются.
Гиперссылки | Не сохраняются.
Отслеживание изменений и стрелки зависимостей | Журнал изменений утрачивается.
Общие книги | Книги изымаются из общего использования, журнал изменений утрачивается.
Условия, назначенные для данных ячейки | Не сохраняются.

Возможности программирования

Свойство Microsoft Excel 2000 | В формате листа Microsoft Excel 2.x
Листы макросов Excel (*.xlm) | Тексты макросов и их функциональность сохраняются.
Макросы Visual Basic | Тексты программ на Visual Basic не сохраняются.
Элементы ActiveX | Не сохраняются.
Диалоговые листы и элементы управления диалоговым окном Формы Office | Не сохраняются.

Чтобы получить сведения о совместимости, обратитесь к Microsoft Office 2000 Resource Kit, доступному на узле Web корпорации Майкрософт.


 Формат книги Microsoft Excel 97-2000 & 5.0/95

Формат книги Microsoft Excel 97-2000 & 5.0/95

Сохранение книги в формате книги Microsoft Excel 97-2000 & 5.0/95 означает, что книга будет сохранена в одном файле, включающем форматы и Microsoft Excel 97 и Microsoft Excel 5.0/95. (Microsoft Excel версии 5.0 и Microsoft Excel 95 имеют единый формат, как и Excel 97, Excel 98 для Мамкинтош и Excel 2000.). Размер файла будет больше из-за использования обоих форматов.

Пользователи Microsoft Excel 2000 имеют возможность продолжать работу с книгой, сохраненнной в двойном формате без потери возможностей, характерных только для этой версии. При попытке открыть книгу в Microsoft Excel версии 5.0 или в Microsoft Excel 95 появится сообщение, рекомендующее использовать файл в режиме только для чтения. Однако если эту рекомендацию проигнорировать и сохранить книгу в более ранней версии Microsoft Excel, некоторые из свойств, характерных только для Excel 97 или Excel 2000, могут быть утрачены. См. сведения о том, какие возможности могут быть утеряны.

Чтобы избежать потерь такого рода, книга может быть защищена от изменений с помощью пароля или объявлена доступной только для чтения. См. сведения об установке пароля и о том, как объявить книгу файлом только для чтения.


Форматы Microsoft Excel, сохраняемые в файлах Lotus 1-2-3 формата FMT и FM3

При сохранении книги Microsoft Excel 2000 в файлах Lotus 1-2-3 форматов WK1,FMT (1-2-3) (*.wk1) или WK3,FM3 (1-2-3) (*.wk3) параметры форматирования содержатся в отдельных файлах *.fmt или *.fm3. Файлы форматирования используются надстройками WYSIWIG или Impress в Lotus 1-2-3 для форматирования листов.

Форматы Microsoft Excel сохраняются следующим образом:

  • Ширина столбцов и высота строк сохраняются.

  • В ячейках, содержащих символы с различным форматированием, весь текст получает формат первого символа в ячейке.

  • Выделение полужирным шрифтом, курсивом, подчеркиванием сохраняются; подчеркивание по значению заменяется на обычное подчеркивание. Верхний, нижний индексы и перечеркивание не сохраняются.

  • Шрифты TrueType заменяются на наиболее близкие из доступных принтерных шрифтов. Цвет шрифта заменяется на наиболее похожий из доступных в Lotus 1-2-3. Размеры шрифтов сохраняются.

  • Текст, отформатированный при установленном параметре автоподбор ширины на вкладке Выравнивание (меню Формат, команда Ячейки), возвращается в исходное (до установки параметра автоподбор ширины) положение.

  • Все повернутые и вертикальные тексты становятся горизонтальными.

  • Выравнивание вправо, влево и по центру сохраняется.

  • Вертикально текст выравнивается по нижнему краю.

  • Отступы внутри ячеек удаляются, содержимое ячеек выравнивается влево.

  • Объединенные ячейки разъединяются. Содержимое перемещается в левую верхнюю ячейку.

  • Условное форматирование удаляется и ячейки форматируются общим стилем.

  • Фон листа не сохраняется.

  • Рамки, заливки и узоры заменяются на наиболее похожие из доступных в Lotus 1-2-3, некоторые цветные штриховки и узоры могут быть заменены на черную штриховку. Цвет рамок заменяется на черный.


Функции Microsoft Excel, не имеющие эквивалентов в Lotus 1-2-3

Для перечисленных ниже функций Microsoft Excel не предусмотрено эквивалентов в Lotus 1-2-3 версии 3.1 или более ранних версиях, а также в Lotus 1-2-3 версии 1.0 для Windows. При сохранении книги в одном из таких форматов эти функции будут заменены на результаты их вычисления. Более подробные сведения о перечисленных ниже функциях можно получить, щелкнув мышью имя нужной функции Microsoft Excel.

Примечание. В список не включены многие функции надстроек Microsoft Excel, а также статистические функции, не имеющие эквивалентов в Lotus 1-2-3.

Функция Microsoft Excel
БДПРОИЗВЕД
ГИПЕРССЫЛКА
ДЕНЬНЕД
ЕЛОГИЧ
ЕОШИБКА
ЕПУСТО
ЛГРФПРИБЛ
ЛИНЕЙН
МВСД
МОБР
МОПРЕД
МУМНОЖ
ОБЛАСТИ
ОСНПЛАТ
ПЛПРОЦ
ПОДСТАВИТЬ
ПОИСК
ПОИСКПОЗ
ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ
ПРОИЗВЕД
ПРОСМОТР
РОСТ
РУБЛЬ
ТЕКСТ
ТЕНДЕНЦИЯ
ТИП
ТРАНСП
ФАКТР
ЦЕЛОЕ
ЧАСТОТА


 Новые возможности Microsoft Excel на Web

Новые возможности Microsoft Excel на Web

Мощь сети Интернет доступна теперь непосредственно из таблиц Microsoft Excel.

Web-запросы (улучшено в версии 2000). Существует возможность создания и выполнения запросов для загрузки данных, доступных через Интернет. Можно выбрать либо всю Web-страницу, либо указать загружаемую таблицу на Web-странице. Excel 2000 содержит несколько образцов Web-запросов, которые можно выполнить.

Создание документов для Web (введено в версии 2000). Excel 2000 обеспечивает быстрые и простые способы создания Web-страниц с использованием знакомых инструментов и возможностей. Теперь можно легко перемещать данные Excel на Web-сервер в виде интерактивных электронных таблиц и диаграмм. Если требуется добавить рисунки или текст либо переместить опубликованные или сохраненные элементы на Web-странице, можно открыть Web-страницу в другом приложении, например, Microsoft FrontPage 2000 или Microsoft Access, а затем отредактировать данные на Web-странице.

Использование интерактивных сводных таблиц для Web-страниц (введено в версии 2000). Отчет сводной таблицы можно сделать доступным на Web-странице в виде сводной таблицы, представляющей из себя компонент, позволяющий пользователям взаимодействовать с данными в Web-обозревателе. Пользователи также могут обновлять данные, изменять макет и выбирать различные элементы для отображения.

Настройка Web-страниц (введено в версии 2000). Существует возможность быстро изменить режим генерирования и форматирования Web-страниц в Microsoft Office 2000 с помощью диалогового окна Параметры Web-документа (меню Сервис, команда Параметры, вкладка Общие, кнопка Параметры Web-документа). Например, можно настроить параметры сохранения рисунков и других вспомогательных файлов, а также указать формат сохранения рисунков для использования на Web-страницах. Устанавливаемые параметры используются во всех приложениях Office, где это возможно.

Управление файлами и связями (введено в версии 2000). Приложения Office автоматически управляют сопутствующими файлами, такими как рисунки. При создании Web-страницы все вспомогательные файлы сохраняются в папке с тем же именем, что и у файла страницы. При сохранении файла в новом расположении Office 2000 проверяет ссылки и восстанавливает те, которые не работают.

Создание универсального внешнего вида (введено в версии 2000). При создании Web-страниц для международного использования Office 2000 сохраняет файлы с использованием соответствующей международной кодировки текста, чтобы пользователи любой локализованной системы могли видеть правильные символы.

Использование рисунков и объектов (введено в версии 2000). Office 2000 делает использование рисунков на Web-страницах легким. Графика для Web-страниц автоматически сохраняется в форматах GIF, JPEG или PNG, а также в формате VML (Vector Markup Language). Даже после сохранения файла в виде Web-страницы рисунки и объекты можно по-прежнему редактировать, открыв Web-страницу в одном из приложений Office. Office 2000 автоматически генерирует замещающий текст для рисунков на основе имен графических файлов.

Сохранение форматирования, специфичного для Office (введено в версии 2000). Во всех файлах Office допускается использование возможностей, которые не поддерживаются в Web, таких как цвета линий и спецэффекты для символов. При сохранении файла в виде Web-страницы вместе с ним сохраняются стандартные цвета и другие параметры форматирования, которые не поддерживаются в Web. При открытии файла в Web-обозревателе эти возможности не проявляются. Однако если вновь открыть файл Office в приложении Office, эти параметры форматирования можно будет по-прежнему видеть и редактировать.

Использование сценариев в Web-документах (введено в версии 2000). Office 2000 дает разработчикам возможность создавать сценарии и клиентские решения на основе HTML в любом приложении Office с помощью редактора сценариев. Этот редактор полностью поддерживает обозреватель для отладки, а также ссылки сценариев, которые можно использовать в файлах Office.

Управление Web-документами (введено в версии 2000). Для управления файлами, хранящимися на Web-сервере, а также для размещения данных Excel в Интернете можно использовать средство «Web-папки». Web-папки можно открыть в проводнике Windows или в любом приложении Office, а затем создавать с их помощью папки, просматривать свойства, а также перетаскивать файлы на любой Web-сервер, на доступ к которому имеются разрешения. (Это средство требует установки на Web-сервере серверных расширений Microsoft Office.)

Начало обсуждения (введено в версии 2000). При работе в Web-обозревателе или в любом из приложений Office вы и ваши коллеги можете просматривать любой тип документов Office. В нижней части окна документа можно закрепить панель обсуждений для добавления примечаний или обмена мнениями о документе, либо можно добавить свои замечания прямо в текст документа. (Это средство требует установки на Web-сервере серверных расширений Office.)

Подписка на документ (введено в версии 2000). Совместная работа стала еще легче благодаря средствам Web-подписки и уведомления. В Office 2000 автоматизирован процесс отправки электронной почты при обновлении документа. Пользователь может подписаться на документ или Web-страницу, а затем указать нужный режим уведомления об изменениях документа. Можно выбрать оповещение по электронной почте или добавить нужную страницу в качестве канала Microsoft Internet Explorer. (Это средство требует установки на Web-сервере серверных расширений Office.)

Проведение собраний по сети (введено в версии 2000). С помощью Microsoft NetMeeting можно совместно работать и обмениваться данными с пользователями из разных мест в режиме реального времени, как если бы все находились в одной комнате. Инициировать собрание по сети с помощью Интернета или интрасети организации можно из любого приложения Office или непосредственно из приложения NetMeeting. Для этого выберите в меню Windows Пуск команду Программы, Internet Explorer, а затем Microsoft NetMeeting. В NetMeeting можно использовать приложение «Доска», обмениваться сообщениями в окне приложения «Разговор» или пересылать файлы другим участникам. Кроме того, для назначения собраний по сети на будущее можно использовать Microsoft Outlook 2000.

Гиперссылки (введено в версии 97). Можно создавать гиперссылки для перехода к другим файлам Office на локальном компьютере, в сети, интрасети организации или в Интернете. Гиперссылка может иметь вид текста или рисунка; можно также написать формулу для создания гиперссылки.

Адреса URL в формулах (введено в версии 97). Адреса URL можно использовать в формулах, как и другие имена файлов и сетевые адреса.

Работа с файлами по адресам URL (введено в версии 97). Существует возможность открытия книг непосредственно с серверов HTTP или FTP.

Сохранение по адресам URL (введено в версии 97). Существует возможность сохранения книг на серверах FTP.

Панель инструментов Web (введено в версии 97). Эта панель инструментов облегчает просмотр файлов Microsoft Excel и Office, связанных гиперссылками. Эта панель инструментов может работать с Web-обозревателем и предоставляет дополнительные средства для доступа к начальной странице и странице поиска.


 Формат листа Microsoft Excel 3.0

Формат листа Microsoft Excel 3.0

При сохранении книги Microsoft Excel 2000 в формате Excel 3.0 в конечном файле листа Excel 3.0 (*.xls) сохраняется только активный лист. Листы, содержащие формулы с трехмерными ссылками на другие листы книги, сохранить в формате Excel 3.0 невозможно.

Свойства и параметры книги

Свойство Microsoft Excel 2000 | В формате листа Excel 3.0
65536 строк в листе | Строки после 16384 пропадают.
32767 символов в ячейке | Символы после 255 пропадают.
Модули Visual Basic для приложений (VBA) 97, листы модулей VBA | Не сохраняются.
Диалоговые листы, элементы управления диалоговым окном Формы Office | Не сохраняются.

Возможности форматирования и разметки

Свойство Microsoft Excel 2000 | В формате листа Excel 3.0
Ячейки содержат текст в разных форматах | Весь текст принимает вид первого символа в ячейке.
Текст, отформатированный при установленном параметре Автоподбор ширины на вкладке Выравнивание (меню Формат, команда Ячейки) | Текст возвращается в исходное положение (до применения параметра Автоподбор ширины).
Вращение текста | Текст, повернутый под углом, отличным от 90, -90 или 0 (нуль) градусов, принимает горизонтальную ориентацию.
Отступы в ячейках | Отступы в ячейках удаляются, и содержимое ячеек выравнивается по левому краю.
Объединенные ячейки | Объединенные ячейки разъединяются. Содержимое помещается в левую верхнюю ячейку.
Условное форматирование | Условное форматирование снимается, и ячейки форматируются в общем стиле.
Фон листа | Не сохраняется.
Новые стили оформления рамок | Стили оформления заменяются на наиболее похожие из доступных в Excel 3.0.
Выровненное подчеркивание нескольких шрифтов | Подчеркивание может быть не выровненным.

Диаграммы

В файле листа Excel версии 3.0 (.xls) сохраняются внедренные диаграммы с активного листа. Для того чтобы сохранить лист диаграммы, сохраните этот лист в формате диаграммы Excel 3.0. Сохраняется только активный лист диаграммы.

Свойство Microsoft Excel 2000 | В формате диаграммы Microsoft Excel 3.0
Вторичная диаграмма в круговой диаграмме | Становится круговой диаграммой типа 1.
Пузырьковая диаграмма | Становится точечной диаграммой типа 1.
Диаграмма «Поверхность» | Становится трехмерной гистограммой.
Трехмерная гистограмма с маркерами данных в виде геометрических объектов (цилиндр, пирамида, и конус) | Становится трехмерной гистограммой.
Комбинированные диаграммы | Все данные выводятся, используя единую ось значений, в основном типе диаграмм.
Линии тренда и планки погрешностей | Не сохраняются.
Таблицы данных в диаграммах | Не сохраняются.
Повернутый текст в подписях оси и данных | Сохраняется как горизонтальный текст.
Градиентное заполнение и узор на элементах диаграммы | Сохраняются в виде наиболее близкого цвета или узора.
Ось времени (ось х в формате времени) | Специальные масштабирование теряется, ось принимает стандартный вид.
Затенение рядов и точек | Не сохраняются.
Масштабируемые маркеры на линейчатой и точечной диаграммах | Не сохраняются.
Особое расположение подписей данных | Надписи возвращаются в стандартное положение.
Отчеты сводных диаграмм | Отображаются как обычные диаграммы. Многоуровневые подписи категорий изменяются и цена деления оси значений преобразуются в литеральные значения

Свойства анализа и обработки сводных таблиц и баз данных

Свойство Microsoft Excel 2000 | В формате листа Excel 3.0
Отчеты сводных таблиц | Сохраняются только данные, отображенные в текущей структуре сводной таблицы.
Web-запросы (меню Данные, подменю Внешние данные) | Результат последнего запроса сохраняется; но сам запрос не сохраняется.
Общие запросы (соединение без имени источника данных) | Не сохраняются.
Запросы с параметрами | Выполнение или редактирование невозможно.
Шаблоны отчетов | Средства создания отчета не сохраняются.
Текстовые ссылки в формулах | Ссылки к строкам и столбцам преобразуются в формат ссылки типа A1. Имена ячеек и диапазонов сохраняются.
Функции, не поддерживаемые в Excel 3.0 | Microsoft Excel пересчитывает функции перед сохранением файла и заменяет их результатом вычислений.
Сценарии | Не сохраняются.
Диапазоны внешних данных | Не сохраняются.
Отчеты, сводных таблиц и сводных диаграмм, построенные по данным OLAP | Доступны только для чтения.
Структурированные отчеты сводных таблиц | При редактировании в Excel 97 отчет переводится в неструктурированный формат, но форматирование ячеек и символов сохраняется.

Графика и объекты OLE

Свойство Microsoft Excel 2000 | В формате листа Excel 3.0
Объекты OLE | Не сохраняются.
Объекты MS Map | Не сохраняются.
Объекты WordArt | Не сохраняются.
Рисунки, обработанные командой Автоформа | Преобразуются в наиболее похожие из доступных в Excel 4.0; трехмерные объекты преобразуются в двумерные.
Структурные схемы | Не сохраняются.
Отсканированные фотослайды | Сохраняются только слайды в формате метафайл.

Возможности для рабочих групп и Интернета

Свойство Microsoft Excel 2000 | В формате листа Excel 3.0
Примечания | Сохраняются как примечания к ячейкам.
Гиперссылки | Не сохраняются.
Отслеживание изменений и стрелки зависимостей | Журнал изменений утрачивается.
Общие книги | Книги изымаются из общего использования, журнал изменений утрачивается.
Условия, назначенные для данных ячейки | Не сохраняются.

Возможности программирования

Свойство Microsoft Excel 2000 | В формате листа Excel 3.0
Листы макросов Excel (*.xlm) | Тексты макросов и их функциональность сохраняются.
Макросы Visual Basic | Тексты программ на Visual Basic не сохраняются.
Элементы ActiveX | Не сохраняются.
Диалоговые листы и элементы управления диалоговым окном Формы Office | Не сохраняются.

Дополнительные сведения о совместимости см. в издании Ресурсы Microsoft Office 2000, доступном на Web-узле корпорации Майкрософт.


 Формат книги Microsoft Excel 4.0

Формат книги Microsoft Excel 4.0

При сохранении книги Microsoft Excel 2000 в формате книги Excel 4.0 все листы этой книги сохраняются скрепленными в конечном файле книги Excel 4.0 (.xlw). Однако пользователи Excel 4.0 на компьютерах с операционной системой Microsoft Windows версии 3.1 могут не иметь возможности открывать книги, содержащие более 25 листов.

Свойства и параметры книги

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 4.0
65536 строк в листе | Строки после 16384 пропадают.
32767 символов в ячейке | Символы после 255 пропадают.
Модули Visual Basic для приложений (VBA) 97, листы модулей VBA | Не сохраняются.
Диалоговые листы, элементы управления диалоговым окном Формы Office | Не сохраняются.

Форматирование и оформление

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 4.0
Частичные разрывы страниц | Сохраняются как стандартные разрывы страниц.
Ячейки содержат текст в разных форматах | Весь текст принимает вид первого символа в ячейке.
Текст, отформатированный при установленном параметре Автоподбор ширины на вкладке Выравнивание (меню Формат, команда Ячейки) | Текст возвращается в исходное положение (до применения параметра Автоподбор ширины).
Вращение текста | Текст, повернутый под углом, отличным от 90, -90 или 0 (нуль) градусов, принимает горизонтальную ориентацию.
Отступы в ячейках | Отступы в ячейках удаляются, и содержимое ячеек выравнивается по левому краю.
Объединенные ячейки | Объединенные ячейки разъединяются. Содержимое помещается в левую верхнюю ячейку.
Условное форматирование | Условное форматирование снимается, и ячейки форматируются в общем стиле.
Фон листа | Не сохраняется.
Новые стили оформления рамок | Стили оформления заменяются на наиболее похожие из доступных в Excel 4.0.
Выровненное подчеркивание нескольких шрифтов | Подчеркивание может быть не выровненным.

Диаграммы

Встроенные диаграммы сохраняются в скрепленных листах. Листы диаграмм сохраняются в скрепленных листах диаграмм. Чтобы сохранить только активный лист диаграмм, выберите формат диаграмм Excel 4.0.

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 4.0
Вторичная диаграмма в круговой диаграмме | Становится круговой диаграммой типа 1.
Пузырьковая диаграмма | Становится точечной диаграммой типа 1.
Трехмерная гистограмма с маркерами данных в виде геометрических объектов (цилиндр, пирамида, и конус) | Становятся объемными гистограммами (прямоугольные фигуры).
Комбинированные диаграммы | Все данные выводятся, используя единую ось значений, в основном типе диаграмм.
Линии тренда и планки погрешностей | Не сохраняются.
Таблицы данных в диаграммах | Не сохраняются.
Повернутый текст в подписях оси и данных | Сохраняется как горизонтальный текст.
Градиентное заполнение и узор на элементах диаграммы | Сохраняются в виде наиболее близкого цвета или узора.
Заливка поверхности диаграммы | Не сохраняются.
Ось времени (ось х в формате времени) | Специальные масштабирование теряется, ось принимает стандартный вид.
Затенение рядов и точек | Не сохраняются.
Масштабируемые маркеры на линейчатой и точечной диаграммах | Не сохраняются.
Особое расположение подписей данных | Надписи возвращаются в стандартное положение.
Отчеты сводных диаграмм | Отображаются как обычные диаграммы. Многоуровневые подписи категорий изменяются и цена деления оси значений преобразуются в литеральные значения

Свойства анализа и обработки сводных таблиц и баз данных

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 4.0
Формулы, содержащие трехмерные ссылки | Величина формулы сохраняется, но сама формула заменяется значением ошибки #Н/Д).
Отчеты сводных таблиц | Сохраняются только данные, отображенные в текущей структуре сводной таблицы.
Web-запросы (меню Данные, подменю Внешние данные) | Результат последнего запроса сохраняется; но сам запрос не сохраняется.
Запросы с параметрами | Выполнение или редактирование невозможно.
Шаблоны отчетов | Средства создания отчета не сохраняются.
Общие запросы (соединение без имени источника данных) | Не сохраняются.
Текстовые ссылки в формулах | Ссылки к строкам и столбцам преобразуются в формат ссылки типа A1. Имена ячеек и диапазонов сохраняются.
Определительные надписи | Не сохраняются.
Функции, не поддерживаемые в Excel 4.0 | Microsoft Excel пересчитывает функции перед сохранением файла и заменяет их результатом вычислений.
Диапазоны внешних данных | Не сохраняются.
Отчеты, сводных таблиц и сводных диаграмм, построенные по данным OLAP | Доступны только для чтения.
Структурированные отчеты сводных таблиц | При редактировании в Excel 97 отчет переводится в неструктурированный формат, но форматирование ячеек и символов сохраняется.

Графика и объекты OLE

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 4.0
Объекты OLE | Не сохраняются.
Объекты MS Map | Не сохраняются.
Объекты WordArt | Не сохраняются.
Рисунки, обработанные командой Автоформа | Преобразуются в наиболее похожие из доступных в Excel 4.0; трехмерные объекты преобразуются в двумерные.
Структурные схемы | Не сохраняются.
Отсканированные фотослайды | Сохраняются только слайды в формате метафайл.

Возможности для рабочих групп и Интернета

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 4.0
Примечания | Сохраняются как примечания к ячейкам.
Гиперссылки | Не сохраняются.
Отслеживание изменений и стрелки зависимостей | Журнал изменений утрачивается.
Общие книги | Книги изымаются из общего использования, журнал изменений утрачивается.
Условия, назначенные для данных ячейки | Не сохраняются.

Возможности программирования

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 4.0
Листы макросов Excel (*.xlm) | Тексты макросов и их функциональность сохраняются.
Макросы Visual Basic | Тексты программ на Visual Basic не сохраняются.
Элементы ActiveX | Не сохраняются.
Диалоговые листы и элементы управления диалоговым окном Формы Office | Не сохраняются.

Дополнительные сведения о совместимости см. в издании Ресурсы Microsoft Office 2000, доступном на Web-узле корпорации Майкрософт.


Формат Microsoft Excel 4.0

При сохранении книги Microsoft Excel 2000 в формате «Файл Excel 4.0» в конечном файле *.xls сохраняется только активный лист. Листы, содержащие формулы с трехмерными ссылками на другие листы книги, сохранить в формате Excel 4.0 невозможно.

Для получения сведений о возможностях Excel 2000, не сохраняемых в формате Excel 4.0, нажмите кнопку [image] .


Открытие и сохранение книги Excel 2000 в Excel 97

Перечисленные ниже свойства Microsoft Excel 2000 утрачиваются при открытии и сохранении книги Excel 2000 в Excel 97

Свойство Microsoft Excel 2000 | В Excel 97
Отчеты, сводных таблиц и сводных диаграмм, построенные по данным OLAP | Доступны только для чтения.
Диапазоны внешних данных | Автоматическое обновление, форматирование столбцов, фильтрация и сортировка не работают.
Структурированные отчеты сводных таблиц | При редактировании в Excel 97 или более ранней версии отчет переводится в неструктурированный формат, но форматирование ячеек и символов сохраняется.
Отчеты сводных диаграмм | Отображаются как обычные диаграммы. Многоуровневые подписи категорий изменяются и цена деления оси значений преобразуются в литеральные значения
Всплывающие подсказки для гиперссылок | Не сохраняются.


 Формат книги Microsoft Excel 5.0/95

Формат книги Microsoft Excel 5.0/95

Перечисленные ниже свойства Excel 2000 утрачиваются при сохранении книги в формате книги Excel 5.0/95 (*.xls).

Свойства и параметры книги

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 5.0/95
65536 строк в листе | Строки после 16384 пропадают.
32767 символов в ячейке | Символы после 255 пропадают.
Виды | Не сохраняются.
Присоединенные панели инструментов | Не сохраняются.

Возможности форматирования

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 5.0/95
Текст, отформатированный при установленном параметре Автоподбор ширины на вкладке Выравнивание (меню Формат, команда Ячейки) | Текст возвращается в исходное положение (до применения параметра Автоподбор ширины).
Вращение текста | Текст, повернутый под углом, отличным от 90, -90 или 0 (нуль) градусов, принимает горизонтальную ориентацию.
Отступы в ячейках | Отступы в ячейках удаляются, и содержимое ячеек выравнивается по левому краю.
Объединенные ячейки | Объединенные ячейки разъединяются. Содержимое помещается в левую верхнюю ячейку.
Условное форматирование | Условное форматирование снимается, и ячейки форматируются в общем стиле.
Фон листа | Не сохраняется.
Новые стили оформления рамок | Оформление рамок заменяется на наиболее похожие из доступных в Excel 5.0 или Excel 95.
Выровненное подчеркивание нескольких шрифтов | Подчеркивание может быть не выровненным.

Диаграммы

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 5.0/95
Вторичная диаграмма в круговой диаграмме | Становится круговой диаграммой типа 1.
Пузырьковая диаграмма | Становится точечной диаграммой типа 1.
Трехмерная гистограмма с маркерами данных в виде геометрических объектов (цилиндр, пирамида, и конус) | Становятся объемными гистограммами (прямоугольные фигуры).
Таблицы данных в диаграммах | Не сохраняются.
Повернутый текст в подписях оси и данных | Сохраняется как горизонтальный текст.
Градиентное заполнение и узор на элементах диаграммы | Сохраняются в виде наиболее близкого цвета или узора.
Заливка поверхности диаграммы | Не сохраняются.
Ось времени (ось х в формате времени) | Специальные масштабирование теряется, ось принимает стандартный вид.
Затенение рядов и точек | Не сохраняются.
Масштабируемые маркеры на линейчатой и точечной диаграммах | Не сохраняются.
Особое расположение подписей данных | Подписи переводятся в стандартное положение.
Отчеты сводных диаграмм | Отображаются как обычные диаграммы. Многоуровневые подписи категорий изменяются и цена деления оси значений преобразуются в литеральные значения

Свойства анализа и обработки сводных таблиц и баз данных

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 5.0/95
Текстовые ссылки в формулах | Ссылки к строкам и столбцам преобразуются в формат ссылки типа A1. Имена ячеек и диапазонов сохраняются.
Новые функции, не поддерживаемые Excel 95 или 5.0 (СРЗНАЧА; МАКСА; МИНА; СТАНДОТКЛОНА; СТАНДОТКЛОНПА; ДИСПА; ДИСПРА; ГИПЕРССЫЛКА; ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ) | Excel пересчитывает функции до сохранения и заменяет формулы результирующей величиной. Функция ГИПЕРССЫЛКА заменяется величиной =#Н/Д.
Вычисляемые поля, вычисляемые элементы и форматирование, основанное на таблицах структурированных данных | Эти свойства сохраняются до изменения или обновления данных сводной таблицы, после чего утрачиваются.
Сохраненное форматирование в отчетах сводных таблиц | Форматирование сохраняется, но структура утрачивается при изменении или обновлении данных сводных таблиц
Возможности сводных таблиц Все новые свойства теряются, включая:
  • расположение поля страницы, пересекающее столбцы и лежащее ниже строк;

  • сообщения об ошибке #Н/Д и отображение ячеек погрешности;

  • поля страницы, данные о которых хранятся на сервере;

  • автосортировка и Автовыбор в полях;

  • множественные выделения в поле страницы;

  • динамическая группировка и сортировка;

  • замена номерами полей данных.
Web-запросы и запросы к внешним источникам | Результат последнего запроса сохраняется; но сам запрос не сохраняется.
Запросы с параметрами | Выполнение или редактирование невозможно.
Общие запросы (соединение без имени источника данных) | Поддерживается в Excel 95 (с ODBC 2.0). В Excel 5.0 (с ODBC 1.0) выводится приглашение на ввод сведений о подключении.
Шаблоны отчетов | Не сохраняются.
Структурированные отчеты сводных таблиц | При редактировании в Excel 97 или более ранней версии отчет переводится в неструктурированный формат, но форматирование ячеек и символов сохраняется.
Отчеты сводных таблиц и сводных диаграмм, построенные по данным OLAP | Доступны только для чтения.
Диапазоны внешних данных | Не сохраняются.

Графика и объекты OLE

Если формат книги Excel 5.0/95 используется по умолчанию, а в книгу вставлен объект OLE, содержащий свойства Excel 2000, эти свойства не будут сохранены при открытии и последующем сохранении книги в Excel 5.0 или Excel 95. Однако, если открыть книгу в Excel 2000, вставить объект книги, содержащий свойства Excel 2000, а затем сохранить ее, свойства Excel 2000 для объекта OLE будут сохранены.

Например, можно открыть в Excel 5.0 или Excel 95 книгу, сохраненную в формате Excel 5.0/95. Однако, если вставить в книгу объект, содержащий свойства, уникальные для Excel 2000 — например, объединенные ячейки или пузырьковую диаграмму — а затем сохранить ее, эти свойства будут утрачены.

Дополнительные сведения о см. в издании Ресурсы Microsoft Office 2000, доступном на Web-узле корпорации Майкрософт.

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 5.0/95
Объекты WordArt | Сохраняются в виде заполненных прямоугольников.
Рисунки, обработанные командой Автоформа | Преобразуются в рисованные объекты Microsoft Excel 5.0/95; трехмерные формы становятся двумерными.
Отсканированные фотослайды | Сохраняются только форматы, доступные в Excel 95 или Excel 5.0.

Возможности для рабочих групп и Интернета

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 5.0/95
Примечания | Сохраняются как примечания к ячейкам.
Гиперссылки | Не сохраняются.
Отслеживание изменений и стрелки зависимостей | Журнал изменений утрачивается.
Общие книги | Книги изымаются из общего использования, журнал изменений утрачивается.
Условия, назначенные для данных ячейки | Не сохраняются.

Возможности программирования

Модули Visual Basic преобразуются в листы модулей. Весь текст в модуле сохраняется; однако в формате Excel 5.0/95 поддерживаются не все новые объекты, методы и свойства Excel 2000. В некоторых случаях для выполнения макросов необходимо отредактировать преобразованный код. Листы макросов Excel (.xlm) сохраняются без потерь.

Дополнительные сведения о совместимости см. в издании Ресурсы Microsoft Office 2000, доступном на Web-узле корпорации Майкрософт.

Свойство Microsoft Excel 2000 | В формате книги Microsoft Excel 5.0/95
Элементы ActiveX | Отображаются, но не могут быть использованы.
Элементы управления диалоговым окном Формы Office | Не поддерживаются.


Новые возможности извлечения данных из внешних баз данных

Для анализа данных, находящихся вне Microsoft Excel, нет нужды вручную вводить их в книги Microsoft Excel. Внешние данные могут быть легко вставлены в таблицы Microsoft Excel с помощью нескольких нажатий клавиш.

Web-запросы (улучшено в версии 2000). Существует возможность создания и выполнения запросов для загрузки данных, доступных через Интернет. Можно выбрать либо всю Web-страницу, либо указать загружаемую таблицу на Web-странице. Excel 2000 содержит несколько образцов Web-запросов, которые можно выполнить.

Обновление импортированного текста (улучшено в версии 2000). Данные из текстовых файлов теперь можно перенести в Excel тем же способом, который используется для создания других запросов к базам данных. При открытии такого файла как обновляемого форматирование и формулы сохраняются.

Доступ к внешним базам данных с помощью Microsoft Query (улучшено в версии 97). Взаимодействие с Microsoft Query было улучшено и надстройка Xlquery.xla больше не требуется (она поставляется для обеспечения совместимости с запросами и макросами старых версий).

Мастер запросов (введено в версии 97). Этот мастер облегчает поэтапную настройку источников данных, подключение к базам данных, выбор и упорядочивание полей, сортировку и фильтрацию данных.

Совместное использование запросов (введено в версии 97). Запросы можно распространять среди других пользователей Microsoft Excel, что освобождает их от необходимости самостоятельно настраивать доступ к данным при запуске запросов.

Шаблоны запросов (введено в версии 97). Лист с запросом может быть сохранен в качестве шаблона, без сохранения копии извлеченных данных. Данные при этом будут извлекаться в момент открытия такого шаблона с запросом на ввод пароля, если это требуется. С помощью шаблонов отчетов можно совместно использовать файлы запросов, которые будут иметь меньший объем и обеспечивать большую безопасность.

Запросы с параметрами (введено в версии 97). Существует возможность создания запросов, выводящих при запуске приглашение на ввод параметров, что позволяет создавать более гибкие запросы и работать с большими базами данных. Например, вместо загрузки данных по каждому товару в базе данных можно использовать название товара в качестве параметра, чтобы загрузить данные только по интересующему товару.

Фоновые запросы (введено в версии 97). Теперь запросы выполняются в фоновом режиме, что позволяет продолжать работу в Microsoft Excel во время загрузки данных. Кроме того, состояние запроса во время его выполнения в фоновом режиме можно проверить.

Автоматическая настройка обновления (введено в версии 97). При обновлении на листе данных, загруженных при выполнении запроса, можно расширить или сократить диапазон внешних данных, чтобы данные в строках и столбцах, расположенных ниже и правее этого диапазона не затрагивались. При наличии формул, работающих с внешними данными, формулы могут быть автоматически удалены или скопированы в соответствии с изменением диапазона.

Прямое редактирование данных (введено в версии 97). Вместо использования Microsoft Query можно работать непосредственно в базе данных для создания новых таблиц, сохранения результатов запросов в виде таблиц, добавления индексов в таблицы, а также добавления, копирования или перемещения записей.

AccessLinks (введено в версии 95). Существует возможность создания форм и отчетов Microsoft Access на основе листов Excel, а также переноса данных с листов Microsoft Excel в Microsoft Access с помощью команды Перенести в MS Access.


Формат Quattro Pro для DOS (WQ1)

В формате WQ1 (Quattro Pro для DOS) сохраняются данные только активных листов.

  • Microsoft Excel сохраняет строки только с 1 по 8192; в ячейке сохраняется до 240 символов.

  • Если функция Microsoft Excel не поддерживается форматом Quattro Pro, она будет пересчитана и заменена результирующей величиной до сохранения.

  • Шрифт заменяется на Courier размером 12 пунктов; все остальное форматирование текста, например, полужирное или курсивное начертание, утрачивается.

  • Ширина столбцов не меняется, но объединения ячеек, вращение текста и другие параметры форматирования ячеек утрачиваются.

  • Большинство форматов чисел сохраняется.

  • Рамки заменяются наиболее похожими из доступных в Quattro Pro. Заливка ячеек и цветные линии рамок не поддерживаются.

  • Настройки диалогового окна Параметры страницы (меню Файл) и принудительные разрывы страниц утрачиваются.

  • Примечания ячеек, рисунки, внедренные диаграммы, объекты, элементы управления форм, гиперссылки, параметры проверки данных, условное форматирование и другие свойства листа утрачиваются.

  • Данные, отображаемые в текущем представлении отчета сводной таблицы, сохраняются. Все остальные данные сводной таблицы утрачиваются.

  • Текст программ на языке Visual Basic для приложений утрачивается.


 Правила использования имен сводных таблиц и диаграмм в формулах

Правила использования имен сводных таблиц и диаграмм в формулах

Разрешены все исходные поля. В формулах, обрабатывающих данные поля, можно ссылаться на любые поля, содержащиеся в исходных данных отчета сводной таблицы, включая поля на панели инструментов сводной таблицы, которые не перемещены в какую-либо область.

Разрешено ссылаться на несколько полей и элементов. В формулах вычисляемых полей допустимо ссылаться на несколько имен полей. В формулах вычисляемых элементов можно использовать только элементы поля, в котором эти элементы создаются или вычисляются.

Порядок полей в именах. Имена полей в имени можно располагать в любом порядке. В следующем примере два имени полей (ячейки C3:E3) можно указать любым из двух способов: либо 'Новиков Мясо', либо 'Мясо Новиков'.

Отчет сводной таблицы с двумя именами полей.

Имена, содержащие пробелы, числа или знаки. Если в имя содержит несколько слов, числа или знаки, заключите его в апострофы.

Итоги. В формулах нельзя ссылаться на итоги, например, «Общие итоги», «Итоги: Мясо».

Имена полей в ссылках на элементы. В ссылку на элемент можно включить имя поля, заключив имя элемента в прямоугольные скобки, например Товар[Мясо]. Такой формат позволяет избежать ошибки «#ИМЯ?» в случае, если два элемента в различных полях имеют одно и то же имя. Например, если в отчете содержатся два элемента «Мясо», один — в поле «Товар», другой — в поле «Категория», то на эти элементы следует ссылаться следующим образом: Товар[Мясо], Категория[Мясо].

Ссылка с указанием положения элемента. На элемент можно сослаться, указав его текущее положение в отчете. Например, Товар[1] — это элемент «Мясо», Товар[2] — это элемент «Морепродукты». Скрытые элементы не нумеруются таким образом.

Ссылка на элемент с указанием его относительного положения. Для ссылки на элемент достаточно указать его относительное положение, которое определяется относительно вычисляемого элемента, содержащего формулу со ссылкой. Если «Кв.3» является текущим кварталом, то ссылке «Кварталы[-1]» соответствует квартал «Кв.2». Если текущим кварталом является «Кв.2», то ссылке «Кварталы[+1]» соответствует квартал «Кв.3». Например, для вычисляемого элемента можно ввести формулу «'Продавец'[-1] * 3%». Если относительная ссылка укажет на элемент, предшествующий первому, либо на элемент, следующий за последним элементом, то появится сообщение об ошибке «#ССЫЛКА!». См. сведения об отключении отображения ошибок.

Ссылка на положение отключает дополнительные параметры. Если в вычисляемом элементе содержится ссылка на элемент с указанием его положения, то в разделах Параметры отображения и Параметры сортировки диалогового окна Дополнительные параметры поля сводной таблицы устанавливаются флажки вручную. Другие флажки становятся недоступными.


Различия в вычислениях формул в Microsoft Excel и Lotus 1-2-3

Предусмотрена возможность вычислений по правилам Lotus 1-2-3

Excel вычисляет формулы и условия баз данных иначе, чем Lotus 1-2-3. Для вычисления по правилам Lotus 1-2-3, на вкладке Переход (меню Сервис, команда Параметры) установите флажок Производить вычисления по правилам Lotus 1-2-3.

Отличие правил вычислений в Excel от Lotus 1-2-3

Текст в вычислениях. В Lotus 1-2-3 содержащийся в ячейке текст считается нулем (0), если эта ячейка используется в формуле. В математических выражениях Excel, таких как сложение и вычитание, нельзя комбинировать текст и числа. Функции Excel считают ячейки, содержащие текст, нулями.

Например, если ячейка A10 содержит текст, а ячейка B10 — число 100, и флажок Производить вычисления по правилам Lotus 1-2-3 снят, то при попытке вычисления по формуле =A10+B10 появится сообщение об ошибке «#ЗНАЧ!». Однгако формула «=СУММ(A10,B10)» выполнит вычисление без ошибок и получит результат 100. См. сведения о математических операторах в Lotus 1-2-3 и Microsoft Excel.

Логические значения ИСТИНА и ЛОЖЬ. В Lotus 1-2-3 логическое выражение может принять значение либо 0 (ноль), либо 1. Такое же значение — либо 0, либо 1 — отображается в ячейке с этим значением. В Excel предусмотрена возможность выполнять вычисления с использованием значений, принятых в Lotus 1-2-3, но логическое значение отображается в ячейке Excel как ИСТИНА или ЛОЖЬ (значение ИСТИНА равно 1, значение ЛОЖЬ равно 0). Например, логическое выражение 2<3 отобразится в ячейке Lotus 1-2-3 как 1, а в Excel — ИСТИНА.

Если установлен флажок Производить вычисления по правилам Lotus 1-2-3, значение ЛОЖЬ будет отображаться в ячейке Excel как 0, а значение ИСТИНА — как 1.

Условия для поиска данных в базе данных. Диапазоны условий для поиска и извлечения данных, для использовании функций базы данных воспринимаются по-разному в зависимости от заданных параметров. Например, при поиске с условием «Джон» будут найдены только те строки, в которых значение «Джон» занимает всю ячейку. Если снять флажок Производить вычисления по правилам Lotus 1-2-3, то будут найдены все строки, в ячейках которых значения начинаются с текста «Джон» — «Джон», «Джонсон», «Джонсен». См. сведения о вводе диапазонов условий в Excel.

Отличие функций Excel от функций Lotus 1-2-3

Отличающиеся функции. Некоторые функции вычисляются по-разному в Lotus 1-2-3 и Excel, в том числе функции @ОСТАТ, @ВПР, @ГПР. Например, функция @ВПР в Lotus 1-2-3 ищет точное соответствие в первом столбце, а в Excel эта функция считает первый столбец отсортированным, и поэтому ищет в нем ближайшее значение, не превышающее искомого значения.

В Excel функции ВПР и ГПР содержат четвертый аргумент «диапазон_просмотра», позволяющий найти точно соответствующее значение. Если для этого аргумента установить значение ЛОЖЬ, то Excel найдет точно соответствующее значение.

Совместимые функции. Excel 2000 содержит функции, предназначенные для совместимости с Lotus 1-2-3 версии 4.0 и более поздних. Функции «А» — СРЗНАЧА, МАКСА, МИНА, СТАНДОТКЛОНА, СТАНДОТКЛОНПА, ДИСПА и ДИСПРА — используют при вычислении все ячейки диапазона, включая пустые, ячейки с текстом и ячейки с логическими значениями ИСТИНА и ЛОЖЬ.

См. сведения о функциях Lotus 1-2-3 и их эквивалентах в Microsoft Excel.


Новые возможности обеспечения безопасности

Цифровая подпись макроса (новая возможность в Office 2000). Разработчики имеют возможность подписывать свои макросы, созданные с помощью Visual Basic for Applications (VBA), что позволяет пользователям установить автора макроса, удостовериться в надежности макроса и отсутствии в нем вирусов. Microsoft Office 2000 распознает макросы, полученные из надежных источников, и не выдает на экран предупреждающего сообщения, если такой макрос не был изменен.

Проверка на вирусы (новая возможность в Office 97). В Microsoft Excel предусмотрена возможность отображения предупреждающего сообщения при открытии книги, содержащие макросы, которые могут содержать вирусы. Такие макросы можно отключить и открыть книгу без них.

Защита общих книг и журналов их изменений (новая возможность в Office 97). Общую книгу можно защитить таким образом, что другие пользователи не смогут сделать ее недоступной для совместного пользования, и не смогут отключить запись изменений в журнале. Это гарантирует запись всех изменений.


Новые возможности совместного использования книг, отображения изменений и журналов изменений

Совместная работа стала более удобной, теперь члены рабочей группы могут одновременно редактировать одну и ту же книгу. С применением отображения вносимых другими пользователями изменений, записью изменений в журнал и добавлением комментариев, понимание результатов работы других пользователей становится совсем легким.

Общие книги (новая возможность в Excel 95, улучшена в Excel 97). В Microsoft Excel 95 появились ограниченные средства работы нескольких пользователей с одной книгой. Теперь эти средства улучшены. Они позволяют в общей книге создавать и изменять формулы, изменять форматирование и даже добавлять листы.

Установка периода обновления общих книг (новая возможность в Excel 97). Есть возможность получать изменения, сделанные в общей книге другими пользователи, через заданные промежутки времени. Можно также задать сохранение в общей книге собственных изменений с таким же периодом.

Установка собственных параметров просмотра общей книги (новая возможность в Excel 97). После фильтрации данных в общей книге и установки параметров печати, эти параметры сохраняются независимо от параметров, заданных другими пользователями. Общая книга открывается с заданными вами параметрами.

Обработка несовместимых изменений (новая возможность в Excel 97). Сведения о разрешении конфликтов между изменениями, внесенными в общую книгу разными пользователями, содержатся в журнале изменений (лист «Конфликты» в Microsoft Excel 95). Предусмотрена также возможность поиска отмененных изменений в журнале изменений книги.

Изменение выделения изменений (новая возможность в Excel 97). Есть возможность помечать исправления, вносимые в общую книгу вами или другими пользователями. Можно также пометить изменения, выполненные с заданного момента времени, либо в заданной области листа. Изменения помечаются цветом, выбранным пользователем. При задержке указателя мыши на выделенной ячейке отображаются сведения: время, тип и автор изменений.

Принятие исправлений и отказ от исправлений (новая возможность в Excel 97). Есть возможность шаг за шагом просмотреть внесенные в общую книгу исправления, принимая их или отклоняя. Все эти сведения записываются в журнал изменений.

Журнал изменений (новая возможность в Excel 97). Есть возможность отслеживать исправления, внесенные в общую книгу в течение заданного периода времени. Сведения об исправлениях можно просмотреть на отдельном листе в отфильтрованном журнале изменений.

Примечания (новая возможность в Excel 97). К любой ячейке можно добавить примечание. Оно вводится в специальное поле, которое появляется возле ячейки. Можно изменить формат примечания, переместить его в другое место. Можно также включить постоянное отображение примечания, либо разрешить его отображение только при наведении указателя мыши на ячейку с этим примечанием.

Последовательный просмотр примечаний (новая возможность в Excel 97). Если требуется просмотреть все примечания, следует выполнить их последовательный просмотр с помощью панели инструментов Рецензирование.

Объединение книг (новая возможность в Excel 97). Есть возможность объединить исправления, содержащиеся в копиях общей книги, редактировавшихся разными пользователями. Каждое примечание к ячейке содержит имя пользователя, вставившего это примечание. При объединении копий, примечания различных пользователей объединяются в одном поле. Этой возможностью, а также «Портфелем» системы Windows следует воспользоваться для работы с общей книгой в тем промежутки времени, когда нет возможности подключиться к сети. Впоследствии исправления, внесенные в этот промежуток времени, можно объединить с копией книги на компьютере, подключенном к сети.


Технические возможности и производительность

Увеличены максимально допустимые объемы книг и данных, с которыми может работать Microsoft Excel.

В одной ячейке помещается до 32.000 знаков (новая возможность в Excel 97). В Excel 95 в одной ячейке помещалось не более 255 знаков. Этот показатель увеличен по просьбам наших клиентов и независимых поставщиков программного обеспечения.

На одном листе помещается до 65.536 строк (новая возможность в Excel 97). В Excel 95 лист мог вместить не более 16.384 строк. Этот показатель увеличен по многочисленным просьбам наших клиентов.

Выполнение запросов в фоновом режиме (новая возможность в Excel 97). Появилась возможность выполнять запросы в фоновом режиме, что позволяет продолжить работу в Microsoft Excel, не дожидаясь извлечения данных. Время от времени можно проверять состояние выполняющегося запроса. Для получения дополнительных сведений о новых возможностях Microsoft Query щелкните кнопку [image].


Формат SYLK (символьная ссылка)

В формате SYLK (Symbolic Link) (*.slk) сохраняются значения и формулы только активного листа с ограниченным форматированием ячеек.

  • Сохраняется до 255 символов в ячейке. Строки сохраняются все.

  • Если функция Microsoft Excel не поддерживается форматом SYLK, она будет пересчитана, а формула будет заменена результирующей величиной до сохранения файла.

  • Большинство установок для текста сохраняется, но он принимает стиль оформления, установленный для первого знака ячейки. Утрачиваются углы поворота текста, объединенные ячейки, выравнивание по горизонтали и вертикали. Цвета шрифтов могут стать другими, если лист, сохраненный в формате SYLK, вновь открыть в Microsoft Excel. Рамки заменяются на однолинейные. Заливка ячеек заменяется на серую.

  • Установки диалогового окна Параметры страницы (меню Файл) и разрывы страниц, установленные вручную, утрачиваются.

  • Примечания к ячейкам сохраняются, но видны только в Microsoft Excel.

  • Рисунки, встроенные диаграммы, объекты, элементы управления формой, гиперссылки, условия, заданные для данных, условное форматирование и другие элементы листа пропадают.

  • Программы на Visual Basic утрачиваются.

  • Данные, отображенные в текущем представлении отчета сводной таблицы, сохраняются, остальные данные теряются.

  • При сохранении файла в формате Microsoft Excel для Macintosh версии 1.5 или более ранней, снимите флажок система дат 1904 на вкладке Вычисления диалогового окна Параметры (меню Сервис). Перед сохранением убедитесь, что все значения видны.


Формат шаблона

В формат файла шаблона Microsoft Excel 2000 заложены все существующие в Excel 2000 возможности работы с данными, диаграммами и макросами.

Сохранить книгу в формате файла шаблоны более ранней версии Excel невозможно.


Текстовый формат (с разделителями — символами табуляции)

В формате текстовых файлов с разделителями табуляции (*.txt) сохраняются данные только активных листов. Сохраняются все строки и все символы каждой ячейки. Столбцы разделяются символом табуляции, а строки символом возврата каретки. Если ячейка содержит запятую, ее содержимое берется в кавычки. Все виды оформления, графика, встроенные объекты утрачиваются.

Если в ячейке вместо результирующей величины отображена формула, эта формула становится текстом. Чтобы сохранить формулы для последующего преобразования в формат Microsoft Excel, выберите команду c разделителями в мастере разбора текстов, и выберите символ табуляции как разделитель границ.

Примечание. Если книга содержит специальные символы, такие как (©), и файл планируется использовать в другой операционной системе, сохраните книгу в текстовом формате, подходящем для этой операционной системы. Например, нужно перенести текстовый файл из Windows на компьютер Macintosh. В этом случае следует сохранить файл в формате Текст (Macintosh). Если используется компьютер Macintosh и нужно перенести файл в Windows или Windows NT, сохраните файл в формате Текст (Windows).


 Изменение запроса на внешние данные

Изменение запроса на внешние данные

Изменение запроса осуществляется с помощью Microsoft Query. Если приложение Microsoft Query отсутствует на вашем компьютере, его необходимо установить. Чтобы получить более подробные сведения, нажмите кнопку [image].

  1. Щелкните ячейку в диапазоне внешних данных, который требуется изменить.

  2. На панели инструментов Внешние данные выберите Изменить запрос [image] .

  3. Внесите необходимые изменения.

    Если запрос можно изменить с помощью мастера запросов, появляется диалоговое окно Создание запроса: выбор столбцов. См. Использование мастера запросов.

    Появление окна Microsoft Query указывает, что запрос можно изменить только в Microsoft Query. Окно мастера запросов не будет отображаться и в том случае, если в последнее время все запросы в книгах создавались с помощью Microsoft Query, а не мастера запросов, если запрос является запросом с параметрами или содержит условие выборки данных, либо тип связи, отличный от внутреннего объединения.

    Если желательно воспользоваться для изменения запроса какой-либо возможностью Microsoft Query, щелкайте кнопку Далее, пока не появится диалоговое окно Создание запроса: заключительный шаг, затем щелкните кнопку Просмотр или изменение данных в Microsoft Query. См. Изменение запросов с помощью Microsoft Query.

Примечание. Дополнительные сведения о работе в Microsoft Query содержатся в справке Microsoft Query.


 (Untitled)

Если нужно разместить интерактивную диаграмму или отчет сводной диаграммы на Web-странице, можно сохранить диаграмму с интерактивными возможностями.

Пример интерактивной диаграммы на Web-странице

При удалении данных, соответствующих диаграмме, диаграмма автоматически обновляется.

Для создания диаграммы с интерактивными возможностями следует сначала создать диаграмму или отчет сводной диаграммы в Microsoft Excel. При интерактивной публикации диаграммы Excel автоматически размещает исходные данные для диаграммы на Web-странице. Для диаграммы в Excel имеется инструмент интерактивных электронных таблиц. Для отчета сводной диаграммы в Excel имеется интерактивный список сводных таблиц.

Пользователи не могут непосредственно вносить изменения в диаграмму. Диаграмма автоматически обновляется при изменении данных в электронной таблице или изменении оформления списка сводных таблиц на Web-странице.

Если нужно изменить размер диаграммы на Web-странице, можно открыть Web-страницу в Microsoft FrontPage 2000 или в режиме конструктора страницы доступа к данным в Microsoft Access.

Возможно, были утрачены форматирование и некоторые возможности при сохранении с интерактивными возможностями.

Когда следует использовать другую программу для публикации данных. При работе с исходными данными в другой программе, например, в Microsoft Access, возможно, будет удобнее опубликовать Web-страницу непосредственно из Access, а не создавать запрос для импорта данных в Excel и для последующей их публикации. Для создания формы или отчета Microsoft Access, отображаемого в Web-обозревателе, можно использовать режим конструктора страницы доступа к данным в Microsoft Access. Для получения сведений о создании Web-страниц в Microsoft Access обратитесь к справочной системе Access.

Дополнительные сведения

Размещение данных Excel в Интернете.


(Untitled)

Большинство создаваемых Web-страниц будут содержать несколько элементов. Например, можно создать Web-страницу, которая содержит логотип, текст, сводную таблицу, список неинтерактивных данных и диаграмму. Преимуществом размещения нескольких элементов на одной странице является то, что пользователям нужно просмотреть только одну Web-страницу, чтобы получить всю необходимую информацию.

Пример Web-страницы, на которой размещено несколько элементов

Несколько элементов на Web-странице можно сделать интерактивными, а остальные — неинтерактивными.

При создании одной Web-страницы можно использовать возможности нескольких приложений Microsoft Office. Например, можно сохранить данные в Excel как Web-страницу и затем использовать Microsoft Access 2000 для добавления групп элементов управления страницы данных или сценариев. Затем Web-страницу можно открыть в Microsoft FrontPage 2000 и добавить темы, чтобы Web-страница выглядела одинаково с другими страницами на Web-узле.

См. сведения о способах размещения данных Excel в Интернете.

Можно комбинировать интерактивные и неинтерактивные данные и данные из других программ Microsoft Office. Например, можно получить имена сотрудников, их должности и размер оклада из содержащей эту информацию базы данных при помощи Microsoft Access 2000, и затем анализировать данные, полученные при помощи Access, в Excel. В Excel можно добавить формулы для вычисления среднего оклада для каждой должности и построения соответствующей диаграммы. Сохраните результаты проведенного вами анализа как интерактивную электронную таблицу или список сводных таблиц на Web-странице. Затем при помощи Microsoft FrontPage 2000 добавьте логотип компании и описание данных на странице.

Возможно, были утрачены форматирование и некоторые особенности при сохранении с интерактивными возможностями.

Дополнительные сведения

Размещение данных Excel в Интернете.

Создание сценариев и Web-страницы.


 (Untitled)

Сводная таблица представляет собой интерактивную таблицу, позволяющую вычислять итоговые значения для больших объемов данных. Сводные таблицы используются для сравнения соответствующих итогов, а также для сортировки, вычисления итогов и промежуточных итогов.

Использование сводной таблицы на Web-странице

В сводной таблице на Web-странице можно анализировать данные, изменяя макет.

Если нужно, чтобы пользователи, работающие с Интернетом, работали со сводной таблицей, или если необходимо опубликовать диапазон внешних данных, которые можно обновлять, можно поместить интерактивную сводную таблицу на Web-страницу. (Версия сводной таблицы, опубликованная в Интернете, называется списком сводной таблицы.) Если нужно создать интерактивную публикацию с возможностью работы со сводными таблицами, пользователи могут фильтровать данные в готовом списке сводных таблиц, анализировать данные при помощи различных представлений данных, и обновлять внешние данные в обозревателе.

Исходные данные для сводных таблиц. Можно создать интерактивную сводную таблицу из готовой сводной таблицы или других данных Microsoft Excel. Если используются другие данные Microsoft Excel и выбран параметр Работа со сводными таблицами в диалоговом окне Опубликовать, Excel создает сводную таблицу на Web-странице.

Чтобы пользователи могли обновлять диапазон внешних данных на Web-странице, нужно выбрать параметр Работа со сводными таблицами для публикации диапазона внешних данных в сводной таблице. Когда пользователи загружают Web-страницу в обозревателе или нажимают кнопку Обновить в списке сводной таблицы, данные автоматически обновляются из исходной базы данных.

Ограничения. Возможно, были утрачены форматирование и некоторые особенности при сохранении с интерактивными возможностями.

Когда следует использовать другую программу для публикации данных. При работе с исходными данными в другой программе, например, в Microsoft Access, возможно, будет удобнее опубликовать Web-страницу непосредственно из Access, а не создавать запрос для импорта данных в Excel и последующей их публикации. Для создания формы или отчета Microsoft Access, отображаемого в Web-обозревателе, можно использовать режим конструктора страницы доступа к данным в Microsoft Access. Для получения сведений о создании Web-страниц в Microsoft Access, обратитесь к справочной системе Access.

Дополнительные сведения

Размещение данных Excel в Интернете.

Сведения о публикации отчетов сводных таблиц Microsoft Excel в Интернете.


 (Untitled)

Чтобы пользователи могли работать с данными, размещенными на Web-странице, можно создать Web-страницу из электронной таблицы Microsoft Excel или отдельных элементов электронной таблицы, сохранив данные с возможностью работы со сводными таблицами. Если нужно создать интерактивную публикацию с возможностью работы с электронными таблицами, пользователи могут выполнить следующие действия:

  • Ввести данные

  • Форматировать данные

  • Обрабатывать данные

  • Анализировать данные

  • Сортировать и применять фильтры

Пример Web-страницы, на которой размещены интерактивные данные

При работе с интерактивными Web-страницами, пользователи могут вносить изменения в данные и оформление элементов Web-страницы.

Вычисление данных на Web-странице. Если пользователи должны периодически заново вычислять данные, можно использовать возможности работы с электронными таблицами. Например, если нужно, чтобы пользователи могли вычислять размер займа на основании конкретных значений процентных ставок, можно создать средство вычисления размера займа для Web-страницы.

Диапазоны внешних данных. Если интерактивная электронная таблица содержит данные из диапазона внешних данных Excel, данные таблицы невозможно обновить при изменении внешних данных. Чтобы иметь возможность обновить внешние данные на Web-странице, необходимо опубликовать диапазон внешних данных как интерактивную сводную таблицу.

На Web-странице можно разместить следующие элементы с поддержкой интерактивных возможностей работы с электронными таблицами:

  • листы

  • отчеты сводных таблиц

  • диапазоны внешних данных

  • диапазоны ячеек

  • отфильтрованные списки

  • области печати

Возможно, были утрачены форматирование и некоторые особенности при сохранении с интерактивными возможностями.

Когда следует использовать другую программу для публикации данных. При работе с исходными данными в другой программе, например, в Microsoft Access, возможно, будет удобнее опубликовать Web-страницу непосредственно из Access, а не создавать запрос для импорта данных в Excel и для последующей их публикации. Для создания формы или отчета Microsoft Access, отображаемого в Web-обозревателе, можно использовать режим конструктора страницы доступа к данным в Microsoft Access. Для получения сведений о создании Web-страниц в Microsoft Access, обратитесь к справочной системе Access.

Дополнительные сведения

Размещение данных Excel в Интернете.


 (Untitled)

Если нужно представить данные в таком формате, чтобы пользователи могли только просматривать данные, можно опубликовать или сохранить данные без поддержки интерактивных возможностей. При этом будет опубликован "мгновенный снимок" данных.

Пример Web-страницы, на которой размещены неинтерактивные данные

При работе с неинтерактивными Web-страницами пользователи могут только просматривать данные, но не выполнять какие-либо действия над ними.

Неинтерактивные Web-страницы можно просамтривать с помощью любого Web-обозревателя, в отличие от интерактивных страниц, для работы с которыми необходим Microsoft Internet Explorer версии 4.01 или более поздней. На Web-странице без поддержки интерактивности можно разместить все элементы Microsoft Excel, в том числе книги, листы, диапазоны ячеек, сводные таблицы, данные в области печати, отфильтрованные списки и диаграммы.

Примечание. Если размещаемые на Web-странице неинтерактивные данные содержат диапазон внешних данных, данные на Web-странице невозможно обновлять. Чтобы можно было обновлять внешние данные на Web-странице, следует опубликовать эти данные как интерактивную сводную таблицу.

Когда следует использовать другую программу для публикации данных. При работе с исходными данными в другой программе, например, в Microsoft Access, возможно, будет удобнее опубликовать Web-страницу непосредственно из Access, а не использовать запрос для импорта данных в Excel и последующей их публикации. Для создания формы или отчета Microsoft Access, отображаемого в Web-обозревателе, можно использовать режим конструктора страницы доступа к данным в Microsoft Access. Для получения сведений о создании Web-страниц при помощи Microsoft Access, обратитесь к справочной системе Access.

Дополнительные сведения

Размещение данных Excel в Интернете.


 (Untitled)

Если нужно поместить на Web-страницу все данные книги одновременно, можно поместить на Web-страницу всю книгу, выбрав параметр всю книгу (меню Файл, команда Сохранить как Web-страницу). Данные будут отображаться так же, как они отображаются в Microsoft Excel, включая вкладки листов, облегчающие переход к отдельным листам.

Пример книги, опубликованной в Интернете

В книгах, опубликованных в Интернете, имеются вкладки, как и в обычных книгах Excel.

При сохранении всей книги невозможно сделать отдельные элементы книги интерактивными. Например, если книга содержит формулы или сводную таблицу, на Web-странице будут отображаться значения, которые были представлены в книге в момент сохранения.

Примечание. Если целиком размещаемая на Web-странице книга содержит диапазон внешних данных, данные на Web-странице невозможно обновлять. Чтобы можно было обновлять внешние данные на Web-странице, следует опубликовать эти данные как интерактивную сводную таблицу.

Дополнительные сведения

Размещение данных Excel в Интернете.


Новые возможности для разработчиков в Microsoft Excel 2000

В Visual Basic для приложений и в среду Visual Basic для приложений в версии Microsoft Office 2000 внесено большое количество изменений, о которых разработчик обязательно должен знать. Дополнительные сведения об изменениях в Visual Basic и в объектной модели Visual Basic, внесенных в Microsoft Excel 2000, можно найти в справке по Visual Basic.

Поддержка антивирусных средств (Новая возможность в Office 2000). В состав Office 2000 могут быть включены программные продукты других поставщиков, использующие интерфейс программирования для проверки документов на наличие вируса. В целях усиления безопасности и для большей надежности разработчики могут добавлять цифровую подпись к макросам VBA. Цифровая подпись служит для удостоверения автора макроса и гарантии того, что макросы не содержат вирусов. В Office 2000 имеется возможность распознавания макросов с цифровой подписью из надежных источников, и соответствующее предупреждение не выдается до тех пор, пока макрос не будет изменен.

Microsoft Visual Basic для приложений 6 ( Новая возможность в Office 2000). Последняя версия Visual Basic для приложений поставляется вместе с Office 2000. Visual Basic 6 предоставляет Microsoft Office такие средства, как, например, немодальные пользовательские формы или поддержка дополнительных элементов управления ActiveX.

Использование сценариев в Web-документах ( Новая возможность в Office 2000). Office 2000 предоставляет разработчикам возможность создавать сценарии и клиентские решения на основе HTML из любого приложения Office при помощи редактора сценариев. Редактор сценариев полностью поддерживается обозревателями при отладке, и ссылки сценария можно использовать в документах Office.

Модель компонентных объектов (Новая возможность в Office 2000). Все приложения Microsoft Office поддерживают единую архитектуру надстроек и объектную модель, называемую моделью компонентных объектов (COM). Архитектура надстроек COM позволяет пользователям средств разработки программного обеспечения (к числу которых относятся, например, Microsoft Office Developer 2000, Microsoft Visual Basic, Microsoft Visual C++ и Microsoft Visual J++) разрабатывать программы надстроек, работающие со всеми приложениями Microsoft Office.

Расширения объектной модели (Новая возможность в Office 2000). Существует множество расширений объектной модели, позволяющих сохранять листы как Web-страницы, предоставляющих расширенный доступ, позволяющих создавать отчеты сводных диаграмм, поддерживающих такие источники данных для отчетов сводных диаграмм, как OLE DB и OLAP, позволяющих создавать надписи для единиц измерения в диаграммах и предоставляющих улучшенную фонетическую поддержку.


 Причины возникновения ошибки #ДЕЛ/0!

Причины возникновения ошибки #ДЕЛ/0!

Ошибка #ДЕЛ/0! появляется, когда в формуле делается попытка деления на ноль (0).

Возможная причина | Предлагаемые действия
В качестве делителя используется ссылка на ячейку, содержащую нулевое или пустое значение (если операнд является пустой ячейкой, то ее содержимое интерпретируется как ноль). | Измените ссылку или введите ненулевое значение в ячейку, используемую в качестве делителя. Кроме того, в качестве делителя можно ввести значение #Н/Д. В этом случае ошибка #ДЕЛ/0! сменится на #Н/Д, указывающую, что значение делителя не определено. Чтобы ошибка не отображалась, используйте функцию ЕСЛИ. Если в качестве делителя используется пустая или содержащая нулевое значение (0) ячейка, функция ЕСЛИ может не отображать никакого значения вместо того, чтобы выполнять вычисления. Например, если ячейка B5 содержит делитель, а ячейка A5 содержит делимое, используйте =IF(B5=0,"",A5/B5). Кавычки обозначают пустую текстовую строку.
В формуле содержится явное деление на ноль (например =5/0). | Исправьте формулу.
Используется макрос, вызывающий макрофункцию, которая возвращает в определенных случаях значение #ДЕЛ/0! | Найдите описание используемых функций и проверьте, не возвращают ли они в определенных случаях значение #ДЕЛ/0!.


Причины возникновения ошибки #####

Значение ошибки ##### выводится в том случае, когда ячейка содержит число, дату или время, число знаков которого больше ширины ячейки, или в том случае, если ячейка содержит дату и/или формулу, которая выводит отрицательный результат.

Увеличьте ширину столбца. Изменить размер столбца можно, перетащив границу между заголовками столбцов.

Выберите другой числовой формат. В некоторых случаях, можно изменить числовой формат ячейки, чтобы число помещалось в ячейку текущей ширины. Например, можно уменьшить число знаков после десятичной запятой. См. также Изменение способа отображения чисел, дат и времени в Microsoft Excel.

Проверьте, не содержат ли ошибку формулы, определяющие значение даты и времени. При определении числа дней между двумя датами убедитесь в том, что формула составлена правильно. Если используется система дат 1900, дата и время в Excel должны быть положительными величинами. Поэтому при вычитании более поздней даты и времени из более ранней даты и времени возникает ошибка #####. (Чтобы использовать систему дат 1900, выберите команду Параметры в меню Сервис, затем перейдите на вкладку Вычисления, и снимите флажок система дат 1904.) Если формула не содержит ошибок, хотя в результате вычислений получается отрицательная величина, можно отобразить это значение, задав формат ячейки, отличный от формата даты или времени. Выберите команду Ячейки в меню Формат, перейдите на вкладку Число и выберите формат, отличный от формата даты или времени.


 Причины возникновения ошибки #Н/Д

Причины возникновения ошибки #Н/Д

Значение ошибки #Н/Д является сокращением термина “Неопределенные Данные”. Это значение помогает предотвратить использование ссылки на пустую ячейку. Введите в ячейки листа значение #Н/Д, если они должны содержать данные, но в настоящий момент эти данные отсутствуют. Формулы, ссылающиеся на эти ячейки, тоже будут возвращать значение #Н/Д вместо того, чтобы пытаться производить вычисления.

Возможная причина | Предлагаемые действия
Для функций ГПР, ПРОСМОТР, ПОИСКПОЗ или ВПР задан недопустимый аргумент искомое_значение. | Задайте правильный аргумент искомое_значение — например, значение или ссылку, но не диапазон ссылок. Можно воспользоваться мастером подстановок для создания формулы подстановки.
Использование функций ВПР, ГПР и ПОИСКПОЗ для просмотра значений в несортированной таблице. | По умолчанию для функций просмотра таблиц сведения должны располагаться в возрастающем порядке. Функции ВПР и ГПР содержат аргумент интервальный_просмотр, позволяющий искать определенное значение в несортированной таблице. Чтобы найти определенное значение, аргумент интервальный_просмотр должен иметь значение ЛОЖЬ. Функция ПОИСКПОЗ содержит аргумент тип_сопоставления, задающий порядок, в котором список должен быть отсортирован для поиска соответствующего значения. Если невозможно найти соответствующее значение, попробуйте изменить аргумент тип_сопоставления.
В формуле массива используется аргумент, не соответствующий диапазону, определяющемуся числом строк и столбцов, который указан в формуле массива. | Если формула массива введена в несколько ячеек, проверьте диапазон ссылок формулы на соответствие числу строк и столбцов или введите формулу массива в недостающие ячейки. Например, если формула массива введена в первые 15 ячеек столбца С (C1:C15), а сама формула ссылается на первые 10 ячеек столбца А (A1:A10), то в ячейках C11:C15 будет отображаться ошибка #Н/Д. Чтобы исправить эту ошибку, уменьшите диапазон формулы (например C1:C10) или увеличьте диапазон, на который ссылается формула (например A1:A15).
Не заданы один или несколько аргументов стандартной или пользовательской функции листа. | Задайте все необходимые аргументы функции.
Используется пользовательская функция, обращение к которой приводит к ошибке. | Проверьте, что книга, использующая функцию листа, открыта и убедитесь в правильности работы функции.
Используется макрос, вызывающий макрофункцию, которая возвращает в определенных случаях значение #Н/Д. | Проверьте правильность указания и размещения аргументов в функции.


 Причины возникновения ошибки #ИМЯ?

Причины возникновения ошибки #ИМЯ?

Ошибка #ИМЯ? появляется, когда Microsoft Excel не может распознать имя, используемое в формуле.

Возможная причина | Предлагаемые действия
Используемое имя было удалено или не было определено. | Определите имя. Выберите команду Имя в меню Вставка, а затем —команду Присвоить. Кроме того, команда Присвоить используется для добавления имени, отсутствующего в списке.
Имеется ошибка в написании имени. | Исправьте написание имени. Чтобы вставить правильное имя в формулу, выделите имя в строке формул, выберите команду Имя в меню Вставка, а затем — команду Вставить. На экране появится диалоговое окно Вставка имени. Выделите нужное имя и нажмите кнопку OK.
Использование заголовка в формуле. | Выберите команду Параметры в меню Сервис, затем выберите вкладку Вычисления. В группе Параметры книги установите флажок допускать названия диапазонов.
Имеется ошибка в написании имени функции. | Исправьте написание имени. Вставьте в формулу правильное имя функции при помощи панели формул. Если функция листа является частью программы надстройки, то программа надстройки должна быть загружена. Для получения дополнительных сведений по использованию программ надстроек нажмите кнопку [image] .
В формулу введен текст, не заключенный в двойные кавычки. Microsoft Excel пытается распознать такую запись как имя, даже если это не предполагалось. | Заключите текст формулы в двойные кавычки. Например, в следующей формуле правильно объединяется текстовый фрагмент “Всего:” со значением ячейки B50: ="Всего: "&B50
В ссылке на диапазон ячеек пропущен знак двоеточия (:). | Исправьте формулу так, чтобы во всех ссылках на диапазон ячеек использовался знак двоеточия (:), например: СУММ(A1:C10).


 Причины возникновения ошибки #ПУСТО!

Причины возникновения ошибки #ПУСТО!

Ошибка #ПУСТО! появляется, когда задано пересечение двух областей, которые в действительности не имеют общих ячеек.

Возможная причина | Предлагаемые действия
Использован ошибочный оператор пересечения диапазонов или ошибочная ссылка на ячейку. | Для создания ссылки на две непересекающиеся области, используется оператор объединения, обозначаемый запятой (,). Например, если формула суммирует два диапазона, проверьте, что в качестве разделителя диапазонов используется запятая (СУММ(A1:A10,C1:C10)). Если запятая пропущена, то Microsoft Excel будет пытаться суммировать общие ячейки указанных диапазонов (A1:A10 и C1:C10), которые на самом деле таких ячеек не имеют. Проверьте, не допущено ли ошибок при вводе ссылок на диапазоны ячеек.

Для получения дополнительных сведений по ссылкам и операторам диапазонов нажмите кнопку [image] .


 Причины возникновения ошибки #ЧИСЛО!

Причины возникновения ошибки #ЧИСЛО!

Ошибка #ЧИСЛО! появляется, когда возникают проблемы при использовании чисел в формуле или функции.

Возможная причина | Предлагаемые действия
В функции с числовым аргументом используется неприемлемый аргумент. | Проверьте правильность используемых в функции аргументов.
Использована функция, при вычислении которой применяются итерации, например, такие функции, как ВНДОХ или НОРМА, и при этом итерации не сходятся и невозможно получить результат. | Попробуйте использовать другое начальное приближение для этой функции.
Введена формула, возвращающая числовое значение, которое слишком велико или слишком мало, чтобы его можно было представить в Microsoft Excel. | Измените формулу таким образом, чтобы результат находился в диапазоне от минус единица, умноженная на десять в 307 степени до единица, умноженная на десять в 307 степени .


 Причины возникновения ошибки #ССЫЛКА!

Причины возникновения ошибки #ССЫЛКА!

Ошибка #ССЫЛКА! появляется, когда используется недопустимая ссылка на ячейку.

Возможная причина | Предлагаемые действия
Ячейки, на которые ссылаются формулы, были удалены или в эти ячейки было помещено содержимое других скопированных ячеек. | Измените формулы или, сразу же после удаления или вставки скопированного, восстановите прежнее содержимое ячеек с помощью кнопки Отменить [image] .
Используется макрос, вызывающий макрофункцию, в определенных случаях возвращающую значение #ССЫЛКА!. | Проверьте аргументы функции и удостоверьтесь, что они ссылаются на допустимые ячейки или диапазоны ячеек. Например, если макрос вызывает функцию из ячейки, расположенной выше первой строки, то отобразится ошибка #ССЫЛКА!, поскольку такая ячейка не существует.
Использована удаленная ссылка на не активное в настоящий момент приложение или на недоступный раздел DDE (Dynamic Data Exchange), например "system". | Запустите нужное приложение. Проверьте, что используется правильный раздел DDE.


 Причины возникновения ошибки #ЗНАЧ!

Причины возникновения ошибки #ЗНАЧ!

Ошибка #ЗНАЧ! появляется, когда используется недопустимый тип аргумента или операнда, а также, если средствами автоисправления формулы не представляется возможным исправить формулу.

Возможная причина | Предлагаемые действия
Вместо числового или логического (ИСТИНА или ЛОЖЬ) значения введен текст, и Microsoft Excel не может преобразовать его к нужному типу данных. | Проверьте правильность задания типов операндов или аргументов в функции или формуле, а также значений ячеек, на которые ссылается формула. Например, если в ячейке A5 содержится число, а в ячейке A6 содержится текстовое значение " Недоступно" , формула " =A5+A6" вернет ошибку #ЗНАЧ!. Чтобы сложить два значения, воспользуйтесь в формуле функцией СУММ (функция СУММ игнорирует текстовые значения): =СУММ(A5:A6)
После ввода или редактирования формулы массива нажимается клавиша ENTER. | Для редактирования формулы укажите ячейку или диапазон ячеек, содержащих формулу массива, нажмите клавишу F2, а затем —клавиши CTRL+SHIFT+ENTER.
Ссылка, формула или функция указана как массив констант. | Проверьте, что ссылка, формула или функция не используются как массив констант. Для получения дополнительных сведений по элементам массива констант нажмите кнопку [image] .
Для оператора или функции, требующей одного значения, возвращается диапазон. | Сделайте необходимые изменения, чтобы вместо диапазона возвращалось одно значение. Измените диапазон таким образом, чтобы в него попадала строка или столбец с формулой.
Использована неправильная матрица в одной из матричных функций листа. | Убедитесь в правильном указании размерности матрицы.
Используется макрос, вызывающий макрофункцию, которая возвращает в определенных случаях значение #ЗНАЧ!. | Найдите описание используемых функций и проверьте условия возврата значения #ЗНАЧ!.


 Запуск макроса при выборе рисованного или графического объекта для перемещения или изменения

Запуск макроса при выборе рисованного или графического объекта для перемещения или изменения

Графическому или рисованному объекту был присвоен макрос, который выполняется при выборе этого объекта. Чтобы при выборе объекта макрос не вызывался, воспользуйтесь одним из следующих способов:

  • Для выделения объекта и отображения контекстного меню пользуйтесь правой кнопкой мыши.

  • Воспользуйтесь кнопкой Выбор объектов [image] на панели инструментов Рисование и поместите границу выделения вокруг соответствующего объекта с помощью мыши.


 Изменение размеров при перемещении объекта и наоборот

Изменение размеров при перемещении объекта и наоборот

  • Для перемещения не содержащей текста автофигуры перемещайте ее внутреннюю часть или границу, но не маркер изменения размера и не маркер изменения формы. Для автофигуры с текстом или без заливки (например, если отображается только контур) следует перемещать мышью границу фигуры. Если щелкнуть внутреннюю часть фигуры с текстом, будет выделен сам текст.

  • Для изменения размеров выделенной автофигуры переместите один из маркеров изменения размера или формы. Перемещение центральной части или границы фигуры приведет к выделению текста или перемещению всей фигуры, вместо изменения ее размеров.


Параметры для рабочих групп

Возможности | Наибольшее число
Наибольшее число пользователей, которые могут одновременно открывать общую книгу | 256
Наибольшее число личных представлений в общей книге | Ограничивается объемом доступной оперативной памяти
Число дней, поддерживаемое журналом изменений | 32000 (по умолчанию 30 дней)
Наибольшее число одновременно объединяемых книг Excel | Ограничивается объемом доступной оперативной памяти
Ячейки, которые могут быть выделены в общей книге | 32,767
Наибольшее число цветов для обозначения изменений, вносимых разными пользователями, при включенном режиме цветового выделения изменений | 32 (каждому пользователю соответствует свой цвет; изменения текущего пользователя выделяются темно-синим цветом)


Параметры листов и книг Excel

Этот раздел содержит ссылки на:

Параметры листов и книг Excel

Спецификации вычислений

Спецификации сводных таблиц

Параметры листов и книг Excel

Возможности | Наибольшее число
Все открытые книги | Ограничивается объемом доступной памяти и ресурсами системы
Размер листа | 65536 строк и 256 столбцов
Ширина столбца | 255 символов
Высота строки | 409 точек
Длина записи для содержимого ячеек (текст) | 32767 символов. В ячейке отображаются только 1024 символа; все 32767 символов отображаются в строке формул.
Число листов в книге | Ограничено объемом доступной памяти (значение по умолчанию — 3 листа)
Число цветов в книге | 56
Число стилей ячейки книги | 4,000
Число именованных представлений в книге | Ограничивается объемом доступной оперативной памяти
Пользовательские числовые форматы | Ограничивается объемом доступной оперативной памяти
Число имен в книге | Ограничивается объемом доступной оперативной памяти
Число окон в книге | Ограничивается ресурсами системы
Число областей в окне | 4
Число связанных листов | Ограничивается объемом доступной оперативной памяти
Число сценариев | Ограничивается объемом доступной оперативной памяти, в итоговый отчет включается первый 251 сценарий
Число изменяемых ячеек в сценарии | 32
Число вычисляемых ячеек в надстройке “Поиск решения” | 200
Пользовательские функции | Ограничивается объемом доступной оперативной памяти
Пределы масштабирования | от 10 до 400 процентов
Отчеты | Ограничивается объемом доступной оперативной памяти
Число уровней сортировки | 3 для однократной сортировки; не ограничено для последовательных сортировок
Число уровней отмены | 16
Число полей в форме данных | 32
Число пользовательских панелей в книге | Ограничивается объемом доступной оперативной памяти
Настройка кнопок панелей инструментов | Ограничивается объемом доступной оперативной памяти

Возврат в начало

Спецификации вычислений

Возможности | Наибольшее число
Точность представления чисел | 15 разрядов
Наибольшее положительное число | 9,99999999999999E307
Наименьшее отрицательное число | -9,99999999999999E307
Наименьшее положительное число | 1E-307
Наибольшее отрицательное число | -1E-307
Длина записи для формулы | 1024 символа
Число итераций | 32,767
Размер массива книги | Ограничивается объемом доступной оперативной памяти. Кроме того, массивы не могут ссылаться на целые столбцы. Например, массив не может ссылаться на весь столбец C:C или на диапазон ячеек C1:C65536. Однако, массив может ссылаться на диапазон C1:D65535, поскольку указанный диапазон на один ряд короче максимального размера листа книги и не включает столбец C или D целиком.
Число выделенных диапазонов | 2,048
Число аргументов функции | 30
Число уровней вложенности функций | 7
Число функций листа Excel | 329
Наименьшая используемая в расчетах дата | 1 января 1900 г. (1 января 1904 г. для системы дат 1904)
Наибольшая используемая в расчетах дата | 31 декабря 9999 г.
Наибольший временной интервал, который можно ввести | 9999:99:99

Возврат в начало

Спецификации сводных таблиц

Возможности | Наибольшее число
Число сводных таблиц на одном листе | Ограничивается объемом доступной оперативной памяти
Число элементов сводной таблицы | 8,000
Число полей строк или столбцов в сводной таблице | Ограничивается объемом доступной оперативной памяти
Число полей страницы в сводной таблице | 256 (может ограничиваться объемом доступной оперативной памяти)
Число полей данных в сводной таблице | 256
Число формул вычисляемых элементов в сводной таблице | Ограничивается объемом доступной оперативной памяти

Возврат в начало


Новые возможности использования функций

Новые и улучшенные функции Microsoft Excel теперь позволяют использовать итоговые значения сводных таблиц в формулах, подсчитывать количество пустых ячеек в диапазоне, а также предоставляют другие возможности.

ГИПЕРССЫЛКА (Введено в версии 97) Создает ссылку, открывающую документ, находящийся на жестком диске, сервере сети или в Интернете.

ДИСПА (Введено в версии 97) Оценивает дисперсию на основе выборки. В отличие от функции ДИСП, функция учитывает при вычислении ячейки с текстом и логическими значениями.

ДИСПРА (Введено в версии 97) Оценивает дисперсию генеральной совокупности. В отличие от функции ДИСПР, функция учитывает при вычислении ячейки с текстом и логическими значениями.

МАКСА (Введено в версии 97) Возвращает максимальное значение в диапазоне ячеек. В отличие от функции МАКС, в функции МАКСА в качестве аргументов могут быть использованы текстовые и логические значения.

МИНА (Введено в версии 97) Возвращает максимальное значение в диапазоне ячеек. В отличие от функции МИН, в функции МИНА в качестве аргументов могут быть использованы текстовые и логические значения.

ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ (Введено в версии 97) Извлекает данные из отчета сводной таблицы.

СРЗНАЧА (Введено в версии 97) Возвращает среднее значение диапазона ячеек. В отличии от функции СРЗНАЧ, в функции СРЗНАЧА в качестве аргументов могут быть использованы текстовые и логические значения.

СТАНДОТКЛОНА (Введено в версии 97) Оценивает стандартное отклонение на основе выборки. В отличие от функции СТАНДОТКЛ, функция учитывает при вычислении ячейки с текстом и логическими значениями.

СТАНДОТКЛОНПА (Введено в версии 97) Оценивает стандартное отклонение генеральной совокупности. В отличие от функции СТАНДОТКЛОНП, функция учитывает при вычислении ячейки с текстом и логическими значениями.


 Отображение или скрытие нескольких книг на панели задач Windows

Отображение или скрытие нескольких книг на панели задач Windows

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Вид.

    Демонстрация

  2. Установите или снимите флажок окна на панели задач.


 Установленные элементы управления ActiveX не появляются в пункте «Дополнительные»

Установленные элементы управления ActiveX не появляются в пункте «Дополнительные»

Необходимо установить дополнительные элементы управления. После установки нового набора элементов ActiveX программа установки для элементов ActiveX обычно регистрирует каждый элемент, делая его доступным в Microsoft Excel. Элементы ActiveX хранятся либо в файлах элементов управления, имеющих расширение .ocx, либо в библиотеках динамической компоновки, имеющих расширение .dll.

Следует зарегистрировать новые элементы управления. Если при нажатии кнопки Дополнительные элементы [image] на панели инструментов Элементы управления нужный элемент не появился в списке, необходимо его зарегистрировать. Нажмите кнопку Дополнительные элементы на панели инструментов Элементы управления [image] . В нижней части списка выберите команду Зарегистрировать элемент управления. В окне диалога Зарегистрировать элемент управления укажите папку, содержащую файлы элементов управления или библиотеки динамической компоновки для данных элементов. Выберите элемент, который нужно зарегистрировать, и нажмите кнопку Открыть.


 После слияния книг не появляются ожидаемые изменения

После слияния книг не появляются ожидаемые изменения

Используются изменения из книги, которая была выделена последней. При слиянии двух книг, изменения в книге, которая была выделена для слияния, заменяют все конфликтующие изменения в книге, из которой была вызвана операция слияния. Если в одной операции для слияния было выбрано несколько книг, то они объединяются в том порядке, в котором они перечислены в диалоговом окне Выберите, какие файлы включить к книгу. Изменения каждой следующей объединяемой книги заменяют предыдущие объединения.

  • Чтобы просмотреть данные, которые были замещены, отобразите лист изменений. Для получения более подробных сведений нажмите кнопку [image] .

  • Чтобы сохранить некоторые изменения объединяемой копии и отбросить другие, просмотрите их. Для получения более подробных сведений нажмите кнопку [image] .


 После прекращения совместного использования книги, а затем после его возобновления, не удается просмотреть журнал изменений.

После прекращения совместного использования книги, а затем после его возобновления, не удается просмотреть журнал изменений.

После окончания совместного использования книги, ведение журнала изменений прекращается, а данные об изменениях очищаются. Если совместный доступ к книге снова возобновляется, то данные об изменениях начинают вестись с этого момента.

Скопируйте лист изменений перед сохранением Если планируется прекращение совместного использования книги, но необходимо сохранить данные об изменениях, то отобразите данные обо всех изменениях в листе изменений, а затем либо скопируйте их из листа изменений в другой лист, либо распечатайте первый. Рекомендуется сохранить копию общей книги, к которой в это время относится лист изменений. Для получения сведений о просмотре листа изменений нажмите кнопку [image] .

Если необходимо сохранить журнал изменений полностью, то не прекращайте совместное использование книги. Чтобы использовать функции, которые недоступны при существовании совместного доступа к книге, работайте с копией книги, а совместное использование прекратите только для копии.


 Числовые элементы сводной таблицы после переименования сортируются или форматируются неправильно.

Числовые элементы сводной таблицы после переименования сортируются или форматируются неправильно.

В полях сводной таблицы формат числовых элементов, по умолчанию, совпадает с форматом исходных данных. Например, элемент "2.0" будет иметь числовой формат с одним десятичным знаком. Поскольку Microsoft сортирует числовые объекты отдельно от текстовых, переименованные числовые элементы будут отсортированы с использованием другого порядка сортировки, отличного от порядка сортировки остальных чисел.


 При изменении данных в ячейке не отображается сообщение об ошибке.

При изменении данных в ячейке не отображается сообщение об ошибке.

Microsoft Excel выводит на экран сообщения об ошибке, установленные для ячеек с помощью команды Проверка меню Данные, только при непосредственном вводе данных в ячейку. Сообщение об ошибке не отображается:

  • Если значение в ячейке, имеющей ограничения на данные, становится некорректным в результате вычислений, произведенных по формуле, содержащейся в этой ячейке.

  • Если некорректные данные помещаются в ячейку макросом.

  • Если пользователь вводит данные в ячейку посредством копирования или заполнения.

Для нахождения ячеек, содержащих некорректные данные, применяется проверка листа. Чтобы получить более подробные сведения, нажмите кнопку [image] .


 Другой пользователь заменил данные или изменения, которые необходимо было сохранить.

Другой пользователь заменил данные или изменения, которые необходимо было сохранить.

Скопируйте данные из листа изменений на исходный лист. Если на тот момент времени, когда были заменены изменения, велся журнал изменений, то изначально введенные данные находятся в листе изменений. Данные этого листа могут быть введены заново в исходный лист. Для получения сведений о просмотре листа изменений и поиске данных нажмите [image] .

Сделайте копию изменений. Чтобы гарантировать существование копии изменений, которые не должны быть внесены, после окончания редактирования используйте команду Сохранить как в меню Файл для копирования копии книги в локальную систему.


 Отчет сводной таблицы, который требуется использовать для создания другого отчета, не отображается в списке мастера.

Отчет сводной таблицы, который требуется использовать для создания другого отчета, не отображается в списке мастера.

Проверьте место размещения отчета. Список на шаге 2 мастера содержит только отчеты из текущей книги. Если отчет сводной таблицы, который вы хотите использовать как источник данных, находится в другой книге, скопируйте отчет в текущую книгу.

Проверьте параметры поля страницы. Требуемый отчет сводной таблицы может содержать поля страницы, настроенные на получение внешних данных при выборе каждого элемента. Чтобы использовать отчет сводной таблицы в качестве источника данных для другого отчета, поля страницы отчета сводной таблицы должны быть настроены на получение внешних данных для всех элементов одновременно. Дважды щелкните каждое поле страницы, нажмите кнопку Далее и установите флажки в группе Параметры поля страницы. См. сведения о параметрах поля страницы.


 После применения автоформата изменился макет отчета сводной таблицы.

После применения автоформата изменился макет отчета сводной таблицы.

Некоторые автоформаты, вызываемые нажатием кнопки Формат отчета [image] , изменяют макет отчета при использовании структурированного или неструктурированного формата. См. сведения о влиянии форматов на отчеты сводных таблиц.

Отмените автоформат. Попробуйте нажать кнопку Отменить [image] . Если отчет сводной таблицы был преобразован в структурированный формат недавно, то, возможно, удастся восстановить его прежний формат и оформление.

Переместите поля обратно на их прежние места. Некоторые автоформаты преобразуют все поля столбцов в отчете сводной таблицы в поля строк, в то время как другие автоформаты преобразуют отдельные поля столбцов в поля строк. Можно восстановить исходные параметры полей.


Книга не использует режим вычислений, сохраненный в шаблоне, на котором она была основана.

Для всех открытых книг Microsoft Excel использует единый режим вычислений. Если изменить этот режим в одной открытой книге, то он изменится и для всех остальных открытых книг. Для получения более подробных сведений нажмите кнопку [image] .


 Поля со значениями даты или времени восстанавливаются некорректно.

Поля со значениями даты или времени восстанавливаются некорректно.

Проверьте поле со значением даты или времени в исходной базе данных. Если не отображаются ожидаемые уровни для размерностей даты или времени в исходных данных, созданных в приложении Microsoft Query с помощью мастера создания куба, проверьте поле даты или времени в текущей реляционной базе данных, к которой выдается запрос. Значения даты и времени в записях базы данных могут храниться в формате текста, а не в формате даты и времени, который может распознать мастер куба OLAP. Если вы полагаете, что именно это является причиной ошибки, обратитесь к администратору реляционной базы данных, чтобы проверить и исправить формат поля, который должен соответствовать формату времени и даты.

Проверьте верхний уровень измерения. При добавлении полей в формате даты и времени как нижних уровней существующей размерности при помощи мастера куба OLAP, мастер не восстанавливает автоматически данные на уровнях год/квартал/месяц/неделя и час/минута/секунда. Мастер выполняет эту операцию восстановления только когда поле, содержащее значение даты или времени, добавляется на верхний уровень нового измерения. Если поле, содержащее значение даты или времени, находится не на самом верхнем уровне, преобразуйте куб данных при помощи мастера куба OLAP в Microsoft Query, либо обратитесь к лицу, создавшему данный куб, для выполнения соответствующих изменений.


 Сводная таблица с Web-страницы вставлена или импортирована неправильно.

Сводная таблица с Web-страницы вставлена или импортирована неправильно.

Воспользуйтесь командой Экспорт в Excel в сводной таблице. При использовании команды Копировать из сводной таблицы на Web-странице с последующей вставкой данных в Microsoft Excel, вставляются только значения, находящиеся в ячейках, и, таким образом, на рабочем листе создается неинтерактивная таблица. При копировании выделяются только те данные, которые отображаются в настоящий момент; отфильтрованные или скрытые данные при этом не выделяются. Чтобы из сводной таблицы в отчет сводной таблицы в Excel были скопированы все данные, следует использовать команду Экспорт в Excel в сводной таблице.

По возможности, измените макет перед тем как экспортировать данные. В сводной таблице на Web-странице могут одновременно отображаться подробные данные и обобщенные данные. Поэтому некоторые макеты, доступные в сводной таблице, могут оказаться несовместимыми с макетами в отчетах сводных таблиц Excel. Для получения дополнительных сведений об изменении макета сводной таблицы для успешного экспорта в Excel, обратитесь к разделу справочной системы по использованию отчета сводной таблицы в обозревателе.


К базе данных, созданной с помощью мастера шаблонов, добавляются пустые записи.

Если на шаге 4 мастера шаблона при создании базы данных были включены записи из существующих книг, то расположение данных в существующих книгах должно соответствовать расположению ячеек, выбранных для полей данных. Например, если на шаге 3 мастера шаблонов было указано, что поле "Идентификатор служащего" вводится в ячейке $D$4 листа "Личные_данные" , то номер служащего должен содержаться во всех существующих книгах в ячейке Личные_данные!$D$4. Если соответствие нарушено, то следует добавить недостающие записи в базу данных.


Неверное отображение рамок.

В данной версии Microsoft Excel рамки применяются не таким способом, как в предыдущих версиях.

Обратите внимание на находящиеся рядом ячейки. Если границы накладываются на выделенную ячейку, то соответствующие границы находящихся рядом ячеек также выделяются. Например, если границы накладываются на ячейки B1:C5, то левая граница ячеек D1:D5 тоже будет выделена.

Проверьте, какая граница была наложена последней. Если к двум находящимся рядом ячейками применяются разные типы границ, то на их общей границе отображается последняя наложенная граница. В более ранних версиях Microsoft Excel преимущества типов границ определялись типом линии.

Выберите подходящий тип границы Еще одним отличием является то, что выделенный диапазон ячеек форматируется как один блок. Например, если необходимо обозначить правую границу диапазона ячеек B1:C5, то граница будет отображена по правому краю ячеек C1:C5. Чтобы отобразить и внутренние границы, выберите кнопку Все границы из палитры Границы.

Проверьте, применяется ли граница к ячейкам, разделенным разрывом страницы. Если границу необходимо применить к ячейкам, разделенным разрывом страницы, а граница отображается только на одной странице, выберите команду Ячейки в меню Формат. Например, необходимо обозначить нижнюю границу последней строки на странице и точно так же обозначить верхнюю границу первой строки на следующей странице. Для этого выделите строки с обеих сторон от разрыва страницы, а затем в меню Формат выберите команду Ячейки. Перейдите к вкладке Граница, а затем в поле Все нажмите кнопку Внутренние [image]. На вкладке Граница удалите вертикальную границу щелчком области просмотра.


Неправильное отображение узора при опубликовании или сохранении данных на Web-странице

Если данные опубликованы или сохранены с поддержкой интерактивных возможностей работы с электронными таблицами, на Web-странице отображаются правильно только границы, составленные из сплошных горизонтальных или вертикальных линий. Границы, которые представляют собой точечные или пунктирные линии, крест-накрест разделяющие ячейку, выглядят на Web-странице как сплошные линии.

При публикации или сохранении данных с возможностью работать со сводными таблицами границы не отображаются.


 Microsoft Excel не может найти файл автономного куба.

Microsoft Excel не может найти файл автономного куба.

Возможно, файл автономного куба (.cub) был переименован или перемещен в другое место.

Убедитесь в том, что имеется доступ к файлу При открытии файла .oqy, полученного из другого источника, убедитесь в том, что у вас имеется доступ к файлу .cub.

Установите местонахождение файла. Если вы пытаетесь подключиться к файлу автономного куба из диалогового окна Настройка “клиент-сервер”, нажмите кнопку Обзор, и укажите размещение файла .cub.

Восстановите соединение с исходной базой данных. Если невозможно найти файл, то, вероятно, существует возможность восстановить подключения отчета к исходной базе данных OLAP на сервере. После этого можно создать новый файл автономного куба. См. сведения о создании файлов автономного куба.


 При публикации или сохранении данных Excel как Web -страницы имена ячеек отображаются неправильно.

При публикации или сохранении данных Excel как Web -страницы имена ячеек отображаются неправильно.

Если публикуемые или сохраняемые данные содержат ссылку на ячейку или диапазон ячеек за пределами публикуемых данных, Microsoft Excel по умолчанию сохраняет весь рабочий лист, но отображает только ячейки в выделенном диапазоне.

В зависимости от того, где располагаются данные на рабочем листе, может оказаться, что ячейка в верхнем левом углу на Web-странице — не ячейка A1. Чтобы эта ячейка была ячейкой A1, выполните следующие действия:

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа, а затем выберите вкладку Общие.

  3. Снимите флажок Сохранять скрытые данные, необходимые для обновления формул.

    Примечания

    • Этот параметр применяется к текущей странице и ко всем страницам, которые в будущем будут сохраняться в Excel.

    • При отказе от сохранения скрытых данных использующие их формулы будут заменены соответствующими вычисленными значениями.


В диалоговом окне “Свойства удостоверения” сертификат был помечен как доверительный источник, однако сертификат не добавлен в список надежных источников.

Если на компьютере установлен Microsoft Internet Explorer 4.0 и Microsoft Office 2000 или Microsoft Excel 2000, диалоговое окно Свойства сертификата появляется при нажатии кнопки Сведения в диалоговом окне Предупреждение системы безопасности; при этом вводится информация о сертификате макроса с цифровой подписью.

Вкладка Доверять в диалоговом окне Свойства сертификата предоставляет возможность доверять сертификату в целом, однако все параметры, выбранные на вкладке Доверять, игнорируются Office 2000 и Excel 2000. Для добавления разработчика макросов в список надежных источников используйте диалоговое окно Предупреждение системы безопасности.


 Отсутствуют некоторые команды и возможности.

Отсутствуют некоторые команды и возможности.

Проверьте, установлены ли на компьютер дополнительные возможности. Возможно, нужная команда или возможность является дополнительной возможностью, выбираемой при установке Excel. См. также сведения об установке дополнительных компонентов. Возможно, команда или возможность поставляются как программа надстройки. См. сведения об установке и загрузке надстроек.

Убедитесь в том, что не используется режим правки ячейки. При правке содержимого ячейки многие команды недоступны. Признаками режима правки ячейки являются размещение курсора (мигающей вертикальной линии) в ячейке и присутствие надписи ПРАВКА в строке состояния. Чтобы завершить правку ячейки и сохранить внесенные изменения, нажмите клавишу ENTER; для отмены внесенных изменений нажмите клавишу ESC.

Проверьте наличие настраиваемых меню или панелей инструментов. Возможно, меню и панели были настроены. Чтобы проверить наличие доступа ко всем имеющимся командам, можно восстановить в исходное состояние встроенные панели инструментов и восстановить исходный набор кнопок на встроенных панелях инструментов.

Проверьте, не была ли открытая книга специально настроена. Открыта книга, которая была специально настроена с помощью программы на Visual Basic. Оригинальные меню и панели инструментов восстановятся при закрытии этой книги или при переходе к другой книге.

Проверьте, доступна ли команда в полном меню. Для просмотра всех команд, доступных в меню, отобразите полное меню.

Убедитесь в том, что с рабочей книгой не работают несколько пользователей одновременно. Некоторые команды и возможности недоступны в режиме совместной работы пользователей с книгой. Признаком совместной работы нескольких пользователей с общей книгой является слово [Общая] в заголовке окна.

Убедитесь в том, что не выбрана диаграмма. Некоторые команды недоступны при работе с диаграммами.

Убедитесь в том, что не был выбран графический объект или карта. Если выбран графический объект или карта, отображаются только команды, доступные в режиме работы с картой или объектом. Чтобы получить доступ к другим командам, щелкните мышью за пределами карты или графического объекта, чтобы снять выделение карты или графического объекта.

Убедитесь в том, что недоступные команды не были отключены администратором сети. Если проводилась автоматическая установка Excel или Microsoft Office, либо установка с сети, возможно, администратор сети сделал некоторые команды и возможности недоступными. Для получения дополнительных сведений обратитесь к администратору сети.

Убедитесь в том, что нужные команды не были изменены в Excel 2000. Команды, использовавшиеся в предыдущей версии Excel, могли быть переименованы или перестали быть доступны в Excel 2000.


Условные форматы применены неверным образом.

  • Проверьте выполнение нескольких условий. Если было указано несколько условий, и данные отвечают более чем одному условию, то в Microsoft Excel будут применены только форматы, отвечающие первому условию.

  • Проверьте наличие пересекающихся условий. Если указаны пересекающиеся условия, то применяется только тот формат, который соответствует первому истинному условию. Например, пусть было задано условие, при котором желтым цветом выделяются ячейки, имеющие значения от 100 до 200 включительно. Также было определено другое условие, при котором ячейки, имеющие значения ниже 120, выделяются красным цветом. Таким образом, ячейки со значениями от 100 до 119.999999999999 будут выделены желтым цветом. Желательно избегать пересекающихся условий.

  • Проверьте ссылки на ячейки. Если в качестве критерия форматирования была использована формула, то в формуле ссылки на ячейки могут оказаться неверными.


 Недоступна база данных, являющаяся источником данных для куба

Недоступна база данных, являющаяся источником данных для куба

При создании куба в Microsoft Query с использованием мастера создания куба или при сохранении файла автономного куба в Microsoft Excel, в куб включаются только выбранные данные.

Подождите, пока не будет завершена загрузка данных. При изменении отчета сводной таблицы или сводной диаграммы, новые данные загружаются из куба данных. При обновлении отчета загружаются новые данные, и куб полностью перестраивается. Для кубов данных, созданных при помощи мастера куба OLAP, данные куба загружаются из исходной реляционной базы данных, что может потребовать некоторого времени.

Обратитесь к лицу, создавшему куб. Если куб был создан не вами, и в списке полей на панели инструментов Сводные таблицы отсутствуют необходимые поля или уровни детализации, попросите лицо, создавшее куб, изменить его так, чтобы куб включал дополнительные данные.

Проверьте содержимое автономного куба Если файл автономного куба (.cub) был создан в Excel, можно изменить файл, чтобы он включал различные данные, в том числе различные измерения, поля данных и уровни детализации.

Проверьте содержимое куба, созданного с помощью мастера куба OLAP. В созданный таким способом куб невозможно добавить данные, однако можно изменить организацию куба и удалить из куба данные. Если в кубе отсутствуют необходимые данные, находящиеся в исходной реляционной базе данных, при помощи Microsoft Query можно создать новый куб, который будет содержать нужные поля. Более подробная информация содержится в справочной системе Microsoft Query. См. также сведения о создании кубов с помощью мастера куба OLAP..


 В файле автономного куба отсутствуют необходимые данные.

В файле автономного куба отсутствуют необходимые данные.

Некоторые данные не были включены в куб при создании файла автономного куба.

Файлы автономного куба, созданные в Excel. Выполните повторное подключение отчета к базе, затем создайте новый автономный файл куба, убедившись в том, что в куб включены все измерения, поля данных и уровни детализации, используемые в отчете. См. сведения об использовании мастера автономного куба.

Файлы автономного куба, созданные в Microsoft Query. Если куб был создан при помощи мастера куба OLAP, и источником данных куба является реляционная база данных, то для добавления необходимых данных нужно создать новый куб. В Microsoft Query откройте файл запроса (.dqy), на основе которого был создан куб, или создайте новый запрос, если файл .dqy не сохранился. Включите в запрос дополнительные поля, которые вы хотите включить в куб, и затем создайте куб заново. Более подробная информация содержится в справочной системе Microsoft Query. См. также сведения о создании кубов с помощью мастера куба OLAP.


Даты и телефонные номера из файла Lotus 1-2-3 отображаются как числа.

Для ячеек, которые содержат дату или номер телефона, был назначен текстовый формат, и в таблице Lotus 1-2-3 в качестве разделителя цифр использовался дефис (например, 2-10-98 или 555-1212). Далее перечислены способы устранения этой проблемы.

Воспользуйтесь приложением Lotus 1-2-3

  1. Откройте файл в Lotus 1-2-3.

  2. Задайте для дат, для которых был назначен текстовый формат, формат дат.

  3. Замените дефисы в датах символами косой черты (/).

Воспользуйтесь приложением Microsoft Excel

  1. Дважды щелкните мышью ячейку.

  2. Удалите знак равенства (=) перед всеми датами и номерами телефонов, затем нажмите клавишу ENTER.

    При отображении дат в качестве разделителя будет использоваться косая черта.

Примечание. Чтобы при отображении дат в качестве разделителя использовался дефис, щелкните мышью ячейку, затем выберите команду Ячейки в меню Формат. Выберите вкладку Число, затем выберите нужный формат в списке Тип.


Десятичная запятая появляется во всех вводимых числах.

В меню Сервис выберите команду Параметры, перейдите к вкладке Правка и снимите флажок Фиксированный десятичный формат при вводе.

Для удаления десятичных запятых из уже введенных чисел, их можно умножить на число, кратное 10. В пустые ячейки введите числа, такие как 10, 100 или 1000, в зависимости от количества десятичных разрядов, которые необходимо удалить. Например, введите в ячейку 100, если нужны целые числа, а введенные содержат два знака после запятой. Скопируйте ячейку, а затем выделите ячейки, содержащие числа с десятичной запятой. (Выделенные ячейки должны быть смежными.) В меню Правка выберите команду Специальная вставка, а затем команду Умножение.


Косые границы накладываются на повернутый текст.

Для наложения границ на ячейки, содержащие повернутый текст нельзя использовать кнопки косых границ [image] и [image] на вкладке Граница (диалоговое окно Ячейки меню Формат). Удалите косые рамки, для этого выделите ячейки и нажмите кнопку Нет [image] в поле Все вкладки Граница. Затем в поле Все нажмите кнопки Внутренние [image] и Внешние [image]. Границы накладываются на границы ячеек, повернутых на тот же угол, что и текст.


 В отчете сводной таблицы отсутствуют требуемые возможности.

В отчете сводной таблицы отсутствуют требуемые возможности.

Источником данных в отчетах сводных диаграмм может являться база данных OLAP. Использует ли отчет сводной таблицы данные OLAP.

Базы данных OLAP поддерживают многие возможности сводных таблиц, например различные итоговые функции, на сервере OLAP, что позволяет ускорить загрузку данных. См. сведения о различиях возможностей, поддерживаемых в отчетах сводных таблиц, для источников данных OLAP и источников данных, отличных от OLAP.


 При закреплении панели инструментов сводной таблицы не удается отобразить список полей.

При закреплении панели инструментов сводной таблицы не удается отобразить список полей.

Список полей отображается только в том случае, если панель инструментов сводной таблицы не закреплена. Чтобы отобразить список полей, панель инструментов нужно сделать незакрепленной. Щелкните мышью ячейку в отчете сводной таблицы и при необходимости нажмите кнопку Отобразить поля [image] .


Обновление связанных данных или переход по гиперссылке занимает много времени

Возможно, занят сервер или узел, на котором размещены указанные данные. Попробуйте выполнить переход по этой гиперссылке или обновить связанные данные позднее. Попробуйте выполнить обновление данных и переходы по гиперссылкам несколько раз в течение суток, чтобы определить, в какие часы время ответа будет наилучшим. Для получения информации о сервере обратитесь к администратору сети.


Невозможно открыть файл Lotus 1-2-3 в Microsoft Excel.

В Excel невозможно открыть некоторые файлы, защищенные паролем.

Отмените парольную защиту на уровне файла

  1. Откройте файл в Lotus 1-2-3.

  2. Сохраните файл без парольной защиты, либо сохраните его как файл формата WKS или WK1.

Примечания

  • В Excel невозможно открыть файлы форматов WKS и WK1, защищенные паролем, и запрашивается пароль перед открытием рабочего листа.

  • В Excel невозможно открыть файлы форматов WK3 или WK4, защищенные паролем на уровне файла.

  • В Excel можно открывать файлы Lotus 1-2-3, защищенные паролем на уровне рабочего листа.


 Итоговая функция, необходимая для куба данных, отсутствует.

Итоговая функция, необходимая для куба данных, отсутствует.

При использовании мастера куба OLAP для создания куба на основе записей в реляционной базе данных, для полей данных доступны только следующие итоговые функции: “Сумма”, “Кол-во значений”, “Минимум” и “Максимум”.

Создайте отчет непосредственно из записей базы данных. Если можно уточнить запрос таким образом, чтобы объем возвращаемых данных не превышал тот объем, который может обработать система, и для данных не нужно создавать куб OLAP, попробуйте настроить запрос так, чтобы из Microsoft Query данные возвращались в Microsoft Excel. При создании отчета сводной таблицы или сводной диаграммы, в основу которой положены записи реляционной базы данных, имеется доступ к полному набору итоговых функций сводных таблиц.

Попробуйте настроить сервер OLAP для базы данных. Серверный программный продукт, выполняющий операции OLAP, Microsoft SQL Server OLAP Services, позволяет задать более широкий диапазон полей, для которых будет вычисляться итоговая функция, чем клиентское программное обеспечение OLAP, поставляемое вместе с Microsoft Office.


При попытке сохранить файл автономного куба не хватает свободного места на диске

Базы данных OLAP предназначены для управления большими объемами подробных данных, и, следовательно, база данных, размещенная на сервере, может занимать значительно больше места на диске, чем имеется на локальном жестком диске. Если для автономного куба данных выбран большой объем данных, свободного места на диске может не хватить.

Освободите место на диске или выберите другой диск. Попробуйте удалить ненужные файлы с диска, прежде чем сохранять файл автономного куба, или попробуйте сохранить файл на сетевом диске.

Уменьшите объем данных, включаемых в файл автономного куба. Подумайте, как можно минимизировать объем данных, включаемых в файл, чтобы при этом файл содержал все данные, необходимые для отчета сводной таблицы или сводной диаграммы. См. сведения об использовании мастера автономного куба. Попробуйте выполнить следующие действия:

  • Исключите некоторые измерения. При работе с мастером автономных кубов на шаге 2 выберите только те измерения, которые действительно будут отображаться как поля в отчетах сводной таблицы и сводной диаграммы.

  • Исключите некоторые уровни детализации. На шаге 2 работы с мастером щелкните знак плюс рядом с каждым из выбранных измерений, и снимите флажки для уровней более низких, чем уровне, отображаемые в отчете.

  • Исключите некоторые поля данных. На шаге 3 работы с мастером щелкните знак “плюс” рядом с полем Измерения, и выберите только те поля данных, которые будут использоваться в отчете.

  • Исключите некоторые элементы данных. На шаге 3 работы с мастером щелкните знак “плюс” рядом с каждым из выбранных измерений, и снимите флажки для элементов, не отображаемых в отчете.

Не отключайтесь от сервера. Если были исключены все ненужные данные, однако по-прежнему сохранить файл автономного куба невозможно, не разрывайте соединение с сервером OLAP, чтобы отчет был непосредственно связан с базой данных.


Не работают команды “Найти” и “Заменить”

Проверьте, не проводится ли поиск по всему содержимому ячейки. В меню Правка выберите команду Найти или Заменить. Снимите флажок Ячейка целиком, а затем снова попытайтесь провести поиск. Флажок показывает, что команды Найти и Заменить ищут только те ячейки, которые содержат символы, указанные в поле Что. Ячейки, содержащие еще какие-нибудь символы, пропускаются.

Проверьте, проводится ли поиск по всему листу. Microsoft Excel проводит поиск только в указанном диапазоне ячеек. Чтобы вести поиск по всему листу, щелкните любую ячейку, чтобы отменить текущий диапазон, и выберите команды Найти и Заменить.

Проверьте, проводится ли поиск значений, полученных по формуле, и комментариев. Чтобы найти константу или значение, полученное по формуле, выберите Значения в списке Область поиска диалогового окна Найти. Чтобы вести поиск в формулах или примечаниях к ячейке, выберите соответственно Формулы или Примечания в списке Область поиска.

Не отображайте специальные символы. Звездочка (*), знак вставки (^), прямые кавычки (") и наклонная черта (\), которые отображаются в строке формул, а не в ячейке, являются символами форматирования. Для их поиска нельзя использовать команды Найти и Заменить. Чтобы скрыть эти символы, выберите пункт Параметры в меню Сервис, а затем — вкладку Переход и установите флажок Клавиши перемещения, использовавшиеся в Lotus 1-2-3.


Открытие файлов, созданных в Quattro Pro

В Microsoft Excel 2000 можно открыть файлы, созданные в Quattro Pro 5.0 for Windows (WB1), Quattro Pro 6.0 for Windows (WB2) и Quattro Pro 7.0 for Windows (WB3).

Установите программу преобразования файлов Quattro Pro. Если при установке Excel еще не была установлена программа преобразования файлов для файлов Quattro Pro, следует установить эту программу, чтобы иметь возможность открывать и сохранять файлы в этом формате.

Чтобы открыть файл в формате Quattro Pro, выполните следующие действия:

  1. В меню Файл выберите команду Открыть.

  2. В поле Тип файлов выберите версию файла Quattro Pro, который нужно открыть.

  3. В поле Папка выберите диск, на котором находится требуемый файл, и затем найдите и дважды щелкните папку, содержащую файл.

  4. Выберите нужный файл, затем нажмите кнопку Открыть.


 Отображаются только самые последние изменения.

Отображаются только самые последние изменения.

Возможно, было отключено ведение журнала изменений. Если ведение журнала изменений для книги было отключено, то отображаются только изменения, сделанные во время текущего сеанса редактирования, так как с момента отключения все пользователи закрыли общую книгу.

Убедитесь в том, что был выбран правильный период времени. Выбрав команду Выделить исправления в подменю Исправления менюСервис, убедитесь в том, что задано правильное значение в поле по времени диалогового окна Выделить исправления.

  • При выборе параметра Со времени последнего сохранения отображаются только изменения, внесенные после последнего сохранения рабочей книги.

  • При выборе параметра Еще не просмотрено отображаются только те изменения, которые не были просмотрены всеми пользователями книги при помощи команды Принять/отклонить исправления подменю Исправления меню Сервис и затем сохранены.

  • Чтобы указать начальную дату, выберите команду С даты, а затем введите дату в поле по времени. Если в поле по времени будет указано Все или будет снят флажок по времени, то отобразятся изменения, внесенные за период ведения журнала изменений.

Дополнительные сведения о просмотре изменений.

Задайте число дней, в течение которых следует хранить журнал изменений. Чтобы сохранить данные об изменениях прошлых сеансов редактирования, необходимо завести журнал изменений для указываемого количества дней. Если требуется вести журнал длительный период времени, то укажите очень большое количество дней, например, 1,000. Для получения более подробных сведений нажмите кнопку [image] .


 Невозможно добавить замечание в обсуждении к рабочей книге.

Невозможно добавить замечание в обсуждении к рабочей книге.

Возможность проведения обсуждений недоступна. Возможность проведения обсуждений становится доступна только после установки на сервере серверных расширений Microsoft Office. Установка этого программного обеспечения должна выполняться администратором сети.

Обновите обсуждения. Недавно добавленные замечания могут не отображаться на экране. Чтобы отобразить панель инструментов Обсуждения, выберите команду Совместная работа в меню Сервис, затем — команду Web-обсуждения. На панели инструментов Обсуждения нажмите кнопку Обсуждения, и затем выберите команду Обновить обсуждения.

Возможно, у вас отсутствуют права доступа к Web-серверу Microsoft Office. Для получения более подробной информации обратитесь к администратору сети.

Возможно, вы работаете автономно. Microsoft Office поддерживает список последних открывавшихся файлов и связанных с ними обсуждений, реплицируя эти файлы на жесткий диск локального компьютера. При автономной работе можно просматривать и фильтровать дискуссии на Web-странице, однако добавить новые дискуссии нельзя.


 Невозможно добавить разработчика макросов в список надежных источников

Невозможно добавить разработчика макросов в список надежных источников

Список надежных источников заблокирован. Возможно, системный администратор заблокировал список надежных источников, поэтому к нему нельзя добавить новых разработчиков макросов.

Возможно, к макросу не была добавлена цифровая подпись. Чтобы можно было добавить разработчика макросов в список надежных источников, разработчик должен добавить к макросу цифровую подпись.

Возможно, на компьютер не был установлен Microsoft Internet Explorer версии 4.0 или более поздней. Чтобы иметь возможность добавлять цифровую подпись к макросу и проверять, находится ли разработчик макросов в списке надежных источников, на компьютер необходимо установить Microsoft Internet Explorer версии 4.0 или более поздней.

Возможно, был выбран низкий уровень безопасности. Чтобы можно было добавить разработчика макросов к списку надежных источников, необходимо установить средний или высокий уровень безопасности.


 Не удается автоматически создать резервную копию Web-страницы

Не удается автоматически создать резервную копию Web-страницы

При сохранении Web-страницы Microsoft Excel не создает резервную копию автоматически. Флажок Всегда создавать резервную копию не применяется к файлам в формате HTML. (Для доступа к этому параметру выберите команду Сохранить как в меню Файл, затем в меню Сервис выберите команду Общие параметры.)

Для сохранения резервной копии рабочей книги в Интернете сохраните исходный файл, затем выберите команду Сохранить как в меню Файл. В поле Имя файла введите новое имя для резервной копии и нажмите кнопку Сохранить. Закройте резервную копию файла и снова откройте исходный файл для продолжения работы с ним.


 Кнопки полей в отчете сводной диаграммы исчезли, и невозможно изменить макет.

Кнопки полей в отчете сводной диаграммы исчезли, и невозможно изменить макет.

  • Возможно, кнопки полей скрыты. Возможно, был установлен флажок Скрыть кнопки полей сводной диаграммы. В этом случае для отображения кнопок полей снимите этот флажок.

  • Возможно, отчет был преобразован в статическую, или обычную, диаграмму. Отчет сводной диаграммы преобразуется в статическую, или обычную, диаграмму, если был удален связанный отчет сводной таблицы, а также при копировании или перемещении отчета сводной таблицы в новую рабочую книгу или при сохранении рабочей книги, которая содержит отчет, в Microsoft Excel 95 или более ранней версии, либо при сохранении в формате, отличном от формата рабочей книги Excel.


Невозможно изменить уровень безопасности в Excel.

Возможно, администратор сети установил более высокий уровень безопасности для вашей рабочей группы, чтобы можно было использовать только не содержащие вирусов макросы. Для получения более подробных сведений обратитесь к администратору сети.


 Команда «Исходные данные» в меню «Диаграмма» недоступна

Команда «Исходные данные» в меню «Диаграмма» недоступна

Если нужно изменить расположение данных для рядов или категорий в отчете сводной диаграммы, или если нужно повторно определить исходные данные, которые нужно включить в диаграмму, не следует использовать команду Исходные данные в меню Диаграмма, как в случае обычной диаграммы. Чтобы изменить расположение данных для рядов или категорий, нужно изменить макет отчета сводной диаграммы, перетащив поля мышью в соответствующие области размещения. Чтобы включить в отчет диаграммы различные источники данных, нужно повторно определить исходные данные, на которых основан отчет сводной диаграммы.


Невозможно экспортировать данные с Web-страницы в Microsoft Excel в Web-обозревателе.

Для экспорта данных с Web-страницы следует использовать Microsoft Internet Explorer 4.01 или более поздней версии и Microsoft Excel 2000. Можно экспортировать только интерактивные сводные таблицы и интерактивные электронные таблицы.

Экспортировать диаграмму с Web-страницы в Excel невозможно. Однако, можно экспортировать исходные данные для интерактивной диаграммы в Excel и затем создать новую диаграмму на основе этих данных.


Невозможно фильтровать данные, опубликованные или сохраненные как Web-страница.

Возможно, данные, которые следует отфильтровать, содержат объединенные ячейки. В интерактивной электронной таблице на Web-странице нельзя фильтровать список, который содержит объединенные ячейки. Разъедините объединенные ячейки в рабочей книге и затем повторно опубликуйте Web-страницу.


 Невозможно отформатировать или отредактировать лист изменений.

Невозможно отформатировать или отредактировать лист изменений.

Скопируйте содержимое на новый рабочий лист. Лист изменений заблокирован и доступен только для просмотра. Его форматирование или редактирование запрещено. Если необходимо изменить порядок столбцов, сделать какие-нибудь другие изменения форматирования или выполнить редактирование, то скопируйте данные из листа изменений в другой лист.

Создайте отдельную копию общей книги. Когда создается копия листа изменений, чтобы иметь возможность его форматирования, рекомендуется сохранить отдельную копию общей книги. Если книга продолжает изменяться, так как с ней работают пользователи, то скопированные данные листа изменений более не относятся к обновленной версии общей книги. Например, расположение ячеек, включая номера строк, записанные в скопированных данных изменений, не могут быть текущими, так как общая книга продолжает изменяться. Чтобы получить последние данные об изменениях, сохраните общую книгу, а затем заново отобразите лист изменений.


 Лист изменений не отображается.

Лист изменений не отображается.

Убедитесь в том, что изменения были сохранены . Все пользователи могли не сохранять изменения с момента включения ведения журнала изменений. Внесите в книгу некоторые изменения, а затем выберите команду Сохранить в меню Файл. После этого можно просматривать лист изменений.

Убедитесь в том, что выбраны правильные параметры выделения исправлений. Возможно, изменения не были выделены для просмотра в листе изменений. Убедитесь, что в диалоговом окне Выделить исправления установлен флажок по времени, а затем из списка по времени выберите Все. Убедитесь, что флажки пользователем и в диапазоне сняты. Установите флажок Вносить изменения на отдельный лист, а затем нажмите кнопку OK.


Не удается открыть файл, созданный в Microsoft Works.

В Microsoft Excel 2000 отсутствует возможность непосредственно открывать файлы, созданные в Microsoft Works версии 3.0 и более поздних версиях. Чтобы открыть такие файлы в Microsoft Excel, следует сначала открыть их в Microsoft Works, в меню Файл выбрать команду Сохранить как и в списке Тип файла выбрать один из следующих форматов. Затем сохранить и закрыть файл, а затем открыть его в Microsoft Excel.

  • Works для Windows версии 2.0/Works для DOS

  • Excel

  • Lotus 1-2-3

Чтобы открыть файл базы данных Microsoft Works в Microsoft Excel, сначала сохраните файл в Microsoft Works в формате dBASE. Затем откройте файл dBASE в Microsoft Excel.


Невозможно опубликовать или сохранить диаграмму с интерактивными возможностями.

Убедитесь в том, что выделена только диаграмма. Чтобы опубликовать или сохранить диаграмму как интерактивную диаграмму на Web-странице, нужно выделить только диаграмму, а не рабочий лист, на котором она размещена.

Убедитесь в том, что данные находятся на рабочем листе. Возможно, диаграмма, которую вы хотите опубликовать, основана на диапазонах данных с двух различных рабочих листов. Убедитесь в том, что все исходные данные для вашей диаграммы размещены на одном рабочем листе.

Убедитесь в том, что несмежные данные добавлены как новые ряды. Возможно, перед опубликованием диаграммы были добавлены данные, несмежные с исходными данными, используемыми для диаграммы, а также добавлены ячейки как новые точки данных, а не как новые ряды. Если данные добавляются к уже существующей диаграмме, и новый диапазон не является смежным с исходным диапазоном, перед публикацией диаграммы убедитесь в том, что ячейки добавляются как новые ряды, а не как точки данных.


Не удается опубликовать или сохранить данные Excel в Web-папке

Опубликование или сохранение данных Excel в Web-папке возможно только в том случае, если на Web-сервере, где находится эта папка, установлены серверные расширения Microsoft FrontPage. На каких серверах были установлены эти средства, можно узнать у системного администратора.

Сохранение Web-страницы на FTP-узле возможно в любом случае.


Невозможно опубликовать или сохранить защищенные паролем данные как Web-страницу.

Данные Microsoft Excel невозможно опубликовать или сохранить как Web-страницу в том случае, если рабочий лист или рабочая книга защищены паролем. Чтобы опубликовать или сохранить данные, снимите пароль, затем заново опубликуйте данные.


 Невозможно обновить данные, опубликованные или сохраненные как интерактивные электронные таблицы на Web-странице.

Невозможно обновить данные, опубликованные или сохраненные как интерактивные электронные таблицы на Web-странице.

Не прибегая к помощи сценариев, невозможно автоматически обновлять диапазон внешних данных в интерактивной электронной таблице. Для обновления данных следует повторно опубликовать электронную таблицу из Excel, используя новые данные.

Чтобы иметь возможность опубликовать диапазон внешних данных, размещенных на Web-странице, опубликуйте или сохраните данные как сводную таблицу. При изменении исходных данных пользователи могут обновлять сводную таблицу из обозревателя. Дополнительные сведения можно найти в справке по Web-компоненту Microsoft Office для списков сводных таблиц или электронных таблиц. Для вывода этой справки щелкните интерактивную электронную таблицу или сводную таблицу на Web-странице в Web-обозревателе, затем нажмите кнопку Справка на панели инструментов элемента управления.


 Невозможно переместить или изменить размер легенды, заголовков или области построения в отчете сводной диаграммы.

Невозможно переместить или изменить размер легенды, заголовков или области построения в отчете сводной диаграммы.

В отчете сводной диаграммы невозможно при помощи мыши изменять размеры легенды, заголовков и область построения. Переместить легенду можно, выбрав вкладку Легенда диалогового окна Параметры диаграммы (меню Диаграмма), и выбрав необходимый параметр в пункте Размещение. Изменить размер заголовка можно, изменяя размер шрифта.

Переместить или изменить размер области построения нельзя; однако, Microsoft Excel автоматически изменяет размер области построения, чтобы отобразить добавления, удаления, а также изменение размеров смежных элементов, например, текста, осей, кнопок полей и легенды.


 Не получается выделить текст или рисунок гиперссылки для его изменения

Не получается выделить текст или рисунок гиперссылки для его изменения

Чтобы выделить текст гиперссылки без перехода в конечный файл, выполните следующее:

  • Щелкните соседнюю с содержащей гиперссылку ячейку и затем, используя клавиши управления курсором, переместитесь на необходимую ячейку.

  • Выделите ячейку, которая содержит гиперссылку, удерживая кнопку мыши, по крайней мере, в течение секунды, а затем отпустите ее.

  • Щелкните ячейку, которая содержит гиперссылку, правой кнопкой мыши, выберите команду Гиперссылка и затем в контекстном меню выберите Изменить гиперссылку.

После того, как гиперссылку удалось выделить, ее можно изменять путем нажатия клавиши F2 или ввода в строку формул.

Чтобы выбрать рисунок гиперссылки без перехода в конечный файл либо щелкните рисунок, удерживая клавишу CTRL, либо нажмите кнопку Выбор объектов [image] на панели инструментов Рисование и затем щелкните рисунок.


Невозможно отправить Web-страницу в виде вложения в сообщение

Web-страницы нельзя отправлять в виде вложений. Если для добавления файла HTML к сообщению электронной почты используется Microsoft Excel, Excel автоматически преобразует файл HTML в формат .xls.

Для отправки копии Web-страницы при помощи электронной почты, нужно отправить копию Web-страницы в виде текста сообщения. В меню Файл выберите команду Отправить, затем выберите команду Сообщение.


Почему не все форматы могут быть использованы в качестве условных?

Форматы ячеек, изменяющие высоту строки и ширину столбца, не могут быть использованы в качестве условных.


Не удается отменить последнее действие

Некоторые действия не могут быть отменены; например, невозможно отменить любую команду меню Файл. Команда Отменить доступна только для тех действий, которые можно отменить.


Невозможно использовать интерактивные данные на Web-странице

Работа с интерактивными данными. С интерактивными данными Microsoft Excel в Интернете могут работать только пользователи с расширенным, профессиональным или стандартным выпусками Microsoft Office 2000. Эти версии Microsoft Office поставляются вместе с Web-компонентами. При наличии выдаваемой на узел лицензии Microsoft Office 2000, можно загрузить эти компоненты из интрасети. Обратитесь за помощью администратору сети.


 Не отображаются макросы в книге или надстройке, открытой в Excel

Не отображаются макросы в книге или надстройке, открытой в Excel

Возможно, макросы были отключены автоматически. Если установлен высокий уровень безопасности, то при открытии рабочей книги или загрузке надстройки, которая содержит макросы без цифровой подписи, макросы отключаются, и запустить их становится невозможно. Чтобы включить макросы без цифровой подписи, следует установить средний уровень безопасности, закрыть рабочую книгу или выгрузить надстройку, после чего снова открыть рабочую книгу или загрузить надстройку. Чтобы в дальнейшем макросы без цифровой подписи автоматически отключались в Microsoft Excel, снова установите высокий уровень безопасности.

Возможно, макросы были отключены при открытии рабочей книги. Если был установлен средний или высокий уровень безопасности и вы отключили макросы, так как не уверены в надежности их источника, то эти макросы нельзя запустить. Чтобы запустить макросы, закройте и снова откройте рабочую книгу или выгрузите и затем повторно загрузите программу надстройки, затем установите флажок Не отключать макросы.


 В качестве начальной страницы установлен файл Office; требуется установить в качестве начальной страницы файл HTML

В качестве начальной страницы установлен файл Office; требуется установить в качестве начальной страницы файл HTML

  1. Откройте Microsoft Excel.

  2. Нажмите кнопку Открыть [image] .

  3. В поле Имя файла введите адрес HTTP Web-страницы и нажмите кнопку Открыть; например, введите http://www.microsoft.com

  4. На панели инструментов Web нажмите кнопку Переход, а затем выберите команду Установить начальную страницу.

  5. Нажмите кнопку Да.

  6. Выйдите из Microsoft Excel.


Был создан файл автономного куба, после чего из отчета сводной таблицы или отчета сводной диаграммы пропали данные.

Возможно, при создании файла автономного куба с помощью мастера автономного куба были пропущены некоторые данные для полей, включенных в отчет. В результате при изменении отчета ожидаемые данные не отображаются, поскольку они отсутствуют в файле автономного куба.

Выполните повторное подключение отчета к базе данных и убедитесь в том, что в отчете отображаются необходимые данные. Затем внесите изменения в файл автономного куба; убедившись в том, что в автономный куб включены все измерения, поля данных и уровни детализации, которые используются в отчете. См. сведения об использовании мастера автономного куба.


Неудовлетворительное качество сканированного изображения

Выполните требуемые действия.

  • Чтобы изменить свойства рисунка и просмотреть рисунок перед сканированием, нажмите кнопку Custom Insert в диалоговом окне Добавить рисунок со сканера или камеры (меню Вставка, подменю Рисунок).

  • Инструкции по изменению параметров изображения содержатся в документации, прилагаемой к данному устройству.


 В общей книге отсутствуют ожидаемые изменения

В общей книге отсутствуют ожидаемые изменения

Включите ведение журнала изменений. Чтобы просмотреть записи об изменениях в общей книге, включите ведение журнала изменений. При отмене режима записи изменений или прекращении совместного использования книги журнал изменений очищается, и становится невозможно просмотреть записи о внесенных изменениях. См. сведения о включении журнала изменений книги.

Убедитесь в том, что другие пользователи сохранили внесенные ими изменения. Другие пользователи могли не сохранить свои изменения. При сохранении общей книги или получении автоматического обновления, от других пользователей принимаются только сохраненные изменения, а не изменения, сделанные ими в своих текущих сеансах редактирования, которые они еще не сохранили.

Убедитесь в том, что Microsoft Excel регистрирует вносимые изменения. Возможно, данные изменения относятся к нерегистрируемым в Excel изменениям (например, изменения форматирования и комментарии). См. список изменений, которые не могут быть выделены.

Убедитесь в том, что был выбран правильный режим выделения исправлений. Выбрав команду Выделить исправления в подменю Исправления менюСервис, убедитесь в том, что в диалоговом окне Исправления выбраны правильные значения параметров.

  • Поле «по времени». Убедитесь, что указан правильный период времени. Если выбрано Со времени последнего сохранения, то будут показаны только те изменения, которые были сделаны после последнего сохранения книги. Если же выбрано Еще не просмотрено, то будут показаны изменения, которые никем из пользователей еще не были просмотрены с помощью команды Принять/отклонить исправления (пункт Исправления в меню Сервис) и затем сохранены. Чтобы указать начальную дату, выберите команду С даты, а затем введите дату в поле по времени. Если в поле по времени будет указано Все или будет снят флажок по времени, то отобразятся изменения, внесенные за период ведения журнала изменений.

  • Параметры поля «пользователем». Убедитесь, что пользователи выбраны верно. Если выбрано Все кроме меня, то будут показаны изменения, сделанные только другими пользователями. Если же будет выбрано Все или флажок пользователем будет снят, то будут показаны изменения, внесенные абсолютно всеми пользователями.

  • Параметры поля «в диапазоне» Убедитесь, что диапазон ячеек введен верно. Чтобы просмотреть изменения для всей книги, снимите флажок в диапазоне.

Дополнительные сведения о просмотре изменений.


 Когда открывается рабочая книга или загружается программа надстройки, которая содержит макрос, не выдается соответствующее сообщение

Когда открывается рабочая книга или загружается программа надстройки, которая содержит макрос, не выдается соответствующее сообщение

Возможно, был установлен низкий уровень безопасности. Чтобы Microsoft Excel выдавал предупреждения о том, что рабочая книга или надстройка содержит макросы, установите средний уровень безопасности.

Возможно, был установлен высокий уровень безопасности, и к макросам не добавлена цифровая подпись. Чтобы Microsoft Excel выдавал предупреждения о том, что рабочая книга или надстройка содержит макросы без цифровой подписи, установите средний уровень безопасности.

Возможно, макрос был создан вами или разработчиком, имя которого вы добавили в список надежных источников. В этом случае Microsoft Excel открывает рабочую книгу и включает макросы. Если вы более не доверяете разработчику макросов, можно удалить разработчика макросов из списка надежных источников. Чтобы Microsoft Excel выдавал предупреждения при каждом открытии рабочей книги или загрузке программы надстройки, содержащей макросы, удалите все источники из списка надежных источников. Чтобы убедиться в том, что все макросы в рабочей книге содержат цифровую подпись, а также чтобы просмотреть источник, из которого получена книга, выберите команду Макрос в меню Сервис, затем выберите команду Редактор Visual Basic. В меню Tools редактора Visual Basic выберите команду Digital Signatures.


 Вспомогательные Web-файлы не нужно хранить в отдельной папке

Вспомогательные Web-файлы не нужно хранить в отдельной папке

При сохранении Web-страницы на Web-сервере, Microsoft Excel по умолчанию хранит все вспомогательные файлы — маркеры, фоновые текстуры и графические файлы — в отдельной подпапке. Если нужно сохранить вспомогательные файлы в той же папке, что и Web-страницу, выполните следующие действия:

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа и выберите вкладку Файлы.

  3. Снимите флажок Создать папку для вспомогательных файлов.

    Примечание. Этот параметр применяется к текущей странице и ко всем страницам, которые впоследствии будут сохраняться в Excel.


 Требуется сохранить ведение журнала изменений без разрешения совместного использования книги.

Требуется сохранить ведение журнала изменений без разрешения совместного использования книги.

Назначьте пароль для защиты рабочей книги. Чтобы завести журнал изменений для книги, ее необходимо сохранить как общую. Если необходимо сделать так, чтобы другие пользователи не могли редактировать книгу, то либо сохраните ее в недоступной для других пользователей области системы, либо назначьте ей пароль. Для получения сведений об установке паролей нажмите кнопку [image] .

Возможно, некоторые функции и операции Microsoft Excel не могут быть занесены в журнал изменений. Некоторые функции и операции Microsoft Excel не могут быть занесены в журнал изменений, так как он может вестись только в том случае, когда для книги разрешено совместное использование. Другие функции, доступные в общей книге, не могут быть выделены или перечислены в листе изменений. Для получения списка функций и операций, которые не доступны в общей книге, нажмите кнопку [image] . Для получения списка функций и операций, которые не могут быть выделены или перечислены в листе изменений, нажмите кнопку [image] .


Пароль, которым защищена книга, не известен

Если книга защищена паролем и этот пароль утерян, открытие книги, ссылка на содержащиеся в ней данные из другой книги, снятие защиты и восстановление данных книги становится невозможным.

Так как при утере пароля доступ к защищенной книге или элементам листа невозможен, рекомендуется держать в надежном месте список всех паролей и соответствующих им книг и листов.


При попытке опубликовать или сохранить данные как Web-страницу выдается сообщение об ошибке

Если при публикации или сохранении данных Microsoft Excel как Web-страницы выдается сообщение о том, что файлу не удается присвоить имя, то причина этой ошибки может заключаться в следующем:

  • Была предпринята попытка опубликовать или сохранить Web-страницу под именем, совпадающим с именем уже созданного файла HTML. Задайте новое имя для файла Web-страницы и затем опубликуйте ее снова.

  • Отсутствует доступ к месту назначения, где вы пытаетесь опубликовать страницу, указан неверный путь или файл уже открыт. Проверьте путь к файлу с указанным именем и убедитесь в том, что в настоящий момент данный файл не открыт ни одним из пользователей.

  • Возможно, объем сохраняемых данных превысил максимально допустимый объем данных, которые можно сохранить, особенно в том случае, если интерактивные данные публикуются в Интернете. Попробуйте уменьшить объем сохраняемых данных.


При выборе базы данных для мастера шаблонов выдается сообщение "Непредвиденная ошибка".

Если на шаге 2 мастера шаблонов был выбран тип базы данных dBASE или Microsoft FoxPro, можно выбрать только папку, в которой содержится база данных. Не следует включать имя файла в поле Укажите имя и положение базы данных.


 Продолжают выдаваться предупреждения о макросах

Продолжают выдаваться предупреждения о макросах

Возможно, макрос, который нужно запустить, получен не из надежного источника. Если установлен средний или высокий уровень безопасности, то при открытии рабочей книги или при загрузке программы надстройки, содержащей макрос с цифровой подписью, полученный не из надежного источника, вы получите предупреждение о наличии макроса. Если вы уверены, что разработчику макроса можно доверять, добавьте его имя в список надежных источников.

Возможно, макрос содержит вирус. Если вы полагаете, что в рабочей книге отсутствуют макросы, то, возможно, компьютер заражен вирусом, добавляющим макровирус в рабочую книгу. Проверьте компьютер на наличие вирусов и попробуйте получить копию рабочей книги, не зараженную вирусом.

Возможно, макрос содержится в файле, который был загружен с Web-узла как страница в формате HTML и затем открыт как временный файл. Если антивирусная программа выдает сообщение об удалении вируса каждый раз при открытии этого файла, это означает, что вирус удаляется из временного файла, а не из исходного файла на Web-сервере. Проверьте компьютер на наличие вирусов и отправьте уведомление о проблемах, связанных с исходным файлом, на адрес источника, откуда получен исходный файл.

Рабочая книга содержит макросы, не нарушающие авторских прав. Microsoft Excel не различает безопасные и небезопасные макросы. Если вы уверены в том, что макросы не нарушают авторских прав и вполне безопасны, возможно, вы решите добавить цифровую подпись к макросу и добавить свое имя в список надежных источников.

Возможно, используется шаблон Excel. Шаблоны Excel по умолчанию не рассматриваются как надежные источники. Даже если установлен флажок Доверять всем установленным надстройкам и шаблонам на вкладке Надежные источники, и на вкладке Уровень безопасности выбран параметр Средняя или Высокая (меню Сервис, подменю Макрос, команда Защита), предупреждение о макровирусе выдается при открытии шаблона, поставляемого вместе с Excel. Чтобы предупреждение не выдавалось, можно установить низкий уровень безопасности, однако перед этим следует убедиться, что все открываемые книги безопасны и не содержат вирусов.


После перемещения Web-страницы в другую папку некоторые ссылки перестали работать

Когда файл сохраняется как Web-страница, все вспомогательные файлы, например маркеры списков, текстуры фона и рисунки, по умолчанию сохраняются во вспомогательной папке. Если Web-страница копируется или перемещается на другое место, необходимо также скопировать или переместить вспомогательную папку, чтобы можно было установить все связи со вспомогательными файлами.

См. сведения об автоматическом обновлении связей.


Невозможно изменить куб OLAP

Убедитесь в том, что исходная база данных доступна. Чтобы изменить куб OLAP, нужно иметь доступ к исходной базе данных на сервере, являющейся источником данных для куба. Убедитесь в том, что эта база данных не была переименована или перемещена в другое место. Убедитесь в том, что сервер доступен, и к нему можно подключиться.

Проверьте, не была ли изменена исходная база данных. Если при создании куба из реляционной базы данных использовался мастер куба OLAP, таблицы в базе данных могли быть переименованы или удалены, вследствие чего исходные данные для куба стали недоступны. Проверьте наличие изменений в структуре или схеме базы данных. Более подробные сведения о действиях, которые для этого следует выполнить, приводятся в справочной системе Microsoft Query; можно также обратиться к администратору баз данных. Если база данных была изменена, возможно, потребуется создать новый куб при помощи Microsoft Query. См. сведения о создании кубов с помощью мастера куба OLAP.


 После опубликования или сохранения Web-страницы невозможно отобразить страницу в Web-обозревателе.

После опубликования или сохранения Web-страницы невозможно отобразить страницу в Web-обозревателе.

Для просмотра интерактивных данных на Web-страницах следует использовать Microsoft Internet Explorer версии 4.01 или более поздней; кроме того, нужно установить на компьютер Web-компоненты Microsoft Office. Эти компоненты могут быть установлены при установке с Microsoft Office 2000, либо, при наличии выдаваемой на узел лицензии Microsoft Office 2000, можно загрузить эти компоненты из интрасети.


Ошибка при попытке перехода к ячейке другой книги

При прослеживании зависимых и влияющих ячеек, Microsoft Excel не может перейти к ячейке книги, если книга не открыта. Откройте книгу, которая содержит эту ячейку, и попытайтесь перейти к ней еще раз.


 Не хватает пространства на диске при попытке получить внешние данные

Не хватает пространства на диске при попытке получить внешние данные

Сколько требуется дискового пространства? При выполнении запроса он временно помещается на жесткий диск. Как правило, необходимо иметь минимум от 3 до 5 Mбайт свободного места на диске, чтобы создать временный файл запроса. Чем больше запрос, тем больше требуется свободного дискового пространства. Если свободного места недостаточно, то выполнение запроса либо займет больше времени, либо не будет доведено до конца.

Проверьте свободное дисковое пространство Чтобы узнать количество свободного места на диске, переключитесь на рабочий стол Windows, дважды щелкните значок «Мой Компьютер», затем выберите необходимый диск. Выберите команду Свойства в меню Файл. Для освобождения места на жестком диске попытайтесь очистить корзину, заархивировать ненужные файлы, удалить их с диска либо удалить компоненты Windows, которые не используются. Для получения более подробных сведений об освобождении дискового пространства смотрите справочную систему Microsoft Windows.

Возможные стратегии при ограниченном дисковом пространстве Если доступное пространство на диске ограничено, попытайтесь выполнить следующее:

  • Упростите запрос Убедитесь, что включены только необходимые для запроса таблицы и поля. Если запрос содержит ненужные таблицы или поля, то удалите их из запроса, чтобы снизить размер временного файла.

  • Используйте условия для уменьшения размера результирующего набора записей Используйте условия для извлечения только определенных записей, а не всех записей из базы данных. Дополнительную информацию можно получить из справочного руководства по Microsoft Query.

  • Установите ограничение числа записей, возвращаемых запросом Ограничьте число записей, возвращаемых запросом В Microsoft Query, выберите команду Параметры в меню Редактирование, установите флажок Макстимальное число возвращаемых записей в группе Параметры и введите максимальное число возвращаемых записей в поле Записи.


 Файл, сохраненный с расширением .xlt, невозможно использовать в качестве шаблона.

Файл, сохраненный с расширением .xlt, невозможно использовать в качестве шаблона.

Microsoft Excel не сохранит файл в формате шаблона, если будет просто указано расширение имени файла .xlt. Чтобы сохранить файл как шаблон, следует выбрать команду Сохранить как в меню Файл. Из списка в окне Тип файла необходимо выбрать Шаблон (*.xlt). В списке Папка укажите место, где будет сохранен шаблон. В окне Имя файла введите имя файла, а затем нажмите кнопку Сохранить.

Чтобы шаблон был доступен в диалоговом окне Создать (меню Файл), сохраняйте пользовательские шаблоны в папке «Шаблоны». Если файл сохранен в другом месте, он может быть только открыт, но использовать его в качестве шаблона нельзя. Сохраняйте стандартные шаблоны книги (Book.xlt) или листа (Sheet.xlt) в папке XLStart или в дополнительной папке автозагрузки. Папка «Шаблоны» обычно располагается в папке
C:\операционная_система\Profiles\имя_пользователя\Application Data\Microsoft\Templates
, а папка XLStart — в
C:\операционная_система\Profiles\имя_пользователя\Application Data\Microsoft\Excel\XLStart
где операционная_система — папка операционной системы, например Windows.


 Сохраненную на файловом сервере Web-страницу не могут найти или просмотреть некоторые пользователи

Сохраненную на файловом сервере Web-страницу не могут найти или просмотреть некоторые пользователи

Если при сохранении Web-страницы на файловом сервере используются длинные имена (имена файлов с пробелами или длиной более 8 символов), пользователи, работающие в Microsoft Windows 3.1 на смогут найти или открыть эту Web-страницу. Windows 3.1 распознает и поддерживает только короткие имена файлов (запись 8.3). Чтобы всегда сохранять файлы Web-страниц с короткими именами файлов, выполните следующие действия:

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа и выберите вкладку Файлы.

  3. Сбросьте флажок По возможности использовать длинные имена файлов.


 Графический объект не отображается на Web-странице

Графический объект не отображается на Web-странице

Существует несколько причин, по которым графический объект может отображаться на Web-странице неправильно.

Настройте параметры обозревателя Поскольку разные обозреватели поддерживают различные версии языка HTML и расширений HTML, текст и графика могут выглядеть по разному на одном и том же компьютере в разных обозревателях. В некоторых случаях вместо графики появляется пустое место, поскольку настройки обозревателя не позволяют отображать графику. Иногда удается отобразить графику, изменив настройки обозревателя.

Просмотрите страницу в различных программах обозревателей. Вновь созданную Web-страницу следует просмотреть в различных Web-обозревателях (некоторые из этих приложений могут быть загружены из Интернета) и с разными настройками монитора. Это позволит убедиться в правильности отображения всех элементов страницы.

Рисунки могут быть отключены в Web-обозревателе Чтобы убедиться в том, что рисунки загружаются, выполните следующие действия:

  1. Откройте Web-страницу в Microsoft Excel.

  2. Выберите команду Параметры в меню Сервис, а затем выберите вкладку Общие.

  3. Нажмите кнопку Параметры Web-документа, а затем выберите вкладку Картинки.

  4. Сбросьте флажок Использовать VML при отображении графики в обозревателях.

Использован неправильный формат изображения Если изображение связано с Web-страницей, а графический формат не поддерживается обозревателем, рисунок не будет показан. Проверьте, что связанное изображение хранится в графическом формате, поддерживаемом Web-обозревателем. Графические форматы JPG и GIF совместимы с большинством обозревателей.

Связанный рисунок мог быть изменен Если в связанный рисунок внесены видимые изменения, например добавление тени, границы или контура, заполнение, изменение контраста или яркости, Excel создает другой рисунок, содержащий эти изменения, для отображения на Web-странице. Когда Web-страница просматривается в Microsoft Internet Explorer 4 или более ранней версии, рисунок появится в измененном виде, но связь с исходным рисунком будет разорвана. Чтобы восстановить связь, нажмите кнопку Сброс параметров рисунка на панели инструментов Настройка изображения.


 На панель обсуждений выводится сообщение о потере или несоответствии данных

На панель обсуждений выводится сообщение о потере или несоответствии данных

Обсуждения хранятся отдельно от остальных данных на соответствующем сервере, а не в книге Excel. Если перемещение книги, которая находилась на Web-сервере, было выполнено без помощи папок Web или Microsoft FrontPage, связи книги с соответствующими замечаниями теряются. Сообщение выводится из-за того, Это происходит Excel не находит обсуждение для текущей книги.

Чтобы восстановить связи книги с ее обсуждением, верните книгу обратно на исходный Web-сервер и перенесите ее с помощью FrontPage. Или можно поместить книгу в папку Web, а затем перенести всю папку Web на новый Web-сервер


 На Web-странице отображается значок X красного цвета

На Web-странице отображается значок X красного цвета

Проверьте правильность всех связей Красный значок X обозначает рисунок, который не найден. Если Web-страница была перемещена или скопирована в другое место без перенесения вспомогательных файлов, связи с рисунками, например фотографиями, маркерами списка или фоновыми текстурами — могут быть разорваны.

Чтобы автоматически делать путь к связанным картинкам относительным при сохранении Web-страниц в Microsoft Excel, выполните следующие действия:

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа и выберите вкладку Файлы.

  3. Установите флажок Обновлять ссылки при сохранении.

    Примечания

    • Когда выбирается этот режим, Excel не переносит и не копирует вспомогательные файлы при перенесении и копировании Web-страницы. Вместо этого адреса на странице изменяются на относительные ссылки.

    • Чтобы обновление произошло, необходимо сохранить перемещенную или скопированную Web-страницу.

    Связанный рисунок мог быть изменен Если в связанный рисунок внесены видимые изменения, например добавление тени, границы или контура, заполнение, изменение контраста или яркости, Excel создает другой рисунок, содержащий эти изменения, для отображения на Web-странице. Когда Web-страница просматривается в Microsoft Internet Explorer 4 или более ранней версии, рисунок появится в измененном виде, но связь с исходным рисунком будет разорвана. Чтобы восстановить связь, нажмите кнопку Сброс параметров рисунка на панели инструментов Настройка изображения.


Сканируется слишком большая или слишком малая часть рисунка

Выполните любое из следующих действий (или оба сразу):

  • Используйте кнопку Custom Insert в диалоговом окне Добавить рисунок со сканера или камеры (меню Вставка, подменю Рисунок) для изменения свойств рисунка и предварительного просмотра рисунка перед сканированием.

  • Инструкции по изменению параметров изображения содержатся в документации по данному устройству.


 Ведение журнала изменений включено, но изменения не отображаются.

Ведение журнала изменений включено, но изменения не отображаются.

При включении ведения журнала изменений данные об изменениях ведутся с момента включения и в течение указанного количества дней. Чтобы просмотреть сведения об изменениях, внесите их и включите выделение изменений. Для просмотра изменений в листе изменений сохраните книгу и отобразите лист изменений. Для получения более подробных сведений нажмите кнопку [image] .


 При попытке открытия в Excel файла HTML этот файл открывается в другой программе Office

При попытке открытия в Excel файла HTML этот файл открывается в другой программе Office

Когда в диалоговом окне Открыть (меню Файл) выбирается файл HTML (Web-страница) и нажимается кнопка Открыть или дважды щелкается файл, он открывается в программе, которая его создала. Например, если попытаться открыть в Microsoft Excel файл HTML, созданный в Microsoft Word, файл будет открыт в Word.

Чтобы открыть такой файл HTML в Excel, щелкните файл в диалоговом окне Открыть правой кнопкой мыши и выберите Открыть в Microsoft Excel в контекстном меню.


 При попытке защиты совместного доступа не удается ввести пароль в поле «Пароль».

При попытке защиты совместного доступа не удается ввести пароль в поле «Пароль».

Защита общей книги Если к книге уже был открыт общий доступ, можно защитить ее и журнал изменений , установив флажок Общий доступ с исправлениями в команде Защитить общую книгу (подменю Защита меню Сервис). Однако такая защита не позволяет назначить пароль.

Назначение пароля книге Чтобы назначить пароль, сначала отмените общий доступ к книге и затем защитите книгу, выбрав команду Защитить книгу и дать общий доступ в подменю Защита меню Сервис. После установки флажка Общий доступ с исправлениями и указания пароля книга автоматически возвращается в режим общего доступа. Поскольку сохраненный журнал изменений очищается при запрещении общего доступа к книге, журнал изменений будет фиксировать изменения, внесенные после возврата книги в режим общего доступа.


 Команда «Защита книги» недоступна при попытке защитить общую книгу

Команда «Защита книги» недоступна при попытке защитить общую книгу

Временно запретите общий доступ Пока книга является общей, защитить ее нельзя. Если необходимо защитить общую книгу, то прежде всего, необходимо временно прекратить ее совместное использование. После этого ее можно защитить, а затем использовать команду Доступ к книге (меню Сервис), чтобы снова сделать книгу общей.

Примечания

  • При запрещении общего доступа к книге история изменений автоматически удаляется.

  • Для получения дополнительных сведений нажмите кнопку [image] .

Назначение пароля книге Чтобы назначить книге пароль, используйте команду Защитить книгу (меню Сервис, подменю Защита submenu). При выполнении этой операции книга не должна быть общей.

Обратите внимание, что защита книги отличается от защиты общего доступа и журнала изменений. Когда книга защищается с помощью команды Защитить книгу (менюСервис, подменюЗащита), общий доступ к книге устанавливается после назначения пароля. Когда пароль назначается с помощью флажка Общий доступ с исправлениями, общий доступ устанавливается автоматически. (Чтобы найти этот флажок, выберите подменю Защита в меню Сервис и выберите команду Защитить книгу и дать общий доступ.)


 Не действуют клавиши перемещения, такие как PAGE UP, HOME и SHIFT+TAB

Не действуют клавиши перемещения, такие как PAGE UP, HOME и SHIFT+TAB

  • Возможно, установлены функции клавиш, используемые в Lotus 1-2-3. В меню Сервис выберите команду Параметры, а затем — вкладку Переход. Снимите флажок Клавиши перемещения 1-2-3 и попытайтесь снова использовать клавишу.

  • Чтобы можно было прокручивать выделенные ячейки, отключите режим прокрутки листа. Если этот режим включен, клавиши перемещения не оказывают влияния на текущее выделение.


Ссылки на другие листы Lotus 1-2-3 не преобразуются правильно или содержат ошибки #ССЫЛКА!

Когда лист Lotus 1-2-3 открывается в Excel, необходимо нажать кнопку Да, если будет предложено обновить книгу с преобразованием связей внутри листа. Когда лист преобразуется в Excel, можно обновить связи с другими листами Lotus 1-2-3 или преобразовать все книги в Excel и соответствующим образом изменить ссылки.

Исправьте ошибки #ССЫЛКА!

  1. В Excel закройте преобразованные листы без сохранения изменений.

  2. Откройте лист в Excel снова, нажмите кнопку Да, когда будет предложено обновить книгу.

Оставьте ссылки на другие листы Lotus 1-2-3 при преобразовании в Excel

  1. Проверьте, что связанные листы Lotus 1-2-3 закрыты.

  2. В Excel откройте лист Lotus 1-2-3, содержащий связи, и нажмите кнопку Да, когда будет предложено обновить книгу.

  3. В меню Файл выберите команду Сохранить как и затем выберите Книга Microsoft Excel из списка в поле Тип файла.

Измените ссылки, чтобы использовать преобразованные книги Excel

  1. В Excel откройте все связанные листы Lotus 1-2-3.

  2. Откройте на лист со ссылками.

  3. Для каждого связанного листа в меню Файл выберите команду Сохранить как и затем выберите Книга Microsoft Excel из списка в поле Тип файла.

  4. Сохраните книгу, содержащую связи.


 Изменение макета или представления отчета сводной таблицы или сводной диаграммы занимает много времени

Изменение макета или представления отчета сводной таблицы или сводной диаграммы занимает много времени

Если внешний источник данных или источник данных, созданный с помощью мастера куба OLAP, содержит слишком большой объем данных, перетаскивание полей с происходит с заметной задержкой.

Перетаскивайте элементы данных в последнюю очередь. В отчете сводной таблице в первую очередь следует перетаскивать поля в области строк, столбцов и страниц. В отчете сводной диаграммы сначала перетаскиваются поля в области рядов, категорий и страниц. Поля в область данных следует перетаскивать последними. Такой подход позволит существенно уменьшить объем данных, отображаемых на промежуточных шагах.

Упростите отчет Исключите некоторые поля или используйте меньший источник данных для отчета сводной таблицы или сводной диаграммы.

Используйте мастер для изменения макета Можно использовать мастер сводных таблиц и сводных диаграмм для изменения макета сводной таблицы или сводной диаграммы. Когда используется мастер, можно внести несколько изменений в макет, а затем извлечь и отобразить данные за один шаг.


 Автоматическое изменение таких форматов как цвет шрифта и затенение ячейки.

Автоматическое изменение таких форматов как цвет шрифта и затенение ячейки.

Если к ячейке был применен условный формат, то формат, используемый Microsoft Excel, зависит от того, отвечает ли значение ячейки или другие числовые данные определенным условиям.

  • Если условие форматирование основано на значениях выделенных ячеек, то ячейки, содержащие текст, расцениваются как строки ASCII. Такие форматы, как жирное начертание и цвет шрифта, могут изменяться при изменении текста.

  • Условные форматы имеют приоритет над форматами, применяемыми к ячейкам при помощи команды Ячейки (в меню Формат) или кнопки на панели инструментов Форматирование. Если указанное условие является верным, то определенный для него формат имеет приоритет над ручным форматированием.


 Вычисляемое поле или элемент поля отображает неправильное значение

Вычисляемое поле или элемент поля отображает неправильное значение

Вычисляемые поля и вычисляемые элементы полей обрабатываются по-разному. Формулы для вычисляемого поля могут воздействовать на сумму текущих данных любых полей, указанных в формуле. Например, в формуле «'Сумма по доходу' * 1,2» происходит умножение сумм заказов для каждого продукта и распространителя на 1,2, а затем итоговое суммирование; умножение каждого отдельного элемента поля на 1,2 с последующим суммированием не выполняется.

Формулы для вычисляемого элемента могут воздействовать на отдельные элементы поля; формула для вычисляемого элемента «Рыбные *115%» умножает каждый элемент в поле «Рыбные» на 115%, а затем полученные значения суммируются в области данных.

Проверка формул. Убедитесь в том, что все формулы для вычисляемых полей и элементов полей сводной таблицы введены правильно. Чтобы просмотреть список формул, выберите мышью отчет сводной таблицы, выполните команду Формулы (панель инструментов Сводная таблица, меню Сводная таблица), а затем — команду Вывести формулы. При работе с отчетом сводной диаграммы можно воспользоваться командой Формулы (панель инструментов Сводная таблица, меню Сводная диаграмма), а затем выбрать команду Вывести формулы.

Проверка порядка вычислений. Проверьте порядок вычисления формул, если для расчета элемента было задано несколько формул. При необходимости неправильный порядок вычисления может быть изменен.


Изменение цвета фона ячеек при сохранении или опубликовании данных на Web-странице

При публикации ячеек на Web-странице без интерактивных возможностей, цвет фона ячейки, если он не указан, будет таким же, как у соседних ячеек. Чтобы этого не происходило, выберите для ячейки белый цвет фона, а затем опубликуйте данные еще раз.


Не удается сохранить или опубликовать диаграмму на Web-странице

При сохранении или опубликовании листа (или его части) с интерактивными возможностями, содержащаяся в нем диаграмма на Web-странице не сохраняется. Чтобы диаграмма или отчет сводной таблицы отображались на Web-странице, они должны быть сохранены или опубликованы отдельно от листа. См. Как разместить интерактивную диаграмму на Web-странице.


Диаграмма не измеряет и не выводит на экран данные требуемым образом

Разные типы диаграмм измеряют и выделяют разные аспекты данных. Так, хорошим средством для демонстрации вклада отдельных частей в общую сумму является круговая диаграмма, гистограмма же позволяет проиллюстрировать отношение отдельных элементов друг к другу и их изменение во времени. Для получения примеров типов диаграмм нажмите кнопку [image] .

В диаграмме типы диаграмм могут комбинироваться. Для получения дополнительных сведений нажмите кнопку [image] .


Не удается добавить отсканированный рисунок или фотографию

Возможны следующие варианты действий.

  • Если нажатие кнопки Insert в диалоговом окне Добавить рисунок со сканера или камеры (меню Вставка, подменю Рисунок) не дает нужного результата, попробуйте воспользоваться кнопкой Custom Insert.

  • Если таким образом вопрос решить не удается, обратитесь за дополнительными новыми сведениями к изготовителю устройства (или посетите его Web-страницу).


Преобразованный файл имеет очень большой размер и открывается очень долго

В результате работы над файлом в приложении Lotus 1-2-3 целые столбцы данных могут иметь особое форматирование. При открытии этого файла в Microsoft Excel выполняется автоматическое преобразование всех форматированных ячеек независимо от наличия в них данных. Электронная таблица при этом становится очень большой, а работа с ней резко замедляется. Избежать этого неудобства помогут следующие меры.

Удаление пустых ячеек в Lotus 1-2-3

  1. Откройте исходный файл WK4 в приложении Lotus 1-2-3 и выделите пустые ячейки, расположенные ниже последней ячейки с данными.

  2. В меню Edit выберите команду Delete, а затем нажмите кнопку OK.

  3. После сохранения данных и закрытия электронной таблицы откройте соответствующий файл в Excel.

Решение вопроса средствами Excel

  1. В Excel выделите все пустые строки ниже последней ячейки листа, в которой содержатся данные.

  2. В меню Правка выберите команду Удалить.

  3. Сохраните книгу.


Не срабатывают сообщения и ограничения на данные

Если ограничения и сообщения, установленные с помощью команды Проверка меню Данные, не действуют, следует проверить следующее.

Правильность задания ограничений для ячеек. Убедитесь в том, что на содержимое ячеек действительно были наложены ограничения. Для этого просмотрите все ячейки, имеющие ограничения. Чтобы получить более подробные сведения, нажмите кнопку [image] .

Ввод данных в ячейки. Убедитесь в том, что пользователи вводят данные в ячейки вручную. Так как при использовании копирования и заполнения сообщения об ошибке не отображаются, в ячейки могут быть занесены неверные данные.

Отключение пересчета вручную. При использовании пересчета вручную ячейки, значение которых не вычислено, могут помешать правильной проверке данных. Чтобы отключить пересчет вручную, выберите Параметры в меню Сервис, а затем перейдите на вкладку Вычисления. Выберите параметр Автоматически в группе Производить пересчет.

Отсутствие в формулах ошибок. Проверьте, что в формулах нет таких ошибок, как #ССЫЛКА! или #ДЕЛ/0!. Microsoft Excel не учитывает ограничения на данные в таких ячейках до тех пор, пока ошибочные значения не будут исправлены.

Правильность ссылок в формулах. После изменения содержимого ячейки, на которую ссылается формула, результат вычисления последней может не соответствовать ограничениям для ячейки с этой формулой. Сообщение об ошибке в этом случае не отображается.

Примечание. Отыскать ячейки с ограничениями, которые содержат недопустимые значения, можно даже в том случае, если данные в эти ячейки были помещены в результате вычисления по формуле, копирования, заполнения или работы макроса. Чтобы получить более подробные сведения о проверке листа, нажмите кнопку [image] .


 Неправильный формат шрифта на Web-странице

Неправильный формат шрифта на Web-странице

При работе с Microsoft Internet Explorer 2.0, Netscape Navigator 3.0 (или более ранней версией этого приложения), а также с любым другим обозревателем, не поддерживающим стилей CSS, размер сохраняемого и публикуемого в виде Web-страницы файла можно уменьшить. Для этого следует использовать только один формат HTML.

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа, а затем выберите вкладку Общие.

  3. Снимите флажок Использовать CSS при форматировании шрифтов.

    Примечание. Этот параметр применяется к текущей странице и ко всем страницам, которые в будущем будут сохраняться в Excel.


Не отображаются линии сетки после выбора гиперссылки на новый лист

После добавления гиперссылки в новый файл (.htm) и последующего перехода через нее на соответствующую Web-страницу линии сетки листа могут быть не видны. Чтобы включить отображение этих линий, выполните следующие действия.

  1. Выберите Web-страницу, на которую ведет данная гиперссылка.

  2. В меню Сервис приложения Microsoft Excel выберите пункт Параметры.

  3. Перейдите на вкладку Вид.

  4. В группе Параметры окна установите флажок Сетка.


Не удается выполнить преобразование формул Lotus 1-2-3

Некоторые функции Lotus 1-2-3 не имеют эквивалентов в Microsoft Excel. Ячейки с непреобразовавшимися формулами снабжаются соответствующими примечаниями и содержат последние результаты вычислений в Lotus 1-2-3.

Для разрешения этого вопроса необходимо, ознакомившись с примечаниями, найти соответствующие ячейки с формулами и ввести в них новые формулы. Для отображения всех примечаний выберите пункт Примечания в меню Вид.

Создание формул в Microsoft Excel

Различия в функциях Lotus 1-2-3 и Microsoft Excel

Эквиваленты функций Lotus 1-2-3 в Microsoft Excel

Различия в вычислениях формул в Microsoft Excel и Lotus 1-2-3

Ввод формулы для вычисления значения


Неправильное отображение узора при опубликовании или сохранении данных на Web-странице

В сохраняемых на Web-странице данных Microsoft Excel этот вид форматирования не поддерживается.

Вместо узоров ячейки можно выделять цветом или границей в виде сплошной линии.


Неправильное отображение отчета сводной таблицы, который публикуется или сохраняется в качестве Web-страницы

При опубликовании или сохранении отчета сводной таблицы в качестве Web-страницы некоторые элементы оформления могут теряться. Например, на Web-страницы не переносятся форматирование ячеек, границы, узоры, а также некоторые типы полей данных. См. сведения об ограничениях в публикуемых на Web-странице отчетов сводных таблиц.


 Отсутствие подписей при печати некоторых страниц

Отсутствие подписей при печати некоторых страниц

Microsoft Excel печатает подписи строк и столбцов только на тех страницах, которые содержат снабженные этими подписями строки и столбцы. Так, если в качестве повторяющихся подписей строк выбраны ячейки A1:A5, Excel не выводит эти подписи на тех страницах, где присутствуют строки только начиная с пятой. При выборе в качестве повторяющихся подписей столбцов ячеек A1:E1 они будут отсутствовать при печати тех страниц, столбцы которых начинаются с E. Чтобы подписи выводились на всех страницах, их следует скопировать в дополнительные строки или столбцы.

Копирование подписей строк в дополнительные строки

  1. Выделите ячейки, содержимое которых должно использоваться в качестве повторяющихся подписей строк, и нажмите кнопку Копировать [image] .

  2. Выделите расположенные в тех же столбцах ячейки дополнительных строк, в которые требуется поместить подписи, и нажмите кнопку Вставить [image] .

  3. В меню Файл выберите команду Параметры страницы, а затем вкладку Лист.

  4. В поле сквозные столбцы укажите целые столбцы, в которых содержатся подписи строк. Например, для повторения подписей строк, скопированных в ячейки столбца A, следует ввести $A:$A.

Копирование подписей столбцов в дополнительные столбцы

  1. Выделите ячейки, содержимое которых должно использоваться в качестве повторяющихся подписей столбцов, и нажмите кнопку Копировать [image] .

  2. Выделите расположенные в тех же строках ячейки дополнительных столбцов, в которые требуется поместить подписи, и нажмите кнопку Вставить [image] .

  3. В меню Файл выберите команду Параметры страницы, а затем вкладку Лист.

  4. В поле сквозные строки укажите строки с подписями столбцов. Например, для повторения подписей столбцов, скопированных в ячейки строк 1 и 2, следует ввести $1:$2.


 Данные запроса отсутствуют или не обновляются должным образом

Данные запроса отсутствуют или не обновляются должным образом

При работе с Web-запросом, который был создан в Microsoft Excel 97, следует помнить, что в Microsoft Excel 2000 (в отличие от Excel 97) рисунки извлекаются автоматически. Наличие рисунков в извлекаемых запросом данных Web-страницы может приводить к ошибкам в вычислении формул. Это связано с перемещением данных и формул при вставке рисунков. Чтобы избежать подобных ошибок, отключите выборку рисунков в Excel 2000.

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа, а затем выберите вкладку Общие.

  3. Снимите флажок Загружать с Web-страниц рисунки, не созданные в Excel.

    Примечание. Этот параметр применяется к текущей странице и ко всем страницам, которые в будущем будут сохраняться в Excel.


 Запрос выполняется слишком долго или компьютер не реагирует на внешние воздействия.

Запрос выполняется слишком долго или компьютер не реагирует на внешние воздействия.

Создание более простого запроса. Убедитесь, что в запрос включены только необходимые таблицы и поля. Если запрос содержит лишние таблицы или поля, то для выборки данных потребуется больше времени, так как перед отображением таблицы результатов будет осуществляться поиск записей во всех таблицах и выбор данных для всех полей.

Проверка правильности используемого в запросе объединения. Мастер запросов автоматически создает внутреннее объединение, если в одной таблице данных имеется первичный ключ, а в другой — поле с тем же именем. Если объединение изменяется на внешнее объединение с помощью модификации запроса в Microsoft Query, убедитесь, что оно верно. Если запрос содержит неверное объединение таблиц, выборка данных займет больше времени. Дополнительные сведения об объединениях и их влиянии на запрос можно найти в справке Microsoft Query.

Ограничение размеров таблицы результатов с помощью условий. Чтобы в выборку попадали только нужные записи базы данных, для них должны быть определены соответствующие условия. Microsoft Query использует условия для получения необходимых записей, которые отображаются в результатах запроса. Так, для просмотра сведений только по поставщикам во Франции укажите, что поле «Страна» должно содержать значение «Франция». Дополнительные подробности по этому вопросу можно найти в справке Microsoft Query.

Проверка наличия необходимого места на жестком диске. Создаваемый запрос временно хранится на жестком диске компьютера. Недостаток свободного места может привести к увеличению времени выборки данных и даже к преждевремменому завершению запроса.

Выполнение запроса в момент наименьшей загрузки сервера. Если необходимые данные находятся на сервере, то в то время, когда он занят, получение этих данных займет больше времени. Чтобы обойти эту проблему, рекомендуется создать пакетный файл, предназначенный для получения данных в другое время, например, после обычных часов работы. Более подробные сведения о создании пакетного файла можно найти в руководстве программиста по Visual Basic для Microsoft Office 97 (Microsoft Office 97/Visual Basic Programmer's Guide).

Выполнение запроса в фоновом режиме. При выполнении запроса может показаться, что компьютер перестал реагировать на внешние воздействия. Чтобы прекратить выполнение запроса, нажмите клавишу ESC. Попытайтесь снова выполнить запрос, но уже в фоновом режиме, для того, чтобы можно было продолжать использовать компьютер во время получения данных. Для получения более подробных сведений нажмите кнопку [image] .

Чтобы проверить состояние выполняющегося в фоновом режиме запроса, который занимает много времени, нажмите кнопку Состояние обновления [image] на панели инструментов Внешние данные. Если запрос необходимо отменить, то нажмите кнопку Прервать.


 Неправильное отображение знаков языка при просмотре самостоятельно созданной Web-страницы

Неправильное отображение знаков языка при просмотре самостоятельно созданной Web-страницы

При открытии Web-страницы Microsoft Excel пытается определить ее кодировку. Если при просмотре в Web-обозревателе содержащиеся на странице знаки отображаются неправильно, нужную кодировку страницы можно выбрать вручную. Путем подбора найдите ту кодировку, при которой текст отображается правильно.

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа, а затем выберите вкладку Кодировка.

  3. В списке Загрузить текущий документ как: выберите предполагаемый язык кодировки страницы.


Вывод значения #ИМЯ? при опубликовании или сохранении данных Excel, содержащих функции пакета анализа

Значение ошибки #ИМЯ? может выводиться при опубликовании или сохранении данных Microsoft Excel на Web-странице в том случае, если в системе отсутствует необходимый для правильной работы функций Excel файл Msowcf.dll. Переустановите Microsoft Office 2000 или обратитесь к системному администратору.


 Отсутствует стрелка в поле отчета сводной таблицы или диаграммы

Отсутствует стрелка в поле отчета сводной таблицы или диаграммы

Поле должно соответствовать размерности куба. В отчетах сводной таблицы и сводной диаграммы, источником которых являются базы данных OLAP, стрелка стрелка поля на кнопке поля размерности, расположенного в области строк и столбцов отчетов сводных таблиц или в области рядов и категорий отчетов сводных диаграмм, отображается только в том случае, когда соответствующее поле относится к самому верхнему уровню размерности. Эта стрелка позволяет отображать или скрывать различные уровни подробности данных, которые представлены в размерности. См. раздел Использует ли отчет сводной таблицы или сводной диаграммы данные OLAP.

Отображение верхних уровней. Если верхние уровни размерности скрыты, верхнее поле также не отображается, а выводимые на экран поля не имеют стрелки Стрелка поля. Чтобы показать скрытые уровни и стрелку верхнего поля размерности, щелкните правой кнопкой мыши любую кнопку поля размерности и выберите в контекстном меню команду Вывод уровней.


 Отсутствует список полей отчета сводной таблицы или сводной диаграммы

Отсутствует список полей отчета сводной таблицы или сводной диаграммы

Отображение незакрепленной панели инструментов «Сводная таблица». Список полей отчета может отображаться только на незакрепленной панели инструментов Сводная таблица. Если панель Сводная таблица не отображается, ее необходимо вывести на экран. Панель инструментов также нужно сделать незакрепленной.

Выбор соответствующего отчета. Отображение списка полей на панели инструментов Сводная таблица возможно только после выбора отчета. Чтобы выбрать отчет, щелкните мышью любую ячейку отчета сводной таблицы или диаграммы.

Отображение списка полей. Нажмите кнопку Отобразить поля на панели инструментов Сводная таблица [image] (она должна быть в утопленном положении).


 Не обновляются данные сводной таблицы или сводной диаграммы

Не обновляются данные сводной таблицы или сводной диаграммы

Отсутствие обновления данных может быть связано с невозможностью подключения к исходной базе данных на сервере и, следовательно, обновления данных автономного куба или куба, созданного в приложении Microsoft Query с помощью мастера куба OLAP.

Доступность исходной базы данных. Проверьте путь к базе данных на сервере, которая является источником данных для куба. Убедитесь в том, что база данных не была переименована или перемещена в другое место. Удостоверьтесь также в том, что сервер доступен и к нему можно подключиться.

Доступность новых данных. Выясните у администратора базы данных, обновлялись ли именно те данные, которые должны быть включены в отчет.

Неизменность организации базы данных. Структура куба OLAP на сервере или реляционной базы данных, которая является источником данных куба, может измениться. Для доступа к изменившимся данным в этом случае может потребоваться внесение соответствующих поправок в отчет, подготовка нового файла автономного куба или создание куба с помощью соответствующего мастера. Необходимые сведения об имевших место изменениях можно получить у администратора базы данных. См. также сведения о создание файлов интерактивного куба и сведения о создании кубов с помощью мастера куба OLAP.


 При попытке добавить отсканированный рисунок или фотографию выдается сообщение

При попытке добавить отсканированный рисунок или фотографию выдается сообщение

Установка на компьютер программного обеспечения для соответствующего устройства. При подключении сканера или фотоаппарата и установке необходимого для их работы программного обеспечения необходимо в точности следовать указаниям производителя оборудования. На компьютер должно быть установлено все программное обеспечение, которое входило в комплект поставки устройства.

Поддержка протокола TWAIN. Убедитесь в том, что устройство поддерживает работу с протоколом TWAIN. На компьютер также должно быть установлено поставляемое с устройством программное обеспечение для работы с этим протоколом. Сведения о поддержке протокола TWAIN обычно приводятся в технической документации на устройство. Эти сведения можно также получить непосредственно у производителя оборудования. Повторите попытку добавления рисунка после установки необходимого программного обеспечения.

Добавление рисунка в другой программе. Если необходимое программное обеспечение установлено, но добавить отсканированный рисунок или фотографию в Microsoft Excel все равно не удается, попробуйте выполнить эту задачу в другом приложении, которое поддерживает работу с протоколом TWAIN. Возможно, это удастся сделать в Microsoft Publisher 98, Microsoft Picture It! версии 2.0 или в Microsoft FrontPage 98 (или в более поздних версиях перечисленных программ). Если в другой программе рисунок добавить удается, попробуйте для вставки рисунка в Microsoft Excel воспользоваться кнопкой Custom Insert диалогового окна Добавить рисунок со сканера или камеры (меню Вставка, подменю Рисунок).

Кнопка «Custom Insert». Поставляемое с устройством программное обеспечение не всегда поддерживает функцию автоматического сканирования. В этом случае, чтобы добавить рисунок, попробуйте воспользоваться кнопкой Custom Insert вместо обычной кнопки Insert диалогового окна Добавить рисунок со сканера или камеры (меню Вставка, подменю Рисунок).


Параметр поворота текста не действует или не отображается на экране

В Microsoft Excel нельзя повернуть сдвинутые ячейки и ячейки, отформатированные при помощи параметров "По центру" и "С заполнением" в поле Горизонтальное вкладки Выравнивание (в меню Формат команда Ячейки). Если все выделенные ячейки были отформатированы указанными выше способами, то параметр поворота текста в поле Ориентация не отображен. Если среди выбранных ячеек есть ячейки, отформатированные иным способом, то параметры поворота отображены на экране. Однако, поворот ячеек, отформатированных выше названными способами, осуществляться не будет.


 Числа не отображаются или не вычисляются как числовые значения.

Числа не отображаются или не вычисляются как числовые значения.

Если числа выровнены по левому краю ячейки, и выравнивание, установленной по умолчанию (Обычное), не изменялось, то форматируемые или вводимые числа воспринимаются как текст. Для преобразования чисел в числовые данные необходимо выполнить следующие действия.

  1. Выделите пустую ячейку, имеющую обычный числовой формат.

    Чтобы определить, какой формат у данной ячейки, выберите команду Ячейки в меню Формат и перейдите к вкладке Число. В поле Числовые форматы выберите Обычные и нажмите кнопку OK.

  2. Введите в ячейку цифру 1 и нажмите клавишу ENTER.

  3. Выберите соответствующую ячейку, а затем нажмите кнопку Копировать [image] на панели инструментов Форматирование.

  4. Выделите диапазон ячеек, содержащих числа в текстовом формате.

  5. В меню Правка выберите команду Специальная вставка, потом операцию Умножить, а затем нажмите кнопку OK.


 Сообщение о потере данных во время изменения куба OLAP

Сообщение о потере данных во время изменения куба OLAP

Включенное в куб поле больше недоступно в исходной базе данных.

Проверка изменений в исходной базе данных. При работе с автономным файлом куба, созданным на основе базы данных OLAP на сервере, выполните повторное подключение отчета к базе, после чего проверьте доступность полей на панели инструментов Сводная таблица. Если поле базы данных стало недоступным, можно создать новый автономный файл куба.

Если источником куба является реляционная база данных, а сам куб был создан в приложении Microsoft Query с помощью мастера создания куба, откройте файл запроса (.dqy), на основе которого был создан куб, в Microsoft Query. Если файл запроса не сохранился, создайте новый запрос. Проверьте доступность полей. Более подробные сведения о том, как это сделать, приводятся в справке Microsoft Query. Если поля из базы данных были удалены, можно создать новый куб. См. сведения о создании кубов с помощью мастера.


Примечание отображается не полностью

  1. Щелкните правой кнопкой мыши ячейку с примечанием, а затем выберите команду Изменить примечание в контекстном меню.

  2. Настройте размеры и форму примечания, перемещая мышью маркер изменения размеров.

Примечание. Просмотру примечаний могут препятствовать закрепленные области. В этом случае примечание выводится в верхней части окна или листа, в то время как нижняя или правая его часть обрезается. Чтобы примечание отображалось полностью, выберите команду Снять закрепление областей в меню Окно.


Не удается вывести несколько областей печати на одной странице

Если область печати на листе Microsoft Excel охватывает несколько несмежных групп ячеек, каждая из них по умолчанию будет распечатана на отдельной странице. Для вывода отдельных частей листа на одной странице имеются следующие возможности.

Совмещение столбцов. Чтобы при печати нужные столбцы располагались рядом, выделите те столбцы, которые не нужно выводить на печать, выберите пункт Столбец (меню Формат), а затем выполните команду Скрыть. Включите в одну область печати все нужные столбцы, а также расположенные между ними скрытые столбцы.

Совмещение строк. Чтобы при печати нужные строки располагались рядом, выделите те строки, которые не нужно выводить на печать, выберите пункт Строка (меню Формат), а затем выполните команду Скрыть. Включите в одну область печати все нужные строки, а также расположенные между ними скрытые строки.


 Сообщение о неправильности данных отчета сводной таблицы

Сообщение о неправильности данных отчета сводной таблицы

Требуется обновление данных отчета. Если источник данных отчета сводной таблицы не является источником OLAP, данное сообщение выводится при первой попытке получения сохраненного в виде Web-страницы отчета, при условии, что поле источника данных содержит данные нескольких типов (например, текст и числовые значения). Для возобновления подключения к источнику данных следует еще раз воспользоваться командой Обновить данные [image] .

Проверка диапазона исходных данных. Если отчет сводной таблице основан на данных листа Microsoft Excel, необходимо удостовериться в том, что исходные данные не были удалены. Если исходные данные относятся к именованному диапазону, а при создании отчета сводной таблицы ссылка на источник задается с помощью имени, проверьте, что последнее не было удалено из соответствующей книги. Проверка имен в книге Microsoft Excel.

Проверка источника внешних данных. Если отчет основан на внешних данных, следует убедиться в том, что соответствующая база данных доступна и подключена.

Проверка наличия достаточного объема оперативной памяти. Если на момент открытия книги отчет содержит неверные данные, попробуйте завершить работу всех приложений, которые не требуются в данный момент. Это позволит освободить дополнительную оперативную память. После этого повторите попытку открытия книги.

Копирование отчета после обновления данных. Дождитесь, когда обновление отчета сводной таблицы завершится, а в строке состояния будет выведено сообщение «Готово», и лишь только после этого приступайте к копированию или вставке отчета в другую книгу.

Проверка формата. Созданный в Excel 97 отчет сводной таблицы с вычисляемыми полями или полем страницы, данные каждого элемента которых извлекаются независимо от остальных данных, обязательно должен сохраняться в формате Excel 2000 (выполните команду Сохранить как меню Файл, а затем выберите формат Книга Microsoft Excel (*.xls) в списке Тип файла). Впоследствии, если это необходимо, можно сохранить книгу и в формате прежней версии Microsoft Excel.


 Отчет сводной таблицы или сводной диаграммы выглядит совершенно иначе после обновления, либо обновить отчет больше не удается

Отчет сводной таблицы или сводной диаграммы выглядит совершенно иначе после обновления, либо обновить отчет больше не удается

Проверка доступности исходной базы данных. Удостоверьтесь в том, что возможно как подключение к внешней базе данных, так и просмотр этих данных.

Проверка изменений в исходной базе данных. Если источником данных для отчета является база данных OLAP, возможно, были внесены изменения в данные куба на сервере. Дополнительные подробности можно узнать у администратора сервера OLAP.


Опубликованную диаграмму не удается просмотреть в обозревателе

В публикуемую Web-диаграмму должны включаться пары значений X и Y (для точечной диаграммы) либо значения X, Y и размеров пузырьков (дляпузырьковой диаграммы). Если выделенный диапазон ячеек не охватывает значений по оси X, Microsoft Excel подставляет их автоматически. Эти значения отображаются на диаграмме в Excel, но на Web-странице будут отсутствовать. Недостающие значения, которые необходимы для построения диаграммы, можно ввести в соседний столбец, а затем добавить их в диаграмму.


 Изменение порядка столбцов в Microsoft Query не отражается на диапазоне внешних данных

Изменение порядка столбцов в Microsoft Query не отражается на диапазоне внешних данных

Измените порядок расположения столбцов в Microsoft Excel. Обновление или изменение данных запроса никак не сказывается на порядке столбцов в Excel. Перемещение столбцов в Microsoft Excel.

Отключите сохранение сведений о порядке столбцов. Чтобы не изменять вручную порядок расположения столбцов в Excel, щелкните мышью любую ячейку из диапазона внешних данных, а затем выберите команду Свойства диапазона данных [image] на панели инструментов Внешние данные. В области Формат и разметка данных снимите флажок Сохранить сведения о сортировке/фильтре/формате для столбца. После изменения порядка столбцов в Query и возврата в Excel расположение столбцов в диапазоне внешних данных изменится.


 После создания куба в Microsoft Query Microsoft Excel по-прежнему использует поля базы данных

После создания куба в Microsoft Query Microsoft Excel по-прежнему использует поля базы данных

Если поля реляционной базы данных, которая указывалась в запросе при создании куба, отображаются на панели инструментов Сводная таблица, в Excel возвращаются данные запроса. Созданный мастером куба OLAP файл определения куба (.oqy) при этом не открывается. Файл определения куба сохраняется после нажатия кнопки Готово в диалоговом окне мастера. По умолчанию файл сохраняется в папке профиля пользователя, которая имеет путь Application Data\Microsoft\Queries.

Чтобы данные для отчета брались из нового куба, выполните команду Открыть (меню Файл Microsoft Excel), в списке Тип файлов выберите пункт Файлы запросов (*.dqy), после чего найдите и дважды щелкните мышью нужный файл (.oqy). При необходимости далее можно создать отчет сводной диаграммы, в котором будут использованы данные созданного с помощью файла (.oqy) отчета сводной таблицы.


 Нарушение порядка столбцов диапазона внешних данных после изменения запроса

Нарушение порядка столбцов диапазона внешних данных после изменения запроса

Сохранение порядка столбцов в Excel или Query. Чтобы после обновления или изменения данных запроса порядок расположения столбцов в Microsoft Excel оставался неизменным, щелкните мышью любую ячейку диапазона внешних данных, а затем выберите команду Свойства диапазона данных [image] на панели инструментов Внешние данные. В области Формат и разметка данных установите флажок Сохранить сведения о сортировке/фильтре/формате для столбца. Если изменение порядка столбцов в Microsoft Query должно автоматически отражаться на диапазоне внешних данных, флажок следует снять.

Изменение имен столбцов в Query. Если флажок Сохранить сведения о сортировке/фильтре/формате для столбца установлен, изменение имени столбца в Query с последующим возвратом данных в Excel приведет к тому, что переименованный столбец займет крайнее правое положение в диапазоне внешних данных. Чтобы этого не происходило, можно перед изменением запроса снять указанный флажок. Тех же результатов можно добиться, вручную переместив столбец в требуемое положение в Microsoft Excel.


Не удается добиться нужного расположения перемещаемых на лист полей данных сводной таблицы

Для изменения порядка отображения полей данных щелкните поле правой кнопкой мыши и выберите в контекстном меню пункт Порядок. Команды подменю Порядок позволят выбрать требуемое расположение полей на листе.


Неправильное отображение повернутого текста при опубликовании или сохранении данных на Web-странице

В публикуемых или сохраняемых на Web-странице данных Microsoft Excel использование повернутого или вертикального текста не допускается. Такой текст автоматически преобразуется в горизонтальный.


Неверный угол поворота текста

Формат повернутого текста может быть потерян, если книга была сохранена в другом формате. В большинстве форматов файлов повернуть текст на любое значение в пределах 180 градусов (от +90 до –90 градусов), как в текущей версии Microsoft Excel, нельзя. В более ранних версиях Microsoft Excel текст может быть повернут на +90, 0 (ноль) или –90 градусов. Если формат файла не поддерживает указанный угол поворота, то поворот текста не осуществляется.


При перетаскивании поля в отчет сводной таблицы или сводной диаграммы данные появляются с задержкой

Если внешний источник или источник, созданный с помощью мастера куба OLAP, содержит слишком большой объем данных, перетаскивание полей с панели инструментов Сводная таблица на лист Excel происходит с заметной задержкой.

Перетаскивайте элементы данных в последнюю очередь. В отчете сводной таблице в первую очередь следует перетаскивать поля в области строк, столбцов и страниц. В отчете сводной диаграммы сначала перетаскиваются поля в области рядов, категорий и страниц. Поля в область данных следует перетаскивать последними. Такой подход позволит существенно уменьшить объем данных, отображаемых на промежуточных шагах.

Измените макет с помощью мастера. Если величина задержки недопустимо велика, вернитесь к мастеру создания сводной таблицы и сводной диаграммы и измените вид сводной таблицы или диаграммы. После изменения структуры таблицы или диаграммы соответствующие данные извлекаются автоматически и отображаются в Microsoft Excel. Дополнительные промежуточные шаги при этом не требуются.


Надпись, рисунок или перемещаемый текст не включаются в диаграмму пользовательского типа

Надписи, рисунки и перемещаемый текст нельзя сохранять в диаграммах, которые определяются пользователем. Эти объекты следует добавлять после того, как диаграмма пользовательского типа уже создана.


 Неправильное отображение текста при опубликовании или сохранении данных на Web-странице

Неправильное отображение текста при опубликовании или сохранении данных на Web-странице

Обновите текущую версию Microsoft Internet Explorer до версии 4.01 или более поздней. Для правильного отображения текста при просмотре Web-страницы с интерактивными данными необходимо приложение Microsoft Internet Explorer 4.01 (или более поздней версии). На компьютер также должны быть установлены Web-компоненты Microsoft Office.

Измените ячейки с автоматическим переносом текста. В публикуемых или сохраняемых на Web-странице данных могут присутствовать ячейки с автоматическим переносом текста. В интерактивной сводной таблице на Web-странице автоматический перенос текста внутри ячейки не поддерживается. Чтобы при сохранении или публикации данных текст не обрезался, используйте менее длинные надписи, разместите текст в нескольких ячейках или увеличьте ширину столбца на листе. После выполнения этих действий данные следует опубликовать еще раз.

Объедините ячейки. Чтобы при опубликовании или сохранении элементов Web-страницы без интерактивных возможностей текст в ячейках не обрезался, можно объединить ячейки в Microsoft Excel, а затем опубликовать данные еще раз.

Не используйте CSS в форматировании шрифтов. Старые версии обозревателей, например, Netscape Navigator 3.0, не поддерживают стилей CSS. Для нормальной работы с подобными приложениями необходимо выполнить следующие действия.

  1. В Microsoft Excel выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

  2. Нажмите кнопку Параметры Web-документа, а затем выберите вкладку Общие.

  3. Снимите флажок Использовать CSS при форматировании шрифтов.

  4. Опубликуйте данные еще раз.


 Текст не отражается и не вращается вместе с графическим объектом

Текст не отражается и не вращается вместе с графическим объектом

В Microsoft Excel текст автофигуры перемещается, но не участвует во вращении и отражении вместе с автофигурой. Чтобы изменить расположение текста внутри автофигуры, выделите границу фигуры, выполните команду Автофигура меню Формат, после чего выберите необходимые параметры на вкладках Выравнивание и Поля.


Текст и другие вводимые данные не отображаются в ячейках

Сброс числового формата. Ячейки могут быть отформатированы таким образом, что их содержимое не отображается на экране. Для удаления форматов, влияющих на отображение данных, выделите ячейки. В меню Формат выберите команду Ячейки и перейдите к вкладке Число. В списке Числовые форматы выберите Общий.

Проверка цвета текста и фона. Содержимое ячейки не видно на экране, если цвет его текста совпадает с цветом фона. Измените цвет фона либо измените цвет текста.


Команда "Принять/отклонить исправления" недоступна.

Чтобы команда Принять/отклонить исправления стала доступной, необходимо организовать совместный доступ к книге. Однако изменения, сделанные до организации совместного доступа, не будут доступны для просмотра.

  • Если требуется выделить изменения и просмотреть их, то совместный доступ к книге следует открыть, включив выделение изменений. Для получения более подробных сведений нажмите кнопку [image] .

  • Для получения сведений о том, как открыть совместный доступ к книге без включения выделения изменений, нажмите кнопку [image] .


При опубликовании или сохранении данных на Web-странице элементы управления имеют слишком большие размеры

Нужные размеры элементов управления и графических объектов, а также их форму и расположение можно подобрать, открыв Web-страницу в приложении Microsoft FrontPage 2000.


 Недоступны обсуждения при работе с книгой

Недоступны обсуждения при работе с книгой

Примечание. Возможность проведения обсуждений становится доступна только после установки на сервере серверных расширений Microsoft Office. Установка этого программного обеспечения должна выполняться системным администратором.

Подключение к несоответствующему серверу обсуждений. Данные обсуждений хранятся отдельно от других данных на сервере обсуждений, а не в книге Excel. При подключении к другому серверу вместо того, на котором расположены данные обсуждений, необходимые данные будут недоступны. Проверьте правильность подключения к серверу.

Перемещение рабочей книги. Обсуждения хранятся отдельно от остальных данных на соответствующем сервере, а не в книге Excel. Если перемещение книги, которая находилась на Web-сервере, было выполнено без помощи папок Web или Microsoft FrontPage, связи книги с соответствующими заметками теряются. Чтобы этого не происходило, при перемещении книги следует пользоваться папками Web или приложением FrontPage.

Книга была переименована. Так как данные обсуждений хранятся отдельно на сервере обсуждений, а не в книге, переименование последней приведет к разрыву связей книги с обсуждениями. Чтобы этого не происходило, книги с обсуждениями лучше не переименовывать.

Автономная работа в старой версии обозревателя. Автономный просмотр обсуждений возможен только в Microsoft Internet Explorer 5 или более поздней версии программы.

Требуется обновление данных книги. Последние данные обсуждений могут автоматически не отразиться в книге. Для обновления книги выберите Обсуждения на панели инструментов Обсуждения, а затем выполните команду Обновить обсуждения.


При нажатии кнопки «Правка» в обозревателе Web-страница открывается не той программой.

Вызов той или иной программы нажатием кнопки Правка в Web-обозревателе зависит от того, как была опубликована открываемая Web-страница.

Если при нажатии кнопки Правка вызывается не та программа, которая требуется, запустите нужную программу и откройте в ней Web-страницу.


 На стандартной панели инструментов отсутствует кнопка электронной почты

На стандартной панели инструментов отсутствует кнопка электронной почты

Если на компьютер не установлена программа электронной почты (например, Microsoft Outlook), кнопка Электронная почта [image] на панели инструментов Стандартная отображаться не будет. См. сведения о требованиях к системе для работы с электронной почтой в Excel.


 В отчете сводной диаграммы отсутствуют форматирование, линии тренда и планки погрешностей

В отчете сводной диаграммы отсутствуют форматирование, линии тренда и планки погрешностей

Microsoft Excel не сохраняет форматирование подписей данных, элементов данных и рядов данных (в том числе линии тренда и планки погрешностей) совместно с представлением отчета сводной диаграммы или соответствующего отчета сводной таблицы.

Под изменением представления подразумевается изменение макета, добавление или удаление полей и элементов, изменение элементов полей страниц, объединение элементов в группы и разбиение групп на отдельные элементы, отображение и скрытие элементов и сведений, сортировка, изменение групповой функции или представления итогов, изменение или запрос исходных данных, а также обновление данных отчета сводной диаграммы или сводной таблицы.

Перед изменением форматирования отчета сводной диаграммы необходимо убедиться в том, что он имеет нужный вид.

Умение создавать и работать с макросами Excel позволит автоматизировать задачу форматирования отчетов. Создание и выполнение макросов.


 В журнале показываются не все изменения

В журнале показываются не все изменения

Сохраните книгу и просмотрите журнал изменений. В журнале изменений показаны только те изменения, которые были сделаны вплоть до последнего сохранения. Если другие пользователи внесли и сохранили изменения после последнего сохранения, эти изменения в журнале не отражаются. Чтобы просмотреть самые последние сохраненные изменения, сделанные другими пользователями, сохраните книгу и просмотрите журнал изменений.

Просмотрите собственные несохраненные изменения. Просмотр несохраненных изменений других пользователей невозможен. Для просмотра своих несохраненных данных выделите исправления на листе.

Сохраните данные и выведите журнал еще раз. Отображенный на экране журнал в Microsoft Excel автоматически не обновляется. Чтобы просмотреть исправления, которые были внесены уже после того, как журнал был выведен на экран, сохраните книгу, а затем выведите журнал на экран еще раз. В меню Сервис выберите пункт Исправления, а затем выполните команду Выделить исправления. Выбрав параметр Вносить изменения на отдельный лист, нажмите кнопку OK.


При выборе сканера кнопка «Вставить» становится недоступной

Кнопка Вставить может быть недоступной, если программное обеспечение сканера не поддерживает автоматическое сканирование. В таком случае следует использовать кнопку Custom Insert.


Сохраняемые или публикуемые на существующей Web-странице элементы отображаются только в конце страницы

Публикуемые или сохраняемые данные Microsoft Excel всегда добавляются в конец существующей Web-страницы.

Для переноса этих данных в другое место на Web-странице можно воспользоваться программой Microsoft FrontPage 2000 или страницей доступа к данным в режиме конструктора Microsoft Access 2000, с тем чтобы указать требуемое расположение элементов. См. сведения о программах для изменения Web-страницы.


Связи в общей книге не работают

Обновите связи с ошибками #ССЫЛКА! вручную. Если другой пользователь создает и сохраняет новую связь в общей книге в то время, когда происходит изменение этой же книги, то при ее сохранении или получении обновления вместо связанных данных возникает ошибка #ССЫЛКА!. Чтобы очистить ошибку #ССЫЛКА! и отобразить связанные данные, выберите команду Связи в меню Правка, укажите связь с ошибкой, а затем нажмите кнопку Обновить.

Проверьте путей и расположения указанных в ссылке файлов. Если общая книга копируется или перемещается в сеть из исходного каталога или если книга, являющаяся источником для связей не сохранена в сети, может выводиться сообщение о невозможности обновления связей. Связи могут быть восстановлены следующим образом.

  • Убедитесь, что книга, являющаяся источником для связей, хранится в сети, а связи в исходной версии общей книги в локальной системе имеют верное сетевое расположение. Для проверки связей используется команда Связи (меню Правка).

  • Если общая книга скопирована, то откройте ее исходную версию в локальной системе, а затем используйте команду Сохранить как (меню Файл), чтобы сохранить общую книгу в сети. Эта команда обновляет связи для нового расположения книги.

  • Если общая книга перемещена или исходная версия больше не доступна (или не является текущей), откройте перемещенную общую книгу и используйте команду Связи (меню Правка), чтобы исправить путь для каждой связи.


 Смещение многоуровневых подписей категорий на диаграмме

Смещение многоуровневых подписей категорий на диаграмме

Диаграмма связана с закрытой книгой. Если в диаграмме используются данные из закрытой книги, многоуровневые подписи категорий будут отображаться не так, как при создании диаграммы. Например, нижние подписи могут быть смещены влево или расположены посередине. Чтобы изменить расположение подписей, откройте соответствующую книгу. Воспользуйтесь командой Связи (меню Правка) в книге с диаграммой. Выберите в списке исходный файл с данными диаграммы, а затем выполните команду Открыть. В результате этих действий расположение подписей будет восстановлено.

Просмотр диаграммы в старой версии Microsoft Excel. Неправильное отображение многоуровневых подписей категорий может быть также связано с сохранением книги в формате более ранней версии приложения и последующем открытием этой книги в старой версии Excel.


Имя вспомогательной папки Web-страницы написано на другом языке

При сохранении файла в виде Web-страницы все вспомогательные файлы, например файлы с маркерами, фоновыми текстурами и графическими объектами, располагаются в специальной папке. По умолчанию ее имя совпадает с именем Web-страницы, к которому через знак подчеркивания (_), точку (.) или дефис добавляется слово «файлы». Слово «файлы» записывается на языке, который был выбран для текущей версии Microsoft Office 2000. Например, для английской версии Office 2000 при сохранении файла Page1 в виде Web-страницы папка будет иметь имя «Page1 files». См. сведения о выборе по умолчанию имен вспомогательных папок.


При опубликовании или сохранении данных на Web-странице имена отображаются как значения или диапазоны

При опубликовании на в Интернете или сохранении данных на Web-странице имена и именованные диапазоны в формулах Microsoft Excel преобразуются в значения или ссылки на ячейки.


 Число в ячейке листа отличается от числа в поле формул.

Число в ячейке листа отличается от числа в поле формул.

Числовой формат, использованный в ячейке, определяет способ отображения числа в ячейке Microsoft Excel. Формат не влияет на значение ячейки, используемое в вычислениях. Когда ячейка активна, оно указывается в строке формул.

Для удаления специальных числовых форматов, которые могут повлиять на отображение значения, выделите ячейки. В меню Формат выберите команду Ячейки и перейдите к вкладке Число. В поле Числовые форматы выберите Обычный. Для получения дополнительных сведений об отображении чисел в Microsoft Excel нажмите кнопку [image] .


В команде "Параметры" отсутствуют требуемые настройки.

Многие из настроек, например цвет окон и цвет выделения, а также настройки, связанные со страной: формат даты и времени — являются настройками Windows. Для изменения этих настроек нажмите кнопку Пуск в Windows, наведите курсор на пункт Настройка, а затем выберите пункт Панель управления.


 Параметры поля страницы недоступны

Параметры поля страницы недоступны

Чтобы перейти к настройке параметров поля страницы, два раза щелкните поле страницы, после чего нажмите кнопку Подробнее в диалоговом окне Поле сводной таблицы. См. сведения о параметрах поля страницы.

Проверка типа поля. Выбранное поле может не быть полем страницы. Эти параметры доступны только для полей страницы.

Проверка использования внешнего источника данных. Отчет сводной таблицы или сводной диаграммы может быть основан не на внешних данных. Эти параметры недоступны в отчетах, основанных на данных листа Excel.

Проверка использования источника данных OLAP. Указанные параметры недоступны в отчетах сводных таблиц и сводных диаграмм, которые основаны на базах данных OLAP. См. раздел Использует ли отчет сводной таблицы или сводной диаграммы данные OLAP.

Проверка типа данных поля. Поле источника данных может иметь недопустимый тип данных. Параметры поля страницы недоступны для полей MEMO или полей с объектами OLE.

Проверка наличия поддержки запросов с параметрами. Драйвер источника данных или драйвер ODBC для внешней базы данных может не поддерживать запросы с параметрами. Обсуждаемые здесь параметры доступны только в том случае, когда используемый источник данных поддерживает такие виды запросов.

Драйверы источников данных OLAP не поддерживают запросы с параметрами. Все драйверы ODBC, поставляемые корпорацией Майкрософт с Microsoft Query, поддерживают запросы с параметрами. Чтобы узнать, поддерживает ли запросы с параметрами драйвер стороннего производителя, обратитесь к поставщику драйвера.

Проверка использования в качестве источника данных другого отчета сводной таблицы. Параметры поля страницы недоступны, если на существующем отчете сводной таблицы основан другой отчет сводной таблицы или более одного отчета сводной диаграммы.

Проверка группирования поля. Чтобы параметры поля страницы стали доступными, выполните разгруппирование поля.


 Определенные в диаграмме пользовательского типа местоположение и размеры элементов не используются в созданном отчете сводной диаграммы

Определенные в диаграмме пользовательского типа местоположение и размеры элементов не используются в созданном отчете сводной диаграммы

В отчете сводной диаграммы нельзя вручную перемещать или изменять размеры легенды, подписей и названий, а также области построения. Таким образом, при создании отчета сводной диаграммы на основе пользовательского типа диаграммы, где указанные элементы были изменены вручную, независимо ни от чего будут использоваться установленные по умолчанию размеры и расположение элементов.


Сканирование занимает слишком много времени

Выбор более низкого разрешения. Чем выше разрешение, тем более продолжительным будет сканирование.

Однократное сканирование. Время получения и обработки данных может увеличиться при многоэтапном сканировании цветного изображения соответствующим устройством и вставке рисунка с помощью кнопки Custom Insert в диалоговом окне Добавить рисунок со сканера или камеры (меню Вставка, подменю Рисунок), а не кнопки Insert. Задержка связана с тем, что сканирование одного и того же изображения выполняется несколько раз. При однократном сканировании добавляйте рисунок с помощью кнопки Insert.

Использование медленного сканера. Скорость работы различных моделей сканеров может быть различной.


 Предупреждение системы безопасности о неподтвержденной подлинности источника

Предупреждение системы безопасности о неподтвержденной подлинности источника

При выборе высокого или среднего уровня безопасности это сообщение означает, что открываемая книга или загружаемая программа надстройки содержит макрос с цифровой подписью, подлинность цифрового удостоверения которого не подтверждена. Это может иметь место, например, если разработчик создал собственное цифровое удостоверение.

Имеется опасность, что подобное неподтвержденное удостоверение могло быть подделано в злоумышленных целях. Например, не исключены попытки выдачи удостоверений с подписью корпорации Майкрософт. При этом описанное предупреждение будет единственным указанием на использование поддельного удостоверения. Профессиональные разработчики программного обеспечения должны снабжать свои продукты только подтвержденными удостоверениями. В связи с этим поступление неподтвержденных сертификатов следует ожидать только от сослуживцев и друзей.

При выборе высокого уровня безопасности, если источник получения макроса заслуживает доверия, следует установить флажок Всегда доверять макросам из этого источника.

Если выбран средний уровень безопасности, запуск макроса возможен и без добавления его разработчика в список надежных источников. Если разработчик макроса не относится к надежным, не включайте автоматический запуск макросов или воздержитесь от открытия книги до тех пор, пока не будет подтверждена надежность источника.


 Выделенная область увеличивается при нажатии кнопки мыши на ячейке или прокрутке

Выделенная область увеличивается при нажатии кнопки мыши на ячейке или прокрутке

  • Если в строке состояния отображена надпись "ВДЛ" , необходимо нажать клавишу F8, чтобы отключить режим увеличения области выделения.


Установленные в диалоговом окне "Условное форматирование" параметры внезапно исчезли.

Среди выделенных ячеек должны быть ячейки, обладающие двумя или более видами условного форматирования. В диалоговом окне одновременно может быть изображен только один набор условий условного форматирования и форматов ячеек.

Выделите другие ячейки и проверьте параметры еще раз. Для получения сведений о поиске всех ячеек листа, имеющих одинаковый условный формат, нажмите кнопку [image] .


Тень графического объекта не сплошная

Накладываемая на прозрачный объект тень отображается в виде линии. Если эту тень нужно сделать сплошной, выберите цвет или способ заливки объекта.


 Общая книга открывается только для чтения

Общая книга открывается только для чтения

Проверьте, не является ли книга общим списком Excel 95. Книга может быть общим списком Microsoft Excel 95. Когда в Microsoft Excel 2000 открывается общий список Microsoft Excel 95, то появляется сообщение о том, что общие файлы Microsoft Excel 95 должны быть открыты только для чтения. Чтобы преобразовать файл в общую книгу Microsoft Excel 2000, выберите команду Сохранить как в меню Файл, в списке Тип файла выберите Книга Microsoft Excel (*.xls), а в поле Имя файла введите новое имя. После этого к книге может быть организован совместный доступ.

Убедитесь, что для книги не был рекомендован доступ только для чтения. Если к книге рекомендован доступ только для чтения, можно открыть файл для внесения изменений, а в ответ на предложение открыть книгу только для чтения нажать кнопку Нет.

Используйте для сохранения данных команду «Сохранить как». Возможно, к книге был открыт доступ только для чтения. После изменения данных такую книгу можно сохранить с помощью команды Сохранить как (меню Файл). Общая книга при этом сохраняется с другим именем и в нее можно вносить изменения.


Ярлычки листов не отображаются в нижней части экрана

Включите отображение ярлычков. Для отображения ярлычков листов выберите пункт Параметры в меню Сервис, перейдите на вкладку Вид и установите флажок ярлычки листов. При необходимости можно увеличить область прокрутки ярлычков.

Увеличьте высоту полосы прокрутки. Если имена листов показываются не полностью или их чтение затруднено, можно увеличить высоту полосы прокрутки. На панели управления Windows два раза щелкните значок Экран, перейдите на вкладку Оформление, в списке Элемент выберите пункт Полоса прокрутки и укажите большее значение в поле Размер.

Включите отображение скрытых листов. Лист может быть скрыт. Тогда в меню Формат выберите пункт Лист и выполните команду Показать. Если команда Показать недоступна, книга не содержит скрытых листов. Если недоступны команды Переименовать и Скрыть, то книга защищена от структурных изменений. Чтобы определить, скрыты листы или нет, необходимо снять защиту с данной книги. При этом может потребоваться пароль.

Примечание. Если листы были скрыты программой на Visual Basic для приложений (путем назначения свойства xlSheetVeryHidden), использование команды Показать не приведет к желаемому результату. При работе с книгой, которая содержит макросы на языке Visual Basic вопросы, связанные со скрытыми листами, следует разрешать с владельцем такой книги.


Орфография проверяется только в части листа

  • Если орфография проверяется в выделенном диапазоне ячеек, остальные ячейки не проверяются. Для проверки орфографии на всем листе необходимо указать одну ячейку.


 Невозможно изменить итоговую функцию для вычисляемого поля

Невозможно изменить итоговую функцию для вычисляемого поля

В вычисляемых полях подведение итогов данных всегда производится с помощью итоговой функции "Сумма". Изменение итоговой функции для вычисляемого поля невозможно.


При опубликовании или сохранении данных на Web-странице текст ячеек отображается не полностью

Измените ячейки с автоматическим переносом текста. В публикуемых или сохраняемых на Web-странице данных могут присутствовать ячейки с автоматическим переносом текста. В интерактивной сводной таблице на Web-странице автоматический перенос текста внутри ячейки не поддерживается. Чтобы при сохранении или публикации данных текст не обрезался, используйте менее длинные надписи, разместите текст в нескольких ячейках или увеличьте ширину столбца на листе. После выполнения этих действий данные следует опубликовать еще раз.

Объедините ячейки. Чтобы при опубликовании или сохранении элементов Web-страницы без интерактивных возможностей текст в ячейках не обрезался, можно объединить ячейки в Microsoft Excel, а затем опубликовать данные еще раз.

Выровняйте текст еще раз. Если в Microsoft Internet Explorer 5 текст ячеек показывается не полностью, длина публикуемого текста превышает размер ячейки, а сам текст выровнен по середине или правому краю. Возможные в этом случае действия описаны ниже.

  1. Откройте исходную книгу (.xls) в приложении Excel.

  2. Выберите мышью ячейку, текст которой обрезан.

  3. В меню Формат выберите команду Ячейки, а затем перейдите к вкладке Выравнивание.

  4. В поле со списком по горизонтали выберите значение по левому краю (отступ).

  5. Опубликуйте или сохраните данные на Web-странице еще раз.

Примечание. При просмотре Web-страниц без интерактивных возможностей в Microsoft Internet Explorer version 4.01 (или более ранней версии обозревателя) выровненный по центру, левому или правому краю текст переносится по словам автоматически.


 Недоступна команда «Проверка» в меню «Данные»

Недоступна команда «Проверка» в меню «Данные»

Ниже перечислены случаи, когда команда Проверка недоступна.

Идет ввод данных. Команда Проверка при вводе данных в ячейку недоступна.

Содержащиеся на листе данные защищены. Чтобы отменить защиту, используйте команду Снять защиту листа в подменю Защита меню Сервис.

Книга является общей. В этом режиме может продолжаться ввод данных и могут выдаваться сообщения об ошибках. Команда Проверка в режиме совместного доступа перестает быть доступной. Чтобы получить более подробные сведения об отмене совместного доступа, нажмите кнопку [image] .


Фоновый рисунок листа не выводится на печать

Microsoft Excel не выводит на печать рисунок подложки, который был добавлен с помощью команды Подложка (меню Формат, подменю Лист).

Добавление графических объектов в отдельные ячейки. Добавленные на лист графические объекты в Excel на печать выводятся. Добавление графических объектов на лист Excel.

Заливка ячеек. Заливка ячеек также выводится на печать. Добавление заливки ячеек.


 Лист, отправленный по электронной почте, отображается неправильно

Лист, отправленный по электронной почте, отображается неправильно

Отправитель и получатель почтового отправления должны иметь почтовую программу, которая бы позволяла просматривать сообщения в формате HTML. При просмотре листа в почтовой программе, не поддерживающей этого формата данных, форматирование листа может быть нарушено, а графические объекты могут не отображаться на экране. В этом случае следует отправить лист как почтовое вложение.


В заголовке обсуждения не отображается имя текущего пользователя

Неверные сведения о пользователе. Если вход в систему выполнялся с чужого компьютера, при добавлении текста обсуждения в заголовке может отображаться имя другого пользователя. Для добавления в заголовок своего имени необходимо выбрать пункт Параметры (меню Сервис) и на вкладке Общие указать соответствующее имя в поле Имя пользователя.

Отключен вывод имен в заголовке. Чтобы имена отображались в заголовках, выберите элемент Обсуждения (панель инструментов Обсуждения), а затем Параметры обсуждения. Установите флажок Экранное имя.


 Итоги в отчете сводной таблицы помечаются звездочками

Итоги в отчете сводной таблицы помечаются звездочками

В итоги OLAP включаются значения для скрытых элементов. Вычисление промежуточных и общих итогов в отчетах сводных таблиц, источником которых являются базы данных OLAP, проводится на сервере OLAP. Таким образом, в вычислениях всегда участвуют значения всех элементов поля, в том числе скрытых. Звездочки в отчете указывают на то, что в общие итоги были включены значения скрытых элементов. См. сведения о вычислении итогов в отчетах сводных таблиц.

Удаление звездочек. Возможность удаления звездочек из подписей промежуточных и общих итогов отсутствует. Чтобы звездочки в отчете не отображались, следует выбрать мышью ячейку в отчете сводной таблицы, выбрать команду Параметры таблицы (панель инструментов Сводная таблица, меню Сводная таблица), а затем в разделе Формат снять флажок помечать итоги *.


После копирования с последующей вставкой выделение пропадает

За один раз допускается копирование и вставка только одной выделенной области. Чтобы копируемые ячейки оставались выделенными, не следует выделять другую группу ячеек до того, как будет выполнена вставка этих данных.


Интерактивная Web-страница не может быть открыта пользователями

С интерактивными данными Microsoft Excel в Интернете могут работать только пользователи с расширенным, профессиональным или стандартным выпусками Microsoft Office 2000 либо с выдаваемой на узел лицензией Microsoft Office 2000 (при условии установки у них Web-компонентов).

Для гарантированной установки Web-компонентов на подключенных к интрасети компьютерах можно воспользоваться возможностью автоматической загрузки этих компонентов при открытии Web-страницы.

  1. В Microsoft Excel выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

  2. Нажмите кнопку Параметры Web-документа и выберите вкладку Файлы.

  3. Установите флажок Загрузить Web-компоненты Office.

  4. В поле Расположение введите путь к файловому серверу, такой как «file:\\my server\my folder».

Примечание. Пользователи обязательно должны иметь доступ к файловому серверу. Загрузка Web-компонентов не должна осуществляться через системы защиты сервера (например, Firewall).


 В диаграмме с датами отсутствует ось времени

В диаграмме с датами отсутствует ось времени

Параметр «ось времени». Проверьте установку флажка ось времени на вкладке Оси в диалоговом окне Параметры диаграммы (меню Диаграмма). Недоступность этого параметра может свидетельствовать о неправильном выборе типа диаграммы или отсутствии значений дат на оси категорий диаграммы.

Тип диаграммы. Ось времени доступна только в плоских или объемных графиках, гистограммах, линейчатых диаграммах, диаграммах с областями и в биржевых диаграммах.

Отчеты сводных диаграмм. В отчетах сводных диаграмм ось времени не отображается.

Значения дат на оси категорий. Удостоверьтесь в наличии дат вдоль оси категорий диаграммы. Если это условие не выполняется, можно изменить представление данных на диаграмме.

Многоуровневые подписи категорий. Ось времени не может быть включена в диаграмму с многоуровневыми подписями категорий. Чтобы подписи категорий в диаграмме, основанной на данных листа, были одноуровневыми, подписи в исходных данных не следует располагать в несколько строк.


 Выбор обозревателя для обсуждений на Web-страницах

Выбор обозревателя для обсуждений на Web-страницах

Обсуждения поддерживаются большинством обозревателей, однако лучше работать в Microsoft Internet Explorer версии 4.0 (или более поздней). Если на компьютере установлена более ранняя версия Internet Explorer или другой обозреватель (например, Netscape Navigator 3.0 или более поздняя версия этого приложения), замечания обсуждений могут добавляться на Web-страницу через начальную страницу серверных расширений Microsoft Office. Чтобы перейти к этой начальной странице, в поле Адрес обозревателя следует ввести текст http://ИмяСервера/msoffice/, где ИмяСервера обозначает Web-сервер, к которому имеется доступ для сохранения файлов. Имя такого сервера можно узнать у системного администратора.

Независимо от используемого обозревателя при переходе к Web-странице через начальную страницу серверных расширений Office панель инструментов Обсуждения будет отличаться от панели инструментов, отображаемой в Internet Explorer 4.0 или более поздней версии этого приложения.


 Листы макросов и диалоговых окон прежних версий Microsoft Excel

Листы макросов и диалоговых окон прежних версий Microsoft Excel

Листы из более ранних версий Microsoft Excel. При открытии в Excel 2000 книги, которая была создана более ранней версией этого приложения, листы макросов Excel версии 4.0 и диалоговых окон Excel версии 5.0 преобразуются в связанные с данной книгой модули проекта Visual Basic для приложений.

Просмотр, выполнение и изменение макросов. Листы макросов и диалоговых окон можно изменять в книге Excel 2000 с помощью редактора Visual Basic.


При назначении числам текстового формата числовые данные не преобразуются в текст

Если числа уже введены, а ячейкам назначен текстовый формат, выделяя каждую ячейку, нажимайте клавишу F2, а затем — клавишу ENTER, чтобы заново ввести числа, но уже как текст. Чтобы ввести числа в виде текста, необходимо назначить текстовый формат незаполненным ячейкам, а затем вводить в них числа.


 При выборе элемента управления выдается сообщение о том, что Microsoft Excel не может найти файл

При выборе элемента управления выдается сообщение о том, что Microsoft Excel не может найти файл

Содержащая макрос книга может быть недоступна. Обычно при выборе мышью элемента управления, который был назначен макросу в другой книге, Microsoft Excel открывает соответствующую книгу и запускает макрос на выполнение. Если при выборе элемента управления выдается сообщение, что файл не может быть найден, книга с макросом либо отсутствует, либо была перемещена (переименована).

Назначение другого макроса. При получении этого сообщения элемент управления следует удалить или назначить ему другой макрос. Откройте книгу, в которой находится назначаемый макрос. Правой кнопкой мыши щелкните элемент управления, выберите в контекстном меню команду Назначить макрос, после чего введите данные в поле Имя макроса.


При нажатии кнопки Custom Insert ничего не происходит

Возможно, окно устройства закрыто другими окнами. Чтобы перейти к нужному окну, нажмите соответствующую кнопку на панели задач Windows.


 При нажатии кнопки или другого элемента управления некоторые команды Microsoft Excel становятся недоступными.

При нажатии кнопки или другого элемента управления некоторые команды Microsoft Excel становятся недоступными.

Был выбран элемент ActiveX. Элементы ActiveX являются внедренными графическими объектами, находящимися в верхней части листа. Чтобы сделать команды доступными, выберите любую ячейку на листе.


Не работают гиперссылки при копировании данных в книгу Excel

После копирования данных в книгу или при открытии Web-страницы в приложении Microsoft Excel, содержащиеся в них гиперссылки могут отображаться неправильно. Несколько гиперссылок могут попасть в одну ячейку. Если помимо гиперссылки в ячейке присутствуют другие гиперссылки или текст, такие гиперссылки работать не будут.

Чтобы гиперссылка работала правильно, она должна добавляться в ячейку с помощью команды Гиперссылка (меню Вставка).


Удаление имени пользователя из примечания

Чтобы в заголовке примечания не фигурировало имя его автора, необходимо выделить это имя и нажать клавишу DELETE.

Примечание. Имя в заголовках вновь добавляемых примечаний можно изменить, но полностью убрать заголовки нельзя. Для изменения имени выберите пункт Параметры (меню Сервис), откройте вкладку Общие и укажите нужное имя в поле Имя пользователя. Это поле не должно оставаться пустым.

Важно помнить, что имя пользователя также используется в общих книгах Microsoft Excel. По этому имени можно определить авторов объединяемых изменений в файлах.


Некоторые столбцы и строки переносятся при печати на другую страницу

Количество столбцов и строк, печатаемых на странице, определяется шириной столбца, высотой строки, отступами и разрывами страницы.

Уменьшение отступов. Чтобы столбцы или строки не печатались на следующей странице, попробуйте уменьшить размер полей верхнее, нижнее, левое и правое. В меню Файл выберите команду Параметры страницы, а затем — вкладку Поля.

Расстановка разрывов страниц. Перед печатью документа можно перемещать разрывы страниц. В меню Вид выберите команду Разметка страницы. Разрывы страниц, установленные вручную, показаны жирными синими линиями; автоматические разрывы показаны штриховыми линиями. Разрывы страниц можно перетаскивать влево, вправо, вверх и вниз.

Если столбец печатается на другой странице — например, на второй странице, а не на первой — перетащите разрыв страницы, расположенный слева от столбца, на один столбец вправо. Если строка печатается на следующей странице, перенесите разрыв страницы, расположенный над строкой, под эту строку. Масштаб листа будет автоматически выбран с учетом нового положения строк и столбцов.

Установка ширины листа по ширине одной страницы. Чтобы на листе укладывалась только одна страница, в меню Файл выберите команду Параметры страницы, а затем — вкладку Страница. В группе Масштаб установите переключатель в положение Разместить не более чем на, введите 1 в поле страницах в ширину или в поле страницах в высоту и удалите число из второго поля.

Выбор ориентации при печати. Чтобы на одной странице выводилось несколько столбцов, установите горизонтальную ориентацию листа. В меню Файл выберите пункт Параметры страницы, а затем откройте вкладку Страница. В разделе Ориентация, выберите альбомная.


 Не удается определить срок хранения журнала изменений в защищенной общей книге

Не удается определить срок хранения журнала изменений в защищенной общей книге

Выполнение команды Защитить книгу и дать общий доступ в книге, не имеющей общего доступа, позволяет задать пароль и установить общий доступ к книге автоматически. При этом в Microsoft Excel используются самые последние значения параметров журнала изменений, которые были определены в текущем сеансе. Если книга ранее не была общей, по умолчанию сведения в журнале изменений будут храниться в течение 30 дней.

Установка периода (в днях) до вступления в действие защиты и совместного доступа к книге. До начала действия защиты книги можно внести необходимые данные в настройки журнала изменений. Выберите команду Доступ к книге в меню Сервис, а затем перейдите к вкладке Правка. Установите флажок Разрешить совместный доступ, а затем выберите вкладку Подробнее. В группе Исправления сделайте необходимые изменения. Выберите вкладку Правка, очистите флажок Разрешить совместный доступ, а затем нажмите кнопку OK. После этого используйте команду Защитить книгу и дать общий доступ (пункт Защита в меню Сервис), чтобы сделать книгу общей и защитить совместное использование и журнал изменений.

Если совместный доступ к книге и журнал изменений защищены паролем, очистка сохраненного журнала изменений не происходит независимо от параметров диалогового окна Доступ к книге. Если пароль не используется, срок хранения журнала изменений можно увеличить, однако уменьшить этот срок или очистить сохраненный журнал пользователи по-прежнему не могут. См. Создание защищенной общей книги.


 При повторном открытии книги гиперссылки не работают

При повторном открытии книги гиперссылки не работают

Имя диска могло быть удалено из списка адресов серверов. Диск, который был подключен к общему сетевому каталогу в момент создания гиперссылки, затем, возможно, был отключен. Чтобы сделать гиперссылку независимой от подключенных на данный момент дисков, укажите в гиперссылке имя сервера и сетевое имя, а не имя диска. Например, измените G:\myfile.xls на \\server\share\myfile.xls. См. Изменение места назначения гиперссылки.

Проверка правильности задания местоположения файлов. Относительные пути в книге могут быть указаны неправильно. Также уже после сохранения книги могли быть удалены файлы, на которые указывают ссылки. Убедитесь, что путь к файлам указан правильно. См. инструкции по управлению Web-файлами и гиперссылками.

Проверка правильности работы сети. Причиной данной неполадки может оказаться отсутствие сетевого доступа к указанным в гиперссылках файлах. Удостоверьтесь в работоспособности сети и в наличии доступа к необходимым сетевым ресурсам.


 При передаче данных в Microsoft Excel возвращаются пустые ячейки

При передаче данных в Microsoft Excel возвращаются пустые ячейки

Проверьте драйвер ODBC. Возможно, использован несовместимый драйвер ODBC. Microsoft Excel 2000 и Microsoft Query 2000 используют драйверы ODBC версии 3.0. Если используется драйвер ODBC предыдущей версии Microsoft Excel или Microsoft Query, то для получения данных необходимо установить самую последнюю версию драйвера.

Проверьте наличие в системе свободной оперативной памяти. Возможна нехватка свободной памяти для получения данных. Чтобы проверить это, переключитесь на рабочий стол Windows. Щелкните правой кнопкой мыши значок «Мой компьютер», выберите команду Свойства, а затем — вкладку Быстродействие, чтобы просмотреть, какой процент памяти свободен. Для освобождения памяти попробуйте закрыть ненужные документы и приложения.

Проверьте, обрабатывает ли Excel запросы других приложений. В Microsoft Excel может быть установлен флажок Игнорировать DDE-запросы от других приложений. Этот параметр может препятствовать другим программам, включая Microsoft Query, организовывать динамический обмен данными(DDE) с Microsoft Excel. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие. Убедитесь, что в группе Параметры флажок Игнорировать DDE-запросы от других приложений снят. После этого снова запустите запрос.


 При нажатии правой кнопки мыши на элементе управления не выдается контекстное меню

При нажатии правой кнопки мыши на элементе управления не выдается контекстное меню

Если выборе правой кнопкой мыши элемента управления не выдается контекстное меню, то в данный элемент управления является элементом ActiveX, а не добавленным с панели инструментов Формы. Чтобы вывести контекстное меню для элемента ActiveX — например, с целью изменения свойств или просмотра макроса, необходимо находиться в режиме конструктора. Чтобы переключиться в этот режим, нажмите кнопку Режим конструктора [image] на панели инструментов Элементы управления.


 При сохранении данных в формате dBASE часть их теряется.

При сохранении данных в формате dBASE часть их теряется.

Сохраняются только данные именованного диапазона или текущей области. Если лист Microsoft Excel сохраняется в формате dBASE (DB2, DB3 или DB4) и содержит диапазон с именем «База данных», в файле dBASE сохраняются только данные из этого диапазона. В случае добавления новых записей после назначения имени диапазона, перед сохранением страницы в формате dBASE этот диапазон необходимо переопределить для включения новых записей.

Если страница не содержит диапазона с именем «База данных», то преобразуются данные только в текущей области. Если первая строка данных содержит текст, то Microsoft Excel использует его в качестве заголовка для определения имен полей. Если же первая строка состоит целиком из чисел, то Microsoft Excel присваивает полям имена N1, N2 и так далее.

Убедитесь, что длина строк символов меньше ширины столбца. При сохранении данных в формате dBASE Microsoft Excel назначает каждому полю (столбцу данных) тип, основанный на данных поля первой записи области базы данных или текущей области.

Если поле первой записи содержит текст, ему назначается символьный тип данных, а любые числа, содержащиеся в этом поле в других записях, становятся символьными строками. Ширина столбца поля определяет длину строки; символьные строки, которые длиннее ширины столбца в dBASE обрезаются. Для предотвращения потери данных следует указать диапазон, который должен быть преобразован в Microsoft Excel и использовать шрифт постоянной ширины символов (например, Courier). Для выбора размера столбца в соответствии с длинами строк данных в меню Формат следует выбрать команду Столбец, а затем — Автоподбор ширины. Числовые поля данных не могут содержать текст; любой текст в таком поле представляется нулем.

Используйте числовой формат, отличный от общего. Если десятичные числа имеют общий числовой формат, то в dBASE десятичные знаки будут отсечены. Перед сохранением данных в формате dBASE следует применить другой числовой формат ко всем данным этого поля. Выберите пункт Ячейки в меню Формат, а затем откройте вкладку Число. В списке Числовые форматы выберите Числовой или Экспоненциальный, а затем укажите необходимое число десятичных знаков.

Установите для значений времени текстовый формат. Поля, содержащие время, не могут быть преобразованы. Перед сохранением данных в формате dBASE с помощью функции электронной таблицы TEXT значения времени следует перевести в текстовые данные. Например, чтобы перевести время 12:34 PM в текстовые данные, используется функция =TEXT("12:34", "hh:mm AM/PM").


 При попытке сохранения общей книги выдается сообщение об отсутствии подключения

При попытке сохранения общей книги выдается сообщение об отсутствии подключения

Определение причины недоступности книги. Другой пользователь мог либо прекратить совместное использование книги, либо прервать связь с книгой, выбрав команду Доступ к книге в меню Сервис, а затем — вкладку Правка, указав соответствующее имя и нажав кнопку Удалить. Если совместное использование книги прекращено во время ее изменения, будет выдано соответствующее сообщение, даже если к ней опять будет разрешен совместный доступ.

Повторное подключение к книге. Чтобы заново подключится к книге, ее необходимо снова открыть, но все сделанные в текущем сеансе несохраненные изменения будут потеряны.

Сохранение изменений. Если требуется сохранить работу, в ответ на сообщение о прекращении связи с общей книгой, нажмите кнопку OK, а затем сохраните книгу под другим именем в диалоговом окне Сохранить как. Закройте сохраненную книгу и заново откройте общую книгу, если она все еще доступна. Если в общей книге велся журнал изменений, с помощью команды Объединить книги (меню Сервис), объедините изменения из сохраненного файла с исходной общей книгой.


 При просмотре Web-страницы на другом компьютере текст и графические объекты выглядят иначе

При просмотре Web-страницы на другом компьютере текст и графические объекты выглядят иначе

Выбор разрешения монитора при создании Web-страницы. Расположение графических объектов и текста на экране зависит от разрешения монитора (от отношения размеров экранных элементов к размеру экрана). Выбор размера экрана может влиять на размеры и расположение рисунков в книге, в том числе на отображение градиентной заливки. Размер пиксела определяет размеры графических объектов относительно размеров текста на экране. См. Проверка размеров экрана и пиксела на компьютере.

Если графические объекты и текст отображаются неправильно, выполните описанные ниже действия, чтобы изменить размеры экрана и пиксела.

  1. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Общие.

    Демонстрация

  2. Нажмите кнопку Параметры Web-документа, а затем выберите вкладку Картинки.

  3. В группе Конечный монитор выполните одно из следующих действий.

    В поле Размер экрана укажите нужный размер экрана.

    В списке Число пикселов на дюйм выберите нужное значение (в пикселах).

    Примечание. Этот параметр применяется к текущей странице и ко всем страницам, которые в будущем будут сохраняться в Excel.

    Настройка параметров обозревателя. Разные обозреватели позволяют работать с различными версиями HTML и HTML-расширений, поэтому отображение текста и графических объектов может зависеть от выбора обозревателя. Иногда внешний вид графических объектов и текста можно изменить путем настройки обозревателя. Таким образом, например, может быть выбран другой цвет текста и подложки или установлены новые параметры отображения графических объектов.

    Просмотр страницы в различных программах обозревателей. Вновь созданную Web-страницу следует просмотреть в различных Web-обозревателях (некоторые из этих приложений доступны в Интернете) и с разными настройками монитора. Это позволит убедиться в правильности отображения всех элементов страницы.


 Что случилось с окном сведений?

Что случилось с окном сведений?

Окно сведений в Microsoft Excel 97 не предусмотрено. Однако существуют другие возможности получить сведения о ячейках листа.

Просмотр зависимостей на листе. Можно найти влияющие и зависимые ячейки с помощью средств панели инструментов Зависимости. Чтобы вывести на экран панель инструментов Зависимости, выберите команду Зависимости в меню Сервис, а затем — Панель зависимостей.

Просмотр примечаний. Чтобы просмотреть примечания на листе, подведите указатель мыши к ячейке с красным уголком. С помощью команды Примечания (меню Вид) можно просмотреть сразу все примечания. При печати примечания могут выводиться как рядом с соответствующими ячейками, так и в конце листа.

Просмотр форматирования ячейки. Щелкните мышью, форматирование которой требуется определить, а затем выберите пункт Ячейки (меню Формат). Сведения о форматировании ячейки содержатся на вкладках диалогового окна Формат ячеек.

Просмотр имени ячейки. Выберите мышью ячейку, имя которой нужно узнать. В поле Имя, которое находится в левой части панели формул отображается адрес ячейки (например, A1) или ее имя. Если ячейка входит в именованный диапазон, просмотреть имена ячеек в книге можно с помощью команды Присвоить (меню Вставка, подменю Имя).


 Недоступны кнопки панели инструментов "Зависимости"

Недоступны кнопки панели инструментов "Зависимости"

Кнопки на панели инструментов "Зависимости" недоступны, если переключатель на вкладке Вид диалогового окна Параметры установлен в положение Не отображать (меню Сервис). Поскольку стрелки слежения являются графическими объектами, при скрытии объектов они не отображаются. Чтобы вывести на экран скрытые объекты, выберите команду Параметры в меню Сервис, а затем — вкладку Вид, и установите флажок Отображать или Только очертания.


Не удается переименовать лист

Включите отображение ярлычков. Для отображения ярлычков листов выберите пункт Параметры в меню Сервис, перейдите на вкладку Вид и установите флажок ярлычки листов (в разделе Параметры окна).

Уменьшите размер горизонтальной полосы прокрутки. Ярлычки листов могут заслоняться горизонтальной полосой прокрутки. Для уменьшения размера последней служит маркер разделения области ярлычков, который находится слева от полосы прокрутки.

Маркер разделения области ярлычков

Подведите указатель мыши к маркеру разделения области ярлычков. Указатель при этом должен принять форму двунаправленной стрелки Указатель в виде двунаправленной стрелки. Перетащите маркер вправо таким образом, чтобы были видны ярлычки листов.

Убедитесь в том, что книга не защищена от изменений. Переименование листа возможно только после отключения защиты.


Что означают цифры 1 или 2 в заголовке книги?

Это значит, что для текущей книги открыто более одного окна. Перейдите в окно, которое нужно закрыть, и нажмите кнопку Закрыть [image] в правом верхнем углу окна книги.

Примечания

  • Кнопка Закрыть окна книги может находиться в правой части меню Microsoft Excel (при развернутом окне) или в строке заголовка книги.

  • Число окон при открытии книги остается таким же, каким оно было на момент ее сохранения и закрытия. Чтобы в открываемой книге было всего одно окно, перед ее сохранением и закрытием необходимо предварительно закрыть все окна, оставив открытым только одно из них.


 Приглашения к вводу данных и сообщения о вводе неправильных данных

Приглашения к вводу данных и сообщения о вводе неправильных данных

Ввод данных в ячейки, для которых были назначены условия проверки, сопровождается сообщениями Microsoft Excel (могут выдаваться помощником, если он включен). Эти сообщения отображаются только при вводе данных, копировании или заполнении ячеек, но не в тех случаях, когда недопустимые значения вычисляются по формуле или помещаются в ячейку с помощью макроса. См. Поиск ячеек, для которых вычислены неправильные значения.

Существуют следующие типы сообщений.

Сообщение для ввода. В этом сообщении говорится о том, какие данные могут вводиться в ячейку. Оно выдается при выборе ячейки. Описание разрешенных для ввода данных может задаваться пользователем самостоятельно. При этом определять ограничения на данные ячейки не обязательно. Данное сообщение остается на экране до тех пор, пока ячейка остается выбранной. См. Отображение сообщения для ввода.

Сообщение об ошибке (предупреждение или информационное сообщение). Сообщения этого типа отображаются при вводе в ячейку неправильных данных. Информационное сообщение можно пропустить. Предупреждение позволяет продолжить работу либо вернуться к исправлению данных. См. Вывод предупреждения.

Сообщение об ошибке, запрещающее ввод неправильных данных. При выборе этого сообщения ввод неправильных данных в ячейку будет невозможен. В нем указывается, с чем связаны ошибки в данных. После выдачи этого сообщения можно только повторить попытку или отказаться от ввода данных. См. Отображение сообщения и предотвращение ввода в ячейку неправильных данных.

Примечание. При общем доступе к книге невозможно ни установить, ни изменить отображаемые сообщения. Установленные ранее сообщения выводятся и во время совместного использования.


Не удается импортировать рисунок

Возможно, в нужной папке не установлен необходимый графический фильтр или фильтр поврежден. Удалите используемый фильтр из папки C:\Program Files\Common Files\Microsoft Shared\Grphflt. Запустите программу установки, чтобы заново установить фильтр. Для получения дополнительных сведений по этому вопросу нажмите кнопку [image] .


Вводимый в ячейку текст не отображается на экране

  • Чтобы просмотреть несколько строк текста внутри выделенных ячеек, выберите команду Ячейки в меню Формат, а затем на вкладке Выравнивание установите флажок Переносить по словам. Если текст представляет собой одно длинное слово, то символы не будут перенесены; можно расширить столбец или уменьшить размеры используемого шрифта.


 Макрос, предназначенный для получения данных не выполняется

Макрос, предназначенный для получения данных не выполняется

Установка приложения Microsoft Query. Для работы макроса Microsoft Visual Basic на компьютер вместе с Microsoft Query должны быть также установлены объекты DAO для Visual Basic.

Проверка источника данных и драйвера. Убедитесь в том, что для указанного в макросе источника данных используется правильный драйвер ODBC или драйвер источника данных. См. Порядок установки драйверов.

Установка и загрузка надстройки ODBC. Выберите пункт Надстройки (меню Сервис) и установите в соответствующем окне флажок ODBC. Если этот флажок ODBC недоступен, эта надстройка не была установлена вместе с другими компонентами Microsoft Excel или Microsoft Office. В этом случае необходима установка надстройки ODBC.


Перетаскивание маркера заполнения приводит к удалению содержимого ячеек

  • Перетаскивание маркера заполнения влево или вверх и остановка в пределах выделенной области (без пересечения левой или верхней границы) приведет к стиранию выделенных данных. Прежде чем отпустить кнопку мыши, перетащите маркер заполнения за пределы выделенной области.


Примечания в сводной таблице не связаны с содержанием ячеек

Примечания в сводной таблице привязаны к самим ячейкам, к которым они были добавлены, а не к их содержанию. При внесении изменений в сводную таблицу примечания не перемещаются.


В структуре, состоящей из нескольких уровней, данные не группируются должным образом

Группирование только подробных данных. Группируя данные, выделяйте только образующие группу строки или столбцы с подробными данными. Не следует включать в выделяемую область соответствующую итоговую строку или столбец. Например, если строка 6 содержит итоговые данные для строк 3—5, то для создания группы выделите только строки 3—5.

Отображение всех данных перед их группированием. Чтобы сгруппировать структуру, состоящую из нескольких уровней, следует отобразить на экране все содержащиеся в ней данные. Убедитесь в том, что все подчиненные итоговые строки или столбцы и соответствующие им подробные данные, образующие следующий уровень структуры, выделены правильно. Например, строка 6 и 10 содержат итоги для строк 3—5 и строк 7—9 соответственно. Строка 11 содержит общий итог. Чтобы сгруппировать детальные данные для строки 11, выделите строки 3—10.

Изменение направления. Если положение символа отображения [image] или скрытия [image] не соответствует расположению подчиненных ему строк или столбцов структуры, то необходимо отобразить на листе все скрытые данные, а затем выделить структурируемый диапазон. В меню Данные, выберите пункт Группа и структура, выполните команду Настройка, а затем проверьте состояние флажков в разделе в направлении. Если итоговые строки или столбцы расположены выше или слева от соответствующих детальных строк или столбцов, снимите флажок в строках под детальными или в столбцах справа от детальных.


При заполнении и копировании данных не работают сообщения об ошибках и ограничения на данные

Поскольку возможно одновременное копирование в несколько ячеек, имеющих разные ограничения на данные, данная функция в этом случае не применяется. При копировании данных или заполнении ячеек данными сообщения не отображаются. Сообщения не будут отображаться также в том случае, если автор листа установил ограничения на данные, но не определил сообщения. Этот вопрос может быть решен несколькими способами.

  • Если лист содержит ограничения, данные следует вводить отдельно в каждую ячейку.

  • Чтобы предотвратить копирование данных и заполнение ячеек, выберите пункт Параметры (меню Сервис), откройте вкладку Правка и снимите флажок Перетаскивание ячеек. После этого разблокируйте ячейки, в которые требуется ввести данные, и установите защиту листа. Чтобы получить более подробные сведения, нажмите кнопку [image] .

Примечание. Проверка листа позволяет обнаружить ячейки, содержащие некорректные данные, которые попали туда в результате копирования или заполнения. Чтобы получить более подробные сведения, нажмите кнопку [image] .


Числа, даты и время отображаются неправильно

Числовые форматы. Отображение чисел, дат и времени суток на листе происходит согласно назначенному ячейкам числовому формату. Чтобы его изменить, выделите ячейки, выберите команду Ячейки в меню Формат, а затем на вкладке Число выберите необходимый формат. Для использования формата даты, принятого по умолчанию, укажите ячейку и нажмите сочетание клавиш CTRL+SHIFT+#; чтобы назначить формат времени, принятый по умолчанию, нажмите CTRL+SHIFT+@.

Отображение ##### вместо числа. Значение ошибки ##### отображается вместо числа, даты или времени в тех случаях, когда данные не могут поместиться в ячейке. Это значение может обозначать также отрицательный результат вычисления формулы даты или времени. Попробуйте увеличить ширину столбца.

Язык и стандарты. Используемые по умолчанию форматы денежной единицы, даты, времени и чисел можно задать в параметрах языка и стандартов, к настройке которых можно перейти из системной папки «Панель управления».


 При сортировке ячеек не выполняется сортировка рисованных и импортированных графических объектов

При сортировке ячеек не выполняется сортировка рисованных и импортированных графических объектов

Размеры и расположение. Высота и ширина объектов не должна превышать высоту или ширину сортируемого столбца. Например, при изменении порядка ячеек или строк высота объектов должна быть меньше высоты строки. При сортировке столбцов слева направо ширина объекта должна быть меньше ширины столбца. Если необходимо, перед выполнением сортировки данных измените высоту строки или ширину столбца.

Выделенный для сортировки диапазон ячеек должен включать все элементы объекта. Например, если объект выходит за пределы сортируемого текста, выделите также пустые строки или столбцы, на которых располагается объект.

Параметры. Возможно, параметры объекта были заданы таким образом, что при перемещении ячеек перемещения объекта не происходит. Чтобы объект перемещался при сортировке ячеек, нажмите кнопку Выбор объектов [image] на панели инструментов Рисование, после чего выделите объект с помощью мыши. Выберите в меню Формат команду Автофигура, Рисунок, Надпись, Объект WordArt, Элемент управления или Объект, а затем установите флажок перемещать, но не изменять размеры на вкладке Свойства.

Чтобы получить более подробные сведения об изменении свойств объекта ActiveX, нажмите кнопку [image] .


 Не удается изменить анимированный рисунок в формате GIF

Не удается изменить анимированный рисунок в формате GIF

Выполнить обрезку, изменить заливку, границу, тень или прозрачность анимированного рисунка в формате GIF с помощью панели инструментов Настройка изображения или диалогового окна Формат рисунка в Microsoft Excel нельзя. Для внесения изменений в такие рисунки следует воспользоваться соответствующей программой для редактирования анимированных рисунков в формате GIF, а затем снова добавить соответствующий файл в книгу.


Не удается обновить изображение ячеек Microsoft Excel в другом приложении

Перед копированием в другое приложение книга, содержащая ячейки, с которыми требуется установить связь, должна быть сохранена и для нее должно быть задано имя.

  1. Сохраните книгу, из которой будет скопировано изображение.

  2. Перейдите в приложение, куда будет скопировано изображение.

  3. В меню Правка другого приложения выберите команду Связи.

  4. Нажмите кнопку Изменить и укажите имя книги Excel, сохраненной на шаге 1.


 Верхний или нижний колонтитулы имеют неправильный вид

Верхний или нижний колонтитулы имеют неправильный вид

Можно выбрать подходящие верхние и нижние колонтитулы из имеющихся или создать собственные. В меню Вид выберите команду Колонтитулы.

Использование черно-белых колонтитулов. Текст колонтитулов всегда печатается черным цветом. Изменить цвет текста колонтитулов нельзя даже при наличии цветного принтера.

Печать одинаковых данных на каждой странице. Чтобы на каждой странице распечатать одинаковые данные (в их числе могут быть графические объекты), вместо заголовков следует пользоваться заголовками печати. Например, чтобы распечатать эмблему и адрес компании, поместите сведения в первые несколько строк листа. В меню Файл выберите команду Параметры страницы, а затем — вкладку Лист и введите номера строк, содержащих адрес, в поле сквозные строки. При печати широкой страницы на нескольких листах необходимо скопировать необходимые данные в дополнительные строки или столбцы.

Колонтитулы не должны содержать графические объекты или ссылки на определенные ячейки.

Сохранение существующих отступов. Левый и правый отступы колонтитулов равны 1,9 см. Они не зависят от соответствующих отступов печатной страницы. Вместо изменения отступа расположенный в одной строке заголовок может быть дополнен пробелами (в полях Слева или Справа). Чтобы перейти в эти поля, воспользуйтесь командами Создать верхний колонтитул или Создать нижний колонтитул в диалоговом окне Параметры страницы. Добавляемые в поле Справа пробелы на экране не видны, но на печать выводятся.

Изменение расстояний от кромки листа до колонтитулов. Отступ колонтитулов от верхнего или нижнего края листа можно изменять. Кроме того, при печати можно задать отступ данных от колонтитулов. Выберите команду Предварительный просмотр, [image] , нажмите кнопку Поля и перетащите с помощью мыши маркеры границ.

Маркеры изменения размера

Использование двух знаков (&) вместо при печати. Поскольку знак амперсанда используется Microsoft Excel для задания особого форматирования в колонтитулах, при необходимости ввести этот знак в колонтитул следует использовать два следующих подряд амперсанда &&. Например, чтобы напечатать заголовок «Подрядчики & услуги», следует ввести Подрядчики && услуги.


Не удается вывести на печать или сохранить открытую в собрании по сети книгу Excel

Открытую в собрании по сети книгу Microsoft Excel можно сохранить на диске или распечатать на принтере того компьютера, где открывалась данная книга. Команда Печать позволяет распечатать файл на принтере, принадлежащем ведущему собрание. Команда Сохранить позволяет сохранить файл на жестком диске компьютера, который принадлежит ведущему собрание, или на сервере, но не на своем жестком диске.

Если требуется сделать копию файла, участвующего в совместной работе, попросите ведущего собрания по сети отправить вам копию этого файла или скопируйте содержимое документа в файл на локальном компьютере.

Примечание. Сохранение книги возможно только при наличии соответствующих прав на нее.


 Не удается изменить масштаб диаграммы или разместить несколько диаграмм на одной печатной странице

Не удается изменить масштаб диаграммы или разместить несколько диаграмм на одной печатной странице

Выбор размера листа диаграммы при печати. Если диаграмма находится на листе диаграммы, ее можно масштабировать при печати. Перейдите на лист диаграммы, выберите команду Параметры страницы в меню Файл, а затем — вкладку Диаграмма. Установите переключатель Размер диаграммы при выводе на печать в нужное положение. При выборе пользовательская диаграмма будет иметь масштаб, заданный при перетаскивании ее маркеров выделения.

Изменение размеров внедренной диаграммы с помощью мыши. Для изменения размеров внедренной на лист диаграммы, выберите ее мышью, а затем перетащите маркеры изменения размера.

Печать нескольких вложенных диаграмм на одной странице. На одной странице нельзя вывести несколько листов диаграмм. Чтобы отпечатать две диаграммы или более на одной странице, создайте на листе внедренные диаграммы, затем измените их размеры так, чтобы диаграммы уместились на печатной странице. Команда Разметка страницы в меню Вид позволяет более точно определить расположение диаграмм в области печати.


Отсутствие некоторых объектов, доступных другим участникам собрания по сети

Проверьте, совпадает ли разрешение вашего экрана с разрешением экрана других участников собрания по сети. Изменение разрешения экрана.


 Невозможно найти созданную или перемещенную диаграмму

Невозможно найти созданную или перемещенную диаграмму

  • Если был создан или перемещен лист диаграммы, то диаграмму можно просмотреть или изменить. Для этого нужно выбрать внизу окна листа ярлычок листа для диаграммы.

  • Если была создана или перемещена внедренная диаграмма, то ее можно разместить на листе. Для этого необходимо выбрать команду Перейти в меню Правка, а затем выбрать команду Дополнительный. Выберите пункт Объекты и нажмите кнопку OK.


 Получено сообщение о том, что недостаточно памяти для создания отчета сводной таблицы или сводной диаграммы

Получено сообщение о том, что недостаточно памяти для создания отчета сводной таблицы или сводной диаграммы

Проверка параметра использования памяти. Если источником отчета является внешний источник данных, но не OLAP, в диалоговом окне сообщения нажмите кнопку OK. Создайте отчет заново, а на третьем шаге работы мастера нажмите кнопку Параметры. На вкладке Параметры внешних данных установите флажок оптимизировать память.

Экономия памяти посредством работы с полями страниц. Если оптимизация памяти не позволяет создать отчет сводной таблицы или диаграммы из внешних данных, настройте одно или несколько полей страниц для получения данных при выборе отдельных элементов. Для этого на третьем шаге работы мастера нажмите кнопку Макет и перетащите одно или несколько полей в область страницы. Два раза щелкните мышью поле страницы, а затем нажмите кнопку Подробнее. В параметрах поля страницы, выберите обновлять внешние данные при выборе каждого элемента (требует меньше памяти). См. сведения об использовании полей страниц для экономии памяти.

Упрощение отчета. Проверьте число добавляемых полей не слишком велико. В зависимости от объема памяти компьютера и количества исходных данных возможное число полей может изменяться. Если в сводной таблице необходимо использовать большое количество полей, добавляйте их в качестве полей строк (в отчетах сводных таблиц), полей рядов (в отчетах сводных диаграмм) или полей страниц. Поля страниц требуют наименьшего объема памяти. При создании поля строки или ряда запрашивается меньше памяти, чем для поля столбца (в отчете сводной таблицы) или для поля категории (в отчете сводной диаграммы).

Создание нескольких отчетов по одним и тем же данным одного из отчетов сводных таблиц. При создании отчета сводной таблицы или сводной диаграммы в Microsoft Excel используется промежуточная область хранения данных отчета. Если на основе одних и тех же данных строится несколько сводных таблиц, при возможности выберите вариант в другой сводной таблице на первом шаге выполнения мастера. При создании этим способом сводных таблиц используется одна копия источника данных, что позволяет избежать его многократного копирования в память.

Упрощение файла. Уменьшите число содержащихся в книге отчетов сводных таблиц и сводных диаграмм.

Создание отчета в отдельном файле. Если отчет сводной таблицы или сводной диаграммы основан на данных листа Microsoft Excel, создайте отчет в отдельной книге. Это позволит избавиться от необходимости одновременного хранения в оперативной памяти как самого отчета, так и данных листа. Важно помнить, что отчет сводной диаграммы должен создаваться в той же книге, что и связанный с ним отчет сводной таблицы.


Книга Microsoft Excel не открывается после ввода пароля

  • При вводе пароля учитывается регистр символов. Необходимо вводить строчные и прописные буквы в точности так, как они вводились при установке пароля.

  • Возможно, пароль был указан неправильно. Введите пароль еще раз.

  • Прежде чем открывать защищенную паролем книгу, убедитесь в том, что режим CAPS LOCK отключен.


Расставленные вручную разрывы страниц не принимаются во внимание

Если параметры книги заданы таким образом, чтобы на печать выводилось строго определенное число страниц, Excel будет автоматически пытаться уменьшить размер печатаемого листа, а расставленные вручную разрывы страниц учитываться не будут. Для проверки соответствующих настроек выберите пункт Параметры страницы в меню Файл, откройте вкладку Страница и просмотрите значение параметра разместить не более чем на в разделе Масштаб.

Использование параметра «установить» вместо «разместить не более чем на». Для печати листа на определенном числе страниц с использованием расставленных вручную разрывов страниц выберите пункт Параметры страницы в меню Файл, откройте вкладку Страница и выберите параметр установить.

Определение каждой страницы как отдельного диапазона печати. Если выбор параметра установить не дает нужного результата, попробуйте определить диапазон печати для каждой из выбранных страниц. На печать будут выводиться несмежные диапазоны в областях печати на отдельных страницах.

  1. Добавьте пустые строки или столбцы туда, где должны проходить разрывы страниц.

  2. Выделите диапазон первой страницы (за исключением пустой строки или столбца).

  3. Удерживая в нажатом положении клавишу CTRL, выделите диапазон второй страницы, исключая пустые строки или столбцы. Повторяйте выполнять описанные действия, пока не будут выделены все предназначенные для печати страницы.

  4. В меню Файл выберите пункт Область печати, а затем команду Задать.

  5. В меню Файл выберите пункт Параметры страницы, откройте вкладку Страница, выберите параметр разместить не более чем на, а затем укажите нужное число страниц.


После разгруппирования или удалении структуры данные остаются скрытыми

Если данные разгруппируются или удаляется структура, а подробные сведения остаются скрытыми, строки или столбцы сведений могут также не отображаться. Для просмотра данных выделите видимые соседние строки или столбцы. Выберите команду Строка или Столбец в меню Формат, а затем — команду Показать.


Страница должна быть напечатана на одной странице в ширину (или в высоту).

Чтобы столбцы или строки не разбивались при печати на несколько страниц, можно так подобрать масштаб, чтобы документ уместился на одной странице в ширину или в высоту. В меню Файл выберите команду Параметры страницы, а затем — вкладку Страница. Установите переключатель в положение разместить не более чем на и введите 1 в поле страницах в ширину или в поле страницах в высоту, затем удалите число из второго поля.


 Сохраняя первоначально выделенный диапазон, необходимо добавить к нему или исключить из него несколько ячеек

Сохраняя первоначально выделенный диапазон, необходимо добавить к нему или исключить из него несколько ячеек

  • Удерживая клавишу SHIFT, укажите последнюю ячейку, которую необходимо включить в заново выделяемый диапазон. Прямоугольная область между активной ячейкой и указанной областью образует новый диапазон.

    Чтобы включить в диапазон дополнительные несмежные ячейки или несмежные диапазоны ячеек, укажите или выделите их, удерживая клавишу CTRL.


 При вводе значений по столбцам автозаполнение происходит не всегда

При вводе значений по столбцам автозаполнение происходит не всегда

Выбор параметра автоматического заполнения. Убедитесь в том, что установлен флажок Автозаполнение значений ячеек на вкладке Правка (команда Параметры в меню Сервис).

Проверка местонахождения курсора. Поместите курсор справа от последнего символа ячейки. Автоматическое заполнение происходит только в том случае, когда курсор находится в конце текущего содержимого ячейки.

Проверка соответствия значений. Вводимые значения могут не соответствовать ни одной из имеющихся в столбце записей или соответствовать нескольким записям. Например, если набрана последовательность знаков AXY, и в столбце имеются записи «AXY1» и «AXY2», то автоматическое заполнение ячейки не произойдет.

Выбор правильной записи. Чтобы выбрать необходимую запись, нажмите клавиши ALT+СТРЕЛКА ВНИЗ и выберите нужную запись. Можно также указать ячейку с помощью правой кнопки мыши и воспользоваться командой контекстного меню Выбор из списка.

Записи в строке. Поиск записей выполняется по столбцу с активной ячейкой. Если необходимые записи находятся в строке, а не в столбце, то автоматическое заполнение ячеек не производится.

Числа, даты, время. Автоматическое заполнение выполняется только для текстовых данных. Записи, полностью состоящие из чисел, дат или значений времени автоматически не заполняются.

Текущая область данных. Убедитесь в том, что активная ячейка расположена в пределах текущей области данных. Например, если областью данных является диапазон ячеек A1:E10, то автоматическое заполнение будет произведено для ячейки A11, даже если ячейка A10 пуста. Однако автоматическое заполнение не выполнится для ячейки A12, так как она расположена вне области данных.

Большие списки. Если используется большой список, то для автоматического заполнения может потребоваться некоторое время.


Значения влияющих ячеек и целевой ячейки или ячейки, на которую наложены ограничения, сильно различаются.

Если значения влияющих ячеек и целевых ячеек или ячеек, на которые наложены ограничения, отличаются на несколько порядков, установите флажок Автоматическое масштабирование в диалоговом окне Параметры поиска решения. В случае нелинейных задач, перед тем как, нажать кнопку Выполнить в диалоговом окне Поиск решения, убедитесь, что начальные значения во влияющих ячейках того же порядка, что и ожидаемые конечные значения.


 Для вычислений в поле данных в качестве итоговой функции вместо функции «Сумма» используется функция «Количество значений» и наоборот

Для вычислений в поле данных в качестве итоговой функции вместо функции «Сумма» используется функция «Количество значений» и наоборот

Проверка наличия пустых ячеек в поле. По умолчанию поле данных в отчете сводной таблицы, источником для которого являются отличные от OLAP исходные данные, использует итоговую функцию «Сумма» для числовых данных и итоговую функцию «Количество значений» для нечисловых и включающих пустые ячейки данных. Таким образом, если поле данных является числовым, но содержит пустые ячейки, будет использоваться функция «Сумма».

Определение, основан ли отчет на источнике данных OLAP. Если отчет сводной таблицы или сводной диаграммы основан на базе данных OLAP, доступные итоговые функции определяются сервером OLAP. Их изменение в отчете Excel невозможно. См. Использует ли отчет сводной таблицы данные OLAP.

Изменение итоговой функции для поля. Если отчет сводной таблицы или диаграммы основан на отличных от OLAP данных, можно два раза щелкнуть мышью нужное поле с итоговой функцией «Количество значений», а затем выбрать в списке Операция функцию Сумма.


 Не удается вывести на печать автофигуры и объекты, скопированные или импортированные из других приложений

Не удается вывести на печать автофигуры и объекты, скопированные или импортированные из других приложений

  1. Выберите с помощью правой кнопки мыши объект, который требуется вывести на печать.

    Для автофигур с текстом или без заливки (например, только контур фигуры), следует помещать указатель мыши на границу фигуры.

  2. В контекстном меню выберите команду Формат тип объекта, а затем перейдите на вкладку Свойства.

  3. Выберите параметр Выводить объект на печать.

Примечание. Если выводимым на печать объектом является элемент ActiveX, следует вывести на экран панель инструментов Элементы управления и изменить свойства объекта в режиме конструктора. Чтобы получить более подробные сведения, нажмите кнопку [image] .


Шаблон отсутствует в диалоговом окне «Создание документа»

Microsoft Excel показывает шаблон в диалоговом окне Создание документа в том случае, если файл шаблона сохранен в одном из следующих мест.

  • В папке «Шаблоны», которая находится обычно в каталоге
    C:\ОС\Profiles\Имя_пользователя\Application Data\Microsoft\Templates
    , где ОС — папка операционной системы, например Windows.

  • В папке XLStart, которая находится обычно в каталоге
    C:\ОС\Profiles\Имя_пользователя\Application Data\Microsoft\Excel\XLStart
    , где ОС — папка операционной системы, например Windows.

  • В папке, которая была указана в окне Каталог автозагрузки на вкладке Общие диалогового окна Параметры (меню Сервис).


 Книга открывается только для чтения

Книга открывается только для чтения

Возможна одна из следующих двух причин.

  • В результате установленного автором книги ограничения она может быть открыта только для чтения. Дополнительные сведения можно получить у автора книги.

  • В более ранней, чем Microsoft Excel 97 версии приложения, книга Excel 2000 открывается только для чтения, как защищенная паролем. Такую книгу следует открывать и сохранять в Excel 97 или в последующих версиях.


 Отсутствует числовое форматирование данных в отчете сводной таблицы или диаграммы

Отсутствует числовое форматирование данных в отчете сводной таблицы или диаграммы

При создании отчета сводной таблицы или диаграммы числовое форматирование исходных данных в Microsoft Excel не используется. Отчет сводной таблицы будет содержать только стандартный числовой формат: без десятичных разделителей и разделителей групп разрядов; отрицательные числа отображаются со знаком минус. Форматирование оси значений в отчете сводной диаграммы будет соответствовать числовому форматированию ячеек данных в связанном отчете сводной таблицы.

Отчет сводной таблицы. Для использования других видов числовых форматов в отчете сводной таблицы необходимо выбрать мышью ячейку в области данных. На панели инструментов Сводная таблица следует выбрать Параметры поля [image] . На вкладке Число выберите нужный числовой формат и соответствующие параметры. Эти действия нужно повторить для каждого поля данных.

Отчет сводной диаграммы. Для использования других видов числовых форматов на оси значений в отчете сводной диаграммы вместо автоматического форматирования, которое подставляется из соответствующего отчета сводной таблицы, отформатируйте ось вручную.


Отображение клетчатого узора на экранах других участников собрания по сети

Уберите другие окна, которые могут заслонять книгу.

  • Закройте неиспользуемые приложения.

  • Сверните другие окна, расположенные на рабочем столе.


Символы структуры не отображаются на листе

Убедитесь в том, что отображение включено. Выберите команду Параметры в меню Сервис, а затем откройте вкладку Вид. Установите флажок Символы структуры. Если символов все еще нет на экране, на панели инструментов Стандартная в поле Масштаб выберите увеличение 100%.


Оптимальное решение не найдено.

Поиск решения может остановиться до достижения оптимального решения по следующим причинам.

  • Пользователь прервал процесс поиска.

  • Команда Показывать результаты итераций в диалоговом окне Параметры поиска решения выбрана перед Выполнить.

  • Пользователь нажал кнопку Стоп в режиме пошагового выполнения итераций, по истечении времени, отведенного на работу процедуры, или после выполнения заданного числа итераций.

  • Установлен флажок Линейная модель в диалоговом окне Параметры поиска решения, в то время как решаемая задача не линейна.

  • Значение, заданное в поле Установить диалогового окна Поиск решения, неограниченно увеличивается или уменьшается.

  • Необходимо изменить значения полей Максимальное время или Итерации в диалоговом окне Параметры поиска решения.

  • В случае задач, значения в которых ограничены множеством целых чисел, необходимо уменьшить значение в поле Допустимое отклонение диалогового окна Параметры поиска решения, что позволит найти лучшее решение.

  • В случае нелинейных задач необходимо уменьшить значение в поле Сходимость диалогового окна Параметры поиска решения, что позволит продолжать поиск решения, когда значение в целевой ячейке изменяется медленно.

  • Необходимо установить флажок Автоматическое масштабирование в диалоговом окне Параметры поиска решения, если значения влияющих ячеек или значения влияющей и целевой ячеек различаются на несколько порядков.

После остановки на экране отображается диалоговое окно Результаты поиска решения. Установите переключатель в положение Сохранить найденное решение или Восстановить исходные значения, внесите нужные изменения и запустите процедуру поиска решения снова. Чтобы получить более подробные сведения об итоговых сообщениях процедуры поиска решения, нажмите кнопку [image] .


 Некоторые формулы были заменены на текст или значения.

Некоторые формулы были заменены на текст или значения.

Если при открытии в Microsoft Excel файла, созданного в другой программе, встречается оператор или функция, которая не может быть преобразована, для заполнения ячейки используется результат вычисления формулы, а не сама формула. В Microsoft Excel возможно повторное задание формулы с использованием эквивалентных операторов и функций.


Встроенный шаблон не входит в установленную версию Microsoft Excel

Все встроенные шаблоны доступны только в том случае, если при выполнении выборочной установки Microsoft Excel они были выбраны. Для получения более подробных сведений об установке шаблонов нажмите кнопку [image] .


Формат файла, в котором должна быть сохранена книга, не появляется в диалоговом окне "Сохранить как".

Убедитесь, что необходимый формат файла включен в Microsoft Excel и установлен на компьютере. Для получения более подробных сведений нажмите кнопку [image] .


Маркер заполнения отсутствует

  • Выберите команду Параметры в меню Сервис, а затем – вкладку Правка и убедитесь, что флажок Разрешить перетаскивание ячеек установлен. Если строка или столбец выделены полностью, то маркер заполнения находится в начале строки или столбца.


 Почему постоянно изменяется размер шрифта на диаграмме?

Почему постоянно изменяется размер шрифта на диаграмме?

По умолчанию при изменении размера внедренной диаграммы или области диаграммы на листе диаграммы шрифт изменяется пропорционально. Если же необходимо, чтобы размер шрифта в диаграмме не изменялся, нажатием кнопки мыши на пустом участке между границей диаграммы и областью построения выделите область диаграммы. В меню Формат выберите команду Выделенная область диаграммы, перейдите к вкладке Шрифт, а затем снимите флажок Автомасштабирование.


 Имя предполагаемого участника собрания по сети отсутствует в списке

Имя предполагаемого участника собрания по сети отсутствует в списке

Подключитесь к другому серверу

  • В диалоговом окне Вызов выберите нужный элемент в списке Каталог.

Отправьте сообщение по электронной почте или позвоните по телефону

Уведомьте участника о предстоящем собрании по сети. Определите, к какому серверу каталогов подключен участник, укажите имя его компьютера либо IP-адрес.


 Не удается объединить книги

Не удается объединить книги

Требования к объединяемым книгам. Чтобы объединить изменения двух книг, они должны удовлетворять следующим требованиям:

  • обе книги должны быть копиями одной книги;

  • файлы копий должны иметь различные имена файлов;

  • книги либо не должны иметь паролей, либо должны иметь одинаковые пароли;

  • книга, с которой были сделаны копии, должна была являться общей;

  • при создании копий необходимо, чтобы ведение журнала изменений было включено;

  • к моменту слияния копий журнал изменений должен вестись как минимум столько дней, сколько прошло со времени изготовления этих копий. Например, если журнал изменений для книг велся в течение 30 дней, а копии были сделаны 45 дней назад, то книги объединять нельзя.

    Если включается ведение журнала изменений, но точно не известно, когда будет происходить слияние книг, то журнал можно сохранить, установив большое количество дней, в течение которых он будет вестись (максимум до 32 767 дней).

Объединение изменений вручную. Если объединить две книги не удается, то данные из одной книги могут быть включены в другую вручную, с помощью их копирования и вставки.


Копирование ячеек с помощью маркера заполнения приводит к появлению неправильных данных

  • Если данные могут быть продолжены в виде ряда, например, числа, даты или элементы пользовательского списка автозаполнения, то их копирование приведет к приращению значений в пределах выделенного диапазона. В этом случае выделите начальные значения еще раз и перетащите маркер заполнения, удерживая нажатой клавишу CTRL.


Значения преобразованного листа отличаются от значений исходного листа.

В Microsoft Excel некоторые операторы и функции вычисляются в порядке, отличном от используемого в других электронных таблицах. Чтобы при вычислении формул использовались правила Lotus 1-2-3, следует в меню Сервис выбрать команду Параметры и затем вкладку Переход. В группе Параметры листа установить флажок Производить вычисления по правилам Lotus 1-2-3.


Предпосылки для запуска процедуры поиска решения с другими начальными условиями.

Если найденное решение нелинейной задачи существенно отличается от ожидаемого результата, запустите процедуру поиска решения с другими начальными значениями влияющих ячеек. Если задать такие значения влияющих ячеек, которые близко расположены от экстремальной точки целевой функции, можно значительно сократить время поиска решения.

При решении линейных задач (то есть, если установлен флажок Линейная модель в диалоговом окне Параметры поиска решения) от начальных значений влияющих ячеек не зависят ни конечные значения, ни время поиска решения.


 При печати на бумагу выводится только часть листа

При печати на бумагу выводится только часть листа

Проверка определения области печати. Если на листе имеется область печати, то только она будет отображена на бумаге. Чтобы узнать, содержится ли на листе область печати, выберите команду Разметка страницы в меню Вид. Область печати отображается на белом фоне.

Очистка области печати для вывода всего листа. Чтобы очистить область печати, выберите команду Очистить область печати (пункт Область печати в меню Файл).

Изменение области печати. Чтобы добавить или удалить из области печати строки и столбцы, в меню Вид выберите команду Разметка страницы, а затем перетащите границы области печати.

Чтобы добавить в область печати не прилегающие к ней ячейки, выделите эти ячейки, щелкните одну из выделенных ячеек правой кнопкой мыши, а затем выберите в контекстном меню команду Добавить к области печати.


Не удается вывести документ на печать

Проверка настроек печати в Windows. Процесс печати на компьютере в первую очередь зависит от настроек Windows. С помощью руководства по устранению ошибок при печати выясните, правильно ли установлен принтер. В меню Пуск Windows выполните команду Справка. Далее откройте вкладку Предметный указатель, затем введите фразу устранение ошибок при печати. Нажмите кнопку Вывести. Следуйте дальнейшим указаниям электронного справочного руководства.

Проверка настроек печати в Microsoft Excel. Если принтер в Windows установлен правильно, проверьте настройки печати в Microsoft Excel. В частности, удостоверьтесь в том, что выбранный в приложении принтер соответствует принтеру, на котором в действительности будет выполняться печать. В меню Файл выберите команду Печать. Выберите нужное устройство в раскрывающемся списке Принтер.


 После обновления внешнего диапазона данных нарушаются сортировка и форматирование

После обновления внешнего диапазона данных нарушаются сортировка и форматирование

Изменение форматирования в Query не влияет на представление данных в Excel. Используемое форматирование влияет на вид таблицы результатов только в Microsoft Query. После возврата данных в Microsoft Excel изменения элементов форматирования, сделанные в Microsoft Query (например, скрытие полей, изменение ширины столбца, высоты строк, шрифта, стиля или размера текста) не отображаются.

Необходимость сохранения форматирования Excel после обновления данных. При каждом обновлении диапазона внешних данных существующие данные в Microsoft Excel заменяются новыми данными. При этом удаляются все структуры и промежуточные итоги. Чтобы сохранить автоматическое форматирование, но не сортировку или организацию структуры, для области результатов запроса нажмите кнопку Свойства диапазона данных [image] на панели инструментов Внешние данные и убедитесь, что в группе Отображение данных установлен флажок автоформат данных.

Сохранение сортировки путем копирования данных. При каждом обновлении диапазона внешних данных все результаты сортировки пропадают. Если необходимо упорядочить или отформатировать данные внешнего диапазона и сохранить сортировку и форматирование, скопируйте данные, а затем используйте команду Специальная вставка с параметром значения для того, чтобы поместить данные на другой лист книги. Далее отформатируйте данные так, как это необходимо. Сортировка и элементы форматирования будут сохранены, но обновление данных станет невозможным, так как лежащий в основе запрос, связанный с внешним диапазоном данных, скопирован не был.

Восстановление сортировки и форматирования с помощью макроса. Чтобы иметь возможность обновления диапазона внешних данных с сохранением сортировки и форматирования, попробуйте создать макрос, предназначенный для форматирования данных области, а затем запустите его после обновления данных. Выберите команду Макрос в меню Сервис, а затем — команду Запись макроса. Определите соответствующее форматирование в диапазоне внешних данных. Нажмите кнопку останова макроса на панели инструментов Остановить запись. Для получения более подробных сведений о записи макроса нажмите кнопку [image] .

Отключение автоматического форматирования после обновления данных. Автоматическое форматирование после обновления диапазона внешних данных можно отключить. Для получения дополнительных сведений нажмите кнопку [image] .


Функции для работы с базами данных и списками

БДДИСП Оценивает дисперсию по выборке из выделенных записей базы данных

БДДИСПП Вычисляет дисперсию по генеральной совокупности из выделенных записей базы данных

БДПРОИЗВЕД Перемножает значения определенного поля в записях базы данных, удовлетворяющих условию

БДСУММ Суммирует числа в поле для записей базы данных, удовлетворяющих условию

БИЗВЛЕЧЬ Извлекает из базы данных одну запись, удовлетворяющую заданному условию

БСЧЁТ Подсчитывает количество числовых ячеек в базе данных

БСЧЁТА Подсчитывает количество непустых ячеек в базе данных

ДМАКС Возвращает максимальное значение среди выделенных записей базы данных

ДМИН Возвращает минимальное значение среди выделенных записей базы данных

ДСРЗНАЧ Возвращает среднее значение выбранных записей базы данных

ДСТАНДОТКЛ Оценивает стандартное отклонение по выборке из выделенных записей базы данных

ДСТАНДОТКЛП Вычисляет стандартное отклонение по генеральной совокупности из выделенных записей базы данных

ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ Возвращает данные, хранящиеся в сводной таблице


Функции для работы с датой и временем

ВРЕМЗНАЧ Преобразует время из текстового формата в числовой формат

ВРЕМЯ Возвращает заданное время в числовом формате

ГОД Преобразует дату в числовом формате в год

ДАТА Возвращает заданную дату в числовом формате Microsoft Excel

ДАТАЗНАЧ Преобразует дату из текстового формата в числовой

ДАТАМЕС Возвращает дату в числовом формате, отстоящую на заданное число месяцев вперед или назад от начальной даты

ДЕНЬ Преобразует дату в числовом формате в день месяца

ДЕНЬНЕД Преобразует дату в числовом формате в день недели

ДНЕЙ360 Вычисляет количество дней между двумя датами на основе 360-дневного года

ДОЛЯГОДА Возвращает долю года, которую составляет количество дней между начальной и конечной датами

КОНМЕСЯЦА Возвращает дату в числовом формате для последнего дня месяца, отстоящего вперед или назад на заданное число месяцев.

МЕСЯЦ Преобразует дату в числовом формате в месяцы

МИНУТЫ Преобразует дату в числовом формате в минуты

РАБДЕНЬ Возвращает дату в числовом формате, отстоящую вперед или назад на заданное количество рабочих дней

РАЗНДАТ Вычисляет число дней, месяцев и лет между двумя датами.

СЕГОДНЯ Возвращает числовой формат текущей даты

СЕКУНДЫ Преобразует дату в числовом формате в секунды

ТДАТА Возвращает текущую дату и время в числовом формате

ЧАС Преобразует дату в числовом формате в часы

ЧИСТРАБДНИ Возвращает количество рабочих дней между двумя датами


Функции для работы с DDE и внешние функции

SQL.REQUEST Связывается с внешним источником данных и выполняет запрос из рабочего листа. Затем функция SQL.REQUEST возвращает результат в виде массива, при этом не требуется дополнительного программирования

ВЫЗВАТЬ Вызывает процедуру из библиотеки DLL или программного ресурса

РЕГИСТРАТОР.ИД Возвращает регистрационный номер указанной библиотеки DLL или ранее зарегистрированного программного ресурса

Подробнее о функциях ВЫЗВАТЬ и РЕГИСТРАТОР


Инженерные функции

БЕССЕЛЬ.I Возвращает модифицированную функцию Бесселя In(x)

БЕССЕЛЬ.J Возвращает функцию Бесселя Jn(x)

БЕССЕЛЬ.K Возвращает модифицированную функцию Бесселя Kn(x)

БЕССЕЛЬ.Y Возвращает функцию Бесселя Yn(x)

ВОСЬМ.В.ДВ Преобразует восьмеричное число в двоичное

ВОСЬМ.В.ДЕС Преобразует восьмеричное число в десятичное

ВОСЬМ.В.ШЕСТН Преобразует восьмеричное число в шестнадцатеричное

ДВ.В.ВОСЬМ Преобразует двоичное число в восьмеричное

ДВ.В.ДЕС Преобразует двоичное число в десятичное

ДВ.В.ШЕСТН Преобразует двоичное число в шестнадцатеричное

ДЕЛЬТА Проверяет равенство двух значений

ДЕС.В.ВОСЬМ Преобразует десятичное число в восьмеричное

ДЕС.В.ДВ Преобразует десятичное число в двоичное

ДЕС.В.ШЕСТН Преобразует десятичное число в шестнадцатеричное

ДФОШ Возвращает дополнительную функцию ошибки

КОМПЛЕКСН Преобразует коэффициенты при вещественной и мнимой частях комплексного числа в комплексное число

МНИМ.ABS Возвращает абсолютную величину (модуль) комплексного числа

МНИМ.COS Возвращает косинус комплексного числа

МНИМ.EXP Возвращает экспоненту комплексного числа

МНИМ.LN Возвращает натуральный логарифм комплексного числа

МНИМ.LOG10 Возвращает обычный (десятичный) логарифм комплексного числа

МНИМ.LOG2 Возвращает двоичный логарифм комплексного числа

МНИМ.SIN Возвращает синус комплексного числа

МНИМ.АРГУМЕНТ Возвращает значение аргумента комплексного числа (тета) — угол, выраженный в радианах

МНИМ.ВЕЩ Возвращает коэффициент при вещественной части комплексного числа

МНИМ.ДЕЛ Возвращает частное от деления двух комплексных чисел

МНИМ.КОРЕНЬ Возвращает значение квадратного корня из комплексного числа

МНИМ.ПРОИЗВЕД Возвращает произведение двух комплексных чисел

МНИМ.РАЗН Возвращает разность двух комплексных чисел

МНИМ.СОПРЯЖ Возвращает комплексно-сопряженное комплексное число

МНИМ.СТЕПЕНЬ Возвращает комплексное число, возведенное в целую степень

МНИМ.СУММ Возвращает сумму комплексных чисел

МНИМ.ЧАСТЬ Возвращает коэффициент при мнимой части комплексного числа

ПОРОГ Проверяет, не превышает ли данное число порогового значения

ПРЕОБР Преобразует число из одной системы мер в другую

ФОШ Возвращает функцию ошибки

ШЕСТН.В.ВОСЬМ Преобразует шестнадцатеричное число в восьмеричное

ШЕСТН.В.ДВ Преобразует шестнадцатеричное число в двоичное

ШЕСТН.В.ДЕС Преобразует шестнадцатеричное число в десятичное


Финансовые функции

АМГД Возвращает годовую амортизацию имущества для указанного периода

АМОРУВ Возвращает величину амортизации для каждого отчетного периода

АМОРУМ Возвращает величину амортизации для каждого периода

АМР Возвращает величину непосредственной амортизации имущества за один период

БЗ Возвращает будущее значение вклада

БЗРАСПИС Возвращает будущее значение начального предложения после учета ряда сложных процентных ставок

ВНДОХ Возвращает внутреннюю скорость оборота для ряда последовательных операций с наличными

ДАТАКУПОНДО Возвращает предыдущую дату купона перед датой соглашения

ДАТАКУПОНПОСЛЕ Возвращает следующую дату купона после даты соглашения

ДДОБ Возвращает величину амортизации имущества для указанного периода при использовании метода двукратного учета амортизации или иного явно указанного метода

ДЛИТ Возвращает ежегодную продолжительность действия ценных бумаг с периодическими выплатами по процентам

ДНЕЙКУПОН Возвращает число дней в периоде купона, который содержит дату соглашения

ДНЕЙКУПОНДО Возвращает количество дней между началом периода купона и датой соглашения

ДНЕЙКУПОНПОСЛЕ Возвращает число дней от даты соглашения до срока следующего купона

ДОБ Возвращает амортизацию имущества на заданный период, используя метод постоянного учета амортизации

ДОХОД Возвращает доход от ценных бумаг, по которым производятся периодические выплаты процентов

ДОХОДКЧЕК Возвращает доход по казначейскому чеку

ДОХОДПЕРВНЕРЕГ Возвращает доход по ценным бумагам с нерегулярным первым периодом

ДОХОДПОГАШ Возвращает годовой доход от ценных бумаг, процент по которым выплачивается в срок погашения

ДОХОДПОСЛНЕРЕГ Возвращает доход по ценным бумагам с нерегулярным последним периодом

ДОХОДСКИДКА Возвращает годовой доход по ценным бумагам, на которые сделана скидка. Пример — казначейские чеки.

ИНОРМА Возвращает процентную ставку для полностью оплаченных ценных бумаг

КПЕР Возвращает общее количество периодов выплаты для данного вклада

МВСД Возвращает внутреннюю скорость оборота для ряда последовательных операций с наличными при различных процентных ставках для выплат и поступлений

МДЛИТ Возвращает модифицированную длительность Маколея для ценных бумаг с предполагаемой номинальной стоимостью 100 рублей

НАКОПДОХОД Возвращает накопленный доход по ценным бумагам с периодической выплатой процентов

НАКОПДОХОДПОГАШ Возвращает накопленный доход по ценным бумагам, процент по которым выплачивается в срок вступления в силу

НОМИНАЛ Возвращает номинальную годовую процентную ставку

НОРМА Возвращает норму прибыли за один период при выплате ренты

НПЗ Возвращает чистый текущий объем вклада, вычисляемый на основе ряда последовательных поступлений наличных и нормы скидки

ОБЩДОХОД Возвращает общую выплату по займу между двумя периодами

ОБЩПЛАТ Возвращает общую выплату, произведенную между двумя периодическими выплатами

ОСНПЛАТ Возвращает величину выплат на основной капитал для вклада в заданный период

ПДОБ Возвращает величину амортизации имущества для явно указанного или соответствующего периода при использовании метода разового учета амортизации

ПЗ Возвращает текущий объем вклада

ПЛПРОЦ Возвращает величину выплаты прибыли на вложения за данный период

ПОЛУЧЕНО Возвращает сумму, полученную в срок вступления в силу полностью обеспеченных ценных бумаг

ППЛАТ Возвращает величину выплаты за один период годовой ренты

ПРОЦПЛАТ Вычисляет выплаты за указанный период выплат.

РАВНОКЧЕК Возвращает эквивалентный облигации доход по казначейскому чеку

РУБЛЬ.ДЕС Преобразует цену в рублях, выраженную в виде дроби, в цену в рублях, выраженную десятичным числом

РУБЛЬ.ДРОБЬ Преобразует цену в рублях, выраженную десятичным числом, в цену в рублях, выраженную в виде дроби

СКИДКА Возвращает норму скидки для ценных бумаг

ЦЕНА Возвращает цену за 100 рублей нарицательной стоимости ценных бумаг, по которым производится периодическая выплата процентов

ЦЕНАКЧЕК Возвращает цену за 100 рублей нарицательной стоимости для казначейского чека

ЦЕНАПЕРВНЕРЕГ Возвращает цену за 100 рублей нарицательной стоимости ценных бумаг с нерегулярным первым периодом

ЦЕНАПОГАШ Возвращает цену за 100 рублей нарицательной стоимости ценных бумаг, по которым выплачивается прибыль в момент вступления в силу

ЦЕНАПОСЛНЕРЕГ Возвращает цену за 100 рублей нарицательной стоимости ценных бумаг с нерегулярным последним периодом

ЦЕНАСКИДКА Возвращает цену за 100 рублей нарицательной стоимости ценных бумаг, на которые сделана скидка

ЧИСЛКУПОН Возвращает количество купонов, которые могут быть оплачены между датой соглашения и сроком вступления в силу

ЧИСТВНДОХ Возвращает внутреннюю скорость оборота для непериодических денежных поступлений

ЧИСТНЗ Возвращает чистую текущую стоимость инвестиции, вычисляемую на основе ряда поступлений наличных, которые не обязательно являются периодическими

ЭФФЕКТ Возвращает действующие ежегодные процентные ставки


Список функций по категориям

Арифметические и тригонометрические функции

Дата и время

Инженерные функции

Информационные функции

Логические функции

Работа со списками и базами данных

Ссылка и подстановка

Статистические функции

Финансовые функции

Функции для работы с DDE и внешние функции

Функции для работы с текстом


Информационные функции

ЕЛОГИЧ Возвращает логическое значение ИСТИНА, если аргумент ссылается на логическое значение

ЕНД Возвращает логическое значение ИСТИНА, если аргумент ссылается на значение ошибки #Н/Д (значение недоступно)

ЕНЕТЕКСТ Возвращает логическое значение ИСТИНА, если аргумент ссылается на значение, которое не является текстом

ЕНЕЧЁТ Возвращает логическое значение ИСТИНА, если аргумент — нечетное число

ЕОШ Возвращает логическое значение ИСТИНА, если аргумент ссылается на любое значение ошибки, кроме #Н/Д

ЕОШИБКА Возвращает логическое значение ИСТИНА, если аргумент ссылается на любое значение ошибки

ЕПУСТО Возвращает логическое значение ИСТИНА, если аргумент является ссылкой на пустую ячейку

ЕССЫЛКА Возвращает логическое значение ИСТИНА, если аргумент ссылается на ссылку

ЕТЕКСТ Возвращает логическое значение ИСТИНА, если аргумент ссылается на текст

ЕЧЁТН Возвращает логическое значение ИСТИНА, если аргумент — четное число

ЕЧИСЛО Возвращает логическое значение ИСТИНА, если аргумент ссылается на число

ИНФОРМ Возвращает информацию о текущей операционной среде

НД Возвращает значение ошибки #Н/Д

СЧИТАТЬПУСТОТЫ Подсчитывает количество пустых ячеек в заданном диапазоне

ТИП.ОШИБКИ Возвращает номер, соответствующий одному из типов ошибок Microsoft Excel

ТИП Возвращает тип значения

Ч Возвращает значение, преобразованное в число

ЯЧЕЙКА Возвращает информацию о формате, местоположении или содержимом ячейки


Логические функции

ЕСЛИ Выполняет проверку условия

И Возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА

ИЛИ Возвращает ИСТИНА, если хотя бы один аргумент имеет значение ИСТИНА

ИСТИНА Возвращает логическое значение ИСТИНА

ЛОЖЬ Возвращает логическое значение ЛОЖЬ

НЕ Меняет на противоположное логическое значение своего аргумента


Функции ссылки и автоподстановки

АДРЕС Возвращает ссылку на отдельную ячейку в рабочем листе в виде текста

ВПР Ищет значение в первом столбце массива и возвращает значение из ячейки в найденной строке и указанном столбце

ВЫБОР Выбирает значение из списка значений по индексу

ГИПЕРССЫЛКА Создает ссылку, открывающую документ, находящийся на жестком диске, сервере сети или в Интернете

ГПР Ищет значение в первой строке массива и возвращает значение из ячейки в найденном столбце и указанной строке

ДВССЫЛ Возвращает ссылку, заданную текстовым значением

ИНДЕКС Использует индекс для выбора значения из ссылки или массива

ОБЛАСТИ Возвращает количество областей в ссылке

ПОИСКПОЗ Ищет значения в ссылке или массиве

ПРОСМОТР Ищет значения в векторе или массиве

СМЕЩ Возвращает смещение ссылки относительно заданной ссылки

СТОЛБЕЦ Возвращает номер столбца, на который указывает ссылка

СТРОКА Возвращает номер строки, определяемой ссылкой

ТРАНСП Возвращает транспонированный массив

ЧИСЛСТОЛБ Возвращает количество столбцов в массиве или ссылке

ЧСТРОК Возвращает количество строк в ссылке


Арифметические и тригонометрические функции

ABS Возвращает модуль (абсолютную величину) числа

ACOS Возвращает арккосинус числа

ACOSH Возвращает гиперболический арккосинус числа

ASIN Возвращает арксинус числа

ASINH Возвращает гиперболический арксинус числа

ATAN Возвращает арктангенс числа

ATAN2 Возвращает арктангенс для заданных координат x и y

ATANH Возвращает гиперболический арктангенс числа

COS Возвращает косинус числа

COSH Возвращает гиперболический косинус числа

EXP Возвращает экспоненту заданного числа

LN Возвращает натуральный логарифм числа

LOG Возвращает логарифм числа по заданному основанию

LOG10 Возвращает десятичный логарифм числа

SIN Возвращает синус заданного угла

SINH Возвращает гиперболический синус числа

TAN Возвращает тангенс числа

TANH Возвращает гиперболический тангенс числа

ГРАДУСЫ Преобразует радианы в градусы

ДВФАКТР Возвращает двойной факториал числа

ЗНАК Возвращает знак числа

КОРЕНЬ Возвращает положительное значение квадратного корня

КОРЕНЬПИ Возвращает значение квадратного корня из (число * «пи»)

МОБР Возвращает обратную матрицу (матрица хранится в массиве)

МОПРЕД Возвращает определитель матрицы, хранящейся в массиве

МУЛЬТИНОМ Возвращает мультиномиальный коэффициент множества чисел

МУМНОЖ Возвращает произведение матриц, хранящихся в массивах

НЕЧЁТ Округляет число до ближайшего нечетного целого

НОД Возвращает наибольший общий делитель

НОК Возвращает наименьшее общее кратное

ОКРВВЕРХ Округляет число до ближайшего целого или до ближайшего кратного указанному значению

ОКРВНИЗ Округляет число до ближайшего меньшего по модулю целого

ОКРУГЛ Округляет число до указанного количества десятичных разрядов

ОКРУГЛВВЕРХ Округляет число до ближайшего по модулю большего целого

ОКРУГЛВНИЗ Округляет число до ближайшего меньшего по модулю целого

ОКРУГЛТ Возвращает число, округленное с требуемой точностью

ОСТАТ Возвращает остаток от деления

ОТБР Отбрасывает дробную часть числа

ПИ Возвращает число «пи»

ПРОИЗВЕД Возвращает произведение аргументов

ПРОМЕЖУТОЧНЫЕ.ИТОГИ Возвращает промежуточный итог в списке или базе данных

РАДИАНЫ Преобразует градусы в радианы

РИМСКОЕ Преобразует число в арабской записи к числу в римской как текст

РЯД.СУММ Возвращает сумму степенного ряда, вычисленную по заданной формуле

СЛУЧМЕЖДУ Возвращает случайное число в заданном интервале

СЛЧИС Возвращает случайное число в интервале от 0 до 1

СТЕПЕНЬ Возвращает результат возведения числа в степень

СУММ Суммирует аргументы

СУММЕСЛИ Суммирует ячейки, удовлетворяющие заданному условию

СУММКВ Возвращает сумму квадратов аргументов

СУММКВРАЗН Возвращает сумму квадратов разностей соответствующих значений в двух массивах

СУММПРОИЗВ Возвращает сумму произведений соответствующих элементов массивов

СУММРАЗНКВ Возвращает сумму разностей квадратов соответствующих значений в двух массивах

СУММСУММКВ Возвращает сумму сумм квадратов соответствующих элементов двух массивов

СЧЁТЕСЛИ Подсчитывает количество непустых ячеек, удовлетворяющих заданному условию внутри диапазона

ФАКТР Возвращает факториал числа

ЦЕЛОЕ Округляет число до ближайшего меньшего целого

ЧАСТНОЕ Возвращает целую часть частного при делении

ЧЁТН Округляет число до ближайшего четного целого

ЧИСЛКОМБ Возвращает количество комбинаций для заданного числа объектов


Статистические функции

FРАСП Возвращает F-распределение вероятности

FРАСПОБР Возвращает обратное значение для F-распределения вероятности

ZТЕСТ Возвращает двустороннее P-значение z-теста

БЕТАОБР Возвращает обратную функцию к интегральной функции плотности бета-вероятности

БЕТАРАСП Возвращает интегральную функцию плотности бета-вероятности

БИНОМРАСП Возвращает отдельное значение биномиального распределения

ВЕЙБУЛЛ Возвращает распределение Вейбулла

ВЕРОЯТНОСТЬ Возвращает вероятность того, что значение из днапазона находится внутри заданных пределов

ГАММАНЛОГ Возвращает натуральный логарифм гамма функции, Γ(x)

ГАММАОБР Возвращает обратное гамма-распределение

ГАММАРАСП Возвращает гамма-распределение

ГИПЕРГЕОМЕТ Возвращает гипергеометрическое распределение

ДИСП Оценивает дисперсию по выборке

ДИСПА Оценивает дисперсию по выборке, включая числа, текст и логические значения

ДИСПР Вычисляет дисперсию для генеральной совокупности

ДИСПРА Вычисляет дисперсию для генеральной совокупности, включая числа, текст и логические значения

ДОВЕРИТ Возвращает доверительный интервал для среднего значения по генеральной совокупности

КВАДРОТКЛ Возвращает сумму квадратов отклонений

КВАРТИЛЬ Возвращает квартиль множества данных

КВПИРСОН Возвращает квадрат коэффициента корреляции Пирсона

КОВАР Возвращает ковариацию, то есть среднее произведений отклонений для каждой пары точек

КОРРЕЛ Возвращает коэффициент корреляции между двумя множествами данных

КРИТБИНОМ Возвращает наименьшее значение, для которого биномиальная функция распределения меньше или равна заданному значению

ЛГРФПРИБЛ Возвращает параметры экспоненциального тренда

ЛИНЕЙН Возвращает параметры линейного тренда

ЛОГНОРМОБР Возвращает обратное логарифмическое нормальное распределение

ЛОГНОРМРАСП Возвращает интегральное логарифмическое нормальное распределение

МАКС Возвращает максимальное значение из списка аргументов

МАКСА Возвращает максимальное значение из списка аргументов, включая числа, текст и логические значения

МЕДИАНА Возвращает медиану заданных чисел

МИН Возвращает минимальное значение из списка аргументов

МИНА Возвращает минимальное значение из списка аргументов, включая числа, текст и логические значения

МОДА Возвращает значение моды множества данных

НАИБОЛЬШИЙ Возвращает k-ое наибольшее значение из множества данных

НАИМЕНЬШИЙ Возвращает k-ое наименьшее значение в множестве данных

НАКЛОН Возвращает наклон линии линейной регрессии

НОРМАЛИЗАЦИЯ Возвращает нормализованное значение

НОРМОБР Возвращает обратное нормальное распределение

НОРМРАСП Возвращает нормальную функцию распределения

НОРМСТОБР Возвращает обратное значение стандартного нормального распределения

НОРМСТРАСП Возвращает стандартное нормальное интегральное распределение

ОТРБИНОМРАСП Возвращает отрицательное биномиальное распределение

ОТРЕЗОК Возвращает отрезок, отсекаемый на оси линией линейной регрессии

ПЕРЕСТ Возвращает количество перестановок для заданного числа объектов

ПЕРСЕНТИЛЬ Возвращает k-ую персентиль для значений из интервала

ПИРСОН Возвращает коэффициент корреляции Пирсона

ПРЕДСКАЗ Возвращает значение линейного тренда

ПРОЦЕНТРАНГ Возвращает процентную норму значения в множестве данных

ПУАССОН Возвращает распределение Пуассона

РАНГ Возвращает ранг числа в списке чисел

РОСТ Возвращает значения в соответствии с экспоненциальным трендом

СКОС Возвращает асимметрию распределения

СРГАРМ Возвращает среднее гармоническое

СРГЕОМ Возвращает среднее геометрическое

СРЗНАЧ Возвращает среднее арифметическое аргументов

СРЗНАЧА Возвращает среднее арифметическое аргументов, включая числа, текст и логические значения.

СРОТКЛ Возвращает среднее абсолютных значений отклонений точек данных от среднего

СТАНДОТКЛОН Оценивает стандартное отклонение по выборке

СТАНДОТКЛОНА Оценивает стандартное отклонение по выборке, включая числа, текст и логические значения

СТАНДОТКЛОНП Вычисляет стандартное отклонение по генеральной совокупности

СТАНДОТКЛОНПА Вычисляет стандартное отклонение по генеральной совокупности, включая числа, текст и логические значения

СТОШYX Возвращает стандартную ошибку предсказанных значений y для каждого значения x в регрессии

СТЬЮДРАСП Возвращает t-распределение Стьюдента

СТЬЮДРАСПОБР Возвращает обратное t-распределение Стьюдента

СЧЁТ Подсчитывает количество чисел в списке аргументов

СЧЁТЗ Подсчитывает количество значений в списке аргументов

ТЕНДЕНЦИЯ Возвращает значения в соответствии с линейным трендом

ТТЕСТ Возвращает вероятность, соответствующую критерию Стьюдента

УРЕЗСРЕДНЕЕ Возвращает среднее внутренности множества данных

ФИШЕР Возвращает преобразование Фишера

ФИШЕРОБР Возвращает обратное преобразование Фишера

ФТЕСТ Возвращает результат F-теста

ХИ2ОБР Возвращает обратное значение односторонней вероятности распределения хи-квадрат

ХИ2РАСП Возвращает одностороннюю вероятность распределения хи-квадрат

ХИ2ТЕСТ Возвращает тест на независимость

ЧАСТОТА Возвращает распределение частот в виде вертикального массива

ЭКСПРАСП Возвращает экспоненциальное распределение

ЭКСЦЕСС Возвращает эксцесс множества данных


Функции для работы с текстом

ASC Преобразует полноширинные (двухбайтные) английские буквы или символы катакана в текстовой строке в полуширинные (один байт).

JIS Преобразует полуширинные (однобайтные) английские буквы или символы катакана в текстовой строке в полноширинные (два байта).

PHONETIC Извлекает фонетические (фуригана) символы из текстовой строки.

YEN Преобразует число в текст, используя денежный формат йены (¥).

ДЛСТР Возвращает количество символов в текстовой строке

ЗАМЕНИТЬ Заменяет символы в тексте

ЗНАЧЕН Преобразует текстовый аргумент в число

КОДСИМВ Возвращает числовой код первого символа в текстовой строке

ЛЕВСИМВ Возвращает самые левые символы текстового значения

НАЙТИ Ищет вхождение одного текста в другой (с учетом регистра)

ПЕЧСИМВ Удаляет все непечатаемые символы из текста

ПОВТОР Повторяет текст заданное число раз

ПОДСТАВИТЬ Заменяет в текстовой строке старый текст новым

ПОИСК Ищет вхождение одного текста в другой (без учета регистра)

ПРАВСИМВ Возвращает самые правые символы текстовой строки

ПРОПИСН Делает все буквы в тексте прописными

ПРОПНАЧ Делает прописной первую букву в каждом слове текста

ПСТР Возвращает определенное число символов из строки текста, начиная с указанной позиции

РУБЛЬ Преобразует число в текст, используя денежный формат

СЖПРОБЕЛЫ Удаляет из текста пробелы

СИМВОЛ Возвращает символ с заданным кодом

СОВПАД Проверяет идентичность двух текстов

СТРОЧН Делает все буквы в тексте строчными

СЦЕПИТЬ Объединяет несколько текстовых элементов в один

Т Преобразует аргумент в текст

ТЕКСТ Форматирует число и преобразует его в текст

ФИКСИРОВАННЫЙ Форматирует число и преобразует его в текст с заданным числом десятичных знаков


 Включение и выключение режима правки непосредственно в ячейке

Включение и выключение режима правки непосредственно в ячейке

  1. Выберите команду Параметры в меню Сервис, а затем – вкладку Правка.

  2. Чтобы разрешить редактирование и ввод данных в ячейки, установите флажок Правка прямо в ячейке.

    Чтобы разрешить редактирование и ввод данных только в строке формул, снимите флажок.


 Вставка неверных данных при нажатии клавиши ENTER

Вставка неверных данных при нажатии клавиши ENTER

Если после использования команды Копировать в меню Правка или кнопки Копировать [image] вокруг области копирования остается бегущая рамка, то это означает, что скопированные ячейки все еще находятся в буфере обмена, и Microsoft Excel вставит их в активную ячейку при нажатии клавиши ENTER. Чтобы снять движущуюся границу, нажмите клавишу ESC.


 После сохранения книги лист изменений удаляется

После сохранения книги лист изменений удаляется

Проверка листа изменений. На листе изменений представлены только те изменения, которые были сохранены пользователями. После просмотра листа и последующего сохранения книги лист изменений удаляется. Однако соответствующие данные изменений остаются доступными в журнале изменений. При очередном просмотре листа изменений в нем будут отображены сохраненные изменения.

Чтобы заново просмотреть лист изменений, выберите команду Выделить исправления (пункт Исправления в меню Сервис). Установите флажок Вносить изменения на отдельный лист, а затем нажмите кнопку OK.