(Без имени)

Справка средства просмотра конфликтов репликации

Средство просмотра конфликтов репликации позволяет просматривать и устранять конфликты, возникающие при объединении изменений в репликах. Конфликты возникают, когда одни и те же данные одновременно изменяются в разных расположениях, например, у издателя и подписчика или у двух разных подписчиков. Могут иметь место конфликты двух типов.

  • Конфликты обновления и вставки, когда одни и те же данные одновременно изменяются в разных репликах. При этом одно из изменений сохраняется, тогда как другое теряется.
  • Конфликты удаления, когда одна и та же строка удаляется в одной реплике и изменяется в другой.

Эти конфликты устраняются на основании приоритетов, установленных при создании подписки, или в созданных пользователем процедурах устранения конфликтов. Средство просмотра конфликтов репликации позволяет просматривать и изменять параметры устранения конфликтов.

В следующей таблице перечислены параметры, доступные в диалоговом окне Просмотр конфликтов репликации, и поясняются их функции.

Примечание

Набор доступных параметров зависит от типа конфликта. Не все параметры появляются в каждом диалоговом окне. Даты отображаются в формате даты/времени ISO, а не в национальном формате.

Параметр | Действие
Причина конфликта | Описание причины конфликта и способа его устранения.
только столбцы с конфликтами | Отображение только столбца GUID (уникального идентификатора) и столбцов, имеющих конфликты.
все столбцы | Отображение всех столбцов в строке.
Сохранить текущие данные | Подтверждение текущего способа устранения конфликта.
Сохранить исправленные данные | Подтверждение текущего способа устранения конфликта, но с включением изменений, внесенных в поля, доступные для редактирования.
Подтвердить удаление данных | Подтверждение текущего способа устранения конфликта; данные останутся удаленными.
Игнорировать конфликт | Конфликт помечается как устраненный без внесения любых изменений. Это приведет к несогласованности; такое состояние должно быть устранено другими способами по мере возможности.
Заменить конфликтующими данными | Замена способа устранения конфликта; сохранение показанных конфликтующих данных.
Заменить существующими данными | Замена способа устранения конфликта; сохранение показанных существующих данных.
Заменить исправленными данными | Замена способа устранения конфликта; сохранение показанных конфликтующих данных с включением изменений, внесенных в поля, доступные для редактирования.
Удалить данные | Удаление данных, показанных в столбцах.
Занести сведения о конфликте в журнал | Создание копии конфликта и ее сохранении в отдельном файле журнала для дальнейшего использования. Файл сохраняется в каталоге папка Windows\profiles\пользователь\Application Data\Microsoft\Database Replication\UnresolvedConflicts.log.


(Без имени)

Справка средства просмотра конфликтов репликации

Средство просмотра конфликтов репликации позволяет просматривать и устранять конфликты, возникающие при объединении изменений в репликах. Конфликты возникают, когда одни и те же данные одновременно изменяются в разных расположениях, например, у издателя и подписчика или у двух разных подписчиков. Конфликты могут также возникать, когда изменение данных в одном расположении нарушает ограничения, наложенные в другом расположении (конфликт расхождения). После возникновения конфликта расхождения данные в двух репликах не могут быть идентичными до устранения конфликта.

Эти конфликты устраняются на основании приоритетов, установленных при создании подписки, или в созданных пользователем процедурах устранения конфликтов. Средство просмотра конфликтов репликации позволяет просматривать и изменять параметры устранения конфликтов.

Если пользователь выбирает параметр игнорирования конфликта расхождения, необходимо как можно скорее устранить конфликт, связанный с различием в ограничениях на данные. Начать следует с занесения в журнал сведений о конфликте, после чего необходимо отправить этот журнал системному администратору. Затем следует проверить ограничения на данные в разных расположениях и обеспечить их согласованность на всех узлах.

В следующей таблице перечислены параметры, доступные в диалоговом окне Просмотр конфликтов репликации, и поясняются их функции.

Примечание

Набор доступных параметров зависит от типа конфликта. Не все параметры появляются в каждом диалоговом окне. Даты отображаются в формате даты/времени ISO, а не в национальном формате.

Параметр | Действие
Причина конфликта | Описание причины конфликта и способа его устранения.
только столбцы с конфликтами | Отображение только столбца GUID (уникального идентификатора) и столбцов, имеющих конфликты.
все столбцы | Отображение всех столбцов в строке.
Сохранить текущие данные | Подтверждение текущего способа устранения конфликта.
Сохранить обновленные данные | Подтверждение текущего способа устранения конфликта, но с включением изменений, внесенных в поля, доступные для редактирования.
Подтвердить удаление данных | Подтверждение текущего способа устранения конфликта; данные останутся удаленными.
Игнорировать конфликт | Конфликт помечается как устраненный без внесения любых изменений. Это приведет к несогласованности; такое состояние должно быть устранено другими способами по мере возможности.
Заменить конфликтующими данными | Замена способа устранения конфликта; сохранение показанных конфликтующих данных.
Заменить существующими данными | Замена способа устранения конфликта; сохранение показанных существующих данных.
Заменить исправленными данными | Замена способа устранения конфликта; сохранение показанных конфликтующих данных с включением изменений, внесенных в поля, доступные для редактирования.
Удалить данные | Удаление данных, показанных в столбцах.
Занести сведения о конфликте в журнал | Создание копии конфликта и ее сохранении в отдельном файле журнала для дальнейшего использования. Файл сохраняется в каталоге папка Windows\profiles\пользователь\Application Data\Microsoft\Database Replication\UnresolvedConflicts.log.


(Без имени)

Справка средства просмотра конфликтов репликации

Средство просмотра конфликтов репликации позволяет просматривать и устранять конфликты, возникающие при объединении изменений в репликах. Конфликты возникают, когда одни и те же данные одновременно изменяются в разных расположениях. Могут иметь место конфликты двух типов.

  • Конфликты обновления и вставки, когда одни и те же данные одновременно изменяются в разных репликах. При этом одно из изменений сохраняется, тогда как другое теряется. Для таких конфликтов пользователь имеет возможность выбрать параметр сохранения существующих данных или замены существующих данных на конфликтующие (отклоненные) данные. Если сохранить существующие данные они остаются в реплике, которая победила в конфликте. Средство просмотра конфликтов репликации Microsoft добавит эти данные в реплику, в которое результаты операций обновления или вставки были первоначально отклонены. При замене существующих данных на конфликтующие, то в реплики включаются данные, которые были первоначально отклонены.
  • Конфликты удаления, когда одна и та же строка удаляется в одной реплике и изменяется в другой.

Средство просмотра конфликтов репликации позволяет просматривать и изменять параметры устранения конфликтов.

В следующей таблице перечислены параметры, доступные в диалоговом окне Просмотр конфликтов репликации, и поясняются их функции.

Примечание

Набор доступных параметров зависит от типа конфликта. Не все параметры появляются в каждом диалоговом окне. Даты отображаются в формате даты/времени ISO, а не в национальном формате.

Параметр | Действие
Причина конфликта | Описание причины конфликта и способа его устранения.
только поля с конфликтами | Отображение только столбца GUID (уникального идентификатора) и полей, имеющих конфликты.
все поля | Отображение всех полей в записи.
Сохранить текущие данные | Подтверждение текущего способа устранения конфликта.
Сохранить обновленные данные | Подтверждение текущего способа устранения конфликта, но с включением изменений, внесенных в поля, доступные для редактирования.
Подтвердить удаление данных | Подтверждение текущего способа устранения конфликта; данные останутся удаленными.
Игнорировать конфликт | Конфликт помечается как устраненный без внесения любых изменений. Это приведет к несогласованности; такое состояние должно быть устранено другими способами по мере возможности.
Заменить конфликтующими данными | Замена способа устранения конфликта; сохранение показанных конфликтующих данных.
Заменить существующими данными | Замена способа устранения конфликта; сохранение показанных существующих данных.
Заменить исправленными данными | Замена способа устранения конфликта; сохранение показанных конфликтующих данных с включением изменений, внесенных в поля, доступные для редактирования.
Удалить данные | Удаление данных, показанных в полях.
Занести сведения о конфликте в журнал | Создание копии конфликта и ее сохранении в отдельном файле журнала для дальнейшего использования. Файл сохраняется в каталоге папка Windows\profiles\пользователь\Application Data\Microsoft\Database Replication\UnresolvedConflicts.log.


(Без имени)

Справка средства просмотра конфликтов репликации

Средство просмотра конфликтов репликации позволяет просматривать и устранять конфликты, возникающие при объединении изменений в репликах. Конфликты возникают, когда одни и те же данные одновременно изменяются в разных расположениях. Конфликты могут также возникать, когда изменение данных в одном расположении нарушает условия на значения, наложенные в другом расположении (конфликт расхождения). После возникновения конфликта расхождения данные в двух репликах не могут быть идентичными до устранения конфликта.

Эти конфликты устраняются на основании приоритетов, установленных при создании реплики, или в созданных пользователем процедурах устранения конфликтов. Средство просмотра конфликтов репликации позволяет просматривать и изменять параметры устранения конфликтов.

Если пользователь выбирает параметр игнорирования конфликта расхождения, необходимо как можно скорее устранить конфликт другими способами. Начать следует с занесения в журнал сведений о конфликте, после чего необходимо отправить этот журнал системному администратору. Затем следует проверить ограничения на данные в разных расположениях и обеспечить их согласованность на всех узлах.

В следующей таблице перечислены параметры, доступные в диалоговом окне Просмотр конфликтов репликации, и поясняются их функции.

Примечание

Набор доступных параметров зависит от типа конфликта. Не все параметры появляются в каждом диалоговом окне. Даты отображаются в формате даты/времени ISO, а не в национальном формате.

Параметр | Действие
Причина конфликта | Описание причины конфликта и способа его устранения.
только поля с конфликтами | Отображение только столбца GUID (уникального идентификатора) и полей, имеющих конфликты.
все поля | Отображение всех полей в записи.
Сохранить текущие данные | Подтверждение текущего способа устранения конфликта.
Сохранить обновленные данные | Подтверждение текущего способа устранения конфликта, но с включением изменений, внесенных в поля, доступные для редактирования.
Подтвердить удаление данных | Подтверждение текущего способа устранения конфликта; данные останутся удаленными.
Игнорировать конфликт | Конфликт помечается как устраненный без внесения любых изменений. Это приведет к несогласованности; такое состояние должно быть устранено другими способами по мере возможности.
Заменить конфликтующими данными | Замена способа устранения конфликта; сохранение показанных конфликтующих данных.
Заменить существующими данными | Замена способа устранения конфликта; сохранение показанных существующих данных.
Заменить исправленными данными | Замена способа устранения конфликта; сохранение показанных конфликтующих данных с включением изменений, внесенных в поля, доступные для редактирования.
Удалить данные | Удаление данных, показанных в полях.
Занести сведения о конфликте в журнал | Создание копии конфликта и ее сохранении в отдельном файле журнала для дальнейшего использования. Файл сохраняется в каталоге папка Windows\profiles\пользователь\Application Data\Microsoft\Database Replication\UnresolvedConflicts.log.