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Chapter 21
Polar Plots 

In addition to X-Y plots, Mathcad worksheets can contain polar plo
Using polar coordinates, you can quickly and easily display angle-
dependent data. 

The following sections describe how to create, use, and format pol
plots:

Creating a polar plot
Basic steps in creating a polar plot. QuickPlots versus plots where you 
explicitly specify the range on the angular axis.

Graphing more than one expression
Procedures for creating polar plots with multiple traces.

Formatting the axes
Procedures for modifying the radial and angular axes.

Formatting individual curves
Procedures for modifying curves or traces in a polar plot.

Setting default formats
Procedures for using default format settings for polar plots.

Labeling your polar plot
Procedures for working with titles, legends, and other labels.

Modifying your polar plot's perspective
Procedures for changing the size of the plot, zooming in on a portion of
plot, and finding coordinates in it.

Gallery of polar plots
A set of sample polar plots illustrating the options for creating polar plots.
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Creating a polar plot 

Mathcad’s polar plot operator lets you plot functions that do not lend themselves we
to Cartesian (x-y) coordinates. A typical polar plot shows the value of a radial express
r versus an angular expression θ. For example, you could use a polar plot to graph 
circular antenna patterns or electric field intensities around an object. 

Mathcad draws polar plots by mapping r and θ onto x and y using the standard 
transformations  and . r and θ can assume positive or 
negative values.

You insert the polar plot operator into a blank space in your worksheet by choos
any one of three equivalent methods: by choosing Graph⇒Polar Plot from the Insert 
menu, by typing [Ctrl ]7, or by clicking the Polar Plot button in the Graph Palette
Like the X-Y plot operator described in Chapter 20, “Graphs,” the polar plot has 
placeholders on its axes for you to fill in that specify expressions to be computed
displayed, and it automatically chooses a default range for the angular axis varia
you do not specify one. In the case where you do not specify the angular axis var
Mathcad creates a polar QuickPlot.

Polar QuickPlot

You can quickly and easily create a polar plot from a single Mathcad expression
do so:

■ Enter the expression or function of a 
single variable you want to plot. Make 
sure the editing lines remain in the ex-
pression. 

■ Choose Graph⇒Polar Plot from the 
Insert menu.

■ Press [Enter ] or click away from the 
graph. 

Mathcad automatically produces a polar plot over a default range of the depende
variable on the angular axis: 0 to 360 degrees (0 to 2π radians). You can graph multiple
expressions on the radial axis, generating several traces on the polar plot, by en
them as described in “Graphing more than one expression” on page 500. 

Notice that you can create a QuickPlot in one of two ways. You can either:

■ First type an expression and then choose Graph⇒Polar Plot from the Insert menu, 
in which case your expression appears automatically in the radial axis placeho
or

x r θ( )cos= y r θ( )sin=
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■ First choose Graph⇒Polar Plot from the Insert menu and then enter an expressio
in the radial axis placeholder.

Explicitly specifying the range on the angular axis

When you want to specify the angular axis argument or the range variable used,
the following steps to create a polar plot:

■ Click where you want the polar plot to appear.

■ Choose Graph⇒Polar Plot from the Insert menu. Mathcad shows a circle with
four placeholders as shown below:

■ Above the plot region, define an angle θ and a function of the angle, r(θ). 

■ The bottom placeholder holds the angle variable to plot against. Enter a rang
variable or any expression involving a range variable in this placeholder.

■ The left placeholder holds a radial expression to plot.

■ The two placeholders to the right hold the upper and lower radial limits. Math
fills in these placeholders by default. If you want, you can modify these limits. 
the section “Formatting the axes” on page 502.

Just as with an equation or other plot types, Mathcad will not process the polar p
until you click outside the plot. 

You can specify many of the characteristics of the polar plot including the size, t
number of grid lines, and the upper and lower radial axis limits. The procedures 
specifying these characteristics are described later in this chapter.

Here are the typical steps in plotting a function like the one shown in Figure 21-1

■ Define a range and an increment for θ. If you don’t, Mathcad generates a polar plo
over a default range of 0 to 360 degrees.

■ Define r(θ), a function of θ.

■ Show r(θ) in a polar plot.
Creating a polar plot 499
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Figure 21-1: Polar plot of a function of θ. 

Graphing more than one expression 

Just as you can graph several expressions on a single Cartesian (X-Y) plot, you
graph several expressions on the same polar plot. Each expression generates a trace. A 
polar plot can show several r expressions against the same θ expression, or it can match
up several r expressions with corresponding θ expressions.

To graph several r expressions versus one θ expression, enter the first r expression 
followed by a comma. You'll see a placeholder immediately below this first express
Enter the second expression here, followed by another comma to get another em
placeholder. All the expressions should use the same range variable, as shown in 
21-2. Figure 21-2 also shows how to define an angular range in degrees.
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Figure 21-2: Polar plot with multiple expressions.

To graph several independent curves on the same polar plot, enter two or more 
expressions separated by commas in the angular axis placeholder and the same n
of expressions in the radial axis placeholder. For example, to plot r(θ) against θ and 
s(φ) against φ you could type “r(θ), s(φ)” in one placeholder and “θ, φ” in the other. 
Mathcad matches the expressions in pairs—r(θ) with θ and s(φ) with φ. It then draws 
a trace for each pair. Each matching pair of expressions should use the same ra
variable. The range variable for one pair need not match the range variables for 
other pairs.

As with x-y plots, you can plot one vector of values against another, using a rang
variable to index the two vectors. This is illustrated in Figure 21-3.
Graphing more than one expression 501
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Figure 21-3: Plotting one vector against another.

Formatting the axes   

You can reformat your polar plot's axes, using the Polar Axes page of the dialog
for formatting polar plots.

To change a polar plot's format:

■ Click in the polar plot to select it.

■ Double-click in the polar plot. Alternatively, choose Graph⇒Polar Plot from the 
Format menu. You'll see the dialog box for formatting polar plots, shown belo

■ If necessary, click the Polar Axes tab.

■ There is a complete group of settings for each axis. Change the appropriate se

■ Click “OK” to accept your changes and close the dialog box. Mathcad redraws
polar plot with the new settings in effect. Alternatively, click “Apply” to see the
plot redrawn without closing the dialog box.
502  Chapter 21  Polar Plots
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Axis settings

Each axis has the following settings associated with it:

Log Scale
When this box is checked, the radial axis is logarithmic. Axis limits must be posit
This setting is available only for the radial axis. Figure 21-10 on page 517 illustr
a polar plot with a logarithmic axis.

Grid Lines
When this box is checked, the tick marks on the selected axis are replaced by
lines. If the axis is logarithmic, then logarithmically spaced grid lines are adde
space permits. Radial grid lines are circles of fixed radius; angular grid lines rad
out from the origin at a fixed angle. Figure 21-8 on page 516 compares a plot 
tick marks to the same plot with grid lines.    

Numbered
When this box is checked, the selected grid lines are numbered. Figure 21-8 
page 516 illustrates numbers being used with grid lines.

Show Markers
When this box is checked, you can add reference lines to your polar plot. See
“Adding radial reference lines” on page 505.

Auto Grid
When this box is checked, Mathcad automatically selects the number of grid 
markings (tick marks or grid lines). When the box is unchecked, you choose 
number of grid markings (from 2 to 99) by typing a number in the No. of Grids t
box. You can specify the number of grid markings only when Log Scale is 
unchecked. Figure 21-9 on page 516 illustrates the effect of Auto Grid.

In addition to these check boxes, the dialog boxes contain the following:

No. of Grids
When available, this text box indicates the number of tick marks or grid lines 
the associated axis. You can enter a number between 2 and 99, inclusive. Th
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is only available when Auto Grid and Log Scale are unchecked. Figure 21-9 o
page 516 shows the effects of defining the number of grid lines on both the ra
and the angular axes.

Axes Style
These buttons let you choose between crossed axes, no axes at all, and a pl
enclosed by a circle (perimeter). Figure 21-11 on page 517 illustrates the differ
between perimeter and crossed axes.   

See the section “Setting default formats” below to learn how to:

■ Quickly restore a polar plot to its default format settings.

■ Use a particular plot as a model for all future polar plots.

Setting limits for axes

Mathcad sets the upper and lower radial axis limits by default. For a linear scale
upper limit is the maximum radial value of whatever is plotted. The lower limit is ze
For a logarithmic scale, the upper limit is set to the next higher integer power of 
above the maximum of the data. The lower limit on a logarithmic scale is set to the
integer power of ten below the minimum of the data. 

You may want to use axis limits other than those set by Mathcad. You can overr
Mathcad's limits by entering limits directly on the graph. To do so:

■ Click in the polar plot to select it. Mathcad shows two additional numbers on 
upper right of the polar plot. These numbers are enclosed within corner symb
as illustrated by the selected plot in Figure 21-4, below.

■ Mathcad treats a negative radial limit as a positive value. To set the maximum v
of the radial axis, click on the number in the top placeholder and type in a ne
number. While there's rarely a reason to change the minimum value, you can
this by clicking on the lower number and typing a new number. 

■ Click outside the plot, Mathcad immediately redraws it using the axis limits yo
specify. Figure 21-4 shows the effect of manually setting limits on a polar plo
504  Chapter 21  Polar Plots
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Figure 21-4: Manually setting axis limits.

Adding radial reference lines 

Mathcad places linearly or logarithmically spaced radial grid lines on a polar plot. 
spaces between grid lines are relatively round numbers that span the range of v
on the angular axis. There may, however, be occasions when you need to place a
line somewhere other than where Mathcad would normally place a grid line. 

To add a radial reference line to the polar plot:

■ Click in the polar plot to select it.

■ Choose Graph⇒Polar Plot from the Format menu or double-click on the plot to
display the dialog box for formatting polar plots. If necessary, click on the Pol
Axes page.

■ Click the Show Markers check box in the radial axis column to add a check. C
“OK”. Mathcad shows two additional placeholders on the upper-left side of the p

■ Click on one of the placeholders and type in the value at which you want the ra
reference line drawn. Repeat this process with the other placeholder to add t
radial reference lines.

When you click outside the graph, Mathcad draws a dashed circle at each numbe
you specified. The number that you typed appears on this dashed circle. To mov
dashed circle, click on the appropriate number and change it. To delete the circle, d
this number or click on the Show Markers check box to remove the check. Figur
5 illustrates the use of radial reference lines.
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Figure 21-5: Adding radial reference lines to a polar plot.

Formatting individual curves 

You can reformat the traces on your polar plot, using the Traces page of the dialo
for formatting polar plots.

To reformat a plot's traces:

■ Click in the polar plot to select it.

■ Double-click in the polar plot. Alternatively, choose Graph⇒Polar Plot from the 
Format menu. Mathcad displays the dialog box for formatting polar plots. 

■ If necessary, click the Traces tab.

■ Click on the appropriate line in the scrolling list box to select a trace. To chan
the name of the trace, type the new name in the text box under the “Legend L
column. To assign a symbol or marker, line type, color, trace type, and line we
to this trace, click on the arrow beside each text box to see a drop-down list o
options, and then click on the option you want. See the next section, “Trace 
settings,” for complete explanations of these fields.

■ Click “OK” to accept your changes and close the dialog box. Mathcad redraws
plot with the new settings in effect. Alternatively, click “Apply” to preview your
changes without closing the dialog box.
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Trace settings

A graph can have up to sixteen individual traces. Each trace is described by a lin
the scrolling list. Mathcad uses these lines as needed, assigning one for each tra
your plot. Each line has six fields: 

Legend Label
This is the name of the trace as it would appear in the legend beneath the plo
the section “Displaying or hiding arguments and legends” on page 511 for mo
information about legends. 

Symbol
This controls whether each point on the curve is marked with a symbol. If y y
choose, you can mark each point with either an “×,” a “+,” a hollow box, or a hollow 
diamond. If you have a lot of points packed closely together, you should prob
select “none.” Figure 21-12 on page 518 shows an example in which each data
is marked by with an “×.” 

Line
This controls whether the line is solid, dotted, or dashed or whether it consist
alternating dashes and dots. This feature provides a useful way to distinguish
unmarked curves in black and white printouts. 

Color
This controls whether the selected trace is red, blue, green, magenta, cyan (a
blue), brown, black, or white. Mathcad ignores this on monochrome displays.

Type
This controls the type of trace that will be displayed. Mathcad can generate th
following types of plots: curves, bar graphs, stepped curves, error bars, stem gr
and points. (You must have at least two traces to use error bars.) Figure 21-1
page 518 illustrates the same polar plot, displayed with a variety of trace type

Weight
This controls the weight or thickness of the trace. Select from 1 to 9 (thinnest
Formatting individual curves 507
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thickest). Select “p” for the lightest (single-pixel) trace. Although this may look
like weight 1 on your screen, a high resolution printer will print it as a very fin
line. This field also controls the size of the symbols marking data points, if you h
selected a symbol other than “none”. If you have selected trace type points, t
field sets the weight of the dot plotted at each data point.

See “Setting default formats” below to learn how to: 

■ Quickly restore a polar plot to its default format settings.

■ Use a particular plot as a model for all future polar plots.

In addition to the scrolling list and its associated text box and lists, the Trace pag
two check boxes: Hide Arguments and Hide Legend. These are explained fully in
“Displaying or hiding arguments and legends” on page 511. 

Setting default formats

Mathcad uses default settings to format the axes and traces of new polar plots a
create them. You can change these defaults in two ways:

■ By saving as defaults the settings of your current plot.

■ By using the Setting Default Formats for Polar Plots dialog box to set defaults
you don't want to use an existing plot. 

Changing defaults only affects new polar plots; previously existing plots are unaffec

Copying defaults from an existing plot

One way to create a new set of defaults is to use the format settings of an existing
plot. The advantage of this method is that you can use “Apply” to see how the fo
settings look while you define them.

To use the format of a particular polar plot as the default polar plot settings:   

■ Select the graph by clicking on it.

■ Click the Defaults tab on the dialog box for formatting polar plots. The Defaul
page appears, as shown below.

■ If the Use for Defaults check box isn't checked, click on it to add one. When y
close the dialog box, Mathcad saves these settings as your default settings.
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Setting defaults without using a polar plot

You don't have to use an existing polar plot to create or revise default formats. Ins
you can use the dialog box for polar plot defaults. To set defaults this way: 

■ Make sure that you don't have any plots selected.

■ Choose Graph⇒Polar Plot from the Format menu. You'll see the dialog box for
polar plot defaults. The following figure shows an example of this dialog box w
the Polar Axes page displayed.   

■ Change the appropriate settings on the Polar Axes and Traces pages.

■ Click “OK” to accept your changes and close the dialog box.

Using default graph settings

If you don't want the format changes made to your polar plot since creating the la
of default settings, you can restore the plot to its current default settings. To do s
Setting default formats 509
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■ Click the Defaults tab on the dialog box for polar plots.

■ Click “Change to Defaults”.

■ Click “OK” to close the dialog box.

Mathcad redraws the plot, using the most recent set of default format settings. Ma
does not use any defaults you might have set using the Use for Defaults check b
any time after the creation of this plot. 

Labeling your polar plot

Mathcad provides several ways to help you to identify what it is you've plotted. Y
can display:   

■ A title centered above or below the polar plot. 

■ A legend identifying each trace.

■ The arguments you used to create the plot.

Figure 21-6 shows the relative locations of each of these labels on a perimeter g
and on a crossed axes graph.

Figure 21-6: Graphs with different labels.
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You can use these labels all together or in any combination. By default, Mathcad 
the title, displays arguments, and hides the legend. 

Working with titles 

To add a title to a polar plot, follow these steps:

■ Click in the polar plot to select it.

■ Choose Graph⇒Polar Plot from the Format menu or double-click on the selected
plot. Mathcad displays the dialog box for formatting polar plots. If necessary, c
on the Labels tab to see the Labels page, as shown below. 

■ Type a title for your polar plot into the Title text box. 

■ Click on either the Above or Below button, depending upon where you want to
the title. 

■ Make sure that the Show Title check box is checked. If it isn't, Mathcad still 
remembers the title but won't display it.

■ Click “OK” to accept your changes. Mathcad redraws the polar plot with the t
in place. Alternatively, click “Apply” to preview your title without closing the 
dialog box.

To change the title's text or position, edit the information in the Title group as 
appropriate. To delete the title, highlight it in the text box and press [Del ].

Displaying or hiding arguments and legends

Mathcad provides both arguments and legends for identifying specific traces on a 
plot:

■ Arguments are the expressions that you typed into the placeholders to create
polar plot. By default, Mathcad displays arguments.
Labeling your polar plot 511
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■ Legends are labels that appear underneath the polar plot. They contain a nam
an example of the line and symbols used to draw the trace. By default, Mathc
hides legends.

To display or hide arguments and legends:

■ Click in the polar plot to select it.

■ Choose Graph⇒Polar Plot from the Format menu or double-click on the graph.
Mathcad displays the dialog box for formatting polar plots. If necessary, click
the Traces tab.

■ To suppress the display of the arguments, click on the Hide Arguments check
to add a check.

■ To show the legend, click on the Hide Legend check box to remove the chec

Modifying your polar plot's perspective

Mathcad provides options for manipulating the presentation of your polar plot:

■ You can make the plot larger or smaller.

■ You can zoom in on a portion of the plot.

■ You can get the coordinates for any point that was plotted to construct the plo

■ You can get the coordinates for any location within the plot.

The rest of this section shows how to use these features.

Resizing a polar plot

Resizing a polar plot is very much like resizing a window:

■ Click in the polar plot to select it.

■ Move the mouse pointer to one of the three handles along the edge of the pola
The pointer will change to a double-headed arrow.
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■ Press and hold down the mouse button and move the mouse in the direction in w
you want the polar plot's dimensions to change.

■ Once the polar plot is the right size, let go of the mouse button. 

■ Click outside the polar plot to deselect it.

Zooming in on a polar plot 

Mathcad allows you to select a region of a polar plot and magnify it. To zoom in o
portion of a plot, follow these steps:

■ Click in the polar plot to select it. 

■ Choose Graph⇒Zoom from the Format menu, or click on the Zoom button in the
Graph Palette. The Polar Zoom dialog box appears. 

■ If necessary, reposition the Polar Zoom dialog box so that you can see the en
region of the graph you want to zoom.

■ Click in the polar plot region and drag the mouse while holding down the mou
button. A dashed selection circle is centered in the plot.

■ When the selection circle just encloses the region you want to magnify, let go
the mouse button. 

■ The radius of the selected region is shown in the Radius box of the Polar Plot Z
dialog box. Click the “Zoom” button to redraw the plot. The axis limits are 
temporarily set to the coordinates specified in the Polar Plot Zoom dialog box

Before you make these axis limits permanent, you can select another region to z
by enclosing another selection circle around the new region. Click “Unzoom” to s
the zooming process over. If you're working with a plot that has already been zoo
you may want to view the original plot as it looked before any zooming took place
do so, click on “Full View”.

Figure 21-7 shows the effects of zooming in on a portion of a polar plot.
Modifying your polar plot's perspective 513
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Figure 21-7: A zoomed-in region of a polar plot.

Getting a readout of polar plot coordinates

To see a readout of polar plot coordinates of the specific points that make up a t
follow these steps:

■ Click in the polar plot to select it.

■ Choose Graph⇒Trace from the Format menu to show the Polar Trace dialog bo

■ If necessary, reposition the Polar Trace dialog box so that you can see the en
region of the graph.

■ Drag the mouse along the trace whose coordinates you want to see. A dotted
crosshair jumps from one point to the next as you move the pointer along the 

■ Use the left and right arrows to move to the previous and next data points. Us
up and down arrows to move to other traces.

■ As the pointer reaches each point on the trace, Mathcad displays the coordina
the pointer location in the Radius and Angle boxes.
514  Chapter 21  Polar Plots
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■ When you release the mouse button, the radius and angle settings of the last
selected are shown in the Radius and Angle boxes. The crosshair remains unt
click outside the polar plot. 

■ Double-click on the control box in the upper-left-hand corner to close the Pola
Trace dialog box. The crosshair will remain on your plot until you click anywhe
outside it.

To copy a coordinate to the clipboard: 

■ Click “Copy Radius” or “Copy Angle”. 

■ You can then paste that value into either a math or text region of your Mathca
worksheet, into a spreadsheet, or into any other application that allows pasting
the clipboard. 

To see a readout of coordinates for any location in a polar plot:

■ Follow the above procedures to call up the Polar Trace dialog box.

■ Click on Track Data Points to uncheck it.

■ In the polar plot region, click and drag the mouse pointer over the points who
coordinates you want to see. A dotted crosshair follows the pointer as you dr
over the plot. Mathcad displays the coordinates of the pointer in the Radius a
Angle boxes. The radius and angle values change continuously to reflect the cu
pointer position.

■ When you release the mouse button, the Radius and Angle boxes show the r and θ 
values of the last pixel selected.
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Gallery of polar plots

Figure 21-8: Different axis formats on the same polar plot.

Figure 21-9: Using Auto Grid on the same polar plot.
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Figure 21-10: Polar plot with a logarithmic axis.

Figure 21-11: Using perimeter and crossed axes styles on the same polar plot.
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Figure 21-12: Using symbols and lines on the same polar chart.

Figure 21-13: Presenting the same plot formatted as lines and symbols and 
then as error bars.
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